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Chapter 1: Welcome
     Congratulations for choosing ClockWork as your personal, or office, Day Planner software.
ClockWork is an advanced day planner for managing your schedules, and “to-do” lists. It has great
flexibility and utility, with many advanced features not found in similar software programs. It can be
used for both personal scheduling, and for managing shared events in your office, because of its easy to
use, flexible networking features. ClockWork was designed exclusively for the MacOS, and its tight
integration with the MacOS makes it very reliable and easy to use. ClockWork uses many of the
conventional operations familiar to MacOS software users.

     Easy and fast synchronization with PowerBook, or Newton computers, allows you to take your data
on the road and then update your calendar when you come back to the office. ClockWork’s elegant user-
interface closely follows Apple’s Human Interface Guidelines, and thus makes learning ClockWork a
snap.

     We hope that ClockWork will make your daily work more efficient and more fun, too. Century
Software strives to meet your expectations and we are constantly improving and evolving ClockWork,
adding new features and making it easier to use.

     However, there is no such thing as perfect, or bug-free software. So if you find a bug, or if you are
missing or not understanding an important feature, or if you are having trouble using ClockWork, please
don’t hesitate to contact us at: support@centsoft.com. We try to answer every question promptly.

Thank you for choosing ClockWork,

The ClockWork Team

Century Software

mailto:support@centsoft.com
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Chapter 2: Installing ClockWork
     To install ClockWork, double click on the ClockWork installer which matches your MacOS computer.
If you do not know which processor that you have, then consult Appendix I, at the end of this manual for
more information. This Appendix supplies the System Requirements needed for ClockWork to operate.

ClockWork Installer PPC

     If you have the newer type of MacOS computer, equipped with a Power PC processor, then use the
ClockWork Installer PPC.

ClockWork Installer 68K

     If you have the older MacOS computer, with a 680x0 processor, then use this installer.

ClockWork Installer FAT

     If you are not sure. or if you want to use the software on both a PowerPC, and a 680x0 computer, then
use the ClockWork Installer FAT, which will install a FAT version of ClockWork. This version will be
able to run on both a PowerPC, and a 680x0 MacOS computers. Howerver, one should try to install the
version most compatible with the computer you are using. That way you will install only what is needed
to optimally operate ClockWork on your particular computer.

Easy Install

     After launching the Installer, you can select the drive and folder from the popup menu in the Install
Location menu. The installer will create a folder called “ClockWork Folder” on the specified disk, and
install ClockWork, and all related files into that folder. If you want to install ClockWork into a different
folder, open the popup menu and choose Select Folder. A dialog box will appear which lets you choose
the desired folder for the installation.

     By default, the ClockWork installer will install all files necessary to get started with ClockWork on the
hard drive. It will install the ClockWork application, some readme files, and the sample AppleScript files.
In addition, the Installer will place the ClockWork Reminder control panel into the System folder of your
startup disk. The ClockWork Reminder is required, if you want to be notified of pending alarms, even if
the application is not running.
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Custom Install

     If you want to override the recommended set which will be installed by the installer, you can choose
Custom Install, instead of Easy Install, from the popup menu in the top left corner. Custom Install lets you
manually choose from three different packages (ClockWork, Reminder, and Newton Synchronize).
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ClockWork Folder

     After installing ClockWork ,you will find a folder called “ClockWork Folder” at the top-level of your
hard disk. This folder contains the ClockWork application and additional files.

ClockWork™

     This is the ClockWork application. Launch it to get started with your Day Planner program.

Order Form

     Use this form to order from ClockWork, a serial number which will allow your software to remain
active. Simply fax the required payment information,using a major credit card. Alternatively you can
order ClockWork serial numbers from our secure web-server http://www.centsoft.com

Scripts

     If you place compiled AppleScript files into this folder, ClockWork will automatically append a Scripts
menu to the menu bar showing the contents of this folder. For more information about AppleScript, please
refer to Chapter 14, AppleScript, in this documentation.

Newton

     This folder contains ClockWork’s Newton package requried for Newton synchronization.

Sample AppleScripts

     This folder contains a number of AppleScripts illustrating the scripting functionality of ClockWork.
For more information about AppleScript, please refer to the AppleScript chapter in this documentation.

http://www.centsoft.com/
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Chapter 3: Online Help
     The folllowing is intended as a “fly through” of ClockWork’s features. It introduces the basic concepts,
illustrates the functionality, and gives useful hints on how to use the different features. In addition to this
documentation, ClockWork offers extensive online electronic help via BalloonHelp and AppleGuide.

AppleGuide

     ClockWork fully supports AppleGuide, the standard electronic help system for the MacOS.
AppleGuide “guides” you through ClockWork’s features using a step-by-step approach.

     To use AppleGuide, open the Help menu and choose ClockWork Guide. If you are working with
System 7, or later, open the question-mark menu item on the right of the menu bar to access AppleGuide.

     AppleGuide is an intelligent, context-sensitive help system, guiding you by drawing coach-marks on
the screen to indicate which menu item to choose, or which button to click.
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BalloonHelp

     BalloonHelp is a standard help system built into the MacOS, enabling context-sensitive help by
showing help balloons for on-screen elements and menu items. ClockWork offers BallonHelp for all menu
items, buttons, icons and other elements. To turn on BallonHelp, open the Help menu and choose “Show
Balloons”. To turn it off, choose the same menu item again. If you are working on System 7, open the
question-mark menu item on the right of the menu bar to access Balloon Help.
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Chapter 4: Working with Views
     ClockWork has four basic views to work with: List, Day, Week and Month. You can switch between
the different views by clicking on the view icons.

Day View

     The Day view shows all the events of a specific day. The top area shows the day number, week number
and holidays. Below are the to-do list and the daily schedule. The Day view (like all other views) behaves
like a paper roll. If you scroll down, you will scroll to the next day, if you scroll up, you will see the past.

Creating a To-Do Item

     To create a new to-do item, simply click in the empty space shown below, in the to-do list. A new to-do
item will be inserted and you can type in the description for this to-do item.
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Completing a To-Do Item

     If you have completed the to-do item,then click in the checkbox on the left, to mark the item as
completed. Click it again to mark it as uncompleted. Uncompleted to-do items will automatically carry
forward to the next day. If you pass the deadline (by default 7 days), a red exclamation mark (!) will be
shown in the checkbox to indicate that it is overdue.

Moving a To-Do Item

     To move a to-do item to a different day, click on the pattern box, hold down the mouse and move the
to-do item to the calendar on the left. If you release the mouse on a particular day, then the to-do item will
be moved to that day.
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Deleting a To-Do Item

     To delete a to-do item, select it by clicking on the pattern box of that item, and then push the backspace
key on the keyboard. Alternatively, you can open the Edit menu and choose Clear.

Creating an Appointment

     The lower part of the Day view shows your daily schedule. To create a new appointment, click on the
start time, hold down the mouse button and drag downwards to the end time desired, then release the
mouse. A new appointment will be created and you can type information about this event right into it.

     ClockWork supports up to 32000 characters of styled text per event. You can use standard text-editing
features like undo, copy-and-paste or drag-and-drop to edit the text. If you enter more text than fits, the
time-line will expand to make more room for the text.
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Moving an Appointment

     If you want to move an appointment, simply click on its pattern box and drag it downwards (or
upwards) to the new time or day. To move the appointment to a different day, simply drag it to the
calendar on the left and drop it at the date you want to move the appointment to. If you want to duplicate,
an appointment, hold down the option key and drag the event to a different time or day. This will create a
copy at the destination time.

Changing the Start or End Time of an Appointment

     To change the end time of an appointment without moving the start time, move the mouse to the end
time of the appointment. The cursor will change to a vertical resize cursor. Click and drag the mouse to
the new end time. If you release the mouse button, the end time of the event will be changed without
moving the starting time of the event. To change the start time of an event, perform a similar operation by
clicking and draging the start time of the appointment.
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Deleting an Appointment

     To delete an appointment, select it by clicking on its pattern, to the left of it, and type a backspace. You
can also open the Edit menu and choose Clear, as an alternative way of deleting the appointment.

Selecting Multiple Appointments

     You can select multiple appointments (event), by holding down the shift-key when clicking on a
second event. This will select all events between the already selected and the target event. To select or
deselect individual events, hold down the command key and click on the pattern of the event. This will
either add it, or remove it, from those being selected.

Selecting all Events of a Day

     To select all events of a particular day, you can click on the top view, displaying the day number, and
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holidays. Selecting all the events of a particular day is useful, especially if you want to delete all the
events of a day, or if you want to move them to a different day, all at once.

Week View

     The Week view shows all the events of a specific week. The top area shows the day number, week
number, and holidays. Below are the to-do lists for each day and the daily schedule. The Week view (like
all other views) behaves like a paper roll. If you scroll down, you will scroll to the next week, if you scroll
up, you will see the previous week.

     The week view works much like the day view - creating appointments or to-do items, changing start
and end time of appointments, and so forth, all operations are just like in Day view. However, the Week
view offers some additional features when working with appointments.

Moving Appointments in Week View
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     To move an appointment, or to-do item in theWeek view, click on the pattern box, hold down the
mouse and move it to its new time or day. It is just that simple.

Creating Repeating Appointments in Week View

     The Week view offers an exceptionally easy way to create repeating appointments for a specific week.
To create a repeating appointment, click on the start time of the first occurrence, hold down the mouse
button and drag the cursor to the desired day that you want to have as the last occurrence. This will create
a repeating appointment for the range of days specified.

     If you enter any text (i.e., notes) for a repeating appointment, the text will be applied automatically, to
all of the repeating appointments. All occurrences of a repeating appointment, also share the same
category and voice annotations.

     If you change the category of a repeating appointment, all occurrences will be changed to the new
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category. While repeating appointments share text, category, and voice annotations, they can have
different start or end times and individual occurrences can be deleted, as explained below.

Exceptions

     If a single instance of a repeating event differs from the rest of the repeating events, it is called an
exception (e.g., a single occurrence of a repeating appointment is delayed for 30 minutes). To create an
exception, of a repeating event, simply move the particular occurrence to a different time, or change its
start or end time like with any other appointment (as discussed previously).

Modifying All Instances

     If you want to change, or move, all instances of a repeating event, or if you want to delete them all at
once, you can select all instances by holding down the option key when clicking on a single instance.
Alternatively, you can select a single instance, open the Edit menu, and then choose Select Repeating.
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     Remember that if you change a single occurence, the change will be applied to all occurences of the
repeating event. To move all occurences at once, simply click on the pattern of one of the selected
appointments and move it to its new start time. If you want to delete them all at once, type a back space or
open the Edit menu and choose Clear.

Month View

     The Month view shows all the events of a specific month. It provides both a good overview and it is
very handy, especially if you want to reschedule existing appointments. The month view lists both to-do
items, and appointments of a specific day, in the same area. Appointments are listed below the to-do items
if both types of events occur on the same day.

Creating Events in Month View

     To create an appointment in the Month view, click on the day you want to schedule the appointment, or
to-do item. Open the Arrange menu and choose Create Appointment, or Create To Do. A new appointment
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or to-do item will be created at the selected day. To specify a start and end-time for the appointment,
double-click the pattern box, or open the Edit menu and choose, Get Info, to open the Get Info dialog box.

Selecting Events in Month View

     To select a single event, simply click on it’s pattern box. You can select multiple events if you hold
down the command key when selecting events. To select all events within a time range, select the first
event, hold down the shift key, and select the last event. All the events in-between will be selected
automatically. To select all events of a particular day, click on the day number, to select all events of the
month, click on the month name. To deselect individual events form a large selection, hold down the
command key and click on the events to be deselected.

     Once you have specified the selected events, you can move them all at once, delete them all at once, or
even change their text size. The changes will be automatically applied to all selected events.

Moving Events in Month View

     To move an appointment, or to-do item, in the Month view, click on the pattern box and move it to a
different date. If you want to duplicate this event at another date, then hold down the option key, and
move the cursor to the new target date.

List View

     Switching to List view is a little different. If you switch from Day view, to List view, by clicking the
List icon, it will show the daily list of events. If you switch from Week view, it will show all the events of
a week, grouped together. To switch to a specific list, open the View menu, and then choose the list view
you want to work in.

Working with Events in List View

     To create an appointment, or a to-do item, in List view, click in the white space at the bottom of the to-
do or appointment-list. You can change the start and end time of appointments by clicking on the
numbers. When you do this, little up/down arrows will be displayed, allowing you to change the time. To-
do items do not show a start or end-time, since they are not bound to a specific time.
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Sorting and Adjusting Columns

     You can changethe way you sort, or the sort criteria, of the List view, by clicking on the column label.
The text will then be underlined, indicating the current sorting criteria. If you hold down the option key
and click on a column label, ClockWork will change the sorting criteria from ascending to descending
order, and back. If you hold down the shift key, you can set a secondary sorting criteria which sorts
events, when two events are equal according to the first sorting criteria. The secondary sorting criteria will
show as a dotted underline below the column label.

Changing Column Order

     You can change the order of columns in List view, by clicking and dragging the column labels.

     Note that you can resize columns by moving the cursor between two columns. The cursor will change
to a horizontal resize cursor, and you can then click and drag the column widths to the size desired.
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Changing Visible Columns

     If you want to decide which columns are visible in List view option, then open the Edit menu and
chose Preferences. Scroll until you see the List icon and click the icon. This will open the List preferences
showing a list of all available columns. Notice that columns visible in List view, are checked. If you want
to show or hide a column, simply check, or uncheck, the column label.

View Options

     You can change the way information is presented in the different views, by changing the view options.
For example, you can choose to hide to-do items, birthdays, etc. View options are “view-specific” because
ClockWork maintains a separate set of view options for Day, Week, Month and List view. You can change
the view options for Day view, without affecting the Week view. Reviewed below are the view options
available for Day, Week, Month and List view.

Restrict Text / Show All Text

     If you have events with lots of text entered (notes, etc.), ClockWork will restrict the text in Week view,
however, in Day view the time line will be expanded (by default) and the entire text will be shown. If you
want to see the full text in Week view, then choose Show All Text from the View menu. The events will
then expand to show the full text, expanding the time line as appropriate needed.
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     If you want to restrict the text, thus preventing expansion of the time-line, you can choose Restrict Text
from the View menu. If there is more text for an event than can be displayed, ClockWork will cut the text.
To view the rest of the text (in this mode), you can click into the text and auto-scroll to the bottom of the
event. This will reveal the hidden portion of the text. To view the hidden text line-by-line, you can use the
arrow keys to navigate the cursor into thehidden part revealing the hidden text.

Show / Hide To-Do Items

     You can show, or hide, all to-do items from the current view by choosing Show/Hide To-Dos from the
View menu. The area reserved for to-do items will be removed and all to-do items will be hidden in the
current view. Hiding to-do items is very useful in Month view, since this view often gets crowded (if you
have a lot of things to do, appointments, etc.).
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Show / Hide Appointments

     Like with to-do items, you can also choose to hide all appointments for the current view leaving only
the to-do items visible. To hide or show all appointments for the current view, choose Show/Hide
Appointments from the View menu.

Show / Hide Birthdays

     If you have entered birthdays in the Birthday Preferences, they will be shown in the Day and Week
view, by default. If you want to show Birthdays in Month view or hide them in Week view, you can open
the View menu and choose Show / Hide Birthdays. This will either show, or hide, the birthdays for the
currently active view.

Show / Hide Holidays

     By default, ClockWork shows holidays in Day, Week and Month view. You can show or hide the
holidays, for the currently active view, by choosing Show / Hide Holidays from the View menu. As an
example, hiding holidays can be useful in Week view, to make more room for events, while showing
holidays in the month view, may be desired. As mentioned before, this is one of the flexible attributes of
ClockWork since it uses, separately stored lists, for each view option
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Chapter 5: Working with events
     Earlier chapters have introduced the basics of how to create, move, and delete, appointments, and to-
do items. This chapter discusses additional features, and the various ways to enter and modify event
information.

Alarms

     ClockWork can automatically remind you of upcoming events with an Alarm icon. You can set
alarms for both appointments, and to-do items. When an alarm goes off, ClockWork will display an
alarm dialog box to remind you of the event. The ClockWork Reminder control panel can remind you of
upcoming events, even if the ClockWork application is not running. ClockWork even contains an option
to automatically power on your MacOS computer when the alarm goes off (see System Requirements).

Turning Alarm On or Off

     To turn on alarm for an event, select the event and click the alarm button in the menu bar. An alarm
icon will appear in the shaded partch of the appointment to indicate an active alarm. Alternatively, you
can open the Edit menu and choose Turn Alarm On, or Turn Alarm Off.

     Note that you can only activate alarms for events in the future. If you have selected an event already
passed, the alarm icon will be grayed.

     By default, ClockWork will remind you 15 minutes prior to the event by showing an alarm dialog
box. You can change the individual alarm presets by going into the Get Info dialog box, and the default
alarm time in the Alarm Preferences.

     You can also turn alarm on, or off, for multiple events at the same time. Simply select multiple events
by holding down the Command or shift key when selecting the events. To turn alarm on, or off, for all
selected events at once, open the Edit menu and choose Turn Alarm On or Turn Alarm Off.

Alarm Dialog

     When an alarm goes off, ClockWork displays the Alarm dialog box and plays back voice annotations.
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If you have Text-To-Speech system software installed, ClockWork will read the text aloud.

     In the alarm dialog box you can either dismiss the alarm, by clicking the OK button, or you can choose
to snooze (delay) the alarm. If you want to snooze the alarm, check the Remind me again check box,
specify the delay, and click OK. The alarm will be postponed for the specified time, and will reappear
again after that time period.

     If you don’t respond to, or dismiss, the alarm dialog, ClockWork will automatically remove the alarm
dialog after 30 seconds of inactivity. The alarm will then be postponed for one minute, and will be re-
displayed again after that time period. This is to make sure that any background processes (like a copy
process in the Finder, etc.) will continue, if you leave your computer during the time an alarm goes off.

Changing Events

     To change various aspects of an event, double-click on the pattern box to open the Get info dialog box.
Alternatively, you can select the event, and then choose the Get Info item from the Edit menu.

     The Get Info dialog box lets you changemany things, such as, the type of an event, or to record voice
annotations, or change the start and end time, or to modify the text. You can also turn the alarm on, or off,
specify the alarm time, and specify the type sound played when displaying the alarm dialog box.

Repeating Events

     By clicking the Repeat button in the Get Info dialog box, you can specify a repeat interval, for the
event, to create multiple occurrences. Alternatively, you can select the event and choose Repeat from the
Edit menu to open the Repeat dialog box.



28

Repeat

     The repeat dialog box lets you specify various options on how to repeat the selected event. The Repeat
cluster lets you specify how often the event should reoccur. Select For X times, if you know exactly how
often the event should occur and type the number of occurrences. If you only know when the last
occurrence will be, select Until and specify the last date. If you don’t know when the event will stop
occuring, then check the Ongoing button. This option will create new occurrences whenever you open
your calendar file.

     Please note that creating a large number of repeating events, can significantly slow down opening the
calendar file, and will also increase the amount of memory required by ClockWork. To help control this
problem, ClockWork  automatically limits the number of occurrences to the current, and next month,
when selecting the Ongoing feature.

Cycle

     Depending on the option selected in the Interval cluster, ClockWork offers additional options in the
Cycle feature. In the Cycle option, you can choose a weekly interval, you can specify the week days. Or if
you select a yearly interval, then you can specify the month in the Cycle.

Group Events

     By default, you can select, modify and delete the individual occurrences of a repeating event. If you
want all occurrences of a repeating event to be collected into a group, check the Group events check box.
If you move an instance of a grouped repeating event, you will move all occurrences at the same time.

Interval

     ClockWork offers various ways to specify occurrences of a repeating event. Select the repeating
interval from the Interval menu, and specify the occurrences in the Cycle option, if necessary.

Grouping and Ungrouping Events
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     Sometimes separate events really belong together, and the occurrences of the second event depends on
the occurrence of the first event. In this case, you can group the two events together. It you move the first
event, ClockWork will move the second event, too.

     To group multiple events, select the events you want to be grouped by holding down the command or
shift-key when selecting. Open the Arrange menu and choose Group to group the selected events. After
grouping the events, moving, selecting, or deleting a single event of the group will apply the change to all
events of that group.

     If you want to break a group of events into separate events, so that you can modify or delete the
individual events, select the group and chose Ungroup from the Arrange menu.

Locking and Unlocking Events

     You can lock events, thus preventing unwanted modifications, or unwanted deletion of events. To lock
an event, select the event and choose Lock from the Arrange menu. A lock icon will be shown in the
pattern box of the event to indicate that it cannot be modified.

     If you accidently try to modify a locked event, ClockWork will beep to remind you that you have tried
to modify the locked event. If you want to unlock a locked event, select it and choose Unlock from the
Arrange menu. This will remove the lock icon, and you will be able to then modify, or delete, the event.

Changing the Category

     Every event has a category assigned to it as indicated by the colored pattern box. If you select an event,
the category popup menu will switch to show the category of the event. If you want to change the
category, select the event and then choose a different category from the pull-down category menu.

     Note that you can also change the category of multiple events at the same time. Simply select multiple
events by holding down the Command or Shift-key when selecting. If you choose a new category from
the category pull-down menu, the change will be applied to all the selected events.
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Showing and Hiding Events

     You can show, or hide, individual events from your calendar to get a better overview, or if you want to
print only certain selected events. To hide the selected events, choose Hide Selected from the Arrange
menu. To hide all events except the selected ones, open the Arrange menu and choose Hide Unselected.
This is useful, if you want to print only the selected events, for example.

     To make all currently hidden events visible again, open the Arrange menu and choose Show All from
the Show menu.

Showing and Hiding Categories

     ClockWork allows you to show, or hide, all events of a specific category. This makes sense, if you are
at work and want to hide all private events, for example. To hide all the events of a specific category, open
the Arrange menu and choose the category from the Show menu. All events of that category will then be
hidden, as the check-mark will be removed (indicating that this category is not shown). A minus, at the
top of the menu, instead of the check-mark, indicates that some events of this category are visible and
some are invisible. To make the events of this category visible again, repeat the process above.

     To hide all categories except a specific category, hold down the option key, open the Arrange menu and
choose Hide All from the Hide menu. Then open the Arrange menu again (without holding down the
option key) and choose the category from the Show menu. This will leave only events of that category
visible, hiding all others.

Overlapping Appointments

     Sometimes, appointments take place at the same time. ClockWork supports overlapping appointments
by staggering them on top of each other.

     If you move the appointment at the bottom, it will jump to the top. Should you want to manually
reorder the staggering of appointments, select the event you want to move to the top, open the Arrange
menu and choose Move To Top. If you want to move an appointment to the bottom, choose Move To
Bottom. Move To Top, and Move To Bottom, menu items are only enabled, if you have selected an
appointment which is overlapping with an other appointment.
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Text in Events

To enter text for an event, click in the edit area of the event and type the text. ClockWork supports up to
32000 characters of styled text per event. You can user drag-and-drop to move portions of text within the
text or from one event to another. ClockWork supports copy-and-paste and undo for every text editing
command just like in most word processors.

Styled Text

     You can change the font, size and style of text entered for an event. To change the Font used for the
next characters while typing, open the Font menu and choose a font. To change all text of an event, select
the event by clicking on the pattern box and choose a font from the Font menu.

     Note that you can also change the size, by using the Size menu, or the style and color, by using the
Style menu.

Recording Voice Annotations

     ClockWork supports recording voice annotations much like a dictaphone. ClockWork uses a 6:1
compression to reduce the size of the recorded sound, and supports hard disk recording, so the length of
the recorded sound is not limited by available memory. Check Appendix I to see if your computer will
allow you to use this feature.

     To record a voice annotation for an event, select the event and click the Microphone icon.
Alternatively, you can open the Sound menu and choose Record.

     A standard record dialog box will be opened which lets you record a voice annotation for the selected
event. To start recording, click the record button and speak into the microphone.
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     The record dialog box works much like a tape recorder. You can stop, pause and play back your
recording by pressing the appropriate button. The speaker icon indicates the record level. Try to adjust the
level of your voice so that the speaker icon shows a normal voice level. The remaining recording time is
indicated by the meter on the bottom, and is limited only the space available on your hard disk.

     After recording the voice annotation, click the Save button to attach the recorded sound to the currently
selected event. A speakerphone icon in the pattern box of the event indicates the attached voice
annotation.

Playing Voice Annotations

     To play a recorded voice annotation, select the event and click the speakerphone icon, or open the
Sound menu and choose Play.

     ClockWork will play back the recorded sound. ClockWork supports asynchronous play back, so you
can continue to work with the program while the voice annotation is played. To stop playing back sound,
click the speakerphone icon again or open the Sound menu and choose Stop.

Erasing Voice Annotations

     To erase a voice annotation, select the event, open the Sound menu and choose Erase.

Sound and the Clipboard

     ClockWork supports copy-and-paste of voice annotations. You can paste sampled sounds created by
other programs, and you can copy and paste voice annotations recorded within ClockWork. To copy a
recorded voice annotation, select the event, open the Sound menu and choose Copy. This will place the
voice annotation onto the clipboard. To paste a recorded sound into an existing event, select the event and
choose Paste Sound from the Edit menu.

Using Text-To-Speech

     ClockWork supports Text-To-Speech system software. If you have Text-To-Speech installed, you can
use the Sound menu to let the computer read text aloud. Text-To-Speech software is part of MacOS 8.0
and can be installed as an add-on-product for earlier versions of the MacOS.

Let the Computer Speak Text Aloud

     To let the computer speak aloud the text of an event, select the event, open the Sound menu and choose
Speak Selection. ClockWork will then use Text-To-Speech to speak aloud the information about each of
the selected events, as well as the text entered for the event.

     To speak aloud information about more than one event, select multiple events by holding down the
Command or Shift key when selecting. Then open the Sound menu and choose Speak Selection.
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ClockWork will then speak aloud information about all selected events. To select all events of a specific
day, click on the day number above the schedule area.

     If you want the computer to speak just a part of the text entered into an event, you can select a portion
of the text and choose Speak Selection from the Sound menu.

     You can stop ClockWork from speaking text aloud by opening the Sound menu and choosing Stop.
Alternatively, you can click the speakerphone icon or hold down the command key and type a period.

Changing the Default Voice

     To change the type of voice used to speak text aloud, open the Sound menu and choose a voice name.
ClockWork will speak aloud the name of the selected voice to give a sample. From now on, the program
will use the selected voice when speaking text aloud.

Find

     To search for an event, by text, open the Edit menu and choose Find. This will open the Find dialog
which lets you enter text to search for in all events.

     Enter the text string to search for into the Find field. If you want to search case sensitive (upper- and
lower case must match), check the Case sensitive check box.

     When the Wrap around checkbox is checked, ClockWork will continue the search at the beginning of
the document, when it reaches the end. Uncheck this box, if you want to search from the current position
to the end of the document only.

     If you check the All at once check box, ClockWork will search the whole document and select all
events which match the search criteria. As an example, this is useful, if you want to search all events
related to a specific event, or person, and print or delete them all at once.

     Click the Find button to start searching for the text. If ClockWork finds an event which matches the
criteria, it will scroll to that event and select it. To find the next event which matches the search criteria,
open the Find menu and choose Find Again.
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Chapter 6: Working with the Calendar
     The calendar on the left of the windows is used to navigate in time. It also provides a good overview
and a fast access to the different views within ClockWork.

     The current day is drawn in green color. A gray border frames the currently visible time range.

     To navigate in time, you can click the up and down arrows either above, or below, the calendar. If you
click on the down-arrow, ClockWork will display the next month, if you click on the up-arrow it will
scroll to the previous month.

     Click on a day number to jump to that day. Click on a week number to switch to the Week view and to
scroll to that week. If you click on the month name, ClockWork will switch to Month view and then
scroll either up, or down, to the selected month.

Resizing the Calendar

     If you need more space for the calendar, to get a better overview or see more detail, you can resize the
area reserved for the calendar, by putting the cursor on the vertical bar between the calendar and the
editor, and then moving the vertical line to the right.
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     If you drag the cursor far enough to the right, so that there is enough space for a second month, then
ClockWork will automatically draw a second month column. Note that you can also hide the calendar, if
you move the cursor to the left.

Show / Hide Calendar

     If you are concerned about screen real-estate (e.g., if you are working on a PowerBook), you can
temporarily hide the calendar. To show or hide the calendar, open the View menu and choose Show / Hide
calendar. To make the calendar visible again, choose the same menu again and repeat the process, or drag
the vertical bar to make room for the calendar.
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Chapter 7: Sharing Events on the Network
     ClockWork offers easy and very flexible networking capabilities, called Shared Events. Using shared
events, you can define a category of events shared on the network. Shared events will then appear in all
calendars of your workgroup network. If anybody makes a change to an event, of that category, all
calendars will be updated automatically.

     In order to use ClockWork’s sharing features, all team members must have access to a common file
server. This can be an AppleShare file server, or simply the personal file sharing capability of every
MacOS computer. However using an AppleShare file server is recommended, because an AppleShare file
server offers better network performance than personal file sharing. The performance of Clockwork’s
sharing feature depends on the networking speed.

     Only Shared Events are published to the Edition file. Every time you save your document, any of the
shared changes are published to the Edition file, and all calendars of your co-workers subscribing to that
Edition are updated automatically. You can share all events, a category of events, only selected events, or
all events within a range of time. Sharing works, even if some computers are temporarily turned off, or if
you are working with a PowerBook on the road. The next time you connect to the file server, ClockWork
will update your calendar and publish any changes made to the network. Personal, or unshared events, are
not published to the Edition file, and thus are not accessible to other users.

Network time

     ClockWork’s sharing feature compares the modification time of events in your calendar, with the
events on the network, when subscribing to an edition. Therefore it is essential, that all computers sharing
events have the same, or nearly the same, clock time and date. We recommend products like MacDCF77
or ClockSyncII to ensure equal system times on the network.

http://www.bkohg.com/zubehoer/funkuhr1_e.html
http://members.aol.com/jbkezer/shareware.html
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Sharing a Category of Events

     To share a category of events, open the Edit menu, and choose Create Publisher, from the Sharing
menu. In the Create Publisher dialog box that appears, choose the category of events you want to share
from the Publish popup menu. All events of that category will then be published into the Edition file and
can be shared by your co-workers.

     Either locate a common accessible file server, or save the edition into a “shared folder”, on your local
hard disk. Enter a name for the shared edition (e.g. Staff Meetings), and click Publish to share the events.
This will create a shared edition containing all events of the category.

     Tell your co-workers to subscribe to the “shared edition” you have created. Whenever you save your
calendar file, any changes made to events of the published category will be published to this shared
edition, and all subscribers will be updated automatically.

Shared vs. Published Editions

     By default, all co-workers will be able to modify Shared events. If anybody makes a change to a
Shared event, or creates a new event of that category, all calendars will be updated automatically. If you
want to prevent others from making modifications to the Edition fille, then, uncheck the Allow
modifications checkbox when creating a new publisher. This will create a Published Edition file, which
allow access with read-only permission. Consequently, your co-workers will be able to subscribe to the
published edition, but they will not be able to make modifications. The Published Edition, however will
still automatically make changes in all subscribers calendar files.
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Publishing TEXT Format

     You can choose to include information about the published events in standard tab-delimited TEXT
format by checking the Include TEXT format check box in the create Publisher dialog box. This allows
other programs which support Publish & Subscribe to subscribe to a ClockWork edition. For example,
you can use Claris Works to subscribe to a ClockWork edition containing shared events. This could be
very useful, if you wanted to create a weekly report listing all meetings with a particular client.

Publishing Selected Events

     When creating a publisher, you can choose to publish the currently selected events, rather than
publishing a category of all events, by choosing Selection from the Publish menu in the Create Publisher
dialog box. This will create an edition containing only the selected events. This is very useful if you want
to publish only certain events related to a specific topic (selected meetings, plane fares, etc.).

Publishing all Events

     If you want to share all events of your calendar, choose All Events from the Publish menu in the Create
Publisher dialog box. This will publish all the events currently stored in your calendar, as well as all
events which will be created in the future regardless of the category or selection. Be aware that creating
an edition with a large number of shared events might affect performance when saving your document.

Publishing a Range of Time

     You can also create a publisher that will publish all events in a specific time frame, independent of the
category. For example, you could create a publisher which publishes all events between November 2nd
and November 5. To publish a range of time, switch to Month view and select the days you want to
publish. If you want to select the whole month, click on the month name. If you want to select more than
one month, hold down the mouse and drag it to the next month.
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     After selecting the range of time to be published, open the Edit menu and choose Create Publisher
from the Sharing menu. In the create Publisher Dialog box that appears, make sure the Sharing popup
menu shows Selection and store the edition on a common accessible file server. Since you have selected a
range of time, ClockWork will publish all events within that time frame.

Subscribing to an Edition

     To subscribe to published events, open the Edit menu and choose Subscribe to from the Sharing menu.
In the Subscribe to, dialog box that appears, locate the edition you want to subscribe to, and click the
Subscribe button. This will insert the events contained in the edition into your calendar. Subscribed events
will be marked with a gray border, and you will automatically receive updates every time somebody
makes changes to these events.

     If the edition is a Shared Edition, you will be able to make changes to the subscribed events. If you
make changes, all of your co-workers will automatically receive an update the next time you save your
document. If the edition was created disallowing modifications, then the subscribed events will show a
lock icon, and you will not be able to modify them.



41

Security

     All events published, or shared, can be subscribed to by anybody. ClockWork currently does offer the
feature of protecting editions with a password. If you are concerned about the protection of information,
make sure the folder in which you store the edition into, has access permission for the members of your
group, only. You can limit the access permission of a folder, to specific users, and consequently assign a
password which is required to access the folder. Please refer to the MacOS manual, or the AppleShare
manual, for instructions on how to set access permission for a shared folder.

Show / Hide Borders

     Events which are part of a publisher, or subscriber, are framed with different types of grey borders. For
those events which are part of a shared edition (modifiable), the events are framed with a light gray
pattern border. Events part of a published edition (read-only) are framed with a dark grey pattern border.

     If you want to hide, or show the borders, open the Edit menu and choose Show / Hide borders from the
Sharing menu.

Stop All Editions

     If somebody in your workgroup publishes a newer edition (i.e., makes changes, additions, and saves)
of one that you are subscribed to,then ClockWork will automatically receives the newer edition, and
merges the new edition into your calendar. For all new, or changed events, ClockWork will scroll to these
events and then select them (the notification of changes process).

     If you want to temporarily stop receiving new editions, open the Edit menu and choose Stop all
Editions from the Sharing menu. When this option is checked, ClockWork will ignore new editions from
the network and you won’t receive any updates for subscribed events. To resume receiving new editions,
uncheck the Stop all Editions menu item.
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Chapter 8: Synchronizing with Newton
     ClockWork offers fast and easy synchronization with the built-in “dates application” of the Newton
MessagePad, or the eMate computers. It synchronizes appointments, to-do items, notes for appointments,
repeating appointments, and to-do items, as well as custom repeating appointments. Synchronization
works in both directions. You can thus make modifications on both sides. ClockWork will transfer new
changes from the Newton to the Mac, and from the Mac to the Newton.

Connecting your Newton

     You can synchronize your Newton using a serial or AppleTalk network connection. To connect your
Newton using a serial connection, use the serial cable which came with your Newton computer and
connect it to either the Modem, or Printer port, of your MacOS computer. If you want to connect using an
AppleTalk network connection, make sure your Newton and MacOS computer are on the same AppleTalk
network.

Installing the ClockWork Package

     For Newton synchronization to work, you have to install the ClockWork.pkg Newton package which
you can find in the Newton folder (within the ClockWork folder). The ClockWork.pkg Newton package
acts as a bridge to the Newton computer providing access to the events stored in your Newton. To install
the ClockWork.pkg Newton package, use the Newton Package Installer which came with your Newton
computer.

Synchronizing

     To synchronize your ClockWork calendar with the built-in dates application of the Newton, open the
File menu and choose Newton from the Synchronize menu. This will open the Newton Synchronize
dialog box. If your Newton is connected via a serial cable, choose the port (Serial Modem Port, or Serial
Printer Port) from the Connection popup menu. Click Synchronize to start the synchronization process on
the MacOS side. The Synchronize dialog box will be shown, indicating that ClockWork is waiting for the
Newton to initiate the synchronization process.

     On your Newton computer, open the Extras drawer and start the ClockWork package. If you have
connected your Newton using a serial cable, make sure the Serial Connection button is selected. Click
Synchronize to start the synchronization process. If you have connected your Newton using an AppleTalk
network connection, then select the AppleTalk button and click Choose Macintosh. Choose your MacOS
computer in the chooser dialog box that appears to start the synchronization process.
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Synchronization Speed

     If you synchronize for the first time, all events from the Newton will be transferred to the MacOS side,
and all events from the MacOS side will be transferred to the Newton. Synchronization times can be quite
long if you synchronize for the first time, since all information about your events have to be transferred.
When you synchronize again, then ClockWork will only transfer the modified events, thus resulting in
significantly shorter synchronization times. However, ClockWork still has to transfer the directory of
events from the Newton to the Mac every time you synchronize. This is to find out which events have
been modified. A large number of events, and a slow Newton, can significantly increase synchronization
time.

     If you feel synchronization takes too long, you can either archive past events in a separate calendar
file, or you can delete the old events from your calendar. Another method is to upgrade your Newton to a
newer model. Older Newton models have a very poor performance when transferring data though the
serial port, or through the network. In contrast, the Newton Message Pad 2000, or newer models, can offer
synchronization speeds up to 10 times faster than older models. For example, a Newton Message Pad
2000 handles subsequent synchronizations within 12 seconds if you have stored 100 events in your
calendar.

Known Limitations

     ClockWork offers very good Newton synchronization capabilities, but there are certain limitations.
ClockWork currently does not synchronize untimed events, sometimes referred to as to-do events. In
addition, ClockWork currently does not support synchronization of birthdays, holidays, and any notes for
individual repeating events. Century Software is working on these limitations and synchronization
capabilities will be improved in future versions of ClockWork.
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Chapter 9: File Synchronization
     ClockWork supports synchronization of calendar files at a per event-level. This is useful if you are
working on a desktop MacOS computer, and want to take your calendar data on the road using a
PowerBook computer. As an example, if you make modifications to your calendar using the PowerBook,
and your secretary adds new appointments on your desktop computer, then you can merge both files
together with complete synchronization. By using File Synchronization to merge the two calendar files,
the new changes from the PowerBook are transferred to the desktop MacOS computer. and all the new
appointments are transferred to your PowerBook.

Preparing for File Synchronization

     To use File Synchronization, you have to connect your PowerBook and your desktop MacOS computer
together using an AppleTalk network, and then enable File Sharing on your desktop computer. Make sure
you can access the files located on your desktop MacOS computer from your PowerBook. For further
instructions on how to enable File Sharing and how to give others access to the files on your computer,
please refer to the MacOS manual, or MacOS AppleGuide available from the Help menu in the Finder.

     Using the Chooser mount your desktop computers’s hard disk, from your PowerBook, so that you can
access the calendar file located on your desktop computer’s hard disk. Copy the calendar file from your
desktop computer to the local hard disk of your PowerBook. If you take your PowerBook on the road you
can make changes to the calendar file adding new appointments or modifying existing ones.

Using File Synchronization

     After you come back to the office and your want to synchronize your PowerBook’s calendar with your
desktop’s, mount your desktop computer’s hard disk from your PowerBook using the Chooser. On your
PowerBook start ClockWork and open your PowerBook’s calendar file. Open the File menu and choose
File from the Synchronize menu. In the Open File dialog box that appears, press the Desktop button and
open your desktop computer’s hard disk mounted via FileSharing. Find the calendar file on your desktop
computer’s hard disk and click synchronize. ClockWork will now merge your PowerBook’s calendar file
with your desktop computer’s calendar file. All new or changed events will be transferred from your
PowerBook, to the desktop computer, and from your desktop computer to your PowerBook. Both calendar
files will be identical after synchronization.

     When you synchronize your PowerBook and desktop computer’s calendar files for the first time,
ClockWork will add a menu item, to the Synchronize menu, identifying your desktop computer’s calendar
file. The next time you want to synchronize the two files, simply choose this menu item and ClockWork
will automatically mount your desktop computer’s hard disk and locate the calendar file.
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Chapter 10: Printing
     ClockWork offers solid printing capabilities and supports printing to many major day planner formats
like Day Runner® or Time/system®.

Preparing to Print

     Before printing your schedule, choose Day, Week, Month or List view. ClockWork will always print
the currently selected view, then select the view desired to print. For example, switch to week view if you
want to print the current week. ClockWork maintains a print setup for every view so that you could set up
Week view to print in landscape format while printing Day view in portrait format. To specify printing
options, open the File menu and choose Print Options. This will open the Printing Options dialog which
lets you specify various printing options for the currently active view.

Format Popup

     If you plan to print to a standard day planner format, choose the format which most closely matches
your day planner from the Format popup menu. When printing to standard day planner formats, make sure
the Show cut lines checkbox is checked as this will print cut lines identifying the boundaries of your day
planner’s paper format. Using the other options in this menu, you can print multiple days to one page or
enlarge the output to create wall charts.

High Resolution Printing

     If you want high quality output, check the High Resolution Printing checkbox. If you want faster
printing and you are willing to sacrifice the quality of the printed output, uncheck this option. If High
Resolution printing is turned off, the output might appear a little rough, but will print much faster.
Naturally, the printing speed is also a function of the type of printer you are using.

Shrink To Fit

     If the Shrink to Fit option is checked, ClockWork will scale the image to fit the specified format.
Check this option if you want to print to standard day planner formats like Filofax®. If you uncheck this
option, a single day will print to multiple pages, if it doesn’t fit on the specified print format.
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Room for Punch Holes

     If you plan to print a standard day planner format and insert the printed copy into your Calendar, then
check the Room for Punch Holes option. ClockWork will leave some extra space on the left side of the
page for applying punch holes. If your day planner has holes at the top of the page, then you can select the
option to leave room at the top for these holes.

Page Setup

     To specify standard printing options like paper format or rotation, click the Page Setup button which
will open the Page Setup dialog of the currently selected printer.

Printing the Schedule

     To print the currently active view (Day, Week. Month or List), open the File menu and choose Print.
The standard print dialog of the currently active printer will be opened. Depending on the type of printer
you are using, you can specify various printing options. Click the Print button to start the printing process.

Printing a Range of Time

     To print a range of time, open the File menu and choose Print Range. This will open the Print Range
dialog which lets you specify a range of time to print (e.g. from 11/16/1997 to 11/22/1997).

Note: When you select a range of time to print (by clicking on the day number above the schedule area),
the Print menu is renamed “Print Selection” and will print the currently selected range of time. A single
click in the schedule area will deselect and the Print Selection menu will be renamed to “Print”.

Known Limitations

     ClockWork currently does not support double-sided printing. Century Software plans to add this
feature in a future version of ClockWork. In the meantime, you can use 3rd party products like Dynopage
to process ClockWork’s printing output for double-sided printing.
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Chapter 11: Importing
     ClockWork supports importing schedules from various day planners. The program can read ASCII-text
files created by the export functions of Claris Organizer, DateBook Pro, Day Maker, Delinra Daily
Planner, Meeting Maker, Meeting Maker XP, Now Up-to-Date, PowerManager and TeamAgenda.

Exporting from other Day Planners

     To export schedules from other day planner software (not mentioned above), please consult the manual
of the product. Make sure you export schedule data in standard ASCII-TEXT format, so ClockWork can
read the file.

Importing

     Open the File menu and choose Import. In the Open dialog box that appears, locate the ASCII-TEXT
file exported by your other day planner software. You can limit the file selection by selecting the
importing file Format from the popup menu. Then select the ASCII-TEXT file and click Import.

     ClockWork will analyze the exported file, and it will insert the new events found into the currently
open document. Please note that the quality of the import results varies depending on the export format
and data in your export file. ClockWork will import appointments, to-do items, categories and the text of
events. However, most day planners don’t export alarm times, repeating events and therefore can’t be
imported.

     Usually, ClockWork will automatically find out about the import format and properly import your
exported schedule. However, depending on the import format, and the data contained in the import file,
ClockWork might make a wrong guess. If ClockWork can’t automatically find out about the format of the
exported file, it sometimes misinterprets the order of information resulting in an incomplete import. If you
are having problems importing your data, try to check the Manual configuration check box to manually
assign the import fields.

Manual Configuration

     If you check the Manual configuration check box in the Import dialog box, ClockWork will show the
Manual Configuration dialog box after analyzing the file. You can use the Manual Configuration dialog
box to manually assign the import fields.
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     To manually assign the relationship between fields of records found in the import file, drag and drop
them from the list on the right to the target fields on the left. When importing the file, ClockWork will
interpret the import file based on the assignment you have specified in this dialog box.

Custom Import Format

     Using the Format popup menu you can specify the file format of your import file. If you are importing
custom data (e.g. data exported from a FileMaker database), you can choose Custom Format from the
Format popup to specify the import format. Use this dialog box to manually specify the format of your
import file, if ClockWork did not find out automatically.

     The Custom Format dialog box allows you to specify Field and Record delimiters enclosing the
individual events, or items, in the import file. You can specify how to interpret date information (e.g. start
date of to-do items) and the time format used to specify start and end time of appointments.
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Chapter 12: Exporting
     ClockWork supports exporting your schedule to various formats of other day planners. If you want to
exchange information with other programs, or if you want to export your ClockWork schedule to another
day planner, you can use the Export functionality to export to standard ASCII-TEXT format which then
can usually be imported by the other programs (based on their importing supportability).

     ClockWork supports export formats which can be used to import the schedule to Claris Organizer,
DateBook Pro, DayMaker, Delinra Daily Planner, Meeting Maker, Meeting Maker XP, Now Up-to-Date,
PowerManager and Team Agenda.

Exporting to other Day Planners

     To export your schedule, open the File menu and choose Export. The Export dialog box will be opened
which lets you specify the export format as well as the file name and location of the export file.

     Choose the file format from the Format popup menu. The export format specifies the order of
information, as well as how special information, like the to-do done/not done status are exported. If you
plan to import the schedule to another day planner choose it from this menu.

     For information on how to import the exported schedule to other programs, please consult the
documentation of the other program. Most day planners, or word processors, are able to import the
standard ASCII-TEXT format exported by ClockWork.

     Please note that the quality of exchanged information varies and is highly dependent on the export
format chosen. Some day planners will not be able to import all information as presented in ClockWork.

Using Export as a Backup

     You can also use the Export functionality to make a secure backup of your schedule in standard ASCII-
TEXT format. If you want to make a backup of your schedule, choose ClockWork from the Format popup
menu.

     Be aware of the fact that the exported file will only contain the most important information of your
calendar file - appointments and to-do items. Repeating events, patterns, color, text-style information,
alarms, birthdays and holidays and other settings are not exported, and therefore cannot be restored.
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Chapter 13: Preferences
     This chapter provides an overview of the ClockWork preferences which can be used to customize the
behavior of the program in order to match your personal requirements. To open the Preferences dialog,
choose Preferences from the Edit menu.

General Preferences

     The General Preferences allow configuration of the autosave functionality, and can be used to
personalize ClockWork by entering a serial number (obtained at time of purchase).

Autosave

     If you want ClockWork to autosave your document at fixed time intervals then use this feature. This
will minimize any data losses should a power loss, or or power surge, occur when you are using
ClockWork. Check the Every X Minutes check box, and specify the autosave time interval in the box. If
you don’t want to be asked wether you want to save the document, when closing your calendar, check the
When closing document check box, and it will be automatically saved at closing.

License

     If you want to unlock a trial version of ClockWork, you can enter your name and a valid serial number
in the License area. ClockWork serial numbers can be purchased online using a major credit card on our
secure web-site http://www.centsoft.com or by using the Order Form fax order which can be found in the
ClockWork folder. Note that you can’t change the user name, or company name, once it is entered without
entering a different serial number at the same time.

http://www.centsoft.com/
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Categories Preferences

     The Categories Preferences can be used to modify the categories popup menu in the main window. You
can create new categories, delete existing ones, rename them or change their pattern and color. To create a
new category, click the New button and type a name for the new category (e.g. Personal). To delete a
category, use the Delete button. Using drag-and-drop you can rearrange the order of categories within the
categories list.

     To change the pattern, or the color, of a category, select the category and choose a pattern and color
from the list on the right. If you double-click a pattern or color-box you can modify the standard patterns
and define your own set of colors.
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Day/Time Preferences

     The Day/Time Preferences can be used to change day start and end times, to show or hide individual
weekdays, and to switch between the International and the U.S. week format.

Shown days

     If you want to hide individual weekdays, uncheck their checkboxes. This is useful, if you use
ClockWork to organize your work schedule and you don’t want to waste screen real estate for Saturdays
and Sundays. If you hide a weekday, it will disappear in all views (Day, Week, Month and List view).

Time

     If your working day does not start at 9 AM or does not end at 5 PM, you can adjust the start and end
time of the working day by adjusting the Day begins at or Day ends at time editors. Using the scaling
popup menu item, you can specify how many minutes a single line in Day and Week view represents. If
you decrease the scaling you will see more detail and you will be able to schedule your appointments
more precisely. If you increase the scaling you will get a better overview, but a less accurate display in the
Day and Week views.

Week format

     ClockWork adjusts the week format based on the MacOS you are running. If you are running on a U.S.
MacOS system, ClockWork automatically defaults to U.S. weekformat (Sunday is first day of week, U.S.
Week number format). If you are running on a European, or Japanese MacOS, ClockWork will default to
International week format (Monday is first day of week, ISO Week number format). If you want to
override the initial settings, switch the Week format button in the preference menu.
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Style Preferences

     The Document Preferences can be used to customize the visual appearance of the calendar and the
different views.

Calendar

     Use the these standard controls to change the font and font size for the calendar. These fonts apply only
to the calendar used on the left of the main window.

Editor

     You can change the font and font size, using these controls, which are used to draw the day numbers,
month names, and time line in Day, Week, Month and List view.

Holidays

     You can change the way holidays are marked in the calendar, and in the different views, by using the
Holidays controls. You can change the style by checking or unchecking Bold, or Outline, and you can
change the color by clicking the Color button.
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List Preferences

     Using the List Preferences, you can show or hide columns in the List view. Columns visible in List
view are checked. If you want to change which columns are visible, check or uncheck the individual
column labels.

Security Preferences

Use the Security Preferences to protect your calendar with a password.
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Security

     Enter a password in the Password edit text field to protect your calendar file with a password. The
password will be visible while you type the password into the password edit text field, but will be
replaced with bullets when you reopen the preferences. Make sure you choose a password you will
remember, because there is no back-door (you may want to write it down in a safe place).

     The next time you open your calendar file, ClockWork will automatically ask for the password, and
will only open the file, if the correct password has been entered.

Options

     While entering a password does protect your calendar file from unauthorized access, a hacker might be
able to open your calendar file with low-level tools bypassing the password protection. Using those tools,
the hacker might be able to read the text entered for events.

     To increase the level of security, you can check the Encrypt text data check box. If you check this
option, ClockWork will encrypt text entered for events with a custom encryption-algorithm. This will
protect your calendar against low-level tools. Please note that turning on encryption can slow down
opening and saving files.
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Birthday Preferences

     Using the Birthday Preferences you can enter the birthdays of your friends and business partners, so
you won’t forget them. Birthdays are shown, along with Holidays, in Day and Week view, and you can
make them visible in Month and List view, too.

     To enter a new Birthday, click the New button. To modify an existing one, select it from the list and
click Edit. To delete a birthday, select it and click Delete.

     If you click New or Edit, ClockWork will open the Birthday dialog which lets you enter the new text,
or modify an existing birthday text.

     Type the name of the person, and specify his or her birthday, then click OK. Be sure to enter the year,
so ClockWork can compute and display the age of the person.
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Holidays Preferences

     The Holidays Preferences can be used to specify which holidays are visible in Day, Week and Month
view. It is also used to edit existing holidays, to delete existing ones, or to enter new holidays.

     Instead of maintaining a list of holiday occurrences for each new year, ClockWork computes holidays
based on different algorithms. While Century Software has tried to compile an exhaustive list of
international holidays, frequent changes in the different countries can’t be tracked completely. If you find
an error in ClockWork’s holiday list for your county, please send an email to: support@centsoft.com

Multiple countries

     You can choose different countries from the popup menu. If you choose another country in themenu
item, the country’s hollidays will be added to the list of visible holidays. This makes it possible to show
the holidays of the USA and Japan, at the same time. If more than one country is visible, the popup will be
labeled “Mixed” and ClockWork will add the name of the country to the holiday so you can distinguish
between them. To hide the holidays of a country, choose the menu again, and unselect the country.

     If you want to switch from USA to Germany, for example, choose Germany from the popup menu to
show the German holidays. Then choose the USA from the popup menu to unselect the USA, and hide the
US holidays, thus leaving only the German holidays visible.

Editing Holidays

     If you can’t find your country in the list, you can enter a new country manually. Choose the current
country (usually “USA”) from the country popup menu to hide the country. Then choose “Custom” from
the country popup menu to switch to custom holidays.

     Using the New, Edit and Delete buttons you can create new holidays, and modify or delete existing
custom holidays. If you click the New or edit button, the Holiday dialog will be opened which lets you
specify both the name and occurrence of a holiday.

mailto:support@centsoft.com
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Title

     Enter the name of the holiday into the Title edit text filed. If the holiday is a working day, check the
Workingday check box. If you uncheck the Workingday checkbox, ClockWork will draw the holiday and
day number in red indicating a non-workingday.

Occurrence

     Holidays follow different rules in different countries. If you know the rule for the holiday you are
specifying, choose it from the Occurrence popup menu. Depending on the Occurrence popup menu
choice. ClockWork will display a different occurrence editor for specifying the occurrence of the holiday.

     If you don’t know the rule, choose Day from the Occurrence popup menu to specify a fixed holiday.

Country

     The country popup menu can be used to specify the country list this holiday will belong to. Choose
“Custom” from the country popup menu, if you are entering holidays for a country not listed in the
country list.
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Alarms Preferences

     The Alarms preferences, reflect the settings of the ClockWork Reminder control panel, and allow you
to change the default alarm settings of new events.

Alarms

     To disable all alarms, switch the Alarms button to Off, to enable alarms, switch to On. If alarms are
disabled, ClockWork and the ClockWork Reminder will not show alarm dialog boxes, even if an alarm is
due. Use this option to temporarily disable alarms, only if you don’t want to be disturbed.

On Alarm

     On most MacOS computers, ClockWork can automatically power-on the computer, if an alarm goes
off. This way, you will never miss an appointment, even if you computer is turned off. However this
option is not available on all computers and will be hidden, if your computer does not support auto-power
on (see Appendix I).

     If you want ClockWork to play a sound when displaying an alarm box, check the Play alert sound
check box. If you want ClockWork to be quiet, uncheck this box.

     When displaying an alarm box, ClockWork can automatically play voice annotations. To play voice
annotations, check the Play recorded sound check box. If you uncheck this box, ClockWork will not play
voice annotations automatically, but you will be able to start play back manually by clicking the speaker
phone icon in the alarm dialog box.

     If your computer has Text-To-Speech system software installed, you can choose to let the computer
speak the event text aloud. Check the Speak text check box, if you want ClockWork to speak the text of
events aloud when displaying an alarm. This option is only available, if you have Text-To-Speech system
software installed.
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Default settings for all new events

     When ClockWork creates a new appointment, or to-do item, it will always apply the default settings.

     To turn on the alarm for all new events, by default, check the Alarm icon check box. Whenever you
create a new appointment or to-do item, ClockWork then will automatically remind you for that event.

     By default, ClockWork will remind you 15 minutes prior to the event. If you want a different default,
you can specify the default alarm time for new events.

     If you have enabled the Play alert sound option, ClockWork will play the sound specified in the Sound
popup menu when an alarm goes off. You can choose sounds installed in your system folder, or custom
sounds recorded in the Sounds Preferences.

Sounds Preferences

The Sounds Preferences lets you adjust the sound volume or record custom sounds for alarms.

Volume

     ClockWork maintains a volume setting separate from the system volume. This ensures that you won’t
miss an appointment, just because you have temporarily muted your system volume in the Monitors &
Sounds control panel. Use the volume slider to adjust the sound volume used to play back voice
annotations, and when speaking text aloud using Text-To-Speech.

Standard sounds for alarms

     You can record custom sounds which will played when an alarm goes off. By default, ClockWork
plays the “Eastern” sound, but you can change the default sound in the Alarms Preferences. To record a
new sound, click the microphone icon. To play back an existing one, select it from the list, or click the
speakerphone icon. To delete a sound, select it and click the trash can icon.
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To Do Preferences

     The To-Do Preferences lets you enter a default deadline, for new to-do items. When the deadline has
passed, a red exclamation mark (!) will be shown in the check box of the to-do item. This will remind you
that this to-do item is over due.
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Chapter 14: AppleScript
     AppleScript is the scripting language of the MacOS. Using AppleScript you can automate the Finder
and many MacOS programs. AppleScript is part of the MacOS, as of System 7.1, and can be installed on
earlier systems as an extension. ClockWork fully supports AppleScript for automating tasks, and to extend
or customize the functionality of the program. ClockWork is scriptable, recordable and attachable.

Scriptability

     Using AppleScript you can create new events and modify, or delete, existing ones. For example, you
can create new documents and appointments, change the start, or end time, of existing appointments, and/
or or get and set the text of events. Using the Script Editor application (located in the Apple Extras
folder), you can record and write AppleScript scripts to automate ClockWork.

Recordability

     In order to make writing AppleScripts for ClockWork easier, the program supports recording of
commands. To start recording, click the Record button in the Script Editor application and manually do
the steps you want to automate in ClockWork. The Script Editor application will record your actions as
AppleScript commands. If you run the script, ClockWork will automatically repeat the actions.
Recordability is also very useful to learn about the syntax of the AppleScript language.

Attachability

     Using attachability, you can modify the behavior of standard commands like opening a new document
or creating a new appointment. Fox example, you could write and AppleScript which overrides creating
new appointments, to do additional tasks like querying a database, or entering the current date and time as
a default text. Attachability also allows AppleScripts to execute at idle time, so you could write a script
which would check for upcoming events and send a message to a pager if necessary.

Scripts Folder

     In the ClockWork folder you can find a folder called “Scripts”. If you write a script to be used with
ClockWork, store the script into this folder. ClockWork scans this folder when the program is launched
and will add a Scripts menu to the menu bar listing the contents of the Scripts folder for easy access. If
you choose a menu item from the Scripts menu, ClockWork will execute the script. Save your scripts  as
compiled AppleScripts, so they will be recognized by ClockWork.
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Sample AppleScripts

     If you want to get started with scripting ClockWork, the Sample AppleScripts folder is a good place to
begin. It contains a number of useful AppleScripts illustrating the scripting commands. Some of them are
useful by themselves, others are intended for demonstration purposes, only. Below you will find the
names of the sample scripts and a short description. AppleScripts are similar to running “macros.”

Archive old Events

     This script cuts old events from the current document, and archives them into an archive file. This is
handy, if your document gets too large. The script remembers the archive file, and reuses it as the archive
target the next time this script is executed.

Create Some Events

     Creates new events specifying various attributes. This script demonstrates how to create events and
how to specify various options using AppleScript.

Delete Completed To-Dos

     This script deletes all To-Do items which are marked as completed.

Delete Old Events

     Deletes all events older than the current date.

Hide Completed To-Dos

    This script hides all To-Do items which are marked as completed.

PageNOW!

     Sends the selected events to a pager using the PageNOW! application. This requires the presence of the
PageNOW! application developed by Mark/Space. Check their web-site for a free demo version http://
www.markspace.com

Read ClockWork EMail

     This script notifies ClockWork, if you have received a ClockWork file as an enclosure in Claris
EMailer. Be sure to check the "Automatically decompress enclosures" in the "Incoming messages"
preferences page in Claris EMailer.

     To automatically invoke this script, place it the AppleScripts folder within the Claris EMailer folder.
Then open the Preferences dialog in Claris EMailer, choose the "New Mail Notification" page, turn on
"Run AppleScript" and select this script in the popup menu.

Send ClockWork EMail

     Sends the selected events, via email, using Claris EMailer. The events are sent both as text and in
native ClockWork format. Use the script "Read ClockWork EMail" to automatically open received
ClockWork attachments.

http://www.markspace.com
http://www.markspace.com


64

Speak Today’s Events

     Speaks aloud all events of the current day using Text-To-Speech system software.

Turn Off Old Alarms

     Turns off all alarms older than the current date and time.

ClockWork Scripting Commands

     ClockWork supports the Required Suite, Standard Suite, Mail Suite and Miscellaneous Standards as
well as the special ClockWork Suite. Use the Open Dictionary menu in the Script Editor and select
ClockWork to get a detailed description of the AppleScript commands supported by ClockWork.

More on AppleScript

     Introducing all the details of the AppleScript language is beyond the scope of this manual. If you want
to learn more about AppleScript, please refer to the AppleScript home page, at:

http://applescript.apple.com

     This web page contains a wealth of information related to AppleScript, as well as information about
other scriptable programs, tools for writing AppleScripts, sample AppleScripts, and information about
books related to AppleScript.

http://applescript.apple.com/
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Chapter 15: Reminder Control Panel
     The Reminder Control panel is installed to your System folder by the ClockWork installer. It is
responsible for displaying alarm dialog boxes, if the ClockWork application is not running. The
ClockWork Reminder control panel also inserts the global ClockWork menu into the menu bar allowing
fast access to your calendar file and today’s to-do items, and appointments, from within any program.

     To access the ClockWork Reminder control panel, open the Apple menu and choose ClockWork
Reminder from the Control Panels menu. The settings available in the ClockWork Reminder are also
available from the Alarms Preferences within the ClockWork application.

Alarms

     To disable all alarms, switch the Alarms button to Off, to enable alarms, switch to On. If alarms are
disabled, ClockWork and the ClockWork Reminder will not show alarm dialog boxes, even if an alarm is
due. Use this option to temporarily disable alarms, if you don’t want to be disturbed.

On Alarm

     On most MacOS computers, ClockWork can automatically power-on the computer, if an alarm goes
off. This way you will never miss an appointment, even if you computer is turned off. However this
option is not available on all computers and will be hidden, if your computer does not support auto-power
on (see Appendix I).

     If you want ClockWork to play a sound when displaying an alarm box, check the Play alert sound
check box. If you want ClockWork to be quiet, uncheck this box.

     When displaying an alarm box, ClockWork can automatically play voice annotations. To play voice
annotations, check the Play recorded sound check box. If you uncheck this box, ClockWork will not play
voice annotations automatically, but you will be able to start play back manually by clicking the speaker
phone icon in the alarm dialog box.

     If your computer has Text-To-Speech system software installed, you can choose to let the computer
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speak the event text aloud. Check the Speak text check box, if you want ClockWork to speak the text of
events aloud when displaying an alarm. This option is only available, if you have Text-To-Speech system
software installed.

Select calendar file

     If you want to specify which calendar file is handled by the ClockWork Reminder control panel, click
the Select calendar file button. In the dialog box that appears, locate your calendar file, and click Open.
The global ClockWork menu will now show the to-do items, and appointments, of the selected calendar
file. The ClockWork Reminder will handle alarms for this file, if the ClockWork application is not
running.

Multiple Reminders

     The current implementation of the ClockWork Reminder control panel only allows you to select a
single calendar file. However, you can duplicate the ClockWork Reminder control panel, and assign each
control panel to a different calendar file. Every Reminder will handle upcomming alarms for its attached
calendar file, and you can even have multiple global ClockWork menus. Be aware that multiple
Reminders will increase the amount of RAM required by the System.
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Appendix I - System Requirements

Hardware

     ClockWork runs on any MacOS computer equipped with a PowerPC processor. It can also be installed
on older Macintosh computers with have, as a minimum, a 68020 processor. The Auto-power-on feature is
available only on computers equipped with a Power-Management functionalitly (this includes most
PowerPC and PowerBook computers). If you are unsure what processor your MacOS computer has, then
contact either the nearest Apple dealer, or the Macintosh Catalog at:

http://www.zdnet.com/mac/catalog.html

System Software

     ClockWork works with System 7.0 or higher. It is compatible with MacOS 8.0 and supports additional
features if the MacOS 8.0 is installed. Text-To-Speech system software (part of MacOS 8) is required for
speech synthesis. Unicode synchronization with the Newton MessagePad (exchange of double-byte
characters like Japanese) is available only on PowerPC systems with MacOS 8.0. The AppleGuide Help
system, AppleScript automation, and drag-and-drop functionality is available only on System 7.5, or
higher. ClockWork supports WorldScript system software (inline input of double-byte characters) which is
available with System 7.5 Kanji, or higher.

Memory requirements

     ClockWork requires 5.4MB of free RAM (6.9MB is recommended), when running on a PowerPC
MacOS computer, with the Virtual memory turned off. If the Virtual Memory is turned on, the memory
reuirements are reduced to 2.5MB of free RAM (4MB is recommended). The ClockWork program needs
at least 3.1MB of free RAM, if running on a 680x0 Macintosh (4.5MB is recommended). The actual
requirements may vary slightly and depend on the number of events stored in your calendar file.

Newton

     ClockWork supports synchronization with the Newton MessagePad 100, 110, 120, 130, 2000, 2100
and eMate computers. It suports Newton OS (NOS) 1.0 and 2.0.

http://www.zdnet.com/mac/catalog.html
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Contacting Century Software
The best way to contact Century Software is via the Internet. Below you will find our Internet addresses
and phyiscal mail addresses.

To check for updates and the latest information about ClockWork, point your web-browser to:

http://www.centsoft.com

If you have any questions regarding ClockWork, or if you should find a bug, please contact:

support@centsoft.com

For sales-related questions, please send an EMail to:

sales@centsoft.com

Mail address:

Century Software
Friedelstrasse 8
12047 Berlin
Germany

http://www.centsoft.com/
mailto:support@centsoft.com
mailto:sales@centsoft.com
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