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Chapter 1

Introduction
OmniForm is the easy way to convert your paper forms to electronic 
forms. Use OmniForm to edit, design, and fill forms, manage 
information databases, and print or fax mail forms among other 
functions.

This chapter gives an overview of the form creation and information 
management capabilities OmniForm provides, as well as an explanation 
of how to use the documentation.

This chapter contains the following sections:

• OmniForm Features

• Using the Documentation
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OmniForm Features
OmniForm Features
OmniForm, an easy-to-use environment for working with forms, is 
more than just form-recognition software. OmniForm includes the 
following features:

Form Input

OmniForm uses Logical Form Recognition™ to convert your scanned 
paper forms or imported image files into electronic, editable forms.

Fill View

Use OmniForm’s Fill View to fill a form with the information you need. 
Information entered can easily be searched and sorted.

Design View

Use OmniForm’s Design View to design your own forms or edit existing 
forms. A variety of toolbars make formatting easy and convenient. Use 
the Scrap Album to store or copy form objects.

OmniForm Database

All information you enter into a form is stored as a part of an OmniForm 
database. You can create, duplicate, sort, and search records, and import 
and export database information. 

Field Validation

You can set up OmniForm to validate a fillable field automatically. 
OmniForm displays a prompt if you enter incorrect information.

Field Calculations

OmniForm’s built-in operators and functions let you define calculations 
that display the correct value as you fill the appropriate field(s) in a 
form. This automates data entry and reduces the possibility of errors.

Form Printing and Faxing

You can print or fax forms from OmniForm. You have a choice of 
printing or faxing just the form, just the data entered in a form, or both 
the form and its information. 
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Using the Documentation
Using the Documentation
This section explains the various instructional and formatting 
conventions used in this manual.

Online Help
OmniForm has both online help and context-sensitive help. Use the 
commands in the Help menu to find information on OmniForm topics 
and on using Help itself.

Click the Help button in the OmniForm standard toolbar to turn your 
cursor into a question mark icon. Click any command, button, or portion 
of the window to open context-sensitive help for that topic.

Formatting
Two formatting conventions are used throughout the manual.

Italicized Text 
• Labeled buttons, menu commands, dialog box text, and any text 

in an onscreen form are italicized; for example, “Choose Open in 
the File menu.”
Menu titles, icon names, dialog box names, and unlabeled 
buttons are not italicized.

• A new term may be italicized the first time it is used; for example, 
“This is a fill text field.”

• Variable entries are italicized; for example, “The entry n must be 
between 4 and 18.”

Courier font
• The Courier font indicates text that you are supposed to enter; for 

example, “Type Sample1  in the File Name text box and click OK.”

• The Courier font is also used to distinguish file locations and file 
and folder names from the rest of the text; for example, “Locate 
the Sample  form in the OmniForm  folder.”
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Using the Documentation
Symbols
Two symbols are used in this manual to highlight text.

This symbol means Note. It introduces a tip or an item of note.

This symbol means Warning. It introduces cautionary text.
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Chapter 2

Installation and Setup
This chapter describes how to install OmniForm and begin using it. It 
contains the following sections:

• System Requirements

• Registering OmniForm

• Installing OmniForm

• Starting OmniForm
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System Requirements
System Requirements
To install and run OmniForm, you need the following setup:

• Macintosh 68040 or higher processor, a Power Macintosh, or a 
Macintosh compatible of either of these versions.

• System 7.1 or higher.

• Free system memory of at least 12MB RAM.

• Minimum of 10MB of free hard disk space.

• CD-ROM drive and internal hard disk.

Additional, but optional requirements include:

• A monitor capable of displaying 256, thousands, or millions of 
colors.

• If you plan to scan forms, you need a scanner with a Pixel 
Translations ISIS scanner driver.

Registering OmniForm
Registering your copy of OmniForm entitles you to technical support, 
notification of special offers and upgrades, and the lowest price offered 
on the next OmniForm upgrade.

Please complete and send in the registration card included in your 
OmniForm package.

See “Caere Product Support” on page 10-13 for information on technical 
support.
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Installing OmniForm
Installing OmniForm
This section describes how to install OmniForm.

CD-ROM extensions must be loaded to use the CD-ROM drive.

1 With all extensions off (see the previous paragraph), insert the 
OmniForm CD in your computer’s CD-ROM drive.

2 Double-click to open the CD if it does not open automatically.

3 Double-click the Installer icon.

4 Follow installation instructions.

5 Enter the serial number found on the CD-ROM case when 
prompted.

6 Restart your computer.
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Starting OmniForm
Starting OmniForm
This section describes how to launch OmniForm. 

Before you install OmniForm, please test your scanner to make sure it is 
running correctly with your computer system using the manufacturer’s 
scanning utility or imaging software.

To start OmniForm:

1 Double-click the OmniForm icon in the OmniForm folder on 
your hard drive.
Form Assistant appears. It contains six options. Each is a basic 
OmniForm procedure.

2 Select an option and click Next>.
Click Cancel to close Form Assistant if you do not want to use 
Form Assistant and want to go directly to OmniForm.

See Chapter 5, OmniForm Procedures, for detailed information on the 
basic OmniForm procedures.
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Chapter 3

Tutorials
These tutorials guide you through some of the main features of 
OmniForm. There are four sections in this chapter:

• Tutorial 1 — Load and Fill a Form

• Tutorial 2 — Edit Text and Add a Graphic

• Tutorial 3 — Design Your Own Form

• Tutorial 4 — The OmniForm Database

Perform these exercises in order if you are new to OmniForm. Each new 
exercise builds upon skills learned in the previous one. Choose the 
tutorial you want to practice if you already know the basics of scanning, 
designing, and using forms.

The tutorials cross-reference sections in this manual for additional 
information on each subject. Read the other chapters in the manual to 
learn about OmniForm features not discussed here.
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Tutorial 1 — Load and Fill a Form
Tutorial 1 — Load and Fill a Form
You will load the Sample form in this exercise in one of three ways:

• Scan in the Sample form with a scanner if you have one. The form 
is supplied inside this manual.

• Fax the Sample form to your computer’s fax modem if you have 
no scanner, use your fax software to save it as a PICT or TIFF file, 
and open it in OmniForm. The form is inside this manual.

• Locate and open the Sample  file if you have no scanner and no 
fax modem. It was placed in your OmniForm:Sample  Forms  
folder during installation.

Decide which method you want to use. You can try all three methods 
eventually if you own both a scanner and a fax modem.

After you have loaded the form into OmniForm, you will practice 
various features of the program.

Launch OmniForm
Double-click the OmniForm icon in the OmniForm folder.
The Form Assistant dialog box appears.

If you accidentally close the Form Assistant dialog box, choose Form 
Assistant in the File menu to reopen it. 
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Tutorial 1 — Load and Fill a Form
• See the next section if you have a scanner and want to scan the 
form.

• See “Fax the Sample Form” on page 3-6 if you have a fax machine 
and a fax modem and want to fax the form to your computer.

• See “Import an Image File” on page 3-6 if you do not have a 
scanner or a fax modem, or if you want to use this method 
instead of the other two methods.

Scan the Sample Form
1 Select Scan in a form and then click Next>.

2 Select a source for the form in the next window.

3 Select Scanner and click Next>.
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Tutorial 1 — Load and Fill a Form
4 Select Letter in the next window if this option is not selected.

The Sample form is a letter-sized page.

5 Click Next>.
The next window offers two form usage options.

6 Select the second option.

You will just fill the form in this exercise, not work on its 
design.

7 Click Next>.
The next window prompts you to place a page in your scanner. 
3-4  Tutorials



Tutorial 1 — Load and Fill a Form
8 Make sure the page is aligned correctly in your scanner, and 
click Finish.
OmniForm scans the form. The OmniForm window displays 
scanning, designing, and straightening progress.

The Sample form opens as Untitled 1  in Fill View. It should 
look the same as the original copy of the form.

9 Click the Save button or choose Save in the File menu.
The Save As dialog box appears.

10 Type Sample  1 in the Save document as text box and click Save.

Proceed to the section “Filling in the Form” on page 3-10 to begin 
using OmniForm’s tools.
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Tutorial 1 — Load and Fill a Form
Fax the Sample Form
To fax the Sample form, you need the following:

• a fax modem connected to your computer

• fax software that is compatible with your fax modem

• access to a regular fax machine

To fax the form:

1 Make sure your fax modem is turned on and that your fax 
software is set up to receive a call.
Refer to your fax documentation for information.

2 Place the Sample form in the fax machine.

3 Set faxing resolution to Fine or Best.
OmniForm may have trouble recognizing documents faxed at a 
lower resolution. Check your fax machine’s manual if you need 
more information about its settings.

4 Dial your fax modem’s number and fax the Sample form as you 
normally would.

5 Once received, use your fax software to open the Sample form 
and save it as a PICT or TIFF file.
Again, refer to your fax software manual if you do not know 
how to do this.

6 See the next section, “Import an Image File” for instructions on 
how to convert your fax file into an electronic form in 
OmniForm.

Import an Image File
OmniForm can recognize PICT or TIFF image files. An image is an 
electronic picture of text and/or graphics. This could be a form created 
in another program or one received as a fax file. See the previous section, 
“Fax the Sample Form” if you want to create a fax file to import.

You will import an image file in this exercise. You can import a fax file 
if you have one, or import the Sample  form that was placed in your 
OmniForm:Sample  Forms  folder during installation.
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Tutorial 1 — Load and Fill a Form
Load the Image File in OmniForm

1 Select Scan in a form in Form Assistant and then click Next>.

2 Select Fax or Image in the next window and then click Next>.

3 Click Select... in the next window.

The Select dialog box appears.
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Tutorial 1 — Load and Fill a Form
• Select TIFF Files in the List Files of type pop-up menu if you 
want to import the Sample  file. Locate and select the Sample  
file in the OmniForm:Sample  Forms  folder.

• Locate and select your fax file if you created one in the 
previous exercise.

• Click Open to return to Form Assistant.
The file name appears in the File text box.

4 Click Next>.
The next window offers two form usage options.

5 Select the second option.

You will just fill the form in this exercise, not work on its 
design.
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Tutorial 1 — Load and Fill a Form
6 Click Finish>.
The OmniForm window displays scanning, designing, and 
straightening progress.

The Sample form opens as Untitled  1 in Fill View.

7 Click the Save button or choose Save in the File menu.
The Save As dialog box appears.

8 Type Sample  1 in the Save document as text box and click Save.

The next section shows you how to begin using OmniForm’s tools.
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Tutorial 1 — Load and Fill a Form
Filling in the Form
The Sample  1 form opens in Fill View.

Fill View Overview

The standard toolbar appears below the menus. The buttons correspond 
to various menu commands.

1 Place your cursor over one of the buttons and hold it there 
without clicking.
A ToolTip describes the button’s function.

Corresponding status text simultaneously appears in the status 
bar at the bottom of the window.

Standard toolbar 
in Fill View

Status text

Hold the cursor over any 
button in the toolbar to 
see its function.
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Tutorial 1 — Load and Fill a Form
2 Click the Highlight button in the toolbar or choose Highlight Fill 
Areas in the View menu to turn off field highlighting.
OmniForm highlights all recognized fields in yellow. This 
makes it easy to see which fields you can fill.

3 Click the button again to turn field highlighting back on.

4 Click the Zoom button and select a page view in the pop-up 
menu.
Alternatively, choose Zoom in the View menu and select a view 
in the cascading menu.

Fill in the Fields

1 Click the field after Name on the form or press the Tab key to 
place the cursor there.
This is a fill text field. The word Name on the form is text.

2 Type your name in the fill text field.

3 Continue to press the Tab key to move to and fill in the Address, 
City, and State fields (or click to place the cursor there).
You can press Shift-Tab to move to a previous field.

4 Tab to or click in the Zip Code field.
This is a comb field. This is a field that is subdivided into comb 
elements. The next fields, Phone Number and Fax Number, are 
also comb fields.

5 Type five numbers in the Zip Code field.
You do not have to click in each box in the field. OmniForm 
moves the cursor automatically for you. 

6 Tab to or click in the Phone Number comb field and type a phone 
number.
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Tutorial 1 — Load and Fill a Form
7 Fill in the Fax Number comb field.
The next item is a table. A table contains cells and each cell 
contains a field. The cells in the table are all fill text fields. The 
headers in the table are text and cannot be changed in Fill View.

• Click in the field under Description and type some text.

• Press the Tab key to move to the field under Quantity and type 
a number.

• Press the Tab key to move to the field under Cost and type 
another number.

8 Move down the page and click in the square next to the words 
Check here to receive our next magazine.

An “X” appears in the box. This is a check box field.

9 Click the word Yes next to the words Would you like to receive 
more information?
Nothing happens. This should be a circle text field but there was 
no circle on the form to indicate this to OmniForm during form 
recognition.

OmniForm provides tools to compensate for missing information on 
forms. The next section describes how to create the circle text field.
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Tutorial 1 — Load and Fill a Form
Design View
There are two views in OmniForm: Fill View and Design View. You fill 
in fields in Fill View. In Design View, you can create and format objects 
(these become fields in Fill View) and add graphics to a form, among 
other functions. 

Click the Design button in the standard toolbar or choose Design in the 
View menu.

As a handy shortcut, Control-click to open a shortcut menu. Choose 
Design in this menu.

OmniForm switches to Design View. Any text you entered in Fill View 
disappears in Design View. It still exists in Fill View.

Standard toolbar

Drawing toolbar

Font/text toolbar Arrange toolbar

Status bar: displays current 
activity and settings.
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Tutorial 1 — Load and Fill a Form
Create a Circle Text Field

1 Click the Circle Text tool in the drawing toolbar.

2 Draw a circle (or oval) around the word Yes next to the words 
Would you like to receive more information?

You will select this circle later in Fill View. 

Return to Fill View

1 Click the Fill button in the standard toolbar to return to Fill 
View.
The text in fill fields is now bold and the number in the table’s 
Cost cell is right-aligned.

2 Click the word Yes next to the words Would you like to receive 
more information?
This time, a circle appears around the word Yes.

You will practice more advanced form editing and design in the next 
tutorial.
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Tutorial 2 — Edit Text and Add a Graphic
You will scan or import the Sample form into OmniForm again in this 
exercise. You will verify and correct OCR, and add a graphic to the form.

Scan or Import the Sample Form
See page 3-16 instructions on importing the Sample  file instead of 
scanning it.

To scan the form:

1 Click the Scan Form button in the standard toolbar or choose 
Scan Form... in the File menu.
The Scan Form dialog box appears.

2 Select Scanner in the Source pop-up menu.

3 Select Auto Form Design to use Logical Form Recognition to 
recognize text and fillable fields in the form.

4 Click OK.
OmniForm scans the form, recognizes both text and fields, and 
opens it in Design View.

5 Click the Save button or choose Save in the File menu.
The Save As dialog box appears.

6 Type Sample  2 in the Save document as text box and click Save.

Proceed to the section “Verifying OCR” on page 3-17.
Tutorials  3-15



Tutorial 2 — Edit Text and Add a Graphic
To import the form as an image file:

1 Click the Scan Form button in the standard toolbar or choose 
Scan Form... in the File menu.
The Scan Form dialog box appears.

2 Select Image File(s) in the Source pop-up menu.

3 Click Select Files....

• Locate the Sample  file in the OmniForm:Sample  Forms  
folder.

• Select the file and click Add>> to place it in the Selected Files 
list.

• Click Done to return to the Scan Form dialog box.

4 Click OK in the Scan Form dialog box.

5 OmniForm loads the form, recognizes both text and fields, and 
opens it in Design View.

6 Click the Save button or choose Save in the File menu.
The Save As dialog box appears.

7 Type Sample  2 in the Save document as text box and click OK.

The next section explains how to use some of the design tools.
3-16  Tutorials



Tutorial 2 — Edit Text and Add a Graphic
Verifying OCR
In this exercise, you will verify and correct OCR as necessary and copy 
a graphic to the new form.

Edit the Text

OCR is not always perfect. Text that is very small, very light or broken, 
or difficult to read in any other way can cause recognition problems. 
This is easily corrected in OmniForm.

1 Choose Form Image in the View menu.
The screen splits to show the form both as it was designed with 
OCR and as it was scanned originally.

2 Compare the recognized text in the top view with the original 
text in the bottom view.
Each view window has its own scroll bar so you can scroll to 
the same portion of each form. Click a window to make it 
active. Use the horizontal bar in-between the two windows to 
resize the view. Your cursor turns into a resize cursor over the 
bar.

3 Use the Zoom button’s pop-up menu to zoom your page view 
in and out.

4 If you find text in the top window that does not match text in 
the bottom window:

Recognized, editable form

Original scanned image of 
the form before OCR

Horizontal bar
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• Click the Selection tool in the drawing toolbar if it is not 
selected already.

• Click any text object with erroneous text in the top window to 
select it.
Your cursor turns into an I-beam when it is positioned over 
the editable area.

• Use the cursor to select the portion of the text that does not 
match the original.

• Retype the highlighted portion of the text so that it matches 
the original.

5 Correct any text as needed this way.
Your text may not need editing, but you can practice selecting 
and changing text if you like.

6 Click the Save button or choose Save in the File menu to save 
your changes.

Copy the Arrow Graphic

1 Scroll to the arrow at the bottom of the page in the bottom 
window and to where it should be in the top window.
Because graphics are not retained during Logical Form 
Recognition, the arrow does not appear in the top window.

2 Click the Graphic tool in the drawing toolbar.
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3 To draw a box around the arrow, draw a box in the top window, 
using the bottom window as a guide. 

4 With the new object still selected, click the Object Definition 
button in the standard toolbar or choose Object Definition... in 
the Format menu. 
The Graphic Definition dialog box appears.

5 Select Form Image in the Source pop-up menu.

6 Click OK.

Graphic box where 
arrow will be placed

Arrow in original form
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The arrow appears in the top window.

7 Choose Form Image in the View menu to close the bottom 
window.
Alternatively, double-click the horizontal bar or drag it all the 
way to the top or bottom of the Form window.

You will learn more advanced design techniques by designing your own 
form in the next tutorial.
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Tutorial 3 — Design Your Own Form
The previous two tutorials introduced you to the concepts of loading, 
filling in, and modifying a form. In this tutorial, you will create the 
personal job-tracking form shown below for a hypothetical free-lance 
editor/writer.

See Chapter 6, Designing a Form, for detailed information on form 
design.
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Pre-Organization
It is a good idea to draw a rough draft of a form before you begin to 
design it, complete with all fields and graphic elements. This makes the 
design process go faster and you will be less likely to have to go back 
and redo portions of the form. In this tutorial, the form pictured on the 
previous page can serve as your rough draft.

You do not have to design the form exactly as it is pictured. Learn the 
form-design concepts presented here and arrange the form as you 
please. Use your own graphic files if you have any.

Open a New, Blank Form
1 Launch OmniForm if you closed it after the last tutorial. Click 

Cancel in Form Assistant if it opens.

2 Click the New button in the standard toolbar or choose New in 
the File menu.
A blank form appears.

3 Choose Page Setup... in the File menu.
The Page Setup dialog box appears.

4 Set page setup options as shown in the picture below and then 
click OK.

5 Click the Zoom button in the standard toolbar or choose Zoom 
in the View menu to select the view size you want.

6 Choose Save in the File menu and save your form as an 
OmniForm Form with the name Job  Tracking .

7 Make sure the Highlight button in the standard toolbar is 
selected so that fill objects show up in yellow.
This makes it easier to see size and position while designing.
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Create the Text Objects
1 Click the Text tool in the drawing toolbar.

You need text objects named Customer: , Contact: , 
Address: , City: , State: , Zip: , Job Type , Editing , 
Tech Writing , Marketing Writing , Advertising 
Copy, Rate: , Expenses: , Profit: , and Comments: .

2 Create the text objects in one of three ways:

• Click the Lock tool in the drawing toolbar to keep the Text tool 
selected.
Draw a text object, type its name while it is still selected, then 
draw the next one, and so on. Click the Lock tool to deselect it 
when you are done.

• Draw a text object. 
With the object still selected, choose Copy and then Paste in the 
Edit menu. Keep choosing Paste until you have created as 
many text objects as you need. Select each object one at a time 
and type its name.

• Draw a text object.
With the object still selected, hold down the Option key and 
drag to create a copy. Repeat this for each new text object you 
need. Select each object one at a time and type its name.

3 Line the text objects up approximately where you see them on 
the form on page 3-21.

Create the Fill Text Objects

Customer Information

1 Click the Fill Text tool in the drawing toolbar.

2 Draw five fill text objects as described in step 2 in the previous 
section.

3 Resize the objects as necessary.
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4 Line the fill text objects up with the Customer, Contact, Address, 
City, and State text objects.

5 Select the Customer fill text object.

6 Click the Object Definition button in the standard toolbar or 
choose Object Definition... in the Format menu.
The Fill Text Definition dialog box appears.

• Type Customer  in the Name text box.

• Select Name in the Type pop-up menu.

7 Click OK.

8 Define the other fill text objects in the same way, choosing the 
appropriate selection in the Type pop-up menu for each. (Select 
Name in the Type pop-up menu for the Contact fill text object.)
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Fill Lines

1 Draw a large fill text object.

2 Drag it beneath the text object Comments.

3 With the object still selected, click the Top Alignment button in 
the font/text toolbar.

4 With the object still selected, click the Left Alignment button in 
the font/text toolbar.
Text entered in Fill View will align to the left and top of the 
field in Fill View.

5 While the object is still selected, click the Object Appearance 
button in the standard toolbar or choose Object Appearance... in 
the Format menu.
The Object Appearance dialog box appears.

• Click the Border tab.
Click the bottom line in the Borders square to delete it.

• Click the Fill Line tab.
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Select Black, a solid line, and 1/4 pt in the pop-up menus, and 
deselect Clear as pictured below.

6 Click OK.
The bottom border disappears from the selected object and fill 
lines appear to show where lines of text will flow.

7 With the object still selected, click the Object Definition button 
in the standard toolbar to open the Fill Text Definition dialog 
box.

• Type Comments in the Name text box.

• Select General in the Type pop-up menu (entries in this field 
could consist of numbers, symbols, and letters).

8 Click OK.
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Create the Comb Objects
You will draw a simple comb object for the zip code and use the Scrap 
Album to copy phone and fax numbers.

Zip Code Comb Object

1 Click the Comb tool in the drawing toolbar.

2 Draw a comb object.

3 With the object still selected, click the Object Definition button 
or choose Object Definition... in the Format menu.
The Comb Definition dialog box appears.

4 Click the Properties tab.
Type Zip  Code in the Name text box.
Select Zip Code in the Type pop-up menu.
Type 5 in the Number of Elements text box.
Type 0.2  in the Width of Elements text box.

5 Click OK.

6 Drag the Zip comb object next to the Zip text object.
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Phone and Fax Number Comb Objects

1 Choose Scrap Album in the Tools menu.
The Scrap Album opens. It contains scraps, copies of OmniForm 
components/objects. Four Scrap Albums were included in 
your OmniForm program, each with a different collection of 
scraps.

2 Select Special Fields in the Scrap Album pop-up menu.

3 Locate the Phone Number scrap in the Scrap Album.

4 Select the scrap and drag it into the form below the City objects.

5 Locate the Fax Number scrap in the Scrap Album.

6 Select the scrap and drag it into the form below the Phone objects.

This exercise illustrates how you can save time by using objects stored 
in the Scrap Album. See “Using the Scrap Album” on page 6-44 to learn 
more about creating, storing, and copying scraps and Scrap Album.
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Your form-in-progress should look similar to this at this point:

Create the Check Box Objects
1 Click the Check Box tool in the drawing toolbar.

2 Draw a check box.
Hold down the Shift key to constrain the shape to a square.

3 With the object still selected, choose Copy and then Paste in the 
Edit menu.

4 Choose Paste two more times.
You now have four check boxes of equal size.
The user of this form wants to be able to select only one check 
box at a time so that each copy of the form records just one job. 
To do so, you must create an option group.

5 Shift-click or drag the cursor around all four check box objects 
to select them.
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6 With the objects still selected, click the Object Definition button 
in the standard toolbar or choose Object Definition... in the 
Format menu.
The Check Box Definition dialog box appears.

7 Type job  type  in the Option Group pop-up menu box.

8 Click OK.

9 Click Yes in the dialog box that asks if you want OmniForm to 
create unique On-Values for you.
Now you will be able to select only one check box at a time in 
Fill ViewFill View. See “Defining a Check Box Object” on page 
6-24 for detailed information on Option Groups.
You can define each check box individually if you like as well 
to give it a unique name.

10 Drag the check boxes in front of the Editing, Tech Writing, 
Marketing Writing, and Advertising Copy text objects under Job 
Type.
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Create the Table Object

Create the Table

1 Click the Table tool in the drawing toolbar.

2 Draw a table.

3 With the table still selected, click the Object Definition button 
or choose Object Definition... in the Format menu.
The Table Definition dialog box appears.

• Type Task List  in the Name text box.

• Type 2 in the Number of Columns text box.

• Type 2.5  in the Width of Columns text box.

• Type 10  in the Number of Rows text box.

• Type 0.25  in the Height of Rows text box.

4 Click OK.

5 With the table still selected, click the Object Appearance button 
or choose Object Appearance... in the Format menu.
The Object Appearance dialog box appears.

6 Click the Background tab and select Clear.

7 Click the Border tab.
A one-point black border is selected by default. Just for looks, 
add a shadow effect to the border:

• Select Lower Right in the Location pop-up menu.
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• Select 3 pt in the Offset pop-up menu.
This moves the shadow three points to the right and bottom of 
the border.

8 Click OK.
A shadow appears behind the table.

Use Table AutoFormat

1 With the table still selected, choose Table AutoFormat... in the 
Format menu.
The Table AutoFormat dialog box appears.

2 Select the Yes option in the window to enable the Appearance list 
box.

3 Select Columns (Reverse Header).

The picture on the left shows how the selected option affects 
your table.

4 Click Next>.

5 Select the Yes option in the next window to enable the Field 
Names text box.

6 Select the first word Label and click Rename. 
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7 Type Task .
All fill text fields within cells in this column are automatically 
renamed Task1, Task2, and so forth.
(You can verify this by selecting a cell and opening the Object 
Definition dialog box.)

8 Repeat for the second word but change its name to 
Completed .
All fill text fields within the cells in this column are 
automatically renamed Completed1, Completed2, and so forth.

9 Make sure Change Header to Match Field Names is selected.
This changes the column names from Label to Task and 
Completed.

10 Click Finish.

Format the Table Cells

1 Place your cursor outside the left edge of the table, hold down 
the mouse button and drag your cursor through the nine rows 
in the left column but not the Task row.

Just the nine rows on the left should be selected. Shift-click to 
select or deselect rows as necessary.

2 Choose Text... in the Format menu.
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The Text dialog box appears.

• Click the Margins tab and type the measurements 0.04, 
0.04,  0.02,  and 0 as pictured above.
This offsets your text from the border around each row, 
making it easier to read.

• Click the Alignment tab and select Left and Bottom.
Text entered in Fill View will align to the left and bottom of 
the cell.

3 Click OK.

4 Repeat steps 2–3 for the Completed column but select Right and 
Bottom for the alignment in the Text dialog box.

5 With the right column still selected, click the Object Definition 
button or choose Object Definition... in the Format menu.
The Fill Text Definition dialog box appears.

• Select Date in the Type pop-up menu.
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• Select the desired date format in the Format pop-up menu.

6 Click OK.
Numbers entered in this row will be formatted as right-aligned 
dates in the format you chose.

7 Drag the table above the Comments text object to the middle of 
the form.
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Create the Graphic Objects
You will create both a graphic object and a fill graphic object. You can 
import a graphic into a graphic object in Design View. You can import a 
graphic into a fill graphic field in Fill View.

Fill Graphic Object

1 Click the fill graphic tool in the drawing toolbar.
It is the second-to-last button.

2 Draw a box in the upper right corner of the form.
You will import a graphic into this field in Fill View later in the 
tutorial.

Graphic Object

1 Click the graphic tool in the drawing toolbar.
It is below the Rectangle tool.

2 Draw a box in the lower right corner of the form.

3 With the object still selected, click the Object Definition button 
or choose Object Definition... in the Format menu.
The Graphic Definition dialog box appears.

• Click Select to open the Select dialog box.

• Locate the Logo  file in the OmniForm:Sample  Forms  folder 
and click Open.

• Select Scale Proportionally in the Options pop-up menu.

4 Click OK.
The graphic is imported into the object you drew and scaled to 
fit in the box while maintaining its original proportions. You 
could place your own graphic or logo in this object instead.
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Define the Calculations
The final objects on this form are fill text objects that have calculations 
defined on them. In Fill View, these fields become part of a calculation 
that determines the profit this user makes on each job after expenses. 
These calculations are very simple but you have the ability to create 
much more complex ones. See Chapter 9, Using Calculations, for 
detailed information.

Create and Define the Fill Text Objects

1 Click the Fill Text tool.

2 Draw a fill text object anywhere on the page.

3 With the object still selected, click the Object Definition button 
or choose Object Definition... in the Format menu.
The Fill Text Definition dialog box appears.

• Type Rate  in the Name text box.

• Select Currency in the Type pop-up menu.

• Select $0.00 in the Format pop-up menu.

• Select Use 1000’s Separator and Enclose Negatives in Parentheses.

4 Click OK.
Numbers entered in the Rate fill text field will use the currency 
symbol and number format appropriate to the current form 
language ($3,000,000 for U.S. English for example). Negative 
numbers will appear within parentheses: ($3,000,000).
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5 With the Rate object still selected, choose Copy and then Paste in 
the Edit menu.

6 Choose Paste twice more.

7 Use the Object Definition command to name the objects: 
Earnings, Expenses, and Profit.
Because you copied and pasted the objects, the other settings 
are exactly the same as for the Rate object.

8 Draw another Fill Text object and use the Object Definition 
command to define it as pictured below:

9 Click OK.

Create the Text Objects

1 Click the Text tool.

2 Draw an object and type an x .

3 Draw another object and type an equal sign(=).
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4 Drag the objects so they are lined up approximately as shown:

Set Up Calculations

Calculate Earnings

Earnings, on this form, equals the hourly rate (Rate field) times the 
number of hours (Hours field) spent on the job.

1 Select the Earnings fill text object.

2 Click the Calculation button in the standard toolbar or choose 
Calculation... in the Tools menu.
The calculation toolbar appears at the top of the window below 
the font/text toolbar.

3 Click the Calculation Builder button in the calculation toolbar.
The Calculation Builder dialog box appears.

Rate field Hours field Earnings field

Expenses field

Profit field

Click to Edit Calculation — the calculation 
for the field appears in the text box.

Accept 
Calculation

Cancel 
Calculation

Calculation 
Builder

Auto 
Calculation
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4 Locate Rate in the Fields list box.

5 Double-click Rate or select it and click Paste.
The field name appears in the calculation toolbar.

6 Click the Multiplication (* ) button in the Calculation Builder 
dialog box.
It appears after [Rate] in the calculation toolbar.

7 Locate and double-click Hours in the Fields list box.
The calculation in the calculation text box should now read:
[Rate]*[Hours]

Click the Cancel Calculation button in the calculation toolbar if you 
make an error to clear the text box and start again.

8 Click the Accept Calculation button in the calculation toolbar to 
define the calculation on the Earnings field.
The Calculation Builder dialog box closes.

Calculate Profit

Profit, on this form, equals the Earnings minus Expenses. You will create 
this calculation manually instead of using the Calculation Builder dialog 
box so you can see another feature of OmniForm.

1 Select the Profit fill text object.

2 Click in the calculation toolbar’s text box to activate the toolbar.

3 Click the Earnings fill text object in the form.
The field name appears in the calculation toolbar.

4 Click in the calculation text box after [Earnings] and type a 
subtraction (- ) sign.

5 Click the Expenses fill text object in the form.
The calculation in the calculation text box should now read:
[Earnings]-[Expenses]

6 Click the Accept Calculation button in the calculation toolbar to 
define the calculation on the Profit field.

7 Click the Calculation button in the standard toolbar or choose 
Calculation... in the Tools menu to close the calculation toolbar.
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Customize the Form

Format Objects

As a general rule, forms are easier to read if you use the same font format 
for all the text objects. Point size and style can be varied according to 
what you decide looks best and is most logical for the form you create.

On the form shown on page 3-21, all text objects are 9-point Arial bold 
with the exception of the text objects under Job Type. These four objects 
are entries under a header and it could be confusing if they had the same 
formatting as the header.

See “Formatting Text” on page 6-35 for detailed information on 
changing text and font attributes.

Align the Objects

Use the Align commands in the Format menu or the Arrange toolbar to 
line up selected objects left, right, center, and so forth.

Use the Snap to Grid command in the Tools menu to line fields up 
precisely along a grid. Choose Grid Settings... in the Tools menu to set the 
size of the grid. Turn this command off if you do not want fields 
snapping to a grid.

Selecting Objects

There are several ways to select multiple objects.

• The Select Special... command in the Edit menu lets you select all 
objects of a certain type at the same time. This way, you can apply 
the same formatting to all selected objects instead of one by one.

• Shift-click to select multiple objects.

• Hold down the mouse button and drag the cursor around all 
objects to select.
An object only has to be touching the selection area to be selected. 
Remember to fully enclose table and comb objects unless you 
want individual elements and cells selected.
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Use the Drawing Tools

You can use the Line, Oval, and Rectangle tools in the drawing toolbar 
to customize your form.

To draw the rounded border around the outside of the form:

1 Click the Rectangle tool.

2 Draw a border around the outside edge of the form.

3 With the border still selected, click the Object Appearance 
button or choose Object Appearance... in the Format menu.
The Object Appearance dialog box appears.

• Click the Background tab and select Clear.

• Click the Border tab and select the settings shown below.

4 Click OK.

See page 3-21 again for the completed form. Your final form should look 
similar to this depending on how you chose to customize it. Your form 
will not as yet have the arrow in the upper right corner. That is added in 
Fill View.
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Tab Order

You can tab from field to field in Fill View. This is faster than moving the 
cursor to each field. When tabbing, OmniForm moves the cursor 
through the fields in the order in which they were created. This may not 
be the order you want. 

To change tab order:

1 Click the Tab Order button in the standard toolbar or choose 
Tab Order... in the Tools menu.
The Tab Order window appears, and numbers appear by each 
field on the form.
Both indicate current tab order.

In the example above, the user wants the check box fields to be 
before the Rate field because that is the order of the fields on the 
form. Your Tab Order dialog box will not necessarily look the 
same as this one.

2 Select the field to reorder.
Note that the corresponding field on the form highlights.

3 Reorder the field in one of the following ways:

• Drag the field up or down in the dialog box to reorder it.

• Click the Move Up button to move the field up. Click as many 
times as needed to move it into place.

• Click the Move Down button to move the field down. Click as 
many times as needed to move it into place.
Tutorials  3-43



Tutorial 3 — Design Your Own Form
• Click Auto Order to have OmniForm order the fields for you.
The tab order numbers on the form change correspondingly 
when you reorder a field in the Tab Order dialog box.

4 Repeat for each field you want to reorder.

5 Click the Tab Order button in the standard toolbar or choose 
Tab Order... in the Tools menu to close the Tab Order window.

Test the Form in Fill View
1 Click the Fill button or choose Fill in the View menu.

2 Click the fill graphic field in the upper right corner of the form.
The Fill Graphic dialog box appears.

• Select Graphic File in the Source pop-up menu.

• Click Select to open the Select dialog box.

• Locate the ArrowR  file in the OmniForm:Sample  Forms 
folder.

• Click Open to return to the Fill Graphic dialog box.

• Select Stretch to Fit in the Options pop-up menu.

3 Click OK.
The graphic is imported into the field you drew and stretched 
to fill the entire box. Click in the field again if you want to 
change the graphic’s appearance or import a new graphic.

4 Tab from field to field to test tab order.
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5 Enter text in the fill text fields to see your formatting and to 
make sure the fields are large enough for text entered.

6 Select a check box under Job Type.

7 Click another check box to deselect the first.

8 Enter text in the table cells.

• Verify that text is not flush against a border, making it hard to 
read. 

• Verify that text in the left column is left-aligned and text in the 
right column is right-aligned.

• Enter dates in the right column in any format and note that 
they are converted to the format you chose when you defined 
the fields. The conversion takes place after you move the 
cursor from the field.

9 Verify that comb field elements contain the right amount of 
numbers.

10 Enter numbers in the calculation fields.
The Expenses and Profit fields should fill automatically and 
correctly as you fill in the other fields involved in the 
calculation.

Return to Design View to make any changes you need. Save this form. 
You will use it in the next tutorial.
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Tutorial 4 — The OmniForm Database
This tutorial is a brief introduction to the OmniForm database. A 
database is a collection of information stored as individual records. 

Each record uses the same form design but can contain different 
information in its fields. OmniForm automatically creates a database 
when you scan in or import a form.

In the previous tutorial, for example, you created the Job  Tracking  
form. As soon as you fill in the form, it becomes the first record in the 
new database. The user of this database creates a new record for each job 
completed, making it possible to store and find a large amount of similar 
information.

See Chapter 8, Managing an OmniForm Database, for detailed 
information, including working with records and importing and 
exporting databases.

This tutorial shows you how to create new records, search for specific 
information in a database, sort records, and delete records. You will use 
the job-tracking form you created in the last tutorial.

Duplicating a Database Record
The hypothetical user of this job-tracking database uses the same form 
design to enter different information in new records. You can add a new, 
empty record to this database and fill in the form each time, or you can 
duplicate an existing record that has similar information when you need 
to add a new record. This way you do not have to fill in the whole record 
— just change one or more fields.
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To duplicate a record:

1 Locate and open the Job Tracking  form you created in the 
previous tutorial.

2 Enter the customer information shown below.

Suppose you did another job for this company but this time 
instead of editing it was marketing writing. You do not have to 
retype all the same information for just one change.

3 Choose Duplicate Record in the Records menu.

4 Click OK in the dialog box that informs you that a record has 
been added to the set.
Another record for Franich & Halsey is added to the set and 
OmniForm moves to the new record. 

5 Select the Marketing Writing check box.
The Editing check box is deselected.

Creating New Records
Suppose after this job you complete two more jobs and need to add two 
more records to the database.

To create new records:

1 Click the New Record button or choose Go To in the Records 
menu and New in its cascading menu.
OmniForm creates a new, empty record.

2 Type The  Borne  Corporation  in the Customer fill text field.
Fill in other information if you like.

3 Click the New Record button again.
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4 Type Zimmer  DTP in the Customer fill text field in the new 
record.
Fill in other information if you like.

5 Use the Record buttons in the toolbar to scroll through your 
records.

Search the Database Records
It is not hard to find information when you only have a few records, but 
depending on your database, you may have thousands. OmniForm 
makes it easy to find the information you need quickly.

To search records:

1 Choose Search... in the Records menu.
The Search dialog box appears.

• Select Customer in the Field Name pop-up menu.

• Select is equal to in the Condition pop-up menu.

• Type Franich  & Halsey  in the Value text box.

This dialog box illustrates why it is important to give fields a unique 
name after you create them. If you had not named the Customer 
field, it would appear simply as FillTextn (where n is a number) 
making it difficult to decide what to choose.

First 
Record

Previous 
Record

Next 
Record

Record 
Number

Last
Record

The field to search
How to search

What to search for

Which records to search
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2 Click OK.

3 OmniForm searches the database and retrieves the two records 
that match the search criteria. This is called the found set.
Status text just below the toolbar shows the search results 
information.

You can narrow a search further by searching a found set for 
more specific information. For example, you might want to find 
only editing jobs you had done for Franich & Halsey. You 
would enter the appropriate information in the Search dialog 
box and select Only Search Current Record Set. This is useful 
when you have a large found set.

4 Click the Clear Search button below the toolbar to return to the 
full database set.

Sort the Database Records
You may need to sort your database records in some logical order, for 
example, alphabetically by customer name as you will in this exercise. 

To sort records:

1 Choose Sort... in the Records menu.
The Sort dialog box appears.

• Select Customer in the Field Name pop-up menu.

• Select Ascending Order (A-Z; descending order would be Z-A).

2 Click OK.
OmniForm examines the Customer field in each record and 
sorts the records alphabetically: the two Franich & Halsey 
records are numbers 1 and 2, The Borne Corporation is number 
3, and Zimmer DTP is number 4.
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3 Click OK in the dialog box that tells you how many records 
were sorted.

You could also sort a subset of retrieved search records. You might, for 
example, find all a certain customer’s records and then sort those 
records by date or any other way you choose.

Database Changes
You have changed individual records in Fill View in this tutorial. 
Changes to one record did not affect changes to another record. 
However, changes in Design View do affect your records.

To make a change in Design View:

1 Click the Design button or choose Design in the View menu.

2 Delete the graphic object in the lower right corner.
3 Click the Fill button or choose Fill in the View menu.

4 Click the appropriate Records button to view each record.
The logo is now missing from every record.

Any change made in Design View affects all the records in that 
particular database. This is important to remember, especially if you 
have more than one user of your database.

You can protect your database from unauthorized changes in several 
ways:

• In Design View, choose Protection... in the Tools menu to open the 
Protection dialog box.
Select Protect Data to make all information read-only. No changes 
can be made in Fill View to any of the records. This also prevents 
users from duplicating or deleting records.
Select Protect Form if you do not want anyone to be able to change 
a form in Design View. Remember, deleting a fill field in Design 
View also deletes all the information that was entered in that field 
in Fill View.

• Have other users use the program OmniForm Filler to open the 
database. This is a version of OmniForm that has only a Fill View. 
Users cannot change the form’s design.
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Deleting Records
You may want to delete an old or obsolete record.

To delete a record:

1 Return to Fill view if you are not in it already.

2 Choose Delete Record in the Records menu.

3 Click Yes in the warning dialog box that appears.
The record you are viewing is deleted permanently from the 
database.

Use the command Delete All Records to permanently destroy all database 
records. You can also use the command to delete a subset of retrieved 
search records.

Suppose, for example, you have 14 entries for PatEl Corporation in your 
customer update database. Then they go out of business and you decide 
you no longer need the information because it just takes up disk space.

You would search for PatEl Corporation in the relevant field, and then 
choose Delete All Records in the Records menu. All PatEl Corporation 
entries would be permanently deleted but the other records would be 
safe.

You cannot undo the Delete Record command!
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Chapter 4

Views and Form Usage
This chapter describes basic OmniForm concepts you should know 
before scanning, importing, or designing a new form.

It contains the following sections:

• Using Form Assistant

• The Design View Window

• The Fill View Window

• Form Usage Options

Proceed to Chapter 5, OmniForm Procedures, if you want to begin 
working with forms immediately.
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Using Form Assistant
This section describes Form Assistant and its basic OmniForm functions.

Form Assistant is a dialog box that appears the first time you launch 
OmniForm. Form Assistant makes decision-making easy when 
processing a form.

This section contains the following topics:

• Opening Form Assistant

• The Form Assistant Options

• Setting the Form Assistant Startup Option

Opening Form Assistant
There are several ways to open Form Assistant.

• Form Assistant opens automatically the first time you launch 
OmniForm.

• Click the Form Assistant button in the standard toolbar at the top 
of the window if OmniForm is open.

• Choose Form Assistant... in the File menu if OmniForm is open.

Form Assistant contains six options for basic OmniForm procedures as 
described in the next section.
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The Form Assistant Options
This section gives a brief description of each option in Form Assistant. A 
cross-reference after each description points you to step-by-step 
instructions for the procedure.

Scan in a form

Select Scan in a form to scan a paper form or import an image file and to 
determine how you will work with the form in OmniForm. See 
“Scanning a Paper Form” on page 5-2 or “Importing an Image File” on 
page 5-8 for instructions.

Fill in a form

Select Fill in a form to fill the currently open form or to open a form and 
fill it. See “Filling a Form” on page 5-13 for instructions.

Print or fax a form

Select Print or fax a form to print or fax the currently open form or to open 
a form and print or fax it. See “Printing or Faxing a Form” on page 5-14 
for instructions.

Search a form for information

Select Search a form for information to search the currently open form for 
information or to open a form and search it. See “Searching a Form” on 
page 5-17 for instructions.

Work on a form’s design

Select Work on a form’s design to redesign the currently open form or to 
open a form in Design View. See “Opening a Form to Design” on page 
5-19 for instructions.

Create a new, blank form

Select Create a new, blank form to open a blank page in Design View. See 
“Creating a New Form” on page 5-20 for instructions.

Show Form Assistant at Startup
• Select the Show Form Assistant at Startup option if you want 

Form Assistant to appear at startup.
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Setting the Form Assistant Startup Option
You can enable or disable Form Assistant at startup. To do so:

1 Choose Preferences... in the Tools menu. A form must e open for 
this menu to be active. The Preferences dialog box appears.

2 Deselect the Show Form Assistant at Startup option if you do not 
want Form Assistant to appear at startup. OmniForm will open 
a blank form instead the next time you launch it. Select the 
Show Form Assistant at Startup option if you want Form 
Assistant to appear at startup.

3 Click OK.

In the Form Assistant dialog box, deselect the Show Form Assistant at 
Startup option if you do not want Form Assistant to appear at startup. 
OmniForm will open a blank form instead the next time you launch it.

Select the Show Form Assistant at Startup option if you want Form 
Assistant to appear at startup.
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The Design View Window
This section provides an overview of the Design View window.

If a form is open in Fill View, click the Design button in the standard 
toolbar or choose Design in the View menu to switch to Design View.

As a handy shortcut, Control-click over a blank area in the form to open a 
shortcut menu. Choose Design in this menu.

The Design View window contains four toolbars and seven menus.

The Design View window also contains the calculation toolbar. Choose 
Calculation in the Tools menu to display this toolbar. See Chapter 9, 
Using Calculations, for detailed information.

Use Design View to edit and create fields on an existing form or to create 
an entirely new form.

For detailed information on Design View and designing forms, see 
Chapter 6, Designing a Form.

Standard toolbar

Drawing toolbar

Font/text toolbar Arrange toolbar

Status bar: displays current 
activity and settings.
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The Fill View Window
This section provides an overview of the Fill View window.

If you are in Design View, click the Fill button in the standard toolbar or 
choose Fill in the View menu to switch to Fill View.

As a handy shortcut, Control-click to open a shortcut menu. Choose Fill in 
this menu.

The Fill View window contains a toolbar and seven menus.

Use Fill View to enter data in fields, create a records database, import 
and export information to and from records, and print, mail, or fax 
forms.

See Chapter 7, Filling a Form, for detailed information on how to enter 
text into fillable fields and move through a form. 

See Chapter 8, Managing an OmniForm Database, for detailed 
information on database creation and management.

Standard toolbar

Status bar: displays current 
activity and settings.
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Form Usage Options
This section describes form usage: how it affects the forms you scan or 
import as image files, how to select form usage, and how to change it.

This section contains the following topics:

• Choosing a Form Usage Option

• Where to Select Form Usage Options

• Changing Form Usage

Choosing a Form Usage Option
Form usage affects the way you can use a form once it is in OmniForm. 

Decide how you will use a form in OmniForm before you scan or import 
it: as a designed form, as an original form, or as a non-designed form image 
as described below.

OmniForm uses Logical Form Recognition (LFR) to identify text, 
rectangles, lines, and fillable areas when it designs a form during 
scanning or import.

Designed Form

Use this option if you want to be able to:

• have full control over a form’s design

• edit all form elements in Design View

• create new objects in Design View

• fill fields in Fill View

A designed form does not retain graphics during Logical Form 
Recognition, but you can import graphics.

Original Form

Use this option if you want to be able to:

• have partial control over a form’s design

• maintain a form’s original look

• draw new fillable objects on the form in Design View

• fill fields in Fill View
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Non-designed Form

This type of form has no fillable fields and no editable text. Basically, it 
is just an image, or picture, on your computer. Use this option if you 
want to be able to:

• input a form of such poor quality that it would cause recognition 
problems

• draw new fillable objects on the form in Design View

• print or fax the form only

See Chapter 6, Designing a Form, for information on adding graphics, 
creating objects, and using other design techniques. 

See Chapter 7, Filling a Form, for information on filling fields in Fill 
View.

Where to Select Form Usage Options
Different form usage options are available depending on whether you 
open Form Assistant or choose Scan Form... in the File menu.

Form Assistant

If you use Form Assistant, you can choose between the designed form 
and original form options.

This dialog box is one of several in Form Assistant; it appears during the 
scanning or import process.

Designed form option

Original form option
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Scan Form Dialog Box

If you use the Scan Form... command, you can choose between the 
designed form and non-designed form options.

Changing Form Usage
Choose Form Usage... in the View menu to change the way you can use a 
form. For example:

• You have an original form but decide to change the design.
You would change the form to a designed form.

• You have a designed form that you have edited but want to fax the 
original form to someone.
You would change the form to an original form.

There is no original view for a form that you design yourself in 
OmniForm.

Select this option for a 
designed form. Deselect it 
for a non-designed form.
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To change form usage:

1 Choose Form Usage... in the View menu.
The Form Usage dialog box appears.

2 Select a form usage option.

• Select Use Designed Form to view the form as it was designed 
by OmniForm on import along with any changes you have 
made to the form’s design.
You can edit all text and fields, and add graphics to the form.

• Select Use Original Form to view the form as it looked 
originally, before you scanned or imported it to OmniForm. 
You can create, resize, move, delete, define, or change the 
appearance of fillable fields with this option. Changes you 
make to text, graphics, and non-fillable objects are not visible 
until you select Use Designed Form.

3 Click OK.
Your form changes to reflect the selected option.

You can change form usage for a non-designed form to a designed form. 
However, it will be blank except for any fillable objects you may have 
added.
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OmniForm Procedures
This chapter describes basic OmniForm procedures: how to turn your 
paper forms into electronic forms; how to fill, print, and fax forms; how 
to open forms to fill, redesign, and search for information.

This chapter contains the following sections:

• Scanning a Paper Form

• Importing an Image File

• Filling a Form

• Printing or Faxing a Form

• Searching a Form

• Opening a Form to Design

• Creating a New Form

• Opening a Form

• International Settings

• Menu Shortcuts
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Scanning a Paper Form
This section describes how to use both Form Assistant and the Scan 
Form... command to turn your paper form into an electronic form.

You can scan paper forms directly into OmniForm if you have a scanner. 
Forms should be blank with crisp, dark text on a white background for 
best results.

You can use the Sample Form included with your OmniForm package 
as a test page if you like.

Scanning With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder.

If OmniForm is open, click the Form Assistant button in the 
standard toolbar to open Form Assistant.
Form Assistant appears.

2 Select Scan in a form  and then click Next>.

3 Select Scanner in the next window and click Next>.

4 Select a paper size in the next window.

• Select Letter if the form is 8.5 by 11 inches.

• Select Legal if the form is 8.5 by 14 inches.

• Select A4 if the form is 21 by 29.7 centimeters (European).

5 Click Next>.
The next window only appears if a form is open already. 
Proceed to step 7 if a form is not open.

6 Select whether you want the scanned page to be a new form or 
to add the page to a currently open form in the next window, 
and then click Next>.

7 Select form usage in the next window.

• Select the first option if you want to edit or redesign a form. 

• Select the second option if you do not want to edit or redesign 
a form, just fill it in.

8 Click Next>.
The last window prompts you to place a page in your scanner. 
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9 Make sure the page is aligned correctly in your scanner, and 
click Finish.
OmniForm scans the form. The OmniForm window displays 
scanning, designing, and straightening progress.

How your form appears in OmniForm depends on the form 
usage option you chose in Form Assistant.

10 Click the Save button in the standard toolbar or choose Save... 
in the File menu to name and save your file.

11 Begin to fill or edit your form.

See Chapter 6, Designing a Form, for detailed information on defining, 
moving, resizing, and creating fields, and other design functions.

See Chapter 7, Filling a Form, for detailed information on the kinds of 
fields you may find on a form and how to fill them.
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Using the Scan Form... Command
1 Click the Scan button in the standard toolbar or choose Scan 

Form... in the File menu.
The Scan Form dialog box appears.

2 Select Scanner in the Source pop-up menu.

3 Click Set Up Scanner... to choose a page size and adjust scanning 
brightness.

• Select an option under Page Size:
Select Letter if the form is 8.5 by 11 inches.
Select Legal if the form is 8.5 by 14 inches.
Select A4 if the form is 21 by 29.7 centimeters (European).

• Select a scanning brightness under Brightness.
Select Auto (AccuPage) if your scanner supports HP AccuPage 
and your form is printed on colored, shaded, or smudged 
paper, or if it has very small type.
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Select Lighten if the form has very thick or run-together text, 
or if the background is smudged, shaded, or colored.
Select Normal if the form has crisp, black text and objects on a 
white background.
Select Darken if the form has very thin or broken text such as 
with a poor-quality fax or a copy of a copy.

• Click OK to return to the Scan Form dialog box.

4 Select an option in the Orientation pop-up menu.

• Select Auto to have OmniForm determine orientation 
automatically.

• Select Portrait for a vertically oriented page.

• Select Landscape for a horizontally oriented page.

• Select Flipped to automatically rotate a portrait page 180 
degrees during the scan.

• Select Flipscape to automatically rotate a landscape page 180 
degrees during the scan.

The Flipped and Flipscape options are useful for scanning pages in a 
book to avoid turning it upside down or sideways.

5 Select import options.

• Select Auto Form Design to use Logical Form Recognition to 
recognize text and fillable fields in the form.
This gives you full control over a form’s design. Graphics are 
not retained but you can import them. See “Creating a 
Graphic Object” on page 6-8 for information on how to do 
this.

Thick, dark text. 
Select Lighten.

Crisp, black text. 
Select Normal.

Thin, broken text. 
Select Darken.

Text on a shaded 
background. Select 
Auto (AccuPage).
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• Deselect Auto Form Design to scan a form without recognizing 
form design. Text and fillable fields are not recognized. This 
results in a non-designed form.
This is useful if you just want to fax a form, or if the form is of 
such poor quality that it would cause recognition problems.

• Select Auto Form Straightening to have OmniForm 
automatically straighten a crooked page.
This is useful if you scan a page in a large, unevenly cut, or 
thick document that is difficult to position correctly.

• Select Add Page(s) to Current Form to make the newly scanned 
page the next page in the current form.
This option is only available if a form is open.

6 Verify that the selected language under Language is the one you 
want for your new form.

• To change the default language for the new form, click 
Preferences... to open a modified Preferences dialog box.

• Select a language in the Language pop-up menu.
See “International Settings” on page 5-22 for more 
information on the international options.

• Click OK to return to the Scan Form dialog box.

7 Select Allow Multiple Languages if your form contains more than 
one language that you want OmniForm to recognize.
This setting does not affect the selected language for your form 
set in the previous step.
Do not select this setting for a single-language form as optical 
character recognition (OCR) may not be as efficient.

8 Click OK in the Scan Form dialog box to begin scanning.
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OmniForm scans the form. The OmniForm window displays 
scanning, designing, and straightening progress if you selected 
those options.

How your form appears depends on whether or not you chose 
Auto Form Design in the Scan Form dialog box.

9 Click the Save button in the standard toolbar or choose Save... 
in the File menu to name and save your file.

10 Begin to fill or edit your form.

See Chapter 6, Designing a Form, for detailed information on defining, 
moving, resizing, and creating fields, and other design functions.

See Chapter 7, Filling a Form, for detailed information on the kinds of 
fields you may find on a form and how to fill them.

See “Printing or Faxing a Form” on page 5-14 if you have a non-designed 
form.
OmniForm Procedures  5-7



Importing an Image File
Importing an Image File
This section describes how to use both Form Assistant and the Scan 
Form... command to import an image file as a recognized OmniForm 
form.

OmniForm can import and recognize black-and-white forms in either 
PICT or TIFF format. Image resolution must be 200, 300, or 400 dots per 
inch (dpi). If you have a fax modem, for example, you can receive a 
faxed form and use the fax program’s software to save the file in PICT 
or TIFF format. OmniForm has the same import options for image files 
as it does for scanned forms.

Importing With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder.

Click the Form Assistant button in the standard toolbar if 
OmniForm is already open.
Form Assistant appears.

2 Select Scan in a form  and then click Next>.

3 Select Fax or Image File in the next window to recognize a form 
that is in a supported image format.
This could be a form created in another program or one 
received as a fax file.

4 Click Next>.

5 Select a file in the next window.

• Click Select... if you need to locate a file.

• Select a file in the Select dialog box and click Open to return to 
Form Assistant.

6 Click Next>.
The next window only appears if a form is open already. 
Proceed to step 8 if a form is not open.

7 Select to have scan the page as a new form and click Next>, or 
to add the page to the currently open form and click Finish>.
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8 Select form usage in the last window.

• Select the first option if you want to edit or redesign a form. 

• Select the second option if you do not want to edit or redesign 
a form, just fill it in.

9 Click Finish>.
The OmniForm window displays scanning, designing, and 
straightening progress.

How your form appears in OmniForm depends on the form 
usage options you chose in Form Assistant.

10 Click the Save button in the standard toolbar or choose Save... 
in the File menu to name and save your file.

11 Begin to fill or edit your form.

See Chapter 6, Designing a Form, for detailed information on defining, 
moving, resizing, and creating fields, and other design functions.

See Chapter 7, Filling a Form, for detailed information on the kinds of 
fields you may find on a form and how to fill them.
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Using the Scan Form... Command to Import
1 Click the Scan button in the standard toolbar or choose Scan 

Form... in the File menu.
The Scan Form dialog box appears.

2 Select Image File(s) in the Source pop-up menu to recognize a 
form in a supported image format.

This could be a form created in another program or one 
received as a fax file.

3 Click Select Files... to open the Select Files dialog box.

• Locate and select a file. 

• Click Add File to add the file to the Files to Process list box.
You can select up to 20 files from one or more folders.

• Click Done to return to the Scan Form dialog box when you 
are done.

4 Select an option in the Orientation pop-up menu.

• Select Auto to have OmniForm determine orientation 
automatically.

• Select Portrait for a vertically oriented page.

• Select Landscape for a horizontally oriented page.

• Select Flipped to automatically rotate a portrait page 180 
degrees during the scan.

• Select Flipscape to automatically rotate a landscape page 180 
degrees during the scan.
5-10  OmniForm Procedures



Importing an Image File
The Flipped and Flipscape options are useful for scanning pages in a 
book to avoid turning it upside down or sideways.

5 Select import options.

• Select Auto Form Design to use Logical Form Recognition to 
recognize text and fillable fields in the form.
This gives you full control over a form’s design. Graphics are 
not retained but you can import them.

• Deselect Auto Form Design to scan a form without recognizing 
form design. Text and fillable fields are not recognized. This 
results in a non-designed form.
This is useful if you just want to print or fax a form, or if the 
form is of such poor quality that it would cause recognition 
problems.

• Select Auto Form Straightening to have OmniForm 
automatically straighten a crooked page.
This is useful if you are importing a received fax file that was 
skewed in the fax machine.

• Select Add Page(s) to Current Form to make the newly scanned 
page the next page in the current form.
This option is only available if a form is open.

6 Verify that the selected language under Language is the one you 
want for your new form.

• To change the default language for the new form, click 
Preferences... to open a modified Preferences dialog box.

• Select a language in the Language pop-up menu.
See “International Settings” on page 5-22 for more 
information on the international options.
Click OK to return to the Scan Form dialog box.

7 Select Allow Multiple Languages if your form contains more than 
one language that you want OmniForm to recognize.
This setting does not affect the selected language for your form 
set in the previous step.
Do not select this setting for a single-language form as optical 
character recognition (OCR) may not be as efficient.
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8 Click OK.
OmniForm imports the form. The OmniForm window displays 
scanning, designing, and straightening progress if you selected 
these options.

How your form appears depends on whether or not you chose 
to have OmniForm design the form during import.

9 Click the Save button in the standard toolbar or choose Save... 
in the File menu to name and save your file.

10 Begin to fill or edit your form.

See Chapter 6, Designing a Form, for detailed information on defining, 
moving, resizing, and creating fields, and other design functions.

See Chapter 7, Filling a Form, for detailed information on the kinds of 
fields you may find on a form and how to fill them.

See “Printing or Faxing a Form” on page 5-14 if you have a non-designed 
form.
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Filling a Form
This section describes how to use both Form Assistant and the Fill 
command to open a form and fill it.

Filling Fields With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder.

Click the Form Assistant button in the standard toolbar if 
OmniForm is already open.
Form Assistant appears.

2 Select Fill in a form and click Next>.

3 Select which form to use in the next window.

• Select the first option and click Select... to open a form.
Select a form in the Open dialog box and click Open to return 
to the Form Assistant dialog box.

• Select the second option to work with the current form.
This option is available only if a form is open.

4 Click Finish> after you select an option.
OmniForm opens the selected form in Fill View.
See “The Fill View Window” on page 4-6 for a description.

5 Click in a field or press the Tab key to place the cursor in the 
first field.

6 Type the information you want to enter. Press the Enter key to 
add new lines to the current field.

7 Press the Tab key to move to the next field.
Press Shift-Tab to move to the previous field.

8 Continue to fill fields in this way.

See Chapter 7, Filling a Form, for detailed information on the kinds of 
fields you may find on a form and how to fill them.

Using the Fill Command
1 If you have a form open and are in Design View, click the Fill 

button in the standard toolbar or choose Fill in the View menu.

2 Follow steps 5–8 in ”‘Filling Fields With Form Assistant” above.
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Printing or Faxing a Form
This section describes how to use both Form Assistant and the Print... 
command to print or fax a form.

You must have fax hardware and software installed to fax a form. Refer to 
your fax documentation for instructions on how to set up your equipment 
for faxing. Faxing uses the Print... command. The word print in these 
instructions describes both printing and faxing.

Printing/Faxing With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder.

Click the Form Assistant button in the standard toolbar if 
OmniForm is already open.
Form Assistant appears.

2 Select Print or fax a form and click Next>.

3 Select which form to use in the next window.

• Select the first option and click Select... to open a form.
Select a form in the Open dialog box and click Open to return 
to the Form Assistant dialog box.

• Select the second option to work with the current form.

4 Click Next> after you select an option.

5 Select what data to print or fax in the next window.

• Select Print or fax blank copies of the form to print the form as it 
would appear in Design View, without any information in 
fillable fields.

• Select Print or fax filled in copies of the form to print all text, 
graphics, and any information in fillable fields.

• Select Print the form’s data over pre-printed forms to print just the 
information you have typed in the fillable fields. Place the 
pre-printed form in your printer.

6 Click Next>.

7 Select how you would like the form to look in the next window.
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• Select the first option to print the form as it was designed by 
OmniForm during import or by the person who designed it in 
OmniForm.

• Select the second option to print the form as it appeared when 
it was a hard copy, without any edits or redesign.

8 Click Finish.
The Print dialog box appears.

9 Select the desired print options and click OK.
See the next section for more information on print options.
OmniForm prints or faxes your form with the settings you 
chose. Depending on your fax software, more dialog boxes may 
appear after you click OK in the Print dialog box.

Using the Print... Command
1 Click the Print button in the standard toolbar or choose Print... 

in the File menu to open the Print dialog box.

2 Select an option in the Form/Data pop-up menu. These options 
are available only in Fill View.

• Select Form and Data to print all text, graphics, and any 
information in fillable fields.

• Select Data Only to print just the information you have typed 
in the fillable fields. This is useful if you want to print data 
over a pre-printed form.

• Select Form Only to print just the form without any 
information in fillable fields.

3 Select an option in the Data pop-up menu.
This option is only available if Form and Data or Data Only is 
selected in the Form/Data pop-up menu.

• Select Current Record Only to print just the current record.

• Select Current Record Set to print the current found set of 
records.
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• Select All Records to print every record in the database.

4 Enter offset measurements under Print offsets for data if you 
want.
This is useful if you want to position data in a specific place on 
the page. This option is only available if Data Only is selected in 
the Form/Data pop-up menu.

5 Click OK.
OmniForm prints or faxes your form with the selected settings.

• Depending on your printer or your fax software, more dialog 
boxes may appear after you click OK in the Print dialog box. 
See your printer or fax documentation for information.

• The Print to File dialog box appears after you click OK if you 
selected the Print to file option in the Print dialog box. Select a 
location for the file, type a file name in the File Name text box, 
and click OK.
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Searching a Form
This section describes how to use both Form Assistant and the Search... 
command to open a form and perform a search.

Searching With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder.

Click the Form Assistant button in the standard toolbar if 
OmniForm is already open.
Form Assistant appears.

2 Select Search a form for information and click Next>.

3 Select which form to use in the next window.

• Select the first option and click Select... to open a form.
Select a form in the Open dialog box and click Open to return 
to the Form Assistant dialog box.

• Select the second option to work with the currently open 
form.

4 Click Finish> after you select an option.
The Search dialog box appears.

5 Select the field to search in the Field Name pop-up menu.

6 Select how to search for the information in the Condition pop-
up menu.

7 Type the information to find in the Value text box.

8 Select which records to search.

The field to search

How to search

What to search for

Which records to search
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• Select Search All Records in the Database to search all records in 
the current database.

• Select Only Search Current Record Set to search the current 
found set of records. This option is available after a search.

9 Click OK.
OmniForm searches the records and finds any that contain the 
information you specified.

See “Searching Records for Information” on page 8-7 for detailed 
information on searching.

Using the Search... Command
1 If you have a form open and are in Design View, click the Fill 

button in the standard toolbar or choose Fill in the View menu.

2 Choose Search... in the Records menu.
The Search dialog box appears.

3 Follow steps 5–9 in the previous section.
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Opening a Form to Design
This section describes how to use both Form Assistant and the Design 
command to open a form in Design View.

See Chapter 6, Designing a Form, for detailed information on designing 
and editing forms.

Opening a Form in Design View With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder.

Click the Form Assistant button in the standard toolbar if 
OmniForm is already open.
Form Assistant appears.

2 Select Work on a form’s design and click Next>.

3 Select the form to use in the next window.

• Select the first option and click Select... to open a form.
Select a form in the Open dialog box and click Open to return 
to the Form Assistant dialog box.

• Select the second option to work with the currently open 
form. This option is only available if a form is open already.

4 Click Finish.
OmniForm opens the selected form in Design View.
See “The Design View Window” on page 4-5 for a description.

Using the Design Command
If you have a form open and are in Fill View, click the Design button in 
the standard toolbar or choose Design in the View menu.

OmniForm displays the form in Design View.
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Creating a New Form
This section describes how to use both Form Assistant and the New 
command to create a new form.

See Chapter 6, Designing a Form, for detailed information on form design.

Creating a New Form With Form Assistant
1 Double-click the OmniForm icon in the OmniForm folder. Click 

the Form Assistant button in the standard toolbar if OmniForm 
is already open.
Form Assistant appears.

2 Select Create a new, blank form.

3 Click Finish.
OmniForm opens a blank form in Design View.

Using the New Command
1 Click the New button in the standard toolbar or choose New in 

the File menu.
OmniForm opens a blank form in Design View.

2 Use the Design View tools to create fields and objects on your 
new form.
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Opening a Form
This section describes how to use the Open... command to open a form. 
You can have up to 20 forms open at the same time.

To open a form:

1 Double-click the OmniForm icon in the OmniForm folder.

2 Click Cancel in Form Assistant if it appears.

3 Click the Open button in the standard toolbar or choose Open... 
in the File menu to open the Open dialog box.

4 Make sure OmniForm Form is selected in the List Files of type 
pop-up menu.

Select All Files instead to open a form created in any version of 
OmniForm for Windows. Otherwise, only forms created on the 
Macintosh are displayed. You can use the PC Exchange control panel 
to make PC forms show as OmniForm forms.

5 Locate and select a file.

6 Click Open.
The form opens in the last view in which it was saved.

See Chapter 6, Designing a Form, for detailed information on defining, 
moving, resizing, and creating fields, and other design functions.

See Chapter 7, Filling a Form, for detailed information on the kinds of 
fields you may find on a form and how to fill them.
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International Settings
This section describes how OmniForm supports different language and 
cultural conventions. You can choose from 45 different locales in the 
International tab in the Preferences dialog box. A locale — as defined for 
OmniForm usage — is a combination of a language and a region. The 
language you select for a particular region affects how your form 
displays currency, numbers, and dates.

Selecting a Language for Your Form(s)
1 If you are in Fill View, click the Design button in the standard 

toolbar or choose Design in the View menu.

2 Choose Preferences... in the Tools menu.

3 Click the International tab.
There are two options: Current Form and New Forms.

4 Click Current Form.

The Language pop-up menu displays the language being used 
for the currently open form. If you have the International 
English or German version of OmniForm, or multiple 
dictionaries, a dictionary in this language will also be used 
during a spell check.

You cannot change the Current Form option if you open the 
Preferences dialog box in Fill View.
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5 Select a different language for the current form if you like.

Changing the language of the current form could cause OmniForm 
to misinterpret any data already entered in that form. OmniForm 
warns you of this if at least one field is filled and you change the 
Current Form selection.

6 Click New Forms.
The Language pop-up menu displays the default language that 
will be used for the next form you open, scan, or import.
The language selected for a new form will also become the 
Current Form selection when that form opens in OmniForm.

7 Select a different default language for new forms if you like.

8 Click OK.

How OmniForm Uses Language Selections
The Current Form language selection affects:

• The formatting of currency, number and date entries in the 
currently open form.

• Which dictionary is used for spell checking. (The International 
English version contains all available dictionaries. Other users 
can call 800-654-1187 to order additional dictionaries.)

• The international symbol that appears in the status bar when a 
form is open.

The New Form language selection affects:

• The formatting of currency, number and date entries in new 
forms you create by scanning or importing, or by choosing New 
in the File menu.

• The international symbol that appears in the status bar when no 
form is open.

Selections made in the International tab do not affect selections made in 
the Numbers, Keyboard, or Date & Time control panels and vice versa. 
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The Options Dialog Box Readouts

Below the Language selection, OmniForm displays readouts: the 
international symbol for the selected language (which appears in the 
status bar); and currency, number, and date conventions specific to that 
language.

The readouts show:

• How OmniForm expects data to be entered in Fill View.

• How OmniForm will format data in Fill View if it is not entered 
correctly. (Formatting takes place after you move the cursor out 
of a field.) See the next section for formatting examples.

Formatting Examples

Currency

If you selected German (Austrian) as the Current Form language, the 
numbers 123456  entered in an appropriately defined currency field 
would display as öS 1.234,56 .

If you selected German (Liechtenstein) as the Current Form language, the 
numbers would display as CHF 1’234.56 .

Date

If you selected English (United States) as the Current Form language, the 
date 2/5/96  entered in an appropriately defined date field would 
display as February  5,  1996 .

If you selected German (Standard) as the Current Form language, the date 
would display as 2.  Mai  1996 .

The Scan Form Dialog Box

The New Form language selection appears in the Scan Form dialog box.

This becomes the Current Form language after the form is in OmniForm.

You cannot change the 
New Forms language if 
this option is selected.

New Forms language 
selection

Click Preferences... to 
change the New Forms 
language selection.
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• Click Preferences... to change the language for your new form.
You cannot change the New Form language selection if Add Page(s) 
to Current Form is checked because a language is already 
associated with the current form. A form can have only one 
selected language.

• If you select Add Page(s) to Current Form, the Language display 
changes to reflect the Current Form language if it is different.

The Object Definition Dialog Box Options

The Current Form language selection affects available formatting options 
for fillable objects defined as type Number, Date, or Currency in the Object 
Definition dialog box. For example, the long-date format for English 
(United States) is MMMM dd,  yyyy . The long-date format for German 
(Standard) is d.MMMM yyyy .

The Allow Multiple Languages Option

How it Works

You can select Allow Multiple Languages in the Scan dialog box for 
multiple-language forms. OmniForm will then recognize all characters 
in all languages it supports. The setting does not affect the language(s) 
selected for your form in the Preferences dialog box and vice versa.

When you select Allow Multiple Languages, OmniForm turns off 
dictionaries during optical character recognition (OCR) so that all 
recognizable characters are allowed. If dictionaries were on, special 
characters such as umlauts might be discarded or questionable words in 
one language could be mistaken for words in another language. 

Do not select Allow Multiple Languages for a single-language form. OCR 
may not be as efficient with dictionaries turned off.

Selecting the New Forms Language

Determine which language composes the majority of your form and 
select that as the New Forms language before scanning. To do so, click 
Preferences... in the Scan Form dialog box.

Remember that the selected language affects sort order and how dates, 
numbers, and currency are formatted in Fill View. See “Multiple 
Languages” on page 7-10 for information on spell-checking a form with 
multiple languages.
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Menu Shortcuts
Use a Control-click to access the two available OmniForm shortcut 
menus. Select a command in a shortcut menu just as you would in the 
regular menu bar.

Use the online help for a description of each menu command.

Where to Click Available Commands

an empty spot in the form Cut, Copy, Paste, Design, Fill, Go To Page

a selected object Cut, Copy, Paste, Object Appearance, Object 
Definition, Size and Position, Font, Text, Table 
AutoFormat (when clicking on a table)
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Chapter 6

Designing a Form
This chapter discusses how to design new forms and edit existing ones 
in OmniForm. OmniForm contains numerous tools in Design View that 
let you create fields and objects, define calculations, and decide how 
your form will look.

This chapter contains the following sections:

• The Design Process

• The Design View Toolbars

• Creating Objects

• Defining Objects

• Changing Object Appearance

• Redesigning Your Form

• Using the Scrap Album

The Sample  Forms  folder in the OmniForm  folder contains many 
sample forms that you can use or redesign for your needs.
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The Design Process
This section gives a brief overview of how to design a new form. A form 
can be as simple as you need or as complex as OmniForm allows. 
Although the steps below are not required, they are recommended.

See “Tutorial 3 — Design Your Own Form” on page 3-21 for step-by-step 
instructions on designing a form.

See “Redesigning Your Form” on page 6-33 for information on how you 
can change existing forms.

To design a new form:

1 Open a new, blank form.

2 Choose Page Setup... in the File menu.

3 Select page size, orientation, and margins, and click OK.

4 Choose Save As... in the File menu.

5 Assign your form a name and location, and then click OK.
Remember to save periodically so you do not lose any work.

6 Use the drawing toolbar to create objects on the form.

7 Choose Object Definition... in the Format menu to define the 
objects you created.
You can assign unique names, filling, and validation properties 
for each selected object.

8 Choose Object Appearance... in the Format menu to set the new 
object’s appearance if necessary.
You can set borders, background color, and other properties.

9 Use the font/text toolbar to format both text objects and fillable 
objects.
Text entered in Fill View will take on the formatting you 
specify in Design View.

10 Drag the objects where you want them on the form and use the 
arrange toolbar to align and arrange them.

11 Choose Tab Order... in the Tools menu to set a logical tabbing 
order for filling the form when it is in Fill View.

12 Test your form in Fill View.

See the appropriate sections in this chapter for detailed information on 
these steps as well as other Design View tools such as the Scrap Album.
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The Design View Toolbars
This section describes each toolbar in Design View and defines its 
buttons. Design view contains five toolbars:

• the standard toolbar

• the font/text toolbar

• the drawing toolbar

• the arrange toolbar

• the calculation toolbar (See Chapter 9, Using Calculations, for 
information on this toolbar and its functions.)

Choose Toolbars... in the View menu to open the Toolbars dialog box and 
select the toolbars to view. You can also use the Tools menu to show/
hide the toolbar. Choose Calculation in the Tools menu to view the 
Calculation toolbar.

Click the Help button in the standard toolbar and click on any toolbar 
button to see its function.

The Standard Toolbar
Use the standard toolbar for basic file operations such as saving and 
printing. Use it also to define and format the fields you create.

All buttons correspond to menu commands of the same name.

Processes such as scanning or opening a form are explained in 
Chapter 5, OmniForm Procedures.

New

Open

Save

Scan

Form 
Assistant

Print Cut

Copy

Paste

Design

Fill

Zoom

Highlight 
Fill Areas

Object 
Appearance

Object 
Definition

Calculation

Size and 
Position

Tab 
Order

Help

Spelling
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The Font/Text Toolbar
Use the font/text toolbar to format text. This toolbar is only active when 
a text, fill text, comb, comb element, circle text, or table cell object is 
selected.

The pop-up menus and buttons correspond to options in the Font or 
Text dialog boxes (choose Font... or Text... in the Format menu). Each 
button displays a thumbnail example of how it formats text.

Text entered in Fill View displays the formatting you specify in Design 
View.

The Arrange Toolbar
Use the arrange toolbar to arrange and align objects on a form.

These buttons correspond to the Align, Bring to Front, and Send to Back 
commands in the Format menu. The last six buttons on the toolbar are 
only active when multiple objects are selected. The illustration on each 
button gives a thumbnail example of how it aligns objects.

Font pop-up menu Font Size pop-up menu Left, Center Horizontal, Right, 
and Justify Alignment buttons

Top, Center Vertical, and 
Bottom Alignment buttons

Bold, Italic, and Underline 
Font Style buttons

Bring to Front

Send to Back

Align Left

Align Right

Center Horizontally

Align Top

Align Bottom

Center Vertically
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The Drawing Toolbar
Use the drawing toolbar to create and select objects.

See “Creating Objects” on page 6-6 for detailed information on using the 
drawing tools.

Selection tool

Text tool

Line tool

Oval tool

Rectangle tool

Graphic tool

Fill Text tool

Comb tool

Check Box tool

Circle Text tool

Table tool

Fill Graphic tool

Lock On/Off tool
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Creating Objects
This section explains how to create objects. You can create fillable objects 
that a user fills in Fill View, and non-fillable objects such as lines and 
rectangles. You will learn how to use all the tools in the drawing toolbar.

See “Defining Objects” on page 6-16 information on how to define 
objects after you create them.

See Chapter 7, Filling a Form, for detailed information on how to fill 
objects (fields) in Fill View.

This section discusses general creation guidelines and then lists all 
objects in the same order as they appear in the drawing toolbar. All 
instructions assume that you are in Design View.

General Creation Guidelines
Use the same basic steps to create most objects. Some objects require 
more steps as described in the following sections.

To create an object:

1 Click a tool in the drawing toolbar.

2 Click anywhere on the form to create an object of a default size, 
or hold down the mouse button and drag the tool to make the 
object the size you want.

3 While drawing, hold down the Shift key to:

• Make a rectangle object a square.

• Make an oval object a circle.

• Keep a line object straight.

4 With the object still selected, you can:

• Type text if it is a text or a circle text object.

• Choose Object Definition... in the Format menu to define a 
fillable object. See “Defining Objects” on page 6-16.

• Choose Object Appearance... in the Format menu to set the 
object’s appearance. See “Changing Object Appearance” on 
page 6-29 for information.

• Hold down the Option key and drag the object to copy it.

5 Drag the object where you want it on the form.
When the object is no longer selected, the drawing tool reverts 
to the Selection tool unless the Lock tool is on.
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Creating a Text Object
A text object is most often used as a title, label, or header.

1 Click the Text tool in the drawing toolbar.

2 Draw the text object.

3 With the object still selected, type the text you want to replace 
the word Label.

Creating a Line Object
Use a line object to separate sections of a form or as a design element.

1 Click the Line tool in the drawing toolbar.

2 Draw a line.

To make sure a line is perfectly straight, hold down the Shift key 
while you draw. 

To rotate a line:

1 Click the Selection tool and select the line to edit.
A handle appears on each end of the line.

2 Place the cursor over one handle.

3 When the cursor turns into a crosshair, hold down the mouse 
key and drag the end of line where you want it.

To rotate the line in 45-degree increments, hold down the Shift key while 
pulling one of the handles in the desired direction.

Text object used as label The State fill text field
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Creating an Oval Object
Use an oval object to highlight areas on a form or as a design element. 
See how the rectangle object is used in the next example.

1 Click the Oval tool in the drawing toolbar.

2 Draw an oval.

To create a circle, hold down the Shift key as you draw.

Creating a Rectangle Object
Use a rectangle object to highlight areas on a form or as a design 
element.

1 Click the Rectangle tool in the drawing toolbar.

2 Draw a rectangle.

To create a square, hold down the Shift key as you draw.

Creating a Graphic Object
Use a graphic object to illustrate text or as a design element. Create a 
graphic object when you want the same graphic to appear in every copy 
of the form such as a company logo.

Because OmniForm recognizes characters, not graphics, while 
designing a scanned or imported form, you must import the graphics 
you want. There are two ways to import a graphic in Design View:

• Copy a graphic from the original form to the designed form.
See “Copying a Graphic From the Original Form” on page 6-10 
for instructions.

• Import an existing graphic.
See the next section for instructions.
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Importing a Graphic

1 Click the Graphic tool in the drawing toolbar.

2 Draw a graphic object.

To create a square graphic object, hold down the Shift key as you 
draw.

3 With the object still selected, click the Object Definition button 
in the standard toolbar or choose Object Definition... in the 
Format menu.
The Graphic Definition dialog box appears.

4 Select Graphic File in the Source pop-up menu.

5 Click Select... to open the Select dialog box.

• Locate and select a file.

• Click Open to return to the Graphic Definition dialog box.
The name of the selected file appears.

6 Proceed to “Graphic Definition Options” on page 6-12 to 
continue.
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Copying a Graphic From the Original Form

1 Choose Form Image in the View menu.
This command is only available when a form has an original 
view. It is not available for forms you design in OmniForm.
The screen splits to show the form both as it was designed with 
Logical Form Recognition and as it was scanned originally.

2 Locate the graphic you want to copy from the original form.
Each view window has its own scroll bar so you can scroll to 
the same place in each form. Click a window to make it active. 
You can use the horizontal bar in-between the two windows to 
resize the view.

3 Your cursor turns into a resize cursor over the bar.

4 Click the Graphic tool in the drawing toolbar.

5 Place the cursor in the top window and draw a box by using 
the graphic in the bottom window as a guide.

Designed form without graphic

Original form with graphic

Horizontal bar
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A corresponding box appears in the top window.

6 With the object still selected, click the Object Definition button 
in the standard toolbar or choose Object Definition... in the 
Format menu. 
The Graphic Definition dialog box appears.

7 Select Form Image in the Source pop-up menu.

8 Proceed to “Graphic Definition Options” on page 6-12.

Graphic box where 
arrow will be placed

Arrow in original form
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Graphic Definition Options

1 Select options for the graphic.

• Select Maintain Original Size to import the graphic without 
changes.

• Select Scale Proportionally to fit the graphic in the fill graphic 
field while maintaining its exact proportions.

• Select Stretch to Fit to change your graphic’s original shape 
and size to fit in the fill graphic field.

This option does not maintain a graphic’s original 
proportions. Depending on the shape of the fill graphic field, 
your graphic may be stretched or compressed. You might 
want to use this for special effects.

• Select Just Change the Options for this Graphic if the graphic 
object contains a graphic already.
This changes how the graphic appears without reimporting it.

• Select Store a Copy of the Graphic with the Form to place a copy 
of the graphic directly in the form. This increases form size 
depending on graphic file size. Otherwise, OmniForm loads 
the graphic each time you open the form. If you move the 
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original graphic, OmniForm cannot load it and it will not 
appear in the form until you reimport it.
This option only appears if Graphic File is selected in the Source 
pop-up menu.

2 Click OK.
OmniForm scans or loads the graphic, depending on the 
selected source. The graphic appears in the Graphic object box.

Creating a Fill Text Object
Use a fill text field wherever you want to enter text in Fill View. Fill text 
fields are commonly used for information such as name, company, 
address, comments, and so forth.

1 Click the Fill Text tool in the drawing toolbar.

2 Draw the fill text object.

To create a square field, hold down the Shift key as you draw.

Creating a Comb Object
Use a comb field to separate information into separate groups of 
elements while maintaining the field as a whole. For example, United 
States forms typically require that you enter zip code numbers in five or 
nine separate boxes. In most languages, phone numbers are separated 
into several boxes.

1 Click the Comb tool in the drawing toolbar.

2 Either click anywhere on the form to create a four-element 
table, or hold down the mouse button and drag the cursor 
slowly.
The number of elements in the comb field increases as you drag 
the mouse. Release the mouse button when the comb field 
contains the number of elements you want.

Many sample forms included with your OmniForm package, such as the 
Objects form, contain comb objects that you can copy and paste into 
your own form. You can also copy objects from the Scrap Album.
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Creating a Check Box Object
Use check boxes for Yes/No questions and for selecting one or more 
choices on a form.

1 Click the Check Box tool in the drawing toolbar.

2 Draw a check box.

To create a square check box, hold down the Shift key as you draw.

Creating a Circle Text Object
Use circle text objects for Yes/No questions and for selecting one or more 
choices on a form (see the example in the previous section).

1 Click the Circle Text tool in the drawing toolbar.

2 Draw a circle text object.

To create a circle instead of an oval, hold down the Shift key as you 
draw.

3 With the object still selected, type the text you want to replace 
the number in the object.

Creating a Table Object
Use a table to enter information for order forms, invoices, comparison 
charts, purchase orders, and so forth.

A table consists of cells. Each cell contains a fill text object by default, 
with the exception of the header. The header cells contain text objects by 
default.
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You can convert these objects to any other kind of object. You can insert 
any object in a table cell. Cells can contain multiple objects.

See “Redesigning a Table” on page 6-38 and “Placing Objects in Table 
Cells” on page 6-42 for more information on tables.

To create a table object:

1 Click the Table tool in the drawing toolbar.

2 Either click anywhere on the form to create a table, or hold 
down the mouse button and drag the cursor slowly.
The number of rows and columns in the comb field increase as 
you drag the mouse. Let go of the mouse button when the table 
contains the number of rows and columns you want.

To create a square table, hold down the Shift key as you draw.

Creating a Fill Graphic Object
Use a fill graphic object to illustrate text, such as a diagram, or as a 
design element, such as a company logo. You can only fill a fill graphic 
in Fill View.

A fill graphic can be different for every copy of a form in your file 
because it is filled in Fill View. Create a graphic object instead if you 
want the same graphic to appear in every copy of the form.

To create a fill graphic object:

1 Click the Fill Graphic tool in the drawing toolbar.

2 Draw the fill graphic object.

To create a square, hold down the Shift key as you draw.
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Defining Objects
This section describes the options in the Object Definition dialog box 
and how they affect a selected object. The dialog box varies according to 
the selected object and form language. Each definable object is described 
in this section in the order it appears in the drawing toolbar.

When you define an object you can:

• Give it a unique name that is useful when sorting or searching 
records, arranging tab order, or defining calculations.

• Provide filling options such as a list of possible entries and help 
messages that appear in Fill View.

• Set validation options such as whether a field must be filled or 
can be skipped.

See the previous section, “Creating Objects” on page 6-6 to learn how to 
create objects. See “International Settings” on page 5-22 for information 
on selecting a form language.

To define an object:

1 Select a fillable object on your form, a fillable object in a table 
cell, or a comb element in Design View.
You cannot define non-fillable objects such as lines.

2 Click the Object Definition button in the standard toolbar or 
choose Object Definition... in the Format menu.

As a handy shortcut, Control-click over the selected object to open a 
shortcut menu. Choose Object Definition... in this menu.

The dialog box that appears varies depending on the selected object. See 
the following sections for descriptions of the definition options available 
for each type of fillable object in a form.

Defining a Graphic Object
See “Creating a Graphic Object” on page 6-8 for detailed information.
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Defining a Fill Text Object
Choose Object Definition... in the Format menu to open the Fill Text 
Definition dialog box when a fill text object is selected. 

Set Property Options

1 Click the Properties tab.

2 Type a unique name in the Name text box.
Each object must have a unique name. A descriptive name such 
as Address makes a field easy to find when sorting, searching, 
defining calculations, and so forth.

3 Select a type in the Type pop-up menu.
Type information is displayed in the status bar in Fill View 
when the cursor is in that field. This helps the user know what 
kind of entry is expected in each field. Field type also helps 
OmniForm match data when sorting records and importing 
and exporting information.

4 Select a display format in the Format pop-up menu.
The format you select affects how field information is 
displayed in Fill View. Options vary according to the Type 
selection.

• If you selected Currency as the Type, for example, you might 
select $0.00 as the format. If you entered 7889  in the field, 
OmniForm would format the entry as $7889.00 . Formatting 
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takes effect after you move the cursor out of a field in Fill 
View.

• A General format leaves the field entry exactly as it is entered. 
In the above example, 7889  entered in the field would be 
displayed as 7889 .

• Field type also affects field validation. You can require that 
the field entry match the field type. See “Set Validation 
Options” on page 6-20 for information.

The next two options are enabled when Number, Currency, or 
Percentage is selected in the Type pop-up menu.

5 Select Use 1000’s Separator to separate a series of three digits 
with a separator specific to the form’s language.
See “International Settings” on page 5-22 for detailed 
information on selecting a language for a form.

6 Select Enclose Negatives in Parentheses to display negative 
numbers within parentheses in the field; for example, -123  
would display as (123) .

Set Filling Options

1 Click the Filling tab.

2 Select List of Choices if you want to be able to select a field entry 
from a pop-up menu of choices in Fill View.

• Type an entry in the text box below the option and click Add 
to place it in the list box.
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You can enter up to 100 entries. Each entry can be up to 100 
characters long.

• Select an entry in the list and click Move Up or Move Down to 
reorder it. 

• Select an entry in the list and click Remove to remove it.

• A field with a list of choices looks like this in Fill View:

A pop-up menu arrow appears when the cursor is in the field. 
Click the arrow to open the list and select an entry. The entry 
appears in the field.

3 Deselect Can Be Filled so an empty field cannot be filled and a 
filled field cannot be changed in Fill View.

The Can Be Filled option, when deselected, overrides the Must be Filled 
in option when it is selected in the Validation tab.

4 Select Tab Stop so that the cursor automatically moves to the 
selected field when the user presses the Tab key. Deselect Tab 
Stop so that the cursor tabs past the selected field.

5 Select the maximum numbers of characters that can be entered 
in the field in the Maximum pop-up menu. (You can also type in 
a number.)

6 Select Help Message to type a message that appears in the status 
bar in Fill View when the cursor is in that field.
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In the example below, the help message tells the user how to fill 
the field.

A help message can be up to 100 characters long.

Set Validation Options

1 Click the Validation tab.

2 Select Must be Filled in to display a prompt in Fill View if the 
user does not fill the field.
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The Can Be Filled option in the Filling tab, when deselected, overrides 
the Must be Filled in option when it is selected.

3 Select Data Must Match Field Type to display a prompt in Fill 
View if the user enters incorrect information in the field.
If the field type is Number, for example, the user cannot enter 
text in the field; 5 is acceptable but five is not.

4 Select an option under Number Checking to display a prompt in 
Fill View if a user enters numbers outside the set range.
Number Checking is enabled when Number, Currency, or 
Percentage is the selected type in the Properties tab.

• Select Lowest Number and enter a number in the text box.
Numbers entered in the selected field must be equal to or 
greater than this number.

• Select Highest Number and enter a number in the text box.
Numbers entered in the selected field in Fill View must be 
equal to or lesser than this number.

5 Click OK to apply the changes and close the dialog box.

Defining a Comb Object
Choose Object Definition... in the Format menu to open the Comb 
Definition dialog box when a comb object is selected.
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This dialog box contains most of the same options as the Fill Text 
Definition dialog box with these exceptions:

• It contains an Interpret As pop-up menu instead of a Format pop-
up menu.

• It contains an Elements section.

• It contains a Fill Right to Left option.

These options are described in this section. See “Defining a Fill Text 
Object” on page 6-17 for detailed information on the other options.

Interpret As

Your selection determines the way information entered in the Comb 
field will be used when searching, sorting, importing, and exporting. 
Available options vary according to the Type selection.

For example, suppose you selected Number in the Type pop-up menu 
and 0.00 in the Interpret As pop-up menu. If you entered 1234  in the field 
in Fill View, OmniForm would interpret this number as 12.34  even if 
the comb did not contain a decimal point as a prefill element. A search 
for 12.34  would return this record.

A specific Interpret As setting is not necessary when you define the 
correct prefill elements in a comb object, such as a decimal point. 
OmniForm would know the entry was a decimal number in this case 
even if you selected the General option in the Interpret As pop-up menu.

Element Options

1 Click the Properties tab.

2 Type a number in the Number of Elements text box.
A zip code field for the United States, for example, would have 
either five or nine elements.

3 Type a number in the Width of Elements text box to set how wide 
all comb elements will be.
You can resize individual elements later if you want to change 
their width.

4 Type a number in the Inter-Element Spacing text box to set the 
amount of space between each comb element.
You can resize individual elements later if you want to change 
inter-element spacing.
6-22  Designing a Form



Defining Objects
Fill Right to Left Option

1 Click the Filling tab.

2 Select Fill Right to Left if you want the first character in the 
comb field to appear in the rightmost element and move left as 
other characters are added.
You would still read this entry from left to right. 
This is useful for entering decimal numbers, such as percentage 
and currency amounts, in fields with a prefill decimal point 
element. When entering $598.07  in a field, for example, 07  
would always appear after the decimal point. This would not 
always happen if the numbers were entered from left to right.

3 Click OK to apply the changes and close the dialog box.

See “Defining a Comb Element Object” on page 6-23 for more 
information.

Defining a Comb Element Object
Choose Object Definition... in the Format menu to open the Comb 
Element Definition dialog box when a comb element is selected.

To define a comb element:

1 Select left and right border measurements under Border Height.
This sets the left and right border height of each element. You 
might, for example, select 1/2 to use the popular half-border 
height often seen on forms. (You will also have to use the Object 
Appearance command to further define borders.)

2 Select Prefill element to place a hyphen in the selected element.
This is useful for phone numbers and other hyphenated 
numbers. You can select this element in Design View and 
change it to another character such as a parenthesis.
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3 Type a number in the Length text box.
This tells OmniForm how many characters to allow in the 
selected element before moving to the next element. In some 
countries, for example, the length of the area code element in a 
phone number is 3.

4 Click OK to apply the changes.

Defining a Check Box Object
Choose Object Definition... in the Format menu to open the Check Box 
Definition dialog box when a check box object is selected.

Set Property Options

1 Click the Properties tab.

2 Type a unique name in the Name text box.
Each object must have a unique name. A descriptive name such 
as Yes Check Box makes a field easy to find when sorting, 
searching, defining calculations, and so forth.

3 Type a group name in the Option Group pop-up menu if the 
check box belongs to an option group.
Creating an option group restricts you to one selection per 
check box group. Selecting a check box in an option group 
automatically deselects any checked box in the same group.
The group name you enter automatically appears in the Option 
Group pop-up menu of the next check box you create. Select 
this name to include the check box in the group.
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4 Select or enter an option in the On-Value pop-up menu.
The on-value is stored in the database when the check box is 
selected. This is the value OmniForm records when a check box 
is “on,” or selected. The value is exported along with other 
information during export. It can also be used in calculations. 
Grouped check boxes must have unique on-values. You can let 
OmniForm create a unique on-value for each new check box 
added to a group.

5 Select or enter an option in the Off-Value pop-up menu.
The off-value is stored in the database when the check box is 
deselected. This is the value OmniForm records when a check 
box is “off,” or deselected. It is exported along with other 
information during export. It can also be used in calculations. 
This option is not available for grouped check boxes.

Set Filling Options

1 Click the Filling tab.

2 Select a mark for the check box: an X, a check mark, or a fill.

3 Deselect Can Be Filled so an empty field cannot be filled and a 
filled field cannot be changed in Fill View.

4 Select Tab Stop so that the cursor automatically moves to the 
selected field when the user presses the Tab key.
Deselect Tab Stop so that the cursor tabs past the selected field.

5 Select Help Message to type a message that appears in the status 
bar in Fill View when the cursor is in that field.
See page 6-20 for an example of a help message.

6 Click OK to apply the changes and close the dialog box.
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Defining a Circle Text Object
Choose Object Definition... in the Format menu to open the Circle Text 
Definition dialog box when a fill circle object is selected.

This dialog box has the same options as the Check Box Definition dialog 
box. See “Defining a Check Box Object” on page 6-24 for information.

Defining a Table Object
Choose Object Definition... in the Format menu to open the Table 
Definition dialog box when a table object is selected.

1 Type a unique name in the Name text box.

Each object must have a unique name. A descriptive name such 
as Order Information makes a field easy to find when sorting, 
searching, changing tab order, and so forth.
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2 Type the number of columns you want in the table in the 
Number of Columns text box.

3 Set column width:

• Type the column width in the Width of Columns text box.

• Select Make Columns Equal Width to resize all columns to the 
same width.
OmniForm resizes columns to an equal width without 
changing table size. If you had two columns, one four 
centimeters wide and the other two centimeters wide, for 
example, each would be resized to three centimeters wide.

4 Type the number of rows you want in the table in the Number of 
Rows text box.

5 Set row height:

• Type the row height in the Height of Rows text box.

• Select Make Rows Equal Height to resize all rows to the same 
height.
OmniForm resizes rows to an equal height without changing 
table size. If you had two rows, one four centimeters high and 
the other two centimeters high, for example, each would be 
resized to three centimeters high.

6 Click OK to apply the changes.

Defining a Table Cell
A table cell contains a fill text object by default. See “Defining a Fill Text 
Object” on page 6-17 for information. See any relevant entry in this 
section if the table cell contains another type of object.

A table cell can contain more than one object. It can also contain 
graphics. See “Placing Objects in Table Cells” on page 6-42 for 
information.

Defining a Fill Graphic Object
Choose Object Definition... in the Format menu to open the Fill Graphic 
Definition dialog box when a fill graphic object is selected.
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1 Type a unique name in the Name text box.

Each object must have a unique name. A descriptive name such 
as Logo makes a fill graphic field easy to find when importing, 
exporting, and changing tab order.

2 Select Tab Stop so that the cursor automatically moves to the 
selected field when the user presses the Tab key. Deselect Tab 
Stop so that the cursor tabs past the selected field.

3 Select Help Message to type a message that appears in the status 
bar in Fill View when the cursor is in that field.
See page 6-20 for an example of a help message.

4 Click OK to apply the changes.
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Changing Object Appearance
This section describes the options in the Object Appearance dialog box 
and how they affect a selected object. See the section “Creating Objects” 
on page 6-6 to learn how to create objects.

To change object appearance:

1 Select an object or objects in Design View.

2 Click the Object Appearance button in the standard toolbar or 
choose Object Appearance... in the Format menu.

As a handy shortcut, Control-click on the selected object to open a 
shortcut menu. Choose Object Appearance... in this menu.

The Object Appearance dialog box appears. The next three 
sections describe Background, Border, and Fill Line options. 
Available options depend on the selected object.

Set the Background

1 Click the Background tab.

2 Select a background color for the object in the Color pop-up 
menu.
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3 Select a background pattern for the object in the Pattern pop-up 
menu.

4 Select a color for the background pattern in the Pattern Color 
pop-up menu.

5 Deselect Clear to have the selected colors and pattern appear as 
the object’s background.

See “Paint Order” on page 6-32 for a description of how paint order 
affects color and pattern display.

Set the Border

1 Click the Border tab.

2 Select border color in the Color pop-up menu.

3 Select a line style in the Style pop-up menu.

4 Select border thickness in the Weight pop-up menu.

5 Select Clear to hide the border and display any paint layers 
beneath it.
See“Paint Order” on page 6-32 for an explanation of how paint 
order affects border display.

6 Click each side of the rectangle in the Borders section to select 
where borders appear on the object.
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7 Select Rounded to round the corners of the border.
To round or square individual corners, click the corners of the 
rectangle after selecting Rounded.

8 Enter a measurement from 0 to 14  in the Rounded text box to 
indicate the degree of border curve.

9 For a shadow effect, select an option in the Location pop-up 
menu in the Shadow section.

10 Select how many points to offset the shadow from the border in 
the Offset pop-up menu.

Set Fill Lines

Text alignment must be set to Left and Top or Exactly in the Text dialog 
box before fill lines can be set. See “Formatting Text” on page 6-35 for 
information.

1 Click the Fill Line tab.
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Options in this tab are only active for selected fill text objects. 
Fill lines appear inside the object much as lines appear on 
writing paper.

2 Select a color for the fill lines in the Color pop-up menu.

3 Select a line style in the Style pop-up menu.

4 Select line thickness in the Weight pop-up menu.

5 Deselect Clear to display the fill lines.
The next section, “Paint Order,” describes how paint order 
affects fill line display.

6 Select Start Fill Line at First Line Indentation to indent the first fill 
line the same amount as the first line of text entered in the field.
See “The Text... Command” on page 6-36 for more information.

7 Click OK to apply the changes and close the dialog box.

Paint Order

OmniForm uses a specific paint order. The table object itself is painted 
first, then the cells inside the table, and then objects inside the cell. This 
makes it possible to have three layers of paint. The last layer painted in 
an object overrides all other layers. Because objects inside a cell are 
painted last, they will cover up the cells and portions of the table.

If an object’s background or border is Clear, however, then that part of 
the object is transparent and an object painted below can show through. 
You can use the Send to Back and Bring to Front commands in the Format 
menu to change paint order.
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Redesigning Your Form
This section describes how to redesign a form using the Design View 
tools and commands. Once you have created objects, you may want to 
move, resize, or convert them. You may also want to make changes to a 
newly scanned or imported form.

This section contains the following topics:

• Selecting an Object

• Moving an Object

• Resizing an Object

• Deleting an Object

• Formatting Text

• Redesigning a Table

• Aligning Objects

• Sending Objects Front or Back

• Changing Tab Order

• Placing Objects in Table Cells

• Converting an Object

Selecting an Object
You can select one or more objects in several ways.

• Click an object to select it.

• Shift-click to select multiple objects.

• Click an object such as a table once to select it, and then click 
again to select an individual table cell. Do the same to select an 
individual comb element.

• Hold down the mouse button and drag the cursor around or 
through all objects to select them.

• Choose Select All in the Edit menu to select all objects on a form.
Designing a Form  6-33



Redesigning Your Form
• Choose Select Special... in the Edit menu to select all objects of the 
same type.

Moving an Object
You can move a selected object or objects in several ways.

• Hold down the mouse button and drag the selected object to 
another location.

• Choose Size and Position... in the Format menu to position the 
selected object precisely on the form.

• Use the Align commands in the Format menu or the 
corresponding button in the Arrange toolbar to align selected 
objects.

• Use the Bring to Front and Bring to Back commands in the Format 
menu or the corresponding buttons in the Arrange toolbar to 
layer overlapping objects.

Resizing an Object
You can resize a selected object in one of two ways.

Click any handle on the selected object, hold down the mouse button 
and resize the object as needed.

Hold down the Shift key before clicking a handle to:

• constrain an oval or a fill circle object to a circle shape

• keep a line object straight

• constrain any other object to a square shape

Or, choose Size and Position... in the Format menu to enter exact 
measurements for an object’s size.
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Deleting an Object
Press the Delete key on your keyboard to delete one or more selected 
objects.

Formatting Text
Use the Font... and Text... commands in the Format menu or the 
corresponding buttons in the font/text toolbar to format selected 
objects. See “The Font/Text Toolbar” on page 6-4 for information about 
each button in the toolbar.

The Font... Command

1 Select the text and/or fill objects you want to format.
Text entered in Fill View takes on formatting assigned to fill 
objects in Design View.

2 Choose Font... in the Format menu.
The Font dialog box appears.

3 Select a font in the Font list.

4 Select a style for the selected font in the Font Style list.

5 Select a point size for the selected font in the Size list.
Designing a Form  6-35



Redesigning Your Form
6 Select an option in the Effects box.

• Select Strikeout to place a line through all characters.

• Select Underline to underline all characters.

7 Select a color for the selected font by using the Color drop-
down list.
A preview of your choices appears in the Sample box.

8 Click OK to apply the formatting.

The Text... Command

1 Select the text and/or fill objects you want to format.
Text entered in Fill View takes on formatting assigned to fill 
objects in Design View.

2 Choose Text... in the Format menu.
The Text dialog box appears.

3 Click the Alignment tab.

4 Select a horizontal alignment option.

• Click Left to align a paragraph to the left.

• Click Center to align a paragraph by its horizontal center.

• Click Right to align a paragraph to the right.

• Click Justify to align a paragraph both right and left.

5 Select a vertical alignment option.

• Click Top to align a paragraph to the top of a field.

• Click Center to align a paragraph by its vertical center.

• Click Bottom to align a paragraph at the bottom of a field.
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• Click Exactly and enter a point size in the text box to align a 
paragraph a specific amount from the top of a field.

6 Click the Spacing tab and select a line-spacing option.
You can change the vertical spacing between paragraph lines. 
Vertical spacing is dependent on selected font size; a single-
spaced paragraph with 12-point text would have 12 points 
between each line in the paragraph.

• Select Single for a single-spaced paragraph.

• Select 1.5 Lines for a paragraph with one-and-a-half spaces 
between each lines.

• Select Double for a double-spaced paragraph.

• Select Exactly to type in the point size you want between each 
line in a paragraph.

7 Type a measurement in the Indentation of First Line in Paragraph 
text box if you want to indent the first line of each paragraph.

8 Select the Margins tab and enter margin measurements in the 
Left, Right, Top, and Bottom text boxes.
This measurement is the amount a paragraph will be offset 
within its bounding box. You may want to use margins if you 
have field borders that would interfere with reading the text.

9 Select the Text Flow tab and select how you want text to flow 
within the set margins of a field.
This option is available for text and circle text objects only.

• Select Flow Text Across Lines to enter text in a field with 
automatic word-wrapping.

• Select Make Text Fit to Lines to fit text to the size of the line. This 
can alter the appearance of text.

Press Enter to create a new line of text. Each new line can be 
resized separately from other lines.

Each line can be selected 
separately and resized.
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OmniForm uses the Make Text Fit to Lines option to design forms during 
scanning and import. Generally, you would want to use the Flow Text 
Across Lines option when formatting text and circle text objects.

Redesigning a Table
Use the Table AutoFormat... command to format a selected table. 

To format a table:

1 Select a table.

2 Choose Table AutoFormat... in the Format menu.
The Table AutoFormat dialog box appears.

3 Select the Yes option to enable the Appearance list box.

4 Select an appearance option for your table.

5 Click Next> if it is available to open the Naming window.
Depending on your appearance selection, the Naming window 
may not be available. In that case, click Finish.

6 Select Yes, change the column names if it is available and you 
want to change the column names.

• Select a column name, click Rename, and type in a new name.

• Repeat these steps for each column name to change.
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7 Select Yes, change the row names if it is available and you want to 
change the row names.

• Select a row name, click Rename, and type in a new name.

• Repeat these steps for each row name to change.

8 Select Change Header to Match Field Names if you want the header 
to have the same name as its corresponding column/row.

9 Click Finish to apply the changes to your table.

Aligning Objects
Use the Align commands in the Format menu or the corresponding 
buttons in the Arrange toolbar to move and align multiple selected 
objects. See “The Arrange Toolbar” on page 6-4 for information about 
each button in the toolbar.

Each selected object aligns to the edge of its bounding box, the 
imaginary box that surrounds all objects. A bounding box appears when 
you select an object and hold down the mouse button. Objects align to 
the outermost selected object.

To align objects:

1 Select the objects to align.

2 Choose Align in the Format menu and an alignment command 
in its cascading menu, or click the appropriate button in the 
align toolbar.

• Select Left to align all selected objects by their left edges.

• Select Right to align all selected objects by their right edges. 

Bounding box
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• Select Center Horizontally to align the selected objects by their 
horizontal centers.

• Select Top to align all selected objects by their top edges.

• Select Bottom to align all selected objects by their bottom 
edges. 

• Select Center Vertically to align the selected objects by their 
vertical centers.

The objects align according to the chosen command.

Sending Objects Front or Back
You can use the Bring to Front or Send to Back commands in the Format 
menu to layer overlapping objects.

Choose Bring to Front to move one or more selected objects in front of all 
objects on a form.

Choose Send to Back to move one or more selected objects behind all 
objects on a form.

Horizontal centers’ 
alignment midpoint

Horizontal centers

Vertical centers’ 
alignment midpoint

Vertical centers
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Changing Tab Order
Tab order is the order in which the cursor moves from field to field on a 
form in Fill View. You may want to change tab order if you have added, 
deleted, or moved fillable objects in Design View.

To change tab order:

1 Click the Tab Order button in the standard toolbar or choose 
Tab Order... in the Tools menu.
The Tab Order window appears and numbers appear by each 
object on the form. Both indicate current tab order.

2 Select the field to reorder.
Note that the corresponding object on the form is selected.

3 Reorder the field in one of the following ways:

• Select a field in the window and drag it up or down to change 
its tab order.

• Click the Move Up button to move the selected field up. Click 
as many times as needed to move it into place.

• Click the Move Down button to move the selected field down. 
Click as many times as needed to move it into place.
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• Click Auto Order to place all fields in the original creation 
order on a form designed by OmniForm during scanning or 
import.
If you created the form in OmniForm, the program uses 
“smart” auto ordering. OmniForm generally reorders fields 
from left to right and top to bottom.

• Click a field with a triangle in front of it to display its list of 
contained fields.
A table, for example, opens to display a list of cells. You can 
click each cell to display the object(s) it contains. You cannot 
change cell order, but you can change tab order within a cell 
if it contains multiple fillable fields.

The corresponding tab order numbers on the field change 
when you reorder a field in the Tab Order dialog box.

4 Repeat for each field you want to reorder.

5 Click the Tab Order button in the standard toolbar or choose 
Tab Order... in the Tools menu to close the Tab Order window.

Placing Objects in Table Cells
Each table cell contains one fill text object by default (except for column 
headers which contain a text object). A cell can contain more than one 
object, fillable or non-fillable.

To place objects in a table cell:

1 Select a tool in the drawing toolbar.

2 Move the cursor over the cell to fill so that it highlights.

3 Click to place the object in the cell, or hold down the mouse 
button and draw an object of the size you want.

To resize an object to fit a cell exactly:

1 With the object in the table cell still selected, choose Size and 
Position in the Format menu.
The Size and Position dialog box appears.
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2 Select Snap Object(s) to Fit Table Cell.

3 Click OK.

4 The object resizes to fit the cell exactly.

Converting an Object
You can convert any selected object to another type of object. You might, 
for example, want to convert objects in table cells to check boxes.

Be careful when converting objects in an existing form. If the old object 
contained information, you will permanently lose that object’s 
information in every record.

You can also convert objects that were not defined properly during 
import; for example, OmniForm might define a line with space above it 
as a fill text field. You could convert this to a line.

To convert a selected object:

1 Choose Convert... in the Edit menu.
The Convert dialog box appears.

2 Select an object type in the list box and click OK.
The object is converted.

Use the Select Special... command in the Edit menu to select multiple 
objects to convert.
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Using the Scrap Album
This section describes the OmniForm Scrap Album and how to use it.

What is the Scrap Album?
The Scrap Album is a convenient place to store frequently used or 
complex objects. Objects stored in Scrap Albums are called scraps. You 
can copy these scraps into any form. You can use one of the several Scrap 
Album files provided with OmniForm or create your own.

Opening a Scrap Album
1 Choose Scrap Album in the Tools menu.

The Scrap Album opens.

2 Select a Scrap Album to view in the Scrap Album pop-up menu, 
or create your own.

See “Creating a New Scrap Album” on page 6-46 for information.

Scrap Album Commands Current Scrap Album

Stored graphic file 
(a scrap)
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Copying Objects to the Scrap Album
1 Open the desired Scrap Album.

2 Select one or more objects on your form and drag them into the 
Scrap Album.
Alternatively, select one or more objects and choose Paste Scrap 
in the Scrap Album Commands icon menu.

Small thumbnails of the objects appear as Scrap 1, Scrap 2, and so forth 
in the Scrap Album.

Placing Scraps in a Form
1 Open the desired Scrap Album.

2 Select a scrap and drag it into your form.
Alternatively, select a scrap and choose Copy Scrap in the Scrap 
Album Commands icon menu.

You can only select one scrap at a time. The selected scrap appears as the 
original object in your form.

Renaming a Scrap
1 Select a scrap.

2 Choose Rename Scrap in the Scrap Album Commands icon 
menu.

3 Type a new name for the scrap and press Enter to accept the 
name.

Press the esc key to cancel the command and leave the name as it is.
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Deleting a Scrap
1 Select a scrap.

2 Select Delete Scrap in the Scrap Album Commands icon menu.
You can also press the Delete key to delete a selected scrap. 
OmniForm prompts you to confirm your choice.

You cannot undo the Delete Scrap command!

Creating a New Scrap Album
1 Select New Scrap Album... in the Scrap Album icon pop-up 

menu.
The New Scrap Album dialog box appears.

2 Type a name in the Scrap Album Name text box.

3 Click OK.
A new, empty Scrap Album appears.

Renaming a Scrap Album
1 Open the Scrap Album to rename.

2 Choose Rename Scrap Album... in the Scrap Album Commands 
icon menu.

3 The Rename Scrap Album dialog box appears.
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4 Type a name in the New Name text box.

5 Click OK.
The new Scrap Album name appears in the Scrap Album pop-
up menu.

Deleting a Scrap Album
1 Open the Scrap Album to delete.

2 Choose Delete Scrap Album in the Scrap Album Commands icon 
menu.

3 OmniForm prompts you to confirm your choice.

You cannot undo the Delete Scrap Album command!

You can also delete a Scrap Album file directly from the hard drive. 
Scrap Album files are stored in Scrap  Album  folder in the OmniForm  
folder. Always close OmniForm before deleting any OmniForm files 
from the hard drive.

Changing the Scrap Album View
1 Choose View in the Scrap Album Commands icon menu.

2 Select a view in its cascading menu.

• Choose Icons to view the scraps as thumbnails of the stored 
objects.

• Choose List to view the scraps as a list.
Scraps are listed in creation order in both Icon and List views.
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Chapter 7

Filling a Form

This chapter describes what kinds of fields a form can contain, how to 
fill those fields, how to move through fields on a form, and how to use 
the standard toolbar.

See Chapter 5, OmniForm Procedures, if you need information on how 
to start working with a form. You must first open, scan, or import a form 
in order to fill it.

This chapter contains the following sections:

• The Fill View Window

• Filling Fields

• Spell Checking

• Moving Through Fields

• Saving in Fill View
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The Fill View Window
This section describes the standard toolbar and its commands. The 
standard toolbar is the only toolbar in Fill View. It is somewhat different 
than the standard toolbar in Design View.

The Standard Toolbar
Use the standard toolbar for basic file operations such as saving and 
printing. Use it also to move through records in a database.

All these buttons correspond to menu commands of the same name. 
Clicking a button is the same as choosing its corresponding menu 
command.

Click the Help button and click on any toolbar button to see its function.

Standard toolbar

New

Open

Save

Scan

Form 
Assistant

Print Cut

Copy

Paste

Design

Fill

Zoom

Highlight 
Fill Areas

First 
Record

Previous 
Record

Record 
Number

Next 
Record

Last 
Record

New 
Record

HelpSpelling 
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Filling Fields
This section describes each type of fillable field in OmniForm, how to fill 
it, and how to check spelling. It contains the following topics:

• Fill Text

• Comb

• Check Box

• Circle Text

• Table

• Fill Graphic

• List Fields

• Fields Defined by a Calculation

• Field Validation

These instructions assume that the cursor is already in a field.

The way information is displayed in a field depends on the current form 
language selection and object definition. See “International Settings” on 
page 5-22 and “Defining Objects” on page 6-16 for detailed information.

Fill Text
Enter characters in a fill text field: letters, numbers, symbols, dates, and 
so forth. Fill text fields can contain any sort of textual information.

Comb
Enter characters in a comb field: letters, numbers, or symbols 
appropriate to the field. Phone numbers and zip codes are commonly 
used comb fields. A comb field consists of individual comb elements. 
Each element can contain a different number of characters.

You do not have to tab from element to element in a comb field. Just type 
the required amount of information and OmniForm automatically 
moves the cursor to the next element as appropriate.

prefill 
element

3-character 
element

prefill 
element

8-character 
element
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Check Box
Click a check box field to fill it. A check box field can be defined to 
contain one of three elements: a check mark, an X, or a fill. If OmniForm 
designs your form and recognizes a check box, it defines the box to 
contain an X by default.

Check boxes are commonly used for Yes/No questions and for selecting 
an item in a group, as in the two examples below:

Check boxes may be grouped; this means that only one can be selected. 
Selecting one check box automatically deselects another checked box in 
the group as in the example below.

Circle Text
Click a circle text field to fill it. A border appears around the filled field. 
A circle text field can contain text and other characters, or it can function 
much like a check box (see “Check Box,” above).

Table
A table field consists of individual cells. Table cells are fill text fields by 
default. Enter characters in these cells just as you would in fill text fields.

Check Fill
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A table cell can also contain any other type of field, even multiple fields 
of the same or different types. In the example below, the table cells on the 
right contain check box fields.

The user clicks this cell to fill it in the same way as a check box field. See 
Chapter 6, Designing a Form, for more information on tables.

Fill Graphic
This section describes both how to import a graphic into a fill graphic 
field and how to delete a graphic in a fill graphic field. 

To import an existing graphic:

1 Click the fill graphic field or tab to the field and press the Space 
bar.
The Fill Graphic dialog box appears.

2 Select Graphic File in the Source pop-up menu.

3 Enter a file name.

• Click Select if you need to locate a file.
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• Select a file format in the Files of Type pop-up menu.

• Select a file and click Open to return to the Fill Graphic dialog 
box.
The file name appears in the File Name text box.

4 Select an option in the Options pop-up menu.

• Select Maintain Original Size to import the graphic without 
changes.

• Select Scale Proportionally to fit the graphic in the fill graphic 
field while keeping its exact proportions.

• Select Stretch to Fit to change your graphic’s original shape 
and size to fit in the fill graphic field.

Depending on the shape of the fill graphic field, your graphic 
may be stretched or compressed. You might want to use this 
for special effects.

• Select Specify Width & Height to specify the graphic’s size. 
Enter measurements for your graphic in the Width and Height 
text boxes under Size. The size of the fill graphic field is 
displayed at the bottom of the Fill Graphic dialog box.
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If you enter a size larger than the fill graphic field, only part of 
the graphic will be visible.

5 Enter offset measurements under Offset if you want.
This is useful if you want to position a graphic exactly in the 
field, crop a large graphic, or move the graphic away from a 
field border that would interfere with its design.

• Enter a number in Left to specify how far from the left side of 
the field to place the graphic.

• Enter a number in Top to specify how far from the top of the 
field to place the graphic.

6 Select or deselect Transparent.

• Select Transparent if you want to be able to see information 
behind the graphic.
Whether a graphic prints transparently depends on your 
printer driver. See your printer documentation for 
information.

• Deselect Transparent if you want the graphic to be opaque. 
You will not be able to see information behind the graphic.

7 Click OK.
OmniForm imports the graphic and displays it in the fill 
graphic field.

To delete an existing graphic:

Select None in the Source pop-up menu and click OK to delete an existing 
graphic from a fill graphic field.

List Fields
Fields can contain a list of selectable entries. A pop-up menu arrow 
appears when the cursor is in the field.

Click the arrow to open the list

Select an entry. The entry appears in the field.
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Fields Defined by a Calculation
The only time you would notice a calculation in Fill View is when a field 
fills in automatically. 

In the example below, the TOTAL field automatically added the 
amounts entered in the first and second fields. The TOTAL would 
increase if the third and fourth fields were filled as well.

You define a calculation on a field in Design View. See Chapter 9, Using 
Calculations, for detailed information on calculations.

Field Validation
Fill text fields can be configured by the creator to:

• Require that you enter information in a field and do not leave it 
blank.

• Require that you enter specific information in a field.

• Require both of the above.

This is field validation and ensures that information entered in a form is 
consistent. For example, you may be required to enter a date in a 
validated Date field. You would receive a reminder prompt from 
OmniForm if you attempted to enter anything other than a date.

• Click No to return to the field and enter the expected information.

• Click Yes to override field validation.

See “Set Validation Options” on page 6-20 for detailed information on 
field validation.
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Spell Checking
Use the spell-checking feature to verify that field entries are correct.

Before you check spelling make sure you have selected the correct 
language for your form in the Options dialog box as described below.

Proceed to “Spell Checking Your Form” on page 7-11 if: you have a 
single-language form; the Current Form language selection is correct; 
you have a dictionary for that language.

Checking the Current Form Language Selection
1 Choose Preferences... in the Tools menu.

The Preferences dialog box appears.

2 Click the International tab.

3 Click Current Form.
You cannot change the Language selection for the current form 
in Fill View.

4 Click Cancel and proceed to “Changing the Language 
Selection” on page 7-10 if the language selection for Current 
Form is incorrect.

5 Click OK if the language is correct.
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Changing the Language Selection
1 Click the Design button in the standard toolbar or choose 

Design in the View menu.

2 Choose Preferences... in the Tools menu.
The Preferences dialog box appears.

3 Click the International tab if it is not displayed.

4 Select the correct language for your form in the Current Form 
pop-up menu.
This also selects the correct dictionary for spell checking.

5 Click OK.

6 Click the Fill View button in the standard toolbar or choose Fill 
in the View menu.

7 Proceed with the spell check as described in “Spell Checking 
Your Form” on page 7-11.

See “International Settings” on page 5-22 for more information.

Multiple Languages
You may have scanned in a form with the Allow Multiple Languages 
option selected (see “The Allow Multiple Languages Option” on page 
5-25). You have two choices for effective spell checking:

• Decide which language makes up the majority of your form and 
select that language as the Current Form selection.
This is faster but less accurate.

• Spell check only the portion of the form that the Current Form 
selection matches. Change the Current Form selection to match 
another portion of the form, spell check that portion, and so on 
for each language in the form.
This is more time-consuming but more accurate. Remember that 
changing the Current Form selection could cause OmniForm to 
reformat data already entered in Fill View.

Dictionaries
Dictionaries for all supported languages are included in the 
International English version of OmniForm. The United States version 
has a standard English dictionary. In the U.S., you can call 800-654-1187 
to order additional dictionaries. You must have a dictionary that 
matches the language of a form to spell check it.
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Spell Checking Your Form
1 Click the Spelling button in the standard toolbar, choose Check 

Spelling... in the Tools menu, or use the Command= shortcut.
The Spelling dialog box appears with the first questionable 
word after Unknown Word.

• The suggested spelling, if there is one, appears in the Change 
To text box.

• Other suggested spellings appear in the Suggestions list box.

2 Select one of the following options:

• Click Ignore to allow the questioned word to remain as is and 
continue the spell check.

• Click Ignore All to ignore all instances of the questioned word 
in the form and continue the spell check.

• Change the word in the Change to text box.
You can retype this word or select a word in the Suggestions 
list to place it in the Change to text box.

• Click Change to accept the spelling in the Change to text box 
and continue the spell check.

• Click Change All to accept the spelling in the Change to text 
box, change all instances of the questioned word in the form, 
and continue the spell check.

• Click Add to add the word to the user dictionary and continue 
the spell check. The added word will not be questioned again 
in the current form or in any other form.

• Click Suggest to place the first word in the Suggestions list box 
in the Change to text box. The list of suggestions may change 
to offer a list of the closest matches to that word.

• Click Close to end the spell check.

3 Click OK in the dialog box that tells you the spell check is done.
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Moving Through Fields
You can click in any field to place the cursor there or you can use the 
following keyboard commands to move the cursor within a form.

Saving in Fill View
If you close a form after making data entries in Fill View (but no changes 
in Design View) OmniForm does not prompt you to save the changes. 
This is because OmniForm saves automatically in Fill View.

OmniForm saves after numerous user actions: moving from one record 
to another, printing or closing a form, before importing or exporting 
data, and in many other situations. You would rarely need to use the 
Save command in Fill View except to:

• Save changes to the entire form, both changes made in Design 
View and data entered in Fill View.

• Save information entered in the Print offsets for data option in the 
Print dialog box.

Use the Save As... command in Fill View to save a form to another 
location or with a different file name.

Action Key Combination

Place the cursor in a field When a form first opens, press the Tab key to place 
the cursor in the first field.

Next field Press the Tab key.

Previous field Press Shift-Tab.

Next line in a fill text field Press Return to create a new line in a multiple-line fill 
text field. 

End of a line in a fill text field Press Command-right arrow.

Beginning of a line in a fill text field Press Command-left arrow.

End of text in a fill text field Press Option-down arrow.

Beginning of text in a fill text field Press Option-up arrow.

Next word in a field Press Option-right arrow.

Previous word in a field Press Option-left arrow.

Next page in a form Press Option-page up.

Previous page in a form Press Option-page down.

First page in a form Press Option-home.

Last page in a form Press Option-end.
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Chapter 8

Managing an
OmniForm Database

This chapter introduces basic database concepts. It explains what a 
database is, how to create one automatically by scanning or importing a 
form, how to create and maintain records in a database, and how to 
protect the vital information entered in your database records.

This chapter contains the following sections:

• What is a Database?

• Managing Database Records

• Protecting Your Database

See Chapter 6, Designing a Form, for detailed information on defining 
fields in a form so that all your records contain the proper information.

See Chapter 9, Using Calculations, for detailed information on using 
calculations. Calculations automate data entry and reduce potential user 
errors.
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What is a Database?
A database is a collection (file) of information stored as individual 
records. Each record uses the same form design but can contain different 
information in its fields.

OmniForm automatically creates a database when you scan in or import 
a form. As soon as you fill in the form, it becomes the first record in a 
new database. Any user of this database can create a new, blank form 
using the record as a template and then fill in new information to create 
another record. This makes it possible to store a large amount of similar 
information and retrieve it quickly and easily.

The user who designed 
this daily planner 
created a new record 
each day. So far, this 
user has a database 
containing three 
records.
The user can sort these 
records by date or 
other entries and 
search for information 
in any field.

Record 1

Record 2

Record 3
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Managing Database Records
This section tells you how to create a database of records and manage its 
information. It contains the following topics:

• Creating New Records

• Duplicating Records

• Moving Through a Database

• Searching Records for Information

• Sorting Records

• Recalculating Records

• Deleting Records

• Exporting Information

• Exported Data and Shared Forms

• Importing Information

The form you open or scan becomes the first record of a new database 
once you fill in a field. You can then create new records with the same 
layout and fields and fill them with different information.

For step-by-step instructions on creating a database and performing 
basic functions, see “Tutorial 4 — The OmniForm Database” on page 
3-46.

Creating New Records
As long as you have a form open and fill at least one field in the current 
record, you can create new records.

You cannot create a new record if data protection is turned on. See 
“Protecting Your Database” on page 8-26 for information.
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To create a new record:

1 Open or scan in a form.

2 If the form opens in Design View, click the Fill button in the 
standard toolbar or choose Fill in the View menu to switch to 
Fill View.

3 Click in a field with the cursor or press Tab to place the cursor 
in the first fillable field.

4 Enter information in the field.

OmniForm cannot create a new record until you fill at least one field 
in an empty form. A form with fields filled only by automatic 
calculations (such as a date field) is still considered empty by 
OmniForm. You must fill at least one field manually before you can 
create a new record.

5 Press Tab to move to the next field.
Because a field is filled, you now have a database with one 
record in it.
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6 Fill in as many fields as you like.

7 Click the New button in the standard toolbar or choose Go To in 
the Records menu and New in its cascading menu.
OmniForm creates and displays a new, empty record with the 
same form design as the first one.

8 Fill in this record with the appropriate information.

9 Continue to create new records in this way as you need.

Duplicating Records
You can duplicate any record in a database as long as it has information 
entered in at least one field. This is useful if you want to create records 
that will contain much of the same information.

A form with fields filled only by automatic calculations (such as a date 
field) is still considered empty by OmniForm. You must fill at least one 
field manually before you can create a new record.

You cannot duplicate a record if data protection is turned on. See 
“Protecting Your Database” on page 8-26 for information.
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To duplicate a record:

1 Open or scan in a form.

2 If the form opens in Design View, click the Fill button in the 
standard toolbar or choose Fill in the View menu to switch to 
Fill View.

3 Fill in the information you want duplicated.

4 Choose Duplicate Record in the Records menu.
OmniForm duplicates and displays the new record.

To change an entry in a filled field, tab to a field or drag your cursor over 
the entry to highlight it and then type a new entry.

Moving Through a Database
Once you have multiple records, use the Record buttons in the standard 
toolbar or the commands in the Records menu to move through a 
database.

First Record

Click the First Record button or choose Go To in the Records menu and 
First in its cascading menu to move to the first record in your database. 

Previous Record

Click the Previous Record button or choose Go To in the Records menu 
and Previous in its cascading menu to move to the record before the one 
you are viewing. If you are viewing record 3, for example, the previous 
record is record 2.

Record Number

The Record Number text box displays the number of the current record. 
Follow these steps to move to another record:

1 Highlight the number in the Record Number text box.

2 Type a new number.

3 Press Return to move to that record. 

First 
Record

Previous
Record

Next 
Record

Record
Number

Last 
Record

New 
Record
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Next Record

Click the Next Record button or choose Go To in the Records menu and 
Next in its cascading menu to move to the record after the one you are 
viewing. If you are viewing record 3, for example, the next record is 
record 4.

Last Record

Click the Last Record button or choose Go To in the Records menu and 
Last in its cascading menu to move to the last record in your database.

New Record

Click the New Record button or choose Go To in the Records menu and 
New in its cascading menu to create and move to a new record.

Searching Records for Information
A database can contain a tremendous amount of information. If you had 
to search manually through hundreds of records in your database to 
find a particular record, it could take hours. An OmniForm search, 
however, can retrieve records with the information you need in seconds.

These retrieved records are called a found set. You can print, fax, or 
export the found set if you wish.

To search for information:

1 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

2 Choose Search... in the Records menu.
The Search dialog box appears.

The field to search

How to search

What to search for

Which records to search
Managing an OmniForm Database  8-7



Managing Database Records
3 Select a field name in the Field Name pop-up menu.
This is the field that contains the information you want to find. 
All the fields in your form are listed here.

To simplify searches, give each field a unique name. Otherwise, you 
will have fields named FillText1, FillText2, and so forth, making it 
difficult to determine which fields contain what information. See 
“Defining Objects” on page 6-16 for detailed information.

4 Select a condition in the Condition pop-up menu.
A condition describes how to look for information entered in 
the Value text box. For example, suppose you entered the words 
Franich  & Halsey  in the Value text box. 
The following bulleted items show the results of a search using 
each available condition option. Proceed to step 5 on page 8-10 
if you already know which condition to select.

•  is equal to: find an exact match of the Value entry.
This finds records that have Franich & Halsey and nothing else 
in the Customer field.

•  is not equal to: find anything but the Value entry.
This finds records that have anything but Franich & Halsey in 
the Customer field.

•  is greater than: find records of greater value than the Value 
entry.
This finds records that have entries in the Customer field later 
in the alphabet than the entry, for example, Franklin or 
Gallatron, Inc.
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•  is greater than or equal to: find records of equal or greater value 
than the Value entry.
This search finds records that have entries in the Customer 
field beginning with the entry name itself up to the letter Z. 

•  is less than: find records of lesser value than the Value entry.
This finds records that have entries in the Customer field 
beginning with a symbol, a number, or letters earlier in the 
alphabet than the entry, for example, France or Dharma Dogs. 

•  is less than or equal to: find records of equal or lesser value than 
the Value entry.
This finds records that have entries in the Customer field 
beginning with a symbol, a number, or the letter A up to the 
entry name itself.

•  begins with: find records that begin with the Value entry.
This search finds records that have Franich & Halsey as the 
entry or at the beginning of an entry in the Customer field.

•  does not begin with: find records that do not begin with the 
Value entry or that do not contain the value entry at all.
This search finds records that do not have Franich & Halsey as 
the beginning of the entry in the Customer field or records that 
do not contain Franich & Halsey at all.

•  ends with: find records that have the Value entry at the end of 
the selected field.
This search finds records that have Franich & Halsey as the 
entry or at the end of an entry in the Customer field.
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•  does not end with: find records that do not have the Value entry 
at the end of the selected field or records that do not contain 
the value entry at all.
This search finds records that do not have Franich & Halsey at 
the end of an entry in the Customer field.

•  contains: find records that contain the Value entry.
This search finds records that have Franich & Halsey entered 
anywhere in the Customer field.

•  does not contain: find records that do not contain the Value 
entry.
This search finds records that do not have Franich & Halsey 
entered anywhere in the Customer field.

•  is empty: find records that have no entry in the selected field.
The Value text box is disabled if this is selected.

•  is not empty: find records that have an entry of any sort in the 
selected field.
The Value text box is disabled if this is selected.

5 Type the text to find in the Value text box.
Information is not case-sensitive. Typing Los  Gatos  is the 
same as typing los  gatos .
How OmniForm searches for the information in the Value text 
box depends on the selection in the Condition pop-up menu as 
described in the previous step.
8-10  Managing an OmniForm Database



Managing Database Records
6 Select an option under Scope of Search.

• Select Search All Records in the Database to search the entire 
record set.

• Select Only Search Current Record Set to search a subset of 
records. This option is only available when you have a found 
set that is open from a previous search.

7 Click OK.
OmniForm searches for and retrieves all records that contain 
the information you specified in the Search dialog box. 

Under the standard toolbar, OmniForm displays the search 
information and number of records in the found set. If you 
need to narrow the search further, choose Search... again.
You might, for example, want to search the Franich & Halsey 
record set for invoices from a specific month. You can search 
each new subset of records as many times as you need to find 
the specific information you want.
OmniForm maintains the current found set if it retrieves no 
records during a search.

8 Click Clear Search under the standard toolbar to return to the 
full record set when you are done.

Search information: the 
found set contains five 
records. 

Click Clear Search to return 
to the full record set.
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Sorting Records
You can sort records in OmniForm in ascending, descending, or original 
order entry. This is useful for many situations. If you wanted to export 
mailing information, for example, you could sort records by postal code 
to reduce bulk mailing costs, or invoices by date to find the most 
delinquent accounts.

To sort records:

1 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

2 Choose Sort... in the Records menu.
The Sort dialog box appears.

3 Select the field by which to sort in the Field Name pop-up menu.
All the fields in your form are listed here.

To make sorting as easy as possible, give each field a unique name 
after it is created. Otherwise, you could have fields named FillText1, 
FillText2, and so forth, making it difficult to figure out which fields 
contain what information. See “Defining Objects” on page 6-16 for 
detailed information.

4 Select a sort order.

• Select Ascending Order to sort records from least to greatest; 
for example, from A–Z or from 0–100. Symbols precede 
numbers which precede letters: $40, 40, Forty.

• Select Descending Order to sort records from greatest to least; 
for example, from Z–A or from 100–0. Letters precede 
numbers which precede symbols: Forty, 40, $40.

• Select Original Order Entered to sort records in the order in 
which you originally entered information in the selected field.
This is useful to view the history of information entered.
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5 Click OK.
OmniForm sorts the records in the order indicated.

Recalculating Records
Recalculating records applies any new or changed calculations to 
selected records in a database. Until you use the Recalculate... command, 
new or changed calculations apply only to new records.

See Chapter 9, Using Calculations, for detailed information on creating 
calculations.

This command reapplies all existing calculations to the selected records. 
You may not always want this to happen.

For example, suppose you changed the mileage calculation in an 
expense form to reflect the latest rate. All new records would use the 
new calculation and reflect this rate. You do not want older records to 
use the new calculation because the original rate was correct at the time.

If you recalculated all records after adding the new calculation to the 
expense form, the mileage rates on your old records would also change. 
They would then be incorrect. To prevent this, you could search the 
records for those records newer than the date you changed the mileage 
calculation, and apply the new calculation only to the newer records.

See “Searching Records for Information” on page 8-7 for information on 
searching.

You cannot recalculate records if data protection is turned on. See 
“Protecting Your Database” on page 8-26 for information.

To recalculate records:

1 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

2 Choose Recalculate... in the Records menu.
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The Recalculate dialog box appears.

3 Select the records to recalculate.

• Select All Records to apply the new or changed calculation to 
either the current found set or to every record in the database 
if the entire record set is open.

• Select Current Record Only to apply the new or changed 
calculation to just the record you are viewing.

• Select From/To to apply the new or changed calculation to a 
range of records.
Enter a number in the From and To text boxes. If you entered 1 
in the From text box and 5 in the To text box, for example, 
OmniForm would recalculate the first five records in your 
database or found set.

4 Click OK.
OmniForm recalculates the records according to your 
specifications.

5 Click OK in the dialog box that informs you how many records 
were recalculated successfully.

You cannot undo a recalculation!
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Deleting Records
This section describes how to delete one or more records in a database. 
Do this to get rid of old, unwanted, or duplicate records.

You can export information from a record first if you want to delete a 
record but save its data. See “Exporting Information” on page 8-16 for 
instructions.

You cannot delete a record if data protection is turned on. See 
“Protecting Your Database” on page 8-26 for information.

To delete the current record:

1 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

2 Choose Delete Record in the Records menu.
A warning dialog box appears. 

3 Click Yes to delete the current record permanently.

You cannot undo a record deletion!

To delete all records:

1 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

2 To delete a found set of records instead of all records, click 
Search... in the Records menu to find the records to delete.
See “Searching Records for Information” on page 8-7 for more 
information.

3 Choose Delete All Records in the Records menu.
A warning dialog box appears. 

4 Click Yes to delete all records or the found set permanently.

You cannot undo a record deletion!
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Exporting Information
This section explains the benefits of exporting information, how to 
prepare for export, and how to export information from an open 
OmniForm form.

See “Importing Information” on page 8-21 for information on how to 
import information into a database.

The Benefits of Exporting Information

Export information from records to:

• Share information with other OmniForm databases. 
Information exported as a database file takes up considerably less 
disk space than the database itself. It can be copied more quickly 
than the entire database.

• Share information between different databases.
You might have a database and decide you need information 
already entered in an OmniForm database. Simply export the 
needed information from OmniForm in the appropriate format 
and use the other database’s commands to import it.

• Save other database users the time of entering data manually by 
sending them an OmniForm Data or other database file.

Preparing for Export

During import, you will link field names in the exported data file to field 
names in the import database. This tells OmniForm where to place the 
field information. If possible, try to:

• Match field names in the exported data to field names in the 
import database.

• Match field order in the exported data to field order in the import 
database.

This makes it easier to figure out which information will go in which 
fields when you link the fields on import.

For example, suppose you export information in the fields Customer, 
Title, and Product, in that order. You have the same field information in 
the import database, but the fields are named What Bought, Name, and 
Position, in that order. You could link CustomerÖName/TitleÖPosition/
ProductÖWhat Bought easily but importing hundreds of fields with 
different names and field order would be difficult and time-consuming.

See Chapter 6, Designing a Form, for information on naming and 
reordering fields.
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To export information:

1 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

2 Choose Export... in the File menu.
The Export Setup dialog box appears.

3 Select a database file type in the Export To pop-up menu.

• Select OmniForm to export information to an OmniForm Data 
file.

• Select Text File to export information to a tab- or comma-
separated text file.
See “Text File Export Options” on page 8-19 for more 
information on this dialog box.

4 Click OK.
The Export As dialog box appears.

• A file name appears in the Save as text box.
The file is named by default with the name of the currently 
open database. You can change the file name if you want.
Managing an OmniForm Database  8-17



Managing Database Records
The filename limit on the Macintosh is 32 characters, so long file names 
will be truncated. Do not change the filename to be the same name as an 
open file.

5 Select a location for the file.

6 Click Save.
The Export dialog box appears.

All the fields in your currently open database appear in the 
Fields in list box.

7 Select each field that contains the information to export and 
click Add>> to move it to the Fields to Export list box.

• Shift-click to select or deselect multiple adjacent records, or 
hold down the mouse button and drag the cursor over 
adjacent records.

• Ctrl-click to select or deselect multiple non-adjacent records.
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• Select a field on the right and click <<Remove if you decide not 
to export its information.

8 Click Range... to open the Record Range dialog box if you want 
to specify a range of records to export.

Otherwise, OmniForm exports all records by default.
• Select All Records to export all records in the current database.

• Select Current Record Set to export the current found set of 
records. This option is available after a search.
Type the first record number to export in the From text box 
and the last record number to export in the To text box.

• Click OK to return to the Export dialog box.

9 Click OK.
OmniForm exports the information in the selected fields to the 
specified file.

10 Click OK in the dialog box that tells you how many records 
were successfully exported.

Text File Export Options

Several options are available after you select Text File in the Export Setup 
dialog box.
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• Select Commas in the Fields Separated By: pop-up menu to export 
information to a comma-separated text file. Information in each 
field will be separated by a comma and enclosed in quotes.

• Select Tab in the Fields Separated By: pop-up menu to export 
information to a tab-separated text file. Information in each field 
will be separated by a tab and enclosed in quotes.

• Select Include Header Record if you want the first line in the text 
file to list the name of each field exported.

If you export more than one record, each record in the text file will be 
separated by a line feed (return).

Exported Data and Shared Forms
This section explains how to use OmniForm Data files to open shared 
forms and how to set up a shared form location. A shared form is one 
other users can access.

When you export OmniForm data from a form, the form’s file name is 
stored inside the Data file. OmniForm uses the file name information as 
well as file location information in the Options dialog box to locate and 
open a copy of the original form. The form automatically imports 
information from the Data file. This is useful for sharing data, especially 
if you want to send another user just part of a database.

To set up the shared form location:

1 Select or create a folder for your shared OmniForm forms.

2 In OmniForm, choose Preferences... in the Tools menu.
The Preferences dialog box appears.

3 Click the File Locations tab.

4 Select Shared Forms in the File Types pop-up menu.

5 Select the location of your shared form(s) by clicking the 
Select... button to locate and select a folder.

6 Highlight and click Select “folder name.”

7 Click OK.

All OmniForm users must enter the same file location in the 
Preferences dialog box to use shared forms.
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To export the data:
• Use the Export... command in the File menu to create an 

OmniForm Data file. See “Exporting Information” on page 8-16 
for information.

To use an OmniForm Data file to open a shared form:

1 Locate the OmniForm Data file to use.

2 Double-click the Data file.
A copy of the shared OmniForm Form from which the 
OmniForm Data file was exported opens. OmniForm 
automatically imports the information in the OmniForm Data 
file into the form.

Importing Information
This section explains how to import field data (information) into an 
OmniForm database from another database source. You can import data 
from three sources:

• Another OmniForm Form
The selected form must be closed.

• An OmniForm Data file
This contains information exported from an OmniForm database.

• A comma- or tab-separated text file.
Each record must be separated by a line feed (return).

Data consists of information entered in fields, such as text, check marks, 
and calculations. Importing data saves you the time of entering the same 
data manually and allows you to share data with other database users.

You must first export data from another database in order to import it 
into OmniForm. See “Exporting Information” on page 8-16 for 
information. See your database documentation if you are exporting 
from another database program. 

You cannot import information if data protection is turned on. See 
“Protecting Your Database” on page 8-26 for information.
Managing an OmniForm Database  8-21



Managing Database Records
To import field information:

1 Open or scan in a form.

2 If you are in Design View, click the Fill button in the standard 
toolbar or choose Fill in the View menu to switch to Fill View.

3 Choose Import... in the File menu.
The Import Setup dialog box appears.

4 Select the type of information to import in the Import From pop-
up menu.

• Select OmniForm Database to import information from an 
OmniForm Form or from an OmniForm Data file.

• Select Text File to import information from a tab- or comma-
separated text file.
See “Text File Import Options” on page 8-25 for more 
information on this dialog box.

5 Click OK.
The Select Import File dialog box appears.

6 Locate and select the file to import.
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7 Click Open.
The Import dialog box appears.

• Fields in the open OmniForm database appear on the left.

• Fields you can import from the other database appear on the 
right.

8 Link fields on the left to fields on the right.
This tells OmniForm which field data to import from the other 
database and where to import it in the current database.

• To link individual fields, select a field on the left, select its 
corresponding field on the right, and click Link.

• Click Auto to automatically link all fields with the same name.
Some fields will not have matching names but contain the 
same information. Or, you may not want to import all fields.
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Linked fields appear in the Links list box.

• Select a link in the Links list box and click Unlink to unlink it.

• Click Unlink All to unlink all fields.

• Select Recalculate Imported Records According to Form’s 
Calculations when it is selectable to apply existing calculations 
to the imported records.

9 Click Range... to open the Record Range dialog box to specify a 
range of records to import.
Otherwise, OmniForm imports all records by default.

• Type the first record number to import in the From text box and 
the last record number of the range to import in the To text box.

• Click OK to return to the Import dialog box.

10 Click OK when you are done linking fields.
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OmniForm imports the information into the selected fields, 
creating as many new records as necessary in the process. 

11 Click OK in the dialog box that tells you how many records 
were imported successfully.

You can import Data files created in the Windows version of OmniForm. 
Convert the Windows file to a Macintosh-compatible format using PC 
Exchange before you import it.

Text File Import Options

Several options are available after you select Text File in the Import Setup 
dialog box.

• Select Commas in the Fields Separated By: pop-up menu to import a 
comma-separated text file. Each item separated by a comma will 
be imported into an individual field. Items enclosed in quotes 
will be imported as one field.

• Select Tab in the Fields Separated By: pop-up menu to import a tab-
separated text file. Each item separated by a tab will be imported 
into an individual field. Items enclosed in quotes will be 
imported as one field.

• Select Include Header Record to have the import file’s field names 
appear in the Fields in list box in the Import dialog box. (The field 
names must already be listed in the import file.)
This is useful for linking fields. If you deselect this option, the 
field names will be generic: Field 1, Field 2, and so forth.

If you export more than one record, each record in the text file must be 
separated by a line feed (return) in order for OmniForm to interpret it as 
an individual record.
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Protecting Your Database
This section describes how to protect both your data and form design 
from deletions or changes.

Remember, the form layout you create in Design View is used by every 
database record. Changes made in Design View affects all records in Fill 
View. This is important to remember if the database has multiple users. 
Deleting a fillable field in Design View deletes all information entered in 
that field in Fill View.

To protect your form or data:

1 If you are in Fill View, click the Design button in the standard 
toolbar or choose Design in the View menu.

2 Choose Protection... in the Tools menu to open the Protection 
dialog box.

3 Select Protect Data, Protect Form, or both.

4 Click OK.

When data protection is on, information is read-only. Users can export 
data or copy text but cannot alter form information in any other way 
such as by filling fields or importing data.

When form protection is on, users can change viewing preferences and 
use most basic file commands such as Print and Save but cannot format 
or redesign the form in any way.

An alert appears if you try to change the form’s design or enter 
information while protection is on.
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OmniForm Filler
You can have other users use the OmniForm Filler program to open any 
OmniForm form. Filler is an easy-to-use version of OmniForm that has 
a Fill View but no Design View. Therefore, Filler users cannot edit the 
form’s design in any way.

The data protection option, when set for a form in OmniForm, is also 
enabled for that form in OmniForm Filler. It cannot be turned off in 
OmniForm Filler.

See “Protecting Your Database” on page 8-26 for detailed information 
on the data protection option.

Contact your local distributor to purchase OmniForm Filler. In the U.S., 
you can call (800) 654-1187 to order OmniForm Filler.
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Chapter 9

Using Calculations
This chapter describes how to use OmniForm’s calculation features. 
OmniForm automatically performs calculations when you fill in the 
appropriate field(s).

Use calculations to automate data entry and prevent errors. For 
example, the average person might find it time-consuming to add a 
column of 100 numbers, and easy to make an error, but OmniForm can 
return an error-free sum in a fraction of a second. All you have to do is 
define the calculation properly and OmniForm does the rest of the work.

This chapter contains the following sections:

• Calculation Overview

• Operators

• Functions
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Calculation Overview
This section gives an overview of how to create calculations. It contains 
the following topics:

• Creating a Calculation

• Calculation Guidelines

• Using the Recalculate... Command

• Usage Conventions

See “Tutorial 3 — Design Your Own Form” on page 3-21 for step-by-step 
instructions on creating a simple calculation.

Creating a Calculation
Calculations are created in Design View. You can create a calculation for 
fill text, comb, check box, and circle text objects.

You must open the calculation toolbar to begin.

To open the calculation toolbar:

1 If you are in Fill View, click the Design button in the standard 
toolbar or choose Design in the View menu.

2 Click the Calculation button in the standard toolbar or choose 
Calculation in the Tools menu.
The calculation toolbar appears.

3 Select a fill text, comb, check box, circle text, or table object in 
your form to activate the toolbar.
The calculation toolbar contains four buttons and a text box.

• Cancel Calculation button
Click this to revert to the last calculation accepted. The text 
box clears if no version was accepted.

• Accept Calculation button
Click this to accept the calculation in the text box.

Click to Edit Calculation — the calculation 
for the selected field appears here.

Accept 
Calculation

Cancel 
Calculation

Calculation 
Builder

Auto 
Calculation
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• Calculation Builder button
Click this to open the Calculation Builder dialog box and 
create your own calculation.

• Auto Calculation button
Click this to have OmniForm attempt to define a calculation 
automatically. OmniForm can determine an auto calculation 
for an entire table in some circumstances.

• Calculation text box
The calculation for the selected field appears here. Click in the 
text box to edit a calculation manually.

4 Create a calculation in one of three ways:

• Use the Calculation Builder to define a calculation.
See “The Calculation Builder” on page 9-3.

• Have OmniForm define a calculation automatically.
See “Auto Calculations” on page 9-5.

• Click in the calculation text box and type a calculation.
Follow the guidelines in “Calculation Guidelines” on page 
9-7. See “Functions” on page 9-11 for examples.

The Calculation Builder

The Calculation Builder dialog box contains operators, a list of all the 
fields in your form, and functions for creating calculations.

To define a calculation with the Calculation Builder:

1 Click the Calculation Builder button in the calculation toolbar.
The Calculation Builder dialog box contains the following:

• Operator buttons
Each button represents an operator. Click a button to insert an 
operator in the calculation text box.
See “Operators” on page 9-9 for detailed information.

• Fields list
This list contains all the available fields in your form. Double-
click a field name in this list to place it in the calculation text 
box, or select it and click Paste.
Alternatively, click any field in your form to insert its name in 
the calculation text box. This is useful if you have many fields 
listed or if they do not have unique names. You can also drag 
the cursor around multiple objects to insert each one.
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• Functions list
This list contains all available functions that can be used in a 
calculation. Double-click a function to insert it in the 
calculation text box, or select it and click Paste.
See “Functions” on page 9-11 for detailed information.

2 Select the operators, fields, and functions that you need for 
your calculation.

3 Click the Accept Calculation button to define the calculation on 
the field and close the Calculation Builder dialog box.

• A calculation is defined on the selected field when you click 
the Accept Calculation button. OmniForm performs the 
calculation automatically in fill mode when the appropriate 
fields are filled.

• You can click the Cancel Calculation button to clear the 
calculation text box or to revert to the last accepted 
calculation.

• You can manually delete entries in the text box and click the 
Accept Calculation button if you want to clear the box 
entirely. This is useful if clicking the Cancel Calculation 
button causes it to revert to a previously accepted version.

4 Click the Calculation button in the standard toolbar or choose 
Calculation in the Tools menu to close the calculation toolbar.
Closing the toolbar also accepts the current calculation.

Operators

List of available 
functionsList of fields in your form
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Example

Suppose you wanted to create a calculation for a Subtotal field in an 
invoice. The Subtotal field is the sum of the Price1 and Price2 fields. There 
is often more than one way to create a calculation. Here are two 
calculations you could create:

• [Price1]+[Price2]  

• Sum([Price1],[Price2])  

Both calculations return the same result. The first calculation is simple 
addition. It is easy for new users to create.

The second calculation uses the Sum function and is more complex than 
the first calculation. This calculation is useful for adding multiple fields 
because you do not need to place the Addition operator between them.

OmniForm automatically inserts the necessary parentheses, brackets, 
and commas when you create a calculation using the Calculation 
Builder. See “Calculation Guidelines” on page 9-7.

Auto Calculations

To create an auto calculation, OmniForm looks for such common field 
names as Quantity, Price, Total, and Sum. It also determines calculations 
based on field type, field names, and column header labels. If you 
selected a field named Total, for example, OmniForm would look for 
fields above the Total field to sum.

This is one reason it is important for fields to have unique names. See 
“Defining Objects” on page 6-16 for detailed information.

1 Select a fill text, comb, check box, circle text, or table object in 
your form to activate the toolbar.
A calculation appears in the calculation text box if one was 
defined for this object before. If so, proceed to step 4.

2 If no calculation appears, click the Auto button in the 
calculation toolbar.
A message tells you if no auto calculation could be created. See 
“The Calculation Builder” on page 9-3 if OmniForm could not 
create a calculation and you want to create your own.
Using Calculations  9-5



Calculation Overview
The Auto Calculation dialog box appears if OmniForm 
proposes an auto calculation.

3 Accept or cancel OmniForm’s proposed calculation.

• Select Apply similar calculation to rest of table to apply the 
proposed calculation to similar fields in a table.

• Click OK to accept the calculation.
The calculation appears in the toolbar’s text box.

• Click Cancel to close the dialog box without creating a 
calculation.

4 Edit the calculation in the toolbar if you need to:

• Click in the calculation text box and make manual changes, or 
click the Calculation Builder button to open the Calculation 
Builder dialog box. See “The Calculation Builder” on page 9-3.

• Click the Accept Calculation button to accept changes.

• Click the Cancel Calculation button to close the Calculation 
Builder and revert to the version created by OmniForm.
You can manually delete entries in the text box and click the 
Accept Calculation button to clear the box entirely. This is 
useful if clicking the Cancel Calculation button causes the 
calculation to revert to a previously accepted version.

5 Choose Calculation in the Tools menu to close the toolbar.
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Using the Recalculate... Command
Recalculating records applies any new or changed calculations to all 
selected records in a database. Until you use the Recalculate... command, 
new or changed calculations apply only to new records or to current 
records whose relevant field entries change. See “Recalculating 
Records” on page 8-13 for detailed information.

Calculation Guidelines
Keep these guidelines in mind as you work with calculations:

• OmniForm automatically inserts list separators, parentheses, and 
brackets when you use the Calculation Builder or the Auto 
button, and when you click the Accept Calculation button.

• OmniForm automatically removes extra spaces (except a space in 
a field name) when it accepts a calculation.
You can insert spaces between operators and after commas when 
creating a calculation if this helps you see it more easily.

• Brackets ( [] ) must enclose a field name that contains a space. 
[ Quantity Ordered ]  * [ Unit Price ]

OmniForm does not automatically insert brackets around a 
manually created field name that contains a space.

• Parentheses ( ()  ) must enclose an entire function.
Sum( [Price1],[Price2] )

This tells OmniForm where the function begins and ends.

• You must insert a comma between fields in a manually created 
function.
Sum( [Price1] , [Price2])

• If you manually enter a decimal number in a calculation, you 
must use the decimal selection selected in the Numbers control 
panel.

• Quotes ( “ ” ) must enclose a text string.
If([Name1]= ” Ann” , ” Dear Ann: ” , ” Dear Customer: ” )

• If you change a field name and that field is part of a calculation, 
you must change the field name in the calculation as well.
OmniForm cannot perform the calculation otherwise.

• Calculations are performed in tabbing order.

• If a calculation contains another field that has a calculation, the 
other field’s calculation is performed first.
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Usage Conventions
Substitute the appropriate field name where you see num and str in the 
function examples. Parentheses are required where indicated. Below is 
a list of conventions showing operator and function usage.

date date value: the expression must evaluate to a valid date 

time time value: the expression must evaluate to a valid time 

num number or numeric expression, num1, num2, etc. indicate 
additional number values 

str text string: str1, str2, etc. indicate additional string values 

... additional repeating values of the given type may be entered 

[ ] brackets inserted around field names 

log exp logical expression 

true exp true expression 

false exp false expression 
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Operators
Operators represent mathematical, comparison, logical, and text 
operations to be performed within a calculation. You must have an 
operator between fields in a calculation.

For example, a calculation for a Total field might look like this:

[Price1] + [Price2] + [Price3]

The plus signs between the field names are the Addition operators in the 
calculation.

The calculation could also look like this:

Sum([Price1],[Price2],[Price3])

The parentheses are the operators in the calculation. Commas, although 
not operators, also separate the fields. 

You must insert the proper parentheses, brackets, and commas when 
you create a function manually or OmniForm will not accept the 
calculation. See “Calculation Guidelines” on page 9-7 for detailed 
information.

OmniForm automatically inserts commas, parentheses, and brackets 
when you create a calculation with the Calculation Builder or the Auto 
button, and when you click the Accept Calculation button. 

Operator Buttons
See “Calculation Overview” on page 9-2 for instructions on creating 
calculations.

Addition

Left 
Parenthesis

Equal

Subtraction Not 
Equal

Division

Power of

Concatenate Greater 
Than

Less Than

Right 
Parenthesis

Logical 
And

Less Than or 
Equal To

Greater Than 
or Equal to

Logical 
Or

Logical 
Not

Multiplication
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Operators — Quick Reference
See “Usage Conventions” on page 9-8 for information on how to 
interpret the examples in the following table.

Operator Type Description Usage Example

+ mathematical Addition: add numbers or fields [num1] + [num2]

- mathematical Subtraction: subtract numbers or fields [num1] - [num2]

* mathematical Multiplication: multiply numbers or fields [num1] * [num2]

/ mathematical Division: divide numbers or fields [num1] / [num2]

^ mathematical Power of: raise a number or field by a power [num1]^2

& text Concatenate: put together strings “str1”&”str2”

= comparison Equal: compare values or results If ([num1]=[num2], true exp, false exp)

<> comparison Not Equal: compare values or results If ([num1]<>[num2], true exp, false exp)

< comparison Less Than: compare values or results If ([num1]<[num2], true exp, false exp)

> comparison Greater Than: compare values or results If ([num1]>[num2], true exp, false exp)

<= comparison Less Than or Equal to: compare values or 
results

If ([num1]<=[num2], true exp, false exp)

>= comparison Greater Than or Equal to: compare values or 
results

If ([num1]>=[num2], true exp, false exp)

And logical Logical And: use with Logical If to put together 
more than one condition. All conditions must 
be true for the Logical If function to be true.

If ([num1]=[num2] And 
[num3]=[num4], true exp, false exp)

Or logical Logical Or: use with Logical If to include more 
than one condition. Only one condition must 
be true for the Logical If function to be true.

If ([num1]=[num2] Or [num3]=[num4], 
true exp, false exp)

Not logical Logical Not: used with the Logical If function 
to negate a condition.

If ([num1]=[num] And NOT 
[num3]=[num4], true exp, false exp

() mathematical Left and Right Parentheses: show precedence. 
A matching set of parentheses must exist.

([num1]+[num2]) * 3

“ ” text Constant Quotes: mark the beginning and 
end of a character used as a constant or 
characters used as a text string. A matching 
set of quotes must exist.

“John Doe”
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Functions
Functions
This section defines each OmniForm function and shows how to use it 
in a calculation. Functions are listed alphabetically. See “Functions — 
Quick Reference” on page 9-33 for an overview of each function.

Functions are single words used by OmniForm to represent operations 
within a calculation. Functions can use field values, information you 
enter, and information from outside sources such as the computer date.

See “Creating a Calculation” on page 9-2 for instructions on creating 
calculations. See “Usage Conventions” on page 9-8 for a list of the 
conventions used in this chapter.

The format of the values returned in the examples is dependent on:

• The Language selection in the International tab of the Options 
dialog box

• The Format selection in the Properties tab of the Object Definition 
dialog box for the selected object

Abs (Absolute Value)
The Abs function returns the positive value of a number or numeric 
expression.

Usage Example
Abs[num1]

If the field [num1] = -50

Then the calculation Abs[num1] returns 50

In the example below, the Amount Paid field is subtracted from the Bill 
Amount field and placed in the Difference field. The absolute value of the 
difference appears in the Credit field.
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Avg (Average)
The Avg function returns the average value of a set of numbers and/or 
numeric expressions. The average value is determined by adding all the 
values and dividing by the number of values. 

Usage Example
Avg([num1,num2] ...)

If the field entries are 11, 14, and 20

Then the calculation Avg([num1],[num2],[num3]) returns 15

In the example below, the average of sales for the past six months is 
calculated. It appears in the Average field.

Date (Current Date)
The Date function returns the current date. The date is derived from the 
current system date. The date is formatted according to how you define 
it in the Object Definition dialog box.

Usage Example
Date()

If a field contains the function Date() and the current date is February 14, 1996

Then the value returned is 2/14/96

In the example below, the current date based on the computer system 
date is put in the Current Date field.
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DayName
The DayName function returns the name of the day of the week for a 
given date.

Usage Example
DayName(Date())

If the current date is February 14, 1996

Then the calculation DayName(Date())returns Wednesday

In the example below, the name of the day of the week is calculated 
using the Cur Date field and put in the Day Name field.

DayOfMonth
The DayOfMonth function returns the number for the day of the month 
for a given date. 

Usage Example
DayOfMonth(Date())

If the current date is February 14, 1996

Then the calculation DayOfMonth(Date()) returns 14

In the example below, the day of the month is extracted from the Date 
field and placed in the Day field.
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DayOfWeek
The DayOfWeek function returns a number for the day of the week for 
a given date. The values returned are: Sunday1, Monday2, Tuesday3, 
Wednesday4, Thursday5, Friday6, and Saturday7.

Usage Example
DayOfWeek(Date())

If the current date is February 14, 1996

Then the calculation DayOfWeek(Date())returns 4 (Wednesday)

In the example below, the day of the week from the Date field appears in 
the Day of Week field.

DayOfYear
The DayOfYear function returns the number for the day of the year for 
a given date. 

Usage Example
DayOfYear(Date())

If the current date is February 14, 1996

Then the calculation DayOfYear(Date()) returns 45

In the example below, the day of the year from the Date field appears in 
the Day of Year field.
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Exp (Exponentiation)
The Exp function returns the value of the constant e to the power of a 
number or numeric expression. The value of e, the base of natural 
logarithms, is approximately 2.71828. This function is the inverse of the 
Ln function.

Usage Example
Exp([num1]) 

If the field [num1] = 3

Then the calculation Exp([num1]) returns 20.08553692

In the example below, the Exp field is calculated using the number in the 
Value field.

FV (Future Value)
The FV function returns the future value of an investment. The future 
value is determined by computing a series of constant periodic 
payments made at the end of each period, earning a fixed interest rate 
per period, for a fixed number of periods. 

Usage Example
FV([payment num],[rate num],[num of periods]) 

If the payment is $100, the annual interest rate is 8%, and the number of years is 30

Then the calculation FV([payment num],[rate num],[num of periods]) returns 
11,328.32 (approximately)

It is important to have the fields in the proper order as listed above.

In a different example below, the future value of a savings plan is 
calculated and put in the Future Value field.
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Hour
The Hour function returns the hour (HH) portion of a given time 
(HH:MM:SS). The hour is based on a 24-hour clock and ranges from 0– 23. 

Usage Example
Hour(Time()) 

If the current time is 18:05:05

Then the calculation Hour(Time()) returns 18

In the example below, the hour is taken from the Time field and put in 
the Hour field.

If
The If function evaluates a logical expression and returns the true 
expression if it evaluates to true (“yes” or “true”). Otherwise, it returns 
the false expression. 

Usage Example
If(log exp,true exp,false exp) 

If the field [Monthly Sales] = 5500

Then the calculation If ([Monthly Sales]>5000,”Good work!”,”Let’s work harder 
next month!!!”) returns the string “Good work!”

In the example below, a text string is placed in the Comment field based 
on the value for the Monthly Sales field.
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Int (Integer)
The Int function returns the integer portion of a number or numeric 
expression. 

Usage Example
Int([num1]) 

If the field [num1] = 16,184.35

Then the calculation Int([num1]) returns 16,184.00

In the example below, the total amount (dollar portion only) is put in the 
Total Sales field.

Left 
The Left function returns characters from a given string from the first 
character on the left to the right for the specified number of characters.

Usage Example
Left([str1],number of characters) 

If the field [str1] = November

Then the calculation Left([str1],3) returns Nov

In the example below, the first three characters of the month’s name 
from the Date field appear in the Month field.
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Length 
The Length function returns the number of characters in a given string. 
The calculation counts all characters in a string including spaces.

Usage Example
Length([str1]) 

If the field [str1] = John Doe

Then the calculation Length([str1]) returns 8

In the example below, the length of the name in the Name field is put in 
the Length of Name field.

Ln (Natural Logarithm)
The Ln function returns the natural logarithm (base e) of a number or 
numeric expression. The number or numeric expression must be greater 
than 0. Ln is the inverse of the Exp function. 

Usage Example
Ln([num1])

If the field [num1] = 2

Then the calculation Ln([num1]) returns 0.69314718 (approximately)

In the example below, the natural logarithm is calculated using the Ln 
Value field and put in the Log field.
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Log (Base 10 Logarithm)
The Log function returns the common logarithm (base 10) of a number 
or numeric expression. The number or numeric expression must be 
greater than 0. 

Usage Example
Log([num1]) 

If the field [num1] = 3

Then the calculation Log([num1]) returns 0.47712125

In the example below, the common logarithm is calculated using the Log 
Value field and put in the Logarithm field.

Lower 
The Lower function returns the lower case of a given string. 

Usage Example
Lower([str1]) 

If the field [str1] = GOOD JOB

Then the calculation Lower([str1]) returns good job

In the example below, the Lower field displays the same information as 
the Comment field but in lower case.
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Max (Maximum)
The Max function returns the maximum (highest) value of a set of 
numbers and/or numeric expressions. 

Usage Example
Max([num1],[num2] ...) 

If the numbers in the fields are 150, 200, and 45

Then the calculation Max([num1],[num2],[num3]) returns 200

In the example below, the Top Sales field displays the highest sales made.

Middle
The Middle function returns the characters from a given string 
beginning at a specified starting position from the left in the string, and 
continuing to the right for the specified number of characters. The first 
(beginning) position in the string is 1. 

Usage Example
Middle([str1],start position number,number of characters)

If the field [str1] = 2/14/96

Then the calculation Middle([str1],3,2) returns 14

In the example below, the Middle and several other functions extract the 
last name from the Full Name field and place it in the Last Name field.

Refer to these other functions elsewhere in this section for more 
information.
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Min (Minimum)
The Min function returns the minimum (lowest) value of a set of 
numbers and/or numeric expressions. 

Usage Example
Min([num1],[num2] ...) 

If the numbers in the fields are 90, 95, 82 and 78

Then the calculation Min([num1],[num2],[num3],[num4]) returns 78

In the example below, the minimum test score is picked out of a list of 
scores and put in the Minimum Score field.

Minute
The Minute function returns the minute (MM) portion of a given time 
(HH:MM:SS). The minute ranges from 0–59. 

Usage Example
Minute(Time()) 

If the current time is 18:05:05

Then the calculation Minute(Time()) returns 5

In the example below, the minutes are put in the Minutes field using the 
Time of Day field.
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Mod (Modulus (Remainder))
The Mod function returns the remainder of a number or numeric 
expression divided by another number or numeric expression. A 
positive number is returned if the dividend is positive, and a negative 
number is returned if the dividend is negative. 

Usage Example
Mod([dividend num],[divisor num]) 

If the numbers in the fields are 87 and 8

Then the calculation Mod([dividend num],[divisor num]) returns 7 (87 ÷ 8 = 10 
with a remainder of 7)

In the example below, the number of computer disks remaining after 
packaging full boxes is placed in the Remaining field.

Month
The Month function returns the number of the month for a given date. 
The month ranges from 1 to 12. 

Usage Example
Month(Date()) 

If the current date is February 14, 1996

Then the calculation Month(Date()) returns 2

In the example below, the month is put in the Current Month field using 
the current system date calculated in the Present Date field.
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MonthName
The MonthName function returns the full name of the month for a given 
date. 

Usage Example
MonthName(Date())

If the current date is February 14, 1996

Then the calculation MonthName(Date()) returns February

In the example below, the name of the month is put in the Month Name 
field using the current system date calculated in the Today’s Date field.

Pi
The Pi function returns the value of the constant Pi (approximately 
3.14159265). 

Usage Example
Pi() 

If a field contains the function Pi()

Then the value of Pi is returned as 3.14159265

In the example below, the area of a circle is calculated using Pi and the 
Radius field and put in the Area field.
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PMT (Payment)
The PMT function returns the payment amount required for a given 
principal at a fixed interest rate per period, for a fixed number of payment 
periods. It assumes payments are made at the end of each period.

Usage Example
PMT([principal num],[interest rate num],[num periods])

If the principal is $30,000, the annual interest rate is 9% (.75% monthly), and 
the number of years is 30

Then the calculation PMT([principal num],[interest rate num],[num periods]) 
returns 241.39 (approximately)

It is important to have the fields in the proper order as listed above. In a 
different example below, the Monthly Payment field is calculated based 
on entries in the Loan Amount, Interest Rate, and Years fields.

Position
The Position function returns the starting position of the find string in a 
given source string, beginning at the specified starting position of 1 from 
the left. If the find string is not found, 0 is returned. 

Usage Example
Position([source str],[find str],[start position num])

If a field contains the name Doe, John and you want to find the comma position

Then the calculation Position(“[source str]”,“,”,1) returns 4

In the example below, the Position function locates the comma. Other 
functions are then used to extract the last name from the Customer Name 
field and place it in the Customer Last Name field.
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Proper
The Proper function returns the given string with the first character of 
each word converted to upper case and the rest of the characters in each 
word converted to lower case. 

Usage Example
Proper([str1]) 

If the field [str1] = john doe

Then the calculation Proper([str1]) returns John Doe

In the example below, the Proper function places the Student Name entry 
in the Proper Name field with the first letter of each name capitalized.

PV (Present Value)
The PV function returns the present value of an investment. The present 
value is the total current value of a series of future payments made per 
period, at a fixed interest rate per period, for a fixed number of payment 
periods. It assumes that payments are made at the end of each period. 

Usage Example
PV([payment num],[interest rate num],[num of periods])

If a $1000 payment is made annually, the annual interest rate is 7.5%, and the 
payment period is for 7 years

Then the calculation PV(1000,7.5,7) returns 5,296.60 (approximately)

In the example below, the present value of an annuity that is paid out is 
calculated and placed in the Present Value field.
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RecordCount
The RecordCount function returns the number of records in the current 
database.

Usage Example
RecordCount()

If a field contains the function RecordCount() and the database contains 156 
records

Then the value returned is 156

In the example below, the number of records appears in the Number of 
Records field.

Replace
The Replace function returns a replacement string for a given source 
string starting at the specified position from the left in the source string 
for the specified length. The beginning position in the string is 1.

Usage Example
Replace([source str],start position num,num of characters,“replacement str”) 

If the field [source str] = GRA32457 and you want it to begin with GS-

Then the calculation Replace([source str],1,3,“GS-”) returns GS-32457

In the example below, the Customer Number entry is reformatted and 
placed in the Our Number field.
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Replicate
The Replicate function returns a given string repeated the specified 
number of times. The maximum length returned is 16,000 characters. 

Usage Example
Replicate(str1, num of times to replicate) 

If the field [str1] = *

Then the calculation Replicate(“*”, 10) returns ********** 

In the example below, the Start Date field is put into the Target Date field 
with leading and trailing asterisks.

Right
The Right function returns characters from a given string beginning 
with the first character on the right and continuing to the left for the 
specified number of characters. 

Usage Example
Right ([str1], num of characters)

If the field [str1] = 1996

Then the calculation Right ([str1],2) returns 96

In the example below, the year is extracted from the Begin Date field and 
placed in the Year field.
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Round
The Round function returns the value of a number or numeric 
expression rounded to the specified decimal places in the second 
parameter. 

Usage Example
Round([num1], num of decimal places) 

If the field [num1] = 2404.685

Then the calculation Round([num1],2) returns 2404.68

In the example below, the value in the Total field is extracted and 
rounded to two decimal places in the Price field.

Second
The Second function returns the second (SS) portion of a given time 
(HH:MM:SS). The second ranges from 0–59. 

Usage Example
Second(Time()) 

If the current time is 18:05:05

Then the calculation Second(Time()) returns 5

In the example below, the seconds are extracted from the Time field and 
placed in the Second field.
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Sign
The Sign function returns a value of 1 if a number or numeric expression 
is positive, -1 if it is negative, and 0 if it is 0. 

Usage Example
Sign([num1]) 

If the field [num1] = -100

Then the calculation Sign([num1]) returns -1

In the example below, the Invoice Amount field is evaluated and a 
message is put in the Warning field if it is negative. The Sign function is 
used to determine if the value is negative.

Sqrt (Square Root)
The Sqrt function returns the square root of a number or numeric 
expression. The number or numeric expression must be positive. 

Usage Example
Sqrt([num1])

If the field [num1] = 8

Then the calculation Sqrt([num1]) returns 2.82842712

In the example below, the square root is calculated using the Number 
field and put in the Square Root field. The Round calculation is used to 
round the result to three decimal places.
Using Calculations  9-29



Functions
Sum
The Sum function returns the total value of a set of numbers and/or 
numeric expressions added together. 

Usage Example
Sum([num1],[num2], ...)

If the numbers in the fields are 3, 6, and 8

Then the calculation Sum([num1],[num2],[num3]) returns 17

In the example below, test scores are added together and put in the Total 
Scores field.

Time 
The Time function returns the current time based on the current system 
clock. The time is returned as HH:MM:SS. 

Usage Example
Time()

If a field contains the function Time() and the current time is 18:05:05

Then the value returned is 18:05:05 

In the example below, the time is put in the Form Time field. (Time 
formatting depends on the current field definition.)
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Trim 
The Trim function returns a given string with all leading, trailing, and 
extra blank spaces removed. 

Usage Example
Trim([str1]) 

If the field [str1] = Jane   Doe

Then the calculation Trim([str1]) returns Jane Doe

In the example below, the Supervisor 1 field or Supervisor 2 field is placed 
in the Manager field depending on which box is checked. The name is 
trimmed of all extra blank spaces.

Trunc (Truncate)
The Trunc function returns the value of a number or numeric expression 
truncated to the specified number of decimal places in the second 
parameter.

Usage Example
Trunc([num1],num of decimal places) 

If the field [num1] = 3.1415926

Then the calculation Trunc([num1],4) returns 3.1415

In a different example below, the sales are summed and placed in the All 
Sales field. The value is truncated down to 10 cents.
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Upper
The Upper function returns a given string as uppercase. 

Usage Example
Upper([str1])

If the field [str1] = Samantha Morrison

Then the calculation Upper([str1]) returns SAMANTHA MORRISON

In the example below, the Salesperson field is converted to all upper case 
and put in the Salesperson Last Name field.

Year
The Year function returns the numeric year for a date. The year is 
returned as CCYY. 

Usage Example
Year([date1])

If the field [date1] = March 17, 1996

Then the calculation Year([Date]) returns 1996

In the example below, the century and year is extracted from the Date 
Entered field and put in the Century and Year field.
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Functions — Quick Reference
See “Usage Conventions” on page 9-8 for information on how to 
interpret the examples in the following table. A brief description and 
usage of each function is listed.

Function Type Description Usage Example

Abs mathematical Absolute Value: returns the value of num Abs(num)

Avg statistical Average: returns the average for num1, num2, 
etc.

Avg(num1, num2, ...)

Date date Date: returns the current date as MM/DD/YY 
based on the current system date

Date()

DayName date DayName: returns the name of the day of the 
week for a given date

DayName(date)

DayOfMonth date DayOfMonth: returns the number for the day of 
the month for a given date

DayOfMonth(date)

DayOfWeek date DayOfWeek: returns the number for the day of 
the week for a given date. Sunday returns 1, 
Monday returns 2, etc.

DayOfWeek(date)

DayOfYear date DayOfYear: returns the number for the day of 
the year for a given date

DayOfYear(date)

Exp mathematical Exponentiation: returns the value of the 
constant e, the base of natural logarithms 
(approximately 2.71828) to the power of 
num, inverse of Ln function

Exp(num)

FV financial Future Value: returns the future value of an 
investment given a payment num, interest rate 
num, and num of periods

FV(payment num, rate num, num 
of periods)

Hour time Hour: returns the hour for a given time Hour(time)

If logical If: if the log exp is true, the true exp is executed, 
otherwise, the false exp is executed

If(log exp, true exp, false exp)

Int mathematical Integer: returns the integer portion or whole 
number of num

Int(num)
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Left text Left: returns the characters for str beginning 
from the left and proceeding to the right for 
num characters

Left(str, num)

Length text Length: returns the number of characters in str Length(str)

Ln mathematical Natural Logarithm: returns the natural 
logarithm (base e — approximately 2.71828) 
of num, inverse of Exp function of num

Ln(num)

Log mathematical Base 10 Logarithm: returns the base 10 
logarithm of num

Log(num)

Lower text Lower: converts the str to lowercase Lower(str)

Max statistical Maximum: returns the maximum (highest) 
value for num1, num2, etc.

Max(num1, num2, ...)

Middle text Middle: returns the characters for str beginning 
at start position num for num of characters

Middle(str, start position num, 
num of characters)

Min statistical Minimum: returns the minimum (lowest) value 
for num1, num2, etc.

Min(num1, num2, ...)

Minute time Minute: returns the minute for a given time Minute(time)

Mod mathematical Modulus: returns the remainder of the dividend 
num divided by the divisor num

Mod(dividend num, divisor 
num)

Month date Month: returns the number of the month for a 
given date

Month(date)

MonthName date MonthName: returns the number of the month 
for a given date

MonthName(date)

Pi mathematical Pi: returns the value of Pi (approximately 
3.14159265)

Pi()

PMT financial Payment: returns the payment required given a 
principal num, interest rate num, and num of 
periods

PMT(principal num, interest rate 
num, num of periods)

Position text Position: returns the position in the source str of 
the find str beginning at start position num

Position(source str, find str, start 
position num)

Proper text Proper Case: converts the first letter of each 
word in str to uppercase and the rest of the 
word to lowercase

Proper(str)
9-34  Using Calculations



Functions
PV financial Present Value: returns the present value of an 
investment given a payment num, interest rate 
num, and num of periods

PV(payment num, interest rate 
num, num of periods)

Record Count database Record Count: returns the number of records in 
the current database

RecordCount()

Replace text Replace: replaces the source str beginning at 
start position num for num of characters with 
the replacement str

Replace(source str, start position 
num, num of characters, 
replacement str)

Replicate text Replicate: repeats a str for num times Replicate(str, num)

Right text Right: returns characters for str beginning from 
the right and proceeding to the left for num 
characters

Right(str, num characters)

Round mathematical Round: returns the value of num rounded to the 
specified num of decimal places

Round(num, num of decimal 
places)

Second time Second: returns the second for a given time Second(time)

Sign mathematical Sign: returns the sign of num. A positive num 
returns 1, zero returns 0, and a negative num 
returns -1

Sign(num)

Sqrt mathematical Square Root: returns the square root of a 
positive number

Sqrt(num)

Sum statistical Sum: returns the total of num1, num2, etc. Sum(num1, num2, ...)

Time time Time: returns the current time as HH:MM:SS 
based on the current system clock

Time()

Trim text Trim: removes leading, trailing spaces, and all 
other extra spaces from str

Trim(str)

Trunc mathematical Truncate: returns the value of num truncated 
down to the specified num of decimal place

Trunc(num, num of decimal 
places)

Upper text Upper: converts str to uppercase Upper(str)

Year date Year: returns the year number for a given date Year(date)
Using Calculations  9-35



Functions
Functions Sorted by Type
This section lists each function by type. 

Database Text

Record Count

Date/Time
Date
DayName
DayOfMonth
DayOfWeek
DayOfYear
Hour
Minute
Month
MonthName
Second
Time
Year

Financial
FV
PMT
PV

Logical
If

Math
Abs
Avg
Exp
Int
Ln
Log
Max
Min
Mod
Pi
Round
Sign
Sqrt
Sum
Trunc
9-36  Using Calculations
Left
Length
Lower
Middle
Position
Proper
Replace
Replicate
Right
Trim
Upper



Chapter 10

Technical Information
This chapter explains how to troubleshoot common problems you may 
encounter. It also provides technical information on such topics as how 
to improve Optical Character Recognition (OCR) and scanning 
performance.

This chapter contains the following sections:

• Before You Begin

• OmniForm Setup Issues

• Scanning and Recognition

• Operation

• Improving Performance

• OmniForm Compatibility

• Error Messages

• Caere Product Support
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Before You Begin
Before You Begin
If you have a problem with OmniForm, first check that your computer, 
scanner, and other applications are functioning properly.

Make backups of OmniForm files regularly, preferably in a location 
other than your hard drive. This could save you hours or days of work 
if the unexpected happens: file deletion or corruption caused by disk 
crashes, viruses, or user error.

Try this First
It may help to try one or all of the following:

• Turn off your computer, restart your scanner, and then restart 
your computer.

• Restart the computer with extensions off to determine if there is a 
an extension conflict.

• Reinstall OmniForm.

System Setup Checklist
• Make sure that your system meets all requirements as listed in 

“System Requirements” on page 2-2.

• Make sure that your scanner is plugged in and turned on, and 
that all cable connections are secure.

• Use the software that came with your scanner to verify that it 
works properly before using it with OmniForm.

• Fix Macintosh problems before using OmniForm again.

• Run virus-checking software regularly.

• Scan your disk for problems occasionally: use a utility that checks 
and diagnoses damaged disks and files, such as MacTools™ or 
Norton Utilities™.

• Defragment your hard disk occasionally with a program such as 
MacTools or Norton Utilities.
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OmniForm Setup Issues
This section contains information on some common installation 
problems and information on how to optimize the installation process:

Memory and Installation
Close all applications — including screen savers and mail applications 
— to free up memory before starting the OmniForm setup program.

Linking OmniForm with Visioneer PaperPort™ 
To link OmniForm with Visioneer PaperPort, locate the OmniForm 
Link  file in your OmniForm  Folder.  Drag the file into the 
System:Preferences:Visioneer  folder.

OmniForm then appears in the PaperPort Link Bar. For more 
information on PaperPort links, please see your PaperPort 
documentation.

Uninstalling OmniForm
Follow these steps to remove OmniForm permanently from your system.

The steps listed here remove all OmniForm files from your computer. 
Back up files and records outside your OmniForm  folder to save them.

1 Delete the OmniForm  Folder .

2 Delete any OmniForm aliases.

3 Delete the System:Preferences:OmniForm 
Preferences  file.
Technical Information  10-3



Scanning and Recognition
Scanning and Recognition
This section describes common scanning and recognition problems and 
possible solutions.

System Hang During Scan
A system hang during a scan could have several possible causes:

• A SCSI termination problem.
Make sure the scanner and any other peripheral devices 
connected to the scanner are terminated properly. See your 
scanner documentation.

• A memory-related problem.
Try closing open windows and applications to free up memory. 
See “Low Memory” on page 10-5.

Scanner Compatibility
If you experience a problem between OmniForm and your scanner, the 
scanner may be incompatible with OmniForm. OmniForm requires a 
scanner with a Pixel Translations ISIS scanner driver.

OmniForm supports image resolutions of 200, 300, or 400 dots per inch 
(dpi). Select line art, bi-tone, or black-and-white line images for the best 
results. OmniForm cannot process grayscale or color scans.
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Operation
Operation
This section provides troubleshooting techniques for potential 
operational problems as well as additional technical information:

• Low Memory

• Low Disk Space

• OmniForm Limits

Low Memory
Low memory can cause error messages, slow performance, or system 
hangs. A minimum of 12MB RAM is required to run OmniForm. More 
is recommended for optimum performance or if you plan to have 
multiple applications open.

Choose About This Macintosh... in the Apple menu to check the amount 
of free memory. You may need to reconfigure your Macintosh for 
additional RAM.

The best solution for low memory is to buy and install more RAM. You 
can increase memory in several other ways as described below: free 
available memory, allocate additional memory to OmniForm, or use 
virtual memory.

Freeing Available Memory

Try closing open applications and windows to free up memory. 
Memory can become fragmented if many applications have been open at 
different times. Try restarting your computer to defragment memory.

Allocating Additional Memory to OmniForm

1 Quit from OmniForm if it is open.

2 Select the OmniForm icon in the OmniForm folder.

3 Choose Get Info in the File menu to open the OmniForm Info 
dialog box.
The amount in the Minimum size box should match the amount 
in the Suggested size box for optimum performance.

4 Change the amount in the Minimum size box to the amount in 
the Suggested size box if it is smaller.
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5 Type a larger number in the Preferred size box if you want to 
allocate more memory to OmniForm.
The program will use the amount specified if extra memory is 
available.

6 Close the OmniForm Info dialog box.

Virtual Memory

Check your Macintosh documentation for information on using virtual 
memory. Virtual memory is hard disk space used temporarily as free 
RAM by your computer. Performance is significantly slower with 
virtual memory on.

Low Disk Space
It is recommended that your disk have at least 12MB of free disk space 
for the best performance. Otherwise, files may be fragmented (that is, 
written in small blocks in many different places on your disk) which 
slows the OCR process.

Free up disk space by removing unneeded files or by copying less 
frequently used files to a floppy disk, an external hard drive, or another 
storage device.

OmniForm Limits
The following limits apply in OmniForm:

• Pages in a form: 100.

• Open forms: 20.

• Records in a database: 10,000 or approximately 5.4 MB of data 
across all records.

• Length of Help message in an Object Definition dialog box: 100 
characters.

• Number of choices in the List of Choices list box in an Object 
Definition dialog box: 100 choices, each up to 100 characters long.
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Improving Performance
If you scan typeset, high-quality printed pages, text recognition 
accuracy should be very high.

With lesser-quality pages, however, text recognition may not be as 
accurate. This section discusses a number of factors that affect scanning 
and recognition performance:

• Document Quality

• Scanning Angle

• Scanner Glass Cleanliness

• Paper Transparency

• HP AccuPage

Document Quality
OmniForm recognizes characters in almost any font from 6 to 72 points 
in size. However, keep the following in mind when using OmniForm:

• The print should be reasonably clean and crisp. Characters must 
be distinct: separated from each other and not blurry or 
overlapping.

• The document should be free of notes, lines, or doodles. 
Anything that is not a printed character slows recognition, and 
any character distorted by a mark will be unrecognizable.

• The document font should be non-stylized; for example, 
OmniForm may not recognize the Zapf Chancery font accurately.

• Forms with underlined text should have the lines placed below 
the text and not touching it for best results. It is difficult to 
recognize underlined text because the underline overprints the 
descenders on the letters g, j, p, q, and y, changing their shape.

Scanning Angle
Make sure that each document is positioned correctly in your scanner 
and is not crooked. Even if you use the Auto Form Straightening option, 
it is possible for the page to be too skewed for OmniForm to design it 
properly. Adjust the page and rescan it if you see numerous recognition 
errors due to skewing. 
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Scanner Glass Cleanliness
The sheet of glass on the flatbed of the scanner must be clean. If it gets 
dirty, wipe it gently with a soft, damp, lint-free cloth or tissue. Be sure 
that it is completely dry before you put pages on it.

See your scanner documentation for more information on proper 
scanner maintenance.

Paper Transparency
Some paper is thin enough that the scanner sees text printed on the 
opposite side of a two-sided page. To correct this problem, put a dark-
colored piece of paper behind the page between the page and the lid of 
the scanner.

HP AccuPage
HP AccuPage is a technology developed and licensed by Hewlett-
Packard. It improves the combined performance of the HP ScanJet 
scanner and OmniForm.

To use HP AccuPage with OmniForm, you must have an HP ScanJet 
Plus scanner or above. Use AccuPage to:

• Improve the recognition of forms printed on colored or shaded 
backgrounds, or on smudged paper.

• Improve the recognition of forms with very small type.

To select HP AccuPage for scanning:

1 Choose Scan Form... in the File menu.

2 Click Set Up Scanner... in the Scan Form dialog box. 

3 Select Auto (AccuPage) and click OK.

4 Continue to scan as you normally would.
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OmniForm Compatibility
This section provides OmniForm compatibility lists.

Database Information Exchange

OmniForm can exchange information with the following databases: 

• Macintosh and PC OmniForm Database files

• comma- or tab-separated text files

Graphic Formats

OmniForm can import the following file types into a graphic object or a 
fill graphic field:

• TIFF

• PICT

• GIF

• JPG

Image File Formats

OmniForm can import and recognize black-and-white forms in either 
PICT or TIFF format. Image resolution must be 200, 300, or 400 dots per 
inch (dpi).

Scanners

If you plan to scan forms, you need a scanner with a Pixel Translations 
ISIS scanner driver.

OmniForm Forms

OmniForm can open OmniForm forms created in any version of 
OmniForm for Windows. Make sure you select All Files in the List Files 
of Type pop-up menu in the Open dialog box. Otherwise, only forms 
created on the Macintosh will be displayed. The same is true for opening 
Macintosh OmniForm forms in OmniForm for Windows.

OmniForm Data Files

You can import Data files created in the Windows version of OmniForm. 
Use PC Exchange to map the .ofm PC extension to the appropriate 
Macintosh ‘OFD’ filetype.

To import a Macintosh Data file into the Windows version of 
OmniForm, you must add an OFD extension to the file name; for 
example, Form 1 DB.ofd .
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Error Messages
Where possible, OmniForm error messages attempt to pinpoint a 
problem and offer a solution. Sometimes one solution may not work or 
there may be more information that does not fit into the dialog box.

Many calculation errors are the result of improperly constructed 
calculations. See “Calculation Guidelines” on page 9-7 for detailed 
information.

Low Memory or Disk Space Errors
If an error message contains the instruction “Close open windows and 
applications to free up memory” see “Low Memory” on page 10-5. If an 
error message says you are low on disk space, see “Low Disk Space” on 
page 10-6.

Scanner Errors
If a scanner error message appears, make sure:

• The scanner is turned on.

• Scanner connections are secure.

• The scanner is not in use by another application.

• Your scanner is compatible with OmniForm. You need a scanner 
with a Pixel Translations ISIS scanner driver.

Test your scanner with the manufacturer’s software to make sure that it 
works properly. Check Caere’s Web site for updated scanner drivers. 
See “Caere Product Support” on page 10-13 for more information.

Other Error Messages
The following messages are listed alphabetically.

All objects within an Option Group must be of the same type.

An Option Group can consist of circle text objects or check box objects. 
OmniForm does not allow the same Option Group name to be assigned 
to different object types.
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Calculation Error: Cannot resolve circular references.

This message appears if two or more fields are logically connected in a 
closed loop so that no value can be returned. For example, suppose you 
selected the field Cost1 and created this calculation for it:

Sum([Cost1];[Cost2])

A circular reference error message would appear because the selected 
field cannot be involved in returning its own sum.

Calculation Error: Invalid Field Name ([field name]). Correct the 
field name or enter another in the expression for [field name].

A field name in your calculation does not exist in the form. It may be 
misspelled or it may have been deleted from the form after the 
calculation was previously accepted. Correct the field name, add it to the 
form if it is missing, or change the calculation.

Calculation Error: Invalid Field used in calculation. [field name1] 
cannot be used in the Expression for [field name2].

You used an invalid field, such as a fill graphic, in a calculation. Only fill 
text, comb, check box, and circle text fields can be used in calculations.

Calculation Error: Missing ']'.

The calculation is missing a bracket. All field names that contain a space 
must be enclosed by brackets. OmniForm does not automatically insert 
brackets around a manually created field name that contains a space. 
You must enter brackets for it manually.

Calculation Error: Missing '('.

The calculation is missing a left parenthesis. (The same message with a 
right parenthesis appears if that is missing.) Parentheses must enclose 
an entire function.

It is easy to leave out a parenthesis in a long, manually created 
calculation containing multiple functions. Try using the Calculation 
Builder instead so that OmniForm inserts parentheses automatically. 
See Chapter 9, Using Calculations, for more information.
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Scrap Album error. Try freeing up hard disk space, and close 
open forms and applications to free up memory.

If disk space or memory is not low, this message may appear because the 
Scrap Album file you selected is missing or corrupted. A Scrap Album 
file moved or deleted from the OmniForm:  Scrap  Albums  folder while 
OmniForm is open will still appear in the Scrap Album pop-up menu. If 
you select it, this message appears.

Restart OmniForm to update the list of Scrap Albums if you delete a 
Scrap Album file from the hard drive.

The current word cannot be added to the dictionary because it 
contains invalid characters.

The word contains a character such as a caret (^) that OmniForm does 
not allow in the dictionary.

The name you entered contains invalid characters. Please enter 
a valid name.

A field name can contain only letters, numbers, the underscore character 
( _ ), and spaces.

This form is protected. Turn off form or data protection to make 
changes.

Form and/or data protection is active. See “Protecting Your Database” 
on page 8-26 for detailed information.
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Caere Product Support
Product support is available if you need help. First, please check this 
manual to find the information you need, or look in the online help if 
you can run OmniForm. You may save yourself a phone call.

World Wide Web
Caere’s home page is located at:

http://www.caere.com

Our Web site contains product information, lists of common questions 
and answers, the latest release notes and online help files, and all known 
issues regarding Caere products.

Product Support Information
Your OmniForm package contains two pages with the most up-to-date 
support information for the United States, Canada, and the European 
Community. Please refer to these pages if you need product support.

Registered users in North America can call Caere Product Support at 
408-395-8319. 

You must be registered to receive product support! Complete and send 
in the registration card in your OmniForm package. If you need to call 
before registering, please have your serial number ready.

Information We Need From You
For the most efficient response, please have the following information 
on hand and be near your computer if you call:

• OmniForm serial number

• OmniForm version

• Macintosh model

• System version

• Network operating system, if applicable

• Scanner manufacturer and model

• Amount of RAM in your system

• Make and model of any peripheral devices (printers, monitors, 
and so forth), if applicable
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Index
A
Align commands 6-39
Arrange toolbar 6-4
Arrowr file 3-44
Auto calculations 9-5 to 9-6

B
Books, scanning 5-5, 5-11
Bounding box 6-39
Brightness options 5-4
Bring to Front command 6-40

C
Calculation

see also Functions
Auto calculations 9-5 to 9-6
Calculation Builder dialog box 

9-3 to 9-5
calculation overview 9-2
command 9-2
creating 9-2 to 9-6
filling a field defined by a 

calculation 7-8
function examples 9-11 to 9-32
functions quick reference chart 

9-33 to 9-35
functions, sorted by type 9-36
guidelines for creating 9-7
operator buttons 9-9
operators, described 9-9
operators, quick reference chart 

9-10
recalculating records 9-7
toolbar 3-39, 9-2
tutorial 3-37 to 3-40
usage conventions chart 9-8

Calculation Builder dialog box 9-3 to 

9-5

Check Box Definition dialog box 
3-30

Check box object
creating 6-14
defining 6-24 to 6-25
filling in fill view 7-4
tutorial 3-29

Circle text object
creating 6-14
defining 6-26
filling in fill view 7-4

Clear Search button 3-49, 8-11
Comb element, defining 6-23
Comb object

copy from scrapbook 3-28
create zip code 3-27
creating 6-13
defining 6-21 to 6-23
filling in fill view 7-3

Control-click, use to open shortcut 
menus 5-26

Convert command 6-43
Currency

affected by language selection 
5-23 to 5-24

formatting 3-37
Current Form option 5-22, 5-23
Cursor

as I-beam 3-18
as resize cursor 3-17, 6-10
moves automatically in comb 

field 3-11
place to see ToolTip 3-10
use to correct text 3-18
use to select objects 3-41, 6-33
use to select table elements 3-33

D
Data protection 8-26
Database

changes to layout 3-50
databases supported 10-9
defined 3-46, 8-2
deleting record(s) 3-51, 8-15
found set 8-7, 8-11
moving through 8-6 to 8-7
recalculating records 8-13 to 

8-14
records management 8-3 to 

8-25
search tutorial 3-48 to 3-49
searching records 8-7 to 8-11
sorting records 8-12 to 8-13
sorting tutorial 3-49
tutorial 3-46 to 3-51

Dates
affected by language selection 

5-23 to 5-24
entering in fill text field 3-45
formatting 3-34

Defining objects
check box 6-24 to 6-25
circle text 6-26
comb 6-21 to 6-23
comb element 6-23
fill graphic 6-27
fill text 6-17 to 6-21
graphic 6-9 to 6-13
table 6-26
table cell 6-27

Delete All Records command 8-15
Delete Record command 8-15
Design command 5-19
Design view
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changing object appearance 
6-29 to 6-32

creating objects 6-6 to 6-15
defining objects 6-16 to 6-28
overview 4-5
redesigning a form 6-33 to 6-43
toolbars 6-3 to 6-5
tutorial 3-13 to 3-14
using the Scrap Album 6-44 to 

6-47
window overview 4-5

Designed form usage option 4-9
Designing forms

aligning objects 6-39
changing tab order 6-41
converting objects 6-43
formatting text 6-35 to 6-37
moving objects 6-34
overlapping objects 6-40
placing objects in table cells 

6-42
resizing objects 6-34
selecting objects 6-33
table redesign 6-38 to 6-39

Dial-up services 10-13
Drawing toolbar 6-5
Duplicate Record command 8-6

E
E-mail

programs supported 10-9
Error messages 10-10 to 10-12
Export

benefits of exporting 
information 8-16

exporting database information 
8-16 to 8-19

preparing for 8-16
Record Range dialog box 8-19

Export As dialog box 8-17
Export command 8-17
Export dialog box 8-18
Export Setup dialog box 8-17
Extensions and installation 2-3

F
Faxing

from Form Assistant 5-14 to 

5-15
requirements 3-6
resolution and OCR 3-6
tutorial 3-6 to 3-9
using the Print command 5-15 

to 5-16
Field validation 7-8
Fields

changing tab order 6-41
check box 7-4
circle text 7-4
comb 7-3
defined by a calculation 7-8
fill graphic 7-5
fill text 7-3
filling 7-3 to 7-8
filling a validated field 7-8
moving through 7-12
shift-tab to 3-11
spell checking 7-9 to 7-11
tab order 3-43, 6-41
tab to 3-11
table 7-4

File formats, supported 10-9
File menu commands

Export 8-17
Form Assistant 4-2
Import 8-22
New 3-22, 5-20
Open 5-21
Page Setup 3-22
Print 5-15
Scan Form 5-4 to 5-7, 5-10 to 

5-12
Fill command 5-13
Fill Graphic dialog box 7-5
Fill graphic object

creating 3-36, 6-15
defining 6-27
filling in fill view 3-44, 7-5
import options 7-6 to 7-7
importing existing graphic 7-5 

to 7-7

when to use 6-15
Fill lines 3-25, 6-31
Fill Text Definition dialog box 3-34, 

3-37, 6-17
Fill text object

creating 6-13
defining 6-17 to 6-21
fill lines 3-25, 6-31
filling in fill view 7-3
format currency 3-37
format date 3-34
tutorial 3-23

Fill view
filling fields 7-3 to 7-8
moving through fields 7-12
overview 4-6
saving changes 7-12
standard toolbar 3-10, 7-2
status text 3-10
ToolTips 3-10
tutorial 3-10 to 3-12
window overview 4-6

Font command 6-35
Font dialog box 6-35
Font types and OCR 10-7
Font/text toolbar 6-4
Form Assistant

appears on launch 2-4
button 4-2
Create a new, blank form 5-20
dialog box 3-2
Fill in a form 5-13
form usage options 4-8
functions overview 4-3
importing image files 5-8 to 5-9
opening 4-2
Print or fax a form 5-14 to 5-15
Scan in a form 5-2 to 5-3, 5-8 to 

5-9
scanning forms 5-2 to 5-3
Search a form for information 

5-17 to 5-18
startup option 4-4
using 4-2 to 4-3
Work on a form’s design 5-19

Form Assistant command 4-2
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Form design
aligning objects 6-39
changing tab order 6-41
converting objects 6-43
formatting text 6-35 to 6-37
moving objects 6-34
overlapping objects 6-40
placing objects in table cells 

6-42
resizing objects 6-34
selecting objects 6-33
table redesign 6-38 to 6-39

Form image
closing 3-20
horizontal bar 3-17, 6-10
select source 6-10, 6-11

Form Image command 3-17, 6-10
Form usage

Auto Form Design option 5-6
changing 4-9, 4-10
choosing an option 4-7 to 4-8
selecting an option 4-8
Use Designed Form option 4-10
Use Original Form option 4-10
where to select 4-8

Form Usage command 4-10
Form Usage dialog box 4-9, 4-10
Format menu commands

Align 6-39
Bring to Front 6-40
Font 6-35
Object Appearance 6-29
Object Definition 3-19, 6-11, 

6-16
Send to Back 6-40
Size and Position 6-43
Table AutoFormat 6-38
Text 6-36

Formatting
affected by language selection 

5-23 to 5-24
Formatting text 6-35 to 6-37
Forms

see also Design view
creating a new form 5-20
data/form protection 8-26

design tutorial 3-21 to 3-45
document quality 10-7
faxing 5-14 to 5-16
fill option in Form Assistant 

5-13
filling tutorial 3-10 to 3-12
filling with Form Assistant 5-13
form protection 8-26
importing image files with 

Form Assistant 5-8 to 5-9
importing image files with the 

Scan Form command 5-10 

to 5-12
load form tutorial 3-2 to 3-9
opening a form to design 5-19
opening forms 5-21
paper transparency 10-8
preorganization before 

designing 3-22
printing 5-14 to 5-16
scanning angle 10-7
scanning forms with Form 

Assistant 5-2 to 5-3
scanning forms with the Scan 

Form command 5-4 to 5-7
searching for information 5-17 

to 5-18
selecting a language for 5-22 to 

5-25
shared 8-20 to 8-21
Windows forms support 10-9

Functions
Abs 9-11
all 9-11 to 9-32
Avg 9-12
Date 9-12
DayName 9-12
DayOfMonth 9-13
DayOfWeek 9-13
DayOfYear 9-14
defined 9-11
Exp 9-14
FV 9-15
Hour 9-16
If 9-16
Int 9-17

Left 9-17
Length 9-18
Ln 9-18
Log 9-19
Lower 9-19
Max 9-20
Middle 9-20
Min 9-21
Minute 9-21
Mod 9-21
Month 9-22
MonthName 9-23
Pi 9-23
PMT 9-24
Position 9-24
Proper 9-24
PV 9-25
quick reference chart 9-33 to 

9-35
RecordCount 9-26
Replace 9-26
Replicate 9-27
Right 9-27
Round 9-28
Second 9-28
Sign 9-29
sorted by type 9-36
Sqrt 9-29
Sum 9-30
Time 9-30
Trim 9-31
Trunc 9-31
Upper 9-32
Year 9-32

G
Go To command 8-6
Graphic Definition dialog box 3-19, 

6-11
options 6-12 to 6-13
Select button 3-36
selecting sources 6-9

Graphic File source option 6-9
Graphic object

creating 6-8 to 6-13
defining 6-9 to 6-13
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import options 3-36
tutorial 3-36
when to use 6-15

Graphics
copy from original to designed 

form 6-10
filling a fill graphic field 7-5 to 

7-7
form image source 6-10
graphic file source 6-9
graphic object tutorial 3-18 to 

3-20
import options 7-6 to 7-7
importing into a graphic object 

6-8 to 6-13
options for import 6-12 to 6-13
supported formats 10-9

Guidelines
calculation 9-7
creating objects 6-6

H
Highlight Fill Areas command 3-11
Horizontal bar

resize form image windows 
3-17, 6-10

use to close form image 3-20
HP AccuPage

benefits of 10-8
when to use 5-4

I
Image files

import with Form Assistant 5-8 

to 5-9
import with the Scan Form 

command 5-10 to 5-12
supported formats 10-9

Import command 8-22
Import dialog box 8-22
Import Setup dialog box 8-22
Importing

See also Importing data
an image file with Form 

Assistant 5-8 to 5-9

an image file with the Scan 
Form command 5-10 to 

5-12
definition options for import 

6-12 to 6-13
graphic from form image 

source 6-10
graphic from graphic file source 

6-9
graphics 6-8

Importing data
See also Importing
Auto linking 8-24
data sources 8-21
linking field names 8-22
to an OmniForm database 8-21 

to 8-25
Improving performance 10-7 to 10-8
Installation

integrating OmniForm with 
PaperPort 10-3

process 2-3
system requirements 2-2
technical information/

troubleshooting 10-3
uninstalling OmniForm 10-3

International options
check/change for spell 

checking 7-9 to 7-10
dictionaries 7-10
selecting 5-22 to 5-25

L
Language, selecting for a form 5-22 

to 5-25
Line object, creating 6-7
Linking

Auto linking 8-24
field names for import 8-23

Logo file 3-36
Low memory

error messages 10-10
fixing 10-5

M
Memory

and installation 10-3
error messages 10-10
low, fixing 10-5

N
New command 5-20
New form 3-22, 5-20
New Form option 5-22, 5-23
Numbers control panel 9-7
Numbers, affected by language 

selection 5-23 to 5-24

O
Object appearance

background 6-29 to 6-30
border 6-30 to 6-31
changing 6-29 to 6-32
define shadow 3-31
fill lines 6-31 to 6-32
paint order 6-32

Object Appearance command 6-29
Object definition

check box 6-24 to 6-25
circle text 6-26
comb 6-21 to 6-23
comb element 6-23
fill graphic 6-27
fill text 6-17 to 6-21
graphic 6-9 to 6-13
how language selection affects 

options 5-25
table 6-26
table cell 6-27

Object Definition command 3-19, 
6-16

Objects
aligning 6-39
changing appearance 6-29 to 

6-32
changing background 

appearance 6-29 to 6-30
changing border appearance 

6-30 to 6-31
changing fill lines appearance 

6-31 to 6-32
converting to another type 6-43
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creating 6-6 to 6-15
creation guidelines 6-6
defining 6-16 to 6-28
filling objects in fill view 7-3 to 

7-8
formatting text 6-35 to 6-37
importance of defining 3-49
moving 6-34
overlapping 6-40
paint order 6-32
placing in table cells 6-42
redesign a table 6-38 to 6-39
resizing 6-34
scaling graphics 3-36
select multiple 3-41
selecting 6-33
sending to front or back 6-40
Shift key, using 6-6
table tutorial 3-31 to 3-35
tutorial on creating objects 3-23 

to 3-36
OCR

correct text 3-18, 6-10
recognition problems 3-12, 3-17
verify 3-17

OmniForm
arrange toolbar 6-4
calculation toolbar 9-2
design view 4-5
drawing toolbar 6-5
features overview 1-2
fill view 4-6
font/text toolbar 6-4
installing 2-3
limits 10-6
standard toolbar in design view 

6-3
standard toolbar in fill view 7-2
starting 2-4
supported programs and file 

formats 10-9
system requirements 2-2

OmniForm Data file
exporting information to 8-17 

to 8-19

importing to database 8-21 to 

8-25
use to open shared form 8-20 to 

8-21
OmniForm Filler 3-50, 8-27
OmniForm for Windows, form 

compatibility 10-9
Online services 10-13
Open command 5-21
Open dialog box 5-21
Operators

buttons 9-9
overview 9-9
quick reference chart 9-10

Option group 3-30, 6-24
Option key, use to copy object 6-6
Original form usage option 4-9
Oval object, creating 6-8

P
Page Setup command 3-22
Page Setup dialog box 3-22
Paint order in OmniForm 6-32
PaperPort integration 10-3
Preferences dialog box

check/change for spell 
checking 7-9 to 7-10

File Locations tab 8-20
International tab 5-22

Prefill element
and Interpret As option 6-22
creating 6-23

Print command 5-15
Print dialog box 5-15
Printing

forms 5-14 to 5-16
from Form Assistant 5-14 to 

5-15
using Print command to fax 

5-14 to 5-16
Product support

see also Troubleshooting
error messages 10-10 to 10-12
information to provide 10-13
US support number 10-13

Protection

OmniForm Filler 8-27
Protect Data/Form options 

8-26
tutorial 3-50

Protection command 8-26
Protection dialog box 8-26

R
Recalculate command 8-13, 9-7
Recalculate dialog box 8-14
Recalculating records 8-13 to 8-14
Recognition

circle text not recognized 3-12
correct text 3-18, 6-10
factors affecting accuracy 10-7 

to 10-8
font style 10-7
text errors, causes 3-17
underlined text 10-7
unrecognizable characters 10-7
verify 3-17

Record Range dialog box 8-19, 8-24
Records

buttons in toolbar 8-6 to 8-7
create new 8-3 to 8-5
create subset 3-49
deleting 3-51, 8-15
duplicating 8-5 to 8-6
how changes to form affect 3-50
management of 8-3 to 8-25
search 8-7 to 8-11
search tutorial 3-48 to 3-49
sort tutorial 3-49

Records menu commands
Delete All Records 8-15
Delete Record 8-15
Duplicate Record 8-6
Go To 8-6
Recalculate 8-13, 9-7
Search 5-18, 8-7
Sort 8-12

Rectangle object, creating 6-8
Rotate

line object 6-7
page during scan 5-5
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S
Sample form

fax form to computer 3-6 to 3-9
faxing tutorial 3-6
hard copy 3-2
importing tutorial 3-6 to 3-8
location of TIFF file 3-2
scanning tutorial 3-3 to 3-5

Save command in fill view 7-12
Scan Form command 5-4 to 5-7, 5-10 

to 5-12
Scan Form dialog box

Auto Form Design option 4-8
form usage options 4-8
language selection in 5-24
settings 5-4

Scanner
see also Scanning
error messages 10-10
glass clarity 10-8
hardware 10-4
options in Scan Form dialog 

box 5-4
supported scanners 10-9

Scanning
and paper thickness 10-8
angle 10-7
books 5-5, 5-11
factors affecting recognition 

accuracy 10-7 to 10-8
paper forms with Form 

Assistant 5-2 to 5-3
paper forms with the Scan 

Form command 5-4 to 5-7
problems 10-4
system hang during 10-4
using HP AccuPage 10-8

Scrap Album
copying objects to 6-44
copying scraps to a form 6-45
creating new 6-46
defined 6-44
deleting 6-46
deleting scraps 6-46
opening 6-44
placing scraps in 6-45

renaming 6-46
renaming scraps 6-45
using 6-44 to 6-47
views 6-47

Search
Clear Search button 8-11
conditions 8-8 to 8-10
found set 3-49, 8-7, 8-11
procedure 8-7 to 8-11
results 8-11
tutorial 3-48 to 3-49

Search command 5-18, 8-7
Search dialog box 5-18
Select button 3-36
Select Import Files dialog box 8-22
Select Special command 6-34
Select Special dialog box 6-34
Selecting objects

multiple 3-41, 6-33
single 6-33
text 3-18
with the Select Special 

command 6-34
Send to Back command 6-40
Setup program requests same disk 

10-3
Shift key

use to create objects 6-6
Size and Position command 6-43
Size and Position dialog box 6-43
Snap Object(s) to Fit Table Cell 

option 6-43
Snap to Grid command 3-41
Sort command 8-12
Sort dialog box 8-12
Sorting

database records 8-12 to 8-13
tutorial 3-49

Spelling
check form language first 7-9
checking in fill view 7-9 to 7-11

Spelling command 7-9 to 7-11
Spelling dialog box 7-11
Standard toolbar

in design view 6-3
in fill view 7-2

System requirements 2-2

T
Tab Order command 3-43, 6-41
Table AutoFormat command 6-38
Table cell

defining 6-27
placing objects in 6-42

Table Definition dialog box 6-26
Table object

auto formatting 6-38
creating 6-14 to 6-15
defining 6-26
design tutorial 3-31 to 3-35
filling in fill view 7-4

Technical information
see Troubleshooting

Text command 6-36
Text dialog box 6-36
Text formatting 6-35 to 6-37
Text object, creating 6-7
Toolbars

arrange toolbar 6-4
calculation toolbar 9-2
drawing toolbar 6-5
font/text toolbar 6-4
standard toolbar in design view 

6-3
standard toolbar in fill view 7-2

Tools menu commands
Calculation 9-2
Check Spelling 7-9 to 7-11
Protection 8-26
Scrap Album command 6-44
Snap to Grid 3-41
Tab Order 3-43, 6-41

ToolTips 3-10
Troubleshooting

back up files 10-2
error messages 10-10 to 10-12
font types and recognition 10-7
improving performance 10-7 to 

10-8
installation and setup 10-3
low disk space error messages 

10-10
Index-6 



low memory error messages 
10-10

memory and installation 10-3
OmniForm limits 10-6
operation 10-5 to 10-6
paper transparency 10-8
PaperPort files 10-3
product support 10-13
recognizing underlined text 

10-7
scanner error messages 10-10
scanner glass clarity 10-8
scanning problems 10-4
system hang 10-4
system setup checklist 10-2
try this first 10-2
uninstalling OmniForm 10-3
unrecognizable characters 10-7

U
Uninstalling OmniForm 10-3
Unrecognizable characters 10-7
US product support number 10-13

V
View menu commands

Design 5-19
Fill 5-13
Form Image 3-17, 6-10
Form Usage 4-9
Highlight Fill Areas 3-11
Zoom 3-11

Views
design view tutorial 3-13
fill view tutorial 3-10
form image 3-17
use horizontal bar to close form 

image 3-20
with Form Image 6-10
zoom choices 3-11

Virtual memory, using 10-5

Z
Zoom command 3-11
Index-7
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