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Where To Begin 

You can choose how you want to learn Microsoft Works, depending on how 
experienced you are with the Macintosh, and how much help and practice 
you want to have before you begin using Microsoft Works on your own. 

First, if you are new to the Macintosh, see your Macintosh owner’s guide to 
learn basic Macintosh techniques. 

Second, follow the “Getting Started” instructions in the Lessons manual to 
personalize and make copies of your Works disks. (If the Lessons manual is 
unavailable, see Appendix G.) 

If Do this 

You have Apple’s HyperCard and 
you want to use the on-line 
tutorial to start learning Microsoft 
Works 

Follow the instructions in the Lessons 
manual, “Starting a Works Tour,” to 
learn about basic Works tasks — right on 
the computer. 

You want some practice before 
you begin using Microsoft Works 
on your own 

Start with the Lessons manual. You’ll 
use actual Microsoft Works software and 
sample files to practice many of Micro¬ 
soft Works’ features. 

You want to start using Microsoft 
Works for your own tasks, and 
you are an experienced Macin¬ 
tosh user 

You’ve used a previous version 
of Microsoft Works 

Go right ahead and begin. With the 
Using Microsoft Works manual as a 
guide, you’ll learn about everything you 
can accomplish with Microsoft Works. 

Read Appendix G, “New Features in 
Works 2.0,” to learn about changes and 
new features in Microsoft Works. 
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Welcome 
xv 

Welcome to Microsoft Works — all the office tools you may ever need: 

■ The Word Processor with spelling checker, mail merge, and drawing 

■ The Database with reporting 

■ The Spreadsheet with charting and drawing 

■ Communications 

■ Macros and a print preview feature in all the tools 

Use the Microsoft Works tools to automate your work. The limits are up 
to you. 
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The Word Processor 

Use the Word Processor to write and edit text. Cut and paste electronically 
to polish your prose. Let Microsoft Works check your spelling and suggest 
corrections. Change the margins and indents and watch Microsoft Works 
make everything fit. Change words quickly and easily by searching and 
replacing. Reformat your document with a few clicks of the mouse. Draw 
lines, circles, boxes, and other graphics for extra flair. Paste in a chart or 
a picture to illustrate your text. Use desktop publishing techniques to create 
a newsletter with linked columns. 

The Database 

Use the Database to file information. Add new records and remove ones you 
don’t need. Sort lists to organize your reports. Have Microsoft Works find 
the information you’re looking for. Prepare numerous reports from one set of 
information — with each report providing just the facts you need. 

The Spreadsheet 

Use the Spreadsheet to calculate numbers. Set up elaborate formulas and let 
Microsoft Works get the answers for you. Change your assumptions and 
change your numbers — see what you get. Use built-in calculations to make 
your work easier. Look at opposite ends of a giant Spreadsheet document — 
at the same time. Save notes about your data and formulas along with your 
Spreadsheet document and hide, view, or print them as you choose. 

Use the Spreadsheet’s charting capability to see what your Spreadsheet 
numbers look like in charts. Change a number in a Spreadsheet document and 
see how it affects your chart — instantly. Add labels and other graphics to 
your Spreadsheet documents. Try different comparisons using the same docu¬ 
ment. Spot trends at a glance, or see who’s got the biggest piece of the pie. 

Communications 

Use Communications to send your information over the telephone. Talk to 
commercial information services to get the latest stock quotes or information 
on almost any other topic. Exchange documents with other computer users. 
Keep in touch with a computerized bulletin board. Communicate with a 
mainframe computer by telling your Macintosh to emulate a VT52 or VT100 
terminal. 
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Using the Tools Together 

Microsoft Works is five tools, but one program. That means you can work 
with several tools at once and move information from one tool to another. 
For example, you can write a letter with the Word Processor, check an 
address in the Database, project future sales with the Spreadsheet, and see 
how your projections look with the Spreadsheet’s charting capability. Then 
you can copy the chart into your letter and send it off to a colleague with 
Communications. 

Using both the Word Processor and the Database, you can personalize your 
form letters and print mailing labels to send them out. 

Or, you can insert stock quotations you receive with Communications into a 
Spreadsheet document to see how your portfolio is doing. 

You can preview all of your documents before you print them, and you can 
use macros to automate repetitive tasks in all of the tools. 

About This Manual 

Read this manual when you’re ready to start using Microsoft Works for your 
own tasks. This manual assumes you have read your Macintosh owner’s 
guide and are familiar with basic techniques, such as choosing commands, 
selecting text, and working with windows. 

This manual is divided into six parts. The first part, “Common Tasks,” 
guides you through tasks that you’ll perform every time you use Microsoft 
Works. These include tasks such as creating, saving, and printing a docu¬ 
ment. The next four parts explain the individual Microsoft Works tools: the 
Word Processor, the Database, the Spreadsheet with charting capability, and 
Communications. The last part of the manual, “Using the Tools Together,” 
explains how to integrate information from the different tools. 

Information on each tool is presented in this way: 

■ The first chapter of each part shows what a document looks like and 
explains how to begin using the tool. 

■ The middle chapters explain, step by step, how to use the tool to perform 
specific tasks. 

■ The final chapter describes the commands you can use with the tool. 

About this manual 
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About documents 
and files 

To learn how to perform a certain task, you should first read the step-by-step 
description. Then turn to the last chapter on the tool for details on the 
specific command or dialog box you’ll be using. 

The appendices explain how Microsoft Works uses disk space, how to use 
Works with other applications and with the LaserWriter printer, and how to 
choose commands from the keyboard. They also explain tool capacities and 
memory limits for various tools, networking, changes since versions 1.0 and 
1.1, and escape codes for VT52 and VT100 terminal emulation. 

For a definition of any unfamiliar terms, look in the index for the entry that 
contains the term followed by the word “defined.” 

Note The full name of this product is Microsoft Works. This manual uses 
the name “Works” for short. 

About Documents and Files 

Throughout this manual, the words “document” and “file” are used to 
represent two distinct items. 

A document is the information held in the Macintosh’s memory. When you 
create a new document, the information exists only in memory until you save 
it on a disk. Once saved, the information stored on the disk is called a file. 
When you open a file from a disk, the Macintosh puts a copy of the informa¬ 
tion into its memory and leaves the original on the disk. The information held 
in memory is called a document. If you make changes to this document and 
then save it, the new information will replace the file currently on the disk. 

■ You create a new... 

■ You make changes to a... 

■ You save a... 

■ You print a... 

■ You close a... 

■ You open an existing... 

■ You delete a... 

document 

file 
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Symbols and Conventions 

The Works manuals, Lessons and Using Microsoft Works, use a few special 
symbols and conventions. 

■ Extended keyboards (Macintosh SE and Macintosh II) have a Delete key 
on the upper-right comer of the main keypad. The Macintosh Plus key¬ 
board has a Backspace key. If you don’t have an extended keyboard, 
press the Backspace key whenever the manual says to press the Delete 
key. 

■ Some keyboards contain additional keys you can use with Works. 

Keyname Use 

Home 

End 

Page Up 

Page Down 

Moves pointer to top of scroll bar 

Moves pointer to bottom of scroll bar 

Moves pointer up one page 

Moves pointer down one page 

■ Keys are sometimes used in combination. If the manual says to press 
Shift + A, for example, hold down the Shift key and press the A key. 

■ The Command key refers to the key marked with §€ . 

Getting Started 

For instructions on how to personalize your master disk, make working 
copies of your disks, and start using Works, see the “Getting Started” 
section in the other Works manual, Lessons. (If Lessons is unavailable, see 
Appendix G.) 

About the README File 

Because Microsoft is constantly improving and updating its products, some of 
the most recent information may not appear in the manuals you receive. If 
there is a README file on your Works Startup disk, it contains important 
information about Works. 

Symbols and 
conventions 

Getting started 
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To view the README 
file 

Product support 

To view the file: 

[7) From the Finder, double-click the README file icon. 

The first page of the README file appears. 

[7] If there is more than one page, use the scroll bar on the side of the win¬ 
dow to scroll through the file as you read. 

If you don’t remember how to scroll through a file, see your Macintosh 

manual. 

[I] To close the file, choose Quit from the File menu. 

Product Support 

If you have a question about Works and you can’t find the answer in your 
manuals, call our Product Support staff. Before you call, please be certain 

that you: 

■ Review the subject in your manuals. 

■ Review the “Getting Started” procedures in Lessons to ensure that your 
system is properly installed. (If Lessons is unavailable, see Appendix G.) 

If you are unable to resolve your problem: 

[7] Check the product number on your disk label. 

[2] Prepare a description of the problem. Include the exact wording of any 
error messages and any other relevant information. 

[3] Have your manuals nearby. 

E Try to call from a telephone located near your computer so you can refer 

to Works on your screen. 

[5] Call Product Support at (206) 454-2030, Monday through Friday between 
6:00 a.m. and 6:00 p.m. Pacific Standard Time. 



Common Tasks 

Many routine tasks are common to all of the tools in Microsoft Works. 
In each tool, you’ll use the same commands and procedures to perform 
these tasks. 



2 Common Tasks 

This part of the manual contains two chapters describing common tasks and 

commands: 

■ Chapter 1, “Common Tasks and Procedures,” explains many of the tasks 
you’ll perform every time you use Works, such as opening files, creating 
and closing documents, getting help, and printing. This chapter also 
explains drawing, which you can use in the Word Processor or Spread¬ 
sheet tools, and macros, which you can use in all of the tools. 

■ Chapter 2, “Common Tasks Command Reference,” describes the menus 

and commands common to all tools in Works. 



1 Common Tasks and 
Procedures 

Many routine tasks are common to all of the tools in Microsoft Works. This 
chapter shows you how to perform these common tasks: 

■ Open a file and create a new document. 

■ Save a document. 

■ Close a document. 

■ Delete a file. 

■ Use the help information. 

■ Print a document, including headers and footers. 

■ Quit Works. 

In addition, this chapter contains information on two of Works’ special 
features. Use this chapter to learn to: 

■ Draw pictures in your Word Processor or Spreadsheet document. 

■ Use macros. 

For information on using tools together, like copying a chart to the Word 
Processor, see “Using the Tools Together,” the last part of this manual. 

Opening a File and 
Creating a New Document 

When you start Works, you’ll see the Open dialog box. You use the Open 
dialog box to open files from a disk. You can also create new documents 
from this dialog box, as well as with the New command from the File menu. 

You can have up to 14 windows on the desktop at once. The maximum 
number depends on how much memory your Macintosh has, and how large 
your documents are. If you have some documents that you refer to often, like 
an address list and a telephone message form, you can leave these on the 
desktop while you’re working on other documents. Whenever you need to 
look up a name or take a message, bring the document you want to the front 
by using the Window menu. 
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To open an 
existing file 

In the Open dialog box, you can also select the Works Desktop to open the 
document or documents you had on the desktop the last time you used 
Works. For more information, see “Quitting Works” in this chapter. 

For information on using files not created with Works, see Appendix B, 

“Using Works with Other Applications.” 

Opening a File from a Disk 

Works lets you open files on your hard disk or in internal or external disk 

drives. 

To open an existing file: 

[7] Choose Open from the File menu. 

Works displays the Open dialog box, listing all files and folders on the 

current disk. 

Types of files you can choose from 

Name of current 
disk 

Name of current 
disk or folder 

List of files and folders 
(all files or just the 
type you choose) 

[2] Select the name of the file you want to open, 

a Click the Open button. 

Works opens a window with a document that is a copy of the file you 
selected. You can work with this copy, which is in the computer’s memory. 
The original file remains on the disk until you replace it by saving changes to 

it, or until you remove it from the disk. 

For information on opening files created in a previous version of Works, see 

appendix G. 
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If you want to look at a listing of a specific type of file in the Open dialog 
box, such as Word Processor or Database files, you can tell Works to list 
only those. 

To list files of one type: 

S Click the icon for the tool whose files you want to see. 

The list changes to show only files of the type you chose and all folders. 

Creating a New Document 

You can create a new document in Works with either the New command or 
the Open command. 

To create a new document from any tool, use the New command. 

m Choose New from the File menu. 

Works displays the Create New Document dialog box. 

E Click the icon for the type of document you want to create. 

E Click the OK button. 

Works opens a new document window on top of the other windows on the 
desktop. 

You can also create a new document from the Open dialog box, which 
appears when you start Works or when you choose the Open command from 
the File menu. 

To create a new document from the Open dialog box: 

E Click the icon for the type of document you want to create. 

E Click the New button. 

Works opens a new document window on top of any other windows you may 
have on the desktop. 

Saving a Document 

All the information that you produce with Works stays in your Macintosh’s 
memory until you close the document or quit Works — or until the power 
goes off. If there’s a power failure you could lose a lot of work. That’s why 
you should save your documents frequently. When you save a document, 
Works stores it safely on a disk. Then, if the power goes out, or you 
accidentally turn off the computer, you’ll have a recent copy to work with. 

This section explains how to save documents and continue working. You can 
also save when you close a document or quit Works. To find out more about 
this type of saving, see “Closing a Document” and “Quitting Works” in this 
chapter. 

To list one type of file 

To create a new 
document from a tool 

To create a new 
document from the 
Open dialog box 
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To save a document 
for the first time 

The first time you save a document, you give it a name. 

m Choose Save As from the File menu. 

Works displays the Save As dialog box, which is ready to accept the 
name you type. 

Type a name here, up 
to 32 characters. 

Click here to eject 
the disk and replace 

it with another. 

|S) Tutorial | 

C > 
Q Brittle 
D II 
D Final Report 
D Letter t > 

\ Saue Document Rs: El Works Prog J| 
Untitled r -/ 

i tjeci j 

| /[ Sane ] [ Cancel ] C Driue ] 

r jl (•> Normal Q Export O Stationery 

L □ l:Kpor1 IK Rich I'OKl Format 1 
Click here to save 
the document with the 
name you just typed. 

Click here to cancel 
the save and go back 
to the document. 

0 Type a name for the document. You can use any characters except 
colons, including spaces and both uppercase and lowercase letters. 

There is little free space on the Works Program disk. If your computer 
doesn’t have a hard disk, you’ll probably want to save your documents on 
another disk. 

0 Use the Eject button to change to another disk. 

If the disk you insert is not initialized, Works asks if you want to initial¬ 
ize it. Click the Two-Sided button to initialize the disk if you’re asked. 

If you have another disk drive, you can use the Drive button to switch to 
the other disk drive, and then save the document on a disk in that drive. 

0 Click the Save button or press the Return key. (Or click the Cancel but¬ 
ton, if you decide not to save.) 

Once Works saves the document on the disk you’ve chosen, you can continue 
using the document. If you have two 3.5-inch disk drives, and you’ve ejected 
the Program disk and inserted a different disk to hold the document, when 
you choose any command, Works asks you to insert the Program disk. Insert 
that disk to continue working with Works. 
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If you’re working with a document that you’ve already saved, you can save 
changes as you work. 

0 Choose Save from the File menu. 

Works saves your changes, and you can continue working with the 
document. 

When you want to save both the original document and the changes you’ve 
made to it, you can save the document with a different name. 

0 Choose Save As from the File menu. 

Works shows you the current name of the document. 

0 Type a new name for the document. 

The new name you type replaces the current one in the text box. 

0 Click the Save button or press the Return key. 

If a file with the name you’ve typed is already on the disk, Works asks if 
you want to replace it with the document you’re saving. You can replace 
it, type a different name, or cancel the command. 

Works saves the document with the new name. The name of the document on 
the desktop changes to the new name. The original file remains on the disk 
with its old name. If you later want to remove the original file, see “Deleting 
a File” in this chapter. 

Note When you use the Save As command, Works treats Database docu¬ 
ments a little differently from the others. For more information, see “Save 
As” in Chapter 2 and “Saving a Selection with a Different Name” in 
Chapter 8. 

If you know you’ll be exporting a file from Works to another program, you’ll 
usually need to save it as a text file. This means that only the data, and not 
the formatting information, is saved. 

0 Choose Save As from the File menu. 

0 Follow all the regular procedures, then click the Export option. 

0 Click the Save button. 

Note In the Word Processor, you can export a file that contains both data 
and formatting by choosing the Export As Rich Text Format option in the 
Save As dialog box. For more information on this option, see “Export As 
Rich Text Format” in Chapter 2. For more information on exporting Works 
files to other applications, see Appendix B, “Using Works with Other Appli¬ 
cations.” 

To save changes to 
a document 

To save a document 
with a different name 

To save a document 
to be exported 
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Closing a Document 

To close a document When you want to remove a document from the desktop, you close it. 

0 Choose Close from the File menu, or click the close box in the upper-left 
comer of the window. 
If you’ve made any changes to the document, Works asks if you want to 
save the changes. 
You can choose to save your changes, throw them out, or cancel the 
close. For instructions on saving, see “Saving a Document” in this 
chapter. 

0 Click the Yes button to save changes, or the No button if you don’t want 
to save changes. 

Works closes the document and removes it from the desktop. 

Deleting a File 

To delete a file When you delete a file, Works erases the file from the disk completely. You 
might want to delete a file if you need room on a disk to save another docu¬ 
ment, or if you’ve saved a document with another name and want to discard 
the original file. 

0 Choose Delete from the File menu. 

Works shows you a list of files to choose from. 

List of files and folders on the current disk 

Delete File: 

\ 

|Q Tutorial | 

D Addresses 
D Article 
D Budget 
D Final Report 
D Letter 
D Report 
D Requests 
□ Results 
□ Sales Projections 

Free Space: 128K 

E3 

fa 

® Works Pr.. 

[ Eject 

[ Delete ] 

[ Cancel ] 
\ 

Amount of free space 
on the current disk 

Click here to eject the disk 
and replace it with another. 

If necessary, click the Eject button to change disks or the Drive button to 
change disk drives. 
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GO Select the file you want to delete. 

0 Click the Delete button. 

Works asks you to confirm that you want to delete the file. 

0 Click the OK button to delete it. 

Works deletes the file from the disk. 

Getting Help 

Works Help explains briefly how to use any command in Works, and refers 
you to a page in this manual for more information. 

To get help: 

m Choose Help from the Window menu. 

The Help window appears at the bottom of your screen. 

The window contains general information about Help and the tool you’re 
using. When you move the pointer outside the Help window, it turns into 
a question mark. 

To get help 
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0 Choose the command you want help on just as you normally choose a 
command from a menu. 

The Help window displays information about the command you chose. 

To see more information, you can scroll the Help window. To get help on 
another command, just choose it from a menu. To leave the Help window 
open and continue working on your document, click anywhere in the 
document. To close the Help window, click its close box. 

Printing a Document 

You can print documents from all of the Works tools except Communica¬ 
tions. In Communications, you can print only the contents of the active win¬ 
dow by using the Print Window command. Although you adjust the format 
for each tool differently, you print them all the same way using the File 
menu. 

Works comes ready to print using both the regular and wide ImageWriter and 
ImageWriter II printers. Your Macintosh owner’s guide has details on how to 
set up the ImageWriter. For information on printing with the LaserWriter, see 
Appendix C, “Printing with the Apple LaserWriter.” 

When you’re working with the Database, you must be in a report window to 
print or adjust the page setup. For more information, see Chapter 9, “Making 
a Report.” 

Before you print, it’s a good idea to save your document. For more details on 
saving, see “Saving a Document” in this chapter. 

To change page 
specifications 

Setting Up the Page 

Before you print a document, choose the Page Setup command from the File 
menu to specify exactly how you want it to be printed. The Page Setup com¬ 
mand lets you specify paper size, printing orientation, special effects, 
headers, footers, and margins. 

To change page specifications: 

0 Choose Page Setup from the File menu. 

The Page Setup dialog box appears. 

0 Click the appropriate options, and type any information that Works needs. 
(Paper size, orientation, and margins, for example.) 
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0 Click the OK button or press the Return key. 

Works stores your specifications with the document, so you only have to 
change them once. For a complete description of the available options, see 
“Page Setup” in Chapter 2. 

With Works and an ImageWriter, you can print on any size paper that fits in To use custom paper 
your printer. To use a paper size other than those offered, click the Custom 
Size option in the Page Setup dialog box. For example, click Custom Size if 
you are printing mailing labels. Then you can specify the exact dimensions of 
your paper in the Paper Width and Paper Height boxes. 

Use a header or footer when you want to print information at the top or bot- To use headers 
tom of every page. The same header or footer will appear on every page of a and footers 
document, and page numbers will appear in sequence. 

Headers and footers are set up in the same way. In the Page Setup dialog 
box, you tell Works what information to print by typing it exactly as you 
want it to appear. To indicate information such as the current date, page 
number, or document name, or to have certain information in bold or italic 
type, Works provides a set of formatting commands; for example, &I speci¬ 
fies that what follows should be printed in italic type. For a list of all format¬ 
ting commands, see “Page Setup” in Chapter 2. 

Formatting commands won’t appear 
in the printed document. 

Headers and footers in Works have been designed to work the same way in 
each tool, so you need to learn only one procedure. However, in the Word 
Processor, additional options are available. For more information, see 
“Headers and Footers” in Chapter 4. 

If you don’t want the header or footer to print on the first page of your Word 
Processor document, choose Title Page from the Format menu before you 
print. The Title Page command does not change the format of the first page; 
it only prevents the header or footer from appearing. 
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To print a document 

To cancel printing in 
progress 

To print only the 
active window 

About Works Desktop 

Printing Your Document 

When you’re satisfied with your page setup, you are ready to print your 
document. 

E Choose Print from the File menu. 
The Print dialog box appears. Unless you change the settings in this box, 
Works will print one copy of your entire document using the preset 
options Faster (for standard quality) and Automatic (for paper feed). 

If you want to see what your document looks like before printing, click 
the Print Preview option. For more information on Print Preview, see 
“Print” in Chapter 2. 

E Make any desired changes to the print specifications. 

E Click the OK button to accept your specifications and start printing. 

Works begins to print your document. 

You can cancel the Print command at any time. 

0 Hold down the Command key and type a period (.). 

Works may continue to print briefly until the printer’s memory is empty. 
After printing stops, Works returns you to the document window. 

If you come across a particular window of information that you’d like to have 
on paper, you can print just that window with the Print Window command 
from the File menu. 

Quitting Works 

When you choose Quit from the File menu, Works records which documents 
you have on the desktop in a file named Works Desktop. 

The next time you start Works, you can select the Works Desktop file in the 
Open dialog box to restore the documents that were on the desktop when you 
left it. You can also double-click the Works Desktop icon from the Finder. 
With Works Desktop, you won’t have to open individual files in order to 
pick up where you left off. 

Note You can create your own Works Desktop files without quitting 
Works, save them with different names, and open them any time you choose. 
For more information, see “Make Works Desktop” in Chapter 2. 
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To quit Works: 

0 If you want to set up the Works Desktop file in a particular way, arrange 
your desktop as you want it to appear the next time you use Works. 
(Close any documents that you don’t want to appear when you next open 
Works Desktop.) 

GO Choose Quit from the File menu. 

If you’ve made changes to any open document since the last time you 
saved, Works asks whether or not you want to save changes for each 
document. 

H] For each document, click Yes to save changes, or No if you’d rather not. 

Works saves any changes and takes you to the Finder. A list of your open 
documents is recorded in a file called Works Desktop. 

You can rename the Works Desktop file from the Finder just like any other 
file. By using different names, you can save different arrangements of files 
and open each arrangement whenever you need it. For example, if you want 
a group of documents to be on the desktop every time you start Works, you 
can save the group and rename it Start Works. This could include a phone 
list, a to-do list, or a memo template. Or, you can set up any group of 
related documents that you use to perform a regular task, and rename it to 
reflect its function. For example, you could save a Word Processor document 
and a Database document and rename the group MailMerge. You can have as 
many renamed Works Desktop files as you want. 

Note The Works Desktop file contains a list of the documents from your 
desktop, not copies of the documents themselves. If you include a document 
in a Works Desktop file, then make changes to that document by opening and 
editing it individually, the latest version will appear on your desktop when 
you next open the Works Desktop file. 

Works does not save any information about untitled documents in the Works 
Desktop file. To include these documents, save each one with the Save As 
command to give it a name before you choose Quit from the File menu. 

When you want to work with a certain desktop arrangement, you have to 
start up with the same disks in the disk drives as when you quit, or Works 
may not be able to find all the files you need. If Works can’t find the files, it 
displays an alert box telling you so. Replace the files in their previous loca¬ 
tions and choose the Works Desktop file again. 

Using Draw 

With Draw, you can emphasize text or numbers by drawing boxes around 
them, add labels with arrows to charts, and draw arcs and freehand shapes in 
your Word Processor and Spreadsheet documents. You can also use desktop 
publishing techniques to create a newsletter with side-by-side columns whose 
contents automatically flow from one page to the next. 

To quit Works 



The Draw Layer 

Pictures are drawn in a transparent layer on top of your document. You can 
make changes to this layer without affecting the document underneath. 

Text layer Draw layer 

Because the draw layer is transparent, you can wrap text around illustrations, 
and include text from your document in the picture area. 

Everything on the draw layer—a line, a rectangle, an arc, or even a para¬ 
graph of text—is treated as a unique object. You can’t erase part of an 
object, but you can change an object’s overall size, shape, location, and 
pattern. 

The draw layer itself is composed of many planes — objects overlap and 
appear to be behind or in front of other objects because each is drawn on its 
own plane. 

Selected objects in the draw layer can be copied into another Works Word 
Processor or Spreadsheet document, but they can’t be copied into the Data¬ 
base or Communications tools. For more information on copying objects 
between documents, see Chapter 20, “Moving Information Between the 
Tools.” 

About Pixels 

Computer screens are composed of small dots, called pixels. (Pixel is short 
for picture element.) There are 72 pixels per inch on a Macintosh screen. 

Pixels are either “on” or “off.” On a black-and-white monitor, for example, 
“on” pixels are black and “off’ pixels are white. An object can contain a 
decorative pattern made up of both “on” and “off’ pixels. 
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On pixel 
Off pixel 

On a color monitor, each pixel in a pattern, whether “on” or “off,” can 
appear in any one of eight colors. 

But your drawings aren’t limited to only eight colors — your eye naturally 
mixes two colors in a pattern together and creates the effect of a third color. 
For example, an object with a pattern of red “on” pixels and blue “off” pix¬ 
els appears purple on the screen. Because your eye mixes the colors, the 
original eight colors can be used to create the appearance of many more 
colors. 

Starting Draw 

You can start Draw from the Word Processor or the Spreadsheet, in either a 
new or an existing document. 

To start Draw: 

® Choose Draw On from the Edit menu. 

The Tools palette appears. The palette contains the following tools: 

Selection tool 

Text tool 

Line tool 

Freehand tool 

Straight-line tool 

Selects objects 

Types text and creates 
columns 

Draws any angle of horizon¬ 
tal, vertical, or diagonal lines 

Draws any shape 

Draws straight lines horizon¬ 
tally or vertically 

To start Draw 
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Rectangle tool Draws rectangles or squares 

Rounded-comer 
Rectangle tool 

Draws rectangles or squares 
with rounded comers 

o 
Zi 

Oval tool 

Polygon tool 

Arc tool 

Draws ovals or circles 

Draws triangles, angles, 
trapezoids, etc. 

Draws 90-degree arcs 

In addition, the palette: 

Shows the pattern selected in the Fill Pattern menu. 

Shows the pattern selected in 
the Line Pattern menu. 

Contains arrows to move a selection 
one pixel up, down, right, or left. 

Shows the current line width. 

Provides four line widths and a transparent line. 

Provides a plain line. 

Provides an arrow for the end of lines. 
Shows the current line type. 

To move the palette anywhere on the screen, place the pointer on the word 
“Tools” and drag. 
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Drawing Lines and Shapes 

A drawn object is composed of these elements: 

■ A shape 

■ A line thickness 

■ A fill or line pattern, or both 

Shape Line thickness Line pattern, fill 
pattern, or both 

Shape is determined by the tool you choose; line thickness is determined by 
the width you choose; and pattern is determined by your selections in the 
Line Pattern and Fill Pattern menus. 

Most objects are similar in the way they are drawn and used. Text objects, 
which differ slightly from other objects, are covered later in this section. All 
other objects are covered in the following paragraphs. 
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To draw an object To draw objects (except for polygons and text objects): 

0 Choose Draw On from the Edit menu. 

Works displays the Tools palette. 

E Choose a tool from the Tools palette. 

The tool is highlighted and the pointer changes to a cross. 

E Place the cross where you wish to place the object. 

B Hold down the mouse button and drag until the object is the dimension 
you want, then release the mouse button. 

The window scrolls automatically to accommodate a large object. 

Place the cross at the 
starting point and drag. 

—-- 

Release the mouse button 
at the ending point. 

Handles appear, indicating that the object is selected. Handles are small black 
squares on the borders of an object. 

An object is automatically selected after you’ve drawn it. When an object is 
selected, you can move, resize, and edit the object as you choose. 

Hint If you want to continue drawing with the same tool, hold down the 
Command key and draw again. 
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Note A line should be drawn to the approximate length, angle, and degree 
you want. You can change the angle of a line after you’ve drawn it by drag¬ 
ging one of its handles. 

An arc is always 90 degrees when drawn; the way you draw it determines its 
direction and curvature. An arc can be extended up to 360 degrees by drag¬ 
ging one of its handles after you finish drawing it. 

In a Word Processor document, before creating an object that extends beyond 
the last screen containing text, make sure that Draw is off. Then use the 
Return key to insert enough blank space to make room for the object. This 
will allow you to scroll to see the entire object. 

You can create perfect shapes by holding down the Shift key while drawing 
an object. The Rectangle, Oval, and Rounded-comer Rectangle tools make 
perfect squares, circles, and squares with rounded comers. Arcs are drawn to 
the nearest quarter circle. Lines are drawn perfectly straight, and at a 45- or 
90-degree angle. 

Polygons are drawn in a different way than other objects. 

To draw a polygon: 

E Choose the Polygon tool from the Tools palette. 

E Place the cross in the window where you want to start the polygon. 

0 Click the location where you want to place the first comer of the 
polygon. 

As you move from one point to another, a line connects the cross to the 
last point you selected. 

0 Click the position where you want the next comer of the polygon. 

E Continue clicking at each comer. 

E To finish drawing the polygon, click at the starting point, or double-click 
anywhere to complete an open polygon. 

To create perfect 
shapes 

To draw a polygon 
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To undo a mistake 

To select an object 

To complete a closed shape, 
click at the starting point. 

Handles appear at each comer of the polygon, indicating that it’s selected. 

Undoing a Mistake 

You can correct a mistake by choosing Undo from the Edit menu. Undo 
reverses only your last action. 

You can also undo mistakes by selecting the object, choosing Clear or Cut 
from the Edit menu, and then redrawing the object. 

Hint Although you can’t erase part of an object, you can make part of an 
object appear to be erased by overlapping it with an object that has white fill 
and line patterns. 

Editing an Object 

You can change an object’s line width, fill or line pattern, size, color, and 
dimensions. You can also copy objects or delete them from the screen. 

Before you can make any changes to an object, it must be selected. 

All objects are automatically selected when you finish drawing them. Once 
you change tools, draw again, or click another part of the screen, you’ll have 
to select the object before you can edit it. 

To select an object: 

0 Choose the Selection tool, if it is not already highlighted in the Tools 
palette. 

0 Click an object’s border to select it. 

Handles appear on the borders of the object to show that it is selected. 

If you select an object by mistake, just click outside the object to deselect it. 

When an object is selected, you can edit it by moving it, resizing it, copying 
it, changing the line width, decorating it with a fill and line pattern, coloring 
it, or deleting it. 
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Note Draw is preset to draw transparent objects (0). If you choose a fill 
pattern for an object, it can be selected by clicking anywhere in the object. 
For more information, see “To use fill or line patterns” in this chapter. 

You can select more than one object at a time. 

To select more than one object: 

0 Choose the Selection tool, if it is not already highlighted in the Tools 
palette. 

0 Hold down the Shift key and click each object you wish to select. 

If you click an object by mistake, just hold down the Shift key and click the 
object again to deselect it. 

You can also select a group of objects using standard Macintosh techniques. 
Place the Selection tool outside one comer of the objects you want to select, 
and drag diagonally to the opposite comer of the objects. If this doesn’t 
work, try dragging a larger rectangle around the objects. 

If a group of objects is selected, any changes you make affect all of the 
selected objects. 

To move an object: 

0 Select the object. 

0 Place the Selection tool anywhere on the object’s border except the 
handles. 

If the object contains a fill pattern, you can also place the Selection tool 
inside the object. 

Select an object and drag it... ...to a new position. 

0 Drag the object to the desired location. 

To select more than 
one object 

To move an object 
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To resize an object 

You can also move an object by selecting it, choosing Cut from the Edit 
menu, clicking the location where you want to move the object, and choosing 
Paste from the Edit menu. 

Hint You can make an object move on a perfect horizontal, vertical, or 
diagonal line by selecting the object, pressing the mouse button, and holding 
down the Shift key while you drag the object. 

Note Placing the Selection tool on a handle and dragging resizes the object. 

In a Word Processor document, before moving an object that extends beyond 
the last screen containing text, make sure that Draw is off. Then use the 
Return key to insert enough blank space to make room for the object. This 
will allow you to scroll to see the entire object. 

You resize objects (except arcs and polygons) by selecting them and dragging 
the handles. To stretch or shrink an object in both dimensions, drag a comer 
handle. To stretch or shrink an object in one dimension, drag a mid-point 
handle. 

r-a- 

ii ii 

C-=-a 

To stretch or shrink in two 
dimensions, drag a corner 
handle. 

To resize a perfect shape, select the object, select a comer handle, and then 
hold down the Shift key and drag the handle. 
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Arcs and polygons don’t have mid-point handles. Dragging a handle on an 
arc or polygon reshapes it in only one dimension. To change the overall 
dimensions of an arc or polygon, use the Group Picture command in the 
Format menu. 

To resize an arc or polygon: 

0 Select the arc or polygon. 

0 Choose Group Picture from the Format menu. 

Handles appear around the boundary of the object. 

0 To stretch or shrink the object in both dimensions, drag a comer handle. 

To stretch or shrink the object in one dimension, drag a mid-point handle. 

0 Choose Ungroup Picture from the Format menu. 

You can reshape the arc or polygon by dragging the handles, or click outside 
the object to deselect it. 

Copying places an exact copy of the object on the Clipboard, allowing you to 
duplicate the object by pasting it elsewhere in your drawing, or in another 
Word Processor or Spreadsheet document. 

To copy an object: 

0 Select the object. 

0 Choose Copy from the Edit menu. 

The object is copied to the Clipboard. 

0 Click the location where you want to paste the object. 

0 Choose Paste from the Edit menu. 

You can copy an object on top of another object, and automatically paste it 
in the exact center of the object. 

0 Copy the object to the Clipboard. 

0 Select the object on which you wish to center the copied object. 

0 Choose Paste from the Edit menu. 

The object on the Clipboard is automatically centered on the object in the 
document. It is selected and placed in the draw layer directly in front of the 
object on which it is centered. 

To resize an arc or 
polygon 

To copy an object 

To copy an object 
and center it 
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To set the line width 

To draw a line with an 
arrow 

to use fill or line 
patterns 

To change a pattern 

The line width you select in the Tools palette affects the width of lines, as 
well as the border width of shapes. 

To set the width of lines and borders: 

[T] Choose a tool from the Tools palette. 

[2] Choose the line width that you want. 

[3] Draw the line or object. 

You can also change the width of lines or borders that you’ve already drawn 
by selecting the object that you want to change and clicking the new line 
width in the Tools palette. 

To draw an line with an arrow: 

[7] Choose the Line tool from the Tools palette. 

[2] Click the line with the arrow at the bottom of the palette. 

[3] Draw the line. 

The arrow appears when you release the mouse button. 

You can also add an arrow to a line you’ve already drawn by selecting the 
line and clicking the line with the arrow in the Tools palette. 

Fill patterns can be used to decorate any object that is not a line. Line pat¬ 
terns can be used to decorate lines and the borders of any object that is not a 
text object. 

To set fill or line patterns: 

Q] Choose a fill or line pattern from the Fill Pattern or Line Pattern menus. 

[2] Choose a tool from the Tools palette. 

{3} Draw the object. 

The fill or line pattern will appear automatically. If the fill or line pattern is 
transparent (0), the fill or line is invisible. 

If a fill or line pattern is active, you can see the pattern in the Tools palette. 
The active patterns are applied to new objects as you create them. To change 
the active patterns, click ouside any selected objects to deselect them, and 
choose new patterns. 

You can change the fill and line patterns using the Fill Pattern and Line Pat¬ 
tern menus. 

To change the fill and line patterns: 

[T] Select the object you want to change. 

[2] Choose a fill pattern from the Fill Pattern menu. 

[3] Choose a line pattern from the Line Pattern menu. 

If the fill or line pattern is transparent (0), the fill or line is invisible. 
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If you have a color monitor, you can display your objects in color; if you 
have a color printer, you can print them in color. 

When you draw an object, its fill and line patterns use the colors chosen in 
the Color - Black Dots and the Color - White Dots commands in the Format 
menu. For information on choosing colors, see “Color - Black Dots/Color - 
White Dots” in Chapter 2. 

You can change the color of an object using the Color commands in the For¬ 
mat menu. 

To change the color of an object: 

[3 Select the object. 

[2] Choose Color - Black Dots from the Format menu. 

[U Continue holding down the mouse button, and choose the color you want 
to use for the object’s black pixels. 

H Choose Color - White Dots from the Format menu. 

H] Continue holding down the mouse button, and choose the color you want 
to use for the object’s white pixels. 

If you have a color monitor, you can view the color mix in a line or fill pat¬ 
tern before applying the colors to an object. Choose the black dot and white 
dot colors from the Format menu. Hold down the Shift key while you pull 
down the Fill or Line Pattern menu. All of the patterns are displayed in the 
colors you chose. 

When you copy or cut an object, it is copied to the Clipboard. You can 
retrieve the last object copied to the Clipboard using the Paste command from 
the Edit menu. 

Each object copied to the Clipboard replaces the previous object. If you want 
to delete an object without changing what is on the Clipboard, use the Clear 
command. 

To delete an object without replacing the content of the Clipboard: 

[T) Select the object you want to delete. 

0 Choose Clear from the Edit menu. 

You can also clear an object by selecting it and pressing the Delete key. 

You can select several objects and treat them as a group. When objects are To group objects 
grouped, all of the individual objects are treated as a single object when 
moving, resizing, filling, coloring, and deleting. 

To group objects: 

[T] Hold down the Shift key and click each object you want to group, or use 
the standard Macintosh techniques to drag a selection box that encom¬ 
passes the objects. 

[1] Choose Group Picture from the Format menu. 

The boundary encompasses the entire group and the objects have one set 
of handles. 

To color an object 

MNMNMMMMMWN 

To change an 
object’s colors 

To delete an object 
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A group 

To move grouped objects, drag any one of the objects in the group, and the 
rest will follow. If you try to drag the space between objects, the group is 
deselected and will not move. 

Note You can create groups within groups. For example, you can group 
several objects and apply a fill pattern to them. Then you can select addi¬ 
tional objects and make all of the objects one large group, which can be 
resized and moved to a different location. 

When you resize a group of objects that contains text, the text is not resized. 
To change the text size, select the group and use the Size command from the 
Format menu. 

To ungroup Objects You turn a group into individual objects once again using the Ungroup 
Picture command. 

To ungroup objects: 

0 Select a picture you have grouped with the Group Picture command. 

0 Choose Ungroup Picture from the Format menu. 

Each object has its own set of handles. Works reverses the Group Picture 
command, but you still need to deselect the group to ungroup the objects. 

0 Click outside the group to deselect the objects. 

The objects are now independent of each other. 

To bring to front or Each object is drawn on its own invisible plane. A new object is always in 
send to back front of all of the other objects you have drawn. You can change the depth of 

an object in the draw layer by bringing it to the front of the draw layer, or by 
sending it to the back of the draw layer. 
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Select an object... ...and send it to the back. 

...and bring it to the front. 

To bring an object to the front or send it to the back: 

□D Select the object you want to move. 

[2] Choose Bring to Front or Send to Back from the Format menu. 

The selected object is placed either in front of or behind all other objects in 
the draw layer. 

Aligning an Object 

There are two ways to align objects horizontally and vertically on your 
screen: 

■ Pixel-by-pixel 

■ By setting a grid 

For precise horizontal and vertical placement of an object, you can use the 
pixel-by-pixel adjustment in the Tools palette. Just select the object you wish 
to position, and then click the up, down, right, or left arrows to move the 
object one pixel at a time. 

You can also move an object pixel-by-pixel using the arrow keys on your 
keyboard. Select the object and hold down an arrow key until the object 
moves to the position you want. 

To align an object 
pixel-by-pixel 
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To position objects 
using the grid 

To turn off the grid 

The Grid On command lets you position objects along the lines of an invis¬ 
ible grid, whose spacing you determine using the Grid Setting command. 

To position objects using the grid: 

0 Choose Grid Setting from the Format menu. 

0 Choose the spacing you wish. 

0 Click the OK button. 

0 Choose Grid On from the Format menu. 

A checkmark next to the command shows that it is in effect. 

With the grid on, everything you move, resize, or draw aligns on the invis¬ 
ible vertical and horizontal grid lines that you have set. 

To position objects at any location on the screen, you must turn the grid off. 

To turn off the grid: 

\u\ Choose Grid On from the Format menu. 

The checkmark disappears, and you can place objects anywhere on the 
screen. 

Text Objects 

Text is anything you can type on the keyboard — letters, numbers, punctua¬ 
tion, and special symbols. With text objects you can create labels, para¬ 
graphs, and columns. Like other objects, text objects are in the draw layer, 
which is separate from the text in a document. Working with text objects 
doesn’t affect the information in a document’s text layer. 

Text objects are similar to other objects in many ways. They can be filled 
with a pattern and they can be moved, resized, copied, filled, colored, and 
deleted, exactly like other objects. They can also be moved to the front plane 
or sent to the back plane, selected as part of a group, and aligned on a grid. 

Unlike other objects, however, text objects have the following characteristics: 

■ A justification — the position of text between the edges of the text object, 
either left, centered, right, or fully justified 

■ Fonts — the design of the characters 

■ Type sizes — from 4 to 72 points 

■ Type styles — normal, bold, italic, underline, outline, or shadow 

■ Colors — for both black and white dots 
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A text object can have only one justification, but it can include multiple 
fonts, sizes, styles, and colors. 

Text objects don’t have a border, so line width and line patterns don’t apply 
to them. 

Text objects are drawn differently from other objects. To draw a text object 

To draw a text object: 

0 Choose the Text tool from the Tools palette. 

0 Position the I-beam pointer where you want to place the text object. 

0 Click to draw a text object one line high and approximately four inches 
wide. 

If you want a different-sized text object, place the pointer where you want 
the text to appear, and drag until the dashed box is approximately the 
length and width of the text you want to type. 

0 Start typing. 

Your first character appears in the upper-left comer of the text object. As 
you type, text automatically wraps to the next line — adjusting itself as it 
reaches the edge of the text object. 
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To add text to a text 
object 

r 6 File Edit Window Format Fill Pattern Line Pattern Macro 

Use the Return key to start new paragraphs, and the Delete key to erase 
mistakes. 

When you finish a text object, the Text tool stays selected. 

0 Turn off the Text tool by clicking the Selection tool, or by choosing 
another tool. 

Note If the text object has a justification other than left justified, when you 
begin typing, your first character may not appear at the upper-left corner of 
the text object. For example, if the text is right justified, the first character 
appears at the upper-right comer of the text object. 

If you type more text than will fit into the object, the text continues below 
the object’s lower boundary until you turn off the Text tool or start a new 
text object. The text object then enlarges to encompass the additional text. 

Editing a Text Object 

You can edit the text in a text object by inserting new text, or copying, 
moving, and removing existing text. 

To add text to a text object: 

0 Choose the Text tool from the Tools palette. 

0 Position the insertion point in the text object where you want to insert 
new text and click. 

0 Type the new text. 
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To copy text in a text object: 

0 Choose the Text tool from the Tools palette. 

U] Drag inside the text object to select the text you wish to copy. 

The selected text is highlighted. 

[3] Choose Copy from the Edit menu. 

The text is copied to the Clipboard. 

[4] Position the insertion point where you want to place a copy of the text. 

0 Choose Paste from the Edit menu. 

To move text in a text object: 

|T| Choose the Text tool from the Tools palette. 

[2] Drag inside the text object to select the text you wish to move. 

The selected text is highlighted. 

[3] Choose Cut from the Edit menu. 

The text is copied to the Clipboard. 

[4] Position the insertion point where you want to move the text. 

[5] Choose Paste from the Edit menu. 

To remove text from a text object: 

|j] Choose the Text tool from the Tools palette. 

[2] Drag inside the text object to select the text you wish to remove. 

The selected text is highlighted. 

[3] Choose Clear from the Edit menu, or press the Delete key. 

The text is permanently removed from the text object. 

You select, fill, copy, resize, and delete a text object exactly as you do other 
objects. For more information, see “Editing an Object,” earlier in this 

chapter. 

When you draw a text object, it has the justification, font, size, style, and 
color chosen in the Format menu. You can change these attributes for the 
entire object before or after drawing. Before drawing, choose the appropriate 
command from the Format menu, and continue holding down the mouse but¬ 
ton while you select a different attribute. If you’ve finished drawing, select 
the object with the Selection tool before choosing the attribute. 

To change the font, size, style, and color of individual characters in a text 
object, select the text with the Text tool, and then choose the attributes from 

the Format menu. 

fo copy text in a 
text object 

To move text in a 
text object 

fo remove text from a 
text object 

To change a text 
object’s attributes 
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To spread text The Spread Text command lets you spread text out or pull it in tighter along 
a line, an arc, or a circle. You can use Spread Text to: 

■ Shorten the spaces between letters in a title. 

■ Write text along a diagonal or arc. 

Spread Text makes individual text objects out of each of the characters in a 
single text object and spreads them out evenly along a line or an arc in the 
same direction that the line or arc was drawn. 

To spread text: 

0 Select text from a document or a text object. 

0 Choose Cut or Copy from the Edit menu to copy the text to the 
Clipboard. 

[2 Create or select a line or arc along which you want to spread the text. 

If you want the line or arc to be invisible, choose no pattern (0) from 
the Line Pattern menu. 

0 Choose Spread Text from the Format menu. 

0 To see the object more clearly, click anywhere outside the object to 
remove the handles. 

6 File Edit Window Format Fill Pattern Line Pattern Macro 
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Each character is now treated as a separate text object. You can work with 
the objects separately, or group them. When they are grouped you can stretch 
the group, compress it, or move it to another location. 

Note If text has not been copied to the Clipboard, and a line or an arc has 
not been designated before the Spread Text command is chosen, the com¬ 
mand is dimmed and you can’t choose it. 

Using Columns 

You can use the Text tool to create columns. 

To create a column: 

□ Choose the Text tool from the Tools palette. 

[I] Position the I-beam pointer where you want the column to appear. 

H] Hold down the Option key while you drag to draw the column. 

A dashed box appears when you release the mouse button. A heading 
with the abbreviation, Col (for Column) is followed by the number of the 
column, the word “Link,” and the word “NONE.” None indicates that 
there is no linked column. 

0 Type text into the column. 

[1] To turn off the Text tool, choose the Selection tool or choose another tool 
from the Tools palette. 

To create a column 
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To link columns 

The amount of text that fits in a column is determined by the size of the 
dashed box. If there is more text than will fit in the box, the text extends 
beyond the bottom of the column. Unlike ordinary text objects, columns 
don’t adjust the bottom of the object to accommodate the amount of text they 
contain. If you have more text than you can fit in one column, you can link 
two or more columns together, or use the handles to resize the column. 

Note If you copy text from any tool in Works and paste it into a column, 
the text becomes part of the column. Since a column is a text object, the 
copied text retains the font, size, style, and color of the original text, but 
accepts the justification of the column it is copied into. If you want the text 
to take on the font, size, style, and color of the column you’re copying into, 
hold down the Option key while you paste the text. 

In a Word Processor document, before creating a column that extends beyond 
the last screen, make sure that Draw is off. Then use the Return key to 
insert enough blank space to make room for the column. This will allow you 
to scroll to see the entire column. 

With linking, text flows automatically from one column into the next. For 
example, if a column on page two contains too much text, you can link it to 
an empty column on page three. The extra text automatically fills the column 
on page three. 

Interview 
2 

With column linking, text that 
extends beyond one column... 

...automatically flows into 
the next column. 

If you increase the amount of text by editing the text or by changing its font 
or size, Works readjusts the text for you. 
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There is no limit to the number of columns that you can link, and you can 
have up to 32K of text in linked columns. 

To link one column to another: 

0 Create two or more columns. 

0 Choose the Selection tool from the Tools palette. 

0 Hold down the Option key and select the columns in the order they are to 
be linked. 

The column headings, which are visible when a column is selected, 
change to reflect the link between the columns. 

For example, if you link columns one, two, and three, the headings are as 
follows: 

■ Column one changes from Col 1 Link NONE to Col 1 Link 2. 

Column two changes from Col 2 Link NONE to Col 2 Link 3. 

■ Column three remains Col 3 Link NONE. 

While editing a column, you won’t see the text adjust into linked columns 
until you finish editing and deselect the column. If you change the size of the 
text, stretch a column, or make any other change that affects the amount of 
text in a linked column, the text redistributes when you deselect the column. 

If there is not enough text to fill all linked columns, one or more columns are 
left empty. If there is more text than will fit in the last column, the text 
extends beyond the bottom of the column. 

Text that flows into a column with different attributes retains its original font, 
type size, type style, and color, but accepts the justification of the column 
into which it flows. 

Column headings can be edited with the Text tool by clicking in the column To edit a heading 
with the Text tool, and then selecting the heading and using standard editing 
techniques as described in “Editing a Text Object” earlier in this chapter. 
Headings must use the following form: 

Col column_name Link continuation_name 

and must be followed by a Return character. Be sure to press the Return key 
at the end of a heading that you’ve edited. Column and continuation names 
can contain any characters, without spaces. You can use UPPERCASE or 
lowercase letters. 

For example, a column heading might be: 

Col Interview Link Interview_continued 
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To turn a text object 
into a column 

One column can be linked to another by clicking in the column with the Text 
tool, selecting the heading, and editing so that the continuation name of the 
first column is the same as the column name of the second column. 

Hint If you change the continuation name of the column you are linking to 
before changing the column name of that column, Works displays an error 
message. To avoid the message, rename the second column before renaming 

the first. 

As text is adjusted to fill linked columns, Works checks the consistency 
between columns to make sure that they are linked properly. Improper linking 
may include a reference to a non-existent column, or more than one reference 
to the same column. If columns aren’t linked properly, Works alerts you, and 
does not redistribute the text. 

You can use a heading to turn a text object into a column. 

[¥] Type a heading on the first line of the text object, being sure to follow 
the rules for editing headings. 
When you deselect the text object, it becomes a column — the column 
heading appears above the column, and the column is surrounded by a 
dashed box. 

You can also create a column from a text object by holding down the Option 
key and selecting the text object with the Selection tool. 

You can turn text objects into linked columns by holding down the Option 
key and selecting them with the Selection tool in the order they are to be 
linked. You can turn a column back into a text object by deleting the column 
heading. 

A Special Use for Columns 

You can create a template for a newsletter or other publication and use it 
every time you publish a new edition. Just create empty columns — each with 
its own specified shape, pattern, color, font, type size, type style, and justifi¬ 
cation. Then give each column a heading that describes its function and links 
it to other columns. New documents built from copies of the template will 
have the same format and attributes as the original document. 
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Exiting Draw 

To exit Draw: 

0 Choose Draw Off from the Edit menu. 

The Tools palette disappears and you are returned to the text layer of your 
Word Processor or Spreadsheet document. Your pictures remain on the 
screen, are saved with the document when you choose Save or Save As, and 
are printed with the document when you print. 

Note You can import pictures from other programs using the Scrapbook. 
For information on the Scrapbook, see your Macintosh owner’s manual. 

Using Macros 

A macro is a set of instructions that Works follows to automatically carry out 
a sequence of actions. Macros save you time and trouble by remembering all 
of the steps in a repetitive task and carrying them out for you. 

You record a macro much like you record a song on a tape recorder. While 
you are recording, you perform the task exactly as you want it to play back 
later. 

Once you’ve recorded a task as a macro, and you want to repeat the task, 
just choose the macro and Works carries it out exactly as you’ve recorded it. 

Macros are simple to use, but are also quite powerful. You’ll probably want 
to be well acquainted with a tool before using macros in that tool. 

How Macros Work 

Macros can record anything you type — text, numbers, and keyboard com¬ 
mands. Macros can also record mouse movements — opening menus, choos¬ 
ing commands, and dragging windows. However, macros can only record the 
points on the screen where you click and release the mouse. Because they 
can’t record mouse movements in between clicking and releasing, you can’t 
use macros to draw freehand objects. 

Macros always play back relative to the starting location in the window you 
record in. For example, suppose you record a macro to type your company’s 
name and address at the top of a page. As you record the macro, you place 
the insertion point at the top of the page, choose a font and type size, and 
type the information. If you play back the macro with the insertion point in 
the middle of a document, the information will appear in the middle, rather 
than at the top of the document. 

To exit Draw 

How macros work 
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To use macros 

To record a macro 

Macros can locate and choose objects, like the close and size boxes in the 
window, but they can’t interpret locations for you. For example, a macro can 
locate the scroll box, but it can’t use the scroll box to move to a specific 
location on the screen. This is because the scroll box shows your location in 
the document relative to the rest of the document. Since documents are of 
different lengths, the distance from the top to the middle of one document 
will not match the distance from the top to the middle of another document. 
For this reason, macros using the scroll bar may not work properly. 

If you record a macro and then play it back in a window in a different loca¬ 
tion on the screen, the macro will still work. This is because the macro is 
recorded relative to the top-left comer of the window. You’ll be able to use 
macros that operate window controls and choose commands regardless of 
window location. However, if you record a macro and play it back in a 
different-size window, or in a window partly moved off the screen, it may 
not play back correctly. 

If you are using Multifinder, you can’t record a macro that chooses a Desk 
Accessory or switches to a program other than Works. 

You can’t turn macros on or off, or start or stop recording macros while 
Works displays a dialog box. To turn macros on or off, or to start or stop 
recording, cancel the message or dialog box, or complete the command. 

To use macros: 

0 Choose Macros On from the Macro menu. 

A checkmark appears beside the command, and you can begin working with 
macros — recording a new macro, playing back an existing macro, or main¬ 
taining your macro files. 

Recording a Macro 

To record a macro: 

0 If Macros On is not checked in the Macro menu, choose Macros On. 

0 Choose Start Recording from the Macro menu. 

0 Type in the letter of a key to be associated with the macro. 

0 Press the Tab key and type in a short description of the macro. 

0 Click the Record button or press the Return key. 

0 Use the keyboard and/or the mouse to perform your task exactly as you 
want to record it. 

0 Choose Stop Recording from the Macro menu. 

Works displays a dialog box from which you can stop recording, continue 
recording, or cancel the macro. 

0 Click the Stop button to stop recording the macro. 
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Note There are three types of keys that can’t be associated with macros: 

■ Accent keys: E, I, N, U, ~ 

■ Modifier keys: Shift, Option, Command, Caps Lock 

■ Reserved keys: Delete (Backspace), ‘, =, -, +, _ 

You can assign the Tab key to a macro by typing the word “Tab” in the Start 
Recording dialog box. You can assign these keys: the function keys FI 
through F15, and the Home, End, Page Up and Page Down keys on an 
extended keyboard (Macintosh SE and Macintosh II) by pressing the key 
while you’re in the Start Recording dialog box. 

You can record a macro when you first start Works, before you open a tool. 
Just click the Cancel button in the Open dialog box, and choose Macros On 
from the Macro menu. 

You can’t record a macro inside a macro. This means you can’t use the 
Option key while recording a macro, unless you are using the Option key to 
create a column. To record a macro to create a column, hold down the 
Option key before drawing the column. 

Playing Back a Macro 

When you play back a macro, it should be appropriate to the situation. For 
example, you wouldn’t ordinarily record a macro in a Word Processor docu¬ 
ment to select and format paragraphs and play it back in a Spreadsheet docu¬ 
ment. If you play back a macro at an inappropriate time or in an inappropri¬ 
ate place, it may have unexpected results. 

Whenever you want a macro to play back the actions you recorded, position 
the pointer at the appropriate place in your document and choose the Play¬ 
back And command from the Macro menu. 

To play back a macro: To play back a macro 

□ If Macros On is not checked in the Macro menu, choose Macros On. 

[U Choose Playback And from the Macro menu. 

Macros are listed in alphabetical order by description. 

0 Select the macro by clicking it or by typing the key associated with the 
macro. 

0 Click the Play button or press the Return key. 

Works automatically repeats the task exactly as you recorded it. 

There are two other ways to play back the macro: 

\u\ Double-click the macro name listed in the Playback dialog box. 

or 

\u\ In your document, hold down the Option key while pressing the key 
assigned to the macro. 
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About macro files 

Macros play back as quickly as possible, often faster than you recorded them. 
If you want to see the dialog boxes or other information that appears on your 
screen as you play back a macro, you can decrease the playback speed. 

To slow down macro playback: 

S Choose Record Pauses from the Macro menu, or choose the Record 
Pauses option from the Start Recording dialog box. 

or 

® During recording, choose one or both of the record delays options from 
the Stop Recording dialog box. 

Because Works plays back macros as quickly as possible, even with Record 
Pauses on you won’t see commands as they are chosen, but you will see any 
resulting dialog boxes. 

See “Record Pauses” in Chapter 2 for more information. 

Hint Macros work best if you type the first letter of the item you want to 
select from a list box. Even if the number of the items in the list box changes 
later, you’ll be able to select the right item. 

To make sure your macro selects the correct item in a selection rule list box 
in the Database, scroll by clicking the scroll arrow, or drag the scroll box to 
the extreme top or bottom of the list box and then click each item sequen¬ 
tially until you’ve selected the item you want. 

About Macro Files 

Macros are recorded and saved in macro files. Macro files are always referred 
to as files, rather than documents, even if they have not yet been saved to a 
disk. 

A macro file can contain one macro, or as many macros as you have avail¬ 
able keys on your keyboard. You can group macro files any way you want. 
For example, macro files can be grouped: 

■ By type (all formatting macros, for example) 

■ By type of document (a Word Processor macro that begins letters and 
another that prints envelopes might be in the same file) 

The first time you turn on macros, Works opens a new, untitled macro file 
for you. The macros you record are saved in memory in this file. When 
you save the file on your disk, the Save Macro File dialog box appears and 
Works proposes the name Microsoft Works(keys). If you save the file with 
the proposed filename, the next time you turn on macros, Works opens 
this file. 
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You can create other macro files and save macros to them by typing a dif¬ 
ferent name in the Save Macro File As dialog box. For more information, see 
“To save a macro file with a different name” in this chapter. 

Note You can record a macro only to an open macro file. To open a macro 
file, use the Open Macro File command in the Macro menu. 

To play back a macro, the file that contains that macro must first be open. 

Working with Macro Files 

You create new macro files, and open, save, and rename existing macro files 
using commands in the Macro menu. You can also perform these functions 
from the Playback dialog box. 

To create a new macro file: 

0 If Macros On is not checked in the Macro menu, choose Macros On. 

0 Choose Open Macro File from the Macro menu. 

0 Click the New button. 

Now you can record a macro in the new file, using the Start Recording and 
Stop Recording commands. Before you open a different macro file or quit 
Works, Works asks you if you want to save the changes to the macro file. 
Click the Yes button and name the file in the Save Macro File dialog box. 

You can also create a new macro file from the Playback dialog box by click¬ 
ing the New button and using the Start Recording and Stop Recording com¬ 
mands from the Macro menu. 

You can have as many macro files as your disk space allows, and you can 
assign a name of up to 27 characters for each macro file. You can use 
spaces, and uppercase and lowercase letters. The only character you can’t use 
is a colon. It is helpful to follow the filename with (keys) to identify the file 
as a macro file, since macro files are stored on the desktop with other files. 

To open an existing macro file: 

0 If Macros On is not checked in the Macro menu, choose Macros On. 

0 Choose Open Macro File from the Macro menu. 

0 Select the macro file from the list. 

0 Click the Open button. 

Works opens a copy of the macro file that you selected. You can work with 
the macros in the file, and make changes to them. The original macro file 
remains on the disk until you replace it by saving your changes or until you 
remove it from the disk. 

You can also open an existing macro file in the Playback dialog box by click¬ 
ing the Open button. 

To create a new 
macro file 

To open an existing 
macro file 
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To save a macro file 
for the first time 

To save changes to 
an existing macro file 

To save a macro file 
with a different name 

Macro files are recorded only in memory until you save them to a disk. If the 
power goes out, or you quit Works without saving, your macro file will be 
lost. To be able to use the macro file later, you must save it. 

To save a macro file for the first time: 

E Choose Save Macro File As from the Macro menu. 

Works displays the Save Macro File dialog box with the proposed name 
Microsoft Works(keys) in the text box. 

0 To save the macro file with the proposed name, click the Save button. 

To save the macro file with a different filename, type a filename into the 
text box and click the Save button. 

Works saves the macro(s) in the new file. 

You can also save a macro file from the Playback dialog box by clicking the 
Save button. 

If you are working with an open macro file that has already been saved, you 
can use the Save Macro File command to save your changes to the file. 

To save changes to an existing macro file: 

0 Choose Save Macro File from the Macro menu. 

Note If you choose Save Macro File and have not previously saved the 
open macro file, Works displays the Save Macro File dialog box. For more 
information, see “To save a macro file with a different name” below. 

If you want to save both the original macro file and the changes you’ve 
made, you can save the macro file with a different name. 

To save a macro file with a different name: 

E Choose Save Macro File As from the Macro menu. 

E Type a name for the file in the Save Macro File As text box. 

If you want to save to another disk, click the Eject button. If you want to 
save to another drive, click the Drive button and save the file on a disk in 
that drive. 

E Click the Save button. 

You can also save a macro file with a different name by clicking the Save As 
button in the Playback dialog box. 
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You delete macros from existing macro files using the Playback And com¬ 
mand. When you delete a macro from a file, it is erased from memory, but is 
still on the disk. When you delete a macro from a file and then save the 
macro file, Works erases the macro completely. 

To delete a macro: 

0 If Macros On is not checked in the Macro menu, choose Macros On. 

0 Choose Playback And from the Macro menu. 

0 Select the macro you want to delete. 

0 Click the Delete button or press the Delete key. 

0 Click the Cancel button to cancel the dialog box. 

0 Choose Save Macro File from the Macro menu. 

To stop using macros: 

0 Choose Macros Off from the Macro menu. 

To delete a macro file: 

0 Delete a macro file from the Finder by dragging it over the Trash icon, 
or, in Works, by using the Delete command from the File menu. 

For macros to work properly: 

■ Macros must be turned on using the Macros On command in the Macro 
menu. 

■ The macro file that contains the macros must be opened, using the Open 
Macro File command. 

If macros are not turned on, or the macro file is not open, and you press the 
key assigned to the macro, you may insert a character in your document. 
Delete the character by using the Delete key. 

If your macro doesn’t play back properly, you can choose Undo from the 
Edit menu to restore your document, and then re-record the macro. 

You can stop a macro in progress by pressing Command +. (period). 

Make sure the macro is appropriate for the tool and is at the correct starting 
location in the document. Playing back a macro at an inappropriate time or 
place can cause problems. 

A macro may need pauses to work properly. For more information, see 
“Record Pauses” in Chapter 2. 

To delete a macro 
from a file 

To stop using macros 

To delete a macro file 

If your macro doesn’t 
work properly 





2 Common Tasks 
Command Reference 

This chapter describes the commands (shaded below) common to all applica¬ 
tions in Microsoft Works. These commands are available on six main menus: 
the Apple, File, Edit, Window, Format, and Macro menus. 

About MS-Works... 

Alarm Clock 
Calculator 
Chooser 
Control Panel 
Find File 
Key Caps 
Scrapbook 

File 

New... 
Open... 

Close &W 
Close All... 
Saue 
Saue As... 
Delete... 

§§S 

Make Works Desktop... 

Page Setup... 
Print... 
Print Window 
Eject Page 

&P 

Print Merge... 

Quit m 

Edit 

Undo 9§Z 

Cut 8§H 

Copy 9€C 
Paste §eu 

Clear 
Select All 

Draw On §§j 

Prepare to Merge... 98M 

Show Field Data 
Multiple Labels 

Format Macro 
Shorn Clipboard 

Help 

Article (WP) 5K 

Set Cell Attributes... 

Borders 

Font 
Size 
Color 

Column Width... 

Macros On 
Macros Off 

Playback And... 

Start Aecording... 
Stop Aecording... 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File As.. 
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When Draw On is chosen from the Word Processor or Spreadsheet Edit 
menu, the Format menu contains additional commands, and the Fill Pattern 
and Line Pattern menus are added to the menu bar. 

Format 

Justification ► 
Font ► 
Size ► 
Style ► 
Color - Black Dots ► 
Color - White Dots ► 

Group Picture §§6 
Ungroup Picture 
Grid Setting... 
Grid On 
Bring to Front §8F 
Send to Back 3§B 

✓Show Column Bones 
Spread Tent 

You can invoke some Works commands from the keyboard, as well as by 
using the mouse. The available Command + key and Option + key combina¬ 
tions are shown in the menus and in Appendix D. 

An alphabetical list of commands appears in the index under “Command.” 

About MS-Works 

About MS-Works... 

filarm Clock 
Calculator 
Chooser 
Control Panel 
Find File 
Key Caps 
Scrapbook 

The Apple Menu 

About MS-Works 

The About MS-Works command shows how much memory is available for 
documents. It also provides some basic information about the Works 
program. 

For a discussion of the desk accessories listed in the Apple menu, see your 
Macintosh owner’s guide. 

Note While desk accessories should not interfere with the functioning of 
Works, sometimes problems do occur. If Works malfunctions while a desk 
accessory is present, try removing the accessory from your System. 
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The File Menu 

New New 

The New command creates an empty document in a new window. 

If you already have 14 windows on your desktop, the New command is 
dimmed until you remove one or more of the windows by closing them. 

When you choose New, Works displays a dialog box in which you choose 
the type of document you want to create. 

rue 

New... 
Open... §80 

Close 
Close Rll... 

sew 

Saue 
Saue Rs... 
Delete... 

ses 

Make Works Desktop... 

Page Setup... 
Print... 
Print Window 
Eject Page 
Print Merge... 

SeP 

Quit m 

To create a new document, click the icon corresponding to the type of docu¬ 
ment you want to create: Word Processor, Database, Spreadsheet, or Com¬ 
munications. Then click the OK button. You can also double-click an icon to 
create a new document. 

The window containing the newly created document becomes the active win¬ 
dow, and the menu bar changes to reflect the Works tool you have chosen. 

Open Open 

The Open command opens a file from the disk and displays a copy of it on 
your screen. 

If you already have 14 windows on your desktop, the Open command is 
dimmed until you remove one or more windows by closing them. 

Open File: 

Up? 
wW SUP* 

Rll Works Word 
Types Processor 

Data 
Base 

Spread Communications 
Sheet 

Q Tutorial] 

[ Open ] 

[ New ] 

[ Cancel ] 

C 
c 

Works Pr... 

Eject ] 

Driue 

□ import File 

File 

I New... 
Open... se 3 
Close sew 
Close Rll... 
Saue ses 
Saue Rs... 
Delete... 

Make Works Desktop... 

Page Setup... 
Print- sep 
Print Window 
Eject Page 
Print Merge... 

Quit seQ 
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The list box contains a list of files and folders on the current disk. You may 
have to scroll the list to see all the names. The name of the current disk 
appears above the Eject and Drive buttons. 

Click the icon for a particular tool to see only files of that type and all fold¬ 
ers in the list box. Clicking the All Works Types icon displays all Works 
files and folders. 

Click the Import File option after clicking a document type to display only 
those files that can be imported to Works. For more information, see Appen¬ 
dix B, “Using Works with Other Applications.” 

To open a file, either select the filename from the list box and then click the 
Open button, or double-click the filename. 

The document appears on the desktop in a new window, which is active. It 
has the same size and location on the screen as it had when you last saved it. 
The menu bar changes to reflect the type of document you have selected. 

There are four other buttons in the Open dialog box: 

New If you click the icon for one of the document types, you can click the 
New button to create a new document of that type. 

Cancel Click the Cancel button to cancel the Open command. 

Eject Click the Eject button to eject the current disk from the disk drive. 
You can then insert the disk containing the file you want to open. 

Drive Click the Drive button to list the files on the other disk drive. 

Close Close 
File 

New. 
Open. 380 

The Close command closes the active document and removes it from your 
screen. 

You can also close a document by clicking the close box in the document 
window’s title bar. If you have changed the document since you last saved it, 
an alert box appears. 

[ Cancel ] [ No ] [[ Ves | 

Saue changes to Rrticle CHIP)? 

Yes Click the Yes button to save the changes. 

No Click the No button if you don’t want to save the changes. 

Cancel Click the Cancel button to cancel the Close command. In this case, 
the document isn’t closed and the changes aren’t saved. Works returns you to 
the document you were working on when you chose the Close command. 



Chapter 2 Common Tasks Command Reference 49 

Close All 

The Close All command closes all open documents and removes them from 
your screen. When you choose Close All, Works asks if you want to close all 
of your open documents. 

Close Rll: 

Rre you sure you want to close all open 
windows on the Desktop? 

□ Saue all changed files without 
further prompting 

( Cancel ] 

If OK )1 

Save all changed files without further prompting If you check this 
box and click the OK button, Works automatically saves all open documents, 
clears the desktop, and displays the Open dialog box. 

If you don’t check this box and you’ve made changes since last saving a 
document, when you click the OK button, Works asks you if you want to 
save the changes to that document. If several documents are open, Works 
asks if you want to save changes for each document. 

If you don’t check the Save all changed files box, and have a new document 
window open, Works displays the Save As dialog box. For more information, 
see “Save As” on the next page. 

Yes Click the Yes button to save the changes. 

No Click the No button if you don’t want to save the changes. 

Cancel Click the Cancel button to cancel the Close All command. 

Save 

The Save command saves the active document. The document is saved on the 
disk containing the file associated with it. Works saves the document with its 
current name and replaces the file on the disk. Works also stores the location 
and size of the window with your saved document. 

After you save a document, it remains active, so you can continue to work 
on it. It is a good idea to save your work periodically; a power failure may 
cause you to lose changes you’ve made since you last saved. 

If you’re saving a document for the first time, Works displays the Save As 
dialog box. 

Close All 

New... 
Open... §80 

Close 8€W 
Close fill... 
Saue 
Saue Rs... 
Delete... 

§es 

1 Make Works Desktop... 1 

Page Setup... 
Print... 
Print Window 
Eject Page 
Print Merge... 

§ep 

Quit m 

Save 

New... 
Open... 380 

Close 
Close Rll... 

sew 

Saue 38 S 
Saue Rs... 
Delete... 

Make Works Desktop... 

Page Setup... 
Print- 
Print Window 
Eject Page 
Print Merge... 

sep 

Quit §8Q 
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Save As Save As 

New... 
Open... §§0 

Close 
Close Rll... 

§§111 

Saue §€S 
Saue fls... 
Delete... 

Make Works Desktop... 

Page Setup... 
Print... 
Print Window 

§§P 

Eject Page 
Print Merge... 

Quit §§Q 

The Save As command saves new documents or new versions of existing 
files. Works also saves the location and size of the window along with your 
data. 

When you choose Save As, Works displays a dialog box. (You’ll also see 
this dialog box if you choose the Save command for a document that has not 
been previously saved.) 

Save Document As If the document already has a name, Works proposes 
it in the text box. To accept the proposed name, and replace the file with the 
same name on the disk, click the Save button. To save the document under a 
different name, so you’ll retain the existing file and also save the version 
with your latest changes, edit the proposed name or type a new one. 

If the name you type has already been used for a different file on the disk, or 
if you don’t change the proposed name, Works asks if you want to replace 
the existing file on the disk. Click the Yes button to replace the file on your 
disk with the active document. Click the No button to see the Save As dialog 
box again. You can then type a different name for the document. 

Eject Click the Eject button to eject the current disk. You can then insert a 
different disk on which to save the document. 

Drive If you have an external disk drive or a hard disk, you can save the 
document on another disk drive. Click the Drive button to change to the disk 
drive on which you want to save the document. 
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After you save a document with Save As, it remains on the screen, but its 
name changes to the new name you gave it. You can continue to make 
changes to it and then save it, either with the same name using the Save 
command, or with another name using the Save As command. 

Note When you click the Save Selected Records option for a Database 
document, the Save As command works slightly differently than described 
above. For more information, see “Save Selected Records Only,” on the next 
page. 

Normal This option should be chosen if you want to save the formatting 
information along with the text of your document. In most cases, you will 
want this option. 

Export Click this option before you click the Save button if you want to 
save only the text of your document and not the formatting information. Use 
this option when you want to export a Works file to use in another program. 

Stationery The Stationery option lets you create a template file that con¬ 
tains preset standards — such as font, size, and style — that you can automati¬ 
cally apply to documents you create. 

A stationery file is like a pad of notepaper that contains standard information, 
like your name and address. It can contain drawings and text with specific 
fonts, sizes, and justifications, or it can contain formatting information 
without drawings or other data. 

When you open a stationery file, an untitled document is displayed on your 
screen. It is a copy of the stationery file, with all the original information and 
settings. You work with this copy and save it as a normal document. 

The stationery file remains unchanged on the disk. The next time you open 
it, you again see all the information in the original document, and the name 
Untitled in the title bar. 

You save a document as stationery in the Save As dialog box by naming the 
document, clicking the Stationery option, and then clicking the Save button. 

In the Finder, a stationery file icon looks just like an icon for the tool it was 
created in, except that the lower-right comer is turned up. 

Note Depending on which Works tool you’re using, there may be one or 
two other options in the dialog box. 

Export As Rich Text Format If you want to export your data with for¬ 
matting to a program that accepts Rich Text Format (RTF), click the Export 
button, and then click the Export As Rich Text Format option. For more 
information on RTF, see Appendix B, “Using Works with Other 
Applications.” 
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Save Selected Records Only Click this option before you click the 
Save button if you previously used the Match Records or Record Selection 
command in the Database, and you want to save only those selected records. 

Important When you use the Match Records or Record Selection command 
in the Database, Works displays only the selected records on the screen. 
When you save, remember to specify another name for the document so that 
you don’t replace your complete Database document with this new smaller 
one. This is a special case of the Save As command in which Works does not 
replace the current window with the new document. 

Delete Delete 
Mb* % 
Neui... 
Open... 880 

Close 
Close Rll... 
Saue 
Saue Rs... 

88W 

§es 

Delete... 

Make Works Desktop... 

Page Setup... 
Print- 
Print Window 
Eject Page 
Print Merge... 

38P 

Quit m 

The Delete command deletes files from your disk. 

Delete File: 

® Works Pr... 

[ Eject ) 

[ Driue ] 

[ Delete 

[ Cancel 

Free Space: 206K 

<S) Tutorial 

The list box contains the names of all files and applications (except Works) 
on the current disk. You may have to scroll the list to see all the names. The 
name of the current disk is shown above the buttons. 

To delete a file from your disk, select the file you want to delete and then 
click the Delete button, or double-click the filename. 

Note You can’t delete an open document from your disk. 

Free Space This number gives the amount of unused space, in bytes, on 
the current disk. 
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In addition to the Delete and Cancel buttons, there are two other buttons in 
this dialog box: 

Drive Click the Drive button to list the files on the disk in the other disk 
drive. 

Eject Click the Eject button to eject the current disk from the disk drive. 
You can then insert the disk containing the file you want to delete. 

Important You cannot undo the Delete command. If you delete a file, it is 
not retrievable. 

Make Works Desktop Make Works Desktop 

When you quit Works, Works automatically saves a list of the files associ¬ 
ated with your open documents, along with their sizes and locations, in a file 
called Works Desktop. 

You can use the Make Works Desktop command to save the existing desktop 
without quitting Works, and to save multiple versions of the desktop for dif¬ 
ferent purposes. 

Saue Works Desktop File 

|Q Tutorial | 
— 
j Rddresset S© Works Pro. 
3 fUihUt 

liudgel [ Eject ] 

j Hna 1 Report [ Driue 
j Bequests 
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Saue Works Desktop fls: ( Saue ] 

|Works Desktop [ Cancel ] 
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New... 
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Close 
Close Rll... 

mw 

Saue 
Saue Rs... 
Delete... 

38S 

Make Works Desktop... 

Page Setup... 
Print... 3§P 
Print Window 
Eject Page 
Print Merge... 

Quit m 

Save Works Desktop As Works proposes the filename Works Desktop 
in the text box. If you accept the proposed name and make changes to the 
number, size, or location of files on your desktop and then choose Quit, 
Works automatically saves the changes to the Works Desktop file. 

To make a desktop file that reflects your current desktop, and that won’t be 
changed when you quit Works, type a filename (other than Works Desktop) 
in the text box, and click the Save button. 

Note The desktop file contains a list of the documents from your desktop, 
not copies of the documents themselves. If you include a document in a desk¬ 
top file, and then make changes to that document by opening and editing it 
individually, the latest version will appear on your desktop when you next 
open the desktop file. 
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Page Setup 

f lie " - 
New... 
Open... ago 

Close 
Close Rll... 
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Make LUorks Desktop... 

Page Setup... 
Print- 
Print Window 
Eject Page 
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Quit m 

Eject Click the Eject button to eject the current disk from the disk drive. 
You can then insert another disk and save your desktop file on that disk. 

Drive Click the Drive button to change to the other drive and save your 
desktop file in that drive. 

Works does not save untitled documents in the desktop file. If you try to save 
a desktop containing an untitled document, Works alerts you. Use Save As to 
name the document. 

When you want to work with a certain desktop arrangement, you have to 
start up with the same disks in the disk drives as when you saved the desk¬ 
top, or Works may not be able to find all the files you need. If Works can’t 
find the files, it displays an alert box. 

Page Setup 

The Page Setup command controls the appearance of a printed document. 

When you save a document, Works stores the settings chosen with this com¬ 
mand along with the document. 

Note In the Database, Page Setup is available only when a report window 
is active. In the Word Processor and Spreadsheet, Page Setup is available 
only when Draw is off. 

ImageWriter_ 

Paper: ® US Letter O 04 Letter 
O US Legal O International Fanfold 
O Computer Paper O Custom Size 

[ Cancel ] 

Orientation Special Effects: Tall Adjusted 
□ 50 7o Reduction 
□ No Gaps Between Pages 

□ Print Row and Column Numbers 
□ Print Cell Notes 

Header: || 

Footer: | 

Left Margin: 11 ~| 

Top Margin: 11 ] 

Paper Width: [TjF 

Paper Height: 111 

Right Margin: [T 
Bottom Margin: IT 

Works comes with the ImageWriter printer driver, which can be used with 
the standard and wide ImageWriter and ImageWriter II printers. If you use 
a different printer driver, the dialog box you see may differ from the one 
above. 
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Paper Click an option: 

US Letter 

US Legal 

Computer Paper 

A4 Letter 

International Fanfold 

Custom Size 

8-1/2" by 11" 

8-1/2" by 14" 

15" by 11" 
(this option works with only a 15" 
ImageWriter) 

8-1/4" by 11-2/3" 
(European letter size) 

8-1/4" by 12" 

Defined by you 

While all margins are set to 0, you can specify custom-size paper to a max¬ 
imum height of 273" and a maximum width of 273". To use a width of more 
than 15", you must click the icon for wide printing orientation. The minimum 
height for custom-size paper is 1", and the minimum width is 1". When all 
margins are set to 1, the minimum height and width is 2.1". If you use con¬ 
tinuous form paper, measure the height of the paper between the perforations. 
If you use continuous form labels, measure the distance from the top edge of 
one label to the top edge of the next label. 

Note Custom Size paper is not an available option when you use a 
LaserWriter printer. 

Orientation Click one of the icons: 

Tall Vertical orientation 

Wide Horizontal orientation 

Special Effects Click any options you want: 

Tall Adjusted Vertical orientation; prints pictures with 
correct proportions 

50% Reduction Prints your document at half the normal 
size 

No Gaps Between Pages Prints your document up to the per¬ 
foration with no extra spacing 

Note Tall Adjusted is preset in all of the Works tools. This setting prints 
most information to the ImageWriter in the appropriate height-to-width ratio. 
Some images may not print properly using Tall Adjusted. If you are 
experiencing problems, turn Tall Adjusted off before printing. 

The Print Row and Column Numbers and Print Cell Notes options are avail¬ 
able only in the Spreadsheet. 



Print Row and Column Numbers Click this option if you are printing a 
Spreadsheet document and you want the row and column headings (numbers 

and letters) to appear. 

Print Cell Notes Click this option if you are printing a Spreadsheet docu¬ 
ment and you want to print the cell notes it contains. Cell notes are printed 
after the Spreadsheet document. Notes are identified by their cell reference, 
and are printed first by column, then by row. For example, A1 through A10, 
then B1 through BIO, and so on. 

Paper Width If you click the Custom Size option, type the paper width in 

inches into the text box. 

Paper Height If you click the Custom Size option, type the paper height 

in inches into the text box. 

Header If you want page headers, type the text you want Works to use for 
the header into this text box. Works prints the header at the top of each page, 
centered between the text and the top edge of the page. If the margin 
between the text and the top of the page is more than one inch, the header 
prints one inch from the top of the page. 

Footer If you want page footers, type the text you want Works to use for 
the footer into this text box. Works prints the footer at the bottom of each 
page, centered between the text and the bottom edge on the page. If the mar¬ 
gin between the text and the bottom of the page is more than one inch, the 
footer prints one inch from the bottom edge of the page. 

Works provides a set of formatting commands to use in headers and footers. 
You can tell Works to print parts of the header and footer at the left, right, or 
center of a page; to include the page number, date, time, and document 

name; and to print in bold or italic type. 

Type To 

&L 

&C 

&R 

&P 

&D 

&T 

&F 

&B 

&I 

&& 

Align the characters that follow at the left margin. 

Center the characters that follow. 

Align the characters that follow at the right margin. 

Print the page number. 

Print the current date. 

Print the current time. 

Print the name of the document. 

Print the characters that follow in bold. 

Print the characters that follow in italic. 

Print a single ampersand. 
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You can include any combination of these instructions in a single header or 
footer. For example, you would type &LTelephone Report&C&D&R&P into 
the header text box to print “Telephone Report” in a header at the left margin 
on each page, the current date centered in the header, and the page number at 
the right margin. You can use either uppercase or lowercase letters in 
formatting commands. 

Note When a Word Processor document is active, you can use the Font, 
Size, and Color commands to adjust the font, size, and color of the header 
and footer. You can also print consecutive page numbers in headers and 
footers throughout a series of documents. For more information, see “Headers 
and Footers” in Chapter 4. 

If you type a header or footer without making any changes to it, it prints in 
the preset font, size, and color for the tool you’re working in. In the Word 
Processor, this is Boston 10 point, black. In the Spreadsheet and Database, 
this is Geneva 9 point, black. 

Margins The margin settings determine the amount of space between the 
edge of the paper and the printed document. 

The margins are preset to 1" at the top, bottom, and sides of the page. To 
change a margin, press the Tab key to move the selection into the box you 
want, then type the number of inches (such as 0.5, 2, or 2.75). 

Note For a Word Processor document, if you set right and left margins that 
conflict with the indent markers on the ruler, Works displays an alert box. 
For more information on setting indents, see “Indenting Text” in Chapter 4. 

Print 

The Print command prints the active document using the settings from the 
Page Setup command and includes any page breaks. 

Quality The Quality setting you choose determines the print resolution. 
The higher the resolution — the more dots used to form characters — the 
better the quality. If you click 50% Reduction in the Page Setup dialog box, 
the Quality options are dimmed. 

Print 

1 ll<‘ BHHMi 
New- 
Open... 8€0 

Close §6W 
Close nil... 
Saue ms 
Saue Rs... 
Delete... 

Make Works Desktop... 

Page Setup... 
Print... 
Print Window 
Eject Page 
Print Merge... 

Quit m 
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Click_For  

Best High resolution (sharpest) 

Faster Medium resolution (less sharp, but prints faster) 

Draft Low resolution (least sharp, but prints fastest) 
Prints text only, in the printer’s preset font, with no graphics, 
no gridlines, and with inconsistent spacing between words. 

Page Range To print all the pages in the document, click the All option. 
To print a range of pages, click the From option and type the first page 
number of the range you want to print. Then press the Tab key to move the 
insertion point into the To box, and type the last page number of the range 
you want to print. 

Copies Type the number of copies you want. 

Paper Feed Click Automatic if you are using continuous-form paper. 
Click Hand Feed if you are using single sheets of paper. 

Print Preview To view a document before you print, click the Print Pre¬ 
view option. 

The document appears in the orientation chosen in the Page Setup dialog box. 
You’ll be able to see headers, footers, and drawings exactly as they’ll print. 

There are four buttons in the Print Preview window: 

Print Click the Print button to print the document. 

Cancel Click the Cancel button to cancel the Print Preview window and 
the Print command. 
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Next If your document contains more than one page, click the Next button 
to view successive pages. 

Previous If your document contains more than one page, click the Previ¬ 
ous button to view preceding pages. Depending on available memory, you 
can preview up to four previous pages at a time. 

While the pointer is over the page area, it changes to a magnifying glass. 
Clicking on a page causes that part of the page to be shown full size. When 
the page is full-sized, the magnifying glass changes to a hand. To view other 
parts of the page, you can move the page by dragging the hand. To reduce 
the page, double-click the hand or click the close box in the title bar. 

Print Window Print Window 

The Print Window command prints the contents of the active window. 

When you choose Print Window, Works prints only the data you see in the 
window, without the title bar, scroll bars, and size box. 

In the Word Processor and Spreadsheet, Print Window is available only when 
Draw is off. 
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Eject Page Eject Page 

The Eject Page command ejects the paper in the Image Writer to the top of 
the next sheet of paper. 

If you are using a LaserWriter, or the Appletalk network, you won’t be able 
to use this command. 
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Close mw 
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Quit 
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Quit 

The Quit command ends a Works session. 

If you have made changes to any open documents and have not saved them, 
Works displays an alert box for each document. 

Saue changes to Sales Projections (SS)? 

Yes Click the Yes button to save the changes. 

No Click the No button if you don’t want to save the changes. 

Cancel Click the Cancel button to cancel the Quit command. If you click 
the Cancel button, the document is not saved and you return to the document 
named in the alert box. 

If you have made changes to a macro file and have not saved it, Works 
displays a dialog box. 

Choose Yes to save the changes. Choose No to ignore the changes and quit 
Works. 

For a description of how to save your document before you choose Quit, see 
“Save” and “Save As” in this chapter. For a description of how to save your 
macro file before you choose Quit, see “Save Macro File” and “Save Macro 
File As” in this chapter. 

When you quit, Works saves a list of the files associated with your open 
documents in a file called Works Desktop. The next time you start Works, 
you can select the Works Desktop file in the Open dialog box. Works then 
restores the documents that were on the desktop when you quit. 

You can also save a desktop without quitting Works. See “Make Works 
Desktop” earlier in this chapter for more information. 

The Edit Menu 

The first six commands on the Edit menu are common to all tools in Works. 
The Draw On command is common to the Word Processor and Spreadsheet 
tools. For related information specific to a particular tool, see the part of this 
manual that pertains to that tool. 

Quit 

New... 
Open... 9€0 

Close 
Close Rll... 
Saue 
Saue Rs... 
Delete... 

38W 

§§s 

1 Make Works Desktop... | 

Page Setup- 
Print... 
Print Window 
Eject Page 
Print Merge— 

3§P 

. 
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Undo Undo 

The Undo command reverses the effects of the last editing command made. 

When you cannot undo something, the command is dimmed. 

Important You cannot undo the Delete command or any other command 
from the File menu. 

Edit 

Undo mz 1 

cut *H 
Copy 86C 
Paste 
Clear 
Select Rll 

Dram On §gj 

Prepare to Merge... 9§M 
Shorn Field Names 
Multiple Labels 

Cut Cut 

The Cut command removes the current selection from your document and 
places it on the Clipboard. 

You can cut text from anywhere in a document, including the entry bar in 
Database and Spreadsheet documents. You can cut drawn objects in Word 
Processor and Spreadsheet documents. 

In a Spreadsheet document, use the Erase Chart command in the Chart menu 
to remove a chart. Use the Cut and Paste commands to move data to another 
Spreadsheet document or to a document from another tool. Within a single 
Spreadsheet document, however, use the Move command to rearrange your 
data. For more information, see “Move” in Chapter 16. In the Database and 
Word Processor, information within a single document can be moved with 
Cut and Paste. 

Copy 

The Copy command copies the current selection and places it on the Clip¬ 
board. Your document remains unchanged. 

You can copy text from any part of a document, including the entry bar in 
Database and Spreadsheet documents. You can also copy drawn objects and 
text that includes a drawn object from Word Processor and Spreadsheet 
documents. 

When you are editing in the entry bar, you can copy text by selecting it and 
choosing Copy. Works puts a copy of the selected text on the Clipboard, 
replacing the Clipboard’s contents. After you copy a selection, you can paste 
it at the insertion point in the entry bar. 

Edit 

Undo d%Z 

Cut :#:« 

Copy 3§C 
Paste 
Clear 
Select Rll 

mi 

Draw On 

Prepare to Merge... 
Show Field Names 

&M 

Multiple Labels 

Copy 

Edit 

Undo 9€Z 

Cut 

Paste 
Clear 
Select Rll 

3§U 

Draw On 

Prepare to Merge... 
Show Field Names 

9§M 

Multiple Labels 
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Paste Paste 

Edit 

Undo %Z 

Cut 
Copy &C 
Paste &LI 

Clear 
Select Rll 

Draw On 

Prepare to Merge... 
Show Field Names 
Multiple Labels 

3§M 

The Paste command pastes the information currently on the Clipboard into 
the active document at the insertion point. If text is selected, Paste replaces 
the selection with the information on the Clipboard. 

In the Spreadsheet, the Paste command pastes all cell properties for every cell 
pasted, including the formula or value, number format, grid status, style, 
alignment, and protection status. If you want to paste only values without any 
formulas, use the Paste with Options command. For more information, see 
“Paste with Options” in Chapter 16. 

Works can paste the contents of a Clipboard that contains a drawn object or 
text and a drawn object, and can tum normal text into a text object. For 
information on pasting drawings, see “Copying Drawings” in Chapter 20. 

Clear. Clear 
Edit 

Undo 98Z 

Cut 
Copy 9€C 
Paste %U 
Clear 

Select Rll 

Draw On 

Prepare to Merge... 38M 
Show Field Names 
Multiple Labels 

The Clear command removes the selection from your document, but does not 
place it on the Clipboard. Use Clear when you want to delete rather than 
move or copy information. 

Note Clear removes the information and any cell or field attributes, but it 
does not remove the font, size, style, or color of a selection. 

Select All Select All 

Edit 

Undo 3SZ 

Cut 
Copy 
Paste &U 
Clear _ 
Selec t Rll 

Draw On 

Prepare to Merge... §§M 
Show Field Names 
Multiple Labels 

The Select All command selects an entire document. 

Select All is useful in the Word Processor when you want to change the font 
or set an indent for an entire Word Processor document. 

In the Database, Select All is used only in the list window. If Match Records 
or Record Selection has been chosen, Select All does not select any records 
that do not match the criteria and are not currently displayed. 

In the Spreadsheet, Select All selects all cells — including blank cells, and 
hidden rows and columns. 

In the Spreadsheet and Word Processor, Select All selects objects in the draw 
layer, if Draw is off. If Draw is on, you can’t choose Select All. 
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Draw On/Draw Off 

The Draw On command starts Draw in the Word Processor and Spreadsheet, 
and displays the Tools palette. With Draw, you can use the palette and the 
commands in the Format, Fill Pattern, Line Pattern, and Macro menus to 
draw pictures in your Works Word Processor and Spreadsheet documents. 

The Tools palette allows you to choose from ten tools, view the current fill 
and line patterns, move a selection pixel-by-pixel, select one of five line 
thicknesses, and add or remove arrows from the ends of lines. For more 
information on the Tools palette, see “Starting Draw” in Chapter 1. 

The Draw Off command removes the Tools palette and turns Draw off. Draw 
Off appears in the Edit menu only when you are using Draw. 

In the Draw Layer 

Draw On 
Draw Off 

Edit 

Undo §§z 

Cut 
Copy §gc 
Paste agu 
Clear 
Select Hll 

Prepare to Merge... 9€M 
Shorn Field Names 
Multiple Labels 

When Draw On is chosen from the Word Processor or Spreadsheet Edit 
menu, the Format menu contains additional commands, and Fill Pattern and 
Line Pattern menus are added to the menu bar. 

The Draw Layer Format Menu 

When you are using Draw, the top part of the Format menu contains com¬ 
mands for changing the justification, style, font, and size of text, as well as 
the colors of text and graphic objects. The bottom part of Draw’s Format 
menu contains commands for manipulating the placement of objects on the 
screen. 

Most of Draw’s Format menu commands are explained in the following para¬ 
graphs. Font and Size are explained in detail under “The Format Menu,” later 
in this chapter. 

Justification 

The Justification command leads to another menu that lists justification com¬ 
mands for the text in a text object. A text object can have only one justifica¬ 
tion. 

Left The Left command aligns all lines with the left edge of the object. 

Center The Center command centers each line between the left and right 
edges of the object. 

Justification 

Font 
Size 
Style 
Color - Black Dots 
Color - lilhite Dots 

► ' 
► 
► 

► 

Group Picture XG 
Ungroup Picture mi 
Grid Setting... 
Grid On 
Bring to Front 
Send to Back :#:B 

<✓$1)0111 Column Bones 
Spread Tent 
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Right The Right command aligns each line with the right edge of the 

object. 
Justified The Justified command aligns the beginning of each line with the 
left edge of the object and the end of each line with the right edge of the 
object. Spaces between complete words in each line are adjusted to give the 
appearance of evenly-spaced text. 

Note When you edit fully-justified text, it appears on the screen as left- 
justified. When you finish editing, the text is fully-justified. The first time 
you choose full justification during a drawing session, Works alerts you to 
this situation. Click the OK button to justify. 

For all justification choices, only complete words are placed on a line. 

Style 

Justification 

Font 
Size _ 

► 
► 
► 
✓Normal 

Color - Black Dots ► Bold 

Color - White Dots ► Italic 
Underline 

Group Picture XG (DmQOOms 

Ungroup Picture XU aojEDcDaoD 

Grid Setting- 
Grid On 
Bring to Front M 

Send to Back XB 

✓Show Column Boxes 
Spread Text 

Style 

The Style command leads to another menu which lists type styles (such as 
Bold or Underline) for a text object. When the Text tool is active, a style 
affects only the selected text, or the text you’re about to type. When an 
object is selected with the Selection tool, a style affects the entire object. The 
checkmarks on the menu indicate those styles currently in effect. 

This command 

Normal 

Bold 

Italic 

Underline 

Outline 

Shadow 

Looks like this 

Normal 
Bold 
Italic 
Underline 
Mta 

You can check multiple styles, such as Bold and Underline. When you 
choose Normal, all other styles are cancelled. 

Color - Black Dots 
Color - White Dots 

Justification ► 
Font ► 
Size ► 
Style ► 1 
Color - Black Dots HI v 
Color - White Dots ► 

Group Picture ^G 

Ungroup Picture XU 

Grid Setting... 
Grid On 
Bring to Front #f| 
Send to Back MB | 

✓Show Column Boxes 
| Spread Text | 

Color - Black Dots /Color - White Dots 

The Color - Black Dots command lets you choose a color for the pixels that 
are black on a black-and-white monitor. On a color monitor, “black” pixels 
in a pattern can be either white or colored. 

The Color - White Dots command lets you choose a color for the pixels that 
are white on a black-and-white monitor. On a color monitor, “white” pixels 
in a pattern can be either white or colored. 



Chapter 2 Common Tasks Command Reference 65 

Note You can choose colors for objects before you draw them by clicking 
outside any selected objects to deselect them, and choosing the black and 
white dot colors for the next object. 

If you choose colors for a patterned object on a black and white monitor the 
pattern may appear as solid black. However, if you have a PostScript printer 
(most LaserWriters), the pattern will print. If you have a LaserWriter SC (or 
any QuickDraw-based printer), a patterned object with black dot and white 
dot colors other than black and white will print as solid black. 

Group Picture/Ungroup Picture 

The Group Picture command lets you select several individual objects and 
move, resize, fill, color, and delete them exactly as if they were a single 
object. To group objects, hold down the Shift key, click each object, and 
then choose Group Picture. 

You can also create a group using standard Macintosh techniques: place the 
selection tool outside one comer of the objects you want to group, drag diag¬ 
onally to the opposite comer of the group, and then choose Group Picture. 

The Ungroup Picture command reverses the Group Picture command. To 
ungroup, select a previously grouped set of objects and choose Ungroup Pic¬ 
ture from the Format menu. Works reverses the Group Picture command — 
click outside the group to deselect the objects. 

Grid Setting 

The Grid Setting command sets the spacing for an invisible alignment grid, 
which aligns objects horizontally and vertically along the grid lines. For a 
grid to be in effect, the Grid On command must be checked in the Format 
menu. 

Choose the spacing you want in the Grid Setting dialog box and click the 
OK button. 

Grid Setting: 

O1/2 inch O1/9 inch O 1 centimeter 

O1/3 inch 01/12 inch O 1/2 centimeter 

O 1 /4 inch 01/18 inch O 1 /4 centimeter 

O1/6 inch O1/24 inch O 1 /? centimeter 

<D 1/8 inch O1/36 inch 01/14 centimeter 

Cancel ) 

Group Picture 
Ungroup Picture 

Format 

► 
► 
► 
► 
► 
► 

&G 
Ungroup Picture 
Grid Setting... 
Grid On 
Bring to Front 3§F 
Send to Back 3§B 

✓Show Column Bowes 
Spread Tewt 

Justification 
Font 
Size 
Style 
Color - Black Dots 
Color - White Dots 

Grid Setting 

Format 

Justification ^ 
Font ^ 
Size ^ 
Style ^ 
Color - Black Dots ► 
Color - White Dots ► 

Group Picture &G 
Ungroup Picture &L) 

Grid On 
Bring to Front &F 
Send to Back 3§B 

✓Show Column Bo»es 
Spread Tewt 
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Grid On Grid On 

Format 
Justification ► 
Font ► 
Size ► 
Style ► 
Color - Black Dots ► 
Color - UJhite Dots ► 

Group Picture 9€G 
Ungroup Picture 98U 
Grid Setting... 
Grid On 
Bring to Front 98F 
Send to Back 3€B 

yShouj Column Bones 
Spread Tent 

If the Grid On command is checked in the Format menu, Works places an 
invisible grid over the screen which automatically aligns objects with the 
nearest horizontal and vertical lines in the grid. The grid affects only objects 
that are drawn or moved while the grid is on. Spacing for the grid lines is set 
using the Grid Setting command. 

If Grid On is not checked in the Format menu, objects are not aligned with 
the Grid. Instead, they are placed in the exact location where they are drawn 
or moved on the screen. 

Bring to Front 
Send to Back 

Format 
Justification ► 
Font ► 
Size ► 
Style ► 
Color - Black Dots ► 
Color - UJhite Dots ► 

Group Picture 3§G 
Ungroup Picture §§U 
Grid Setting- 
Grid On 

961 

Send to Back <£B 
s/Shoiu Column Bowes 

Spread Tewt 

Bring to Front/Send to Back 

The Bring to Front command moves a selected object to the frontmost plane 

in Draw. 

Select the object you want to bring to the front, and then choose Bring to 
Front from the Format menu. The object overlaps any other objects on the 

screen. 

The Send to Back command moves a selected object to the backmost plane in 
Draw. The object is overlapped by other objects on the screen. 

Show Column Boxes Show Column Boxes 

I 

Format 
Justification ► 
Font ► 
Size ► 
Style ► 
Color - Black Dots ► 
Color - UJhite Dots ► 

Group Picture 3€G 
Ungroup Picture 
Grid Setting- 
Grid On 
Bring to Front 36F 
Send to Back m 

Iv'Shou* Column Bowes 
| Spread Tewt | 

If the Show Column Boxes command is checked in the Format menu, the 
dashed lines around columns are displayed on the screen. 

If Show Column Boxes is not checked, the dashed lines around columns are 
not displayed on the screen. 
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Spread Text 

The Spread Text command lets you align text along a line or an arc. 

To use Spread Text, select text from a document or a text object. Copy it to 
the Clipboard, and draw or select the line or arc along which you want to 
spread the text. Then choose Spread Text from the Format menu. 

Spread Text makes individual objects out of each of the characters in the 
selected text object and spreads them out evenly in the direction that the line 
or arc was drawn. 

You can group the text using the Group Picture command and then drag the 
object s handles to spread the text further or pull the text tighter along the 
line or arc. 

Wofe If you don’t want to see the line or arc, choose transparent (0) from 
the Line Pattern menu, or choose no line width from the Tools palette. 

If text has not been copied to the Clipboard, and a line or an arc has not been 
designated before the Spread Text command is chosen, the command is 
dimmed and you can’t choose it. 

Spread Text 

Format 

Justification ► 
Font ^ 
Size ^ 
Style k 
Color - Black Dots ► 
Color - IBhite Dots ► 

Group Picture 
Ungroup Picture §SU 
Grid Setting... 
Grid On 
Bring to Front &F 
Send to Back $£B 

✓Shorn Column Bones 
Spread Tent 

The Fill Pattern Menu 

The Fill Pattern menu provides patterns to fill all objects except lines. 

You can fill an object by choosing a tool, choosing a pattern, and drawing 
the object, or by selecting an existing object and choosing a pattern. 

When you turn Draw on in a document, the fill is transparent (0). 

You can choose a fill pattern before drawing objects by clicking outside any 
selected objects to deselect them, and choosing a pattern for the next object. 

The Fill Pattern menu 

Fill Pattern 
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The Line Pattern 
menu 

The Line Pattern Menu 

The Line Pattern menu provides patterns for lines and borders for all objects 
except text objects. The width of the line depends on the line width selected 

in the Tools palette. 

You can choose a line pattern and width by choosing the tool, choosing the 
width, selecting a pattern, and drawing the object, or by selecting an object 
and then choosing the width and pattern. If you choose (0), the line or 
border is transparent. 

You can choose a line pattern before drawing objects by clicking outside any 
selected objects to deselect them, and choosing a pattern for the next object. 

The Window Menu 

Show Clipboard 
Hide Clipboard 

Window HHSI 

Show Clipboard 

Help 

Business Cards (DB) 19K 

Show Clipboard/Hide Clipboard 

The Show Clipboard command opens the Clipboard window. This window 
contains the last selection you cut or copied since your Macintosh was 
turned on. 

You cannot edit the contents of the Clipboard. 

To close the Clipboard window, click its close box, choose Close from the 
File menu, or choose Hide Clipboard from the Window menu. 

Help 

The Help command leads you to the Works help system. 

When you choose Help, Works looks on the Works Program disk and in the 
folder from which you started Works. If Works can’t find Help, you’re asked 
to locate and open it. Once Works knows Help’s location, you won’t be 
asked again unless you change its location. 



Chapter 2 Common Tasks Command Reference 69 

When Works locates Help, it displays a window: 

Help (WP) 
Vord Processor 

Microsoft Vorks Help gives you information about commands for the tool you are using. If 
you are using the Vord Processor, you can get help on Vord Processor commands. If you 
are using the Database, you can get help on Database commands, and so on. 

If you need more information than Help gives, refer to the Using Microsoft Vorks page 
number next to each command name. Your manual provides more details about each 
command. 2 

a 

The window contains general information about the active tool. It also directs 
you to additional information about each command available for the tool. 

When the Help window is active, the pointer becomes a question mark any¬ 
where outside the Help window. To get help about any command, pull down 
a menu and choose the command. A description of the command, as well as 
a page number from this manual, is displayed in the window. 

For example, if you want a brief explanation of the Save As command, 
choose Save As from the File menu while the Help window is active. 
A description of Save As is displayed in the window. 

You can scroll vertically in the Help window, change its size and position, 
and close it, just as with other Works windows. 

You can leave the Help window open while you work on a document. To 
make the document active, click anywhere within the document window. 

To close the Help window, click its close box. 

Activate Window 

The Activate Window command is actually a group of commands that 
changes according to the windows you have open on the desktop. There is 
always one command for each open window. The only exceptions are the 
Help and Clipboard windows. 

Each command that appears in this part of the Window menu activates the 
window containing the document with the same name as the command. 

Use this command to activate a window quickly. The command name shown 
here is just an example; your menu will show whatever windows you have 
open. 

You can activate the last window in the list of document names by pressing 
Command+ , (comma). Works brings the window to the front, and moves 
the document name to the top of the list. In this way, you can easily move 
through a series of open documents. 

Activate Window 

Window 

Show Clipboard 

Help 86? 

Business Cards IDBI 19K 
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Font 

Set Cell Attributes... 

Borders ► 

./Boston 

Size ► 
Color ► 

Chicago 
Courier 
Geneua 
Heluetica 
Monaco 
Times 

Column Ulidth... 

Three commands in the Format menu — Font, Size, and Color—are common 

to all Works tools. 

Font 

The Font command leads to another menu which lists fonts that you can use 
for your text. When you choose a font in the Word Processor, it affects only 
the selected text or the text you’re about to type. In the Spreadsheet, a font 
affects the entire document. In the Database, a font affects the active view 
(form, list, or report) for the entire document. When drawing, a font can 
affect the entire text object, selected text within the object, or text you’re 
about to type. 

You can change fonts before you type text by selecting the font you want and 
then typing the text, or you can change the font of text already in your docu¬ 
ment by selecting the text and choosing a font. The font will be changed, but 
the type size will remain unchanged. In the Word Processor, Spreadsheet, 
and Draw, the type styles will also remain unchanged. 

Works’ preset fonts are: 

Word Processor 

Database 

Spreadsheet 

Boston 10 

Geneva 9 

Geneva 9 

Note Works uses the fonts in your System file; the System shipped with 
Works includes the Boston font. If you use two 3.5-inch disk drives, Boston 
10 point will be the preset font and size for the Works Word Processor. If 
you use a hard disk and you don’t install the font on your working disk using 
the Font/DA Mover, the preset font will be Geneva. To save space on your 
working disk, use the Font/DA Mover to remove those fonts that you don’t 
use. For information on the Font/DA Mover, see your Macintosh owner’s 
guide. 

If you are using a LaserWriter printer, the Font Substitution option automati¬ 
cally converts some fonts, such as Geneva, to LaserWriter fonts. Other fonts, 
such as Boston, have no automatic substitution. Generally, it is best to 
choose a font recommended for the LaserWriter, such as Times or Helvetica, 
before you print. For more information, see your LaserWriter manual. 
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Size Size 

The Size command leads to another menu which lists type sizes. When you 
choose a size in the Word Processor, it affects only the selected text or the 
text you’re about to type. In the Spreadsheet, a size affects the entire docu¬ 
ment. In the Database, a size affects the active view (form, list, or report) of 
the entire document. When drawing, a size can affect the entire text object, 
selected text within the object, or text you’re about to type. 

You can change sizes before you type text by selecting the size you want and 
then typing the text, or you can change the size of text already in your docu¬ 
ment. Just select the text, and then choose a size. The size of the selection 
will be changed, but the font will remain unchanged. 

The sizes shown in outline type on the menu are those recommended for the 
font selected in the Font menu. You can choose any size for any font, but 
those sizes that are not recommended will produce a rougher appearance, 
both on the screen and on the printed page. 

Other In addition to the sizes listed, to take full advantage of the scaling 
available on the LaserWriter printer, you can choose the Other command. 
When you choose Other, Works displays a dialog box from which you can 
choose any size from 4 to 72. 

1 Format 1 
Set Cell Rttributes... 

Borders ► 

Font ^ 

Size ► 9 Point 
Color ^ 10 Point 

✓1IS PsDffiQ 
1 4 Point 

18 Point 

20 Point 

24 Point 

Other... 

Column Width... 

Set Font Size: 

[ Cancel j 

To save space on your disk, use the Font/D A Mover to remove those sizes 
that you don’t use. For more information, see your Macintosh owner’s guide. 

Color Color 

The Color command leads to another menu which lists commands for chang¬ 
ing the text color of a document. If you have a color monitor, you can 

i ot i ’ ** 

Set Cell Rttributes... 

display colors; if you have a color printer, you can print them. Borders ^ 

In the Word Processor, color choices affect only the selected text. In the 
Spreadsheet, color choices affect the entire document. In the Database, color 
choices affect the active view (form, list, or report) of the entire document. 
When drawing, the color chosen in Color - Black Dots affects the black dots 

Font t 

Size ^ 

Color ► ✓Black 

Column Width... 
QMMQa 
Red 

in a pattern and the color chosen in Color - White Dots affects the white 
dots. 

Green 

Blue 

Cyan 

Magenta 

Yellouj 
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Macros On 
Macros Off 

Playback Rnd... 

Start Recording— 
Stop Recording- 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File fis... 

Playback And 

Macro 
^Macros On 

Macros Off 

Playback Rnd... 

Start Recording... 
Stop Recording- 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File fis... 

The Macro Menu 

The commands in the Macro menu are common to all tools in Works. 

Macros On/Macros Off 

The Macros On command tells Works that you are ready to use macros. 
When you choose Macros On, Works opens the Microsoft Works(keys) file 
and records your macros to this file in memory. If Microsoft Works(keys) is 
not on the same disk as the Works Program, Works opens another untitled 
macro file and records your macros to that file. 

The Macros Off command tells Works that you are no longer using macros. 

A checkmark in the menu indicates the command currently in effect. 

Playback And 

The Playback And command lets you play back pre-recorded macros, and 
delete macros from a macro file. Playback And also gives you quick access 
to commands for recording macros, creating new macro files, opening exist¬ 
ing macro files, and saving both new and existing macro files. 

Play To play back a macro, select the macro from the list and click the 
Play button. You can also play back a macro without using the menu. Hold 
down the Option key and press the key associated with a macro in the open 
macro file. 
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Record Click the Record button to record a new macro. Works displays 
the Start Recording dialog box. For more information, see “Start Recording” 
in this chapter. 

Delete To delete a macro, select it in the list box and click the Delete but¬ 
ton. Works deletes the macro from memory. The macro is deleted from the 
disk the next time you save the macro file. 

New Click the New button to open a new macro file. Works opens a new 
macro file, and immediately returns you to your document. The macros you 
record will be recorded in the new macro file. 

Open Click the Open button to open an existing macro file. Works 
displays the Open Macro File dialog box. For more information, see “Open 
Macro File” in this chapter. 

Save Click the Save button to save an existing macro file to a disk. 

Save As Click the Save As button to save a new macro file, or a new ver¬ 
sion of an existing macro file to a disk. Works displays the Save Macro File 
As dialog box. For more information, see “Save Macro File As” in this 
chapter. 

Note If you choose Playback And and you have not saved the open macro 
file, a macro filename will not appear in the Playback And dialog box. Once 
you save a macro file, you’ll see the filename of the open macro file at the 
top of the dialog box. 

Start Recording 

The Start Recording command begins recording a series of keyboard and 
mouse commands for later playback. 

Start Recording: 

Key Description of new macro 

□ Record pauses ( Cancel ] 

To start recording a macro, type a single key to be associated with the 
macro. Press the Tab key, type a short description, and then click the Record 
button. 

Works plays macros back at the fastest possible speed. Choose Record pauses 
if you want to play back the macro at the speed at which it was recorded, 
including any time delays. 

Start Recording 

Macro 

s/Macros On 
Macros Off 

Playback Rnd... 

Start Recording... 
Stop Recording... 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File fls... 
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Stop Recording 

Macro 

✓Macros On 
Macros Off 

Playback Rnd... 

Start Recording... 
Stop Recording... 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File Rs... 

Note There are three types of keys that can’t be associated with macros: 

■ Accent Keys: E, I, N, U, ' 

■ Modifier Keys: Shift, Option, Command, Caps Lock 

■ Reserved Keys: Delete (Backspace), ‘, =, -, + , - 

Stop Recording 

The Stop Recording command tells Works that you have finished recording 

the macro. 

When you choose Stop Recording, Works displays a dialog box from which 
you can choose to stop recording, continue recording, or cancel the macro. 

Stop If you click the Stop button, Works stops recording and saves the 
macro to the macro file in memory. If you want to record a pause, and have 
not chosen Record Pauses in the Macro menu, click Record previous delay 
before clicking the Stop button. This option records the delay immediately 
preceding your choice of the Stop Recording command. 

Continue If you’ve started recording a macro and decide that you want to 
start recording pauses, choose Record future delays. If you want to record the 
delay immediately preceding your selection of the Stop Recording command, 
choose Record previous delay. 

To record_Choose__ 

The pause preceding this point Record previous delay 

Pauses from this point Record future delays 

The pause preceding this point Both options 
and all pauses from this point 

If you choose the Record Pauses command in the Macro menu before record¬ 
ing, Record previous delay and Record future delays are already selected for 
you. If you chose either option during recording, the Record Pauses com¬ 
mand is automatically checked in the Macro menu. 
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Record Pauses Record Pauses 

If the Record Pauses command is not checked, Works records and plays the 
macro back at the fastest possible speed. 

If this command is checked, Works plays the macro back at the speed at 
which it was recorded, including any time delays. 

If you choose Record previous delay or Record future delays in the Currently 
Recording dialog box, Works checks the Record Pauses command for you. 

Macro 

✓Macros On 
Macros Off 

Playback Rnd... 

Start Recording... 
Stop Recording... 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File Hs... 

Open Macro File Open Macro File 

The Open Macro File command opens a new or existing macro file. When 
you choose Open Macro File, Works displays a list of existing macro files 
for you to choose from. 

Open Macro File 

CD Works Pro... 

[ oec> 1 
[ Driue ] 

[ Open ] 

[ Neni ] 

[ Cancel ] 

Si Tutor ial 

Macro 

✓Macros On 
Macros Off 

Playback Rnd... 

Start Recording... 
Stop Recording... 

Record Pauses 

Open Macro File... 

I Saue Macro File 
1 Saue Macro File fis... 

Open To open an existing macro file, select the file in the list box and 
click the Open button. 

New To open a new macro file, click the New button. Works opens a new 
macro file, and immediately returns you to your document. Any macros you 
record will be recorded in the new macro file. This file is unnamed until you 
save it. 

Eject To open a macro file on another disk, click the Eject button and 
insert the disk containing the file you want to open. 

Drive Click the Drive button to list the macro files on the other disk drive. 
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Save Macro File 

Macro 

^Macros On 
Macros Off 

Playback Rnd... 

Start Recording- 
Stop Recording- 

Record Pauses 

Open Macro File... 
Sane Macro File 

| Saue Macro File Rs... | 

Save Macro File As 

Macro 

^Macros On 
Macros Off 

Playback Rnd— 

Start Recording- 
Stop Recording... 

Record Pauses 

Open Macro File... 
Saue Macro File 
Saue Macro File Rs... 

Save Macro File 

The Save Macro File command saves the currently open macro file to the 
disk. Works saves the file with its current name and replaces the old copy of 
the file on the disk. 

If the macro file has not been saved previously, Works displays the Save 
Macro File dialog box. 

Save Macro File As 

The Save Macro File As command saves a new macro file, or a new version 
of an existing macro file. When you choose Save Macro File As, Works 
displays a dialog box. 

Save Macro File As If the file has never been named, Works proposes 
the name Microsoft Works(keys) in the text box. If the file already has a 
name, Works proposes that name. To accept the proposed name, and replace 
the macro file with the same name on the disk, click the Save button. To 
save the file with a different name, edit the proposed name or type a new 
one. 

Eject To save the file to another disk, click the Eject button and insert the 
disk to which you want to save. 

Drive Click the Drive button to save the file to another disk drive. 
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You can write just about anything with the Word Processor: letters, memos, 
reports, press releases, advertising copy, or even a novel. 
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The next three chapters show you what you need to know about writing with 
the Word Processor: 

■ Chapter 3, “Writing and Editing,” shows what a Word Processor docu¬ 
ment looks like, how to enter and edit text, and how to change the font, 
the type size, the type style, and the color of text. 

■ Chapter 4, “Formatting a Document,” explains ways to arrange your writ¬ 
ing on the page. 

■ Chapter 5, “Word Processor Command Reference,” describes the Word 
Processor commands. 

If you want to use the Word Processor with other tools — for example, to 
make form letters or mailing labels with Database information, or to copy 
charts from the Spreadsheet — see “Using the Tools Together,” the last part 
of this manual. 



3 Writing and Editing 

When you write and edit with the Word Processor, you don’t have to retype 
whole pages to make a change. You just insert, delete, or correct your text, 
and Works automatically adjusts the lines within paragraphs and repaginates. 
After you finish editing with the Word Processor, you have a finished pro¬ 
duct, ready to print. 

This chapter shows you how to: 

■ Recognize the parts of a Word Processor document, and create a new 
document. 

■ Enter text. 

■ Undo an editing mistake. 

■ Select text. 

■ Delete text. 

■ Cut, copy, and paste. 

■ Find and replace text. 

■ Change fonts, type sizes, type styles, and colors. 
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To create a new Word 
Processor document 

An Overview 

A Word Processor document looks like this: 

Creating a New Word Processor Document 

Before you can type or edit a document, you need to create a new document 
or open an existing file. 

When you start Works or choose Open from the File menu, the Open dialog 
box appears. 

To create a new Word Processor document: 

0 Click the Word Processor icon. 

HI Click the New button. 

Works opens a new Word Processor document. You can begin typing. 
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Typing 

To write with the Word Processor, you type text. The Word Processor stores 
the text in your Macintosh’s memory until you close the document. 

Text is made up of characters — letters, numbers, symbols, and spaces are all 
characters to the Word Processor. 

The Word Processor takes care of fitting your words onto lines as you type. 
When you type enough to reach the end of a line, any word that doesn’t fit 
within the right indent marker automatically moves to the next line. This is 
called wordwrap. 

r * File Edit Ulindotu Search Format Spell Macro 

Untitled UUP) 

... I1.. I2.., iT■, I3. ■, i,, ■ l4. ■ ■ i, ■, l5., ■ i,,, l6. ■ ■ i B 
i 

French, Swiss, and Italian regional leaders plan to attend the 

fireworks ceremonies in their respectr™? rniTy^.i iuu, and unrflending| 

lending their support to the success of the race. 

Wordwrap lets you type complete paragraphs without pressing the Return 
key. If you insert text in the middle of a paragraph, wordwrap automatically 
adjusts the lines; if you delete text in the middle of a paragraph, wordwrap 
closes up the empty space. 

As with an electric typewriter, the Return key in the Word Processor ends a 
line and starts a new one. But the Word Processor Return key actually types 
an invisible character, called a return character. This character signals the end 
of a paragraph for wordwrap. 

You should press the Return key only at the end of a paragraph. Wordwrap 
makes a neat paragraph of anything between return characters. 

If you want to control the ends of lines yourself—as in poetry or lists, for 
example — you can press the Return key at the end of each line. A single 
line with a return character at the end is just a short paragraph to the Word 
Processor. Wordwrap won’t affect these lines. 

Wordwrap 

The Return key 
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To insert a blank line You can also use the Return key to insert blank lines into your document. 

0 Position the insertion point where you want to insert the blank line. 

Position the insertion point here. 

6 File Edit Window Search Format Spell Macro 

ID ..n] 

1°, . . i . . . I1 , . I , . i I2. . 

= Article (WP) . ------ 

i,,, .... i I5 i i i i i i i i i I6 i i i i i i i | | o 
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UHlft Whs 
The new Hilltop Climber will hit the slopes in the Great Alpine 

\Race, sponsored by the Wheeler Bicycle Company. 
[Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

At major stops along the way, citizens of Alpine towns and 
cities_win turn out__to_greet__the racers with fireworks displays 

0 Press the Return key once if you’re at the beginning of a paragraph, or 
twice if you’re anywhere else in the text. 

A blank line is inserted just above the insertion point. 

6 File Edit Window Search Format Spell Macro 1 □ o
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■ Article (WP) ----- 
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The new Hilltop Climber will hit the slopes in the Great Alpine 
\Race, sponsored by the Wheeler Bicycle Company. 

[Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

__At major stops along the way, citizens of Alpine towns and_ 
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You can insert text anywhere in a document by moving the insertion point. 

□ Position the pointer and click to move the insertion point to where you 
want to insert some text. 

You may need to press the Return key, the Tab key, or the spacebar to 
put the insertion point where you want it. 

0 Begin typing. 

Your text pushes the insertion point and any following text to the right. 

Each Macintosh font contains optional characters for foreign letters, accents, 
and commercial, mathematical, and scientific symbols. For information on 
how to use these characters, see your Macintosh owner’s guide. 

If you type more than one page of text into your Word Processor document, 
you will notice that a horizontal dotted line appears on your screen. This is a 
page break indicator. When the page break has scrolled up on the screen so 
that it is the first line in the window, the page number in the vertical scroll 
box changes to show the page number corresponding to the first line of text 
in the window. For more information about page breaks, see “Formatting an 
Entire Document” in Chapter 4. 

Undoing a Mistake 

In many cases, the Undo command cancels the last action you’ve taken. 

To undo a mistake: 

0 Choose Undo from the Edit menu. 

If Undo isn’t appropriate or allowed for the last action you took, the com¬ 
mand is dimmed. 

If you save your text often (every ten minutes or so), you may prevent major 
mistakes that you can’t undo. Saving a document stores a copy of it on your 
disk. If you make a lot of mistakes, or any changes that you don’t want to 
keep, you can close the document without saving it, and then open the docu¬ 
ment again. For more information, see “Saving a Document” in Chapter 1. 

To insert text 

To type optional 
characters 

Page breaks and 
page numbers 

To undo a mistake 



Selecting Text 

When you want to do something with a block of text — remove it, for 
example — you must first select it. Works shows a selection by reversing the 
highlight — turning black letters on a white background into white on black. 
On a color monitor, if you’ve chosen a color using the Apple Control Panel’s 
Color icon, Works uses that color to show a selection. 

You can select a character, a word, a line, a sentence, a paragraph, or any 

size block of text. 

To select a word quickly, move the insertion point anywhere on the word and 

double-click. 

To select a line or paragraph quickly, move the insertion point to the left 
edge of the document — between the left edge of the window and the left 
margin of the text. When you’re at the correct place, the I-beam pointer 
becomes an arrow pointer. Click to select a line of text, double-click to select 
an entire paragraph, or drag to select consecutive lines. 

Click here to select the line. 
Double-click here to select the paragraph. 

r 
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Double-click a word to select it. 
Drag across a character to select it. 



Chapter 3 Writing and Editing 85 

To select text by dragging: 

E Position the pointer on one edge of what you want to select, and press 
the mouse button. Drag to select as much as you want, then release the 
button. 

You can also select an entire document — without dragging. You may want 
to do this to change the font or format throughout a document. 

® Choose Select All from the Edit menu. 

Works selects all the text in the document. 

If you decide your selection doesn’t cover exactly what you want, you can 
extend or reduce the selection. 

Original selection 

* File Edit LUindom Search Format Spell Macro 

in— 

... ■ i i i i i i l2i i i 

= Article (LDP) =• 

1 i i i Pi i i 1 i i i Pi i i 1 i I5, . , 1 . I6i . , 1 . o 
> ◄ 1 

Ul\rmn=amimwn Climber will hit the slopes in the Great Alpine 
Race, sponsored by the Wheeler Bicycle Company. 

Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

__At_ major stops along the way, citizens of Alpine towns and 

B Hold down the Shift key and click or drag at the side of the selection to 
extend or reduce it. 

To select by dragging 

To select an entire 
document 

To change a selection 
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To extend the selection, position the pointer at the end of the original 
selection. Hold down the Shift key and the mouse button, and click 
or drag until your selection is complete. 

r 6 File Edit Window Search Format Spell Macro 

Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

At major stops_along_the way, citizens^ o^Mpme_towns_and_ 

Deleting 

To delete a single 
character 

To remove something from a document, you delete it. You can select any 
amount of text and delete it with the Delete key, or the Cut or Clear com¬ 
mand from the Edit menu. You can also use the Delete key to delete single 
characters. You can undo a deletion with the Undo command from the Edit 

menu. 

You can delete a single character using the Delete key. 

[D Position the insertion point to the right of the character you want to 
delete. 

H] Press the Delete key. 

Works removes the character from your document. 
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You can delete a blank line to close up the space between two paragraphs. 

□ Position the insertion point at the left edge of the first line of the para¬ 
graph you want to move up. 

Insertion point 

6 File Edit Window Search Format Spell Macro 

=n — Rrticle (HIP) 

P-l 1 1 1 1 1 1 I1! 1 1 1 l i i Fi -L 1 1 1 1 1 1 1 1 1 1 1 1 1 l4! l i 1 i i i Fi i i 1 ■ i i l6i ■ ■ i » - > 
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The new Hilltop Climber will hit the slopes in the Great Alpine 
Race, sponsored by the Wheeler Bicycle Company. 

Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

_At major stops along the way, citizens of Alpine towns and 

CD Press the Delete key. 

Works deletes the blank line between the two paragraphs. 

The blank line is deleted. 

r , 
* File Edit UJindom Search Format Spell Macro 

Lii 1 » 1 l1! 1 1 1 I2 1 1 1 1 1 1 1 

= Article (HIP) =- 
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.The new Hilltop Climber will hit the slopes in the Great Alpine 
Wace, sponsored by the Wheeler Bicycle Company. 

/\ Teams from around the world will challenge each other on 
j the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

At major stops along the way, citizens of Alpine towns and 
citieswill turn out_to_greet__the racer s__with_f ire works displays. 

Insertion point 

To delete a blank line 
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To delete a selection 

To cut a selection 

You can press the Delete key twice to join two paragraphs into one. 

r A File Edit IDindotv Search Format Spell Macro 

To delete text, you first need to select it. 

0 Select whatever you want to delete. 

0 Press the Delete key or choose Cut or Clear from the Edit menu. 

Works removes the selection from your document. If you chose Cut, Works 
puts your selection on the Clipboard. 

Cutting, Copying, and Pasting 

The Clipboard is a place in your Macintosh’s memory that temporarily holds 
information. The Cut command takes a selection out of its current location 
and puts it on the Clipboard. The Copy command leaves the selection where 
it is, but also puts it on the Clipboard. The Paste command copies the con¬ 
tents of the Clipboard into a new location. 

You can cut a selection to move it to another location or to delete it entirely. 

To cut a selection: 

0 Select the information you want to cut. 

0 Choose Cut from the Edit menu. 

The selection remains on the Clipboard until you cut or copy another selec¬ 
tion. If you try to cut a bigger selection than Works has space for in 
memory, Works tells you so that you can select a smaller portion. 
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You can copy a selection to put the same information in other places. To copy a selection 
To copy a selection: 

0 Select the information you want to copy 

0 Choose Copy from the Edit menu. 

The selection remains on the Clipboard until you cut or copy another selec¬ 
tion If you try to copy too much, Works tells you so that you can select a 
smaller portion. 

You paste the contents of the Clipboard into a location you choose in a docu¬ 
ment. Once you have cut or copied a selection to the Clipboard, you can 
paste it into as many locations as you want. 

Each time you cut or copy information, the new selection replaces the old 
one on the Clipboard. So if you want to paste a selection that you’ve already 
cut or copied to the Clipboard, you should do so before cutting or cop vine 
anything else. 

To paste a selection: 

To paste a selection 

0 Cut or copy a selection to the Clipboard. 

Selected text 

6 File Edit lUindoui Search Format Spell Macro 

Article (HIP) 

11111111*11111 ■ l2j«»1111 l3i 111111 l4i. ■ i,., I5,,. i.., fiTTTTE 

IMS ftSi® UIlojjNsal] 
The new Hilltop Climber will hit the slopes in the Great Alpine 
Race, sponsored by the Wheeler Bicycle Company. 

Fireworks in the Alps 

_At major_stops_alon§_the wa^ citizens, of, Alpine_towns_and_ 

[H Move the insertion point to where you want to paste the text. 

0 Choose Paste from the Edit menu. 
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To find text 

mate 
The new Hilltop Climber will hit the slopes in the Great Alpine 
Race, sponsored by the Wheeler Bicycle Company. 

Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

JTeams from around the world will challenge each other on 
^Ithe tough mountain slopes of France, Switzerland, and ItaiV. 

|At major stops along the way, citizens of Alpine towns and 
cities will turn out to greet the racers with fireworks displays. 

St. Etienne 

affli-i-T! 

May 10 Lucerne May 28 

Pasted text 

You can repeat steps 2 and 3 as many times as you want. 

You can cut and paste text and drawings between documents, as well as 
within a document. For more information, see Chapter 20, “Moving Informa¬ 

tion Between the Tools.” 

Finding Text 

If you’re looking for a word or phrase, or want to move quickly to specific 
text within a document, the Word Processor can find it for you. 

With the Find command, Works finds all occurrences of the text you specify. 
This can include instances where the text is embedded in other text. For 
example, if you tell Works to find “able,” it will highlight those four charac- 
ters in “valuable.” If you want Works to ignore such occurrences, click the 
Match Whole Words Only option in the Find dialog box. 
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Worlcs ignores capitalization in the text you specify to be found. If you want 
to find only those occurrences of text where the capitalization is exactly as 
you type it in the text box, click the Check Upper/Lowercase option in the 
rind dialog box. 

To find text: 

0 Choose Find from the Search menu. 

Works asks you what you want to find. 

* File Edit Window pgfflTB Format Spell Macro 

Article (WP) 
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The new Hilltop Climber will hit the slopes in the Great Alpine Race, sponsored bu the 
Wheeler Bicycle Company. y 

Fr!no from aro“nd the *orld w111 challenge each other on the tough mountain slopes of 
France, Switzerland, and Italy. 

Fireworks in the Alps 

At major 3tops along the way, citizens of Alpi ne towns and cities will turn out to greet 
the racers with fireworks displays. y 

Find Ulhat: 

0® □ Match Whole Words Only □ Check Upper/Lowercase 

£ Cancel if find Sietit 

0 Type the characters you want to find. 

0 Click one or both of the options if you want. 

0 Click the Find Next button. 

Works highlights the first occurrence of the string of characters if it is in the 
document. You’ll see a message telling you if your string of characters isn’t 
there. 

If you want Works to look for another occurrence of the text you specified 
click the Find Next button again. 
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Replacing Text 

To replace a single 
selection 

You can replace selected text in a single location by typing over it. You can 
also have the Word Processor find a word or phrase for you in a document. 
Then, you can choose to replace every occurrence of it at once, or decide 

each case individually. 

To replace a single selection: 

\T\ Select the text that you want to replace. 

Select the text you want to replace. 

£ flip Friit iiiinrlnm Search Format Spell Macro 

,\ The new'gBnSXHEBSS will hit the slopes in the Great Alpine 
Race, sponsored by the Wheeler Bicycle Company. 
Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

At major stops along the way, citizens of Alpine towns and 
cities will turn out_to_greet_the racers_withJireworks disiDla^i . 

E Type the replacement text. 

The text you type replaces the text that you selected. 

r * File 

Type the new text. 

Edit Window Search Format Spell Macro 
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The new bicyclel will hit the slopes in the Great Alpine Race, 
sponsored by the Wheeler Bicycle Company. 
Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

At major stops along the way, citizens of Alpine towns and 
cities_will turn out_to_greet_the racers^ith_fireworks displays._]ji 

You can also replace the selection with the contents of the Clipboard by 
using the Paste command. 
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For more extensive search and replace actions, use the Replace command 
rrom the Search menu. The Replace command finds and replaces text You 
can replace all occurrences of the text, or you can selectively replace each 
occurrence, one at a time. As with the Find command, you can click options 
to specify whether Works searches for whole words only and for text with 
matching uppercase and lowercase letters. You can also select the text you 
want to replace before choosing the Replace command, then have it automati¬ 
cally appear in the Find What box. 

To replace text: 

0 Choose Replace from the Search menu. 

A dialog box appears asking you what you want to find and what you 
want to replace it with. 

0 Type the text you want to find. 

0 Press the Tab key to move the insertion point into the second box, and 
type the replacement text. 

0 Click one or both of the options if you want. 

The word “bicycle” will be replaced 
with the words “Mountain Wheeler". 

File Edit Window I | Format Spell Macro 

Article (WP) 
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[KM 
The new bicycle will hit the slopes in the Great Alpine Race, sponsored by the Wheeler 
Bicycle Corieany. 

Teams from around the world will challenge each other on the the tough mountain slopes 
of France, Switzerland, and Italy. 

Fireworks inVhe Alps 

At major Stops along thy wau. Citizens of A1 pi ne tnwns arid nties Will turn out to greet 

Find What: bicycle 

Replace With: Mountain WheelerJ 

0® □ Match Whole Words Only ^ Check Upper/Lowercase 

[ Cancel ~j [Replace All] [Replace, then Find] Replace 

To find and 
replace text 

0 Click one of the buttons to either start or cancel the search. 
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To change the font 

Sometimes a word or phrase occurs often, but you want to replace it in only 
one place. Use the Find Next button to find successive occurrences of the 
specified text until you see the one you want to replace. Or use the Find Next 
button to verify each occurrence of the specified text before you replace it. 
After each replacement, you can look for another occurrence. 

There are several other buttons in the Replace dialog box. The small buttons 
above the Cancel button insert tabs and return characters into the Find What 
and Replace With text boxes. The other buttons tell Works to automatically 
replace all occurrences of the specified text, replace one occurrence and find 
the next, or replace only the occurrence you’ve just found. 

For more information on the options and buttons in the Replace dialog box, 
see “Replace” in Chapter 5. 

Changing the Appearance of Text 

You can change the font, type size, type style, and color to add emphasis to 
or increase the impact of parts of your text. The font (such as Boston) is the 
design of the characters. Each font can have different type sizes (such as 10 
point) and type styles (such as bold). Each character can have a different 
color. If you have a color monitor, you’ll be able to see the colors; if you 
have a color printer, you’ll be able to print them. You can change these attri¬ 
butes as you’re typing, or you can make a selection and then change them for 

the entire selection. 

To change the font of existing text: 

HI Select the text you want to change. 

H] Choose Font from the Format menu and continue holding down the 
mouse button. 
Another menu appears to the right of the Font command. 

m Choose the font you want for your selection. 

The available fonts are those that appear in your System file. Some fonts, 
like Geneva, Monaco, and New York, are designed specifically for use with 
the Image Writer. Although they appear in your System file, not all fonts are 
recommended for the ImageWriter. You can add and remove fonts and font 
sizes on your disk using the Font/DA Mover program that comes on your 
Macintosh System disk. For more information, see your Macintosh owner’s 

guide. 
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Different type styles can change the 
italic or some other style. Different 
parts of a document. 

way your text looks, making it bold or 
type sizes and colors can add emphasis to 

To change the size, style, or color of existing text: 

0 Select the text you want to change. 

0 Choose Size, Style, or Color from the Format menu and continue holding 
down the mouse button. 6 

Another menu appears to the right of the command. 

0 Choose the attributes you want for your selection. 

If you choose Size, and then choose Other, you can type any integer from 
4 up to 72 points. 

Note With ImageWriter printers, not all sizes are recommended for all 
fonts. The recommended font sizes are those that are installed in your System 

To change the type 
size, style, or color 

Recommended font sizes for the selected text appear in outline type under the 
Size command. Other sizes appear in normal type. If a size is not recom¬ 
mended, you can still use it, but your text displays and prints somewhat 
rougher than text in the recommended sizes. 

With PostScript LaserWriter printers, although text may look jagged on the 
screen, the printer scales any size to print perfectly. 

To change the font, size, style, or color while you’re typing: 

0 Select the text attributes that you want to use by choosing Font, Size, 
Style, or Color from the Format menu. 

Continue holding down the mouse button. Another menu appears to the 
right of the command. 

0 Choose the desired font, size, style, or color. 
0 Start typing. 

Everything you type will have the attributes you chose until you change them 
again. If you move the insertion point to text with different font attributes 
whatever you type will appear with those attributes. 

To change the text’s 
appearance while 
typing 
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You can also change the type style as you type by using the Command + key 
equivalents displayed in the Style menu. 

Plain 10 point Boston font is the standard Word Processor typeface. 
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4 Formatting a Document 

The format of a document is how it appears on your screen or on paper With 
Works, you can have the Word Processor do much of the formatting while 
you type. For example, you can specify that the first line of each paragraph 
should be indented half an inch. The Word Processor will then take care of 
the indenting —all you do is type and press the Return key at the end of each 
paragraph. 

This chapter shows you how to: 

■ Change spacing. 

■ Change the justification of text. 

■ Use the ruler to adjust indentation. 

■ Set tabs and make columns and tables. 

■ Copy a format. 

■ Format and print a document with headers and footers. 

You can have as many different formats as you want within a single docu¬ 
ment, but each format you choose will affect an entire paragraph. For exam¬ 
ple, if you double-space most of a report, but want to single-space and indent 
quotations, make the quotations separate paragraphs. Once you’ve set up a 
format, you can copy it whenever you want to use the identical format 

Changing Spacing 

The Word Processor lets you choose between single, one-and-a-half, and 
double spacing. One-and-a-half and double spacing are useful when you want 
to print documents for others to review. You can choose six lines per inch 
along with single, one-and-a-half, and double spacing. Six lines per inch is 
useful for printing on commercially prepared forms and mailing labels. 
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To Change spacing To change the spacing in a document: 

□ Position the insertion point in the paragraph you want to change, or select 

one or more paragraphs. 
Use the Select All command from the Edit menu if you want to select the 

entire document. 
[2] Choose Spacing from the Format menu and continue holding down the 

mouse button. 
Another menu appears to the right of the Spacing command. 

[3] Choose the spacing you want. 

1-1/2 spacing 
Single spacing 

NJjThe new Mountain Wheeler will hit the slopes in the Great Alpine 
(Race, sponsored by the Wheeler Bicycle Company. 

\ /Teams from around the world will challenge each other on the 

Itough mountain slopes of France, Switzerland, and Italy. 

/ 
/At rr 

\will 

At major stops along the way, citizens of Alpine towns and cities 

turn out to greet the racers with fireworks displays. 

Double spacing 

The spacing you set remains in effect until you change it. Because spacing is 
associated with individual paragraphs, if you move the insertion point to a 
paragraph with different spacing, the menu will show whatever spacing is 
associated with that paragraph. 

Changing Justification 

Justification refers to how text is spaced within a line. Most typewriters give 
you left-justified text. Most newspapers and magazines are fully justified (so 
that text in columns lines up evenly along both edges). The Word Processor 
lets you choose between left, right, and full justification. You can also center 
text, such as titles, captions, or lines of poetry. 
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When you create a new document, your text is automatically left-justified. 
To change the justification: 

□ Position the insertion point in the paragraph whose justification you want 
to change, or select one or more paragraphs. 

Use the Select All command from the Edit menu if you want to select the 
entire document. 

Choose Justification from the Format menu and continue holding down 
the mouse button. 6 

Another menu appears to the right of the Justification command. 
Choose the justification you want. 

IE 

IE 

Works changes the justification for the paragraph that 
point or for the paragraphs you’ve selected. 

contains the insertion 

To change 
justification 

Left 
Right 

/ 

Window Search Format Spell Macro 

Article (HIP) j 

\ /Wheeler President Hiram Albert Wheeler is extremely pleased 
/by the new bike his company has produced. From his home 
Jin \vheeling, West Virginia, he said: 

"This is a great moment in my life. When I was a young 
man the Wheeler Flying Eagle took the world by storm. Now 
the Hilltop Climber will do the same. I'm taking my summer 

vacation in the Canadian Rockies—with my own Hilltop 
Climber!" 

/ 
Eveiy major television network will cover the race in somdj 
det-aii. Since all the bicycles in the race will be Hilltop! 
Climbers, we expect to have a lot of free product exposureK 
from the race. I \ 

m M 
Centered Justified 

The justification you set remains in effect until you change it. Because justifi¬ 
cation is associated with individual paragraphs, if you move the insertion 
point to a paragraph with different justification, the menu will show whatever 
justification is associated with that paragraph. 
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To see the ruler 

To hide the ruler 

The Ruler 

You use the ruler to set indentation and tab stops. Ruler settings apply to the 
first paragraph in a selection or the paragraph containing the insertion point. 
The ruler comes with standard settings indicated by markers. When you 

create a new document, the ruler is already showing. 

If the ruler isn’t showing: 

© Choose Show Ruler from the Format menu. 

The ruler appears at the top of the window. 

Both the first line indent Right indent marker 
marker (•) and the left indent 
marker 0) are here. 

As you move the insertion point to paragraphs with different settings, you 
can see the markers change in the ruler. When you adjust settings with more 
than one paragraph selected, your new settings affect the entire selection. 

If you’d like to see more of what you’re typing, you can make the ruler 

disappear. 

H Choose Hide Ruler from the Format menu. 

Indenting Text 

The Word Processor lets you set indentation on both the left and the right. 
You can set one indentation for the first line of a paragraph, and the same or 
a different indentation for the rest of the paragraph. If you indent only the 
first line of a paragraph, you get the standard paragraphs that you see in 
books. If you indent from both the left and right margins, you set off a por¬ 

tion of text for emphasis. 

If you indent only the lines after the first line of a paragraph, you have what 
is called “hanging indentation.” This lets you prepare a standard bibliogra¬ 
phy, for example, or itemize points effectively with numbers or bullets. 
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You can automatically indent the first line of every paragraph, so that you 
don’t have to press the Tab key each time you start a new paragraph. 

□ Choose Show Ruler from the Format menu if the ruler isn’t showing. 
The ruler appears at the top of the window. 

GO Drag the first line indent marker along the ruler to the position you want. 

To see the first line indent marker ( ■ ), drag the > marker at the left 
edge of the ruler. 

As you type, the first line of each paragraph will automatically be indented. 

You can also use this method on previously typed text. Just select the 
paragraph(s) and follow the procedure above. To change every paragraph in 
the document use the Select All command from the Edit menu. The first line 
of each selected paragraph changes as soon as you release the button. 

Only the first line of the paragraph is indented. 

r « 

§□= 

First line indent marker (•) 

File Edit Window Search Format Spell Macro 'I 
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MS'S 
The new Hilltop (Climber will hit the slopes in the Great 

Alpine Race, sponsored by the Wheeler Bicycle Company 

Teams from around the world will challenge each other on 
the tough mountain slopes of France, Switzerland, and Italy. 

Fireworks in the Alps 

_At_rnajor j>tq£_s ^lc^^h^\^y^citizens_pf_Aj£ine towns_and_ 

You can set up hanging indentation by indenting the lines following the first 
line of a paragraph. You can do this either before you begin to type or on 
previously typed text that you select. 

□ Choose Show Ruler from the Format menu if the ruler isn’t showing. 

0 With both indent markers at the left edge of the ruler, move the pointer to 
the top of the markers. 

0 Drag the left indent marker along the ruler to the position you want. 

The first line indent marker remains at the left margin. 

To indent the first line 

To set hanging 
indentation 
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To indent an entire 
paragraph 

Setting margins 

To set up hanging indentation, put the first line indent 
marker (•) to the left of the left indent marker OJ. 

le Edit Window Search Format Spell Macro 

--=i Article (HIP) 'HE 

1°/,, i & 
• ► i 

mate 
/The new Hilltop Climber will hit the slopes in the Great Alpine 
' Race, sponsored by the Wheeler Bicycle Company. 

A. Teams from around the world will challenge each other 
' on the tough mountain slopes of France, Switzerland, 

and Italy. 

y2. At major stops along the way, citizens of Alpine towns 
' and cities wil turn out to greet the racers with fireworks 

displays. 

These three paragraphs all have hanging indentation. 

You can set an indentation that applies to an entire paragraph. You can do 
this either before you begin to type or on previously typed text that you 
select. 

0 Choose Show Ruler from the Format menu if the ruler isn’t showing. 

0 Drag the first line indent marker to the position you want. 

0 Drag the left indent marker to the same position. 

Setting Margins 

Indentations and margins are not the same in Works. When you set an inden¬ 
tation, that space is added to whatever margin you set with the Page Setup 
command from the File menu. For example, if the left margin is 1" and the 
left indent is .5", the text will begin 1.5" from the left edge of the paper. 

Indentation affects text in the selected paragraph(s) or the paragraph contain¬ 
ing the insertion point. You indent to move text in from the margins, which 
you set with the Page Setup command. For instructions on setting margins, 
see “Printing a Document” in Chapter 1. The margins you set apply to the 
entire document. 

Note If the side margins you set conflict with the position of the indent 
markers, Works changes the right indent marker to a hollow triangle to alert 
you to the problem. 
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Setting and Using Tabs 

Tabs let you skip across the page by measured amounts. Tabs are measured 
in inches rather than in number of characters, so that text lines up no matter 
what font, size, or style of type you’re using. 

If you want to type in two or more columns, you can set a left tab stop for 
each column after the first one, so that you don’t have to type spaces to get 
to the proper location. Right tab stops help you align columns of numbers 
along a single digit, while decimal tab stops align numbers along their 
decimal point. Center tab stops center text within a column. 

Setting Tab Stops 

In a new Word Processor document, tab stops are preset at every half inch on 
the ruler, but you can’t see them. You can remove these by setting your own. 
When you set a tab stop, all preset tab stops to the left of the new one are 
lost. 

You can set different tab stops for each paragraph you want to modify. 

To see the tab stops on the ruler that correspond to a particular paragraph, 
select the paragraph containing tab stops. Works has four types of tab stops: 
left, right, decimal, and center. 

Pressing the Tab key moves the insertion point to the right. When you move 
to a left tab stop, that tab stop determines the left edge of the next text you 
type. 

Right tab stops anchor the right edge of text. Decimal tab stops align 
numbers along their decimal points. Right and decimal tabs are most useful 
for aligning columns of numbers, so that you can type and read them easily. 

Center tab stops center text within your document and are useful for 
headings. 

To set tab stops: 

□ Choose Show Ruler from the Format menu if the ruler isn’t showing. 

H] Position the pointer in the blank area below the ruler markings at each 
place you want to set a tab stop. Click once for a left tab stop, twice for 
a right tab stop, three times for a decimal tab stop, and four times for a 
center tab stop. 

To change a tab stop, continue clicking it until it is replaced by the tab stop 
you want. 

To set tab stops 
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To move or remove a 
tab stop 

To make a table 

r 6 File Edit Window 

Center tab stop 

Search Format Spell 
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Right tab stop Decimal tab stop 

If you want to change a tab stop’s location, or just want to remove it, you 
can drag it. 

To move a tab stop: 

0 Drag the tab stop to a new location. 

When you release the mouse button, the text in the selected paragraph(s) or 
the paragraph containing the insertion point realigns under the new tab stop. 

To remove a tab stop: 

[■] Drag the tab stop down into the text. 

When you release the mouse button, the tab stop disappears. 

Using Tabs for Tables 

By setting a series of tab stops, you can make a table. You can use tables to 
list facts or figures in several columns. 

To make a table: 

0 Set a left tab stop for each column of the table. 

0 Move the insertion point to the left edge of the screen and press the Tab 
key. 

Works aligns the insertion point with the first tab stop. 

0 Type the first entry for the first line. 

0 Press the Tab key to move to the second column and then type the next 
entry. 

0 When you finish with the last entry of the first line, press the Return key. 
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Copying a Format 

If you have different sections throughout a document that require the same 
format, you can set the format for one paragraph and then copy that format to 
other paragraphs. 

The formats you can copy are justification, indentation, tabs, and spacing. 

To copy a format: 

□ Position the insertion point anywhere in the paragraph whose format you 
want to copy. 

0 Choose Copy Format from the Format menu. 

0 Move the insertion point to anywhere within another paragraph. 

0 Choose Paste Format from the Format menu. 

Works changes the format in the second paragraph to match that of the first. 

You can repeat steps 3 and 4 to copy the same format to as many paragraphs 
as you want. If you want to copy a format to several adjacent paragraphs, 
select them all before pasting the format. 

Formatting an Entire Document 

Some formatting options work on the printed document as a whole. 

■ You can set manual page breaks to keep related information together, or 
unrelated information apart. 

■ You can repeat information about a document, such as the title or date, at 
the top and bottom of every page with headers and footers. 

■ You can include automatic page numbers in headers or footers. 

■ You can specify a title page at the beginning of a document on which 
headers and footers don’t print. 

Page Breaks 

Works automatically sets page breaks in all documents. An automatic page 
break appears as a dotted line on your screen. The dotted line does not 
print — instead, it signals Works to begin printing on a new page. You can 
leave page breaks where they appear, or change their location with the For¬ 
mat menu. 

To copy a format 
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To set a page break 

To remove a manual 
page break 

You change the location of page breaks by inserting manual page breaks in 
your document. You can identify manual page breaks by their dashed, rather 
than dotted, lines. 

To set a manual page break: 

[7] Move the insertion point to the line you want to be at the top of the page. 

[2] Choose Insert Page Break from the Format menu, or press Shift + Enter. 

A dashed line appears just above the text containing the insertion point. 
When you set a manual page break, Works automatically repaginates the 
entire document from that point on. 

Manual page break indicator 
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taking my summer vacation in the Canadian Rockies--with my own Hilltop 
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Every major television network will cover the race in some detail. Since all the_ 

Insertion point 

If you decide not to break a page at a particular spot, you can remove the 
manual page break. 

To remove a manual page break: 

[7] Click anywhere in the line just below the dashed line. 

[2] Choose Remove Page Break from the Format menu. 

You cannot remove an automatic page break; however, you can force Works 
to adjust the position of automatic page breaks by inserting manual page 
breaks so that Works repaginates the document. 
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Headers and Footers 

Headers and footers contain information that helps you to identify a docu¬ 
ment. They are not displayed on the screen, but can be viewed before print¬ 
ing by choosing the Print Preview option in the File menu’s Print dialog box. 

Headers and footers often contain the title of the document, the name of the 
author, and the date. Or, a header might center a key word, such as “Confi¬ 
dential,” at the top of every page. 

You can create headers and footers in the Word Processor in any font, size, 
or color. Headers and footers can have styles; text aligned at the left, right, 
or center; and can include page numbers, too. 

To tell Works to include a style, the date, time, or page number, or to align 
text in a particular way, you use a set of formatting commands. For a list of 
these commands, see “Page Setup” in Chapter 2. 

To set a header or footer: 

0 Choose Page Setup from the File menu. 

Two text boxes in which you can type header and footer information 
appear in the lower half of the Page Setup dialog box. The insertion point 
is in the Header box. 

0 Type the information for the header, including any formatting commands, 
such as &L or &D. 

0 Move the insertion point to the Footer box and type the information for 
the footer. 

0 Click the OK button or press the Return key. 

To set a header 
or footer 

When you print the document, the formatting commands will not appear, but 
Works will align the text as you specified, and include the style, page 
number, date, and time, if you included them. 
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To change the font, 
size, or color of a 
header or footer 

In the Word Processor, but not in other Works tools, you can use any avail¬ 
able font, size, or color for header and footer text. 

To change the font, size, or color of a header and footer: 

0 Choose Page Setup from the File menu. 

0 Choose the attributes you want to use from the Font, Size, or Color 
menus. 
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0 Click the OK button or press the Return key. 

You’ll be able to see the changes on the screen if you choose the Print Pre¬ 
view option in the File menu’s Print dialog box. You can also check the set¬ 
tings by seeing which items are checked in the menus. 

When you print your document, the header and footer will be in the font and 
size you’ve selected. If you have a color printer, the header and footer will 
print in the color you’ve selected. You can select only one font, size, and 
color for your header and footer. Changing the font for the footer, for exam¬ 
ple, also changes the font for the header. If you haven’t chosen a font, size, 
or color for the header and footer, they will print in Works’ preset font, size, 
and color (Boston, 10 point, black). 

Setting Consecutive Page Numbers 

You may want to break a very large project into parts. You’ll find it easier 
to switch between smaller documents than to move around in one very 
large document. You can give each part its own header and footer for 
identification. 
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In the Word Processor, but not in the other tools, you can print a series of 
documents that each start with a beginning page number that you specify. 

H From the Word Processor, choose Print from the File menu to print the 
first document in the series. 

0 Activate the next document you want to print. 

0 Choose Set Page # from the Format menu. 

0 In the dialog box, set the starting page number for the next document in 
the series. (Just add one to the last page number of the document you just 
printed.) 

0 Choose Print from the File menu to print the second document in the 
series. 

Repeat steps 2 through 5 for each succeeding document in the series. 

Setting a Title Page 

You may not want to have a header and footer on the first page of a docu¬ 
ment. By designating the document as having a title page, you tell Works to 
wait until the second page before printing any headers and footers. 

To set a title page: 

® Choose Title Page from the Format menu. 

Works starts the header and footer on the second page. It does not change the 
format of the first page in any other way. 

To set consecutive 
page numbers 

To set a title page 





5 Word Processor 
Command Reference 

The Apple, File, Window, and Macro menus are identical for all Microsoft 
Works tools. For information on these menus, see Chapter 2, “Common 
Tasks Command Reference.” 

This chapter discusses all the shaded commands shown below. The Print 
Merge command is included here because you use it for a Word Processor 
document. 

File 

New... 
Open... §§0 

Close 
Close Rll... 

a§W 

Saue 
Saue Rs... 
Delete... 

aes 

Make Works Desktop... 

Page Setup... 
Print... 
Print Window 
Eject Page 

asp 

Print Merge... 

Quit m 

Undo a§z 

Cut a§H 
Copy aec 
Paste aeu 
Clear 
Select Rll 

Draw On a§j 

Prepare to Merge... 
Show Field Names 
Multiple Labels 

Find... 9€F 
Replace... a§R 

Go To Page %G 

Format 
Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format a$K 
Paste Format &V 

Justification ► 
Spacing ► 

Insert Page Break 
Title Page 
Set Page # ... 

Spell 

Correct Spelling... 

Options... 
Dictionary... 
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You can invoke some Works commands from the keyboard, as well as by 
using the mouse. The available Command + key combinations are shown on 
the menus and in Appendix D. 

An alphabetical list of commands appears in the index under “Command.” 

Print Merge 

New... 
Open... 

Close 
Close Rll... 

#W 

Saue 
Saue Rs... 
Delete... 

Make Works Desktop... 

Page Setup... 
Print... 
Print Window 
Eject Page 

3§P 

Print Merge... 

Quit m 

The File Menu 

The File menu is described in detail in Chapter 2, “Common Tasks Com¬ 
mand Reference.” The Print Merge command is included here because it 
applies only to the Word Processor. 

Print Merge 

The Print Merge command is available only for Word Processor documents 
with at least one placeholder entered using the Prepare to Merge command. 

After all placeholders have been entered with the Prepare to Merge command, 
the merging process begins when you choose Print Merge. 

When you choose Print Merge, Works displays the Print dialog box. Choose 
Print Merge and select the Print Preview option to view all your merge infor¬ 
mation before you print. 

If a Database document you specified with Prepare to Merge is not open, or 
if a field name you specified with Prepare to Merge cannot be found, Works 
displays an alert box and cancels the Print Merge operation. 

You can use Record Selection rules in the Database if you want to merge 
with only part of your Database document. 

For more information, see “Prepare to Merge” in this chapter, and Chapter 
21, “Merging: Creating Mailing Labels, Form Letters, and Forms.” 

The Edit Menu 

The first six commands in the Edit menu are common to all Works tools. For 
information on these commands and the Draw On command, see “The Edit 
Menu” in Chapter 2. 

This section explains additional Edit menu commands that are available in the 
Word Processor. 
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Prepare to Merge Prepare to Merge 

The Prepare to Merge command specifies information to be merged into a 
Word Processor document from a Database document. To print the merged 
information, use the Print Merge command from the File menu. 

Before you choose Prepare to Merge, be sure that the Database document 
from which you want to merge data is open. When you choose Prepare to 
Merge, Works displays a dialog box that asks you to select the Database 
document and the field from which the data is to be taken. 

Prepare to Merge: 

Select Merge Data Base: Select Merge Field: 

First Name a 
Last Name C 
Title II 
Address 
City 
State 
Zip 
Home Phone 
UJork Phone 5 

Edit 

Undo 38Z 

Cut 3§H 
Copg &C 
Paste :#:Ll 
Clear 
Select All 

Draw On 3§J 

Prepare to Merge... *M 
Show Field Names 
Multiple Labels 

Select Merge Data Base From the list of Database documents in the list 
box on the left, select the document from which the merge data is to be 
taken. 

The field names of the Database document you select will then appear in the 
list box on the right. 

Select Merge Field Select the field name from which the merge data is to 
be taken. 

When you click the Merge button, a placeholder — a rectangle containing the 
Database document name and the field name — is inserted into your Word 
Processor document at the insertion point. 

If you close a specified Database document, delete a specified field, or 
change a specified field name, Works displays a message — “NOT ON 
DESKTOP” or “FIELD NOT IN DB” — in the appropriate placeholders. 
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Show Field Data 
Show Field Names 

Edit 

Undo 3§Z 

Cut •m 

Copy &c 
Paste m\ 

Clear 
Select Rll 

Drain On 

Prepare to Merge... 
Show Field Names 

| Multiple Labels ] 

Show Field Data/Show Field Names 

The Show Field Data command displays the contents of the fields in the 
record to be merged into a Word Processor document just as they will be 
shown in the final document. If no record is selected, Show Field Data 
displays the contents of the first record. If a record is selected, Show Field 
Data displays the contents of that record. 

When you choose Show Field Data, the menu item changes to Show Field 
Names. 

When you choose Show Field Names, Works again displays the placeholders. 

Multiple Labels Multiple Labels 
Edit 

Undo §8Z 

Cut WM 

Copy 3§C 
Paste 
Clear 
Select Rll 

WA\ 

Draw On 

Prepare to Merge... 
Show Field Names 

§§M 

Multiple Labels 

The Multiple Labels command lets you print a Word Processor document that 
contains more than one record per page of merged information from a Data¬ 
base document. This command allows you to print multiple labels (two- and 
three-across), as well as multi-column lists. 

Before you choose Multiple Labels, your document must contain at least one 
placeholder, and the Database document from which you want to merge data 
must be open. To insert a placeholder, use the Prepare to Merge command in 
the Edit menu. To print the information, use the Print Merge command in the 
File menu. 

For complete information on creating a merge document for multiple labels, 
see “Creating Mailing Labels” in Chapter 21. 

The Search Menu 

Find 

The Find command searches for text that you specify. 

Replace... 9§R 

Go To Page #... 98G 
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Find UJhat: l 
0® i □ Match Whole Words Only □ Check Upper/Louiercase 

( Cancel ] | FindNeat | 

Find What Type the text you want to search for. This can be as short as a 
single character or as long as 80 characters. You can search for any alpha¬ 
numeric characters and all symbols on the Macintosh keyboard, as well as tab 
stops and carriage returns. 

If you select any occurrence of the text before you choose Find, it will 
appear in the Find What box. 

Tab (0) Click this button to find tab stops. Clicking the tab stop button 
inserts a tab stop character in front of the insertion point in the Find What or 
Replace With text box. 

Return character (®) Click this button to find return characters. Clicking 
the return character button inserts a return character in front of the insertion 
point in the Find What or Replace With text box. 

Match Whole Words Only Click this option to find only those 
occurrences of the text that have leading and trailing word breaks (spaces, 
punctuation, and tabs). This tells Works to find only those occurrences of the 
specified text not embedded in other text. 

Check Upper/Lowercase Click this option to find only those occurrences 
of the text having uppercase and lowercase characters that match what you 
type. 

When you click the Find Next button, Works finds and selects the first 
occurrence of the specified text after the insertion point. 

To find additional occurrences of the specified text, click the Find Next but¬ 
ton after each occurrence is selected. As you continue clicking the Find Next 
button, the search continues to the end of the document, and then goes to the 
beginning and searches forward to the point at which the search began. 

To cancel the search at any time, click the Cancel button. 

If Works cannot find the specified text in the document, it displays an alert 
box. 

The next time you choose Find, the last text you specified is selected in the 
Find What text box unless different text is selected in the document. If that is 
the text you want, click the Find Next button to start the search. Otherwise, 
type the new text you want to search for. 
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Replace 

Search 

Replace 

The Replace command finds and replaces specified text — either selective 
occurrences of the text or all occurrences. 

Find What: i 
Replace With: 

CD® □ Match Whole Words Only □ Check Upper/Lowercase 

( Cancel ] [Replace Fill] [Replace, then Find] ( Replace ] [[ Hnd Ne«1 J 

Find What Type the text you want to search for. This can be as short as a 
single character or as long as 80 characters. You can search for any alpha¬ 
numeric characters and all symbols on the Macintosh keyboard, as well as tab 
stops and return characters. 

If you select any occurrence of the text before you choose Replace, it will 
appear in the Find What box. 

Replace With Type the replacement text, up to 80 characters. 

Tab (0) Click this button to find or replace tab stops. Clicking the tab stop 
button inserts a tab stop character in front of the insertion point in the Find 
What or Replace With text box. 

Return character ((3) Click this button to find or replace return charac¬ 
ters. Clicking the return character button inserts a return character in front of 
the insertion point in the Find What or Replace With text box. 

Match Whole Words Only Click this option to find only those 
occurrences of the text that have leading and trailing word breaks (spaces, 
punctuation, and tabs). This tells Works to search for only those occurrences 
of the specified text not embedded in other text. 

Check Upper/Lowercase Click this option to find only those occurrences 
of the text having uppercase and lowercase characters that match what you 
type. 

Works starts the search at the insertion point. The search continues to the end 
of the document, and then goes to the beginning and searches forward to the 
point at which the search began. 

Replace All Click this button to replace all occurrences of the specified 
text in the document. 

Replace, Then Find Click this button to replace the selected text and then 
go to the next occurrence of the specified text. Works selects the next 
occurrence, but does not replace it. 
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Replace Click this button to replace the current selection only. 

Find Next Click this button either to start a search or, if an occurrence of 
the specified text has been found, to leave it as is and search for the next 
occurrence. 

To cancel the search at any time, click the Cancel button. 

As you selectively find and replace text, Works scrolls automatically to the 
next occurrence of the specified text. If Works cannot find the specified text 
in the document, it displays an alert box. 

The next time you choose Replace, the last text you specified is selected in 
the Find What box unless different text is selected in the document. If that is 
the text you want, click a button to start the search. Otherwise, type the new 
text you want to search for. 

Go To Page # Go To Page # 

The Go To Page # command scrolls a document to the page you specify and 
places the insertion point at the beginning of the first line. 

Go To Page #: 

— 

( Cancel ] 
^ qk i 

Search 

Find... §€F 
Replace... 38R 

Works proposes the page number currently displayed in the scroll box. Type 
the number of the page you want to find, then click the OK button. 

The Format Menu 

Three commands — Font, Size, and Color — are common to all Works tools. 
For information on these commands, see “The Format Menu” in Chapter 2. 
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Show Ruler 
Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format 
Paste Format 

Justification ► 
Spacing ► 

Insert Page Break 
Title Page 
Set Page # ... 

Show Ruler/Hide Ruler 

The Show Ruler command displays the ruler. 

r « File Edit Window Search Format Spell Macro 

l°i i i i ... i1.,. i 
12 

i i i 1 l l l 

■ Article (lilP) 

1 i i i l3i i i 1 i i i l4i i i 1 ' 1115< i ■ i 
16 

I I I ll l l 

■01 

l_L_J£ 
> ◄ 

The ruler is calibrated in inches. The indent markers and tab stops reflect the 
settings for either the first paragraph of a selection or the paragraph contain¬ 
ing the insertion point. If you make a change to the indent markers or tab 
stops on the ruler, the change applies to all of the selected paragraphs or the 
paragraph containing the insertion point. You can move indent markers, and 
insert, delete, and move tab stops on the ruler. 

When the ruler is displayed on the screen, the Show Ruler command on the 
menu changes to Hide Ruler. Hide Ruler allows you to display approximately 
two additional lines of text in the document window. 

The ruler displays the following information about how a paragraph is 
formatted: 

■ The amount of space the first line is indented from the left margin. This 
is indicated by a small solid box. 

■ The amount of space all subsequent lines are indented from the left mar¬ 
gin. This is indicated by a small solid triangle pointing right. 

■ The amount of space all lines of a paragraph are indented from the right 
margin. This is indicated by a small solid triangle pointing left. 

Note Margins are defined and displayed using the Page Setup command 
from the File menu. 

■ The positions of left tab stops. Initially, there are left tab stops every half 
inch. When you insert a new tab stop, all preset tabs to the left of the 
new tab stop are lost. To insert a left tab stop, point to a position in the 
blank area below the ruler markings and click. 

■ The position of right, decimal, and center tab stops. Initially, there are no 
right, decimal, or center tab stops. To insert a tab stop, point to a posi¬ 
tion in the blank area below the ruler markings. Click twice for a right 
tab stop, click three times for a decimal tab stop, and click four times for 
a center tab stop. To change a tab stop, continue clicking until the tab 
stop you want appears. To delete a tab stop, drag it down into the text. 
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Style 

The Style command leads to another menu which lists style commands. You 
use this menu to choose type styles such as Bold, Italic, and Underline. The 
checkmarks on the menu indicate those styles currently in effect. 

You can check multiple styles, such as Bold and Underline. When you 
choose Normal, all other style options are cancelled. 

Some of the Style commands are illustrated below. 

* File Edit Window Search Format Spell Macro 

Outline Underline Italic Superscript 
Bold Plain Shadow 

Style 

Hide Ruler 

Font ^ 
Size ► 

✓Normal 9§N 
Color ^ Bold 3SB 

Italic % 1 
Underline &U 

(DfflQOQffiS 

gnacDgtzg 
Superscript 
Subscript 

Copy Format 9§K 
Paste Format 9€V 

Justification ► 
Spacing ► 

Insert Page Break 
Title Page 
Set Page # ... 

Copy Format/Paste Format 

The Copy Format and Paste Format commands copy the format of one para¬ 
graph to another paragraph or to a range of paragraphs. 

To copy a format, position the insertion point anywhere in the paragraph 
whose format you want to copy, then choose Copy Format. 

To paste the format, position the insertion point anywhere in the paragraph 
you want to reformat, or select a range of paragraphs. Then choose Paste 
Format. 

The following formatting information is copied with Copy Format and Paste 
Format: 

■ Left and right indents 

■ First line indent (of a paragraph) 

■ Left, right, decimal, and center tab stops 

■ Spacing 

■ Justification 

Copy Format 
Paste Format 

Format 
Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format MK 

Paste Format &Y 

Justification ► 
Spacing ► 

Insert Page Break 
Title Page 

1 Set Page # ... I 
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Justification 

Format 

| Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format §8K 

Paste Format 3§Y 

Justification 

Spacing ► 

Insert Page Break 
Title Page 
Set Page # ... 

✓Left 
Center 
Right 
Justified 

Spacing 

Justification 

The Justification command leads to another menu which lists justification 
commands. You use this menu to choose the alignment of text between the 
indent markers. You can justify the paragraph containing the insertion point, 
or select several paragraphs before justifying them. 

The Left command aligns all lines with the left indent marker. 

The Center command centers each line between the indent markers. 

The Right command aligns each line with the right indent marker. 

The Justified command aligns the beginning of each line with the left indent 
marker and the end of each line with the right indent marker. Spaces between 
complete words in each line are adjusted to space text evenly throughout the 
line. 

For all justification choices, only complete words are placed on a line. 

Spacing 

Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format 
Paste Format 

Justification ► 
✓Single 

1 1/2 Spaces 
Insert Page Break Double 

Title Page 
Set Page # ... 6 Lines per inch 

The Spacing command leads to another menu which lists commands for the 
line spacing in a document. When you choose one of the spacing commands, 
Works adjusts the selected paragraphs, or the paragraph containing the inser¬ 
tion point, to the spacing you choose. 

Single provides a single space between lines; 1 1/2 Spaces provides a space 
and a half between lines; Double provides two spaces between lines. Six lines 
per inch is used along with single, one-and-a-half, or double spacing, and is 
the standard spacing for many pre-printed forms. 

Insert Page Break 
Remove Page Break 

Format 

| Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format 
Paste Format 

Justification ► 
Spacing ► 
r.. 

Insert Page Break 
Title Page 

Insert Page Break/Remove Page Break 

The Insert Page Break command inserts manual page breaks into a document. 

With Works, pagination is automatic. An automatic page break appears as a 
dotted line. The Insert Page Break command, however, allows you to manu¬ 
ally insert page breaks in places other than where pages would automatically 
break. 

When you choose Insert Page Break, a dashed line appears above the inser¬ 
tion point to indicate the page separation. When you insert a manual page 
break, Works automatically repaginates the entire document, starting at that 
point. 

When you put the insertion point in the line following a manual page break, 
the command on the menu changes to Remove Page Break. If you choose 
this command, Works removes the manual page break indicator. 



Chapter 5 Word Processor Command Reference 121 

Title Page 

The Title Page command tells Works not to print a header or footer on the 
first page of a document. It does not affect the formatting of existing text on 
the first page. 

When you choose Title Page, the command appears with a checkmark beside 
it on the menu. 

To print a header and footer on the first page, choose Title Page when it is 
checked. Works removes the checkmark. 

Set Page # 

If you specify in the Page Setup dialog box that page numbers are to be 
included in a header or footer box, the Set Page # command tells Works 
what number to begin numbering pages with. 

Set Starting Page #: 

m 

[ Cancel ] »■< 

In the Set Starting Page # box, type the page number for the first printed 
page. Works proposes 1. Insert the number you want, then click the OK but¬ 
ton or press the Return key. 

Tfie Spell Menu 

Correct Spelling 

Title Page 
— 

1 Format —i 

Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format 
Paste Format 

Justification ► 
Spacing ► 

I Insert Page Break 
Title Page 

| Set Page # ... 

Set Page # 

Format H 

Hide Ruler 

Font ► 
Size ► 
Style ► 
Color ► 

Copy Format 
Paste Format 3§Y 

Justification ► 
Spacing ► 

1 Insert Page Break 1 
| Title Page 

Set Page # ... 

Correct Spelling 

The Correct Spelling command checks for misspelled words in a selection or 
an entire document, makes suggestions for correcting your spelling, and 
replaces misspelled words. The selected text or entire document is always 
checked from the beginning, and words are corrected in the existing font, 
style, size, and color. 

The first time you choose Correct Spelling, you may be asked to locate and 
open the dictionary. The dictionary is located in the Dictionary folder on the 
Startup disk. Once Works knows the dictionary’s location, you won’t be 
asked again, unless you change its location. 

Options... 
Dictionary... 
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If Works finds words it doesn’t recognize, a dialog box appears, with a list 
box that contains the dictionary. You can drag the dialog box anywhere on 
the screen to see the questioned words in context. Questioned words are 
highlighted in the document. 

Note When spell-checking is finished, Works leaves the last questioned 
word selected. To check spelling again on the same document, click the 
mouse button to remove the selection. 

Works does not check the spelling inside text objects. 

Unknown Works displays words it does not recognize in the Unknown text 
box. You can click the unknown word to transfer it to the Replace With text 
box for editing. 

Replace with Works suggests a correction in the Replace With text box 
for the word highlighted in your document. If you don’t agree with the 
correction, you can scroll through the list box and select the appropriate 
word. To scroll quickly through the dictionary, use the scroll bar on the bot¬ 
tom of the list box. To scroll more slowly, use the scroll bar on the side. 

If you want, you can edit the text in the Replace With text box using the 
same editing techniques you use in the Word Processor. 

Note As you type text into the Replace With text box. Works scrolls the 
dictionary to match the letters that you type. You can insert a word in the 
Replace With text box without finishing your typing. Just select the word in 
the list box to automatically place it in the Replace With text box. 

Skip If Works does not recognize a word, but it is not misspelled, click the 
Skip button to leave the word as it is. 

If All is checked. Works skips all other occurrences of the word. If All is not 
checked, Works displays the word in the Unknown text box each time it is 
found. 
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If you have skipped any words, when Correct Spelling is finished, Works 
asks you if you want the speller to remember the words for future use. If you 
click the Yes button, Works adds these words to a file with the name of the 
document you checked, plus a “.diet” extension. The next time you check 
your document, Works uses both the main dictionary and the skipped-word 
dictionary to check your spelling. Works recognizes the skipped words and 
doesn’t question them. 

A document’s skipped word dictionary is replaced every time you save 
skipped words in that document. If you want to save a skipped word diction¬ 
ary for later use, rename it in the Finder. 

You can also open the skipped word dictionary just like any Word Processor 
document, check the spelling, and add the skipped words to the main 
dictionary. 

Replace If you want to replace a misspelled word with the word in the 
Replace With text box, click the Replace button. 

If All is checked, Works replaces all occurrences of the word. If All is not 
checked, Works replaces only the first occurrence of the word. 

You can type a word in the Replace With text box, or select it from the list 
box. If you type a replacement word that is not in the dictionary, Works asks 
if you want to add it to the dictionary. If you click the Yes button, and the 
Quick Add box is checked, the word is automatically added to the dictionary. 

Note You can also replace a word that is highlighted in your document by 
double-clicking the replacement word in the Dictionary list box. 

View Dictionary This option is selected for you when you choose the 
Correct Spelling command. View Dictionary displays the dictionary in the list 
box — allowing Works to check your spelling against the words in the dic¬ 
tionary, and letting you add and delete words from the dictionary. 

View Suggestions Click this option to view an alternative for the word in 
the Unknown dialog box. Works replaces the dictionary in the list box with a 
list of words that are similar to the unknown word. Works inserts the first 
suggestion in the Replace With text box. 

If you replace a word in the Unknown text box with a word in the Sugges¬ 
tions list box, or if you skip the unknown word, Works automatically 
chooses the View Dictionary option and continues checking your spelling. 

Works tells you if there are no suggestions for the unknown word. Click the 
OK button to return to the dictionary and continue the spelling check. 
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Add You can add a word to the dictionary in three ways: when it is 
highlighted by the spelling checker, by typing a different word in the Replace 
With text box, or by typing a different word in the Adding Word to Diction¬ 
ary dialog box. When Works displays a word you want to add to the diction¬ 
ary in the Unknown text box, click the Unknown text box. The word appears 
in the Replace With text box. Click the Add button. 

To add a word that doesn’t appear in the Unknown text box, type the word in 
the Replace With text box and click the Add button. 

You can add dictionary entries up to 31 characters long, and you can add as 
many words to the dictionary as your disk space allows. 

If Quick is checked, Works automatically adds the word to the dictionary. If 
Quick is not checked, Works presents you with a list of words formed by 
adding different suffixes to the word. 

Adding mold to Dictionary 

Add Word Now 

3 epsilon □ Must Capitalize 

□ epsilons □ epsilonal 

□ epsilones □ epsilonless 

□ epsiloned □ epsilonness 

□ epsilond □ epsilonlike 

□ epsiloning □ epsilonment 

□ epsiloner □ epsilonable 

□ epsilonest □ epsilonible 

□ epsilonly □ epsilonally 

□ epsilons □ epsilonous 

Cancel 

Note Works adds suffixes to the word without checking the spelling of the 
new word — not all suffixes create real words. 

Works presents suffixes for the word in the Unknown text box rather than the 
Replace With text box. 

Click the check box next to each form of the word you wish to add. You can 
also edit words as you would in any Works Word Processor document; edit¬ 
ing automatically selects the word. If you accidentally select a word you 
don’t want to add, just click the check box again. 

Click the Must Capitalize check box to capitalize all words in the dialog box. 

Click the Add Word Now button to add the selected words to the dictionary. 

You can use the same dialog box to add unrelated words. If you want to add 
a different word and be given a choice of suffixes, type a new word into the 
box to the left of the Must Capitalize check box. Then double-click the new 
word’s check box. 
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Note To add an abbreviation to the dictionary, add a period to the end of 
the abbreviation while you are in the Adding Word to Dictionary dialog box. 

You can also add words containing special (diacritical) characters, such as e, 
ii, n, and 9, to the dictionary. These characters appear in the dictionary in 
alphabetical order after “z.” For example, if you add the word “ano,” it 
appears after “azure,” not after “announce.” 

Delete Select a word in the list box and click the Delete button to delete it 
from the dictionary. 

If Quick is checked, Works automatically deletes the word from the diction¬ 
ary. If Quick is not checked, Works asks you if you are sure you want to 
delete the word. 

Cancel Click the Cancel button to cancel Correct Spelling. 

When Works finishes checking your spelling, it displays a count of the words 
in the document, and of the words questioned. The count for words ques¬ 
tioned includes words you automatically skipped or replaced, and errors 
related to the options — such as homonyms and double word errors — even if 
the options are turned off. For more information, see “Options” below. 

If you check a selection, rather than an entire document, Works doesn’t 
display the word count dialog box. 

Options 

Options tell Works to look for or skip certain types of words and word com¬ 
binations. 

Options: 

^ Must capitalize after period 

S Proper noun capitalization 

^ Min numbers and letters 

^ Double word errors 

^Tmo spaces after period 

□ Homonyms 

S Treat hyphens as spaces 

[ Cancel ] | OK ] 

Must capitalize after period If this option is checked, Works questions 
any uncapitalized word that follows a period, exclamation point, or question 
mark. If this option is checked, Works also questions a word that follows an 
abbreviation. In the Replace With text box, Works proposes that the word 
begin with a capital letter. 

Options 

Spell 

Correct Spelling... 

Options... 
| Dictionary... 
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Proper noun capitalization If this option is checked, Works questions 
proper nouns, such as names, that are not capitalized. 

Mix numbers and letters If this option is checked, Works questions text 
that mixes letters and numbers, such as the part number Y1083. 

Double word errors If this option is checked, Works questions repeated 
words like “and and.” 

Two spaces after period If this option is checked, Works questions a 
period, question mark, or exclamation point that is not followed by two 
spaces. In the Replace With text box, Works proposes the questioned punc¬ 
tuation followed by two spaces. 

Homonyms Homonyms are words that sound alike, but are not spelled 
alike, such as “pair,” “pear,” and “pare.” 

If this option is checked, Works may ask you to locate and open the 
MsWorksHymn file, if it is not already open. 

When Works locates a homonym, it displays a dialog box over the dictionary 
dialog box, and presents alternative spellings. 

Rlternatiue spelling for: new 

□ |knew He knew it was true. 

She had a new boy friend. 

It was an Rfrican gnu. 

□ new 

□ gnu 

□ 
[ Stop Checking These Homongms j 

( 0K ] [ Stop Checking RLL Homonyms ] 

If you have used the correct homonym, click the OK button. 

To choose a proposed homonym, click the check box beside the homonym 
and click the OK button. You can edit the homonym as necessary, using the 
same editing techniques you use in the Word Processor. 

If the correct homonym is not proposed, click the check box beside an empty 
text box, click the text box, and type the new homonym. 

If there are more than four alternative spellings for a homonym, a button 
appears in the dialog box. Click this button to view additional choices. 

Stop Checking These Homonyms tells Works to stop checking the current 
group of homonyms. 

Stop Checking ALL Homonyms cancels the homonym checker, and turns off 
homonym checking in the Options dialog box. 
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You can add additional words to the homonym file, or delete words if the 
dictionary contains homonyms that you don’t misuse. For more information, 
see “Adding and deleting words in the homonym file” below. 

Homonym files are always referred to as files, rather than documents, even if 
they have not yet been saved to a disk. 

Return to the Open dialog box to add or delete words in the Works homonym 
file. Click the Word Processor icon, then click the Import File option. Select 
and open the MsWorksHymn file (switch drives if necessary). The homonym 
file opens as an untitled Word Processor document. A row of asterisks 
separates each group of homonyms. 

To delete a homonym group, select the group and one row of asterisks and 
press the Delete key. Do not delete the first line in the document. 

To add a new homonym group, scroll to the bottom of the document and 
type each homonym followed by an example of its use. Divide the homonym 
and example by at least one space. Complete the group by typing a line with 
two asterisks. If you have a series of similar homonyms, use commas and 
type them like this: 

** 

sight, sights, sighted He has excellent sight, 
site, sites The architect chose a hilly site. 
cite, cites, cited She was cited for contempt of court. 
** 

When you have finished, choose Save As from the File menu and save the 
document as an Export file with the filename “MsWorksHymn.” Works asks 
if you want to replace the existing file; click the Yes button. Close the un¬ 
titled document without saving your changes. 

To save time when homonym checking, Works stores an abbreviated 
homonym file in a file named MsWorksHymn Table. This file contains the 
old copy of your homonym file; you must delete it so that Works can find the 
changes in the new MsWorksHymn file. After you delete the MsWorksHymn 
Table, Works automatically makes a new copy of it for you. 

Treat hyphens as spaces If this option is checked, Works checks each 
half of a hyphenated word independently and will not question the hyphena¬ 
tion. If this option is not checked, Works checks for correct hyphenation. 

Adding and deleting 
words in the 
homonym file 
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Dictionary 

Spell 
Correct Spelling... 

Options... 
Dictionary... 

Dictionary 

When you check spelling and save your skipped words, Works creates a 
skipped-word dictionary, and gives it the same name as the document you 
checked, plus a “.diet” extension. A document’s skipped-word dictionary is 
replaced every time you save skipped words in that document. If you want to 
save a skipped-word dictionary for later use, rename it in the Finder. 

The Dictionary command lists skipped-word dictionaries on the current disk. 
The name of the current disk appears above the Eject and Drive buttons. 

|0 Works Program! 

D Article.diet <> Select Skipped Words 
CD Tutorial 

a 

® Works Program 

( Open ) I [ Eject ) 

[ Cancel ] j [ Driue ] 

Open Select the dictionary in the list box and click the Open button to 
open it. When you choose Correct Spelling, Works uses both the main dic¬ 
tionary and the open skipped-word dictionary to check a document. 

Note If you have another commercially available dictionary, move the file, 
MsWorkDict, to another folder and choose Check Spelling from the Spell 
menu. Select the dictionary you want from the dialog box. 

Once you’ve moved MsWorksDict, Works asks you to locate the dictionary 
every time you check spelling. You can avoid this by renaming the new dic¬ 
tionary MsWorksDict in the Finder. 

Eject Click the Eject button to eject the current disk from the disk drive. 
You can then insert the disk containing the dictionary file you want to open. 

Drive Click the Drive button to list the files on the other disk drive. 



The Database 

The Works Database automates your filing system. With your information 
stored in the Database, you’ll have quick access to any combination of 
records. If you want a list of sales leads in Cincinnati, or restaurant names 
that begin with “S” in Buffalo, just ask the Database. If the information is 
there, you’ll find it quickly and easily. 

Printed reports put Database information down on paper. From one set of 
information, you can print many different reports. Each report will contain 
just the particular information you want to pull from the Database document. 



This part of the manual explains how to create and use Database documents: 

■ Chapter 6, “Creating a Database Document,” shows you two ways to 
view a Database document, and shows you how to create a new Database 
document and add information to it. It also explains how to correct mis¬ 
takes as you make entries. 

■ Chapter 7, “Editing a Database Document,” shows how you can change 
your information or the way it’s presented. It also explains how to use 
computed fields. 

■ Chapter 8, “Organizing a Database Document,” shows you how to 
quickly put your information in order, how to find what you need, and 
how to make several smaller, specialized Database documents out of one 
large one. 

■ Chapter 9, “Making a Report,” shows you how to define and print a 
report. You’ll learn how to sum the contents of your fields and produce a 
grand total at the end. 

■ Chapter 10, “Database Command Reference,” describes the commands 
you can use with the Database. 

If you want to merge Database information into a Word Processor document, 
see Chapter 21, “Merging: Creating Mailing Labels, Form Letters, and 
Forms.” 



6 Creating a Database Document 

This chapter explains how to get started with the Database. It shows you 
how to: 

■ View a Database document in a form window and a list window. 

■ Set up a new Database document. 

■ Add new fields. 

■ Switch between list and form windows. 

■ Make entries. 

An Overview 

When you create a new Database document, you set up fields to contain 
information. After you set up a field, you determine how you want it to store 
information — as text, perhaps, or as a date or number. Once you’ve speci¬ 
fied all your fields, you’re ready to add information. 

You can add information to a form or a list. Because a form shows all the 
fields on the screen at one time, it’s easier to enter full records using a form. 
If you only have a few fields, however, you may find it easier to make 
entries in a list. Either way, all the information goes into a single Database 
document. You can organize and review your information in either a list win¬ 
dow or a form window. 
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Looking at a form 

Looking at a list 

Looking at a Form 

When you first set up a Database document, you create a form and fill it out. 

Zoom box 

Entry bar Record 

6 File Edit Window Organize Format Report Macro 

|First Name |Barbara] | Address 12122 Broad Street [ 

[Last Name [Smith 

Icompang [ Wheeler Bicycle Company! 

[Position | Board Member 1 

[vork Phone 1(504)222-1111 | 

New Orleans 

Izip 170101 

[Birthday [January 1, 1918 1 

| Home Phone |(5Q4) 1 11-2222 | 

Field Field name Entry or field data 

This example from an address file shows a single record in a form window. 
All the information about one person or subject — the name, address, and so 
forth — makes up one record. 

Each record is divided into fields of information. The address is one field, 
the city and state are others. Each field has a name so that you know what 
sort of information to fill it with. When you enter information — for example, 
“2122 Broad Street” — you make an entry in a field. Entries are sometimes 
called field data. 

Looking at a List 

When you want to see many records at once — to make comparisons, for 
example — you can list them. 
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Remember that a Database document can be much larger than a window. You 
move around in a large document by scrolling. The scroll bars at the right 
and bottom of the window show you where you are in a Database document 
and enable you to scroll. If the document is not larger than the window, 
scroll bars will not appear. 

Planning a Database Document 

There’s nothing complicated about setting up a Database document. It’s easy 
to rearrange your information with the Works Database — you can play with 
your document until it looks just the way you want. 

The most important thing to remember is that you work with your Database 
information using the fields you set up. 

For example, if you set up an address list, you could set up two fields, 
“Name” and “Address”. Your first record might look something like this: 

r 6 File Edit Window Organize Format Report Macro 

|Name |HiramWheeler | 

| Address 11020 Wheeler Way . Wheelerville, OH | 

Planning a Database 
document 
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To set up a new 
Database document 

A Database document like this has room for everyone’s name and address. 
But it’s not designed well for searching or sorting. A better way to set up a 
document like this is to make a separate field for each component that you 
might want to search for or sort on: 

r 6 File Edit Windom Organize Format Report Macro 

Now you can find all the people who live in Ohio, or who work for the 
Department of the Interior. Or anyone whose first name is John and whose 
zip code is 44444. Or any combination you can think of. Even if you don’t 
set up fields in the most useful way when you create a new Database docu¬ 
ment, you can always go back and add new fields at any time. 

Setting Up a New Database Document 

When you set up a new Database document from scratch, you have to create 
a new Works document. Because there’s no information in the document yet, 
Works asks you to set up fields first. After you name one or more fields, 
you’ll be able to start entering your information. 

To set up a new Database document: 

0 In the Open dialog box, click the Database icon. 

0 Click the New button. 

Works creates an empty document with the name “Untitled,” and asks 
you for the name of the first field. 
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Type a field name here. 

E Type the name of your first field. 

A field name must begin with a letter, and it cannot contain certain char¬ 
acters, such as asterisks, parentheses, or hyphens. 

B Click the Add Field button or press the Return key. 

The new field with the name you typed appears in the form window, and 
the dialog box reappears so that you can set up another field. 

Field name in bold type 

r * 

Border 

'Organize Format Report Macro 

Untitled (DB) 

Field Name: 

Done 

E Type a name for the second field and for as many other fields as you 
want. 

Works adds each new field below the previous one. 

E Click the Done button when you’ve added all the fields you want. 

The dialog box disappears, and the first field is selected. 
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To add a new field 

Adding a New Field 

You can add a new field whenever you want. 

El Choose Add New Field from the Edit menu. 

Works displays a dialog box asking you for the field name. 

0 Type a name for the field. 

0 Click the Add Field button or press the Return key. 

If you’re in a list window when you add a field, Works adds the field to the 
right of the rightmost field and scrolls to the new field. Works puts the field 
name at the top of the new column. 

New field in a list 

r 6 File Edit Window Organize Format Report Macro 

il 

tfork Phone | Birthday 

Rddresses (DB) - 
Position jCompany Name of Spouse 

— 

504) 222-1111 January 1, 1931 Board Member Wheeler Bicycle Corr; 

415)333-4444 Januarly 2, 1928 Board Member Wheeler Bicycle Corr; 

614)432-1235 January 3, 1838 Chairman Wheeler Bicycle Corr; 

212) 121-2121 January 4, 1 948 Board Member Wheeler Bicycle Corr! 

312)343-3434 March 28, 1950 Board Member Wheeler Bicycle Corr: 

312) 999-6666 December 5, 1941 Board Member Wheeler Bicycle Corr! 

614)432-2939 May 3,1955 Secretary Wheeler Bicycle Corr! 

373)387-3877 June 23, 1949 Lawyer Wheeler Bicycle Corr; 
614) 747-7474 April 18, 1958 Assistant Wheeler Bicycle Corr; 

614) 393-3939 October 20, 1961 Office Manager Wheeler Bicycle Corr; 

If you’re in a form window when you add a field, Works adds the new field 
in the first blank area it finds that is large enough to accommodate a field. 

r 6 File Edit Window Organize Format Report Macro 
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You can move any field at any time when you’re using the Database. Notice, 
however, that the position of a field in the list window is not related to its 
position in a form window. For more information, see “Sizing and Arranging 
Fields in a Form Window” and “Sizing and Arranging Fields in a List Win¬ 
dow” in Chapter 7. 

There’s also another way to add a field in a form window. Move the pointer 
to wherever you want the upper-left comer of the field to be. Then hold 
down the mouse button and drag to the right far enough to accommodate the 
field name and field data. When you release the button, Works displays a 
dialog box asking you for the field name. 

If you’re making a new Database document, each field in a form window 
consists of a double box, with the field name in one box and space for your 
entry in the other box. 

The Format menu lets you change the way fields show up on the form. For 
example, in the previous illustration, there are no boxes around the field 
names. To find out how to change the format of your field, see “Changing 
the Appearance of Fields in a Form Window” in Chapter 7. 

Switching Between List and Form Windows 

You can switch between list and form windows by choosing a command or 
by clicking the mouse. 

To switch windows by choosing a command: 

s Choose Show List or Show Form from the Format menu. 

If you pull down the Format menu when you’re in a list window, the first 
menu item switches to Show Form, so that you can go back to the form 
when necessary. 

You can also move between list and form windows by clicking the mouse. 

To move from a form window to a list window: 

S Double-click anywhere in the white space of a form window. 

Works displays the list, and scrolls to display the record that was displayed 
in the form window. 

To move from a list window to a form window: 

0 Double-click the box to the left of any record. 

Works displays the form, with the record you selected showing. 

To switch by 
choosing a command 

To switch by 
clicking the mouse 
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To make an entry 

Making an Entry 

An entry is the content of a field for a single record. An entry can be blank 
or it can contain some information. To enter information, first select an 
entry, and then start typing. You can type information into an active entry in 
your Database document in either a list window or a form window. When an 
entry is active, you can change its contents. 

To make a Database entry: 

0 Select an entry by clicking it. 

The entry you click becomes the active entry. 

Click an entry to select it. 

6 File Edit Window Organize Format Report Macro_ 

1 

11 □ :zzf 
| Work Phone Birthday 

Hddresses (DB 
Position 

(504) 222-1111 January 1,1918 Board Member 

(415)333-4444 January 2, 1928 Board Member 

(614)432-1235 January 3, 1938 Chairman 

(212)121-2121 January 4, 1948 Board Member 

(312)343-3434 March 28, 1950 Board Member 

(312)999-6666 December 5. 1941 Board Member 

(614)432-2939 May 3,1955 Secretary 

(373)387-3877 June 23,1949 Lawyer 

1(614) 747-7474 April 18,1958 Assistant 

1(614) 393-3939 October 20,1961 Office Manager 

L 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Wheeler 

Bicycle Corr: 

Bicycle Corr; 

Bicycle Corr; 

Bicycle Corr: 

Bicycle Corr; 

Bicycle Corr; 

Bicycle Corr; 

Bicycle Corrj 

Bicycle Corr; 

In a list window, you can select an entry only in a record that already 
contains information, or in the first blank record. 

r * File Edit Window Organize Format Report Macro 

1 

Click anywhere in a field to select the entry. 

0 Start typing. 
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When you type, the information appears in the entry bar at the top of the 
screen (but not in the active entry). The cancel box and the enter box appear 
to the left of the entry bar. 

Click here to undo your typing. 
Click here to enter your typing. 

r 6 File 

~ 

Ec it Window Organize Format Report Macro 

KBI Toni 

If you make a mistake, you can make corrections or cancel the typing. The 
cancel box restores the entry to what it was before you began typing. The 
enter box enters what you type. 

The Database can read times and dates in most formats that you might want 
to use, but converts them to its own standard formats. For information about 
typing dates and times, see “Changing the Format of a Field” in Chapter 7. 

You can type up to 250 characters for an entry. Even if the field is too nar¬ 
row to display all the characters, you will see the full entry in the entry bar. 

To put information into the Database, you enter it. When you enter informa¬ 
tion, you tell the Database that you’re finished typing. The Database stores 
the entered information as an entry. 

To enter information into a list window: 

To enter the information and Do this 

Leave the selection where it is Click the enter box or 
press Enter 

Move the selection to the same field in the next 
record 

Press Return 

Move the selection to the next field in the same 
record 

Press Tab 

Move the selection to the same field in the preced¬ 
ing record 

Press Shift + Return 

Move the selection to the preceding field in the 
same record 

Press Shift + Tab 

To enter what 
you type 



To enter information into a form window: 

To enter the information and Do this 

Leave the selection where it is Click the enter box or 
press Enter 

Move the selection vertically to the next field in the 
same record 

Press Return 

Move the selection horizontally to the next field in 
the same record 

Press Tab 

Move the selection vertically to the preceding field 
in the same record 

Press Shift + Return 

Move the selection horizontally to the preceding 
field in the same record 

Press Shift + Tab 

In a form window, if you press the Return or Tab keys when the last field in 
a record is selected, Works moves the selection to the next record. If you 
press Shift + Return or Shift + Tab when the first field in a record is selected, 
Works moves the selection to the preceding record. 

Note You can also use the keyboard’s arrow keys to move the selection to 
another field. In a list window, you can move to any field that contains infor¬ 
mation, or to the fields in the first blank record. In a form window, you can 
move through all the fields in a record. If the first or last field is selected, the 
arrow keys move you to the record that immediately precedes or follows the 
current record. 
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You’ll often need to update your Database documents, changing old informa¬ 
tion and adding new. This chapter explains how to: 

■ Select information. 

■ Change the appearance of fields. 

■ Change the way information is displayed in a field. 

■ Calculate with the Database. 

■ Rename a field. 

■ Size and arrange fields in both form and list windows. 

■ Divide a list window into panes. 

■ Insert a record. 

■ Show a grid. 

■ Copy information. 

■ Make corrections and remove information. 

If you want to add new fields to an existing Database document, see “Adding 
a New Field” in Chapter 6. 

If you want to rearrange and organize your information, rather than change it, 
see Chapter 8, “Organizing a Database Document.” 

Selecting Information 

Before you perform an action on any part of a Database document, you select 
it. You can select entries, fields, or records. Then you can perform actions 
like sorting, removing, or copying. When you make a selection, Works 
displays the number of the record containing the active selection at the left of 
the cancel box. This number is called the record indicator. 
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To select information In a list window, you can select an entry, a field (column), a record (row), or 
a block of entries. You can also cancel (remove) a selection by clicking the 
deselect box at the far left of the field names. 

When you select more than one entry, only one entry is active at a time. This 
entry is bordered in white. You can move through the selection, moving the 
active entry, by pressing the Return, Tab, or arrow keys. 

Click an entry to select it. 

Double-click an entry to change 
its field attributes. 

r « File 1 Edit Window Organize Format Report Macro 

1 Barbara 

worn WM Addresses (DB) ~=P1I 

Click a field name to select 
all entries in the field. 
Double-click a field name to 
change its name. 

/ First Name |Last Name |Title |Address |ci*y |State |Zip | Hoi 

Barbara [Smith JMs. 12122 Broad Street INew Orleans ;L A 170101 i(50 

Thomas 1 Reinhardt IMr.. 11212 Evergreen Lane ; Santa Clara Jca’’’ .195050 1(41 

Hiram .! Wheeler j Mr". .[l 020 Wheeler Way iWheelerville jOh""" 144444 "1(61 

Paul”' jWinthrop IMr. .[n 22 Haught Dr . ; Hillside "]iNY. ""]; V0800 "1(91 
Homer i Winslow ;Mr. 172 Maritime I Chicago "TiT""" ""16O6O9" "1(31 
Robert ; Sawyer w~ .13999 Duke Street : Chicago Til"""" "J60610"" "1(31 
Sheiley 1 Schmidt ;Miss IIT^PalmCourt;:: iWheelerville Toh ’ .[44444 1(61 
Richard : Dolan IMr". 19357 Circle Court 1 Cincinnati lwT .[39555"" "1(61 

J Leslie j Poulin IMrs. ’[ Mil Maple Street [ iWheelerville Joh’’’ .[44444 i(6i 
r Susan !Stanton IMs. 13976 Cherry Court i Cincinnati ""[oh""" [44839 "1(37 

Click here to select all entries in a record. 

Click the deselect box to cancel a selection. 

In a form window, you can select only one entry at a time. 

r * File Edit 

Click anywhere in a field to select an entry. 

Window Organize Format Report Macro 

Barbara 

Addresses (DB) i 

First Name 

Last Name Smith 

| Address [2122 Broad Street 

|c»«l I New Orleans 1 

[State|LA | 

I Zip |701Q1~ 

|Company | Wheeler Bicycle Company! |Hame of Spouse~[~ 

[Position | Board Member | 

1 York Phone 1 (504) 222-1 111 I 

I Birthday | January 1 , 1918 | 

[Home Phone | (504) 111 -2222 | 

o 

Double-click a field name 
to change its name. 

Double-click an entry to 
change its field attributes. 
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In either type of window, when you select an entry, it becomes active and 
you can change its contents in the entry bar. When you select a field, you 
can move it, size it, change its name, or change its attributes. 

The content of the active entry is displayed in the entry bar. Even though it is 
not highlighted, it is selected; anything you type will replace what is 
displayed. To edit the entry, you can select any part of it. 

Double-click to select a 
word, or drag to select Click to position the insertion 

more text. point. 

6 File Edit Window 
1 llVll /ll oiooBfi 

Organize 
BHEI C + r-rk rt+lx 

Format Report Macro 

n 

First Name |Last Name | Title 

WM Rddresses (DB) 
|Address 1 City Istate |Zip 

■E 

| Hoi 
Barbara | Smith [Ms. 12122 Broad Street iNew Orleans [LA 170101 j(50 
Thomas i Reinhardt 1 Mr. 11212 Evergreen Lane [Santa Clara JCA ]95050 "1(41 
Hiram i Wheeler. IMr [1626 Wheeier Way. IWheelerville ’ [OH. [[44444"[ 1(61 
Paul". IWinthrop i Mr. 

. 
[Hillside. |ny i 10800 1(91 

Homer i Winslow Mr 172 Maritime [Chicago [if. 160609 " 1(31 
Robert 1 Sawyer Mr ']"j3|^D^eStj^^"""‘ ! Chicago [ir:: 60610 |(31 
Shelley I Schmidt •Miss 13957 Palm Court IWheelerville [OH. "I44444"" "1(61 

Richard ! Dolan Mr 19357 Circle Court i Cincinnati OH ;]39555[[ "1(61 

Leslie. i Poulin ]Mrs7" 11 if Maple Street. IWheelerville ]oh ::: [44444 "1(61 
Susan iStanton 1ms':: 13976 Cherry Court i Cincinnati [OH. J44839 1(37 

Changing the Appearance of Fields 

When you set up a new Database document, the records are displayed in a 
form window with borders around each field name and each entry. The field 
name is in bold type, and the entry is in plain type. You can change the way 
records are displayed to get different effects. 

You can use commands in the Format menu to change the font and size of 
your data. If you have a color monitor, you can also change its color. If you 
change the font, size, or color, it affects all fields in the active view (form, 
list, or report) of the document. The Font, Size, and Color commands are 
explained in detail under “The Format Menu” in Chapter 2. 

You can use the Font, Size, and Color commands in both the list and form 
windows. In the form window, there are additional commands for changing 
the appearance of fields. 

To select in the 
entry bar 
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To put borders 
around field names 
or entries 

To put field names or 
entries in bold type 

Changing the Appearance 
of Fields in a Form Window 

To add or remove borders around field names or entries: 

\u\ Choose Border Field Name or Border Field Data from the Format menu. 

To display field names or entries in bold type: 

\u\ Choose Bold Field Name or Bold Field Data from the Format menu. 

A command that is currently in effect is checked in the menu. To remove a 
checkmark, choose the command again. 

Some of the different appearances you can create are shown below. The com¬ 
mands you choose affect all fields and records in a document. 

Plain text 
No border 

Bold field name 

Border 

Rddresses (DB) 

First Name Barbara 

[Last Nam^ Smith 

fTitlelMs. 

[Company] Vheeler Bicycle Company 

1 Address | 2122 Broad Street 
o 

| City | Nev Orleans 

I State | LA 

fiipl 70101 

Bold entry 
Plain field name 

No border 
Border 
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Changing the Format of a Field 

There’s more to formatting in the Database than using borders or bold type. 
You can also set field attributes that determine what kind of information can 
be kept in a field, and how that information is displayed. For example, you 
can specify that a field named “Total Cost” contains only numbers displayed 
as dollar amounts. 

Field attributes apply to field data in both list and form windows. The normal 
settings are left-aligned plain text for non-numeric characters and right- 
aligned Fixed format for numbers. 

Field attributes include the type of field, the way numbers are displayed, 
the alignment and style of text, and the number of decimal places to be 
displayed. You can also specify that a numeric field be computed or that 
a date field include the day of the week. 

With the Set Field Attributes command, you can customize the appearance of 
your data whenever you want. Because the field type determines which other 
attributes are available to you, you should choose the field type first. 

To set or change field attributes: 

0 Select a field or an entry in the field. 

0 Choose Set Field Attributes from the Format menu. 

The Set Field Attributes dialog box appears. 

0 Click the options you want for the field. 

0 Click the OK button. 

For a complete description of the options available in the Set Field Attributes 
dialog box, see “Set Field Attributes” in Chapter 10. 

When you specify a date field with the Set Field Attributes command, the 
Database gives you a choice of short, medium, or long displays. You can 
also choose to have the day of the week displayed with the medium and long 
displays. You can type the date in any of the following formats, and the 
Database will display it in the form you chose in the Set Field Attributes dia¬ 
log box: 

■ 08/10/88 

■ 8-10-88 

■ 8.10.88 

■ 08/10/1988 

■ Wed, Aug 10, 1988 

■ Aug 10, 1988 

■ August 10, 1988 

■ Wednesday, August 10, 1988 

To set or change field 
attributes 

To type a date 
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To type a time 

What is a computed 
field? 

Then, depending on the options you choose, Works displays the date like 
this: 

Display Show Day Unchecked Show Day Checked 

Medium Aug 10, 1988 Wed, Aug 10, 1988 

Long August 10, 1988 Wednesday, August 10, 1988 

You can enter the current date into an active entry by pressing 
Command + D. 

Works displays time using a 12-hour clock, even if you enter a time in 24- 
hour format. 

If you type Works displays 

8:04 8:04 AM 

20:04 8:04 PM 

8:4 pm 8:04 PM 

20:4 8:04 PM 

If you don’t use 24-hour time, remember to include the “am” or “pm”. If you 
don’t specify this, Works displays “AM”. 

You can enter the current time into an active entry by pressing 
Command + T. 

Important You can change a text field to a date, time, or numeric field 
after you enter the data. However, if you change the type of field and the 
data is not in an acceptable format, Works deletes the data. You can change 
a date, time, or numeric field to a text field and retain all your data. 

Calculating with the Database 

A computed field contains the results of a calculation based on the contents 
of other fields. For example, a computed field in a payroll Database docu¬ 
ment might calculate weekly wages by multiplying the “Hours Worked” field 
by the “Dollars Per Hour” field. 

The Spreadsheet is best for making projections or performing complex calcu¬ 
lations. However, computed fields in the Database allow addition, subtrac¬ 
tion, multiplication, division, and exponentiation. (Exponentiation raises one 
number to the power of another; for example, 2A2 = 4 and 2A3 = 8.) 
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In computed fields in the Database, you can use all Works functions except 
those that require ranges for arguments, such as Sum(Al:A5). Functions used 
in the Database can’t relate to more than one record at a time and can only 
use other fields in the same record. 

Functions you can’t use in the Database are: 

■ The IRR and MIRR Financial functions. 

■ The HLookup, Index, Lookup, Match, and VLookup Special-purpose 
functions. 

The following functions often take ranges as arguments, but can be used in 
the Database with a single field reference, a list of fields separated by com¬ 
mas, or a value in place of a range: 

■ All of the Statistical functions — Average, Count, Max, Min, SSum, 
StDev, Sum, and Var. 

■ The FV, NPV, Pmt, PV, and Rate Financial functions. 

■ The And, Choose, If, IsBlank, and Or Logical functions. 

For detailed information on Works functions, see Chapter 15, “Spreadsheet 
and Database Functions.” 

You designate a computed field in the Set Field Attributes dialog box. 

To make a computed field: 

0 Select a numeric field. 

[U Choose Set Field Attributes from the Format menu. 

0EI Click the Computed option. 

6 File Edit Window Organize] Report Macro 

Requests (DBI IS! 
Supplier City Country 

Fitzgerald Meatpacki Argentina 

Kelly's Barbie Treat: Melbourne Australia 

n Brazi 

flight 

ead 

ite 

liquids 

ood 

od grouf 

ii: 
e Set Field Rttributes For Total Cost 

k 
„ Type: Display: Rlign: Style: 

If OTent O General OLeft □ Bold 

?. <§) Numeric O Fitted O Center □ Underline 

” O Date (§) Dollar (§) Right □ Commas 

. OTime 

K 

O Percent 

O Scientific 
| j|pecimal Places 

□ Computed 
is 

duMWId- :LVUII 

□ Show Dog 

-:MUXIUU 

( Cancel ] ]( OK )) 

-UU-ZZZ-:- 
treatJ 

s and pri 

m 
Williams‘s Fruit 

Marca de Lopez 

i Christchurch 

i Pamplona 

iNew Zealand 

; Spain 

1216220 

]232 22 22 2 

To make a computed 
field 
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To enter a formula 

To rename a field 

0 Click the OK button. 

Works returns you to the form or list you were looking at. The equal sign in 
the entry bar shows you that Works needs a formula for the calculation. 

To tell Works what you want to compute, you enter a formula. A formula for 
a computed field can contain field names, operators, functions, and numbers. 
To include a field name, you can either type the name yourself or click the 
field name and have Works put it in the entry bar for you. A formula can 
contain up to 238 characters. 

To enter a formula for a computed field, first follow the procedure for desig¬ 
nating a computed field, above. Then: 

0 Type the formula at the insertion point. 

It might look something like this: 

0 Click the enter box or press the Enter key. 

Works calculates the contents of the new field from the formula you typed. If 
you included a nonexistent field name in the formula, Works displays an alert 
box. 

Mathematical operator 
First field name 

fk File Edit Window Jrganizc Forme t Report Macro 

I llXlk/ll =Number on Team*Cost per Person 

Selected entry 

Second field name 

|City 

Requests (DB) j 
[Supplier [Country [Telephone 

liquids I Etienne’s Fish Shop [Marseilles [France [40-00-00 

o
 

o
 

o
 

*=► 

ite [Dickerson's Snack ShHolyhead [Great Britain ! (0492) 11111 $0.00 

ood [Dreiviertel Pfund j Munich [ Germany [22 00 00 $6.66 
:Cafe Hansi I Vienna [ Austria .143*66 00 $0.00 

: treat [Williams's Fruit [Christchurch [New Zealand [216220 $6.o6 
ue sauc*[ Kelly's Barbie Treat: 1 Melbourne [Australia ;456-777 $6.oo 

i A. Joshi Pastries ;Jodhpur [ India 1674-444 $0.66 
[Abrahamsson BakeriiGoteborg [Sweden [l 5 22 22. $6.66 

ead [Konditori Andersen [Copenhagen [Denmark ]’j12'22 22. .$6.66 
[Peking Duck Mart : Beijing [China 756434"]™ ’’ ’ ’$6 oo 

od groufi Spiro Agnopoulos : Olympia [Greece .|21999 "’’’"'Jo.’66’ 
:arbos [Siam Exports 1 Bangkok [Thailand "195-34-23. $6.66 

Renaming a Field 

If you decide to change the name of a field, you can rename it. 

To rename a field: 

0 Select the field. 
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E Choose Change Field Name from the Edit menu. 

The Field Name dialog box appears. The current name is selected, so you 
can just type the new name to replace it. 

E Type the new name in the dialog box. 

E Click the OK button or press the Return key. 

Works replaces the old name with the new one. 

You can also double-click the field name to see the Field Name dialog box. 

Sizing and Arranging Fields 
in a Form Window 

You can change the size and arrangement of fields in a form window when¬ 
ever you want. 

To change the size of a field in a form window: 

□ Position the pointer on the right edge of the field data box. 

The pointer turns into a two-way arrow. (If you have removed the borders 
from the field data, move the pointer to where the box would normally 
be. When you’re at the right place, the two-way arrow appears.) 

E Hold down the mouse button and drag to the right or left until the box is 
the size you want. 

To change the 
size of a field 

r « File Edit Window Organize Format Report Macro 

”1 (999)378-4973 

Press the mouse button here... 
...and drag until the field is the size you want. 
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To move a field You don’t have to leave fields where you first create them. Works lets you 
move fields to wherever they make the most sense to you. 

To move a field in a form window: 

□ Position the pointer over the field name. 

The pointer turns into a hand. 

0 Drag the field to its new location. 

To change the width 
of a field 

r 6 File Edit Window Organize Format Report Macro 

i io 

If a field won’t fit where you want to put it, you’ll have to make room for it. 
You can make it smaller, make surrounding fields smaller, or move another 
field out of the way. 

Sizing and Arranging Fields 
in a List Window 

The width or placement of fields in a new list may not satisfy you. They’re 
all the same width, and their order is based on the order in which you first 
typed the field names. But in an address book, for example, you might want 
the “First Name” field to be wider than the “Middle Initial” field. And it 
would make more sense to have “Last Name” as the first field, rather than 
“Zip Code” or “State.” Works lets you size and arrange your fields however 
you want them at any time. 

To change the width of a field in a list window: 

0 Position the pointer on the right edge of the field name box. 

The pointer turns into a two-way arrow. 
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Drag to the left to 
narrow a field. 

Drag to the right to 
widen a field. 

* File Edit Window Jrganize Format Report Macro 

^quests (DB) 
Team |Peeps (Requested Ft| (♦tost per Person (Local | Available Comment 
USA 10 Hamburgers $5.10 Yes May, June High-proteii 
France .7. Bouillabaisse $1.50 Yes May, June Supplement: 
England .6. Fish and Chips $5.40 No May, June English favo 
Germany .8. Brezen $1.10 Yes May, June High-carbo 
Austria .5. Wiener Schnitz* $4.25 Yes May, June High-proteir 
New Zealand .6. Kiwis $2.70 No January South Pacifi 
Australia .8. Barbequed Shri $6 10 Yes August, September Spicy barbe 
India .6. Samosas $2.05 No May, June Appetizer 
Sweden .5. Knackebrod $1.95 j Yes May, June Filling 
Denmark .6. Poise $4.60 Yes May, June Best with br 
China .7. Pressed Duck $5.90 No May, June Rare treat 
Greece ’ _5. Moussaka $3.95 (Yes May, June Includes 3_f 

HI Drag to the right to widen the field, or to the left to narrow it. 

As you drag to adjust the field size, a dotted line shows you where the 
new edge of the field will be. 

To move a field in a list window: 

[j] Position the pointer on the name of the field you want to move. 

[|] Drag the field to the right or left. 

As you drag, Works highlights the field names that you pass over. 

Dragging the “Requested Food ” field to the left 

* File Edit Window Organize Format Report Macro 

teaks 

id Requests (OB) 

Argentina j 16 (steaks $7.20 [Yes iMay, June 
O 

Australia j 8 Barbequed Shrimp j&i'o. (.(Yes. i August, September TT7 

Austria .Ts. Viener Schnitzel ""”"$4(25""“" (((((((] Yes. iMay, June 
Brazil '5 Lamb $5 60. CjNo iMay, June 
Canada I 8 . Pea Soup .$120. ;Yes iMay, June 
China 17 Pressed Duck .:No (May, June 
Denmark 16. Poise $4^60. :Yes(((( iMay, June 
Egypt. ].]9. Dates .$2 05."" i No i July, August 
England 16’ ‘" Fish and Chips ("("($576 (((((((([No iMay, June 
France 1.\7 Bouillabaisse (((((((($ l('50'((((((( :Yes (May, June 
Germany Mi. Brezen $110. .iYes iMay, June 
Greece _ Moussaka T $3 95. _]Yes_ _ _ June 

To move a field 

Works scrolls horizontally when you get to the edge of the window. 
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To divide the window 
into two panes 

ID When Works highlights the field that you want to be adjacent to the field 
you’re moving, release the mouse button. 

The field you’re moving is inserted to the left of the highlighted field if 
you’re dragging left, or to the right if you’re dragging right. 

Dividing a List Window into Panes 

When you have a large Database document with many fields and records, it 
can be time-consuming to scroll back and forth to compare information in 
entries that are far apart. To make it easier for you to look at your informa¬ 
tion, Works provides split bars that divide a list window into panes. The two 
panes on either side of the vertical split bar scroll horizontally. The two 
panes above and below the horizontal split bar scroll vertically. Dividing a 
window into panes lets you hold one pane stationary on the screen while you 
scroll through another pane to find particular information. 

You can divide the window into both side-by-side and top-and-bottom panes. 

[3 Position the pointer on either the horizontal or vertical split bar. 

The pointer turns into a two-way arrow. 

[2] Drag the split bar until it lines up with the right edge of the field or the 
bottom edge of the record at which you want to divide the Database 
document. 

When you release the mouse button, the list window divides into two panes. 

Split bar in its initial position 

r 6 File Edit Window Organize Format Report Macro 

- 
Team Number on Team 

Requests 
Requested Food | Cost per Person (Local Supplier? | Availi 

Argentina 6 Steaks $7.20 jYes jMay, J 

Australia .8. Barbequed Shrimp i $6.10 jYes jAugust 

Austria .5. Wiener Schnitzel $4.25 |Yes i May, J 

Brazil .5. Lamb $5 60 jNo i May, J 

Canada " ' 8' ’ ’' Pea Soup $1.20 ; Yes i May, J 

China .7. Pressed Duck $5.90 iNo jMay, J 

Denmark .6. Poise $4.60 : Yes i May, J 

Egypt .9. Dates $2.05 (No 1 July 'a 

England .6. Fish and Chips $5 40 iNo (May, J 

France .7. Bouillabaisse $1 50 jYes i May, J 

Germany .8. Brezen $1 10 |Yes i May, J 

Greece .5. Moussaka $3.95 jYes : May, J 

Holland .4. Goudse Kaas $2.95 :Yes iJune,J 

India .6. Samosas $2.05 iNo : May, J 

Italy .5. Gnocchi $4.75 iNo ; May, J 

Mexico .7. Tostadas $5.00 iNo : May, J 

New Zealand !.6. Kiwis $2.70 ;No :Januan 

.th m 
Split bar that has been dragged to the right 



Chapter 7 Editing a Database Document 153 

With four panes, you can see even more parts of a Database document at 
once because you can scroll each pane both vertically and horizontally. 

To divide the window into four panes: 

0 Drag each split bar into the positions you want. 

6 File Edit Windom Organize Format Report Macro 

□ Requests (OB) HI 
Team | Number on Team Requested Food | Cost per Person {Local Supplier? | Availa P Argentina 6 Steaks $7.20 jYes iMay, Ji. 
Australia iz®ir Barbequed Shrimp i —. VYes 7" :August, 
Austria 5 Viener Schnitzel ; Z7MM7777 iYes " iMay, Ji. 
Brazil 775. Lamb 777:1:66. :No iMay, Ji 
Canada IIJZ Pea Soup 771720. iYes i May 7Ji 
China .7. Pressed Duck 77M:?° i No iMay, Ji 
Denmark 6 Poise. $4.60. jYes. iMay, Ji. Q 
Egypt. 9 Dates $2.05 [No i July, Ai O 
England .6. Fish and Chips 77$|:4i!i. iNo iMay', Ji 
France 7 7. Bouillabaisse $130. iYes iMay, Ji 
Germany 77.8.. Brezen 

——. 
jYes iMay, Ji 

Greece 77757. Moussaka .$3 95. iYes iMay, Ji 
Holland .4. Goudse Kaas .$2.95. iYes iJune,J 
India .6. Samosas $2"05. irio iMay, Ji 
Italy. .5. Gnocchi ::i4:75. iNo iMay, Ji 
Mexico .7. Tostadas .$5:66 iNo :May, Ji 
New Zealand .6. Kiwis 77M-79. jNo iJanuary iiiiii 

i Spain 

>U.; 

6 
■ite 

Tapas 

zrmm: 
.$4"35. 

J. 

IYes. iMay, Ji O 

a 

Now you have four scroll bars. Each scroll bar controls the two panes that 
are in line with it. For example, the upper scroll bar controls the two upper 
panes, and the left scroll bar controls the two left panes. Otherwise, the scroll 
bars work normally. 

To close a pane: 

0 Drag the split bar back to the far left or upper edge of the pane. 

Inserting a Record 

You can add a new record between other records, in both a list and a form 
window. 

To insert a record: 

0 Select a record in a list window, or scroll to a particular record in a form 
window. 

0 Choose Insert Record from the Edit menu. 

To divide the window 
into four panes 

To close a pane 

To insert a record 
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To show or hide 
the grid 

Works inserts a blank record before the selected or displayed record. 

New blank record inserted in a list window 

r * File Edit Ulindou) Organize Format Report Macro 

Argentina 6 [Steaks $7.20 [Yes iMay, June 

Australia .8 iBarbequed Shrimp i .$6710 ^ ZMZZ i August, S< 

Austria .5. [Wiener Schnitzel i .$4“25.. .[Yes [May, June 

.f s :Lamh $5 60. .No iMay . June 

Canada 8 ;Pea Soup $1.20 

. 

iYes iMay, June 

China .. "lII [Pressed Duck | 'ZKZ. iMay, June 

Denmark .6.. .[Poise ' ] .$4’60 ijYes!!:::: iMay, June 

Egypt. [Dates .$2"05. .[No. i July, Augt 

England .6. [Fish and Chips .$540 ' [No iMay, June 

France .7. : Bouillabaisse j siJo'Z iYes iMay, June 

Germany .8. iBrezen .$1.10. .[Yes iMay, June 
— 

New blank record inserted in a form window 

r 4 File Edit Window Organize Format Report Macro 

\ 

Requests (DBI 

| Number on Team! | 

[Requested Food j 

It-ocal Supplier? [ | | Available! 

[Cost per Person 1-1 

| Supplier] 

ic'*« |Country^ ]] [Telephone | 

o 

Showing the Grid 

In a list window, lines separate each column and row. You can choose 
to turn this grid on or off. If Show Grid is checked in the Format menu, 
Works displays the grid. If Show Grid is not checked, Works doesn’t display 

the grid. 
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To show the grid, if Show Grid is not already checked: 

S Choose Show Grid from the Format menu. 

To remove the grid, choose Show Grid again. 

Here’s how each choice looks: 

6 File Edit Window Organize Format Report Macro 

First Name Last Name Title Address City Istate Zip Hoi 
Barbara Smith Ms. 2122 Broad Street New Orleans LA 70101 (5C 
Thomas Reinhardt Mr. 1212 Evergreen Lane Santa Clara CA 95050 (41 
Hiram Wheeler Mr. 1020 Wheeler Way Wheelerville OH 44444 (61 
Paul Winthrop Mr. 1122 Haught Dr. Hillside NY 10800 (91 
Homer Winslow Mr. 72 Maritime Chicago IL 60609 (31 
Robert Sawyer Mr. 3999 Duke Street Chicago IL 60610 (31 

6 File Edit Window Organize Format Report Macro 

First Name |Last Name | Title |Address Icity |State |Zip | Hoi 
Barbara Smith Ms. 2122 Broad Street New Orleans LA 70101 (50 
Thomas Reinhardt Mr. 1212 Evergreen Lane Santa Clara CA 95050 (41 
Hiram Wheeler Mr. 1020 Wheeler Way Wheelerville OH 44444 (61 
Paul Winthrop Mr. 1122 Haught Dr. Hillside NY 10800 (91 
Homer Winslow Mr. 72 Maritime Chicago IL 60609 (31 
Robert Sawyer Mr. 3999 Duke Street Chicago IL 60610 (31 

Copying Information 

You can copy individual records, fields, or entries, and blocks of records, 
fields, or entries. Copying within and between documents saves you from 
having to retype similar information. For example, if you have ten people in 
your address book who live in Seattle, Washington, you can type the city and 
state once, and copy the rest. Although you can copy in both list and form 
windows, it’s easier in a list window, because you can copy multiple records 
at once. 
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To copy a record Some records are only slightly different from one another. To save time and 
typing, you can copy one of these records and change the copies where 

necessary. 

To copy a record: 

0 Make sure you’re in a list window. 

0 Click the record selector box at the left of the record you want to copy. 

0 Choose Copy from the Edit menu. 

0 Select the row where you want the copy to go. 

0 Choose Paste from the Edit menu. 

Works inserts a new row containing the copied information above the 
selected row, and moves the following records down to accommodate the 

new one. 

To copy an entry There are times when you’ll want two or more records to have the same entry 
for a particular field. To copy an entry into the same field of the next record: 

□ Select the entry below the one you want to copy. 

0 Press Command + ” 

Works displays the copied information in the entry bar. 

0 Click the enter box or press the Return key. 

Works copies the information into the selected entry. 

To make multiple To make multiple copies of an entry or block of entries: 

copies of an entry 
0 Make sure you’re in a list window. 

0 Select the entries you want to copy. 

6 File Edit Windoui Organize Format Report Macro 

10 □ | Cincinnati 

1 n — 1 Addresses (DB) ^m ' ■ -i ■art 

First Name iLast Name | Title |Address |State |Zip 
Barbara ; Smith jMs. = 2122 Broad Street INew Orleans jLA 170101 Kid 
Thomas 1 Reinhardt IMr M212 Evergreen Lane :Santa Clara jca;:: 195050 1(41 

Hiram 1 Wheeler ~ IMr. T1 020 W he el er Way : Wheelerville "Ioh""’’’ 144444. "l(61 

Paul.. IWinthrop I Mr " 1 i i 22 Haught Dr .""’" : Hillside 1NY 110800 1(91 

Homer 1 Winslow IMr. ! 72 Maritime i Chicago ML 160609 1(31 

Robert ISawyer IMr. ""[3999 Duke Street. 1 Chicago ML 160610 lil? 
Shelley j Schmidt :Miss 13957 Palm Court : Wheelerville |oh’” 44444 1(61 

Richard IDolan ]Mr •••••• ""19357 Circle Court iCincinnati ]0H. ]39555"" 1(61 
... 

Leslie 1 Poulin :Mrs. "j’i 11 Maple Street 1 Wheelerville Ioh. 144444 

Susan IStanton Ms ' 13976 Cherry Court ^Cincinnati | OH ICfflgBi(37 
David ; Morgan iMr. ""J 19373 Manor Road / •Li. 

Drag the mouse to select 
the entries you want to copy. 

Make sure there are 
empty entries to receive 
the copy. 
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0 Choose Copy from the Edit menu. 

0 Select the entries to receive the copy. 

0 Choose Paste from the Edit menu. 

Works fills in the selected entries with a copy of the information. 

6 File Edit Windom Organize Format Report Macro 

11 Cincinnati 

= 11 — Addresses (DB) — —- 
First Name Last Name Title Address City State Zip Hoi 
Barbara Smith Ms. 2122 Broad Street New Orleans LA 70101 (50 
Thomas Reinhardt Mr. 1212 Evergreen Lane Santa Clara CA 95050 (41 
Hiram Vheeler Mr. 1020 Vheeler Way Wheelerville OH 44444 (61 
Paul Winthrop Mr. 1122 Haught Dr. Hillside NY 10800 (91 
Homer Winslow Mr. 72 Maritime Chicago IL 60609 (31 
Robert Sawyer Mr. 3999 Duke Street Chicago IL 60610 (31 
Shelley | Schmidt Miss 3957 Palm Court Wheelerville OH 44444 (61 
Richard Dolan Mr. 9357 Circle Court Cincinnati OH 39555 (61 
Leslie Poulin Mrs. 111 Maple Street Wheelerville OH 44444 (61 
Susan Stanton Ms. 3976 Cherry Court Cincinnati OH 44839 (37 
David Morgan Mr. 9373 Manor Road Cincinnati OH 44839 1. 

- — _ _ _ _ _ mJm _ _J. _ i _ 

Now you can select these two blocks of entries to copy and paste into the 
next two records. 

* File Edit UHndom Organize Format Report Macro 

10 Cincinnati 

Rddresses (BB) j 
First Name |Last Name | Title |Address Icity (State |Zip |Ho 
Barbara Smith !Ms. 121 22 Broad Street iNew Orleans iLA 170101 j(50< 
Thomas iReinhardt 1 Mr. 11212 Evergreen Lane iSanta Clara |ca’“. 195050 1(41! 
Hiram ! Wheeler !Mr. i 1020 Vheeler Way. ; Wheelerville j OH. 144444 "1(61- 
Paul. | Winthrop iMr. !l 122 Haught Dr. i Hillside i NY i 10800 1(9U 
Homer : Winslow i Mr. :72 Maritime i Chicago [IlZ 160609 ](3i i 
Robert | Sawyer iMr. 13999 Duke Street Chicago [iL. 160610 j(3i; 
Shelley. Schmidt Miss 3957 Palm Court Wheelerville jaH~ :44444 j (61 - 
Richard Dolan Mr. 9357 Circle Court | Cincinnati iOH' 139555 1(61- 
Leslie. Poulin Mrs!. 111 Maple Street Wheelerville iOH. ; 44444 
Susan Stanton Ms. 3976 Cherry Court j] OH wmm 

IC37: 
David Morgan Mr. 9373 Manor Road A Cincinnati OH ■(371 

Martin Cook Mr.. 9292 First Street / ' ! 

Laura Martin Mrs. 2838 Pine Valley ± 

M 

Select these entries... .and paste them here. 

Then you can select the four identical blocks of entries and copy and paste 
them into the next four records. You can repeat this process to fill your 
records as often as you need to. 
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To correct a typing 
mistake 

To replace selected 
text 

Making a Correction 

When you find a typing mistake in an entry, you can correct it. 

To correct a typing mistake: 

0 Select the entry containing the mistake. 

0 In the entry bar, put the insertion point to the right of the mistake. 

0 Press the Delete key to back over the entry. 

0 Type the correction. 

0 Click the enter box or press the Enter key. 

When you select text in the entry bar, you can replace it by typing or by 
using the Cut, Copy, or Paste commands from the Edit menu. 

To replace selected text by typing: 

0 Select text in the entry bar by dragging across it. 

0 Type the replacement, or press the Delete key to remove the whole 

selection. 

The text you type replaces the original text. 

0 Click the enter box or press the Enter key. 

The new text appears in the selected entry. 

You can also select just one word of an entry in the entry bar by double¬ 

clicking it. 

Removing Information 

Works lets you remove information from a Database document in three dif¬ 

ferent ways: 

■ Cutting takes information out of a Database document and puts it on the 
Clipboard. This is useful for cutting and pasting as well as for removing 
information. You can cut records, entries, and blocks of data. 

■ Clearing permanently removes records, fields, entries, or blocks. Cleared 
information does not go on the Clipboard. 

■ Deleting a field removes a field from the Database document, including 
the field name and all entries. This is useful for removing an entire field 
that you don’t need anymore. 

If you delete a field or cut or clear information, then decide you don’t like 
the result, you can use Undo in the Edit menu to reverse your last command. 



Chapter 7 Editing a Database Document 159 

If you cut a field or an entry, Works cuts the contents, but leaves a blank 
field or entry in its place. If you cut a record, Works removes the record and 
closes up the empty space. 

To cut information: 

To cut information 

0 Select the information you want to cut. 

0 Choose Cut from the Edit menu. 

Works takes the information out of the Database document and places it on 
the Clipboard. You can paste what you cut back into the Database document 
at a location you select. 

When you clear information, Works blanks the selected entries. If you clear a 
field, entry, or record, Works clears the contents, but leaves a blank field, 
entry, or record in its place. 

To clear information: 

To clear information 

0 Select the information you want to clear. 

0 Choose Clear from the Edit menu. 

Works removes the information from the Database document, but does not 
put it on the Clipboard. If you reconsider, choose the Undo command before 
you do anything else. 

When you delete a field, Works removes it from the document and closes up 
the space it left behind. 

To delete a field: 

To delete a field 

0 Select the field. 

0 Choose Delete Field from the Edit menu. 

The field disappears. If you decide you really don’t want to delete the field 
after all, you can use the Undo command. 

If you cut a selection, you can paste it back into a Database document at a 
location you select. 

To paste the contents of the Clipboard: 

To paste the contents 
of the Clipboard 

0 Select a record or field, or the upper-left entry of a block of entries that 
you want to paste to. 

0 Choose Paste from the Edit menu. 

Works fills in the selected entries with the information from the Clipboard. 





8 Organizing a Database 
Document 

This chapter shows you how to organize a Database document so that you 
can find information easily. 

You’ll learn how to: 

■ Sort information. Put your information in alphabetical, numerical, or 
chronological order, backwards or forwards. 

■ Find information. Scroll to view those fields that contain the characters 
you specify. 

■ Match records. Quickly call up the records that contain the information 
you specify. 

■ Use record selection rules. Use up to six criteria to have Works show you 
records with specific information only. 

By using record selection rules and then saving the selected records with 
another name, you can create subsets of your Database document. This 
chapter shows you how. 

Sorting Information 

If your records aren’t in the order you want, you can sort them. Sorting 
arranges records in alphabetical, numerical, or chronological order, either 
backwards or forwards. You can sort on any field, in both form and list 
windows. 

Sorting is more than just putting A before Z in your Database document. You 
can do successive sorts on different fields to group your records just the way 
you want them. Each sort is done individually by repeatedly choosing the 
Sort command. 
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For a multi-level sort, you first sort on the field you’re least interested in. For 
example, to get an address list in order by last name and then by first name, 
you’d first sort on the first name field. For each level of a multi-level sort, 
Works retains the order of all previous sorts. 

Multi-level sorting lets you presort a large mailing, for example. You can 
group the records in your mailing list in order by last name, first name, city, 
state, and zip code. When you put labels on your mass mailing, it will 
already be sorted by each of these categories. 

To sort Depending on the type of information a field contains, the Sort command in 
the Organize menu presents different options: 

If you select this type of field You can choose these options_ 

Text Alphabetical order or reverse 

Numeric Numerical order or reverse 

Date or Time Chronological order or reverse 

Note There are some instances when you may want to put numbers into a 
text field rather than into a numeric field. Zip codes are a good example. 
Numeric fields can’t show leading zeroes (in zip codes like 08080). They 
also subtract the two halves of nine-digit zip codes (like 98073-0808). For 
these reasons, a field containing zip codes should usually be text. 

To create a text field, type =” in the entry bar before typing the number. 

To sort information: 

□ Select the first field you want to sort on. 
You can either click the field name or select any number of entries in a 
field to select the field to sort on. 

[|] Choose Sort from the Organize menu. 
Works tells you which field you’re sorting on, and gives you a choice of 
sorting sequences. 

\ 
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The field you selected is reflected in the dialog box. 

Organize Format Report Macro 

Sort the Document on This Field: 

Team 

<•> From fl to Z 
O From Z to fl 

O from (I to 9 
O from 9 to 0 

O f hronological 
O Rfruerso Chronologic at 

[ Cancel ] 

upplier ?[ Availabl 

[May, June 

j May, June 

[May , June 

i May, June 

I May|, June 

jJanuary 

iAugust, S< 

: May, June 

[May , June 

[May, June 

[May, June 

jMayi, June 

[May , June 

[May, June 

[May , June 

[May, June 

iMay, June jijijj 

jMay, Junef 

5 

Junef^V 

ID Click the appropriate sequence. 

0 Click the OK button. 

Works sorts the entire document based on the field you specified. 

In this example, the sorted document looks like this: 

r , 

* File Edit Windouj Organize Format Report Macro 

1 Argentina 

Repeat the procedure for any other fields you want to sort on. 
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To find information 
quickly 

Finding Information Quickly 

Sometimes you need to locate specific information in a Database document. 
For example, suppose you want to find the entries in the Requests sample 

document that mention “Pressed Duck.” 

To find the entries: 

□ Choose Find Field from the Organize menu. 

Works displays a dialog box. 

[2] In the text box, type the information you’re looking for. 

[H Click the Find Next button. 

Works highlights the first entry that contains your information. When Works 
looks for the information, it searches all fields in one record, then searches 

the next record, and so on. 

Edit Windom Organize Format Report Macro 

Argentina 

Australia 

Austria 

Brazil 

Canada 

China 

Denmark 

Egypt. 
England 

France 

Germany 

Greece 

6 

8*' 

"'s'' 
's'" 

J..I 
6 

6 

I.7.I 
8 

.5” 

|Steaks. 

iBarbequed Shrimp 

I Wiener Schnitzel 

| Lamb 

jPea Soup 

jjpressed Duck 

: Poise 

j Dates’ 

jFish and Chips 

i Bouillabaisse 

iBrezen 

iMoussaka 

$7.20 

$6.10 

$4.25 

$5.60 

$'126 

$5.90 

"$4.60 

$205 

$5.40 

"$rso’“ 
”$r.‘io" 
'$3.95 

|Ves 

]Yes'" 

"[Yes" 

jYes 

:No 

]Yes" 

]:No"'" 

jNo 

IYes 

"lYes 

iYes 

IMay, June 

! August, S' 
i May, June 

:May, June 

iMay, June 

iMay, June 

I May { June 

jJuly, Augt 

iMay, June 

IMay, June 

jMay, June 

iMau, June 

To continue finding entries that contain the information you specified, choose 
Find Field again. The characters you typed will still be in the text box, so 

you just click the Find Next button. 

Matching Records 

The Match Records command is a shortcut to seeing a subset of a Database 
document. You type a few characters or words and let Works match the 
records that contain that information. When Works is done, you will be look¬ 
ing at only those records that contain the information you specified. 
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You don’t have to type an entire word or number—just enough information 
to begin a match, like “Chi” when you’re searching for records containing 
“Chicago”. 6 

Suppose you want to find all the records that contain the word “Hillside” in 
the Addresses Database document: 

E Choose Match Records from the Organize menu. 
Works displays a dialog box. 

E In the text box, type the information you want Works to look for. For this 
example, you would type Hillside 

E Click the OK button. 

Works displays any records that contain your information. If Works can’t 
find the information, an alert box is displayed, and you can try again. 

All records that contain Hillside 

* File Edit Windotu Organize Format Report Macro 

/ - 

□- 
First Name |Last Name |Title 

Addresses (DB) —■ = 

Address |City (state |zip 
HE 
Hon 

m 
wm 

- Paul : Vinthrop :Mr. 1122 Haught Dr. ! Hillside is— 110800 (91 < 
Shirley :Hanes :Ms. 2310 Hillside Dr. iNew Orleans :LA : 701 01 (50< L Jeanne :Barnes ;Ms. 1301 Cherry Lane (Hillside !ny 

_ _L_!_!_j 

With the Match Records command, you can scroll displayed records and 
view them in a form window. You can also cut, copy, or clear the informa¬ 
tion, remove the grid, and print the window. 

To be able to see all the records and use other Database commands, you must 
go back to the full Database document. 

s Choose Match Records again to remove the checkmark on the menu. 

Works displays all your records and makes all Database commands available. 

To find matching 
records 

To see all records 
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Using selection rules 

Parts of a selection 
rule 

Using Selection Rules 

When you’re looking for very specific information, you can set up record 
selection rules. Works follows your selection rules as it searches for the 
information you want. Then Works shows you only those records that meet 
your selection rules. Selection rules are especially useful when you want to 

print your information in a report. 

How Selection Rules Work 

Record selection rules aren’t as complicated as they may sound. You go 
through a record selection process yourself when, for example, you look in 
your address book for people who work in San Diego. You tell yourself, 
“Look for people who are business associates and work in San Diego.” Or, in 
the language of selection rules: “Type” field contains Business, and Loca¬ 

tion” field contains San Diego. 

In the same way, you use selection rules in Works to find information that 
meets your criteria, usually to make some sort of decision. For example, the 
auditor of a department could have Works find all months in which the 
department director spent over the allotted $300 per month and months in 
which the director traveled frequently, to see the impact of travel on the 

budget. 

A record selection rule is made up of three components: a field name, a com¬ 
parison phrase, and some record comparison information. The field name 
corresponds to a field in the active Database document. The comparison 

phrase comes from the following list: 

■ equals 

■ is greater than 

■ is greater than or equal to 

■ is less than 

■ is less than or equal to 

■ is not equal to 

■ is blank 

■ is not blank 

■ contains 

■ begins with 

■ ends with 

■ does not contain 

■ does not begin with 

■ does not end with 

For text fields, all of the above phrases are available. For numeric, date, or 

time fields, the first eight phrases are available. 

You type the record comparison information that Works will use. 
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To make a simple record selection rule: 

0 Choose Record Selection from the Organize menu. 

A dialog box appears containing the fields in your Database document, a 
list of comparison phrases, and a box in which to type record comparison 
information. 

To make a simple 
selection rule 

Fields in the open Database 
document 

6 File Edit Window I Organize 

Comparison phrases 

| Format Report Macro 

\ 
Record Selection: 

Requested Food 
Local Supplier? 
Ruailable 
Number on Team R> 

\ contains 
^ begins with 

is greater than 
[is greater than or equal to 

/' 

Record Comparison Information: 

/Selection Rules: No Rules fire In Effect 

O and O Or 

O find O Or 

O and O Or 

O ftftd O Or 

O ftnd O Or 

Cancel Delete Rule Install Rule ) c Select 

Selection rules are displayed here. Comparison information 
goes here. 

E From the left box, select the field you want Works to use in the 
comparison. 

You may have to scroll to see all the fields in the box. 

0 From the right box, select the appropriate comparison phrase. 

You will need to scroll to see all the phrases. 

S Type the record comparison information in the space provided. 



H] Click the Install Rule button. 

Works displays the completed selection rule. 

* File Edit Window Organize I Format Report Macro 

Record Selection: 
is greater than 
is greater than or equal to 
is less than 
is less than or equal to 

Record Comparison Information: 

Selection Rules: Local Supplier? is notxequal to VES 

Oflnd ®0r 

o Rml O or 

O Rml O Or 

O find O Or 

O find O Or 

[ Cancel ) Delete Rule [ Install Rule 

After you click Install Rule, Works 
blanks out the Record Comparison 

Information box, so you can type 
something else for the next rule. 

0 Click the Select button to have Works find the records that meet your 

selection rule. 

Works searches through your Database document looking for records that 
match up. It then displays just those records. If Works doesn’t find matches, 

it displays an alert box. 

When you’re looking at selected records, you see a subset of the total Data¬ 

base document. The rest of the records are still in memory. 

If you want to look at all your records again, choose Show All Records from 
the Organize menu. If you’d like to turn your selection into a separate Data¬ 
base document, see “Saving a Selection with a Different Name” at the end of 
this chapter. You might want to do this if you made a selection in order to 
give someone a subset of your Database document, or to make mailing labels 

from a subset of your document. 
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Setting Up More Complex Rules 

A single selection rule helps to find information — but with Works, you can 
be much more specific. Connectors (“And” and “Or”) let you link together up 
to six selection rules. v 

After you set up a single selection rule, but before you carry out the selection 
with the Select button, Works presents you with these two connectors to 
choose from: 

Setting up more 
complex rules 

Using connectors 

■ And lets you link together multiple selection rules. Each additional rule 
eliminates more of the records in your Database document, so you zero in 
on the ones you need. When you use “And” between two selection rules, 
Works selects only those records that satisfy both rules. 

■ Or lets you choose between multiple selection rules. If a record doesn’t 
match the first rule, it might match the second or third. 

You can use these connectors separately or in combination. For example, a 
developer examining real estate holdings in El Paso might use selection rules 
like these: 

Location equals El Paso 

And Type equals Shopping Center 

Or Location equals El Paso 

And Type equals Residential 

These rules eliminate all other properties, such as office buildings or hotels, 
and all properties not in El Paso. Notice that the following set of rules would 
not produce the same result: 

Location equals El Paso 

And Type equals Shopping Center 

Or Type equals Residential 

Because the “And” connector takes precedence over the “Or” connector, this 
set of rules would select records containing shopping centers in El Paso! and 
all residential properties (regardless of location). 

You can also use connectors to extend a comparison, setting up a range of 
items, rather than a single item, to match. An example of a range is: 

Sales are greater than $100,000 

And Sales are less than $1,000,000 
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To add further rules 

To change part of 
a rule 

To add further rules to your original rule: 

H If you already clicked the Select button after installing your first rule, 
choose Record Selection from the Organize menu again. Otherwise, 

you’re ready to add another rule. 

(E Click And or Or. 

[3] Select a field name. 

0 Select a comparison phrase. 

00 Type the comparison information. 

U] Click the Install Rule button. 

| The next set of connectors becomes available. 

r 6 File Edit niiniinm Format Report Macro 

Team £ 
Requested Food 
Local Supplier? _j 

l equals 
m hi 

begins with 
is greater than || 
is greater than or equal to O Number on Team K 

Record Comparison Information: 1 

\ 
Selection Rules: Local Supplier? is not equal to YESj 

Available contains MAY O And ® Or 

\{Oflnd ® Or 

O and 0»f 

O and O Of 

O and Onr 

[ Cancel J f Delete Rule ) [ Install Rule ) 

All installed rules are displayed here. 

You can continue to add rules in this manner until the dialog box is full. 
When you’re done, click the Select button to select the records that match 

your selection rules. 

Changing Your Mind 

If you make a mistake or decide not to make a particular selection, or if you 
just want to see all the records, you can cancel the record selection rules or 

make new ones. 

Until you click the Install Rule button, you can change any part of your rule. 

To change part of a rule: 

[i] Select different items from the list boxes or type new comparison infor¬ 

mation before you click the Install Rule button. 
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To remove a rule after you click the Install Rule button: 

[■] Click the Delete Rule button. 

Works erases the last installed rule. You can repeat this step for as many 
rules as you have. 

To see all of your records: 

[■] Choose Show All Records from the Organize menu. 

Saving a Selection with a Different Name 

If you have a main Database document that you use to store most of your 
information, you can create several smaller documents from it. The smaller 
documents would contain subsets of the information in the main Database 
document. 

For example, a subset of a customer list might contain shipping addresses for 
the northeast region. If you save the northeast region data alone in another 
file, you can print mailing labels for northeast customers using a form in the 
Word Processor. For more information, see Chapter 21, “Merging: Creating 
Mailing Labels, Form Letters, and Forms.” 

To create a subset of a Database document: 

0 Use the Record Selection command from the Organize menu to display 
only the records you want to include in the smaller document. 

E Delete any fields you don’t need in the smaller document. 

0 Choose Save As from the File menu. 

The Save As dialog box appears, giving you a chance to save the infor¬ 
mation with a different name or on a different disk. 

E Type a new name for the smaller Database document. 

E Click the Save Selected Records Only option. 

E Switch to another disk, if you want. 

E Click the Save button. 

Works saves the smaller Database document with the name you just typed. 
The original document remains safely on the disk, unchanged. If you want to 
work with the new subset of data, you need to open the new file. 

Note This is a special case for the Save As command in which the newly 
saved document does not replace the existing document on the screen. This 
lets you save subsets of a large Database document without affecting the data 
currently in memory. 

To remove a rule 

To see all records 

To create a subset 
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You print information from a Database document in a report To print a 

2“"’ I°Ut neef i° firSt sf up a report definition. This definition specifies 

f a"f °r,mat °f 3 partlcular rePort- A rePort is a printed listing, in 
tebu ar form of either a selected subset of information in a Database docu¬ 
ment or all the information. You can set up several different report defini¬ 
tions for each Database document, depending on the information you need 
by selecting certain records or including only particular fields. 

™DaSfe'YoSSk™ tow'te ‘ a"d “* reP«s *“> 

Set up a report definition in a report window, including specifying fields 
to be totaled. You’ll also learn how to store the definition with the Data¬ 
base document, so you can print updated reports without having to set up 
a new report definition each time. 6 ^ 

■ Copy subtotals and totals to the Clipboard to review the numbers before 
printing, or to use the numbers in a Word Processor or Spreadsheet docu- 

■ Prepare your information and print a report. 

■ Work with reports by selecting and changing a previously defined 
You II also learn how to duplicate and delete a report definition. 

report. 
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A report prints a table of information, with a record on each row, like this. 

Requests Report 

Team Number on Team 

Argentina 6 
Australia 8 
Austria 5 
Brazil 5 

China 7 
Denmark 6 
Egypt 9 
England 6 
France 7 
Germany 8 
Greece 5 
Holland 4 
India 6 
Italy 5 
Mexico 7 
New Zealand 6 
Spain 6 
Sweden 5 
Thailand 4 
USA 10 

Requested Food 

Steaks 
Baibequed Shrimp 
Wiener Schnitzel 
Lamb 
Pea Soup 
Pressed Duck 
Poise 
Dates 
Fish and Chips 
Bouillabaisse 
Brezen 
Moussaka 
GoudseKaas 
Samosas 
GnoccN 
Tostadas 
Kiwis 
Tapas 
Knackebrod 
Peanut Chicken 
Hamburgers 

Cost ner Person 
$7.20 
$6.10 
$4.25 
$5.60 
$1.20 
$5.90 
$4.60 
$2.05 
$5.40 
$1.50 
$1.10 
$3.95 
$2.95 
$2.05 
$4.75 
$5.00 
$2.70 
$4.35 
$1.95 
$5.25 
$5.10 

Local Supplier? 

Yes 
Yes 
Yes 
No 

Yes 
No 

Yes 
No 
No 

Yes 
Yes 
Yes 
Yes 
No 
No 
No 
No 

Yes 
Yes 
Yes 
Yes 

1 

For information on other ways to print Database information, see Chapter 21 

“Merging: Creating Mailing Labels, Form Letters, and Forms.” 
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Before You Begin 

Before you open a report window and start defining a report, you should 
understand the relationship between report definitions and the open Database 
document. When you choose New Report from the Report menu, Works 
opens a window displaying a report definition that consists of selection rules, 
the order and width of fields, and field sums. 

When you choose New Report to create a new report, the initial information 
in the report window comes from the open Database document. Changes you 
make to the report definition will not affect the Database document itself. 
This feature allows you to define numerous independent reports, each con¬ 
taining different information. 

Since the initial values for a report definition are taken from the open Data¬ 
base document, you can set up initial record selection rules and field widths 
for a report definition in either a list window or a report window. 

To set up a new report definition, you’ll choose the New Report command 
and follow these steps: 

■ Specify headers and footers, paper size, printing orientation, and margins 
with the Page Setup command from the File menu. 

■ Create or review any record selection rules, and make any necessary 
changes. 

■ Size and arrange fields, and specify which fields to print by changing the 
right margin in the Report window. 

■ Specify any fields to sum, using the TotalsPage menu. 

■ Specify when to subtotal groups of records, using the TotalsPage menu. 

■ Specify when to start a new page after a subtotal, using the TotalsPage 
menu. 

■ Specify whether or not to print a grid, using the Format menu. 

■ Give the report a new title if you want. 

Working in a report 
window 

Setting up a new 
report definition 

All of this information makes up your report definition. The rest of this 
chapter details the procedures. 

Setting Up a Report Definition 

A report definition tells Works what information to print from a Database 
document. You use record selection rules to choose just the records that meet 
the criteria for your report. For example, if you’re looking at credit ratings 
for customers, you can print a report of just those customers whose bills are 
90 days past due. 
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To define a new 
report 

Because you might want to print several different reports from the same 
Database document, Works lets you store up to eight report definitions with 
each document. Whenever you want to print a report, you choose one of the 
report definitions and print the report. 

To define a new report: 

® Choose New Report from the Report menu. 

Works displays the report window and adds the TotalsPage menu to the 
menu bar. 

The upper area of the report window 
displays selection rules. Zoom box 

Report window Report title New menu 

r * File Edit, Window Organize Format TotalsPage Macro 

- Requests Report 1 — 

Selection Rules: Local Supplier? equals YESl 
or Available contains MAY /\ 

■ l°> , ■ i i . i Pi i i i i i i l2i i i 1 i i i l3i i i 1 i i i l4i i i 1 i i I5i i i i i ■ i l6i i i i i i 
. K 

Teahv 1 Number on Team |Requested Food | Cost per Person |Local Supplier?! Availa 

. USA \ 

. France 

. England 

. Germany 

. Austria 

10 i Hamburgers j $5.10. 

7 : Bouillabaisse $1.50 

6 ; Fish and Chips $5.40 

8 iBrezen $1.10 

5 :Wiener Schnitzel i $4.25 

|Yes :May,ji. 

I Yes 

|No ;May,Jt 

!Yes iMay, Ji 

:Yes ;May, Jt 

■ 5TI 1 T TC> a 

Mexico .1.7.Ifostadas. $5.66 |No iMay 

JU1RT :niyu hi poi 

, June jFull meal 

Left edge 
marker 

Selection rules in effect are carried 
over from the Database document. 

Once in a report window, you can set up selection rules. But you cannot use 
the mouse to select records or entries. You can select only individual fields. 
To change the selection from one field to another, just click the field name 
you want to select. 
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Setting Up Paper Size, Printing Orientation, Headers 
and Footers, and Margins 

Use the Page Setup command from the File menu to set up your report page. 
Paper size, printing orientation, and margins determine the amount of infor¬ 
mation that can be printed for each record. 

You will want to use wide orientation if you want to print more fields in your 
report than will fit on a standard 8-1/2" x 11" page. 

You’ll be able to see your right margin by looking at the right edge marker (a 
sideways triangle beneath the ruler) in the report window. 

Works prints everything inside the right report margin. Anything outside the 
right report margin won’t be included when you print your report. 

The right margin is based on the page width and right margin set in the Page 
Setup dialog box. To print the fields you want, change the right margin by 
dragging the right marker in the report window. 

Note You can’t move the right margin beyond the margin set in the Page 
Setup dialog box. For example, if page size is set at 8.5 inches, and your 
right margin is 1 inch, you won’t be able to move the triangle beyond 7.5 
inches. To decrease your right margin, change the settings in the Page Setup 
dialog box. 

For complete information about using the Page Setup command, see “Page 
Setup” in Chapter 2. 

Arranging the Fields to Print 

When preparing a report definition, you decide what order to put the fields in 
and which fields to include in the printed report. Once you have made these 
decisions, you may need to either adjust some field widths or adjust the mar¬ 
gins of your report. 

Before you begin, look at the report window and locate the edge markers. 
The two markers — sideways triangles — show you how wide your report will 
be. You determine where the left marker is when you set the left margin in 
the Page Setup dialog box. You can set the right marker in the Page Setup 
dialog box, or you can move it in the report window. When you print the 
report, fields, or parts of fields to the left of the right edge marker are 
included in the report. 
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To rearrange fields 

To move fields in and 
out of a report 

You can rearrange the horizontal position of the fields to be printed. 

To rearrange fields: 

[I] Drag the field name left or right until the field name of the field you want 
to be adjacent to is highlighted. 

If you have many fields in your Database document, some of them may not 
fit within the margins of your report. You can take unwanted fields out of a 
report in three ways: 

■ Rearrange the fields. 
If an unwanted field is in the report and a field you want to print is not, 
you can rearrange the fields so that the unwanted field is no longer inside 
the right margin. 

■ Drag the right edge marker to the left to leave out the unwanted fields. 

If the unwanted fields are to the right of the fields you want to print, you 
can drag the right edge marker to the left until the unwanted fields are 
outside the right margin. 

■ Widen the fields that you want to print. 
If the unwanted fields are to the right of the fields you want to print, you 
can drag the pointer on the right edge of the field name box to widen the 
fields you want to print. 

These fields are 
included in the report. 

These fields are not 
included in the report. 

6 File Edit Window Organize Format TotalsPage Macrt 
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Using the TotalsPage Menu 

Your Database document might be enhanced by including totals that are sums 
of a column of numbers. For example, a payroll report might sum the total 
payroll. Works also lets you set up subtotals, such as payroll per department, 
in addition to the total payroll. With the TotalsPage menu in the Database, 
you can select fields to be totaled or subtotaled. You can review the totals 
before printing the report, and you can create summary documents with just 
this totals information. 

When you use the TotalsPage menu to specify totals, subtotals, or new 
pages, the commands in effect for a selected field are checked in the menu. 
To change your specifications, select the field and choose any command 
again to remove the checkmark. 

The simplest total sums all the numbers in a field. 

To total a field: 
To total a field 

0 Select a numeric field that you want totaled. 

0 Choose Sum This Field from the TotalsPage menu. 

6 File Edit UJindom Organize Format TotalsPage 

Sum This Field 

Macro 

Requests Re 

Selection Rules. Local Supplier? equal 
or Available contains MA 
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The total for that field will appear at the bottom of the field when you print 
the report. 

For fields that you’ve specified to be totaled, you can also specify two kinds 
of subtotals. In both cases, you will get more meaningful results if you sort 
your records before specifying the subtotals. 
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To subtotal when field 
data changes 

To subtotal when the 
first character in a 
field changes 

To print a new page 
after a subtotal 

You can set up a report to print subtotals whenever there are changes in the 
contents of a specified key field. Many Database documents can be organized 
into divisions or groups. For example, payroll can be divided into depart¬ 
ments. For a payroll Database document, you might want a subtotal when¬ 
ever the department name changes. In this case, the field containing depart¬ 
ment names would be the key field. 

Here’s how to set up such a subtotal: 

m Select a numeric field that you want to subtotal. Just click the field name. 

0 Choose Sum This Field from the TotalsPage menu. 

0 Select the key field that you want the subtotals based on. 

0 Choose Take a Sub-Total on Field Change from the TotalsPage menu. 

When you print the report. Works will print a subtotal every time the key 
field’s contents change. For example, in a payroll report, you’d get a subtotal 
after all the entries for Manufacturing, and another after all the entries for 
Sales, and so forth. Then, Works prints a grand total at the end of the report. 

You can also set up a report to print subtotals whenever the first character in 
a specified key field changes. For example, you might want to get subtotals 
for each group of records having an entry in the last name field beginning 
with the same letter, so that you subtotal A’s, B’s, C’s, and so on. 

To set up this kind of subtotal: 

ITl Select a numeric field that you want to subtotal. Just click the field name. 

0 Choose Sum This Field from the TotalsPage menu. 

0 Select the key field that you want the subtotals based on. 

0 Choose Take a Sub-Total on 1st Char from the TotalsPage menu. 

When you print the report, Works will print a subtotal each time the first 
character of the entries in the key field changes. 

To make reports easy to read, you may prefer to start a new page after print¬ 
ing each subtotal. That makes a subtotal the last printed line on each page. 

To start a new page after each subtotal, first complete either of the two pro¬ 
cedures shown above for specifying subtotals. After you choose either Take a 
Subtotal on Field Change or Take a Sub-Total on 1st Char: 

0 Choose New Page After Total from the TotalsPage menu. 

When you print the report, Works will skip to a new page after it prints each 

subtotal. 
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Printing with or without a Grid 

Works normally prints a grid separating the records and fields in a report. If 
Show Grid is checked in the Format menu, Works displays and prints the 
grid. If Show Grid is not checked, Works doesn’t display or print the grid. 

To print the report without a grid, if Show Grid is checked: 

® Choose Show Grid from the Format menu. 

To print the grid, choose Show Grid again. 

Changing Font, Size, and Color 

Works normally prints your report using a black 9-point Geneva font. If you 
want to change the font, size, or color, choose the appropriate command 
from the Format menu. 

For more information on these commands, see “The Format Menu” in 
Chapter 2. 

Font, size, and color changes affect all the data in the report. Each report can 
have a different font, size, and color. If you change the report’s font or size, 
you may need to adjust your field widths or report margins. 

Changing a Report Title 

Works proposes a title for a report based on the name of the associated Data¬ 
base document. You can change this title at any time to make it more mean¬ 
ingful to you. 

To change a report title: 

0 From the report window, choose Change Report Title from the Edit 
menu. 

0 Type a new name in the space provided. 

0 Click the OK button. 

Storing a Report Definition 

After you have completed a report definition, you can choose to preview any 
subtotals or totals you may have specified (see the following section, “Pre¬ 
viewing Report Totals”), print the report immediately, use the Window com¬ 
mand to return to a list or form window, or close the report window. When 
you close the report window, Works stores the report definition with the 
associated Database document. When you later save the Database document, 
the report definition is saved along with it. 

To change font, size, 
and color 

To change a report 
title 
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Previewing Report Totals 

To preview totals 
before printing 

After setting up your report definition, if you’ve specified fields to be 
summed, you can preview the totals and subtotals before you print the report. 

To preview the totals: 

[■] From the report window, choose Copy Totals from the Edit menu. 
Copy Totals is available only after you have specified at least one field to 

be summed. 

When you specify subtotals with the Take a Sub-Total on Field Change com¬ 
mand, Works copies the records containing subtotals and the grand total to 
the Clipboard. When you specify subtotals with the Take a Sub-Total on 1st 
Char command, Works copies the first record of each group to the Clipboard, 
substituting the subtotal of each entire group for the number related to each 
particular record. You can then open the Clipboard to see this information. 

Note You can also preview the totals by selecting Print from the File 
menu, clicking the Print Preview option, and then clicking the OK button. 
If the totals are on another page, click Next until they come into view. 

To create summary 
documents 

If you use Copy Totals to copy data to the Clipboard, you can use the data 
just like anything else on the Clipboard. For example, you can paste the 
information into a Word Processor or Spreadsheet document to create a sum¬ 
mary document containing just the totals information, without all the support- 

ing numbers. 

Printing a Report 

To print a report There are three stages in printing a report: preparing the information, opening 
a report window, and printing the report. 

To prepare your information: 

□ Open the Database file from which you want to print a report. 

[3 Sort the records so they appear in the order you want. 

[3 Review any formatting characteristics specified with the Set Field attri¬ 

butes command. 
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To open a report window: 

m 

0 
0 

0 

Choose Select Report from the Report menu. 

The Select Report dialog box appears, containing a list of all reports that 
you ve defined for the active Database document. 

Select the name of the report that you want to print. 

Click the OK button. 

Works displays the report window. 

Make any changes to the definition. 

To print the report: 

0 Choose Print from the File menu. 

0 Review the options to make sure they’re all set as you want them, and 
make any necessary changes. 

0 Click the OK button. 

Works prints your report. If your printer is disconnected 
paper, Works displays a message. 

or you run out of 

Working with Reports 

Many businesses and professionals print regular revisions of reports — 
address lists, customer lists, or payment overdue lists, for example. The first 
time you define such a report may be the only time you need to, because you 
can select that same report definition each time you print the report As long 

as your Database document contains the fields contained in the report defini 
tion, there s nothing else to worry about, even if the contents of the fields 
change completely. 

It’s easy to switch between a report window and a list or form window by 

using the Window and Report menus. Remember that any changes you make 
m the report window apply only to that report —they are not carried back 
into the list or form window. Each report can use its own set of record selec- 
don rules. This relationship also holds true for the order and width of fields 
which can be adjusted in the report window with no effect on the Database 
document. 
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To select a previously 
defined report 
definition 

To select a previously defined report definition: 

0 Sort or rearrange records in the Database so they’ll print in the desired 

order. 
0 Choose Select Report from the Report menu. 

The Select Report dialog box appears. Any reports that you’ve defined for 
the active Database document appear in the box. 

0 Click the name of the report definition that you want. 

0 Click the OK button. 

The menus change in the menu bar, and Works displays the report definition 

you’ve selected. 

Changing a report 
When a report definition window is active, you can change the definition or 
you can print the report as specified. For example, you can rearrange fields, 
change the selection rules, or add or change totals. The changes you make 
will be stored with the associated Database document. When you save the 
Database document, the report definition will be saved along with it. 

To duplicate a report 
definition 

Duplicating and Erasing Report Definitions 

You may want to copy a previously defined report definition, rather than 
create another report definition from scratch that’s only slightly different. 
You can have up to eight report definitions for any Database document. If 
you already have eight, you’ll need to erase one definition in order to add 

another. 

To duplicate a report definition: 

0 In a form or list window, choose Duplicate Report from the Report menu. 

0 Select the report definition you want to duplicate from the list. 

0 Click the OK button. 

Works duplicates the report definition, displays it in a report window, and 
gives it a name. The name of the report consists of the name of the Database 
document, the word “Report,” and a number indicating how many reports are 
connected with that Database document. You can now make changes to the 

duplicate to create a new report. 

To erase a report 
definition 

To erase a report definition: 

0 In a form or list window, choose Erase Report from the Report menu. 

0 Select the report definition you want to erase. 

0 Click the OK button. 

Works erases the report definition. 
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Reference 

The Apple, File, Window, and Macros menus are identical for all Microsoft 
Works tools. For information on these menus, see Chapter 2, “Common 
Tasks Command Reference.” 

This chapter discusses all the shaded commands shown below. 

Edit 

Undo 38Z 

Cut §§H 
Copy 38C 
Paste 
Clear 
Select Rll 

38U 

Br»u»On m 

Paste Function... 

Insert Record 381 

Change Field Name... 
Add Neiii Field... 
Delete Field 

Format 

Shorn Form 38L 

✓Show Grid 

Font ► 
Size ► 
Color ► 

Set Field Attributes... 

Organize 

Find Field... 38F 

Match Records... 38M 

Record Selection.. 
✓Show Rll Records 

Sort... 38R 

Report 

Select Report... 
New Report... 
Duplicate Report... 
Erase Report... 

Format 

Shorn List 38L 

✓Bold Field Name 
Bold Field Data 

✓Border Field Name 
✓Border Field Data 

Font ► 
Size ► 
Color ► 

Set Field Attributes... 
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When the New Report command is chosen from the Report menu, the Edit 
and Organize menus contain additional commands, the Format menu changes, 
and the TotalsPage menu is added to the menu bar. 

Edit 

Undo 3€Z 

Cut 
Copy Totals 98C 
Paste 
Clear 
Select nil 

Oram On m 

Change Report Title... 

Organize 

I Record Selection... 
[yShoiAi Oil Records 

Format 

✓Show Grid 

Font ► 
Size ► 
Color ► 

TotalsPage 

Sum This Field 

Take a Sub-Total on Field Change 
Take a Sub-Total on 1st Char 

Nero Page After Total 

You can invoke some Works commands from the keyboard, as well as by 
using the mouse. The available Command + key combinations are shown in 
the menus and in Appendix D. 

An alphabetical list of commands appears in the index under “Command.” 

The Edit Menu 

The first six commands in the Edit menu are common to all Works tools. For 
information on these commands, see “The Edit Menu” in Chapter 2. 

This section explains additional Edit menu commands that are available in the 
Works Database. 
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Paste Function Paste Function 

The Paste Function command inserts a built-in function into the entry bar, if 
the selected field is a computed field. Computed fields are set using the Set 
Field Attributes command in the Format menu. 

Select the field to contain the function. Click in the entry bar where you want 
to insert the function, and choose Paste Function. Works displays a list box, 
which contains a list of all available Works functions. You can use all 
Spreadsheet functions in the Database, except for functions that use ranges as 
arguments. For information on specific functions, see Chapter 15, “Spread¬ 
sheet and Database Functions.” 

Paste Function: 

RCosO 
RndO 
ASinO 
HTanO 
ATan2() 
AuerageO 
Choose!) 5 

[ Cancel ] [[ OK 

Edit 

Undo §§Z 

Cut 
Copy 9§C 
Paste 
Clear 
Select Rll 

0rout On I 

Paste Function... 

Insert Record 3§l 

Change Field Name... 
Add New Field... 
Delete Field 

To paste a function, select the function you want from the list, and then click 
the OK button. 

If the entry bar is inactive, Works activates it and pastes an equal sign ( = ), 
followed by the selected function. If the entry bar is active, Works pastes the 
function at the insertion point. 

If you don’t type an operator after the preceding operand, Works adds a plus 
sign ( + ) before the pasted function. Works also pastes the required 
parentheses, with the insertion point between them, so you can enter the 
function’s arguments. 

For information on specific functions, see Chapter 15, “Spreadsheet and 
Database Functions.” 
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Insert Record Insert Record 

Edit 

Undo 3§Z 

Cut m\\ 
Copy 9§C 
Paste §§U 
Clear 
Select Rll 

Dram On m 

Paste Function... 

Change Field Name... 
Rdd Neui Field... 
Delete Field  

The Insert Record command inserts a blank record immediately before the 
selected record in a list window or before the record currently displayed in a 
form window. In a form window, the command is dimmed until you make a 
selection. 

Change Field Name Change Field Name 

Undo m2 

Cut m\\ 
Copy me 
Paste 
Clear 
Select Rll 

Dram Dn m 

Paste Function... 

Insert Record 

The Change Field Name command changes the name of a field. 

To change a field name, either select a field and choose Change Field Name, 
or double-click a field name in either a list or form window. 

Field Name: 

Untitled 1 

f Cancel ) 

Type the new name in the Field Name box, then click the OK button. 
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Add New Field 

The Add New Field command adds a new field to a list or form window. 

Add New Field 

Field Name: 

[ Cancel 

Type a name for the new field, then click the Add Field button. 

In a list window, Works adds the field to the right of the rightmost field. In a 
form window, Works adds the field in the first blank area it finds that is 
large enough to accommodate a field. 

In either kind of window, you can move the field wherever you want. You 
can add a field at any time. 

Delete Field 

The Delete Field command deletes a field, including both the field name and 
the data in the field, for all records. 

First, select the field to be deleted by clicking the field name. You can do 
this in either a list or form window. In a list window, Works highlights all 
the data in the field; in a form window, Works highlights the data for the 
displayed record. Then, choose Delete Field to delete the field. 

You can undo Delete Field immediately after you use it with the Undo com¬ 
mand from the Edit menu. 

Undo 8§Z 

Cut 
Copy 3§C 
Paste 
Clear 
Select flll 

mu 

Draw On m 

| Paste Function... 

| Insert Record „ 

| Change Field Name... | 
Add New Field... 

| Delete Field 

Delete Field 

Undo 3§Z 

Cut 3§H 
Copy 3§C 
Paste 
Clear 
Select Rll 

m 

Draw On =f!Ui 

Paste Function... 

Insert Record mi 

Change Field Name... 
Rdd New Field... 
Delete Field 
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The Organize Menu 

Find Field Find Field 

Match Records... a§M 

Record Selection.. 
^Shouj Rll Records 

Sort... *:R 

The Find Field command finds and selects, one at a time, all fields in a Data¬ 
base document that contain a specified pattern of characters. 

When you choose Find Field, Works displays a dialog box in which you can 
type the character pattern that you want to find. 

Find Next Field That Contains Type the character pattern you want to 
find. 

Search Text Fields Only This is checked as a preset option. It speeds 
your search for text in a document containing many numeric, date, or time 
fields. If you want Works to look in all fields, click this option to remove the 
checkmark. 

Click the Find Next button or press the Return key to start the search. Works 
selects the first entry that matches your criteria. To find the next and succes¬ 
sive occurrences of the specified pattern, choose Find Field again. The text 
you typed will already appear in the text box, so you only need to click Find 
Next or press the Return key to restart the search and have Works select the 
next occurrence. 

Match Records Match Records 

irganize 

Find Field... §€F 

Match Records... #M 

Record Selection... 
v'Show Rll Records 

Sort... §€R 

The Match Records command finds and displays all records in a Database 
document that contain a specified pattern of characters anywhere in the 
record. 

When you choose Match Records, Works displays a dialog box in which you 
can type the character pattern that identifies the records you want to find. 
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Match Records That Contain Type the character pattern you want 
to find. 

Search Text Fields Only This is checked as a preset option. It speeds 
your search for text in a document containing many numeric, date, or time 
fields. If you want to look in all fields, click this option to remove the 
checkmark. 

Click the OK button or press the Return key to start the search. Works 
displays only those records containing the pattern. To end the command and 
display all records again, choose Match Records again. 

When you choose Match Records from a form window, Works displays the 
records in a form window, and you can scroll through them. 

When you choose Match Records from a list window, Works displays the 
records in a list window, and you can scroll through them. If you double¬ 
click a record in the list, Works displays that record in a form window, and 
the Match Records command ends. 

Record Selection 

The Record Selection command defines up to six different selection rules by 
which records in a Database document are selected, and then finds and 
displays those records. You can then work with those records alone. 

Record Selection is useful in preparing reports or in creating other smaller 
Database documents with the Save As command. 

Record Selection 

Organize 

Find Field... 3£F 

Match Records... 3§M 

Record Selection... 

^Shour Rll Records 

Sort... §gfl 



To use Record Selection, you build one or more selection rules by selecting a 
field and a comparison phrase, and entering record comparison information. 
In the list box on the left, select a field on which you want Works to base the 
record selection. If you have more fields in your document than can fit in the 
window, scroll the window until you see the field you want. 

In the list box on the right, select the comparison phrase to use in your first 
record selection rule. Scroll the window to see all the available phrases. 
Notice that for text fields you have more phrases available than for numeric, 
date, or time fields. 

Record Comparison Information Type the text of your comparison 
information to complete the record selection rule. Then click the Install Rule 
button. 

If you want to extend your selection rules, or if you want to make your rule 
more specific, select a connector (“And” or “Or”) from those below and to 
the left of the completed rule and repeat the process of selecting a field, 
selecting a comparison phrase, and entering comparison information. 

You can have up to six record selection rules. 

Click the Install Rule button (or press Command +1) to install each new 
selection rule. Before you click this button, be sure to review the components 
of your rule. You can make any changes you want, including pressing the 
Cancel button, until you click the Install Rule button. Thereafter, you’ll need 
to delete the rule and start over to make any changes. 

When you are satisfied with your selection rules, and want to find records 
based on them, click the Select button. 

Click the Delete Rule button (or press Command + D) to delete the last rule 
you installed. 

Click the Cancel button to leave the Record Selection rules as they were 
before you chose the command and to return to the original Database 
document. 

If no records meet the rules you specify, Works displays an alert box. 

To turn off these rules and display all the records, click Show All Records 
from the Organize menu. 
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Show All Records 

The Show All Records command terminates the effect of the Record Selec¬ 
tion command and displays all the records in a Database document in either a 
list or form window. 

Sort 

The Sort command arranges all the records in a Database document in order 
based on the entries in a specified field. 

To select the field you want to sort on, either click the field name, or select 
one or more entries in the field. 

Sort the Document on This Field: 
Address 

<§) From A to Z 
O From Z to A 

O From (I to 9 
O From 9 to Cl 

O F ftronoloqicol 
O Aeuerso Chronologic of 

1 Cancel 1 |__OK_jJ 

Show All Records 

Organize 

Find Field... &F 

Match Aecords... 9§M 

Aecord Selection... 
■/Shorn fill Records 
. 

1 Sort... 9§A 

Sort 

| Organize IH 

Find Field... 3SF 

Match Records... 9§M 

Aecord Selection... 
/Shorn All Aecords 

Click an option to select the sequence you want. Then click the OK button or 
press the Return key. 

Note Each type of field —text, numeric, date, or time —has two possible 
sort orders: forward and reverse. For example, if you select a date field, the 
available options are Chronological and Reverse Chronological. 
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The Format Menu 

Show List 
Show Form 

✓Bold Field Name 
Bold Field Bata 

✓Border Field Name 
✓Border Field Data 

Font ► 
Size ► 
Color ► 

Set Field Attributes.- 

Bold Field Name 
Bold Field Data 

Format 

Shorn List 9§L 

✓Bold Field Name 

Bold Field Data 

✓Border Field Name 
✓Border Field Data 

Font ► 
Size ► 
Color ► 

Set Field Attributes..* 

Three commands in the Format menu — Font, Size, and Color are common 
to all Works tools. For information on these commands, see “The Format 

Menu” in Chapter 2. 

Show List/Show Form 

The Show List and Show Form commands tell Works what format to use in 

displaying your data. 
Choose Show List to view your data as a list of records in tabular form. This 
format allows you to see multiple records at the same time. If you have many 
fields, you may see only parts of records on your screen. To see other 
records or fields, use the scroll bars. 

Choose Show Form to view your data as a form with one complete record 

displayed. 
You can switch back and forth between these views at any time by choosing 
these commands from the menu. You can also switch views by double¬ 
clicking in the white space of a form window or in a record selector box in a 
list window. When you do the latter, the form window displays the record 
you selected. You can then scroll to see other records. 

Bold Field Name/Bold Field Data 

These commands display the field name, the field data, or both, in bold type 

in a form window. 

Choose Bold Field Name to make the field name bold. Choose Bold Field 
Data to make the data in a field bold. When chosen, the commands are 
checked on the menu. Choose the command again to remove the checkmark. 
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Border Field Name/Border Field Data 

These commands display a border around the field name, the field data, or 
both, in a form window. 

Choose Border Field Name to display the field name with a border. Choose 
Border Field Data to display the data in a field with a border. When chosen, 
the commands are checked on the menu. Choose the command again to 
remove the checkmark. 

Border Field Name 
Border Field Data 

Format 

Show List 8£L 

✓Bold Field Name 
Bold Field Data 

✓Border Field Name 

✓Border Field Data 

Font ^ 
Size ^ 
Color ^ 

Set Field Attributes... 

Show Grid Show Grid 

If the Show Grid command is checked in the Format menu, Works displays 
the grid lines in your Database document. If the command is not checked, 
Works does not display grid lines. This command is available in the list win¬ 
dow and the report window. 

Format 

Show Form 3§L 

✓Show Grid 

Font ^ 
Size ^ 
Color ► 

Set Field Rttributes... 

Set Field Attributes Set Field Attributes 

The Set Field Attributes command specifies the attributes of field data. You 
can set field attributes in both a list window and a form window. 

When you create a new field, the information in the field is treated as normal 
text, left-aligned. 

To specify the field attributes, select a field and choose Set Field Attributes, 
or double-click an entry. Works then displays a dialog box. 

Set Field Rttributes For Title 

Type: Display: Align: Style: 
(§)TeHt O General <§) Left □ Bold 
O Numeric O Fined O Center □ Underline 
O Date O Dollar O Right □ I! ommas 
OTime O Percent 

O Scientific 
^Decimal Places 

□ Computed □ Show Day ( Cancel ) ([ OK j| 

Format 

Show Form 3§L 

✓Show Grid 

Font ► 
Size t 
Color ► 

Set Field Attributes... 



Type Options 

Text Field data can be any alphanumeric characters. 

Numeric Field data must be numbers. 

Date Field data must be entered in one of eight specified date formats. For 
more information, see “Changing the Format of a Field” in Chapter 7. 

Time Field data must be entered in one of four specified time formats. For 
more information, see “Changing the Format of a Field” in Chapter 7. 

Computed If you define your data as Numeric, Date, or Time, you can 
specify that the contents of a field are to be computed by arithmetic opera¬ 
tions performed on numeric data in other fields. 

Click Numeric, then click the Computed box. When you leave the dialog 
box, the insertion point, preceded by an equal sign ( = ), is placed in the 
entry bar. You can then type a formula. 

Type a formula for a computed field using field names, numbers, and the fol¬ 
lowing symbols: 

Symbol Meaning 

+ Add 

— Subtract 

— Negate (if used with one operand only) 

* (asterisk) Multiply 

/ Divide 

() Group of operations 

A Raise to a power 

You can include all functions available in the Spreadsheet in a computed 
field, except those that require ranges for arguments. For more information, 
see Chapter 15, “Spreadsheet and Database Functions.” 

Instead of typing field names into a formula, you can also click them. 

Display Options 

General Values are displayed as precisely as possible, given the width of 
the entry. Trailing zeros are not displayed. 

Fixed Values are displayed with a fixed number of places to the right of 
the decimal point. 

Works uses Fixed format for all Database values unless you specify 
otherwise. 

The fixed number of decimal places is two, unless you change it using the 
Decimal Places option. 
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Dollar Values are displayed in dollars and cents format. Dollars are 
displayed to the left of the decimal point. Cents are displayed to the right of 
the decimal point with two digits, unless you change the number of digits 
using the Decimal Places option. A dollar sign ($) appears to the left of the 
most significant digit. 

Negative numbers are enclosed in parentheses. 

Type 0 in the Decimal Places box to display whole dollars with no decimal 
point. Type 2 to display dollars and cents. 

The value is adjusted to the nearest whole dollar or whole penny, depending 
upon your choice of 0 or 2 decimals. For example, the value 9.505 is 
displayed as $10 if zero decimal places are specified; it is displayed as $9.51 
if two decimal places are specified. 

Percent The numeric value of an entry is multiplied by 100 and displayed 
with a percent sign (%) to its immediate right. 

You can also specify the number of decimal places to be displayed in the per¬ 
centage. The value .156, for example, is displayed as 15.6% if you type 1 in 
the Decimal Places box, and 16% if you type 0. 

Scientific Scientific notation allows you to express very large or very 
small numbers. In scientific notation, a numeric value has three parts: a 
decimal number in the form n.nn, the exponentiation symbol E or e, and an 
integer in the form ±ii for the exponent. 

For example, the value 1,210 would be displayed as 1.2IE+ 03, where 1.21 
is the decimal number, E is the exponentiation symbol, and +03 is the 
exponent. 

Show Day If you define your field type as Date, you can specify that the 
day of the week be displayed as well. 

Decimal Places The number in this box specifies the number of digits to 
be displayed to the right of the decimal point, if you define a field as Fixed, 
Dollar, Percent, or Scientific. 

The preset value is 2. Change this by typing a number from 0 to 15. 

Align Options 

These options allow you to align the contents of selected entries. All entries 
in the selected fields will be displayed as you specify here. 

■ Left 

■ Center 

■ Right 
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Select Report 

Neui Report... 
Duplicate Report... 
Erase Report... 

Style Options 

These options allow you to change the style of your data. All entries in the 
selected fields will be displayed as you specify here. 

■ Bold 

■ Underline 

■ Commas: This option is available only for numeric fields. 

The Report Menu 

Select Report 

The Select Report command selects a previously defined report definition. 
Once it’s selected you can make changes to it or print the report. If you 
change the selection rules, these changes will be saved automatically along 
with the report definition. 

Select the report definition you want, then click the OK button or press the 
Return key; or double-click the report name. 

Works opens a report window containing the selected report definition. 
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New Report 

Report 

^Hec^eport... ~ 
New Report... 

Duplicate Report... 
Erase Report... 

New Report 

The New Report command creates a new report definition. 

When you choose New Report, Works opens a report window. 

Selection Rules With commands from the Organize menu, you can 
specify the records you want to include in your report. If you specify selec¬ 
tion rules in the Database document immediately before choosing New 
Report, those rules will appear in the report window as well. 

When you close the report window, Works adds the definition to your list of 
available reports. 

Duplicate Report Duplicate Report 

The Duplicate Report command duplicates a previously defined report defini¬ 
tion. This is useful for creating two or more reports that are very similar. 

Report 

I Select Report... 
| Nem Report... 

Duplicate Report... 

| Erase Report... 
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Erase Report 

Report 

Select Report... 
Neui Report... 
Duplicate Report... 
Erase Report... 

Duplicate Report: 

Select the report definition you want to duplicate, then click the OK button or 
press the Return key. 

Works opens a report window with a copy of the selected definition, but with 
a new title. Now you can make any changes you want. 

When you close the report window, Works adds the definition to your list of 
available reports. 

Erase Report 

The Erase Report command deletes a report definition from your Database 
document. 

Erase Report: 
Addresses Report I 

Addresses Report 2 

Select the report you want to delete, then click the OK button or press the 
Return key. 

Works deletes the definition from the Database document. 
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In the Report Window 

Once you open a report window, the menu bar changes and a different set of 
commands is available to you. Some of these commands are identical to the 
regular Database commands; others are completely new. All of the report 
window commands are described in this section. 

The Edit Menu 

Copy Totals Copy Totals 

The Copy Totals command copies totals and subtotals, specified with com¬ 
mands from the TotalsPage menu in a report window, to the Clipboard. This 
allows you to preview the information before printing the report, or paste the 
information into another Works document. 

Once information is on the Clipboard, you can paste it into another docu¬ 
ment, just as you can any other information on the Clipboard. For example, 
you can use the totals and subtotals as a summary of the data in your Data¬ 
base document. 

You can also preview totals and subtotals before printing using the Print Pre¬ 
view option in the Print dialog box. For more information, see “Print” in 
Chapter 2. 

Edit 

Undo mz 

Cut ftH 
Eopy Totals *c 
Paste 
Clear 
Select Rll 

96U 

Draw Or; 

Change Report Title... 

Change Report Title Change Report Title 

The Change Report Title command changes the title of a report. 

The new title appears in the title bar of the report window and in the dialog 
boxes that contain a list of report titles. It is also reflected in the header or 
footer of a report if you specify the filename to be printed with the &F 
command. 

Edit 

Undo mZ 

Cut mu 
Copy Totals me 
Paste mu 
Clear 
Select Rll 

Draw Or; M 

Change Rep ort Title... 

The Organize Menu 

Record Selection Record Selection 

The Record Selection command specifies which records in a Database docu¬ 
ment to print in a report. It works exactly the same as the Record Selection 
command from the main Database Organize menu. 

When you print the report. Works prints only those records meeting your 
record selection rules. 
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Show All Records 

Organize 

| Record Selection^"! 
s/Shour fill Records 

Show All Records 

The Show All Records command tells Works to print all records in a Data¬ 
base document in a report, rather than only those that match the selection 
rules. 

The Format Menu 

Show Grid 

Format 

v'Show Grid | 

Font ► 
Size ► 
Color ► 

Show Grid 

This command specifies whether a report should be printed with or without 
grid lines. 

Choose Show Grid to print a report with grid lines. When chosen, the com¬ 
mand is checked on the menu. To print a report without grid lines, choose 
Show Grid again to remove the checkmark. 

The TotalsPage Menu 

Sum This Field Sum This Field 

Take a Sub-Total on Field Change 
Take a Sub-Total on 1st Char 

Neti> Page After Total 

The Sum This Field command tells Works which fields to sum and then print 
totals for. Subtotals are derived from the numeric values of the specified 
fields and are accumulated as the records are printed or when you choose 
Copy Totals from the Edit menu. 

Select the field you want Works to total, then choose Sum This Field. When 
the command is checked on the menu, it is effective for the currently selected 
field. 

When you print the report, Works prints the specified totals. 

If you choose to sum one or more fields, but do not specify when to print 
subtotals with the Take a Sub-Total on Field Change or Take a Sub-Total on 
1st Char commands, totals are printed at the end of the report for all speci¬ 
fied fields. 

After all records have been printed, Works prints a grand total — the sum of 
all previously printed totals. 
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Take a Sub-Total on Field Change/Take a Sub-Total on 1st Char 

These commands tell Works when to print subtotals of the numeric values in 
the field you’ve specified to be summed. 

To use either Take a Sub-Total on Field Change or Take a Sub-Total on 1st 
Char, you select a key field which is different from the field designated to be 
summed, then choose one of these commands. After the contents of each 
record is printed, Works compares the contents of the key field in the printed 
record with the contents of the key field in the next record to be printed. 

When you choose the Take a Sub-Total on Field Change command, Works 
looks to see if the contents of the two compared fields are different. If they 
are, Works temporarily stops printing records, and prints the subtotal of those 
fields specified by the Sum This Field command. 

When you choose the Take a Sub-Total on 1st Char command, Works looks 
to see if the first character of the two compared fields is different. If it is, 
Works temporarily stops printing records, and prints the subtotal of those 
fields specified by the Sum This Field command. 

In both cases, the subtotals for the entire report are accumulated as they 
are printed. At the end of the report, Works prints a grand total of all the 
subtotals. 

New Page After Total 

The New Page After Total command tells Works to print the next Database 
record on a new page after a subtotal is printed. 

After you select a field to be summed, choose either Take a Sub-Total on 
Field Change or Take a Sub-Total on 1st Char. Then choose the New Page 
After Total command. 

New Page After Total is associated with the specific Take a Sub-Total on 
Field Change or Take a Sub-Total on 1st Char command you choose immedi¬ 
ately before you choose New Page After Total. This way, you can specify 
that a new page be started after one type of subtotal, but not after another. 

Take a Sub-Total on 
Field Change 
Take a Sub-Total on 
1st Char 

TotalsPage 

New Page After Total 

TotalsPage 

Sum This Field 

Take a Sub-Total on Field Change 
Take a Sub-Total on 1st Char 

Nem Page after Total 
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The Works Spreadsheet automates the kind of figuring you do with a sheet of 
paper and a calculator: taxes, sales projections, cash-flow analyses, or per¬ 
sonal net worth statements. The Spreadsheet gives you cells to fill with 
labels, numbers, and formulas. You type in the data, and Works does the cal¬ 
culating for you. 

You can change the numbers to see what happens, and let Works recalculate 
again, automatically. Once you have the numbers in place, you can chart 
your figures to see how they look. Then, when you change a number, you 
can watch the chart change at the same time. When you have the result you 
want, you can print it. 

The formulas you enter into the Spreadsheet can include everything from 
simple addition and subtraction to trigonometric equations and logical 
comparisons. 

q w*cu ^ 
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These six chapters explain how to use the Spreadsheet: 

■ Chapter 11, “Entering Information,” shows you what a Spreadsheet docu¬ 
ment looks like, and how to type labels, numbers, and formulas into the 
Spreadsheet. 

■ Chapter 12, “Working with the Spreadsheet,” shows how to make 
changes or additions to your Spreadsheet document, and different ways to 
look at it. 

■ Chapter 13, “Formatting and Printing,” shows how to arrange your infor¬ 
mation on the screen and prepare for printing. 

■ Chapter 14, “Charting a Spreadsheet Document,” describes the 
Spreadsheet’s charting capability. 

■ Chapter 15, “Spreadsheet and Database Functions,” describes Works’ 
built-in functions. 

■ Chapter 16, “Spreadsheet Command Reference,” describes all the 
Spreadsheet commands. 
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In this chapter, you’ll learn how to: 

■ Recognize the parts of a Spreadsheet document and design your own 
documents. 

■ Select parts of a Spreadsheet document. 

■ Enter and correct information. 

■ Use labels and values. 

■ Build a formula using operators and references. 

■ Avoid circular references. 

■ Create cell notes. 

An Overview An overview 

This section shows you what a Spreadsheet document looks like in Works, 
explains what a spreadsheet is, and shows how to design one for maximum 
effectiveness. The Spreadsheet helps you analyze numbers that you arrange in 
rows and columns, such as budgets or financial statements. Change the 
numbers to see what happens — the Spreadsheet makes the calculations. You 
can also chart your numbers with the Spreadsheet. If you change a number in 
a document, the chart instantly reflects it. 
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Looking at a 
Spreadsheet window 

Parts of a 
Spreadsheet 
document 

Looking at a Spreadsheet Window 

A Spreadsheet window looks like this: 

Column headings 
Enter box 

Cancel box 
Formula in the active cell 

Entry bar Label 
Zoom box 

Value 

I Row headings 
The cell reference A1 refers to this cell. Page break 

indicator 

A Spreadsheet document is made up of columns and rows. Each column has 
a lettered heading (labeled A to Z, then AA, AB, and so on to IV), and each 
row has a numbered heading (1 to 16,382). Columns and rows intersect to 
form cells. You can locate a cell or refer to it with a cell reference — its 
column heading and row heading. For example, A1 is the cell reference for 
the cell in the upper-left comer of a Spreadsheet document. 

You tell Works where you want to enter information by selecting cells. As 
you type, the information appears in the entry bar. You enter the information 
into the active cell by clicking the enter box or by pressing the Enter key. 
The number of cells you can fill is dependent upon the amount of memory 
available to you. 

You put numbers, formulas, and labels into cells to create a Spreadsheet 
document. When you change numbers, you can see how the changes affect 
the outcome of Spreadsheet calculations. 

You set up a calculation by entering a formula. For example, 2 + 2 is a sim¬ 
ple formula. A1 + A2 is also a formula. Using this formula, Works looks for 
numbers in cells A1 and A2, and adds them. 

Labels make your Spreadsheet documents easier to understand. Labels are 
text, such as Total Expenses, Percent, or 1988 Projections, that explain your 
numbers and formulas. 
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Designing a Spreadsheet Document 

You may not realize it, but you’ve probably already prepared something simi¬ 
lar to a Spreadsheet document. Maybe it was several columns of figures you 
jotted down for a promotional campaign, or a departmental budget you wrote 
on filler paper. But chances are that you’ve done something like this before. 

These steps will help you clarify your thoughts: 

■ Choose a subject. For example, if your major purpose is to set up an 
expense report document, don’t get sidetracked by putting a travel budget 
in the same Spreadsheet document. 

■ Choose the components. Write down all the types of information you 
need for your calculations. When you type them into a column in a 
Spreadsheet document, you will be setting up your labels. 

■ Decide on a structure. Map out what goes where. A good structure not 
only lends itself to easy calculation by Works, it also makes it easy to 
find the information you need after the calculations are complete. 

■ Plan the calculations. Determine equations that produce the results you 
want. These equations will become your Spreadsheet formulas. 

■ Decide on the numbers. When your labels and formulas are entered into 
your Spreadsheet document, you will need only the numbers to find your 

answers. 

Selecting Parts of a 
Spreadsheet Document 

Before you can enter information into a Spreadsheet document, you tell 
Works where to put the information by selecting a cell or a range of cells. 
The information you type goes into the active cell in the selection. The cell 
indicator in the entry bar shows you which cell is active. In a range of 
selected cells, only the cell that is highlighted is active. 

Designing a 
Spreadsheet 
document 
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To select a single cell 

To select the last cell 

Cell indicator 

Content of the active cell 

Active cell 

* File Edit lllinc out Select Format Options Chart Macro 
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13 

14 

15 

16 

17 

18 
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Alpine Race Budget 

Expenses May Percent j June Percent { 
Basic Food 5 $30,000 B 2222*] $i6,666 ] ]]]j5*[ 
Special Food Requests $6,000 j .444*] $6,666] .9*| 
Lodging 3 $60,6661 4444*]. $20]000 : .30*1 
Bicycles ••••••p6^666] 14.81*1 $5,000 : ]]]]]]].7*1 
Promotions ""']$i2,666'T 8.89*] ] II 2'000 ] Il'i's*; 
Total Expenses ::$i28;6oo7 94!81*|. ] $53,000 ; lilies*; 

Total Budget Available I ■"2135,666] ]]]]i666o*l $67,500 i i66*I 
.T 

Under (Over) Budget IIISSjpT' . $14,500 ; 
.1. 

21*1 

o 

You can select cells by clicking or dragging with the mouse or by choosing 
commands from the Select menu. You can also select a cell by using certain 
keys on the keyboard. For more information, see the next section, “Entering 
Information into a Spreadsheet Document.” 

To select a single cell, click the cell. 

6 File Edit Window 

Click a cell to select it. 

Select Format Options Chart Macro 

B4 1 50000) 

Budget (SS) 

*L §1 c_1 •> E 1 F 
1 Alpine Race Budget 
2 | j j 1 
3 Expenses May j Percent : June Percent | 
4 Basic Food § $30,000 B "]] '2222*1. $i6]66o j ;ili5*;n 
5 Special Food Requests $6,000 ! ’]]™444*|. .$61666] 9*1 
6 Lodging 

ZMM1 4444*; ]]$2o]6o6 ] 30*1 
7 Bicycles $20,666 ] II jj 46l*i $51666] 7*1]. 
8 Promotions $1216661 IIII®:®?*!. :$i]2lop6i is*; 
9 Total Expenses .$1261666 T .94"8'i'*i. $531666] .79*1. 

10 i i 
11 Total Budget Available j $135,000 ! 100.00*; '"$^1666"! 166*1 
12 1 i i .i.t. 
.:.•.? : 1 

13 Under (Over) Budget $7,000 : 5.i9*i $14,506] .21*1. 
14 1 

Works considers the last cell in your Spreadsheet document to be the cell at 
the intersection of the last row and column containing a value or formula. To 
select the last cell, choose Last Cell from the Select menu. 
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The following table describes how to select various ranges of cells. 

To select this range Do this 

A block of cells 

One row or column 

Many rows or columns 

All cells through the last cell 

All cells in a Spreadsheet 
document 

Drag from the cell in one comer of the 
block to the cell in the opposite comer. 

Click the row or column heading. 

Drag from the first row or column head¬ 
ing to the last heading. 

Choose All Cells from the Select menu. 

Choose Select All from the Edit menu. 

When selecting a range of cells, if you drag past the last row or column on 
the screen, Works scrolls the document and adds to the selection. You can 
also use the Shift key to extend a selection beyond one screen: 

□ Select the cell that marks the beginning of the range. 

0 Scroll the document to the end of the range you want to select. 

0 Hold down the Shift key while you select the cell that marks the end of 
the range. 

Works selects all the cells between and including the two selections. 

Entering information 
into a Spreadsheet Document 

You can enter text (as labels or part of a formula), numbers, or formulas into 
cells. Text and numbers are also known as constant values. 

To enter a constant value, you select a cell and type the value. To enter 
a formula, you select a cell, type an equal sign ( = ), and then type the 
formula. 

As you type the information you want to put into the active cell, it appears in 
the entry bar. You can be sure that your entry is correct before you use it for 
a calculation or a label because it won’t appear in the active cell until you 
enter it. You can type up to 238 characters in the entry bar. 

Enter box 
Cancel box 

r * File Edit 

Formula 

Window Select Format Options Chart Macro 

To select a range of 
cells 

To extend a selection 
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To enter what you 
type 

To move through a 
selection 

To cancel your typing 
in the entry bar 

To edit an entry 

When you enter a constant value or a formula, Works stores it in the active 
cell and displays the value in the cell. 

There are several ways to enter what you type. You can click the enter box, 
or use the keyboard as described below: 

To enter what you type and 
make the active cell 

The cell on the right 

The cell on the left 

The cell below 

The cell above 

The same cell 

Press these keys 

Tab 

Shift + Tab 

Return 

Shift + Return 

Enter 

You can also use these keys or the arrow keys to move around in the docu¬ 
ment when you are not entering information. 

To enter a constant value and select any other cell at the same time, just click 
the other cell. 

If you select a range of cells, you can press the Tab key or the Return key to 
move the active cell within the range without changing the selection. You can 
quickly enter information into many cells by selecting the range, typing, and 
then pressing the Tab key or the Return key, depending on which direction 
you want to move. 

Making Corrections to an Entry 

If you make a mistake while you’re typing information into the entry bar, 
you can correct it. 

To cancel your typing in the entry bar: 

0 Click the cancel box to the left of the entry bar. 

Works cancels your typing and restores the original entry. If the original 
entry was blank, the entry bar will also be blank. 

To edit an entry, you can use the usual Macintosh editing techniques: Use the 
Cut, Copy, and Paste commands, the Delete key, or select what you want to 
change and type to replace it. 
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Entering a Label 

Labels let you write explanatory information in a Spreadsheet document. 
Labels make the numbers and formulas easier to understand. You can label 
the contents of a column or row, or include notes to explain how to perform 
a certain calculation. Labels help other people understand your Spreadsheet 
document, and can also help you when you return to a document that you 
haven’t used in a long time. 

You can do all sorts of creative things with labels: a line of hyphens can 
separate values in a column from their total; a number followed by a letter 
can specify a quarter of the year; a number can label a year. The following 
illustration gives some examples of how you can use labels. 

You can type up to 238 characters in a label. 

To enter a label: 

□ Select a cell. 

0 Type the label. 

0 Click the enter box or press the Enter key. 

If a label doesn’t fit in a cell, Works automatically runs the label into any 
blank cells in the same row, cutting off the label at the first non-blank cell, if 
necessary. If you don’t want the label to overflow into an adjacent blank cell, 
select the blank cell and press the spacebar. The cell now contains a charac¬ 
ter, even though you can’t see it, so the label will not run into that cell. 
You can also widen the column to hold the label. For more information, see 
“Changing Column Width” in Chapter 13. The entry bar shows the full entry, 
regardless of the width of the column. 

To enter a label 

To fit labels into cells 
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To begin a label with 
a number or symbol 

To enter a number 

To type a number in 
scientific notation 

Whenever you start an entry with a letter, Works stores the entry as a label 
You can, however, start labels with numbers or math symbols, if you tell 
Works that you’re typing a label rather than a value or formula. 

You might need to begin a label with a number. For example, you might 
indicate thousands by typing 1000, or you might want to use a label such 
as 1988. 

To tell Works that you want to begin a label with a number or a symbol: 

□ Select a cell. 

E Type a quotation mark (”). 

0 Type the label. 

0 Click the enter box or press the Enter key. 

Works enters the label into the active cell. 

The quotation mark is a signal to Works that you’re typing a label. It appears 
in the entry bar, but not in the cell. 

When Works encounters a label while performing a calculation, it treats the 
label as zero. 

Entering a Number 

To enter an integer or decimal number: 

0 Select a cell. 

E Type a number. 

Include a decimal point, if necessary. For a negative number, begin with 
a minus sign. Do not type commas or dollar signs. 

E Click the enter box or press the Enter key. 

Works enters the number and displays it in the active cell. 

If the number you enter cannot be accurately represented, given the width 
of the cell, Works fills the cell with # symbols. When you widen the cell 
enough, you see the actual value. 

For very large and very small numbers, you can use scientific notation. 
Works accepts exponents to ±99. If you enter an exponent outside this 
range, Works displays * Error* in the cell. 
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To type a number in scientific notation, type an integer or decimal number, 
followed by an E and an integer that represents an exponent of 10. 

When you enter a number in scientific notation, it looks like this: 

Mantissa 

r 6 File Edit Ulin do jj 

Exponentiation symbol 
Exponent 

f86E23 

Select Format Options Chart Macro 

A1 

* 1 [ ° 

= Untitled 
1?j 

(SSI 

1° 1 c 
E 

r.f i 
i 1 86E+23I i. 
2 

O 

If the result of a calculation is a number with an exponent outside the accept¬ 
able range, Works displays * Exponent* in the cell. 

To enter a date: 

0 Select a blank cell. 

0 Choose Set Cell Attributes from the Format menu. 

0 Choose Date Short, Date Medium, or Date Long. 

Date Short shows the date numerically, with slash marks between the 
month, day, and year (8/10/88). Date Medium abbreviates the name of 
the month (Aug 10, 1988). Date Long spells out the full name of the 
month (August 10, 1988). 

0 Click the OK button or press the Return key. 

0 Type the date into the entry bar and click the enter box or press the Enter 
key. 

To enter a time: 

0 Select a blank cell. 

0 Choose Set Cell Attributes from the Format menu. 

0 Choose Time. 

0 Click the OK button or press the Return key. 

0 Type the time into the entry bar and click the enter box or press the Enter 
key. 
You can type the time in 24-hour format (20:04) or 12-hour format (8:04 
PM). If you use the 12-hour format, be sure to include “am” or “pm”. If 
“am” or “pm” is missing, Works assumes AM. 

To enter a date 

To enter a time 
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About numbers and 
formats 

What is a formula? 

To enter a formula 

A cell’s format is separate from its numeric value. The format determines 
how the value is displayed. For more information, see “Changing Number 
Formats” in Chapter 13. 

In a new Spreadsheet document. Works displays numbers as precisely as pos¬ 
sible within the width of each cell. However, Works stores number values up 
to 18 places long, regardless of how they are displayed. 

Building a Formula 

Formulas make the Spreadsheet a useful tool. Without them you’d just have 
rows and columns of numbers. Formulas tell Works what to do with the 
numbers. 

You enter a formula into a cell just as you do text and numbers. When you 
select a cell containing a constant value (either text or numbers), Works 
displays the value in the entry bar without any formatting. In the cell itself, 
Works displays the value and any formatting. When the selected cell contains 
a constant value, the display in the entry bar and in the cell may be the same. 
When the selected cell contains a formula, however, Works displays the for¬ 
mula in the entry bar and its calculated result in the cell. You can always 
examine the cell’s content by selecting the cell and looking in the entry bar. 

Here’s an example of what a formula might look like: 

Equal sign 
References 

Value 

(B4+D4)*0.1 

Operators 

A formula calculates a new value from existing values. A formula can consist 
of values, cell references, operators, and functions. 

A formula can be as simple as =B1 + B2, which adds the values in cells B1 
and B2. Or, a formula can be complex: 

= Pi( )/2 —ATan(Bl/Sqrt(l — B1A2)) 

Every formula begins with an equal sign. The equal sign tells Works that 
what follows is a formula, and that it needs to be calculated. 

You can set up much of a formula by pointing and clicking with the mouse. 
You can point to cells, drag across blocks of cells, and paste functions 
without typing. (Functions are explained in Chapter 15, “Spreadsheet and 
Database Functions.”) 
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To enter a formula: 

0 Select a cell. 

0 Type an equal sign ( = ). 

0 Type the formula in the entry bar. 

0 Click the enter box or press the Enter key. 

Works enters the formula into the active cell, and displays the resulting 
value. The formula still shows up in the entry bar, so that you can see both 
the formula and the result simultaneously. 

You can set up a simple total of a group of cells by pointing and clicking. To get a total 
The formula for a total looks like this: 

r 6 File Edit Window Select Format Options Chart Macro 

B9 H3 =B4+B5+B6+B7+B8|^ 
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7 Bicycles .$20,000 ].14 8i*c;;;;;;; $53666] ZZZ7*i’Z 
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The formula will be entered into 
the active cell. 

When you click a cell to put a 
reference into the entry bar, 
Works outlines the cell. 

To enter this formula: 

0 Select a cell. 

0 Type an equal sign ( = ). 

0 Click each cell that you want to add. (Notice that you cannot use a range 
of cells in this particular formula, so do not drag across the cells.) 

Works inserts addition operators ( + ) between the cells you click. 

0 Click the enter box or press the Enter key. 

Works enters the formula into the active cell, calculates it, and displays the 
resulting value. 

You can also sum a range of numbers with the Sum function. For more 
information, see “Sum” in Chapter 15. 
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Relative references 

References 

In Works, columns are labeled A through IV, beginning with columns A 
through Z, and then AA, AB, AC, and so on, to IV. Rows are labeled 1 
through 16,382. The cell in column A, row 1, is referred to as Al. The 
number of cells you can fill is dependent upon the amount of memory avail¬ 
able to you. 

References make formulas flexible. You can use the same value in many for¬ 
mulas by entering the value in a cell and referring to that cell in the formu¬ 
las. Then, if you change the value of the cell, Works recalculates the formu¬ 
las using the new value. 

When you build a formula, you can refer to cells using relative references or 
absolute references. 

Relative References 

A relative reference gives general directions to Works, rather than a specific 
location. It’s like saying, “Go up two blocks and over one.” If you copy a 
relative reference to another cell, the reference changes relative to its new 
position. For example, if a relative reference in a formula points two rows up 
and one column to the right, and you copy the formula to another location, it 
still points two rows up and one column to the right, but it points to a dif¬ 
ferent cell than it did originally. 

A B c 
1 . . : 

2 

3 Original 

4 Copy 
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Absolute References 

An absolute reference is like a mailing address: 9522 Almont Street. No 
matter where you copy the reference to, it still points to the same cell. For 
example, an absolute reference to cell B1 always points to cell Bl, even if 
the formula containing the reference is copied to another location in the 
Spreadsheet document. Works uses dollar signs to indicate that a reference is 
absolute. $B$1 is an absolute reference to cell Bl. 

A B c 
1 
2 

3 Original 

4 Copy 

The difference between relative and absolute references is important only 
when you cut or copy a formula from one cell and paste it into another, or 
when you use the Fill Right or the Fill Down commands from the Edit menu. 
For information on copying references, see “Copying Cells” in Chapter 12. 

You can enter a cell reference into a formula either by clicking the mouse or 
by typing. When you use the mouse, Works puts the reference into the entry 
bar for you. 

To enter a reference: 

0 Select a cell, then start a formula by typing an equal sign ( = ). 

U] Click the cell that you want to refer to, or type the cell reference. 

You can refer to as many cells as the formula needs. If you do not type an 
operator into the formula before you select each cell after the first one, 
Works supplies the addition operator ( + ). For example, if you type an equal 
sign, and then click two cells, Works adds the contents of the two cells. 

Changing Reference Styles 

When you click or drag to enter a reference into a formula, the reference will 
be relative. You can change the style of a reference by using the Absolute 
Cell Ref command from the Edit menu. This command takes effect on the 
cell reference immediately preceding the insertion point or the selected refer¬ 
ence in the entry bar. 

Absolute references 

To enter a reference 
into a formula 
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To make a reference 
absolute 

To make an absolute cell reference from a relative one: 

0 Select the cell containing the formula that includes the relative reference 
you want to change. 

HI In the entry bar, position the insertion point immediately to the right of 
the relative reference, or select the reference. 

C4 

File Edit LDindou' 

This is the reference you want to change. 

Select Format Options Chart Macro 
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0 Choose Absolute Cell Ref from the Edit menu. 

Works inserts dollar signs before the column letter and row number, indicat¬ 
ing that the reference is now absolute. 

Works adds dollar signs to show 
that the reference is now absolute. 

File Edit Window Select Format Options Chart Macro 
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You can also create absolute references by typing dollar signs before the 
column letter and row number of a relative reference. 
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To make a relative reference from an absolute one: 

0 Select the cell containing the formula that includes the absolute reference 
you want to change. 

0 In the entry bar, position the insertion point immediately to the right of 
the absolute reference, or select the reference. 

0 Choose Absolute Cell Ref from the Edit menu. 

Works removes the dollar signs, indicating that the reference is now relative. 

You can also remove the dollar signs by using the Delete key. 

Mixing References 

If you want to refer to cells in such a way that only the column or the row 
reference is absolute (or relative), you can use mixed references. For exam¬ 
ple, in the reference $B3, only the column reference is absolute. In the refer¬ 
ence B$3, only the row reference is absolute. It’s like giving a street but no 
address — the second house down on Almont Street. The house depends on 
where you are, but the street remains the same. 
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With these mixed references, the formula always 
uses cells in rows 4 and 5 (the absolute 
references), but may not always use cells in 
column B (the relative reference), if the 
formula is copied elsewhere. 

To make a reference 
relative 
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To enter or reverse a 
mixed reference 

To use an arithmetic 
operator 

You can enter a mixed reference by typing it into the entry bar. Just put a 
dollar sign before the reference you want to be absolute. 

You can reverse a mixed reference either by typing and using the Delete key 
or by using the Absolute Cell Ref command from the Edit menu. 

Operators 

An operator is an instruction, such as + or —, that tells Works to calculate a 
new value from existing values. For example, in the formula =3 + 6, the 
addition sign (+) is the operator that instructs Works to add the operands 3 
and 6 to produce the new value 9. 

Works uses two kinds of operators: arithmetic and comparison. 

Arithmetic Operators 

The arithmetic operators represent standard calculator functions. 
These include: 

+ Addition 

— Subtraction 

- Negation (if used with one operand only) 

* Multiplication 

/ Division 

Exponentiation 

To use an arithmetic operator: 

0 Select a cell. 

0 Type an equal sign to start a formula. 

0 Type the first number or click a cell reference. 

0 Type an arithmetic operator. 

0 Type the second number or click a cell reference. 

0 Type as many additional numbers and operators as you need. 

0 Click the enter box or press the Enter key. 

Works enters the formula into the active cell, calculates it, and displays the 
resulting value. 

Remember that if you don’t type an operator after an operand (number or cell 
reference) in a formula, Works automatically inserts an addition sign (+) 
before the next cell reference. 
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Comparison Operators 

A comparison operator compares two values and produces the value 1 
(TRUE) or 0 (FALSE). Works has six comparison operators: 

= Equals 

< Less than 

< = Less than or equal to 

> Greater than 

> = Greater than or equal to 

<> Not equal 

For example, 3<2 produces the value 0 (FALSE), while 2<3 produces the 
value 1 (TRUE). If cell B17 contains 5 and cell B52 contains 13, then 
B17>B52 produces 0 (FALSE) and B17<B52 produces 1 (TRUE). 

Order of Operators 

If you combine several operators in a single formula, Works performs the 
operations in this order: 

Exponentiation 

— Negation 

* and / Multiplication and division 

+ and — Addition and subtraction 

— <<= >>= <> Comparison operators 

If you want to change this order, use parentheses. Works first calculates the 
expressions in parentheses, and then uses those results to calculate the rest of 
the formula. For example: 

Without parentheses With parentheses 

4*3 + 2=14 

— 3A2 = —9 

4* (3+ 2) = 20 

(— 3)A2 = 9 
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Avoiding circular 
references 

Creating cell notes 

Avoiding Circular References 

To help Works perform as efficiently as possible, avoid circular references in 
your formulas. A circular reference is a reference that has no ending point. 
The cells involved in a circular reference cannot be calculated. When Works 
encounters a circular reference, it displays an alert box. 

A circular reference in a Spreadsheet document is a reference that refers to a 
cell which in turn refers back to the original cell. More specifically, a circu¬ 
lar reference occurs when, in order to calculate a formula in a particular cell. 
Works needs the value of the same cell that contains the formula. An 
example of such a reference is the formula =Sum(Al:A6) when entered into 
cell Al. 

A more common example of a circular reference involves a chain of cells and 
references. For example, a formula in cell El may refer to cell E2, which 
contains a reference to cell E3, which contains a reference to cell E4, which 
contains a reference back to cell El. A circular reference like this cannot be 
resolved. 

Creating Cell Notes 

You can create cell notes to provide additional information about a cell’s con¬ 
tents. Use the Open Cell Note command from the Edit menu to open a win¬ 
dow in which you type notes associated with a selected cell. Cell notes 
remain with the cell and can be viewed and printed. 

Hint You can also open a cell note by selecting a cell and then pressing the 
Command key while double-clicking the mouse. 

If the Show Notes Indicator is checked in the Options menu, a marker in the 
upper-right comer of a cell indicates that it is annotated. 

For more information on cell notes, see “To print cell notes” in Chapter 13, 
and “Open Cell Note” in Chapter 16. 
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After you’ve set up a Spreadsheet document, you’re ready to start playing 
with the numbers to see the results of various scenarios. This chapter shows 
you ways you can work with a completed Spreadsheet document. 

This chapter shows you how to: 

■ Play What-If—change the content of a cell to see the effect that change 
has on the rest of your information. 

■ Choose when to recalculate, rather than having Works do it automatically. 

■ Display formulas to help analyze the design of a Spreadsheet document. 

■ Divide the Spreadsheet window into panes, so that you can view different 
parts of the Spreadsheet document at the same time. 

■ Find a cell anywhere in a Spreadsheet document. 

■ Work with blocks of cells by copying, pasting and moving them; turning 
rows into columns and back; and filling empty cells. 

■ Sort a Spreadsheet document by rows. 

■ Insert blank rows and columns. 

These tasks help you analyze the information in your Spreadsheet document. 
If you want to polish the appearance of your document, or prepare it for 
printing, see Chapter 13, “Formatting and Printing.” 

Changing the Content of a Cell 

One of the Spreadsheet’s most important assets is its ability to recalculate 
whenever you make a change. 

Each time you make a change, you play What-If. What if the rate on your 
building loan goes up by 2%? What if it goes up 5%? 

As long as you’ve saved your original Spreadsheet document on a disk, 
you’re working with a copy. None of the changes you try are permanent 
unless you want them to be. On the other hand, if you find several alternative 
scenarios that you’d like to keep, you can print each one, or save each with a 
different name. 
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To change the 
content of a cell 

You can change a cell’s entire content by selecting the cell and typing new 
information to replace the old. Or, you can change part of a cell’s formula or 
constant value in the entry bar using standard Macintosh editing techniques. 
Click in the entry bar and type the information you want to add, or use the 
Cut, Copy, and Paste commands from the Edit menu to replace information. 

When you click in the entry bar, Works activates it and displays a cancel 
box, an enter box, and an insertion point. 

When you are done making changes, click the enter box (or press the Enter 
key) to enter the new information into the cell. If you decide not to keep 
your changes, click the cancel box. Works restores the previous contents of 
the entry bar. 

The cancel and enter boxes are 
visible when the entry bar is active. 

When the entry bar is active, you 
can edit the cell’s value or formula. 
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Click the enter box or press 
the Enter key to enter the edited 
value or formula into the active cell. 
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Controlling Calculation 

The Works Spreadsheet normally calculates automatically whenever you enter 
or change a value, or whenever you open an existing Spreadsheet file. Each 
recalculation takes some time. But with Works, you don’t have to wait. 
While calculations are being performed, you can continue to enter values or 
perform other Spreadsheet functions, or you can open another Works docu¬ 
ment. 

While Works is recalculating the Spreadsheet document, the icon representing 
the pointer changes slightly. If the pointer is an arrow, Works inverts its 
colors to white on black; if the pointer is an I-beam, Works adds a circle to 
the stem of the I. When the pointer returns to its normal appearance, recalcu¬ 
lation is done. 

You should not use numbers displayed on the screen until calculations are 
complete, since the numbers may change as a result of the calculations. 

If you have many numbers to enter and don’t want calculations to be per¬ 
formed until you are finished, you can switch to manual calculation. With 
manual calculation, you tell Works when you are ready to recalculate. 

To set manual calculation: 

0 Choose Manual Calculation from the Options menu. 

Then, when you’ve entered all your information and are ready to recalculate 
manually: 

0 Choose Calculate Now from the Options menu. 

If you no longer have many changes to make, you can switch back to 
automatic calculation. 

0 Choose Automatic Calculation from the Options menu. 

When you’re examining the effects of changes to a single cell, automatic cal¬ 
culation saves you the trouble of repeatedly telling Works to recalculate. 

Showing Formulas or Values 

The Spreadsheet normally displays the values that result from calculations. 
The entry bar displays the content of the active cell. Sometimes you may 
want to see all the formulas in a Spreadsheet document, so you can figure out 
the logic behind its design. 

To set manual 
calculation 

To return to 
automatic calculation 
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To show formulas 

To show values 

To have Works display all the formulas and unformatted values: 

[■] Choose Show Formulas from the Options menu. 
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For analyzing numbers, it’s better to look at values than formulas. 

To have Works display values: 

0 Choose Show Values from the Options menu. 

Works now shows you the formatted values. 
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Dividing the Spreadsheet Window 
into Panes 

Often you’ll want to see the results of a change in one cell on another cell far 
away. Scrolling back and forth from the cell with the change to the cell with 
the result could get tiresome, so Works provides split bars that divide the 
Spreadsheet window into panes. The two panes on either side of the vertical 
split bar scroll horizontally. The two panes above and below the horizontal 
split bar scroll vertically. That means you can leave one pane stationary while 
you scroll the other pane until it shows the second cell. When you make a 
change, you’ll see the effects of it instantly, even across an entire 
Spreadsheet document. 

Dividing the window into panes also lets you freeze row and column labels 
while you scroll through numbers in another pane. If you have a very wide or 
very long Spreadsheet document, you won’t have to guess what the numbers 
at the far end of the document refer to. 

You can divide the window into both side-by-side and upper and lower 

panes. 

0 Position the pointer on either the horizontal or vertical split bar. 

The pointer turns into a two-way arrow. 

[2] Drag the split bar until it lines up with the right edge of the column or the 
bottom edge of the row at which you want to divide the Spreadsheet 

document. 

When you release the mouse button, Works divides the window into two 

panes. 

Note If you create a pane containing only one or two rows, that pane will 

not have a scroll bar. 

While the Spreadsheet window is split, you can’t use the Draw feature. 

To divide the window 
into two panes 
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To divide the window 
into four panes 

Drag the vertical split bar 
to divide the window into 

two side-by-side panes. 
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Scroll bars 

With four panes you can see even more parts of a Spreadsheet document at 
once because you can scroll each pane both vertically and horizontally. 

To divide the window into four panes: 

E Drag both split bars into the positions you want. 
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6 File Edit Window Select Fori 

Drag both the horizontal and vertical split 
bars to divide the window into four panes. 
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Options Chart Macro 

— 
A 

m Budget (SS) I 
c d 1 * G 

1 n< Race Budget 

2 s. 
3 Expenses »ercent June Percent j 

5 Special Food Requests 4.44% $6,000 9%j 

6 Lodging 44.44% $20,000 30951 

7 Bicycles 14.81% $5,000 7951 

8 Promotions 8.89% $12,000 i 8%! 

9 Total Expenses 94.81% $53,000 79951 / 
10 1 hi* 

1 1 Total Budget Available 100.00% $67,500 100951 

12 
;.1. 

1 
13 Under (Over) Budget 5.1 9%. $1 4,500 21 95 j 

14 1 
.| 

15 | 

16 1 
17 .1.:. 

| 
18 \L_j .1.j. a 

Scroll bars' 

Now you have four scroll bars. Each scroll bar controls the two panes that 
are in line with it. For example, the upper scroll bar controls the two upper 
panes, and the left scroll bar controls the two left panes. 

To close a pane: 

E Drag the split bar back to the far left or upper edge of the pane. 

Finding a Cell 

If you want to look at a cell that’s just beyond the edge of the window, you 
can find it easily by scrolling. But a cell that’s far away on a very large 
Spreadsheet document may be difficult to find. 

If you specify the coordinates of a cell, Works will find it for you. If you 
know only what’s in the cell, you can specify its value, and Works will try to 
find a cell that matches what you type. 

Works can also find the last cell and the active cell in a Spreadsheet 
document. 

To close a pane 
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To find and select 
a cell 

Using Cell References or Cell Content 

There are two commands in the Select menu that allow you to find a particu¬ 
lar cell: Find Cell and Go To Cell. Use Find Cell to have Works select a par¬ 
ticular cell, and use Go To Cell when you want to see the value of a cell, but 
do not want to select it. 

With the Find Cell command, you can find and select a cell by specifying its 
reference or value. If the value you’re looking for is a label, you can specify 
a portion of the text, and Works will look for the cell containing it. 

To find a cell containing the error value * Error* or N/A, type =Error() or 
=NA() in the Find Cell dialog box. When you type a formula (beginning 
with an equal sign) in the dialog box, Works calculates the formula and looks 
for a cell displaying the resulting value. For example, since = Error( ) gives 
the value * Error*, Works looks for a cell containing *Error*. 

To find and select a cell: 

0 Choose Find Cell from the Select menu. 

0 Type the reference or the value of the cell you’re looking for, or type a 
formula whose resulting value is in the cell. 

0 Click the Find Next button. 

If you type 60000 or B6 in the Find Cell 
dialog box, Works finds and selects this cell. 
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If you type a reference, Works moves to the cell and selects it. If you type 
the cell value or formula, Works looks across each row for a cell whose 
value matches what you typed. If it finds a match, Works moves to and 
selects the cell. If Works can’t find anything to match the text you typed, it 
displays an alert box. 

With the Go To Cell command, you can find a particular cell by specifying 
its cell reference. Works finds the cell and makes it visible in the window. It 
does not select the cell. 

The Go To Cell command is useful while you’re typing a formula and want 
to see a particular cell. Because the cell is not selected, it will not appear in 
the entry bar as a reference. Go To Cell is also useful when you want to 
select a large range of cells. 

To find a cell without selecting it: 

0 Choose Go To Cell from the Select menu. 

0 Type the reference of the cell you’re looking for. 

0 Click the OK button. 

Works moves to the cell but does not select it. 

The cell you specify in the Go To Cell dialog 
box appears in the window, but is not selected. 
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To find a cell without 
selecting it 
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To find the last cell 

To find the active cell 

What happens when 
you copy references? 

Finding the Last Cell or the Active Cell 

The Last Cell and Show Active Cell commands from the Select menu help 
you move quickly around a Spreadsheet document. 

Works considers the last cell in a Spreadsheet document to be the cell at the 
intersection of the last row and column that contain a value or formula. 

To select the last cell of your existing Spreadsheet document: 

\u\ Choose Last Cell from the Select menu. 

Works scrolls to the last cell, which marks the lower right boundary of your 
document, and selects it for you. 

If you have been scrolling all around the document looking at various cells, 
the Show Active Cell command takes you back to where you were last 
working. 

To scroll to the currently selected cell: 

[i] Choose Show Active Cell from the Select menu. 

Works scrolls to the active cell. 

Copying Cells 

It doesn’t take long to type the content of a cell. But why type the same 
thing over and over again? With Works, you don’t have to. Using commands 
from the Edit menu, you can copy it. For example, if you have sales projec¬ 
tions for four quarters, you can set up the formulas for the first quarter and 
then copy them for the rest. 

When you copy and paste a formula that contains relative references, the 
references are adjusted to reflect their new locations. If you copy and paste a 
formula containing a relative reference that refers up two rows and over one 
column, the adjusted reference will refer up two and over one to whatever 
new cell holds that relative position. For example, if the formula in cell C7 is 
= C4 and you copy it to cell D7, Works changes the formula to =D4 so that 
it still refers to the cell “three up from the formula cell.” When you paste 
relative references, the new references look different from the old ones, and 
refer to different cells. However, a copy of an absolute reference refers to 
exactly the same cell as the original reference. 
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Copying and Pasting Values and Formulas 

When you copy, Works places a copy of the selected cells onto the Clipboard 
for you to paste somewhere else. 

To copy and paste a selection: 

0 Select the area you want to copy. 

To copy and paste 
a selection 
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Selection to be copied to the 
Clipboard 

0 Choose Copy from the Edit menu. 

Works puts the selection onto the Clipboard. It stays there until you 
replace it with another selection. 

0 Click the upper-left cell of the area you want to paste into. 

Make sure that the cells you want to paste into are blank or can be 
replaced. 

0 Choose Paste from the Edit menu. 

Works pastes the full contents of the Clipboard back into the Spreadsheet 
document, adjusting relative references to reflect their new locations. 
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To paste values only 

6 File Edit Window Select Format Options Chart Macro 
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Pasting Values Only 

Sometimes you will want to paste just resulting values, without the formulas. 
The Paste with Options command lets you choose to paste just values from 
the Clipboard back into a Spreadsheet document. 

For example, if you have an accounts receivable ledger in one Spreadsheet 
document and a general ledger in another, you could paste just the total of 
the accounts receivable (that is, values only) to the general ledger. You don’t 
want to paste the formulas that produce the values, however, since those 
would produce different values in the general ledger. 

To paste values only: 

E Select the area you want to copy, and choose Copy from the Edit menu. 

E Click the upper-left cell of the area you want to paste into. 

Make sure that the cells you want to paste into are blank or can be 
replaced. 

E Choose Paste with Options from the Edit menu. 

B Click the Values Only option. 

E Click the OK button. 

Notice that if you click the Both Values and Formulas option. Works 
proceeds exactly the same as if you had chosen the normal Paste command. 
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Transposing Rows and Columns 

You might want to turn a column into a row if you want to plot that column 
as a bar chart. Or you might want to turn a row into a column so you can 
make a pie chart out of it. Transposing rows and columns is also useful for 
converting records and fields that you copy from the Database. For informa¬ 
tion about copying information from the Database, see the last part of this 
manual, “Using the Tools Together.” 

To transpose rows and columns: 

[H Cut or copy a selection to the Clipboard. 

The selection can be a single row or column or any range of cells. 

H] Click the upper-left cell of the area you want to paste into. 

This cell can be in the same Spreadsheet document, or you can move to 
another one. Make sure the cells you want to paste into are blank or can 
be replaced. 

0 Choose Paste with Options from the Edit menu. 

0 Click the Transpose option. 

0 Click the OK button. 
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The contents of cells B4.B13... 

...have been transposed into this row. 

Works transposes the rows into columns or vice versa, then adjusts relative 
references to reflect their new locations. 

To transpose rows 
and columns 
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To fill into adjacent 
cells 

Filling 

Filling lets you copy the content of a row or column into adjacent rows or 
columns. Within a selection, you fill cells to the right of the first column of 
the selection or below the first row of the selection. Filling fills in all cells 
within the selection, replacing their content if they are not blank, so you 
should be sure that any cells containing information can be replaced. 

To fill into adjacent cells: 

0 Drag across one column or row containing the data you want to copy and 
as many blank adjacent rows and columns as you want to fill. 

Make sure the entire block is highlighted. 

r 6 File Edit Window Select Format Options Chart Macro 

C4 I I 10000 

14  

The contents of these cells... 

...will fill these cells. 

[3 Choose Fill Right or Fill Down from the Edit menu. 

Works copies the contents of the original cells into the adjacent cells. 

Note Select only the range of cells you want to fill before choosing Fill 
Down. Selecting an entire column and filling all 16,382 cells takes a lot of 
memory and slows down your work. 
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* File Edit Window Select Format Options Chart Macro 
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The contents of the original cells 
remain unchanged... 
...when the new cells are filled 

with the Fill Right command. 

If you have any relative references in copied formulas, Works adjusts them 
relative to their new positions. Absolute references stay the same. 

Moving Cells 

Suppose you developed a whole Spreadsheet document and then decided you 
wanted your totals at the top, instead of at the bottom. The Move command 
lets you select a block of cells and move it to a new location within your 
Spreadsheet document. 

When you move cells, all references in the cells in the new location refer to 
the same cells that they did before you moved them; the formulas still calcu¬ 
late from the same values. Works adjusts any other formulas in the Spread¬ 
sheet document that contain references to the moved cells, so that they refer 
to the new location of the moved cells. 

To move a block 
of cells 



240 The Spreadsheet 

To use the Move command, you must know the coordinates of the cell at the 
upper-left comer of the location you want to move to. 

To move a block of cells: 

0 Select the block that you want to move. 

r 6 File Edit Window Select Format Options Chart Macro 

0 Choose Move from the Edit menu. 

0 Type the reference of the cell that will contain the upper-left comer of the 
moved selection. 

Works will replace the contents of any cells that aren’t blank, so make 
sure their contents can be replaced. 

0 Click the OK button. 
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If you type El5 in the Move dialog box, 
Works moves the selected cells here. 
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The original location is now blank. 

Works moves the selection from its old location and pastes it into the new 
one. All relative references in the moved cells refer to the same cells they 
referred to before the move. 

If you don’t know the exact coordinates of the location where you want to 
move the selection, there’s another way to move cells. After you select the 
block you want to move, position the pointer on the cell at the upper-left 
comer of the destination block, but don’t select it. Then hold down the Com¬ 
mand and Option keys and click. 

Sorting 

You can change the order of rows in a selection by sorting. You might want 
to sort a payroll document in alphabetical order by last names, or you might 
want to sort a stockroom inventory by part number. 

Works lets you sort in ascending and descending order. 

If you have numbers and text in the same column, the numbers come first, 
whether you’re sorting in ascending or descending order. Blank cells are 
always sorted last. 
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You can sort on up to three key columns. This allows you to have subgroups 
for subtotals. For example, you could sort a payroll document by department, 
supervisor, and last name, setting up subtotals for each category. That would 
let you analyze payroll expenses by department and supervisor. 

In the example below, the selected cells are being sorted in ascending order 
on key column A. 

If you type A in the Sort dialog box, Works sorts the 
entire selection based on the contents of column A. 
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Sorting affects only selected cells. Works rearranges the selected cells in each 
row according to the order you specify for the key column. When you change 
the order, most cells will have different cell references. Works changes both 
absolute and relative references, inside and outside the selection, to reflect 
new cell locations. 
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To sort a Spreadsheet document: 

0 Select the cells you want to sort. 

0 Choose Sort from the Edit menu. 

0 Type the letter heading of the column that you want to sort — the key 
column. 

0 Click the order you want to sort in (ascending or descending). 

0 If you have a second or third key column, move the insertion point into 
the appropriate box and type the letter. 

0 Click the OK button or press the Return key. 

Works reorders your selection. 

Note If you try to sort columns based on key row headings, Works 
displays an alert box. 

Inserting Rows or Columns 

You can insert rows or columns into a Spreadsheet document whenever 
necessary. So if you have just finished a large document after hours of work 
and you discover that you need just one more row, Works can help you. 

When you insert rows or columns, both relative and absolute references are 
adjusted accordingly. So if you have a cell referring to cell A1 and insert a 
row above row 1, the changed reference will be to cell A2, one row down. 

To insert a row or column: 

□ Click the row or column heading where you want to insert a new row or 
column. 

[U Choose Insert from the Edit menu. 

Works inserts the new row or column at the selection, moving the selected 
row beneath the insertion, or the selected column to the right of the insertion. 
All the rows or columns that follow the new one are renumbered. If you need 
to insert more than one row or column, you can repeat the procedure. 

To sort a Spreadsheet 
document 

To insert a row or 
column 
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The two previous chapters explained how to set up a Spreadsheet document 
and calculate with it. In this chapter, you’ll learn how to change the way it 
looks — its format. This chapter also explains how to print a Spreadsheet 
document when you have the format adjusted to your liking. 

Read this chapter to learn how to: 

■ Change the way numbers are displayed. 

■ Realign the content of cells. 

■ Emphasize cells with bold type, underlining, or borders. 

■ Display or remove the grid. 

■ Change column width. 

■ Protect cells from changes. 

■ Set page breaks for printing. 

■ Print a Spreadsheet document. 

The value of a cell and how Works displays that value within the cell are dif¬ 
ferent. The value of a cell is determined by the data or formula it contains. 
How that value is displayed is determined by the format of the cell. 

You can change the appearance of a Spreadsheet document in a variety of 
ways without affecting formulas or values in cells. You can display data in a 
number of ways: 

■ With a fixed number of decimals 

■ As dollars or percents, or in scientific notation 

■ With various alignments and type styles 

■ With or without commas 

When you change a cell’s format, its value does not change. Works displays 
the cell’s value in the new format. 

Using the Format menu’s Set Cell Attributes command, you can specify the 
format of a cell before or after you enter the content of the cell. When you 
want to enter data that all use the same format, you can format selected cells 
before you start typing. Then, when you enter the data into those cells, 
Works displays it in the format you chose. Or, you can enter your data first, 
then select the cells and choose a format. 

About cell formats 
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To change the format 
of numbers in cells 

To change the 
number of decimal 
places 

Changing Number Formats 

Unless you specify otherwise, Works displays numbers in General format 
(that is, as accurately as possible, given the cell width). For example, if you 
type 12345.6789, Works may display it in a variety of ways, depending on 
the width of the cell: 12345.6789, 12345.7, 12346, 1E + 4, and so on. 

Numbers can be displayed in the following formats: General, Fixed, Dollar, 
Percent, Scientific, Date, or Time. With all formats except General, Date, 
and Time, you can set a fixed number of decimal places to display. With 
Date, you can choose short, medium, or long formats. One Spreadsheet 
document can contain many different cell formats. You can select columns, 
rows, a single cell, or a block of cells to format. For information about the 
number formats you can use, see “The Format Menu” in Chapter 16. 

To change the format of cells: 

0 Select the cells you want to format. 

0 Choose Set Cell Attributes from the Format menu. 

0 Choose General, Fixed, Dollar, Percent, Scientific, Date, or Time from 
the dialog box. 

0 Click the OK button or press the Return key. 

Works adjusts the format of the selected cells accordingly. 

r * File Edit Window Select Format Options Chart Macro 
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Unless you specify otherwise, Works displays two decimal places in your 
numbers in all formats except General. You can choose to display up to 15 
decimal places. 
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To change the number of decimal places: 

0 Select the cells for which you want to change the number of decimal 
places. 

0 Choose Set Cell Attributes from the Format menu. 

0 Type the number of decimal places you want displayed in the Decimal 
Places box. 

0 Click the OK button or press the Return key. 

Works adjusts the numbers accordingly. 

You can choose to display numbers with or without commas. If you type 
commas into your numbers as you enter them, Works treats the numbers as 
text. 

To show commas: 

0 Select the cells you want to format. 

0 Choose Set Cell Attributes from the Format menu. 

0 Choose Commas. 

0 Click the OK button or press the Return key. 

Aligning Cell Content 

Numeric values in Works are automatically right-aligned (they line up on the 
right side of the cell), so that columns of numbers are easy to read. Labels 
automatically line up on the left side of the cell. However, you might want to 
center or right-align your labels, or left-align your numbers. So Works lets 
you specify the alignment of cells. You can select columns, rows, a single 
cell, or a block of cells to realign. 

To change the alignment of cells: 

0 Select the cells whose alignment you want to change. 

0 Choose Set Cell Attributes from the Format menu. 

0 Choose Left, Center, or Right alignment. 

0 Click the OK button or press the Return key. 

Works adjusts the alignment of the selected cell or cells. 

To display numbers 
with commas 

To change alignment 
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To change type style 

Adding Emphasis 

Spreadsheet cells contain normal (plain) type unless you change the type style 
with the Format menu. You can add emphasis to the content of any cell by 
changing the style of the cell to bold and/or underlined text. 

Underline 

If you format a cell to have underlined text, the underlining extends across 
the full width of the cell. 

To change the type style of cells: 

0 Select the cells whose type style you want to change. 

0 Choose Set Cell Attributes from the Format menu. 

0 Choose Bold or Underline. 

0 Click the OK button or press the Return key. 

Works changes the type style of the selected cells. 

Note You can also change the type style by using the following 
Command + key equivalents: 

Keyboard command Style 

Command + B Bold 

Command + U Underline 

Command + N Normal 
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You can also add emphasis to cells by adding a border. 

To add a border to cells: 

0 Select the cells you want to border. 

GO Choose Borders from the Format menu. 

[H Choose Outline, Left, Right, Top, or Bottom. 

Note If you select more than one cell and choose Outline, Works outlines 
the selection. To individually outline each cell in a selection, select a range, 
choose Borders from the Format menu, and choose Left, Right, Top, and 
Bottom for the selection. 

To remove a border, select the cells whose border you want to remove, 
choose Borders from the Format menu, and then choose None. 

Displaying the Grid 

You can choose whether or not to display the grid lines in a Spreadsheet 
document. 

To display the grid: 

[■] Choose Show Grid from the Options menu. 

Works displays the grid and places a checkmark in the menu. 

To remove the grid, choose Show Grid again. 

Works removes the checkmark from the menu. 

Changing Column Width 

The standard column width is 12 characters. A single column can display up 
to 40 characters. That’s large enough to show long labels like Advertising 
and Total Invoices. 

When something doesn’t fit in a cell, you can widen the cell. In General for¬ 
mat, numbers are displayed as accurately as possible given the width of the 
column, using scientific notation if necessary. 

To add borders 

To display or remove 
the grid 
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To change column 
width 

To set cell protection 

You change the width of a column by dragging the line at the right of the 
column heading or by choosing Column Width from the Format menu. 

To change column width by dragging: 

□ Position the pointer on the right edge of the column heading. 

The pointer becomes a two-way arrow. 

0 Drag to the right to make the column wider, or to the left to make the 
column narrower. 

To change column width by using the Format menu: 

□ Select a cell in the column you want to change. 
You can select cells in multiple adjacent columns if you want to change 
the width of all of them. 

0 Choose Column Width from the Format menu. 

0 Type a number, up to 40, for the overall column width. 

0 Click the OK button or press the Return key. 

When you enter a label, if you type more characters than will fit in a cell 
before you’ve widened it, Works continues the label into adjacent blank cells, 
if possible. When you enter a number that is too long for a cell, Works 
displays the cell filled with number signs (#). Widening the column will 
allow the number to be displayed. 

Protecting Cells from Changes 

When you set up forms for other people to fill in, or if you have important 
formulas that took a long time to set up, you probably would like to protect 
this work from being changed. In Works, you can do this with cell protec¬ 
tion. Later on, if you need to change the contents of a protected cell, you can 
remove cell protection. 

You can set protection separately for each cell or range of cells. 

To set cell protection, if Protected is not checked: 

0 Select the cell or range of cells you want to protect. 

0 Choose Protected from the Options menu. 

Works protects the selected cells and displays a checkmark in the menu. 
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You won’t be able to type in the protected cells unless you remove cell pro¬ 
tection. The values in cells with formulas still change, but you won’t be able 
to change the formulas themselves until you remove cell protection. 

To remove cell protection, if the Protected command is checked: 

□ Select the protected cell or range of cells. 

0 Choose Protected from the Options menu. 

Works removes the cell protection and deletes the checkmark from the menu. 

Printing 

When you’re ready to print a Spreadsheet document, you can specify page 
breaks and set up headers and footers to print at the top and bottom of every 
page. 

For a detailed explanation of the printing process, including how to fill out 
the necessary dialog boxes, see “Printing a Document” in Chapter 1. This 
section discusses only items that are specific to printing a Spreadsheet 
document. 

Setting Page Breaks 

In a Spreadsheet document, you can set both horizontal and vertical page 
breaks. Works automatically sets page breaks according to the margins you 
choose using the Page Setup command from the File menu. But you may 
want to specify your own page breaks. That’s what the Set Page Break com- 
mand is for. 

To set a page break: 

0 Select the cell that you want to be at the upper-left comer of the new 
page. 

0 Choose Set Page Break from the Options menu. 

Vertical and horizontal dashed lines (page break indicators) show where 
you’ve set the page break. 

To remove cell 
protection 

To set a page break 
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To remove a manual 
page break 

If you select cell D3, Works inserts 
these vertical and horizontal page 
break indicators. 
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To set a page break across an entire row or column, select the row or column 
heading before choosing the Set Page Break command. 

To remove a manual page break: 

0 Select the cell in the upper-left comer of the page. 

0 Choose Remove Page Break from the Options menu. 

Works removes the manual page break — both the horizontal and vertical 
dashed lines. 

You can remove just the horizontal page break or just the vertical page break 
by selecting any cell just below or to the right of the dashed line, respec¬ 
tively, before choosing Remove Page Break. 

Printing a Spreadsheet Document 

When you’re ready to print a Spreadsheet document, you have three options. 
You can choose to print: 

■ All cells through the last cell. 

■ Only cells that appear in the window. 

■ Only selected cells. 

Cell notes can be printed with any of these options. 
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If you use the Print command without selecting any cells, Works prints all 
cells through the last cell. 

If you use the Select All command from the Edit menu, Works prints all cells 
in the Spreadsheet document (256 x 16,382 cells). 

You can choose whether or not to print row and column headings. If you 
want these printed, click the Print Row and Column Numbers option in the 
Page Setup dialog box. 

With the ImageWriter printer, you can also choose to print any selection 
reduced to 50% of its original size by clicking the 50% Reduction option in 
the Page Setup dialog box. 

To print an entire Spreadsheet document: 

□ Make sure that no more than one cell is selected in the document. (Other¬ 
wise, Works will print only the selected cells.) 

E Choose Page Setup from the File menu. 

0 Click the appropriate options and type any text you want for a header and 
footer. 

E If you want to print cell notes, click the Print Cell Notes option. 

E Click the OK button or press the Return key. 

E Choose Print from the File menu. 

E Click the appropriate options. 

E Click the OK button or press the Return key. 

Works prints your entire Spreadsheet document. If the document is too wide 
to fit on one page, Works prints the remaining columns on subsequent pages 
before continuing to print the remaining rows. 

Normally, the Spreadsheet prints across the narrow part of the page. Because 
Spreadsheet documents are often wider than they are long, you may want to 
print in the wider direction. 

To print a Spreadsheet document horizontally: 

E Choose Page Setup from the File menu. 

E Click the Orientation icon showing horizontal (wide) printing. 

E Click the OK button or press the Return key. 

E Choose Print from the File menu. 

E Click the appropriate options. 

E Click the OK button or press the Return key. 

Works prints your Spreadsheet document horizontally on the paper. 

To print an entire 
Spreadsheet 
document 

To print a Spread¬ 
sheet document 
horizontally 
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To print the active 
window 

To print just the active window: 

\m\ Choose Print Window from the File menu. 

To print a range of 
cells 

To print a selected range of cells: 

0 Select the range of cells you want to print. 

H] Choose Print from the File menu. 

H] Click the appropriate options. 

0 Click the OK button or press the Return key. 

Works prints just the selected range of cells. If the selection crosses a page 

break, Works prints the selection on two pages. 

To print cell notes To print cell notes: 

\m\ Click the Print Cell Notes option in the File menu’s Page Setup dialog 

box. 

Cell notes are printed separately, after the Spreadsheet document has been 
printed. Cell notes are identified by their cell reference, and are printed first 
by column, then by row. (For example, A1 through A10, then B1 through 

BIO, and so on.) 

To preview cell notes before printing, click the Print Cell Notes option in the 
Page Setup dialog box. Then choose Print from the File menu, and click the 
Print Preview option. For more information on Print Preview, see “Print” in 

Chapter 2. 



14 Charting a Spreadsheet 
Document 

This chapter explains how to use the Spreadsheet’s charting capability to plot 
the information in your Spreadsheet documents. You’ll learn how to: 

■ Create series charts. 

■ Create pie charts. 

■ Work with chart definitions and charts. 

The Spreadsheet’s charting capability converts information from Spreadsheet 
documents into charts. Each Spreadsheet document can have up to eight chart 
definitions stored with it. A chart definition consists of the information you 
specify in a dialog box for either a series chart or a pie chart. 

When you’re trying out different scenarios in the Spreadsheet — changing the 
numbers or the formulas you use for calculation — the results show up 
immediately on your chart. Charts can speed up your analysis of numbers. 
Relationships that are otherwise hard to see show up easily on a chart. 

Charts also enhance presentations. If you use an overhead projector and have 
a LaserWriter printer, you can make changes up to the last minute, and print 
the charts directly on overhead transparencies. Or, you can have your printed 
charts made into slides. 

You can use information from other spreadsheet or database programs to 
make charts. Just copy the information into a Works Spreadsheet document; 
then you’re ready to create a chart. For more information, see Appendix B, 
“Using Works with Other Applications.” 

Works can create two types of charts: series charts and pie charts. 

■ Series charts show relationships between numbers. For example, a series 
chart might illustrate a company’s total sales for each of the last four 
quarters. 

■ Pie charts help you see proportions of a whole. For example, a pie chart 
might show a breakdown of your expenses as part of an overall budget. 

Types of charts 
Works can create 
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Series Charts 

This section gives a brief overview of the different kinds of series charts, and 
describes how to create them. Works draws four types of series charts: line 
charts, bar charts, stack charts, and combination charts (called “combo” in 
the dialog box). 

* File Edit Window Macro r 6 File Edit Window Macro 

Line Chart Stack Chart 

6 File Edit Window Macro * File Edit Window Macro 

I Sales in Chart 1 | 

Sales in the Americas 

□ Monthly Sales o Cumulative Sales 

Combination Chart 

Each of these charts gives you a different way of looking at the same infor¬ 
mation. The type you use depends on the information you’re analyzing, or 
how you want to show it. It’s similar to working with an artist: you supply 
the information and explain what kind of chart you want, and the artist draws 
it. Of course, with Works you can use the same information with different 
types of charts to quickly see which one works best. 



Chapter 14 Charting a Spreadsheet Document 257 

Line and Bar Charts 

A line chart uses a line to link together points that represent numbers. When 
you compare more than one set of numbers, each set of numbers has one 
line. As each line crosses the categories on the horizontal axis, it marks the 
intersection with a distinct symbol called a point marker. In the following 
illustration, for example, the point marker representing South America is a 
square. 

6 File Edit Window Macro 

For a single set of numbers (three months of North American sales projec¬ 
tions, for example), a bar chart draws a series of bars, each representing one 
number. When you’re comparing more than one set of numbers, such as three 
months of sales projections for North America and South America, a bar 
chart groups the numbers by category (months, in this case), so you can see 
at a glance how the figures for each month compare. 

Line charts 

Bar charts 
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When to use line or 
bar charts 

6 File Edit Window Macro 
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□ North America □ South America 

Ja 

Bars for each category 
are grouped together. 

Line charts are very effective at showing a trend — a growth or decline in 
numbers over time. Use line charts when it’s important to see trends over a 
period of time — how last year’s growth curve compares to this year’s, for 
example. 

Bar charts compare sets of numbers divided into discrete categories. Use bar 
charts when it’s important to compare numbers within a category of 
numbers — April of this year and April of last year, for example. 

Stack and Combination Charts 

Stack charts are a variation on bar charts. Stack charts illustrate component 
parts of a total as they change. For example, the stack chart on the next page 
shows how sales projections in North and South America compare with actual 
sales. 

Stack charts 
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A regular bar chart doesn’t show these amounts added up, so although you 
see how the amounts compare, you don’t see their totals. 

Combination charts combine a bar chart with a line chart. Use combination 
charts when you want to see one set of numbers (with bars) and the trend of 
another set of numbers (with a line) at the same time. 

Combination charts 
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To create a series 
chart 

Creating a Series Chart 

To set up a chart definition for a series chart, you use a chart definition dia¬ 
log box. In this dialog box, you provide all the information Works needs to 
draw a series chart of your Spreadsheet data. You specify the chart type, a 
chart title, titles for the vertical and horizontal scales, the headings of the 
columns and rows to be charted and to be used for the data legend and the 
horizontal titles, and the vertical scale of the chart. 

To see the chart definition dialog box: 

|¥1 Choose New Series Chart or Select Chart Definition from the Chart menu. 

Choosing New Series Chart takes you directly to a new chart definition 
dialog box. 
Choosing Select Chart Definition gives you the Select Chart Definition 
dialog box which contains a list of existing charts. Select a chart defini¬ 
tion name and click the OK button to see the chart definition dialog box. 

The following illustration shows how you use the information in your 
Spreadsheet document to set up a chart definition in the dialog box and to 
create a chart. 
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6 File Edit Window Macro 



262 The Spreadsheet 

To specify a chart 
title 

To choose a chart 
type 

To specify titles for 
scales 

Specifying a Chart Title 

You can put a title on the chart by typing it into the Chart Title text box of 
the chart definition dialog box. If you don’t specify a title, Works will plot 
the chart without any title. 

To specify a chart title: 

[■] Type a title into the Chart Title text box. 

When you plot the chart, this title appears directly above the chart. 

Choosing a Chart Type 

The four icons in the upper-left comer of the New Series Chart dialog box let 
you choose between a line chart, a bar chart, a stack chart, or a combination 
(combo) chart. 

To choose a chart type: 

0 Click the icon that represents the type of chart you want to make. 

If you aren’t sure what type you want, review the descriptions at the begin¬ 
ning of this section, or just choose a type to experiment with. You can easily 
change to another type later. 

Specifying Titles for the Horizontal and Vertical Scales 

You can specify titles for the horizontal and vertical scales of the chart. Scale 
titles help to explain the units of information shown on the scales. If you 
don’t type scale titles into the text boxes, Works will not show any vertical 
and horizontal scale titles. 

To specify titles for the scales: 

0 In the New Series Chart dialog box, type titles into the Vertical Scale 
Title and Horizontal Scale Title text boxes. 

When you plot the chart, these titles appear on the chart. 

Choosing the Information To Chart 

Numbers define the chart, telling Works how high to make a bar or where to 
put a point on the scale. 

The numbers that define a chart are in the rows and columns of your 
Spreadsheet document. Works lets you plot up to four sets of information in 
a series chart. That means you can choose up to four rows from a Spread¬ 
sheet document for charting. 
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To specify the rows and columns that you want to chart: 

0 Move the New Series Chart dialog box aside by dragging its title bar so 
you can see the rows and columns you want to chart. 

d] In the Values to be Plotted boxes, type the headings (numbers) of the 
rows that contain the values you want to chart from the Spreadsheet 
document. 

If the data you want to chart is in columns, you’ll need to transpose it 
into rows before charting. Activate the Spreadsheet document and use the 
Copy and Paste with Options commands from the Edit menu. 

0 In the From Column and To Column boxes, type the headings of the 
columns which begin and end the information you want in the rows you 
specified in step 2. 

Works will chart numbers in the specified rows from the beginning 
column to the ending column. The columns must be adjacent to one 
another. 

Labels help you identify your numbers. Your Spreadsheet row labels (the text 
that describes the information in the rows) become the data legend. The data 
legend describes the sets of information in the chart. Your Spreadsheet 
column labels (the text that describes the information in the columns) become 
titles for the horizontal axis. Works calls these horizontal titles. 

To specify a data legend and horizontal titles: 

0 In the Data Legends in Column box, type the heading of the column con¬ 
taining the labels for the rows of information you’re charting. 

The data legend will appear at the bottom of the chart, and will identify 
the shading patterns used for each bar in a bar chart, or the shape of the 
point marker used for each line in a line chart. 

0 In the Horizontal Titles in Row box, type the heading of the row contain¬ 
ing the labels for the columns that you’re charting. 

These labels will appear along the horizontal scale to label each bar in a 
bar chart or each point in a line chart. (If you are charting many columns, 
there may not be room for every label on the chart, so Works will show 
representative labels.) 

Setting the Vertical Scale 

You can choose to have a numeric scale or semi-logarithmic scale for the 
chart. A numeric scale is divided into ten regular increments—10, 20, 30, 
40, .. .100, for example. A semi-logarithmic scale exaggerates the size of 
smaller numbers and minimizes the size of larger numbers. It makes it easier 
to show very large numbers and very small numbers on the same chart. 

To specify rows and 
columns to chart 

To specify a data 
legend and horizontal 
titles 

To set the vertical 
scale 
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For example, with a semi-logarithmic scale, the distance on the chart below 
between 1000 and 10,000 is the same as the distance between 10,000 and 
100,000. 

6 File Edit Window Macro 

Semi-logarithmic scale 

You can also choose to limit the chart to a certain range, between a minimum 
and a maximum. You might want to do this if all your amounts were greater 
than a certain amount, like a million; less than a certain amount, like two 
million; or between two amounts. If your minimum were one million and 
your maximum two million, you could use the full range of the chart to see 
the numbers between those two figures. 

Setting a maximum can also make a chart with a numeric scale easier to read. 
When you choose a numeric scale, Works uses the largest number in the 
chart as the top of the scale. Works divides the scale into ten segments. For 
example, if the largest number is 793, each marker on the vertical scale will 
be a multiple of 79 (79, 158, 237, ...). To establish more standard divisions, 
you can set a maximum that is a multiple of ten. For example, with a max¬ 
imum of 1,000,000, you’ll have divisions at 100,000, 200,000, and so forth. 
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Numeric scale with maximum set to 1,000,000 

To set the vertical scale: 

0 In the New Series Chart dialog box, click Numeric or Semi-Logarithmic 
for the vertical scale. 

[XI Type a maximum, a minimum, or both, if you want them. 

Choosing To Show a Grid or Labels 

A grid helps you see where points on the chart line up on the scales. Labels 
(titles) help you identify what the numbers mean. You can choose whether or 
not a chart will show the grid or the labels. 

To show the grid or labels, if they are not already checked in the New Series 
Chart dialog box: 

\u\ Click the Draw Grid option, 
or 

\u\ Click the Label Chart option. 

If the options are checked already, and you do not want either a grid or the 
labels on your chart, click to remove the checkmark. 

Your chart definition is now complete. 

To choose a grid or 
labels 
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To plot the chart 

To avoid plotting the 
chart 

Click an icon to tell Works what Set a maximum or minimum 
type of chart you want. for the vertical scale here. 

Works abbreviates the chart 
definition name, if necessary. 

Sales Pro Chart 1 

V 

\ 

Type of Chart: 

O 
LINE 

w 9 

llfili 

Ualues to be Plotted: 

1st Row: 

2nd Row: 

3rd Row: 

4th Row: 

From Column: 

To Column: 

B 

Uertical Scale: 
(§) Numeric 
O Semi-Logarithmic 

Maximum: 

Minimum: 

O [flftfflf Data Legends in Column: R ^ Draw Grid 
E] Label Chart /\ COMBO 

Horizontal Titles in Row: 1 

Chart Title: N. and S. Europe Sales Projections 

Uertical Scale Title: Dollars in Thousands 

Horizontal Scale Title: Months after Great Rlpine Race 
\ 

[ Cancel ] |[Plot It! 

Click here to draw a series chart. 
Click to remove the checkmarks if you don’t 

want a grid or labels on the chart. 

Plotting the Chart 

After you’ve filled out the dialog box, you can take any of the following 
actions. 

To plot the chart: 

\u\ Click the Plot It! button. 

Works draws the chart and stores the definition with the Spreadsheet 
document. 

To then return to the chart definition dialog box: 

\u\ Double-click anywhere in the chart window. 

To store the chart definition without drawing the chart: 

\u\ Click the close box. 

Works stores the definition and returns you to the Spreadsheet document. 
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To return to the Spreadsheet document without storing the chart definition or 
drawing the chart: 

0 Click the Cancel button. 

If you want to continue working with your series chart before you begin 
learning about pie charts, skip ahead in this chapter to “Working with Charts 
and Chart Definitions.” 

Pie Charts 

This section explains what pie charts show, what you might use them for, 
and how to create them. 

Pie charts compare parts of a whole. For example, a pie chart can illustrate 
which parts of a company’s budget are allocated to production, marketing, 
development, and overhead. 

You can supply a title in 
the Chart Title text box. 

You can change the chart definition name 
using the Change Chart Name command 
from the Edit menu. 

Specify value titles in the Column 
of Value Titles text box. 

Specify column and rows to be charted in 
the Plot Values in Column, From Row, and 

Through Row text boxes. 

When to use a pie 
chart 
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To create a pie chart 

To specify a chart 
title 

Creating a Pie Chart 

Pie charts compare only one set of information, dividing it into parts of a 
total — the pie. In a Spreadsheet document, this corresponds to one column 
of numbers. A column of labels provides the key for each slice of the pie. 

Works calls these labels value titles. 

If you have a Spreadsheet document with several columns of information that 
you want to chart as pie charts, you can define a pie chart for each column. 
Each of the pie chart definitions will be stored with your Spreadsheet docu¬ 

ment, so that you can look at them at any time. 

To set up a chart definition for a pie chart, you use a chart definition dialog 
box. In this dialog box, you specify the column containing the values you 
want to plot, the beginning and ending row headings, and the column con¬ 

taining the labels for the value titles. 

To see the chart definition dialog box: 

[i] Select New Pie Chart or Select Chart Definition from the Chart menu. 

Choosing New Pie Chart takes you directly to a new chart definition dia¬ 

log box. 

Choosing Select Chart Definition gives you the Select Chart dialog box, 
which contains a list of existing charts. Select a chart definition name and 

click the OK button to see the chart definition dialog box. 

Specifying a Chart Title 

You can put a title on the chart by typing it into the Chart Title text box of 
the chart definition dialog box. If you don’t specify a title, Works will plot 

the chart without any title. 

To specify a chart title: 

[1] Type a title for the chart into the Chart Title text box. 

When you plot the chart, this title appears directly above the chart. 

Completing the Chart Definition 

When you define a pie chart, you need to tell Works which values to plot. 
Fill in the rest of the New Pie Chart dialog box to indicate which values 
you want to plot and which value titles you want to use. Remember that you 
can move the dialog box to see the Spreadsheet document by dragging its 

title bar. 
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Prelimina Chart 2 

Pie Chart Definition: 

Chart Title: Preliminary Budget 

Plot Ualues in Column: |b^ 

From Rom: |Y" 

Through Rom: [5"" 

Column of Ualue Titles: R 

Plotting the Chart 

After you’ve filled out the dialog box, you can take any of the following 
actions. 

To plot the chart: 

\m\ Click the Plot It! button. 

Works draws the chart and stores the definition with the Spreadsheet 
document. 

To then return to the chart definition dialog box: 

0 Double-click anywhere in the chart window. 

To store the chart definition without drawing the chart: 

0 Click the close box. 

Works stores the definition and returns you to the Spreadsheet document. 

To return to the Spreadsheet document without storing the chart definition or 
drawing the chart: 

0 Click the Cancel button. 

To plot the chart 

To avoid plotting the 
chart 

To learn about more ways to work with your pie chart, continue on to the 
next section, “Working with Charts and Chart Definitions.” 
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To change a chart 
definition name 

Working with Charts and Chart Definitions 

Once you’ve set up a chart definition for either a series chart or a pie chart, 

you can continue to work with it. You can: 

■ Change the name of a chart definition. 

■ Select either a chart or a chart definition to look at again. 

■ Change a chart by changing information in the Spreadsheet document or 

by changing its definition. 

■ Copy or remove chart definitions from a Spreadsheet document. 

This section tells you how to work with all types of charts. 

Changing Chart Definition Names 

The title bar of a chart definition dialog box shows the name of the chart 
definition. When you set up several chart definitions for a single Spreadsheet 

document, you’ll be able to identify each one by name. 

Unless you specify a name using the Edit menu as described below, Works 
automatically names each chart definition with the name of the Spreadsheet 
document plus the word “Chart” and a number from 1 to 8. If the 
Spreadsheet document name is too long to fit, Works abbreviates it. 

If you prefer, you can change the name of a chart definition to make it more 

meaningful to you. 

To change the name of a chart definition: 

[H When a chart definition dialog box is open, choose Change Chart Name 

from the Edit menu. 

0 Type a new name into the text box. 

0 Click the OK button or press the Return key. 

The name in the title bar of the dialog box changes to reflect what you typed. 
You’ll see this same name in the title bar of the chart when you plot the 
chart, and in the dialog boxes that appear for other commands from the Chart 
menu. The name of the chart definition doesn’t appear on the chart itself, 
however. You can put a title on your chart by typing it into the Chart Title 

text box in the chart definition dialog box. 



Chapter 14 Charting a Spreadsheet Document 271 

Selecting a Chart 

After you’ve defined a chart, you can choose to draw it directly from the 
Chart menu. You don’t have to set up a new definition every time you want 
to chart something. 

Here’s how to draw a chart quickly: 

0 Choose Draw Chart from the Chart menu. 

Works displays a dialog box listing the chart definitions stored with the 
active Spreadsheet document. 

0 Select the chart you want to see. 

0 Click the OK button or press the Return key. 

Works draws the chart. 

Selecting a Chart Definition 

If you’ve set up a chart definition, you might want to look it over or make 
changes. You can move to a chart definition dialog box either from the Chart 
menu (when you’re working in the Spreadsheet) or from the chart itself. 

When you want to look at a chart definition for a Spreadsheet document, you 
can use the Chart menu. 

0 Choose Select Chart Definition from the Chart menu. 

Works displays a dialog box listing the chart definitions stored with the 
active Spreadsheet document. 

0 Select the definition you want to see. 

0 Click the OK button or press the Return key. 

Works opens the dialog box containing the definition you specified. 

The Chart menu is not available when you’re looking at a chart. But you can 
still return to the chart’s definition if you want to make changes. 

To see the chart definition when a chart window is open: 

0 Double-click anywhere in the chart window. 

Works displays the chart definition dialog box. 

To draw a chart 

To see a chart 
definition from the 
Chart menu 

To see a chart 
definition from 
the chart 
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To change the 
Spreadsheet while 
charting 

To change a chart 
definition 

Changing a Chart 

You may find that you need to change something about a chart. You can 
change the actual contents of a Spreadsheet document and see those changes 
reflected immediately in the chart. Or you can change the chart definition: the 
information you want to chart, the type of chart, the titles on the chart, or the 

scale of the chart. 

You can work on a Spreadsheet document and a chart at the same time, as 
you analyze your information. If you’re making projections or comparing 
alternatives, you see graphically how alternative numbers or calculations 
affect your results — without waiting, because the chart is linked directly to 

the Spreadsheet document. 

To change Spreadsheet information while charting: 

0 Click anywhere in the Spreadsheet window to activate it. 

[U Select the cells you want to change and make the changes. 

As you enter the changes in the Spreadsheet document, the chart will reflect 

them. 

The chart definition tells Works what information to plot and where to put it. 

You can change a chart definition whenever you want. 

To change a chart definition: 

E Open a chart definition dialog box. 

You can do this from the Chart menu or by double-clicking a chart. 

0 Change the appropriate information in the definition. 

0 Click Plot It! to see the changed chart, or click the close box to save the 
changes to the definition and discard the original definition. 

Remember, if you change your mind, you can always click Cancel to return 
to the Spreadsheet document without storing the changes to the definition or 

seeing the chart. 
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Copying a Chart Definition 

Works lets you make a copy of a chart definition. Then you can make 

changes to the copy without changing the original. You’ll find this useful 
if you need to make several similar charts from the same Spreadsheet 
document. 

To copy a chart definition: 

□ Choose Duplicate Chart from the Chart menu. 

Works displays a dialog box listing the chart definitions stored with the 
active Spreadsheet document. 

0 Select the definition you want. 

0 Click the OK button or press the Return key. 

The chart definition dialog box appears. You can change the title of the chart 
and its characteristics. 

To copy a chart 
definition 

When you click Plot It! or the close box, you store the new definition with 
the Spreadsheet document. The original definition remains on the disk as 
well. 

Removing a Chart Definition 

Suppose you decide you no longer need a chart, or you accidentally make a 
chart you don’t want. Or perhaps you already have the limit of eight defini¬ 
tions, and you want to make a new one. You can remove a chart definition 
you don’t want to make room for another. 

To remove a chart definition: 

HI Choose Erase Chart from the Chart menu. 

Works displays a dialog box listing the chart definitions stored with the 
active Spreadsheet document. 

H] Select the definition you want to remove. 

0 Click the OK button or press the Return key. 

Works removes the chart definition. 

To remove a chart 
definition 





15 Spreadsheet and 
Database Functions 

This chapter is divided into three sections: 

■ An introduction to Works functions. 

■ A brief listing of the available Spreadsheet and Database functions 
arranged by subject category. 

■ A detailed alphabetical directory of these functions. 

Functions 

A function is a built-in calculation that produces a new value from other 
values, called arguments. 

Works has 64 built-in functions that you can paste or type into Spreadsheet 
formulas. You can also paste or type these functions into computed Database 
fields, except for functions that use ranges as arguments, such as 
Sum(Al:A5). Functions used in the Database can’t relate to more than one 
record at a time and can only use other fields in the same record. 

Functions you can’t use in the Database are: 

■ The IRR and MIRR Financial functions. 

■ The HLookup, Index, Lookup, Match, and VLookup Special-purpose 
functions. 

The following functions often take ranges as arguments, but can be used in 
the Database with a single field reference, a list of fields separated by com¬ 
mas, or a value in place of a range: 

■ All of the Statistical functions — Average, Count, Max, Min, SSum, 
StDev, Sum, and Var. 

■ The FV, NPV, Pmt, PV, and Rate Financial functions. 

■ The And, Choose, If, IsBlank, and Or Logical functions. 
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Parts of a function 

Arguments to 
functions 

To enter a function 
into a formula 

Syntax of Functions 

Each function consists of the function name, a set of parentheses, and argu¬ 
ments (the values the function uses to produce a new value) separated by 
commas. 

Name of fu notion 
Parentheses 

-1 

Argumer 

-i iweragel f30000 .10000) 

its separated by a comma 

The parentheses are very important. They tell Works where the arguments 
begin and end. When you paste a function using the Paste Function command 
from the Edit menu, Works provides the parentheses and positions the inser¬ 
tion point between them. All you do is type the arguments and the commas. 

If you type the function instead of pasting it, remember to type the 
parentheses. Do not leave any space before the left parenthesis. Be sure to 
finish with a right parenthesis. Otherwise, Works displays an alert box. 

In a Spreadsheet document, a function argument can be a number, a formula, 
a cell reference, a range reference, another function, or an expression such as 
C3/2. You can click cells to insert references into the arguments of a 
function. 

In a Database, an argument to a function can be a number, a formula, a field 
name, or another function. 

Functions may have no arguments, one argument, or several arguments. 
Many functions have more than one argument. For example, both 
Average(Fl:F5) and Average(Fl,F2,F3,F4,F5) calculate the average value of 
cells FI through F5. Pmt(0.0167,36,12000) calculates the amount you’d have 
to pay back on a loan of $12,000 over a period of 36 months at 1.67% 
interest per month. 

You can include functions in a formula either by typing them or pasting 
them. 

To paste a function into a formula in the entry bar: 

0 Select the cell or calculated field to hold the formula. 

0 Position the insertion point where you want the function to go in the 
formula. 

0 Choose Paste Function from the Edit menu. 
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0 Select the function you want from the list. 

0 Click the OK button or press the Return key. 

Works pastes the function into your formula, including the parentheses. 
The insertion point is inside the parentheses, ready to accept arguments to 
the function. 

The insertion point shows 
where the arguments go. 

E Type any values or, in the Spreadsheet, click any cell references required 
by the function. 

0 Include any additional operators and operands that you need in your 
formula. 

=Sum(B4:B8|) 

0 Click the enter box or press the Enter key. 

Works enters the formula into the active cell or calculated field, calculates it, 
and displays the resulting value. 

When you enter the formula, Works displays the 
formula in the entry bar... 

...and displays the result of the 
calculation in the selected cell. 

* File Edit Window Select Format Options Chart Macro 

Expenses May P frcent June : Percent ! 
Basic Food $30'0001. 22 .22*1 $10,000 
Special Food Requests . .4 .44* j . 9*1 
Lodging """piojioo]. "44 A4%\. ’ $20,000 j 

.+• 
30*1 

Bicycles .$20^001.J 14 Sir .$57666 =: ~7*I" 
Promotions $12,666]"/" si '89*1. "" $12,000 18*J 
Total Expenses $128,000 y '94 ii*l ""]$53^bbo"|. 79*i" 

Total Budget Available | $1OT]000 j. 100 0
: 

0
: 

tf
j 

$67/500 j. 

. 
l 

100*{ 

Under (Overji Budget 1. "5" 19*|'"" $14^500 J " 

.r 

.1.. 
21*1 



278 The Spreadsheet 

To enter a range 
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If you choose to type a function rather than paste it, be sure to type an 
equal sign to begin the formula, and include parentheses before and after the 
arguments. 

An empty cell or a cell containing text is normally treated as 0 when used as 
an argument to a function. However, the functions Average, Count, Max, 
Min, SSum, StDev, Sum, and Var ignore these cells completely. 

In some cases, numeric values represent a logical value of either TRUE or 
FALSE. For example, in the If function the first argument returns the second 
argument if the function is TRUE, and the third argument if it is FALSE. 
The number 0 represents FALSE, and all other numbers, or a blank, 
represent TRUE. 

For example, if Spreadsheet cell A1 contains 2, then the formula If(Al,3,4) 
equals 3 would result in the value 3. The If function returns the second argu¬ 
ment, 3, which is TRUE. If A1 contains 0, or is blank, then If(Al,3,4) 
equals 4. The If function returns the third argument, 4, which is FALSE. 

In other cases, the result of a function may be a numeric value that represents 
a logical value. In the IsNA function, for example, the number 0 represents 
FALSE, and the number 1 represents TRUE. 

For example, if A1 contains N/A, IsNA(Al) equals 1 (TRUE). If A1 con¬ 
tains a label or number, or is blank, IsNA(Al) equals 0 (FALSE). 

The And, Or, and Not functions are examples of both these types of func¬ 
tions in that their arguments, as well as their results, are logical values 
represented by numbers. 

For example: 

Not(l) equals 0 And(— 1,2,4) equals 1 

Not(2) equals 0 And(— 1,2,0) equals 0 

Not(0) equals 1 Or(0,0,5) equals 1 

You can use range references in functions used in the Spreadsheet. You can 
refer to a range of cells with one reference; for example, Sum(Cl:E10). The 
reference includes the beginning reference, a colon standing for “to,” and the 
ending reference. For example, the range reference A2:B5 refers to all the 
cells from A2 (the upper-left cell) to B5 (the lower-right cell), inclusive. 

To enter a range reference into a formula: 

□ Select a cell, then start a formula by typing an equal sign. 

0 Type the function name and a left parenthesis, or paste the function to be 
used with the Paste Function command from the Edit menu. 

0 Drag across a block of cells, or type a reference for a range of cells. 

0 If you typed the function, end the reference with a right parenthesis. 

If you drag with the mouse, an outline shows you the range of cells 
you’re referring to. If you type, remember to include the colon. You can 
use a combination of clicking and typing. 
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Drag down this range of cells... 

...to enter this reference into the formula. 

Cell into which the 
formula will be entered 

First cell in the range 

Last cell in the range 

In the function directory that follows, arguments are described with this 
notation: 

Value or number Refers to an argument that must be a number, cell refer¬ 

ence, or formula, as in Min(2,3), Min(Al,Bl), or 
Min(3 +Al,Sqrt(4)) 

Range Refers to an argument that must be a range reference, 
such as B9:F9 

Values Refers to an argument that can be a number, cell refer¬ 
ence, formula, or range reference 

To distinguish different arguments in a function, numbers are added to the 
standard notation. For example, if there is more than one value, they are dis¬ 
tinguished by value-1, value-2, and so on. If there is more than one range, 
they are distinguished by range-1, range-2, and so on. 

When there is a useful descriptive word for an argument, such as “rate” in a 
Financial function, that word is used in place of the generic term “value.” 
Sometimes the standard notation is modified by another word, as in lookup- 
value and compare-range, for values in functions that look up values and 
compare ranges (HLookup, Lookup, Match and VLookup). 

Notation conventions 
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About Date and Time 
functions 

Works stores dates and times internally as serial numbers from 0 to 49710, 
where 0 is the number for January 1, 1904, and 49710 is the number for 
February 6, 2040. Times are stored as decimal fractions. For example, the 
serial number for noon on 5/9/88 is 30810.5. To find out a date s serial 
number, select a cell or computed field containing the date, and format it as 
General. The serial number appears in the entry bar. 

Because Works stores dates and times as serial numbers, you can perform 
calculations with them as you would with other numbers. For example, you 
could enter the date you bought stock in one cell, the date you sold it in 
another cell, and a formula that subtracts the two in a third cell. The first two 
cells should be in a Date format, and the cell containing the formula should 
be in General format. 

Works provides three formats for dates (Date Short, Date Medium, and Date 
Long), and one format for time. When you choose a date or time format in 
the Set Cell Attributes dialog box and enter a date or time into a cell, Works 
displays the date or time and stores its serial number. 

If you change the format to something besides a date or time format, the 
serial number appears in the cell with the new format. 

You can enter dates in any of these ways: 

4/23/88 23-Apr 

4/23 Apr 23 

23-Apr-88 Apr-88 

4/88 23/apr/88 

You can enter times in any of these ways: 

4:48 PM 16:48 

4:48 AM 4:48 

4:48 a 4:48 P 

If you enter a date or time into a cell that has a format other than General, 
Works converts the date or time into a serial number and stores that number 
but does not change the format of the cell. For example, if you type 4-Apr 
into a cell that has the format m/d/yy, Works stores its serial number, 30775, 
and displays 4/4/88. 

If you enter a serial number for a date or time that is out of range, Works 
displays * Error* in the cell. 

You can also enter both a date and time into one cell. Be sure to separate the 
date and time by a space. For example, you can type either 4123188 16:48 
or 4:48 PM Apr-88. If you enter both a date and a time into a cell. Works 
displays the date or time in the format selected in the Set Cell Attributes 
dialog box. 
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Functions by Subject Category 

The detailed directory of functions in this chapter is presented in alphabetical 
order for quick reference. However, to help you more readily see what func¬ 
tions are available in Works, they are also presented below, grouped by sub¬ 
ject category. 

Mathematical Functions 

Abs(number) 
Absolute value of number 

Exp (number) 

e to the power number 

lnt(number) 

Integer part of number 

Ln(number) 

Logarithm, base e, of number 

Log 10 (number) 

Logarithm, base 10, of number 

Mod {number, divisor-number) 

Remainder of number divided by divisor-number 

Pi() 
Value of tt 

Rand( ) 
Random number between 0 and 1 

Round (number} number-of-digits) 
Number rounded to number-of-digits 

Sign (number) 
Sign of number 

Sqrt {number) 
Square root of number 

Mathematical 
functions 
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Statistical functions 

Trigonometric 
functions 

Statistical Functions 

Average(values-l ,values-2,...) 
Average of values in values 

Co\mt(values-l ,values-2,...) 
Count of values in values 

M3.x(values-1 ,values-2,...) 
Maximum value in values 

Min(values-1 ,values-2f...) 
Minimum value in values 

SSum(values-l,values-2,...) 
Sum of values displayed on the screen 

StDev(values-l,values-2,...) 
Standard deviation of values 

Sum(values-1 ,values-2,...) 
Sum of values 

Var(values-1 ,values-2,...) 
Variance of values 

Trigonometric Functions 

ACos {number) 
Arccosine of number 

ASin (number) 
Arcsine of number 

ATan (number) 
Arctangent of number 

ATan2(jt-number yy-number) 
Arctangent of point (x-number,y-number) 

Cos(number) 
Cosine of number 

Degrees (number) 
Converts number from radians to degrees 

Radians (number) 
Converts number from degrees to radians 

Sin (number) 
Sine of number 

Tan (number) 
Tangent of number 
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Logical Functions 

And(values-1 ,values-2,...) 
1 (TRUE) if all values are non-zero (TRUE); otherwise, 0 (FALSE) 

Choose(index,value-l,value-2,...) 
Uses index to select a value from the values 

False() 
Returns the value 0 (FALSE) 

If (number, value-if-true, value-if-false) 

Value-if-true if number is non-zero (TRUE); value-if-false if number is 0 
(FALSE) 

lsBlwnk(values-l ,values-2,...) 
1 (TRUE) if all values are blank or text; otherwise, 0 (FALSE) 

IsError(va/ue) 
1 (TRUE) if value is any error value 

IsNA(vaZwe) 
1 (TRUE) if value is the error value N/A 

Not (number) 

1 (TRUE) if number is 0 (FALSE); 0 (FALSE) if number is non-zero 
(TRUE) 

Or(values-l,values-2,...) 

1 (TRUE) if any logical value in values is non-zero (TRUE); otherwise 0 
(FALSE) 

True() 
Returns the value 1 (TRUE) 

Financial Functions 

FV (rate, nper,pmt,pv, type) 

Future value of investment 

IRR (range, guess) 

Internal rate of return of range 

MIRR(rajzge, safe, risk) 

Modified internal rate of return of range 

NPer(rate,pmt,pv,Jv, type) 
Number of payments of investment 

NPV(rate, values-1, values-2,...) 
Net present value of values 

Pmt (rate, nper,pv,fv, type) 

Periodic payment of investment 

P V (rate, nper,pmt,jv, type) 
Present value of investment 

Rat e(nper,pmt,pv,fv, type, guess) 
Rate returned on investment 

Logical functions 

Financial functions 
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Date and Time Date and Time Functions 
functions 

Dat eiyear, month, day) 
Returns serial number of the specified date 

Day (serial number) 
Converts serial number to a day of the month 

Hour (serial number) 
Converts serial number to an hour of the day 

Minut^(serial number) 
Converts serial number to a minute 

Month {serial number) 
Converts serial number to a month of the year 

Now() 
Returns serial number of current date and time 

Second (serial number) 
Converts serial number to a second 

T\mt(hour, minute, second) 
Returns serial number of the specified time 

Weekday(^na/ number) 
Converts serial number to a day of the week 

Year (serial number) 
Converts serial number to a year 

Special-purpose 
functions 

Special-Purpose Functions 

Error() 
Returns the value * Error* 

HLookup(lookup-value,compare-range, index-number) 

Value in a table selected by lookup-value 

In dex(range,row, column) 
Reference in range selected by index values row and column 

Lookup (lookup-value,compare-range, result-range) 

Value in a table selected by lookup-value 

Match (lookup-value,compare-range, type) 
Number of a value selected by lookup-value 

NA( ) 
Returns the value N/A 

Typ c(value) 
Type of value 

VLookup(lookup-value, compare-range, index-number) 
Value in a table selected by lookup-value 
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Alphabetical Directory of Functions 

The directory that follows gives detailed information and examples for each 
of the 64 built-in functions. 

AbS(number) 

The Abs function gives the absolute value of number. 

Example 

Abs(2) equals Abs( — 2) equals 2 

ACoS(number) 

The ACos function gives the arccosine of number. The arccosine is the angle 
in radians whose cosine is number. Number must be in the range — 1 to 1. 
The angle will be in the range 0 to it. 

Examples 

ACos(-0.5) equals 2.094 (2tt/3 radians) 

ACos( — 0.5)* 180/Pi( ) equals 120 (degrees) 

And(values-1 ,values-2,...) 

The And function gives the value 1 (TRUE) if all the values in the list of 
arguments are non-zero (TRUE). If any of the values is 0 (FALSE), And 
gives the value 0 (FALSE). 

If a reference argument contains text or blank values, those values are 
ignored. 

Examples 

And(2 + 2 = 4,2-1-3 = 5) equals 1 

And(2 + 2 = 5,2 + 3 = 5) equals 0 

Abs 

ACos 

And 
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ASin ASin(number) 

The ASin function gives the arcsine of number. The arcsine is the angle in 
radians whose sine is number. Number must be in the range — 1 to 1. The 
angle will be in the range — tt/2 to tt/2. 

Examples 

ASin( —0.5) equals —0.524 ( —tt/6 radians) 

ASin( —0.5)* 180/Pi( ) equals —30 (degrees) 

ATan ATail(number) 

The ATan function gives the arctangent of number. The arctangent is the 
angle in radians whose tangent is number. The angle will be in the range 
— tt/2 to tt/2. 

Examples 

ATan(l) equals 0.785 (tt/4 radians) 

ATan(l)*180/Pi( ) equals 45 (degrees) 

ATan2 ATan2(x-number,y-number) 

The ATan2 function gives the arctangent of x-number and y-number. The 
arctangent is the angle in radians determined by the point whose x and y 
coordinates are x-number and y-number. The angle will be in the range 
— tt to tt, excluding — tt. 

If both x-number and y-number are 0, ATan2 gives the value 0. 

Examples 

ATan2(l,l) equals 0.785 (tt/4 radians) 

ATan2( -1,-1) equals — 2.356 (— 3tt/4 radians) 

ATan2( — 1, — 1) * 180/Pi( ) equals — 135 (degrees) 

Average Average(values-1 ,values-2,...) 

The Average function gives the average of the numbers in the list of 
arguments. 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 
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Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Average(Al:A5) equals 11 

Average(Al:A5,5) equals 10 

Average(Al:A5) equals Sum(Al:A5)/Count(Al:A5) 

ChOOS@(index, value-1,value-2,...) 

The Choose function uses index to select a value from the following argu¬ 
ments in the list. If index is 1, Choose gives value-1; if index is 2, Choose 
gives value-2; and so on. 

If index is less than 1 or greater than the number of the last value in the list, 
Choose gives the error value *Error*. 

Examples 

Choose(2,10,20,30,40) equals 20 

Given that A2 = 2, Choose(A2,10,20,30,40) equals 20 

Choose 

CoS(number) Cos 

The Cos function gives the cosine of number, where number is an angle in 
radians. 

Examples 

Cos(1.047) equals 0.5 

Cos(60*Pi()/180) equals 0.5 

COU nt(values-1 ,values-2,...) Count 

The Count function gives the count of the numbers in the list of arguments. 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Count(Al:A5) equals 5 

Count(Al:A5,5) equals 6 
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Date 

Day 
Month 
Weekday 
Year 

Date(year,month,day) 

The Date function gives the serial number of the date specified by year, 
mouthy and day. For an explanation of dates and serial numbers, see “About 
Date and Time functions” earlier in this chapter. 

The serial number is an integer in the range 0 to 49710, representing dates 
from January 1, 1904, to February 6, 2040. The arguments year, month, and 
day should make up a valid date in this range. That is, year should be 
between 1904 and 2040; month should be between 1 and 12; and day should 
be between 1 and 31. 

Works automatically converts a date constant to a serial number. For exam¬ 
ple, 4/15/1988 and 15-April-1988 both convert to the serial number 30786. If 
you want year, month, or day to be formulas, rather than constants, you must 
use the date function — for example, = Date(1988,4,15). 

Example 

Date(1988,Choose(l,3,6,9,12),!) equals Date(1988,3,l) equals 30741 

Day(serial-number) 
Month(serial-number) 

Weekday(serial-number) 
Year(serial-number) 

The Day function gives the number of the day in serial-number as an integer 
in the range 1 to 31. The Month function gives the number of the month as 
an integer in the range 1 to 12. The Weekday function gives the number of 
the weekday as an integer in the range 1 to 7. The Year function gives the 
number of the year as an integer in the range 1904 to 2040. 

Serial-number should be in the range 0 to 49710 to represent a valid date. If 
serial-number is not an integer, only the integer portion is used, since dates 
are represented as integers. 

To compute days, months, and years, format the cell containing the date in 
Date Short, Date Medium, or Date Long format. Format the cell containing 
the formula for addition, subtraction, multiplication, or division in General 
format. 

Examples 

Day(Date(1988,4,15)) equals 15 

Month(Date(1988,4,15)) equals 4 

Weekday(Date(1988,4,15)) equals 6 

Year(Date(1988,4,15)) equals 1988 
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DcgreeSfriumber) 

The Degrees function converts an angle in radians to degrees. 

Example 

Degrees(2*Pi()) equals 360 

Error() 

The Error function takes no arguments and returns the value *Error*. 

Example 

Given that A1 contains the formula =Error(): 

If(IsError(Al),0,l) equals 0 

Exp(number) 

The Exp function gives e raised to the power of number. The mathematical 
constant e is 2.7182818..., the base of the natural logarithm. 

Exp is the inverse of the Ln function (natural logarithm). 

To calculate powers of other bases, use the exponentiation operator ('). 

Examples 

Exp(l) equals 2.7182818 (the value of the natural base, e) 

Exp(Ln(3)) equals 3 

False() 

The False function takes no arguments and returns the value 0 (FALSE). 

Example 

Choose(4,False( ),True( ),True( ),False( ),True()) equals 0 

Degrees 

Error 

Exp 

False 
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FV FV(rate,nper,pmt,pv,type) 

The FV function gives the future value of an investment involving constant 
cash flows. 

If you omit either pv or type, it is assumed to be 0. 

For a complete description of the arguments in FV, see PV. 

HLookup H LOO ku P(looku p-va I ue, compare-range, index-number) 
VLookup VLooklip(lookup-value, compare-range, index-number) 

HLookup and VLookup find an entry in a table. 

HLookup searches the first row of compare-range until it finds the largest 
value that is less than or equal to lookup-value. Then it goes up or down the 
column by the number of rows indicated by index-number and gives the value 
found there. 

If index-number is 1, HLookup gives the value from the current row. If 
index-number is 2, HLookup gives the value from the row below. If index- 
number is 0, HLookup gives the value in the row above the current row. If 
index-number is -1, HLookup gives the value in the row that is two rows 
above the current row. 

The values in the first row of compare-range must be in ascending order. If 
lookup-value is smaller than the smallest value in the first row of compare- 
range, HLookup gives the error value * Error*. 

The VLookup function is identical to the HLookup function, except that it 
searches the first column of compare-range until it finds the largest number 
that is less than or equal to lookup-value. Then it goes to the right by the 
number of columns indicated by index-number to get the entry. For VLookup 
to work properly, the first column must be in ascending order. 

Note The HLookup and VLookup functions can be used only in the 
Spreadsheet. 

Examples 

If A1:E1 contains the values 10000, 20000, 30000, 40000, and 50000, and 
A5:E5 contains the values .01, .02, .03, .04, and .05, then: 

HLookup(35000,Al:El,5) equals .03 

HLookup(35000, A1: E1,1) equals 30000 

HLookup(5000,Al:El,5) equals *Error* 

HLookup(.035,A5:E5, — 3) equals 30000 
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Hour 
Minute 
Second 

The Hour function gives the hour in serial-number as an integer in the range 
0 to 23. The Minute and Second functions give the minute and second as 
integers in the range 0 to 59. 

Hour, Minute, and Second use only the fractional part of serial-number, 
since times are represented as decimal fractions in the range 0 to 1, not 
including 1. 

Examples 

Hour(0.7) equals 16 

Minute(Time( 16,48,0)) equals 48 

Second(Time(l6,48,0)) equals 0 

Hour(serial -number) 

Minute(serial -number) 

S6C0nd(serial -number) 

lf(number,value-if-true,value-if-false) if 

The If function gives value-if-true if number is non-zero (TRUE), and value- 
if-false if number is 0 (FALSE). 

Example 

Given that A5 contains the number 98: 

If((A5<80),l,0) equals 0 

lnd@X(range, row, column) Index 

The Index function gives the value in a cell in a range at the intersection of a 
row and a column, starting from the cell in the upper-left comer of range. 

Note The Index function can be used only in the Spreadsheet. 
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Examples 

Index(B2:D4,2,3) equals the value of D3 

Index(B2:D2,l,2) equals the value of C2 

Index(B2:B4,2,l) equals the value of B3 

Index(B2:D2,0,0) equals the value of A1 

Index(C4:D4, -1,-1) equals the value of A2 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Index(Al:A5,3,l)/3 equals 3 

Int Int(number) 

The Int function gives the largest integer less than or equal to number. 

Examples 

Int(8.9) equals 8 

Int( —8.9) equals —9 

IRR IRR(range, guess) 

The IRR function gives the internal rate of return of a series of cash flows, 
represented by the numbers in range. The internal rate of return is the interest 
rate that gives the series of cash flows a net present value of zero. 

Works uses an iterative technique to compute IRR, which can have more than 
one solution. If the successive results of IRR do not converge after 20 itera¬ 
tions, IRR gives the error value * Error*. 

Range should be a reference that contains numbers. If range contains text or 
blank values, those values are ignored. 

Guess specifies the starting value of the iteration. If IRR does not converge, 
try different values for guess. Usually, a starting value between 0 and 1 will 
yield a meaningful result. 

Note The IRR function can be used only in the Spreadsheet. 

Example 
If you have an investment represented by the cash flows ($5000), $1000, 
$1500, $2000, ($3000), $2500, and $5000, which are entered in A1:A7, 
then: 

IRR(A1:A7,10%) equals 15.05% 
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lsBlank(values-1 ,values-2,...) IsBlank 

The IsBlank function can have any number of arguments. All arguments must 
be cell references. IsBlank gives the value 1 (TRUE) if all cell references in 
the list of arguments are blank or contain text. Otherwise, it gives the value 0 
(FALSE). 

IsError(vaiue) IsError 

The IsError function gives the value 1 (TRUE) if value is the error value 
* Error*. Otherwise, it gives the value 0 (FALSE). 

If you want to see if a range of cells contains any *Error* values, use the 
Sum function to sum the range. If any cells contain *Error*, the result of the 
Sum function will be * Error*. 

Example 

Given that A1 contains the formula =3/0: 

If(IsError(Al),0,l) equals 0 

IsNA(value) IsNA 

The IsNA function gives the value 1 (TRUE) if value is the error value N/A. 
Otherwise, it gives the value 0 (FALSE). 

Example 

Given that A1 contains the formula =NA(): 

If(IsNA(Al),0,l) equals 0 

Lfl(number) Ln 

The Ln function calculates the natural logarithm of number. Natural loga¬ 
rithms use the mathematical constant e, 2.7182818..., as a base. 

Number must be positive. 

Ln is the inverse of the Exp function, e raised to the power number. 

Examples 

Ln(2.7182818) equals 1 

Ln(Exp(3)) equals 3 

Ln(8)/Ln(2) equals 3 (the base 2 logarithm of 8) 
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LoglO 

Lookup 

LoglO(number) 

The LoglO function gives the base 10 logarithm of number. 

Number must be positive. 

LoglO is the inverse of base 10 exponentiation. 

Examples 

Log 10(10) equals 1 

Logl0(lE5) equals 5 

Logl0(10A5) equals 5 

Logl0(8)/Logl0(2) equals 3 (the base 2 logarithm of 8) 

Looklip(lookup-value, compare-range, result-range) 

The Lookup function searches compare-range for the largest value that is less 
than or equal to lookup-value. Lookup gives the corresponding value in 
result-range. 

The values in compare-range must be in ascending order. If lookup-value is 
smaller than the smallest value in compare-range, Lookup gives the error 
value * Error*. Compare-range and result-range should have the same 
length. Each of these range arguments must be one-dimensional, but they 
need not both be in the same direction. 

Note The Lookup function can be used only in the Spreadsheet. 

Examples 

If A1:E1 contains the comparison values 10000, 20000, 30000, 40000, and 
50000, and A4:E4 contains the values 10, 20, 30, 40, and 50, then: 

Lookup(35000,Al:El,A4:E4) equals 30 

Lookup(5000,Al:El,A4:E4) equals *Error* 

Lookup(35000,Al:El,Al:El) equals 30000 
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MatCh(lookup-value, compare-range, result-range) Match 

The Match function gives the number of the comparison value in compare- 
range that matches lookup-value. If lookup-value matches the first com¬ 
parison value, Match gives 1. If lookup-value matches the second comparison 
value, Match gives 2, and so on. If lookup-value does not match any of the 
comparison values, Match gives the error value * Error*. If compare-range 
contains multiple rows, Match searches from left to right, one row at a time; 
that is, it first searches the first row, then the second row, and so on. 

The rules for matching the values are determined by result-range. If result- 
range is 1, lookup-value matches the largest comparison value that is less 
than or equal to lookup-value. If lookup-value is less than the smallest com¬ 
parison value, then it does not match any of them. The comparison values 
should be in ascending order. 

If result-range is - 1, lookup-value matches the smallest comparison value 
that is greater than or equal to lookup-value. If lookup-value is greater than 
the largest comparison value, then it does not match any of them. The com¬ 
parison values should be in descending order. 

If result-range is 0, lookup-value matches the first comparison value that is 
equal to lookup-value. If lookup-value is not equal to any of the comparison 
values, then it does not match any of them. The comparison values can be in 
any order. 

Note The Match function can be used only in the Spreadsheet. 

Examples 

If A1:A5 contains the numbers 60, 70, 80, 90, and 100, then: 

Match(75,Al:A5,l) equals 2 

Match(55,Al:A5,l) equals * Error* 

If A1:A5 contains the numbers 100, 90, 80, 70, and 60, then: 

Match(75,Al:A5, — 1) equals 3 

Match(105,Al:A5, — 1) equals * Error* 

If A1:C3 contains the numbers: 
10 20 30 

40 50 60 
70 80 90 

then Match (40,A1:C3,0) equals 
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Max MaX(values-1 ,values-2,...) 

The Max function gives the largest number in the list of arguments. 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Max(Al:A5) equals 27 

Max(Al:A5,30) equals 30 

Min Mi ll(values-1, values-2,...) 

The Min function gives the smallest number in the list of arguments. 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Min(Al:A5) equals 2 

Min(Al:A5,0) equals 0 

Minute M i n U te(serial-number) 

The Minute function converts serial number to a minute as an integer in the 
range 0 to 59. For more information, see Hour. 

MIRR M1R R(range, safe, risk) 

The MIRR function gives the modified internal rate of return of a series of 
cash flows, represented by the numbers in range, given safe and risk. Safe is 
the rate returned by the investment that will finance the negative cash flows. 
Risk is the rate at which the positive cash flows can be reinvested. 

Range should be a reference that contains numbers. If range contains text or 
blank values, those values are ignored. 
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Where n is the number of cash flows in range, the formula used is: 

(—NPV(risk,values\positive\)*( \ + risk )n\ 7^7 

NPV(safe,values[negative])*( 1 +safe) ) 

Note The MIRR function can be used only in the Spreadsheet. 

Example 

If you have an investment represented by the cash flows ($5000), $1000, 
$1500, $2000, ($3000), $2500, and $5000, entered in A1:A7, and you hope 
to finance your negative cash flows with money borrowed at 12% and rein¬ 
vest your positive cash flows at 17%, then: 

MIRR(A1:A7,12%,17%) equals 15.19% 

Mod(number, divisor-number) 

The Mod function gives the remainder (modulus) after number is divided by 
divisor-number. The result has the same sign as divisor-number. 

If divisor-number is 0, Mod gives the error value *Error*. 

Examples 

Mod(3,2) equals Mod( —3,2) equals 1 

Mod(3, — 2) equals Mod( -3,-2) equals — 1 

Mod(7,4) equals 7 —Int(7/4)*4 equals 3 

Month(serial-number) 

The Month function converts serial number to a month of the year as an 
integer in the range 1 to 12. For more information, see Day. 

Mod 

Month 
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NA NA() 

The NA function gives the error value N/A. 

Example 

Given that A1 contains the formula =NA(): 

If(IsNA(Al),0,l) equals 0 

Not Not(number) 

The Not function gives the value 0 (FALSE) if number is non-zero (TRUE), 
and gives 1 (TRUE) if number is 0 (FALSE). 

Examples 

Not(l + 1=2) equals 0 

Not(l + 1 = 3) equals 1 

Now Nowo 

The Now function gives the serial number of the current date and time, 
updated at every recalculation. 

The integer part of the serial number is in the range 0 to 49710, representing 
dates from January 1, 1904, to February 6, 2040. The fractional part is in the 
range 0 to 0.999, representing times from 0:00:00 or 12:00:00 AM to 
23:59:59 or 11:59:59 PM. 

NPer NPer(rate,pmt,pv,fv,type) 

The NPer function gives the number of periods of an investment involving 
constant cash flows. 

If you omit either fv or type, it is assumed to be 0. 

For a complete description of the arguments in NPer, see PV. 
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NP V(rate,values-1 ,values-2,...) NPV 

The NPV function gives the net present value of a series of future cash 
flows, represented by the numbers in the list of values, discounted at a con¬ 
stant interest rate specified by rate. 

The cash flows are assumed to occur at equal time intervals, the first cash 
flow occurring at the end of the first period. 

The list of values can contain one or more arguments. The values arguments 
should be numbers, or references that contain numbers. If a reference argu¬ 
ment contains text or blank values, those values are ignored. 

Or(values-1 ,values-2,...) Or 

The Or function gives the value 1 (TRUE) if any of the values in the list of 
arguments is non-zero (TRUE). If all of the values are 0 (FALSE), Or gives 
the value 0 (FALSE). 

If a reference argument contains text or blank values, those values are 
ignored. 

Examples 

Or(l + 1=2,2 + 2 = 5) equals 1 

Or(l + 1= 3,2 + 2 = 5) equals 0 

Pl<) PI 

The Pi function takes no argument and gives the number 3.14159..., an 
approximation of the mathematical constant tt. 

Example 

ATan(l)* 180/Pi() equals 45 (degrees) 

PlT)t(rate,nper,pv,fv,type) Pmt 

The Pmt function gives the periodic payment of an investment involving con¬ 
stant cash flows. 

If you omit either fv or type, it is assumed to be 0. 

For a complete description of the arguments in Pmt, see PV. 
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PV 
FV 
NPer 
Pmt 
Rate 

PV(rate,nper,pmt,fv,type) 
FV(rate,nper,pmt,pv,type) 

N Pei*(rate, pmt, pv,fv, type) 
Pmt(rate,nper,pv,fv,type) 
Rate(nper, pmt, pv,fv, type, guess) 

Present value (pv), future value (fv), number of periods (nper), periodic pay¬ 
ment (pmt), and interest rate per period (rate) are the five standard parameters 
in cash flow problems involving constant payments. Each of the above func¬ 
tions gives the value of one of these financial arguments, given the values of 
the others. 

For the arguments pv, fv, and pmt, use the following cash flow convention: 
cash received is represented by a positive number; cash paid out is 
represented by a negative number. The examples below illustrate this 
convention. 

Rate and nper must refer to the same period. For example, if nper is the 
number of months, then rate must be the effective monthly interest rate. 

Type indicates whether payments occur at the beginning or the end of the 
periods. If type is 0, the first payment is assumed to occur at the end of the 
first period; if type is 1, the first payment occurs at the beginning. If you 
omit type, it is assumed to be 0. 

Works uses an iterative technique to compute Rate, which can have zero, 
one, or two solutions. If the successive results of Rate do not converge after 
20 iterations, Rate gives the error value * Error*. 

Guess specifies the starting value of the iteration. If you omit guess, it is 
assumed to be 0.1 or 10%. If Rate does not converge, try different values for 
guess. Usually, a starting value between 0 and 1 will yield a meaningful 
result. 

All of the arguments must be numbers. In PV, FV, NPer, and Pmt, you can 
omit the last two arguments; in Rate, you can omit the last three arguments. 
Any argument (except guess, as noted above) that is omitted is assumed 
to be 0. 

Works uses the following equations to solve for one financial argument in 
terms of the others: 

pv * (1+ rate }nper + pmt * (l + rate * type )* (1 + rate )nper ~ 1 

rate +fv= 0 

(/or rate <>0) 

pv + pmt * nper +fv = 0 

(/or rate =0) 
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Examples 

You have received a loan of $12,000 at an interest rate of 9% (monthly rate 
of 0.75%), and you must pay it off in 24 monthly payments made at the end 
of each month. Pv is 12000, rate is 0.75%, nper is 24, and fv and type are 0. 
The monthly payment is calculated by: 

Pmt(0.0075,24,12000) equals -548.22 

A limited partnership plans to buy an apartment building for $750,000 with 
the expectation of selling the building for $1,500,000 in 6 years. The rent 
from the apartments amounts to $100,000 annually. Pv is - 750000, fv is 
1500000, nper is 6, pmt is 100000, and type is 0. The numbers $100,000, 
$750,000, and $1,500,000 are entered in cells Al, B2, and C3. If your guess 
at the annual rate of return is 10%, the actual annual rate of return is calcu¬ 
lated by: 

Rate(6,Al,— B2,C3,0,0.1) equals 22.73% 

You now have $1,000 in your savings account earning 6% annual interest 
(0.5% monthly interest), and you plan to deposit $100 at the beginning of 
every month for the next 12 months. Pv is - 1000, rate is 0.5%, pmt is 
- 100, nper is 12, and type is 1, so the amount of money in your savings 
account at the end of 12 months is calculated by: 

FV(0.005,12,- 100,- 1000,1) equals 2301.40 

RadianS(number) 

The Radians function converts an angle in degrees to radians. 

Example 

Radians(180) equals 3.14159... (the value of tt) 

Rand() 

The Rand function gives a random number in the range 0 to 0.999_Rand 
generates a new random number every time the Spreadsheet or Database 
document is recalculated. 

Radians 

Rand 
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Rate Rate(nper,pmt,pv,fv, type, guess) 

The Rate function gives the interest rate per period of an investment involv¬ 
ing constant cash flows. 

If you omit jv or type, it is assumed to be 0. If you omit guess, it is assumed 
to be 0.1 or 10%. 

For a complete description of the arguments in Rate, see PV. 

Round ROlind(number,number-of-digits) 

The Round function gives number rounded to number-of-digits. If number - 

of-digits is positive, number is rounded to that many decimal places. If 
number-of-digits is 0, number is rounded to the nearest integer. If number- 
of-digits is negative, number is rounded to the left of the decimal point. 

Examples 

Round(2.15,l) equals 2.2 

Round(2.149,1) equals 2.1 

Round( — 1.475,2) equals —1.48 

Round(891, - 2) equals 900 

Second SGCOnd(serial-number) 

The Second function converts serial-number to a second as an integer in the 
range 0 to 59. For more information, see Hour. 

Sign Sign(number) 

The Sign function gives 1 if number is positive, 0 if number is 0, and — 1 if 
number is negative. 

Examples 

Sign(7 + 3) equals 1 

Sign(4 — 4) equals 0 

Sign(3 — 7) equals — 1 
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Sin(number) Sin 

The Sin function gives the sine of number, where number is an angle in 
radians. 

Examples 

Sin(0) equals 0 

Sin(Pi( )/2) equals 1 

Sin((3*Pi( ))/2) equals — 1 

Sqrt(number) Sqrt 

The Sqrt function gives the positive square root of number. 

Number must be greater than or equal to 0. If number is negative, Sqrt gives 
the error value * Error*. 

SSlim(values-1, values-2,...) SSum 

The SSum function gives the sum of the numbers in the list of arguments as 
they are displayed on the screen. If the cells appear in a range, arguments 
displayed in Fixed, Dollar, or Percent format are truncated to the value 
displayed on the screen. If the reference is to a single cell, the actual values 
are shown. 

If a reference argument contains text or blank values, those values are 
ignored. 

This function is intended to guarantee that the sum of values displayed 
matches the screen exactly. In other words, it is the result you get by using a 
calculator to add all the values in the argument list as they are displayed on 
the screen. 

Examples 

If A1:A5 contains the numbers 10.2, 7.12, 9.0, 27.031 (displayed with two 
digits after the decimal point), and 2, then: 

SSum(Al: A5) equals 55.35 

Notice that the same formula using the Sum function gives a different result: 

Sum(Al:A5) equals 55.351 
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StDev StDeV(values-1 ,values-2,...) 

The StDev function gives the sample standard deviation of the numbers in the 

list of arguments. 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

The formula used is: 

Sqrt(Var{values-l,values-2,...)) 

Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

StDev(Al:A5) equals 9.460 

StDev(Al:A5, Average(Al:A5)) equals 8.462 

Sum Sli m(values-1 ,values-2,...) 

The Sum function gives the sum of the numbers in the list of arguments. 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 

Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Sum(Al:A5) equals 55 

Sum(Al:A5,5) equals 60 

Tan Tan(number) 

The Tan function gives the tangent of number, where number is an angle in 
radians. 

Examples 

Tan(0.785) equals 0.999 

Tan(45*Pi( )/180) equals 1 

Time Time(hour, minute, second) 

The Time function gives the serial number of the time specified by hour, 
minute, and second. For an explanation of times and serial numbers, see 
“About Date and Time functions” in this chapter. 



Chapter 15 Spreadsheet and Database Functions 305 

The serial number is a decimal fraction in the range 0 to 1, not including 1 
representing times from 0:00:00 or 12:00:00 AM to 23:59:59 or 11:59:59 ’ 
PM. Hour, minute, and second should make up a valid time in this range. 

Works automatically converts a time constant to a serial number. For exam¬ 
ple, 16:48:00 and 4:48:00 PM both convert to the serial number 0.7004. 
However, within a formula, Works doesn’t convert text like “16:48:00” or 
“4:48:00 PM” to a serial number. If you want hour, minute, or second to be 
formulas, rather than constants, you must use the time function — for exam¬ 
ple, = Time (16,48,0). 

Examples 

Time(12,0,0) equals 0.5 

Time( 16,48,0) equals 0.2 

Trueo 

The True function takes no arguments and gives the value 1 (TRUE). 

Example 

Choose(2,False( ),True( ),True( ),False( ),True( )) equals 1 

True 

Type(value) Type 

The Type function gives the type of value. 

If value is a cell reference and the cell referenced is blank or contains text 
Type gives 2. 

Otherwise, Type gives 1 when value is a number, 8 when value is the error 
value N/A, and 16 when value is the error value * Error*. 

Examples 

If A1 contains the text “Smith”, then: 

Type(Al) equals 2 

Type(5) equals 1 

Type(l/0) equals 16 

Var(values-1 ,values-2,...) Var 

The Var function gives the sample variance of the numbers in the list of 
arguments. 

1 

The arguments should be numbers, or references that contain numbers. If a 
reference argument contains text or blank values, those values are ignored. 
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The formula Works uses to calculate variances is: 

n*(S(*2))-Q>)2 
n*(n — 1) 

The sample variance is the best estimate of the population variance based on 
a sample of the population. If your sample represents the entire population, 
you can compute the true population variance by including the average of the 
sample in the list of arguments to Var: 

Var(Population ,Average(Population)) 

Examples 

If A1:A5 contains the numbers 10, 7, 9, 27, and 2, then: 

Var(Al:A5) equals 89.5 

Var(Al:A5,Average(Al:A5)) equals 71.6 

VLookup VLOOkup(lookup-value,compare-range,index-number) 

The VLookup function searches the first column of compare-range for the 
largest value that is less than or equal to lookup-value. Having found that 
value in some cell in the column, VLookup moves left or right in that row by 
an amount specified by index-number and gives the value found there. For 
more information, see HLookup. 

Note The VLookup function can be used only in the Spreadsheet. 

Weekday Weekday(serial-number) 

The Weekday function converts serial-number to a day of the week as an 
integer in the range 1 to 7. For more information, see Day. 

Year Year(serial-number) 

The Year function converts serial-number to a year as an integer in the range 
1904 to 2040. For more information, see Day. 
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Reference 

The Apple, File, Window, and Macro menus are identical for all Microsoft 
Works tools. For information on these menus, see Chapter 2, “Common 
Tasks Command Reference.” 

This chapter discusses all the shaded commands shown below. 

Selec t Format 

Undo &Z 

Cut 
Copy sec 
Paste seu 
Clear 
Select All 
Paste with Options... 1 

Draw On agj 
Moue... 
Insert *i 
Paste Function... 
Absolute Cell Ref 
Fill Right 
Fill Down m 
Open Cell Note... 

Sort... 

All Cells 
Last Cell 

Find Cell... 
Go To Cell— &G 

Show Actiue Cell | 

Set Cell Attributes... 

Borders 

Font 
Size 
Color 

Column Width... 

Options 

✓Show Grid 
Show Notes Indicator 

Show Formulas 
✓Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Now 9§= 
Manual Calculation 

✓Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

C har t 

Draw Chart... 
New Series Chart... 
New Pie Chart- 
Select Chart Definition- 
Duplicate Chart... 
Erase Chart... 

Edit 

Undo 3§Z 

Cut §€H 
Copy 8§C 
Paste 
Clear 

Change Chart Name... 
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You can invoke some Works commands from the keyboard, as well as by 
using the mouse. The available Command-I-key combinations are shown on 
the menus and in Appendix D. 

An alphabetical list of commands appears in the index under “Command.” 

The Edit Menu 

Undo 3§Z 

Cut §€« 
Copy 8€C 
Paste 9€U 
Clear 
Select nil 
Paste with Options.. 

Draw On 
Moue... 
Insert :#:l 
Paste Function... 
Rbsolute Cell Ref &R 
Fill Right 8€R 
Fill Down MQ 

Open Cell Note... 

Sort... 

The first six commands on the Edit menu are common to all tools in Works. 
For information on these commands and the Draw On command, see “The 
Edit Menu” in Chapter 2. For specific information on using the Copy and 
Paste commands in the Spreadsheet, see “Copying Cells” in Chapter 12. 

This section explains the additional Edit menu commands available in the 
Works Spreadsheet. 

Paste with Options Paste with Options 

The Paste with Options command pastes a Spreadsheet selection from the 
Clipboard to the same or another Spreadsheet document. 

Paste with Options: 

(§) Ualues Only 

O Both Ualues and Formulas 

□ Transpose 

[ Cancel 

To Paste with Options, use the Cut or Copy command to put your selection 
on the Clipboard. Select a cell as the starting point of the paste and then 
choose Paste with Options. 

Values Only Click this option to paste only the formatted values in a 
selection. 

To copy a cell note using the Paste with Options command, make sure that 
the Values Only option is not chosen in the dialog box. 

Both Values and Formulas Click this option to paste both the formatted 
values and formulas in a selection. 

If you choose to paste both values and formulas, Works adjusts the relative 
cell references in the pasted cells according to their new locations. 

Transpose Click this option to paste rows into columns or columns into 
rows. The selection can contain multiple rows or columns. 
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Move Move 

The Move command moves a selected cell or range of cells from one location 
to another. 

Use Move to move information within a Spreadsheet document. When you 
use Move, the relative cell references point to the same cell value that they 
pointed to before the move. 

Note Use the Cut and Paste commands when you want to move informa¬ 
tion from one Spreadsheet document to another Spreadsheet document or to 
another type of document. 

Edit 

Undo §gz 

Cut 
Copy 8ec 
Paste 3gu 
Clear 
Select nil 
Paste with Options... 

Draw On 8§J 
Moue... 
Insert *1 
Paste Function... 
Absolute Cell Ref 3§R 
Fill Right §6R 
Fill Down *D 
Open Cell Note... 

Sort... 

To move information, choose Move from the Edit menu and type the destina¬ 
tion cell reference into the text box. 

Works moves the selection from its present location to its destination, begin¬ 
ning with the upper-left cell of the selection. 

If there is data in the destination cell, Works warns you that it will be 
replaced and asks if you want to continue the move. 

Hint You can also move the information from one cell to another by select¬ 
ing the cell you want to move the information from and pressing the 
Command + Option keys while clicking the cell you want to move the infor¬ 
mation to. 
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insert Insert 

Undo 38z 

Cut m 
Copy 38C 
Paste 38U 
Clear 
Select Rll 
Paste mith Options... 1 

Dram On 
Moue... 

38J 

Paste Function... 
Rbsolute Cell Ref 
Fill Right 
Fill Domn 
Open Cell Note... 

38R 
380 

Sort... 

The Insert command inserts a blank row or column into a Spreadsheet 

document. 

To insert a blank row or column, select a row or column and choose Insert 
Works inserts a blank row and moves the selected row below the inserted 
row. Works inserts a blank column and moves the selected column to the 
right of the inserted column. Works then increments by one all rows or 
columns after the inserted row or column, and adjusts all cell references 
according to the new row or column headings. 

Paste Function Paste Function 

Edit 

Undo 38Z 

Cut rm 

Copy 38C 
Paste 
Clear 
Select Rll 

| Paste mith Options... | 

Dram On 38J 
Moue... 
Insert 381 

1 Paste Function... 

Rbsolute Cell Ref 38R 
Fill Right 38R 
Fill Domn 38D 
Open Cell Note... 

Sort... 

The Paste Function command inserts a built-in function into a formula in the 

entry bar. 

Select the cell to contain the formula, and click in the entry bar where you 
want to insert the function. Then choose Paste Function. Works displays a 
list box, which contains a list of all available Works functions. 

Paste Function: 

RCosO TjT-T 
RndO 
RSinO 
RTanO 
RTan20 
RuerageO iii 

ChooseO <> 

[ Cancel ] 

To paste a function, select the function you want from the list, then click the 
OK button or press the Return key. 
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If the entry bar is inactive, Works activates it and pastes an equal sign (=) 
followed by the selected function. If the entry bar is active, Works pastes the 
function at the insertion point. 

If you don’t type an operator after the preceding operand, Works adds a plus 
sign ( + ) before the pasted function. Works also pastes the required 
parentheses, with the insertion point between them, so you can enter the 
function’s arguments. 

For information on specific functions, see Chapter 15, “Spreadsheet and 
Database Functions.” 

Absolute Cell Ref Absolute Cell Ref 

The Absolute Cell Ref command allows you to switch between a relative cell 
reference and an absolute cell reference. 

Absolute cell references are indicated by a dollar sign ($) preceding the refer¬ 
ence to the column, to the row, or to both, as in $B$4. 

To change a reference or range reference in the entry bar, position the inser¬ 
tion point to the immediate right of the reference or select it, then choose 
Absolute Cell Ref. If the reference is absolute, Works changes it to relative 
by deleting the dollar signs. If the reference is relative, Works changes it to 
absolute by inserting dollar signs. If the reference is mixed, Works reverses 
each part of the reference. 

Edit 

Undo 

Cut 
Copy &C 
Paste §gu 
Clear 
Select All 
Paste with Options... 

Draw On 3§J 
Moue... 
Insert m\ 

Paste Function... 
Rbsolute Cell Ref :£:fl 1 
Fill Right &R 
Fill Down 
Open Cell Note... 

Sort... 

Fill Right/Fill Down 

The Fill Right command copies the cells in the leftmost column of a selection 
into the remaining columns of the selection. The Fill Down command copies 
the cells in the top row of a selection into the remaining rows of the selec¬ 
tion. If the cells in the remaining columns and rows are not empty, Works 
replaces the existing data in those cells. 

When you choose Fill Right or Fill Down, Works adjusts relative cell refer¬ 
ences in formulas to reflect their new positions. 

Select only the range of cells you want to fill before choosing Fill Down. 
Selecting an entire column and filling all 16,382 cells takes a lot of memory 
and slows down your work. 

Fill Right 
Fill Down 

Edit 

Fill Down :#:D 
Open Cell Note... 
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Open Cell Note 

Edit —BMHHHI 

Undo §€Z 

Cut mu 
Copy 3€C 

Paste 3§U 
Clear 
Select Rll 

1 Paste with Options... | 

Draw On :#:J 
Moue... 
Insert *1 
Paste Function... 
Rbsolute Cell Ref m 
Fill Riyht 3§R 
Fill Down §§D 

| Open Cell Note... 

Sort- 

Sort 

Edit 

Undo 3§Z 

Cut 9€H 
Copy 3£C 
Paste 3§U 
Clear 
Select Rll 
Paste with Options... 

Draw On 3§J 
Moue... 
Insert m\ 
Paste Function... 
Rbsolute Cell Ref *:fl 
Fill Right §§R 
Fill Down mu 
Open Cell Note... 

Sort... 

Open Cell Note 

The Open Cell Note command opens a window in which you type notes asso¬ 
ciated with a selected cell. Use the basic Macintosh editing techniques to edit 
your note, if necessary. When you are finished typing, click the close box. 

!□* Budget (SS) Note R4 =01 

1 

a 
0 

If the Show Notes Indicator is checked in the Options menu, a marker in the 
upper-right comer of a cell indicates that it is annotated. 

To view new or existing cell notes, select the cell and choose the Open Cell 
Note command, or hold down the Command key while double-clicking the 
cell. To print cell notes with your document, choose the Print Cell Notes 
option in the File menu’s Page Setup dialog box. 

Sort 

The Sort command sorts the rows of a selection according to the contents of 
key columns within the selection. 

You tell Works which rows to sort by selecting them. Then you specify 
which columns are the key columns, and whether to sort in ascending or des¬ 
cending order. You can specify up to three key columns. 

Select Sort Keys: 

1st Key 
Column m <§) Ascending 

O Descending 

2nd Key 
Column □ 

<§) Ascending 

O Descending 

3rd Key 
Column □ 

(§) Ascending 

O Descending 

( Cancel i rs~i 



Chapter 16 Spreadsheet Command Reference 313 

Columns Specify a key column by typing the column heading (letter) of 
the column you want Works to sort. 

If there are duplicates in the key column, Works checks to see if you have 
defined more than one key column. Specify second and third key columns by 
typing the headings of the columns in order of importance, with the most 
important key column first. 

Next to each Key Column box, click Ascending or Descending to tell Works 
what order to sort in. In ascending order, Works sorts in this order: numbers, 
error values, text, blanks. In descending order, Works sorts in this order: 
error values, numbers, text, blanks. 

Numbers are sorted from the smallest negative value to the largest positive 
value. Text is sorted in the following order: 

space !" * $%&' ()*+,-. / 0 1 23456789:;< 

= >?@>ABCDEFGHIJKLMNQPQRSTUVWXYZ 

J1 71 j*2 Q c \ /f * A ... - - + 0 

The numbers in the text sorting order refer to numbers that are typed into a 
Spreadsheet document as text values. Numbers that appear in a Spreadsheet 
document as numeric values are sorted separately. 

Works ignores capitalization and accent marks when sorting text. 

You can sort on more than three key columns by doing two sorts. When you 
do sorts based on more than three key columns, keep in mind the following: 

■ The most recent sort takes precedence. 

■ Works retains the previous sort order in places where the current sort pro¬ 
duces equal items. 

If you want Works to take into account more than three key columns, sort the 
data three key columns at a time, starting with the least important group of 
columns and progressing to the most important group, but listing the most 
important column first within each group. 

For example, if you have five key columns you want to use to sort the rows 
of a selection, do one sort with the fourth and fifth most important columns 
selected as the first and second key columns. Then do a second sort with the 
three remaining columns, beginning with the most important column. 
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All Cells 

Find Cell... S€F 
Go To Cell... §§G 

Show flctiue Cell 

The Select Menu 

All Cells 

The All Cells command selects all the cells from A1 to the last cell. (The last 
cell is at the intersection of the last row and column that contain a value or 
formula.) 

Last Ceil Last Cell 
Select 

| All Cells 
Last Cell 

Find Cell... 3§F 
Go To Cell... 3§G 

Shorn flctiue Cell 

The Last Cell command selects the cell at the intersection of the last row and 
column that contains a value or formula. 

Find Cell Find Cell 
Select 

All Cells 
Last Cell 

Find Cell... #F 
Go To Cell... 38G 

Show Rctiue Cell 

The Find Cell command finds and selects either the specified cell or the cell 
containing the specified text. 

Enter Cell to Select or 
Tent to Find: - 

[ Cancel ] [[ Find Nentjj 

Works proposes the cell or the text you last specified. You can either accept 
the proposed response or type a new one. 

To find cells containing * Error* or N/A, type =Error() or =NA() in the 
text box. When you type a formula in the dialog box, Works calculates the 
formula, then looks for the cell containing the resulting value. 

Click the Find Next button to have Works begin the search. 



Chapter 16 Spreadsheet Command Reference 315 

Go To Cell 

The Go To Cell command finds a specified cell and displays it in the win¬ 
dow. It does not select the cell. 

Use Go To Cell when you are building a formula in the entry bar and want to 
see the contents of a particular cell. Because Works doesn’t select the cell, it 
will not appear as a reference in your formula. 

Go To Cell: l 

( Cancel J 1 0IC 1 

Go To Cell 

Select 

nil Cells 
Last Cell 

Find Cell... 8§F 
Go To Cell... #G | 

Shorn flctiue Cell 

Works proposes the cell you last specified. You can accept the proposed 
response or type a new one, using either a cell’s contents or a cell reference. 

Click the OK button to have Works begin the search. 

Show Active Cell 

The Show Active Cell command scrolls the Spreadsheet document so that the 
active cell is visible. Use this command when you scroll the document away 
from the active cell and want to return to it quickly. 

Show Active Cell 

Select 

Rll Cells 
Last Cell 

Find Cell.. 
Go To Cell. 

Show flctiue Cell 
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The Format Menu 

Set Cell Attributes 

Borders ► 

Font ► 
Size ► 
Color ► 

Column Width... 

Three commands in the Format menu — Font, Size, and Color—are common 
to all Works tools. For information on these commands, see “The Format 
Menu” in Chapter 2. 

Set Cell Attributes 

The Set Cell Attributes command specifies the way in which information in 
cells is displayed. 

When you create a new cell, numeric values are treated as normal text, 
right-aligned. Labels are treated as normal text, left-aligned. 

To specify cell attributes, select a cell or range of cells and choose Set Cell 
Attributes. Works then displays a dialog box. 

Set Cell Rttributes: 

Display: Rlign: Style: 

(§) General O Date Short O Left □ Bold 
O Fined O Date Medium O Center □ Underline 

O Dollar O Date Long O Right □ Commas 
O Percent 
O Scientific 

OTime 
□ Shorn Day 

|^^|Decimal Places 

f Cancel ] ft OK )| 

Display Options 

General Values are displayed as precisely as possible, given the width of 
the cell. Leading zeros are not displayed. 

Fixed Values are displayed with a fixed number of places to the right of 
the decimal point. 

The fixed number of decimal places is two, unless you change it using the 
Decimal Places option. 
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Dollar Values are displayed in dollars and cents format. A dollar sign ($) 
appears to the immediate left of the most significant digit. Dollars are 
displayed to the left of the decimal point. Cents are displayed to the right of 
the decimal point with two digits, unless you change the number of digits 
using the Decimal Places option. 

Negative numbers are enclosed in parentheses. 

Type 0 in the Decimal Places box to display whole dollars with no decimal 
point. Type 2 to display dollars and cents. The value is adjusted to the 
nearest whole dollar or whole cent depending upon your choice of 0 or 2 
decimals. For example, the value 9.505 is displayed as $10 if you specify 0 
decimal places; it is displayed as $9.51 if you specify 2 decimal places. 

Percent The numeric value of an entry is multiplied by 100 and displayed 
with a percent sign (%) to its immediate right. 

You can also specify the number of decimal places to be displayed in the per¬ 
centage. The value .156, for example, is displayed as 15.6% if you type 1 in 
the Decimal Places box, and 16% if you type 0. 

Scientific Scientific notation allows you to express very large or very 
small numbers. 

Scientific notation consists of three parts: a decimal number in the form n.nn, 
the exponentiation symbol E or e, and an integer in the form ±ii for the 
exponent. 

For example, the value 1,210 is displayed as 1.21E + 03, where 1.21 is the 
decimal number, E is the exponentiation symbol, and +03 is the exponent. 
The value .00121 is displayed as 1.2IE —03. 

With the Decimal Places box, you can specify the number of decimal places 
to be displayed in the decimal number. 

Date and Time Options 

You can type the date in any of the following formats, and the Spreadsheet 
will display it in the form you choose in the Set Cell Attributes dialog box: 

■ 08/10/88 

■ 8-10-88 

■ 8.10.88 

■ 08/10/1988 

■ Wed, Aug 10, 1988 

■ Aug 10, 1988 

■ August 10, 1988 

■ Wednesday, August 10, 1988 
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Display Show Day Unchecked_Show Day Checked 

Short 8/10/88 8/10/88 

Medium Aug 10, 1988 Wed, Aug 10, 1988 

Long August 10, 1988 Wednesday, August 10, 1988 

Time Works displays time using a 12-hour clock, even if you enter a time 
in 24-hour format. 

If you type Works displays 

8:04 8:04 AM 

20:04 8:04 PM 

8:4 pm 8:04 PM 

20:4 8:04 PM 

If you don’t use 24-hour time, remember to include the “am” or “pm”. If you 
don’t specify this, Works displays AM. 

Show Day If you choose Date Medium or Date Long and click the Show 
Day option, the day of the week is also displayed. 

Align Options 

These options allow you to align the contents of selected cells. 

Left Aligns the cell content to the leftmost position. 

Center Centers the cell content. 

Right Aligns the cell content to the rightmost position. 

Decimal Places 

The number of decimal places tells Works how many digits to display to the 
right of the decimal point when you specify Fixed, Dollar, Percent, or Scien¬ 
tific format. 

In the text box, type the number of decimals, from 0 to 15, that you want 
displayed. For more information, see “Fixed,” “Dollar,” “Percent,” and 
“Scientific,” above. 
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Style Options 

The Style options change the type style of information in selected cells. 

Bold Emphasizes text, and can be used in combination with Underline. 

Underline Underlines the cell’s content, and can be used in combination 
with Bold. 

Commas When you select a cell or a range of cells and choose Commas, 
Works displays a comma between each group of three digits to the left of the 
decimal point in the selected cell or range of cells. 

If the Commas option is not checked, commas are not displayed. 

Hint You can also open the Set Cell Attributes dialog box by double¬ 
clicking a cell. 

Borders SS35J 

The Borders command leads to another menu which lists border commands 
for selected cells. Borders add emphasis to a single cell or to a range of cells. 

Borders are displayed on the screen and print with the Spreadsheet. You can 
see the borders better if you remove the checkmark from the Show Grid com¬ 
mand in the Options menu. 

You can choose any combination of borders. 

This command Creates this border 

Around the outermost edges of the 
selection 

On the left edge of every cell in the 
range 

On the right edge of every cell in the 
range 

On the top edge of every cell in the 
range 

On the bottom edge of every cell in the 
range 

No border — removes borders from 
every cell in the range 

Outline 

Left 

Right 

Top 

Bottom 

None 
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Column width Column Width 

Format 

Set Cell Attributes... 

Borders ► 

Font ► 
Size ► 
Color ► 

Column liiidth... 

The Column Width command sets the width of selected columns. 

You don’t have to select an entire column. If you select any cell in a column, 
the new column width applies to all cells in that column. To adjust all the 
columns in a Spreadsheet document, select an entire row by clicking a row 

heading. 

In the text box, you can either accept the proposed response or type a new 
number. The standard column width is 12 spaces, and the maximum column 
width is 40 spaces. 

To change column width with the mouse, point to one of the lines that divide 
the column headings. When the pointer becomes a two-way arrow, drag to 
the left or right. 

The Options Menu 

Show Grid Show Grid 

Show Notes Indicator 

Show Formulas 
</Show Ualues 

Protected 

Set Page Break 
Bemoue Page Break 

Calculate Now 9€= 
Manual Calculation 

^Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

When checked, the Show Grid command tells Works to display and print grid 
lines on your Spreadsheet document. 

Grid lines are not displayed or printed if the Show Grid command is not 
checked. 
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Show Notes Indicator Show Notes Indicator 

When checked, the Show Notes Indicator command displays and prints a 
marker in the upper-right comer of any cell that has a cell note. 

Markers are not displayed or printed if the Show Notes Indicator command is 
not checked. 

Options 

|s/ShoLii Grid 
Show Notes Indicator 

Show Formulas 
✓Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Now d%= 

Manual Calculation 
✓Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

Show Formulas/Show Values 

These commands tell Works to display and print either the formatted value or 
the unformatted content of cells. 

These commands affect all cells in a Spreadsheet document. 

If you choose Show Formulas, Works places the formulas on the Clipboard 
when you cut or copy cells, or prints the formulas when you print a range of 
cells. 

If you choose Show Values, Works places the formatted values on the Clip¬ 
board when you cut or copy cells, or prints the formatted values when you 
print a range of cells. 

Show Formulas 
Show Values 

Options 

✓Show Grid 
Shoui Notes Indicator 

Show Formulas 

✓Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Nom §6= 
Manual Calculation 

✓Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 
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Protected Protected 

Options 

v'Show Grid 
Show Notes Indicator 

Show Formulas 
v/Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Now 36= 
Manual Calculation 

'✓Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

When checked, the Protected command tells Works to protect selected cells 
from accidental loss or change. 

The cells are not protected if the Protected command is not checked. 

When you choose Protected, Works won’t allow you to enter numbers, for¬ 
mulas, or labels. If you try, Works displays an alert box telling you to 
remove cell protection before entering data. 

Set Page Break 
Remove Page Break 

Options 

^Show Grid 
Show Notes Indicator 

Show Formulas 
v'Show Ualues 

Protected 

Set Page Break 

Remoue Page Break 

Calculate Now 36= 
Manual Calculation 

^Automatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

Set Page Break/Remove Page Break 

These commands set and remove manual page breaks in a Spreadsheet 
document. 

Works automatically determines where pages break, based on column widths 
and on the margin settings you enter using the File menu’s Page Setup com¬ 
mand. Page breaks can also be manually inserted. 

To set a manual page break, select the cell you want to be in the upper-left 
comer of the page, then choose Set Page Break. Works inserts vertical and 
horizontal dashed lines (page break indicators) to mark the manual page 
break, then repaginates the rest of the document. 

To remove a manual page break, select a cell immediately to the right of a 
vertical break or below a horizontal break, then choose Remove Page Break. 
Works removes the page break indicator and automatically repaginates the 
rest of the document. To remove both a vertical and a horizontal page break 
indicator at once, select the cell in the upper-left comer of the page before 
choosing Remove Page Break. 



Chapter 16 Spreadsheet Command Reference 323 

Calculate Now/Manual Calculation 

m^ntCTKUl^e No* “““““I “Hows you to recalculate a Spreadsheet docu¬ 
ment. The Manual Calculation command tells Works to recalculate a 
Spreadsheet document only when you choose Calculate Now. 

You don t need to choose Calculate Now when calculation is automatic- in 
that case whenever you make a change, Works automatically recalculates 
dependent formulas in all open Spreadsheet documents and charts. 

Calculate Now 
Manual Calculation 

'✓Show Grid 
Show Notes Indicator 

Show Formulas 
✓Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Manual Calculation 
✓Rutomatic Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 

Automatic Calculation 

When you create a new Spreadsheet document, Automatic Calculation is 
checked. This command tells Works to recalculate the Spreadsheet document 
whenever you change the content of a cell, or whenever you open an existing 
Spreadsheet file. Since calculation is done in the background, and doesn’t § 
interfere with your work, you’ll probably want to have this command in 
effect most of the time. 

Automatic Calculation 

Options 

✓Show Grid 
Show Notes Indicator 

Show Formulas 
✓Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Now §§= 
Manual Calculation 

Freeze Titles Horizontal 
Freeze Titles Uertical 
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Freeze Titles 
Horizontal 
Freeze Titles Vertical 

Options 

yShow Grid 
Show Notes Indicator 

Show Formulas 
v^Show Ualues 

Protected 

Set Page Break 
Remoue Page Break 

Calculate Now 33 
Manual Calculation 

v-'Rutomatic Calculation 

Niijjj--iaiijjii.iju.uni 
Freeze Titles Uertical H 

Freeze Titles Horizontal/Freeze Titles Vertical 

These commands freeze rows or columns so that they won’t scroll. This is 
most useful for keeping row or column headings on the screen as you scro 
through a large Spreadsheet document. 

The Freeze Titles Vertical command freezes the rows above the split bar. 
First you make a horizontal split using the split bar, then choose Freeze 
Title’s Vertical. When you scroll vertically, the area above the split bar 

doesn’t scroll. 
The Freeze Titles Horizontal command freezes the columns to the left of the 
split bar. First, you make a vertical split using the split bar, then choose 
Freeze Titles Horizontal. When you scroll horizontally, the area to the left of 

the split bar doesn’t scroll. 
For more information on using split bars, see Dividing the Spreadsheet Win 

dow into Panes” in Chapter 12. 

The Chart Menu 

Draw Chart 

New Series Chart... 
New Pie Chart- 
Select Chart Definition- 
Duplicate Chart- 
Erase Chart... 

Draw Chart 

The Draw Chart command draws a chart that you have already defined with 
either the New Series Chart command or the New Pie Chart command. 

To draw a chart, select the chart you want, then click the OK button. Works 
draws the chart and makes the chart window active. 
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New Series Chart New Series Chart 

The New Series Chart command defines a new series chart. Use a series chart 
when you want to compare different sets of data. You can plot up to four 
rows at once. Up to eight chart definitions can be defined for each 
Spreadsheet document. If New Series Chart is dimmed on the menu, you 
need to remove a chart definition with the Brase Chart command before you 
can create a new one. 

Chart 

6 File Edit Window Macro 

The title bar displays the name of the chart definition (not the chart title). 
You can leave the name as is or rename the definition to something more 
meaningful to you. To change the name, use the Change Chart Name com¬ 
mand from the Edit menu. For more information, see “Change Chart Name” 
at the end of this chapter. 

Since you may need to refer to the Spreadsheet document to set the chart 
parameters, you can move this dialog box just like a regular window. Drag 
the title bar to move the box and see the information you need. 

After you set up the chart definition, you have three choices: 

■ Click the Plot It! button to plot the chart and to store the definition with 
your Spreadsheet document. 

■ Click the close box to store the definition with your Spreadsheet docu¬ 
ment and to make the Spreadsheet document active. 

■ Click the Cancel button to return to the Spreadsheet document and discard 
the definition. 



When you save your Spreadsheet document, chart definitions are also saved 
and are available when you later open the Spreadsheet document. 

Type of Chart Click the type you want. 

For analyzing trends. 

For making comparisons. 

For analyzing cumulative effects. 

For seeing both trends and comparisons. 

Line 

Bar 

Stack 

Combo 

Values to be Plotted 

1st Row Type the row heading (a number) of the first of the four rows of 
values you want to plot. Works proposes row 3, assuming row 1 contains a 
title for your Spreadsheet document and row 2 contains column labels. 

2nd Row Type the row heading of the second row of values you want to 
plot. Works proposes row 4. If you want to plot only one row of values, 
press the Delete key to erase the 4 and leave the box blank. 

3rd Row Type the row heading of the third row of values you want to 

plot. 

4th Row Type the row heading of the fourth row of values you want to 

plot. 

From Column Type the column heading (a letter) of the first column of 
values you want to plot. Works proposes column B. 

To Column Type the column heading of the last column of values you 
want to plot. Works proposes column M. 

Data Legends in Column Type the heading of the column containing the 
data legends (the labels that describe the rows you are plotting). Works pro¬ 
poses column A. 

Horizontal Titles in Row Type the heading of the row containing the 
horizontal titles (the labels that describe the columns you are plotting). Works 
proposes row 1. 

Chart Title Type a chart title. If you type nothing here, Works will not put 
a title on the chart. 

Vertical Scale Title Type a label for the vertical scale, such as Units, 
Dollars, or Millions of Dollars. If you type nothing here, Works will not put 
a vertical scale title on the chart. 

Horizontal Scale Title Type a label for the horizontal scale. If you type 
nothing here, Works will not put a horizontal scale title on the chart. 
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Vertical Scale 

Numeric Click this option to scale the data numerically. This box is 
initially checked. 

Semi-Logarithmic Click this option to scale the data logarithmically. The 
vertical scale on the chart is logarithmic. Works automatically computes the 
number of cycles based on the range of values in the rows you are plotting. 

Maximum Type the maximum value you want to plot. If you leave this 
box blank, Works plots all values in the specified rows, and divides the verti¬ 
cal scale based on the largest plotted value. 

Minimum Type the minimum value you want to plot. Works proposes 0. If 
you leave this unchanged, Works plots all values in the specified rows and 
begins the vertical scale with 0. 

New Pie Chart New Pie Chart 

The New Pie Chart command defines a new pie chart. Use a pie chart when 
you want to compare individual parts of a whole. If New Pie Chart is 
dimmed on the menu, you need to remove a chart definition with the Erase 
Chart command before you can create a new one. 

Chart 

Dram Chart... 
Nem Series Chart... 
Nem Pie Chart... 

Select Chart Definition... 
Duplicate Chart... 
Erase Chart... 

The title bar displays the name of the chart definition (not the chart title). 
You can leave the name as is or rename the definition to something more 
meaningful to you. To change the name, use the Change Chart Name com¬ 
mand from the Edit menu. For more information, see “Change Chart Name” 
at the end of this chapter. 

Since you may need to refer to the Spreadsheet document to set the chart 
parameters, you can move this dialog box just like a regular window. Drag 
the title bar to see the information you need. 
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After you set up the chart definition, you have three choices: 

■ Click the Plot It! button to plot the chart and to store the definition with 
your Spreadsheet document. 

■ Click the close box to store the definition with your Spreadsheet docu¬ 
ment and to make the Spreadsheet document active. 

■ Click the Cancel button to return to the Spreadsheet document and discard 
the definition. 

When you save your Spreadsheet document, chart definitions are also saved 
and are available when you later open the Spreadsheet document. 

Chart Title Type a chart title. If you type nothing here. Works will not put 
a title on the chart. 

Plot Values in Column Type the heading (a letter) of the column of 
values you want to plot. Works proposes column B. 

From Row Type the heading (a number) of the first row containing values 
you want to plot. Works proposes row 3. 

Through Row Type the heading of the last row containing values you 
want to plot. Works proposes row 7. 

Column Of Value Titles Type the column heading containing the titles of 
the values you want to plot. Works proposes column A. 

Select Chart 
Definition 

Char t 

Draui Chart... 
Neui Series Chart... 
New Pie Chart... 
Select Chart Definition... 

Duplicate Chart... 
I Erase Chart... 

Select Chart Definition 

The Select Chart Definition command allows you to change or verify 
an existing chart definition before plotting the chart. 

Select Chart Definition: 
Budget Chart I 

Budget Chart 2 

[ Cancel ] 

Select the chart definition you want to change or verify, then click the OK 
button. Works displays the definition in the appropriate definition dialog box. 
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After you change whatever specifications need to be changed, you have three 
choices: 

■ Click the Plot It! button to plot the new chart. This button also replaces 
the original chart definition with the modified one and stores it with the 
Spreadsheet document. 

■ Click the close box to store the modified definition with your Spreadsheet 
document without plotting the chart and to make the Spreadsheet docu¬ 
ment active. 

■ Click the Cancel button to return to the Spreadsheet document and discard 
any changes you made to the definition. 

When you save your Spreadsheet document, the modified chart definition is 
saved and will be available when you later open the Spreadsheet document. 

Duplicate Chart Duplicate Chart 

The Duplicate Chart command duplicates an existing chart definition. If eight 
charts are defined, Duplicate Chart is dimmed on the menu, and you’ll need 
to remove a chart definition with the Erase Chart command before you can 
duplicate another one. 

Duplicate Chart; 
Budget Chart 1 

Budget Chart 2 

( Cancel ] J__OK_JJ 

Chart 

Draw Chart... 
Neui Series Chart... 
New Pie Chart... 
Select Chart Definition... 
Duplicate Chart... 

[ Erase Chart... 

Select the chart definition you want to duplicate, then click the OK button. 
Works displays the definition and proposes a new name in the chart definition 
dialog box. 
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Erase Chart 

Chart 

Draw Chart... 
New Series Chart... 
New Pie Chart- 
Select Chart Definition... 
Duplicate Chart..._ 
Erase Chart... 

After you change whatever specifications need to be changed, you have three 

choices: 

■ Click the Plot It! button to plot the chart and store the new definition with 

your Spreadsheet document. 

■ Click the close box to store the new definition with your Spreadsheet 

document and to make the Spreadsheet document active. 

■ Click the Cancel button to return to the Spreadsheet document and discard 

the new definition. 

When you save your Spreadsheet document, the new definition is saved with 
it and will be available when you later open the Spreadsheet document. 

Erase Chart 

The Erase Chart command erases a chart definition stored with a Spreadsheet 

document. 

Erase Chart: 

[ Cancel ] [[ OK j| 

Choose the chart definition you want to erase, then click the OK button. 
Works removes the chart definition from the list of definitions stored with the 

Spreadsheet document. 
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1 he bdit Menu - 

Change Chart Name —-  
Change Chart Name 

The Change Chart Name command changes the name of a chart definition. - 

Change Chart Name... 

Edit 

Undo a§z 

Cut MX 

Copy 3§C 
Paste m 

Clear 

Type the new name and click the OK button. 

The new name appears in the chart window’s title bar and in the dialog boxes 
that contain a list of chart names. 

This command is available only when a chart definition dialog box is active. 





Communications 

Works Communications opens up a world of opportunities for you. Using 
Communications, you can talk with computers just about everywhere You 
can browse through files in computer libraries, send and receive information 
or make financial transactions. 
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The chapters in this part of the manual explain how to use Works 

Communications. 

■ Chapter 17, “Specifying Settings and Calling a Computer,” shows how 
data communications works, how to match the way your computer com¬ 
municates with the way other computers communicate, and how to store 
telephone numbers and have Works dial them automatically. 

■ Chapter 18, “Sending and Receiving Information,” explains how you can 
send and receive messages and information, such as a Spreadsheet docu¬ 
ment that a spreadsheet program on another computer can use. 

■ Chapter 19, “Communications Command Reference,” describes the Com¬ 

munications commands. 



17 Specifying Settings 
and Calling a Computer 

To use Works Communications, you need to make sure that the Works set¬ 
tings match those of the computer you’re calling. Information services like 
Dow Jones or CompuServe and other accessible computers will provide you 
with the necessary information. Then, you need to put the service’s phone 
numbers into your Works phone book so you can get in touch with them. 

In this chapter, you’ll learn how to: 

■ Understand how data communications works. 

■ Specify settings. 

■ Use the Works phone book. 

■ Dial another computer and respond when the connection is made. 
■ Adjust the echo. 

■ Hang up the phone. 

■ Prepare to answer calls. 

■ Call an information service or personal computer. 

An Overview 

This section gives an overview of how data communications works, and 
explains the terms you’ll use in Works Communications. 

Connecting Computers 

You can send and receive information between your computer and 
another computer over telephone lines or through cables. This is called data 
communication. 

You’ll usually send messages over the telephone. To do that, you need a 
modem—a device that converts the computer’s digital signals into voice- 
frequency signals that can travel over the telephone. A modem (modulator- 
demodulator) translates (modulates) electrical impulses into telephone signals 
when you send messages. 

The modem 
connection 
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The cable connection 

Baud rate 

Character settings 

When you receive messages, it translates (demodulates) the telephone signals 
back into electrical signals your computer can understand. 

An acoustic coupler is a type of modem that receives sound signals through 
a standard telephone receiver, rather than electrical signals over cables. An 
acoustic coupler is more vulnerable to noise and static than other modems, 
and more suitable for low-speed transmissions. 

You can also send information directly from computer to computer using a 
cable Your computer dealer can show you how. When two computers are 
directly connected, you’ll be able to send information faster than you usually 
can over the telephone line, but only over short distances (among offices in 

the same building, for example). 

Speed of Transmission 

Your Macintosh sends information to a modem in tones that represent zeros 
and ones. These zeros and ones are binary digits, or bits. Each bit is only a 
fraction of a single letter, and hundreds of them go out every second. The 
rate of speed at which the bits are sent is the baud rate. You set the baud rate 
to tell Works how fast to send out information. Because of static and other 
random noises in the telephone lines, messages you send over the telephone 
travel at relatively slow speeds—but still much faster than you can type. II 
you lease direct lines or use a satellite, you can send messages at very high 

rates of speed. 

How Information Travels 

To make sure that your message gets through accurately, communications 
programs at both ends must send and receive information in the same way. 
When you subscribe to a computer service or plan to connect with another 
computer, somebody at the other end tells you in advance what settings to 

choose. 
In addition to setting the speed of transmission, you specify three characteris¬ 
tics about the characters that make up your message. When you send a mes¬ 
sage, it goes out in pulses of sound or electricity. The data size tells the 
receiving computer how many pulses make up one character. Stop bits tell 
when one character ends and another begins. Parity is a method the computer 
uses to check for errors in the data transmission. 

Unless both computers send and receive information using the same settings, 
they won’t understand each other —like two people talking to each other in 

different languages. 
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Greetings 

Just as diplomats follow a specified ritual when they greet each other, so do 
computers. The handshake setting tells one computer how the other computer 
will send and receive information. K 

The handshake is a form of protocol—computer diplomacy. Not all comput¬ 
ers use the same protocol, but most information services and personal com¬ 
puter communications programs use the protocols that Works provides. 

Creating a New 
Communications Document 

For each computer that you intend to call, you can create a new document to 
contain the appropriate settings. Each computer you call may use different 
settings. 

To create a new Communications document: 

0 In the Open dialog box, click the Communications icon. 

0 Click the New button. 

Works displays the Settings dialog box. Whenever you create a new Com¬ 
munications document, the Settings dialog box is automatically displayed. 

You can have only one Communications document open at a time. 

Communications Settings: 

Type: 

Baud Rate: 

® TTV o UT-100 O UT-52 □ «u to-wrap □ Newline 

O 300 0 2400 O 9600 Delete Key Means: 
® 1200 0 4800 0 19200 _ . . 

® Delete 
Data Size: ® 8 Bits O? Bits O Backspace 

Stop Bits: ® 1 Bit 0 2 Bits Number of screens: 

Parity: <§) None O Odd O Euen 

Handshake: ONone <5) Hon/Hoff O Hardware O Both 

Phone Type: <§) Touch-Tone® O Rotary Dial 

Line Delay: [[U| Character Delay: |o | 

El Capture Tent When Document Opens 

Connect To: ® 
[ Cancel ] [[ OK 

Handshake setting 

To create a new 
Communications 
document 
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To specify settings 

To change settings 

To add a number to 
the phone book 

Specifying Settings 

When you create a new Communications document, the preset options are 
those normally used by information services. 

To specify settings: 

0 Click the appropriate settings. 
[H Type the number of screens you want to review during a session, if 

different from 4. 

0 Type the line or character delay, if any. 

0 Click the OK button or press the Return key. 

Works stores the settings with the Communications document, and saves 
them when you save the document. 

For a complete description of the Settings options, see Settings in 

Chapter 19. 

Note Because Capture Text When Document Opens is checked in the Set¬ 
tings dialog box, Works asks you to name the file you will save text to after 
you click the OK button. Once you type a filename in the Save Captured 
Text As dialog box and click the Capture button, Works will save the text 
you type and receive during your session. The text is saved in a Word Pro¬ 
cessor file with the name you’ve typed. See “Receiving Information in 
Chapter 18 for more information on capturing and saving text. 

To change the settings at any time: 

g Choose the Settings command from the Communications menu, and 
repeat the procedure for specifying settings. 

Adding or Changing Numbers 
in the Phone Book 

Each Communications document has its own phone book stored with it, 
which contains up to eight phone numbers. The phone book also stores a 
name for each number, so that you’ll know which computer you’re dialing. 
The phone book is empty until you put numbers into it. 

To add a number to the phone book: 

□ Choose Dial from the Communications menu. 
The phone book appears, with the insertion point in the first blank 

name box. 



Chapter 17 Specifying Settings and Calling a Computer 339 

Type the 
name here. 

Type the number here. 

\ 
Name: \ Phone Number: 

[Omfl r~ 
(HD 

HmD 

HM) 
mr\ 

foliil 

dM) 
folafl 

( Cancel 11[ OK 1 

[I] Type a name. 

0 Press the Tab key to move the insertion point into the number box, and 
type a phone number. 

A number can be up to 50 digits long. Be sure to include all the digits 
you’d normally dial if you were making the call yourself—any long dis¬ 
tance access codes or internal accounting codes, for example. 

If you have a Hayes or Hayes-compatible modem, you can insert commas 
for pauses and hyphens for easier reading. If, for example, you must dial 
9 for an outside line, you can type 9, 111-0000 so Works will pause after 
it dials 9. 

If you have a different kind of modem, see your modem documentation 
for information on commas and hyphens. 

0 Click the OK button or press the Return key. 

Works stores the new name and number with the Communications document. 

To change or remove a name or number: 

0 Choose Dial from the Communications menu. 

0 Select the name or number by dragging across it. 

0 Press the Delete key to remove the selected name or number, or type the 
correction to change or replace the selected name or number. 

0 Click the OK button or press the Return key. 

Works stores the change with the Communications document. 

To change or remove 
a name or number 
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To dial a number with 
a Hayes-compatible 
modem 

To dial a number with 
a different modem 

To respond when a 
connection is made 

To adjust the echo 

Dialing a Phone Number 

Before dialing, make sure your modem is connected to the Macintosh and to 

a telephone wall outlet. 

If you have a Hayes or Hayes-compatible modem, you can use the Dial com¬ 
mand to send the appropriate command to the modem to tell it to dial the 
number. For other modems, you must send the dialing command as well as 

the phone number. 

To dial a phone number (Hayes or compatible modem): 

m Choose Dial from the Communications menu. 

[H Click the Dial button next to the number you want. 

Works dials the number for you and displays the message “Dialing...” to tell 
you that the modem is dialing. When you are connected, Works displays the 
message “CONNECT”. 

To dial a phone number (non-Hayes-compatible): 

[I] Type the dialing command for your modem in the Communications docu¬ 

ment window. 
Refer to your modem documentation for information on dialing 
commands. 

or 
[■} If you have an acoustic coupler modem, dial the number, then place the 

telephone receiver in the headset. 

Once you’re connected, respond to the prompts of the service you ve dialed, 
or if you’re calling another personal computer, type something like “Hello” to 
let the other person know you’re connected. 

Getting an Echo 

Some computers send back each character they receive, so that you see two 
of each character on your screen. This is called an echo. If you re seeing two 
of each character when you connect with another computer, turn the echo off. 
If you’re not seeing any characters as you type, turn the echo on. 

To adjust the echo: 

@ Choose Echo On or Echo Off from the Communications menu. 

The command in effect has a checkmark on the menu. 

Echo On is often called “full duplex” and Echo Off “half duplex.” 
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Hanging Up 

nhnni»n^A fiP W‘th ,W°!-ks Communications is just as easy as hanging up a tele- 
p ne. After you ve finished your session with an information service or 
another computer operator, you’re ready to hang up. Remember that hanging 
up does not necessarily log you off from the system you were connected § 
with, so ,t is a good practice to log off before you hang up. 
To hang up: 

® Choose Hang Up from the Communications menu. 

Works displays the messages “Hanging up...”, “ + + + » and “AtH”. 

P® tWO messafs indicate that the connection has been broken. You can 
then close or save the document. 

i^L ii transmits y°“r message over the phone lines. Periodically some- 
mg will go wrong with a transmission. If you are disconnected in the mid¬ 

dle of a session, Works displays the message, “NO CARRIER...” The mes¬ 
sage means that you’ve been disconnected. You can quit or try again 

Preparing to Answer a Call 

When you’re expecting a call from another user, you need to get ready. 

H Stionsfde^ C°mmunications document, or open an existing Communi- 

[U Confirm that the settings in the Settings dialog box are correct. 

Then, to set your Hayes-compatible modem to auto-answer: 

® Ch°0se the Answer Phone command from the Communications menu. 

This tells your modem to answer the telephone when it rings. When the 
Answer Phone command is in effect, it is checked on the menu. 

P-y0U f'nish your Communications session and break the connection with 
the other user, you may want to change the setting on your modem. 

To set the modem so that it won’t answer the telephone: 

® Choose the checked Answer Phone command. 

Works removes the checkmark from the menu. 

frTtvL7hdem iS 1,01 Hayes"comPatible, consult your modem documentation 
and type the appropriate command in the Communications document window. 

To hang up 

To answer a call 
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To call an information 
service 

Completing a Connection 

Once vou’re connected to another computer, what do you do? It depends on 
fe W of computer you’re calling. This section briefly explains about rnfor- 

mation services and other personal computers. 

Calling an Information Service 

Information services like Dow Jones or CompuServe, have more information 
than many reference’libraries. Although they all work differently, this section 
shows you some of their similarities, so you’ll know what to expect when 

you call one. 

To call an information service: 

ID Dial the service. 
When you connect, the service will probably ask for an ldentlfica“°" 
code and a password. (Your service provides this information when you 

subscribe.) 
0 Type your identification code and password. 

Now you’re logged on to the service. The time from when you log on to 
when you log off is your session. The service should guide you with 
prompts through the session. By answering questions and choosing from 
menus, you should be able to find what you’re looking for. 
Some information services have a system operator whom you can ask for 

help if you have difficulties. 
Because many information services charge you for the tune you ^con¬ 
nected, Works Communications provides some commands that let you 
save time when you send and receive information. For more information, 
see Chapter 18, “Sending and Receiving Information.” 

0 When you’re finished, log off and hang up. 

Note Commercial information services, such as CompuServe, The Source, 
and Delphi may require that you transmit control characters to utilize some 
functions of the^service. To transmit a control character in Works, hold down 
the Command key and press whatever character key you need. For example, 
to transmit Control+ C, hold down the Command and Control keys and press 

the C key. 
For Works Communications documents: 

This key combination Corresponds to 

Command + Option + 3 

Command + Option + Delete 

Command + Option + [ 

Break 

Delete 

Escape 
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Calling a Personal Computer 

S^SSSSSsSSsaas* 
acquaintances who have personal computers. 

To call a personal computer: 

B SMinS5 -* •» * 
0 Dial the number. 

a When Works says “CONNECT”, begin typing. 

information6 C°nneCted’ you can ^ messages and send and receive 

To call a personal 
computer 

beTpfacCe°mPUter a8am’ ^ ““ 0pCn thiS file 311(1 dia1’ and the settings will 

(^5® rInf()rmadon ‘hat aPPears in the Communications window which is 





18 Sending and Receiving 
Information 

Sometimes you’ll want to interact with another computer by sending or 
receiving messages. This type of information is called text. When you’re 
using an information service, you usually send and receive text. What you 
see on the screen while you’re using Communications is text. 

At other times you 11 want to send files, like Spreadsheet documents, for 
someone else to look at, or you’ll want to get a copy of an application pro¬ 
gram available on an information service. A file can be either a file created 
with an application, or an application program itself that you send or receive. 

ou can t read the particular file that you’re sending or receiving while the 
transmission is in progress. You can, however, use other Works tools during 
this time. 6 

Microsoft Works gives you flexibility in communicating with other comput¬ 
ers. By using terminal emulation, your Macintosh can mimic different types 
of terminals when connected to a host computer. This allows your computer 
to respond to commands from the host that are usually intended for terminals 

You set the type of terminal emulation — TTY, VT52, or VT100_in the 
Settings dialog box. TTY terminals use only ASCII characters, which are the 
simplest form of communication between computers. VT52 and VT100 termi¬ 
nals use a more complex form of communication. With VT52 and VT100 ter¬ 
minal emulation you can use the keypad in the Communications menu bar to 
send special codes to the host. 

This chapter shows you how to: 

■ Send both text and files. 

■ Receive both text and files. 

If you want to gain access to a bulletin board or information service, see 
“Sending Text” and “Capturing and Saving Text” in this chapter. If you plan 
to send or receive an application program or application file, see “Sending a 
File” and “Receiving and Saving a File” in this chapter. 
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Ways to send 
information 

To send text as you 
type it 

To send blocks of 
text 

Sending Information 

Works Communications gives you two ways to send information: 

■ As text: You can type the information in the Word Processor, save it, and 
send it out as text. This is especially useful for sending messages through 
electronic mail. Communications will send the information much faster 
than you can type it, so you can save on long-distance telephone bills. 

■ As a file: If you send a file to another Macintosh, or another type of com¬ 
puter, the recipient will be able to save the file and then open it later with 
the appropriate tool or program. 

Information sent as text is meant to be read and used during the course of 
communicating with the other computer. Information sent as a file is meant 
to be used later, with another tool or application. 

Sending Text 
Text is whatever you type with the keyboard. Everything you type with the 
Word Processor, for example, is text. The formatting and drawn objects in 
a Word Processor document are not text, however. Nearly every computer 
reads plain text the same way, which makes it possible for you to send text 
to other computers. When you call up an information service, you type text 
to tell it who you are and what you want to do. 

To send text as you type it: 

0 Connect with the receiving computer. 

0 Start typing. 

Once you connect with another computer, you can start typing. Most infor¬ 
mation services or bulletin boards will prompt you for commands, guiding 
you through a session. If you’re connecting with another personal computer, 
you can just type messages as though you were talking. 

You don’t have to type everything you send while you’re sending it. With the 
Send Text command, you can send large amounts of text faster than you can 
type. First, you save information in a Word Processor document. Then you 
send the text in the document with the Send Text command just as though 
you were typing it. Since much of the expense of using an information ser¬ 
vice depends on how long you’re connected, you can save money by sending 
large amounts of text from a document, rather than by typing it as you 

send it. 
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To send blocks of text: 

0 Connect with the receiving computer. 

® sure the disk containing the Word Processor file is in the disk 

0 Choose Send Text from the Communications menu. 

Works displays a dialog box listing files to choose from. 
0 Select a file from the list. 

0 Click the Send button. 

The information zips across the screen as Works sends it. 

Sending a File 

Works Communications lets you send complete files, as well as text The 

rr °f aHfl t Cln Save k and use k> just as thou8h you had sent a copy of 
the file on a disk. You can send formatted Word Processor files containing 
different fonts or type sizes; Database files that can be sorted and analyzed- 
or Spreadsheet files with formulas that work, so that they can be recalculated. 
To send a file: 

0 Connect with the receiving computer. 

0 Choose Send File from the Communications menu. 

Works displays a dialog box listing files to choose from. 
0 Select a file from the list. 

0 Click a protocol option. 

For a complete description of the available options, see “Receive File” in 
^napier 17. 

0 Click the Send button. 

Works sends the file and tells you when the transmission is complete. The 
recipient can save the file for later use. 

Receiving Information 

As soon as you connect with another computer, you can receive whatever 

“m! SetndSufr°m, -he °ther end’ The info™ation goes into the memory of 
your Macintosh, and is temporarily stored there until you close the communi- 
cation document, turn the computer off, or quit Works. 

Witfi Works Communications, you can save the information you receive for 
review by using the Capture Text When Document Opens option in the Set¬ 
tings dialog box, or the Capture Text command. You can save files for later 
use with the Receive File command. 

To send a file 
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To capture and save 
text for review 

Capturing and Saving Text 

Works automatically saves your communications session if Capture Text 

When Document Opens is checked in the Settings dialog box. 

To capture and save text: 

m Create a new Communications document and specify the appropriate set¬ 

tings in the Settings dialog box. (If you don’t remember how to do this, 

see “Specifying Settings” in Chapter 17.) 

[H Make sure the Capture Text When Document Opens option is checked. 

0 Click the OK button. 
Works displays a dialog box in which you can name the document that 

will hold the text. 

0 Type a name for the document. 

0 Click the Capture button. 
Everything you type or receive will now be saved as a Word Processor 

document with the filename you specify. 

0 Choose End Text Capture from the Communications menu when you are 

finished with your session. 

To capture and save 
text during a session 

After you end your session, you can open the Word Processor file and review 

the entire session at your leisure. 

You don’t always have to save an entire session, however—you can start 
saving text at any time while you’re connected. For example, if you call an 
information service to find out the average housing costs in Indianapolis, but 

have to look through a lot of extra material before you find what you want, 

you can wait until you’re ready before saving anything. 

To capture and save text during a session: 

0 Open a new Communications document. 

0 When you specify your settings, make sure that Capture Text When 
Document Opens is not checked in the Settings dialog box. 

0 Click the OK button. 

0 Connect with the other computer and start your communications session. 

0 Whenever you’re ready to start saving text, choose Capture Text from the 

Communications menu. 
Works displays a dialog box in which you can name the document that 

will hold the text. 
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0 
0 

0 

Type a name for the document. 

Click the Capture button. 

Works saves everything that you type or receive from the other computer, 
text will appear on your screen as it is received. 

Choose End Text Capture from the Communications menu when you are 
finished with your session. 

You can stop saving text at any time: 

S Choose End Text Capture from the Communications menu. 

Works stops saving text to the document, but you continue to receive 
information on your screen. 

the 

To stop saving text 

Receiving and Saving a File 

Information services often have entire files or application programs that you 
can transfer for storage on a disk. For example, you might want to transfer a 
new stock analysis application program so that you can examine your port¬ 
folio. Or a friend with a personal computer might want to send you a copy of 
a new game (if it’s in the public domain). Vy 

Works Commumcaucns can take such information and save it in a file on a 
disk. If it is an application program, it must go onto a disk before you can 
use if If it is a file, you may only be able to use it with a particular applica¬ 
tion. Such information is useful only if you store it on a disk. 

Before you can receive a file, you have to make sure that your computer and 
the other computer are using the same language, or file transfer protocol. 

To receive and save a file: 

To receive a file and 
save it on a disk 

0 Connect with another computer. 

0 When you know you’re about to receive a file, choose Receive File from 
the Communications menu. 

Tell the information service or computer operator at the other end to start 
sending the file. 

Works displays a dialog box in which you can assign a name to the file 
you are receiving, and choose a transfer protocol. 

0 Type a name for the file. 



0 Click a protocol option. 
For an explanation of the available options, see “Receive File in 

Chapter 19. 
fil Make sure the correct disk is in the disk drive. 

0 Click the Receive button. 

As the file comes in, Works saves it with the name you’ve chosen and tells 
you when the transmission is complete. If you receive a Macintosh applica¬ 
tion program, you can open it like any other application. If you receive a 
file you’ll be able to open it with the appropriate application. 

Note If the sender is sending a file from Works in MacBinary format, you 
can receive the file automatically — without choosing the Receive File com¬ 
mand. Just leave a Communications document open on your computer. When 
the file is sent, Works automatically saves it to a file on the current disk with 
the filename used by the sender. If you already have a file of that name saved 
on your disk, Works will add a digit to the filename. 

If you are saving or receiving a file, Works checks for errors during transmis¬ 
sion and asks the other computer to re-send information if a bad connection 
or noise in the line introduces errors into the file. If the information continues 
to contain errors. Works cancels the transmission and alerts you. You should 

hang up, reconnect, and try again. 
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Command Reference 

The Apple, File, and Window menus are identical for all Microsoft Works 
tools. For information on these menus, see Chapter 2, “Common Tasks Com¬ 
mand Reference.” 

This chapter discusses the shaded commands shown below: 

Communications 

✓Echo On 
Echo Off 

Dial... m 

Hang Up 
Answer Phone 

Capture Tent... 
Send Tent... 

Receiue File... 
Send File... 

Settings... 

Keypad 
i_ _____ 

|pr7||pf2||pf3] PF4 

EBB 'l' 

□BB 
00 6 

□0 0 E 
n 

1 0 1 
t 
e 
r 

You can invoke some Works commands from the keyboard, as well as by 
using the mouse. The available Command + key combinations are shown on 
the menus and in Appendix D. 

An alphabetical list of commands appears in the index under “Command.” 
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Echo On 
Echo Off 

Echo Off 

Dial... *D 
Hang Up 83= 

Answer Phone 

Capture Tent... 
Send Tent... 

Receive File... 
Send File... 

Settings... 

The Communications Menu 

Echo On/Echo Off 

These commands control whether or not Works echoes characters on your 
screen. 

Many computers send the characters they receive back to the sending termi¬ 
nal, which then displays these characters a second time. As you type, it looks 
as if you are typing the characters twice. If you are seeing two of each char¬ 
acter, choose Echo Off. If you are not seeing any characters, choose 
Echo On. 

Dial Dial 

Communications 

✓Echo On 
Echo Off 

Dial... 831 

Hang Up 83= 

Answer Phone 

Capture Teut... 
Send Tent... 

Receive File... 
Send File... 

Settings... 

The Dial command allows you to record names and telephone numbers. The 
Dial command also dials the numbers automatically when you have a Hayes- 
compatible modem. 

Name: Phone Number: 

HlaTl 

[Dial] 

[Dial] 

foIaTl 

(lilaTl 

[Dial] 

[ Dial 1 

IHaTI 

( Cancel ] | OK J 
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You can record up to eight names and telephone numbers in the text boxes. 
Type the numbers for the services or other computers you dial most fre¬ 
quently. With a Hayes-compatible modem, you can type a comma for a pause 
so Works will pause after dialing a number, such as 9 for an outside line, 
and hyphens so you can read your phone number more easily. (Consult your 
modem or telephone system documentation for any dialing codes you may 
have to include.) 

Click the OK button to store the names and numbers with your Communica¬ 
tions document. When you save this document. Works also saves these 
names and numbers. 

To dial a number with a Hayes-compatible modem, click the Dial button to 
the left of the name and number you want. 

Without a Hayes-compatible modem, you won’t be able to use the Dial com¬ 
mand. In the Communications window, type the dial commands specified for 
your modem. 

After dialing, you should see the following sequence on your screen: 

Dialing... 

CONNECT 

If you are communicating with another Macintosh or other personal com¬ 
puter, either you or the other party can start typing as soon as the connection 
is made. 

If you are communicating with an information service, such as CompuServe, 
The Source, or Dow Jones, follow the instructions in the service’s manual. 

Hang Up Hang Up 

The Hang Up command ends a Communications session and disconnects the 
modem from the telephone line. 

Communications 

✓Echo On 
Echo Off 

Dial... 9§D 
Hang Up m = 

Answer Phone 

Capture Tent... 
Send Tent... 

Receiue File... 
Send File... 

Settings... 
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Answer Phone Answer Phone 

Communications 

✓Echo On 
Echo Off 

Dial... &D 
Hang Up %= 
Answer Phone 

Capture Tent... 
Send Tent... 

Receiue File... 
Send File... 

Settings... 

The Answer Phone command tells Works to have the modem answer all 

incoming calls on the first ring. 

Without a Hayes-compatible modem, you won’t be able to use the Answer 
Phone command. In the Communications window, type the appropriate com¬ 

mands specified for your modem. 

Answer Phone is not initially checked on the Communications menu. When 
you choose it, Works puts a checkmark on the menu. The command is in 

effect when it is checked on the menu. 

To tell Works not to answer any incoming calls, choose Answer Phone when 

it is checked. Works removes the checkmark. 

Capture Text 
End Text Capture 

Communications 

✓Echo On 
Echo Off 

Dial... 3§D 
Hang Up 
Answer Phone 

Capture Tout... 

Send Tent... 

Receiue File... 
Send File... 

Settings... 

Capture Text/End Text Capture 

The Capture Text command saves everything you send and receive while 
connected to another computer, until you choose the End Text Capture 

command. 

|© Works Program 1 
□ Addresses 
D Article 
D Budget 
Q Dictionary 
Q Final Report 

O 

5 

Saue Captured Tent As: © Works Progr.|| 

I C aptured Tent 1 C Eject ] 

( Capture ] ( Cancel ] C Driue ] 

L ____ 

Use the Eject and Drive buttons to choose the disk on which you want to 
save. When you click the Capture button, Works begins to save everything 
displayed on your screen in the specified Works Word Processor file. 

After you choose Capture Text, the command on the menu changes to 
End Text Capture. When you want to stop capturing text, choose End Text 

Capture. 
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Send Text 

The Send Text command sends the text from a specified Works Word Proces¬ 
sor file to the receiving computer. 

Send TeHt: 

1(g) Works Program-] 

(g) Works Pr... 
□ Report 

O 

( Eject ] 

( Driue ] 

( Send ] 

( Cancel ] 

To send the text, select the file you want to send, then click the Send button. 

When you send a previously saved Word Processor file, only the text is sent, 
not the formatting information. To send a text file not created in Works, you 
must first import it to the Word Processor and then save it. 

Send Text is useful when you are using Works to prepare and send electronic 
mail. For example, you can compose a letter with the Word Processor and 
save it. Then, make the connection to your electronic mail service. When the 
service instructs you to type your letter, choose Send Text to send it to the 
service. 

Send Text 

Communications 

s/Echo On 
Echo Off 

Dial... mu 
Hang Up §§= 
Answer Phone 

Capture TeHt... 
Send Tent... 

Receiue File... 
Send File... 

Settings... 

Note If you want to send formatting and drawn objects, use the Xmodem 
Data option, or the Send File command to send the file. 
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Receive File 

Communications 

✓Echo On 
Echo Off 

Dial... 9SD 
Hang Up 9€= 
Answer Phone 

Capture Tent... 
Send Tent... 

Receiue File... 

Send File... 

Settings... 

Receive File 

The Receive File command receives formatted files or program files from 
another computer. 

|0 Works Program | 

D ftddretset < > 
Q Bddi'8ts _ 
Q fill Me 
0 Budget 
D Final Report t a 

I Saue Receiued File Rs: ® Works Progr... 

Hmodem File 1 ( Eject ] 
I 

f Receiue ] [ Cancel ] C Driue } 

Receiue Protocol: <§) MacBinary 
O Hmodem Tent (Remoue LF) 
O Hmodem Data 

Type a name for the file. Use the Eject and Drive buttons to choose the disk 
on which you want to save the file. 

Receive Protocol The protocol you use must match the protocol used by 
the other computer. There are three options to choose from: 

■ Click the MacBinary option to receive a file in the MacBinary format 
when receiving information from a commercial information service. 

■ Click the Xmodem Text option to receive a file from a computer other 
than a Macintosh or from a computer whose software does not support the 
MacBinary format. Use this option to receive text files — files containing 
only alphanumeric characters and no formatting information. 

■ Click the Xmodem Data option to receive a file from a computer other 
than a Macintosh or any computer whose software does not support the 
MacBinary format. Use this option to receive files containing both 
alphanumeric characters and formatting information. 

With each of the above protocols, both computers will check for errors in 
transmission using the Xmodem protocol. If an error occurs, Works tells you. 
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As your computer receives a file, Works displays a message box telling you 
the status of the transmission and alerting you when transmission is complete 

Note If you are receiving a file from Works in MacBinary format, you do 
not need to use the Receive File command. Works Communications will 
automatically receive a file when it is sent using MacBinary protocol. The 
file will be saved on the current disk with the filename used by the sender. If 
you already have a file of that name saved on your disk, Works will automat¬ 
ically add a digit to the name of the file you are receiving. 

Send File 

The Send File command sends a formatted Macintosh data file or a Macin¬ 
tosh program file. 

Send File: 

| Q Works Program-] 

D Addresses 1H1 ® UJorks Pr... 
□ Article 

[ Eject ] D Budget 
□ Final Report 
□ Requests 
□ Summary 

[ Driue ] 

( Send ] 

2 
( Cancel ] 

Send Protocol: <S) MacBinary 

O Hmodem Tent (Insert LF Rfter CR) 
Q Hmodem Data 

The Send Protocol options are the same as those in the Receive File com¬ 
mand. For more information, see “Receive File” in this chapter. 

Select the file you want to send, then click the Send button. Works displays a 
message box telling you the status of the transfer and alerting you when 
transmission is complete. 

Send File 

Communications 

v'Echo On 
Echo Off 

Dial... 9€D 
Hang Up 3§= 
Answer Phone 

Capture Tent... 
Send Tent... 

Receiue File... 
Send File... 

Settings... 
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Settings 

Communications 

✓Echo On 
Echo Off 

Dial... a£D 
Hang Up 3§= 
Answer Phone 

Capture Tent... 
Send Tent... 

Receiue File... 
Send File... 

Settings... 

Settings 
The Settings command gives Works the parameters to use for communi¬ 

cations. 

When you choose Settings, Works displays a dialog box identifying the 
Macintosh, modem, and phone system parameters that must be specified. 

This dialog box is also displayed when you create a new Communications 
document. This allows you to initialize the parameters before you create a 
document. 

Communications Settings: 

Type: <§) TTY O UT-100 O UT-52 □ Rulo-u*rap □ Newline 

Baud Rate: 0 300 O 2400 O 9600 Delete Key Means: 
® 1200 O 4800 O 19200 @ De|ete 

Data Size: ® 8 Bits O 2 Bits O Backspace _ 

Stop Bits: <§> 1 Bit 0 2 Bits Number of screens: [4 | 

Parity: ® None O Odd O Euen 

Handshake: O None ® Hon/Hoff O Hardware O Both 

Phone Type: <§) Touch-Tone® O Rotary Dial 

Line Delay: IQS Character Delay: |o | 

^ Capture Tent When Document Opens 

Connect To: « O [ Cancel ) |f OK 

The preset options are suitable for communicating with most commercial 
services and with other Macintosh computers equipped with modems manu¬ 
factured by Apple Computer, Inc., Hayes Computer Products, Inc., and 
Prometheus Products, Inc. If the service, computer, or modem that you want 
to communicate with requires different settings, change the settings by click¬ 
ing the appropriate options. 

When you save a Communications document, Works saves the settings with 
the document. 

If you regularly use a service requiring settings other than those proposed, 
you should create a new Communications document and change the necessary 
parameters in the Settings dialog box. Name and save the document with the 
Save As command from the File menu. When you want to use the service, 
open the file. Your parameters will be properly set. 
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Type Works allows your Macintosh to emulate three types of terminals. 
Emulation means that your Macintosh can mimic different types of terminals 
when connected to a host computer. The Type setting allows you to choose 
one of these terminal emulation types: 

■ TTY 

■ VT52 

■ VT100 

Auto-wrap The Auto-wrap setting automatically wraps text to the next line 
when the characters you type reach the maximum width of the screen. This 
setting applies only when you are emulating a VT52 or a VT100 terminal. 

NewLine The NewLine setting moves the cursor to the left-most position 
on the next line when the host computer sends a new line character. This set¬ 
ting applies only when you are emulating a VT52 or a VT100 terminal. 

Delete Key Means Delete/Backspace The Delete Key Means Delete 
setting inserts a Delete character (ASCII 127) when you press the Delete key. 
The Delete Key Means Backspace setting inserts a Backspace character 
(ASCII 08) when you press the Delete key. These settings apply only when 
emulating a VT52 or VT100 terminal. 

Baud Rate Baud rate is a measure of the speed of data transmission. It is 
roughly the same as the number of bits per second. Each letter or numeric 
digit consists of 8 bits. Thus, 300 baud is approximately 30 characters per 
second. Most modems used over the switched telephone network operate at 
300, 1200, or 2400 baud. You need to know the baud rate at which your 
modem operates and then set this parameter by clicking the appropriate 
option. Works proposes 1200 baud. 

Number of Screens The Number of Screens setting allows you to scroll 
through a specified number of screens during your current Communications 
session. This makes it possible to find information quickly, log off, and then 
review the information without the expense of spending additional time con¬ 
nected to a host computer. 

You specify the number of screens you want to scroll through by typing a 
number from 1 to 100 (the standard setting is 4). Works keeps these screens 
in memory so you can review previous screens while you’re still connected. 

After a full screen of text is received, a standard Macintosh scroll bar appears 
on the right side of the Communications window. 

As you continue to receive text, it may exceed the number of screens you’ve 
set. When this happens, screens are removed from memory in the order they 
were received. For example, if you set 2 as the number of screens, when 
screen 3 comes into view, screen 1 is erased from memory. You now scroll 
between screens 2 and 3. 

Note It’s a good idea to specify only the number of screens you need. Sav¬ 
ing a large number of screens will reduce the memory available for other 
Works tools. If you don’t have enough free memory, Works won’t allow you 
to save the number of screens you’ve set. 



Data Size While data is represented internally in your Macintosh as 8 bits 
per character, it can be transmitted in either 8-bit or 7-bit segments. Most 
commercial services transmit 8-bit characters, so Works proposes 8 bits. You 
don’t have to change this setting unless the system you are communicating 
with can receive data only in 7-bit segments. 

Stop Bits Most commercial services use one stop bit to identify the end of 
the transmission of a single character, so Works proposes 1. You don’t have 
to change this setting unless the other computer can transmit only two stop 
bits. 

Parity Parity describes the bit, if there is one, added to transmitted charac¬ 
ters for error checking. (After the receiving computer or terminal uses the 
parity bit to check for transmission errors, the bit is automatically removed 
from the characters.) Most commercial services do not use parity, so Works 
proposes None. If necessary, change this by clicking the appropriate option. 

Handshake Handshake refers to the way terminals or computers being 
used as terminals tell each other whose turn it is to send or receive data. It is 
normally used when transmitting data at very high rates of speed to synchro¬ 
nize the sending and receiving systems. 

Handshaking, if used, is done by either hardware or software. Most commer¬ 
cial services support Xon/Xoff handshaking, so Works proposes Xon/Xoff. If 
you are communicating at 2400 baud or greater, or intend to use the Capture 
Text command, use Xon/Xoff. 

Phone Type The telephone system uses two kinds of dialing: 

■ Rotary Dial 

■ Touch-Tone 

Your modem uses different codes to dial automatically. Works needs to know 
which dialing method you’re using. Works proposes Touch-Tone. If your 
telephone system is rotary dial, change the setting by clicking the Rotary Dial 
option. 

Line Delay/Character Delay When transferring files over com¬ 
munications facilities, it is sometimes impossible to establish handshaking 
between the two systems. If the transmitting system sends data as fast as it 
can, and if the receiving computer cannot keep up with the sender, data can 
be lost. Most of the time you can prevent this if you slow down the transmit¬ 
ting computer by delaying between characters or between lines as they are 
sent. 

Enter an amount of time to delay by changing either Line Delay or Character 
Delay from the proposed setting of 0. The delay you specify is in increments 
of 1/60 of a second. For example, if you type 3, the delay will be 3/60 of a 
second. 
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T f W 6n DoC1Ument °Pens Capture Text allows you to save 
information for review at a later time. When the Capture Text option is 
chosen, Works asks you to name a file in which you’ll be saving captured 
text. Everything you type or receive will then be saved in a Word Processor 
document with the filename you specify. racessor 

6Ct T° ^CHck thC °pti°n that corresP°nds to the Macintosh port to 
m°dem;S/“ached- Works proposes the telephone port. It is 

y recon™®nded that you connect your modem to this port. (This may 

disk ) ’ CVer’ y°U USC ^ telephone P°rt for connecting a hid 

When all the parameters are set, click the OK button. 

The Keypad 

The Communications keypad is for use with VT52 or VT100 terminal emula- 
lon when your keyboard doesn’t include a numeric keypad. The keypad can 

for 'th^hnsfyPC SpetClal,CT°de! (called escaPe codes) *at provide instructions 
for the host computer. Use the keypad along with the keys on your keyboard 
to send escape codes to the host. y 

See Appendix H for a list of the VT52 and VT100 
supports. 

escape codes that Works 

The Keypad 
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Microsoft Works is more than four separate tools. While each tool helps you 
in one area of your work, the tools can also work together to perform addi- 
tional tasks they can’t perform alone. 

The Word Processor is ideal for writing, and with information from the Data¬ 
base you can also use it to make business forms, customized letters, and 
mailing labels. You can copy Communications information and Database 
figures to the Spreadsheet, and you can include Spreadsheet figures and Com- 
munications information in Database documents. You can also copy Com¬ 
munications and Spreadsheet information, including charts, to the Word 
Processor. You can use Draw and the Word Processor’s or Spreadsheet’s 
other special features to make the information more interesting and attractive. 
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This part of the manual explains how to use the Works tools together: 

■ Chapter 20, “Moving Information Between the Tools,” tells you how to 
move information and drawings between the Works tools. 

■ Chapter 21, “Merging: Creating Mailing Labels, Form Letters, and 
Forms,” shows you how to use the Database to create form letters an 
mailing labels, to address envelopes, and to fill in forms you create in the 

Word Processor. 

For information on using Works with other programs, see Appendix B, 
“Using Works with Other Applications.” 

For information on the specific tools in Works, see the appropriate parts of 

this manual. 
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365 

Thischapter explains how to move information between the Works tools 
You II learn how to: 

■ Copy information between Word Processor documents. 

" dCr“°n betWCen Word Processor> Spreadsheet, and Database 

■ Copy Communications information. 

■ Copy charts and drawings to Word Processor and Spreadsheet documents. 

Sf w°Fa or°CeSSOr,isjhe most c°nvenient tool for integrating information. 
fhe formatting’ and merging capabilities give you 
the most flexibility for combining information from the various tools. 

You’ll often want to include information from a Database, Spreadsheet or 
Communications document in a Word Processor document. For example a 
business report might require inventory information from a Database docu¬ 
ment, sales projections from a Spreadsheet document, and travel information 
or stock quotes from a Communications document. 

To learn how to work with the information once you move it, you should 
turn to the appropriate chapters in this manual for each tool. Before you trv 
the procedures in this chapter, you should already know how to select infor¬ 
mation within each tool. Before moving drawings, you should already know 
how to select a drawn object. y 

Copying information between tools is subject to available memory, particu¬ 
larly if you are copying large selections. When you copy information to the 
Clipboard, you increase memory usage by the amount you copy. When you 
paste the Clipboard’s contents, you paste a copy of the Clipboard’s contents 
increasing memory usage again by the same amount. If the Clipboard’s con-’ 
tents are large, you may not have enough memory to paste. If Works displays 
an alert box, try copying your information in smaller sections. 

About memory usage 

Note When you have finished pasting a large selection from the Clipboard 
it s a good idea to free some memory by reducing the size of the Clipboard. 
To reduce the Clipboard’s size, reduce the amount of information by select¬ 
ing and copying a small amount of information (for example, a single word) 
from your document. 6 J 
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Copying Information Between Tools 

tniS IS me resU11 yvu wam, ^ui/auvuw — 

mand in any of the following procedures. 

To copy information 
between the tools 

situations. 

To copy information between the tools: 

m Make sure that the document you want to copy from is open. If it is not 
active, activate it by choosing its name from the Window menu. 
Works brings the document to the front and displays the scroll and title 
bars to show you that the window is active. 

[H Select the information you want to copy. 

r x r minrinm Conrrh Format SdgII Macro 

[H Choose Copy from the Edit menu. 
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S Open the file you want to paste into. 

0 To copy to the Word Processor, position the insertion point in a blank 
line or select the text that you want to paste over. (Scroll if necessary.) If 
you select text in a Word Processor document, Works replaces it when 
you paste the contents of the Clipboard. 

To copy to the Database or Spreadsheet, select the entry or cell at the 
upper-left comer of the area you want to paste into. You can also select a 
range of entries or cells as the paste area. 

0 Choose Paste from the Edit menu. 

Works pastes the copied information. 

As long as the information remains on the Clipboard, you can paste it as 
many times as you want. For example, to use the same chart at the beginning 
of each section of a document, you can copy it once from the Spreadsheet 
then scroll through your document, pasting a copy of it each time you come 
to a new section. 

Copying Information 
to the Word Processor 

When you select information to copy to the Word Processor, you need to 
consider how it will look in a Word Processor document. Your selection may 
be longer than a single page, or wider than a standard page. Works divides 
selections longer than a page into page-sized pieces for the Word Processor. 
It Database records or Spreadsheet rows are wider than a Word Processor 
page, you can format your information to fit after you paste it in 

When you copy information to a Word Processor document, all attributes_ 
tont, type size, type style, color, and justification — are also copied. 
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To copy between 
Word Processor 
documents 

Copying Between Word Processor Documents 

You can copy information from one Word Processor document to another by 
using the general procedure described above. Notice that if you position the 
insertion point in a blank line, Works automatically opens up enough space to 

paste the entire contents of the Clipboard. 

To copy Spreadsheet 
information to the 
Word Processor 

Copying Spreadsheet Information 
to the Word Processor 

When you copy Spreadsheet information to the Word Processor, the contents 
of each column are separated by a tab character. Each row ends with a return 
character. If the rows are wider than the Word Processor page, paste the 
information first, then select and format it to fit. 

When you copy Spreadsheet numbers or formulas to the Word Processor, 
Works pastes them as text. The relationship between the cells in the 
Spreadsheet no longer exists. For example, if you change a number in a 
column copied to the Word Processor, the total for that column will not 
change. You need to select the total in the Word Processor document and 
change it using the standard Macintosh editing techniques. 

You may want to adjust tab stops to change the alignment of the columns. 
For more information, see “Setting and Using Tabs in Chapter 4. 

To copy Database 
information to the 
Word Processor 

Copying Database Information 
to the Word Processor 

When you copy records from the Database, each field arrives separated by a 
tab character. Each record follows on its own line, ending with a return 
character. Records that are wider than the Word Processor page can be 
selected and formatted to fit after you paste. 

When you copy Database information, Works normally copies field names as 

well as the selection. 

Hint To paste only the selection, without the field names, hold down the 
Option key while you choose the Paste command. 

When you copy Database numbers or the results of a computed field to the 
Word Processor, Works pastes them as text, and won’t be able to recalculate 
them in the Word Processor. If you want to adjust any numbers, select them 
in the Word Processor document and use the standard Macintosh editing 

techniques. 

To copy records in the Database, you should copy from a list window, 
because in the form window you can copy only one field at a time. In the list 
window, you can copy a field, a record, or a range of adjacent records, 

entries, or fields. 
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Copying from Other Applications 
to the Word Processor 

You copy information from other Macintosh applications in one of two ways: 

■ To copy small amounts of information, use the Scrapbook and Clipboard. 
For more information, see “Using the Scrapbook and Clipboard” in 
Appendix B. 

■ To copy large amounts of information or an entire document, use the 
Import File option in the Open dialog box. For more information, see 
Appendix B, “Using Works with Other Applications.” 

To copy information 
from other 
applications 

Copying Information 
to the Database 

When you copy information to a Database document, the information 
assumes the font, type size, type style, color, display and alignment of the 
field it is copied into. 

Note If the Clipboard contains text and drawings from a Word Processor or 
Spreadsheet document, Works pastes only the text into the selected field. If 
the Clipboard contains only a drawing, you won’t be able to choose Paste in 
the Database tool’s Edit menu. 

Important If the text on the Clipboard includes more than 250 characters 
that are not separated by tab characters, or by two or more return characters, 
only the first 250 will be pasted into the selected Database field. 

Copying Word Processor Information 
to the Database 

When you copy information from the Word Processor to the Database, you 
need to tell Works how to distinguish between fields and records. Each piece 
of information that will go into a field must be separated from the next piece 
of information by a tab character or by two or more blank spaces. Each 
record must end with a return character. Any blank lines become blank 
records. 

This section explains how to copy Word Processor information to the Data¬ 
base, using spaces, tab characters, and return characters to keep the informa¬ 
tion in its characteristic fields and records. 
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To copy Word 
Processor information 
to the Database 

To copy Word Processor information to the Database: 

□ In the Word Processor, insert one tab character between each piece of text 
that you want to appear in a separate field. Insert return characters to start 
new records. (See the W ord Processor section of this manual for in forma- 
tion on inserting tab and return characters.) 

F * File Edit Ulindom Search Format Spell Macro 

Untitled (WP) _ 
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Dear Mr. McGrath: 

Alligator Bicycle Repair is proud to sponsor the 
for the 1986 Racing Season This year’s team includes: 

Shelley Schmidt 
Richard Dolan 
Leslie Poulin 
Susan Stanton 
Pamela Partriage 

3957 Palm Court 
9357 Circle Court 

1 1 1 Maple Street 
3976 Cherry Way 

/105 Coalinga Way / 

Wheelerville * OH 44444 
Cincinnati OH 39555 
Wheelerville OH 44444 
Cincinnati OH 44839 
Santa Cruz ,9506d\ 

Tab characters are inserted to prepare 
for pasting into the Database. 

Return characters follow each line. 

0 In the Word Processor document, select the text that you want to copy. 

0 Choose Copy from the Edit menu. 

0 Activate the Database document. 

Make sure you’re in a list window. 

0 Select the field in the upper-left comer of the area you want to paste into. 

Since the information fills fields to the right, and records down, the 
records to be filled should be blank unless you want to copy over existing 
information. To avoid overwriting information, select the blank record at 
the end of the Database. If you try to copy over existing records, Works 
asks you to confirm the loss of some data before proceeding. 

0 Choose Paste from the Edit menu. 

Works pastes the copied information. 

Note When pasting text from a Word Processor document to a list window 
in a Database document, a portion of text may be pasted in the next record. 
This is because a carriage return is inserted at the end of each line of Word 
Processor text when pasting. To move the text to the appropriate location, 
select it, and cut and paste. 
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You can now use Database commands to manipulate the information. After 
adjusting the width of several columns, the Database document looks like 
tnic 

File Edit Window Organize Format Rpnnri 

The copied information is pasted into the Database 
document, beginning with the selected entry. 

Copying Spreadsheet Information 
to the Database 

When you copy Spreadsheet information to the Database, each Spreadsheet 
column becomes a Database field. Each Spreadsheet row (or portion of a 
row) you copy becomes a Database record. If you paste a Spreadsheet 
column below an existing field, or a Spreadsheet row to the right of an exist¬ 
ing record, the new and existing information combine to make one field or 
one record. 

In the Database, you’ll need to set up enough fields to accommodate all the 
columns you’re copying from the Spreadsheet. The columns that don’t fit 
won’t be pasted into the Database. 

To copy information from the Spreadsheet to the Database: 

0 Select the information in the Spreadsheet. You can select a single cell a 
block of cells, or entire rows or columns. 

File Edit Ulindoui Select Format Ontinns chart 
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To copy Spreadsheet 
information to the 
Database 
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H] Choose Copy from the Edit menu. 

0 Activate the Database window. 
0 Select the entry in the upper-left comer of the area you want to paste 

into. 
If you don’t want the Spreadsheet information to be copied over existing 
Database text, select the blank record at the end of the Database docu¬ 
ment. If you select text, the Spreadsheet information will be pasted over 
it, but you’ll first see an alert box asking you to confirm that it is accept¬ 
able to have the Database text deleted. 

0 Choose Paste from the Edit menu. 

Works pastes the selected cells into the Database document. Each cell 
becomes a Database entry. 

r 6 File Edit Windom Organize Format Report Macro 

Copying Information 
to the Spreadsheet 

When you copy information to a Spreadsheet document, the information 
assumes the font, type size, type style, color, display, alignment, and border 

type of the cell it is copied into. 

Copying Word Processor Information 
to the Spreadsheet 

To copy from the 
Word Processor to 
the Spreadsheet 

When you copy information from the Word Processor to the Spreadsheet, you 
need to tell Works how to distinguish between columns and rows. Each piece 
of information that will go into a cell must be separated from the next piece 
by a tab character or by two or more blank spaces. Each row must end with a 
return character. Any blank lines become blank rows. 
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To copy Word Processor information to the Spreadsheet: 

0 In the Word Processor, insert tab characters between the text that you 
want to appear in separate columns. Insert return characters to start new 
rows. (See the Word Processor section of this manual for information on 
inserting tab and return characters.) 

* File Edit Ulindom Search Format Spell Macro 

TT 
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Dear Mr. McGrath. 

b 1- b 4 l 

Alligator Bicycle Repair is proud to sponsor the "I0SI&66" fggaa 
for the 1986 Racing Season. This year s team includes: 

Shelley Schmidt 
Richard Dolan 
Leslie Poulin 
Susan Stanton 
Pamela Partriage 

3957 Palm Court 
9357 Circle Court 
11 1 Maple Street 
3976 Cherry Way 
.105 Coalinga Way 

Wheelerville OH 
Cincinnati OH 
Wheelerville OH 
Cincinnati OH 

^Santa Cruz CA 

44444 
39555 
44444 
44839 

^95060 X 

Tab characters are inserted to prepare 
for pasting into the Spreadsheet. 

Return characters follow each line. 

0 In the Word Processor document, select the text that you want to copy. 
0 Choose Copy from the Edit menu. 

0 Activate the Spreadsheet document. 

0 Select the cell in the upper-left comer of the area you want to paste into. 

Since the information fills cells to the right, and rows down, cells in the 
area to be filled should be blank unless you want to copy over existing 
information. To avoid overwriting information, select a blank cell at the 
end of the Spreadsheet. If you try to copy over existing records, Works 
asks you to confirm the loss of some data before proceeding. 

0 Choose Paste from the Edit menu. 

Works pastes the copied information. 

Note When pasting text from a Word Processor document to a Spreadsheet 
document, a portion of text may be pasted in the next row. This is because a 
carnage return is inserted at the end of each line of Word Processor text 
when pasting. To move the text to the appropriate location, select it, and cut 
and paste. 
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You can now use Spreadsheet commands to manipulate the information. 
After adjusting the width of several columns, the Spreadsheet document looks 

like this: 

File Edit Window Select Format Options Chart Macro 

[3957 Palm Court jVheeleryillo 

9357 Circle Court [Cincinnati. 

I l l Maple Street : Vheelerville 

3976 Cherry Way [Cincinnati 

Richard Dolan 

Leslie Poulin 

Susan Stanton 
” Pamela Partriage 1105 Coalinga Way.[Santa Cruz 

The copied information is pasted into the spreadsheet 
document, beginning with the selected cell. 

Copying Database Information to the Spreadsheet 

To copy information from the Database to the Spreadsheet. 

□ Select the information in a Database list window. You can select 
individual or adjacent records, fields, or field entries. 
When you copy Database information, Works normally copies field 
names as well as the selection. 
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[2] Choose Copy from the Edit menu. 

[3] Activate the Spreadsheet window. 
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0 Select the cell in the upper-left comer of the area you want to paste into 

Since the information fills cells to the right and rows down, the cells in 
the area to be filled should be blank unless you want to copy over exist- 
mg information. To avoid overwriting information, select a blank cell at 
the end of the Spreadsheet. If you tiy to copy over existing cells, Works 
asks you to confirm the loss of some data before proceeding. 

0 Choose Paste from the Edit menu. 

Works pastes the selected information into the Spreadsheet. 

Hint To paste only the selection, without the field names, hold down the 
Option key while you choose the Paste command. 

When you copy from the Database, 
Works always pastes the field 
names as well as the selection. 
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31 

5 
4 Hamburgers $510. 
5 Bouillabaisse $1 50.1.1. 
6 Brezen $1 To . 
7 Viener Schnitzel $4.25 “ . 
8 Barbequed Shrinl $6.i'o" 
9 Knackerbrod $1.95. 

10 Poise $4 60.1.!. 
11 Moussaka $3.95 ‘ . 
12 Peanut Chicken 1 $5.25 ' 1. . 
13 Steaks. $7.20 ' . 
14 Tapas $4.35.[. 
15 Pea Soup $1.20 ] . 
16 Goudse Kass ' $2.95' . 
17 

EH 
5 

Text becomes Spreadsheet labels, and numbers become Spreadsheet values 
Works copies the field names as labels in one row, with each record in a 
separate row. The information is displayed in the existing cell format. 
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To copy 
Communications 
information 

Copying Communications Information 

You copy information from a Communications document in different ways, 

depending on how you received it. 

If you used the Capture Text command to gather the information the infor¬ 
mation is already stored in a Word Processor file. In this case, follow the 
procedures for copying from Word Processor documents. 

If you used the Receive File command to gather the information, use the pro¬ 
cedure that is appropriate to the file you received. For example, lf y°u 
received a Spreadsheet file and want to copy it into a Works Database docu¬ 
ment, see “Copying Spreadsheet Information to the Database in this chapter. 

Note If the Clipboard contains text and drawings from a Word Processor or 
Spreadsheet document, Works pastes only the text into the Communications 
window and sends it out over the modem. If the Clipboard contains only a 
drawing, you won’t be able to choose Paste in the Communications tool s 

Edit menu. 

Copying Drawings 

You can draw and edit objects in a document if Draw is on in the window 
that contains the document. Draw remains on in a document, even it you 
activate Draw in another document, until you turn Draw off within that docu¬ 
ment, close the document, or quit Works. 

You can copy a drawn object, or an object along with underlying text. 

■ Within a Word Processor or Spreadsheet document 

■ From one Word Processor or Spreadsheet document to another 

■ From the Word Processor to the Spreadsheet 

■ From the Spreadsheet to the Word Processor 

In addition, you can create a text object from regular text and paste it into a 
Word Processor or Spreadsheet document. 

Note You can copy drawings to the Scrapbook for use with other applica¬ 
tions. For more information, see “Using the Scrapbook and Clipboard in 

Appendix B. 

Before you paste a drawn object, or text that includes a drawn object, you 
should insert enough blank space in the receiving document to paste the 
object (and any surrounding white space that you copied with it). Otherwise 
the object will be pasted over existing information in the document. 



Chapter 20 Moving Information Between the Tools 377 

If you paste an object over information in your document, you can turn on 
raw select the object, and move it. For more information, see “Using 

Draw in Chapter 1. 6 

WoS'prnf 211 °HbjeCt’ °r tCXt th3t inC,udes 3,1 ob)ect’ over information in a 
Word Processor document, you can also turn Draw off, and move the text 
separate^. If you position the insertion point ahead of the object and press 
the Return key, the text scrolls down behind the object. However, if you 
position the insertion point within the area that includes the object, or below 
the object, the text and drawing scroll together down the page.J 

;h"a,Wtord Processor document, before pasting an object that extends beyond 

™Jfi SCT COnta'Tg,teXt’ use the Retum key to insert enough blank 
space to make room for the object. This will allow you to scroll to see the 

rwC CI'pboard c°ntains on|y a drawn object, you can paste it into a Word 

mT if°th0rrr'k doc,ument‘ In the Database a"d Communications 
tools, if the Clipboard doesn t contain text, you won’t be able to choose 
Paste from the Edit menu. 

A drawn object is pasted into a document’s draw layer and is automatically 
selected. If there is more than one object, they are all selected. To move the 
objects separately, click away from the objects, then select the object you 
want to move. J J 

When you paste a drawn object: 

■ If Draw is off, Works pastes the drawing in the center of the window 
and turns Draw on. 

■ If Draw is on, Works pastes the object in the center of the last point 
clicked in the window. If there was no point clicked in the window 
Works pastes the object in the center of the window. 

■ If Draw is on, and there is a selection in the document you are copying 
to, the object is pasted in the center of the selection, frontmost in the 
draw layer. (However, if the drawing is an exact duplicate of the selected 
object, the drawing is pasted slightly below and to the right of the 
selected object.) 6 

A chart created from a Spreadsheet document is handled like any other drawn 
object However you can’t use the Cut command with charts. You copy a 

is active ^ C lpb°ard by choosin8 CoPy from the Edit menu when the Chart 

When you paste a chart into a Word Processor or Spreadsheet document 
Works automatically turns Draw on. The chart and the text are grouped so 
hat they can be moved as a unit. To edit the elements separately, choose the 

Ungroup command from the Format menu, click away from the group and 
select one object in the group. See “To ungroup objects” in Chapter 1 for 
more information. 

To copy a drawn 
object 

To copy a chart 
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To copy text and 
objects together 

You can copy Word Processor or Spreadsheet information that includes both 

text and drawn objects. 

To copy text and drawn objects together: 

□ In the Word Processor or Spreadsheet document, make sure that Draw 

is off. 
[T| Highlight the text and the entire object (or group of objects) to be copied. 

If you’re copying Word Processor information into the Spreadsheet, make 
sure that each piece of text that will go into a cell is separated by a tab 
character or by two or more blank spaces. Each row must end with a 

return character. 

0 Choose Copy from the Edit menu. 

Your selection is copied to the Clipboard. 

6 File Edit Window Search Format Spell Macro 

n ^ Article (WP)J 

Fireworks in the Alps 

e way, citizens of Alpine towns and cities will turn out to gr 

rks displays. 

The Hilltop climb 
jughest terrain!" 

Wheeler President 

teLUniS; 

L ucer ne May 28 
Zurich May 29 

Chur June 3 

Lugano June 1 U 
Milan June 1 2 

> 

H Try this piece of precis ion machinery 

/if:* President MartinWhe eler 

& iiaoil® tFinuDOD ftfe© IFmaefliSoratL 

Hi ram A1 bert Wheeler is extremely pleased by the new b1 ke hi3 

0 Activate the Word Processor or Spreadsheet document you are pasting to. 

0 Choose Paste from the Edit menu. 

When you paste text and drawn objects: 

■ If Draw is off in the document you are pasting to, Works pastes the text 
on the document’s text layer and the object on the draw layer. Each layer 

can be edited individually. 
■ If Draw is on in the document you are pasting to, Works pastes only the 

object into the document’s Draw layer. 
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The following table shows how pasting works: 

If Draw is Clipboard contains 

Off text 

object(s) 

text and object(s) 

On text 

object(s) 

text and object(s) 

Works pastes 

text 

objects(s) 

text and object(s) 

text, but turns it into an 
object 

object(s) 

object(s) only 

and pr *“*d™ 
on in the document you am copyrnfloaS.lTl.r'", “Xt' Dr,w mns‘ Ke 
text. py g to> and the Clipboard must contain only 

When you create a text object: 

" L'To rnTtf,“'i0n ‘Vhe Word <*■«**** document that you’re pant 
/°/vhe text 1S pasted lnt0 the document’s draw layer as a new 

JKT * - “ * d« Sre yo„ 
■ If a text object within the document is selected with the Text tool thp 

iSLTo„^,S,,P ,S inser“ inslde ,he Bxt i" front of dte 

■ objm’,he - « - 

To create a text object 
from normal text 

STon^dTin !ZZ S2LTJ&s» « *«®y 
the most formatting options and iTynteS to”™ wd 

provide some ideas on enhancing information in a Word8Processor documen 

You can change the appearance of a document by: 

' S’JSSK ?'■1!,pe size-,ype sly‘e-or color of“* «*» «<*« 

■ S2*.you’ve copied a targe 

■ Moving the tab stops to adjust columnar tables. 

To change a 
document’s 
appearance 
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• Changing the line spacing or indenting certain pieces of information for 

■ Adding headers and footers using the range of options available in the 

Word Processor. 
■ Using the Draw On command to add labels, additional lines, oxes. or 

circles to dravTattention to important information. For more information, 

see “Using Draw” in Chapter 1. 

This chanter gives you the skills you need to move information between 
7 i rSn ef?! “Merging- Creating Mailing Labels, Form Letters, and 

gfves yoi. another way to automatically combine information from 
different tools with the Word Processor’s merge capability. 



21 Merging: 
Creating Mailing Labels, 
Form Letters, and Forms 

The Word Processor and the Database work together to let you add informa¬ 
tion from a Database document to a form you create in a Word Processor 
document. With this merge capability, you can create form letters, address 
mailing labels and envelopes, and print on preprinted continuous forms. 

smg Works drawing capabilities, you can design an attractive form that 
Works fills out for you automatically. 

This chapter begins with an overview of the merge procedure, followed by 
several examples of how to use merging in your work. You’ll learn how to: 

■ Create a merge document using the Word Processor and Database. 
■ Print a series of customized documents. 

■ Create and print continuous and multiple-column 
■ Create a form letter. 

■ Fill out forms — those you design yourself using 
preprinted forms. 

mailing labels. 

the Word Processor and 
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Creating a Merge Documem 

A merge document looks like any other Word Processor document. However, 
if you choose the Show Field Names command from the Edit menu, you can 
see that it contains placeholders in place of some regular text. A placeholder 
is a rectangle containing the name of a Database document and a field name. 
A merge document with placeholders looks something like this. 

a ciio cHit iiiinriniii Search Format Spell Macro 

September 12, 1989 

lArifiressesTItTillArmresses:First NarnellAddresses Last Name) 

1 Addresses. Addressl____, 
lAfidresses:C1tul. lAddresses:State| |Addresses:ZifiJ 

Dear lAddresses.TitlellAddresses.Last Narnel. 

We are Dleased to welcome jou as our lewest Mountain Wheeler Bicycle 
dealer in the greater fAddri< ses.Citjjj a ~ea. You have been selected as a 

npt Ain WhPPlPr dealer h&i nf nn if ni ikt apdi nn rcr fird* nf SalP’S- m 
Placeholders Name of Database field 

Name of Database document 

About the merge 
procedure 

To create a merge 
document 

To create a merge document, you add information from a Database document 
to a Word Processor document. First, you indicate where you want the infor¬ 
mation to go by inserting placeholders into your Word Processor document 
with the Prepare to Merge command. Then, you use the Print Merge com¬ 
mand to print customized copies of the Word Processor document. For each 
entry in a Database field you specify, Works replaces the placeholder in the 
Word Processor document with an entry from the specified field. So, each 
record in the Database document produces one customized Word Processor 

document. 
The general procedure for creating a merge document and printing the cus¬ 
tomized copies is summarized below. Specific examples follow on how to 
use merging to create form letters, continuous and multiple-column mailing 
labels, and customized forms. 

Begin by opening both the Database document that you want to merge infor¬ 
mation from and the Word Processor document that you want to merge infor¬ 

mation into. 



I 

0 XafcSk™” Wi,h 'he informa,ion yo” «open an 

You can have more than one Database document open to merge from. 

S censor fileCW PrOCeSSOr document> or open an existing Word Pro- 

S ^e°rcopEeSS°r d°CUment’ type any text that wiU remain the same 

0 Position the insertion point where you want to insert the first placeholder. 
0 Choose Prepare to Merge from the Edit menu. 

Select the Database 
document containing 
the information 
you want to merge. 

Select the appropriate 
field name here. 

0 Select the Database document you want to use. 

Works displays a list of the field names for that document. 

0 Select the appropriate field name. 

0 Click the Merge button. 

Works displays information from the first record 
document. If a record is selected in the Database 
mation from that record. 

in the specified Database 
, Works displays infor- 

Repeat steps 4 through 8 for each piece of Database 
include in your Word Processor document. 

information you want to 

You can change the information displayed in the Word Processor document 
y activating the Database document and selecting another record. When you 

fmmath ^ ^ord Processor document again, you’ll see information displayed 
from the newly selected record. F y 

Chapter 21 Merging 383 



384 Using the Tools Together 

To view placeholders Any time you want to view the placeholders: 

g Choose Show Field Names from the Edit menu. 

When you choose Show Field Names, the command name changes to Show 

Field Data in the Edit menu. 

Note Works moves a placeholder to the next line on the screen if the place¬ 
holder does not fit. However, the information may not move depending on 
its length. If the information in a field is too long to fit on the 
moves to the second line. If it is too long for the second line Works prints 
as much of the information as possible, but does not include the information 

that doesn’t fit. 

You delete placeholders, and change their font, size, style and color, exactly 
as you do ordinary text. If you change the attnbutes of a placeholder, all t 
information in the placeholder changes to reflect your choices. 

When you choose Show Field Data, you view the Database information as it 
will look in your finished Word Processor document. 

Note If you close a specified Database document, or if you open the Word 
Processor merge document before you have opened a specified Database 
document, you’ll see the message “NOT ON DESKTOP” m the appropriate 
placeholder You need to open the Database document in order to print or see 

information displayed from the records. 

If you delete a specified field or change a specified field name in a Database 
document, you’ll see the message “FIELD NOT IN DB” in the appropriate 

placeholder. 

To prepare to print 
customized 
documents 

Printing Customized Documents 

You use the Print Merge command to print customized documents. To 

prepare for printing: 

[T] In the specified Database document(s), sort the records to arrange them in 

the order you want them to print. 
HI If you want to print only a subset of the records in the Database, use the 

Record Selection or Match Records command from the Organize menu to 

select the records you want to print. 
[|] Activate the Word Processor merge document, choose Page Setup from 

the File menu, and make any changes. 

[3 Prepare your printer for printing; add special forms or paper. 
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To print your customized documents: 

0 Choose Print Merge from the File menu. 
The Print dialog box appears. 

0 Click any appropriate options, then click the OK button. 

If you d like to view your document before printing, you can choose the 
Pnn, Pre^ew 0p,i„„ i„ „* dialog box, vieJas mA/Si asXL 
and then click the Print button to print. For more information on Print ’ 
Preview, see “Print” in Chapter 2. 

Works begins to print the customized document. 

To print customized 
documents 

If you choose Print instead of Print Merge from the File menu Works mints 
one copy of the Word Processor merge document. If you choose Show Field 

££££: JSL"* Works prints one*- d-“ld 

Note Print Merge prints all records in the selected Database document 
Choosing specific page numbers in the Print Merge dialog box determines 
which pages are printed, but has no effect on the number of records printed 

P"nt a subset of records in a merge document, you must use the Record 
Selection or Match Records commands in the Database to select the records 

Work^fnChapterS 0rmatl°n ^ selection’ see “How Selection Rules 

Creating Mailing Labels - 

To create mailing 
labels 

® Continuous labels (one-across) 

■ Multiple-column labels (two-across, three-across, etc.) 

To create mailing labels, you change options in the Page Setup dialog box to 
correspond to the measurements of your mailing label, and then you create a 
merge document in the Word Processor containing only placeholders. You 
can save the document to use whenever you want to print mailing labels. 

You can create two types of mailing labels: 

^P^ration and printing are basically the same for both continuous 

eachTypePof £1™ ^ S' Settmg “P the merge document is different for 

The instructions that follow assume that you are using an Image Writer 

Ap^LaseyrWr?er.”Sm8 “ LaSerWriter’ see APPendix C> “Printing with the 
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To prepare labels for 
printing 

To set up the merge 
document for 
continuous labels 

Preparing Labels for Printing 

First, create a new Word Processor document and change options in the Page 

Setup dialog box. 

(7] Create a new Word Processor document. 

Q[] Choose Page Setup from the File menu. 

[I] Click the Custom Size option, 
m Type a width measurement in the Paper Width box. 

For continuous labels, measure the width of the mailing label, and type 
the measurement in the Paper Width box. 
For multiple-column labels, type the width of the page that contains the 

labels. 
[5] Click the No Gaps Between Pages option. 

0 Type a height in the Paper Height text box. 
For continuous labels, measure from the top of one label to the top of t e 
next, and type this measurement in the Paper Height text box. 
For multiple-column labels, type the height of the page that contains the 

labels. 
[7] Set the left, right, top, and bottom margins. 

Type numbers to represent inches or fractions of inches. For examp e, 
typing .25 would leave a quarter of an inch margin, and typing .125 
would leave an eighth of an inch margin. 
For continuous labels, set a quarter of an inch left margin, an eighth of an 
inch right margin, and top and bottom margins of zero. The left and nght 
margins may need to be adjusted to match the label position on the printer 

platen. 

0 Click the OK button. 

If you’ll be printing continuous labels, follow the steps below. If you 11 be 
printing multiple-column labels, skip the information below and go to Set¬ 
ting Up the Merge Document for Multiple-Column Labels later in th 

chapter. 

Setting Up the Merge Document for 
Continuous Labels 

Before you set up the merge document, follow the instructions under “Prepar- 

ing Labels for Printing.” 

To set up the merge document for continuous labels: 

0 Open the Database file you want to use for the mailing labels. 

[71 Activate the Word Processor merge document and design your mailing 
U label by choosing the font, type size, type style, and color you want from 

the Format menu. 



0 Choose Prepare to Merge from the Edit 
To review this procedure, see “Creating 
this chapter. 

menu to insert the placeholders, 
a Merge Document” earlier in 

^irenge the information in the placeholders as you normally would a 

If Show Field Names is chosen, you’ll see the following: 

* File Edit 

in r;- 

Remember to add spaces and appropriate 
punctuation between placeholders. 

^indoui Search Format Spell Macro ^ 

L\ ^Untitled IlliPi — — 

P* 1 1 1 1 1 1 \*1 1 1 

lAddressesFirst 
.I'.. 1 . - I5.|6. O 

1 

lAddresses:Addn 
—Ul 1 lci Lr^uui coocS.LaSl wamfil 
ssl 

I 

lAddresses:Citnl lAddr esses btatpl 1 a ri hroc.r-- 7i 1-. 1 

— 

K„ 1° w^“^.e W"1 rr=ss0r's n,ler “ the width of your 
, , , Processor. Set the margins to correspond to the width of 

^ttu7US R'8h' and Uft Marg‘n you specified wilh 

To see the amount of vertical space available in your label, you can press the 

0Rfernkey Untl y°j S.ee a page break line- The sPace between the beginning 

to work S^ thC ^ brCak " thC “ °f Vertical sPace you have8 

Be sure to remove the extra return characters until the page break is no 

othfS! when printing" * rem°Ve P*8'! bMk' Works ** 'very 
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To set up the merge 
document for 
multiple-column 
labels 

Setting Up the Merge Document for 
Multiple-Column Labels 

Before you set up the merge document, follow the instructions under “Prepar¬ 

ing Labels for Printing” earlier in this chapter. 

To set up the merge document for multiple-column labels: 

m Open the Database file you want to use for the mailing labels. 

m Activate the Word Processor merge document and design your malhn§ 
0 Tabel by choosing the font, type size, type style, and color you want from 

the Format menu. 
0 Choose Spacing from the Format menu, then choose 6 Lines per inc . 

m Set manual tab stops on the ruler that leave enough space on the left for 
D the label, the gap between the first and second label, and a small left ma 

gin for the second label. 
E if you have three-across labels, set another tab stop for the third label, as 

you did for the second label in step 4. 
g] Choose Prepare to Merge from the Edit menu and insert the placeholders 

for the first line of the first label. 
An appropriate first line would include placeholders for Title First Name, 
and Last Name. If you don’t remember how to insert placeholders, see 
“Creating a Merge Document,” earlier in this chapter. 

0 if field names are showing, choose Show Field Data from the Edit menu. 

Qj] Choose Multiple Labels from the Edit menu. 
0 Copy the first line, click at the end of the line, press the Tab key, and 

paste the line following the first tab stop. 
WnrifQ nastes the information from the next record. 

Copy these placeholders... 

Edit Window Search Format 

..and paste them here. 

Spell Macro 

Mailing Labels i LHP I 

. 1*. i i l i i ■ I2, i i l i i i [3i i i Ll 

If you have three-across labels, press the Tab key and paste again, 

ra Press the Return key and repeat steps 6 and 9 for the second line on the 
label, and again for each additional line. 

0 Select and copy all of the lines in your Word Processor document. 
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Q Place the insertion point at the end of the information and press the 
Return key until the insertion point is at the top of your next label. For 
one-inch-high labels, this will be the seventh line. 

Paste the information for the next set of labels. 

HD 
Copy and paste as many rows of labels as necessary to fill 
labels. one sheet of 

Printing Mailing Labels 

You use the same procedure for printing both continuous and multiple 
column labels. F 

0 Choose Print Merge from the File menu. 

Works displays the regular Print dialog box. 
0 Click the OK button. 

You may need to experiment with label alignment. Test your alignment with 
a few records first. Adjust the alignment of the labels in the printer and the 
margins in the Page Setup dialog box until you are satisfied. 

Be sure to remove page breaks from your document before printing If vou 
don t remove page breaks, Works will skip every other label when printing. 

To print the labels 
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Note In some cases, with continuous labels, you may notice a brief delay 
(no longer than two minutes) as Works sends print information to your disk 

and prepares to print your labels. 

If you are printing more than 128 labels, you will also find that Works leaves 
the 129th label blank, then continues to process the next 128 labels, bince 
Works processes and temporarily stores the information on 128 pages (labels) 
before printing, your Macintosh may run out of disk space during this pro¬ 
cess. If this happens, you’ll see an alert box. To free up disk space, you can 
move any unnecessary files from the disk, and then try printing again. 

A print merge prints all records in the selected Database document. Choosing 
specific page numbers in the Print Merge dialog box determines which pages 
are printed, but has no effect on the number of records printed. To pnnt a 
subset of records in a merge document, you must use the Record Selection or 
Match Records commands in the Database to select the records for merging. 
For information on record selection, see “How Selection Rules Work in 

Chapter 8. 

Other ideas You can use Print Merge to create other label-like documents. Here are a few 

suggestions: 

■ Print multiple-column lists, such as address lists. 

■ Address envelopes. 
■ Print continuous index cards to catalog your compact disk or tape 

collection. 

■ Print membership cards for a club. 

■ Print form letters. 

To set up a form 
letter 

Creating a Form Letter 

A form letter contains some standard text, but also adds information specific 
to each recipient. Names and addresses are the most common types of infor¬ 
mation you would want to merge into a form letter. But you can also create a 
Database document with specific phrases or sentences that apply to individual 

recipients. 
For example, if you sell bicycles to bike shops, you might want to thank 
each shop individually for its order, mentioning the amount the shop 

purchased. 
To set up a form letter, you create a merge document by typing all the text 
that will remain the same in each letter, and inserting placeholders for the 
information that will vary. If you need to review this procedure, follow the 
instructions in “Creating a Merge Document” earlier in this chapter. 
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If Show Field Names is chosen, your document looks like this: 

Marvin A. Carlson 

Regional Sales Manager 

September 18, 1989 

l£3,dresses:First Nampjfecidresses i ast NnmpJ 
[Addresses: Addressl 

|A0aresses:ClSl,|Addresses:Statfil(Adiiresspg7inl 

Dearl^-ddressesjmel[AddressesiLast Namcf 

Thank you for your continued support of Whppipr Rimrio r 

Nearly any office or business uses a variety of forms: 

■ Expense reports 

■ Address lists of customers, clients, friends, and contacts 
■ Invoices and statements 

II up once, and have Worts fill 1, J whenever yon «ed i“ y°“ 

Your entire form can come from your Word Processor Hnp„m„n, 

design a layout that prints information on a “ 

Creating Your Own Form 

To set up a form that yon can late, complete during a prim merge: 

°Pe" W Crea“ ,he Datatee that conutins you, information 

“ ?eMe a W»ri document and design your form 

STsMfnS SSS!?" — - draw 
the Format menu. ‘ h F d StyIe commands available from 

To set up a form 



392 Using the Tools Together 

0 when you are satisfied with your form, add placeholders and complete 

your merge document. 

If you need to review this procedure, see “Creating a Merge Document" ear- 

lier in this chapter. 
If Show Field Names is chosen, the document looks like this: 

* File Edit llJindoui seann - 
=n===========^^^ Statement Form (IBP) — —— -pr„ 

10=. ..,i-.i2iT i i i i i i°i i i i i i ! r. ■1 i '1110.11 i 111 11H 

Wte®1®r ifleycl® Company 
1076 Evergreen Street 

Youngstown, OH 66999 

Trv lArrt Rec-.Companu Name] 

|Arrt Rnc.Address] 

|Arrt RecCitul. |Ar.r.t Rec.StateJ lAcct Kec.ALMJ 

Invoice No. 
Description Payment 

|nrrlprc; lnV01Ce H Inrrifirs-.DescriDtionJ 
|nrrifirs:PaumenIi 

. sn-1 

Using Preprinted Forms 

If you decide to use preprinted 

i/this chapter. 

MofA TTsins oreorinted forms will take some experimentation to get precise 
NotG Using p P . w/nrH Processor using six-lines- 

^SnTh^SmTtirO"^ tW document is se't up, you can save 

it and use it over and over again to pnnt that form. 



Appendix A 
File Management 

This appendix lists the contents of the Works disks, provides system informa- 
tion for all users and provides file management information for users with 
two J.^-inch disk drives. 

Note To avoid loss or damage to your Works master disks, copy them to 
your hard disk or to 3.5-inch disks. After you make your working copies 
always use them for your work. Store your master disks in a safe place to 
protect them from loss or damage. For instructions on making working copies 
of your Works disks, see “Copying the Master Works Disks” in Appendix G 

Microsoft Works contains three double-sided disks: 

■ Microsoft Works Startup disk 

■ Microsoft Works Program disk 

■ Microsoft Works Tour disk 

(If you are upgrading from a previous 
disk is not included in your package.) 

version of Works, the Works Tour 

The Works Startup disk contains two folders: the System folder and the 
Works Dictionary folder. The Dictionary folder contains the following files: 

■ MsWorksDict 

■ MsWorksHymn 

The Works Program disk contains the following files and folders: 

■ Microsoft Works 

■ MsWorksHelp 

■ Tutorial folder, which contains sample files for Lessons 

■ Works Tools folder, which contains the Works-Works Transporter file 
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To use the Works 
tour 

What happens when 
you start Works? 

The Works Tour disk contains the file named A Works Tour. To use the 
tour, you must have Apple’s HyperCard. 

To use the Works HyperCard tour: 

H If you are running HyperCard from a hard disk, install HyperCard, copy 
the Works Tour to your hard disk, and double-click the Works Tour icon. 

or 

0 If you are running HyperCard from a 3.5-inch disk, insert the HyperCard 
Startup disk into one drive, and then turn on the computer. 

0 Choose the Open Stack command from the File menu. 

0 Insert a copy of the Works Tour disk in the other drive, and click the 

Open button. 

System Information 

When you start Works with the Startup disk in the internal disk drive, the 
Macintosh uses the System on this disk. When you start Works with a hard 
disk, the Macintosh uses the System on your hard disk. 

It is recommended that you use Works with a System version 6.0.2 or later. 
Hard disk users who don’t have this version on their hard disk should contact 
their authorized Apple dealer for information on updating. 

Important Do not copy the System folder on the Works Startup disk over 
the existing System folder on your hard disk. Doing so will delete additional 
desk accessories, fonts, and important files from the system on your hard 

disk. 

Works uses the fonts installed in your System file. You can install and 
remove fonts from the System file using the Font/DA Mover. 

Works’ preset font for the Database and Spreadsheet is Geneva Works’ 
preset font for the Word Processor is Boston, which is supplied in the System 
file on the Works Startup disk. Hard disk users who want to use the Boston 
font must copy it to their System using the Font/DA Mover. See the Macin¬ 
tosh owner’s guide for more information on copying fonts. 

To print a document on a Macintosh printer, you must have a printer driver 
in your System. The ImageWriter driver is included in the System folder on 
the Works Startup disk. If you have a hard disk, Works uses the printer 

driver on the hard disk. 

If you are using a LaserWriter, see Appendix C, “Printing with the Apple 

LaserWriter.” 



Appendix A File Management 395 

te^s^nfoimation^abou^you/preferences^ such as^th*6*11 ^ The flle con- 
you use the spell checker. You can’t onen ofnSr ^ "S y°U Choose when 
If the file is accidentally deleL^^te^et^ * MsWo“- 

mints raVcopy oftthe^rogramSdi^VAfter°U *"* !7 ^ your docu' 
may run out ofdisk 3 * °f ^ y°U 

' sswsjirit^ *- *» *» 
Save your documents on a separate, initialized disk. 

Managing files 

To save your documents on another disk: 

0 Choose Save As from the File menu. 

0 Insert a blank, initialized disk into the internal disk drive. 
1—1 Click the Save button. 

Worts saves on rhe disk whose Mme appeare ^ ^ ^ ^ 

™v° «£ £S*"»£" yo“r Works Pro8ram 

JoJZallrt Worts tok? for K i° ?{0,herkdisk’ whe" >»" choose the Hel 

from, and rte*„ S SyC fS ‘h!,! ““! Works *“ 
insert a disk containing*e Heb file f " iP,iS “ f°“n‘'- Works ffiks VO" 
drtve, if necessary, J ^ 'h' 

JZ See 80 °r deleK "* *** 'he ftogrcn, disk ,o 

To save on another 
disk 

any of the Spell commands, WoS search^ for fh m*?? ?n ■*°d Ch°°Se 
MsWorksHymn files first in the fold^Sf w V MsWorksDict and 
in the System folder. If the files are not fou^w T* St?rted fr°m’ 211(1 then 
MsWorksDict file and/or MsWorksHymn fife*’ 3SkS y°U t0 locate the 
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Using Works 
with Other Applications 

397 

M«inS^rr„ST^T,i0n drin8S ««ed with other 
applications. This appendix explains how^ “forn“llon froin Works » other 

" ££'SJS'° ““ ^ W°rd Pro“^. database, and 

T r TT W°"> Pt0CeSS°r “ Rich Text F°™ (RTF). 
a^EtS °CUme”,S CreaK files >">“ «• •« with otter 

’ wSs WOnl ProCeSS°r- Da“base' “d SPreadsl“« «« Horn Apple- 

■ Use SYLK files from Microsoft MnlUplan or Microsoft Excel 

"pplSio„TPb00k md CI‘Pb0"d "»>TC “ ”d Swings between 

f"'S *- nU'M™S W- — Works 

Word Processor Documents 

«**£St'2S£at Pm d““ »- a «e created in a»y 

■ Microsoft Word for the Apple Macintosh, version 1.0 

■ Mac Write, all versions through version 5 0 

■ ^Sxs.r:10' ?- rr 
spaces and carriage returns fText ST f document’ as well as the 
SYLK files are a type of textile ) somet™es called ASCII files. 

Importing non-Works 
files 



A - P 
(including Microsoft word processing and page 

p!l>“nnfc Macimosh and the IBM PC. Most applications on 

;TnAi. RTF format. 

To import a Word, MacWrite, text, or RTF file to the Works Word 

Processor: 

0 
0 
0 

Choose Open from the File menu. 

Click the Word Processor icon. 

Click Import File. 
Works lists all Word, MacWrite, 

and text files on the current disk. 

i j . cvt ic filps from the Word Processor. Note You should not open SYLK tiles irom me 
if vnu do onen one, iust close it and open another file instead. 

0 Click the name of the file you want to import as a Word Processor 

document. 
0 Click the Open button. 

Works opens a Word Processor window, called Untitled, containing the docu¬ 

ment you specified. 

Database Documents 
You can oeate a Worts Dalabase document from a text file created by other 

programs, such as Microsoft File. 
Works can import files to the Database created in any of three forma . 

■ St^a^ 
. “rlTn are separated by two or more 

spaces and records are separated by a return character. 

mat when converting database files to Macintosh text files.) 
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To import a text file to the Works Database: 

0 Choose Open from the File menu. 

0 Click the Database icon. 

0 Click Import File. 

Works lists all text files on the current disk. 

a C,“ 2 o™ 22.“'yo"wara to *—L 

A dialog box appears, asking you to specify the format of the file. 

Separate Database Fields By: 

® Tabs (Each Record Ended By B Return) 

O Two Or More Spaces (Treated fls R Tab) 

O Returns Field(s) Per Record 

[Cancel ) 

^ recorded" necessary1' type the number of fields per 

with each one^Ae^tio^As^ng^fv^d8 ™P°rted’ exPeriment 
the wrong format, this is perfectly safe y d°" 1 SaVe 3 document with 

0 Click the OK button. 

Works opens a Database window called TTntitUri * • • 
you specified. The fields will be named “Reid “ST” the.document 
can rename the fields with the Change Field w ’ F d 2’ and so on- You 
menu. The first record may consisZf ,hf r S**1*1 ,mm «* Edit 
you rename your fields, you may waul to Aft" 
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Spreadsheet Documents 

You can create a Works Spreadsheet document from a text file created in 

other applications. 
Works can import files created in either of two formats: 

. As a SYLK file created in Microsoft Multiplan or MicrosoftExceL 

which cells to place the labels. from other spreadsheet appli- 

SYLK Files to or from Works” in this 

. AsTtlxt file in which text or numeric information is separated by tab 

hiformatkin^from ^eid to^egii^^ ne^rov/11 

A STaracter indicates the beginning of the content of a new cell. 

Works. 

To import SYLK or other text files to the Works Spreadsheet: 

□ Choose Open from the File menu, 

d] Click the Spreadsheet icon. 

^ Works fists ail SYLK and other text files on the current disk. 

0 Click the name of the file yon want to import as a Spreadsheet document. 

HI Click the Open button. 
a a\*\no hnv annears asking 

♦✓A ot-warMfv the format of the text file. 
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SrosoS"" fi'e W"S CreaKd as a SYLK ™ Mnldplan 

“orS,r~aS if“ “ S “ f,fe «,h v*es. 

or 

0 Click the OK button. 

y!l^Sa Spreadsheet window, called Untitled, containing the document 

« read TP°rtin8 a f°™ula that Works 

by is n “■> ^«« 
a formula, make any necessary changes and delete dTqSon”^ “ “ 

exporting Documents to Files that can- 
be Used with Other Applications 

SSfP0" a"y WO'kS W°rd Pro“ss», Danrhase, or Spremlshee, 

trST and the^IBMPC °rd - P* 

can save a Spreadsheet document in the SYLK format or as a text file. °U 
To export a Works document: 

0 Choose Save As from the File menu. 

0 Click Export and type a name for the document into the text box 

ExS Tr“hTxfpoit” W“h RTF■ di<* *> 
0 Click the Save button. 

Exporting documents 



\x/ith 

Saue TeKt fls: 

(i) SVLK (to Multiplan or E«cel) 

OTent with Ualues Only 

OTeHt with Ualues/Formulas 

[ Cancel j 

Click the SYLK option if you want to use the document with Multiplan 

or Microsoft Excel. ... 
Click the Text with Values Only option to save the document as text with 

only the values in the cells. 
i Click the Text with Values/Formulas option to save the document as 

...or. Kr>th th<> values and the formulas. 

After clicking an option: 

© Click the OK button. 

Hint When saving a Word Processor 
automatically insert a carriage return at 
the Option key while choosing Save. 

document as text only, you can 
the end of each line by holding down 

but can’t be edited. 

Importing from 
AppleWorks 

Importing a File trom 
AppleWorks 
You import a file from AppleWorks to Microsoft Works using Apple File 
Exchange Apple File Exchange ships with all systems, versio • . j f 
If you don’t have Apple File Exchange, contact your authorized Apple dealer 

for a System update. 

on 5.25-inch disks, you must first copy them to 3.5-inch disks. 
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Ipp7nGSwiSl a 3S-tX a°525 ini ? ^ IIe’ Apple IIc> or ze z;s; r ^ To copy files from 
5.25-inch to 3.5-inch 
disks 

To convert 
AppleWorks files 

0 SE* Works-WOTks Me tao .fie Apple HI, Exchange 

0 Start Apple File Exchange on the Macintosh. 

3 drive1 ** ** C°ntaining y°UF APPleWorks files into the Macintosh 

S Select the Works-Works Transporter. 

0 In the list box, select the file(s) to be converted. 
HI Click the Transfer button. 

The Worics-Works Tranter convene ft, ffles Worb fmm 

Choose Quit from Ihe File menu lo quit Apple File Exchange. 

Conversion Specifics 

Because AppleWorks and Microsoft Works use different r,i* f 
evmylhmg „ converted exactly from one file fo “mlofcr ’ "°‘ 

Differences in Word Processor Fiioe x , • 

and footem are msefred in die Works Won, WsSEuSlt Sf" 

names^ao^rrewrdfo^anlfenc/t^'th'1'7 col,ver,ed 10 Reid 

sxfjss"*to fom -sses ;s:„s 
S2r “■v*« 



to or from Works 
i . . cYi k files created with either Microsoft Multiplan or 

<« «- 
all) in another program. 

Features of the Three Spreadsheet Programs 

External references; named.M»Spto°S m SfSW 

spreadsheets front Micro- 

soft Excel and Multiplan that contain named cells. 

Differences in Error Values 

Error values are different in Works and Microsoft Excel. 

Differences in Operators 

Works does not support the intersection (space), union (,), or concatenation 

^ opera-hat Microsoft Excel and Multiplan support. 

Differences in the Built-In Functions 

There are a number of differences in the functions supported by the three 

programs. 

Differences in the Arithmetic Results Produced 
by the Built-In Functions 
The functions built into Works should produce results nearly identica to 

those produced by Microsoft Excel. differences 

“£ef calculado^cIue^o^he^ffereiU internal representation and 

methods of performing arithmetic used by the two programs. 

or approximately 18 decimal digits. 



Differences in Implementation 

you use argument yaluLTtam a^uThk , or MulIiP'«" If 
Works gives the same J5S S MicS0ft £^2*,!^ " MulliP<“. 
also^lows some argument vatues that Miemsoftt^SiS'* 

Also, the IsError function in Works gives n if th„ 
Mtcrosoft Excel and „u„ip„„, IsEnL 

Differences in Logical Values 

The functions And, Or Not Tm^ c- ^ 
FALSE in Microsoft E^celidTRUE or 
1 or 0 in Works. *P n* These functl°ns give the values 

Built-In Functions Available for Use in Formulas 

Not all functions are available in all three programs c 
are optional in Microsoft Excel are rS h^’, Some arSuments that 

function. The following table identifies thns f ^S’ Suuc^ as *n (he Index 
one or two of the “ T*? “ 
tion is available for that program. A X 3118 that the func' 

Function 

ACOS 

AREAS 

ASIN 

ATAN2 

CHOOSE 

COLUMN 

COLUMNS 

DATE 

DAY 

DEGREES 

DELTA 

DOLLAR 

ERROR 

FIXED 

GROWTH 

HLOOKUP* 

HOUR 

X 

X 
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INDEX (Form 2) 

ISBLANK 

ISREF 

ITERCNT 

LEN 
LINEST 
LOGEST 

LOOKUP (Form 2) 

MATCH* 

MID 
MINUTE 

MONTH 

NOW 
RADIANS 

RAND 
REPT 

ROW 

ROWS 
SEARCH 

SECOND 

SSUM 

TEXT 

TIME 
TRANSPOSE** 

TREND 

TYPE 
VALUE 

VAR 
VLOOKUP 
WEEKDAY 

YEAR 

X 
X 

X 

X 

X 

X 

X 
X 

X 

X 

X 
X 

X 

X 

X 

X 

X 

X 

*The Works implementation that Micro- 

foft“gives3 wX^oVows some inputs that Microsoft Excel does not allow. 

**In Works, the TRANSPOSE operation is available as an option in the Paste with Options 

command. 
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Using the scrapbook and Clipboard 

another; if y0Pu oneapplication to 

application. "lessor or Spreadsheet document to another 

To move text and drawings into the Scrapbook: 

0 Select the text or drawing. 

0 SiZ,?' " C0py from "* m' •» move -he selection the 

0 Choose Scrapbook from the Apple menu. 

0 Choose Paste from the Edit menu. 

Repeat this predate for each it<an y0„ ^ ^ 

Worts W„S^^“KZlea,‘lra,W”d0br *“ *• 
pasted into the Scrapbook If the anniiA ,°th the text and the drawing are 
PICT resources ^ “? P3Sting into can read 
you can paste your text. The ability^ accemPICT1?8' ^ * Ca" rCad tCXt’ 
the mechanics for pasting different tvn^f1* r T resources and text, and 
each appi,cation. E^r 

copy the Scrapbook1fik toThTs^stem folder SSlT USi"8 and 
of the destination application. Then’ C 1S^ ^as ^our coPy 

0 Start the application. 

0 Choose Scrapbook from the Apple menu 

’ inf0n“i0n in Uk Scnl*°<* until you find dte item you wan, 

0 Select the item. 

B cSZt?' °r C°Py f,0m “* “ » n»ve the selection onto the 

0 Close the Scrapbook. 

0 Select an insertion point and choose Paste from the Edit menu 

Repeat this procedure for each item you want to move from the Scrapbook. 

sSapboSeTo^hf^Im^dkka0" ^ ^ ScraPbook’ ™ke sure the 
application. ® dlSk 88 your C0Py of *e destination 

mapped objects created in other program?. b y°U C3n t un8rouP bit- 

To move items into 
the Scrapbook 

To move items from 
the Scrapbook 



If you regularly use Works with other 

Microsoft Excel, or Mac^Vy°“ the background while you’re using another 
MultiFinder lets you run Works in t g onto a computer 

application at the file'yon don’t have to 
service and want to capture g the fiie. You can start capturing 

BSS 3a*£CTS5SL, - L Macintosh Mn„i- 

Finder user’s guide. 



Appendix C 
Printing with the Apple 
LaserWriter 

You can pnnt all of your Works documents on the Apple LaserWriter printer. 

For^fn?^ the LaserWri,ter’ y°u must install the LaserWriter printer driver 
For instructions, see your LaserWriter manual. 

thC LaSelfri!er software’ choose the Chooser desk accessory 
om the Apple menu. The Macintosh displays a dialog box containing icons 

STn 8 Pnrter driVefS °n the disk‘ Select the LaserWriter icon and 
S thedoSbox ^ Want thC Madnt°sh *° member who you are. Then 

LaserWriter Options 

2KT- *ef LaserWriter, the Page Setup and Print dialog boxes are 

the8PaLdSpf,Ti f?mKh°SlShOWn earl'er in this manua1' The differences in 
the Page Setup dialog box that are important to Works are explained below 

SempZd S"p0“o„r"“' f0r “ C0mple,e »f LaserWriter Page 

page seu,p from ,he R,e—■ 



Reduce or Enlarge When printing with the ImageWriter, you have a 
choice of printing full size or at a 50% reduction. 

With the LaserWriter, you can enter any percentage of reduction. If you print 
Helvetica 12 at 90% reduction, for example, the printed document will 
appear in Helvetica 10. If you use 80% reduction, the printed document will 

appear in Helvetica 9. 
Use the Reduce or Enlarge option to increase the amount of information you 
can print on a page. If you use the Reduce or Enlarge option for a Database 
document, Works adjusts the right edge marker in the report window. In the 
Word Processor and the Spreadsheet, Works also adjusts the page break 

indicators. 
Font Substitution This is a preset option that tells the LaserWriter to sub¬ 
stitute its built-in fonts for whatever font is displayed on the screen. How¬ 
ever not all fonts have a substitute. Generally, it is best to use only fonts 
that are recommended for the LaserWriter, such as Times, Helvetica, or 

Courier. 
Smoothing The smoothing option is preset. For faster pnnting, the 
smoothing option should be turned off, unless you have pasted a picture from 

MacPaint into the Word Processor. 

Note There is no custom page size option in the LaserWriter Page Setup 

dialog box. 

Printing Multiple-Column Mailing Labels 

You can create, set up, and print a merge document for multiple-column ^ 
mailing labels on the LaserWriter, as explained in “Creating Mailing Labels 
in Chapter 21. However, when you are preparing the labels for printing, you 
choose different options in the Page Setup dialog box from those used with 

the ImageWriter. 

Follow these steps to print labels: 

■ Prepare the labels for printing using the procedure below. 

■ Set up the merge document by following the procedure in To Set Up the 
Merge Document for Multiple-Column Labels in Chapter 21. 

■ Print the mailing labels by following the procedure in “Printing Mailing 

Labels” in Chapter 21. 
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To Prepare Labels for Printing 

0 Create a Word Processor document. 

0 Choose Page Setup from the File menu. 

0 Click the US Letter option. 

0 atTihncheft and right margiDS at 5 inch and the toP and bottom margins 

SCttlngS may vary ^Pending on the size of your labels You mav 
need «, expenmen, «, f,„d He settings tha, work for ™ 

111 Click the OK button. 





Appendix D 
Choosing Commands 
from the Keyboard 

Many menu commands in Works can also be invoked from the keyboard. 

Ji™°SlhTmandS from the teyboaM, hold down the Command key 
IS t duP ?e2etter corTesPonding to the particular command For exanf 

fhe S key h°“ ^‘he Command ^ and “ 

n°UcSlM.a»° commands from the keyboard, hold down the Option key and 
press the letter corresponding to the particular command. P Y 

To use special commands in Communications, hold down the Command and 

2SSS5ST-''wMe you pre“ —“r 
The following tables list the keyboard commands for all of the Works tools. 

Key 

Option + = 

Option + - (hyphen) 

Option + Delete 

Command+ . (period) 

Macro Key Equivalents 

__Result 

Start Recording 

Stop Recording 

Playback Macro 

Stop Macro in progress 

Key 
Communications Key Equivalents 

Result 

Command + Option+3 

Command + Option + Delete 

Command + Option + [ 

Break 

Delete 

Escape 
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Key WP 

Works Command + Key Equivalents 

SS DB COM DRAW 

B 

C 

D 

F 

G 

I 

J 

K 

L 

M 

N 

O 

P 

Q 

R 

S 

T 

U 

V 

w 
X 

Y 

z 

Sort 

Bold 

Copy 

Find 

Go To Page # 

Italics 

Draw On/Off 

Copy Format 

Prepare to Merge 

Normal Text 

Open 

Print 

Quit 

Replace 

Save 

Underline 

Paste 

Close 

Cut 

Paste Format 

Undo 

Absolute Cell 
Ref/ Relative 
Cell Ref 

Bold 

Activate last 
document in 
Window menu 

Help 

Copy 

Enter Date 

Find Field 

Insert Record 

Show List/Form 

Match Records 

Open 

Print 

Quit 

Save 

Enter Time 

Paste 

Close 

Cut 

Undo 

Duplicate field in 
previous record 

Activate last 
document in 
Window menu 

Help 

Send to Back 

Copy Copy Copy 

Fill Down Dial 

Find Cell Bring to Front 

Go To Cell Group Picture 

Insert 

Draw On/Off Draw Off 

Normal Text 

Open Open Open 

Print Print Print 

Quit Quit Quit 

Fill Right 

Save Save Save 

Underline Ungroup Picture 

Paste Paste Paste 

Close Close Close 

Cut Cut Cut 

Undo Undo 

Calculate Now Hang Up 

Activate last 
document in 
Window menu 

Help 

Hang Up 

Activate last 
document in 

Activate last 
document in 

Window menu Window menu 

Help Help 
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of the Tools 
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wffr!118 ta,bleS describe data imitations for the Database and 

Spreadsheet. mem0iy f°r the Word Database, and 

Data Limitations for the Database and Spreadsheet 

sJreaS?etbeThlSfh°W ^ limitations for the Database and the 

app y t0 the Macintosh Plus>the Maci"tosb SE, 

Database 

Fields in a record 

Characters in a field 

Characters in a field name 

Spreadsheet 

Characters in the entry bar 

Characters in a formula 

Columns in a spreadsheet 

Rows in a spreadsheet 

Number of data points in a series chart 
(except bar charts) 

Number of rows in a pie chart 

Limits 

60 

250 

64 

238 

200 

256 

16,382 

80 

15 



Memory Capacities for the Word Processor, 
Database, and Spreadsheet 

The table below shows the approximate memory capacities for the Word Pro¬ 

cessor, Database, and Spreadsheet. 

Macintosh 

Plus* * 

Word Processor 

Pages in a document 
(text with formatting) 

180-240 

Database 

Records in a database 

(at 100 characters 

per record) 

Spreadsheet 

Number of filled cells 

6,000 

22,500 

Draw 

Amount of text in linked columns 

* Memory capacities for the Macintosh SE and II without additional RAM match those of the 

Macintosh Plus. Capacities increase proportionally wich additional RA 

Word Processor capacities are affected by graphics, and by tex. containing 

many font changes. 

Database capacities are affected by the average number of characters per 

record. 
Spreadsheet capacities are affected by graphics by the average length 

of formulas, and by the amount of text in labels. 

A/nfe If vou are using MultiFinder, memory capacity varies based on the 

guide. 
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Us*n9 Works with AppleShare 
and Other Networks 
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SsSSSr--- 
?i£‘SSL-'=ssir 

To copy Works to a server: 

0 Create a new folder on your server and title it Works Program. 
LLl Follow the instructions in “Getting StarfeH” in t 

Ihe Works program and olher filet roTfolto manUa' “ 

Setting up Works on 
a server 

Copying Works to a 
server 
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Opening Works 
documents on a 
network 

tant to know how Works responds. 

The first nerson to open any Works document from a server has Read/Wnte 
privileges^ If you are the first person to open a document from the server, 
you can make changes to the document and save it back on the server disk 

using the same name. 
if vmi onen a Works document after someone else has opened it, you have 
ReadoSy1]privileges. You can see the document and make changes;• How- 

ever if you wish to save your changes, you need to save the fi e on 
SSrEng a different name. To do this, use the Save As command 

from the File menu and type in a different filename. 

U nv OtYinl P * 

HI Open the document you want to copy. 

HI Choose Save As from the File menu. 

[5] Type a new name for the document in the dialog box. The name must be 

different from the name of the network document. 

0 Click the Save button. 

If vou are not the first person to open a particular document from the network 

sewr, Works tells you that you have opened the document with Read O y 

privileges. 

Using Works with a 
file server 

. fr,iinwing table shows where Works files are created when the Works 

Jlder and thf local System folder are on the same volume and when they are 

« riifffwnt volumes (as with AppleShare). 

Filename On same volume 

MicrosoftWorks(keys) Works folder 

Works Desktop Works folder 

MsWorksPref System folder 

On different volumes 

System folder 

Main level of volume con¬ 

taining System 

System folder 

Quitting Works Quitting Works 

When you quit Works while on 
automatically saved in the same 

the network, the Works Desktop document is 

folder from which you started Works. 



Appendix G 
New Features in Works 2.0 

This appendix is intended for previous users of Wnrtc it a -u 

changes you’ll find in Microsoft Wortsve ion loandlw^scnbes^ 
look the Works manuals to find fimher !Z^2o” ’ y°U Where ,0 

S K SonllisTpSx ffto' te “'5 IO lhe “Ne» F« 
should also read “Changes Since Works 1 a” Upda,ln8 fronl veni,on 10. you 

and menus' s°™ w°*s 

SFSsatssrSSSSir 

Startup information for Works 2.0 is described below 

wrnZ SS* Wodcs "OW loqurm, , Macintosh Plus. SE. or n, 

users with System versions earlier than 6 la3 hanJ dlsk' Hard dislt 
Apple deale/for ** 

sss sy^rffl sr sxjs? nthe w°rts s,anup “ 
disk. acces^)n^s’ ^on(s snd^mportan^l^’from’th^System orfyour hard*113* 

Startup information 



Personalizing Your Master Disk Before you begin using Works, you 
Ed personalize your master Works Program disk. 

To personalize your disk: 

□ If you have a hard disk, start up your computer and insert the Program 
disk into the internal disk drive. 
If you have 3.5-inch disk drives, start your computer m^rt the 
Works Startup disk into one disk drive, and then insert the Works 
gram disk into the other disk drive. 

0 Double-click the Program disk and Works icons to open Works. 
0 Type your name and your organization’s name in the dialog box. 

0 Click the OK button, or press the Return key. 
0 Choose Quit from the File menu to return to the Finder. 

Now make copies of your master disks for safekeeping. 

_ • Uaetar Works Disks Before using Microsoft Works you 
SKSE*. S A of each of .he mas*, disks to prevent accidenra, 
We r»r Hamaee to the master disks. 

Imnortant You may copy your Microsoft program for personal use only. It 
fSrLIw to cyopyPyour Microsoft program on magnetic tape disk or 

medium for purpose odrer than your personal use. See your 
disk packet for the complete license agreement. 

You’ll copy Works in one of two ways, depending on your hardware. 

■ If you have a hard disk, you’ll want to copy all of the ^s fromdw 
Works Proeram disk, and the Works Dictionary folder from the Works 
Startup ^isk^^stdouble-click the disk icon, select the Works rcons, and 
Arcka thp.m over 

Imoortant Do not copy the System folder on the Works Startup disk 
over the existing System folder on your hard disk. Doing so will de e 
additional Des^Accessories, fonts, and important files from the System 
on your hard disk. 

if von don't already have the Boston font in your System file, use the 
Font/DA Mover u/move it from the System file on the Works Startup 2f tofoeSystem file on your hard disk. See your Macintosh owner s 
guide for information on copying fonts. 
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H t K ; Ch dlSk dnves’ c°py the Wofks Startup and Works Pro 
E 'f by each Works master disk icon over the icon of a 
blank disk you’ve initialized as double-sided. 

Opening Files Created in a Previous Version of Works in the 

Works' unless ^he fikhat f‘1 h° °Pen 3 1 flle created in a Previous version of 

earlier versions of Microsoft*Work” from the dfsl^Th^mm off rCm°Ve 

lt wehr,he c°T'f.fwhi,e eys When you are asked if you want to rebuild the desktop click OK 

iron !r’ Start Wprks 2'0, open’ 311(1 save y°ur old documents ’ (If the Works 

rve'Kr,"01” a ,he s“ W°"“ 2 » ^ 

The new Works features for each tool are described below. 

Common Tasks 

Close All The Close All command closes all open documents and removes 
them from your screen. See “Close All” in Chapter 2. removes 

Stationery The Stationery option in the Save As dialog box lets vou save 

a group of options such as font, type style, color, and alignment and aoolv 
them to other documents. See “Save As” in Chapter 2 PP Y 

W°rkS D®Skt°P The Make Works Desktop command allows you to 
save an existing desktop without quitting Works, and to save multiple ver 

sions of the desktop. See “Make Works Desktop” in Chapter 2. P 

Print Preview The Print Preview option in the Print dialog box lets vou 
see each page of your document before you print. See “Print” in Chapter 2. 

New features in 
Works 



nrawina The Draw feature has many new shapes and commands. You can 
MT-sheet as well as in the Word Processor, and you 

can create linked columns of text. When you choose the Draw On comrnan , 
Works displays the Tools palette for drawing shapes and patterns. See 

Edit Menu” in Chapter 2. 
Fonts You can now change fonts in the Database and the Spreadsheet as 
well as in the Word Processor. An enhanced Format menu prwides add - 
r 1 f„„, c;Vp ennnort that includes color options. The Font, style, size, 
andColor commands fn the Format menu lead You. mother" containing 
these formatting choices. See “The Format Menu in Chapter 2. 

Macros Works’ Macro feature lets you record a series of ^use or key¬ 
board commands, save them, and play them back automatically. See The 

Macro Menu” in Chapter 2. 
Full Window/Small Window Commands The Window menu no longer 
contains the Full Window and Small Window commands. You 11 enlarge and 
reduce window size using the zoom box in the upper-nght comer of the tit 
It See^your Macintoshowner’s guide for more information on the zoom 

box. 

The Word Processor 

Decimal and Center Tabs The Word Processor now has four types of 
tabs- left right, center, and decimal. Click under the ruler to set tabs once 
for left twice for right, three times for decimal, and four tunes for center 
tabs. Repeatedly click an existing tab to cycle through the tab types. See 

“Show Ruler/Hide Ruler” in Chapter 5. 

Multiple Record Support The Multiple Labels command in the Word 
Processor’s Edit menu lets you print a series of Database records side by 
side Side-by-side records are useful for columns or multiple-column labels. 
te'MuWpl Labels” in Chapter 5, and “Creating Matltng Labels m 

Chapter 21. 
Search for Tabs and Return Characters You can search and replace 
ta^and reujrn characters using buttons in die Find and Replace dtalog boxes. 

See “The Search Menu” in Chapter 5. 
SDacina The new Spacing command in the Format menu includes options 
foSe one and oni-half double, and six-lines-per-inch spacing. The six- 
lines-per-inch setting is used in combination wAJeod^settings mi 
especially useful when working with pre-pnnted forms. See Spacing 

Chapter 5. 
Spelling Checker Works includes a built-in spellerthatchecks yourspe - 
ine suggests corrections, and replaces misspelled words. Its 60,000 w 
dictionary can be personalized by adding words that you commonly use in 
your documents. See “The Spell Menu” in Chapter 5. 

RTF Files You can import and export files saved with Microsoft Rich Text 
Format (RTF). RTF retains all formatting in a form used by many^word p 
cessing and page layout programs on the Macintosh and the IBM 

“Open” and “Save As” in Chapter 2. 
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The Database 

^Hk3~ss3S3®l 
you can t use any functions that take ranges as arguments See Chanter15 
Spreadsheet and Database Functions.” Adapter 15, 

Changing the Report Window The report window now has scroll bars 

size You°™ ^ 3 ShZC b°\f0r SCrolling and hanging the report window’s ’ 

m3 C°mmanu Nj?mes To make the Database easier to use the com 
mand names in the TotalsPage menu have changed as follows: 

From 

Total-1st Char Field 

Total on Field Change 

To 

Take a Sub-Total on 1st Char 

Take a Sub-Total on Field Change 

The order of commands in the TotalsPage menu has also changed. 

The Spreadsheet 

You can now use up to 16,382 rows in a Maximum Number of Rows 
Spreadsheet document. 

Select All Command The Select All command now appears in the Edit 
menu in the Spreadsheet as well as in the Word Processor and Database In 

All” rChapteer2SeleCt AH SdeCtS ^ Ce"S’ induding blank cells' See “Select 

Funct'ons The Spreadsheet includes Date and Time functions. See 
Chapter 15, Spreadsheet and Database Functions.” 

r N«— 
cS!tHC®,,.fttr'bUteS Command The Set Cell Attributes command con- 

hdates these commands in one dialog box: General, Fixed Dollar Percent 

Ch'v“l6 ’ ' Ali8nm""’ *nd S,y"' See “SeI CelfAnnbmes T 

Cell Bordering Worics 2.0 lets you outline a cell or range of cells to call 
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Freezina Titles You can freeze selected rows or columns horizontally or 
SE^Zurey won', scroll. Thisis for tap.* h^g. c» Ihe 

screen as yoo scroll through your Spreadsheet 
commands are included in the Options menu. See Freeze Titles 

Titles Vertical” in Chapter 16. 

Changes since 
Works 1.0 

Changes since Works 1.0 

If you’re upgrading from version 1.0, you’ll also find the following changes 

in Works 2.0: 
Number Of Open Windows You can have a maximum of 14 windows 

open at one time. 
Print Window Each sheet of paper is automatically ejected from an Image- 
Writer printer when you use the Print Window command. 

Mailing Labels Works offers an improved way to print mmhng labels with 
anlmageWriter printer. See “Printing Customized Documents in Chapter 21. 

Indent Markers The left indent and first line indent ruler markers in the 
Word Processor are now easier to adjust, making it easier to crea e e 
indents you want—especially hanging indents. See Indenting Text in 

Chapter 4. 
Page Breaks In the Word Processor, Works displays manually inserted 
page breaks differently from automatic page breaks. A manually mserted 
page break appears as a dashed line. An automatic page break appears as 
dotted line. See “Page Breaks” in Chapter 4. 

Capture Text When Document Opens The Communications Settings 
dialog box now contains this option. When chosen. Works will always ask 
you to name the file in which you are saving captured text as soon as you 
begin a new Communications session. See Settings in Chapter 19. 

Number of Screens Works now lets you scroll up to review previous 
screens from your current Communications session. This allows you to 
3 tS information, log off. and then review thetin otmatton wtton. 
the expense of spending additional time connected to a host computer. See 

“Settings” in Chapter 19. 
VT52 and VT100 Terminals You can use Works to emulate VT52 and 
VT100 terminals. See Chapter 18, “Sending and Receiving Information, 
and Appendix H, “VT52 and VT100 Escape Codes.” 

Networks Works can be used with AppleShare and other networks. See 
Appendix F, “Using Works with AppleShare and Other Networks. 



Appendix H 
VT52 and VT100 Escape Codes 

These codes are not displayed on the screen. Instead, they a?e inteXed a, 

!ng E°oS„ SP“lal S“h “ m0vin8 ““ ~ <* dele.- 

The following table lists the escape codes received from the host comouter 
when your computer is emulating a VT52 or VT100 terminal. P 

Group Sequence Function 

Cursor 
Cursor 
Cursor 
Edit 
Edit 
Mode 
Mode 
Mode 
Report 
Report 
Report 
Report 
Reset 
Reset 
Reset 
Tab 
Tab 
Tab 
Tab 
Tab 
Tab 
Edit 
Edit 
Edit 
Erase 

ESC [ Pn Z 
ESC [ Pn I 
TAB 
ESC [ Pn M 
ESC [ Pn L 
ESC [ > 5 I 
ESC [ ? 1 h 
ESC [ ? 1 | 
ESC [ 0 c 
ESC [ 6 n 
ESC [ 5 n 
ESC Z 
ESC c 
ESC [ Ps z 
ESC [! p 
ESC [ 3 g 
ESC [ 5 W 
ESC [ 0 g 
ESC [ 2 W 
ESC H 
ESC [ 0 W 
ESC [ Pn P 
ESC [ Pn X 
ESC [ Pn @ 
ESC [ 2 J 

Cursor backwards by tab 
Cursor horizontal tabulation 
Move to next tab stop 
Delete line 
Insert line 
Reset Modes — cursor on 
Set cursor key application mode 
Set cursor key normal mode 
Device reports — response ESC [ ? 1 2c 
Request cursor position report 
Request device status reports — ESC [ 0 
VT100 Who are you —response is ESC 
Reset to power-up state 
Reset to power-up state 
Soft terminal reset 
Clear all tab stops 
Clear all tabs 
Clear tab at current position 
Clear tab at current position 
Set tab 
Set tab at current position 
Delete char 
Erase char 
Insert chars 
Erase entire display (shift erase); position cursor 
in home position 

n 
[?i;2c 



Group Sequence Function 

Erase ESC [ 2 K 
Erase ESC [ 1 J 

Erase ESC[ 1 K 

Erase ESC [ 0 J 
Erase ESC [ 0 K 

Erase ESC [ ? 2 J 

Erase ESC [ ? 2 K 

Erase ESC [ ? 0 K 

Erase ESC [ ? 1 J 

Erase ESC [ ? 1 K 

Erase ESC [ ? 0 J 
Mode ESC [ 4 1 
Mode ESC [ 4 h 
Cursor LF 
Cursor ESC [ PI;Pc f 
Cursor ESC [ Pn B 
Cursor ESC [ Pn G 
Cursor ESC [ Pn D 
Cursor ESC [ Pn E 
Cursor ESC [ PI;Pc H 
Cursor ESC [ Pn F 
Cursor ESC [ Pn C 
Cursor ESC [ Pn A 
Cursor ESC D 

Cursor BS 
Cursor CR 
Cursor ESC E 
Cursor ESC [ u 
Cursor ESC 8 
Cursor ESC M 

Cursor ESC [ s 
Cursor ESC 7 
Mode ESC = 

Erase entire line, incl. cursor position 
Erase from start of display to cursor, incl. 
cursor 
Erase from start of line, incl. cursor 
position 
Erase to end of page (erase key) 
Erase from cursor to end of line, incl. cur¬ 
sor position 
Selective erase entire display (shift erase), 
position cursor in home position 
Selective erase entire line, incl. cursor 
position 
Selective erase from cursor to end of line, 
incl. cursor position 
Selective erase from start of display to 
cursor, incl. cursor 
Selective erase from start of line, incl. cur¬ 
sor position 
Selective erase to end of page (erase key) 
Disable insert char mode 
Enable insert char mode 
Advance cursor down to next line 
Cursor addressing 
Cursor down — constrain 
Cursor horizontal absolute 
Cursor left —constrain 
Cursor next line 
Direct cursor positioning 
Cursor preceding line 
Cursor right —constrain 
Cursor up — constrain 
Index— moves cursor down, functions in 
same manner as LF 
Move back one char and erase 
Move to beginning of line 
NewLine function (CR — LF) 
Restore cursor 
Restore cursor position and attributes 
Reverse Index — moves cursor to the 
same position on preceding line will not 
move if at top 
Save cursor 
Save cursor position and attributes 
Alternate keypad mode 
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Group Sequence Function 

Mode ESC [ ? 20 1 
Mode ESC [ ? 7 I 
Mode ESC [ ? 25 h 
Mode ESC > 
Mode ESC [ ? 20 h 
Mode ESC [ ? 7 h 
Mode ESC [ ? 25 1 
Mode ESC [ 20 1 
Mode ESC [ > 1 I 
Mode ESC [ > 7 1 
Mode ESC [ > 9 1 
Mode ESC [ > 8 1 
Mode ESC [ 20 h 
Mode ESC [ > 7 h 
Mode ESC [ > 9 h 
Mode ESC [ > 8 h 
Mode ESC [ > 5 h 
Mode ESC [ > 1 h 
Erase FF 

BELL 

Disable auto LF on CR 
Disable auto wrap mode 
Disable cursor 
Disable keypad alternate mode 
Enable auto LF on CR 
Enable auto wrap mode 
Enable cursor 
Reset CR on LF 
Reset Modes —disable 25th line 
Reset Modes —exit alternate keypad mode 
Reset Modes — no auto CR on LF 
Reset Modes—no auto LF on CR 
Set CR on LF 
Set Modes —alternate keypad mode 
Set Modes — auto CR on LF 
Set Modes —auto LF on CR 
Set Modes — cursor off 
Set Modes — enable 25th line 
Form feed (clear screen) 
Sound Bell 





Index 

& formatting commands, footer/header 56 
+ + + message 341 

12-hour/24-hour time format 146, 215, 280, 318 
3.5-inch disk drive 395, 403, 419 

A Works Tour file 394 
Abbreviations, adding to dictionary 125 
About MS-Works command 46 
Abs function 281, 285 
Absolute Cell Ref command 

Command + A equivalent 414 
mixed reference reversing 222 
reference changing 219, 221, 311 

Absolute reference 
changing to relative reference 221 311 
copying 234, 239 
defined 219 
sorting, adjustment 242 
symbol 219-221, 311 

Absolute value function 281, 285 
Accent 83 
ACos function 

defined 282, 285 

Multiplan/Excel/Works differences 405 
Acoustic coupler 336, 340 
Activate Window command 69, 414 
Active cell 

defined 209 
display 315 
finding 231, 234 
moving within cell range 212 

Active entry 142-143 
Active window printing 10, 12, 59, 254 
Add New Field command 136, 189 
Adding words to dictionary 124-125 
Adding words to homonym file 127 
Addition operator (+) 

arithmetic operator 196, 222 
inserting automatically 217, 219, 222, 311 

Addition operator (+) (continued) 
performance order 223 

Address list 
See also Form 
sorting 162 

Alert box 
cell matching 233 
circular reference 224 
column sorting 243 
Database text, copying over 372 
document changes 48, 60 
field name nonexistent 112, 148 
file not found 13, 54 
function syntax error 276 
label printing 390 
margin setting conflict 57 
memory insufficiency 365 
record matching 168 
record selection rule, unmatched 192 
searching 115, 117 

Alignment 
See also Justification 
cells 247, 318 
center See Centering 
Database entry 197 
Draw objects See Drawing 
labels 247, 389 
left See Left alignment 
numbers 247 
preprinted forms 392 
right See Right alignment 
text See Justification 
text object See Drawing 

All Cells command 211, 314 

Alphabetical sorting, Database fields 161-163 
Alphanumeric character searching 115, 116 
Ampersand (&) printing 56 
And connector 169-170, 192 
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And function 
Database use 147, 275 
defined 283, 285 
Multiplan/Excel/Works differences 405 

Angle conversion 289, 301 
Answer Phone command 341, 354 
Apple File Exchange 402-403 
Apple HyperCard 394 
Apple LaserWriter printer See LaserWriter printer 

Apple menu commands 46 
AppleShare network 417, 424 
AppleWorks 398, 402-403 
Arccosine See ACos function 
Arcsine See ASin function 
Arctangent See ATan function; ATan2 function 

Areas function 405 
Argument See Function 
Arithmetic operator 222-223 
Arithmetic results, Excel/Works differences 404 

Arrow See Drawing 
Arrow keys 

moving in Spreadsheet document 212 
selecting Database field 140, 142 

Arrow pointer 84, 149-152 

ASCII file 
See also Text file 
defined 397 

ASin function 
defined 282, 286 
Multiplan/Excel/Works differences 405 

Asterisk (*), multiplication operator symbol 190, zzz 

ATan function 282, 286 
ATan2 function 282, 286 
Auto-wrap 359 
Automatic Calculation command 227, 3Z3 

Average function 
Database use 147, 275, 278 
defined 282, 286 

Background, running Works with MultiFinder 4 
Backspace key, used as Delete key xix 

Bar chart . , , 
See also Combination chart; Stack chart 
creating See Series chart 
defined 257 
labels See Column label; Row label 
use suggestions 258, 326 

Baud rate 336, 359 
Binary digits (bits) 336, 359 

Black and white monitor 14, 64 
Black command 71 
Blank cell See Cell 
Blank line 

deleting 87 
inserting 82 

Blue command 71 
Bold command 64, 96, 119, 248, 414 
Bold Field Data command 144, 194 
Bold Field Name command 144, 194 

Bold style 
Command + B equivalent 248, 414 

entries 144, 198 
field data 144, 194, 198 
field name 144, 194 
footers and headers 56 
setting 

Database document 198 
Draw text object 28, 64 
Spreadsheet document 248, 319, 414 
Word Processor document 96, 119, 414 

Border 
active entry 142 
cells 249, 319, 423 
field name, field data 144, 195 

Border Field Data command 144, 195 
Border Field Name command 144, 195 
Borders command 249, 319 
Bottom command 249, 319 a 
Break key, Command + Option + 3 equivalent 342, 

413 
Bring to Front command 27 , 66, 414 
Bulletin board access 345 
Business forms See Form 

r_lov Af, 

Cable connection 336 
Calculate Now command 227, 323, 414 

Calculation 
See also Spreadsheet formula 
automatic 217, 222, 227, 323 
Excel/Works differences 404 
manual 227, 323 

Canceling 
chart 

pie chart 269, 328 
series chart 267, 325 

Correct Spelling command 125 
entry bar typing 212 
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Canceling (continued) 

macro recording 38, 74 
printing 12, 58 

Quit command 60 

record selection rule 170, 192 
searching 115, 117 

Capitalization 

after period option 125 

proper noun option 126 

searching option 91, 93, 115-116 

Capture Text command 348-349, 354 

Capture Text When Document Opens option 348, 
361, 424 

Caret (), exponentiation operator 196, 222-225 
Carrier, Communications 341 

Cash flow functions See Investment 
Cell 

active cell See Active cell 
addition 217, 222 

alignment 247, 318 

annotation See Cell note 
attribute 

removing 62 

setting 246, 316-319, 423 

blank See herein empty cell 
bold style 248, 319 

border 249, 319, 423 

constant value See Constant value 
contents, editing 212, 226 

copying 234-236, 238, 308, 311 
date format 280, 317-318 
defined 208 

dollar, cents format 246, 317 
editing 212, 226 

empty cell 

argument value 278 
label overflow 213 
sorting 241 

entering information 

date/time 215 

formula 216-217 
label 213-214 

methods 208, 211-212, 214, 414 
number 214-215 

filling 238, 311 
finding 

selecting See herein selecting 

without selecting 232-233, 315, 414 
fixed format, decimal 316 
format, defined 245 

Cell (continued) 

formatting 245-249, 316-319 

formula See Spreadsheet formula 
label See Cell label 

last cell 210, 234, 314 

moving 239-241, 309 

note See Cell note 

number entry 211, 214-215 
outlining 249, 319 

pasting 62, 234-237, 308 

percentage format 246, 317 
protection 250-251, 322 
range See Cell range 

reference See Reference 
scientific notation 246, 317 
selecting 

active cell 315 

All Cells command method 211 314 
defined 210-211 

Find Cell command method 232-233, 314, 414 
Last Cell command method 210, 234, 314 
range 211 

style options 248, 319 

time format 280, 317-318 

underlining style 248, 319 
value See Value 

Cell label 

See also Column heading; Row heading 
alignment 247, 318 

column label 263, 265, 326 
defined 213 

entering 213-214 
length 213, 250 

row label 263, 265, 326 
Cell note 

creating 224, 312 

indicator mark 312, 321 
new feature 423 

printing 56, 254, 312 

window 224, 312 
Cell range 

active cell moving 212 
border 249, 319, 423 

entering information 212 
error value finding 293 

intersection of row and column 291 
moving 239-241, 309 
printing 254 

reference 276, 278 
selecting 211 
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Cell reference See Reference 

Center command 63, 120 

Center justification 
Draw text object 28, 63 
Word Processor document text 98, 120 

Center tab stop 103, 422 

Centering 
See also Center justification 

cell content 247, 318 

Database entry 197 

Draw object 23 

footer 56 

header 56 

Change Chart Name command 270, 325, 327, 331 

Change Field Name command 149, 188, 397 

Change Report Title command 181, 201 
Changes in Version 2.0 of Microsoft Works 419-424 

Character 
See also Text 
Communications See Communications 

defined 81 
deleting 86 
limitations See Data limitations 

optional characters 83 
return See Return character 

searching 115, 116 
type style See Type; specific style 

Chart 
bar chart See Bar chart 

canceling 
pie chart 269, 328 
series chart 267, 325 

changing 272 
combination chart 256, 259, 326 

copying See Chart definition 
copying between documents 377-378 

data legend 263, 326 
definition See Chart definition 

drawing 271, 324 

grid 265 
horizontal scale 262, 326 

horizontal title 263, 326 
label See Column label; Row label 

line chart See Line chart 
list of existing charts 260 
overhead transparencies 255 
pasting between documents 377-378 

pie chart See Pie chart 
plotting See Plotting 

Chart (continued) 
scale See Series chart 

selecting 271 
series chart See Series chart 
setting up See Chart definition 

slides 255 
Spreadsheet document link 272 

stack chart 258, 326 

title 
pie chart 268, 328 
series chart 262, 326 

transposing columns and rows 237, 263, 308 

types 255-256, 326 

Chart definition 
changing 272, 325, 328 

copying 273, 329 

defined 255, 272 
display 260, 268, 328 

erasing 273, 330 

name 
automatic 270 
changing 270, 327, 331 

display 270, 325 
number allowed 255, 273, 325 

pie chart 268, 327-328 

saving 325-326, 328 

selecting 271 
series chart 260, 325-327 

setting up 260, 268 
title See herein name 

Chart menu commands 324-330 

Choose function 
Database use 147, 275 

defined 283, 287 
Multiplan/Excel/Works differences 405 

Chronological sorting 161-162, 193 

Circular reference 224 

Clear command 
Database selection 159 

defined 62 

drawing 
object removal 20, 25 

text removal 31 

text deleting 86, 88 

undoing 159 

Clearing 158 
Clipboard 

closing 68 
copying Macintosh applications to Microsott 

Works 369 
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Clipboard (continued) 
copying to Clipboard 

Database document, restrictions 369 
generally 61, 89 
Spreadsheet document 235, 308 

cutting to 61, 88, 308 
defined 88 
display 68 
drawing copying, pasting 23 
drawing replacing or retrieval 25 
editing 68 
memory requirements 365 
Paste command 

between tools 367 
Database document 159 
defined 62 
Spreadsheet document 235 
Word Processor document 88-89, 92 

Paste with Options command 236-237, 308 
replacing text 92 
report totals preview 182, 201 
Scrapbook information transfering 407 
summary document creating 182, 201 

Close All command 49, 421 
Close command 8, 48, 68, 414 
Closing 

See also Saving 
all documents 49, 421 
Clipboard 68 
document 8, 48 
Help window 69 

Colon (:) 

cell range reference symbol 278 
document naming incompatibility 6 
macro file name incompatibility 41 

Color - Black Dots command 25, 64, 71 
Color - White Dots command 25, 64, 71 
Color command 71, 95 
Coloring 

Draw object 25, 64 
Draw text object 

coloring object 25, 28, 30, 64 
coloring text 30, 71 

footer or header 57, 108 
report text 181 
text 71, 95 

Color monitor 
drawing display in color 25, 64 
pixels 14-15, 64 

Color monitor (continued) 
text color 71 

Column 
box See Drawing 
charting See Series chart; Pie chart 
copying 311 

copying to Database document 371 
copying Word Processor selection to 372 
Draw text object See Drawing 
filling 238, 311 
freezing scrolling 324, 424 
heading 

defined 208, 218 
freezing 324, 424 
in Draw 33, 35-36 
printing 56, 253 

inserting 243, 310 

intersection with row, cell value display 291 
key column 242-243, 313 
label 263, 265, 326 
linking in Draw 34-36 

multiple-column labels See Multiple-column labels 
named column 404 

number allowed in Spreadsheet document 415 
searching for specified entry 290 
selecting 211 
sorting 241-243, 312-313 
title See herein label 
transposing with row 237, 263, 308 
width 249-250, 320 

Column Width command 250, 320 
Combination chart 256, 259, 326 
Comma (,) 

function component separator 276 
inserting into number 198, 247, 319 
inserting into phone number 339 

Command 
& formatting commands 56 
About MS-Works 46 
Absolute Cell Ref 

Command + A equivalent 414 
mixed reference reversing 222 
reference changing 219-221, 311 

Activate Window 69, 414 
Add New Field 136, 189 
All Cells 211, 314 
Answer Phone 341, 354 
Apple menu commands 46 
Automatic Calculation 227, 323 
Black 71 
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Command (continued) 

Blue 71 
Bold 64, 119, 248, 319, 414 

Bold Field Data 144, 194 

Bold Field Name 144, 194 

Border Field Data 144, 195 

Border Field Name 144, 195 

Borders 249, 319 

Bottom 249, 319 
Bring to Front 27, 66, 414 

Calculate Now 227, 323, 414 

Capture Text 348-349, 354 

Center 63, 120 
Change Chart Name 279, 325, 327, 331 

Change Field Name 149, 188, 397 

Change Report Title 181, 201 
Chart menu commands 324-330 

choosing from keyboard 413 

Clear 
defined 62 
Draw object removal 20, 25 

Draw text removal 31 
Database selection 159 

text deleting 86, 88 

undoing 159 
Close 8, 48, 68, 414 

Close All 49, 421 
Color - Black Dots 25, 64, 71 

Color - White Dots 25, 64, 71 

Color 71, 95 
Column Width 250, 320 
Common Tasks command directory 45 
Communications menu commands 352-361 

Copy 
cell content editing 212, 226 
Command+ C equivalent 414 

copying between tools 366-367 
copying to Clipboard See Clipboard 
Database selection, copying to Spreadsheet 374 

Draw text copying 31 
drawing from Clipboard 23, 377 

entry copying 156 
record copying 156 
Scrapbook information transfenng 407 
Spreadsheet document selection copying 235 

Spreadsheet information, copying to Database 

document 372 
text copying 61, 89 
text/drawn object copying together 3 / o 

value copying 236 

Command (continued) 

Copy (continued) 
Word Processor document, copying to 

Database 370 
Word Processor document, copying to 

Spreadsheet 373 

Copy Format 105, 119, 414 

Copy Totals 182, 201 
Correct Spelling 121-123, 125, 128 

Cut 
cell content editing 212, 226 
Command + X equivalent 414 

cutting to Clipboard 61, 88, 308 

Database selection cutting 159 

defined 61, 88 

Draw text moving 31 

drawing mistake 20 
moving a drawn object 22 
moving information between tools 366, 40/ 

moving text in text object 31 
Spreadsheet selection, moving between 

documents 61, 309 

text cutting 86, 88 

Cyan 71 
Database command directory 185 

Delete 
file deleting 8, 52-53 
macro file deleting 43 

undoing 53, 61 

Delete Field 159, 189 

Dial 
Command+ D equivalent 414 

dialing 340, 352 
phone number recording 338-339, 352 

Dictionary 128 

Draw Chart 271, 324 

Draw Off 37, 63, 414 

Draw On 
Command+ J equivalent 414 

drawing objects 18 
menu additions 46, 63 
starting Draw 15, 63, 414 

Duplicate Chart 273, 329 
Duplicate Report 184, 199 

Echo Off 340, 352 

Echo On 340, 352 
Edit menu commands 

Common Tasks 60-63 
Database 186-189, 201 
Spreadsheet 308-313, 331 
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Command (continued) 

Edit menu commands (continued) 
Word Processor 112-114 

Eject Page 12, 59 

End Text Capture 348-349, 354 
Erase Chart 273, 330 

Erase Report 184, 200 

File menu commands 47-60, 112 
Fill Down 238, 311, 414 

Fill Right 238, 311, 414 

Find 90-91, 114-115, 414 
Find Cell 232, 314, 414 

Find Field 164, 190, 414 
Font 70, 94 

Format menu commands 

Common Tasks 70-71 

Database 186, 194-198, 202 
Spreadsheet 316-320 
with Draw on 46, 63 

Word Processor 117-121 

formatting commands (&-letter), footer/header 56 
Freeze Titles Horizontal 324, 424 

Freeze Titles Vertical 324, 424 
Go To Cell 232-233, 315, 414 
Go To Page # 117, 414 
Green 71 

Grid On 28, 65, 66 

Grid Setting 28, 65 

Group Picture 

Command+ G equivalent 414 
drawing resizing 23 

selecting objects in Draw 25, 65, 67 
Hang Up 341, 353, 414 
Help 9-10, 68-69, 393 

Hide Clipboard 68 
Hide Ruler 100, 118 

Insert 243, 310, 414 

Insert Page Break 106, 120 

Insert Record 153-154, 188, 414 
Italic 64, 96, 119, 414 

Justification 
in Draw 63 

Word Processor 99, 120 
Justified 64, 120 

key See Command key 
Last Cell 210, 234, 314 
Left 

cell border 249, 319 

justification 63, 120 

Macro commands menu 41-43, 72-76 

Command (continued) 
Macros Off 43, 72 

Macros On 38, 41, 43, 72 
Magenta 71 

Make Works Desktop 
new feature 421 

use suggestions 53 

Manual Calculation 227, 323 
Match Records 

Command 4-M equivalent 414 

Database document, full display 165 

printing subset of Database records 384 
385, 388 

record matching 165, 190-191, 414 
Move 61, 239-240, 309 

Multiple Labels 114, 388, 420 
New 5, 47 

New Page After Total 180, 203 
New Pie Chart 268, 327-329 
New Report 176, 186, 199 

New Series Chart 260-262, 325-327 
None 319 

Normal 64, 119, 248, 414 
Open 

Command+ 0 equivalent 414 
document creating 4-5, 47-48, 80 
file importing 398-400 

Open Cell Note 224, 312, 423 

Open Macro File 40-41, 75 
Options 125 

Options menu 320-324 
Open Stack 394 

Organize menu commands 186, 190-193 202 
Other 71 

Outline 

cell border 249, 319 

type style 64, 119 
Page Setup 

cell note printing 56 

column heading printing 56 

Database restrictions 54 

footer/header setting 11, 56, 107 

LaserWriter printer differences 409-411 
mailing label printing 386, 411 
margins setting 57 

page setup 10-11, 54-57 
paper size 11, 55 

printing horizontally 253 

printing reduction 55, 253, 410 
report setup 177 
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Command (continued) 

Page Setup (continued) 
row heading printing 56 
Spreadsheet document setup 253 

Paste 
cell contents editing 212, 226 
Command + V equivalent 414 
Database selection 156-157, 159, 375 

defined 62 
Draw text pasting 31 
drawing from Clipboard 23 

entry pasting 157 
moving a drawn object 22 
pasting between tools 367-378 

record pasting 156 
Scrapbook information transfer 407 
Spreadsheet data, copying to Database document 

372 
Spreadsheet data, moving between documents 61, 

309 
Spreadsheet data, moving within document 61, 

235 
text pasting 62, 88-89 

text replacing 92 
text/drawn object pasting between tools 3/8 
Word Processor document, copying to Database 

370 
Word Processor document, copying to 

Spreadsheet 373 

Paste Format 105, 119, 414 
Paste Function 187, 276, 310 
Paste with Options 236-237, 308 

Playback And 38, 43, 72, 413 
Prepare to Merge 113, 382-383, 414 

Print 
Command + P equivalent 414 

canceling printing 12 

cell range printing 254 
document printing 12, 57-59, 414 
LaserWriter printer differences 409 

merge document printing 384 

report printing 183 
Spreadsheet document printing 253 

Print Merge 
customized document printing 382, 384-383 

documents merging 112, 382 
mailing label printing 114, 389-390 

Print Window 10, 12, 59, 254 

Protected 250-251, 322 

Quit 12-13, 60, 414 

Command (continued) 

Receive File 349, 356 
Record Pauses 40, 75 
Record Selection 

Database records subset creating 171, 384 

printing records 385, 390 

record selecting 382 
record selection rule creating 167, 191, 201 

Red 71 
Remove Page Break 106, 120, 252, 322 

Replace 93, 116, 414 
Report menu commands 198-200 

report window commands 201-203 

Right 
cell border 249, 319 
justification 64, 120 

Save 7, 49, 414 

Save As 
Database document saving 7, 52, 171 

document saving 6, 7, 50 

file exporting 7, 51, 399 

Save Macro File 42, 76 
Save Macro File As 42, 76 
Search Menu commands 114-117 

Select All 
document selecting 62, 85, 211 

new feature 423 
Spreadsheet document printing 253 

Select Chart Definition 260, 268, 271, 328 

Select menu commands 314-315 

Select Report 183, 184, 198 

Send File 347, 357 
Send Text 346-347, 355 

Send to Back 27, 66, 414 
Set Cell Attributes 246, 316-319, 423 

Set Field Attributes 145, 147, 197 

Set Page # 109, 121 
Set Page Break 251, 322 

Settings 338, 356 
Shadow 64, 119 
Show Active Cell 234, 315 

Show All Records 168, 171, 

Show Clipboard 68 
Show Column Boxes 66 

Show Field Data 114, 384 
Show Field Names 114, 382, 384, 385 

Show Form 137, 194, 414 

Show Formulas 228, 321 

Show Grid 
Database grid display 155, 

192, 193, 202 

195 
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Command (continued) 

Show Grid (continued) 

report printing 181, 202 

Spreadsheet grid display 249, 320 
Show List 137, 194, 414 

Show Notes Indicator 224, 312, 321 
Show Ruler 100, 118 

Show Values 228, 321 
Size 71, 95 
Sort 

Database document 162, 193, 414 

Spreadsheet document 243, 312 
Spacing 98, 120, 388, 422 

Spell Menu commands 121-128 
Spread Text 32, 67 

Spreadsheet command directory 307 
Start Recording 38, 41, 73 

Stop Recording 38, 41, 74 
Style 

in Draw 64 

Word Processor documents 95, 119 
Subscript 119 

Sum This Field 

field subtotaling 180 
field totaling 179 

report totaling 202 

Superscript 119 

Take a Sub-Total on 1st Char 

Take a Sub-Total on Field Change 180 203 423 
Title Page 11, 109, 121 
Top 249, 319 

TotalsPage menu commands 179, 186, 202-203 
Underline 64, 119, 248, 414 
Undo 

clearing undoing 158, 159 

Command + Z equivalent 414 
cutting undoing 158 

deleting undoing 86, 158, 159, 189 
drawing mistake 20 

Edit menu command undoing 61, 83 
ineffective 61 

Ungroup Picture 

Command+ U equivalent 414 
drawing copying between tools 377 
drawing resizing 23 

drawing ungrouping 26, 65, 414 
White 71 

Window menu commands 68-69 

Word Processor command directorv 111 
Yellow 71 

Command key 

control character transmitting 342 
defined xix 
drawing tool selection 18 
using keyboard commands 46, 413, 414 

Command + , (comma) 69, 414 
Command +. (period) 

cancel printing 12 
macro playback stopping 43, 413 

Command + ’’(quotation mark) 156, 414 
Command + B 

boldface type style 96, 248, 414 
Send to Back 414 

Command + D 
date entry 146, 414 
Dial 414 
Fill Down command 414 

Command + key equivalents 
type styles 96, 248, 413-414 
using 46, 413-414 

Command+ N 248, 414 
Command + Option 241, 309 
Command + Option keys 241, 309, 342, 413 
Command + Option + 3 342, 413 
Command + Option + [ 342, 413 
Command 4- Option + Delete 342, 413 
Command + T 146, 414 
Command + U 248, 414 
Commas See Comma 
Commercial symbol 83 
Common Tasks 

defined 1, 3 
new features 421-422 

Common Tasks command directory 45 
Communications 

+ + + message 341 
acoustic coupler 336, 340 
application program, saving to disk 349 
ATH message 342 
auto-wrap 359 
baud rate 336, 359 

Break key, Command + Option + 3 equivalent 342 
413 

cable connection 336 
call 

answering 341,354 
calling another computer 343 
hanging up 341, 353 
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Communications (continued) 

capture text See herein text 

carrier defined 341 
character delay setting 360 

character setting 336, 360 
Command + key equivalents 351, 413 

computer connections 

breaking 341 

cable 336 
data communication 335 

modem See Modem 

responding 340 
CONNECT message 340 
control character transmitting 342 

cursor, moving to new line 359 

data size/transmission 

defined 336 

setting 359-360 . , 
Delete key, Command + Option + Delete equivalent 

342, 413 
dialing See Phone number 

disconnection 341 
document See Communications document 

echo 340, 352 
escape codes 361, 425-427 
Escape key, Command + Option+ [ equivalent 342, 

413 

file 
See also File 

defined 345 
receiving 347, 349-350, 356-357 

receiving in MacBinary format 350 

saving 349 
sending 346, 347, 357 

handshake 337, 360 

hanging up 341, 353 
Hayes modem See Hayes modem 

information service access 345 

keypad 361 
line delay setting 360 

logging off 341, 353 
MacBinary format 350 

modem See Modem 

NewLine setting 359 
NO CARRIER message 341 

parameters 338, 358-361 

parity 336, 360 
personal computer calling 343 
phone number See Phone number 

port 361 

Communications (continued) 

protocol 337, 356-357 

Rotary Dial setting 360 
screen scrolling 359, 424 

sending 
drawn object 355, 356 

formatting 355, 356 

text 346-347, 355 

session ending 341, 353 
settings 338, 343, 358-361 

speed 336, 359 

stop bit 336, 360 
telephone See herein call; modem; phone number, 

port; settings 
terminal emulation 345, 359 

text 
capturing as Word Processor document 338, 348 

capturing during a session 347-349, 354 
capturing when document opens 338, 348, 

361, 424 
defined 345-346 

sending 344-345, 355 

Touch-Tone setting 360 
transmission speed 336, 359, 360 

use suggestions xvi 
X modem textJX modem data 356 

Xon/Xoff option 360 
Communications document 

Communications settings specifying 358 

copying to other tools 376 

creating 47, 337-338, 358 
phone number See Phone number 

printing 10 

saving 343 
settings 338, 343, 358, 361 

Communications menu commands 352-361 

Comparison operator 223 
Comparison phrase See Record selection rule 

CompuServe 335, 342, 351 

Computed field 
defined 146-147 

formula entry 148 
setting 147-148, 195-196 

Computer 

calling 343 
connections 

cable connection 336 
data communications 335 

disconnection 341 

hanging up 341, 353 
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Computer (continued) 

connections (continued) 

modem connection See Modem 
settings 338, 343, 358-361 

protocol 337, 356-357 
Computer paper 55 
Concatenation operator (&) 404 
CONNECT message 340 
Connectors See Record selection rule 
Constant value 

defined 211 
display 216 
editing 226 
entry 211 

Continuous form paper 55, 58 
Continuous labels 

defined 385 
preparation for printing 386-389 
printing 398-390 

Control character transmitting 342 
Conversion with Appleworks files 402-403 
Copy command 

cell contents editing 212, 226 
Command + C equivalent 414 
copying between tools 366-367 
copying to Clipboard See Clipboard 
Database selection, copying to Spreadsheet 374 
Draw text copying 31 
drawing from Clipboard 23, 377 
entry copying 156 
record copying 156 

Scrapbook information transfer 407 
Spreadsheet document selection copying 235 
Spreadsheet information copying to Database 

document 372 
text copying 61, 89 

text/drawn object, copying together 378 
value copying 236 
Word Processor document 

copying to Database 370 
copying to Spreadsheet 373 

Copy Format command 105, 119 
Copy Totals command 182, 201 
Copying 

See also Filling; Moving; Pasting 
5.25-inch disk to 3.5-inch disk 403 
absolute reference 234, 239 
adjacent cells 238, 311 
between tools 365-367 
cells 234-236, 238, 308, 311 

Copying (continued) 

chart between documents 377-378 
chart definition 273, 329 
column 311 

Communications document to other tools 376 
copying to Clipboard See Clipboard 
Database information 

copying to Word Processor document 368 
copying to Spreadsheet document 374-375 

Dictionary folder to hard disk 421 
document with Save As command 7 50 
drawings See Drawing 
entry 155-156 
field 155-156 
files to 3.5-inch disk 403 
fonts to hard disk 421 
formatting, paragraph 105, 119 
formula 234-235 

Macintosh applications to Microsoft Works See 
Importing files 

memory requirements 365 
Microsoft Works master disk 393, 420-421 
Program disk 421 
record 155-156 
relative references 234, 239, 308 
row 311 

Scrapbook information transferring 407 
spacing 105, 119 

Spreadsheet document selection 235, 308, 311 
Spreadsheet information 

copying to Database document 371-372 
copying to Word Processor document 368 

Startup disk 421 
System folder 420 
text 61, 89 

text/drawn objects together 378 
value 235, 236, 308 

^0IX! ^rocessor documents, copying between 368 
Word Processor information 

copying to Database document 369-371 
copying to Spreadsheet document 372-374 

Correct Spelling command 121, 123, 125, 128 
Correct spelling 

canceling 125 
defined 121 
Dictionary folder 121, 123 
homonym checking 126-127 
imported dictionary, using 128 
misspelled or unknown word 

add to dictionary 123, 124 
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Correct spelling (continued) 
misspelled or unknown word (continued) 

suggested replacements 123 

skipping 122-123 
searching options 125-127 

new feature 422 
punctuation checking 126-127 

skipped word dictionary 
add new word 123, 124-125 

delete word 125 

saving 128 

viewing 123 

Cos function 282, 287 

Cosine 282, 287 

Count function 
cell with 0 or text 278 
Database use 147, 275 

defined 282, 287 
Criteria matching See Record selection rule 

Cross pointer 18 
Cursor See Pointer 

Custom paper size 11, 55 
Customized document, printing 382, 384-38:) 

Cut command 
cell content editing 212, 226 
Command + X equivalent 414 

cutting to Clipboard 61, 88, 308 

Database selection cutting 159 

defined 61, 88 

drawing 
moving an object 22 
moving text in text object 31 

undoing a mistake 20 
moving information between tools 366, 407 
Spreadsheet selection, moving between documents 

61, 309 
text cutting 86, 88 

Cutting 
See also Cut command; Deleting 

between tools 366, 407 
Database selection 159 

defined 158 

text 86, 88 
undoing 158 

Cyan command 71 

Dashed line 
column box border 32, 66 
manual page break indicator 

322, 424 

106, 120, 251-252, 

Data 
moving See Moving , 
protection See Cell protection 

size See Communications 
transmission See Communications 

Data communications See Communications 

Data legend 263, 265, 326 

Data limitations 415 

Database , 
charting information in Spreadsheet document 23 o 

command directory 185 
Command + key equivalents 413 

copying between tools 368-372, 374 

data display 137, 194 
data limitations 415 
document See Database document 

entry bar See Entry bar 
entry See Entry; Field data; Value 

field See Field 

file See File 
form See Form 
form window See Form window 

formula See Database formula 

functions See Function 
importing non-Works file 398-399 

list window See List window 

memory capacity 416 

new features 423 
Page Setup command restrictions 54 

record See Record 

report See Report 
Select All command use 62 

use suggestions xvi 

value See Value 
Database document 

appearance, preset 143 

color of text 71 

copying 
information to Spreadsheet document 374-375 

information to Word Processor document 36 

Spreadsheet information to 371-372 
Word Processor information to 369-371 

creating 47, 134-135 
date format 139, 145-146 

font 70, 394, 422 

font size 71 

form 132 
form window See Form window 

full display 165 
grid 154-155, 181, 198 
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Database document (continued) 

list window See List window 
merging with Word Processor document See 

Merge document 
planning 132-134 
removing information 158-159 
saving 51-52, 171 
scrolling 133 
setting up 134-135 
sorting See Sorting 
subset, creating 171, 384 
summary document 182, 201 
time format 139, 146 

Database formula 

See also Function; Spreadsheet formula 
argument 276 
entry 148 
field name inserting 196 
function 

entry 187, 276 
use restrictions 147, 275 

symbols 196 
Date 

current date 
entering into field 146, 414 
serial number 298 

display 145-146, 280, 317-318 
entry method 

cell 215, 280, 317 
field 145-146, 196, 414 

field See Date field 
formatting 

cell 215, 280, 317-318 
field 145-146, 196 

functions 280, 284 
importing in Spreadsheet file 400 
printing in header or footer 56 
recalculation update 298 
serial number 280, 288 
weekday 

display 146, 197, 317-318 
function 306 

Date field 
See also Date 
current date entering 146, 414 
record selection rule comparison phrases 166 
setting 145-146, 196 
sorting See Sorting 
weekday display 146, 197 

Date function 284, 288, 403, 423 

Date Long format 215, 280, 318 
Date Medium format 215, 280, 318 
Date Short format 215, 280, 318 
Day See Date 
Day function 284, 288, 405 
Decimal number 

entering into cell 214 
place setting 197, 246, 316, 318 

Decimal tab stop 103, 118, 422 
Degree conversion 301 
Degrees function 282, 289, 405 
Delete command 

file deleting 8, 52-53 
macro file deleting 43 
undoing 53, 61 

Delete Field command 159, 189 
Delete key 

Backspace equivalent xix 
cell contents editing 212 
character deleting 86 

Command + Option + [ equivalent 413 
erasing Draw text object 30 
paragraph joining 87-88 
phone number deleting 339 
text deleting 86, 88, 158 

Deleting 

See also Clearing; Cutting 
blank line 87 
character 86 
chart definition 273, 330 
defined 158 
Database selection 159 
dictionary word 125 
Draw text object 31 
drawing 20, 25 
field 159, 189 
field name 189 
file 8, 52 
grid 154-155, 181, 195 
homonym file, word in 127 
macro 43, 73 
page break See Page break 
phone number 339 
record selection rule 171, 192 
report fields 178 
tab stop 104 
text 62, 86, 88 
undoing 53, 61, 86, 158-159 

Delphi 342 
Delta function 405 
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Desk accessory 46 
Desktop publishing 13, 36 

Desktop See Works Desktop 

Dial command 
Command + D equivalent 414 

phone number 
dialing 340, 352 
recording 338-339, 352 

Dialog box, moving 263, 268, 325 

Dictionary command 128 
Dictionary file See MsWorksDict 

Dictionary folder 
copying to hard disk 393, 421 

location 121, 395 
Dictionary, skipped word See Correct spelling 

Disk 
changing 6, 8, 48, 50, 53, 54 
copying 5.25-inch disk to 3.5-inch disk 403 

copying master disk 393, 420-421 

file management 393-395 

hard See Hard disk 

initializing 6 
macro deleting 43, 73 
memory available display 46, 52 

personalizing master disk 420 
Program disk See Program Disk 

Startup disk 393, 419-421 
startup information 344-395, 419-421 

Works disks described 393 

Disk drive requirement 419 
Division operator (/) 196, 222, 223 

Document 

See also File 
activating 69, 364 
arrangement saving See Works Desktop 

Clipboard See Clipboard 

closing 8, 48 
closing all 49, 421 
Communications See Communications docume 

copy using Save As command 7, 50 

creating 5, 47, 48 
custom, printing 382, 384-385 

cutting 61 
Database See Database document 

defined xviii 
Desktop See Works Desktop 

Draw layer See Drawing 

exporting 401-402 

file distinction xviii 

file See File 

Document (continued) 

footer See Footer 
formatting See Formatting 

header See Header 
merge See Merge document 

naming 6-7, 49-50 
pasting text from Clipboard 62 

printed document, formatting 

printing 
active window 10, 12, 59, 254 

document name 56 

page setup 10-11, 54-57 

partial document 58 

preview 12, 58 
procedure 12, 57-58 

Read/Write privileges 418 

replacing 7, 50 

saving 
all open documents 49 
document arrangement See Works Desktop 

document to another disk 395 

filename conventions 6 

formatting 51 
frequency 5, 49, 83 
new name 6, 7, 50 

same name 7, 49 

text file method 7 

selecting 62 
sharing 417-418 
Spreadsheet See Spreadsheet document 

stationery 51 
summary document 182, 201 

text 
color options 71 

font options 70-71 
Word Processor See Word Processor document 

Dollar format 
Database document 197 
Spreadsheet document 246, 317 

Dollar function 405 
Dollar sign ($), absolute reference symbol 2iy-zzi, 

311 
Dotted line, automatic page break indicator 83, 105, 

120, 424 
Double spacing 97, 120 
Double word errors, checking 126 

Dow Jones 342, 353 

Draft printing 58 



Draw feature 
See also Drawing 

disabled during Spreadsheet window split 229 
exiting 37, 63, 414 
memory capacity 416 
new feature 422 
starting 15, 63, 414 

Draw Chart command 271, 324 
Draw layer See Drawing 
Draw Off command 37, 63, 414 
Draw On command 

Command + J equivalent 414 
drawing objects 18 
menu additions 46, 63 
starting Draw 15, 63, 414 

Drawing 

aligning See herein object; text object 
angle 15, 19 
arc 

perfect shape 19 
resizing 23 
text placement on 32, 67 

arc tool 16 
arrow 

aligning with arrow 16, 27 
drawing lines with arrow 16, 24 

arrow key 27 
border width 24 
bring object to front 27, 66, 414 
Center command 63 
character 32, 33, 66 
chart See Chart 
circle 16, 19, 32 
Clear command 31 
Color - Black Dots command 25, 64, 71 
Color - White Dots command 25, 64, 71 
coloring 

drawn object 25, 64 
text 30, 71 
text object 25, 28, 30, 64 

column See herein text object 
Command key tool selection 18 
Copy command 31, 32 
copying 

between tools 14, 376-377 
copying from or to Macintosh application 407 
copying objects within Draw 23 
text and object together 378, 407 

cross pointer 18 

Drawing (continued) 

Cut command 
moving an object 22, 61 
text moving 31 
text spreading 32 

Delete key 30 
deleting 20, 25, 31 
desktop publishing 13, 36 
Draw layer defined 14 
drawn object See herein object 
erasing 20 
exporting drawings 376, 407 
exiting 37, 63, 414 
fill pattern 

added to Format menu 46, 63 
display 16 
preset 21 
setting 24, 31, 67 

Fill Pattern menu 16, 24, 46, 63, 67 
filling See herein fill pattern 
Format menu command additions 46 63 
Freehand tool 15 
grid 27-28, 66 
Grid On command 28, 65, 66 
Grid Setting command 28, 65 
Group Picture command 23, 25, 65 67 
handles, defined 18 
heading, column 33, 35, 36 
I-beam pointer 29 
importing drawings 37, 407 
Justification command 63 
Justified command 64 
layering of objects 27 
Left command 63 
line 

drawing with arrow 16, 24 
perfect shape 19 
text placement on 32 

line pattern 
added to Format menu 46 
display 16 
setting 24, 68 
text spreading 32 

Line Pattern menu 16, 24, 32, 46, 63 68 
Line tool 15 
line width 16, 24 
linking columns 34-36 
mistake undoing 20 

moving See herein object; text object 
new feature 422 
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Drawing (continued) 

object 
See also herein text object 
aligning pixel-by-pixel 16, 27 

aligning using grid 28, 65-66 

bring to front 27, 66 
centering, automatically 23 

coloring 25, 64 
copying See herein copying 

defined 17 

deleting 25 
drawing procedure 18 

editing 20 
erasing 20 
fill pattern See herein fill pattern 

grouping 25-26, 65, 67 

layering 27 
line pattern See herein line pattern 

moving 21-22, 26 
moving between tools, applications 4U/ 

placement in plane 14, 26, 28, 66 

removal 20, 25 

resizing 22, 23 
selecting, procedure 20-21 
selecting, Select All command unusable 62 

Selection tool 15 
selection, automatic 18 
send to back 27, 66, 414 
sending to another computer 355, 356 

text See herein text object 
transparent objects 21, 24, 67, 68 

ungouping 26, 64 

Oval tool 16 
palette See herein Tools palette 

Paste command 
copying object 23 
moving an object 22 

text pasting 31 

pasting 
between applications 407 

between tools 376-377, 407 

Draw text 31 
copied object 23 
moved object 22 
text and drawing together 378 

pattern See herein fill pattern; line pattern; pixel 

perfect shapes 19, 22 

pixel 
alignment by pixel 16, 27 
black and white monitor 14 

Drawing (continued) 

pixel (continued) 
color changing 25 
color monitor 15, 64 

defined 14-15 

pattern 64 
planes 14, 26, 28, 66 

pointer 

cross 18 
I-beam 29 

polygon 19, 23 
polygon tool 16 
Rectangle tool 16 

removing 
object 20, 25 

text 31 
resizing See herein object; text object 

Return key 30 
Right command 64 
Rounded-comer Rectangle tool 16 

Scrapbook use 37, 407 
selecting See herein object; text object 

Selection tool 15 
send object to back 27, 66, 414 
sending object to another computer 355, 356 

Shift key 19, 21 
Spread Text command 32, 67 

square 19 
starting Draw 15, 63 

Straight-line tool 15 

Style command 64 

template 36 

text object 
See also herein object 

adding text 30 
aligning on arc, line 32, 67 
aligning pixel by pixel 16, 27 

aligning using grid 28, 65-66 

centering 23 
character as text object 32, 33, 66 

coloring object 25, 28, 30, 64 

coloring text 30, 71 
column box 33-34, 36, 66 
column heading 33, 35, 36 

columns 33-36 
columns, linking 34-36 
copying object See herein copying 

copying text 31 
creating from normal text 379 

defined 28 



Drawing (continued) 

text object (continued) 
deleting 31 

drawing procedure 29-30 
editing 30, 31, 64 

filling See herein fill pattern 
font 28, 30, 70 

justification 28, 30, 63-64 

moving between applications 407 
moving between tools 379, 407 
moving text 31 

placement in plane 28 
removing text 31 
resizing 29, 31 

selecting 31 

text spreading 32, 67 

turning into linked column 36 
type size 28, 30, 71 

type style 28, 30, 64 
Text tool 

column creating 33 
defined 15 

drawing text object 29 
editing text object 31 
turning off 30 

tool selection with Command key 18 
Tools palette 

described 15-16, 63 

drawing object 18 

drawing polygon 19 

drawing text object 29 
line width setting 24 

moving on screen 16 

pixel-by-pixel alignment 16, 27 

transparent objects 16, 21, 24, 67, 68 
trapezoid 16 

triangle 16 

Undo command 20 

Ungroup Picture command 23, 26, 65 
use suggestions 13 

Word Processor document drawing restriction 19 
22, 34 

Drive See Disk drive requirement 
Duplicate Chart command 273, 329 

Duplicate Report command 184, 199 

Echo 340, 352 

Echo Off command 340, 352 

Echo On command 340, 352 

Edit menu commands 

Common Tasks 60-63 

Database 186-189 
report window 201 
Spreadsheet 308, 313, 331 
undoing 61 

Word Processor 112-114 
Editing 

cell contents 212, 226 
Clipboard 68 

entry in Database document 143, 158 
undoing a command 61 

Eject Page command 12, 59 
Electronic mail 343, 355 
Empty cell See Cell 
End key xix 

End Text Capture command 348, 349, 354 
Ending a Works session 12-13, 60, 418 
Enlarging 410 
Enter key 

cell information entering 208, 212 
Database entry inserting 139, 140 

Entering See Inserting 
Entry 

See also Field; Field data; Value 
active entry 142-143 

alignment 197 

bar See Entry bar 

bold style 144, 194, 198 
border 144, 195 

centering 197 

contents display 143 

copying 155-156 
creating 138-140 
defined 138 

deleting 159, 189 

editing 143, 158 

field See Field 

finding 164, 190, 414 
length 139 

moving 139, 140 

selecting 138, 142 

Spreadsheet entry See Cell 
type style setting 198 

underline style 198 
Entry bar 

entry editing 143, 158, 212, 226 

equal sign ( = ), formula entry 148 196 
label display 213 
length 211, 415 
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Entry bar (continued) 
Spreadsheet formula display 216 

text copying 61 
typing in 139-140 

Equal sign ( = ) 
Database formula entry 148, 196 

Database text field creating 162 

equals operator symbol 223 
function entry into formula 278 
Spreadsheet formula entry 211, 216 

Equals operator (=) 223 
Erase Chart command 273, 330 
Erase Report command 184, 200 

Erasing See Deleting 
Error function 284, 289, 405 

Error value 
Error function 284, 289, 405 
Excel/Works differences 404 

finding 293, 314 

N/A 298 
numeric value 305 

Escape codes 361, 425-427 
Escape, Command + Option+ [ equivalent 413 

European letter size 55 
Excel See Microsoft Excel 
Exiting See Closing; Draw; Quitting 

Exp function 281, 289 
Expense report See Form 

Exponentiation 
defined 146 
function 281, 289 

limits 214 
operator O 196, 222-223 

scientific notation 246, 317 

Exporting files 7, 51, 401-402 
Expression, argument component 276 

Extended keyboard xix, 39 

External references 404 

False function 
defined 283, 289 
Multiplan/Excel/Works differences 405 

numeric value 278 

See also Entry; Numeric field; Text field 

add new field 135-137, 189 

attribute 
removing 62 
setting 145-146, 195-198 

Field (continued) 
computed field See Computed field 
comparison See Record selection rule 

contents display 114, 194 

copying 
to Word Processor document 366 
within and between Database document; 

Word Processor selection to 369-371 

r'rpatinp 135-137, 189 

data See Field data 
date field See Date field 

defined 132 
deleting 159, 189 
finding 164, 190, 414 
formatting 143-146, 195-198 

key field 180, 203 

length 415 

moving 
form window 150 
list window 151-152 

name See Field name 
number allowed per record 415 

report field See Report 

selecting 
list window 142 
report window 176 

sizing 
form window 149 

list window 150-151 

sorting See Sorting 
subtotaling 180, 203 
time field See Time field 

totaling 179, 202 

Field data 
See also Entry 
attributes setting 145-146, 195-198 

bold style 144, 194, 198 

border 144, 195 

defined 132 
display in merge document 114, 384 

Field name 
bold style 144, 194 

border 144, 145 
changing 148-149, 188, 397 

conventions 135 

creating 135-136 

deleting 189 
display in merge document 114, 384 

formula, inserting 196 

function argument 276 

155- 
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Field name (continued) 
length 415 

merging See Merge document 
record selection rule component 166 

FIELD NOT IN DB message 384 
File 

See also Document 
arrangements saving 13 
ASCII file defined 395 

Communications file See Communications 
conversion with Appleworks files 402-403 
defined xviii 
deleting 8, 52 

Desktop See Works Desktop 
document distinction xviii 
exporting 7, 51, 401-402 
importing See Importing files 
list display 4, 5, 48 
management 393-395 
naming See Document saving 
opening 3-4, 47 
README xix-xx 

*** JfXt ^0lmat file Rich Text ^rma 
RTF file See Rich Text Format 396 
saving 

changes to file 49, 50 
file arrangements 13 

stationery 51, 421 
SYLK See SYLK file 
template 51 
text file See Text file 
Works Desktop See Works Desktop 

File menu commands 47-60, 112 
File server 417 
Filename conventions 6 
Fill Down command 238, 311, 414 
Fill pattern See Drawing 
Fill Pattern menu 16, 24, 46, 63, 67 
Fill Right command 238, 311 414 
Filling 

See also Copying 
cells 238, 311, 414 
drawing See Draw 

Financial functions 
See also Investment 
Database use 147, 275 
defined 283, 300 

Find Cell command 232, 314, 414 

Find command 90-91, 114-115, 414 
Find Field command 164, 190, 414 

Finding 

See also Replacing; Searching; Selecting 
active cell 231, 234 
capitalization option 91, 115 
cell See Cell 
character 115, 116 

criteria matching See Record selection rule 
entry 164, 190, 414 
error value 293, 314 
field 164, 190, 414 
last cell 210, 234, 314 
N/A value 314 
return character 115, 116, 422 
tabs 115, 116, 422 
text 90-91, 114-115 
whole word 90, 115, 116 

Fixed format, number 196, 246, 316 
Fixed function 405 
Folder list display 4, 48 
Font 

changing 70, 94 
copying to hard disk 421 
Database document 70, 394 422 
defined 94 
Draw text object 28, 30, 70 
footer, setting 57, 108 
header, setting 57, 108 
LaserWriter options 70, 409-410 
moving 70, 71, 94, 394, 421 
new feature 422 
optional characters 83 
presettings 70, 394 
removing 70, 71, 94, 394 
size See Type size 
Spreadsheet document 70, 394, 422 
type style See Type style 
Word Processor document 70, 394, 422 

Font command 70, 94 
Font/DA Mover 70, 71, 94, 394, 421 
Footer 

ampersand (&) printing 56 
color 57, 108 
date printing 56 
defined 107 
document name printing 56 
exclusion from first page 11, 109 121 
font setting 57, 108 
formatting 57, 107 
page number printing 56, 57 
setting 11, 56, 107 
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Footer (continued) 

time printing 56 

Foreign letter 83 

Form 
creating from merged document 391-392 

Database document creating 132 

letter 388-389 
preprinted forms 392 

Form window 
Database entry 

inserting 140 

selecting 142 

display 137, 194 

field 
adding 136-137, 189 
formatting 143-145, 195 

moving 150 

sizing 149 

sorting 161 
information copying 155 
List window, switching to 137, 194 

record 
appearance changing 143 

inserting 153-154, 188 

matching 165, 191 
sorting See Sorting 

report window, changing to 183 

Format See Formatting 

Format menu commands 
Common Tasks 70-71 
Database 186, 194-198, 202 

report window 202 
Spreadsheet 316-320 

with Draw On 46, 63 
Word Processor 117-121 

Formatting 
bold See Bold style 

cell 245-249, 316-319 
commas style 198, 247, 319 
copying paragraph formatting 105, 119 

date 
cell 215, 280, 317-318 

field 145-146 
decimal places 197, 246, 316, 318 

dollars, cents format 197, 246, 317 

field 143-146, 195-198 
fixed format 196, 246, 316 

font See Font 

footer 56, 107 
general format 196, 246, 316 

Formatting (continued) 

header 56, 107 
moved document 379 

numbers 
cell 246-247, 316-318 

field 145, 196-197 
paragraph See Paragraph 

percentages 197, 246, 317 
Rich Text Format See Rich Text Format 

saving with document 51 
scientific notation 197, 246, 316 
sending to another computer 355, 356 

Spreadsheet document 245 

time 
cell 280, 318 
field 146, 196 

type styles See Type styles 

underlining See Underlining 

values 196-197, 245, 316-318 
Word Processor document 97, 105 

Formatting commands (&-letter), footer or header 56 

Formula See Database formula; Spreadsheet formula 

Freeze Titles Horizontal command 324, 424 

Freeze Titles Vertical command 324, 424 

Full duplex See Echo On command 

Full justification 

Draw text 28, 64 

text 98, 120 

Function 
Abs 281, 285 
ACos 282, 285, 

And 
Database use 147, 275 

defined 283, 285 
Multiplan/Excel/Works differences 405 

argument 
count numbers 287 

defined 275 
empty cell 278 
function component 276 

largest number 296 

logical value 278 
notation conventions 279 

numeric value 278 
reference inserting 276 
sample standard deviation 304 

smallest number 296 

text in cell 278 

sum 303, 304 
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Function (continued) 
argument (continued) 

types 276 

variance 305-306 
ASin 282, 286, 405 
ATan 282, 286 

ATan2 282, 286 

availability differences in Multiplan/Excel/Work' 
404-406 

Average 

Database use 147, 275, 278 
defined 282, 286 

Choose 

Database use 147 
defined 283, 287 

Multiplan/Excel/Works differences 405 
Cos 282, 287 
Count 

cell with 0 or text 278 

Database use 147, 275 
defined 282, 287 

Database use 147, 275 
Date 

defined 284, 288 

Multiplan/Excel/Works differences 405 
new feature 423 

storing as serial numbers 280, 288 
date functions 280, 284, 423 
Day 284, 288, 405 

defined 275-276 

Degrees 282, 289,405 
directory 285-306 

entry into formula 276-278, 310 

equal sign (=) to begin formula 278 
Error 284, 289, 405 
Exp 281, 289 

False 278, 283, 289, 405 

financial functions See Financial functions 
FV 

Database use 147, 275 

defined 283, 290, 300 
HLookup 

Database use incompatibility 147, 275 290 
defined 284, 290 

Multiplan/Excel/Works differences 405 
Hour 284, 291, 405 
If 

Database use 147, 275 
defined 283, 291 

Function (continued) 
Index 

Database use incompatibility 147 275 291 
defined 284, 291 ’ ’ 

Multiplan/Excel/Works differences 406 
inserting into formula 276, 310-311 
Int 281, 292 
IRR 

Database use incompatibility 147 275 292 
defined 283, 292 ’ ’ ^ 

IsBlank 

Database use 147, 275 
defined 283, 293 

Multiplan/Excel/Works differences 406 
IsEiror 283, 293, 406 
IsNA 283, 293 
listing 310 

Ln 281, 293 

Log10 281, 294 

logical 147, 275, 283 
Lookup 

Database use incompatibility 147 275 
defined 284, 294 

Multiplan/Excel/Works differences 406 
Match 

Database use incompatibility 147 275 294 
defined 284, 295 

Multiplan/Excel/Works differences 405, 406 
mathematical functions 281 
Max 

cell with 0 or text 278 

Database use 147, 275 
defined 282, 296 

Min 

cell with 0 or text 278 

Database use 147, 275 
defined 282, 296 

Minute 284, 291, 296, 406 
MIRR 

Database use incompatibility 147 275 297 
defined 283, 296 

Mod 281, 297 

Month 284, 288, 297, 406 
NA 284, 298 

Not 283, 298, 405 

Now 284, 298, 406 

NPer 283, 298, 300 
NPV 

Database use 147, 275 
defined 283, 299 
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Function (continued) 
Or 

Database use 147, 275 
defined 283, 299 
Multiplan/Excel/Works differences 405 

parentheses 276 
parts 276 
pasting 187, 276, 310-311 
Pi 281, 299 
Pmt 

Database use 147, 275 
defined 283, 299, 300 

PV 
Database use 147, 275 
defined 283, 300 

Radians 282, 301, 406 
Rand 281, 301, 406 
range reference 276, 278-279 

Rate 
Database use 147, 275 
defined 283, 300, 302 

Round 281, 302 
Second 284, 291, 302, 406 
Sign 281, 302 
Sin 282, 303 
special-purpose functions 284 

Sqrt 281, 303 
SSum 

cell with 0 or text 278 
Database use 147, 275 
defined 282, 303 
Multiplan/Excel/Works differences 406 

statistical functions 147, 275, 282 

StDev 
cell with 0 or text 278 
Database use 147, 275 
defined 282, 304 

Sum 
cell with 0 or text 278 
Database use 147, 275 
defined 282, 304 

syntax 276 
Tan 282, 304 
Time 

defined 284, 304-305 
storing as decimal fractions 280 

time functions 284, 423 
trigonometric functions 282 
True 283, 305, 405 
Type 284, 305, 405, 406 

Function (continued) 
Var 

cell with 0 or text 278 
Database use 147, 275 
defined 282, 305 
Multiplan/Excel/Works differences 406 

VLookup 
Database use incompatibility 147, Z/o, 

defined 284, 290, 306 
Multiplan/Excel/Works differences 405 

Weekday 284, 288, 306 
Year 284, 288, 306, 406 

Function key 39 
FV function 

Database use 147, 275 
defined 283, 290, 300 

290, 306 

, 406 

General format 196, 246, 316 
Go To Cell command 232-233, 315, 414 
Go To Page # command 117, 414 
Graphics See Chart; Drawing 
Greater than operator (>) 223 
Greater than or equal to operator (5s) 223 

Grid 
in Draw 27-28, 66 
Database document 154-155, 181, 19j 

report 181, 202 
Spreadsheet document 249, 265, 320 

Grid On command 28, 65, 66 
Grid Setting command 28, 65 
Group Picture command 

Command+ G equivalent 414 
resizing arc, polygon 23 
selecting objects in Draw 25, 65, 67 

Grouping objects in Draw 25-26, 65, 67 
Growth function 405 

Half duplex See Echo Off command 
Hand pointer 59, 150 
Handles defined 18 
Handshake 337, 360 
Hang Up command 341, 353, 414 
Hanging indentation 100-102 

Hard disk 
See also Disk 
copying Works to 421 
System starting 394, 420-421 
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Hard disk (continued) 
system requirements 419 

Hard page break See Page break 
Hayes Computer Products, Inc. 358 
Hayes modem 

auto-answer 341 
dialing 340, 352, 353 
phone book 339, 353 
preset options 358 

Hayes-compatible modem See Hayes modem 
Header 

ampersand (&) printing 56 
color 57, 108 
date printing 56 
defined 107 
document name printing 56 
exclusion from first page 11, 109 121 
font setting 57, 108 
formatting 56, 107 
page number printing 56 
setting 11, 56, 107 
time printing 56 

Heading See Column heading; Row heading 
Help command 9-10, 68-69, 395 
Help folder on Program disk 393, 395 
Help from Product Support xx 
Help window 9-10, 68-69 
Hide Clipboard command 68 
Hide Ruler command 100, 118 
Highlight reversal 84 
Highlighted cell See Active cell 
HLookup function 

Database use incompatibility 147, 275 290 
defined 284, 290 

Multiplan/Excel/Works differences 405 
Home key xix 

Homonym checking option 126 
Homonym file 127, 393, 395 
Horizontal page break See Page break 
Horizontal printing 55, 253 
Horizontal scale 262, 326 
Horizontal title 263, 326 
Hour function 284, 291, 405 
HyperCard 394 

I-beam pointer 29, 84 
If function 

Database use 147, 275 
defined 283, 291 

ImageWriter II printer See ImageWriter 
ImageWriter printer 

font size recommendations 95 
printing reduction 253, 410 
setting up 10 

ImageWriter printer driver 54 
Importing files 

Apple Works file 402-403 
ASCII file 397 
dictionaries 128 

printer 

Database documents 398-399 
Macintosh applications 369, 407 
Microsoft Excel/Multiplan files 404-406 
opening file 48 
Rich Text Format 398 
Scrapbook use 407 
Spreadsheet documents 400-401 
SYLK files 400, 404-406 
text files 397-400 

Word Processor documents 397-398 
Indentation 

See also Margin 
copying 105, 119 
hanging indentation 100-102 
margin distinction 102 
markers, new feature 424 
setting 100, 118 

Index function 

Database use incompatibility 147, 275, 291 
Multiplan/Excel/Works differences 406 

Information service access 345 
Initializing disks 6 
Insert command 243, 310, 414 
Insert Page Break command 106, 120 
Insert Record command 153-154, 188 
Inserting 

addition operator ( + ) 217, 219, 222 311 
blank line 82 

cell information 208-211, 212, 414 
cell label 213-214 
column 243, 310 
commas 198, 247, 319 
Database entry 138-140 
Database formula 148 
field name into Database formula 196 
function into formula 187, 276, 310-311 
mixed reference 222 
page break, manual 106, 120, 251, 322 
phone number 338-339 
placeholder 113, 382-383 
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Inserting (continued) 
record 153-154, 188 
reference into Spreadsheet formula 219 
return character 81 
row 243, 310 
Spreadsheet formula 217 

text 83 
Int function 281, 292 
Integer function 281, 292 
Integer, entering into cell 214 
Integration between tools See Tools 
Interest rate per period of investment 302 

Internal rate of return 
function 292 
modified, function 296 

International Fanfold 55 
Intersection operator (space) 404 
Investment 

See also Financial functions 
future value 290, 300-301 
interest rate per period 300-301, 302 
net present value 299 
number of periods 298, 300-301 
periodic payment 299, 300-301 
present value 300-301 

Invoice See Form 
IRR function 

Database use incompatibility 147, 275, 292 

defined 283, 292 
IsBlank function 

Database use 147, 275 
defined 283, 293 
Multiplan/Excel/Works differences 406 

IsError function 
defined 283, 293 
Multiplan/Excel/Works differences 405 

IsNA function 283, 293 
Isref function 406 
Italic command 64, 96, 119 , 414 
Italic style 

Command +1 equivalent 414 
Draw text object 28, 64 
footers and headers 56 
text 96, 119 

Itercnt function 406 

Justification 
See also Alignment 
center See Center justification 

Justification (continued) 

copying 105, 119 
defined 98 
full See Full justification 
Draw text object 28, 30, 63-64 
left See Left justification 
right See Right justification 

setting 98, 120 
Justification command 63, 99, 120 
Justified command 64, 120 

Key 
arrow 

moving in Spreadsheet document 212 
selecting Database field 140, 142 

Backspace xix 
combinations, using xix 
Command See Command key 
Command + key See Command + key equivalents; 

Command + specific key 

Delete 
Backspace key equivalent xix 
cell contents editing 212 
character deleting 86 
Command + Option+[ equivalent 413 

erasing Draw text object 30 
paragraph joining 87-88 
phone number deleting 339 
text deleting 86, 88, 158 

End xix 
Enter 

cell, entering information 208, 212 
Database entry inserting 139, 140 

function 39 
Home xix 
macro incompatibility 39, 74 

Option 
Command + Option keys 241, 342, 415 

Draw columns 33 
macro playback 72 

Option+ - (hyphen) 413 
Option + = (equal sign) 413 
Option + Delete 413 
Page Down xix 
Page Up xix 
Return 

blank line inserting 82 
cell, entering information 212 
Database entry inserting 139, 140 
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Key (continued) 

Return (continued) 

drawing text object 30 

entry activating 142 

insertion point positioning 83 
paragraph ending 81 

return character entry 81 

Sh?f?if‘ ^ COmbination See herein Shift + Return 

cell selection extending 211 

drawing perfect shapes 19 

dfawing> selection of multiple objects 21 
Shift + Return 

cell, entering information 212 

Database entiy inserting 139, 140 
Shift + Tab 

cell, entering information 212 

Database entry inserting 139, 140 
spacebar 

blank cell display 213 

insertion point positioning 83 
Tab 

assigning to macro 39 

cell, entering information 212 

Database entiy inserting 139, 140 
entry activating 142 

insertion point positioning 83 
macro recording 38, 73 
margin setting 57 

Shift key combination See herein Shift 4- Tab 
tab stop, moving to 103 
text replacing 93 

Key column 242-243, 313 
Key field 180, 203 

Keyboard command 

recording in macro 37, 73 
type styles 96, 248, 414 
using 413-414 

Keyboard, extended xix, 39 

Keypad, Communications 361 

Label See Cell label; Column heading; Column 

label; Continuous labels; Mailing label- 

Multiple-column labels; Row label; Row heading 
LaserWriter printer s 

driver specification 409 

font substitution 70, 410 
options 409-410 

PostScript LaserWriter printer 95 

LaserWriter printer (continued) 

printing, custom size paper 55 
Last cell 210, 234, 314 
Last Cell command 210, 234 314 
Left alignment 

cell content 247, 318 

Database entry 197 

footer or header 56 
Left command 

cell border 249, 319 

justification 63, 120 
Left justification 

Draw text object 28, 30, 63-64 
text 98, 120 

Left tab stop 103, 118, 422 
Len function 406 

Less than operator (<) 223 

Less than or equal to operator (=$) 223 
Letter See Form letter 
Letter size paper 55 

Limitations, data 415 
Line 

See also Drawing 

automatic adjustment 81 
blank line 

deleting 87 

inserting 82 

break, manual 81 

dashed See Dashed line 

dotted^ automatic page break indicator 83, 105, 

drawing See Drawing 
indenting See Indentation 
selecting 84 

spacing See Line spacing 
Line chart 

See also Combination chart; Series chart 
creating See Series chart 
defined 257 

labels See Column labels; Row labels 
use suggestions 258, 326 

Line pattern See Drawing 

Line Pattern menu 16, 24, 32, 46, 63, 68 
Line spacing 

copying 105, 119 

multiple-column labels 97, 388 
setting 97-98, 120 

Linest function 406 
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See Microsoft Excel; Microsoft Linked spreadsheets 
Multiplan 

Linking columns, in Draw 34-36 
List box defined 48 
List window 

copying to Spreadsheet document 374 
copying to Word Processor document 368 

Database entry 
inserting 139 
selecting 142 

Database report definition 175 

display 137, 194 
field 

adding 136, 189 
moving 151 
sizing 150 
sorting 161 

Form window, switching to 137, 1V4 

grid setting 154 
information copying 155 
panes 152-153 
record 

inserting 153, 188 
matching 191 
selecting 142 
sorting See Sorting 

report window, changing to 183 
splitting 152-153 

Ln function 281, 293 
Local defined 417 
Log off, Communications 341, 353 
Log 10 function 281, 294 
Logarithm functions 

base 10 281, 294 
natural logarithm 281, 289, 293 

Logarithmic scale See Semi-loganthmic scale 

Logest function 406 
Logical functions 

Database use 147, 275 
defined 283 

Logical value 
function argument 278 
Multiplan/Excel/Works differences 405 

Lookup function 
Database use incompatibility 147, Zlo, zw 

defined 284, 294 
Multiplan/Excel/Works differences 405,406 

MacBinary format 350, 356, 357 

Macintosh II 415, 419 
Macintosh applications 

copying to Microsoft Works 369 
exporting documents to 401 
importing files from 397-401 

Macintosh Plus 415, 419 
Macintosh SE 415, 419 
Macro 

canceling 38, 74 
defined 37 
deleting 43, 73 
file See Macro file 
function key, assigning to macro 39 
keys which cannot be used 39, 74 

new feature 422 
playback 

locations 38 
method 39-40, 72 
Option + Delete equivalent 413 

problems 43 
speed 40, 73, 75 

recording 
keyboard commands 37, 73 
macro file must be open 40 
method 38-39, 73-74 
Option + key equivalents 413 

pauses 74-75 
speed 74-75 
stopping 38, 74 
text 37 

saving 42, 73 
stopping in progress, Command + .(period) 

equivalent 43, 414 

Tab key 
assigning to macro 39 
starting macro recording 38, 73 

text recording 37 
troubleshooting helps 43 

Macro command menu 41-43, 72-76 

Macro file 
changes, saving 42, 76 
character limitation 41 
defined 40 
deleting 43, 73 
MicrosoftWorks(keys) file 42, 72 
naming 41, 42, 76 
opening 40-41, 72-73, 75 
saving 42, 73, 76 

Macros Off command 43, 72 
Macros On command 38, 41, 43, 72 



Index 455 

MacWnte file, importing to Microsoft Works 397-398 
Magenta command 71 
Magnifying glass pointer 59 
Mailing labels 

See also Labels 383 
creating 171, 385 

multiple-column See Multiple-column labels 
new features 422, 424 
preparing to print 386-389 
printing 55, 114, 389-390 

Mailing sorting 162 

Make Works Desktop command 53, 421 
Manual, Using Microsoft Works 

description xvii-xviii 

information update on README file xix-xx 
Manual Calculation command 227, 323 
Manual page break See Page break 
Margin 

See also Indentation 
Database report 177, 423 
indentation distinction 102 
setting 57, 102, 118 

Master disk See Microsoft Works 
Match function 

Database use incompatibility 147 275 295 
defined 284, 295 ’ ’ 

Multiplan/Excel/Works differences 405 
Match Records command 

Command+ M equivalent 414 
Database document, full display 165 
printing subset of Database records 384 385 388 
record matching 165, 190-191 

Matching See Finding; Record; Searching 
Mathematical functions 281 
Mathematical symbols, optional 83 
Max function 

cell with 0 or text 278 
Database use 147, 275 
defined 282, 296 

Memory 

availability display 46, 52 
capacities 416 
copying, requirements 365 

Menu See specific mem 
Merge document 

continuous labels See Continuous labels 
customized document, printing 382 384-385 
defined 382 
form letter 390-391 
forms 391-392 

Merge document (continued) 
mailing labels See Mailing labels 
merging 113, 383 

^'colui™ ,abels See Multiple-column labels 
placeholder See Placeholder 
preparing to merge 113, 382-384 
printing 112, 384-385 
use suggestions 381, 390, 391 

Merging See Merge document 
Microsoft Excel 

differences from Works 404-406 
exporting documents to 402-404 
importing from 400 

Microsoft File 398 
Microsoft Multiplan 

differences from Works 404-406 
exporting documents to 402, 404 
importing files from 400 

Microsoft Word 397 
Microsoft Works 

changes in version 2.0 419-424 
copying master disk 393, 420-421 
copying other Macintosh applications to 369 
copying to file server 417 
Desktop See Works Desktop 
disks 

See also Disks 
contents described 393 

exporting documents 401-402 
help from Product Support xx 
importing files See Importing files 
information display 46 

information update in README file xx-xxi 
manual, description xvii-xviii 
MultiFinder use 408 

Multiplan/Excel differences 404-406 
network use 417-418, 424 
new features 419-424 
Program disk See Program disk 
quitting 12-13, 60, 418 
running with MultiFinder 408 
Startup disk 393, 419-421 
System folder 393, 394, 419-420 
system startup information 394-395 419-421 
tools, using together See Tools 
Works Desktop See Works Desktop 

Microsoft Works(keys) file 42, 72 
Mid function 406 
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Min function 
cell with 0 or text 278 
Database use 147, 275 

defined 282, 296 

Minus sign (-) 196, 222 
Minute function 284, 291, 296, 406 

MIRR function 
Database use incompatibility 147, 2/!), m 

defined 283, 296 
Misspelled word See Correct spelling 

Mixed reference 222, 311 

Mod function 281, 297 

Modem 
acoustic coupler 336, 340 

call answering 341, 354 

connection port 361 

defined 335 
dialing 340, 352-353 
disconnection 353 
Hayes modem See Hayes modem 
Hayes-compatible modem See Hayes modem 

phone type setting 360 
Modulator-demodulator See Modem 

Modulus defined 297 
Money format See Dollar format 

Monitor 
black and white 14, 64 

color 
drawing display 25, 64 

text coloring 71 
pixels 14-15, 64 

Month function 284, 288, 297, 406 

Mouse 
cell selection 210 
column width changing 320 
movement, recording in macro 37-38, /3 

Move command 61, 239-240, 309 

Moving 
cell 239-241, 309 
dialog box 263, 268, 325 
drawing See Drawing 

field 
form window 150 

list window 151 
report window 178 

font See Font/DA mover 
information between tools 366-36 /, 4U/ 

Spreadsheet data 61 

tab stop 104 
Tools palette 16 

MsWorksDict file 393, 395 

MsWorksHelp folder 393 
f177 393. 395 

MultiFinder 
effect on memory capacity 416 

running with Works 408 
Multiplan See Microsoft Multiplan 

Multiple-column labels 

defined 385 
merging document 114, 388-389 

new feature 422 
preparing for printing 385-386 

printing 389-390 
Multiple Labels command 114, 388, 422 

N/A error value 298 

N/A value 
finding 314 
Multiplan/Excel/Works differences 405 

numeric value 293, 305 

NA function 284, 298 

Named selection 404 

Naming 
charts See Chart definition 

documents 6-7, 49-50 

field See Field name 

macro file 41, 42, 76 
Natural logarithm functions 281, 289, 293 

Negation operator (-) 222, 223 

Net present value 299 
Network use 417-418, 424 

New command 5, 47 
New features 419-424 
New Page After Total command lSO, 203 

New Pie Chart command 268, 3Z/-3ZV 

New Report command 176 186 199 
New Series Chart command 260-262, 327-72/ 

NewLine setting 359 

None command 319 
Normal command 64, 119, 248, 414 

Not equal operator (^) 223 

Not function 
defined 283, 298 
Multiplan/Excel/Works differences 405 

NOT ON DESKTOP message 384 
Notation conventions, arguments 279 

Now function 284, 298, 406 
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NPer function 283, 298, 300 
NPV function 

Database use 147, 275 
defined 283, 299 

Number 
absolute value 285 
alignment 247 
argument list count 287 
average 286 
comma display 198, 247, 319 
constant value See Constant value 
decimal See Decimal number 
degree to radian conversion 301 
entry into 

cell 211, 214-215 
text field 162 

exponents 214 
formatting 

cell 246-247, 316-318 
field 145, 196-197 

function argument 276, 279 
length, display in cell 214, 250 
negative number 

enclosure 197, 317 
Sign function 302 

positive 302 

radian to degree conversion 289 
random number 301 
recording in macro 37 
remainder 297 
rounding off 302 
serial 280, 288 
square root 303 

totaling Database document numbers See Repoi 
Number sign (#) 214, 250 P 
Numeric field 

See also Number 
calculation 147 
comma inserting 198 
decimal places 197 
display format 145, 196-197 

record selection rule comparison phrases 166 
setting 145, 196 
sorting See Sorting 
totaling 202 

Numeric keypad 361 
Numeric scale defined 263, 327 
Numeric value See Value 

Object drawing See Drawing 
One-and-a-half line spacing 97, 120 
Open Cell Note command 224, 312 423 
Open command 4-5, 47-48, 398-400 
Open Macro File command 40-41, 75 
Open Stack command 394 
Operator, arithmetic 

combining, performance order 223 
defined 222 

Multiplan/Excel/Works differences 404-406 
Option key 

Command + Option key commands 241 342 413 
Draw columns 33 
macro playback 72 

Option + -(hyphen) 413 
Option + = (equal sign) 413 
Option + Delete 413 
Option + key equivalents 46, 413 
Optional character 83 
Options command 125 
Options Menu 320-324 
Or function 

Database use 147, 275 
defined 283, 299 

Multiplan/Excel/Works differences 405 
Or, record selection connector 169-170, 192 
Organize menu commands 186, 190-193, 201-202 
Other command 71 
Outline command 

cell border 249, 319 
type style 64, 119 

Outline type style 28, 64, 119 
Overhead transparencies 255 

Page 

break See Page break 
footer See Footer 
header See Header 

number limitation in Word Processor 
numbering See Page number 
previewing See Print Preview option 
scrolling See Scrolling 
setup See Page Setup command 

Page break 
automatic 

document 416 

dotted line indicator 83, 105, 120 424 
removing 106 
setting 83, 105, 120, 322 
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Page break (continued) 

horizontal 
removing 252, 322 

setting 251, 322 

manual ,.„ .r i 
dashed line indicator 106, 120, 251-2SZ, 

322, 424 
removing 106, 120, 252, 322 

setting 106, 120, 251, 322 

vertical 
removing 252, 322 

setting 251, 322 

Page Down key xix 

Page number 
automatic 83, 105 

display 83 
printing 56, 57 

setting 109, 121 
Page range printing 58 

Page Setup command 
cell note printing 56 
column heading printing 56 

Database restrictions 54 

footer setting 11, 56, 107 

header setting 11, 56, 107 
LaserWriter printer differences 409-41 

mailing label printing 386, 411 

margins setting 57 
page setup options 10-11, 54-57 

printing 
horizontally 253 
reduction 55, 253, 410 

report setup 177 
row heading printing 56 
Spreadsheet document setup 253 

Page Up key xxi 
Painting See Drawing 

Palette See Drawing . 
Panes See List window; Spreadsheet window 

Paper See Printing 

Paragraph 
automatic adjustment 81 

end character 81 

formatting 
copying 105, 119 
indenting 100-102, 118 
justification 98-99, 120 

line spacing 97-98, 120 

margins 102, 118 
ruler display 100, 118 

Paragraph (continued) 
formatting (continued) 

tab stops 103-104, 118 

joining 87 

selecting 84 

Parentheses (()) 
Database formula grouping 196 

function component 276, 278 
negative number enclosure 197, 317 
operator performance order control 223 

Parity 336, 358 
Paste command 

cell editing 62, 212, 226, 235 
Clipboard contents pasting See Clipboard 

Database selection 159, 375 

defined 62 
Draw text pasting 31 
drawn object moving 22 

entry pasting 157 
pasting between tools 367 
pasting drawing See Drawing 

record pasting 156 
Scrapbook information transfer 40/ 

Spreadsheet data 
copying to Database document 372 

moving between documents 61, 309 

moving within document 61, 235 

text 
pasting 62, 88-89 

replacing 92 

Word Processor document 

copying to Database 370 
copying to Spreadsheet 373 

Paste Format command 105, 119, 414 
Paste Function command 187, 276, 310 
Paste with Options command 236-237, 308 

Pasting 
See also Copying; Cutting 
between Macintosh applications 407 

between tools 365-367 

cell 62, 234-237, 308 
Clipboard contents See Clipboard 

Database selection 156-159, 375 

Draw text See Drawing 
drawn object See Drawing 

formulas 235, 308 
function 187, 276, 310-311 
memory requirements 365 
Spreadsheet document selection 235, JOB 
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Pasting (continued) 
text 62, 88-89 

value 236, 308 

Pattern See Drawing 

Pattern matching See Finding; Match Records 
command 

Pauses in macros See Macro 

Percent formatting 197, 246, 317 
Percent sign (%) 197, 317 

Periodic payments 299, 300-301 
Personal computer calling 343 
Personalizing master disk 420 
Phone book 338-339 
Phone number 

adding 338-339, 352-353 
changing 339 

dialing 340, 352-353 
length 339 

number allowed 338, 353 
removing 339 

storing with Communications document 339 
Pi function 281, 299 

PICT resources 407 

Pictures See Drawing 
Pie chart 

canceling 269 

chart definition 268, 327-328 
chart title 268, 328 

creating 267-269, 327-328 
defined 255, 267 

number of rows allowed 415 
plotting 268-269, 328 

value titles 268, 328 
Pixel See Drawing 

Placeholder 

continuous labels 387 
defined 113, 382 

display 114, 384 

formatting 384 

inserting 113, 383 

multiple-column labels 388 

printing customized document 385 
Playback And command 39, 43, 72, 413 
Playing back a macro See Macro 
Plotting 

pie chart 268-269, 324, 328 

series chart 262-266, 324-327 
Plus sign ( + ) 196, 222 
Pmt function 

Database use 147, 275 

Pmt function (continued) 
defined 283, 299, 300 

Point marker defined 258 
Pointer 

arrow 84, 149-152 
cross 18 

hand 59, 150 

I-beam 29, 84 

magnifying glass 59 
moving pointer 

Communications terminal emulation 359 
using keys xix 

question mark 9, 69 

two-way arrow 149, 150, 152 
Polygon drawing See Drawing 

PostScript LaserWriter printer 95 
Prepare to Merge command 113, 382-383 414 
Preprinted forms 392 
Print command 

canceling printing 12 
cell range printing 254 

Command-I-P equivalent 414 

document printing 12, 57-59, 414 

LaserWriter printer differences 409 
merge document printing 384 
report printing 183 

Spreadsheet document printing 253 
Print Merge command 

customized document printing 382, 384-385 
documents merging 112, 382 

mailing label printing 389-390 
Print Preview option 

customized document previewing 385 

Database report totals previewing 182 
document previewing 12, 58 

header/footer previewing 107, 108 
new feature 421 

Print Window command 10, 12 59 254 
Printer 

Apple LaserWriter See LaserWriter printer 
color 25, 71 

font substitution 70, 71, 94, 394 421 
ImageWriter See ImageWriter printer 

LaserWriter See LaserWriter printer 
PostScript LaserWriter 95 

Printer driver requirements 394 
Printer message 183 
Printing 

active window 10, 12, 59 254 
all cells 253 
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Printing (continued) 

ampersand (&) 56 

canceling 12, 58 

cell note 56, 254, 312 

cell range 254 

color 
drawing 25 

text 71 
column heading 56, 253 
Communications document 10 

customized document 382, 384-385 

date 56 
document See Document 

document name 56 

drafts 58 
enlargement 410 

fonts See Font 
horizontally 55, 253 
mailing labels See Mailing labels 
merge document See Merge document 
multiple-column labels See Multiple-column labels 

number of copies 58 
orientation setting 55 

page number 56, 57 

page range 58 
page setup options 10-11, 54-57 

paper 
computer paper 55 
continuous form 55, 58 

European letter size 55 

feed 58 

height 56 
International Fanfold 55 

message 183 
single sheets 58 
size specification 11, 55, 56, 177 

US legal size 55 
US letter size 55 

width 56 
partial document 58 

preset options 12 
preview See Print Preview option 

quality 57-58 
reduction 55, 253, 410 

report 
new page following subtotal 180, 203 

orientation setting 177 

procedure 182-183 

subtotals 203 

resolution 57-58 

Printing (continued) 
row heading 56, 253 

smoothing 410 
Spreadsheet document 252-254 

Spreadsheet formula 321 

time 56 
value, formatted 321 
window, active 10, 12, 59, 254 

Product Support xx 

Program disk 
contents 393 
copying to floppy disk 421 

personalizing 420 
README file location xix 

saving files to 395 
Prometheus Products, Inc. 358 
Proper noun capitalization, checking 126 

Protected command 251, 322 

Protecting cells 250-251, 322 
Protocol, Communications 337, 356-30/ 

PV function 
Database use 147, 275 

defined 283, 300 

Question mark pointer 9, 69 
Questions, help from Product Support xx 

Quit command 12-13, 60, 414 

Quitting 
a document See Saving 
Microsoft Works 12-13, 60, 418 

Quotation mark (”) 
file importing message 401 

cell labeling 214 

Radian, conversion to degree 289 

Radians function 282, 301, 406 

Rand function 281, 301, 406 

Random number 301 
Range reference 276, 278-279 

Rate function 
Database use 147, 275 

defined 283, 300, 302 
Read/Write privileges 418 

README file xix-xx 
Recalculating See Calculation; Spreadsheet formula 

Receive File command 349, 356 
Receiving a file See Communications 
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Record 

See also Field 

appearance changing 143 

comparison See List window; Record selection 
rule 

contents 132 

copying 155-156 

copying from Word Processor document 369-370 
copying to Word Processor document 368 

criteria matching See Record selection rule 
defined 132 
display 

all records 168, 171, 192, 193, 202 

merge document record 114, 383 

record as form or in list 137, 194 
inserting 153-154, 188 

matching 164-165, 190-191, 414 

number allowed in Database 416 
selected records saving 52 
selecting 

in list window 142, 191 

in report window 202 
sorting See Sorting 

Record future delays, macro recording 74 
Record indicator, defined 141 

Record Pauses command 40, 75 

Record previous delay, macro recording 74 
Record Selection command 

Database records subset 
creating 171, 384 

printing 385, 390 

record selecting 382 

record selection rule creating 167, 191, 201 
Record selection rule 

adding rules 170 

changing 170, 192 

comparison phrase 
defined 166 

list 166, 192 

range setting 169 

complex rules 169, 192 

components 166 

connectors 169-170, 192 
creating 167, 191, 199, 201 
deleting 171, 192 
defined 166 

linking 169 

number allowed 192 
range setting 169 

report definition creating 175 

Record selection rule (continued) 
simple rules 167 

subset of Database records, creating 171, 384 
transfer between windows 183 

Recording a macro See Macro 73 
Red command 71 

Reduction See Printing 
Reference 

absolute reference See Absolute reference 
changing 219-221, 311 
circular 224 

column inserting, adjustment 243 
defined 208, 218 

difference between absolute and relative 219 
inserting into argument 276 

inserting into Spreadsheet formula 219 
mixed reference 222, 311 

moving cells, adjustment 239 

relative reference See Relative reference 
row inserting, adjustment 243 

Relative reference 

cell moving 241, 309 

changing to absolute reference 219-220, 311 
column copying, adjustment 311 
copying 234, 239, 309, 311 
defined 218 

row copying, adjustment 311 
sorting, adjustment 242 

Remote defined 417 

Remove Page Break command 106, 120, 252 322 
Removing See Closing; Deleting 

Repagination See Page break 

Replace command 93, 116, 414 
Replacing 

See also Deleting; Finding; Searching 
file 7, 50 6 

misspelled or unknown word 122 
text 92-93, 116-117, 414 

Report 

defined 173 

definition 

changing 184 

components 175 

creating 175-176, 199 
defined 173, 175 

duplicating 184, 199-200 
erasing 184, 200 

number allowed 184 

selecting 183, 184, 198 

storing 176, 181, 199, 200 
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Report (continued) 
definition (continued) 

title 181, 201 
example 174 

field 
arranging 178 

key field 180, 203 

removing 178 
subtotaling 180, 203 

totaling 179, 202 

widening 178 

font changing 181 

grid, removing 181 

margins 177 
paper size setting 177 1Qa 
previously defined report, selecting 184, 198 

new page following subtotal 180, 203 

orientation setting 177 

procedure 182-183 

subtotals 180, 203 

revisions 183-184 

selecting 183, 184, 198 

subtotals 
preview 182, 201 

printing 180, 203 
procedure 180, 202, 203 

summary document 182, 201 

title changing 181, 201 

totals 
preview 182, 201 
procedure 179, 202 

type color or size changing 181 

Report menu commands 198-200 

Report window 

closing 181 
commands 201-203 

edge markers 177 

field selecting 176 
new features 423 
opening 176, 183,199 

record selecting 202 
record selection rules transfer 183 

report definition 175 
report printing 182-183 
switching to list/form windows 183 

Rept function 406 
Resizing See Drawing 
Resolution, printing 57-58 

Return character 

entry 81 
finding 115, 422 

replacing 116 

Return key 
blank line inserting 82 
cell, entering information 212 

Database entry 

activating 142 
inserting 139, 140 

drawing text object 30 
insertion point positioning 83 

paragraph ending 81 
return character entry 81 
Shift key combination See Shift + Return 

Reversing a command See Undo command 

Rich Text Format 
file exporting 7, 51, 401 

file importing 398 

new feature 422 

Right alignment 
cell content 247, 318 

Database entry 197 

footer or header 56 

Right command 
cell border 249, 319 
justification 64, 120 

Right justification 
Draw text object 28, 30, 64 

text 98, 120 
Right tab stop 103, 422 

Risk defined 296 
Rotary dial phone 360 
Round function 281, 302 

Row 
charting See Series chart 
column width adjusting 320 

copying 311 
copying to Database document 371 
copying Word Processor selection to 372 

filling 238, 311 
freezing scrolling 324, 424 

heading 
defined 208, 218 

freezing 324 
printing 56, 253 

inserting 243, 310 Q1 
intersection with column, cell value display 291 

label 263, 265, 326 

named row 404 
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Row (continued) 
number allowed 

in pie chart 415 

in Spreadsheet document 415, 421 
selecting 211 

sorting 241-243, 312-313 

transposing with column 237, 263 308 
Row function 406 

Rows function 406 

RTF See Rich Text Format 
Ruler 

calibration 118 

continuous label printing 387 
defined 100 

display 100, 118 

indentation 100-102, 118 
tab stop 103-104, 118 

Safe defined 296 

Sample standard deviation 304 
Sample variance 305-306 
SANE package 404 
Save As command 

Database document saving 7, 52, 171 
document saving 6, 7, 50 
file exporting 7, 51, 401 

Save command 7, 49, 414 

Save Macro File As command 42, 76 
Save Macro File command 42, 76 
Saving 

chart definition 325-326, 328 
closing 

a document 8, 48 

all documents 49, 421 

Communications 
document 343 
file 349 

settings 338, 343, 358 

text, during a session 341, 349, 354 

text, when document opens 348, 361, 424 
Database document 51-52, 171 
document 

all open documents 49 

arrangement See Works Desktop 
filename conventions 6 
frequency 5, 49, 83 
new name 6, 7, 50 

same name 7, 49 

saving to another disk 395 

Saving (continued) 
document (continued) 

text file method 7, 51 

file arrangements 13 
file changes 49, 50 

macro file 42, 73, 76 

report definition 176, 181, 199 200 
selected records 52 

Scale, series chart 263-265, 327 
Scientific notation 

See also Exponentiation 
Database document 197 
defined 197, 317 

Spreadsheet document 214-215 246 317 
Scientific symbol 83 
Scrapbook 

copying or moving information to or from 

Macintosh applications 369, 407 
drawing 

exporting 376, 407 
importing 37, 407 

Screen See Pixel; Scrolling 
Scrolling 

Database document 133 

Go to Page # command 117, 414 
list window panes 152-153 
macros 38 

page number display 83 

Spreadsheet window panes 229 

Search and replace See Replace command 
Search function 406 

Search Menu commands 114-117 
Searching 

See also Finding; Replacing 
alert box 115, 117 

alphanumeric character 115, 116 
canceling 115, 117 

capitalization option 91, 115, H6 
Find Field command 164, 190 

Match Records command 165, 190 

record selection rule See Record selection 
replacing See Replacing 
return character 115, 116, 422 

Spreadsheet table value search 290 
tab 115, 422 

text 90-91, 114-115 
text field only 190, 191 

whole word option 90, 115, 116 
Second function 284, 291, 302, 406 

rule 
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Select All command 
document printing 62, 85, 211 

new feature 423 
Spreadsheet document printing 253 

Select Chart Definition command 260, 268, 2/1, 

Select menu commands 314-315 
Select Report command 183, 184, ivo 

Selecting 
See also Finding; Searching 

cell See Cell 

chart 271 
column 211 
Database document for merging 113, 382-3 

document 62, 85, 211 

dragging method 85 
drawing See Drawing 

entry 138, 142 

field 
list window 142 
report window 176 

font See Font 
last cell 210, 234, 314 

line 84 
paragraph 84 

record 
list window 142, 191 

report window 202 

report 183,184, 198 
report definition 183, 184, 198 

row 211 
text 84-85 
text in entry bar 158 
Works Desktop file 12, 60 

Selection, named 404 
Selection rule See Record selection rule 

Semi-logarithmic scale 263-264, 327 

Send File command 347, 351 
Send Text command 346-347, 355 
Send to Back command 27, 66, 414 

Serial number 280, 288 

Series chart 
bar chart 257-259, 263, 326 

canceling 267, 325 
chart definition 260, 325-326 

chart title 262, 326 
column specifying 263 
combination chart 256, 259, 326 

creating 260-267 
data limitations 415 

defined 255 

Series chart (continued) 
grid 265 
horizontal scale 262, 326 

horizontal title 263, 326 
information choosing 262 
label See Column label; Row label 

line chart See Line chart 

numeric scale 263, 327 
plotting 262-266, 324-327 

row specifying 262-263 

scale 263-265, 327 

scale titles 262, 326 
semi-logarithmic scale 263, 327 

stack chart 258, 326 
transposing columns to rows 237, 263, 3U8 

types 256, 262 
values plotting 326 
vertical scale 263-264, 327 

Server, file 417 - 
Set Cell Attributes command 246 316-319, 4Z3 

Set Field Attributes command 145, 14/, tV5-iv/ 

Set Page # command 109, 121 
Set Page Break command 251, 322 
Setting up a page See Page Setup command 

Settings command 338, 356 

Shadow command 64, 119 
Shadow type style 28, 64, 119 
Sharing documents See Network use 

Shift key 
cell selection extending 211 

drawing perfect shapes 19 
drawing, selecting multiple objects 21 

Shift + Return 
cell, entering information 212 
Database entry inserting 139, 140 

Shift+Tab 
cell, entering information 212 
Database entry inserting 139, 140 

Show Active Cell command1 234 315 
Show All Records command 168, 171, 192, 193, 2uz 

Show Clipboard command 68 
Show Column Boxes command 66 
Show Field Data command 114.384 
Show Field Names command 114, 382, 384, 

Show Form command 137, 194, 414 

Show Formulas command 228, 321 

Show Grid command 
Database grid display 155, 195 

report printing 181, 202 
Spreadsheet grid display 249, 320 
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Show List command 137, 194, 414 

Show Notes Indicator command 224, 312 321 
Show Ruler command 100, 118 

Show Values command 228, 321 
Sign function 281, 302 

Sin function 282, 303 
Sine 282, 303 

Single spacing 97, 120 
Six lines per inch spacing 97, 388 
Size command 71, 95 
Size, type See Type size 

Sizing drawing See Drawing 

Sketching See Drawing 

Skipped word dictionary See Correct spelling 
aiasn (/), division operator symbol 196 222 
Slides 255 

Small Window command 422 

Smoothing, print quality 410 
Sort command 

Database document sorting 162, 193, 414 
Spreadsheet document sorting 243, 312 

Sort order See Sorting 
Sorting 

address list 162 

alphabetical order 161,162, 193 
ascending order 241, 243, 313 

chronological order 161, 162, 193 
columns 241-243, 312-313 

descending order 241, 243, 313 
empty cell 241 

fields 161-163, 193, 414 

key column 242-243, 313 

multiple columns 242 

numeric order 161, 162, 193 
performance order 

Database document 193 

Spreadsheet document 313 
records 161-163, 193 

reference adjustment 242 
row 241-243, 312-313 
subgroups 242 

Source, The 342, 353 
Spacebar 

cell, blank display 213 

insertion point positioning 83 

Spacing See Alignment; Line spacing 
Spacing command 98, 120, 388, 422 

Special-Purpose functions 284 
Spell Menu commands 121-128 

Spelling checker See Correct spelling 

Split bars 

list window panes 152-153 

Spreadsheet window splitting 229 
Spread Text command 32, 67 
Spreadsheet 

calculation 227, 323 
chart See Chart 

Command + key equivalents 413 
data limitations 415 
defined 205, 207 

document See Spreadsheet document 
drawing See Drawing 
file See File 

font 70, 394, 422 

formula See Spreadsheet formula 
functions See Function 

importing files to 400-401 
label See Cell label 

memory capacity 416 

moving data between documents 61 309 

Multiplan/Excel/Works differences 404-406 
new features 423-424 

Paste command properties 62 

protection of cells 250-251, 322 
Select All command use 62 
use suggestions xvi 

Spreadsheet document 
activating 325, 328 

calculation 227, 323 
cell See Cell 

cell note See Cell note 

changes, effect on chart 272 
chart See Chart 

circular reference 224 
color of text 71 

column See Column 

constant value See Constant value 

copying Database information to 374-375 
copying selection 235-236 

copying to Database document 371-372 

copying to Word Processor document 368 

copying Word Processor document to 372-374 
creating 47 

date entry 215, 280, 317 
described 208 

drawing See Drawing 

entering information See Cell 
exporting 401-402, 404-406 
font 70, 394, 422 

formatting 245 
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Spreadsheet document (continued) 
function See Function 
grid lines 249, 265, 320 , . , 
label See Cell label; Column label; Row label 

moving selection 239-241, 309 

page break 
removing 252, 322 

setting 251, 322 

planning 209 

printing 
active window 254 

cell notes 253 
horizontally 253 
page set up 251-252 
procedure 252-253 

protection of cells 250-251, 322 

row See Row 
Scrapbook use 407 

selecting 209-211 
sorting See Sorting 
time entry 215, 280, 318 
tvpe color or size 71 
window panes See Spreadsheet window 

Spreadsheet formula 
See also Function 
arithmetic operator 222, 223 

calculation 
automatic 217, 222, 227, 323 

manual 227, 323 
cell range reference 278 

copying 234-235 

defined 208, 216 
display 216, 217, 228, 321 

editing 226 
entry into cell 211, 217 

equals sign ( = ) entering 211, 216, 2/8 

function argument 276 
function entering 276-278, 310 

length 415 
pasting 235, 308 

reference See Absolute reference; Reference; 

Relative reference 

Spreadsheet window 

example 208 
panes 229-231 

Sqrt function 281, 303 

Square root 281, 303 

SSum function 
cell with 0 or text 278 

SSum function (continued) 
Database use 147, 275 

defined 282, 303 
Multiplan/Excel/Works differences 406 

Stack chart 258, 326 . 
Standard Apple Numeric Environment package 404 

Standard deviation See Sample standard deviation 
Start Recording command 38, 41,73 

Start Recording macro. Option + - e9ul^a'®nl 
Starting Microsoft Works See Microsoft Works, 

Open command 

Startup disk 393, 419-421 

Statement See Form 

Stationery file 51, 421 

Statistical functions 

defined 282 
StDev function 

cell with 0 or text 278 
Database use 147, 275 

defined 282, 304 

Stop EcoKhng3 macro, Option +-(hyphen) equivalent 

413 
Stop Recording command 38, 41, 74 

Stopping macro See Macro 

Style command 
Draw text object 64 

text 95, 120 
Subscript command 119 

Subtotals See Report 
Subtraction operator (-) 196, 222, m 
Suffixes, adding to new dictionary word 12 

Sum function 
cell with 0 or text 278 

Database use 147, 275 

defined 282, 293, 304 

Sum This Field command 

field 
subtotaling 180 

totaling 179 
report totaling 202 

Summary document 182, 201 

Superscript command 119 

SYLK file 
Database restriction 399 

defined 397, 400 
exporting file as 402 
importing 400-401, 404-406 
Word Processor restriction 398 
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Symbols 

arithmetic operators 196, 222 
comparison operators 223 
entry into cell label 214 

optional characters 83 

special symbols used with Works xix 
Syntax of functions 276 

System folder 393, 394, 419-420 
System version 6.0 

requirements for Works version 2.0 394, 419 
upgrading from previous systems 420 

Tab key 

assigning to macro 39 

cell, entering information 212 
Database entry 

activating 142 

inserting 139, 140 

insertion point positioning 83 
macro recording 38, 73 

Shift key combination See Shift + Tab 
tab stop, moving to 103 
text replacing 93 

Tab stop 

center 103, 118, 422 
copying 105, 119 

decimal 103, 118, 422 
deleting 104 

display 103, 118 

finding 115, 422 
left 103, 118 

moving 104, 118 

moving to 103 

new features 422 
preset 103, 118 

replacing 116 

right 103, 118 

table creating 104 
Table creating 104 

Take a Sub-Total on 1st Char command 180 203 

TakC203 U423°tal °n FieId Change command 180, 

Tan function 282, 304 
Tangent 282, 304 

Telephone See Communications; Modem; 
Phone number 

Template 

columns using Draw 37 

Template (continued) 
file template 51 

Terminal emulation 345 359 
Text 

argument value 278 

automatic word wrap See Wordwrap 

capture See Communications 
cell, entering text in 211 
centering 98, 120 

color See Coloring 

Communications text See Communications 
copying selection 61, 89 

copying to or from Scrapbook 407 
copying with drawn object 378 

correction See Correct spelling 

creating text object from normal text 379 
cutting 88 

defined 28, 81 

deleting 62, 86, 88 

entry bar text 158 

finding 90-91, 114-115 
font See Font 

inserting 83 

justification See Justification 
matching See Finding 

moving to or from Scrapbook 407 
object See Drawing 
pasting 62, 89 

recording in macro 37 

replacing 92-93, 116-117, 414 
searching 90-91, 114-115 
selecting 84-85 

sending to another computer 346-347 355 
size See Type size 
subscript 119 

superscript 119 

type style See Type style 

wordwrap See Wordwrap 
Text field 

See also Field 

number, entry into 162 

record selection rule See Record selection rule 
searching 190, 191 
setting 145, 196 

sorting 162-163, 193 
zip codes 162 

Text file 

defined 7, 397 

exporting 401-402 
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Text file (continued) 
importing 397-400 

saving file as 7, 51 

Text function 406 
Text object See Drawing 

Time 
current time 

entering into field 146, 414 

serial number 298 

display 146, 280, 318 

entry method 
cell 215, 280, 318 
field 146, 196, 414 

formatting 
cell 215, 280, 318 

field 146, 196 
functions 280, 284 
importing in Spreadsheet file 400 

printing 56 
serial number 280, 291, 304-305 

Time field 
See also Time 
current time entering 146, 414 
record selection rule comparison phrases 166 

setting 146, 196 
sorting 162-163, 193 

Time format See Time 

Time function 
defined 284, 304, 406 

new feature 423 
time stored as serial number 280 

chart definition title See Chart definition 

chart title 
pie chart 268, 328 
series chart 262, 326 

column See Column 

freezing title 324, 424 
horizontal title 263, 326 

scale titles 262, 326 

value titles 268, 328 
vertical title See Data legend 

Title Page command 11, 109, 121 

Title page setting 11, 109, 121 

Tools 
See also Common Tasks; Communications; 

Database; Drawing; Spreadsheet; 

Word Processor 

copying between 365-367 

data limitations 415 

Tools (continued) 
formatting integrated document 379 

memory capacities 416 
using the tools together xvn, 363-365 

Tools folder 393 
Tools palette See Drawing 

Top command 249, 319 
Total on Field Change command 423 

Total-1st Char Field command 423 

Totals See Report; Sum function 
TotalsPage menu 179, 186, 202-203 

Touch-Tone phone 360 

Tour disk 394 
Transparencies 255 
Transpose function 406 
Transposing columns and rows 237, 263, 3U8 

Trend function 406 
Trigonometric functions 282 

True function 
defined 283, 305 
Multiplan/Excel/Works differences 405 

numeric value 278 

Tutorial folder 

location 393 
moving, deleting 395 f ... 01S 

Twelve-hour/twenty-four-hour time format 14b, ztb, 

280,318 
Two-way arrow pointer 149, 150, 152 
Type See Coloring; Font; Type size; Type sty e, 

Value 
Type function 284, 305, 405, 406 

Type size 
Draw text object 28, 30, 71 

text 71, 95 

Type style 
See also Font 
bold See Bold style 
italic See Italic style 
normal 64, 119, 248, 414 

filing, o A 1 A 

Command + key equivalents 248, 414 

Database document 198 
Draw text object 28, 30, 64 
Spreadsheet document 248, 319, 414 
Word Processor document 95-96, 119, 414 

shadow 28, 64, 119 

outline 28, 64, 119 
underlining See Underlining 
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Underline command 64, 119, 248, 414 
Underlining 

Command + U equivalent 248, 414 
Database selection 198 
Draw text object 28, 64 

Spreadsheet selection 248, 319, 414 
Word Processor selection 119, 414 

Undo command 

clearing undoing 158, 159 

Command + Z equivalent 414 
cutting undoing 158 

deleting undoing 86, 158, 159, 189 
drawing mistake undoing 20 

Edit menu command undoing 61 
ineffective 61 

Ungroup Picture command 

Command + U equivalent 414 
drawing 

copying between tools 377 
resizing 23 

ungrouping 25, 65, 414 
Union operator (,) 404 

US legal size paper 55 

US letter size paper 55 

Value 

See also Number; Function 
charting See Chart 

constant value See Constant value 
copying 235, 236, 308 
defined 245 

display values 228, 321 

error See Error value 

format/value distinction 216, 245 

formatting 196-197, 245, 316-318 
function argument 276, 279 

investment See Investment 
matching 295 

numeric representing logical value 278 
pasting 235, 236, 308 

plotting See Plotting 
printing 321 

titles 268, 328 
type 305 

Value function 406 

Value title defined 268 
Var function 

cell with 0 or text 278 

Database use 147, 275 

Var function (continued) 
defined 282, 305 

Multiplan/Excel/Works differences 406 
Variance, sample See Sample variance 
Vertical page break See Page break 
VLookup function 

Database use incompatibility 147 275 290 'WK 
defined 284, 290, 306 ’ 306 

Multiplan/Excel/Works differences 405 406 
VT52 terminal emulation 

escape codes 425-427 
new feature 424 
setting 345, 359 

VT100 terminal emulation 
escape codes 425-427 
new feature 424 
setting 345, 359 

Weekday See Date 

Weekday function 284, 288, 306, 406 
White command 71 

Whole word, finding 90, 115, 116 
Window 

activating 69, 414 

active, printing 10, 12, 59, 254 
cell note 224, 312 

form See Form window 

help window 9-10, 68-69 
list See List window 

location, size stored with document 49 
number allowed open 3, 47, 424 

panes See List window; Spreadsheet window 
printing 10, 12, 59, 254 

report window See Report window 
size changing, new feature 422 

Spreadsheet See Spreadsheet window 
Window menu commands 68-69 

Word See Microsoft Word; Text 
Word Processor 

command directory 111 

Command + key equivalents 413-414 
drawing See Drawing 
file See File 

importing files 397-398 
memory capacity 416 
new features 422 

Select All command use 62 
use suggestions xvi 

wordwrap See Wordwrap 



470 Word Processor document Zoom box 

Word Processor document 
captured Communications text 338, 348 

color of type 71, 95 

copying 
between Word Processor documents 368 

Database document to 367-368 
information to Database document 369-371 
information to Spreadsheet document 372-374 

Macintosh applications to 369, 407 

Spreadsheet document to 367-368 

text and drawn objects together 378 

text selection 61, 89, 368 

creating 47, 80 
drawing See Drawing 13 

example 80 

font 70, 394, 422 
footer See Footer 

formatting 97, 105 

header See Header 
indentation See Indentation 

label printing See Mailing labels 

margins See Margin 
merge document See Merge document 

number of pages allowed 416 

paragraph See Paragraph 
sending text to another computer 346-347, 

tab stops See Tab stop 

table creating 104 
template See Template 

text file See Text file 

type size 71, 95 
type styles 95-96, 119, 414 

typing 81 

Wordwrap 
Auto-wrap, Communications setting 3o'? 

defined 81 
line, paragraph adjustment 81 

placeholder 384 

Works Desktop 
described 3-4 
number of windows open 3 

renaming file 13, 53 

saving to file n „ 
Make Works Desktop command method U, dj 
Quit command method 12-13, 60 

selecting file 12, 60 
untitled documents 13 

Works See Microsoft Works 

Works Tour 394 

Works-Works Transporter file 
AppleWorks file conversion 402-403 

location on disk 393 

Wrap See Wordwrap 
WYSIWYG See Print Preview option 

Xmodem Data 355, 356 

Xmodem Text 356 

Year function 284, 288, 306, 406 

Yellow command 71 

Zip code, text field use 162 

Zoom box 422 
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