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NTIL NOW THE POWER of CAD was for 

the technical elite. Because it took an 

engineer to master the complex commands 

and concepts required to use Computer Aided 

Design. No longer. Now there is Key CAD 

Complete, the next generation that puts high 

performance CAD at anyone’s fingertips. 

Why is CAD So Useful? 

CAD turns your MAC into a precision design 

and drafting tool. You can produce drawings, 

plans and layouts to perfect scale and accuracy. 

At home you’ll use Key CAD to plan an 

addition or renovation to your house, create a 

school project or design a piece of furniture. 

Key CAD’s powerful floating point coordinate 

system automatically calculates distance and 

dimensions. 

At work you'll produce mechanical, architec- 

tural, construction, manufacturing and civil 

engineering drawings, electrical schematics, 

office layouts, business graphics, flow charts 

and diagrams. 

Whether you’re an inventor, a hobbyist, 

craftsman, electrician, architect or contractor, 

Key CAD takes you step by step from conception 

to realization. 

But that’s only the beginning. With Key CAD 

you’re only limited by your imagination. It’s so 

powerful and intuitive you can use your Mac 

for film animation or even drive a sophisticated 

computerized engraving device. 

Only With Key CAD Complete 

You Get Features Like These! 

EDITING: Modify « Cut ¢ Copy e Paste ¢ Skew 

e Scale  Rescale @ Radial and Linear Duplicate 

e Move e Rotate * Mirror e Flip ¢ Delete e Fillet 

e Inverse Fillet ¢ Chamfer ¢ Text Import 

e Resize .¢ Text Block « Extend Trim e Fill © Join 

e Unjoin ¢ Group ¢ Ungroup e Lock ¢ Unlock 

e¢ Nudge ¢ Automatic Snap To. 

- DRAWING: Line (multiple line styles or choose 

your own thickness) ¢ Square ¢ Rectangle 

e Oval ¢ Circle ¢ Arc Text © Arrow @ Open or 

closed polygon « Multigon ¢ Free-Formed 

Spline Tool ¢ Shift Key option for perfectly 

straight lines « Absolute, Relative or Polar 

Coordinates ¢ Full Dimension Manipulation 

Toolbox ¢ Scale in mm, cm, m, km, in, ft, ft-in, 

yds or miles. 

DESIGN AND VIEWING: Zoom ® Pan ® Scale 

e View layers @ Precision display options: 

English or metric, fractions or decimals, integer or 

floating point. Build up to 256 levels or overlays 

e Exponential, log and trig functions ¢ Rubber 

Band feature to stretch images ¢ Unparalleled 

UnDo feature restores preceding action ¢ Unique 

memory handling technology allows you to 

create almost any size design ¢ Multiple size, 

styles and fonts in B&W or any color ¢ Choose 

from 16.8 million colors or work with full gray 

scale «© Paper sizes include mechanical, 

architectural, metric, metric oversize or 

custom. Competitive CAD packages without all 

these features cost hundreds of dollars more! 

Save Hundreds Of Hours 

With Key CAD Complete’s 

FREE Symbol Libraries 

Why redraw the wheel when professionals 

have done it already. Included inside are over 

470 symbols for: Home, Office, Mechanical, 

Electrical, Landscape, Interior Design, Electronic 

and more... All symbols are in PICT format. 

SYSTEM REQUIREMENTS: Macintosh Plus or greater, 

PowerBook 140 or greater, minimum 2MB of RAM with 

System 6, 4MB of RAM with System 7 or above. Use mouse or 

keyboard. Supports any size B&W or color monitor. Supports 

any TrueType or PostScript font. Apple Unix compatible. Works 

with all Macintosh compatible dot matrix, ink jet and laser 

printers (including full PostScript support), also supports any 

Hewlett Packard or Houston Instruments compatible plotter. 

impons Exports DXF, IGES, PICT, PICT2, AYZ, XY 

Coordinates HPGL and EPS. Math co-processor supported but 

not required. Hard disk required. 

ISBN 1.2 S6434- 00.3 - 1 
Macintosh is a registered trademark and TrueType is a Trademark of Apple Computer Company. PostScript is a registered trademark of Adobe 
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SoftKey Software Products of 

Florida, Inc. 

PROGRAM LICENSE AGREEMENT 

PLEASE READ THE FOLLOWING TERMS CAREFULLY 

BEFORE USING THIS PROGRAM. 

KeyCAD Complete for Macintosh® is a registered trademark of 
SoftKkey Products International B.V. 

All rights reserved. This program contains proprietary information 

which is protected by copyright. No part of this program may be 

reproduced, transcribed, stored in a retrieval system, translated into 

any language or computer language, or transmitted in any form 
whatsoever without the prior consent of the Publisher. 

NOTICE: SoftKey Software Products of Florida, Inc., Softkey Products 
International B.V., and affiliated companies (collectively the "Publisher") 
make no representations or warranties of any kind whatsoever with 
respect to the contents hereof and specifically disclaim any implied 

warranties or merchantability or fitness for any particular purpose. 
The Publisher shall not be liable for errors contained herein of for 
incidental or consequential damages in connection with the furnishing, 
performance, or use of this program or its contents. 

The Publisher warrants the diskettes on which the software is recorded 
to be free from defects in material and faulty workmanship under 
normal use for a period of 90 days after the date of the original 
purchase. If during this 90 day period, a defect in the diskettes should 
occur, the diskettes may be returned to the Publisher or an authorized 
dealer and the Publisher will replace the diskettes without charge 
provided that you have completed and returned the enclosed registration 

card from the Publisher. 
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KeyCAD Complete for MAC Basics 

Basics 

This chapter discusses the basic layout, on how KeyCAD Complete 

for Mac works. The general layout of the Program Start Up Window 

is displayed with all of the proper names of tools, menus, readouts, 

etc. Each toolbox found within the program is explained in a general 

overview of how those particular tools work. 

This chapter is not intended to provide a step by step explanation of 

each toolbox and readout. To gain a more detailed explanation of 

how to use specific tools, menus or commands, please refer to the 

appropriate chapter in this manual. 
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Edit Toolbox 

The Edit toolbox contains tools that you use on previously designed 
objects. There are only two tools within the Edit toolbox that do not 
edit the shape of predrawn objects. These are the Zoom tool and the 
Text tool. 

Remember that the following tools require that an object or points 
within an object be selected before you perform the Edit function you 
have choosen. These tools are Resize, Skew, Rotate, Fillet, and 

Chamfer. The Selection tool and the Point Select tool are used for 
selecting the objects or groups of points you wish to edit. 

The Edit tools use the mouse and keyboard entry when working with 
objects. When using the mouse, use a click and drag method. If you 
use the keyboard entry you must first have selected the objects or 
points. Then, double click on the Edit tool of your choice. The 
following Edit tools are the only tools that support keyboard entry. 
They are: Selection, Point Select, Resize, Skew, Rotate, Fillet and 

Chamfer tools. The Trim, Zoom and Text tools do not require any 
keyboard entry. 

Selection Tool 

pi <2 

Point Select Tool 

Resize Tool 

Skew Tool 

Rotate Tool 

Fillet Tool 

Chamfer Tool 

Trim Tool 

Zoom Tool 

Text Tool PlekxCh als 
Edit Toolbox 
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The following is a picture of the Snap To tools as they appear in the 

program. The names have been listed for the appropriate tool icon. 

The name indicates the Snap To command that is to be performed 
when using that particular tool. These tools should be used in all 
precise alignment of objects as well as object start or end-points. 

Drag Zone 

Close Button 

Any Point 

End-Point 

Point On 

Center 

Corner 

Intersection 

Perpendicular 

Line Center 

Percentage 

Absolute 

Snap To Toolbox 

NOTE: Refer to the Snap To Tools section of this manual for a detailed 
explanation on how to use these tools. 
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Dimension Toolbox 

The Dimension tools are designed to help create dimension lines that 
appear with witness lines (also called extension lines), which 

automatically represent the correct dimension value or measurement. 
A dimension may contain the size of a particular object or the distance 
between two separate objects. You can create dimension lines for 
diagonal lines that measure the vertical or horizontal distance and 

even the length of the angular line. 

Linear 

Parallel 

Angular 
Dimension tools as 

they appear in the Diameter 

program. Balas 

Leader Lines 

Dimension Toolbox 

One of the most important factors in using these dimension tools, is 

that they are designed to work in combination with the Snap To tools. 

This assures you of an accurate dimension between two designated 

points. 

SoftKey: Changing The Way America Buys Software 1-7 
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Readouts (Position Info) 

In addition to using the Snap To tools for locating specific points on 

your design, you may also use the Readouts found at the bottom of 
your screen. The Readouts are designed to help you in specific point 

locations, angles of lines, and distance or lengths of objects. Readouts 
are primarily designed to be used with the mouse movements on the 
screen. 

Think of the Readouts as a set of gauges that update automatically with 

accurate information as you move the pointer, draw, edit, select, or 

reposition objects. The Readouts are designed to work with English 
or Metric measurement and display feet and inches, or decimal 
equivalence. 

Refer to the Readouts to help draw or edit any object. For example, 
as you position the cursor to draw an object, the Readouts display the 

X and Y coordinates of your mouse cursor, which help you locate the 
exact spot to begin drawing. As you rotate objects, you can check the 
degree of rotation while watching the Readouts angle display. 

Absolute Coordinates 

Note that you have two sets of coordinates. One set reads X, Y 
coordinates and the other reads W, H coordinates. The X, Y displays 
are called the Absolute Coordinates. This means that they track the 
mouse location from the point of origin of the screen. The X, Y 
coordinates assist you on accurate location of the start and end-point 

of the drawing or editing of an object. 

Absolute Nudge 

Buttons 

Absolute Coordinates 
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incremental Coordinates 

The Incremental Coordinates are displayed with the letter (W) for the 
Width and (H) for the Height of any object drawn. 

Select a Draw or Edit tool; click to start the selected function. The W, 

H readout is automatically set to zero(0) to track the actual movement 
of the mouse when drawing or editing an object. 

NOTE: The W,H or Incremental Readouts only display and track the 

start and end-point of your mouse movements. 

Incremental Nudge 4b Ww: 6O.19 
Buttons = H: O.i4 

incremental Coordinates 

Nudge Buttons 

The Absolute and Incremental Nudge buttons are shown in the two 
previous figures. These buttons move a selected object by setting any 
nudge increment. Set the nudging rate under the Nudge subheading 
found under the Edit menu at the top of your screen. The program 
defaults to one pixel nudge rate. 

The Absolute Nudge buttons move the selected object according to 
the nudge rate. This does not change the size of the object, but rather 
changes the location of the object. 

The Incremental Nudge buttons change the width and height of any 
selected object. The center of the selected object is used as a reference 
point, and nudges according to the current nudge rate. 
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Percentage Readouts 

The Percentage readouts are used mainly for the resizing of selected 
objects. When you draw an object, the percentage display shows 
100%, when you release the mouse button. This means that the object 
you have drawn is at 100% size. If you then resize the object using the 
Resize tool, you have the option of resizing by percentage versus using 

the coordinates. The readouts display the width and height percentages. 

100% 
Percentage displays 

= aes 100% 

Radius and Diameter Readouts 

When you are creating arcs or circles, the Radius and Diameter 
readouts display an accurate measurement of the radius or diameter 
of the object you are drawing. 

Radius display 

Diameter display 

Angle Readouts 

This section of the Readouts window, tracks the angular movement of 

the cursor. It is useful when creating angular lines or rotating objects 
to a specific angle. 

Angle display ————- | “4. -350° 59" 
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KeyCAD Complete for MAC Basics 

Menu Bar 

The Menu Bar permits more efficient work within your design. The 
Menu Bar can be turned on or off as necessary. To turn the Menu Bar 
on or off, first pull-down the Layout menu and then select the Menu 

Bar command. Hold down the Command-M keys to turn the Menu 
Bar on or off. 

The commands, tools, and options found within the Menu Bar can be 

accessed within the various menus found at the top of your screen. 

The buttons and pull-down menus have been designed with minimal 
size. They are placed along the edge of the title bar to minimize space 
utilization and allow an unobstructed design environment. 

If you are using a monitor that is smaller than the width of the Menu 
Bar, the program cuts off the options furthest to the right. It omits one 

option at atime, until the width of the Menu Bar fits within your screen 
size. 

The following pages provide a brief definition of each option found 

within the Menu Bar. Please refer to the Menu to access further details 

on selected options. The Menus provide detailed examples on how 
to use these options while creating your design. Refer to the Contents 
Section at the begining of the manual for a list of commands contained 

within each menu. 
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Mirror 
This function permits you to duplicate and flip a selected 
object. The mirrored object is slightly offset from the 
original. To use the Mirror command, first select the 
object then click on the Mirror button within the Menu 
Bar. You can Mirror individual objects or groups of 

objects. 

Flip Vertical 

This button allows you to Flip selected objects along the 
vertical axis. It is comparable to flipping the selected 
object upside down. You can Flip individual objects or 
groups of objects. 

Flip Horizontal 

This button allows you to Flip selected objects along the 
horizontal axis. It is comparable to flipping the selected 

object to the right. You can Flip individual objects or 
groups of objects. 

Group 

This button allows you to consolidate a set of selected 
objects as one grouped object. A grouped set of objects is 
treated as a single object, rather than several individual 
objects. 

Ungroup 

The Ungroup button automatically divides a grouped 
object into individual objects. 

Lock 
This button allows you to Lock the characteristics and 
location of a selected object or groups of objects, so that 
you Cannot change them. 

Unlock 
This button allows you to Unlock selected objects that you 
have previously locked. 
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Join 

This button allows you to connect (Join) all selected lines 

or arcs that share an overlapping (connected) end-point. 

Unjoin 

This button allows you to disconnect all selected lines or 
arcs that have been Joined together. 

Eyedropper 
The Eyedropper button allows you to select the current 

color from any color within your design. Once you click 
the Eyedropper button on a color within your design, that 

color then becomes the current color. The color you have 
clicked on is then displayed in the Color button. 

Current Color 

This button displays the current color within the 
program. Click once on the button to select the color 
picker. 

Grid Lines On or Off 
This button allows you to turn the Grid Lines on or off. 
This function is dependent on the current status of the 

Grid Lines when you click the button. Set the Grid 
spacing under the Grid pop-up menu found under the 

Layout menu. 

Snap To Grid 

This button allows you to quickly turn the Snap To Grid 
option on or off. 

Axis Lines On or Off 

This button allows you to toggle the Axis Lines, on or off. 
The Axis Lines represent the Origin point. This is the 

reference source for all Absolute coordinates and 

Readouts. 
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Fit to Window 
This button allows the program to automatically fit the 
entire design within your current window size. This is 
useful for the overall layout of a design. 

Actual Size 
al Click on this button to display your design at its actual 

size. This is useful when you have Zoomed In or Out and 
wish to return to Actual Size without using the Zoom tool 

or Menu command. To access the keyboard equivalent 
for Actual Size, press the Command-E keys. The Menu 
command is found under the Options menu. 

Tools: [+] Toolbox Pull-Down Menu 

This pull-down menu allows you to turn on or off 
any of the toolboxes found within the program. 

Tools: 3 

“Edit 

“Draw 

Snap 

Dimension 

“Position Info 

Toolbox Pull-Down Menu 
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Edit Toolbox 

The Edit tools offer the ability to edit or change any object that has been 
created within the program, in addition to designs that were imported 
from elsewhere. If you are working on imported designs, verify that 
the design is in a vector format, NOT a raster format such as paint files. 
The way that the Edit tools work, is by selecting the individual or 
groups of points that you wish to edit. You may select points by 
clicking on the individual vertex points of the object or by dragging 
a selection rectangle around the points you wish to edit. 

The Edit tools offer you the following types of functions: Selecting 
Objects, Individual point selection, Resizing of objects, Skewing 
objects to any angle, Rotating objects from 0 to 360 degrees, Fillet and 

Chamfer capabilities, Trimming of objects, Zooming and Text. 

To maintain a high level of accuracy, you may combine the Edit tools 
with the Snap To tools which are also found within the program. The 

Snap To tools are designed to work in conjunction with all of the tools 
found within the program. You may refer to the Snap To Tools section 
of this manual for more details concerning these tools. 

This section of the manual offers you a detailed explanation of each 
tool capability as well as some step by step instructions on how to use 

the Edit tools. 
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Edit Tools and Individual Names 

The following example is a complete list of all the Edit tools and the 
proper name for each tool. It is very important to learn their proper 
names. 

Selection Tool 

SREVe . oa Ey waar 

Point Select Tool 

Resize Tool 

Skew Tool 

Rotate Tool 

Fillet Tool 

Chamfer Tool 

Trim Tool 

Zoom Tool 

Text Tool 

ra 

Edit Tools 
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Selection Tool 

The Selection tool is primarily used for repositioning selected objects 
to any location within your design. This tool allows you to select and 
move individual or groups of objects anywhere within your design 

area. 

This tool is the first tool in the Edit toolbox, and is sometimes called 

a Cursor tool. The tool works in two different fashions when selecting 
objects. First, you can simply click on any part of an object therefore 
highlighting the object. (You may add more objects by holding down 
the Shift key when clicking on additional objects.) The second 
method of selection is to drag a selection rectangle around the object 
or group of objects that you wish to select. 

If you have a specific location that you want to type when moving 
objects you may do so by using Keyboard Entry. This is explained 
further in this section under the subheading Keyboard Entry. 

Selecting Objects 

One of the most common ways of selecting objects is to click on a part 
of the object you wish to select. After clicking on the object, the vertex 
points become highlighted. Once the points are highlighted you can 

then place the cursor on top of a line within the object and hold down 
the mouse button, then begin dragging the object to any location on 
the screen. When dragging the object a ghost line appears, which 

represents the boundary lines of the object or objects selected. 

NOTE: You can maintain a perfect horizontal or vertical movement 

while holding down the Shift key once you have started dragging the 
object. 

SoftKey: Changing The Way America Buys Software 2-3 



Edit Toolbox KeyCAD Complete for MAC 

Example 1 

The following example provides further explanation on how to use the 

Selection tool by clicking on the object of your choice. 

Step 1 

Create a simple object as shown below, then place the cursor on top 

of the object as shown and click the mouse button once. 

ae Click mouse once 

Step 2 

Once you have clicked the mouse button, the vertex points of the 
object are highlighted as shown below. 

=e — Selected vertex points 

3 
Step 3 

Now that the object is selected, you can begin to move it. While 

keeping the cursor on top of the selected object hold down the mouse 

button and begin dragging the object to a different location. The ghost 

lines then appear to help you align the object with other objects. You 

can maintain a perfect horizontal or vertical movement while holding 

down the Shift key once you have started dragging the object. 

Ghost lines 
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Example 2 

The following example provides further explanation on how to use the 

Selection tool with a selection rectangle. 

Step 1 

Create a simple object as shown below, then click on the Selection 

tool within the Edit toolbox. Now place the cursor near the object (as 
shown below) and hold down the mouse button while dragging the 
mouse. This creates the selection rectangle and therefore selects any 
objects within the selection rectangle. This works well when you want 
to select multiple objects to be moved together. 

— Selection Rectangle 

Step 2 

Once you have selected the objects, the vertex points of the objects 
are highlighted as shown below. 

— Selected vertex points 

Step 3 

Now that the object is selected, you can begin to move it. While 
keeping the cursor on top of the selected object hold down the mouse 
button and begin dragging the object to a different location. The ghost 
lines then appear to help you align the object with other objects. You 
can maintain a perfect horizontal or vertical movement while holding 
down the Shift key. 
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Keyboard Entry with Selection Tool 

When using the Selection tool you have the option of using Keyboard 
Entry. This means that if you have a specific location you wish to move 
an object to, you can do so easily. To access the Selection tool Dialog 
box, simply double click on the Selection tool icon. 

When moving an object, you must first select one. If you have not 

selected an object, you must first snap to a point on the object, then 
press the Enter key. This allows the program to determine which point 

of the object should be placed at the new coordinates. When 
snapping to the point of your choice be sure to use the Snap To tools 
within the Snap To toolbox to assure complete accuracy when moving 

the object. The Dialog box lets you choose from Cartesian or Polar 
coordinates. 

| Selection Tool 

Coordinates 

@ Cartesian C) Polar 

(0.00 __] 
v:[0.00 | 

5 3 

. +4 

: § 
S & 

3 5 
& E 
33 | 3 
e3 & 
4 co 

3 3 

Selection Tool Dialog box 

NOTE: The typed coordinates are relative to the object's current 
position. 
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‘++| Point Select Tool 

The Point Select tool is primarily used for individually repositioning 
selected points to any location within your design. To maintain 
perfect accuracy in working with the Point Select tool, combine this 
tool with the Snap To tools. This tool is the second tool in the Edit 

toolbox, and is also known as a Cursor tool. 

If you prefer not to use the mouse when moving selected points you 

have the option to specify any X, Y coordinates of your choice by using 
Keyboard Entry. Keyboard Entry is explained in greater detail within 
this section. 

Selecting points with the Point Select tool 

This tool works in two different ways when selecting objects. First 
click on any individual vertex point within an object; therefore 
highlighting just that point. (You may add more individual points by 
holding down the Shift key when clicking on additional vertex points.) 
a eee 

, ) 
I 

; The second method of selection is to drag a 
selection rectangle around the individual point or 

eS ae 7 groups of points that you wish to select. 

Selection 
Rectangle 

When the points are highlighted, place the cursor on top of a selected 
point within the object, hold down the mouse and move these points 

to any location on the screen. When dragging these points, a ghost 
line appears representing the boundary lines of the points you have 

selected. You can maintain a perfect horizontal or vertical movement 

while holding down the Shift key once you have started dragging the 
selected points. 
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Example 

The following example shows how the Point Select tool can help in 

editing your designs. A simple closet layout has been created for this 
purpose. Itis possible to use a design of your choice or create a similiar 

design to the one below. 

Example of a Closet Layout 

Step 1 

After you have created a design, select the Point Select tool from the 
Edit toolbox. Now drag a selection rectangle around the end of the 
closet as shown below. Once selected, the individual points are 
highlighted. Now move these selected points. 

Selection 

Rectangle | p 

Example of the Point Select Tool 
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Step 2 

Place the Point Selection tool cursor on top of a highlighted point as 

shown below. After placing the cursor on top of the point, hold down 

the mouse button and drag the selected points to the left. Watch the 

readouts at the bottom of your screen for precise movement. Remember 
that you can hold down the Shift key to constrain your movement 
horizontally. 

Hold down mouse button —_ 

and drag to the left 

Step 3 

Once you have reached a desired distance, release the mouse button 
and your design is automatically updated to reflect the changes. This 
is a very useful tool for updating previously drawn designs. 
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Keyboard Entry with Point Select Tool 

The Point Select tool has the option of using Keyboard Entry for a very 
precise movement. This means that if you wish to move any point or 

group of points to a specific location (XY Coordinates) , you can do 

so easily. To access the Point Select tool Dialog box, simply double 
click on the Point Select tool icon. 

It is important to remember that when moving selected points using 

Keyboard Entry, you must first select the points you wish to move. 
After selecting the points, you must first snap to one of the selected 
points, then press the Enter key. This allows the program to determine 

which point of the object should be placed at the new coordinates. 
When snapping to the point of your choice be sure to use the Snap To 

tools within the Snap To toolbox for complete accuracy when moving 
the selected points. The Dialog box allows you choose from Cartesian 

or Polar coordinates, as well as Relative or Absolute reference 

coordinates. 

Point Tool 

Coordinates 

@) Cartesian C) Polar 

it 

¥ 

Point Select Dialog box 

NOTE: The Absolute coordinates that you enter are in reference to the 
point of origin of the working design. The program initially sets the 

origin to the lower left-hand corner of the design. 
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Resize Tool 

When using the Resize tool you have the ability to change the 

horizontal and vertical widths of any object. Also when using the 
Resize tool you can choose from the mouse or Keyboard Entry. 

In using the mouse, you simply click and drag the corner of the object 
you wish to resize. You can watch the readouts at the bottom of your 
screen to maintain any specific size. While resizing objects, ghost 
lines appear for visual representation. 

If you choose to use Keyboard Entry, you must first select the object 
and then double click the Resize tool icon to access the Keyboard 
Entry Dialog box. Once the Dialog box appears you can then 
numerically enter the width and height of the object. 

Selecting an object for resizing 

First select the Resize tool from the Edit toolbox, then place the cursor 

on the object of your choice and click the mouse button. The points 
of the object then become highlighted and you are ready for resizing. 

If you have multiple objects that make up one design and you wish to 

resize all of them at one time, drag a selection rectangle around those 
objects to highlight the object vertex points. 

Point and click Selection Rectangle 

SoftKey: Changing The Way America Buys Software 2-11 



Edit Toolbox KeyCAD Complete for MAC 

Example 

The following example shows you how to resize the window you just 
created. Notice that the window is made up of multiple objects such 
as lines and rectangles. Therefore, when you select the window, drag 
a selection rectangle around the entire window as shown below, to 
highlight the points within the window. 

Step 1 

First, drag the selection rectangle around the window to highlight the 

points within the window. 

Selection Rectangle 

Step 2 

Be sure that the Resize tool is selected, then place the cursor on top 

of the corner point as shown below. This is the point you need to drag 
for resizing the window. The opposite point that you grab is used as 

the anchor point when resizing. This means that the point stays in its 
original position, while dragging the other point. 

Anchor point 

i — Point being dragged 
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Step 3 

Now hold down the mouse button and begin dragging. The ghost lines 
appear as a visual reference for resizing the window. Watch the 

readouts at the bottom of your screen to maintain a specific size. Once 
you have reached the desired size, release the mouse button. 

Ghost lines 

Window after resizing 
Drag the mouse to the 

desired size 

Keyboard Entry with Resize Tool 

When resizing objects you have the option to use numeric Keyboard 
Entry. This is very helpful when you need to resize an object to a 
specific size. 

To access the Resize tool Dialog box, simply double click the Resize 
tool icon. When using Keyboard Entry with the Resize tool, you must 
first have an object selected. The Resize Dialog gives you the option 

to resize by percentage or by object size. You can choose from which 
part of the object you want to resize. 

@ Object Size © Percent 

Width: 

seeenenecceneccecsaeracsersecenseeerererseneseuserensneseeseenseesenceenseeceneecereeceuresseeeneeseseenesseeeeesonerseeens 
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Skew Tool 

This tool is designed to give any selected object a skewed angle. 
When this tool is used, the selected object takes on an angular shape. 

The Skew tool supports the mouse as well as numeric Keyboard Entry. 
When using the mouse, first select the entire object so that the vertex 
points are highlighted. Next place the mouse cursor on top of a 

highlighted vertex point; then click and drag to a desired angle. When 
using the mouse a ghost line appears to give you a visual representation 
of the object as it is being skewed. You can watch the readouts at the 
bottom of your screen to obtain any necessary angle. 

Example 

Step 1 

Create a shape similiar to the one shown below. Then select the object 
so that the vertex points are highlighted. Now place the cursor on the 
top point of the triangle, then click and drag the cursor to the left as 

shown below. 

Ghost lines 

Step 2 

Once you have reached a desired distance or angle release the mouse 
button. This example shows a triangle skewed to a 30 degree angle. 

Skewed Object 
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Keyboard Entry with Skew Tool 

The second method of using the Skew tool would be with numeric 

Keyboard Entry. Using Keyboard Entry is useful when you need to 
skew an object to a specific angle. 

Before accessing the Skew tool Keyboard Entry Dialog box, select an 
object. Then simply double click on the Skew tool icon and the Dialog 
box appears. Once the Dialog box appears type in the angle of your 

choice and click the OK button. Your selected object is automatically 
updated to reflect the new changes. The Dialog box offers you the 

option to choose which direction to skew the object. Choose from Up, 
Down, Left or Right. The Distance entry determines how far you skew 
the object. 

oS Sanaa Sana Sa Sn a naan Son ea Una SS a On On San Tne nn On nn “h nn nnn nn an nnn na nn ns nn nnn nn ns nn hn Sa nnn nn nn nnn ann na a , 

Skew Tool 

Skew Direction: 

Up 

O 
@) Left Right ©) 

Skew Tool Dialog box 
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Rotate Tool 

By using the Rotate tool you can rotate any object from O to 360 
degrees. All objects rotate from the center of the object that you have 

selected. Rotating objects can be performed by two methods; the 
mouse or Keyboard Entry. 

The following example shows how to use the Rotate tool with your 
mouse. 

Example 

Step 1 

First you need to create an object similiar to the one shown below or 
use an object of your choice. Once you have completed this step, 
select the object so that the vertex points are highlighted. Select the 
object by clicking directly on the object or by dragging a selection 
rectangle around the object. 

R 
Step 2 

Place the cursor on the corner vertex point, then click and drag the 

mouse in a counter clockwise direction. Once you start to drag the 
mouse a ghost line appears representing the boundaries of the object. 
After you reach the desired rotation release the mouse button. Watch 
the readouts at the bottom of your screen for the degrees of rotation. 

Begin dragging 

the mouse 
Rotated object 
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Keyboard Entry with Rotate Tool 

You have the option to rotate any object or groups of objects by using 
numeric Keyboard Entry. You must select an object before accessing 
the Keyboard Entry Dialog. After selecting an object, double click on 
the Rotate tool icon. Once the Dialog box appears you can type in 

any degree of rotation. You also have the option to choose from 
Degrees or Radians. After you enter the correct information click on 
the OK button. 

NOTE: The program allows you to rotate individual objects or groups 

of objects when using Keyboard Entry. Be sure to have all the 
necessary objects selected before accessing the Dialog box. 

@) Degrees 

C) Radians 

Rotate Tool Dialog box 
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Fillet Tool 

When using the Fillet tool, you can add a radius to any object that you 
may have created. Remember that the Fillet tool works with corner 
points of an object. What this means is that before you can apply a 
fillet with the Fillet tool, the corner point you are selecting must be 
joined together or made of enclosed objects such as rectangles, 
squares, polygons, etc. The example shown below gives a further 
explanation. 

Example 1 

With the two lines shown below, the Fillet tool cannot be 

used to apply a radius between the end-points of the two 

lines. In this instant you would use the Arc tool from the 
Draw toolbox, then snap each end of the arc to the 

end-points of the two lines. For more information con- 

cerning the Arc tool please refer to the Draw Tools section 
under the Arc tool subheading. 

Arc tool Use Arc tool to apply a radius 
between two separate end-points 

ss 

The rectangle shown below is the type of object you use the Fillet tool 
with. The reason the Fillet tool works on the rectangle is because the 
corner points are joined together and make up just one vertex point 

rather than two as shown above. 

—— 

You can apply the Fillet tool to 
corner vertex points which are joined 
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Using the Fillet tool 

The following example guides you through the proper usage of the 
Fillet tool. This tool works with the mouse and enables you to enter 
a precise radius with the numeric Keyboard Entry. 

Example 2 

Step 1 

First, create a shape similiar to the one below or use a shape you have 
already created. The shape shown below has been created with the 
Rectangle tool. After creating a shape, select the Fillet tool from the 
Edit toolbox and click on the corner vertex point as shown below. 

Click on corner vertex point —— = 

Step 2 

Now hold down the mouse button and begin dragging the cursor 
towards the center of the rectangle as shown below. You can watch 
the readouts at the bottom of your screen to maintain a specific radius. 
Once you have reached the desired radius, release the mouse button. 
The design is automatically updated to reflect the filleted corner. 

Drag cursor towards the center 
of the rectangle 

Release mouse button to 

display the radius 
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Keyboard Entry with Fillet Tool 

The Fillet tool has the ability to type in the radius with numeric 
Keyboard Entry. The Dialog box allows you to type in the exact radius 
and to select from a Standard fillet or an Inverse fillet. 

Standard Fillet — Inverse Fillet 

The Fillet tool can select points in two ways. One is to place the Fillet 
tool cursor on top of the corner point you wish to select and click the 
mouse button one time. The second method is to use the Fillet tool 
and drag a selection rectangle around the point(s) you wish to apply 

a fillet to. 

When using the Keyboard Entry with the Fillet tool, you must select 
the point(s) before activating the Dialog box. To access the Fillet tool 

Dialog box first select the points then double click on the Fillet tool 
icon. After you have entered the correct radius and chosen the 
standard or inverse fillet, click the OK button. 

SOOO OOOO IOI SOOO OPO O HOO IO OOOO OOOO LLL IIMA 

Fillet Tool 

Radius: 

@) Standard Fillet 

© Inversed Fillet 

J 
== 

OODOOODOOSINOOOOOOOOOOOO WOOHOO OOOO OOOH IOI HHH IES LHASA AIH 

Fillet Tool Dialog box 
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Chamfer Tool 

When using the Chamfer tool, you can quickly apply an angular 
corner to any object you have created. Remember that the Chamfer 
tool works with the corner points of an object. What this means is that 
before you can apply a chamfer with the Chamfer tool, the corner 
point you are selecting must be joined together or made of enclosed 

objects such as rectangles, squares, polygons, etc. The example 
below gives you further explanation. 

Example 1 

With the two lines shown below, the Chamfer tool cannot 

be used to apply a radius between the end-points of the 

two lines. In this instance you would use the Line tool 
from the Draw tools, then snap each end of the line to the 

end-points of the separated lines. For more information 

concerning the Line tool please refer to the Draw Tools 
section under the Line tool subheading. 

Use Line tool to apply a 

chamfer between two 
separate end-points 

Line tool 

Draw 

Toolbox 

The rectangle shown below is the type of object you use with the 
Chamfer tool. The reason the Chamfer tool works on the rectangle is 

because the corner points are joined together and make up just one 

vertex point rather than two as shown above. 

You can apply the Chamfer tool to eee 

corner vertex points which are joined ae 
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Using the Chamfer Tool 

The following example guides you through the proper usage of the 

Chamfer tool. This tool works with the mouse and enables you to enter 
a precise length and angle of the chamfered corner, when using the 
numeric Keyboard Entry. 

Example 2 

Step 1 

First create a shape similiar to the one below or use a shape you have 
already created. The shape below has been created with the 
Rectangle tool. After creating a shape, select the Chamfer tool from 

the Edit toolbox and click on the corner vertex point as shown below. 

Click on corner vertex point _—— 

Step 2 

Now hold down the mouse button and begin dragging the cursor 
towards the center of the rectangle as shown below. You can watch 
the readouts at the bottom of your screen to maintain a specific length. 
Once you have reached the desired chamfer, release the mouse 
button. The design is automatically updated to reflect the chamfered 

corner. 

Drag cursor towards the center 
of the rectangle 

Release mouse button to 

display the chamfer 
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Keyboard Entry with Chamfer Tool 

The Chamfer tool has the ability to type in the angle and length of angle 
with numeric Keyboard Entry. The Dialog box allows you to type in 
the exact angle as well as the length of the chamfer. 

The Chamfer tool can select points in two ways. One is to place the 
Chamfer tool cursor on top of the corner point you wish to select and 

click the mouse button one time. The second method is to use the 

Chamfer tool and drag a selection rectangle around the point(s) to 
which you wish to apply a chamfer. 

When using the Keyboard Entry with the Chamfer tool you must select 
the point(s) before activating the Dialog box. To access the Chamfer 
tool Dialog box first select the points then double click on the Chamfer 
tool icon. After you have entered the correct angle and length, click 
the OK button. 

Chamfer Tool 

Length: 

Chamfer Tool Dialog box 
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Trim Tool 

The Trim tool is useful for cutting objects or trimming away segments 

of objects that would otherwise require you to redraw, resize or edit 
in some fashion. The Trim tool quickly assists you in the cutting of 
lines, rectangles, polygons as well as the outlines of arcs or circles. 

When you select the Trim tool from the Edit toolbox, your cursor turns 
into a crosshair. When you place the crosshair on a line and click the 
mouse button, the Trim tool inserts a vertex point therefore breaking 

the line. 

The following example explains how to properly use the Trim tool. 

This trims the excess hangover on the object. 

Example 

Step 1 

First select the Trim tool from the Edit toolbox and place the cursor at 

the point you wish to trim the excess line, as shown below. Then click 
the mouse button. 

Excess hangover to 
be trimmed 

Place cursor at trim point ee 

and click mouse ——- 
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Step 2 

Once you have clicked the mouse, a highlighted vertex point appears. 

This indicates that the program has trimmed the excess line at the 

highlighted point. 

Trimmed point 4 

Step 3 

After trimming the line as explained in the previous steps, you can then 

delete the excess line. To delete the excess line, first select the 

Selection tool from the Edit toolbox and click once on the excess line, 

then press the Delete key on your keyboard. 

Trimmed object 

NOTE: Be sure that when you press the Delete key, no other objects 
are selected simultaneously. If any objects other than the trimmed line 
are selected and you press the Delete key, all selected objects are then 
removed. 
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Zoom Tool 

Zoom + icon The Zoom tool allows you to change the 
level of enlargement or reduction of the 
drawing view. It would be the same as 
using a magnifying glass when looking at 
your design. It is very useful to zoom in 
on a drawing for a close view of details 

or to zoom out for an overview of the 
as drawing layout. 
: The program offers several ways to use 
Sa a the Zoom tool for zooming in or out. 

You can also set the percentage of zoom 
Regional Zoom within the Preference Dialog found under 

the Edit menu. 

Zoom - icon 

When you initially start the program, the Zoom tool is defaulted to a 
plus sign in the center of the icon. This indicates that this tool is set 
to zoom in. You can change the plus sign to a minus sign by holding 
down the Option key after you have selected the Zoom tool, thus 
allowing you to zoom out. 

Another way to use the Zoom tool is to click and drag with the Zoom 
tool, therefore creating a Regional zoom. This means that the area 

within the selection rectangle while dragging the Zoom tool, magnifies 
to the full screen size. 

Zooming In 

Select the Zoom tool from the Edit toolbox and place it over the point 
you wish to zoom in on, then click the mouse button. You can set the 
percentage of zoom, which determines the degree by which the 

screen zooms each time you click the mouse. (The Zoom Percentage 
setting is found in the Preference Dialog under the Edit menu.) 

Place Zoom tool at the © ———— | De 
point you wish to zoom in 
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Zooming Out 

Select the Zoom tool from the Edit toolbox and place it over the point 
you wish to zoom out. You can set the percentage of zoom, which 
determines the degree by which the screen zooms each time you click 
the mouse. The Zoom Percentage setting is found in the Preference 
Dialog under the Edit menu. 

Once you selected the Zoom tool, hold down the Option key to 
change the magnifying glass from a + (plus) to a - (minus). Now click 
the mouse button and the screen zooms out. You may repeat this 
process as many times as necessary. 

Place Zoom tool 

at the point you a 
wish to zoom out 

Regional Zoom 

To use this method of zooming, first select the Zoom tool from the Edit 
toolbox. Now hold down the mouse button and drag a selection 
rectangle to select the part of the design you want to magnify. The area 
identified within the selection rectangle is displayed to the maximum 

size of the screen. The magnification factor is determined by the size 
of the area selected. 

Drag a selection rectangle 
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Text Tool 

This tool allows you to add captions and paragraphs of text to any 

drawing, for easy edit and reposition. You can mix fonts, font sizes, 

font styles, and the color of text. 

Align Right 
Align Center 

Text Menu 

Before you type text within a design, choose the font, font size, font 
style, and text alignment that are appropriate for your document. The 

program supports any Macintosh font that you have installed within 

your system. KeyCAD Complete also supports TrueType and PostScript 
fonts. You can align text along the left or right margins, or center it 

between margins. 

KeyCAD Complete's pop-up menus make for fast access when 

selecting the text of your choice. To access the pop-up menus, pull 

down the Text menu and drag the mouse cursor on top of a menu 

selection such as: Font, Size, or Style. 

Adding Text to a document 

Choose a font from the Font menu. 
Choose a font size from the Size menu. 
Choose a font style from the Style menu 
Choose align Left, Right, or Center from the Text menu. 

Choose the Color of your choice. 

After making your choices, select the Text tool from the Edit toolbox 
and add text to any part of your design. KeyCAD Complete defaults 

to Geneva 12-point text with left alignment when the program is 

initially started. 
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Moving Text Blocks 

The creation of a text block allows you to move the text to a location 
of your choice. To do this, select the Selection tool from the Edit 
toolbox, and click on the text that you have already created. 

iMovinga 

Click on the text to ee block 

highlight text block 

Editing Text within a Text Block 

You may select text within a text block for editing purposes. To select 
part of a text object, first select the Text tool from the Edit toolbox. 
Then select the letters or words you wish to edit by dragging through 

the text. After you select the text, it becomes highlighted. You can 
now edit the highlighted text. Remember that you can have multiple 
styles, sizes, and colors within the same text block. 

Drag |-beam through the text 
to highlight individual words 
or letters if 

=i-ti-amnee LeXt within 
:@ text block 

Deleting a Text Block 

You can easily delete an entire text block at one time. First, select the 
Selection tool from the Edit toolbox. Then, click once on the text block 

you wish to delete and press the Delete key. 

SoftKey: Changing The Way America Buys Software 2-29 



KeyCAD Complete for MAC 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Draw Tools 

Draw Tools 

The Draw tools are used in the construction of basic 

shapes, that can be combined together to create complex 
shapes. The Draw tools consist of rectangles, squares, 

circles, ovals, polygons, multigons, arcs, lines, and free- 

formed splines. The Draw toolbox automatically appears 

to the left side of your window when the program is first 
started, but you can relocate the toolbox to any position 
on the screen. 

To select a tool for drawing with the mouse, simply click 
one time on the tool of your choice. Then click and drag 
the mouse to construct the selected object. 

If you want to access the Draw tools Numeric Keyboard Entry Dialog, 
you double click on the tool icon, and the Numeric Keyboard Entry 
Dialog appears. 

These two methods of selection work the same for all Draw tools. 

The Draw toolbox can be turned on or off for your convenience. You 
can turn on or off toolboxes under the Tools pull-down menu on the 
Menu Bar, or the Toolbox pop-up menu found under the Windows 

menu. 

Combining Draw Tools with Snap To Tools 

The Draw tools are designed to work in conjunction with the Snap To 
tools. This allows you to precisely snap to end-points, midpoints, 

tangents, etc. when starting and finishing the objects found in the 
Draw toolbox. 
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|] Rectangle / Square Tool 

The Rectangle / Square tool is designed to draw both rectangles and 
squares when selecting one tool icon. KeyCAD Complete defaults to 

the Rectangle tool. If you want to draw squares, select the tool icon 
and hold down the Shift key when using the tool, to draw perfect 
squares. 

Squares Rectangles 

Rectangle Tool combined with Snap To Tools 

The Rectangle / Square tool can be used with the Snap To 

tools, therefore allowing you to start or end the rectangle 
or square from another object center, midpoint, end-point, 

percentage point, etc. Remember that you can start and 

finish any rectangle or square from any of the Snap To 

tools. Use the Tab key to change Snap To tools when 
dragging the mouse to create selected objects. 

You can also choose to draw the rectangle or square from 

the objects center point. You can choose the Draw from 

Center option under the Layout menu. When you select 
this option, the tool draws the object double the size of 
the Incremental Readouts or the distance you drag the 
mouse (width and height). 

Draw from Center, 

Draw from Center is located under the Layout menu 
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Drawing a Rectangle/Square with the Mouse 

The following instructions explain how to construct a rectangle or 

square, while using the mouse. 

(J First, select the Rectangle/Square tool from the Draw 

toolbox. 
[| Now, place the cursor at the start point of your choice, 

and click and drag the mouse until you reach the desired 
size. Watch the readouts at the bottom of your screen for 
the object size. The W indicates the objects width, and 
the H indicates the object height. 

Absolute Readouts Incremental Readouts 

(Object Size) 

The Absolute coordinates display the object size added to the 
Absolute coordinates of the start point. This means that the coordinates 

are calculated from the Origin point (Axis Lines Intersection). 

The Incremental readouts display the object size in relation to the start 
point. 
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Using Keyboard Entry with Rectangle/Square Tool 

You can access the Rectangle/Square tool Numeric Keyboard Dialog, 

if you double click on the tool icon. After you double click, a Dialog 
box appears, allowing you to numerically enter the object size and 
start point. 

After you double click on the tool and the Numeric Entry Dialog box 
appears, it disregards the mouse actions and the object is drawn to the 
numeric information you enter into the Dialog box. You can set the 
object width, height and angle as well as the start point of the rectangle 
or square. 

Start Point 

When setting the start point, first select the Start Point button, notice 
that the Dialog box information changes to coordinate positions. 
When you enter the coordinate positions you can also set the start 
point to be at a selected point on the object such as, Upper Left, Upper 
Right, Lower Left, Lower Right, or Center point of the rectangle or 

square. The start point is always relative to the Absolute Point of your 
document. 

, | | 
Rectangle/Square Tool 

1 © Object Size @ Start Point 
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Rectangle/ Square Tool Dialog box 
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Object Size 

When you click on the Object Size button the Dialog changes, so that 
you can enter the object's width and height. Remember that the 
Object Size information is drawn from the selected Draw From and 
Start Point coordinates. 

If you select the Draw From Center option, the width and height are 
reduced to half the actual size. 

Rectangle/Square Tool 

@ Object Size © Start Point | 

Object Size Info 

: 

: 
: 

= 

> 

Draw From: 

Upper 
® Left 

Lower Lower C) Left Center Right 
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Object Size Dialog box 

8 
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tel Circle / Oval Tool 

The Circle / Oval tool is designed to draw both circles and ovals while 
selecting one tool icon. KeyCAD Complete defaults to the Oval tool. 

If you want to draw perfect circles, select the tool icon and hold down 
the Shift key when using the tool to draw perfect circles. 

ee 
Circle Oval 

Circle/Oval Tool combined with Snap To Tools 

The Circle / Oval tool can be used with the Snap To tools, 

therefore allowing you to start or end the objects from 
another object center, midpoint, end-point, percentage 

point, etc. Remember that you can start and finish any 
circle or oval from any of the Snap To tools. Use the Tab 
key to change Snap To tools when dragging the mouse to 
create selected objects. 

You can also choose to draw the circle or oval from the 
object center point. You can choose the Draw From 
Center option under the Layout menu. When you select 

this option, the tool draws the object and doubles the size 
of the Incremental readouts or the distance you drag the 
mouse (width and height). 

Draw from Center. 

Draw from Center is located under the Layout menu 
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1] Drawing a Circle or Oval with the Mouse 

The following instructions explain how to construct a circle or oval, 

while using the mouse. 

OJ First, select the Circle/Oval tool from the Draw toolbox. 

(J Now, place the cursor at the start point of your choice, 

and click and drag the mouse until you reach the desired 
size. Watch the readouts at the bottom of your screen for 
the object size. The W indicates the object width, and the 
H indicates the object height. 

Absolute Readouts Incremental Readouts 

| (Object Size) 

The Absolute coordinates display the object size added to the 
Absolute coordinates of the start point. This means that the coordinates 

are calculated from the Origin point (Axis Lines Intersection). 

The Incremental Readouts display the object size in relation to the start 
point. 
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Using Keyboard Entry with Circle/Oval Tool 

You can access the Circle/Oval tool Numeric Keyboard Entry Dialog 
box, if you double click on the tool icon. After you double click a 
Dialog box appears, allowing you to numerically enter the object size 
and start point. 

After you double click on the tool and the Numeric Keyboard Entry 
Dialog appears, the Dialog box disregards the mouse actions and the 
object is drawn to the numeric information you enter into the Dialog 

box. You can set the objects width, height and angle as well as the 
start point of the circle or oval. 

Start Point 

When setting the start point, first select the Start Point button, notice 

that the Dialog box info changes to coordinate positions. When you 
enter the coordinate positions you can also set the start point to be at 

a selected point on the object such as Top, Left, Right, Center and 

Bottom of the circle or oval. The start point is always relative to the 
Absolute Point of your document. 

POO OOOO ROO OOOO OOOH II 

Oval / Circle Tool 

© Radius ODiameter [| 

| Cobject Size @Start Point | 

H: 
Start Point 

coordinates 

Draw From: top 
O 

Left QO 
Center 

Bottom 

Oval / Circle Tool Dialog box 
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Object Size 

When you click on the Object Size button the Dialog changes, so that 
you can enter the object width, height, and angle. Remember that the 

Object Size info is drawn from the selected Draw From and Start Point 
coordinates. 

The Circle/Oval tool has the options of using Radius, Diameter or 
Object Size for creating the object. Select one of the options after you 

have set the Start Point and Draw From options. 

If you select the Draw From Center option, the width and height of the 
circle or oval, are reduced to half of the actual size. 

Oval / Circle Tool 

©) Radius C) Diameter 

@ Object Size © Start Point 

Object Size , Width: 

Draw From: Top 

O 

Left€) @) () Right 
Center 

Bottom 

Cancel 

Oval / Circle Dialog box 
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Gl Polygon Tool (Open and Closed) 

The Shift key together with the Polygon tool constrain each segment 

to a perfect Horizontal or Vertical line. 

The Polygon tool is designed to draw Open or Closed polygons, that 

can contain many individual sides. Polygon shapes are often closed 
shapes, which means that the last line connects with the beginning 

point of the polygon. Closed polygons include triangles, parallelograms, 

stars, octagons, and many other shapes. 

Closed Polygon 

++ 
Open Polygon 

Polygon Tool combined with Snap To Tools 

The Polygon tool can be used with the Snap To tools, 
therefore allowing you to start or end polygons from 
another object's center, midpoint, end-point, percentage 

point, etc. Remember that you can start and finish any 
polygon from any of the Snap To tools. Use the Tab key 
to change Snap To tools when dragging the mouse to 
create selected polygons. 

To use a Snap To tool with the polygons start point, first 

select the Snap To tool of your choice, then select the 
Polygon tool and place the start point. To finish the 

polygon at a specific Snap To tool, press the Tab key to 
change the Snap To tool while drawing the polygon, and 
double click at the desired end-point. 

BOGS - | 
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| | Creating a Polygon with the Mouse 

O) First, select the Polygon tool from the Draw toolbox, then 

place the crosshair cursor at the desired start point. 

1 Now, click the mouse button one time, to set the first 

point. Then drag the mouse to the second point location 
and click the mouse button. Repeat this process as many 

times as necessary. 

(J) When you are finished with the polygon, double click the 
mouse button to end the polygon. If the end-point is 
within a 10 pixel radius of the start point, the polygon is 

automatically closed. If you double click outside of the 
10 pixel radius, the polygon ends at the point you click, 
creating an open polygon. 

Once you have created either an Open or Closed Polygon, you can 
fill it with any of the fill patterns available. You can change the line 
type and size that makes up the boundaries of the polygon. You can 
change lines from under the Layout menu, in the pop-up menu called 

Lines. 

Types... 
Size... 

You can also change the color of the polygon by selecting the polygon 

and then choosing a new color from the color picker. If you have filled 
the polygon and change colors, the fill then reflects the color changes, 
therefore allowing for colored fills. 

a 

Lines pop-up menu 
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Using Keyboard Entry with the Polygon Tool 

When using the Polygon tool you have the option of using numeric 
Keyboard Entry, instead of the mouse. To access the Dialog box, 
double click on the Polygon tool icon. 

Within the Polygon tool Dialog box, you can choose from Open or 
Closed polygons and set the start point of the polygon and the number 

of points within the polygon. You can also choose from Cartesian or 
Polar coordinates. The Dialog box also displays which point you are 
entering, as well as the total number of points making up the polygon. 

After you have entered a point coordinate press the Enter Point button, 

place and add the new point to the polygon. Continue adding points 
as necessary. Once you have the desired number of points, click on 
the End Polygon button,to automatically end the polygon you are 
working on. Click the OK button to close the Dialog box. 

Polygon Tool 

@Open (Closed 

Coordinates 

@) Cartesian C) Polar 

10.00 _] 
v:[0.00 | 

Cena Polygon 
Current Point: 

a SITIOS SEAHAM RAHMAN MAIO SKS aso a OH 

“pebeon Dialog box 
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[ol Multigon Tool 

The Multigon tool is designed to draw objects that contain any 
number of sides, with each side even in length. This tool is used when 

you want to create octagons, pentagons, triangles, etc. This tool saves 
a lot of time in creating various multigons. Other programs usually use 
the Polygon tool for creating multigons. 

KeyCAD Complete defaults the Multigon tool to contain five even 
sides. You can change the number of sides in the Preference Dialog, 
which is found under the Edit menu. 

Different objects created with the Multigon tool 

Multigon Tool combined with Snap To Tools 

The Multigon tool can be used with the Snap To tools, 
therefore allowing you to start or end the multigon from 

another object center, midpoint, corner, percentage point, 

etc. Remember that you can start and finish any multigon 
from any of the Snap To tools. Use the Tab key to change 

Snap To tools when dragging the mouse to create your 
multigon. 

You can also choose to draw the multigon from the 

object's center point. You can choose the Draw From 
Center option under the Layout menu. When you select 
this option, the tool draws the multigon and doubles the 

size of the Incremental Readouts or the distance you drag 
the mouse (width and height). 

Draw from Center, 

Draw from Center is located under the 

Layout Menu 
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[oO | Drawing a Multigon with the Mouse 

The following instructions explain how to construct a multigon, while 
using the mouse. 

(1 First, set the number of sides you want in your multigon. 
You can set the number of sides within the Preference 
Dialog under the Edit menu. 

Second, select the Multigon tool from the Draw toolbox. 

Now, place the cursor at the start point of your choice, 
and click and drag the mouse until you reach the desired 
size. Watch the readouts at the bottom of your screen for 
the multigons width. The W indicates the object width, 
and the H indicates the object height. 

NOTE: The start and end-point of the Multigon can snap to any of the 

Snap tool options. 

Absolute Readouts Incremental Readouts 

(Object Size) 

The Absolute coordinates display the object size added to the distance 
your cursor is from the absolute point of yourdocument. The Absolute 
readouts track the mouse movement in relation to the Origin point. 
This means that the coordinates are calculated from the Origin point 
(Axis Lines Intersection). 

The Incremental Readouts display the object size in relation to the start 
point or the distance you drag the mouse. 
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Using Keyboard Entry with the Multigon Tool 

You can access the Multigon tool Numeric Keyboard Entry Dialog 

box, if you double click on the tool icon. After you double click, a 

Dialog box appears, allowing you to numerically enter the object size 
and start point. 

After you double click on the tool, the Numeric Keyboard Entry Dialog 
box appears. It disregards the mouse actions and the object is drawn 

to the numeric information you enter into the Dialog box. You can 
set the object width and angle as well as the start point of the multigon. 
The Draw From button is the point on the multigon, which is placed 
at the Start Point coordinates. 

Start Point 

When setting the start point, first select the Start Point button, notice 

that the Dialog box information changes to coordinate positions. 

Left - Right 

Start Point coordinates 

When you enter the coordinate positions you can also set the start 
point to be at a selected point on the object such as Top, Left, Right, 
Center and Bottom of the multigon. The start point is always relative 

to the Absolute Point of your document. If you choose the Center 
Draw From point, the multigon doubles the width you type in the Total 
Width Entry box. The Angle is in reference to the start point, and if 
you enter an angle it draws the entire multigon at the specified angle. 
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Object Size 

When you click on the Object Size button, the Dialog changes, so that 

you can enter the multigons width and angle. Remember that the 
Object Size information draws from the selected Draw From and Start 
Point coordinates. 

The Multigon tool Dialog has the option to enter the number of sides 
that make up the multigon. Remember, that each side is even in 
length. You can also enter the Total Width of the multigon, as well 
as the angle that the object is to be drawn. 

If you have selected the Draw From Center option, the width and 
height of the multigon, is twice the Total Width entry. 

Multigon Sides: 

Start Point @ Start Point 

Info 

Left () ® () Right 
Center 

Bottom 

Multigon Tool Dialog box 

Click on the OK button once you have entered the correct information. 
You can choose the Cancel button to exit the Dialog and cancel the 

multigon drawing. 
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Arc Tool 

The Arc tool is designed to draw both elliptical and 90 degree arcs, 
while selecting one tool icon. KeyCAD Complete defaults to the 

elliptical Arc tool. If you want to draw perfect circular arcs, select the 
tool icon and hold down the Shift key when using the tool. 

—— 

Elliptical Arc Circular Arc 

Arc Tool combined with Snap To Tools 

The Arc tool can be used with the Snap To tools, therefore 

allowing you to start or end the arc from another object 

center, intersection, end-point, percentage point, etc. 

Remember that you can start and finish any arc from any 
of the Snap To tools. Use the Tab key to change Snap To 

tools when dragging the mouse to create selected objects. 

Start point 

of Arc 

The example above shows how the Arc's start point was snapped to 
the end-point of a line, and the end-point of the Arc was snapped to 

the corner point of the rectangle. 
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Using the Arc Tool with the Mouse 

You can create arcs in two ways while using the mouse button. The 
two types of arcs are elliptical arcs and perfect 90 degree arcs. 

Creating an Elliptical arc 

a Elliptical arc 

(11 First, select the Arc tool from the Draw toolbox. 

[J Now, place the crosshair cursor at the desired start point, 

then click and drag the mouse. Note how the arc follows 
the crosshair cursor, allowing you to change the length 
and height of the arc. 

[J Once you have reached the desired arc, release the mouse 
button. 

Note: You can snap the start and end-point of the arc to any of the Snap 
To tool options. 

Creating a Circular arc 

90 degree arc 

First, select the Arc tool from the Draw toolbox. 

Then, place the crosshair cursor at the desired start point. 
Now, click and hold down the mouse button while 

dragging the mouse. When dragging the mouse hold 

down the Shift key and release the mouse button. A 
straight line from the start point to the cursor appears 

representing the radius of the arc. 
Drag the cursor in a clockwise or counter clockwise 

direction and watch the arc being created. Press the 

mouse button one time to end the arc. 
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Using Keyboard Entry with the Arc Tool 

You can access the Arc tool Numeric Keyboard Entry Dialog box, if 
you double click on the tool icon. After you double click a Dialog box 
appears, allowing you to numerically enter the radius and degree of 
arc, and set the start point. 

After you double click on the tool the Numeric Keyboard Entry Dialog 
box appears. It disregards the mouse actions and the arc is drawn to 

the numeric information you enter into the Dialog box. You can set 
the arc radius and degree of length, and you can choose from Elliptical 

or Circular arcs. 

Elliptical Arc 

When selecting the Elliptical arc button, the Dialog prompts you to 

type in the X, Y coordinate start and end-points for the arc you are 
creating. 

Circular Arc 

If you select the Circular arc button, your End-Point Entry boxes 
change to Radius, Start Angle, and Arc Angle. When creating the 
circular arc, you must first set the start point of the arc, and then the 

radius and degree of length for the arc. 

firc Tool 

@) Elliptical © Circular 

Start Point 

weeecceencenencnrsceeceeseesseececenacscceneceeenceceasrsnenscseessceessensssesssessccensesesseeasess 

End Point 

Relative H: 

Relative Y: 

Arc Tool Dialog box | 
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Line Tool 

The Line tool is designed to draw lines at any angle or length. You can 
draw a line by clicking on the Line tool icon and positioning the cursor 
where you want the line to begin. The cursor then becomes a crosshair 
showing the exact position where the line begins or ends. If you want 
to draw perfect horizontal or vertical lines, select the tool icon and 

hold down the Shift key when using the tool. 

Horizontal Lines Vertical Lines 

When creating a line, drag the cursor in the direction the line is to be 
created. As long as you hold down the mouse button, you can 
lengthen or shorten the line and change its angle. 

Line Tool combined with Snap To Tools 

The Line tool can be used with the Snap To tools, 

allowing you to start or end any line from another object 
center, midpoint, end-point, percentage point, etc. 

Remember that you can start and finish any line from any 
of the Snap To tools. Use the Tab key to change Snap To 

tools when dragging the mouse to create lines. 

For example, start the line from the end-point of another 
line and finish the line at the center point of a circle, by 

changing Snap To tools after you set the start point of the 

line. 
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Using Keyboard Entry with the Line Tool 

You can access the Line tool Numeric Keyboard Entry Dialog box, if 
you double click on the tool icon. After you double click a Dialog box 
appears, allowing you to numerically enter the length, angle and start 
point. 

After you double click on the Line tool and the Numeric Keyboard 
Entry Dialog box appears. It disregards the mouse actions and the line 
is drawn to the numeric information you enter into the Dialog box. 
You can set the lines length and angle as well as the start point. 

When setting the start point, first select the Start Point button. Notice 
that the Dialog box information changes to coordinate positions. 

These coordinates allow you to set the start and end-points of the line. 
You can choose from Cartesian or Polar coordinates for drawing the 
line. If you select the Polar coordinates, you must still set a start point 
for the line you are drawing. 

1) Cartesian coordinates allow you to set the start and 
end-point at any X, Y coordinates. 

(1) Polar coordinates allow you to enter the length and angle 
of the line. You must still set the start point coordinates 
for the line you are creating. 

Once you have entered the correct information, click on the OK 
button to complete the new line. 

You can click on the Cancel button to cancel the line drawing 
operation. 
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Spline Tool 

The Shift key together with the Spline tool constrain each spline 
segment to a perfect horizontal or vertical line. 

The Spline tool is designed to draw Open or Closed free-formed 

splines, that can contain many individual spline segments. Choose 
the Spline tool when you want to create a curve that passes through 
specific points in your design. You must specify the points that 

KeyCAD Complete should use to draw the curve. Then KeyCAD 

Complete calculates and draws the free-formed curve for you. 

Closed Free-Formed Spline 

= 
Open Free-Formed Spline 

Spline Tool combined with Snap To Tools 

The Spline tool can be used with the Snap To tools, 

therefore allowing you to start or end curved splines from 
another object center, midpoint, end-point, percentage 
point, etc. Remember that you can start and finish any 
open or closed spline from any of the Snap To tools. Use 

the Tab key to change Snap To tools when dragging the 
mouse to create selected splines. 

To use a Snap To tool with the Spline tool start point, first 
select the Snap To tool of your choice, then select the 
Spline tool and place the start point. To finish the Spline 

at a specific Snap To tool, press the Tab key to change the 
Snap To tool while drawing the spline, and double click at 
the desired end-point. 

BORE - | 
SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Draw Tools 

Creating a Free-Formed Spline with the Mouse 

To start drawing a free-formed spline, position the cursor on the first 

point of the spline. Click the mouse button and move the mouse, the 

mouse button does not have to be held down. A line follows the 
mouse movement. Position the pointer on the next point that the curve 

should pass through and click the mouse button again. Another line 
begins from the previous point. You can continue moving the mouse 

and clicking to specify the number of points you want. 

When you are finished specifying the number of points, double click 

the mouse button. KeyCAD Complete automatically draws the 

curved lines through the points you have placed. 

After you have created a spline, you can change the tension value of 
the spline to loosen or tighten the curves that pass through the points. 
The Smoothing pop-out menu is found under the Edit menu. From the 

pop-up menu you can choose Smooth, Unsmooth and the Tension 
Dialog boxes. 

Smooth 

Unsmooth 

Smoothing pop-up menu 

> smoothing 

Tension Dialog box 
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Using Keyboard Entry with the Spline Tool 

When using the Spline tool you have the option of using numeric 
Keyboard Entry, instead of the mouse. To access the Dialog box, 
double click on the Spline tool icon. 

Within the Spline tool Dialog box, you can choose from Open or 

Closed splines and set the start point of each spline and the number 

of points within the free-formed spline. You can also choose from 

Cartesian or Polar coordinates. The Dialog box displays which point 
you are entering, as well as the total number of points making up the 
spline. 

After you have entered a point coordinate, press the Enter Point 

button, to place and add the new point to the free-formed spline. 

Continue adding points as necessary. Once you have the desired 
number of points, click on the End Spline button to automatically end 
the spline you are working on. KeyCAD Complete draws the curved 

lines through the points. Click the OK button to close the Dialog box. 

Spline Tool 

@ Open Closed 

Coordinates 

() Cartesian ©) Polar 

ya10.00___] 
v:[0.00 | 

Current Point: 
= 

= 

DME LAH 

ele Sialos 5 box 
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Dimension Tools 

“fe The Dimension tools are very important for drafting or 
+} creating any type of blueprint. The tools found within the 
———{ Dimension toolbox consist of Linear, Parallel, Angular, 

Diameter, Radius, and Leader Line tools. 

The Dimension toolbox can be turned on or off and can 

be relocated for faster access. You can access the 

Dimension toolbox from under the Tools pull-down menu 
found on the Menu Bar. You can also turn it on or off 

from under the Window menu using the Toolboxes 
pop-up menu. A check mark Y _ indicates if the toolbox 

is on or Off. 

Tools: 3 

“Edit 

“ Draw 

Snap 

Dimension 

“Position Info 

Tools pull-down menu 

Combining Dimension Tools with Snap To Tools 

Some of the Dimension tools can be used with the Snap To tools. The 
Dimension tools that work with the Snap To tools are Linear, Parallel, 
Angular, and Leader Line. The Diameter and Radius tools automatically 
snap to the points of the object you have dimensioned. 
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The following is a complete list of the Dimension tools found within 
the toolbox. 

Linear Tool 

Parallel Tool a 
Angular Tool | 
Diameter Tool mS 

Radius Tool 

Leader Line Tool | 
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Dimension Options 

The dimensions that appear when using the dimension tools, have 

several options available. These options are designed to give your 
design a more custom look. The options available appear in the 

Dimensioning pop-up menu found under the Layout menu. These 

options consist of Arrows In, Arrows Out, Arrowheads choices, Center 

Text, Text Frame, Single Tolerance, Double Tolerance, Limiting 

Tolerance, and the Tolerance Values Dialog box. The Tolerance 
Values Dialog is discussed in the Layout Menu chapter under the 

Tolerance Values sub-chapter. 

You can access the Dimensioning options pop-up menu under the 

Layout menu. 

firrows In 

“ Arrows Out 

Arrowheads 

> Dimensioning 

“ Center Text 

pee 

Single Tolerance 

“ Double Tolerance 

Limiting Tolerance 

Tolerance Values... 

a’ —he 

Se 

~ ae 

“ Text Frame a 
nse dc imag —, 

—* 

-©) 

Dimensioning Options pop-up menu 

Changing dimension colors 

You can change the color of any complete dimension including, text, 
arrowhead lines, and witness lines. First, select the dimension and its 

witness lines and then choose a new color from the color picker. 

Changing font size and style 

Drag the Text tool over the text within your dimension, therefore 
highlighting the text, and choose the font size or style from the Text 
menu. 
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Dimension Examples 

The following examples display how the different options affect your 

= 1.472" ee 

Arrows In option 

> 0.946" h 

Arrows Out option 

dimensions. 

See a 

Text Frame option 

hi 1.770" -0.500 > 

Single Tolerance option 

, +0.500 pe 1.770 “Se >| 

Double Tolerance option 

BS e 22 ee 

i Bee 82 

Limiting Tolerance option 
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Linear Dimension Tool 

The Linear Dimension tool automatically calculates the dimensions 
between any two points and displays the correct distance between 
those points. For example, you can dimension lines, squares, 

rectangles, sides of polygons as well as the distance between objects. 
The Linear tool is designed to display only horizontal dimensions i.e., 
the horizontal distance between any two points. 

ass a. 

a 
Linear dimension examples 

=<... 

Es 
Linear dimension between two objects 

NOTE: The examples above show a dimension that displays the actual 

distance between any two points. The Linear tool snaps to any of the 
Snap To tools. 
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How to use the Linear Dimension Tool 

CO First, select the Linear tool from the Dimension toolbox. 

(J Select the Snap To tool that you wish to snap to the first 

point of the dimension. 

Then, place the cursor near the point from which you 

want to start the dimension. Now click, hold down the 

mouse button and drag the cursor to the second point of 
the dimension, and release the mouse button near the 

point. 

Now you can drag the dimension text out away from the 
object and then click one time to set the dimension 
distance. 

When using the Snap To tools, you can dimension from the end-point 
of one object to the center point of another object. You can start and 
end a dimension from any two combinations of the Snap To tools. 

Remember that the Linear Dimension tool always displays the 
dimension perfectly horizontal. 

You can apply any of the dimension options within the Dimensioning 
pop-up menu to any linear dimension. 

Example of Linear Dimensioning 
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Parallel Dimension Tool 

The Parallel Dimension tool automatically calculates the dimension 
between any two points and displays the correct distance between 
those points. For example, you can dimension lines, squares, 

rectangles sides of polygons as well as the distance between objects. 
The Parallel tool is designed to display only parallel dimensions i.e., 
the parallel offset of the actual length between any two points. 

414" “| 8 
Parallel dimension examples 

se 
Parallel dimension between two objects 

NOTE: The examples above show the dimension that displays the 

actual length between any two points. The Parallel tool snaps to any 

of the Snap To tools, allowing you to start and end at different points 
of any two objects. 
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How to use the Parallel Dimension Tool 

O First, select the Parallel tool from the Dimension toolbox. 

(J Select the Snap To tool that you wish to snap to the first 
point of the dimension. 

Then, place the cursor near the point you from which you 
want to start the dimension. Now, click, hold down the 

mouse button and drag the cursor to the second point of 
the dimension, and release the mouse button near the 

point. 

Now you can drag the dimension text out away from the 
object and then click one time to set the parallel 

dimension distance. 

When using the Snap To tools, you can dimension from the midpoint 
of one object to the corner point of another object. You can start and 
end a dimension from any two combinations of the Snap To tools. 

Remember that the Parallel Dimension tool always displays the 
dimension perfectly parallel to the line or imaginary line between two 

objects. 

You can apply any of the dimension options within the Dimensioning 

pop-up menu to any parallel dimension. 

ge) 3 3 Se 

-_ 

we = 
-_ = > 

| Imaginary line or 
actual length between 
the two center points 
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Angular Dimension Tool 

The Angular Dimension tool automatically calculates the dimension 
between any two points that create an angular dimension and displays 
the correct angle between those points. For example, you can 
dimension triangles, angles of pentagons, sides of polygons as well as 
the angle between objects. The Angular tool is designed to display 

only angular dimensions between any two points. 

68.75; : 

Angular dimension examples 

45.00; 

Angular dimension between two objects 

NOTE: The examples above show the dimension that displays the 
actual angle between any two points. The Angle tool snaps to any of 

the Snap To tools, allowing you to start and end at different points of 

one or two objects. 
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How to use the Angle Dimension Tool 

O First, select the Angle tool from the Dimension toolbox. 

J Select the Snap To tool that you wish to snap to the first 
point of the angled dimension. 

Then, place the cursor near the point from which you 
want to start the dimension. Now click, hold down the 

mouse button and drag the cursor along the angled line, to 
the second point of the dimension, and release the mouse 

button near the point 

Click once when you 
reach desired offset distance 

a 
First Point 

Second Point 

1 Now you can drag the dimension text out away from the 
object, while in a circular motion to reach any angle. 
Then click once to set the angled dimension distance. 

When using the Snap To tools, you can accurately snap to the 
end-points of the angled line you are dimensioning. 

The Angle Dimension tool only displays angular dimensions. 

You can apply any of the dimension options within the Dimensioning 
pop-up menu to any Angle dimension. 
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Diameter Dimension Tool gt 

The Diameter Dimension tool automatically calculates the dimension 
of any circle's diameter and displays the correct diameter information 
of the circle. The Diameter tool is used only for dimensioning the 
diameter of a circle. This tool does not require that you use a Snap 

To tool. The Diameter tool automatically snaps to the circle boundary 
points. 

iuaao 

Diameter dimension of a circle 

NOTE: The examples above show the Diameter Dimension of a circle. 
The Diameter tool automatically snaps the circle's boundary line, 
allowing you to quickly display the diameter of any circle. 
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How to use the Diameter Dimension Tool 

O First, select the Diameter tool from the Dimension 
toolbox. 

(J Then, place the cursor near the circle's boundary line. 
Now click, hold down the mouse button and drag the 
cursor in a circular motion around the edge of the circle, 
and release the mouse button near the point. 

+ Ss Place cursor-near 

the circle 

Drag the cursor to the 

desired text position, and 
release the mouse button 

(J Now you can drag the dimension text to any position on 
the dimension line and release the mouse button. Where 

the position of the mouse is when you release the button, 

is the position of the dimensions text. 

You can apply any of the dimension options within the Dimensioning 
pop-up menu to any diametrical dimension. 
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Radius Dimension Tool 

The Radius dimension tool automatically calculates the dimension of 
any arc radius, circle, or fillet and displays the correct radius 
information on the screen. The Radius tool is used only for dimensioning 
the radius of a 90 degree arc, radius of a circle, or the fillet of an object. 

This tool does not require that you use a Snap To tool. The Radius tool 

automatically snaps to the radius start point by clicking the mouse near 

the radius you are dimensioning. 

0.514" 0.805" 

Radius dimension of a Circle Radius of an Arc 

15000" 

Radius of a Fillet 

NOTE: In the examples above the radius dimension display three 
different types of radiuses. The Radius tool automatically snaps the 
radius start point allowing you to quickly display the radius of any 
circle, fillet, or 90 degree arc. 
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How to use the Radius Dimension Tool 

(First, select the Radius tool from the Dimension toolbox. 

[ Then, place the cursor near the radius boundary line. 
Now click, hold down the mouse button and drag the 
cursor in a circular motion around the edge of the arc, 

circle, or fillet and release the mouse button near the point 

you wish to lock the radius dimension to. The Radius tool 
automatically snaps to the start point. 

re ——— Place cursor near 

the arc and hold down 

the mouse button 

Start Point © 

of Radius 

[J Now you can drag the dimension text to any position on 
the dimension line and release the mouse button. Where 
the position of the mouse is when you release the button, 
is the position of the dimensions text. 

Ss Drag the cursor to the 
Va desired text position, 

and release the mouse 

button 

You can apply any of the dimension options within the Dimensioning 

pop-up menu to any radius dimension. You can also change the font 

size, style or color. 
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Leader Line Tool 

The Leader Line tool is used for special quotes or parts of your design 

that need a line with an arrow at the beginning of the line. 

== 
Leader Line example 

.500 radius typ. 

The Leader Line tool can be combined with the Snap To tools, so that 

you can snap to specific points of other objects. 

How to use the Leader Line tool 

1 First, select the tool from the Dimension toolbox. 

[1 Now place the tool at the point from which you wish to 

start. 

(J Then click, hold down the mouse button, and drag the 
cursor to a desired length. Now release the mouse button 

and drag the mouse to the end-point you wish, and click 
the mouse button one time. 

The Leader Line tool has three points you have to place in order to 
create the leader line. 

2nd Point 
3rd Point 

ae 2 — End-Point 

Creating A Leader Line 

Ist Point 

Start Point 
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Snap To Tools 

Almost all technical and engineered drawings require you 
to draw lines, circles and rectangles in a very precise 
location, in specific relationships to each other. For 

example, you may need to start a line at the intersection 
of two different objects, or draw a line perpendicular to 

another line. KeyCAD Complete provides you with the 
Snap To tools to help you in locating the precise points 

required in creating a very detailed and accurate design. 

The Snap To toolbox has the option of being turned on or 

off and can be relocated for added convenience. The 

Snap To toolbox does not appear on the screen when you 

first start the program. You can access all toolboxes 

under the Toolbox subheading found under the Window 
menu at the top of your screen. A check mark (W) beside 
the toolbox name indicates that it is active. 

The Snap To tools have been designed to work in combination with 
the Edit, Draw, and Dimension tools found within the program. 

When using the Snap To tools with the Draw tools you can quickly 
start a line from the end-point of another line and then finish the line 
at the center of a circle. Using the Snap To tools with other tools 
ensures that the line or object created starts and ends in the precise 

location desired. 

You can also set the sensitivity that determines how close the mouse 
cusor must be to an object for the program to snap to a specific point. 

The sensitivity setting is found in the Preference Dialog under the Edit 

menu. 
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When using the Snap To tools you can change tools 
while dragging the mouse, by pressing the Tab key. 

This is so you can start drawing or editing with one 
Snap To tool and end with another. 

tab 

The following is a picture of the Snap To tools as they appear in the 

program. The names have been listed for the appropriate tool icon. 

The name indicates the Snap To command that is performed when 

using that particular tool. These tools should be used in the precision 
alignment of objects as well as with the start and/or end-points of 

objects. 

Drag Zone 

Close Button 

Any Point 

End-Point 

Point On 

Center Point 

Corner Point 

Intersection Point 

Perpendicular 

Line Center 

Percentage 

Absolute Point 

Snap To Toolbox 

NOTE: Remember, by combining these tools with the Draw, 

Dimensioning, and Edit tools you have more precise control of the 

tools function. Always use the Snap To tools before Joining objects. 
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Any Point 

KeyCAD Complete defaults to the Any Point Snap To tool, when you 

first start the program. This allows you to choose any point within your 

document to set a point. KeyCAD Complete supports an interactive 

snap to function. This means the ghost line of the object you are 
drawing or editing snaps to the selected tool's appropriate function, 

allowing you to see where the end-point is to be placed prior to 

releasing the mouse button. on the Any Point tool you see no ghost 

lines. 

NOTE: If the Snap To Grid option is on, you can only snap to points 
on the current grid setting. If the Snap To Grid option is turned off, 

you can locate a point at any coordinate within your current 

document. 

Changing Snap To Tools 

You can change the Snap To tool at any time while pressing the Tab 
key. This is helpful if you want to start with the Any Point Snap To tool 
and end with another Snap To tool. 

When using the Any Point Snap to tool, the cursor always snaps to 
the point on the screen, at the time you click the mouse button. 

Setting Tool to Lock or Reset 

You can set the Any Point tool to a locked position, so that it does not 
reset after you set the first point. Double clicking Locks the tool to a 
black background and single clicking results in a gray background in 

the Reset mode. 
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End-Point 

Use the End-Point Snap To tool to quickly connect the object you are 
creating to the End-Point of another object. The End-Point Snap To 
tool supports an interactive snap to function. This means the ghost line 

of the object you are drawing or editing snaps to the end-point you are 
closest to, allowing you to see where the end-point is to be placed 
before you release the mouse button. 

Anytime the End-Point Snap To tool is selected, the cursor automatically 
snaps to the closest end-point. Any point within an object can be 

considered an end-point. 

The following examples show how objects can have several 
end-points within one object. 

e 2e- 

a ee 
The tool snaps to any end-point if you are within the sensitivity range 
of the end-point being snapped. Sensitvity can be set in the Preference 

Dialog, found under the Edit menu. 
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NOTE: If the Snap To Grid option is turned off you can then snap to 

the closest end-point of the object you are nearest. If the Snap To Grid 

option is on, you can only snap to points on the current grid setting. 

Changing End-Point Snap To Tool 

You can change the End-Point Snap To tool at any time during your 
design process, by pressing the Tab key. This is helpful if you want 
to start with the End-Point tool, and end the object with a different 
Snap To tool, such as the Center tool. 

Setting End-Point Tool to Lock or Reset 

The End-Point tool can be set to a locked position,to prevent resetting 
after you set the first point. Double clicking Locks the tool to a black 
background while a single click on the tool results in a gray 
background in the Reset mode. 
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Point On 

Use the Point On Snap To tool to connect the objects you are drawing 

to a point on another object. The point the tool snaps to, is the closest 
calculated point at the current position when you release the mouse 
button. The Point On Snap To tool supports an interactive snap to 

function. This means the ghost line of the object you are drawing or 
editing snaps to the closest point within the object, allowing you to see 
where the point is to be placed before you release the mouse button. 

Anytime the Point On Snap To tool is selected, the cursor automatically 
snaps to the closest point within the nearest object. Any point within 

an object is considered a point. The tool snaps to any point if you are 
within the sensitivity range of the point you are snapping to. Sensitivity 
can be set in the Preference Dialog, found under the Edit menu. 

NOTE: If the Snap To Grid option is on, you can only snap to points 

on the current grid setting. If the Snap To Grid option is turned off you 

can snap to the closest vertex point within the object nearest to the 
mouse cursor. 

Changing Snap To Tools 

You can change the Snap To tool at any time while pressing the Tab 
key. This is helpful if you want to start with the Point On Snap To tool, 
and end with a different Snap To tool, such as the End-Point Snap To 

tool. 

Setting Tool to Lock or Reset 

Set the Point On tool to a locked position, to prevent resetting after the 

first point is set. Double clicking Locks the tool to a black background 

while a single click sets the tool in a gray background in the Reset 

mode. 
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Center Point 

Use the Center Point Snap To tool to connect the objects you are 
drawing to the center point of another object. The tool snaps to the 

center point of the closest object in relation to its current position, 
when you release the mouse button. The Center Point Snap To tool 
supports an interactive snap to function. This means the ghost line of 

the object you are drawing or editing snaps to the closest center point 
of an object, allowing you to see where the point is to be placed before 
you release the mouse button. 

Anytime the Center Point Snap To tool is selected the cursor 
automatically snaps to the closest center point within the nearest 

object. The tool snaps to any center point of an object, if you are 
within the sensitivity range of the object you are snapping to. 
Sensitvity can be set in the Preference Dialog, found under the Edit 
menu. 

NOTE: If the Snap To Grid option is on, you can only snap to points 

on the current grid setting. If the Snap To Grid option is turned off you 

can then snap to the closest point. 

Changing Snap To Tools 

You can change the Center Point Snap To tool at any time while 
pressing the Tab key. This is helpful if you want to start with the Center 
Point Snap To tool, and end with a different Snap To tool, such as the 
Corner Point Snap To tool. 

Setting Tool to Lock or Reset 

You can set the Center Point tool to a locked position, so that it does 

not reset after you set the first point. Double clicking Locks the tool 

to a black background while a single click on the tool results in a gray 
background in the Reset mode. 
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Corner Point 

Use the Corner Point Snap To tool to connect the objects you are 
drawing to the corner point on another object. Lines have two 
end-Points that KeyCAD Complete identifies as corner points. The 

corners of other objects such as, rectangles, arcs, circles, and ellipses, 
are at the corners of the rectangular boundary lines. 

"= — Corner point 

a sm U a | 

Corner eed 

point of a rectangle 

The tool snaps to the corner point of the object which is closest to the 
current position at the moment you release the mouse button. The 
Corner Point Snap To tool supports an interactive snap to function. 

This means the ghost line of the object you are drawing or editing 
snaps to the closest corner point of an object, allowing you to see 

where the point will be placed before you release the mouse button. 

When the Corner Point Snap To tool is selected the cursor automatically 
snaps to the closest corner point within the nearest object. The tool 

snaps to any corner point of an object, if you are within the sensitivity 
range of the object you are snapping to. Sensitivity can be set in the 
Preference Dialog found under the Edit menu. 
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NOTE: If the Snap To Grid option is on, you can only snap to points 

on the current grid setting. If the Snap To Grid option is turned off you 

can then snap to the corner point. 

Changing The Corner Point Snap To Tool 

You can change the Corner Point Snap To tool at any time while 

pressing the Tab key. This is helpful if you want to start with the Corner 
Point Snap To tool, and end with a different Snap To tool, such as the 
Perpendicular Point Snap To tool. 

Setting Tool to Lock or Reset 

You can set the Center Point tool to a locked position, so that it does 

not reset after you set the first point. Double clicking Locks the tool 
to a black background while a single click on the tool results in a gray 
background in the Reset mode. 
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Intersection 

The Intersection Snap To tool should be used when you want to 
connect the start or end-point of an object where two other objects 
intersect. An intersection is defined as any point where the lines of 
two objects meet or cross. 

Intersection point — 

Be 
Intersection point 

When using the Intersection tool, you can snap to any intersection 

point of two objects. 

The Intersection Snap To tool supports an interactive snap to function. 

This means the ghost line of the object you are drawing or editing 
snaps to the closest intersection of any two objects, allowing you to 
see which intersection the point is to be snapped to before you release 
the mouse button. 

The Intersection tool snaps to any intersection point of any two 

objects, if you are within the sensitivity range of the intersection you 
are snapping to. Sensitivity can be set in the Preference Dialog found 
under the Edit menu. 

NOTE: If the Snap To Grid option is on, you can only snap to the 
closest points on the current grid setting. If the Snap To Grid option 

is turned off you can then snap to any intersection point of two objects. 
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Perpendicular 

This tool should be used when you need a line automatically drawn 
perpendicular to other objects within a design. 

The following examples show lines drawn perpendicular to other 
types of objects. 

ee ee 
Rectangle Open or Closed Polygons 

Line Circle 

To draw a line perpendicular to an object. 

First, select the Line tool from the Draw toolbox. 

Then, select the Perpendicular Snap To tool. 

[J Now, place your mouse cursor near the object you want 
the line to be perpendicular to, click and drag the mouse 
to the desired line length and release the mouse button. 
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You can also designate that a line be perpendicular to an object you 
are finishing the line at. As you are dragging the line to the object you 
wish to be perpendicular to, before releasing the mouse button make 

sure the Snap To tool selected is the Perpendicular tool. Now when 

you release the mouse button near the object, the end-point of the line 
becomes perpendicular to the object. 

NOTE: If the Snap To Grid option is on, you can only snap to points 

on the current grid setting. If the Snap To Grid option is turned off you 
can then have lines snap perpendicular to other objects. 

Changing the Perpendicular Snap To Tool 

You can change the Perpendicular Snap To tool at any time after you 
have started drawing a line, by pressing the Tab key. 

Setting Tool to Lock or Reset 

You can set the Perpendicular tool to a locked position, so that it does 

not reset after you set the first point. Double clicking Locks the tool 
to a black background while a single click on the tool results in a gray 
background in the Reset mode. 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Snap To Tools 

Line Center 

The Line Center tool automatically sets the start or end-point of a line 
at the exact midpoint of a line or free-formed spline. This tool always 
snaps to the midpoint, which is always located between any two 
end-points. 

The following examples further explain how one object may have 
more than one line within the object. This means that the Line Center 
tool snaps to any midpoint between any two points. 

— 

— - 

Midpoint 

= a 
To draw a line at another line midpoint, first select the Line tool from 

the Draw toolbox and then select the Line Center tool. Now place the 
mouse cursor near the object you wish to snap to. Click and drag the 
mouse away from the object, and the line start point automatically 
snaps to the line center point of the object. Remember that the line 
center is located between any two points with a line between them. 
The line can be straight or curved. 

Midpoint 

a Midpoint 
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You can also designate the end-point of the line you are drawing, to 
finish at the line center point of another object. As you are dragging 
the line to set its end-point, be sure that the Line Center Snap To tool 

is selected, before releasing the mouse button. Now, when your 
mouse cursor is near the object you wish to set the end-point at, 
release the mouse button. KeyCAD Complete automatically snaps 
the end-point of the line to the line center point. 

The Line Center Snap To tool supports an interactive snap to function. 

This means the ghost line of the object you are drawing or editing 

snaps to the line center point you are closest to. Therefore allowing 
you to see where the line center will be placed before you release the 
mouse button. 

NOTE: If the Snap To Grid option is on, you can only snap to points 

on the current grid setting. If the Snap To Grid option is turned off you 

can then have lines snap to line center points of other objects. 

Changing The Line Center Snap To Tool 

You can change the Line Center Snap To tool at any time after you have 
started drawing a line, by pressing the Tab key. 

Setting Tool to Lock or Reset 

You can set the Line Center tool to a locked position, so that it does 
not reset after you set the first point. Double clicking Locks the tool 
to a black background while a single click on the tool results in a gray 

background in the Reset mode. 
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Percentage 

When using this tool, it allows you to locate a point on a line, arc, or 

polygon by specifying a percentage value of the line. The percentage 
indicates a distance along the length of the line. The start point is 
considered 0% and the end-point is 100%. A point located at 40% of 

the line's length can be specified and KeyCAD Complete automatically 

locates that point. 

0% 25% 50% 75% 100% 

a 

Start Point End-Point 

You can set the percentage snap value in the Preference Dialog, which 

is found under the Edit menu. 

To draw a line starting at a percentage point of another line, first select 

the line tool from the Draw toolbox. Then select the Percentage Snap 

To tool, place the mouse cursor near the line you wish to snap the start 
point to, and click and drag the mouse away from the line. KeyCAD 
Complete automatically snaps the start point, to the percentage snap 
point of the line you selected. 

The previous paragraph explained how to snap the start point of a line. 

The same principle applies to the end-point of the line you are 

creating. As you are dragging the line, change the Snap To tool to the 
Percentage tool. Then position the end-point of the line, near the line 

you want to snap to and release the mouse button. 
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The Percentage Snap To tool supports an interactive snap to function. 

This means the ghost line of the object you are drawing or editing 
snaps to the percentage point you are closest to. This allows you to 
see where the percentage point is placed before you release the mouse 

button. 

NOTE: If the Snap To Grid is on, you can only snap to points on the 

current grid setting. If the Snap To Grid option is turned off, you can 
then have lines snap to any percentage point that you have set for the 

percentage tool. 

Changing The Percentage Snap To Tool 

You can change the Percentage Snap To tool at any time after you have 
started drawing a line, by pressing the Tab key. 

Setting Tool to Lock or Reset 

You can set the Percentage tool to a locked position, so that it does 
not reset after you set the first point. Double clicking Locks the tool 
to a black background while a single click on the tool results in a gray 
background in the Reset mode. 

Sensitivity Settings 

The Percentage tool snaps to any percentage point of any line, if you 
are within the sensitivity range of the percentage point you are 
snapping to. Sensitivity Snap To setting can be found in the Preference 
Dialog, which is found under the Edit menu. 
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Absolute Point 

The Absolute Point tool always snaps objects, start or end-points of 
objects to the Absolute point of a design. The absolute point is the 

same as the point where the X, Y - Axis lines meet; it can also be 

referred to as the Origin point. The absolute point is always equal to 
X -O and Y - 0. This is the reference point for all absolute readouts. 

The absolute point is located at the lower left corner of a design when 
the program is first started. 

The absolute point is a great point of rotation. It is used for rotating 

and duplicating objects simultaneously, thus giving you a point of 
rotation that can be located at any point within a design. This is 
because the Axis Lines can be moved to any location. 

Rotate objects around 

the Absolute Point (Origin Point) So 

The Absolute Point Snap To tool supports an interactive snap to 

function. This means the ghost line of the object you are drawing or 
editing snaps to the current absolute point within your document, 
allowing you to see where the end-point of the drawn line is to be 
placed before release of the mouse button. 

To draw a line from the absolute point, first select the Line tool from 

the Draw toolbox. Then select the Absolute Snap To tool and place 
the mouse cursor near the absolute point on the document. By 
clicking and dragging the mouse, the start point of the line automatically 

snaps to the absolute point. 
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You can also designate the end-point of the line you are drawing, to 
finish at the absolute point within your document. As you are dragging 

the line to set its end-point, be sure that the Absolute Point Snap To 

tool is selected, before releasing the mouse button. Now, when your 

mouse cursor is near the absolute point in your document, release the 
mouse button. KeyCAD Complete automatically snaps the end-point 

of the line to the absolute point. 

NOTE: If the Snap To Grid option is on, you can only snap to points 

on the current grid setting. If the Snap To Grid option is turned off, 

you can then have lines snap to the absolute point that you have set 
within your document. 

Changing The Absolute Snap To Tool 

You can change the Absolute Point Snap To tool at any time after you 
have started drawing a line or moving an object, by pressing the Tab 
key. 

Setting the Absolute Point Tool to Lock or Reset 

You can set the Absolute Point tool to a locked position, so that it does 
not reset after you set the first point. Double clicking Locks the tool 
to a black background while a single click on the tool results in a gray 

background in the Reset mode. 

Sensitivity Settings 

The Absolute Point tool snaps to any absolute point coordinate that 

you have currently set within your document, if you are within the 
sensitivity range of the absolute point you are snapping to. Sensitivity 

of Snap To settings can be found in the Preference Dialog under the 

Edit menu. 
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File Menu 

The File menu contains the following commands: New, Open, Close, 

Save, Save As, Import (file formats), Export (file formats), Open and 

Save Symbols, Paper Size, Page Setup,Plot, Print, and Quit. 

Some of the File menu commands can be accessed with keyboard 
equivalents, when combining the Command key with the appropriate 

key, as shown below. The following pages in this chapter explain the 
proper uses for these menu commands. 

Close 

Save 

Save Als... 

Import 

Export 
aa 

Open Symbol... 

Save Symbol... 

Paper Size... 

Page Setup... 

Plot... 

Print... ae P 

File Menu 
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New 

The New command allows you to open a new document as shown 
below. The new document is untitled and has only one layer. The 
title bar automatically displays "Untitled1", which means that the 
document has no name. If you wish to name the document, you must 
first save the document to name it. If you choose not to name the 
document, and open another new document, then the number 1 of 

"Untitled1" changes as you open each new document. 

KeyCAD Complete supports multiple documents, meaning that you 

can use the New command even if a document is previously opened. 
The new documents appear on top of each other, without replacing 

the previous document. In order to change the names of the new 
documents, save them. 

@ File Edit Layout Options Window Eagets Text 

oH 

aes 

2a 
eta 
cx 

Poe 

BRENNER | Seca. Se eS 97.8 CNY 
ene? 

BANGS eH: 

eset COME PME HO aHR 

ap ee iasteceen ses 

New Untitled Document 
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Open... 

This command allows you to open previously created documents. To 

access this command you can select the Open command from the File 
menu, or you may press the Command - O keys. After you have 
chosen the Open command, a Dialog appears allowing you to select 

the name of the file to be opened. 

On the appearance of the Dialog box select the document you want 
from the list in the box. The list contains the names of each KeyCAD 

Complete file and folder on the current drive. If you have more file 
names than what can fit in the window, use the scroll bars to find the 

file or folder name required. 

If you decide not to open a file, you may click the Cancel button, to 

return to where you left off when first selecting the Open command. 
You may refer to the Macintosh User Manual under Opening 
Documents and Folders. 

O Bracket a2| Hard Disk 
DO Camera : 
D Untitled-1 
O Untitled-2 Desktop 

EIDSOOOOOSOOIOOOS OASIS OOOO OOS OOS OOOOH OMS SII MNP OLN ONIN HORMONAL H SDN INH H NHN 

Open Dialog box 
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Close 

The Close command is used to close the currently active document. 
The Close command is found under the File menu or you can choose 
to press the Command - W keys to activate the Close command. (One 
of the quickest ways to close a window is to click on the Close button, 
found in the upper-left corner of the window.) 

Other open documents are not affected by the Close command. To 
close a window that is not active, click on the window first to activate 

it and then choose the Close command. 

If at anytime you have made changes to a currently active document 
since the last time you saved it, a message Dialog appears asking if you 

wantto save the new changes before closing the window or document. 

If you decide to close all opened documents or windows, you will see 
an empty desktop with KeyCAD Complete still open. 

AAAI AIS NNO HAHN HAHAHAHAHAHA HADEN H AANA HOA INAH AAAI AO ALARA ALLA L LLL LLL LLL LLP A LL LDL LAE LALO LE ILE LL LE LALO OLE, 

Save changes to “Untitled-?” before 

closing? 

ee 

i Nes] 
« 4 

° G2 ee ee eee 

Close Document Warning Dialog box 
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Save 

This command saves a copy of the current document you are working 

on. The Save command is found under the File menu, or you may 
access the Save command by pressing the Command - S keys. 

When choosing the Save command, only the document that is active 
is saved. The program always saves the file to the currently selected 
folder or drive. If you have several windows open, you must activate 
the window that contains the document you wish to save, before 
selecting the Save command. 

If you are working on an untitled document, a Dialog box appears 
asking you to name the document. The example below shows the 
Save Dialog. 

© Adobe Dimensions™ 

© Adobe Photoshop® 2.0.1 

© Aldus IntelliDraw 
O Aldus PageMaker 4.2 

Save File As: 

Save Dialog box 

Once the Dialog appear, you can then type a name and either click 

the Save button or press the Return key. If your current disk does not 
have sufficient room, a message appears asking you to save the 
document to another disk. 

If you have saved the document earlier and then choose the Save 
command, you see neither Dialog nor message. The Save command 
automatically updates the current document by replacing the version 
on the-disk with the version currently active on the screen. 
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Save As... 

When you want to update the most recent changes of your current 
document, choose the Save command. You use Save As when you 
want to save a copy of the current document without affecting or 
replacing the version currently within your window. 

The Save As command saves a file or document under a different 

name, folder, or ona different disk drive. You can use Save As to save 

a new file or document for the first time. The Save As command is 

found under the File menu at the top of your screen. 

&) Hard Disk ¥ <— Hard Disk 

f) Bracket 

Mm Camera 

i} FinarPian 

fi Untitied-1 

) Untitied-? 

Save File fis: 

. SLD DOM ODOM 

Save As Dialog box 

You could use Save As in a couple of different ways. For example, you 
can make a backup copy of a current work file, or keep both the 

original version of the file along with a more recent version. In making 
different versions, you save the original version under one name, and 
then use Save As again to save the new document under a different 

name. 

If you want to save a file in a different folder, double click the folder 
name in the list box to open the new folder. You can also change 
which drive the new file is saved to, by clicking on the drive name 
shown in the upper right-hand corner of the Save As Dialog. 
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Import 

The Import option is a pop-up menu that allows you access to the 

different file formats that are supported within KeyCAD Complete. 
The formats that can be imported are PICT, DXF (AutoCAD), IGES, 

and XYZ Coordinates. 

PICT 

Choose PICT to display files that have been saved in PICT or PICT2 
formats. The PICT format allows you to export your KeyCAD 
Complete documents to almost any Macintosh program that supports 

the PICT format. Remember that the PICT format is an integer based 
format and does not maintain a floating point database. (Integer is 
defined as a whole number or zero, no numeric digits to the right of 
the decimal point.) 

DXF 

Choose DXF to display or open files that have been saved in the DXF 

format. The DXF format is the most popular among AutoCAD users, 

this format is used when transferring AutoCAD files from one 
computer program to another. 

IGES 

The IGES format is used in transporting AutoCAD files or other CAD 

programs within the industry. IGES stands for Initial Graphics 
Exchange Standard. This format is very common among analysis 
programs. 
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XYZ Coordinates 

This format is used when you want to import XYZ coordinate points. 

When using this format, the program only places data points in the 
proper coordinate position. The program does not draw lines or 

curves between these points. 

Export 

The Export option is a pop-up menu that allows you access to the 

different file formats that are supported within KeyCAD Complete. 

These formats can be exported to any program that supports the PICT, 

DXF, IGES, HPGL, EPS, and XYZ Coordinates. When you choose one 

of the formats within the Export menu, a Dialog box appears 

prompting you to name the file. 

The formats are briefly defined under the Import section of this 

chapter. Export menu supports two more formats than the Import 

menu, these formats are HPGL and EPS. 

HPGL 

This format is exported when you want to create an HPGL file that can 

be used with plotter servers. A file can be plotted without having to 

have the KeyCAD Complete program when plotting. Think of it as a 

stand alone format. 

EPS 

The EPS format stands for Encapsulated PostScript, which translates a 

file to the PostScript page-command language. This format is very 

popular among page layout and illustration programs. 
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Open Symbol... 

Symbols are treated like individual files that can be placed within your 
current design. Symbols are predrawn images that you can use in 

saving time when creating your design. 

Remember that a Symbol file format is different from the regular file 
format that your designs are saved in when you select the Save or Save 
As command. 

To open a symbol, pull down the File menu and select the Open 
Symbol command. A Dialog box appears asking you to choose the 
symbol name of your choice. Once you find the symbol name of your 
choice, click on the name one time and then click on the Open button. 

You can also double click on the symbol name to instantly open the 
file. 

Save Symbol... 

When you have created an object to be saved as a Symbol, you must 
first select the object that you wish to save, before choosing the Save 
Symbol command. Once you select the Save Symbol command from 
the File menu, a Dialog box appears prompting you to name the 

symbol you are saving. Once you have saved the symbol, you can 
then open that symbol from the Open Symbol command. 
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Paper Size... 

When you select the Paper Size command from the File menu, a 
Dialog box appears asking you to choose the paper size for your new 

document. You have several industry standards to choose from, or the 
option to create a custom paper size. The program also supports most 
of the metric standard sizes of paper. The pull-down menus have the 

letter or numeric name along with the paper's actual dimension size. 
When the program is first started, it defaults to the Mechanical "A" size 
(8.5"x11") piece of paper. You can change Paper Size at anytime 

while creating your design. 

Once you choose a paper size, the program represents the paper with 
a white background. If you scroll to the edge of the paper, you can 

notice where the paper ends and the background color of your monitor 
begins. Click the OK button once you have selected the proper paper 
size. 

Below is an example of the Paper Size Dialog box, and the following 
pages display the pull-down menu options. 

Paper Size: 

@ Architectural: 

O Mechanical: 

| 

| 

© Metric: | DIN A4: 210mm x 297mm 

© Oversize: | A4: 240mm # 330mm 

© Custom: 

width: — 

AANANAABARASIAP ASE REBRABBANRDBSNRIEDSEBAINEDORRPRDD ARR P PRASAD ANEPNENAABSS ON NERD BPR DSDAN EDEN SBADD 

Paper Size Dialog box 
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Paper Size Chart 

Architectural: A 9* x 427" 

B 2 xe 

= 18" x 24" 

D 24" x 36" 

E 36" x 48" 

F 28" x 40" 

30/42 30" x 42" 

Mechanical: A 8.5" x 11" 

B 11" x 17" 

E 7" x22" 

D 22" x 34" 

E 34" x 44" 

Metric: DIN A4 210mm x 297mm 

DIN A3 297mm x 420mm 

DIN A2 420mm x 594mm 

DIN Al 594mm x 841mm 

DIN AO 841mm x 1189mmM 

DIN B1 707mm x 1000mm 

Metric Oversize: A4 240mm x 330mm 
A3 330mm x 450mm 

A2 450mm x 625mm 

Al 625mm x 880mm 

AO 880mm x 1230mm 

Custom Size... Can choose from in., mm or cm and 
have custom horizontal and vertical 

paper widths. 
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Page Setup... 

The Page Setup command specifies the page size, orientation, and 

pagination of your current file when you choose to print the active file. 
You find the Page Setup command under the File menu. After you 
choose the Page Setup command, the Page Setup Dialog box appears 

on screen. 

NOTE: The information which is displayed in the Page Setup Dialog 
depends on the system software and printer drivers' that you may use 

with your Macintosh. 

The following example displays and discusses the page setup for the 

ImageWriter. If you are using an Apple LaserWriter, a plotter, or 

another printing device, the settings and choices within the Dialog 

box are different. 

@ US Letter © A4 Letter 
© US Legal © International Fanfold 

C) Computer Paper 

ation Special Effects: (J fall fidjusted 
— [] 80 % Reduction 
= [] No Gaps Between Pages 

IOP OOS OOD OOOO IMI OPINION PIII IOI ODIO OOOO IOI IIIA IAIN? 

Page Setup Dialog box for ImageWriter 

If you choose to change the page size or the orientation, you must click 
on the appropriate button. Once you have made your settings, you 
can then select Print from the File menu. 
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Plot 

The Plot command allows you to plot your designs to any HPGL 
(Hewlett Packard) compatible plotter. The Plot Dialog box allows you 

to setup the program's parameters to your plotters specification. For 
plotter specifications refer to your Plotters Manual. 

You have the option to set the Baud Rate, Stop Bits, Parity, Data Bits, 

and you can choose from several different HP plotter models. Each 
option is a pull-down menu, so click and hold down the mouse button 

to access the pull-down menus. 

Before clicking on the Plot button, be sure that the Dialog box settings 

are set for your plotter. 

Your plotter must be plugged into the printer port on the back of your 

Macintosh. 

The paper size that you plot to, is determined by the Paper Size Dialog 

box found under the File menu. 

Plot: 

Baud Rate: 

Stop Bits: 

Parity: 

Data Bits: 

Plotter 

Plot Dialog box 
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Plot dialog pull-down menus are listed below: 

Baud Rate: Parity: ae | 

Data Bits: 

Stop Bits: 

Plotter: “HP-72270 

HP- 7440 

HP-7470A 

HP-?#475A 

HP-7475B 

HP-7550A 

HP-?75508 

HP-?570A 

HP-75 700 

HP- 75806 

HP-?75800 

HP-?565E 

HP-Draft Master 
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Print 

You can choose the Print command from the File menu or you can 
press the Command-P keys. Once you choose the Print command, the 
program prints only the active view on the screen. Only the active 
window is printed. Any other documents or files in the background 
that were opened when you chose the print command are not printed. 

NOTE: The information which is displayed in the Print Dialog 
depends on the system software and printer drivers that you use with 
your Macintosh. 

The following example displays and discusses the Print Dialog box for 

the ImageWriter. If you are using an Apple LaserWriter, a plotter, or 

another printing device, the settings and choices within the Dialog 
box are different. You should refer to the Printer or Plotter Manual for 

more details concerning your printing device. 

4 

g 4 LPIPPPPIIIPPFPILL OL IPDS PP EPL EPL EPL IPL PPIPPL SPLIT PREPPPEPIL FIP PDD 

1 ImageWriter 

Quality: @ Best ©) Faster ©) Draft 

Page Range: @ All © From: BS To: =e 

i] Copies: 

Paper Feed: @ Automatic © Hand Feed 

ImageWriter Print Dialog box 

You can choose from Best, Faster, or Draft quality printing. Select 

either All or From what page To what page you want to print, as well 
as the number of copies to be printed. Once you have made your 
selection, click the Print button or press the Return key. 
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Quit 

The Quit command allows you to exit the KeyCAD Complete 

program, when you finish working on a file and you wish to leave the 

program. You have the option of choosing the Quit command from 

the File menu or pressing the Command-Q keys. 

If at anytime you have changed the currently opened file, the warning 
"Save changes before quitting?" appears. If you want to save the 

changes then click Yes. If you had several windows opened on the 
screen, KeyCAD Complete asks you to save each one individually. 
The warning "Save changes to...?" appears, naming each open file that 
you have changed. This allows you to decide to save the changes or 

not. If any of the opened files are untitled, the Save Dialog box appears 

to let you name the file before saving it. 

Save changes to “FineLine” before 

quitting? 

Quit Dialog box 
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Edit Menu 

The Edit menu is designed to offer you the commands for changing, 
editing or modifying any objects and text within your design. For 
example some of the commands found within the Edit menu are 

Undo, Cut, Copy, Paste, Clear, Select All, Detect All, etc. Many of 

these commands have menu equivalents for quicker access. 

The Preferences dialog box is accessed under the Edit menu. This is _ 
were you can change the preference of certain defaults found within 
the program. Some of the Menu Bar commands, are also found under 
the Edit menu. 

£34342 £3 

Select All 

Detect All a6 KK 

Hide Selection oul 

Duplicate a6 0D 

Duplicate Offsets... 

Mirror Horizontal 

Flip » 

Nudge > 
smoothing 

Preferences... 

Show Clipboard 

Edit Menu 
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Undo 

The Undo command allows you to cancel the last action that changed 
the file you are working on. For example, if you create a door, then 
resize the door and decide that the original size is preferable, then 

choose the Undo command from the Edit menu. 

Undo is found under the Edit Menu 

The Undo command permits cancellation of the last action on an 
object, such as cutting or pasting, duplicating, resizing, reshaping or 

changing position and location. 

NOTE: Undo works only on the last action performed. Once another 
action changes the file, the preceding action cannot be undone. 

Scrolling, selecting a drawing, changing of a Dialog box, or the 
resizing of a window, are actions that cannot be undone and 

effectively do not change a file. 

Two choices are presented in activating the Undo command. One is 
to pull down the Edit menu and drag the mouse over the word Undo, 
then release the mouse button. The second, is to press the Command- 
Z keys. 
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Cut 

The Cut command removes any selected objects or text from your 
design and automatically places them on the Clipboard. Remember 

that when you use the Cut command, you replace anything currently 
on the Clipboard with the new selection that you have Cut. 

You can choose the Cut command from the Edit menu or press the 
Command-xX keys. 

Undo ae 

Cut is found under the Edit Menu 

Use Cut to delete objects, text, or to move them to a new location on 

your design. To use the Cut command you must first select the object 
or text and then choose the Cut command, so it cuts the selected 

objects to the Clipboard. Move or scroll the document to a new 
location and choose the Paste command to place the Clipboard 

contents at the center of your new location. The Paste command is 
also found under the Edit menu. 

Cut can be used to move objects from one KeyCAD Complete 

document to another. Cut the object from the first document, then 

open the second document and choose the Paste command. If you 
have multiple windows opened, you can Cut from the active window 
then click on the window you wish to activate, then choose the Paste 
command. 
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Copy 

Choose the Copy command to copy selected objects or text to the 
Clipboard. The copied object replaces anything on the Clipboard 

with a newly selected object. Use the Copy command to duplicate 
objects or text within the current document or different files. 

You can choose the Copy command from the Edit menu, or press the 
Command-C keys. 

Copy is found under the Edit Menu 

You must select the objects or text prior to selecting the Copy 
command. After selecting the Copy command, the objects or text 
remain selected. Deselection is done by clicking anywhere on the 
drawing area. 

Once a selection is copied to the Clipboard, the object or text can be 
pasted to another section of the document or even to the file of another 

application that supports the paste command. 

The Copy command is used for copying and pasting objects or text into 
the Scrapbook. The Scrapbook is found under the Apple menu. For 

more information concerning the Scrapbook, please refer to the 

Macintosh Owner Manual. 
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Paste 

The Paste command places a current copy of the Clipboard contents 

into the active layer of the current window. Pasting an object from the 

Clipboard does not clear the Clipboard contents. Because the 
contents of the Clipboard remain on the Clipboard, you can use the 

Paste command repeatedly to make multiple copies of text or objects 
within the same or different files. For a description on other methods 

of duplicating objects, please refer to Duplicate and Duplicate offsets 
under the Edit Menu section of this manual. 

You can choose Paste from the Edit menu, or press the Command-V 

keys to activate the Paste command. 

Paste is found under the Edit Menu 

Pasting an Object 

KeyCAD Complete pastes an object by placing it in front of all other 
objects within the current file. 

(1 If you have just opened the current file and choose the 
Paste command, the copy is placed in the center of the 
screen. 

(J If you have scrolled the file in the window, the copy is 
placed in the center of the screen. 
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[J Since KeyCAD Complete supports multiple layers within 
one file, you can also use the Cut, Copy, and Paste 

commands when moving objects between layers. 

Be sure to activate the layer first before choosing the Copy 
command, then activate the layer you wish to Paste the 

object into. 

Transferring Pasted Objects 

An option exists for the transferring of complete drawings, individual 
objects, and text created in other applications. The aforementioned 
designed in MacDraw, Canvas, FreeHand, Illustrator, can be transferred 

to the Clipboard or the Scrapbook, and then pasted into your KeyCAD 

Complete documents. The entire contents of the Clipboard or 

Scrapbook, are pasted into the KeyCAD Complete document as one 

object and not separately. Once the objects have been pasted within 
the document, resizing of the object can be done. 

NOTE: To paste a drawing, object or text from any kind of Paint 
product such as MacPaint, SuperPaint or PhotoShop remember the 

applications draw the images on pixel basis dot by dot (bitmapped). 

You will be unable to edit the objects that appear within the 
boundaries of the pasted object. You can neither Ungroup nor Unjoin 

these objects. Files created in a Paint application are called Raster 
files. 

If you use Cut, Copy, and Paste to transfer objects from applications 
that support vector objects such as MacDraw, Canvas, ClarisCAD, 

and KeyCAD Complete, you will be able to edit, ungroup, or unjoin 

these objects. Files created in a draw application such as the ones 
listed in this paragraph are called Vector files. 
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Clear 

The Clear command removes (clears) selected objects or text from 

your design. The Clear command does not place the cleared object 
on the Clipboard. Clear is used when you want to delete or 
permanently remove any selected object or text. This is useful to clear 
an object from the design, while maintaining the contents of the 
Clipboard. 

You can select any object or text and press the Delete key, which 
removes (clears) the selected object. The Delete key does not affect 
the contents of the Clipboard. 

NOTE: Remember to use the Undo command to cancel the most 

recently cleared object. 

How to Clear an Object 

First, select the object or text that you wish to clear. 
Second, pull down the Edit menu and select Clear. You 
may choose to press the Delete key. 

(J The object selected is then permanently removed from 
your design. If necessary you can choose Undo to retrieve 
the object. 

OO 
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Select All 

The Select All command allows quick access for selection of objects 
within your design. This includes text and geometric shapes. The 

vertex points of each object are highlighted as an indicator that the 

objects are all selected. 

Upon choosing the objects within your design, it is easy to move them 

to a different location. 

Moving objects with Select All 

(1) First, pull down the Edit menu, then choose the Select All 
command. You should notice that all vertex points are 
highlighted. 

Now, select the Selection tool (Arrow tool), which is the 
first tool in the Edit toolbox. 

Place the cursor on top of one of the selected objects, then 

hold down the mouse. button while dragging the objects to 

a new position. You can watch the readouts at the bottom 
of your screen for a precise location. 

Another way of making the Select All command work for you, is to 
select all objects before you choose a command that affects the entire 
file. For example, you can lock all the objects within your design to 
a specific grid point, or you can even group all of the objects together. 
If you want to clear everything on your design, choose the Select All 
command, and then press the Delete key, or select Clear from the Edit 
menu. This is much faster than selecting each individual object. 
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Using Select All to Move Objects 

With the Select All command subsequent mouse repositioning moves 

all the objects together. Individual objects cannot be repositioned but 
you can change the place of the entire design by dragging the objects 

to anew setting. If your entire design is bigger than your monitor, you 

may want to choose Fit to Window to help you in design adjustment. 

Resizing with Select All 

Once the Select All command is chosen, you cannot resize each 
individual object. If you drag a handle, it proportionally and 

simultaneously resizes all of the selected objects. For example, if you 
drag a handle to reduce the size of one object, all selected objects are 
reduced by the corresponding amount that you drag the mouse. 
However, the distance between all objects does not change. The 

distance from the center of one object to the center of the next object 
remains the same. Only the object size changes either by enlargment 

or reduction. Objects can be reduced by pushing the mouse towards 
the center of an object and enlarged by dragging it away. 

An entire design can be reduced or enlarged yet maintaining 
proportional spacing between objects. First, select the Select All 

command from the Edit menu, and then choose the Group command 

found under the Options menu. Then select the Resize tool and grab 

a selected handle, and begin reducing or enlarging. An example for 

this option is if you want to reduce the entire size of a design,, fit on 

a particular size of paper. 
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Detect All 

The Detect All command should not be confused with the Select All 

command. These two commands have completely different end 
results. You can access the Detect All command under the Edit menu, 

or you can press the Command - K keys. 

Detect All is designed to undo the Hide Selection command also 
found under the Edit menu. The Hide Selection command hides any 
selected objects from being selected again. To select an object which 
is currently hidden use the Detect All command. 

Example 

(J First, select one or more objects, and then select the Hide 

Selection command from the Edit menu. 

(1 After choosing Hide Selection, the chosen objects cannot 
be selected. 

(J To deactivate the Hide Selection pull down the Edit menu 

and choose Detect All. The hidden objects become 
reselectable. 

This feature is useful when working in very detailed design areas; 

encountering problems selecting a particular point due to the close 

proximity of several points. To remedy this, select the points not to 
be altered and use the Hide Selection command, permitting work on 
the point of your choice. To release the Hide Selection upon 

completion of work, pull down the Edit menu and select the Detect 
All command. 
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Hide Selection 

The Hide Selection command allows you to select any object or 
groups of objects such as lines, rectangles, circles, polygons, and hide 
them to prevent selection with any of the tools. 

Example 

(1) First, select the objects to be hidden using the Selection 
tool from the Edit toolbox. 

[J Now, pull down the Edit menu or press the Command - J 

keys to activate the Hide Selection command. 

1 Now, you cannot select any of the objects that were 
previously selected. 

(1) To release the Hide Selection command, pull down the 

Edit menu and select Detect All. This allows selection of 

any object that was previously hidden from selection. 

This feature is useful when you are working in very tight design areas; 
encountering problems selecting a particular point due to the close 
proximity of several points. To remedy this, select the points which 
are not to be altered and use the Hide Selection command. To release 
the Hide Selection upon completion of work, pull down the Edit menu 
and select the Detect All command. 
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Duplicate 

The Duplicate command immediately copies any and all selected 

objects, including text blocks. Subsequently, it places the duplicate 
object in the current window. This command does not place a copy 
of the selected objects onto the Clipboard, therefore the Paste 

command is not necessary. Duplicate is an option that allows copies 

of any selected object in one easy step. 

The Duplicate command is found under: the Edit menu, or you can 
press the Command - D keys. 

The Duplicate Offsets affect the location of the newly duplicated 
objects. Please, refer to the upcoming section called Duplicate 
Offsets, for more information. 

Using Duplicate 

When using the Duplicate command, first select the object(s) that you 
wish to duplicate. Then, pull down the Edit menu and select the 
Duplicate option, or press the Command - D keys. The copy that 

appears is slightly offset from the original. Once the object is selected, 
you can immediately edit, reduplicate or relocate it. 

If you select and duplicate objects that appear on different layers, the 
duplicates appear on the same layers as the original objects. If you 

wish to duplicate an object(s) and place them on a different layer, use 
the Cut, Copy and Paste commands. This copies the object and places 

it on the Clipboard. Pasted objects appear in the active layer. 
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Example 

The example below shows you a duplication of a bush for a landscape 
layout. 

1. First, select the bush as shown below. Notice the 

highlighted points around the object. 

2. Now pull down the Edit menu and select Duplicate, or 
press the Command - D keys. After selecting Duplicate, 

notice the new object is highlighted. Use the Selection 

tool to drag the duplicate to a new location. 

Duplicate Bush 
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3. After moving the second duplicate bush, select the 
Duplicate command and make a third bush. Reposition 
the third bush to its proper location. 

Third Bush 

4. When moving the objects after duplication monitor the 
readouts at the bottom of the screen to assist in relocating 
the selected object to a precise coordinate. 

NOTE: The Duplicate Offsets Dialog box determines the offset 
distance the duplicate object(s) is to be placed after duplication. The 

Duplicate Offsets Dialog can be accessed from the Edit menu. 
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Duplicate Offsets... 

The Duplicate Offsets Dialog box is useful for laying out charts and 

other design elements such as evenly spaced bolt patterns or multiple 

shrubs in a landscape design. The Duplicate Offsets Dialog function 

duplicates a selected object requiring a number of evenly spaced 

copies. 

The Duplicate Offsets Dialog can be accessed by pulling down the 
Edit menu. Once you type in the Horizontal and Vertical offsets 
together with the number of Repeats, click the OK button or press the 

Return key to close the Dialog. 

The Horizontal or Vertical offsets are changed within the Duplicate 

Offsets Dialog. The Duplicate command duplicates the number of 

objects and their offsets in correlation to the settings within the 
Duplicate Offsets Dialog. 

All Duplicate Offset objects are measured from the origin of the 
preceding object. Once you choose the Duplicate Offsets and Repeat 

Count of a selected object, the position of the first copy is measured 
from the origin of the original object. The position of the second copy 

is measured from the origin of the first duplicate copy. This process 
is repeated as many times as the Repeat Count entry displays. 

Copies of objects created via the Duplicate Offsets or Duplicate 
command are placed in front of the original. This applies to each 
duplicated object regardless of the Repeat Count number. 

NOTE: The Duplicate Offsets and Duplicate command do not affect 

the contents of the Clipboard. 
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The example below shows the actual Duplicate Offsets Dialog box 

settings found within the program. 

Duplicate Offsets: 

Horizontal Offset: 

Vertical Offset: 

Repeat Count: 

Duplicate Offsets Dialog box 

How to use the Duplicate Offsets 

(1 First, select the object you wish to duplicate by using the 
Duplicate Offsets Dialog box. Use the Selection tool for 

selecting objects 

Selected object 

(J Once you have selected the object pull down the Edit 
menu and select Duplicate Offsets. After the Dialog box 
appears type in a Horizontal Offset of 1.00" and a Vertical 
Offset of O", and a Repeat Count of 2. Now click the OK 

button or press the Return key. Your design should repeat 

as shown below. 

OO 
Object after Duplicate Offset command 
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Mirror Horizontal 

The Mirror Horizontal command allows you to flip any selected object 
or group of objects in a diametrically different direction. Select an 

object and perform the Mirror command to make a duplicate of the 
object flipped horizontally and placed by a certain offset. 

The Mirror Horizontal command is found under the Edit menu. For 

quick access to the Mirror Horizontal command, activate the Menu 
Bar and click the Mirror button. 

© AW) ee 
Mirror Button 

The Menu Bar can be turned on or off by pressing the Command - M 

keys or by pulling down the Layout Menu. 

How to use Mirror Horizontal 

The following example shows you how to use the Mirror command to 
create a frontal view of a tree. Creation of the first half of the tree is 
devised using the Open Polygon tool. 

O First select the object or groups of objects that you wish to 
mirror. Use the Selection tool for selecting objects. 
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1 Once the object is selected, you need to pull down the 
Edit menu and select Mirror Horizontal, or press the 
Mirror button on the Menu Bar. 

1 Notice that after you select the Mirror command, the 
newly duplicated copy is selected and slightly offset in the 
Horizontal axis. This is so you can move or edit that 

object if necessary. 
Now that the second half of the tree is created, use the 

Selection tool to drag the mirrored copy in alignment with 

the original half of the tree. The example below shows 

the end result after alignment of the mirrored objects. 
Once the mirrored objects are aligned, take the Line tool 

and make accent lines within the trees boundary lines. 
This adds a more realistic appearance. 

Final Example 
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Flip 

The Flip command lets you flip any selected object or group of objects 
horizontally or vertically. When flipping objects, the program uses 

the center of the selected objects for a reference point. 

The Flip command is found under the Edit menu. The Flip options are 

found within a pop-up menu. To access the pop-up menu, drag the 

mouse cursor on top of the word Flip while holding down the mouse 

button. 

Horizontal 

Vertical 

Hold down mouse button to access pop-up Menu 

For quick access to the Flip Horizontal and Vertical commands use the 

Menu Bar buttons. To turn the Menu Bar on or off, pull down the 

Layout menu or press the Command - M keys. 

se) (2H) 
Flip Vertical Flip Horizontal 

Buttons Buttons 

Example 

The Flip Horizontal command is useful for creating objects that should 

be symmetrical along a vertical axis. An example of this, is if you draw 
a free-formed shape, copy the shape, and then reposition and flip the 
copy to produce two free-formed shapes with symmetrical curves and 

lines. The Vertical Flip command works in the same manner, except 

the objects flip on the Vertical axis. 
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Flip Horizontal flips the object along the Horizontal axis. 
Think of it as flipping the object to the right of the original 
object. 

Vertical Axis Line 

Up or Down 

Horizontal Axis 

Left to Right 

[=] Flip Vertical flips the object along the Vertical axis. Think of 
it as flipping the object down from the original object. 

Vertical Axis Line 

Up or Down 

Horizontal Axis 

Left to Right 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Edit Menu 

Nudge 

The Nudge commands are very useful when you want to move 
selected objects in small or large increments without using the 
Selection tool (Arrow tool). When moving objects, it sometimes 
becomes difficult to move selected objects using the Selection tool 
(Arrow tool). With this in mind, KeyCAD Complete has designed 

several convenient ways of Nudging (moving) selected objects. You 
can set the distance an object is to be nudged, by accessing the Nudge 
Rate Dialog box. 

To access the Nudge command pull down the Edit menu, highlight 
Nudge and a pop-up menu appears, from which you can select either 

Nudge UP, DOWN, LEFT, or RIGHT. You can also access the Nudge 

Rate Dialog box. 

Nudge Rate... 

Nudge Pop-up Menu 

The Nudge Buttons 

KeyCAD Complete has placed Nudge buttons on the Readout display 

window. The display buttons support two types of Nudge, i.e., 

Incremental Nudge and Absolute Nudge. The following examples 
display two types of Nudge. 

Nudge Absolute Nudge Incremental 

Buttons Buttons 

SoftKey: Changing The Way America Buys Software 7-21 



Edit Menu KeyCAD Complete for MAC 

Nudge Absolute 

The Nudge buttons allow you to nudge any selected object(s), and 
individual vertex points from the Absolute reference point (Origin 

Point). The Absolute (Origin) Point is where the axis lines meet. The 

program defaults to the lower left of the screen. 

For example, select an object then click on one of the Nudge buttons, 
either to the left or to the right and up or down. The selected object 
moves in that direction according to the distance set within the Nudge 
Rate Dialog box. The program defaults the Nudge Rate to one pixel 
or 1/72". 

NOTE: Remember the reference point from which the Nudge is 
calculated, is the Absolute (Origin) point of your design. 

Absolute Nudge Buttons 

Nudge X (Left or Right), when clicking on these buttons 

the object moves along the X-Axis. 

4b X: 0.58 

Nudge Left or Right 

Nudge Y (Up or Down), when clicking on these buttons 

the object moves along the Y-Axis. 

os 
rd ¥: -0.83 

Nudge Up or Down 

Click the Nudge buttons as many times as necessary. 
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Nudge Incremental 

These nudge buttons allow you to nudge any selected object(s) and 
individual vertex points in Incremental coordinates. Incremental 

means that the selected object moves in reference to the original 
position of the object or points. For example, if you select a rectangle 

and then click on the 4 W Nudge buttons, the rectangle changes 
in width, which changes the size of the selected object. The nudge 
distance is set in the Nudge Rate Dialog box. 

If you select an object then click on one of the Incremental Nudge 
buttons, either (W) left or right and (H) up or down, the selected 

objects change in Width or Height according to the distance set within 
the Nudge Rate Dialog box. The program defaults the Nudge Rate to 
one pixel or 1/72". 

When using the W or H nudge buttons on selected objects, the width 
and height are referenced from the center of the selected object. 

Incremental Nudge Buttons 

40 Ww: 0.19 

7 H: 0.14 LT . ° 

[J Nudge W, when clicking on these buttons the object 
changes along the X-Axis. 

qb Ww: 0.19 

Nudge Width (Left or Right) 

CJ Nudge H, when clicking on these buttons the object 
changes along the Y-Axis. 

rs. 

Nudge Height (Up or Down) 
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Setting the Nudge Rate 

When using the Nudge commands, you can set the distance an object 
moves each time you use the Nudge command. To access the Nudge 
Rate Dialog box, pull down the Edit menu and drag the cursor on top 

of the word Nudge. A pop-up menu, displays. Now select the Nudge 

Rate... Once the dialog box appears you can then type in the nudge 
rate. Click, OK once you have typed in the correct rate. Click on the 
Cancel button if you wish to cancel and return to the previous setting. 

The Nudge Rate Dialog affects the all of the Nudge commands. 

NOTE: The Nudge Rate is always tied to the current scale of your 
design. 

Nudge Rate... 

Nudge Rate Dialog box 
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Smoothing 

This command is designed to round the angles of polygons, splines 
and unsmoothed freehand shapes. This command can also work 

conversely by changing the rounded angles back into sharper angles. 

You can access the Smoothing commands under the Edit menu, hold 

down the mouse button on top of the word Smoothing and a pop-up 

menu appears. From the pop-up menu you can access Smooth, 
Unsmooth, and Tension Dialog box. 

Smoothing smooth 

Unsmooth 
NN en i 

Tension... 

Smoothing Pop-up Menu 

1 Smooth 
Spline Smooth changes any selected polygons to smoothed 
splines. Smooth rounds the corners of polygons and 
unsmoothed free-formed shapes. 

(J Unsmooth 
The Unsmooth command changes splines, smoothed 

polygons and any smoothed free-formed shapes into 
polygons with sharp angles. 

(1) Tension... 
This command allows you to access the Tension Dialog 
box and change the tension value from which the Smooth 

command is tied. You can loosen or tighten the 

smoothness of selected objects. 
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Using the Smooth command 

The following example shows the effects of the Smooth command 

when applied to a polygon. 

(J First, create a simple open polygon, then select the 

polygon by using the Selection (Arrow) tool, so that all of 
the points within the polygon are highlighted. 

Highlighted points aa = 

Unsmoothed Polygon 

[J Now, select the Smooth command from the Smoothing 
pop-up menu. After selecting Smooth, the polygon 

automatically smooths the angled corners of the polygon. 

SEs 
Smoothed Polygon 

Unsmooth 

[1 After you have smoothed the polygon, you can select the 
smoothed polygon and choose Unsmooth. The polygon 

returns to its original angular shape. 

eo 
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Tension Dialog Box 

When you access the Tension Dialog box you are setting the amount 
of smoothness that is to be applied when you use the Smooth 

command. 

You can select the Tension Dialog box from the Smoothing pop-up 

menu, which is found under the Edit menu. 

When entering the tension value, the smaller the number the tighter 
the curves are going to appear. If you go with too small a number, the 

corner points become angular. This has a similar effect to the 
Unsmooth command. 

If you increase the tension value, the curve smoothness becomes 
looser, taking on a larger curve effect. If the value is to high, you can 

make objects with no straightness. 

Spline Tension: 

Tension: |u| (2) | 

Tension Dialog box 
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Preferences... 

This Dialog box allows you to personalize KeyCAD Complete. You 
can change the way the program defaults certain tools and commands. 
The Preferences options are useful when you want to adjust the 
KeyCAD Complete environment to fit your working habits. 

You can access the Preferences Dialog box under the Edit menu. The 
dialog permits a choice of several options. 

Multigon Sides 

The number in this box represents how many even sides 
you have when using the Multigon tool found in the Draw 
toolbox. 

Curve Smoothness 

KeyCAD Complete uses splines when creating any curves 
within the program. This setting allows you to determine 
how many points are placed on each curve segment. The 

higher the number, the smoother the curves appear. The 
lower the number, the rougher the look to the curves 

Snap To Tool Sensitivity 

This setting lets you determine how close you have to be 
to the object outline. The number represents how many 
pixels away from the object you can be. A pixel is equal 
to one dot on your screen. 

Snap To Tool Percentage 

The percentage value you type into this box determines 

the point on the line the Snap To tool snaps to. You can 

set it from 0 to 100%. Refer to the Percentage Snap To 

Tool for more information. 
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Auto Reset Tools 

You can turn this option on or off. An X in the box indicates that it 

is on. This option when turned on, resets the tool you have selected 
back to the Arrow tool (Selection tool), after you have used the 
selected tool one time. If you leave this option turned off, then the tool 
you select stays selected until you choose another tool. 

Preference Dialog 

Multigon Sides: [5 | 

Curve Smoothness: 

Snap Tool Sensitivity: [5 | 

| Snap Tool Percentage: [25 | % 

CL] Auto Reset Tools 

Preferences Dialog box 

Show Clipboard 

The Show Clipboard command opens the Clipboard. The Clipboard 

window shows the objects or text that you most recently cut or copied 
to the Clipboard. The Clipboard is used when you want to copy 

(duplicate), or move selected objects from any part of your design to 
another part, or even to a different file. You can also move objects to 
other applications that support the Clipboard Cut, Copy, and Paste 

commands. 

You access the Show Clipboard window under the Edit menu. 

When you choose Show Clipboard from the Edit menu, a window 
appears which displays the most recently copied object or text to the 
Clipboard. To close the window click on the Close button of the 

window. 
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Layout Menu 

When using the Layout menu, think of the commands as items that 

customize design requirements. The Layout menu allows you to 
access commands such as turning the Menu Bar on or off, Drawing 
Scale, Fit to Window, Axis Lines on or off, Grid specifications, and 

many other commands used for creating, viewing, and measuring 
objects. 

Several commands have keyboard equivalents for fast access, when 
combining the Command key with certain letters as shown in the 
menu below. 

Drawing Scale... 

Fitto Window %1 

“Axis Lines 

Page Breaks 

Grid 

Align to Grid 

Draw Parallel 3#Y¥ 

Parallel... 

Draw from Center 

Colors... 

Readouts 

Lines 

The Layout Menu 
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Menu Bar 

The Menu Bar is designed to let you work efficiently and quickly 
within your design. The Menu Bar can be turned on or off as 
necessary. To turn the Menu Bar on or off, first pull down the Layout 
menu and then select the Menu Bar command. You may also hold 
down the Command-M keys to turn the Menu Bar on or off. 

The commands, tools, and options found within the Menu Bar can be 

accessed within the various menus found at the top of your screen. 

The buttons and pull-down menus have been designed with minimal 

size. They follow along the edge of the title bar to minimize space 
utilization and should not interfere with design work. 

If you are using a monitor that is smaller than the width of the Menu 
Bar, the program cuts off the options furthest to the right. It cuts off 

one option at a time, until the width of the Menu Bar fits within your 
screen size. 

A brief definition of each option found within the Menu Bar is provided 
on the following pages. Further information on these options is 

available by referring to the menu that contains the required option. 
The Menus have more detailed examples on how to use these options 
in the creation of your design. Refer to theTable of Contents at the 

begining of this Manual for a List of Commands contained within each 
menu. 
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Mirror 
This button allows you to duplicate and flip a selected 
object. The mirrored object is slightly offset from the 
original. To use the Mirror command, first select the 

object then click on the Mirror button within the Menu 
Bar. You can Mirror individual objects or groups of 

objects. 

Flip Vertical 
This button allows you to Flip selected objects along the 

vertical axis, comparable to flipping the selected object 
upside down. You can Flip individual objects or groups of 

objects. 

Flip Horizontal 
This button allows you to Flip selected objects along the 
horizontal axis, comparable to flipping the selected object 
to the right. You can Flip individual objects or groups of 

objects. 

Group 

This button allows you to consolidate a set of selected 
objects as one grouped object. A grouped set of objects is 
treated as a single object, rather than several individual 
objects. 

Ungroup 

The Ungroup button automatically divides a grouped 

object into individual objects. 

Lock 
This button allows you to Lock the characteristics and 
location of any selected object or groups of objects, so 

that it cannot be changed. 

Unlock 
The Unlock button Unlocks selected objects that have 
been previously locked. 
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Join 

This button allows you to connect (Join) all selected lines 

or arcs that share overlapping (connected) end-points. 

Unjoin 
The Unjoin button disconnects all selected lines or arcs 
that have been previously Joined. 

Eyedropper 

The Eyedropper tool allows you to select the current color 
from any color within your design. Once you click the 
Eyedropper tool on a color within your design that color 
then becomes the current color. The color you have 
clicked on is then displayed in the Color button. 

Current Color 

This button displays the current color within the 
program. It allows you to select the color picker when 

you click once on the button. 

Grid Lines On or Off 
The Grid button turns the Grid Lines on or off, depending 
on the current status of the Grid Lines when you click the 
button. You can set the Grid spacing under the Grid pop- 

up menu found under the Layout menu. 

Snap To Grid 
This button allows you to quickly turn the Snap To Grid 
option on or off. 

Axis Lines On or Off 
Clicking this button toggles the Axis Lines on or off. 

NOTE: The Axis Lines represent the Origin point, a reference site for 

all Absolute coordinates and Readouts. 
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ai 

Fit to Window 
This button automatically makes the entire design fit 
within your current window size. This is useful for the 
overall layout of a design. 

Actual Size 
This button displays your design at its actual size. This is 
very useful when you have Zoomed In or Out and wish to 
return to Actual Size without using the Zoom tool or Menu 

command. To access the keyboard equivalent for Actual 
Size, press the Command - E keys. The Menu command 
is found under the Options menu. 

Tools: [+] Toolbox Pull-Down Menu 

This pull-down menu turns on or off any of the 
toolboxes found within the program. 

“Edit 

“Draw 

Snap 

Dimension 

“Position Info 

Toolbox Pull-Down Menu 
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Drawing Scale... 

The Drawing Scale Dialog box is used for setting the scale that you 

work in when creating your design. You can specify what an inch or 

centimeter measurement stands for in actual size. KeyCAD Complete 

supports all of the scales used in today's engineering fields. 

Scale factors are very useful when working on precise designs that are 
larger than the paper needed to print the design. Working with scaled 

drawings, is knowing how a design proportionally fits with respect to 

the real world coordinates. 

Access the Drawing Scale Dialog from the Layout menu. 

Drawing Scale... 

The program defaults to 1" (in.) equals 1" (in.). Once you change the 

scale it stays to the new setting until you change it again. Below are 
some example scales that are commonly used. 

1/16 in. = 1 ft. 

1/8 in. 1 ft. 

1/4 in. 1 ft. 

1/2 in. 1 ft. 

These scales are more commonly used in Architectural designs. Since 
most Architectural designs are very large in real life, a small scale 

factor is needed to permit the design to fit on a reasonable size of 
paper. 

KeyCAD Complete Drawing Scale Dialog supports both English and 
Metric scales and they are interchangeable. 
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Example 

Below is a simple room presented in two different scales to assist in 

the comprehension of how scales can benefit your design. 

CJ Create the room 1" = 1" scale factor. Notice that the size 

of the room is very small in comparison to the real world 

size of the same room. 

can 
ae 

e250" 

+ = 

C} Now create the same room but use 1/8" = 1' scale factor, 

to show the real life measurements. 

= 

10’-0" 

2 =: 
a. 
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Setting the Drawing Scale 

Set the Drawing Scale at the begining of your design, when you first 

open a new file. 

When setting the scale factor you must consider setting the Display 
options to display the proper units of measurement. 

The first step in setting the Drawing Scale is opening the Drawing Scale 
Dialog box. Pull-down the Layout menu and select Drawing Scale, A 
Dialog box appears asking you to set the scale of your choice. You 
can set the units to inches, feet, yards, millimeters, centimeters, 

decimeters, meters. 

You can select the Rescale Objects box to automatically update any 
previously drawn objects. If you do not select the Rescale Objects, 
then only the objects you draw from this point take on the new scale 
factor. This allows you to have multiple scale factors within one 
document. 

Drawing Scale: 

Screen Units: World Units: 

Feet 
Yards : 
Millimeters 
Centimeters 

Decimeters 

Meters 

[_] Rescale Objects 

Unit Options Drawing Scale Dialog box 

Once you change the scale, your readouts at the bottom of your screen 
change accordingly. 
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Fit to Window 

This command quickly lets you see an overview of the entire 

document by fitting it to the current window size. This command is 
useful for designs that cover several pages. You can change the view 
to see how the whole design looks, and ensure a proper fit on the 

selected paper size. KeyCAD Complete reduces or enlarges the size 

of a design to permit viewing of it in its entirety within your current 

window size. 

You can choose the Fit to Window command under the Layout menu 

or you can press the Command - 1 keys. 

Drawing Scale... 

Fitto Window 321 

Fit to Window Menu command 

KeyCAD Complete also gives you the option to use the Fit to Window 
button on the Menu Bar. To activate the Menu Bar, either pull-down 

the Layout Menu or press the Command - M keys. 
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Axis Lines 

The Axis Lines command turns on or off the Axis lines on your screen. 
The axis lines represent where the X & Y axis lines meet. This is 

considered the Absolute reference point of your design. When the 
program is first started the axis lines appear in the lower left-hand 

corner of the screen. The axis lines can be moved by selecting the 
Move Origin under the Options Menu. 

X-Axis runs horizontal or (left to right). 

Y-Axis runs vertical or (up and down). 

To access the Axis Lines command pull down the Layout Menu. You 
can tell in the menu if the axis lines are on or off. A check mark beside 

the name indicates that they are on. 

Drawing Scale... 

Fitto Window #1 

“Axis Lines 

KeyCAD Complete offers the option of using the Axis Lines button 

found on the Menu Bar. You can activate the Menu Bar command 

under the Layout Menu, or press the Command - M keys. Click on 
the button, to turn the lines on or off, like a toggle switch. 
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Page Breaks 

This command permits viewing of how a drawing divides into pages 

for printing purposes. It shows the page breaks of any file (document). 

A page break appears as dashed lines on your screen. Your design may 
extend over the page break lines. The dashed lines DO NOT print; 

they represent where KeyCAD Complete divides the drawing into 
printed pages. The page break lines are in accordance with the page 

size and orientation selected in the Page Setup Dialog box. 

Page break lines cannot be moved or adjusted on the page where they 

appear on your design. KeyCAD Complete automatically sets the 
page break positions based upon the settings chosen in the Paper Size 

and Page Setup Dialog boxes. 

(J To display Page Breaks choose the Page Break 

command from the Layout Menu. 

Drawing Scale... 

Fitto Window #1 

“Axis Lines 

Page Breaks 

1) To hide the page breaks, choose the Page Breaks 
command again and the lines disappear. The 

Page Breaks command works as a toggle switch. 
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Grid 

The Grid options are accessed through the Grid pop-up menu, which 

is found under the Layout menu. Drag the mouse cursor on top of the 

word Grid and a pop-up menu appears as shown below. Within this 
menu you can choose to turn the Grid lines on or off, Snap To Grid, 
and set the Grid Spacing. 

a Grid Lines 

“Snap to Grid 

Grid Spacing... 

Grid Pop-up Menu 

Grid Lines 

Grid lines are evenly spaced on the screen and can be used for 
reference points when creating your design. These lines help you 

accurately position and adjust the size of objects. The space between 

each grid line can be set to a specific distance. To change the grid 
spacing, select the Grid Spacing command; a Dialog box appears 
allowing you to set the grid spacing. 

The Grid Lines option works like a toggle switch, and the check mark 

Y beside the option means that the grid lines are on. Select the Grid 
Lines option to turn them off and the check mark disappears. 

To turn the grid on or off simply click on the grid button found on the 
Menu Bar. The Menu bar appears under the title bar of your window. 
You can turn the Menu Bar on or off from the Layout menu or by 

pressing the Command - M keys. 

SoftKey: Changing The Way America Buys Software 8-13 



Layout Menu KeyCAD Complete for MAC 

Snap To Grid 

If you want to ensure that objects drawn conform exactly to the Grid, 
turn on the Snap to Grid option. When you turn on the Snap to Grid 

option, KeyCAD Complete restricts the sizing, placement, and 

drawing of objects to the spacing of the grid. 

Objects change size in increments of the grid spacing only when the 

Snap to Grid option is activated. Objects cannot move to positions 
between the grid points. Move them so that the boundary lines of the 
object align only with the grid lines. 

Turning on the Snap to Grid 

To turn on the Snap to Grid option select it from the Grid pop-up menu 

found under the Layout menu. The option works like a toggle switch, 

and when the Snap to Grid is on, a check mark “ appears beside 
the name. 

Alternatively turn the Snap to Grid on or off by clicking on the Snap 
to Grid button found on the Menu Bar. Turn the Menu Bar on or off 
by selecting the command under the Layout menu or by pressing the 
Command - M keys. For more details concerning the Menu Bar refer 
to the Menu Bar section of this chapter. 

Menu Bar 

The Menu Bar Command 
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Grid Spacing... 

The spacing between the horizontal and vertical grid lines can be set 

by accessing the Grid Spacing Dialog box. The grid spacing can be 
set for both the Horizontal and Vertical lines. 

Access the Grid Spacing Dialog box by selecting the Grid Spacing 

option found in the Grid pop-up menu, which is found under the 

Layout menu. 

a Grid Lines 

“S$nap to Grid 

Grid Spacing... 

With the appearance of the Dialog box, type in the horizontal and 

vertical distance required. The horizontal and vertical distances do 

not have to be the same. Once you have typed in the desired settings 
click on the OK button and the Grid lines are automatically updated 
to reflect the new settings. You can cancel the Dialog by clicking on 

the Cancel button, and the program returns to the previous settings. 

Grid Spacing: 

Horizontal: 

Vertical: 

Grid Spacing Dialog box 
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Align to Grid 

The Align to Grid command automatically aligns individual or groups 
of objects to the current grid spacing. 

Using the Align to Grid 

O) First, select the object you wish to align to, by using the 
Selection tool. 

[1 Second, turn on the Align to Grid command by selecting it 
from the Layout menu. 

Now, select the End-Point Snap To tool and click on the 
vertex point within the object you wish to align to the 
grid. Clicking on the point with the Snap To tool tells the 
program which point you wish to snap to the grid. 

Once you have snapped to the desired point while holding 

down the mouse button drag the object to the closest grid 
point and release the mouse button. The object is 

automatically aligned to the grid point. 

NOTE: You must use the Snap To tools when aligning objects to the 
grid. This is so the program can understand which point of the object 
you want aligned to the grid. You can use any of the Snap To tools 
when using the Align to Grid command. 
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Dimensioning 

The Dimensioning pop-up menu allows you to access several options 

for the dimension tools. Most options work like a toggle switch, and 
have check marks “beside them to indicate that they are on. These 
options include Arrows In, Arrows Out, Center Text, Text Frame, 

Single, Double, Limiting Tolerances. 

Tolerance Values Dialog box can be accessed from the Dimensioning 
pop-up menu. This Dialog is for setting the upper and lower tolerance 

values for the Limiting Tolerance option. 

The Arrowheads pop-up menu is where you select the type of 

arrowhead for the dimension lines. 

Using these options enhances the custom look appearance of the 

document and helps in using industry standard methods of drafting. 

Dimensioning a Arrows In 
“ Arrows Out 

Arrowheads 

“ Center Text 

/ Text Frame 

Single Tolerance 
“” Double Tolerance 

Limiting Tolerance 

Tolerance Values... 

Dimensioning Pop-up Menu 
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Dimensioning Options 

Arrows In 

This option makes the Arrows appear on the inside of the witness lines. 

The example below displays how the arrows look when using the 
Arrows In option. 

Arrows Out 

This option makes the Arrows appear on the outside of the witness 

lines. The following example displays how the arrows look when 
using the Arrows Out option. 

ao"5 
Arrowheads 

The Arrowheads pop-up menu provides the Arrowhead types available 

for selection with dimensions. The following example displays the 
available options. 

Arrowheads > Fe 

OLN V0 
Center Text 

When selecting this option the text that appears with your dimension 

is automatically centered between the witness lines. This is useful if 

you alter the size of an object that is already dimensioned. The text 
remains in its original position until you select the dimension and 
choose Center Text. 
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Text Frame 

After selecting the Text Frame option, the dimension text automatically 
has a box drawn around the text. The example below displays how 

the Text Frame appears. 

2.097 

Single Tolerance 

This option displays a tolerance value with the dimension text. The 

Tolerance option can be combined with the Text Frame option as 

shown in the examples below. To set this tolerance value, choose 
Tolerance Values from the pop-up menu and set the upper tolerance 

to your specifications. 

2.397 0.050 

Single Tolerance with Text Frame 

2.997 40.050 

Single Tolerance without Text Frame 

Double Tolerance 

This option displays your dimensions with a double tolerance value, 
i.e. an upper and lower tolerance value. To set these upper and lower 

values, access the Tolerance Values Dialog box. The Double 

Tolerance option can be displayed with or without a text frame. The 
following examples show how the options appear with a dimension. 

SoftKey: Changing The Way America Buys Software 8-19 



Layout Menu KeyCAD Complete for MAC 

Examples of Double Tolerance options 

Double Tolerance with Text Frame 

+0.050 
2.997 9 000 

Double Tolerance without Text Frame 

Limiting Tolerance 

When choosing this option your dimensions appear with a double 
dimension value that has added the upper and lower tolerance values 
to the actual dimension. The examples below illustrate this option. 
The upper tolerance value is set to 0.050 and the lower tolerance value 
to 0.025. These values are automatically added to the original 
dimension. You set the values in the Tolerance Values Dialog box 
found within the Dimensioning pop-up menu. 

Original dimension 

Dimension after selecting the Limiting Tolerance option 

2.647 
2.997 

Limiting Tolerance with Text Frame 
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Tolerance Values 

The Tolerance Values Dialog is where you set the upper and lower 

tolerance values that are applied to the Single, Double and Limiting 

Tolerance options. The following example illustrates the Tolerance 
Values Dialog. 

Tolerance Values: 

Upper Tolerance: 

Lower Tolerance: 

Cancel 

Tolerance Values Dialog box 

Draw Parallel 

This command draws all objects with a parallel of the object you are 

drawing. Select the Draw Parallel command before you start drawing 
the object. The parallel options can be set within the parallel Dialog 
box, which is also found under the Layout menu. 

me 
Draw Parallel examples 
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Parallel... 

The Parallel Dialog box is where you set the parallel options for 
drawing parallel objects. You can choose from drawing the parallel 

to the Inside, Outside, or Center of the original object. You can also 
set the distance that the parallel is to be offset from the original. 

Parallel Options: 

C) Inside 

‘) Outside 

Parallel Options Dialog box 

Draw from Center 

This command sets the Draw tools to always draw from the objects 
center. When using this command the readouts display half of the 
objects width and height, due to the fact that it is drawing the object 
from the center. If you want to draw a circle with a specific radius, 
select Draw from Center and the width and height readouts display the 
radius. 
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Colors... 

The Colors command gives access to the color picker within the 

program. Thecolor picker allows you to choose any color or grayscale 
that is available to your hardware. 

You can access the Colors command under the Layout menu, or press 
the Command - F keys. You can also bring up the color picker by 
clicking on the Color button on the Menu Bar. You can turn the Menu 
Bar on or off from the Layout menu, or press the Command - M keys. 

The Color button displays the currently selected color. 

KeyCAD Complete provides an easy method to select a color that you 

may have previously chosen. Use the Eyedropper tool to conveniently 
change the current color in the color picker. 

Using the Eyedropper tool 

[Click on the Eyedropper tool, which is found on the Menu 
Bar. 

[J Now, place the tip of the Eyedropper on top of the color 

you wish to select, and then click the mouse button. 
1 Notice that the color button changes to the color you have 

clicked on. This new color stays active until you change it 
again. 
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Readouts 

The Readouts pop-up menu gives access to the options available for 

the Readouts window. From the pop-up menu you can set the 

readouts to display certain levels of precision. You can also set the 
readouts to display feet and inches. A check mark (W), indicates 
which option is active. 

Readouts 

Readouts Pop-up Menu 

The following example is the Readouts window, which appears at the 
bottom of the screen. These readouts can be turned on or off, and can 

be moved to any location on the screen. 

Ww: 0.19 100% | RAD.: 0.29 6 = 

H: O. 14 100% | DIA.: 0.5? —— 

Readouts Window 
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Lines 

The Lines pop-up menu allows you to choose from the different types 

and sizes of lines. The choice of lines consist of plain lines, 

centerlines, and different types of dashed lines. The line size applies 

to all line types. You can also access the Line Size Dialog box. 

Types... 

size... 

Lines Pop-up Menu 

» 

Line Types: 

SOLENOID, 

Line Types Dialog box 

Changing Line types 

If you have already created an object and you wish to change the line 
type of that object, proceed as follows: 

(J First, select the object then pull down the Layout menu 

and access the pop-up menu, to select the line type of 

your choice. 
[J Only the selected objects change to the new line type. 
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Line Size 

This Dialog box is used to select the line thickness that appears when 

using the Draw tools. The lines are determined by point size. The 
Dialog box displays the line width after you type in the point size. Use 

whole numbers such as 1, 2, 3, etc. You can choose from 1 to 20 on 

the line size. 

Line Size: 

Points: mm) 

Line Size Dialog 

The following examples illustrate what the different lines sizes look as 
printed. 

1 point line 

2 point line 

4 point line 

6 point line 

8 point line 
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Options Menu 

The Options menu is where you select various options available to the 
program. The commands consist of filling objects with Fill Patterns, 
Lock or Unlock objects, Join or Unjoin objects, Group or Ungroup, 

Move Origin, and Actual Size. 

Several of the Options menu commands can also be accessed from the 

Menu Bar (refer to Menu Bar section). The commands that have Menu 

Bar equivalents are Lock, Unlock, Join, Unjoin, Group, Ungroup. 

Menu Bar Buttons Menu Commands 

Lock Options 

[A] Unlock Fill Patterns b 

acaal Lock 
Unjoin Unlock 

Grou Join 
ca . Unjoin 

Ungroup 

Bring to Front 

Send to Back 

Group 

Ungroup 

Move Origin... 

Actual Size a6 E 
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Fill Patterns 

The Fill Patterns pop-up menu gives access to the various fill patterns 
for filling objects. You can apply a fill to any object such as polygons, 
circles, rectangles, squares or multigons. If an object is made up of 
lines and arcs, you must first join the different elements of the object 
together prior to filling it. 

To select a fill pattern pull down the Options menu and drag the 
mouse on top of Fill Patterns. A pop-up menu appears, then drag the 

mouse cursor on top of the fill of your choice and release the mouse 
button. 

Options 

Fill Patterns 

RGN 
F 

i 

rare Bs 

a 

3 
6 tet 

_ "~. 
2 BM , 

Fill Pattern Pop-up Menu & Tear off Menu 

Select a fill pattern; when you return to the Fill Pattern pop-up menu, 

the selected fill is identified by a white frame. This indicates that a fill 
is currently selected. 
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Applying a Fill Pattern to an object 

CJ First, select the object you wish to fill. More than one 
object can be selected by holding down the Shift key 
while clicking on additional objects. 

(J Now, select the fill of your choice from the Fill Pattern 
pop-up menu. 

Filled objects 

When an object is already filled and you decide to do further edits to 
the size or shape of the object, the fill pattern is automatically updated 
to reflect the changes. 
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Lock and Unlock 

Objects within your document can be locked to prevent them from 
being accidentally moved, edited or deleted. When you lock an 
object you cannot cut, delete, move, rotate, mirror or flip it. Neither 

can you change its' appearance, stacking order (layer) size, alignment 
to the grid, smooth, unsmooth, or reshape the object that is locked. 

However, you can select copy and duplicate a locked object. 

If you include a locked object among objects selected for grouping and 

then choose the Group command, KeyCAD Complete keeps that 

object locked even though it is grouped with other objects. 

The Lock command is found under the Options menu; or use the Lock 

and Unlock buttons found on the Menu Bar. The Menu Bar is turned 

on or off from under the Layout Menu. 

NOTE: You can protect an entire document by selecting all of the 
objects in the document and locking them. When locked, none of the 
objects can be changed. 

Locking an Object 

O First, select the object by clicking on it with the Selection 
tool. 

O Second, choose the Lock command from the Options 
menu or click on the Lock button found on the Menu Bar. 

[3] Unlocking an Object 

1 First, click on the object(s) you wish to Unlock, making 
sure the boundary points are highlighted. 

[1 Second, choose the Unlock command from the Options 
menu, or click on the Unlock button found on the Menu 
Bar. 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Options Menu 

Join and Unjoin 

When you select Join from the Options menu or the Menu Bar, the 
program automatically connects all line segments with overlapping 

end-points. Overlapping means that the end-points are connected by 
snapping them to each other, (using the Snap To tools). The Join 

command combines individual line segments, arcs, polygons, and 

free-formed splines into one polygon. 

Overlapping end-points | 

The Join command turns individual line segments and arcs into 
polygons. Perform any of the procedures or choose any of the 

commands that you want to use with open or closed polygons. You 
can resize, reshape, smooth or fill joined objects. 

You can choose Join from the Options menu or click on the Join button 

found on the Menu Bar. Select objects prior to selecting the Join 

command. 

How to Join objects 

1) First, select the objects you wish to join, by using the 
Selection tool and Shift clicking on the individual objects. 
(Be sure that the end-points are overlapping, connected). 

| Now, select the Join command from the Options menu or 

click on the Join button found on the Menu Bar. 
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Unjoin 

When you select Unjoin from the Options menu, any selected objects 
are automatically disconnected from each other. Unjoin separates the 
segments that have been combined into one joined polygon, therefore 
making them individual line segments. Unjoin divides rectangles, 
rounded rectangles, polygons or circles into individual line segments. 

You can choose the Unjoin command from the Options menu or click 
on the Unjoin button found on the Menu Bar. 

How to Unjoin objects 

OO First, select the object, by using the Selection tool from the 
Edit toolbox. 

1 Then, select the Unjoin command from the Options 
menu, or click on the Unjoin button on the Menu Bar. 
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Bring to Front 

The Bring to Front command from the Options menu, moves any 

selected object all the way to the front of the stacking order. This 
command is useful in moving an object from behind another object, 

allowing an edit to the object. After editing the object move the object 
to the back of the stacking order. If several objects are selected and 
then Bring to Front is chosen, all selected objects move together in 
front of the unselected objects. The transposed objects remain in the 
same stacking order they were prior to the command. Choose the 
Bring to Front command from the Options menu, or press the 
Command - F keys. 

Send to Back 

The Send to Back command moves any selected object to the last 
position of the stacking order. An object moved to the back can be 

partially or totally obscured from your view by other objects placed 
in front. Although obscured, the object remains selected and you can 
move it to the front if necessary. You can choose the Send to Back 
command from the Options menu, or press the Command - B keys. 

To move an object Front or Back 

(J First, select the object(s). This command also works with 

grouped objects. 
[J Then, select the command of your choice and the selected 

object move to the Front or Back depending on which 
command is selected. 
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Group and Ungroup 

Designs can be made of many different individual objects. A design 

may need to consolidate, or group, several objects into one object, to 
make work with a design easier. Once objects are grouped; it enables 

them to work as one single object. 

Ungrouped objects selected 

Same objects grouped and selected as a group 

Notice in the example above that the objects have individual boundary 
points when not grouped. After grouping the objects, they share the 
same boundary points, making them act as one object. 

Clicking on a set of grouped objects select the entire group 
simultaneously. It is possible when working with grouped objects, to 

resize, delete or duplicate them. Once a set of objects are grouped, 
you cannot change the individual objects that make up the group, 
(unless the objects are first ungrouped). 

Objects can only be grouped on the same layer. When you select 

objects for grouping, they appear at different positions in the object 
stacking order. Once you group these objects, they take on the 
stacking order of the foremost grouped object. 
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#7 Grouping Objects 

0 

0 

0 

First, select the objects you wish to group, by clicking on 

individual objects, use the Selection tool and hold down 

the Shift key. You can drag a selection rectangle around 

the objects you wish to group. 
Choose Group from the Options menu, or click on the 

Group button found on the Menu Bar, or press the 

Command - G keys. 
Once the objects are grouped, a display of boundary 
points are exhibited around the grouped objects. 

Ungrouping Objects 

0 

0 

0 

First, ungroup any grouped objects, if you want to make 
any changes to the individual objects within the group. 

Ungrouping objects breaks those objects into individual 
objects again. You cannot ungroup locked objects. You 

must first unlock the objects, using the Unlock command. 

Select the grouped objects by clicking on them with the 

Selection tool. 
Choose Ungroup from the Options menu, or click on the 

Ungroup button found on the Menu Bar. 

Once grouped objects are Ungrouped, you can make changes to each 

individual object. KeyCAD Complete automatically highlights the 

selected objects. 
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Move Origin 

The Move Origin command allows you to move the Absolute point of 
the design. The Absolute point is where all absolute coordinates are 

calculated from. The Absolute coordinates are considered the X and 
Y coordinates or the horizontal and vertical distance from the zero 

point. The Origin point is where the horizontal and vertical axis lines 

intersect. 

You can move the Origin point to any location on the current 
document. Moving the Origin point affects all layers. 

You can access the Move Origin command from the Options menu. 

Actual Size 

Use the Actual Size command to return the current document back to 

the 100% view. Actual Size means the measurement on the screen 

is the size the document is to be printed at. 

Actual Size is useful to quickly remove any zoom in or out commands 
you may have performed. The design returns to 100% viewing. 

Access the Actual Size command from the Options menu, or press the 

Command - E keys. 
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Windows Menu 

The Windows menu gives you access to various options that affect the 
characteristics of the windows setup. The options are: Scrolling 

Speed, Background Color, Title Options, Toolboxes. 

The following example shows how the menu appears within the 

program. 

indouws 

Scrolling $peed... 
Background Color... 

PNM PROM DEIN LLDPE DAD DDL LIED LLL SOOM PLO MLM OM OM PMOL PDA PDL LAAN OS) 

Title Options > 
AAA RAP SAR SARS ARPA ASAP DPR P SSDP SOB SD DIP PADD SP LIP P APPR SPISP SSDS PADI APIS APDIP LDS PSP DSP PAL DIPPED LPP IP PP 

Toolboxes e 

The Windows Menu 
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Scrolling Speed 

The Scrolling Speed Dialog box allows you to change the speed at 
which your document scrolls when clicking on the Scroll Arrows. 

The Scrolling Speed is determined by the number of pixels at which 

your document moves before it redraws the screen. 

The Dialog can be changed in two different ways; either click on the 
small arrows next to the numeric display, or highlight the numeric 
value and type in a value. The program defaults to 50 pixels. The 

higher the number the faster the document scrolls. 

BRERS REEL LOL LLL ELL LEADS BERS SERRE EPALPLELLPER LALLA LEPE EEE LE: 

scrolling Speed: 

Scrolling Speed Dialog box 

Once you have typed in the desired speed, click on the OK button and 
the new settings become effective. You can click on the Cancel 
button to return the Dialog to the previous settings. 
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Background Color 

The Background Color option allows you to change the background 
color of your document. If you have any objects that have no fill to 
them, the background color appears through the objects. The 
background color covers the entire size of your current document 
page size. 

When you choose the Background Color from the Windows menu, a 
color picker Dialog box appears. You can choose from any color 

available to your current video hardware. KeyCAD Complete 
supports up to 16.8 million colors. 

OOOOH OOOO OOOH HHA HHO IPH AOI OOOO OOOO OOOO OOOO OOOO OOOO OOOO IOS, 

Background Color: 

Hue 

Saturation 

Brightness 

Red 

Green 

Blue 

You can type in the R G B values of any color, as well as the Hue, 
Saturation, or Brightness of any color. The selected color appears in 
the color box located in the upper left-hand corner of the Dialog. 

Once you have selected the color , click on the OK button, or click 

on the Cancel button to return to the previous background color. 
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Title Options 

KeyCAD Complete offers several different options for titling your 

documents. These options consist of the Drawing Name, Drawing 

Name / Axis, Axis and Layer Name. 

Drawing Name 
Drawing Name / Axis 
Axis 
Layer Name 

Title Options Pop-out Menu 

Select the Title options by accessing the Title pop-up menu under the 
Options menu. The document title can be changed at anytime during 
the design process. 

The selected title appears in the middle of the Title Bar at the top of 
your screen. 

If you choose the Layer Name option, only the active layer name 
appears. 
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Toolboxes 

The toolbox pop-up menu turns on or off any of the toolboxes, as well 

as the Readout display at the bottom of your screen. You have access 
to the Edit toolbox, Draw toolbox, Snap To toolbox, Dimension 

toolbox, Position Info (readouts). A check mark “/ beside the name 

indicates that the toolbox is active. 

Toolbovues 

“Oram 

Snap 

Dimension 

“Position Info 

The Toolbox Pop-up Menu 

The toolboxes can also be accessed from the Menu Bar. This 

pull-down menu is designed to quickly turn on and off the tools. You 
can turn the Menu Bar on by pressing the Command - M keys or by 
pulling down the Layout menu. 

Taols: 3 

“Edit 

“ Draw 

Snap 

Dimension 

“Position info 

The Tools Pull-down Menu 
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Layers Menu 

Introduction 

The Layers menu is where you control the various layers that you 
create. KeyCAD Complete allows you to add information to a 
document in separate overlay, called layers, which act as transparent 

overlays. Layers are used to hold or display various aspects of a 
design. A single layer can contain and display different aspects of a 
design, KeyCAD Complete supports up to 256 layers. 

For example draw a floorplan on one layer, adding the windows and 
doors of the floorplan to a different layer, and the dimensions of the 
floorplan to another layer. Each layer can be separately named for 
easy access. 

Layers 

SLE! 7 ntitied 
Layer Info... 

Layers Menu and Layer Names Pop-up Menu 

Layering: 

« Untitled 

Layer Name: 

Untitled 

femoue 

Layers Information Dialog box 
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Example 

The example below explains how you can have different information 

on separate layers. Notice that the separate layers information still 
pertains to one design and not separate designs. 

Layer 1: Contains the original design created. 

Contains the dimensions of the design on Layer 1, 
while Layer 1 remains hidden. 

542" 
0.389" ia 

ar 7 

Layer 1 and 2: The example below shows both Layers 1 and 2. 

0.542" +> 
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Layer Names Pop-up Menu 

Under the Layers menu you can access the Layer Names pop-up 

menu. This menu displays the names of any layers that you have 
created. The program defaults to one untitled layer. A check mark 
/ beside the layer name indicates that the layer is active. 

“Untitled 

Layers Name Pop-up Menu 

Layers Dialog box 

Working with the layers provides the option of naming the layer, 
showing individual layers, showing all layers, hiding layers, hiding all 

layers, adding new layers, renaming layers, or removing layers. The 
Dialog lists the names of the layers to help you choose the layer you 
wish to assign any attributes to. A dot beside the layer name indicates 
that the layer is visible. 

Layering: 

e Untitled 

Layer Name: 

Untitled 

Layers Dialog box 
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Text Menu 

The Text Menu allows you to edit words, sentences, and paragraphs 
that are created using the Text tool (found in the Edit toolbox). KeyCad 
Complete gives you the ability to label charts, to display measurements 
and to give titles to objects and designs. This chapter teaches you how 

to change the font, the style, the size or the alignment of a text block 
in order to place text anywhere in a design. 

Dashed-lined boxes represent the borders of a text block. When a text 
block first appears on the screen, the default size is about 1.5 inches 

by 1.5 inches. The size of the text block can be altered by using the 
Selection tool. 

Like the appearance of objects is governed by the palette icons in the 

toolbox, text appearance is governed by the selections in the Text 

Menu. Changing the appearance is very easy to do. First, select the 
text to be changed using the Text tool, then select one of the Text Menu 
options. Only the selected or highlighted text is affected by the 
change. 

The initial font style that KeyCad Complete is set to is Geneva 12 
point. The font style is easily changed using the Text tool and the Text 
menu. 

“Align Left 
Align Right 
Align Center 

Text Menu 
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Font 

Fonts are different types of lettering styles that are installed within your 
System Folder. For adding and removing fonts, refer to your 
Macintosh User Manual. 

How to change Fonts 

Highlight the text to be changed with the Text tool by 
clicking the mouse button and dragging the highlight bar 

across to the end of the desired text . (To highlight 
individual words, double click on them.) The highlighted 
area is blackened. 

Pull down the Text Menu at the top of the screen and 

choose the font submenu. Drag the mouse across and up 
or down to the desired font. A check mark / denotes the 
chosen font. 

Unlike most programs of this nature, KeyCad Complete remembers 
the last selected font. This means that after you have changed any font, 
all subsequent text is written with or uses the same font style until you 
change it again. For example, if you change some text to Courier with 
the Text tool and then create an object, when you reuse the Text tool, 

the Courier font will still be chosen. 

The Font pop-up menu displays a list of all fonts available in the 

Macintosh Current System Folder. To add and remove fonts from your 
System refer to your Macintosh User Manual. KeyCAD Complete 
supports PostScript and TrueType fonts. 

Chicago 

Courier 

Geneva 

Helvetica 

New York 

Palatino 

Fonts Pop-up Menu 
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Size 

The size of text is regulated by the Size function under the Text menu. 
The initial or default point size of text is 12. The size can be raised 

or lowered depending on your needs. 

How to change Font Size 

1 Highlight the desired text by clicking the mouse and 
dragging it across the words to be changed. (Individual 
words can be highlighted by double clicking on them.) 
The highlighted text is blackened. 

(J Pull-down the Text menu at the top of the screen, choose 

the Size function, then select the desired size. After you 
have selected the desired size, a check mark / denotes 

the chosen point size. 

Under the Size pop-up menu only certain point sizes are shown. The 

numbers shown are the recommended sizes to receive the best quality 
text. KeyCad Complete supports other point sizes, however, the text 

quality may be inferior. Font sizes are determined for each individual 
font, when you install the actual font within your System Folder. 

Son wees cccasoncereencesereceseceasereeseseseeses 

Align Left 
Align Right 
Align Center |---------------- 

Size Pop-up Menu 

KeyCad Complete allows point sizes that are larger than 18 points. 
Use the Other option under the Size submenu. When the Other option 
is chosen, a Dialog box appears. Type ina whole number for the point 

size and press Return or click on the OK button. 
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Style 

Font styles are useful for adding a special touch to your text within any 

document you have created. KeyCAD Complete supports several 

styles such as Plain, Bold, Italic, Underline, Outline, Shadow, 

Condensed, and Extended. You can combine any one of these styles 
with any Font or Font Size. KeyCAD Complete default Style is Plain 
text. The style can be changed at any time. 

KeyCAD Complete supports keyboard equivalents for some of the 

Font Styles as shown in the pop-up menu below. 

How to change Font Style 

O Highlight the text with the Text tool by clicking the mouse 

and dragging it across the desired text. (Double clicking 
on words highlights them.) When highlighted, the 
selected text is blackened. 
Pull down the Text menu at the top of the screen, select 
the Style pop-up menu and the desired style. After 

selecting the Style, the highlighted text changes to the 
new style. You can have multiple styles within the same 
text block. 

Plain Text 36P 

Bold a6 

freavic 6 | 

Underline #U 

Online 

S|hjaldjoyu 

Condensed 

Extended 

Style Pop-up Menu 
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Align 

The last three options under the Text menu are Align Left, Align Right, 
and Align Center. These three options are used to justify the text inside 

the text block. This option makes it easier to place text on designs. 
The default mode is Align Left. The mode can be changed in order 
to create right or center aligned text, as in headlines or titles. 

How to Change Text Alignment 

© Highlight the text using the Text tool by clicking at the 
beginning of the block and dragging across to the end of 
the text. (Individual words are highlighted by double 

clicking on them.) Highlighted text is blackened. 

(J Pull down the Text menu at the top of the screen and 

choose the appropriate Align options. 

Font 

Size 

Style 

“Align Left 
Align Right 
Align Center Alignment options 

The Text Menu 

Below are some examples of the alignments and how they appear 

within a text block. 

ext Aligned Left 

Text Aligned Righ 

Text Aligned Center 

Do not forget that font sizes, styles, and align modes can be changed 
prior to typing the text. Simply make the desired choices from the 
Text menu at the top of the screen before typing the titles, paragraphs, 

or captions in your designs. 
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KeyCAD Tutorial 

© Introduction 

‘a System Requirements 

Q) Opening PICT symbols (symbols that come with the 
program) 

Exercise 1 

Exercise 2 

Exercise 3 

Exercise 4 

Exercise 5 

Exercise 6 

Decimal Equivalents Inch / Fraction 

ANN TRE EA Ge RP a Metric Equivalents 
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Introduction 

While you continue to improve your various drawing techniques with 
this tutorial, you will find that new information is introduced in a 
gradual manner. This will assure you of a precise learning process that 

can be adjusted to your specific needs without having to acquire 
unnecessary information before practising the basic design techniques. 

The following tutorial has been created to further assist you in your 
understanding of the basic features found within KeyCAD Complete, 
which leads you to the many powerful design techniques available 
within the program. It does this by providing a general design 
foundation from which you can work within. 

After completing the tutorial, you will be able to use the Draw Tools, 
Snap To Tools, Edit Tools and Dimension Tools which are available 

within the program. Finally, you will have an appreciation of how 
KeyCAD Complete allows you to develop professionally detailed 
drawings with the least amount of time and money invested. 

To help in keeping this tutorial fast and user friendly, many of the 

KeyCAD Complete features and combinations of tools were not 

included in this tutorial. For more detailed and comprehensive 
coverage of how to use all features, refer to the KeyCAD Complete 

User Manual. 
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System Requirements 

(J KeyCAD Complete requires a minimum of 2MB of RAM 
and a hard disk. System 7 users should use 4MB of RAM. 

(J KeyCAD Complete operates on a Macintosh Plus or 

greater. 

(J KeyCAD Complete works on black and white, 
monochrome and color Macintosh computer sytems. 

Recommended Hardware 

(J Math Coprocessor (KeyCAD Complete is fully functional 

without a math coprocessor, however the Math 
coprocessor increases the speed of the program.) 
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Opening PICT Symbols 

The program comes with free PICT symbols that you can use in 
creating your designs. These symbols are saved as MacDraw PICT 
files. This allows you to use these symbols with any graphics program 
that can accept PICT formats. 

To open a PICT symbol in KeyCAD Complete use the Import options 
found in the File menu. 

PICT... 

DHF... 

IGES... 

The Import Pop-up Menu 

Step 1 

Pull down the File menu and drag the cursor on top of the 
Import options, and then select the PICT format. 

Step 2 

Once the File Dialog box appears, select the desired PICT 

symbol and double click on the file name. This places the 
symbol in the middle of your current screen size. You can 
move the symbol to any location by using the Selection tool. 

Step 3 

Once you have placed the PICT symbol you can save it as a 
KeyCAD Complete symbol. If you save it as a KeyCAD 
Complete symbol, only KeyCAD Complete can import the 
newly saved symbol. To open a symbol that has been saved as 
a KeyCAD Complete symbol, you must use the Open Symbol... 
command found in the File menu. 
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Exercise 1 

Create a 2.0 in. diameter circle with its center at the end-point of a 
horizontal line. 

Example Design 

Answer 1 

Step 1 

First, select the Circle tool from the Draw toolbox, and draw a 

2.0 in. circle. To draw a circle, select the tool then place the 
cursor at the desired start point, then click and drag the mouse 

while holding down the Shift key. Watch the readouts at the 
bottom of your screen to obtain the correct size of circle. 

[OQ 
Circle Tool 

d> w:0.88 100% | RAD: 1.00 Pe 

=> H:-0.49 100% | DIA:2.00 

Readouts | 

Diameter 
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Step 2 

After you have created a 2.0 in. diameter circle, select the Line 
tool from the Draw tools. 

Line Tool 

Step 3 

Select the Center point Snap To tool. (Remember that the Snap 

To tools are designed to work in conjunction with the Draw 
tools.) 

Center Point Snap To Tool 

Step 4 

After you have selected the Line tool and Snap To tool, place 

the cursor near the boundary line of the circle and click and 
drag the mouse to the desired line length. Notice that when you 
first click the mouse, the start point of the line automatically 
snaps to the center point of the circle. 

Place cursor near boundary line 

Step 5 

Release the mouse button once you have reached the desired 
line length. (You can select a different Snap To tool for the 
end-point of the line by pressing the Tab key during the 
drawing of the line.) 
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Exercise 2 

In this exercise, create a line perpendicular to a circle. 

Example design 

Answer 2 

Step 1 

You must first create a circle, the circle can be any size. To 
draw a circle, select the Circle tool from the Draw toolbox and 

place the cursor at the desired start point., Then, click and drag 

the mouse while holding down the Shift key. The Shift key 
allows you to create perfect circles, if you release the Shift key 
the tool will draw ovals. 

Circle Tool 

Step 2 

After you have drawn a circle, select the Line tool from the 
Draw toolbox. 

Line Tool 

Step 3 

Then, select the Perpendicular Snap To tool from the Snap To 

toolbox. (Remember that the Snap To tools are designed to 
work in conjunction with the Draw tools.) 

Perpendicular Tool 
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Step 4 

Place the cursor near the boundary lines of the circle, then click 
and drag the mouse to any desired line length. Notice that the 

line you are creating automatically snaps to a perpendicular 
position in relation to the circle. The perpendicular angle is 
determined by the position of the start point of the line. In this 

example, the start point of the line is fixed at a horizontal 

position in relation to the circle. 

Place cursor near the boundary line 

Step 5 

Once you have reached the desired line length, release the 
mouse button. This method of creating a perpendicular line by 
combining Draw tools with the Perpendicular Snap To tool, 
works with any of the objects in the Draw toolbox. 
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Exercise 3 

In the following exercise, draw a circle with its' start point at the 

intersection point of two lines. This exercise is designed to demonstrate 
how you can start any object from the intersection point of any two 
objects. 

Example design 

Answer 3 

Step 1 

First, create two lines that intersect as shown in the example 

above. Use the Line tool from the Draw toolbox. 

Line Tool 

Step 2 

Now, select the Circle tool from the Draw toolbox. 

[O] 
Circle Tool 

Step 3 

Select the Intersection Snap To tool from the Snap To toolbox. 

Intersection Snap To Tool 
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Step 4 

Place the cursor near the intersection point of the two lines. 
Then, click and drag the mouse to create a circle, hold down 

the Shift key to draw perfect circles. Notice that the start point 
of the circle snaps to the intersection point of the two lines. 

Place cursor near intersection point 

Step 5 

Drag the mouse button to the desired size, and then release the 
mouse button. You can watch the Readouts to obtain a certain 
diameter. This method of creating objects with their start points 
at the intersection point of any two objects works with any 
intersection point, by combining Draw tools with the 
Intersection Snap To tool. (You can select a different Snap To 

tool for the end-point of the circle by pressing the Tab key 
during the drawing of the circle.) 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Tutorial 
LT 

Exercise 4 

The following exercise demonstrates how to use the Linear Dimension 

tool, when dimensioning a rectangle. This example uses a simple 

object such as a rectangle, but you can use the same steps when 
dimensioning between any two points. 

ae 
Example Design 

Answer 4 

Step 1 

First, create a rectangle similar to the one in the example above. 

Use the Rectangle tool when drawing your rectangle. 

[3] 
Rectangle Tool 

Step 2 

Select the Linear Dimension tool from the Dimension toolbox. 

Linear Dimension Tool 
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Step 3 

Select the End-Point Snap To tool from the Snap To toolbox. 

End-Point Snap To Tool 

Step 4 

Then, place the Dimension tool cursor near the first point of the 

rectangle. Click and hold down the mouse button while 
dragging the cursor to the second point of the rectangle. Release 
the mouse button at the second point. Since you selected the 
End-Point Snap To tool, the dimension lines automatically snap 
to the points of the rectangle. 

Click near first point Drag to second point 
a 

Step 5 

After you release the mouse button at the second point of the 
dimension, notice how the dimension lines follow the cursor 

movement. Once you reach the desired distance from the 
rectangle, click one time to anchor the dimension. After you 
click the mouse button to anchor the text, the dimension 

automatically appears between the arrowheads. (You can select 
a different Snap To tool for the start or end-point of the 
dimension you are creating by pressing the Tab key during the 
drawing of the dimension.) 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Tutorial 

Exercise 5 

This exercise demonstrates how to use the Angular dimension tool. 

The following example illustrates a closed polygon witha 90 degree 
v-shape in the middle of the polygon. 

see 

Example Design 

Answer 5 

Step 1 

Create a polygon similar to the one in the example shown 

above. Use the Closed Polygon tool found in the Draw 
toolbox. 

Polygon Tool 

Step 2 

After you have created the closed polygon, select the Angular 
Dimension tool from the Dimension toolbox. 

Angular Dimension Tool 
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Step 3 

Select the End-Point Snap To tool from the Snap To toolbox. Be 
sure to double click on the End-Point tool so that the tool is 
locked. 

End-Point Snap To Tool 

Step 4 

Place the cursor near the angular point of reference as shown 

below. Then, click and hold down the mouse button,while 

dragging the cursor to the second point of the angled line. Once 

you are near the second point of reference, release the mouse 
button. This operation indicates to the program from which line 
you want to obtain an angular dimension. 

Second point of reference 

Click near angular 

point of reference 

Step 5 

After you release the mouse button at the second point, notice 
how the program has built an angular dimension line which 
follows the mouse movements. Now, drag the cursor to the 

third reference point as shown below, and click the mouse 

once. This is telling the program the size of the angle you are 

dimensioning. Drag the mouse away from the object and click 
one time to anchor the dimension. 

Third point of reference 
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Exercise 6 

In the following exercise create a closet that would be used in a typical 
floorplan. For the purpose of this exercise create the design using a 
scale factor of 1/8" = 1'. 

26'-0" = 

10'-0" 

& a 
Example Design 

| 
Answer 6 

Step 1 

The first step in creating the closet as shown above, is to set the 
scale factor of the design. Select Drawing Scale from the 
Layout menu. Set the Screen Units to .125 inches and the 
World Units to 1.0 feet as shown below. Then, click on the OK 

button, your document has a scale factor of 1/8" equals 1' foot. 

Screen Units: World Units: 

[i25 | 

[] Rescale Objects 
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Step 2 

Select the Parallel Dialog box from the Layout menu. Select the 
Inside option button and set the width to .125, then click on the 

OK button. 

@) Inside 

©) Outside 

C) Center 

The Parallel Format Dialog box 

Step 3 

Now that the parallel options are set, select the Rectangle tool 
from the Draw toolbox. Then, select the Draw Parallel option 

from the Layout menu, a check mark (W), beside the option 

indicates that it is active. Now draw a (3-1/4") 26'-0" wide by 
(1-1/4") 10'-O" high rectangle. This represents the outer walls of 

the closet. 

“Uraw Parallel  #¥ 

Draw Parallel option 

26'-O" or (3-1/4") wide 

10'-O" or 

(1-1/4") high 
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Step 4 

Create a 3'-O" door for the closet. Select the Rectangle tool and 
draw a 3/8" (3'-0") wide x 1/8" (1'-O") high rectangle. 

ss 
3/8" (3'-O") wide x 1/8" (1'-0") high rectangle 

Step 5 

Draw a 3'-0" (3/8") vertical line extending up from the upper 

left-hand corner of the rectangle created in Step 4. The 
example below shows how the line and rectangle should look. 

3'-O" (3/8") vertical line 

Step 6 

Now select the Arc tool from the Draw toolbox and draw a 
circular arc from the upper right-hand corner of the rectangle to 

the end-point of the vertical line. 

End-point of arc ——__ 

—— Start point of arc 

Step 7 

After creating the door, select all objects that make up the door 

by dragging a selection rectangle around the entire door 
assembly, using the Selection tool. Then, select the Group 

command, group the entire door assembly. This helps in 

relocating the door to its proper position. You can group 

objects by selecting the Group command from the Options 

menu or by clicking on the Group button found on the Menu 
Bar. 

Menu Command Group Button 
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Step 8 

Place the door in the proper location as shown below. The 
door is 1' from the left interior wall. 

Place door 1' from left wall 

Step 9 

Use the Polygon tool to create the shelf in the closet. The shelf 
is 2'-4" wide. Then place a dashed-line set back 1'-O" from the 

edge of the shelf, this represents the clothes rod for hanging 
clothes on. Use the Polygon tool to create the dashed-lines. 
You can change the line type from the Layout menu. 

23 

= 
10'-0" 

Step 10 

Now select the Linear Dimension tool and dimension the closet 

as shown above. Be sure to use the End-Point Snap To tool 

when dimensioning the closet. 

End-Point Snap To Tool 
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0.03125 

0.046875 

0.0625 

0.078125 

0.09375 

0.109375 

0.1250 

0.140625 

0.15625 

0.171875 

0.1875 

0.203125 

0.21875 

0.234375 

0.2500 

KeyCAD Complete for MAC 

0.3125 

0.328125 

0.34375 

0.359375 

0.3750 

0.390625 

0.40625 

0.421875 

0.4375 

0.453125 

0.46875 

0.484375 

0.5000 

Decimal Equivalents Inch / Fraction 

0.53125 

0.546875 

0.5625 

0.578125 

0.59375 

0.609375 

0.6250 

0.640625 

0.65625 

0.671875 

0.6875 

0.703125 

0.71875 

0.734375 

0.7500 

Tutorial 

0.765625 

0.78125 

0.796875 

0.8125 

0.828125 

0.84375 

0.859375 

0.8750 

0.890625 

0.90625 

0.921875 

0.9375 

0.953125 

20.96875 

0.984375 

1.0000 
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Glossary 

Angular Dimensioning: A tool found in the Dimension toolbox, 

which allows dimensioning of angular objects or lines. 

ANSI Standard: The ANSI Standard is the most universal standard 

used in the USA. ANSI stands for American National Standards 

Institute. 

Application: A program that has been created to perform a specific 

task such as word processing, database information, spreadsheets, 
etc. KeyCAD Complete is an example of a graphics or draw 

application. 

Arrowheads: Arrows which appear at the end of the dimension lines 

indicating the points being dimensioned. 

Associative Dimensioning: This means if one area of the dimensioned 

object is adjusted, all parts of the dimension area are adjusted 
accordingly. Any change to a single object or dimension causes all 
components of that dimension to be automatically updated to reflect 

the new changes. 

Axis Lines: The lines that are positioned horizontally and vertically 
within a document window. Axis lines help in providing guidelines 
for creating objects horizontally and vertically. 

Background Color: The color that KeyCAD Complete uses to fill any 

area that is not filled with an object fill pattern or color. 

Block: A Block (Text Block) is the rectangular area enclosing any text 
that you have typed in your document. 

CAD: Computer Aided Design - this is using a computer to assist you 
in the creation of blueprints or precision graphics. 

Chamfer Tool: An Edit tool which allows corners of joined objects 
to be chamfered. Chamfering is the process of clipping off a corner 

of an object, thus giving the object an angular corner. 
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Chooser: An option under the Apple Menu where printers and other 
preferences are placed for selection. 

Clipboard: The clipboard allows text, graphics, and objects to be 
moved within the same document, or to move objects to and from 
other applications. 

Dimension Line: Shows the direction of any dimension. This line also 
shows the relationship of a dimension to the referenced object. 

Duplication Options: Assigns duplication coordinates and repetitions 
to any selected object. 

Edit Tools: Tools which appear in the Edit toolbox permitting the edit 

or alteration of points and objects. These tools include selection, point 
selection, resize, skew, rotate, chamfer, fillet, etc. 

Elliptical Arc: A tool found within the Draw toolbox which is used 

to create curved lines. 

Equilateral Triangle: A triangle with three equal sides. 

Extension Lines: These lines occur when the dimension is established 

outside of an object's boundary lines. These lines are designed to tie 
the dimension line and the numerical value of the objects being 

dimensioned. 

Fillet Tool: An Edit tool which allows corners of objects to be rounded 
off to a specific radius. 

Finder: The desktop of the Macintosh. The finder screen is where 

organization and management of files and folders take place. 

Floating Point Accuracy: The format used for precise mathematical 
computations. This format uses extended precision storage to avoid 

excessive round-off errors in all objects created. 

Ghost Lines: These are dashed-lines which run parallel to the 

selected points you are moving or editing within your document. 
These lines move as you reposition the mouse. 

SoftKey: Changing The Way America Buys Software 



KeyCAD Complete for MAC Glossary 

Grow Buttons: The small boxes found in the upper right-hand corner 

of your window title bar. These buttons are activated by clicking them 
once with the mouse cursor. These buttons are used to enlarge or 

decrease the window size. 

Horizontal Dimensioning: An option in linear dimensioning for 
finding the horizontal distance between any two points. 

Isosceles Triangle: A triangle with two equal length sides. 

Layer: A level in your document used to help in the organization of 

objects. KeyCAD Complete allows designs to be created in separate 

transparent sheets and stacked on top of one another. Layers can be 

temporarily hidden to view your document in different ways. 

Linear Dimensioning: A special tool found within the Dimension 

toolbox, which allows the linear dimensioning of any two points. 

Line Tool: A tool found within the Draw toolbox, which is used to 

construct individual horizontal or vertical lines of any length or angle. 

Math Coprocessor: Computer processing chip which aids in the 

mathematical calculations of creating objects. 

Numerical Value: The number which is displayed when two points 
have been dimensioned. 

Origin: The location which is represented as Zero for all Draw and 

Edit tools. The Origin is also referred to as the Absolute Point of the 
document. 

Precision Readouts: The numeric values displayed at the bottom of 
the document. This information window contains the Absolute, 

Incremental, Percentage, and Angular information about objects and 
their position. 

Radial Duplication: This is where objects are rotated and duplicated 

simultaneously around a specific point. 

Relative Point: The Relative Point represents a point in space against 

which angles are measured. The Relative Point automatically has a 
circle drawn around it. 
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Relocate: To move objects to a new location or coordinate. 

Resize: The Edit function, that changes an object size. 

Rotate: An Edit function which allows objects to be moved around 
a fixed point. 

Scaling: The process of assigning different scale factors to objects. 
Scaling can be performed in English or Metric measurements. 

Scrapbook: This is where users store text blocks, graphics, etc., 

which can then be pasted into other documents. 

Scroll Bars: The gray bar area at the right-hand side and bottom of 
each document window. Press the arrows at the end of the scroll bars 
to move across the drawing area within a window. 

Selection Points: The small circles and squares which appear at 

vertex points within objects. 

Skew: An Edit function which allows objects to be slanted or sheared 
in a specific direction. 

Symbols: An object or groups of objects which are saved in individual 
files, with the capability of being recalled for future use. 

Text Tool: A tool found within the Edit toolbox which allows words, 

sentences, and paragraphs to be created in blocks and placed 
anywhere within your document 

Toolbox: A palette of tools which appear within the program window. 

Vertical Dimension: An option found within the Dimension toolbox 

for finding the vertical dimensions of any two points. 

X-Axis: The horizontal plane in a document. 

Y-Axis: The vertical plane in a document. 
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NTIL NOW THE POWER of CAD was for 

U:. technical elite. Because it took an 

engineer to master the complex commands 

and concepts required to use Computer Aided 

Design. No longer. Now there is Key CAD 

Complete, the next generation that puts high 

performance CAD at anyone’s fingertips. 

Why is CAD So Useful? 

CAD turns your MAC into a precision design 

and drafting tool. You can produce drawings, 

plans and layouts to perfect scale and accuracy. 

At home you’ll use Key CAD to plan an 

addition or renovation to your house, create a 

school project or design a piece of furniture. 

Key CAD’s powerful floating point coordinate 

system automatically calculates distance and 

dimensions. 

At work you'll produce mechanical, architec- 

tural, construction, manufacturing and civil 

engineering drawings, electrical schematics, 

office layouts, business graphics, flow charts 

and diagrams. 

Whether you’re an inventor, a hobbyist, 

craftsman, electrician, architect or contractor, 

Key CAD takes you step by step from conception 

to realization. 

But that’s only the beginning. With Key CAD 

you’re only limited by your imagination. It’s so 

powerful and intuitive you can use your Mac 

for film animation or even drive a sophisticated 

computerized engraving device. 

Only With Key CAD Complete 

You Get Features Like These! 

EDITING: Modify * Cut ¢ Copy « Paste ¢ Skew 

e Scale ¢ Rescale ¢ Radial and Linear Duplicate 

¢ Move ¢ Rotate * Mirror ¢ Flip ¢ Delete « Fillet 

e Inverse Fillet ¢ Chamfer © Text Import 

e Resize ¢ Text Block ¢ Extend Trim e Fill © Join 

e Unjoin ¢ Group ¢ Ungroup ¢ Lock ¢ Unlock 

e Nudge ¢ Automatic Snap To. 

DRAWING: Line (multiple line styles or choose 

your own thickness) ¢ Square ¢ Rectangle 

e Oval ¢ Circle ¢ Arc ¢ Text ¢ Arrow @ Open or 

closed polygon e Multigon ¢ Free-Formed 

Spline Tool e Shift Key option for perfectly 

straight lines ¢ Absolute, Relative or Polar 

Coordinates ¢ Full Dimension Manipulation 

Toolbox ¢ Scale in mm, cm, m, km, in, ft, ft-in, 

yds or miles. 

DESIGN AND VIEWING: Zoom ® Pan ® Scale 

e View layers ¢ Precision display options: 

English or metric, fractions or decimals, integer or 

floating point. Build up to 256 levels or overlays 

e Exponential, log and trig functions ¢ Rubber 

Band feature to stretch images ¢ Unparalleled 

UnDo feature restores preceding action ¢ Unique 

memory handling technology allows you to 

create almost any size design ¢ Multiple size, 

styles and fonts in B&W or any color ¢ Choose 

from 16.8 million colors or work with full gray 

scale ¢ Paper sizes include mechanical, 

architectural, metric, metric oversize or 

custom. Competitive CAD packages without all 

these features cost hundreds of dollars more! 

Save Hundreds Of Hours 

With Key CAD Complete’s 

FREE Symbol Libraries 

Why redraw the wheel when professionals 

have done it already. Included inside are over 

470 symbols for: Home, Office, Mechanical, 

Electrical, Landscape, Interior Design, Electronic 

and more... All symbols are in PICT format. 

SYSTEM REQUIREMENTS: Macintosh Plus or greater, 

PowerBook 140 or greater, minimum 2MB of RAM with 

System 6, 4MB of RAM with System 7 or above. Use mouse or 

keyboard. Supports any size B&W or color monitor. Supports 

any TrueType or PostScript font. Apple Unix compatible. Works 

with all Macintosh compatible dot matrix, ink jet and laser 

printers (including full PostScript support), also supports any 

Hewlett Packard or Houston Instruments compatible plotter. 

Imports & Exports DXF, IGES, PICT, PICT2, AYZ, XY 

Coordinates HPGL and EPS. Math co-processor supported but 

not required. Hard disk required. 

For more information, or to obtain a catalog of our many products, please write or fax: 

SoftKey Software Products of Florida, Inc. ¢ 4800 North Federal Highway ¢ 3rd Floor, Building D * Boca Raton, FL 33431 

SALES (407) 367-0005 

PRODUCT OF U.S.A. 

FAX (407) 367-1611 TECHNICAL SUPPORT (407) 367-1415 

Macintosh is a registered trademark and TrueType is a Trademark of Apple Computer Company. PostScript is a registered trademark of Adobe 
Systems Incorporated. Other trademarks are the property of their respective companies. PACKAGE DESIGN: REACTOR 


