Creating and Using Fields http://web.archive.org/web/20000919160442/http://ww...

The Wayback Machine - http://web.archive.org/web/20000919160442/http://www....

Creating and Using Fields

by Jan McClintock

Updated 3/3/2000 by Leister Productions.

You can create up to 100 Notes fields per person and as many Event and
Fact fields in Reunion as you like. The most important decisions in using
Reunion involve the use of fields. Before getting into the mechanics of
creating fields, here are a few things to think about first.

Beware over-specialization

Before going wild here, remember that creating reports and charts as
well as sharing your data with others gets more complicated the more
distinctly your data is recorded. Each time you use a specialty field, you
are separating more data from the basic genealogical fields of name,
birth, marriage, death, and notes that all genealogy software has in
common.

So? Well, one possible problem will be using GEDCOM files for sharing
your data. Read about GEDCOM files in this article, and in the electronic
manual. GEDCOM Tags for fields that you use or create are not always
supported by other genealogical software. That means that the data you
have in these fields will be either ignored or trashed by other software
when it imports your GEDCOM file.

Another side effect of specialty fields is choosing which data gets
reported. The more fields you have available, the more choices you must
make and the more space the data takes up in a report or chart. You use
the Layout windows for both reports and charts to choose which fields
are used. Use the Layout -> Define Layouts menu choice from any
report or chart window to open this window.

Family History Layout
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— Generation Prefix [ 0ccupation [l
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Field order is set in Edit Person Window.
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Here is an example of an overloaded chart box. Not only is it hard to
understand, but there is so much data here that people might just ignore
the whole thing.

Harrg Bine ROSENGRANT, Grandfather 40, M
birth. 30 Sep 1881, Clinton Twp, Wyoming Co, P
death. 24 Oct 1966, Abington, ont%omer Co,PA
brp. Starkville Cemeterg “Wyorming Co, P

edu. Tunnel Hill School, farkville, P&, 1899

occ. Railroad; Carpenter ; USMC

& Minnie Myrle BERRY, Grandmother, 41,F

birth. 1882, Dover, Morris Co, NJ

death. 196

brp. Starkville Cemetery, Wyoming Co, PA

occ. Housewife

m. 17 Jul 1899, Tunkhannock, Wyoming Co, P&

What About the Data?

Say you have some data from city directories, and you're trying to decide
where to put it. Here are a few questions to ask each time you enter data.

1) What type of data is it?

Is this an event or a fact? City directories are always dated, and these
dates, although usually no more specific than a year, are important to the
use of the data (see 2 below). Therefore, this data is a series of Events.
However, before you jump to conclusions and start creating City
Directory Events, read on...

Remember that with a Fact, the dates are usually insignificant. For
instance, a man's occupation (his life's work or career) is a fact (it
may cover his entire adult life), but his employment with a certain
company is an event (he was employed for a specific time period).
Another example: a man's nationality is a Fact, but his naturalization
is an Event. Similarly, the cause of death is a fact, but the burial is
an event; and the religion is a fact, but the confirmation is an event,
etc.

2) What does this data do for your research?

City directory data establishes that a person or a family lived at a certain
address at least sometime during the year the directory was published,
and it also usually lists the occupation of each person. Under varied
circumstances, this data could be construed as an event, a source, a fact,
or material for a notes field.

3) How are you going to use this data?

You will probably use this data to help find more information about this
person or family. It's not exactly riveting story material by itself or in a
list. However, it can lead you to other data, like the nearest church where
you can look for membership info, or to the place of employment where
job records might be found.

Overall, most Reunion users will use Events, Facts, and Notes fields for
two purposes: creating reports and charts, and analyzing your
genealogical data.
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Reports and Charts

You may decide to enter some of your data into separate, specific fields in
order to use Reunion's report capabilities in the course of sharing your
data. If you open the Options -> Define -> Person Fields window,
you'll see the "Narrative Form" information in the right half of the
window. This is where you tell Reunion how to word your reports.
Reunion uses this format with the actual data to make neat-looking and
neat-reading reports, just the way you want:

Narrative Form

Arrangement: | Name Verb Place Date. ¥ |

Yerb: |was confirmed |

Place: |in |

Sample
Gregq was confirmed in Pennsylvania on 12 Nov 1997,

Obviously, some information will not lend itself well to Event or Fact
fields, because of limited space and the way they are used. By entering
that data in a Notes field, you can compose it in free-form text for easy
reading.

Analyzing Your Data

Some fields in your family file will probably be used for your own
research and analysis of that family, and won't be shared with other
people. For instance, the contents of a Census event field won't be
interesting reading for a non-genealogist, and certainly an Interest Level
flag field won't mean much to anyone except you. Instead, these fields
are used by you in the course of your research. Recording this data in
Reunion allows you to compare this data to the other information on this
person or family -- for genealogical analysis. To that end, you would use
the searching, listing, and sorting features of Reunion. For instance,
using Find -> Anything, you could conceivably look for everyone who
was listed in a city directory during 1890.

If you added the data to a Notes field instead, you could still search on
the text of the note, but you would have to create a report from the list
window to see the entire contents, since a list view will not contain the
entire text. Note fields are also free-form text, meaning you would have
room to enter the entire data found in the directory, line by line - this is a
distinct advantage for some types of data. Each note field can hold up to
64,000 characters; that's quite a few pages of text - roughly 16 (8.5x11")
pages in size 10 font.

Here is an example of using different fields with the city directory data.

1) Notes: I would store the actual data in a Notes field, maybe called
"Research" if other data is entered there, or more specifically, "City
Directory." Here, Edward SMITH is the only person mentioned in the
directory, so this Notes field is under his name.
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Edit Person
Edward Delmer SMITH Person ID: 469
& Name | [E)Events \ [ Facts \ | ) Hotes ] | = Flags \
Misc. Notes ~| [cimy DIRECTORIES : =
1908, Polk's Scranton City Directory, p.45, "Smith, Edward D lab r 1029 Columbia Av"118 E
Medical 1909, Polk's Scranton City Directory, p.69, "Smith, Edward foreman r 1029 Columbia Av"118
1911, William's Directory of Scranton, p.102, "Smith, Edward D., foreman Wilk's Dairy,
454 Thurmont"112
Check Scranton birth and death indexes through GRSNP.
Wilk’s Dairy operated from at least 1901 until at least 1923 ; Hampton Ave & Frye Rd, Green Ridge
2) Event: when you use this data to make conclusions, like "Edward and
Maggie Smith lived at 1029 Columbia Avenue in Scranton at least from
1908 to 1909," enter that in a Residence Event field, if you are using one
(here it is used in a Family Events field).
Edit Family
Edward Delmer SMITH & Margaret A. FULLMAN Family ID: 333
€ Marriage = Children \ &) Notes ' | [EEvents |
Type Date Place Memo
Residence 1908-1909 1029 Columbia Ave, Scranton, Lackawanna Co, PA

3) Finally, the Source for this data is the city directory:

Edit Source (118)

Source Fields ] [ “sFree-Form Text | | &8 Preview \

Scranton City Directories, published by R.L. Polk & Co., Times Bldg, Scranton =
1892-1923; copied from the originals at the Lackawanna Historical Society , Scranton,
P&, May 1994,

Timing is not Everything

The best time to decide which fields to use and to add is before you
spend hours, days, or weeks entering your data. However, all is not lost if
you've already done it. Careful use of the Move feature in Delete/Move
Fields [Help -> Search for Help, "Delete move fields"] can get your
data just where you want it. Remember that this feature moves ALL of
the data from one field to another. If there is already some data in the
field to which you are moving information, then the moved data will be
appended (added at the end). If you want to move only part of the data
from one field to another, you'll have to cut and paste.
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Mechanics

To modify a preformatted field or to create a new field, choose Options
-> Define -> Person/Family Fields. Each tabbed window (Events,
Facts, Notes, Flags) will offer a slightly different set of options, but the
basic uses are the same. Make sure to check the list of preformatted
fields first, to avoid unnecessary work and possible duplication of fields.
If the field you need isn't preformatted, simply click the Add button, and

type in the name of

http://web.archive.org/web/20000919160442/http://ww...

your new field.

Define Person Fields

EEvents | \ DFacts \ [ @Notes \ I "‘Flags \

— Abbrevyiation
Citizenship =
Confirmation Long: | Death |
Confirmation LDS Date Place Memo
Crernation Short: |death I |dp I Idm
—Narrative Form
Emigration
9 = Arrangement: | Name Yerb Place Date. W I
Ermployment
Endowment Yerb: Idied I
Graduation Place: | in I
Honors -/ Sample
Gregq died in Pennsylvania on 12 Nov 1997
[ < AddEvent |
‘> & Delete Event ‘ Gedcom Tag:|ppat B4 aActive
(] (]
Abbreviations

The abbreviations apply to the title of the fields. You can enter any
abbreviations you wish, for preformatted fields or for newly-created
fields. The Long abbreviation will be used in Person and Family Group

Sheets.
Spouses
1 Edvard Delmer SMITH
Birth Nov 1878 Mowis Co, HT
Death S Jun 1943 Seranton, Lackawanna Co, PA; Hahneman Hospital
Burial 7 Jun 1943 Shady Hill C emetery, Clarks Summit, Lackavwanna Co, P&
Father

The Short abbreviation will be used in charts.

Edward Delmer SMITH

birth. Nov 1878

bp. Morris Co, NJ

death. 5 Jun 1943

dp. Scranton, Lackawanna Co, PA;
burial. 7 Jun 1943

brp. Shad? Hill Cemetery

edu. Middle

occ. Stone Cutter

rel. Methodist Episcopal

Clarks Summit, Lackawanna Co, PA
march Grade gchool; Sth Grade

Hahneman Hospital

Narrative Form
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Here is where you tell Reunion how to word this field in reports. This
applies only to narrative reports&emdash; those which create sentences
and paragraphs, like the Register Report and the Ahnentafel Report.

If you change the Arrangement of words, you may have to also change
the capitalization and order of the Verb and the Place. For instance, the
Narrative Form default arrangement for the Christen Event is "Verb Date
Place." The is reported like the sample, "Christened on 12 November
1997 in Pennsylvania." If you changed the arrangement to "Name Verb
Place Date," the sample reads, "Gregg Christened in Pennsylvania on 12
November 1997." You will have to change the verb to start with a lower-
case letter for this to read correctly. You can also change or add words to
meet your specifications, for instance, "was christened" instead of
“christened."

GEDCOM Tags

You can alter or add your own GEDCOM tag to any fields, but don't have
false expectations of using mercenary tags in any real-world situations. If
you know that the field you are using will never be shared or you will
never have reason to export it using the GEDCOM standard, don't bother
with the GEDCOM tag at all. Again, the documentation at the above
GEDCOM web site will be useful when faced with a non-standard field

type.
Active Fields

Active fields are listed in Add pop-up menus when you are in an Edit
window. Check this article for more details. [Even if you are a beginner,
the article may answer some questions]

Examples and Ideas

I am posting a separate page with some examples and ideas for fields in
Reunion. I welcome additions to this list, and I'm sure each of you has
some good ones! Please send them to me and I will add them to this

page.
Field Examples and Ideas Page

Top of Page
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