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INTRODUCTION

An abundance of character sets, or fonts, is one of the pleasures of
the Macintosh computer. Until now, Macintosh owners wishing to
partake of this pleasure had to purchase canned character sets or use
a balky and undocumented font editor to make their own.

FONTastic™ has been developed to make it easy for every Macintosh
user to create a special-purpose character font, or customize an
existing font.

In addition to the normal font editing commands which you might
expect, FONTastic has the ability to style characters (italics, bold,
etc.) and scale a font up or down automatically. For example, to create
a smooth New York 48 font for printing, you could double the size
of New York 24, then use FONTastic’s editing capabilities to smooth
the ragged edges. Outlined or shadowed characters don’t always look
exactly right; with FONTastic, you can tune up any font style
perfectly. You could even perform double outlining or similar opera-
tions. Fonts may be scaled independently in either axis, so you could
exaggerate characters horizontally to make a fat font, or vertically
to make a tall font.

We have worked very hard to make FONTastic as easy to use as other
top quality Macintosh software, which helps us keep this user’s guide
short. We believe a printed user’s guide is necessary for two reasons.
There is some background information about fonts which you should
know, and there are a few non-obvious tidbits about FONTastic which
are best discussed in a user’s guide.

No special knowledge about fonts is required, but we do expect you
to basically know how to use your Macintosh. Most of the user inter-
face of FONTastic is similar to MacPaint, so you probably already
know most of what you need to know to edit fonts. Terms such as
‘double-click’, ‘dialog box’, ‘file’, etc. are described in the Macintosh
manuals, and are not further defined here.






Chapter 1
ABOUT FONTASTIC

CONTENTS OF THE DISK

Your release disk contains the FONTastic program, a file with several
fonts (named ‘“Fonts”), and the standard Apple System folder.

The Fonts file is compatible with Apple’s Font Mover utility, so fonts
may be freely moved around by either the Font Mover or FONTastic.
You must replace the Font Mover with FONTastic on your font disks.
FONTastic and the Font Mover should not coexist on the same disk,
since the Finder would become confused about which one to invoke
when a font file is opened. If FONTastic is moved to a disk where
the Font Mover had once existed, FONTastic’s icon may change to
look like the Font Mover icon. This is a well-known quirk of the
Finder, but does not affect FONTastic operation.

To make it easier for you to use FONTastic, we have not copy pro-
tected this disk. We advise you to immediately make a backup copy
of the release disk for your protection, and set aside the original disk
for disaster recovery. We don’t advise you to make copies for your
friends; that is theft. We can’t run a business without customers, and
we can’t sell for the price we do without a LOT of customers, so please
be honest with us.

HOW TO USE FONTASTIC

FONTastic is invoked either by opening it from the desktop or by
opening a font file icon. A font selection window then allows you to
choose an existing font file and font (or create a new font). After choos-
ing a font, you are shown a map of the characters in the font. You
may edit individual characters from this map, or you may make
changes to a range of characters or to the entire font by choosing com-
mands from the pull-down menus.

After editing, you may store the font back where it came from, rename
it, move it to another file, or throw your changes away.

The following chapters discuss editing in detail.




Chapter 2
ABOUT MACINTOSH FONTS

FONT TERMINOLOGY

Figure 2-1 provides an illustration of the terms we are going to define
in this chapter.

Ascent » i
Baseline #--------— SIS ED SIS
Descent .
Leading =

L +
Origin Width

Figure 2-1
Illustration of Terms

Apple documents more features than we do here; see their “Inside
Macintosh” book if you really want to explore fonts in detail.
FONTastic takes care of a lot of the low-level details automatically,
so there is no need to get into those details here.

The font characteristics we care about fall into two groups: those
which apply to the entire font, and those which apply to individual
characters.
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The important font attributes are the font name, its size, and its
‘ascent’, ‘descent’, and ‘leading’. ‘Kerning’ also can be set by
FONTastic. Important character attributes are the ‘origin’ and
‘width’.

The font name is used to select the font from a menu. It is important
to notice that capital letters are distinct from lower case letters. Thus,
the system font “Chicago” is not the same as a font named
“CHICAGO”. You may wish to use a naming convention based on
this feature if you have built such a large font that it must be split
into more than one piece.

Internally, the Macintosh uses a font ID number, which is built by
combining a font number (assigned by Apple) with the font size.
FONTastic automatically numbers new fonts starting with font ID
200. When storing a new font, it picks the next font number greater
than 200 which doesn’t already exist on the destination file. If re-
quired, you may override this automatic numbering by typing the
desired number in the “Save As...” window.

The font size is measured in points. A point here is distinct from the
mathematical concept of a point or a dot on the screen. Our ‘point’
is a printer’s term for a distance of approximately 1/72 of an inch.
The declared point size of a font is used by the text drawing routines
to select or scale a font. You are familiar with this from the text size
menu of MacPaint. The declared font size is not forced to have
anything to do with the actual character size, but is normally defin-
ed as the sum of the ascent and descent (more or less). Apple defines
the font size as the distance from one ascent line to the next ascent
line in single-spaced text.

The baseline of a font is the imaginary line that all capital characters
rest on.

The ‘ascent’ of a font is the distance from the baseline to the top of
the highest character in the font.

The ‘descent’ of a font is the distance from the baseline to the bottom
of the lowest descender in the font (such as the bottom of a ‘y’ or ).

The ‘leading’ (pronounced ‘lehding’) of a Macintosh font is the space
from the descender of one row to the ascender of the next. The
typographer’s definition of this term is different, but it really doesn’t
matter; just think of it as a way of spacing one line from the next.




FONTastic User’s Guide

FONTastic allows you to change the baseline, ascent, descent, and
leading by grabbing screen indicators with the mouse and dragging
them to where you want them. Any time you change these indicators,
you are changing the entire font.

‘Kerning’ is a printer’s term to describe overlapping characters. Long
ago, when printing was done with metal type, certain letters were
notched to fit together more closely. Letter pairs such as “To’ would
be ‘kerned’ together so that the ‘o’ would nestle under the cap of the
‘T’. Things are easier these days, since you can specify kerning by
adjusting a control indicator rather than grinding down a tiny piece
of metal type.

High quality typography requires kerning tables, which specify ker-
ning values for each character pair. This requires a special text editor
which uses the kerning table to calculate where to display the cur-
rent character based on the previous character. Things are much
simpler on the Macintosh, since characters kern a fixed amount
regardless of the character to their left. Figure 2-2 shows a kerned
character. The ‘y’ kerns left because part of it lies to the left of the
origin marker. The tail of the ‘y’ thus extends into the character to
its left, allowing tighter character spacing. Kerning is set simply by
adjusting the origin marker so that one or more columns of character
dots lie to the left of the origin marker. The part of the character to
the left of the origin marker then kerns into the previous character.

Kerning
+¥
Ascent +
Bageline #»
Descent » F/
+ +
Origin Width
Figure 2-2

Character Kerning
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The individual character attributes we care about are ‘origin’ and
‘width’. Both can be adjusted by controls on the screen during
character editing, as shown at the bottom of Figures 2-1 and 2-2.

The leftmost control sets the character origin, and the rightmost con-
trol sets the character width. If the leftmost character dot is to the
right of the origin control, as in Figure 2-1, the character is drawn
with blank space ahead of it (this space is called ‘offset’). If the left-
most character dot is to the left of the origin control, as in Figure
2-2, the character kerns left, and overlaps the previous character.

‘Width’ is the distance by which to advance the drawing pen to the
next character after drawing the current character. If this is greater
than the actual width of the character dots, space is left after that
character and before the next character. If the width setting is less
than the actual width of the character (an unusual case), the next
character will overlap this one. Normally, you would adjust the width
control to be at least one column to the right of the last column of
the character, so there is a little space between characters. FONTastic
allows zero width (overstrike) characters to be defined; simply move
the width control on top of the origin control. The next character is
then drawn at the same spot as the current one.

When drawing characters, the drawing pen starts at the origin point,
on the baseline, and the dots defining the character are copied to the
screen. The actual dots making up the character may be drawn to
the left or the right of the origin point, depending on whether the
character had kerning or offset. After drawing the character, the pen
is advanced just to the right of the width marker to prepare for draw-
ing the next character.

Setting the origin and width is described in Chapter 4. The font is
stored in a compressed format, so no actual space is taken up by blank
columns between the markers and actual dots of the character.

A font has up to 255 characters. Not all characters must be defined
in every font; there is a special character called the ‘missing character’
which is drawn in place of any undefined characters. The missing
character is a square box in the standard Macintosh fonts, or a ver-
tical bar in new fonts created by FONTastic. You can edit the missing
character of a font by selecting the Edit Missing option from the
Special menu.
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Fonts are limited to a maximum size of 32K bytes. This is a generous
size for normal fonts, but the limitation may require large fonts to
be split into more than one piece. For example, you may have to put
capital letters and numbers in one font and lower case letters and
special symbols in another. This is only required for very large fonts
with a lot of characters defined. Editing such large fonts may require
a 512K memory Macintosh if you are to take full advantage of
FONTastic’s cut & paste, styling, or scaling features. If there is not
enough memory to handle it, such operations may fail with a warn-
ing message (leaving the font unchanged).

FONT FILES

Font files are basically files which contain only fonts. Special at-
tributes are set by the creating program which identify the file as
a font file, so either FONTastic or Apple’s Font Mover program is
invoked when the file icon is opened.

You would normally keep your fonts on a font file and copy them to
the system file for use. It is also possible to copy them to application
program files, such as MacWrite. Such fonts are available only to that
application, and override any similarly named fonts on the system file.

FONTastic can create new font files from scratch, edit fonts in ex-
isting font files, or even edit fonts on non-font files, such as the
MacWrite program file. We recommend that you do all your font
editing from font files. It is easier to keep up with your fonts that
way, and they are transportable to people who haven’t yet bought
FONTastic.
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GETTING STARTED

FONT SELECTION WINDOW

The font selection window shown in Figure 3-1 is displayed when
FONTastic first starts up, or after a font is closed. This versatile win-
dow allows you to select a font for editing, change the active font files,
copy fonts between files, create a new font, or remove a font.

The two inner windows allow you to open two files at the same time.
Each window’s file may be changed independently. Each window is
titled with the name of the file currently active in that window, and
the window shows all fonts in that file. If there are too many fonts
to fit in the space, scroll bars are enabled so you may scroll thru the
list of font names.

Fonts are selected by clicking on their name with the mouse. A type
sample of the selected font is displayed in the lower right corner.
Information about the font is displayed in the lower left corner. But-
tons in the center allow you to edit, copy, or remove the selected font.
You can also select the font and begin editing by double-clicking its
name.

Certain fonts are required in the System file; these are marked with
an asterisk and may not be deleted.

The system font (Chicago-12) of the startup disk cannot be edited. If

you wish to change it, change a copy on another disk (not the startup
disk).
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# File Edit Diew Special

FONTastic
System Altsys:Fonts

*Chicago-12 [ «Copy« ] [Broadway E-18

*6Geneva-9 Cairo-36

*Geneva-12 Math-12

*Monaco-9 Math-24

NY Nights-12
hts-24

NYIltalic-18

Russian-12

Scan-48

Name N¥ltalic

Point size: 18 5&11]]?/6’
Disk space: 5902 bytes

* required for system use

Figure 3-1
Font Selection Window

SELECTING A FILE

Font files are selected for editing either by opening the font file icon
from the Macintosh desktop, or by opening FONTastic and selecting
the file from the font selection window.

The first way is the easiest; just open the font file, and FONTastic
starts up with that file active. If only one file is selected, its fonts
are shown in the right window and the System file’s fonts are shown
in the left window. If two files are selected (click on the first, press
the shift key while you click on the second, choose Open from the
File menu), one is shown on the left and the other is shown on the
right.

If you open FONTastic directly, with no files selected, the left win-
dow contains the System file and the right window contains the
Fonts file, if there is such a file on your disk.

You can change the active file in either window the same way; click
on the File button under the window. This brings up the standard
file selection window, which works very much like the font selection
window. You may scroll thru the list of files on the current disk,

10
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switch between the internal and external drives, or eject the disk so
you may insert another one. Select the file you want from the list,
then click the Ok button to return to the font selection window. The
selected file is then opened, and any fonts it contains are listed in
the font selection window.

The file named System on your startup disk contains the system
fonts. You would normally move fonts to the System file in order
to use them, but this is not required. For example, moving fonts to
the MacWrite program file allows those fonts to be used by that
customized version of MacWrite without cluttering the system file.

COPYING FONTS

Fonts may be copied from file to file very easily. From the font selec-
tion window, open one file window for the source file and the other
for the destination file. Select the font name from the source window
and click the Copy button. The font is copied to the destination file
in the other window and given a unique font ID which doesn’t con-
flict with any font already there. If a font with the same name and
point size already exists in the destination file, you are asked if you
want to replace it. If you answer Ok, the duplicate is replaced by the
source font, otherwise the Copy is not performed.

The copy is always given the same name and point size as the original.
The font ID is left unchanged unless there is a numbering conflict
in the destination file, in which case the font is renumbered. If you
want to change the name, point size, or font ID, you should open the
font for edit, then choose the Save as... command from FONTastic’s
File menu to save it with a different name, size, or ID.

REMOVING A FONT

To remove a font from a font file, select it, then click the Remove
button. You are asked to confirm the deletion; click Ok and the font
is immediately removed from that file. Be sure you have saved a copy
of the font somewhere before doing this!

CREATING A NEW FONT

Create a new font by clicking the New button in the font selection
window. You are asked to enter a font size, then a new, unnamed

11




FONTastic User’s Guide

font of that size is created and opened for editing. During editing,
you may change the size if you wish. When you are ready to save
the font, choose the Save as... option from the File menu. Type the
new font name and size into the Save as... window, then click Ok.
The font is saved to the current font file (the file in the rightmost
window, if there are two files selected). If you wish to put the font
into another file, click the File button in the Save As... window. This
presents a file selection window, which allows you to scroll thru a
list of all files on the current disk, eject the current disk, switch
between disks, or select a file. After selecting a file, you are returned
to the Save As... window, which you can complete by clicking the
Ok button.

CREATING A NEW FONT FILE

Creation of a new font file begins like creation of a new font. Click
the New button in the font selection window, and edit the font; or
select an existing font for editing. Choose the Save as... command
from the File menu, and click the New File button in the Save as...
window. Another window is displayed, into which you may type a
new file name. After creating the new font file, FONTastic returns
to the Save as... window, where you may type the font name and click
Ok to save it onto the new font file.

SETTING FONT IDS

FONTastic generates font ID numbers in such a way that you nor-
mally don’t have to worry about this, but sometimes it is necessary
to control the font ID. The generated font ID can be changed in the
“Save As...” window. Although legal values for font IDs range from
0to 511, you should not use numbers greater than 255, since Apple’s
old Font Mover gets confused with larger numbers.

QUITTING FONTASTIC

There are two ways to quit FONTastic. Either choose the Quit op-
tion from the File menu, or click the Quit button in the font selection
window. FONTastic cleans up, then returns you to the Macintosh
desktop, ready to use your new fonts.

12




Chapter 4
EDITING A CHARACTER

CHARACTER SELECTION

A window like that shown in Figure 4-1 is displayed after a font is
opened.

Sample
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Figure 4-1
System View of Font Characters

The window in Figure 4-1 shows all of the character positions as they
are defined in the system font. Undefined characters are displayed
as boxes. Pulling down the View menu shows that this is the System
view.

You may change the display to an actual view of the characters in
the edit font by choosing Actual from the View menu. This display
is shown in Figure 4-2. Note that undefined characters are displayed
as gray boxes in the actual view so they show up more clearly.
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® File Edit Diew Special
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Figure 4-2

Sample
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Actual View of Font Characters

In either view, the selected character or range of characters is shown
by inverted colors in the selected character boxes. Selections remain
valid when the view is changed, so you can mark a character in one
view and flip to the other view to verify that it is in the right place

relative to the other characters.

CHARACTER EDITING

To edit a character, select it from the font view window, then choose
Open from the File menu (or just double-click the character). Alter-
natively, typing a character on the keyboard closes any open character

and activates the typed character.
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® File Edit Diew Special
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Figure 4-3

Character Editing Window

Editing a character works very much like drawing with MacPaint.
The character edit window is divided into several sections. The large
central area displays an enlarged picture of the character which is
eight times actual size. An actual size image of the character is
displayed in the upper left corner. Down the left side is a selection
of drawing tools. A narrow window just to the left of the large cen-
tral area displays controls for adjusting ascent, descent, baseline, and
leading. A short window along the bottom displays controls for
adjusting the character origin and width.

The character edit window is opened with the pencil tool active. Press-
ing the mouse button while the pencil is active changes the color of
the character dot under the pencil from black to white, or white to
black. The pencil continues to draw dots in that color until you release
the mouse button. The pencil can both draw and erase, so most editing
can be done by using just the pencil.

Several other tools are shown in the tool window. Use the eraser to
erase large areas. The hand allows you to scroll characters too large
to fit into the character edit window. The four-arrow tool scrolls the
character’s dots within its character box.

15
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The line and box tools allow you to draw straight lines or rectangular
boxes. Move the cursor to the starting position and press the mouse
button to start drawing. With the mouse button held down, move the
cursor to the ending position and release the mouse button to end
the line or box.

The dashed box allows rectangular areas to be selected for cutting
or pasting. See the section on cut and paste for more details.

No tool can draw above the ascent line or below the descent line, but
tools can automatically extend the character to the left or right if
drawing is done in that area. The character is packed back down to
a minimum width when it is closed.

A shortcut allows any tool to function as a scrolling hand; while the
option key is pressed, the current tool changes to a hand. You can
scroll the window to where you want it, then release the option key
and continue editing without having to change tools.

Press the shift key and the mouse button together to constrain a tool
to horizontal or vertical motion only.

Change whether a line grid is displayed in the character edit win-
dow with the Grid On or Grid Off toggles in the View menu.

CHANGING ORIGIN AND WIDTH

To adjust the origin or width markers, position the cursor on the
desired control. Press the mouse button, hold it down while drag-
ging the control to its new location, then release the mouse button.
Dashed lines are shown while the control is being dragged, so you
can line up the control with the dots in the character.

Moving both controls on top of each other causes the character to have
zero width. By positioning the controls to the left or right of the
character dots, you can cause this character to overlap the character
to its right or left. If both controls overlap, the origin control must
be moved to the left before the width control can be moved in either
direction.

16
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CHANGING ASCENT, ETC.

Change the ascent, descent, baseline, or leading by dragging the
appropriate control in the vertical control window. The ascent and
descent controls are indicated by bars. The baseline and leading are
both arrows. If leading and descent controls coincide (leading is zero),
adjusting the appropriate control is delicate. You must have the cur-
sor positioned on the arrowhead for leading, or on the leftmost part
of the bar for descent.

Any change to the controls in the vertical control window affects the
entire font, so take care. If you reduce the ascent or descent too much,
you could lose the top or bottom rows of every character, and you
would have to Revert to a previously saved version of the font.
FONTastic warns you if this is about to happen, and you can respond
Ok, to do the operation anyway, or Cancel, to stop it before it loses
anything. If you reply Ok, Undo cannot be used to recover the lost
rows.

UNDO AND REVERT

The Undo command (in the Edit menu) allows you to undo the effect
of the last operation you performed with the current tool. Revert (in
the File menu) takes you back to the character as it was when you
last opened it for editing, or last did a character Save.

CUT AND PASTE

Select the Cut, Copy, or Paste option from the Edit menu when in
the character edit window to perform bit-level cut and paste. Character
cut and paste in the 16x16 font edit window is described in the next
chapter. Bit-level operations allow characters to be cut from MacPaint
and pasted into a font, or vice-versa. You can also cut and paste rec-
tangular areas from character to character.

The dashed box tool is used to select a rectangular area in the cur-
rent character. This works like MacPaint’s selection rectangle, except

17
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the selected bits cannot be dragged or scaled. After selecting an area,
you may Cut, Copy, or Clear it. The cut area may be pasted into
another character, or into other files (such as MacPaint documents).

By default, Paste aligns the top left corner of the pasted data with
the top left corner of the current character, and scales to the height
of the font. If a single character dot is selected before pasting, the
top left corner of the pasted information is aligned with that dot and
no scaling is performed. If a rectangular area is selected, the pasted
data is scaled to fit into the selected area. If the pasted data isn’t where
you want it, Undo the paste, select the correct dot, and paste again.
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Chapter 5
EDITING THE FONT

SELECTING

Selecting a character or range of characters is necessary before cut-
ting, copying, styling, or clearing characters in the font window. A
character must also be selected before opening it for editing, but
usually character editing is done by double-clicking the character,
which selects and opens in one operation.

A single character is selected from the font view by positioning the
cursor on it and clicking the mouse button. A range of characters may
be selected by positioning the cursor on the starting character, then
pressing the mouse button and dragging to the ending character
before letting up on the mouse button. The current selection may be
extended by pressing the shift key while moving the cursor to the
new ending character. All characters in the font may be selected by
choosing the Select All command from the Edit menu.

STYLING

FONTastic styling commands allow any standard Macintosh text styl-
ing to be applied to selected characters. This makes it possible to
create perfect italic and other custom faces by editing the styled
characters.

After selecting the character or range to be styled, choose the Style...
option from the Special menu. A selection box is displayed, and you
may check the styling features you wish to have applied. When you
click the Ok button, the styling is performed.

Three styling variations are displayed in this box that don’t show
up in most other text styling menus. Expand adds a little to the width
of each character, so characters are spaced slightly further apart.
Condense narrows each character. Invert flips black to white, and
white to black.
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Each time you perform character styling, the selection box starts out
with no styling variations selected. This allows you to make styling
variations to a character one variation at a time, or even make a
change multiple times (super-bold or super-italic for example). Once
a character has been styled, you cannot unstyle it, except by Undoing
or Reverting. FONTastic styling is thus unlike styling in other
Macintosh programs, which leave the original character definition
unchanged.

The ascent or descent of a font may be too small to perform the
requested styling operation without losing the top or bottom of the
styled character. If this occurs, an alert box is displayed which tells
you what is going to happen, and offers a choice between automatical-
ly fixing the ascent or descent so nothing is lost, proceeding with the
operation anyway, or cancelling the operation.

SCALING

The entire font may be scaled automatically by choosing the Scale
Font... command from the Style menu. A window is displayed which
tells the current size of the font and asks for a new size. The horizon-
tal and vertical sizes are entered separately, so you may scale more
in one direction than in the other. The new size may be larger or
smaller than the current size; the scaling is based on the ratio of the
two numbers. Both numbers must be greater than 0, and less than
128.

Scaling just a few letters of a font can best be done by using the scaling
feature of the bit-level cut and paste operation (while in the character
edit window). First, cut the character to be scaled. Next, draw the
desired size of selection box in the destination character. Finally, paste
the previously cut character into that box.

UNDO AND REVERT

Undo and revert allow you to gracefully recover from mistakes or
ideas which didn’t work out. When the font window is active, Undo
reverses the effect of the last change made to the font. This includes
all the features described in this chapter. Undo cannot be undone.
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Revert allows you to throw away all changes made to the font since
you started editing. It works the same as a close without save followed
by an open of the same font.

CUT AND PASTE

A character or range of characters may be cut out of a font and pasted
back into that font or another font. To do this, first select the
characters to be copied, then choose Copy or Cut from the Edit menu.
Copy puts a copy in the paste buffer, but leaves the selected
characters as they are. Cut makes a copy and clears the selected
characters. Clear does not make a copy, but clears the characters by
making them undefined in the font.

To paste the characters in the font, select the starting character posi-
tion to be pasted into, and choose the Paste option from the Edit
menu. The contents of the paste buffer are pasted into the font start-
ing at the selected character. If a rectangular range of characters was
copied, a rectangular range with the same dimensions is pasted back.
If there is no space available in which to paste the characters, they
are skipped. For example, if you copy a full column of characters but
paste it into the font starting halfway down, only the top half of the
column is pasted; the bottom half is ignored because there is no place
to put it.

During a paste, the pasted characters are scaled so their new height
matches the height of the destination font. The width is scaled by
the same factor as the height.

CHANGING SAMPLE TEXT

The standard Macintosh text editing commands are active in the
sample window, so you can type any text you wish into this window.
The sample window itself may be made larger or smaller by adjusting
the grow box in its lower right corner.
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HELPFUL TIPS

1) On a 128KB Mac, large fonts may cause some problems. The most
often seen problems are an inability to see a sample of the font you
have selected from the Mover window (it gets displayed in a magnified
Geneva font instead), or inability to edit a desired font. These
problems are caused by memory space conflicts, and normally can
be corrected by quitting FONTastic and restarting. The problems
usually only show up after several fonts have been edited.

2) Before cutting letters from MacPaint, draw guidelines for ascent
and descent. Cut each letter with the lasso, and include a small piece
of the ascent and descent guidelines with the letter shape. Since the
paste scales the full height of the cut letter (including guidelines) into
the full height of the destination font, this guarantees proper scal-
ing for every letter in the font. The width is scaled automatically by
the same proportions as the height. Once you understand it, you can
use the scaling feature to advantage to get other special scaling effects
during paste.

3) Don’t use special characters in font names. In particular, paren-
theses or slashes cause problems in any Macintosh software which
uses font menus.

4) Remember that the printer tries to use a font twice the size of
the displayed font for increased printing resolution. If you change a
font named ‘Myfont-12’, and have a font named ‘Myfont-24’ on the
disk, your changes will not show up in printed output unless you also
change ‘Myfont-24’. If you don’t have a ‘Myfont-24’, the printer
doubles ‘Myfont-12’, so the changes show up (but will be printed with
less resolution than the printer is capable of). For the best resolution
in printing, always make a font twice the size of any you use, and
smooth its edges as much as possible.
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5) FONTastic works with the ‘Switcher’ program. Switcher allows
you to run several programs at once on a 512KB Mac. Running
FONTastic and MacPaint together makes character cut and paste
from Macpaint much easier. Be sure you select the always convert
clipboard option of Switcher. The minimum amount of memory
FONTastic can run with is 128KB, but 192KB or 256KB is recom-
mended. Be VERY cautious if running more than one copy of
FONTastic simultaneously. Do not attempt to make edits or copy fonts
to a file opened in more than one Switcher partition. There is no syn-
chronization between the multiple copies of FONTastic, so the second
time you write or copy to the file, it will be totally destroyed. As long
as you only do saves or copies from one Switcher partition, you should
have no problems.

6) Figure 6-1 shows how the keyboard maps to the font. The left half
of the table shows the obvious characters, but the right half requires
multiple key sequences. Codes starting with O- mean press Option
and the letter following the dash together, let up both, then press
the other letter in the box. Codes starting with S-O mean press Shift
and Option and the other letter in the box simultaneously. Codes
starting with Opt mean press Option and the other key
simultaneously.
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Keyboard Mapping
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