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Welcome to FONTastic Plus

Welcome to FONTastic Plus! With FONTastic Plus you can
easily edit any Macintosh font. Create your own fonts with
normal characters, logos, or custom art. Be as creative as you

like.

FONTastic Plus 20 can be run on any Macintosh Plus, SE,
SE/30, 11, IIx or Ilcx with either one or two 800K disk drives
or a hard disk drive.

We assume that you are familiar with the basics of using your
Macintosh when you come to FONTastic Plus. You should al-
ready know how to:

activate a window open

close a window scroll

copy. cut & paste select an item
drag

It you cannot remember how to do some of the basics men-

tioned above, you may quickly review them in your Macintosh

owner's manual. Also, knowing how to use MultiFinder and

l_]":*‘[la?tt:["ain1: will add efficiency and increase your creative possi-
ilities.

This manual includes a quick tutorial, an extended tutorial,
and a reference section. It also includes a chapter about the
basics of Macintosh tonts. If you want to know a little more
about how FONTastic Plus works before you start, take the
"Quick Tour of FONTastic Plus.” Otherwise, just jump right

in—use the index and reference sections to answer any ques-
tions that might arise.

FONTastic Plus is both fun and useful—we hope you enjoy it.



Before you begin, please make a backup copy of your
FONTastic Plus disk. (See your Macintosh owner's manual if
yvou need help copying.) Use only the backup copy to work
with and put the original in a safe place.

If you have a single 800K disk drive, format an 800K disk and
place a copy of your system folder onto that disk. Then copy

the FONTastic Plus program and the Fonts file supplied on
the FONTastic Plus disk to the new disk.

If you have two floppy disk drives, place your system disk in
the internal drive and the backup copy of the FONTastic Plus
disk in the external drive.

[f you have a hard drive, create a folder on your hard disk and
FGW everything on the FONTastic Plus master disk into that
older.

Remember that FONTastic Plus is a copyrighted program. Dis-
tributing copies of it, in any form, is a crime. However, since
we realize the importance of backing up important programs,
FONTastic Plus is not copy-protected.



Chapter 1

A Quick Tour of FONTastic Plus
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A Quick Tour

Chapter 1
A Quick Tour of FONTastic Plus

Overview

Join us now for a quick tour of FONTastic Plus. In the next
few pages youll discover some of the features that make
FONTastic Plus the best program of its kind. By the end of
this tour, you'll have created a useful special character and will
know how to:

Enter FONTastic Plus

Open a file

Open a font

Add a character to a font
Save a font

Install a font on another disk
Close FONTastic Plus

Use the new font

Delete a font

Things to Know

- You should read the information in the introduction.

« If you have only floppy disks, watch for these special symbols:
/1DD/ and /2DD/. Hard disk owners can ignore anything
associated with these symbols.



/1DD/ marks special instructions for owners of only one flop-
py disk drive.

/2DD/marks special instructions for owners of two floppy disk
drives.

Things You'll Need
+ A backup copy of the FONTastic Plus disk.

Remember: Be sure to use your backup copy of FONTastic
Plus. Put the original disk in a safe place with the write pro-
tect window open.

+ An application. In the tutorial we will refer to MacWrite, but
any program that allows you to choose and use different
typefaces will work the same. Just substitute the program
that you want to use whenever we tell you to use MacWrite.

Entering FONTastic Plus

Fontastic™ Plus 2.0

» Double-click on the FONTastic Plus icon shown above to
start the program.

First, you'll see FONTastic Plus's introductory screen. Click
on it to make it go away. Next, you'll see the Macintosh Stan-
dard File Selection window. In that window will be the names
of all files containing FONTs, FONDs, or NFNTs and any
files Ecl:u which they may be added, including program applica-
tion files:
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(& Aitsysa]

< Fontastic™ Plus 2.0

00 Fonts

0O Samples of our Fonts
< TeachTewut

Altsys4
[ Eject )
[ Drive )

Opening a File

+ Select and open the Fonts file (on the FONTastic Plus disk
or in your FONTastic Plus folder) by double-clicking on the
file's name.

You'll see a window that looks like the one below. This win-

dow is called the file window and its righthand part shows
the selection list:

Type:
Name:

1D:

Point size:
Size:

Disk free:

10752 bytes

Broadway E
Broadway E- 18
Cairo
Cairo-36

KeyMap
KeyMap-12

Math
Math-12

Math-24
NY Mights
NY¥ Nights-12
NY Nights-24
NYltalic
NYltalic-18
Russian




The selection list contains two types of items. The items in
bold text are FOND:s (a resource containing auxiliary tables
associated with a group of FONTs or NFNTs). The items in
plain text with a number appended are the actual FONTs or

NFNTs (as the case may be). In this tutorial we will be deal-
ing only with FONTSs.

Opening a Font

- Select Venice-24 from the selection list by clicking on its
name:

s —————— JLLIL]

Type: FONT Hath-24
Name: Uenice il
- NY Nights-12
10: 202 NY Nights-24
Point size: 24 NYltalic
Size: 8126 bytes NYltalic-18
Disk free: 10752 bytes Russian
Russian-12

Scan

ABCDEFGHLIXLM | “scon-as
NOPQRSTUVWXYZ | |1 .
abcdefghijkimnop | 700

After you've selected Venice-24, you'll see a sample of Venice-
24 in the file window's lower left corner. Look in the top left
corner for information about Venice's point size, its font 1D,
the amount of memory the font uses and the total amount of
unused space on your disk.

+ Open the font either by double-clicking on its name or by
choosing the Open font command in the File menu.

The font window is now open. At the top of the window
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you'll see a title that reads: “Fonts: Venice-24" and the charac-
ters displayed in the grid will be the actual Venice-24 charac-
ters:

5[ Fonts: Venice-24

Now let’s take a look at a text sample of Venice-24:

- Open a sample window via the New sample item in
the File menu.

An editable sample window will open, displaying text in Ven-
ice-24. You can change this text to display any characters you
wish by selecting the sample window and editing the text in it
just as you would in any Macintosh text application:

S J==—on= Sample of Fonts: Uenice-24 EEE— |
ABCDEFGHLJKLMNOPQRSTUVWXUZ
abcde fghijk (mnopgrstumvxyz
0123456789 The quick brown fox




. Reactivate the font window by either selecting Venice-24

from the window activation section of the Windows
menu (as below) or by clicking on any exposed portion of
the font window.

Full screen

Adding a Character to a Font

In this part of the tutorial, you'll create the degrees Fahrenheit
( F) character for your Venice font. Having this character will
save you an extra keystroke every time you need to print a
Fahrenheit temperature. Those of you who live in the enlight-
ened parts of the world where Celsius degrees are used can
substitute the letter "C" for every occurrence of the letter "F

below.

What we'll do first is to copy a capital "F" to a new location—
the shift-option-F position (or shift-option-D for Celsius De-
grees: the C won't work). This procedure requires four steps.

l. Click on the letter "F" in the font window or just
type—shift F .

2. Copy the letter. Select Copy from the Edit menu to save a
copy of 'F" to the clipboard.

10
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Windows View Effects
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Undp /7
e =y |onts: Venice-24 Sl———————"|
I P ——— T PP - E F G :
Cut WM |
Paste %0 | C G L
Clear |
SPOP PSPPSR 1 1 T —— EETR K M o |
Edit missing %M ||
Edit next #N K N 0
Edil previous ¥B

3. Find the shift-option—F position.

- Press the shift-option-F keys together.

+ Note the new highlighted location. This is the location for
the shift-option-F .

4. The "F" that you just copied is still in the clipboard. Select
Paste from the Edit menu. This pastes the "F" into the new
position.

Now you are ready to add the degree symbol to the ‘F” in the
shift-option-F position.

* Open the character window by either double-clicking on the
shift-option-F position in the character grid of the font win-

dow or selecting the Open character command from the
File menu.

11
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[fC]EEEEEE |dieresis from UeniceMod |

Aciual sare (mage

Plame mdicalnr s—

Hand for scroling —
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L chrimivireg boel ——

Box draing toal ———

Crcle drawing fool —

SLjen fl&-ﬁ'ﬂ“ﬁ

Eraser —
Sebaction bo |
Widih ool ———— | :
Bise : sad
ofifsat =7 width 15 FE']
Chrigin Widih

You'll see the character window (as shown above) on top ot
the font window. The letter “F" will be enlarged so that each
pixel (small square) in it is large enough to click on easily, just
like the FatBits mode in MacPaint. You might notice that most
of the tools in the character window are similar to the Mac-
Paint tools.

. Using the pencil, draw the degree symbol to the left of the
"F". Click the mouse button to either add or remove a pixel
with the pencil. Notice that the true size of the character
and the changes you make are shown in the box at the
upper left comer of the character window.
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Testing the Character

Now let's see how this new character works in relation to the
other characters in the font.

+ Choose Sample of Fonts: Venice-24 from the
Windows menu.

+ Scroll down in the window until you see some blank space
for typing. Test your new character by typing shift—option-F
a few times:

iD= sample of Fonts: Uenice-24
0123456789 The quick brown fox

jumps over the (azy dog. FFFFFFFH

- Notice that the characters overlap, incorrectly.
To fix this problem you need to adjust the character origin.
+ Reactivate the character window:.

+ Select the four-arrow tool from the tool palette in the charac-
ter window.

13



- Click on the large character and drag it to the right until the
leftmost dots of the degree symbol are just to the right of the
origin guideline.

el |===mmmm Idieresis from UeniceMod ===

ﬂ‘]:' ; e o R P

E ]
¥x

7
-
&

/
\\
*

: h

offsat -7 width 13 ﬂ

You'll also need to adjust the width of the character since now
the character falls to the right of the width guideline.

. Select the width tool from the tool palette.
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+ Click on the width line and drag it to the right until it is one
fatbit to the right of the rightmost dots of the letter "F".

I —— Idieresis from UeniceMod ——|
HT ......
At -
+
2 )
N,
]
®
offset -7  width 21 g

This change will give the character more room when it is
typed.

» Check the 'F in the sample window again.

The characters in the sample reflect the changes you made to
the origin and width. Is there enough space between the char-
acters now? If not, adjust the origin and width again.

Congratulations! You've just created a new character.

Saving Your Edited Font

You have created your new character using the Venice-24 font.
To keep your original Venice-24 font unchanged you can save
the font containing the new character under a new name.

15



. Activate the font window (the one with all the characters) by
clicking anywhere in it.

. Select Save a copy as. . . from the File menu

. Type in the name VeniceMod (for modified Venice).
+ Press the tab key to skip over the size.
+ Type in the Font ID "200".

The message at the top of the window tells you that your new
font will be saved into the Fonts file:

——e

Save current font onto: Fonts

Name:

Size: 24

Font 1D: | 200

| &

. Click on Save.

VeniceMod is now saved in the Fonts file and FONTastic
Plus then returns you to the font window.

Installing Your Font onto Another Disk

16

There are two convenient ways to install your font onto anoth-

er disk:
1. You can use the Save a copy as. .. command, or

2 You can use file windows and the Edit menu commands

Copy and Paste
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Since were on a tour, well use the Save a copy as...
command to install your new font into the System file on your

MacWrite disk, and the file window to remove the font from
the System file on the MacWrite disk.

+ Make sure the font window containing your modified Venice
is still selected and that you are not in MultiFinder. The rea-
son you must not be in MultiFinder is that your System file
is a file shared by all applications open under
MultiFinder and its integrity must be preserved or those ap-
plications will get very confused. So don't mess with your
System file while running MultiFinder.

- Select Save a copy as. . . from the File menu.

- Make sure the name is VeniceMod.

- Make sure the Font ID is 200
- Click on File.

- /1IDD/ Click on Eject in the Altsys file directory window
when it appears.

« /1DD/ Insert your MacWrite disk which contains the Sys-
tem File you wish to put the font into,

+ /2DD/ Click on Drive to transfer to the MacWrite disk If

MacWrite is not on this disk, click Eject and insert your
MacWrite disk into this drive.

| mt;“,.; One st Fne l Ty ik aves

Altsys4 5 Altsys4
‘@ Fontastic™ Plus 2.0

0O Fonts E Eject I| ( Eject )
aTesren || Cm ) | G
(_Open ) | (open )

| (_Cancel ) M [ Cancel ]

17



+ Find the System file in the System Folder on your disk and
double-click on its name to open it.

The Save a copy as. .. window will reappear. Note that

now Save current font onto: has “System” after it, rather
than "Fonts.”

. Click on the Save button.
« /1DD/ You'll be asked to swap disks.

. Your VeniceMod font is now saved into the System file on
your disk. You can use the font anytime you use any applica-
tion with a Font menu and that disk is your System disk.

Quitting FONTastic Plus

Now vou can leave FONTastic Plus to try out your new char-
acter in MacWrite.

. Close the font window.

A Save window appears asking if you want to save the
changes to font VeniceMod-24.

. Click on No, since you have saved a copy of this font into

the System file already and don't want to overwrite the orig-
inal Venice-24 in the Fonts file.

. Select Quit from the File menu.

. /1DD/ Eject the FONTastic Plus disk; insert the
MacWrite disk.

18
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Using the New Font
+ Open MacWrite from the disk you installed the font onto.

+ Choose VeniceMod in the Font menu.

& File Edit Search Format JICEIN style

Chicago
Courier
DemoOnly
Fontfog
Geneva
Helvetica
212°F 96.8°F “F'FF mome

. Monaco
New York
Symbol
Times
UVenice

o O ol ol ‘L

= ) = B |

. ST P S I...l....l ! | i...l..a...l. i
&) @) [6lines/inch

+ Type shift-option—F to try out your new character.

+ Quit MacWrite when you tire of typing this letter.

Now you know how to make a new character in FON Tastic
Plus and you can go ahead and create more of them. If you

would like to keep this modified Venice FONT, read the sum-
mary.

But if you don't want to leave this font in your System file,
read on.

*

Remmru'{%'l'nur Font from the System File on
the MacWrite Disk

- /1DD/ Reinsert the FONTastic Plus disk.

+ Open FONTastic Plus by double-clicking on its icon.
19
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First the introductory screen (click), then the Standard File
Selection window will appear.

. /1DD/ Click the Eject button in the window. Then insert
your MacWrite disk. Notice that the name of the directory
changes to the name of the MacWrite disk.

. /2DD/ Click Drive to select the drive containing your Mac-
Write disk.

(B Maclrite
IQHntlllrlin F 2 Macllrite
[ Eject ]
[ Drive |

<l

[ oOpen |
|| [ Cancel |

. Find and open the System file (in the System Folder on a
hard disk).

. /1DD/ Swap disks as you are asked to.

+ The file window will appear:

[—— System

Type: Chicago
N Chicaqo-12
Name: Courier
10: Courier-10
Point size: Geneva
Size: Geneva-9
Disk free: 20480 bytes Geneva-12
Helvelica

Helvetica-9
Helvetica-12
Monaco
Monaco-9
Times
Times=10

Times-12
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The column on the right now contains a listing of the FONTS,
FONDs, and NFNTs you have in your System file. Your listing
may look different, depending on what you've installed in your
System file.

+ Select the VeniceMod FOND from the list.
« Select Clear from the Edit menu.

+ A dialog will appear that asks you if you really want to re-

move VeniceMod. Click Yes.

+ Close the System file by clicking on the close box.

%;ml:{wing Your Font from the FONTastic Plus
S

- Select Open file. .. from the File menu and open the
Fonts file.

+ Select the VeniceMod FOND from the listing of FONDs in
"Fonts."

+ Select Clear from the Edit menu.

A box appears asking if you want to remove VeniceMod.

+ Click Yes.

* You may now exit FONTastic Plus by selecting the Quit
command from the File menu.

Summary

We hope you've enjoyed this tour and that you've caught a
glimpse of how useful FONTastic Plus will be to you in the fu-
ture. You have learned how to get into FONTastic Plus, add a

21
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character to a font, save a font, copy a font into an application
file (the System file—your computer's most important applica-
tion), remove fonts and exit FONTastic Plus.

If there are any sections that you do not completely under-
stand, feel free to go back through them. If you are ready to
learn more about FONTastic Plus, turn to the extended tutori-
al provided in Chapter 3. However, if you are ready to turn
your creativity loose, turn to the the reference section.

Enjoy!
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About Macintosh FONTSs. FONDs
and NFNTs






Chapter 2

About Macintosh FONTS,

FONDs and NFNT's

In this chapter, you will learn about the features of Macintosh
FONT, FOND and NENT resources. Then you can use these
concepts to create professional-looking typefaces. You will also
find some hints for using typefaces effectively.

Fonts

A font on the Macintosh is a complete alphabet of any one
type design in a given size. Fonts include upper-case and low-
er-case letters, numerals, punctuation marks and symbols. The
maximum number of characters possible is 256, but you do not
normally have to make your fonts that large, and besides, the
Macintosh won't let you use more than 223 of them.

Thousands of different typefaces exist, each creating a differ-

ent effect. The figure below shows a sample of the faces pro-
vided with FONTastic Plus in the Fonts file.

PyccHan (Russian)

Scan
EmmmEm "
Eroadway F

25



Typeface Characteristics
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All typefaces have standard characteristics. Varying these char-
acteristics helps to create faces with unique identities. These
characteristics include the following:

Ascenders
W T
SET T
xheight
Baseline 1
* Descender

Baseline. The baseline is an imaginary line on which the
capital letters rest.

X-height. The x-height is a measurement equal to the
height of the main body of lower—case letters (such as "x), not
including ascenders or descenders.

Ascender. The ascender is the part of such letters as "h” and
"b" that extends above the x-height.

Ascent. The ascent is the distance from the baseline to the
top of the highest character in the font.

Descender. The descender is the part of such letters as "p’
that extends below the baseline.

Descent. The descent is the distance from the baseline to
the bottom of the lowest descender such as the bottom of the



About FONTSs, FONDs and NFNTSs

Leading. (pronounced "ledding’). Leading is the amount of
space between lines. When the descenders of one line touch
the ascenders of the line below, there is no leading. Many
Macintosh programs ignore any leading set in the font and im-
pose their own. If you notice your leading settings being ig-
nored, it's probably your program that is doing the ignoring.

Origin and Width. The origin and width determine how
much horizontal space is allotted to a character. The origin
marks the left boundary and the width determines the right
boundary of that space.

Normally there is some blank space before and after the char-
acter. (The blank space before the character is called "offset.”)
But sometimes the character itself takes up all the space. And
sometimes there is less space allotted than the actual character
needs. Then the character will overlap the character before or
after it. See "kerning” below for a discussion of overlapping to
the left of a character.

Kerning. Kerming is a printer's term to describe overlapping
characters. Long ago, when printing was done with metal type,
certain letters were notched to fit together more closely. Letter
pairs such as "To" would be "kerned” together so that the "o
would nestle under the cap of the "T". Things are easier these
days. With FONTastic Plus you make the adjustment electron-
ically instead of grinding down a tiny piece of metal type.

We use the term kerning loosely here, in accordance with Ap-
ple’s font terminology. A single character can be kerned into
all other characters, as described below. In chapter 4 we de-
scribe kerning pairs, where a character kerns differently de-
pending on the character it is adjacent to.
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Kerning of a character with all other characters is set simply
by adjusting the origin so that part of the character lies to the
left of the origin marker. That part extends into the space giv-
en to the preceding character and is said to kern into the pre-
ceding character. Similarly, a character may extend to the
right of the width line, so it kerns into the following character.

DESEEI'E sl T e ISEEER A freeresss s
T 1

Origin  Width

In FONTastic Plus, the character origin and width are deter-
mined in the edit window. The Font Attributes. .. item
in the File menu controls the ascent, descent baseline and

leading. Kerning is determined in either the edit window (all
characters) or the metrics window (kerning pairs).

Point Size
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A "point” is simply the printer's term for 1/72 of an inch (ap-
proximately). If you are looking at Geneva 12, for example, the
font's point size is 12 points, or 12/72 of an inch. Normally that
size is the distance between the ascent line and the descent
line. Apple, however, often defines point size as the distance
from one ascent line to the next ascent line (in single-spaced
text). Thus, in some cases, the point size includes leading,
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Serifs and Sans

Two basic kinds of typeface are serif and sans serif. Serif faces
have small cross strokes (serifs) at the top or bottom of the
main stroke. Sans serif faces do not. The figure below illus-
trates the difference between serif and sans serif typefaces.

Sr:?'rfs < M M > Serifs

The "M" on the left is sans (without) serifs. The "M" on the
right is from a face with serifs.

Hints for Using Typefaces Effectively

The hints below are from experts in the use of typefaces. Fol-
low them if you want to use the faces you create with

FONTastic Plus in the creation of visually effective docu-
ments.

I. For text, serif faces are usually better. The serifs help guide
the eye along the line of text, making it more readable.

2. Use a 10 or 12 point size face for more readable text.
3. Avoid using all capitals for emphasis or for headings. In-

stead, use italics in text and boldface or a larger point size
for headings and subheadings.



4. Mix and match font typefaces carefully. Too many varieties
create confusion. A good rule of thumb is: "Never use more
than three typefaces on a single page.”

5. Avoid mixing different faces with extremely contrasting
shapes. such as pronounced curves or exaggerated serifs.

6. Rather than creating variety through mixing different faces,
try creating variety by using bolding and italics, and by ex-
panding or condensing type.

7. Avoid small sizes of reverse type (white type on a dark back-
ground). It is difficult to read. The New York Nights font is
included here merely as an exercise to show off FONTastic
Plus's capabilities.

8. Use a font with a large x-height for text. Because lowercase
letters predominate in copy, their size affects the overall ap-
pearance of a font. A font with a large x-height is more read-

able.

9. When creating your own font, keep in mind that font char-
acters should be uniform in such charactenistics as angles,
thick and thin parts of the stroke, and serifs.

If you want more information about creating a uniform and
beautiful font, you may want to read a book on typography.

Below are a few suggestions given by David S. Rose
(CompuServe 70210,563):

First Principles of Typography by Stanley Morison, Cam-
bridge: at the University Press, 1951.

Printing Types: An Introduction by Alexander Lawson, Bos-
ton: Beacon Press, 1971

The Crystal Goblet; sixteen essays on typography by Beatrice
Warde, Cleveland and New York: World Publishing Compa-
ny, 1956.
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Resources on the Macintosh

To understand the following dissertations on FONDs, FONTs
and NFNTs, you probably need to know something about
Macintosh resources. A resource on the Macintosh is a little
packet of structured data that has three identifying character-
15T1CS:

1. A resource type name of four ASCII characters (for instance

FONT).

2. A resource [D number which can range between 0 and
32767 and must be unique within a given resource file.

3. An optional resource name (for instance Geneva).

FONTs

The FONT resource is historically the oldest of the typeface-
related resources. Apple made the FONT resource obsolete in
1986 (with the introduction of the Macintosh Plus) by intro-
ducing the FOND-NFNT combination. However, many older
programs still needed FONTS, so there are still plenty of them
around. A FONT resource contains the bitmap images of all
the defined characters in a particular size of a particular type-
tace. Because of technical issues, a FONT ID is limited to the
range of 0-255. The resource name for a FONT is the name of
the font: Geneva's resource name is (surprise!) Geneva. The
original Macintosh programmers didn't think anyone would

need more than 256 typefaces. Well, they were wrong, and
thus was born the FOND.
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FOND:s

32

Note: The FOND resource is used only by Macintoshes with the
128K ROM or above. If you put fonts created with FONTastic
Plus on an original (128K) Macintosh or a 512K unenhanced Mac-
intosh, the FOND information is completely ignored. On all newer
Macintoshes it is essential to have a FOND associated with all
FONTs or NFNTs. If FONTastic Plus finds that such a FOND
doesn’t exist, it will tell you it is upgrading your FONT or NFNT
to the FONTastic Plus version. All that happens is that the appro-
priate FOND is added to your file, ensuring future compatibility
with Macintosh programs and Systems.

The FOND resource is a rather complex beast which contains
information related to an entire family of FONTs or NFNTs
(we'll get to that difference in the section on NFNTs). It con-
tains a great deal of information related to spacing and kern-
ing of the various FONTs or NFNTs attached to it. A
FOND's ID is not limited to the old 0-255 range which limited
a FONT's ID. FOND ID numbers can range between 0 and
32767 (except that numbers above 16383 are reserved by Ap-
ple). In practice, however, FONDs have retained the same ID
as their corresponding FONTSs. This correspondence does not
hold when you convert FONTs to NFNTs. A FOND with
NFNTs attached should have an [D number in the range
1024-16383. Apple reserves the range 3072-16383 for commer-
cial typeface vendors, so if you're creating faces for your own
use, use the range 1024-3071 for FOND IDs, otherwise contact
the AppleLink address FONT REG and request an allocation
of [Ds.

For example, when you open up the Fonts file (supplied on the
FONTastic Plus disk) with FONTastic Plus, the FONTSs
Venice-12 and Venice-24 belong to the Venice FOND which
appears in bolded type. When you edit a FOND in FONTastic
Plus you are editing the width and kerning pair information
for the entire family of Venice, namely Venice-12 and Venice-
24. Macintoshes with the 128K ROM (or better) look at this
FOND for width information. If a width table has been creat-
ed for this FOND by editing the FOND in the metrics win-

dow (see Chapter 4). the Macintosh uses the information
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found in the FOND's width table instead of using the individ-
ual (integer) widths set in each of the FONTs. Many programs
today require the existence of a FOND resource with properly
set up widths. If you are experiencing spacing difficulties with
typefaces created in FONTastic Plus. open the FOND's met-
rics window and use the Effects menus Set FOND
widths from FONT item. Warning: do this only to bit-

map fonts, never to PostScript fonts.

In addition to width and kerning pair information, the use of
FONDs and FONT families allows you to use specially creat-
ed FONTSs for stylistic variations like italic and boid. This al-
lows you to get better quality printouts because, unless you
create specially made (and better looking) styles of your own,
the Macintosh will automatically derive the various style vari-
ations from the plain FONT, a process which can produce
pretty ugly letters. FONTastic Plus's Effects menu lets you to
create a styled version of a FONT which you then edit to
make as smooth as possible. You can use the Altsys Family
Builder program (see the section on the Family Builder in
Chapter 5) to add this styled FONT to the FOND family, and
from within applications you can select just the style option
without having to change the actual font selection. If you con-
vert your FONTs to NFNTSs, you can use FONTastic Plus's
own internal version of the Family Builder which allows you

to Save as... your new styles as NFNTSs, allowing your

Macintosh to use your edited styled version instead of auto-
matically deriving its own.

NFNT's

An NFNT is internally exactly the same as a FONT. It differs
from a FONT in that it has the resource type name of NFNT
and its resource ID number is not numerically related in any
way to the ID of the FOND it's connected to. The resource
IDs of NFNTs may change every time they are moved with
Apple’s Font/DA Mover or FONTastic Plus and thus can be
considered essentially random. The family FOND of a family
of NFNTs contains a list of all the NFNT IDs that are related
to it. This list is what gets changed any time the family is
moved from one file to another.
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FONTastic Plus 2.0 allows you to convert FONTSs to NFNTs

with the Convert family to NFNT item in the File

menu. Families of NFNTs normally have only one FOND re-
source to tie them all (including all stylistic variations) togeth-
er. According to some rules promulgated by Apple Computer,
this FOND resource should have an ID number between 1024
and 16383 We advise you to convert all the FONTs you
create with FONTastic Plus to NFNT families so as to avoid
the FOND ID conflicts that can occur if you have many type-
faces installed in your System. If you are using Word Perfect
1.0.x, do not do this because Word Perfect 1.0.x does not rec-
ognize NFNTs.

If you are technically inclined you might investigate Inside
Macintosh, Volume [, pp 215-232 and Volume IV, pp 27-45.
Another source of useful information is Macintosh Technical
Notes #191 and #198, which are available for downloading

from GEnie, CompuServe, and AppleLink.
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Chapter 3
Extended Tutorial

In this chapter you'll learn about many of FONTastic Plus's
other capabilities, including:

How to create a new font file.
How to move fonts between files.
How to create new fonts.
More extensive editing techniques
a) for the entire font
b) for individual characters
How to print a sample of your font.

[f you want to take full advantage of the advanced features
that FONTastic Plus offers, you'll want to work through this
extended tutorial. You'll learn some hints and shortcuts that
will make typeface editing more efficient and more fun.
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Creating a New File

This section shows how to create a new file for storing fonts.
Such files can store FONTs, FONDs and NFNTs and may be
given any name.

+ Enter FONTastic Plus by double-clicking on the FONTastic
Plus icon, then clicking on the introductory screen.

The standard file selection window will appear:

| Hlttiﬂ
IR T | 1544
< Fontastic™ Plus 2.0
[ Fonts ( Eject J
D Samples of our Fonts ( Drive )
& TeachTeut
| Open |
7 __Cancel |

. Click on Cancel since we want to create a new file instead
of opening up an existing file.

. Select New file. . . from the File menu.

A standard file selection window will appear and FON Tastic
Plus will ask you to enter the name of your new file.

+ Type in "MyFile™ as the name of your file and click in the
Save button.

A file window titled "MyFile” opens up. There are no fonts
listed in the selection list since we have just created the file:
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Point size:
Size:
Disk free: 15360 bytes

]

Copying a Font from One File to Another

Whenever you wish to edit a font that resides in your System
file, we advise you to first copy it into a separate file before
you start to edit, and edit in that new file. In fact, the System
font, "Chicago-12", which is used by your Macintosh for its
messages, cannot be edited in the running System file (and
cannot be changed on Macintoshes with 128K ROMs or bet-
ter without a special patch available from Apple). Therefore
you must copy this font to a separate file before editing.

Now that we have created a file we are ready to add fonts to

the file. For this example, you will copy several fonts from your
System file to your newly created file, MyFile.
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. Select Open file. . . from the File menu

The file selection window appears.

. /2DD/ Make sure your system disk is in the internal drive

and click on Drive until the drive containing your system
disk appears in the directory.

. Find the System Folder on your disk, open it, then select the
System file and open it.

A second file window titled "System” opens up on top of the
file window titled "MyFile” (the topmost file window is the ac-
tive one). We can now copy several of the fonts from the Sys-
tem file and paste them into MyFile.

. Select the fonts Geneva-10 and Geneva-12, by pressing the
mouse button down on one name and dragging to the next.
Both fonts are highlighted and the amount of disk space
needed by both fonts is indicated in the top left corner next
to Total space. (If you do not have Geneva-10 and Gene-
va-12 in your System file, substitute any other fonts.)

_— System

Chicago
Chicago-12
Geneva

Geneva-9

Total space: 4934 bytes

Disk free: 7168 bytes Monaco
Monaco-9

Monaco-12

2k
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- Select Copy from the Edit menu.

This copies both of the FONTs and any FOND:s that are asso-

ciated with those FONTSs. (Only relevant FOND information
is copied).

- Reactivate the file window, "MyFile", either by clicking on
an exposed portion of the window or by using the

Windows menu. Do not close the System file window. It
must remain open for the following Paste to work properly.

+ Select Paste from the Edit menu.

+ If there is not enough disk space available to copy the fonts
into MyFile, an alert appears indicating the paste cannot be
completed. You then need to transfer MyFile to another disk
before copying and pasting the fonts.

You then see the FOND, Geneva, (in bold lettering), and
Geneva-10 and Geneva-12 listed in MyFile's selection list.

Copying a FOND from One File to Another

We have just seen how to copy fonts between files. It is also
possible to copy an entire FOND between files. When you
copy a FOND, FONTastic Plus copies the FOND informa-
tion, all associated FONTs belonging to that FOND, and oth-

er FOND:s associated with the family of FONT: all in one op-
eration,

+ Reactivate the "System"” file window.

- Select the FOND, Monaco (in bold lettering with no size ap-
pended).

+ Note the space used by the FOND and all its associated

FONTSs, This information is given next to Size: in the upper
left hand corner of the "System" file window. This figure is
the amount of space that the paste operation may need.
Sometimes, it may need less space. FONTastic Plus deter-
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mines the exact amount of space at the time of the paste op-
eration.

+ Select Copy from the Edit menu.

. Reactivate the "MyFile" file window.
. Select Paste from the Edit menu.

. If there is not enough disk space available to copy the entire
FOND to this file, an alert appears informing you that the

Paste cannot be completed. You should delete some files on
this disk to free up more space and retry the Copy and
Paste.

You'll then see the FOND name and all associated FONTs in
the selection list part of the file window for MyFile. (In this
case. Monaco, Monaco-9, Monaco-12, and any other sizes of
Monaco that you may have in your System file).

Removing a Font from a File

42

You may wish to make more room on your FONTastic Plus
disk by removing a font you no longer need. Make sure you
have an archive copy of the font elsewhere, then follow these
steps to remove the Monaco-9 font from MyFile:

. Select Monaco-9 from MyFile. Scroll to find it if necessary,

. Select Clear from the Edit menu.

A dialog box will appear, asking if you really want to remove
the selected fonts,

. Click Yes.

The font Monaco-9 disappears from the font selection list in
MyFile, and the FOND Monaco gets updated appropriately.
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Note: Certain System fonts (like Chicago 12) are necessary to
the Macintosh and cannot be removed. You'll see an alert dia-
log if you try to remove one of these fonts. You should never.
under any circumstances, remove fonts from the System while
running MultiFinder. Doing so will be harmful to the health of
your System file.

Removing a FOND from a File

At times you may wish to eliminate an entire family of FONTSs
or NFNTs. When you remove a FOND from a file
FONTastic Plus also automatically removes all associated
FONTSs or NFNTSs belonging to that FOND's family.

Note: If a font belongs to more than one FOND. it will not
be removed. You may separately select such a font and remove
it, causing all its parent FONDs to be appropriately updated.

Make sure you have the fonts archived somewhere, then fol-
low these steps to remove the Monaco FOND and its FONTS
from MyFile.

+ Select the FOND Monaco.

+ Select Clear from the Edit menu.

A dialog box will appear, asking if you are sure you want to re-
move the selected fonts.

+ Click Yes.
FONTastic Plus will remove the FOND and all associated

FONTS (in this case Monaco, Monaco-12 and any other sizes
of Monaco) from MyFile.
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Moving Fonts In and Out of System and
Application Files

You can move fonts into or out of either a disk's System file or
an application in the manner demonstrated in the quick tuto-
rial in Chapter 1.

You can customize an application (program) by adding fonts
to its application file. Fonts added to an application are only
available while you are using that application. If you customize
an application with a font already found in the System file,
don't worry. The application automatically uses your installed
font, not the one in the System.

The process of copying a font into an application is almost the
same as removing one.

. To Copy: Open the file which contains the font you wish
to copy. Select the font name and then select Copy from
the Edit menu. Now select Open file. .. from the File

menu again to open the destination file.
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+ Find and open the System file or an application file (such as
MacWrite) you wish to copy the font into.

+ The file window containing the selection list will appear. It
now contains a listing of the FONTs, FONDs and NFNTs
that are in that application or system. Note that none of your
disk’s System fonts (such as Monaco) are listed in an applica-
tion. Some applications may have unnamed fonts defined.
These are normally used for tool palettes and usually should
not be changed. Never delete such a font:

=" Ui ——— ———————
Type; -9 i

Name:
10: L3
Point size:

Size:

Disk free: 37888 bytes

&

+ After making sure the application or system file that you
want to copy the font into is the active window (i.e. on top),

select Paste from the Edit menu. The font is then copied
to this file.

Note: If you are Copying a font with the same name and
point size as one already in the application, you are asked if
you want to replace the existing font.

The copy of a FONT/NFNT maintains the same ID and
point size as the original. If necessary (in case of a duplicate
ID) FONTastic Plus will assign a unique new ID automatically

when the system or application you are pasting into already
has a FONT/NFNT with the same [D.
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. To Remove: Open the file or application which contains
the font you wish to remove. Select the font name and then
select Clear from the Edit menu. Do not remove fonts
which have no name (such as "~12°), or those which you did
not previously install. Some applications use fonts for tool
palettes, and removing those fonts would damage the appli-
cation. FONTastic Plus cannot Revert a font removal, so
be sure you know what you're doing before attempting this.

Editing or Creating Fonts

Now that you have learned how to move fonts around, it is
time to delve deeper into the font editing process.

Do you want to copy special characters from one font to an-
other? Or quickly create a different size for your font? Or style
the whole font with bolding, italics, shadowing, etc.? Do you
want to create a new font? This section will tell you how to do
all of the above and much more.

Working with Large Fonts

Before starting, you should note that there are some limitations
on the size of the fonts you can create or work with. You will
sometimes receive a wamning should your font exceed 32767
bytes. It's usually pretty safe to ignore the warning,

Macintoshes with the Old (64K) ROM

If you are using a Macintosh with 64K ROM., limit your fonts
to a maximum size of 32767 bytes. Larger sizes do not work on
these machines.

This is a generous size for most ImageWriter Il fonts, but you
may have to split up a larger font like those for the
[mageWriter LQ. For example, you may have to put capital
letters and numbers in one font and lower-case letters and
special symbols in another.
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All other Macintoshes

You may create fonts as large as 256K bytes on all other Mac-
intoshes. However, such large fonts are not compatible with

64K ROM machines and some few applications

Setting Up a New Font

To set up a new font, do the following:

+ Activate the file window of the file into which you wish to
put your new font.

For this example place the new font into the Fonts file sup-
plied on the FONTastic Plus disk. At this point, it would be a
good idea to close all other file windows that are currently
open so as to reduce screen clutter. If necessary open the

Fonts file on the FONTastic Plus disk using the Open
file. .. command in the File menu.

The tile window containing the selection list will appear:

Type:
Name:

n:

Point size:
Size:

Disk free:

Fonts

10752 byles

Broadway E
Broadway E- 18
Cairo
Lairo-36
KeyHMap
Keyrap-12
Hath
Math=-12
Math-24
NY Nights
NY Nights-12
NY Nights-24
NYItalic
NYItalic-18
Russian

I
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. Select the New font. .. command from the File menu.

A window will appear with a default point size of 12:

Create new Tonl

Size:

. Click OK.

FONTastic Plus will create an unnamed 12 point font and

open it for editing. Note that the ascent, descent and leading
are automatically set for the size you selected. You will see the
System font, Chicago in the character boxes.

. Choose the Actual item from the View menu to see the
blank boxes that will soon be filled by your font.

Copying Characters from an Existing Font to a
New Font

One quick way to create a new font is to use characters from
an existing font as a starting point. In this section we use this
shortcut to demonstrate how you can copy selected characters
between fonts.

. Reactivate the "Fonts" file window and select the font Ven-
ice-12.

. Open the font Venice-12 so we can copy characters from this
font into the new font we are creating. We need to select
the characters we wish to copy to our new font. The follow-
ing section describes various ways characters can be select-

ed.
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Selecting Characters

Each character or group of characters you wish to work with
must be selected. There are several ways to select characters.

An Individual Character

To select a single character:

» Find the character in the font window and click on it.
Or

+ Type the character on the keyboard.

All the Characters in a Font

To select all the characters in the font, you need only one
command:

- Choose Select all (32A) from the Edit menu.

A Range of Characters
A group of characters may be selected very quickly:

» Place the pointer on the starting character of the group you
wish to select. For our example, place the pointer on the
capital A,

+ Drag the pointer to the ending character of the group. For
our example, drag the pointer to the capital Z
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. If you need to extend the group, hold the shift key down
while you drag over the additional characters.

FONTastic Plus will highlight the letters A through Z in the
Venice-12 font window:

e Fonts: Denice 12 ===

At this point we have selected the characters we wish to copy.

. Select the Copy command from the Edit menu.
. Reactivate the "Untitled1-12" font window.

. Select the character positions in the grid for capital A
through 7 as you did before. The character positions are
empty but at the top of each character position in the grid
there is a label to indicate which character is normally asso-
ciated with that position. This label should be set to show
the characters; however, if it is not, you can switch this label
to the characters by selecting Key from the View menu.

. Select Paste from the Edit menu. The characters are cop-
ied into these positions and appear in the character grid in

"Untitled]-12".
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Note: When you paste characters between fonts of different
point sizes, hold down the option key while selecting Paste
so that characters will be automatically scaled to the point size
of the destination font. If you want an unscaled Paste. do a

regular Paste, without holding down the option key. You
will probably need to touch up scaled characters.

Shuffling Characters Within a Font

The following steps are for trading the locations of two char-
acters, but the principles are the same for any type of shuffle.
Usually the shuffle is done to assign more logical key combina-
tions to the characters.

- Select and Cut the first character.

» Select an unused box.

- Paste the character into it

+ Select and Cut the second character.

- Paste it into the first location.

+ Select and Cut the first character out of its holding area.

+ Select the second location and Paste the first character to it

Styling a Font

You can automatically style your selected characters with any
of the standard Macintosh text styles, such as Bold, Qutline,
etc. This styling actually changes the characters and cannot be
changed back to Plain except with Undo or Revert. It is

useful for making a hand-tuned styled font such as the
NYItalic-18 on the FONTastic Plus disk. FONTastic Plus also
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gives you three additional options besides italic, shadow, bold,
outline and underline. They are as follows:

Expand

Expand adds one point to the width of each character. That
means that the characters are spaced slightly further apart.

Condense

Condense reduces the width of each character by one point. It
means that the characters are pulled a little closer together.

Invert

Invert reverses the color of a character and its background
from black to white or vice versa. The Macintosh always
prints a standard space character as a block of white. If you
need black spaces between words, use the option-space key
(also known as a non-breaking space) or an otherwise unused
character.

Steps to Styling
To style letters in your font, follow these steps:
+ In the font window, select the character(s) to be styled. For

this example select the capital letters A through Z in
Untitled1-12,

. Select Style. .. from the Effects menu. A style selection
window will appear.
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Scale entire font... Select Style
—
. i (] Bold [J shadow

H,,"ﬁm;t'ﬂ flip *®, &) Italic [] Condense
Uertical flip . ] underline ] Espand
Rotate ®/ ] Dutline O] invert

Sel FONT widths from FOND

Set FOND widthvg Tram FONT : | Il

+ Click on the box for each of the styling features you want ap-
plied to your font. For our example select Italic.

. Click OK.

+ To see a sample of the changes you've made, select New
sample from the File menu. Do you like your changes? If
not, reselect the font window and Undo.

Alternatives in Styling

If you want to make more changes or if you want to have a
style applied again, select Style as many times as you wish.
For example, you can create a super-bold or super-italic style
by selecting Bold or Italic more than once, or you can make a
Boldltalic font by selecting both Bold and Italic,

+ As an example, reactivate the font window for Untitled1-12
and select the capital A through capital Z characters.

+ Select the Style command from the Effects menu once
again and choose Italic.

. Click OK.

You have now double italicized the new font. Reactivate the

sample window to check the effects of this second style opera-
tion.,
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[f you were pleased with the outcome, you probably would
want to polish the changes to make the font smoother. To do
this you would need to touch up individual characters in the
character window.

If you wanted to have both styled and unstyled versions of

your font, select Save as... from the File menu. Do not do
this now. We will demonstrate this later in the tutorial.

In some cases a styling operation can cause a character to ex-
tend outside the ascent and descent of the font. When this oc-
curs an alert message will appear.

+ Choose one of the following:

1. Have the program automatically fix the ascent or de-
scent.

2. Proceed with the styling operation anyway with the re-
alization that some parts of characters may be lost.

3. Cancel the operation.

Undoing and Reverting

Undo and Revert allow you to gracefully recover from mis-
takes or ideas which didn't work out. Each works a little dit-
ferently.

Undo

When the font window is active, the Undo command in the

Edit menu reverses the effect of just the last change made to
the font. It does not undo earlier changes. Any editing opera-
tion (style, scale, paste, etc.) can be undone.
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Suppose we decide we don't like the doubly italicized font
that we just created and would rather have italicized it only
once. We can do the following to obtain the effect we desire:

+ Make sure the font window Untitledl-12 is the active win-
dow.

- Select Undo style from the Edit menu.

Redo | -y

Cut ®H
Copy wC
Paste wy
Clear

Select all A
Edit missing ¥M
Lt newt _hy
Ldit ppapious B

+ Reactivate the sample window to see the effect of the

Undo.
Redo

When the font window is active, the Redo command in the

Edit menu reverses the effect of a previous Undo operation.
If we had decided that we did like the doubly italicized font

after all, we would merely select Redo style from the Edit

menu. Note that unlike the character edit window, there is

only one level of Undo/Redo from the font window.

Revert

When the font window is active, Revert allows you to throw
away all changes made to the font since you started editing or
since you last saved the font. We cannot do this now because
our Untitledl-12 font hasn't been saved to disk yet. However,
if you wanted to Revert you would do the following:
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. Select Revert from the File menu

New file...
Open file...
Meu fant.. -y
Open character =0

Save =S
Save as...
Save a copy as...

Font attributes... |
Lonuvert family to NENY

New sample

Open sample...

Page satup...

Print sampla...

Quit =0

Because you cannot undo Revert a dialog box will appear
asking, "Revert to the last version saved”

. Either click on Yes or Cancel, whichever is appropriate.

Saving the Font

Now that we have created a 12 point italic font that we are
satisfied with, we should save what we have done so far. Since
we still want to work with the font after saving it, we do not
want to close the font window. To save the font and leave the
font window open:

. Select Save from the File menu. Since this is a new font,

the Save as window will appear, asking what name you
wish to give the font. (If this was not a new font, FONTastic
Plus would merely save whatever editing you have done))
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+ Type in the new name. For our example type Veniceltalic

The point size shown on this window is correct, therefore we
do not need to alter this field.

The font ID field initially has 200 in it. You normally do not
need to alter this field. Let the program assign the ID. If you
want to, you may assign an ID which does not conflict with
any other.

. Click Save.

We have now saved whatever editing we have done up to this
point and our font's name is now "Veniceltalic-12" instead of
"Untitled]l-12" as you can see from the title bar on the font
window.

Scaling an Entire Font

Changing the height and width of a font's characters is called
scaling. For our example we will scale our newly created font,
Veniceltalic-12, to twice its size for high resolution printing
(see section below for further details).

. Select Scale entire font. . . from the Effects menu.

A dialog box will appear which shows you the current size of
the font and asks for a new size.

PN NS

Select Scale Factors
Horizontal

. 1 T - ST F : :
Horizontal flip %, rom: |12 To: |24
Vertical flip *®. Vertical
Rotate »®/ From: |12 To: |24

Set FONT widths from FOND l Ok ; '

Set FOND widths Tram FDNT
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. Enter the new horizontal or vertical size or both. For our ex-
ample enter 24 for both horizontal and vertical size.

. Click OK.

You have now scaled Veniceltalic-12 to 24 point size. Check
the sample window to see the effect of this operation.

At a later time, you will need to clean up rough edges and per-
form touch-ups on individual letters in the character window
using the character editing techniques discussed in Chapter 1
and later in this chapter. If you do not do this manual touch-
up work, your font will print exactly like it used to and you
will have gained nothing.

The size you choose may be larger or smaller than the current
size. Just pick a number between 1 and 127.

If you don't have enough main memory in your computer for
FONTastic Plus to make the desired change, you'll get a warn-
ing that the size you have chosen is too large for the available
memory.

Because the two sizes are entered separately, you may scale the
font more in one direction than the other. As the difference
between the sizes becomes greater, the characters become in-
creasingly distorted. Eventually they may become hard to rec-
ognize.

Preparing Fonts for High Resolution Printing

Remember that when printing on an ImageWriter I or 11, the
Macintosh tries to use a font twice the size of the selected
font. Therefore, for the best resolution in printing to those
printers you need to take the following steps:

+ Create a font twice the size of the one you use (by scaling as
we just did in the previous section). Otherwise, the print
driver will just double the size of the smaller font, with rath-
er jagged results.
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+ Smooth the larger font's edges as much as possible. Do not
change the widths of the double size characters because if
you do, you'll have tremendous spacing problems.

- If you make changes to the font size you see on screen, be
sure to also change the font which is twice its size. Other-
wise, the changes will not show up when you print.

- If you have an ImageWriter LQ, use the above instructions,
but substitute three times size (12 goes to 36) fonts. If you
have a LaserWriter of any sort, substitute 4.1667 times fonts,
but name them 4 times size. For example if you use the 12

point size on screen, you must also make a 50 point font, but
call it 48 points when you Save as. . ..

Saving A Copy As. ..

Now that we have scaled our font for high resolution printing,
we need to save this scaled version under the new point size.

The command, Save a COpY as..., in the File menu can
be used whenever you wish to save a new version of a font
under a different name and change the font's ID or point size.

Note: Two fonts with the same font ID but different names
cannot exist in the same font file. Also, two fonts with the
same name but different font IDs cannot exist in the same file.

- Reactivate the font window if necessary.

» Choose the Save a copy as... command from the File
menu.
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. Change the size that is automatically displayed from 12 point
to 24 point.

Save current font onto: Fonts

Name: |Ueniceltalic

Size: 24

Font 10: | 202

. After you have changed the size, click on Save

You have now saved a copy of our scaled Veniceltalic-24 font
into the Fonts file.

. At this point Close the font window for Veniceltalic-12.

You are asked whether you want to save the changes you have
made to the font since you last saved it.

. Since we have saved our scaled changes under a different
point size using the Save a copy as... command, click

No. The effect of the scale operation will not affect our
original 12 point Veniceltalic,
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Printing a Sample

Besides seeing a sample of the font you are editing on the
screen, it is often necessary to see a printed copy of the font.

Note: You can follow along with this portion of the tutorial
only if your computer is attached to a printer. Otherwise, just
read through this portion to familiarize yourself with the sam-
ple printing capabilities of FONTastic Plus.

+ Open up the font Veniceltalic-12.

- Open the sample window (New sample from the File
menu) for Veniceltalic-12.

+ Select the Page setup. .. command in the File menu.

The standard Macintosh Page Setup dialog box will appear, in
which you can specify the type of paper and page orientation
you wish to use. Do so.

+ Select the Print sample... command from the File
menu.

A dialog box will appear asking whether you wish to print the
sample text (the editable text that appears in the sample win-
dow) or the key map:

Select type of sample:
() Print key maps
@ Print text

[ cancel |
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The key map is a printout of the character grid (similar to
what you see in the font window of FONTastic Plus) with the
key positions displayed in the label portions of the grid and
the actual character for that position shown in the character
box. To obtain this sample do the following:

. Select Print key maps from this dialog
. Click OK.

Another standard printer dialog box appears asking for infor-
mation such as how many copies to make and what pages you
wish to print. For our purposes just accept the default values

. Click OK.

If your computer is attached to the printer correctly you will
get a printout of the key map for the font Veniceltalic-12. The
number of pages that print will depend on the size of the box

selected from the View menu while the font window was ac-
tive: if you selected Small box, then one page will print; if
you selected Medium box, then four pages will print; if you
selected Large box, then sixteen pages will print. The de-
fault box for a 12 point typeface is Small box
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Now we will print the text displayed in the sample window. If
you would like to print something else besides the default sam-
ple text, you can type whatever you want in the sample win-

dow. When you are finished typing:
- Select Print sample. .. from the File menu.

+ Select Print text from the dialog box that appears and
click OK.

Again the standard printer dialog box will appear, asking for
information on how many copies, etc.

. Click OK.

The sample window text will be printed in your font. The
printout will be the actual size of the bitmaps you entered into
FONTastic Plus, they will not be the 2X, 3X or 4X sizes that
produce Best looking output on printers like the ImageWriter
Il, ImageWriter LQ or LaserWriter [ISC. You will see these
Best looking characters when you print from other programs:
the print driver for the printer will then choose the appropri-
ate size to print in Best quality.
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Editing or Creating Characters

Now that you have learned to edit the font as a whole, it is
time to learn how to edit individual characters.

For instance, if you want to touch up the appearance of a par-
ticular character, or you want to learn how to make individual
characters, this section of the tutorial will help you accomplish
these goals. In it you learn how to use the editing tools and
how to assign a keyboard location to your new characters.

For the following examples on how to edit individual charac-
ters, we'll create a new demonstration font in the Fonts file.

. Close all windows except for the file window titled "Fonts”.
. Select New font. . . from the File menu.
A dialog box will appear, asking for the size of the new font.

. Enter the desired point size (in this case 18) and click OK.

A new font window named "Untitled1-18" will appear. It you

have not restarted FONTastic Plus since page 38, your win-
dow will be named "Untitled2-18".
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Selecting the Position of a Character

When you create a new character, you must decide which key
(or key sequence) will produce that character. Then you assign

the character to a grid location for that key or key combina-
tion.

There are several ways you can find the location of a charac-
ter.

I. Change the view to the System view by selecting System
in the View menu. Select the desired character in the Sys-
tem view. When you change to the other view (Actual

from the View menu), note the highlighted box. This is the
location you want.

or

2. Press the key or key combination on the keyboard. The loca-
tion on the grid of that key or key combination is highlight-
ed.

or

3. Change the view to key by selecting Key in the View
menu. The grid labels describe the key position. Click in the
desired character box.

- We will start by creating the lower-case 'n" in our new font.
Select this letter by any of the above methods.

Opening the Character Window

You must open the character window before you can create or
modify your characters.
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. Select Open character in the File menu
Or use a shortcut—

+ Double click on the position in the character grid of the
character you wish to work with.

The character window will appear. If you were modifying an
existing character, it would be displayed in the window. Since
you are creating a new character, the window is blank.

[EBOEES==—=—— n from Untitied! - 18 EEEE——=|

offsat O width 1
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The Various Drawing Planes in FONTastic Plus

There are three drawing planes in FONTastic Plus. Fach
plane is used for a different purpose to help make character
drawing easy.

LR

Foreground

When you open the character window, the plane that is active
is the foreground drawing plane. This is the primary plane and
only things drawn in the foreground plane become part of the
character you are creating.

Background

The background plane is used as a guide or template. Every-
thing drawn in the background plane is strictly for screen
viewing only, and does not become a part of the font, All of
the tools work in the background plane, so you can draw any
type of image. This plane is useful for comparing two charac-
ters by placing one in the background while editing the fore-
ground.

When you are in the foreground plane, the image in the back-
ground plane shows as gray. When you are in the background
plane, the foreground image is gray.

Guidelines

The guidelines plane lets you draw horizontal and vertical
guidelines which appear in every character of the font. They
are helpful for making standard width lines, or x-height lines,
used for assuring all lower-case letters have the same height.
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Using the Character Editing Tools

Editing a character is very much like drawing in fatbits with
MacPaint. You even use many of the same drawing tools. If
you need, you can review their functions in the illustration be-
low. Remember that when using the pencil, you can either
click (to change a single dot) or drag (to draw continuously).
The line, circle and box tools must be dragged out from some
starting point to an ending point.

— Camarad characier image al aclual size

= Drawing pane madecab

—— For scrolling characiers 106 arge 1o W o the adit window

i

'i' —— Foi scioling a charachr batwaen the ascani and descen lines
_ —— Fl drawing of erasing dol by dot

\ — Eor drawing linis by draggng the mousas

-

———— For driwing rectangular aneas

——— [Fod drawing cucular or oval areas

—— Fif arasing large arsas

£ 4 — [Fof selecing angas 1o cul, pashe, copy. Mowve or Qnow

4% | ——— For changing the width of a character

The Four-arrow Tool and Scroll Hand

One special tool here is the four-arrow tool. Use it for posi-
tioning your character between the ascent and descent lines,
or origin and width lines. This tool moves only the character:
the grid and the guidelines stay put. The scroll hand, in con-
trast, simultaneously moves everything in the window.

. Use either positioning tool by clicking it on top of the
edit area you wish to move, then drag with the mouse.
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Limits of the Drawing Area

The editing tools have no effect above the ascent line or be-
low the descent line. However, you can go as far to the left or
right as you wish.

Actual-size Image

In the drawing area, a character will be enlarged to eight
times its normal size when you first open the character win-

dow (8x magnification in the View menu). You can also
have the character enlarged to four times or two times by us-

ing the 4x magnification or 2x magnification selec-
tions in the View menu respectively.

» Look at your character in the small box at the upper left cor-
ner of the edit window. This is an actual size image of the

character. If the character is very large, this area shows only
the central portion.

Shortcut to the Scroll Hand

Whenever you want to use the scroll hand, you can do so
without having to select it in the tool box.

- Hold down the option key.

The tool you are using temporarily changes to the scroll hand.

+ Scroll the character to where you want it.

+ Release the option key.

The scroll hand switches back to the tool you were using.
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Accurate Horizontal or Vertical Moves

Trying to drag a tool in a precise horizontal or vertical line
can be difficult. You can use the following steps to drag any
tool horizontally or vertically.

+ Position your tool precisely where you want to start.
. Hold down the shift key.

. Press the mouse button and drag your tool in the approxi-
mate direction you want to go.

Your tool makes changes only within a straight line no matter
how much you wander.

Creating a Character

(0

Now that you have learned about some of the edit window
features, it's time to create a character. We have an empty
character window in front of us now. The first thing we
should do is adjust the width guideline.

. Select the width tool from the tool palette.
. Click on the width guideline (the rightmost guideline) and

drag it to the right leaving space to draw the letter 'n". We
can adjust the width more precisely later.
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Setting Additional Guidelines

It is often convenient to add additional guidelines to the
drawing area to assist drawing. When vou add a guideline in
the character window, you are adding that guideline to the en-
tire font. Therefore, when you open up another edit window
the guideline appears in that window also.

For our purposes we will add a guideline for the x-height of
the characters. Remember from Chapter 2 that the x-height is
the height of the main body of lower-case letters (such as "x"),
excluding ascenders or descenders.

» Change the planes in the edit window by clicking on the
El.‘?ine indicator until the guideline plane is active as shown
elow.
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+ Since we want to add a horizontal guideline, press the mouse
button down just below the horizontal borderline at the bot-
tom of the drawing area. You must be within two or three
screen dots below the borderline. If you properly position
the cursor, pressing the mouse button will turn the cursor
pointer into a crossbar.

/1
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+ Without letting up on the mouse, drag the line to the posi-
tion you wish to place it. (Let's position a horizontal guide-
line about halfway between the baseline and ascent, see illus-
tration below),

|E[ S n from Untitled1-18
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Any guideline which you added may be moved when in the
guidelines plane simply by dragging it. Place the pointer on
top of the line you wish to move and drag it to the desired lo-
cation.

To remove your horizontal guideline, place the pointer on top
of the line you wish to remove, and drag it below the horizon-
tal borderline at the bottom of the drawing area.

You can also add vertical guidelines if you wish. The process
is the same as for horizontal guidelines: place the pointer in
the area two to three screen points to the left of the vertical
borderline (i.e. in the last two or three screen points of the tool
palette) and drag to the right. To remove vertical lines you
drag the lines back to the left of this vertical borderline.

Note: The ascent, descent, leading, baseline and origin guide-
lines cannot be removed or added as described above.
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Drawing the Letter

We are now ready to draw the letter.

+ Change the drawing plane back to the foreground plane by
clicking on the plane indicator until the "F" for foreground
appears. Remember all drawing you want to appear in the
actual font must be performed in this plane.

- Select the line tool from the tool palette and position the
pointer to the right of the origin guideline and just below
the x-height guideline.

[E00===== n from Untitled] - 18 ===0F
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+ Hold down the shift key then press the mouse button to
constrain movement vertically and drag the pointer down to
the baseline.

+ Let up on the mouse, select the pencil tool and draw the rest
of the letter 'n".

If you make a mistake while drawing use the Undo and
Redo commands described below.
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Undoing, Redoing and Reverting

Three useful commands, Undo, Redo and Revert, make

character drawing very easy and efficient . Each of the com-
mands has its own specific use as described below.

Undo

[f you make a mistake or do not like the last action you took,
immediately select Undo in the Edit menu. Your mistake
will be removed. If you were to Clear by mistake, for in-
stance, you could immediately choose Undo clear.

I =Y

Bede cleay

Cut ®=H
Copy =C
Paste =0

Clear

Salact all =
Edit missing ®M
Edit next =N
Edit previous =B
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Redo

If you decide after you have performed an Undo operation
that you really did want to do the operation after all, you can

immediately select Redo and the operation will be restored.

Undo cloa

Cut #H
Copy ®C
Paste =D
Clear

Select ol =§
Edit missing %M
Edit nent ®N
Edit previous ¥B

FONTastic Plus supports four levels of undo and redo in the
character window so you can undo or redo up to four opera-
tions. You can undo and redo all operations performed in the
character window foreground plane except for scrolling the
character with the hand (which does not actually change any-
thing in the character). Undo and Redo are not available in
either the background or guideline plane.
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Revert

Revert, when selected, while a Character Window is active,
eliminates all the changes you have made to that character
since you last saved your work or since you last opened the

character for editing. The Revert command is found in the
File menu.

New Tile...
Open fMile...
Mew fant... LN
Open character ®#0

Save xS
Save as...
Save a copy as...

Font attributes... ¥
[pnoert family to NEN]

Open sample...

Fage setup...

frint samplea...

Quit 0

Adjusting the Origin and Width

When you are happy with the way the character looks, you are
ready to adjust the origin and width of the character.

The types of effects you can create are as follows:

Normal Width

Normally you should set the width at least one column beyond
the right of the character's dots.

{6



Extended Tutorial
Overstrike

You can create an overstrike (or zero-width) character to al-
low the next or previous character to print on top of it. To do
so, move the width guideline on top of the origin guideline. If
the character is to the right of these lines, it overlaps the fol-
lowing character. If the character is to the left of the lines it
overlaps the preceding character. Because of the way the
Macintosh text display works, overlapping the preceding char-
acter works better than overlapping the following character.

Offset

Oftset is the distance between the leftmost dot of a character
and its origin.

Overlap (Kerning)

You can position the character or adjust the width guideline
so that the origin and width guidelines fall within the charac-
ter's dots. If the origin guideline falls within the character's
dots, your character will overlap the character on the left. If
the width guideline is moved within the character’s dots, the
character will overlap the one on the right. (See "Kering” in
Chapter 2 for a more complete discussion of left overlap.)

For this character we will leave the offset as it is. If you want-
ed to adjust the offset, you would use the four-arrow tool to
position the character with respect to the origin.

To adjust the width:

+ Select the width tool from the tool palette

» Click the mouse at the horizontal position where you wish to
place the width guideline. For our character, place the width
line one column to the right of the rightmost bits of the let-
ter. We will test this width later and readjust it if necessary.
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Shortcuts for Creating Similar Characters

8

Now that we have created the letter 'n” we are ready to start
on the rest of the character set. A shortcut in creating charac-

ters is to copy similar parts of characters from one character to
another. We will use the letter "'n” as a base to create the let-
ters, 'h” and "u’.

. Close the character window for the letter 'n".

The font window for our new font is now the active window
and our newly created character appears in it.

. Select the "n” in the font window and copy this character
using the Copy command in the Edit menu.

. Select the position for the letter "h” in the font window grid.

. Select Paste from the Edit menu. The letter 'n” now ap-
pears in the grid in the position for the letter "h".

. Open the character window using the Open character

command in the File menu or double-clicking on this char-
acter position.
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+ All we need to do to convert the 'n” into an “h” is to add the
vertical extension to the line on the left of the character.

This can be accomplished using either the pencil or line tool
as shown below.

offset 0  width © Iﬁ

When you are satisfied with the way the "h” looks, close the
character window.

We are now ready to create the letter "u” in our new font.

Again we can use the letter 'n” we created earlier as a base for
this character.

+ Select the letter 'n” from the font window again.
+ Select Copy from the Edit menu.

+ Select the position where the letter "u” belongs in the font
window,
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. Select Paste from the Edit menu. The letter 'n” now ap-
pears in the grid in the position where the "u” belongs.

- Open up the character window for this character.

We can use the Horizontal flip and Vertical flip com-
mands in the Effects menu to change the 'n” into a "u”.

. Choose the selection tool (the dashed box) from the tool pal-
ette and select all the bits of the character.

. Select the Horizontal flip command from the Effects
menu. This flips the "'n" horizontally around the center of the
character to give the effect below.

[BJ======m8 u from Untitled|-15 =SSN

offset 0O width 9
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+ Select the Vertical flip command from the Effects menu.,

This flips the bits selected vertically around the center of the
rectangle.

S JSess u from Untitled!- 18 DRSS

offset 0 width @ )

You now have the letter, "u”. Adjust the position of the charac-
ter with the four-arrow tool if necessary.

The Horizontal flip, Vertical flip, and Rotate com-

mands in the Effects menu all flip or rotate around the center
of the selection rectangle if bits are selected; otherwise, they
flip or rotate around the center of the character.

+ When you are pleased with the letter "u”, close the character
window.

You have just created three characters with a minimal amount

of effort. You can use the above techniques and those that fol-
low to create many more interesting characters and fonts.
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Cutting, Copying, Clearing and Pasting

82

The following instructions are for cutting and pasting while
you are creating or modifying your character. They do not ap-
ply to adding or removing characters to or from fonts from the
font window.

To Cut, Copy, or Clear

Use the following steps:
. Select the selection tool (dashed box tool).

This tool selects areas just like the selection rectangle in Mac-
Paint.

+ Drag the rectangle until it surrounds the desired area.

. Select Cut, Copy. or Clear from the Edit menu or use
these keyboard shortcuts: 3X for Cut, #C for Copy, Back-

space for Clear.

To Paste

You may paste material from MacPaint (or almost any other
oraphic program) into the character window’s foreground or
background plane. You may also paste material copied or cut
from one character into another character from the same or
from a different font.

To paste material and keep its original size:

. Select Paste from the Edit menu or just type 3V,
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To paste material so that it scales according to the ascent and
descent of the font:

(Note: This is useful when pasting between fonts of different
point sizes.)

» Hold down the option key while selecting the Paste com-
mand from the Edit menu.

To paste material and scale it to a desired size:
+ Select the dashed box tool.

» Drag the box until it is the size you desire.

+ Use the Paste command.

The pasted material is now scaled to fit the box size, but it
may be distorted.

+ Use the editing tools to clean up the pasted material.

To move pasted material that isn't quite where you wanted it:

» While the selection box is still active you can place the cross-
bar pointer inside the selection box and drag the pasted ma-
terial to the location that you want. As soon as you are
pleased with the pasted material's placement, deselect the
rectangle by clicking outside the rectangle.

As an example of how copy and paste work from the edit win-
dow we can create the letter "H" for our new font.

+ Open your "System" file using the Open file. .. command
in the File menu.

+ Open the font NewYork-18.
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The font window for NewYork-18 will appear.

. Select the capital 'I” in the font window and open the char-
acter window for this character.

. Using the selection rectangle, select the bits of the 1"

. Select Copy from the Edit menu.
. Reactivate the new font window named "Untitled]-18"

. Select the character position for the capital "H™ and open the
character window for this character.

. Hold down the option key while selecting Paste from
the Edit menu.

The ‘I" appears in the character window. In the next section
we use this "I” to create the rest of the letter 'H".

Dragging Bits to a New Location

Besides being able to drag pasted bits to a new location, you
can also drag selected bits.

. Select the selection rectangle tool from the tool palette

+ Select the bits that you wish to move with the selection rec-
tangle.

. Position the pointer inside the selection rectangle and drag
the bits to the location you wish. After moving the selected
bits to the new location, you may deselect the bits by click-
ing outside the selection rectangle.

In addition to just moving the bits, you can make a copy of
the bits and then drag the copy to the position you want. We
will do this using the 1" that we pasted to create the letter "H".
Perform the following steps to accomplish this:
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+ Select the selection rectangle tool from the tool palette.

+ Select the bits that you wish to copy: in this case the entire
letter T".

» Place the crossbar pointer inside the selection rectangle and

press and hold down the option key and then drag the bits
to the right.

A copy of the bits appears. You can position these bits a

suitable distance from the original to create the second bar of
the "H".

BC) . H from Untitled |- 10 S|

........

1
P
E:}
& |
‘g AR - T N Y j :, .......
\ # :
- o R
» 1
=

offset 2 width 7

|

» When you are satisfied with their placement, deselect the bits
by choosing another tool or by selecting another set of bits.

Use the line or pencil tool to draw the crossbar for the "H".
and your letter is now complete.
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Scaling Selected Bits

Another interesting feature of FONTastic Plus is the ability to
scale selected bits to any size. To demonstrate this we create
the capital "C" for our new font from the lower-case "¢’ in

NewYork-18.

. Reactivate the "NewYork-18" font window and copy the low-
er case "¢ from the font window.

. Reactivate the “Untitled1-18" font window and paste the "¢’
into both the position for the lower-case "¢” and the position

for the upper-case "C".

. Open up the character window for the upper-case "C".

. Use the selection rectangle tool to select all of the bits of the
"¢". (see illustration below).

B[  {rom Untitled1-18 E——=—-0F
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Extended Tutorial

+ Place the arrow pointer one or two points inside the top
right corner point of the selection rectangle. Try to place it
as precisely as possible.

» Press the mouse button down and start to drag the rectangle
up and to the right slightly. The bits will start to grow. Stop
when the image looks about right for a capital "C".

IS C from Untitled1-18 F—————181H

................................................
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of fsat 1 width 10 a

Remember, if you do not like the way the image looks, you
can always Undo and try again.

This scaling operation can be done from any of the four cor-

ners of the selection rectangle, but you are limited to scaling
between the ascent and descent of the font.
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Rotating Bits

Another useful feature of FONTastic Plus is its ability to ro-
tate selected bits 90 degrees. We'll demonstrate this by devel-

oping a cloverleaf character in the shift-option-3 position of
our new font.

The following is a shortcut for switching to a new character
from the character window without having to close the win-
dow and reopen another.

« With the character window for the capital C from
"Untitled1-18" active, type shift-option-3.

You can type any character or combination of keypresses
when the character window is open and FONTastic Plus will
immediately change the character window to show the new
character you are requesting. Since you have just typed a

shift-option-3. the character window for the capital C will
change immediately to the character window for shift-

option-3. No character is defined in this position, so the win-
dow will be blank.

. Prepare the window for drawing by adjusting the width
guideline and making sure you are in the foreground plane.
Moving the width line before drawing is not required but
helps reduce screen clutter.
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+ Use the pencil tool to draw the right leaf of the cloverleaf

similar to the illustration below.
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+ Select these bits with the selection rectangle tool, and use
the option key to copy and drag them up and to the left.

- Select Rotate from the Effects menu enough times to posi-
tion the leaf as shown on the next page.
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The bits that were selected are rotated 9 degrees around the
center of the selected rectangle. If no bits were selected, the
rotation would occur around the center of the entire charac-
ter.
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+ If the bits are not precisely placed, select them and drag
them until they are where you want.

We only have to create the left leaf of the cloverleat now. This
is how we'll do it:

+ Again select the right leat of the cloverleat, then copy and
drag these bits to the left.
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- Use the Horizontal ﬂip command in the Effects menu to
change these bits so they are facing the way we wish.

EC|==== guilsinglleft from Untitled!-18 S=mmp]y
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+ If the bits are not precisely placed after the flip, select them
again and drag them to the location that you want.

« All you need to do now is create the stem with the pencil
tool.

Scaling an Individual Character

Changing the height or width of a character is called scaling.
Individual characters are best scaled by scaling the character's
dots.

+ Select the character to be scaled with the selection rectangle
tool.

+ Place the pointer in the top right corner of the selection rec-
tangle, press down on the mouse button, and drag the bits
until the character is the size you desire.

+ Reposition the character if necessary,
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Remember that the size is limited by the ascent and descent
lines. If you need a larger area, you must change the ascent

and descent values with the Font attributes. .. command
in the File menu. Doing so changes the ascent and descent

for the entire font. (See the Reference Section for details on
how this is done.)

Testing Your Character
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You can see the actual size of your character in the box at the
top left of the character window. You also need to test how
the character looks in relation to the rest of the font. You do
so in the sample window.

. Select New sample from the File menu to get the sample
window for your new font.

. Type in the characters we have just created to see how they
look and to check their spacing.

. Go back and adjust the width for any characters that need
more or less space between them.

. Go back and clean up any characters you are not pleased
with.

. You can do a Print sample. . . on these new characters to
see how they appear in print.



Extended Tutorial

Leaving the Extended Tutorial
+ Click on the close box of "Untitled]-18"

+ If you want to save the characters you have just created,

click Yes and name the font whatever you wish (following
the guidelines discussed in the Reference Section under the

Save a copy as. .. command in File Menu).

- If not, just click on No.

The font window for “Untitled1-18" and all associated charac-
ter windows and the sample window close automatically.

« If you are finished using FONTastic Plus select Quit from
the File menu.

Using FONTastic Plus and MacPaint under
MultiFinder

FONTastic Plus is completely compatible with Apple’s Multi-
Finder program. MultiFinder will allow you to run FONTastic
Plus and MacPaint together on a Macintosh with enough
memory (at least 2 megabytes of main memory). This arrange-
ment makes cutting and pasting from MacPaint into the char-
acter window much easier. You can cut and paste images from
MacPaint into either the foreground plane or the background
plane, depending on whether you want the image to become a
part of the font or whether you want to use the image as a
guide or template.

We will not give you all the instructions for using MultiFinder,
but do take note of the following:

+ Assign a minimum of 512K of memory to FONTastic Plus:
800K is recommended.

+ Never remove fonts from your System file while running
MultiFinder. Not even Apple's Font/DA Mover can remove
fonts from a System running MultiFinder.
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Summary

You have just completed a fairly extensive tutorial on the
many features of FONTastic Plus. We have shown you several
techniques that will aid you in your future typeface design en-
deavors. Turn your creativity loose and experiment.

There are a few features that we did not go into in this tutori-
al. Chapter 4 goes into detail about editing the FOND and
the metrics window that is associated with FOND editing. If
you want to establish kerning pairs or fractional width charac-
ters, be sure to read this chapter.

Chapter 6 (Reference) in this manual gives an explanation of
all the menu items in FONTastic Plus and its basic window
features. There are a few menu items that were not covered in
this tutorial. They are, however, discussed in Chapter 6.
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FOND Editing
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Chapter 4
FOND Editing

In this chapter you will learn how to edit the FOND resource.
Since the FOND resource is used only by Macintoshes with
the 128K ROM or better, this chapter is only for those who
plan to create fonts which will be used on such machines. If
you install a FOND on an original 128K Macintosh or an un-

enhanced 512K Macintosh, its information will be completely
ignored.

Recall from Chapter 2 that a FOND is basically a table con-
taining information about a family of related FONTs/NFNTs
which share width information, kerning pair information and
other tables. When you edit a FOND in FONTastic Plus you
are editing the width or kerning pair information for the en-
tire family of FONTs/NFNTSs belonging to that FOND. All
Macintoshes (except the original 128K Macintosh and the un-
enhanced 512K Macintosh) refer to this FOND for width and
kerning pair information. If these tables have been created for
the FOND using the techniques described in this chapter,
many Macintosh programs can use the information found in
these tables instead of using the less accurate information pro-

vided in the FONT/NFNT.
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Editing the FOND
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FONTastic Plus provides a special window, the metrics win-
dow, for editing the FOND. The metrics window can display
several characters simultaneously, with intercharacter spacing
presented as accurately as is possible on the screen. While it
still may be necessary to generate some print samples to
achieve optimum results, this window makes it possible to set
the width and kerning pair information for the FOND inter-
actively.

To edit a FOND in FONTastic Plus, perform the following

operations:

+ Select the FOND you wish to edit from the selection list in
the file window. Remember that the FOND's name will be
displayed in bold lettering.

. Select the Open fond command from the File menu or
double click on the FOND's name in the selection list of the
tile window.

Width/kerning tables to edit: ||
(@ Plain
@ RLUTITE
) Hald
O Bold I talic

A style selection window will appear. Only the buttons for
styles that exist will be selectable. Choose the style you want
to change, or press return to default to the plain style. The
metrics window for the selected style will then appear. When
you first open it, all entries in the metrics window will be emp-
ty and the center character position will be selected.
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The title bar of the metrics window shows vou the name of
the font we're editing, the largest point size of that font, and
the ratio of the size displayed in the window to the actual size
of that largest size. In the window above, we are looking at a
48 point font displayed at two times its actual size [2:1] You
can resize this window with the grow box at the lower right if
you need to see other ratios (for instance 1:1, actual size). Be-
low the title bar is the character display area. It is here that
the characters being adjusted are shown in context with other
characters. The metrics window will always display the largest
point size defined in the font. The widths in the boxes below
the character display are normalized to that largest point size.
Dotted horizontal lines are displayed to mark the position of
the font’s baseline, ascent and descent. Dotted vertical lines
show the origin of the first character and the width of each
character.

Below the display area is a small rectangular area which con-
tains a set of indicators (small inverted “T" shaped controls),
one for each character displayed. The indicators mark the po-
sition of the character's width and are used for adjusting the
width and kerning pair information.

The bottom part of the window contains the adjustment area.
This area is divided into a variable number of entries, based
upon the width of the window. Each entry may be empty or
refer to a character. The characters shown in the display area
are those referenced by the non-empty entries in the adjust-
ment area. The spacing for any combination of characters may
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be examined by assigning them to consecutive entries in the
metrics window and observing them in the display area.

Collectively. the offset. width, and kerning pair information
for a character are referred to as its metrics. You can edit and
adjust the width and kerning pair information for a character
in FONTastic Plus using the metrics window The next sec-
tion describes how to go about this.

Adjusting Character Metrics
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Each entry in the adjustment area has controls for two spacing

adjustments: Width and Kern. In empty slots, these controls
are disabled, while in non-empty slots the controls display the
current value of each of these adjustments. The value of each
adjustment may be altered using one of the arrows contained
in the control. Press the left arrow to reduce the value, or the
right arrow to increase it,

The width of a character is the increment applied to the cur-
rent position after drawing the character. The next character’s
origin line lies on top of the current character's width line. In
the character window, only integral values for character
widths can be defined. However, you can define fractional
widths for a FOND to get more precise spacing using the
width control in the metrics window. You should note howev-
er, that most Macintosh programs do not yet use these frac-
tional widths.

The kern control is used to specify kerming pair information. It
sets an adjustment to the width which is applied whenever
this character and the character in the entry to the right ap-
pear in adjacent positions. The kern value may be negative,
but the sum of the kermn and width values may not. The kern
adjustment is enabled only if there is a character referenced by
the entry to the right.

Note: Kerning pair information must be handled explicitly by
an application program. You should be aware that most of the
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software currently available for the Macintosh does not use
this information. Here is a list of programs that explicitly sup-
port kerning pairs:

Aldus FreeHand (all versions)
Aldus PageMaker 3.01

Quark XPress 2.1
ReadySetGo! 4.5

The Selected Entry

Only one of the entries in the adjustment area can be marked

as the selected entry. Some of the operations performed in
the metrics window affect only this selected entry. You'll be
able to tell that an entry is selected if its character name label
is highlighted. For example, the "c¢” character below is the se-
lected entry.

g ot

Hidth: 22.94

(=1

Hidth: 21.39 JHidth: 19.43

Changing the Selected Entry:

+ Position the pointer on the label of the entry you want to se-
lect and click the mouse button.

OR

- Repeatedly press the tab key until the desired entry is select-
ed.
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Changing the Character Assigned to an
Entr}f:

+ Select the entry you wish to change.

. Type the desired character on the keyboard or select Edit
next or Edit prE\?iﬂuS from the Edit menu.

Adjusting a Bitmap Character’s Width:

WARNING: Do not adjust the widths of a PostScript font's
characters in FONTastic Plus. You will end up with a spac-
ing nightmare. For example, do not adjust the widths of the
Times, Helvetica, Courier, or Symbol fonts. The only place
to adjust such widths is in a PostScript font editing program
like Fontographer.

. Press one of the arrows in the width control of the entry ref-
erencing the character. Use the left arrow to decrease the

width or the right arrow to increase it. Release the mouse
button when the desired width is reached.

OR

» Position the pointer on the width indicator tor the character.

BB Columbia-48 metrics [2:1] D

%

Hidth: 40. 00 | Hidth 27,00 QW idth:
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d
2




FOND Editing

+ Drag the indicator to the desired width and release the
mouse button. You can press and hold down the command
(3€) key while dragging to perform a demagnified move. This
decouples the pointer from the width indicator, allowing a
smaller increment of adjustment. The value in the width
control tracks the indicator as it is moved.

B Columbia-48 melrics [2:1] =Rl

Hidth: 20 .00 |Hidth 27.00 JHidth 25.00
ES £3C)] (3C3]
Kern: 0.00 | Kern: 0.00 | Kern: 0,00
ED &5 D =

FAc:lding a Kerning Pair to any Macintosh
ont

You should note that you can add kerning pairs to any Macin-
tosh font from any vendor. For instance you can add kerning
pairs to fonts like Times, Helvetica, Courier, and Symbol.
Note also that if you print documents with these modified
fonts, you must install your modified bitmaps into the System
on the computer that does the printing. Kerning information is
usually used by programs that print PostScript, but bitmap
fonts can also take advantage of kerning. Just make sure your
application program explicitly supports kerning pairs.

+ Make sure that the characters in the pair are assigned to ad-
jacent entries in the metrics window.
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- Press one of the arrows in the kerning pair control in the en-
try referencing the left character of the pair. Use the left ar-
row to tighten the spacing or the right arrow to loosen it.
Release the mouse button when the desired amount of kern-
ing is achieved.

OR

. Position the pointer on the width indicator of the left charac-
ter in the pair.

» Hold down the option key.

+ Drag the indicator to the position at which the desired
amount of kerning is achieved, then release the mouse but-
ton. You may use demagnification by pressing the command
(@8) key. The value in the kerning control tracks the indica-
tor as it is moved.

Removing a Kerning Pair:

+ Make sure that the characters in the pair are assigned to ad-
jacent entries in the metrics window.

+ Use the arrows in the kerning pair control in the entry refer-
encing the left character of the pair to set the kerning ad-
justment to zero. Release the mouse button when the value
reaches zero.

OR

» Position the pointer on the width indicator of the left charac-
ter in the pair.

- Press the option key.

» Drag the indicator to the position at which the kerning offset
becomes zero, then release the mouse button. You may use
demagnification by pressing the command (3€) key. The val-
ue in the kerning control tracks the indicator as it is moved.
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Copying Kerning Tables from FOND to FOND

You can copy the kemning table from one FOND to another.
This will allow you to use one typeface’s kering table as the
slt{:alrting point for some other typeface's table. Here's how to do
this:

+ Open the FOND whose kerning table you wish to copy and
choose the style you wish to copy.

. Use the Copy item from the Edit menu to copy the kern-
ing table into the Clipboard.

+ Open the FOND of your target typeface and choose the
proper style.

- Paste the kerning table from the Clipboard into the target
FOND.

You may also copy kerning tables from style to style within the
same typeface family. Here's how to do this:

+ With the metrics window for the source style selected,

choose the Copy item from the Edit menu.
+ Close the metrics window.

» Double-click on the family FOND again to open the metrics
window again, this time choose the destination style from
the style dialog.

+ Choose Paste from the Edit menu.
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Hints for Editing FONDs Effectively
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If you are using any Macintosh except the original 128K Mac-
intosh or the unenhanced 512K, the System will use the width
information set up in the FOND instead of the individual
widths set in the FONT/NFNT. Therefore, before you define
widths in the FOND using the metrics window, you need to
make sure that you have defined widths in the FOND for all
characters that are defined in the FONT/NFNTSs belonging
to that FOND. If not, you will get inaccurate spacing for char-
acters whose widths have not been set up in the FOND.
When you're in the metrics window you may use the com-

mand Set FOND Widths From FONT in the Effects
menu, to set all FOND widths to approximate values, derived
from the largest FONT/NFNT available. This provides a
good starting point for precise modification. If you perform
this operation, any previously existing width information gets
overwritten, so make sure you have another copy of any
FOND that contains changes you've already made.

The Set FONT Widths From FOND command in the

Effects menu can be used to quickly set the widths of a par-
ticular size bitmap font after you have changed width informa-
tion in the FOND using the metrics window. It's a good idea
to set all sizes of the bitmap font's widths from the FOND for
optimal spacing. This will ensure that the widths for all sizes in
the family are consistent.

If the FONT/NFNT widths differ from the FOND widths,
character spacing is liable to be wrong. It will differ between
the older Macintoshes and the newer ones (some difference is
to be expected in any event). Worse, it will vary between pro-
grams which support fractional spacing and those which do
not.
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Chapter 5
Hints for Advanced Usage

Using FONTastic Plus with Fontographer

If you use FONTastic Plus to edit the bitmap counterpart of a
PostScript font created with Fontographer, do not change the
widths of the characters. If you change those widths with
FONTastic Plus, the spacing relationships set up by Fontogra-
pher will be destroyed. The screen character spacing would
then be different than the printer spacing, resulting in ugly
and inconsistent spacing in printed results. This warning ap-
plies to any PostScript font.

Copying FONT:s

When copying FONTS from one file to another in FONTastic
Plus, all associated FONDs are also copied. For example, if
you copied the FONT Cooper-12, to another file and
Cooper-12 happened to belong to the FONDs Cooper,
CooperBold, and CooperBoldltalic, all three of these FONDs
would be copied and would appear in the selection list of the
destination file along with the FONT Cooper-12. You may
only have intended or needed the FOND Cooper, and feel
the selection list is cluttered with the additional FONDs.
FONTastic Plus works this way to be compatible with Apple's

Font/DA Mover.

You can get rid of these unnecessary FONDs without having
to worry about deleting Cooper-12. As long as a FONT be-
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longs to at least one other FOND that you're not deleting, the
FONT won't be deleted. Therefore, you may remove the un-

necessary FONDs CooperBold and CooperBoldltalic.

Setting Widths for FONT's from the FOND

If you use the Effects menu's Set FONT Widths from

FOND to set the widths for your FONT from the fractional
width tables in the FOND, make sure that you have set up
some width in the FOND for each character defined in all the
FONTSs. If you don't make sure there is a fractional width for

every character, you'll get very strange widths for any charac-
ter whose width is not defined in the FOND.

Defining a Non-White Space Character

The Macintosh does not treat the space character as a normal
character: it is always drawn as a white space. If you want a
black space, as for the NYNights FONT supplied on the
FONTastic Plus disk, use the non-breaking space character
(entered by typing option-space). You will have to handle line
wrap manually, by inserting a true blank.

Assigning FONT IDs
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When assigning ID numbers to FONTSs, there are a few things
to be aware of They are as follows:

1. We recommended that you avoid using FOND [Ds greater
than 255 if your typeface contains FONTs. FONDs with
FONTs attached and IDs greater than 255 may cause prob-
lems with certain versions of the Font/DA Mover. [f, how-
ever, your typeface has NFNTSs in it, you must use a FOND
ID between 1024 and 16383. We advise you to convert all
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FONTs to NFNTs with the Convert family to NFNT
item from the file menu so as to avoid the problem of con-

flicting FONT IDs.

2. Many applications use FONTSs for their tool palettes It is
therefore possible that the number you assign to your FONT
may conflict with the application's FONT ID for its tool pal-
ette The result of this is that you see your FONT instead of
seeing the tool palette when you open the application. To
avoid this problem we suggest that you do not number your

FONTs with the following IDs: 248, 249, 250, 384. and 510

Changing FOND/FONT ID and Name

To quickly change a FOND or a FONT ID or name, when
the file window is active use the Font attributes. . . item
from the File menu. Select the FONT or the FOND to be

changed, choose the Font attributes. .. item and type in
the new name and/or ID. This is quicker and better than edit-

ing and then performing a Save a copy as. . ., since it up-
dates all FONDs which reference the FONT.

It you change the ID of a FOND, make sure you make a corre-
sponding change to one of the FONTSs attached to that
FOND. For example, if you change the FOND ID of the Scan
FOND from 204 to 227, you must change the Scan-48 FONT

ID from 204 to 227 likewise. As above, use the File menu's

Font attributes. . . item to quickly change the ID of a se-

lected FOND or FONT. This process is not necessary if there
are only NFNTs attached to your FOND.
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Developing Fonts for Commercial Use

Altsys places no licensing requirements on fonts you make and
you are free to commercialize your fonts in any way desired.

When developing fonts for commercial use, the FONTastic
Plus font files should be converted to the FONT/DA Mover
font file types. This is a simple task.

. Start the FONT/DA Mover.

- Open the FONTastic Plus file.

.Create a new file. (FONT/DA Mover assigns its own file
type, and the standard suitcase icon.)

.Copy the contents of the FONTastic Plus file into the
FONT/DA Mover file.

Building Families of FONTs/NFNT's

If you need to develop your own family of FONTSs, merging
various styles into a single FOND, you may use either the
NFNT conversion capabilities in FONTastic Plus, or Altsys
Family Builder program. If you are creating strictly bitmap
FONTs with FONTastic Plus, then the NFNT route is the
easiest and most convenient. If you are creating PostScript
typefaces, you will need the Family Builder.

For details on the price and availability of Family Builder, con-
tact Altsys Corporation.

What are NFNTs?
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NFNTs are an extension of the Macintosh typeface handling
system. They allow for FOND ID numbers much larger than
256 and should allow you to use many more typefaces without
causing numbering conflicts.

NFNTSs also allow related typefaces to share the same FOND
resource, making it easier to build families of typefaces.
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Some Definitions:

Typetace family: a group of faces that are built on a base

typeface. For exampe, New York, New York Bold New
lei Italic, and New York Boldltalic are all in the same
family.

Base face: the unstyled, or plain version of a typeface. For

example, New York is the base face for the New York fami-
ly of typefaces.

Styled face: a face that has been reshaped by one of the ef-
fects in FONTastic Plus's Effects menu or has been created
from scratch with an effect already intrinsic but based on
?nme base face. For example, New York Italic is a styled
ace.

Creating a Family of Faces

» Select the FOND (the bolded name in the selection list) of
the face you wish to be the base face:

=== New Yorkers a7l

Type: FOND _w
: ew York-

Hrfma. New York New York-10

o 2 New York-12

Point size: New York-14

Size: 20204 bytes New York-18

Disk free: 42012672 bytes New York-20
8
|

» Choose the Convert family to NFNT item from the
File menu.
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. The conversion will occur and you'll see NFNT for the

Type: in the file window if you select one of the point sizes
of the newly converted family:

New Yorkers

Name: New York

New York-=10
I: 1024 New York-12
Point size: 9 New York-14
Size: 2032 bytes New York-18
Disk free: 42009600 bytes New York-20

ABCDEFGHI JELHNOF QRSTUVWHYZ
abodefghijkimnopgratuvwiye 01234536789
The quick brown fox jumpa over the lazy dog.

T
&)

If you need to convert an NFNT family back to FONTSs, do
exactly as above except this time the menu item will read

Convert family to FONT instead of Convert family

to NFNT. Apple's Font/DA Mover version 3.6 or earlier will
not properly handle families converted back to FONTSs, so it
is best to go back to the original family rather than convert

back to FONTs.

When you've done the NFNT conversion for all the various
styled faces of the family, you're ready to bring them together.
Here's how:

. Select one of the styled NFNTs and open its font window.
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Hints for Advanced Usage

- Use the Save as. . . item from the file menu and you'll get
this dialog:

Save NFNT as:

Family 1D: 1024
Size: 14
Style: (O Plain @ Italic

(O Bold ) Bold Italic

+ Make sure that the Family name: and Family ID: fields
match those of your base FOND, then click in the proper

Style: button.

« Click in the Save button or press return.

Do this tor each of the styled sizes that you have and you will
end up with a family of NFNTs with only one FOND to
choose in your Font menu. Now when you choose a style from
your Style menu (or Type dialog) your hand-tuned style will

show up instead of the Macintosh's rather uglier synthesized
style,

Note: This process does not work for PostScript fonts. You

must use Altsys' Family Builder if you wish to create families
of PostScript fonts,
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Laser Writer Typetaces

FONTastic Plus bitmap FONTs/NFNTs are compatible with
the LaserWriter, but do not print as smoothly nor as quickly as
the built-in LaserWriter typefaces. Even with “smoothing’
turned on, bitmapped FONTs are inferior to the PostScript
typefaces developed especially for the LaserWriter. The only
time this advice does not hold true is when you have built an
exact 4X size font and use the 1/4 size font on screen. Then
your printouts will be at least the equal of PostScript printouts.

When you wish to develop your own family of typefaces for
the LaserWriter and other PostScript compatible devices you
will need Fontographer.

Fontographer is a professional PostScript typeface editor for
the Macintosh computer. It allows you to construct true out-
line typefaces and automatically generates PostScript files
which can be downloaded to the LaserWriter. Fontographer's
typefaces work just like the standard built-in LaserWriter type-
faces, giving you fast, high-resolution printing.

For details on price and availabity of Fontographer, contact
Altsys Corporation.

Kerning PostScript Typefaces
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As described in Chapter 4, you may set or edit the kerning

pairs of any PostScript typeface. However, you must never
use FONTastic Plus to change the character widths of any
PostScript typeface.
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File Window

Type: FONT H’:“;:;' fl‘:
s
rl'q[:mu. :::ica NY N1nght3"1?
- NY Nights-24
Point size: 24 NYitalic
Size: 8126 bytes N¥italic-18
Disk free: 10752 bytes Russian
Russian-12

ABCIIB?G&{’L]]CIM 55::::1—45
NOPQRSTUVIWXYZ | /1Y
abcdefghijklmnop | VoM<
| arstuvaoxuz |

This is the window you see after opening a file from within

FONTastic Plus.

It has a standard title bar and close box at the top, a scrollbar
and size box down the right. The file window may be moved,
resized, and closed like any other window.

Just below the title bar on the left is the FONT/FOND infor-
mation section. The amount of available free space left on the
disk is given next to Disk free:. If a single FONT/NFNT is
selected, the name of the FONT/NFNT., its ID, the point size,
and the its size in bytes is displayed. If several fonts are select-
ed, the total space occupied by the selected fonts is given next

to the Total space: field. If a FOND is selected, its name
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and ID are given along with the size of the total space occu-

pied by the FOND and all the FONT/NFNTs in its family.

Directly below the FONT/FOND information section is the
sample text area. If a single FONT/NENT is selected, sample
text is displayed using that FONT/NFNT. This sample text
area shows what the FONT or NFNT will look llke if dis-

played or printed by an application that understands fractional
w1dths If this sample text area looks wierd, you probably need
to define the NULL character (character 00 declmal} by drop-
ping some points into it. Then open the metrics window for

the FOND in question and use the Effects menu's Set
FOND widths from FONT item This process usually

needs to be carried out on fonts that were created in other
font editors or are very old.

To the right of both of these sections is the selection list. All
FONDs, FONTE and NFNTs located in this file are displayed
in this section. FONDs are indicated in bold text. FONTSs are
indented, listed in plain text, and have their point size append-
ed to their name. NFNTs are displayed in the appropriate

style. You can use the scroll bar on the right to scroll through
the selection of FONDs, FONTs and NFNTs.

B === NINT Goudys —i

GoudyDldstyle
GoudyOldstyle-12
GoudyOldstyle-24

GoudyODldstyle-B._-12

Total space: 47076 bytes GoudyOldstyle-B._-24
Govdydildstyle-8._ -1
Disk free: 741888 bytes Govdylldsiyle-8. -2

Govdyolastyle-itelic- 12
bovayiilastyle-/talic-24
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Font Window

This is the window you'll see after opening a FONT,

It has a standard title bar and close box along the top, and a
scroll bar and size box along the right. The FONT window
may be moved, resized and closed like any other window.
Scroll up or down to reveal all the characters in the FONT.

The FONT window shows the characters of your FONT in a
matrix. Each position of the matrix is labelled with either the
keycode, character number, offset, or width, depending on

which option in the View menu has been chosen. The label
has a bold outline if the character has been defined in the
FONT. The label is inverted if the character has been edited
but not saved. Under the label is the character box which
shows each character.

Selected characters are highlighted in the font window. Select
a character by clicking in its box or typing it on the keyboard.

A range of contiguous characters may be selected by dragging
through it.

Most operations like Cut, Copy, Paste, Clear or effects op-
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erations such as Style, Horizontal flip, Vertical flip, or
Rotate. operate only on the selected characters. Scale

entire font... always operates on all the characters of a
font at once.
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Character Window
F_I from Denice-24 aassssl5|

offset 0 width 23 |2

Characters are edited in the character window. This window

has a standard title bar and close box along the top. It also has
a size box in the lower right hand corner.

The largest area of the window is the central edit area. This is
where all drawing and editing takes place. The character ap-
pearing here may be moved around with the scroll hand.
When you first open the character window, the character ap-
pears at eight times its actual size. You can also see and work
with the character at four times or two times its actual size by

selecting 4x magnification or 2x magnification, re-
spectively from the View menu.

The oftset and width values tfor the character are indicated
along the bottom of the character window.

Note: If you have edited to the left of the origin, the offset

changes to a negative number. If you subsequently erase
what you have added to the lett of the origin, the offset will
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remain negative even though no dots appear to the left of
the origin guideline. The offset remains negative until you ei-
ther switch to another character or close the character win-
dow, at which time the white space is eliminated and the
offset is updated. The same situation exists when you draw
to the right of the origin when creating a new character.
The offset will remain zero even though you may have white
space before the first dots of the character. When you switch
to another character or close the character window, the
white space will be removed and added to the character’s

offset.

Indiscriminate setting of origin and width in FONTastic Plus
can create the effects illustrated below.

lﬁ Sample of mod0OW-12 ﬁ

Effects of Width Settings

The quick bro wn fo X
Of the ‘0"  jumps ¢ ver the lazy
do g

Of the ‘4" jumps over the lazy dog

Effects of Origin Placement

The quick br own f ox

jumps over the lazy  0f the ‘o’

dog

The quick brown [oX Of the “w*

Of the ‘0° 023456789

-
|

Down the left side of the character window is the actual size
character, the current plane indicator, and the editing tools.

The character at its actual size is shown in the top box on the
left side. (Actually what appears in this box is the center of the
central edit area if this area is greater than 35 dots wide or
high) This allows you to see what your character actually
looks like while you are editing.
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The second box from the top is the current plane indicator.
Successive clicks in this indicator step from Foreground to
Background to Guidelines and back to Foreground. Drawing
and editing occur in the currently selected plane for Fore-
ground and Background planes. You can only add, move or re-
move guidelines while the Guideline plane is selected.

Hand. The hand tool is used to scroll the entire character
window. It is useful when characters are too large to fit into
the edit window. It does not change the character, but simply
moves it on the screen.

- Select the hand tool and position the pointer over any part

of the edit area. Drag the character to the position you de-
sire.

+ You can also use the hand without having to select the hand

tool by pressing the option key simultaneously with the
mouse button. This changes the currently selected tool into
the hand, which can then be used to drag the edit area.

Four-arrow Tool. The four-arrow tool is used to scroll the
character between the ascent and descent guidelines as well as
between the origin and width guidelines. It actually changes

the character by moving all the dots which make that charac-
ter.

+ Select the four-arrow tool and position the pointer over the
character. Drag the character to the position that you desire.
Be careful not to drag the character above the ascent line or
below the descent line because if you do, the part that sticks
out will be lost. A character may only be offset a maximum
of 99 points. The limit on the width of a character is 255

points.

Pencil. The pencil tool is used for drawing or erasing dot by
dot. You can either drag or click with the pencil. Clicking
draws just one dot. Dragging produces a line. Holding down
the shift key when beginning a drag constrains the points
drawn to a straight line.
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Line. The line tool is used to draw straight lines either verti-

cally, horizontally or diagonally. Holding down the shift key
when beginning a drag constrains you to straight horizontal or
vertical lines.

+ Select the line tool and position the pointer where you wish
to start the line.

+ Press down the mouse button and drag the other end of the
line to where you want it. The line is drawn after you release
the button.

Box. The box tool is used for drawing and then filling in rec-
tangular areas either in black or white.

To fill a rectangular area with black:

« Select the box tool and position the pointer where you wish
to start the box.

+ Press down the mouse button and drag the pointer in the di-
rection that you want the box to be drawn. A rectangular

outline the size of the box appears as you are dragging. The
box is filled in as soon as you let up on the button.

To ftill a rectangular area with white:
- Hold down the command key (#) then push down the

mouse button and drag the pointer in the direction that you
want the box to be drawn. When you let up on the mouse

button, the box is drawn in white.
To obtain an outline of a rectangular area:

. Draw the rectangle filling it with black as described above.

+ Determine the thickness of the outline and position the
pointer that many fatbits inside the black rectangle.

+ Draw a second rectangle (inside the first) filling it with white
as described above. You now have a rectangular outline.

If you hold down the shift key while dragging with the box

tool, you will always get a square.



Reference

Circle. The circle tool is used for drawing and then filling
circles or ovals in either black or white.

To till a circular or oval area with black:

Select the circle tool and position the pointer where you
wish to start the circle.

Press down the mouse button and drag the pointer in the di-
rection that you want the circle to be drawn. An oval out-
line the size of the circle appears as you are dragging. The
oval is filled in black in as soon as you let up on gt%e mouse
button. Hold down the shift key before and during the drag
to constrain the oval to be a circle.

To fill a circular or oval area with white:

Hold down the command key (3€) simultaneously with the
mouse button and drag the pointer in the direction that you
want the circle to be drawn. The oval or circle is filled in
with white as soon as you let up on the mouse button. Hold

the shift key down before and during the drag to constrain
the oval to be a circle.

Eraser. The eraser tool is used for erasing large areas.

Select the eraser tool, position the pointer where you wish to
erase, and press down on the mouse button. The dots under
the eraser are erased.

Selection Rectangle. The dashed selection rectangle is

used for selecting areas to cut, copy or paste. This tool is also
used to move selected areas and to scale selected bits.
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Width Tool. The width tool is used to set the width for
each individual character. You cannot set the width of a char-

acter beyond 255 points, since that is the limit for character
widths on the Macintosh.

+ Select the width tool and position the pointer on top of the
width guideline.

+ Press down on the mouse button and drag the width guide-
line to the location that you desire.
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Sample Window

B === sample of Enper: Exper-18 =———————(8iF|
ABCDEFGHIJKLMNOPQRSTUVWXYZ P

abedef ghijfklmno parsturwxyz 0123456789
quickbrown fox jumps over thelazydog,

&
=

The sample window displays text in the font currently being
edited. This window displays fractional width samples only
when the metrics window is selected. When the font window
or character edit window are selected, it shows integer width
samples. You can alternately select the metrics window and
the font window to see the difference between the two kinds
of spacing.

It has a standard title bar and close box along the top and a
scroll bar and size box along the right.

Each font can have its own sample window(s). You may open
and edit any text file or create a new sample file. You can
edit the text files using the regular text editing commands (this
window also supports the clipboard).

Any changes to the font shown in the sample window will
show up immediately, so if you want to see your edited charac-
ter in context, leave a sample window showing while you do
character editing.
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The Metrics Window
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S =—===m=== Scan-48 metrics [}:1] 3|

A _‘ b _ .

Hidih 41,00 fHidth 30 .00 JHidih Z6.00
(IE) &%) &)
K | 0,00 |Kern 0. 00 | Kern 0, 0o
cac) Ky D =

The metrics window is opened when you open a FOND for

editing. It is used to set fractional character width spacing for
the FOND and kemning pairs.

To open the metrics window, select a FOND from the selec-
tion list of the file window and either double click on the

FOND name or select Open fond from the File menu. The
metrics window is initially empty when opened and the center
character position is selected.

The window has a standard title bar and close box. No scroll
bars are displayed, but the bottom right comer has a size box
which allows the window to be resized.
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The central portion of the window shows several characters
across the screen. Showing several characters makes it easier
to see the relationships between the spacings of several char-
acters. Dotted lines indicate common baseline and width indi-
cator lines for all the characters.

The small inverted "T" shaped controls at the bottom of the
width lines are width adjustment controls. To adjust kerning

with these controls, hold down the option key while adjust-

ing the control associated with the left character in a kerning
pair.

Under the width adjustment controls is a row of rectangles
that shows the character name currently assigned to each met-
rics window slot. One entry is highlighted; this is the selected
entry which is logically connected to the keyboard. Typing a
key changes the character assigned to this entry. Advance the

selection to the next entry by typing the tab key, or clicking
on the entry you wish to select.

Below the name boxes are width and kern indicators. Each
may be changed by clicking in the adjusting arrows associated
with that control.

All direct adjustments are made by dragging the indicator.
Such drags may be demagnified (performed with greater-than-
normal precision: 0.1 units per pixel drag) by pressing the com-
mand (3€) key during the drag

You can adjust character widths by dragging the width indica-

tors left or right, or by changing the width value with the ar-
rows that point left and right.
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Kerning pairs are adjusted by dragging the width indicator of

the left character of the pair while the option key is held
down. They may also be set by changing the left character's
kern value with the left/right arrows. If the kerning value of a
character is non-zero, that character and the one to its right
are defined as a kerning pair. Change the kern value back to
zero to remove that kerning pair.

Note: Values in the width and kerning indicator boxes are in
points based on the largest point size in the style being edited.
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Apple Menu

Masterduggler™ >
Access Privileges
Alarm Clock
Calculator
Chooser

Control Panel
Find File

Key Caps

Note Pad
Proverb

Puzzle
Scrapbook

= BockFAH
B Finder

il Fontastic™ Plus 2.0
& Ready,Set,Go! 4.5

About Multifinder...

Select the About FONTastic Plus...

entry from the

Apple menu to see the current version number of this copy
of FONTastic Plus. Click in the box to continue.
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File Menu
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New file...
Open file...
MNew font... EN
Open font =0

Save ®Ss
Save as...

Save a copy as...
Revert

Font attributes... I
Convert family to NENT
New sample

Open sample...

Fage setup...

Print sample...
Quit =0

The File menu features operations which open or close win-
dows and deal with font and sample text files.

New file. .. creates a new font file. This command is active
from all windows. A file directory window is presented in
which file names on the disk are dimmed and you are request-
ed to enter the name of the new file you wish to create. A new
file is created to which fonts may be added. The new file win-
dow opens and becomes the active window.

n file... opens an existing file which can contain
fonts. This command is active from all windows. A file direc-
tory window is presented from which you select the file name
that you wish to open. The file window for the selected file
opens and becomes the active window.

New font. .. opens a new unnamed font. This command is
only highlighted when you have a file window active. The
new font is placed in the active file (the file specified as the
active file window). A dialog box will appear in which you
specify the point size for the new font. An empty font window
will then appear.
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fond/font/character changes depending on the
window that is active. If a file window is the active window
and a single font has been selected, this menu item reads

font. The result of this command is to open up the
tont window for editing the selected font. If a file window is
active and a single FOND has been selected, the menu reads

Open fond. The result of this command is to open up the
metrics window for the selected FOND. If a font window is
the active window and either a single character or a range of

characters are selected, this menu item reads Open

character. The result of this command is to open up the
character window for the selected characters.

Close closes the currently active window and any associated
windows. The effect is the same as clicking in the window's
close box.

Save writes the characters from the currently active font to
the font file it came from.

Save as... does the same as Save, only it allows you to
change the name and ID of the font being saved.

Save a copy as... allows you to save the font from the
currently active font window to a different file without chang-
ing the name of the currently active font.

Save current font onto: Fonts

Name: |Ueniceltalic

Size: 24

Font 10:
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To Change or Supply a Name

Before you decide on a FONT name, you need to know two
things.

1. Do not use special characters in FONT names. Parentheses
or slashes in particular cause problems in software which
uses font menus.

2. Macintosh software distinguishes between capital letters
and lower case letters. Thus a font named "Chicago™ would

be identified as different from one named "CHICAGQO."
To Disguise the Point Size

Some software accepts only fonts that are assigned certain siz-
es (typically 9 point or larger) However, you may wish to use a
font of a different size (6 point, for example)) In that case, you
would disguise your font's point size.

. Select the size field that is provided in the Save as window.
- Type in the new size (9, in this example).

Note: This command changes the name (for example, from
MyFont-6 to MyFont-9), but does not change the actual size
of the font. This trick works only with bitmap printers; it
will not work with PostScript printers.

. Click on Save if the other choices are satisfactory.
To Change the ID Number

FONTastic Plus automatically assigns to a new FONT or
NFNT one of the ID numbers that is not already used in your
font's file. Normally, therefore, you do not need to worry about
the ID. But if there is an ID conflict you'll need to change it.

The Macintosh operating system recognizes FONT [Ds from 0
to 511. While FONTastic Plus can handle IDs up to 511. the
FONT/DA Mover version 3.6 or lower (from Apple) can only
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handle IDs less than or equal to 255. If you use FONTastic
Plus to install and copy fonts, you can use IDs greater than 255.
It is highly recommended, however, that you avoid using
FONT IDs greater than 255. Apple has warned that FONTs
with [Ds greater than 255 may cause problems. Note that
FONTastic Plus automatically assigns ID numbers starting
from 200 and working up.

[f you are using NFNTSs, note that the only ID number you
should worry about is the FOND ID, which should range be-
tween 1024 and 3071 if you create fonts non-commercially.
NFENT IDs are assigned randomly by the Font/DA Mover or
FONTastic Plus whenever you move NFNTs from one file to
another, and thus do not need to be assigned any special num-
ber. FOND:s attached to NFNTs should have a unique ID that
will not clash with IDs from any other source. This will be true
if you buy typefaces from any commercial vendor who has reg-

istered FOND IDs with Apple.

Savm%lthe Font to Another File on the

Same Disk

The file that the font is saved to by default is named at the top
of the Save a copy as... window. However, you can use

this window to save the font to different file on the same disk.

+ Select Save a copy as. . . from the File menu.

. Click on File

The disk directory window will appear.

» Double click on the name of the file you want to save your
font to.

You are returned to the Save a copy as. .. window where
the name of the new file now appears.

. Click on Save.

137



138

Freating a New File and Saving a Font to
t

Once you are in the font window, you may use the Save a

copy as window for creating a new font file, then saving
your selected font to it.

. Select Save a copy as... from the File menu to open
the Save a copy as window.

+ Click on New file.

A new window appears which allows you to name your new
font file.

+ Type the name of your new file.

. Click on Save.

Your new file is created, and you are returned to the Save as
window.

« If necessary, type in the name of your font and make the oth-
er changes you desire.

. Click on Save.

Now your font is saved to the new font file and you are re-
turned to the font window.

Revert returns you to the last saved version of the entire
font or just one character, depending on the type of window
currently active. You are asked to confirm this operation since
it overwrites any changes you have made to the font or char-
acter since the last save, and cannot be undone.

Font attributes. .. displays information about the cur-

rently active font. You may change the ascent, descent and
leading from this window. When the file window is active,
and a single FOND, FONT or NFNT is active, it displays the
name and the ID of the selected FOND, FONT or NFNT.
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You may change the name and the ID. This is a quick and
easy way of changing the name and/or the ID. All relevant
FONDs/FONTs/NFNTSs are appropriately updated.

NOTE: You can reduce ascent or descent settings so much
that the tops or bottoms of your characters may be cut off as
shown below. The following will happen:

. FONTastic Plus warns you that your change will destroy
part of your characters (there will be "a loss of data”).

2. You choose either OK or Cancel.

Eesssssmss— Sample of Anglican: Anglican-24 E——
HBLBETOW I IRLIANOPOKS LUV [©
XL avcoemapyrunyoparsmvwxys
VIZ3490(%Y ULhe QUICKR DTOWY [0X
JUps over e a3y aod.

1
[

Warning: if you reply OK, you cannot recover those missi
parts with Undo. You must Revert to a previously sav
version of the font, and you will lose all the changes made
since the last Save.

Convert family to NFNT gives you the ability to con-
vert a whole family of FONTSs to their NFNT form, making
FOND ID conflicts much less of a problem than they used to
be. If you are converting a FONT family with separate
FOND:s for each style, be careful when converting to NFNTs
to select the base (unstyled) FOND for the conversion. Do not
select a styled FOND or you will break up a previously stable
family of fonts and make proper family recreation very diffi-
cult. This also implies that you should always do the conver-
sion to NFNTs on a backup copy of the family and never con-
vert your original.

If vou need to convert an NFNT family back to FONTSs, se-
lect the family FOND and then choose this menu item. It will

read Convert family to FONT instead of Convert
family to NFNT. Apples Font/DA Mover version 3.6 or
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earlier will not properly handle families convert back to
FONTs, so it is best to go back to the original family rather
than convert back to FONTSs.

Normal conversion of a FONT family to an NFNT family
means that any FOND resources that are part of a FONT
family (the Bold or Italic or BoldItalic FONDs) will go away,
since they are no longer needed. All the information in these
FOND resources is incorporated into the new base FOND re-
source by the conversion process. That is why when you open
a FOND resource with family information in it, you are greet-
ed with a dialog that asks you to choose a style with which to
work. All the width and kerning table information for all of an

NFENT family's styles are now stored in a single FOND re-
source.

New sample lets you create a sample text file. It is initial-
ized to a default string and displays the text in the sample win-
dow for the currently active font. This menu item is only high-
lighted when a font window or character window is active.

Open sample. . . lets you open any text file. It displays the
text in the sample window for the currently active font. This

menu item is only highlighted when a font window or charac-
ter window is active.

Note: The sample text files can be saved using the commands

Save and Save as. ..

Page setup. .. displays a dialog box in which you specify
the type of paper and page orientation you wish to use when
printing a font sample. This menu item is only highlighted
when the sample window is active.

Print sample. .. prints a sample of your font. This menu
item is only highlighted when a sample window is active. A di-
alog box appears asking whether you want to print the text in
the sample window or the keymap for the font. You can print
to either an ImageWriter or a LaserWriter printer. The font
that prints will be the actual size you have chosen in the font



Reference

window, not any higher resolution 2X or 4X font you may
have created.

Quit closes all windows and quits FONTastic Plus, returning
you to the Finder. If any windows have information that has
not been saved, you are asked whether you wish to save those

fonts before quitting. Respond Yes to save the font, No to
throw away all your changes, or Cancel to cancel the quit op-

eration.
Edit Menu
Undo pencil ®7
Redo pencil *®Y
Cut *H
Copy *L
Paste *U
Clear
Select all A
Edit missing %M
Edit next N
Edit previous ¥B

The Edit menu contains the standard editing operations as
well as a few commands unique to FONTastic Plus.

The first two items allow up to four levels of Undo and
Redo in the character window, and one level of Undo and
Redo in the font window. The type of operation to be un-

done or redone is shown next to the Undo or Redo opera-
tion. If no undo or redo is possible, the menu item is dimmed.

Cut copies the selected items (characters or parts of charac-
ters) to the clipboard and clears those items.

Copy copies the selected items (characters or parts of charac-

ters) to the clipboard without otherwise disturbing those
items. FONTs/NFNTs and FONDs are not copied to the

clipboard, but are held in a special font-moving area.
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Paste copies the contents of the clipboard into the current
character, font or file. If pasting a range of characters, you
must first select a range into which the new characters are to
be pasted. Pasting into the font window clears any existing
characters before pasting the new ones. Pasting characters or
parts into the character window adds the pasted information
to the character.

If you hold down the option key while selecting the Paste
item, any character you Paste will be scaled to fit the ascent
and descent of the character you're Pasteing into.

Clear removes the selected characters or parts of characters
without placing them into the clipboard.

Select all selects every character in the font window.

Edit missing edits the "missing character”. Not all fonts have
the full complement of 255 characters. Whenever a person
uses a key combination that has not been assigned a font char-
acter, the font draws a special character. That character is
called a "missing character.” In the standard Macintosh fonts,
it is a square box. In fonts created by FONTastic Plus, it is a
vertical bar.

[t you wish to use a different symbol for the missing character,
take these steps:

. Select Edit missing from the Edit menu.
+  Make the changes you wish.

+  Close the character window.
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Edit next advances the current character selection to the
next character in the character grid of the font window after
the currently displayed character. This command works when
either the font window is active or the character window is
active.

+ Select Edit next from the Edit menu. Or type #€N.

Edit previous advances the current character selection to
the preceding character in the character grid of the font win-
dow. This command works when the font window, the met-
rics window or the character window is active.

+ Select Edit previous from the Edit menu. Or type 6B,
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Windows Menu

Full screen
Fonts ®o
+Fonts: Venice-12 21

The Windows menu makes it convenient to deal with a
large number of windows open at the same time. Up to ten
windows may be opened in FONTastic Plus. Each one has a
position in the Windows menu window activation section,
and may be brought to the top of the window stack by choos-

ing that entry from the Windows menu.

Full screen toggles the topmost window's size between its
current size and the full screen. This command performs the
same operation as clicking the window grow box in the title

bar.
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L]
View Menu

Actual +RActual
System System
Decimal %0 Decimal %D
Octal Octlal
Hex *H Hew #*H

vKey ®K wKey %K
Offset wF Offset =¥
Wwidth ®W Width #1

vBn magnification *E Large bow ®E
4w magnification =R Medium box *AR
2% magnification T ~sSmall bou =T
Grid on 0 Brrill on A

The View menu controls the appearance of the font and
character windows.

Actual changes the view of the font displayed in the active

font window character grid to the actual characters in the
font.

System changes the view of the font displayed in the active
font window character grid to the standard characters of the
"Chicago” font. This view can be used to assign the key posi-
tions when creating characters.

Decimal changes the labels in the active font window char-
acter grid to display the decimal character number.

Octal changes the labels in the active font window character
grid to display the octal character number.

Hex changes the labels in the active font window character
grid to display the hexadecimal character number.

Key changes the labels in the active font window character
grid to display the keycode for the character.
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Note: The character grid labels like SO=, Oee, C-8 are inter-

preted as:

S- shift key
O- option key
C- command key.

For example to key in SO[ hold down the shift key, option
key and the [ key together. Another example is "Oee”: in this
case hold down the option key and type € then let up on
those two keys and type another €.

Offset changes the labels in the active font window charac-
ter grid to display the individual character oftsets.

Width changes the labels in the active font window charac-
ter grid to display the individual character widths.

8x magnification, 4x magnification, and 2x
magnification are all commands which control the size of
the displayed character in the character window. 8x
magnification shows the character at eight times its actual
size. 4x magnification shows the character at four times its
actual size and 2x magnification shows the character at
twice its actual size. When a font window is selected, these
items become Large box, Medium box and Small box
The proper size box is automatically chosen when you open a
font window, but you can change this choice with these menu
items in order to see more characters.

Grid on is used to display a line grid in the character win-
dow. If the line grid is displayed the menu item changes to
Grid off to turn the line grid off
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Effects Menu

ElTects

Scale entire font...

Style...

Horizontal flip »®,
Uertical flip -,
Rotate %8/

Set FOND widths from FONT

The Effects menu contains a set of operations which produce

special effects on the font as a whole or on selected characters
depending on the effect that is selected.

S_CELIE entire font. .. is used to increase or decrease the
size of the entire font to the point size selected.

Select Scale Factors
Horizontal

From: |12 Te: |24
vertical
From: |12 To: |24

147



148

Style. .. is used to style selected characters with any of the
standard Macintosh text styles, such as Bold, Outline, etc.,, in
addition to three additional options: Expand, Condense and
Invert, provided by FONTastic Plus. If the font window is ac-

tive, Style. .. styles the selected characters. If a character
window is active, the operation is performed on that charac-
ter.

Select Style

[ Boild [] Shadow
Italic [l Condense
[] Underline [] Ewpand
[C] Dutline [ Invert

Horizontal flip and Vertical flip flip the image horizon-
tally or vertically around the center of the selected rectangle if
a selection is made. If no selection is made it flips the charac-
ter around the center of the character. If the font window is

active, Horizontal flip or Vertical flip flips all of the se-
lected characters. If the character window is active, the opera-

tion is performed only on that character or on the selected
portion of the character.

Rotate is used to rotate the character or selected image 90
degrees around the center of the selected rectangle if a selec-
tion is made, or around the center of the character if no selec-

tion is made. If the font window is active Rotate rotates all
of the selected characters.
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Set FONT Widths from FOND sets the FONT widths
for the active FONT from the fractional width table of the
FOND. If the associated FOND has no width tables, an alert
box indicating that no fractional width tables are available is
displayed. Otherwise all character widths for the active
FONT are set from the FOND fractional width table. This
can be used to quickly set the widths of a particular size bit-
map FONT after changing the widths in the metrics window.
All sizes of a bitmap FONT should have their widths set from

the FOND for optimal spacing. This item is enabled only if
width tables exist in the FOND. When editing FOND met-

rics, the menu item Set FOND Widths from
FONT is highlighted, and can be used to initialize all the
FOND widths from the largest FONT/NFNT available. This

is useful for initializing the FOND widths when first starting

to edit the FOND metrics. It wipes out any prior width values
the FOND may have had.
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Many command key shortcuts have been defined to make us-
ing FONTastic Plus more convenient. Many menu items list
command key equivalents to the right of the menu item; type
the command key equivalent to perform that menu operation.

Backspace. The Backspace key is a shortcut for Clear in the
font window and the character window.

Tab. The Tab key advances the current selection to the next
position in the metrics window.,

Option. The Option key changes the current drawing tool to
a scrolling hand when in the character window. The scrolling
hand may be used to quickly drag the character image around
the window. When pasting into the character window, Option
pastes scaled rather than unscaled dots. In the metrics win-
dow, the Option key is used to set kerning while dragging
character width indicators.

Shift The Shift key is used to make constrained horizontal

or vertical moves when drawing in the character window.
When drawing an oval, however, the shift key constrains the
drawing to a circle. In the font window, the shift key allows
you to add contiguous selected items to an already selected
area. In the file window, the shift key allows you to make dis-

contiguous selections of FONTs, FONDs or NFNTs.
Command 3€). The Command key (3€) draws lines, ovals or

rectangles in white instead of black.
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1DD 5-6, 17-18, 19-20
2DD 5-6, 17-18, 20, 40

About FONTastic Plus...

133
Actual 63, 65
allocation of FOND IDs
by Apple 32
Apple menu 133
AppleLink 32
application file 6, 44

ascender 26
ascent 26, 28, 68, 69, 138

background 67, 125

backspace key 150

backup copy 6

baseline 26, 28, 68, 69,
138

bold 51

box 68, 123

character window 123
characteristics 26

circle tool 68, 127

Clear 21, 42-43, 46, 74, 82,

142

clipboard 10-11, 129

Close 135

command (3€) key 131,
146, 150

commercial typefaces 32,
112, 137

Condense 52

152

Convert family to
NENT/FONT 34,

113-114, 139-140

Copy 10, 16, 39-46, 48, 50,
82-84, 109, 141

copy characters 48

create 38, 46, 64, 70

Cut 51, 82, 141

decimal 145

demagnified 103, 131

descender 26

descent 26, 48, 69, 138

double-click 6-7, 9

dragging 68, 84-85, 87,90,
125-126

drawing plane 67

edit 11, 16, 21

Edit missing 142

Edit next 101, 142

Edit previous 101,
142-143

Effects menu 52, 57, 80,
81, 106, 147

eraser tool 68, 127

expand 52

family 34, 97

Family Builder 33, 112

fatbits 12, 15

file menu 9, 11, 54, 57, 59,
76, 130

file selection window 6,

38



file window 7, 20, 38, 40,
45, 119

FONDs 8, 32-33, 41, 43,
97, 105, 109, 119-120,
130

Font attributes... 28, 92,
111, 138

font ID 8, 17, 45, 59-60,
111, 119, 136-137

font selection window 8

font window 8, 121

Font/DA Mover 112, 136

Fontographer 109, 116

fonts 8, 25, 109, 112,
119-120

foreground 67, 73, 125

four-arrow tool 13-14, 68,
125

fractional widths 100

Full screen 144

Grid off 146

Grid on 146

guidelines 67, 71-72, 77,
124-125

hand tool 68-69, 125

hard disk 1, 2, 5

hex 145

horizontal 57, 71-72

Horizontal flip 80-81, 91,
148

icon 6, 112
ID, FONT 59-60, 111,
119, 136

K

L

M

N

Index

ID, NENT 33-34, 137

ImageWriter 11 46, 58, 63

ImageWriter LQ 46, 59,
63

invert 52

italic 53

kerning 27-28, 77, 99-105,
116

kerning control 103-104

Kerning pair 33, 99-105,

130-132

kerning tables 105

Key 50, 146, 150

keymap 61-62, 140

large fonts 46-47
LaserWriter 59, 116
LaserWriter 1ISC 59, 63
leading 27, 72

line tool 68, 73, 126

Macintosh Plus, SE,
SE/30, II, IIx, Ilex 1

MacPaint 93

MacWrite 19-20

magnification 69, 146

me%ics window 98-106,
1

missing character 142

MultiFinder 43, 93
New file 38, 134, 138

New font 47-48, 64, 134
New sample 9, 53, 92, 140
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NENT 6, 8, 25, 31-34, 43,
45, 97, 106, 110-116,
119-120,136-137,
139-140, 149

NULL character 120

Octal 145

Offset, offset 77, 123, 145

Open character 11, 65-66,
80, 135

Open file 21, 40, 44, 47
83,134

Open fond 98, 130, 135

Open font 8, 135

open sample 9, 53, 92, 140

option key 51, 69, 83-84,
104, 146, 150

origin 13, 15, 27-28, 76-77,
123-124

outline 52

oval 68, 127

overlap 13, 77

overstrike 77

Page setup... 61, 140

Paste 11, 16, 41-42, 45, 51,
78, 80, 82-84, 142

pencil 12, 68, 125

plane indicator 67, 71

point size 8, 28-30, 48,
58-60, 64, 99, 119, 136,
147

Print key maps 61-62

Print sample... 61, 63, 92,
140-141

154

Print text 61, 63

printer 58-59, 61-63, 109,
116,

printing 58-59, 61-63,
140-141

Quit 18, 21, 141

Redo 55, 75, 141

remove 19, 21, 42-43

Revert 51, 54-56, 74, 76,
138

Rotate 81, 89-90, 148

sample window 9, 13, 15,
53,61, 129

sans serif 29

Save 16, 18, 56-57, 60,
135-138

Save a copy as... 16-17,
59-60, 93, 135, 137-138

Save as... 54, 56, 59, 135

scaling 57-58, 83, 86-87,
01-92, 147

scroll hand 68-69

select all 49, 142

selecting characters 49-51

selection list 7

selection rectangle 68,
84-87, 127

selection tool 68, 84-87,
127

serif 29-30

Set FOND widths from
FONT 33, 106, 120, 149




Set FONT widths from

FO
shift
150
style

ND 106, 110, 149
key 70, 73, 126-127,

33, 51-54, 148

System 19-20, 65, 93, 145

T

tab key 101, 131, 150
tool 12, 68, 85, 125-127

tool palette 12, 14, 68, 77.

111

. 125-127

Total space 40, 119
Undo 53, 54-55, 73-75,

U

141
V

Vertical flip 80-81, 148
vertical guidelines 72
View menu 48, 65, 69,

121
W

. 145-146

width 15, 27, 70, 76-77,
99-103, 110, 123-124,

128
widt
102

0129, 131, 146
n control, fractional
-103

widt

h indicator, metrics

window 99-103

widt!
128

l"I
3

h tool 14, 68, 70, 77,

" windows menu 144

X
x-hei

ght 26, 30, 71-72

zero-width 77

Index
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