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LICENSE NOTICE, LIMITED WARRANTY AND
DISCLAIMER AND LIMITATION OF LIABILITY

 Abracadata, Ltd. grants to Licensee the non-exclusive license to use the Software
on one computer and to make a backup copy of the Software for Licensees own use. All
rights and protections under federal, state and international law, including but not limited
to the law of copyright, patent, trademark, trade secret and contract, shall remain in full
force and effect. Licensee may not download, reproduce, distribute, republish, sell, rent,
lease, sublicense, or translate the Software or documentation in violation of those laws and
this License. The Software remains confidential, proprietary information, in which
Abracadata, Ltd., the authors, suppliers and developers of the Software claim trade secret
rights. Licensee may not modify, reverse engineer, decompile or disassemble the Software.

Abracadata, Ltd. warrants to Licensee and to no other person or entity that the
physical disks provided to Licensee (but not the Software recorded on them or the
documentation), are free from defects in materials or workmanship for a period of 30 days
from the original purchase date. If during this 30-day period a defect should occur, the
original disk(s) may be returned with a copy of your dated sales receipt and a brief
description of the problem to Abracadata, Ltd., PO Box 2440, Eugene, OR 97402, for
replacement free of charge. Licensees sole remedy in the event of a defect in the disk is
limited to replacement of the disk. Any implied warranties found to exist shall terminate no
later than 30 days after purchase. If the disk has been physically damaged, is beyond the 30-
day limit or is not accompanied by proof of purchase, include $10.00 for each disk plus
$3.00 postage and handling per request. Please return the disk only, not the entire package.
Do not staple or paper clip the disk. Package the disk carefully to prevent bending, and
mark the package Do Not X-Ray or Use Magnets. Ship via UPS or U.S. Postal Service with
return receipt requested. Abracadata, Ltd. is not responsible for disks not received when
Licensee cannot provide proof of shipment and Abracadata, Ltd.s receipt.

This Limited Warranty shall not extend to any claim of any person or entity for
or right to recover any other damages whatsoever, including but not limited to, loss of
profit, loss of information, business interruption, or special, incidental, or consequential
damages or other similar claims, arising out of the use or inability to use the Software or
documentation, even if Abracadata, Ltd. has been specifically advised of such damages. In
no event shall Abracadata, Ltd.s liability for any damages to License or any other person
ever exceed the actual price paid for the Software, regardless of the form of the claim.

In all other respects, the Software and documentation is licensed AS IS, WITH
ALL FAULTS. ABRACADATA, LTD. SPECIFICALLY DISCLAIMS ALL
OTHER WARRANTIES REGARDING THE SOFTWARE AND DOCUMEN-
TATION, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO,
ANY IMPLIED WARRANTY OF MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Abracadata, Ltd. specifically makes no representation or
warranty that the Software is fit for any particular purpose.

This Limited Warranty gives Licensee specific legal rights. Licensee may have others, which
vary from state to state. Because some states or provinces do not allow the exclusion or
limitation of liability for consequential or incidental damages, or the limitation on duration
of an implied warranty, some of the limitations may not apply to Licensee.

Abracadata, Ltd. gives no assurance that the information used in the develop-
ment of the Software is reliable and accurate. Any recommendations or suggested results in
the Software represent only the generic opinions and judgments of the author and are
intended to be applicable in a variety of circumstances. However, individual circumstances
vary and may render certain recommendations and results inapplicable. Abracadata, Ltd.
gives no assurance that the opinions or judgments of the author are reliable or accurate.

If any provision of this License is held to be unenforceable, it will be construed to
have the broadest interpretation that would make it valid and enforceable. Invalidity or
unenforceability of one provision will not affect any other provision of this License. This
License shall be governed by the laws of the State of Oregon.



  Technical Support

Abracadata appreciates your support and interest in using our products!
We provide free technical support so if you run into problems, or have
questions that you can’t find answers for in this manual, help is only a
phone call away.

Before calling though, please look through your manual for the solution.
You’ll find the answer to many of your questions and problems here. In
particular, check the “Trouble Shooting” appendix for a possible answer. If
you are unable to find a satisfactory answer in the manual, please gather
the following information then call the technical support number below for
assistance.

1. Determine the version of Mighty Draw you have. The version number
follows the program name, which is under its application icon. The
“Getting Started” chapter shows where the application icon is located on
your disk.

2. Know what version of system software you are using. If uncertain about
what version you have, select About The Finder under the Finder’s Apple
menu.

3. Know which, if any, Inits  are on your system. Inits are utility programs
whose icons may appear along the bottom of the screen when you start
your computer. They typically modify standard system operation in some
fashion. It’s not uncommon for Inits to cause compatibility problems
between themselves, or other applications. They are located inside your
System Folder.

4. Call Abracadata’s technical support number between 8:30 AM and 4:30
PM Pacific time: 503-342-3030. Please don’t call our order lines for technical
support. These employees are not trained for technical support. Unlike
some companies, we don’t charge for support. We only ask that you pay for
the call so that we may continue to provide economical products for you
and all our customers.
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  Introduction

Welcome to Mighty Draw, a powerful yet easy-to-use drawing program.
Mighty Draw lets you quickly and easily create pie charts, column charts,
bar charts, organizational charts, flowcharts, electronic schematics, flyers,
ads, greeting cards, and much more.

Extensive symbol library support is provided. You can pick from a large
variety of symbols included with Mighty Draw, or create your own custom
symbol libraries. The provided symbol themes include animals, sports,
maps, borders, people, business, transportation, recreational, military, flags,
furniture, flowchart, electronic schematic, and more.

Simply continue reading to learn about all of the features, and thank you
for purchasing Mighty Draw!

6



Chapter 1

  Getting Started

If you are familiar with the Macintosh’s desktop  environment, you’ll feel
right at home using Mighty Draw. This manual’s primary focus is on
specific information you need to use Mighty Draw. However, for your
convenience, “Appendix A” contains some additional information about
the Mighty Draw desktop. If you need more help, please study your
computer’s Owner’s Guide, which provides in-depth information about
standard Macintosh features.

Before continuing, make a backup of your original Mighty Draw disk and
use the backup as your working copy.  Should your working copy become
damaged, you can make another one from your original disk. Mighty Draw
requires version 6.0.3 or later of the Macintosh system software, and is
system 7 compatible.

What’s On Your Mighty Draw Disk

Your Mighty Draw disk contains the following:

Mighty Draw application the Mighty Draw program
Sample Drawings compressed sample drawings
Symbol Libraries compressed symbol libraries

Note: There also may (or may not) be a Read Me file. If present, double-
click and read it for information to new to make it into the manual.

Hard Disk Installation

To install Mighty Draw onto your hard disk:

1. Insert your working Mighty Draw disk into your drive.
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Chapter 1, Getting Started

2. Drag the Mighty Draw disk icon onto your hard disk.

3. Double-click the newly created Mighty Draw folder.

4. Double-click the Symbols file, then click Extract to de-archive the
compressed symbol library files into a Symbol Libraries folder.

5. Double-click the Samples file, then click Extract to de-archive the
compressed sample files into a Sample Drawings folder.

6. If desired, drag the two original files, Symbols and Samples, into the
trash can to free up the hard disk space they use.

Floppy Disk Installation

You can start Mighty Draw directly from your working disk by double-
clicking its icon. However, to access the symbol libraries and sample
drawings, you must first de-archive them. Prepare two formatted blank
disks to hold all the files, then work through the following steps.

1. Insert your working Mighty Draw disk into your drive and double-
click the Symbols file icon.

2. Change to the destination disk. If you have two drives, insert one of the
blank disks into the second drive and click the Drive button if necessary to
change to the second drive. If you have one drive, click Eject and insert a
blank disk (be prepared to do a fair amount of disk swapping in this case).

3. Click the Extract button to de-archive the files.

4. Follow the same procedure to de-archive the Samples archive. How-
ever, in this case if you have only one drive, you can copy/drag the
Samples archive to the second blank disk first so you won't have to perform
the disk swapping. Both the archive and de-archived files will fit on one
disk.

Starting Mighty Draw

Double-click the Mighty Draw application icon, or for detailed start-up
instructions, work through the following.



To start Mighty Draw:

1. Find and double-click the Mighty Draw Folder (or the disk icon, if
starting from a floppy disk).

2. Double-click the Mighty Draw application icon to start the program.

Useful Tip: Drawings you save to disk appear with a document icon when
viewed from the Finder desktop. You can double-click a document icon to
start Mighty Draw and have the drawing load automatically. Here’s a
sample document icon:

If needed, “Appendix A” provides an overview of Macintosh windows and
the Mighty Draw desktop.
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Chapter 2

  Mighty Draw Tutorial

It’s best to read this chapter from start to end since later sections build on
information introduced earlier. We recommend actually performing the
described operations.

Sample Drawings

Included sample drawings provide a quick introduction to Mighty Draw.
However, don’t limit yourself to what you see in the samples. You are
limited only by your imagination. Mighty Draw has the capability to create
much more than is demonstrated with the provided samples.

Viewing The Sample Drawings

To view a sample drawing (or any drawing you’ve saved to disk) at its
normal size, you need to open it first (Browse under the File menu lets you
view scaled down versions of drawings without opening them).

To open and view a sample drawing:

1. Repeatedly select Close from the File Menu to remove all Mighty Draw
windows. Closing unneeded windows conserves memory and reduces
desktop clutter. You can also close a window by clicking its close box.

2. Select Open from the File Menu and double-click the Sample Draw-
ings folder.

3. Double-click the name of a sample drawing. The first in the list will do
to start with.
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4. Look the sample over. Use the window’s scroll bars as needed to move
around and view all of the sample drawing.

5. Close the sample’s window and Open other samples. Repeat this
process as desired or until you’ve seen all the sample drawings.

Creating A Greeting Card

One of many ways you might use Mighty Draw is to create birthday cards,
Christmas cards, Valentine’s cards, or other types of greeting cards. You’ll
find some greeting card samples inside the Sample Drawings folder, which
you can use as is, or for ideas.

You’ll also find ready-made frames inside the Sample Drawings folder. To
use one, simply open a frame file, select a frame, Copy and Paste it into an
empty window, position it as desired, type a message inside it, and print
(read further for positioning ideas).
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Or, you can construct frames from ready-made borders by selecting
Borders under the Symbols menu. A borders symbol library also contains
some additional styles, accessed from the Library menu item (see the
“Menus” chapter).

Following is only one example of how you can construct a birthday card
using the ready-made borders. Many other card variations are possible -
use your imagination! Of course, you can also create your own borders
using the drawing tools.

Before starting, you’ll need an empty drawing window. If one isn’t open,
repeatedly select Close under the file menu to remove all Mighty Draw
windows, then select New, also under the File menu.

Construct a border for the inside of the card. Press the command key and
the number 2 at the same time to bring up the dialog of borders. Click the
border in the upper right-hand corner of the dialog, then click OK.

Drag the border to the upper left-hand corner of the screen. Position the
selector over the border, press and hold the mouse button, drag the border
to the new position and release the button.
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Complete the top half of the border. Choose Duplicate from the Edit menu,
then choose Flip Horizontal from the Arrange menu. Position the duplicate
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next to the first border as shown. Use the arrow keys to fine-tune the
position as needed.

           

Complete the border by duplicating the top half. Position the selector over
the left-hand border, hold down the Shift key, and click to select it. Choose
Duplicate from the Edit menu, then choose Flip Vertical from the Arrange
menu.
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 Position the bottom half of the border as shown.
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Group the four pieces together. Drag a selection box around all four border
pieces as shown, then choose Group from the Arrange menu.

Duplicate the border for the outside of the card. Choose Duplicate from the
Edit menu, then position the duplicate in the lower right corner of the
drawing area as shown.

Add text to the card. Click the Text tool, click on a blank area of the screen,
then type the text you want.

 Click the selector tool and position the text as shown.

16

Chapter 2, Mighty Draw Tutorial



After printing out the card, fold it as follows: Fold the top half away from
you, then fold the left side away from you.

There are a few options for adding text to the inside of the card. You can
handwrite a message, of course, but you can also use a paint program to
type text, flip it upside down, then paste it into Mighty Draw using Paste
As Pict under the Edit menu. Or you can flip the page upside down after
printing the first time, then run the page through again, this time printing a
drawing with text only in the lower right-hand corner. Shown here is an
example of text pasted using Paste As Pict.
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Using Patterns

Mighty Draw provides a palette  of patterns along the top of the drawing
window.

You can use the patterns for both filling object interiors, or for drawing
lines and object borders. The pattern used for object borders, and for
drawing lines, is referred to as the line, or pen, pattern.

The not-equal symbol at the top left corner of the palette (see the preceding
illustration) tells Mighty Draw not to use any pattern. Using it as a line
pattern lets you create objects that have no borders. Using it as a fill pattern
creates objects with transparent interiors. Here are some examples of
objects drawn with various pattern combinations:

Notice in the preceding illustration that the textured circle in the back-
ground has no border. The not-equal symbol was used as its line pattern.
Similarly, you can see through both the arc and the box that's in front of the
circle. The not-equal symbol was used as the fill pattern in this case. Also
demonstrated is the use of line patterns to draw dotted and dashed lines.
Here are some patterns you may find useful for that purpose:

The two reference boxes at the left end of the pattern palette show the
current working  line thickness, working line pattern, and working fill
pattern.

The triangle indicator between the two boxes shows which type of pattern
is affected by clicks on patterns in the palette, the line pattern or the fill
pattern. Click a pattern when the indicator points toward the right, and the
working fill pattern is changed, as well as any selected objects’ fill patterns.
Similarly, if the indicator points toward the left, the working line pattern,
and any selected objects’ line patterns are changed. To change the direction
of the indicator, click the desired reference box. You’ll see step-by-step how
to use these shortly.

The line-pattern reference box also shows what the current line thickness is.
You set the line thickness by choosing a size from the Line menu, or by
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pressing a number (1-8) on the keyboard. Here’s how the reference boxes
look when the line width is changed to 3 dots thick and a textured fill
pattern is clicked:

And here’s some examples drawn with the preceding settings:

As the illustration demonstrates, when you draw with the tools, the final
object you create takes on the working line thickness, line pattern, and fill
pattern that’s shown in the two reference boxes. The exception is text. Text
doesn’t draw using patterns but you can specify its color.

Changing Objects’ Patterns

To change fill patterns:

1. Click the selector tool, then click the fill-pattern reference box.

2. Select an object. You can change more than one object at once by shift-
clicking additional objects, or by dragging a selection box around them (see
“Selecting Objects”). We’ll change the fill patterns of the following objects:

The handles (small squares) indicate that both objects are selected.

3. Click a fill pattern. Try clicking various patterns until you find one you
like. Here’s how the preceding examples look when an arbitrary textured
pattern is clicked:
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Notice that all selected objects take on the clicked pattern.

To change line patterns:

1. Activate the selector tool and click the line-pattern box.

2. Select an object. You can change more than one object by shift-clicking
additional objects, or by dragging a selection box around them. We'll work
with the same objects used earlier:

3. Click a line pattern. Try clicking various patterns until you find one you
like.

To remove an object’s border, click the not-equal symbol that’s at the top
left corner of the pattern palette.

Changing Grouped Objects’ Patterns

Please see “Group” in the “Menus” chapter for information about grouped
objects.

Once an object is grouped, Mighty Draw treats all its component objects as
a single object unit. This means, if you select a grouped object and click a
pattern, all components of the grouped object take on the pattern. At times,
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you may only want to change an individual component object and not all
objects within the group.

To do so, you must first temporarily ungroup the object. To do so, select the
grouped object then choose Ungroup from the Arrange menu. Click a blank
area to unselect all objects. Select the component object that you want to
change and follow the same procedures described earlier. When done,
select the component objects and choose Group from the Arrange menu.

Using Colors

The Color menu lets you choose
foreground and background colors
for fill patterns and line, or pen,
patterns. Note that the terms pen
pattern  and line pattern  refer to the
same thing, the pattern that’s used to
draw lines or object’s borders.

The Fill Foreground and Fill Background menu items set colors for objects’
interior fill patterns. The Pen Foreground and Pen Background items set
colors for line patterns and object border patterns. The currently selected
color has a check mark beside it.

When Mighty Draw draws colored objects, what would normally have
been black draws using the foreground colors, and what would have been
white draws using the background colors. The following steps illustrate
this more clearly.

Changing Objects’ Colors

To change the color of an existing object:

1. Activate the selector tool.

2. Select an object (or objects). We’ll use the following object:
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3. Set the object’s colors. Use the Color menu items and choose the desired
colors according to the following illustration, which is an enlargement of
the preceding illustration’s top left corner.

By experimenting with various textured patterns and different foreground
and background color combinations, you can create a wide variety of color
blends. As an experiment, try setting the fill foreground and background
colors for an existing object as shown in the preceding steps, then click
various fill patterns and watch the effect the different patterns have on the
object’s color.

Note for black and white users: If you select Display In Color from the
Color menu and your computer only displays black and white, any color
other than white in your drawings displays as black. For this reason, you’ll
probably want to display in black and white so you can see pattern
textures. However, to do a color printout, you need to display in color first.
Also, since you can’t see object colors in black and white, you can select an
object using the selector tool, then choose Object Color from the Color
menu to determine its color. You’ll need to temporarily ungroup grouped
objects to check the color of individual objects within the groups.

Moving Objects

The selector tool lets you move objects to new locations.

To move an object: Move onto it and hold down the mouse button. Drag
the dotted outline to a new location and release the button.
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To move several objects at once: Select all the objects you want to move
(see “Selecting Objects”). Move directly over any one of them, hold down
the mouse button, then drag the resulting outlines to a new location and
release the button.

Resizing Objects

First, click the selector tool.

To resize an object: Move onto the object you want to resize and click to
select it. Move onto one of its handles and hold down the mouse button.
Drag the object’s outline (or enclosing box) inward or outward to a new
size.

Resize in other directions by dragging with a different handle.

Erasing Objects

First, click the selector tool.

To delete: Select the object (or objects, see “Selecting Objects”) that you
want to remove and press the delete key, or choose Clear from the Edit
menu.

You can also choose Cut from the Edit menu to remove selected objects and
place them into the clipboard, then paste them back into the same window,
or another window.  See “Edit Menu” for more about cutting and pasting.
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To reverse an accidental delete: Immediately select Undo from the Edit
menu. If you click elsewhere, or perform other operations, Undo may be
unavailable since it works only for the last operation performed.

Erasing Parts Of Objects

Mighty Draw is an object-oriented program. Unlike a painting program,
each thing you draw, whether a line, circle, or whatever, is a separate object
based on coordinate locations. This is an ideal environment for drawing
programs, which must easily size and move objects. But since everything is
based on coordinates, it isn’t possible to erase a portion of a single object
like a rectangle (by rubbing away or cutting out a piece like in a paint
program).

However, you can often simulate a partial erase by drawing on top of the
unwanted part of an object with another white object. Or at other times,
maybe you only need to resize an object. For example, if a line is too long,
rather than erase the part that’s too long, you can grab its handle and size it
down (see the previous section).

To erase part of an object with a white object: First, click white for both
the fill pattern and the line pattern (see “Using Patterns”). Click the desired
tool and draw a white object over the part of the object that you want to
erase.

In the preceding illustration, portions of the original circle and line were
erased by drawing over them with a white oval, box, and line.

Editing Existing Text

Use the text tool to create text, or to edit existing text objects.

To edit an existing text object:

1. Activate the text tool.
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2. Click a text object. Move the I-Beam  cursor onto a text object and click to
reactivate the text for editing (see the following illustration). A blinking bar
cursor, the insert  cursor, appears in the text at the position where you
clicked.

3. Edit the text. Use the arrow keys to move the blinking insert cursor
within the text. Press the delete key to delete text, or from the keyboard,
type any additional text you may want. In the preceding example, we used
the right arrow to move to the end of “Bear”, then pressed the delete key to
end up with the following:

 4. Click another tool or new location. Click another tool to stop editing
text and use the clicked tool, or click another location to start typing new
text.

To change existing text’s font, size, or style:

1. Click the selector tool.

2. Click a text object.  Handles should appear at its corners.

3. Select the desired Text menu item(s). Choose a new font, size, or style
from the Text menu. While the text is selected, continue choosing additional
menu items as desired. We changed the previous example’s font from
Geneva to Times, and set its style to Shadow, which resulted in this:

See the “Tool Palette” and “Menus” chapters for more.
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Chapter 3

  Tool Palette

The tool palette, which contains icons for the selector tool, various drawing
tools, and a text tool, is located along the left side of the drawing window.

To select a tool for use, move onto it and click. The currently selected tool is
highlighted, which indicates it’s activated for use.

 Selector Tool

Many of Mighty Draw’s features let you manipulate existing objects. For
example, you can copy objects, resize them, move them, rotate them, and
much more. But for these features to work, they need to know which object,
or objects, you want to change. That’s where the selector tool comes in. You
use the selector tool to let other features know which objects you want to
change by selecting the objects.

The features that do the actual manipulations are described in their
respective sections of this manual (the Table Of Contents shows where).
This section focuses on the various ways you can use the selector tool to
select objects.
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Selecting Objects

First, you need to click the selector tool to activate it for use.

Handles. Small squares, called handles, indicate an object is selected.  Here
are some examples of selected objects:

Before showing you how to select objects, you need to know the difference
between filled and unfilled objects. An object which has a white interior is
still considered a filled object if the white pattern was used as its fill pattern.
An unfilled object is one that was created using the not-equal symbol as its
fill pattern (for more about patterns, see “Using Patterns” in the tutorial
chapter).

Unfilled objects have no interior fill pattern at all, which means you can see
through them. Here are some examples of both filled and unfilled objects:

Notice that the circle on the left is beneath an unfilled arc and an unfilled
rectangle. You can see the circle through the interior of the arc and rect-
angle. The circle on the right has a white fill pattern so you can’t see the
rounded box through its interior.

To select a filled object: Move onto a visible part of the object and click.

To select an unfilled object: Click its visible borders. For example, to select
the unfilled arc and the unfilled rectangle shown in the earlier illustration,
move onto their borders and click. If you clicked inside the rectangle on top
of the circle, you would select the circle rather than the rectangle.

To select small objects, thin lines, or closely-spaced objects: These objects
are sometimes slightly more difficult to select. It helps to remember that the
tip of the arrow pointer is the active part of the arrow that’s used for
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selecting. So when selecting small or closely-spaced objects, carefully place
the tip of the arrow exactly on the object and click. If handles appear on an
object other than the one you want, click an empty, blank area inside the
drawing to unselect all objects, then try again. Sometimes, you may find it
easier to select small objects by dragging the selection box onto them. How
to use the selection box is described shortly.

To unselect objects: Click any blank screen area inside the drawing
window to unselect all objects, or click an unselected object to select it and
unselect all others.

Selecting Multiple Objects

At times, you may want to select more than one object at a time. Mighty
Draw lets you accomplish this a couple of ways.

To select by shift-clicking: Hold down the shift key and click additional
objects to make multiple selections, or to unselect a single object and leave
any remaining objects selected.

To select an additional object:

To unselect an object:

To select by dragging the selection box: Move to the top left corner of the
objects to be selected. Hold down the mouse button and drag the dotted
selection box to the lower right corner of the objects. Release the button.
Any object within any part of the box is selected.

Note: Though the illustration completely encloses the objects to be selected,
in fact, all objects the box overlaps are selected, even if they are not com-
pletely enclosed within the box.
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To select all objects at once: Choose Select All from the Edit menu. You
might want to do this to adjust the position of (move) the entire drawing
within the drawing window (see “Moving Objects”).

About Selected Objects

Features that operate on selected objects affect all the objects that are
selected. For example, if two objects are selected and you click a pattern,
both objects take on the pattern.

In general, items from the Edit, Arrange, Text, and Color menus operate on
selected objects. In fact, most of these items remain dim and unusable until
one or more objects have been selected.

 Line Tools
The line and constrained line tool draw lines between two points. First,
click the line tool icon that you want to use.

To draw a line: Move to the start point of the line and hold down the
mouse button. Drag the line to the desired end point, then release the
button.

See “Using Patterns” in the tutorial chapter for how to set the pattern used
for drawing lines and objects’ borders.

Setting Line Thicknesses

The line thickness (or width) setting not only applies to the width that’s
used for lines, but also to the width used for other objects’ borders. For
example, here’s what you get if you draw some objects with the line
thickness set to 3 dots wide:

You can set the line width quickly by pressing a number (1-8) on the
keyboard, or by choosing a new size from the Line menu.
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A check mark appears beside the selected menu item. The working line
thickness is also shown in the line-pattern reference box.

Changing existing objects’ line widths. To change an existing object’s line
or border width, click the selector tool then select an object. Choose a width
from the Line menu or press 1-8 on the keyboard.

Using Dimension And Arrow Lines

You can also draw lines with an arrow at either end, on both ends, or auto-
dimensioning lines which have two arrows and the length of the line placed
at its center. A line width of one is always used for lines that have arrows.

To draw an arrow line: Select the type of arrow line you want from the
Line menu (you can also press 9 to select a dimension line). Click the line
tool. Move to the line’s start position and hold the mouse button down.
Drag to the desired size then release the button.

 About Constrained Lines

The constrained line tool lets you draw lines at perfect 45 or 90 degree
angles. You can also constrain other lines by holding down the shift key
before you begin a line. Here are some sample constrained lines:
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 Box, Rounded Box, And Oval Tools
As their names imply, these tools draw boxes (squares and rectangles),
boxes with round corners, and ovals (or circles). First, click the tool icon
that you want to use.

To draw using any of these tools: Place the pointer where you want one
edge of the object to begin and hold down the mouse button. Drag the
object to the size, then release the button.

Constraining Boxes And Ovals. You can hold down the shift key before
you begin drawing to constrain sizes to equal widths and heights as you
drag the objects to size. This lets you easily draw perfect circles and
squares.

Please refer to “Using Patterns” and “Setting Line Thicknesses” for infor-
mation about changing patterns and border thicknesses.

 Arc Tool
You can use the arc tool to draw arcs that are filled with patterns, or arcs
that are unfilled consisting only of the arc lines. First, move onto the arc tool
icon and click.

To draw arcs: Move to the desired position and hold down the mouse
button. Drag downward if you want the arc to represent the upper part of a
circle or oval, and drag upward for the bottom part of a circle or oval (see
the following illustration). Release the button.

Constraining Arcs. You can hold down the shift key before you begin
drawing to constrain arc sizes to equal widths and heights as you drag the
arc to size. This lets you easily draw 90 degree arcs. The arcs in the preced-
ing illustration were constrained by holding the shift key.

Please refer to “Using Patterns” and “Setting Line Thicknesses” for how to
set arc fill patterns and border thicknesses.
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 Polygon Tool
The polygon tool lets you draw a series of connected lines to create a
multiple-sided object. Many components of the predrawn object symbols
were drawn using the polygon tool. Here are some polygon examples:

To use the polygon tool, first click its tool icon.

To draw a polygon: Move to a vertex start point and click. Move to the first
line’s end point (and next line’s start) and click again. Continue this
sequence until you’ve completed the object by ending at your original start
point, or double-click to end.

 Sketch Tool
You can use the sketch tool when you need to create irregularly-shaped
objects. Here are some sketched examples:

First, click the sketch tool icon to activate it for use.

To sketch a region: Move the pointer to the start position, hold down the
mouse button and move the mouse. Release the button to stop drawing.

About The Sketch Tool

Though you may need to use the sketch tool from time to time, it's best to
use the polygon tool if you can accomplish the same thing with it. Objects
drawn with the sketch tool tend to have many more points for Mighty
Draw to remember and redraw. The polygon tool lets you create faster-
drawing, more efficient objects.

Often, you can trace over a sketched area with the polygon tool and achieve
a much faster-drawing object with no notable difference in appearance.

 Text Tool
You can use the text tool to add names or other text labels to your draw-
ings, or to edit existing text. First, click the text tool to activate it for use.
Now when you move into the drawing area, an I-Beam pointer appears.
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To add text to a drawing: Move the I-Beam pointer to the spot where you
want to begin typing and click. You’ll see a flashing cursor appear. Go to
the keyboard and type your text. Letters you type appear at the flashing
cursor’s location. Press the delete key if you make a mistake or press return
to end a line of text and start a new line below the previous line. When you
have finished typing, simply select a different tool. The text you typed is
converted into a single text object.

To type at a different location: If you want to continue typing but at a
different location, move the mouse to select the new location and click. The
last text you typed is kept as an object and you can begin typing a new text
object as before.

To edit existing text: You can reactivate an existing text object for further
typing or editing by moving onto it and clicking. Please see “Editing
Existing Text” in the tutorial chapter for more detailed instructions.

To edit using the mouse: Move onto the text, hold down the mouse button
and drag to highlight the desired text, then release the button. Press the
delete key or select Cut, Copy, or Paste from the Edit menu. Pasted text is
inserted where the blinking cursor is located (or it replaces any currently
highlighted text).

Manipulating Selected Text Objects

You can use the selector tool to select an existing text object, then use items
from the Text and Edit menus to operate on it. Please see “Editing Existing
Text” in the tutorial chapter for additional information.
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Chapter 4

  Menus

As with virtually all Macintosh applications, you access many of Mighty
Draw’s features through the menu it displays along the top of the screen.
This chapter describes these features.

Using Menus

If you are completely familiar with using Macintosh menus, you can skip
this section and move on to sections containing Mighty Draw specific
information. Instructions for using the pull-down menus follow.

To list a menu: Move onto its title and hold down the mouse button. A list
of menu items displays.

To select a menu item: Continue to hold down the mouse button, then
move the mouse downward. Menu items highlight as the pointer passes
over them. Release the mouse button to select the highlighted menu item.

Menu items that you cannot currently select are dim and will not highlight.
You may need to select an object or perform some other operation before
you can use a dim item.

Submenus

A few menu items, such as Size under the text
menu, have additional options (or submenus) to
choose from. Menu items which themselves
contain a submenu have a triangular indicator
beside them.

To select submenu items: Move the mouse toward the right and down the
list of choices to highlight the desired item, then release the mouse button.
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Menu Command Keys

You can access many frequently-used menu items using
the keyboard. These items are indicated with a com-
mand key symbol and a keyboard character. Here are
some examples:

To make a menu selection from the keyboard, hold
down the command key and press the appropriate
keyboard character. In the above illustration, to choose
Undo, hold down the command key and press the letter
“Z”.

Note: A few keys are treated special by Mighty Draw. To provide even
easier menu access, they also select menu items without the command key
held down. For example, to rotate a selected object left, you can press “<“
without using the command key. You can find a complete listing of
command keys in “Appendix B”.

Apple Menu

About

This shows information about Mighty Draw
such as the copyright date, the company that
published it, and the programmer’s name.

Status

Select Status for information about the system and your active drawing,
such as its page size and the amount of free memory that’s left.

Desk Accessories

Desk accessories are usually short programs under the Apple menu that do
some specific task (like a clock, calculator, or puzzle).
Please refer to your Owner’s Guide  for more about
desk accessories.

File Menu

New

Select New to open a new, untitled drawing window.
Up to 5 may be open at once.
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Open

Use open to bring in an existing drawing from disk. Mighty Draw loads the
drawing into your computer’s memory, opens a window for it, then
displays the drawing.

To open an existing drawing from disk:

1. Select Open from the File menu. A file dialog displays.

Double-click folder names to open them and list their contents. Click the
folder box above the filenames, or the disk icon above the buttons, to move
between folders. Click the Drive (or Desktop) button to catalog and open a
file from a different volume (or drive).

2. Double-click the name of the file you want to open. Double-click the
file’s name or click the name once and click Open.

Note: Mighty Draw tries to open any PICT file type. Importing non-Mighty
Draw files may result in the loss of information that Mighty Draw can’t use.
For example, Mighty Draw is object-oriented so bitmap data is ignored
(data from paint programs or scanned images). To import bitmap graphics,
do it through the clipboard using Paste As PICT under the Edit menu.

Close

Select Close, or click the close box, when you are finished with a drawing
and want to remove its window from the desktop.

Save

Choose Save to save a drawing to disk. If the window is untitled, a dialog
appears so you can name it. Type a unique name for your drawing then
click Save.
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If the drawing already has a name, you are not prompted for a new name.
The current name is used and the save is performed immediately. This lets
you quickly save an updated version of your drawing. To save even more
quickly, hold down the command key and press “S”.

Warning: Save replaces any previous version of your drawing with your
current version. To keep a previous version, use Save As to give your
current version a different name.

Use Save frequently so you’ll always have a recent version of your drawing
on disk. This provides added protection in case a power failure occurs or
your computer quits working for any reason. If you update your disk
version often, you’ll lose only a few recent changes and not your entire
drawing or hours of work.

Save As

Use Save As to save an untitled drawing, to save a drawing under a
different name, or to save to a different disk. After the save, the name above
the drawing window changes to the new name.

To save a drawing:

1. Select Save As from the File menu. A file dialog displays.

To save inside a folder, double-click its name to open it. Click the folder box
above the filenames, or the disk icon above the buttons, to move between
folders. Click the Drive (or Desktop) button to save to a different drive or
volume (or disk).

2. Type a name for your drawing. Type a name in the box located below
“Save document as:”.

3. Click Save. This saves the drawing into the current folder.
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Once your drawing is saved, you can use Open from the File menu to
retrieve it at a later time.

Backup your work. If you’ve made many changes, use Save As to save an
additional backup copy of your work to a floppy disk. If your original disk
or file becomes damaged, you can restore it from the backup copy. For
important work, it's also a good idea to keep one additional copy of the
previous session’s work and don’t touch it during the current work session.
If for some reason, your current copy and the backup become damaged,
you’ll have the previous session’s work to fall back on. For example, if a
system failure causes your original file to save incorrectly, the same
problem will most likely cause any backup to save incorrectly. Your only
salvation may be an additional copy of your previous session’s work.

Revert

Select Revert from the File menu if you’ve made changes since last saving
your work, then decide that you don’t want to keep the changes. This
replaces your current work with the last version saved. Revert remains
unselectable until you make changes to a drawing after using Open, Save,
or Save As.

Browse

You can use Browse to look at the drawings saved on a disk.

To Browse a folder:

1. Select Browse from the File menu. A file dialog displays.

2. Double-click the file you want to see. A browse dialog appears showing
the selected drawing.
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3. View the drawing then click the desired button. Click Previous or Next
to view additional drawings from the cataloged list, or click Stop.

Page Setup

Choose Page Setup to set the paper size and other printing options. This is
optional. Standard settings are used if you don’t change them.

After choosing Page Setup, the dialog you’ll see varies depending on the
printer you have. If you aren’t using an Apple printer, the driver supplied
with your printer displays the dialog and controls its content. For the
ImageWriter, the Page Setup dialog looks similar to this:

A brief description of some common options for the page setup dialog
follows. Refer to your Owner’s Guide for more information about Page Setup
and printing documents.

US Letter. This is the default paper setting. Use it for normal printing to the
ImageWriter on paper that’s 8-1/2 by 11 inches.

US Legal. Use this option for paper that’s 8-1/2 by 14 inches.

Computer Paper. This is for wide-carriage computer paper.

A4 Letter. This option is for European standard paper. Its size is 8-1/4 by
11-2/3 inches (210 by 296 mm).

International Fanfold. For the ImageWriter only, this is the international
standard size of 8-1/4 by 12 inches (210 by 305 mm).

B5 Letter. This option is for the Laserwriter only. Its paper size is 15 by 11
inches (381 by 279 mm).

Tall Adjusted. This prints drawings with the same proportions they have
on the screen. Use it to print drawings with correct scaling.

50% Reduction. Drawings are printed at half their normal width and
height.

No Gaps Between Pages. Printing is continuous without page breaks when
this option is selected.
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Portrait Orientation. This refers to the left orientation icon. It lets you print
drawings with the same upright orientation they have on the screen.

Landscape Orientation. Select this to print sideways (turned right 90
degrees).

Reduce or Enlarge. When using a Laserwriter, you can type a number from
25 to 200 to reduce or enlarge your printout. A value of 100 is normal size
(100% of image), 200 enlarges a drawing to twice its size (100% X 2 = 200%),
and 50 reduces a drawing to half its normal size (100% / 2 = 50%).

Printer Effects. These Laserwriter options are for bit mapped fonts.

Print

Select Print to set the number of copies you want, the page range, and to
print the drawing in the front-most window.

If you have problems printing, you may need to install printer resources or
use the Chooser desk accessory (under the Apple menu) to specify the type
of printer you have and how it is connected to your computer. Please refer
to your Owner’s Guide  if you need help installing printer resources, using
the Chooser, and for additional printing information.

As with Page Setup, the dialog you’ll see varies depending on the printer
setup you have. If you aren’t using an Apple printer, the driver supplied
with your printer displays the dialog and controls its content. This is the
dialog you’ll most likely see for the ImageWriter:

Best. This increases the printer resolution producing the best quality text
and lines. Use it when the quality of lines, patterns, and text is more
important than getting the fastest possible printout.

Fast. Drawings print faster than when using Best but the printer resolution
is lower so lines are more coarse and text may not look as nice.

Draft. Don’t use this option. It's used for dumping text straight to the
printer, not for printing object-oriented drawings.

Page Range. This sets the range of pages you want to print for multiple-
page drawings. Normally, you’ll print an entire drawing, however, you
have the option of specifying which pages to print. The pages print in
vertical columns numbered as illustrated here:
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4 page drawing 2 x 3 page drawing
1 3 1 4
2 4 2 5

3 6

Copies. Type the number of copies you want to print.

Automatic. Used for continuous paper. The computer advances the
printer’s paper and continues to print if you are printing multiple copies.

Hand Feed. If printing multiple copies, you are prompted before each copy,
and can continue to print or stop.

To Start Printing

After setting the printing options, click the OK button to start printing.
Remember to make sure your printer is on and ready for printing. You can
hold down the command key and press “.” to stop printing.

Quit

Select Quit when you are completely finished using Mighty Draw. You are
reminded to save any newly created or changed drawings.

Edit Menu

Most choices under the Edit menu work with objects
you select with the selector tool, or text you select with
the text tool. These items are dim and unavailable until
you select one or more objects, or text. See “Selecting
Objects” if you need help.

Undo

Choose Undo to reverse the last change made to a
drawing. In most instances you can select it again and
reverse the undo (restore the last change you made). Use Undo right away
if you make a mistake. It may be dim and unavailable if you click in a
window or perform some other operation first.

Cut

Cut lets you remove selected objects from your drawing and place them
into the clipboard.

To Cut objects:

1. Click the selector tool.
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2. Click an object and choose Cut. Select the desired objects, then choose
Cut from the Edit menu. You can also hold the command key and press the
letter “X”.

Copy

Copy lets you place a copy of selected objects in the clipboard without
removing them from your drawing.

To Copy objects:

1. Click the selector tool.

2. Click an object and choose Copy. Select the desired objects, then choose
Copy from the Edit menu. You can also hold the command key and press
the letter “C”.

Choose Show Clipboard from the Edit menu to view the clipboard’s
contents. Use Paste to insert the clipboard’s contents into a drawing.

Paste

Paste lets you copy the clipboard’s contents into a drawing. Choose Show
Clipboard to view the clipboard’s contents.

To Paste: If the window that you want to paste into is not currently the
front-most window, click any part of it to bring it to the front. Select Paste
from the Edit menu (or hold the command key and press the letter “V”).
The selector tool is activated so you can easily move the pasted objects to
the desired position.

To Copy and Paste between windows: Bring the window you want to
copy objects from to the front. Select the objects with the selector tool, then
choose Copy. Next, bring the destination window to the front and select
Paste.
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Paste As PICT

Mighty Draw is an object oriented drawing program, so it does not fully
support bitmap image editing (from paint programs, scanners, etc.).
However, it does support importing virtually any type of image, including
bitmaps, as PICT objects.

Use Paste As PICT to paste the clipboard’s contents, whether bitmap
images, or other objects, into a drawing and have them treated as a single
PICT object. A PICT object may be moved, resized, duplicated, and deleted
using the selector tool, but is otherwise unchangeable.

Note: Mighty Draw also supports icon images, small bitmap images which
are editable. Please see “Create Icon” later in this chapter.

Clear

Clear lets you remove unwanted objects from a drawing. The objects are
not placed in the clipboard. Use Cut to remove objects and place them in
the clipboard for pasting.

To Clear objects:

1. Click the selector tool.

2. Click an object and choose Clear. Select the desired objects, then choose
Clear or press the delete key.

You can immediately choose Undo to restore the deleted objects.

Duplicate

You can perform the equivalent of a Copy and Paste in one operation by
selecting Duplicate.

To Duplicate objects:

1. Click the selector tool.

2. Click an object and choose Duplicate. Select the desired objects, then
choose Duplicate. You can also hold the command key and press the letter
“D”.
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A duplicate copy of the selected objects is placed into the clipboard then
pasted back into your drawing. Since a copy is in the clipboard, you can
continue to paste additional copies using Paste.

Select All

When the selector tool is active, choose Select All or hold down the com-
mand key and press the letter “A” to quickly select every object in a
drawing. You might want to do this to change the border color, working
color, or line width for all the objects, or to move them all.

Info

Info lets you obtain information
about a selected object. The type of
information varies depending on
the kind of object it is. This illustra-
tion shows information for a
selected text object.

To find an object’s Info:

1. Click the selector tool.

2. Click an object and choose Info. Or, hold down the command key and
press the letter “I”.

Show Clipboard

Choose Show Clipboard to view the contents of the clipboard. Select Paste
to insert the clipboard’s contents into a drawing. Use Cut, Copy, or Dupli-
cate to put objects into the clipboard. Please see their respective sections for
more information.
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Arrange Menu

Bring To Front, Send To Back

These menu items let you arrange the stacking order
of selected objects. Use Bring To Front to move an
object in front of other objects, or use Send To Back
to place it behind (beneath) other objects.

To bring an object to the front:

1. Click the selector tool.

2. Select an object and choose Bring To Front. Or, hold the command key
and press the letter “F”.

Follow the same procedure to send an object to the back, choosing Send To
Back (command - “B”) instead.

Rotate Left, Rotate Right

Use these menu items to rotate selected objects left or right 90 degrees.

To rotate an object left:

1. Click the selector tool:

2. Select an object and choose Rotate Left. Or, press the “<“ keyboard
character without using the command or shift key.

Follow the same procedure to rotate an object to the right, choosing Rotate
Right (or pressing “>”) instead.
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Flip Left-Right, Flip Up-Down

Choose these menu items to flip the orientation of selected objects from left
to right, or top to bottom.

To flip an object left to right:

1. Click the selector tool:

2. Select an object and choose Flip Left-Right. Or, press “”” (quote)
without using the command or shift key.

Follow the same procedure to flip an object vertically, choosing Flip Up-
Down instead (or press “:” without using the command or shift key).

Group, Ungroup

Group converts a collection of objects selected with the selector tool into a
single grouped unit. Once grouped, the objects are treated as a single object
until they are ungrouped. For example, if you select a grouped object then
select a pattern, all the individual objects within the group take on the
pattern.

To group objects:

1. Click the selector tool.

2. Select the objects you want to group, then choose Group. Or, hold the
command key and press the letter “G”.

Use Ungroup (command - “U”) to separate grouped objects into their
individual component objects again.



47

Chapter 4, Menus

Lock, Unlock

You can use Lock to keep objects from being moved, grouped, deleted, or
otherwise changed.

To lock an object:

1. Click the selector tool.

2. Select an object and choose Lock. Or, hold down the command key and
press the letter “L”.

Notice the locked object has a small key-like symbol above its top left
handle indicating it is locked. Use Unlock (command - “J”) to make locked
objects changeable again.

Text Menu

Font, Size, Style

As their names imply, the Font, Size, and
Style menu items let you pick a font, its size,
and style. Your choices are used the next
time you type with the text tool.

If a text object is selected, or you are
currently typing text with the text tool, it
also changes to the chosen font, size, or style. This lets you easily experi-
ment and change existing text. See “Editing Existing Text” for more
detailed information.

Font. You use the Font/DA program that came with your computer to
install fonts into your system. Please refer to your Owner’s Guide  for how
(System 7 and later users: the installation is different for you - follow the
instructions in your Owner’s Guide  as well). Here’s a sample of the Font
submenu:
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Size. When you look at the size choices for a given font, you’ll notice that
one or more of the sizes are shown with outlined numbers.

Outlined numbers indicate the sizes for which a real font actually exists. A
font looks best at the outlined sizes. When you choose a size that isn’t
outlined, the font is scaled to the size (TrueType fonts look good at all
sizes).

Other. Choose Other from the Size submenu to specify a font size that isn’t
provided by the menu’s size choices.

Style. A font’s style refers to the way it looks. Style choices include plain,
bold, italic, underline, outline, and shadow. Here’s how they look:

Except for plain, which cancels all other styles, the styles are accumulative.
For example, it’s okay to use bold and outline at the same time.
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Left, Center, Right

Use these menu items to specify how you want selected text, or text you
type, to be aligned.

The chosen alignment is used by the text tool the next time you type text. If
you have a text object selected, or are typing text, it also takes on the new
alignment.

Single Space, 1-1/2 Space, Double Space

These choices let you set the spacing between lines of text. Single spacing is
normal.

The chosen spacing is used by the text tool the next time you type text and
press the return key. Any existing text objects selected with the selector tool
change to the new spacing also. See “Editing Existing Text” for more
related information.

Line Menu

Set line and object border widths by choosing the size you
want under the Line menu. The current working size has a
check mark beside it and is shown for reference inside the
box at the top left corner of a drawing window. The drawing
tools use the working size.

If the selector tool is active when you choose a size, any selected objects’
borders or selected line objects change to the chosen size.

You can also draw special lines that have an arrow at either end, both ends,
or dimension lines with two arrows and the line’s length automatically
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placed in the center. These lines are always drawn with a line size/width of
one.

A keyboard shortcut is provided for setting line sizes quickly. You can
press a number (1-8) to specify a size, press zero to specify no line, or press
9 for dimension lines. Please see “Line Tools” and “Using Patterns” for
additional information.

Color Menu

Use the color menu to change
existing object colors or to specify
colors to use when drawing. You
can see colors on the screen if you
have a Macintosh that displays
colors. If you have a black and
white machine, you can specify
colors for printing to color printers,
such as the ImageWriter II with a color ribbon.

Fill And Pen Colors

Please see “Using Colors” in the “Mighty Draw Tutorial” chapter for color
information and an example of how to set an object’s colors.

Display In Color/Black & White

If you select the Display In Color menu item, any color other than white in
your drawing displays as black on machines that only display black and
white, and the menu item changes to Display In Black & White so you can
reverse the selection.

To do a color printout, you need to display in color first. Similarly, you can
display in black and white for a black and white printout. Please see “Using
Colors” in the “Mighty Draw Tutorial” chapter for additional information.

Object Color

If you have a black and white computer, you can choose Object Color to see
the color of objects.

To check an object’s color:

1. Click the selector tool.

2. Click an object then choose Object Color.
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For grouped objects, the color of the first object in the group is shown.
You’ll need to temporarily ungroup the object to check the color of indi-
vidual objects within the group.

Symbols Menu

Library

Mighty Draw provides extensive symbol library
support. To access or manipulate symbol libraries,
select Library from the Symbols menu. The following
dialog appears:

Note: The first time you select Library, no library names appear in the
library list. You’ll need to use Open Library to open one or more of the
provided libraries before you can access any symbols.

A description of all the Library options follows.

Library list. A list of the working libraries. To work with a particular
library, click its name in the list.
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Symbol Name list. A list of the symbols in the currently selected library
(from the library list). Click a symbol name, and its image appears in the
Symbol box on the top right.

Symbol box. Shows the currently selected (highlighted) symbol from the
Symbol Name list.

Selection box. If you use the selector tool to select objects before choosing
the Library menu item, you can cycle through and view them in the
Selection box, or add them to the working Library (see “<< Add <<“, “<<“,
and “>>” below).

Paste. Click Paste, or double-click a symbol name, to paste a symbol into
your drawing and exit the Library dialog.

Delete. Click Delete to remove the currently selected symbol from a library.

Rename. Use Rename to change a symbol’s name.

<< Add <<. Click Add to add the selected object shown in the Selection box
into the currently selected library. A dialog appears for naming the object.

Exit. Click this to exit the library dialog without pasting an object into your
drawing.

<<. Click this button to move backward through selected objects.

>>. Click this to move forward through selected objects.

New Library. Click this button to create a new empty library file. After
selecting New Library, a file dialog appears. You’ll probably want to create
the library inside the Symbol Libraries folder. To do so, open the Symbol
Libraries folder from within the file dialog, then type a name for your new
library and click Save. The name is added to the Library list. Now you can
add selected objects to the library (see “Selection box” and “<< Add <<“
above).

Open Library. This lets you open an existing symbol library and add its
name to the list of working libraries. You need to open a symbol library file
before you can access its symbols. After selecting Open Library, a file dialog
appears. Move to the Symbol Libraries folder to find the provided symbol
libraries, and double-click the desired library name. You may work with up
to 10 libraries at once.

Close Library. Select a library name and click Close Library to remove it
from the list of working libraries. This doesn’t delete the library from disk.
Use the Finder to permanently delete a library file. Click Open Library to
add the name back into the working library list when desired.
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Create Icon, Edit Icon

Mighty Draw lets you create
and edit small images, called
icons, at the single pixel
(screen dot) level. This gives
you a high degree of control
over the appearance. Select
Create Icon to make a new
icon, or select an existing icon
and choose Edit Icon to
change it. The icon dialog
appears:

If you have a color Macintosh, both a color and a black and white version of
the icon appear at normal size in the dialog, along with a color palette to
choose colors for editing. In this case, click the color icon box, or the black
and white icon box, to select which you want to edit. On a black and white
Macintosh, only the black and white icon box appears for editing.

To edit, move into the large edit area and click, or hold down the mouse
button and move the mouse. This sets pixels to black (or to the working
palette color when using color systems - click a palette color to change
colors). Clicking a black pixel resets it to white.

On color systems, you can copy the color icon over the black and white icon
(or vice versa) by holding the command key and clicking the destination
icon box. For example, if editing the color icon, hold the command key and
click the black and white icon box to copy the color icon over the black and
white version (all colors are translated to black and white). Warning: You
can’t undo a copy so be certain it’s what you want to do.

If using color, you should still create a black and white version of your icon
so it will display on a black and white system as well (use the copy feature
described above to aid in creating the black and white version). Similarly, if
you go from a black and white system to a color system, you’ll need to
create the color versions so they’ll show up in drawings that use your icons
(or select Display In Black & White from the Color menu).

Click OK when you’re finished editing. The icon pastes into your drawing
and may be positioned as desired. Use the selector tool to select it, then
choose Edit Icon if you want to change the icon at a later time.

Pie Chart, Column Chart, Bar Chart

Mighty Draw provides a quick, easy way to create standard pie charts
(explodable), column charts, and bar charts. You’ll find samples of them in
use in the Sample Drawings folder.
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To make a chart, select the desired menu item. A dialog appears for
entering the chart’s data:

Type in the desired labels and chart values. To move between fields, use the
tab key or click the desired box. As you enter data, a scaled down version of
the chart displays for reference in the Chart box.

You can specify each bar’s (or pie slice’s) pattern, foreground color (black
part of pattern), and background color (white part of pattern) by clicking a
label or value field to activate it, then choosing the desired setting from the
popup menus (hold the mouse button down on a popup menu to bring up
the menu of color or pattern choices).

When finished, click OK to paste the chart into a drawing. Use the selector
tool to position it. You can ungroup the charts to reposition text labels, or
change the text font, size, or style. When creating bar or column charts, you
may find it useful to draw a box the size of the chart, then send it to the
back and set it to a pattern or color to control the chart’s background
appearance.

The entered chart data is maintained until you quit Mighty Draw. If you
want to change the last pasted chart, simply delete it, then select the chart
menu item again (only if you haven’t quit Mighty Draw since entering the
chart’s data). The dialog reappears with the original data you entered.
Change it as desired and click OK to paste an updated chart using the
newly changed data.

To clear the chart data, hold the option key down when selecting a chart
menu item (before pulling the Symbols menu down).

Flowchart, Borders

Mighty Draw comes with flowchart and border symbols built in for easy
access under the Symbols menu. You can access many other predrawn
symbols using the Library feature described earlier.
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To add a built-in symbol into your drawing:

1. Select the desired Symbols menu item. A dialog of symbols displays.

2. Double-click the desired symbol. Or, click the symbol once and click
OK. The symbol pastes into your drawing and the selector tool activates so
you can move it to the desired position.

Layout Menu

Overview

Select Overview from the Layout menu to see a
scaled down version of your whole drawing.

Show/Hide Rulers

Choose Show Rulers if you want visible rulers while drawing. If rulers are
used, this item changes to Hide Rulers. Where the rulers meet at the top left
corner of a drawing window, you’ll see an abbreviation of the working unit
(see “Rulers” for more).
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Show/Hide Ruler Lines

Select this to show and hide ruler reference lines that you may find helpful
for drawing and positioning objects more precisely. Here’s how they look:

Show/Hide Page Breaks

This lets you show or hide striped lines that indicate where each page of a
multiple-page drawing begins and ends.

Each page in a drawing corresponds to a printed page on paper. This
means if you change the paper size with Page Setup, it affects the size of a
page and where the page-break lines appear. You’ll probably want to show
page breaks if your drawing is more than one page in size, and it doesn’t
hurt to leave them visible all the time. See “Drawing Size” for more.

Show/Hide Measurements

Choose this to show or hide size measurements that appear as you stretch
an object to size (when you draw).

For box, oval, and arc objects, width and height measurements appear.
Length and angle measurements are shown for line objects. Here’s an
example of what you’ll see while dragging an object to size:



57

Chapter 4, Menus

The measurements are useful when you need to draw lines or other objects
at a specific size. You can find an existing object’s size by selecting it and
choosing Info from the Edit menu.

Rulers

Choose Rulers to set the number of ruler divisions, and the working units.
You can choose to work in centimeters, millimeters, or inches using fraction
or decimal measurements.

Drawing Size

Use Drawing Size to change how many pages a drawing is in size, which
increases or decreases the amount of space inside the drawing window.
Each page in size corresponds to a printed page on paper. You can trim the
edges off the paper and attach the pages together.

You may prefer to use the “No Gaps Between Pages” option under Page
Setup when printing multiple-page drawings. This causes the drawing to
print continuously down the paper vertically (right through the perfora-
tions). You will only need to attach each vertical column side by side to
complete the entire printed drawing.

When Mighty Draw begins, the drawing size is set to 1 page wide by 1 page
high (unless you save new defaults, see “Save Defaults”). You can create
drawings that are up to 8 x 8 pages in size. However, you should limit the
size to what you really need for a given project. Remember that an 8 x 8
page drawing contains a total of 64 pages which could take a considerable
amount of time to print. The width and height do not have to be the same.
The following drawing size examples are all okay:

Page Wide x Pages High
1 x 2
2 x 1
2 x 2
2 x 4
4 x 4



To change the drawing size:

1. Select Drawing Size from the Layout menu. A dialog containing a grid
of boxes appears.

Each of the boxes
represents one page.

2. Set the desired size.
Move the pointer onto
the grid and click (or
hold the button down
and drag) to reduce or
enlarge the drawing size. Click the OK button when the size is what you
want.

If you are changing the size of an existing drawing, you can’t reduce its size
below the number of pages that are currently used. You can select Status
from the Apple menu to see a drawing’s current size and how many pages
are actually used.

In some cases, a drawing’s page size may change automatically. For
example, if you use Page Setup and choose a paper size (page size) that is
smaller than the current size, existing objects may extend beyond the
boundaries for the new page size. If so, additional pages are added.

Note: Mighty Draw won’t let you size a window larger than the current
drawing size, so if you have a large screen monitor and want to size the
window to fill the screen, you may need to set the drawing size to more
than one page in width and height.

Save Defaults

You can choose Save Defaults from the Layout menu to save the front-most
window’s configuration for use as default settings for new windows. The
settings are used when you select New from the File menu or open a
drawing that wasn’t created by Mighty Draw (Mighty Draw attempts to
load any PICT drawing).

This lets you specify how you want options such as rulers, ruler lines, and
measurements set. Simply configure any window with the settings the way
you like, make it the front-most window, then select Save Defaults and click
OK at the confirmation dialog.
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  Appendix A

The Mighty Draw Desktop

This information is provided for new Macintosh users, or those who may
want a refresher about using the mouse and the desktop environment.

A Few Macintosh Terms

Click. Click means to quickly press and release the mouse button.

Double-click. This means for you to click twice.

Drag. To drag, hold down the mouse button and move the mouse. Release
the button to end the drag. Normally when dragging, you’ll move onto an
object or other item then hold the button and drag its outline.

Pointer. The pointer is the symbol on the screen that moves when you
move the mouse. You’ll most often see one of the following pointers while
using Mighty Draw.

Command Key/Apple Key. The command key, sometimes referred to as
the Apple key, is often used to modify some action, or to select a menu item
using its command-key equivalent .

The Desktop

When Mighty Draw starts, you’ll see this screen:
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The menus along the top of the screen provide access to many of Mighty
Draw’s features. The Apple symbol is a menu also.

Mighty Draw lets you work with several drawings (documents) at once.
This is convenient for copying objects from one drawing and pasting them
into another drawing. Each drawing resides within its own window, which
displays when you open an existing drawing or select New from the File
menu. The drawing’s name appears at the top of the window (“Untitled” is
used for new window).

When there is more than one window, the front-most window is active. All
drawing and menu selections apply to it. To bring another window to the
front, move onto any visible part of it and click.

All document windows are movable and sizable.

To move a window: Move the pointer onto its title bar,  hold down the
mouse button, then drag the window’s outline to a new location and release
the button (hold the command key to keep its stacking order from chang-
ing).

To zoom a window: Click the zoom box  at the upper right corner to
instantly enlarge a window. A second click restores the original size.
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To close a window: Click the close box  at the upper left corner to close a
window. It has the same effect as selecting Close from the File menu.

To resize a window: Move onto the size box,  hold down the mouse button,
then drag the window’s outline inward or outward to the size you want
and release the button.

A window’s scroll bars let you move around a drawing to see the parts that
aren’t currently visible.

To scroll a window: Move onto a scroll arrow and hold down the mouse
button. To move by a page, click the page region of the scroll bars. To move
a specified amount, drag the scroll box to the desired position.

To Quit Mighty Draw: When you want to quit Mighty Draw, use Save
under the File menu to save the drawings that you want to keep, then select
Quit, also under the File menu.

See the “Tool Palette” chapter for a description of the tools along the left
side of a drawing window, and see “Using Patterns” for detailed informa-
tion about the patterns along the top of a drawing window.
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Macintosh Mighty Draw Command Keys

FILE MENU SYMBOLS MENU

 N = New  Y = Library
 O = Open  1 = Flowchart
 S = Save  2 = Borders
 P = Print
 Q = Quit

EDIT MENU LAYOUT MENU

 Z = Undo  W = Overview
 X = Cut  R = Show/Hide Rulers
 C = Copy  - = Show/Hide Ruler Lines
 V = Paste  M = Show/Hide Measurements
 D = Duplicate
 A = Select All SPECIAL KEYS
 I = Info Space = Toggles between current

ARRANGE MENU tool & selector tool

 F = Bring to Front < = Rotate Left
 B = Send to Back > = Rotate Right
 , = Rotate Left " = Flip Horizontal
. = Rotate Right : = Flip Vertical
 ' = Flip Horizontal 1-8 = Sets line/border width
 ; = Flip Vertical 9 = Dimension Line
 G = Group 0 = No line/border
 U = Ungroup Shift = Hold for constrained
 L = Lock drawing and to select/
 J = Unlock unselect multiple objects

COLOR MENU

 K = Object Color
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Flowchart Symbol Command Keys

S = Start, Stop F = Flowchart

O = Operation, Process C = Connector

D = Decision

I = Initialize, Prepare

N = Input, Output

T=Punched Paper Tape

B = Pg Connector, Break

E = Screen, CRT

A = Disk Operation

P = Printout

M = Manual Operation

K  = Keyboard Input

V=Punched Bore Cards

Q=Magnetic Tape
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  Appendix C

Trouble Shooting

Due to the complexity of today’s interactive computer software, it’s
virtually impossible for any software publisher to guarantee a particular
piece of software is 100% bug free. The system software (yes, even Apple’s
system software), and other software you purchase usually have a few
undiscovered bugs lurking around. Though they may be somewhat
annoying, most bugs are fairly benign and don’t result in serious problems
or loss of work. Occasionally though, a more serious failure is bound to
occur (if not software related, then possibly a hardware failure).

For that reason, we can’t emphasize enough: backup work that is important
to you! Use Save frequently to update your disk copy of a drawing as a
safeguard against your system going down. Then, save a backup copy of
your work using Save As. Especially when you’ve put enough time into a
project that you don’t want to run the risk of having to redo it. And just as
important, keep an additional copy of your previous session’s work! This is
important! If for some reason, a file becomes corrupt and you save a backup
of it, the backup will be corrupt as well, so keep that third copy from your
previous session’s work to fall back on (preferably on a floppy disk to
guard against a hard disk failure).

We’ve made every effort to ensure Mighty Draw performs reliably!
However, if you do encounter a problem (or incorrect operation), we would
certainly appreciate knowing about it so that it can be fixed. First though,
check through this appendix for a possible solution to problems that arise.
If you don’t find a solution here, jot down the steps involved in duplicating
the problem, then contact Abracadata for assistance. Please see the “Techni-
cal Support” section near the beginning of the manual for specific instruc-
tions before calling.

Init Compatibility Problems

Often, when things do go wrong, it’s caused by incompatibilities between
Inits or other software on your system. Inits are utilities placed in the
System Folder which alter the normal operation of your system in some
way, usually for the better, but not always.

Since Inits change normal system operation, it’s not uncommon for them to
cause a conflict with each other, or other applications. Try disabling all Inits
on your system and see if the problem you are experiencing goes away.
Either temporarily remove the Inits from your system folder, or use an Init
manager to disable them, then select Restart from the Finder.
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If the problem goes away, you’ll know one of your Inits is the cause. Install
them one at a time until you find the guilty Init. While we can’t guarantee a
fix for this type of problem, if you notify us, we will look into a solution.
However, the responsibility for a solution may fall to the Init developer
since Inits often change standard system operation and create problems
that don’t otherwise exist.

Memory Problems Under MultiFinder (and System 7)

The information here only applies if you are running under MultiFinder or
System 7.

Mighty Draw is compatible with MultiFinder and System 7. However, you
may need to allocate more memory for Mighty Draw to use.

The default amount of memory Mighty Draw uses is enough for most
projects. However, if you are working with large drawings, or several
drawings at once, you may need to specify more memory.

You can choose Status from the Apple menu while using Mighty Draw to
see how much memory a drawing uses, and how much free memory is left.
Try to keep at least as much memory free as is used by the largest opened
drawing (half again more is even better).

If the program generally works okay, but when working with large
drawings or many files you experience system bombs or other erratic
behavior, suspect a memory problem. Try giving the program more
memory to run within, then see if the problem goes away.

To allocate more memory for Mighty Draw, first, Quit the program if it is
running then highlight its application icon and choose Get Info from the
Finder’s File menu. Try adding 200-300K of memory or more to the amount
shown. Decide the exact amount based on your needs and how much
memory you have available.

Errors Opening Files Or Importing PICTs

Mighty Draw supports the PICT file type. If you get a PICT version error,
you are probably trying to paste or open the PICT2 format. Mighty Draw
only supports the PICT2 format using Paste As PICT under the Edit menu.

You’ll need to export from the original application using the PICT format
(most applications provide this capability) or import the PICT into Mighty
Draw through the clipboard using Paste As PICT (the same is true for
importing paint-type images, or scanned images).

If you get an Unknown PICT Data error, that could be bad news (do you
have that backup?). This generally indicates the file you are trying to open
has somehow become corrupted. Some of its data isn’t what it should be. A
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low-memory situation when the file was being saved could cause this type
of problem (see the previous section), but isn’t necessarily the cause.

Mighty Draw files are saved in PICT format, so sometimes you can salvage
a file by first importing it into another program that supports both import-
ing and exporting the PICT format, such as MacDraw, or some other
application. If it’s a file that was originally saved by Mighty Draw, and it’s
the Mighty Draw specific information in the file that’s bad, a different
program may successfully read the file since it ignores Mighty Draw
specific information. If this works, you can export it as a PICT file and bring
it into Mighty Draw again, though some information will be lost in the
process. For example, you’ll probably need to regroup objects.

Problems Importing Bitmap Images

Mighty Draw only supports importing bitmap images (as created by paint
programs or by scanning images) using Paste As PICT under the Edit
menu. Since Mighty Draw is object-oriented, it ignores any bitmapped
information when opening PICT files or using the normal Paste menu item.
Images imported using Paste As PICT may be moved, resized, duplicated,
or deleted, but are otherwise unchangeable. You’ll need to perform any
editing using a paint-type program before importing them through the
clipboard.

Ruler Numbers Or Dimension Line Measurements
Don’t Draw Correctly

If ruler numbers or dimension line measurements don’t draw (or appear as
small boxes), you are experiencing a font ID conflict. This happens rarely
but does come up occasionally on systems with a large number of fonts,
usually in the hundreds. It occurs because the font manager gives a font in
your system the same ID as that of Mighty Draw’s internal ruler font. When
Mighty Draw requests its font using the ID number, it’s given the one in
your system instead.

The solution is to temporarily remove groups of fonts from your system
until the problem goes away. Then you’ll know which font group contains
the font that’s causing the problem and can narrow it down to the particu-
lar font from there.

Other Possible Problem Areas

Sometimes problems occur if your Desktop file is damaged. This is an
invisible file your system uses to keep track of icons, folders, and various
other information. If you are experiencing problems, try rebuilding the
desktop file. To do so, restart your computer and hold down both the
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command and option keys through the startup sequence. When a dialog
appears asking if you want to rebuild the desktop, click OK.

It could be that one or more of your system files has been damaged. You
can try reinstalling your system if you suspect them. Especially be suspi-
cious of system files if you experience trouble while using the Finder, or
with a variety of applications.

Have you checked your system for viruses lately? They can cause both your
system and applications to behave erratically. You can obtain a good public
domain or commercial virus detecting program to check your system for
viruses.

You might also try running a diagnostic utility to check your hard disk for
problems, especially if the problem is related to opening, closing, moving,
or copying files. Your hard disk isn’t full, is it?

If all else fails, you could try duplicating the problem on a friend’s (or local
dealer’s) computer to determine for certain whether it’s unique to your
system. If the problem goes away on a different computer, then you'll know
that it's related to something on your system, and can continue to isolate
the cause. If it's on both machines, you should probably give us a call and
tell us how to duplicate it so we can check it out.
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