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SuperBladePro
 

What it does

SuperBladePro gives graphics a 3-D look by creating beveled edgesand surface 
textures. The effects can be subtle or stark, raisedor sunken. There are several 
kinds of bevels, textures, and mirrorlikereflections, and controls for light, gloss, 
iridescence, tarnish,glassiness, and more. It's a timesaving way to make touchable-
looking text, web buttons, and special effects.

Super BladePro can use the preset files from the original BladePro.

 

How to install

To use this software, you need a paint program which accepts standardPhotoshop 
3.0 plugins.

Just put the plug-in filter into the folder where your paint programexpects to find it. 
If you have Photoshop, the folder is Photoshop:Plugins:Filters or Photoshop:Plug-
ins. You must restartPhotoshop before it will notice the new plug-in. It will appear
in the menus as Filters->Flaming Pear->SuperBladePro.

Most other paint programs follow a similar scheme. 

If you have Paint Shop Pro: you have to create a new folder, putthe plug-in filter 
into it, and then tell PSP to look there. 

PSP 5 and 6:

Choose the menu File-> Preferences->General Program Preferences...and choose 
the Plug-in Filters tab. Use one of the "Browse" buttonsto choose the folder that 
contains the plug-in.

The plugin is now installed. To use it, open any image and selectan area. From the 
menus, choose Image->Plug-in Filters-->FlamingPear->SuperBladePro. 

PSP 7:

Choose the menu File-> Preferences-> File Locations... and choosethe Plug-in 
Filters tab. Use one of the "Browse" buttons to choosethe folder that contains the 
plug-in.

The plugin is now installed. To use it, open any image and selectan area. From the 
menus, choose Effects->Plug-in Filters->FlamingPear->SuperBladePro



PSP 8:

Choose the menu File-> Preferences-> File Locations... In thedialog box that 
appears, choose Plug-ins from the list. Click"Add", then click "Browse" and 
choose the folder that containsthe plug-in.

The plugin is now installed. To use it, open any image and selectan area. From the 
menus, choose Effects->Plugins->Flaming Pear->SuperBladePro.

 

Controls

When you invoke SuperBladePro, a dialog box will appear:

Quick start
 

 

Click the dice button a few times until you see 
something thatyou like. 

Click OK. The progress bar will appear, and then 
your selectionwill have a new 3-D look.

   

Bring the filter back and take a look at the controls. 
On leftare a popup menu and several sliders.

: Choose the shape of the bevel from this 
popup menu. Choose fromstraight, curved, up-
and-down, and doubled forms. The last shapeis a 
Gaussian bevel which produces a very smooth 
result at theexpense of some detail.

Shape

: The width, in pixels, of the beveled edge. If 
this is more thanhalf the width of the widest partof 
the selection, no area willbe left unbeveled.

Radius

       

 

dice

 

 

 



: Larger values here give the bevel a steeper 
appearance. Positivevalues cause the selection to 
rise out of its background, andnegative values 
make it sink in.

Height

: Larger values reduce the rippled 
appearance of the bevel. (If you want the kind of 
smoothing found in earlier versions of BladePro,set 
Smoothness to zero.)

Smoothness

bevel shapes

Texture specifies the amount of texturing, if any. 
Positive values makethe texture rise out of the bevel, 
negative ones make it sink in.

Embossing makes the brightness of the underlying 
image influence the shape.

Gloss controls the shininess. Zero gives a chalky 
appearance; highernumbers are glossier.

Glare controls the size of the glossy highlight.

Reflection controls how much the selection reflects 
the Environment graphic.If you don't want any 
reflection at all, turn this slider downto zero.

Glassiness gives the selection a glassy rather than 
opaque appearance. Thecolor of the original image 
becomes the color of the glass.

Caustic, for glassy selections, this slider controls the 
brightness ofthe caustic highlight that appears 
opposite the light source.The tiny square just to the 
right of the slider lets you chooseprismatic or white 
caustics.

Iridescencecontrols the strength of iridescent 
coloration, and...

Iri colors  controls the choice of colors.

Together, Caustic and Iridescence reproduce the 
effect that givessoap bubbles their colors: if light is 
reflected from two surfacesseparated by a very thin, 
transparent layer, interference colorswill appear.

Light angle controls are the two grey spheres. To 
change the placement of a light,drag the small blue 
dot to a new position. Best results come fromplacing 
the light somewhere in the upper half of the ball.

Spotlight slidersnext to the light angle controls can 
produce uniform illumination or a spotlight effect.
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Color-buttons are for changing the lights' colors. If 
you want to turn a lightcompletely off, set its color to 
black.

 

 

The next column of controls has an assortment of 
buttons and picturesconcerned with texture and 
reflections. 

Texture popup menuchooses the texture you want. 
The first item is 'no texture';the next eleven items are 
built-in textures; and the last itemis the custom texture.

You can use any greyscale BMP file as a custom 
texture. To dothis, select the custom texture item 
from the popup menu, anduse the file browser you'll 
then see to choose a picture. SuperBladeProwill load 
the picture and use it as a texture.

The texture graphic is just below. Clicking on it is 
another way you can load a newtexture file, and you 
can reposition the texture by dragging itwith the 
mouse.

Texture files are "height fields" and describe the shape 
of asurface: black is low, white is high, grey is in 
between. SuperBladeProcomes with several texture 
files in its 'environments and textures' folder, and you 
can make your own. They can be as large as 256by 
256 pixels (larger ones will be squeezed to fit) and the 
right edge should wrap seamlessly around to the left, 
and the top to the bottom.

The texture zoom slider is right below the texture 
graphic. It lets you scale the textureup or down by a 
factor of 16.

Next is theenvironment graphic: When Reflection is 
on, Blade will produce mirrorlike reflectionsof the 
environment graphic. Just click on the graphic and you
can load any BMP file as an environment. You can 
find severalsamples in the 'environments and textures' 
folder that came withSuperBladePro.

If you don't want your selection to be reflective, turn 
the reflectionslider down to zero.

Some of the example environments, like 'gold', appear 
to containtheir own light source coming from the top 
left. If that conflictswith your design plan, you can 
spin the environment with - amazinglyenough - the 
environment spinner button, so that it better matches
the rest of the lighting. This button is the one with the 
little curly arrow on it.
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Dice randomize the settings. Click it as much as you 
want to see differenteffects. 

Glue mode lets you combine the sun with the 
underlying image in variousways. Modes other than 
"normal" produce special effects.

Plus % and minus buttons: if the selected image 
area is larger than the preview are, thesebuttons will 
let you zoom in and out . You can also repositionthe 
preview by dragging it around; your cursor will turn 
into a hand.

Auto Preview makes the preview update 
automatically whenever you move anycontrol. Turn it 
off if you want to save time.

:Load preset SuperBladePro comes with some 
presets, which are files containingsettings. To load 
one, click this button and browse for a presetfile.

:Save presetWhen you make an effect you like, 
click this button to save thesettings in a file.  

Important: The presets expect their texture and 
environment files to bein the 'environments and 
textures' folder. If presets fail to load properly, 
SuperBladePro will ask you where that folder is. The

section of this guide explains in more detail.Installation
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Update folder lets you update a whole folder full of 
presets to the newestversion. If you have a folder full 
of presets from original BladePro,you can 
automatically turn them into SuperBladePro presets 
containingpreviews. 

  update folder  

At the bottom of the screen are some more controls.

SuperBladePro can simulatewater stains. This uses 
four sliders:

Rain is the amount of water falling from the top of the 
selection.

Evaporation sets the rate at which water evaporates. 
If evaporation is greaterthan rain, waterstains may 
only appear near wrinkles in the surface.

Diffusion controls the horozontal spread of the water

Wander makes water wander over flat areas instead 
of falling straightdown.

There are tworain color buttons. As rain becomes 
heavier, the color changes from the first color to the 
second.

There is a wet/dry checkboxwhich controls whether 
the rain acts like opaque paint or transparentdye.
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The remaining controls produce a weathered or 
damaged appearance.

 

Dust makes dull powder appear on upward-facing 
surfaces.

Grit  puts high-frequency noise in the texture.

Tarnish puts dull, matte color in the concave parts of 
the surface. Thecolor-button just to the right of the 
slider lets you change thetarnish color.

Abrasion is similar to Tarnish, but it puts dirt on 
convex areas.

Moss places moss-like matter on upward-facing 
surfaces.

Moss has two color buttons: one for the moss itself, 
one for the underlying soil.

Leakinessmakes the moss leak water, and makes 
the blotches soak it theresulting stains.

Blotchesgrows lichen-like blobs. Blotches have 
color, scale, and coveragecontrols.

Blotch Sizemakes the blotches bigger or smaller.

The random seednearby changes the detail of the 
blotches. You can click it repeatedlyuntil you see the 
effect you like.
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random seed

Other controls  

Dice This randomizes the settings. Click it as much as 
you want tosee different effects. 

Glue mode Lets you combine the sun with the 
underlying image in variousways. Modes other than 
"normal" produce special effects.

Plus,%  andminus buttons: If the selected image 
area is larger than the previeware, these buttons will 
let you zoom in and out. You can alsoreposition the 
preview by dragging it around; your cursor will turn 
into a hand.

Auto Preview When this box is checked, the 
preview automatically updates wheneveryou move 
any control. Turn it off if you want to save time.

Load presetSuperBladePro comes with some 
presets, which are files containingsettings. To load 
one, click this button and browse for a presetfile. A 
small preview of the effect appears in the file chooser.

SuperBladePro can load the presets from original 
BladePro, butcan only save in the new 
SuperBladePro format with a graphic preview.

Save presetWhen you make an effect you like, click 
this button to save thesettings in a file.  Settings are 
always saved with small previews.

Undo backs up one step.

Simple Bevelproduces a plain effect suitable for 
making buttons.

 

Three more buttons:

 OK  Applies the effect to your image.

 Cancel Dismisses the filter, and leaves the image 
unchanged.

Register Allows you to type in a registration code.
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Five effects you can try  More tutorials...

 



1. A web button

Suppose you want to make a web button that has the 
word "Go" onit. 

In your paint program, paint an area in 
some neutral color. With your text tool, 
make the word "Go" in green.

Using your favorite selection tool, with 
antialiasing turned on,select a a button-
shaped area around the word.

Bring up SuperBladePro. Click the 
Load button (it looks like aCD with a 
blue triangle pointing from it) . Navigate 
to your 'environmentsand textures' 
folder and open the preset called 
'button, basic'.

After the preset loads, the preview 
should show your button with a basic 
bevel effect.

Play with the controls. The Radius 
control changes the width of the bevel. 
The Shape, Height, and Texture 
controls, in particular,let you make the 
most useful changes.

Click OK. There's your button.

For a more sophisticated effect, make a button as 
above but withoutthe word "Go". Instead, make a 
blank button. Then, in a new layer,make a selection 
in the shape of the word "Go" and use SuperBladePro
to make the word look like gold; use the preset called 
called'gold, basic'. Last, settle the word "Go" on the 
button by givingit a drop shadow.

 

 

2. A ruby  
 

Make a selection with some straight 
sides and fill it with ruby-red.Bring up 
SuperBladePro and decide how you 
want your ruby to look.

Adjust the Shape and Radius and Height 
to produce a shape with some internal 
edges in it.

Rubies are glassy, so set Glassiness to 
about 90. You want it to appear sparkly 
and reflective, so set Gloss to about 50, 
Glareto 50, Reflection to 75. Choose 
an environment with flatteringcolors in it: 
'Rum' is nice.

To increase sparkle further, turn Caustic 
up to 60 to producea highlight away 
from the light. Even better, use both light    



sources:move the second one to about 
the 2 o'clock position, and set its color 
to creamy-yellow.

Introduce more variety of color by 
turning Iridescence to about15 and 
putting the Iri Colors slider somewhere 
in a pink-and-yellow region.

Subtle texture will make your ruby look 
best. Click the texturegraphic and load 
the texture file called 'ripples2'. Set the 
Textureslider to something between 10 
and 30, and experiment with theTexture 
Zoom until you like the result.

Click OK. There's your ruby.

3. A glassy logo   
 

Use your text tool to write a word in 
50% gray, using a large,husky font - 
say, Gill Sans Bold at 100 pt. 

Make sure the text is selected, and call 
up SuperBladePro. Loadthe 'rainbow 
glass' preset. The word should now 
appear as glasswith a bright rainbow 
caustic.

Play with the controls. Try a white 
caustic, or a different environment,or a 
different degree of glassiness or 
reflectivity.

Click OK if you like the effect.

 

If you want to experiment with colored 
glass, cancel out of thefilter, and use 
your paint tools to paint each letter a 
differentcolor. Moderately saturated 
tones at about half of full brightness
work best. Then go back into the filter 
and see how the coloredglass looks.

   

4. Tarnished metal  
 

Select a region of your image, and call 
up SuperBladePro. 

Load the preset called 'old copper'. The 
important elements hereare 100% 
reflection of a coppery environment, a 
wavy texture,some pale green tarnish 
like corroded copper, and a light source
at the upper left, which matches the light 



in the environmentmap.

If the real light and the light in the 
environment don't match,the tarnish will 
look wrong. If you want, try moving the 
light source and spinning the environment 
to see how they need to bein sync.

The tarnish collects in the concave parts 
of the surface, so it will react to the scale 
and height of the texture, as well asthe 
crevices in some of the bevel shapes. 
Try changing those settingsand the 
tarnish amount and color to see how 
they interact.

Try some other combinations: the 
environment 'city' with blacktarnish 
looks like dirty silver. The 'dull steel' 
environmentwith brick-red tarnish looks 
like rust; strange tarnish colorslike 
magenta give a surreal effect.

Good textures to use with tarnish are 
'scales', 'pits', 'crackle',and 'dimples'. 
And try the preset called 'my tailpipe' to 
seea oxidized metal effect that uses 
tarnish and iridescence together.

   

5. Iridescent surfaces  
 

Select a part of your image, and call up 
SuperBladePro, and loadthe preset 
called 'ski goggles 1'. 

The selection reflects a nearly colorless 
environment, but theiridescence adds 
plenty of color to the result. The 
Iridescenceslider controls the strength 
of the added color, and the Iri Colors
slider decides the range of possible hues.

The final outcome of colors will react to 
the shape of the beveland the strength 
of the texture, so try changing those 
settingsto get a feel for how the colors 
change. Basically, the more strongly
sloped the surface gets, the wider variety 
of colors it will have.

The Iri Colors slider produces assorted 
effects. At zero, iridescencedisappears. 
At very small values, about 7, surfaces 
become dull brown, like slightly oxidized 
metal. At 12, you have an anti-reflective
coating. Soap bubbles are about 25, and 
higher values give thehues you see in ski 
goggles and sunglasses.

Adding a very small amount of 
iridescence can create attractive

   



variation in hue in any effect. Check out 
the preset 'my tailpipe'and change its 
iridescence settings to see what's 
possible.

Hints  
 

Selections with an antialiased edge will yield vastly 
better resultsthan ones with hard edges. Most paint 
programs have an optionto create an antialiased edge 
for text-shaped and freehand selections.

If you find that the textures look grainy, try setting 
your monitorto 24-bit (millions of colors) mode 
rather than 16-bit (thousandsof colors) mode.

The environment and texture graphics can be any 
BMP file at all,and you can use your paint software 
to make your own. Includedwith SuperBladePro 
are...

Thirty-two 
environments 

2am
bronze sunset
cheap gold
city
copper
Curacao
driftwood
dull steel
glitter
gold
hillside
island
la-la land
puffy
red copper
road
rum
sea & sky
tinsel
watery
white chrome
winter
big city
canal
chinarock
cove
empire
greenstairs
lumphini
samui
victoria sky
zwolle

Eighteen textures 

burrs
cow
crackle
crumples
dendrites
dimples
fibrous
grass
lumps
pits
plaster
ringlets
ripples2
ruffles
scales
silk
tumor
turbulence

 

Free SuperBladePro tutorials are available here:
 .

http://
www.flamingpear.com/download.html

   

http:/


Several Extra Texture Packs are available for free -- 
check  .http://www.flamingpear.com/textures.html

If you want to make your own metal environments, it 
aids realismto make the bright parts slightly bluer and 
the dark parts slightly redder than your base hue.

If you want to produce a scene with shiny objects in 
front of some backdrop, you can use a small (64x64 
pixels or so) versionof the backdrop as your 
environment map. This way the shiny objectswill 
match their background. There's an example of this at

http://www.flamingpear.com/bladex2.html .

Constructing a 3-D shape from a selection's edge 
results in aslightly ripply surface, so reflections tend to 
have fine striationsin them. For that reason, the best 
results come from environmentswith contrasty ramps 
of color and a bare minimum of detail. Takea look at 
the included samples to get an idea.

You can use bevels with a small radius and negative 
height tocreate a chiseled edge.

SuperBladePro can be used purely as a texture 
generator; justset Bevel Height to zero, and reduce 
Radius to the minimum. Try this using the texture 
'dimples' and some tarnish.

You can make your own textures: dark areas are low, 
bright areasare high. Try this recipe:

Find an interesting piece of a some image.
Use the cloning brush to make a roughly square, 
roughly homogenouschunk
Gaussian Blur by about 0.5 pixels
Adjust->Auto Levels
Use the highpass filter on it, radius 4 to 8 pixels
Adjust->Auto Levels again
Wrap the edges of the selection to make a seamless 
tile.

Try inverting the grey values of the whole image. If the 
picturebecomes generally darker, then use the 
inverted picture. Thatway, positive settings of the 
texture slider will produce bumps,and negative 
settings pits.

Frequently Asked Questions

Answers to troubleshooting questions appear online at 
.http://www.flamingpear.com/faq.html

More presets and tutorials appear  and .here here

You can chck for new releases of the filter at e

 

http://
http://www.flamingpear.com/bladex2.html
http://


www.flamingpear.com . And if you have ideas for 
improvements, or commentary, or questions,please 
email .support@flamingpear.com

Version History

Version 1.09 April 2003

Adds bigger previews in the preset browser. Adds a 
button for automatically updating a whole folder of 
presets.

Version 1.08 April 2003

Fixes the appearance of zoomed-out views in Paint 
Shop Pro 8 .

Version 1.07 December 2002

Fixes the appearance of text in the interface when 
running underMac OS X 10.2.3 .

Version 1.06 April 2002

Fixes a bug in the both the Windows and Macintosh 
versions whereloading presets would sometimes 
cause spurious error messages.

Version 1.04 August 2001

Fixes yet a third bug in the Macintosh version where 
presets wouldsometimes not load their texture and 
environment files. This versionis PowerPC only.

Version 1.02 September 2000

Fixes another bug in the Macintosh version where 
presets wouldsometimes not load their texture and 
environment files.

Version 1.01 September 2000

Fixes a bug in the Macintosh version where presets 
would sometimesnot load their texture and 
environment files.

Version 1.0 September 2000

The first public release. 

Novel features include waterstains, blotches, 
abrasion, spotlighting,dust, grit, embossing, moss, 
and smooth Gaussian bevels. The Windowsversion 
will operate correctly even if Windows is installed on
a drive other than C:.
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How to Purchase

You can place an order online here. A secure server for transactions is available.

 

Questions

Answers to common technical questions appear on the support page, and free 
upgrades appear periodically on the download page.

Trouble with your order? Orders are handled by Kagi; please contact
admin@kagi.com. 

For bug reports and technical questions about the software, pleasewrite to
support@flamingpear.com .

mailto:admin@kagi.com
mailto:support@flamingpear.com

