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Error or Freeze When Installing Photoshop in Mac OS
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Solutions
What to Do If These Solutions Don't Work

The solutions in this document address most errors and freezes that interrupt the Adobe Photoshop installer. However, this document 
does not address the installer rejecting your serial number or problems upgrading from earlier versions of Photoshop. For these 
problems, contact Adobe Customer Services at 800-492-3623. 

You can solve most of these errors and freezes by following Solution 1. Sometimes a specific error indicates you should try specific 
solutions first, as shown the section "Which Solutions to Try for Specific Errors." However, many different factors can cause these 
errors, so you may need to try all given solutions. If the installer freezes or returns an error not listed below or in Adobe's Technical 
Solutions database (http://www.adobe.com/supportservice/custsupport), work through all the solutions. You can find known installation 
issues by searching Adobe's Technical Solutions database for "photoshop and install" and words from the error. 

Note: You must install Photoshop on a computer that meets the minimum system requirements shown in the user guide. Also, do not 
copy a back-up of the Photoshop folder to your hard drive instead of using the Photoshop installer. Not only can this carry problems 
from one hard drive to the next, but it does not include necessary files installed outside of the Photoshop folder. 

Causes of Errors or Freezes During an Installation
Many system variables can interfere with an installation. The usual cause is software that loads automatically, such as system 
extensions, control panels, and third-party device drivers. Damaged application or system files can also be the cause. In a few cases, 
hardware problems interfere. 

Which Solutions to Try for Specific Errors
If the installer returns one of the following errors, try the given solutions in sequence before trying the other solutions. 

"This installation requires a System folder on the destination drive. The installation has been canceled. 1008:1, -48 Duplicate File 
Name," followed by "An error occurred that prevented the installation from completing" -- Solution 5. 

"This transaction has expired." The Photoshop installer doesn't actually return this error; the Adobe Photoshop Registration program 
does. If you can start Photoshop as expected, register Photoshop by phone or by mail rather than online or see document 311234 , "
Error 'This transaction has expired.' When Installing Photoshop for Mac OS." If Photoshop doesn't start, follow the solutions below 
starting with Solution 1. 

Cleaning Up After an Installation Fails
Each time an error or freeze interrupts the Photoshop installation, you should reboot the computer, empty the Trash, and remove the 
Photoshop application files before you try the next solution. Doing so frees up hard drive space and removes any damaged files that 
the installer can't overwrite. 

To delete previous installations of Photoshop:
1. Move any personal files (e.g., images, third-party plug-ins) out of the Photoshop folder and its subfolders. 
2. Delete the Photoshop folder (e.g., Adobe Photoshop 5.0).  

3. If you are using Photoshop 4.0.x, delete the Adobe Photoshop 4.0 Prefs file in the System folder:Preferences folder. The Adobe 
Photoshop 5 Prefs and Color Settings files are in the Adobe Photoshop 5.0:Adobe Photoshop Settings folder, so you deleted 
them in step 2. 

Solutions
Do one or more of the following, writing down any changes in the installer's behavior or error. Keeping a log will help you 
troubleshoot if the problem turns out to be a complex one. 

Solution 1
Copy the installer files from the CD to your hard disk, restart with minimal extensions, then install Photoshop:
1. Reboot the computer.
2. Delete previous installations of Photoshop. 
3. Empty the Trash. 



4. Insert the Photoshop Application CD into the CD-ROM drive.
5. Double-click the CD.
6. Locate the Photoshop folder and copy it to your hard disk. Leave this copy of the setup files on your hard drive until you install 

successfully. 

Note: If an error occurs when copying files from the CD, it may be dusty, damaged, or you may have a problem with your 
CD-ROM drive or driver. Clean the CD and caddy with a soft, lint-free cloth to ensure that they are free of dust and fingerprints. 
Try copying files from other CDs to your hard disk to ensure your CD-ROM drive is working properly. If you cannot copy files from 
other CDs, contact your CD-ROM drive's manufacturer or the computer's manufacturer. If you can copy files from other CDs, but 
not the Photoshop CD, contact Adobe Technical Support.

7. Restart the computer with only the appropriate base system extension set enabled. For example: 
- For System 7.5, choose System 7.5 Only from the Extensions Manager control panel, and then restart.
- For System 8.x, choose Mac OS 8.x Base from the Selected Set pop-up menu in the Extensions Manager control panel, 

and then then restart. 
8. Double-click the Setup file in the Photoshop folder on your hard disk. Follow the prompts to complete the installation.

Solution 2
Optimize and repair the hard drive, and then follow Solution 1. To optimize and repair the hard drive, do one or more of the 
following:

-- Use a disk repair utility (e.g., Apple Disk First Aid, Norton Disk Doctor, TechTool Pro). 

Disclaimer:Adobe Systems does not provide support for third-party diagnostic software. The following instructions are 
provided as a courtesy. Contact the developer of your disk utility for support.

To use Apple's Disk First Aid utility, included on system software CDs:
1. Start the computer from a bootable disk (i.e., the disk labeled "Disk Tools" included with your System 7.x installation 

disks) or system software CD. 
2. Double-click the Disk First Aid application. 
3. Select the drive(s) to be verified or repaired.
4. Click Verify to check the disk or Repair to check and repair the disk. If you click Verify, Disk First Aid tells you if there is 

a problem with the disk and asks you if you want to repair it. Always repair the disk when prompted.
5. Choose File > Quit.
6. Eject the CD. 

-- Update all SCSI drivers to ensure that they are not damaged and are compatible with the current system. For further 
support, contact the manufacturer of your hard drive or your drive formatting utility. 
1. Start the computer from a bootable disk (i.e., the disk labeled "Disk Tools" included with your System 7.x installation 

disks) or system software CD.
2. Double-click the HDSC Setup, Drive Setup application. 
3. Click the Drive button until you select your SCSI drive (i.e., hard drive).

Note:On a disk drive that has been formatted with a third-party disk utility (e.g. Norton Utilities, MacTools, Symantec 
Tools for Macintosh), you may receive the message, "Drive selection failed. Unable to locate a suitable drive 
connected to the SCSI port." Clicking Continue quits HDSC setup. You must use the Disk Tools disk from that utility's 
disk set for these steps. For instructions, refer to the utility's documentation.

4. Click Update to install updated SCSI drivers to each SCSI disk (e.g., hard drive, cartridge).
5. Choose File > Quit.
6. Eject the CD. 

-- Use a third-party disk utility (e.g. Norton Utilities, TechTool Pro, Symantec Tools for the Macintosh) to ensure that damaged 
sectors are marked unusable. For instructions, refer to the utility's documentation.

-- Defragment and optimize your hard drive using a disk utility (e.g., Norton Utilities, MacTools). For instructions, refer to the 
utility's documentation.

Solution 3
Replace the system software by performing a clean install (i.e., installing new system software into a new System Folder, instead of 
installing over the existing system software), and then follow Solution 1. Please note that simply running the system software installer 
or an updater (e.g., System 7.5.3 - System Updater 2.0) does not ensure that a completely new copy of system software is properly 
installed. Rather than just running an updater, you must install a complete new System Folder. If your most recent system floppy or 
CD is an updater (not a full version), you will need to reinstall the most recent full version, then run the updater on that System 
Folder. For more information on performing a clean system software installation, see document 314980 , "Reinstalling System 8.0.x, 
7.6.x, 7.5.x, 7.1.x, or 7.0.x Software."



Solution 4
Follow Solution 3, but install the system software on a different hard disk (not a different partition on the same disk) and then make it 
the startup disk. To change the startup disk:
1. Choose Control Panels > Startup Disk from the Apple menu.
2. Select the drive on which you installed the new system software. 
3. Reboot the computer. 

Solution 5
Delete the hidden Temporary Items file using a disk editing utility (e.g., Norton Disk Editor included with Norton Utilties, Apple 
ResEdit). To delete the hidden Temporary Items file using Norton Disk Editor:

Disclaimer:These instructions are provided as a courtesy. Adobe Technical Support does not provide support for non-Adobe 
applications. For support on the use of a disk editing utility, contact the software developer (e.g., for Norton Utilities, contact 
Symantec Inc; for ResEdit, contact Apple). Only make changes to files specifically referred to here. Editing files may render them 
unusable, may prevent your system or applications from starting, and may cause data loss. 

1. Quit all applications.
2. Start Norton Utilities.
3. Choose Utilities > Norton Disk Editor.
4. In the Choose a Volume dialog box, select your startup (i.e., boot) disk, then click Open.
5. In the Hard Disk Directory window (where Hard Disk is the name of your startup disk), select the Temporary Items file by clicking 

on it once.
6. With the Temporary Items file selected, click on the Info button in the upper portion of the Norton Disk Editor window. The 

Information dialog box will appear.
7. In the Finder Flags section of the Information dialog box, make sure Name Locked is deselected.
8. In the Finder Attributes section of the Information dialog box, make sure the Finder Locked and Protected options are 

deselected. 
9. In the Name field at the top of the Information dialog box, rename the Temporary Items file (e.g., DeleteMe). Click OK to exit 

the Information dialog box.
10. Choose File > Quit.
11. In the Finder, refresh the hard drive window by closing it, then double-clicking on your hard drive icon to open the window 

again.
12. Locate the renamed file (e.g., DeleteMe), drag it to the trash, then empty the trash.
13. Install Photoshop.

What to Do If These Solutions Don't Work
If the previous section does not solve your installation problems, your hardware is probably conflicting with Photoshop's installer. 

As a last resort, you could reformat the drive, then install only the system software and Photoshop from the original CDs. Before you 
do, make sure you have all application and operating system disks, and that you've downloaded the latest system update and stored 
it on an external drive. Do not install any additional software or hardware until you've successfully installed Photoshop. 

Note: Reformatting the drive will erase all files. Before reformatting, make sure you've backed up all the data files for all your 
applications. Don't back up your hard drive and restore your system software and applications instead of reinstalling, however. 
Restoring them may cause the problem to occur again.
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The solutions in this document address most errors and freezes that interrupt the Adobe Photoshop installer. However, this document 
does not address the installer rejecting your serial number or problems upgrading from earlier version of Photoshop. 

You can solve most of these errors and freezes by following Solution 1. Sometimes a specific error indicates you should try specific 
solutions first, as shown the section "Which Solutions to Try for Specific Errors." However, many different factors can cause these 
errors, so you may need to try all given solutions. If the installer freezes or returns an error not listed below or in Adobe's Technical 
Solutions database (http://www.adobe.com/supportservice/custsupport), work through all the solutions. You can find known installation 
issues by searching Adobe's Technical Solutions database for "photoshop and install" and words from the error. 

Note: You must install Photoshop on a computer that meets the minimum system requirements shown in the user guide. Also, do not 
copy a back-up of the Photoshop folder to your hard drive instead of using the Photoshop installer. Not only can this carry problems 
from one hard drive to the next, but it does not include registry entries or files installed outside of the Photoshop folder. 

Causes of Errors or Freezes During an Installation
Many system variables can interfere with an installation. The usual cause is software that loads automatically in Windows, such as 
screen savers, device drivers, terminate-and-stay-resident (TSR) programs, and virus protection utilities. The installation can also be 
interrupted when the installer writes to the Windows registry or queries it for the location of certain directories and .ini files. In a few 
cases, hardware problems interfere. 

Which Solutions to Try for Specific Errors
If the installer returns one of the following errors, try the given solutions in sequence before trying the other solutions. 

"A fatal exception 0D has occurred at 0028:C0002840 in Vxd_vmm.(01) + 00001840."  -- Solution 2. 

"Isset_se caused a General Protection Fault in Setup.exe" -- Solution 1. 

"MS Setup Toolkit API Error, Bad Arg 3:AddSectionFiles to CopyList." -- Solutions 1, 9, 4, 7. 

"Not enough disk space on target drive while decompressing to [pathname]" installing Photoshop 5.0.x -- Solutions 1, 7. 

"Not enough disk space on target drive while attempting to copy files. To continue, first free disk space on the target drive and then 
click OK" installing Photoshop 3.0.x or 4.0.x  -- Solutions 1, 8, 9, 7. 

"Setup is unable to initialize the setup program. There may be a scripting error" or 
"Setup is unable to load the installation script file." -- Solutions 1, 2, 3, 5. 

"Please insert disk #" (e.g., disk 8), or 
"General File Transfer error. Please check your target location and try again," or "General File Transfer error -5," or
"The read-only file, C:\Adobe\Photoshop\Psicon.dll was found while attempting to copy files to the destination location"  -- Solutions 
1, 10, 2, 8, 9, 7, 4, 3. 

"Unable to create a directory under C:\Windows\System. Please check write-access to the directory." -- Solutions 1, 6. 

Cleaning Up After an Installation Fails
Each time an error or freeze interrupts the Photoshop installation, you must remove temporary files from the hard drive and any of the 
Photoshop application files that were installed before you try the next solution. Doing so frees up hard drive space and removes any 
damaged files that the installer can't overwrite. 

Deleting Previous Installations of Photoshop
To delete previous installations of Photoshop:



1. Move any personal files (e.g., images, third-party plug-ins) out of the Photoshop directory and its subdirectories. 
2. Choose Start > Settings > Control Panel, double-click Add/Remove Programs, select Adobe Photoshop, and then click 

Add/Remove. 

Note: The control panel will return an error if you delete the Photoshop folder before running the Add/Remove Programs 
control panel. For more information, see document 317448 , "Error When Uninstalling Photoshop 4.0.x or later in Windows."

3. Navigate to the Photoshop folder (e.g., x:\Program Files\Adobe\Photoshop 5.0, where "x" is a drive letter). If it still exists, choose 
File > Delete.

Note: If Windows won't let you delete a file (e.g., Psicon.dll) because the file is in use, write down the location, restart the 
computer in MS-DOS mode (Windows 95 or Windows 98) or choose Start > Programs > Command Prompt (Windows NT 4.0), 
then disable the file by renaming (e.g., type "rename C:\Adobe\Photoshop\Psicon.dll Psicon.old"). Restart your computer in 
standard Windows mode, move the file to the Recycle Bin, and then delete the rest of the files and the directory. 

4. Click Yes in the Confirm Folder Delete dialog box.
5. Empty the Recycle Bin.

Deleting Temporary Files
To delete temporary files:
1. Choose Start > Find > Files or Folders. 
2. In the Named text box, type "*.tmp".
3. Choose My Computer (Windows 95) or Local Hard Drives (Windows 98 or Windows NT 4.0) from the Look In pop-up menu.
4. Click Find Now. 
5. When the search results appear, choose Edit > Select All.
6. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. 
7. Remove from the Recycle Bin any non-temporary files you want to keep, and then empty the Recycle Bin.

If Windows doesn't show you filename extensions, enable it to do so: 
1. In Windows Explorer, choose View > Options, then click the View tab.
2. Select Show All Files, deselect the option labeled, "Hide MS-DOS File Extensions for File Types that Are Registered" (Windows 

95 or Windows 98) or "Hide File Extensions for Known Files" (Windows NT 4.0), then click OK.

You should also make sure that there's adequate free space on the hard drive to which applications write temporary files (.tmp). You 
only need to do this once. Exit from all applications and then doing the following:
- In Windows 95 and Windows 98, edit the "Set Temp=" line in the Autoexec.bat file to specify a folder on a non-compressed hard 

drive that has sufficient free space:
1. Make a backup copy of the Autoexec.bat file.
2. Open the original Autoexec.bat file in a text editing application that can save in text-only format (e.g., Windows Write, 

Notepad).
3. Locate the line that begins

Set temp=

The folder designated on the right of the equal sign is where Windows stores most of its temporary files. 

4. Note the drive letter and folder name (e.g., C:\Temp). If this line does not exist, you will create it in step 7. 
5. In Windows Explorer, verify that the drive and folder exist. If the drive does not exist, choose another drive. If the folder 

does not exist, create it by clicking the drive, then choosing File > New > Folder, and then naming the folder "Temp".
6. Make sure that the drive has at least 50 MB of free space by right-clicking it, then choosing Properties from the pop-up 

menu, and then noting the Free Space field. If the drive does not have enough space, either remove unnecessary files 
from it or edit the line in the Autoexec.bat file to specify a drive that does have enough space. 

7. In the Autoexec.bat file, if this line does not exist, add it using the following format:

Set temp=C:\Temp

Where "C" is a drive with enough free space and "Temp" is the folder you verified or created.

8. Save the Autoexec.bat file in text-only format.
9. Restart Windows.

- In Windows NT 4.0, edit or add the TEMP user variable on the Environment tab of the System Control Panel to specify a folder 
on a non-compressed hard drive that has sufficient free space:
1. Choose Start > Settings > Control Panel, then double-click System, and then click the Environment tab. 
2. In the User Variables section, locate TEMP in the Variable column. The folder designated in the Value column is the 

folder where Windows stores most of its temporary files. 



NOTE: This section may also list a TMP variable. Some applications use the TMP variable for their temporary files, while 
others (including Photoshop) use the TEMP variable. Although you can assign different drives and folders to either 
variable, you'll have an easier time removing temporary files if Windows stores them in one place.

3. Note the drive letter and folder name (e.g., C:\Temp) in the Value column. If the hard drive is designated as 
"%SystemDrive%," this is the same hard drive on which the Winnt folder resides. If this value does not exist, you will create 
it in step 6. 

4. In Windows NT 4.0 Explorer, verify that the drive and folder exist. If the drive does not exist, choose another drive. If the 
folder does not exist, create it by selecting the drive, then choosing File > New > Folder, and then naming the folder 
"Temp".

5. Make sure that the drive has at least 20-50 MB of free space by right-clicking it and then choosing Properties from the 
pop-up menu to see the Free Space field on the General tab. If the drive does not have enough free space, either remove 
unnecessary files from it or edit the value of the TEMP variable to specify a drive that does have enough free space. 

NOTE: Check with your system administrator before editing or adding a variable; you may need to have Administrator 
access.

6. If the TEMP variable does not exist in the User Variables section, type TEMP in the Variable text box. If the TEMP 
variable exists, select the variable name. Then type the following in the Value text box:

C:\Temp

Where "C" is a drive with enough free space and "Temp" is the folder you verified or created.

7. Click Set and then click OK.
8. Restart Windows.

Solutions
Do one or more of the following, writing down any changes in the installer's behavior or error. Keeping a log will help you 
troubleshoot if the problem turns out to be a complex one. 

Solution 1
Copy the installer files from the CD to your hard disk, restart Windows in Safe Mode (Windows 95 or 98) or VGA Mode (Windows NT 
4.0), then install Photoshop:
1. Exit from all applications.
2. Delete temporary files. 
3. Delete previous installations of Photoshop. 
4. Insert the Photoshop Application CD into the CD-ROM drive.
5. In Windows Explorer, double-click the CD-ROM drive to open it.
6. Locate the Photoshop directory and copy it to your hard disk. Leave this copy of the setup files on your hard drive until you 

install successfully. 

Note: If an error occurs when copying files from the CD, it may be dusty, damaged, or you may have a problem with your 
CD-ROM drive or driver. Clean the CD and caddy with a soft, lint-free cloth to ensure that they are free of dust and fingerprints. 
Try copying files from other CDs to your hard disk to ensure your CD-ROM drive is working properly. If you cannot copy files from 
other CDs, contact your CD-ROM drive's manufacturer or the computer's manufacturer. If you can copy files from other CDs, but 
not the Photoshop CD, contact Adobe Technical Support.

7. In Windows 95 or Windows 98, move all icons and shortcuts from the Windows\Start Menu\Programs\StartUp folder to another 
folder. In Windows NT 4.0, move all icons and shortcuts from the Winnt\Profiles\<Current User>\Start Menu\Programs\Startup 
and Winnt\Profiles\All Users\Start Menu\Programs\Startup folders to two other folders. 

8. Exit from Explorer.
9. Disable your virus protection software. 
10. Restart the computer in Safe Mode (Windows 95 or Windows 98) or VGA Mode (Windows NT 4.0): 

- Safe Mode: Hold down the F5 key (Windows 95) or the Ctrl key (Windows 98). Click OK in the Desktop dialog box indicating 
that Windows is running in Safe Mode. 

- VGA Mode: Choose the menu choice Windows NT 4.0 Workstation Version 4.00 (VGA Mode). If this menu doesn't appear 
or flashes by too quickly, chose Start > Settings > Control Panel, double-click System, and choose the Startup/Shutdown 
tab. Increase the Show list for . . . seconds option in the System Startup. 

11. Double-click the Setup.exe file in the Photoshop folder on your hard disk. Follow the prompts to complete the installation.
12. Restart Windows in Normal mode.

Solution 2



Disable hard drive compression or clear enough disk space on a hard drive without compression and then follow Solution 1. For more 
information, check your compression software documentation, or your Windows documentation for compression built into Windows. 

Solution 3
Optimize and defragment the hard drive(s) and then follow Solution 1. In Windows 95 and Windows 98, use the included ScanDisk 
and Disk Defragmenting utilities by choosing Start > Programs > Accessories > System Tools. In Windows NT 4.0, scan the hard 
drive(s) for errors by entering the "CHKDSK/f" command at the Command Prompt, and then defragment the hard drive(s) with a 
Windows NT 4.0-compatible third-party utility.

Solution 4
Re-create the virtual memory swap file (Windows 95) or paging file (Windows NT 4.0) to make sure that it isn't damaged and then 
follow Solution 1:
- In Windows 95, re-create the swap file by specifying a fixed virtual memory setting: 

1. Exit from all applications.
2. Create a Windows startup disk by choosing Start > Settings > Control Panel, then double-clicking Add/Remove Programs, 

then clicking the Startup Disk tab, and then following the on-screen instructions. (After changing system settings, such as 
virtual memory, Windows may be unable to start, so you may need a startup disk.)

3. Choose Start > Settings > Control Panel; double-click System, then click the Performance tab, and then click Virtual 
Memory.

4. Select "Let Me Specify My Own Virtual Memory Settings." 
5. From the Hard Disk pop-up menu, choose a hard drive that has at least twice the amount of your computer's installed RAM. 

For example, if your computer has 24 MB of RAM, choose a hard drive that has at least 48 MB of free space. (To check 
how much free space a drive has, start Windows Explorer, then right-click the drive, and then choose Properties from the 
pop-up menu and note the Free Space field.)

6. In both the Minimum and Maximum text boxes, enter a value equal to twice the amount of your computer's installed RAM.
7. Click OK to close the Virtual Memory dialog box. 
8. Click Yes when you see the message, "You have chosen not to let Windows manage virtual memory automatically . . ." in 

the Confirm Virtual Memory Setting dialog box.
9. Click Close in the System Properties dialog box.
10. Restart Windows by clicking Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the startup disk 

and then restart Windows.
11. Follow Solution 1. 

- In Windows NT 4.0, re-create the virtual memory paging file:
1. Exit from all applications. 
2. Choose Start > Settings > Control Panel, then double-click System, and then click the Performance tab.
3. In the Virtual Memory section, click Change.
4. From the Drive list, select a hard drive that has at least twice the amount of your computer's installed RAM. For example, if 

your computer has 24 MB of RAM, select a hard drive that has at least 48 MB of free hard drive space. For best 
performance, choose a hard drive not used for the Photoshop scratch disk(s).

5. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your 
computer's installed RAM plus 12 MB. 

6. In the Maximum Size box, enter a value equal to twice the amount of your computer's installed RAM.
7. Click Set and then click OK.
8. Click OK to close the System Properties dialog box.
9. To restart Windows, click Yes in the System Settings Change dialog box. 
10. Follow Solution 1. 

Solution 5
Update to a newer version of your video driver and then follow Solution 1. install Photoshop. Contact the video driver manufacturer 
to see if a newer version is available.

Solution 6
Contact your hard disk or controller card manufacturer to see if they have any device software updates. If you have a SCSI controller 
for your hard drives, check the SCSI card for incorrect settings, drivers, hardware damage, or cable damage. For instructions, contact 
the SCSI card manufacturer. Then, follow Solution 1. If you can't contact these manufacturers, check for hard disk problems by 
installing Photoshop on a different hard disk. 

Solution 7
Backup and edit the registry, and then reinstall Photoshop:

Disclaimer: Adobe does not support problems that result from improperly modifying the registry. The registry contains critical system 
and application information. Make sure to back up the registry before modifying it. For more information, refer to your Windows 
documentation or contact Microsoft.

1. Exit from all applications.



2. Delete temporary files. 
3. Delete previous installations of Photoshop. 
4. Choose Start > Run. Type "regedit" in the Open text box and click OK.
5. Choose Registry > Export Registry File. Choose a location and name for the backup file, and then click Save in the Export 

Registry File dialog box.
6. Select the HKey_Local_Machine\Software\Kodak key in the left side of the Registry Editor window.
7. Choose Edit > Delete. If installing Photoshop 5.0.x, continue to the next step. If installing Photoshop 4.0.x, skip to step 13. 
8. Select the HKey_Local_Machine\Software\Microsoft\Windows\CurrentVersion key in the left side of the Registry Editor window.

Note: Make sure to select the Windows key, not the key named for the version of Windows that you are using (e.g., Windows 95). 

9. Double-click CommonFilesDir in the right side of the Registry Editor window. 
10. Ensure the Value Data text box reads "X:\Program Files\Common Files" (where X designates the startup disk) and click OK in the 

Edit String dialog box.
11. Double-click ProgramFilesDir in the right side of the Registry Editor window.
12. Ensure the Value Data text box reads "X:\Program Files" (where X designates the startup disk) and click OK in the Edit String 

dialog box.
13. Choose Registry > Exit. 
14. Double-click the Setup.exe file in the Photoshop folder on your hard disk. If installing Photoshop 5.0.x, continue to the next 

step. If installing Photoshop 4.0.x, follow the prompts to complete a typical installation. 
15. Click Next in the Welcome dialog box. Click Next in the Select Country dialog box. Click Accept in the Software License 

Agreement dialog box.
16. Select Custom and then click Next in the Set Up dialog box. 
17. Deselect Adobe Online and Cmap Files and then click Next in the Select Components dialog box.

Note:  Adobe Online enables you to go to the Adobe Web site by clicking on Photoshop's tool bar. When the Adobe Online 
files aren't installed, you cannot access Adobe's Web site directly from Photoshop. The Cmap files enable you to use foreign 
language fonts in Photoshop. You can custom install these files after you've successfully installed the rest of the program. 

18. Click Next in the Start Copying Files dialog box. Follow the prompts to complete the installation.

Solution 8
Make sure you have read/write access to the drive containing the Kpcms directory before installing Photoshop:
1. Exit from all applications.
2. Delete temporary files. 
3. Delete previous installations of Photoshop. 
4. In File Manager or Windows Explorer, double-click on the Kpcms.ini file in the Windows directory.
5. Write down the drive letter specified after the [KEPS Precision] line, and ask your network administrator to give you read/write 

access to that drive. 
6. Follow Solution 1.

Solution 9
Rename the Kpcms.ini file in the Windows directory (e.g., to Kpcms.old), and then follow Solution 1. 

Solution 10
Create a new folder with a name of eight characters or less (e.g., C:\Pshop). Follow Solution 1, but with the following changes: 
- Custom install everything but Photoshop's Program Files, then do a custom install of Photoshop's Program Files.
- Install Photoshop to the new folder instead of the default folder.

What to Do If These Solutions Don't Work
If the previous section does not solve your installation problems, your operating system or hardware is probably conflicting with 
Photoshop's installer. 

You could reinstall Windows to a new folder, copy the installer files from the CD to your hard disk, and install Photoshop by following 
Solution 1. Before doing this, make sure you have all application and operating system disks, and that (for Windows NT 4.0) you've 
downloaded the latest Service Pack and stored it on an external drive. For instructions on reinstalling Windows 95 to a new folder, 
see the Microsoft Knowledge Base article Q142096 at http://support.microsoft.com/support/kb/articles/q142/0/96.asp. For Windows 98, 
see article Q193902 at http://support.microsoft.com/support/kb/articles/q193/9/02.asp.  For Windows NT 4.0, consult your 
documentation or Microsoft. 

You could try some of the solutions in document 318576 , "How to Troubleshoot System Errors or Freezes in Photoshop for Windows 
95," document 322406 , "How to Troubleshoot System Errors or Freezes in Photoshop for Windows 98," or document 317889 , "How 
to Troubleshoot System Errors or Freezes in Photoshop for Windows NT 4.0." 

As a last resort, you could reformat the drive, then install only Windows and Photoshop. Before you do, make sure you have all 
application and operating system disks, and that you've downloaded the latest Service Pack and stored it on an external drive. Do not 



install any additional software or hardware until you've successfully installed Photoshop. 

Note: Reformatting the drive will erase all files. Before reformatting, make sure you've backed up all the data files for all your 
applications. Don't back up your hard drive and restore Windows and your applications instead of reinstalling, however. If the problem 
is caused by an application or Windows, restoring them may cause the problem to occur again.
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Photoshop 5.0 Installer Screen Does Not Reappear After Verification of Photoshop 4.0.x CD in 
Windows 95

Issue
After you eject the Adobe Photoshop 4.0 CD-ROM during the Photoshop 5.0 upgrade installer's verification process in Windows 95, 
the Photoshop 4.0 AutoPlay screen (i.e., the screen that says, "Adobe Photoshop 4.0, please make a selection") remains. The 
Photoshop 5.0 installer screen does not reappear, even if you reinsert the Photoshop 5.0 CD. 

Solutions
Do either or both of the following:

Solution 1
Press Esc to exit from the Photoshop 4.0 AutoPlay screen. If the Photoshop 5.0 installer screen does not reappear (you may have to 
wait a little while), try the next solution.

Solution 2 
Eject whichever CD is in the CD drive and then restart the computer. Insert the Photoshop 5.0 CD and then start the installer. After 
you select "Verify original Photoshop diskette or CD," hold down the Shift key while you insert the Photoshop 4.0 CD to disable the 
Photoshop 4.0 AutoPlay screen. 

Additional Information
The Photoshop 5.0 upgrade installer searches your hard drive for a previous version of Photoshop. If the installer locates one, it 
automatically continues the installation; otherwise, it prompts you to insert either the CD or a disk from the previous version. 

The Photoshop 4.0 AutoPlay screen appears each time you insert the Photoshop 4.0 CD. On older computers (e.g., 486s), the 
Photoshop 5.0 installer screen may take some time to reappear after removing the Photoshop 4.0 CD during the verification process.

Photoshop 3.0.x and earlier's installers do not have an AutoPlay screen.
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Photoshop 5.0 Upgrade Installer Won't Verify Disk Images of Photoshop on the Hard Drive

Issue
When you install the Adobe Photoshop 5.0 upgrade and click Verify Original Photoshop Diskette or CD, the installer returns the error, 
"Verification Error: A qualifying version of Photoshop was not detected. Please try again or cancel the installation. If you have a valid 
copy of Photoshop that was not detected, please call Adobe Customer Service for assistance."

Detail
You are attempting to verify Photoshop 4.x or earlier a disk images (i.e., copies of the installer files) on your hard drive and not a 
Photoshop 4.x or earlier installation disk or CD-ROM.

Solution
Verify the original Photoshop 4.0.x or earlier installation disk or CD.

Additional Information
To prevent software piracy, Photoshop 5.0's upgrade installer verifies the installation or original media of your earlier versions of 
Photoshop to make sure those who upgrade actually have an earlier version.
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Photoshop's Preferences Files General Information

Adobe Photoshop's preferences files contain application settings (e.g., general display options, calibration options, separation setup 
information, tool options, palette positions, unsaved actions). The preferences files also contain information about the location of 
Photoshop's Plug-ins folder, which Photoshop uses to find and load plug-ins. In Photoshop 5.0.x for Mac OS, the Adobe Photoshop 5 
Paths file directs third-party plug-in installers (e.g., Extensis PhotoTools or Nowhouse Propeller Paint Engine) to the location of the 
plug-ins folder. Photoshop 5.0.x for Windows does this with a registry key.

A damaged preferences file can cause unexpected Photoshop behavior (e.g., tools don't work, plug-ins are unavailable, menu items 
are dimmed, out-of-memory errors, or errors when starting). When you rename a preferences file then restart and exit Photoshop, a 
new one is created, often correcting the problem. If the problem continues with the new preferences file, it may be that your original 
preferences file was not the cause (e.g., a device driver or extension is corrupting the preferences). You can restore your (custom) 
settings by deleting the newly created preferences file and restoring the original file name. If you deleted the original preferences 
file, your custom settings, and unsaved actions (Photoshop 4.0.x), are lost. 

Photoshop's Preferences File Name and Location
Each version of Photoshop has a different name for its preferences file, so if you have multiple versions of Photoshop installed, each 
uses its own custom preferences settings. Photoshop's preferences files and their locations are listed below.

Photoshop for Mac OS
Photoshop 2.5.x and later automatically create and save their preferences file in the Preferences folder in the System Folder. 
Photoshop 2.0.x and earlier prompt you to locate the preference file, or create the preferences file and specify its location, if they 
cannot find an existing one during startup.

Photoshop Version Preferences File's Name Location
Photoshop 5.5 Adobe Photoshop 5 Prefs Adobe Photoshop 5.5:Settings
Photoshop 5.5 Actions Palette Adobe Photoshop 5.5:Settings
Photoshop 5.5 Color Settings Adobe Photoshop 5.5:Settings
Photoshop 5.5 Adobe Photoshop 5.5 Paths System Folder:Preferences folder
Photoshop 5.0 Adobe Photoshop 5 Prefs Adobe Photoshop 5.0:Adobe Photoshop

Settings folder
Photoshop 5.0 Actions Palette Adobe Photoshop 5.0:Adobe Photoshop

Settings folder
Photoshop 5.0 Color Settings Adobe Photoshop 5.0:Adobe Photoshop

Settings folder
Photoshop 5.0 Adobe Photoshop 5 Paths System Folder:Preferences folder
Photoshop 4.0.x Adobe Photoshop 4.0 Prefs System Folder:Preferences folder
Photoshop 3.0.x Adobe Photoshop 3.0 Prefs System Folder:Preferences folder
Photoshop 3.0.x LE Adobe Photoshop LE Prefs System Folder:Preferences folder
Photoshop 2.5.x Photoshop Prefs System Folder:Preferences folder
Photoshop 2.5 LE Photoshop LE Prefs System Folder:Preferences folder
Photoshop 2.0.x - 1.0.x PS Prefs Photoshop's Plug-ins folder or selected folder

Photoshop for Windows
Photoshop 4.0.x and 3.0.5 save their preferences files in the Photoshp\Prefs directory. Photoshop 3.0.4 and earlier save their 
preferences files in the Windows directory.

Photoshop Version Preferences Files' Names Location
Photoshop 5.5 Adobe Photoshop 5.5 Prefs.psp Program Files\Adobe\Photoshop 5.0\Settings 
directory
Photoshop 5.5 Actions Palette.psp Program File\Adobe\Photoshop5.0\Settings
Photoshop 5.5 Color Settings.psp Program Files\Adobe\Photoshop5.0\Settings
Photoshop 5.0 Adobe Photoshop 5 Prefs.psp Program Files\Adobe\Photoshop 5.0\Adobe 
Photoshop

Settings directory
Photoshop 5.0 Actions Palette.psp Program File\Adobe\Photoshop5.0\Adobe 

Photoshop
Settings directory

Photoshop 5.0 Color Settings.psp Program Files\Adobe\Photoshop5.0\Adobe 
Photoshop

Settings directory



Photoshop 4.0.x Photos40.psp and Ccolorsd Photoshop 4.0.x\Prefs subdirectory
Photoshop 3.0.5 Photos30.psp and Ccolorsd Photoshp\Prefs subdirectory
Photoshop 3.0.5 LE Phot30le.psp and Ccolorsd Photosle\Prefs subdirectory
Photoshop 3.0.4 - 3.0 Photos30.psp and Ccolorsd Windows directory
Photoshop 3.0.4 LE - 3.0 LE Phot30le.psp and Ccolorsd Windows directory
Photoshop 2.5.x Photoshp.psp and Ccolorsd Windows directory
Photoshop 2.5 LE Photosle.psp and Ccolorsd Windows directory

Recreating Photoshop's Preferences File
You can recreate Photoshop's preferences file if you want to restore Photoshop's default settings or troubleshoot unexpected behavior. 
Because Photoshop's installer does not install the preferences file, reinstalling Photoshop does not create a new one.

Photoshop for Mac OS
To recreate the preferences files for Photoshop 5.0:
1. Quit Photoshop.
2. Rename the appropriate Adobe Photoshop 5 Prefs, Color Settings, and/or Actions Palette files in the Adobe Photoshop 

5.0:Adobe Photoshop Settings folder. If necessary, also rename the Adobe Photoshop 5.0 Paths file in the System 
Folder:Preferences folder.

3. Restart Photoshop.

NOTE: If the Plug-ins folder is in a folder other than the Adobe Photoshop 5.0 folder and you rename the Adobe Photoshop 5 
Prefs file, when you restart Photoshop you may need to retarget the Plug-ins folder. See instructions below.

To recreate the preferences file for Photoshop 4.0.x, 3.0.x, and 2.5:
1. Quit Photoshop.
2. Rename the Adobe Photoshop 4.0 Prefs (Photoshop 4.0.x), Adobe Photoshop 3.0 Prefs (Photoshop 3.0.x), or Photoshop Prefs 

(Photoshop 2.5.x) file in the System Folder:Preferences folder.
3. Restart Photoshop.

To recreate the preferences file for Photoshop 2.0.x and earlier:
1. Quit Photoshop.
2. Rename all files named "PS Prefs." You can use the Find File utility to find files by choosing File > Find (or by choosing Find 

File from the Apple menu).
3. Start Photoshop. 
4. In the Where is the Preferences File? dialog box, select the Plug-ins folder, then click Open.
5. Click New to create a new preferences file, then click Save to save the file named PS Prefs in the Plug-ins folder.

Photoshop for Windows
To recreate the preferences files for Photoshop 5.0:
1. Exit from Photoshop.
2. Rename the appropriate Adobe Photoshop 5 Prefs.psp, Actions Palette.psp, and/or Color Settings.psp files in the Adobe 

Photoshop 5.0\Adobe Photoshop Settings directory.
3. Restart Photoshop.

NOTE: If the Plug-ins folder is located in a folder other than the Adobe Photoshop 5.0 folder and you rename the Adobe 
Photoshop 5 Prefs file, when you restart Photoshop you may need to retarget the Plug-ins folder. See instructions below.

To recreate the preferences files for Photoshop 4.0.x and 3.0.x:
1. Quit Photoshop.
2. Rename the Ccolorsd file, and the Photos40.psp file (Photoshop 4.0.x) or the Photos30.psp (Photoshop 3.0.x) file, which are in 

the Photoshp\Prefs subdirectory (Photoshop 4.0.x and 3.0.5) or in the Windows directory (Photoshop 3.0 and 3.0.4).
3. Restart Photoshop.

To recreate the preferences files for Photoshop 2.5.x:
1. Quit Photoshop.
2. Rename the Photoshp.psp and Ccolorsd files, which are in the Windows directory.
3. Restart Photoshop.

Retargeting the Plug-ins Folder
When you retarget the Plug-ins folder, Photoshop rewrites the location of the Plug-ins folder in its preferences file.

Photoshop for Mac OS
To retarget the Plug-ins folder in Photoshop 5.0 or 4.0.x:
1. In Photoshop, choose File > Preferences > Plug-ins & Scratch Disks.
2. Verify that the line of text in the Plug-Ins Folder section specifies the Plug-ins folder. If it specifies another folder or is blank, 

click Choose.



3. In the Select the Plug-ins Folder dialog box, click once on the Plug-ins folder to select it.
4. Click Select "Plug-ins" below the scroll box.
5. Click OK to exit the Plug-ins & Scratch Disks Preferences dialog box.
6. Restart Photoshop.

To retarget the Plug-ins folder in Photoshop 2.5.x and 3.0.x:
1. In Photoshop, choose File > Preferences > Plug-ins.
2. In the Select the Plug-ins Folder dialog box, click once on the Plug-ins folder to select it.
3. Click the Select "Plug-ins" button, which appears below the scroll box.
4. Restart Photoshop.

Photoshop for Windows
To retarget the Plug-ins directory in Photoshop 5.0 or 4.0.x:
1. In Photoshop, choose File > Preferences > Plug-ins & Scratch Disks.
2. Verify that the path in the Plug-Ins Folder section specifies the Plug-ins directory. If it specifies another directory or is blank, click 

Choose, select the Photoshop Plug-ins directory, then click OK.
3. Click OK to exit the Plug-ins & Scratch Disks Preferences dialog box.
4. Restart Photoshop.

To retarget the Plug-ins directory in Photoshop 3.0.x:
1. In Photoshop, choose File > Preferences > Plug-ins.
2. Click once to select the Photoshop Plug-ins directory, then click OK.
3. Restart Photoshop.
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Optimizing Performance in Photoshop 4.0.x and 5.0 for Mac OS

What's Covered
Photoshop Options and Plug-ins
Image Files
Operating System Software 
Hardware
Mac OS Resources

Available random-access memory (RAM) and computer processor speed have the greatest effect on Adobe Photoshop's performance. 
Other factors, however, such as the options you select, your workflow, and the operating system and hardware configuration, can also 
affect Photoshop's performance. These options are discussed in this document, as well as in Appendix A (Improving Performance) of 
the Photoshop 4.0 User Guide and the Appendix (Troubleshooting) of the Photoshop 5.0 User Guide. Optimizing the operating 
system and hardware configuration will improve performance in other applications as well. 

Photoshop Options and Plug-ins
The options you select and plug-ins you use in Photoshop can affect its performance. The options and plug-ins that most directly 
affect performance include the Image Cache option, the Scratch Disk option, the Export clipboard option, the Enable Async I/O 
plug-in, the Detect Watermark plug-in, and the option for using preview thumbnails in palettes.

Adjusting the Image Cache
Photoshop 4.0 and later uses image caching to redraw high-resolution images on-screen faster. With image caching, Photoshop 
quickly updates a low-resolution version of an image as you edit it. To enable the Image Cache option, you specify the number (1 to 
8) of low-resolution versions you want Photoshop to store (cache). The more versions you specify, however, the slower Photoshop will 
open image files. Photoshop's default Image Cache setting is 4. Setting the Image Cache option to 1 disables image caching; only 
the active screen image is cached.

NOTE: Image Caching may cause a less accurate preview. When needed, view files at 100% to ensure an accurate preview.

To adjust the Image Cache setting:
1. Choose File > Preferences > Image Cache.
2. Enter a value from 1 to 8 in the Cache Levels text box. Click OK.
3. Restart Photoshop.

Setting Scratch Disks
A scratch disk in Photoshop is similar to virtual memory in Mac OS. For the best performance you should set the Primary (Photoshop 
4.0.x) or First (Photoshop 5.0) scratch disk to a defragmented hard drive that has plenty of unused space and fast read/write speeds 
(rather than a network drive or removable media such as a Zip or JAZ drive). Photoshop requires at least 25 MB (Photoshop 4.0.x) or 
80 MB (Photoshop 5.0) of free hard drive space, but more is recommended. If you have more than one hard drive it is suggested that 
you specify additional scratch disks. Photoshop 4.0.x supports up to 2 GB of scratch disk space on a total of 2 volumes; Photoshop 5.0 
supports up to 200 GB of scratch disk space on a total of 4 volumes. 

To set the Scratch Disk preference:
1. Choose File > Preferences > Plug-Ins & Scratch Disks
2. Choose the drive that has the most free space from the Primary (Photoshop 4.0.x) or First (Photoshop 5.0) pop-up menu.
3. Choose a second drive, if available, from the Secondary (Photoshop 4.0.x) or Second (Photoshop 5.0) pop-up menu.
4. If you are using Photoshop 5.0, choose other drives, if available, from the Third and Fourth pop-up menus.
5. Click OK.
6. Restart Photoshop.

Deselecting Export Clipboard
The Export Clipboard setting allows Photoshop to export anything copied to the clipboard as a PICT file. The exporting is time 
consuming, however, and occurs whenever you quit Photoshop or go from Photoshop to another application. Deselecting this setting 
increases Photoshop's performance.

To deselect Export Clipboard:
1. Choose File > Preferences > General.
2. Deselect Export Clipboard.
3. Click OK.
4. Restart Photoshop.



Using the Enable Async I/O Plug-in
The Enable Async I/O plug-in installed with Photoshop 4.0.x enables faster disk operations (read and write speed). The Enable Async 
I/O plug-in requires a Power Macintosh or Macintosh AV model that has a hard drive formatted with a utility compatible with Apple 
SCSI Manager 4.3.1 or later.

The Enable Async I/O plug-in is disabled by default. After you enable it, an asterisk appears after the Efficiency percentage (e.g., 
100%*) in the lower left of Photoshop's image window. To view the Efficiency percentage, choose Efficiency from the pop-up menu 
in the lower left of the image window.

To enable the Enable Async I/O plug-in:
1. Quit Photoshop.
2. In the Finder, locate Photoshop's Plug-ins:Extensions:~Enable Async I/O folder.
3. Delete the tilde ("~") from the beginning of the ~Enable Async I/O folder name.
4. Restart Photoshop. (Replace the tilde to disable the plug-in.)

Using the Detect Watermark Plug-in
Photoshop 4.0 and later include the Digimarc Corporation's Detect Watermark, Embed Watermark, and Read Watermark digital 
watermarking plug-ins. The Detect Watermark plug-in checks each image you open for a digital watermark, which increases the time 
it takes for Photoshop to open the file. If the plug-in detects a watermark, a copyright symbol appears on the image window's title bar. 
You can find the source of the image by choosing Filter > Digimarc > Read Watermark. 

To disable the Detect Watermark plug-in:
1. Quit Photoshop.
2. In the Finder, locate Photoshop's Plug-ins:Digimarc folder.
3. Type a tilde ("~") at the beginning of the Detect Watermark plug-in's filename or move the Detect Watermark plug-in from the 

Plug-ins folder (e.g., move it to the desktop).
4. Restart Photoshop.

For updated Digimarc plug-ins, check Digimarc's Web site at http://www.digimarc.com. Make sure to install the updated plug-ins you 
download into Photoshop's Plug-ins:Digimarc folder. 

Minimizing Palette Preview Thumbnails
Photoshop requires additional memory to display preview thumbnails in the Layers, Channels, and Paths palettes. Photoshop 
updates the preview thumbnails as you make changes to an image. The more preview thumbnails Photoshop displays, and the larger 
their size, the more memory Photoshop requires to draw and update them.

To minimize or disable thumbnail previews in palettes, choose Palette Options from the palette's pop-up menu, then select the 
smallest size or None for Thumbnail Size, then click OK. 

Image Files
You can optimize your work flow to improve Photoshop's performance by minimizing file size, editing individual channels, using the 
Quick Edit feature, and using image compression selectively. Additionally, because layers and channels significantly add to the size 
of a file, you can minimize file size by merging layers and deleting channels as they are no longer needed. Finally, if you are 
preparing images for color separation, you can work in RGB mode until you are ready to print and then change the images to CMYK 
mode.

Minimizing Resolutions
You can minimize the size of your files by reducing their resolution, which is measured in pixels per inch (PPI). Photoshop requires 
more memory and disk space to process high-resolution images, therefore increasing the time it takes to display, process, and print 
them. Increasing the resolution of an image does not always improve the quality of the image, but may instead only increase its file 
size. You want the resolution of images to be the highest value your printer can use. Resolutions higher than that only add 
information that your printer can't use, but must process, thereby increasing print times.

For continuous-tone images (e.g., photographs) you plan to print, begin by using a resolution that is 1.5 to 2 times the screen 
frequency, measured in lines per inch (lpi), that you'll use to print the image. For line-art images (e.g., drawings), use the same value 
as your printer's resolution, measured in dots per inch (dpi). For example, if the resolution of your printer is 600 dpi, and you plan to 
print the image using the printer's default screen frequency of 85 lpi, save continuous-tone images at a resolution between 127 ppi 
(85 lpi x 1.5) and 170 ppi (85 lpi x 2), and save line-art images at a resolution of 600 ppi.

Recommended resolutions for continuous-tone images:
Output Recommended resolution
Mac OS monitor 72 ppi
Windows-compatible monitor 96 ppi
300 dpi laser printer 100 ppi
600 dpi laser printer 150 ppi
725 dpi inkjet printer 150 ppi



1200 dpi or higher imagesetter 1.5 times the screen frequency (lpi) value specified 

For more information on resolution and lpi, see Related Records.

To reduce the resolution of an image in Photoshop:
1. Open the image, then choose Image > Image Size. 
2. In the Image Size dialog box, decrease the Resolution value, then click OK.

Minimizing the Number of Layers
Layers make many operations in Photoshop dramatically easier, but they also increase file sizes. After you have completed changes 
to layers, you can flatten (merge) them to reduce a file's size. You should also make sure to remove blank layers from the file since 
they too increase its size. It is important to remember that Photoshop does not let you separate layers after merging them. Instead, 
you can either use the Undo command or you can use Photoshop 5.0's History palette to reverse a merge.

- To flatten all layers in a file, choose Layer > Flatten Image.
- To merge a layer with the layer below it:

1. In the Layers palette, select the layer above the layer with which you want to merge it.
2. Choose Layer > Merge Down. 

Saving Files Without Composited Images
If you select 2.5 Compatibility (Photoshop 4.0.x) or Include Composited Image With Layered Files (Photoshop 5.0), Photoshop 
includes a composite image layer with each layered file it saves, which increases the sizes of *.psd files. Deselecting this option 
enables smaller files.

To deselect the option for composited images:
1. Choose File > Preferences > Saving Files.
2. Deselect 2.5 Compatibility (Photoshop 4.0.x) or Include Composited Image With Layered Files (Photoshop 5.0).
3. Click OK.
4. Restart Photoshop.

Using Image Compression
Each of the BMP, CompuServe GIF, GIF89a, JPEG, EPS, Photoshop, and TIFF formats support compression. The BMP, GIF, 
GIF89A, JPEG and Photoshop formats have built-in compression -- files in these formats are always saved with compression. 
Compression is optional when saving TIFF and EPS files. Although compressed files generally have smaller sizes, Photoshop may 
take longer to open or save them. With the exception of images saved in Photoshop format, Photoshop must decompress the file to 
open it and then recompress the file to save it. You can improve performance by saving your file in compressed Photoshop format (a 
compression format in which there is no data loss) as you work. When you are finished editing the image, you can then save it in the 
format you want and apply any final compression . 

To save a TIFF file without compression in Photoshop:
1. Open the file and then choose File > Save As.
2. Name the file, choose TIFF from the Save As pop-up menu, and then click Save.
3. Deselect LZW Compression in the TIFF Options dialog box.

To save a Photoshop EPS file without compression in Photoshop:
1. Open the file and then choose File > Save As.
2. Name the file, choose Photoshop EPS from the Format pop-up menu, and then click Save.
3. In the EPS Options dialog box, choose either ASCII or Binary for encoding. (Do not select any of the JPEG options).

Applying Filters to Individual Channels
Photoshop requires less memory to apply a filter to a single channel than it does to apply a filter to multiple channels or to an entire 
image (a composite channel). In a flattened image, each RGB channel is about one-third the size of the file; each CMYK channel is 
about one-fourth the size. To edit a single channel, select the channel you want to edit in the Channels palette.

Using Quick Edit
Quick Edit lets you open and edit a portion of an image, rather than the entire image, which decreases the time Photoshop needs to 
open and modify the image. You can use Quick Edit with Photoshop 2.0, Scitex CT, or uncompressed TIFF images.

Photoshop 5.0 does not automatically install the Quick Edit plug-in. To install Quick Edit, quit Photoshop and then insert the 
Photoshop 5.0 CD-ROM; open the Other Goodies:Optional Plug-ins:Quick Edit folder, drag the Quick Edit file to the Photoshop 
Plug-ins folder on your hard drive, and then restart Photoshop.

To use Quick Edit:
1. Choose File > Import > Quick Edit.
2. Select the file you want to edit, then click Open.
3. In the Quick Edit dialog box, drag to select an area of the image, or select the Grid option and then select one of the image 



area tiles.
4. Click OK to open the image and then make the changes.
5. Choose File > Export > Quick Edit Save to save the changes with the original file.

Dragging and Dropping Between Files
Dragging and dropping layers or files is more efficient than copying and pasting them. Dragging bypasses the clipboard and transfers 
data directly. Copying and pasting can potentially involve more data transfer and is much less efficient. 

Operating System Software
By customizing your system so it runs efficiently, you not only increase the amount of memory available to applications, but also 
ensure that applications will run efficiently. By Increasing the amount of memory available to Photoshop, allocating more memory to 
it, quitting applications you are not using, or disabling nonessential extensions, you improve Photoshop's performance.

Restarting the Macintosh to Defragment Memory
Starting and quitting applications repeatedly can fragment the memory in Mac OS. Applications may be unable to access all the 
available memory if memory is fragmented, or is unavailable in a single, contiguous block. This can decrease their performance or 
may prevent them from starting. Restarting the Macintosh defragments its memory.

Allocating More Memory to Photoshop
Photoshop uses random-access memory (RAM) to process image information. The more RAM available to Photoshop, the faster 
Photoshop can process image information. If other applications are open, it decreases the amount of memory potentially available to 
Photoshop. Quitting applications you are not using makes more memory available to Photoshop. 

To allocate more RAM to Photoshop:
1. Quit Photoshop.
2. Start any applications you want to run simultaneously with Photoshop.
3. In the Finder, choose About This Macintosh (System 7.1.x and 7.5.x) or About This Computer (System 7.6.x and later) from the 

Apple menu.
4. Note the Largest Unused Block value, which is the total amount of available memory.
5. In the Finder, select the Adobe Photoshop application icon, then choose File > Get Info.
6. In the Adobe Photoshop Info window, enter a value for Preferred Size that is less than 90% of the Largest Unused Block value 

you noted in step 4.

NOTE: If you use RAM Doubler, do not allocate more than 90% of the installed RAM. See "System Extensions" below for more 
information.

7. Close the Adobe Photoshop Info window.

Optimizing Memory Control Panel Settings
Memory management options, such as virtual memory, can affect Photoshop's performance. Since Power Macintoshes use different 
memory management options than 68000-series Macintoshes, and other Macintoshes support varying memory management options, 
the options that appear in the Memory control panel can differ between Macintosh models and operating system versions. 

When virtual memory is enabled, your system uses hard-drive space to store information normally stored in memory (RAM). Because 
accessing information on a hard drive is slower than accessing it in memory, using virtual memory can decrease performance. In 
addition, the hard-drive space used for virtual memory cannot be used for Photoshop's scratch disk, which Photoshop uses to store 
image information as you work. If you need more memory when working in Photoshop, Adobe recommends installing more RAM.

To optimize the Memory control panel settings for Photoshop:
1. Choose Control Panels > Memory from the Apple menu.
2. Set the Disk Cache to a maximum of 128K.
3. Select Modern Memory Manager (Power Macintoshes running System 7.5.5 or earlier) or 32-bit Addressing (68000-series 

Macintoshes). If you are running System 7.5.6 or later on a Power Macintosh, the Modern Memory Manager option does not 
appear in the Memory control panel since this option is built-in to the system software and is always enabled.

4. Deselect RAM Disk.
5. Deselect Virtual Memory unless you do not have enough installed RAM for the recommended memory allocation to Photoshop.

Note: In Mac OS 8.x, you have more flexibility with the disk cache and Virtual Memory settings. If you have 64 MB of RAM or 
more, enabling Virtual Memory will not affect Photoshop's performance. If you have less than 64 MB of RAM, you should 
disable Virtual Memory. The same guideline apply to your Disk Cache settings in Mac OS 8.x. If you have less than 64 MB of 
RAM, set the Disk Cache to a maximum of 128K. If you have 64 MB of RAM or more, you can use larger Disk Cache settings. 
Apple recommends 32K of Disk Cache for every 1 MB of RAM installed.  

6. Restart the Macintosh.

System Extensions



System extensions and control panels use memory that could be made available to other applications, including Photoshop. If your 
Macintosh has a limited amount of memory, use Apple's Extensions Manager to disable nonessential extensions and control panels. 
Disabling nonessential extensions can also prevent extension conflicts. For more information about disabling extensions, see 
document 314385 , "Disabling Extensions and Isolating Extension Conflicts in System 7.x", or document 311687 , "Disabling 
Extensions and Isolating Extension Conflicts in Mac OS 8.0.x."

The Connectix RAM Doubler extension enables your system to use its proprietary virtual memory routines to simulate increased 
memory. Although Connectix has tested RAM Doubler with Photoshop and found it to be compatible, allocating only installed 
memory to Photoshop ensures optimum Photoshop performance, and allows applications in the background to use virtual memory. 

Hardware
Photoshop's performance is affected by the hardware you use: the faster the processor or hard drive, the faster Photoshop can process 
image information. Other hardware enhancements, such as installing additional RAM, using a multiprocessor system, or optimizing 
and defragmenting drives, can also improve Photoshop's performance.

Processor Speed
Photoshop's speed is limited by the speed of the Macintosh's CPU (Central Processing Unit). Since Photoshop manipulates large 
quantities of data and performs many calculations, its speed is greatly dependent on the processor's speed.

As a native PowerPC application, Photoshop can take advantage of PowerPC processors, which are faster than 68000-series (68K) 
processors. Photoshop can also take advantage of multiprocessor systems (i.e., systems that have two or more PowerPC processors), 
which are much faster than a single-processor system. All Photoshop features are faster on a multiprocessor system, while the 
advantage is greater for some.

Installed RAM
Photoshop requires memory (RAM) that is three to five times the file size of the image you are editing. If memory is insufficient, 
Photoshop uses hard-drive space (i.e., a scratch disk) to process information. Photoshop is fastest when it can process all or most 
image information in memory, without having to use the scratch disk. Allocate enough memory to Photoshop to accommodate your 
largest image file. 

Hard Drives
As you add, delete, and move files on a hard drive, its available space is no longer a single, contiguous block. If the system does not 
have enough contiguous space, it saves fragments of a file to different locations on the hard drive. It takes an application longer to 
read a fragmented file than one saved to a contiguous location. You can defragment files and optimize available hard drive space 
by using a disk utility (e.g., Speed Disk included with Symantec's Norton Disk Utilities for Macintosh, FWB Turbo ToolKit).

Since Photoshop reads and writes image information while editing an image, the faster the access speed of the drive containing the 
image or Photoshop's scratch disk, the faster Photoshop can process image information. To improve Photoshop performance, work on 
files saved on drives with fast access speeds, such as an internal hard drive, rather than those with slow access speeds (a network 
drive) or removable media (e.g., Zip or JAZ drive, disk). Removable media often have slower access times and are more easily 
damaged than internal hard drives.

Mac OS Resources
The following books and Web sites provide troubleshooting tips and further information about the Mac OS:

Books
The Mac OS 8 Book

The Ultimate Macintosh User's Guide, Craig Danuloff and Mark R. Bell: Ventana Communications Group, Inc., 1997. (ISBN: 
1566046882)

Macs for Dummies (5th Ed.)
David Pogue: IDG Books, 1997. (ISBN: 0764502255)

MacWorld Mac OS 8 Bible (6th Ed.)
Lon Poole: IDG Books Worldwide, 1997. (ISBN: 076454036X)

Beyond the Little Mac Book
Steve Broback and Robin Williams: Peachpit Press, 1997. (ISBN: 0201886669)

How Macs Work
John Rizzo and K. Daniel Clark: Ziff Davis Press, 1996. (ISBN: 1562764012)

The Little Mac Book
Robin Williams and Kay Yarborough Nelson: Peachpit Press, 1995. (ISBN: 1566091497)

More Macs for Dummies
David Pogue: IDG Books, 1997. (ISBN: 0764502670)

Sad Macs, Bombs, and Other Disasters: And What to Do About Them
Ted Landau: Peachpit Press, 1997. (ISBN: 0201688107)

Voodoo Mac: Mastery Tips and Masterful Tricks, 2nd Ed.
Kay Yarborough Nelson: Ventana Communications Group, Inc., 1994. (ISBN: 1566041775)



Web Sites
Apple Support: http://www.apple.com/support
Apple Tech Exchange: http://support.info.apple.com/te/te.qry
Mac Conflict Solution Site: http://www.quillserv.com/www/c3/c3.html
Mac Resource Page: http://www.macresource.pair.com
MacCentral Online: http://www.maccentral.com
MacFixIt Troubleshooting Solutions for the Macintosh: http://www.macfixit.com
MacDirectory: http://www.macdirectory.com
MacWeek: http://www.macweek.com
VersionTracker: http://www.versiontracker.com
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Optimizing Performance in Photoshop 4.0.x and 5.0 for Windows 95 and NT

What's Covered
Photoshop Options and Plug-ins
Image Files
Operating System Software 
Hardware
Windows Resources

Available random-access memory (RAM) and computer processor speed have the greatest effect on Adobe Photoshop's performance. 
However, other factors (e.g., the options you select, your workflow, and your operating system and hardware configuration), can also 
affect Photoshop's performance. These options are discussed in this document, as well as in Appendix A (Improving Performance) of 
the Photoshop 4.0 User Guide and the Appendix (Troubleshooting) of the Photoshop 5.0 User Guide. Optimizing your operating 
system and hardware configuration will also improve performance in other applications. 

Photoshop Options and Plug-ins
The options you select and plug-ins you use in Photoshop can affect its performance. The options and plug-ins that most directly 
affect Photoshop's performance include the Image Cache option, the Detect Watermark plug-in, and the palette thumbnails option.

Adjusting the Image Cache
Photoshop 4.0.x and 5.0 use image caching to redraw high-resolution images faster. With image caching, Photoshop uses 
low-resolution versions of an image to update the image quickly on-screen as you work. To enable the Image Cache option, you 
specify the number (1 to 8) of low-resolution versions you want Photoshop to store (cache). The more versions of an image you have 
Photoshop cache, however, the slower it opens image files. Photoshop's default Image Cache setting is 4. Setting the Image Cache 
option to 1 disables image caching; only the current screen image is cached, just as in versions of Photoshop previous to 4.0.x. 

To adjust the Image Cache setting:
1. Choose File > Preferences > Memory & Image Cache.
2. Enter a value from 1 to 8 in the Cache Levels text box.
3. Restart Photoshop.

Using the Detect Watermark Plug-in
Photoshop 4.0.x and 5.0 include the Detect Watermark (Digiopen.8be), Embed Watermark (Digisign.8bf), and Read Watermark 
(Digiread.8bf) digital watermarking plug-ins, created by Digimarc Corporation. The optional Detect Watermark plug-in scans each 
image you open for a digital watermark, which increases the time it takes for Photoshop to open the file. When the plug-in detects a 
watermark, it puts a copyright symbol on the image window's title bar. You can find the source of the image by choosing Filter > 
Digimarc > Read Watermark. 

To disable the Detect Watermark plug-in:
1. Exit from Photoshop.
2. Move the Digiopen.8be plug-in file from the Program Files\Adobe\Photoshop 5.0\Plugins\Digimarc folder to another location 

(e.g., desktop).

Minimizing Palette Preview Thumbnails
Photoshop requires additional memory to display preview thumbnails in the Layers, Channels, and Paths palette. Photoshop updates 
the preview thumbnails as you make changes to the image itself. The more preview thumbnails Photoshop displays, and the larger 
the thumbnail you select, the more memory Photoshop requires to draw and update preview thumbnails.

To minimize or turn off palette previews in the Layers, Channels, or Paths palette, select Palette Options from the palette's pop-up 
menu. For Thumbnail Size, select the smallest thumbnail size or select None, then click OK. 

Image Files
You can optimize your work flow to improve Photoshop's performance by minimizing file size, editing individual channels, using the 
Quick Edit feature, and using image compression selectively. Additionally, because layers and channels add significantly to the size 
of a file, you can minimize file size by merging layers and deleting channels when you no longer need them. And finally, if you are 
preparing images for color separation, you can work in RGB mode until you are ready to print and then change the images to CMYK 
mode. When converted from CMYK to RGB, a file's size should decrease by about 25%.

Minimizing File Size
You can minimize the size of your files by reducing their resolution, measured in pixels per inch (ppi). Photoshop requires more 
memory and disk space to process high-resolution images, therefore increasing the time it takes Photoshop to display, process, and 



print them. Increasing the resolution of an image does not always improve the quality of the image, and instead only increases its file 
size. You want the resolution of your images to be the highest value your printer can use. Resolutions higher than that only add 
information to your image that your printer can't use, but must process, and thus increase print times.

For continuous-tone images (e.g., photographs) you plan to print, begin by using a resolution that is 1.5 to 2 times the screen 
frequency, measured in lines per inch (lpi), that you'll use to print the image. For line-art images (e.g., drawings), use the same value 
as your printer's resolution, measured in dots per inch (dpi). For example, if the resolution of your printer is 600 dpi, and you plan to 
print the image using the printer's default screen frequency of 85 lpi, save continuous-tone images at a resolution between 127 ppi 
(85 lpi x 1.5) and 170 ppi (85 lpi x 2), and save line-art images at a resolution of 600 ppi.

Recommended resolutions for continuous-tone images:
Output Recommended resolution
Macintosh monitor 72 ppi
Windows-compatible monitor 96 ppi
300 dpi laser printer 100 ppi
600 dpi laser printer 150 ppi
725 dpi inkjet printer 150 ppi
1200 dpi or higher imagesetter two times the screen frequency (lpi) value you specified 

For more information on resolution and lpi, see Related Records.

To reduce the resolution of an image in Photoshop:
1. Open the image, then choose Image > Image Size. 
2. In the Image Size dialog box, decrease the Resolution value, then click OK.

Using Image Compression 
Although compressed files generally have small file sizes, Photoshop may take longer to open or save them. With the exception of 
images saved in Photoshop format, Photoshop must decompress a file to open it and then recompress the file to save it. The BMP, 
CompuServe GIF, GIF89a, JPEG, EPS, Photoshop, and TIFF formats all can be saved with compression. You can improve 
performance by saving your file in compressed Photoshop format (a compression format in which there is no data loss) as you work, 
and then save your file in the format you want when you are finished editing the image. 

To save an image without compression, choose File > Save As, select the format you want, then select the "no compression" option 
in the format's option dialog box (e.g., select the TIFF format, then, in the TIFF Options dialog box, deselect LZW Compression).

Editing Individual Channels
Photoshop requires less memory to apply a filter to a single channel than it does to apply a filter to multiple channels or to an entire 
image (composite channel). In a flattened image, each RGB channel is about one-third the size of the file; each CMYK channel is 
about one-fourth the size. To edit a single channel, select the channel you want to edit in the Channels palette.

Using Quick Edit
Quick Edit enables you to open and edit a portion of an image, rather than the entire image, which decreases the time Photoshop 
needs to open and modify the image. You can open a portion of a Photoshop 2.0, Scitex CT, or uncompressed TIFF image using the 
Quick Edit feature.

Photoshop 5.0 does not automatically install the Quick Edit plug-in. To install it, exit from Photoshop, then drag the 
Goodies\Quikedit\Quicked.8bp file to the Program Files\Adobe\Photoshop 5.0\Plugins folder. 

To use the Quick Edit feature:
1. Choose File > Import > Quick Edit.
2. Select the file you want, then click Open.
3. In the Quick Edit dialog box, drag to select an area of the image, or select the Grid option and then select one of the image 

area tiles.
4. Click OK to open the image.
5. Choose File > Export > Quick Edit Save to save the opened section back to its original file.

Operating System Software
By customizing your operating system so it runs efficiently, you not only increase the amount of system resources available to 
applications, but also ensure your applications run efficiently. Optimizing your hard drive and virtual memory, organizing or removing 
temporary files, and disabling unnecessary applications running in the background improves Photoshop's performance.

Temporary Files
When you work in an application, a copy of your data file is stored temporarily on the hard drive. Many applications create .tmp files 
and then delete them when you exit from the application. Crashes or system errors, however, may prevent an application from 
deleting these files. These files can build up over time, taking up disk space and causing problems. From time to time, you should 
exit from all programs and remove all temporary files. After the first time you do this, you should also make sure there's adequate free 



space on the hard disk to which temporary files (.tmp) are written by exiting from all applications and then doing the following: 

In Windows 95:
-- Remove all temporary files:

1. In Windows Explorer, choose Tools > Find > Files or Folders. 
2. In the Named text box, type "*.tmp".
3. Choose My Computer from the Look In pop-up menu. Some applications write temporary files to hard drive partitions 

and folders other than the ones designated in the Autoexec.bat file. 
4. Click Find Now. 
5. When the search results appear, choose Edit > Select All.
6. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. Windows 95 

will not delete temporary files that are still in use. 
7. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the 

Recycle Bin.

-- Make sure the "Set Temp=" line in the Autoexec.bat file references a folder on a non-compressed hard drive that has at 
least 20-50 MB of free space:
1. Make a backup copy of the C:\Autoexec.bat file (e.g., Autoexec.old).
2. Open the original Autoexec.bat file in a text editor that can save in text-only format (e.g., Windows Write or Notepad).
3. Locate the line that begins "Set temp=" and write down the drive letter and folder name that follow the equal sign 

(this is where most Windows applications put their temporary files). If this line does not exist, write down "C:\Temp."
4. Verify the drive you wrote down has at least 20-50 MB of free space. If the drive does not have enough space, either 

remove unnecessary files or choose a drive that does has enough space and write down the drive letter for this drive.
5. Verify the folder you wrote down in step 3 exists on the drive you wrote down in step 4. If the folder does not exist, 

create it by double-clicking on the drive, choosing File > New > Folder, and then typing in the folder name. 
6. Make sure the "Set Temp=" line in the Autoexec.bat file references the drive and folder you wrote down in steps 4 

and 5. Or, if there is no "Set Temp=" line in the Autoexec. bat file, add the line following this formatting:

Set temp=x:\<folder name>

For example, if you set up a TEMP directory on the C: drive, the line would read "Set Temp=C:\TEMP."

7. Save the Autoexec.bat file in text-only format.
8. Restart Windows.

- In Windows NT 4.0:
-- Remove all temporary files:

1. Choose Start > Find > Files or Folders. 
2. In the Named text box, type "*.tmp".
3. Choose Local Hard Drives from the Look In pop-up menu. Some applications write temporary files to hard drive 

partitions and folders other than the designated ones. 
4. Click Find Now. 
5. When Windows displays the search results, choose Edit > Select All.
6. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. Windows NT 

will not delete temporary files that are still in use. Instead, it will return the error, "Cannot delete <filename>: Access 
denied." If a file returns this error, deselect the file noted in the error message by holding down the control key and 
clicking the filename. 

7. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the 
Recycle Bin. 

-- Edit or add the TEMP user variable on the Environment tab of the System Control Panel to specify a folder on a 
non-compressed hard drive that has sufficient free space:
1. Choose Start > Settings > Control Panel, double-click System, and click the Environment tab. 
2. In the User Variables section, locate TEMP in the Variable column. The folder listed in the Value column is where 

most Windows applications put their temporary files. 

NOTE: This section may also list a TMP variable. Some applications write temporary files in the folder referenced in 
the TMP variable, while others (including Photoshop) write them to the folder referenced in the TEMP variable. 
Although you can assign different drives and folders to these two variables, you'll have an easier time cleaning out 
your temporary files if Windows writes them all to the same place. 

3. Write down the drive letter and folder name (e.g., C:\Temp) in the Value column. If this value does not exist, write 
down "C:\Temp." If the hard drive is designated as "%SystemDrive%," this is the same hard drive on which the Winnt 
folder resides. 

4. Verify the drive you wrote down has at least 20-50 MB of free space. If the drive does not have enough space, either 
remove unnecessary files or choose a drive that has enough space and write down the drive letter for this drive.



5. Verify the folder you wrote down in step 3 exists on the drive. If the folder does not exist, create it by double-clicking 
the drive, choosing File > New > Folder, and then typing in the folder name.

6. If the TEMP variable does not exist in the User Variables section, type TEMP in the Variable text box. If the TEMP 
variable exists, select the variable name. Then type the following in the Value text box: 

X:\<folder name>

For example, if you set up a TEMP directory on the C: drive, the value for the TEMP variable should read "C:\TEMP."

NOTE: You may need to have Administrator access to edit or add a variable. Check with your system administrator. 

7. Click Set, then OK.
8. Restart Windows.

Optimizing and Defragmenting Your Hard Drives
Over time, the computer's hard disk can become damaged or fragmented (unavailable in a large contiguous block). If there is not 
enough contiguous space for the system to save a file, it saves pieces of the file to different locations on the disk. It takes an 
application longer to read a fragmented file whose pieces are saved in several locations. 

In Windows 95, use the included ScanDisk and Disk Defragmenting utilities by choosing Start > Programs > Accessories > System 
Tools. In Windows NT 4.0, Scan your hard drives for errors using the command CHKDSK/f at the command prompt, or scan and 
defragment your hard drives using a Windows NT 4.0-compatible utility. 

Windows' Virtual Memory and Photoshop's Scratch Disk Files
Virtual memory allows your system to use hard-disk space to store information normally stored in memory (RAM). Because it takes 
longer to access information on a hard disk than it does to access information in memory, using a portion of the hard disk as virtual 
memory can decrease performance. In addition, Photoshop cannot use the hard-disk space the system uses for virtual memory for its 
scratch disk files, which it uses to store image information as you work. If you need more memory to work in Photoshop, Adobe 
Systems recommends installing more RAM.

Specifying a fixed virtual memory setting helps prevent Photoshop's scratch disk files from competing for the same space with virtual 
memory, especially if you set the virtual memory setting on a different drive than Photoshop's primary scratch disk. For both kinds of 
virtual memory, be sure to use a drive with enough free, uncompressed space. 

NOTE: After changing system settings, such as virtual memory, Windows may be unable to start, so you may need a startup disk. 
Create a Windows startup disk by choosing Start > Settings > Control Panel, double-clicking Add/Remove Programs, clicking the 
Startup Disk tab, and following the on-screen instructions. 

- In Windows 95: 
1. Exit from all applications.
2. Create a Windows startup disk by choosing Start > Settings > Control Panel, double-clicking Add/Remove Programs, 

clicking the Startup Disk tab, and following the on-screen instructions. 
3. Choose Start > Settings > Control Panel, double-click System, click the Performance tab, then click Virtual Memory.
4. Select the "Let Me Specify My Own Virtual Memory Settings" option.
5. From the Hard Disk pop-up menu, choose a hard drive that has at least twice as much free disk space as there is RAM. For 

example, if your computer has 24 MB of RAM, choose a hard drive that has at least 48 MB of free space. 
6. In both the Minimum and Maximum text boxes, enter a value that is double the amount of your computer's installed RAM.
7. Click OK to close the Virtual Memory dialog box. 
8. When the message, "You have chosen not to let Windows manage virtual memory automatically. . ." appears in the 

Confirm Virtual Memory Setting dialog box, click Yes.
9. Click Close in the System Properties dialog box.
10. Restart Windows by clicking Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the startup disk 

and then restart Windows.

- In Windows NT 4.0:
1. Exit from all applications.
2. Choose Start > Settings > Control Panel, double-click System, then click the Performance tab.
3. In the Virtual Memory section, click Change.
4. From the Drive list, select a hard drive that has at least twice as much free space as there is RAM. For example, if your 

computer has 24 MB of RAM, select a hard drive that has at least 48 MB of free hard drive space. For best performance, 
choose a different hard drive than those used for the Photoshop scratch disks.

5. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your 
computer's installed RAM plus 12 MB. 

6. In the Maximum Size box, enter a value that is twice the amount of your computer's installed RAM.
7. Click Set, then click OK.
8. Click OK to close the System Properties dialog box.



9. To restart Windows, click Yes in the System Settings Change dialog box. 

Applications Running in the Background
As it starts, Windows uses some of the installed RAM. Photoshop competes with other programs you start for the remainder. You may 
not be aware of programs that start automatically and run in the background. Make sure no programs are starting automatically when 
Windows starts by doing the following: 

- In Windows 95:
-- Remove programs from the StartUp folder:

1. Start Windows Explorer.
2. Move all icons and shortcuts from the Windows\Start Menu\Programs\StartUp folder to another folder.
3. Restart Windows. You can move the icons and shortcuts back if Photoshop's performance doesn't improve noticeably.

-- Edit the Win.ini file to disable (i.e., remark out) programs and utilities that load automatically (e.g., video control panels, 
screen savers, virus protection utilities):
1. Make a copy of the Win.ini file, which is in the Windows folder.
2. Open the original Win.ini file using a text-editing application that can save in text-only format (e.g., Notepad).
3. In the [Windows] section, insert a semicolon at the beginning of the "load=" and "run=" lines. For example:

;load=
;run=

4. Save the Win.ini file in text-only format, then restart Windows. You can delete the semicolons you added to each line 
to restore the original configuration if Photoshop's performance doesn't improve noticeably. 

- In Windows NT 4.0:
-- Remove programs from the StartUp folder:

1. Exit from all applications.
2. Start Windows NT Explorer.
3 Move all icons and shortcuts from the Winnt\Profiles\<Current User>\Start Menu\Programs\Startup folder to another 

folder. This will disable any startup applications that are Private to the Current User's logon from starting 
automatically until you move the icons and shortcuts back. 

4. Move all icons and shortcuts from the Winnt\Profiles\All Users\Start Menu\Programs\Startup folder to another folder. 
This will disable most startup applications that are Common to All Users from starting automatically until you drag the 
icons and shortcuts back. 

5. Restart Windows. You can later move the icons and shortcuts back if Photoshop's performance doesn't improve 
noticeably. 

-- Close applications that are specified to start automatically in the registry:
1. Restart Windows. 
2. Right-click on the task bar.
3. Choose Task Manager from the pop-up menu.
4. Click the Applications tab. 
5. Select an application name, then click End Task.
6. Restart Photoshop. If Photoshop's performance improves noticeably, contact the application's manufacturer for help in 

permanently disabling it from starting automatically. 

Hardware
Photoshop's performance is limited by the hardware you use: the faster processor or hard disk you use, the faster Photoshop can 
process image information. Other hardware options, such as installing additional RAM, using a multiprocessor system, or using 
optimized and defragmented disks, can also improve Photoshop's performance.

Processor Speed
Photoshop's speed is limited by the speed of the computer's processor, or CPU (Central Processing Unit). Since Photoshop 
manipulates large quantities of data and performs many calculations, its speed is greatly dependent on the processor's speed. 
Running Photoshop on a computer with a Pentium, Pentium II, Pentium Pro, or MMX processor will provide faster processing. 
Photoshop ships with plug-ins that take advantage of the optimizations of these chips. 

All Photoshop features are faster on a multiprocessor system, although some can take greater advantage of the multiprocessor 
system's capabilities. 

Installed RAM
To work with an image, Photoshop requires an amount of memory (RAM) that is three to five times the file size of that image. If 
Photoshop has insufficient memory, it uses hard-disk space (scratch disk) to process information. Because accessing information in 
memory is faster than accessing information on a hard disk, Photoshop is fastest when it can process all or most image information in 
memory, without using the scratch disk. Allocate enough memory to Photoshop to accommodate your largest image file. 



Hard Disks
Since Photoshop reads and writes image information while working on an image, the faster the access speed of the disk containing 
your image or Photoshop's scratch disk, the faster Photoshop can process image information. To improve Photoshop performance, 
work on files saved on disks with fast access speeds, such as an internal hard disk, rather than those with slow access speeds, such as a 
network server (hard disk accessed over a network) or removable media (e.g., floppy disk, Zip, Jazz, Bernoulli). Removable media 
often have slower access times and are more easily damaged than non-removable disks.

Resources 
The following books and Web sites provide troubleshooting tips and general information about the Windows 95 or Windows NT 
operating system.

Books
Microsoft Windows 95 Resource Kit
Microsoft Windows NT Workstation Resource Kit
Peter Norton's Complete Guide to NT 4 Workstation
Windows 95 for Dummies
Windows NT 4 for Dummies

Web Sites
BYTE Magazine: http://www.byte.com
The Cobb Group: http://www.cobb.com
Microsoft Drivers and Other Downloads: http://support.microsoft.com/support/downloads/default.asp
Microsoft Support: http://support.microsoft.com
PCWeek: http://www.pcweek.com
PC World: http://www.pcworld.com
Savill Tech LTD: http://www.ntfaq.com
WinFiles.com: http://www.winfiles.com
Windows Magazine: http://www.winmag.com
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Photoshop 5.0 Color Management Technical Guides

There is a series of technical guides on the Adobe Web site that describe the features, functions, and philosophy behind color 
management in Adobe Photoshop 5.0. These guides were created by Adobe Technical Support. 

You can see these technical guides by going to http://www.adobe.com/supportservice/custsupport/techguide.html and clicking Adobe 
Photoshop. You can also get to the guides from Adobe's home page; go to http://www.adobe.com, click Support and Services, click 
Technical Guides, and then click Adobe Photoshop. 

Color Management Systems 
This guide provides an introduction to color management systems (CMS), explains why they are of increasing importance in the 
desktop publishing industry, and defines some of the basic concepts and components of a CMS.

Color Management in Adobe Photoshop 5.0
This guide provides the key concepts behind color management in Photoshop 5.0, and explains the new Color Settings dialog boxes 
and other color-related features.

Color Management Workflows for Photoshop 5.0
This guide presents a number of workflows using the new color management features of Photoshop 5.0. Use it as a resource 
whenever you have questions on how to move color images through Photoshop.
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How to Troubleshoot System Errors or Freezes in Photoshop for Mac OS

What's Covered
How to Use This Document
Beginning to Intermediate Troubleshooting
Advanced Hardware and Other Troubleshooting

As with any software, your Mac OS operating system may return errors, or may freeze when trying to return an error. Infrequent system 
errors are usually no cause for concern. Frequent system errors, on the other hand, usually indicate a computer hasn't been receiving 
consistent, basic maintenance, or wasn't shut down properly (e.g., by choosing Special > Shut Down) before being turned off.

System errors that occur in Adobe Photoshop 5.0 and earlier can manifest themselves in many different ways, including (but not 
limited to) the following:

Errors, "Type 1," "Type 3," "Type 11," "Type 28."

"The application 'unknown' has unexpectedly quit."

"Floating Point Coprocessor not installed."

"The default monitor setting is invalid."

A bomb icon appears on screen, dialog boxes are blank or flickering, your cursor freezes, etc. 

Although a system error may appear to only occur in only one application, this does not necessarily mean the application is the 
cause. Many different factors can cause system errors, including extension conflicts, damaged or conflicting files, system software, or 
hardware. Photoshop may just be the only application that is memory- or processor-intensive enough to cause another, more 
fundamental problem to manifest itself. 

How to Use This Document
If you receive multiple system errors or freezes while working in different files in Photoshop 5.0 or earlier, use this document to help 
you determine the cause. This document lists all causes of system errors that occur in Photoshop known to Adobe Technical Support, 
along with the steps necessary to isolate and correct the causes. Adobe Technical Support arranged the troubleshooting tasks in this 
document from the easiest and most likely to resolve common causes to the most complex and likely to resolve uncommon causes. 
The overwhelming majority of system errors can be resolved by performing one or more of the tasks listed in the Beginning to 
Intermediate Troubleshooting section. The tasks listed in the Advanced Hardware and Other Troubleshooting section are extreme 
and are only necessary in rare cases.

Before performing any of the following tasks, ask yourself these questions: "Has this problem always occurred?," "If not, when did it 
start occurring?," and "Did anything change on the computer since the problem began?" If a problem has always existed, something 
already set on your system, such as a video display card driver that needs upgrading, could be the cause. If the problem started 
occurring suddenly, too little available hard drive space, too many temporary files, or a recent change to your system may be the 
cause. For example, Photoshop may have a conflict with a recently-installed application. Your answers to these questions can help 
you determine the possible cause(s) of the error. You can then perform the troubleshooting tasks that are the most likely to isolate the 

cause first. If you are unable to determine which tasks to perform first, begin with the first item in this document, and then proceed 
through each step, one item at a time. 

Since many variables can cause system errors, it's important to be logical and methodical when isolating and resolving the cause. Be 
sure to perform each step correctly and completely before proceeding on to the next step.

Beginning to Intermediate Troubleshooting
The tasks in this section will help you isolate the most common causes of system errors that occur frequently, and in more than one 
file, in Photoshop. Before performing any of these tasks, make sure to back up all personal files (e.g., Photoshop image files you 
created, third-party plug-ins, etc.). Always restart your computer after a system error occurs to refresh your computer's memory; 
Continuing to work without restarting could compound the problem.

A. Download and install the latest Photoshop update. Registered users can download free updates from Adobe's Web site at 
http://www.adobe.com. You can also purchase the update on CD-ROM (while supplies last) from Adobe Customer Services at 
800-492-3623.



NOTE: Upgrading to the latest full version (i.e., full release) of Photoshop will solve a wider range of problems. When deciding 
if you should upgrade, remember that hardware and software must meet the latest version's system requirements. You may 
prefer to try the solutions in the rest of this document before upgrading. You can order a Photoshop upgrade from an Adobe 
Authorized Reseller or directly from Adobe. To locate an Authorized Reseller in your area, visit Adobe's Web site at 
http://www.adobe.com/purchase/#dealer or call Customer Services at the number above.

B. Run Photoshop with all extensions disabled to verify that an extension conflict is not the cause. To disable extensions upon 
startup in System 7.0.x or later, restart the computer with the Shift key held down until the message "Welcome to Macintosh. 
Extensions Off." appears. Disabling extensions will also disable any virtual memory or RAM compression software (e.g., RAM 
Doubler).

NOTE: Non-Apple keyboards may have a different method for restarting the Macintosh with Extensions off. For information on 
the proper method to start without extensions, contact your keyboard manufacturer. 

If the error does not recur with extensions disabled, troubleshoot extension conflicts. For instructions, see document 314385 , 
"Disabling Extensions and Isolating Extension Conflicts in System 7.x," or document 311687 , "Disabling Extensions and 
Isolating Extension Conflicts in Mac OS 8.0.x."

Holding the Shift key down at startup disables most, but not all system extensions. If the error recurs after you restart with the 
Shift key held down, take the following additional steps to manually remove all system extensions (and other software that loads 
at startup) from your System Folder:
1. Move the Control Panels, Extensions, Fonts, and Preferences folders from the System Folder to a new location (e.g., the 

desktop).
2. If you are using System 7.x, skip to step 4. If you are using Mac OS 8.0.x, create a new folder, name it "Extensions," and 

then move it into the System Folder.
3. Move the Appearance extension from the old Extensions folder into the Extensions folder you created in step 2. 
Mac OS 8.0.x requires the Appearance extension to start the Macintosh. If the Appearance extension isn't installed in the 
System Folder:Extensions folder, the system returns the following error:

"The Finder could not start up because the following system library could not be found: AppearanceLib. To start up, use 
the CD or floppy disks that came with your computer. To start up from a CD, hold the "C" key while starting up, or consult 
the User's Guide that came with your computer."

If the system returns this error, you must start your Macintosh using a startup disk (e.g., Mac OS 8 CD-ROM, Disk Tools).

4. Restart the Macintosh and try to re-create the error. 

C. Re-create the Photoshop preferences file:

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the Actions 
palette menu. In Photoshop 5.0, the actions are saved in a separate preferences file. 

1. Quit Photoshop.
2. If you are using Photoshop 5.0, rename the Adobe Photoshop 5 Prefs and Color Settings files) in the Adobe Photoshop 

5.0:Adobe Photoshop Settings folder. If you are using an earlier version, rename the Adobe Photoshop 4.0 Prefs file 
(Photoshop 4.0), the Adobe Photoshop 3.0 Prefs file (Photoshop 3.0.x), or the Adobe Photoshop LE Prefs file (Photoshop 
3.0.x LE) in the System folder:Preferences folder. 

3. Restart Photoshop.

D. Make sure that an appropriate amount of memory is allocated to Photoshop. To set Photoshop's memory (RAM) allocation, 
select the application icon, choose File > Get Info, and increase both the Minimum size and Preferred size settings to the 
following values: 
 
Photoshop 5.0 for the Power Macintosh: 24 MB (24,576k)
Photoshop 4.0.x for the Power Macintosh: 14 MB (14,734k) 
Photoshop 4.0.x for the 68k Macintosh: 10 MB (10,000k) 
Photoshop 3.0.x for the Power Macintosh: 13 MB (13,440k) 
Photoshop 3.0.x for the 68k Macintosh: 8 MB (8,192k) 

E. Remove all plug-ins from Photoshop's Plug-ins folder:
1. Quit Photoshop.
2. Create a new folder outside of the Photoshop folder (e.g., on the desktop) to temporarily store the Photoshop plug-ins.
3. Open the Photoshop:Plug-ins folder, then select all the plug-ins and folders located within the Plug-ins folder 

(Command-A).
4. Move all the plug-ins and folders within the Plug-ins folder to the folder you created in step 2.



5. Re-create the Photoshop preferences file(s) (see step C above).
6. Try to re-create the error. If the error does not reoccur, add plug-ins back one at a time (restarting Photoshop each time you 

add one or more plug-ins) until you find the one that caused the error. 

F. In the Memory control panel, disable Virtual Memory, enable Modern Memory Manager (if available), and set the Disk Cache 
size to 96K or less.

G. Reinstall Photoshop:
1. Move any personal files in the Photoshop folder to another location.
2. Delete the Photoshop folder and the Photoshop Prefs file(s) noted in step C above.
3. Reinstall Photoshop from the CD-ROM or original installation disk set, following the on-screen instructions.

NOTE: If you had installed an updated version of Photoshop, be sure to reinstall the update after you reinstall Photoshop.

H. Specify a hard drive partition that has enough free space -- three to five times the file size of your image (or at least ten times 
the size of bitmap-mode images) -- as the primary scratch disk; specify a secondary scratch disk if your hard drive has enough free 
space (or for Photoshop 5.0, a third and fourth scratch disk). In Photoshop 4.0.x, do not specify the same hard drive partition for 
both the primary and secondary scratch disks. To specify a scratch disk in Photoshop, choose File > Preferences > Plug-ins & 
Scratch Disks (Photoshop 4.0.x or later) or choose or File > Preferences > Scratch Disk (Photoshop 3.0.x ). Set the Primary 
Scratch Disk to the internal hard drive. If there is more than one internal hard drive, select the startup disk (i.e., the disk where 
the active System Folder resides). 

Photoshop uses a scratch disk file (i.e., temporary disk space used for storing data and performing computations) when there is 
insufficient RAM for image editing. Photoshop 4.0.x can have up to two scratch disks, and each can be up to 2 GB. Each scratch 
disk must be on a separate hard drive partition. For example, if you have 5 GB of free space on an unpartitioned hard drive, and 
all scratch disks are assigned to it, Photoshop 4.0.x can use up to 2 GB of space in one scratch disk file. To use the full 4 GB, 
partition your hard drives so that there are as many partitions as there are scratch disks you want to use. In Photoshop 5.0, you 
can assign up to four partitions for scratch disk files. Although the scratch disk files still have a limit of 2 GB each, Photoshop 5.0 
can write as many scratch disks per partition as there is free disk space -- if you have 5 GB of free disk space on an unpartitioned 
hard drive, and all scratch disks are assigned to it, Photoshop 5.0 can use up to 5 GB of space in three scratch disk files (2 GB, 2 
GB, 1 GB).

I. Check the hard drive by doing one or more of the following:
-- Use a disk repair utility (e.g., Apple Disk First Aid, Norton Disk Doctor, TechTool Pro) to check for disk problems. 

DISCLAIMER: Adobe Systems does not provide support for third-party diagnostic software. The following instructions are 
provided as a courtesy. Contact the developer of your disk utility for support.

To use Apple's Disk First Aid utility, included on system software installation disks and system software CDs:
1. Start the computer from a bootable disk (i.e., the disk labeled "Disk Tools" included with your System 7.x installation 

disks) or system software CD.
2. Double-click the Disk First Aid application. 
3. Select the drive(s) to be verified or repaired.
4. Click Verify to check the disk or Repair to check and repair the disk. If you click Verify, Disk First Aid tells you if there is 

a problem with the disk and asks you if you want to repair it. Always repair the disk when prompted.
5. Choose File > Quit.

-- Update all SCSI drivers to ensure that they are not damaged and are compatible with the current system. For further 
support, contact the manufacturer of your hard drive or your drive formatting utility. 
1. Start the computer from a bootable disk (i.e., the disk labeled "Disk Tools" included with your System 7.x installation 

disks) or system software CD.
2. Double-click the HDSC Setup, Drive Setup application. 
3. Click the Drive button until your SCSI drive (i.e., hard drive) is selected.

NOTE: On a disk drive that has been formatted with a third-party disk utility (e.g. Norton Utilities, MacTools, Symantec 
Tools for Macintosh), you may receive the message, "Drive selection failed. Unable to locate a suitable drive 
connected to the SCSI port." Clicking Continue quits HDSC setup. You must use the Disk Tools disk from that utility's 
disk set for these steps. For instructions, refer to the utility's documentation.

4. Click Update to install updated SCSI drivers to each SCSI disk (e.g., hard drive, cartridge).
5. Choose File > Quit.

-- Use a third-party disk utility (e.g. Norton Utilities, TechTool Pro, Symantec Tools for the Macintosh) to ensure that damaged 
sectors are marked unusable. For instructions, refer to the utility's documentation.

-- Defragment and optimize your hard drive using a disk utility (e.g., Norton Utilities, MacTools). For instructions, refer to the 



utility's documentation.

J. When external SCSI devices (e.g., external hard drives, removable media drives, ZIP drives, Jazz Drives, optical drives, external 
CD-ROM drives, scanners, etc.) are connected to the Macintosh, ensure SCSI connection devices, cables, or termination are not 
the cause by turning the computer and all SCSI devices off, disconnecting all SCSI devices from the Macintosh, then restarting 
the computer. If multiple devices are present you can leave them connected to each other, but you need to disconnect the 
entire SCSI chain from the back of the computer. 

NOTE: do not connect or disconnect SCSI cables or SCSI devices with the power turned on for the computer or SCSI devices. 
Doing so can permanently damage the computer or the SCSI devices or both. For more information on SCSI troubleshooting, 
see document 316381 , "SCSI Chain Troubleshooting Guide."

K. Replace the system software by performing a clean install (i.e., installing new system software into a new System Folder, instead 
of installing over the existing system software). Please note that simply running the system software installer or an updater (e.g., 
System 7.5.3 - System Updater 2.0) does not ensure that a completely new copy of system software is properly installed. Rather 
than just running an updater, it is necessary to install a complete new System Folder. If your most recent system floppy or CD is 
an updater (not a full version), you will need to reinstall the most recent full version, then run the updater on that System Folder. 
For more information on performing a clean system software installation, see Related Records.

L. If you have a Power Macintosh and System 7.5.5, install Apple's PowerPC Interrupt Extension (available online from Apple and 
other sources). If you have System 7.5.6 or later, this extension is unnecessary since its function is built into the operating 
system. 

M. Make sure that your hard disk drivers and all media formatting are compatible with Apple's SCSI Manager 4.3.1 or later. For 
information about formatting software's compatibility with SCSI Manager 4.3.1, contact the manufacturer of the drive 
mechanism and your formatting software. Reformatting your hard disk after updating the hard disk driver is not required, but 
reformatting may prevent system errors.

NOTE: Reformatting the drive will erase all files on the drive beyond recovery. Before reformatting, make sure you've backed up 
all your data files for all your applications. 

Common hard drive formatting software that is compatible with SCSI Manager 4.3.1 includes:
-- Apple's HDSC 7.3 or later, or Drive Setup 1.0.x and higher, for Apple hard drives (Drive Setup must be used to format 

or update an IDE drive present in newer Macintosh computers).
-- FWB's Hard Disk Toolkit 1.62 or later.
-- La Cie's SilverLining 5.54, 5.6, or later.

For additional information about your hard drive formatting software, contact the product's developer.

N. Reset (i.e., "zap") the Parameter RAM (PRAM) by pressing the Command+Option+P+R keys when restarting the computer. Hold 
these keys down until you hear the startup chimes twice, then release the keys. 

NOTE: Resetting the Parameter RAM resets the system's preferences to the default settings (e.g., Black and White in the 
Monitors control panel, LocalTalk Built In in the Network control panel, etc.). Some video displays (e.g. some Radius displays) 
may be extremely difficult to read after resetting PRAM and may require a special procedure to reset the display after resetting 
the PRAM. For more information see document 315344 , "PRAM General Information."

O. Reformat the drive, then install only the system software and Photoshop from the original installation disks or CD. Do not install 
any additional software or hardware until you've made sure that the problem no longer occurs. 

NOTE: Reformatting the drive will erase all files on the drive beyond recovery. Before reformatting, make sure you've backed up 
all your data files (e.g., image, word processing, desktop publishing, and illustration files) you created in all your applications. 

Try to re-create the error. If the system errors persist in this simplified configuration, the problem is caused by a hardware issue, 
and you should troubleshoot the problem with the help of the manufacturer or an authorized reseller. Before calling the 
manufacturer, however, you may want to continue with the following section.

Advanced Hardware and Other Troubleshooting
If the tasks listed in the previous section did not solve your system errors, you probably have a hardware or related conflict with 
Photoshop.

DISCLAIMER: Adobe does not support hardware, and these solutions are provided only as a courtesy. For further assistance, please 
contact your hardware manufacturer or an authorized repair service facility. 

NOTE: If you choose to remove or rearrange hardware yourself, turn off the power to the computer and any connected peripherals 
before doing so. 



A. Turn off your computer, remove any processor accelerator, cache, and other expansion cards installed in the computer, then 
restart the computer.

B. If you are running Photoshop 3.0.x or earlier on a 68K Macintosh upgraded to a Power Macintosh using a Power PC upgrade 
card, turn off the computer, remove the upgrade card from the computer, and restart the computer. Then, reinstall Photoshop by 
selecting Custom Install and choosing either the 68K version or Universal version in the installation dialog box.

C. If you are running Photoshop 3.0.x or earlier on a non-Power Macintosh (i.e., 68K Macintosh) computer using a third-party video 
card with your monitor, turn off your computer, then plug the monitor into the built-in video rather than the third-party video 
card. If no on-board video is available, it may be necessary to remove and replace the video card to test for video hardware 
problems.

NOTE: Starting some Mac OS or compatible computers without the video card in the Processor Direct Slot (PDS) can damage 
the computer. Contact an authorized dealer or service provider for hardware support.

D. If your system has a clock-chip accelerator (e.g., Newer Technology's PowerClip), remove it. Adobe Photoshop was neither 
designed for nor tested on systems with clock-chip accelerators. 

E. Ensure the RAM SIMMs or DIMMs are installed properly and are not the cause by doing one or more of the following:
-- Remove then reinstall the SIMMs or DIMMs to ensure they are seated properly. 

-- In Photoshop's Get Info dialog box, set both the Minimum Size and Preferred Size for Memory Requirements down to the 
minimum recommended settings: 19,518K (Power Macintosh) for Photoshop 5.0; 14,734K (Power Macintosh) or 10,000K 
(68K Macintosh) for Photoshop 4.0.x; or 8,192k (Power Macintosh) or 10,000 (68K Macintosh) for Photoshop 3.0.x. If system 
errors do not occur with Photoshop's memory allocation at the minimum settings, but system errors do occur when a large 
amount of RAM is allocated to Photoshop, one or more of the SIMMs or DIMMs is likely the cause. To test the integrity of 
SIMMs or DIMMs, remove and replace them with equivalent DIMMs or SIMMs that are known to work (see step c below).

-- When you have a large number of SIMMs or DIMMs installed in your computer, remove a subset of them. For example, if 
you have four SIMMs or DIMMs installed, remove two and test to see if the problem persists. If it does, put those two back in 
and remove the other two, testing again to see if the problem persists. If the problem does not occur again, one or more of 
the removed SIMMs or DIMMs are the cause.

-- Change the order of the installed SIMMs or DIMMs.

-- Install new SIMMs or DIMMs. 

-- Remove composite RAM SIMMs. Adobe does not recommend using composite RAM SIMMs.

-- Make sure your SIMMs or DIMMs are all of the same speed and size, and are from the same manufacturer. Check with your 
dealer to determine the speed, size, and manufacturer of installed SIMMs or DIMMs.

F. Run from a different hard drive installed in the same computer or the same hard drive installed in a different computer.

G. Replace the computer's motherboard (logic board). If replacing a computer's motherboard, be sure that all components are 
replaced as well, including the Macintosh ROM and 680x0 or PowerPC processor. In some cases the Macintosh ROM or 
processor or both may be moved from one motherboard to another; if the problem you are experiencing is caused by a 
malfunctioning Macintosh ROM or processor, replacing the motherboard while using the original Macintosh ROM or processor 
will not solve the problem. If you replace your computer's motherboard, Adobe recommends also replacing the Macintosh ROM 
and processor on the motherboard at the same time. Check with the service technician who replaces the motherboard to be sure 
that the new motherboard also contains a new ROM and processor.
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As with any software, your Windows 95 operating system may return errors, or may freeze when trying to return an error. Infrequent 
system errors are usually no cause for concern. Frequent system errors, on the other hand, usually indicate a computer hasn't been 
receiving consistent, basic maintenance, or wasn't shut down properly (i.e., by choosing Start > Shut Down) before being turned off. 

System errors can manifest themselves in Adobe Photoshop 5.0 and earlier in many different ways, including (but not limited to) the 
following:

- One or more of the following or similar errors occur: 
"This program has performed an illegal operation and will be shut down. If the problem persists, contact the program vendor."

"PHOTOSHP caused a General Protection Fault in module <filename>." 

"PHOTOSHP caused an Invalid Page Fault in module <filename>." 

"Application Error."

"Unhandled exception detected. Application will be terminated."

"Illegal Instruction."

"Segment load failure in <filename>."

"Unable to intialize Photoshop because the preferences file is invalid."

- Dialog boxes are blank or flickering or your cursor or screen freezes, etc. 

Although a system error may appear to occur only in Photoshop, this does not necessarily mean Photoshop is the cause. Many 
different factors can cause system errors, including low-level DOS problems, memory conflicts between device drivers, software, 
hardware, and corrupt elements in specific files. Photoshop may just be the only application that is memory- or processor-intensive 
enough to cause another, more fundamental problem to manifest itself. 

How to Use This Document
If you receive multiple system errors or freezes while working in different files in Photoshop 5.0 and earlier, use this document to help 
determine the cause. This document lists all causes of system errors that occur in Photoshop known to Adobe Technical Support, 
along with the steps necessary to isolate and correct the causes. Adobe Technical Support arranged the troubleshooting tasks in this 
document from the easiest and most likely to resolve common causes to the most complex and likely to resolve uncommon causes. 
The overwhelming majority of system errors can be resolved by performing one or more of the tasks listed in the Beginning to 
Intermediate Troubleshooting section. The tasks listed in the Advanced Hardware and Other Troubleshooting section are extreme 
and are only necessary in rare cases.

Before performing any of the tasks, ask yourself these questions: "Has this problem always occurred?" "If not, when did it start 
occurring?" "Did anything change on the computer since the problem began?" If a problem has always occurred, something already 
set on your system, such as the video display card driver that needs upgrading, could be the cause. If the problem started occurring 
suddenly, the computer might have too little hard disk space left, there may be too many temporary files, or a recent change to your 
system may be the cause. For example, Photoshop may have a conflict with a recently-installed application (e.g., an application 
whose installer created a shortcut to it in the Start > Programs > StartUp menu). Your answers to these questions can help you 
determine the possible cause of the error. You can then perform the troubleshooting tasks that are the most likely to isolate the cause 

first. If you are unable to determine which tasks to perform first, begin with the first item in this document, and then proceed through 
each step, one item at a time. 

Since many variables can cause system errors, it's important to be logical and methodical when isolating and resolving the cause. Be 
sure to perform each step correctly and completely before proceeding on to the next step.



Beginning to Intermediate Troubleshooting
The troubleshooting tasks in this section will help you isolate the most common causes of system errors that occur frequently, and in 
more than one file, in Photoshop. Before performing any of these tasks, make sure to back up all personal files (e.g., Photoshop 
image files you created, third-party plug-ins, etc.). Always restart your computer after a system error occurs to refresh your computer's 
memory; continuing to work without restarting could compound the problem.

NOTE: Some of the solutions in this section require you to look for files with specific filename extensions (e.g., filename.psp). By 
default, Windows Explorer hides filename extensions it recognizes. To display all filename extensions in Windows Explorer:
1. Choose View > Options.
2. Click the View tab in the Options dialog box.
3. Select Show All Files.
4. Deselect the option labeled, "Hide File Extensions for Registered File Types."
5. Click OK, then close the Options dialog box.

A. Make sure you are using the latest version of Photoshop. You can order the Photoshop upgrade from an Adobe Authorized 
Reseller or directly from Adobe. To locate an Authorized Reseller in your area, visit Adobe's Web site at 
http://www.adobe.com/purchase or call Customer Services. Photoshop Registered users can download updates for free from the 
Free Plug-Ins and Updates section on Adobe's Web site at http://www.adobe.com. You can also purchase the update on 
CD-ROM (while supplies last) from Adobe Customer Services at 800-492-3623.

NOTE: Before upgrading to the latest version of Photoshop, make sure your hardware and software meet that version's system 
requirements. You may prefer to try the other solutions in this document before upgrading. 

B. Make sure your computer has at least the minimum amount of random-access memory (RAM) that Photoshop requires to run: 32 
MB for Photoshop 5.0, 16 MB for Photoshop 4.0.x, and 10 MB for Photoshop 3.0.5. To see how much RAM you have, choose 
Start > Settings > Control Panel, double-click the System Control Panel, then click the General tab. The amount of RAM your 
computer has will be listed in the Computer section. 

C. Re-create Photoshop's preferences files:

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the Actions 
palette menu. In Photoshop 5.0, the actions are saved in a separate preferences file. 

1. Exit from Photoshop.
2. If you are using Photoshop 5.0, rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the 

Photoshop5\Adobe Photoshop Settings folder. For earlier versions, delete or rename the Photos40.psp and CColorsd files 
in the Photoshop\Prefs directory (Photoshop 4.0.x) or the Photos30.psp and CColorsd files in the Win32app\Photoshp\Prefs 
directory (Photoshop 3.0.5).

3. Start Photoshop.

D. Make sure no programs are starting automatically when Windows 95 starts by doing the following:
-- Prevent programs from starting automatically in Windows by removing them from the StartUp folder:

1. Start Windows Explorer.
2. Move all icons and shortcuts from the Windows\Start Menu\Programs\StartUp folder to another folder.
3. Restart Windows.
4. If the system error continues to occur, move the icons and shortcuts back. If the error does not occur, move them back 

one at a time to isolate the one that was causing the error. 

-- Edit the Win.ini file to disable (i.e., remark out) programs and utilities that load automatically in Windows (e.g., video 
control panels, screen savers, virus protection utilities):
1. Make a copy of the Win.ini file, which is in the Windows folder.
2. Open the original Win.ini file using a text-editing application that can save in text-only format (e.g., Notepad).
3. In the [Windows] section, insert a semicolon at the beginning of the "load=" and "run=" lines. For example:

;load=
;run=

4. Save the Win.ini file in text-only format, then restart Windows.
5. If the system error continues to occur, delete the semicolons you added to each line to restore the original 

configuration. If the error does not occur, delete the semicolons in front of the lines one at a time to isolate the one 
that was causing the error.

-- Close all applications, except Systray and Explorer, one by one by pressing Control+Alt+Delete to display the Close 
Program dialog box, selecting an application, and then clicking End Task. (Systray and Explorer are basic Windows 
components.) Reopen Photoshop and try to re-create the error before closing the next application. If the error does not 



occur after closing an application, that application has a conflict with Photoshop. 

Sometimes after closing an application and viewing the Close Program dialog box again, you will see it is still running. 
Sometimes you'll need to close that application more than once to stop it from running. Other times, this indicates the 
application is loading in the registry or in DOS. Contact the application's manufacturer for information on disabling it.

E. Troubleshoot your MMXCore and FastCore plug-ins by doing one or both of the following:
-- Update both your MMXCore and FastCore plug-ins. For instructions, see document 315096 .  

-- If the error continues to occur after updating these plug-ins, rename your MMXCore and FastCore plug-ins: 
1. Exit from Photoshop.
2. In Windows Explorer, rename the Mmxcore.8bx file, which is in the Program Files\Photoshop5\Plug-Ins\Extensns 

folder (Photoshop 5.0) or the Adobe\Photoshop\Plugins\Extensns folder (Photoshop 4.0.x), to "Mmxcore.old". 
3. Start Photoshop.
4. If the error continues to occur, exit from Photoshop.
5. In Windows Explorer, rename the Fastcore.8bx file, which is in same folder as the Mmxcore.8bx file, to "Fastcore.old".
6. Start Photoshop. 

F. Remove Photoshop and then reinstall it while in Safe Mode to make sure it is installed correctly. For instructions, see document 
316844 .

NOTE: If the copy of Photoshop you removed is newer than the version installed by your installation CD, (i.e., the version you 
removed had been updated), be sure to update the reinstalled copy of Photoshop.

G. Re-create the Windows swap file by specifying a fixed virtual memory setting to make sure a damaged swap file is not the cause: 

1. Exit from all applications.
2. Create a Windows startup disk by choosing Start > Settings > Control Panel, double-clicking Add/Remove Programs, 

clicking the Startup Disk tab, and following the on-screen instructions. (After changing system settings, such as virtual 
memory, Windows may be unable to start, so you may need a startup disk.)

3. Choose Start > Settings > Control Panel, double-click System, click the Performance tab, then click Virtual Memory.
4. Select the option labeled, "Let Me Specify My Own Virtual Memory Settings." 
5. From the Hard Disk pop-up menu, choose a hard drive that has at least twice the amount of your computer's installed RAM. 

For example, if your computer has 24 MB of RAM, choose a hard drive that has at least 48 MB of free space. (If you don't 
know how much hard disk space you have on a drive, start Windows Explorer, right-click on the drive, and choose Properties 
from the pop-up menu to see the Free Space field.)

6. In both the Minimum and Maximum text boxes, enter a value equal to double the amount of your computer's installed 
RAM.

7. Click OK to close the Virtual Memory dialog box. 
8. When the message, "You have chosen not to let Windows manage virtual memory automatically. . ." appears in the 

Confirm Virtual Memory Setting dialog box, click Yes.
9. Click Close in the System Properties dialog box.
10. Restart Windows by clicking Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the startup disk 

and then restart Windows.

For more information on virtual memory settings, see Related Records or consult your Windows 95 documentation.

H. Change the number of colors and resolution of the video display adapter to determine whether there is a conflict with your video 
driver:
1. Choose Start > Settings > Control Panel, double-click Display, then click the Settings tab.
2. Change the Color Palette setting to 256 colors. If it's already at 256 colors, change it to True Color (this may be designated 

as 24-bit color, 16,777,216 colors, or millions of colors). 
3. Change the Desktop Area setting to 640x480. If it's already at 640x480, change it to 800x600. 
4. Click Apply and then OK.
5. Restart Windows and Photoshop. If changing the video display driver fixes the problem, contact your video card 

manufacturer for an updated driver. 

Many video display adapter manufacturers update their software drivers frequently. In general, if you haven't updated your 
display adapter driver recently, contact the video card manufacturer for an updated driver or download one from the 
manufacturer's Web site. To determine the manufacturer of your video card, view the card's properties in Device Manager 
(see solution I in this section).

I. Verify all your device drivers are Windows 95 compatible. Device drivers are software programs that run hardware (e.g., scanner, 
video card, SCSI card, mouse, keyboard). 

NOTE: Some of your hardware devices may require additional utilities, such as the EZ SCSI software, which comes with the 



drivers for SCSI cards. Contact the manufacturer of a device to make sure you are using the latest driver and the correct software.

To isolate device driver conflicts:
1. Choose Start >  Settings > Control Panel, double-click System, and then click the Device Manager tab.
2. Click the plus sign to the left of each device type, and look for any black exclamation marks in yellow circles. 
4. If a device shows an exclamation mark, double-click that device.
5. Look in the Device Status field for further information. 
6. If the Properties dialog box shows a Driver tab, click it. In Windows 95 or Windows 95a, the Provider line in the File Details 

section will tell you the manufacturer of the driver. In Windows 95B, click the Driver File Details button for this information. 
If the manufacturer is listed as Microsoft, you are probably using the most generic version of the driver and not one by the 
manufacturer of the device, and you should get the most recent driver written by the manufacturer. 

J. Specify a different printer as your default printer to determine whether there is a conflict with current default printer driver:
1. Choose Start > Settings > Printers.
2. Right-click a PostScript printer (other than the current default printer), then choose Set as Default from the pop-up menu. If 

a PostScript printer driver isn't installed, you can specify a non-PostScript printer as your default printer. Do not specify a 
non-printing output device, such as a fax or modem. 

If you only have one printer installed, install a PostScript printer driver through the Add Printer Wizard by choosing Start > 
Settings > Printers. When asked, "Do you want your Windows-based programs to use the printer as the default printer?" in 
the Add Printer Wizard dialog box, select Yes. You do not have to have a PostScript printer to install and target a 
PostScript driver. For more information, see document 316834 .

K. Verify Windows is using a fully 32-bit file system:
1. Choose Start > Settings > Control Panel, double-click System, and click the Performance tab.
2. If the File System field says "Some drives are using MS-DOS compatibility," one or more of your drivers are 16-bit and you 

need to install the 32-bit version for complete Windows 95 compatibility. Contact the manufacturer of your hard drives, 
CD-ROM drives, and other SCSI devices for the latest driver. 

L. When you work in an application, a copy of your data file is stored temporarily on the hard drive. Make sure there's adequate 
free space on the hard disk to which temporary files (.tmp) are written by exiting from all applications and then doing the 
following:
-- Remove all temporary files:

1. In Windows Explorer, choose Tools > Find > Files or Folders. 
2. In the Named text box, type "*.tmp".
3. Choose My Computer from the Look In pop-up menu. Some applications write temporary files to hard drive partitions 

and folders other than the ones designated in the Autoexec.bat file. 
4. Click Find Now. 
5. When the search results are displayed, choose Edit > Select All.
6. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. 
7. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the 

Recycle Bin. Windows 95 will not delete temporary files that are still in use, but will delete those not in use.

NOTE: Repeat this procedures from time to time. Windows deletes temporary files when Windows and applications close 
normally. When the system crashes, however, the temporary files can build-up on the hard drive. 

-- Edit the "Set Temp=" line in the Autoexec.bat file to specify a folder on a non-compressed hard drive that has sufficient 
free space:
1. Make a backup copy of the Autoexec.bat file .
2. Open the original Autoexec.bat file, which is in the root folder (e.g., C:\), in a text editor that can save in text-only 

format (e.g., Windows Write, Notepad).
3. Locate the line that begins:

Set temp=

The folder designated on the right of the equal sign is the folder where Windows puts most of its temporary files. 
4. Note the drive letter and folder name (e.g., C:\Temp). If this line does not exist, you will create this line for the 

C:\Temp folder in step 7, after you verify the folder exists on a hard drive with enough space.
5. In Windows Explorer, verify the drive and folder exist. If the drive does not exist, choose another drive. If the folder 

does not exist, create it by clicking on the drive, choosing File > New > Folder, and then typing in the name.
6. Make sure the drive has at least 20-50 MB of free space by right-clicking it and choosing Properties from the pop-up 

menu to see the Free Space field. If this drive does not have enough space, either remove unnecessary files or edit 
the line in the Autoexec.bat file to use a drive that has enough space. 

7. In the Autoexec.bat file, if this line does not exist, add it using the following format:

Set temp=C:\Temp



Where C is the drive with enough space and Temp is the folder you verified or created.
6. Save the Autoexec.bat file in text-only format.
7. Restart Windows.

M. Specify a hard drive partition that has at least 3 to 5 times the file size of your image (or at least ten times the size of bitmap 
mode images) available in free disk space as the primary scratch disk (or for Photoshop 5.0, a third and fourth scratch disk), and 
then specify a secondary scratch disk if your hard drive has enough free space. In Photoshop 4.0.x, do not specify the same hard 
drive partition for both the primary and secondary scratch disks. To specify a scratch disk in Photoshop, choose File > 
Preferences > Plug-ins & Scratch Disks (Photoshop 4.0.x or later) or choose or File > Preferences > Memory (Photoshop 3.0.x ).

Photoshop uses a scratch disk file (i.e., temporary disk space used for storing data and performing computations) when there is 
insufficient RAM for image editing. Photoshop 4.0.x can have up to two scratch disks, and each can be up to 2 GB. Each scratch 
disk must be on a separate hard drive partition. This means if you have 5 GB of free space on an unpartitioned hard drive, and 
all scratch disks are assigned to it, Photoshop 4.0.x can use up to 2 GB of space in one scratch disk file. To use the full 4 GB, 
partition your hard drives so that there are as many partitions as there are scratch disks you want to use. In Photoshop 5.0, you 
can assign up to four partitions for scratch disk files. Although the scratch disk files still have a limit of 2 GB each, Photoshop 5.0 
can write as many scratch disks per partition as there is free disk space. This means if you have 5 GB of free disk space on an 
unpartitioned hard drive, and all scratch disks are assigned to it, Photoshop 5.0 can use up to 5 GB of space in three scratch disk 
files (2 GB, 2 GB, 1 GB).

If you do not have approximately 3 to 5 times the file size of your average file available in free disk space on the drives 
designated as your scratch disks, you should either change the scratch disk location(s) or free more disk space by deleting 
temporary files (see solution L in this section) or removing some other files from the drives. 

NOTE: If you don't have a fixed virtual memory setting (see solution H), choose a hard drive partition different from the one 
where Windows virtual memory is set to. Without a fixed virtual memory setting, Windows can use all the free space on a hard 
drive.

N. Disable hard drive compression to make sure it is not the cause. For more information, check your compression software 
documentation, or your Windows documentation for compression built into Windows.

O. Optimize and defragment your hard drive(s) using either the ScanDisk and Disk Defragmenting utilities included with Windows 
95 or a disk optimization utility (e.g., Norton Utilities by Symantec Corporation). You can access these utilities by choosing Start 
> Programs > Accessories > System Tools. For instructions, refer to your Windows 95 documentation or the documentation 
provided with the disk optimization utility.

ScanDisk scans your hard disk for bad sectors, lost allocation units, and lost chains. ScanDisk can search for and correct lost file 
fragments, cross-linked files, invalid file names and invalid dates and times: all of these items can cause errors in Windows 95. 
ScanDisk should be run on each partition if you have partitioned or multiple hard drives.

Disk Defragmenter rearranges the files and free space on your computer so files are stored in contiguous units and free space is 
consolidated in one contiguous block.  

P. Start Windows 95 in Step-By-Step Confirmation Mode to load only the critical items in the system files (e.g., Config.sys). For 
instructions, see document 316224 . 

Q. Make sure there is only one copy of each of the Windows system files (e.g., Win.com, System.ini, Win.ini, Autoexec.bat) and 
driver files (e.g., files with names ending in .drv) on your computer. If there are multiple copies, rename any duplicated system 
files not located in the Windows directory (e.g., rename the Win.ini file to "Win.old"), then restart Windows. (The exception is the 
Autoexec.bat file, which should be in the root of the C:\ drive, not in the Windows folder.)

R. Turn off Graphics Hardware Acceleration to ensure it is not the cause:
1. Choose Start > Settings > Control Panel, then double-click System. 
2. Select the Performance tab, then click Graphics.
3. In the Advanced Graphics Settings dialog box, move the Graphics Hardware Acceleration slider to None, then click OK.

NOTE: You can experiment with the different acceleration levels to determine which works best with your computer. For 
additional information, see the Microsoft Windows 95 Resource Kit (chapter 17, "Performance Tuning: Setting Graphics 
Compatibility Options").

4. Click OK, then Close.
5. Restart Windows 95.

NOTE: If the system error no longer occurs after disabling Graphics Hardware Acceleration, the source of the problem is 
probably the computer's display adapter. You should use the Graphics Hardware Acceleration option only when your 



computer runs without problems (e.g., system errors).

S. Use the error message to identify the application which is involved in the error. If the error message points directly to an 
application's file, search your hard drive for that file. Deinstall and reinstall the application to which that file belongs. If the error 
message points to a Windows 95 file, reinstall Windows 95 over itself. You may need to go on to solution S and reinstall cleanly. 
However, reinstalling Windows 95 over itself first can save you time in the long run because you can keep your data files on the 
hard drive, and you don't need to reformat your drive.

T. Reformat the drive, then install only Windows 95 and Photoshop from the original installation disks or CD-ROM. Make sure you 
have all application and operating system disks before taking this step. Do not install any additional software or hardware until 
you've made sure that the problem no longer occurs. 

NOTE: Reformatting the drive will erase all files on the drive beyond recovery. Before reformatting, make sure you've backed up 
all your data files (e.g., image, word processing, desktop publishing, or illustration files) you created in all your applications. 
However, don't back up your hard drive and restore Windows and Photoshop instead of reinstalling. If the problem is caused by 
an application or Windows and it is restored, the problem may occur again. 

Try to re-create the error. If the system error no longer occurs, install your other applications one at a time, trying to re-create the 
error after each installation. If the problem occurs right after installing another application, there may be a conflict between it 
and Photoshop. 

If the error persists when you only have Windows 95 and Photoshop installed, the problem is caused by a hardware issue, and 
you should troubleshoot the problem with the help of your computer's manufacturer or an authorized reseller. Before calling the 
manufacturer, however, you may want to try one or more of the following:

Advanced Hardware and Other Troubleshooting
If the tasks listed in the previous section did not solve your system errors, your hardware is probably conflicting with Photoshop.

DISCLAIMER: Adobe does not support hardware, and these solutions are provided only as a courtesy. For further assistance, please 
contact your hardware manufacturer or an authorized reseller. 

NOTE: If you choose to remove or rearrange hardware yourself, turn off the power to the computer and any connected peripherals 
before doing so. Troubleshooting hardware problems yourself may void your computer's warrantee.

A. If you have a SCSI controller for your scanner or hard drives, check your SCSI card for incorrect settings, drivers, hardware 
damage, or cable damage. Also, check that your SCSI chain is terminated properly. For instructions, contact your SCSI card 
manufacturer. 

B. Ensure the RAM SIMMs or DIMMs are installed properly and are not the cause by doing one or more of the following: 
-- Change the order of the installed SIMMs or DIMMs.

-- When you have a large number of SIMMs or DIMMs installed in your computer, remove all but the minimum amount 
needed to run Windows and Photoshop and test to see if the problem persists. If it does, put the ones you removed back in 
and remove the others, testing again to see if the problem persists. If the problem does not occur again, one or more of the 
removed SIMMs or DIMMs are the cause.

C. If your computer has a non-Intel processor (e.g., AMD, Cyrix, Newgen), note that Photoshop was not tested with any non-Intel 
processors. If you have performed all of the above steps and the error still occurs, it is the result of an incompatibility with your 
non-Intel processor. 
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How to Troubleshoot System Errors or Freezes in Photoshop for Windows 98
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As with any software, your Windows 98 operating system may return errors, or may freeze when trying to return an error. Infrequent 
system errors are usually no cause for concern. Frequent system errors, on the other hand, usually indicate a computer hasn't been 
receiving consistent, basic maintenance, or wasn't shut down properly (i.e., by choosing Start > Shut Down) before being turned off. 

System errors can manifest themselves in Adobe Photoshop 5.0.x and earlier in many different ways, including (but not limited to) 
the following:

-- Dialog boxes are blank or flicker or the cursor or screen freezes. 
-- One or more of the following or similar errors occur: 

- "This program has performed an illegal operation and will be shut down. If the problem persists, contact the program 
vendor."

- "PHOTOSHP caused a General Protection Fault in module <filename>." 
- "PHOTOSHP caused an Invalid Page Fault in module <filename>." 
- "Application Error."
- "Unhandled exception detected. Application will be terminated."
- "Illegal Instruction."
- "Segment load failure in <filename>."
- "Unable to intialize Photoshop because the preferences file is invalid."

Although a system error may appear to occur only in Photoshop, this does not necessarily mean Photoshop is the cause. Many 
different factors can cause system errors, including low-level DOS problems, memory conflicts between device drivers, software, 
hardware, and corrupt elements in specific files. Photoshop may just be the only application that is memory- or processor-intensive 
enough to cause another, more fundamental problem to manifest itself. 

How to Use This Document
If you receive multiple system errors or freezes while working in different files in Photoshop 5.0.x and earlier, use this document to 
help determine the cause. This document lists all causes of system errors that occur in Photoshop known to Adobe Technical Support, 
along with the steps necessary to isolate and correct the causes. Adobe Technical Support arranged the troubleshooting tasks in this 
document from the easiest and most likely to resolve common causes to the most complex and likely to resolve uncommon causes. 
The overwhelming majority of system errors can be resolved by performing one or more of the tasks listed in the Beginning to 
Intermediate Troubleshooting section. The tasks listed in the Advanced Hardware and Other Troubleshooting section are extreme 
and are only necessary in rare cases.

Before performing any of the tasks, ask yourself these questions: "Has this problem always occurred?" "If not, when did it start 
occurring?" "Did anything change on the computer since the problem began?" If a problem has always occurred, something already 
set on your system, such as the video display card driver that needs upgrading, could be the cause. If the problem started occurring 
suddenly, the computer might have too little hard disk space left, there may be too many temporary files, or a recent change to your 
system may be the cause. For example, Photoshop may have a conflict with a recently-installed application (e.g., an application 
whose installer created a shortcut to it in the Start > Programs > StartUp menu). Your answers to these questions can help you 
determine the possible cause of the error. You can then perform the troubleshooting tasks that are the most likely to isolate the cause 

first. If you are unable to determine which tasks to perform first, begin with the first item in this document, and then proceed through 
each step, one item at a time. 

Since many variables can cause system errors, it's important to be logical and methodical when isolating and resolving the cause. Be 
sure to perform each step correctly and completely before proceeding on to the next step.

Beginning to Intermediate Troubleshooting
The tasks in this section will help you isolate the most common causes of system errors that occur frequently, and in more than one 
file, in Photoshop. Before performing any of these tasks, make sure to back up all personal files (e.g., Photoshop image files you 
created, third-party plug-ins, etc.). Always restart your computer after a system error occurs to refresh your computer's memory; 
continuing to work without restarting may compound the problem.

NOTE: Some of the solutions in this section require you to look for files with specific filename extensions (e.g., filename.psp). By 



default, Windows Explorer hides filename extensions it recognizes. To display all filename extensions in Windows Explorer:
1. Choose View > Folder Options.
2. Click the View tab in the Folder Options dialog box.
3. Select Show All Files under Hidden Files.
4. Deselect the option labeled, "Hide File Extensions for Known File Types."
5. Click OK.

1. Update or Upgrade Photoshop.
Registered Photoshop users can download free updates from Adobe's Web site at http://www.adobe.com. You can also purchase an 
update on CD-ROM (while supplies last) from Adobe Customer Services at 800-492-3623.

Upgrading to the latest full version (i.e., full release) of Photoshop will solve a wider range of problems. When deciding if you should 
upgrade, remember that hardware and software must meet the latest version's system requirements. You may prefer to try the 
solutions in the rest of this document before upgrading. You can order a Photoshop upgrade from an Adobe Authorized Reseller or 
directly from Adobe. To locate an Authorized Reseller in your area, visit Adobe's Web site at http://www.adobe.com/purchase/#dealer 
or call Customer Services at the number above.

2. Make Sure that Photoshop Has Enough RAM.
Make sure that your computer has at least the minimum amount of random-access memory (RAM) that Photoshop requires to run: 32 
MB. To see how much RAM you have, choose Start > Settings > Control Panel, double-click the System Control Panel. The amount 
of RAM your computer has will be listed at the bottom right of the panel.

3. Re-create Photoshop's Preferences Files.

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0.x and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the Actions 
palette menu. In Photoshop 5.0.x, the actions are saved in a separate preferences file. 

1. Exit from Photoshop.
2. Rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the Photoshop 5.0\Adobe Photoshop Settings folder. 

For earlier versions, delete or rename the Photos40.psp and CColorsd files in the Photoshop\Prefs folder (Photoshop 4.0.x) or 
the Photos30.psp and CColorsd files in the Win32app\Photoshp\Prefs folder (Photoshop 3.0.5).

3. Start Photoshop.

4. Run Photoshop While No Other Programs Are Running in the Background.
Make sure that no programs are starting automatically when Windows 98 starts by doing the following:
-- Exit from active applications one by one by pressing Control+Alt+Delete to display the Close Program dialog box, selecting an 

application, and then clicking End Task. However, do not end the tasks called, "Systray" and "Explorer," as these are basic 
Windows components. Reopen Photoshop and try to re-create the error before closing the next application. If the error does not 
occur after closing an application, that application has a conflict with Photoshop. 

Sometimes after closing an application and viewing the Close Program dialog box again, you will see it is still running. 
Sometimes you'll need to close that application more than once to stop it from running. Other times, this indicates the 
application is loading in the registry or in DOS. Contact the application's manufacturer for information on disabling it. 

-- Prevent programs from starting automatically in Windows by removing them from the StartUp folder:
1. Start Windows Explorer.
2. Move all icons and shortcuts from the Windows\Start Menu\Programs\StartUp folder to another folder.
3. Restart Windows.
4. If the system error continues to occur, move the icons and shortcuts back. If the error does not occur, move them back one at 

a time to isolate the one that was causing the error. 

-- Edit the Win.ini file to disable (i.e., remark out) programs and utilities that load automatically in Windows (e.g., video control 
panels, screen savers, virus protection utilities):
1. Make a copy of the Win.ini file, which is in the Windows folder.
2. Open the original Win.ini file using a text-editing application that can save in text-only format (e.g., Notepad).
3. In the [Windows] section, insert a semicolon at the beginning of the "load=" and "run=" lines:

;load=
;run=

4. Save the Win.ini file in text-only format, then restart Windows.
5. If the system error continues to occur, delete the semicolons you added to each line to restore the original configuration. If 

the error does not occur, delete the semicolons in front of the lines one at a time to isolate the one that was causing the 
error.



5. Remove and Reinstall Photoshop.
Remove Photoshop and then reinstall it while in Safe Mode to make sure that it is installed correctly. For instructions, see document 
322358 .

NOTE: If you had installed an updated version of Photoshop, be sure to reinstall the update after you reinstall Photoshop.

6. Make Sure that Virtual Memory Is Set Correctly.
Re-create the Windows swap file by specifying a fixed virtual memory setting to make sure that a damaged swap file is not the cause: 
1. Exit from all applications.
2. Create a Windows startup disk by choosing Start > Settings > Control Panel, double-clicking Add/Remove Programs, clicking the 

Startup Disk tab, and following the on-screen instructions. (After changing system settings, such as virtual memory, Windows may 
be unable to start, so you may need a startup disk.)

3. Choose Start > Settings > Control Panel, double-click System, click the Performance tab, then click Virtual Memory.
4. Select the option labeled, "Let Me Specify My Own Virtual Memory Settings." 
5. From the Hard Disk pop-up menu, choose a hard drive that has at least twice the amount of your computer's installed RAM. For 

example, if your computer has 24 MB of RAM, choose a hard drive that has at least 48 MB of free space. (If you don't know how 
much hard disk space you have on a drive, start Windows Explorer, right-click on the drive, and choose Properties from the 
pop-up menu to see the Free Space field.)

6. In both the Minimum and Maximum text boxes, enter a value equal to double the amount of your computer's installed RAM.
7. Click OK to close the Virtual Memory dialog box. 
8. When the message, "You have chosen not to let Windows manage virtual memory automatically. . ." appears in the Confirm 

Virtual Memory Setting dialog box, click Yes.
9. Click Close in the System Properties dialog box.
10. Restart Windows by clicking Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the startup disk and 

then restart Windows.

For more information on virtual memory settings, see Related Records or your Windows 98 documentation.

7. Make Sure that Your Video Driver Doesn't Conflict with Photoshop.
Change the number of colors and resolution of the video display adapter to determine whether there is a conflict with your video 
driver:
1. Choose Start > Settings > Control Panel, double-click Display, then click the Settings tab.
2. Change the Color Palette setting to 256 colors. If it's already at 256 colors, change it to True Color (this may be designated as 

24-bit color, 16,777,216 colors, or millions of colors). 
3. Change the Desktop Area setting to 640x480. If it's already at 640x480, change it to 800x600. 
4. Click Apply and then OK.
5. Restart Windows and Photoshop. If changing the video display driver's settings fixes the problem, contact your video card 

manufacturer for an updated driver. 

Many video display adapter manufacturers update their software drivers frequently. In general, if you haven't updated your 
display adapter driver recently, contact the video card manufacturer for an updated driver or download one from the 
manufacturer's Web site. To determine the manufacturer of your video card, view the card's properties in Device Manager (see 
solution 7 in this section).

8. Make Sure that Device Drivers Are Windows 98 Compatible
Device drivers are software programs that run hardware (e.g., scanner, video card, SCSI card, mouse, keyboard). 

NOTE: Some of your hardware devices may require additional utilities, such as the EZ SCSI software which comes with the drivers for 
SCSI cards. Contact the manufacturer of a device to make sure you are using the latest driver and the correct software.

To isolate device driver conflicts:
1. Choose Start >  Settings > Control Panel, double-click System, and then click the Device Manager tab.
2. Click the plus sign to the left of each device type, and look for any black exclamation marks in yellow circles. 
3. If a device shows an exclamation mark, double-click that device.
4. Look in the Device Status field for further information. 
5. If the Properties dialog box shows a Driver tab, click it. If the device manufacturer or provider is not shown here, click Driver File 

Details. If the manufacturer is listed as Microsoft, you are probably using the generic version of the driver and not one by the 
device's manufacturer. You should get the most recent driver written by the manufacturer.  

9. Make Sure that Your Printer Driver Is Compatible with Photoshop.
Specify a different printer as your default printer to determine whether there is a conflict with current default printer driver:
1. Choose Start > Settings > Printers.
2. Right-click a PostScript printer (other than the current default printer), then choose Set as Default from the pop-up menu. If a 

PostScript printer driver isn't installed, you can specify a non-PostScript printer as your default printer. Do not specify a 
non-printing output device, such as a fax or modem. 



If you only have one printer installed, install a PostScript printer driver through the Add Printer Wizard by choosing Start > 
Settings > Printers. When asked, "Do you want your Windows-based programs to use the printer as the default printer?" in the 
Add Printer Wizard dialog box, select Yes. You do not have to have a PostScript printer to install and target a PostScript driver. 
For more information, see document 573005 .

10. Make Sure that the File System Is 32-bit.
Verify Windows is using a fully 32-bit file system:
1. Choose Start > Settings > Control Panel, double-click System, and click the Performance tab.
2. If the File System field says "Some drives are using MS-DOS compatibility," one or more of your drivers are 16-bit and you need 

to install the 32-bit version for complete Windows 95 compatibility. Contact the manufacturer of your hard drives, CD-ROM 
drives, and other SCSI devices for the latest driver. 

11. Optimize Windows's Handling of Temporary Files.
When you work in an application, a copy of your data file is stored temporarily on the hard drive. make sure that there's adequate free 
space on the hard disk to which temporary files (*.tmp) are written by exiting from all applications and then doing the following:
-- Remove all temporary files:

1. Exit from all applications.
2. In Windows Explorer, choose Tools > Find > Files or Folders. 
3. In the Named text box, type "*.tmp". Do not type anything in the Containing Text box.
4. Choose My Computer from the Look In pop-up menu. Some applications write temporary files to hard drive partitions and 

folders other than the ones designated in the Autoexec.bat file. 
5. Click Find Now. 
6. When the search results are displayed, choose Edit > Select All.
7. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. 
8. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the 

Recycle Bin. Windows 98 will not delete temporary files that are still in use, but will delete those not in use.

NOTE: Repeat this procedures periodically. Windows deletes temporary files when Windows and applications close 
normally. When the system crashes, however, the temporary files can build-up on the hard drive. 

-- Edit the "Set Temp=" line in the Autoexec.bat file to specify a folder on a non-compressed hard drive that has sufficient free 
space:
1. Make a backup copy of the Autoexec.bat file .
2. Open the original Autoexec.bat file, which is in the root folder (e.g., C:\), in a text editor that can save in text-only format 

(e.g., Windows Write, Notepad).
3. Locate the line that begins:

Set temp=

The folder designated on the right of the equal sign is the folder where Windows puts most of its temporary files. 
4. Note the drive letter and folder name (e.g., C:\Temp). If this line does not exist, you will create this line for the C:\Temp 

folder in step 7, after you verify the folder exists on a hard drive with enough space.
5. In Windows Explorer, verify the drive and folder exist. If the drive does not exist, choose another drive. If the folder does not 

exist, create it by clicking on the drive, choosing File > New > Folder, and then typing in the name.
6. Make sure that that the drive has at least 20-50 MB of free space by right-clicking it and choosing Properties from the 

pop-up menu to see the Free Space field. If this drive does not have enough space, either remove unnecessary files or edit 
the line in the Autoexec.bat file to use a drive that has enough space. 

7. In the Autoexec.bat file, if this line does not exist, add it using the following format:

Set temp=C:\Temp

Where "C" is the drive with enough space and "Temp" is the folder you verified or created.

8. Save the Autoexec.bat file in text-only format.
9. Restart Windows.

12. Optimize Your Scratch Disks.
Specify a hard drive partition that has at least three to five times the file size of the image (or at least ten times the size of bitmap 
mode images) available in free disk space as the primary scratch disk for Photoshop, and then specify a secondary, third, or fourth 
scratch disk if your hard drive(s) has enough free space. To specify a scratch disk in Photoshop, choose File > Preferences > Plug-ins & 
Scratch Disks.

Photoshop uses a scratch disk file (i.e., temporary disk space used for storing data and performing computations) when there is 
insufficient RAM for image editing. In Photoshop 5.0, you can assign up to four partitions for scratch disk files. Although the scratch 
disk files still have a limit of 2 GB each, Photoshop 5.0 can write as many scratch disks per partition as there is free disk space. This 
means if you have 5 GB of free disk space on an unpartitioned hard drive, and all scratch disks are assigned to it, Photoshop 5.0 can 



use up to 5 GB of space in three scratch disk files (2 GB, 2 GB, 1 GB.)

If you do not have three to five times the file size of your average file available in free disk space on the drives designated as your 
scratch disks, you should either change the scratch disk location(s) or free more disk space by deleting temporary files (see solution 11 
in this section) or removing some other files from the drives. 

NOTE: If you don't have a fixed virtual memory setting (see solution 6), choose a hard drive partition different from the one 
where Windows virtual memory is set to. Without a fixed virtual memory setting, Windows can use all the free space on a hard 
drive.

13. Disable Hard Drive Compression.
Disable hard drive compression to make sure that it is not the cause. For more information, check your compression software 
documentation, or your Windows documentation for compression built into Windows.

14. Optimize and Defragment Your Hard Drive(s).
Optimize and defragment your hard drive(s) using either the ScanDisk and Disk Defragmenting utilities included with Windows 98 or a 
disk optimization utility (e.g., Norton Utilities by Symantec Corporation). You can access these utilities by choosing Start > Programs > 
Accessories > System Tools. For instructions, refer to your Windows 98 documentation or the documentation provided with the disk 
optimization utility.

ScanDisk scans your hard disk for bad sectors, lost allocation units, and lost chains. ScanDisk can search for and correct lost file 
fragments, cross-linked files, invalid file names and invalid dates and times: all of these items can cause errors in Windows 98. 
ScanDisk should be run on each partition if you have partitioned or multiple hard drives.

Disk Defragmenter rearranges the files and free space on your computer so files are stored in contiguous units and free space is 
consolidated in one contiguous block.  

15. Run Photoshop in a Minimized Windows Configuration.
Use Windows System Configuration Utility to load only the critical items in the system files. 
1. Choose Start > Programs > Accessories > System Tools > System Information.
2. Choose Tools > System Configuration Utility.
3. Select Selective Startup then deselect all its check boxes, except the Process System.ini file box.
4. Click OK and restart Windows by clicking Yes in the System Settings Change dialog box.

If errors still occur after restarting in this mode, go on to the next troubleshooting step. If errors do not occur, you can determine which 
item is causing problems in Photoshop by reenabling one item, starting Photoshop, trying to re-create the error, and repeating this 
process until you isolate the one that causes the problem. Contact Microsoft for further information on updating or disabling the item 
that causes the conflict.

When you are done testing the problem with the minimum number of system files loading, repeat the above procedure, but in step 4 
select the option labeled, "Normal startup - load device drivers and software." 

16. Clean Up System and Driver Files.
make sure that there is only one copy of each of the Windows system files (e.g., Win.com, System.ini, Win.ini, Autoexec.bat) and 
driver files (*.drv) on your computer. If there are multiple copies, rename any duplicated system files not located in the Windows 
directory (e.g., rename the Win.ini file to "Win.old"), then restart Windows. (The exception is the Autoexec.bat file, which should be in 
the root of the C:\ drive, not in the Windows folder.)

17. Disable Graphics Hardware Acceleration
Disable Graphics Hardware Acceleration to ensure that it is not the cause:
1. Choose Start > Settings > Control Panel, then double-click System. 
2. Select the Performance tab, then click Graphics.
3. In the Advanced Graphics Settings dialog box, move the Graphics Hardware Acceleration slider to None, then click OK.

NOTE: You can experiment with the different acceleration levels to determine which works best with your computer. For 
additional information, see the Microsoft Windows 98 Resource Kit (Chapter 26, "Performance Tuning").

4. Click OK, then click Close.
5. Restart Windows 98.

NOTE: If the system error no longer occurs after disabling Graphics Hardware Acceleration, the source of the problem is 
probably the computer's display adapter. You should use the Graphics Hardware Acceleration option only when your computer 
runs without problems (e.g., system errors).

18. Troubleshoot MMXCore and FastCore Plug-ins.
If you are using Photoshop 4.0.x, update both your MMXCore and FastCore plug-ins. For instructions, see document 315096 . If the 



error continues to occur after updating these plug-ins, rename the MMXCore and FastCore plug-ins: 
1. Exit from Photoshop.
2. In Windows Explorer, rename the MMXCore.8bx file, which is in the Program Files\Photoshop 5.0\Plug-Ins\Extensions folder to 

"MMXCore.old". 
3. Start Photoshop.
4. If the error continues to occur, exit from Photoshop.
5. In Windows Explorer, rename the fastcore.8bx file, which is in same folder as the MMXCore.8bx file, to "fastcore.old".
6. Start Photoshop. 

19. Identify the File Involved in the Error.
Use the error message to identify the application which is involved in the error. If the error message points directly to an application's 
file, search your hard drive for that file. Deinstall and reinstall the application to which that file belongs. If the error message points to 
a Windows 98 file, reinstall Windows 98 over itself. You may need to go on to solution 20 and reinstall cleanly. However, reinstalling 
Windows 98 over itself first can save you time in the long run because you can keep your data files on the hard drive, and you don't 
need to reformat your drive.

20. Reformat the Hard Drive.
Reformat the drive, then install only Windows 98 and Photoshop from the original installation disks or CD-ROM. Make sure that you 
have all application and operating system disks or CDs before taking this step. Do not install any additional software or hardware until 
you've made sure that the problem no longer occurs. 

NOTE: Reformatting the drive will erase all files on the drive beyond recovery. Before reformatting, make sure that you've 
backed up all your data files (e.g., image, word processing, desktop publishing, or illustration files) you created in all your 
applications. However, don't back up your hard drive and restore Windows and Photoshop instead of reinstalling. If the problem 
is caused by an application or Windows and it is restored, the problem may occur again. 

Try to re-create the error. If the system error no longer occurs, install your other applications one at a time, trying to re-create the error 
after each installation. If the problem occurs right after installing another application, there may be a conflict between it and 
Photoshop. 

If the error persists when you only have Windows 98 and Photoshop installed, the problem is caused by a hardware issue, and you 
should troubleshoot the problem with the help of your computer's manufacturer or an authorized reseller. Before calling the 
manufacturer, however, you may want to continue with the next section.

Advanced Hardware and Other Troubleshooting
If the tasks listed in the previous section did not solve your system errors, your hardware is probably conflicting with Photoshop.

DISCLAIMER: Adobe does not support hardware, and these solutions are provided only as a courtesy. For further assistance, please 
contact your hardware manufacturer or an authorized reseller. 

NOTE: If you choose to remove or rearrange hardware yourself, turn off the power to the computer and any connected peripherals 
before doing so. Troubleshooting hardware problems yourself may void your computer's warrantee.

1. Check for SCSI Problems
If you have a SCSI controller for your scanner or hard drives, check your SCSI card for incorrect settings, drivers, hardware damage, or 
cable damage. Also, check that your SCSI chain is terminated properly. For instructions, contact your SCSI card manufacturer. 

2. Check for Problems with RAM SIMMs or DIMMs
Ensure the RAM SIMMs or DIMMs are installed properly and are not the cause by doing one or more of the following: 
- Change the order of the installed SIMMs or DIMMs.

- When you have a large number of SIMMs or DIMMs installed in your computer, remove all but the minimum amount needed to 
run Windows and Photoshop and test to see if the problem persists. If it does, put the ones you removed back in and remove the 
others, testing again to see if the problem persists. If the problem does not occur again, one or more of the removed SIMMs or 
DIMMs are the cause.

3. Use an Intel processor
Photoshop was not tested with non-Intel processors (e.g., AMD, Cyrix, Newgen). If your computer has a non-Intel processor and the 
error still occurs after and you have performed all of the procedures in this document, the error is likely the result of an incompatible 
non-Intel processor. 
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As with any software, your Windows NT 4.0 operating system may return errors, or may freeze when trying to return an error. Infrequent 
system errors are usually no cause for concern. Frequent system errors, on the other hand, usually indicate a computer hasn't been 
receiving consistent, basic maintenance, or wasn't shut down properly (i.e., by choosing Start > Shut Down) before being turned off. 

System errors that occur in Adobe Photoshop 5.0 and earlier can manifest themselves in many different ways, including (but not 
limited to) the following:

- One or more of the following or similar errors occur: 

"Application Error."

"Application exception error occurred."

"Dr. Watson detects an error"

"Unhandled exception detected. Application will be terminated."

"Illegal Instruction."

"PHOTOSHP caused an Invalid Page Fault in module <filename>." 

"Segment load failure in <filename>."

"Unable to intialize Photoshop because the preferences file is invalid."

"Exception: Access Violation."

- Dialog boxes are blank or flickering, your cursor or screen freezes, etc. 

NOTE: Because Photoshop 3.0.x was released before Windows NT 4.0, it was not tested for use with Windows NT 4.0. 

Although a system error may appear to occur only in Photoshop, this does not necessarily mean Photoshop is the cause. Many 
different factors can cause system errors, including memory conflicts between device drivers, software, hardware, and corrupt 
elements in specific files. Photoshop may just be the only application that is memory- or processor-intensive enough to cause 
another, more fundamental problem to manifest itself. 

How to Use This Document
If you receive multiple system errors or freezes while working in different files in Photoshop 5.0 or earlier, use this document to help 
you determine the cause. This document lists all causes of system errors that occur in Photoshop known to Adobe Technical Support, 
along with the steps necessary to isolate and correct the causes. Adobe Technical Support arranged the troubleshooting tasks in this 
document from the easiest and most likely to resolve common causes to the most complex and likely to resolve uncommon causes. 
The overwhelming majority of system errors can be resolved by performing one or more of the tasks listed in the Beginning to 
Intermediate Troubleshooting section. The tasks listed in the Advanced Hardware and Other Troubleshooting section are extreme 
and are only necessary in rare cases.

Before performing any of the tasks, ask yourself these questions: "Has this problem always occurred?" "If not, when did it start 
occurring?" "Did anything change on the computer since the problem began?" If a problem has always occurred, something already 
set on your system, such as the video display card driver that needs upgrading, could be the cause. If the problem started occurring 
suddenly, the computer might have too little hard disk space left, there may be too many temporary files, or a recent change to your 
system may be the cause. For example, Photoshop may have a conflict with a recently-installed application (e.g., an application 
whose installer created a shortcut to it in the Start > Programs > StartUp menu). Your answers to these questions can help you 
determine the possible cause of the error. You can then perform the troubleshooting tasks that are the most likely to isolate the cause 

first. If you are unable to determine which tasks to perform first, begin with the first item in this document, and then proceed through 
each step, one item at a time. 



Since many variables can cause system errors, it's important to be logical and methodical when isolating and resolving the cause. Be 
sure to perform each step correctly and completely before proceeding on to the next step.

[[My changes below in green. Also see Source field addtions. (and K) - Mike]]

Beginning to Intermediate Troubleshooting
The tasks in this section will help you isolate the most common causes of system errors that occur frequently, and in more than one 
file, in Photoshop. Before performing any of these tasks, make sure to back up all personal files (e.g., Photoshop image files you 
created, third-party plug-ins, etc.). 

NOTE: Some of the solutions in this section require you to look for files with specific filename extensions (e.g., filename.psp). By 
default, Windows NT Explorer hides filename extensions it recognizes. To display all filename extensions in Windows NT Explorer:
1. Choose View > Options.
2. Click the View tab in the Options dialog box.
3. Select Show All Files.
4. Deselect the option labeled, "Hide File Extensions for Known Files."
5. Click OK, then close the Options dialog box.

A. Update or Upgrade Photoshop. Registered Photoshop users can download a free update from Adobe's Web site at 
http://www.adobe.com. You can also purchase an update on CD-ROM (while supplies last) from Adobe Customer Services at 
800-492-3623.

Upgrading to the latest full version (i.e., full release) of Photoshop will solve a wider range of problems. When deciding if you 
should upgrade, remember that hardware and software must meet the latest version's system requirements. You may prefer to try 
the solutions in the rest of this document before upgrading. You can order a Photoshop upgrade from an Adobe Authorized 
Reseller or directly from Adobe. To locate an Authorized Reseller in your area, visit Adobe's Web site at 
http://www.adobe.com/purchase/#dealer or call Customer Services at the number above.

B. Make sure that your computer has at least the minimum amount of RAM that Photoshop requires to run: 32 MB for Photoshop 
5.0; 16 MB for Photoshop 4.0.x. To check the amount of RAM, choose Start > Settings > Control Panel, double-click the System 
Control Panel, then click the General tab. The amount of RAM is listed in the Computer section of the System Properties dialog 
box. 

C. Download and install the latest Windows NT 4.0 Service Pack from http://www.microsoft.com. If you've reinstalled an application 
or Windows NT after installing the latest Service Pack, you'll need to reinstall the Service Pack as well. Some applications 
(including Photoshop) install commonly used system files, overwriting the updated versions installed by the Service Pack. 

D. Re-create Photoshop's preferences files:

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the Actions 
palette menu. In Photoshop 5.0, the actions are saved in a separate preferences file. 

1. Exit from Photoshop.
2. For Photoshop 5.0, rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the Photoshop5\Adobe 

Photoshop Settings folder. For Photoshop 4.0.x, delete or rename the Photos40.psp and CColorsd files in the 
Photoshop\Prefs folder.

3. Start Photoshop.

E. Make sure that no programs are starting automatically when Windows NT starts by doing the following:
-- Prevent programs from starting automatically in Windows by removing them from the StartUp folder:

1. Exit from all applications.
2. Start Windows NT Explorer.
3 Move all icons and shortcuts from the Winnt\Profiles\<Current User>\Start Menu\Programs\Startup folder to another 

folder. This will disable any startup applications that are Private to the Current User's logon from starting 
automatically until you move the icons and shortcuts back. 

4. Move all icons and shortcuts from the Winnt\Profiles\All Users\Start Menu\Programs\Startup folder to another folder. 
This will disable most startup applications that are Common to All Users from starting automatically until you drag the 
icons and shortcuts back. 

5. Restart Windows, then try to re-create the error.
6. If disabling the startup items does not solve the problem, move the icons and shortcuts back. If it does solve the 

problem, move them back one at a time to isolate the one that caused the error. 

-- Close applications that are specified to start automatically in the registry:
1. Right-click the task bar.



2. Choose Task Manager from the pop-up menu.
3. Click the Applications tab. 
4. Select one application name, then click End Task.
5. Restart Photoshop and try to re-create the problem before closing the next application. If the problem does not occur 

after you close an application, that application has a conflict with Photoshop. 

F.    Specify a different printer as your default printer to determine whether there is a conflict with current printer driver:
1. Choose Start > Settings > Printers.
2. Right-click a PostScript printer (other than the current default printer), then choose Set as Default from the pop-up menu. If 

you have only one printer installed, install a PostScript printer driver through the Add Printer Wizard by choosing Start > 
Settings > Printers, and then set it as the default. You do not have to have a PostScript printer to install and target a 
PostScript driver.  

If you do not wish to install a PostScript printer driver, you can specify a non-PostScript printer as your default printer. Do not 
specify a non-printing output device, such as a fax or modem as the default printer. Contact the printer manufacturer to make 
sure that you have the latest printer driver. For more information, see document 312649 .

G. Change the number of colors and resolution of the video display adapter:
1. Choose Start > Settings > Control Panel, double-click Display, then click the Settings tab.
2. Change the Color Palette to 256 colors. If it's already at 256 colors, change it to True Color (this may be designated as 

24-bit color, 16,777,216 colors, or millions of colors). 
3. Change the Desktop Area to 640x480. If it's already at 640x480, change it to 800x600.
4. Click Test, and follow the on-screen instructions.
5. If the test screen displayed properly, click Apply to make the change.
6. Click OK.
7. Restart Windows and then Photoshop. If changing the video display driver fixes the problem, contact your video card 

manufacturer for an updated driver. 

Many video display adapter manufacturers update their software drivers frequently. In general, if you haven't updated your 
display adapter driver recently, contact the video card manufacturer for an updated driver or download one from the 
manufacturer's Web site. 

H. When you work in an application, a copy of your data file is stored temporarily on the hard drive. Make sure that there's 
adequate free space on the hard drive to which temporary files (*.tmp) are written by exiting from all applications and then 
doing the following:
-- Remove all temporary files:

1. Choose Start > Find > Files or Folders. 
2. In the Named text box, type "*.tmp".
3. Choose Local Hard Drives from the Look In pop-up menu. Some applications write temporary files to hard drive 

partitions and folders other than the designated ones. 
4. Click Find Now. 
5. When the search results are displayed, choose Edit > Select All.
6. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. 
7. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the 

Recycle Bin. Windows NT will not delete temporary files that are still in use. Instead, it will return the error, "Cannot 
delete <filename>: Access denied." If a file returns this error, deselect the file noted in the error message by holding 
down the control key and clicking the filename. 

NOTE: Repeat this procedure periodically. Windows deletes temporary files when Windows and applications close 
normally. When the system crashes, however, the temporary files can build-up on the hard drive.

-- Edit or add the TEMP user variable on the Environment tab of the System Control Panel to specify a folder on a 
non-compressed hard drive that has sufficient free space:
1. Choose Start > Settings > Control Panel, double-click System, and click the Environment tab. 
2. In the User Variables section, locate TEMP in the Variable column. The folder designated in the Value column is the 

folder where Windows puts most of its temporary files. 

NOTE: This section may also list a TMP variable. Some applications use the TMP variable for their temporary files, 
while others (including Photoshop) use the TEMP variable. Although you can assign different drives and folders to 
these two variables, you'll have an easier time cleaning out your temporary files if Windows writes them all to the 
same place. 

3. Note the drive letter and folder name (e.g., C:\Temp) in the Value column. If the hard drive is designated as 
"%SystemDrive%," this is the same hard drive on which the Winnt folder resides. If this value does not exist, you will 
create it with a value of C:\Temp in step 7, after you verify the folder is on a hard drive with enough space. 

4. In Windows NT Explorer, verify that the drive and folder exist. If the drive does not exist, choose another drive. If the 



folder does not exist, create it by selecting the drive, choosing File > New > Folder, and then naming the folder 
"Temp".

5. Make sure that the drive has at least 20-50 MB of free space by right-clicking it and choosing Properties from the 
pop-up menu. Note the Free Space field on the General tab. If this drive does not have enough space, either remove 
unnecessary files or edit value of the TEMP variable to use a drive that has enough space. 

NOTE: Check with your system administrator before editing or adding a variable. You may need to have Administrator 
access.

6. If the TEMP variable does not exist in the User Variables section, type TEMP in the Variable text box. If the TEMP 
variable exists, select the variable name. Then type the following in the Value text box:

C:\Temp

Where "C" is the drive with enough space and "Temp" is the folder you verified or created.

7. Click Set, then click OK.
8. Restart Windows.

I. For the primary scratch disk, specify a hard drive partition that has free disk space equal to at least three to five times the file size 
of the image (or at least ten times the size of bitmap mode images) and then specify a secondary scratch disk if your hard drive 
has enough free space. (In Photoshop 5.0, you can also specify a third and fourth scratch disk). In Photoshop 4.0.x, do not 
specify the same hard drive partition for both the primary and secondary scratch disks. To specify a scratch disk in Photoshop, 
choose File > Preferences > Plug-ins & Scratch Disks (Photoshop 4.0.x or later).

Photoshop uses a scratch disk file (i.e., temporary disk space used for storing data and performing computations) when there is 
insufficient RAM for image editing. Photoshop 4.0.x can have up to two scratch disks, and each can be up to 2 GB. Each scratch 
disk must be on a separate hard drive partition. For example, if you have 5 GB of free space on an unpartitioned hard drive, and 
all scratch disks are assigned to it, Photoshop 4.0.x can use up to 2 GB of space in one scratch disk file. To use the full 4 GB, 
partition your hard drives so that there are as many partitions as there are scratch disks you want to use. In Photoshop 5.0, you 
can assign up to four partitions for scratch disk files. Although the scratch disk files still have a limit of 2 GB each, Photoshop 5.0 
can write as many scratch disks per partition as there is free disk space: If you have 5 GB of free disk space on an unpartitioned 
hard drive, and all scratch disks are assigned to it, Photoshop 5.0 can use up to 5 GB of space in three scratch disk files (2 GB, 2 
GB, 1 GB).

If you do not have enough available free disk space on the drives designated as your scratch disks, you should either change the 
scratch disk location(s) or free more disk space by deleting temporary files (see solution H in this section) or removing unneeded 
files. 

NOTE: If possible, choose a hard drive partition other than the one specified for Windows virtual memory (see solution J).

J. Re-create the virtual memory paging file:
1. Exit from all applications.
2. Choose Start > Settings > Control Panel, double-click System, then click the Performance tab.
3. In the Virtual Memory section, click Change.
5. From the Drive list, select a hard drive that has at least twice the amount of your computer's installed RAM. For example, if 

your computer has 24 MB of RAM, select a hard drive that has at least 48 MB of free hard drive space. For best 
performance, choose a different hard drive than those used for the Photoshop scratch disks.

6. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your 
computer's installed RAM plus 12 MB. 

7. In the Maximum Size box, enter a value equal to twice the amount of your computer's installed RAM.
8. Click Set, then click OK.
9. Click OK to close the System Properties dialog box.
10. To restart Windows, click Yes in the System Settings Change dialog box. 

K. Scan your hard drive(s) for errors by using the CHKDSK/f command at the Command Prompt or by using a Windows NT 
4.0-compatible third-party utility. 

L. Remove Photoshop and then reinstall it from the installation disks or CD-ROM while in VGA mode. Starting Windows NT 4.0 in 
VGA mode loads fewer drivers than normal mode. The most significant of these is the video driver, which is temporarily 
replaced with the Windows NT 4.0 standard VGA driver. You must restart Windows NT in normal mode to start Photoshop.
1. Move any personal files (e.g., images, third-party plug-ins) out of the Photoshop folder and its subfolders. 
2. Choose Start > Settings > Control Panel, double-click Add\Remove Programs, select Adobe Photoshop, and then click 

Add/Remove. If the Photoshop folder exists after the uninstall, delete it and its subfolders.
3. Restart Windows NT 4.0.
4. When the computer reboots, choose the menu choice Windows NT Workstation Version 4.00 [VGA Mode]. If this menu 



doesn't appear or flashes by too quickly, choose Start > Settings > Control Panel, double-click System, and choose the 
Startup/Shutdown tab. Increase the number set for the "Show list for . . . seconds" option in the System Startup.

5. Insert the Photoshop CD-ROM and choose Install Photoshop from the Autoplay window. If Autoplay does not load, choose 
Start > Find > Files or Folders in Windows NT Explorer, search the Photoshop folder on the CD-ROM for Setup.exe, then 
double-click the file. If you have installation disks (Photoshop 4.0.x or earlier), insert Disk 1 and then double-click 
Setup.exe.

6. Restart the computer in Normal mode. You may need to reinstall the latest Windows NT Service Pack, because the 
Photoshop installer installs versions of common files that are older than the ones in the Service Packs. For more 
information, visit Microsoft's Web site or contact Microsoft.

NOTE: If you had installed an updated version of Photoshop, be sure to reinstall the update after you reinstall Photoshop.

M. Disable hard drive compression. Compression can be applied to the entire drive or specific folders. For more information, 
consult your Windows NT documentation.

N. Use Event Manager to check for reports of damaged files or stopped drivers (i.e., drivers that failed to start or load). 
1. Choose Start > Programs > Administrative Tools (Common) > User Manager, and click your user name.
2. Choose Policies > Audit.
3. In the Audit Policy dialog box, select Audit These Events, then select the Failure option on the File and Object Access 

line. 
4. Click OK and then attempt to re-create the error. If the error occurs again, choose Start > Programs > Administrative Tools 

(Common) > Event Viewer.
5. Choose Log > System.
6. In lines that begin with a red stop sign, the Source column will indicate which service or driver is stopped. Lines that begin 

with an exclamation mark in a yellow circle are warnings of possible trouble, such as a nearly full hard drive.

If you find it hard to determine what events relate to your error message, start a fresh system log. In the Event Viewer, 
choose Log > Clear All Events, and save the events in a file when prompted. Then attempt to re-create the error and view 
the system log.

O. Disable Application Performance Boosting:
1. Choose Start > Settings > Control Panels, double-click System, then click the Performance tab.
2. Under Application Performance, move the slider from Maximum to None.

Application Performance Boosting specifies the priority of the foreground application relative to background applications. 
Setting it to None gives equal amounts of processor time to all applications.

P. Verify that all your device drivers are compatible with Windows NT 4.0. Device drivers are software programs that run hardware 
(e.g., scanner, video card, SCSI card, mouse, keyboard, CD-ROM, or removable hard drives and media). Some of your hardware 
devices may require additional utilities, such as the EZ SCSI software which comes with the drivers for SCSI cards. Contact the 
manufacturer of a device to make sure you are using the latest driver and the correct software.

Q. Use the error message to identify the application which is involved in the error. If the error message points directly to an 
application's file, search your hard drive for that file. Deinstall and reinstall the application to which that file belongs. If the error 
message points to a Windows NT file, reinstall Windows NT over itself. You may need to go on to solution Q and reinstall 
cleanly. However, reinstalling Windows NT over itself first can save you time because you can keep your data files on the hard 
drive, and you don't need to reformat your drive.

R. Reformat the drive, install only Windows NT 4.0 and Photoshop from the original installation disks or CD-ROM, then the latest 
Windows NT Service Pack (see solution B). Make sure you have all application and operating system disks, and that you've 
downloaded the latest Service Pack and stored it on an external drive before taking this step. Do not install any additional 
software or hardware until you've made sure that the problem no longer occurs. 

NOTE: Reformatting the drive will erase all files on the drive beyond recovery. Before reformatting, make sure you've backed up 
all your data files (e.g., image, word processing, desktop publishing, and illustration files) you created in all your applications. 
Don't back up your hard drive and restore Windows and Photoshop instead of reinstalling, however. If the problem is caused by 
an application or Windows and it is restored, the problem may occur again. 

Try to re-create the error. If the system error no longer occurs, install your other applications one at a time, trying to re-create the 
error after each installation. If the problem occurs right after installing another application, there may be a conflict between it 
and Photoshop. 

If the error persists when you only have Windows NT and Photoshop installed, the problem is caused by a hardware issue, and 
you should troubleshoot the problem with the help of your computer's manufacturer or an authorized reseller. Before calling the 
manufacturer, however, you may want to try one or more of the following:



Advanced Hardware and Other Troubleshooting
If the tasks listed in the previous section did not solve your system errors, your hardware is probably conflicting with Photoshop.

DISCLAIMER: Adobe does not support hardware, and these solutions are provided only as a courtesy. For further assistance, please 
contact your hardware manufacturer or an authorized reseller. 

NOTE: If you choose to remove or rearrange hardware yourself, turn off the power to the computer and any connected peripherals 
before doing so. Troubleshooting hardware problems yourself may void your computer's warrantee.

A. If you have a SCSI controller for your scanner or hard drives, check your SCSI card for incorrect settings, drivers, hardware 
damage, or cable damage. Also, check that your SCSI chain is terminated properly. For instructions, contact your SCSI card 
manufacturer. 

You can find some SCSI hardware problems and the name of the driver files using the SCSI Adapters Control Panel:
1. Choose Start > Settings > Control Panel, and double-click SCSI Adapters. 
2. For each adapter listed on the Devices tab, click the name and then click Properties. The Device Status section on the 

Cardinfo tab will tell you if the SCSI adapter is working correctly or not, but it only reports hardware problems. 
3. If you suspect there's a problem with this device or driver, click the Driver tab and note the Driver Name and Driver File. 

Either rename these files in Windows NT Explorer then reinstall the SCSI device drivers, or contact the manufacturer of 
your SCSI card for updated drivers or further help.

B. Ensure that the RAM SIMMs or DIMMs are installed properly and are not the cause by doing one or more of the following: 
-- Change the order of the installed SIMMs or DIMMs.

-- If you have a large number of SIMMs or DIMMs installed in your computer, remove all but the minimum amount needed to 
run Windows and Photoshop and test to see if the problem persists. If it does, put the ones you removed back in and 
remove the others, testing again to see if the problem persists. If the problem does not occur again, one or more of the 
removed SIMMs or DIMMs are the cause.

C. If your computer has a non-Intel processor (e.g., AMD, Cyrix, Newgen), note that Photoshop was not tested with non-Intel 
processors. If you have performed all of the above steps and the error still occurs, the cause may be an incompatibility with your 
non-Intel processor.
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When artifacts (unexpected pixel data) appear in an Adobe Photoshop image, they indicate that the image file contains damaged 
data. Artifacts may appear as areas of unexpected color, a line, a series of repeating lines, areas where one or more of the color 
channels have missing or misplaced information, scrambled image elements, or random pixels (called "noise") scattered throughout 
an image. Artifacts are part of the file's data -- they not only appear on your monitor, but are also present when you print the image 
or move it to another computer. 

Once a file has artifacts, it is permanently damaged. To ensure other files don't get damaged, it's important that you find and 
eliminate the variable(s) causing the artifacts and back files up more often.

What Causes Artifacts
Artifacts are caused by problems with the hardware and software upon which Photoshop and your file are dependent. Artifacts usually 
occur when you save or copy a file. The most common causes of artifacts are:

- media problems (e.g., bad sectors or bad blocks)
- bad RAM
- damaged or poor-quality SCSI or IDE cables, connectors, or other connection hardware
- SCSI problems (e.g., termination or ID conflicts)
- network problems (software or hardware)
- operating system problems
- radio, electrical, or magnetic interference

Distinguishing Artifacts from Display Problems
An unexpected element or the appearance of damaged data may not be an artifact. Using the program incorrectly, as well as display 
problems and limitations can cause false artifacts. Some of these false artifacts appear only on-screen, but some are a permanent 
part of the file's data. 

These display problems are not artifacts, because the incorrectly displayed pixels are not part of the file's data. To determine if you're 
seeing a display problem or an artifact, sample the affected pixels with the eyedropper tool to determine if their color value is 
different from the color displayed, or move the suspect file to another computer and see if the artifact appears there as well. If the 
image appears to be damaged on the other computer, it's probably not just a display issue, but damaged data.

The on-screen appearance of images in any application is affected by the computer's video display. For example, on systems 
incapable of displaying 24-bit color (millions of colors), images often appear grainy, pixelated, or blotchy. 

Even on 24-bit displays, though, full-color images can be manipulated in Photoshop until the image data has too few colors or 
unwanted pixelization (e.g., using the Posterize command or converting to indexed color). The most common causes of permanent 
false artifacts are: scanning at low resolution, creating images at low resolution, resaving a JPEG file (i.e., recompressing a file 
already saved in a lossy compression format), viewing an image at high magnification, or increasing an image's resolution beyond its 
actual image data. Such images often appear pixelated, speckled, or jagged. When applied repeatedly to an image, some 
Photoshop commands or filters (e.g., Levels or Noise) can cause images to appear to be damaged and/or of low quality. When 
working with such commands or filters, work with a copy of the file so you won't risk damaging the image's data. Instead of modifying 
a JPEG image, always modify the native Photoshop file and save it in JPEG format.

Troubleshooting Process
To determine what's causing artifacts, you need to remove, replace, and update suspect system variables. Once you have established 
a pattern, you can reduce the number of variables, making troubleshooting much faster and more efficient. 

After removing a variable, continue working in Photoshop and see if the artifacts continue. If they do not, start adding back variables 
one at a time and continue testing. If, at some point in this process, you can re-create the artifacts, the last variable added is the most 
likely cause. Remove it and continue testing. If none of the other variables cause artifacts, you've found the cause. 



Keep a Log to Discover Patterns
Because artifacts occur for many different reasons, determining the cause can be very time consuming. Also, since artifacts often 
occur intermittently or infrequently, it can be difficult to determine whether your troubleshooting has solved the problem. If you can 
find a pattern in the way the artifacts appear, you can troubleshoot them much more easily. 

Keeping a log while working and troubleshooting in Photoshop helps you isolate which system variables are causing the problem. Be 
sure to record all information about the images in which artifacts appear, including file size, dimensions, file type, what hard drive 
they were saved to, the troubleshooting you did and the result of that troubleshooting, the filters you have used, and any suspicious 
behavior you notice in the operating system or any application. 

Your log should also indicate whether artifacts appear in one, some, or all images. If artifacts appear in a single image, that image 
may be damaged, while Photoshop and your system are fine. If artifacts appear in some, but not all, images, look for things that the 
affected images have in common. Are they
all the same size? Do they all contain the same kind or number of elements (e.g., many layers, channels, or paths)? Also, examine 
your workflow: have all the affected images been moved and stored to or from the same location? If you can find a pattern, you will 
reduce the number of variables you have to test.

Troubleshooting Photoshop- and System-Related Variables
Damaged or incompatible software components can cause artifacts in Photoshop images. The troubleshooting procedures in this 
section will help you isolate the most common causes of artifacts that occur frequently, and in more than one file. Before performing 
any of these tasks, back up all personal files, such as Photoshop image files you created. Restart your computer after each 
troubleshooting step to refresh your computer's memory. 

1. If You're Using Photoshop 5.0 Update to Photoshop 5.0.2
Photoshop 5.0 for Mac OS sometimes adds band-shaped artifacts to a large image when you reduce its pixel dimensions. 
Photoshop 5.0.2 reduces pixel dimensions of large images without adding artifacts. 

Registered users can download the Photoshop 5.0.2 update for free from Adobe's Web site at 
http://www.adobe.com/prodindex/photoshop/updat502.html, or purchase it on CD-ROM for $14.95 from Adobe Customer 
Services at 800-492-3623.

2. Save Images to a Local Hard Disk
Save and open files directly to or from a local hard disk. Photoshop was not designed to open or save files to anything other 
than a local hard disk. Use the Finder to copy files to a network drive or removable disk. 

3. Test the Photoshop Plug-ins for Damage or Incompatibility
Move the Plug-ins folder from the Photoshop folder to a new folder on your desktop, and try to re-create the artifact:
1. Quit Photoshop.
2. Create a new folder outside of the Photoshop folder (e.g., on the desktop) to temporarily store the Photoshop plug-ins.
3. Open the Photoshop:Plug-ins folder, then select all the plug-ins and folders in the Plug-ins folder by pressing 

Command+A.
4. Move all the plug-ins and folders within the Plug-ins folder to the folder you created in step 2.
5. Rename the Photoshop preferences files. If you are using Photoshop 5.0.x, rename the Adobe Photoshop 5 Prefs.psp and 

Color Settings.psp files in the Photoshop5\Adobe Photoshop Settings folder. If you are using Photoshop 4.0.x, delete or 
rename the Photos40.psp and CColorsd files in the Photoshop\Prefs directory.

Note: If you delete the preferences file, custom Preferences settings (Photoshop 5.0.x and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the 
Actions palette menu. In Photoshop 5.0.x, the actions are saved in a separate preferences file. 

6. Restart Photoshop and try to re-create the artifact. If you can't, add plug-ins back one at a time (restarting Photoshop after 
each time you add one or more plug-ins) until you find the one that caused the artifact. 

4. Check for Outdated Multiprocessor Plug-ins If You Have DayStar Digital Equipment
DayStar Digital makes accelerator boards, and Genesis MP Macintosh-clone computers. Both DayStar Digital and Adobe have 
heard reports from customers of artifacts running Photoshop (usually version 4.0.x) on multiprocessor Macintosh computers using 
Daystar components (e.g., Daystar Genesis 360 Multiprocessor PowerMac clones). 

Disclaimer: Adobe does not support other companies' hardware or software, and these solutions are provided only as a 
courtesy. For further support or to get an updated plug-in, please contact DayStar Digital at http://www.daystar.com or 
800-962-2077. 

- If you are using Photoshop 3.0.5, make sure the Photoshop Plug-ins folder has only one Multiprocessor Accelerator plug-in, 
and that it is version 1.0.2 or later.

- If you are using Photoshop 4.0.x or later, make sure the Photoshop Plug-ins folder includes only one Multiprocessor 
Extension plug-in and does not include the Multiprocessor Accelerator plug-in. 



5. Run Photoshop With Extensions Off
To turn extensions off upon startup in System 7.0.x or later, restart the computer with the Shift key held down until the message 
"Welcome to Macintosh. Extensions Off." appears. This will also disable any virtual memory or RAM compression software (e.g., 
RAM Doubler).

If you can't re-create the artifacts with extensions disabled, troubleshoot extension conflicts. For instructions, see document 
314385 , "Disabling Extensions and Isolating Extension Conflicts in System 7.x," or document 311687 , "Disabling Extensions 
and Isolating Extension Conflicts in Mac OS 8.0.x."

Holding the Shift key down at startup disables most, but not all system extensions. If you can re-create the artifacts after you 
restart with the Shift key held down, take the following steps to manually remove all system extensions (and other software that 
loads at startup) from the System Folder:
1. Move the Control Panels, Extensions, Fonts, and Preferences folders from the System Folder to the desktop.
2. If you are using System 7.x, skip to step 4. If you are using Mac OS 8.0.x, create a new folder, name it "Extensions," then 

move it into the System Folder.
3. Move the Appearance extension from the old Extensions folder into the Extensions folder you created in step 2. This 

extension is required by Mac OS 8.0.x.  
4. Restart the Macintosh and try to re-create the artifacts. 

6. Make Sure Your Hard Disk Isn't Damaged or Fragmented
Check the hard drive by doing one or more of the following:
- Use a disk repair utility (e.g., Apple Disk First Aid, Norton Disk Doctor or TechTool Pro) to check for disk problems. 

Disclaimer: Adobe Systems does not provide support for third-party diagnostic software. The following instructions are 
provided as a courtesy. Contact the developer of your disk utility for support.

To use Apple's Disk First Aid utility, included on your system software CDs:
1. Start the computer from any bootable floppy disk (i.e., the floppy labeled "Disk Tools" included with your System 7.x 

installation disks) or system software CD.
2. Double-click the Disk First Aid application. 
3. Select the drives to be verified or repaired.
4. Click Verify to check the disk or Repair to check and repair the disk. If you click Verify, Disk First Aid tells you if there is 

a problem with the disk and asks you if you want to repair it. Always repair the disk when prompted.
5. Choose File > Quit.

- Use a third-party disk utility (e.g. Norton Utilities, TechTool Pro or Symantec Tools for Mac OS) to ensure damaged sectors 
are marked unusable. For instructions, refer to the utility's documentation.

- Defragment and optimize your hard drive using a disk utility (e.g., Norton Utilities or MacTools). For instructions, refer to the 
utility's documentation.

7. Use a Different Hard Drive
Run Photoshop on a different hard drive installed in the same computer. Also, specify a Scratch Disk on this drive by choosing 
File > Preferences > Plug-ins & Scratch Disks (Photoshop 4.0.x or later) or choosing File > Preferences > Scratch Disk (Photoshop 
3.0.x ). If you can still re-create the artifacts, try using the same hard drive installed in a different computer, making sure to set up 
the Scratch Disk there as well.

8. Perform a Clean Install of the Operating System
Replace the system software by performing a clean install (i.e., installing new system software into a new System Folder, instead 
of installing over the existing system software). Please note that simply running the system software installer or an updater (e.g., 
System 7.5.3 - System Updater 2.0) does not ensure that a completely new copy of system software will be properly installed. 
Rather than just running an updater, it is necessary to install a new System Folder. If your most recent system floppy or CD is an 
updater (not a full version), reinstall the most recent full version before running the updater. For more information on performing 
a clean system software installation, see Related Records.

9. Use Compatible Hard Disk Drivers
Make sure the hard disk drivers on your computer and all media formatting are compatible with Apple's SCSI Manager 4.3.1 or 
later. For information about formatting software's compatibility with SCSI Manager 4.3.1, contact the manufacturer of the drive 
mechanism and your formatting software. Reformatting your hard disk after updating the hard disk driver is not required, but 
reformatting may repair bad media problems that can cause artifacts.

NOTE: Reformatting the drive will erase all files on it. Before reformatting, make sure you've backed up all your data files for all 
your applications.  

Common hard drive formatting software that is compatible with SCSI Manager 4.3.1 includes:
- Apple's HDSC 7.3 or later or Drive Setup 1.0.x and later, for Apple hard drives (Drive Setup must be used to format or 



update IDE drives in newer Macintosh computers)
- FWB's Hard Disk Toolkit 1.62 or later
- La Cie's SilverLining 5.54, 5.6, or later

For additional information about your hard drive formatting software, contact the product's developer.

10. Reformat the Hard Disk
Reformat the disk, then install only the system software and Photoshop from the original installation disks or CD. Do not install 
any additional software or hardware until you've made sure you cannot re-create the artifacts. 

NOTE: Reformatting the hard disk will erase all files on it. Before reformatting, make sure you've backed up all personal files 
(e.g., image, word processing, desktop publishing, and illustration files). Depending on the frequency of the artifacts, you may 
prefer to test possible hardware conflicts before reformatting your hard disk.

Try to re-create the artifact. If it persists in this simplified configuration, the problem is caused by a hardware issue. You should 
troubleshoot the problem with the help of the manufacturer or an authorized reseller, suggesting that they try one or more of the 
procedures in the following section.

Troubleshooting Hardware Variables
If the tasks listed in the previous section did not eliminate the artifacts in your Photoshop images, your hardware may be damaged or 
conflicting with Photoshop.

Disclaimer: Adobe does not support hardware, and these solutions are provided only as a courtesy. For further assistance, please 
contact your hardware manufacturer or an authorized repair service facility. 

Note: Only Apple-certified repair facilities should repair your Macintosh. If you choose to remove or rearrange hardware yourself, turn 
off the power to the computer and any connected peripherals before doing so. Be aware that troubleshooting hardware yourself may 
void your warranty. 

1. Check for Problems with RAM SIMMs or DIMMs 
Get Info on the Photoshop Application file (Command + I) and set the minimum and preferred settings to the default amount of 
RAM listed in the minimum memory setting. Then, start Photoshop and try to re-create the artifacts. If you can't re-create the 
artifacts, you probably have bad RAM that should be
replaced. Note, however, that even if you can re-create the artifacts, you may still have bad RAM. 

To make sure the RAM SIMMs or DIMMs are not causing the artifacts do one or more of the following:
- There are also free utilities available that perform RAM diagnostics for you such as RAMometer for the Mac by Newer 

Technology, but they cannot catch all problems.
-- Remove then reinstall the SIMMs or DIMMs to ensure they are seated properly. 
-- If you have a large number of SIMMs or DIMMs installed in your computer, remove a subset of them. For example, if 

you have four SIMMs or DIMMs installed, remove two and test to see if the problem persists. If it does, put those two 
back in and remove the other two, testing again to see if the problem persists. If you can't re-create the artifact, one or 
more of the removed SIMMs or DIMMs are the cause.

-- Change the order of the SIMMs or DIMMs.
-- Install new SIMMs or DIMMs. 
-- Remove composite RAM SIMMs. Adobe does not recommend using composite RAM SIMMs.
-- Make sure your SIMMs or DIMMs are all of the same speed and size, and are from the same manufacturer. Check with 

your dealer to determine the speed, size, and manufacturer of installed SIMMs or DIMMs.

2. Troubleshoot SCSI Devices
When external SCSI devices (e.g., external hard drives, removable media drives, ZIP drives, Jazz Drives, optical drives, external 
CD-ROM drives or scanners) are connected to the Macintosh, ensure SCSI connection devices, cables, or termination are not the 
cause by turning the computer and these devices off, disconnecting all SCSI devices from the Macintosh, then restarting the 
computer. If your computer has multiple devices you can leave them connected to each other, but you need to disconnect the 
entire SCSI chain from the back of the computer. 

Note: Do not connect or disconnect SCSI cables or SCSI devices with the power turned on for the computer or SCSI devices. 
Doing so can permanently damage the computer or the SCSI devices or both. For more information on SCSI troubleshooting, 
see document 316381 , "SCSI Chain Troubleshooting Guide."

3. Check for Damaged Expansion Cards
Turn off the computer, remove cache cards and other expansion cards installed in the computer, then restart the computer.

4. Remove Any Clock-Chip Accelerators from the Processor 
A clock-chip accelerator (e.g., Newer Technology's PowerClip) is hardware added to your CPU that forces your computer's 
processor to run at a higher speed. Adobe Photoshop was not designed for nor tested with clock-chipped CPUs. Under some 



conditions, a clock-chipped CPU may cause crashes or artifacts. 

5. Replace the Motherboard 
Replace the computer's motherboard (logic board). When doing so, you should also replace the Macintosh ROM and PowerPC 
processor. In some cases the Macintosh ROM or processor, or both, may be moved from one motherboard to another; if the 
problem you are experiencing is caused by a malfunctioning Macintosh ROM or processor, replacing the motherboard while 
using the original Macintosh ROM or processor will not solve the problem. If you replace your computer's motherboard, Adobe 
recommends also replacing the Macintosh ROM and processor on the motherboard at the same time. Check with the service 
technician who replaces the motherboard to be sure that the new motherboard also contains a new ROM and processor.

6. Check to See If You Are Using a PowerMac 8100 100/110/120 Series or
PowerComputing Powerbase 100/110/120 Series Computer Adobe Technical Support has learned that Photoshop 4.0.x may 
create artifacts in CMYK TIFF and
EPS graphics when run on computers with a 601 processor running at 100, 110, or 120 MHz, and the Nu-Bus internal bus 
architecture (e.g., PowerMac 8100 100/110/120 series, PowerComputing Powerbase 100/110/120). However, this does not occur 
on all machines, even all machines in a given lab. If you've done every solution in this document and you still can re-create 
artifacts on one of these machines, work with your original files in RGB or Lab mode. Then, save a copy of the file, then open 
and save the copy in another application that can save in CMYK (e.g., Macromedia FreeHand). 
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When artifacts (unexpected pixel data) appear in an Adobe Photoshop image, they indicate that the image file contains damaged 
data. Artifacts may appear as areas of unexpected color, a line, a series of repeating lines, areas where one or more of the color 
channels have missing or misplaced information, scrambled image elements, or random pixels (called "noise") scattered throughout 
an image. Artifacts are part of the file's data -- they not only appear on your monitor, but are also present when you print the image 
or move it to another computer. 

Once a file has artifacts, it is permanently damaged. To ensure other files don't get damaged, it's important that you find and 
eliminate the variable(s) causing the artifacts and back files up more often.

What Causes Artifacts
Artifacts are caused by problems with the hardware and software upon which Photoshop and your file are dependent. Artifacts usually 
occur when you save or copy a file. The most common causes of artifacts are:

- media problems (e.g., bad sectors or bad blocks)
- bad RAM
- damaged or poor-quality SCSI or IDE cables, connectors, or other connection hardware
- SCSI problems (e.g., termination or ID conflicts)
- network problems (software or hardware)
- operating system problems
- radio, electrical, or magnetic interference

Distinguishing Artifacts from Display Problems
An unexpected element or the appearance of damaged data may not be an artifact. Using the program incorrectly, as well as display 
problems and limitations can cause false artifacts. Some of these false artifacts appear only on-screen, but some are a permanent 
part of the file's data. 

These display problems are not artifacts, because the incorrectly displayed pixels are not part of the file's data. To determine if you're 
seeing a display problem or an artifact, sample the affected pixels with the eyedropper tool to determine if their color value is 
different from the color displayed, or move the suspect file to another computer and see if the artifact appears there as well. If the 
image appears to be damaged on the other computer, it's probably not just a display issue, but damaged data.

The on-screen appearance of images in any application is affected by the computer's video display. For example, on systems 
incapable of displaying 24-bit color (millions of colors), images often appear grainy, pixelated, or blotchy. 

Even on 24-bit displays, though, full-color images can be manipulated in Photoshop until the image data has too few colors or 
unwanted pixelization (e.g., using the Posterize command or converting to indexed color). The most common causes of permanent 
false artifacts are: scanning at low resolution, creating images at low resolution, resaving a JPEG file (i.e., recompressing a file 
already saved in a lossy compression format), viewing an image at high magnification, or increasing an image's resolution beyond its 
actual image data. Such images often appear pixelated, speckled, or jagged. When applied repeatedly to an image, some 
Photoshop commands or filters (e.g., Levels or Noise) can cause images to appear to be damaged and/or of low quality. When 
working with such commands or filters, work with a copy of the file so you won't risk damaging the image's data. Instead of modifying 
a JPEG image, always modify the native Photoshop file (.psd) and save it in JPEG format. 

Troubleshooting Process
To determine what's causing artifacts, you need to remove, replace, and update suspect system variables. Once you have established 
a pattern, you can reduce the number of variables, making troubleshooting much faster and more efficient. 

After removing a variable, continue working in Photoshop and see if the artifacts continue. If they do not, start adding back variables 
one at a time and continue testing. At some point in the process, if you can re-create the artifacts, the last variable added is the most 
likely cause. Remove it and continue testing. If none of the other variables cause artifacts, you've found the cause. 

Keep a Log to Discover Patterns



Because artifacts occur for many different reasons, determining the cause can be very time consuming. Also, since artifacts often 
occur intermittently or infrequently, it can be difficult to determine whether your troubleshooting has solved the problem. If you can 
find a pattern in the way the artifacts appear, you can troubleshoot them much more easily. 

Keeping a log while working and troubleshooting in Photoshop helps you isolate which system variables are causing the problem. Be 
sure to record all information about the images in which artifacts appear, including file size, dimensions, file type, what hard drive 
they were saved to, the troubleshooting you did and the result of that troubleshooting, the filters you have used, and any suspicious 
behavior you notice in the operating system or any application. 

Your log should also indicate whether artifacts appear in one, some, or all images. If artifacts appear in a single image, that image 
may be damaged, while Photoshop and your system are fine. If artifacts appear in some, but not all, images, look for things that the 
affected images have in common. Are they all the same size? Do they all contain the same kind or number of elements (e.g., many 
layers, channels, or paths)? Also, examine your workflow: have all the affected images been moved and stored to or from the same 
location? If you can find a pattern, you will reduce the number of variables you have to test.

Troubleshooting Photoshop- and System-Related Variables
Damaged or incompatible software components can cause artifacts in Photoshop images. The troubleshooting procedures in this 
section will help you isolate the most common causes of artifacts that occur frequently, and in more than one file. Before performing 
any of these tasks, back up all personal files, such as Photoshop image files you created. Restart your computer after each 
troubleshooting step to refresh your computer's memory. 

1. Use Photoshop 4.0.1 or Later
Photoshop 4.0 for Windows adds artifacts to 16-bit grayscale images when you use the Levels, Auto Levels, or Curves 
commands. Photoshop 4.0.1 and later apply levels and curves to 16-bit grayscale images without adding artifacts. 

You cannot remove these artifacts after saving the image. However, if you haven't saved the image, you may be able to remove 
the artifacts by choosing Edit > Undo or File > Revert. You can also undo some of the artifacts in Photoshop 4.0 by choosing 
Image > Mode > 8 Bits/Channel. However, when you convert a 16-bit grayscale image to an 8-bit grayscale image, the image 
will have less information and, therefore, a smaller range of colors for the Level and Curves commands to work with.

2. Save Images to a Local Hard Disk
Save and open files directly to or from a local hard disk. Photoshop was not designed to open or save files to anything other 
than a local hard disk. Use the Windows Explorer to copy files to a network drive or removable disk. 

3. Re-create Photoshop's Preferences Files
Rename the Photoshop preferences files. If you are using Photoshop 5.0.x, rename the Adobe Photoshop 5 Prefs.psp and Color 
Settings.psp files in the Photoshop5\Adobe Photoshop Settings folder. If you are using Photoshop 4.0.x, rename the 
Photos40.psp and CColorsd files in the Photoshop\Prefs directory. 

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0.x and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the Actions 
palette menu. In Photoshop 5.0.x, the actions are saved in a separate preferences file. 

4. Test the Photoshop Plug-ins for Damage or Incompatibility
Move the Plug-ins folder from the Photoshop folder to a new folder on your desktop, and try to re-create the artifact:
1. Exit from Photoshop. 
2. In Windows Explorer, create a new folder outside of the Photoshop folder (e.g., on the desktop) to temporarily store the 

Photoshop plug-ins. 
3. Open the Program Files\Photoshop5\Plug-Ins folder (Photoshop 5.0.x) or the Adobe\Photoshop\Plugins folder (Photoshop 

4.0.x), then select all the plug-ins and folders in the folder by pressing Ctrl + A.
4. Press Ctrl + X to cut all the plug-ins and folders from the Plug-ins folder, open the folder you created in step 2, and press 

Ctrl + V to paste them there. 
5. Restart Photoshop and try to re-create the artifact. If you can't, add the plug-ins back one file or folder at a time (restarting 

Photoshop each time) until you find the one that caused the artifact. If you can re-create the artifact after adding back a 
folder, then remove all plug-ins from that folder and add them back one-by-one. 

5. Check for viruses.
Use current anti-virus software (e.g., Norton AntiVirus or McAfee AntiVirus) to check your system for viruses. Although virus 
infections are rare, they can cause artifacts. Running virus detection software regularly (e.g., daily) prevents viruses from 
damaging software on your system. Virus detection software manufacturers release updated virus definitions regularly; using the 
most recent definitions gives you greater protection against new viruses. For instructions on running your virus detection software 
or obtaining updated virus definitions, see the software's documentation.

6. Run Photoshop While No Other Programs Are Running in the Background
In Windows 95 or Windows 98, make sure no programs are starting automatically with Windows by doing the following:

- Remove programs from the StartUp folder:



1. Start Windows Explorer.
2. Move all icons and shortcuts from the Windows\Start Menu\Programs\StartUp folder to another folder.
3. Restart Windows.
4. If you can re-create the artifacts, move the icons and shortcuts back. If you cannot recreate the artifacts, move the 

icons and shortcuts back one at a time to isolate the one that was causing the error. 

- In Windows 95, edit the Win.ini file to disable (i.e., remark out) programs and utilities that load automatically (e.g., 
video control panels, screen savers, virus protection utilities):
1. Make a copy of the Win.ini file in the Windows folder.
2. Open the original Win.ini file in a text-editing application that can save in text-only format (e.g., Notepad).
3. In the [Windows] section, insert a semicolon at the beginning of the "load=" and "run=" lines. For example:

;load=
;run=

4. Save the Win.ini file in text-only format, then restart Windows.
5. If you can re-create the artifacts, delete the semicolons you added to each line to restore the original 

configuration. If you cannot re-create the artifacts, delete the semicolons in front of the lines one at a time to 
isolate the one that was causing the error.

- Close all applications, except Systray and Explorer, one by one by pressing Control+Alt+Delete to display the Close 
Program dialog box, selecting an application, and then clicking End Task. (Systray and Explorer are basic Windows 
components.) Reopen Photoshop and try to re-create the artifacts before closing the next application. If you cannot 
re-create the artifacts after closing an application, that application has a conflict with Photoshop. 

Sometimes after closing an application and viewing the Close Program dialog box again, you will see it is still 
running. Sometimes you'll need to close that application more than once to stop it from running. Other times, this 
indicates the application is loading in the registry or in DOS. Contact the application's manufacturer for information 
on disabling it.

In Windows NT 4.0, Make sure no programs are starting automatically with Windows NT by doing the following:
- Remove programs from the StartUp folder:

1. Exit from all applications.
2. Start Windows NT Explorer.
3 Move all icons and shortcuts from the Winnt\Profiles\<Current User>\Start Menu\Programs\Startup folder to 

another folder. This will disable any startup applications that are Private to the Current User's logon from starting 
automatically until you move the icons and shortcuts back. 

4. Move all icons and shortcuts from the Winnt\Profiles\All Users\Start Menu\Programs\Startup folder to another 
folder. This will disable most startup applications that are Common to All Users from starting automatically until 
you drag the icons and shortcuts back. 

5. Restart Windows, then try to recreate the error.
6. If disabling the startup items does not solve the problem, move the icons and shortcuts back. If it does solve the 

problem, move them back one at a time to isolate the one that caused the error. 

- Close applications that are specified to start automatically in the registry:
1. Right-click on the task bar.
2. Choose Task Manager from the pop-up menu.
3. Click the Applications tab. 
4. Select one application name, then click End Task.
5. Restart Photoshop and try to recreate the problem before closing the next application. If the problem does not 

occur after you close an application, that application has a conflict with Photoshop. 

7. Optimize and Defragment Your Hard Disks
Optimize and defragment your hard disks using either the ScanDisk and Disk Defragmenting utilities included with Windows 95, 
Windows 98, Windows NT or a disk optimization utility (e.g., Norton Utilities by Symantec Corporation). You can access these 
utilities by choosing Start > Programs > Accessories > System Tools. For instructions, refer to your Windows documentation or 
the documentation provided with the disk optimization utility.

ScanDisk scans your hard disk for bad sectors, lost allocation units, and lost chains. ScanDisk can search for and correct lost file 
fragments, cross-linked files, invalid file names and invalid dates and times: all of these items can cause errors in Windows. Run 
ScanDisk on each partition or hard disk.

Disk Defragmenter rearranges the files and free space on your computer so files are stored in contiguous units and free space is 
consolidated in one contiguous block.  

In Windows NT, scan your hard disks for errors by typing "CHKDSK/f" at the Command Prompt, or by using a Windows NT 



4.0-compatible third-party utility. 

8. Make Sure Virtual Memory Is Set Correctly
Re-create the virtual memory swap file (Windows 95 or Windows 98) or paging file (Windows NT) to make sure it isn't damaged:
- In Windows 95 or Windows 98, re-create the swap file by specifying a fixed virtual memory setting: 

1. Exit from all applications.
2. Create a Windows startup disk by choosing Start > Settings > Control Panel, double-clicking Add/Remove Programs, 

clicking the Startup Disk tab, and then following the on-screen instructions. (After changing system settings, such as 
virtual memory, Windows may be unable to start, so you may need a startup disk.)

3. Choose Start > Settings > Control Panel; double-click System, then click the Performance tab, and then click Virtual 
Memory.

4. Select "Let Me Specify My Own Virtual Memory Settings." 
5. From the Hard Disk pop-up menu, choose a hard drive that has at least twice the amount of your computer's installed 

RAM. For example, if your computer has 24 MB of RAM, choose a hard drive that has at least 48 MB of free space. 
(To check how much free space a drive has, start Windows Explorer, then right-click the drive, and then choose 
Properties from the pop-up menu and note the Free Space field.)

6. In both the Minimum and Maximum text boxes, enter a value equal to twice the amount of your computer's installed 
RAM.

7. Click OK to close the Virtual Memory dialog box. 
8. Click Yes when you see the message, "You have chosen not to let Windows manage virtual memory automatically . . 

." in the Confirm Virtual Memory Setting dialog box.
9. Click Close in the System Properties dialog box.
10. Restart Windows by clicking Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the 

startup disk and then restart Windows.

- In Windows NT 4.0, re-create the virtual memory paging file:
1. Exit from all applications. 
2. Choose Start > Settings > Control Panel, then double-click System, and then click the Performance tab.
3. In the Virtual Memory section, click Change.
4. From the Drive list, select a hard drive that has at least twice the amount of your computer's installed RAM. For 

example, if your computer has 24 MB of RAM, select a hard drive that has at least 48 MB of free hard drive space. For 
best performance, choose a hard drive not used for the Photoshop scratch disk(s).

5. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your 
computer's installed RAM plus 12 MB. 

6. In the Maximum Size box, enter a value equal to twice the amount of your computer's installed RAM.
7. Click Set and then click OK.
8. Click OK to close the System Properties dialog box.
9. To restart Windows, click Yes in the System Settings Change dialog box. 

9. Use a Different Hard Drive
Run Photoshop on a different physical hard drive (not just a different partition) installed in the same computer. Also, set your 
Scratch Disk(s) to only this drive by choosing File > Preferences > Plug-ins & Scratch Disks. 

10. Reformat the Hard Disk
Reformat the disk, then reinstall Windows and Photoshop, installing both from the original installation disks or CD. Do not install 
any additional software or hardware until you've made sure you cannot re-create the artifacts. 

NOTE: Reformatting the hard disk will erase all files on it. Before reformatting, make sure you've backed up all personal files 
(e.g., image, word processing, desktop publishing, and illustration files). Depending on the frequency of the artifacts, you may 
prefer to test possible hardware conflicts before reformatting your hard disk. However, don't back up your hard disk and restore 
Windows and Photoshop instead of reinstalling. If the problem is caused by an application or Windows and it is restored, that 
might re-create the artifacts. 

Try to re-create the artifact. If it persists in this simplified configuration, the problem is caused by a hardware issue. You should 
troubleshoot the problem with the help of the manufacturer or an authorized reseller, suggesting that they try one or more of the 
procedures in the following section.

Troubleshooting Hardware Variables
If the tasks listed in the previous section did not eliminate the artifacts in your Photoshop images, your hardware may be damaged or 
conflicting with Photoshop.

DISCLAIMER: Adobe does not support hardware, and these solutions are provided only as a courtesy. For further assistance, please 
contact your hardware manufacturer or an authorized repair service facility. 

NOTE: If you choose to remove or rearrange hardware yourself, turn off the power to the computer and any connected peripherals 
before doing so. Be aware that troubleshooting hardware yourself may void your warranty. 



1. Check for Problems with RAM SIMMs or DIMMs 
Ensure the RAM SIMMs or DIMMs are installed properly and are not the cause by doing one or more of the following: 
- Change the order of the installed SIMMs or DIMMs.
- When you have a large number of SIMMs or DIMMs installed, remove all but the minimum amount needed to run 

Windows and Photoshop and test to see if the problem persists. If it does, put the ones you removed back in and remove 
the others, testing again to see if the problem persists. If you cannot re-create the artifacts, one or more of the removed 
SIMMs or DIMMs are the cause.

- Remove then reinstall the SIMMs or DIMMs to ensure they are seated properly. 
- Install new SIMMs or DIMMs. 

2. Troubleshoot SCSI Devices
When external SCSI devices (e.g., external hard drives, removable media drives, ZIP drives, Jazz Drives, optical drives, external 
CD-ROM drives, or scanners) are connected to your computer, first make sure the software device drive for the SCSI card and 
device is current, then ensure SCSI connection devices, cables, or termination are not the cause. Contact the manufacturer of 
the SCSI device or your computer for the most recent driver for the SCSI device or for further information about your SCSI 
devices. 

NOTE: Do not connect or disconnect SCSI cables or SCSI devices when the computer or SCSI devices are turned on. Doing so 
can permanently damage the computer or the SCSI devices, or both. 
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Photoshop, Networks, and Removable Media

What's Covered
Issues When Working from Networks or Removable Media
Recommended Workflow
Suggestions for Troubleshooting

Installing and running an application and saving or opening files across a network or off of removable media involves many variables. 
Because of this, some problems (e.g., damaged files, denied access, or slow performance) occur more frequently when you work from 
a network than they would if you worked off a local hard disk. However, problems using Adobe Photoshop across a network or off of 
removable media may not happen immediately and may be intermittent. Adobe Technical Support only supports using Photoshop 
on a local hard disk because of the difficulty to re-create or accurately identify network- and peripheral-configuration problems. 

Issues When Working from Networks or Removable Media
Photoshop is a resource-intensive application, requiring more RAM and hard disk space than most other applications. While 
Photoshop will work with networks and removable media, doing so compromises the application's performance and reliability. For 
example, because Photoshop reads and writes image data while you work on an image, the faster the access speed of the disk 
containing your image or Photoshop's scratch disk files, the faster Photoshop can process image data. Internal hard disks have fast 
access speeds than network servers (a hard disk accessed over a network) or removable media. 

Additional Variables When Using Networks
There are many different types of network configurations (e.g., multi-launch, client-server, or peer-peer) or types (e.g., ethernet, token 
ring, or IP) made by many different companies. Each configuration requires specialized software and hardware, with varying set-ups, 
preferences, and updates. This additional layer of software and hardware increases the chances of an error occurring (e.g., from line 
noise, RF interference, or packet collisions). 

Data transmission along a network is affected by file servers, routers, bridges, network cards, software, cables, connectors, power 
cables, and power supplies. Network connections can suddenly become unavailable, increasing the risk of data loss and application 
errors. During transmission and reception, network software verifies that data has been sent and received. However, the depth of 
verification depends on the network software package, and may not be accessed by the operating system. The network or operating 
system may not notify you if a Photoshop image or scratch disk file contains damaged or incomplete information. 

Additional Variables When Using Removable Media
There are many kinds removable media (e.g., external parallel [Windows], external/internal SCSI , internal IDE) manufactured by 
many companies. They all require cables and device drivers to be recognized by Windows or Mac OS. Also, removable media are 
more easily damaged than internal disks, increasing the risk of damaged image data or scratch disk files. 

Recommended Workflow
To prevent data loss, Adobe Technical Support strongly recommends working in Photoshop directly on the local hard disk. Save files 
to your hard disk first and then transfer them to the network or removable drive in the Finder or in the Windows Explorer. To retrieve 
files, copy them in the Finder or in the Windows Explorer from the network or removable drive to your hard disk then open the files in 
Photoshop. This will also avoid problems that may come from differing network system setups (e.g., Windows NT Server, Netware, or 
AppleTalk) and removable media device drivers not being completely compatible with the operating system or Photoshop.

Suggestions for Troubleshooting
If you decide to work directly with networks or removable media, you may run into errors or damaged data. Compare the results of the 
suggestions below with your network- or removable media-based workflow to narrow down the cause of a problem. Many different 
factors can cause problems, including memory conflicts between device drivers, damaged or conflicting files, operating system 
software, hardware or low-level DOS (Windows) problems. If you believe the problem is not related to your network or removable 
media, see Related Records for more troubleshooting information.

DISCLAIMER: The following instructions are provided as a courtesy. Adobe Systems does not provide support for networks and 
removable media. 

- Make sure you are using the latest update of Photoshop. Registered users can download updates for free from the Free Plug-Ins 
and Updates section on Adobe's Web site at http://www.adobe.com, or can purchase the update on CD-ROM (while supplies last) 
from Adobe Customer Services at 800-492-3623.

- Transfer the file from the network or removable disk to an local hard disk. Then, open it in Photoshop. 
- Use another computer connected to the same network or type of removable media.
- Set the scratch disks to a local hard disk.
- Check with your network administrator to see if there are any known issues with the network or if any network configuration (e.g., 



updated drivers or changed access privileges) have been changed.
- Install and run Photoshop to an local hard disk and try to replicate the problem. If you can, troubleshoot the problem on the 

local configuration. If you can't, your problem is caused by working off of removable media or a network. 

NOTE: Once a file has artifacts, they may permanently be part of the image data. Replicate your image in a new file using the 
local hard disk. 
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Msvcrt20.dll Error When Starting Photoshop 3.0.4 or Later in Windows

Issue
When you start Adobe Photoshop 3.0.4 or later, Windows returns the error, "This version of Msvcrt20.dll is not compatible with 
Win32s."

Solutions
Reinstall the Msvcrt20.dll file from the Photoshop CD-ROM: 
1. Exit all applications.
2. If you are using Windows 3.1x, open the Windows File Manager and choose File > Search. If you are using Windows 95, open 

the Windows Explorer and choose Tools > Find > Files or Folders.
3. Search for the Msvcrt20.dll file.
4. Rename all copies of the Msvcrt20.dll file to "Msvcrt20.old."
5. Reinstall the Msvcrt20.dll file by doing one of the following:

NOTE: When you configure your computer for dual booting, you will have duplicates of the Msvcrt20.dll file in each operating 
system's Windows\System directory. Make sure to reinstall each operating system's version in copy in the correct Windows\System 
directory. 

-- If you are using Windows 3.1x, reinstall Photoshop. For instructions, refer to the documentation included with Photoshop.

-- If you are using Windows 95 or Windows 95A (Service Pack 1), download the Msvcrt update from Microsoft's Web site. After 
downloading the upate, run it to extract the Msvcrt update files. Included with the Msvcrt files is a ReadMe file, which 
contains install instructions. The Msvcrt update is located on Microsoft's Web site at (
http://support.microsoft.com/download/support/mslfiles/Msvcrt.exe).  

-- If you are using Windows 95B (OSR2), insert your Windows CD into the CD-ROM drive and choose Start > Programs > 
MS-DOS Prompt. Then, type the following commands at the DOS prompt, pressing Return after each line: 

d:\
cd win95
extract /a d:\win95\win95_02.cab msvcrt20.dll /l c:\windows\system

Where D: is your CD-ROM drive indicator, and C: is the indicator for the drive on which Windows 95 is installed, and 
Windows is the name of the directory in which Windows 95 is installed.

NOTE: If Windows is using the file, it returns an error stating it cannot rename or overwrite the existing file. Restart Windows 
and try again.

6. Restart Windows.

Additional Information
Windows returns the error, "Msvcrt20.dll for Win32s. Error: This version of Msvcrt20.dll is not compatible with Win32s" when a version 
of the Msvcrt20.dll file that is incompatible with Windows is installed, multiple Msvcrt20.dll files are installed, or the Msvcrt20.dll file 
is damaged.

The Msvcrt20.dll file is a system file shared by many applications. When you install Photoshop 3.0.4 or later in Windows 3.1x, the 
setup program installs a version of the Msvcrt20.dll file that is compatible with your operating system. However, it will not overwrite an 
Msvcrt20.dll file installed by another application, even if that file is incompatible with the installed version of Windows. 

When you install Photoshop 3.0.4 or later in Windows 95, the Photoshop setup program does not install a Msvcrt20.dll file because 
that file is installed with Windows 95. However, another application's setup program may have installed a duplicate of the 
Msvcrt20.dll file, or overwritten the Msvcrt20.dll file with a version that is incompatible with the installed version of Windows.

The versions of the Msvcrt20.dll file compatible with each version of Windows are:

Operating System File Version File Size Date 

Windows 3.1x 2.10.000 244,736 bytes 1/20/95

Windows 95 2.11.000 253,952 bytes 7/11/95

Windows 95A (Service Pack 1) 2.11.000 154,464 bytes 12/31/95

Windows 95B (OSR2) 2.11.000 253,952 bytes 8/24/96
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How to Print Photoshop Images in Different Places on a Page

Adobe Photoshop prints images centered. To print a Photoshop image off-center, you must either add white space (pixels) to the 
image and then print it from Photoshop, or print the image from a page layout application (e.g., Adobe PageMaker, QuarkXPress). 
Both methods are detailed below.

Printing an Image Off-Center From Photoshop
When printing an image, Photoshop centers the entire image area, including the canvas, on the printed page. To print the image 
off-center from Photoshop, use Photoshop's Canvas Size command to add white space to the sides, top, or bottom of your image. 
Once you've added the amount of canvas you want, the image will print off-center in the desired location on the page. 

To add canvas to an image and print from Photoshop:
1. Open your image in Photoshop.
2. Click the Default Colors icon (small black and white squares) in Photoshop's toolbox to set the background color to white, so that 

the canvas you add to your image is white.
3. Choose Image > Canvas Size.
4. In the New Size section, enter a Width and Height for the canvas, so the canvas, when centered on your page, will include the 

area of the page where you want your image to print. For example if you are printing on 8.5" x 11" paper, and you want to print 
your image in the top left corner of the page, enter a Height of approximately 10" and a Width of approximately 7", depending 
on the imageable area of your printer.

5. For Placement (Photoshop 3.0.x) or Anchor (Photoshop 4.0.x or later), click the square on the grid that represents where you 
want your image to be located on the canvas. For example, if you want your image to be placed in the lower left corner of your 
canvas, click the lower left square on the grid.

NOTE: Adding canvas to an image increases file size, which can slow image processing (e.g., screen redraw, printing). Add only 
enough canvas to shift the image to desired location on the printed page. For example, to print an image at the top center of 
the page, change only the Height to the maximum imageable area of your printer, then click the top center square for 
Placement or Anchor.

6. Click OK.  
7. To preview the new image size (including canvas) on the page, click and hold the box in the lower-left corner of the document 

window, where the file size is displayed.

NOTE: The dimensions of the page shown in the page preview box correspond to the page size selected in the Page Setup 
dialog box.

 8. Print the image from Photoshop.

Printing an Image Off-Center From a Page Layout Application
Because adding canvas to an image increases file size and slows printing, you may want to print the image off-center from a page 
layout application (e.g., Adobe PageMaker, QuarkXPress) instead.  

To print a Photoshop image off-center from a page layout application:
1. In Photoshop, choose File > Save to save your Photoshop image in a file format (e.g., TIFF, EPS) that can be imported into 

your page layout application.
2. Import your Photoshop image into the page layout application document, then move it to the desired location on the page.
3. Print the image.
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Error "Could Not Initialize Photoshop Because of a Disk Error" in Windows 3.1x or Later

Issue
When you start Adobe Photoshop 2.5.x or later, the system returns the error, "Could not initialize Photoshop because of a disk error." 
or "Could not initialize Photoshop due to a disk error."

Solutions
Do either or both of the following:
A. Recreate the Photoshop preferences file:

1. Exit from Photoshop.
2. Delete the Photoshop preferences files. For preferences file names and locations, see Additional Information.

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the 
Actions palette menu. In Photoshop 5.0, don't delete Actions Palette.psp. 

B. Use a disk utility (e.g., ScanDisk, Norton Disk Doctor) to locate and repair media problems (e.g., bad sectors, damaged directory 
information) on the hard drive containing Photoshop and the system software and other volumes designated as a Photoshop 
scratch disk.

Additional Information
The Photoshop preferences file stores location and content information about a variety of Photoshop settings. Photoshop creates 
preferences files during startup. When the information contained in the preference files are damaged, or when there are media 
problems on the hard disk(s), Photoshop is unable to initialize during startup, and the system returns an error.

Photoshop Preferences File Names and Locations
Photoshop Version Preferences Files' Names Location

Photoshop 5.0 Adobe Photoshop 5.psp Photoshop5\Adobe Photoshop
Settings directory

Photoshop 5.0 Actions Palette.psp Photoshop5\Adobe Photoshop
Settings directory

Photoshop 5.0 Color Settings.psp Photoshop5\Adobe Photoshop
Settings directory

Photoshop 4.0.x Photos40.psp and Ccolorsd Photoshop\Prefs subdirectory
Photoshop 3.0.5 Photos30.psp and Ccolorsd Photoshp\Prefs subdirectory
Photoshop 3.0.5 LE Phot30le.psp and Ccolorsd Photosle\Prefs subdirectory
Photoshop 3.0.4 - 3.0 Photos30.psp and Ccolorsd Windows directory
Photoshop 3.0.4 LE - 3.0 LE Phot30le.psp and Ccolorsd Windows directory
Photoshop 2.5.x Photoshp.psp and Ccolorsd Windows directory
Photoshop 2.5 LE Photosle.psp and Ccolorsd Windows directory
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Using AppleScript With Photoshop 5.0 and 4.0.x

What's Covered
AppleScript Support in Photoshop 5.0 or 4.0.x
Sample Scripts
Closing Dialog Boxes Automatically
Additional Information on External Automation in Photoshop

AppleScript is a scripting language that lets you automate tasks in applications (e.g., Adobe Photoshop 5.0 for Mac OS) and in the 
Mac OS itself. AppleScript is included with Mac OS 7.1 or later, or you can download it from Apple's Web site at 
http://www.applescript.apple.com/sw.html. AppleScript includes the Script Editor application for constructing scripts. See your Apple 
documentation for more information.

Photoshop 5.0 and 4.0.x have limited support for external automation using AppleScript on the Macintosh or an OLE automation 
controller, such as Microsoft Visual Basic, in Windows. Using either of these methods lets you start Photoshop and execute actions 
externally.

To view a list of the AppleScript commands an application supports (i.e., the application's Dictionary) start Script Editor and choose 
File > Open Dictionary, then select the application and click Open.

DISCLAIMER: Adobe Technical Support cannot troubleshoot or help you create scripts. The sample scripts in this document are 
provided as a courtesy to help you begin. For assistance with AppleScript, please consult an AppleScript programming guide or 
contact Apple Technical Support at 800-767-2775.

AppleScript Commands with Photoshop 5.0 or 4.0.x
Photoshop 5.0 or 4.0x for the Mac OS is compatible with the following AppleScript commands. To automate tasks in Photoshop, use 
the corresponding command. 

Photoshop Function AppleScript Command Description
Open a file open Open the specified object(s). 

Print print Print the specified object(s).

Quit Photoshop quit Quit the application.

Start Photoshop run Sends the script to an application when it is double-clicked.

Run an existing Action do script Plays the specified Action. Enter the name as it appears in the 
Actions palette.

AppleScript does not have a Batch command, and you cannot access Photoshop's Batch command using AppleScript. The 
Photoshop User Guide makes reference to Photoshop batch process files. This is not a reference to Photoshop's Batch command. 
Instead, you can use AppleScript's Repeat command (as shown in sample 2 for Photoshop 5.0 and 4.0.x, below) to process a batch of 
files.

Sample Scripts
For each of the following samples, enter the commands in Script Editor, then either select Application from the Kind pop-up menu 
when saving the script, or run the script from within Script Editor by clicking Run. 

The first time you run a new AppleScript run with Photoshop, AppleScript displays the message, "Where is Adobe Photoshop® 5.0?" 
or "Where is Adobe Photoshop® 4.0?" You will need to specify to AppleScript where Photoshop is installed, select it, and click OK. 
Thereafter, when you run that script with Photoshop, it should not produce this message. 

When you run an AppleScript on Photoshop, Photoshop remains in the background. If you have other applications open, you may 
not see the script being run on Photoshop. To see the completed script, select Photoshop in the Finder, or do not have any other 
applications running when you run the script. Refer to your AppleScript documentation for more information.

NOTE: The samples below only work with the default actions that are installed with Photoshop. If you have edited the default actions 
(especially the names), these samples may not work correctly. These samples do not automatically save Photoshop images. To save 
the file, include a Save command in the script.  

Sample 1 for Photoshop 5.0
The following script will display the Select a File to Open dialog box (in which you must select a file to open and click OK), start 
Photoshop, open the file, and run the Sepia Toning (layer) action.



set FileToOpen to choose file with prompt "Select a file to open..."
tell application "Adobe Photoshop® 5.0"

open FileToOpen
do script "Sepia Toning (layer)"

end tell

NOTE: To create the registration (®) symbol, press Option+R.

Sample 2 for Photoshop 5.0
The following script will repeat 10 times the command to display the Select a File to Open dialog box (in which you must select a 
file to open and click OK), start Photoshop (if it is not already running), open the file, and run the Sepia Toning (layer) action. 

repeat 10 times
set FileToOpen to choose file with prompt "Select a file to open..."
tell application "Adobe Photoshop® 5.0"

open FileToOpen
do script "Sepia Toning (layer)"

end tell
end repeat

Sample 3 for Photoshop 5.0
The following script will display the Select a File to Open dialog box (in which you must select a file to open and click OK), start 
Photoshop, open the file, and display the Print dialog box. You must choose Photoshop from the Finder to see the Print dialog box. 

set FileToOpen to choose file with prompt "Select a file to open..."
tell application "Adobe Photoshop® 5.0"

open FileToOpen
print FileToOpen

end tell

Sample 1 for Photoshop 4.0.x
The following script will display the Select a File to Open dialog box (in which you must select a file to open and click OK), start 
Photoshop, open the file, and run the Vignette (full image) action. A vignette is a picture that gradually fades to light tones at its 
edges.

set FileToOpen to choose file with prompt "Select a file to open..."
tell application "Adobe Photoshop® 4.0"

open FileToOpen
do script "Vignette (full image)"

end tell

Sample 2 for Photoshop 4.0.x 
The following script will repeat 10 times the command to display the Select a File to Open dialog box (in which you must select a 
file to open and click OK), start Photoshop (if it is not already running), open the file, and run the Vignette (full image) action.

repeat 10 times
set FileToOpen to choose file with prompt "Select a file to open..."
tell application "Adobe Photoshop® 4.0"

open FileToOpen
do script "Vignette (full image)"

end tell
end repeat

Sample 3 for Photoshop 4.0.x
The following script will display the Select a File to Open dialog box (in which you must select a file to open and click OK), start 
Photoshop, open the file and display the Print dialog box. You must choose Photoshop from the Finder to see the Print dialog box. 

set FileToOpen to choose file with prompt "Select a file to open..."
tell application "Adobe Photoshop® 4.0"

open FileToOpen
print FileToOpen

end tell



Closing Dialog Boxes Automatically
An AppleScript command can automatically open a dialog box; it cannot, however, automate clicking a button within the dialog 
box, such as the Print button in the Print dialog box. Because some dialog boxes won't close until you click a button within them, a 
Script will stop if it opens such a dialog box. To close these dialog boxes, you can use a utility, such as Okey Dokey Pro, to 
automatically select the default button in the dialog box, enabling the script to continue. You can download Okey Dokey Pro free of 
charge from the c/net Shareware Web site at http://www.shareware.com.

Additional Information on External Automation in Photoshop
You can find information about automation objects in the online help. Additional information is in the documentation (e.g., 
Photoshop SDK Guide.pdf) included with the Adobe Photoshop SDK (Software Developers Kit). The SDK is available from Adobe 
Developer Relations area of the Adobe web site at http://www.adobe.com. The SDK is also located on the Photoshop CD-ROM in the 
Adobe Technical Info\Developer Support\SDK folder.

The Adobe Photoshop SDK contains technical information that assists developers in creating plug-ins for Photoshop. It also contains 
information and examples that are helpful in understanding the external automation connections in Adobe Photoshop.
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Errors Using a Camera or Scanner with TWAIN in Photoshop in Windows NT or Windows 95 
Troubleshooting Guide

Issue
Adobe Photoshop 3.0.x or later returns one or more of the following errors occur when you acquire an image using a scanner or 
camera and TWAIN in Windows NT 4 or Windows 95:

"Could not complete your request because there is no scanner installed."

"Could not complete your request because of a problem with the scanner."

"Could not initialize TWAIN. Make sure that the TWAIN.DLL is installed in the Windows directory."

Solutions 
Download or scan the image using the application included with your scanner (e.g., HP Deskscan II) or camera or another application 
that supports TWAIN. If you are using a scanner and are unable to acquire images from any other application, your scanner may not 
be set up properly, and you should contact your scanner manufacturer (for basic troubleshooting tips, see Additional Information). If 
you can acquire an image from another application, do one or more of the following: 

Solution 1
Reselect the camera or scanner data source in Photoshop by choosing File > Import > Select TWAIN Source or Select TWAIN_32 
Source in the Select Source dialog box, clicking OK, and then selecting the data source for your device. 

NOTE:  Windows 95 is compatible with both TWAIN (16-bit) and TWAIN_32 (32-bit). But Windows NT 4.0  is only compatible 
with TWAIN_32. If you're using Windows 95 and are not sure which TWAIN to use, check with the device's documentation or 
manufacturer. 

Solution 2
Decrease the amount of memory allocated to Photoshop.

1. In Photoshop, choose File > Preferences > Memory & Image Cache.
2. In the Physical Memory Usage section, reduce the Used by Photoshop setting to 50% and click OK.
3. Restart Photoshop.

NOTE: Photoshop can up to the amount of RAM allocated in the Memory & Image Cache Preferences dialog box. 
Reducing the amount of RAM used by Photoshop allows the camera or scanner software to access more available RAM. 
Some of these applications require more RAM than others.

Solution 3
If your computer freezes while your scanner is in the process of scanning, scan only a 1 by 1 inch section of the image at 72 ppi. If 
you can scan a 1 by 1 inch section of the image at 72 ppi, your scanner is working correctly with TWAIN in Photoshop, but your 
system resources are limited. Do one or more of the following:

a. Scan at a lower resolution. For more information on scanning resolutions in Photoshop, see document "311216 ."
b. Exit any applications running in the background before scanning.
c. If you are using Windows 95, see document 316693 .for instructions for troubleshooting memory-related problems.

Solution 4
Make sure TWAIN-related files are installed in the correct directories and have the correct file size and date. If the TWAIN-related 
files are missing or do not have the correct file size and date, rename the files. Then reinstall Photoshop, choosing Custom install 
and deselecting all options except Program Files.

File Location Size in Bytes Version Modified Date

Photoshop 3.0.1 installs:
Twain.dll Windows 22,944 1.00\0 Wednesday, March 11, 1992
Twain8b.8ba Photoshp\Plugins 15,424 n/a Monday, October 11, 1993
Twain32.8ba Photoshp\Plugins 19,968 n/a Monday, October 31, 1994
Psut16.dll Photoshp 32,168 n/a Thursday, October 20, 1994
Psut32.dll Photoshp 11,776 n/a Wednesday, October 12, 1994

Photoshop 3.0.4 installs:
Twain.dll Windows 22,944 1.00\0 Wednesday, March 11, 1992



Twain32.dll Windows 104,448 1.5 a3\0 Thursday, July 15, 1993
Twain8b.8ba Photoshp\Plugins 20,224 n/a Friday, June 16, 1995
Twain32.8ba Photoshp\Plugins 18,432 3.0.4 Monday, June 19, 1995
Psut16.dll Photoshp 12,479 n/a Tuesday, May 16, 1995
Psut32.dll Photoshp 15,360 3.0.4 Tuesday, May 16, 1995
Psut9516.dll Photoshp 20,992 n/a Thursday, May 18, 1995
Psut9532.dll Photoshp 20,480 3.0.4 Thursday, May 18, 1995

Photoshop 3.0.5 installs:
Twain.dll Windows 85,696 1,6,0,0 Thursday, August 24, 1995
Twain_32.dll Windows 75,776 1,6,0,0 Thursday, August 24, 1995
Twunk_16.exe Windows 48,592 1,6,0,0 Thursday, August 24, 1995
Twunk_32.exe Windows 69,632 1,6,0,0 Thursday, August 24, 1995
Twain8b.8ba Photoshp\Plugins 20,256 n/a Monday, January 15, 1996
Twain_32.8ba Photoshp\Plugins 18,432 3.0.5 x107 Monday, January 15, 1996
Psut16.dll Photoshp 12,479 n/a Monday, January 15, 1996
Psut32.dll Photoshp 15,360 3.0.5 Monday, January 15, 1996
Psut9516.dll Photoshp 19,968 n/a Monday, January 15, 1996
Psut9532.dll Photoshp 18,432 3.0.5 x105 Monday, January 15, 1996

Photoshop 4.0 installs:
Twain.dll Windows 85,696 1,6,0,0 Thursday, August 24, 1995
Twain_32.dll Windows 75,776 1,6,0,0 Thursday, August 24, 1995
Twunk_16.exe Windows 48,592 1,6,0,0 Thursday, August 24, 1995
Twunk_32.exe Windows 69,632 1,6,0,0 Thursday, August 24, 1995
Twain8b.8ba Photoshop\Plugins\ 20,288 n/a Wednesday, October 30, 1996

Import
Twain_32.8ba Photoshop\Plugins\ 15,360 4.0 Wednesday, October 30, 1996

Import
Psut16.dll Photoshop 12,479 n/a Wednesday, October 30, 1996
Psut32.dll Photoshop 15,872 3.0.5 Wednesday, October 30, 1996
Psut9516.dll Photoshop 19,456 n/a Wednesday, October 30, 1996
Psut9532.dll Photoshop 18,432 3.0.5 x105 Wednesday, October 30, 1996

Photoshop 4.0.1 installs:
Twain.dll Windows 85,696 1,6,0,0 Thursday, August 24, 1995
Twain_32.dll Windows 75,776 1,6,0,0 Thursday, August 24, 1995
Twunk_16.exe Windows 48,592 1,6,0,0 Thursday, August 24, 1995
Twunk_32.exe Windows 69,632 1,6,0,0 Thursday, August 24, 1995
Twain8b.8ba Photoshop\Plugins\ 20,288 n/a Tuesday, August 20, 1996

Import
Twain_32.8ba Photoshop\Plugins\ 15,360 4.0 Wednesday, October 30, 1996

Import
Psut16.dll Photoshop 12,479 n/a Tuesday, May 16, 1995
Psut32.dll Photoshop 15,872 3.0.5 Wednesday, December 20, 1995
Psut9516.dll Photoshop 19,456 n/a Tuesday, December 19, 1995
Psut9532.dll Photoshop 18,432 3.0.5 x105 Thursday, December 14, 1995

Photoshop 5.0 installs:
Twain.dll Windows 87,392 1,6,0,3 Monday, February 10, 1997
Twain_32.dll Windows 77,312 1,6,0,3 Wednesday, October 11, 1995
Twunk_16.exe Windows 48,560 1,6,0,1 Thursday, October 19, 1995
Twunk_32.exe Windows 69,632 1,6,0,1 Thursday, October 19, 1995
Twain_32.8ba Program Files\Adobe\ 19,1968 5.0 Thursday, May 14, 1998

Photoshop 5.0\Plug-Ins\
Import-Export

Psut9516.dll Program Files\Adobe\ 19,456 n/a Thursday, May 14, 1998
Photoshop 5.0\

Psut9532.dll Photoshop 18,432 3.0.5 x105 Thursday, May 14, 1998

NOTE:  Windows 95 may round file sizes; to determine a file's byte size (as opposed to it's approximated size in kilobytes), 
right-click on the file, then choose Properties from the pop-up menu.

Solution 5
If you are running Quarterdeck CleanSweep Deluxe, disable it. Starting Photoshop while CleanSweep Deluxe is running prevents 
some plug-ins from loading, including your Photoshop scanner plug-in. 



NOTE: The following solution is a temporary one. For help with removing or to find out how to update CleanSweep Deluxe. 
refer to the documentation included with it or contact Quarterdeck Corporation.

To temporarily disable CleanSweep Deluxe:
1. Exit all applications.
2. Press Control+Alt+Delete to open the Windows Task Manager.
3. Select Csinject and click End Task.
4. Restart Photoshop. 
5. Select your scanner data source, and scan your image.

Additional Information
The TWAIN interface allows different types of devices, such as scanners and digital cameras, to communicate with Photoshop and 
other TWAIN-compatible applications. To acquire images in Photoshop using TWAIN, you need a Source Manager file and TWAIN 
Data Source (*.ds) file for your scanner or camera. Adobe does not provide these software modules, however, and you must obtain 
them from the scanner or camera manufacturer.

If you cannot acquire an image from any other application, your camera or scanner may not be set up correctly, and you should 
troubleshoot  the problem with the help of the scanner or camera manufacturer. However, before calling the manufacturer, you may 
want to try one or more of the following to ensure the camera or scanner is set up correctly:

DISCLAIMER:  Adobe does not support third-party hardware, and these solutions are provided only as a courtesy. For further 
assistance, please contact your scanner manufacturer. 

-- Make sure the camera or scanner is turned on and connected to the port where your scanner card is installed. 

-- Make sure the cables are seated properly and not kinked, bent, or damaged. All cables must be firmly connected. Replace 
cables if necessary. 

-- Copy all data source files (*.ds) into the root of the Twain or Twain_32 directory. 

-- Deinstall the scanner or camera software, restart Windows, then reinstall the software. For information on deinstalling and 
reinstalling scanner or camera software, refer to your documentation or call the scanner or camera manufacturer. 

-- Contact the manufacturer for an updated, 32-bit data source file. For Windows NT, all TWAIN components must be 32-bit, 
including a 32-bit data source file. Check your scanner documentation or contact the manufacturer to see if your current data 
source file is 32-bit. 

-- If you are running Windows 95, verify that Windows 95 detects your camera or scanner hardware properly:
1. Choose Start > Settings > Control Panels > System > Device Manger.
2. Double-click the scanner category (e.g., SCSI controllers, HP ScanJet Scanners).
3. Double-click the specific scanner icon (e.g., HP ScanJet IIc).
4. Check in the Device Status field for the text, "Device is operating properly." If the Device Status line does not read,  

"Device is operating properly," reinstall the device driver software. Contact the device manufacturer for installation 
instructions.

5. Repeat steps 3-4 for related hardware (SCSI controller, Scanner, etc.).
6. If needed, install or reinstall camera or scanner hardware (SCSI Controller, Scanner) through the Control Panel by 

selecting Start > Settings > Control Panels > Add New Hardware and following the on-screen instructions.

-- Make sure that your camera or scanner and its card are compatible with each other and with your version of Windows. Contact 
the manufacturer for information on compatibility between scanners, scanner cards, drivers, and your version of Windows.
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Scanned Images Display with Moire, Screen, or Plaid Pattern in Photoshop

Issue
Scanned images display and print with a moiré, screen, or plaid pattern, or with colored or gray blotches in Adobe Photoshop 3.0.x 
or later.

Solutions
Do one or both of the following:

Solution 1
Rescan the image from original artwork or photographs rather than a reproduction (e.g., a halftone).

Solution 2
To minimize the moiré pattern, do one or more of the following:

NOTE:  Minimizing the moiré pattern may decrease the image's detail.

-- Rescan the image at twice the resolution, use Photoshop's Gaussian Blur filter to reduce the moiré pattern, resample the image, 
then use the Unsharp Mask filter:
1. Scan the image at twice the recommended resolution.
2. With the image open in Photoshop, select Filter > Blur > Gaussian Blur.
3. Select Preview in the Gaussian Blur dialog box, then move the slider under Radius until the moiré pattern disappears or is 

acceptably decreased.
4. Select Image > Image Size and resample the image to your preferred resolution.
5. Select Filter > Sharpen > Unsharp Mask.
6. Select Preview in the Unsharp Mask dialog box and move the Amount, Radius, and Threshold sliders to regain sharpness 

in the image.

-- Rescan the image at twice the resolution, resample the image, use Photoshop's Gaussian Blur filter to reduce the moiré pattern, 
then use the Unsharp Mask filter:
1. Scan the image at twice the recommended resolution.
2. Select Image > Image Size and resample the image to your preferred resolution.
3. With the image open in Photoshop, select Filter > Blur > Gaussian Blur.
4. Select Preview in the Gaussian Blur dialog box then move the slider under Radius until the moiré pattern disappears or is 

acceptably decreased.
5. Select Filter > Sharpen > Unsharp Mask.
6. Select Preview in the Unsharp Mask dialog box and move the Amount, Radius, and Threshold sliders to regain sharpness 

in the image.

-- Rescan using a scanning application (e.g., ScanPrep, ScanPrepPro, Ofoto) that includes an option (e.g., Descreening) that can 
compensate for scanning halftoned artwork.

Additional Information
Previously printed material (i.e., a picture from a magazine, book, brochure, newsletter, poster) has already been broken up into a 
halftone pattern for reproduction. Because scanners convert light and dark areas into a dot pattern, or halftone, creating a dot pattern 
of areas that are already dot patterns produces a moiré pattern.
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Installing Manufacturer and Model Specific Video Drivers in Windows 95 General Information

When Windows 95 detects new hardware, it may load generic video drivers for cards that use a standard chip-set (e.g., MGA, Cirrus 
Logic, Tseng, S3) even when manufacturer and model-specific drivers are available on the Windows 95 CD-ROM. When Windows 95 
uses generic drivers for video cards, the operating environment can become unstable and cause errors.

Installing or reinstalling Windows 95-compatible drivers that specify the manufacturer and model of your video card ensures the most 
stable environment for all programs.

To install a Windows 95-compatible video driver that specifies the manufacturer and model of your video card:
1. Choose Start > Settings > Control Panels.
2. Double-click the Display Control Panel.
3. Select the Settings tab.
4. Click Change Display Type.
5. Click Change in the Adapter Type section.
6. Install a driver that specifies the manufacturer and model of your video card:

If you have a driver from your video card manufacturer, click the Have Disk button.

OR: If you do not have a driver from your video card manufacturer, select a video driver provided on the Windows 95 CD-ROM 
by selecting the Show All Devices option. Scroll through the list of Manufacturers and Models and select your specific video card 
manufacturer and model. Click OK. Windows will prompt you to insert the Windows 95 CD-ROM.

OR: If the manufacturer or model of your video card is not listed in Manufacturers and Models, contact your video card 
manufacturer for a Windows 95-compatible driver.

7. Restart the computer.
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Error "Illegal operation, Photoshop caused a page fault in module <unknown>" in Photoshop 3.0.x 
or Later in Windows 95

Issue
When you start or work in Adobe Photoshop 3.0.x or later, Windows 95 returns the error, "Illegal operation, Photoshop caused a page 
fault in module <unknown>."

Solution
Install or reinstall a Windows 95-compatible video driver that specifies the manufacturer and model of your video card:
1. Choose Start > Settings > Control Panel.
2. Open the Display Control Panel, then select the Settings tab.
3. Click Change Display Type.
4. Click Change in the Adapter Type section.
5. If you have a driver from your video card manufacturer, click the Have Disk button. If you do not have a driver from your video 

card manufacturer, select Show All Devices, then scroll through the list of Manufacturers and Models and select your specific 
video card manufacturer and model. Click OK, then insert the Windows 95 CD-ROM when prompted.

NOTE: If the manufacturer or model of your video card is not listed in Manufacturers and Models, contact your video card 
manufacturer for a Windows 95-compatible driver.

6. Restart the computer.

Additional Information
When Windows 95 detects new hardware, it may load generic video drivers for cards that use a standard chip-set (e.g., MGA, Cirrus 
Logic, Tseng, S3) even when manufacturer- and model-specific drivers are available for the video card on the Windows 95 CD-ROM. 
When Windows 95 uses generic drivers for video cards, errors may occur. When Windows or a program returns an error in module 
<unknown>, the selected video driver may be damaged or incompatible with your monitor and video card.



Adobe Customer Support Services 

Memory or Scratch Disk Error When Opening an Image in Photoshop 3.0.x or Later

Issue
When you try to open an image, Adobe Photoshop 3.0.x or later returns the error, "Out of memory," "Scratch Disk is full," or "Not 
Enough Memory (RAM)," or "Could not open the document because the scratch disks are full."

Solutions
Do one of the following:

Solution 1
On the hard disk partition you designate for scratch disk files, make sure you have free disk space equal to 3-5 times the size of the file 
you're trying to open. If the file you're opening has many channels or layers, its file size in the Image > Image Size dialog box when 
opened may be larger than its file size in Windows Explorer, requiring even larger scratch disk files. 

Solution 2
Specify a hard disk partition that has more free space as the primary scratch disk, and then specify a secondary (or for Photoshop 5.0, 
a third and fourth) scratch disk. For Photoshop 4.0.x and earlier, do not specify the same hard disk partition for both the primary and 
secondary scratch disks. To specify a scratch disk in Photoshop:
- In Photoshop 4.0.x or 5.0, choose File > Preferences > Plug-ins & Scratch Disks.
- In Photoshop 3.0.x, choose File > Preferences > Scratch Disks (Mac OS) or File > Preferences > Memory (Windows).

Solution 3
Recreate the Photoshop preferences file. For instructions, see Additional Information.

Additional Information
To open a file, Photoshop requires free disk space for a scratch disk file equal to 3-5 times the size of the file. Because Photoshop's 
native file format (.psd) uses Run Length Encoded (RLE) compression, files saved in .psd format are often larger in size when opened 
in Photoshop than when saved on the hard drive. The more alpha channels and layers in a .psd file, the more hard drive space 
Photoshop requires to open the file. If a .psd file has many channels and layers, the Current Size (Photoshop 3.0.x) or Pixel 
Dimensions (Photoshop 4.0.x or later) fields in the Image Size dialog box may indicate a file size that's more than 10 times the file 
size indicated by the operating system. For example, a file whose size is 25 MB file on the hard drive may open as a 500 MB file in 
Photoshop if it has many channels and layers. 

Photoshop uses a scratch disk file (i.e., temporary disk space used for storing data and performing computations) when there is 
insufficient RAM for image editing. There can be two scratch disks in Photoshop 3.0.x and 4.0.x, and each can be up to 2 GB. Each 
scratch disk must be on a separate hard drive partition. This means in Photoshop 4.0.x and earlier if you have 5 GB free on an 
unpartitioned hard drive, and all scratch disks are assigned to it, Photoshop can use up to 2 GB of space in one scratch disk file. To 
use the full 4 GB, partition your hard drives so that there are as many partitions as there are scratch disks you want to use. In 
Photoshop 5.0, you can assign up to four partitions for scratch disk files. Although the scratch disk files still have a limit of 2 GB each, 
Photoshop 5.0 can write as many scratch disks per partition as there is free disk space. This means if you have 5 GB free on an 
unpartitioned hard drive, and all scratch disks are assigned to it, Photoshop 5.0 can use up to 5 GB of space in three scratch disk files 
(2 GB, 2 GB, 1GB).

Photoshop's Preferences File
The Photoshop preferences file, which Photoshop creates during startup, stores information about Photoshop settings. When the 
preferences file is damaged, Photoshop may return an error regarding available RAM (i.e., memory) or Scratch Disk space. Deleting 
the preferences file and restarting Photoshop forces Photoshop to create a new preferences file that contains default preferences 
settings and default plug-in folder and file information. 

NOTE: When you delete the preferences file, custom Preferences settings and unsaved actions in Photoshop 4.0.x are lost. To save 
any actions you've created, choose Save Actions from the Actions palette menu before deleting the preferences file. Photoshop 5.0.x 
saves the actions in a separate preferences file. 

To re-create the preferences file in Photoshop for Mac OS:
1. Quit Photoshop.
2.  If you are using Photoshop 4.0.x, choose Save Actions from the Actions palette menu to save any actions you've created.
3. If you are using Photoshop 5.0, locate the Adobe Photoshop 5 Prefs in the Adobe Photoshop 5.0:Adobe Photoshop Settings 

folder. For other versions, locate the Adobe Photoshop 4.0 Prefs file (Photoshop 4.0.x), the Adobe Photoshop 3.0 Prefs file 
(Photoshop 3.0.x), or the Adobe Photoshop LE Prefs file (Photoshop 3.0.x LE) in the System folder:Preferences folder. Delete or 
rename the file.

4. Restart Photoshop.



To re-create the preferences file in Photoshop for Windows:
1. Exit from Photoshop.
2.  If you are using Photoshop 4.0.x or earlier, choose Save Actions from the Actions palette menu to save any actions you've 

created.
3. If you are using Photoshop 5.0, rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the Photoshop > 

Adobe Photoshop Settings folder. For other versions, delete or rename either the Photos40.psp and CColorsd files in the 
Photoshop\Prefs directory (Photoshop 4.0.x) or the Photos30.psp and CColorsd files in the Win32app\Photoshp\Prefs directory 
(Photoshop 3.0.5) or the Windows directory (Photoshop 3.0.4, 3.0).

4. Restart Photoshop.
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Error "File not found" When Opening a DCS EPS File in Photoshop

Issue
When you try to open a Photoshop DCS (1.0 or 2.0) file, Adobe Photoshop returns one of the following errors:

- Photoshop for Mac OS returns the error "Could not open or parse a DCS plate file because a File was not found."
- Photoshop for Windows returns the error "Could not open the document because the file could not be found."

Solutions
Do one or more of the following to help ensure that Photoshop can read all of the DCS component files (i.e., the master file and the 
separation files):

NOTE: If you're trying to open a DCS 2.0 file that was created with A Lowly Apprentice Platemaker, Pantone Channel 24, or 
another third-party plug-in or application, skip directly to Solution 4.

Solution 1
Place all of the DCS component files into the same folder on a local volume and then open the composite DCS file.

Solution 2
If you're using Mac OS, quit all applications and then rebuild the desktop file by holding down the Command and Option keys while 
restarting the computer. Keep pressing the keys until you receive the message, "Are you sure you want to rebuild the desktop file on 
the disk '[diskname]'? . . ." Click OK and then open the composite DCS file.

Solution 3
Make sure that all DCS component files are named according to DCS naming conventions and then open the composite DCS file. 
Each separation file should have a filename extension that indicates the color of the separation plate on which it will print (e.g., 
"filename.c" for the cyan plate, "filename.m" for the magenta plate, "filename.5" for the first spot color, "filename.6" for the second 
spot color).

Solution 4
Open each DCS component file in Photoshop and then merge them into a single file:
1. Open each DCS separation file (e.g., "filename.c," "filename.m," "filename.y," "filename.k," "filename.5") in Photoshop:

- In Mac OS, choose File > Open, select the first separation file, and then click Open. Repeat for the remaining separation 
files.

- In Windows, choose File > Open As, choose Photoshop EPS (*.eps) from the Open As pop-up menu, select the first 
separation file, and then click Open. Repeat for the remaining separation files.

2. Choose Window > Show Channels.
3. From the Channels palette menu, choose Merge Channels and then complete the following: 

-- For four channel CMYK images:
a.  In the Merge Channels dialog box, choose CMYK from the Mode pop-up menu. Enter 4 in the Channels field and 

then click OK. 
b. Choose the correct separation file from each of the channel pop-up menus (e.g., choose "filename.c" from the Cyan 

pop-up menu) and then click OK in the Merge CMYK Channels dialog box. 
-- For CMYK images with spot color channels (i.e., multichannel images) in Photoshop 5.0 (If you're using Photoshop 4.0.x or 

earlier, see Related Records for further information on editing multichannel images):
a. In the Merge Channels dialog box, choose Multichannel from the Mode pop-up menu. Enter the number of channels 

in the Channels field (e.g., enter "6" for an image that has two spot color channels) and then click OK.
b. Choose the correct separation file from the Image pop-up menu in the Specify Channel [Channel Number] section 

and then click Next. Make sure that you specify channel 1 as filename.c, channel 2 as filename.m, channel 3 as 
filename.y, channel 4 as filename.k, channel 5 as filename.5, channel 6 as filename.6, and so on. Repeat for each 
channel and then click OK.

NOTE: (Windows only) Click No to each of the messages, "Save changes to the Adobe Photoshop document 
"filename" before closing?"

c. Choose Image > Mode > CMYK.
d. Double-click the first alpha channel in the Channels palette.
e. Select Spot Color in the Color Indicates section, then click the color swatch in the Color section.
f. Assign a color to the channel by using the Color Picker or the Custom Color dialog box and then click OK.
g. Repeat steps d-f for any remaining alpha channels.



Additional Information
Desktop Color Separation (DCS) describes preseparated images, and is an enhancement to the Encapsulated PostScript (EPS) 
graphic file format. A DCS 1.0 file comprises five component files -- four separation files (cyan, magenta, yellow, and black) and a 
master file to which each separation file is linked. A feature of Photoshop 5.0 is the option to save an image as a DCS 2.0 file, which 
also supports spot color information.

DCS file links can break when your desktop file is damaged, when you move or rename any of the separation files, or when any of the 
component files are damaged. To open a DCS master file, Photoshop must be able to find the linked separation files. If one or more 
of the links are broken, Photoshop returns the error "Could not open or parse a DCS plate file because a File was not found." (Mac 
OS) or "Could not open the document because the file could not be found" (Windows). For example, Photoshop returns an error while 
opening the DCS 1.0 file named "Bridge.eps" that is in the Adobe Technical Info:Test Files folder (Mac OS) or the Techinfo\Tstfiles 
folder on the Photoshop 5.0.x Application CD-ROM because the file was inadvertently renamed after the separation files were saved.

DCS 2.0 files written by other applications or plug-ins (e.g., Platemaker, Channel 24) might not be compatible with Photoshop. You 
will not be able to open those files in Photoshop 5.0.
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Error "An Unknown User is Already Using a Copy . . . with This Serial Number" in Photoshop for 
Mac OS 

Issue
When you try to start Adobe Photoshop 3.0.x or later for Mac OS, it returns the error, "Could not start the application because an 
unknown user is already running a copy of Adobe Photoshop with this serial number." Or, Photoshop quits while you are working in it 
and returns the error, "An unknown user is already using a copy of Adobe Photoshop with this serial number." 

Solutions
Do one or more of the following:

Solution 1
Ensure no other Photoshop users on the network are using the same serial number:

1. Quit Photoshop and shut down the Macintosh.
2. Disconnect cables from all network connections (AppleTalk and/or Ethernet).
3. Restart the Macintosh, then restart Photoshop. 

Solution 2
Re-create the Photoshop preferences file:

NOTE: If you delete the preferences file, your custom Preferences settings and unsaved actions in Photoshop 4.0.x will be lost. 
To save any actions you've created, choose Save Actions from the Actions palette menu in Photoshop 4.0.x before performing 
the following steps. In Photoshop 5.0, the actions are saved in a separate preferences file. 

1. Quit Photoshop.
2. If you are using Photoshop 5.0, rename the 3 files (Actions Palette, Adobe Photoshop 5 Prefs, and Color Settings) in the 

Adobe Photoshop 5.0:Adobe Photoshop Settings folder. If you are using an earlier version, rename the Adobe Photoshop 
4.0 Prefs file (Photoshop 4.0), the Adobe Photoshop 3.0 Prefs file (Photoshop 3.0.x), or the Adobe Photoshop LE Prefs file 
(Photoshop 3.0.x LE) in the System folder:Preferences folder. 

3. Restart Photoshop.

Solution 3
Run Photoshop with all extensions off to verify that added extensions are not the cause. To turn all extensions off upon startup in 
System 7, restart the computer with the Shift key held down until the message "Welcome to Macintosh. Extensions Off." appears.

NOTE:  If you're using a Non-Apple keyboard, you may need to use a different method to disable extensions. Refer to the 
documentation included with the keyboard for instructions.

If the error reoccurs after you restart with the Shift key held down, move the Fonts folder, Extensions folder, Control Panels folder, 
Startup Items folder, Adobe Photoshop 3.0 Prefs file, control panels, and system extensions from the System Folder to another 
location (e.g., the desktop), then restart the Macintosh. For more information, see document 314385 , "Disabling Extensions and 
Isolating Extension Conflicts in System 7.x", or document 311687 , "Disabling Extensions and Isolating Extension Conflicts in Mac OS 
8.0.x."

Solution 4
Re-create the AppleTalk Preferences file and the Finder Preferences file:

1. Quit Photoshop.
2. Delete the AppleTalk Preferences file and the Finder Preferences file from the System Folder:Preferences folder.
3. Restart the Macintosh.
4. Restart Photoshop.

Solution 5
Remove and reinstall Photoshop:

1. Move any non-Photoshop files (e.g., images you have created, third-party plug-ins) out of the Adobe Photoshop folder and 
its subfolders.

2. Delete the Adobe Photoshop folder and the Adobe Photoshop preferences file from the System Folder:Preferences folder.
3. Reinstall Photoshop from the software disks or CD-ROM.
4. Restart the Macintosh and rebuild the desktop file by holding down the Command and Option keys while restarting the 

computer. Keep the keys held down until you receive the message "Are you sure you want to rebuild the desktop file on the 
disk '[diskname]'?" Then click OK.



Solution 6
Make sure that Photoshop has been exited properly on all networked Macintoshes:
1. Quit Photoshop on the Macintosh on which you received the "serial number" message, then shut down that Macintosh.
2. Start Photoshop on the other Macintoshes on the network.  If Photoshop has been removed from any of the Macintoshes on the 

network, reinstall it on those computers.
3. Quit Photoshop, and shut down the Macintoshes on the network.
4. Restart the Macintosh on which the error occurred, then restart Photoshop.

Solution 7
Make sure that the network software recognizes that Photoshop has been exited properly on all networked Macintoshes:
1. Quit Photoshop on the Macintoshes on the network.
2. Shut down the network software. For instructions, contact the manufacturer (e.g., Novel, Microsoft).
3. Restart the network software.
4. Restart the Macintosh on which the error occurred, then restart Photoshop.

Solution 8
Reinstall the Macintosh system software by performing a clean install (i.e., install new system software into a new System Folder, 
instead of updating the existing system software). For additional information, see document 200407 .

Solution 9
Reset the Parameter RAM (PRAM) by holding down the Command + Option + P + R keys when restarting the computer. Hold these 
keys down until you hear the startup beep twice, then release the keys. 

NOTE: Resetting the Parameter RAM resets the system's preferences to the default settings (e.g., Black and White in the Monitors 
control panel, LocalTalk Built In in the Network control panel). For more information, see document 200307 .

Additional Information
Photoshop checks your network during startup and when running to ensure that no other copies of the application with the same serial 
number are being used. If Photoshop receives a message back from your network software or the System, it will force you to exit the 
program. Usually this happens when another copy of Photoshop with the same serial number is being used, but can also happen 
when System or network files are damaged. 

Photoshop includes a single-user license, which permits one copy of the application to be used on any one computer over a network. 
Contact Adobe Customer Services for information about Photoshop five-user licenses.
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Import Submenu Dimmed or Contains No Plug-ins in Photoshop for Mac OS

Issue
The Import submenu in Adobe Photoshop is dimmed or does not contain any plug-ins.

Solutions
Do one or more of the following:

Solution 1
Ensure the plug-in files are in the Plug-ins folder on the hard disk. 

Solution 2 
Retarget the Plug-ins folder:
1. In Photoshop, choose File > Preferences > Plug-ins & Scratch Disks.
2. Verify that the path in the Plug-Ins Folder section is correct (e.g., Hard Drive: Adobe Photoshop 5.0: Plug-ins). If it is not, click 

Choose.
3. In the Select the Plug-ins Folder dialog box, click once on the Plug-ins folder to select it.
4. Click Select "Plug-ins" below the scroll box.
5. Click OK to close the Plug-ins & Scratch Disks Preferences dialog box.
6. Restart Photoshop.

Solution 3
Recreate the Photoshop preferences file:

Note: When you delete the main preferences file, custom preferences settings and unsaved Photoshop 4.0.x actions are lost. To save 
any Photoshop 4.0.x actions you've created, choose Save Actions from the Actions palette menu before deleting the preferences file. 
Photoshop 5.0.x saves the actions in a separate preferences file. 

1. Quit Photoshop.
2. If you are using Photoshop 4.0.x, choose Save Actions from the Actions palette menu to save any actions you've created.
3. Delete the Adobe Photoshop 5 Prefs in the Adobe Photoshop 5.0:Adobe Photoshop Settings folder or delete the Adobe 

Photoshop 4.0 Prefs file in the System folder:Preferences folder. 
4. Restart Photoshop.

Additional Information
Photoshop loads import plug-ins located in its plug-ins folder and lists them in the Import submenu. If Photoshop cannot access the 
plug-ins, it dims the Import submenu or does not list import plug-ins.

The Photoshop preferences file includes the plug-ins resource, named PipL cache, which stores location and content information 
about the plug-ins folder. If the folder's name or contents change and the PipL is not updated, Photoshop cannot access the plug-ins. 
The Photoshop preferences file contains plug-ins information and other custom settings information. After you delete Photoshop's 
preference file, Photoshop creates a new Preferences file, which includes Photoshop's default preference settings, the next time you 
start Photoshop.



Adobe Customer Support Services 

Font Characters Cut Off in Photoshop for Mac OS

Issue
Font characters with descenders (e.g., j, p, q, y) or ascenders (e.g., b, d, f, h) are cut off in Adobe Photoshop for Mac OS. 

Solutions
Do one of the following:

Select Preserve Character Shapes in the ATM control panel:
1. Quit Photoshop.
2. Open the ATM control panel and select the Preserve Character Shapes option. In ATM Deluxe 4.0, choose File > 

Preferences, choose General from the pop-up menu, and select the Preserve Character Shapes option. 
3. Restart the Macintosh.

OR:  Convert the characters to outlines in another application, then open them in Photoshop:
1. Launch an application that can convert text to outlines or paths (e.g., Adobe Illustrator, Macromedia FreeHand).
2. Type the characters, then convert them to outlines.
3. Save the file in a format supported by Photoshop (e.g., EPS).
4. Open the file in Photoshop.

OR:  Type the characters in another image editing application (e.g., Fractal Painter), save them in a format supported by Photoshop 
(e.g., TIFF), then open them in Photoshop.

Additional Information
When you select Preserve Line Spacing in the ATM control panel, font characters with long descenders or tall ascenders typed in 
Photoshop display and print truncated from Photoshop. When you select Preserve Character Shapes in the ATM control panel, or 
when you type the characters in another application, the font characters display and print correctly in Photoshop.

ATM can either preserve character shapes or line spacing, but not both. ATM's Preserve Character Shapes option enables font 
characters to display and print as accurately as possible. ATM's Preserve Line Spacing option enables the line lengths of text to 
display and print as accurately as possible. Deselecting Preserve Line Spacing may change line breaks in text.

Truncated characters can occur in any font at any point size, however truncation is more obvious at larger point sizes (e.g., above 72 
points), and in fonts that have particularly long ascenders and descenders, such as script or flourished fonts. The problem occurs in 
both Adobe fonts (e.g., Ex Ponto) and non-Adobe fonts (e.g., Letraset Papyrus). Adjusting the leading in Photoshop's type dialog box 
has no effect on the truncated characters.
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Program Error in Photoshop 3.0.x or Later in Windows NT 4.0

Issue
When you start or work in Adobe Photoshop 3.0.x or later in Windows NT 4.0, Photoshop returns one of these errors: 

"Could not launch Photoshop because of a program error."
"Could not open file [filename] because of a program error." 
"Could not save file [filename] because of a program error." 
"K mode exception not handled."
"K_mode_exception_not_handled."

Solutions
Do one or more of the following:
A. Specify a different default printer:

1. Choose Start > Settings > Printers.
2. Right-click a PostScript printer other than the current default, then choose Set as Default from the pop-up menu. If a 

PostScript printer driver isn't installed, you can select a non-PostScript printer. Do not select a non-printer device, such as a 
fax or modem. 

B. Install a PostScript printer driver (e.g., Microsoft PostScript printer driver), then set up that printer as your default printer. You 
don't have to have a PostScript printer connected to your computer to install a PostScript printer driver. For more information on 
installing printer drivers, see your Windows documentation.

C. Remove and then reinstall the printer driver for the default printer. For instructions, see the printer driver documentation or 
contact the printer manufacturer.

D. Disable any fax software.

E. Install an updated version of the printer driver for the default printer. Contact the printer driver manufacturer for availability.

F. Recreate Photoshop's preferences files:

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created, choose Save Actions from the Actions palette menu. 
Photoshop 5.0 saves the actions in a separate preferences file. 

1. Exit from Photoshop.
2. For Photoshop 5.0, rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the Photoshop5\Adobe 

Photoshop Settings folder. For other versions, delete or rename the Photos40.psp and CColorsd files in the 
Photoshop\Prefs directory (Photoshop 4.0.x) or the Photos30.psp and CColorsd files in the Win32app\Photoshp\Prefs 
directory (Photoshop 3.0.5) or the Windows directory (Photoshop 3.0 through 3.0.4).

3. Restart Photoshop.

G. Recreate the Virtual Memory paging file:
1. Exit all applications.
2. Right-click on My Computer and then choose Properties from the pop-up menu.
3. Click the Performance tab, then click Change.
4. From the Drive list, select a hard disk that has at least twice the amount of your computer's installed RAM. For example, if 

your computer has 24 MB of RAM, select a hard disk that has at least 48 MB of free hard disk space.
5. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your 

computer's installed RAM plus 12 MB. 
6. In the Maximum Size box, enter a value equal to twice the amount of your computer's installed RAM.
7. Click Set, then click OK.
8. Click OK to close the System Properties dialog box.
9. To restart Windows, click Yes in the System Settings Change dialog box. 

Additional Information
When Photoshop starts, or when it acquires, opens, saves, or creates a file, it checks the default printer driver for information about 
that printer (e.g., page size, margins, imageable area). When Photoshop can't interpret this information it returns a program error. 
Photoshop may be unable to interpret the information if the printer driver is damaged or incompatible with Windows NT 4.0, or if the 
driver is for a non-printer device (e.g., fax) or a non-PostScript printer (e.g., PCL). 



Also when Photoshop starts, it reads its own preferences files to load customizable settings (e.g., palette placement, brush sizes). 
When the preferences files are damaged, Photoshop can't read them and returns a program error. If you rename the preferences files 
and then start Photoshop, Photoshop creates new preferences files containing its default settings.

Windows NT requires a fixed size for a paging file (i.e., the space Windows uses for virtual memory). Photoshop may return a program 
error if the paging file is damaged. When you recreate the paging file, program errors in Photoshop are less likely to occur. For more 
information about the paging file, refer to Windows NT on-line Help or your Windows documentation.
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Error ". . . MSVCRT40.DLL is intended only for Win32s" When Starting Photoshop 4.0.x or Later for 
Windows

Issue
When you start Adobe Photoshop 4.0.x or later, Windows returns the error, "This version of MSVCRT40.DLL is intended only for 
Win32s." After you click OK, Photoshop starts as expected.

Detail
The Error dialog box reads as follows:

Microsoft Visual C++ Runtime Library
MSVCRT40.DLL for Win32s
Error: This version of MSVCRT40.DLL is only intended for Win32s.

Solution
Rename each Msvcrt40.dll file, then reinstall either Photoshop (Windows 3.1x) or the Msvcrt40.dll file (Windows 95, Windows NT):
1. Exit from all applications.
2. Using Windows File Manager or Windows Explorer, search for each Msvcrt40.dll file and rename them "Msvcrt40.old".
3. Either reinstall Photoshop (Windows 3.1x), or reinstall the Msvcrt40.dll file ( Windows 95, Windows NT) by doing one of the 

following:

- For Windows 95A:
Download the Msvcrt.exe file from Microsoft's Web site at http://support.microsoft.com/download/support/mslfiles/Msvcrt.exe. The 
Msvcrt.exe file installs the Msvcrt40.dll and Msvcrt20.dll files. 

- For Windows 95B:
Insert your Windows CD-ROM into the CD drive, then choose Start > Programs > MS-DOS Prompt. At the DOS prompt, enter the 
following commands and press Enter after each line:

D:\
CD Win95
Extract /A win95_02.cab msvcrt40.dll /L C:\Windows\System 

(Where "D" is the CD drive, "C" is the Windows 95 drive, and "Windows" is the Windows 95 folder.)

NOTE: If Windows is using the file, it will return a message that it cannot rename or overwrite the existing file. Restart Windows 
and try again.

- For Windows NT:
Insert your Windows CD-ROM into the CD-ROM drive, then choose Start > Programs > Command Prompt. At the DOS prompt, 
enter the following commands and press Enter after each line:

C:
CD\
Expand D:\i386\Msvcrt40.dl_ C:\Winnt\System32\Msvcrt40.dll

(Where "D" is the CD-ROM drive, "C" is the Windows NT drive, and "Winnt" is the Windows NT directory.)

NOTE:  If Windows is using the file, it will return a message that it cannot rename or overwrite the existing file. Restart Windows 
and try again.

Additional Information
Many applications install a Msvcrt40.dll system file. If a version of this file is installed, but incompatible with your operating system, 
Photoshop will return an error but otherwise perform as expected.

In Windows 3.1x, Photoshop installs a version of the Msvcrt40.dll file that is compatible with Windows 3.1x. It does not, however, 
overwrite other installed Msvcrt40.dll files, even if those files are incompatible with Windows 3.1x. If you rename each Msvcrt40.dll 
file and then reinstall Photoshop, Photoshop and other applications will use the compatible Msvcrt40.dll. file installed by Photoshop.

In Windows 95, Photoshop does not install or require a Msvcrt40.dll file. However, it will still return an error if the file is incompatible 
with your operating system. If you rename the Msvcrt40.dll file, Photoshop will not return an error, but other applications may not run. 
If you install the compatible version of the file, Photoshop and other applications will run as expected.
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Exported Duotones Print an Extra Plate from Photoshop 2.5.x and Later

Issue
When you print duotones created in Adobe Photoshop 2.5.x and later from a page layout application (i.e., Adobe Illustrator, Adobe 
PageMaker, QuarkXPress), a PANTONE process color duotone prints on a separate plate, rather than on the appropriate process color 
plate. For example, if the duotone contains "PANTONE Process Black CV," a separate plate, called "PANTONE Process Black CV" 
prints in addition to the black plate.  

Solution
Rename the process color used in the duotone:
1.  Choose Mode > Duotone in Photoshop 2.5.x or 3.0.x or choose Image >  Mode > Duotone in Photoshop 4.0.x or later to open the 

Duotone Options dialog box.  
2.  In the Duotone Options dialog box, rename the process color "Black" (or "Cyan," "Magenta," or "Yellow"). Make sure that the first 

letter or the color name is capitalized.
3. Resave the duotone as an EPS and reimport the file into the page layout application.

Additional Information
Process colors in page layout applications are always named "Cyan," "Magenta," "Yellow" and "Black."  Process colors from the 
PANTONE Coated list in Photoshop are named "PANTONE Process <Colorname> CV." Renaming the duotone color in Photoshop to 
match its counterpart in the page layout application ensures separations print correctly.
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CleanSweep Deluxe Causes Errors or Prevents Plug-ins from Loading in Photoshop

Issue
Plug-ins do not load or an error occurs or in Adobe Photoshop 3.0.x or later for Windows 95 or NT 4.0. 

Details
CleanSweep Deluxe is installed.

One or more of the following symptoms occurs"
- When you start Photoshop, it returns one of the following errors:

"Could not load the ‘Fast Core Routines’ module because of a program error."
"Could not load the ‘MMX Core Routines’ module because of a program error."
"Could not load the ‘Multiprocessor Support’ module because of a program error."
"Could not load the tablet pressure extension because of a program error."

- When you open a file, Photoshop returns the error, "Could not open [filename] because Photoshop cannot recognize file 
extension."

- TWAIN sources (e.g., scanner, digital camera) are missing.

- The following filters are missing from the Filters menu: Radial Blur, Smart Blur, Displace, Pinch, Polar Coordinates, Ripple, 
Shear, Spherize, Twirl, Wave, ZigZag, Color Halftone, Crystallize, Mezzotint, Pointillize, Clouds, Difference Clouds, Lens Flare, 
Lighting Effects, Texture Fill, Extrude, Solarize, Tiles, Wind, De-Interlace, and NTSC Colors.

- The Render and Video submenus are missing from the Filters menu.

Solutions
Do one of the following:
- Install CleanSweep Deluxe 3.0.8 or obtain the Update for Deluxe US version 3.07 to Deluxe US version 3.08(433k) from 

Quaterdeck.

- Exit Photoshop, disable the Csinject component of CleanSweep Deluxe, and restart Photoshop:

Windows 95:
1. Exit Photoshop.
2. Press Ctrl+Alt+Del to display the Close Program dialog box.
3. Select Csinject, click End Task, and follow the on-screen instructions.
4. Restart Photoshop.

Windows NT 4.0:
1. Exit Photoshop.
2. Press Ctrl+Alt+Del and click Task List.
3. Click the Processes tab.
4. Select Csinject, click End Process, and follow the on-screen instructions.
5. Restart Photoshop.

- Exit Photoshop, uninstall CleanSweep Deluxe, and restart Photoshop:
1. Exit Photoshop.
2. Choose Start > Settings > Control Panel.
3. Double-click Add/Remove Programs.
4. Choose CleanSweep Deluxe, click Add/Remove, and follow the on-screen instructions.
5. Restart Photoshop.

Additional Information
The CleanSweep Deluxe utility tracks the installation of programs, assists in uninstalling programs, and monitors changes to your hard 
drive. To enable Photoshop to load plug-ins, and start and open files without returning an error when CleanSweep Deluxe is active, 
you must either disable CleanSweep Deluxe's Csinject component after Windows is started or uninstall CleanSweep before starting 
Photoshop.

During Windows startup, the Csinject component loads a DLL file required by CleanSweep Deluxe. After Windows is started, Csinject 
remains active though it is no longer needed. When Csinject is active, Photoshop for Windows may be unable to load some plug-ins, 



or may return an error while starting or opening a file. You can disable Csinject using the Task Manager or Close Program dialog box 
without adversely affecting CleanSweep Deluxe or other applications.

For additional information on the operation or uninstallation of CleanSweep Deluxe refer to the CleanSweep manual or call 
Quarterdeck Corporation.
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File Icons and Associations Change After Installing Photoshop 4.0.x, 4.0.1 Tryout, or 5.5 in 
Windows 

Issue
When you install Adobe Photoshop 4.0.x, Adobe Photoshop 4.0.1 Tryout, or Photoshop 5.5, some file formats (e.g., TIFF, JPEG, GIF) 
become associated with Photoshop or Adobe ImageReady. Their file icons change to Photoshop icons, and when you double-click 
them, Photoshop starts instead of the desired application.

Solutions
Do one of the following:

Solution 1
Reinstall the applications that were associated with the file formats.

Solution 2
Manually associate an application with a file format:

NOTE: Manually associating an application with a file format does not restore the file icons to match the associated application. To 
restore file icons, you must reinstall the application.

1. Choose Start > Programs > Windows Explorer.
2. Select a file whose file format association you want to change. For example, if you want to change the file format association 

for all TIFF files, select a TIFF file.
3. Press Shift + F10, or shift and right-click on the file.
4. Select Open With from the pop-up menu.
5. In the Open With dialog box, select the application you want to associate the file format with. If the application isn't listed, click 

Other, then locate and select the application you'd like.
6. Select the Always Use This Program To Open Files of This Type option.
7. Click OK.
8. Repeat steps 1-7 for any other file format associations you want to change.

Additional Information
When you install an application in Windows 95, Windows 98, or NT 4.0, the application's installer can associate the application with 
file formats commonly used by the application. This is a Windows function which is available to all applications running under 
Windows. Files of that format then appear with the application's file icons, and when you double-click on the files the application 
automatically launches. 

For example, when you install Photoshop 5.5 in Windows 95, Windows 98, or NT 4.0, Photoshop's installer associates Photoshop with 
several file formats, including TIFF, JPEG, and GIF and changes their icons to Photoshop icons. If you later install another 
application that commonly uses TIFF, JPEG, and GIF files, the associations for those formats may in turn switch to the new 
application. 

Photoshop 5.0.x only associates its native format (.psd) to itself. Photoshop 5.5's installer, however, allows you to change or 
disassociate formats to either Photoshop or ImageReady, or maintain the defaults associations. The default format associations for 
Photoshop 5.5 are Windows Bitmap (.bmp), Encapsulated PostScript (.eps), FlashPix (.fpx), Amiga (.iff), PICT, PC Exchange (.pcx), 
Pixar (.pxr), Photoshop raw data (.raw), Scitex CT (.sct), Targa (.tga), Tagged Image File Format (.tif). The default format associations 
for ImageReady are Portable Network Graphics (.png), JPEG, and GIF.

The practice of associating file formats to a specific application is part of the Windows specification. If you previously double-clicked 
on a file icon and a different application started, it was because that application had associated the file format with itself when it 
installed.
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Creating Predictable Separations Using Photoshop 5.0.x

What's Covered
Monitor Calibration
Imagesetter Calibration 
Dot Gain On-Press
Separation Setup
Lab Color Mode 

To generate reliable color separations from Adobe Photoshop, it's important to understand the role of calibration. This document 
outlines the issues involved with  calibration. For more detailed information, see the Adobe Photoshop User Guide and document 
321625 , "Photoshop 5.0 Color Management Technical Guides."

Monitor Calibration
Colors displayed on a monitor can look different from those that are printed, but you can control certain factors to help ensure 
predictable printed results. 

Lighting and Viewing Conditions 
It is important to work in a controlled environment where the ambient light does not change during the course of the day. Any change 
can affect your perception of colors on your monitor. Ideally, you should work in an artificially lit room that has a consistent brightness 
level. You can control the brightness level by closing your room off to external light sources and then taping down the monitor and 
room lighting controls once they are set.

The reflected light from brightly colored walls or clothes also affect how you perceive colors. View colors in a room with gray walls 
while wearing neutral-colored clothing, if possible. 

Colors On-screen
The colors displayed by a monitor can be affected by the monitor's age and temperature. Adjust the display according to the 
manufacturer's instructions and let the monitor warm up for an hour before making color corrections to an image. Also, do not leave 
the monitor running overnight. 

Color Cast 
Most uncalibrated monitors have a bluish color cast. Use the Adobe Gamma Control Panel (or another calibration application) to 
eliminate the cast and bring your monitor into a known neutral state. Working with an uncalibrated monitor can lead you to over- or 
under-correct images. For example, if you don't adjust for a monitor's bluish color cast, you'll likely add yellow and red to an image to 
compensate for the cast, resulting in the printed image having a yellow and red color cast.

Imagesetter Calibration
Unless the imagesetter and processor are well maintained, the dot percentage designated in Photoshop may not be the actual 
percentage measured with a densitometer on film. For example, if you specify a 65 percent halftone tint, the densitometer reading 
can vary by as much as 20 percent. Use a well-calibrated densitometer to measure dot densities for accurate halftones. You should 
calibrate an imagesetter at least once a day and check color separation output with each new roll of film and batch of chemicals.

Selecting Calibration Bars in the Page Setup dialog box prints an 11-step, gray wedge on your separations. You can use this gray 
wedge to record densities at different levels from a given imagesetter. Photoshop can compensate for these density changes with 
transfer functions. If you enter information about the density that is recorded at different levels, Photoshop makes the necessary 
adjustments to ensure linearization (i.e., to ensure  the requested tints closely match the output). This option is recognized only when 
you print directly from Photoshop, or when you save the file as EPS and print to a PostScript printer. For best results, use the 
calibration utility provided by the manufacturer of your imagesetter rather than the transfer functions. 

Dot Gain On-Press
Even if the dot percentages recorded on film are accurate, they may change during printing due to dot gain on the printing press. Dot 
gain occurs when halftone dots reproduce larger on paper (in varying degrees depending on the paper stock) than they do on film. 
This can cause oversaturated color and inaccurate reproduction. A certain amount of dot gain always occurs on-press, but you can 
compensate for it if you know what to expect.

For each project, ask your printer how much dot gain to anticipate. Photoshop compensates for on-press dot-gain with lookup tables in 
the CMYK setup dialog box. The lookup tables take into consideration the nature of the paper stock, how colors reproduce on the 
stock, and the level of dot gain expected on the stock at the 50 percent mark. Photoshop uses this 50 percent value to generate a 
curve that applies dot gain compensation throughout the image. 



Separation Setup
When preparing color separations, it is important to select the correct separation options in the Separation Options section of 
Photoshop's CMYK Setup dialog box. The two types of separations you can choose are Gray Component Replacement (GCR), which 
is the default, and Undercolor Removal (UCR). Contact your printer to find out the method for generating the black plate with which 
they have the most experience. Many printers are more comfortable with the UCR method of printing. 

Other options in the dialog box--such as Black Ink Limit, Total Ink Limit, and UCA Amount--involve conditions specific to the press on 
which your separations will be printed. Contact your printer for advice on entering these values. 

Lab Color Mode 
Photoshop uses the Lab color mode as an intermediary in most mode conversions. Lab color is a device-independent color mode 
that appears the same no matter what type of monitor or printer you're using, as long as the devices are calibrated. In all color mode 
conversions, Photoshop converts images to Lab mode. For example, when you convert a file from RGB to CMYK, Lab is the color 
mode that the conversion uses as a neutral ground. For more information, see document 310838 , "The Lab Color Mode in 
Photoshop."
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Preparing Photoshop Files for Print Separations

What's Covered
Screen Frequency and Image Resolution
Dot Gain On Press
Generating the Black Separation Plate
Ink Limits
The Printer's Role in Producing Film

To get the best separations from Adobe Photoshop, it is important to maintain a dialog with the different professionals involved in the 
printing process. Of all these conversations, the one with your printer is the most crucial. You should choose a print shop before you 
begin the design process. To choose a print shop, consult with several printers and tour their facilities. When you take a tour, ask to 
see printed samples of their work and spec sheets for their equipment. Many good printers provide information geared to working with 
desktop files. Be sure to find out about their printing press capabilities.

When you pick a printer and are ready to start working on a project, do not hesitate to ask any questions you may have. Asking the 
right questions helps you to establish a good rapport with the printer, and will help you get the information you need to produce good 
separations. 

The following sections detail the most important information you need from your printer to produce good color separations in 
Photoshop, which are: 
- the range of screen frequencies the press can handle 
- press conditions and potential dot gain 
- method for generating black separation plates 
- ink limitations of the press and the ink density of the black plate
- the printer's role in producing film 

Your printer may also be able to guide you in selecting and modifying images that will print well, and perhaps can recommend a 
color house for high-end scans. 

Screen Frequency and Image Resolution
When you first talk with your printer, determine the screen frequency potential of the press. The screen frequency may vary depending 
on the plates. Also, a higher screen frequency may be more expensive. The screen frequency directly affects the resolution of the 
scanned image in Photoshop. In general, the image resolution needs to be 1.5 to 2 times the screen frequency at which the file is 
printed. For example, if the press can support a 150-line screen, you won't need an image resolution greater than 300 pixels per inch 
(ppi). A higher image resolution won't yield significantly better results, but will generate a much larger file size. On the other hand, a 
lower resolution for your image may create a file that looks blockish or pixelated when printed.

Dot Gain On Press
Be sure to ask how much dot gain the printer experiences on-press for a given paper stock. Ask how much dot gain is expected 
on-press from the film stage to press sheet in the midtones. Many printers will tell you the amount of dot gain expected from the proof 
stage to the press sheet, but this is the wrong value to use in Photoshop. 

In general, coated stock registers a dot gain of 18% to 25% in the midtones. Dot gain for uncoated stock and newsprint varies from 
30% to 40%. Because midtones register the greatest amount of gain on-press, Photoshop uses the gain in the midtones as a good 
indication of the gain that occurs over the rest of the image. If your printer is unsure of the dot gain value, use the default values 
provided CMYK Setup dialog box: 
- Ink Colors: SWOP (Coated)
- Dot Gain: 20%

Generating the Black Separation Plate
Photoshop offers two ways to generate the black separation plate: Undercolor Removal (UCR) and Gray Component Replacement 
(GCR). The options appear in the CMYK Setup dialog box.

The difference between the two methods mainly affects the black plate. GCR generates black throughout the image, beginning in 
the highlights. UCR generates black mainly in the 3/4-tones and in the black part of the image, thus holding shadow detail better. 
See how the two methods distribute black ink by observing the black in the Gray Ramp when you choose either GCR or UCR. (Notice 
also that the supporting C, M, and Y are adjusted.)

For best results, choose GCR or UCR, depending on which method the print shop has more experience using and is more comfortable 



with. Many printers are more comfortable with UCR. 

Ink Limits
Also ask your printer about the total ink limit the press can support and the total ink density used for the black plate. Enter this 
information in the CMYK Setup dialog box. Many small- to medium-sized print shops may not be able to provide this information. If 
you are unsure, use the default values. 

The Printer's Role in Producing Film
A close working relationship with your printer in producing film can save time and money. Ask your printer what role the print shop will 
play in producing film. Pick a printer who assumes this function in-house or who is willing to work closely with your imaging house or 
service bureau.
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Images Look Jagged in Photoshop 4.0.x or Later

Issue
Images in Adobe Photoshop 4.0.x or later appear jagged or blurry on-screen, but print as expected. 

Solution
Change the image's magnification to one of the following percentages: 6.25%, 12.5%, 50%, 100%, 200%, 300%, 400%, 500%, 
600%, 700%, 800%, 900%, 1000%, 1100%, 1200%, 130%, 140%, 150%, or 1600%. You can change the magnification using the 
Zoom tool, or by typing the percentage in the lower left corner of the Navigator palette or the lower left corner of the application 
window.

Additional Information
Photoshop 3.0.x and earlier display images in fixed pixel ratios (e.g., 1:16, 1:8, 1:4, 1:2, 1:1, 2:1, 11:1). Photoshop 4.0.x and later 
are optimized to display images at magnification percentages that correspond to these fixed pixel ratios. Changing the magnification 
percentage in Photoshop 4.0.x and later to one that does not correspond with a Photoshop 3.0.x view ratio does not affect the actual 
pixel data, rather it only affects Photoshop's ability to accurately display the pixel data on-screen. In Photoshop 4.0.x and later, you 
can specify views up to a 100th decimal place. However, because of the limitations of monitor resolution it is not always possible to 
display the image smoothly, especially on diagonal lines and curves.

Photoshop 3.0.x View Ratios Photoshop 4.0.x and Later View Percentages
1:16 6.25%
1:8 12.5%
1:4 25%
1:2 50%
1:1 100%
2:1 200%
3:1 300%
4:1 400%
5:1 500%
6:1 600%
7:1 700%
8:1 800%
9:1 900%
10:1 1000%
11:1 1100%
12:1 1200%
13:1 1300%
14:1 1400%
15:1 1500%
16:1 1600%
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Simplifying Windows 95 to Troubleshoot Errors in Photoshop, ImageReady, or ImageStyler

System errors in Windows 95 are often caused by startup items or device drivers that have become damaged, or that conflict with 
each other or with other applications. To troubleshoot errors, you can disable these items by starting in Step-By-Step Confirmation 
Mode, or, for more extensive troubleshooting, by using a Test Configuration file with Step-By-Step Confirmation Mode. 

Starting Windows 95 in Step-By-Step Confirmation Mode enables you to selectively bypass startup items (e.g., the Registry, the 
Autoexec.bat file), but not device drivers. If errors still occur after restarting in this mode, one of the device drivers that loaded may be 
causing the error. You can use a Test Configuration file at this stage to selectively bypass device drivers, loading only the minimum 
device drivers necessary to run Adobe ImageStyler, Adobe ImageReady, or Adobe Photoshop (i.e., mouse, keyboard, video). If errors 
do not occur after you disable startup items or device drivers, you can determine which item is causing problems in ImageStyler, 
ImageReady, or Photoshop by reloading them one by one.

NOTE: Applications that load automatically in Windows can also cause errors to occur. Before you begin troubleshooting, launch 
Explorer and move all icons and shortcuts from the Windows\Start Menu\Programs\StartUp directory to another directory, then restart 
Windows and ImageStyler, ImageReady, or Photoshop. Windows 95's Safe Mode disables StartUp programs, but it loads the Windows 
standard VGA video driver, which does not display enough colors to run ImageStyler, ImageReady, or Photoshop.

NOTE: Photoshop 3.0.5 is the earliest Windows 95-compliant version. Therefore, this document pertains to Photoshop 3.0.5 and 
later.

Using Step-By-Step Confirmation Mode for ImageStyler, ImageReady, or Photoshop
To run Windows using the Step-By-Step Confirmation Mode for ImageStyler, ImageReady, or Photoshop:
1. Restart Windows 95. When the "Starting Windows 95. . ." message displays, press the F8 key.
2. Select Step-By-Step Confirmation from the Startup Menu.
3. Type "Y" or "N" to the following prompts as indicated:

NOTE: Type "Y" for any prompt that references DoubleSpace, DriveSpace, or DoubleBuffer (Dblbuff.sys). DoubleSpace and 
DriveSpace are disk compression schemes. Windows requires these drivers when your disk is compressed with these utilities. 
DoubleBuffer enables you to load a double-buffering driver for a SCSI controller.

Process the system registry? N
Create a startup log file (BOOTLOG.TXT)? N
Process your startup device drivers (CONFIG.SYS)? N
DEVICE=C:\WlN95\HlMEM. SYS? Y
DEVICEHlGH=C:\WlN95\lFSHLP.SYS? Y
DEVICEHlGH=C:\WIN95\SETVER.EXE? N
Process your startup command file (AUTOEXEC.BAT)? N
Load the Windows graphical user interface? Y
Load all Windows drivers? Y

NOTE: You must load all Windows drivers in order to load the video driver necessary to run ImageStyler, ImageReady, or 
Photoshop. If you do not load all Windows drivers, Windows will start in Safe Mode.

After you type "Y" to load all Windows drivers, Windows will eventually start.

Creating a Test Configuration in Windows 95 for ImageStyler, ImageReady, or Photoshop
If errors still occur after you start Windows in Step-By-Step Confirmation Mode, one of the device drivers that loaded may be causing 
the problem. Create a Test Configuration for Windows that selectively disables all device drivers except the mouse, keyboard, and 
video driver necessary to run ImageStyler, ImageReady, or Photoshop.

To run Windows using a Test Configuration for ImageStyler, ImageReady, or Photoshop:
1. Choose Start > Control Panel > System.
2. Click the Hardware Profiles tab.
3. Select Original Configuration, then click Copy.
4. In the Copy Profile dialog box, type "Test Configuration" and click OK.
5. Click the Device Manager tab.
6. Click the plus symbol (+) next to each device.
7. Select a device that you want to disable, then click the Properties button. 
8. In the Device Usage section, click the check box next to "Disable in this hardware profile," then click OK.



NOTE: Devices required by Windows 95 cannot be disabled and do not have a Device Usage option.

9. Repeat steps 7-8 for all devices except the mouse, keyboard, and display adapter device drivers.
10. Close the System Properties Control Panel, then restart Windows.
11. When the "Starting Windows 95..." message displays, press the F8 key. Then follow steps 1-3 in the Using Step-By-Step 

Confirmation Mode for ImageReady or Photoshop section above.
12. After you finish the Step-By-Step Confirmation, Windows will prompt you to select a startup configuration. Select Test 

Configuration and press Enter. Windows starts using minimized startup items and device drivers.

NOTE: If more than one configuration (e.g., Original Configuration, Test Configuration) is available, Windows will continue to prompt 
you to select a startup configuration each time you restart your computer. Follow the steps below to remove the Test Configuration.

To remove your Test Configuration:
1. Start Windows in the Original Configuration, then choose Start > Control Panel > System.
2. Click the Hardware Profiles tab.
3. Select Test Configuration.
4. Click the Delete button.
5. Close the System Properties dialog box.
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Photoshop Image Doesn't Print with Expected Custom Halftone Screen from Other Applications

Issue
Imported Photoshop 2.5.1 or later images do not print with the expected custom halftone screen, as specified in Photoshop's Halftone 
Screens dialog box.

Solutions
In Photoshop, resave the image as an EPS (*.eps) file by choosing EPS from the Format pop-up menu then selecting Include 
Halftone Screen in the EPS Format dialog box.

OR:  Specify a custom halftone screen for the image within the printing application (e.g., QuarkXPress, PageMaker).

Additional Information
Only the EPS file format includes custom halftone screen information. When printing an imported Photoshop EPS file from another 
application, custom halftone screens included in the EPS file override the printing application's default halftone screens. 

Photoshop images saved in other file formats (e.g., TIFF, PICT) do not contain custom halftone screen information, as these formats 
are unable to include custom halftone screen information. Imported Photoshop images saved in formats other then EPS print from 
other applications using the application's default halftone screen or with the halftone screen assigned to it in the application.

To set custom halftone screens for a CMYK image in Photoshop:
1. Open a CMYK image.
2. Choose File > Page Setup, then click Screens.
3. In the Halftone Screens dialog box, deselect Use Printer's Default Screens.
4. Select Cyan from the Ink pop-up menu, then enter the desired screen frequency and angle.
5. Select each remaining ink (i.e., Magenta, Yellow, Black) from the Ink pop-up menu, and enter the desired screen frequency 

and angle.
6. Click OK.

To set a custom halftone screen for a grayscale image in Photoshop:
1. Open a grayscale image.
2. Choose File > Page Setup, then click Screens.
3. In the Halftone Screen dialog box, deselect Use Printer's Default Screen.
4. Enter the desired screen frequency.
5. Click OK.
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Error "Scratch Disk is Full" When Editing a File in Photoshop 3.0.x or Later

Issue
When you edit a file in Adobe Photoshop 3.0.x or later for Windows, Photoshop returns the error, "Scratch disk is full." 

Solutions
Do one or more of the following:
A. For the primary scratch disk, specify a hard disk partition that has 3-5 times the size of the file you're editing in free space, and 

then specify a secondary (or for Photoshop 5.0, a third and fourth) scratch disk. If you are using Photoshop 4.0.x or earlier, 
specify a different hard disk partition for the primary and secondary scratch disks. To specify a scratch disk in Photoshop:
- In Photoshop 4.0.x or 5.0, choose File > Preferences > Plug-ins & Scratch Disks.
- In Photoshop 3.0.x, choose File > Preferences > Memory.

B. Optimize and defragment your hard drive(s) using the ScanDisk and Disk Defragmenter utilities included with Windows,  the 
Scandisk and Defrag commands included with MS-DOS 6.2x and later, or a disk optimization utility (e.g., Norton Utilities by 
Symantec Corporation). You can access these utilities in Windows by choosing Start > Programs > Accessories > System Tools. 
For instructions, refer to your Windows 95 documentation or the documentation provided with the disk optimization utility.

C. Increase the amount of virtual memory available to Windows. For instructions, see Additional Information.

D. If you are running Windows for Workgroups 3.11, deselect the 32-bit File Access option in the Windows Virtual Memory dialog 
box. (This may cause some Windows applications to run slower.):
1. Exit all applications.
2. Open the 386 Enhanced Control Panel.
3. Click Virtual Memory, then click Change.
4. Deselect Use 32-Bit File Access, then click OK.
5. Click OK to restart Windows.

OR: Upgrade to Photoshop 3.0.4.

E. Adjust the percentage of memory used by Photoshop:
1. In Photoshop, choose either File > Preferences > Memory (Photoshop 3.0.x) or File > Preferences > Memory & Image 

Cache (Photoshop 4.0.x and later).
2. In the Physical Memory Usage section, change the Used By Photoshop setting to either 75% (Windows 3.1x, Windows 95), 

or 65% (Windows NT 3.5x or later), then click OK.
3. Restart Photoshop.

F. Recreate Photoshop's preferences files:

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created in Photoshop 4.0.x, choose Save Actions from the Actions 
palette menu. In Photoshop 5.0, the actions are saved in a separate preferences file. 

1. Exit from Photoshop.
2. If you are using Photoshop 5.0, rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the 

Photoshop5\Adobe Photoshop Settings folder. For other versions, delete or rename the Photos40.psp and CColorsd files in 
the Photoshop\Prefs directory (Photoshop 4.0.x) or the Photos30.psp and CColorsd files in the Win32app\Photoshp\Prefs 
directory (Photoshop 3.0.5).

3. Start Photoshop.

Additional Information
Photoshop uses a scratch disk (i.e., temporary disk space used for storing data and performing computations) when there is insufficient 
RAM for image editing. When there is insufficient RAM and scratch disk space to perform image editing operations, Photoshop 
returns the error "Scratch disk is full." 

There can be two scratch disks in Photoshop 3.0.x and 4.0.x, and each can be up to 2 GB. Each scratch disk must be on a separate 
hard drive partition. This means in Photoshop 4.0.x and earlier if you have 5 GB free on an unpartitioned hard drive, and all scratch 
disks are assigned to it, Photoshop can use up to 2 GB of space in one scratch disk file. To use the full 4 GB, partition your hard 
drives so that there are as many partitions as there are scratch disks you want to use. In Photoshop 5.0, you can assign up to four 
partitions for scratch disk files. Although the scratch disk files still have a limit of 2 GB each, Photoshop 5.0 can write as many scratch 
disks per partition as there is free disk space. This means if you have 5 GB free on an unpartitioned hard drive, and all scratch disks 



are assigned to it, Photoshop 5.0 can use up to 5 GB of space in three scratch disk files (2 GB, 2 GB, 1 GB).

Photoshop uses the virtual memory swap file to swap parts of the application in and out of memory, but does not use virtual memory 
for image editing operations. When virtual memory is insufficient, Windows retains large portions of Photoshop in RAM, which 
reduces the amount of RAM available for image editing. Increasing virtual memory frees up RAM for image editing. When 
Photoshop's Physical Memory Usage is set to 100%, there may not be enough RAM available to Windows to perform some 
operations (e.g., printing, scanning). For some image editing operations, Photoshop requires a combined amount of available RAM 
and scratch disk space that equals 3-5 times the size of the file.

When 32-bit File Access is enabled in Windows for Workgroups 3.1.1, Photoshop 3.0, 3.0.1, and 3.0.3 may create lost clusters, 
resulting in less disk space and random errors (e.g., "Could not open/save file [filename] because of a program error"). Photoshop 
3.0.4 and later do not create lost clusters when 32-bit File Access is enabled.

A lost cluster, or file allocation unit, is a file fragment that is no longer associated with the original file. When you save a file to disk, 
the file is not always written contiguously to the hard disk. The FAT (File Allocation Table) links the end of one file fragment with the 
beginning of the next one. When the FAT loses file fragment links, the result is a lost cluster. Microsoft's Scandisk utility repairs or 
removes lost clusters.

Microsoft developed 32-bit disk and file access based on a Western Digital IDE hard drive controller, which is incompatible with many 
hard disks. Enabling 32-bit disk or file access to an incompatible hard disk will cause FAT problems, especially when Win32s is 
installed, as with Photoshop 3.0.x.

The Photoshop preferences file stores location and content information about Photoshop settings. Photoshop creates a preferences 
file during startup. When the information contained in the preferences file is damaged, Photoshop may return the error, "Scratch disk 
is full." Deleting the preferences file and restarting Photoshop forces Photoshop to create a new preferences file that contains default 
preferences settings and updated plug-in folder and file information.

To increase the amount of virtual memory available to Windows:
For Windows 95:
1. Exit all applications.
2. Make sure a startup floppy disk is available before you continue. After you change system settings, such as Virtual Memory, 

Windows may be unable to start, so you may need a startup floppy disk to start Windows. For instructions on creating a startup 
floppy disk, see Additional Information.

3. Right-click on My Computer and then choose Properties from the pop-up menu.
4. Click the Performance tab, then click Virtual Memory.
5. Select the Let Me Specify My Own Virtual Memory Settings option, then click OK.
6. From the Hard Disk pop-up menu, choose a hard disk that has at least twice the amount of your computer's installed RAM. For 

example, if your computer has 24 MB of RAM, choose a hard disk that has at least 48 MB of free hard disk space.
7. In both the Minimum and Maximum boxes, enter a value equal to twice the amount of your computer's installed RAM.
8. Click OK to close the Virtual Memory dialog box. The message, "You have chosen not to let Windows manage virtual memory 

automatically. . ." will appear in the Confirm Virtual Memory Setting dialog box.
9. If you've created a startup floppy disk, click Yes to close the Confirm Virtual Memory Settings dialog box.
10. Click Okay to close the System Properties dialog box.
11. To restart Windows, click Yes in the System Settings Change dialog box. If Windows doesn't restart, insert your startup floppy disk 

and then restart Windows.

For Windows NT 4.0:
1. Exit all applications.
2. Right-click on My Computer and then choose Properties from the pop-up menu.
3. Click the Performance tab, then click Change.
5. From the Drive list, select a hard disk that has at least twice the amount of your computer's installed RAM. For example, if your 

computer has 24 MB of RAM, select a hard disk that has at least 48 MB of free hard disk space.
7. In the Initial Size box in the Paging File Size for Selected Drive section, enter a value equal to the amount of your computer's 

installed RAM plus 12 MB. 
8. In the Maximum Size box, enter a value equal to twice the amount of your computer's installed RAM.
9. Click Set, then click OK.
10. Click OK to close the System Properties dialog box.
11. To restart Windows, click Yes in the System Settings Change dialog box. 

For Windows NT 3.51:
1. Exit all applications.
2. Open the System Control Panel.
3. Click Virtual Memory.
4. From the Drive list, select a hard disk that has at least twice the amount of your computer's installed RAM. For example, if your 

computer has 24 MB of RAM, select a hard disk that has at least 48 MB of free hard disk space.
5. In the Initial Size and Maximum Size boxes in the Paging File Size for Selected Drive section, enter a value equal to twice the 



amount of your computer's installed RAM.
6. Click Set, then click OK.
7. Click OK to close the System dialog box.
8. To restart Windows, click Yes in the System Settings Change dialog box.

For Windows 3.1x:
1. Exit all applications.
2. Open the 386 Enhanced Control Panel.
3. Click Virtual Memory, then click Change.
4. From the Type pop-up menu, choose None and then click OK.
5. Click OK to close the Virtual Memory dialog box.
6. Click Yes when Windows displays the message, "Are you sure you want to make changes to virtual-memory settings?"
7. Click Restart Windows.
8. After Windows restarts, open the 386 Enhanced Control Panel.
9. Click Virtual Memory, then click Change.
10. From the Drive pop-up menu, choose a hard disk that has at least twice the amount of your computer's installed RAM. For 

example, if your computer has 24 MB of RAM, choose a hard disk that has at least 48 MB of free hard disk space.
11. From the Type pop-up menu, choose Permanent.
12. In New Size box, enter a value equal to twice the amount of your computer's installed RAM.
13. Click Yes to close the Virtual Memory dialog box.
14. Click OK to close the Virtual Memory dialog box. Click OK if Windows displays the message, "Windows will not use more than 

the virtual memory specified by the Recommended Size. Are you sure you want to create a larger swap file?"
15. Click Restart Windows.



Adobe Customer Support Services 

Program Error in Photoshop 3.0.4 or Later in Windows 95

Issue
When you start or work in Adobe Photoshop 3.0.4 or later in Windows 95, Photoshop returns one of these errors: 

- "Could not launch Photoshop because of a program error."
- "Could not open file [filename] because of a program error." 
- "Could not save file [filename] because of a program error." 
- "Could not open [filename] because an error occurred while printing."

Solutions
Do one or more of the following:

A. Specify a different default printer:
1. Choose Start > Settings > Printers.
2. Right-click a PostScript printer other than the current default, then choose Set as Default from the pop-up menu. If a 

PostScript printer driver isn't installed, you can select a non-PostScript printer. Do not select a a non-printer device, such as 
a fax or modem. 

B. Install a PostScript printer driver (e.g., Adobe PostScript printer driver, Microsoft PostScript printer driver), then set up that printer 
as your default printer. You don't have to have a PostScript printer connected to your computer to install a PostScript printer 
driver. For more information on installing printer drivers, see your Windows documentation.

C. Remove and then reinstall the printer driver for the default printer. For instructions, see the printer driver documentation or 
contact the printer manufacturer.

D. Disable any fax software on your system.

E. Install an updated version of the printer driver for the default printer. Contact the printer driver manufacturer for availability.

F. Re-create Photoshop's preferences files:

NOTE: If you delete the preferences file, custom Preferences settings (Photoshop 5.0 and earlier) and unsaved actions 
(Photoshop 4.0.x) will be lost. To save any actions you've created, choose Save Actions from the Actions palette menu. 
Photoshop 5.0 saves the actions in a separate preferences file. 

1. Exit from Photoshop.
2. For Photoshop 5.0, rename the Adobe Photoshop 5 Prefs.psp and Color Settings.psp files in the Photoshop5\Adobe 

Photoshop Settings folder. For other versions, delete or rename the Photos40.psp and CColorsd files in the 
Photoshop\Prefs folder (Photoshop 4.0.x) or the Photos30.psp and CColorsd files in the Win32app\Photoshp\Prefs folder 
(Photoshop 3.0.5) or the Windows folder (Photoshop 3.0.4).

3. Restart Photoshop.

G. Specify a fixed Virtual Memory setting:
1. Exit from all applications.
2. Make sure that a startup disk is available before you continue. After you change system settings, such as Virtual Memory, 

Windows may be unable to start, so you may need a startup disk. For instructions on creating a startup disk, see Additional 
Information.

3. Right-click on My Computer and then choose Properties from the pop-up menu.
4. Click the Performance tab, then click Virtual Memory.
5. Select the Let Me Specify My Own Virtual Memory Settings.
6. From the Hard Disk pop-up menu, choose a hard disk that has free disk space equal to at least twice the amount of your 

computer's installed RAM. For example, if your computer has 24 MB of RAM, choose a hard disk that has at least 48 MB of 
free space.

7. In both the Minimum and Maximum boxes, enter a value equal to twice the amount of your computer's installed RAM.
8. Click OK to close the Virtual Memory dialog box. The message, "You have chosen not to let Windows manage virtual 

memory automatically . . ." will appear in the Confirm Virtual Memory Setting dialog box.
9. If you have a startup disk, click Yes to close the Confirm Virtual Memory Settings dialog box.
10. Click Okay to close the System Properties dialog box.
11. To restart Windows, click Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the startup disk 

and then restart Windows.



H. If you've specified a fixed Virtual Memory setting, re-create the Virtual Memory swap file:
1. Exit from all applications.
2. Make sure that a startup disk is available before you continue. After you change system settings, such as Virtual Memory, 

Windows may be unable to start, so you may need a startup disk. For instructions on creating a startup disk, see Additional 
Information.

3. Right-click on My Computer, then choose Properties from the pop-up menu.
4. Click the Performance tab, then click Virtual Memory.
5. Select the "Let Windows Manage My Virtual Memory Settings (Recommended)" option, then click OK.
6. Click Yes in the Confirm Virtual Memory Settings dialog box.
7. Click Okay to close the System Properties dialog box.
8. Click Yes in the System Settings Change to restart the computer.
9. Right-click on My Computer, then choose Properties from the pop-up menu.
10. Click the Performance tab, then click Virtual Memory.
11. Select the Let Me Specify My Own Virtual Memory Settings.
12. From the Hard Disk pop-up menu, choose a hard disk that has free disk space equal to at least twice the amount of your 

computer's installed RAM. For example, if your computer has 24 MB of RAM, choose a hard disk that has at least 48 MB of 
free space.

13. In both the Minimum and Maximum boxes, enter a value equal to twice the amount of your computer's installed RAM.
14. Click OK to close the Virtual Memory dialog box. The message, "You have chosen not to let Windows manage virtual 

memory automatically . . ." will appear in the Confirm Virtual Memory Setting dialog box.
15. If you have a startup disk, click Yes to close the Confirm Virtual Memory Settings dialog box.
16. Close the System Properties dialog box.
17. To restart Windows, click Yes in the System Settings Change dialog box. If Windows doesn't restart, insert the startup disk 

and then restart Windows.

Additional Information
When Photoshop starts, or when it acquires, opens, saves, or creates a file, it checks the default printer driver for information about 
that printer (e.g., page size, margins, imageable area). When Photoshop can't interpret this information it returns a program error. 
Photoshop may be unable to interpret the information if the printer driver is damaged or incompatible with Windows 95, or if the 
driver is for a non-printer device (e.g., fax) or a non-PostScript printer (e.g., PCL). 

Also when Photoshop starts, it reads its own preferences files to load customizable settings (e.g., palette placement, brush sizes). 
When the preferences files are damaged, Photoshop can't read them and returns a program error. If you rename the preferences files 
and then start Photoshop, Photoshop creates new preferences files containing its default settings.

By default, Windows 95 manages virtual memory dynamically -- it uses as much or as little hard disk space as needed. Photoshop 
may return a program error if the swap file (i.e., the hard drive space Windows 95 uses for virtual memory) is damaged. Adobe 
recommends using Photoshop with a fixed amount of virtual memory. When you specify a fixed virtual memory setting or re-create 
the swap file, program errors in Photoshop are less likely to occur. For more information about the swap file, refer to Windows 95 
on-line Help or your Windows documentation.

After you change virtual memory settings, Windows will display the message, "You have chosen not to let Windows manage virtual 
memory automatically. You may not be able to restart your computer, or system performance may be degraded. Do not continue if 
you are unsure whether you need to do this. Are you sure you want to continue?" This message refers to the unlikely possibility that 
Windows won't be able to change or create a virtual memory file. This could happen if there is not enough space available on the 
designated hard drive; if Windows is damaged; if the hard drive is damaged, severely fragmented, or has unmapped bad blocks; or if 
the device driver for your hard drive is outdated. 

You can avoid problems by making sure that the hard drive designated for virtual memory has enough space: You can remove 
unnecessary temporary (*.tmp) files and move personal data files to another location (e.g., another hard drive or a removable drive). 
In addition, you can use utilities that come with Windows to free up hard drive space and maintain your hard drive: Scandisk (with a 
surface scan) will remove lost file fragments; Disk Defragmenter will optimize the available space on the hard drive. To access these 
programs, choose Start > Programs > Accessories > System Tools. See your Windows documentation for more information on 
Scandisk and Disk Defragmenter.

If you have a SCSI hard drive, the version of the driver for the SCSI adapter card might need to be updated or might be incompatible 
with Windows virtual memory. Contact the manufacturer of the SCSI adapter card for updates or further information.

To create a startup disk:
1. Choose Start > Settings > Control Panel.
2. Double-click the Add/Remove Programs Control Panel.
3. Click the Startup Disk tab.
4. Follow the on-screen instructions.
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Installing ImageStyler, ImageReady, or Photoshop in Windows 95 Safe Mode

Software that loads automatically in Windows (e.g., screen savers, device drivers, terminate-and-stay-resident [TSR] programs, virus 
protection utilities) can conflict with Adobe ImageStyler, Adobe ImageReady, or Adobe Photoshop's installer application and cause 
errors. Starting Windows in Safe Mode temporarily disables conflicting software and device drivers, decreasing installer errors.

After you install the application successfully, restart Windows in Normal mode. ImageStyler, ImageReady, and Photoshop will not run 
in Safe Mode. For more information about Windows 95's startup modes, contact Microsoft Technical Support.

Installing ImageStyler, ImageReady, or Photoshop From CD-ROM
To install ImageStyler, ImageReady, or Photoshop from the CD-ROM when running Windows in Safe Mode, copy the installer files 
from the CD to your hard disk, restart Windows in Safe Mode, then start the installer application:

NOTE: Because Windows loads only the mouse, keyboard, and standard VGA device drivers in Safe Mode, you cannot access your 
CD-ROM while in Safe Mode.

1. If you are reinstalling ImageStyler, ImageReady, or Photoshop, move any personal files (e.g., images, third-party plug-ins) out of 
the ImageStyler, ImageReady, or Photoshop folder and its subfolders. Then, choose Start > Settings > Control Panel, 
double-click Add\Remove Programs, select Adobe ImageStyler, Adobe ImageReady, or Adobe Photoshop, and then click 
Add/Remove. 

2. Insert the CD into the CD-ROM drive.
3. Exit from all applications, then choose Start > Programs > Windows Explorer.
4. In Explorer, double-click the CD-ROM drive to open it.
5. Locate the ImageStyler, ImageReady, or Photoshop directory and copy it to your hard drive.

NOTE: If an error occurs when copying files from the CD to the hard drive, the CD may be dirty or damaged, or there may be a 
problem with the  CD-ROM drive. Clean the CD and caddy with a soft, lint-free cloth to ensure that they are free of dust and 
fingerprints. Try copying files from other CDs to your hard drive to ensure that the CD-ROM drive is working. If you cannot copy 
files from other CDs, contact your CD-ROM drive's manufacturer or the computer's manufacturer. If you can copy files from other 
CDs, but not the ImageStyler, ImageReady, or Photoshop CD, contact Adobe Technical Support.

6. Exit from Explorer.
7. Choose Start > Shut Down > Restart the Computer.
8. When you see "Starting Windows 95 . . . ," press the F5 key.
9. Click OK in the Desktop dialog box indicating that Windows 95 is running in Safe Mode. If Windows does not display the words 

"Safe Mode" in each corner of the Desktop, repeat steps 6 and 7.
10. Double-click the Setup program (e.g., Setup.exe or Imageready.exe) in the ImageStyler, ImageReady, or Photoshop folder on 

your hard drive to install the application.
11. Restart Windows in Normal mode.

Installing Photoshop 4.0.x or Earlier from Disks
To install Photoshop 4.0.x or earlier from disks when Windows is running in Safe Mode:
1. Choose Start > Shut Down > Restart the Computer.
2. When you see "Starting Windows 95 . . . ," press the F5 key.
3. Click OK in the Desktop dialog box indicating that Windows 95 is running in Safe Mode. If Windows does not display the words 

"Safe Mode" in each corner of the Desktop, repeat steps 1 and 2.
4. Insert Disk 1, then start the installer application (Setup.exe) to install Photoshop.
5. Restart Windows in Normal mode.
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Exporting Images with Spot Colors as DCS 2.0 from Photoshop 5.0

What's Covered 
Saving Your Images as Photoshop DCS 2.0
Using Photoshop DCS images with Other Applications

In Adobe Photoshop 5.0, you can save images in the DCS 2.0 file format, which supports Spot Color channels in CMYK, 
Multichannel, and Grayscale modes. A DCS 2.0 image can include up to twenty-four color channels (e.g., CMYK and three spot 
colors), which you can create using Photoshop's Channels palette.

When saving DCS 2.0 images from Photoshop 5.0, you have many preview and file options to choose from. Choosing the appropriate 
options ensures your images will display and print correctly. To determine which options to choose, it is important to know the 
requirements of the application into which you'll be placing your DCS 2.0 image. See Using Photoshop DCS images with Other 
Applications for more information.  

Saving Your Images as Photoshop DCS 2.0
If you have created spot color channels in your Photoshop 5.0 image and you want those spot colors to be available in, and to color 
separate from, a page-layout application, you need to save the image in Photoshop DCS 2.0 format. 

NOTE: When you use spot colors, you might need to create knockouts and traps if you will be printing your image on a press. For 
more information see your Adobe Photoshop 5.0 User Guide.

To save an image in Photoshop DCS 2.0 format:
1. Choose File > Preferences > General and make sure Short PANTONE Names is selected. Using short PANTONE names ensures 

the names of spot colors you create in Photoshop match those in other applications.
2. Make sure your image is flattened in the Layers palette. A flattened image contains only one layer named "Background" (in 

italics). If the image is not flattened, choose Layer > Flatten Image.
3. Make sure your image is in a color mode that supports the Photoshop DCS 2.0 file format (i.e., CMYK Color, Multichannel, or 

Grayscale). If the image is not in one of these modes, choose Image > Mode > [Mode].

NOTE: If your image contains CMYK process colors and one or more spot colors, choose CMYK Color. If your grayscale or color 
image does not contain process colors, choose Multichannel to decrease file size and print time of large images (e.g., 30 MB or 
larger).

4. Choose File > Save As.
5. Choose Photoshop DCS 2.0 from the Format pop-up menu, specify the name and location of the image, then click Save.
6. From the Preview, DCS, and Encoding pop-up menus, choose the options that are appropriate for the application into which 

you will be placing the DCS 2.0 image (see Using Photoshop DCS images with Other Applications below). Click OK in the DCS 
2.0 Format dialog box.

Using Photoshop DCS images with Other Applications
Listed below are the graphic applications most commonly used for printing Photoshop images. If the application you want to use is 
not listed, check its User Guide to determine how to use DCS 2.0 images with it.

Adobe Illustrator
Illustrator 8.0 is optimized to work with DCS 2.0 files saved with Multiple-File with Color Composite chosen from the DCS pop-up 
menu of the DCS 2.0 format dialog box. 

Illustrator 7.0 and earlier do not support Photoshop DCS 1.0 or  2.0 images. To use a DCS image with elements created in Illustrator, 
you will need to combine the Illustrator file with the DCS file in a page-layout application such as Adobe PageMaker.

MacroMedia Freehand
For a Photoshop DCS 2.0 image to print correctly from Freehand 8.0, you must save it from Photoshop 5.0 with a multiple-file option 
chosen in the DCS pop-up menu of the DCS 2.0 format dialog box. If you import a single-file Photoshop DCS 2.0 image into 
Freehand, the link to the high-resolution separation data will be lost and only the low-resolution preview will print.

Adobe PageMaker
PageMaker 6.5x and earlier display and print only multiple-file DCS 2.0 images saved with specific previews correctly. For 
information on which preview options to choose, see document 320965 . 

QuarkXPress

If you will be importing the DCS image into a QuarkXPress 4.0 or earlier document, save the Photoshop DCS 2.0 image with a 
multiple-file option chosen in the DCS pop-up menu and with any preview option chosen from the Preview pop-up menu in the DCS 
2.0 Format dialog box.



Adobe Customer Support Services 

Creating a Tint of Spot Color in Photoshop 5.0

The Solidity setting in the Spot Channel Options dialog box of Adobe Photoshop 5.0 controls the opacity for the on-screen preview 
of spot colors. It does not affect the printed tint of the spot color, however.  For the screen preview of the spot color to correctly reflect 
the printed tint, the Solidity setting must be 100%, even if you want a tint of less than 100% for the printed spot color.

Creating Spot Color Tint that Matches On-Screen and In Print
To create a tint of a spot color channel so the on-screen preview and printed colors match:
1. Double-click the spot channel in the Channels palette.
2. Enter 100 in the Solidity text-box, and click OK in the Spot Channel Options dialog box.
3. Select the portion of the spot color channel to tint. For more information see Chapter 7: Selecting, pages 137-164 in the 

Photoshop 5.0 User Guide.
4. Choose Edit >Clear.
5. Select Edit > Fill.
6. Choose Black from the Use pop-up menu, enter your tint percentage in the Opacity text box, and choose Normal from the Mode 

pop-up menu. Click OK.
7. Repeat steps 3-6, as necessary, to create a different tint for other portions of the spot color channel.
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Photoshop 4.0.x Installer's AutoPlay Screen Appears While Installing Photoshop 5.0 in Windows 98 
and Windows NT 4.0

Issue
After you insert the Adobe Photoshop 4.0 CD-ROM in the drive during the Photoshop 5.0 upgrade installer's verification process, 
Photoshop 4.0.x's AutoPlay screen appears. 

Solution
Click Quit to the Desktop in the AutoPlay screen to return to the Photoshop 5.0 installation process. 

Additional Information
Photoshop 5.0's upgrade installer searches your CD-ROM drive, hard drive, or diskette drive for a previous version of Photoshop, and 
if it locates one, it will automatically continue the installation process. If you do not have a previous version of Photoshop on your 
hard drive, the Photoshop 5.0 upgrade installer prompts you to insert either a CD-ROM or diskettes for verification. 

The AutoPlay screen (i.e., the screen that says, "Adobe Photoshop 4.0, please make a selection") is set to run each time you insert 
the Photoshop 4.0.x CD-ROM into the drive. The Photoshop 5.0 upgrade installer disables the AutoPlay screen in Windows 95; 
however, it does not disable the AutoPlay screen in Windows 98 or Windows NT 4.0.  

The installers in Photoshop 3.0.x and earlier do not have an AutoPlay screen.
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Dot Gain Option in Photoshop 5.0.x

What's Covered
Importing Your Photoshop 4.0.x Settings into Photoshop 5.0.x
Manually Entering Values Using a Dot Gain Conversion Chart
Setting Dot Gain Using Curves
Using Dot Gain When Converting Images to Grayscale

Dot gain is the increase of the density of halftone dots as ink is absorbed by paper. It occurs in varying degrees depending on the 
paper stock and other environmental factors, and can cause over-saturation of printed inks.  

The dot gain algorithm of Adobe Photoshop 5.0.x was improved over that of Photoshop 4.0.x and earlier to more accurately 
represent the correct dot gain. For example, if you use a 15% dot gain value in Photoshop 4.0.x, use a 5% dot gain value in 
Photoshop 5.0.x. 

Some dot gain always occurs on-press, but you can compensate for it if you know how much to expect. Ask your printer how much dot 
gain to anticipate. For more information about discussing this and other settings with your printer, see document 314707 , "Preparing 
Photoshop Files for Print Separations."

Importing Your Photoshop 4.0.x Settings into Photoshop 5.0.x
To use your Photoshop 4.0.x dot gain settings in Photoshop 5.0.x:
1. Start Photoshop 4.0.x. 
2. Choose File > Color Settings > Printing Inks Setup.
3. Click Save. Name the file with the extension ".API" and click Save.
4. Click OK to exit from the Printing Inks Setup dialog box.
5. Exit from Photoshop 4.0.x and start Photoshop 5.0.x
6. Choose File > Color Settings > CMYK Setup and select Built-In.
7. Click Load, select the file you saved and click Open (Mac OS) or Load (Windows).
8. Click OK in the CMYK Setup dialog box.

Manually Entering Values Using a Dot Gain Conversion Chart
To manually enter dot gain values in Photoshop 5.0.x based on settings from Photoshop 4.0.x:
1. Start Photoshop 4.0.x.
2. Choose File > Color Settings > Printing Ink Setup and note the number in the Dot Gain field.
3. Find the corresponding Photoshop 5.0.x value in the chart below.
4. Exit from Photoshop 4.0.x and start Photoshop 5.0.x.
5. Choose File > Color Settings > CMYK Setup and select Built-In.
6. Choose Standard from the Dot Gain pop-up menu, then enter the percentage that corresponds with your Photoshop 4.0.x dot 

gain settings. 
7. Click OK in the CMYK setup dialog box.

Photoshop 4.0.x Dot Gain Photoshop 5.0.x Dot Gain Photoshop 4.0.x Dot Gain Photoshop 5.0.x Dot Gain
-10 -10 16 6

-8 -10 18 9

-6 -10 20 12

-4 -10 22 15

-2 -10 24 18

0 -10 26 21

2 -9 28 25

4 -7 30 29

6 -5 32 32

8 -3 34 36

10 -1 36 40

12 1 38 40

14 4 40 40

Setting Dot Gain Using Curves
In Photoshop 5.0.x, you can set calibrated dot gain settings for each of the four colors as well as adjust any point on the scale: 



1. Choose File > Color Settings > CMYK Setup and select Built-In.
2. Choose Standard from the Dot Gain pop-up menu. In the Curves dialog box, edit the curves by hand or by entering numbers. 

You can also use one curve for all for colors by selecting All Same. 
4. Click OK in the Curves dialog box.
5. Click OK in the CMYK Setup dialog box.

Using Dot Gain When Converting Images to Grayscale
In Photoshop 5.0.x, you can use dot gain settings when converting images to grayscale by choosing File > Color Settings > Grayscale 
Setup and select Black Ink; the default RGB option does not use the dot gain settings. The Black Ink option is equivalent to 
Photoshop 4.0.x's Use Dot Gain for Grayscale Images option, and uses the dot gain settings specified in the CMYK Setup dialog box.
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Error "Not Enough Disk Space On Target Drive..." When Installing Photoshop 5.0 in Windows

Issue
The Adobe Photoshop 5.0 installer returns the error, "Not Enough Disk Space On Target Drive while decompressing to [pathname]" 
when you install Photoshop in Windows 95,  Windows 98, or Windows NT 4.0.

Solutions
Do one or more of the following:

Note: When the Photoshop 5.0 installation is interrupted, such as when you receive the error above, the installer may leave 
temporary files on the hard drive. To troubleshoot the error above, you may need to repeat several of the procedures to remove these 
files, as well as any of the Photoshop application files that were installed.

Solution 1
Ensure you have read/write access to the target drive, delete temporary files, then uninstall and reinstall Photoshop:

1. Make sure you have read/write access to the drive on which you want to install Photoshop. Note that some network drives may 

have specific read/write permissions; check with you network administrator if you are installing to a network.
2. Delete temporary files. For instructions, see Additional Information.
3. Uninstall previous installs of Photoshop 5.0. For instructions, see Additional Information.
4. Install Photoshop.

Solution 2
If you are using Windows 95 or Windows 98, delete temporary files, uninstall Photoshop, copy the installer files from the CD to your 
hard disk, restart Windows in Safe Mode, then install Photoshop:
1. Delete temporary files. For instructions, see Additional Information.
2. Delete previous installs of Photoshop 5.0. For instructions, see Additional Information.
3. Insert the Photoshop Application CD into the CD-ROM drive.
4. Exit from all applications, then choose Start > Programs > Windows Explorer.
5. In Explorer, double-click the CD-ROM drive to open it.
6. Locate the Photoshop directory and copy it to your hard disk.

Note: If an error occurs when copying files from the CD to the hard disk, the CD may be dusty, damaged, or you may have a 
problem with your CD-ROM drive. Clean the CD and caddy with a soft, lint-free cloth to ensure that they are free of dust and 
fingerprints. Try copying files from other CDs to your hard disk to ensure your CD-ROM drive is working properly. If you cannot 
copy files from other CDs, contact your CD-ROM drive's manufacturer or the computer's manufacturer. If you can copy files from 
other CDs, but not the Photoshop CD, contact Adobe Technical Support.

7. Exit from Explorer.
8. Choose Start > Shut Down > Restart the Computer.
9. When you see the message, "Starting Windows 95. . ." or "Starting Windows 98. . .," press the F5 key.
10. Click OK in the Desktop dialog box indicating that Windows is running in Safe Mode. If you do not see the words "Safe Mode" in 

each corner of the Desktop, repeat steps 6 and 7.
11. Double-click the Setup.exe file in the Photoshop folder on your hard disk. Follow the prompts to complete the installation.
12. Restart Windows in Normal mode.

Solution 3
Delete temporary files, uninstall Photoshop, backup and edit the registry, and then reinstall Photoshop:

Disclaimer: The Windows Registry contains information that is critical to your computer and applications. Adobe does not provide 
support for problems that arise from improper modification of the Windows Registry. Experience editing system files is highly 
recommended. Make sure to back up the registry before modifying it. For more information on the Windows Registry Editor, refer to 
your Windows User Guide or contact Microsoft Technical Support.

1. Delete temporary files. For instructions, see Additional Information.
2. Delete previous installs of Photoshop 5.0. For instructions, see Additional Information.
3. Exit from all applications.
4. Choose Start > Run. Type "regedit" in the Open text box and click OK.
5. Choose Registry > Export Registry File. Choose a location and name for the backup file, and then click Save in the Export 

Registry File dialog box.
6. Select the HKey_Local_Machine\Software\Microsoft\Windows\CurrentVersion key in the left side of the Registry Editor window.



Note: Make sure to select the Windows key, regardless of the operating system you are using.

7. Double-click CommonFilesDir in the right side of the Registry Editor window. 
8. Ensure the Value Data text box reads "X:\Program Files\Common Files" (where X designates the startup disk) and click OK in the 

Edit String dialog box.
9. Double-click ProgramFilesDir in the right side of the Registry Editor window.
10. Ensure the Value Data text box reads "X:\Program Files" (where X designates the startup disk) and click OK in the Edit String 

dialog box.
11. Select the HKey_Local_Machine\Software\Kodak key in the left side of the Registry Editor window.
12. Choose Edit > Delete.
13. Choose Registry >Exit.
14. Install Photoshop.

Solution 4
Delete temporary files, uninstall Photoshop, backup and edit the registry, and then perform a custom install of Photoshop:
1. Delete temporary files. For instructions, see Additional Information.
2. Delete previous installs of Photoshop 5.0. For instructions, see Additional Information.
3. Do steps 1 - 11 in solution 3 to ensure that the registry has the correct settings.
4. Double-click Setup.exe in the Photoshop directory on the Application CD.
5. Click Next in the Welcome dialog box. Click Next in the Select Country dialog box. Click Accept in the Software License 

Agreement dialog box.
6. Select Custom and then click Next in the Set Up dialog box. 
7. Deselect Adobe Online and Cmap Files and then click Next in the Select Components dialog box.

Note:  Adobe Online enables you to go to the Adobe Web site by clicking on Photoshop's tool bar. When the Adobe Online 
files aren't installed, you cannot access Adobe's Web site directly from Photoshop. The Cmap files enable you to use foreign 
language fonts in Photoshop. 

8. Click Next in the Start Copying Files dialog box. Allow the installation to complete.
9. Deselect Display Photoshop ReadMe file and click Finish in the Setup Complete dialog box. Click OK in the Adobe Photoshop 

5.0 Setup dialog box.

Solution 5
Reinstall Windows to a new folder, copy the installer files from the CD to your hard disk, restart Windows in Safe Mode (Windows 95 
and Windows 98) or VGA Mode (Windows NT 4.0), and then install Photoshop 5. 

Note: For instructions on reinstalling Windows 95 to a new folder, see the Microsoft Knowledge Base article Q142096 at 
http://support.microsoft.com/support/kb/articles/q142/0/96.asp. Reinstalling Windows 95 or Windows NT into a new directory first can 
save you time because you can keep your data files on the hard drive, and you don't need to reformat your drive. For help installing 
Photoshop in Safe Mode or VGA Mode, see Related Records.

Additional Information
When you install Photoshop, it decompresses its installation files and creates temporary files on your hard drive. At the end of the 
installation process, the installer deletes the temporary files. When the Photoshop installation process is interrupted (e.g., there is not 
enough room on the hard drive to decompress files), the installer doesn't delete the temporary files. Because these files can interfere 
with the Photoshop installation process, you should delete them before running the installer again. Similarly, removing any installed 
Photoshop files creates room on the hard drive and allows the installer to write new files without overwriting any potentially damaged 
old files. 

Other variables that can interfere with the Photoshop installer include software that loads automatically in Windows, such as screen 
savers, device drivers, terminate-and-stay-resident (TSR) programs, and virus protection utilities. Starting Windows in Safe Mode 
temporarily disables conflicting software and device drivers, decreasing installer errors. The Photoshop installation process can also 
be interrupted when the installer writes to the Windows registry. The Photoshop installer queries the Windows registry for the location 
of the Common Files and Program Files directories and Kodak's Kpcms.ini file. When the registry contains incorrect information, the 
installer returns an error because it cannot locate a directory or .ini file. 

Deleting Temporary Files
To delete temporary files:
1. Choose Start > Find > Files or Folders. 
2. In the Named text box, type "*.tmp".
3. Choose Local Hard Drives from the Look In pop-up menu.
4. Click Find Now. 
5. When the search results appear, choose Edit > Select All.
6. Choose File > Delete. Click Yes when you are asked if you want to send all the files to the Recycle Bin. 



7. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the Recycle 
Bin.

Deleting Previous Installations of Photoshop
To delete previous installations of Photoshop:

1. Navigate to, and select the Photoshop 5.0 folder (e.g., x:\Program Files\Adobe\Photoshop 5.0 folder and then choose File > 
Delete (where "x" is the Photoshop installation drive)), then choose File > Delete.

2. Click Yes in the Confirm Folder Delete dialog box.
3. Select the x:\ProgramFiles\CommonFiles\ Adobe folder and choose File > Delete (where x is the startup drive).
4. Check the Recycle Bin for any non-temporary files you do not want to delete, and remove them if desired. Empty the Recycle 

Bin.
5. Click Yes in the Confirm Folder Delete dialog box.
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Error "Could Not Initialize Photoshop Because of a Disk Error" Troubleshooting Guide

Issue
When you start Adobe Photoshop 2.0 or later for Mac OS, the system returns one of the following errors:

"Could not initialize Photoshop because of a disk error."

"Could not initialize Photoshop due to a disk error." 

"Could not initialize Photoshop because the file has been damaged by a disk error."

Solutions
Do one or more of the following:
A. Recreate the Photoshop preferences file:

NOTE: If you delete the preferences file, custom Preferences settings and unsaved actions in Photoshop 4.0.x will be lost. To 
save any actions you've created, choose Save Actions from the Actions palette menu. Photoshop 5.0 saves actions in a separate 
preferences file. 

1. Quit Photoshop.
2. Rename the Photoshop preferences file:

Photoshop Version Filename Location
Photoshop 5.0 Adobe Photoshop 5.0 Prefs Adobe Photoshop 5.0:Adobe Photoshop Settings
Photoshop 4.0.x Adobe Photoshop 4.0 Prefs System Folder:Preferences 
Photoshop 3.0.x Adobe Photoshop 3.0 Prefs System Folder:Preferences 
Photoshop 3.0.x LE Adobe Photoshop LE Prefs System Folder:Preferences 
Photoshop 2.5.x Photoshop Prefs System Folder:Preferences 
Photoshop 2.5.x LE Photoshop LE Prefs System Folder:Preferences 
Photoshop 2.0 PS Prefs Photoshop plug-ins (default location)

3. Restart Photoshop.

B. Use a disk utility (e.g., Apple Disk First Aid, Norton Disk Doctor) to locate and repair media problems (e.g., bad sectors, damaged 
directory information) on the hard drive containing Photoshop and the system software, and other volumes designated as a 
Photoshop scratch disk.

C. Run Photoshop with all extensions off to verify an extension conflict is not the cause. To turn all extensions off upon startup in 
System 7.0.x or later, restart the computer with the Shift key held down until the message "Welcome to Macintosh. Extensions 
Off." appears. This will also disable any virtual memory or RAM compression software (e.g., RAM Doubler).

NOTE: Non-Apple keyboards may have a different method for restarting the Macintosh with Extensions off. For information on 
the proper method to start without extensions, contact your keyboard manufacturer. 

If the error does not reoccur with extensions disabled, troubleshoot extension conflicts. For instructions, see document 314385 , 
"Disabling Extensions and Isolating Extension Conflicts in System 7.x," or document 311687 , "Disabling Extensions and 
Isolating Extension Conflicts in Mac OS 8.0.x."

Holding the shift key down at startup disables most, but not all system extensions. If the error occurs again after you restart with 
the Shift key held down, take the following additional steps to manually remove all system extensions (and other software that 
loads at startup) from your System Folder:
1. Move the Control Panels, Extensions, Fonts, and Preferences folders from the System Folder to a new location (e.g., the 

desktop).
2. If you are using System 7.x, skip to step 4. If you are using Mac OS 8.0.x, create a new folder, name it "Extensions," then 

move it into the System Folder.
3. Move the Appearance extension from the old Extensions folder into the Extensions folder you created in step 2. Mac OS 

8.0.x requires the Appearance extension to start the Macintosh. If the Appearance extension isn't installed in the System 
Folder:Extensions folder, the system returns the following error:

"The Finder could not start up because the following system library could not be found: AppearanceLib. To start up, use 
the CD or floppy disks that came with your computer. To start up from a CD, hold the "C" key while starting up, or consult 



the User's Guide that came with your computer."

If the system returns this error, you must start your Macintosh using a startup disk (e.g., Mac OS 8 CD-ROM, Disk Tools).

4. Restart the Macintosh and try to re-create the error. 

Additional Information
The Photoshop preferences file stores location and content information about a variety of Photoshop settings. Photoshop creates a 
preferences file during startup. When the information contained in the preferences file is damaged, when there are media problems 
on the hard disk(s), or when there is an extensions conflict,  the system returns the error, "Could not initialize Photoshop because of a 
disk error."
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Error "Could not personalize your copy of Adobe Photoshop..." When Starting Photoshop 5.0 for 
Mac OS

Issue
When starting, Adobe Photoshop 5.0 returns the message, "Could not personalize your copy of Adobe Photoshop because of missing 
or invalid personalization information."

Solutions
Do one or more of the following:

Solution 1
Make sure you are entering the serial number exactly as it appears on your registration card:
- Use the correct characters. For example, be sure to differentiate between the number zero and the upper-case letter "O," or the 

number one and the lower-case letter "L."
- Use the numbers above the letters on the keyboard, rather than using the numeric keypad.
- Make sure the Caps Lock key is off. 
- Make sure the number is complete and formatted correctly. The number should end with a hyphen followed by three digits and 

should contain no spaces (e.g., PSW123R1234567-123). 
- Make sure there are no spaces before or after the serial number by highlighting the number in the Serial Number text box with 

the mouse or the Tab key and then reentering the number.

Solution 2
Rename the Adobe registration database file, then remove and reinstall Photoshop:
1. Rename Adobe Registration Database file, which is in the System Folder:Preferences folder.
2. Delete the Photoshop folder.
3. Perform a typical install of Photoshop.
4. Start Photoshop.

Solution 3
Perform a clean install of the system software, then remove, reinstall, and restart Photoshop. For more information on performing a 
clean install, see document 314980 . 

Additional Information
Like other Adobe product installers, the Photoshop installer creates the Adobe Registration Database file in which it records customer 
information you entered during installation. Adobe product installers can access some of your customer information in this file so you 
don't have to reenter it when you install other Adobe products or reinstall Photoshop. This file can become damaged, which prevents 
Photoshop from starting. These errors can also result from damaged system software.
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Exclude Non-Image Data Option in Photoshop 5.0.x

Adobe Photoshop 5.0.x's Save a Copy dialog box includes an Exclude Non-Image Data option, so that the file size of images you 
don't intend to print will not be unnecessarily large. Web or video applications do not need the data that this option excludes, as 
printers, page layout applications, and service bureaus do. When this option is selected, Photoshop excludes the following data from 
the file:

- The names of alpha channels, including spot channels. Instead, Photoshop renames these channels "Alpha 1," "Alpha 2," etc., 
in the order they were created.

- Any added duotone information. If Exclude Non-Image Data is selected when you save a copy of a duotone image, the copy 
will include only the original grayscale image (i.e, before conversion to Duotone mode). 

- Photoshop-specifc page setup information, such as custom transfer functions and halftone screens.
- Paths, including clipping paths
- Image previews, including thumbnail and EPS previews.
- Guides and grids.
- ICC profiles.
- File information, such as captions.
- Resolution information (when saving in native Photoshop format only). While Photoshop does exclude resolution information, n

o image data is lost -- the image's resolution will be 72 ppi and the print size will change accordingly, but the pixel dimensions 
will remain constant.
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Photoshop Files Change Colors When Imported into Premiere or After Effects

Issue
Adobe Photoshop 5.0 images are brighter or change color when imported into Adobe Premiere or Adobe After Effects.

Solution
In Photoshop, specify that color management information is excluded from the file, then resave the file.
1. Open the image file in Photoshop 5.0 and choose File > Color Settings > RGB Setup.
2. Choose Monitor RGB from the RGB pop-up menu.
3. Deselect (uncheck) Display Using Monitor Compensation, then click OK.
4. Choose File > Color Settings > Profile Setup.
5. In the Assumed Profiles section, choose None from the RGB pop-up menu, then click OK.
6. Save the file and then import it into After Effects or Premiere.

Additional Information
Premiere and After Effects use the Monitor RGB color space to display images, and ignore any color management information. 
Therefore, these applications don't use the color management information that may be present in a Photoshop file. Since Premiere 
and After Effects don't use the color management information to display an image, the image's colors may not look the same as it 
does in Photoshop. Setting Photoshop's color space to Monitor RGB and setting the profile to None excludes all the color 
management information in the image file.
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Using Photoshop 4.0.x's Setup for CMYK Workflow in Photoshop 5.0

What's Covered
Loading Photoshop 4.0.x CMYK Settings into Photoshop 5.0
Loading and Customizing Photoshop 4.0.x CMYK Settings into Photoshop 5.0

Adobe Photoshop 5.0 uses updated algorithms and ICC profiles to produce accurate, predictable color. For those who have become 
accustomed to the way Photoshop 4.0.x produces CMYK color, however, Photoshop 5.0 also lets you load and use Photoshop 4.0.x's 
CMYK color conversion settings. Using these settings in Photoshop 5.0 enables you to closely match the way Photoshop 4.0.x 
produces CMYK color.

This document provides two ways to load your Photoshop 4.0.x settings into Photoshop 5.0. The first section contains the simplest 
method and the second section contains the method that offers the greatest color accuracy.

Loading Photoshop 4.0.x CMYK Settings into Photoshop 5.0
This procedure is divided into three sections. The first section is the simplest method for loading your Photoshop 4.0.x settings into 
Photoshop 5.0. If you choose to use this procedure, you must perform the steps in the first section. The steps in the second and third 
sections are optional, and whether you should use them depends on your color-management needs.

The steps in first section enable you to match the CMYK conversion behavior of Photoshop 4.0.x without changing your Photoshop 
5.0 CMYK settings. The steps in the second section let you use the full range of color management options available in Photoshop 
5.0. The steps in the third section enable you to use your Photoshop 4.0.x ICC profile as the assumed profile when opening images 
in Photoshop 5.0.  

NOTE: Photoshop 4.0.x's method of converting an image to CMYK mode is not as robust as those methods possible with Photoshop 
5.0's color management. By loading the settings used in Photoshop 4.0.x, you will be unable to specify any unidentified ICC profiles 
used to create an image when you open the image in Photoshop 5.0.

To load Photoshop 4.0.x CMYK Settings into Photoshop 5.0:
1. Start Photoshop 4.0.x.
2. Choose File > Color Settings > Separation Tables.
3. Click Save in the Separation Tables dialog box. 
4. Name the file with a ".ast" extension, choose your desktop folder, then click Save in the Save dialog box.
5. Click OK in the Separation Tables dialog box.
6. Quit Photoshop 4.0.x.
7. Start Photoshop 5.0.
8. Choose File > Color Settings > CMYK Setup.
9. Select Tables for the option labeled, "CMYK Model" and click Load.
10. Choose Separation Tables (*.AST) from the Files of Type pop-up menu, select the file you saved in steps 3-4, then click Load.
11. Click OK in the CMYK Setup dialog box. You are now configured to use the CMYK conversion method and settings found in 

Photoshop 4.0.x. 

To take advantage of the color management features in Photoshop 5.0 (e.g., device-independent color, ICC profile usage.) using the 
same settings you had in Photoshop 4.0.x:
12. Choose File > Color Settings > CMYK Settings, then click Save.  
13. Navigate to the folder containing your ICC profiles:

- In Windows 95 and Windows 98, navigate to the Windows\System\Color folder.
- In Windows NT 4.0, navigate to the WinNT4\System32\Color folder.
- In Mac OS, navigate to the System Folder:Color Sync Profiles (for ColorSync 2.5) or the System Folder:Preferences: Color 

Sync Profiles (ColorSync 2.1.2 and earlier).

14. Give the file a name that designates it as your Photoshop 4.0.x settings and has a ".icm" extension (e.g., "ps4set.icm"), then 
click Save.

15. Click OK in the CMYK Setup dialog box.
16. Restart Photoshop 5.0.
17. Choose File > Color Settings > CMYK Setup.
18. Select ICC for the option labeled, "CMYK Model." 
18. Click OK to the message, "Discard CMYK tables?"
20 Choose the profile you saved in step 14 from the Profile pop-up menu.
21. Click OK in the CMYK Setup dialog box.
22. In Windows Explorer (Windows 95 and Windows 98) or Windows NT Explorer (Windows NT 4.0), delete the .ast file you saved in 

steps 3-4.



If you'll be opening images saved from Photoshop 4.0.x, then you should set your Photoshop 4.0.x ICC profile as your assumed 
profile in the Profile Setup dialog box. To set your Photoshop 4.0.x profile as your assumed profile:
23. Choose File > Color Settings > Profile Setup.
24. In the Assumed Profiles section, choose the ICC profile saved in step 14 from the CMYK pop-up menu.
25. In the Profile Mismatch Handling section, choose Convert to CMYK Color from the CMYK pop-up menu, then click OK.

Loading Photoshop 4.0 CMYK Settings and Customizing Photoshop 5.0
The procedure in this section provides the most flexibility and options for customization of your Photoshop 4.0.x settings in 
Photoshop 5.0. Because this procedure enables you to make changes to the built-in printing inks and separation settings in the CMYK 
Setup dialog box and then create a profile with those settings, other applications, such as PageMaker and Illustrator, will be able to 
work with the same CMYK options found in Photoshop 5.0. 

The following steps may work best for service providers and prepress professionals who need to make changes to the settings used to 
generate CMYK separations in Photoshop 5.0. This method provides the most avenues for customizing the way Photoshop 5.0 
converts RGB images to CMYK. Performing these steps will give you use of your Photoshop 4.0 Separations Table as an ICC profile 
and use of your Printing Ink Set up file as your conversion settings for converting to CMYK color in Photoshop 5.0. This method also 
ensures your Profile setup is configured to use the ICC profile you saved from your separation setup.

To load Photoshop 4.0.x CMYK settings into Photoshop 5.0:
1. Start Photoshop 4.0.x.
2. Choose File > Color Settings > Printing Inks Setup.
3. Click Save in the Printing Inks Setup dialog box.
4. Name the file with a ".api" extension, choose your desktop folder, then click Save in the Save dialog box.
5. Click OK in the Printing Inks Setup dialog box.
6. Choose File > Color Settings > Separation Tables.
7. Click Save in the Separation Tables dialog box. 
8. Name the file with a ".ast" extension, choose your desktop folder, then click Save in the Save dialog box.
9. Click OK in the Separation Tables dialog box.
10. Quit Photoshop 4.0.x.
11. Start Photoshop 5.0.
12. Choose File > Color Settings > CMYK Setup.
13. Select Built-In for the option labeled, "CMYK Model" and click Load.
11. Select the Printing Inks file you saved in steps 3-4, then click Load.
12. Click OK in the CMYK Setup dialog box. You are now configured to use the CMYK conversion method and settings found in 

Photoshop 4.0.x. 
13. Choose File > Color Settings > CMYK Setup.
14. Select Tables for the option labeled, "CMYK Model" and click Load.
15. Choose Separation Table (*.AST) from the Files of Type pop-up menu, navigate to your desktop, select the file you saved in 

steps 7-8 above, then click Load in the Load dialog box.
16. Click Save in the CMYK Setup dialog box.
17. Navigate to the folder containing your ICC profiles:

- In Windows 95 and Windows 98, navigate to the Windows\System\Color folder.  
- In Windows NT 4.0, navigate to the WinNT4\System32\Color folder.
- In Mac OS, navigate to the System Folder:Color Sync Profiles (for ColorSync 2.5) or the System Folder:Preferences: Color 

Sync Profiles (ColorSync 2.1.2 and earlier).

18. Give the file a name that designates it as your settings from Photoshop 4.0.x and has a ".icm" extension (e.g., "ps4set.icm"), 
then click Save.

19. Select Built-In for the option labeled, "CMYK Model" in the CMYK Setup dialog box. 
20. Click OK to the message, "Discard CMYK tables?"
21. Make sure your Ink Colors file is the one you selected in step 11, then click OK.
22. Restart Photoshop 5.0 to reinitialize the list of available profiles. You can now convert colors to CMYK in Photoshop 5.0 like you 

did in earlier versions of Photoshop.
23. Choose File > Color Settings > Profile Setup.
24. In the Assumed Profiles field section, choose the ICC profile you saved in step 15 from the CMYK pop-up menu.
25. In the Profile Mismatch Handling section, choose Convert to CMYK Color from the CMYK pop-up menu, then click OK.
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ICC Profiles in Photoshop 5.0

What's Covered 
What is an ICC Profile?
Using and Embedding Profiles in Photoshop 5.0
Where to Obtain ICC Profiles

This record will give you a basic understanding of ICC Profiles and how you can use them to get accurate color representation in 
Photoshop 5.0.

The ICC (International Color Consortium) was established in 1993 by eight industry vendors (including Adobe Systems) for the 
purpose of creating, promoting, and encouraging the standardization and evolution of an open, vendor-neutral, cross-platform color 
management system. This group introduced the standard device profile format used to characterize color devices. (For more 
information about the ICC, see http://www.color.org.)

What is an ICC Profile?
An ICC profile is a file that describes how a particular device reproduces color (i.e., it describes the device's color space). ICC profiles 
can be created for three types of devices: a display device (monitor), an input device (a scanner or digital camera), or an output 
device (a printer). 

ICC profiles can be either generic or custom. Generic profiles are created by the device manufacturer. The manufacturer creates the  
profile by using profiling software and instruments to examine the color characteristics of a group of the same devices under 
controlled conditions. The generic profile that comes with a device is not specific to that device or its working conditions.

Custom profiles describe a specific device under set working conditions. Typically, custom profiles are created by using a color 
measuring instrument (i.e., a spectrophotometer or colorimeter) and its companion software. You can also create custom display 
profiles by using Adobe Gamma to modify a generic profile for your monitor. (Adobe Gamma is a control panel that installs with 
Photoshop 5.0. See Related Records for more information on using Adobe Gamma.) Third-party applications, such as LightSource's 
Colortron system, let you create a display profile by using a colorimeter to characterize your screen; Candela Color Synergy lets you 
create an input profile for your scanner, and a output profile for your printer.

Using and Embedding ICC Profiles in Photoshop 5.0
Photoshop 5.0 supports ICC profiles for all display, input, and output devices. Photoshop 5.0 and other ICC-aware applications use 
profiles to produce colors more accurately, so they look the same when printed or viewed on a different monitor. Photoshop also uses 
profiles to better convert RGB values to CMYK and vice versa, to display images from Photo CDs with more accurate color, and to soft 
proof an image so you can see more accurately how it will look with different settings. For more information on using ICC profiles in 
Photoshop, see the Photoshop color management guides on Adobe's Web site at 
http://www.adobe.com/supportservice/custsupport/TECHGUIDE/PSHOP/main.html.

You can embed ICC profiles into any RGB or grayscale *.psd, *.eps, *.tif, *.jpg, *.pct, or *.pdf file saved from Photoshop 5.0. An 
embedded profile remains with the file, so the device's color space information can then be read by any ICC-aware application. To 
set up profile embedding in Photoshop, choose File > Color Settings > Profile Setup, and then select the color modes in the Embed 
Profile section to embed any of the RGB, CMYK, Grayscale, or Lab profiles.

Where to Obtain ICC Profiles
Photoshop 5.0 installs a selection of generic profiles for display and output devices to the following locations:

Windows 95 and 98 Windows\System\Color folder

Windows NT 4.0 Windows\System32\Color folder

Mac OS System Folder:Color Sync Profiles (ColorSync 2.5) or System Folder:Preferences:Color Sync Profiles (Colorsync 2.1.2 or 
earlier).

Adobe does not create the profiles that it includes with its applications, but distributes them as a courtesy to customers. Generic ICC 
profiles are usually available from the device manufacturer. Contact the manufacturer or search their Web site to obtain the generic 
ICC profiles. ICC profiles may also be included with other applications that handle color management (e.g., Adobe Illustrator, Adobe 
PageMaker).

 In Windows, ICC profiles have a *.icm extension; in Mac OS, ICC profiles usually have a *.pf or *.icm extension. (*.icm files are 
cross-platform compatible.)



Hardware and Software for Creating Monitor Profiles 
An accurately calibrated and characterized monitor is a prerequisite for color management. Listed below are companies that make 
software or hardware (or both)  that generates ICC profiles for an individual monitor. 

ICC Profilers URL Software Supported Hardware

Agfa Division, Bayer Corp. http://www.agfahome.com/prod
ucts/dtp/software/colortune.html

ColorTune  and ColorTune Pro X-Rite Colortron 2, X-Rite 
DTP92
GretagMacbeth 
SpectrolLino/SpectroScan

Apple Computer http://www.Apple.com/colorsync/ ColorSync None

Candela http://www.candelacolor.com/ ColorSynergy All GretagMacbeth and X-Rite

Color Partnership http://www.colorpar.com/ Optcal Mac: GretagMacbeth, 
SpectrolLino/SpectroScan
and OptimateI, II, III
Windows: X-Rite DPT92

Color Savvy http://www.colorsavvy.com/ SavvyProfile All ColorMouseToo, 
GretagMacbeth, and X-Rite

Color Solutions http://www.color.com/ ColorBlind Professional
ColorBlind ICC

All GretagMacbeth, Minolta, 
Sequel, Techkon, and X-Rite

Delta-e http://www.delta-e.com/ Profiler All GretagMacbeth and X-Rite

GretagMacbeth http://208.159.8.2/about.htm ProfileMaker All GretagMacbeth

Heidelberg Color Publishing 
Solutions

http://www.linocolor.com/ LinoColor Profilers All GretagMacbeth 

Kodak Polychrome Graphics http://www.kpgraphics.com/ ColorFlow ICC Profile Tools
ColorFlow ICC Monitor Profile 
Builder
ColorFlow Input Profile Builder 

GretagMacbeth 
SpectroLino/SpectroScan, 
X-Rite Colortron 2, All Minolta, 
X-Rite DTP92

Monaco Systems http://www.monacosys.com/Tool
sIndexfset.html

MonacoProfiler GretagMacbeth 
SpectroLino/SpectroScan, 
MonacoView,Techkon, X-Rite 
DTP41 and X-DTP92

Pantone http://www.pantone.com/ Personal Color Calibrator None

Radius http://www.radius.com/ ColorMatch
Separation Lab

None

Scitex Corp. http://www.scitex.com/ Profile Wizard All GretagMacbeth

Sonnetech http://www.colorific.com/ Colorific None

Southwest Software http://www.swsoft.com/ Color Encore for Monitors X-Rite DTP92

X-Rite http://www.xrite.com/ ColorShop X-Rite Colortron 2, X-Rite 
DPT92
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Photoshop 5.0.x Color Settings for Web Images

What's Covered
Adobe Gamma
RGB Setup
Profile Setup
Color Settings for Web Graphics
Saving Your Images for the Web

Adobe Photoshop 5.0.x provides color management tools to ensure consistent color output images that will be displayed on the 
Internet. Before making any color adjustments to existing images in Photoshop 5.0.x, you will need to know what color space these 
images were created in to get reliable color output. To understand color adjustment in Photoshop, it is important to understand how 
color is displayed and converted by means of Adobe Gamma, RGB Setup, and Profile Setup. This document describes how to ensure 
color accuracy in Photoshop images intended to be viewed in a Web browser.

Adobe Gamma
More than likely, you have already calibrated your monitor using Adobe Gamma. Adobe Gamma optimizes your monitor's display to 
a neutral state by setting Brightness and Contrast, White Point, Color Temperature and Gamma settings. Once your monitor is 
properly calibrated, Photoshop enables you to accurately manage the on-screen colors in new images. Although not every monitor 
displaying your images from the Internet will be calibrated, by calibrating your monitor to a neutral state you can create images that 
fall between the dark and bright extremes of an uncalibrated monitor.

RGB Setup
The RGB Setup dialog box contains settings that tell Photoshop how to convert and display images. By default, Photoshop 5.0.x 
uses the sRGB color space, which has a 2.2 gamma. Adobe chose sRGB as the default because the majority of computers (i.e., 
Windows-based computers) have a default gamma of 2.2. However, if you created images in Photoshop 4.0.x or earlier using the 
program's default Monitor Setup, your images were created using the AppleRGB color space with a 1.8 gamma. You may want to co
nvert these images to a gamma setting of 2.2 since 90% of all computers on the market display with a 2.2 gamma so that the images 
will look their best on these systems.

The Display Using Monitor Compensation option in the RGB Setup dialog box lets Photoshop display your images with the 
calibrated monitor settings you made using Adobe Gamma. When this option is selected, Photoshop will display your images 
between the dark and bright extremes of an uncalibrated monitor. However, for an accurate representation of how Web browsers, 
such as Microsoft Internet Explorer or Netscape Navigator, will display your images, this option should be deselected. Deselecting 
Display Using Monitor Compensation will enable Photoshop to display your image as it would appear on an uncalibrated monitor or 
in a Web browser.

Profile Setup
The Profile Setup dialog box contains settings for how Photoshop will manage ICC profiles when it opens and saves images. The 
Embed Profiles section lets you select which profiles will be included in the image when it is saved. Deselecting some or all profiles 
enables you to decrease an image's file size.

The Assumed Profiles and Profile Mismatching Handling sections enable you to tell Photoshop what color space your files are 
coming from and, if necessary, to what color space to convert them. The first time you open an untagged image created with 
Photoshop 4.0.x or earlier, your image will be converted to the color space selected in the Profile Mismatch Handling section. You 
may want to convert your images to the Windows (sRGB) color space since most Internet users use Windows-based computers. Or, you 
may want to leave your images unconverted if they have the correct color for the Web. Use the Profile Setup dialog box to ensure 
your images are neither opened from, nor converted to, an incorrect color space. For more information, see the "Existing Images" 
instructions below.

NOTE: Images saved in the Indexed Color mode (e.g., GIF89a file format) will not be affected by the settings in the Profile Setup 
dialog box. Photoshop will not convert these images because index color images do not contain an ICC profile. Images saved in 
Indexed Color mode include color tables (i.e., index), which contain the images' color information. 

Color Settings for Web Graphics
Below are several work flows for creating Photoshop images for the Web. You may find that one or more of these options will work 
better for your needs.

New Images
If you are creating new Web images and want the colors to appear correctly on as many computers as possible, do the following:



1. Choose File > Color Settings > RGB Setup.
2. From the RGB pop-up menu, choose sRGB.

NOTE: If your Web images will be displayed primarily on Mac OS monitors, choose AppleRGB.

3. Select Display Using Monitor Compensation, then click OK.
4. Choose File > Color Settings > Profile Setup.
5. Deselect RGB and Grayscale in the Embed Profiles section.
6. In the Assumed Profiles section, choose None from the RGB pop-up menu.
7. In the Profile Mismatch Handling section, choose Ignore from the RGB pop-up menu. Click OK.

Existing Images (No Color Conversion)
If you have Web images whose colors look just the way you want in a Web browser, you may not want to convert them into a different 
color space. Before opening these images in Photoshop make these changes to ensure the images are not converted:

1. Choose File > Color Settings > RGB Setup.
2. From the RGB Setup pop-up menu, choose sRGB.
3. Deselect Display Using Monitor Compensation, then click OK.
4. Choose File > Color Settings > Profile Setup.
5. Deselect RGB and Grayscale in the Embed Profiles section.
6. In the Assumed Profiles section, choose None from the RGB pop-up menu.
7. In the Profile Mismatch Handling section, choose Ignore from the RGB pop-up menu. Click OK.

Existing Images (Color Conversion)
If you have images that have been created from various platforms or color spaces, you should set up Photoshop to ask you to choose 
which profile was used when your file was created and then convert it to a common color space (i.e., RGB). To do this, follow these 
instructions:

1. Choose File > Color Settings > RGB Setup.
2. From the RGB pop-up menu, choose sRGB.

NOTE: If your Web images will be displayed primarily on Mac OS monitors, choose AppleRGB.

3. Select Display Using Monitor Compensation, then click OK.
4. Choose File > Color Settings > Profile Setup.
5. Deselect RGB and Grayscale in the Embed Profiles section.
6. In the Assumed Profiles section, choose Ask When Opening from the RGB pop-up menu. 
7. In the Profile Mismatch Handling section, choose Convert to RGB Color from the RGB pop-up menu.

After you make these settings to convert existing images, Photoshop 5.0.x will prompt you each time you open a file, asking you to 
choose which profile was used when your file was created. If your file came from a Macintosh computer without a profile on an earlier 
version of Photoshop from either platform, choose AppleRGB. If your image came from an image editing program other than 
Photoshop on a Windows system, choose sRGB.

Saving Your Images for the Web
To keep your Web graphics as small as possible, you should save your files without the additional color tags. These color tags keep 
track of all the profile information. Excluding the additional color tags will help keep your images' file sizes as small as possible.

Selecting Exclude Non-Image Date will not change how Web browsers display colors in the image. However the following 
information will not be saved with the image: alpha channels, paths, guides, grids, thumbnail previews, EPS previews, ICC profiles, 
and file information (e.g., caption, keywords, copyright). If you select the Photoshop format (*.psd), the resolution of the resulting file 
will be 72 ppi.  Additionally, any duotone images will become grayscale files including only data from the Black channel of the 
original image.

To exclude non-image data when saving your image:
1. Choose File > Save A Copy.
2. Select Exclude Non-Image Data in the Save A Copy dialog box.
3. Choose a name, location, and file type and then click Save.
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Using Adobe Gamma in Windows NT 4.0

As the Adobe Photoshop 5.0 User Guide states, Adobe Gamma is a monitor calibration and profile creation utility installed with 
Photoshop 5.0. Since Windows NT 4.0 does not allow utilities to interact directly with system hardware, Adobe Gamma cannot 
calibrate or change the monitor display. You can, however, use Adobe Gamma in Windows NT 4.0 to create an ICC profile for your 
monitor. This profile can help you achieve accurate on-screen color in Photoshop and other applications that support ICC profiles, 
such as Adobe PageMaker and Adobe Illustrator. 

Photoshop 5.0 uses ICC profiles to display the device's color space if Display Using Monitor Compensation is selected in the RGB 
Setup dialog box. (To access the RGB Setup dialog box, choose File > Color > RGB Setup.)

To start Adobe Gamma, do either of the following:
- Double-click the Adobe Gamma.cpl file from its default location in the Program Files/Common Files/Adobe/Calibration/ folder.
- Move Adobe Gamma to the Windows/System 32 folder, and then start it from the Control Panel:

1. Log into Windows NT as an administrator.
2. Locate the Adobe Gamma.cpl file in the Program Files/Common Files/Adobe/Calibration/ folder and then move it to the 

Windows/System32 folder.
3. Choose Start > Settings > Control Panel and then double-click Adobe Gamma. (If Adobe Gamma does not appear in the 

Control Panel, choose View > Refresh.)
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Photoshop 5.0.x Color Settings for Non-Postscript, Ink-Jet Printers

What's Covered
General Steps and Settings
Settings Specific to Your Printer

Adobe Photoshop 5.0.x uses ICC profiles when matching colors between a monitor and a non-Postscript, ink-jet printer. An ICC profile 
describes the colors a device can display or produce. Many printer manufacturers include product line-specific profiles with their 
device software or on their Web sites. You can create custom profiles for your individual printer using a third-party profiling package 
(e.g., Light Source Colortron, Delta E Profiler). You must place profiles in the system's ICC profiles folder so that ColorSync (Mac OS) 
or ICM (Windows) can make them available to ICC-aware programs such as Photoshop. For more information, see document 321382 , 
"ICC Profiles in Photoshop 5.0."

To achieve a good match between on-screen and printed color, images must consistently move from Photoshop's current RGB 
working space to the color space of the printer. The specific settings that will accomplish this consistency vary depending upon the 
availability of ICC profiles for your printer and the ability to associate profiles with the printer driver using ColorSync or ICM. To find 
out if your printer supports ICC profiles, ColorSync, or ICM, consult the printer's documentation or manufacturer.  

General Steps and Settings
Regardless of your printer's ColorSync or ICM support, you should do the following as the first steps to manage your color output:
1. Use RGB images when printing to a non-Postscript device. Colors from images in other color modes (e.g., CMYK, Grayscale) will 

not print predictably.
2. Calibrate your monitor and create an ICC profile for it using Adobe Gamma. For instructions, see the Photoshop User Guide or 

document 321601 , "Using Adobe Gamma on Mac OS;" document 321608 , "Using Adobe Gamma in Windows 95 and 
Windows 98;" or document 321399 , Using Adobe Gamma in Windows NT 4.0."

3. In Photoshop, choose File > Color Settings > RGB Setup. 
4. In the RGB Setup dialog box, choose Display Using Monitor Compensation and then click OK.

Settings Specific to Your Printer
When printing from Photoshop, complete the steps below that are appropriate for your printer:

If your printer driver supports associated ICC profiles and you have a profile for your printer, do the following:
1. Associate the printer driver with its ICC profile using the instructions provided in your printer's documentation. 
2. Enable your printer driver's ICC option using the instructions provided in your printer's documentation.
3. In Photoshop, choose File > Print. 
4. Select the Printer Color Management option, choose RGB Color from the Space menu, and then click Print.

NOTE: The Printer Color Management option is available only for non-Postscript printers. Postscript printers use Postscript Color 
Management. For more information on Postscript Color Management, see Adobe's Web site at 
http://www.adobe.com/supportservice/usergroup/PDFS/stp012999.pdf .

If your printer driver does not support ICC profiles and you have a profile for your printer, do the following:
1. In Photoshop, choose File > Print.
2. Deselect Printer Color Management (i.e., switch from the printer driver's color management to Adobe's), choose the profile for 

your printer from the Space menu, and then click Print. 

If you do not have a profile for your printer, do the following:
1. In Photoshop, choose File > Print.
2. Deselect Printer Color Management, choose the generic profile for your operating system (Apple RGB [Mac OS] or sRGB 

[Windows]) from the Space menu, and then click Print.

Most printer drivers offer color controls in addition to those above. For more information about  your printer driver's other color 
features, consult the printer's documentation or contact the hardware vendor.
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Opening Kodak Photo CD Images in Photoshop 5.0.x

What's Covered
Source and Destination Profiles
Creating a Destination Profile of Your Working Color Space
Specifying Profiles When Opening a Photo CD Image
Source and Destination Profiles Included With Photoshop

Adobe Photoshop 5.0.x uses the Kodak ICC Color Management System (KICC CMS) to open Kodak Photo CD images. KICC CMS 
uses ICC profiles to convert the color space of a Photo CD image. Source and destination profiles enable Photoshop to accurately 
and consistently convert color in the Photo CD images it opens. This document explains each type of profile to help you decide 
which one to choose when opening Photo CD images in Photoshop 5.0.x.

Source and Destination Profiles
 ICC (International Color Consortium) profiles, which include source and destination profiles, are files that describes how a particular 
device reproduces color -- they describe the device's color space. ICC profiles can be created for three types of devices: a display 
device (monitor), an input device (a scanner or digital camera), or an output device (a printer). Mac OS, Windows 95 or later, and 
Windows NT 4.0 manage and store ICC profiles differently (see the table below for details).

Operating System ICC Profile Manager Source Profile Location Destination Profile Location
Mac OS ColorSync 2.x System Folder:ColorSync Profiles System Folder:ColorSync Profiles

Windows 95 KICC CMS Windows\System\Color Windows\System\Color

Windows 98 ICM 2.0 Windows\System\Color Windows\System\Color

Windows NT 4.0 KICC CMS Windows\System32\Color Windows\System32\Color

Source Profiles
A source profile describes the color space used to create an image. Kodak Photo CD source profiles also describe the type of film 
(color negative or color slide) used to create the original image.

Color slide (i.e., color transparency, color reversal) film source profiles describe the film processing: Kodak Kodachrome film uses K-14 
processing; Kodak Ektachrome and all other types of slide film use E-6 processing. The source profiles may also describe the 
scanning method used for the Photo CD image. In Photoshop, the processing information appears in the Image Info dialog box with 
the Product Type of Original code. If you are using Photoshop in Windows, the processing information also appears in the Source's 
Open dialog box in the KDeviceSettings line of the Show Profile Attributes area.

Destination Profiles
A destination profile describes the color space in which the image opens (e.g., RGB, CMYK, LAB). You determine which profile to 
use based on your workflow. For example, you can use ICC profiles to open an image into an RGB color space and then later convert 
it to CMYK, or you can use a CMYK profile to open an image directly into the CMYK color space. For more information on the 
appropriate destination profile for your workflow, see Adobe's Web site at 
http://www.adobe.com/supportservice/custsupport/TECHGUIDE/PSHOP/main.html. To determine the color space of the profile in 
Photoshop, ensure that Show Profile Attributes is selected, select the profile, and then note the Device Colorspace in the 
Destination's Open dialog box.

Creating a Destination Profile of Your Working Color Space
Before opening a Photo CD image, you may want to create an ICC profile for the RGB working color space in Photoshop 5.0. You 
can then choose that profile as the destination profile when you open a PhotoCD image. This procedure ensures that Photoshop 
opens the image into the working color space. 

To create an ICC profile for the RGB working color space:
1. In Photoshop, choose File > Color Settings > RGB Setup.
2. Select the desired RGB working space from the RGB pop-up menu.
3. Click Save in the RGB Setup dialog box.
4. Navigate to the System Folder:ColorSync Profiles folder (Mac OS), Windows\System\Color folder (Windows 95 or 98), or 

WinNT\System32\Color (Windows NT) folder.
5. Name the profile and then click Save in the Save dialog box.
6. Click OK to close the RGB Setup dialog box.

Specifying Profiles When Opening a Photo CD Image
You must specify a source and destination profile for a Photo CD image when you open it in Photoshop 5.0.x. Before you can specify 



a source profile, you must know which type of film was used to create the image. To determine the type of film:
1. Choose File > Open.
2. Select the image from the [x]:/Photo_CD/Image folder (where "x" is the CD-ROM drive) and then click Open.
3. Click Image Info in the Kodak ICC Photo CD dialog box.
4. Note the type of film used:

-- If Medium of Original reads "Color Negative," the type of film is color negative.
-- If Medium of Original reads "Color Reversal," use the Product Type of Original code to determine the type of film:

Product Type of Original Type of Film
052/55 SPD 0000 Color slide film scanned as Photo CD (Ektachrome) or Color slide film scanned as Pro Photo CD 

(Ektachrome)

116/72 SPD 0000 Color slide film scanned as Pro Photo CD (Ektachrome)

116/22 SPD 0000 Color slide film scanned as Photo CD (Kodachrome) 

5. Click OK.

To open a Photo CD image in Photoshop 5.0.x:
1. Choose File > Open.
2. Select an image from the [x]:/Photo_CD/Image folder (where "x" is your CD-ROM drive) and then click Open.
3. Choose a resolution from the Resolution pop-up menu in the Kodak ICC Photo CD dialog box. The file size appears below the 

Resolution pop-up menu.
4. Click Source.
5. Select a source profile and then click Open. Determine the correct Source profile according to the type of film used to create the 

image:

Type of Film Source Profile
Color negative film pcdcnycc.pf (Mac OS)

pcdcnycc.icm (Windows)

Color slide film (i.e., color transparency 
film, color reversal film)

For Kodachrome: pcd4050k.pf or pcdkoycc.pf (Mac OS); pcd4050k.icm or 
pcdkoycc.icm (Windows)
For Ektachrome and other types: pcd4050e.pf or pcdekycc.pf (Mac OS); 
pcd4050e.icm or pcdekycc.icm (Windows)

Color slide film scanned as Photo CD For Kodachrome: pcdkoycc.pf (Mac OS); pcdkoycc.icm (Windows)
For Ektachrome: pcdekycc.pf (Mac OS); pcdekycc.icm (Windows)

Color slide film scanned as Pro Photo CD For Kodachrome: pcd4050k.pf (Mac OS); pcd4050k.icm (Windows)
For Ektachrome: pcd4050e.pf (Mac OS); pcd4050e.icm (Windows)

6. Click Destination.
7. Select a destination profile and then click Open.
8. Click OK to open the image in Photoshop.

Source and Destination Profiles Included With Photoshop
Photoshop 5.0 includes the following Kodak ICC source and destination profiles (other applications may install additional ICC 
profiles):

ICC Source Profile Film Type Description

pcd4050e.pf (Mac OS)
pcd4050e.icm (Windows)

Kodak Ektachrome or all other color slides Kodak PhotoCD Universal Ektachrome 3.4

pcd4050k.pf (Mac OS)
pcd4050k.icm (Windows)

Kodak Kodachrome color slides Kodak PhotoCD Universal Kodachrome 3.4

pcdcnycc.pf (Mac OS)
pcdcnycc.icm (Windows)

Color negatives Kodak PhotoCD Color Negative 3.0

pcdekycc.pf (Mac OS)
pcdekycc.icm (Windows)

Kodak Ektachrome or all other color slides Kodak PhotoCD Universal E-6 3.2

pcdkoycc.pf (Mac OS)
pcdkoycc.icm (Windows)

Kodak Kodachrome color slides Kodak PhotoCD Universal K-14 3.2



Destination Profile Destination Device
Ebug15m7.icm Generic EBU 1.5 Gamma Monitor

Ebug18m7.icm Generic EBU 1.8 Gamma Monitor

Epsn1p04.icm Epson ES-800C Single Pass

Epsn3p04.icm Epson ES-800C Three Pass

Eucmyk06.icm Light GCR 300 UCR CMYK Euro Positive Proofing

Eucmyk50.icm Light GCR 360 UCR CMYK Euro Positive Proofing

Genkdcs1.icm KODAK Generic DCS Camera Input

Gncmyk04.icm Light GCR 280 UCR CMYK US Negative Proofing

Gncmyk50.icm Light GCR 360 UCR CMYK US Negative Proofing

Hpsj2cx.icm HP ScanJet IICX/T

Hpsjtwm7.icm Hewlett Packard ScanJet IIc

Jpcmyk06.icm Light GCR 300 UCR CMYK Japan Std. Proofing

Jpcmyk50.icm Light GCR 360 UCR CMYK Japan Std. Proofing

Ls3510m7.icm Nikon LS-3510 AF

Mt600zm7.icm Microtek 600ZS

Openrgb.icm KODAK Open Interchange RGB

Pslabint.icm Adobe Photoshop CIELAB

Pslabpcs.icm Adobe Photoshop CIELAB

Rfs2035m.icm Kodak Professional RFS 2035 Film Scanner

Stdpyccl.icm Std Photo YCC Print

Xyz2xyz.icm XYZ to XYZ Identity Profile

Xyzinput.icm XYZ to XYZ Identity Input Profile
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Using Adobe Gamma on Mac OS

What's Covered
Benefits of Calibrating Your Monitor
How to Use Adobe Gamma
Preventing Conflicts With Other Monitor Calibration Utilities

Adobe Gamma is a utility installed by Adobe Photoshop 5.0 that you can use to calibrate your monitor and create an ICC profile that 
describes the monitor's color space. You can then use this profile with Photoshop and other ICC-aware applications, such as Adobe 
Illustrator 7.0.x and Adobe PageMaker 6.5x. Applications use profiles to produce colors more accurately, so they look the same when 
printed or viewed on a different monitor

Benefits of Calibrating Your Monitor
Calibrating your monitor lets you eliminate unwanted color casts from it, so it can provide the best display possible in your working 
conditions. After calibrating your monitor, you can create an ICC profile that characterizes it. This profile can then be used by any 
ICC-aware application to compensate for the characteristics of your monitor when displaying color. Accurately calibrating and 
characterizing your monitor is the crucial first step in developing a color-managed workflow. For more information on using a 
color-managed workflow in Photoshop 5.0, see the technical guides on Adobe's Web site at 
http://www.adobe.com/supportservice/custsupport/TECHGUIDE/PSHOP/main.html.

How to Use Adobe Gamma
Photoshop 5.0 installs Adobe Gamma into the System Folder:Control Panels folder. 

To use Adobe Gamma to calibrate your monitor and create an ICC profile:
1. Choose Apple Menu > Control Panels > Adobe Gamma.
2. Select Step By Step for the version you would like to use, click Next, and then follow the on-screen instructions. For more 

information, see the Adobe Photoshop 5.0 User Guide, "Calibrating Your Monitor," pp. 82-84. 

NOTE: After you complete the Adobe Gamma Assistant, the ICC profile you created (along with all other ICC profiles) will be in 
the System Folder:Preferences:ColorSync Profiles folder (ColorSync 2.1.2 and earlier) or System Folder:ColorSync Profiles 
folder (ColorSync 2.5). The new profile will automatically be set as the system profile in the ColorSync System Profile 
(ColorSync 2.1.2 and earlier) or ColorSync (ColorSync 2.5) control panel.

After creating the ICC profile for your monitor, configure Photoshop to use the profile so it displays images according to the 
characteristics of your monitor:
1. Start Photoshop.
2. Choose File > Color Settings > RGB Setup.
3. Select Display Using Monitor Compensation and then click OK.

NOTE: Deselect Display Using Monitor Compensation if you'll be printing to a non-PostScript color printer (e.g., a QuickDraw 
printer), creating graphics for Web display, or importing files saved from Photoshop 5.0 into applications that do not support ICC 
profiles (e.g., Adobe Premiere 5.0, Adobe After Effects 3.1, Microsoft PowerPoint). Otherwise, unexpected results may occur 
when. For more information, see Related Records.

Preventing Conflicts With Other Calibration Utilities
If you've installed Adobe Gamma and another monitor calibration utility, you should disable one of them to prevent a conflict that 
could cause inaccurate display. This includes the Gamma control panel, which installs with Photoshop 4.0.x or earlier and 
PageMaker 6.x. 

To uninstall the Gamma control panel:
1. Open the System Folder:Control Panels folder.
2. Move the Gamma file to the System Folder:Control Panels (Disabled) folder.

To uninstall Adobe Gamma:
1. Open the System Folder:Control Panels folder.
2. Move the Adobe Gamma file to the System Folder:Control Panels (Disabled) folder.



Adobe Customer Support Services 

Using Adobe Gamma in Windows 95 and Windows 98

What's Covered
What Adobe Gamma Does
How Adobe Gamma Works
How to Use Adobe Gamma
Adobe Gamma and Third-Party Monitor Calibration Utilities

Adobe Gamma is a Control Panel installed with Adobe Photoshop 5.0 that you can use to calibrate your monitor at the system level 
and to create an ICC profile describing your monitor's behavior. Any application that uses ICC profiles can use this profile. 

What Adobe Gamma Does 
By calibrating your monitor at the system level, Adobe Gamma enables you to eliminate unwanted color casts from your monitor and 
to obtain the best display possible for your work environment. In addition, Adobe Gamma characterizes your monitor by means of an 
ICC profile, which is a file that includes a description of the characteristics of your monitor. This profile can be used by ICC-aware 
applications, such as Adobe Illustrator 7.0.x, Adobe PageMaker 6.5x in addition to Photoshop 5.0, to compensate for your monitor's 
color-display limitations. Accurately calibrating and characterizing your monitor is the crucial first step in developing a 
color-managed workflow. 

How Adobe Gamma Works
The Photoshop 5.0 installer installs the Adobe Gamma Control Panel (Adobe Gamma.cpl) into the Windows\System folder, and 
installs the Adobe Gamma Loader application (Adobe Gamma Loader.exe) into the Program Files\Common Files\Adobe\Calibration 
folder. In addition, it installs a shortcut to the Adobe Gamma Loader application in the Windows\Start Menu\Programs\Startup folder, 
which means it will appear in the Start > Programs > Startup menu and Adobe Gamma loader will start automatically during 
Windows startup. 

While loading Adobe Gamma.cpl during Windows startup, the Adobe Gamma Loader application applies settings in the Adobe 
Gamma.cpl file to the system and applies calibration settings you saved for your monitor at the system level. 

How to Use Adobe Gamma
To use Adobe Gamma to calibrate your monitor and save an ICC profile:
1. Choose Start > Settings > Control Panel.
2. Double-click Adobe Gamma.
3. Select Step By Step Wizard, click Next, then follow the on-screen instructions.

NOTE: Before completing the Adobe Gamma Wizard and saving your ICC profile, you can use the Before and After buttons to 
see how the changes you made affect the display of your monitor. 

After you've named your monitor's ICC Profile and clicked Finish in the last step of the Adobe Gamma Wizard, the ICC Profile 
will be saved along with all other ICC profiles in the Windows\System\Color folder. For more information, see "Calibrating your 
Monitor" on pages 82-84 of the Adobe Photoshop 5.0 User Guide. 

To configure Photoshop 5.0 to optimize the display according to the characteristics of your monitor:
1. Start Photoshop and choose File > Color Settings > RGB Setup.
2. Make sure Display Using Monitor Compensation is selected and click OK.

NOTE: When Display Using Monitor Compensation is selected, unexpected results may occur (e.g., colors shift, image is too dark 
or too light) when you print to non-PostScript (e.g., QuickDraw) color printers, when creating graphics for Web display, or when 
importing files saved from Photoshop 5.0 into applications that do not support ICC profiles (e.g., Adobe Premiere 5.0, Adobe 
After Effects 3.1, and Microsoft PowerPoint). In such cases, it is recommended you deselect Display Using Monitor 
Compensation. For more information, see document 321267 .

Adobe Gamma and Third-Party Monitor Calibration Utilities
If you already have a monitor calibration utility capable of creating ICC profiles installed, you should either disable the other utility 
or prevent Adobe Gamma from applying its settings at the system level when Windows starts. This will prevent the two from 
conflicting and causing an inaccurate display. To disable your third-party calibration utility, refer to the documentation included with 
it. To prevent Adobe Gamma from loading its settings at startup remove Adobe Gamma Loader:
1. Choose Start > Settings > Taskbar.
2. Click the Start Menu Programs tab.
3. Click Remove in the Customize Start Menu section.



4. Double-click Programs, if it is not expanded, then double-click StartUp.
5. Select Adobe Gamma Loader.exe and click Remove.
6. Click Yes when asked if you want to remove this item.
7. Click Close in the Remove Shortcuts/Folders dialog box, then Click OK in the Taskbar Properties dialog box.

NOTE:  Adobe Gamma will still be available in the Control Panel folder, but its settings will not be loaded when Windows starts. 

After you remove Adobe Gamma Loader from the StartUp folder, Photoshop 5.0 will continue to use Adobe Gamma to access the 
monitor profile you specified. If you create a profile in a third-party monitor calibration utility, Adobe recommends you load that 
profile in Adobe Gamma:
1. Choose Start > Settings > Control Panel.
2. Double-click Adobe Gamma.
3. Select Control Panel, then click Next. 
4. Click Load to the right of the ICC Profile text-box. 
5. Navigate to the directory containing the profile you want to load (e.g., Windows\System\Color). Select the profile created by 

your third-party monitor calibration utility and click Open.
6. Click OK in the Adobe Gamma Control Panel.
7. Click Save when the message, "Save changes to the profile <profilename.icm> before closing?" appears. After closing the 

Adobe Gamma and clicking Save, the profile created by the third-party utility will be available to Photoshop 5.0.
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Accurate Screens and Photoshop

What's Covered
Accurate Screens
Using Accurate Screens in Photoshop

Digital screening technologies help prevent problems, such as moiré patterns or color shifts, that can occur when printing halftone 
images. These technologies also help speed imaging, present better quality screens, and can provide more detail by having more 
cells in an area. Many imagesetter manufacturers have their own screening technologies (e.g., Agfa's Balanced Screens), but some 
use Adobe Accurate Screens. 

Accurate Screens
Accurate Screens is a digital screening technology developed by Adobe. Accurate Screens uses the supercell pattern of halftone 
screen dots as a solution to the misregistration problems that sometimes occur with the traditional rosette pattern of dots. The 
supercell pattern contains halftone cells made up of smaller halftone cells, each containing a number of halftone dots. When 
electronic screening can't match the optimal placement of the halftone dots, the supercell pattern minimizes the impact by spreading 
the correction over a larger area than traditional patterns. 

Accurate Screens is not a retail product. It is available from OEMs (Original Equipment Manufacturers) that partner with Adobe. For 
more information, contact the manufacturer of the imagesetter's RIP (Raster Image Processor).

Using Accurate Screens in Photoshop
If you select Photoshop's Use Accurate Screens option, Photoshop includes a PostScript LanguageLevel 2 comment when you output 
a file. To read the comment, a RIP must support both PostScript LanguageLevel 2 and Accurate Screens. Otherwise, selecting the 
option has no effect. Check with the imagesetter operator to determine whether you should use the Accurate Screens option. 
Although you must use other digital screening technologies at the imagesetter's RIP, you can use Accurate Screens in Photoshop by 
selecting the Use Accurate Screens option.

To use Accurate Screens in Photoshop:
 - In Windows, choose File > Print, click Setup, click Screens, deselect Use Printer's Default Screens and then select Use Accurate 

Screens. 
- In Mac OS, choose File > Page Setup, select Adobe Photoshop 5.0.x from the pop-up menu, click Screens, deselect Use 

Printer's Default Screens, and then select Use Accurate Screens. 

You can also attach Accurate Screens settings when saving an EPS file by selecting Include Halftone Screen in the EPS Options 
dialog box. However, screen information is best applied at the RIP or within the page-layout application. For example, if you apply 
screen information to an image in Photoshop, place that image into a page-layout program, and then send the file to an 
imagesetter, the output may have moiré patterns if the imagesetter is configured to image film at a different line screen setting.
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Unable to Open Photo CD Images in Photoshop 5.0.x for Windows

Issue
When you try to open a Kodak Photo CD (*.pcd) image in Adobe Photoshop 5.0.x for Windows, the *.pcd file format does not list in 
the in the Files of Type pop-up menu in the Open dialog box. Or, when you click the Source button in the Kodak ICC Photo CD 
dialog box, no source profiles list in the Open dialog box. 

Solutions
Do one or more of the following:

Solution 1
Remove Photoshop, rename Kodak's Photo CD DLL files, then reinstall Photoshop:
1. Exit from Photoshop.
2. Uninstall Photoshop using the Add/Remove Programs Control Panel.
3. In Windows Explorer, choose Tools > Find > Files or Folders. 
4. Search the drive containing the Winnt (Windows NT 4.0) or Windows (Windows 95, Windows 98) folder for the following files:

kpsys32.dll
kpcp32.dll
sprof32.dll
pcdlib32.dll

5. Rename each file to have a ".old" extension instead of a ".dll" extension.
6. Restart Windows.
7. Reinstall Photoshop.
8. Start Photoshop and open the Kodak Photo CD image.

Solution 2
Install the Kodak Digital Science Photo CD Acquire Module for Windows, then use the Import or Acquire command to open the Photo 
CD image. 
1. Download the Photo CD Acquire Module from Kodak's Web site at 

http://www.kodak.com/global/en/service/software/pcdAcquireModule.shtml or order it from Eastman Kodak Company Digital 
Imaging Support (800-235-6325). 

2. Follow the instructions included with the Photo CD Acquire Module to install it.
3. In Photoshop, open a Photo CD file by choosing File > Import > Kodak Photo CD v3.0.

Additional Information
When starting, Photoshop 5.0.x searches for the Kodak Photo CD DLL files it needs to open Photo CD files. If the DLL files are 
outdated or damaged, Photoshop may be unable to open Photo CD images. To ensure the DLL files Photoshop needs are the 
correct version and are undamaged, you must rename the installed DLL files and then reinstall Photoshop. Renaming the installed 
DLL files ensures the Photoshop installer will install the correct DLL files. 

To open Photo CD images, Photoshop 5.0.x uses the Kodak ICC Color Management System (KICC CMS), which uses ICC source and 
destination profiles. Photoshop 4.0.x uses the Kodak Digital Science Photo CD Acquire Module, which uses Kodak proprietary 
Precision Transform (*.pt) files, a precursor to ICC profile files. 

Photoshop 5.0.x can also use the Kodak Digital Science Photo CD Acquire Module instead of KICC CMS to open Photo CD images. 
Please note, however, when you use Kodak Digital Science Photo CD Acquire Module, your choices of destination color spaces will 
be more limited. The Acquire Module will, however, give you image enhancement options, image orientation options, a larger 
preview, and options for modifying units of measurement and resolution. These features are not available when you open a Photo 
CD file using the Open command but are when you use the Import command.

For more information, see document 321574 , "Opening Kodak Photo CD Images in Adobe Photoshop 5.0.x."
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Double-Clicking Active Server Page (*.asp) File Starts Photoshop Instead of Desired Application in 
Windows 

Issue
When you double-click an Active Server Page (*.asp) file in Windows, it opens in Adobe Photoshop 3.0.x or later instead of a Web 
browser (e.g., Netscape Navigator, Microsoft Internet Explorer) or HTML editor (e.g., Adobe PageMill, Allaire Homesite, Microsoft 
FrontPage).

Solutions
Do one or more of the following:

Solution 1
Open the file from within the browser or HTML editor.

Solution 2
Reassociate the *.asp file with the browser or HTML editor (for more information on associating file formats with applications, see 
document 315812 ):
1. Select the *.asp file.
2. Press Shift+F10. 
3. Choose Open With from the pop-up menu.
4. In the Open With dialog box, select the browser or HTML editor. If the browser or HTML editor is not listed, select Other and 

then browse to find it.
5. Select "Always use this program to open files of this type" and then click OK.

Solution 3
Remove and then reinstall the browser or HTML editor:
1. Move any personal files (e.g., images, third-party plug-ins) out of the existing browser or HTML editor folder and subfolders. 
2. Choose Start > Settings > Control Panel, double-click Add\Remove Programs, select the HTML editor's or browser's name from 

the list, and then click Add/Remove. 
3. Check for the folder of the program you removed:

-- If the browser folder remains, delete it and its subfolders.
-- If the HTML editor folder remains, delete it and its subfolders.

4. Restart Windows.
5. Reinstall the browser or HTML editor.

Additional Information
Every file type in Windows has a three-digit extension associated with it. The extension determines which program starts when a file 
is double-clicked -- Windows will start the program associated with the file type. 

For example, Photoshop's installer associates several file types (e.g., *.tif, *.jpg) with Photoshop, and in doing so, changes their icons 
to Photoshop icons. If you install another application that commonly uses *.tif or *.jpg file types after installing Photoshop, those files 
may then be associated with the new application.

Photoshop has used the *.asp file extension for its color separation tables (used in conversions to CMYK mode) since Photoshop 3.0. 
Microsoft started using the *.asp extension for Active Server Pages files. These files are HTML pages containing embedded scripts 
that are processed through a Microsoft Web Server before reaching the browser. 
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Installing ImageReady, ImageStyler, or Photoshop in Windows 98 Safe Mode

Software that loads automatically in Windows (e.g., screen savers, device drivers, terminate-and-stay-resident [TSR] programs, virus 
protection utilities) can conflict with Adobe ImageStyler, Adobe ImageReady, or Adobe Photoshop's installer application and cause 
errors. Starting Windows in Safe Mode temporarily disables conflicting software and device drivers, decreasing installer errors.

After you install the application successfully in Safe Mode, restart Windows in Normal mode. ImageStyler, ImageReady and 
Photoshop will not run in Safe Mode. For more information about Windows 98's startup modes, contact Microsoft Technical Support.

Installing ImageStyler, ImageReady, or Photoshop from the CD-ROM
To install ImageStyler, ImageReady, or Photoshop from the CD-ROM when running Windows in Safe Mode, copy the installer files 
from the CD to your hard disk, restart Windows in Safe Mode, then start the installer application:

NOTE: Because Windows loads only the mouse, keyboard, and standard VGA device drivers in Safe Mode, you cannot access your 
CD-ROM while in Safe Mode.

Standard instructions for starting Windows 98 in Safe Mode:
1. If you are reinstalling ImageStyler, ImageReady, or Photoshop, move any personal files (e.g., images, third-party plug-ins) out of 

the ImageStyler, ImageReady, or Photoshop folder and its subfolders. Then, choose Start > Settings > Control Panel, 
double-click Add\Remove Programs, select Adobe ImageStyler, Adobe ImageReady, or Adobe Photoshop, and then click 
Add/Remove. 

2. Insert the CD into the CD-ROM drive.
3. Exit from all applications, then choose Start > Programs > Windows Explorer.
4. In Explorer, double-click the CD-ROM drive to open it.
5. Locate the ImageStyler, ImageReady, or Photoshop folder and copy it to your hard disk.

NOTE: If an error occurs when copying files from the CD to the hard disk, the CD may be dusty, damaged, or you may have a 
problem with your CD-ROM drive. Clean the CD and caddy with a soft, lint-free cloth to ensure that they are free of dust and 
fingerprints. Try copying files from other CDs to your hard disk to ensure your CD-ROM drive is working properly. If you cannot 
copy files from other CDs, contact your CD-ROM drive's manufacturer or the computer's manufacturer. If you can copy files from 
other CDs, but not the ImageStyler, ImageReady, or Photoshop CD, contact Adobe Technical Support.

6. Exit from Explorer.
7. Choose Start > Shut Down > Restart the Computer.
8. As Windows 98 starts, press the left CTRL key. If Windows won't start in Safe Mode this way, use the alternate instructions below.
9. At the Microsoft Windows 98 Startup Menu, choose option 3. Safe Mode, then press Return.
10. Click OK in the Desktop dialog box indicating Windows 98 is running in Safe Mode. If Windows does not display the words "Safe 

Mode" in each corner of the Desktop, repeat steps 6 and 7 or see the alternate instructions below.
11. Double-click the Setup program (e.g., Setup.exe or Imageready.exe) in the ImageStyler, ImageReady, or Photoshop folder on 

your hard disk to install the application.
12. Restart Windows in Normal mode.

Alternate instructions for starting Windows 98 in Safe Mode:
1. Choose Start > Programs > Accessories > System Tools > System Information.
2. Choose Tools > System Configuration Utility.
3. On the General tab, select the option labeled, "Diagnostic startup - interactively load device drivers and software."
4. Click OK, and restart Windows by clicking Yes in the System Settings Change dialog box.
5. At the Microsoft Windows 98 Startup Menu, choose option 3, Safe Mode, then press Return.
6. Click OK in the Desktop dialog box indicating Windows 98 is running in Safe Mode. 
7. Double-click the Setup program (e.g., Setup.exe or Imageready.exe) in the ImageStyler, ImageReady, or Photoshop folder on 

your hard disk to install the application.
8. Choose Start > Programs > Accessories > System Tools > System Information.
9. Choose Tools > System Configuration Utility.
10. On the General tab, select the option labeled, "Normal startup - load device drivers and software."
11. Click OK, and restart Windows by clicking Yes in the System Settings Change dialog box.
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Producing Consistent Color Between Photoshop 5.0.x and PageMaker 6.5x Using a CMYK 
Workflow

What's Covered
Who Should Use This Workflow
Creating a Device Profile for Your Monitor
Configuring the Photoshop 5.0.x Color Settings
Configuring the PageMaker 6.5x CMS Setup
Configuring Print Settings
Updating Legacy Photoshop Files With New CMS Settings

Maintaining color when transferring documents and images between applications and devices (e.g., monitors, printers, or scanners) is 
a complex process. The process is limited by the color capabilities of monitors, applications, operating systems, and printers. A color 
management system (CMS) can offer optimized output to printers, but requires that you have special equipment to calibrate your 
hardware and create device profiles (files that describe how particular devices reproduce color). True color management also requires 
that you control all color-biasing elements in your work environment (e.g., paint color of the room, direct or indirect sun light), which 
can be expensive and time consuming.  This document describes an alternative color-managed workflow using the tools provided 
with Adobe Photoshop 5.0.x and Adobe PageMaker 6.5x.

Color management is often incorrectly defined as a way to get the best-looking display and print color from all applications. Color 
management discussed in this record has little to do with the "best-looking color."  Instead, this record provides instructions for getting 
dependable, matching color printouts from Photoshop 5.0.x and PageMaker 6.5x. Once you are able to match color from Photoshop 
and PageMaker, you can be confident that any color correction you make to Photoshop images will be maintained when you print 
these images from PageMaker.  

Who Should Use This Workflow
The workflow described in this document includes only tools provided with Photoshop 5.0.x and PageMaker 6.5x. If you have 
professional color-management equipment and software to calibrate your hardware devices and create custom device profiles, you 
should follow the instructions provided by the manufacturer for calibrating and making profiles rather than relying on generic profiles 
supplied by the manufacturer or Adobe.  You most likely will get better results creating a monitor profile using a spectrophotometer -- 
a hardware device that can measure light, such as X-Rite or Colortron II -- than using a software program like Adobe Gamma. 

This workflow is designed for use with a PostScript language printer. If your final output will be to a non-PostScript color inkjet printer, 
see document 321999 , "Printing Consistent Color From Photoshop 5.0.x and PageMaker 6.5x to a Non-PostScript Inkjet Printer."

Creating a Device Profile for Your Monitor
Each monitor comes from the factory with different color capabilities, and these can change over time. Because of this, creating an 
ICC-compliant custom profile (also known as "characterization") and regularly calibrating your monitor are two important steps in 
color management. If you have already created an ICC monitor profile using a calibration and profile-generating utility, you may use 
that profile in this workflow.  If not, create an ICC profile using a third-party utility or using the Adobe Gamma utility, which is 
included with Photoshop 5.0.x.  

To create a monitor profile, follow the instructions on pages 82-84 of the Adobe Photoshop 5.0 User Guide. Alternatively, see 
Related Records on "Using Adobe Gamma."

NOTE: When you characterize your monitor, do not adjust the settings too far in any direction, as this can lead to unwanted color 
shifts in your images.

Configuring the Photoshop 5.0.x Color Settings
The following instructions establish settings in Photoshop 5.0.x's Color Settings dialog boxes for images that will eventually be 
printed as CMYK images to a PostScript printer. Since it is very common practice to open RGB images in Photoshop before 
converting them to CMYK, it is important to make sure both the RGB and the CMYK settings are correct in Photoshop.

For detailed information on the implementation of color management in Photoshop 5.0.x, see the Photoshop technical guides on 
Adobe's Web site at http://www.adobe.com/supportservice/custsupport/TECHGUIDE/PSHOP/main.html.  

1. Start Adobe Photoshop 5.0.x.
2.  Choose File > Color Settings > RGB Setup.
3.  Choose an appropriate color space for prepress work, such as Adobe RGB (1998) or Colormatch.  Make sure that Display Using 

Monitor Compensation is enabled and that Preview is selected, and then click OK to close the RGB Setup dialog box.



NOTE: Setting your RGB setup in Photoshop 5.0.x to Adobe RGB (1998) or Colormatch ensures you are working in a standard 
color space for CMYK printing. This will not necessarily produce the best color matching with applications that do not support 
ICC-compliant CMS, however. Converting your images to this new working space can change their appearance or color values; 
for more information about this please see the technical guide mentioned above. Photoshop gives you the option of working in 
other color spaces, but for this workflow you should stay in one of these color spaces unless instructed by your service provider to 
do otherwise. 

4. Choose File > Color Settings > Profile Setup.
5. Select RGB and CMYK in the Embed Profiles section. Choose None from both the RGB and CMYK pop-up menus in the 

Assumed Profiles section. Click OK to close the Profile Setup dialog box.
6.  Choose File > Color Settings > CMYK Setup.
7. Select ICC in the CMYK Model section.
8. Choose the profile for the final output device from the Profile pop-up menu.  If you do not have a profile for your final output 

device, contact your service provider to obtain one.
9.  Choose Kodak Digital Science ICC CMS (Windows and Mac OS) or Apple ColorSync (Mac OS only) from the Engine pop-up 

menu.

NOTE: If you have a proprietary color management system, you can choose it from the Engine pop-up menu, but it must also be 
available in PageMaker to guarantee matching printouts from PageMaker and Photoshop.

10. Choose Perceptual (Images) from the Intent pop-up menu and select Preview. Click OK to close the CMYK Setup dialog box.
11. Open or create your image, and print it if you want. See the Printing section below for specific instructions on printing from 

Photoshop.
12. Save your image as a TIFF file; you can color manage TIFF images in PageMaker.

NOTE: For these changes to take effect in previously saved images, you will have to open and resave the images. You can 
automate this process using an action; see the last section of this document for more information.

Configuring the PageMaker 6.5x CMS Setup
This section describes how to set up color management for all new PageMaker documents.  Note that you will have to individually 
update documents created prior to setting up color management. If any of these existing PageMaker documents contain Photoshop 
5.0.x TIFF images, you must also select each TIFF image in PageMaker, choose Element > Image > CMS Source, and then choose 
the desired color management engine, profile, and rendering intent. Alternatively, you may open the images in Photoshop, resave 
them, and then replace them into PageMaker.  

To configure PageMaker's CMS settings for new publications:
1. Start PageMaker, but do not open a file.
2. Choose File > Preferences > General.
3. Click CMS Setup.
4. Choose On from the Color Management pop-up menu.
5. Choose Separations Printer from the Monitor Simulates pop-up menu.
6. From the New Items Use pop-up menu, choose the same CMS Engine (e.g., Kodak ICC or Colorsync) that you chose for 

Photoshop in step 9 in the previous section.
7. Choose the monitor profile you created earlier in this document from the Monitor pop-up menu.
8.  Choose your PostScript proofing device from the Composite Printer pop-up menu.

NOTE: If you do not have a profile for your PostScript proofing device, contact your printer manufacturer to obtain one. If the 
manufacturer does not have a profile for the device, experiment with the output produced with other profiles to determine which 
one best fits your printer.  

9.  Choose the profile  for your final output device from the Separations Printer pop-up menu. This should match the profile you 
selected in Photoshop's File > Color Settings > CMYK Setup > Profile pop-up menu in step 8 in the previous section.

10. Choose your Monitor profile for the RGB Image Source pop-up menu.
11. Choose your Separations Printer profile from the CMYK Image Source pop-up menu.
12. Click OK in the Color Management System Preferences dialog box.
13. Click OK in the Preferences dialog box.
14. Create your PageMaker file and print it. See the Configuring Print Settings section below for specific instructions on printing 

from PageMaker.
 
When turning on Color Management in PageMaker, you are telling PageMaker that it should use device profiles to manage the color 
information of the image when printing. When you print separations, PageMaker will use the profile selected in the Separations 
printer pop-up menu to manage the color information; when you print composites, PageMaker will use the Composite printer profile 
selected here. The output produced with color management turned on in PageMaker is almost entirely dependent on the accuracy of 
the profiles selected in the CMS Setup dialog box. These profiles are created by the manufacturers of the devices in your workflow 
(e.g., monitor, scanner, and printer) and can be obtained from the manufacturers. For instructions on where to obtain device profiles 



not included with PageMaker 6.5x, see document 311632 , "Obtaining Device Profiles (Precision Transforms) Not Included With 
PageMaker 6.x."

Configuring Print Settings
To match output between Photoshop and PageMaker, each application must send comparable color information to the printer. To 
achieve comparable results, you must pay attention to certain settings in the print dialog box.

Printing from Photoshop 5.0.x
1. Choose File > Page Setup and select the printer that will be the final output device.
2. Make any printer driver specific options (e.g., page size or orientation).  

NOTE: Different printer drivers have different print options. Make sure you choose appropriate color settings for the image that 
you are printing. For further information about what each of the settings means and how it will affect your printing, consult your 
printer documentation or contact the manufacturer.

3. Choose File > Print.
4. From the Space pop-up menu, choose the profile you chose in the CMYK Setup dialog box.
5. Click Print.

Printing from PageMaker 6.5x
1. Choose File > Print. 
2. Click Features and note any color-related settings.
3. Click Print.

NOTE: If the printout does not match Photoshop's, make sure color-related settings in Step 2 match the settings made in Step 2 
of the Photoshop printing procedure.

For more information on CMS settings in Photoshop 5.0.x, read Chapter 5 of the Adobe Photoshop 5.0 User Guide. For more 
information on CMS settings in PageMaker 6.5x, read Chapter 9 of the Adobe PageMaker 6.5 User Guide.

Updating Legacy Photoshop Files With New CMS Settings
If you have a large number of Photoshop TIFF files in a PageMaker 6.5x publication and you would like to update them with the 
CMS settings you've chosen above, you may wish to create an action in Photoshop 5.0.x to automate this process.

To create an action that will re-save images in Photoshop 5.0.x:
1. Open an image in Photoshop 5.0.x.
2. Choose Window > Show Actions.
3. Choose New Action from the Actions palette pop-up menu.
4. Name the Action and then click Record.
5. Choose File > Save As and choose TIFF from the Save As pop-up menu.
6. Click Save. (Do not change the filename or location.)
7. Click OK in the TIFF Options dialog box.
8. Choose File > Close.
9. Click the Stop button in the Actions palette.
10. Choose File > Automate > Batch.
11. Make sure your new action appears in the Action pop-up menu in the Play section of the dialog box. If it doesn't, repeat steps 

3-8.
12. Choose Folder from the Source pop-up menu.
13. Click Choose, and then select the folder containing the images you've placed into PageMaker.
14. Choose Folder from the Destination pop-up menu.
15. Click Choose and select the same folder you selected in step 13.
16. Click OK.
17. Repeat steps 12-16 for any other folders that contain images you've placed into the PageMaker publication.

NOTE: After resaving TIFF images that have been placed in a PageMaker publication, you may need to update the links in the 
publication.

For more information about actions, see the Adobe Photoshop 5.0.x User Guide. 
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