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This manual and the software described in it are
copyrighted with all rights reserved. Under the
copyright laws, this manual and the software
may not be copied, in whole or part, without the
written consent of Silicon Beach Software, Inc.,
except in the normal use of the software or to
make backup copies. This exception does not
allow copies to be made for others, whether or
not sold, but all of the material purchased (with
all backup copies) may be sold, given, or loaned
to another person.

You may take the software from one computer
to another, but you may use the software on
only one computer at a time. A multi-use
license may be purchased to allow the software
to be used on more than one computer at the
same time, including a shared-disk system.
Contact Silicon Beach Software, Inc. for
information on multi-use license.

© 1986 Silicon Beach Software, Inc.
P.O. Box 261430

San Diego, CA 92126

(619) 695-6956

LaserBits is a trademark of Silicon Beach
Software, Inc.

Macintosh is a trademark licensed to Apple
Computer, Inc.

MacDraw, MacPaint, MacWrite and Switcher are
trademarks of Apple Computer, Inc,

Times and Helvetica are trademarks of Allicd
Corporation.

Warranties

Silicon Beach Software, Inc. warrants the disk
to be free of defects for 90 (ninety) days from
the purchase date. If the disk is found to be
defective in this 90 day period, return it to
Silicon Beach Software for a free replacement.
After 90 days, return it with $5.00 for a
replacement. To obtain this warranty, you
must send in the registration card.

THE SYSTEM IS A COPYRIGHTED
PROGRAM OF APPLE COMPUTER, INC.
LICENSED TO SILICON BEACH
SOFTWARE, INC. TO DISTRIBUTE FOR
USE ONLY IN COMBINATION WITH
SUPERPAINT. APPLE COMPUTER, INC.
MAKES NO WARRANTIES, EITHER
EXPRESS OR IMPLIED, REGARDING
THE ENCLOSED COMPUTER SOFT-
WARE PACKAGE, ITS MERCHANT-
ABILITY, OR ITS FITNESS FOR ANY
PARTICULAR PURPOSE. THE EXCLU-
SION OF IMPLIED WARRANTIES IS NOT
PERMITTED IN SOME STATES. THE
ABOVE EXCLUSION MAY NOT APPLY
TO YOU. THIS WARRANTY PROVIDES
YOU WITH SPECIFIC LEGAL RIGHTS.
THERE MAY BE OTHER RIGHTS THAT
YOU MAY HAVE WHICH VARY FROM
STATE TO STATE.

Finder, System, System.Resource,
ImageWriter Driver are copyrighted programs
of Apple Computer, Inc. licensed to Silicon
Beach Software, Inc. to distribute for use only
in combination with SuperPaint. Apple
Software shall not be copied onto another
diskette (except for archive purposes) or into
memory unless part of the execution of
SuperPaint. When SuperPaint has completed
execution Apple Software shall not be used by
any other program.
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TWO LAYERS

DOCUMENT
DIMENSION

Welcome to SuperPaint! By now you have probably experimented
with the application a little, and may even feel somewhat proficient
with it. If you have used any other graphics programs for the
Macintosh, much of SuperPaint should seem familiar. Nevertheless,
there’s nothing like the last resort (reading the manual) for tying down
loose ends, and learning how to really put a program to work!

SuperPaint’s single most distinguishing feature is its ability to
incorporate both painted (dot-by-dot) and drawn (object-oriented)
images in a single document. You must use very different techniques
to edit these two kinds of images. To simplify things, SuperPaint
documents are split into two layers, one for each kind of image.

You will work with only one of these layers at a time. The layer you
are currently working on is always “in front” of the other layer. You
can either superimpose the layers, or hide the one you aren’t working
on (the one “in back™). To change from one layer to the other, you
click on the icon in the top of the tool palette that contains the paint
brush and the compass icons.

The Paint layer contains an image consisting of many dots. Init, you
can use all sorts of painting tools, like a spray can, paint brush,
eraser, and paint bucket to erase or paint more dots in the document.
You can also paint rectangles, ovals, and round-cornered rectangles.
Remember, though, that painted shapes are nothing more than a
collection of dots. Once you create a rectangle, for example, you
cannot go back and change the pattern it was painted with. Instead,
you must erase the dots that made up the old rectangle and paint a new
one in its place.

In the Draw layer, objects are distinct from each other. Since they
remember all their characteristics, such as line width and pattern, it is
easy to go back and change the pattern of a rectangle in the Draw
layer. Changes are easy to make -- without erasing anything.

Objects are entities that are stored as mathematical information in the
computer. They can overlap each other, and be stacked up. They
cannot be edited dot-by-dot.

When a program creates data or images and saves them to disk, it
stores them in a file. The word “file” is the commonly-used computer
term. With the Macintosh, files are normally referred to as
documents. SuperPaint documents contain images that are 8 inches
across and 10 inches high.

PART 1: GETTING STARTED

L UL L LR L L O L L L A

LB L LOL LR LR UL LN LI LA LI L, L L |



Mol b ol oF ul ool M al b M ab A ol Mool M d)

l

Wb bl al ol al

I

THE TOOL
PALETTE

Figure 1.1

Figure 1.2

Along the left-hand side of the screen, there is a palette filled with
various tool icons. Clicking on one of these icons tells SuperPaint
what task you want to perform next. For instance, after clicking on
the oval-shaped icon (the Oval tool), you can paint an oval. The tool
you last clicked on remains selected until you click on a different tool.
Thus, after painting your first oval, you can proceed to paint several
more, without touching the tool palette again.
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Since the Paint and Draw layers are so different from each other, it
stands to reason that you need different tools for each one. Figure 1.1
depicts the tool palette when the Paint layer is active (in front).
Compare it to Figure 1.2, which shows the Draw layer’s tool palette.
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THE
PATTERN
PALETTE

Figure 1.3

At the very top of the tool palette is an icon (the Layer selector) which
distinguishes between the two sets of tools. When the compass is on
top, the Draw layer is in front, where you can work on it, and the
palette contains drawing tools. When the Layer selector displays a
paint brush on top, the palette is filled with painting tools, and the
Paint layer is in front. By clicking on the Layer selector , you can
switch from one layer to the other.

Along the bottom of the screen is another palette, filled mostly with
patterns. At any one time, 35 patterns are visible, and available for
several uses. You can switch the rightmost 32 boxes between two
sets of patterns by clicking on the arrowheads in the palette. The
Black and White patterns are always available, as is the pattern marked
“None.” Areas painted with the None pattern are transparent, whereas
things painted White are opaque.

Whr“re\ VrBIack
e

White & None

2

One set of patterns (the set that SuperPaint initially displays) looks
fine when printed on either the ImageWriter or the LaserWriter. This
set contains, for example, brick and woven patterns. The other set
contains gray patterns that look particularly good on the LaserWriter.
You will get the most benefit from these “LaserWriter grays,” if you
use them in Draw-layer objects.

At the left-hand side of the pattern palette is the Line/Fill selector. The
selector applies any pattern selection either to area fills or to lines and
borders. Clicking on the larger, filled rectangle (to the right) lets you
select fill patterns. Clicking on the narrow rectangle permits selection
of line and border-drawing patterns. The line and fill selectors are
displayed with the currently selected line and fill patterns. The current

PART 1: GETTING STARTED
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Figure 1.4

MANIPULA-
TING THE
SCREEN
DISPLAY

Multiple
Windows

Figure 1.5

selector mode (Line or Fill) is indicated by a small arrowhead that
points to the appropriate side of the selector.

Line paﬁem\

/"’ } \ None

IUne/Fz‘H indicator Fill pattern
(Line pattern selected)

SuperPaint gives you plenty of control over the screen configuration.
You can display and edit up to 10 documents at a time. You can even
make the palettes and the menu bar invisible, and edit documents
using the entire Macintosh screen.

You can open several documents simultaneously. By choosing Open
or New from the File menu, you add a window onto the desktop.

& File Edit Options Windows Peint Font Size Style
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At any time, only one window is active. The active window shows
the typical Macintosh highlighting (the Hallway document in Figure
1.5, for instance). To switch to a different document, click any
exposed portion of its overlapped window. Sometimes that isn’t
possible -- a window might be completely obscured. In that case,
simply choose the document you want from the Windows menu (as
in Figure 1.6). Every open document is represented in the Windows
menu.

PART 1: GETTING STARTED




Figure 1.6

Zooming
Windows and
the Full Screen
Command

Figure 1.7

% File Edit Options BIIOTIOTES Paint Font Size Style
Hide Palettes ®H

Hide Back Layer 3L

Show Rulers

Reduced View XL
4] Full Screen ®F b

Multiple windows are extremely useful when you need to cut/copy
and paste images between documents.

Click here to expand wfndaw\

Untitled - 1 ===

==

The active window can be expanded to maximum size by Zooming or
with the Full Screen command. On versions of the Macintosh with
enhanced Read-Only Memory (ROM) software, you can click in the
Zoom box. This is the small box at the right-hand side of a window’s
title bar (see Figure 1.7). On an unenhanced Macintosh, zoom the
active window by double-clicking anywhere in its title bar. Return the
window to its unzoomed size by repeating the same operation (i.e.,
click in the Zoom box or double-click in the title bar). Of course, you
can always adjust the size of a window by dragging the Size box in its
lower right-hand corner (see Figure 1.8).

PART 1: GETTING STARTED
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Figure 1.8

Hiding the
Palettes and
the Menu Bar
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Untitled - 1

Drag to here

You can gain even more screen space by choosing the Full Screen
command from the Windows menu (or by pressing Command-F).
The Full Screen command takes the active document out of its
window and places it directly on the desktop. While using Full
Screen mode, there are no scroll bars, nor any windows. To scroll,
you must use the Hand (see below). To switch to another document,
choose it from the Windows menu. To bring a desk accessory out,
choose it from the # menu.

Choosing Full Screen again places the open documents back in their
normal windows.

By choosing Hide Palettes in the Windows menu (or by pressing
Command-H), you can remove the tool and pattern palettes from the
screen. In combination with the Full Screen command, this lets you
work with the most recently selected tool, using almost the entire
screen at once.

To restore the Palettes to the screen, choose Show Palettes from the
Windows menu, or press Command-H again.

You can even remove the menu bar whenever the palettes are hidden.
To achieve this effect, turn on the “Hide menus when hiding palettes”
option in the Preferences dialog box (reached by choosing
Preferences in the Options menu). That way, you really can work
with the entire Macintosh screen at one time. When you are done,
press Command-H to restore the menu bar and palettes.

The Full Screen command and “Hide menus” option are not available

when using a Macintosh that has a large screen of any sort. They
work only on standard Macintoshes.
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Scrolling

Scroll Bars

Figure 1.9

The Hand

At any moment, you can only see a portion of your document. To see
and manipulate the rest of a document, you must scroll (i.e., shift) the
viewing area. There are several ways to accomplish this.

Close box Title bar Zoom box
\ Vs - ~

Specimen Window

Scroll
bar

Scroll arrows

Scroll box

Size hox J

When you employ windows, you can use scroll bars to move around
in the document. The vertical scroll bar (at the right-hand side of a
window) is used to move the document up and down in the window.
Likewise, the horizontal scroll bar shifts the window left and right.
Clicking on a scroll bar’s arrow slowly shifts the document in the
window in the indicated direction. Dragging the scroll box lets you
move to a position relative to the size of the document. For instance,
dragging a scroll box to the middle of a scroll bar positions the
viewing area halfway into the document. Finally, clicking in the gray
area of the bar (the page bar) scrolls by one windowful in the direction
of the arrow that is on the same side of the scroll box.

The best way to learn how the scroll bars work is to experiment with
them. Open one of the sample SuperPaint documents included on the
disk, and try scrolling it with the scroll bars.

Another way to scroll is by using the Hand. The Hand is always
available, even in Full Screen mode. To use the Hand, press and hold
the Space bar. The mouse cursor will change into the shape of an
open hand. You can then drag the document in any direction you like.
Just press the mouse button and drag the cursor in the direction you
want the document to shift. Notice that the document moves along
with the cursor, and that the scroll boxes shift automatically.

PART 1: GETTING STARTED
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Scrolling Tools
and Dragging

Hiding the
Back Layer

Figure 1.10

While entering text, press and hold Command-Space bar to use the
Hand.

Holding down the Shift key constrains Hand motion to the vertical or
horizontal. The direction depends on which way you initially move
the cursor.

All tools automatically scroll the document as necessary. For
example, you can easily create a rectangle that is larger than the
window. As you drag a corner of the rectangle past the edge of the
window, the document will scroll obligingly, and the rectangle will
continue to grow. When you bring the corner of the rectangle back
within the window, the document will stop scrolling.

Likewise, you can drag selections anywhere in a document. As you
drag a selection past the edge of the window, the document will scroll
accordingly, until you bring the cursor back within the window.

You can disable this feature, if you desire. To do so, choose Turn
Scrolling Off from the Options menu (or press Command-").
Turn it back on by choosing Turn Scrolling On from the Options
menu (or press Command-" again).

These rules also apply while in Full Screen mode.

Normally, you can see what you have created in both the Paint and the
Draw layer at one time. Because this can be confusing, there is a
command to hide the back layer (the one you are not currently
working on). Choose Hide Back Layer from the Options menu.
You can press Command-L to achieve the same effect, or click on the
Layer selector with the Option key held down. To turn layer hiding
off, choose Show Back Layer from the Options menu, or press
Command-L again.

Note that when the back layer is not visible, the Layer selector
indicates this. Either the paint brush or the compass is dimmed,
whichever is the hidden back layer.

Back layer visible

Back fayer hidden

PART 1: GETTING STARTED



UNDO

PREFER-
ENCES
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You can always reverse your most recent editing operation by
choosing Undo from the Edit menu. Repeatedly choosing Undo
will alternately restore or reverse the most recent editing command.

For example, let’s say you are unhappy about the position to which
you just dragged a selection. Choosing Undo will return the
selection to its original position. Undoing again places the selection in
the new position, etc.

There are two ways to use the Undo command from the keyboard.
The first is Command-Z, which is standard in most Macintosh
programs. The second way is by pressing the tilde (~) key in the
upper left-hand corner. The latter shortcut originated from MacPaint
and is very convenient. When entering text, this key simply enters the
tilde character. Use the menu command or Command-Z to undo when
entering text.

You cannot undo File operations (e.g., printing, saving a
document, etc.).

There are features of SuperPaint that you can tailor to your liking. If
you choose Preferences from the Options menu, you will be
presented with a dialog box containing these features and their current
settings.

For example, you can choose whether you would prefer the pattern
palette to be at the top or the bottom of the screen. You can also
indicate whether you want the menu bar to disappear when you
choose Hide Palettes from the Windows menu.

Your most recent Preferences selections will be remembered the next
time you start SuperPaint. Your preferences are automatically stored
in a file named “SuperPaint Prefs.” The preferences file can reside in
the same folder as SuperPaint, or in the same folder as your System
file.

PART 1: GETTING STARTED
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Part 2
Painting
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CONSTRAIN-
ING

PAINTING
SHAPES

Paint from
Center

Patterns and
Borders
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The most important thing to understand about the Paint layer is that
you will use it to create patterns of dots. Once you paint something,
the only way to alter it (besides using the Undo command) is to erase
dots or add dots.

Constraining is used to restrict a shape you are painting to some
particularly useful subset of the tool’s capabilities. For example,
when painting an unconstrained line, you can select any pair of
endpoints. When painting a constrained line, though, SuperPaint will
restrict it to certain angles (e.g., vertical, horizontal, 45 degrees).
Once you have selected a tool, constraints are invoked by pressing and
holding one or more keys (usually Shift, but sometimes both Shift and
Option) while you press the mouse button to use the tool. Generally,
you must hold the constraint key(s) throughout that use of the tool.

The description of each tool includes all the constraint variations.

Normally, you will paint a shape by specifying the locations of its
corners. Sometimes, that is not the most convenient way. That’s
why SuperPaint includes the Paint from Center option. You can enter
this mode by choosing Paint From Center in the Options menu,
or by double-clicking the Rectangle, Rounded Rectangle, Oval, or
Circle. The affected shape tools reflect this mode by displaying a
small crosshair. While in this mode, pressing the mouse button
specifies the center of the shape, while releasing the mouse specifies
the outside location.

To restore the initial shape-drawing mode, choose Paint from
Corner in the Options menu, or double-click one of the four shape
tools.

Remember that the patterns that are used to paint the borders and
interiors of shapes are taken from the pattern palette. To painta
transparent shape, set the fill pattern to “None.” For more information
on patterns, see the discussion in Part 1.

You can also control the thickness of the border with the Line Size
selector. See the discussion of the Line tool, below.

PART 2: PAINTING
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Rectangle

Figure 2.1

Constraints

Rounded
Rectangle

Constraints

Oval

Constraints

Circle

Constraints
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This tool lets you paint rectangular shapes. When you select it, the
cursor becomes a solid crosshair. The thickness of the crosshair
indicates which line thickness is currently selected. In Paint from
Corner mode, move the cursor to a starting point, press the mouse
button to select one corner, then drag the rectangle’s opposite cormer
in any direction, as in Figure 2.1A.

el r 1. Press mouse butfon here el

X[ Qe

é g, % 2 i. Press mouse

t] button here

BlA AlA "

NE: A

—I= Rt _

i (5]

| O | b o
=E§ 2. Dragto herel/ 2. Drag to hereJ
+[> A. Paint from Corner B. Paint from Center

In Paint from Center mode, press the mouse button on the center
point, then drag the rectangle’s corner wherever you want it (see
Figure 2.1B).

The Shift key restricts this tool to the creation of squares.

This tool works just like the Rectangle tool, except it paints shapes
with rounded corners.

The Shift key lets you create squares with rounded corners.

The Oval tool lets you draw ovals. You actually specify a rectangle,
within which SuperPaint paints an oval. Paint from Center works just
as with the Rectangle tool.

The Shift key restricts this tool to creating circles.

The Circle tool works precisely like a constrained Oval. With it, you
can draw only circles.

None,
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Polygon

Constraints

Freehand

Figure 22

Constraints
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The Polygon tool lets you paint a shape with as many sides as you
want. Click once to set the starting point. Move the pointer and click
at the second corner, then the third, etc. Double-click the last corner
to complete the polygon, or click outside the window.

SuperPaint will automatically paint the final edge and fill the polygon
with the current fill pattern. If the fill pattern selected is “None,”
when you double-click to finish the polygon, the cursor location
becomes the final point. Unlike a filled polygon, a line will not be
drawn from that point to the beginning point.

The polygon’s border is painted according to the current line size.

The Shift key constrains the sides of the polygon to angles of 45 and
90 degrees.

Holding Shift and Option constrains polygon sides to angles of 30, 60
and 90 degrees.

Either constraint remains in effect only so long as you hold the key(s)
down. You can even change (or eliminate) constraints in the midst of
adding an edge to the polygon. If you press the Shift key while
painting an edge, it immediately jumps to the nearest permitted angle.
If you release the Shift key, it starts following the cursor again.
Likewise for the Shift/Option constraint. -

The Freehand tool allows you to paint any shape you want. Move the
cursor to the starting point, then drag it to outline the shape you want.
Release the mouse button to define the ending point. If you have
selected a fill pattern other than “None,” SuperPaint automatically
connects the starting and ending points.

2. Prag to here,
then release

3. SuperPaint completes
and filis shape \

1. Press mouse
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OTHER
TOOLS

;7 Pencil

Figure 2.3

Constraints

Paint
Brush

15

The Pencil tool lays down a thin trail of black or white paint while you
hold the mouse button down. When you select this tool, the cursor
changes to a small pencil. If, when you first press the mouse button
to engage the pencil, the tip of the pencil cursor lies over a white area,
it will leave a trail of black paint. The reverse is also true: If you start
over a black area, the pencil will leave a white trail.
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[lE===——_—__—= Pencil Example
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The pencil is extremely useful in the magnified mode (as in Figure
2.3), where it is easy to edit small details on a dot-by-dot basis.

The Shift key restricts the pencil’s trail to either vertical or horizontal
motion. The direction of the constraint is based on the direction of the
pencil’s first motion.

The brush applies paint in the currently selected fill pattern and brush
tip shape. To use it, click the tool, then drag the cursor across the
window. As long as you hold the mouse button down, the paint will
continue to flow.

PART 2: PAINTING




Figure 2.4
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Drag from here...

..To here

Normally, brushed paint is opaque -- it obscures any image beneath it.
You can permit overpainted images to show through the white areas of
the paint pattern, if you like. To do this, choose Transparent Paint
from the Paint menu. You can also think of transparent paint as
painting with the black portion of the pattern only. There is yet
another kind of paint which applies the pattern only to black areas of
the painting. To use it, choose Paint on Black from the Paint
menu. Choose Opaque Paint to return to the original kind of paint.
To temporarily use transparent paint, hold the Command key down
while dragging the brush.

To select a different brush shape, choose Brush Shapes from the
Paint menu or double-click on the Paint Brush tool. SuperPaint
displays a dialog containing the various brush shapes. Click on the
shape you want.

To customize a brush shape in the Brush Shape dialog, hold down the
Option key when you click on one. You can then edit a magnified
view of the brush. Click the cursor on a white square in the brush
shape to convert it to a black one. Conversely, clicking on a black
square changes it to a white one. A normal size view of the brush
shape is displayed to the left of the magnified view. Click the OK
button to accept the new shape, or click Cancel to reject it. Modified
brush shapes are stored in the SuperPaint Prefs file.

PART 2: PAINTING
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Figure 2.5
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The best way to learn how the various kinds of paint work is to try
them out.

Constraints | The Shift key restricts the brush to horizontal or vertical movements.

Spray Can | The spray can applies a coat of paint to the image, in a manner similar
: to an airbrush. The paint is in the current fill pattern.

Figure 2.6

Several slow passes:f
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The spray can works like a can of real spray paint: The slower you
drag the can, the heavier the paint coat will be. Drag faster and the
coat gets lighter. If you use it with a white fill pattern, the spray can is
able to create interesting “feathering” effects.

Opaque, Transparent and Paint on Black work just the same as with
the Paint Brush.

The density of the paint varies according to the line size (see the Line
tool, below). If the line size is small, the paint coat will be dense. A
large line size yields a sparse coat.

The Shift key restricts the spray can to horizontal or vertical
movements.

The Eraser tool provides a quick and efficient way to get rid of
unwanted parts of your pictures. The tool works like a blackboard
eraser (but without the dust). Simply hold down the mouse button
and sweep it back and forth to erase everything underneath it.

R AR
DL
AN NN

NN

Drag the eraser where needed

Remember that if you make a mistake, you can always use the Undo
command (in the Edit menu) to restore anything you erased in your
most recent drag of the Eraser.

To erase the visible portion of the Paint layer, double-click on the
Eraser tool.

To erase the document’s entire Paint layer, double-click the Eraser tool
while holding down the Command and Option keys.
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The Shift key restricts the eraser to horizontal or vertical movement
only.

Use the Paint Bucket tool to fill any enclosed area in the Paint layer.
The bucket uses the currently selected fill pattern.

Paint pours from here

To use the Bucket, click its tool, place the bucket-shaped pointer
within a white area to be filled, and click the mouse button. The paint
flows from the very tip of the bucket’s spill (see Figure 2.8).

The white area to be filled must be completely enclosed in black dots,
or else paint will leak out and spread throughout the document.
Should that happen, remember you can reverse the error by using the
Undo command. Then go back and locate the gap. You might find
the Magnifier tool (see Part 4) helpful in finding the leak.

You may also fill black areas that are completely enclosed by white
dots.

Normally, the paint bucket will fill any connected, enclosed area in the
Paint layer, whether it is visible (within the active window) or not. To
restrict the paint bucket to filling only those portions of the enclosed
area that are visible, hold down the Option key when you click to fill
an area.

To paint a line, click on the Line tool. Its icon looks like a diagonal
line on the palette. The cursor will change to a crosshair shape. Drag
from the starting point and release the mouse at the ending point. The
line is painted in the current line pattern and size.

PART 2: PAINTING
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Holding the Shift key restricts line angles to 45 and 90 degree angles.

135 degrees 0O degrees 45 degrees 0 30
60
90 degrees 90
Drag from here )
while pressing
the Shift key 120

150

B. Option-Shift-
constrained lines

A. Shift-constrained lines

Holding the Shift and Option keys restricts line angles to 30, 60 and
90 degree angles.

Click here fori

unifarm line Click here N
thickness for line Click here to
height set line width

—|

A. Equal height
and width

B. Different height
and width

In the tool palette is a Line Size selector as illustrated in Figure 2.10.
Choose a thickness by clicking in the center of one of the lines. The
selected line thickness is then highlighted by a small arrowhead on
each side.

You can paint lines that are of differing horizontal and vertical
thickness. By clicking on the left side of a line size choice, you select
the height (vertical thickness) of lines. Clicking the right side
determines the width (horizontal thickness). The left arrowhead
indi;:;ttes the height selection while the right arrowhead indicates the
width.

Below the thickest line size choice is a crosshair. This is the Line Size
indicator. The horizontal segment reflects the selected line height, and
the vertical segment, the width. You can think of the segments of the
cross as depicting the thickness of the line if you were to paint it
exactly horizontally or vertically. For example, Figure 2.10B
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illustrates the appearance of the Line Size selector and indicator when
the line height is at its maximum and width is at a minimum.

When the line height is set wide, and the width is set thin (or vice
versa), lines that are neither horizontal nor vertical take on an in-
between thickness.

When the Line tool is selected, the cursor takes the same shape as the
Line Size indicator, telling you how thick the line will be.

The Perpendicular Line functions precisely like the Line tool with the
Shift key constraint engaged. With it, you can paint lines at 45 and 90
degree angles.

Holding down the Option key permits line angles of 30, 60 and 90
dgrees.

The Arc tool paints a quarter of an oval. After selecting the Arc tool,
move the cursor (which will change to a crosshair shape) to the
starting point. Drag the cursor to the ending point and release the
mouse button, The arc outline will be painted in the current line size
and pattern, and its interior will be painted with the current fill pattern.
To paint just the outline of the arc, set the fill pattern to “None” before
you start dragging the cursor.

Drag this way bDrag this way
A
A
B

A. Arc starts horizontally from B. Arc starts vertically from
point A point A

There are two possible arcs that will fit any given pair of starting and
ending points. One arc leaves the starting point horizontally, while the
other starts out vertically. You select which of these you want by
adjusting the cursor’s initial dragging motion. If your cursor starts
out by moving horizontally, you will get an arc that starts the same
way.

The Shift key restricts the Arc tool to generating quarter-circles.
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You will use the Text tool to paint text into your document. You can
incorporate text:

In any font that is currently installed.

In any size, up to 127 points.

In any combination of styles (bold, italic, etc.).

With line spacing of single, 1 1/2, or double spacing.
Justified right, left, or centered.

* Filled with any pattern.

e & & o o

To use the Text tool, click on it in the palette. The cursor changes to
an “I-beam.” Click the mouse wherever you want to paint some text,
SuperPaint displays a blinking vertical bar, which is the text insertion
point, in the current font size. At this point, you can type in some
text. If you make a mistake, you can correct it only by backspacing.

When you first start SuperPaint, the Text tool will use plain, 12 point
Geneva characters. To use something different, make your choices

from the Font, Size, and Style menus before or while entering text.

Once you click the mouse again, the text is “pasted down” and
becomes a collection of dots. That means subsequent font, size and
style selections will no longer affect the painted characters.

The Font menu contains the names of all fonts that are currently
installed. You can select any one of them. Each string of text can
incorporate only one font, size, style, and inter-line spacing. As you
are typing, if you want to end one string and start another, press the
Enter key.
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| size

9 point
10
12 Font Size:

14
,ainsfaﬁed

Current 20font sizes
font size
24

28
36
48
T2
Dther size...

A. Font Size menu B. Other size dialog

The Size menu lets you select from several popular text sizes (see
Figure 2.12A). SuperPaint indicates which of these sizes are installed
by displaying their size numbers in outline style. In Figure 2.12A, for
example, only the 12- and 24-point fonts are installed. If you choose
an uninstalled size, the text might not look as good as it would in an
installed font size.

You can choose a nonstandard size by choosing Other Size... from
the Font Size menu and SuperPaint will display a dialog box (Figure
2.12B) in which you can enter any size you want from 1 to 127.
Once again, if the size you indicate has not been installed, characters
you type might not look very good.

«Plain Text b of
Bold ¥B
fialic %1
Underline
Duitlinle]
fhadom

Text styles

vieft
Ceniler

allghment :
Right

vSingle Space
1 -1/2 Space

Spacing Double Space

Tert Pattern ®T

pattern
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To incorporate text styles, make your selection from the Style menu.
You can choose from Bold, Italic, Underline, Outline, and
Shadow. Examples of these styles can be found in the Style menu
itself (see Figure 2.13). You can form any combination of these
styles. Choosing an already-selected style will turn it off again.
Choosing Plain cancels all other style selections.

There are Command-key shortcuts to choosing some font styles:
Command-B selects Bold style, Command-I selects Italic, and
Command-P (Plain) cancels all style selections.

You can press the Return key while entering text. This brings the text
cursor to the beginning of the next line, aligned beneath the initial
position of the text cursor (the position you originally clicked on, or
where you started a new string by pressing Enter).

When you first start SuperPaint, text lines are spaced closely (single-
spaced). To obtain a different interline spacing, choose the desired
spacing from the Style menu. You can choose from single, 1 1/2, or
double spacing.

You can specify how text lines up with the initial text cursor position.
It will line up with the leftmost character if you choose Left alignment
from the Style menu. This is the initial setting. You can also center
the text, or make it align along the rightmost character by choosing
Center or Right, respectively, from the Style menu.

ffm‘ﬂ'a! cursor

Inifiaf'cursor Initial cursor\

You can specify You can specify You can specify

how text lines up
with the initial
text cursor position

A. Left-aligned

how text lines up
with the initial
text cursor position

B. Centered

how text lines up
with the initial
text cursor position

C. Right-aligned

You can paint characters in any pattern. Set the fill pattern as desired.
Select the Text tool and click in the document to position the insertion
point. Then choose Text Pattern from the Style menu, or press
Command-T. Solid characters (such as those in plain or bold styles)
will be painted in the selected pattern as you type. Hollow characters
(such as Outline and Shadow styles) will be outlined in black, then
filled with the pattern. Figure 2.15 contains some examples.
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Plain  Underline
Bold Outline
/talfric Shadow

The text pattern may be changed (as long as you do not click the
mouse in the document) by selecting a different pattern from the
palette and choosing Text Pattern again (from the Style menu).

The Line Size selector has no effect on text.

Normally, anything you type will obscure whatever is behind it.
SuperPaint lays down a white area beneath each character you type. If
you want the image to show through your text, choose Transparent
Paint from the Paint menu. To return to typing on a white
background, choose Opaque Paint from the Paint menu.

Once you have painted something, it is possible to go back and erase,
move, or modify it. Often, you must first select a region of the Paint
layer that you are interested in before you can do anything to it. In
this section, we will discuss selection techniques, as well as the things
you can do with a selection.

The Selection Rectangle tool shows up on the palette as a dashed
rectangle. With it, you can mark off rectangular areas that you want to
work on. Select the tool. The cursor will change into a dashed
crosshair. Move the cursor to one corner of the area of interest and
drag over to the other corner. When you release the mouse button, the
boundary of the selected region will be highlighted with a pattern of
moving dashes. Because this highlighting is reminiscent of a common
theatrical sign, the Selection Rectangle is sometimes called the
marquee. Bill Atkinson, author of MacPaint, refers to this effect as
“marching ants.”

The entire rectangular region is now selected, white space and all.
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The Shift key restricts the selection area to the shape of a square.

-

e e e - ———

1 A. Option- B. Command-
Original sefection selection selection

The Option key (Figure 2.16A): Upon button release, this lassoes all
shapes enclosed in the rectangle and changes the selected tool to the
Lasso (see the discussion of the Lasso, below).

The Command key (Figure 2.16B): When you release the mouse
button, this causes the selection rectangle to shrink to the minimum
size needed to enclose any shapes inside.

Double-click the Selection Rectangle tool to select all areas currently
visible in the Paint layer. Choose Select All from the Edit menu (or
press Command-A) to obtain a selection rectangle for the entire paint
layer.

Holding down the Command key while choosing Select All from
the Edit menu causes the selection rectangle to shrink to the minimum
size needed to enclose any shapes in the Paint layer.

Holding down the Option key while choosing Select All from the
Edit menu causes all shapes in the Paint layer to be selected. This is
the equivalent of drawing a lasso around the entire document.

The area you want to work on will not always be rectangular. To
select regions of an arbitrary shape, you will need the Lasso. The
Lasso tool looks like a rope with a loop in it. When you select the
Lasso tool, the cursor takes on a shape similar to the tool’s icon.
Move the cursor to the starting point of the boundary. The base of the
lasso cursor is the point that draws the border. Press the mouse
button and pause for a second. Now drag the cursor around the
desired boundary until you reach the starting point again. When you
release the button, SuperPaint will automatically complete the
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boundary, and will select all shapes enclosed therein, not including
exterior white space. Figure 2.17 illustrates this process.

2. ..around
1o here

t.Drag J
from here...

3. Lassoed shape 4. Drag lassoed
is highlighted shape where needed

The Option key causes the lasso to incorporate the entire enclosed area
into the selection, including white space.

Double-clicking the Lasso tool lassoes all visible, on-screen shapes in
the Paint layer.

To move a selection around, you must begin by using the Selection
Rectangle or Lasso tool. Then move the tip of the cursor over a part
of the selection that is inside the moving outline and the cursor will
change to an arrow. When the tool cursor changes to an arrow, you
can drag the selection wherever you want it (see Figure 2.17, step 4).

You can drag a selection outside of the visible portion of the Paint
layer. As the cursor reaches the edge, the document will automatically
scroll in the direction you are dragging (unless you have turned off the
automatic scrolling feature). To stop scrolling, return the cursor to the
visible portion of the document, or release the mouse button.

The Shift key constrains the motion of a dragged selection to
horizontal or vertical movements.

The Option key lets you drag a copy of the selection. The original
remains in place.

Holding Command and Option causes the dragged selection to leave a
trail of copies behind it. You can use this as a different kind of paint
brush.
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There is a holding area in which you can place a single selection for
temporary storage. This area is known as the Clipboard.

To remove a selected portion of the Paint layer and place it in the
Clipboard, choose Cut from the Edit menu, or press Command-X.
The selection will disappear from the document.

You may also place a copy of your selection in the Clipboard without
removing it from the Paint layer. To do so, choose Copy from the
Edit menu, or press Command-C.

To take a copy of the Clipboard contents and place it in your
document, choose Paste from the Edit menu, or press Command-V.
The contents will appear in the center of the display area in whichever
kind of selection (Lasso or Selection Rectangle) you used to place it in
the Clipboard in the first place. You can then drag it wherever you
want it. The Clipboard copy of the selection can be pasted into your
document again and again if you want. It will not be displaced from
the Clipboard until you Cut or Copy another selection.

To remove a selection from the document, choose Clear from the Edit
menu, or simply press the Backspace key. The Clipboard is not
affected by the Clear command or the Backspace key.

The Invert command in the Paint menu changes all white areas to
black, and black areas to white, within the selection. Choosing
Invert again will restore the selection to its original state.

To change a rectangular selection into a mirror image of itself, use the
Flip Horizontal command, from the Edit menu. The right side
becomes the left side, and vice versa. You cannot flip a lassoed
selection.

You can flip a shape so that its top and bottom trade places. Use Flip
Vertical to achieve this effect. You can reverse either kind of flip by
repeating it.

You can rotate a rectangular selection by 90 degrees left (counter-
clockwise) or right (clockwise). To rotate counter-clockwise, choose
Rotate Left from the Edit menu. Choose Rotate Right to rotate
the selection clockwise. You cannot rotate a lassoed selection.
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Free Rotate

Figure 2.18

With these five commands, you can create some interesting effects in
the Paint layer. They let you rotate selections to arbitrary angles,
stretch them, distort them out of shape, lean them over to one side, or
impart an illusion of depth.

Each of these effects necessarily distorts your original image to some
extent. For that reason, you will be better served by keeping a copy
of the original, and using the effects only on copies. If you use more
than one effect on a figure, or use the same effect multiple times, the
distortion can become pronounced.

Patterns do not tend to survive these effects very well. If you know
ahead of time that you will probably be rotating or changing the
perspective (for example) of a figure, paint it without any patterns.
After you have used the effects you need, you can safely go back and
fill them as you wish.

These five effects only work on selections made with the Selection
Rectangle tool. They are not available when you lasso something.

2. .choose
free Rotate..

3. drag ax

L Result
corner handle... * . RESLS

You can rotate a rectangular selection in finer increments than Rotate
Left and Right allow, by using the Free Rotate command in the
Paint menu. After you have made your selection, choose Free
Rotate. The selection rectangle will turn gray, and a small hollow
“handle” will appear at each of the rectangle’s corners. Move the
cursor over one of these handles. When the crosshair cursor turns
into an arrow, you can drag the corner about the center of the
rectangle, until you have reached the angle desired (see Figure 2.18).
You can continue to rotate the selection in this way until you are
satisfied with the rotation angle. To fix the selection in place, click
anywhere in the window other than on a handle. The gray selection
rectangle and handles will then disappear.

29
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This command lets you change the size and proportion of a rectangular
selection. After selecting the portion of the Paint layer to be stretched,
choose the Stretch command from the Paint menu. The selection
rectangle will turn gray and small rectangular handles will appear at
each corner. If you drag one of these handles, the opposite corner
will remain fixed while the selection rectangle grows or shrinks to
follow the cursor (see Figure 2.19). When you release the mouse
button, the contents of the selection rectangle stretch to match the new
size and shape.

Before... ..after stretching

When you stretch a selection by its handles, you adjust its width and
height at the same time. You can adjust only the width or only the
height, if you like. Simply move the cursor over one of the edges of
the selection rectangle until it turns into an arrow, and then drag it. If
you drag a vertical side, you can move it to the left or right. Similarly,
you can drag horizontal sides up and down only.

Pressing the Shift key before dragging a Stretch selection handle
causes the rectangular selection to remain in its original proportions.
For example, if the selection rectangle was initially twice as high as it
was wide, that relationship will still hold after Shift-stretching.

You can also stretch a rectangular selection without using the Stretch
command. After selecting a portion of the Paint layer with the
Selection Rectangle tool, press the Command key while dragging a
corner or a side of the selection rectangle. Holding down the
Command and Shift keys allows you to keep the selection in
proportion as you stretch it (just like pressing Shift while dragging a
stretched selection). These variations were included in SuperPaint
because they are familiar to so many MacPaint users.
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You can distort a rectangular selection much as if you had painted it on
a sheet of rubber, and were tugging on a corner. After making your
selection, choose Distort from the Paint menu. The selection

| rectangle will turn gray, and a small, hollow handle will appear at each

corner. Move the crosshair cursor over one of these handles, until it
turns into an arrow. Then drag the corner wherever you want it. The
contents of the selection will distort accordingly. To stop distorting
the selection, click the cursor anywhere but on a handle. Figure 2.20
illustrates this process. -

Distort| ;DISZC?!'I}
Before.. ..after
= =} D‘ o, o .

t. Select and 2. .. drag handie
choose Siant... gideways...

3. .. drag handle
or vertically..,

SuperPaint lets you slant a rectangular selection to the right or left (or
up or down). Once you have made your selection, choose Slant
from the Paint menu. The selection rectangle will turn gray, and a
small, hollow handle will appear at each corner of the selection
rectangle. Move the crosshair cursor over one of these handles, until
it turns into an arrow. Then drag the corner left or right (or up or
down), until the selection is slanted to the desired degree. If your
initial dragging motion is vertical, you can only adjust the height of the
side attached to the handle. Conversely, if your initial dragging
motion is horizontal, you can adjust only the side-to-side position of
the side attached to the handle.
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To create an artificial perspective effect, you can stretch or shrink the
top or bottom edge of a rectangular selection. This can give the
illusion of depth, when used properly. After making your selection,
choose Perspective from the Paint menu. The selection rectangle
will turn gray, and a small, hollow handle will appear at each corner
of the selection rectangle. Move the crosshair cursor over one of these
handles, until it turns into an arrow. Then drag the corner left and
right, until you have achieved the desired perspective effect. See
Figure 2.22.
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Before... ..after

It is possible to take a portion of the Paint layer and move it into the
Draw layer. To do so, begin by selecting the desired region with the
Selection Rectangle or Lasso tool. Then choose Copy to Drawing
from the Edit menu, or press Command-E. The screen flashes to tell
you something happened.

All the dots in the selection are copied to the Draw layer, and are
contained in a single painted object. That object is simply a collection
of dots. Itis not the same as a normal object created in the Draw
layer.

PART 2: PAINTING

WwmwmmiIuwimimyly

1

1

1
|

mmn

hmiymin

1
I

MyNwmEmMmmmIm~»nw



Part 3:
Drawing

mmmmmmmmmmmmmmuEmmmmumummmmpmmmm .



CONSTRAIN-
ING

TOOLS

Patterns and
Borders

34

Unlike painted shapes and lines, objects created in the Draw layer are
not just a collection of dots. Each object is an entity. Inside
SuperPaint, an object is stored as mathematical information. In the
technical jargon, they are sometimes called “vector” objects.

Objects created in the Draw layer will normally look better when
printed than they do on the screen. That’s because printers usually
have higher resolution than the Macintosh screen. SuperPaint takes
the formula that defines the object and turns it into an image that
contains as many dots per inch as the printer can produce. For
example, using Apple’s LaserWriter, these “vector” objects are printed
at 300 dots-per-inch resolution.

Constraining is used to restrict an object that you are drawing to some
particularly useful subset of the tool’s capabilities. For example,
when drawing an unconstrained line, you can select any pair of
endpoints. When drawing a constrained line, though, SuperPaint will
restrict it to certain angles (e.g., vertical, horizontal, 45 degrees).
Once you have selected a tool, constraints are invoked by pressing and
holding one or more keys (usually Shift, but sometimes one or more
of Shift, Option or Command) while you press the mouse button to
use the tool. Generally, you must hold the constraint key(s)
throughout that use of the tool.

Objects drawn with constraints do not remember these constraints.
For example, let’s say you create a 45 degree line by using the Shift
constraint with the Line tool. If you go back and modify the location
of an ending point, you must press Shift to maintain the constraint. If
you don’t, you can move the ending point anywhere.

For this reason, the Circle and Perpendicular Line tools are very
useful in the Draw Layer. When you draw with these two tools,
SuperPaint remembers that the circle or constrained line was created
by these tools. When you modify a circle, for example, it will always
remain a circle.

The description of each tool includes all the constraint variations.

Objects you draw will use the current line size and the current line and
fill patterns. You can change these parameters at any time. When you
set different patterns or line sizes they are immediately applied to all
selected objects. For more on this subject, see the discussion of
Selection, a little later in this section.
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Figure 3.1

Normally, you will draw an object by specifying the locations of its
corners. Sometimes, that is not the most convenient way. That’s

why SuperPaint includes the Draw from Center option. You can enter
this mode by choosing Draw From Center in the Options menu,
or by double-clicking on certain tools, namely the Rectangle, Rounded
Rectangle, Oval or Circle. The affected tools reflect this mode by
displaying a small crosshair. While in this mode, pressing the mouse
button specifies the center of the shape, while releasing the mouse
(after dragging) specifies the outside location,

To return to the initial shape drawing mode, choose Draw from
Corner in the Options menu, or double-click one of the four tools.

Objects remember which mode they were drawn in. When you resize
an object, it will react accordingly. If it was created in Draw from
Corner mode (the default setting), one corner will remain fixed while
you adjust an edge or the opposite corner. If it was created in Draw
from Center mode, the object’s center will remain fixed while you
adjust its corners or edges. When you select a shape that was created
in Draw from Center mode, it displays a small crosshair at its
centerpoint.

This tool lets you draw rectangular shapes. When you select it, the
cursor takes the shape of the Line Size selector (a cross that reflects
the border line’s thickness). In Draw from Corner mode, move the
cursor to a starting point, press the mouse button to select one corner,
then drag the rectangle’s opposite corner in any direction, as in Figure
3.1A.
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In Draw from Center mode, you press the mouse button on the center
point, then drag the rectangle’s corner wherever you want it (see
Figure 3.1B).

The Shift key restricts this tool to the creation of squares.

This tool works just like the Rectangle tool, except it draws shapes
with rounded corners.

The Shift key lets you create squares with rounded corners.

The Oval tool lets you draw oval objects. You actually specify a
rectangle, within which SuperPaint draws an oval. Draw from Center
works just as with the Rectangle tool.

The Shift key restricts this tool to creating circles.

The Circle tool works almost exactly like a constrained oval. With it,
you can draw only circles. The difference between a constrained oval
and a circle makes itself evident when you resize the object. A
constrained oval can be stretched out of shape, while a circle always
remains circular,

None. .

The Polygon tool lets you draw a shape with as many sides as you
want. Click once to set the starting point. Move the pointer and click
at the second corner, then the third, etc. Double-click the last corner
to complete the polygon, or click outside the window.

If the currently selected fill pattern is anything other than “None,”
SuperPaint will automatically draw the final edge and fill the polygon
with the current fill pattern.

If the selected fill pattern is “None,” when you double-click to finish
the polygon, the cursor location becomes the final point. Unlike a
filled polygon, a line will not be drawn from that point to the
beginning point. You can go back and fill the polygon later, but that
last edge will never be drawn. See Figure 3.2 for examples.
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I With a fill

pattern of "None,” y(:sws(;alrfa
click here... ey, pattern...

2. ..then here..

3. ..and then J _the polygon is filled, but
double-click here still has no final edge.

The polygon’s border is drawn according to the current line size.

You can adjust the location of a polygon’s vertices, or even add new
vertices. See the discussion of the Reshape command, later in this

section.

The Shift key constrains the sides of the polygon to angles of 45 and
90 degrees.

Holding the Shift and Option keys constrains polygon sides to angles
of 30, 60, and 90 degrees.

Either constraint remains in effect only so long as you hold the key(s)
down. You can even change (or eliminate) constraints in the midst of
adding an edge to the polygon. If you press the Shift key while
drawing an edge, it immediately jumps to the nearest permitted angle.
If you release the Shift key, it starts following the cursor again.
Likewise for the Shift/Option constraint.

The Arc tool draws a quarter of an oval. After selecting the Arc tool,
move the cursor (which will change to look like the Line Size
indicator) to the starting point. Drag the cursor to the ending point and
release the mouse button. The arc outline will be drawn in the current
line size and pattern, and its interior will be filled with the current fill
pattern. '
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Drag this way Drag this way
A
A
B
B
A. Arc starts horizontally from B. Arc starts vertically from
point A point A

There are two possible arcs that will fit any given pair of starting and
ending points. One arc leaves the starting point horizontally, while the
other starts out vertically. You indicate which of these you want by
adjusting the cursor’s initial dragging motion. If your cursor starts
out by moving horizontally, you will get an arc that starts the same
way.

Use the “None” pattern to draw an unfilled arc.

Arcs are not restricted to 90 degree wedges. See the description of the
Reshape command, later in this section.

The Shift key restricts the Arc tool to generating quarter-circles.

The Freehand tool allows you to draw any shape you want. Begin by
clicking on the Freehand tool. Move the cursor to the starting point,
then drag it to outline the shape you want. Release the mouse button
to define the ending point. If you have selected a fill pattern other than
“None,” SuperPaint will automatically connect the starting and ending
points before filling the shape.

If the selected fill pattern is “None,” when you release the mouse
button to finish the shape, the cursor location becomes the final point.
A line will not be drawn from that point to the beginning point. You

can go back and fill the shape later, but that last edge will never be
drawn.

None.
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To draw a line, click on the Line tool. The cursor will change to a
cross shape. Then drag from the starting point and release the mouse
at the ending point. The line is drawn in the current line pattern and
size.

Holding the Shift key restricts line angles to 45 and 90 degrees, as in
Figure 3.4A.

135 degrees O degrees 45 degrees 0 30

[10]

Q0 degrees 90
Drag from here
while pressing

+he Shift key ‘20

150

B. Optlon-Shift-
constrained lines

A. Shift-constrained lines

Holding the Shift and Option keys restricts line angles to 30, 60 and
90 degrees, as in Figure 3.4B.

The Perpendicular Line functions precisely like the Line tool with the
Shift key constraint engaged. With it, you can draw lines of 45 and
90 degrees. SuperPaint remembers that lines drawn with the
Perpendicular Line tool are restricted to 45 and 90 degree angles.

Holding down the Option key permits line angles of 30, 60 and 90
degrees. Lines drawn this way retain the constraint. That is, you
cannot change such a line to attain a 45 degree angle.

In the tool palette is a Line Size selector as illustrated in Figure 3.5.
Select a thickness by clicking in the center of one of the lines. The

selected line thickness is then highlighted by a small arrowhead on

each side.

Click here fon
uniform fine
thickness

mere to

set fine width

Click here
for line
height

A. Equal height
and width

B. Different height
and width
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You can also draw lines that are of differing horizontal and vertical
thickness. By clicking on the left side of a line size choice, you select
the height (vertical thickness) of lines. Clicking the right side
determines the width (horizontal thickness). The left arrowhead
indicates the height selection while the right arrowhead shows the
width.

Below the thickest line size choice is a cross. This is the Line Size
indicator. The horizontal segment reflects the selected line height, and
the vertical segment, the width. You can think of the cross segments
as depicting the thickness of the line if you were to draw it exactly
horizontally or vertically. For example, Figure 3.5B illustrates the
appearance of the Line Size selector and indicator when the line height
is at its maximum and width is at a minimum.

When the line height is set wide, and the width is set thin (or vice
versa), lines that are neither horizontal nor vertical take on an in-
between thickness.
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Thin height, thick width Thick height, thin width

When drawing any kind of shape, the cursor takes on the shape of the
Line Size indicator, telling you how thick the line will be.

Line size changes are immediately applied to all selected objects.

The Text tool is used to add text objects to your document. You can
incorporate text:

* In any font that is currently installed.

* In any size, up to 127 points.

 In any combination of styles (bold, italic, etc.).

* With line spacing of single, 1 1/2, or double spacing.
* Justified right, left, or centered.

* Filled with any pattern.

PART 3: DRAWING

LUSSL UL L Ut L UL AL L LN L OO L. L L O RO L, (L L Lo,



BT AT AT T AT AT Y T Y T AT Y AT T Y A 1 o

Figure 3.7

Text objects print with the maximum resolution available on the printer
you use, providing you choose the proper font for the printer. On the
LaserWriter, for example, Helvetica, Times, Symbol, and Courier
always print at the highest possible resolution.

A text object is a rectangle into which you can type or paste text.
Within the rectangle, text automatically adjusts to fill the full width of
each line, without chopping words in half, if possible. This is known
as word wrap. What happens when the text reaches the bottom of the
rectangle depends on the kind of text object.

There are two kinds of text objects, fixed and expanding.

In a fixed text object, you manually set the height and width of the
rectangle. When the text reaches the bottom of the rectangle, no more
is displayed. Additional text is retained in the text object, but it cannot
be seen.

You can only set the width of an expanding text object’s rectangle. As
you type more text, the bottom of the rectangle automatically expands
to contain it. Conversely, if you delete characters from an expanding
text object, the bottom of the rectangle shrinks as necessary.

41

Note
fixed/ expanding
indicators
[ L 3 ] o] =
#An expanding A fixed Text
Text ob ject ob ject does not
ad justs to fit. g 7Aietiafn
[ ] | ]
When selected, text objects display a Text Type indicator, between the
top right- and left-hand handles (see Figure 3.7). To change a text
object from fixed to expanding, or vice versa, select it and click on the
Text Type indicator. The indicator looks like a small, hollow
rectangle on fixed text objects. On expanding text objects, it looks
like a downward-pointing arrow.
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To create a text object, begin by clicking on the Text tool in the palette.
The cursor will change to an “I-beam.” To create an expanding text
object, drag the mouse to define its width (remember that its height is
automatically determined). Fixed text objects can be created by
holding down the Option key while dragging. You may specify both
the height and width of a fixed text object.

To help you place a text object precisely, you can temporarily change
the I-beam cursor into a crosshair by holding down the Command
key. Place the center of the crosshair where you want the upper left-
hand corner of the text object to begin. Then, press the mouse button
and drag to the right. Release the button when the desired width is
reached.

Once you have created a text object, SuperPaint outlines it with a
dotted line, and temporarily fills it with an opaque white background,
against which you can type. The rectangle contains a blinking vertical
bar (the insertion point) in the current font size. Figure 3.8 illustrates
this process.

/ 3. ..and begin typing.

f |

I.Drag from here...

i
2. .10 here.. J

At this point, you can begin to enter text by typing at the keyboard, or
even by pasting from the Clipboard. If you make a mistake while
typing, correct it by backspacing. Move the insertion point anywhere
within the object by clicking the cursor where you want it. Select text
by dragging the cursor from the first character you want through to the
last. Then Cut, Copy, Clear, Paste, or type right over the selection.
Double-clicking the cursor within the text will select a word.

To edit an existing text object, choose the Text tool, and click the

I-beam cursor inside it. You can then backspace, insert, or replace
text that was already in the object.
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Fonts, Sizes,
and Styles

Figure 3.9
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‘When you first start SuperPaint, text objects use plain, 12 point

Geneva characters (a conservative correspondence typeface). To use a
different typeface, make your choices from the Font, Size, and

Style menus. Change these parameters on a preexisting text object
simply by selecting it, then choosing from the appropriate menus.

The Font menu contains the names of all fonts that are currently
installed. You can choose any one of them. Each text object can
incorporate only one font, size, style combination, and inter-line
spacing.

9 point
10
/- ﬂ&\ Font Size:
14
installed
Current font sizes|
font size ;V
28
36 (cancet)
48
T2
Bther size...
A. Font Size menu B, Other size dizlog

The Size menu lets you select from several popular text sizes (see
Figure 3.9A). SuperPaint indicates which of these sizes are installed
by displaying their size numbers in outline style. In Figure 3.9A, for
example, only the 12- and 24-point fonts are installed. If you choose
an uninstalled size, the text will not look as good as it would in an
installed font size. If you are using a LaserWriter font (e.g.,
Helvetica, Times, etc.) and printing on a LaserWriter, this will not be
a problem. The text will come out just fine. Otherwise, the printed
results will look similar to what you see on the screen.

You can choose a size not included in the Size menu by choosing
Other Size... from the Font Size menu. SuperPaint will display a
dialog box (Figure 3.9B) in which you can enter any size you want.
If the size you request has not been installed, characters you type
might not look very good. Nevertheless, SuperPaint will try to
approximate the typeface as best it can. If you use a LaserWriter font
(e.g., Helvetica, Times, etc.), it will come out very nicely when
printed on a LaserWriter, regardless of whether the size is installed.

When very large size fonts or certain styles are used, parts of the text

may appear to be cut off on the screen. This text will be printed
properly, despite the incorrect screen display.

PART 3: DRAWING



Figure 3.10

Line Spacing

Aligning the
Text

Figure 3.11

44

To incorporate text styles, make your choice from the Style menu.
You can choose any combination of Bold, Italic, Underline,
Outline, and Shadow. The Style menu itself (see Figure 3.10)
contains examples of these styles. Choosing an already-selected style
will turn it off. Choosing Plain cancels all other style selections.

vPlain Text P
Bold ®B
Text styles| fiakic *®1
Underiine
[0uitiine]
Shademm

wleft
alighment | center

Right

vSingle Space
spacing 1-1/2 Space
Double Space

pattern Tent Pattern T

There are Command-key shortcuts to choosing some font styles:
Command-B chooses Bold style, Command-I chooses Italic, and

| Command-P (Plain) cancels all style choices.

Text objects can contain multiple lines. You can start a new line by
pressing Return. Lines are also formed automatically, as you type
past the rightmost border of the text object.

When you first start SuperPaint, text lines in new objects are spaced
closely (single-spaced). To obtain a different interline spacing,
choose the desired spacing from the Style menu. You can choose
from single, 1 1/2, or double spacing.

You can specify how text will line up relative to the object rectangle.
All lines will start at the leftmost column if you choose Left alignment
(from the Style menu). This is the initial setting. You can also center
the text, or make it align along the rightmost column by choosing
Center or Right respectively, from the Style menu. See Figure
3.11 for examples.

lighed left aligned righ
f s aligned to center 94719 7\

= ¥ [ 1] > =E L 2
You can specify You can specify You can specify
how textlines upin  how textlines up in how textlines up in
a ext object a text object a extobject

L ] [ 1] EE [ ]
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Setting the
Text, Line, and
Fill Patterns

Figure 3.12

Figure 3.13

Not on the
LaserWriter

Resizing Text
Objects

Characters can be drawn with any pattern. First, before selecting the
text object, click on the fill pattern desired (this prevents the text object
from being filled with the pattern). Next, select the text object and
then choose Text Pattern from the Style menu, or press
Command-T. Solid characters (such as those in plain, italic, or bold
styles) are drawn in the selected pattern. Hollow characters (such as
outline and shadow styles) are outlined in black, then filled with the
pattern. Figure 3.12 illustrates the various styles of text drawn with a
pattern.

Plain  Underline

Bold Outline

/ratic  Shadow

Initially, a text object is filled with a pattern of “None.” Its border’s
line pattern is also “None.” You can adjust the line size and patterns

in exactly the same way as for Rectangle objects. Select the text object
and click on the patterns and line sizes you want. Figure 3.13

lustrates his,
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In general, text consisting of patterns cannot be printed on a
LaserWriter as shown on the screen. To produce these effects on the
LaserWriter, the text must be in the Paint layer.

Like other objects in the Draw layer, you can adjust the size of text
objects. Using the Selection tool, click on the object, then drag a
corner handle.

You can only set the width of expanding text objects. The height will
automatically adjust as necessary to accommodate the text inside. If
you drag a handle at the top of an expanding text object, you can shift
the attached side edge to the right or left. The top edge will
automatically shift up or down to accommodate the text inside.
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Likewise, dragging a handle at the bottom of the text object causes the
top edge to remain fixed while the bottom edge floats to accommodate
the new width. Figure 3.14 illustrates this.

Opposite handlie
/ remaihs sfm‘r’onarm

[ ] L | | |
Youcan o’nly set the You can only s’et the width of
width of expanding expanding textobjects, The height
textobjects. The will automatically sdjust as necessery

height will 0 accommodate the text inzide.

automatically adjust a L

a3 necessary o
accommodate the text

inside.

. ' R
) 2. .1o here /

I. Drag from here...

With fixed text objects, you can drag the corner handles anywhere you
want. The text inside will reformat to try to stay inside the new
rectangle. If the rectangle is too small, some of the text will be cut off
(it will reappear when you expand the rectangle). If it is too large,
you will simply have some empty space at the bottom.

In either case, you can rapidly correct the size of a fixed text object by
clicking twice on its Text Type indicator (the hollow rectangle at the
top center of the selected object). This temporarily changes it to an
expanding text object (at which point the height of the rectangle
adjusts automatically), then back again.

You can resize just the width or just the height of a fixed text object by
holding down the Shift key while dragging a handle. If you first drag
the handle sideways, you can only adjust the width. Dragging
vertically lets you change only the height.

Once you have drawn an object, it is possible to go back and clear,

.| move, duplicate, or modify it. To do so, you must first select the

object of interest. This section discusses how you select objects, and
what you can do with those selections.

Begin by clicking on the Selection tool from the palette. The cursor

remains in the shape of an arrow as long as the Selection tool is in
effect.
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To select a single object, all you need do is click the cursor on a filled
portion of the object. In other words, if an object is filled with any
pattern except “None,” you can select it by clicking in its interior or on
its border. If the object is filled with a pattern of “None,” you must
click on its border to select it.

You can always select a text object, a LaserBits object (see Part 5), or
a painted object by clicking within its interior, regardless of its fill

pattern,
f Handle 5\

| ] = |
\Handlesj

If you have successfully selected the object, it will display its handles
(see Figure 3.15). We will discuss the handles’ usefulness later in
this section.

Click here

Sometimes you will want to work with more than one object at a time.
This is most useful when you want to make the same change (e.g., fill
pattern, border thickness, printing color, etc.) to several objects at
once.

There are four ways to select multiple objects at one time.

Normally, when you click the Selection tool on one object, all other
selections are automatically canceled. If, however, you hold down the
Shift key when you click on an object, previously selected objects
remain selected, and the new object becomes selected as well (see
Figure 3.16).

NGOHHHHL0
AAANANIONN

WA
Click here, while J ' Adc{fﬁona! ob ject )
pressing the Shift key is selected
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Likewise, if you have multiple objects selected, you can deselect one
of them by holding Shift while clicking on a filled portion of it.

In general, holding Shift while clicking on an object alternately selects
or deselects it, while preserving the selection status of other objects.

Another way to select several objects that are in close proximity to
each other is to enclose them in a selection rectangle, as illustrated in
Figure 3.17. With the Selection tool in effect, place the cursor at one
comer of an imaginary rectangle that will fully enclose the intended
selection. Then drag the cursor to the other corner of that rectangle.
SuperPaint will display a dotted rectangle to indicate the selection area.
When you release the mouse button, all objects completely contained
in the rectangle are selected. All other objects are deselected.

i.Drag from here...

3. Ob jects encliosed 5
2. .10 here rectangte are selected

The selection rectangle can be used in conjunction with the Shift key.
If you hold the Shift key down while drawing a selection rectangle,
the selection status of all completely enclosed objects will be reversed.
That is, enclosed objects that were selected will become deselected,
and vice versa. The selection status of objects outside the selection
rectangle is unaffected. This is just like using the Shift-click technique
on all enclosed objects.

Often, you will need to treat a group of associated objects as if they
were a single object. For example, you may have created a cube out
of rectangles and polygons. Most of the time, you'll want to move or
change the cube, and not one or two of its individual objects. You
could use a selection rectangle every time you select the cube, but that
can be inconvenient. To ease the task, you can tell SuperPaint to
consider multiple objects to be a group. Selecting one member of the
group selects them all.
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To create a group, begin by selecting all its members. Use the Shift-
click or selection rectangle techniques. Then choose Group from the
Draw menu (or press Command-G). All the individual objects’
handles will disappear, to be replaced with a single set of handles for
the group, as in Figure 3.18. So long as the objects remain in the
group, they are treated as a single object. :

I Select all object 2. After Group
to include in the commahd, group
group (nhote: teardrop ob jects share
is naot selected) common handles

You can also release a group, to gain access to individual objects.
Choosing Ungroup from the Draw menu (or pressing Command-U)
replaces the selected group’s single handle set with all its constituent
objects’ handles. SuperPaint now treats these as discrete objects
again.

To select all objects in the Draw layer, choose Select All from the
Edit menu, or press Command-A. Keep in mind that some of the
objects selected may not be visible in the window.

To deselect all objects (e.g., select no object), click on a shape tool
(e.g., Rectangle, Polygon, etc.) or click anywhere in the document
where there are no objects.

To move a selection, press and hold the mouse button while the
selection cursor is over a filled portion of a selected object (not one of
its handles). Then, drag the selection wherever you want it. Release
the mouse button when the object has reached its destination. Objects
remain selected after you drag them around. Figure 3.19 illustrates
this process.

@@@

I. Drag fram her 2. .1To here
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As a shortcut, you can select and drag an object (or a Group of
objects) in one motion. With the Selection tool engaged, move the
cursor over a filled portion of an unselected object, and press the
mouse button. Then, drag the object to its destination.

Normally, SuperPaint shows you a fully rendered version of the
selection while you drag it around. Because large or complex
selections can take a extra time to draw, the motion of the dragged
selection can appear to lag behind the mouse. Actually, the selection
itself follows the cursor perfectly. It is just the image of the selection
that temporarily lags behind. When you release the mouse button, the
selection will be drawn at precisely the corresponding position in the
document. To be certain of the selection’s placement, just pause
before releasing the button.

If you prefer to eliminate the lag, try choosing Drag as Qutlines
from the Draw menu. Instead of depicting the complete selection
while dragging, SuperPaint will draw only a dotted outline. The
outline tracks the mouse more closely, since it is easier to display. As
soon as you finish dragging the selection, it will once again be
displayed normally. To return to the original dragging style, choose
Drag as Objects from the Draw menu.

Holding the Shift key down while dragging a selection restricts its
motion to horizontal or vertical, whichever is the initial direction of the
movement.

After you have drawn an object, you can always go back and alter its
shape. Begin by selecting the object. Four corner handles will
appear. Move the cursor onto a handle and drag it (see Figure 3.20).
The handle at the opposite corner will remain fixed, while the dragged
corner follows the cursor as you wish. Use this process to shrink the
object, expand it, or adjust its ratio of height to width.

This corner
remains stationary %
' H ; ' 2. ..1to bhere
I. Drag '
from here..
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Note that you cannot resize multiple objects at one time if they were
individually selected. You cannot resize LaserBits objects. You can
resize a Grouped set of objects.

The Shift key constrains the resize operation to a single dimension?
horizontal or vertical. The constraint dimension depends on the initial
drag direction. If you begin by dragging the handle horizontally, you
will only be able to resize horizontally.

Holding the Command and Shift keys while resizing causes the object
to maintain its original proportions. In other words, you can expand
or shrink it, but its ratio of height to width will remain the same. An
example: Say the original selection’s height is 4 inches, and its width
is 2 inches. If you resize it proportionally so that its height becomes 2
inches, its width will be 1 inch.

There is a holding area in which you can place a selection for
temporary storage. This area is known as the Clipboard.

To remove a selection from the Draw layer and place it in the
Clipboard, choose Cut from the Edit menu, or press Command-X.
The selection will disappear from the document.

You can also place a copy of your selection in the Clipboard, without
removing it from the Draw layer. To do this, choose Copy from the
Edit menu, or press Command-C.

To take a copy of the Clipboard object and place it in your document,
choose Paste from the Edit menu, or press Command-V. The
Clipboard contents will appear in the center of the viewing area. You
can then drag it wherever you want it. The Clipboard copy of the
selection can be pasted into your document again and again, should
you so desire. It will not be displaced from the Clipboard until you
Cut or Copy another selection.

If you want to make a copy of a selection and have it appear
immediately in the document, choose Duplicate from the Edit menu,
or press Command-D. The selection will remain in place, and an
identical copy will appear nearby. You can drag the duplicated
selection wherever you want it.

The Duplicate command has a handy feature that distinguishes it
from Copy/Paste. The first time you duplicate a selection, the new
copy usually appears to the right, and slightly below the original.
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Now, let’s say you move this copy two inches to the right of the
original, and then duplicate the new copy. This second duplicated
object will appear two inches to the right of the second, if there is
room for it. In fact, if you continue to use the Duplicate command,
the cloned objects will line right up. Figure 3.21 illustrates this effect.
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To remove a selection from the document, choose Clear from the
Edit menu, or simply press the Backspace key. The Clipboard is not
affected by the Clear command.

It is possible to take a selection in the Draw layer and move it into the
Paint layer. Start by selecting the desired object(s). Then choose
Copy to Painting from the Edit menu, or press Coramand-E. The
screen flashes to tell you something has happened. An image of the
selected objects has been copied to the Paint layer.

The image that appears in the Paint layer is, of course, a collection of
dots. It is not an object entity like in the Draw layer. These dots can
never be reconverted to become a true object.

The Clipboard is not affected by the Copy to Painting command.

Just as you can alter the size of previously-drawn objects, you can
also change their fill patterns, line patterns, and line widths. Begin by
selecting the object or objects you want to alter. Then, make your
changes via the pattern palette (see Part 1), or with the Line Size
selector.
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A painted object is a rectangle which contains a collection of dots from
the Paint layer. You cannot actually create painted objects in the Draw
layer. You must create them elsewhere, and then paste them into the
Draw layer.

The most common source of images for painted objects is the Paint
layer. First, select a portion of the Paint layer (with the Selection
Rectangle or Lasso) and cut or copy it to the Clipboard with the
appropriate Edit menu commands. Then you can switch to the Draw
layer and paste the Clipboard contents into the document.

While in the Paint layer, you could also move a selection directly to
the Draw layer with the Copy to Drawing command in the Paint
menu.

Finally, selections that are cut or copied from some other kinds of
documents will create painted objects when you paste them into the
Draw layer. In particular, a selection from a MacPaint document can
produce a painted object.

A painted object is contained in a rectangle that is initially filled with a
pattern of “None,” and has a border pattern of “None.” Thus, painted
objects initially appear to be transparent, and all objects behind them
show through. To provide an opaque background for a painting,
select a fill pattern as you might for a rectangle or text object. You can
also frame the painted object by setting a border pattern and size.

To adjust the size of a painted object, first select it (with the Selection
tool), then drag a handle until the image has the size and shape you are
looking for. Also see the discussion of the Scale Selection command,
in Part 4.
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Since a painted object is a collection of dots, stretchmg it to make it
larger will usually cause distortion.

Holding down the Shift key while resizing a painted object lets you
stretch it horizontally or vertically, depending on your initial drag
direction.

Holding the Command and Shift keys while dragging the handle
forces the resized object to maintain its original proportions (i.e., it
will keep its original ratio of height to width).

Please note that the descriptions of the Group ,Ungroup and Duplicate
commands are included in the Selection discussion, earlier in Part 3.

Objects in the Draw layer can overlap. Usually, recently created
objects are displayed in front of older ones. It is as if you were
throwing cards on the table. They stack up. What if you want to
rearrange the objects? SuperPaint provides two commands to help
you do this.

To move an obscuring object behind all others, select it and choose
Send to Back from the Draw menu.

To take a partially obscured object and bring it out on top of all others,
click on the visible portion and choose Bring to Front from the
Draw menu. If the object is entirely obscured, you can still bring it to
the front. Simply send the intervening objects to the back of the Draw
layer (with Send to Back), until you can see the one you want.
Move it into a clear space (or place it in the Clipboard), and then
restore the objects you moved to their original order. Finally, drag the
newly revealed object where you want it. Figure 3.23 illustrates this
process.

54

first, select ..then Send to Back... ..or Brihg to Front
the object...
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Reshape

Figure 3.24

Figure 3.25
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The Reshape command lets you adjust the shape of arcs or polygons.
First, click on the Selection tool, then click on the object that you want
to modify.

. Select 2. .choose
the arc... Reshape...

If the selected object is an arc, the Draw menu contains the command
Reshape Arc. When you choose it, the four corner handles are
replaced with two (see Figure 3.24). There is one handle for each end
of the arc. Drag these handles to open or close the arc. By reshaping
an arc, you can create a pie-section of any angle you want.

If you select a polygon, this command reads Reshape Polygon. It
allows you to adjust the positions of individual vertices (corners) of a
polygon. You may only reshape one polygon at a time. When you
choose this command, the four corner handles disappear, to be
replaced by one handle at each vertex. To adjust the position of a
vertex, drag its handle where you want it.

] a

R— [

I.Select 2. ..choose 3. .draga
polygon... Reshape... vertex handle

With the Reshape Polygon command, you can add new vertices.
Select the polygon and choose the Reshape command. Then hold
down the Command key as you drag a handle. The vertex you drag
will remain in place. Instead, SuperPaint will insert a new vertex
between the selected one and the next in the sequence (the one you
originally drew after the dragged vertex).
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In Figure 3.26, for example, assume the triangle was drawn in vertex
order 1, then 2, then 3. After choosing Reshape from the Draw
menu and Command-dragging vertex 2, the new vertex has been
inserted between vertices 2 and 3.

2 2 2
1 1
3 5 3
. Select polygon 2...press 3. ..release
and choose Command key mouse hutton
Reshape... and drag vertex.. ahd Command key

SuperPaint can adjust objects’ positions so that they line up along their
tops, bottoms, sides, etc. To use this capability, select the objects you
want to align, and choose Align Objects... from the Draw menu.
SuperPaint will display a dialog like the one in Figure 3.27. In this
dialog, you may specify a horizontal alignment (i.e., line the objects

| up along their left or right edges, or their centers), or a vertical

alignment (i.e., line them up along their top or bottom edges, or their
centers), or both.

Align Objects...
@ Left Sides (O L/R Centers () Right Sides
O Tops O T1/B Centers O Bottoms

If you specify just a horizontal alignment, SuperPaint will move the
objects so that they line up vertically. Specifying a vertical alignment
causes the objects to line up horizontally. If you specify both vertical
and horizontal alignment, the objects will stack up on top of each
other.

After you make your alignment choice, click the OK button to line the
objects up. Click the Cancel button to leave the objects as they were.
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Figure 3.28 illustrates horizontal and vertical alignment of objects.
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When you first start SuperPaint, drawing a new object (except for an
object drawn with a pattern of “None”) will obscure any older objects
beneath it. If you would like to be able to see through holes in an
object’s pattern, choose Transparent from the Draw menu. You
can change the transparency of existing objects by selecting them and
then using the Transparent command.

To prevent covered objects from showing through, you must make the
object opaque. Select the object and choose Not Transparent from
the Draw menu.

2 trans parent &

Figure 3.29 shows the difference between opaque (Not Transparent)
and transparent objects, respectively. Transparent objects are
particularly useful for creating shadow effects, as in Figure 3.30.
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Note: Objects print transparently on an ImageWriter, but not on a
LaserWriter. On a LaserWriter, objects are always opaque, regardless
of the Transparent/Not Transparent setting, except for painted objects,
which are always transparent.

You can assign printing colors to objects. If you print a document on
a color-capable printer, such as the ImageWriter 11, colored objects
will then print in color. On monochrome printers, like the LaserWriter
or the original ImageWriter, colored objects simply print in black and
white.

To add printing colors to your Draw layer, begin by choosing Show
Color Palette from the Options menu. SuperPaint will replace the
pattern palette with a palette of the available colors, as depicted in
Figure 3.31.

| g ] ForecRouND | Black | Red [ Green orange [ Purpie]vallow]

| BACKGROUND Red | Green | Blue |Orange|Purpie|Yellow |

You must separately specify the colors to be used in an object’s fill
pattern and those to be used in its line pattern. At the left-hand side of
the color palette is a line/fill selector which works just like the one for
patterns. Click on the large, filled rectangle to adjust the fill colors, or
on the narrow rectangle to adjust line colors. An arrowhead indicates
which (line or fill) has been selected.

You may specify both a foreground and a background color. Black
dots on the screen will print in the foreground color, while white dots
on the screen print in the background color. You cannot specify a
foreground color of White, nor a background color of Black.
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For example, let’s color a stripe-filled rectangle that has a solid Black
border. Begin by selecting it. To color the border, click on the left-
hand (line) side of the line/fill selector. Then, click in the Foreground
portion of the palette labeled Purple. You need not set the background
color of a solid Black pattern. Next, click on the right-hand (fill) side
of the line/fill selector. Let’s make the pinstripes blue, on a yellow
background. Choose Blue in the Foreground portion of the color
palette, and Yellow in the Background portion.

To find out what an object’s printing colors are, display the color
palette and click on the object. The color palette highlights the selected
object’s foreground and background colors according to the line/fill
selector setting. When set to “line,” the color palette displays the
current line colors. Likewise for “fill.”

When you first create an object, its line and fill colors are the same:
The foreground color is Black and the background color is White.

To restore the pattern palette, choose Pattern Palette from the
Draw menu.
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To create a new document, choose New from the File menu (or
press Command-N). SuperPaint will open a window with a blank
document in it. A freshly created document is automatically given the
name “Untitled - #”°, where “#” is replaced by a number (e.g.,
“Untitled - 17, etc.). You can change the name when you save the
document on disk.

Before you can work with an existing document, SuperPaint must
first open it. Opening a document causes it to be loaded from disk
into the computer’s memory and then displayed. To open a
document, begin by choosing Open from the File menu (or press
Command-O). The dialog illustrated in Figure 4.1 will be displayed.
Initially, the window within the dialog displays all folders and
SuperPaint documents in the current folder (the one from which you
started SuperPaint). Besides SuperPaint documents, you can also
open three other kinds of documents by clicking on the appropriate
button in the dialog:

+ MacPaint documents

e MacDraw “PICT” documents. MacDraw can save documents
in this format by clicking the button labeled PICT, in its Save
As... dialog. PICT documents contain nearly all the
information in a MacDraw document.

+ StartupScreens. When you place a StartupScreen document in
the folder containing the System file, the full-screen image
stored in it will be displayed when you start the Macintosh
from that disk. The document must be named “StartupScreen”
for this to work. Often, disks containing game programs
include an entertaining StartupScreen,

The list of files in the dialog window will display only one kind of
document at a time. In Figure 4.1, for instance, the button labeled
SuperPaint has been selected. Thus, all the documents in the window
are SuperPaint documents. To open a PICT document, press the
button labeled PICT. The SuperPaint documents will disappear, to be
replaced by any PICT documents in the current folder.

If there are more documents and folders than can fit in the window, a
scroll bar is activated, so you can look at the rest. To look in a folder
enclosed by the current one, simply double-click on its name. To look
at a folder that encloses the current one, move the cursor to the current
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D Fig 111-05
O Fig 11106

D Fig 1ll-07 T
O Fig 111-08

D Fig 111-09 Scroll bar
O MacPaint

Candidate
documents

SuperPaint
SuperPaint @ Sup

documents
selected

O StartupScreen QO PICT

folder name (above the window) and hold the mouse button down. A
menu of enclosing folders will drop down, including, at the very
bottom, the name of the disk on which the folders reside. To look
inside one of these folders, drag the cursor to its name and release the
mouse button. Figures 4.2 and 4.3 illustrate the relationship between
folders and this menu.

L—  SuperPaint Stuff
18 items 96K in folder 190K av.

@ -
3 i
B i

way Dark Castle S.Jaint/Figs

/

!

[EC=== s.Paint/Figs ==
T items 32K in folder 190K availab]

Doug’s Files

Doug’s Files
14 ftems 589K in disk 190K availab]

Word Stuff
SuperPaint Stuff

B E‘E a
B C) CJ) W]
7 a n 1
1% (3 15

Fig II-3 h Figl-s
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To look in a different (already-inserted) disk, click the Drive button.
Click the Eject button to eject the disk in the current drive so you can
insert another one.

When you locate the document you want to work on, click on its name
and click the Open button (or just double-click on its name).
SuperPaint will open it into a new window.

If, instead, you decide not to open a document, click the Cancel
button.

When you want to store a SuperPaint document on disk, use the Save
(Command-S) and Save As... commands from the File menu.

The Save command replaces an old copy of the document with the
latest version. Save As leaves the original version intact, while
allowing you to store the document with an alternate name or format,
and perhaps in a different disk or folder.

Saving a SuperPaint document is very similar to opening one.
Choosing Save on a brand new document (whose window title is
“Untitled - #”), or using Save As... on an existing one, displays a
dialog such as the one in Figure 4.4.
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The window within the dialog displays only the folders contained in
the current folder. When you save your document, it will reside in the
folder named above the window. In Figure 4.4, for example, the
document would be saved in a folder named SuperPaint Stuff. You
can select a different folder or disk in precisely the same manner
described under Opening a Document.

Before saving the document, you may type in a name for it. Try to
use a name that easily identifies the contents or purpose of the
document.

Finally, you can choose the document format to use. As with Open,
you can save a document in SuperPaint format (the initial setting),
MacPaint, PICT, or as a StartupScreen document. If you will only
want to use the document with SuperPaint, save it in that format.
SuperPaint documents retain all the information you place in them.

Documents saved as MacPaint can be viewed or modified by
MacPaint, but are only painted (dot-by-dot) images -- all information
in the Draw layer is turned into dots in the MacPaint document.

PICT documents retain most of their information. When you load a
PICT document into MacDraw, you can edit most objects in the Draw
Layer. The Paint layer becomes a large painted (bit mapped, in
MacDraw terminology) object. Most page layout programs can read
PICT documents, too.
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StartupScreens, like MacPaint documents, have all the Draw layer
painted into their Paint layer. StartupScreen documents consist of an
image that will fill the entire screen, and no more. The top left corner
of the window becomes the top left corner of the document, and only
what is needed to fill a screen is saved.

To preview what the StartupScreen will look like, view your
document in Full Screen (Command-F) mode, with menus and
palettes hidden (Hide Menu Bars turned on in the Preferences dialog,
and Command-H).

When all these decisions about folder, document name and format are
made, click the Save button to store the document on disk.

If an identically-named document already resides in that folder
(differences in capitalization don’t count), SuperPaint will ask whether
you want to replace the original. Let it proceed by clicking the Yes
button. To go back and give the new document a different name or
store it in a different folder, click the No button.

SuperPaint does not allow you to replace a document that has the same
name, but a different format. For example, if you already have a
MacDraw document named Invoice, you cannot replace it with a
SuperPaint document of the same name. If you really do want to
replace it, save the document under a different name, for the moment.
When you exit from SuperPaint (by choosing Quit from the File
menu or by pressing Command-Q), delete or rename the original
document, and then rename the new one.

If you only want to save a portion of a SuperPaint document, choose
the Save Selection... command from the File menu. SuperPaint
will display a dialog similar to Save As... The only significant
difference (from Save or Save As) is that you cannot save a selection
in StartupScreen or MacDraw PICT format. You can, however, save
the selection as a MacPaint or SuperPaint document. The latter choice
retains all information in the selection.

You can restore the open version of a document to the state that it was
in when last you Saved it, as long as it is a SuperPaint document.

You might want to do this after an unsuccessful “what-if” session. To
restore the document, choose Revert from the File menu.
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You can print SuperPaint documents on a LaserWriter, LaserWriter
Plus, or an ImageWriter [ or II. You should also be able to use
printers or typesetting machines that are compatible with the
LaserWriter or ImageWriter.

With an ImageWriter II, you can take advantage of SuperPaint’s color
capabilities (see the discussion of the color palette in Part 3). To print
in color, make sure the Preferences option, Print in Color, is turned
on. Conversely, if you want to print in black and white despite any
color choices in a document, turn Print in Color off. See the
discussion of Preferences in Part 1.

To print, you choose Print... from the File menu and then click the
OK button. There are some other issues you may want to be familiar
with, though..,

A cardinal rule: A printed SuperPaint document looks like its image in
the window when you start to print. In other words, if the Paint layer
is in front, it will also be in front on the printed page. If the back layer
is hidden (with the Hide Back Layer command from the Window
menu), it will not appear when you print the document. Be sure to set
the layers as you want them to appear before you start to print,

You must begin by choosing the printer you want to use. With older -
Macintosh system software, you will use the Choose Printer desk
accessory. Newer systems use the Chooser desk accessory. You
may also need to use the Contro! Panel.

Start the desk accessory by choosing Choose Printer from the &
menu. Click on the appropriate port and printer. If you are using a
LaserWriter, click on the Printer port icon, click the AppleTalk
Connected button and then click “LaserWriter.” To use the
ImageWriter, click on the port to which the ImageWriter is attached
and click on “ImageWriter.” Finally, click the OK button.

With more recent system software, you may need to use the Control
Panel. If you will be using an AppleTalk printer, such as the
LaserWriter or the AppleTalk ImageWriter, you must make sure
AppleTalk is connected. Choose the Control Panel from the &
menu. In the AppleTalk box, click the Connected button to turn on
AppleTalk. Close the Control Panel by choosing Close from the
File menu (or click in its close box). Now choose the Chooser
from the € menu. Click on the LaserWriter or ImageWriter icon and
then the Printer port icon. Then close the Chooser.
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To use a local (non-AppleTalk) ImageWTiter, you need not connect
AppleTalk. With the Chooser, simply select the port to which the
ImageWriter is attached (Printer or Modem), and click on
“ImageWriter.” Then close the Chooser.

Before you print, make sure the Macintosh knows what kind of paper
and, if desired, what image reduction/expansion you want. Choose
Page Setup from the File menu. The dialog you get will depend on
the kind of printer you selected. Figure 4.5 shows the dialog for an
ImageWriter.

Imagellriter SO m ‘
Paper: @ US Letter O A4 Letter
O US Legal QO International Fanfold Cancel
O Computer Paper E

Orientation Special Effects: [XITall Adjusted

[150 % Reduction
[[JNo Gaps Between Pages

With the Page Setup dialog, you can choose from several kinds of
paper. You will probably use US Letter, or A4 in Europe.
Remember that SuperPaint documents are 8 inches wide by 10 inches
high, no matter what size paper you choose.

You can also select the image’s orientation on the page. The image
can either be printed upright (Portrait, the most common setting) or on
its side (L.andscape).

Under “Special Effects,” when printing pages in upright orientation on
the ImageWriter, be sure the Tall Adjusted option is turned on. This
keeps the printed dots square, as they appear on the screen.

On an ImageWriter, you can choose to print your document at full
size, or reduce it to 50% of its screen size (4 by 5 inches). On the
LaserWriter, you can reduce a document as far as 25% size (2 by 2.5
inches), or expand it to as much as 400% (equivalent to 32 by 40
inches). Just enter the reduction or expansion percentage.

If you print sideways, or if you expand the printed image (on a
LaserWriter), it may take two or more sheets of paper to contain the
complete image. Printing a document sideways, with no reduction,
takes two pages. Printing a document with a 400% expansion on the
Laserwriter takes 16 pages.
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On the ImageWriter, there is one more “Special Effects™ option,
labeled No Gaps Between Pages. Normally, SuperPaint centers the 8
by 10 inch document on the page. Turning this option on causes the
image to be printed at the very top, left-hand comer of the page, with
no margin at all.

There are two more options on the LaserWriter. If you choose Font
Substitution, non-LaserWriter (i.e., non-PostScript) fonts in your
document in the Draw layer will be automatically translated to the
closest LaserWriter fonts. If you do not use this option, text in non-
LaserWriter fonts will print at ImageWriter resolution. The second
option is called Smoothing. When you use Smoothing, painted
images are digitally processed to look slightly better on the
LaserWriter. Primarily, Smoothing decreases the prominence of the
“stair-step” effect of diagonal lines (the infamous “jaggies™). Try
printing with and without Smoothing, to see which you prefer.

When Smoothing is on, it takes significantly longer to print a
document that has anything in its Paint layer.

So much for the preliminaries. Choosing Print... from the File
menu will produce a dialog similar to the one in Figure 4.6.

Imagetriter V2 (_—m(_j
Quality: @® Best (O Faster O bDraft

Page Range: @ Rll O From: D To: D I
Copies: ]

Paper Feed: @ Automatic O Hand Feed

On the ImageWriter, you can select the quality of print to use. There
are three print qualities, but only two are used by SuperPaint. The
highest quality is called Best. Best quality images are well-formed
and quite dark. They also print rather slowly. Faster quality prints
more quickly. The resulting images are still very good, though not as
dark as when using Best quality. Draft quality is for printing text
only, and is therefore not relevant to SuperPaint.

The LaserWriter always uses the very highest quality printing.
With either printer, you can select how many copies to print. Just

type a number from 1 to 999. Initially, this field is always set to give
you one copy.
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You can specify a range of pages to print. This is only pertinent if
your document spans multiple pages when printed (i.e., if you are
printing it sideways, or with an expansion factor--see the discussion
of Page Setup). When a document is split into multiple pages, the
top, left-hand corner page is page 1, with subsequent pages numbered
across, then down. See Figure 4.7. For example, to print out just the
bottom strip of pages in a document expanded by 400%, indicate a
page range from 13 to 16.

ho expansion, 400Z% expansion,
printed sideways printed upright
PEZ2 13 14
page | 5{617 18
Qi i 112
page 2 130141 1Sib

Finally, you can select the paper source. ImageWriter paper can either
be fed manually or automatically. When you click Automatic from the
Paper Feed selection (or Continuous Feed on older versions of the
Macintosh System), the printer will transport the paper by itself.
Clicking the Manual Feed button (this used to be called Cut Sheet )
causes the Macintosh to prompt you to insert each new sheet.

On the LaserWriter, clicking the Paper Cassette button causes paper to
be fed automatically. If you click the Manual Feed button, the
Macintosh will prompt you to insert each new sheet.

You are almost ready to print. If you are using an ImageWriter, load
the paper so that the very top of the sheet is covered by the paper bail.
The bail is a metal bar that supports several rubber rollers against the
platen (the large black rubber cylinder that carries the paper). If you
are using tractor-fed paper, make sure the tension lever is off (toward
the rear of the printer on an ImageWriter I, toward the front on an
ImageWriter IT). When printing on individual sheets, turn the tension
lever on.

When you are ready to print, click the OK button, or press the Return
key.
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While printing, SuperPaint displays a dialog box with three buttons.
Click Cancel to stop the printer and eject the page. If you click the
Pause button, the printer will halt, and the Continue button willbe
enabled. You can now straighten the paper, replace the ribbon, etc.
When you are ready to proceed, click the Continue button.

TWO-LAYER | You may have noticed that there is one tool on the palette that we have
SELECTION yet to discuss. This is the Two-Layer Selection (TLS) tool. This tool
lets you make a special kind of document selection. With it, you can
Lo select a section of both the Paint and the Draw layer at the same time.

f
HLETH

Clicking on the TLS tool automatically turns off layer-hiding. That
way, you will always see what you are selecting.

What can you do with a TLS selection? Only one thing: You can
copy it to the Clipboard. From there, you can paste the results in
either layer, into the Scrapbook, or into another program’s document
(after quitting SuperPaint or by using Switcher).

The TLS tool works a little differently in each layer.

From the Paint | In the Paint Layer, this tool works almost exactly like the Selection

Layer | Rectangle tool. Choose the TLS tool from the palette and move the
cursor to one corner of the desired selection. The TLS cursor is
shaped like a dotted crosshair. Press the mouse button and drag it to
the opposite corner of the selection. When you release the mouse
button, dashes on the boundary of the selection jitter back and forth
(to distinguish it from the Selection Rectangle border’s smooth,
unidirectional flow). Choose Copy from the Edit menu, or press
Command-C. Everything inside the rectangle will be included in the
selection, even if it is actually in the Draw layer. Any portion of the
Draw layer that is included is turned into dots that are incorporated
into the selection.

You can paste the resulting contents of the Clipboard into either layer.
In the Paint layer, the pasted results are incorporated into the painting.
In the Draw layer, the result is a painted object, the size of the TLS
rectangle.

From the Draw | The TLS tool is a little more complicated when used in the Draw layer.

Layer | You draw the TLS rectangle in exactly the same way as in the Paint
layer. As you can see from Figure 4.8, not only are the contents of
the rectangle selected, but so too are all Draw layer objects intersecting
the rectangle. (Unlike the Selection Rectangle, Draw layer objects
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need not be entirely enclosed in a TLS rectangle to be selected.) When
you are satisfied with the selection, Copy it to the Clipboard.
Anything in the Paint layer that falls within the selection area is
included as one painted object.

f2. ..drag from here...

. Select

TLC tool... _ 3. ..to here. Copy 4. ..then Paste

to clipboard... into Draw layer.

When you paste the results into the Draw layer, you get a painted
object the size of the TLS rectangle. In addition, you get copies of all
objects that intersected it.

When you paste the results into the Paint layer, you get a selection
rectangle of minimum size to contain all selected objects and the TLS
rectangle (see Figure 4.9). Inside the selection rectangle is the portion
of the Paint layer that was inside the TLS rectangle, along with all
selected objects. The background of the selection rectangle is solid
white.

The Scale Selection command, in the Edit menu, allows you to
specify an expansion or contraction factor to apply to the current
selection. When you choose Scale Selection, SuperPaint displays
the dialog depicted in Figure 4.10. Choosing a scaling factor larger
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0B U

than 100% expands the selection. Factors less than 100 percent
shrink it.

]
-

Scale Selection

O 25%
O 50%

@ 200%
O 400%

Scaling factors of 25, 50, 200, and 400% work well, so they are
included as buttons in the Scale Selection dialog. If none of the four
preset factors suits you, type in any scaling factor you need.

Drawn objects scale very nicely, since they are stored as mathematical
information. Selections in the Paint layer tend not to scale quite as
nicely.

If you are using a LaserWriter, and want to reduce a Paint layer
selection, turn it into a painted object in the Draw layer first (see Copy
to Drawing, in Part 2). The LaserWriter prints all the dots in a painted
object, even when reduced to as little as 25% of original size. All the
original dots are printed, but smaller.

The Magnifier tool gives you close-up views of any portion of the
document. When you click the magnifier icon in the tool palette, the
cursor turns into a miniature magnifying glass. When you click the
magnifier in the document, the viewing area will split vertically. The
left side of the window becomes a pane that shows a normal
magnification view centered on the clicked area. The right-hand side
is a magnified view, centered on the same area, the location where you
clicked the magnifier.

You can use any tool in the magnified area. Anything you do to the
magnified document is reflected in the unmagnified side. You can
even use the magnifier on the close-up view. The first click of the
magnifier displays a 2X view (all features appear at twice their actual
size), the second click displays a 4X view, and the third click displays
an 8X view.
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Normal View
on this side

To decrease magnification, click in the normal-size view, with any
tool selected. Magnification will decrease by half for each click.
When you reach 1X, the split view is replaced by the original, normal
size view.

The most common way to use the magnified mode is to edit dots in the
Paint layer, using the Pencil. Clicking on a dot with the tip of the
pencil turns it white. Clicking on white space creates a black dot.

Although objects created in the Draw layer are displayed on the screen
with dots, these dots cannot be edited as they can in the Paint layer
(not even in a painted object). Draw-layer objects can only be created,
moved, resized, or deleted. Magnifying the Draw layer can be useful
for precision resizing or reshaping. =

Holding down the Command key when you click the magnifier brings
the magnification directly up to 8X (or double-click on the Magnifier
tool). While working on the Paint layer, you can also obtain
maximum magnification by selecting the Pencil tool and then holding
down the Command key while you click in the window at the location
you want magnified, or by simply double-clicking on the Pencil tool.

Each of these shortcuts centers the magnified view on the clicked area.
To return directly to normal magnification, hold down the Command
key while you click on the unmagnified view, with any tool selected.

You can also restore normal magnification by double-clicking on the
Magnifier tool in its palette.
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Figure 4.12
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SuperPaint lets you see, at a glance, an overview of the complete
document. To accomplish this, choose Reduced View from the
Windows menu, or press Command-W. The viewing area splits
vertically into two panes. The left-hand pane shows a compressed
view of the entire 8 by 10 inch document page. The right-hand pdne
is a fully functional normal-view working area. You can use any tool
on the normal view side, and see its effects immediately on both sides.

To return to the normal viewing mode, choose Normal View from
the Windows menu, or press Command-W again.

Any attempt to use the Magnifier tool automatically cancels the
reduced view mode.

Sometimes it is helpful to know your exact position within a
document. Choosing Show Rulers from the Windows menu
displays two rulers in the display area. One stretches across the top
edge, and the other along the left-hand side. The rulers are initially
marked in inches. They scroll along with the document. The current
position of the cursor is marked on the rulers with a dotted line.
Figure 4.12 illustrates what rulers look like.

sl$ﬁ

Untitled - 1

§!J|2I|l|||||311|||11|4

...... i i

]ILJ

llll'“‘!!!E

)

Chqose Hide Rulers from the Windows menu to turn them off
again.

The rulers can show centimeters, if desired. Choose Preferences
from the Options menu, and choose Centimeters under Ruler
Measure.
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Figure 4.13

Figure 4.14
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SuperPaint usually lets you create objects anywhere in a document.
Sometimes it is useful to restrict the placement of corners of objects to
a regular grid of points. Having such a grid makes it easy to align the
shapes you create, resize, or move.

You can enable, disable, and otherwise control this kind of grid by
choosing the Grid... command from the Options menu. When you
do, you will see the dialog in Figure 4.13.

e

Alignment Grid...
Measure in: @ Inches (O Centimeters O Points

' @&Use grid with spacing of:

(EPIR | Inches
O Turn grid off
O Invisible Grid @ Lisible 6rid

|

You can set the grid spacing in terms of inches, millimeters, or points
(1/72 inch, which is one screen dot). Let’s say you set the grid
spacing to .25 inch. That means the grid consists of a rectangular
matrix of points, each .25 inch from its neighbor (as in Figure 4.14).

You can make the grid visible or invisible. If it is visible, SuperPaint
will display a dot at each grid point. Turn on the button labeled
Visible Grid, to see the grid. The grid dots, though visible in the
window, are not part of your document. They will not, for instance,
print out with the rest of a document.

E[ 1= Untitled - 1 5 EC== Untitled - | ===

1. Drag the ob ject. 2, .when you release if, the ob ject
shifts so that its top left-hand
corner coincides with a grid
intersection.
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To enable the grid (i.e., turn it on), turn on the button labeled Turn
Grid On. While the grid is on, you will notice a few changes: First of
all, when you drag a selection and release it, the selection will
automatically shift so that its top left-hand corner coincides with the
nearest grid point (see Figure 4.13). The corners of any shapes or
lines you create will automatically align with the nearest grid
intersection.

The grid need not be turned on for it to be visible. Likewise, the grid
need not be visible for it to be turned on. All in all, you will probably
find the grid easiest to use if you make it visible when you turn it on.

Though SuperPaint comes with approximately 60 patterns, chances
are that someday you won’t find exactly the one you need. That’s no
problem. Just modify an existing pattern. Choose Edit Patterns...
from the Options menu, or double-click on the pattern you want to
edit (if you’re in the Draw layer, be sure that no objects are selected,
or else the first click will cause their fill or pen pattern to change).

i — |

'( oK ) (Cancel ]

| e

Once you have selected the pattern to edit, SuperPaint shows it to you

in a magnified view, along with a sample figure filled with the pattern

(see Figure 4.15). If you click on one of the black dots in the pattern,
it turns white. If you click on white space, it turns black. The change
is immediately reflected in the filled figure.

When you have edited the pattern to your satisfaction, click the OK
button. If you change your mind, and do not want to save the edited
pattern, click the Cancel button.
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Modified patterns are stored in your SuperPaint document, If you
create a set of patterns that you find particularly handy, make a copy
of the document that contains them (use the Save As... command in
the File menu), named (for instance) “Handy Patterns.” Erase
everything from both layers of Handy Patterns. From then on, when
you want to use that set of patterns, start out with a copy of the Handy
Patterns document instead of using the New command.

When you create a document with the New command, you will start
out with the basic, unedited set of patterns included with SuperPaint.

Normally, tools automatically scroll the document when you move
them past the edge of the viewing area. Occasionally, this behavior
could hamper your efforts. To disable automatic scrolling, choose
Scroll Off from the Options menu. Conversely, choose

Scroll On to enable automatic scrolling again.
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LaserBits™ is the feature that allows you to edit dots at 300 dots-per-
inch resolution. The name comes from the fact that in Apple’s
MacPaint program, 8 times magnification has always been called
FatBits. LaserBits is also a type of magnification, but instead of
seeing dots at 72 dots-per-inch (dpi) resolution, the magnification is
blown up even more, so that each dot is one of 300 dots per inch.

Keeping that many dots in the SuperPaint document that you’re
working on would take a lot of memory. If you wanted to edit several
portions of the Paint layer at 300 dpi, you would run out of memory.
So, SuperPaint keeps the images that are being edited at 300 dpi in
separate SuperPaint documents.

Here’s a brief overview of how the LaserBits feature works. You
select a portion of the Paint layer with the Selection Rectangle tool.
Then, you choose New LaserBits from the File menu. You type
in a name and then get another window. In that window you see your
selection, only it is blown up four times as big as it was originally.

You can then use all of SuperPaint’s editing tools, including the Pencil
at 8X magnification. Each of the dots in this window are one of 300
dots per inch. When you’re done editing, you close the window.

At that point you’re back to your original document and in it you see a
new painted object in the Draw layer. It looks roughly like your
image that you edited at 300 dpi, but it’s actually just a representation
of it, since the screen is only capable of showing dots at 72 dpi.

This object is called a LaserBits object. It can be moved around in
your document. Wherever you place it is exactly where it will be
printed at 300 dpi on a LaserWriter (72 dpi on an ImageWriter).
When you print, SuperPaint knows how to go find the additional
image or images on the disk and include them in the printout.

If you decide to do some more editing of your LaserBits object, you
just select it (click on it) and then choose Open LaserBits from the
File menu. This reopens the special window that shows the image at
300 dpi. You can then edit again and save your changes, closing the
window when you’re dorne.

There is no limit on the number of LaserBits objects permitted in a

SuperPaint document. The only limitation is the amount of disk space
you have available.
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Figure 5.1
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To create a LaserBits object, begin by opening a SuperPaint document
and switching to its Paint layer. Next, make a selection with the
Selection Rectangle tool. This selection must not be larger than two
inches wide by two and a half inches high. The reason for this
limitation is that when the selection is blown up four times, it must
still fit in a SuperPaint document. Two inches times four takes up the
maximum eight inches width, and two and a half inches times four
takes up the maximum ten inches high.

Choose New LaserBits from the File menu. If your selection is
too large, SuperPaint will let you know at this point and you’ll have to
try again, selecting a smaller portion.

0 3logos

0 Abrbone images
[ Ahbiernae serean
[y finberne shapes

D Airtincontract
Save document as —=Files
[Heto-300dpi |
[(seve ] [Cencel | [ _Drive )

@® SuperPaint Q Mackaint

O Startupscreen O e

If your selection is not too large, you will see a dialog that is the same
as the kind produced by a Save As... command.

Each LaserBits object is actually stored in a separate SuperPaint
document. So, you must provide this new SuperPaint document with
a name. Notice that you can only save the LaserBits object in
SuperPaint format. The other three choices are dimmed.

Enter a name and click the Save button or press Return. A new
window is opened and your selection from the Paint layer is pasted
into it, only it is four times as big as it was before. Notice in the title
bar of the new window that it shows the name you entered, followed
by (LaserBits).
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Rirborne Images

You can use all the painting and drawing capabilities of SuperPaint in
the LaserBits window. When you close this LaserBits window and
save your changes, a LaserBits object appears in the Draw layer.

A LaserBits object has hollow handles so that it can be distinguished
from other objects. LaserBits objects are like painted objects - they
consist of a collection of dots. But the dots are merely the closest

representation possible on the screen of an image that consists of
300 dpi.

The screen can only show 72 dots-per-inch resolution, so only one
out of every sixteen dots in the LaserBits object is actually displayed.
Nevertheless, when you print your document, its LaserBits objects
will be printed in full detail on a LaserWriter.

O Rirborne images ==

"= ? @ ~anggel -

eﬂ@m

b ¢

[T

\ Laserfits

ob ject

PART 5: LASERBITS

UYL B LU L LB OB L OB O LU L AL, LI, LA LY, L, L



B A A

OPEN
LASERBITS

PLACE
LASERBITS

83

You can manipulate LaserBits objects just like painted objects, with a
few exceptions. You can drag them to position them in the document.
You can cut, copy, paste, duplicate, or clear them. You cannot,
however, resize, flip or rotate a LaserBits object. Nor can you include
a LaserBits object in a group.

To edit a LaserBits object, select it, then choose Open LaserBits
from the File mciu. SuperPaint will reopen the document that
contains the 300 dpi image. If it cannot locate the document on any
inserted disk, SuperPaint will ask you to insert a disk.

Once it has located the LaserBits object’s document, SuperPaint
displays the contents in a LaserBits window. You can edit this
document exactly like any other SuperPaint document. Use any tool,
in either layer.

Each dot in this document is 1/300 inch across when printed on a
LaserWriter. If you created this image with the New LaserBits
command, the source of the image consisted of dots 1/72 inch across.
Thus, each dot in the original image has been replaced with 16 dots (4
across by 4 high) in the LaserBits document. That’s why the image
will initially look very jagged. You will have to smooth these
“jaggies” manually, using the Paint layer tools. Although adding and
deleting all those dots can be tedious, the resulting image on the
LaserWriter can be startling.

When you have finished editing the document, close the window in
the usual way (click in the window’s Close box or choose Close
from the File menu). SuperPaint will ask whether you want to save
your changes. Click on the appropriate button (Yes, No, or Cancel).
Clicking on the Cancel button lets you continue to edit the document
without saving it on disk. Once you have closed the window, the
associated LaserBits object will be updated with your changes.

You cannot open more than one LaserBits window at a time. You
must close any open LaserBits document before you can edit another
one.

Sometimes you will want to incorporate existing LaserBits objects into

the document that you are working on. You might, for example,
insert a company logo at the top of an invoice.
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To do this, simply choose the Place LaserBits... command from
the File menu. SuperPaint will ask you to identify which document
to open. Once you select the document, a LaserBits object is placed in
your current document.

You can also select a normal SuperPaint document with the

Place LaserBits... command, but its contents will appear in the
current document at 1/4 the original size and print that way on a
LaserWriter.

You see, a LaserBits document is really just another SuperPaint
document. Itjust contains a blown up image (remember, the New
LaserBits command took care of enlarging it four times) that is
reduced when printing takes place. The key is that when it is reduced
and printed, SuperPaint can still keep track of all the dots, producing a
resolution of 300 dpi.

When you copy a LaserBits object to the Clipboard, SuperPaint opens
the separate LaserBits document, retrieves the image and places it in
the Clipboard, all 300 dots per inch of it. Since a lot of dots are being
moved around, this may take awhile. It also may require a lot of disk
space to hold this large Clipboard.

This is the way you will want SuperPaint to work if the Clipboard is
the only way to transfer the image (for example, to MacWrite). But if
the program that you are copying to can open PICT documents, it may
be easier to save the SuperPaint document that contains the LaserBits
object as a PICT document. This PICT document will contain a
painted object (they are called “bit mapped” objects in MacDraw) that
contains all the dots. Most page layout programs have the capability
of “importing” PICT documents.

If you are cutting and pasting LaserBits objects between SuperPaint
documents only, you can speed up the process by unchecking “Put
LaserBits in Clipboard for other programs” in the Preferences dialog.
When this item is not checked, SuperPaint puts only the screen image
in the Clipboard, but keeps track of the LaserBits document associated
with it that contains the actual 300 dpi image.

Then, when you paste from the Clipboard into another SuperPaint
document, the LaserBits object appears in the Draw layer, and the link
to its separate LaserBits document is established. If you paste this
same image from the Clipboard into some other program, only the
screen image, at 72 dpi, will be pasted.
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If you are copying a SuperPaint document which contains LaserBits
objects from one disk to another so that you can take it to another
computer, be sure to also copy all of the associated LaserBits
documents. They are simply SuperPaint documents with the name
that you have given them.

Printing a document on the LaserWriter that contains a couple of
LaserBits objects will take longer than normal documents. One way
to speed this process up is to turn the Smoothing option off. This is
done by choosing the Page Setup... command in the File menu. If
Smoothing has a check mark next to it, it is on. If there is no check
mark, it is off,

If, while printing a SuperPaint document that contains LaserBits
objects, SuperPaint cannot locate a LaserBits document it needs, it
will ask you to insert the disk containing the document. Once you
insert a disk, SuperPaint will search for the needed document on the
disk. If that document is not on the inserted disk, SuperPaint will put
a dialog box on the screen that will allow you to Eject the inserted disk
and try another, or to Cancel.
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Align Objects command 56
Arc tool, drawing 37, 55
Arc tool, painting 21

B

Black pattern 4

bit map objects see painted objects
. Bring to Front command 54

Brush Shapes (edit) command 16

C

Circle tool, drawing 36

Circle tool, painting 13

Chooser desk accessory 67
Choose Printer desk accessory 67
color printing 58

constraining 12, 34

Control Panel desk accessory 67
Copy to Drawing command 32
Copy to Painting command 52
copy LaserBits Objects 84

Cut command, drawing

Cut command, painting 28

D

Distort command 31
document

create 62

definition 2

MacPaint 62, 65

open 62

PICT 62, 65

size 2

StartupScreen 62, 66

SuperPaint 62
Drag as Objects command 50
Drag as Qutlines command 50
Draw from Center command 35
Draw from Corner command 35
Draw layer 2

B8

E

Edit Patterns command 77

edit
300 dots per inch see LaserBits
Brush shapes 16
patterns 77

Eraser tool 18

expanding text object 41

F
FatBits see magnification
fill pattern 4
fixed text object 41
Flip Horizontal command 28
Flip Vertical command 28
folders 63
font

size 23, 43

style 23, 44
Free Rotate command 29
Freehand tool, drawing 38
Freehand tool, painting 14
Full Screen command 6

G
Grid command 76
Group command 48

H

Hand §

Hide Back Layer command 9
Hide Palettes command 7
Hide Rulers command 75
hide menu bar 7

Invert command 28
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LaserBits
copy 84
explanation 80
New LaserBits 81
objects 82
Open LaserBits 83
Place LaserBits 83
printing 85
LaserWriter
grays 4
printing 70
resolution of LaserBits objects 80
resolution of objects 34
Lasso tool 26
Layer selector
explanation 3, 4
icon 3
visiblefinvisible 9
layers
explanation 2
selecting 2, 4
Line/Fill selector 4
Line Size selector 20, 39
Line tool, drawing 39
Line tool, painting 19
line
height 20, 40
patterns 4
width 20, 40

M

MacDraw PICT format 62
MacPaint format 62
magnification 73
Magnifier tool 73

N

New command 62
None pattern 4
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O
objects

align 56

bring to front 54

color 58

explanation 2, 34

group 48

line size 52

patterns 52

moving 49

resizing 50

selecting 47

send to back 54

ungroup 48
Opaque Paint command 16
Open command 62
Open LaserBits command 83
Other Size font 23, 43
Oval tool, drawing 36
Oval tool, painting 13

P
Page Setup 68
Paint Bucket tool 19
Paint Brush
edit Brush Shapes command 16
tool 15
Paint from Center command 12
Paint from Corner command 12
Paint layer 2
Paint on Black command 16
painted objects 53
palette
patterns 4
tools 4
pattern palette 4
Pencil tool 15
Perpendicular Line tool, drawing 39
Perpendicular Line tool, painting 21
Perspective command 32
PICT format 62

INDEX



Place LaserBits command 83
Polygon tool, drawing 36, 55
Polygon tool, painting 14
Preferences 7, 10

Print command 67

printing LaserBits objects 85

R
Rectangle tool, drawing 35
Rectangle tool, painting 13
Reduced View command 75
Reshape '
arc 55
polygon 55
Tesizing
objects 50
paint selections see  Stretch
text objects 45
Revert command 66
rotate selection see Free Rotate
Rotate Left command 28
Rotate Right command 28
Rounded Rectangle tool, drawing 36
Rounded Rectangle tool, painting 13
rulers
choose inches/centimeters 75
show/hide 75

S

Save command 64
Save As command 64
Save Selection command 66
Scale Selection command 72
Scroll Off command 78
Scroll On command 78
scrolling

Hand 8

on/off 78

scroll arrows 8

scroll bar 8

scroll box 8

tools 9

while dragging 9

90

Select All command, drawing 49
Select All command, painting 26
Selection Rectangle tool 25
Selection tool 46
selecting
Draw layer 46
Paint layer 25
selections
cut and paste in Draw layer 51
cut and paste in Paint layer 28
moving in Draw layer 49
moving in Paint layer 27
Send to Back command 54
Show Color Palette command 58
Show Palettes command 7
Show Rulers command 75
Slant command 31
Spray Can tool 17
StartupScreen documents 62, 66
Stretch command 30
SuperPaint Prefs document 10

T
Text Pattern command 24, 45
Text tool, drawing 42
Text tool, painting 22
Text Type indicator 41
text

align 24, 44

fonts 23, 43

Draw layer 40

Other Size 23, 43

Paint layer 22

pattern 24, 45

resizing text objects 45

size 23, 43
tool palette

in Draw layer 3

in Paint layer 3
Transparent Paint command 16
transparent

painting 16

objects 57

pattern 4
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Turn Scrolling Off command 9
Turn Scrolling On command 9
Two-Layer Selection tool 71

U
Undo 10
Ungroup command 48

\'
vertex (polygon) 55

W

White pattern 4

Windows menu 5

windows
managing 6, 7
multiple 5
zooming 6
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SuperPaint
Version 1.1 Addendum

Version Compatibility
Documents created with SuperPaint 1.0 are fully compatible with SuperPaint 1.1.

Which System and Finder to Use

SuperPaint 1.1 is shipped on a 400K non-startup disk. You can copy SuperPaint to a hard disk or prepare a working
copy on a floppy disk. Apple Computer has provided the recommended configurations shown in the chart below. You
should locate your machine in the chart and use the System and Finder versions listed there.

Recommended @
Systems
System 3.2 - Finder 5.3 ©

System 3.3 - Finder 5.4

System 4.2 - Finder 6.0

@ Best System for hardware @ OK to use
@ Best System for AppleShare OK with AppleShare

Memory Considerations

Macintosh 512: You can usually open two windows at once. If you have the maximum number of windows
open, the New, Open, New LaserBits, and Open LaserBits commands are not available, and are dimmed in the
File menu. To use LaserBits™, simply close one of the two open windows.

SuperPaint will not run on a 512K Macintosh if more than 35K of memory has been allocated to “resident” software.
This includes such things as RAM Cache, RAM Disk, HyperDrive System software, efc. If it runs into this problem,
SuperPaint will alert you with a message that indicates there is insufficient memory for it to run. Or, if it does ruon, it
may limit the maximum number of open windows 1o one. Eliminate any cache, RAM Disks, large desk accessories,
or other such items, and then try again. Once SuperPaint is running, choose About SuperPaint from the Apple
menu to find out how much memory is available.

Macintosh Plus: You can usually open 9 to 10 windows at once.

Macintosh SE: You can usually open 9 to 10 windows at once.



Macintosh IT: SuperPaint rans in the “2 color/2 grays” (black and white) mode only. To switch to this mode,
choose the Control Panel from the Apple menu, click on Monitors, and set the number of colors or grays to 2. If the
Monitors icon does not appear in the Control Panel (¢ven after scrolling), consult your Macintosh IT manual for
instructions on installing Contro! Panel resources.

If you are not in the 2-color or 2-grays mode when you attempt to run SuperPaint, a dialog box opens with a Quit
button. Press the Quit button and reset the number of colors/grays to 2, then run SuperPaint.

You can usually open 9 to 10 windows at once.

Setting the Macintosh II to 2-Color/Grays Mode

s()==—--= Control Panel =——1|

Characteristics of monitor : 32
= O Black & White /Grays °‘°"
General @ Color .
16
(Convergence Test]  [256

1. Select Monitors icon
2. Select 2 Colors or 2 Grays

Using MultiFinder

SuperPaint 1.1 is compatible with MultiFinder, Apple’s multi-tasking operating system option. SuperPaint 1.1 is
also “MultiFinder aware,” which means it has been optimized to work in the MultiFinder environment. This
optimization permits quick switching between programs, allows as much time as possible for programs running in the
background, and supports background printing with PostScript® LaserWriters.

The minimum memory size required to use SuperPaint 1.1 with MultiFinder is 410K. The suggested memory setting
is 520K which allows you to have three documents open. See your MultiFinder User’s Guide for details on changing
an application’s memory size. Also note that SuperPaint hides its palettes when it is in the background.

Occasionally when quitting an application under MultiFinder 1.0, the Macintosh can either crash or hang immediately
after returning to the Finder. This is not a SuperPaint problem. Apple has confirmed this as a known MultiFinder 1.0
bug which will be fixed before their next system software release.

Running with Switcher

SuperPaint 1.1 is compatible with version 5.1 of Switcher. SuperPaint 1.1’s memory partitions are optimized for use
with MultiFinder. Therefore, if you are using Switcher, you need to specify the memory partition sizes directly; you
cannot use the defaults. The recommended minimum partition is 445K while the preferred setting is 625K. In order to
open as many as 10 documents under Swilcher, the partition would have to be 875K. You can specify memory
partitions by using the “Configure then Install...” command from the Switcher menu in Switcher.



If you allocate only the minimum amount, you may run out of memory while working on a document that has a large
number of objects, particularly if there are many bitmapped objects in the Draw layer. You can only open one window
at a time with 445K of memory. Therefore, you cannot create or edit LaserBits objects with only 445K bytes of
memory allocated.

SuperPaint works better if you let it allocate the preferred amount of 625K. With this amount, SuperPaint can open
up to four windows at once. With a single document open, that document can have a very large number of objects.

For SuperPaint to work properly with Switcher and other programs, all the programs being loaded into Switcher,
including Switcher, must reside on the System disk. This is because of the way the Clipboard works in SuperPaini—
it is not a constraint inherent in Swiicher. This will not be a problem for hard disk owners, since the hard disk is
usually the System disk, and also contains all the programs. With an 800K disk, you may need to set up different
disks that contain the groups of programs that you want to load into Switcher.

Networking with AppleShare

SuperPaint 1.1 is compatible with AppleShare and is “multi-launchable.” This means more than one person can run
the same copy of SuperPaint when it is residing on an AppleShare server. However, all users running SuperPaint
from the server must have their own *“SuperPaint Prefs” file in their system folder, and “SuperPaint Prefs” files on the
server must not be in the same folder as SuperPaint. SuperPaint 1.1 will display an error message if more than one
user tries to open the same document from the server.

Printing with LaserWriters

SuperPaint 1.1 requires LaserWriter driver 4.0 or later and ImageWriter driver 2.5 or later. If you are using SuperPaint
on a network with other Macintoshes, all machines should be using the same driver version.

The 4.0 or later LaserWriter drivers have some options worth noting. When printing from SuperPaint, the Larger
Print Area option should always be turned ON (click in the box so that an X appears). The Precision Bitmap
Alignment option determines the look of painied images and the size of the printed document. If this option is ON
(the box is checked), then Draw objects are reduced slightly in size and the painted images are left intact. The size of
the actual printout will be 7.66" x 9.60". If the Rulers maich Precision Bitmap Alignment option is ON in
the Preferences dialog box, the on-screen rulers will match the printout. This choice provides the best printout of the
Paint layer, bitmapped objects in the Draw layer, and LaserBits.

Conversely, if Precision Bitmap Alignment is OFF (not checked), painted images get stretched, causing
distortion or misalignment of the Paint layer, bitmapped objects in the Draw layer, and LaserBits. If the Rulers
match Precision Bitmap Alignment option is OFF, the on-screen rulers will match the printout. The size of
the actual printout will be 8" x 10". This is the maximum printing area available in this version of SuperPaint.

The Faster Bitmap Printing option can speed up printing with SuperPaint, but Apple warns that you may have
problems (such as a system or printer error) when using this option. We have also noted distortion of LaserBits and
scaled painted objects when this option is ON. If you experience difficulties printing, turn the Faster Bitmap
Printing option OFF.

The LaserWriter smoothing setting only effects painted images. Objects in SuperPaint’ s Draw layer are not effected by
“smoothing.” These objects always print at the full resolution of the output device.

In the SuperPaint 1.1 Page Setup dialog, you can now use values greater than 100% to produce LaserWriter
enlargements. For example, by setting this value to 200%, SuperPaint 1.1 will print four 8" x 10" documents which
could be pasted together for a large-scale layout.

At the bottom of the Page Setup dialog for PostScript LaserWriters is a setting labeled Align Patferns on
LaserWriter/LaserWriter Plus. This box should normally be checked if you’re printing to a LaserWriter or a
LaserWriter Plus. If you’re printing to a LaserWriter IINT or LaserWriter IINTX this box should not be checked.

This setting turns on or off a fix for a pattern alignment problem that exists on the LaserWriter and LaserWriter
Plus. This pattern alignment problem has been corrected in the LaserWriter IINT and LaserWriter IINTX printers.



SuperPaint uses custom PostScript code to accelerate the printing of LaserBits, and to map QuickDraw gray patterns
in the Laser Grays palette to their PostScript halftone equivalents. This may cause problems with print spoolers,
other non-standard printing software, or non-Apple laser printers, The Send Custom PostScript to Printer
setting found in the LaserWriter’s Page Setup dialog allows you to turn off this feature if it is causing problems
with your printing setup.

The recommended settings for PostScript LaserWriters for most SuperPaint printouts are:

Command Setting Status
Page Setup Faster Bitmap Printing CFF
Page Setup/Options Larger Print Area ON
Page Setup/Options Precision Bitmap Alignment ON
Options/Preferences Rulers match Precision Bitmap Alignment ON

Use the following settings if you need a full 8" x 10" print area. Note the bitmaps will be distorted but not reduced:

Page Setup Faster Bitmap Printing OFF
Page Setup/Options Larger Print Area ON

Page Setup/Options Precision Bitmap Alignment OFF
Options/Preferences Rulers match Precision Bitmap Alignment OFF

The recommended LaserWriter IISC settings for most SuperPaint printouts are:

Page Setup Exact Bit Images ON
Page Setup Text Smoothing ON

The “Exact Bit Images” option on the LaserWriter [ISC makes bit images print perfectly, but everything on the page
will be shrunk by 4% and the quality of the printed text will suffer. The “Send Color to Printer” option has no effect
on the quality of the printout.

Printing with GCC LaserPrinters

The recommended GCC Personal LaserPrinter settings (using PLP driver 2.0) for most SuperPaint printouts are:

Command Setting Status
Page Setup Send Color to Printer OFF
Page Setup Smooth Bitmaps? ON
Page Setup/Options Best-locking bitmaps? ON
Page Setup/Options Always align objects with bitmaps? ON
Page Setup/Options Enlarged printable area? ON

Whenever you have “Best-looking bitmaps” turned on, you should also turn on “Always align objects with bitmaps.”
SuperPaint documents will print on the Personal LaserPrinter in the High, Medium Draft (150 dpi), and Draft (75 dpi)
modes. When the Personal LaserPrinter prints at 300 dpi, it does not scale patierns to match the screen display. Thus,
patterns printed on this printer do not maich the screen display.

Printing with ImageWriters

A Print Darker on ImageWriter I at Best Quality option is available in the Page Setup dialog when
printing with an ImageWriter I or I. This setting only effects Best quality printing on the ImageWriter I and
ImageWriter I wide carriage printers. When this box is checked, the Paint layer and all bitmapped images will be
printed dark in the Best mode.

Like most Macintosh programs, SuperPaint needs some free space on your startup disk when you print the document
to an ImageWriter. A rule of thumb is the startup disk must have free space equal to two to three times the size of the
document to be printed.



Printing with Other Printers

On printers other than ImagerWriters or PostScript LaserWriters, the Page Setup dialog has an additional check
box labeled Send Color to Printer. This setting is for use only with black and white printers that do not
correctly ignore or remap any color information in the document such as the GCC Personal LaserPrinter with GCC
driver 2.0. An example of this problem is shown below.
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If the output from your printer has the problem shown above, choose Page Setup... from the File menu and
click to turn off the Send Celor to Printer command. The color information will not be sent to your printer
and the problem illustrated above will not occur.

Compatibility with New Hardware Products

SuperPaing 1.1 is compatible with the AppleFax Modem, the LaserWriter IISC, IINT, and IINTX printers, the
ImageWriter LQ printer, the General Computer Corp Personal LaserPrinter and other “non-PostScript” printers.
SuperPaint 1.1 supports the shghﬂy smaller page size used by some of these printers, as well as the standard A4 paper
size used in Europe. If you are using a LaserWriter, be sure to turn on the Precision Bitmap Alignment and
Larger Print Area options to avoid clipping a small portion of the right side of the document.

Prefs Notes

If SuperPaint 1.1 does not find a “SuperPaint Prefs” file in the system folder or in the same folder as SuperPaint, it
will create a new “SuperPaint Prefs” file.

SuperConvert™ 1.1

The SuperPaint 1.1 disk includes SuperConvert 1.1, a utility program that provides conversions to and from LaserBits
and other high-resolution bitmap formats. The SuperConvert 1.1 documentation is on the disk in the MacWrite file
called “SC 1.1 User Manual.”

SuperConvert converts SuperPaint files containing LaserBits objects to and from the following high-resolution
bitmapped file formats: ThunderScan®, Tagged Image File Format (TIFF), and Encapsulated PostScript® (EPS). Iis
main function is to convert scanned images from ThunderScan and TIFF to LaserBits format for editing, and to convert
LaserBits images to TIFF or EPS formats for importing into other programs, such as page-layout programs.

If a scanned-image TIFF file contains gray-scale information, an alert appears to inform you that this file cannot be
converted into a bitmap. For best results when importing scanned images into SuperPaint, save the scanned image in
the SuperPaint 1aserBits file format whenever possible.



Part 1: Getting Started

Errata

Page 4: The second paragraph says there are two pattern palettes. Actually, there are four. The first palette
contains the common “design” patterns. The second palette contains a range of gray patterns referred to as the
“LaserWriter Grays.” The third pattern palette is blank, allowing you to easily add and save your own patierns.
The fourth palette contains various line-patterns and cross-hatches.

Page 5: As mentioned above in Memory Congiderations, you cannot open more than 2 windows on a 512K
Macintosh. On a Macintosh Plus, SE, or II, you can usually open 9 to 10 windows at once.

Page 9: The seventh paragraph says that the Hide Back Layer command is in the Options menu. Actually, it
is in the Windows menu.

Enhancements

It is possible to have your own patterns available at all times by placing them in the “SuperPaint Prefs” (short for
preferences) file, To do so, close all document windows and then modify the pattern{s). The changes will be recorded
in “SuperPaint Prefs” as soon as you click the OK button in the Edit Patterns dialog.

When you edit patterns with a document open, the changes are saved with the current open document. These changes
are not recorded in the “SuperPaint Prefs” file. The next time you open that particular document, you’ll have the
modified patterns available. If you open a different document, or use the New command, you’ll get the pattern palettes
that are stored in “SuperPaint Prefs.”

Part 2: Painting

Errata

Pages 29-32: For selections in the Paint layer that are being rotated, distorted, stretched, etc., the handles are not
hollow, as illustrated in the manual. They are filled. This helps distinguish them from the handles on LaserBits
objects, which are hollow.

Page 30: The second paragraph on the Stretch command says you can stretch a selection by moving the cursor
over one of the edges alter selecting the Stretch command. This is not correct. The shortcut discussed at the bottom
of page 30 (Command-Shift dragging a rectangular selection) does work, but it does not involve the Stretch
command. Once you choose Stretch, you can only pull on the handles. You can constrain a stretch to the first
direction in which you move the cursor, either vertical or horizontal, by holding down the Shift key while stretching.
You can also enable proportional stretching by holding down the Command and Shift keys while dragging the handle.

Enhancements

Two handy features have been added to the Brush Shapes dialog. First, while editing a brush shape, you can replace
the current brush with a design taken from anywhere on the screen. Simply move the cursor outside the dialog and
press the mouse button. Drag the cursor while holding down the mouse button. ‘Whatever is under the cursor also
appears magnified in the brush editing box. Adjust the cursor position until the box contains the design you want,
then release the button. This is called “Picking up a Brush.” If you don’t like the design, click the Revert button and
try again. Second, if you Command-click in the brush editing box, all dots in the design are inverted.

You can use the current fill pattern to fill a selection made with the Selection Rectangle tool. To do so, choose Fill
from the Paint menu. If you are using Transparent paint (see page 16), the original contents of the selection
rectangle will show through any white portions of the pattern. If you Fill with Opaque paint (again, see page 16),
the previous contents of the selection rectangle will be completely obscured.



The Free Rotate effect can be constrained to rotations in increments of 5 degrees by holding the Shift key while
rotating. Unlike Rotate Left and Rotate Right, which are restricted to a maximum size of 8 inches by 8 inches,
you can select and rotate the entire Paint layer with the Free Rotate effect. Of course, any portion of the Paint layer
that ends up off the 8" by 10" page will be lost. For best results when rotating in the Paint layer, leave a little white
area showing around the object by making the selection rectangle slightly larger than the area to be rotated.

While using the Distort effect, you can constrain your movement to the first direction in which you move the
mouse, either vertical or horizontal, by holding down the Shift key while dragging.

When using Perspective, you can drag the handles either vertically or horizontally. For a symmetrical effect, you
can hold down the Shift key while dragging and the corresponding corner will move toward or away from the center,

Part 3: Drawing
Errata

Page 56: The vertex numbers referenced in the first paragraph are incorrect. Figure 3.26 shows vertex 1 being
dragged, and the new vertex is inserted between vertices 1 and 2.

Page 56: Figure 3.27, illustrating the Align Objects dialog, is incorrect. While the description on page 56 is
correct, the dialog looks like this:
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Page 57: The “Not Transparent” choice mentioned in the second paragraph has been renamed as Opaque. Thus,
the Draw menu now contains the choices, Opaque and Transparent.

Page 58: The last paragraph states you cannot specify a foreground color of white nor a background color of black.
This restriction has been lifted. You can assign any color to either the foreground or the background.

Enhancements

The Draw menu contains three new commands: Lock, Unlock and Align to Grid. By locking an object, you preclude
any modifications to it. For example, while an object is locked, you cannot change its size, shape, position, border
thickness, colors, or patterns. However, you can change its stacking order with the Bring to Front or Send to
Back commands. To lock or unlock an object or objects, select the object(s) and choose Lock or Unlock from the
Draw menu. The handles of locked objects are drawn in a gray pattern to distinguish them from unlocked objects.

If you have checked the Grid snap on button in the Grids and Rulers dialog, the Align to Grid command is
enabled. When this command is chosen, all selected objects will shift so that the top left-hand corner coincides with
the nearest grid point.

You can rotate most drawn objects, however, painted objects, text objects and LaserBits objects will not rotate, All
other objects can rotate 90 degrees at a time by using the Rotate Right and Rotate Left commands in the Edit
menu. If you rotate several objects at once, each will rotate in place. You can Group multiple objects and then rotate
the group around a single point. If the group contains objects that cannot be rotated (i.e., painted objects, text objects
and LaserBits objects), all objects that can be rotated will rotate, and the remainder will be moved but not rotated.
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There are a few more details regarding text in the Draw layer that need to be mentioned:

= A text object cannot be edited when it has been grouped. You must choose Ungroup before editing.

= Some spelling checker programs, such as MacProof, will work on text in SuperPaint. However, you may have
to reformat the text after using these programs.

» Creating a new text object in front of an existing one can be tricky. When you press the mouse button to define
the boundaries of the new object, SuperPaint may decide you are defining an insertion point in the old one instead.
To avoid this problem, just hold down the Command key while you drag the new text object.

 Text is not resized when a selection is scaled.

There are two ways to display the color palette. The standard way is to choose Show Color Palette from the
Options menu. A shortcut is to hold the Option key and click in the pattern palette. If you “Option-click” again,
SuperPaint will switch back to the pattern palette.

Miscellaneous

In Apple’s MacDraw, polygons can be “smoothed.” Since SuperPaint does not have this feature yet, any polygons
smoothed in MacDraw and then copied and pasted into the Draw layer of SuperPaint will not retain their smoothing.
Pasting into the Paint layer will retain the smoothed shape, but the polygon becomes a bitmapped image.

There is a bug in the ImageWriter 2.3 driver that effects text objects in Outline or Shadow style when printing on an
ImageWriter II with a color ribbon. The ImageWriter does not follow your color assignments, and you may find text
filled or cutlined with some unexpected colors. To avoid this problem, use ImageWriter driver 2.5 or later.

Part 4: Both Layers

Errata

Page 66: The first paragraph states the top left of the document is saved as the StartUpScreen. This is not
correct. The upper-left corner of the visible portion of the document becomes the upper-left corner of the
StartUpScreen. If you use the Full Screen mode to preview the StartUpScreen and then go back to having the menu
bar and paleties on screen, the visible upper-left corner will be different. You can use Full Screen to figure out which
portion of the document you want to be the StartUpScreen, noting carefully the upper-left corner. When you change
back to normal screen with menu bar and paleties showing, you will need to shift the viewing area so that the visible
upper-left corner is the same as it was in Full Screen mode. Then do a Save As... and click in the StartUpScreen
button in the dialog.

Page 67: The second paragraph says you must turn on a “Print in Color” option in the Preferences dialog in
order to print in color. This has been changed. If you assign colors to objects and have a 4-color ribbon in an
ImageWriter 1, the printout will be in color. To print in black and white, use a black-only ribbon,

Page 70: The right side of Figure 4.7 which depicts how the LaserWriter breaks a 400% expanded document into
pages, and the associated description, is incorrect. In fact, when a document is split into multiple pages, the top left-
hand corner is page 1. Subsequent pages are numbered down, then across. Thus, reading across, the right side of
Figure 4.7 should be page 1, 5, 9, and 13, elc., as shown below.
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Page 73: Figure 4.10 is incorrect. The Scale Selection dialog contains an additional button labeled Other.
Click this button to enter a scale factor other than 25, 50, 200, or 400%.

Pages 75-76: The procedures for using the Grid and Rulers have changed a bit from the way they are described in
the manual. First, they have been combined into one command, Grid & Rulers... in the Options menu. Any
changes you make in this dialog will be saved with the document that you are working on. For example, let’s say you
check “Show rulers” and “Grid snap on,” and then save the document. The next time you open that document, the
rulers will be visible and “Grid snap” will be in effect.
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Page 77: Figure 4.15 and the accompanying description are incorrect. The Edit Patterns... dialog contains three
buttons: OK, Save, and Revert. To replace the selected pattern with one you have edited, click the Save button. To
return the edit box to its original pattern, click Revert. To exit the Edit Pattern dialog after modifying the original
pattern, you must click either the Save or Revert button, then the OK button.

‘While editing a pattern, you can “pick up” a pattern from anywhere on the screen. Simply move the cursor outside the
dialog and press the mouse button. Drag the cursor while holding down the mouse button. For added precision, press
the Option key while dragging the mouse. This allows the pointer to move in increments of one pixel instead of
eight. Whatever is under the cursor also appears in the pattern editing box. Adjust the cursor position until the box
contains the desired pattern, then release the button. If you don’t like the pattern, click the Revert button and try again.
If you want to invert all the dots in the edit box, just Command-click inside the box.

There is a shortcut for choosing the font size already contained in the Size menu’s Other command. For example, if
the “Other” font size is 6 points, and you want to use a 6 point font size, hold down the Option key while you choose
Other... from the Size menu. The dialog in which you normally enter the “Other” size will not appear. Instead, the
current “Other” font size will immediately become the current font size. The current Other size is displayed in
parentheses in the Size menu (e.g., Other (6)...). In fact, like the rest of the Size menu choices, the Other choice
displays in outline style if its current setting is an installed font size.

Enhancements

If you need to use Scale Selection... over and over again, applying the same scaling factor each time, there is a
shortcut. Hold down the Option key while you choose the Scale Selection... command from the Edit menu.
SuperPaint will immediately scale the selection without making you fill out a dialog. It will automatically apply the
percentage of scaling you used last.

There is a shortcut for changing between the current Grid & Rulers... settings and having them all turned off.
Hold down the Option key while you choose Grid & Rulers... from the Options menu. Instead of having to fill
out the associated dialog, SuperPaint will switch from your customized settings to everything off, or from everything
off to your original settings.



There are shortcuts for turning the Rulers and Grid on and off individually. Press Command-Shift-G to turn the Grid
on, This also enables “Grid snap” if it was off, or vice versa. Command-Shift-R works similarly for the Rulers.

The description of the Turn Scrolling On/Off command on page 78 neglects to mention a keyboard shortcut: To
switch between the automatic Scrolling On and Off modes, press Command-" (the reverse apostrophe).

You can move selections in either layer by a single screen dot (1/72 inch) at a time, using the Nudge commands in
the Option menu. You can nudge the selection up, down, left, or right. Each of the Nudge directions has a
Command key equivalent. Command-Y is the same as Nudge Up, Command-J is Nudge Left, Command-K is Nudge
Right, and Command-M is Nudge Down. These keys form a kind of skewed diamond on the keyboard. The top of the
diamond (Command-Y) moves the selection up, just as the remaining keys move in directions corresponding to their
positions on the diamond. On a Macintosh Plus, SE, or II keyboard, you can use the arrow keys as shortcuts for the
Nudge commands. Each time you press an arrow key, the selection moves one screen dot in the direction of the arrow,

Miscellaneous

Certain tools ignore the “Grid snap” effect. These are the Lasso, Brush, Pencil, Spray Can, Eraser, and the Freehand
Tool in both layers. Grid snap will also be ignored whenever you are proportionally sizing something. The Grid is
never visible when you hide the back layer.

If you intend to print with a PostScript LaserWriter, SuperPaint 1.1 requires LaserWriter driver version 4.0 or later. If
you have problems printing on a LaserWriter, check to be sure that you are using the correct version of the driver,
How can you tell which version of the LaserWriter driver you are using? The Page Setup Print... dialog will tell
you. The top, right-hand comer of the box contains the version number. If there is no number, or if the number is
not at least 4.0, you have the wrong version. You can get the right version from your Apple dealer.

The fact that SuperPaint uses the standard LaserWriter and ImageWriter driver files provided by Apple Computer has
such benefits as making SuperPaint work readily with spooler software, enabling foreground and background colors,
and having colored objects print in color when pasted into other applications. This also means that we must accept the
output these standard drivers produce. Depending on whether you’re using an ImageWriter I or I and whether you’ve
selected Best or Faster mode, the quality of the printouts will vary. In some cases the images in one layer may not be
as dark as those in the other layer,

Part 5: LaserBits™

Errata

Page 81: The first paragraph says to start by making a selection with the Selection Rectangle. Actually,
selections that will be turned into LaserBits objects may be made with the Lasso or Two-Layer Selection tool as well.

Miscellaneous

If you use SuperPaint 1.1 to open a LaserBits document created with SuperPaint 1.0, the panels may be slightly
shifted. Just realign the panels and save the LaserBits document with SuperPaint 1.1. Do not use SuperPaint 1.0 with
this LaserBits document since the panels will be misaligned again.

A LaserBits document can contain anything in both the Paint and Draw layers, including object text.

A LaserBits object prints at full 300 dots-per-inch resolution on the LaserWriter only when you print the document
that contains that LaserBits object. If you open a LaserBits document with the Open or the Open LaserBits
commands and print it while you’re working in that LaserBits window, it will be printed in the normal 8 by 10 inch,
72 dots-per-inch resolution,

When you make a selection and create a LaserBits object from it, the original selection is not automatically erased from
the current layer. Thus, you can leave it intact and move the LaserBits object elsewhere, if you like. However, in
most cases you will probably want to cut the portion of the layer that was originally selected to create the LaserBits
object. It won’t be obvicus that it is still there because the LaserBits object may obscure it.
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When you select a LaserBits, text, or painted object, the Flip and Rotate commands in the Edit menu should be
dimmed but aren’t. Though these commands are not available at that point, this is not an oversight. Instead, it stems
from a decision made in the interest of speeding up the program. If SuperPaint were to dim these commands when
appropriate, the extra processing would cause a delay of up to a full second every time you wanted to use one of these
commands. If you try to use Flip and Rotate when a LaserBits, text, or painted object is selected, nothing happens.
While this is not the way a Macintosh program is supposed to behave, we assumed you would prefer this minor
inconvenience to a sluggish program.

Tips and Techniques
Shifting An Entire Document

Occasionally, you may need to shift the position of an entire document on the page, while keeping both layers
together, To do this, you must shift each layer’s contents individually. Here is the best way to accomplish this:

Start with the Draw layer. Choose Reduced View from the Windows menu. Draw a small, hollow rectangle in a
convenient corner of the document. Be sure to place the rectangle in a location that does not overlap anything in the
Paint layer. The rectangle should be in a portion of the document that will remain on the page. Select the rectangle
and choose Copy to Painting from the Edit menu. You will use this rectangle to align the layers.

Choose Select All from the Edit menu and drag the Draw layer’s contents wherever you need them. Then switch to
the Paint layer and choose Select All. Drag the Paint layer’s contents until the two rectangles or “registration
marks™ are superimposed. When you have finished repositioning the document, clear the rectangle from the Draw layer
and erase it from the Paint layer.

Getting the Most Out of a LaserWriter

The LaserWriter is capable of 300 dots-per-inch (dpi) resolution, as opposed to 72 dpi resolution with the ImageWriter.
There are two ways o get this higher resolution: use objects that are created in the Draw layer and use LaserBits. One
good rule of thumb is to create your graphics in the Draw layer whenever you can. This is especially true for text.

The patterns in the “gray” pattern palette are special. With Precision Bitmap Alignment off, all other patterns
print at 75 dpi, even on the LaserWriter. The LaserWriler prints at 75 dpi, which is why the rulers are different for the
ImageWriter and the LaserWriter. However, the Draw layer grays are printed at 300 dpi on a LaserWriter. Since the
screen can only show 72 dpi, these gray patterns will look much better on a LaserWriter printout than on the screen.

When you copy from the Paint layer to the Draw layer, or paste something that consists of dots into the Draw layer
from some other program, you get a “painted object.” These normally print at 75 dpi on the LaserWriter, as they are
just collections of dots. But having the dots in the Draw layer allows you to do something you can’t do in the Paint
layer—scale the painted object down in size and mot lose any of the dots. If you select a painted object and scale
it to 50% of its original size, even though it looks so-so on the screen, it will still print all those dots in half the arca.

Scaling a painted object to half size packs the dots in to 150 dpi. If you scale the image to 25%, it packs the dots in
t0 300 dpi. These packed bitmapped objects will normally look terrible on the screen and be sluggish to move around.
They also take a lot of memory and will make the files they are saved in quite large, requiring a lot of disk space. But
they can produce some beautiful results on the LaserWriter. They also can be copied to the clipboard or scrapbook and
pasted into other programs.

Finding LaserBits Files

SuperPaint first looks for a LaserBits decument in the same folder as the master document. If the LaserBits document
is not found, it looks where the master document was originally located. If the LaserBits document still cannot be
found, it opens a search dialog. To avoid this problem, if you copy a SuperPaint document to a new disk, you should
copy all of its LaserBits files to the new disk, too.
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An Entire Page of LaserBits

You can create a 300 dots-per-inch painted document with SuperPaint fairly easily. This super-high-resolution
document will contain over 7 million dots—16 times the number of dots in a typical paint layer.

First, start with an image in the Paint layer. You will have to split this 8" x 10" image into sixteen 2" x 2.5"
LaserBits documents. Choose the Grid & Rulers... command from the Options menu and set up a 0.5" grid.
Then turn on the Grid Snap and Show Rulers options. Click the OK button. Starting at the top left corner of the
document, use the Selection Rectangle tool to select a segment of the document that is 2" wide by 2.5" high, i.e., 4
snaps over and 5 snaps down. Then choose New LaserBits from the File menu. SuperPaint will create a LaserBits
document from the original segment. Save it, assigning the LaserBits document an appropriate name. Next, start at
the upper right corner of that first segment and select the next 2" x 2.5" segment. The Grid will not allow you to
select any portion that has already been selected, nor will it allow you to miss anything just to the right of that first
segment. The Grid makes sure that everything gets selected eventually, and that there is no overlap. Remember that
you will probably want to erase all the dots in the Paint layer when you are done with this process.

Repeat this sequence for each of the 16 segments. The rest is up to you. You can open each of the LaserBits versions
of the segments and add all the details you want. You can make full use of both the Draw and Paint layers in the
LaserBits documents. Before printing, switch to the Draw layer and choose Hide Back Layer from the Windows
menu. This will prevent the original Paint layer from showing if it had not been erased.

If you are working with 300 dpi scanned images, it is worth noting that most of the major manufacturers of 300 dpi
scanners provide an option to save their scanned image directly into the SuperPaint document format, The resultis a
“master” document that has 16 LaserBits objects, each 2" x 2.5" in size. Of course, all of the actual dots are being held
in 16 separate LaserBits documents which are automatically “linked” to the master document.

You should always open the master document when making changes to a LaserBits document. Then, when you save
the changes to the LaserBits document, a dialog opens to remind you to save the changes to the master document also.

Printing in Color

Having trouble with the concepts of Foreground and Background colors? It’s no real rick. When you set an object’s
Foreground color, you're telling SuperPaint which color to print for the black parts of the object. Likewise, the
Background color substitutes for the white parts, but not the transparent parts, of the object. You can separately color
the Line (border) and Fill (interior) portions of an object. Thus, an object can have as many as four colors; two for
the interior and two for the border.

Want to use more than one color in the Paint layer? You can’t do it directly, but there is an alternate method: Using
the Lasso or Selection Rectangle tool, select each portion you want to color and make a painted object out of it by
choosing Copy to Drawing from the Edit menu. Erase the Paint layer copy by pressing the Backspace or Delete
key, then switch to the Draw layer, select the new painted object, and assign the desired colors (o it.

Need more than the eight colors provided by the Color palette? There’s a method called “dithering™ which can be used
to simulate more colors. Instead of using a solid color, choose a gray pattern. Then choose foreground and background
colors that mix to produce the desired result. For example, to produce yellow-green, choose vellow and green as your
foreground and background colors. You can adjust dithered colors by choosing gray patterns that are more or less
dense. The denser or darker the gray, the more emphasis there will be on the foreground color, and vice versa.

You can assign only one color to the entire Paint layer. With the color palette visible, the Line/Fill selector set to
Fill and the Paint layer on top, you can choose a foreground color. The black dots in the Paint layer will be printed in
this color. Since the Paint layer is always (ransparent, you cannot designate a background color.

You can Copy objects that have been assigned colors and then Paste them into other programs such as MacWrite or
Microsoft Works. When you print using an ImageWriter II with a 4-color ribbon, these copied objects should still
print in color. However, assigned colors do not carry over to Silicon Press, the label printing utility. It was developed
before Apple provided color printing in the ImageWriter driver file and so it has its own color printing software.

SBS 2-24-88
TIB
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SuperPaint Shortcuts

Command Keys

8080 HH0e000066

Scroll Send to Bring to
Off/On Back Front
Quit Reduce Copy to Reshape Text NudgeUp Ungroup Iralic pen Plain
View Other Polygon Pattern
Layer

(AJ[SJ(DJ(FJ(GJ[HJ[JJ[KJ[LJ(;J(;J

Select All Save Duplicate Full Group Hide Nudge  Nudge Hide/Show Print
Screen Palettes  Left Right Back Layer

8000000066 w»

Undo Cut Copy Paste Bold New Nudge Change

I Juhnil

Choose Select All (Paint) -
Use Seclection Rectangle  —
Pencil in painting =
Click non-magnified side —
Shift-R =
Shift-G =

Press Ontion kev and.,.
Choose Select All (Paint) —
Use Selection Rectangle =
Use Lasso -
Use Paint Bucket =
Click on a pattern =
Click on color palette -
Click on Layer Selector -
Choose Scale Selection —
Drag a selection (Paint) -
Command key and drag -
a selection (Paint)

Minimal seclection on page

Minimal selection within rectangle

Direct to 8X magnification
Direct to no magnification
Show/Hide Rulers

Show Grid and Grid snap on/
Hide Grid and Grid snap off

Lasso entire Paint layer
Lasso the selection

Include white area

Fill on-screen only

Change to color palette
Change to normal palette
Hide/Show Back Layer

Use last scale percentage
Leave a single copy behind
Leave multiple copies behind

Down

Double click,,.
Selection Rectangle tool
Paint Brosh

Pencil

Magnifier

Eraser
Command-Option-Eraser
Rectangles, Oval, Circle
Any pattern

Tide Bar (old ROMs only)
Polygon

Press Shift key and..,
Make lines & shapes
Option-lines and shapes
Use Perspective

Click on objects

Move selection(s)

Miscellaneous
Space Bar

Layer

Select entire window

Edit brush shape

Direct to 8X magnification
Direct to 8X magnification
Erase window

Erase entire Paint layer
Paint/draw from center
Edit that pattern

Zoom the window
Complete polygon

Constrain lines to 45° & 90°
Constrain lines to 30°, 60°, 90°
Opposite corner moves too
Select/deselect multiple objects
Constrain movement to
horizontal or vertical

Hand



