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What is ShrinkWrap?

ShrinkWrap is a utility application which allows you to create and/or mount disk image 

files conveniently. You can also use it to write the image back to another disk. Additionally, 

ShrinkWrap gives you a quick method for mounting disk image files on the Desktop. You 

can even take advantage of Aladdin's industry-standard StuffIt compression to reduce the 

size of the image files you create.

ShrinkWrap is a Mac OS application for Macintosh and Power Macintosh, requiring 

System 7.1.1 and later for most of its features.  It contains both 68K and PowerPC native 

code, is AppleEvent aware, 32-bit clean, AV, ’040 cache and virtual-memory compatible.  

Although a Macintosh SE or better is required for full functionality, the Mac Plus can still 

use ShrinkWrap to mount, convert and verify uncompressed disk image files.  The 

Component Manager, available with QuickTime 1.6 or System 7.1 or later, is required to 

handle compressed or encrypted disk images. To take advantage of the new HFS+ and 

large volume support introduced with ShrinkWrap 3.5, you will need to be running MacOS 

8.1 or later. MacOS 8 or later is required for Appearance Manager and MacOS 8.5 or later 

for Navigation Services.

How to Contact Aladdin Systems

Web: http://www.aladdinsys.com

email: info@aladdinsys.com

FAX: (831) 761-6206

Phone: (831) 761-6200

Mail: Aladdin Systems, Inc.
165 Westridge Drive
Watsonville, CA 95076

Alternatively,  use the iSupport menu for Internet support (described on page 27).
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Disk Images and Why We Use Them

Why do we need to deal with disk images?
Although there is some similarity between disks duplicated from disk images 
and disks copied by dragging icons, the results are not identical.  Disks 
created from image files are exact duplicates, including the exact icon 
placement, appearance of all windows, and the correct name of the disk.  In 
addition, with disk images you have the added assurance that all the files 
have been duplicated correctly and completely.  More importantly, Apple's 
Installer may not recognize disks copied by dragging icons, even if they appear 
identical in every way.

Some convenient uses for disk images:

1.  Backing up your original floppy disks to removable media:
A Magneto-Optical, Iomega, Bernoulli, SyQuest, SuperDisk or CD-R drive can 
serve as an excellent means to back up your software.  When disk image files 
are stored in compressed form, they are space efficient but still easily 
accessible with ShrinkWrap.  Just drag the compressed image onto the 
ShrinkWrap icon and the file will be immediately mounted on the desktop. 

2.  Installing Apple's System Updates and System Software Extensions:
Since most of Apple's System Software, System Updates and System 
Extensions (CD-ROM Setup, PlainTalk, printer drivers, etc.) are distributed 
online in image file format, it's convenient to be able to mount the images and 
run the Installer without ever having to copy the images back to floppy disk.

3.  Distributing multiple disk images on floppies:
Using compressed ShrinkWrap disk image files, you can often achieve 
adequate compression to store three or more 800K disk images on a 1.44 MB 
HD floppy.

4.  Mounting floppies on Macs without a SuperDrive or on a floppyless Mac:
For Macs not equipped with a SuperDrive or any newer Mac which has no 
floppy drive (such as the iMac), ShrinkWrap provides a cost-effective and 
convenient means of accessing data stored on HD floppy disks.
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5.  Creating “instant” RAM disks:
Placing a ShrinkWrap disk image file in your Startup Items folder will make 
it always available from startup, just like a RAM disk.  However, when you’re 
done with the ShrinkWrap RAM disk and need to free up the memory, just 
drag the mounted image to the trash.  No need to restart.  Many users find 
ShrinkWrap temporary RAM disks to be a fast and more space efficient place 
to store their Web browser’s cache files. This only works for non-compressed 
images.

6.  Distributing software collections and archives on CD-ROM:
ShrinkWrap provides a convenient and economical means for your customers 
to obtain copies of their software on floppy media even if your product is now 
being distributed exclusively on CD-ROM.  With ShrinkWrap's extensive 
AppleScript support and StuffIt InstallerMaker integration, you can even offer 
users the ability to create floppies directly from your product's installer.

7.  Verifying the integrity of development builds:
ShrinkWrap provides both DiskCopy and CRC-32 checksums to use in 
confirming the data integrity of floppies or CD-ROM’s when it's  vital that you 
ensure an exact copy was made.

What's New in ShrinkWrap 3.5?

ShrinkWrap 3.5 adds:

• Support for segmented disk images

• Support for HFS+ and volumes larger than 4GB — the NDIF format is limited to 
2GB volume sizes, so you would need to use sufficient compression to get larger 
volumes under this 2GB limit with NDIF.

• New Appearance Manager-savvy dialogs and progress bar

• Progress bar now indicates progress in the same manner as the Finder in its Copy 
dialog

• New Preferences Dialog which is a movable modal dialog with panels

• Navigation Services support, including multiple selection. Throughout this manual, 
whereever you see Open dialog, Open File dialog or Save dialog, the Navigation 
Services equivalent will be used if present.

• More custom options in the Mount and Save As… dialogs

• An option to copy only used blocks
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• Support for DiskCopy formats through 6.3

• The option to create image files with Drive Container format has been removed

How do I use ShrinkWrap?

Drag and Drop:
You will probably find that the most efficient way to use ShrinkWrap is via 
the drag and drop interface.  By placing the ShrinkWrap application or an 
alias to ShrinkWrap on your desktop, you can have quick access to almost all 
features just by dragging files, folders or volumes onto the ShrinkWrap icon.

1. The default actions for drag and drop items are as follows:
•  Image files:  These are mounted on the desktop just as if you had used the Mount 

Image command from the Image menu and selected each file individually.
• Disks:  Exact copies of these volumes are created and saved as disk image files, in 

the same manner as the Create Image from Disk menu command.
• Folders: A new image file is created, mounted and filled with the contents of the 

folder, just as with the New Image from Folder menu command.

Note: Any combination of file, folders or disks can be dropped 
onto ShinkWrap, but the order in which they are processed 
can be unpredictable.

2. Modifier keys can be held down while you drag and drop an icon or group of icons onto 
ShrinkWrap to change the behavior:

•  Shift:  Holding down this key will cause disk image files which are not compressed 
to be mounted as unlocked disks so that write operations are allowed.

•  Command:  Holding down Command will cause disk images to be written back to 
disk.  In the case of disk image files, this is the same as the Write Image back to 
Disk menu command.  For disks, this is equivalent to the Duplicate Disk command.

• Control:  Holding down Control will calculate 32-bit checksums for the selected disk 
images, just like the Verify Image and Verify Disk menu commands.

• Shift-Control:  Holding down Shift and Control will convert image files of all 
readable types to the current writable image format as selected in Preferences, just 
like the Convert Image menu command.  For example, if ShrinkWrap Self-Mounting 
is selected in the Creating Preferences panel, dragging a selection of image files or 
folders containing disk image files onto ShrinkWrap while holding down Shift-
Control will convert each of these disk image files to a self-mounting image file.
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• Option:  Holding down the Option key will bring up a one-time Preferences dialog 
that will allow you to make temporary changes to your Preference options.  These 
changes will stay in effect until you quit the application or enter the Preferences 
again and press OK.

Note: When the Command, Control or Shift-Control modifiers 
are used on a selection that contains folders, ShrinkWrap will 
process all the disk image files contained within the selected 
folders.

Note: In order for ShrinkWrap to tell that you've held down a 
modifier key, you must keep it depressed until the progress 
dialog appears.

3. All options in Preferences are also in effect for drag and drop.  For example, when copying 
or mounting, if the “Automatically decode and expand archives” option is enabled (as it is 
by default), archived and encoded files will be handed off to the StuffIt Engine for 
preprocessing and the files that the StuffIt Engine returns will be handled by ShrinkWrap.  
If a folder is returned, its entire contents will be searched to find image files that can be 
mounted.

Show Log:
The ShrinkWrap Log is a report of all operations that have been conducted 
since the beginning of the session, including dates and times, detailed 
information on the disk images processed, checksums and errors.  You can 
view the log at any time by selecting the Show Log command from the Edit 
menu.  The contents can be copied to the clipboard or saved to disk as a 
SimpleText document using the standard Save or Save As menu commands in 
the File menu.  If you close the Log windows later or quit, you will be prompted 
to save the log file.

Note: If you decline to save a log, you can reopen it at any time 
until you quit from ShrinkWrap.  The log is created on launch 
and runs continuously until you quit the application.  By 
selecting the Show Log command or Close, you just control 
when it's visible

Note: The Verify Image and Verify Disk commands will 
automatically open the log when they complete so that you 
can examine the results of the verification and record 
checksum values.
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Preferences:
ShrinkWrap 3.5's new Preferences dialog has a scrolling icon list on the left 
which allows you to set Preferences for eight categories of actions. The "Use 
Defaults" and "Revert" buttons apply only to the panel being displayed and 
not to all Preferences, collectively.

1. Checking “Expand archives” check box will cause any archive format 
currently supported by the StuffIt Engine (.hqx, .uu, .bin, .sit, .sea, .cpt, .pkg, 
.zip, .arc, .gz, and .Z) to be automatically expanded to locate image files if you 
have StuffIt Engine 3.5 or later installed on your computer. If this is checked, 
the “Delete archive after expanding” check box is enabled. Checking it deletes 
the archive from the disk after it has been expanded into its original image 
file.  Use this feature carefully. "Expand encoded files" provides similar 
functionality for files which are encoded in any of the supported formats listed 
in the dialog.
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2. The "Mounting" panel is where you set options about how image files 
should be mounted.

a) Checking the “Mount images unlocked by default” check box will cause 
ShrinkWrap to reverse the normal behavior of the Shift key, causing image 
files to be mounted as unlocked volume normally and to be mounted as 
locked volumes if the Shift key is held down. This is only available for non-
compressed image files — compressed image files may not be mounted as 
unlocked volumes.

b) Checking the “Keep mounted images in RAM” check box will instruct the 
ShrinkWrap driver to load mounted images completely into RAM, provided 
there's enough free memory available. 

Here is a quick review of the advantages of each method:
Mounting images into RAM:

Images mounted in RAM are accessed lightning fast (just like a RAM 
disk).
Images mounted in RAM never require any free hard drive space.
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The original images are less susceptible to corruption if your computer 
crashes.

Mounting images directly from the hard drive or server:
Each mounted image requires <1K of RAM.
Mounting the images occurs much faster, since the entire image file 
need not be immediately loaded into memory.
The maximum number of mounted image files is not limited by 
available RAM.

c) Checking "Automatically launch installer" will cause ShrinkWrap to scan 
each disk upon mounting for the presence of an Apple, Aladdin, or 
MindVision created installer application. If such an installer is found, it 
will be automatically launched after all the image files are mounted. Only 
the first installer found on an image will be launched.

Note: If you drag and drop a group of disk image files on 
ShrinkWrap with this option enabled, only the first installer 
found is launched.

Note: If a single image contains multiple installers (such as 
both the 68K and PPC versions) only the first found will be 
launched. To guarantee that you get the installer you wish, 
you should have this preference option set to Off.

d) Checking the “Auto-size mounted folders” check box will cause ShrinkWrap 
to skip the New Image dialog when creating the image file to mount a folder 
and use the suggested size that is normally displayed as the default value 
in the edit box.  This value is calculated to take into account the allocation 
block size of the new volume, overhead for the Boot Block, Master Directory 
Blocks, Volume Information Blocks, Catalog Tree and Extents Tree.  
However, the means of determining the probable size of the desktop 
database on the new volume is just an educated guess based on the number 
of files contributing bundles to the database.  You will likely have a few K 
left free on the new volume and there is the potential that there may not be 
room enough on the drive to build a full desktop database.
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3. The "Verifying" panel is where you set your preferences concerning the 
degree of verification you wish ShrinkWrap to perform.

a) Checking the “Verify mounted disk image checksums” check box will cause 
ShrinkWrap to verify the checksums of each image file prior to mounting it on 
the desktop.  This provides a means of confirming the data integrity of the 
image file prior to it being mounted, although at a noticeable performance 
cost.  If you mount images from a network, floppy or CD-ROM, the verification 
process can take several seconds to several minutes depending also upon the 
size of the image.

b) Checking the “Verify destination disk checksums” check box will provide an 
additional verification pass when copying image files to disk or conducting 
disk-to-disk copies to verify that checksums on the destination disk match the 
original.  This verification pass is in addition to sector-by-sector verification 
already done by the driver.

c) Checking the “Confirm overwriting destination disk” check box will cause a 
confirmation dialog to be displayed each time you are about to overwrite a 
formatted floppy disk.
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4.  The Creating panel has four popup menus and a checkbox to define what 
format images you create by default as well as other options to be used when 
creating disk image files. These popups will be shown and explained on the 
following pages.
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a) The “File Format” pop-up menu indicates what image file format should be 
used when creating or converting new disk image files.  Disk image files are 
generated using the New Image, New Image from Folder, Create Image from 
Disk, and Convert Image commands, or the equivalent modifier keys when 
used via drag and drop.
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b) The “Compression” pop-up menu indicates what compression method 
should be used when creating or converting new disk image files.  If the file 
format you’ve selected doesn’t support compressed disk images, this pop-up 
will be disabled.

None: No compression is used.  Same as DiskCopy’s Read/Write option.

Simple: Doesn't copy blank blocks.  Doesn’t require Component Manager.  
Same as DiskCopy’s Read-Only option.

DiskCopy: Uses DiskCopy 6.1 compression.  Same as DiskCopy’s Read-Only 
Compressed option.

StuffIt: Uses StuffIt compression.  Not supported by DiskCopy, but saves 
about 30% more space on average.

Note: Compressed image files can’t be mounted as unlocked 
volumes.  For this reason, the New Image and New Image 
from Folder commands will always create uncompressed 
image files, regardless of the current compression setting.  
After you’ve unmounted the disk image file, you can then 
convert it to a compressed image file using the Convert Image 
command.

ShrinkWrap 3.5 User Guide Page 12



c) The “Encryption” pop-up menu indicates what encryption method should be 
used when creating or converting new disk image files.  If the file format 
you’ve selected doesn’t support encryption, this pop-up will be disabled.  If 
you enable StuffIt’s RSA-compatible 40-bit encryption, ShrinkWrap will 
encrypt new disk image files using a password of your choice or a randomly 
generated password.  Encrypted disk image can be compressed or 
uncompressed and mounted as locked or unlocked volumes. 

Caution: Make sure to remember your password!  You will 
need it to access the encrypted disk image file. Aladdin has 
no key to assist in decrypting an encrypted file.
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d) The "Segment Size" popup sets the default image size. Most common 
media types are listed in the popup for your convenience. If you select 
"Single Segment" you will be get a full-sized, non-segmented image file. 
"Custom:" provides you with a dialog where you set your defaults in case 
you have a new media type or other requirement which necessitates it.

If you check the "Copy used blocks only" box, data in the space previously used 
by deleted files will not be copied to the image. You will thus end up with a 
full-sized image with no data in the space which contained unused blocks on 
the original volume. Use of this option will preclude the use of disk-recovery 
tools, such as Norton Unerase, to recover deleted files from the image. 
Selection of this option, in addition to the security provided by not 
unintentionally copying deleted files, results in an image which can be more 
significantly compressed.
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5. The "Stuffing" panel tells ShrinkWrap whether to compress the image files 
it creates into their own StuffIt archive using Aladdin's StuffIt Engine 4.5 (or 
later).

a) Checking the “Delete originals after compressing” check box deletes the 
original image file from the disk after it has been compressed into an 
archive.

b) Checking "Make archives self-extracting" creates archives which can be 
unstuffed even without possession of a StuffIt product.

c) Checking the “Encrypt archives with password” check box will encrypt all 
image file archives created with ShrinkWrap using a password of your 
choice or a randomly generated password.

Caution: Make sure to remember your password!  You will 
need it to expand any encrypted images in the archive. 
Aladdin has no special”key” to recover an image if the 
password is forgotten.
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6. The "BinHexing" panel contains a checkbox which tells ShrinkWrap to 
encode the file into BinHex 4.0 format (.hqx). 

a) Checking the “Automatically encode in BinHex format” check box will 
create a BinHex version of the final file that will preserve the resource fork, 
file type and creator, and Finder attributes when transferred over the 
Internet. It will also enable a subsidiary checkbox. 

b) Checking the “Delete after encoding” check box deletes the original disk 
image files after they have been encoded into BinHex format by 
ShrinkWrap. Use this feature carefully as you will only have the encoded 
file left.
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7. Use the "Batch" panel to set preferences for batch floppy mode and deleting 
image files after conversion.

a) Checking the “Enable batch floppy mode” check box will allow you to 
efficiently conduct batch operations on large quantities of floppy disks.  
Just keep feeding in disks and ShrinkWrap will continue to create image 
files, duplicate the disk images or verify the disks.  When you're done, just 
press Stop.

b) Checking the “Delete original after converting” check box deletes the 
original disk image files after they have been converted to a new image 
format by ShrinkWrap. Use this feature carefully as the original image will 
no longer be available to you.
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8.The Destination panel's four  radio buttons let you indicate where the image 
files and StuffIt archives created by ShrinkWrap should be stored.

a) Selecting “Same as ShrinkWrap™” will use the folder containing the 
running ShrinkWrap application. 

b) Selecting “Same as original” will use the folder (or desktop) that contains 
the original image file or disk.

c) Selecting “Ask” will prompt you for a destination with a Open file dialog at 
runtime.

d) Finally, selecting “Use:” will allow you to specify a default folder of your 
choice.  If ShrinkWrap for some reason can't find this folder on startup, it 
will default to the startup volume desktop folder.

Note: You should always choose your destination folder to be 
located on an unlocked volume with plenty of free disk space.
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Image Menu Commands

New Image - To create and mount a new blank disk image file on the desktop, do 
the following:

1. Select the New Image command from the Image menu.

2. Type in the name of the volume, or accept the default name “Untitled”.
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3. Set the volume type you wish to create from the Size popup menu.

4. If you chose the Custom option, set the size from the textbox which appears.
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5. Set the volume format and file system via the Format popup menu.

Note: While Mac OS Extended (also known as HFS+) volumes 
are more efficient in space utilization, they are only usable 
with MacOS 8.1 and later. Further, there is no gain in 
efficiency for volumes under 32 MB in size and no practical 
gain for volumes under 128MB, without the use of a tool to 
set a smaller than 4K allocation block size. This is due to the 
fact that no allocation block may be less than 0.5K in size 
and the default HFS+ block size is 4K. Under HFS (Mac OS 
Standard), there is a limit of 65K allocation blocks on a 
volume.

6. Hit the Create button.
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New Image from Folder - To create and mount a new disk image file with the 
contents of a folder from within the ShrinkWrap application, do the following:

1. Choose the New Image from Folder command from the Image menu.

2. Select a source folder using the Open or Navigation Services dialog which 
appears.

3. If the “Auto-size mounted folders” option is set in Preferences, you're done.  
Otherwise you'll see the New Image dialog.

4. Type in the name of the volume, or accept the default name of the folder 
name.

5. Select the volume size/type from the Size popup menu. (figure on next page)

6. If you chose the Custom: option, set the size in the textbox which will 
appear to the right.

7. Set the file system to be used in the Format popup menu.

8. Hit the Create button.
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Note: If you select a size for the new volume that is too small 
for the folder contents, a “Destination disk is full” error will 
result and the contents of the folder will be incompletely 
copied.  Under certain circumstances, the Finder may not 
allow you to unmount a completely full mounted image file by 
dragging it to the trash.  If this is the case, you will need to 
restart your Mac.

Mount Image - To mount a disk image file on the desktop so that it acts like a 
virtual floppy disk, do the following:

1. Select the Mount Image command from the Image menu.

2. Select the image file or folder containing image files you wish to mount from 
the Open dialog.

3. Check the option to mount as unlocked on the bottom if the image files are 
uncompressed and you need read/write access to the mounted disk.

4. Check the option to keep mounted images in RAM for faster access at the 
expense of available memory. This essentially makes the image file a RAMDisk.
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5. Hit the Open button.  

Note: Image files can be mounted only if they are located on 
local Macintosh disks or AppleShare servers.  If you attempt 
to mount an image file that is on a PC disk or mounted 
image, you may receive an error.

Unmount Image - To unmount image files in the Finder, just drag the mounted 
volumes to the trash.  To unmount from within the ShrinkWrap application, do the 
following:

1. Choose the Unmount Image command from the Image menu.

2. Select the disk image volume to unmount using the Open File dialog.

Note: Ejecting a mounted image file will only cause it to be 
automatically “reinserted”.  This prevents you from being 
prompted to reinsert the ejected volume later, a task that's 
almost impossible to accomplish from the system modal 
dialog.

Create Image from Disk - To make an image file of a floppy disk, CD-ROM, hard 
disk, removable disk or a mounted image, do the following:

1. Choose the Create Image from Disk command from the Image menu.

2. Select the disk or mounted image to copy using the Open File dialog.

3. If Batch Floppy Mode was enabled in the Preferences dialog, you will be 
prompted to enter another floppy disk when the first copy is complete.  Press 
Stop when you don't wish to create any more image files.
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Write Image Back to Disk - To write a disk image file back to disk, do the following:

1. Choose the Write Image to Disk command from the Image menu.

2. Select the image file to copy using the Open File dialog.

3. Insert a destination disk or select the destination volume in the Save 
dialog.

4. If Batch Floppy Mode was enabled in the Preferences dialog, you will be 
prompted to enter another floppy disk when the first copy is complete.  Press 
Stop when you don't wish to make any more copies.

Caution: The unlocked floppy disk that you insert or 
destination volume that you select will be totally overwritten 
with the contents of the image file.  For an additional layer of 
protection, enable the option to confirm overwriting the 
destination disk in Preferences.

Duplicate Disk - To duplicate disks, do the following:

1. Choose the Duplicate Disk command from the Image menu.

2. Select the floppy disk volume to duplicate using the Open File dialog.

3. Insert a destination disk or select the destination volume in the Save 
dialog.

4. If Batch Floppy Mode was enabled in the Preferences dialog, you will be 
prompted to enter another floppy disk when the first copy is complete.  Press 
Stop when you don't wish to make any more copies.

Caution: The unlocked floppy disk that you insert or 
destination volume that you select will be totally overwritten 
with the contents of the image file.  For an additional layer of 
protection, enable the option to confirm overwriting the 
destination disk in Preferences.

Convert Image - To convert any readable disk image file format to the image file 
format chosen in Preferences, do the following:

1. Choose the Convert Image command from the Image menu.
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2. Select the image file or folder containing image files to convert using the 
Open dialog.

Verify Image - To verify image files and display their 32-bit checksums, do the 
following:

1. Choose the Verify Image command from the Image menu.

2. Select the image file or folder containing image files to verify using the 
Open dialog.

3. The log appears, displaying the 32-bit checksums and other file 
information.

Note: If the original image file format contained archived 
checksums and these don't match the calculated values, an 
alert will be displayed and the values will be shown in the 
ShrinkWrap Log.

Verify Disk - To verify a volume or mounted image:

1. Choose the Verify Disk command from the Image menu.

2. Select the disk to verify using the Open dialog.

3. The log appears, displaying the 32-bit checksum and other volume 
information.
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The iSupport Menu

The iSupport menu provides directed contact, via your web browser, to the appropriate 
pages on Aladdin's website for each of the seven choices pictured above.

Scripting Support

ShrinkWrap supports a custom AppleEvent suite which gives you the ability to control and 
automate almost all of the functions within the application.  The most common usage of 
these advanced capabilities is through OSA compliant scripting systems such as 
AppleScript or UserLand Frontier.  In order to facilitate your use of ShrinkWrap with 
scripting systems, ShrinkWrap includes an 'aete' resource which details the full 
complement of AppleEvents and AE objects supported.  To examine the 'aete' resource, 
open Apple's Script Editor, choose Open Dictionary from the File menu and then select the 
ShrinkWrap application.  Sample scripts are included in the AppleScript™ Examples 
folder. 

Important Tips

Do you have enough available RAM?
The ShrinkWrap driver has two modes, RAM-based and file-based.  When you 
select the option to “Keep mounted images in RAM” and there is enough free 
memory available, the driver mounts an image file by creating a RAM disk 
the size of the disk image file, copying the contents of the image file to RAM, 
and then mounting the disk image directly from RAM.  Consequently, to 
mount an image file in the RAM-based mode, you must always have enough 
free RAM to load the disk image file completely into memory.  (Sorry!  Virtual 
memory doesn't count.)

Note: The system heap will expand when memory blocks are 
allocated to the ShrinkWrap driver to mount disk images in 
RAM.  When you unmount disk images, the corresponding 
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memory is freed.  However, the system will not compact and 
resize the system heap until the free memory is required by 
another application.  So don't be surprised if your system 
heap doesn't immediately shrink back to its original size.

Do you have enough free space on your startup disk?
When the “Keep mounted images in RAM” option is disabled, the driver 
mounts the disk image by mapping their blocks directly from the hard disk or 
network share.  Unfortunately, compressed DiskCopy 5.0d1 image files can’t 
be mounted this way. They require ShrinkWrap to convert them to a 
temporary scratch file which is stored within the invisible Temporary Items 
folder on your startup disk and then directly mounted with read-only access.  
Consequently, to mount this image file format in the file-based mode, you 
must have as much free hard drive space as disk capacity you wish to mount.

Note: If you should experience a crash when an image file is 
mounted, any scratch files used for temporary storage of the 
mounted image will be automatically recovered by the system 
to the “Rescued items” folder in your Trash.  If an image file 
was mounted unlocked, it may contain checksums that were 
never updated to reflect changes you made before the crash.  
To fix this, disable the “Verify mounted image checksums” 
option, mount the suspect image file, then drag the mounted 
volume onto ShrinkWrap.  A new image file will be created 
from the mounted volume that has valid checksums.

What is the difference between a compressed image and stuffing an image?
A compressed image file will result in a smaller file but one that cannot be 
changed or mounted as a writeable  volume. It will be like a CD and can be 
used to store information that is not likely to change or need to be updated in 
a smaller space than the original files used.

An image file that is Stuffed after it is created must be expanded each time it 
is used and then recompressed (if you wish) when you are done working with 
it, but it can be mounted as a writeable volume and changed when desired. 
This requires more steps to mount the volume and requires one pay attention 
to which version of the image file is being used, kept, trashed, etc.
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ShrinkWrap Disk Image Files vs. DiskCopy

The ShrinkWrap 3.5 image file format is identical to the DiskCopy 6.2 New Disk Image 
Format (NDIF) except in the following ways:

• ShrinkWrap image files are saved with ShrinkWrap's creator code.

• ShrinkWrap image files support StuffIt 40-bit encryption.

• ShrinkWrap image files support StuffIt compression, which on average saves over 
30% more space and compresses in less than half the time.

If you would like to batch convert a folder of disk image files to ShrinkWrap 3.5 disk 
images, do the following:

1. Drag the folder containing the disk images onto ShrinkWrap while holding down the 
Shift, Control & Option keys.

2. Select “Same as original” as the destination option.

3. Disable option to “Automatically compress image files” (since compression is 
integrated into NDIF image files).

4. Enable option to “Delete image files after conversion” (if you want the old image files 
removed).

5. Select “ShrinkWrap 3.5” in the File Format pop-up.

6. Select “StuffIt” in the Compression pop-up (or “DiskCopy” to create image files that 
DiskCopy 6.1 can open).

7. Select “None” in the Encryption pop-up.

8. Hit OK.

ShrinkWrap will then recursively navigate all the folders contained within the folder you 
selected, identify valid image files, and convert them to the new format.  

Note: A sample AppleScript applet called Make StuffIt 
Compressed has been provided in the AppleScript™ 
Examples folder to automate this conversion process.
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ShrinkWrap Self-Mounting Image Files

Self-mounting image files are essential for distributing disk images to people who don’t 
necessarily already have a copy of ShrinkWrap or DiskCopy.  They’re mounted by simply 
double-clicking on their icon, not unlike how you’d double-click a folder to access its 
contents.  The basic overhead for making a disk image file self-mounting is <35K.  
Choosing compression and/or encryption can add an additional 2-25K, since the 
components for these features must also be included.  Unlike mounting image files with 
the ShrinkWrap application, an uncompressed self-mounting image will always mount as 
unlocked when double-clicked.  Modifier keys and ShrinkWrap application preferences 
have no effect.

Component Manager
Just like QuickTime, ShrinkWrap uses Component Manager 3.0 to implement PowerPC 
and 68K compression and encryption methods in the ShrinkWrap application, driver, and 
self-mounting image files.  If you have a system older than System 7.1 and don’t have 
QuickTime 1.6 or later installed, the Component Manager will not be available and you 
won’t be able to process compressed or encrypted image files.
DiskCopy 6.3.x:

The latest versions of DiskCopy fully support ShrinkWrap 3.5 image files and DiskCopy 
6.3 image files created with ShrinkWrap 3.5, provided that you don’t choose StuffIt 
compression or any encryption.  ShrinkWrap Self-Mounting image files can be read and 
mounted by DiskCopy under the same conditions, but compressed image files may 
unexpectedly show up as unlocked volumes when mounted.  Since any changes you make 
will not actually be saved, we recommend you avoid processing ShrinkWrap Self-Mounting 
image files with DiskCopy.
RAM Doubler:

Connectix RAM Doubler and ShrinkWrap will work fine together provided that there is 
enough real memory for the images to be mounted in RAM.  When real memory gets 
sparse, most of the smart tricks used by RAM Doubler to increase memory won't work (re-
allocating memory, compressing memory blocks, etc.) because there simply isn't any free 
memory to play with.  RAM Doubler then falls back on standard virtual memory and the 
system will slow to a crawl.
Hard Disk Toolkit:

If you format removable media with FWB’s HDT driver and enable the “Physical eject on 
unmount” option, the drive will unexpectedly eject the media when ShrinkWrap unmounts 
the volume in preparation to write an image back to disk.  You should disable this option 
by launching Hard Disk Toolkit, double-clicking the ejectable drive, selecting the active 
SCSI driver, hitting the Configure Driver button, and then disabling the check box for this 
option.
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Anti-Viral Utilities:

Some anti-viral utilities may consider ShrinkWrap's activities to be “suspicious” in nature 
and will stop processing to warn you of some events.  If this happens to you, Aladdin 
recommends switching to a less invasive anti-viral utility or setting your anti-virus 
preferences appropriately.
Background Compression Utilities:

ShrinkWrap usually can't mount image files that have been compressed with background 
compression utilities such as StuffIt SpaceSaver, AutoDoubler or More Disk Space unless 
they are mounted in RAM.
Hardware Accelerators:

ShrinkWrap will not run with some types of processor accelerators since certain required 
floppy driver support is not provided.  To use ShrinkWrap, first restart with the accelerator 
disabled.
MFS Disks:

ShrinkWrap is unable to create image files of Mac 400K disks due to restrictions on MFS 
disks introduced with System 7.  All other features, however, are fully supported with 
disks of this type.
Old Macs:

Some older Macs (Mac 128K, 512K, 512KE & Plus) will be unable to create, verify or copy 
disk images with ShrinkWrap since their floppy disk drivers do not support the necessary 
control calls.  However, disk image files can still be mounted, converted and verified on 
these machines under certain circumstances (non-HFS+, not compressed, etc). Aladdin 
does not support or recommend the use of ShrinkWrap on these machines, but does 
acknowledge that some users have reported limited usability.
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