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If you're new to Web page design, this chapter will give you a brief overview of what you need to know to get 
started.

How the Web works

In the most basic sense, the World Wide Web is a very large collection of pages stored on computers, or Web 
servers, around the world. Hypertext links make it possible for readers to move freely among these pages in 
any order they choose. It's this ability to link one Web page to other related pages that gives the Web its web-
like quality.

Here are some definitions of the basic parts that make up the World Wide Web:

Web pages are the individual files that make up a Web site.
A home page is the starting page for a Web site. It often has some sort of table of contents that allows 
readers to link to other parts of the Web site.
Web sites are collections of Web pages that contain related information. The pages within a site are 
linked together so that readers can move easily among them.
Web servers are computers that store Web pages and respond to requests from different browsers.
Web browsers are programs that allow readers to view Web pages.
Common Gateway Interface (CGI) scripts are programs that run on a Web server to process forms and 
otherwise extend the capabilities of the server.

Using HTML

Web pages are written in Hypertext Markup Language, or HTML. HTML allows you to add tags to your 
Web page to indicate special characteristics. Some tags affect the look of a Web page, others affect how it 
functions. HTML includes tags for:

links to other Web pages or to a specific element within a page
structural elements such as tables or lists
graphical elements such as images

Claris Home Page makes it possible for you to add structural, graphical, and formatting tags to a Web page 
quickly and easily, without a prior understanding of HTML. When you add an element or change its attributes, 
Claris Home Page inserts the appropriate tags for you. If you are an experienced HTML user, you can also 
add tags directly to the HTML code.

Using browsers to read Web pages

Every Web page has a unique address. This address is called a Uniform Resource Locator, or URL. When a 
reader types your page's URL or clicks on a link, a browser locates the page, interprets the HTML tags, and 
displays the contents of that page.



There is a variety of browser programs to view Web pages on different platforms, including Mac OS, 
Windows, and UNIX. Some browsers may interpret an HTML tag one way, while others interpret it differently, 
and some may ignore it completely. For example, some browsers don't support tables or frames, and a few 
browsers don't support images. As you're designing your Web page, it's important to keep this in mind, and 
become familiar with the capabilities of the browsers your readers are most likely to use.

Designing the structure of your Web site

Before you begin to create your Web site in Claris Home Page, spend some time planning what the purpose of 
the site will be, what content it will contain, and how to structure it. Planning before you begin helps you 
create a Web site that has a unified look and a well-designed structure.

Using a flowchart

A simple flowchart is a useful way of diagramming how your pages will link to each other. Using a flowchart 
lets you resolve any design issues before you create your actual pages in Claris Home Page. For example, it 
can potentially save you time to diagram your links on paper before creating them, so if you decide to change 
the overall structure of the site, you won't need to recreate all of the links.

When you're creating your flowchart, make sure your pages are linked in a way that makes it easy for your 
readers to navigate through the site. Many readers will arrive at your home page: make sure that your readers 
can get a general idea of what's on your site there and can easily access the different pages. You can do this by
creating a table of contents or navigation buttons.

However, keep in mind that not all of your readers arrive at your home page first. Some readers may start at 
another page within your site. For example, readers using a search engine such as Yahoo or Alta Vista may be 
searching for a keyword that appears somewhere within your site, but not on the home page. For this reason, 
it's a good idea to make it easy to return to your home page from other pages in your site, by including a link 
to the home page.

Organizing your files

When you set up all your Web pages and image files in one location on your computer, you can ensure that 
they're all working together properly and that the process of uploading the Web site to the server goes more 
quickly and easily.

Here are some general guidelines:

Place all of your Web pages for a site in one folder.

This allows you to make relative links between files in the site. For information on relative paths, see
 next.Using relative or absolute paths

Create an images folder within the site folder to store all the GIF and JPEG images.

This helps ensure that all images associated with your Web pages display correctly. For more 
information, see .Managing your image files

Use relative paths to define the location of your Web pages in the site folder.

Using relative or absolute paths

When you create a link or insert an image in your Web page, Claris Home Page stores the path to the file you 
are linking to. Claris Home Page uses relative paths by default, but you can change the default setting to use 



absolute paths if you want. A is a location defined in relation to the page from which the link
originates. It also defines the relationship between a page and any images appearing on that page. An

 always defines the location relative to the root level of your computer- the pathname does not change 
when a file is moved.

relative path
absolute 

path

For example, let's say your Web page files that compose your Web site are in a folder called Pages. When you 
create links between these files, the relative path is simply the filename. The absolute path would be

 (for Macintosh) or  (for Windows).Macintosh HD\Pages\filename.html c:\Pages\filename.htm

In most cases, you will want to use relative paths. By using relative paths you can easily move your files to a 
different machine without having to re-specify all of your links for the new location.

For more information, see  and
.

Previewing your web page in a browser Specifying where converted image files 
are stored

Web page design considerations

Your Web page's appearance in Claris Home Page is based on the default preferences settings in Netscape 
Navigator 2.0. As mentioned earlier, your Web page will display differently depending on the browser a reader 
uses to view it. In addition, you need to be aware of other factors that will affect the appearance and 
performance of your Web pages.

Readers view your Web page on many kinds of monitors. A page designed to take full advantage of a 20-inch 
screen may not display as effectively on a laptop computer screen. If you anticipate that your readers will be 
using widely divergent sizes of computer screens, it's a good idea to test how your page will appear on these
different screens.

Large image files can slow the download time of your Web pages to your readers' computers, especially when 
they're using a modem. Most readers are connected to the Internet via a modem. Some may have very fast 
lines, others will use 28800 bps, 14400 bps, or 9600 bps modems. While you are developing your Web pages, 
you can check the download time of your images at different connection speeds using the Document Statistics 
window. For more information, see .Using the Document Statistics window
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This chapter provides the basic information you need to use Claris Home Page, including:

starting Claris Home Page
working in a document
viewing your work
creating a title for your Web page
saving your Web page
setting the color and background of your Web page

Starting Claris Home Page

To start Claris Home Page, double-click the Claris Home Page folder on your system to display its contents, 
and double-click the Claris Home Page 1.0 application icon. You can also double-click a file that was created 
in Claris Home Page to open the application.

When you open Claris Home Page, a new untitled Web page appears on the screen.

If you don't want Claris Home Page to create a new document each time you start it, you can set the general 
preferences to do nothing or to display an Open dialog box at startup. Choose Preferences from the Edit menu, 
and choose Display Open Dialog Box or Do Nothing from the At Startup pop-up menu in the General 
preferences area.

Working in a Claris Home Page document

You can use Claris Home Page documents to create Web pages. Working in Edit Page mode is similar to 
working in other word processing documents. For example, you can type text, insert images, or copy and paste 
elements in much the same way. However, because of HTML limitations you can't set specific fonts, character 
styles, or tabs. Claris Home Page provides object and link editors that let you apply HTML attributes to your 
Web page elements.



Opening HTML files

You can open and edit any HTML file in Claris Home Page.

To open an HTML file:

Choose Open from the File menu.1. 
 Select the file you want to open.2.
 Click Open.3.

Using Edit Page mode

By default, when you first open a file or create a new document, Claris Home Page displays the document in 
Edit Page mode.

Edit Page mode displays the contents of your Web page in a format that allows you to perform all of the 
editing tasks involved in creating your Web page, such as typing and formatting text, inserting images, creating 
links, and so forth.

If you want to change the mode that Claris Home Page opens documents in, choose Preferences from the Edit 
menu, choose General from the pop-up menu or click the General tab, and then choose Preview Page or Edit 
HTML Source from the Open Documents in pop-up menu. For more information, see 

 and .
Using Preview Page

mode Using Edit HTML Source mode

To switch to Edit Page mode, choose Edit Page from the Window menu or click the Edit Page button .

Cutting, copying, and pasting

In Claris Home Page, you can cut, copy, and paste text, tables, links, images, and other elements within your 
Web page, between other Web pages, or between Claris Home Page documents and other applications.

To cut or copy and paste an element:

 Select the element.1.
 Choose Cut or Copy from the Edit menu.2.

Claris Home Page places a copy of the selected element on the Clipboard.

If you choose Cut, the element is removed from its original location, and placed on the Clipboard. If you 
choose Copy, the element stays where it is and a copy is placed on the Clipboard.

Select the spot in the document or in another document where you want the element to go.3. 
 Choose Paste from the Edit menu.4.

You can also drag elements to cut, copy, and paste them. If you drag an element within the same 
document, it is cut and pasted. If you drag an element from one Claris Home Page document to another,
it is copied and pasted.

Changing your mind

If you want to delete something in your document, select it and press the Delete or Backspace key.

If you want to cancel the last action you performed, select Undo from the Edit menu.



Using the toolbars

Claris Home Page includes four toolbars you can use to perform tasks quicker than selecting the 
corresponding option from a menu. They are the basic toolbar, style toolbar, tool palette, and the Image Map 
Editor toolbar.

The basic toolbar provides access to many of the commonly used features in Claris Home Page. Place the 
pointer over a button to see its name appear at the right of the toolbar. Click a button to activate your choice, or 
drag the Anchor, Horizontal Rule, or Table button onto your page to insert those elements.

The style toolbar has buttons you can use to format text.

To show or hide the basic toolbar or the style toolbar, choose Preferences from the Edit menu, choose General 
from the pop-up menu or click the General tab, and select or deselect the appropriate checkbox.

 You can set the Show Toolbar preferences to display the toolbar in the Claris Home Page 
application window or in the document windows.
Windows:

Claris Home Page also has a floating tool palette you can use to insert elements into your documents. To 
display the tool palette, choose Show Tool Palette from the Window menu. To hide the tool palette, choose 
Hide Tool Palette from the Window menu.

To use the tool palette, click one of the icons and drag it onto your Web page to add the corresponding 
element (with the exception of the Insert Image icon-click this icon to display the Open dialog box). You can 
move the tool palette anywhere on your screen by dragging its title bar. Click the close box of the tool palette 
or choose Hide Tool Palette from the Window menu to close the tool palette.

The Image Map Editor toolbar provides buttons for you to add special features to an image. To use the Image 
Map Editor toolbar, double-click the image to open the Image Object Editor, and click the Image Map button 
to open the Image Map Editor.

Using object and link editors

When you add some elements to your Web page, such as a table, a link, or an image, you use an editor to 
specify and edit its characteristics.

To open the Link Editor and edit a particular link, select the link in Edit Page mode and choose Show Link 
Editor from the Window menu. For more information about links, see .Links

You can use several methods to open the Object Editor for an element. You can double-click the element, 



select the element and choose Show Object Editor from the Window menu, or select the element and click the 
Object Editor button in the basic toolbar.

Most of the editors are displayed in expandable windows. Click the triangle at the bottom of the editor 
window to display the rest of the window.

Resizing elements

In Claris Home Page, you can resize many of the elements, such as tables, images, and form elements, using 
the mouse.

To resize an element:

 Select the element.1.

The element is highlighted with a border that includes one or more handles.

Drag the bottom handle to change the height of the element, drag the right-side handle to change the 
width of the element, and drag the lower-right corner handle to change the height and width of the 
element at the same time.

2. 

Aligning elements

You can change the horizontal alignment of text, images, and other elements in relation to the Web page. 
Choose Alignment from the Format menu or click the Indent or Outdent button on the style toolbar.

Viewing your work

Claris Home Page provides you with several ways of checking your Web page after you've worked on it in 
Edit Page mode, including: Preview Page mode, previewing in a browser, using the Document Statistics 
window, and Edit HTML Source mode.

Using Preview Page mode

When you switch to Preview Page mode, Claris Home Page displays your Web page the way it might appear 
in a browser. (Keep in mind, however, that the appearance of your Web page may vary when displayed in 
different kinds of browsers.)



In Preview Page mode, you can test interactive elements of your Web page, such as links and certain form 
capabilities, and you can see how elements such as numbered lists will look in a browser.

 In Preview Page mode, all of the editing capabilities and some menu options are disabled.Note

To switch to Preview Page mode, click the Preview Page button on the basic toolbar or choose Preview 
Page from the Window menu.

Previewing your web page in a browser

From Claris Home Page, you can preview your Web page in an actual browser, such as Netscape Navigator, 
at any time. Note that to test links among pages, you need to save all your pages before previewing them in a 
browser.

To view your Web page in a browser, click the Preview in Browser button on the basic toolbar or choose 
Preview in Browser from the File menu.

Claris Home Page opens your Web page in Netscape Navigator by default. If you don't have Netscape 
Navigator on your system or if you want to see how your Web page looks in a different browser, you need to 
change the default browser. See  next.Changing the default browser

In Windows, if you are using Netscape Navigator, Claris Home Page opens a new copy of 
Navigator each time you choose Preview in Browser from the File menu. To avoid opening multiple copies, 
quit Navigator each time you are finished viewing a Web page.

Important

Changing the default browser

You can change the browser Claris Home Page uses to display your Web pages.

 Choose Preferences from the Edit menu.1.
Choose Browser Preview from the pop-up menu or click the Browser Preview tab.2. 

 Click Set.3.

An Open dialog box appears.

Select the browser filename and click Open.4. 
 Click OK to close the Preferences dialog box.5.

Using the Document Statistics window

The Document Statistics window provides estimates of how long it will take your readers to download your 
Web page (or sections of your page) to their browser. You can check the estimated download time for a page 
you're building any time you are working with your page in Edit Page mode.

 The Document Statistics window displays estimates of download time under ideal conditions. Network 
congestion, server loading, or other adverse conditions can increase the download time of your Web pages
significantly.

Note

To use the Document Statistics window:

 If you want to see statistics for a certain section of your Web page, select that section.1.
 Choose Document Statistics from the Edit menu to open the window.2.



 Read the appropriate field for the whole document or the section you've selected.3.

Field Name Definition 

Character Count Number of characters in your Web page or selection 

Word Count Number of words in your Web page or selection 

Total Image Size Number of bytes for all images in your Web page or of all images in the section you 
selected

Minimum Download Time at 
14,400 

Estimate of how long it will take a reader to download your Web page or the section you
selected using a 14400 bps modem 

Minimum Download time at 
28,800 

Estimate of how long it will take a reader to download your Web page or the section you
selected using a 28800 bps modem 

Using Edit HTML Source mode

When you switch to Edit HTML Source mode, Claris Home Page displays the exact HTML code of your 
Web page. You can edit, delete, add, or customize HTML code while in this mode. Claris Home Page saves 
and incorporates the changes you make.

 Be careful when editing your Web page in Edit HTML Source mode. Unless you are familiar with 
HTML code and its syntax, you can destroy your work. As a precaution, make a copy of your Web page 
before you change it in Edit HTML Source mode.

Important

In Edit HTML Source mode, you can use all of the usual text editing operations such as typing, undoing, 
cutting, copying, pasting, dragging, and finding and replacing text. Other options, such as those found in the 
Insert, Format, and Style menus, are not available when editing the HTML source code.

 The Link Editor and Object Editors include an Extra HTML field. You can use this field to add any of 
the HTML tags that are not supported by Claris Home Page.
Note

To switch to Edit HTML Source mode, click the Edit HTML Source button on the basic toolbar or choose 
Edit HTML Source from the Window menu.

You can change the display font of the code in Edit HTML Source mode. Choose Preferences from the Edit 
menu, choose HTML Editing from the pop-up menu or click the HTML Editing tab, and then choose a font or 
size that you want to see.



Setting extra HTML preferences

You can use several Claris Home Page options to change the HTML code of your Web page.

To make changes to the code that specifies HTML output, choose Preferences from the Edit menu, choose 
HTML Output from the pop-up menu or click the HTML Output tab, and then change the appropriate option.

Choose this 
HTML 

Output option 
To do this 

Header 
Comment 

To add information about your Web page to the beginning of the HTML file. (These comments are only visible 
when viewing the HTML source code.) Choose None if you don't want any information added. Choose 
Identify as Home Page file if you want a comment added identifying your Web page as a Claris Home Page file. 
Choose Identify and time-stamp if you want a comment added identifying your Web page as a Claris Home 
Page file and a time- stamp identifying the last time the file was saved. 

Line Break 
Format 

To specify the line break format your file will follow. Use this option only if you want to edit the HTML code of 
your Web page in a text editor since Claris Home Page can handle all line break conventions. Choose
Macintosh (CR), Windows (CRLF), or Unix (LF) to specify the kind of line breaks you want to use. 

Paragraph 
Alignment 
Uses 

To specify how centered text is coded. Choose <CENTER> tag to have Claris Home Page use the <CENTER> 
tag. Choose ALIGN parameter to have Claris Home Page use the ALIGN=CENTER parameter within other tags
(such as <P>). 

Generate </P> 
tags 

To add a closing </P> tag to every opening <P> tag in your file. This should normally be enabled, but it may 
cause problems with some browsers.

Use Absolute 
Pathnames 

To use absolute or relative pathnames when you create links to local files. When the option is deselected, Claris 
Home Page uses relative pathnames. For more information about relative and absolute pathnames, see Using
relative or absolute paths. 

Generate X-
SAS tags 

Claris Home Page uses several custom tags (beginning with "X_SAS") to save information such as where the 
Claris Home Page application window appears on the screen and what size the window is. Enable this option to
add these additional tags to the HTML file. 

To add extra code or tag parameters for prefix comments, HTML, HEAD and BODY tags, choose Document 
Options from the Edit menu, choose HTML Extras from the pop-up menu or click the HTML Extras tab, and 
then change the appropriate option:

Choose this option To add 

Prefix Comments Commented text to the beginning of your HTML file, such as the name of the author, messages, and so 
on.

<HTML> Tag 
Parameters Parameters to the <HTML> tag. 

<HEAD> Tag 
Parameters Parameters to the <HEAD> tag. 

Text in Head Section Text that will appear in the HEAD section of the file. This option allows you to add tags other than <
TITLE>. 

<Body> Tag Parameters Parameters to the <BODY> tag. 

Creating a title for your Web page

Claris Home Page prompts you to give your Web page a title the first time you save the document. The title 
you create for your Web page appears at the top of most browsers' windows.

The words that appear in a Web page's title are also used in searches by many Internet search engines. If it is 
important that readers are able to find your Web page via keyword searches, make sure that the title includes 
words your readers are most likely to use when doing a keyword search.

To give your Web page a title or edit the current title:

 Choose Document Options from the Edit menu.1.
Choose General from the pop-up menu or click the General tab.2. 

 Enter the title in the Document Title text box.3.
 Click OK.4.



Saving your Web page

As in any application, it is important to save your files frequently to avoid the possibility of losing data. In 
addition, within Claris Home Page certain functions will only work after you have saved your Web page. For 
example, if you have created links between your Web pages, you will need to save all of the pages that have 
links or are the target of links before you can test the links.

To save a Web page:

 Choose Save from the File menu.1.

If you haven't given your Web page a title yet, the Enter Title dialog box appears. Enter a title and click 
OK. (For more information, see .)Using Edit HTML Source mode

The Save dialog box appears.

Type the filename for your Web page followed by the extension  for a Windows file or for 
a Macintosh file in the Save File As text box.
2. .htm .html

In order for your files to be seen as Web pages in Claris Home Page and in Web browsers, they must 
have .htm or .html extensions.

 Click Save (Macintosh) or OK (Windows).3.

You can specify the default filename extension for new Web pages you create. (You should set the extension to
 or .) Choose Preferences from the Edit menu, choose General from the pop-up menu or click the 

General tab, and type the extension in the Default HTML File Suffix text box.
.htm .html

You can also have Claris Home Page save your documents automatically. Choose Preferences from the Edit 
menu, and choose General from the pop-up menu or click the General tab. Specify how often (in minutes) you 
want Claris Home Page to save your files by selecting the Auto-save document every "#" minutes checkbox 
and typing a number in the text box.

Claris Home Page saves changes to your files as often as you specify and prompts you for titles and filenames 
for your Web pages if you haven't created them yet.

Printing your Web page

You can use Claris Home Page to print the Web pages you create. You can print a page while in Edit Page 
mode, Preview Page mode, or Edit HTML Source mode and Claris Home Page will print your page as it
appears in that particular mode.

To print your Web page:

Choose Print from the File menu.1. 

Your system's standard Print dialog box appears.

 Click Print (Macintosh) or OK (Windows).2.

Claris Home Page prints the entire contents of your Web page file.

Setting the color and background of your Web page

You can change the color or use an image as a tiled pattern for the background of your Web page. When you 
use an image, it overwrites the color setting. To see how the image looks as the background pattern, preview 



your Web page in a browser.

To change the color of your Web page's background:

 Choose Document Options from the Edit menu.1.

The Document Options dialog box appears.

 Choose Colors and Background from the pop-up menu or click the Colors and Background tab.2.
 Click the Background color box.3.

The Color dialog box appears.

 Select the color you want to use as the new background for your Web page.4.
 Click OK to close the Color dialog box.5.
 Click OK to close the Document Options dialog box.6.

The background color of your Web page changes.

To use an image as a tiled background for your Web page:

 Choose Document Options from the Edit menu.1.
Choose Colors and Background from the pop-up menu or click the Colors and Background tab.2. 

 Click Set.3.

An Open dialog box appears.

 Select the image file you want to use.4.
 Click Open.5.

The path of the image file and a thumbnail representation of the image appear in the Document Options 
dialog box.

 Click OK to close the Document Options dialog box.6.

To remove an image from the background of your Web page, choose Document Options from the Edit menu, 
choose Colors and Background from the pop-up menu or click the Colors and Background tab, and then click 
None.

 To reset all of the color settings of your Web page to their default values, choose Document Options from 
the Edit menu, choose Colors and Background from the pop-up menu or click the Colors and Background 
tab, and then click Use Defaults. Note that this will also remove a background image from your Web page and 
reset the color of all links. (For more information on setting the color of links, see .)

Tip

Changing the color of links



Text
Opening a text file
Typing text
Finding and replacing text
Applying styles to text

Using paragraph styles
Using character styles
Removing character styles
Adding special characters

Creating a list
Entering and formatting list items
Inserting a list entry
Creating a nested list
Reordering items in a list
Changing the number style in a numbered list

Changing the color of text
Using horizontal rules to separate text

Claris Home Page lets you work with text in some of the ways that you would in a standard word processor. 
You can insert text, cut and paste from another page or another document, and find and replace text. You can 
use several levels of headings, apply styles, change the size of text, and change the color of text.

Be aware, though, that HTML imposes certain limitations on your text formatting. For example, HTML 
doesn't let you precisely control font style or size, change spacing between words or lines, add tabs, or change 
how words are hyphenated. Other limitations arise because readers use different types of browsers and 
different platforms. If a browser window is set to a different size, the layout you carefully arranged on your 
page may look considerably different. Although you can't predict exactly how text will appear to your readers, 
you can test the appearance of text on different browsers they are likely to be using.

Opening a text file

You can open text files in Claris Home Page that you created in other applications. Choose Open from the File 
menu. When you save the file in Claris Home Page, it is saved as an HTML document.

Typing text

You can add text to your Web page by typing it directly onto the page, by copying and pasting it from another 
Web page or application, or by dragging it from another page in your Web site. On the Macintosh, you can 
drag text from another application as well.

You can delete text by selecting it and pressing Delete, and undo your last action by choosing Undo from the 
Edit menu or pressing Command-Z (Macintosh) or Ctrl-Z (Windows). See  for 
more information about copying and deleting elements in a Web page.

Cutting, copying, and pasting

As you type, the lines of text in a paragraph run continuously and wrap evenly regardless of the size of the 
window. The text you type also wraps evenly in the reader's browser window no matter what size it is.

Press Return (Macintosh) or Enter (Windows) to end a paragraph of text and insert a hard break. Claris Home 
Page adds an extra line after each paragraph.

If you want to make a paragraph break without adding the extra line, choose Line Break from the Insert menu.

You can also press Option-Return to insert a line break.Macintosh: 



You can also press Ctrl-Enter to insert a line break.Windows: 

 You can choose to have Claris Home Page show line break symbols or hide them in Edit Page mode. To 
show line break symbols, choose Show Line Breaks from the Edit menu. To hide line break symbols, choose 
Hide Line Breaks from the Edit menu.

Note

 You can use a transparent image to control line spacing by inserting it between lines or paragraphs and 
adjusting its size in the Image Object Editor. For more information, see .
Tip

Adding transparency to an image

Finding and replacing text

You can find and replace strings of text, including text characters, words, phrases, and keyboard symbols, such 
as the ampersand (&).

To find and replace text:

Choose Find/Change from the Edit menu.1. 

The Find & Replace dialog box appears.

Type the text you want to find in the Find text box.2. 
 If you want to replace the found text, type the replacement text in the Replace With text box or if you 

want to delete the found text, leave this box blank.
3.

 Choose the options you want to use.4.

Choose this 
option To do this 

Partial Word Find any instance of the word you are searching for, even if it is in another word (for example, to find 
the word "walk" in "walking"). This is the default setting. 

Entire Word Only find the text if it appears by itself without any other characters. 

Case Sensitive Only find exact matches of the text, including case. For example, "Apple" would find "Apple" but not 
"apple." Leave unchecked to ignore case. 

Search 
Backwards Search backward from the insertion point instead of forward. 

Wrap Around Search through the page again. 

Click the appropriate button to perform the search.5. 



Choose this button To do this 

Find Find the text you typed in the Find field. 

Replace After a successful find, replace the found text. 

Replace All Replace all instances of the found text with the text in the Replace With field. 

Replace and Find After a successful find, replace the found text and search for the text again. 

 Click Done.6.
 If you want to perform another find, choose Find Next from the Edit menu.7.

Applying styles to text

Use Claris Home Page to apply standard HTML formatting styles to paragraphs and to individual characters 
or words easily. In Edit Page mode, choose a style and Claris Home Page adds the appropriate HTML tags to 
the text or paragraph for you.

Using paragraph styles

You can use paragraph styles to add different level headings, lists, quotes, and bylines to your Web pages.

When you apply a paragraph style, the change affects all of the text within the paragraph. In most cases, if text 
within the paragraph already has a character style, it adopts the paragraph style in addition to the character 
style. For example, if you make the first word in a paragraph italic and then make the paragraph into a heading, 
the paragraph becomes a heading with the first word set in italics.

To apply a paragraph style:

 Select the paragraph or group of paragraphs you want to format.1.
 Choose the style from the Format menu.2.

Choose one of these 
styles To do this 

Normal Remove heading or preformatted list styles. 

Headings 1-6 Format headings at six different levels, where Heading 1 is the highest level. 

Preformatted 

Format the text of the paragraph to display in the monospace font used by the user's 
browser. This causes all of the characters typed to have the same width so you can use 
multiple spaces to line up text exactly how you want it to look. If your readers' browsers 
support tables and you want to present text in multiple columns, you might want to use a 
table instead. For more information on tables, see Tables.

Bullet List, Numbered List, 
or Other (Term, Definition, 
Directory, and Menu list 
items)

Format paragraphs into items in a list. You can choose from several different types of lists
depending on the information you are presenting. For more information, see Creating a list. 

Number Style Label the list items using alphabetic or numeric characters. 

Address 
Format your byline or address so readers can find it easily. When bylines and the email 
address of a Web page's author are included in a Web page, they are usually placed at the 
bottom of the Web page, separate from other text. 

Alignment Align text to the left side, center, or right side of the Web page. 

Blockquote Format a paragraph as an extended quotation by indenting both the left and right sides of
the paragraph. 

Using character styles

Character styles include physical and logical character styles, color, size, and raw HTML.

Characters formatted with a  look the same no matter what browser you use as long as the physical style



browser you use supports that physical style. Characters formatted with  appear differently 
depending on how the browser you are using interprets that style. For example, in one browser text styled
"emphasis" may appear in italics while in another browser it might appear underlined.

logical styles

 It's usually a good idea to use logical styles throughout your Web pages when and where you can. This 
way, each browser can work within its own limitations to interpret the information you want differentiated in a
consistent way.

Note

Here is how Claris Home Page displays the logical styles it supports. Remember, they may look different in 
other browsers.

To apply a character style:

 Select the characters you want to format.1.
 Choose a style from the Style menu.2.

Type of 
style Choose one of these styles To do this 

Logical 
styles 

Strong Indicate the text is very important.

Emphasis Indicate the text is important. 

Citation Indicate that the text is from a book or other document. 

Inserted Indicate that the text has been inserted into the document. 

Deleted Indicate that the text had been deleted from the document. 

Sample Indicate that the text is a sequence of literal characters. 

Keyboard Indicate that the text is keyboard input.

Variable Indicate that the text is a variable.

Code Indicate that the text is code. 

Physical 
styles 

Bold Make text bold.

Italic Make text italic.

Underline Make text underline.

Strikethrough Make text strikethrough.

Superscript Make text superscript.

Subscript Make text subscript.

Teletype Make text teletype.

Size 1 to 7 (3 is the default) Make the text larger by choosing a larger number or smaller by 
choosing a smaller number. 

Color Red, Blue, Green, Yellow, Black, 
Default, Other 

Make the text a different color. For more information, see Changing 
the color of text. 

Removing character styles

To remove a physical or logical style from text, select the text and choose Plain from the Style menu. To 
remove all character styles from text, select the text and choose Reset from the Style menu.

Adding special characters

If you want to add special characters (such as the copyright symbol) to your Web page, your keyboard may 
not be encoded to let you type the character. In addition, even if your keyboard is encoded to let you type the 
character, depending on your system the character may not display correctly when your readers view your 
Web page. You can use the Raw HTML character style in Claris Home Page to make sure that such special 
characters display correctly on your Web page.



HTML recognizes the International Standards Organization (ISO) Latin-1 character set. Each character in the 
ISO Latin-1 character set is assigned a numeric entity. If you want to use an ISO Latin-1 character in your text, 
you can enter the numeric entity for that character as raw HTML in Claris Home Page and the actual character 
is displayed when you preview your Web page in a browser or after you close and reopen your Web page.

For a complete list of all the characters in ISO Latin-1 and their numeric entity names, see 
.

ISO Latin-1 
character set

To enter a special character:

Type , the number for your special character, and a semicolon ( ).1. &# ;

When you add  before the number, the number is recognized as a numeric entity for a special 
character.

&#

Select the  the number you typed, and the semicolon, and choose Raw HTML from the Style 
menu.
2. &#,

The characters you typed appear in red. The special character appears when you view your page in a 
browser, and it also appears in Claris Home Page the next time you open the file.

 If you are inputting many special characters within a paragraph of text, such as accented characters, you 
can input all the text in the paragraph as Raw HTML for convenience.
Tip

Creating a list

There are several ways you can format text to help you organize information on your Web page. Using lists is 
one popular method. You can create five kinds of lists using Claris Home Page: bulleted, numbered, glossary 
(term and definition), menu, and directory lists.

The first step in creating a list on your Web page is deciding which kind of list to use.



Use this kind 
of list For this type of information 

Bulleted list Items that don't necessarily follow a sequence (also known as an unordered list). In this kind of list, a bullet 
precedes each item. 

Numbered list 

Items that need to be listed in a sequence (also known as an ordered list). In this kind of list, a number or letter 
precedes each item, which you can specify.

Edit Page Mode

Preview Page Mode

Glossary list Terms that might be unfamiliar to the user. Glossary lists consist of terms that are followed by their definitions. 

Menu list 
A list of short items (less than a sentence long) that don't necessarily follow a sequence. Menu list items are not 
preceded by special characters, numbers, or letters.
Important Menu lists are being phased out of HTML so their use in Web pages is discouraged. 

Directory list 

A list of short items (less than 20 characters long) that don't necessarily follow a sequence. Directory lists are 
similar to menu lists, except that some browsers display directory lists in two or more columns rather than one 
column. 
Important Directory lists are being phased out of HTML so their use in Web pages is discouraged. 

 When you create a numbered list in Edit Page mode, you see a number symbol (#) or an X in front of 
each entry. The actual numbers or letters only appear when you view your page in Preview Page mode or in a 
browser.

Note

Entering and formatting list items

You use one method to create bulleted, numbered, menu, and directory lists and a different method to create 
glossary lists. For a glossary list, you enter and format separate list items for the term and the definition.

To create a bulleted, numbered, menu, or directory list:

 In Edit Page mode, type the list items, starting each item on a new line.1.
 Select the list.2.
 From the Format menu, choose Bullet List, Numbered List, or Other (and choose Menu or Directory 

from the submenu).
3.

You can view the results in Preview Page mode or in a browser.

To create a glossary list:

 Type the first term in the glossary list.1.
Select the term.2. 
Choose Other from the Format menu and then choose Term.3. 

 Press Return (Macintosh) or Enter (Windows) and type the term's definition.4.

The term's definition is automatically formatted as a definition paragraph.

 Press Command-Return (Macintosh) or F8 (Windows) and type the next term.5.
 Repeat steps 4 and 5 for each glossary term and definition you want to create.6.

Inserting a list entry

You can add items to an existing list without having to reapply the list's style.



 Click at the end of the line that is above where you want to enter the new item.1.
Choose List Entry from the Insert menu.2. 

You can also press Command-Return to insert a list item.Macintosh: 

 You can also press F8 to insert a list item.Windows:

Creating a nested list

A nested list is a list within another list.

 Type the list and the subcategory list. Start each item on a new line.1.
 Select all of the text.2.
 Choose the list style you want to apply to the text from the Format menu.3.

 Select the text you want to nest.4.
 Choose Nest List from the Format menu or click the Indent button .5.

You can apply a different list style to the nested list.

To remove the nested list style, choose Un-Nest from the Format menu or click the Outdent button .

Reordering items in a list

You can drag list items to a new position in the list.

To select a single list item that you want to reposition, you need to select the entire item (including the 
paragraph return at the end of the line).

Triple-click the item you want to move.1. 

If you want to move more than one item at a time, hold down the Shift key and select the items.

 Drag the selected item or items into the left margin of the new location.2.

 If you change the order of numbered list items, they're renumbered automatically.Note

Changing the number style in a numbered list

There are five number styles you can use for a numbered list.



To change the number style:

 Select the numbered list.1.
 Choose Number Style from the Format menu and select a number or alphabetic style.2.

In Edit Page mode, you see number symbols (#) or X's in the list. You can view your page in Preview 
Page mode or in a browser to see the actual numbers or letters.

Changing the color of text

You can change the color of all of the text on your Web page or you can change the color of selected text. 
Colors assigned to selected pieces of text are character styles and therefore override the colors you assign as 
the default color for text on your Web page.

To change the default color for all the text on a Web page:

 Choose Document Options from the Edit menu.1.

The Options dialog box appears.

 Choose Colors and Background from the pop-up menu or click the Colors and Background tab to 
see a new set of options.
2.

 Click in the Text box.3.

A Color dialog box appears.

Select the color you want for the text and click OK.4. 
Click OK again to close the Options dialog box.5. 

 To change all options to their original settings, choose Document Options from the Edit menu, select 
Colors and Backgrounds, click Use Defaults, and then click OK. Your links revert to their default color, any 
Note



text not assigned a specific color character style reverts to the text default color, and any image background 
disappears.

To change the color of selected text:

 Select the text.1.
 Choose Color from the Style menu.2.
Choose one of the pre-defined colors or choose Other for more options.3. 

If you choose a pre-defined color, the color is applied to the text you selected. If you choose Other, a 
standard color dialog box appears. Click on the color you want, and click OK to apply a new color to 
the text.

 If you want to define a custom color, click Define Custom Color in the Color dialog box. For 
information on how to set a custom color, consult your Windows documentation.
Windows:

 To change the color of selected text back to the default color, choose Color from the Style menu, and 
choose Default.
Note

Using horizontal rules to separate text

You can use horizontal rules to separate your Web page into sections.

To create a horizontal rule, place the insertion point where you want the horizontal rule to appear and choose 
Horizontal Rule from the Insert menu.

Claris Home Page inserts horizontal rules of a size commonly used by many Web page designers.

To change the size of a horizontal rule:

 Double-click on the horizontal rule.1.

The Horizontal Rule Object Editor appears.

 Type new values for the dimensions of the rule.2.

For Height, enter a new size in pixels. For Width, choose Percent or Pixel to enter a size in pixels or a 
percentage of the overall browser window width respectively.

 You can also use the mouse to change the height of a horizontal rule. Click the rule to select it and drag 
the handle on the bottom of the rule to change the rule's height.
Note



Images
Converting image files
Adding an image
Using the Image Object Editor
Setting the image size
Making images interactive
Creating an interlaced image
Adding transparency to an image
Managing your image files

Specifying where converted image files are stored

The images that you include on your Web pages can be simple line art or color photographs. You can use an image 
for visual effect alone, or make it function as a clickable link to another Web page or to a Common Gateway 
Interface (CGI) script.

You can make an image  so that readers can see more of the image as it's downloading onto their 
computers. You can also add a single transparent color to an image to make parts of it (like the background) 
disappear.

interlaced

You can even use an image to create a background pattern for your Web page. For more information, see
.

Setting 
the color and background of your Web page

Claris Home Page comes with a library of clip art to use on your Web pages. You can also create your own libraries 
of images. For more information, see .Libraries and Clip Art

 Sometimes readers turn off image loading in their browser, and some browsers don't support images. Keep 
these possibilities in mind when deciding where to include images on your Web pages and what alternative labels to 
use as image placeholders.

Note

Converting image files

Images that you include on your Web page must be in one of the two standard formats used on the Web: GIF 
(Graphics Interchange Format) or JPEG (Joint Photographic Experts Group).

Claris Home Page automatically converts PICT files on the Macintosh and BMP files on Windows into GIF format. 
You can also convert images to GIF or JPEG format using an image editing program, such as Adobe Photoshop, or 
a conversion program, such as the Equilibrium Debabilizer on the Macintosh. Such programs may produce smaller 
files than the Claris Home Page automatic conversion.

 To view JPEG images that you insert into Claris Home Page on the Macintosh, you need QuickTime 2.0 or 
later installed on your computer. Your Web page readers won't need this application if their browser supports JPEG
images.

Note

Adding an image

When you add an image to a Web page, Claris Home Page creates a pointer to the folder where the image file is 
stored. When readers open your Web page, their browser downloads the image and displays it.

Web pages with large image files take longer to download. As you add images to your Web page, you can check 
how long it will take readers to download. For more information, see .Using the Document Statistics window

Before you add images to your Web pages, make sure the image files are stored in the image folder that you have 
set up for your Web site. You can set the image folder to be the default location where Claris Home Page stores 
converted files. See  for more information.Managing your image files



To add an image to your Web page:

 Place the insertion point in the page where you want the image to appear.1.
 Choose Image from the Insert menu.2.

An Open dialog box appears.

 In the Open dialog box, select the GIF, JPEG, BMP, or PICT image file and click Open.3.

The image appears on the Web page.

If the image is a JPEG or GIF file, Claris Home Page creates a pointer to the current location of the file. If the 
image is a BMP or PICT file, Claris Home Page converts the file to GIF format and places the converted file 
in the default images folder.

Using the Image Object Editor

Once you've added an image to your page, you can use the Image Object Editor to change the attributes of your 
image. The bottom section of the Image Object Editor is expanded or collapsed depending on how you left it last.

You can open the Image Object Editor three different ways:

Double-click an image.
Click an image, and choose Show Object Editor from the Window menu.
Click an image, and click the Object Editor button on the toolbar.

To expand the Image Object Editor, click the triangle at the bottom of the window.

To change the attributes of an image, select the image and then change the settings in the Image Object Editor. To 
apply the new settings, press Tab or click the close box of the Image Object Editor.

Use this image 
attribute 
setting 

To do this 

Alt label Set the text that appears in place of the image if your reader's browser doesn't support images or if your reader has 
turned image loading off. You should always provide an alternative label for important images. 

Border Change the thickness in pixels of the border around the image. A setting of 0 makes the border around the image 
invisible. 

Alignment 

Change how the image is aligned with text. Choose Top to align the top of the image with the top of the text next 
to it. Choose Middle to align the middle of the image with the text next to it. Choose Bottom to align the bottom of 
the image with the bottom of the text next to it. Choose Left or Right to place the image on the left side or right side 
of the page and have text flow around it.
Note View your page in a browser to see the actual left and right alignment of the image within text. 

Image Map 
Open the Image Map Editor so you can create an interlaced image, add transparency to an image, or add hotspots to 
an image map. See Creating an interlaced image, Adding transparency to an image, and Creating an image map for 
more information.

Width Change the width of the image. 

Height Change the height of the image. 

Reset Size Restore a resized image back to its original size. 

Behavior Change how an image works. You can set the image to be a normal image, a form button, or an image map for links. 
For more information, see Making images interactive. 

Extra HTML Add other HTML attributes to your table. (This is an advanced feature that requires knowledge of HTML; it 
specifies additional parameters for the <IMG> tag. For more information, see Using Edit HTML Source mode.) 

Setting the image size

How you set an image to scale in a browser depends on the type of image. For example, you may not want a 
photograph to rescale as your readers resize their browser windows because it distorts the image, but you may want 
a simple border or dividing line to rescale as the browser window changes. In Claris Home Page you can set fixed
dimensions for how the image is displayed in a browser. Or, you can have a border or other image resize 
proportionately as your readers resize their browser windows.



To resize an image or set how the image size adjusts to the size of a browser window:

Double-click on the image to open the Image Object Editor.1. 
 Choose a setting type from the Width or Height pop-up menus.2.
Choose this 

type To have the image sized like this 

Percent Image width or height appears as the chosen percentage of the browser window width or height.

Pixels Image width or height always appears as the specified size, measured in pixels, regardless of the browser 
window's size. 

 Type the number of pixels or percent for the image's width or height.3.
 Press Return (Macintosh) or Enter (Windows).4.

 Use the mouse to change the width and height of the image proportionately. Select the image, hold down the 
Shift key, and then drag the lower-right corner handle.
Tip

Making images interactive

You can make images more than just visual elements on your Web pages. You can make them interactive so the 
reader can click them to perform an action.

You can make an image function as:

A submit button in a form, so readers can click it to send form data to the server. For more information, see
.Using an image as a submit button

A link, so readers can click it to go to a different Web page or to an anchor in the same Web page. For more 
information, see .links
An image map, so readers can click different parts of it to activate different links. For more information, see

.Linking parts of an image

Creating an interlaced image

When a browser downloads a normal GIF image, the image gradually appears, line by line, from top to bottom on 
the screen. If an image is large and takes a long time to download, this can be frustrating for the reader. Readers 
might have to wait for almost the entire image to download before they really know what the image is.

To avoid this problem, you can change an image so that it is interlaced. When a browser downloads an interlaced 
GIF image, a rough outline of the entire image is displayed first and then detail is gradually added.

To make an image interlaced:

 Double-click the image to open the Image Object Editor.1.
 Click the Image Map button to open the image file in the Image Map Editor.2.

The image appears in the Image Map Editor.

 Click the Interlace button in the toolbar.3.

To change the image back into a non-interlaced image, click the Don't Interlace button .

 Close the Image Map Editor and save the changes to the image.4.

The image file is stored and displayed as an interlaced image.

To set Claris Home Page to convert PICT and BMP images into interlaced GIF images:

 Choose Preferences from the Edit menu.1.
 Choose Images from the pop-up menu or click the Images tab to display a new set of options.2.



 Select Make Interlaced GIF.3.
 Click OK.4.

 This setting only affects GIF files that Claris Home Page automatically converts from PICT or BMP files.Note

Adding transparency to an image

You can make a single color in an image transparent so the background of the Web page shows through. This is 
useful for making the rectangular background and outline of an image disappear.

To make the background of an image transparent:

If necessary (such as with most scanned images and photographs), use an image-editing program to make 
the image background a single color and then add the image to your Web page.
1. 

 Select the image and open the Image Object Editor.2.
 Click the Image Map button to open the image file in the Image Map Editor.3.
 Click the Transparency Tool button in the toolbar.4.
 Move the pointer over the image until it turns into an eyedropper.5.
 Using the eyedropper, click to select the color of the image you want to make transparent.6.

All pixels of the selected color become transparent.

 Close the Image Map Editor and save the changes to the image.7.

The color you selected in the image becomes transparent so you can see the background of your Web page. 
To learn how to change the color or background of your Web page, see

.
Setting the color and background of

your Web page

To remove transparency from an image, open the image in the Image Map Editor, and click the Remove 
Transparency button in the toolbar.

Managing your image files

You can specify the folder where Claris Home Page stores the GIF files it creates when you add a PICT or BMP 
image to your Web page. You can also have Claris Home Page prompt you for a filename and location each time it 
converts a file.

If you store your images folder in the same folder that contains your Web pages, the relative path to the images is 
always maintained, even when you move your Web site onto the Web server. The path can be broken, however, if 
you move an image file, the folder containing the image file, or the Web page that references the image. If you do
this, you must reinsert the image into the Web page to set the new path.

If you need to store your image folder somewhere other than within your Web site folder, you can specify an 
absolute path to the image files that won't change when you move your Web page files to a new location. For 
example, the images you add to your Web pages may already reside in a special image folder on the Web server 
you're going to use for your Web pages.

For more information about organizing your Web pages, see .Planning

Specifying where converted image files are stored

To set the default location where Claris Home Page stores the converted GIF files:

 Choose Preferences from the Edit menu.1.
Choose Images from the pop-up menu or click the Images tab to display a new set of options.2. 



 Click Set.3.
 Navigate to the folder where you want to store the created images and click Select "folder

name."
4. Macintosh:

 Type the directory path where you want to store the created images and click OK.Windows:

 Click OK.5.

To specify that Claris Home Page prompt you for a filename and location each time it converts an image file:

 Choose Preferences from the Edit menu.1.
Choose Images from the pop-up menu or click the Images tab.2. 
 Select Prompt for File Name/Location and click OK.3.

When Claris Home Page converts a file, it prompts you to assign a filename and a location for the converted 
file.

To specify absolute paths to where your images are stored:

Choose Preferences from the Edit menu.1. 
Choose HTML Output from the pop-up menu or click the HTML Output tab.2. 

 Select Use Absolute Pathnames and click OK.3.

Claris Home Page generates a complete, exact pathname that's not relative to the location of your Web page 
each time you insert an image. For more information about absolute paths, see

.
Using relative or absolute 

paths



Tables
Using the Table Object Editor
Entering text into a cell
Inserting an image into a cell
Resizing a table or parts of a table

Changing the table width or height
Resizing a cell

Changing the alignment of elements in a table

Tables provide a way of organizing and displaying information on your Web page. A simple table is made up 
of a series of rows and columns. A single block of information is called a cell and can contain text, images, lists, 
form elements, and other tables. In fact, anything that can be placed in an HTML document can be placed in a 
table cell.

 Tables are a relatively new part of HTML, and not all browsers support them. For this reason, before you 
start creating tables, make sure you know who your audience is and what kinds of browsers your readers use. 
If the majority of your readers are using browsers that don't support tables, you might want to consider using 
preformatted text to lay out your information. For information on using preformatted text, see

.

Note

Using paragraph 
styles

To create a table:

 Place the insertion point where you want your table to appear on your Web page.1.
 Choose Table from the Insert menu.2.

A table with two rows and columns appears, along with the Table Object Editor.

Once you've created a table, you can use the Table Object Editor to add more rows and columns, and to 
apply other attributes to the table and to elements that you enter into the cells.



Using the Table Object Editor

Once you've added a table to your page, you can use the Table Object Editor to change the attributes of your 
table. For example, you can make the border invisible so your readers are unaware that the information is 
contained in a table. The Table Object Editor appears automatically when you create a table.

You can also open the Table Object Editor three other ways:

Double-click a table border.
Click a table, and choose Show Object Editor from the Window menu.
Click a table, and click the Object Editor button on the Toolbar.

Click the triangle to expand or collapse the bottom section of the Table Object Editor.

To change the attributes of a table, select the table or the cell and then change the settings in the Table Object 
Editor. To apply the new settings, press Tab or click the close box of the Table Object Editor.

Use this table 
attribute setting To do this 

Border Change the thickness of the borders of the table. A setting of 0 makes the borders of the table invisible. 

Rows Change the number of rows in the table. Rows are added to and subtracted from the bottom of the table.
The maximum number of rows in a table is 50. 

Columns Change the number of columns in the table. Columns are added to and subtracted from the right side of the 
table. The maximum number of columns in a table is 20.

Add Row Add a row directly below the selected cell or table. 

Remove Row Delete the selected row or the bottom row of the selected table and its contents. 

Add Columns Add a column directly to the right of the selected cell or table. 

Remove Columns Delete the selected column or the last column on the right of the selected table and its content.

Width Change the width of the table. 

Height Change the height of the table. 

Spacing Change the amount of space between cells (by making the border thicker). 

Padding Change the amount of space around the data in cells. 

Extra HTML 
Add other HTML attributes to your table. (This is an advanced feature that requires knowledge of HTML; it 
specifies additional parameters for the <TABLE> tag. For more information, see Using Edit HTML Source 
mode.) 

You can also change the attributes of individual cells in a table. Click in the table cell to select it and change 
the appropriate attribute in the Table Object Editor.

Use this cell 
attribute setting To do this 

Alignment Change how elements are aligned within the table. 

Row Span Change how many rows a cell spans. 

Col Span Change how many columns a cell spans.

Header Cell Make the selected cell a table header cell in order to label a row or column. (Text in header cells appear in 
bold face type in Claris Home Page; they may look different in your browser.) 

Extra HTML Add other HTML attributes to a particular cell. (This is an advanced feature that requires knowledge of 
HTML; it specifies additional parameters for the <TH> or <TD> tag.) 

Entering text into a cell

To enter text in a cell, click in the cell to select it and start typing.

You can copy and paste text from one cell to another, from another application into your table, or from an open 
Web page into your table. You can also drag text from one cell to another or from an open Web page.

To delete text in a cell, select the cell and press Delete.



 As you type or copy text into a cell, the cell expands downward with all of the other cells in the same 
row of the table. The width of the cell, however, remains the same.
Note

Inserting an image into a cell

When you insert an image into a cell, the cell expands downward if the image height is larger than the cell 
height. The width of the cell, however, does not change automatically to accommodate the image, so you may 
need to adjust it. For information on changing the size of a cell, see .Resizing a table or parts of a table

To insert an image in a cell:

 Select the cell by clicking in it.1.
 Choose Image from the Insert menu.2.

The Open dialog box appears.

Select the image you want to insert and click Open.3. 

You can also copy and paste an image into your table from other cells, other Web pages, or other applications, 
or drag an image to insert a copy of it from other cells or open Web pages.

Resizing a table or parts of a table

There are different ways you can change the size of a table and the table's cells. You can change the width or 
height of the table in relation to the browser window, change the number of rows or columns in the table, 
change the table's dimensions using the mouse, and change the size of individual cells.

Changing the table width or height

You can change the size of a table and the rows and columns in it by using the Width and Height settings in 
the Table Object Editor.

To resize a table in relation to the browser window:

 Double-click on the table border to open the Table Object Editor.1.
Choose a setting type from the Width or Height pop-up menus.2. 

Choose 
this type To have the table sized like this 

Percent Table width or height appears as the chosen percentage of the browser window width or height.

Pixels 
Table width or height is always the specified size, measured in pixels, regardless of the browser window's 
size.
Note Some browsers that support tables do not support table widths measured in pixels.

Default 

The browser used to view the table determines the table's width or height. In Claris Home Page, the table is 
tall enough to display the text and images inside it and is as wide as the window (equivalent to a width 
setting of 100 percent).
Note The default selection does not add the width or height attributes to the <table> tag. 

 Type the number of pixels or percent for the table's width or height (if you selected Default for the 3.



width or height, you don't need to enter a value).
 Press Return (Macintosh) or Enter (Windows).4.

To resize a table using the mouse:

Select the table and drag the bottom handle to change the height of the table, drag the right-side handle to 
change the width of the table, or drag the lower- right corner handle to change the width and height at the same 
time.

Resizing a cell

You can resize cells in a table by resizing the whole table. You can also change a cell so that it spans two or 
more rows or columns. When you make a cell span more than one row, it expands downward. When you 
make a cell span more than one column, it expands to the right.

If you resize a cell to span over cells that contain text or graphics, the text or graphics are lost.Important

To change the number of rows or columns a cell spans:

 Click inside the cell to select it.1.

A heavy line appears on the inside of the cell.

 Choose Show Object Editor from the Window menu or click the Object Editor button on the toolbar 
to open the Table Object Editor.
2.

 Type the number of rows or columns you want the cell to span and press Tab or click the close box of 
the Table Object Editor.
3.

To resize a cell using the mouse:

Click on the cell to select it and drag the bottom handle to change the number of rows it spans, drag the right-
side handle to change the number of columns it spans, or drag the lower-right corner handle to change the 
number of rows and columns it spans at the same time.



Choose 
this To have elements aligned like this

Top Elements are aligned at the top of the cell. 

Middle Elements are aligned in the middle of the cell. 

Bottom Elements are aligned at the bottom of the cell. 

Baseline 

Text is aligned by the baseline of each character. The baseline is an imaginary line that divides the main body 
from the descender of a lowercase letter, such as a "g" or "j." This setting is generally used in tables where each 
cell contains a single line of text. When you are viewing your page in Claris Home Page, however, the text will 
look like it's top-aligned. Preview the page in your browser to see how it will look.

Changing the alignment of elements in a table

Any element that is in a table cell can be aligned to the border of the cell or to other elements in a row. You 
can also align text elements to the left, right, and center of a cell.

To align elements vertically:

 Click in the cell to select it.1.
 Choose Show Object Editor from the Window menu or click the Object Editor button on the toolbar 

to open the Table Object Editor.
2.

 Choose a setting from the Alignment pop-up menu.3.



Libraries and Clip Art
Using a library
Editing a library

Adding entries to a library
Renaming or deleting entries

Creating a new library

With Claris Home Page, you can use libraries to store Web page elements that you use frequently. For 
example, you can store logos, navigation buttons, boilerplate text, clip art, tables, form elements, and pieces of 
HTML code.

To display the elements of an entry in the bottom section of a library window, select the entry in the top 
section of the window.

 When a library file is open and selected, the Library menu appears on the menu bar, and the New 
Library Entry button appears in the library window's toolbar.
Note

Using a library

Claris Home Page comes with a library of clip art to get you started.

To open and use a library:

Choose Open from the File menu.1. 



The Open dialog box appears.

 Select the path to the library you want to open and click Open.2.

 Library files have an extension.Windows: .hlb

Position the library window on your screen so you can see the library's contents and your Web page.3. 
 Select the entry that contains the elements you want to use and follow the appropriate step in the table.4.

To copy Do this 

One element of an entry onto 
your Web page Drag the element from the bottom section of the library window to your Web page. 

Multiple elements of an entry 
onto your Web page 

Select the elements you want to copy from the bottom section of the library window 
while holding down the Shift key and drag them to your Web page.

All of the elements of an entry 
onto your Web page 

Drag the icon of the entry in the top section of the library window onto your Web 
page. 

Editing a library

You can change the contents of a library in different ways. You can rename entries, make new entries, add 
elements to an entry, add entries from other Claris Home Page libraries, and delete entries in a library.

You can change the order of entries in the library by dragging their icons to new positions in the top section of 
the library window. You can also edit text elements in the bottom section of the library window by using the 
same tools and methods you use to edit text on your Web page.

Adding entries to a library

To make a new entry:

 Choose New Entry from the Library menu or click the New Entry button in the toolbar.1.

An untitled entry appears in the top section of the library window. You may have to scroll through the 
list of entries to see it.

 Type a name for the new entry.2.
 Add elements to the entry by selecting the entry in the top section of the library window and pasting 

the elements into the bottom section.
3.

 You can also drag an element directly into the top section of the library window to make a new 
entry.
Note

To add entries from other libraries:

Open both libraries and arrange them side by side.1. 
Drag each entry from the original library to the top section in the new library window.2. 

 To delete elements from the entry, select them in the bottom section of the library window and 
press Delete.
Note

Renaming or deleting entries

To rename an entry:

 Double-click the entry name in the top section of the library window.1.



 Type a new name for the library entry.2.

To delete an entry:

 Click on the entry's icon in the top section of the library window.1.
 Choose Clear from the Edit menu or press Delete.2.

Creating a new library

Libraries can contain references to GIF files or anything that you can place in an HTML file.

To create a library:

 Choose New Library from the File menu.1.

An untitled library window appears with a top and bottom section.

 Choose Save from the File menu.2.

In the dialog box that appears, type a name for your library.

 Claris Home Page saves your library with the extension .Windows: .hlb



Links
Linking to pages within your Web site
Linking to other Web pages and resources
Linking to an anchor on a page

Creating an anchor
Creating a link to an anchor
Changing an anchor name

Testing links
Copying links
Deleting links
Changing the color of links
Linking parts of an image

Creating an image map
Specifying a default URL
Testing hotspot links

You can include hypertext links in your Web pages to allow your readers to move easily from one page to 
another within your site, or to other locations on the World Wide Web.

There are several kinds of links you can create in Claris Home Page, including:

links within your own Web site
links to other Web sites
links to FTP sites
links to email addresses

You can make text, images, or specific parts of an image (called an image map) into links. You can also create 
links that reference frames, which is discussed in .Frames

Every link needs to have an address. This address is referred to as a , or Uniform Resource Locator. Claris 
Home Page automatically inserts the URL when you create a link to another page in your Web site or to an 
anchor within a Web page.

URL

Links can use relative paths or absolute paths. For more information on relative and absolute paths, see
.

Using 
relative or absolute paths

It's best to have the contents of your Web pages in place before you begin creating links. Making a flow chart 
of your pages can help you keep track of where you want to add links and where those links should lead. (For 
information, see .)Using a flowchart

Linking to pages within your Web site

With Claris Home Page, you don't need to type the URL of a Web page within your own Web site to link to it.

When a link is used, it takes you to the top of the linked page by default. To make a link go to a different place 
in the page, see .Linking to an anchor on a page

To create a link to another Web page you've created:

 Select the text or image you want to make the link.1.
Choose Link to File from the Insert menu or click the Insert Link to File button on the toolbar.2. 

 Select the name of the Web page file you want to link to and click Open.3.

The text becomes underlined and the color of the text or the image border changes to indicate the link.



 To remove the visible border from a linked image, select the image, choose Show Object Editor 
from the Window menu, and change the number in the Border text field to .
Tip

0

For information about changing the default color of links, see .Changing the color of links

To create another link to the same location:

 Select the new text or image you want to make into a link.1.
 Choose Show Link Editor from the Window menu.2.
 Choose the most recent URL listed at the top of the URL pop-up menu.3.

You can also click the Browse Files button to locate a file.

Linking to other Web pages and resources

To link to another Web page or resource, you must know the exact URL for that Web page or resource and 
you must use the correct syntax when you type it into the Link Editor.

To create a link to another site:

 Select the text or image you want to make the link.1.
Choose Link to URL from the Insert menu or click the Link Editor button on the toolbar.2. 

The Link Editor appears.

 To see some examples of the correct syntax for URLs, click Show Examples.3.
 Type the URL of the link's destination in the URL text box.4.

To link to Use this syntax 

A Web page within your Web site file.html 

A Web page outside your Web site http://servername/dir/file.html 

An anchor on the same Web page #anchorname 

An anchor on a page within your Web site file.html#anchorname 

An anchor on a page outside your Web site http://.../file.html#anchorname 

An email address mailto:username@hostname 

An anonymous FTP site ftp://servername/dir/file.txt 

You can use links to send an electronic message to a specific email address. When links to email 
addresses are used, the browser opens an email message window where you can type and send a
message addressed to that email address.

 Press Return (Macintosh) or Enter (Windows).5.

The text becomes underlined and the color of the text or the image border changes to indicate the link.

 To remove the visible border from a linked image, select the image, choose Show Object Editor 
from the Window menu, and change the number in the Border text field to .
Tip

0

For information about changing the default color of links, see .Changing the color of links



To create another link to the same location, select the new text or image you want to make into a link 
and choose the most recent URL listed at the top of the URL pop-up menu.
6. 

Linking to an anchor on a page

You can create a link to an  so your readers can jump to a specific spot on your Web page. Links can 
jump to anchors on the same page as the link itself or to anchors on other Web pages.

anchor

To create a link to an anchor, you create an anchor at the spot in your Web page where you want your readers 
to jump to and then create a link to it.

Creating an anchor

 Position the insertion point where you want to place the anchor in your Web page.1.
 Choose Anchor from the Insert menu, or click the Insert Anchor button on the toolbar.2.

A dialog box appears with a default name for the anchor. You can type a new name for the anchor if you 
want to. Giving a descriptive name makes it easier to link to the correct anchor if you create many 
anchors.

 Click OK.3.

An anchor icon appears on your Web page.

 Choose Save from the File menu so you can link to the anchor you've created.4.

Creating a link to an anchor

After you've created and named anchors in your pages, you can create links to them.

 Open the Web page that contains the anchor you want to link to.1.
 Select the text or image you want to make the link to the anchor.2.
 Choose Link to URL from the Insert menu, or click the Link Editor button on the toolbar.3.

The Link Editor opens.

 Type the anchor's name preceded by a number symbol ( ) in the URL text box or choose it from the 
pop-up menu.
4. #

The text becomes underlined and the color of the text or the image border changes to indicate the link.

 To remove the visible border from a linked image, select the image, choose Show Object Editor from the 
Window menu, and change the number in the Border text field to .
Tip

0



For information about changing the default color of links, see .Changing the color of links

You can also use this shortcut to create a link to an anchor:

Open the page where you want to place the link and open the page containing the anchor.1. 
While holding down the Option key (Macintosh) or Control key (Windows), click the anchor icon 

and drag it to the position where you want the link to appear.
2. 

 Release the mouse button.3.

Claris Home Page inserts a text link to the anchor.

By default, the text of the link is  where  is the name of the file containing 
the anchor and  is the name of the anchor.

filename#anchorname filename
anchorname

 If you want to change the default text, select the link and type the new text for it.4.

 It is possible to create links to anchors on other people's Web pages by typing the URL of the anchor. If 
you do create links to anchors on other people's Web pages, keep in mind the possibility that they might
rename, delete, or move their anchors, which can cause your links to break or send your users to the wrong 
place on someone else's Web page.

Note

Changing an anchor name

You can change the name of an anchor at any time or add extra HTML code to it. Note, however, that any 
links you've made to the anchor must be re-created using the new name you assign.

To rename an anchor:

 Double-click the anchor icon in your Web page.1.

The Anchor Object Editor appears.

If you want to add extra HTML code to the anchor tag, type it in the Extra HTML text box.Note

 Type a new name for the anchor and press Return (Macintosh) or Enter (Windows).2.

Testing links

Once you have created links, you can test them to make sure that they work.

The way you test a link depends on what kind of link it is and how you want to test it.



To test a link Do this 

To a Web page or anchor within 
your Web site using Edit Page 
mode 

Command-click the link (Macintosh) or Alt-click the link (Windows). 

To a Web page or anchor within 
your Web site using Preview Page 
mode 

Select Preview Page from the Window menu, and then click the link. 

To an external Web page or 
resource 

Choose Preview in Browser from the File menu to display your Web page containing the 
link in the default browser and then click the link. To change the default browser, see
Changing the default browser. 

Copying links

You can copy and paste links between pages of your Web site rather than re-creating them multiple times. 
Simply select the link text or image and copy and paste as you would normally, or you can drag the link from 
page to page. Claris Home Page copies the entire link, including the link's address. You can also store links in 
a library. See  for more information.Libraries and Clip Art

For more information about copying elements, see .Cutting, copying, and pasting

Deleting links

To delete a link but not the text or image associated with the link, select the link text or image, choose Show 
Link Editor from the Window menu, and click Remove Link.

To delete the text or image in addition to the link itself, select the link and press Delete.

Changing the color of links

You can change the default color of links in your Web page. Note that not all browsers display the colors that 
you select, so you'll probably want to view your Web pages in your browser to check your new color scheme.

 Choose Document Options from the Edit menu.1.

The Options dialog box appears.

 Choose Colors and Background from the pop-up menu or click the Colors and Background tab to 
display a new set of options.
2.

Click one of the types of links to specify a new color for it.3. 
Choose To change the color of Default color 

Normal Link Links that the user has never clicked Blue 

Active Link Links while they are being clicked Red 

Visited Link Links the user has already clicked Purple 

The Color dialog box appears.

Select the color you want for that type of link.4. 
 Click OK.5.
Repeat steps 3 through 5 for each link color you want to change.6. 

 Click OK.7.

Linking parts of an image



When you turn an image into a simple link, the entire image becomes a clickable link that leads to a single 
destination. When you create an image map, however, you can link different parts of an image to separate 
destinations.

Making an image map work requires knowledge of HTML code, available CGI programs, and the capabilities 
of your Web server. If you do not have this knowledge, you might consider using several individual images as 
links instead of an image map.

To link different parts of an image, you need to change the image's behavior attribute to image map, define 
specific link areas of the image called assign destination URLs, and then provide a CGI script to pull 
everything together.

hotspots,

 For your image maps to work, the Web server where you load your Web pages must be running an 
image map CGI program and you must assign a link to the image that references the image map CGI program 
and the .map file that Claris Home Page creates and stores in the same folder as the original image file. Claris 
Home Page generates NCSA-compatible image map files.

Note

Creating an image map

To create an image map, you first change the behavior attribute of the image and then you make parts of the 
image into linkable hotspots.

 Select the image and open the Image Object Editor.1.
 Choose Image Map from the Behavior pop-up menu.2.

The Image Map Editor appears.

Click the Image Map button in the Image Object Editor.3. 

The image file opens in the Image Map Editor.

 Select the Rectangular Link or the Circular Link tool in the Image Map Editor toolbar and draw 
a rectangle or circle over the area of the image that you want to be a hotspot.
4.

The pointer changes into a crosshair pointer as you move it over the image area.



 Double-click the hotspot to open the Link Editor.5.
Type the filename or URL of the link destination in the URL text box.6. 

 Repeat steps 4 through 6 to create other hotspots in the image.7.

Claris Home Page numbers each hotspot as you draw it, with lower- numbered hotspots in front.

If you draw hotspots that overlap each other, hotspots in front take precedence over the ones in 
back. Use the Move Link buttons to change the order that layered hotspots are used.
Note

 Save your image map and close the Image Object Editor.8.

Claris Home Page creates the image map file (.map file) and stores it in the same folder as the original 
image file.

 Save your Web page.9.

Specifying a default URL

You can make the areas of an image map that aren't covered by hotspots link to a specific file or URL. When a 
reader clicks on the image map but does not click on a particular hotspot, the link is activated.

To specify a default URL for the image map, select the image, open the Image Object Editor, click Image 
Map, and type the file or URL in the Default URL text box.

Testing hotspot links

To test whether the image map hotspots work as links:

 Click the Preview Page mode button on the toolbar.1.



Move the pointer over the image.2. 

The pointer changes to a hand when it's over a hotspot, and the hotspot's URL appears in the lower-left 
corner of the Claris Home Page application window.

 Click the hotspot.3.



Frames
Adding frames to a frame document

Creating frames within frames
Using the Frame Object Editors

Using the Frame Object Editor
Using the Frame List Editor

Moving frames
Resizing frames
Associating your frames with Web pages
Using links in frames

Browsers usually display a single Web page. It is possible to have a browser display more than one Web page 
at a time. You do this by creating a special kind of Web page, called a , that is divided into 
rectangular sections called . When you are editing frames in the frame document, you cannot add text, 
images, links, or other elements to them. Frames are simply containers that you use to display Web pages.

frame document
frames

You can place as many frames in a frame document as you like and you can resize the frames and change their 
orientation. You can place a Web page that contains links in one frame and have the links open different Web 
pages in another frame.

Before you decide to use frames, be aware that they are a new feature of the Netscape extensions to HTML 3.0 
and aren't supported on most browsers. Claris Home Page automatically adds an explanatory message to 
frame documents for readers who use browsers that don't support frames.

When you open a frame document, Claris Home Page automatically opens it in Edit Frames mode. This is an 
additional mode available only when you are working with a frame document. To edit the message that appears 
in browsers that don't display frames, switch to Edit Page mode. To view the message, use Preview Page 
mode. To edit the HTML source code of the frame document directly, use Edit HTML Source mode.

To create a frame document, choose New Frame Layout from the File menu.

 The contents of frames are only visible when you preview your Web page in a browser. In 
addition, many of the changes you make to frames won't appear until you save your frame document and the 
Web pages displayed in the frames. Also, displaying Web pages in multiple frames can pose problems for 
standard navigation commands in browsers, such as Back.

Important

Adding frames to a frame document

A new frame document contains a single frame that you can use to display one Web page. You can add 
horizontal frames, vertical frames, and (frames within a frame) to display more than one Web page at 
a time.

frame lists

To add horizontal frames:

 Choose Subdivide Vertically from the Frame menu or click the Subdivide Vertically button .1.

The single frame is divided into two horizontal frames.

Choose Subdivide Vertically again to add the next horizontal frame.2. 

To add vertical frames:

 Choose Subdivide Horizontally from the Frame menu or click the Subdivide Horizontally button .1.



The single frame is divided into two vertical frames.

 Choose Subdivide Horizontally again to add the next vertical frame.2.

 You can also add a new frame to a specific place in a frame document instead of dividing an existing 
frame. Select a frame and choose Add Row/ Column from the Frame menu. If the frame you selected is a 
horizontal frame, a new horizontal frame is added above it. If the frame you selected is a vertical frame, a new 
vertical frame is added to the left of it.

Tip

To delete a frame, select the frame and press the Delete or Backspace key.

Creating frames within frames

If you want to have vertical frames and horizontal frames in the same frame document, you need to create 
frames within a frame. A frame that contains other frames is called a , and has a different Object 
Editor than the frames inside it.

frame list

To create frames within a frame:

 Select the frame.1.
 If you want to split the frame into two horizontal frames, select Subdivide Vertically. If you want to 

split the frame into two vertical frames, select Subdivide Horizontally.
2.

 Continue selecting Subdivide Vertically and Subdivide Horizontally to divide the frame any way you 
like.
3.

Using the Frame Object Editors

Once you have created a frame document and added frames to it, you can use the Frame Object Editors to 
change the attributes of your frames.

You use the Frame Object Editor to name a frame, associate frames to Web pages, and apply other attributes to 
frames. You use the Frame List Editor to change the orientation and size of a frame list (a frame containing 
other frames).

Using the Frame Object Editor

To open the Frame Object Editor, do one of the following:

Double-click a frame.
Click a frame, and choose Show Object Editor from the Window menu.
Click a frame, and click the Object Editor button in the basic toolbar.

To expand the Frame Object Editor to display more options, click the triangle .

To apply the changes you make to a frame in the Frame Object Editor, press Tab or Return (Macintosh) or 
Enter (Windows).

You can change the following frame attributes:



Use this frame 
attribute To do this 

Size Change the size of the frame. See Resizing frames for more information. 

URL Specify the URL for the Web page you want displayed in the frame. 

Name Specify a name for the frame. You need to specify a frame's name in the Link Editor when you want the target 
Web page of a link displayed in the frame. 

Scrollbars 
Specify whether the frame has a scrollbar or not. Choose Always if you want the frame to have a scrollbar, 
Never if you don't want the frame to have a scrollbar, or Auto if you want the frame to have a scrollbar when the 
Web page displayed in the frame is larger than the frame itself. 

Margin Width Specify how far you want the Web page displayed in the frame indented from the sides of the frame. You can 
specify any amount from 0-100 pixels. 

Margin Height Specify how far you want the Web page displayed in the frame indented from the top and bottom of the frame. 
You can specify any amount from 0-100 pixels.

Fixed Size Select if you don't want the reader to be able to resize the frame. Leave unselected if you want the reader to be 
able to resize the frame. 

Extra HTML 
Add other HTML attributes to a frame. (This is an advanced feature that requires knowledge of HTML; it
specifies additional parameters for the <FRAME> tag. For more information, see Using Edit HTML Source
 mode.) 

Using the Frame List Editor

To open the Frame List Editor, double-click the border of a frame list.

To expand the Frame List Editor to display more options, click the triangle .

To apply the changes you make to a frame list in the Frame List Editor, press Tab or Return (Macintosh) or 
Enter (Windows).

You can change the following frame list attributes:
Use this frame 
list attribute To do this 

Size Change the size of the frame list. 

Direction Change the orientation of the frames within a frame. Choose Vertical to change horizontal frames in a frame 
list into vertical frames. Choose Horizontal to change vertical frames in a frame list into horizontal frames.

Extra HTML 
Add other HTML attributes to a frame list. (This is an advanced feature that requires knowledge of HTML; it 
specifies additional parameters for the <FRAMESET> tag. For more information, see Using Edit HTML 
Source mode.) 

Moving frames

If your frame document contains multiple frames, you can move them from one location to another using the 
mouse. Simply drag the frame you want to move to its new location within the frame document.



You can resize a frame in your frame document using the Frame Object Editor. You can also resize frame lists 
using the Frame List Editor.

To resize a frame or frame list:

 Double-click the frame or frame list border to open its Object Editor.1.
 Choose an option from the Size pop-up menu of the Editor you opened2.
Select 
this To have the frame or frame list sized like this 

Percent The frame or frame list dimensions are the specified percentage of the frame document. 

Pixels The frame or frame list is the specified amount of pixels tall if it has a horizontal orientation or the specified 
amount of pixels wide if it has a vertical orientation. 

Stars 

The frame or frame list uses all of the remaining space in the frame document. For example, if you have two 
frames, and you set the first frame to 40 percent and the second frame to Stars, the second frame uses the 
remaining 60 percent of the frame document. If more than one frame in a frame document has the Stars size 
attribute, the remaining space is divided up between them proportionately based on the value in the Size text
box. 

 Type the number of pixels or percent for the frame or frame list's size (if you selected Stars, you don't 
need to enter a value) in the Size text box.
3.

 Press Return (Macintosh) or Enter (Windows).4.

Associating your frames with Web pages

Once you are finished adding, resizing, and moving frames, you need to associate each frame with the Web 
page you want that frame to display.

To associate frames with Web pages:

 Double-click the frame to open the Frame Object Editor.1.
 Type the URL of the Web page you want displayed in the frame in the URL text box.2.
Press Return (Macintosh) or Enter (Windows).3. 

The URL of the Web page appears in the frame.

Select each of the other frames in your frame document and repeat steps 2 and 3 to associate them 
with Web pages.
4. 

 Save the frame document.5.

Be sure to associate all of the frames in your document with a Web page.Important

Resizing frames



.

 

Using links in frames

When a reader clicks a link in a frame, the target page appears in the frame and the original page containing 
the link disappears.

If you want to keep the original page that contains the link in the frame, you must specify a different frame to 
display the target page. This is useful for displaying a table of contents for a Web page in one frame, and the 
actual Web page in another.

To specify a different frame to display target Web pages:

 Associate the Web page that contains the links with a frame in your frame document and save the 
frame document. (For more information on associating a Web page with a frame, see

.)

1.
Associating your 

frames with Web pages
 Select the frame where you want the target Web pages displayed.2.
 In the Frame Object Editor, type a URL for the first Web page you want readers to see before they 3.

activate a link in the other frame.
 Type a name for the target frame in the Name text box. (If necessary, click the triangle to expand the 

Frame Object Editor.)
4.

You use this name to associate the link with the frame later.

 Press Return (Macintosh) or Enter (Windows) and save the frame document.5.

The name of the frame appears in the frame.

 Open the Web page containing the links in Edit Page mode.6.

 If you haven't created the links in the Web page yet, use this shortcut. Choose Document Options 
from the Edit menu, choose General from the pop-up menu or tab, and type the name of the target frame 
that you specified in step 3 in the Default Target text box (Macintosh) or the Default Target Frame text 
box (Windows). Now all of the links you create in the Web page will automatically reference the target
frame.

Tip

 Select the first link and open the Link Editor. (Choose Show Link Editor from the Window menu or 
click the Link Editor button in the basic toolbar.)
7.

 Type the name that you gave the frame in step 3 in the Target Frame text box. (If necessary, click the 
triangle to expand the Frame Object Editor.)
8.

 Press Return (Macintosh) or Enter (Windows).9.
 Repeat steps 6 to 10 to change the other links in the Web page.10.
Save the Web page.11. 



Forms
Creating a form
Adding form elements to your Web page

Adding a text field
Adding a text area
Creating a password field
Using radio buttons or checkboxes in a list
Creating a pop-up menu or scrolling list
Adding a submit button
Adding a reset button
Creating a hidden entry

Specifying a CGI script for your Web page

Claris Home Page provides the elements you need to create a form on your Web page. You can use a form to 
solicit input from readers who read your Web pages. For example, a reader can order a product, provide 
feedback, fill out a questionnaire, or specify search criteria.

To process a reader's input, the form needs to call a Common Gateway Interface (CGI) script written in a 
script or programming language (such as AppleScript or Perl) located on a Web server.

Many CGI scripts that handle form input are available on the Web. They can be adapted to handle your 
form's input. Some Internet Service Providers (ISPs) already have form CGI scripts available on their sites.
Note

Creating a form

You can create only one form per Web page in Claris Home Page. Your form can contain text, images, tables, 
and so forth, in addition to the form elements your reader interacts with. When you create a form, you add each 
form element separately and assemble them on the page. Form elements include text areas, text fields, pop-up 
menus, buttons or checkboxes that the reader can select, and a submit button that the reader clicks to send 
their input to the server. You can also include a button for resetting the reader's input, a password field, and 
hidden entry elements in your form.

You can change form elements the same way you change other Web page elements, that is, you can copy 
them, move them around, and resize them using the same basic methods. See  for 
more information.

Cutting, copying, and pasting

Adding form elements to your Web page

All form elements are added to your Web page in the same way. Form elements include: text fields, text areas, 
password fields, radio buttons, checkboxes, pop-up menus, scrolling lists, submit buttons, a reset button, and 
hidden entries. Some elements work differently and therefore have specific instructions. The following sections 
detail each element and their use.

To add a form element to your Web page:

Place the insertion point in the page where you want the element to appear.1. 
 Choose Forms from the Insert menu and then choose an element from the submenu.2.
Select the element and open its Object Editor (choose Show Object Editor from the Window menu).3. 

 Enter the name and other specifications for the element in the Object Editor.4.

The name of the element is used by the CGI script to locate the reader's input.

 Press Return (Macintosh) or Enter (Windows) to assign the specifications to the element.5.



Adding a text field

Text fields can only contain one line of text, can be 1 to 500 characters wide, and can only be resized 
horizontally. These fields are generally used for shorter information such as a name or phone number.

You can set the maximum number of characters that your readers can enter in the Maximum Length text box 
of the Object Editor.

You can also add text to a text field to show the reader what kind of information to input, or to provide a 
default value to be input if the reader doesn't enter anything in the field.

Adding a text area

Text areas allow your readers to enter multiple lines of text. The size of a text area is measured in rows and 
columns where each row is equivalent to one character in width and each column is equivalent to one character 
in height. A text area can be 1 to 100 rows wide and 5 to 500 columns tall.

The size of a text area does not limit the amount of text that your readers can enter; if more text is entered, the 
text area will scroll.

Creating a password field

You can add a field to your form that allows the reader to type a password. When the reader enters text into the 
password field, a series of bullets appears.

Password fields are identical in all respects to text fields, except that they display as bullets rather than text. Be 
sure to add an image or text to your Web page to let the reader know it is a password field.

Using radio buttons or checkboxes in a list

Radio buttons allow the reader to select one choice from a list of options. Checkboxes allow the reader to 
select as many choices as they like from the list.



You need to assign the same name to every radio button in a list so they can work together. In addition, you 
must assign a unique value to each radio button or checkbox to differentiate it from the others in the list.

To create a list of radio button or checkbox choices:

 Type the list and place the insertion point before the first item in the list.1.
 Choose Forms from the Insert menu and then choose Radio Button or Checkbox.2.

A radio button or a checkbox appears in your Web page at the insertion point.

 Select the radio button or checkbox and open its Object Editor.3.

 Type a name in the Button Name textbox and press Return (Macintosh) or Enter (Windows).4.

This name needs to be the same for every radio button in a list.

 Type a unique name in the Button Value textbox for the radio button or checkbox and press Return 
(Macintosh) or Enter (Windows).
5.

This value needs to be different from every other button in the list.

 To make a radio button or checkbox selected by default, select Checked.6.

The default choice is selected unless the reader selects a different button or checkbox in the list.

 Only one radio button in a list can be the default button.Note

 Repeat steps 2 through 6 for each radio button or checkbox you want to add to the list.7.

Creating a pop-up menu or scrolling list

Pop-up menus and scrolling lists allow readers to choose from a list of items. Readers can choose one item at a 
time from a pop-up menu and make multiple selections in a scrolling list.



To create a pop-up menu or scrolling list:

 Choose Forms from the Insert menu and then choose Popup Menu.1.
 Select the pop-up menu and open its Object Editor.2.
 Assign a name to the element in the Name text box.3.

The name of the element is used by the CGI script to locate the reader's input.

Type a number in the Items Visible text box.4. 

Type  if you want the element to be a pop-up menu. If you want it to be a scrolling list, type a value 
greater than 1 to specify the number of list items you want to be visible in the list.

1

Click Edit Items.5. 

The Menu dialog box appears.

Type the names of the items you want to include in the pop-up menu or scrolling list.6. 
 If you want to allow the reader to select more than one item in a scrolling list, select Allow Multiple

Selections.
7.

 To make a particular item the default choice, click next to it in the Menu dialog box.8.

A checkmark appears next to the item in the dialog box.

Click OK.9. 

In the case of pop-up menus, the default choice is displayed in the menu when the reader is not using 
the menu and it appears in the menu with a checkmark next to it when the reader is using the menu.

In the case of scrolling lists, the default choice appears highlighted in the list. Be sure to make the 
Number of Items Visible value large enough so that the default item is visible when the reader isn't 
working with the list.

 You can make multiple items in a pop-up menu or scrolling list default items. Make sure that Allow 
Multiple Selections is selected, click next to all of the items, and for scrolling lists, make sure the Number of 
Items Visible value is large enough so that all of the default items are visible when the reader isn't working 

Note



with the list.

Adding a submit button

A form can have more than one submit button, each one specifying a different way that the information is 
processed. You need to include a submit button for readers to send their information.

Submit buttons must call a CGI script to function properly. For this reason, you won't be able to test their 
functionality in Edit Page or Preview Page mode.

When you add a submit button to your page, the default text Submit appears in it. You can change this text if 
you want readers to see something different.

To assign an identifying name to the button for use in a CGI script, select the button, open its Object Editor, 
and type a name in the Action Name box. (The default name is name.)

Using an image as a submit button

You can turn an image into a submit button, so that when the reader clicks on the image, the form is submitted.

For information on other ways to use an image, see .Making images interactive

To use an image as a submit button:

 Double-click the image to open its Object Editor.1.
Choose Form Button from the Behavior popup menu.2. 

An outline appears around the image indicating that it is a submit button.

Adding a reset button

You can add a reset button to your form so readers can clear their form entries and return the form to its default 
values. This is helpful if the reader makes a mistake or wants to send new data.

Reset buttons must call a CGI script to function properly. For this reason, you won't be able to test their 
functionality in Edit Page or Preview Page mode.

When you add a reset button to your form, the default text Reset appears in it. You can change this text if you 
want the reader to see something different.

Creating a hidden entry

Hidden entries allow you to supply additional information to the CGI script without displaying the information 
on your Web page. When readers submit their forms, hidden entry data is sent to the server along with the data 
they have entered in the form.

When you add a hidden entry to your Web page, a box appears with the word HIDDEN in it. Select the 
hidden entry, open its Object Editor and enter the appropriate values in the Entry Name and Entry Value text 
boxes. These values are sent to the CGI script when the reader clicks a submit button.

 Because hidden entries are invisible to the reader, they don't appear when you view your Web pages in 
Preview Page mode or in a browser.
Note



Specifying a CGI script for your Web page

As mentioned earlier, forms need to call a CGI script in order to process the data that readers enter. You can 
specify a CGI script for each Web page that contains a form.

To specify a CGI script for your Web page:

 Choose Document Options from the Edit menu.1.
 Choose General from the pop-up menu or tab to display the document options information.2.
Type the name and path for the CGI script file on the server in the Form Action text box.3. 
Choose GET or POST from the Form Action pop-up menu to specify how you want the form data 

sent to the server.
4. 

 Click OK.5.



Special Characters

If you want to add special characters (such as the copyright symbol) to your Web page, your keyboard may 
not be encoded to let you type the character. In addition, even if your keyboard is encoded to let you type the 
character, depending on your system the character may not display correctly when your readers view your 
Web page. You can use the Raw HTML character style in Claris Home Page to make sure that such special 
characters display correctly on your Web page.

HTML uses the International Standards Organization (ISO) Latin-1 character set. HTML assigns each 
character in the ISO Latin-1 character set a numeric entity. If you want to use an ISO Latin-1 character in your 
text, you can enter the numeric entity followed by a semicolon for that character as raw HTML in Claris Home 
Page. You see the actual character when you preview your Web page in a browser or in Claris Home Page 
after you close and reopen the document.

 If your browser does not recognize a numeric entity, then the characters listed in brackets appear in its 
place.
Note

Numeric entity (raw 
HTML option) Special character produced 

&#00;-&#08; Unused 

&#09; Horizontal tab 

&#10; Line feed 

&#11;-&#12; Unused 

&#13; Carriage Return 

&#14;-&#31; Unused 

&#32; Space 

&#33; ! (Exclamation mark) 

&#34; " (Quotation mark) 

&#35; # (Number sign) 

&#36; $ (Dollar sign) 

&#37; % (Percent sign) 

&#38; & (Ampersand) 

&#39; ' (Apostrophe) 

&#40; ( (Left parenthesis) 

&#41; ) (Right parenthesis) 

&#42; * (Asterisk) 

&#43; + (Plus sign) 

&#44; , (Comma) 

&#45; - (Hyphen) 

&#46; . (Period) 

&#47; / (Solidus - slash) 

&#48;-&#57; 0 1 2 3 4 5 6 7 8 9 (Digits 0-9) 

&#58; : (Colon) 

&#59; ; (Semi-colon) 

&#60; < (Less than) 

&#61; = (Equals sign) 

&#62; > (Greater than) 

&#63; ? (Question mark) 

&#64; @ (Commercial at) 

&#65;-&#90; A B C D E F G H I J K L M N O P Q R S T U V W X Y Z (Letters A-Z) 

&#91; [ (Left square bracket) 

&#92; \ (Reverse solidus - backslash) 

&#93; ] (Right square bracket) 



&#94; ^ (Caret) 

&#95; _ (Horizontal bar - underbar) 

&#96; \Q (Grave accent - back apostrophe) 

&#97;-&#122; a b c d e f g h i j k l m n o p q r s t u v w x y z (Letters a-z) 

&#123; { (Left curly brace) 

&#124; | (Vertical bar) 

&#125; } (Right curly brace) 

&#126; ~ (Tilde) 

&#127;-&#159; Unused 

Values 128-159 These values are not assigned to displayable characters in the ISO8859-1 code and should not be 
used for displayable characters in HTML. 

&#160; Non-breaking space [&nbsp] 

&#161; ¡ (Inverted exclamation) [&iexcl; &iexcl] 

&#162; ¢ (Cent sign) [&cent; &cent]

&#163; £ (Pound sterling) [&pound; &pound] 

&#164; ? (General currency sign) [&curren; &curren] 

&#165; ¥ (Yen sign) [&yen; &yen]

&#166; | (Broken vertical bar) [&brvbar; &brvbar] 

&#167; § (Section sign) [&sect; &sect]

&#168; ¨ (Umlaut - dieresis) [&uml; &uml] 

&#169; © (Copyright) [&copy; ©]

&#170; ª (Feminine ordinal) [&ordf; &ordf] 

&#171; « (Left angle quote, guillemotleft) [&laquo; &laquo] 

&#172; ¬ (Not sign) [&not; &not]

&#173; - (Soft hyphen) [&shy; &shy] Many browsers do not properly handle this character. RFC 1866
recommends using the &shy; entity name instead of this ISO code. 

&#174; ® (Registered trademark) [&reg; ®] 

&#175; (Macron accent) [&macr; &macr]

&#176; ° (Degree sign) [&deg; &deg]

&#177; ± (Plus or minus) [&plusmn; &plusmn] 

&#178; 2 (Superscript two) [&sup2; &sup2] 

&#179; 3 (Superscript three) [&sup3; &sup3] 

&#180; ´ (Acute accent) [&acute; &acute] 

&#181; µ (Micro sign) [&micro; &micro]

&#182; ¶ (Paragraph sign) [&para; &para] 

&#183; · (Middle dot) [&middot; &middot] 

&#184; ¸ (Cedilla) [&cedil; &cedil]

&#185; 1 (Superscript one) [&sup1; &sup1] 

&#186; º (Masculine ordinal) [&ordm; &ordm] 

&#187; » (Right angle quote, guillemotright) [&raquo; &raquo] 

&#188; (Fraction one-fourth) [&frac14; &frac14] 

&#189; (Fraction one-half) [&frac12; &frac12] 

&#190; (Fraction three-fourths) [&frac34; &frac34] 

&#191; ¿ (Inverted question mark) [&iquest; &iquest] 

&#192; À (Capital A, grave accent) [&Agrave; À] 

&#193; Á (Capital A, acute accent) [&Aacute; Á] 

&#194; Â (Capital A, circumflex accent) [&Acirc; Â] 

&#195; Ã (Capital A, tilde) [&Atilde; Ã] 

&#196; Ä (Capital A, dieresis or umlaut mark) [&Auml; Ä] 

&#197; Å (Capital A, ring) [&Aring; Å] 

&#198; Æ (Capital AE dipthong, ligature) [&AElig; Æ] 

&#199; Ç (Capital C, cedilla) [&Ccedil; Ç] 

&#200; È (Capital E, grave accent) [&Egrave; È] 

&#201; É (Capital E, acute accent) [&Eacute; É] 



&#202; Ê (Capital E, circumflex accent) [&Ecirc; Ê] 

&#203; Ë (Capital E, dieresis or umlaut mark) [&Euml; Ë] 

&#204; Ì (Capital I, grave accent) [&Igrave; Ì] 

&#205; Í (Capital I, acute accent) [&Iacute; Í] 

&#206; Î (Capital I, circumflex accent) [&Icirc; Î] 

&#207; Ï (Capital I, dieresis or umlaut mark) [&Iuml; Ï] 

&#208; (Capital Eth, Icelandic) [&ETH; ]

&#209; Ñ (Capital N, tilde) [&Ntilde; Ñ] 

&#210; Ò (Capital O, grave accent) [&Ograve; Ò] 

&#211; Ó (Capital O, acute accent) [&Oacute; Ó] 

&#212; Ô (Capital O, circumflex accent) [&Ocirc; Ô] 

&#213; Õ (Capital O, tilde accent) [&Otilde; Õ] 

&#214; Ö (Capital O, dieresis or umlaut mark) [&Ouml; Ö] 

&#215; x (Multiply sign) [&times; &times]

&#216; Ø (Capital O, slash) [&Oslash; Ø] 

&#217; Ù (Capital U, grave accent) [&Ugrave; Ù] 

&#218; Ú (Capital U, acute accent) [&Uacute; Ú] 

&#219; Û (Capital U, circumflex accent) [&Ucirc; Û] 

&#220; Ü (Capital U, dieresis or umlaut mark) [&Uuml; Ü] 

&#221; (Capital Y, acute accent) [&Yacute; ]

&#222; (Capital THORN, Icelandic) [&THORN; \xde ] 

&#223; ß (Small sharp s, German, sz ligature) [&szlig; ß] 

&#224; à (Small a, grave accent) [&agrave; à] 

&#225; á (Small a, acute accent) [&aacute; á] 

&#226; â (Small a, circumflex accent) [&acirc; â] 

&#227; ã (Small a, tilde accent) [&atilde; ã] 

&#228; ä (Small a, dieresis or umlaut mark) [&auml; ä] 

&#229; å (Small a, ring) [&aring; å] 

&#230; æ (Small ae dipthong, ligature) [&aelig; æ] 

&#231; ç (Small c, cedilla) [&ccedil; ç] 

&#232; è (Small e, grave accent) [&egrave; è] 

&#233; é (Small e, acute accent) [&eacute; é] 

&#234; ê (Small e, circumflex accent) [&ecirc; ê] 

&#235; ë (Small e, dieresis or umlaut mark) [&euml; ë] 

&#236; ì (Small i, grave accent) [&igrave; ì] 

&#237; í (Small i, acute accent) [&iacute; í] 

&#238; î (Small i, circumflex accent) [&icirc; î] 

&#239; ï (Small i, dieresis or umlaut mark) [&iuml; ï] 

&#240; (Small eth, Icelandic) [&eth; ] 

&#241; ñ (Small n, tilde) [&ntilde; ñ] 

&#242; ò (Small o, grave accent) [&ograve; ò] 

&#243; ó (Small o, acute accent) [&oacute; ó] 

&#244; ô (Small o, circumflex accent) [&ocirc; ô] 

&#245; õ (Small o, tilde) [&otilde; õ] 

&#246; ö (Small o, dieresis or umlaut mark) [&ouml; ö] 

&#247; ÷ (Division sign) [&divide; &divide] 

&#248; ø (Small o, slash) [&oslash; ø] 

&#249; ù (Small u, grave accent) [&ugrave; ù] 

&#250; ú (Small u, acute accent) [&uacute; ú] 

&#251; û (Small u, circumflex accent) [&ucirc; û] 

&#252; ü (Small u, dieresis or umlaut mark) [&uuml; ü] 

&#253; (Small y, acute accent) [&yacute; ]

&#254; (Small thorn, Icelandic) [&thorn; \xdf ]

&#255; ÿ (Small y, dieresis or umlaut mark) [&yuml; ÿ] 



Shortcuts
General shortcuts
Text shortcuts
Libraries shortcuts
Images and image maps shortcuts
Links shortcuts

Claris Home Page includes many keyboard and mouse shortcuts you can use to do your work faster. See also
 for other shortcuts you can use. Remember that any shortcut that involves editing or

changing the contents of your Web pages won't work in Preview Page mode.
Using the toolbars

Some key combination shortcuts are also displayed in the Claris Home Page menus. To use a key 
combination, hold down the first key listed in the table and then press the next key or click the mouse as
indicated. For example, to close the active Claris Home Page window, press Command (Macintosh) or Ctrl 
(Windows) and simultaneously press W.

If you are using a PC with Windows, the Enter key referred to in these tables is the key in the main part of the 
keyboard unless otherwise noted as the key located on the numeric keypad. Also, to perform some of the 
shortcuts for Windows, you press the Alt key and then press several keys in succession rather than pressing 
them simultaneously. The keys you need to press for such shortcuts are separated by commas. For example, 
the shortcut to switch to Edit Page mode in Windows is Alt, W, E.



To do this Use this shortcut on a Macintosh Use this shortcut on a PC with Windows

Close window Command-W Ctrl-W 

Copy Command-C Ctrl-C 

Cut Command-X Ctrl-X 

Insert a horizontal rule 
Drag the Insert Horizontal Rule button from
the basic toolbar to the spot where you 
want to insert the rule 

Drag the Insert Horizontal Rule button 
from the basic toolbar to the spot where 
you want to insert the rule 

Insert a table 
Drag the Insert Table button from the basic
toolbar to the spot where you want to 
insert the table

Drag the Insert Table button from the 
basic toolbar to the spot where you want 
to insert the table

Move a window without bringing it to 
the front 

Command-click on the window's title bar 
and then drag it Not available 

Open Document Options Command-J Alt-J 

Open Document Statistics Command-K Alt, E, S 

Open new page Command-N Ctrl-N 

Open a file Command-O Ctrl-O 

Open the Link Editor Enter Enter (numeric keypad) 

Open the Menu Object Editor to 
change the attributes of a form's pop-
up menu or scrolling list 

Option-double-click the pop-up menu or
scrolling list 

Ctrl-double-click the pop-up menu or
scrolling list 

Paste Command-V Ctrl-V 

Paste to and paste from the Clipboard 
(trade places for whatever is selected 
with the contents of the Clipboard) 

Option-Command-V Ctrl-Shift-V 

Preview in browser Command-R Ctrl-R 

Print Command-P Ctrl-P 

Quit Command-Q Alt, F, X 

Save, Save As Command-S Ctrl-S 

Scroll up or down one line at a time Option-Page Up and Option-Page Down Ctrl-Page Up and Ctrl- Page Down 

Select All Command-A Ctrl-A 

Show/hide Object Editor Command-E Alt, W, O 

Show/hide Link Editor Command-L Alt, W, L 

Switch to Edit HTML Source mode Command-Shift-H Alt, W, S 

Switch to Edit Page mode Command-Shift-E Alt, W, E 

Switch to Preview Page mode Command-Shift-P Alt, W, P 

Undo Command-Z Ctrl-Z 

 

 

 
 

General shortcuts



To do this Use this shortcut on a Macintosh Use this shortcut on a PC with 
Windows

Move the insertion point to the next 
field in a dialog box or an Object Editor 
or to the next cell in a table 

Tab Tab 

Move the insertion point to the previous
field in a dialog box or an Object Editor 
or to the previous cell in a table 

Shift-Tab Shift-Tab 

Select a range of characters using the
keyboard 

Shift-Right Arrow key and Shift-Left Arrow
key 

Shift-Right Arrow key and Shift-Left 
Arrow key 

Select words using the keyboard Option-Right Arrow key and Option-Left 
Arrow key 

Ctrl-Right Arrow key and Ctrl-Left 
Arrow key

Delete the previous word using the 
keyboard Option-Delete Ctrl-Backspace 

Delete the following word using the 
keyboard Option-Forward Delete (del) Ctrl-Delete 

Copy text Option-drag the text to the spot where you
want to place the copy 

Ctrl-drag the text to the spot where you
want to place the copy 

Insert a non-breaking space Option-Space In Edit Page mode, Alt+0160 on the 
numeric keypad 

Insert a line break Option-Return Ctrl-Return 

Create a new list item Command-Return Ctrl-Enter (numeric keypad) or F8 

Create a new list item and indent it Command-Option- Return F9 

Create a new list item and indent it to 
the previous level of indentation 
(outdent) 

Command-Shift-Return F7 

Insert a horizontal rule 
Drag the Insert Horizontal Rule button from
the basic toolbar to the spot where you want 
to insert the rule 

Drag the Insert Horizontal Rule button 
from the basic toolbar to the spot 
where you want to insert the rule 

Insert a table 
Drag the Insert Table button from the basic
toolbar to the spot where you want to insert 
the table

Drag the Insert Table button from the 
basic toolbar to the spot where you 
want to insert the table

Find Next Command-G F3 

Find/Change Command-F Ctrl-F 

Reverse the direction of the Find/ 
Change and Find Next commands in the 
Edit menu 

Hold down the Shift key while choosing the
command 

Hold down the Shift key while 
choosing the command 

Libraries shortcuts

To do this Use this shortcut on a Macintosh Use this shortcut on a PC with Windows

Select multiple library entries in 
the top section of a library 
window 

Shift-click the entries Shift-click the entries 

Make a new library entry using 
selected text

Drag the text to the top section of the library 
window 

Drag the text to the top section of the library 
window 

Make a new library entry 
containing a link to a Claris 
Home Page file 

Drag the Insert Link to File button in the Claris 
Home Page file into the top section of the 
library window
Note The file you link to must be saved first 

Drag the Insert Link to File button in the
Claris Home Page file into the top section of 
the library window
Note The file you link to must be saved first 

Insert a library entry without 
opening the library document 

Command-Y and begin typing the first
characters of the entry name 

Alt, R, Y and begin typing the first characters 
of the entry name 

 

Text shortcuts 



To do this Use this shortcut on a Macintosh Use this shortcut on a PC with 
Windows

Return an image to its original width Double-click the bottom handle Double-click the bottom handle 

Return an image to its original height Double-click the right handle Double-click the right handle 

Return an image to its original width and
height 

Double-click the lower- right corner 
handle

Double-click the lower- right corner 
handle

Resize an image proportionately Shift-click on the lower- right corner
handle and drag 

Shift-click on the lower- right corner
handle and drag 

Replace a missing image with another 
(Claris Home Page displays a "missing 
image" message in its place)

Double-click the message to display an 
Open file dialog box and choose the new 
image file 

Double-click the message to display an 
Open file dialog box and choose the 
new image file 

Open an image in the Image Map Editor Option-double-click the image Ctrl-double-click the image 

Move a hotspot 1 pixel in the Image Map
Editor arrow key arrow key 

Move a hotspot 10 pixels in the Image 
Map Editor Option-arrow key Ctrl-arrow key 

Resize a hotspot 1 pixel in the Image Map
Editor Shift-arrow key Shift-arrow key 

Resize a hotspot 10 pixels in the Image 
Map Editor Shift-Option-arrow key Shift-Ctrl-arrow key 

Links shortcuts

To do this Use this shortcut on a Macintosh Use this shortcut on a PC with Windows

Open the Link 
Editor Enter Enter (numeric keypad) 

Test a link in Edit 
Page mode Command-click the link Alt-click the link 

Insert an anchor 
Drag the Insert Anchor button from the basic toolbar 
to the spot where you want to insert the anchor
Note Claris Home Page names the anchor for you 

Drag the Insert Anchor button from the basic
toolbar to the spot where you want to insert the 
anchor
Note Claris Home Page names the anchor for you 

Insert a link to 
another Claris 
Home Page file 

Drag the Insert Link to File button from the basic 
toolbar to the spot in the other Claris Home Page
document where you want to insert the link
Note The file you link to must be saved first 

Drag the Insert Link to File button from the basic 
toolbar to the spot in the other Claris Home Page
document where you want to insert the link
Note The file you link to must be saved first 

Insert a link to an 
anchor 

Option-drag the anchor to the spot where you want to 
create the link 

Ctrl-drag the anchor to the spot where you want to 
create the link 

 

 
 

Images and image maps shortcuts



Troubleshooting
Problems installing or running Claris Home Page
Problems using Claris Home Page
Problems opening files not created in Claris Home Page
Problems with links
Problems viewing documents in a browser

This document is intended to serve as a troubleshooting guide for users of Claris Home Page. For more information 
about a specific feature, choose Topics from the Help or menu.

Problems installing or running Claris Home Page

An error message appears when I try to start Claris Home Page: "There is not enough memory to open 
Claris Home Page (XXX needed, XXX available)." (Macintosh only)

Your computer does not have enough memory to use Claris Home Page at the same time as the other 
applications you are running. If you have other applications running, try exiting from them (bring the 
other application to the front, and choose Quit from the File menu). See the documentation that came 
with your Macintosh computer for other ways to increase available memory.

An error message appears when I try to start Claris Home Page: "You need a Macintosh equipped with a 
PowerPC processor to run this application." (Macintosh only)

You have installed a copy of Claris Home Page that is optimized for the PowerPC processor chip. This 
copy will not work on older Macintosh computers that are not equipped with this chip. You must re-
install Claris Home Page from the original program disks.

Every time I start Claris Home Page, it opens one or more files without my telling it to.

Claris Home Page automatically opens any files in the Startup Items folder (Macintosh) or Startup 
folder (Windows) located in the same folder as the Claris Home Page application. To disable this, 
remove the unwanted files from the Startup Items or Startup folder.

Problems using Claris Home Page

Online Help doesn't work. (Choosing an item from the Help menu displays an error message.)

The Claris Home Page online Help uses a set of help files that are installed along with the application. 
These files should be located in a folder named Help, in the Claris Home Page folder. If the Help folder 
has been moved, renamed, or deleted, or if the application has been moved to a different location, then 
online Help will not work. Make sure the Help folder is named "Help" and that it and the application 
are both located in the Claris Home Page folder, or re-install the help files using your original Claris 
Home Page installation disks.

Images in JPEG format are drawn as gray rectangles in Claris Home Page, but appear fine in a browser. 
(On Windows, the same problem may sometimes occur for GIF images as well.)

Claris Home Page requires certain software to be installed in order to display JPEG files.

On the Macintosh, QuickTime version 2.0 or greater must be installed in the Extensions folder.

On Windows, the Accusoft imaging DLL (Accuisr5.dll) must be installed in the same directory as 
Claris Home Page. To install the Accusoft imaging DLL, re-install Claris Home Page from the original
program disks.



An image appears stretched or squished.

You may have accidentally resized the image, or have changed the size of the image in a drawing 
program. Click once on the image in Claris Home Page to select it, and then reset it to its natural size 
by either double-clicking on the resize handle in the lower-right corner of the image, or opening the 
Object Editor and clicking the Reset Size button.

An image has the wrong background color.

HTML documents generally have a gray background color. (You can select a different background 
color using the Document Options command.) Image files may have a different background color, such 
as white. To make the document background color show up in your image, you need to make the 
image's background transparent. To do this, open the image file in Claris Home Page (by choosing 
Open from the File menu, or by double-clicking on the image in an HTML file and clicking the Image 
Map button in the Object Editor), select the Transparency Tool and click on the background part of 
the image (it should turn gray), and choose Save from the File menu.

This procedure will only work for images in GIF format. JPEG images cannot use transparency. To 
change the background color of a JPEG image, you must use an image editing program such as Adobe
Photoshop.

In the place where one of my images should appear, Claris Home Page draws a red box and the words 
"Missing image" appear. (The words "Missing image" may not appear for small images.)

This happens when Claris Home Page can't locate an image file. The file may have been accidentally 
moved, renamed, or deleted, or your HTML file may have been moved without bringing the image file 
along. To correct the problem, locate the image file (or re-create it if it has been deleted), and then 
double-click on the red box. Claris Home Page displays a standard file selection dialog box. Select the 
image file and press OK. The red box should be replaced by the desired image.

In some cases, the red box and "Missing image" label may also appear if the image file is corrupt, or if 
there is not enough memory for Claris Home Page to display the image. If you suspect this may be the 
case, verify that the image file is not corrupt (for example, by opening it in another application), and try 
closing other documents or giving Claris Home Page more memory.

Problems opening files not created in Claris Home Page

This section describes problems that can occur when opening an HTML file that was not created in Claris Home 
Page. For example, the file may have been downloaded from the Internet, written using a text editor, or created in a 
different HTML editing application.

When I open an HTML document that was not created in Claris Home Page, it contains mysterious 
fragments of red text.

If a file contains incorrect HTML code, Claris Home Page displays the incorrect codes in red. This 
often occurs with files created in a text editor&emdash;browser applications are relatively tolerant of 
HTML errors, so you might not be aware of the error until you open the file in Claris Home Page. To 
correct the problem, simply delete the red text.

This problem can also occur for files that make use of HTML extensions not supported by Claris 
Home Page, such as blinking text. If you open a file that contains blinking text in Claris Home Page,
the tags <BLINK> and </BLINK> appear on either side of the blinking text. If you delete the BLINK 
tags, the text will no longer blink when it appears in a browser.

In general, when Claris Home Page displays red HTML code in your document, you must use your 
own judgment to determine whether this is due to errors in the HTML file (which should be deleted), 
or to the use of HTML extensions (which should not be deleted). If you are unsure, try making a copy 
of the file, removing the questionable code, and viewing the resulting file in a browser application. If
removing the questionable code does not change the document's appearance in a browser, then you 
can safely delete it.

When I open an HTML document that was not created in Claris Home Page, tables aren't laid out correctly 



(rows and columns aren't the right size, or captions don't appear).

Claris Home Page 1.0 does not fully support all of the HTML options for controlling table layout. The 
options for controlling cell width and height and for creating captions are not supported, and column 
widths do not adjust to accommodate the amount of text in each cell. This will not affect the 
appearance of the table in a browser; it only affects the appearance within Claris Home Page itself. To 
get a better feel for how a table will appear in a browser, use the Preview in Browser command.

When I double-click on an HTML file on the Windows desktop, Claris Home Page isn't opened, the 
browser is.

On Windows, only one application is allowed to be the default viewer for a given file extension. In this 
case, the browser is the default viewer for HTML files, so it is opened when you click on an HTML 
file. To open an HTML file in Claris Home Page, drag the file itself (not a shortcut) to the Claris Home 
Page icon, or start Claris Home Page directly, and choose Open from the File menu. You can also 
change the association of the file type&emdash;see your Windows documentation for more details.

When I open an HTML document in Claris Home Page, text doesn't wrap around the pictures.

Claris Home Page 1.0 cannot display text wrapped around pictures. You can specify text wrapping by 
selecting the image and choosing Left or Right alignment in the Object Editor, but the text will not 
actually wrap around the image in Claris Home Page. This does not affect the appearance of the text in 
a browser; it only affects the appearance within Claris Home Page itself. To get a better feel for how the 
text will appear in a browser, use the Preview in Browser command.

When I open an HTML document in Claris Home Page, my background image does not appear.

Claris Home Page 1.0 does not display background images. You can specify a background image 
using the Document Options command, but the background image will not actually appear in Claris
Home Page. This does not affect the appearance of the document in a browser; it only affects the 
appearance within Claris Home Page itself. To get a better feel for how the document will appear in a
browser, use the Preview in Browser command. (If the background image does not appear in the 
browser, the image file may be corrupt or missing. Verify that the image file is intact, and then use the
Document Options command to re-select the background image.)

When I open an HTML document in Claris Home Page, some other feature does not display correctly 
(blinking text, Java applets, browser plug-ins, etc.).

HTML is a rapidly evolving standard, and is constantly being extended. Claris Home Page does not 
support every HTML extension that has been proposed. If your document uses an extension to HTML 
that is not supported by Claris Home Page, it may not appear correctly in Claris Home Page. This will 
usually be indicated by the appearance of the unknown HTML codes in red. This does not affect the
appearance of the document in a browser; it only affects the appearance within Claris Home Page itself. 
To get a better feel for how the document will appear in a browser, use the Preview in Browser
command.

Problems with links

When I click on a link, Claris Home Page displays the message "Sorry, Claris Home Page 1.0 can only 
follow links to local files."

All links in an HTML file contain a URL (Universal Resource Locator), that identifies the file or other 
object that the link points to. There are two types of URLs: , that point to a file on the local 
machine (or to a file on the same machine as the document containing the link), and , 
that point to a file on a machine somewhere on the Internet. Claris Home Page can only process local 
URLs. To test a link to an external URL, open your document in a browser.

local URLs
external URLs

 You can view the URL for a link by opening your document in Edit Page mode and double-
clicking the link to open the Link Editor. The URL appears in the URL text box in the Link Editor. 
External links begin with a sequence of letters followed by a colon, such as http:, ftp:, or mailto:. Local 
links do not have this prefix.

Tip



When I click on a link, Claris Home Page displays some other error message, such as "Sorry, unable to 
follow the URL "...", due to a disk error: no such file (error -43)."

This message appears when a link refers to a file that does not exist or that Claris Home Page can't 
find. The target file may have been accidentally moved or renamed, or may have been deleted. You 
should update the link's URL. This can be done as follows:

 Open the document containing the link.1.

Make sure you are in Edit Page mode (choose Edit Page from the Window menu).

Select the link.2. 
 Choose Link to File from the Insert menu, or click the Browse Files button in the Link Editor.3.
Select the target file for the link.4. 

 A common cause for this error is incorrect use of the "Use absolute pathnames" setting in the
HTML Output panel of the Preferences dialog box. This setting should normally be enabled. For more 
information, see .

Note

Using relative or absolute paths

When I click on a link that points to another part of the same file (i.e. to an anchor), nothing happens. Or, 
when I click on a link that points to an anchor in another file, Claris Home Page takes me to the beginning 
of the other file, instead of taking me to the location of the anchor.

The anchor has been accidentally renamed or deleted, or the link's URL has been entered incorrectly. 
To correct this problem:

 Verify that the target anchor still exists (open the target document in Edit Page mode, and 
look for the anchor symbol).
1.

If the anchor does not exist, choose Anchor from the Insert menu to re-create it.

 Select the target anchor, and choose Show Object Editor from the Window menu.2.

The Name text box in the Object Editor shows you the name of the anchor. If the name is 
incorrect, type the correct name in this box.

 Open the document containing the link in Edit Page mode.3.
Double-click the link to open the Link Editor.4. 
Inspect the value in the URL text box. (It should end in a pound sign, followed by the name 

of the anchor.) Enter the correct anchor name in this box.
5. 

 

My document contains an image that I have made into an image map (by creating rectangular or circular 
hotspot links). However, when I open the document in Preview Page mode and click on the image, the links 
don't work (nothing happens, or the image is simply selected).

When you make an image map, Claris Home Page creates an image map file associated with the 
image (GIF or JPEG) file. However, to activate the image map, you also need to make a change in the 
HTML document where the image appears. To do this:

 Open the HTML document in Edit Page mode.1.
Select the image.2. 
 Choose Show Object Editor from the Window menu.3.
 If the Object Editor is not fully expanded, click on the triangle symbol in the lower-left corner 

of the window to expand it.
4.

 Choose Behavior from the pop-up menu.5.

Problems viewing documents in a browser

This section discusses problems that can arise when attempting to preview a Claris Home Page document in a 



browser application.

When I choose the Preview in Browser command, the following message appears: "Sorry, not enough 
memory to open the browser application. Try quitting some other applications."

There is not enough memory to open the browser application at the same time as Claris Home Page.

On the Macintosh, try reducing the amount of memory allocated to the browser (by selecting the 
browser's icon in the Finder and choosing Get Info from the File menu), or follow the usual steps for
making more memory available: quitting other applications, turning off extensions, etc. Typically, you 
will need a Macintosh equipped with at least 12 megabytes of memory to run Claris Home Page and a
browser application at the same time.

On Windows, some browsers will restart each time a page is previewed and a new copy of the 
application is opened. To free memory, close the application windows not in use.

When I choose the Preview in Browser command, the browser opens, but the file is not displayed.

The browser may not be installed correctly. Some browsers (notably, the Microsoft Explorer on 
Windows) can be damaged by applications that change registry entries, causing the system to
incorrectly send "open file" messages to them. Re-install a fresh copy of the browser if you have this 
problem.

When I choose the Preview in Browser command, some other error message appears, such as "Sorry, an 
error occurred (-xx) while attempting to open the browser application", or "Sorry, an error occurred while 
attempting to send this file to the browser."

There may be a problem with the browser application you have selected as the default, or the browser 
application may be missing.

Choose Preferences from the Edit menu to open the Preferences dialog box. Choose Browser Preview 
from the pop-up menu or click the Browser Preview tab to display a new set of options. Click Set and
re-select the browser.

My page doesn't look quite the same in the browser as it does in Claris Home Page (different fonts, lines are 
broken at different positions, etc.).

The HTML standard does not precisely define the appearance of a document. It sets broad guidelines, 
but individual programs (such as browsers) are free to use their own variations. Therefore, it is 
impossible to create an HTML file that will look exactly the same in every browser.

Claris Home Page 1.0 attempts to display HTML documents as they will appear in Netscape 
Navigator 2.0 (based on Navigator's default preferences settings). Certain features (such as table 
layout) are implemented differently in Claris Home Page than in Navigator, and minor differences in 
spacing are inevitable. With other browsers, or if you have altered Navigator's font preferences, there 
will be greater differences. Finally, your document may use advanced features not supported by the 
browser, such as tables, frames, or colored text.

If you plan to publish your HTML document on the Internet, it may be viewed by many different 
browsers on many different platforms. Therefore, you should not attempt to, or expect to, precisely 
control the layout and appearance of your document. Even if your HTML document is to be used 
locally (on an "Intranet"), users may employ different browsers or have customized font preferences 
and other browser settings that will affect the appearance of the document.

When I view my page in a browser, a strange character sometimes appears on blank lines.

Claris Home Page inserts a non-breaking space character (represented by the HTML code &nbsp;) on 
what are otherwise blank lines. This is done to work around a flaw in certain browsers, such as 
Netscape Navigator, which ignores blank lines. Unfortunately, other browsers sometimes incorrectly 
interpret this HTML code as representing a different (non-blank) character: for example, Netscape 
Navigator 2.0 with "Japanese encoding autodetect" enabled sometimes does this.

My image maps don't work in the browser. When I view my document in Claris Home Page using Preview 



Page mode, clicking on an image takes me to the appropriate location, but clicking on the image in the 
browser has no effect.

Image maps require the support of a CGI script running on an HTTP (Web) server. When you open 
your local copy of a document in a browser application, there is no HTTP server, so image maps will
not work. (When you view your document in Claris Home Page Preview Page mode, Claris Home 
Page simulates the function of the CGI script.)

To try your image maps in a browser, you need to upload your document to an HTTP server and make 
sure that the appropriate CGI script is installed.

Links within my Web site work fine in Preview Page mode, but don't work when I click on them in a 
browser.

A variety of problems can cause links to function incorrectly (see ). One
additional problem that can occur outside of Claris Home Page involves the Base Document URL text 
box in the Document Options dialog box. Claris Home Page 1.0 assumes that this field (which
corresponds to the <BASE> tag in the HTML code), if not empty, contains the URL of the document 
in which it appears. If you enter a different URL in this text box, relative links may not work correctly. 
The solution is to remove the value in the Base Document URL text box, or set it to the URL of the 
page in question, and then use the Link Editor to re-create any malfunctioning links in that page.

Problems with Links

Images from the Claris Home Page Clip Art library work fine when I view my pages on my local computer, 
but don't work when I upload my site to a Web (HTTP) server.

When uploading your site to a Web server, you need to make sure to include all files used in the site, 
including image files. The standard way to do this is to create an Images folder inside the folder that 
contains your site, and to place all image files in this folder. When you transfer the site folder to a 
server, the images will automatically be included.

When you insert an image from a library into your document, Claris Home Page uses the path to the 
original image file in the Clip Art folder. To correct the problem, you need to copy the actual image file 
into your site's Images folder, and replace all references in your site to the original image file with the 
new file.
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