
MacPlasmap 
 
 
 

Version 1.82 
 
 

Program by Jingdong Liu 
 

©1988-1990 Jingdong Liu 
Biology Department 
University of Utah 

 
 
 

 
 
 
 
 
 
 
 

(EcoRI/PvuII) 1
HgiEII 181

NdeI 183

NarI 235
BglI 245
FspI 256
PvuI 276
PvuII 306

PvuII 628

AflIII 806

MmeI 996

MmeI 1180
AlwNI 1217

Eco57I 1333
HgiEII 1387

PpaI 1766
Cfr101 1779
GsuI 1784

BglI 1813
AvaII 1837

FspI 1919

AvaII 2059
PvuI 2066

ScaI 2177

XmnI 2294

SspI 2501
AatII 2617

EcoO109 2674

EcoRI
SacI
KpnI
SmaI
XmaI
BamHI
SalI
AccI
HincII
PstI
SphI
HindIII

lacZ

lacI

ORI

Ap
pUC19
2686 bp

 
 



 
 
 
 
 
 
 

Limited Warranty 
Although the author has reviewed this manual and tested this software, the author makes no 
warranty or representation, either express or implied, with respect to this manual and the 
software, their quality, accuracy, performance, merchantability, or fitness for a particular 
purpose.  This manual and the software are distributed "as is", and the user assumes the entire 
risk as to its quality and performance. 
 
In no event will the author be liable for direct, indirect, special, incidental, or consequential 
damages resulting from any defect in the software or manual, even if he has been advised of the 
possibility of such damages. 
 
Copyright, distribution, and the use of MacPlasmap 
MacPlasmap program and this manual are copyrighted by the author.  You may freely distribute 
them as long as it is not altered in any form and the copyright notice is preserved.  If you find 
this program worthwhile and use it routinely, you should register with US $25.  Registered users 
will be notified of future upgrades when they become available. 
 • Note: Earlier versions of this program were distributed by Kinko's as part of their 
Academic Courseware Exchange package.  Please treat this version as a free upgrade if you 
purchased MacPlasmap previously. 
 
 
Copyright © 1988-1990 Jingdong Liu 
Biology Department 
University of Utah 
Salt Lake City, UT 84112 
 
Apple, ImageWriter and LaserWriter are registered trademarks of Apple Computer, Inc. 
Macintosh, Finder, MultiFinder are trademarks of Apple Computer, Inc. 
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INTRODUCTION 
 
Welcome to MacPlasmap 
If your study or research involves preparation of circular plasmid maps, MacPlasmap may be the 
tool for you.  It draws, stores, and prints high-quality circular plasmid maps with the data you 
specify.  As a molecular biologist and a Macintosh user, you have probably tried to do this on a 
Macintosh computer, and you may have been aware of the following inherent difficulties: 
 

● Precise positioning of restriction sites and genes on a circle. 
● Attaching an arc (representing a gene) onto a circle. 
● Drawing maps of different sizes based on related, previous maps. 
● Converting one type of map to a different type. 

 
MacPlasmap is designed to overcome all of the above while still retaining other essential features 
of a drawing program.   As a stand-alone Macintosh application, MacPlasmap supports such 
common facilities as data entry, saving, retrieving, and printing.  If necessary, plasmid maps 
produced by MacPlasmap can be transferred to other advanced drawing programs for 
modifications.  Keeping plasmid data on disk or in printed form also makes it easy to organize 
plasmid construction information consistently.  Consequently, you can use MacPlasmap both as 
a plasmid data manager and a plasmid drawing aid. 
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About this manual 
This manual is intended to provide detailed information for the efficient use of MacPlasmap.  
The three major sections in the rest of this manual are organized as follows: 
 

Overview of MacPlasmap  introduces basic features and some useful concepts of the 
program.  It will be helpful if you at least scan it through. 

Drawing Plasmid Maps   can be used as a tutorial for drawing plasmid maps from start 
to finish.  You will find references for individual editing functions 
such as entry and editing of restriction sites, genes, polylinkers, 
etc. 

MacPlasmap References  lists all menu commands for quick reference.  
 
As a reminder, there is also a help screen under the File menu in MacPlasmap.  You can 
probably get enough information from there to start using the program. 
 
What you need to know 
To use MacPlasmap and this manual, it is assumed that you are already familiar with the 
essential concepts of circular plasmid maps and the Macintosh computer.  Experience with any 
typical Macintosh program should enable you to start using MacPlasmap easily.  If you are new 
to Macintosh, you may find it helpful to familiarize yourself with basic techniques of clicking, 
dragging, menu selection, etc. 
 
System Requirement 
The minimum configuration required to run MacPlasmap is a Macintosh 512K with system 
version 4.1 or newer.  The program is able to notify you about the use of older systems or 
potential memory shortages.  Printing for Apple ImageWriter, ImageWriter II, and LaserWriters 
is supported.  The program works well with Macintosh II and Multifinder. 
 
Acknowledgement 
I would like to thank Dr. Sandy Parkinson for his critical comments and suggestions on the 
programming and design of this program.  I am also grateful to many of my colleagues, 
particularly Tom Morrison and Jin Chen, who provided valuable feedbacks about earlier versions 
of this program.  This program is written in Think's Lightspeed Pascal version 2.0.
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OVERVIEW OF MacPlasmap 
 
This section provides an overview of plasmid map drawing in MacPlasmap.  It also introduces 
some useful concepts based on which MacPlasmap handles various plasmid data, and some 
general techniques of data entry and editing.   
 
 
The MacPlasmap desktop 
A plasmid map is always drawn in a window on the startup of MacPlasmap.  This can be a map 
from the document you double-clicked on, or a pUC19 map if the program was launched by 
double-clicking on the application icon.  From now on you can start drawing new maps, or 
modifying old ones.  Illustrated below is MacPlasmap's desktop which you will find it 
worthwhile to spend a moment to get familiar with. 
 
 

 
 
 
 
There are eight different icons on the left side of the window, and a plasmid map within the 
window.  Seven of the icons constitute different editing tools, and the adjustment tool is used to 
adjust the positions of text labels and the map circle in a plasmid map. 
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Three methods of data entry and editing 
You can enter and edit plasmid data by any of the following three methods, all of which invoke 
the use of various dialog boxes: 
 
1) Choosing commands from the Data menu. 
 
2) Clicking on tool icons.  Clicking on a tool icon on the left side of the active window will have 
the same effect as choosing the corresponding command from the Data menu. 
 
3) Clicking and dragging within the drawing window.  You will probably find this the easiest 
way of entering map data.  Clicking and/or dragging the mouse within the drawing window, but 
outside the plasmid map circle, will produce a flashing number indicating the position 
coordinate at that site of the map circle.  After releasing the mouse at the position of you interest, 
you can start one of three operations: adding a site, adding a polylinker, or inserting a fragment.  
This is done by a second click within the coordinate box and then, without releasing the mouse, 
choosing commands from a pop-up menu.  Likewise, clicking and dragging inside the map 
circle, and a subsequent click within a coordinate-containing box will invoke a pop-up menu that 
allows entry of a gene, or deletion of a fragment.  When an editing dialog box is activated by this 
method, the number coordinate(s) will be automatically filled in appropriate fields of dialog 
boxes. 
 
An example of popup menus for site and gene editing is shown below: 
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Map adjustment 
When MacPlasmap draws plasmid maps, it tries its best to properly position all the text labels. 
However you can re-position them if they do not appear satisfactory.  This is done by first 
selecting the adjustment tool (the hand icon) at the left side of the window and then clicking and 
dragging over the text you want to move.  The entire plasmid map can also be moved by clicking 
and dragging inside the map circle (see diagram below).  During this process the cursor appears 
as hand-shaped.  You cannot enter plasmid data by the clicking and dragging method in this 
mode. 
 
 

 
 

 Adjust site  Adjust plasmid circle 

 
Double-clicking anywhere in the window will return to the data entry and editing mode.  The 
two modes can also be easily switched by pressing the Space key. 
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Text display 
MacPlasmap provides limited control over display and printing of text items in plasmid maps.  
Text font and size can be chosen from two hierarchical menus under the Edit menu (see figure 
below).  Current font and size are check-marked in the menus.  In MacPlasmap version 1.8, each 
map can have only one text font and size.   
 

Note  1) The font list shown in the figure is only a sample.  Your choice of fonts 
depends on the number of fonts available in your system software. 
2) The default text setting is Geneva 9 points which gives clear display on the 
screen and ImageWriter printers.  On LaserWriter printers, Times and Helvetica 
fonts usually give better results. 

 
 

 
          Text font               Text size 
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Plasmid map data used by MacPlasmap 
In MacPlasmap, the following groups of data can be specified and used to control the drawing of 
a plasmid map: 
 
  
 Data Type Information Required 
Restriction sites Site name, location, and show (or hide) site position. 

Genes Gene name, start, end, orientation, shading pattern, arrow type, and segment thickness 

Polylinkers Location and sites. Endpoint optional. 

Map parameters Map circle size, thickness, map types and display unit (kb or bp) 

Plasmid info Plasmid name, size, construction data and the author, and references/comments 

 
 
The reference point 
MacPlasmap draws plasmid maps by using a '0' point, located at the top of the circle, as the 
location reference (see figure below).  Any numerical data input (for site and gene locations, for 
example) should use this site as the reference point.  The number increases clockwise and 
decreases counterclockwise. 
 

    

The 'O' point 
 +

 
 
 
Numbering system 
The basic unit for numbers related to plasmid properties can either be kilobase (kb) or basepair 
(bp).  The kb values are automatically expressed to two decimal points.  Map parameters such as 
circle size and thickness are expressed in screen dots (or pixels) and they must be integer values. 
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DRAWING PLASMID MAPS 
This section describes typical ways of drawing plasmid maps with MacPlasmap.  All the editing 
functions are explained in some detail.  Saving and retrieving plasmid files and printing plasmid 
maps are also described in this section. 
 
Starting 
You can draw a new plasmid map either from scratch or from an existing plasmid map through 
stepwise modifications.  
 
1)From scratch.  Choose New... from the File menu.  This will bring up a dialog box asking for 
some initial information that MacPlasmap needs to draw a new plasmid map.  Fill in the 
necessary data, or use the default settings, which are shown in the dialog box below: 
 

 
 
Some important points about this dialog box are discussed below: 
 
● The size and width of the map circle are expressed in screen dots (pixels).  They must 
be integer values.  (The screen of Macintosh plus and SE is 512✕342 dots, and that of 
Macintosh II is 640✕480 dots.) 
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● MacPlasmap can draw two types of map shown in the Map type field.  In the second 
type (single circle), the circle width attribute is used to represent the default thickness of 
gene segments. 
 
● The state of the Show site position as default check box determines the default value 
of Show site position in the Site editing dialog box (see page 10).  These two check 
boxes have the same value when a new site is initially created, but the Show site position 
box can be subsquently changed for each individual site as desired, without affecting the 
state of Show site position as default.  If Show site position is on, then the site position 
for that site will be drawn on the map, otherwise only the site name will be drawn.        

 
Note  If you have used earlier versions of MacPlasmap, you will notice that Show 
site position as default is a replacement of Number site position, and these two 
buttons work differently. 

 
● Linear map drawing is not supported in the current version of MacPlasmap. 
 

2) From an existing plasmid map.  Choose Open... from the File menu to open a plasmid data 
file, and change the plasmid parameters to those desired for the new plasmid.  
 

Caution  To prevent overwriting the old plasmid by modified data, it is 
recommended that you always change the plasmid name first (through the map 
parameter editing dialog box, page 16).  MacPlasmap recognizes the new name as 
a new plasmid, and presents the Save As... dialog box when you choose Save (or 
Command-S).  Alternatively, you can use Save As... to change the document 
name of the modified plasmid map. 

 
 In either of the above cases, further editing is done through the use of seven dialog boxes 
permitting the editing of restriction sites, genes, polylinkers, insertion and deletion of fragments, 
references and comments, and overall appearance of the map. 
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Site editing 
Restriction enzyme recognition sites (or any other sites of particular importance) may be edited 
with the site editing dialog box shown below.  To activate this dialog box, one of the following 
three methods may be used (also described in the last section, OVERVIEW OF MacPlasmap): 
 

1) Click outside the plasmid circle, drag to the desired location (indicated by a flashing 
number), then release the mouse and click in the flashing box.  Select the Add Site... item 
when a popup menu appears. 
 
2) Click in the site editing icon on the left side of the window. 
 
3) Choose Sites... from Data menu. 
 
 

 
 
 

All site editing is done within the site dialog box.  Enter site name (default New) and location 
(automatically displayed if the flashing box was on prior to activating the dialog box), then click 
the Save site button (or use Command-S), or the OK button.  A bold line appears below the Save 
site button when the location number is valid, otherwise the number will not be recorded. 
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Clicking the New site button restores the default site name and location, in preparation for 
entry of new sites. 

 
To remove a site from the map, you need to first select the site from the site list (by clicking 

on it), and then click the Remove site button.  
 
Warning  Removed sites cannot be recovered by clicking the Cancel button. 
 
Selecting a site from the site list also displays its current attributes in appropriate fields 

(name, location and show/hide site position).  You can make changes and save them by clicking 
the Save site button.  The old site will be replaced by the changed one.  If you prefer to draw the 
position along with the site, you should check-on the Show site position box. 

 
When editing is finished, clicking the OK button will cause re-drawing of the plasmid map 

on screen, with the new data incorporated.  
 
Note that removal of sites (or genes) from the plasmid does not change the size of the 

plasmid. It only removes them from the site (or gene) list.  To actually delete a DNA fragment 
from the plasmid, use the deletion editing described later in this section (page 15, Deletion and 
Insertion). 

 
Sometimes sites can overlap when many are clustered in one region of the circle.  You can 

remedy such problems either by using polylinkers or by shifting their positions with the 
adjustment tool (the hand-shaped cursor).  

 
Note  1) The maximum number of sites in a plasmid map is limited to 60. 
2) You can press the TAB key to quickly move the cursor from one text editing 
field to another.  When combined with the Command-S keys for save, this general 
technique allows fast data input within dialog boxes. 
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Gene editing  
Genes (or other contiguous segments of interest) can be edited in a way similar to site editing.  
The three buttons, New gene, Save gene, and Remove gene, work exactly the same way as the 
corresponding buttons in the site editing dialog box.  Other attributes specific to genes are 
described below and illustrated in the following diagram: 
 
 
 

Click in the Shape  box to 
select gene shapes

Click in the Shading  box to 
select shading patterns
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Any of the following attributes can be specified to either a newly added gene or a pre-existing 
one after it is selected from the gene list. 
 

Shape.  Four different types of arc are available for drawing genes.  They are listed under 
a pop-up menu which can be activated by clicking on the box displaying the current 
shape. 
 
Shading.  Shading patterns are chosen from 38 standard patterns on a popup menu, 
which can be activated by clicking the small shading box. 
 
Thickness.  The thickness of a gene segment can be changed by clicking and dragging 
the small circle located at the top-right corner of the thickness rectangle. 
 
Orientation.  If the Show orientation (from start to end) item is checked, an 
appropriate arrow will be drawn with the gene to indicate the orientation of the current 
gene.  The type of arrow is determined by the gene shape attribute. The arrow is always 
drawn from the start to the end point of the gene. 

 
Note   There are two limitations of gene editing in the current version of 
MacPlasmap: 1) Genes are not allowed to go across the 'O' point.  2) The 
maximum number of genes in a plasmid map is 30. 
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Polylinker editing  
Polylinkers should be used to group restriction sites that are too crowded to be drawn separately.  
Use the same techniques as for editing sites and genes to activate the polylinker editing dialog 
box, and then enter the data as given in the example shown in the dialog box.  The polylinker 
format, which requires that the start position and the sites of a polylinker be separated by a slash 
(/),  must be matched for successful data entry.  An optional endpoint can be applied to specify a 
segment on the plasmid circle upon which the polylinker is attached (provided that the Connect 
to circle box is checked on).  Without this value, the polylinker is drawn as a single site on the 
circle. 
 
By convention, sites in a polylinker are ordered clockwise, and the polylinker location is the 
position of the first site in the linker. 
 
You can control the appearance of a polylinker with four parameters in the dialog box.  
Polylinker on the screen can be moved by using the adjustment tool as for any other text items. 
 
An example of polylinker data is shown below: 
 
 

 
 

 
Note  A maximum of four polylinkers is allowed for each map. 
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Deletion and insertion of fragments 
MacPlasmap allows the deletion and insertion of fragments on plasmid maps.  These are often 
necessary for drawing new maps from pre-existing ones.  These two functions are performed 
through the use of other two dialog boxes, which can be invoked by any of the three methods 
already described for other editing operations.  Note that the option Show truncated genes is 
currently not supported.  Therefore insertions into a gene, or deletions ending or starting within a 
gene will remove that gene from the gene list.  Sites and polylinkers affected by this operation 
will also be removed.  By definition, a site is affected if it is included in the deleted fragment, 
and a gene is affected (inactivated) when one of the following is true. 
 

● The site of insertion is inside the gene. 
● At least one of the deletion endpoints is inside the gene.  
● The deletion completely covers the gene. 

 
Note  Deletion or insertion of fragments changes the size (in kb or bp) of the 
plasmid.  This will cause necessary re-drawing and re-adjustment of text items 
associated with the map circle.  If the changes are small and you prefer to keep 
the original text positions, you can check the Keep text adjustment box (see 
below).  This check box is turned on by default to prevent accidental loss of 
adjustment.  If the changes are significant and the original text adjustments no 
longer apply, you can choose the Calculate text positions command from the 
Edit menu to re-calculate test positions and then re-adjust them by using the 
adjustment tool. 
 

  
 

These procedures are also recommended when you change the plasmid size from 
the Overall parameter editing dialog box (page 16, next section). 
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Map parameter editing  
MacPlasmap uses a number of map parameters to control the overall appearance of a plasmid 
map.  Through the use of the map parameter dialog box (which is essentially the same as the 
New... dialog box, page 7), the following aspects of a plasmid map can be changed: 
 

1) Plasmid name.  It is often necessary to change the name of a plasmid when it is 
derived from modifying a previous map.  Changing the plasmid name will also have the 
following two effects: a)The title of the window containing the map will be changed to 
the plasmid name, b)The corresponding item under the Windows menu will show the 
new name. 
 

Note  Since changing the name of the current plasmid signifies the creation of 
a new plasmid, this change is recommended as the first step of producing a 
new map from an old one. 

 
2) Plasmid size.  This should not be changed unless absolutely necessary.  Modifications 
like insertion and deletion of fragments automatically updates this attribute. 
 
3) Map circle diameter and thickness.  Change these to control the size and the thickness 
of the map circle.  
 
4) Plasmid type.  Switch between two types of maps. 
 
5) Site positions.  The Show site position as default check box works the same as in the 
New... dialog box described in page 8.  This item does not directly affect the drawing of 
sites, but merely changes the default value of the Show site position check box in the 
Site editing dialog box. 
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Reference/Comment Editing 
Information about the plasmid can be entered with this dialog box (shown below).  Note that the 
maximum length of a reference is 255 characters. References longer than that will be truncated.  
The Show info on page box is checked by default which allows the plasmid information to be 
included as part of the map.  Un-check this box if you don't want this to occur.  The text can also 
be repositioned by using the adjustment tool. 
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Saving and retrieving map data 
You can save the maps you created in two different types of files: MacPlasmap data file and 
picture (PICT) file.  Use the Save or Save As... command from the File menu to save a data file.  
Only data files can be retrieved by MacPlasmap.  Maps saved as PICT files by using the Save As 
PICT File... command will not be recognized by MacPlasmap, but can be opened by most 
commercial Macintosh drawing programs, thereby providing a way of communicating with other 
programs.  The same kind of transfer can be done by copying the map from MacPlasmap (using 
Copy Map to Clipboard from the Edit menu), and pasting it into other programs.  
 

Caution  MacPlasmap is capable of drawing very fine hairlines on LaserWriters, a 
function that some drawing programs do not seem to have.  Printing plasmid maps with 
other drawing programs may produce thicker lines than if the maps are printed directly by 
MacPlasmap. 

 
 Plasmid data files can be retrieved by simply choosing the Open... command from the 
File menu.  An opened plasmid map will be displayed in a new window.  As many as 15 maps 
can be displayed concurrently within the program. 
 
 
Printing Plasmid Maps 
 
Plasmid maps can be printed on either Apple LaserWriters or ImageWriters, by choosing the 
Print... command from the File menu.  
 

Caution  When using ImageWriters, be sure to select Page Set Up... first, and 
choose 'Tall Adjusted' as Special effect.  If this is not done, plasmid maps will 
not print as true circles.  
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MacPlasmap REFERENCE 
 
This section briefly summaries the MacPlasmap menu commands, many of them have been 
detailed or mentioned in previous sections.  
 
Apple Menu 
 About MacPlasmap...  Shows the version number and memory available for the program. 
 
File Menu 
 Help/H...  Shows an on-line help screen explaining some basic operations of MacPlasmap. 
 
 New/N...  Opens a new window for a new plasmid. 
 
 Open/O...  Opens plasmid data files from disk.  Data files must be created by MacPlasmap 

using the Save or Save As... command.  
 
 Close/W.  Closes the front-most window on the screen.  If the current plasmid data have not 

been saved, a warning dialog is given before closing is allowed. 
 
 Save/S.  Saves data file using the same name as when the file was last saved.  The old file 

with the same name is overwritten. 
 
 Save As...  Saves the data file with a new name.  The standard file dialog box is presented. 
 
 Save As PICT File.../G.  Saves data to a PICT file with a new name.  PICT files can not be 

read and modified by MacPlasmap, but can be opened by most commercial drawing 
programs. 

 
 Page Setup...  Sets up printing pages.  It is important to do this every time when changing 

printers.  
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Caution  Be sure to check the 'Tall Adjusted' option in the Special 
Effects section of the dialog box when using an ImageWriter or 
ImageWriterII.  This will ensure that maps print as true circles. 

 
 Print/P.  Prints plasmid maps on either ImageWriters or LaserWriters. 
 
 Transfer/T.  Transfers to any other application directly from MacPlasmap without returning 

to the desktop. 
 
 Quit/Q.  Quits MacPlasmap. 
 
Edit Menu.  
 Undo/Z.  Not supported in MacPlasmap.  For use by desk accessories. 
 
 Cut/X.  For use by desk accessories. 
 
 Copy/C.  For use by desk accessories.  
 
 Paste/V.  For use by desk accessories. 
 
 Clear.  For use by desk accessories. 
 

Copy Map to Clipboard/M.  Copies the current plasmid map to the clipboard as a picture 
which can then be pasted into other drawing programs or into the scrapbook.  

 
Text font.  Displays a list of fonts available on your system.  You can choose one of them as 

the text font in a plasmid map.  Currently used font in the map is check-marked. 
 
Text size.  Displays a list of font sizes you can use to specify the text size in a plasmid map.  

As with Text font, currently used size is indicated by a check-mark. 
 
Calculate text positions/A.  Re-calculates the positions of site names on the screen.  All 

previous adjustments will be discarded.  This command is commonly used when the 
plasmid size is changed (by deletion or insertion of a fragment, for example)  .  
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Data Menu.  
This menu contains seven items corresponding to the seven editing functions of 
MacPlasmap.  Selection of any item will bring up a dialog box for data entry.  Choosing 
items from this menu is only one of the three ways to enter map data.  It gives you the option 
of using keyboard commands (æ-1 to æ-7) instead of clicking and dragging with the mouse. 

 
Windows Menu. 

The Windows menu provides a means for organizing multiple windows on the screen.  All 
window titles, which are the same as document names, are listed under the Windows menu.  
Choosing one item from the list brings the corresponding window to the front.  This is an 
easy way to activate a particular window when many windows are open.  The item 
corresponding to the frontmost window is always check-marked. 
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COMMENTS AND SUGGESTIONS 
 

Your comments are vital to the improvement of MacPlasmap.  Please send your suggestions 
and/or bug reports to 
 

Jingdong Liu 
Biology Department 
University of Utah 
Salt Lake City, UT 84112 

 
 
Phone: (801) 581-6307 
E-mail: Jliu@bioscience.utah.edu 

USA 
 

Your comments may include (but not limited to): overall usefulness of MacPlasmap, program 
bugs and their descriptions, features you like and dislike, functions you want to be added, etc. 
 
Program version: 
 
Comments: 
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 Name:_________________________ Address:______________________________ 

 City:__________________________ State:_________________________________ 

 Contry:________________________ Phone #:______________________________ 
 
 


