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Chapter 1:  Planning your Web site

Welcome to the Claris Home Page application from Claris Corporatio
Claris Home Page is a powerful Web authoring tool you can use to
create Web pages quickly and easily. This guide explains how to us
Claris Home Page to author your Web pages for publishing on the W
Wide Web.

Note You can visit the Claris Web site for the latest information on 
Claris Home Page, at http://www.claris.com/.

Hypertext Markup Language (HTML) is a language used to display
documents on the World Wide Web so they can be viewed from an
platform (such as UNIX, Windows, and Macintosh). You don’t need
know HTML in order to author Web pages because Claris Home Pa
provides the HTML tags for you. On the other hand, Claris Home Pa
provides you a way to work directly in the HTML source and add yo
own HTML tags if you want.

Spend some time planning your Web site so that the organization and v
presentation of your Web pages communicate your intent effectively. W
you are ready to build your site, you can use the Claris Home Page Si
Editor to view and edit your site’s organization. In the Site Editor, you c
also perform other tasks, such as creating pages, checking the downlo
time of your site, and uploading your files to the Web.

Designing the structure of your Web site
Designing your Web site begins with planning the purpose of the site
what the content will be, and how you want to structure it. A well-
designed Web site can make it easy for your audience to navigate an
the information you want them to receive. It can also make it easier for
to manage and update later on. 
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Planning the purpose and content of the site
Perhaps the most important consideration is figuring out how your s
will serve your intended audience. Your site may provide entertainm
or a special service, such as access to reference materials, advertisi
sales of goods and services. Your site could include a questionnaire
solicits information from your viewers. Knowing what information you
viewers want and how often you should update that information will
help you maintain your site so that it’s fresh and useful. The more y
know about your audience, the better you can serve them with your 

Outlining the structure of the site
When you plan your site, you may want to experiment with several 
designs for organizing information, and consider multiple ways peo
can navigate to the individual pages in your site. Most people will 
experience your site one page at a time with the home page as the
starting page. The home page will often have some sort of table of 
contents that describes what’s on the site. Sketching an outline or f
chart of your site can illustrate the home page and how it will link to t
other pages in the site. You can resolve any design issues and chan
overall structure of the site before you create the actual pages and 
in Claris Home Page.
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It’s always possible that someone may arrive at another page in your
first. For example, someone using a search engine such as Yahoo o
Vista may search for a keyword that appears somewhere within you
site, but not on the home page. For this reason, it’s a good idea to inc
a link on all of the pages in your site that goes back to the home pa

Deciding what to include in your Web pages
Claris Home Page provides several ways to display information in y
Web pages. The options you use depend on the type of information
want to include. 

Deciding what to include in your Web page can also depend on wh
your audience is and which browsers they’ll be using. Older browse
that don’t support the current version of HTML won’t necessarily 
support all of the latest options, such as tables, frames, text fonts a
color, or plug-ins for databases, movies, sound, and applets.

Using common elements to create a theme
Repeating common elements in your site can be effective for tying 
information together and communicating the main message of your 
Using company logos, slogans, mottos, and special graphics are go
examples of this. You can also take this a step further and use art fo
background of your pages, special images for buttons, and color 
schemes for text and images. More subtle effects for creating a unify
theme across your Web pages include naming your links consisten
having special placement of text and images, and using bold and ita
in your pages.

You can create your own Claris Home Page libraries to save these sp
design effects and common elements and then use them for each new
you create. In addition, you can save any page you create as an HTM
template, and use this template to create more pages for your site.
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Including text and images in your pages
Text and images are the basic visual elements you see in most Web
and are supported by all versions of HTML. Claris Home Page provi
ways to use text and images to build a Web site easily. In Claris Ho
Page, you can type text as you would in a word processor, and the
appropriate HTML is inserted for you. If you want to include some 
special characters, such as the copyright symbol, in your site, you c
use Claris Home Page to format the symbols as HTML so that they
appear in all browsers. You can also bring text you created in anoth
application into a Web page and easily apply HTML formatting style
to it.

When you use images other than JPEG or GIF, Claris Home Page 
converts them, if possible, to GIF format, one of the standard image
formats recognized by Web browsers. Claris Home Page includes 
libraries of GIF images you can use in your pages. You may decide
use images instead of text for your links in a table of contents or 
navigational list, so that you associate information graphically to oth
pages in your site. When selecting images for your site, keep in min
that larger, complex images that incorporate many colors and textu
can significantly add to the download time of a page. 

You can easily get an estimate for download time of your pages us
the Document Statistics feature. (See “Using the Statistics window”
page 2-14 for more information.) Word counts for your pages are a
available through this feature.

Tip If you use black and white or one-color images on your pages, t
download faster.

Using tables or frames for page layout
In addition to using tables for organizing information into rows and 
columns, you can hide the borders and use tables to design the pa
layout. You can simulate tabs and margins in HTML by placing text a
images in table cells that are uniformly spaced apart. You can then
this table for all pages in your site. (See “Saving a page as a templa
on page 2-25.)
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A frame page is another useful way for controlling how information 
displayed in your site. You can use frames to display simultaneous
views of your Web pages, so that your viewers can navigate throug
your site in the same window. The disadvantage in using frames, 
however, is that not all browsers support frames—if you decide to u
frames, consider setting up alternate pages for those browsers that 
support them. 

Horizontal rules also offer alternative ways of controlling the layout 
your Web page. Horizontal rules are objects you can use to divide y
pages into sections. You can align them to the right, left and center
the page and change their length, width, and shading. 

Including forms or a database on your site
Claris Home Page supports making your Web site interactive throu
the use of forms in your pages. You can use forms to solicit informat
from your viewers, whether you are prompting them to sign a guest
book, to fill out a questionnaire, or to search your database of good
they can place an order.

To use forms, you will need a Common Gateway Interface (CGI) sc
to process data back and forth between your viewer’s browser and 
Web server where your site is published. For more information, see
chapter 9, “Adding forms to your Web page.” 

Claris Home Page also lets you link to a FileMaker Pro 4.0 databas
your page, so that you can use the integrated Web server capabiliti
FileMaker Pro, instead of a CGI script, to process form data. Use th
FileMaker Connection Assistant and FileMaker form libraries to crea
form pages that readily connect to the database. 

Including movies, sound, or animation
You can use Claris Home Page to set up pages that feature movies
sound, and animation for your Web audience. A browser plug-in 
application is required for these files to display on your Web pages.
Plug-ins are small add-on applications for viewing various types of 
information like multimedia and data processing. If you decide to 
include any elements that require a plug-in to work, your site should
provide a link to the plug-in itself, so your viewers can download it. A
a courtesy to your viewers, it’s also a good idea to provide brief 
instructions for putting the plug-in in their browser’s preferences fold
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Including applets (small applications)
Applets, such as those written in the Java programming language, 
provide added functionality and multimedia effects to your Web pag
Java applets can be used to create special effects, such as clocks,
calculators, and other interactive elements. Other types of applets a
the process of being developed in other programming languages (s
as ActiveX). You can use Claris Home Page to add a Java applet to 
Web page and to customize its parameters. 

Including your own additional HTML
If you’re knowledgeable about HTML, you can modify the source of yo
Web page using Edit HTML Source mode. This mode shows you the 
underlying HTML enable/disable tags that describe the structure and 
function of the page contents. You can also use the object editors to add
own HTML code to each page element as you work in Edit Page mod
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Tip Because you can view the HTML source for any page on the Wo
Wide Web, looking at the source of pages you like is a great way to
design ideas and learn more about HTML.

Setting up the site
Before you begin creating the Web pages for your site, use Claris Ho
Page to set up a folder for storing the files in a single location. Defin
the site in Claris Home Page allows you to view all the site files you
create in the Site Editor. You can use the Site Editor to open the file
add new Web pages to the site, and apply document options to one
more pages in the site. Use the Site Editor to create a mirror of your
as it will be published on the Web and then use it to verify the links a
upload the files to the server when you’re ready.

Your Internet service provider or Web server administrator may requ
that your site have a home page. The home page, usually named 
“index.htm,” is the point of entry for your site and is the first page link
to the domain name in the URL for your site. 

Tip You can create multiple sites within one main site folder by nami
all the home pages in their respective site folders the same file nam
(such as index.htm).
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It’s also a good idea to set up an images folder when you set up you
to contain all of the images that you insert into your Web pages. You
set this folder to be the default folder for storing images Claris Hom
Page automatically converts to GIF format. 

To set up a site:

1 Create a site folder to contain your pages and associated site file

1 Define the site in Claris Home Page to use the Site Editor as you w

1 Create a media or images folder within the site folder to store all 
JPEG, GIF , and media files referenced by your Web pages

1 Set the default media folder so Claris Home Page will automatica
store all files it converts to GIF in the specified folder

1 Use the Site Editor to keep track of the site contents

Defining a new site
Defining a site in Claris Home Page allows you to view the organizat
of all the site’s files in the Site Editor. You can define your site in Cla
Home Page based on the contents of a folder. When you define a s
Claris Home Page creates a site definition file that stores the site 
information in the site folder and opens the Site Editor.

To define a site using a new empty folder:

1. Start Claris Home Page.

For more information, see “Starting Claris Home Page” on page 

2. Choose New from the File menu.

3. In the New dialog box, click Create New, select Empty Site from the 
scrolling list, and click OK. 

4. In the Save As dialog box, navigate to the location where you wan
store the site.

5. Type the name for the site folder in the File Name text box (Windows) 
or the Save Site Folder As text box (Macintosh).

6. Click Save.

The Site Editor opens and displays the new site folder and its 
contents.
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To define a site using an existing folder:

1. Start Claris Home Page.

2. Choose Open Folder as Site from the File menu.

The Browse for Folder dialog box (Windows) or the Select a Fold
dialog box (Macintosh) appears.

3. In the dialog box, navigate to the folder you want to define as the 
folder and click OK (Windows) or Select Folder Name (Macintosh).

The Site Editor opens and displays the contents of the site folder 
specified.

Note Claris Home Page creates a site definition file, which defines t
site based on the contents of the site folder and stores FTP login set
that you need to upload your site. The site definition file has the 
extension .wst and resides in the site folder. For more information s
“Specifying the Web server account” on page 12-8.

As you develop your Web site, you can use the Site Editor to view t
contents, open files, or create new pages in the site. You can also m
document changes to any of the pages, such as changing the backg
color. When your Web site is complete and ready for publishing, yo
can use the Site Editor to upload all your files to the Web in one ste
See “Using the Site Editor” on page 2-27 for more information.

Setting up the media folder
A media folder is useful to have inside your site folder for containing 
the images, movies, and other media files for your site. You can cre
this media folder on your computer, or have Claris Home Page crea
one for you and then use it for consolidating media into one location

To create a media folder using Claris Home Page:

1. Open the Site Editor by choosing Open Folder As Site from the File menu 
and selecting the site folder where you want to store the images fo

2. In the Site Editor, click the Consolidate button  on the toolbar.

If you have open or unsaved files, a message appears prompting
to save the unsaved files. Click OK to continue.

The Consolidate dialog box appears.

3. In the Consolidation dialog box, type the name of the media folde
the Media folder name text box.

Claris Home Page creates a folder and places it inside the site fo
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4. Click Consolidate.

For more information about consolidating images, see “Consolidatin
media files” on page 12-4.

To set the media folder to store all images that Claris Home Page 
converts to GIF format:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh). 

2. Click the Images tab in the dialog box.

3. Click Convert and save automatically to directory.

4. Click Browse to choose your media folder. 

For more information, see “Specifying the default converted imag
folder” on page 4-3.

Previewing and testing your site
There are many factors that affect the final presentation of your site
the Web, many of which are beyond the Web designer’s control. Fo
example, your audience might be using all kinds of different compu
systems with or without a capacity for displaying graphics. Your 
audience may also have different types of connections to the Web,
different modem speeds, and different preferences settings in their W
browsers. While you may not be able to control these factors, you c
preview the design of your pages in different Web browsers and prov
alternative ways for viewing your site.

Claris Home Page provides two ways to preview a page as you’re 
designing it. You can use Preview Page mode to display your page
Claris Home Page as it might appear in a browser. And you can us
Preview in Browser mode to display your page in one or two brows
you have set up on your computer. To use this mode, you don’t nee
be connected to the Web. However, there are some things, such as
external links, CGI scripts, certain applets, and form interaction, etc. 
you must test on the Web server in order to know that they work an
appear the way you planned them.

Note You must have a browser installed on your computer to be abl
use the Preview in Browser feature.
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Testing at different resolutions
You can test your pages for how they may appear to people using 
monitors set to lower resolutions by using the Size Window feature
Claris Home Page.

To use the Size Window feature in Claris Home Page:

1 Choose Size Window from the View menu (Windows), or the Window
menu (Macintosh), and then choose the resolution (lower than yo
current resolution), to which you would like to resize the window,
from the submenu.

Testing with different Web browsers
Each browser interprets the HTML of your Web pages slightly differe
from other browsers. It’s a good idea to test your pages in as many W
browsers as possible. As you create your Web pages in Claris Hom
Page, you can see how they’ll look in a browser using the Preview 
Browser mode. When you choose this option, Claris Home Page st
the browser application that is set in the system registry (Windows)
whichever is installed—Microsoft Internet Explorer or Netscape 
Navigator—(Macintosh) and displays the page in the browser windo
Claris Home Page uses this browser as the default until you change
setting. See “Previewing your work” on page 2-12 for more informati
on changing the default browser or adding a second default browse

There are a number of Web browsers available that work on the 
Windows, Mac OS, and UNIX platforms, including Microsoft Interne
Explorer, Netscape Navigator, NetCruiser, Mosaic, and the America
Online (AOL) browser. Some Web browsers are commercial progra
and others are available free of charge. 

The same page viewed with different browsers will have different 
results in terms of what features they support. For example, not all 
browsers will support tables, and things like color, fonts, formatting 
styles and sizing may differ from browser to browser (especially acr
platforms). As a general rule, older browsers do not support newer 
HTML elements, such as frames or client-side image maps, and 
multimedia effects, such as animated GIFs or right-aligned images.
you suspect that some of your intended audience will have older 
browsers, you might consider having alternative text-only pages of y
site they can view.
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Note Claris Home Page uses the Rainbow or Safety Palette, which 
supported by all browsers, by default. Claris Home Page also supp
several color palettes that you can use to build your Web pages. 
However, not all palettes are supported uniformly by all Web browse
For example, Microsoft Internet Explorer supports fewer colors than
Netscape Navigator. If you use an unsupported color for your text, 
browser will not display the color of the text. Make sure to test your
pages on many browsers.

Testing on the Web server
Web servers are computers that store Web sites and respond to req
from different browsers over the Internet. The server is always turned
and running 24 hours a day. Your entire Web site will reside on a W
server when it’s published. 

There are some things in your Web site that you can’t test until you
actually upload the site to the Web server. For example, if your site
includes elements that require a CGI script to work (such as a form
searchable database, or a server-side image map), you’ll need to tes
it works with the CGI script on the Web server. 

Web page elements you will want to test once your files are on a se
include:

1 Server-side image maps

1 Forms connected to a CGI script

1 Forms connected to a FileMaker Pro database

1 Movies, sound, and animations that require plug-ins and helper 
applications

1 Applets that extend the functionality of the site

1 Links to external Web sites or Internet-accessible resources

1 External links to helper applications that go with your multimedia

1 Mailto links for sending messages to your email address

You can view an estimated download time of these elements in Cla
Home Page. For more information, see “Using the Statistics window”
page 2-14.
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Chapter 2:  Claris Home Page basics

Claris Home Page provides you with the tools you need to create W
pages. You can use these tools to insert text, images, tables and o
Web page elements into a page, create links to other pages, and edi
work. 

Two edit modes let you edit the content of your Web page and the ac
HTML source for the page. Object and link editors let you change th
attributes of an element, such as the size of an image, the alignmen
text in a table cell, or the URL of a linked page. Toolbars and special 
palettes make it easy to switch modes, insert elements, and apply 
formatting styles in your page. 

Other options help you preview your work in Claris Home Page or a
browser of your choice, view time estimates of how long it might tak
to download a page or an element on the page, and make changes
several pages at one time using the Site Editor.

Claris Home Page also provides a variety of templates and assistan
help you get started.

Starting Claris Home Page
To start Claris Home Page, double-click the Claris Home Page 3.0 fo
on your system to display its contents, and double-click the Claris Ho
Page 3.0 application icon.

Windows: You can also click the Start button, point to the Claris Home
Page 3.0 folder, and then click the Claris Home Page icon. Or you 
right-click an HTML file and choose Claris Home Page from the conte
menu.

Macintosh: You can also double-click a file that was created in Clar
Home Page to open the application.

When you start Claris Home Page, a new untitled Web page appea
the screen.

Windows

Macintosh
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If you don’t want Claris Home Page to create an untitled document e
time you start it, you can change the default setting to display nothin
to display an Open dialog box at startup. Choose Application Options from 
the Tools menu (Windows) or Preferences from the Edit menu 
(Macintosh), click the General tab, and then choose the appropriate 
setting from the At Startup pop-up menu.

Creating a Web page
There are several ways you can create a Web page in Claris Home P
You can start from scratch, adding text and other elements to a bla
page, or you can use Claris Home Page templates that already con
information. Templates are sample Web pages that contain predefi
formats for you to use as a starting point when you create a Web p

To create a blank, untitled Web page do one of the following:

1 Choose New Page from the File menu.

Windows: You can also click the New Page button  on the Basic 
toolbar.

1 Choose New from the File menu, select Create New, select Blank Page, 
and then click OK.

1 Open the Site Editor and click the New Page button  on the toolbar.

See “Using the Site Editor” on page 2-27 for more information.

To create a page using a template:

1. Choose New from the File menu. 

The New dialog appears.

2. Click Use Template and then choose a template from the scrolling li
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3. Click OK.

Note You can make your own HTML templates from pages you crea
and use them repeatedly as often as you wish. Templates that you c
appear in the scrolling list in the New dialog box. See “Saving a pag
a template” on page 2-25.

Using site assistants
Included with Claris Home Page are special assistants to help you c
a specific kind of site, such as one that uses frames, or one that con
forms connected to a FileMaker Pro database. Assistants are step-
step panels that guide you through the process of creating these sp
types of Web sites. You specify the information for the site and Cla
Home Page creates the pages and links them together.

To use a site assistant:

1. Choose New from the File menu. 

A New dialog box opens.
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2. Click Use Assistant and then select an assistant in the list.

3. Click OK.

4. Follow the instructions on each panel of the assistant. 

A progress chart indicates your progress as you complete the ste

Note  You can create an empty site folder and add your own pages t
Select Create New in the New dialog box and select Empty Site in the 
scrolling list. See “Defining a new site” on page 1-8 for more 
information.

Working in a Claris Home Page document
When you create a Web page in Claris Home Page, it is displayed in
Page mode by default. Working in Edit Page mode is similar to work
in word processing documents. For example, you can type text, ins
images, or copy and paste elements in much the same way. Howev
because of HTML limitations, there are some things you can’t do, s
as set tabs or page margins. Claris Home Page provides toolbars, 
palettes, and object and link editors that let you apply HTML attribu
to your Web page elements.

Select this assistant To do this

FileMaker Connection Assistant Create a Web site that lets your Web audience acc
a FileMaker database from the Web.

Frame Assistant Create frame documents—a special kind of Web 
page that is divided into sections called frames.

Newsletter Assistant Create a Web site for a newsletter. This assistant 
creates a home page with links to other pages or 
links to anchors in the home page.

Personal Site Assistant Create a personal Web site to display photos, 
favorite links, addresses, and more.

Presentation Assistant Create a presentation. This assistant creates a se
of sequential Web pages that you can use to inform
clients of new products or services.

Report Assistant Creates a Web site for a report. This assistant crea
a home page with links to other pages or links to 
anchors in the home page.

School Site Assistant Create a Web site for your school. Each classroom
or department can have their own Web page.

Standard Site Assistant Create a Web site with links to multiple pages.
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Keyboard shortcuts are listed next to options in the menus and a con
menu is also available for some elements like text and images whil
you’re working on a page. To display the context menu, right-click 
(Windows) or Control-click (Macintosh) the element in the page. Fo
listing of keyboard, mouse, and context menu shortcuts, see append
“Shortcuts for using Claris Home Page.”

Opening HTML files
You can open and edit any HTML file in Claris Home Page.

To open an HTML file:

1. Choose Open from the File menu.

2. Select the file you want to open.

3. Click Open.

Changing the size of the document window
You can change the size of your document window to view it using y
monitor’s specific size.

To change the size of your document window:

1. Choose Size Window from the View menu (Windows) or Window 
menu (Macintosh).

2. Select the monitor size you want to view your document window

Select Default to return the document window to the size that Clari
Home Page first opened your document as.

Using Edit Page mode
Edit Page mode displays the contents of your Web page in a format
allows you to perform all of the editing tasks involved in creating yo
Web page, such as typing and formatting text, inserting images, crea
links, and so forth.

By default, when you first open a file or create a new document, Cla
Home Page displays the document in Edit Page mode.

If you want to change the default mode that Claris Home Page ope
documents in, choose Application Options from the Tools menu 
(Windows) or Preferences from the Edit menu (Macintosh), click the 
General tab, and then choose Preview Page or Edit HTML Source from the 
Open Documents in pop-up menu. 
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To switch to Edit Page mode, choose Edit Page from the View menu 
(Windows) or from the Window menu (Macintosh) or click the Edit Page 
button  on the toolbar.

Cutting, copying, and pasting
In Claris Home Page, you can cut, copy and paste text, tables, links
images, and other elements within your Web page, between other W
pages, or between Claris Home Page documents and other applica

To cut or copy and paste an element:

1. Select the element.

2. Choose Cut or Copy from the Edit menu.

If you choose Cut, Claris Home Page removes the element from it
original location, and places it on the Clipboard. If you choose Copy, 
the element stays where it is and a copy is placed on the Clipboa

3. Select the location in the page where you want the element to go

4. Choose Paste from the Edit menu.

Tip You can also drag elements to cut, copy, and paste them. If you 
an element within the same document, it is cut and pasted. If you d
an element from one Claris Home Page document to another, it is co
and pasted.

Undoing your work
If you want to delete something in your document, select it and press
Backspace or Delete key. 

If you want to cancel the last action you performed, choose Undo from 
the Edit menu.

Using the toolbars and palettes
Claris Home Page includes toolbars and special tool palettes you can
to perform tasks quicker than selecting the corresponding option from
menu. Tool tips display a description of the tools when you hold the 
mouse pointer over them.

Basic and Style toolbars:  The Basic toolbar provides access to many 
the commonly used features in Claris Home Page such as Edit Pag
Preview Page, and Preview in Browser modes. Click a button to acti
your choice. When you click a button to insert an element, the elem
is inserted at the insertion point in the page. 
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Tip  You can also drag the Insert Anchor , Insert Horizontal Rule , or 
Insert Table  buttons onto your page to insert those elements.

The Style toolbar has buttons you can use to format text. Select the
and click a button to activate your choice, or choose an option from t
pop-up menu.

Tip You can also drag the Make Numbered List Entry button , or Make 
Bullet List Entry button  onto your page to insert those elements. 

The Basic and Style toolbars appear by default. 

Image editor toolbars:  The toolbars in the Image editors provide too
for you to add transparency or interlacing to images and hotspots to
image maps. To use these toolbars, double-click the image to open
Image Object Editor. To open the Client-Side Image Map Editor, cli
the Behavior tab, if necessary, and then click the Edit button. To open the 
Transparency and Interlacing Image Editor, click the Appearance tab, if 
necessary, and then click the Set button. 

Basic toolbar (Windows)

Basic toolbar (Macintosh)

Style toolbar 

Client-Side Image Map Editor toolbar

Transparency and Interlacing Image Editor toolbar
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Frame page toolbar:  When you create a frame page, the Edit Frames 
button  appears on the Basic toolbar to let you know you are work
in Edit Frames mode. Also added to the toolbar are five frame layou
buttons. Click on these buttons to subdivide a frame vertically, 
subdivide a frame horizontally, add a frame to your frame page, sele
parent frameset, or select a root frameset.

Library toolbar:  When you open a Claris Home Page library, a librar
toolbar appears on the library window along with a Library menu opti
This toolbar provides buttons for new entries into a library, inserting
specific element into a page, and using a specific element for the 
background of a page.

Site Editor toolbar:  Another toolbar is found in the Site Editor. This 
toolbar provides buttons for adding a new page, setting document 
options, checking site statistics, verifying links and references, 
consolidating, and uploading.

Forms tool palette:  Claris Home Page has a floating Forms tool pale
you can use to insert form elements into your documents. To display
Forms tool palette, choose Forms Palette from the View menu (Windows) 
or Show Forms Palette from the Window menu (Macintosh). To hide the
Forms tool palette, click the close box or choose it again from the V
menu (Windows) or from the Window menu (Macintosh).

Toolbar in Edit Frames mode

Library toolbar

Site Editor toolbar
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To use the Forms tool palette, drag one of the buttons onto your W
page to add the corresponding element. You can also click once on
button in the Forms tool palette to insert an element at the insertion
point. Move the Forms tool palette anywhere on your screen by dragg
its title bar.

Using the object and link editors
When you add an element to your Web page, such as a table, an im
or a hypertext link, you use an object editor or the link editor to spec
or make changes to its characteristics. 

In all of the object and link editors, you will find an additional field in
which you can add extra HTML. You can add the HTML directly to th
object or hypertext link in Edit Page mode without having to go to E
HTML Source mode. For more information, see “Adding extra HTM
to your page” on page 2-16.

Most object editors open for you when you insert an element into th
page. You can use different methods to open the object editor for a
element:

1 Double-click the element

1 Select the element and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu (Macintosh)

1 Select the element and click the Object Editor button on the Basic 
toolbar
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You can see the results of a change without having to close the obj
editor by clicking in a different text box.

Hypertext links can be edited using the Link Editor. To open the Link
Editor and edit a particular link: select the link in Edit Page mode and
choose Link Editor from the View menu (Windows) or Show Link Editor 
from the Window menu (Macintosh). 

The Link Editor is displayed in an expandable window. Click the 
triangle  on the bottom section of the window to display more 
information. 

Resizing elements using the mouse
Besides using the object editors, you can resize many of the elemen
your page, such as tables, images, frames, and form elements, usin
mouse.

Click to expand bottom
section of Link editor
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To resize an element using the mouse:

1. Select the element.

The element is highlighted with a border that includes one or 
more handles.

2. Drag the bottom handle to change the height of the element, drag
right-side handle to change the width of the element, and drag th
lower-right corner handle to change the height and width of the 
element at the same time.

To resize graphic elements proportionately, Shift-drag the corner 
handle.

Aligning elements
You can change the horizontal alignment of text, images, and other
elements in relation to the Web page. 

To change the alignment of an element:

1. Select the element and choose Alignment from the Format menu.

2. Choose Align Left, Align Center, or Align Right from the submenu.

You can also change the alignment of text and other elements using
Align Left , Align Center , and Align Right  buttons on the toolbar.

To align elements within a table cell, select the table cell that conta
the element you want to align. In the Table Object Editor, click the Cells 
tab, and then select the appropriate option from the Horizontal Align or 
Vertical Align pop-up menu. For more information, see “Changing the
alignment of elements in a table” on page 5-10.

Previewing your work
Claris Home Page provides you with different ways for checking yo
Web page after you’ve worked on it in Edit Page mode. You can us
Preview Page mode to preview the page in Claris Home Page, and
Preview in Browser mode to view it in a browser that you specify. Y
can also use the Statistics window to get an estimate of download ti
for your page and elements on the page.

For information about viewing the source tags for your page, see “Us
Edit HTML Source mode” on page 2-16.
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Using Preview Page mode
When you switch to Preview Page mode, Claris Home Page displa
your Web page the way it might appear in a browser. Keep in mind
however, that the appearance of your Web page may vary when 
displayed in different kinds of browsers. 

In Preview Page mode, you can test interactive elements of your W
page, such as links and certain form capabilities, and you can see h
elements such as numbered lists will look in a browser. 

Note  In Preview Page mode, all of the editing capabilities and some
the menu options are disabled.

To switch to Preview Page mode, click the Preview Page button  on the 
Basic toolbar or choose Preview Page from the View menu (Windows) or 
the Window menu (Macintosh).

Previewing your Web page in a browser
In Claris Home Page, you have three preview choices for viewing yo
Web page in a browser. By default, Claris Home Page is set to open 
page in Internet Explorer and Netscape Navigator. The third choice all
you to preview your Web page in all the browsers you currently have
your system. If you don’t have Internet Explorer or Netscape Navigato
your system, or if you want to see how your page looks in a different
browser, you can change the default browsers. See “Changing the pre
browser settings” next.

To preview your Web page in a browser, do one of the following:

1 Choose Preview in Browser from the View menu (Windows) or the 
Window menu (Macintosh) and then choose a browser from the 
submenu.

1 Click the Preview in Browser button  on the toolbar and choose a
browser from the pop-up menu.

Note You can set Claris Home Page to automatically save changes in 
page before previewing in a browser. Choose Application Options from the 
Tools menu (Windows) or Preferences from the Edit menu (Macintosh), 
click the General tab, and if necessary, select the Auto-save before running 
commands checkbox. 
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Changing the preview browser settings
You can change the settings for both Preview in Browser options that 
Claris Home Page uses to display your Web pages. The name of the
browser appears in the Preview in Browser submenu.

To change a default browser:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the Browser Preview tab.

3. Click Browse for either Preview Browser One option or Preview 
Browser Two option.

An Open dialog box appears.

4. Select the browser application and click Open.

The name and path of your selection appears in the dialog box.

5. Click Clear if you wish to change your choice back to the default.

6. Click OK to close the Application Options (Windows) or Preferenc
(Macintosh) dialog box.

Using the Statistics window
The Statistics window provides estimates of how long it will take your 
viewers to download your Web page (or elements in your page) to the
browser. You can check the estimated download time for a page you’r
developing any time you are working with your page in Edit Page mod

Note  The Statistics window displays estimates of download time unde
ideal conditions. Network congestion, server loading, or other adve
conditions can significantly increase the download time of your Web
pages.

To use the Statistics window:

1. If you want to see statistics for a specific element or section of yo
Web page, select it first.

2. Choose Document Statistics from the Tools menu (Windows) or from
the Edit menu (Macintosh).

The statistics window for the selected document appears.
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3. Click the Document or the Selection tab and read the estimated 
statistics for the whole document or the section you’ve selected.

This statistic Provides this information

Character Count Number of characters in your Web page or selection

Word Count Number of words in your Web page or selection

Total Image Size Number of bytes for all images in your Web page or in
the section you selected

Approximate Download 
Times

Estimates of how long it will take a viewer to download 
your Web page or the section you selected using 
different modem speeds
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Adding extra HTML to your page
You can add extra HTML to your pages using Edit HTML Source mo
and to specific elements in a page while you are working in Edit Pa
mode. You can also change some of the file output tags that Claris H
Page automatically inserts for you. There are several ways to add e
HTML to your Web pages:

1 Add attributes to an element in an object editor

1 Add comments or HTML text

1 Add HTML to the Prefix Comments, HTML, HEAD, and BODY 
tags (the document tags) in Edit Page mode or Preview Page mo

1 Use Edit HTML Source mode to add extra HTML to the page

1 Change specific HTML output settings for all pages in 
Claris Home Page

Using Edit HTML Source mode
As you create your Web page in Edit Page mode, Claris Home Pag
inserts the HTML tags for you. You can view these tags and add yo
own HTML to it in Edit HTML Source mode. Claris Home Page sav
and incorporates the changes you make.

Important Be careful when editing your Web page in Edit HTML Sourc
mode. Unless you are familiar with HTML and its syntax, you can 
destroy your work. As a precaution, make a copy of your Web page
before you change it in Edit HTML Source mode.

To switch to Edit HTML Source mode:

1 Click the Edit HTML Source button  on the Basic toolbar or choose
Edit HTML Source from the View menu (Windows) or the Window 
menu (Macintosh). 

When in Edit HTML Source mode, the HTML menu appears on the me
bar, which contains options for setting the text display in this mode.

Tip When you wish to edit an element in Edit HTML Source mode, firs
select the element in Edit Page mode and then switch to Edit HTML So
mode. This way you open to the exact location you want to edit withou
having to search for the element.
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In Edit HTML Source mode, you can use all of the usual text editing
operations such as typing, undoing, cutting, copying, pasting, dragg
and finding and replacing text. You can also change the display of t
and HTML tags to make viewing it easier. Other options, such as th
found in the Insert, Format, and Style menus, are not available in E
HTML Source mode. 

Changing the text display in Edit HTML Source mode
To make viewing easier, you can change the way HTML tags and t
are displayed in Edit HTML Source mode. You can change the font t
and font size of the source, use syntax coloring to distinguish tags f
text, and use the word wrap option to temporarily break lines of tex
within the document window so you don’t have to scroll horizontally

To change the display in Edit HTML Source mode: 

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the HTML View tab. 

3. Make the appropriate selections and click OK.
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Claris Home Page displays a sample of text with your selections app
to it. Use the scroll bars to view your full settings. When Syntax Coloring 
is not selected, the sample text appears as black. 

To distinguish tags from text, use different colors and styles for them
Select Use Syntax Coloring, choose a tag type from the HTML Element pop-
up menu, and select a color and style for that type. 

To change the font type and size of the source, choose them from t
HTML Font pop-up menus. The settings apply to all pages you view
Edit HTML Source mode.

To make temporary line breaks and turn off horizontal scrolling, sel
the Word Wrap check box. 

Note You can also turn Syntax Coloring and Word Wrap on and off 
from the HTML menu.

To restore all the HTML Editing settings to their default values, click
Use Defaults.

Adding attributes to an element
You can add extra HTML attributes to an element in Edit Page mode
do this:

1. Select the element you want to add an attribute to and then open
object or link editor. 

2. Click the Extended tab, if necessary, or the triangle  to show the Extra 
HTML Attributes text box. 
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3. In the Extra HTML Attributes text box, type the appropriate HTML and
close the object or link editor. 

Claris Home Page adds the HTML to the element’s tag.

Adding HTML to text
You can add HTML code or comment to your text in a Web page to
format special characters or insert a comment that is visible in the so
on a browser (you can view it in Edit HTML Source mode).

To add HTML to the text in your Web page:

1. Choose HTML Code or Comment from the Insert menu.

2. Type your code or comment in the text box.

Adding HTML to the document tags
You can add extra HTML attributes to the document tags for your 
Web page.

To add attributes to a document tag:

1. Choose Document Options from the Tools menu (Windows) or from 
the Edit menu (Macintosh).

2. Click the Extended tab, and then type the HTML attributes in the 
appropriate text box. 

Type extra HTML
in this text box To add

Prefix Comments Commented text to the beginning of your HTML file, such a
the name of the author, messages, and so on.

<HTML> Tag Attributes Attributes to the <HTML> tag. Commented text that states th
enclosed text is HTML and may contain two elements, HEAD 
and BODY, such as the title of a document, list elements, and
so on.

<HEAD> Tag Attributes Attributes to the <HEAD> tag. Commented text that contain
general information about your HTML file, such as a record of 
the HTML file’s original URL, a relationship between files, 
and so on.

Text in Head Section Text that appears in the HEAD section of the file. This optio
allows you to add tags other than <TITLE>.

<Body> Tag Attributes Attributes to the <BODY> tag. Commented elements that 
contain the actual text of the HTML file, such as headings lists,
addresses and so on.
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3. Click OK to close the Document Options dialog box.

The extra HTML you type in these text boxes only affects the curre
Web page you have open unless you have selected several pages 
the Site Editor. To apply your changes to multiple pages, open the 
Editor (choose Open Site Folder from the File menu), select the pages yo
want to change, and make the appropriate option changes in the 
Document Options dialog box.

Changing HTML output settings
HTML output are automatically inserted for you. These application 
options affect the way a file is saved, and the type of HTML that Cla
Home Page applies for text and hypertext links.

You can change the default settings if you want to. Your change affe
all pages that you create in Claris Home Page. 

To change the default HTML output settings:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh). 

2. Click the HTML Source tab, and then change the appropriate settin

Select this HTML 
output setting To do this

Default HTML File 
Extension (Windows) 
or Suffix (Macintosh)

Change the default filename suffix for new HTML files. Should 
typically be .htm or .html, for instance mypage.htm or 
mypage.html.

Header Comment Add information that identifies your pages as Claris Home Page
files at the beginning of the HTML. (These comments are only 
visible when viewing the HTML source.)

Choose None if you don’t want any information added.

Choose Identify as Home Page file if you want a comment added 
identifying your Web pages as Claris Home Page files.

Choose Identify and time-stamp if you want a comment added 
identifying your Web pages as Claris Home Page files and a time
stamp identifying the last time each file was saved.

Line Break Format Specify the line break format your files will follow. Use this option
only if you want to edit the HTML code of your Web page in a text 
editor since Claris Home Page can handle all line break 
conventions.

Choose Macintosh (CR), Windows (CRLF), or Unix (LF) to specify the 
kind of line breaks you want to use.
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Setting the color and background of your Web page
You can change the color or use an image as a tiled pattern for the
background of your Web page. When you use an image, it overrides
color setting. 

You can also specify a different color for the background of tables a
table cells. See “Using the Table Object Editor” on page 5-3 for mo
information. 

Using the Site Editor, you can change several pages at one time. Ch
Open Folder As Site from the File menu, select the pages you want to 
change in the Site Editor, and then follow these instructions to chan
the background of all selected Web pages. (See “Changing the color
background of a table” on page 5-11 for more information.) 

Changing the background color
To change the color of your Web page’s background:

1. Choose Document Options from the Tools menu (Windows) or from 
the Edit menu (Macintosh).

The Document Options dialog box appears.

2. Click the Appearance tab.

Paragraph Alignment 
Uses

Specify how centered text is coded.

Choose <CENTER> tag to have Claris Home Page use the 
<CENTER> tag.

Choose ALIGN attribute to have Claris Home Page use the 
ALIGN=CENTER parameter within other tags (such as <P>).

Generate </P> Tags Add a closing paragraph tag to every opening paragraph tag in y
files. This option is selected by default.

Generate X-CLARIS 
Tags

Claris Home Page uses several custom tags (beginning with “X-
CLARIS”) to save information such as where the Claris Home Page
application window appears on the screen and what size the 
window is. Enable this option to display these additional tags in the
HTML file.

Use Absolute 
Pathnames

Specifies fixed pathnames for hypertext links between files based
on the computer where they reside. Because the pathnames do n
change, links can be broken when files are moved to another 
computer. When this option is deselected, Claris Home Page use
relative pathnames based on the location of files that contains the
links.

Select this HTML 
output setting To do this
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3. Place the pointer on the Background Color box and hold the mouse 
button down until the pop-up color palette appears.

4. Select the color you want to use as the new background for your
Web page.

To select a color not found in the pop-up color palette, choose Other 
from the color palette, select the color you want to use, and then
click OK.

5. Click OK to close the Document Options dialog box.

The background color of your Web page changes.

You can change the color palette that appears in the pop-up menu. 
note, however, that not all colors are supported uniformly by all We
browsers. For more information see “Changing the default color pal
display” on page 2-23.

Using an image for the background
To use an image as a tiled background for your Web page:

1. Choose Document Options from the Tools menu (Windows) or from 
the Edit menu (Macintosh).

2. Click the Appearance tab.

3. Click the Set button for the Background Image.

An Open dialog box appears.

4. Select the image file you want to use.

5. Click Open.

The path of the image file and a thumbnail representation of the 
image appear in the Document Options dialog box.

6. Click OK to close the Document Options dialog box.
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Note If you select both a color and an image for the background, the
image overrides the background color unless image loading is turned
in the browser.

To hide the background image in Edit Page mode:

Background images normally display in Edit Page mode. To increa
performance, you can set Claris Home Page to not display them in 
Page mode. 

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the Images tab.

3. Click the Display Background Images in Edit Mode check box to deselect
the option.

To remove an image from the background of your Web page:

1. Choose Document Options from the Tools menu (Windows) or 
Document Options from the Edit menu (Macintosh).

2. Click the Appearance tab.

3. Click Restore Default Background.

Changing the default color palette display
You can change the color palette that appears for the color settings i
Document Options dialog box:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the General tab.

3. Choose a new palette from the color palette pop-up menu and 
click OK.

Also note, however, that not all colors are supported uniformly by a
Web browsers.
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Saving your Web page
As in any application, it is important to save your files frequently to 
avoid the possibility of losing data. In addition, within Claris Home Pa
certain functions will only work after you have saved your Web pag
for example switching to Preview Page mode or Preview in Browse
mode. You can set Claris Home Page to automatically save a new 
and give it a temporary filename whenever you switch modes.

Claris Home Page save your Web page as an HTML file with the def
extension of .htm. You can also save your page as a template file to r
for creating other Web pages.

To save a Web page:

1. Choose Save from the File menu.

The Enter Title dialog box appears the first time you save a new pa
Enter a title and click OK. You can change the title later if you want
(For more information, see “Changing the title of your Web page
next.) 

The Save dialog box appears. 

2. Choose HTML File from the Save as type or File type pop-up menu.

3. In the File name or Save file as text box, type the filename for your Web
page followed by the extension .htm  for a Windows file or .html  
for a Macintosh file. 

In order for your files to be seen as Web pages in Claris Home P
and in Web browsers, they must have the .htm or .html extension. 
text box provides a default name as “title” with the proper extens

4. Click Save.

To change the filename extension that appears by default in the Sa
dialog box: 

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the HTML Source tab.

3. Type the extension in the Default HTML File Extension text box 
(Windows) or Default HTML File Suffix text box (Macintosh).
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Changing the title of your Web page
Claris Home Page prompts you to give your Web page a title the fir
time you save the document. Later you may wish to change it. The 
of a Web page appears in the title bar at the top of most browser 
windows. This title can be different than the filename and does not n
an HTML extension. You can see what the title is for your Web page
Preview Page mode.

The words that appear in a Web page title are also used in searche
many Internet search engines. If it is important that viewers are abl
find your Web page via keyword searches, make sure that the title 
includes words your viewers are most likely to use when doing the 
keyword search.

To change the title of your Web page:

1. Choose Document Options from the Tools menu (Windows) or from 
the Edit menu (Macintosh).

2. Click the Parameters tab.

3. Enter the title in the Document Title text box.

4. Click OK.

The new title appears in the title bar in Preview Page mode.

Saving a page as a template
You can save your Web page as a Claris Home Page template and 
for creating other Web pages.

To save a Web page as a template:

1. Choose Save As from the File menu.

If you haven’t saved your Web page yet, the Enter Title dialog bo
appears. Enter a title and click OK. (For more information, see 
“Changing the title of your Web page” on page 2-25.)

The Save dialog box appears. 

2. Select the Page Template folder located in the Claris Home Pag
folder. The file must be saved in this folder.

3. Choose HTML Template from the Save as type or File type pop-up menu.

4. In the File name or Save file as text box, type the filename for your 
template followed by the extension .htm . 
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5. Click Save.

A dialog box opens asking you to type a short description of the 
template.

6. Type a descriptive name for the template and click OK.

The name you type appears in a list of templates in the New dial
box the next time you start Claris Home Page.

To use the template:

1. Choose New from the file menu.

2. Click Use Template and select the template in the list. 

A sample picture of the page appears on the left. 

Note  If your template doesn’t appear in the list, exit Claris Home 
Page and then start the application again.

3. Click OK to close the New dialog box. 

The template opens as a new untitled page.

Auto-saving your files
You can set Claris Home Page to automatically save a new page and
it a temporary filename whenever you switch to a preview mode. Cla
Home Page will continue to save the file at the regular intervals you
specified. 

To set the auto-save option:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the General tab. 

3. Specify how often (in minutes) you want Claris Home Page to sa
your files by selecting the Auto-save document every “#” minutes check 
box and typing a number in the text box.

Time stamping your saved file
When you save your Web page, Claris Home Page adds a header 
comment by default to the HTML source to indicate the date and tim
that you saved it and to identify it as a Claris Home Page file. This 
comment is only visible when viewing the HTML source. 
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You can change the default setting to remove the date and time sta
and just identify your pages as Claris Home Page files or to save all 
without the header comment.

To change the header comment setting: 

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the HTML Source tab.

3. Choose a header type from the Header Comment pop-up menu. 

See “Changing HTML output settings” on page 2-20 for informatio
about the other options in this dialog box. 

You can also place a comment of your choice that is only visible to y
and not by browsers. Choose Comment from the Insert menu. Type your
comment in the Comment dialog box your comment usually appear
the top of the page in Edit HTML Source mode.

Printing your Web page
You can use Claris Home Page to print the Web pages you create.
can print a page while in Edit Page mode, Preview Page mode, or E
HTML Source mode and Claris Home Page will print your page as 
appears in that particular mode. For example, table borders that are
to zero will print in Edit Page mode but not in Preview Page mode.

To print your Web page:

1. Choose Print from the File menu. 

Your system’s standard Print dialog box appears.

2. Click OK (Windows) or Print (Macintosh).

Claris Home Page prints the entire contents of your Web page fi

Using the Site Editor
The Site Editor is another type of editor found in Claris Home Page. T
Site Editor displays information about all of the files that exist inside
site folder. 

To open the Site Editor:

1. Choose Open Folder As Site from the File menu.
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The Browse for Folder dialog box (Windows) or the select a Fold
dialog box (Macintosh) appears.

2. In the dialog box, navigate to the folder you want to define as the 
folder and click OK (Windows) or Select “Folder Name” (Macintosh).

The Site Editor opens and displays the site folder you specified a
its contents.

To use the Site Editor, select one or more pages and click a button o
toolbar or choose an option from the menus. To open a file from the 
Editor, double-click its icon in the list. If you double-click an image file
Claris Home Page opens it in the Image Object editor.

To perform this task Do this

Open a page that’s listed in the Site Editor Double-click its name in the list.

Create a new page Click the New Page button  on the toolbar.

Set document options for one or more pages Select the filenames in the list and click 
Document Options button from the Site Editor 
toolbar. 

To check the links in your Web pages before 
you upload the files

Click the Verify Links/References button  in 
the toolbar to display the Verify Links/
References dialog, and then click OK.

Consolidate the image files Click the Consolidate button  in the toolbar 
to display the Consolidate dialog box, and 
then click Consolidate.

Upload individual files or an entire site to a 
remote server

Select only the files you wish to upload, and 
then click the Upload button  in the toolbar 
to display the Upload dialog, and then click 
OK. To upload the entire site, click Entire Site 
in the Upload dialog box. See chapter 11, 
“Uploading your pages to a Web server” for 
more information.
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Chapter 3:  Adding text to your Web page

Claris Home Page lets you work with text in some of the ways that y
would in a standard word processor. You can type text, cut and paste
from another page or another document, find and replace text, and c
your spelling. You can use several levels of headings, apply styles,
change the size of text, change the text font, and change the color o

Be aware, however, that HTML imposes certain limitations on your t
formatting. For example, HTML doesn’t let you change spacing 
between words or lines, add tabs, or change how words are hyphen
Other limitations arise because all browsers and platforms are not a
If a browser window is set to a different size, the layout you carefull
arranged on your page may look considerably different. Although y
can’t predict exactly how text will appear to your audience on the W
you can test the appearance of text on different browsers they are li
to be using. 

Entering text
You can add text to your Web page by typing it directly onto the pa
by copying and pasting it from another Web page or application, or
dragging it from another page in your Web site. On the Macintosh, y
can drag text from another application as well. (See “Cutting, copyi
and pasting” on page 2-7 for more information about copying eleme
in a Web page.)

You can delete text by selecting it and pressing Delete, and cancel 
last action by choosing Undo from the Edit menu or pressing Ctrl-Z 
(Windows) or 3-Z (Macintosh). 

As you type, the lines of text in a paragraph run continuously and w
evenly regardless of the size of your window. The text you type also
wraps evenly in a Web browser window no matter what size it is.

Press Enter (Windows) or Return (Macintosh) to end a paragraph o
text and insert a paragraph break. Claris Home Page adds an extra
after each paragraph. If you want to make a paragraph break witho
adding the extra line, choose Line Break from the Insert menu or press 
Shift-Enter (Windows) or Shift-Return (Macintosh).
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Note Claris Home Page shows line break symbols by default in Edit
Page mode. To hide the line break symbols, choose Application Options 
from the Tools menu (Windows) or Preferences from the Edit menu 
(Macintosh) and click the General tab. Click to deselect the Show Line 
Breaks check box, and click OK.

Opening a text file from another application
You can open text files that you created in other applications and ap
HTML formatting styles to them in Claris Home Page. 

To open a text file in Claris Home Page:

1. Choose Open from the File menu. 

Select the text file in the Open dialog box.

Windows: Choose Text Files from the Files of type pop-up menu and 
navigate to the folder where the text file is located.

Macintosh: Only HTML and text files appear in the Open 
dialog box.

2. Click Open.

The text file appears in Edit Page mode.

Note You can also copy text from another application and paste it in
untitled Claris Home Page document.

Finding and replacing text
You can find and replace strings of text, including text characters, 
words, phrases, and keyboard symbols, such as the ampersand (&

To find and replace text:

1. Choose Find/Change from the Edit menu. 

The Find/Change dialog box appears.

Line break symbol
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2. Type the text you want to find in the Find text box.

3. If you want to replace the found text, type the replacement text in
Change text box or if you want to delete the found text, leave this 
box empty.

4. Select the options you want to use.

Select this option To do this

Search In Select the page you want to search in. Search the Top Page, All 
Open Pages, and All Pages In All Open Sites. Using the Site Editor 
you can also Selected Pages In The Top Site, All Pages In The Top 
Site, and Selected Pages In All Open Sites.

In Edit Mode
In HTML Mode

Select the mode you want to search in. Search In Edit Mode to 
find the a match in Edit Page mode only. Search In HTML Mode 
to find a match in Edit HTML Source mode only.

Case Sensitive Only find exact matches of the text, including case. For 
example, “Coffee” would find “Coffee” but not “coffee.” 
Leave unchecked to ignore case.

Whole Word Only find the text if it appears by itself without any other 
characters.

Search Backwards Search backward from the insertion point instead of forwar

Wrap Around Search through the page again.
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5. Click the appropriate button to perform the search.

Choose Find Next from the Edit menu if you want to find the same tex
again without reopening the Find/Change dialog box.

Applying styles to text
Use Claris Home Page to apply standard HTML formatting styles to
paragraphs and to individual characters or words easily. In Edit Pag
mode, choose a style and Claris Home Page adds the appropriate H
tags to the text or paragraph for you.

Using paragraph styles
You can use paragraph styles to format different level headings, lis
quotes, and bylines and to align paragraphs to the sides of the pag

When you apply a paragraph style, the change affects all of the tex
within the paragraph. In most cases, if text within the paragraph alre
has a character style, it adopts the paragraph style in addition to th
character style. For example, if you make the first word in a paragra
italic and then make the paragraph into a heading, the first word is 
set in italic. 

To apply a paragraph style:

1. Select the paragraph or group of paragraphs you want to format.

2. Choose the style from the Format menu.

Click this button To do this

Find Next Find the text you typed in the Find text box.

Change All Replace all instances of the found text with the text you type
in the Change text box.

Change After a successful find, replace the found text.

Change, Find After a successful find, replace the found text and search f
the text again.

Choose one 
of these styles To do this

Normal Remove any Heading, Preformatted, Address, or List styles 
from a paragraph.
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Using character styles
Claris Home Page provides styles for applying HTML attributes to te
characters. Character styles include physical and logical character 
styles, and Font, Size, and Text Color.

Characters formatted with a physical style (such as Bold, Italic, or 
Strikethrough) look the same no matter what browser they appear i
long as the browser supports that physical style. (If a browser does
support the style, then there’s no way of knowing how the characte
will be interpreted.) 

Preformatted Format the text of the paragraph to display in the monospa
font used by the Web browser. This causes all of the 
characters typed to have the same width so you can use 
multiple spaces to line up text exactly how you want it to look.

Note Tables are more useful for presenting text in multiple 
columns as long as the browser supports tables. For more
information on tables, see chapter 5 “Adding tables to your
Web page.”

Address Format your byline or address so your audience can find 
it easily.

Note Bylines and the email address of the Web page autho
are usually placed at the bottom of the Web page, separate
from other text.

Headings 1–6 Format text with six different heading levels, where 
Heading 1 is the largest and Heading 6 is the smallest.

Bullet List, Definition List 
(Term and Definition), or 
Numbered List 

Format paragraphs into a list of items. You can choose from
several different types of lists depending on the information
you are presenting. For more information, see “Creating a 
list” on page 3-9.

Number List Style Label the numbered list items using alphabetic or numeric
characters.

Increase Indent Format a paragraph as an extended quotation by indentin
both the left and right sides of the paragraph. Uses the 
<BLOCKQUOTE> tag.

Decrease Indent Remove the indentation of the paragraph. Removes the 
<BLOCKQUOTE> tag.

Alignment Align text to the left side, center, or right side of the 
Web page. Choose Align Left, Align Center, or Align Right from 
the submenu.

Choose one 
of these styles To do this
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Characters formatted with a logical style appear differently depending 
on how a browser interprets that style. For example, characters 
formatted with the Emphasis style might appear in italics in one brow
while in another browser they might appear underlined. This allows 
more flexibility between browsers.

Here is how Claris Home Page displays the logical styles it support
Remember, they may look different in other browsers.

To apply a character style:

1. Select the characters you want to format.

2. Choose one or more character styles from the Style menu.

Type of 
character style

Choose one of 
these styles To do this

Physical styles Plain Remove all physical and logical character 
styles, such as Bold. Does not affect Font, Size,
or Text Color.

Bold Make text bold.

Italic Make text italic.

Underline Make text underline.

Strikethrough Make text strikethrough.

Superscript Make text superscript.

Subscript Make text subscript.

Teletype Make text teletype.
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Removing paragraph or character styles
To remove a paragraph style, you reset the selected text back to No
Select the text and choose Normal from the Format menu. (Character 
styles remain unaffected.) 

To remove all character styles from text, select the text and choose Plain 
from the Style menu. 

Logical styles 
(choose Other 
from the Style 
menu)

Strong Indicate the text is very important.

Emphasis Indicate the text is important.

Citation Indicate that the text is from a book or other 
document.

Inserted Indicate that the text has been inserted into the
document. 

Deleted Indicate that the text has been deleted from the
document.

Sample Indicate that the text is a sequence of literal 
characters.

Keyboard Indicate that the text is keyboard input.

Variable Indicate that the text is a variable.

Code Indicate that the text is code.

Font None Make text display in the default font of the Web 
browser. 

Other Type a list of fonts separated by commas (for 
example, Helvetica, Ariel, Courier ). 
The text will display in the first listed font 
found on the browser’s system.

(Font name) Make the text display in the font specified. (If 
the font is not available on the browser’s 
system, another font will be substituted.)

Size 1 through 7 (3 is 
the default)

Format text with 7 sizes where 7 is the largest 
size and 1 is the smallest.

Increase Format text with the largest size (same as 7).

Decrease Format text with the smallest size (same as 1)

Text Color Black, White, 
Gray, Red, Blue, 
Green, Magenta, 
Cyan, Yellow, 
and Other

Make the text a different color. For more 
information, see “Changing the color of text” 
on page 3-14.

Type of 
character style

Choose one of 
these styles To do this
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Changing how text is displayed in Claris Home Page
To make working with text easier, you can change how text is displa
in Edit Page and Preview Page modes without affecting the actual 
HTML formatting styles of the text. 

Note This procedure does not change the way text is displayed in y
Web pages on the Internet. 

To change how the text is displayed in Claris Home Page:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the Fonts tab.

3. Choose a font type and size. 

Change the proportional font settings to set how normal or plain t
appears. Change the monospaced font settings to set how text ap
in form fields and with the Preformatted or Teletype styles.

Note The default display font setting is Times, 12 points.

Formatting special characters
Characters that require more than one key to type, such as the copy
symbol (©), are not guaranteed to appear in all browsers or on all ty
of computers. To ensure special characters like this appear in your 
page, you type numeric entities assigned by the International Stand
Organization (ISO) in the HTML Code text box. For example, the numeric
entity for the copyright symbol is &#169; . The actual character appear
when you preview the page in a browser or after you close and reo
the page in Claris Home Page. 

For a complete list of the ISO Latin-1 character set and the assigne
numeric entities, see appendix A, “Codes for special characters.” 

To enter a special character:

1. Switch to Edit Page mode, if necessary.

2. Place the insertion point where you want the special character to
appear.

3. Choose HTML from the Insert menu and then choose Code.

An HTML Code icon  appears in your page and the HTML Co
window opens.



 

Adding text to your Web page

 

3-9

    

(

    

 a 

  

 
ge in 
 you 

  

ert 

  

ou 

ind 

  

 

 an 
 

4. Type &#, the number for your special character, and a semicolon ; ) 
in the HTML Code window. 

When you add &# before the number, the number is recognized as
numeric entity for a special character.

5. Click the close box of the HTML Code window.

The HTML Code icon remains as a placeholder for the code you
assigned. The special character appears when you view your pa
a browser, and it also appears in Claris Home Page the next time
open the file.

To enter in HTML code as a comment, click the Include<!--NOEDIT--> 
Marker checkbox. When checked, Claris Home Page will not conv
the HTML code between the comment lines.

Creating a list
There are several ways you can format text to help you organize 
information on your Web page. Using lists is one popular method. Y
can create three kinds of lists using Claris Home Page: bulleted, 
definition, and numbered lists.

The first step in creating a list on your Web page is deciding which k
of list to use.

Use this kind of list For this type of information

Bulleted list Items that don’t necessarily follow a sequence (also known
as an unordered list). In this kind of list, a bullet precedes 
each item.

Definition list Terms that might be unfamiliar to the user. Definition lists 
consist of terms that are followed by their definitions.

Numbered list Items that need to be listed in a sequence (also known as
ordered list). In this kind of list, a number or letter precedes
each item, which you can specify.

Browser view

Edit Page mode view
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Note When you create a numbered list in Edit Page mode, you see 
number symbol (#) or an X in front of each entry. The actual number
letters only appear when you view your page in Preview Page mod
or in a browser.

Creating a bulleted list
To create a bulleted list:

1. In Edit Page mode, type the list items, starting each item on a new

2. Select the list.

3. Choose Bullet List from the Format menu or click the Make Bullet List 
Entry button on the toolbar.

Note You can also start a new bulleted item by clicking anywhere in t
text and choosing List from the Insert menu.

To add an item to a list, click in the list where you want to begin a n
item and press Enter (Windows) or Return (Macintosh).

Creating a numbered list
To create a numbered list:

1. In Edit Page mode, type the list items, starting each item on a new

2. Select the list.

3. Choose Numbered List from the Format menu.

Note You can view the results of a numbered list in Preview Page
mode or in a browser. 

To add an item to a list, click in the list where you want to begin a n
item and press Enter (Windows) or Return (Macintosh).

There are five number styles you can use for a numbered list.

To change the number style:

1. Select the numbered list.

2. Choose Number List Style from the Format menu and select a numb
or letter style.

In Edit Page mode, you see number symbols (#) or X’s in the list. Y
can view your page in Preview Page mode or in a browser to see
actual numbers or letters.

Edit Page mode

Preview Page mode
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Creating a definition list
To create a definition list:

1. Choose Definition List from the Format menu and then choose Term.

2. Type the first term and press Enter (Windows) or Return 
(Macintosh). 

The insertion point is indented and the format changes to Definit

3. Type the definition for the first term and press Enter (Windows) o
Return (Macintosh).

The insertion point moves back out to the left margin and the form
changes to Term.

Repeat steps 2 and 3 for each glossary term and definition you w
to create.

Tip You can tell what the format is for text by clicking the text and
looking at the pop-up menu on the toolbar. The format name chan
in the pop-up menu when you click a paragraph that has a differe
format.

To add an item to a list, click in the list where you want to begin a n
item and press Enter (Windows) or Return (Macintosh).

Creating a nested list
A nested list is indented within another list to show subcategories.

To create a nested list:

1. Type the list and the subcategory list, starting each item on a new

2. Select all of the text.

3. Choose Bullet List from the Format menu.

4. Select the subcategories you want to nest.

5. Click the Increase Indent button  on the toolbar.

To remove the nested list style, click the Decrease Indent button .

Reordering items in a list
You can drag list items to a new position in the list. 
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To select a single list item that you want to reposition, you need to se
the entire item (including the paragraph return at the end of the line

1. Triple-click the item you want to move. 

If you want to move more than one item at a time, hold down the S
key and select the other items.

2. Drag the selected item or items into the left margin of the new locat

Note If you change the order of numbered list items, they’re renumbe
automatically.

Checking your spelling
Claris Home Page provides a spelling checker to help you polish yo
writing. You can check the spelling of all the words in the page you
working on and check individually selected words. You can also use
spelling checker to count the number of words in your Web page or
selection. 

Once you choose one of these options, the Spelling dialog box app
and Claris Home Page begins checking for questionable words.

The spelling checker verifies the words you are checking with those
the main dictionary (that is installed in the Claris folder, see chapter
“Installing Claris Home Page” in the Getting Started guide that 
accompanied your application) and with whatever is the currently 
selected dictionary. If it does not find a word that matches, it sugge
alternatives. If the spelling of the word in question is correct (such as
spelling of someone’s name), you can add the word to a user diction
by clicking Learn if you already have created a user dictionary.

To check the spelling Do this

In a page Choose Spell and then Check Spelling from the Tools menu 
(Windows) or Edit menu (Macintosh).

In selected text Select the words you want to check, and then choose Spell and 
then Check Selection from the Tools menu (Windows) or Edit 
menu (Macintosh).



Adding text to your Web page 3-13

he 

), 

 

.

t.

nt.

 

Click the triangle  to display the questionable word in context in t
bottom of the spelling dialog box.

Changing dictionaries
To change the dictionary that Claris Home Page is currently using, 
choose Spell from the Tools menu (Windows) or Edit menu (Macintosh
and then select Select Dictionaries.

Use this option To do this

Replace Click to replace the questionable word with the word 
selected in the list (changes to Done when check is 
complete). Type a keyboard shortcut (shown to the left of
the word) to replace a word.

Check Type the text in the Word text box you want to check. 
Click Check. The spelling of the word is checked and if 
questionable, a list of optional words appear.

Skip Click to keep the word in question as is and move on to 
another selection.

Learn Click to add the questionable word to the user dictionary

Cancel Click to stop the spelling checker.

Words checked Learn how many words are in the selection or documen

Questionable words Learn how many questionable words are in the docume

Questionable word in context 
text box

See the questionable word in context. Click the triangle to
hide or show the word in context.

Shows questionable words in context
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Editing dictionaries
To edit words in your user dictionary, choose Edit User Dictionary from 
the Edit menu. In the dialog box, you can add a new entry to the 
dictionary, remove entries from the list, edit dictionary entries, impo
dictionary entries from a text file, or export the contents of a dictiona
to a text file.

 

International ProofReader text proofing software © 1995 by Inso 
Corporation. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.

Changing the color of text
You can change the color of all of the text on your Web page and y
can change the color of selected text. Colors assigned to selected te
character styles and therefore override the default color you assign
all text on your Web page.

Use this option To do this

Add Add the entry to the dictionary

Remove Remove a selected entry from the dictionary

OK Apply your changes to the user dictionary and close the dialog box.

Cancel Close the dialog box without making any changes to the user dictiona

Entry Type a new entry or edit a selected entry.

Import Import entries from another dictionary.

Export Export entries from another dictionary.
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You can also change the color of hypertext links. See “Changing th
color of links” on page 7-14.

Note Not all colors are supported uniformly by all Web browsers.

Changing the default color of text
To change the default color for all the text on a Web page:

1. Choose Document Options from the Tools menu (Windows) or Edit 
menu (Macintosh). 

The Options dialog box appears.

2. Click the Appearance tab if necessary, to see a new set of options.

3. Place the pointer over the Text box in the Text Color area and hold the 
mouse button down until the pop-up color palette appears.
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Note You can change the default color palette that appears. See 
“Changing the default color palette display” on page 2-23 for mo
information.

4. Select the color you want for the text.

5. Click OK to close the Options dialog box.

To change the color of all text on your page back to the default setti

1. Choose Document Options from the Tools menu (Windows) or from 
the Edit menu (Macintosh).

2. Click the Appearance tab. 

3. Click Restore Default Colors, and then click OK. 

Your links revert to their default color and any text not assigned a 
specific color character style reverts to the text default color.

Changing the color of selected text
To change the color of selected text:

1. Select the text in your page.

2. Choose Text Color from the Style menu or click the Text Color button 
 on the toolbar and then choose one of the pre-defined colors

choose Other for more options. 

If you choose a pre-defined color, the color is applied to the text y
selected. 

If you choose Other, a Color dialog box appears. Click on the color
you want, and click OK to apply the new color to the text.

Windows: If you want to define a custom color, click Define Custom 
Colors in the Color dialog box. For more information on how to set
custom color, consult your Windows documentation.

Macintosh: If you want to define a custom color, click More Choices 
in the Color dialog box. For more information on how to set a cust
color, consult your Macintosh documentation.

To change the color of selected text back to the default color, chooseText 
Color from the Style menu, and then choose Default.
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Using horizontal rules to separate text
You can use horizontal rules to separate your Web page into sectio
Horizontal rules are objects that you can resize to be short or long, t
or thin. 

Inserting a horizontal rule
You can insert horizontal rules anywhere in your page including ins
table cells. To insert a horizontal rule: 

1. Place the insertion point where you want the horizontal rule to app
in the page.

2. Choose Horizontal Rule from the Insert menu or click the Insert 
Horizontal Rule button  on the toolbar.

Claris Home Page inserts horizontal rules of a size commonly us
by many Web page designers. 

Changing the attributes of the horizontal rule
You can change the size and alignment of the horizontal rule and m
it look like a solid line or recessed in the page

To change the attributes of a horizontal rule: 

1. Double-click the horizontal rule to open the Horizontal Rule Obje
Editor.
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2. Click either the Appearance or Extended tab to change the settings as
appropriate, and then apply the settings by pressing Tab or click
the close box of the Horizontal Rule Object Editor.

Tip You can also use the mouse to change the thickness of a horizo
rule. Click the rule to select it and drag the handle at the bottom of 
rule up or down.

Use this horizontal 
rule attribute setting To do this

Height Change the thickness of the rule. 

Width Change the length of the rule. Choose Percent to make the 
length a percentage of the browser window’s width. Choose
Pixels to make the length a fixed amount that is not affected 
by the browser window’s width.

Alignment Change the alignment of the rule to the left side, right side, o
center of the paragraph or page.

Shade Make the rule look recessed. Deselect to make the rule sol

Extra HTML Attributes Add other HTML attributes to the horizontal rule. (This is an
advanced feature that requires knowledge of HTML; it 
specifies additional parameters for the <HR> tag. For more 
information, see “Adding extra HTML to your page” on 
page 2-16.
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Chapter 4:  Adding images to your Web page

Images that you include on your Web pages can be simple line art 
color photographs. You can use an image for visual effect alone, or
make it function as a clickable link. Make an image interlaced so that 
your audience can see more of the image as it’s downloading onto 
computers. Add a single transparent color to an image to make par
it (like the background) disappear. You can even use an image to cr
a background pattern for your Web page. (For more information, se
“Using an image for the background” on page 2-22.)

Images that you include on your Web page must be in one of the tw
standard formats used on the Web: JPEG (Joint Photographic Experts 
Group) or GIF (Graphics Interchange Format). Claris Home Page 
converts image files in other formats to GIF for you.

Claris Home Page comes with a library of GIF images to use on yo
Web pages. You can also create your own libraries of images. For m
information, see chapter 6, “Using Claris Home Page libraries.”

When you’re deciding where to include images on your Web pages
keep in mind that some browsers don’t support images and sometim
people turn off image loading in their browsers. You can specify an
alternative label that appears in place of the image in these cases.

Web pages with large image files take longer to download. As you 
images to your Web page, you can check how long it will take brows
to download. For more information, see “Using the Statistics window
on page 2-14.

When you’re ready to upload your pages to the Web, you can use C
Home Page to consolidate all the referenced image files into one fol
See “Consolidating media files” on page 12-4 for more information.
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Inserting an image 
When you insert an image into your Web page, Claris Home Page 
creates a pointer to the folder where the image file is stored. Before
add images to your Web pages, make sure the image files are stor
the images folder that you have set up for your Web site (see “Settin
the media folder” on page 1-9 for more information). Then set the 
images folder to be the default location where Claris Home Page st
converted files. (See “Specifying the default converted images folde
on page 4-3.)

To insert an image into your Web page:

1. Place the insertion point in the page where you want the image to ap

2. Choose Image from the Insert menu or click the Insert Image button  
on the toolbar.

You can also add an image to your Web page by dragging it. 

3. In the Open dialog box, select the image file and click Open.

The image appears on the Web page.

If the image is a JPEG or GIF file, Claris Home Page creates a poi
to the current location of the file. If the image is in a different file 
format (such as BMP, TIFF, or PICT), Claris Home Page converts
file to GIF format. 

Note To view JPEG images that you insert into Claris Home Page on
Macintosh, you need QuickTime 2.0 or later installed on your compu
Your audience won’t need this application if their browsers support 
JPEG images.

Converting image files to GIF format
Claris Home Page automatically converts image files such as PICT
BMP files into GIF format when you insert them into a page. 

When Claris Home Page converts an image, it automatically stores
converted image file in the Claris Home Page folder. You can set th
default so that images are automatically stored in your images folde
the site folder, or you can also have Claris Home Page prompt you f
filename and location each time it converts a file. You can also set Cl
Home Page to automatically add an interlacing effect to the conver
images. For a description of what the interlacing effect does, see 
“Creating an interlaced image” on page 4-8.
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Specifying the default converted images folder
To set the default location where Claris Home Page stores the conve
GIF files:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the Images tab to display a new set of options.

3. Select Convert and save automatically to directory (Windows) or Convert 
and save automatically to folder (Macintosh).

4. Click Browse to select the folder you want the converted images 
stored in.

5. Click OK.
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Specifying each filename and location
To set Claris Home Page to prompt you for a filename and location e
time it converts an image file to GIF format:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the Images tab.

3. Select Prompt for File Name/Location and click OK.

When Claris Home Page converts a file, it prompts you to assign
filename and a location for the converted file.

Note When Claris Home Page converts Photoshop or TIFF files, it 
automatically adds the word (converted) to the filename.

Automatically interlacing converted images
When Claris Home Page converts an image into GIF format, an 
interlacing effect is applied to the converted image. You can change
default setting so that Claris Home Page does not automatically ma
every image it converts to GIF interlaced as well. For more informati
see “Creating an interlaced image” on page 4-8.

To remove the default interlacing for converted images:

1. Choose Applications Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh). 

2. Click the Images tab to display a new set of options.

3. Deselect the Make Interlaced GIFs check box.

4. Click OK. 

Note This setting only affects GIF files that Claris Home Page 
automatically converts from other image file formats, such as PICT
BMP files. 
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Using the Image Object Editor
Once you’ve added an image to your page, you can use the Image O
Editor to change the attributes of your image. You can change the 
appearance of an image (such as the size and alignment), add spe
effects to it, and make it behave as a form button or an image map. 
can also use the Image Object Editor to locate the file if the referen
link to it is broken. 

Note You can also make an image into a single hypertext link that y
can click to go to a different page. For more information, see chapte
“Creating links and anchors.” 

You can open the Image Object Editor three different ways:

1 Double-click an image.

1 Click an image, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu (Macintosh)

1 Click an image, and click the Object Editor button  on the toolbar.
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To change the attributes of an image, select the image and then ch
the settings in the Image Object Editor. Click the Appearance tab to see 
more options. To apply the new settings, press tab or click the close
on the Image Object Editor.

Use this 
Appearance setting To do this

Location Locate and re-establish the reference link to a missing file. The
Location text box displays the path of the reference link to the 
image file. Click Browse to select a new path.

Alt Label Type the text that appears in place of the image if a Web browse
doesn’t support images or if your viewer has turned image loading
off. You should always provide an alternative label for important 
images.

Width Change the width of the image. Choose Percent to make the width 
a percentage of the browser window’s width. Choose Pixels to 
make the width a fixed amount that is not affected by the browse
window’s width. For more information, see “Setting the image 
size” next.

Height Change the height of the image. Choose Percent to make the height 
a percentage of the browser window’s height. Choose Pixels to 
make the height a fixed amount that is not affected by the browse
window’s height. For more information, see “Setting the image 
size” next.

Original Size Restore a resized image back to its original size.

Border Change the thickness in pixels of the border around the image. 
setting of 0 makes the border around the image invisible.

Alignment Change how the image is aligned with text in a line or on the pag

Choose Top to align the top of the image with the top of the text 
next to it.

Choose Middle to align the middle of the image with the text next 
to it.

Choose Bottom to align the bottom of the image with the bottom 
of the text next to it.

Choose Left or Right to place the image on the left side or right side 
of the page and have text flow around it. (View your page in a 
browser to see the actual left and right alignment of the image 
within text.)

Transparency and 
Interlacing

Click Set to make a GIF image interlaced or to add transparency
to a GIF image. See “Creating an interlaced image” on page 4-8
and “Adding transparency to an image” on page 4-9 for more 
information.
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To change the behavior of an image, click the Behavior tab and choose a 
setting. For more information, see “Making images interactive” on 
page 4-10. 

To add extra HTML attributes to an image, click the Extended tab and 
type the appropriate HTML. For more information, see “Adding extr
HTML to your page” on page 2-16.

Setting the image size
You can set the size of an image to rescale to the browser window’s 
or to remain fixed as the window’s size changes. Whether you set an
image to rescale in a browser depends on the type of image. For exam
you may not want a photograph to rescale as your viewers resize the
browser windows because it distorts the image, but you may want a sim
border or dividing line to rescale as the browser window changes. 

To set the image size and how it adjusts to the size of a browser win

1. Double-click on the image to open the Image Object Editor.

2. Click the Appearance tab to display a new set of options.

3. Choose the setting type from the Width or Height pop-up menus.

1 Choose Percent to set the size as a percentage of the browser 
window’s width or height.

1 Choose Pixels to set the size as a fixed number of pixels that 
remains unaffected by the browser window’s size.

Use this Behavior 
tab setting To do this

Picture Change a form submit button or image map to a picture.

Form Submit Button Make an image behave like a form submit button.

Image Map Make an image behave like an image map.

Click Edit to open the Image Map Editor so you can add hotspot 
links to the image map. See “Creating an image map” on page 7-
for more information.

Use this Extended 
tab setting To do this

Extra HTML 
Attributes

Type code for additional HTML attributes for your image. (This is an 
advanced feature that requires knowledge of HTML; it specifies 
additional parameters for the <IMG> tag. 
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4. Type the number of pixels or percent for the image’s width or heig

5. Press Enter (Windows) or Return (Macintosh).

Tip Use the mouse to change the width and height of the image 
proportionately. Select the image, hold down the Shift key, and then
drag the lower-right corner handle.

To set the image to its original size, click the Original Size button in the 
Image Object Editor.

Creating an interlaced image
When a Web browser downloads a normal GIF image, the image 
gradually appears, line by line, from top to bottom on the screen. If 
image is large and takes a long time to download, this can be frustra
for someone viewing it. Your audience might have to wait for almost 
entire image to download before they really know what the image is

To avoid this problem, you can change an image so that it is interla
When a browser downloads an interlaced GIF image, a rough outlin
the entire image is displayed first and then detail is gradually added

Note  When Claris Home Page converts image files to GIF format, th
images are automatically set to be interlaced. For more information
image conversion, see “Converting image files to GIF format” on 
page 4-2.

To make an image interlaced:

1. Double-click the image to open the Image Object Editor.

2. Click the Appearance tab, if necessary, to display a new set of option

3. Click Set to open the image file in the Transparency and Interlacin
Image Editor.

4. Click the Interlace button  on the toolbar.

To change the image back into a non-interlaced image, click the Don’t 
Interlace button .

5. Close the Transparency and Interlacing Image Editor and save t
changes to the image file when Claris Home Page prompts you t

The image file is stored and displayed as an interlaced image. 

Tip To open the image in the Transparency and Interlacing Image Ed
using the mouse, right-click (Windows) or Control-click (Macintosh)
the image and choose Transparency and Interlacing from the pop-up menu.
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Adding transparency to an image
You can make a single color in an image transparent so the backgro
of the Web page shows through. This is useful for making the 
rectangular background and outline of an image disappear. It can als
useful for controlling the space between objects or lines of text with
invisible image.

To make the background of an image transparent:

1. If necessary (such as with most scanned images and photograph
use an image-editing program to make the image background a si
color and then add the image to your Web page.

2. Select the image and open the Image Object Editor.

3. Click the Appearance tab to display a new set of options.

4. Click the Transparency and Interlacing Set button to open the image file
in the Transparency and Interlacing Image Editor.

5. Move the pointer over the image until it turns into an eyedropper, a
click to select the color of the image you want to make transpare

All pixels of the selected color become transparent.

Note  You can only make one color transparent in an image.

6. Close the Transparency and Interlacing Image Editor and save t
changes to the image file when Claris Home Page prompts you t

The color you selected in the image becomes transparent so you
see the background of your Web page. To learn how to change t
color or background of your Web page, see “Setting the color an
background of your Web page” on page 2-21.

Tip To open the image in the Transparency and Interlacing Image Ed
using the mouse, right-click (Windows) or Control-click (Macintosh)
the image and choose Transparency and Interlacing from the pop-up menu.

To remove transparency from an image:

1 Open the image in the Transparency and Interlacing Image Edito
and click the Remove Transparency button  on the toolbar.

To use a transparent image to control line spacing:

1. Make a square image that is a single color and the same color a
image’s background (usually white).
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2. Set the size to be a fixed amount of pixels.

3. Make the image transparent.

4. Insert the image between the lines of text you want spaced accor
to the size of the image.

Note You can also insert spacers to separate objects and text on yo
page. See “Using horizontal rules to separate text” on page 3-17, fo
more information.

Making images interactive
You can make images more than just visual elements on your Web
pages. You can make them interactive so your audience can click t
to perform an action.

You can make an image function as:

1 A link, so viewers can click it to go to a different Web page or to 
anchor in the same Web page. 

To make an image into a link, select the image and choose Link to File 
or Link to URL from the Insert menu. For more information, see 
chapter 7, “Creating links and anchors.”

1 An image map, so viewers can click different parts of it to activat
different links. 

To turn an image into an image map, select the image and open
Image Object Editor. Click the Behavior tab, select Image Map and 
click Edit. Draw hotspots in the image and link them to pages in th
Image Map Editor. For more information, see “Creating an image
map” on page 7-8.

1 A submit button in a form, so viewers can click it to send form da
to the server. 

To make an image into a Submit form button, select the image a
open the Image Object Editor. Click the Behavior tab and select Form 
Submit Button. For more information, see “Using an image as a subm
button” on page 9-18.
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Chapter 5:  Adding tables to your Web page

Tables provide a way of organizing and displaying information on yo
Web page. A table is made up of a series of rows and columns. A si
block of information in a table is called a cell and can contain text, 
images, lists, form elements, and other tables. In fact, anything that
be placed in an HTML document can be placed in a table cell. You 
make the background a different color than the rest of the page.

Note Tables are a relatively new part of HTML, and not all browsers
support them. For this reason, before you start creating tables, make
you know who your audience is and what kinds of browsers they us
the majority of your viewers are using browsers that don’t support 
tables, you might want to consider using preformatted text to lay ou
your information. For information on using preformatted style, see 
“Using paragraph styles” on page 3-4.

Inserting a table
There are two ways that Claris Home Page adds a table to your We
page. You can insert an empty table and then add text and images
You can also paste a copy of spreadsheet data or an exported tab-
separated (or tab-delimited) file from a database into your Web page
Claris Home Page formats it into a table. 

Once you’ve created a table, you can use the Table Object Editor to
more rows and columns, and to apply other attributes to the table.

To insert an empty table:

1. Place the insertion point where you want your table to appear on y
Web page.

2. Choose Table from the Insert menu. 

A table with two rows and two columns appears, and the Table Ob
Editor opens.



 

5-2

 

Claris Home Page User’s Guide

   

an 

  

ble 

    

 add 

  

 to 

  

nt, 

dd 
from 

the 
eight 
ns 

 cell 
or 

pen 

ce or 

he 

      
To insert a table of data from another application:

1. Copy the data from a spreadsheet file or tab-delimited text from 
exported database file. 

2. Place the insertion point in the Web page where you want the ta
to go.

3. Choose Paste from the Edit menu.

Claris Home Page inserts a table containing the copied text.

Once you’ve created a table, you can use the Table Object Editor to
more rows and columns, and to apply other attributes to the table.

Adding elements to the table
You add elements—text or images—to a table individually according
the cell you select. 

Note If you select the entire table and start typing or insert an eleme
the table is deleted.

To enter text in a cell, click in the cell to select it and start typing. To a
an image or other element, select the cell and choose the element 
the Insert menu.

As you type, the cell expands downward with all of the other cells in 
same row of the table. The cell also expands to accommodate the h
of an image or other element. The width of the cell, however, remai
the same. For information on changing the width of the cell, see 
“Changing the cell width or height” on page 5-7.

You can copy and paste text, images, and other elements from one
to another in a table, from another open Web page into your table, 
from another application into your table.

You can also drag elements from one cell to another cell or from an o
Web page to your table.

To delete an element in a cell, select the element and press Backspa
Delete. To delete an entire row or column, including its contents, 
double-click one of the cells to open the Table Object Editor, click t
Table tab, and click Remove Row or Remove Column.
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Using the Table Object Editor
Use the Table Object Editor to change the attributes of a table and 
contents of each cell. For example, you can make the border invisibl
your viewers are unaware that the information is contained in a tab
The Table Object Editor appears automatically when you insert a ta
into your page. 

You can also open the Table Object Editor three other ways:

1 Double-click a table border or cell in a table.

1 Click a table or cell, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh).

1 Click a table or cell, and click the Object Editor button  on the 
toolbar.

Note When you select the table border and open the Table Object Ed
only the Table tab settings are displayed. To see the Cells tab settings, 
select a cell in the table.
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Changing table attributes
To change the attributes of a table, select the table and then chang
settings in the Table Object Editor (click the Table tab if necessary). To 
apply the new settings, press Tab or click the close box of the Tabl
Object Editor. See “Resizing a table or parts of a table” on page 5-6
more information. 

Use this table 
attribute setting To do this

Rows Specify the number of rows in the table. Rows are added to and 
subtracted from the bottom of the table. The maximum number of 
rows you can specify is 100.

Add Row Add a row directly below the selected cell or table.

Remove Row Delete the selected row or the bottom row of the selected table a
its contents.

Columns Specify the number of columns in the table. Columns are added t
and subtracted from the right side of the table. The maximum numbe
of columns you can specify is 25.

Add Column Add a column directly to the right of the selected cell or table.

Remove Column Delete a selected column, or the right-most column of a selected
table, and its contents.

Width Change the width of the table. Choose Percent to make the width a 
percentage of the browser window’s width. Choose Pixels to make 
the width a fixed amount that is not affected by the browser 
window’s width. Choose Auto to make the width fit evenly around 
the table elements. For more information on changing the table 
width, see “Changing the table width or height” on page 5-6.

Height Change the height of the table. Choose Percent to make the height a 
percentage of the browser window’s height. Choose Pixels to make 
the height a fixed amount that is not affected by the browser 
window’s height. Choose Auto to make the height fit evenly around 
the table elements. For more information on changing the table 
height, see “Changing the table width or height” on page 5-6.

Spacing Change the amount of space between cells (by making the borde
thicker).

Padding Change the amount of space around the data in cells.

Border Change the thickness of the table borders to make it appear beve
or three-dimensional. A setting of 0 makes the borders of the table 
invisible.

Table Color Change the background color of a table. For more information on
changing the color and background of a table, see “Changing the 
color and background of a table” on page 5-11.
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Changing cell attributes
To change the attributes of a cell, select the cell and then change th
settings in the Table Object Editor. Click the Cells tab if necessary in the 
Table Object Editor to display the cell attribute settings. To apply th
new settings, press Tab or click the close box of the Table Object Ed

Table Image Specify a background image for a table. Click Set to select an image 
file. Click Remove to restore the default background setting.

Extra HTML 
Attributes 

Add other HTML attributes to a table. Requires knowledge of 
HTML. For more information, see “Adding extra HTML to your 
page” on page 2-16.

Use this cell 
attribute setting To do this

Column Width Change the width of all the cells in a column. For more information
see “Changing the table width or height” on page 5-6.

Column Span Change how many columns a cell spans. For more information, s
“Resizing a cell to span rows and columns” on page 5-9.

Row Height Change the height of all the cells in a row. For more information, se
“Resizing a row or column using the mouse” on page 5-9.

Row Span Change how many rows a cell spans. For more information, see 
“Resizing a cell to span rows and columns” on page 5-9.

Horizontal Align Change how elements are horizontally aligned within the cells. Fo
more information, see “Changing the alignment of elements in a 
table” on page 5-10.

Line Wrap Make text wrap in a cell.

Vertical Align Change how elements are vertically aligned within the cells. For 
more information, see “Changing the alignment of elements in a 
table” on page 5-10.

Header Cell Format the selected cell as a table header cell in order to label a r
or column. (Text in header cells appear in bold face type in Claris 
Home Page; they may look different in your browser.)

Cell Color Change the background color of an individual cell. For more 
information, see “Changing the color and background of a table” on
page 5-11.

Row Color Change the background color of an entire row. 

Note The cell color for a specific cell will override its row color 
setting.

Use this table 
attribute setting To do this
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Selecting cells in a table
There are two ways to select cells in a table. You can select multipl
cells in a range or at random.

1 To select a range of cells, hold down the Shift key as you click to
select multiple table cells in a row or column.

1 To select random cells, Ctrl-click (Windows) or Command-click 
(Macintosh) the desired table cells.

Resizing a table or parts of a table
There are different ways you can change the size of a table and the
table’s cells. You can use the Table Object Editor or the mouse to cha
the size of the table, individual cells, or rows and columns.

You can set the size of a table to be a percentage of the browser wind
size so that the table adjusts according to what the size of the windo
Or you can set the size to be a fixed number of pixels so that the tab
always the same size regardless of which browser it appears in.

Note Some browsers that support tables do not support widths meas
in pixels.

Changing the table width or height
You can change the width and height of a table and how it appears
different browser windows by using the Table Object Editor. You ca
also resize a table using the mouse.

To resize a table in relation to the browser window:

1. Double-click on the table border to open the Table Object Editor.

2. Click the Table tab if necessary.

3. Choose a setting type from the Width or Height pop-up menus.

Cell Image Specify a background image for a cell. Click Set to select an image 
file. Click Remove to restore the cell’s default background setting.

Extra HTML
Attributes

Add other HTML attributes to an individual cell in a table. Requires 
knowledge of HTML. For more information, see “Adding extra 
HTML to your page” on page 2-16.

Use this cell 
attribute setting To do this
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4. Type the number of pixels or percent for the table’s width or heig

If you leave the Width or Height boxes empty, the browser used to view
the table will determine the table’s width or height. (In other word
no width or height attributes are added to the <TABLE> tag.) In 
Claris Home Page, the table is tall enough to display the text and
images inside it and is as wide as the window.

5. Press Tab or close the Table Object Editor to apply your change

To resize a table using the mouse: 

1 Select the table.

1 Drag the bottom handle to change the height of the table.

1 Drag the right-side handle to change the width of the table.

1 Drag the lower-right corner handle to change the width and heigh
the same time.

Changing the cell width or height
Changing the size of a cell affects the size of the table and the row 
column that the cell is in. To change the size without affecting other
cells, see “Resizing a cell to span rows and columns” on page 5-9.

Choose this type To have the table sized like this

Pixels Table width or height is always the specified size, measured in
pixels, regardless of the browser window’s size. 

Note Some browsers that support tables do not support table 
widths measured in pixels.

Percent Table width or height appears as the specified percentage of t
browser window width or height.

Auto Table width or height fits evenly around its elements.
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To resize a cell using the Table Object Editor:

1. Select a cell in the table and open the Table Object Editor.

2. Click the Cells tab if necessary.

3. Choose a setting type from the Width or Height pop-up menus.

4. Type a number in the Width text box for column’s width.

5. Type a number in the Height text box for row height.

6. Press Tab or close the Table Object Editor to apply your change

To resize a cell using the mouse:

1 Drag the bottom border of the cell to change the height.

1 Drag the right border to change the width of the cell. 

The size of all the other cells in that row or column changes too.

Note Dragging the handles instead of the border causes the cell to s
columns and rows. See “Resizing a cell to span rows and columns”
page 5-9 for more information.

Choose this type To have the cell sized like this

Pixels Column width or row height is always the specified size, 
measured in pixels, regardless of the browser window’s size. 

Note Some browsers that support tables do not support widths
measured in pixels.

Percent Column width or row height appears as the specified percenta
of the browser window width or height.

Auto Cell width or height fits evenly around its elements.
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Resizing a row or column using the mouse
When you change the cell width or height in a table, the row and colu
that the cell is part of resizes also. You can also resize a row or colu
using the mouse.

Note Some browsers may ignore the size you set for the row or colu
In addition, some browsers may override the specified size if the row
column size you set is too small to display the text or images within t
row or column.

To resize a row or column using the mouse:

1. Select the table.

2. Place the pointer over the border of the row or column you want 
resize.

The pointer changes into a double-headed arrow.

3. Drag the border of the row or column to resize it.

Resizing a cell to span rows and columns
You can resize a cell without affecting the size of other cells by mak
the cell span more than one column or row. This is useful if you wan
make a table heading, for example.

Important  If you resize a cell to span over cells that contain text or 
graphics, the text or graphics are lost.

To change the number of rows or columns a cell spans:

1. Click inside the cell to select it.

A heavy line appears on the inside of the cell.
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2. Open the Table Object Editor.

3. Click the Cells tab if necessary.

4. Type a number in the Span text box for rows or columns you want the
cell to span. 

5. Press Tab or click the close box of the Table Object Editor to app
the changes.

Claris Home Page gives you a warning that resizing the cell may
cause elements in some cells to be deleted. 

Note You can select the Header Cell check box in the Table Object Editor
to format text in the selected cell as a row or column header.

To make a cell span more than one column or row using the mouse

1 Drag the handle to make the cell span more than one column. Th
other cells remain unchanged.

Changing the alignment of elements in a table
Any element that is in a table cell can be aligned to the border of the
and to other elements in a row. You can also align text and images to
left, right, and center of a cell. 

To align text and images to the left, right, or center of a cell:

1. Select the element.

2. Choose Alignment from the Format menu and then choose Align Left, 
Align Center, or Align Right.

To align elements top, middle, or bottom of a cell:

1. Click in the cell to select it.

2. Choose Object Editor from the View menu (Windows) or Show Object 
Editor from the Window menu (Macintosh) or click the Object Editor 
button on the toolbar.

3. Click the Cells tab if necessary.

4. Choose a setting from the Vertical Align pop-up menu.

Choose this setting To have elements aligned like this

Top Elements are aligned at the top of the cell.

Middle Elements are aligned in the middle of the cell.
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Changing the color and background of a table
You can change the color or background image of a table or individ
cells in the table, and make it different than the background of the r
of the page. 

Note Some browsers may ignore cells with no elements. Therefore,
some cells may not display background color settings.

For more information about setting the background of the rest of the
page, see “Setting the color and background of your Web page” on
page 2-21.

To change the color of a table, individual cells, or a row of cells:

1. Select the table or cell you wish to change.

2. Open the Table Object Editor.

3. Click the Table tab if you’re changing the color of a table or the Cells 
tab if you’re changing the color of individual cells.

4. Place the pointer over the Table Color, Cell Color, or Row Color box and 
hold the mouse button down until the pop-up color palette appea

Note You can change the default color palette that appears. For 
information on how to do this, see “Changing the default color pale
display” on page 2-23.

5. Select the color you want for the table or table cell.

A color set for an individual cell overrides the row or table colors

To change the background image of a table or individual cell:

1. Select the table or cell you wish to change.

2. Open the Table Object Editor.

Bottom Elements are aligned at the bottom of the cell.

Baseline Text is aligned by the baseline of each character. The baseline
an imaginary line that divides the main body from the descende
of a lowercase letter, such as a “g” or “j.” This setting is 
generally used in tables where each cell contains a single line o
text. When you are viewing your page in Claris Home Page, 
however, the text will look like it’s top-aligned. Preview the 
page in your browser to see how it will look. 

Choose this setting To have elements aligned like this
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3. Click the Table tab if you’re changing the background of a table or th
Cells tab if you’re changing the background of an individual cell.

4. Click the Table Image Set or Cell Image Set button.

5. In the Open dialog box, select the image file and click Open.
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Chapter 6:  Using Claris Home Page libraries

You can use a Claris Home Page library to store Web page element
copy them onto new pages. For example, you can store logos, navig
buttons, boilerplate text, clip art, tables, form elements, and pieces 
HTML code. A library lets you organize the elements in groups by en
name so they’re easy to find and copy onto your pages.

The library window is like a card catalog: The left section of the windo
lists the entries and the right section displays the contents (the Web 
elements) of each entry. You can copy individual elements from the
right section or you can copy a whole group of elements by dragging
entry name from the left section of the library window onto your pag
When you add an element to the library, you can either add it to an
existing entry or make a new entry for it.

To get you started, Claris Home Page provides library files that con
clip art, animations, images, applets, movies, and styles ready for yo
use. You can use these libraries or your Web pages to create your 
custom libraries.

When you copy Web page elements that reference other files (such
GIF image files, movie files, or applets) from one of these libraries o
your page, you need to save a copy of the referenced files for your 
as well. When you create a new library and add these kinds of elem
to it, you also need to add a copy of the referenced files to the folder
the library file is in. You can use Claris Home Page to do this. See 
“Consolidating media files” on page 12-4.

Opening a Claris Home Page library
To open a library:

1. Choose Library from the File menu and then choose Open or a library 
name from the submenu.

Library names appear in this submenu of all library files that reside
the Contents folder inside the Claris Home Page folder. Library fi
have the .hlb extension.

2. If you chose Open, navigate to the folder where the library file reside
and click Open.
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The library window appears and a new Library menu appears on
menu bar.

Note The GIF image files and other referenced files that are provide
with a Claris Home Page library are stored in the same folder as th
library file (in the Contents folder). When you copy an image from o
of these libraries onto your Web page, the reference is made to the im
file located in that folder. When you want to upload all the files in yo
site to the Web server, you’ll need to have all the referenced image 
located in your site folder. An easy way to copy them into your site 
folder is to use the consolidate images feature. For more informatio
see “Consolidating media files” on page 12-4.
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Using a library
Libraries are useful for keeping common Web page elements organ
in one file and copying them onto new Web pages in your site.

The two new pop-up buttons on the Library toolbar are a way to ins
library elements into your Web page.

To insert a library element into your page:

1. Open the pages you want to insert library elements into and open
library.

2. Select the element in the right-hand section of the library window

3. Place the pointer over the Insert in Page button  on the Library 
toolbar, hold the mouse button down until you see the pop-up me
and then choose a page.

The library element is inserted at the insertion point in the page.

To insert a library element into the background:

1. Open the page you want to insert a library background image into 
open the library.

2. Select the element in the right section of the library window.

3. Place the pointer over the Use As Page Background button  on the 
Library toolbar, hold the mouse button down until you see the pop
menu, and then choose the page.

The Library element is inserted into the background of the page.

You can hide the background in Edit Page mode if you want. To hid
background image:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

2. Click the Images tab to display a new set of options.

3. Deselect the Display background images in Edit Page mode check box.

4. Click OK.

The background is hidden in Edit Page mode but still appears in
Preview Page mode and in the browser.
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To copy library elements using the mouse:

1. Open the pages you want to copy elements into and open the lib

2. Position the library window on your screen so you can see the 
library’s contents and your Web page.

3. Drag elements from the library to copy them onto your pages.

Creating a library
You can create a library to contain references to GIF files and any 
elements that you can place in an HTML file. When you add Web p
elements to a library that reference other files, you should also add
referenced files to the same folder that the library file is in.

To create a library:

1. Choose Library from the File menu and then choose New. 

An untitled library window appears.

To copy Do this

One element Select the element in the right section of the library 
window and drag it onto your page.

All of the elements in an entry Select the library entry in the left section of the librar
window and drag it onto your page. All the elements 
displayed in the right section of the library for the 
selected entry are copied onto your page.



 

Using Claris Home Page libraries

 

6-5

   

t.)

        

ris 

        

ries. 
a 
res, 
n of 
he 
The untitled library window displays an untitled entry on the left 
section and information about library files on the right section.

2. Add elements to the library. (See “Adding entries to a library” nex

3. Choose Save from the File menu.

4. In the dialog box that appears, type a name for your library and 
choose the location for the file.

Note To save a library so that it appears in the File menu in the 
Library submenu, save the file in the Contents folder inside the Cla
Home Page folder.

5. Click Save.

Claris Home Page saves your library with the file extension .hlb .

Adding entries to a library
When you add Web page elements to a library, they’re stored in ent
You can organize your library elements in groups. For example, in 
background library, your entries might be paper textures, floral textu
and so on. When you select the paper texture entry on the left sectio
the library window, the different paper texture elements appear on t
right section.



 

6-6

 

Claris Home Page User’s Guide

 

an 
from 
n 

      

. 

  

ry.

  

 

            

. 

  

ry.

  

 

n of 

      

n 

  

s to 
There are several ways you can add an element to a library—you c
make a new entry and copy elements into it, you can copy elements 
other libraries, you can drag them from your Web page, and you ca
drag files from your desktop into an open library.

To make a new entry:

1. Choose New Entry from the Library menu or click the New Entry button 
 on the toolbar.

An untitled entry appears on the left section of the library window

2. Select the entry name “untitled” and type a name for the new ent

3. Add elements to the entry by pasting or dragging them from your
page into the right section of the library window.

4. Choose Save from the File menu.

To add entries from other libraries:

1. Open both libraries and arrange them side by side.

2. Choose New Entry from the Library menu or click the New Entry button 
 on the toolbar.

An untitled entry appears on the left section of the library window

3. Select the entry name “untitled” and type a name for the new ent

4. Drag each entry from the original library to the right section in the
new library window.

To delete elements from the entry, select them in the right sectio
the library window and press Delete.

5. Choose Save from the File menu.

Editing library entries
The contents of a library can be organized in different ways. You ca
change the order of entries in the list, rename an entry to include 
subcategories and, delete entries in the library window.

Changing the order of entries in the list
You can change the order of entries in the list by dragging their icon
new positions in the left section of the library window. 
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Renaming an entry
To rename an entry:

1. Double-click the entry name in the left section of the library windo

2. Type a new name for the library entry.

3. Choose Save from the File menu.

Deleting an entry
To delete an entry:

1. Click on the entry’s icon in the left section of the library window.

2. Choose Clear from the Edit menu or press Delete.

3. Choose Save from the File menu.

Editing text elements in the library window
You can edit text elements of an entry by using the same tools and
methods you use to edit text on your Web page. Select the text you 
to edit and choose an option. For example, if you want to change a
style to bold, select the text and choose Bold from the Style menu. You 
can also cut, copy, and paste text from another library. See chapter 3
“Adding text to your Web page.”
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Chapter 7:  Creating links and anchors

You can include hypertext links in your Web pages to allow your 
audience to move easily from one page to another within your site, o
other locations and resources on the World Wide Web.

Claris Home Page makes it easy for you to create links from your W
page to other:

1 pages in your site

1 places in the same page

1 sites on the Web

You can also create special kinds of links to pages so they appear 
frames, and links to databases so they appear in forms (see chapte
“Adding frames to your Web page” and chapter 9 “Adding forms to yo
Web page” for more information).

You can make text, images, or specific parts of an image (called an
image map) into hypertext links that connect to pages, anchors in a pa
and other Internet-accessible resources, such as email addresses.

Every page or resource on the World Wide Web needs to have an ad
so that you can link to it. This address is referred to as a URL, or Uniform 
Resource Locator. When you create links to other Web sites or to Inte
resources , you must specify the exact URL of the destination. Howe
when you create a link to another page or anchor within a page in yo
Web site, Claris Home Page automatically inserts the required URL. 

It’s best to have the contents of your Web pages in place before yo
begin creating links. Making a flow chart of your pages can help yo
keep track of where you want to add links and where those links sho
lead. (For more information, see “Outlining the structure of the site” 
page 1-2.)

Linking to pages within your Web site
Any text element or graphic image on your page can be a hypertext
to another page in your Web site. When you set up text or an image
be a hypertext link, you choose the page you want to link to, and Cl
Home Page automatically inserts the destination URL for that link.
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You can also link parts of an image to other pages in your Web site
creating an image map. See “Creating an image map” on page 7-8

Creating a link to a Web page
When you create a link, you select text or an image and specify a 
destination URL for it. By default, a link you create in a page takes y
to the top of the page you’re linking to. To make a link go to a differe
place in the page, you need to create an anchor. See “Linking to an 
anchor in your page” on page 7-3.

To create a link to a Web page in your site:

1. Select the text or image you want to make into a link.

2. Choose Link to File from the Insert menu or click the Link Editor button 
 on the toolbar.

3. Select the name of the Web page you want to link to and click Open.

The text becomes underlined and the color of the text or the ima
border changes to indicate the link.

To remove the visible border from an image link, select the imag
choose Object Editor from the View menu (Windows) or Show Object 
Editor from the Window menu (Macintosh), and type 0 in the Border 
text box.

For information about changing the default color of links, see 
“Changing the color of links” on page 7-14.

4. Save your Web page.

To create another link to the same location or a recently used URL:

1. Select the new text or image you want to make into a link.

2. Choose Link Editor from the View menu (Windows) or Show Link Editor 
from the Window menu (Macintosh).

3. Choose the most recent URL listed at the top of the URL pop-up menu.

You can also click the Browse Files button to locate a file.

Use the pop-up menu to see 
the most recently used URLs.
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For information about testing links, see “Testing the links” on 
page 7-12.

Setting a Base Document URL:  You can specify a Base Document 
URL for the links on a page in your site. This feature can be used fo
complex Web sites that comprise many folders so that the links are
associated with a single document or folder. If your Web site is a sin
folder, this feature is not necessary.

Note Some older browsers do not support the HTML element used 
create the Base Document URL for a page.

Setting a Base Document URL for the links in a page is generally d
before links are created for that page, because it affects all the links
create for that page.

To set the Base Document URL for a page in your site:

1. Choose Document Options form the Tools menu (Windows) or 
Document Options from the Edit menu (Macintosh). 

2. Click the Parameters tab, if necessary

3. Type the complete pathname for the page in your site that will se
as the Base Document URL in the Base Document URL text box. For 
example:

http://domain_name.com/folderB/subfolderB/index.htm

4. Click OK to apply your setting.

Linking to an anchor in your page
When you create a link to a page, the link goes to an anchor at the to
the page. You can create your own anchors and place them anywher
want in the page. When someone clicks on a hypertext link to an anc
the browser displays the part of the page that contains the anchor.

You can create links that jump to anchors on the same page that con
the link or that jump to anchors on other pages in your Web site.

Creating an anchor
To create an anchor in your page:

1. Position the insertion point where you want to place the anchor i
your Web page.
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2. Choose Anchor from the Insert menu, or click the Insert Anchor button 
 on the toolbar.

A dialog box appears with a default name for the anchor.

3. Type a new name for the anchor.

You’ll refer to this name when you create a link to the anchor.

4. Click OK.

An anchor icon  appears on your Web page.

5. Save your Web page.

Creating a link to the anchor
After you’ve created and named the anchor in your page, you can cr
a link to it. 

To create a link to an anchor:

1. Open the Web page that contains the anchor you want to link to.

2. Select the text or image you want to make into a link to the anch

3. Choose Link to URL from the Insert menu, or click the Link Editor 
button on the toolbar.

The Link Editor opens.

4. In the URL pop-up menu, choose the open page that contains the
anchor, and then choose the anchor name from the submenu.
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5. Close the Link Editor and save the page.

The selected text or image becomes underlined and the color of 
text or the image border changes to indicate the link.

To remove the visible border from a linked image:

1. Select the image, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh). 

2. Type 0 in the Border text box.

3. Close the Image Object Editor.

For information about changing the default color of links, see “Chang
the color of links” on page 7-14.

You can test the link in Preview Page mode or Preview in Browser 
mode. For more information, see “Testing the links” on page 7-12.

Tip You can create a link to the anchor by dragging the anchor from 
page to another. When you drag the anchor from one page to anoth
the anchor remains in its original location and a text link to the ancho
inserted in the new location. To create a link in the same page as th
anchor, hold down the Control key (Windows) or Option key 
(Macintosh), and then drag the anchor to the location where you wan
insert the link. By default, the text of the link is #anchorname where 
anchorname is the name of the anchor. 

Choose the name 
of the file
Choose the anchor 
in that file
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Changing the anchor’s attributes
You can change the name of an anchor at any time or add extra HT
to it. Note, however, that any links you’ve made to the anchor must
re-created using the new name you assign.

To rename an anchor:

1. Double-click the anchor icon in your Web page. 

The Anchor Object Editor appears.

2. Type a new name for the anchor in the Name text box.

3. Close the Anchor Object Editor to apply the changes.

To add HTML to an anchor element:

1. In the Anchor Editor, click the Both tab.

2. Type the HTML in the Extra HTML text box.

3. Close the Anchor Object Editor to apply the changes.

Linking to external Web pages and resources
To link to a Web page or other Internet-accessible resources outsid
your Web site, you must know the exact URL for that Web page or 
resource and you must use the correct syntax when you type it into
Link Editor.

To create a link to an external site:

1. Select the text or image you want to make into a link.

Enter the new name 
for the anchor
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2. Choose Link to URL from the Insert menu or click the Link Editor button 
 on the toolbar.

The Link Editor appears.

3. Type the URL of the link’s destination in the URL text box.

You can see some examples of the correct syntax for URLs by 
clicking Show Examples.

Note An example of an Internet-accessible resource is an email 
address.You can use mailto links to send an electronic message to 
specific email address. When mailto links are clicked, the browse
opens an email message window where you can type and send 
message addressed to that email address.

4. Close the Link Editor.

The selected text or image changes to indicate the link.

To remove the visible border from a linked image:

1. Select the image.

2. Choose Object Editor from the View menu (Windows) or Show Object 
Editor from the Window menu (Macintosh).

To link to Use this syntax

A Web page within your Web site file.html

A Web page outside your Web site http://servername/dir/file.html

An anchor on the same Web page #anchorname

An anchor on a page within your Web site file.html#anchorname

An anchor on a page outside your Web site http://.../file.html#anchorname

An FTP site ftp://servername/dir/file.txt

An email address mailto:username@hostname
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3. Type 0 in the Border text box in the Image Object Editor.

For information about changing the default color of links, see “Chang
the color of links” on page 7-14.

To create another link to the same location, select the new text or im
you want to make into a link and choose the most recent URL listed
the top of the URL pop-up menu.

You can test your links to external pages and resources by using th
Preview in Browser mode. For more information, see “Previewing a
testing your site” on page 1-10.

Creating an image map
You can divide an image into multiple parts and link the parts (calle
hotspots) to different pages in your Web site. When you create an ima
map, you link different parts of the image to separate destinations. 

You can create client-side image maps and server-side image map
Client-side image maps are easy to implement, because they elimin
the need for a CGI script, which is required by server-side image m
and they may perform faster because of the reduced demand on th
server processor. However, some older browsers such as Mosaic a
earlier versions of Internet Explorer and Netscape Navigator do not
support the client-side image map.

If you want to accommodate people who have newer browsers and t
who have older browsers, you might consider creating both a client-
and a server-side version of each image map on your Web site. You
might consider using several individual images as links instead of a
image map.

To create either kind of image map, you need to assign hotspots to the 
image. Hotspots are hypertext areas on an image map that people 
click to jump to different URLs.

Circular hotspot

Rectangular hotspot
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Creating a client-side image map
When you create a client-side image map, you draw hotspots over p
of the image and link them to pages or URLs. You can make the ar
of an image that aren’t covered by hotspots link to a default URL. Wh
someone clicks on the image map but doesn’t click on a particular 
hotspot, the default link is activated.

To create a client-side image map:

1. Select the image and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh).

2. Click the Behavior tab, if necessary.

3. Click the Image Map radio button, and then click the Edit button.

The image file opens in the Image Map Editor.

4. Use the Zoom pop-up menu to increase the magnification of the 
image.

5. Select the Rectangular Link  or the Circular Link  tool on the toolbar 
and draw a rectangle or circle over the area of the image that you w
to be a hotspot. 

When you are finished creating the hotspot, the Link Editor appe

6. Type the filename or URL of the link destination in the URL text box 
or choose it from the URL pop-up menu.

URL filename shown
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7. Repeat steps 5 and 6 to create other hotspots in the image.

Claris Home Page consecutively numbers each hotspot as you d
it, with smaller-numbered hotspots in front.

Note If you draw hotspots that overlap each other, hotspots in fro
take precedence over the ones in back. Use the Move Link button
change the order that layered hotspots are used.

8. For areas that aren’t covered by a hotspot, type a URL in the Default 
URL text box or choose it from the Default URL pop-up menu

9. Close the Link Editor and the Image Map Editor.

To remove all hotspots and destination URLs from an image map:

1. Select the image.

2. Choose Object Editor from the View menu (Windows) or Show Object 
Editor from the Window menu (Macintosh). 

3. Click Clear.

Creating a server-side image map
It is useful to provide server-side image maps for members of your W
audience who may have old browsers. Making a server-side image 
work requires an available CGI image map program or equivalent 
software supported by your Web server. You must also choose wha
type of server-side image map is supported by your Web server or 
Internet service provider, NCSA or CERN. 

To set the type of server-side image maps you create:

1. Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh).

Type the URL link destination
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2. Choose the Images tab, if necessary.

3. Set the Image Map Format option to NCSA or CERN.

4. Click OK.

To create a server-side image map:

1. Select the image and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu (Macintosh)

2. Click the Behavior tab, if necessary.

3. Click the Image Map radio button, and then click the Edit button..

The image file opens in the Image Map Editor.

4. Click the Create Server Side Image Map check box.

5. Use the Zoom pop-up menu to increase the magnification of 
the image.

6. Select the Rectangular Link  and the Circular Link  tools to draw 
hotspots in the image.

The Link Editor appears for every hotspot you draw.

7. In the Link Editor, Type the filename or URL for each hotspot link
destination in the URL text box.

To specify a default URL for the image map, type the URL in the
Default URL text box or choose the URL from the pop-up menu ne
to the Default URL text box.

Claris Home Page consecutively numbers each hotspot as you d
it, with smaller-numbered hotspots in front.

Note  If you draw hotspots that overlap each other, hotspots in fro
take precedence over the ones in back. Use the Move Link button
change the order that layered hotspots are used.

8. Save your image map file by choosing Save from the File menu, and 
then close the Image Map Object Editor.

The image map file is named the same as the image file except 
the extension is .map instead of .jpg or .gif. This map file is creat
in the same folder as the image file.

9. With the image still selected in your page, choose Link to URL from the 
Insert menu or click the Link Editor button  on the toolbar.

The Link Editor appears.

10.For most ISPs, you will need to type the pathname of the image-
handling script and map file name in the URL text box. 
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Depending on your ISP, you may type something like this for a C
called “imagemap” and an image file called “picture.gif,” which 
would have a map file called, “picture.map”:

/cgi-bin/imagemap/~myfiles/images/picture.map

Note Check with your ISP for the format of this link.

11.Close the Link Editor.

12.Save your Web page.

Important Talk to your Web server administrator or Internet service 
provider to get the Web server requirements for using a server-side
image map. Some Web server software may have built-in image m
support, and not require an additional CGI, though they still may requ
either a NCSA or CERN image map format. Other servers may req
a special file name extension for the map file other than the .map 
extension that Claris Home Page creates. 

For more information on server-side image map issues, see http://
www.claris.com/support/products/clarispage/.

To remove all hotspots and destination URLs from an image, select
image, open the Image Map Object Editor, and click Clear.

You can test the image map links in Preview Page mode. For more
information, see “Testing the links” on page 7-12.

Testing the links
You can test a link to a page or an anchor in your Web site using Prev
Page mode or a context menu in Edit Page mode. Links to other W
sites or Internet-accessible resources must be tested in a Web brow

You can also use the Site Editor to make sure all the links are corre
before you upload your site to the Web. See “Verifying links and 
references” on page 12-6. 

Before you test the links, make sure you save all of your Web pages
contain the links or are the target of links.

To test a link in Preview Page mode:

1. Choose Preview Page from the View menu (Windows) or the Window
menu (Macintosh) or click the Preview Page button  on the toolbar.
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2. Move the pointer over the link until it turns into a hand  .

3. Click the link.

Claris Home Page displays the linked page. If the link is connecte
an anchor on the page, then the part of the page that contains th
anchor appears at the top of the window.

To test a link using a context menu in Edit Page mode, right-click 
(Windows) or Control-click (Macintosh) the link and choose Follow Link 
from the pop-up menu.

For information about other keyboard and mouse shortcuts you can
in Claris Home Page, see appendix B “Shortcuts for using Claris Ho
Page.”

To test a link to an external Web site or Internet-accessible resourc

1. Click the Preview in Browser  button, and choose a browser from
the pop-up menu. 

Claris Home Page starts the default browser application and ope
the page in it. 

2. Move the pointer over the link until it becomes a hand  and clic
the link. 

See “Previewing your work” on page 2-12 for more information. 

Copying links and anchors
You can copy and paste links or anchors between pages of your Web
rather than re-creating them multiple times. Simply select the link o
anchor and copy and paste as you would normally, or you can drag
from one page to another. To copy a link or an anchor to a location
the same page, hold down the Alt key (Windows) or Option key 
(Macintosh) while you drag it. Claris Home Page copies the entire li
including the link’s address. 

You can also store links and anchors in a library and copy them fro
there into your Web page. See chapter 6, “Using Claris Home Page
libraries” for more information.

For more information about copying elements, see “Cutting, copyin
and pasting” on page 2-7.



7-14 Claris Home Page User’s Guide

k 

lor 

ur 
Deleting links
To delete a hypertext link but not the text or image associated with 
the link:

1. Select the link. 

2. Choose Link Editor from the View menu (Windows) or Show Link Editor 
from the Window menu (Macintosh). 

3. Click Remove Link.

To delete the text or image in addition to the link itself, select the lin
and press Delete.

Changing the color of links
You can change the default color of links in your Web page. The co
of the link can change to show whether it has been clicked or not.

Note  Not all browsers display the colors that you select, so you’ll 
probably want to view your Web pages in your browser to check yo
new color scheme.

To change the color of links:

1. Choose Document Options form the Tools menu (Windows) or 
Document Options from the Edit menu (Macintosh). 

2. Click the Appearance tab, if necessary.
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3. Choose a color from the Text Color pop-up menus for the type of link
you want to change. 

Note You can change the default color palette that appears in the
pop-up menus. See “Changing the default color palette display” 
page 2-23.

4. Select the color you want for that type of link.

5. Click OK.

6. Repeat steps 3 through 5 for each link color you want to change

7. Save your page.

Changing the color of links affects only the document you’re workin
on. To change the color of links of all pages in your site at once, you
do so in the Site Editor. See “Using the Site Editor” on page 2-27.

Choose a color from 
this pop-up menu To change the color of Default color

Normal Link Links that the viewer has never clicked Blue

Visited Link Links the viewer has already clicked Purple

Active Link Links while they are being clicked Red
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Chapter 8:  Adding frames to your Web page

Web browsers usually display a single Web page. It is possible to h
a browser display more than one Web page at a time. You do this b
creating a special kind of frame layout document that is divided into
rectangular sections called frames. When you’re editing frames in the 
page, you cannot add text, images, links, or other elements to them
Frames are simply containers, placeholders that you use to display 
pages. 

A page that uses frames (also known as the root frameset) can show
audience the entire scope of your site in one window and make it ea
navigate through the pages. You can place as many frames in a pa
you like and you can resize the frames and change their orientation.
can place a Web page that contains links in one navigational frame
have the links open different Web pages in another frame.

Note Before you decide to use frames, be aware that they are a ne
feature of the Netscape extensions to HTML 3.0 and aren’t suppo
by many Web browsers. 

Claris Home Page automatically adds an explanatory message to p
that use frames for people who use Web browsers that don’t supp
frames. You should customize this message by changing it in Edi
Page mode and insert a link to a non-frame version of your Web pag
you want.
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Creating a page that uses frames
There are two ways to create a page that uses frames in Claris Hom
Page. You can create a page using the Frame Assistant. The assis
helps you set up your frame layout, create a navigational menu (like
table of contents) and assign existing files to your frames. For more
information on using the Frame Assistant, see “Using site assistants
page 2-4. 

You can also create a page that uses frames without the use of the F
Assistant. To create a page that uses a navigational menu, see “Cre
a navigational frame layout” on page 8-11.

To create a page that uses frames:

1. Open all the Web pages you want displayed in the frames.

2. Choose New from the File menu.

The New dialog box appears. 
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3. If you want to create a page that uses frames yourself, click Create 
New, select Frame Page in the list, and click OK.

If you want to use an assistant to create the page, click Use Assistant, 
select Frame Assistant in the scrolling list, and click OK. Skip the rest 
of these steps and follow the instructions in the Frame Assistant.

4. Select the pages that you want to display in frames by clicking th
check boxes next to each page in the dialog box.

 

If the pages you want displayed in the frames are not open, click Add 
File, select the page, and then click Open. Once selected, the Web pag
appears in the list with a selected check box next to it.

If you don’t select any pages, Claris Home Page creates a page 
two blank frames.

5. Choose Horizontal or Vertical from the Document Orientation pop-up 
menu to set the orientation of the frames.

6. Click OK.

An untitled page containing frames opens displaying the Web pag
the orientation you specified.
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Important Claris Home Page automatically displays pages that us
frames in Edit Frames mode. This is an additional mode availabl
only when you are working with frames. When a page that uses 
frames is open and selected, the Frame menu appears on the m
bar, the Edit Frames button  is selected, and the Subdivide Horizontally 

, Subdivide Vertically , Add Frame , Select Parent Frameset , and 
Select Root Frameset  buttons appear on the toolbar.

Modifying the frame explanatory message
When a page that uses frames is viewed with a browser that does n
support frames, a message appears instead of the page. You can 
customize this message.

To make changes to the alternative message:

1. Switch to Edit Page mode by clicking the Edit Page button  on the 
toolbar.

2. Select the sample text that appears by default and type a new 
message.

You can add formatting styles to the text, insert images and mak
links to other pages in this message.

3. Switch back to Edit Frames mode by clicking the Edit Frames button 
 on the toolbar.

Adding frames to your page
When you first create a page that uses frames, Claris Home Page let
select the pages you want to display in the frames and automatical
creates a horizontal or vertical frame for each page you specify. You
add frames to the page at any time, and divide existing frames into m
horizontal or vertical frames. 

Tip You can rearrange the position of frames on the page by using 
mouse. Simply drag the frame you want to move to its new location
within the page. 

To add a new frame:

1. Select a frame in the page and choose Add Frame from the 
Frame menu. 

An open dialog box appears so you can choose a Web page for the f
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2. Select the page you want displayed in the new frame.

3. Click Open. 

If the frame you selected is a horizontal frame, a new horizontal 
frame is added above it. If the frame you selected is a vertical fra
a new vertical frame is added to the right of it. See “Using the fra
object editors” on page 8-6 for information about changing the 
orientation of horizontal or vertical frames. 

If you want to add a frame without specifying a Web page to display
the frame, choose Add Blank Frame from the Frame menu.

To delete a frame, select the frame and press Backspace (Windows)
Delete (Macintosh).

Creating frames within frames
If you want to have horizontal frames and vertical frames in the sam
page, you need to create frames within a frame. Frames that are gro
together are enclosed by their own border. This type of border is ca
a parent frameset. The border that encloses the entire grouping of fram
on the page is called a root frameset.

To create frames within a frame:

1. Select the frame.

2. Divide the frame into two frames:

1 To divide a frame into two horizontal frames, choose Subdivide 
Horizontally from the Frame menu or click the Subdivide Horizontally 
button  on the toolbar. The single frame is divided into two 
horizontal frames.

1 To divide a frame into two vertical frames, choose Subdivide 
Vertically from the Frame menu or click the Subdivide Vertically 
button . The single frame is divided into two vertical frames

Note You can change the vertical and horizontal orientations of all t
frames in the root frameset or a parent frameset. See “Changing th
orientation of frames” on page 8-10 for more information.
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Using the frame object editors
You can change the attributes of a frame using two frame object edit
You use the Frame Object Editor to assign Web pages to the frame
your page and to change the appearance of the frames (such as th
size). You use the Frame List Object Editor to change the direction
the frames within a frameset. You can have several framesets in a 

You can also use the Frame Object Editor to name the frames and 
open any Web pages you need to make additional edits to. Naming
frames is necessary when you want to create one stationary frame 
holding a table of contents or navigational buttons and another dyna
frame for displaying alternating pages. For more information, see 
“Creating a navigational frame layout” on page 8-11. 

Using the Frame Object Editor
To open the Frame Object Editor, do one of the following:

1 Double-click a frame.

1 Click a frame, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu (Macintosh)

1 Click a frame, and click the Object Editor button  on the toolbar.

To apply the changes you make to a frame, press Tab or close the F
Object Editor. 
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Using the Frame List Object Editor
You can change the orientation of a group of frames within a frame
or all the frames on your page.

To change a group of frames within a frameset, select a frame within
frameset and choose Select Parent Frameset from the Frame menu or click
the Select Parent Frameset button . 

To change all the frames in your page, choose Select Root Frameset from 
the Frame menu or click the Select Root Frameset button .

To open the Frame List Object Editor, select a parent or root frame
and do one of the following:

1 Choose Object Editor from the View menu (Windows) or Show Object 
Editor from the Window menu (Macintosh).

1 Click the Object Editor button  on the toolbar.
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Assigning Web pages to your frames
All frames in the page need to have a Web page assigned to them. C
Home Page prompts you to assign pages when you first create a p
that uses frames and when you add frames to the page. In addition
you can:

1 use the Frame Object Editor to assign a page to a selected fram

1 drag the file icon of a Web page or an anchor icon from an open W
page onto a frame

To assign a page to a frame using the Frame Object Editor:

1. Select the frame and open the Frame Object Editor. 

2. Click the Content tab, if necessary.

3. Specify the filename of the Web page you want to appear in the fra
in the Page Displayed in Frame text box. 

You can either type the URL to the filename in the text box, choo
the URL from the pop-up menu of open or recently opened files,
click the Assign File button to choose the file.

4. Press Tab to apply the new setting.

The Web page appears in the frame.

5. Select each of the other frames in your document and repeat the
steps to assign Web pages to them.

6. Close the Frame Object Editor.

7. Save the page.

Important  Be sure to assign Web pages to all of the frames in your 
document. If a frame is not assigned a Web page, the viewer’s brow
may place a defaulted message.
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Changing the appearance of a frame 
You can use the Frame Object Editor to change the size of frames a
specify whether to display a border or scrolling bars on them. 

To change the appearance of a frame, select the frame, open the F
Object Editor, and click the Appearance tab. To apply the new settings in
the object editor, press Tab or close the object editor.

Tip You can also resize frames using the mouse. Place the pointer ove
border of the frame or frameset until it changes into a double-headed
arrow. Then drag the border to its new position.

Use this frame 
attribute setting To do this

Size Change the size of a frame. 

Choose Percent to make the size a percentage of the browser 
window’s size. 

Choose Pixels to make the size a fixed amount that is not affected by
the browser window’s size.

Choose Stars to make the size of a frame use the remaining space in
the page. This setting acts like a wildcard to match the remaining 
space with the settings of the other frames. For example, if you hav
two frames in the page, and you set the first frame to 40 percent an
the second frame to Stars, the second frame uses the remaining 6
percent of the document. If more than one frame in a document ha
the Stars setting selected, the remaining space is divided up betwe
them proportionately based on the value in the Size text box.

Fixed Size Select if you don’t want the viewer to be able to resize the frame. 
Leave unselected if you want the viewer to be able to resize the 
frame.

Margin Width Specify how far you want the Web page displayed in the frame 
indented from the sides of the frame. You can specify any amount 
from 0-100 pixels.

Margin Height Specify how far you want the Web page displayed in the frame 
indented from the top and bottom of the frame. You can specify any
amount from 0-100 pixels.

Scrollbars Specify whether the frame has a scrollbar or not.

Choose Always if you want the frame to have a scrollbar, Never if you 
don’t want the frame to have a scrollbar, or Auto if you want the frame 
to have a scrollbar when the Web page displayed in the frame is 
larger than the frame itself.

Note It’s a good idea to test how these scrollbars appear in differen
browsers. For more information, see “Testing with different Web 
browsers” on page 1-11.

Show Border Specify whether the frame has a border or not. 



8-10 Claris Home Page User’s Guide

 

, open 

r.

e 

tical 
 the 
tion 
e.

 the 

page.

 

e 
 

e 
nd 

s 
en 
Changing the appearance of a frameset
You can use the Frame List Object Editor to change the size and 
orientation of all the frames in a frameset and to specify whether to
display a border around it.

To change the appearance of a frameset, select the frameset border
the Frame List Object Editor, and click the Appearance tab. To apply the 
new settings in the object editor, press Tab or close the object edito

Tip You can also resize a group of frames using the mouse. Place th
pointer over the border of the frameset until it changes into a double-
headed arrow. Then drag the frameset to its new position.

Changing the orientation of frames
You can change the orientation of a frame or a group of frames to ver
or horizontal. To change the orientation of an individual frame, select
frame, and then drag it to a new location. When you change the orienta
of a group of frames, all the frames within that frameset border chang

To change the orientation of a frameset:

1. Select a frame within the frameset you want to change, and click
Select Parent Frameset button  or Select Root Frameset button .

The root frameset includes all frames and parent framesets on the 

2. Open the Frame List Object Editor.

Use this frame 
attribute setting To do this

Size Change the size of a frameset. 

Choose Percent to make the size a percentage of the browser 
window’s size. 

Choose Pixels to make the size a fixed amount that is not affected by
the browser window’s size.

Choose Stars to make the size of the frameset use the remaining spac
in the page. This setting acts like a wildcard to match the remaining
space with the settings of the other frames. For example, if you hav
other frames in the page, and you set the frameset to 40 percent a
the other frames to Stars, the other frames uses the remaining 60 
percent of the document. If more than one frame in a document ha
the Stars setting selected, the remaining space is divided up betwe
them proportionately based on the value in the Size text box.

Show Border Specify whether the frameset has a border or not. 
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3. Click the Appearance tab.

4. Choose Horizontal or Vertical from the Direction pop-up menu.

All the frames within the frameset change their orientation as 
selected.

Adding other HTML attributes to a frame
You can add your own HTML attributes to a frame or frameset by 
specifying it in the Frame or Frame List Object Editor. 

To specify additional attributes for a frame: 

1. Select the frame, parent frameset, or root frameset and open its o
editor.

2. Click the Extended tab. 

3. Type the desired HTML in the Extra HTML Attributes text box. To apply 
the new settings, press Tab or close the object editor. 

Note This is an advanced feature that requires knowledge of HTML
specifies additional attributes for the <FRAME> tag. 

Creating a navigational frame layout
You can set up a navigational frame that contains a list of links and m
the linked pages display in another frame. This is useful for creating
table of contents for your Web site that always remains visible.
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To create this type of layout you need to create a navigational frame
a target frame, assign a page to each frame, and name the target f
Then you need to create links in the navigational list to the pages in y
site and refer each to the target frame. 

Before you set up the frames, you need to create the pages for your
site, including the page that contains the navigational list. 

To create a navigational frame layout:

1. Open the Web page that contains your navigational list and the f
page you want to display in the target frame.

Usually the first page you want displayed in the target frame is th
first item in the navigational list.

2. Create a page that uses frames by choosing New from the File menu, 
clicking Create New, selecting Frame Page and clicking OK.

A list of the open Web pages appears in the Frame dialog box.

3. Select the page that contains the navigational list and then selec
first page you want displayed in the target frame.

4. Click OK.

An untitled page appears with two frames displaying the two assig
pages in Edit Frame mode.

5. Double-click the target frame to open the Frame Object Editor. 

6. Click the Content tab, if necessary.

Note If you want to change the page that is assigned to the frame, 
the new name in the URL text box or choose it from the URL pop-up 
menu in the Frame Object Editor. 
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7. In the Frame Name text box, type a name for the target frame.

Type a name that’s easy to remember, such as “target.”

8. Close the Frame Object Editor and save the page.

Note To modify the message that your audience will see if their 
browsers don’t support frames, click the Edit Page button on the 
toolbar and type a new message. To switch back to the frames, c
the Edit Frames button.

9. In the page that contains the navigational list, specify the target fra
for each linked page. Do one of the following:

1 If you’ve already created the links in navigational list, you’ll nee
to specify the target frame for each link individually. See 
“Specifying the target frame for linked pages” next.

1 If you haven’t created the links yet, you can set up a default tar
frame that’s automatically referred to by every link you create. S
“Creating links that refer to the target frame” on page 8-14.

Specifying the target frame for linked pages
When you create a navigational frame layout, each item in the 
navigational list that is linked to a page must also refer to the target
frame. You specify the target frame for each link in the navigational 
using the Link Editor. 

Note If you haven’t created the links yet, you can set up a shortcut so 
you’ll only have to specify the target frame once. See “Creating link
that refer to the default target frame” next.

To specify the target frame for each link in the list:

1. In the page that contains the navigational list, select the first item
the list and click the Link Editor button  on the toolbar.

If necessary, click the triangle  to expand the Link Editor.
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Note The name of the page that the item is linked to appears in th
URL text box. (If you haven’t created the link yet, this box is blank
See “Creating links that refer to the default target frame” next.)

2. In the Target Frame text box, type the name of target frame. 

Be sure to match the name of the target frame exactly as you typ
in the Frame Object Editor (for example, “target”).

3. Repeat these steps for every item in the list and save the page.

You can test the page that uses frames in Preview Page mode by clic
the links in the navigational frame and viewing the alternating page
displayed in the target frame.

Creating links that refer to the target frame
You can set up a default target frame that Claris Home Page 
automatically refers to whenever you create a link. This is useful if y
haven’t created the links yet in your navigational list to the pages yo
want displayed in a single target frame. 

Note You can specify a different target frame for individual links in th
Link Editor. 

To create links that automatically refer to the target frame:

1. In the page that contains the navigational list, choose Document 
Options from the Tools menu (Windows) or Edit menu (Macintosh

2. Click the Parameters tab in the Options dialog box.

3. Type the name of the target frame in the Default Target Frame text box.

4. Click OK to close the Options dialog box. 

5. Create links to all the pages by selecting each item in the list, 
choosing Link to File from the Insert menu, selecting the page you wa
to link the list item to and clicking Open. 
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For each link you create, the target frame is automatically specifi
You can change the target frame for an individual link by selectin
the link, opening the Link Editor, and typing a new name in the Target 
Frame text box.

For more information on creating links, see “Linking to external W
pages and resources” on page 7-6. 

You can test the frame layout in Preview Page mode by clicking the
links in the navigational frame and viewing the alternating pages 
displayed in the target frame.
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Chapter 9:  Adding forms to your Web page

Forms provide a way of soliciting information from people who visit 
your site. You can use Claris Home Page to create interactive forms
your audience can use to order a product, provide feedback, fill out
questionnaire, or access a database. 

CGI (common gateway interface) script forms require a CGI that is 
specifically designed to process the data entered by your Web audie
The CGI must run on the Web server. Many Internet service provid
have ready-made CGI programs that need little or no modification to
with the form pages in your site. You can find links to CGI scripts an
CGI resources on the Claris Home Page technical support Web pa
http://www.claris.com/support/products/clarispage/.

Note  You can also create forms that work directly with FileMaker Pr
databases. For more information about using FileMaker Pro with Cl
Home Page, see chapter 10, “Connecting to a FileMaker Pro datab

Inserting a form area 

When you create a form in Claris Home Page, you insert a special f
area in your page to contain the form elements, such as text areas 
check boxes, and a submit button, and the reference link to the CG
script. The form area can contain anything else you want to add, suc
text and images. 

You can have multiple form areas on a page, but each form area can
only one CGI script associated with it to process the data that is ent
in that area.

To insert a form area in Claris Home Page:

1. Place the insertion point in the Web page where you want the fo
to go.

2. Choose Form from the Insert menu, and then choose Form Area from 
the submenu.

A form area with a red border appears in the page, and the Form A
Object Editor opens.
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Once you have inserted the form area, you can add form elements 
other Web page elements to it, and specify the form action (location
the CGI script) in the Form Area Object Editor.

Specifying the form’s CGI script
You use the Form Object Editor to specify the action and method of
form. The form action is the URL of the CGI script on the Web serv
and the method describes how to send the information to the serve
Which action and method you specify depends on the instructions y
receive from the server administrator.

To specify the form’s CGI script:

1. Open the Form Object Editor by double-clicking the red border of 
form area in your page.
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2. In the Action text box, type the path of the data-handling CGI scrip
on the server. For example:

/cgi-bin/public/counters/count.acgi

What you type in the Action text box depends on instructions you 
receive about the CGI script’s name and location on the server. 
Consult your Internet service provider or Web server administrat
for the appropriate information for your form and CGI.

3. Choose Post or Get from the Method pop-up menu. 

Verify this choice with your Web server administrator or Internet 
service provider.

4. Close the Form Area Object Editor.

5. Save your page.

Adding elements to the form
A form area can contain any number of form input elements for you
audience to use. These include text fields, password fields, text are
check boxes, radio buttons, pop-up menus, scrolling lists and submit
reset buttons. You can add hidden entry form elements to store 
information about the form that is hidden from your audience. You c
also add other HTML elements such as text and images to the form 

 

Every form input element needs a name and a value that is used by
CGI script to process the information. After you insert a form eleme
into the form area, you can use its object editor to specify its name 
value. You can also use the element’s object editor to specify other
parameters such as the size that it displays on the page.
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Note  You can change form elements the same way you change oth
Web page elements; that is, you can copy them, move them around
resize them using the same basic methods. See “Cutting, copying, 
pasting” on page 2-7 and “Resizing elements using the mouse” on 
page 2-11 for more information.

Inserting form elements
You can use the Insert menu or the Forms tool palette to insert form
elements into the form area.

To insert a form element using the menu:

1. Place the insertion point in the form area on the page where you w
the element to appear.

2. Choose Form from the Insert menu and then choose an element fro
the submenu.

Claris Home Page inserts the form element and opens its object
editor.

To insert a form element using the Forms tool palette:

1. Choose Forms Palette from the View menu (Windows) or choose Show 
Forms Palette from the Window menu (Macintosh).
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2. Select a form element icon and drag it from the palette to the for
area on your page.

Using the form element’s object editor
You can use the object editor for each form element to set the name
value of the element and other attributes, such as display size.

When you insert a form element into the page, Claris Home Page 
automatically opens its object editor. You can also open the object ed
by doing one of the following:

1 Double-click the form element.

1 Select the form element and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh).

1 Select the form element and click the Object Editor button  on the 
toolbar.

1 Select the element by clicking it so that its selection handles app
and then click the right mouse button (Windows) and choose Form 
Object Editor from the context menu that appears. On Macintosh, ho
down the Control key and then click the mouse button before 
choosing Form Object Editor from the context menu that appears.

Drag this icon To insert this form element

A check box

A radio button

A submit button

A reset button

A text area

A text field

A password field

A scrolling list/pop-up menu
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Adding a text field 

Text fields can contain only one line of text, can be 1 to 500 charac
wide, and can only be resized horizontally. These fields are genera
used for shorter information such as a name or phone number. 

To add a text field to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Form from the Insert menu, and then choose Text Field from the 
submenu.

Claris Home Page inserts a text field form element and opens the 
Field Object Editor.

3. In the Text Field Object Editor, type a descriptive name for the te
field in the Name text box.

For example, Phone Number .



 

Adding forms to your Web page

 

9-7

        

ield 

    

rs 

      

hat 
 is 

  

int 

  

ey 

ere 
is 
 tall 

limit 
d, 

        

 Text 
4. In the Size text box, type a number from 1 to 500.

The number you type here determines the display size of the text f
in the browser window. 

5. In the Max Length text box, type the maximum number of characte
(from 1 to 1000 ) someone can enter in the text field.

6. Close the Text Field Object Editor to apply your settings.

You can enter sample text in the text field to show your audience w
kind of information to enter, and to provide a default value if nothing
entered in the field. 

To enter sample text in the text field:

1 In Edit Page mode, click inside the text field so that the insertion po
appears, and then type your sample text.

Adding a text area 

Text areas allow your audience to enter multiple lines of text, which th
can scroll through using the scrollbars.

The display size of a text area is measured in rows and columns wh
each row is equivalent to one character in height and each column 
equivalent to one character in width. A text area can be 1 to 100 rows
and 5 to 500 columns wide. This display size of a text area does not 
the amount of text that your viewers can enter; if more text is entere
the text area will scroll.

To add a text area to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Form from the Insert menu, and then choose Text Area from the 
submenu.

Claris Home Page inserts a text area form element and opens the
Area Object Editor.
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3. In the Text Area Object Editor, type a short descriptive name in t
Name text box.

4. In the Rows text box, type a number from 1 to 100 to set the height of 
the text area.

5. In the Columns text box, type a number from 5 to 500 to set the width 
of the text area.

6. Choose Virtual, Physical, or Off from the Wrap pop-up menu to set the
type of word wrapping in the text area.

Choose Virtual to wrap text onscreen, but not include line break 
characters with the form data. Choose Physical to wrap text onscreen 
and include line break characters with the data. Choose Off to disable 
word wrapping onscreen, and include line break characters in th
form data if a viewer types them.

7. Close the Text Area Object Editor to apply your settings.

Adding a list of radio buttons
Radio buttons allow your audience to select exactly one choice from
list of options. Only one radio button in a list can be selected at a tim

You need to assign the same name to every radio button in a list so
can work together. In addition, you must assign a unique value to e
radio button or check box to differentiate it from the others in the lis
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To add a radio button to an item in a list in the form area:

1. Place the insertion point inside the red border of the form area, n
to the first item in the list.

2. Choose Form from the Insert menu and then choose Radio Button.

Claris Home Page inserts a radio button form element and opens
Radio Button Object Editor.

3. In the Radio Button Object Editor, type a short descriptive name 
the Button Name text box.

The name you type describes the set or group of items that the r
button belongs to in the list. This name needs to be the same for e
radio button in a group or list and can be letters, numbers or a 
combination of both.

4. In the Button Value text box, type a unique description for the radio
button.

This value needs to be different from every other button in the lis
The values can be letters, numbers or a combination of both. Th
value you type here is returned to you by the CGI script when the
form is submitted and tells you which radio button someone click
in the list.



 

9-10 Claris Home Page User’s Guide

nt 

o a 
any 
g to 
ging 

the 
5. Select Checked if you want the radio button to appear selected by 
default.

The default choice is selected unless the viewer selects a differe
button or check box in the list.

Note Only one radio button in a list can be the default button.

6. Close the Radio Button Object Editor to apply your settings.

Adding a check box
You can add a single check box to a form or multiple check boxes t
list of choices in a form. Check boxes allow the viewer to select as m
choices as they like from the list. Make sure radio buttons that belon
the same group are named the same. Similarly, check boxes belon
to the same group must also be named the same.

To add a check box to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Form from the Insert menu and then choose Check Box.

Claris Home Page inserts a check box form element and opens 
Check Box Object Editor.
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3. In the Check Box Object Editor, type a descriptive name in the Button 
Name text box.

If you have a group of check boxes in a list, the name you type 
describes the group. This name needs to be the same for every c
box in the group and can be letters, numbers or a combination of b

4. In the Button Value text box, type a unique description for the 
check box.

The value you type can be letters, numbers or a combination of b
This value is returned to you by the CGI script when the form is 
submitted and tells you which check box someone has clicked in
form. 

5. Select Checked if you want the check box selected by default.

The check box is selected unless the viewer clicks it.

6. Close the Check Box Object Editor to apply your settings.

Adding a pop-up menu or scrolling list
Pop-up menus and scrolling lists allow your audience to choose fro
list of items. A pop-up menu shows only one item in the list until 
someone clicks on it. A scrolling list shows more than one item, and
your audience can scroll to see the remaining items in the list.

You can specify whether viewers can choose one item at a time or s
multiple items in the list. 

To add a pop-up menu or scrolling list to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Forms from the Insert menu and then choose Pop-up Menu 
from the submenu.

Pop-up menu

Scrolling list
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Claris Home Page inserts a pop-up menu form element and open
Pop-up Object Editor.

3. In the Pop-up Object Editor, type a descriptive name for the pop-
menu in the Name text box.

4. In the Items Visible text box, type the number of items you want to 
appear on the page before your audience interacts with it.

Type 1 if you want the element to be a pop-up menu. Type a num
greater than one (2–100) if you want the element to be a scrolling

5. Select the Allow Multiple Selections check box if you want your 
audience to select more than one item in the list.

If you leave this check box unselected, your audience can select 
one item in the list at a time. 

6. Click Edit Items to create the list of items and specify their values.

The Define Pop-up List dialog box appears. 
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7. In the Define Pop-up List dialog box, click Add to add each new list 
item to the list.

8. In the Title column, type the names of the items as you want them
appear in the pop-up menu or scrolling list.

9. Click in the Check column next to the items that you want to appea
as selected by default in the form.

A checkmark  appears in the Item List scrolling area next to ea
item you specify as a default choice. If the list item appears in a p
up menu, a checkmark indicates that it is selected by default. If t
list item appears in a scrolling list, it’s highlighted to indicate that it
selected.

10.In the Value column, type a description of the list item.

This value can be the same as the item’s title and must be differe
than the other items in the list. You can type letters, numbers or 
combination of both. 

11.Click Remove if you want to delete an item from the list and click OK 
when you’re done.

12.Close the Pop-up Object Editor to apply your settings and save y
page.
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You can test the functionality of the pop-up menu or scrolling list by
clicking on the list items in Preview Page mode. 

To test the pop-up menu or scrolling list:

1 Click the Preview Page button  on the toolbar.

1 Choose list items from the list or click them to select them.

Adding a password field
Password fields are identical in all respects to text fields, except tha
when text is typed in them, the characters display as asterisks or bu
rather than text.

To add a password field to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Forms from the Insert menu and then choose Password from 
the submenu.

Claris Home Page inserts a password field form element and op
the Password Field Object Editor.
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3. In the Password Field Object Editor, type a descriptive name for 
text field in the Name text box.

4. In the Size text box, type a number from 1 to 500.

The number you type here determines the display size of the 
password field in the browser window. 

5. In the Max Length text box, type the maximum number (from 1 to 
1000 ) of characters someone can enter in the password field.

6. Close the Password Field Object Editor to apply your settings.

Adding a reset button
You can add a reset button to the form areas so your audience can re
a form to its original state and clear their form entries. This is helpfu
the viewer makes a mistake or wants to submit new form data.

Reset buttons must call a CGI script to function properly. For this 
reason, you won’t be able to test their functionality in Edit Page or 
Preview Page mode.

To add a reset button to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Forms from the Insert menu and then choose Reset Button from 
the submenu.

Claris Home Page inserts a reset button form element and open
Reset Button Object Editor.
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3. Close the Reset Button Object Editor.

When you add a reset button to your form, a default label, Reset, appears 
in it.

To change this label so that the viewer sees something different: 

1 Double-click the text Reset in the form element to select it and type
the new text. 

Adding a submit button 

You need to include a submit button for your audience to send their
information. Each time someone clicks the submit button, the 
information filled in the form area is sent to the CGI script. 

You can add more than one submit button and assign a different ac
name to each one that corresponds with the different actions suppo
by the CGI script. When someone clicks on a particular submit butt
on your form, the data is sent to the CGI script and handled accordin
the action specified for that submit button. For example, one submi
action name may add a record to a database. Another action name
delete a record.
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Submit buttons must call a CGI script to function properly. For this 
reason, you won’t be able to test their functionality in Edit Page or 
Preview Page mode.

To add a submit button to the form area:

1. Place the insertion point inside the red border of the form area.

2. Choose Forms from the Insert menu and then choose Submit Button 
from the submenu.

Claris Home Page inserts a submit button form element and open
Submit Button Object Editor.

3. If you’re adding more than one submit button to your form, type t
name of the action in the Action Name text box.

The action name identifies how the button works and is not the bu
label.

Note  Some older browsers do not support multiple submit button
associated with separate names and values or actions. Also, act
supported by a CGI will vary from script to script. Check the 
documentation that comes with your CGI script to be sure you use
action name that is supported by your CGI.
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4. Close the Submit Button Object Editor.

When you add a submit button to your form, the default label appea
in it.

To change this label so that the viewer sees something different: 

1 Double-click the text Submit in the form element to select it and type
the new text. 

Using an image as a submit button
You can turn an image into a submit button, so that when someone c
on the image, the form is submitted. 

For information on other ways to use an image, see “Making image
interactive” on page 4-10.

To use an image as a submit button:

1. Insert the image into the form area on your page.

2. Double-click the image to open the Image Object Editor.

3. Click the Behavior tab in the Image Object Editor and select Form 
Submit Button.

4. Click the Appearance tab, type the action name (for example, subm
in the Name text box.

Note  Some older browsers do not support multiple submit button
associated with separate names and values or actions. Also, act
supported by a CGI will vary from script to script. Check the 
documentation that comes with your CGI script to be sure you use
action name that is supported by your CGI.

5. Close the Image Object Editor to apply the new setting.

Adding a hidden entry 

Hidden entry form elements allow you to supply additional informatio
to the CGI script without displaying the information on your Web pag
When viewers submit their forms, hidden entry data is sent to the se
along with the data they have entered in the form.

To add a hidden entry to the form area: 

1. Place the insertion point inside the red border of the form area.
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2. Choose Forms from the Insert menu and then choose Hidden Entry from 
the submenu.

Claris Home Page inserts a hidden entry form element and open
Hidden Form Entry Object Editor.

3. In the Hidden Form Entry Object Editor, type the appropriate valu
in the Entry Name and Entry Value text boxes. The Entry Name 
identifies the value entered in the Entry Value.

4. Close the object editor to apply your settings.

Note Because hidden entries are invisible to the viewer, they don’t 
appear when you view your Web pages in Preview Page mode or i
a browser.
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Testing your forms
Forms are not complete until they behave exactly as you intended, w
includes the data processing that is done by the CGI scripts. 

You can use Preview Page mode to test the functionality of all of th
form input elements except for the reset and submit buttons. 

To test form behaviors, such as the submit and reset buttons, and o
relevant data processing functions, your form must be running on a W
server with the appropriate CGI script as specified in the Form Area
Object Editor. See “Specifying the form’s CGI script” on page 9-2 fo
more information. 

This form element Functions this way in Preview Page mode

Text field You can type in text in the Text Field Object Editor.

Text area You can type in text in the Text Area Object Editor and use th
scroll bars to see all of the text that you typed.

Password field You can type in it as many characters as you specified in the
Password Object Editor. When you type, asteriks or bullets 
appear instead of the characters.

Radio button in a list When you click on the button, all other radio buttons in the lis
(as specified by their group name) are unselected. You can onl
select one radio button at a time.

Check box You can click the check box to select it and unselect it.

Pop-up menu Only one item appears. When you click on the item, the pop-u
menu appears. If you selected Allow Multiple Selections in the 
Pop-up Object Editor, you can select more than one item in the
list and a checkmark appears next to each one.

Scrolling list A scrolling list appears with the number of items you specified.
You can scroll to see more items. If you selected Allow Multiple 
Selections in the Pop-up Object Editor, you can select more than
one item in the list and each one appears highlighted.

Hidden entry Nothing appears.
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Chapter 10:  Connecting to a FileMaker Pro databas

You can use Claris Home Page to create special pages that give yo
Web audience access to a FileMaker Pro 4.0 database file that is o
and shared across a TCP/IP network. The number and type of page
create depend on the level of access or privileges you give your audi
and what features you want to include on your pages.

For a general understanding of HTML forms, see chapter 9, “Addin
forms to your Web page”.

To create FileMaker Pro form pages, you use the CDML (Claris 
Dynamic Markup Language) tags to specify database fields, and 
database actions, such as searching, deleting, duplicating, editing, 
creating new records.

There are two ways to connect your Web site to a FileMaker 4.0 
database:

1 You can use the FileMaker Connection Assistant, which creates 
entire Web site that connects to a FileMaker Pro database. 

1 You can use the FileMaker Connection Libraries of CDML tags a
insert them into existing pages. There are two libraries, the FileMa
Form Library and the FileMaker Reference Library.

You also need FileMaker Pro 4.0, available separately from Claris 
Corporation. FileMaker Pro 4.0 includes the FileMaker Pro Web 
Companion plug-in, which acts as both a Web server and a CGI 
application by serving Web pages over the Internet or an intranet a
processing database requests from the browser.

Preparing the FileMaker Pro database
Most likely, the database you want to publish already has a numbe
records that can be searched by your Web audience. You can also
publish a database that contains no records and have your Web aud
“populate” it by creating records from their browsers.
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Follow these guidelines for preparing the database to be accessed 
the Web:

1 Make sure that the FileMaker Pro database is in good working or
(see the FileMaker Pro documentation for information on recover
corrupt databases and general file maintenance).

1 To avoid character encoding problems, avoid using special charac
such as the following in the database file, layout, and field names
? : @ = & > < # % { } ' | \ ^ ~ [ ] ` ¨ © " (space).

1 The database should have a layout with all the fields that will be u
when the database is accessed from the Web. This layout should
contain any fields that won’t be accessed from the Web.

1 The fields should have the desired formatting (currency, date, 
thousands separator, etc.)

1 If you plan on using the FileMaker Connection Assistant, the 
database file must be open on the machine where you use Claris
Home Page or on the network you have access to.

1 The options for Web sharing must be set for the FileMaker Pro 
application and the database you want to access. See the 
FileMaker Pro documentation for more information on enabling t
FileMaker Pro Web features both for the database and for the 
application itself.

Creating FileMaker Pro forms and sites
When you publish a FileMaker Pro database in your Web site, you 
create pages that support the actions performed by your Web audie
when they interact with the database. Every action is initiated from 
FileMaker Pro form and has two possible responses: success and e
In the case of success the action or request leads to another page 
display the reply or results. In the case of an error, the request lead
an error page that usually explains the error.
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You can design your site, and then use either the FileMaker Connec
Assistant or the FileMaker Form Library to create a site that connect
a FileMaker Pro database. If you use the FileMaker Connection 
Assistant to create the site, you first decide the features and privileg
that you want, and then go through the assistant panels to set up the
When you are done with the assistant, Claris Home Page creates a
necessary pages and links for a basic site that connects to a 
FileMaker Pro database.

If you use the FileMaker Connection Libraries to create a site, you u
the FileMaker Form Library to create FileMaker forms and the 
supporting reply and error pages. When using the FileMaker Form 
Library to create pages, it is not necessary to have the database op
However, it is necessary to have the following information:

1 the filename of the database (For Windows, this includes the *.F
filename extension.)

1 the exact name of each layout in the database that will be used b
FileMaker Pro form pages

1 the exact names of the fields used in the FileMaker Pro form page
your site (It is helpful to print out field definitions to keep track of th
field names.)

1 the exact filenames of all pages that will be in the site, including er
and reply pages

See “Using the FileMaker Connection Libraries” on page 10-24 for 
more information on using the FileMaker Connection Libraries to bu
a site that connects to a FileMaker Pro database.
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Using the FileMaker Connection Assistant
Claris Home Page provides an assistant that you can use to create a
necessary FileMaker forms to connect to a database. With the assis
you specify the filename of the database file and the layout, the fiel
you want to appear on specific pages, and the access privileges an
features you want to provide to your Web audience. The FileMaker
Connection Assistant creates all of the necessary form pages and l
based on the options you choose.

To use the assistant, you need the following:

1 local or remote access to a prepared database, which must be o
before you begin

1 the IP address of the remote computer hosting the FileMaker Pro
database file

1 Export records privileges enabled in the database file

1 TCP/IP networking installed and configured on your computer

1 Web sharing enabled for the FileMaker Pro application and for th
database you want to access.

To open the FileMaker Connection Assistant:

1. Choose New from the File menu.

2. Click Use Assistant.

3. Select FileMaker Connection Assistant in the scrolling list.

4. Click OK.
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The assistant displays a series of panels. When you complete th
settings on a panel, click Next to continue.

Note The assistant is designed to be completed in a single sessio
When you click Cancel, Claris Home Page ends the session, and all 
settings entered up to that point are lost.

5. Click Next to select the FileMaker Pro database that you want you
Web audience to have access to.

Selecting the FileMaker Pro database
On the Database Selection panel in the FileMaker Connection Assis
you see the names of databases running on the server you specify
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To select a database:

1. In the IP Address text box, type the IP address of the computer whe
the FileMaker Pro database is open.

Click This computer to enter the IP address of the computer you are
working on. To connect to a server on the network, ask your netw
administrator for the IP address of the remote computer you wan
access. 

2. Type your user name in the User Name text box, and then type your 
password in the Password text box.

If your database file is set up to use the Web Security database, e
your user name and password. If your database file is using 
FileMaker Pro access privileges for security, enter only the passw
See the FileMaker Pro documentation for more information on 
security and access privileges.

3. Click Connect to server. 

A list of databases appears in the scrolling list of the Database 
Selection panel of the assistant. 

4. Select the database you want, then click Next. 

Important If the connection to a FileMaker Pro database is unsuccess
you will want to verify the following:

1 The files you want to access are running either on your own comp
or over the network.

1 The IP address is correct.

1 The password and user name are correct.

1 The Web companion is set up in the FileMaker Pro application, a
Web sharing is set up for the database file.

Choosing a FileMaker layout
On the Choose a FileMaker Layout panel, you can choose the FileM
layout containing the fields you want. The fields on the layout you se
will be used by the assistant to create the pages of your site. Make
the layout contains all the fields that will be used for the entire site, 
which may include fields for searching and sorting the database as 
as fields that will be used to create new records and to display reco
information. Select the layout name in the Layout pop-up menu, and then
click Next to continue with the FileMaker Connection Assistant.
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Setting features and privileges for your Web audience
On the Feature Selection panel in the FileMaker Connection Assist
you set options for how you want your Web audience to interact wit
your database.

Using the assistant, you can create forms in your Web pages that a
your Web audience to:

1 search the database and view the search results in a list of recor
a page 

1 see a detailed view of each record in the search results
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1 edit, delete, and/or duplicate a record in the detailed view of the 
search results

1 add records to the database

The options you select on the Feature Selection panel determine w
pages the assistant creates. The assistant creates a page for every
you select as well as pages for displaying replies and error messag

If you select this option on 
the Feature Selection panel

The assistant 
creates these pages With these filenames

Search a database for specific 
information and return a list of 
results

Index page
Search page 
Search Results page 
Error page 

default.htm
search.htm
search_results.htm
search_error.htm

View details on individual 
records returned from a search

Index page
Search page 
Search Results page
Details page
Error page 

default.htm
search.htm
search_results.htm
record_detail.htm
search_error.htm

Edit individual records Index page
Search page 
Search Results page
Details page
Edit Reply page
Error pages 

default.htm
search.htm
search_results.htm
record_detail.htm
record_detail_reply.htm
search_error.htm 
record_detail_error.htm

Delete individual records Index page
Search page 
Search Results page
Details page
Delete Reply page
Error pages 

default.htm
search.htm
search_results.htm
record_detail.htm
record_detail_reply.htm
search_error.htm 
record_detail_error.htm

Duplicate individual records Index page
Search page 
Search Results page
Details page
Duplicate Reply page
Error pages 

default.htm
search.htm
search_results.htm
record_detail.htm
record_detail_reply.htm
search_error.htm 
record_detail_error.htm

Add new records to a database Index page
New Record page 
New Record Reply page
Error page 

default.htm
new.htm
new_reply.htm
new_error.htm



 

Connecting to a FileMaker Pro database

 

10-9

   

arch 

  

ite 

        

ro 
pt 

s and 
sing 

      

arch 
rch 

and 
When you click Next, the FileMaker Connection Assistant displays 
additional panels for setting options for each page, based on your 
selections. 

For example, if you create a site that lets your Web audience only se
and view records, the FileMaker Connection Assistant creates the 
following pages:

1 an default.htm that is an entry point into the pages of your Web s
that access a FileMaker Pro database

1 a search.htm page for submitting a search request to the 
FileMaker Pro database

1 a search_results.htm page for displaying search results 

1 a details.htm page for viewing details for a single record

1 a search_error.htm page for displaying an error (for example, “ze
records found”) in processing the search request, which can prom
the viewer to submit the request again.

The FileMaker Connection Assistant creates all the necessary page
saves them in a folder you specify. You can edit the pages further u
the Claris Home Page editing tools and the FileMaker Connection 
Libraries. Choose FileMaker Form Library or FileMaker Reference Library 
from the View menu (Windows) or the Window menu (Macintosh).

Setting Search options
You can specify which database fields you want to appear in the Se
page of your Web site. In addition, you can specify whether the sea
information for each field is to be defined by your Web audience, 
whether the search is fixed, or a combination of fixed search criteria 
criteria specified by your Web audience. 
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The Web audience can type search criteria in the search fields and
specify field comparison operators. For example, in a search for a n
in the Name field of a database, your Web audience can type searc
criteria in the field, and then they can choose “begins with” from the
field comparison pop-up menu. If the Web viewer typed “Ignat” in th
Name field as the search criteria, then the search results return rec
where the first characters of the Name field begin with that string of
characters (for example, Ignat, Ignatius, Ignatowski).

 

In a fixed search, you predefine the search criteria (including the fie
comparison operator) for each field in the search. Your Web audien
does not need to type search criteria in a field or choose the field 
comparison operator.

You can use a fixed search to allow your audience to search for an
display a set of records that is of interest only to them. For example
your database contained daily menu information, your Web audienc
might be accessing your site to see only the menu choices for the d
Your fixed search would be on today’s date, and the search results w
display records (menu information) only for the current date. 

To set up the Search page:

1. Select a field in the Fields list. Then click the Add button. Repeat for 
each field that will appear in the Search page.

All the fields you add appear in the Fields on Search page list.
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2. Select a field in the Fields on Search page list.

The field label is the name of the field as it will appear to your W
audience.

You can change the field label by typing over it in the Field label 
text box.

3. Set the search options for the selected field.

1 If you selected Specified by Web user, choose a field comparison 
operator from the Operator pop-up menu, and then go to step 5.

1 If you selected Fixed, choose the operator for the field, and then
continue.

The operator you choose determines how records match the sea
criteria entered into a particular field. This determines which reco
are displayed in the search results.

Click To

Specified by Web user Have search results based on search criteria your 
audience specifies for that field.

Fixed (“canned”) search Have search results based on the operator and searc
value you specify for that field. 

Choose this field 
comparison operator To show these search results to your Web audience

Equal to Records that match the search criteria exactly

Not equal to All records except those that match the search criteria

Less than Records with values less than the search criteria

Less than or equal Records with values less than or exactly equal to the sea
criteria values

Greater than Records with values greater than the search criteria

Greater than or equal Records with values greater than or exactly equal to the 
search criteria values

Contains Records that contain the character or string of characters 
specified in the search criteria

Begins with Records with the character or string of characters specifie
in the search criteria at the beginning of a value

Ends with Records with the character or string of characters specifie
in the search criteria at the end of a value
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4. For a fixed search, type the search value in the Search value text box 
(For example, for a field called “Shift,” you might type “Full Time”
to find only full time employees). Then go to step 8.

You can type FileMaker Pro search symbols in addition to or inste
of text you type here. For example, to find records with today’s d
in a date field, type two forward slashes (//) in the Search value text 
box for the date field.

Note  The Search value text box is not available unless the Fixed 
(“canned”) search option is selected.

5. For a Web user-defined search, you need to specify the HTML for
(radio buttons, check boxes, pop-up menu, text field, or text area)
the field in the Field format pop-up menu. 

6. To use a value list from the FileMaker Pro database, choose Pop-up 
menu, Radio button, or Check box in the Field format pop-up menu.

Note  The Values list text box is not available if the field format is text
text area, image, or read-only text.

7. Type the name of the value list in the Value list text box.

Note  The Number of items visible and Allow multiple selections options 
are available only when the field format selected is a pop-up men

8. Repeat steps 3 through 7 as appropriate for each field in the Fields on 
Search page list.

9. Click Next.

The Search Page Logical Operator panel appears.
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Setting the Search Page logical operator
The Search page logical operator determines how records are sear
when a search request is submitted.

If the option is set to OR, the records in the search results are retur
based on the search criteria matching one or more fields. If the optio
set to AND, the records in the search results are returned based on a
search criteria matching. 

To set the logical operator for all searches made by your Web audie
click Fixed. To let your Web audience choose the logical operator fo
their searches, click User specified.

After setting the Search page logical operator, click Next. The Search 
Results panel appears.
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Setting options for the Search Results page
Once a search request is submitted, the search results are returned
Web viewer as a list of records that display on a separate Search Re
page. You set options for this page on the Search Results panel in 
FileMaker Connection Assistant.

To set up the Search Results page:

1. Select a field in the Fields list. Then click the Add button. Repeat for 
each field that will appear in the Search Results page.

2. Set the option for the number of records to display per page in th
Matches per page area of the panel. 

The Specified by user option adds a pop-up menu element on the Sea
page, where the Web viewer can make a choice for the maximum
number of records that will display per page of their search results

3. Click Next.

The Sort Results panel appears.
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Setting a sort order for search results
On the Sort Results panel, you can specify whether the results for t
search are sorted or not.

1 If you choose the Yes - Specify a predetermined sort order option, the 
search results are sorted before they are displayed in the search r
page. For this choice, you choose the fields to sort by, and choos
sort order (ascending, or descending) in the next panel of the 
assistant.

1 If you choose the Yes - Allow the Web user to select a field to sort with 
option, the Search page contains a pop-up menu of all the fields
featured on the Search page and a pop-up menu of the sort orde
choices (ascending, descending). The Web viewer can make the
choices for sorting the records that are returned as search result

After setting the sorting options, click Next. If you selected the Yes - 
Specify a predetermined sort order option, the Predetermined sort order 
panel appears. Otherwise, panels for setting up any remaining pag
your Web site appear.
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Setting a predetermined sort order for search results
You can choose to sort search results so that records return to your
audience in a specified order.

To set a predetermined sort order for your search results:

1. Select a field from the Search Results fields list.

2. Click Add.

3. Choose a sort order for the field. 

Ascending is the default value. Descending sorts the records from 
greater values to lesser values. 

4. Repeat these steps for as many fields as you want to sort on.

After setting the predetermined sort order for your search results, c
Next. Panels for setting up any remaining pages in your Web site app



Connecting to a FileMaker Pro database 10-17

d on 
er 
at 

ion 

eb 

nu, 
Setting options for the Details page
The assistant creates the Details page to display an individual recor
an entire page. The Details page for a record appears in the brows
when a Web viewer clicks the link (the contents of the first field for th
record) in the list of records displayed in the Search Results page. 

If you selected record modification privileges on the Feature Select
panel, your Web audience can edit, delete, or duplicate individual 
records from the Details page.

To set up the Details page:

1. Select a field in the Fields list. Then click the Add button. Repeat for 
each field you want to appear in the Details page.

The field label is the name of the field as it will appear to your W
audience.

You can change the field label by typing over it in the Field label text box.

2. Select a field in the Fields on Details page list.

3. Specify the HTML format (radio buttons, check boxes, pop-up me
text field, text area, or read-only text) for the field in the Field format 
pop-up menu. 

Note If you did not choose Edit Individual Records on the Feature 
Selection panel, the Field format pop-up menu, Values list text box, Items 
visible text box, and Multiple selections check box are not shown.
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4. If you want to format the selected field as a pop-up menu, check
boxes, or radio buttons, see step 6 on page 10-12 to use a value
defined in the FileMaker Pro database.

5. Repeat steps 1 through 4 as appropriate for each field on your De
page.

6. Click Next.

If you selected record creation privileges on the Feature Selectio
panel, the next panel that appears is the New Record panel.

Setting options for the New Record page
If you design your site so that your Web audience will be able to cre
new records, you can set options for information they can type and
submit as a new record in the New Record Page panel.

To set options for the New Record page:

1. Select a field in the Fields list. Then click the Add button.

Note FileMaker container, calculation, summary, and related field
cannot be used to create a new record from the New Record pag

2. To change the field label of a field, select the field in the Fields on New 
record page list and change the field label by typing over it in the Field 
label text box.
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3. Specify the HTML format (radio buttons, check boxes, pop-up me
text field, or text area) for the field in the Field format pop-up menu. 

4. If you want to format the selected field as a pop-up menu, check
boxes, or radio buttons, see step 6 on page 10-12 to use a value
defined in the FileMaker Pro database.

5. Repeat steps 2 through 4 as appropriate for each field in your Ne
Record page.

6. Click Next.

The Additional Pages panel appears.

The Additional Pages panel appears and displays information abou
additional reply and error pages that the assistant creates based on
features and privileges you set in previous panels. Click Next, and then 
the Style panel appears.

Setting style options for the FileMaker Pro form pages
On the Style panel of the FileMaker Connection Assistant, you set t
page background and text style of your FileMaker Pro form pages. 

The assistant provides a list of pre-made styles and displays an exa
of each one on the left side of the Style panel. You can change the
and background color of these styles and use your own GIF image 
the background if you want.
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To set the basic page style for your FileMaker Pro form pages:

1. Select a style in the Style scrolling list.

2. Click Custom to enter custom values for the color of text and links 
well as the color of the background.

The Custom Style panel appears.

3. Make your selections for text color and background in the Custom
Style panel.

1 To use an image for the background, select Image in the 
Background area of the panel, and then select the image nam
from the pop-up menu.

1 To import an image, select Import Image in the Background area of
the panel, and then click Browse to locate the image on your 
computer.

4. Click Next to continue with the assistant.

The Final hints and suggestions panel appears. Click Next, and the 
Location panel appears.

Finishing up with the assistant
The last step before finishing the FileMaker Connection Assistant is
specify a location and folder for the files. On the Location panel, clic
New Folder to create a new folder for your site; or click Existing Folder to 
specify the name and location of an existing folder that will contain yo
FileMaker Pro form pages. Then click Create to create the pages.
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The FileMaker Connection Assistant creates the FileMaker Pro form
pages based on the options you specified and inserts all the neces
CDML tags and links. Claris Home Page displays your site in the S
Editor, and opens the ReadMe file for the site you just created with
assistant. You can double-click the icon of any page in the Site Edito
open it and make changes. See “Using the Site Editor” on page 2-27
information on using the Site Editor.

Be sure to click the Consolidate button  on the Site Editor toolbar to 
copy the image files into the new site folder. 

The pages created by the FileMaker Connection Assistant are desi
to be used right away without modification. For information on 
transferring your pages to a server, see “Copying your files to 
FileMaker Pro” on page 10-55 and “Testing the database in your si
on page 10-56 for information on testing the site. 

If you want to customize the appearance of the pages you created 
the assistant, you can use the Claris Home Page editing tools to m
changes. You can use the FileMaker Connection Libraries to edit a
expand the database functionality of the site and to create new 
FileMaker Pro form pages as well. See the following sections “Editi
FileMaker Pro form pages” and “Using the FileMaker Connection 
Libraries” for more information.

Note Some of the CDML tags in the FileMaker Pro form pages that t
assistant creates are required tags. It is better not to edit the requir
CDML tags in the pages the assistant creates. Changing a required
CDML tag (such as the filename of the database the entire site dep
on) in one file requires changing the database filename in other files
refer to it. See “Editing required CDML tags” on page 10-23 for mor
information.

Editing FileMaker Pro form pages
When you use Claris Home Page to create pages that connect to a
FileMaker Pro database, you use CDML tags to specify FileMaker 
commands, actions, and database information. CDML tags are not 
HTML tags and are expressly used for specifying interactions with 
FileMaker Pro. 
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The CDML tags that appear on the pages created by the FileMaker
Connection Assistant let your Web audience search, add, and mod
records. When you create pages using the FileMaker Connection 
Libraries, you drag CDML tags from the libraries onto your pages.

The CDML tags appear in Edit Page mode as objects identified by 
FileMaker icon and the name of the CDML tag. (The CDML tag icon
do not appear in the browser once your site is published.) 

Double-click a CDML tag to display its object editor and to edit 
attributes. Some CDML tags are not editable and are used to displa
links and database information supplied by FileMaker Pro (such as
number of records in a found set). 

To view details of all elements in a page as you work, switch views. Y
can then read comments and tag information.

To view a detailed display in Edit Page mode:

1 Choose Display Mode from the View menu (Windows) or the 
Windows menu (Macintosh), and then choose Detailed from the 
submenu. 

Tip Print from this display mode to examine the tags on your pages m
closely.

You can copy, paste, and move CDML tags the same way you do o
Web page elements. See “Cutting, copying, and pasting” on page 2

Using the CDML tag object editors
Claris Home Page provides object editors that are unique to each 
FileMaker form element. You use these object editors to specify the
database, the layout, the action (if applicable), and various attributes
the element.

To use a CDML tag object editor, do one of the following:

1 Double-click the CDML tag icon.

Basic view in Edit Page mode Detailed view in Edit Page mode
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1 Select the CDML tag icon and choose Object Editor from the View 
menu (Windows) or Show Object Editor from the Window menu 
(Macintosh).

1 Select the CDML tag icon and click the Object Editor button  on the 
toolbar. 

Editing required CDML tags
Some of CDML tags used to specify certain database tasks or action
required in some pages. Most of the required CDML tags are hidden 
that contain the name of the database, the name of the layout used
process a request, and other necessary information for executing th
action or task.

Editing CDML Code tags
The CDML Code tag is used to represent a specific CDML tag who
value(s) come from a FileMaker Pro database file. The CDML Cod
tag is similar to the HTML Code tag (available from the Insert men
which is used to specify actual HTML tags in your page. 

This tag Is used to specify the following information

-Db The filename of the database your pages refer to. This is a hidden entry.

-Lay The name of the layout being accessed in an edit, delete, or duplicate acti
This is a hidden entry.

-Format The filename of the page that confirms a record has been modified or that
action (such as editing, deleting, or duplicating records) has occurred. Th
is a hidden entry.

-Error The filename of the page that is returned if an error occurs in processing t
request to modify the database. This is a hidden entry.

-New A button in the browser that is used by the audience to create a new reco
Text on the button can be edited.

-RecID The unique record identification of the current record so that it can be edite
deleted, or duplicated. This is a hidden entry.

-Edit A button in the browser that is used by the audience to edit or update a 
record. Text on button can be edited.

-Delete A button in the browser that is used by the audience to delete a record. T
on the button can be edited.

-Dup A button in the browser that is used by the audience to duplicate a record
Text on the button can be edited.

The CDML Code tag
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In order to see the behavior of the CDML Code tag, the connection
the FileMaker Pro database must be active, and the page must be 
published in the browser.

To edit a CDML Code tag:

1. Double-click its icon and

2. Type your changes in the scrolling area of the CDML Object Edit

3. Close the CDML Object Editor to apply your settings.

Editing the CDML Code tag is similar to editing HTML.

Using the FileMaker Connection Libraries
The FileMaker Connection Libraries contain the CDML tags you ne
to create a site that connects to a FileMaker Pro database. There ar
FileMaker Connection Libraries that come with Claris Home Page: 
FileMaker Form Library (FileMaker Form.hlb) and the FileMaker 
Reference Library (FileMaker Reference.hlb). 

To use a CDML tag from the FileMaker Connection Libraries:

1. Drag it from the right side of the library window onto your page.

2. Set the attributes for the tag by double-clicking it to display its obje
editor.

3. Close the tag’s object editor to apply the setting.

CDML Code Tag Object Editor
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Using the FileMaker Form Library
In the FileMaker Form Library, CDML tags are grouped according t
how they are used to build pages in the site that connects to a 
FileMaker Pro database. The CDML tag combinations contained in
library entries are used to accomplish the most common database 
actions, such as searching records and modifying the database (cre
editing, duplicating, or deleting records). Each library entry in the 
FileMaker Form Library features notes on the usage and syntax of 
CDML tags as well as the CDML tags themselves, which you can d
onto your pages.

You can use the CDML tag combinations in the FileMaker Form 
Library to quickly build pages that give your Web audience access 
FileMaker Pro database. This library is best used to create an entire
and to learn the relationships between CDML tags.

To open the library:

1 Choose FileMaker Form Library from the View menu (Windows) or 
Windows menu (Macintosh).

On the left side of the library window, the name of the action appear
uppercase as the first level of the library entries. You can click on th
action name (such as SEARCH or NEW RECORD) to read an overview of 
which pages are necessary for executing the action. 
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The names of the pages that pertain to the action (such as Search Page) 
appear as second-level entries on the left side of the library window. 
third level entries (such as Required tags and Specifying search criteria) 
contain the groupings of CDML tags that pertain to a page. Click a th
level library entry to display the CDML tags on the right side of the 
library window.

Using the FileMaker Reference Library
The FileMaker Reference Library lists CDML tags alphabetically. 
CDML tags can be dragged from this library onto your pages. 

To open the library:

1 Choose FileMaker Reference Library from the View menu (Windows) or 
Windows menu (Macintosh).

Click a tag to see a short description.
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Building the Index page
The index page is used by your audience to start a session with yo
FileMaker Pro database—to either search the database or create n
records in it. For example, in the index page (default.htm) created by
assistant, there is a link to the Search page (search.htm) and anothe
to the New Record page (new.htm). You can copy these links and p
them into other pages, so that a session with your FileMaker Pro 
database can be initiated from any page in your site. You can chang
text of the hyperlinks for searching your database or adding new reco

To create a link to any other page in your site that will take the Web
viewer to another FileMaker form page in your site:

1. Create a new blank page.

2. Type the text for your link.

3. Select the text, and then click the Link Editor button  on the 
toolbar.

4. In the URL text box, type your URL according to the following 
syntax, where the URL appears on a single line without spaces, 
“databasename” is the filename of your database; “layoutname” is
name of your layout; and “otherpage.htm” is the name of the 
FileMaker form page you want to display when this link is clicked 
the browser:

FMPro?-db=databasename&-lay=layoutname&-format=other
page.htm&-view

5. Close the Link Editor to apply your setting.

6. Save the Index page.

This tag Is used to specify the following information

-Db The filename of the database for your site

-Lay The name of the layout used by the page you are linking to

-Format The filename of the FileMaker form page you want to link to

-View The action of displaying a format file or page in your site
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Building the Search page
In the Search page, your Web audience can either specify their ow
search criteria, submit a predefined search request that you specify
submit a search request that is a combination of their own search cri
and a predefined request that you specify. 

If you want your audience to be able to specify their own search crite
set up input elements on the Search page. If you define a search re
in advance, your Web audience can just click a button to start a sea
If you want to combine search criteria that is specified by your audie
with search criteria that you specify, your page comprises both type
elements: CDML tags that specify your predefined search criteria, a
input elements where your audience can specify their own search 
criteria.

To build a Search page:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh). 

The FileMaker Form library opens, listing the CDML tags logically
by action. 

3. In the SEARCH section of the library, click the Required tags entry 
under the Search Page entry.

The required tags for a Search page appear on the right of the lib
window.

 

4. Click the tag labeled FileMaker Form to highlight the entire group, then
drag the selection to your Search page.

5. In the same Required tags entry, choose at least one tag for submittin
a search request. Drag one or all the tags into the FileMaker form 
that contains the other required tags.
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6. Specify the attributes for each required tag in the page. Double-c
the icon to display the object editor.

Adding fields to the Search page
You can add fields and choose the format for how they will appear in
Search page. Drag items from the Search Fields section of the Specifying 
search criteria entry in the FileMaker Form Library. 

Note FileMaker container fields cannot be used to define a search 
request.

To use input elements from the FileMaker Form Library:

1. Open the FileMaker Form Library. 

2. In the Specifying search criteria entry, choose the element you want, an
drag it onto the FileMaker form area of your Search page.

For this tag Specify the following information

-Db The filename of the database your pages refer to. This is a hidden en

-Lay The name of the layout being accessed in the search. This is a hidde
entry.

-Format The filename of the page that is returned as a response to the searc
request a request. This is a hidden entry.

-Error The filename of the page that is returned if an error occurs in processin
the search request. This is a hidden entry.

-Find The text on the button used in the browser to submit a search reques

-FindAll The text on the button used in the browser to find all records in your 
database.

-FindAny The text on the button used in the browser to find any (random) recor
in your database.

Drag this element 
to your page To use this format for the search field

Text field A text field form element. See “Adding a text field” on page 9-6 
for more information.

Pop-up menu A pop-up menu or scrolling list form element. 

Note Fields that you want to format as pop-up menus or scrolling
lists must have values associated with them, either defined by yo
in Claris Home Page or defined in value lists in the FileMaker Pro
database. For more information on defining values with Claris 
Home Page, see “Adding a pop-up menu or scrolling list” on 
page 9-11.



10-30 Claris Home Page User’s Guide

en 

er 

:

.

e 
 

e 
r 
 

e 
r 
 

7 

g 
3. Double-click each form element to bring up its object editor, and th
enter the field name to which it corresponds in the Name text box.

4. Close the object editor to apply your settings.

Using value lists from the FileMaker Pro database
Some FileMaker fields in your database file might have a value list 
associated with them to facilitate data entry. Value lists from FileMak
can be used in your Search page.

To use FileMaker Pro value lists for check boxes and radio buttons

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Specifying 
search criteria. 

The search criteria tags appear on the right of the library window

3. In the Search Fields section of the library, choose an HTML input typ
(for example, choose Check Box), and then drag the element into the
FileMaker form area of the Search page.

Check box A check box form element. 

Note Fields that you want to format as check boxes must have 
values associated with them, either defined by you in Claris Hom
Page or defined in value lists in the FileMaker Pro database. Fo
more information on defining values with Claris Home Page, see
“Adding a check box” on page 9-10.

Radio buttons A radio button form element. 

Note Fields that you want to format as radio buttons must have 
values associated with them, either defined by you in Claris Hom
Page or defined in value lists in the FileMaker Pro database. Fo
more information on defining values with Claris Home Page, see
“Adding a list of radio buttons” on page 9-8.

Text area A text area form element. See “Adding a text area” on page 9-
for more information.

Reset A button appearing in the browser. When clicked, this button 
resets all other input elements to their default values. See “Addin
a reset button” on page 9-15.

Drag this element 
to your page To use this format for the search field



Connecting to a FileMaker Pro database 10-31

e 

ox 

 
here 

nter 
r 

.

in 
h 

the 
f the 
4. Double-click the FMP-ValueList tag to display its object editor. Typ
the name of the field in the Field Name text box, and then type the 
name of the value list in the Value List text box.

5. Close the FMP-ValueList Tag Object Editor to apply the setting.

6. Double-click the check box element itself to display the Check B
Object Editor.

7. Type only the name of the field to which it corresponds in the Name 
text box.

8. Close the Check Box Object Editor to apply the setting.

Tip In the browser, the elements within the FMP-ValueList tag area
(denoted by the box with the red border) repeat as many times as t
are values in the value list. You can format the orientation of the 
elements in this tag, so that multiple values appear vertically in the 
browser by typing a carriage return character. Press Enter (or Shift-E
for less white space between lines) on Windows; or press Return (o
Shift-Return for less white space between lines) on Macintosh, 
immediately following the FMP-ValueListItem tag in the 
FMP-ValueList area.

To use FileMaker value lists for pop-up menus:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Specifying 
search criteria. 

The search criteria tags appear on the right of the library window

3. In the Search Fields section, drag the CDML Code tag that appears 
the Pop-up Menu section into the FileMaker form area of the Searc
page.

4. Double-click the CDML Code tag to edit the raw code. Without 
deleting quotation marks, change the words “field name here” to 
field name, and then change “value list name here” to the name o
value list.

5. Close the CDML Code Tag Object Editor to apply the setting.
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Specifying search criteria
When making a search request in the FileMaker Pro database, your 
audience specifies their criteria in the fields on the Search page. Ev
field that is used for searching needs to have an associated rule or 
for how to search it. In addition, the entire find request must have a 
or logic for how it is processed in the FileMaker file. You can set up yo
Search form so that the logic for the search and fields is specified b
your Web audience. You can also predefine the logic for both the fie
and the search request itself, or combine logic that is specified by b
you and your audience. 

To set the logical operator for a search request:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Specifying 
search criteria. 

The search criteria tags appear on the right of the library window

3. For a fixed search request, drag the -LOp (logical operator) tag i
the FileMaker form area in the Search page.

4. Double-click the -LOp tag to display its object editor.

5. Select AND for a search request that matches records to all the 
submitted search criteria exactly or select OR for a search request that
matches records to at least one of the submitted search criteria.

6. Close the -LOp Object Editor to apply the change.

For a search request whose logic will be specified by the Web audie
drag the two -LOp tags denoted by radio buttons into the FileMaker
form area in the Search page.

To set the field comparison operator for each field in a search requ

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Specifying 
search criteria. 

The search criteria tags appear on the right of the library window
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3. For a search request where the field comparison operator is fixe
drag the -Op tag into the FileMaker form area in the Search page

The -Op tag should appear immediately before the field with whi
you associate it.

4. Double-click the -Op tag to display its object editor.

5. Select a field comparison operator from the list.

6. Close the -Op Object Editor to apply the change.

For a search request whose field comparison operators will be spec
by the Web audience, drag the field comparison pop-up menu elem
from the Specifying search criteria section in the library into the FileMaker
form area in the Search page. The field comparison operator shoul
appear immediately before the field with which you associate it.

Choose this field 
comparison operator To show these search results to your Web audience

Equals Records that match the search criteria exactly

Contains Records that contain the character or string of characters
specified in the search criteria

Begins with Records that feature the character or string of characters 
featured in the search criteria at the beginning of a value

Ends with Records with the character or string of characters featured 
the search criteria at the end of a value

Greater than Records with values greater than the search criteria

Greater than or equals Records with values greater than or exactly equal to the
search criteria values

Less than Records with values less than the search criteria

Less than or equals Records with values less than or exactly equal to the sea
criteria values

Not equals All Records except those that match the search criteria
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Setting options for sorting the search results
You can specify whether you want the results of your search to be so
or not and whether the Web viewer initiates the sort. You can also 
predefine a sort order or combine a predefined sort order with choic
for sort order your audience makes before submitting a search requ

To specify the field that search results are sorted by:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Specifying 
sort order. 

The tags for specifying sort order appear on the right of the librar
window.

3. Drag the -SortField and -SortOrder tags into the FileMaker form a
of the Search page.

The -SortField tag must appear directly before the -SortOrder tag
associated with it.

4. Double-click the -SortField tag to display its object editor, and the
type the name of the sort field.

5. Close the -SortField Object Editor to apply your change.

6. Double-click the -SortOrder tag to display its object editor, and th
choose the sort order. For a sort order based on a value list, cho
Custom, and then type the name of the list in the Value List text box.

7. Close the -SortOrder Object Editor to apply your change.

To set up sorting options specified by your Web audience:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, click the entry for Specifying 
sort order. 

The tags for specifying sort order appear on the right of the librar
window.

3. In the Sort Field section, choose the CDML Code tag and drag it in
the FileMaker form area of the Search page.
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The purpose of this tag is to display a pop-up menu of all the field
the layout you specified for the Search page. Your Web audience
choose the field to sort on from this list.

4. In the Sort Order section, choose the sort order element that appear
the Specified by user section. 

This element is a pop-up menu with sorting values (ascending, 
descending) already defined.

5. Drag the element so that it appears directly after the CDML Code
(the sort field) in the FileMaker form area of the Search page.

Setting options for the search results
You can set the maximum number of records displayed in the Sear
Results Page, or you can allow your Web audience to choose a 
maximum from a pop-up list you add to the Search page.

To set the maximum number of records displayed in each Search 
Results page:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Result 
set options. 

The tags for Search result options appear on the right of the libra
window.

3. Drag the -Max tag into the FileMaker form area of the Search pag

4. Double-click the -Max tag to display its object editor.

5. Type a number for the maximum number of records you want 
displayed in a Search Results page.

6. Close the -Max Object Editor to apply your change.

To allow your Web audience to determine the maximum number of
records displayed in the Search Results page:

1 Choose the pop-up list from the Result set options library entry. This 
element requires no modification to be used in the Search page.
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Saving the Search page
Once you have set up the fields and the options for searching and so
you can save and name the Search page. The name of the Search
should correspond to the filename used in all files that refer to it. Fo
example, the Index page file named “index.htm” might refer to the 
Search page file called “search.htm.” 

Building the Search Results page
The Search Results page displays the records that are found or ma
according to the search request made in the Search page. There ar
ways of displaying records in a found set: as a list or as a table. 

Formatting results
The FMP-Record tag appears as an area that contains the fields fo
records in the search results page. In the browser, this record area
repeat depending on the number of records found and the maximum
number of records displayed per page. For information on setting th
maximum number of records displayed per page, see “Setting optio
for the search results” on page 10-35.

To format search results as a list:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh). 

3. In the SEARCH section of the library, select the entry for Displaying 
results under the Search Results Page section. 

4. Drag the FMP-Record tag into your Search Results page.

5. Position the pointer so that it is within the FMP-Record area, and t
copy and paste a FMP-Field tag for every field you want to appea
the area.

FMP-Record tag shown in Detailed display mode
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6. Double-click each FMP-Field tag to display its object editor, and th
type the name of the field for each tag.

7. Close the FMP-Field Tag Object Editor to apply your settings.

8. Add text to the area to create field labels, if necessary.

Tip In the browser, the elements within the FMP-Record tag area 
(denoted by the box with the red border) repeat as many times as t
are records in a found set. You can format the orientation of the elem
in this tag, so that multiple records appear vertically in the browser 
typing a carriage return character. Press Enter (or Shift-Enter for le
white space between lines) on Windows; or press Return (or Shift-
Return for less white space between lines) on Macintosh, immediat
following the last FMP-Field tag in the FMP-Record area.

To format search results as a table:

1. Create a new blank page.

2. Open the FileMaker Form Library. 

3. In the SEARCH section of the library, select the entry for Displaying 
results under the Search Results Page section. 

4. Drag the table element from the library into the Search Results p

The table displays two columns, each with a field and field label. T
row in which the FMP-Field tags appear is identified by a red bord

5. Type over the Field_Label text to replace it with the name of the fie

6. To add more columns (to display fields), double-click the table 
border to display the Table Object Editor.

7. Click the Table tab, and type a number in the Columns text box, or click 
Add Column.

8. Copy and paste the FMP-Field tag so it appears in each addition
column and within the red border.

9. Double-click each FMP-Field tag to display its object editor, and th
type the name of the field for each tag.

10.Close the FMP-Field tag object editor to apply your settings.
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You can set up any table you create with Claris Home Page to disp
results for your search. To do this:

1. Double-click the table border to display the Table Object Editor.

2. Click the FileMaker tab, and then select the Use as FileMaker results table 
check box.

3. Type a number for the row where the FileMaker record informati
will end in the table in the End Repeating at row text box.

The default is 1, but if you are using the first row to display field 
labels (field names), type the number 2.

4. Type a number for the row where the FileMaker record informati
will begin in the table in the Start Repeating at row text box. 

The default is 1, but if you are using the first row to display field 
labels (field names), type the number 2.

5. Close the Table Object Editor to apply your settings.

For search results formatted as lists or tables, the maximum numbe
records displayed per page will vary based on options you set in th
Search page. See “Setting options for the search results” on page 1
for more information.

Building navigational links and text
Your Search Results page can contain tags for navigating to the nex
previous pages of records in a found set as well as links to the Rec
Detail page, which shows one record per page. You can also include
that provide information about the FileMaker Pro found set.

Search results shown in browser
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To add navigational links to the previous and next range of records 
found set:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Navigating 
under the Search Results Page section. 

3. Drag the FMP-LinkPrevious and FMP-LinkNext tags into your 
Search Results page.

4. Place the insertion point so that it is within the FMP-LinkNext and
FMP-Previous areas, and then type the text for the links.

To make the field data that is returned in the Search Results page i
link to the Record Details page for the record displayed:

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Navigating 
under the Search Results Page section. 

3. Drag the special FMP-Field tag in the Link to Record Detail secti
of the Displaying results library entry into the FMP-Record area. 

The special FMP-Field tag is denoted by a blue border in Edit Pa
mode to indicate that it is a link. 

If you are using a table to format the search results, drag the spe
FMP-Field tag into the appropriate table cell (any cell in a row or
rows denoted by the red border). 

4. Double-click the special FMP-Field tag to display its object editor
and then, in the Field Name text box, type the name of the field that wil
be the link to the Record Detail page.

5. Close the special FMP-Field Object Editor to apply your setting.

6. With the FMP-Field tag selected, choose Link Editor from the View 
menu (Windows) or choose Show Link Editor from the Window menu 
(Macintosh). 

7. In the Link Editor, type the name of your record detail page in pla
of “record_detail.htm.” In place of “layout name here,” type the nam
of the layout used by the page you are linking to.

8. Close the Link Editor to apply your setting.
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Including search information and statistics
You can include search information and database statistics in the Se
Results page. Including search information is useful when testing th
pages or to provide information to your Web audience. Tags for 
indicating the current action (find), current database, current layout
current format, and current maximum records per page are example
information you can provide.

To add search information and statistics to the Search Results pag

1. Open the FileMaker Form Library. 

2. In the SEARCH section of the library, select the entry for Search 
information or Statistics under the Search Results Page section. 

3. Drag the tags you want to include in the Search Results page (fo
example, drag FMP-CurrentMax).

4. Type the text you want next to the FMP-CurrentMax icon.

Saving the Search Results page
When you save the Search Results page, the name should correspo
the filename used in all files that refer to it. In the case of the Searc
Results page, its filename is specified in the -Format tag of the Sea
page. For example, the Search page named “search.htm” might ref
the Search Results page called “search_results.htm.” See “Building
Search page” on page 10-28 for more information.

Building the Record Detail page
The Record Detail page displays a single record in an entire page. 
Record Detail page can be read-only, or it can be editable. If the Re
Detail page is editable, it’s the page where your Web audience can 
delete, or duplicate records.

To build a read-only Record Detail page:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh).
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3. In the RECORD DETAIL (READ ONLY) section of the library, select the 
entry for Displaying record data.

4. Drag library elements into the Record Detail page.

5. In your Record Detail page, double-click each CDML tag to displ
its object editor.

6. For each CDML tag, type the name of the field in the Field Name 
text box.

For Portals, type the name of the relationship in the Relationship Na
text box. For the FMP-Field contained in the FMP-Portal tag, type 
name of the relationship and the field in the Field Name text box.

7. Close the object editor to apply the settings.

To build an editable Record Detail page:

1. Create a new blank page.

2. Open the FileMaker Form Library. 

3. In the RECORD DETAIL (EDITABLE) section of the library, select the 
entry for Required tags under the Detail page section. 

The required tags for the Record Detail page appear on the right
the library window.

 

4. Click the tag labeled FileMaker Form to highlight the entire group
then drag the selection to your Record Detail page.

The FileMaker form area appears in the Record Detail page as a
with a red border containing the required tags.

For this type of read-only data Drag this element

Field values FMP-Field

Images from FileMaker container 
fields

The image element in the Field section of the 
library entry

Repeating field values FMP-Repeating tag (containing the 
FMP-RepeatingItem tag)

Portal FMP-Portal tag (containing the FMP-Field tag)
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5. In the same Record Detail page required tags library entry, choose
tags for modifying the database. Drag one or all the tags into the
FileMaker form area that contains the other required tags.

 

6. Specify the attributes for each tag except the -RecID tag. 
Double-click an icon to display its object editor.

Note  Though the -RecID has an editable attribute value, it is bett
not to change it, because it is set up in the FileMaker Form Libra
for use in the Record Detail page.

Adding fields to an editable Record Detail page
You can add and format fields in an editable Record Detail page. D
items from the Displaying record data entry in the FileMaker Form Library 
to the Record Detail page. 

To use input elements from the FileMaker Form Library:

1. Open the FileMaker Form Library. 

For this tag Specify the following information

-Db The filename of the database your pages refer to. This is a hidden
entry.

-Lay The name of the layout being accessed in an edit, delete, or duplica
action. This is a hidden entry.

-Format The filename of the page that confirms that an action (editing, 
deleting, or duplicating records) has occurred. This is a hidden entr

-Error The filename of the page that is returned if an error occurs in 
processing the request to modify the database. This is a hidden ent

-Edit Text on the button in the browser which is used by the audience to
edit or update a record.

-Delete Text on the button in the browser which is used by the audience to
delete a record.

-Dup Text on the button in the browser which is used by the audience to
duplicate a record. 
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2. In the Displaying record data library entry, choose the element you 
want, and drag it onto the Record Detail page.

3. To specify the field names for each element, double-click the CDM
Code tag to display the CDML object editor. 

4. Without deleting quotation marks, change the words “field name 
here” to the field name, and then change “value list name here” to
name of the FileMaker Pro value list.

5. Close the CDML Code Tag Object Editor to apply the setting.

Drag this element 
to your page

To use this format for fields in an 
editable Record Detail page

FMP-Field tag Read-only text value of the field whose name you specify.

Text field A text field form element. See “Adding a text field” on 
page 9-6 for more information.

Pop-up menu A pop-up menu or scrolling list form element. 

Note  Fields that you want to format as pop-up menus or 
scrolling lists must have values associated with them, either 
defined by you in Claris Home Page or defined in value lists in
the FileMaker Pro database. For more information on defining
values with Claris Home Page, see “Adding a pop-up menu o
scrolling list” on page 9-11.

Check box A check box form element. 

Note  Fields that you want to format as check boxes must have
values associated with them, either defined by you in Claris 
Home Page or defined in value lists in the FileMaker Pro 
database. For more information on defining values with Claris
Home Page, see “Adding a check box” on page 9-10.

Radio buttons A radio button form element. 

Note  Fields that you want to format as radio buttons must have
values associated with them, either defined by you in Claris 
Home Page or defined in value lists in the FileMaker Pro 
database. For more information on defining values with Claris
Home Page, see “Adding a list of radio buttons” on page 9-8.

Text area A text area form element. See “Adding a text area” on page 9
for more information.

FMP-Repeating tag 
(containing the 
FMP-RepeatingItem 
tag)

Text values as they appear in a repeating field, where only th
first repetition is editable. The HTML repeats for all the 
repetitions in the specified field.

FMP-Portal tag 
(containing the 
FMP-Field tag)

Text values as they appear in a portal, where only the first 
record is editable. The HTML repeats for each record in the 
portal. 
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Adding an email reply option to an editable Record Detail page
You can have FileMaker Pro send an email message notification to
address you specify whenever the database is modified.

To add an email notification to an editable Record Detail page:

1. Create a new blank page. 

2. Type the message of your email.

3. Choose Save from the File menu. Type email_format  as the title of 
your document.

4. In the Save dialog box, choose FileMaker Include File in the Save as type 
list (Windows) or in the File type pop-up menu (Macintosh).

5. Save the file to your site folder. Click Save.

6. Open the FileMaker Form Library.

7. In the RECORD DETAIL (EDITABLE) section of the library, select the 
E-Mail notification entry.

The required tags for sending email appear on the right of the libr
window.

8. Drag the entire group of tags into the FileMaker form area of you
editable Record Detail page.

9. Double-click each tag within the Mail Tags area to display its obje
editor and set the attributes for each tag.

For this CDML tag Type the following as its attribute

-Mailto The email address of the recipient.

-MailFrom The email address of the sender.

-MailSub The subject of the email.
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Note A FileMaker form area can support only one set of mail tags.

You can edit the email message later on (for example, to include fie
data). For information on how to do this, see the following section, 
“Changing the text of the email message reply file.” 

Saving the Record Detail page
Once you have set up the Record Detail page the way you want, you
save it. The name of the Record Detail page should correspond to 
filename used in all files that refer to it. For example, the Search Res
page called “search_results.htm” might refer to a Record Detail pag
named “record_detail.htm.”

Changing the text of the email message reply file
You can edit the text of the email message used in reply files. Besid
text, you can include CDML tags in the email text file. For example,
including the FMP-Field tag in the email format file lets you include 
field values from the FileMaker file in the body of the email messag

To add CDML tags to an email notification file:

1. Open the file containing the body text of your email notification 
message.

2. In the Claris Home Page dialog box, click the FileMaker Pro HTML 
Include File radio button, and then click OK.

3. Type or edit the text of the message.

4. Choose FileMaker Reference Library from the View menu (Windows) or 
the Window menu (Macintosh).

5. Select the FMP-Field entry.

-MailFormat The filename of the email format file. For example: 
email_format.txt. (This is the body of your email 
message.)

-MailHost The address of the SMTP server host. For example, 
smtp.domain.com

-MailCC (optional) The email address of the person who is carbon copied.

-MailBCC (optional) The email address of the person who receives a blind carbo
copy.

For this CDML tag Type the following as its attribute
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6. Drag the FMP-Field tag into your email_format.txt file. Drag as ma
instances of this tag as necessary for displaying each field value
you want.

7. Double-click each FMP-Field tag to display its object editor.

8. Type the name of the field in the Field Name text box. Do this for each 
FMP-Field tag.

9. Type supporting text next to the FMP-Field tag in the message.

10.Save the email message file.

Building the Record Detail Reply page
If you have given database modification privileges to your Web 
audience, they see a confirmation page in the browser after they mo
the database. Use the Record Detail Reply page to create the mes
provide information about the current action executed, and provide li
to other pages in your site. For information on creating links and 
anchors, see chapter 7, “Creating links and anchors.”

To provide the Web audience with information about the current act
(for example, edit, delete, duplicate) executed:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh).

3. In the RECORD DETAIL (EDITABLE) section of the library, select the 
entry for General information, under the Detail Reply Page section.

4. Drag the tags (for example, drag FMP-CurrentRecordCount) you
want to include in the Record Detail Reply page.

5. Type supporting text next to the FMP-CurrentRecordCount icon.
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6. Save your page.

The name of the Record Detail Reply page should correspond to
filename used in all files that refer to it. For example, the Record
Detail page might have “record_detail.htm” as the filename, and 
Record Detail Reply page might have “record_detail_reply.htm” a
its filename.

Building the New Record page
If you have given record creation privileges to Web viewers, they ca
add a record to the database you publish on the Web. The New Re
page contains input elements, which set up the fields for your Web 
audience to fill in and create a new record. 

To build a New Record page:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh). 

3. In the NEW RECORD section of the library, select the entry for 
Required tags. 

The required tags for the New Record page appear on the right o
library window.

 

4. Click the tag labeled FileMaker Form to highlight the entire group, then
drag the entire selection to your New Record page.

The FileMaker form area appears in the New Record page as a 
with red borders containing the required tags.
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5. Specify the attributes for each required tag. Double-click the icon
display the object editor.

Adding fields and data entry options
You can add fields to the New Record page and choose the format
the fields as they will appear in the New Record page. 

To use input elements from the FileMaker Form Library:

1. Open the FileMaker Form Library. 

2. In the NEW RECORD section, select the Data Entry library entry.

3. Choose the element you want, and drag it onto the FileMaker for
area of your New Record page.

For this tag Specify the following information

-Db The filename of the database your pages refer to. This is a hidden 
entry.

-Lay The name of the layout being accessed to perform a new record actio
This is a hidden entry.

-Format The filename of the page that is returned as a confirmation that a 
record has been added. This is a hidden entry.

-Error The filename of the page that is returned if an error occurs in 
processing the new record request. This is a hidden entry.

-New Text on the button in the browser which is used by the audience to 
create a new record.

Drag this element 
to your page To use this format for the fields in a New Record page

Text field A text field form element. See “Adding a text field” on page 9-6 
for more information.

Pop-up menu A pop-up menu or scrolling list form element. 

Note Fields that you want to format as pop-up menus or scrolling
lists must have values associated with them, either defined by yo
in Claris Home Page or defined in value lists in the FileMaker Pro
database. For more information on defining values with Claris 
Home Page, see “Adding a pop-up menu or scrolling list” on 
page 9-11.

Check box A check box form element. 

Note Fields that you want to format as check boxes must have 
values associated with them, either defined by you in Claris Hom
Page or defined in value lists in the FileMaker Pro database. Fo
more information on defining values with Claris Home Page, see
“Adding a check box” on page 9-10.
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4. Double-click each form element to bring up its object editor, and th
type the field name to which it corresponds in the Name text box.

5. Close the object editor to apply your settings.

See also “Using value lists from the FileMaker Pro database” on 
page 10-30 for information on using fields with FileMaker value lists
the New Record page.

Adding an email reply option to a New Record page
You can have FileMaker Pro send an email message notification to
address that you specify whenever a record is added to the databa

To add an email notification or reply to a New Record page:

1. Create a new blank page.

2. Type the message of your email. This is the body of your email 
message.

3. Choose Save from the File menu. Type email_format  as the title of 
your document.

4. In the Save dialog box, choose FileMaker Include File in the Save as type 
list (Windows) or in the File type pop-up menu (Macintosh).

5. Save the file to your site folder. Click Save.

6. Open the FileMaker Form Library.

7. In the NEW RECORD section of the library, select the E Mail notification 
entry.

The required tags for sending email appear on the right of the libr
window.

Radio buttons A radio button form element. 

Note Fields that you want to format as radio buttons must have 
values associated with them, either defined by you in Claris Hom
Page or defined in value lists in the FileMaker Pro database. Fo
more information on defining values with Claris Home Page, see
“Adding a list of radio buttons” on page 9-8.

Text area A text area form element. See “Adding a text area” on page 9-
for more information.

Reset A button appearing in the browser. When clicked, this button 
resets all other input elements to their default values. See “Addin
a reset button” on page 9-15.

Drag this element 
to your page To use this format for the fields in a New Record page
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8. Drag the entire group of tags into the FileMaker form area of you
New Record page.

9. Double-click each tag within the Mail Tags area to display its obje
editor and set the attributes for each tag.

Note A FileMaker form area can support only one set of mail tags.

You can edit the email message later on (for example, to include fie
data). For information on how to do this, please see, “Changing the 
of the email message reply file” on page 10-45.

Saving the New Record page
Once you have set up the New Record page the way you want, you
save it. The name of the New Record page should correspond to th
filename used in all files that refer to it. For example, the Index pag
might have filename “index.htm,” and it may refer to the New Recor
page filename, “new_record.htm.”

For this CDML tag Type the following as its parameter

-Mailto The email address of the recipient.

-MailFrom The email address of the sender.

-MailSub The subject of the email.

-MailFormat The filename of the email format file. For example: 
email_format.txt.

-MailHost The address of the SMTP server host.

-MailCC (optional) The email address of the person who is carbon copied.

-MailBCC (optional) The email address of the person who receives a a blind 
carbon copy.
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Building the New Record Reply page
The New Record Reply page is the confirmation page that is prese
to the Web audience after they have added a record. You can creat
message in this page (for example, “Thank you. You have success
created a new record.”) in this page as well as provide links back to o
pages in your site using the Claris Home Page editing tools.

To provide the Web audience with information about adding a new 
record:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh). 

3. In the NEW RECORD section of the library, select the entry for 
Displaying record data under the New Reply Page section.

4. Drag the tags (for example, drag FMP-Field) you want to include
the New Record Reply page.

5. Type supporting text next to the FMP-Field icon.

6. Save your New Record reply page.

The name of the New Record Reply page should correspond to the
filename used in all files that refer to it. For example, the New Reco
page might have filename “new_record.htm,” and it may refer to the
New Record Reply page filename, “new_record_reply.htm.”

Building the error pages
You can create the following error pages based on the actions and 
privileges you set for your Web audience: 

1 a Search Error page for errors that occur while processing a sea
request.

1 a Record Detail Error page for errors that occur while processing
request to edit, delete, or duplicate records.

1 a New Record Error page for errors that occur while processing 
request to create a new record.
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Displaying error information
To display error information generated by FileMaker Pro:

1. Create a new blank page.

2. Choose FileMaker Form Library from the View menu (Windows) or the
Window menu (Macintosh).

3. Select the entry for the error page you want:

1 Error handling in the Search Error Page section

1 Error handling in the Detail Error Page section

1 Error handling in the New Error Page section

4. Select the FMP-CurrentError tag, and then drag the tag to your E
page.

5. Type supporting text in the error page. For example, “An error of ty
FMP-CurrentError occurred.”

6. Save and name the error page as it corresponds to the action.

The names of the error pages must correspond with the filename
used in the form pages where the action is initiated, and as spec
by the -Error tag. For example, the Search page might have the 
filename, “search.htm” and it may refer to the error page, 
“search_error.htm.”

Handling errors
You can use the FMP-If tag to handle errors and display error mess
conditionally. This can be useful for providing meaningful feedback
your Web audience when an error occurs.

To handle errors conditionally:

1. Open the error file you want to edit.

2. Open the FileMaker Form Library.

3. Select the entry for the error page you want:

1 Error handling in the Search Error Page section

1 Error handling in the Detail Error Page section

1 Error handling in the New Error Page section

4. Select the FMP-If tag, and then drag it onto your error page.

5. Double-click the FMP-If tag to display its object editor.
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6. Type the condition for the error tag in the Condition text box. Use the 
following syntax (in this case, the example pertains to a search e
where zero records are found):

currenterror.eq.401

7. Close the FMP-If tag object editor to apply the setting.

8. Place the insertion point so that it is inside the FMP-If tag area, a
then type the message that will display when the condition is me

The FMP-If area can contain CDML tags.

9. Save and name the error page as it corresponds to an action.

The names of the error pages must correspond with the filename
used in the form pages where the action is initiated and as speci
by the -Error tag. For example, the New Record page might have
filename, “new_record.htm” and its error page might be 
“new_record_error.htm.”

This example tests for error number 401, which corresponds to zer
records found. See the FileMaker Pro error code numbers in the 
FileMaker Pro online Help topic “Status(CurrentError) function” for 
possible results. See the following section for a list of comparison 
operators, such as .eq.

To add to this example and test for additional errors:

1 Add an FMP-If tag for every additional test. 

Alternatively, you can use the FMP-If/FMP-Else tags to display a mess
if the condition is true and another message if the condition is false.

FMP-IF and FMP-Else in Detailed Display Mode
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Displaying content conditionally
You can use the FMP-If and FMP-Else tags to display HTML in a pa
conditionally. A useful application of this feature is for displaying 
messages in reply and error pages.

There are reserved words or codes that can be used to specify a 
condition. The comparison operators that can be used are indicated
the following table.

Using a True/False condition
A true/false or Boolean expression can be used to test a condition. 
comparison operators that can be used for a true/false condition ar
equals (.eq.) and not equals (.neq.). For example, to test if the data
is sorted, you can use this syntax in specifying the condition in an 
FMP-If tag:

IsSorted.eq.False

Using a numeric comparison condition
Use the following codes or reserved words to test numbers or spec
error numbers or numeric information or statistics on the current stat
the FileMaker Pro database. You can use all comparison operators
except for contains (.cn.) and does not contain (.ncn.).

This comparison operator Indicates

.eq. Equals

.neq. Not equals

.gt. Greater than

.gte. Greater than or equal to

.lt. Less than

.lte. Less than or equal to

.cn. Contains

.ncn. Does not contain

This number Indicated by this code Can be used as in this example

Current error number CurrentError CurrentError.eq.509

Records in found set CurrentFoundCount CurrentFoundCount.gte.100
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Using a text comparison condition
When using a text comparison condition, all comparison operators 
allowed. As a general rule, any CDML tag that returns alphanumeri
characters can be used in a text comparison condition. Use only th
name of the tag to specify a condition. For example:

CurrentDate.gte.10/10/96

ClientPassword.eq.password_name

Fieldname.cn.literal_value

Copying your files to FileMaker Pro
Before copying your files to FileMaker Pro, it’s a good idea to open yo
site folder in the Site Editor and perform media consolidation and 
verification of links and references. See chapter 12, “Uploading you
pages to a Web server” for information on how to do this. 

You can copy your site folder to the FileMaker Pro host computer us
your network software to mount the server volume and copy your fi
onto it. Copy the contents of your site folder into the Web folder, whi
is located in the FileMaker Pro application folder.

See the FileMaker Pro documentation for more information.

Current maximum number 
of records on a page

CurrentMax CurrentMax.lte.50

Current records in 
database

CurrentRecordCount CurrentRecordCount.gt.1000

Current record number CurrentRecordNumber CurrentRecordNumber.gt.500

Current number of 
records skipped at the 
beginning of a range

CurrentSkip CurrentSkip.lt.20

Record number of the last 
record in a range

RangeEnd RangeEnd.neq.20

Number of records shown 
in range

RangeSize RangeSize.eq.40

Record number of first 
record in range

RangeStart RangeStart.eq.1

This number Indicated by this code Can be used as in this example
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Testing the database in your site
As you develop your site, it’s a good idea to look at your pages from
point of view of your Web audience, using a browser. Using the sam
computer, you can edit your pages in Claris Home Page, and then 
FileMaker Pro and your browser software to view the results. Ideall
you would run all three applications at once and make modifications
you go.

To test your site on the same computer or on a computer on your 
network:

1. Copy the contents of your site folder to the Web folder in the 
FileMaker Pro application folder on your computer or on a compu
on your network.

2. Start FileMaker Pro, and then open your database file.

3. If necessary, set options to enable the FileMaker Pro Web 
Companion and to share the database file.

Select the Web Companion plug-in in Application Preferences an
choose Sharing from the File menu. Configure the Web Companion
User Interface to the home page of your site, or the default.htm p

4. Start your browser.

5. Type the following URL as the location, where “IP_address” is the
address of the computer that is running FileMaker Pro.

http://IP_address/

6. Press Enter.

Your home page or index page (default.htm) appears in the browse
You can test the links to go to a search or add records page, subm
request, and then view the results both in the browser and in the 
FileMaker file.

As you edit files in Claris Home Page, you can save them to the We
folder, and then click Reload in the browser. It is recommended that 
set the options for clearing the disk cache in your browser, so that o
the most recent versions of your files are displayed in the browser as
save and re-save your pages.
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Chapter 11:  Adding multimedia to your Web page

Multimedia includes not only JPEG and GIF images, but movies, sou
animation, and objects that allow people to interact with your Web pa
It offers you a way to make your Web page more appealing to your
audience. With Claris Home Page, you can quickly add Quicktime 
movies, Java applets, and other types of multimedia to your Web p
to make it stand out and draw your audience in.

Some types of multimedia, such as QuickTime movies, require exte
helper applications on your audience’s machines in order to view or h
them. In addition, their browsers require specific plug-in applications
be able to recognize and display the multimedia.

You can use Claris Home Page to provide an alternative message 
your viewers who can’t see your multimedia and a way for them to 
download the necessary helper application or browser plug-in.

Adding multimedia that rely on browser plug-ins
Web browser plug-ins are small applications that extend the capabil
of the browser to read your files in a specific way. Plug-ins make it 
possible for browsers to support more than HTML, JPEG, or GIF fil
on the Web. They tell the browser to open files in a specific applicat
on your computer. For example, a QuickTime plug-in tells the brow
to open any files that have the QuickTime extensions .mov or .snm in
QuickTime application on your computer.

With Claris Home Page, you can insert multimedia and specify 
parameters or change its attributes in the Plug-in Object Editor.

Inserting multimedia into your page
When you insert multimedia into your Web page, Claris Home Page
creates a reference link to the multimedia file and displays an icon 
represents the file in Edit Page mode. To view or hear the actual me
use Preview in Browser mode. 

To insert multimedia that requires a browser plug-in:

1. Place the insertion point in the page where you want the multime
to appear and choose Plug-in from the Insert menu.
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A message appears warning you to not select an actual plug-in, 
the multimedia file for it instead.

2. Click OK.

3. In the Open dialog box, select the multimedia file and click Open.

An icon representing the multimedia file appears on your Web pa

Opening the Plug-in Object Editor 
Once you have inserted a multimedia file into your page, you can use
Plug-in Object Editor to change the location of the file, specify the wid
and height of the multimedia display, and provide a URL that has a p
in available for downloading.
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To open the Plug-in Object Editor, do one of the following:

1 Double-click the multimedia icon.

1 Click the multimedia icon, and choose Object Editor from the View 
menu (Windows) or Show Object Editor from the Window menu 
(Macintosh).

1 Click the multimedia icon, and click the Object Editor button  on the 
toolbar.

To apply the new settings, press Tab or click the close box of the P
in Object Editor.

Setting multimedia options 
In the Plug-in Object Editor, you can set Claris Home Page to:

1 specify a new path to where the multimedia file is located

1 change the width and height of how the multimedia is displayed

1 specify a link to a required plug-in for your viewers to download i
they don’t have the plug-in installed in their browsers

To update the path to where a multimedia file is located:

1. Select the multimedia icon in your Web page and open the Plug-
Object Editor.

2. In the Location text box, type a new path or click Browse to locate the 
multimedia file and enter a new path.

Note When you click Browse, a message appears warning you to no
select an actual plug-in, but the multimedia file for it instead. Click OK.
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To change the display size of the multimedia using the Plug-in Obje
Editor:

1. Select the multimedia icon in your page and open the Plug-in Ob
Editor.

2. Choose Pixels or Percent and type a new size in the Width and Height 
text boxes.

1 Choose Pixels to make the size a fixed amount that is not affect
by the browser window’s size.

1 Choose Percent to make the size a percentage of the browser 
window’s size. 

Tip Press Tab to apply a new setting without closing the object ed

3. Close the object editor to apply your changes.

To change the display size using the mouse:

1. Select the multimedia icon.

2. Drag one of the handles to change the size. 

1 Drag the bottom handle to change the height. 

1 Drag the right-side handle to change the width of the plug-in. 

1 Drag the lower-right corner handle to change the width and hei
at the same time.

To specify a link to a required plug-in: 

1. Select the multimedia icon in your page and open the Plug-in Ob
Editor.

2. Type the URL for the appropriate plug-in page in the Plug-in Page text 
box.

When your audience cannot see the multimedia on your page beca
the required plug-in is missing from their systems, their browsers 
display a message similar to this: 

“This page contains information of type “xxxx” that can only be 
viewed with the appropriate plug-in. What do you want to do?” 

If they click the Plug-in Info button to get the plug-in, the plug-in pag
that you specified in the Plug-in Object Editor appears. Clicking Can
closes the message.
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Adding extra HTML to the multimedia element
You can add your own HTML directly to the plug-in element using th
Plug-in Object Editor. 

Note This is an advanced feature that requires knowledge of HTML
specifies additional parameters for the <EMBED> tag.

To add extra HTML, double-click the plug-in icon to open the Plug-i
Object Editor. Click the Extended tab and type the HTML in the Extra 
HTML Attributes text box. The HTML that you type is added to the 
<EMBED> tag.

Adding a QuickTime movie to your Web page
You can add a QuickTime movie to your Web page and set it to 
automatically play when a browser downloads the page or include a
movie controller allowing your audience to start the movie when the
want. 

Your audience must have the appropriate QuickTime plug-in 
application for their browsers as well as a QuickTime movie player 
their computers in order to view the movie. When you insert a 
QuickTime movie into your Web page, Claris Home Page automatica
inserts a link to the QuickTime Web site where these applications a
available for downloading. If your viewers do not have these 
applications on their computers, they will see a dialog box where th
can activate this link. 

QuickTime movies must have the extension .mov or .snm for a We
browser to recognize them. In addition, if you create a QuickTime mo
on a Macintosh, you must “flatten” the movie (remove the resource fo
so that it can play on all platforms. Flattening is not necessary for mo
created in QuickTime for Windows. A flattening tool is available at th
QuickTime Web site.

Note You must preview your page in a Web browser for the movie 
to run.

Inserting the QuickTime movie
When you insert a movie into your Web page, Claris Home Page 
displays a movie icon in your Web page while in Edit Page mode. T
view the actual movie, you use Preview in Browser mode.
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To insert a QuickTime movie into your Web page:

1. Place the insertion point in the page where you want the movie t
appear and choose QuickTime Movie from the Insert menu.

2. In the Open dialog box, select the QuickTime movie file (it must ha
the .mov or .snm extension) and click Open. 

If you have QuickTime installed, a movie icon appears on your 
Web page. 

Opening the QuickTime Object Editor
Once you insert the QuickTime movie into your Web page, you use
QuickTime Movie Object Editor to set the play options, and change
other attributes of the movie, such as the width and height. You can 
use the QuickTime Movie Object Editor to add your own HTML to th
movie element.

To open the QuickTime Movie Object Editor, do one of the following

1 Double-click the movie icon.

1 Select the movie icon, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh).
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1 Select the movie icon, and click the Object Editor button  on the 
toolbar.

To apply the new settings, press Tab or click the close box of the 
QuickTime Movie Object Editor.

Setting the movie play options 
In the QuickTime Movie Object Editor, you can set Claris Home Page

1 automatically play the movie when the page is downloaded

1 play the movie continuously, repeating it until you close the page
stop it using the movie controller

1 display a movie controller so someone viewing the movie can ma
it stop

To make the movie play automatically when the page is downloade

1. Select the movie icon in your page and open the QuickTime Mov
Object Editor.

2. Click the Parameters tab and select No from the Loop pop-up menu.

3. Click the Auto-play check box.

4. Apply your changes by closing the QuickTime Movie Object Edit

To make the movie play continuously:

1. Select the movie icon in your page and open the QuickTime Mov
Object Editor.

2. Click the Parameters tab and choose Yes from the Loop pop-up menu 
if you want it to play forward continuously. Choose Auto-Reverse 
from the Loop pop-up menu if you want it to play forward and then
backward in a continuous loop.

3. Click the Auto-play box.

4. Close the object editor to apply your changes.

Changing the size of the movie window 
You can use the QuickTime Movie Object Editor to change the size
the movie as it’s displayed in the page. You can also use the mous
change the width and height of the movie.
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To change the size using the QuickTime Movie Object Editor:

1. Select the movie icon in your page and open the QuickTime Mov
Object Editor.

2. Click the Parameters tab and type a new size in the Width and Height 
text boxes.

3. Choose Percent to make the size a percentage of the browser 
window’s size. Choose Pixels to make the size a fixed amount that i
not affected by the browser window’s size.

Tip Press Tab to apply a new setting without closing the object ed

4. Close the object editor to apply your changes.

To change the size using the mouse:

Select the movie icon and drag the bottom handle to change the he
of the movie, drag the right-side handle to change the width of the 
movie, or drag the lower-right corner handle to change the width an
height at the same time.

To change the size back to its original setting, click the Original Size 
button in the QuickTime Movie Object Editor.

Testing the QuickTime movie 
To test the movie, you need to preview it in a browser. You also nee
test it on the same machine that has the Movie Player or QuickTim
application. 

To preview the QuickTime movie:

1 Hold the mouse button down on the Preview in Browser button on the 
toolbar and choose a browser from the pop-up menu.

Adding extra HTML to the movie element 
You can add your own additional HTML directly to the movie eleme
using the QuickTime Movie Object Editor. 

Note This is an advanced feature that requires knowledge of HTML
specifies additional parameters for the <EMBED> tag.

To add extra HTML to the movie element:

1. Double-click the movie icon to open the QuickTime Movie Objec
Editor. 
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2. Click the Extended tab and type the HTML in the Extra HTML Attributes 
text box. 

The HTML that you type is added to the <EMBED> tag.

Adding a Java applet to your Web page
You can use Claris Home Page to add Java applets, small applications 
written in the Java programming language, to your Web page. Java
applets offer an endless possibility of special effects that can be as
simple as making an image dynamic or as complex as monitoring r
time data from a browser. Applets can be downloaded from a Web 
server and run on most computers. 

Many Java applets are available for free, or as shareware on the We
you to customize and use in your Web pages if you don’t want to cre
them yourself. Claris Home Page 3.0 comes with some sample app
files you can modify or use as they are.

To view and interact with a Java applet, you need a “Java-enabled” W
browser, such as Netscape Navigator 3.0. You must preview your p
in the browser for the applet to run.

Inserting the Java applet
When linking to a Java applet, you create a link to a .class file. This
.class file may then reference other files, which need to be in the sa
directory (Windows) or folder (Macintosh). For more information abo
a specific Java applet, refer to the readme file or documentation inclu
with the Java applet.

To insert a Java applet into a Web page:

1. Place the insertion point in the page where you want the applet t
appear and choose Applet from the Insert menu.

2. In the Open dialog box, select the main applet class file (it must h
the .cls  or .class  extension) and click Open.

An icon representing the applet appears on your Web page.

Note If you did a complete install from the Claris Home Page CD-RO
disc, sample applets are located in the Contents folder in the Claris
Home Page 3.0 folder.
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Opening the Applet Object Editor
Once you’ve inserted the applet, you use the Applet Object Editor t
specify the parameters of the applet.

To open the Applet Object Editor, do one of the following:

1 Double-click the applet icon.

1 Select the applet icon, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh).

1 Select the applet icon, and click the Object Editor button  on the 
toolbar.

To apply any new settings you make in the Applet Object Editor, pr
Tab or click the close box of the Applet Object Editor.
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Specifying the applet’s parameters
Some applets are designed to be customized. For example, a ticker
applet allows you to specify a value for the text parameter that scro
your words across the screen. You can specify applet parameters a
their values in the Applet Object Editor.

To specify a parameter for an applet:

1. Select the applet icon in your page and open the Applet Object Ed

2. Click the Parameters tab.

3. Click Add.

A parameter is added to the list with the default name, New Parameter, 
appearing in the Name column.

4. Click in the Name column of the new parameter.

5. Select the words New Parameter, and type the name of the paramete
you wish to add.

6. Click in the Value column of the new parameter and type the value
the parameter you are adding.

To delete a parameter, select the parameter in the list and click the
Remove button.

Macintosh: Click Restore All to clear the settings and reset all Name/
Value pairs to their original names.

To apply your changes, press Tab or click the close box of the App
Object Editor.

Specifying the applet’s size, alignment, and margins
You can use the Applet Object Editor to change the width or height
the applet, realign the applet in relation to text on the page, or set th
amount of white space around the applet.

To apply your changes, press Tab or click the close box of the App
Object Editor.

To change the height or width of the applet:

1. Click the applet icon and open the Applet Object Editor.

2. Click the Content tab if not already selected.

3. Type a new size in the Width and Height text boxes.
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To change the alignment of the applet in relation to text on the page

1. Click the applet icon and open the Applet Object Editor.

2. Click the Content tab if not already selected.

3. Select an alignment type from the Alignment pop-up menu.

To set the amount of space around the applet:

1. Click the applet icon and open the Applet Object Editor.

2. Click the Content tab if not already selected.

3. Type a number from 0 to 100  in the HSpace and VSpace text boxes.

Adding extra HTML to the applet element
You can add your own additional HTML directly to the applet eleme
using the Applet Object Editor. 

Note This is an advanced feature that requires knowledge of HTML
specifies additional parameters for the <APPLET> tag.

To add extra HTML to an applet:

1. Double-click the applet icon to open the Applet Object Editor. 

2. Click the Extended tab and type the HTML in the Extra HTML Attributes 
text box. 

The HTML that you type is added to the <APPLET> tag.

To specify an alternate HTML tag that is used by browsers when th
other tag is unsupported:

1. Double-click the applet icon to open the Applet Object Editor. 

2. Click the Extended tab and type the alternate HTML in the Alternate 
HTML text box. 

Choose this option To do this

Top Align the top of the applet with the top of the text next to 
it.

Middle Align the middle of the applet with the text next to it.

Bottom Align the bottom of the applet with the bottom of the text 
next to it.

Left or Right Place the applet on the left or right side of the page and
have text flow around it.
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The HTML that you type is added to the <APPLET> tag.

Changing the name or location reference to the applet
When you insert an applet into your Web page, the applet name an
location—the path to the folder where the applet is located—appear
the Applet Object Editor. You can change the name and location to r
to a different applet. Claris Home Page updates the reference to the
applet file.

To change the name or location of the applet:

1. Click the applet icon and open the Applet Object Editor.

2. Click the Content tab.

3. In the Name and Location text boxes, type a new name and path for th
applet file, or click the Browse button to find and select the applet file

4. Close the Applet Object Editor to apply your changes.

To have two applets on the same page find and communicate with 
other, you need to specify an instance name for both of them.

To specify the applet instance name:

1. Click the applet icon and open the Applet Object Editor.

2. Click the Extended tab.

3. In the Instance Name text box, type a name for the applet file.

4. Repeat these steps for the other applet, giving it the same name i
Instance Name text box.

5. Close the Applet Object Editor to apply your changes.

Providing an alternative message
You can provide an alternative message to appear instead of the a
whenever a page containing applets is viewed with a browser that d
not support applets.

To provide an alternative message:

1. Click the applet icon and open the Applet Object Editor.

2. Click the Content tab.

3. In the Alt Label text box, type a message.

4. Close the Applet Object Editor to apply your changes.
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Chapter 12:  Uploading your pages to a Web serv

Once you have built your Web pages on your computer, you can us
Claris Home Page to make them available to everyone on the Worl
Wide Web or to share them with other users who have access to the 
server. 

Claris Home Page makes the task of transferring or uploading your files 
to the Web easy when you use the Site Editor. You can upload a pa
an entire site including any referenced files in a single step. You can 
upload open pages as you’re working on them in Edit Page mode.

Claris Home Page helps you prepare your site for uploading and 
provides several ways to upload the files, update your Web site, an
download files from your Web site.

Claris Home Page uploads and downloads files using FTP (File Tran
Protocol) and requires a network connection that supports it. You c
have a direct connection or a connection via a modem to the Intern
You can also publish your site on an intranet, a network that uses 
Internet technology but is not public. 

Preparing to upload the site
Before you upload your pages to the Web, use the Site Editor to do
final check on all the files in your site. To prepare for uploading you
site, you can use the Site Editor to:

1 check the estimated download times of all the pages in your site

1 verify that all links and references in your pages are not broken

1 consolidate all referenced images and multimedia files

1 identify the location where files will be uploaded

To use the Site Editor:

1. Choose Open Folder as Site from the File menu.

The Browse for Folder dialog box (Windows) or the Select a Fold
dialog box (Macintosh) appears.

2. In the dialog box, navigate to your site folder.

3. Click OK (Windows) or Select “folder name” (Macintosh).
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All the files in your site folder appear in the Site Editor. The Site 
Editor also displays the name of your site and the total number a
size of your Web pages.

Note  When you open your site in the Site Editor, Claris Home Pa
creates a site definition file in your site folder called 
“site_definition.wst.” (The .wst extension stands for “Web site.”) 
Claris Home Page uses this file to store your site settings.
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Checking the document statistics
You can use the Site Editor to check the document statistics for you
entire site. Claris Home Page gives an approximate estimate of the
downloading time for individual pages in your Web site or for your 
entire site.

To check the statistics for pages in your site:

1. In the Site Editor, select the files you wish to check, or if you want
check the entire site, select nothing.

2. Click the Statistics button  on the toolbar. 

The Statistics dialog box appears.

3. Click the Selection tab to view the statistics for the selection.

4. Click Done to close the Statistics window.
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Consolidating media files
You can use Claris Home Page to consolidate all the media files, 
including images, sounds, movies, etc., referenced by your Web pa
within your site, so they will be uploaded when you upload your site
a Web server. You can consolidate them in your site folder or in a fo
that’s separate from the pages and other associated files in your sit
you have a lot of images in your Web pages, this can help you keep t
organized and ensure that the reference links to the images won’t b
broken when you upload your pages to the Web.

When you consolidate your media files, Claris Home Page creates 
folder (named “Media” by default) or uses one that you specify to ho
the image and media files. Claris Home Page checks all references t
image and media files made by the pages in your site folder. If a file
not in the folder you specified, Claris Home Page makes a copy of 
file and places it there. The reference link in the Web page is change
reflect the new location. When you consolidate again, any new ima
or media are added to the folder.

Note The media consolidation feature does not detect media files th
are referenced within Java source code, as may be the case with m
file Java applets. Media files referenced in this manner do not get 
consolidated.

To consolidate media files in your Web site:

1. Open the Site Editor by choosing Open Folder as Site from the File 
menu, selecting your site folder, and clicking OK (Windows) or Select 
“folder name” (Macintosh).

2. Select the files you wish to consolidate, or select the site folder t
consolidate media for the entire site.

3. Click the Consolidate button  on the Site Editor toolbar. 

If you select items in the Site Editor before clicking the Consolidate 
button, the Consolidate dialog box appears. Click Selected Files/Folders 
or Entire Site, and then click OK.
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4. In the Consolidate dialog box, specify where you want to consolid
the media files by choosing an option from the Consolidate media files 
pop-up menu.

5. If you want your media files consolidated in a separate folder(s) fr
the rest of your site files, type the name of your media folder in th
Media Folder name text box. 

By default, Claris Home Page consolidates media files in a folde
called “Images.” If the folder doesn’t exist, Claris Home Page crea
a folder using the name in the Media Folder Name text box. 

Claris Home Page uses this folder whenever you consolidate me
for this site until you change it in this dialog box. If later you open 
individual page from this site folder and click the Consolidate button 
on the Basic toolbar (rather than on the Site Editor toolbar), Clar
Home Page automatically consolidates all media to this folder. 

6. Click Consolidate.

Claris Home Page checks the reference links in each page you 
selected and consolidates all the referenced media files into the fo
you specified. If the media file is not already in this folder, Claris 
Home Page makes a copy of it and places it there. 

Note A warning dialog box may appear if a referenced file in your s
cannot be located. You can click OK to locate the file, click Skip file 
to leave the link unchanged, or click Cancel to end the consolidation 
process and return to the Site Editor to examine your pages.

Choose this option To specify this

At the same level as the 
HTML file

Images or media that are featured in a page are copied to th
same folder where the page that features them is located.

In a one media folder for 
your site 

All images or media that are featured in your Web site are 
copied to a single folder that you specify in the Media Folder
Name text box (see step 4). 

In a separate media folder 
for every folder in your site

Images or media that are featured in a page that’s in a 
subfolder to the site folder are copied to a separate media 
subfolder. Claris Home Page creates a media subfolder for
every folder in the site using the same media folder name 
that you entered in the Media Folder Name text box (see step 4). 
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To consolidate images in a page you’re working on:

1 In Edit Page mode, click the Consolidate button on the Basic toolbar.

Claris Home Page consolidates all image and media files referen
in the page to the default media folder you specified. If the media
folder you specify does not exist, Claris Home Page creates it in
same folder that contains the page you’re working on.

Verifying links and references
You can use the Site Editor to check for broken links in your Web pag
Claris Home Page verifies links to pages, anchors on pages, and 
references to image files or other associated files in your site. Clari
Home Page does not verify links to external Web sites or files on a 
volume of a computer that is not networked to your computer. You c
also verify links and references in a page you’re working on in Edit P
mode.

For information about creating links to pages or anchors on a page
Chapter 7, “Creating links and anchors.” References to image files 
other media files are automatically created when you insert an imag
media file into your Web page. For more information, see chapter 4
“Adding images to your Web page” and chapter 11, “Adding 
multimedia to your Web page.”

To verify links in your Web site:

1. Open the Site Editor by choosing Open Folder As Site from the File 
menu, selecting your site folder, and clicking OK (Windows) or Select 
“folder name” (Macintosh).

2. In the Site Editor, select the pages you want to check. If you wan
verify the links of the entire site, select all files.
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3. Click the Verify Links and References button  on the Site Editor toolbar.

If you selected something in the Site Editor before you clicked th
button, the Please Select dialog box appears. Click Selected Files/
Folders or Entire Site and click OK.

Claris Home Page verifies the links and references in your site. I
there are any broken links, Claris Home Page displays the Verify
dialog box for each broken link it finds.

This dialog box displays the path for the broken link and also ent
it automatically in the Change to text box.

4. Type the new path for the links destination in the Change to text box 
or click Browse to locate the missing file.

5. For each broken link that Claris Home Page finds, do one of the 
following: 

1 Click Change to fix the link as specified in the Change to text box 
and continue checking for other broken links.

1 Click Change All to fix all links to the same file as specified in the
Change to text box and continue checking for other broken links

1 Click Skip to not make changes to a broken link and continue 
checking for other broken links. 

1 Click Remove Tag to remove the HTML tag containing the broken
link or reference.

1 Click Cancel to close the Please Change dialog box. 
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To verify links in an open page you’re working on:

1. In Edit Page mode, click the Verify Links and References button  on 
the Basic toolbar.

Claris Home Page checks all the links in the page and if it finds a
broken link, the Verify dialog box appears.

2. Type the new path for the link’s destination in the Change to text box 
or click Browse to locate and enter the new path.

3. For each broken link that Claris Home Page finds, do one of the 
following: 

1 Click Change to fix the link as specified in the Change to text box 
and continue checking for other broken links.

1 Click Change All to fix all links to the same file as specified in the
Change to text box and continue checking for other broken links

1 Click Skip to not make changes to a broken link and continue 
checking for other broken links. 

1 Click Remove Tag to remove the HTML tag containing the broken
link or reference.

1 Click Cancel to close the Please Change dialog box.

Specifying the Web server account
You only need to specify the destination of your Web site once in Cla
Home Page before you upload your files. You can set specifications
your Web server account and use it when you upload or download a
Claris Home Page saves the account settings for each individual si
You can set Claris Home Page to upload files to accounts with Netc
Earthlink, another Internet service provider, America Online, or to a
specific intranet account.

The Web server you upload your files to must support passive or ac
FTP (File Transfer Protocol). Your Internet service provider, 
Webmaster, or system administrator will give you the server name (y
Web site domain), the names of the folder(s) where you can upload 
files to, the name of your account, and a password for your account. 
will probably also receive guidelines for naming files, such as how t
name the home page file of your site (typically named “index.htm”).
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To specify the Web server account:

1. Open the Site Editor by choosing Open Folder as Site from the File 
menu, selecting your site folder, and clicking OK (Windows) or Select 
“folder name” (Macintosh).

2. Click the Upload button  on the Site Editor toolbar.

The Upload dialog box appears.

3. Click Set FTP Options.

The FTP Options dialog box appears.

4. Choose your service provider from the Service Provider pop-up menu. 

5. Fill out or customize the FTP server settings, as appropriate.

6. Click OK to close the FTP Options dialog box.

Claris Home Page saves your account settings for the site in the
definition file. 

7. To close the Upload dialog box without uploading, click Cancel.

Uploading to the Web server
You can use Claris Home Page to upload selected files or your ent
Web site to a server at once. You can also upload an open page th
you’re working on and any associated images, movies or other con
files that the page references.

Choose this setting To specify this

Server Name The domain name of the remote server, for example, 
any_server.com .

User Name The name of your account.

Password The password for your account. Select the Save Password 
check box to have Claris Home Page remember it.

Remote Folder The name of the folder on the remote server where your s
files reside. If you’ve specified the account information, and 
you’re connected to the server, you can click Browse to look 
for the remote folder and enter its name for this setting.

FTP Mode Use Passive or Active mode for transferring files. Claris Home 
Page uses Passive mode by default. Choose Active from the 
pop-up menu if you’re using a Macintosh Internet Config 
Setup that’s active. 
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Uploading an entire site
Use the Site Editor to upload the entire contents of your site folder.

To upload your entire site:

1. Open the Site Editor by choosing Open Folder as Site from the File 
menu, selecting your site folder, and clicking OK (Windows) or Select 
“folder name” (Macintosh).

2. Click the Upload button  on the Site Editor toolbar.

The Upload dialog box appears.

3. Select Entire Site in the dialog box.

4. Click Upload.
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Note  If the Upload button is dimmed, your FTP settings may be 
incomplete or currently unspecified. Click Set FTP Options to display 
the FTP Options dialog box, and specify your FTP settings for yo
Web server account. See “Specifying the Web server account” o
page 12-8 for more information. 

Claris Home Page displays a progress bar while your files uploa

To stop uploading, press the Esc key (Windows) or 3-period 
(Macintosh).

Uploading selected files
You can use the Site Editor to upload individual files in your site, 
including your pages and Web associated images, movies, or other
content files that the pages reference. You can also upload an open
page and its associated files while viewing it in Edit Page mode by 
clicking the Upload button .

To upload individual files in the Site Editor:

1. Open the Site Editor by choosing Open Folder as Site from the File 
menu, selecting your site folder, and clicking OK (Windows) or Select 
“folder name” (Macintosh).

2. In the Site Editor, select the files or folders you want to upload.

3. Click the Upload button  on the toolbar.

The Upload dialog box appears.
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4. Click Upload and enter FTP account settings, if needed.

Note  If the Upload button is dimmed, your FTP settings may be 
incomplete or currently unspecified. Click Set FTP Options to display 
the FTP Options dialog box, and specify your FTP settings for yo
Web server account. See “Specifying the Web server account” o
page 12-8 for more information. 

Claris Home Page displays a progress bar while your files uploa

To stop uploading, press the Esc key (Windows) or 3-period 
(Macintosh).

Uploading an open Web page
You can upload individual pages that are open in Claris Home Pag

To upload an open Web page:

1. Choose Remote from the File menu, and then choose Upload from the 
submenu, or click the Upload button  on the Basic toolbar.

An Upload dialog box for the page appears.
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2. Select the Include image files check box if you want to upload images
or other files referenced by the page.

3. Click Upload.

4. Enter your password, if necessary, and click OK.

Claris Home Page displays a progress bar while your page uploa

Updating your Web site
You can maintain your Web site by downloading old or out-of-date fil
uploading new or changed files to the server, and deleting old files fr
the server, if necessary. When you download a file, Claris Home Pa
copies the file onto your hard drive, and a copy of the file remains on
Web server. You can delete this file from the server if you want.

Uploading only files that have changed
To upload only the pages or files that are new or have been change

1. Open the Site Editor by choosing Open Folder as Site from the File 
menu, selecting your site folder, and clicking OK (Windows) or Select 
“folder name” (Macintosh).

2. Click the Upload button  on the Site Editor tool bar to display the
Upload dialog box. 

3. Select Only those files that have changed since the last upload.

4. Click Set FTP Options if you need to enter or change the FTP accou 
settings and click OK.

5. Click Upload.

Claris Home Page displays a progress bar while your files uploa

To stop uploading, press the Esc key (Windows) or 3-period 
(Macintosh).
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Downloading files from the Web
You can use Claris Home Page to download files from your Web site
remote server. When you download a file, Claris Home Page make
copy of the file and places it on your computer. You can also use Cl
Home Page to browse the contents of your site folder on the Web a
delete files from it.

To download your files from a remote server:

1. Choose Remote from the File menu and then choose Download from 
the submenu.

The Download dialog box appears.

2. If you want to change the server name, the name of the folder th
contains your files on the server, or other FTP settings, click Change 
Download Options, make your changes, and click OK. See “Specifying 
the Web server account” on page 12-8 for more information on F
settings.

3. Click Browse to choose a location where you want to download th
files to. 

4. Select a volume or folder and click OK.
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5. Click Download.

When you download a single file, a copy of the file is saved onto yo
hard disk. The name of this copy is the same as the original, which
remains on the Web server. 

Deleting files from the Web server
You can delete a file or entire subfolder from your site on the 
Web server.

To delete a file from your site folder on the server: 

1. Choose Remote from the File menu, and then choose Download from 
the submenu.

The Download dialog box appears.

2. Click Change Download Options, and specify your FTP settings.

3. In the download Options dialog box, click Browse.

The Browse dialog box appears, showing the list of files on the 
FTP server.

4. Locate and select the file you wish to delete. 

5. Click Delete.

Claris Home Page deletes the file from the server.
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Appendix A:  Codes for special characters

The following is a list of the International Standards Organization (IS
Latin-1 characters and their corresponding numeric entities. How to
these special characters in your Web pages is described in chapter
“Adding text to your Web page” (see page 3-8).

Note If a browser does not recognize a numeric entity, then the 
characters listed in brackets appear in its place.

Numeric entity
(raw HTML option) Special character produced

&#00;–&#08; Unused

&#09; Horizontal tab

&#10; Line feed

&#11;–&#12; Unused

&#13; Carriage Return

&#14;–&#31; Unused

&#32; Space

&#33; ! (Exclamation mark)

&#34; " (Quotation mark)

&#35; # (Number sign) 

&#36; $ (Dollar sign) 

&#37; % (Percent sign) 

&#38; & (Ampersand) 

&#39; ' (Apostrophe) 

&#40; ( (Left parenthesis) 

&#41; ) (Right parenthesis) 

&#42; * (Asterisk) 

&#43; + (Plus sign) 

&#44; , (Comma) 

&#45; - (Hyphen) 

&#46; . (Period) 

&#47; / (Solidus - slash) 

&#48;–&#57; 0 1 2 3 4 5 6 7 8 9 (Digits 0-9) 
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&#58; : (Colon) 

&#59; ; (Semi-colon)

&#60; < (Less than) 

&#61; = (Equals sign) 

&#62; > (Greater than) 

&#63; ? (Question mark) 

&#64; @ (Commercial at) 

&#65;–&#90; A B C D E F G H I J K L M N O P Q R S T U V W X Y 
Z (Letters A-Z)

&#91; [ (Left square bracket) 

&#92; \ (Reverse solidus - backslash) 

&#93; ] (Right square bracket) 

&#94; ^ (Caret) 

&#95; _ (Horizontal bar - underbar) 

&#96; ` (Grave accent - back apostrophe)

&#97;–&#122; a b c d e f g h i j k l m n o p q r s t u v w x y z (Letters a-z)

&#123; { (Left curly brace)

&#124; | (Vertical bar) 

&#125; } (Right curly brace) 

&#126; ~ (Tilde) 

&#127;–&#159; Unused 

 Values 128-159 These values are not assigned to displayable character
the ISO8859-1 code and should not be used for 
displayable characters in HTML. 

&#160; Non-breaking space [&nbsp] 

&#161; ¡ (Inverted exclamation) [&iexcl; &iexcl] 

&#162; ¢ (Cent sign) [&cent; &cent] 

&#163; £ (Pound sterling) [&pound; &pound] 

&#164; ¤ (General currency sign) [&curren; &curren] 

&#165; ¥ (Yen sign) [&yen; &yen] 

&#166;  (Broken vertical bar) [&brvbar; &brvbar] 

&#167; § (Section sign) [&sect; &sect] 

Numeric entity
(raw HTML option) Special character produced
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&#168; ¨ (Umlaut - dieresis) [&uml; &uml] 

&#169; © (Copyright) [&copy; ©] 

&#170; ª (Feminine ordinal) [&ordf; &ordf] 

&#171; « (Left angle quote, guillemotleft) [&laquo; &laquo]

&#172; ¬ (Not sign) [&not; &not]

&#173; – (Soft hyphen) [&shy; &shy] 

Many browsers do not properly handle this character. It is
better to use the &shy; entity name instead of this ISO 
numeric entity.

&#174; ® (Registered trademark) [&reg; ®] 

&#175; ¯ (Macron accent) [&macr; &macr] 

&#176; ° (Degree sign) [&deg; &deg] 

&#177; ± (Plus or minus) [&plusmn; &plusmn] 

&#178;  (Superscript two) [&sup2; &sup2] 

&#179;  (Superscript three) [&sup3; &sup3] 

&#180; ´ (Acute accent) [&acute; &acute] 

&#181; µ (Micro sign) [&micro; &micro] 

&#182; ¶ (Paragraph sign) [&para; &para] 

&#183; · (Middle dot) [&middot; &middot] 

&#184; ¸ (Cedilla) [&cedil; &cedil] 

&#185;  (Superscript one) [&sup1; &sup1] 

&#186; º (Masculine ordinal) [&ordm; &ordm] 

&#187; » (Right angle quote, guillemotright) [&raquo; &raquo] 

&#188;  (Fraction one-fourth) [&frac14; &frac14]

&#189;  (Fraction one-half) [&frac12; &frac12] 

&#190;  (Fraction three-fourths) [&frac34; &frac34] 

&#191; ¿ (Inverted question mark) [&iquest; &iquest] 

&#192; À (Capital A, grave accent) [&Agrave; À]

&#193; Á (Capital A, acute accent) [&Aacute; Á] 

&#194; Â (Capital A, circumflex accent) [&Acirc; Â] 

&#195; Ã (Capital A, tilde) [&Atilde; Ã] 

&#196; Ä (Capital A, dieresis or umlaut mark) [&Auml; Ä] 

Numeric entity
(raw HTML option) Special character produced
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&#197; Å (Capital A, ring) [&Aring; Å] 

&#198; Æ (Capital AE dipthong, ligature) [&AElig; Æ] 

&#199; Ç (Capital C, cedilla) [&Ccedil; Ç] 

&#200; È (Capital E, grave accent) [&Egrave; È] 

&#201; É (Capital E, acute accent) [&Eacute; É] 

&#202; Ê (Capital E, circumflex accent) [&Ecirc; Ê] 

&#203; Ë (Capital E, dieresis or umlaut mark) [&Euml; Ë] 

&#204; Ì (Capital I, grave accent) [&Igrave; Ì] 

&#205; Í (Capital I, acute accent) [&Iacute; Í] 

&#206; Î (Capital I, circumflex accent) [&Icirc; Î] 

&#207;  Ï (Capital I, dieresis or umlaut mark) [&Iuml; Ï] 

&#208;  (Capital Eth, Icelandic) [&ETH; ‹]

&#209; Ñ (Capital N, tilde) [&Ntilde; Ñ] 

&#210; Ò (Capital O, grave accent) [&Ograve; Ò] 

&#211; Ó (Capital O, acute accent) [&Oacute; Ó]

&#212; Ô (Capital O, circumflex accent) [&Ocirc; Ô] 

&#213; Õ (Capital O, tilde accent) [&Otilde; Õ] 

&#214; Ö (Capital O, dieresis or umlaut mark) [&Ouml; Ö] 

&#215; x (Multiply sign) [&times; &times] 

&#216; Ø (Capital O, slash) [&Oslash; Ø] 

&#217; Ù (Capital U, grave accent) [&Ugrave; Ù]

&#218; Ú (Capital U, acute accent) [&Uacute; Ú] 

&#219; Û (Capital U, circumflex accent) [&Ucirc; Û] 

&#220; Ü (Capital U, dieresis or umlaut mark) [&Uuml; Ü] 

&#221;  (Capital Y, acute accent) [&Yacute; †] 

&#222;  (Capital THORN, Icelandic) [&THORN; fi] 

&#223; ß (Small sharp s, German, sz ligature) [&szlig; ß] 

&#224; à (Small a, grave accent) [&agrave; à] 

&#225; á (Small a, acute accent) [&aacute; á] 

&#226; â (Small a, circumflex accent) [&acirc; â] 

&#227; ã (Small a, tilde accent) [&atilde; ã] 

Numeric entity
(raw HTML option) Special character produced
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&#228; ä (Small a, dieresis or umlaut mark) [&auml; ä] 

&#229; å (Small a, ring) [&aring; å] 

&#230; æ (Small ae dipthong, ligature) [&aelig; æ] 

&#231; ç (Small c, cedilla) [&ccedil; ç] 

&#232; è (Small e, grave accent) [&egrave; è] 

&#233; é (Small e, acute accent) [&eacute; é] 

&#234; ê (Small e, circumflex accent) [&ecirc; ê] 

&#235; ë (Small e, dieresis or umlaut mark) [&euml; ë] 

&#236; ì (Small i, grave accent) [&igrave; ì] 

&#237; í (Small i, acute accent) [&iacute; í] 

&#238; î (Small i, circumflex accent) [&icirc; î] 

&#239; ï (Small i, dieresis or umlaut mark) [&iuml; ï] 

&#240;  (Small eth, Icelandic) [&eth; ›] 

&#241; ñ (Small n, tilde) [&ntilde; ñ] 

&#242; ò (Small o, grave accent) [&ograve; ò] 

&#243; ó (Small o, acute accent) [&oacute; ó] 

&#244; ô (Small o, circumflex accent) [&ocirc; ô] 

&#245; õ (Small o, tilde) [&otilde; õ] 

&#246; ö (Small o, dieresis or umlaut mark) [&ouml; ö] 

&#247; ÷ (Division sign) [&divide; &divide] 

&#248; ø (Small o, slash) [&oslash; ø] 

&#249; ù (Small u, grave accent) [&ugrave; ù]

&#250; ú (Small u, acute accent) [&uacute; ú] 

&#251; û (Small u, circumflex accent) [&ucirc; û] 

&#252; ü (Small u, dieresis or umlaut mark) [&uuml; ü]

&#253;  (Small y, acute accent) [&yacute; ‡] 

&#254;  (Small thorn, Icelandic) [&thorn; fl] 

&#255; ÿ (Small y, dieresis or umlaut mark) [&yuml; ÿ]

Numeric entity
(raw HTML option) Special character produced
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Appendix B:  Shortcuts for using Claris Home Pag

General shortcuts

To do this Use this shortcut on a PC with Windows Use this shortcut on the Macintosh

Insert a horizontal rule. Drag the Insert Horizontal Rule button  from the 
Basic toolbar to the position where you want to 
insert the rule.

Drag the Insert Horizontal Rule button  from the 
Basic toolbar to the position where you want to 
insert the rule.

Insert a table. Drag the Insert Table button  from the Basic 
toolbar to the position where you want to insert 
the table. 

Drag the Insert Table button  from the Basic 
toolbar to the position where you want to insert 
the table. 

Move a window without 
bringing it to the front. 

Not available. 3-click on the window's title bar and then 
drag it.

Open an object editor for a form 
element.

Right-click the form element (such as a check 
box or radio button) and choose Form Object 
Editor from the context menu.

Control-click the form element (such as a check 
box or radio button) and choose Form Object 
Editor from the context menu.

Open the Frame Object Editor. Right-click the frame and choose Show Object 
Editor from the context menu.

Control-click the frame and choose Show Object 
Editor from the context menu.

Switch to Edit HTML Source 
mode.

Press Shift-Ctrl-H. Press Shift-3-H.

Switch to Edit Page mode. Press Shift-Ctrl-E. Press Shift-3-E.

Switch to Preview Page mode. Press Shift-Ctrl-P. Press Shift-3-P.

Move the insertion point to the 
next or previous setting in a 
dialog box or object editor or to 
the next or previous cell in a 
table.

Press Tab to move forward or Shift-Tab to back. Press Tab to move forward or Shift-Tab to b
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Text shortcuts

Library shortcuts

To do this Use this shortcut on a PC with Windows Use this shortcut on the Macintosh

Select the next or previous 
paragraph.

Press Shift-Ctrl- D  or Shift Ctrl-C. Press Shift-Option- D  or Shift-Option-C.

Select text from the insertion 
point to the end or the beginning 
of the document.

Not available. Press Shift-3-Dor Shift-3-C.

Select a range of characters. Press Shift-B  or Shift- A . Press Shift-B  or Shift- A .

Select a range of whole words. Press Shift-Ctrl-B  or Shift-Ctrl- A . Press Shift-Option-B  or Shift-Option- A .

Delete the previous or following 
word.

Press Ctrl-Backspace or Ctrl-Delete. Press Option-Delete or Option-Forward Dele
(del).

Copy selected text. Ctrl-drag the text to the position where you 
want to place the copy. 

Option-drag the text to the position where you 
want to place the copy.

Insert a non-breaking space. In Edit Page mode, press Alt and type 0160  on 
the numeric keypad.

Press Option-space bar.

Insert a line break. Press Shift-Enter. Press Shift-Return.

Create a new list item. Press F8. Press 3-Return.

Create a new list item and indent 
it.

Place the insertion point in the list and press F9. Place the insertion point in the list and pres
Option-3-Return.

Create a new list item and indent 
it to the previous level of 
indentation (decrease indent).

Place the insertion point in the list and press F7. Place the insertion point in the list and pres
Shift-3-Return.

Reverse the direction of the 
search while using the Find/
Change, Find Next and Find 
Previous commands to go 
backward through a document 
or forward.

In the Find/Change dialog box, hold down the 
Shift key while clicking Change, Find, Find Next, 
or Find Previous. 

In the Find/Change dialog box, hold down the 
Shift key while clicking Change, Find, Find Next, 
or Find Previous. 

To do this Use this shortcut on a PC with Windows Use this shortcut on the Macintosh

Make a library entry using 
selected text.

Drag the text to the left section of the library 
window.

Drag the text to the left section of the library 
window.

To perform various tasks on 
selected objects in the library 
window.

Right-click the selected object and choose 
various options from the context menu.

Control-click the selected object and choose 
various options from the context menu.
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Images and image map shortcuts

To do this Use this shortcut on a PC with Windows Use this shortcut on the Macintosh

Return a selected image to its 
original size (width and height).

Double-click the lower-right corner handle of the 
image border.

Double-click the lower-right corner handle of the 
image border.

Return a selected image to its 
original width.

Double-click the right handle of the image 
border.

Double-click the right handle of the image 
border.

Return a selected image to its 
original height.

Double-click the bottom handle of the image 
border.

Double-click the bottom handle of the image 
border.

Resize a selected image 
proportionately.

Hold down Shift and drag the lower-right corner 
handle.

Hold down Shift and drag the lower-right corner 
handle.

Replace a “missing image” icon 
with a new image.

Right-click the icon, choose Browse Files from 
the context menu, and select the new image.

Control-click the icon, choose Browse Files from 
the context menu, and select the new image.

Open the Image Object Editor. Double-click the image or right-click the image 
and choose Image Object Editor from the context 
menu.

Double-click the image or Control-click the 
image and choose Image Object Editor from the 
context menu.

Open an image in the 
Transparency and Interlacing 
Image Editor.

Ctrl-double-click the image. Option-double-click the image.

Open the Image Map Editor. Right-click the object and choose Image Map 
Editor from the context menu.

Control-click the object and choose Image Map 
Editor from the context menu.

Move a selected hotspot 1 pixel 
in the Image Map Editor.

Press the arrow keys. Press the arrow keys.

Move a selected hotspot 10 
pixels in the Image Map Editor.

Hold down Ctrl while pressing the arrow keys. Hold down Option while pressing the arrow 
keys.

Resize a selected hotspot 1 pixel 
in the Image Map Editor.

Hold down Shift while pressing the arrow keys. Hold down Shift while pressing the arrow key

Resize a selected hotspot 10 
pixels in the Image Map Editor.

Hold down Shift-Ctrl while pressing the arrow 
keys.

Hold down Shift-Option while pressing the 
arrow keys.
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Links shortcuts

To do this Use this shortcut on a PC with Windows Use this shortcut on the Macintosh

Open the Link Editor. Press Crtl-L or Enter (numeric keypad) with 
Number Lock off.

Press 3-L or Enter (numeric keypad) with 
Number Lock off.

Create a link. Select the text or image, right-click it, and 
choose Link to File from the context menu. 

You can also choose a file listed under Link to 
Recent URL or Link to open file in the context 
menu.

Select the text or image, Control-click it, and 
choose Link to File from the context menu. 

You can also choose a file listed under Link to 
Recent URL or Link to open file in the context 
menu.

Test a selected link in Edit Page 
mode.

Right-click the link and choose Follow Link from 
the context menu.

Control-click the link and choose Follow Link 
from the context menu.

Remove a selected link. Right-click the link and choose Remove Link 
from the context menu.

Control-click the link and choose Remove Link 
from the context menu.

Insert an anchor in place of 
selected text.

Right-click the selected text and choose Insert 
Anchor from the context menu.

Note Claris Home Page names the anchor for you.

Control-click the selected text and choose 
Insert Anchor from the context menu.

Note Claris Home Page names the anchor for you.

Insert a link to an anchor. Ctrl-drag the anchor to the location on the page 
or on another page where you want to create the 
link.

Option-drag the anchor to the location on the 
page or on another page where you want to 
create the link.
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Appendix C:  Troubleshooting and problem solvin

Problems installing or running Claris Home Page
Every time I start Claris Home Page, it opens one or more files with
my telling it to.

Claris Home Page automatically opens any files in the Startup folde
(Windows) or Startup Items folder (Macintosh) located in the same 
folder as the Claris Home Page application. To disable this, remove
unwanted files from the Startup or Startup Items folder.

An error message appears when I try to start Claris Home Page: “Th
is not enough memory to open Claris Home Page (XXX needed, XX
available).” (Macintosh only)

Your computer does not have enough memory to use Claris Home P
at the same time as the other applications you are running. If you h
other applications running, try exiting from them (bring the other 
application to the front, and choose Quit from the File menu). See the 
documentation that came with your Macintosh computer for other w
to increase available memory.

An error message appears when I try to start Claris Home Page: “Y
need a Macintosh equipped with a PowerPC processor to run this 
application.” (Macintosh only)

You have installed a copy of Claris Home Page that is optimized for
PowerPC processor chip. This copy will not work on older Macintos
computers that are not equipped with this chip. You must re-install 
Claris Home Page from the original program disks.

Problems using Claris Home Page
Onscreen Help doesn't work. (Choosing an item from the Help men
displays an error message.)

The Claris Home Page Help uses a set of help files that are installe
along with the application. These files should be located in a folder 
named “Help files,” in the Claris Home Page folder. If the Help folde
has been moved, renamed, or deleted, or if the application has bee
moved to a different location, then onscreen Help will not work. Ma
sure the Help folder is named “Help files” and that
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it and the application are both located in the Claris Home Page folde
re-install the help files using your original Claris Home Page installat
disks.

Images in JPEG format are drawn as gray rectangles in Claris Hom
Page, but appear fine in a browser. (On Windows, the same proble
may sometimes occur for GIF images as well.)

Claris Home Page requires certain software to be installed in order
display JPEG files, described as follows:

On Windows, the Accusoft imaging DLL (Accuisr5.dll) must be 
installed in the same directory as Claris Home Page. To install the 
Accusoft imaging DLL, re-install Claris Home Page from the origina
program disks.

On the Macintosh, the QuickTime application program version 2.0 o
later must be installed in the Extensions folder.

An image appears stretched or squashed.

You may have accidentally resized the image, or changed the size o
image in a drawing program. Click once on the image in Claris Hom
Page to select it, and then reset it to its natural size by either doubl
clicking on the resize handle in the lower-right corner of the image, 
opening the Image Object Editor and clicking the Original Size button.

In the place of where one of my images should appear, Claris Hom
Page shows a red box and the words “Corrupt or missing image” 
appear. (The words “Corrupt or missing image” may not appear for
small images.)

This happens when Claris Home Page can't locate an image file. The
may have been accidentally moved, renamed, or deleted, or your HT
file may have been moved without bringing the image file along. To
correct the problem, first locate the image file (or re-create it if it ha
been deleted). Then select the red box, Ctrl-double-click (Windows
Command-double-click (Macintosh) it and choose Browse Files from
the context menu. Claris Home Page displays a standard file select
dialog box. Select the image file and click OK. The red box should be 
replaced by the desired image.
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In some cases, the red box and “Corrupt or missing image” label m
also appear if the image file is corrupt, or if there is not enough mem
for Claris Home Page to display the image. If you suspect this may
the case, verify that the image file is not corrupt (for example, by 
opening it in another application), and try closing other documents 
giving Claris Home Page more memory.

Problems opening files not created in Claris Home Page
When I double-click on an HTML file on the desktop, Claris Home Pa
isn't opened, the browser is. (Windows only)

On Windows, only one application is allowed to be the default view
for a given file extension. In this case, the browser is the default vie
for HTML files, so it is opened when you click on an HTML file. To 
open an HTML file in Claris Home Page, drag the file itself (not a 
shortcut) to the Claris Home Page icon, or start Claris Home Page 
directly, and choose Open from the File menu. You can also change th
association of the file type—see your Windows documentation for m
details.

When I open an HTML document that wasn’t created in Claris Hom
Page, it contains mysterious fragments of red text.

If a file contains incorrect HTML code, Claris Home Page displays t
incorrect codes in red. This often occurs with files created in a text 
editor—browser applications are relatively tolerant of HTML errors, 
you might not be aware of the error until you open the file in Claris 
Home Page. To correct the problem, simply delete the red text.

This problem can also occur for files that make use of HTML extensio
not supported by Claris Home Page, such as blinking text. If you ope
file that contains blinking text in Claris Home Page, the tags <BLINK
and </BLINK> appear on either side of the blinking text. If you dele
the BLINK tags, the text will no longer blink when it appears in a 
browser.

When Claris Home Page displays red HTML code in your documen
this is due to the use of HTML extensions (which should not be dele
or errors in the HTML file (which should be deleted). If you are unsu
try making a copy of the file, removing the questionable code, and 
viewing the resulting file in a browser application. If removing the 
questionable code does not change the document's appearance in
browser, then you can safely delete it.
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When I open an HTML document that wasn’t created in Claris Hom
Page, some of the HTML does not display correctly (blinking text, Ja
applets, browser plug-ins, etc.).

HTML is a rapidly evolving standard, and is constantly being extend
Claris Home Page does not support every HTML extension that has b
proposed. If your document uses an extension to HTML that is not 
supported by Claris Home Page, it may not appear correctly in Clar
Home Page. This is usually indicated by the appearance of the unkn
HTML codes in red. This does not affect the appearance of the docum
in a browser; it only affects the appearance within Claris Home Pag
itself. To get a better feel for how the document will appear in a brows
use Preview in Browser mode.

Problems with links
When I click on a link, Claris Home Page displays the message “So
Claris Home Page 3.0 can only follow links to local files.”

All links in an HTML file contain a URL (Uniform Resource Locator)
that identifies the file or other object that the link points to. There are t
types of URLs: local URLs, which point to a file on the local machin
(or to a file on the same machine as the document containing the li
and external URLs, which point to a file on a machine somewhere on
Internet. Claris Home Page can only process local URLs. To test a 
to an external URL, open your document in a browser.

Tip You can view the URL for a link by opening your document in Ed
Page mode and double-clicking the link to open the Link Editor. The
URL appears in the URL text box in the Link Editor. External links begin
with a sequence of letters followed by a colon, such as http:, ftp:, or
mailto:. Local links do not have this prefix.

When I click on a link, Claris Home Page displays some other error
message, such as “Sorry, unable to follow the URL “...”, due to a di
error: no such file (error -43).”

This message appears when a link refers to a file that does not exis
that Claris Home Page can't find. The target file may have been 
accidentally moved or renamed, or may have been deleted. You sh
update the link's URL. This can be done as follows:

1. Open the document containing the link.

If necessary, switch to Edit Page mode by choosing Edit Page from the 
View menu (Windows) or Window menu (Macintosh).
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2. Select the link.

3. Choose Link to File from the Insert menu, or click the Browse Files 
button in the Link Editor.

4. Select the target file for the link.

Note A common cause for this error is incorrect use of the “Use abso
pathnames” setting in the HTML Source tab of the Applications Optio
dialog box (Windows) or Preferences dialog box (Macintosh). This 
setting should normally not be enabled.

When I click on a link that points to an anchor in the same file, noth
happens. Or, when I click on a link that points to an anchor in anoth
file, Claris Home Page takes me to the beginning of the other file, 
instead of taking me to the location of the anchor.

The anchor has been accidentally renamed or deleted, or the link's 
has been entered incorrectly. To correct this problem:

1. Verify that the target anchor still exists (open the target documen
Edit Page mode, and look for the anchor symbol).

If the anchor does not exist, choose Anchor from the Insert menu to re-
create it.

2. Select the target anchor, and choose Object Editor from the View menu 
(Windows) or Show Object Editor from the Window menu 
(Macintosh).

The Name text box in the Object Editor shows you the name of the
anchor. If the name is incorrect, type the correct name in this box
select the name from the pop-up menu.

3. Open the document containing the link in Edit Page mode.

4. Select the link and open the Link Editor.

5. If the anchor is local to this document, inspect the value in the URL 
text box. (It should begin with a pound sign followed by the name
the anchor.) Enter the correct anchor name in this box. 

If the anchor is located on another Web page or site, the value in
URL text box should include the filename of the page or URL of th
site followed by the pound sign (#) and the correct anchor name.
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Problems viewing documents in a browser
When I choose the Preview in Browser command, the following mess
appears: “Sorry, not enough memory to open the browser applicatio
Try quitting some other applications.”

There is not enough memory to open the browser application at the s
time as Claris Home Page.

On a PC with Windows, some browsers will restart each time a pag
previewed and a new copy of the application is opened. To free mem
close the application windows not in use.

On the Macintosh, try reducing the amount of memory allocated to 
browser (by selecting the browser's icon in the Finder operating sys
software and choosing Get Info from the File menu), or follow the usual
steps for making more memory available: quitting other applications
turning off extensions, etc. Typically, you will need a Macintosh 
equipped with at least 12 megabytes of memory to run Claris Home
Page and a browser application at the same time.

When I choose the Preview in Browser command, the browser ope
but the file is not displayed.

The browser may not be installed correctly. Some browsers (notabl
Internet Explorer for Windows) can be damaged by applications tha
change registry entries, causing the system to incorrectly send “ope
file” messages to them. Re-install a fresh copy of the browser if you h
this problem.

When I choose the Preview in Browser command, some other erro
message appears, such as “Sorry, an error occurred (-xx) while 
attempting to open the browser application”, or “Sorry, an error 
occurred while attempting to send this file to the browser.”

There may be a problem with the browser application you have sele
as the default, or the browser application may be missing.

Choose Application Options from the Tools menu (Windows) or 
Preferences from the Edit menu (Macintosh) to open the Preferences
dialog box. Click the Browser Preview tab to display a new set of options
Click Clear and re-select the browser. 

My page doesn't look quite the same in the browser as it does in Cl
Home Page (different fonts, lines are broken at different positions, e
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The HTML standard does not precisely define the appearance of a 
document. It sets broad guidelines, but individual programs (such a
browsers) are free to use their own variations. Therefore, it is imposs
to create an HTML file that will look exactly the same in every brows

Claris Home Page 3.0 attempts to display HTML documents as they
appear in Netscape Navigator 2.0 (based on Navigator's default 
preferences settings). Certain features (such as table layout) are 
implemented differently in Claris Home Page than in Navigator, and
minor differences in spacing are inevitable. With other browsers, or
you have altered Navigator's font preferences, there will be greater
differences. Finally, your document may use advanced features no
supported by other browsers, such as tables, frames, or colored tex

If you plan to publish your HTML document on the Internet, it may b
viewed by many different browsers on many different platforms. 
Therefore, you should not attempt to, or expect to, precisely control
layout and appearance of your document. Even if your HTML docum
is to be used locally (on an “Intranet”), users may employ different 
browsers or have customized font preferences and other browser se
that will affect the appearance of the document.

When I view my page in a browser, a strange character sometimes
appears on blank lines.

Claris Home Page inserts a non-breaking space character (represe
by the ISO Latin Character code, &nbsp;) on what are otherwise bla
lines. This is done to work around the interpretation of HTML by certa
browsers, such as Netscape Navigator, which ignores blank lines. 
Unfortunately, other browsers sometimes incorrectly interpret this 
HTML as representing a different (non-blank) character: for exampl
Netscape Navigator 2.0 with “Japanese encoding autodetect” enab
sometimes does this.
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Links within my Web site work fine in Preview Page mode, but don'
work when I click on them in a browser.

A variety of problems can cause links to function incorrectly (see 
“Problems with links” on page C-4). One additional problem that ca
occur outside of Claris Home Page involves the Base Document URL text 
box in the Document Options dialog box. Claris Home Page 3.0 assu
that this field (which corresponds to the <BASE> tag in the HTML 
source), if not empty, contains the URL of the document in which it 
appears. If you enter a different URL in this text box, relative links m
not work correctly. The solution is to remove the value in the Base 
Document URL text box, or set it to the URL of the page in question, a
then use the Link Editor to re-create any malfunctioning links in tha
page.

Images from the Claris Home Page libraries work fine when I view 
pages on my local computer, but don't work when I upload my site 
Web (HTTP) server.

When uploading your site to a Web server, you need to make sure 
include all files used in the site, including image files. The standard w
to do this is to create an Images folder inside the folder that contains 
site, and to place all image files in this folder. When you transfer 
(upload) the site folder to a server, the images will automatically be
included.

When you insert an image from a library into your document, Claris
Home Page uses the path to the original image file in the Content fo 
To correct the problem, you need to copy the actual image file into y
site's Images folder, and replace all references in your site to the orig
image file with references to the new file or open the Site Editor and 
the consolidate feature.

Problems using Claris Home Page assistants
What happens if I finish the assistant early?

The assistant assigns default values to all of the settings and creates
based on the default settings.

I used a Claris Home Page assistant to create a site and know I 
wondering, where is my home page?

Your home page is named index.htm and it is located inside the fol
you selected to save your assistant files.
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I finished the assistant–now what do I do if my links are not working

Make sure your links reference the correct filenames. If you changed
filenames of the documents created by this assistant, you must re-c
the links using the Link Editor and reference the new filenames.

How do I upload my new site to the Web?

When you finish the assistant, Claris Home Page opens the new si
the Site Editor. To upload the site to a Web server, click the Upload 
button  on the Site Editor toolbar. To use the Uploading feature, m
sure your computer network supports File Transfer Protocol (FTP) 
that your Web server account settings are specified completely. Fo
more information on setting FTP options and uploading your pages,
chapter 12, “Uploading your pages to a Web server.”

What do I do if my images are missing after I upload my site to the W

The first thing you should do is consolidate all the images in your site
clicking the Consolidate button  on the Site Editor toolbar. When you
consolidate the images, Claris Home Page copies the image files or 
referenced content files from other folders and places them in your 
folder. Any references to this content in your Web pages will be upda
automatically to ensure that none of your media is missing when yo
upload your site again to the Web server.
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 files; images; Web pages; 
libraries

BMP 4-1, 4-2
consolidating 12-4
converting 4-1, 4-2, 4-3
downloading 4-1, 4-8
GIF 4-1, 4-2, 4-3, 4-8
JPEG 4-1, 4-2
PICT 4-1, 4-2
sizes 2-15
storing 1-8
supported formats 4-1

Image Map Editor 7-11
image maps

 

See also

 

 images; links
behavior attributes 7-11
Circular Link tool 7-9, 7-11
client-side 7-9
creating 4-10, 7-11
default links 7-10, 7-11
described 7-8
hotspots 7-8
Rectangular Link tool 7-9, 7-11
server-side 7-10

Image Object Editor 4-5, 7-11
images

 

See also

 

 image files; image maps
adding 4-2
alternative label for 4-6
behavior attributes 7-11
borders 7-2
buttons on forms 9-18
deleting linked images 7-14
described 4-1
formatting

aligning with text 4-6
background colors 4-9
borders 4-6
changing attributes 4-5 to ??, 
4-7

scaling 4-7

sizing 4-7
transparent 4-9

hotspots, image map links 4-10
in tables 5-2
interactive 4-10
interlaced 4-8
JPEG images, gray rectangle 
display C-1

linking 7-8
performing actions 4-10
Web page backgrounds 2-22

indented lists. 

 

See

 

 lists
indenting text 3-5, 3-11
installation, troubleshooting C-1
interlaced images 4-8
ISO Latin-1 character set 3-8

 

J

 

Java applets
adding 11-9
adding extra HTML 11-12
changing name or location 11-13
display 11-11
specifying parameters 11-11

Java applets, adding 11-9
JPEG files. 

 

See

 

 images; libraries
jumps. 

 

See

 

 links; frames, assigning 
Web pages to

 

K

 

keyboard shortcuts
listed B-1

 

L

 

labeling
images 4-6
list items 3-5
table rows and columns 5-5

left aligning text 3-5
less than sign, special code for A-1
letter spacing 3-5
libraries

 

See also

 

 elements; image files; 
files; Web pages

changing text elements 6-6
copying elements from 6-3
creating 6-4

described 6-1
displaying 6-3
editing text elements in 6-7
entries

adding 6-6
deleting 6-7
editing 6-6
moving 6-6
renaming 6-7
reordering 6-6
selecting 6-1

file extensions 6-3
opening 6-3

line break format 2-20
lines

breaks 3-1, 3-2
horizontal 3-17
spacing 3-1

Link Editor 2-11, 7-2
links

 

See also

 

 anchors; image maps
active color 7-15
borders 7-2
breaking 7-14
changing colors 7-14
copying 7-2, 7-13
creating 7-2, 7-4, 7-6
deleting 7-14
described 7-1
error messages C-4
external Web pages 7-6
hotspots 7-8
in frames 8-11, 8-14
normal color 7-15
pathnames 2-20
planning 7-1
repeating 7-2
testing 7-12
to email address 7-7
to FTP site 7-7
visited color 7-15

links, error messages C-4
lists

 

See also

 

 forms
bullet 3-9
described 3-9
glossary 3-9
in forms 9-11
indented 3-11
items

adding 3-10
number styles 3-11
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reordering 3-11
selecting 3-12

nested 3-11
numbered 3-9, 3-10
ordered 3-9
scrolling, in forms 9-11
unordered 3-9

logical character styles 3-5, 3-7

 

M

 

mailto URLs 7-7
media folder 12-5
modes

 

See also

 

 Site Editor
Edit Frames 8-2
Edit HTML Source 2-16
Edit Page 2-6
Preview in Browser 2-12, 2-13, 
2-14, 2-24

Preview Page 2-13
monospace font 3-5
movie play options, setting 11-7
multimedia plug-in options 11-3

 

N

 

navigational frame layout 8-11
nesting

 

 See also

 

 frames; lists
frames 8-1
lists 3-11

Netscape Navigator 2-13
Newsletter Assistant. 

 

See

 

 assistants
normal links, default color 7-15
number style 3-5
numbered lists. 

 

See

 

 lists

 

O

 

object editors

 

See also

 

 toolbars
Anchor Object Editor 7-6
Applet Object Editor 11-10
described 2-10
for form areas 9-2
for form elements 9-4
Frame List Object Editor 8-6, 8-7, 
8-10

Frame Object Editor 8-6

Horizontal Rule Object 
Editor 3-17

Image Map Editor 7-11
Image Object Editor 4-5, 7-11
Link Editor 2-11, 7-2
QuickTime Object Editor 11-6
Table Object Editor 5-3

of 8-10
opening

HTML files 2-6
images 4-2, 11-2, 11-6
libraries 6-1

order forms 9-1
ordered lists. 

 

See

 

 lists

 

P

 

page templates. 

 

See

 

 templates
paragraph alignment uses 2-20
paragraphs

 

See also

 

 characters
aligning 3-5
creating 3-1
formatting 3-4
spacing 3-1
styles 3-4

parent frameset
described 8-5
selecting 8-10

Password Field Object Editor 9-14
passwords

for FileMaker Pro databases 10-5
form element for 9-14
saving FTP account 
passwords 12-9

pasting elements 2-7
pathnames 2-20
Personal Site Assistant. 

 

See

 

 assistants
physical character styles 3-5, 3-6
PICT files. 

 

See

 

 images; libraries
pictures. 

 

See

 

 images; libraries
planning Web sites 1-1, 1-3
plug-ins, browser 1-12, 11-1
plus sign, special code for A-1
pop-up menu

 

See also

 

 forms
defining values for 9-11

Pop-up Object Editor 9-11
preferences. 

 

See

 

 application options

preformatted text 3-5
Presentation Assistant. 

 

See

 

 assistants
previewing

 

See also

 

 testing
background images 2-21
baseline text alignment 5-11
frame documents 8-2
in a browser 1-10, 2-13
in Preview Page mode 2-13
number styles 3-10
special characters 3-9

printing
Web pages 2-27

problem solving tips
accessing onscreen help C-1
fixing links C-4
installing Claris Home Page C-1
opening files C-3
previewing in browser C-6
running Claris Home Page C-1
using assistants C-6
using Claris Home Page 
Assistants C-8

 

Q

 

questionnaires. 

 

See

 

 forms
QuickTime

adding movies 11-5
movie play options 11-7
resizing movie window 11-7

QuickTime Object Editor 11-6
quotations, formatting 3-5

 

R

 

Radio Button Object Editor
radio buttons. 

 

See

 

 forms; toolbars
Rectangular Link tool 7-9, 7-11
relative pathnames 2-20
remote server. 

 

See

 

 Web servers
replacing text 3-2
Report Assistant. 

 

See

 

 assistants
resizing elements 2-11
right aligning text 3-5
right click. 

 

See

 

 context menu
root frameset

described 8-1
selecting 8-10
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rows. 

 

See

 

 lists; preformatted text; 
tables

rules, horizontal 3-17

 

S

 

saving elements 6-4
saving files 2-24
saving files to a remote server 12-12
School Site Assistant. 

 

See

 

 assistants
scrolling lists. 

 

See

 

 forms
search and replace (text) 3-2
searching in a database form. 

 

See 

 

 
FileMaker Pro forms

selecting
framesets 8-10
library entries 6-3
list items 3-12
table cells 5-2

separators 3-17
server. 

 

See 

 

Web server
shortcut menu. 

 

See

 

 context menu
site assistants 2-4
site definition files

described 12-1
Site Editor

 

See also

 

 downloading; modes; 
uploading

defining a site 1-8
described 1-7
site definition file 1-9, 12-2
using 2-27

site,setting up 1-7
span cells across columns/rows 5-9
special characters 3-8, A-1
spelling checker 3-12
spreadsheet data 5-1
Standard Site Assistant. 

 

See

 

 assistants
starting Claris Home Page 2-1
startup options 2-3
statistics, download 2-14
Style toolbar 2-7
styles

character 3-5, 3-7, 3-14
colors 3-14
HTML limitations 3-1
logical 3-5
paragraph 3-4

physical 3-5
special characters 3-8

Submit Button Object Editor 9-16
symbols, typing 3-8

 

T

 

table cells
described 5-1
padding 5-4
selecting 5-2

Table Object Editor 5-3
tables

 

See also

 

 lists; preformatted text
adding extra HTML attributes 5-4
browser support 5-1
columns 5-4
customizing 3-18
described 5-1
formatting

aligning elements 5-10
borders 5-4
changing attributes 5-4
changing cell attributes 5-5
height 5-6
spacing 5-4
text 5-10
width 5-6

headings 5-10
importing

spreadsheet data 5-1
tab separated files 5-1

inserting 5-1
labeling 5-5
libraries 6-1
rows 5-4
selecting 5-2

tags. 

 

See

 

 HTML; styles
templates

 

See also

 

 assistants; Web pages
described 1-3
saving 2-25

testing

 

See also

 

 previewing
appearance of text 3-1
FileMaker Pro forms 10-56
form input elements 9-20
form reset buttons 9-15
form submit buttons 9-16
frame associations 2-13
links 7-12
QuickTime movies 11-8

Web pages 2-13
with different browsers 1-11

text
adding 3-2
addresses 3-5
bylines 3-5
copying 3-1
deleting 3-1
finding 3-2
formatting

aligning 3-4, 4-6
colors 3-7, 3-14
fonts 3-1
headings 3-4
HTML limitations 3-1
line breaks 3-1
monospace font 3-5
preformatted 3-5
quotations 3-4
sizing 3-7
spacing characters 3-5
styles 3-4

hyphenating 3-1
in forms 9-6, 9-7
in lists 3-9
in tables 5-10
libraries 6-6
paragraphs 3-4
replacing 3-2
special characters 3-8
styles 3-5
titles 2-25
wrapping 3-1

Text Area Object Editor 9-7
text areas. 

 

See

 

 forms
Text Field Object Editor 9-6
text fields. 

 

See

 

 forms
time estimates 2-14
titles 2-25
tool palette for form elements 2-9
toolbars

 

See also

 

 object editors
described 2-7

transparent images 4-9
troubleshooting. 

 

See

 

 problem solving 
tips

U
undoing actions 2-7
Uniform Resource Locator. See URLs
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unordered lists. See lists
uploading

See also copying; downloading; 
Site Editor

described 12-1
entire Web sites 12-10
open Web pages to a server 12-12
preparing for 12-1

URLs
See also addresses; anchors; links
copying 7-2
email addresses 7-7
examples 7-7
FTP sites 7-7
HTTP 7-7
mailto 7-7
specifying 7-6
syntax 7-7
Web pages 7-7

V
visited links, default color 7-15

W, X, Y, Z
wallpaper. See backgrounds
Web browsers 1-11, 1-12, 2-14

HTML feature support 1-3
plug-in applications 11-1
previewing in 1-10
testing with 1-11

Web Companion 10-1, 10-5, 10-56
Web pages

See also files; image files; 
FileMaker forms; templates

assigning to frames 8-8
backgrounds 2-21
creating titles 2-25
editing 2-6
linking 7-1
navigational frame layout 8-1
opening 2-6
previewing 2-12, 2-13
printing 2-27
saving as templates 2-24
URL syntax 7-7
using frames 8-1, 8-2, 8-11
viewing 2-12

Web Security database 10-5
Web servers

account settings 12-8
downloading files from 12-14
testing on 1-12
uploading files to 12-9

Web Sharing 10-1, 10-4, 10-5, 10-56
Web sites

See also copying; uploading; 
downloading; Site Editor

definition file 12-1
deleting files from 12-15
design of 1-2
media folder 12-5
size of 12-2
testing 1-1

words, counting 2-15
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