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Welcome to Nisus 

Introduction: The Ni’sus Way 

Nisus [L., noun of action f, niti, to strive, endeavor.) Effort, endeavor. 

Now that you have Nisus, you can be confident of producing a well- 

designed, accurate document. With Nisus you become part of a 

powerful communications partnership—your job is to provide the 

creative input while Nisus quickly handles the time-consuming details. 

Nisus can make anyone who has a need to write into a word-processing 

expert, even without complicated training. With virtually unlimited 

undos and redos, for example, you can polish your document to 

perfection. Multiple clipboards enable you to save (and edit) different 

portions of a document until you are ready to put them together. 

Index and table of contents are easily generated, and Nisus also 

provides character, word count and readability information. 

Form follows function. In a word processor, preparing the text is 

function. Beyond its powerful text editing abilities, Nisus offers the 

user versatile resources to shape the visual form of the final text. 

Nisus files are saved as text. This means that any word processor 

that can read text files (and that means virtually any word processor) 

can read files created with Nisus. This is significant because we at 

Paragon created Nisus as a tool to enable increased communication. 

Perhaps the most impressive feature in Nisus is the incredible search 

and replace facility. Not only can you find and replace specific words 

and phrases, but you can search for patterns of characters, even if 



youre not precisely sure what you're seeking. And you can look 
through all your files, whether they're open or not. 

Nisus easily integrates graphics and text by including both text editing 
and graphics tools. You can «’:=w or paste a picture over the text, 
then with a single click show ti.. words through the picture. Another 
click will wrap the words around it. Picture outlines can be filled 
with any one of many available patterns or used creatively with 
other pictures. As with text, you can undo one or all previous 
commands. 

If you use certain words or phrases frequently, you can create a 
glossary replacing a simple abbreviation with the full word. Even 
more convenient, glossary entries can be converted to their definitions 
with a keystroke, or entered directly. 

Add to all of this the most sophisticated thesaurus and spelling checker 
available, an editable page preview that updates instantly, and a 
facility for writing and recording your own macros. 

Impressed? You should be, but don’t let all that Nisus has to offer 
intimidate you. Remember, Nisus was written with only the Macintosh 
in mind. Though packed with powerful features, Nisus is for everyone 
from novice to professional. 

There is no doubt that Nisus is “the amazing word processor for the 
Macintosh.” But as good as Nisus is, Paragon Concepts continues to 
work to make it even better. Updates will be available to registered 
owners, So be sure to send in your registration card. 

Using the Manual 

The manual is organized so that you can read the material straight 
through, in the order that it is presented. It is also meant to be used 
for reference. 

The manual observes the following conventions: the basic text of the 
manual is in this typeface. When the manual refers to a command in 
the menus, or in a dialog box, or quotes from a text in a dialog box, 
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that text is printed in the font as it appears on the screen (Chicago). 
When the manual refers to an item elsewhere in the manual that has 
a title, or is the label for an illustration you will see it, as it appears in 
the manual, for example: “see Figure 3-1” or “for more information 
see the section on The Nisus Menus, page 9.” 

As you read, you will notice some paragraphs preceded by I. This 
indicates information of particular importance or shortcut methods 
of doing things. 

Most often, Nisus shortcuts involve using Command key (%) 
equivalents. To use a Command key equivalent, first press the 
Command key, and while continuing to hold it down, press whatever 
other key or keys are required. For example, pressing Command and 
then the letter X will cut a selected text. Look for Command key 
shortcuts in text and figures throughout the manual. On the screen, 
you can see Command key equivalents in some menus. You can also 
see them in dialogs when you press the Command key. 

Logically related tasks are grouped into single chapters. Topics may 
be mentioned in more than one place, where appropriate, but they 
are explained in depth only once. When using the manual for reference, 
consult the Table of Contents to find general topics, but refer to the 
Index to locate specific words or terms. 

If you are new to word processing, the tutorial will be of great value 
to you. In any case, it will introduce you to the Nisus way of doing 
things. 

Nisus faithfully follows the Macintosh User Interface. Though Nisus 
is among the most powerful word processors on the market, it has a 
very gentle learning curve. The menu commands are placed where 
one might expect them to be. Skills learned in editing the main 
document can be transferred to another part of the program (headers, 
footers and footnotes as well as the glossary and macros). 

Any action that can be accomplished in the main text editing window 
can probably be accomplished in any other window: Copy, Cut, 
Paste (from any window to any other—even dialog boxes [where 
you can even use your Command keys]), insertion point control from 
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the keyboard, double/ triple-clicking, zooming windows, reverse 
scrolling, change Font, Size and Style, apply line numbers (even 
in the Catalog and Find/Replace dialog window). 

It is possible to customize Nisus, but not at the expense of consistency 
of use over different computers. The menu commands always appear 
where they were when shipped. Thus, mouse access to them is the 
same on any Macintosh. And in Nisus, you can set as many 
personalized menu key equivalents as you wish. 

We are concerned about you and your work. Nisus is very forgiving. 
Virtually any action can be undone, and undone. Various portions of 
your work can be temporarily stored on any of the ten editable 
clipboards. Nisus enables you to save your work automatically, with 
backup copies even saved to a second disk drive. 

Technical Support 

If you encounter problems trying to get Nisus to do what you need 
to accomplish, the solution is probably in the Manual or in the on-line 
Help... facility under the @ menu. However, if you still have 
difficulties, check Troubleshooting page 465. Then, if the problem 
persists, call Paragon Concepts Technical Support. 

Make your phone call when you are near your Macintosh and Nisus 
is running. Please have as much information as possible about the 
problem you are experiencing before you call, including; 

* The kind of Macintosh you are using (Mac+, SE, etc.) 
* Other hardware you are using if applicable (monitors, drives, 

printers, etc.) 
¢ How many megabytes of memory you have in your system 
¢ What version of Nisus you are using (which appears in the 

About Nisus®... dialog in the Apple € menu) 
* What version of the Macintosh System Software you are 

using (which appears in the About the Finder... dialog 
in the Apple @ menu when you are running the Finder) 

¢ Whether or not you are working under MultiFinder, and if 
so, what partition you have assigned to Nisus (under the 
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Finder, click on the Nisus application icon and choose Get 
Info... from the Apple € menu) 

e Any cdev's (Control Panel Devices) and/or INIT'‘s 
(Initialization programs) you may have in your system. 

ts Try to have a phone by your Macintosh and have Nisus running 
- | when you call. It is much easier for the Technical Support staff of 

Paragon to help you if they can “walk through” the process with 
you. 

The Technical Support staff is always giad to help. Technical Support 
can be reached at 1 (800) 922-2993. We created Nisus so that you 
could do your writing more easily. We want to assure that all your 
writing Nisus are a pleasure with Nisus. 
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Getting Started 

Package Contents 

When you open the Nisus box you should find the following: 

¢ Program Disk (containing the Nisus Application and the 
Read Me file) 

¢ Spelling Checker/Thesaurus Disk 
Other Files Disk (containing the Programming Dialect, 
Tutorial Files, Help file, and Stationery Files) 

Registration and Warranty Card 
Nisus Manual 
Quick Reference Guide 
Nisus Menu Reference pamphlet 
Nisus Macro Language: Programming Dialect pamphlet 

See your dealer immediately if any item is missing. 

Complete and mail the registration card. Only registered owners will 
receive technical support and be notified of updates. For your 
convenience, Nisus is not copy protected. 

system Requirements 

For optimum convenience, you should have at least a Macintosh 
Plus (1 MByte RAM) with a hard drive and one disk drive. If you 
have a Macintosh Plus (or a newer system) without a hard drive you 
must have two 800K-disk drives. Nisus can be used on a Macintosh 
XL or Lisa with a hard drive, running MacWorks™ Plus and modified 



to use one double-sided drive and a hard drive. You must use System 
Software version 5.0 (System file 4.2 and Finder file 6.0) or greater. 
The latest version appropriate for your Macintosh configuration is 
recommended. 

What You Are Expected to Know... 

It is assumed that you are familiar with all Macintosh operations 
described in the user manuals supplied with your computer. 

installation 

Hard Disk Installation 

If you are using a Hard Disk, copy all the files from the Nisus Disks 
to a single folder on your hard disk. 

Disk Drive Installation 

Using Nisus with two 800K-drives is not recommended. The program 
will work independently, but using the Spelling Checker or Thesaurus 
will require extensive disk swapping. 

Keep your documents on the copied Program disk if there is room. 
You may also keep them on a separate disk. Nisus will only ask for 
the disk when you save the document, because documents are kept 
entirely in memory until they are saved. 

i” The original Nisus disks should be stored in a safe place as your 
backup, in case your working copies are damaged. You will need the 
unchanged original to take advantage of any future upgrades. 

i” Know what kind of printer you are using. There are two basic kinds 
of printers: QuickDraw and PostScript. The Apple ImageWriter 
printers are QuickDraw printers while many Apple LaserWriter 
printers are PostScript printers. If you are using a PostScript printer 
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you will want to set your Nisus New File (see page 65) with Display 
As PostScript® selected. This will assure that what you see on 
screen on the graphics sheets is what you will be able to print on 
your printer. 

Launching Nisus 

Getting started in Nisus is just like launching any other Macintosh 
application. Locate the folder containing the Nisus application or any 
Nisus document. Double-click on the Nisus icon or on any Nisus 
document. If you want all the advanced features of Nisus to be 
available, both the application and the Programming Dialect) need to 
a bein the same folder. 

The Nisus Menus 

Figure 2-1 The Nisus Menu Bar 

This is a brief overview of the Nisus menus and many of their menu 
items. It will help you gain a general understanding of most of the 
features as you pull down the menus for the first time. The primary 
menus in Nisus are illustrated in Figure 2-1. For more detailed 

information, consult Help... under the @ menu, the Nisus Menu 

Reference pamphlet, as well as the table of contents, index and 

glossary. 

It is a convention of Macintosh menu commands to have an ellipsis 
(“...) follow those commands that bring up a dialog of some kind 
but don't directly affect your document. 

Many menu commands are modified when you choose that command 
with a “modifier” key pressed. This has been a feature in Nisus since 
its first release. Early users of Nisus already know that you can append 

to the clipboard by pressing the Shift key while choosing Copy from 
the Edit menu. Now, when you press one or more of the modifier 
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keys as you choose a menu item, the original command will be changed 
to read what the command accomplishes with that modifier key 
pressed, as illustrated in Figure 2-2. 

New 

Open... 

Catalog... 
Open Selection 

Close 

Save 

Save As... 

Revert To Saved 

Get Info... 

Preferences » 
Save Preferences 

Layout Page... 
Page Setup... 
Print... 

SET lle, LS TT | EM hited es 2 

Transfer... 

Quit 

MN] | New 

—r 

SE eT TTT SR tah es ES de + delle 

Transfer... 

Upen... 

Catatog... CT 
Open Selection 30 

Close All xu 

Save AliChanged X§ 
Save fis... SA 

Revert All Changed 
Get Info... 

Preferences > 
Save Preferences SP 

Layout Page... 
Page Setup... 

Print All 

Quit 

Figure 2-2 The File menu, and with the Option key pressed 

The modifier keys are: 

eShift 

eOption 
«Command 

You can see screen shots of the menus in all of their modifications as 
well as simple explanations of what each command accomplishes in 
the Nisus Menu Reference pamphlet. 

It is possible to use many of your menu commands when various 
dialogs are open. 

We have tried to keep hierarchical menus to a minimum, and then, 
only for less utilized commands (and these can all be accessed by 
way of Nisus' Menu Keys facility). 
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The @ Menu 

The Apple € menu primarily provides you with desk accessories 
while you are using Nisus. You can choose items in the Apple @ 
menu from your keyboard by assigning command key equivalents 
using Menu Keys. It also accesses: 

¢ About Nisus®... gives you the version of Nisus. 
* Help... is available here to give you initial assistance. To 

use it, Nisus must be able to find the Help files which should 
be in the same folder as the program or in the System Folder. 
If not, you will be asked for their location. 

The File Menu 

The File menu provides you with commands to Open..., Save, 
and Close your documents. 

¢ Catalog... brings to the front the Catalog window which 
can be used to open documents, load a Glossary, Macro, or 
dictionaries, and add or remove files from your search list. 

Note that while the Catalog window is in front, a Catalog 
menu appears at the right of the menu bar. 

* Get Info... brings to the front an information window 
which gives statistics such as word and character count and 
readability indices. The current document is evaluated 
individually and totals for all open documents are reported 
together. 

e Preferences gives you options to control the way Nisus 
works. 

¢ Layout Page... allows you set the margins and view your 
page as it will look when printed. 

« Page Setup... allows you to customize and sct options 
for printing. 

¢ Merge... allows you to merge documents, usually a mailing 
list and a form letter. 

¢ Quit allows you to close Nisus when you have finished 
working. 
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The Edit Menu 

The Edit menu provides you with commands to Copy, Cut, Paste, 
and Clear (remove without appending to the clipboard) text or 
graphics. You will find commands for many editing features: 

° Select All 

e UPPERCASE, lowercase, Capitalize 
« Move Left, Move Right, Sort 9, Break Lines, Zap 

Gremlins 

Ten editable Clipboards are also located here. 

The Tools Menu 

The Tools menu gives access to search and replace functions. When 
Find/Replace is chosen a new Search Method menu appears at 
the right of the menu bar. Both basic and very complex searches can 
be made using this menu. 

The Tools menu also contains commands which enable you to Jump 
To any place in the text and to Mark Text.... As you set markers, 
their names are appended to the Jump To submenu. 

The Tools menu gives you access to most of the advanced features 
of Nisus. 

¢ Spelling..., Thesaurus... and Hyphenate 
¢ Jump To 

You can Cross Reference... various portions of your 
text and Update H-Reference if your document changes. 

¢ The Place Page... and Place New Page commands 
allow you to place an updateable image of any other file 
into your document. 

* You can also create a user Glossary for writing abbreviations 
that can be expanded instantly or when your document is 
complete. 
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The Edit Tools submenu permits synchronous scrolling, 
comparison of two files and checking of parentheses as well 
as the ASCII Table... 

e The Display submenu contains various options you can 

choose to display in your document. Space Tab & 9 shows 
various symbols in your document that represent tabs, 

carriage returns, line feeds and forced page breaks. Text 

Hilites produces dotted boxes around variables, indexed 

words and words added to the Table of Contents. Graphic 

Anchors show the point in your document to which any 
graphic on the graphic layer is attached. 

¢ Windows provides options for handling multiple windows. 
This menu can be pulled down from the title bar of your 
document window by pressing the Option or Command 
key as you click on it. 

« Macros contains all the tools for working with macros. If a 
macro file is loaded, its macros are listed below the dotted 
line in the Macros submenu. 

The Format Menu 

In the Format menu you can select from a variety of commands 
that shape the appearance of your document. Among these commands 
are: 

« Insert Ruler 

* insert Header, Insert Footer 
« Insert Footnote 
° insert Page Break 

* Keep On Same Page 
¢ Insert Date, insert Time, Insert Doc Name and 

Insert Page #* as well as Update Time & Date variables 
¢ Mark Index and Mark Contents. 

The Font, Size, and Style Menus 

The Font, $ize, and Style menus allow you to change the appearance 
of your text. 
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The Style menu gives you access to the Define Style... feature. 
As you create user styles, they are appended to the Style menu. 

Note the special commands Any Font, Any Size, + Any Styles, 
Any Color and Any More User Styles. They are not av-:ilable 
when the top window is a document window. These are used only 
for describing the attributes of searched text in the Find/Replace 
dialog or in text in the Macros and Glossary windows. 

Additional Menus 

When needed, additional menus appear to the right of the Style 
menu. Each of these menus contain commands that will help in 
performing specific tasks. These additional menus are: Catalog, 
Layout, Search Method, Graphics, Header/Footer and 
Footnotes. 

CHAPTER TWO 



3 
Tutorial 
Session 1: 

Tour the Window 

This session of the Tutorial presents an introductory tour of the Catalog 
and various icons in a Nisus window. You will learn what they are 
called and what they accomplish. Page numbers (page » follow those 
items discussed in the manual. 

¢« Double-click on the Nisus icon . Find the Tutorial folder 

in the Catalog (page 191) window that appears in the upper right 
hand corner of your screen behind the blank Untitled-1 
document. Select the eTutorial folder by clicking on it, then 

click the (open button. Drag your mouse across the two 

files labeled Window Icons Tour and Window Icons 
Tutorial 3.0. Click the Open button. Using the Catalog, you 
can open more than one file at a time as illustrated in Figure 3-1. 

&) *Tutorial 

© personal 

fv) Lindow tcons Tour 
fy) Ulindow Icons Tutorial 

<= Macintosh... 

Figure 3-1 Catalog with two files highlighted for opening 

15 
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The following window, Figure 3-2, will appear as the top window. 

= Window Icons tutorial 

Zoom Box; Macintosh Standerd 
Close Box; The Arrows Nisus Show Info Ber Icon 

Macintosh Stendard will change Nisus Show Master Ruler leon 
position (and Nisus Show Graphics Palette icon 

Nisus Layout Page Icon 
not point to Nisue Horizontal Split Ber Handle 

Up Seroll Arrow; Macintosh Standard 

Serol] Box; Mecintesh Stenderd 

what they 
refer to} as 
the icons are 
“clicked.” 

Nisus 
Nisus Vertical Split Size Box. 

Show Macintosh Standard 
Vertical Ruler, Nisus Left Scroll Arrow Down Scroll Arrow 

an Nisus Seroll Box Nisus Right Scrotl Arrog ~Liscintesh Standard 

Click on the Show Info Bar icon [J | to select it. It will become 
highlighted I and the Info Bar (page 6) 
FZ 

will appear below the window’s Title Bar. 

Click on the Show Master Ruler icon [cal to select it. It will 

become highlighted [ra] and the Master Ruler (page 7m 
ass Ez) BS ey See Shtext 

will appear below the Info Bar. 

Click on the Show Graphics Palette icon to select it. It will 

become highlighted and the Graphics Palette «page 242) 

BO Sao 1 |) Gh) = oo Ry 
a ee ee | ae a i 

will appear below the Info Bar in place of the Master Ruler. 

Click once again on the Show Graphics Palette icon to cause 
it to disappear. 
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e Click on the Show Info Bar con RE to cause it to disappear. 

e Click on the Layout Page icon It will “flash” once and the 

Layout... window (page135), Shown in Figure 3-3 will open. 

Window Icons Tutoriel Layout 

CE iii panel 110.000" 647.250" ls BE I 
0.500" te 

27% b. fhe: 00" 

Figure 3-3 The Layout Window 

e Click on the Close Box 

to return to the original window (we will explore this Layout window 
in a later session of the Tutorial, page 39). 

You can view and edit in two portions of your document 
simultaneously. 

e Beneath the Layout Page icon is the Horizontal Split Screen Bar 
handle SMM (page «79. Drag it down below the rounded rectangle. 
This will split your window into two panes similar to Figure 3-4. 

Above the Horizontal Split Screen Bar handle is the Down arrow of 
the upper pane and beneath the Horizontal Split Screen Bar handle is 
the Up arrow of the lower pane. At the bottom of the window there 
is a Down arrow. While the window is split this is the Down arrow 
for the lower pane. 

Tutorial: Session 1: Tour the Window 1 7 
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¢ In the lower pane of the window, hold the mouse button down 

on the Down arrow Ke] and scroll to the bottom of the page 

until your window appears as in Figure 3-4. 

¢ Click your insertion point | in the sentence in the lower pane. 

; Window Icons Tutor) eee Ts 

Zoom Box; Macintosh Stendard Ly, = 
Nisus Show Info Bar Icon 

Nisus Show Master Ruler icon 

Nisus Show Grephics Palette tcon “p 

Nisus Leyout Page Icon — 

Nisus Horizonte? Split Bar Handte // Be 

Close Box; 

Macintosh Standard 
The Arrows 

wilt change 

position (and 
not point to 

what they 

refer to) as 
the icons are 

“clicked.” 

Up Scroll Arrow; Mecintesh Stendard 

Scroll Bex; Macintosh Standerd 

eatisaees ss seeles etal 
vest 8s oak eros crise 

Figure 3-4 Split Window 

This is the active pane. Over this pane your insertion point looks like 
an “I - beam.” Over the inactive pane it appears as an arrow h. 
(Entering text at the “I - beam” will be discussed in Session 4 of the 
Tutorial.) The upper pane knows where the insertion point is. 

e Click on the Scroll Box [| in the upper pane. The Scroll Box 

L will “flash” | 

key; the upper pane automatically scrolls to show the insertion 
point position. 

; the upper pane will be activated. Press the Enter 

¢ Double-click on the Horizontal Split Screen Bar handle Mf to 
return the window to its original state. 

You can make your window almost any size you wish. 

¢ Click on the Size Box in the lower right-hand corner of the 
window. 
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¢ Hold the mouse button down and drag the window up and into 
the left as illustrated in Figure 3-5, so the edge of the window is 
inside where the scroll bars were. 

¢ A portion of another file’s window is visible along the right and 
bottom edges of your screen as seen in Figure 3-6. 

Rey 

Figure 3-6 Using the Size Box B 

¢ Choose Catalog... from the File menu. 

Notice that the Catalog indicates what file is open with a check mark 

tig’ in place of the mini icon. 

e Click on the scroll bar at the bottom of the screen. 

The file Window Icons Tour is now the front window. 

¢ Follow the ten steps indicated in that file for another tour of the 
window. At step 10, unclick the two highlighted icons, but don’t 

yet close the window. 

You may, Sometime, need to work in more than one file/ window at 

a time and need to move one window partially off the screen. 

« Place your pointer on the Title Bar of the file Window Icons 

Tour and drag it straight down about an inch, so that its vertical 
scroll bar is visible but its Down arrow is hidden. 

e Press the Option key while you click on the Up arrow until you 
reach the bottom of the file. Your window will scroll “backwards” 
as illustrated in Figure 3-7. 
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: Window tcons Tour == 

Pressing the Option key while 

scrolling 4 window causes the 

scrolling to move in the reverse 
direction of the arrow. 

——  ? 

Figure 3-7 Reverse scrolling with the Option key 

e Click in the Zoom Box E! to return the window to its original 
position. 

Suppose you had moved the window off the screen to the right so 
that the Zoom Box was not visible. 

* Double-click the Title Bar to return the window to its original 
position with the zoom box visible. 

The scroll bar at the bottom of the window functions essentially the 
same as that on the right edge of the window except that its icons 
move the window horizontally instead of vertically. 
Along the left edge of the screen a small sliver of the file Window 
Icons Tutorial is visible. 

¢ Click on that sliver of window to make it the front window. 

¢ Click on the Scroll Box and drag it to the top of the file. 

¢ Click your insertion point at the top of the file. 
You can either close the windows individually by clicking their 
respective Close Boxes or you can close all open windows at once. 

e Press the Option key and click the Close Box. 
This session is now complete. 
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Session 2: 
Manipulating Rulers 

This session of the Tutorial presents the basic skills used in 
manipulating rulers. You will learn how the different icons and menus 
on the Master Ruler affect your document. Page numbers (page «#) follow 

those items discussed in the manual. 

® Double-click on the Nisus icon . Find the Tutorial folder 

in the Catalog window that appears in the upper right hand 

corner of your screen. Select the eTutorial folder by clicking on 

it; then the {Open ___J button; then do the same for the folder 
labeled Cases as illustrated in Figure 3-8. 

iu 

7 Cel Mar 

© Encinitas 

C Escondido 

(2 Linda Vista 

Figure 3-8 Catalog window with Cases folder open 

¢ Click on Del Mar then click Open. Follow the same procedure 
with the file labeled 9/13/89. You will see the window that 
appears in Figure 3-9. 
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wasnt expected at the office for a while so J took advantage of the 
time to get some information from the two sisters. Jayn and Carole. | 
had driven up 1-805 to 1-5 and got off onto Via de ia Valle. Just a short 
way into the “flood plane” of the San Dieguito river, past the tomato 
fields I turned. The little green sign read The thoughtless 
Anglos hadn't considered using an fi on the street sign. At the bottom, 
the canyon is barren and unassuming. Up above large homes were 
nestled into the hillsides surrounded by lush green shrubs that soak up 
the water from the Colorado and San Juaquin rivers. 1 turned onto 
Vista del Lugano into a little cu/ oe sechuddled in a tiny bow! among 
the hills. The two houses I was looking for were side by side on 
opposite sides of the s#; taking up the entire street. Each was a clear 
representa 

Info BaF wacecs 

Beneath the Title Bar, you can see the Nisus Info Bar. Below that you 
can see the Master Ruler at the top of the document. At the left edge 
of the Info Bar is a number “0/1.” This number indicates where your 
Insertion Point | happens to be (in this case, it refers to the number 
of characters into the paragraph by the number of lines from top of 
the page). As soon as you make a change to a document, the Change 
Indicator icon Y appears to the left of these numbers. It will disappear 
when you save your file and reappear once a new change occurs. 
Centered in the Info Bar is the Page Number icon LD). As you scroll 
through the document you will notice the numbers beside it change 
as the pages flow past. The capital I on the right edge of the window 
is the Show Info Bar icon. Because the Info Bar is showing, the Show 
Info Bar icon| J |is highlighted TI 

¢ Click on the Show Info Bar icon to make the Info Bar disappear 
or reappear. Other items can appear on this Info Bar. They are 
explained further elsewhere in the manual gage eg. All these icons 
on the Info Bar are indicator icons which give you information 
about your document but have no effect on it. 
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Rulers 

Paragraph Ruler wace 54 

Between the Info Bar and the actual ruler portion of the Master Ruler 
are a series of other icons. Of the two on the far left only one concerns 

us at this time: the Show Rulers icon cm: which is presently 
Feteeveres 

highlighted $6} Notice that this icon is subtly, though visibly, 
different from the Show Master Ruler icon [a] in the Scroll Bar near 

the upper right hand corner of the window. 

Line Wrap and First Line Indent pase «7 

e Click on the Show Rulers icon ray a few times to see how it 
moves your ruler and document to the left and right hiding, then 
revealing the Paragraph Ruler icon C2). 

e Leave the Paragraph Ruler icons visible. 

From the Master Ruler you can control the paragraph indents by 

clicking on and dragging the Line Wrap Indicators ? and the first 
line indent/outdent by clicking and dragging the First Line 

Indent/Outdent icon ¥. These icons do not indicate the actual margins 
of your document (they are set in Layout Page...). Rather, they indicate, 
within those margins, the point at which your lines will wrap. 

¢ Scroll down to the beginning of the next paragraph to notice that 
the same “format” is maintained; the paragraph has the same 

basic shape and appearance as the one above. 

° Press the Enter key to return to the position of your Insertion 
Point. 

¢ Drag the First Line Indent/Outdent icon into the two inch mark 
to change the depth of the indent. 

¢ Drag the Right Line Wrap Indicator is in to the seven inch mark, 

then drag the Left Line Wrap Indicator ® in to the three inch 
mark to change the appearance of the paragraph. If this is your 
first experience with a computer you will notice that the lines 
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“wrap” automatically when there is no more space available on 
any particular line. This is called text wrapping. You press the 
Return key only to start a new paragraph. 

* Scroll down again as illustrated in Figure 3-10 till you see the 
next paragraph. 

into a little cz/ we szc huddled in a tiny bow! 
among the hills. The two houses I was looking 
for were side by side on opposite sides of the 
Sac, taking up the entire street. Each was a ne 
clear representation of the two primary styles ne 
of the area. Ene 

Cz The ranch house at number 34 sprawled lazily in its raw, golden- e stained wood facing, hidden in a full cluster of eucalyptus trees. Its [/ 
neighbor, number 37, was stately and carefully detailed in Spanish He 
revival stucco. The terra cotta tiled roof was ablaze with blooming 
bougainvillea. “B&J" was visible on the wrought iron weather vane 
above the ranch, while glazed ceramic tiles laid into the front wall of the 

Ssgstatirel (sdpsstelsedtethnads fr hitepe testers ipgesths ctatesssszeissssatece thafetttacedscesssasijecspeat TEEte2j tase ts thsesesetssecsssssidtesteis 
Bis bidet trae ert sheet oe 

Figure 3-10 Line Wrap and the Prote Ctive Ruler 

Notice that a new Paragraph Ruler icon (2 has appeared to the left 
of the margin and that this paragraph maintains the same formatting 
as before you made any changes. This feature of Nisus is called a 
Protective Ruler (page 990; it protects succeeding paragraphs from being 
changed when you alter the format of the paragraph above. 
* Press the Enter key once again. (Whenever you press the Enter 

key the place of your insertion point will immediately be brought 
into view. “Where was I?” ...press Enter.) 

Perhaps you don’t like the way these line wraps shape the text. 

* Move your insertion point up to the Menu Bar, choose Edit 
and drag down to Undo (it will say Undo Move Margin with 
a number beside it). Repeat this procedure until you've returned 
to the original format. (You can go forward again by choosing 
Redo etc., back and forth, till you are satisfied, or simply change 
the ruler directly.) 
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If you want to change the line wrap region for the document. 

¢ Click on the Paragraph Ruler to select it | Make changes. 

e Drag the First Line Indent/Outdent icon in to the two inch mark 
to change the depth of the indent. 

e Drag the Right Line Wrap Indicator fa in to the seven inch mark, 
then drag the Left Line Wrap Indicator #. in to the three inch 
mark to change the appearance of the paragraph. 

Selecting a Paragraph Ruler will prevent a Protective Ruler from 
being inserted. All paragraphs governed by the selected ruler, that is, 
all paragraphs till the next Paragraph Ruler, will be altered accordingly. 

¢ Undo once again so that the Line Wrap Indicators and First Line 
Indent/Outdent are as they were when you opened the document. 

What we have just done regarding the insertion of protective rulers 
applies to anything you can do to a ruler. Whenever you make a 
ruler change to a paragraph, whose Paragraph Ruler has not been 
selected, a Protective Ruler will be inserted. These alterations include 
changing the line wrap region and first line indent as well as 
manipulating tabs, line spacing, paragraph spacing, and justification. 

Tab Stops (oaeca 

You can add a variety of tab settings to your document. These are 
ma in the Tab Wells to the right of the Show Rulers icon 
[4/4 /4/4) Tabs allow you to move your insertion point 
horizontally into your document to continue typing at a specified 
point. 

* Scroll down to the end of the document. Note that there is a 
Paragraph Ruler at the beginning of the limerick. 

¢ Place your insertion point in front of the “W” (of With) at the 
beginning of the third line and click the mouse, then press the 
Tab key. Do the same with the next line (in front of the “S” of 
She). Nisus has tab stops built in, set at one half inch intervals 
from the left margin. You can, however, set your tabs to appear 
anywhere in your document. 
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¢ Select the Paragraph Ruler at the beginning of the limerick. With 
your pointer, reach up to the tab well. 

¢ Click on the Left Tab 4. and drag it to the two inch marker on 
the Master Ruler. The two indented lines will automatically align 
themselves with the tab marker. Repeat the process and place a 
second Left Tab on the three inch marker of the Master Ruler. 
The other triangles (tabs) in the Tab Wells (continuing from left 
to right) though not demonstrated here, can be used to line up 
your tabbed text along its center point, its right edge, or a decimal 
point in a number, respectively. 

* Place your insertion point at the beginning of the limerick and 
drag across it to select its entire text. 

¢ Move your insertion point up to the Menu Bar, choose Edit 
and drag down to Move Right (page 12. The entire limerick will 
be moved over to line up with the new tab stops you have inserted 
when you release the mouse button. The result of this command 
is illustrated in Figure 3-11. 

I've never been a fan of adolescent poetry, but this was work so | ia 
made very small talk with Carole as her sister went on her literary 
search. 

Thetis tice Hah ocr) sorts Daten 
Wess We Fee hs Web] Stooth aka fanny 

VARY Net Peet cher Sor hon dy, 

ahe 0s obmiott Whe Eanated 
But [tated aud then the vss edie 

Justification, Line and Paragraph Spacing oc: 
90, 92, and 94} 

The rulers also control spacing between lines. 
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e Click on the Paragraph Ruler so that only it is selected. Click on 
the Auto icon of the Line Spacing icon [EX[=] 0 [Aste] in the Master 
Ruler to see the various options you have for spacing. 

You can have the lines spaced automatically Nisus will maintain 
a certain minimum line height counted in pixels (points). (Point height 
is >;” on screen; one pixel is the smallest point that can be seen on 

screen.) “O " means that the minimum space necessary to display the 
tallest character on a line will be kept; no change will appear until 
you reach a number higher than the number of points in the font you 
are using . You can either type a number into the number box ee or 
click on the increase [==] or decrease [EJ icon until you achieve the 
desired result (when the line height is as small as it can be, the 
decrease icon is dotted: [fi]. It is possible to have a fixed line height 
[Fix]. Nisus will maintain a set number of points between the bottom 
of one line and the bottom of the next. Or, you can choose to have 
Nisus maintain a certain number of lines as spacing [tine]. In this 
instance, Nisus measures the line height and automatically keeps 
that line height or increases or decreases the distance between the 
bottom of one line and the following by half line intervals. Choose a 
variety of these options and watch how the choices affect your text. 
Because each line of the limerick has a return character at its end you 
can get the same visual result by using the Paragraph Spacing icon 
lL ° |. The measurement method set in Line Spacing 
or also applies to Paragraph Spacing. 

e Click on the Increase (S| and Decrease Paragraph Spacing 
icons or enter a number into the number box to see the 
different options you have for spacing. Choose a variety of them 
and watch how these choices affect your text. 

Paragraph and line spacing offer different results. 

¢ Return your insertion point to the top of the document. You 
should still have only one Paragraph Ruler at the top of the 
document controlling a number of paragraphs. 

¢ Select that Paragraph Ruler and then click on the measurement 
method icon until appears. 

* Double-click your insertion point in the number box of the 
Paragraph Spacing icon to select what is there. 

¢ Type the number 2 and press Enter. 
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Now, as you scroll through the document you will see how the lines 
are single spaced but there are two spaces between each paragraph 
(until you reach the next Paragraph Ruler). 

Scroll down to the paragraph that sp:.:s pages one and two, 
beginning: "I haven't spoken with -er in ages,...” 

Click on your mouse so that the insertion point is at the beginning 
of the paragraph. 

Choose Insert Ruler from the Format menu. Notice that the 
Paragraph Ruler is selected and a Protecting ruier has not been 
inserted. 

Delete that ruler by simply pressing the Backspace or Delete key. 

Click on the Decrease Paragraph Spacing icon [Zs] so that it reads 
to see how one paragraph is affected as illustrated in Figure 

3-12. 

S Pactiic. 

Ca ff haven't spoken with her in ages, but I do keep all the family [/3 
members’ phone numbers in my book.” she tofd me as she Stepped over f.:: 
to the telephone nook. “She moved to Los Angeles a few years ago but ae 
recently moved back. You ought to be able to find her at (619) 481-1477. 
Oh, but that was her father's house, she’s moved to a singles community |!!! 
by the beach. Her new number is 481-6154." I had carefulty written it its 

all down then went back to correct it with the pen and pad she elferen he 
She was civil regardiess of how she felt. He 

] thank : - . é 

LURK AY BEcCeececrsetetiompnrigesbten Hie Inde ee der teat ay tS So oe Ce Pia Ris inne te A v4) . 7 bitte ssehibed J- it oa th kt Likes OO Listes 4 bee 

Scroll the window of file 9/13/89 up to the top and place the 
insertion point at the beginning of the document. 

Choose Save from the File menu and then click the Close Box 
are 

¢ 

This session is now complete. 
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Session 3: 
Graphics 

You can easily add graphics to your documents without leaving Nisus. 
~ This session of the Tutorial presents the basic skills used in creating 

and manipulating graphics. You will learn how the different icons on 

the Graphics Palette and the Graphics menu affect your document. 
Page numbers (page » follow those items discussed in the manual. 

You may continue from where you left off (before closing the file) in 
Session 2 of the Tutorial or begin a new session of working with 
Nisus. 

Graphics Sheets wage 233 

* Open the file labeled 9/13/89. 

¢ Scroll down to the paragraph beginning: “Jayn was home 

and invited us over.” and place your insertion point following 
the words “Saitilo pavers.” 

¢ Click on the Show Graphics Palette icon (under the Master 

Ruler icon) or choose Graphics Palette from the Dispfay 

submenu of the Tools menu. When the Graphics Palette appears 

the Show Graphics Palette icon will be highlighted and you 
will see a wide variety of tools and patterns with which you can 
draw graphics. Also, on the right hand edge of the Menu Bar the 
Graphics menu will appear (page 271 ). 

e Click on the Show Vertical Ruler icon (By in the lower left hand 

corner of the window. It will be highlighted and the Vertical 
Ruler will appear along the left edge of your window. On the 
graphics sheets your pointer's position will always be shown in 
the rulers. 

¢ Click on the Rectangle drawing tool icon{[_]] in the lower left 

comer of the Graphics Palette to select it; it will become highlighted 
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e Press the Shift key to constrain the rectangle to a square while 
drawing. 

* Anywhere in the window, click on the mouse button to draw a 
square of approximately one half inch on a side. Notice how the 
text automaticaiiy “wraps,” or makes room to allow the graphic 

to fit into the space because Text Wrap On |° 

center of the Graphics Palette) is selected (page 258). 

e Click on the icon to show the pull down menu and choose Text 

Wrap Off 

Palette and that the text now flows, invisible, behind the graphic. 

¢ Click on the Overlay Attributes menu @age 22 (which is in its 

Opaque mode)| Gana choose Transparent Leal] You 

will see the text from the background flow through the graphic. 
Return to the @paque mode. 

You can fill the box with a pattern to make it appear more like a 

paving tile. The Pen/Fill Pattern Selector | cH indicates that you 

have drawn a graphic with a black border and a white center (page a 

¢ Click on a variety of the patterns in the Pattern Palette robotics aoe 
to see how the graphic can be changed. 

At. 

¢ Click on the Palette Scrolling icon 0 to scroll through the patterns 

ay- 

e Click on one of those Eee cL pac so that the fill pattern 
can be seen in the Selector box and your graphic . 

e Click on the Text tool | T| rx) to select it; the icon will become 

highlighted TI 

¢ Click on the white fill icon Gr. 

¢ Click anywhere in the window. A dotted box = 
in which you can type. 

till you find patterns with less than 50% ¢ 

will appear 

° Type ‘1'" (one foot, i.e. the numeral one and an apostrophe). 
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¢ Choose 9 from the $ize menu. 

e Click on the Bidirectional Arrow tool to select it; the icon 

will become highlighted 

* Click on the 3 pixel line thickness icon to select the appropriate 

line weight “1D. That weight indicator will show 

in the center of the Pen Size Selector icon (page26). 

* Click the mouse button and drag the mouse to draw an arrow 
just above and the entire length of the square. 

e Click on the “1°” (one foot) again to select it, then on the small 

black square in the lower right corner of the invisible box that 
B a 

surrounds it 1° <3) Drag the square toward the number so 

a 8 

that only the digit and the apostrophe show wl @ then drag the 

graphic and center it over the arrow. 

The number is behind the arrow and being covered by it. 

* Choose Bring To Front from the Graphics menu. 

¢ Drag your Selection Tool diagonally across the three graphics 
aAVCLLL, WUL yvuse v¥t 

aly Gone Off W sch 
oa i'm presse 

Lo ee wonde 

she Seed hadn't 
2inad fail>d Py, ” mes eame'to onl vs (the double-headed arrow, the “one foot” and 

atier if sha‘d_spatled 

me and invited us'>1 

the “tile”) so they are all selected when you release the mouse 
Bvue was vw 

I atte! 

button € E 
ad 2 

came Ri o 

e Choose Group from the Graphics menu age 772. 

You now have a complex graphic. It can be left on the graphics 
sheets for the text to flow around or you can place it on the text layer 
as a character graphic. 
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Character Grapnic cone 6 

Choose Cut from the Edit menu. 

Choose Master Ruler from the Display submenu of the Tools 

menu or click on the Show Master Ruler icon (= 

Choose Paste from the Edit menu. The graphic is now a Character 
Graphic and will follow along in the line of type as if it were any 
other character. The item can still be manipulated: it can be 
centered on the line or resized. 

Click on the graphic once to select it, and then drag the graphic 
so that it is centered in the line as illustrated in Figure 3-13. 

262- -5296, or ” BOB-JAYN. They were iueey their names came to onlK> 
seven digits, though she could have made dialing easier if she'd spelletii 
her name in the usual manner. at 

Jayn was home and invited us over. The sisters must have made thi: 
trek ae Carole’s walk way was paved in those popula 

resealed trees? I was surprised to see them placed in an offsdi:! 
pattern f rather than the usual. ee 

Figure 3-13 A Character aul 

Nisus graphics can be very complex. The character graphic at the end 
of the paragraph is made up of 49 separate components. To examine 
it on your own, double-click on it. The window Graphic for 
‘9/13/89’ will open allowing you to edit the graphic in place. 

Click once on the graphic to select it. 

Choose Ungroup from the Graphics menu (the reverse process 
of what we did with the single tile). Remember, you can always 
Undo until you close the document! 

Tutorial: Session 3: Graphics 



e When you have finished exploring, click the Close Box ER without 

Saving any changes. 

This session is now complete. 

session 4: 
Creating a Document; 

Entering and Manipulating Text 

Now that we have explored some of the basic parameters of Nisus it 
is time to create a document. 

This session of the Tutorial presents the basic skills used in entering 

and manipulating text. You will learn how to Copy, Cut and Paste 

in your document and from one document to another. You will learn 

how to change the Font, Size and Style, of your text, check the 
spelling, see how it will appear on a full page of paper and print the 
document. 

You will also learn how to make your own personal stationary. Page 
numbers (page ») follow those items discussed in the manual. 

You may continue from where you left off (before closing the file) in 
Session 3 of the Tutorial or begin a new session of working with 
Nisus. 

e Open the file labeled 9/13/89. 

¢ A tiny portion of the Catalog is visible in the upper right corner 
of the screen. Click on it or choose Catalog from the File menu. 

° Click on Del Mar and choose Tutorial from the pop down 
menu as illustrated in Figure 3-14. 
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a & Del Mar ; 

©) Cases 

eed 9) tetter- Arthur 
SS Harddisk fe) letter- Bob a 
— Macintosh HD (a) letter- Dave 

letter- Donne 
[e) tetter- Frances Hi 

[& ietter- George ate 
fe) letter- Harvey ae 

C3 | [e) letter- Jim 

[o) 8/22/89 

8/23/89 
sf 951489 

Coren). 
Figure 3-14 A and B Navigating Through the Catalog 

¢ Double-click on the Personal folder then the correspondence 
folder. Then open the file called letter. It will look like Figure 
3-15. 

Entering Text 

ry, | une 25, 1990: 
stadt 
stgey 

Sincerely, 

Figure 3-15 A Stationery Document 
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The insertion point is flashing above the word “Dear,” ready for 
you to type the name and address. 

¢ Type: 

Ms. Susan Monas 

: 13045 Ewina Way 

Poway, CA 92064 

e Place your insertion point between Dear and the comma that 
follows and type “Sue.” 

* Place your insertion point at what would be the second line beneath 

Dear Sue and type (purposefully including the typographical 

errors): “I've been meaning to call you for months. | 

Know, we only live twenty-five miles from each other, 
but you know how busy life can get. I know you're 
teacing an English class up in Ramona. I] recetnly 
came across this teenager's limeric. (Press the Return 
key to start a new paragraph, then continue:) It made me think 
of you, and | wondered if you'd find it helpful as a 
project for your kids.” 

Notice again that while typing text at a computer you don’t hit the 
return key at the end of a line but only to start a new paragraph. 
Also, as we learned above when exploring the rulers, you don’t need 
to place more than one return character, between paragraphs. These 
operations are accomplished automatically through line and 
paragraph spacing. 

Copy Between Files cg... 

¢ Click on the Title Bar of the window visible above the document: 
9/13/89; go to the Tools menu, drag down to Windows (page 

198) sub menu and choose 9/13/89; or press the option or 
Command key and click your mouse on the Title Bar and choose 
9/13/89. 

¢ Scroll down to the limerick, place your insertion point immediately 
following the Paragraph Ruler and drag across the poem to select 
it. 
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e Choose Copy from the Edit menu. 

Whenever you Copy or Cut, whatever has been copied or cut is 

temporarily placed on the Clipboard. You may look at it. 

« Choose Show Clipboard from the Edit menu. 

Nisus has ten editable clipboards. You can manipulate your text on 
the clipboard before pasting it in your text window. 

¢ Close the clipboard either by clicking the Close Box ER or by 

choosing Close from the File menu. 

¢ Choose Toggle Front 2 from the Windows sub menu of the 
Tools menu, or click on the horizontal scroll bar that is visible at 
the very bottom of your screen as illustrated in Figure 3-16. 

search. Be 

There once was a girl soft as Dawn, 

Whose movements were smooth as a fawn. 

With her feet she was handy, 

She was almost like Bambi. 

But I moved, and then she was gone. 

fe 

Figure 3-16 Working with Windows 

Notice that the windows are of different sizes. When you save your 
document, the size, shape and position of the window on the desktop 
will be saved with the file. If you click the Zoom Box F1] in the upper 
right corner of the window the document window will fill the page; 
clicking a second time will return it to its previous position. If the 
Zoom Box is hidden you can accomplish the same effect by double- 
clicking on the Title Bar. 

¢ Place a return character following the text of the letter you’ve 
written and choose Paste ages) from the Edit menu. 

The limerick is now pasted in the letter. 

Perhaps you want the limerick to precede the sentence: It made me 
think of you.... 

* Place your insertion point in front of that sentence and select it 
by dragging across the sentence to its end, or “triple-click” (click 
three times in rapid succession on the desired sentence). 
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Choose Clipboard 1 from the Clipboards (*#) sub menu of 
the Edit menu. 

Choose Cut from the Edit menu. 

The limerick is still on Clipboard 0 and the sentence has been placed 
on Clipboard 1. You can see this by choosing Show Clipboard 

again from the Edit menu, then choosing Clipboard 0 from the Set 
Clipboard {#) sub menu of the Edit menu. Be sure to choose 

Clipboard 1 again before the next action. The number in the 

parentheses following Set Clipboard at the bottom of the Edit 
menu indicates which Clipboard is current. 

Click your insertion point at the end of the limerick, enter a 
return character and choose Paste from the Edit menu. 

Enter another return character and type: “Let's get together 

to enjoy a good mea! and a private reading at Marilyn's 

down by the take. I'll give you a call.” 

Changing Font, Size and Style paces 102 

You may want to give the letter a bit more pizazz. 

Drag across the limerick to select it. 

Click on the Master Ruler icon to show the ruler. 

Click on the right justify icon (=| Choose Geneva (Geneva) 
from the Font menu (pressing the Option or Command key as 
you pull down the menu displays the font names in their own 
fonts). Choose 14 point from the $ize menu. Drag the Right 
Line Wrap Indicator to six and a half inches 

Select the “handy/Bambi” lines and drag the Right Line Wrap 
Indicator # in further to the five and a half inch mark. 
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Rectangular Selection sae 75 

* Place your insertion point in front of Dawn; press the Option 
key while you drag through gone. This is rectangular selection. 
Notic. as illustrated in Figure 3-17, that this highlights the words 
Dawn, fawn and gone only. Choose Italic from the Style 
menu; then choose Extend from the More Styles submenu of 
the Style menu. 

Dear Sue, 

I’ve been meaning to call you for months. I know, we only live 
twenty-five miles from each other, but you know how busy life can 
get. I know you're teacing an English class up in Ramona. I recetniy 
came across this teenager's limeric. _ 

There once was a girl soft as RRR 
Whose movements were smooth as alge 

With her feet she was handy, 
She was almost like Bambi. 7 r 
But | moved, and then she was BRT | 

it made me think of you, and I wondered if you'd Lind it hetpful 
as a project for your kids.” 

Let's get together to enjoy a good meal and a private reading at 
Marilyn’s down by the take. I'll give you a call. ee 

We've finished writing the letter but now it is time to check the 
spelling. 

Check Spelling trace 217 

* Place your insertion point at the top of your document. 

¢ Choose Spelling... from the Tools menu. When the dialog box 
appears as illustrated in Figure 3-18, click Start Checking. 
When the spelling checker stops at a word click Replace if it is 
a misspelled word or Skip for words that are correctly spelled, 
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though not in a standard dictionary. You can also click $kip All 
for recurring proper names. The Macintosh will beep at you and 

display the message No more misspelled words, when that 
is the case. 

° Close the Spell Checking dialog. 

SSS 

Unknown Word: 

Condition: Misspelled word 

Replace With: 
[start Checking) Srortinecang 

Suggestions: 

recently 
reciting _| (CJEdit User Dictionary 
resettling ie 

Figure 3-18 The Spel! Checking Dialog 

Page Layout wage 135) 

The letter is now ready for final formatting before printing. You 
want to be sure that the letter appears on the page properly. To do 
this check the letter in Layout Page.... 

* Click on the Layout Page icon or choose Layout Page... 
from the File menu. You will see that the text of the letter is a bit 
high for the page. 

e Click on the Side by Side icon so that you can edit your letter 
and see how the page layout is affected as illustrated in Figure 
3-19. 
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Dear Sue, 

I’ve been meaning to call you 124} ain ae 
twenty-five miles from each othe 
get. | know you're teacing an Engyay| 
came across this teenager’s limerifii] | eo et et 

[Whose movemen({iiq 
With her feet. 

as a project for your kids,” yy | 
Let's get together to enjoy a gor 

Marilyn’s down by the lake. I'll gi | 

window open 

¢ Click on the window with your letter Untitled-2 to make it the 
active window and place your insertion point at the top of the 
page. Enter a few return characters till you are satisfied with the 
appearance of your letter. 

Saving om, PriNtiNg ou.» and Closing 

You are now ready to save the letter, print it and put it away. 

* Choose $ave from the File menu. In the dialog that comes up 
type “letter- Susan”. Notice that the letter will automatically be 
saved in the folder in which you originally found the file. However, 
you can, save it anywhere else you wish simply by navigating 
through the folders and disks indicated in the dialog window. 

* Click Save. 

¢ Make sure you are connected to a printer, then choose Print... 
from the File menu. See Figure 3-20. When the dialog comes up 
click Time and Date to update the date on the letter (you 
would want to do this only when there is a date variable in your 
document that needs updating) then click { _ 
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LaserWriter “LaserWriter I] NTH” 52 am cmp | 

. =: hed anamee 

Copies: Poges:@ Ali O From: (| Ta: [| 

Cover Page: @NoO First Page © Last Page 

Paper Source: ® Paper Cassette © Manual Feed 
GE GORE! RMS tm be dh dy 

{J As Numbered In Document 
Page Range: 

@ Odd 0 Even Pages ©Odd Pages ©Even Pages 

[) Cross References 
intin : Before Pr g Update Time & Date 

Figure 3-20 The Print Dialog window 

¢ Click on the Close Box in the upper left corner of the window or 

choose Close from the File menu. 

Nisus Stationery cage cx 

Before moving on, take a closer look at Diego’s personal stationery. 
You can make some for yourself. 

¢ A tiny portion of the Catalog is visible in the upper right corner 
of your screen. Click on it. Notice that, unlike the Open dialog, 
the Catalog can always be on your screen. Its powers will be 
explored further, at another point in the tutorial. 

Notice that the icon in front of “letter” in the Catalog window is 
different from all the other Nisus file documents. This is called a 
“Stationery File.” You can set up any number of different Stationery 
Files with any combination of formatting characteristics and give 
them any name you wish. Each one will appear as “Untitled-#” (in 
an increasing numerical sequence during that working session) 
whenever it is opened. The one you name Nisus New File and store 
in the System Foider will be the file Nisus opens whenever you choose 
New. 

This stationery has a date with a dotted box surrounding it. This 
item is called a variable and can be placed in your text by choosing 
insert Date from the Variables submenu of the Edit menu. 
(Various options regarding the appearance of the date are available 
through the dialog box that opens when you choose Set Date & 
Page* Formats... at the bottom of that submenu.) 
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e Choose Update Time & Date from the Format menu. The 
date can also be made current on printing. 

¢ Scroll through the letter and notice that there is a “header” and a 
“footer” at the top and bottom of the page. You cannot put your 
insertion point in that area to change it while in this document 
window. 

* Click on the Show Headers/Footers icon !fJ: in the upper left 
corner of the Master Ruler; it will become highlighted and the 
text in your window will shift to the right to show where headers 
and/or footers have been inserted in your document. 

¢ Scroll in your letter till you see “Dear,.” See Figure 3-21. There 
you will see two small icons: es “Header on Odd Page” and Ld 
“Footer on Odd Page.” These indicate that the Header and Footer 
for this document are attached at these points. 

(a UN Cd-2 a aemee a Ja 
tala) (Sieisls 
te 4 2 

Whew ls gk 

CQ 
* Small window for illustration purposes only] 

Q 

* Double-click on the Header on Odd Page icon. The Headers 
ond Footers for... window will open. This window shows all 
the headers and/or footers for the document. The text in this 
window can be edited just as any Nisus document, using the 
same techniques you have already learned. 

e¢ Triple click on Diego de ta Escribir (double-clicking on a 
word in Nisus selects that word, triple clicking selects that line 
and quadruple clicking selects that paragraph). Type in your 
own name; choose the font, size and style(s) you want. You may 
wish to have your address with your name at the top (or at the 
bottom) of the page. Cut and Paste as you wish. If you prefer 
to have all your information in the header or the footer, after you 
have typed the information to your satisfaction, place your 

Tutorial: Session 5: Searching 



insertion point in the one you do not want and choose Remove 

Header/Footer from the Header/Footer menu that appears 
on the far right of the menu bar when the Headers and Footers 
for... window is open. 

Notice the graphic in the header and footer. This is a character graphic 
that was created by selecting a fancy fill pattern and a “white” line 

pattern fal . Following the procedures described above in Session 3 

of the Tutorial, you can alter this according to your needs and desires. 

e Click the Close Box to retum to the main document. 

Whatever attributes the window shows when you save it will appear 
when you reopen it. This applies to both the size and the placement 
of the window on your screen. If you do not want the show 
Header/ Footer on Page icons to appear or the master ruler to show, 
simply reverse the procedure that was used above to show them—click 
on the in the ruler. 

e Choose Save fis... from the File menu. Determine where you 
want the file saved by navigating through the folders. Type the 

name you want to use for the file (“Personal Stationery” is 

safe) then click on the Nisus Stationery icon Ss {the second 

from the left) and click Save as illustrated in Figure 3-22. 

= Hard Disk 

© Other 

© Tutorial 

Save document as: 

Change Nome, Don't Save 

SORE x... 
Figure 3-22 The Save As... dialog window 

e Click the Close Box ER 

This session is now complete. 
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Session 5: 

searching 

One of the most powerful features of Nisus is its Find/Replace ability. 
In an open (or a closed) file, you can find virtually anything that can 
be described. This session of the Tutorial presents an introduction to 
the Find/Replace capabilities of Nisus. You will learn how to do a 
find and replace using the Normal Search mode. You will also learn 
how to find and replace text patterns using PowerSearch and, through 
that, you will be introduced to the GREP (Global Regular Expression 
Parser) searching language. You will also be introduced to the Macro 
tools and abilities of Nisus. Page numbers (page #) follow those items 
discussed in the manual. 

Find and Replace... 

Changing Text Attributes Using PowerSearch 

* Open the file labeled *Tutorial (this is an early disk version of 
Session 2 of the Tutorial found in your manual; it is not necessarily 
accurate and appears here only for you to experiment with). 

The manual is printed using a font called Palatino for its basic text 
with sub headings in Helvetica. When menu and dialog box commands 
are referred to in the manual the font Chicago is used (this is as 
they appear in the program). If you do not have Palatino or Helvetica 
in your system (which is probable), the portions of the file that were 
in those fonts will appear on screen as Geneva. 

e Drag your mouse down to the bottom of the Font menu. The 
names Palatino and Helvetica appear in italics to indicate 
that these fonts are in your document but not in your system. 

For the sake of this exercise we will change the font of the document 
to Geneva without affecting the menu items already in Chica go. 

* Choose Find/Replace... from the Tools menu. The 
Find/Replace dialog window appears. 
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Powersearch 

| PowerSearch+ § 
el fi X) Ignore Cose [} Whole Word K) Wrap Around 

Figure 3-23 Find/Replace window with the Find menu 

¢ Click on Normal Search (this is the Find pop up/down menu) 
so that the pop down menu appears and choose PowerSearch 
as illustrated in Figure 3-23. 

The window will expand to show new searching menus. 

¢ Choose ny character or 9 from the Wild Card menu. 

¢ Choose 1+ from the Repeat * menu. The following characters 
will appear in the Find box: (Any character or 4 (1+). 

* Press the Tab key to move your insertion point to the large 
horizontal box beneath the Find text edit box and beside the pop 
down menu labeled Replace (this is called the Replace text edit 
box) and choose Found from the Match menu. The Find/Replace 
window will now appear as illustrated in Figure 3-24. 

Oa ees Find/Replace Sei a). 
Witd Card Specioi Repeat * Position Clipboard Match 

ace: a 

¥) 4} BY ignore Case CO Whole Ward 6) Wrop Around 

Replace, then Find 

Figure 3-24 Find/Replace window with PowerSearch expressions 

e Double-click in the Replace text edit box to select the “text” there. 

¢ Choose Geneva from the Font menu, then check to verify that 
Any Size, + Any Styles Any More User Styles and Any 
Color are also selected. 
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Press the Tab key to move your insertion point to the Find box, 
selecting what is there. (You can also click your mouse three 
times in rapid succession in the Find box to select the “text” 
there (double-clicking selects one “word” triple clicking selects a 
sentence).) 

Choose Palatino from the Font menu then check to verify that 
Any Size, + finy Styles Any More User Styles and Any 
Color are also selected. 

Be sure that Ignore Case and Wrap Rround are checked as 
in the illustration above then click (Replace Ait], 

The dialog box illustrated in Figure 3-25 will appear. 

Number of substitutions: $4 

Figure 3-25 Find/Replace dialog box 

The number 94 refers changes in individual paragraphs, not characters. 

Click [| ok 9. Notice that the “text” in the Find box is still 
selected. Now choose Helvetica from the Font menu. 

Click (Reptace aul) 
This time the number of substitutions (for the sub headings) is 26. 

Click __0k _]j and examine your file. Notice that if Palatino and 
Helvetica were in your system the text in those fonts would be 
changed to Geneva while all the sizes and styles remained 
unchanged. This is also the case with all the text in Chicago, 
and New York (which you used to enter text for the letter in 
the exercise of Session 2). 

Before we move on lets examine what the PowerSearch+ symbols are 
for what we've just done. 

Click on the Find/Replace window so that it becomes the front 
window or choose Find/Replace... from the Tools menu if it 
is completely hidden. 
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e (Click on the Find pop up menu and choose PowerSearch+. 
The phrases change to symbols (“metacharacters”) that represent 
those same search characteristics. 

2 Any character or Return 
+ 1+ 
& Found 

As you become more familiar with the searching capabilities of Nisus 
you will become more comfortable recognizing, and using, these 
symbols. 

No rmal Search (page 204) 

¢ Select the word Nisus in the second paragraph of the file: 
“Double-click on the Nisus icon” (either double-click on it or 
drag across it). 

¢ Choose Copy to Find from the Tools menu. 

¢ Click on the Find/Replace window to make it the active window. 

¢ Choose Normal Search from the Find pop up menu. Notice 
that the menu options in this window are no longer enabled. 

Notice that the appropriate font, size, style and color have been marked 
in their respective menus. 

¢ Choose Any Font, Any Size, +Any Styles, Any More User 
Styles and Any Color from the Font, Size and Style menus. 

e Choose Copy from the Edit menu. 

¢ Press the Tab key to move your insertion point to the Replace 
text edit box or Double-click your mouse there and choose Paste 
from the Edit menu. 

The word Nisus (in Any Font, Any Size, +Any Styles, Any 
More User Styles and Any Color) will replace the &. 

¢ Choose 12 from the $ize menu, Bold from the Style menu 
and Extend from the More Styles sub menu. 

¢ Click and click in the dialog box that 
indicates that 8 changes were made, then check your document 
to see the results: NISUS. 
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Pattern Matching Using PowerSearch+ jeu 

In the sample file being examined “Page numbers m follow those 
items discussed in the manual.” This, however, is not the most “User 
Friendly” manner of indicating page numbers. It would be much 
nicer if the word “page” appeared in parentheses indicating that that 
number actually referred to a page and not to something else. We 
could scroll through the document looking for each time a number 
appears in parentheses and then insert the word “page” or we could 
find the pattern of an open parenthesis with one or more digit followed 
by a closed parenthesis and then have Nisus insert the word “page” 
in each instance. 

e Choose Find/Replace from the Tools menu. 

* Choose PowerSearch from the Find pop up menu. 

¢ Clear out whatever may be in that box by pressing the Tab key 
to place your insertion point there and pressing the delete or 
backspace key. 

¢ Type an open parenthesis: “(” and a close parenthesis: “)” then 
place your insertion point between them. 

* Choose 0-9 from the Wild Card menu and 0+ from the Repeat 
# menu. 

* Click Find — repeatedly. 

Notice that each instance of that pattern will be found regardless of 
how many digits appear between the parentheses. Notice also that 
“real” characters can be combined with PowerSearch (or 
PowerSearch+) expressions. 
At the beginning of the document is a number sign in parentheses 
“w” and at the top of page 3 there is a sub heading: Paragraph Ruler 
(81-91). To find these the find expression needs to be fine tuned a 
bit. 

* Place your insertion point following the open parenthesis and 
type the number sign “#” then choose 0 or 1 from the Repeat 
# menu. 

* Place your insertion point following the expression and type 
a hyphen “-” then continue to choose 0 or 1 from the Repeat 
¥ menu, 0-9 from the Wild Card menu, then 0+ from the 
Repeat # menu. 
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¢ Place your insertion point in front of the open parenthesis: “(” 
and choose the open parenthesis: “{“ from the Match menu. 

e Place your insertion point following the open parenthesis: “(” 
and choose the close parenthesis: “)” from the Match menu. 

« Choose the open parenthesis: “{” from the Match menu. 

¢ Place your insertion point following the expression and 

choose the close parenthesis: “)” from the Match menu. 

¢ Choose the open parenthesis: “{“ from the Match menu. 

¢ Place your insertion point following the close parenthesis: “}” 
and choose the close parenthesis: “)” from the Match menu. 

¢ Press the Tab key to move your insertion point to the Replace 

box, selecting what is there, and choose Any Font, Any Size, 

Plain, Any Styles,Any More User Styles and Any Color). 

e Choose (...Found 1) from the Match menu. 

e Type page then choose Space from the Special menu. 

¢ Choose (...Found 2) from the Match menu. 
The Find/Replace dialog window should now appear as illustrated 
in Figure 3-26. 

De eer ea Find/Repiece Hi 

Wild Card Special Repeat * Position Cliphoord Match a 

OC *Dee-CaDEDe®) 

CFemd 1} page Gpace)C Found 2)) 

{¥) ? I ignore Case (C1 Whele Word Wrap Rround 

Figure 3-26 Find/Replace dialog window searching for parenthesized 
number 

Your find expression will find an open parenthesis followed by a 
number sign (which may or may not be there) followed by any number 
of digits (which may or may not be there) followed by a hyphen 
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(which may or may not be there) followed by any number of digits 
(which may or may not be there) followed by a close parenthesis. 
The expression is divided into two smaller expressions enclosed by 

af 

» the PowerSearch parentheses: “ 

In the Replace box the word “page” and a space are added into the 
midst of these expressions. 

+ Click (piace ail) 
There will be six substitutions. 

¢ Click { ¢ 
document. 

} in the dialog box that appears and check your 

* Click once again on the Find/Replace window to make it the 
active window, choose PowerSearch+ from the Find pop up 
menu to examine what has been accomplished. 

Once again the phrases change to symbols (“metacharacters”) that 
represent the same search characteristics. 

The backslash “\” changes the meaning of the character it precedes. 
When it precedes a character that functions as a metacharacter (that 
is it has a specific symbolic meaning in the PowerSearch+ (or GREP) 
searching language), it “turns off” that symbolic meaning and causes 
it to function literally. The reverse is also true; a backslash can cause 
a character that has no special meaning to function ina special way. 
Those characters surrounded by parentheses (in this case “\(...\)”) 
are interpreted as individual expressions to be found and can be 
replaced by themselves (i.e. \1 etc.). 

:d 0-9 
+ 1+ 
- Oor1 
‘4 0+ 
\s space 

e Choose Save from the File menu and then click the Close Box 
ale 

¢ 

* 

Search in Closed Files 

Nisus can be used to build a textual data base. 
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It is not uncommon to have correspondence saved in files named for 
the date the letters were written or the person to whom they were 
addressed, but it is often difficult to find the one or two letters or 

documents that deal with a particular key word. There are Desk 
Accessories that can find a file on your disks if you search by name. 
However, Nisus can find any document based on any key word (or 
even some other text attribute) in the file. 

An example of how your text files can be used as a data base follows: 

Suppose you are on the Technical Support staff at Paragon. People 
frequently ask how Nisus handles columns. You could rewrite a letter 
each time adding the specific details the correspondent requested, or, 
you could use the power of Nisus to help prepare the responses. 
Certain aspects of the procedures could be copied from previous 
letters and sent out... if those letters could be found. That is our present 
task... find those letters. 

¢ Choose Catalog... from the File menu. Inside the «Tutorial 

folder is a folder marked Personal. Open that folder, then open 

the correspondence folder inside it. There, a number of folders 

labeled by the numerical equivalents of the months of 1989 are 
listed. 

¢ Open 5/89, choose Select All from the Edit menu then choose 
Add To Search List from the Catalog menu that appears on 
the right edge of the Menu Bar. 

@ Barney Muillner 
@ Deboroh Biumenthal 

@ Dorit Yardeni 

@& Ezekiel Mosgir 
@ Gary Lewkin 
@& Katie Ann Herrick 

@ Mrs. Robert Helner 
@& Paulette Smyth 

@ Randal Martino 

Figure 3-27 The Catalog with icons indicating files have been added 
to the Search List 
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Notice as illustrated in Figure 3-27 that the small file icon has been 
changed to an eye indicating that the file will be searched for the text 
in question. 

¢ Repeat this process with the remainder of the folders (6, 8, 9, 10, 
11). By the time you have finished you will have added over 
forty files to the search list. Imagine how long it would take you 
to search through each one individually.... 

* Navigate through the Catalog to find your Macros folder and 
double-click on the file labeled Macros for Creating to “load” 
those macros as illustrated in Figure 3-28. 

“Loading” a macro file adds the macros in that file to the commands 
available to you. A long list of macro commands will be added to the 
bottom of Macros submenu of your Tools menu. 
Macros are many “micro” (i.e. individual) commands accessible from 
the Nisus menus that are gathered together so that they all work ina 
sequence when called by a particular macro command. A specific 
macro 1s like a servant with a dedicated purpose. 

* Choose Save Search List from the bottom of the Macros 
submenu of your Tools menu. 

alee Cotelog Eels 
& <shipMacres Folder 

le) About the Macros > 
iw Macros for Creating 

pe Macros for Editing 
Ele Macros for Locating 
fie Macros for Merging 

—>Macintosh...| B 

Figure 3-28 The Catalog showing Macro Files with Macros for 
Creating “loaded” 

When a macro command is chosen one generally says that the macro 
iS “running,” or you “run” a macro. 
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When the macro Save Search List has run, the names and locations 

of the various files you have added to the search list will be added to 

the macro Restore Search List. 

¢ Choose Find/Replace... from the Toots menu. 

* Type “column” in the Normal Search box of the Find/Replace 

window. Be sure that }gnore Case is checked and Whole 
Word and Wrap Around are not, as illustrated in Figure 3-29. 

SS =e =a 

ee Ignore Case [] Whole Word ()Wrep Rround 

Car) Replace, then Find 

Figure 3-29 The Find/Replace dialog window prepared to search 

through closed files 

Find ji. Nisus will now search each of the selected files. 

When it finds a file with the word “column(...)” in it that file will 
be opened and the word “column” will be highlighted in the 
center of your screen. To continue searching for more files with 

“column” simply click again. 

Nisus finds each appearance of the word “column” in a particular 
file before it continues on to find the word in other files. When you 

i after the last occurrence of the search word has been 

found, Nisus will display a dialog box illustrated in Figure 3-30 
indicating that the text is not found. 

column: Text not found 

Figure 3-30 The “End of Search” dialog box 

Click (ox). 
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Those files without “column” in them will simply be removed from 
the search list. 

« Choose Catalog... from the Fi! menu (or click on the Catalog 
window if it is visible). 

Notice that all the files that had thi. icon beside them no longer 
show that icon. Those files open o: . our desktop have a check by 
them. The remainder (those that are <iosed) have no special indicator. 
You can review the files that discuss columns. We will return to 
these document windows later. 

By running the macro Save Search List, we have changed the 
macro Restore Search List. The information of what files were 
on the search list has been added to it. You can save this information 
in a separate document so that the list is not lost if and when you 
save a different search list. 

¢ Press the Option key while you choose Save Search List from 
the Macros submenu of the Tools menu. 

This time, instead of “running”, the Macros for Creating the 
macro file window, illustrated in Figure 3-31, opens. 

Save Scarch List . 
aeerch:listintheCatelog-whencalled.4 pis 
Since tt -ectually:modifies another macro, the-searc i: 
ether-macres and: remambered-until -yousave-snethe ere 

Copy *"-"*4 hiss 

Find-Nent-*°-"k°9 

Show Clipboard 

Find/Replace-“*.+"-“Open:"*8°*-**A""*- "Wal: 
Show-Clipbosrd:‘off"4 at 
(1+ —Wow-putthereault-inte the Restore Search List-mact 
Edit:‘Macros4 a 

Jump: “*Select-RSL-mecro’4 
Pasted 

To the left of the vertical line is the name of the macro and to its right 
is the list of “micro” commands that make up the macro. 
Notice at the top there is a description of what the macro does: 
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//This macro writes the macro Restore Search List so that it will 

restore the search list in the Catalog when called. 

//Since it actually modifies another macro, the search list will be 
saved with the other macros and remembered until you save another 
one in place of it. 

¢ Scroll up till you get to the top of the preceding menu. You will 
see the list of all the files that have been saved. These are now 
part of the macro Restore Search List. 

e Place your insertion point in front of the word Open at the 
beginning of the list and select the entire list. 

e Choose Copy from the Edit menu; New from the File menu; 

then Paste from the Edit menu. 

You can save this search list as a separate file and have various 
search lists for different tasks. 

¢ Choose Save from the File menu and type Search List Nisus 
Tech Support, then close that window. 

When you wish to refer to the Nisus Tech Support files copy this list, 
open the Macros for Creating window as described above, and 
paste the list over whatever list appears in the macro. 

* Close the Macros for Creating window by clicking on its 
close box 

¢ Choose the macro Restore Search List from theTools menu. 
Notice that now all the files that once had the eye icon beside them 
once again display that icon. 

* Close each technical support letter as you finish reviewing its 
contents. 

This session is now complete. 
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4 
Working with Text and 

Documents 

The various aspects of texts and documents are tightly woven together. 

This chapter tells you how to create, open, save, print and close a 
document. It also explains how to add, format, edit and change the 
appearance of text in that document. The details of document layout, 
including page setup, headers and footers, footnotes, page and line 
numbering are dealt with here. The chapter explains the convenience 
features in Nisus, such as markers, paragraph sorting, and undo. 
Also included are more powerful features like style sheets, cross 
referencing, and merging documents. 

The chapter begins with a discussion of how to create a document 
file. The details of how to enter and manipulate, as well as change, 
the appearance of its text follow. Instructions on managing multiple 
files, as well as how to print and save your documents complete the 
chapter. 

An Introduction to Files 

When you open the Macintosh “desktop” you see a variety of types 
of icons. Along with the common folder C4 the two primary types 

are applications eS and files ! A file is created by a particular 
application. 
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Numerous file types can be created by Nisus. These include: 

Document file 
Glossary file 
Macro file 
Stationery file 
User Dictionary file 
Preferences file 

The document file is the most common. Unlike a blank sheet of paper, 
a document file always has some format when it opens on the 
Macintosh desktop. The letter, memo or report, whatever you type, 
is the text you enter in a document file. 

Memory Based Word Processing 

Nisus is a memory based (not a disk based) word processor. While 
you are working on a document, it is kept entirely in memory; 
consequently, all editing operations are very fast. Scrolling and 
searching are also very fast. The size of your document, however, is 
limited by the amount of available memory. 

If you are running low on memory, a warning dialog will appear 
and one or more windows may “black out.” To restore the window, 
click in the black area; Nisus will display the window if at all possible. 
For more information, see Memory Use page 466. 

Save your work and try any one or more of the following to increase 
available memory: 

* Close some windows which you do not absolutely need to 
have open. 

* Clear the clipboards: press the Option key and choose Copy 
from the Edit menu. This wili clear all clipboards. 

¢ Use Clear Undos... (Option Undo), but remember that 
you will not be able to undo this action and any other made 
before it. 

e If using MultiFinder you may have to increase the memory 
available to Nisus. To do this you first have to quit Nisus, 
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select the Nisus application icon, choose Get Info from the 

File menu of the Finder, and then type a larger value into 
the box at the bottom right corner of the dialog (make sure 
the application is not locked — check the box in the upper 
right corner of that window). 

¢ You may have set a large RAM Cache. Check the control 
panel setting of the RAM Cache and try turning it off (the 
amount of available RAM is indicated on the right hand 
edge of the Info Bar). Setting too large a RAM Cache can 
also slow Nisus down if it makes your Macintosh low on 
memory. 

Creating or Opening a File 

The commands in the File menu allow you to create, open, close, 
save, and print documents, revert to the saved version of your 
document, get information about it, and merge documents. 

Creating a New File 

To create a new document, choose New from the File menu. 

> To establish the format of a new file when it opens (font, size, style, 
rulers, etc.) create a Nisus New File as explained on page 65. 

Ie” You can also create a new document by opening a Nisus Stationery 
file. 

Opening an Existing File 

The Open Dialog 

To open an existing document, choose Open... from the File menu. 
Figure 4-1 displays the standard Open File dialog which can be uscd 
instead of the Catalog which is introduced, page 62, and in detail on 
page 191. 
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To open a file either double-click on that file's name or select the file 

by clicking once on its name then clicking on the button. 
You must choose Open... from the Fite menu every time you want 
to use the Open File dialog. 

© <Nisus (nent) 

(> <Nisus 2.0 

C <Nisus 3.0 

C correspondence 

Co MacQWweERTY 
© Mactag 

© QUED/M 2.09 

v2 = 

. . BS ; N “hie N 

= | iad 
File Type: Nisus® Readable (J Read only 

Figure 4-1 The Open File dialog 

Initially, you are shown every kind of file that Nisus recognizes. You 
can view files by kind when you click the document icons at the 
bottom of the dialog. Folders are always displayed. 

FE hieus® Readable 
Click this icon to display the names of all files understood by Nisus. 

Sd veues Only 

Click this icon to display only the names of files created by Nisus. 

WSNisus® Glossary 
Ctick this icon to display only the names of Nisus glossary files. 
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WENisus® Macros 
Click this icon to display only the names of Nisus macro files. 

‘een Saas Dictionary 
Click this icon to display only the names of Nisus dictionaries, user 
dictionaries and thesaurus files. 

FeeMicrosoft® Word 

Click this icon to display only the names of Microsoft Word files. 
During conversion from Microsoft Word, Nisus does not preserve 
the following 

Vertical bar tab stops 
Style Sheets 
Paragraph lines, boxes, and keep together 
Multiple sections 
side by Side Paragraphs 
Tables 
Equations * @ @ #@ @ @ ® 

i” Note that tables and equations can be duplicated as PICTs in Microsoft 
Word and then pasted into Nisus as graphics. To accomplish this, 
select the item in Microsoft Word and press Command-Option-D. 
You should use the Scrapbook desk accessory as a temporary storage 
area if you will be importing a lot of tables and/or equations in this 
manner. 

Headers and footers for only the first section of a Microsoft Word 
document will be imported. 

i Nisus can read Microsoft Word 3.0x and 4.0 if they have been 
“slow saved” in Microsoft Word. If you have not saved your files in 
this manner, you need to open the document once again in Microsoft 
Word and choose Save fis... and click the appropriate option to 
slow save the file. 
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Be acwr te® 
Click this icot: to display only the names of files created in MacWrite 

‘sion lL. You may also use the MacWrite Clirboard to transfer 
scuments tc and from MacWrite. Read Edit.:y Preferences in 
hapter 15 to ‘carn how to use the MacWrite Clirboard. Nisus does 

+ot preserve \:acWrite headers and footers. 

Opening a File With the Catalog 

The Catalog is the window in the upper right corner of the screen 
when you first open Nisus and choose Catalog... from the File 
menu. This is Nisus’ version of the Open File Dialog. 

You can open the Catalog, or bring it to the front by choosing 
Catalog... from the File menu. When the Catalog window is active, 
the Catalog menu appears at the right end of the menu bar. It 
allows you to navigate through folders, open documents and has 
many other properties and functions. 

To open a file using the Catalog double-click on that file's name or 
select one or more files then click the button. 

See more about the Catalog under File and Window Management, 
page 191 later in this chapter. 

Read Only 

By checking the Read Only box in the Open File dialog, you can 
specify that files are to be opened in Read Only mode. Any files you 
open with this box checked cannot be modified. 

The I-beam changes into a lock # when the active file is a read-only 
document; this lets you know that the window is read-only. Any 
attempt at changing the file will bring up the dialog shown in Figure 
4-2. 
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Sorry, this window Is reed-oniy 

Figure 4-2 Attempting to change a read-only window 

1 If you have a document open, you can open a second (third, fourth, 
etc.) read only copy of the open document by pressing the Shift key 
while double-clicking on the title of the file in the Catalog window. 

Saving Files 

It is important to save your work often. There are many ways in 
which you can save your files. 

Saving a New File 

Changes to your document are stored in memory until the time you 
save. Choose Save from the File menu to save your document on 
disk. 

When you save an untitled file, you will be asked to give your document 
a name and set its document type. This also happens if you choose 
Save Rs... from the File menu. 

The first time you save an untitled file, even if you choose Save, you 
will see the Save As dialog as shown in Figure 4-3. The current disk 
and folder name in the dialog shows where your file will be saved. 
To save the document in another folder change the folder before you 
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CG <forms “>| <— Macintosh HD 
CO <Nisus (next) 
© <Nisus 2.0% fe 
2 <Nisus 3.0 ee 
C) correspondence be 
OC MacQWeERTY Pa 
CG MacTac 

Save document as: 

Change Name, Don't Save 

File type: 
eer ere Nisus® Document 

Figure 4-3 The Save As dialog 

File names may be up to 31 characters long. You should limit yourself 
to 27 characters so Nisus can append .bak to the document name 
when it saves a backup. Nisus will shorten the name before appending 
-bak, if necessary. 

You can save your document in one of four formats. Each is explained 
below. 

Pe Nisus Document 

This is the most common document format and is therefore selected 
by default. 

Sh... Stationery 
A stationery document is a template document which when saved 
can be reused. When you open a stationery document, its contents 
are automatically transferred to an untitled document. The sta tionery 
file can contain text and graphics just as a regular Nisus document 
does, or it can be an empty file used only to set up the Starting font, 
style, and size, ruler settings, and any aspect of the window, including 
Its size, position on screen, state of the rulers, etc. You may save as 
many stationery documents as you wish. 
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To create a stationery, “template,” document: 

1. Choose New from the File Menu. 
2. Set font, style, size and ruler to your specifications. 
3. Add text (including variables) and graphics, if any, that you 

wish to appear every time you open the template document. 
4. Set up the window the way you want it to open. 

5. Choose Save fis... from the File menu to give your template 
document a name. 

6. If you have a PostScript printer, choose As PostScript® 
from the Display submenu of the Tools menu. 

7. Click on the Nisus® Stationery icon to make it a stationery 
type file. 

8. Type in a name for the template, and click Save __]}. 

When you save a file as Nisus® Stationery, its screen window 
name will change to Untitled. To open the template document, choose 
it from the Open dialog or the Catalog window. For example, choose 
“Business Letter” if you wish to write a letter using the business 
letter format that you have already created and saved as a stationery 
document. 

When you open a stationery file, the file opened is named Untitled. 
Therefore you can modify it and save it without destroying the original. 
When you choose $ave, you will be asked to name it with the dialog 
in Figure 4-3. 

Saving a Nisus New File 

The stationery file also allows you to set preferences for your new 
files. When you choose New from the File menu, Nisus looks for a 
stationery document called Nisus New File first in the folder containing 
Nisus and then in the System Folder. If it is found, it will be opened 
and named Untitied-#. 
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To set new file preferences: 

. Choose New from the File Menu. 
2. Set any window, font, style, size and ruler to your 

specifications (any menu item that can be checked or 
unchecked and any dialog that is saved with the file (such 
as the one that appears when you choose Set Scale... 

from the Graphics menu) can be saved a part of your Nisus 
New File—these attributes wil] be identified in the manual 
as they are discussed, or check the index for Nisus New 
File). 

3. Set the window size, location and the state of all the icons, 
rulers, etc. 

. Choose Save As... from the File menu. 

. Name your document Nisus New File. 

. Click on the Nisus® Stationery icon. 

. Save your document in the folder containing the Nisus 
application or in the System Folder. 

—4 

“1S OF 

Because choosing New opens all documents as Untitled, you can 
make modifications to the template after it is opened and save it with 
a new name without fear of overwriting the original. 

Bi icrosone Word 3.0x 

EXT Only 
Because the file type of Nisus documents is TEXT, other programs 
can open Nisus documents as TEXT Only even if they were not saved 
that way by Nisus. If you choose this option the file will be saved 
with only the text information. All formatting and graphics will be 
omitted, making the file take up less space than it would otherwise. 

Normally when you Save As... by another name, the title of the 
window changes to the new name. However, the title of the document 
will not change when you Save fs Text Only. Although the version 
saved on disk is Text Only, the document in the window is 
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unmodified—none of its information is lost. This enables you to save 

a document as Text Only and continue working. 

Saving an Existing File 

Once you give your document a name, you don’t see a dialog when 

you choose $ave. Your document is saved quietly and the Change 
Indicator icon (_{9), indicating that the file has been modified since 
the last save, disappears from the information bar. 

You should save your work regularly. This protects you from losing 
your work because of a mistake, power failure or hardware problem. 
If a problem does occur, you may lose all the work you have done 
since the last time your document was saved. Because it is easy to 

forget to Save, Nisus will save your document automatically every 
several keystrokes if you tell it to do so. See Customizing Nisus, 
Saving Files Preferences page 441. 

When you save your file to disk, it is safe as long as the disk is 
reliable. If the disk is damaged or lost, your work may be lost. Therefore, 
make it a practice to save a second copy of your work on a separate 
disk. You may do this manually, or have Nisus do it automatically 
whenever your document is saved. 

Each time you save your document, a new file is written to the disk. 

If the save was successful and Nisus is set to remove backups, the 
previous version of the document on disk is removed. If Nisus is 
instructed to save backup files, the previous version of the file will 
remain on the disk with .bak added to its name. 

I Saving Preferences explains how to have Nisus save your files 
automatically, save a backup copy and save on two disks at once. 

Saving an Alternate Version of a File Using Save As... 

If you want to make a change to an existing document and save the 
new document without affecting the original, choose Save As... 
from the File menu. You can change the text, the format, or the file 
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type or merely change the name and/or location of the file. The 
original file will be closed and your newly saved file will remain 
open with the new name, location or any other changes made to it 
will be saved. 

Editing a File 

The Document Window 

a st cae cepa ae fee eee a ine 7 

Master Ruler 

Vertical Scroll Bar 

Horizontal! Scroll Bar 
vans 3% Aaa aLiees LAR RA ine Cea? L bal Hes “Tad: ar ypests ON Gis IA ir isithl amit eo 

ccfey coae.ets acuate tbucbte canst eMetges EET meme iprae re eee Ee 

Figure 4-4 A Sample Untitled Window 

When you choose New from the File menu, or open an existing 
document, a document window will appear on your screen as 
illustrated in Figure 4-4. This section describes the different parts of 
the document window: the Info Bar, Scroll Bar, Master Ruler, and 
Graphics Palette. Some of these items are available in other types of 
windows. 

LI 633/4 0 1[3)}-2[1)} } 645k B28 
Figure 4-5 The Information Bar with the Sync. Scrolling icon showing 
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4 D2 } 3987K ()2 

Figure 4-6 The information Bar without the Sync. Scrolling icon but 
showing the Current Clipboard icon 

The Info Bar 

You can show and hide the Info Bar Figure 4-5 and Figure 4-6 by 

clicking the Show Info Bar icon{ [| at the top of the Vertical Scroll 

Bar of the window, or by choosing Info Bar from the Display 
submenu of the Tools menu. 

The Change Indicator icon dS appears at the left side of the Information 
Bar when the document has changed since the last save. 

When a file is opened as Read Only, the lock icon f@ is displayed in 
place of the Change Indicator icon because the contents of the file 

cannot be changed (and the insertion point has a lock on it: ®). 

The insertion point position indicator (a pair of numbers separated 
with a slash: 633/4 in Figure 4-5) displays the current position of the 
insertion point. Nisus is shipped with the first number representing 
the character count from the beginning of the paragraph. The second 
number represents the line number from the beginning of the page. 
To change this display, see Measurement Preferences page 448. 

The page number is displayed to the right of the page number icon 1) 
in the center of the information bar. If your document has multiple 
columns, the column number is displayed in brackets following the 
page number (1[3]-2[1] indicates that column three of page one and 
column one of page two are on screen). If you choose to number 
your pages with Roman numerals (set in Set Date & Page# 
Formats... from the Format menu) the numbers in the Info Bar 
will appear as Roman numerals (Uppercase or lowercase) with thcir 
Arabic equivalents beside them: D XX!V(24). 

The Synchronized Scrolling indicator BB is displayed at the far right 
of the information bar when synchronized scrolling is turned on. It is 
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displayed in the information bars of both windows the scroll bars of 
which are synchronized. The Sync. Scroliing command is in the 

Edit Tools submenu of the Tools menu. See below, page 200, for 
how to use Sync. Scrolling. 

When Synchronized Scrolling is not activated and a clipboard other 
than Clipboard 0 is the current clipboard, the Current Clipboard 
icon () followed by the number of the current clipboard will appear 
on the right hand end of the Info Bar as illustrated in Figure 4-6. 

To the left of the Synchronized Scrolling indicator, the number followed 
by a K (845K in Figure 4-5) is the Available Memory indicator. It 
indicates that you have that much available memory (measured in 
kilobytes [K] of RAM Random Access Memory) remaining with which 
to work. 

To the left of the Available Memory indicator, Nisus can inform you 
if you have unmatching parentheses or quotations. For more on this 
feature see Matching Quotes and Parentheses, page 325. 

The Master Ruler 

The Master Ruler as shown in Figure 4-7 displays the margins, the 
first line indent/outdent, the line wrap indicators, tab stops, 
justification, line height, paragraph spacing and, (if there is one), the 
name of the current ruler, in the current paragraph. The ruler 
dimensions can be in centimeters or inches, according to the settings 
assigned when choosing Measurement... in the Preferences 
submenu of the File menu. 

The Master Ruler permits you to set tab stops, line and paragraph 
indents, line height, paragraph spacing, and paragraph justification 
for the paragraph in which the insertion point appears. For information 
on how to set these attributes, see Formatting Paragraphs using Rulers 
page 86 later in this chapter. Note that margin limits are set only 
when the Layout window is open. 
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7 Show Headers/Footers 

Show Rulers 
Ruler 

Tab Paragraph | Paragraph Name 
Justification : i pacing 

The Master ruler as shown here displays the 
margins, the first line indent/outdent, the line 
wrap indicators, tab stops, justification, line 
height, paragraph spacing and, (if there is one), 
the name of the ruler, of the current paragraph. 

First Line Indent/Outdent — 

Left Line Wrap Indicator ‘Right Line Wrap Indicator 

| Named Paragraph Rule - 

Un-named Paragraph Ruler 

Left Margin Right Margin 

Figure 4-7 The Master Ruler 

To show the Master Ruler at the top of your document window, click 

the Master Ruler icon = in the scroll bar, or choose Master Ruler 

from the Display submenu of the Tools menu. 

The Left Margin Display 

The left margin of the document window displays the Header and 
Footer icons and the paragraph rulers. 

aeaeeoeee 

you have inserted any. See Headers and Footers page 152 in 
this chapter for more information. 
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o. Show Rulers icon displays rulers (to the left of paragraphs) 
that have formats differing from the format in the preceding 
paragraph. See page 86 for a discussion of rulers. 

Icons in the Vertical Scroll Bar 

The icons above the vertical scroll bar perform the following functions: 

be das Show Info Bar icon 

Click this icon to show and hide the information bar. 

=) eds Show Master Ruler icon 
Click this icon to show or hide the Master Ruler. (If the Graphics 
Palette is showing, the Master Ruler appears in its place.) 

Bits Show Graphics Palette icon 
Click this icon to display the Graphics Palette and enter 
graphics mode. Click it again, or click the Master Ruler icon, 
to return to text mode. 

vaasisd Layout Page... icon 
Click this icon to display the Layout window. The features of 
this window are described in Layout Page..., and Printing 
pages 135, and 169, respectively. 

M8 ...... Horizontal Split Screen Bar handle 
The small black strip just below the Layout Page... icon is 
called the Horizontal Split Screen Bar handle. It is used to 
split a window into two horizontal panes. Another split bar 
at the bottom left corner of the window is used to split the 
window into two vertical panes. To use cither one, drag it 
along the scroll bar to the point where you want the split. 

ite” Double-click the split bar to return the window to its unsplit state. 

Icons in the Horizontal Scroll Bar 

The icons to the left of the horizontal scroll bar perform the following 
functions: 
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Click this icon to display a vertical ruler that can be used to 
measure your distance from the top or bottom of the page. 

You can also activate this ruler by choosing Vertical Ruler 
from the Display sub menu of the Tools menu. When on 
the graphics sheets a line will appear in the ruler to indicate 

the actual position of the mouse. 

a eee Vertical Split Screen Bar handie 
The small black strip just to the right of the Show Vertical 
Ruler icon is called the Vertical Split Screen Bar handle. It is 
used to split a window into two vertical panes. The other 
split bar just below the Layout Page... icon is used to split 
the window into two horizontal panes. To use either onc, 
drag it along the scroll bar to the point where you want the 
split. 

Graphics Palette 

To display the Graphics Palette shown in Figure 4-8, click the Show 

Graphics Palette icon in the scroll bar, or choose Graphics 

Palette from the Display submenu of the Tools menu. This puts 
you in the graphics sheets. You can use the graphics tools from this 
Graphics Palette to draw pictures in your document. 

Figure 4-8 The Graphics Palette 

Tools are provided to create and edit drawings. The Graphics Palette 
contains menus that determine how graphics interact with your text 
and with each other. For more information on the graphics sheets 
and the Graphics Palette, please refer to Chapter 7, Working With 
Graphics, page 233. 
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Adding Text 

When you type, text is inserted into the active document window at 
the insertion point (which continues to move farther to the right until 
the line wraps). Text may be inserted at any point in the document. 
Scroll until the text you want to see is in view, place the I - beam is at 
that point, then click the mouse button. 

You can also use the Paste command to insert text into your 
document. When you choose Paste, whatever is on the Clipboard is 
placed at the insertion point. If there is a current selection, it is replaced 
when you choose Paste or type. 

To move the insertion point to the end of the document, click anywhere 
after the last character in the document. To place the insertion point 
immediately after the last character on a linc, click anywhere on the 
line after the last character. The insertion point may also be moved 
using the arrow keys. For a listing of keyboard commands that move 
the insertion point, refer to the Quick Reference Guide pamphlet. 

ie” To bring the insertion point into view, press Enter. 

Selecting Text 

When you click once within the text of the document window, the 
insertion point will be placed at the I-beam. You can drag the I-beam 
to select text, or hold down the Shift key while you click to extend 
the current selection. 

ls” There are faster ways of selecting whole words, lines and paragraphs. 
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To select... Piace the I-beam over it and... 

e aword double-click 
* asentence triple-click 
* aline Option triple-click 
* to beginning of sentence Shift triple-click 
* a paragraph click 4 times 
* adocument click 5 times or choose Select All 

CHAPTER FOUR 



To continue selecting text as the mouse is moved, hold down the 
mouse button after clicking the desired number of times and drag. 
This selects text as whole objects. For example, if you double-click 
and drag, you will select only whole words, if you click four times 
and drag, you will select only whole paragraphs. 

“IG When you Option triple-click to select a line which has a return 

character “4” at the end, the return character is not selected. 

Rectangular Selection 

The standard selection method selects characters, wrapping from the 
end of one line to the beginning of the next. Nisus also provides a 
method for selecting a column of text. This is called a rectangular 
selection. 

Rectangular selection works best on columns separated by tabs. In 
Figure 4-9 a column without its following tabs is selected while in 
Figure 4-10, a column and its following tabs are selected. 

On the 19th ‘of: March‘the ‘following 

Widgets? f'§ 

{4521-1 
3918-156 

: OM! Eee: - 

Figure 4-9 A Rectangular Selection without Tabs selected 
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oy On the 19th of M 

| Pao 
| -Wikisky sy, 

| SAREE 

Figure 4-10 A Rectangular Selection with Tabs selected 

To move the Stock # column in front of the Widgets column, as in 
Figure 4-10, use rectangular selection. 

The I-beam changes into the Rectangular Selection Tool i when the 
Option key is pressed. Create rectangular selections by pressing the 
Option key while dragging. As you drag, a frame defines the 
rectangular region of characters being selected. Because the characters 
of proportional fonts are of varying width, the actual selection will 
probably be ragged. 

The selection edges of each line are defined by the boundary character 
nearest to the rectangle. In Figure 4-10, the right side is straight, 
because tabs are used to separate the columns and tabs are of equal 
width. The left edge is not straight because the stock numbers do not 
Start at exactly the same point on every line. 

ite” When selecting column text in this way, you may sometimes need to 
select the tab characters which define your columns (that is to the Icft 
or right of your column). To include them, make sure that the “white 
Space” produced by the tabs is also selected. 

When you paste text that was cut or copied with rectangular selection, 
the first line of the selection is inserted at the insertion point and the 
rest of the lines are inserted on the lines below at the same number of 
characters in from the left line wrap. No filler spaces are added, so if 
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the lines below the first are not as long (as illustrated in the difference 

between line one and the remainder of the lines in Figure 4-11 B), 

the rectangular selection will no longer appear as a column. Similarly, 

if there is no carriage return below the insertion point, the entire 

rectangular selection will be pasted into one line. 

To paste a rectangular selection there must be an insertion point, 

rather than a selection. Figure 4-11 A shows a column being selected 

and copied onto the Clipboard. In Figure 4-11 B, the insertion point 

was placed before the first line (before Nisus) and then the column 

was pasted. 

Nisus allows rectangular selections. 
Rectanguar selections can be cut. 
Rectangular selections can be pasted. 
Rectangular selections contain columns. 
They can be edited on the Clipboard. 

i + Metre rere Oates OE Aee eer eat 

100.01 Nisus aliows rectangular selections. 
85.29Rectanguar selections can be cut. 

| 95.82Rectangular selections can be pasted. 
80.00Rectangular selections contain columns. 
99.9¢They can be edited on the Clipboard. 

Figure 4-11 A. Selecting a column B. Pasting the column 

Nothing can be pasted or typed while a rectangular selection is active 

(highlighted). 

IG> The Intelligent Cut and Paste feature does not work with 

rectangular selections. Furthermore, rectangular selections cannot be 

pasted into dialog edit boxes. 

Noncontiguous Selection 

You can select items on the text layer that are not next to each other 
and have your editing choices affect all of the selected text as illustrated 
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in Figure 4-12. This is called Noncontiguous Selection. Press the Com- 
mand and Option keys, then select a word, a line, a paragraph, and/or 
a Character Graphic. 

its While you can select Character Graphics as well as text, the menu 
commands in Font, Size and Style (except Color) will not affect 
their appearance. 

Certain commands are disabled during noncontiguous selection: 

In the Edit menu: 

¢ Paste 

« Move Left 

« Move Right 

« Sort 9 

e Break Lines 

¢ Zap Gremlins 
(and their modified commands). 

In the Tools menu: 

¢ Copy to Find 

¢ Mark Text... 
e Cross Reference... 

¢ Kyphenate 
¢ all the commands in the Edit Tools submenu 
e inthe Display submenu: 

¢ Document 

e Headers/Footers 

¢ Footnotes 
* in the Glossary submenu: 

¢ Expand Abbrev.. 

In the Format menu, the only commands enabled are Update Time 
& Date, Set Date & Page *Formats..., Mark index, Make 
index, Mark Contents and Make Contents.... 

Entering text from the keyboard is disabled when noncontiguous 
items are selected. 
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i= You cannot noncontiguously select paragraph rulers. 

—— aes Nonconti 
Mown below in the valley by the lake I knew I'c 

find Harvey. He was an |i. Not 
the kind that needed to conquer the big fish from his 
high-powered boat, but the quiet contemplative 
tiem) turted ott Del Dios Higteyvay deen te Labe ge 
Brive and slowly cruised along the shore. (ee a 
ittle houses half-hidden in the trees belied the fact : 

that | was still in the largest Bibag i 
California. It probably wouldn't be long before 

Figure 4-12 Noncontiguous Selection 

This form of selection also works in the Catalog. You can select a 

variety of files in a particular folder that are not next to each other 

and then open them, add them to your search list, or copy their 

names. 

Undo Command 

When you make a mistake, you always wish that you could just 

undo it: put back the deleted text or graphic, or change the formatting 

back to the way it was. As you work in Nisus, your changes are 

stored sequentially in a list called the Undo List in the order you 

made them—just in case you want to undo them later. 

When multiple documents are open, the changes to all of them are 

held in the same undo list. Therefore, you may not be able to undo a 

change to another document without undoing the changes you just 

made to the current document. When you close a document, all the 

changes made to it are removed from the undo list. They are not 

saved with the document. The order of the remaining changes in the 

undo list is not changed. 
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ie Initially, the undo list is empty. It is preset to remember up to 300 
changes. You can change this number as explained in Editing 
Preferences, page 443. 

ts" By making the number of undos smaller, you can reduce the amount 
of memory required by the undo list. This may be necessary to edit 
larger documents. 

it You can clear the undo list, thereby freeing up memory, by choosing 
Undo while pressing the Option key. The Undo command changes 
to Clear Undos... and you get the warning dialog illustrated in 
Figure 4-13. 

Are you sure you want to clear 
the Undo list? This action is not 
undoabie} 

Figure 4-13 The Clear Undos Warning Dialog 

ts The undo list is not saved when you quit. It starts empty when you 
open Nisus, and as you make changes, it grows. 

Undoing Changes 

To undo a command, choose Undo from the Edit menu. To undo 
the command before that, choose Undo again. You may continue 
doing this up to the number of actions that are in the undo list. 

Redoing Changes 

Not only can you undo your previous actions, you can also redo 
them. Redo—the opposite of Undo—undoes your undo. It puts your 
commands back into effect. You can continue redoing all the 
commands in the undo list until it is empty. The Redo list is remembered 
as long as you do not make any editing changes to the text. You can 
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Undo and Redo any number of times, but as soon as you resume 

editing your document, the Redo list is cleared. The Undo list continues 
to accumulate the new commands you make. 

To help you visualize these Undo and Redo lists, imagine that the 
process of preparing your document is like a walk across an open 
field with many branching paths. Refer to Figure 4-14. You can take 
any path you like. Having gone a certain distance along the path 
ABCD in the figure, you change your mind and want to go back to 

the point B which you passed. That is what Undo allows you to do. 

Figure 4-14 Undo and Redo paths 

Imagine now that you have gone back to B, you find you have gone 
back too far and want to retrace your original path to C. That is 

where Redo helps you. Suppose now that you end up at C (having 
redone part of the original path) and start on the new path CEF, (by 
making changes to the document). Immediately, the rest of the original 
path CD is forgotten - the Redo list is cleared before the path to E 
begins. The new undo list, however, can get you back along any 
portion of the path ABCEF. 

Undo Command Keys 

The keyboard equivalents for the Undo and Redo menu items change 
when Undo is chosen. In fact, they are swapped. If you wish to undo 
several actions at once by using a keyboard equivalent, first use #2, 
then use 4P%2Z (Command-Shift-Z) for subsequent undos. Note the 
difference between the shifted and unshifted 2. 
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ie” If you prefer, you can set Undo and Redo to two different Command 
keys. For example, you may set Redo to ¥Y while keeping Undo as 
3 2. When you do this, the Command key equivalents are not swa pped 
as before. #2 always means Undo and #¥Y always means Redo. 
You can also make Command-Shift-2 always mean Redo by not 
assigning it any key. See page 452 to learn how to set Command 
keys. 

Clipboards 

Clipboards temporarily store copied (or cut) text and/or graphics. 
You can 

¢ Place a single character or an entire document on the 
Clipboard 

* Edit text you have put on your clipboard 
° Transfer text or graphics from another application into Nisus. 

Nisus understands the MacWrite Clipboard format, so when you usc 
this feature you can transfer text along with its attributes. Read about 
the MacWrite Clipboard under Editing Preferences page 443. 

Nisus allows the standard Cut, Copy and Paste operations using 
any of its ten clipboards. 

its” While you can store many different items on the various clipboards, 
only one clipboard is active for cutting and pasting at a time. This 
clipboard is called the Current Clipboard. If the Current Clipboard is 
other than Clipboard 0, the Current Clipboard icon @) followed by 
the number of the current clipboard will appear on the right hand 
end of the Info Bar. 

Cutting, Copying, Appending and Swapping 

When you select text and then choose Cut or Copy from the Edit 
menu, the selected text is placed in the current Clipboard, replacing 
whatever was there. The current clipboard number is displayed in 
parentheses beside the Set Clipboard menu command at the bottom 
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of the Edit menu and in the upper right corner of the Info Bar, as 
well as in the title bar of the clipboard when it is showing. 

Choose Copy from the Edit menu to copy the selection onto the 

Clipboard. Copy will not alter the selection. Choosing Cut from the 

Edit menu will remove the current selection and place it on the 
Clipboard. All other clipboards are unaffected. The insertion point 
will then appear where the selection was removed. 

In Nisus you can add multiple selections to the existing contents of 
the Clipboard. This is useful for gathering noncontiguous text on the 
Clipboard. To append the selection to the current Clipboard, hoid 
down the Shift key while choosing Copy or Cut. You will notice 
that the menu commands names change to Append Copy and 

Append Cut respectively when the Shift key is pressed. 

To swap the selection with the contents of the current Clipboard, 

hold down Shift while choosing Paste from the Edit menu. You 
will notice that the menu command name changes to Swap Paste 

when the Shift key is pressed. 

ie’ If you choose Copy when no text is selected, the last deleted text 
will be copied to the Clipboard. 

I> If you choose Copy while holding down the Option key you can 
clear all the clipboards. Notice that the menu command name changes 
to Clear Clipboards when the Option key is pressed. This might 
be done if you are trying to free up memory. 

Pasting 

After you have copied something to the clipboard you can then insert, 

{or paste) it back into your document. To insert the contents of the 
Clipboard into your document, choose Paste from the Edit menu. 
When in text mode, this will insert the Clipboard contents at the 
insertion point. If a graphic is on the Clipboard, it will be inserted as 
a graphic character. See Character Graphics, page 236. 
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When on graphics sheets, you paste text from a clipboard into a text 
box. Read about text in graphics on page 249. All the text in a text 
box has the same attributes, so the pasted text will have the same 
font, size, and style. If you have not created a text box and you try 
pasting text in the graphics sheet, nothing will be pasted. 

is To create text with various font, size and Style as well as ruler attributes 
use the Place commands as explained in Desktop Publishing and 
HyperText Links Using Page Graphics, page 291. 

Multiple Clipboards 

There are ten identical clipboards to use while editing. Only one of 
them is current and will be affected by Copy and Cut operations. 
This is called the Current Clipboard. You may change the Current 
Clipboard by choosing its name from the Set Clipboard (0) 
submenu. You may display the Current Clipboard by choosing Show 
Ciipboard from the Edit menu. If you are doing a lot of clipboard 
Swapping you should probably assign Command key equivalents to 
the various clipboards. See Assigning Command Keys to Menu 
Commands page 452. 

It is especially convenient to use clipboards as temporary storage for 
frequently used text or graphics or even rulers. The multiple clipboards 
are especially useful in copying between different Glossary or Macro 
files. 

You can also access all ten clipboards from the Nisus Macro Language. 
For information about using clipboards with macros, see Edit Menu 
Commands, page 411. 

If the Current Clipboard is one other than Clipboard 0, and the Sync. 
Scrolling Indicator @2§) is not showing, the Current Clipboard icon 
and the relevant number will appear at the right edge of the Info Bar: 
o*) 8” 

When the Clipboard is showing the Set Clipboard (?) submenu is 
available by pressing the Option or Command key and clicking on 
the Clipboard title bar as illustrated in Figure 4-15. 

84 CHAPTER FOUR 



eee Cipbeard 4 

P| 

Figure 4-15 An open clipboard with the Set Clipboard submenu 

wVewloawraAWUA = & 

Editing Clipboard Contents 

Clipboards can be edited. Choose Show Clipboard from the Edit 
menu, then edit as in any other document window. 

i Drawing on the clipboards’ graphics sheets, if there is no text present, 
is not recommended. You will not be able to paste the graphic unless 
you attach it to a return character. 

Moving Selection 

The Cut, Copy and Paste commands in the Edit menu are used to 
move selections around. 

To move a selection (the selected text will be deleted): 

1. Choose Cut. 
2. Place the insertion point where you want to insert the 

selection. 

3. Choose Paste. 

To insert a second copy of a selection (the selected text will remain in 
its Original location): 

1. Choose Copy. 

2. Place the insertion point where you want to insert a copy of 
the selection. 

3. Choose Paste. 
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Formatting Paragraphs using Rulers 

A Nisus document consists of one or more paragraphs. A paragraph 
starts at the beginning of the document (the first paragraph) or after 
typing a return character, and it ends at the end of the document or 
after typing a return character. 

A blank or empty paragraph results when a return character follows 
another return character with no visible text in between. There may, 
however, be spaces or tabs between the two returns. Nisus treats 
empty paragraphs like any other non-empty paragraph. The one 
exception to this rule occurs when you choose Get Info... from the 
Fite menu in order to count paragraphs for statistical purposes. In 
that case, though paragraphs with nothing but graphics are counted, 
all empty paragraphs are ignored. 

Paragraph formats are controlled by rulers. As you type text, the 
most recent ruler controls the format of all following paragraphs 
until the next ruler is inserted. 

When you change the format of a paragraph, you change the settings 
of a ruler. A ruler can apply to a single paragraph or many paragraphs. 

Click the Show Paragraph Rulers icon !CT}} in the top left of the 
Master Ruler to show the rulers. All rulers appear in the left margin, 
opposite the paragraphs which they affect. 

Paragraph format includes first line indent/outdent, left and right 
line wrap boundaries, tabs, line spacing, paragraph spacing and 
justification. 
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Paragraph Line Wraps And Tabs 

Paragraph Line Wraps 

The left and night indicators ? set the points on the left and right 
where the lines of your paragraphs will “wrap” as in Figure 4-16. 

The first line indent/outdent # indicator determines where the first 
line of a paragraph will begin. Drag these indicators along the Master 
Ruler to change their settings. 

Figure 4-16 shows the first-line indent set to the right of the left line 
wrap indicator. This indents the first line of the paragraph. You can 
swap its position with the left line wrap indicator to achieve a hanging 
indent. 

I wasn't expected at the office for a while so I took advantage of the 
time to get some information from the two sisters, Jayn and Carole. | 
had driven up 1-805 to 1-5 and got off onto Via de la Valle. Justa short 

way into the ‘flood plane” of the San Dieguito river, past the tomato 

fields I turned. The little green sign read The thoughtless 
Anglos hadn't considered using an fi on the street sign. At the bottom, 
the canyon is barren and unassuming. Up above large homes were 

nestled into the hillsides surrounded by lush green shrubs that soak up 
the water from the Colorado and San Juaquin rivers. I turned onto 

Vista del Lugano into a little «u/ ve sachuddied in a tiny bowl among 
the hills. The two houses I was looking for were side by side on 
opposite sides of the aa; taking up the entire street. Each was a clear 
representation of the two 

ait ta new Pea em ee en 

Figure 4-16 The Left and Right L Line eWeek indicators extended to the 
Margin Limits 

You cannot move the line wrap indicators nor the first-line indent 
into the gray regions which represent the margin limits as illustrated 
in Figure 4-16. If you need to move the indents out farther, you can 
reduce the gray region by setting page margin limits in the Layout 
window. Refer to Layout Page..., on page 135. Note, however, that 
you cannot exceed the printer limits. 
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te” When you have paragraphs of different formats selected, the Master 
Ruler shows the format of the first selected paragraph. To change the 
paragraph indents of all paragraphs selected relative to their current 
position, hold Shift while making your changes to the Master Ruler. 
Without holding Shift, the changes will be absolute. That means, the 
-hanges will be the same for all paragraphs. For example, if you 
change the left paragraph indent, it will move to the same position 
for ali selected paragraphs. 

Tab Stops 

Tabs are used to align columns of text. Pressing the Tab key lines up 
the text that follows at the next tab indicated on the ruler. Four types 
of tabs can be placed on the ruler. As illustrated in Figure 4-17, these 
types differ in the way they justify the text: 

left tab 4. text is aligned left on a left tab stop 
centertab 4 text is centered beneath a center tab stop 
right tab & _ text is aligned right on a right tab stop 
decimal tab << = decimal points align on a decimal tab stop 

€ g 
alignment alignment alignment 
example example example 

Figure 4-17 Tab stop justification 

To set a tab stop on the ruler, click and drag it from one of the four 
tab wells, |4.| 4} 4/4] Once placed on the ruler, tabs can be 
repositioned by dragging. To clear a tab stop, drag it “beneath” the 
ruler, then release it. To help you position paragraph indents and 
tabs on the ruler, use the dotted guide line displayed as you drag a 
paragraph indent or a tab. There is no limit to the number of tabs 
you can set on any particular ruler. 
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Leader Fabs 

In Nisus you can specify what leader character is to be inserted 
before the tab stop. This type of tab is called a leader tab and is 
illustrated in Figure 4-19. Select the bar containing dots, 
Co), just below the tab weils to turn all tab wells into 
leader tab wells. This is called the leader bar and will be highlighted 
when the leader tab wells are active. Any tabs you set while the 
leader tab wells are active will be leader tabs that look like &, &, & 
or >. 

You can change the character that is used for the leader. Double-click 
the tab icon on the ruler whose leader you want to change. You will 
see the dialog shown in Figure 4-18. 

Select the jeading character for this tab: 

XNONone ¥P @......... *LO-__RUO [ ] 

Figure 4-18 Changing an individual tab leader 

You can select one of the predefined leaders shown or type a character 
of your own in the box on the right. 

To change the leader for all tabs you subsequently take from the tab 
wells, double-click the leader bar. You will get the dialog illustrated 

in Figure 4-18 except that you may not choose None. 

You may change the leader setting at any time. However, when you 
do, the tab wells are converted to leader tab wells. 

Center tab wR 

a alignment................alignment alignment 
sever OXAMPIE oo... a OXAMPHE nn OMAN DIG ee 2B 7459 

Figure 4-19 Tab stop justification with leader tabs 
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Paragraph Justification 

= |= |= 
Figure 4-20 The Paragraph Justification boxes with full justification 

selected 

You can specify how the individual lines of a paragraph will be 
aligned with respect to the left and right line wrap indicators. The 
choices are left, middle, right and full justification as illustrated in 
Figure 4-20. 

Left and right justification aligns text with the left or right paragraph 
indent, respectively. See Figure 4-21 and Figure 4-23 respectively for 
these two justification options. Middle justification centers text 
between the two line wrap indicators. This is illustrated in Figure 
4-22. 

Full justification justifies text by adjusting spaces, so text is aligned 
on the left and the right paragraph indent. The first and last word of 
each line touches the left and right line wrap indicators. The last line 
in a paragraph is not fully justified. This method of justification is 
illustrated in Figure 4-24. 

Paragraph Justification affects the text of that paragraph in which the 
insertion point resides, or whatever greater number of paragraphs 
have been selected, or, if a Paragraph Ruler has been selected, whatever 
text that ruler controls. 

y by ake ne 
Harvey. He was an inveterate fisherman. He 
didn't need to conquer the big fish from his 
high powered boat; he was the quiet 
contemplative kind. | turned onto Lake Drive 
and siowly cruised along the shore] 

Figure 4-21 Left Justification 
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y by ind 
Harvey. He was an iislorals fase tad He 
didnt need to conquer the big fish from his 

high-powered boat: he was the quiet 
contemplative kind. | turned onto Lake Drive 

and siowly cruised along the shore. 

Figure 4-22 Center Justification 

y by elknew 
Harvey. He was an inveterate fisherman. He 

didn't need to conquer the dig fish from his 
high-powered boat; he was the quiet 

contemplative kind. | turned onto Lake Drive 
and siowly cruised along the shore. 

¥ by 
Harvey, He was an inveterate fisherman. He 
didn't need to conquer the big fish from his 
high-powered boat; he was the quiet 
contemplative kind. | turned onto Lake Drive 
and slowly cruised atong the shore. 

Figure 4-24 Full Justification 

i> If a text is in full justification it will hyphenate more than if it is in 
any of the other justification modes. 

The New Line Character 

You can enter a new line character (which appears as: « when you 

choose $pace, Tab & 4] from the Display submenu of the Tools 
menu). This forces a new line without beginning a new paragraph. 
Type Shift-Enter to force a new line. This is useful when you want to 
force a new line but do not want it to obey the indent (or outdent) 
setting of your ruler. This is also useful for separating lines of a 
paragraph which you may want to sort by the beginnings of paragraphs 
as illustrated in Figure 4-58 on page 121. 
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i The new line character is also variously known as a “forced line feed 
character” and a “soft return.” 

Line Height 

Figure 4-25 The line height box 

Line height refers to the actual height of a line, not the space between 
lines. The lines affected by “Line Height” are those of the paragraph 
in which the insertion point resides, all the selected paragraphs, or 
those paragraphs controlled by that particular Paragraph Ruler. A 
setting of 0 in the number box indicates that no extra space will be 
added. 

You may set the line height method three different ways by clickin g 
on the icon at the right edge of the Line Height Box (illustrated in 
Figure 4-25): automatic (fee) [Fix ]}) or by standard line heights 
({Line]). The three options rotate one after the other. 

is” A line is measured in points, or pixels, depending on the size of the 
font used. 

You can increase or decrease the height by clicking the expand icon 
to increase line height) or contract icon ({Z=| to decrease line 

height) boxes or by typing a value in the number box [o] . When 
the height between lines can be decreased no further, the decrease 
icon is dotted: | #22). 

means that Nisus maintains enough space between lines to 
display the tallest character on that line. If you insert a graphic or a 
character of a font size larger than the remainder of the text on a 
particular line, Nisus will automatically spread that line so that the 
characters do not overlap. This option is illustrated in Figure 4-26. 
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Inthe valley by the lake | knew i'd find Harvey. 
inveterate fisherman, He didn’t need to conquer the big fish trom his 
high-powered boat; he was the quiet contemplative kind. | turned onto 

Lake Drive and slowly cruised along the shore. The Aas half-hidden 

inthe # Doar | § * & belied the fact that | was still in the 
second largest city in California. | knew it probably wouldn't be long 

before they'd all be reptaced by . Harvey's old "60'S vintage 

silver Porsche was parked off the road near the northern end. | pulled 
in behind him and called out through the swamp grass jush along the 
water line; he rarety took the rowboat out more than a few yards from 
shore. When he didn't answer! walked further into the brush toward 

Figure 4-26 Automatic Line Height 

means that Nisus will maintain a fixed amount of space between 
lines regardless of the various heights of the characters on that line. 
If you insert a graphic or a character of a font size larger than the 
remainder of the text on a particular line, Nisus will allow the various 
characters to overlap. This option is illustrated in Figure 4-27. 

y ke | knew arvey. He was an 
inveterate fisherman. He didn't need to conquer the big fish from his 
high-powered boat; he was the quiet contemplative as. I turned onto 
Lake Dq t isag along the shore. The half-hidden 
inthe ay a belied the fact that t was silllin the 
second largest city In Califorhta. aan robably wouldn't be iong 
before they'd all be replaced b . Harvey's old '60’s vintage 
silver Porsche was parked off the road near the northern end. | pulled 
in behind him and catled out through the swamp grass lush along the 
water line, he rarely took the rowboat out more than a few yards from 
shore. ¥¥hen he didn't answer | waiked further into the brush toward 
the water Irying not to lose my loafers in the muck under foot. He was 
in his usual spot in his Usual position. i never understood how he 
never had to go to work. His poetry books never brought in any 
money, of course, but he always paid his rent on tme. He lay on his| 

Figure 4-27 Fixed Line Height 

ig” When your method is set at fixed or automatic, the value in the 
number box is understood in points. 

means that Nisus will keep your lines a certain standard line- 
space from each other. This is the option most like the mechanical 
method of spacing lines on a typewriter. The distances available in 
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the line option are set to half-line increments. This option is illustrated 
in Figure 4-28. 

n the valley by the lake! knew F'dfindHa':-- He was an 
| inveterate fisherman. He didn't need to conquer tne big fish from his | 

high-powered boat; he was the quiet contemplative kind. | turned onto 

Lake Drive and slowly cruised along the shore. The as, halt-hidden 

in the & § % i & * & belied the fact that | was still inthe | 

second largest city in California. | knew it probably wouldn't be long 

| 
before they'd all be replaced by Bat Harvey's oid ‘60's vintage 

Figure 4-28 Line Height By Line 

Ite” When the method is set at line, the value in the number box is 
understood to refer to lines. 

is” If you have set your line height method at [[Aute]] you may not see a 
change in the spread of your lines until a pixel or two beyond the 
size of your font because the Macintosh takes into account the 
“descenders,” “ascenders,” and spaces between the lines when 
counting the height of a line. 

Paragraph Spacing 

Ei 
Figure 4-29 The Paragraph Spacing box 

The Paragraph Spacing box, illustrated in Figure 4-29, enables you to 
affect the spaccs between paragraphs. Paragraph spacing refers to 
the height of the lines between paragraphs. The space is added above 
the paragraph in which the insertion point resides. The paragraphs 
affected are those in which the insertion point resides, all the selected 
paragraphs, or those paragraphs controlled by that particular 
Paragraph Ruler. 

04 CHAPTER FOUR 



A setting of “O” inserts no extra space. Each setting higher than this 
inserts additional space between paragraphs. 

pacing function interactively. When 

t [ Fix ] Nisus will increase or decrease 
the spacing between paragraphs in one pixel increments (the value 
in the number box refers to pixels). When Line Spacing is set at 
Nisus will increase or decrease the spacing between paragraphs in 
half-line increments (the value in the number box refers to lines). 

Changing Rulers 

The ruler display at the top of your document is called the Master 
Ruler. It displays, and is used to change, the format of the current 
paragraph. The current paragraph is that one in which the insertion 
point appears or the one that has its paragraph ruler in the left margin 
display selected. 

When paragraphs with different formats are selected, the Master Ruler 
shows the line wrap and first line indent, line height and paragraph 
spacing of the first selected paragraph and those other formats (tabs 
and justification) that they share in common. 

Changing any of the above format attributes when dissimilar 
paragraphs are selected replaces any conflicting attributes. For 
example, you can set uniform line height for a group of paragraphs 
by selecting them and then changing the line height. 

If the paragraph indentation differs for selected paragraphs, the 
indicators on the Master Ruler reflect the indentation of the first 
selected paragraph. Changing an indent will set it to be the same for 
all selected paragraphs. To move an indent relative to its current 
position, press Shift while changing it. This is illustrated in part C of 
Figure 4-30. 
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in the valley by the lake | knew I*d tind Harvey. 
He was an inveterate fisherman. He didn't need 
to conquer the big fish from his high powered 
boat, he was the quiet contemplative kind. 

I turned onto Lake Drive and slowly cruised 
along the shore The houses, half-htdden in 
the trees belied the fact that Iwas still in the 
second largest city in Caittornia 

C. First-line indents changed relatively ae 

Figure 4-30 Changing paragraph indents for different formats 

The first paragraph indents are reflected on the Master Ruler in parts 
A, B, and C of Figure 4-30. 

In part B, the left indent and the first-line indent indicators are moved 
to 1.5" without the Shift key pressed. This sets both indents for every 
selected paragraph. 
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In part C, the Shift key was pressed while dragging the indicator to 
1.5” (the same distance as in part B). This moved the first-line indent 
the same amount to the right (.25”) for each selected paragraph. 

Changing Similar Rulers 

Change Similar Rulers in Region 

To change all copies of a ruler in a selected region, hold the Command 
key down while making the change in the master ruler. All copies of 
the first ruler of that region will be changed the same way. 

Change All Similar Rulers in the Document 

To change the format of all paragraphs controlled by a particular 
ruler, place your insertion point in a paragraph controlled by that 
ruler, press the Command key and make the changes on the Master 
Ruler. 

i> This is useful if you have different paragraph formats in a document 
and decide to change one of them. You can change all copies of that 
format to reflect the desired change. 

i You can also change all similar rulers by using named rulers and 
changing the attributes of any particular named ruler (see Named 
Rulers, page 100). 

Creating Rulers 

When you open a new document it contains one ruler. As long as 
you do not change any paragraph formats all paragraphs you type 
are formatted according to this ruler. The Master Ruler displays the 
format of the current ruler across the top of your document window. 
The current ruler is the one controlling the current paragraph, which 
is the paragraph of your insertion point. 
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When you change the format of a particular paragraph by changing 
the Master Ruler while leaving the insertion point in tat paragraph, a 
new ruler is placed, if necessary, after that paragraph. This is called a 
Protective Ruler. You can change a single paragraph in this manner 
without influencing all the subsequent paragraphs. 

For a step by step illustration, use one of the sample documents 
supplied, or create your own, and do the following: 

1. Make sure the Master Ruler is showing. If it is not, then 

choose Master Ruier from the Display submenu of the 

Tools menu, or click the Show Master Ruler icon =) im the 
Vertical Scroll Bar. 

2. Click the Show Rulers icon = on the top left of the Master 
Ruler. 

3. Find a paragraph that has no ruler immediately at its 
beginning or at the beginning of the following paragraph. 
For the purposes of this illustration this should not be the 
last paragraph of the document. Remember that, when 
dealing with rulers, a blank line is also a paragraph! 

4. Place your insertion point anywhere within the paragraph. 
5. Make a ruler change. For example, drag or add a tab stop 

on the Master Ruler. Watch how two rulers are inserted, 
one at the beginning of the paragraph, the other at the 
beginning of the next one. 

6. Now, without moving the insertion point, make another 
change to the Master Ruler by moving or adding a tab. 

Notice that now no rulers were added. Any further changes to that 
paragraph do not insert rulers. 

The first ruler is inserted to impose the new format and the second 
ruler continues the format that was previously in effect. Neither ruler 
is inserted if a ruler already exists or if it is the last paragraph of the 
document. 

Using the same file, return it to its original state by choosing Undo 
twice. Place your insertion point in the first paragraph of the document 
and repeat steps 4 and 5 above. This time, because there was already 
a ruler at the top of the file, only the second ruler will be inserted. 

CHAPTER FOUR 



ad 

For the last illustration, select the ruler at the beginning of the second 
paragraph in the document (make sure the document has more than 
two paragraphs) and repeat steps 4 and 5 above. Note that this time 
no rulers were inserted. This means that the second paragraph and 
all subsequent paragraphs, up to the next ruler, are affected by the 
format change. 

i You can change the format of a paragraph ruler without having a 
new ruler inserted at the next paragraph. To do this, select the 
paragraph ruler (it should be visible) and make the changes to the 
Master Ruler as illustrated above. Alternatively, click anywhere in 
the paragraph and press Option while making the changes to the 
Master Ruler. This latter method is applicable even if paragraph rulers 
are not visible. 

ks” You can place a copy of the current ruler in front of the current 
paragraph by choosing Insert Ruler from the Format menu. 

Inserting Protective Rulers 

Quite often you want to copy a ruler format from one paragraph to 
another without affecting any other paragraphs. To do this rulers can 
be copied and pasted. Before you paste the ruler with the new format 
to your paragraph, you need to insert a “Protective Ruler” at the next 
following paragraph so that its format is not changed. Do the following: 

1. Select and copy the new ruler which you want to paste in 
front of a paragraph. 

2. Move your insertion point to the beginning of the first 
paragraph which you do not wish to be affected by the new 
ruler format. 

3. Choose Insert Ruler from the Edit menu. This inserts a 
copy of the current ruler, thus not affecting any text format. 

4. Move your insertion point to the beginning of the paragraph 
where you wish the new ruler format to apply. 

3. Paste the ruler. 
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Copying and Pasting Rulers 

When you use the Clipboard to transfer text, you must pay attention 
to rulers if you want to maintain your original text format. It is best 
to make the rulers visible when working with documents which 
contain more than one ruler. In this way, you can see whether rulers 
are being selected with the text. 

Rulers precede the paragraph where their control begins and format 
all folowing paragraphs up to the next ruler. If you select and copy 
text without its formatting ruler, and paste it in a part of the document 
with a different format, it will not retain its formatting. The pasted 
text will take on the formatting of the surrounding text. 

If you want the format of the paragraph to be preserved, include the 
ruler in the selection. When you choose Copy or Cut, only rulers in 
the current selection are copied onto the Clipboard. When you choose 
Paste, remember that the last ruler pasted will affect all paragraphs 
up to the subsequent ruler, unless you insert a protective ruler before 
the paste. Select a ruler by clicking on it. You can then cut, delete, or 
copy it. You can replace one ruler with another by selecting the 
current ruler and choosing Paste. It will be replaced by the ruler 
that was previously copied onto the Clipboard. Rulers can only be 
replaced by rulers. If you have text on the Clipboard and a ruler is 
selected when you paste, the text will be added just after the ruler—at 
the beginning of the paragraph. 

i” If you want to have several predefined ruler formats to use in your 
document, you can create a macro for each format. See Chapter 14: 
Working with Macros for more details. 

Named Rulers 

Paragraph rulers can be named. All rulers with the same name will 
share the same attributes. To name a paragraph ruler, either select it 
or place your insertion point in the paragraph and then click in the 
Ruler Name Box illustrated in Figure 4-31 the name you wish to use 
then set the ruler attributes you wish to have for that ruler. When 
you finish, press the Enter key or click the mouse back in your 
document. If you named a ruler you can find that name and select 
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that ruler from the pop-down menu by clicking on the down arrow 
to the left of the Ruler Name Box as illustrated in Figure 4-32. 

subheading 

sub sub 

Text 

Name Ruler... 

Figure 4-32 The Named Rulers Menu 

To have another paragraph share those same attributes, place your 
insertion pointer in that paragraph or select the ruler that controls it, 
click your mouse in the Ruler Name Box and type in the name of the 
desired ruler. When you press Enter or click back in the document 
window, the ruler's attributes will take effect. 

A named paragraph ruler will have a line in it while an unnamed 
paragraph ruler will be plain {23. 

Re-naming, Deleting & Finding Rulers 

The last menu command on the named rulers pop-down menu shown 
in Figure 4-32 is the Name Ruler... command. It can be used to 
rename existing rulers, to delete named rulers, and to find the next 
occurrence of a named ruler. 
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To do any one of these things choose Name Ruler,... The dialog 
illustrated in Figure 4-33 appears. 

Figure 4-33 The ruler Renaming Dialog 

The top shadowed box is a pop-down menu with all the existing 
ruler names. Click on it and the menu shows all the named rulers as 
illustrated in Figure 4-34. Select the ruler you want to rename. Its 
name is shown in this box. Type in the new name into the edit box 
shown and click (Rename). This renames all occurrences of the chosen 
ruler to the new name. 

To delete the chosen ruler click (delete |, When a named ruler is 
deleted its name is removed from the named ruler menu. Any ruler 
with that name in the document, will remain with the same attribu tes 
but will become unnamed. 

To find the next occurrence of the chosen ruler, click the {L i 
button. The next ruler with that name is selected. 

You can also bring up this dialog, with the name of the chosen ruler 
already entered, by selecting the ruler name from the named rulers 
pop-down menu Figure 4-32 while holding the Option key. 

You can quickly find the next ruler with a given name by selecting 
its name from the named rulers pop-down menu Figure 4-32 while 
holding the Shift key. 
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Figure 4-34 The ruler renaming dialog pop-down menu. 

New Name: 

is Another way to name all similar rulers that already exist is described 
in Changing Similar Rulers, page 97. Select the ruler to be named, 
type the appropriate name in the Ruler Name Box, then press the 
Command key as you press the Return or Enter key. 

iis” You can paste named rulers from one document to another. If, however, 
you have rulers in each document that share the same name, but 
have different attributes, the existing document's ruler will override 
the attributes of the ruler being pasted. 

Text Attributes 

Nisus allows a wide variety of fonts, sizes and styles. These are called 
text attributes. You can change text attributes with the Font, Size 
and $tyle menus. Attribute changes apply only to the currently 
selected text. 

If there is no selection, the changes will apply to the next text you 
type at that insertion point. New characters typed from the keyboard 
generally inherit the attributes of the character immediately preceding 
the insertion point. If you change attributes at the insertion point and 
type no text, the changes will not be recorded. 
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Font 

All available fonts are displayed in the Font menu as illustrated in 
Figure 4-35. The currently selected font is preceded by a check mark. 

The available sizes for the current font are displayed in Outline 
style in the $ize menu. Any size can be chosen, but if it does not 

exist, the closest one will be scaled to the desired size. This, however, 

causes distortion and slows down screen updating. To add additional 

fonts or sizes, use the Font/DA Mover supplied with your Macintosh 
and refer to your Macintosh Owner's Guide for instructions. 

& 

Helvetica 
Jerusslem 

London 

Mobile 
Moneco 

New York 

“Palatine 

Paregen 
Symbol 

Times 
Soakmen 

<e@pl fingbats 
StClOAnUTIC 

lursive 
Menite 
Courier 

WN Nalvetica Narra 
Rie Fant 

Figure 4-35 The Font menu 

is An open document containing fonts not in the current system will 
show their names italicized in the Font menu. You may edit with 
them, however they will display and print as Geneva in the document, 
until you add the missing fonts to your system. 

Ie” You can display the fonts you have in your system on your Font 
menu in their actual fonts, as illustrated in Figure 4-36. Press the 
Option key either before you pull down the Font menu or at any 
time while the menu is open. 
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Figure 4-36 The Font menu with the Option or Command key 
pressed 

Size 

finy Size 

increase 

Decrease 

Figure 4-37 The Size menu 

Using the $ize menu, illustrated in Figure 4-37, you can set the size 
of your text to any whole point size from 1 through 255. The text 
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size may be set to a value that is not displayed in the menu by 

choosing Other and typing the points size into the dialc< illustrated 
in Figure 4-38. In addition, Increase and Decreas- anges th: 
font size in 1 point increments. 

Enter Point Size:[109 | 

Figure 4-38 The Other size dialog 

Style 

You will find the most common styles in the Styje menu. The other 
supplied styles are available in the More Styles submenu as shown 
in Figure 4-39. 

Superscript 

Subscript 

* finy Styles 
More Styles > Cutie 
Color >| Shadow 

Condense 
Extead 

Lower Underline 

Define Style.. 

Word Underline 
Superscript 2 

Subscript 2 

Overbar 

Figure 4-39 The Style menu and More Styles submenu 

Styles can be combined. Select the text you wish to change, then 
make any number of selections from the Style menu. Some styles 

106 CHAPTER FOUR 



cannot apply to the same text at the same time. Extend and 

Condense, for example, have opposite effects and cannot be active at 
the same time. 

(a Plain cancels all other styles when applied. When particular styles 
are chosen that are not compatible with already applied styles, the 
earlier style is removed from the selected text. The most recently 
chosen style prevails. 

I= The underline styles can be combined. A double underline can be 

achieved by applying both Underline and Lower Underline. 

Word Underline removes all underlines from the white space 
between words. When you have an underline style applied, 

Underline will be checked along with any of the variations, such as 

Word Underline. If you uncheck Underline, all underline styles 
will be removed. 

Superscript and Subscript: Two Levels 

Nisus gives you two levels of the Superscript style and two levels 

of the Subscript style. These styles are particularly helpful when 
working with mathematical or scientific equations. Characters typed 
in any of these styles are automatically proportionally sized for best 
appearance. The second levels can be used with either Superscript 

or Subscript, or they may be used individually. Note that when 
Superscript 2 is checked, Superscript or Subscript is also 
checked and when Subscript 2 is checked, Subscript or 
Superscript is also checked. 

Ia Second level Superscript and Subscript are for advanced users. 
Nisus does not always update the second level of Superscript or 
Subscript on the screen immediately. Printing however, is not af- 
fected by this when using the ImageWriter or a PostScript printer. 
You can force Nisus to update the screen by clicking the zoom box. 
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Figure 4-40 First level Superscript and Subscript together 

Nisus 

Nisus 

Figure 4-41 Basic text with Superscript 2 

NisusNisusee* 

Figure 4-42 Basic text with Superscript and Superscript 2 

Nisus 

Figure 4-43 Basic text with Subscript 2 

NiSUSNisusye re 

Figure 4-44 Basic text with Subscript and Subscript 2 

NiSUS yigueNisus 

Figure 4-45 Basic text with Subscript and Superscript 2 

Nisus, News 

Figure 4-46 Basic text with Subscript 2 and Superscript 2 

Nisus \S"Snisus 
Figure 4-47 Basic text with Superscript and Subscript 2 

: Nisus 
Nisus News 

Figure 4-48 Basic text with Superscript 2 and Subscript 2 

Nisus Nisus  Nius 

Figure 4-49 Superscript, Superscript 2 and Subscript 2 
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Figure 4-50 Basic text with all levels combined in a variety of ways 

it First level Superscript and Subscript are mutually exclusive and 

cannot be applied together. You cannot superscript a subscript or 
subscript a superscript using the first level as these apply only to the 
basic text style as illustrated in Figure 4-40 . Using the second level, 
you can superscript a superscript or subscript a superscript, or sub- 
script a subscript or superscript a subscript as illustrated in Figure 
4-41 through Figure 4-50. 

Invisible 

The Invisible style allows you to place invisible notes in your 

document. When you wish to display them, choose Invisible Text 

from the Display submenu of the Tools menu. To hide the invisible 
text choose Invisible Text again. 

Color 

The Color menu offers eight colors. Color styles can be combined 
with other styles. Colors can be used to mark, search and replace 
text. On a monochrome monitor it is still possible to search for text 
formatted (though, obviously, not visible) in a particular color. Color 
text will not function on the Graphics Sheets. The Color submenu is 
shown in Figure 4-51. 
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Figure 4-51 The Style menu and Color submenu 

User Styles and Style Sheets 

A style sheet is a collection of user defined styles consisting of font, 
size, style, ruler and other possible attributes to which you give a 
name. That name appears at the end of the Style menu. You can 
create many such named styles. Once created, they can be used just 
like the regular styles to format text. 

For example, if you create a new style called Heading which combines 
the Bold and Underline with the Palatino font, a new style with 
the name Heading appears on the $tyle menu. If you then select 
some text and choose Heading, the text will become Palatino, Bold, 
Underline. If the selected text has some other style attributes which 
do not conflict with those of the Heading style, they will remain. 
Thus if the original text was in Geneva /talic, it becomes Palatino, 

You can format text in the Heading style, and later edit the user 
style. All the text in this style will automatically be changed to reflect 
the new user style. 
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Creating User Styles 

User styles in Nisus can be defined on a character level, paragraph 
level (also known as style sheets) and/or document level. Document 
level] user styles are created as Nisus Stationery files explained on 
page 64. Nisus Stationery files can contain combinations of character 
and paragraph level user styles as well. 

To create a user style on the character level, choose Define Style... 
from the Style menu. The User Style dialog is displayed as shown 
in Figure 4-52. You can set the attributes of the user style by choosing 
from the menus or by checking the check boxes in the dialog. 

You can make any character level user style a paragraph level user 
Style if you have given names to any rulers. Simply add that ruler's 
name as one of the attributes of a character level user style by typing 
its name in the Ruler Name box. You can also determine the attributes 
of the following paragraph’'s ruler by typing the name of that ruler in 
the Style of Next 9 box. 

Give the user style a name and click (tone }) The name of the 
user style appears at the bottom of the Style menu. You can now 
apply it to text just like any other style. 

Editing Style: New StyteNeme:/ 

Ruler Name: Style of Next 4: [ 

Ci Font: Cisize:[12_] Ccoior: Breck} 
Style: C) Undertine LC Superscript 

Plain Cj Lower Underline C] Subscript 

CJ @old C) Dotted Underline [) Superscript 2 
C) slate CJ Word Underline [} Subscript 2 
CJ Ontiias C] Overbar (J Table of Contents 
0D Shader Sirike through C) Index 
UC) Condensed ox [] Keep Tent On Same Page 
CjExtend Hisibie CD tgnore Spelling 

Figure 4-52 User Style dialog 
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The following sections discuss rules for applying user styles, and 
overlapping them with the standard styles. 

Applying User Styles 

To apply a user style to selected text, choose the user style from the 
Style menu. All the attributes of the user style will be applied to the 
text. When you click in a region of text which contains a user style, a 
check mark is placed by the user style menu item. 

You may overlap user styles. The attributes of user styles are added 
together, but the font and size of the last user style applied are used. 

For example, create two user styles—one that contains Underline 

and Cursive and another that contains Underline, 8B old and Venice. 
Now apply these two user styles to the same text. All the stylistic 
attributes are added together, but the text takes on the font and size 
of the last applied style. Figure 4-53 shows an example of applying 
one of these user styles to overlap another; the bold. underline 

and Venice user style is applied first and then undeviineand 
Cursive is applied. 

Spot jumped owr a Leg and caught the rabbit. 

undertine & Cursive font. bold, underline & 
‘Venice font. 

Figure 4-53 Overlapping user styles with Bold, Underline & Venice 
and Underline & Cursive attributes, respectively 

Notice that where the user styles overlap, the text is in Curoive font 
because this uscr style was applied second. 
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Changing User Styles 

To edit a user style choose the Define Style... command which 
brings up the User Style dialog. Then choose the user style name you 
wish to edit from the $tyJle menu. This action enters the name into 
the dialog allowing you to edit the style. 

Edit the name of the style. Click to save your changes. 

will ignore any changes you have made to the style. 

iG? For a quicker way to edit a user style: hold down the Option key 
while choosing the user style name from the Style menu. The user 
style editing dialog opens with the user style entered, ready for editing. 
This only works with user styles which are used in the active window. 

The ability to change a user style is a very powerful feature. It allows 
you to select certain parts of the document, set them in a user style 
and be able to change the appearance of that text instantly. Changing 
a user Style only affects the attributes that are specifically linked to 
that user style. For example, to make the following text: 

The dog was scared by the iguana. 

stand out, a user style that contains bold, New York, and size I 4 

1s applied: 

The dog was scared by the iguana. 

To make dog and iguana stand out even more, one word is italicized 
and the other underlined by adding these attributes directly, not 
using user styles. 

The dog was scared by the iguana. 

This text is now bold, New York and size 14, but in order to make it 
even more prominent, outline and Venice 14 are applied by editing 
the user style, giving this final result: 
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dog wes scared by the iguana. 

Notice that when the user style was edited from bold to outline the 
italicized and underlined text was untouched. Ali style attributes not 
associated with the user style are not changed. 

its Changes made to a user style cannot be undone using the Undo 
command. Edit the style again to undo any changes you make. 

Ir You can use User Styles to make multiple tables of contents and 
indexes. The details on how to accomplish this are explained on page 
320. 

Removing User Styles 

To remove a user style from text: 

1. Select the text 
2. Choose the checked user style from the $tyle menu. 

If some of the text you select is not in the user style, then the menu 
item will not be checked. In this case, choose it twice to remove it. 
The first time, the whole selection is put into the style; the second 
time, the style is removed from the selection. Built-in styles perform 
in a similar manner. 

If a selection contains styles that are not in the user style these will 
not be affected when you remove the user style. For example, if a 
user Style that contains Underline is applied to the following text: 

New York is in New York. 

it becomes 

New York is in New York. 

114 CHAPTER FOUR 



When the user style is removed from “is in New York”, the resulting 
text becomes: 

New York is in New York. 

Notice how the second “New York ” is still italicized. Removing a user 
style only removes the attributes associated with that user style. An 
exception to the rule occurs when another user style exists in the 
selection with the same attributes; in this case, whichever attributes 

exist in the other style will be preserved. 

Font and size are handled a little bit differently. If you remove a uscr 
Style that contains a font or size, then the text will return to the font 
and size which was in effect before the user style was applied. 

Deleting User Styles from a Document 

To delete user styles: 

1. Choose Define Style.... This brings up the User Style 
editing dialog. 

2. Choose the style you wish to delete from the Style menu. 

3. Click the button in the User Style dialog. 

This brings up a dialog as in Figure 4-54 which asks if you wish to 
remove all attributes of the deleted user style from the text in your 

. 4 Y ‘ 
document. Click or press Return to remove all attributes 

associated with the user style from the text and the user style name 
from the document. Clicking will leave remove the user 

style name from the document while leaving all text attributes 
unchanged. 
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: Remove all attributes of 
*Y this style from the text in 

your document? 

se) * 

Figure 4-54 You are also asked whether to remove the effect of the 
user Style in the document after removing user style 

Importing User Styles 

User styles are specific to each document, but you may import user 
styles that have been created in other documents. The style name 
will show up at the bottom of the Style menu preceded by the 
document name if that document is open and is not the top window. 
To import the user style, select the text you want to apply the user 
style to and choose the user style: it will automatically be applied 
and imported into the style list of the current document. Remember 
that each document has its own list of user styles, so when you 
import another user style it is actually copied into the Style list of the 
current document. 

If you copy some text that contains one or more user styles and then 
paste that text into another document, the text will retain those user 
styles. All the user styles that are associated with the text will be 
imported into the new document. The only requirement is that the 
original window must be open during the paste. If the original window 
is closed, the pasted text will retain its attributes, but it will lose any 
associations with user styles. 

If a user style with the same name already exists in the new window 
but has different attributes the dialog shown in Figure 4-55 appears. 
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User Style Conflict 

The user styie “Reference Header” canflicts 

with an existing style that has the same 
name. 

%1 @ Rename the user style and import it with 
the tent. 

bmport As: |ilTaruraeo ioe | 

%2 © Use the user style which is already in the 

document. 

%3 COtransfer the text oad attributes without 

the user style. 

| ox | . y; 

Figure 4-55 User Style Conflict dialog 

You then have the following options: 

e Rename the user style and import it with the text. 
« Use the user style that is already in the document. 
¢ Paste the text and its attributes without the user style. 

If you rename the user style, it will be imported with the new name. 

If you use the user style that is already in the document, the text will 
take on the attributes of that user style. The original user style will 
not be imported. If you paste the text without the user style, it will 
retain its attributes, but the user style will not be imported. 

User Styles as Invisible Notes 

By creating a special user style called, for example, Memo, which 
includes the Invisible style, you can make invisible notes within a 

document. They can be made visible by choosing Invisible Text 
from the Display submenu of the Tools menu. They can also be 
made visible by editing the Memo style and removing the invisibic 

attribute. If, in addition, you use a special style for the Memo style, 

such as SHAGOM or OutliMe, which stands out from the 
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surrounding text, the notes will be easy to see when they are made 
visible. When you want to hide them again, simply edit the Memo 
user style to include the invisit.:. attribute. 

In Figure 4-56 the notes appe: — adowed when they are made visible. 
This ts because the user stvi- used to create them had both the 
Sl @@@OW and Invisible attribute. 

rs” You may also use the Invisible style alone, but by using a user 
style with the invisible attribute you have more control. 

Ee User Style Notes Example Previow (eee 
-) Ima1 &) 11.0007 8.500" 10.777" 8.000° 
i fat Bou Gicae: a s 

250 

The coldest winters in the world occur in the | 
boreal forests of Siberia. Coniferous forests 
include the tallest trees in the world end 
support the highest standing biomesses of 
brood of all ecological communities. 

Saks eikw aff Gc Gerrans 
Whatever their climates, boreal forests are 
cheracterized by having a small number of 
pornmon tree species. 

24 IDS 

iehabeasbas wie dee Tevseree 

| 
' 
if 

Deciduous Forest 
Soy ef areas fram Who ground), tnsiving | 
ap @uendl Gas hatthent sam 
he deciduous forest is known for its strong | 
seasonal fuctustions of temperature end ampl 

pitation thet is fairly evenly distributed 
hout the year. trees produce | 
well edapted for rapid photosynthesis | [IN 

Huring the werm, moist summers and 
plominate these environments. 

Gresaland i 
Eveuned ww 08 ho (gens Tiong fm hs | 

Gresslends are common where potential | 

| 

! 

eed 

i) 

— ew eee 
ry —"s 

A ee ee 

‘ q -: 

etels ete ee 

wvaporation exceeds precipitation. 

ress] ds are structurelly sim 
bhey are dominated by nor 

becaise 
plants that 

Figure 4-56 Example using Memo user style to position photographs 

se In addition to their standard function as a tool for formatting 
documents, Nisus user styles can be used to prevent text in unusual 
fonts from being flagged by the Spelling Checker, and develop multiple 
tables of contents and indexes of the same document. 
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Editing Tools 

Display White Space 

Sometimes it is desirable to see spaces, tabs and return characters 
within the document. These are called white space characters, Nisus 
displays them as symbols as shown in Figure 4-57. This feature is 

accessed by choosing $pace, Tab & 4 from the Display submenu 

of the Tools menu. 

Space 
Tab 

Paragraph 

“ 
q| 

¢ Line Feed 

4 Forced Page Break 

Figure 4-57 White space symbols 

The Edit menu has many commands which directly affect selected 
text. 

Changing Case 

¢ To change all letters to uppercase choose UPPERCASE 
¢ To change all letters to lowercase choose lowercase 
¢ To reverse the case of all letters press the Shift key and 

choose Toggle Case 

¢ To capitalize all words in a selection choose Capitalize 

I Text must be selected when you choose one of these commands, 
otherwise they will not be enabled. This is a change from previous 
versions of Nisus. 
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Move Text Horizontally 

Groups of paragraphs can be moved horizontally. Select the 
paragraphs to be moved. Choose Move Right or Move Left from 
the Edit menu. This will insert or delete one tab in front of each 
paragraph automatically. This is useful when lining up columns with 
other text. Each time the selected paragraphs are moved, they move 
to the next tab stop. 

is” Press Shift while choosing Move Right or Move Left to move the 
paragraphs by inserting spaces, rather than tabs. 

sort Paragraphs 

Nisus lets you arrange paragraphs in alphabetical or numerical order. 
When you choose the Sort 4 command the current text selection 
will be sorted. You may sort a list of names by doing the followin g: 

1. Type one name per paragraph. 
2. Select the group of paragraphs containing the names. 
3. Choose Sort 4 from the Edit menu. 

The paragraphs will be rearranged so that the names are in alphabetical 
order. Use the same procedure to sort a list of numbers. 

Any selection containing partial paragraphs will be extended to include 
the entire paragraph. Remember that paragraphs end with a return 
character. This is important, because the comparisons during sorting 
Start at the beginning of paragraphs. If you want to sort the lines of a 
paragraph as they are wrapped on the screen, choose Break Lines 
first. 

If you have a list of names and addresses with each field on a different 
line, you can still sort so that only the names are alphabetized, and 
the addresses stay with the names. Instead of typing a return at the 
end of each line enter a new line character (by pressing the Shift then 
typing the Enter key) as illustrated in Figure 4-58. (In order to affect 
this sort a return character has to be at the top of the list.) 
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Figure 4-58 Sorting Sara a New Line Characters 

If the selection contains a mixture of numeric and alphabetic 
paragraphs then the two groups will be separated by the sort. 
Regardless of whether an alphabetic or an numeric character appears 
first in the selection, the sort will be done with the alphabetic entries 
appearing first and the numeric entries being displayed last. 

ts An ASCII sort can be forced by pressing the Option key and choosing 
ASCII Sort. This sorts characters by their ASCII values not their 
alphabetical positions An ASCH sort will force the numeric paragraphs 
to appear at the top of the list. For example, the alphabetic sort 
recognizes characters like a to be before b in the alphabet while the 
ASCII sort does not. 4 is 8C while b is 42 (ASCII numbering sequence 
is 00, 02, 03, 04, 05, 06, 07, 08, 09, OA, OB, OC, OD, OF, OF, 10- 1F, 20 
- 2F, 30 - 3F, 40 - 4F, etc.) The ASCII sort also puts all uppercase 
characters before any lowercase characters. The ASCII sort is noticeably 
faster than the alphabetic sort when applied to a large selection area. 
If you press both the Shift and the Option keys while choosing Sort 
{| the command changes to ASCII + spaces. This means that the 
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paragraphs will be sorted by their ASCII code value while ignoring 
any “leading” spaces in front of them. 

its” You can see the ASCII value of any character by checking the ASCII 
Table (choose ASCII Table from the Edit Tools submenu of the 
Tools menu). Typing a key while the ASCII table is active selects 
that character, showing you its ASCII code. You can also check the 
ASCII value of any particular character by selecting it and running 
the macro Find ASCti Code which is in the Macros for Editing 
file. For more information on ASCII and how the ASCII Table works 
see The ASCII Table page 329. 

ts” A numeric paragraph is one beginning with a digit. All other 
paragraphs are alphabetic. 

Break Wrapped Lines 

The Break Lines command places a return character 9 at the end 
of each wrapped line. A return character defines a paragraph and so 
each line becomes a separate paragraph, this is especially useful when 
transmitting Electronic Mail. You can break the lines of a paragraph 
Into separate paragraphs. Do this by choosing the Break Lines 
command from the Edit menu. 

You can also use Break Lines to insert a blank line after every 
paragraph (before breaking lines) in the selection. Do this by pressing 
Shift while choosing Break Lines. The command name changes to 
Break Lines +. 

Gremlins 

Characters that are produced using the Control or Option keys are 
called “gremlins” in Nisus. If you import text from another operating 
system you may see some “garbage” characters when you edit the 
text on the Macintosh. These extra characters that are not a part of 
the text are called gremlins. 
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Gremlins are usually displayed as U) which is the symbol for a non- 
displayable character. To remove gremlins, first select the region of 

text and then choose Zap Gremlins from the Edit menu. 

Some gremlins are both visible and useful, such as the bullet * which 
is created by pressing the Option and the 8 while the Option key is 
still depressed. Many other option characters exist as an extension of 
the standard ASCII character set. Another helpful character that is 
considered a gremlin is the character produced when you insert a 
page break. This is the form feed character that can also be produced 
from the keyboard by pressing Control-L on the Mac SE and Mac II. 
Remember that Zap Gremiins will also remove these useful 
characters. It is therefore best to Zap Gremlins before you begin 
working with your document, immediately after you import it from 
another system. 

(= Note that by using pattern matching with PowerSearch and macros 

you can write your own Zap Gremlins macro which will zap only 

specified characters. 

i Gremlins are defined as any character whose ASCII code ranges are : 
0-8, 10-12, 14-31, 127-255. In Helvetica font, Gremlin characters 

are: AACENOUAaaaaaCEds GiiTiNd O656ULEUT°CLS§-YBOO™ “4/EDoot 
<2¥pd Din)’ Qeee 3 jv f=A«»... AAOCEa—"" OY 

Using Variables 

Nisus provides variables whose values are automatically updated. 
You can place date or time variables in your document that can be 
updated on command. You can also insert cross references to other 
parts of a document, such as figure numbers or chapter titles. These 
are also updated on command. 
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Date: B/1/% 
Time: 4:01 PMi 
Document Name:Chapter 5 Working with Text 
Current page number{l52 
Cross Reference: See Figure 5-26 on pageil53} 

Figure 4-59 Highlighted variables in text 

The variables that are available in Nisus are illustrated in Figure 
4-59. 

Variables appear as normal text. Unless they are highlighted, they 
cannot be distinguished from the surrounding text just by looking at 
them. You can highlight all the variables in your document by choosing 
the Text Hilites command from the Display submenu of the Tools 
menu. Your variables will then be boxed in dotted lines. Although 
text placed in the index or in the contents is not a variable, it also 
appears in a dotted box when Text Hilites is checked. 

The page number variable is especially helpful when placed in a 
header or footer. This will number every page on which the header 
or footer lies. For more information on page numbering, see Page 
Numbering, page 168. 

To place a variable in your text, choose the variable you want to 
insert from the Format menu. The variable will take on the attributes 
of the surrounding text. To select a variable, click on it, then you can 
change its attributes just like those of any other character. To change 
the display format for variables, use the Set Date & Page# 
Formats command from the Format menu. See also Variable Format 
Preferences, page 462,in Chapter 15 Customizing Nisus. 

The date and time variables are not kept current. To update them 
choose Update Time & Date from the Format menu. You may 
also choose to have them updated automatically every time you print 
(there are appropriate check boxes in the Print dialog). If you do not 
have them updated when you print, you can use the date and time 
as time-stamps because they will retain the time when they were 
inserted. 
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i If you insert a new time or date this will automatically update the 
existing times and dates in the document. To insert a time stamp that 

will not update use the supplied macro Time Stamp. 

Jump 

Nisus provides other ways besides using scroll bars for you to move 
around within your document. Nisus allows you to specify any page 
or line number and jump to it. 

To jump to a specific page, choose Page... from the Jump To 
submenu of the Tools menu. The dialog illustrated in Figure 4-60 
appears. 

*P @ Pege 
Jump to XL O Line Columa(t | 

%*MQ Marker 

x. (Genes) 
Figure 4-60 The Jump dialog when choosing Page... 

When you press Return or click the uum | button, you will jump 
to the end of your document. Otherwise, type the page number you 

{ Jump _} button. This want to jump to and press Retum or click the 
will bring you to the beginning of that page. 

To jump to a specific line number counted from the beginning of the 
file, choose Line... from the Jump To submenu. Then type the line 

ae | 
number and press Retum or click Lump J. 

i Note that when using Line..., the line numbers are always counted 
from the beginning of the document, never from the beginning of the 

page. The setting of the Line * Prefs... {in the Display submenu 
of the Tools menu) has no effect on this feature. 
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You may also jump to any marked position in your text, both in the 
current window or in other open windows when you choose Line... 
or Page... from the Jump To submenu and clicking the Marker 
button and typing the marker name. You can also jump to any marked 
position simply by choosing that marker name when it appears at 
the bottom of the Jump To submenu. 

Working with Markers 

Think of markers as electronic bookmarks. You can use them to return 
instantly to exact places in your document. Markers can also be used 
to cross-reference different locations and text in your document. 

You can mark both a location (insertion point) and a selection of text. 
When a text selection is marked, the start and end positions of the 
text selection are marked. When an insertion point position is marked, 
the start and end positions are the same. When you mark a selection 
of text and then delete the text, the start and end positions merge 
and a marked insertion point is left behind. 

setting Markers 

1. Place the insertion point at the position you wish to mark or 
select the text you wish to mark. 

2. Choose Mark Text... from the Tools menu. If you made 
a selection, the first word will appear as the default marker 
name. You can use this name or type a different name for 
the marker. 

3. Click [ Sel 

This will place a marker at the insertion point and add the marker 
name to the Jump To submenu of the Tools menu. If there is a 
selection at the time you place the marker, the whole selection will 
be marked. When you choose a marker name from the Jump To 
submenu of the Tools menu the insertion point will jump to the 
marked location; if a selection of text was marked, the marked text 
will be selected. 
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tte If you click ( set } with no marker name or the name NIL, the 

special marker NIL will be set. The Command key equivalent 38° 
(grave accent) will be automatically assigned. Whenever you jump to 
this marker, the current insertion point will be exchanged with the 

NIL marker. If you repeatedly jump to the NIL marker, you will be 
Jumping back and forth between the two locations. You may set one 
NIL marker per file, and you cannot jump to the NIL marker of 
another document. 

Jumping to Markers 

To jump to a marked position in any open file, choose the marker 

name from the Jump To submenu of the Tools menu. You can also 

choose Line... or Page... from the Jump To submenu of the Tools 
menu and type the marker name. When you press Return, Nisus will 
jump to that marker, selecting any marked text. By jumping to a 
marker, you can tell whether a selection of text or just the position 
was marked. 

The marker names in all open windows are displayed in the Jump 

To submenu of the Tools menu. The markers of the top window are 
placed first, followed by the markers for the other open windows 
which are preceded by the names of the files. The only NIL marker 
shown is the one for the front window. For instructions on how to 
jump to text where a particular header or footer is defined see page 
156. 

Moving and Deleting Markers 

You can set any number of markers in your document. To move a 
marker, just set a marker with the same name at the new location. 

When the Mark Text... dialog is active, you can choose markers 

from the Jump To submenu of the Tools menu to place their names 
in the dialog instead of typing them. 
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To delete a marker, choose Mark Tent... from the Tools menu. 
Choose the marker you wish to delete from the Jump To submenu 

of the Tools menu, or type its name, then click 

its" You may also delete a marker by holding Option while selecting it 
from the Jump To submenu of the Tools menu. 

is Note that inserting and deleting markers does not alter the text and 
so cannot be undone using the Undo feature. 

Editing Marked Text 

When you add new text between the first and last characters of marked 
text, the added text is included as part of the marked text. Anything 
you type after the last marked character is not part of the marked 
text. If you want to extend the marked text at its end, type just before 
the last character, then delete the last character. For example, assume 
that the word plant is marked in the following text: 

Weeding plant rows... 

The word plant should have been planted, so to extend it: 

1. Place the insertion point before the ¢ in plant 
2. Type “ted” 
3. Delete the last t in plantedt 

ix” If you delete the marked text in the document, the marker will not be 
deleted. It will stay with the first remaining character preceding its 
previous position. For example, if you mark the word fountain in the 
portion of text The crystal fountain flows... and then delete the words 
crystal fountain that marker will appear to the right of the space 
following the word The. 
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Cross Referencing 

When you want to refer to a particular page, line or paragraph you 
actually cross reference markers. This means that you must mark the 
text you wish to cross reference before you insert a cross reference 
variable. 

Cross Referencing Markers 

Markers can be referenced from other parts of your document. As 
illustrated in Figure 4-61 you can cross reference to: 

e Page number of the marker location 
e Line number from the top of the document 
e Line number from the top of the page 
e Paragraph number from the top of the page 
e Marked text (including footnotes as explained, page 157). 

Cross-Reference To: Display as: 

Appendix | K © Page # 
attributes © Line # 
Character Graphic ae © Page Line # 

Close BE © Paragraph # 
Customizing a @© Marked Text 
Cutting and Copying fin K) Use Surrounding Styse 
Desktop Publishing and #& 
Dictionaries Preference cy 

Figure 4-61 Inserting a cross reference marker or variable 

As you change your document, markers will move with the text. The 
cross reference will then reflect the new marker position. Similarly, 
cross referenced text will display the actual marked text. If the text is 
changed later, the cross referenced text will only be updated when 

you choose Update H-Reference from the Tools menu. See Editing 
Marked Text, page 128 in this chapter. 
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If you attempt to delete a marker that has been cross referenced (by 
pressing the Option key as you choose the marker name from the 
Jump To submenu of Tools menu), the dialog illustrated in Figure 
4-62 will warn you. If you go ahead and delete it anyway, the cross 
references to that marker will become invalid. 

This marker has been 

cross-referenced. You will jose 

all cross-references to this 

marker. YOU CANNOT UNDO THES. 

Are you sure you want to delete 
the marker? 

Figure 4-62 The Delete Cross Referenced Marker Dialog 

Cross referencing allows you to maintain accurate references to other 
parts of your document. Use cross-referencing to refer to: 

Section names that may change 
Page numbers of text containing specific subject matter 
Figure names and numbers that may change 
The line number of marked text 
The paragraph number of marked text 

As the text moves, any reference to its page number, paragraph number 
or line number will change to reflect its new position. 

Cross referencing the actual marked text is useful when you want to 
quote some text from another part of the document. For example, 
you can refer to figures by cross-referencing their titles. To do this 
mark the caption text “Figure 21-7" below the figure. Then choose 
Cross Reference... from the Tools menu and cross reference the 
marker text in the place where you wish to refer to Figure 21-7. If the 
text, using the cross reference, was: 

See Figure 21-7 on page 40 for an example of ... 

then the correct page number and figure name displayed at each 
reference could be easily updated even if the figure number or position 

130 CHAPTER FOUR 



in the document changed. (The cross references are shown in bold in 
the above example for illustration purposes. Normally, they will match 
the surrounding text.) 

If the figure name or number is changed you will have to choose 

Update H-Reference from the Tools menu so that the new name 

will be displayed. When a document is ready to be printed, you can 
have the cross references updated before printing by clicking the 
appropriate buttons in the Print dialog. 

1. Mark the text to be cross referenced (a figure number or any 
other text). 

2. Place your insertion point where you want the cross reference 
to appear. 

3. Choose Cross Reference... from the Tools menu. 
4. Select the marker name you wish to have cross referenced, 

click the desired Display as: option and click 0k J. 

Is” If you enter a cross reference to marked text and do not choose the 
option Use Surrounding Style the text of the marker will be 
entered into your document as it appears where it was marked (that 
is with all the font size and style attributes). You can change the 
attributes of that text, but, if you later choose Update H-Reference, 

the cross reference text will revert back to the attributes of the text as 
it was where it was marked. 

Cross Reference Variables 

Cross references are treated as variables. When you choose the Cross 

Reference... command from the Tools menu you get a dialog as 
shown in Figure 4-61, on page 129 which lists all the current marker 
names. You can then choose a marker and using the buttons on the 
right, choose which cross reference to use. 
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You can then choose to display at the insertion point one of the 
following references: 

¢ The page number of the marker: Page *. 
¢ The line number of the marker (from the beginning of the 

document): Line *. 
¢ The line number from the beginning of the marker’s page: 

Page Line #. 
e The paragraph number on marker’s page: Paragraph #*. 

« The marked text itself: Marked Text. 

You can combine these items by making multiple references to the 
marker. To get a format like “See Figure 4.5 on page 201”: 

1. Mark the text “Figure 4. 5” if it is not already marked. 
2. Type See. 
3. Insert a reference to the marker's text as explained above. 
4. Type “on page ” (space before and after). 
5. Insert a page number reference to the marker. 

If you cross reference marked text, the text will normally be inserted 
with the same attributes as it had when it was marked. You may 
have these attributes ignored, however, by checking Use 
Surrounding Style. The text will then take on the attributes of the 
text immediately preceding the cross reference variable. 

is" You can use your arrow keys to navigate in the Cross Reference 
dialog. 

Copying and Pasting Markers 

You can copy and paste markers from one document to another with 
three possible outcomes. 

If you copy the marker and the cross referenced text and paste them 
both in second file where there are no matching marker names, the 
cross references will appear as they did in the original file. 
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If you copy the marker and the cross referenced text and paste them 
both into a second file where there are matching marker names, the 
pasted marker will override the one of the same name in the “receiving” 
document. 

If you copy the cross-reference without the marked text and pasting 
that text in another document, this will result in invalid cross 
references. When cross references are updated, you will find 
## MISSING MARKER: marker name## in all places where a missing 
marker was referenced (marker name will be the name of the missing 
marker). Invalid cross references to page, line or paragraph numbers 
will appear as number signs ####. You may create a marker with 
the name of the missing marker and the invalid cross-reference will 
be restored the next time it is updated. 

Document Layout 

The features covered here are: 

¢ Page Setup 
e Headers and Footers 

° Footnotes 

« Page Numbering 
¢ Line Numbering 

Page Setup 

When you create a new document, it is a good idea to set the paper 
size and orientation immediately if these are non-standard. This way 
you will be able to see your document as it will be printed while it is 
still on the screen. The positions of the margins influence the line 
length and therefore the length of the document. 

Choose Page Setup... from the File menu to set the page size and 
orientation. The dialog that appears will depend on the printer you 
use. Each printer offers different options as illustrated in Figure 4-63 
and Figure 4-64. 
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The options set in this dialog affect the entire document. 

LaserWriter Page Setup 

Paper: @ US Letter OA4 Letter 
© B65 Letter © US Legal 

Reduce or 
Enlarge: [100 fee 

Orientation 

Start page #: (1 | 

Footnotes/Endnotes... 

© Tabloid 

Printer Effects: 

C) Font Substitution? 

Gj Text Smoothing? 

J Graphics Smoothing? 

i) Faster Bitmap Printing? 

DJ Custom Paper: 

Size: Wiath (6.000 | inches 

Height inches 
Position: @© Center 

© Upper Right Corner 

Gd Print Cropping Marks 

Figure 4-63 The LaserWriter Page Setup Dialog 

imageWriter 

Paper: ~ @US Letter = 

© US Legal 
© Computer Paper 

Orientation Special Effects: 

Start page #: fi] 

Footnotes/Endnotes... 

On4 Letter 
© International Fanfold 

[_] Tall Adjusted 

[}50 % Reduction 
CL] No Gaps Between Pages 

{)] Custom Paper: 

size: Width [6.oco | inches 
Height inches 

Position: © Center 

© Upper Right Corner 

Print Cropping Marks 

Figure 4-64 The ImageWriter Page Setup Dialog 
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Paper Size 

US Letter is standard 84 by 11 paper. Select the size you want if it is 

listed. If you need another size, click Custom. Then type the size of 

your paper. You may have a custom page centered within the US$ 
Letter page boundanies or placed in the upper nght corner. 

(se You cannot enter a paper size that is larger that the paper your 
printer will accept. 

If you are printing on paper which is larger than the page size you 
specify, cropping marks will help you align the pages later. 

i= To get the largest possible printing area on 84 by 11 paper: 

1. Choose Page Setup.... 

2. Click on the button. 

3. Check the box Larger Print Area (Fewer 
Downloadable Fonts). 

4. Choose Layout Page... or click on the Layout Page icon. 

5. Choose Expand or click on the Expand Margins icon. 

Paper Orientation 

Set the orientation to portrait EL£4) or landscape by clicking 
the appropriate icon. This will affect the way two-up printing works, 
as described in Layout Page... and Printing. If you select landscape 
printing, Nisus will rotate your document 90° when printing, but 
paper feeding remains standard. 

Layout Page... 

The Layout Page... command in the File menu allows you to 
view a whole page ona small scale so that it fits on a small screen 
and you can get an idea of how it will look when it is printed. 
Layout Page... views the current page in your document. You 
may also use Layout Page... at any time to do the following: 
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Change margin limits 
Change columns and/or gutters 
Add and change page frames 
Set pages to be single-sided, doub]:-sided, or two-up 
View facing pages (mirrored horiz: ntally or vertically and/or 
centered vertically or horizontall:: 
Set Two-Up Printing (for brochure iayouts) 

The changes you make in the Layout window affect the entire 
document. When you choose Layout Page... or click the Layout 
Page... icon |i] in the scroll bar of the document window, the Layout 
menu, illustrated in Figure 4-65, will appear at the right of the menu 
bar. 

Layout 

Center 

Expand 

Set Margins... 

Set Options... 
Set Frame... 

Set Columns... 

Figure 4-65 The Layout menu 

The Layout window gives you a full page overview of how your 
document will look when it is printed. When a document is closed, 
its corresponding Layout window closes automatically. Because 
Layout windows are resizable, the page picture displayed changes 
its scaling as the window size changes. On large screens you can 
zoom the Layout window to see the full size of the displayed page. 

The Layout window has an intuitive user interface. By clicking and 
dragging the mouse you can change the margin limits, move the 
printing region on the page, view two pages side by side, mirror the 
margins horizontally or vertically, or center the margins horizontally 
or vertically. Furthermore, if you set the pages to facing pages you 
can move the odd or even pages independently while pressing the 
Shift key in order to adjust the gutter (the space between the two 
pages). The Layout window is modeless. This means you can leave 
the Layout window open while editing the document. The Layout 
window is updated as you type. Figure 4-66 shows the Layout window 
of a sample document. 
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z The Nisus™ Way Layout 

2 EE aches 
Ot 27% §]0.750" (49.500" 

Figure 4-66 Layout window 

When you are in ...Layout the printing region of your text is bordered 
by a dotted rectangle defining the margin limits. Most printers do not 
print to the very edges of the paper. The edges of the maximum 
printing region are called the printer limits. You can have the margin 
limits set all the way up to the printer limits. When the margin limits 
are fully expanded, it is not possible to move the printing region. If 
the margin limits are set inside the printer limits, you have the freedom 
of moving the text around on the page. Figure 4-67 shows a diagram 
labeling these terms. 

Printer Limits 

Page Size 

Margin Limits 

Figure 4-67 Single-sided page elements 
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The icons above the vertical scroll bar in the Layout window perform 
the following functions: 

cies Show Layout Info Bar icon 
Click this icon to show and hide the Layout Info Bar. 

Ql] stieas Magnifying Glass icon 
Click this icon. The pointer changes into a magnifying glass 
when it is moved over the printing region. Move the 
magnifying glass to the part of the page you want to view 
and click. The document window is activated and that part 
of the page is scrolled into view. Alternatively, you can achieve 
the same result without clicking the magnifying glass by 
double-clicking at the same position in the preview window. 

aa Document icon 

Click this icon to activate the document window and the 
insertion point position is scrolled into view. 

—....... Side by Side icon 
Click this icon to tile the document and the preview window 
side by side. 

Margin Limits 

Pages have four margin limits: 

Cltop Li] bottom 
K right bliett 

In Nisus the margin limits are set for the whole document when in 
the Layout window. These must not be confused with the actual 
margins, which are set using the rulers and which can be different 
for each paragraph, but can never overrule the margin limits. The 
exact positions of the margin limits are shown in the Layout Info bar. 
See Figure 4-68. These values are updated as you change them. 
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Two Up 
Facing Pages 

Normal! 

Figure 4-68 The Layout Info Bar 

Paper height and width, and text height and width are also displayed 
in the Layout Info Bar: 

(zl Paper height c Paper width 

[) Text height b4 Text width 

Text height = Paper height - (Top margin + Bottom margin) 

Text width = Paper width - (Left margin + Right margin) 

Paper height and width are defined in the Page Setup... dialog. 

Click the Center Page icon or choose Center Page from the 

Layout menu, so that the left, en top and bottom margin limits 
have equal distances from the page ed ges. 

|, or choose Expand Margins 

from the Layout menu so that all four margin limits and the text 
move out to the printer limits. 

Click the Expand Margins icon | 

is If you hold down Command while clicking Expand Margins icon the 
text does not move along with the margin limits. 

The Page Setup and Print icons can be used in place of the 
corresponding menu commands in the File menu. When you choose 
a different print driver from the Chooser and then click {__ K 
in the Page Setup dialog, the Print icon changes into that driver icon. 
The Print icon shown above displays the LaserWriter icon. 
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Setting the Margin Limits Visually 

The margin limits are displayed as dotted lines surrounding the 
printing region. When you move the pointer over the dotted edges of 
the printing region, the pointer changes shape. Over the top and the 
bottom margins the pointer changes into =, and over the left and 
the right margins it becomes 4P. These icons are called the resizing 
tools. When the pointer changes into a resizing tool, you can click 
and drag the margin limits to change them. 

ite” If you move the margin limits without holding the Command key 
the paragraph indents move with them. If you press Command and 
drag the margin limits beyond the paragraph indents, the paragraph 
indents will be moved in with them; otherwise, they will not be 
affected. This is illustrated in Figure 4-69. 
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Figure 4-69 A) Document preview B) Document Preview after moving 
the right margin without holding Command. C) Document preview 

after moving the right margin while holding Command 

Setting Margin Limits, Columns, and Gutter Precisely 

Double-click anywhere inside the Layout Info Bar or choose Set 
Margins... from the Layout menu to type in the values of the 
margin limits, number of columns, or column gutter. You will see 
the dialog shown in Figure 4-70. 
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Set Margins ond Columns 

(Top/Left Page) 

Figure 4-70 The Set Margins... dialog 

For precise measurements type the values of the margins into this 
dialog, rather than using the Layout visual graphic interface. 

Page Layout 

single-Sided Pages 

If you want to reproduce your document on one side of the paper 
click the Normal Page icon The margin limits of even and odd 
pages will be identical. If you have set the orientation to landscape 
mode in the Page Setup... dialog, the Normal page icon changes 
into The Layout window shows a scaled version of the printing 
region surrounded by the margin limits. If you click anywhere inside 
the printing region it becomes highlighted. As you click and drag it, 
the values of the margin limits are automatically updated in the 
information bar. 
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Facing Pages 

If you want to reproduce your document on both sides of the paper, 

click the Facing Pages icon fe (portrait mode) in the Layout 

information bar. Nisus displays two pages at a time in the Layout 
window. If you have set the orientation to landscape mode the Facing 

Pages icon becomes (zi. Facing pages have four margin limits: top, 

bottom, inside, and outside. In portrait mode, the page on the left is 

the even page, and that on the right is the odd page. In landscape 
mode, the top page is the even page, and the bottom page is the odd 
one. The inside margins also account for the gutter margins (the 
binding area). In Nisus you only specify the margins of the even 
page (left/top page). Nisus then calculates the margin limits of the 
odd page based on what options you have set in the Layout Options 
dialog (see Layout Options, page 146). Figure 4-71 shows facing pages. 
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Figure 4-71 Facing Pages diagram 
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Two-Up Pages 

If you want to reproduce your document so that two pages are printed 

on one side of paper, click the Two-Up icon (portrait mode). 

This layout is ideal for making brochures or pamphlets. If the page 

orientation is set to landscape mode, the Two-Up icon becomes 

If you want to print double-sided documents click Odd Pages in 
the Print dialog then put the paper back in the paper tray and click 

Even Pages. When you are through printing, fold the sheets in half 
and staple them in the middle. This produces a complete booklet. 

You can use this printing technique in conjunction with both portrait 
and landscape printing. Landscape mode prints booklets or pamphlets 
whose pages turn from right to left. Portrait mode prints booklets in 
which pages flip from bottom to top. Figure 4-72 illustrates the pages 
that are printed together on a single sheet of paper. The orientation 
shown is for landscape printing, but the pages are grouped in a 
similar way when in portrait mode. 

Figure 4-72 Layout of 4 and 8-page booklets produced in Landscape 
mode 
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The two-up printed output is different than what is displayed in the 
Layout window. Even if pages 2 and 3 are displayed as if they are on 
the same sheet in the Layout window, they will not be so when 
printed. Because each double sided sheet represents 4 pages of two-up 
output, a document will always be a multiple of 4 pares when printed 
in this layout. The numbering scheme for two-i::: pages is best 
illustrated with an example. For a document with 4 c: 8 pages it is as 
shown in Figure 4-72. 

Mirror Image Pages 

If you want to reproduce your document so that the printing region 
locations on the pages are mirror imaged as in Figure 4-73, click the 
Facing Pages icon or the Two-Up icon. Set the margins of the left/ top 
page. Check the Margin Mirrored Horizontally (or vertically) 
option in the Set Options... dialog. 

Figure 4-73 Mirror image Pages 

As you drag the edges of the printing region, both the inside and the 
outside margins are mirrored horizontally. This means that the left 
margin of the even page is equal to the right margin of the odd page, 
and the right margin of the even page is equal to the left margin of 
the odd page, as illustrated in Figure 4-74. 
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Repeated Pages 

Repeated pages are produced when the printing region of the left 
pages are identical to those of the right pages as in Figure 4-75. 

Figure 4-75 Repeated Pages 

In Nisus the inside margins include the gutter margins. To produce 
repeated pages with gutters, the left margin of the odd page must 
equal the left margin of the even page plus the gutter margin. Create 
mirror image pages as explained in the previous section. Hold Shift 
while you click and drag the left page in the Layout window as 
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illustrated in Figure 4-76 As you drag watch the values of the margin 
limits in the info bar. 

S| m Untitied-8 Layout a ee 
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Figure 4-76 Margins Mirrored Horizontally with Shift at pressed 

Layout Options 

Ecosystem Paper Layout Options 

Margins Facing end 2-Up 
KI Shown CJ Margins Mirrored Vertically 
I On Grid C Margins Mirrored Horizontally 
CL) Centered Vertically (] First Page On Left/Top 
Cj Centered Horizontally 

Margin Distances From Graphics 
© Top Left Corner @ Clip To Printer Limits 
@® Edges Of Paper © Clip To User Defined Page Limits 

Figure 4-77 Changing Layout options 
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You can change the ...Layout environment by using the Layout 
Options dialog, illustrated in Figure 4-77, which is accessible by 
choosing the $et Options... command in the Layout menu. The 
margin limits are affected by the boxes which are checked. 

Margins 

These options affect the margin limits: 

e If Shown is checked the margin iimits will be displayed as 
dotted lines in the Layout window. 

e If Oh Grid is checked, the margin limits will be forced to 
position on a 0.125" grid. 

« Centered Vertically keeps the top and bottom margins 
equal. If one of them is changed, the other will change to 
match it. 

Centered Horizontally keeps the left and right margins 
equal. When you change one of these margins, the other 
margin is also changed. 

Margin Distances From 

These options permit you to choose how the margins are displayed 
in the ... Layout Information Bar: 

¢ Click Top Left Corner to display margins as distances 
from the top-left corner of the page. 

¢ Click Edges Of Paper to display the actual width of the 
margins. 

Facing and Two-Up 

Facing and Two-Up printing methods are designed to hetp you in 
preparing two-sided documents. Nisus provides options to ensure 
that when you change the margin on one of the pages, the margins 
on the other side are adjusted properly. 
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The first page is usually placed on the right or bottom, depending 
upon the page orientation. You may change this. When in the Layout 
window, choose Set Options... from the Layout menu then check: 
First Page On Left/Top. 

Graphics 

The graphics options enable you to decide where graphics will be 
clipped. These options affect only how graphics are printed—no 
information is lost. 

Clip To Printer Limits allows you to clip graphics in your document 
which extend beyond the user defined margin limits. 

Clip To User Defined Page Limits allows you to print the 
portion of graphics which lie inside the margin limits. Parts of graphics 
which extend outside the margin limits will simply be “chopped off.” 

is You can display and print graphics as a box with a large X through 

it, eo instead of the actual graphic. This allows faster scrolling 
and printing while concentrating only on the text. Choose Gra phics 
As X from the Dis play submenu of the Tools menu. No information 
is lost; the entire graphic will print when required. 

Columns and Gutters 

You may have up to 8 columns of equal width in a document. When 
this number is changed, the entire document is affected and 
reformatted accordingly. The default is a single column. While you 
cannot vary the number of columns within a document, you can add 
graphic text boxes as explained on page 249, or entire documents 
with different column attributes using the Place Page...,and Place 
New Page commands. For more information on using the Place 
Page feature see Desktop Publishing and HyperText Links using Page 
Graphics, page 291. 
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Ecological Systems Columns 

Number Of Columns: #101 82202 *3@3 *404 
4505 8606 *%707 #808 

Line Thickness 

None 

Hairline 

Column Gutter Width = 0.500" f——l 
Maximum Gutter Width = 3.250” yb $a 

Figure 4-78 Using more than one column 

To change the number of columns, choose Layout Page... then 

choose Set Columns... from the Layout menu. Decide on the 
number of columns. You can place an optional vertical line between 
columns and you can set its thickness. To set the column gutter, drag 
the torn page on the right as shown in Figure 4-78. Both the current 
column gutter width and the maximum column gutter width are 
updated in the dialog. The column gutter width changes as you drag 
the torn page. 

To set the thickness of the line, click on the desired line thickness in 

the dialog. Click None to have no line drawn between columns. 

The square dot on top of the line is called its handle. You may change 
the length of the line by dragging its handle vertically. The line will 
stretch and shrink as you drag the handle up and down. 

Footnotes appear at the bottom of the column in which they are 

inserted if you choose the footnote placement option Place 

footnotes at bottom of page. 

Headers and footers will span multiple columns. 
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i” To start a new column choose Insert Page Break from the Format 
menu. You can achieve the same result by selecting one block of text 
you want in one column and choosing Keep On Same Page. 

Page Frames 

Frames are boxes which surround the text on each page of the 
document. Choose Set Frame... from the Layout menu to change 
the page frame. The frame lies just outside the margin limits that you 
set in the Layout window. 

Ecological Systems Page Frame 

XN © None xAO{ xo xcO ( “DO 

*%U @ User Defined: 
1} @ Edit tst Frame 

#2 © Edit 2nd Frame 

Line Thickness 

Figure 4-79 Page Frame dialog 

In the dialog box that appears, Figure 4-79, you can choose between 
the four default page frames or define your own custom frame of 
one or two Hines: 

¢ Click User Defined to define your own frame. 
¢ Click Edit Ist Frame or Edit 2nd Frame to edit the 

frames. 

¢ Click None to remove the frame. 

You can change the size of the frame by dragging the handle on the 
top-center of the frame in the diagram. You can round the comers of 
the frame by dragging the handle in the top-left corner of the diagram. 
You can edit the frame at any time by repeating the above process. 
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If your margins are too close to the printer limits and you place a 
frame around your text the frame may not show on all sides as 
illustrated in Figure 4-80. 

Figure 4-80 Frame beyond the printer limits 

In that case you will get a dialog box illustrated in Figure 4-81, when 
printing. If you still want the frame, you will need to bring your 
margins and or line wrap indicators in from the edge of the document. 

The page frame is outside the 

printer dimits. It will be clipped. 
Continue? 

Figure 4-81 Dialog when page frame is beyond printer limits 
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Layout Undo 

Nearly every command executed in the Layout window is undoable. 
some exceptions are: 

¢ Changing the thickness or height of the line in the middle of 
the column gutter. 

e Changing preview options that do not affect the text or the 
page position on a paper. Some examples are the show and 
hide margins, mirror margins and display margins from.... 

Headers and Footers 

A header is a mini-document which appears at the top of every page 
until superseded by a new header. A footer is similar, but its contents 
appear at the bottom of the page. A header and footer are attached at 
the beginning of the paragraph in which they are inserted. 

Headers and footers appear first on the page of their attachment 
paragraph, and then on all subsequent pages until the next header or 
footer is inserted. The exception to this is odd/even headers and 
footers, as explained below. 

Headers and footers are useful for labeling pages and putting the 
name of the document or chapter at the top or bottom of each page. 
They can include graphics and multiple paragraphs of text, but they 
are limited to about 33% of the page size. If too much is inserted into 
the header or footer, the excess will not be displayed. 

Inserting Headers and Footers 

To insert a header or footer: 

1. Place the insertion point immediately before the paragraph 
where you want the header or footer to begin. 

2. Choose Insert Header or Insert Footer from the 
Format menu. 
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Inserting a header or footer will open the Header/ Footer window 
which can be edited just like any other text window. All the headers 
and footers are shown in this window, in the order in which they 
appear in the document. 

Opening Header/Footer Window 

There are four ways to open the Header/ Footer window illustrated 
in Figure 4-82: 

* Choose Insert Header. 
e Choose Insert Footer. 
¢ Double-click any header or footer (the actual text at the top 

or bottom of a page.) 
¢ Double-click a header or footer icon in the left margin. 

¢ Choose Headers/Footers from the Display submenu of 
the Tools menu 

———— Headers © Footers for “Nisus Manual” SERED IE 

alas S| (be 

rcs [4 

o Nisus Manual _ 
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ey 4-82 Header/Footer window 

Note that when a header/footer window is in front, the 
Header/Footer menu appears at the right of the menu bar. See 
Figure 4-84 A & B. To close the Header/Footer window and get back 
to your document, click the close box or choose Close from the File 
menu, or Document from Display submenu of the Tools menu. 
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Header and Footer Types 

When you insert a header or footer, it appears initially on all pages 
up to the next header (footer), but placement can be limited to even 
or odd pages. 

Editing Headers /Footers 

The Header/Footer window contains all the headers or footers in the 
document. You may edit any one of them. To find the paragraph to 
which a specific header or footer is attached, place the insertion point 
within the header (footer) before you close the Header/Footer window, 
or choose Go To Reference from the Header/Footer menu. The 
insertion point is then placed at the beginning of the paragraph where 
the header or footer is defined. 

Notice the appearance of the header and footer icons in Figure 4-82 
and Figure 4-83. The header icon has a black bar extending across 
the top to signify that it is a header. The footer icon has a bar at the 
bottom. 

P Header LJ Footer 
[) EvenHeader [1] Even Footer 
[4 Odd Header Odd Footer 

Figure 4-83 Header and Footer icons 

you have these icons displayed in the left margin you can tell at a 
glance what type of header or footer is represented in the 
Header/Footer window. These icons also appear in the main document 
where they have the same meaning. 

Changing the Type of Headers and Footers 

To change the type of a header or footer, pull down the 
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Header/Footer menu that appears on the right side of the menu 
bar. Figure 4-84 A & B shows how to change or delete headers and 
footers. 

Header Footer 

Remove Footer 

Header. Footer 

Remove Header 

All Pages 
Odd Pages 
Even Pages 
le 6 mig re, 

Go To Reference 

Odd Pages 
“Even Pages 

Go To Reference 

Figure 4-84 A & B Header/Footer menus 

You can define the type of header or footer by using the menu 

commands. To delete, choose Remove Header or Remove 
Footer. Headers and footers can also be removed by deleting the 
return character from the beginning of their attachment paragraphs. 

[” Any number of headers and footers can be placed in a document but 
no more than one header and one footer may be attached to a single 
paragraph. 

Using Multiple Headers and Footers 

You can define multiple headers and footers within a single document 
in order to place different headers and footers on different pages. 
When more than one header appears on a page, the header closest to 
the top of the page is displayed. Likewise, the footer closest to the 
bottom of the page is displayed when there is more than one footer 
on a page. 

You may change headers and footers throughout the document by 
inserting them at the paragraph where you want them to begin. 

its” If you want to prevent the appearance of headers (footers) past a 
particular page, insert a blank header on the page where you want 
the header to stop displaying. 
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ts” It is not necessary to use headers and footers to create top and bottom 
margins unless these margins vary in size throughout the document. 
Change the margin limits for the whole document while in the Layout 
window. 

Closing Header/Footer Window 

Close the Header/Footer window to return to the main document. 
You will be returned to the paragraph where the current header or 
footer was inserted. The current header or footer is the one containing 
the insertion point. 

i=” Hold the Shift key down when closing the Header/Footer window if 
you want to return to where the header or footer was inserted. If you 
do not hold Shift, you are returned to where the insertion point was 
when you opened the Header/ Footer window. 

Footnotes and Endnotes 

Footnotes consist of two parts: the footnote reference, as shown here 
and the footnote text as shown at the end of this page, following a 
short horizontal line called the separator line.’ <+————_—_—_ 

A footnote or endnote is a mini-document which appears either at 
the bottom of a particular page or at the end of a document. Notes 
will appear in a region above any footers that have been created. The 
reference symbols for the notes can be entered anywhere in the text. 
A character graphic can have a footnote, but footnotes cannot be 
placed on the graphics sheets, nor in a graphics-text box. Footnotes 
can include graphics both on the text and the graphics sheets. 

Inserting Footnotes and Endnotes 

1. Place the insertion point immediately following the text. 
2. Choose Insert Footnote from the Format menu. 

‘This is an example of a standard footnote. Footnote placement options 
in this document are Place footnotes at bottom of page and Footnotes 
may separate from their references. 
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3. Type the footnote text; close the Footnotes for... window 
using Close from the File menu or the close box. 

4. Repeat the process for each note. They are numbered auto- 
matically 

Inserting a footnote will open the Footnotes for... window which 
can be edited just like any other Nisus document. 

The automatic margins of the notes are the same as the margin limits’ 

set for the document in Layout Page.... The footnote symbol is 
indented to a default tab of 0.5 inches. These parameters can be 
altered. The font, and style attributes used in the document are main- 
tained in the notes but can be changed as with any other text. 

The footnote symbol in the document appears in a scaled version of 

superscript style that does not affect the spacing of your lines. Other- 
wise, it shares the same attributes of font, size and style as the character 

immediately preceding the note symbol. In the footnotes text, while 
the font and style remain the same as in the document, the text font 
size becomes (the closest whole number to) 2 of the document font 
size. The font, size and style of the footnote's text and symbol can be 
changed without affecting that of the document. The reverse is also 
true. 

Cross Referencing Footnotes 

You can cross reference existing footnotes so that the same text will 
use the same marker in your document. Select the footnote marker 
and choose Mark Text from the Tools menu. When the dialog appears, 
the footnote marker will be in the text edit box. Type some text to 
identify the note (the footnote marker will appear only as a nonprint- 

able character). Click (set) Once the footnote marker has been 

set you can cross reference to it the same as to any other marked text 
as explained in Cross Referencing, page 129. 

‘The actual margin here is at the margin limit set in Layout Page.... 
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Opening the “Footnotes For...” Window 

There are four ways to open the Footnotes for... window: 

* Choose Insert Footnote from the Format menu (thus 
also inserting a tootnote). 

¢ Choose Footnotes from the Display sub-menu of the 
Tools menu. 

¢ Double-click on the footnote reference in the text (when your 
I-beam becomes an arrow). 

¢ Double-click on any footnote or endnote text. 

In the footnotes window all the footnotes are shown in the order in 
which they appear in the document. You can cut, copy, or paste text 
from note to note. You can also perform these operations from, or 
back to, your document, or to another document.’ 

The Footnotes for... window, Figure 4-85, contains all the notes 
of the document. Any one of them can be edited just as another 
Nisus document. 

In the Footnotes for... window, each note is treated as a mini-page. 
When a new footnote is inserted, its format follows the current pattern. 
The rulers of all the notes can be selected so that these as well as 
other formatting options can be altered simultaneously. Variables 
can be entered into the notes. Nisus' powerful Find/Replace capabili- 
ties are accessible while in the Footnotes for... window and it is 
possible to Jump To but not Mark Text.... The Thesaurus... 
and Spelling... are also accessible while the Footnotes for... 
window is open.’ Nisus' macro language functions in the Footnotes 
for... window. 

‘In the Footnotes for... window you will not be prevented from 
cutting or copying the reference mark; however you would not normally need 
to do this. 

’A general spell check of a document will not check the notes. To 
check the spelling of the notes, open the Footnotes for... window and do 
an independent spell check. 
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Editing Footnotes and Endnotes 

| ESS Footnotes for “Footnotes Figure” } 

‘They lived on Vista del Lugano, a little cul- 
de-sac huddled intoa tinybowl among the hills above 
the San Dieguito's ‘flood plain”) 

4've always iaved the way capa talk see 
other family members. They can't choose them, or fr 
lose them. but the certain can abuse them. 

the names were patting to me. OK Bob aha 
Jimm but Jay . Carcle, Grace. Dawn. who next? 

* ve never Saari a fan of paslesant poetry, 

but this was work so I made an effort to appreciate 
the vases while Carole went on her literary search 
and cetunnee Lets 

tea 4-85 The “Footnotes ea ” Window 

ifs” It is not possible to index items or number lines in the notes. 

When the Footnotes for... window is open the Footnotes menu, 
Figure 4-86, appears at the right of the menu bar. From this menu 
decisions are made regarding footnote symbols and placement. it is 
also possible to return to that point in the text where a specific note 
was entered. 

Footnotes 

Footnote Symbol... 
Footnote Placing... 
LE EY LS I 

Go To Reference 

Figure 4-86 Footnotes menu 
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Choosing the Footnote Reference Symbol 

1 © Set Individual symbois. 

%2 © Set default symbols for new footnotes/endnotes. 

%*N @© Number Autometicall 

XS © Stert Numbering At: 
In the document: in the notes: 

R301 RcCOl 

xO] #0 O [1] 
*5 0 (1) MEO) 

NFO. 

x7 @* xG @* 
%3 © None *%H O None 
%9 © Other: ie] %1 © Other: [| 
%0 [[] Superscript. J ( Superscitnt. 

Figure 4-87 The Footnote Symbol Dialog Window 

To choose the footnote reference symbol, choose Footnote 
Symbol... from the Footnotes menu. In the dialog box which 
opens, many prepared footnote symbols are available. Any symbol! 
accessible on the Macintosh can be used in a numbering scheme 
(Option T = t, Option Shift 7 = ¢, Option 6 = §, Option 8 = «, Option 
7 = {, etc.). These symbols, however, will not be considered in the 
numbering sequence. The numerals will continue following the sym- 
bols with whatever the previous number was, plus one. 

It is also possible to change a note symbol from a numeral to an 
asterisk or other non-digit symbol. This is done note by note using 
the Footnote Symbol... command. 

I” Note that the asterisk or star symbol is already placed high relative 
to other characters. When used as a footnote symbol it should not be 
put in superscript style. 

Choose the symbol you want to use in the document from the dialog 
illustrated in Figure 4-87. This will automatically check the same 
symbol in the notes. If you wish to make these different, change the 
symbol to be used in the notes. 
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You can use one symbol set in the text of the document and a different 
one in the notes. For example you may want to use a bracketed 
number in the document and a plain number in the footnote. Click 

the [1] button in the left column under “in the document,” and 

then click the button showing either “1” or “1.” in the right column 
under “in the notes.” 

ts In the document or in the Footnotes for... window, the font, size, 

and style of the footnote symbol can be changed just as in any text. 
These changes will only affect that individual symbol. The symbol in 
the text functions independently of its counterpart in the notes. To 
make the corresponding symbol in the document text duplicate those 
attributes, return to the text and make the same change there. 

Once a note is created it is possible to change its symbol] without 

going through the Footnotes for... window. Press the Shift key 
and double-click on the note or the footnote symbol in the text. 

The options automatically set in this window are Set individual 

symbols, Number automatically (beginning at 1) and a simple 
numeral which appears in superscript both in the document and in 
the notes. Certain options are mutually exclusive. With Set default 
symbols for new footnotes/endnotes checked, numbering 
remains automatic and a new set of symbols can be selected. 

To start a new sequence of numerals Check Start Numbering At, 

enter the number at which counting should resume and click ( ok} 

Choosing Footnote Placement 

The standard Nisus placement of notes, if you don’t make any choices 
in the dialog illustrated in Figure 4-88, is as follows: 

° Footnotes (as opposed to endnotes), that is, notes at the end 

of each page (or column) of the document. 
¢ 5 points below the end of the document text on each page, 

beneath a footnote separator line 108 points long, indented 
36 points from the left margin. 
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¢ Insufficient space on a page for the entire note text will 
cause Nisus to place the remainder of the footnote text on 
the following page. 

is” An example of the results of the standard options (reduced to fit) is 
shown in Figure 4-89 Nisus Footnote Placement, page 167. The same 
text and formatting with only the footnote placement options differing 
is illustrated in Figure 4-90 on pagel64 and Figure 4-91 on page 165. 

Footnote/Endnote Placing: 

%E CD Endnotes. 

%B (] Place footnotes at bottom of page. 

20 (] Don't divide footnote tent. 

NS [) Footnotes may separate from their references. 

A () Renumber footnotes on every page. 

%F () Footnotes do not enceea{fiiy}t of page. 

Seperation between dacument end footnotes: [sj points. 

Separator line size: 108] palnts. 

Olstance between seporator and left margin: points. 

Figure 4-88 The Footnote/Endnote Placing Dialog Window 

Nisus offers six other options for placement of your notes. Each one 
can be changed in the Footnote/Endnote Placing dialog box 
shown in Figure 4-88. Choose Footnote/Endnote Placing... to 
open the Footnote/Endnote Placing dialog box from the 
Footnotes menu available when the Footnotes for... window 
is active or double-click on the footnote separator line. Some combi- 
nations of the settings are mutually exclusive. 

1. Endnotes (Endnotes) 
Check this to place all the notes at the end of the document. 
All other options are thereby disabled. You can create only 
footnotes or endnotes in any single document. It is possible 
to change between them at any time. 

2. Place footnotes at bottom of page. (Bottom) 
Check this for the notes to appear at the bottom of the page 
rather than just below the end of the document text. 
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3. Don't divide footnote text (Don't Divide) 
In the standard option, a note's text is permitted to start on 
one page and, if there is insufficient room, to continue on 
the next. Check Don't divide footnote text to prevent 
this from occurring. The note's text will then always appear 
as an undivided block, but may be on a page other than its 

- reference symbol in the document. (The following option is 
automatically checked along with this.) See Nisus Footnote 
Placement 3, (Figure 4-90 page 164). 

4. Footnotes may separate from their references 

(3 Separate) 
There may be insufficient room to place even the first line of 
the note's text at the bottom of the page. 
*If this option is unchecked, Nisus will move the line of the 

document with the note symbol to the next available page. 
There, both symbol and note text can appear together. 
*If this is checked, Nisus will keep the symbol on one page 
and permit the note text to appear on a succeeding page, 
thus separating it from its reference. 
*This option is always checked when Don’t divide 

footnote text is checked in order to avoid large gaps at 
the bottoms of pages. See Nisus Footnote Placement 4, (Figure 
4-91 page 165). 

). Renumber footnotes on every page(%Renumber) 

Check this to have numbered footnotes begin again from 
“1” on each page. This is disabled when Footnotes may 
separate from their references is checked, because 
that would create ambiguous footnote reference numbers. 

6. Footnotes do not exceed [Ea)% of page. (%Foot- 
notes) 
This may be set to virtually any percentage. The option auto- 
matically selects Footnotes may separate from their 

references. 

WORKING WITH TEXT AND DOCUMENTS 163 



© 
P
U
B
L
]
 

B}
OW

IC
O.

J 
SI
St
py
 

€
 

a3
eg
 

‘a
uo
# 

se
m 

ay
s 

wa
y)
 

pu
e 

‘p
oa
cu
 

|
 

yn
g 

“I
qu
de
g 

241
] 

ou
ll
e 

se
m 

ay
g 

‘A
pU
eY
 

se
m 

ay
s 

399
} 

23
4 

YI
M 

U
M
}
 

© 
SE
 

Y
O
U
 

Ba
m 

Sy
Ua
Wa
AO
U!
 

a
s
o
U
 

AA
 

U
M
E
]
 

Se
 

O
S
 

[1
9 

& 
Se
m 

au
d 

aa
y]
 

Y
M
 

pa
ui
ng
as
 

pu
r 

r
e
s
s
 

Ar
ei

9y
] 

49
y 

VO
 

W
I
M
 

af
or

e 
a
p
y
 

sa
se
A 

ay
) 

aw
pa
ud
de
 

03
 

y
o
}
 

UR
 

ap
eW
 

| 
Os
 

Y
O
M
 

SE
M 

SI
U)
 

IN
G 

‘A
zy
ao
d 

ju
sr
sa
jo
pe
 

jo
 

uz
} 

# 
Us
eq
 

sa
aa
u 

an
f,
 

‘a
uo
ud
 

ys
ty
Aj
s 

Ja
 

QI
U]
 

SJ
aq
uM
uU
 

ay
} 

Jo
 

Us
Aa
s 

]]
e 

pa
ss
a 

Ay
ye
p 

ay
s 

‘B
up
fo
o]
 

yn
oy

yt
y 

—
 

,‘
aw

oy
 

$3
45

 
M
s
 

UL
] 

‘f
oo
rp
s 

o}
 

Jo
 

au
o3
 

Ap
ea
re
 

GA
RY
 

SP
LY

 
aY
L 

“y
ay
 

[y
er
 

fp
] 

‘a
za
py
 

A2
14

 
O}
 

BW
IO
IP
M 

aL
 

No
d 

jn
q 

‘U
ap
oo
e 

s Io
UV

ey
 

Jo
y 

au
ls
 

[I
d 

ay
y 

Y
M
 

yU
oW

aA
oA

U]
 

Au
e 

pe
y 

se
y 

sn
 

jo
 

ra
yy
ia
u 

‘W
t 

yq
no
p 

J,
 

,C
UO

NP
UL

IO
JU

T 
Ju
aL
MS
 

as
ou
l 

aa
ey
 

‘s
de
ys
ad
 

‘u
Xe
l 

1
3
,
 

:p
ay
se
 

pu
e 

Aj
sn
oj
po
ei
d 

«c
i 

ay
 

pa
yu
ey
y 

{ 
» PU
LU
T 

| U
p
m
o
m
 

(u
ut
y]
 

mo
uy

 
y 

‘n
od
 

0}
 

wa
y)
 

Mo
ys
 

aw
 

ja
] 

“U
ay

UM
 

pe
y 

ul
eu
) 

Jo
 

Om
) 

ay
) 

su
ia
od
 

Y
M
 

pa
ll

y 
se
m 

J]
 

“X
Oq
 

& 
UL
 

as
oo

| 

za
8e

g 
€ 

HO
UR

OR
],

| 
BO

LQ
OO

L 
sn

si
ny

 

{y
xo
u 

OY
M 

“
U
M
E
 

‘a
de
LF
 

‘B
]O

Ie
D 

‘U
Ae

l 
yn
g 

‘
A
u
t
 

PU
P 

GO
g 

I
O
 

“w
u 

07
 

B
u
n
 

au
am

 
sa

we
y 

ay
y,
 

Wa
y)
 

ae
ng

e 
we
s 

Ap
ur

ey
ao

 
As
ay
) 

yn
g 

‘W
ay

: 
as
o}
 

20
 

‘W
ay

} 
as

oo
up

 
yu
r 

Aa
yy

 
“s
ue
qu
aw
 

A
p
u
 

ay
jo
 

wm
og
e 

41
%;
 

aJ
do
ed
 

Ae
m 

ay
y 

pa
c]

 
sh

em
je

 
aa

],
 

3u
l4

] 
, si
ad
ed
 

jo
 

yw
eq

 
¥ 

pu
no
j 

| 
ua
ym
 

og
e 

Je
af

 
© 

ja
so

p 
s Au
rw
ty
 

in
o 

3u
tu

ra
p 

SE
M 

J 
“U
ay
} 

JO
] 

& 
pa
le
ys
 

ul
ay

] 
Jo
 

om
) 

ay
 

y
u
 

| 
y4

om
 

wi
m 

As
nq

 
as
am
 

a
o
e
 

pu
e 

je
g 

U
a
y
M
 

Ya
am

 
& 

ad
U0

 
Jo
uU
Ip
 

Ja
y 

a
r
s
 

P|
 

‘a
sa

y 
au
ty
] 

Jo
 

yo
] 

& 
pu
ad
s 

0}
 

pa
sn
 

au
s 

**
*A
pl
ur
ey
 

nq
 

‘u
os
te
y]
 

ay
y 

jo
 

pa
nc
ud
de
 

ya
aa

u 
| 

‘s
he

p 
as

oy
y 

ul
 

as
oj

o 
A
a
 

21
9M
 

ai
mM
eg
 

pu
e 

A
w
u
l
y
 

‘m
ou
y 

n
o
,
 

,
 

‘s
8u
rj
aa
y 

Ja
y 

po
uS
ie
s 

AA
T)

 
“p
as
ay
o 

ay
s 

pe
d 

pu
r 

ua
d 

ay
y 

yi
m 

Hf
 

PI
LI
OD
 

0}
 

YD
eq
 

JU
aM
 

| 
OS

 
Te
y]
 

Ua
 

WM
 

Pl
. 

PS
L9

-1
8p

 
St
 

Jo
qu
mu
 

Ma
u 

Ja
p 

“y
pe
aq
 

ay
y 

Aq
 

Ay
tu
nu
rw
os
 

sa
j8

ut
s 

e 
07

 
pa

no
w 

$ ay
s 

‘a
sn
oy
 

SJ
oy
ze
j 

Ja
y 

se
m 

ye
u)
 

in
g 

‘C
LP
L-
L8
h 

(6
19
) 

32
 

Jo
y 

pu
ly

 
0)

 
vI
qG
e 

aq
 

oO}
 

1y
8n
o 

no
d 

pu
e 

o
e
 

si
va
k 

Ma
j 

e 
sa
ja
su
y 

SO
] 

Ul
Ol
J 

YD
eq
 

pa
ao

w 
ay
s,
 

“H
Xo
OO
U 

au
oy
da
y)
 

ay
} 

0}
 

w2
a0
 

pa
dd
ay
s 

ay
s 

se
 

aw
 

Pf
oy
 

ay
s 

,y
oo
g 

Aw
 

ut
 

si
aq

um
u 

au
oy
d 

£
 

U
A
L
R
]
 

ap
OW
NO
OY
 

ss
 

ip
] 

L 
af
eg
 

‘w
ie
ld
 

p
o
o
,
 

s,
ou
n8
ai
gq
 

ur
s 

a4
; 

SA
og
F 

TI
NY

 
ay
s 

Su
ow
e 

[M
og
 

Au
y 

& 
On
l!
 

pa
jp
pr
y 

oe
s-
ep
 

*[
N2
 

ap
ni
] 

& 
‘o
ur
Fn
] 

ja
p 

ey
s}
A 

UO
 

pa
ar
 

Si
oq

uo
ur

 
Ay
ur
ey
 

ay
y 

yp
e 

da
ay
 

op
 

3 
yn
g 

z 
J
i
g
 

[k
at
 

& 
O}
U}
 

p
o
u
m
y
 

oY
ys

 
0
}
 

j
U
R
M
 

J 
O
p
 

so
u 

‘s
ad
e 

uy
 

Ja
y 

uy
im
 

ua
yo
ds
 

j ua
ae
y 

J.
 

3
y
b
e
g
 

Z
u
l
w
o
w
 

Aj
ie
a 

ay
} 

OJ
U]
 

W
O
O
 

ay
y 

Jo
 

YW
WI
EM
 

ay
y 

Wo
lf
 

UM
OI
Y]
 

Us
aq
 

pe
y 

| 
Us
No
Y)
 

se
 

12
2]
 

OU
 

SP
EU
L 

UM
EG
 

IN
Og
e 

pa
ys
e 

| 
Ua
yM
 

jo
 

| 
22
8}
8 

pl
oo
 

ay
y 

yn
g 

‘s
ig
ns
 

Uo
He

Ia
Ua

d 
}X
aU
 

VY
} 

“‘
UO
UT
WI
OS
 

00
} 

[|
e 

S]
 

se
 

‘p
ue

 
‘O
SO
[2
 

Ud
aq
 

Ja
Aa

u 
pe
y 

je
g 

pu
re
 

aj
ol
e>
 

Ma
uy

 
|]

 
‘u

on
da

ds
al

 
je
lp
io
> 

e 
Zu
ns
ad
xa
 

1,
us
em
 

| 
'p
se
d 

pa
l[
y-
[o
od
 

e 
Zu
pz
oo
ys
aa
o 

e
m
 

ss
ey

s 
e 

y
s
n
o
n
y
 

Uy
 

p
o
w
e
a
y
s
 

ye
y]
 

un
s 

ay
) 

Ul
 

pa
mo
ys
 

sa
se
a 

pu
e 

sj
ad
ie
 

ja
ys
e,
j 

‘S
UN
S 

SE
M 

aj
os
eD
 

as
ey
m 

wo
os
 

Al
pe
; 

ay
} 

0)
 

Ja
AO

] 
pa
y 

ay
y 

yS
no
my
y 

pa
y 

se
m 

| 
| Ja
dj
ay
 

pr
ed
 

Ja
m 

e 
pi
oy
e 

pf
no

o 
Aj
nu
ey
 

SI
U}
 

Je
aj
> 

se
m 

YY
 

‘s
ay

 
po
y 

| 
Bu
ry
yA
sa
aa
 

po
oj
si
ap
un
 

Ap
ey
el
pa
ur
uy
 

ay
s 

‘a
oo

1u
 

Ja
y 

IN
OG
E 

LI
EW
IT
Y 

“S
al

 
YI
M 

ye
ad
s 

0}
 

pa
po
au
 

[ 
J2
y 

pj
oy

 
| 

Ua
y 

AA
 

“J
oo
p 

ay
y 

Ja
ms
ue
 

0}
 

ja
da
ay
as
no
y 

ay
y 

Jo
} 

Zu
o]
 

a4
) 

},
up

tp
 

yy
 

Figure 4-90 Nisus Footnote Placement 3 
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Figure 4-91 Nisus Footnote Placement 4 
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Removing footnotes 

Footnotes can be removed using a variety of methods. 
¢ Place the insertion point immediately to the right of the 

symbol in the document and press Delete or Backspace. 
¢ Select the note symbol in the text and cut it by choosing 

Cut (3) or Clear from the Edit menu or press the delete 
or backspace key. A double-click on a note symbol] (while 
the I-beam is an arrow) will open the Footnotes for... 
window; but not select the symbol. 

If selected, the entire footnote can be pasted elsewhere in the text or 
in another document. The numbering sequence of all the notes, in 
whichever documents are affected, will be updated automatically. 
Selecting and changing the symbol of the note (though not its font, 
size or style) in the main body of the document will eliminate the 
entire note (symbol and text). Nisus is very forgiving; simply Undo... 
if this should occur. 

(*" A footnote cannot be cut from within the Footnotes for... window. 
Deleting, backspacing or cutting it there will only remove what appears 
(the text and/or the symbol) in the notes section of the document but 
will not affect the numbering, nor will it remove the separator line. 
The symbol will remain in the body of the text. 

Closing the “Footnotes for...” Window 

To close the Footnotes for... window and return to the main 
document: 

* Click the close box in the upper left corner of the window or 
choose Close from the Fite menu (%W). The insertion point 
returns to where it was before the Footnotes for... win- 
dow was opened. 

¢ Choose Go To Reference from the Footnotes menu to 
return to the corresponding symbol in the document. 

¢ Choose Document from the Display submenu of the Tools 
menu. The insertion point will return to where it was before 
the Footnotes for... window was opened. 

e Press Shift and click the close box to return to the reference. 
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Figure 4-89 Nisus Footnote Placement 
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Page Numbering 

“Page number” is a variable that you will find especially useful in 
headers and footers. Insert it anywhere in the text and it will show 
the correct page number. To insert a page number, choose Insert 
Page * from the Format menu. To change between Arabic and 
Roman numbering choose Set Date & Page*# Formats from the 
Format menu. 

Page Numbers will normally start at 1. To begin numbering at another 
number, enter the page number you want in the text box provided 
following Start page *: in the Page Setup... dialog box or in 
the Set Date & Page * Formats... dialog. You can set the 
starting page number to any reasonable value. Setting it negative 
will allow you to start page numbering at other than the first page. 
For example suppose you had three cover pages for your document 
which you did not want numbered. Set Start Page # at -2. Insert 
the first header (or footer) which has the page number variable, on 
the fourth page, it would then be numbered 1. 

Line Numbering 

You may have line numbers appear next to every line of your 
document. The lines can be numbered either from the beginning of 
the document or from the beginning of the page. 

To number lines automatically, choose Line Numbers from the 
Display submenu of the Tools menu. They are displayed in the left 
margin. If you print the document when the line numbers are 
displayed, the line numbers will also be printed. The Line # Prefs... 
dialog allows you to choose the method of numbering and the font, 
style and size of the line numbers. It also allows you to make your 
page appear as a Pleading Page used in legal settings (a Pleading 
Page stationery file is shipped with your original disk). See Line 
Number Preferences, page 461. 

To cancel the display of line numbers, choose Line Numbers again. 
When line numbers are being displayed, the Line Numbers 
command is checked in the menu. 
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Keeping Text Together and Forcing Page 
Breaks 

You can keep sections of your text together or force a page break. 
Select the text you want to have on the same page (including, if you 
wish character graphics—this has no effect on the graphics sheets) 
and choose Keep On Same Page from the Format menu. 
Alternatively, if you want to start a new page, simply place your 
insertion point where you want the new page (or column) to begin 

and choose Insert Page Break from the Format menu. 

Printing 

When you are ready to print, choose Print... from the File menu or 

click the Print icon in the Info bar of the Layout window. If you 

have a LaserWriter you will see the Print dialog illustrated in Figure 
4-92. Any options you change below the dotted line will be saved 
with the document so that the next time you print they will be set the 
same way. A similar dialog is displayed for the ImageWriter. 

copier IM) Pages:@ au Orrom[ —]to:| _] 
Cover Page: @No © First Page © Last Page re 

Paper Source: @ Paper Cassette © Manual Feed 

fk] As Numbered in Document 
Page Range: 

@ Odd &® EvenPages OOdd Pages © Even Pages 

Ci Cross References 

Ci Time @ Date 
Before Printing Update: 

Figure 4-92 LaserWriter Print Dialog 

Type the number of copies you want in the Copies box. Each page 
of the document will be printed this number of times before the next 
page is printed. Documents are not collated. 

You may specify a page range to print in the From and To boxes. 

You may leave either end of the range open. For example, type 5 in 
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the From box to print every page from page 5 to the end of the 

document. If you want to print the entire document, click RII. 

If you want to print only one page, type the number of that page into 
both boxes. For example: © From: To: [157 |, will print only page 
157. 

Click First Page or Last Page following Cover Page in the 
Print dialog to have a cover page printed containing the following 
information: 

Your user name as set in the Chooser desk accessory 
The name of the printing application 
The name of the document 
The date 
The time 
The name of the printer 

Click the Manual Feed button if you want to feed each sheet 
manually for double-sided printing or printing one sheet at a time on 
special paper or envelopes. 

To print two sided documents choose Odd Pages first, then turn 
over all the pages and choose Even Pages. 

Pages will be printed either from last to first or the reverse depending 
on what you have selected in the Printing Options dialog which 
appears when you choose Printing... from the Preferences 
submenu of the File menu. Different printers release the printed 
page either face up or face down. This variable would determine 
how you should set your option. For more on Printing Options, 
see Printing Preferences, page 449. 

If you check As Numbered [n Document, the numbers in the 
page range boxes will be interpreted to mean those numbers on the 
pages that you see in the headers or footers (or beside the page 
number icon in the Info Bar). This number can change depending on 
how you set Start page #: in Page Setup or in the Set Date & 
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Page * Formats... dialog. To interpret the page range in terms of 
the actual sheets of paper rather than the document page numbers, 
leave this option unchecked. This option has no effect if the starting 

page number is set to 1. 

_& If you set your beginning page number to a negative value you must 

uncheck As Numbered In Document for those pages before “1” 
to print. 

Cross-references will not be updated when you print. To assure that 

cross-references are updated, check Cross References. This option 
has no effect if you do not use the cross-referencing feature. 

You can insert the current time and date into your document and not 
have them change. If you want them to reflect the time and date that 

the document is printed, check Time and Date. This has no effect if 
you do not use time or date variables. 

i= To cancel printing, press the Command and period keys until the 
print dialog clears the screen. Note that printing may not stop if you 
are using a print spooler such as the PrintMonitor. 

Merging Documents 

Introduction 

The most common application of the Merge... command is probably 
the preparation of customized form letters. There are, however, many 
other applications of this feature which are not as obvious. An example, 
useful for teachers, is preparing customized homework or exam 
problems from templates. Another is the filling out of forms with 
data provided in another file. Nisus has the capability of producing 
very professional looking forms which can be filled out using macros 

or using Merge.... 
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Using Merge 

To use the Merge... command, you have to: 

. Prepare the Template Document. 

. Prepare the Data Document. 
. Prepare the Data Definition document if needed. 
. Make sure all these documents are in the same folder. 
. Open the Template Document and close all other documents. 
. Choose Merge... from the File menu. 

Kh 

ON ON & 

The examples that follow use form letter preparation because that is 
the most obvious and common application of Merge.... We refer to 
the addressee of each letter as the “Customer.” 

When preparing a number of form letters to mail out you need two 
files: 

* The form letter template, which we will refer to as the Template 
Document. This contains the skeleton of the document which 
will be merged with specific data to produce a number of 
merged documents. 

* The list of names, addresses, and any other customer- specific 
words. The text in each item in the list replaces the specified 
data fields in the Template document to produce the output 
of the Merge... command. We refer to the document which 
contains this list as the Data Document. 

The result of aMerge... operation is the production of several new 
documents based on the contents of the Template and Data documents. 
The new documents can either be sent to a new window in Nisus, or 
may be sent directly to the printer. 

In the following you will find a description of how to prepare the 
Template Document and the Data Document. You will learn how 
conditionals are used and then the simple steps to follow to use 
Merge.... Finally, examples are shown to illustrate these features. 
The last section describes some more advanced features. 
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Preparing the Template Document 

The Template Document is an ordinary letter prepared as if you 
were writing to one customer but in which you have to envision all 
the possible inflections and possibilities you wish to cover in your 
whole mailing list. When creating the Template Document, it is 
advisable to use an existing letter written to an individual, or if one 
does not exist, to prepare an individual letter first. Then you could 
check through it and replace each person-specific word or phrase 
with a generic descriptive word placed inside special brackets, for 
example «name». These generic words become the fieldnames which 
you will use and which will be replaced with person-specific text 
during the Merge operation. The Basic Examples on page 179 illustrate 
a typical Template Document, more advanced examples can be found 
on page 188. The field names you use must be placed, separated 
using commas or tabs, as the first record in the Data Document file, in 

the same order as the corresponding data fields appear in your Data 
Document. (See Preparing the Data Document below). 

To type the special brackets: 

Character Keys to Type 

es clsebca cides tit cca alceaeiod eetasaceataee! Option\ 

DD esddica tye tanagndaastatient ei oaeaeasCosiwausayinies Shift Option\ 

The first line of the Template Document may contain the name of the 
Data Document file inside the special brackets, in the following format: 

«DATA My Mailing List» 

where “My Mailing List” is the file name of the data document (in 
the same folder as the Template Document). If this statement is not 
present, and you choose Merge..., Nisus will ask you to locate the 
Data Document on disk. 
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Preparing the Data Document 

The Data Document is a document which holds all the customer- 
specific text. One paragraph is allocated to eact: -ustomer. nd commas 
(or tabs) separate each Data Record. For exé:":ple, if | want the 
name and address of a company in one recor, you coud have the 
following in your Data Document: 

company ,address,city,zip | 
Paragon Concepts Inc.,990 Highland Drive Solana Beach,CA 92075 
The XYX Company Inc.,1234 Dover St..My Town, CA 99999 

The Definition Record 

The first line of the Data Document is called the Definition Record. It 
defines the special words you use in the Template Document inside 
brackets «...» to designate each field. The subsequent lines specify 
the customer-specific fields to be merged with your Template 
Document. Each comma (or tab) separated field can be used in more 
than one place in the Data Document and is referred to in the Template 
Document by typing its name, exactly as it appears in the Definition 
Record, but enclosed inside the brackets «. To make things clearer 
we will rewrite the above sample Data Document file using tabs to 
separate fields rather than commas: 

company city zip 
Paragon Concepts Inc. 990 Highland Drive Solana Beach CA 92075 
The XYX Company Inc. 1234 Dover St. My Town CA 99999 

The Definition Record 

In the actual Data Document you can choose to use either tabs or 
commas to separate the fields. 

ks” The Definition Record can, if required, be placed inside a separate 
document. In that case, the first line of the Template Document must 
give the name of that document in the following format: 

«DATA Definition File Name, Data File name» 
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Either or both file names can be replaced with the question mark 
followed by an optional message, in which case you will be asked to 
locate the file. For example: 

«DATA ?Locate the Definition File,?Locate the Data File» 

Both the Data Document and the Definition Document must be tn 

the same folder as the Template Document’. 

If you want to add a comma or a tab inside one of the fields, or you 
want a space at the beginning or end of the field, then you must 

place straight quotes "..." around those characters or the entire field. 
For example, in the above Data Document, if you wanted to have a 
comma after the company name (before the Inc.), your Data Document 
would be the following: 

company address city zip 

Paragon Concepts"," Inc. 990 Highland Drive Solana Beach CA 92075 
The XYX Company"," Inc. 1234 Dover St. My Town CA 99999 

You may, alternatively, put straight double-quotes around the entire 
field. You may need to do this, for example, if you want spaces at the 
beginning or end of the field. 

In the above example, wherever you have the word «company» in 
the template document, it will be replaced with the fields in the first 
column, and the word «address» will be replaced with those in the 
second column, and so on. This continues until the number of records 
you have specified in the dialog box is used up, or the records run 
out. 

Each record does not need to have the same number of fields. The 

first record defines the maximum number of fields which you can 

‘Each file name can be replaced with the full path to the file, in 
which case the files need not be in the same folder. The path is specified from 
the root directory using colons to separate the name of each folder. For example: 
MyDiskName:FolderName:NextFolderName:FileName. See “file path” in the 
index for other explanations. 
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access in the letter. Any record which has excess fields will have the 
extra fields ignored; any record which does not have a sufficient 
number of fields is considered to have the last fields missing. 

If you want to use quotes in your Data Document, you can use 
“Smart Quotes.” They will be treated like any other character in the 
Merge operation’. 

is” “Smart” quotes can be entered from the keyboard as follows: 

Quote Keys to Type 
 ebaieceah diac Pe aaa Se asc acat saee tet Option [ 
v aadevcsdab@stcoeuesauctactueeataaenueuseaaiyest Shift Option [ 

Choosing Fields 

You can choose how to split each part of the customer-specific text 
Into separate fields. For example, you could treat the whole address 
as one field, but then you must keep the address as one paragraph 
and not use returns between lines of the address (use Shift Enter, 
which inserts a forced line break but keeps it as one paragraph). This 
is because returns are treated as Data Record separators and so cannot 
appear inside the data itself unless, of course, you put them inside 
quotes. It is most common to treat each line of the address as onc 
field. This lets you use any field of the address separately in the 
letter. 

Running Merge 

When you have prepared the Template Document and the Data 
Document and (if needed), the Data Definition document, make sure 
they are all in the same folder. Close all other documents and open 
the Template Document. Choose Merge... from the File menu. 
You will see the dialog illustrated in Figure 4-93. 

‘If you want to use straight quotes in the Data Document then you 
must double them up. For example: “Dumbo, “"The Flying Elephant”. 
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Range of records to merge: 

@® All © From: fd To: 

Send merged documents to: 

(Printer 

Figure 4-93 The Merge dialog 

If you have not inserted the Data Document file name into your 
Template Document’s first line, (see page 173 for an explanation) or 
if Nisus cannot find the file, you will get a standard open file dialog 
asking you to locate the data file. 

If you have not put the special brackets «» around the fields in your 
Template Document, you will be reminded by the dialog illustrated 
in Figure 4-94. 

There are no fields tn this document. 

Each field must be enclosed in «>» brackets. 

Type Option-\ to open and Shift-Option-\ to close. 
See manual for more details. 

Figure 4-94 The Missing Brackets warning dialog 

After a successful merge, the original files remain unchanged. If you 
have clicked the button in the dialog in Figure 
4-93, the merged documents will be in one new document file which 

will become the new active window. If you click (Printer —_—s 

in the dialog, the merged documents will be printed. It is usually 
advisable to use the Document option for a small test run first. Then, 
when you are certain that everything works the way you want, you 
can use the Printer option, or simply print the merged file. 
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Troubie Shooting 

Pay particular attention to the following when using Merge...: 

¢ Misspelling the Data Document name in the Template 
Document file produces the message “Could not open the 
DATA document “Data Doc’”” as illustrated in Figure 4-95 
where the name you have typed is put in place of “Data”. 
Check the name carefully, it must be correct. The file name 
is not case sensitive: it will be found even if the file name is 
not in the correct case. 

Could not open the DATA document “Data Doc”. 

Figure 4-95 The Unfound Data Document dialog 

* To make sure the data file always opens, be sure that the 
Data Document is in the same folder as the Template 
Document, or you must provide the full path to the file in 
place of the name. (See page 194 for details on how to construct 
the path to a file). 

* All the opening brackets in your Template Document must 
have corresponding closing brackets. When you are 
preparing the Template Document you can choose Balance 
0) from the Edit Tools submenu of the Tools menu. To 
keep track of the brackets. (See page 325 for more details.) If 
brackets are not closed, either of the dialogs illustrated in 
Figure 4-96 and Figure 4-97 can result. 

Fieid “ENDIF” is not defined 

Figure 4-96 An undefined field warning dialog 
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«iF field» command is missing the field. 

Figure 4-97 A missing field warning dialog 

¢ Every «IF...» statement must have an «ENDIF» to follow or 
you will get an error message like the ones above. 

e Between the conditionals «IF...» and «ENDIF» every part of 
the text is significant and any text can be placed there, 
including returns, spaces etc. 

Basic Examples 

The Data Document 

Tom,Berkley,1234 Minute Rd., Templetown,MA 12345 
Terrance,Atomby,,1234 Minute Rd.,Templetown,MA 12345 
Phitlip, Barnaby,2343 Billings Drive™,” Suite 333 Alameda,CA 92123 

Definition Document 

first name,last name,company,street,address,state,zip 

Template Document 

«DATA Definition Document,Data Document» Name of document 

«first name» «last name» containing the Data 
«street» Definition 
«address» ustate» «zip» Name of document 

: containing the Data 
Dear «first names, 

We are pleased to let you know that our new version of Nisus is about to ship, All we have to 
do is finish it! You will receive it at your home address, Please call us to let us know how you 
like it. 

Sincerely, 

Bili Weatherby 
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Merged documents 

Tom Berkley 

1234 Minute Rd. 

Templetown MA 12345 

Dear Tom, 

We are pleased to let you know that our new version of Nisus is about to ship. All we have to 
do is finish it! You will receive it at your home address. Please call us to tell us how you like it. 

Sincerely, 

Bil! Weatherby 

Terrance Atomby 

1234 Minute Rd. 

Templetown MA 12345 

Dear Terrance, 
We are pleased to let you know that our new version of Nisus is about to ship. All we have to 
do is finish it! You will receive it al your home address. Please call us to tell us how you like it. 

Sincerely, 

Bij] Weatherby 

Phillip Barnaby 
2343 Billings Drive, Suite 333 

Alameda CA 92123 

Dear Phillip, 
We are pieased to let you know that our new version of Nisus is about to ship. All we have to 
do is finish it! You will receive it at your home address. Please call us to tell us how you like it. 

Sincerely, 

Bill Weatherby 

More Advanced Features 

The more advanced capabilities of the Merge... command include: 

* The ability to use conditionals and only merge parts of data 
if certain conditions are fulfilled. 

* The ability to put up dialogs for keyboard entry of fields 
(The ASK and SET instructions). 
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e The ability to include another document in the same folder 
as the Template Document (The INCLUDE instruction). 

¢ The ability to control when the next record is to be used 
(The NEXT and OMIT instructions). 

These features, among other things, enable you to put up a dialog to 
ask for a keyboard entry, to print labels, and to merge all the records 

of (for example) California customers or all the records for customers 
outside of California. 

ie” Note that all features are controlled by instructions in the Template 
document only. No instructions are ever inserted into the Data 
Document. All instructions have to be placed inside the special brackets: 
«» Otherwise they will be understood to be part of the text. 

Conditionals: «JF»...«ENDIF» 

Sometimes you will want to insert different text into your Template 
Document, depending upon whether you are writing to a company 

or to an individual. This can be done using Merge... by placing 
conditionals inside your Template Document. The “«If...” statement 
with the special opening brackets begins a conditional. Following it, 
you can type any one of the words you have used to define the fields 
in your Data Document. Using our example, you can check to see if 
there is a company field by using the statement «IF company». Any 
text in your Template Document between this statement and the 
«ENDIF» statement (or the «ELSE» statement if this is present) will 
be left in the letter if the statement is true. The statement is considered 
true provided there is something in the “company” field in the Data 
Document. If the company field is empty’, the text enclosed by 
these two statements will be removed from the final letter, unless 
you have specified an alternative between them with the «ELSEIF» 
statement. In that case the text between the «ELSEIF» and the «ENDIF» 
will be substituted. 

1 Just an empty position in the Data Document. This usually implies 
two consecutive commas or tabs. 
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its” The “IF” statement can make other checks, including numeric checks, 
where the text enclosed by the two statements will only be inserted if 
the field “Income” meets the specified condition. 

Example: «IF Income > 50000»You really should join our Country 
Club. ...«ENDIF» 

All the following conditional tests can be applied: 

Test Symbol Meaning 

FH cvecenseccvoversscunenarsrasevevenscavuunsvesases Equal 

<> or # (Option =) wcecseseen Not equal 
D> scivasiatua teaeuetodtibasabeseisesmseasteueness Greater than 
Se aes suns viadanwentarateceentlaebonaeeseeieaoes Less than 
<= or S$ (Option <) wee Less than or equal 
>= OF 2 (OPTION >) wo ceeeeeneee Greater than or equal 

Comparisons may be done numerically or alphabetically. In order 
for the comparison to be numerical, the values on both sides must be 
in one of the standard forms. Numbers cannot contain a comma, ora 
dollar sign, or a hyphen. Examples of acceptable numbers are: 

12, -23, 45.5, 12.5E-24. 

Examples of unacceptable numbers: 

$24.45, 50,000, 89-90, ($, comma, hyphen not allowed). 

The ASK Instruction: Keyboard Entry of Fields 

There may be occasions when you need to pause the merge and 
enter a field from the keyboard. A typical way of accomplishing this 
isto insert the ASK instruction in the appropriate place in your template 
document. The general format of this instruction is 

«ASK field name = ?Message» 

'This is scientific notation and means 12.5x10°24 
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Example: If the following is placed in the template file: 

«ASK company =?Enter company name.» 

each time this statement is encountered in the merge process you 
will get the dialog illustrated in Figure 4-98. You can then do one of 
three things: 

¢ Enter the company name, then click [[_ ok 
© Click to bypass that record; 
© Click to stop the merge, in which case you may 

end up with a partially merged document. 

You can place this statement anywhere in the Template Document. 
In particular you can also place it between the «IF...» and «ENDIF» 
statements. If you placc it after the «ELSE» statement it will only ask 
you for an entry when some field is missing. 

Example: The following expression in the template document: 

«IF company»«ELSE»«ASK company =?Enter company 
name.» «ENDIF» 

will only ask you for the company name for those records in which 
the company field is missing. 

Enter company neme. 

fT 

Figure 4-98 The ASK Dialog 

The message “Enter company name.” need not be there. You can 
also use one of the already defined fields in the message. 
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Example: The expression: 

«IF Address»«ELSE»«ASK Address =?Enter «company's 
address.» 

would give you a dialog with the message: 

“Enter Paragon’s address” 

assuming that it had picked up the company as “Paragon” in the 
data record. The entered address would then be used in the merged 
document. 

The SET instruction is also used to enter data from the keyboard. 
There are two different ways of using SET. 

Example: In this statement the field «budget» is set to $100,000 each 
time the Template document is merged with a data record: 

«SET budget = 100000» 

Example: This statement presents the dialog and asks you to enter a 
value for the budget field, but only once: during the merging of the 
first letter or document. All subsequent merged documents will use 
that same value of the budget. If you want a different entry for each 
data record you must use the ASK instruction. 

«SET budget =?Enter budget» 

You can also set one field equal to another such that it will keep the 
same value for each record used. For example: 

«SET FirstCompany = «company» 

which will set the field FirstCompany to be the name of the company 
in the first record, and will remain the same for the entire merge 
operation. 
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The INCLUDE Instruction 

The «INCLUDE Filename» instruction allows you to add to the 
template file the contents of the file whose name appears in place of 
“Filename.” 

Example: To include a “thank you” paragraph or two in the letter to 
some of your customers, place the following statement at the 
appropriate point in the file: 

«INCLUDE Thank You Note» 

“Thank You Note” is the name of a file which must be in the same 

folder as the Template Document. After the merge, the included file 
contents will replace the statement. 

Example: 

«INCLUDE ?Locate the file to be included.» 

When this statement is encountered you are asked to locate the file to 
be included. The message following “?” can be omitted. 

The included document may itself contain any instructions, including 
another INCLUDE statement. 

The NEXT Instruction 

Merge can be used to create mailing labels, where you may want 30 
or more labels on each page. Each data record normally produces a 
one page merged document. To force the next record to be merged 
without a forced page break, you use the instruction «NEXT» which 
means read the next record and use it for subsequent fields. 
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Example: If the following is in the Template Document: 

«DATA My Data File» 

«Name» 

«Address» 

«State» «ZIP» 
«NEXT» 

«Name» 

«Address» 

«State» «ZIP» 

The first two sets of names and addresses in the Data Document 
would be placed in the same merged document replacing the bracketed 
field names. 

The OMIT Instruction 

The OMIT instruction is used to omit the next record in the list. It is 
most useful after an IF test. For example if you have a list of customers 
and you only want to send letters to those outside the state of California, 
you can place the following instruction just below the «DATA...» 
instruction: 

«IF State = CA»«OMIT»«ENDIF» 

This will have the effect of omitting all records from California. If the 
opposite is needed, that is you want to send letters only to those in 
California, the following statement will do it: 

«IF State = CA»«ELSE»«OMIT» «ENDIF» 

(Alternatively you could use «IF State # CA»«OMIT»«ENDIF») 
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Field Indirection 

You can use a field inside a field. For example: 

««YourField»» 

which allows one more level of substitution: it places in the document 
the value of the field whose name is the substitution for «YourField». 
For example: 

«SET TheNameToUse =?Which name do you want to use in 
the salutation?» 

The template letter would then begin with: 

Dear ««TheNameToUse»», 

If the user responds with “first”, the field defined by «first» would 
be used, alternatively the user can respond with “last” in which case 
the field defined by «last» would be used. If the user responds with 
the name of a field which is not defined by the time the statement is 
reached, the merge operation aborts. 
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Advanced Examples 

The Data Document 

Tom,Berkley,Innovation Technology,1234 Minute Rd.,Templetown,MA 12345 Terrance.Atomby,,1234 Minute Rd .templetown,MA 12345 
Phillip,Barnaby,Computer Techniques Ltd.,2343 Billings Drive",” Suite 333, Alameda,CA 92123 

Definition Document 

firstname, last name,company,street,address,state,zip 

Template Document 

Name of document 

containing the Data 
Definition 

«DATA Definition Da ment,Data Document» 
«first names «last namew«lF Company» 
«Company»«ENDIF» 
ustreet» 

«address» «state» «zip» 

Name of document 
Dear «first name», containing the Data 
We are pleased to let you know that our new version of Nisus is ab but to ship. All we have to do is finish it! You will receive it atelF Company» «Company» or would you rather we sent it to «ENDIF» your home address«IF Company»? Please call us with your cme address if you would rather receive itthere.«ELSE » «ENDIF» 

Sincerely, 

Notice the period needed if Bill Weatherby question mark not present 
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Merged documents 

Tom Berkley 
innovation Technology 
1234 Minute Rd. 

Templetown MA 12345 

Dear Tom, 
We are pleased to let you know that our new version of Nisus is about to ship. All we have to 
do is finish it! You will receive it at Innovation Technology or would you rather we sent it to 

7 your home address? Please cal! us with your home address if you would rather receive it there. 

Sincerely, 

Bil] Weatherby 

Terrance Atomby 

1234 Minute Rd. 
Tempictown MA 12345 

Dear Terrance, 
We are pleased to let you know that our new version of Nisus is about to ship. All we have to 
do is finish it! You will receive it at your home address. 

Sincerely, 

Bill Weatherby 

Phillip Barnaby 
Computer Techniques Lid, 
2343 Billings Drive, Suite 333 
Alameda CA 92123 

Dear Phillip, 
We are pleased to Ict ie know that our new version of Nisus is about to ship. All we have to 
do is finish it! You will receive it at Computer Techniques Ltd. or would you rather we sent it 
to your home address? Please call us with your home address if you would rather receive it 
there. 

Sincerely, 

Bili Weatherby 
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Summary of Commands 

Instruction Meaning 
«DATA My File Name» .................. Used in Template to specify loca- 

tion of Data Document. 
CLA Pa SY siapecsties esate ees teint hol VOS Te locating dialog to locate 

Data Document. 
«DATA ?Message.....ecsesese AddS message to above. 
«DATA Definition Recd, Data File» 
sas wipe Sep echingsn asa hnaud ese sstedatetelvncnds Fither document name can be re- 

placed with ?Message. 
ePIC NAM Oris. hess acetic Used to designate field. 
«SET Field Name = value» ............. Value can be any text or number. 
«SET Field Name = ?prompt»......... Sets value once for all records. 
«ASK Field Name = ?prompt».......Asks for value once for each 

record. 
«INCLUDE Doc Name»................... Document must be in same folder. 
«INCLUDE ?prompt»............:..... Gives File dialog with prompt. 

The following possibilities and syntax illustrate the conditionals: 

«IF field» Text«Else»Text»«EN DIF» 
spe daatersan can apectausahesbebteslSnveavacuaves vidhduhieaehs True only if field tested has value, 

otherwise the text following ELSE 
is inserted. 

«IF field = value»Text«Else»Text»<ENDIF» 
shtactne eve eee devetasestebe cla Nisan came ete: Value can be either numeric or 

text. Numbers cannot include, 
commas, $, or hyphens. 

Other possible replacements for the “=” sipn are: 

Test Meaning 
<> Or # (Option =) wees Not equal 
GORA el cisinthaesates dances anatase costs Greater than 
Ske ateletaes eae dasa aaiehadisns se tebpeiaaRONRe Less than 
<= or $ (Option <) oc Less than or equal 
>= or 2 (Option >)... eee Greater than or equal 

190 CHAPTER FOUR 



File and Window Management 

You can open more than one document at a time in Nisus. Each 
document opened appears in its own window. This section describes 
how to manage multiple files and their windows and how to work 

with window panes. The commands discussed are Catalog... and 

Open Selection in the File menu and the various commands in 

the Windows submenu which is located in the Tools menu. 

The Catalog 

Nisus has many unique features which help you manage your files. 
One of these is the Catalog. Its primary function is to give you, from 
within Nisus, immediate access to the files and folders on your disk, 

but it has many more useful and powerful applications. 

¢ Its window can stay open during editing. 
e Files other than documents are displayed in its scroll list. 
e Each kind of file is preceded by its own unique, identifying 

icon which indicates whether the file ts open. 
* You can copy its contents onto the Clipboard. 
¢ You can select consecutive or noncontiguous files to open 

simultaneously. 
e You can use it to load glossaries, macro files, dictionaries, 

and user dictionaries. 
* You can use it to add documents (open or closed) to a search 

list. 

¢ You can view all types of files in the current folder. 
¢ You can search for a file or document name using the 

Find /Replace feature. 
* You can choose the font, size, and style in which you want 

the filenames to appear in the Catalog window. 
*« You can resize and place the Catalog window anywhere 

you want on your desktop, allowing longer file lists and 
names to be more visible. 

e You can view what disks (or partitions) you have loaded in 
your Macintosh. 
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@ File added to search list 
Q file of unknown type 
© Folder 
EW” Legal Glossary 
f2} MecWrite 4.6 document 
&> Medical Glossary 

Microsoft Word document 
iy’ My legal Macros 
fio My medical Macros 

My Stationery 
fe) Nisus Document 1 
[} Nisus Document 2 
b> Nisus Hyphenation 
fy Nisus iegal Dictionary 
LS Nisus medical Dictionary 
kt Nisus Preferences 3.0 
6} Nisus Thesaurus 
Ev opened file 
@ Qued/M an application 

Your Stationery 

Figure 4-99 The Catalog window enlarged to show ail file types 

Figure 4-99 shows how cach type of file in the Catalog is preceded 
by its identifying icon. Open documents and loaded files are preceded 
by shaded file icon with a check mark. 

Changing Attributes of the Catalog 

You may change the display attributes of the file names listed in the 
Catalog by using the Font, Size, and Style menus while the Catalog is the front-most window. To save the appearance of the Catalog, 
choose Save Preferences from the File menu. This will preserve 
the settings for future sessions of Nisus. 

You may move and resize the Catalog to any position on the desktop. 
When you zoom the Catalog, it will alternate between its current position and the upper right corner of the screen, where it appcars 
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initially. You do not need to save preferences to save this aspect of 
the Catalog's appearance. 

Searching for Files in the Catalog 

When the Catalog is the front window, you can search for a file or 
folder name by typing the first few characters of the name. 

You can also use the Find/Replace dialog to find file names in the 
Catalog. Jt searches the text in the Catalog, which is a Read Only 
window. 

Note that you can also search for a key word in the file name, but 
then only the key word is selected when it is found. To open the file 

or folder you have to click on its full name. If you try to use a 
with only a part of the name selected, you will get an error message. 

Displaying All Files in a Folder 

Choose Catalog... from the File menu and then choose All Files 
from the Catalog menu which appears to the right of the menu bar 
to view all types of files in the current folder. 

Using a Search List 

Use the Catalog to add files to your search list. When you have 
created such a list you can search through the designated files even 
though they are closed. See Searching Multiple Documents on page 
212 for more detailed information about using a search list. 

Its” If you want to open a second copy of a file, hold the Shift key down 
when you double-click the document name in the Catalog window. 
The second copy will be opened as Read-only. 
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Open Selection 

Use this feature to open several files in a project. Copy their file 
names from the Catalog and paste or type them into your current 
document or into a separate document. Whenever you want to open 
them all, select their names in the document and choose Open Selection. 
For example, if your current document requires frequent reference to 
particular files which are saved in different places, you might want 
to list them together in a single file so they can be opened all at once 
whenever you are working on that document. 

The files which you select must be in the current folder or they will 
ordinarily not be opened. 

In order to access a file in a folder other than the current one, precede 
the file name with a pathname. A pathname describes the path to 
where the file is stored on disk. The format is 

¢ Disk name:Folder name list:File name 

where Folder name list is a list of folders separated by colons. The 
current directory can be omitted if you precede the path with a colon. 

A full path name is one that begins with a disk name followed bya 
colon followed by zero or more folder names (each one separated by 
colons) followed by the file name. An example of a full path name 
containing the names of two folders and the file called Chapter 5 is 

* HD II:Manuals Folder:Nisus Manual: Chapters 5 

A partial path name is a path that begins at the current directory, 
that is a colon followed by zero or more folder names separated by 
colons followed by a file name. An example of a partial path name 
containing two folder names is 

e :Nisus Manual: Chapters 5 
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isus 3.0 MANUAL 3: Manual 3 :<omManual -ePManual 3 complete 

Macintosh HD System Folder Misus Macrese 
Macintosh HD System Felder ‘Nisux Glessarye 

Macintosh HD HardDisk Other : Nisus 3.0 MANUAL 3:<Manual 3 :buttons 
Macintosh HO Har dDisk Other :Nisus 3.0 bugs Harvey's bug list 
Macintosh HD HardDisk Other :<Nisus 3.0 bugs :3.0 Bug Reperts 

Macintosh HD :current werk Deme'‘status 
Macintosh HD ‘Har disk ‘Other -correspondence Envelope Stationer ies NRA Envelepe deme 

Macintosh HO current work Harvey's Diary fn 
Macintosh HD ‘Har dDisk ‘Other :<Nisus 3.0 MANUAL 3:<Manyal 3:<@Manual Manual 3 tcon index oe 

Macmtosh HD Har dDisk Other ‘correspondence Paragen Stationary |/:' 
Macintosh HD HardDisk Other :<Nisus 3.0: MANUAL Hints [2 

Macintosh HD ‘HardDisk ‘Other :<Nisus 3.0 MANUAL 3:<Manual 3 :coManual ManwalTemplate [/:: 
Macintesh HD -HardDisk Other :<Nisus 3.0 MANUAL 3:(Manual 3 :<@Manual ‘index terms [= 

See HIRES Bee: PESTA SGN pastes: sess tecthees bh iy: 

Figure 4-100 AS 

zr The macros Copy Pathname and Copy Open Pathnames (in 
the file Macros for Locating) can help automate this process. To set 
up a document with nothing but pathnames to files used in a particular 
project, first open all the appropriate files, then run the macro Cop y 
Open Pathnames (this copies the pathnames to the clipboard). 
Open a new file and paste the pathnames into it. You can then save 
the new file as “Open Selection Project X” as illustrated in Figure 
4-100 so that when you are ready to resume work on that particular 
project, all you need do is keep the one file on your desktop, open it, 
choose Select All from the Edit menu then choose Open Selection 
from the File menu. All files (unless their names and/or locations on 
disk have been changed) will then be opened. 

Windows 

Windows Submenu 

When you have multiple windows on your screen, it is easy to lose 
track of where they all are. The one you want may be buried behind 
others. Closing, resizing and moving windows to find it is 
inconvenient. The Windows menu will help you keep track. To 
bring the window behind the active window to the front choose 
Toggle Front 2. To send the active window behind all others choose 
Send Back. 
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To bring a window to the front, click on it, or choose its name from 
the Windows submenu of the Tools menu. 

Is You can also access the Windows submenu by pressing the Option 
or Command key while clicking on the Title Bar of any window as 
ilustrated in Figure 4-101. 
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Figure 4-101 The Windows submenu from the Title Bar with Change 
Indicator icons showing 

I's The Change Indicator icon appears before the name of any file the 
window of which is open and has been changed. 

Click anywhere within a window to select it. This will bring it to the 
front. The front window is called the active window. It is the window 
which accepts characters as you type. 

Another way to bring a window to the front is to open it using the 
Open... command. If the file is already open, it will just be brought 
to the front. If you have a large screen, you can place the Catalog 
window to the side and leave it open. While closed Nisus documents 
are indicated by a simple file icon [e} the icon of open documents 

masee 

Btees will be grayed and show a check mark in the Catalog window Hig”. 
Double-click on the document you want to bring to the front. 

Zooming Windows 

To zoom a window, click its zoom box HJ in the Title Bar. You may 
also double-click the Title Bar, a feature useful when the zoom box is 
inaccessible. 
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Zooming a window causes it to change its position and size. This 
allows you to edit and read your document more easily, although it 
may cover up other windows behind it. You may return the window 
to its previous size by zooming once more. On a small screen the 
window will fill the screen. On a big screen it will assume a size 
slightly larger than the full page but will not fill the screen. 

i If you hold Shift while zooming a window, the active window and 
the window behind it will be arranged side-by-side. This is useful for 
viewing the two most recently active windows simultaneously. See 
Synchronous Scrolling of Two Windows, page 200. 

Stacking and Tiling Windows 

To arrange all the windows in an orderly fashion choose $tack or 

Tile. When you $tack windows they are placed on top of one another 
as in Figure 4-102. 

" € File Edit Tools Format Font Size Style 10:35:46 AN 
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Figure 4-102 Stac 

The currently active window is placed on top of the rest, with the 
Title Bar of each window showing. This way, you can see the names 
of all your windows and sclect the one you want to bring to the 
front. 
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ig You can stack all windows by holding Shift and Option while zooming 
the front window. 

Windows can also be arranged in the tiled format. This will fit as 
many of your windows as possible into the available screen space 
without overlapping them. Choose Tile to produce the result seen in 
Figure 4-103. 
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Figure 4-103 Tiled Windows 

A convenient way to work with tiled windows is to leave all but one 
of them tiled, zooming just the one you wish to work with. This will 
cause the window to fill the screen, so that you can see as much of 
your document as possible. When you have finished working with 
the window, zoom it back into tiled formation and repeat the process. 

ts” Tile the top two windows by pressing Shift while zooming the front 
window. You can also tile all windows by pressing Option while 
zooming any one of them. 

Ls” It is possible to lose a window by moving it off your screen. If just a 
small part of it is showing, it may not be easily noticeable. To bring it 
to the center of your screen, choose its name from the Windows 
submenu of the Tools menu or from the Windows menu which 
you can pull down from the Title Bar while pressing the Option or 
Command key. 
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Working with Background Windows 

Background windows are those which are not active. It is sometimes 
convenient to work with a window without making it active (bringing 
it to the front). You can use the mouse to move the insertion point 
and select text In background windows just as in the active window. 

To affect a background window, hold down Command while you 
press the mouse button. This will enable you to select text, change a 
control, scroll or move a window without making that window active. 
This is very helpful, because bringing a window to the front will 
often cover the window you are working with. 

For example, when using the Find/Replace dialog, you can scroll 

through the window behind it and even set the position of the insertion 
point without bringing it to the front. If you brought it to the front, it 
would cover the Find/ Replace dialog. 

= Because the close box is not visible in background windows, you arc 
protected against closing them accidentally. To close a background 
window click in the region where the close box is normally displayed 
while pressing both Command and Option. 

I> When you apply a command that brings up a dialog, the decisions 
made in that dialog will apply to all open windows if you hold down 
the Option key while clicking a button. For example, to save all open 
windows at once, hold down Option while choosing Save. Similarly 
you can apply the following commands to all open windows by 
holding down Option and choosing: 

« Save (becomes save All Changed) 
e Close (becomes Close All) 
e Revert To Saved (becomes Revert Al! Changed) 
* Any command in the Display submenu 
e Show Headers/Footcrs icon, Paragraph Rulers icon 

« Select All (becomes Select All Docs) 

e Print... (becomes Print All) 
e AFont, Size, or Style menu command 

See the Nisus Quick Reference Guide pamphlet for more details. 
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iz” When using the Print All command in conjunction with background 
printing using MultiFinder, the Print Monitor will only display the 
name for the first document, but, in fact, all files will be printed 
correctly. 

synchronous Scrolling of Two Windows 

When you are viewing two documents with similar contents, you 
may want them to scroll together. This is especially useful for 
comparing an original document with a revision. Choose Sync. 
Scrotling from the Edit Tools submenu in the Tools menu to 
cause the top two windows to scroll together. 

When either window’s scroll bar is used, both windows will scroll 
the same amount—the scroll bars are locked together. To turn off 
Sync. Scrolling, choose it again. 

When a window's scroll bar is synchronized with another window's 
scroll bar and the Info Bar is shown for that window, the Sync Scrolling 
icon Bee appears in the Info Bar. 

i" You can also scroll the top two windows together by holding down 
the Shift key when clicking on the scroll bar of the top window. 

i To align the windows side-by-side, make sure they are the top two 
windows by clicking in one and then clicking in the other. Hold Shift 
and zoom one of them. 

Splitting Windows 

To look at separate parts of your document at the same time you can 
split your window—horizontally, vertically or both—into panes as 
shown in Figure 4-103. 
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A window canbe splitinto | A window can be split into 
as many as four panes. | as many as four panes. 
Each of these panes shows | Each of these panes shows 
an independent view of the | an independent view of the 
same document and can same document and can 
be individually scrolled. | be individual scrolled. 

Be be individually scrolled. | be individually scrolled. 
The rulers indicate ac- The rulers Indicate ac- 
curately foreach window. | curately for each window. 

Drag the Horizontal MB or Vertical : Split Screen Bar handle along 
the scroll bar. Release the mouse where you wish to divide your 
window. The window will look the same except for the split line 
running through it, and the scroll bar will be split into two scroll 
bars. 

As you edit your document in any pane, changes affect all panes 
because all panes are views of the same document. Any selection 
made in one pane will be selected in all other panes when they are 
activated. 

When you use the scroll bars, you activate the pane that is controlled 
by that scroll bar. In windows which are split both horizontally and 
vertically, the four panes created by the double split can be scrolled 
by four independent scroll bars. The last horizontal and vertical scroll 
bars used determine the active pane. 

You can think of the four panes as a grid with four sections: top and 
bottom on the left side and top and bottom on the right side. To 
activate the top left section, scroll in the bottom left bar (to locate the 
insertion point on the left side), then scroll in the top right bar (to 
locate the insertion point in the top half of the window). 
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i” The pointer becomes an I-beam | when it is moved over the active 

pane. In any other pane, it is an arrow h. 

You may close a pane by dragging the split bar to one end of the 
scroll bar or by double-clicking it. 

Windows and Multiple Screens 

When a window is opened, Nisus displays it on the screen that contains 
the pointer. If you have multiple screens, you can open one window 
on one screen, move the pointer over to the second screen and open 
another window. The first window will be displayed on the first 
screen and the second window on the second screen. 

Dialog boxes are displayed on the screen that the pointer is on. 

Stacking or tiling windows will affect only those windows which 
intersect the screen where the pointer is located. 
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5 
Finding and Replacing Text 

This chapter introduces you to the basics of the find and replace 
facility of Nisus. It explains how to find some occurrence of text or 
graphics and replace it with another. It shows how to set the search 
options and then explains how you can search for text in a particular 
font, style or size. It also explains how to search in several open or 
closed files. The concept of pattern matching is fully developed in 
Chapter 12, page 331 and Chapter 13, page 353 

Although most of what follows in this chapter is geared to finding 
and replacing text, it also applies to graphics on the text sheet. See 
Chapter 7: Working with Graphics, page 233 for an explanation of the 
text and graphic sheets. 

Nisus offers a wide range of find and replace capabilities. You can 
search for text or graphics in three ways: 

* Normal Search: Nisus searches for whatever word, phrase, 
or sequence of characters (and graphics) is specified. It can 
also restrict searches to text in a particular font, style, size or 
any combination. 

¢ PowerSearch: With the help of menus, Nisus offers a 
simple way to write descriptive searching patterns used for 
pattern matching. This is explained in Chapter 12. 

¢ PowerSearch+: is a very powerful method for finding 
patterns and character sequences using a form of shorthand 
called “regular expressions” dealt with in Chapter 13. 

You can search for text or graphics in: 

¢ A selected area of text 

¢ The current file 

_ © All open files 
° All files in the search list 
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You can specify whether to search forward or backward from the 
insertion point. You can tell Nisus to continue searching and wrap 
around the end of the document for a forward search, or the beginning 
for a backward search. 

You can also search and replace Character Graphics. See Chapter 7: 
The Text Sheet: Character Graphics page 236 for the definition of 
Character Graphics. You can copy a graphic, paste it into the 
Find/Replace dialog and then search or replace it. 

The Nisus Find/Replace dialog window can be thought of almost as 
any other window. When it is active almost all of Nisus' menus are 
still enabled. You can open various files, sort paragraphs, show and 
edit your clipboards, access your Glossary, use your macros, number 
lines, etc. 

Finding Literal Text 

1. Choose Find/Replace... from the Tools menu. The 
Find/Replace dialog appears on your screen as shown in 
Figure 5-1. 

Normal Search 

fj Ignore Case [) Whole Word &) Wrap Around | 

Replace, then Find Repiace All 

The Search Direction 

The Replace/Index Pop-up Menu 

The Search Options 

Figure 5-1 The Find/Reptace Dialog 

2. Type the text you want to find in the Find box. (The Find 
box can contain morc than one line; sometimes not all is 
visible. Move the | - beam up and down to see all the lines 
or click the Find/ Replace window's zoom box to expand it.) 
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3. Click the desired search options and when you are ready to 

start the search, click (Find } or press Return or Enter. 

The first occurrence of text closest to the current selection or insertion 
point will be selected (above or below, depending on the direction of 
search). Nisus can display a dialog whenever a match is not found as 
illustrated in Figure 5-2, or simply beep. You can set the searching 
preferences either way, as explained page 445. 

keyboard: Text not found 

Figure 5-2 The literal text was not found 

To find the next occurrence of text, click [Find } again or press 
Return or Enter. When you have finished, close the Find/Replace 
dialog. 

You will also see the Search Method menu shown in Figure 5-3 
appear at the far right of the menu bar. 

Search Method 

“Find Text Only 
Reptace Text Only 

“Search Active File 

Search All Open 

Search File List 

Figure 5-3 The Search Method menu 

Search Options in the Find/Replace Dialog 

Ignore Case 

To make Nisus match both uppercase and lowercase characters, type 
the characters exactly as they should be found and uncheck Ignore 
Case. A search for the word “Happy” would not find “happy.” With 
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ignore Case checked both “Happy” and “happy” would be found. 

Whole Word 

To prevent Nisus from finding parts of words, check Whole Word, 
so that a search for the word “hat” would not stop at the word “that.” 

te" You may check Whole Word to search for a phrase of several words. 
The only condition required is that the text being searched begins at 
the beginning of a word and ends at the end of a word. For a definition 
of what constitutes a word in Nisus, see Word Definition in Nisus 
page 376. 

Wrap Around 

If Wrap Around is checked, the search starts at the insertion point 
or the selected text, and continues to the end of the document and 
then starts over from the beginning. With Wrap Around unchecked 
the search terminates at the end of the document. 

Search Direction 

To change the direction in which Nisus searches relative to the current 
selection or the insertion point, click on one of the two arrows in the 
Find/Replace dialog. Click the down arrow icon to search forward 
(from the insertion point to the end of the document). Click the up 
arrow icon LE) to search backward (from the insertion point to the 
beginning of the document). 

Finding White Space 

You can search for white space characters such as tabs, returns, and 
spaces. When you import documents from data base programs or 
communication programs, you may find that it is essential to search 

206 CHAPTER FIVE 



for tabs and replace them with returns or vice versa. To display the 

white space as symbols, choose $pace, Tab & 4 from the Display 

submenu of the Tools menu. 

Hold the Shift key down and press Return or press Tab respectively 
to add a return or a tab character to the find text in the Find box or 
the replacement text in the Replace box. Nothing will be visible. 

ts Be careful when deleting return characters which have anchored to 
them graphics, rulers, headers and footers, these will be removed 
when their anchoring return characters are deleted. 

Finding All Occurrences 

Normal Search || keyboard 

st Ignore Case Cj Whole Word &) Wrap Rround 

Figure 5-4 The Find/Replace dialog with Option pressed 

To find all occurrences of a particular word or expression typed in 

illustrated in Figure 5-4). If the Find/Replace dialog window is not 
the front window, press the Option key and choose Find AH from 
the Tools menu. This will select every occurrence of the found text 
and give you a dialog box illustrated in Figure 5-5 telling you how 
many occurrences of that expression appear in your document. 

212 found. 

Figure 5-5 The Result of the Find Ail Command 
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Finding Text with Attributes 

You can set the attributes of the text in the Find and Replace boxes 
directly from the menus. You can also paste text with attributes into 
the Find/Replace dialog. Changing the attributes in the Find box 
will make the search attribute-sensitive. Changing the attributes in 
the Replace box is discussed later. 

Font and Size Attributes 

To search for text in a particular font or size, type the text to be 
found in the Find box, select whatever portion is to be attribute 
specific, and choose the appropriate font, size, or a combination of 
these from the Font and Size menus. To search for text without 
regard to any font or size, choose Any Font or Any Size from the 
Font or Size menu respectively. For example, a search for the word 
“hellO- in Helvetica and finy Size would match the word “hello” (9 
point Helvetica) and also “hello” (14 point Helvetica), but “hello” 
in the Times font would not be found. 

style Attributes 

To search for text in a particular style or a combination of styles, 
uncheck + Any Styles from the Style menu and choose the 
appropriate styles from the Style menu. + Any Styles matches 
any styles other than plain. For example, with Bold and+ Any Styles 
checked, a search for the word “pretty” (Bold) would also find “pretty” 
(Bold /talic) and “pretty” (Bold Underline) but would not find 
“pretty” (Plain). 

Finding Text Only (Ignore Attributes) 

To search for text without regard to any attributes, activate the 
Find/Replace dialog and check Find Text Only in the Search 

208 CHAPTER FIVE 



Method menu. You can achieve the same result by selecting the 
typed text in the Find box and choosing Any Font and Any Size 
from the Font and Size menus, respectively, and then choosing 
Plain and checking+ Any Styles from the Style menu. 

Finding User Styles 

A user style is identified by the name you give it, not just by its 
attributes. For example if you create a user style called “Boldvetica” 
which is 12 point Helvetica Bold, text typed in Boldvetica will look 
the same and print the same as text typed using 12 point Helvetica 
Bold. The two are indistinguishable to the user, yet they are, in fact, 
recognized by Nisus as different. You would notice the difference if 
you edited Boldvetica’s size from 12 to 14 point. The text in Boldvetica 
would immediately reflect the change, whereas the text in 12 point 
Helvetica Bold would remain unchanged. 

Nisus recognizes the difference between text in a user style and text 
with identical attributes but not in the user style. When the 
Find/Replace dialog is the front window you can search for any user 
style as though it were any other style. Select the text in the Find box 
and choose the desired user style or styles from the Style menu. If 
you paste text with a user style into the Find/Replace dialog, the 
user style name will appcar in the Style menu as checked as well as 
all of its attributes. Therefore in your search for text in a particular 
user style you will only find text in that user style. 

Replacing Text 

. Choose Find/Replace... from the Tools menu. 
. Type the find text in the Find box. Set the search options. 
. Click in the Replace box and type the new text. 
. Click (ring } or press Return or Enter when you are ready 

to start the search. If the text is found: 

° Click | Replece, then Find | to change this occurrence of text 
and then find the next one. This is useful when you want 
to replace some, but not all, instances of the old text. 

hm Wh a 
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e Click to change this occurrence only. 

e Click to replace all occurrences of the text 
from the selection to the end (or throughout the entire 
document if Wrap Around is checked). 

To replace a selection of text and then find the next occurrence of the 
old text without activating the Find/Replace dialog, press the Shift 
and Command keys and choose Replace & Find from the Tools 
menu. 

ter CAUTION: If no text is typed in the Replace box and 1S 
clicked, then the found text will be replaced with nothing. That is, it 
will be removed. 

Finding and Replacing in a Selection 

When you wish to find and replace in a selected region of text only, 
press the Option key. The buttons in the Find/Replace dialog will 
change as illustrated in Figure 5-4. Click sie (rmolinsomctien) to 
find all occurrences in the selected region or to replace 
all in that selected region. You can also do a replace all in a selected 
region by pressing the Option and Command keys while choosing 
Replace in Selection from the Tools menu. 

Replacing Text with Attributes 

To make the replacement text have specified font, size and styles, 
select it, uncheck + Any Styles and choose the appropriate font, 
size, and styles from their respective menus. For example, a replace 
of all found occurrences of the word “fish” (Bold and + Any Styles 
checked) with “birds” (Outline checked and + Any Styles 
unchecked) would find “fish” (Bold), “fish” (Bold Underline), and 
“fish” (Bold Italic) and replace them with “birds” (Outline) but would 
not find “fish” (italic). Note that if the replacement text had + An y 
Styles checked the styles of “fish” would be applied to “birds” so 
that “fish” would be replaced by “birds” (Bold, Outline, Underline). 
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im” Note that for the replacement text to be attribute—-sensitive, Replace 

Text Only must be unchecked in the Search Method menu. This 
command is normally checked by default but when you select the 
replacement text and choose a font, a size, or a style it is automatically 
unchecked. 

Replacing Text Only; Ignoring Attributes 

If you wish the replacement text to take on the same attributes (font, 

size, and style) of the found text make sure Replace Text Only 

from the Search Method menu is checked. When this command is 
checked, the replacement text takes on the attributes of the first character 
of the found text. 

Note that if a graphic is part of your replacement pattern and Replace 

Text Only is checked, the replacement will replace what it finds 
with the unlikely ASCII code 01 in place of the graphic. 

Cancelling a Search 

To cancel a search press Command % and hold down Period (.) until 
the search stops and you get a dialog which reads “Process aborted 
by user.” If you stop a Replace All command before it completes 
the replace, no replaces will have been made. After such an abort 
you can get a partial replace by choosing Redo Change All from 
the Edit menu. 

Finding and Replacing Graphics 

You can find and replace character graphics, that is graphics that 
have been pasted on the text sheet. You cannot search for graphics 
on the graphics sheets. If you check the Find Text Only command 
from the Search Method menu, the search for a graphic will find 
any graphic in the text. If Find Text Onty is not checked, the search 
for a graphic will find only those graphics whose pixel height and 
width, as indicated in the $ize menu (Other) match exactly the one 
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pasted into the Find box. Because graphics usually differ in size, the 
search often identifies the searched-for graphic uniquely. You cannot 
create a graphic in the Find/Replace box, but you can paste one 
there. (A character graphic has an ASCII code equal to 1.) 

You can replace a graphic with a graphic or with text and vice versa, 
but you must have the Replace Text Only command on the Search 
Method menu unchecked. Graphics can also forma part of a searching 
pattern just like any regular character. 

Ke” Note that you cannot search for graphics on the graphics sheet. Though 
the Find/Replace... command is enabled while on the graphics 
sheets, any searching done will not select or replace text until you 
return to the text sheet. 

Searching Multiple Documents 

Normally when using the Find /Replace dialog, only the front 
document is searched. In Nisus, multiple documents, whether open 
or closed, can also be added to the list of searched documents. When 
the Find/Replace dialog is active, the Search Method menu, as 
shown in Figure 5-3, page 205, appears on the far right of the menu 
bar. The Search Method menu contains the following commands: 

¢ Search Active File 

* Search All Open 

« Search File List 

Choose Search Active File or Search All Open as appropriate. 
The Search File List command is highlighted and checked when a 
search list is created. 
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Creating the Search List 

To search through closed documents, you first create a search list. To 

do this, activate the Catalog window by choosing Catalog... from 
the File menu. When the Catalog window is active, the Catalog 
menu appears on the far right of the menu bar. 

Adding Files to the Search List 

To add a document to the search list, select its name from the Catalog 
window and choose f'dd To Search List from the Catalog menu. 
Folders cannot be placed into a search list directly; you must open 
them and select the files to be added to the search list. Note that 
documents added to the search list do not have to be in the same 
folder. All documents on the search list are marked with an eye icon 
€& as illustrated in Figure 5-7. 

Removing Files from the Search List 

To remove a document from the search list, select the document and 
choose Remove From Search List. Documents that have been 
searched are automatically removed from the search list. 

ts The menu commands Add To Search List and Remove From 
Search List are enabled when files are selected in the Catalog 
window, as illustrated in Figure 5-6. The Catalog menu appears 
only when the Catalog is the front window. 

Ks” It is possible to remove all files from the search list simultaneously. 
Press the Option key and choose Clear Search List from the 
Catalog menu. 
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Catalog 

Nisus"™ Only 

/Nisus™ Readable 

Nisus™ Macro 

Nisus™ Glossary 

Nisus™ Dictionary 

Microsoft’ Word 

MacWrite™ 

All Files 

Read Only 

Add fo Search List 

Remove From Search List 

= == Catalogo SS" 

[e} Beta testers 
@ compare Nisus 

@ Desiderata i 
(8) Desiderata hierarchical list}: 
@& Mw is N™ Wrd Pressr Dffrnt]::: 
fs) Nisus 2.5 new features He: 
@& the Nisus™ story 
@ The Nisus™ Way 
@& The Nisus Way 

< Macintosh... 

Figure 5-7 Files in the search list are preceded by an eye icon 

Global Search 

After creating the search list, reactivate the Find/Replace dialog and 
make sure that the Search File List command in the Search 
Method menu is checked. Finally, choose the search options and 
press Return or Enter to start the search. When a match is found, 
Nisus opens the document containing the matched text, and scrolls 
to the selected text. As documents are searched they are removed 
from the search list. 

_ (> You can save and restore the search list using the supplied macros 
Save Search List and Restore Search List. 
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Tips and Special Techniques 

As you become more familiar with the find and replace facility of 
Nisus, the following tips and techniques will be very useful. 

¢ Text can be selected, copied and pasted from any document 

into the Find/Replace dialog and vice versa. 

¢ To insert an explicit return or tab in the Find/Replace dialog 
press Shift and then press Return or Tab. 

* Most buttons and check boxes in the Find/Replace dialog 
have Command key equivalents, press Command to see them. 

¢ The Tab key moves the insertion point back and forth between 
the Find and Replace boxes. If there is text in either box, 

that text is selected. 

* When using Find/Replace be aware of any extra spaces or 
tabs in the search or replace text. (Choose Space, Tab & 4 

from the Display submenu of theTools menu). 

* To find the next occurrence of text without bringing the 
Find/Replace dialog to the front, press Shift and choose 
Find Next from the Tools menu. 

e Select text and choose Copy to Find from the Tools menu 

to enter text directly into the Find box without bringing the 
Find /Replace dialog to the front. This can also be done by 
pressing Command while double-clicking and dragging to 
select the text (only if you have not created and loaded a 

Command macro). Note that the text selected will be entered 
into the Find box in the same font, style, and size as it 

appeared in the documents, however, it will turn on the 

Find Text Only command in the Search Method menu. 

The Search Method menu will not appear unless the 
Find /Replace dialog is the front window. 

* Select text press the Option key and choose Copy to 
Replace from the Tools menu to enter text directly into 

the Replace box without bringing the Find/Replace dialog 
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to the front (this works only if you have not created and 
loaded an Option macro). Note that the text selected will 
be entered into the Replace box in the same font, Style, and 
siZe as it appeared in the documents, however, it will turn 
on the Replace Text Onty command in the Search 
Method menu. The Search Method menu will not appear 
unless the Find /Replace dialog is the front window. 

You can use the Find/Replace dialog to index all occurrences 
of a word or phrase. See Chapter 12 for more details. 

To clear the Find/Replace dialog of all text and attributes 
tab from one text editing box to the other and clear each one 
in turn. Then close the window. When you reopen the 
window, it will be in Any Font, etc. 
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6 
Working with the Spelling 

Checker and Thesaurus 

The file: Nisus Thesaurus is actually a combination dictionary and 
thesaurus, displaying both definitions of the less common meanings 
of words and their synonyms. The Spelling Checker has 135,000 words 
while the Thesaurus has 1.4 million responses at 40,000 entry points. 

Loading the Dictionary 

When you are ready to check the spelling of your document choose 

Spelling... from the Tools menu. If this is the first time you have 
checked your spelling, Nisus will attempt to locate the dictionary. If 
the dictionary is in a folder other than Nisus or the System Folder 
you will be asked to find it. Figure 6-1 illustrates this dialog. If you 
want to keep your dictionary in a different folder, you can avoid this 
dialog by setting your dictionary preferences in advance (see 
Dictionaries Preferences page 451). 

Please locate a dictionary. 

& Folder 

LU Nisus Source 

© folder 

Cm MPWw 

© Nitus Folder 

CC Nisus Manual 

© Papers 

© System Folder 
© Utilities 

Figure 6-1 Finding the Dictionary 
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Find the file Nisus Thesaurus and open it in the same way as you 
open a document. Note that in this context, “open” really means 
load. The only evidence that the dictionary is loaded is a check against 

maeae 

its name in the Catalog window: #i¥. If the dictionary cannot be 
found or the file Nisus Hyphenation file is missing, the dictionary 
will not be loaded. If you can see the dictionary in the folder but 
cannot load it, make sure the Nisus Hyphenation file is also present 
in the same folder. 

te" If you have more than one dictionary supplied by Paragon,’ you 
may change dictionaries at any time by opening another one through 
the Catalog or Open File dialog. 

Close box Skips current word Skips all instances o 
current word 

[ SE Spell Checking: Untitied~2 Em a =a 
Unknown Word: 

Condition: Misspeticd word 

Replace With: Replaces 

current 

word 

start L fherk ise 

Check Word Suggestions: 

LI €dit User Dictionary 

Repiaces all 
Marks word so that it is never checked again in that document instances of current word 

Figure 6-2 The Spell Checking dialog 

Spell Checking 

To check the spelling of the front document choose Spelling... from 
the Tools menu. This brings up the Spell Checking dialog illustrated 
in Figure 6-2. If you want to check for errors in headers, footers, 
footnotes, macros or the glossary, their windows have to be open 
and active. 

When an unknown word is found, you will be given as many as 16 
correctly-spelled suggestions. The spelling checker also flags words 

‘For information on what dictionaries are available, call Paragon at 
619-481-1477. 
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it does not know, lowercase letters at the start of sentence, and repeated 

words. This does not necessarily mean that they are misspelled. What 
the Spelling Checker docs in these cases is explained in Checking for 
Other Errors on page 225. 

When the Nisus Spelling Checker finds a word not in its dictionary, 
it suggests alternatives and allows you to correct it. You can use the 
Spelling Checker to check individual words which are typed directly 
into its dialog. The Spelling Checker is available at al] times. 

You are able to set the starting point of the spelling checker by changing 
the position of the insertion point. Ordinarily, changing the insertion 
point brings the document window to the front, but pressing and 
holding the Command key while you scroll and/or move the insertion 
point allows you to leave the document window behind the Speil 
Checking dialog, and thus to continue spell checking. 

I” When you do click in the document window to move the insertion 
point you will be required to restart the spelling checker. Click 

}] from the new position. 

When using machines with large or multiple screens, the Spell 
Checking dialog can be visible at all times. This allows all the 
suggestions or words in the user dictionary to be available while 
editing a document. 

You can use the arrow keys on the keyboard to navigate in the Spell 
Checking dialog. 

Memory of Position 

The spelling checker remembers where it is in the document even 
when its dialog is not the front window or is closed. If you bring the 
spell Checking dialog to the front, you can continue checking from 
where you stopped. It will forget its position if you edit the document 
or bring another document to the front and you will have to click 

[Start Checking} in the spelling dialog. 
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Spell Checking Your Entire Document 

To spell-check an entire document, place the insertion point at the 
spot where checking is to begin and click in the Spell 
Checking dialog. 

Words are checked between the insertion point and the end of the 
document, and then checking continues from the beginning of your 
document to the starting point. When the whole document has been 
checked, the Spelling Checker beeps and displays the message No 
more misspelled words found. 

During the spell checking session you may want to edit your document 
directly. If this happens you must restart the spell checking session 

[Start Checking) Checking] by clicking once again. 

spell Checking a Selection 

If you have a selection rather than an insertion point in your document, 
only that selection is spell-checked. The spelling checker starts at the 
beginning of the selected text and stops at the end. Then the insertion 
point is placed back at the beginning of the selection. 

spell Checking a Word 

You can check the spelling of a word by typing it in the Replace 
With box of the Spell Checking dialog. Click to verify 
the spelling of the word in the Replace With box. This will not 
interfere with the process of spell-checking the entire document. If 
the word is misspelled suggestions will be given as in Figure 6-2. If it 
is spelled correctly you will see the message The word is spelled 
correctly in the Condition field. 

220 CHAPTER SIXx 



The Spell Checking Dialog 

The Replace Suggestions 

When the Nisus Spelling Checker finds a word not in its dictionary, 
it suggests alternatives and allows you to correct it. You can use the 
Spelling Checker to check individual words which are typed directly 
into its dialog. The suggestions given are based upon both the actual 
characters and the phonetic sounds of the unknown word. 

Figure 6-2 on page 218 shows the Spell Checking dialog with nicki as 
a misspelled word. A phonetically chosen suggestion lower down in 
the scroll list is knack. lt uses a kn combination in place of the n in the 
unknown word since these phonemes make the same sound. 

If you cannot find the word you want in the suggestion list click the 
unknown word in the dialog to bring it into the Replace With box 
and edit it. 

Replacing words 

Use the scroll list to view suggestions for misspelled words. Click 

one of them to place it in the Replace With box. Replace the word 

in your document with the word in the Replace With box by 
clicking (Replece }. 

Skipping Words 

if the Spelling Checker comes upon a word that it does not recognize, 
yet ts accurately spelled, clicking will leave the unknown 
word unaltered. Click [ Skip ail |to have the spelling checker ignore 

all appearances of a word during a spell checking session. 

Instead of skipping a correctly spelled but unknown word, you ma 
add it to the user dictionary. When such a word is found, click 

If no‘user dictionary is loaded, Nisus prompts you to locate a User 
Dictionary. If you wish to create a new User Dictionary, click 
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then click (_fdd_). Any time spelling is checked, Nisus will also 
automatically search for those newly added words in your customized 
dictionary, provided that it has been loaded. If a user dictionary is 
loaded, the Spelling Checker will not flag the words in it. The user 
dictionary is explained in detail beginning on page 223. 

There are a variety of ways to have the Spelling Checker skip words 
that might otherwise be flagged. 

* Skip the word in a session of spell checking by clicking Csi Jor(sep a) 
¢ Mark the word in a particular file so that it is never again 

flagged in that file by clicking (__Ignere _}, 
¢ Apply a User Style with the attribute Ignore to a word or 

phrase. 
¢ Add them to a user dictionary. 

Skip All 

Words skipped with are kept in memory, so spelling 
checking is faster than using a user dictionary, but they are forgotten 
when you quit Nisus. 

The Spelling Checker is session oriented, rather than document 
oriented. Any new words Nisus learns when you click are 
remembered across documents until you quit the program. This makes 
it easy to check many documents at once. 

If you accidently click on a misspelled word, you will 
have to quit Nisus and reopen it to make the spelling checker erase 
its memory. It is recommended that you add your own special words 
to your own custom dictionary. 

ts” When the Spelling Checker dictionary is re-loaded (by clicking on 
the spell checking dictionary you have loaded, either Nisus Dictionary 

ethan 
weeane or Nisus Thesaurus, whichever has the check mark fi showing 

beside its name in the Catalog window) all memory of the “Skip 
All” list is lost. This releases the memory taken up by that list. This is 
the easiest way to clear that list during a spell checking session. 
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Ignore 

Click to have Nisus ignore a particular word in a file 
that it does not recognize. This will cause the Spelling Checker to 
mark a specific word and bypass it without entering it into a user 
dictionary. The Spelling Checker will never again flag that word in 

~ that file/document. The Spelling Checker will, however, flag that word 
in all other files in which it appears, unless it has been “ignored” 
there as well. 

You can create a user style that will be ignored by the Spelling Checker. 
Choose Define Style... from the Style menu, then, when you 
determine the various attributes of the style, click Ignore Spelling 
This is especially useful if your text has extensive numerical strings, 
expressions in foreign languages or uses foreign language, or character 
fonts that would not be recognized by the Spelling Checker. 

Ignore Spelling 

You can define a user style with the attribute Ignore Spelling. 
This style can then be applied to words, phrases or formulas that you 
want the Spelling Checker to avoid. This is particularly useful if you 
use foreign language or symbol fonts or if you use specialized 
terminology that places option or number characters in the middle of 
words. For detailed information on how to define user Styles see 
User Styles and Style Sheets beginning on page 110. 

User Dictionaries 

You can increase the vocabulary of the spelling checker by adding 
words to a user dictionary. You can have any number of uscr 
dictionaries, but only one of them can be used at a time in addition 
to the main dictionary. 
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Creating a User Dictionary 

You can create additional user dictionaries by clicking (New _) while 
the Spell Checking dialog is open. Type its name and click 
in the dialog that comes up, as shown in Figure 6-3. 

When you open Nisus, the user dictionary Nisus User Dictionary is 
loaded automatically, provided it is in the same folder as Nisus or in 
the System Folder (or have set your Dictionary Preferences differently). 
If you wish to use a different user dictionary, double-click on its 
name in the Catalog window. This closes the current dictionary and 
opens the new one. You can verify this by checking the Edit User 
Dictionary box in the Spell Checking dialog and then looking at its 
contents. 

&) Dictionary & Thesaurus 0... 

f? BRILAYP — Macintosh HD 
(2 ENDEND 

Mm ENG.YP 
2 ENDIOLEY 
i? ENGPHON VEN Drive 

Nisus Dic tionary 
ry Nisus Thesaurus 

Create User Dictionary As: 

My Legal User Dictionary 

Figure 6-3 Creating a user dictionary 

Editing a User Dictionary 

To edit the current user dictionary, check Edit User Dictionary in 
the Spell Checking dialog. The dialog will then display the contents 
of the current user dictionary in its scroll list as illustrated in Figure 
6-4. 
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i eres Spell Checking: "Manuel 3 complete aise 
User Dictionary Nisus User Dictionary Skip 

Skip AL Rdd/Remove Start { heeking| 

User Dictionary: Fleplace fig 

- QWERTY 
Reconfig. fil 
reconfig.fil 
reconfiguration 

Figure 6-4 Editing the user dictionary 

To add a word, enter it into the Add/Remove box and then click 
(add __}. To remove the word, click (Remove). You can transfer words 
from the scroll list to the Add/Remove box by clicking them. Then 
you can edit them and click to replace the old version of the 
word. 

Uncheck Edit User Dictionary to resume spell-checking. 

fe You can also add words without explicitly editing the user dictionary. 
When the spelling checker finds an unknown word, it can be added 
to the current user dictionary, if it has been loaded, by clicking on 
the activated button. Any user dictionary you have named 
“Nisus User Dictionary” and placed in the same folder as the Nisus 
application or in your System Folder will load automatically. 

iis User dictionaries are case-sensitive, so pay close attention to the 
capitalization of words in the user dictionary. 

ier You can create an individualized user dictionary by creating a file 

with a word list and running the macro Add to User Dictionary. 

Checking for Other Errors 

The Nisus Spelling Checker does more than just check for misspelled 
words. It looks for other possible errors. This section explains the 

- following messages: 
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¢ First word of sentence not capitalized 
¢ Incorrectly formed word 
¢ Misspelled word 
« Repeat of last word 

First Word of Sentence not Capitalized 

The Spelling Checker assumes that a word at the beginning of a 
sentence should be capitalized. It flags words that begin with a 
lowercase after a period. It also locates sentence fragments as in: 

“The church on the corner was finished last month. down the 
street. I visited it a week ago...” 

In this example the Spelling Checker will flag the word down, the 
remnant of an old sentence that was meant to be deleted. 

Incorrectly Formed Word 

When correctly spelled root words are combined with improper 
prefixes or suffixes in a document, the Spelling Checker will give 
you the Incorrectly formed word message. If, however, these 
words are checked for spelling as individual words, their condition 
will be shown as Misspelled word. 

° prememory 
* wordest 

Misspelled Word 

This is the message given when a word is not found in the dictionary. 
It may be misspelled or just unknown to the spelling checker. 

If the word is spelled correctly, you should add it to your user 
dictionary by clicking the button. This will prevent it from 
being flagged as misspelled in the future. 
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Repeat of Last Word 

You are alerted when a word is immediately repeated. It is usually a 
mistake when words are repeated in this way: 

° The ferry will take us across the the water. 

Sometimes, however, it is correct: 

¢ lam very very happy today. 

Using the Thesaurus 

To look up a word in the Nisus Thesaurus, select the word in your 
document, then choose Thesaurus... from the Tools menu. You 
will see the Thesaurus dialog shown in Figure 6-5. 

Webster's Electronic Thesaurus™ 

Current: Original: speech 

1) noun communication, expression, or interchange of thoughts in 
spoken words. 

discourse, speaking, talk, utterance, verbalization 
cmp: vocalization 
rei: articulation, uttering, vocalization, vocalizing, 

voice, voicing, expressing, expression, language 

Figure 6-5 Thesaurus dialog displaying “speech” in the Word Box 

The purpose of the information in the dialog is to help you find 
synonyms. To do this, the following information is displayed: 

° The part of speech 
e Aconcise definition 

¢ Synonyms for that definition 

You can replace the selected word in your document by double-clicking 
on the synonym in the Thesaurus dialog. You will see it momentaril y 
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selected, then the dialog will disappear, and the word will replace 
the previous selection in your document. Alternatively, you can click 
the word once, then click (Repiace }. 

You can look up most synonyms listed in the Thesaurus dialog by 
clicking it once and then clicking [ Lookup | (be careful, as double- 
clicking places the word in your document). Clicking a synonym 
transfers it to the Next box. You may also press Return instead of 
clicking the button. This is helpful when you have just 
typed in a word and have your hands on the keys. 

A history of the last 10 words looked up is kept in the pop-up menu 
to the right of the Current box. To see these words, click on the 
word displayed in the Current box, as illustrated in Figure 6-6. 

Webster's Electronic Thessurus™ 

Current: Binauiiuss Original: happiness 
triumph 

gentia 
health 

Health 

eli-being or pleasurable satisfaction. 
. blessedness, bliss, blissfulness 

Figure 6-6 Thesaurus word history with: Healthy, health, gentle, 
triumph, happiness 

To look up any of these words once more, just choose them from this 
pop-up menu. This list is remembered until you quit Nisus. 

Click to close the Nisus Thesaurus dialog without replacing 
the selection in your document. 

Interpreting the Results 

Meanings are listed in an order that reflects the usefulness of their 
synonyms. This means that the most common meanings, which would 
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be first in an ordinary dictionary are sometimes listed much later in 
the list. In fact, the most common definitions of a word may not be 
listed at all. Only meanings leading to synonyms are shown. 

A number of abbreviations are used in the Thesaurus in the left 
margin beside secondary lists of words. These will help you decide 

~ which direction your word search should continue. 

® syn: Synonyms: This list will show you 
words that have the same or very nearly 
the same meaning as the original word. 
The words in the synonym list share a 
common denotation though they may 
differ in connotation. 

*rel: Related: These words are near 
synonyms. They have the same 
implications as the original word, though 
their emphasis may be different. 

eant: Antonyms: The words in this list 
contradict the meaning of the original 
word with equal or nearly equal force. 

*con: Contrasted: These words in some sense 
oppose the meaning of the original word 
though they are not in complete 
contradiction. 

ecmp: Compare: These words suggest a “sce 
also” list that express a related idea 
possibly worthy of exploring. 

When you look up a word which is not found, you will be given a 
list of up to 16 alternate words. This does not necessarily mean that 
the word is spelled incorrectly; it means that the word is not in the 
thesaurus. The alternate words are chosen using both the typographical 
and phonetic qualities of the unknown word. Therefore, you will see 
some alternatives which have spellings that may differ quite a bit, 
but sound the same as the unknown word, as illustrated in Figure 
6-7. 
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Webster's Electronic Theseurus™ 

Current:(_nede} 

The word wes not found in the thesaurus. Please try another word. 

Suggestions: 

need, node, nude, knead, nod, nudge, endue, needy. made, 

mode, Nate, note, nuke, knead, net, neck 

J Gepiece) (concer ) | 
Figure 6-7 Thesaurus alternate selections for the typo, “nede.” 

There are also many words which try to guess at the correct spelling 
by changing or deleting letters of the unknown word. These words 
are an attempt to guess the word you intended to type. 

Intelligent Synonyms 

Synonyms are displayed in the same case (upper or lower) and tense 
as the word you looked up. This feature helps you find synonyms 
which can be immediately substituted for your previous word. You 
do not need to change the case or tense of the synonyms. 

ts’ Words cannot be added to the Thesaurus. 

Hyphenation 

Automatic Hyphenation 

Nisus can automatically hyphenate text which has been placed in the 
Auto-Hyphenate mode. Text can be placed in this mode by using the 
Hyphenate command on the Tools menu. When hyphenating, Nisus 
checks for correct hyphenation points using the Nisus Hyphenation 
file. Therefore in order for automatic hyphenation to work, one of 
the following set up procedures must be followed: 

¢Choose Dictionary Preferences from the Preferences 
submenu of the File menu. Save the appropriate settings by 
choosing Save Preferences from the File menu. Make 
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sure that the Nisus Hyphenation file is in the System Folder 
or in the same folder as the Nisus application. Finally, quit 
and Nisus and re-start Nisus. These start-up preferences will 
now be in effect. 

This start-up procedure will also ensure that the spelling checker 
will not ask you to locate the dictionary. You need only repeat this 
installation if you move your dictionaries, or remove or delete the 
“Nisus Preferences 3.0” file from the System Folder. 

Three levels of possible hyphenation points are determined: the gram- 
matically most desirable, less desirable, and least desirable. A word 
at the end of a line is hyphenated only if an excessive amount of 
white space would result otherwise. The most desirable hyphenation 
points are used unless excessive white space would still remain. Any 
word which is wider than the column (and which cannot fit using 
hyphenation rules) will be broken and hyphenated without regard to 
any rules. 

ite” You can set Hyphenate as an attribute of all text in your Nisus 
New File. 

Manual Hyphenation 

You can insert soft hyphens into your words. A hyphen character is 
inserted when you type Command minus (%-). The hyphen character 
is not displayed unless needed to hyphenate. 
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Working with Graphics 
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Before the Introduction 

The ability to use graphics in Nisus is “only a click away!” 

Pen/Fill Pattern 

| Selector 

Object Pen | | | Black Pattern 
Attribute — Size | 

Too! Palette Monus Selector - White Pattern 

. SNAPS are =r PiciocioLt |) PlGh) Ts sEato 
re ee a ee Se ee - ae 

Opaque/Transparent/Invert | Exterior! .{Interio 

Text Wrap Off/On None Pattern 

Front of/Behind Text Palette Scrolling 

Paragraph/Page Attachment Pattern Palette 

Figure 7-1 The Graphics Palette 
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simply click on the [S| Show Graphics Palette icon in the vertical 
scroll bar and all the t-. 's of Nisus' graphics sheets as illustrated in 
Figure 7-1 are availa’... you. For a walk-through of some basic 
graphics features reac .- 4 utorial, Session 3: Graphics, page 29. 

Technical Introduction 

Like most Macintosh applications Nisus allows you to paste pictures 
(PICT type data) into a document. The difference between Nisus and 
other word processing applications is that Nisus will allow you to 
access the graphic components of the pasted picture; that is, you can 
edit pasted PICT data within Nisus. In addition you can draw directly 
in Nisus' graphics sheets. These are features usually found only in 
separate graphics applications. 

While Nisus has three types of graphics (Character Graphics, Page 
Anchored Graphics, and Paragraph Anchored Graphics, —discussed 
in detail beginning on pages 236, 255, and 253 respectively) the 
functioning of a Nisus window can be likened to three transparent 
overlapping sheets: two graphics sheets with the text sheet in between. 

To work on the graphics sheets, you must be in graphics mode where 
the Graphics Palette shows. The text sheet is accessible only when 
you are in text mode, though the text ruler need not show. The text 
sheet is the sheet where you normally type your text. 

In Macintosh usage, the term object graphic means a graphic made up 
of lines, arcs, characters and patterns which have characteristics that 
can be altered with ease because they are mathematically defined. 
This meaning of object graphics does not include bitmaps; bitmap 
graphics are defined using dots. The only way to place bitmap graphics 
in Nisus is to import them. Once in Nisus they can be resized but 
cannot be edited. 

When object graphics are imported into Nisus they can be edited, but 
only on a graphics sheet. (To understand the distinction, for example, 
MacPaint documents are bitmaps while MacDraw documents are 
object graphics. Some programs will allow you to create graphics of 
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both types.) Any kind of graphic can be pasted into either the text 
sheet or the graphics sheets. The way the graphic interacts with the 
surrounding text and graphics is determined, among other things, by 
the sheet it is on. Each graphic pasted into the text sheet behaves as if 
it were a single character, almost the same as a letter. For this reason, 
it is referred to as a “character graphic.” 

Nisus allows you to create object graphics on the graphics sheets. 
Although this is the only type of graphic that you can create in 
Nisus, you can copy any kind from other applications and paste onto 
any of the graphics sheets in Nisus. For more information on importing 
graphics, see page 286. 

While you are on the text sheet, any graphic you paste is placed as a 
character graphic at the insertion point. If necessary, the height of the 
line on which you paste the graphic is automatically adjusted, as it 
would be for any other text character of the same height. Graphics 
on the text sheet can be resized, cropped and can also be moved 
outside their position box called the character window. 

Graphics on the graphics sheets can be placed in front of or bchind 
the text on the text sheet; they can have the text wrap around them 
or flow through them; they can be made opaque or transparent or 
(using a non PostScript printer) the points at which they intersect can 
be caused to invert; they can be grouped and ungrouped (though 
only graphics of the same type [means of attachment] can be grouped 
together). 

Graphics on the graphics sheets can be made to flow with the text or 
remain on a particular page. A character graphic (that is, a graphic 
on the text sheet) stays with the characters on either side of it and 
flows both horizontally and vertically with the text. 

You can import bit-mapped graphics via the scrapbook and/or 
clipboard although you cannot create them within Nisus. You can 
also draw your own object graphics within Nisus on the graphics 
sheet and then copy and paste them on the text sheet as character 
graphics. See the section below on object graphics. You can even 
paste graphics containing PostScript commands. Such graphics contain 
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a version for the screen and PostScript commands that are actually 
sent to the printer. The details regarding pasting these kinds of graphics 
are discussed on page 287. 

is A graphic on a graphics sheet is anchored either to a text paragraph, 
the anchor paragraph, and moves vertically with that paragraph or it 
is anchored to a particular page, and remains on that page. Any 
graphic on the graphics sheets will stay horizontally where you 
position it. However, if the anchor paragraph is removed, the graphic 
is also removed. This means that if the return character which starts 
the anchor paragraph is deleted, the graphic is also deleted. If you 
see this happen, simply undo your action and move the graphic to 
another paragraph. If, on the other hand, it is a page anchored graphic, 
it will remain on that page until you remove or delete that graphic. 
see Page/ Menu page 253 on how to attach a graphic to a paragraph 
or a page. 

The Text Sheet: Character Graphics 

Character graphics are any graphics pasted or placed when you are 
on the text sheet or any other window in Nisus other than the Graphics 
sheets (i.e. the Glossary or Macros). All character graphics are PICTs. 
The character graphic is placed at the insertion point and the current 
line is lowered to allow the graphic to fit completely below the previous 

line, as with the G shown here. The character raphic rests on 
the base line where it is pasted. 

When a graphic is pasted on the text sheet, it behaves like a character. 
You can select, delete, copy and paste it along with other text. If you 
put the graphic next to a word (with no spaces in between) it becomes 
part of that word and will wrap with it. If you double-click a word, 
however, any character graphics inside that word are not selected 
with it and the word itself is treated as two words for the purpose of 
double-clicking. You can mark a character graphic for the index or 
the table of contents, or as a point in your text to which you can 
jump and/or cross reference. You can even find and replace a character 
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graphic using the Find/Replace dialog. Two graphics are considered 
the same if their graphics window (both height and width) is the 
same. See Finding and Replacing Graphics page 211 for more details. 

Character graphics are only affected by the following commands 

from the Style menu changes: Underline, OUCIine, Shadon, 

Lower Underline, Dotted Underline, re, oo crip: SHEHEC 
ee 

through, Overbar, Boul and [Invisible]. They are not affected 
by Font or $ize attributes nor are they affected by the Bold or 
italic style. Character graphics in OUQIIMG are boxed and character 
graphics in $l) @@©D style are outlined with a shadowed box. 

Resizing, Moving and Cropping Character 
Graphics 

You can change the size and position of a character graphic when on 
the text sheet. To do this, click once on the character graphic to select 
it. You will see four square handles—one on each corner of the graphic 

and four rounded handles on each side of the graphic: 

_S “a 
change its size, drag one of the square handles. The adjoining text is 
reformatted around the newly resized character graphic. To change 
the margin of white space surrounding it, drag one of the rounded 
handles. To change its position, just drag it to the new location. You 
may slide the graphic below the base line by dragging it straight 
down. See Figure 7-2. 

te” Holding the Option key while dragging reverses the meaning of the 
drag and crop handles. You can change the size by pressing the 
Option key as you drag one of the rounded handles. Alternatively, 
you can change the margin of white space by pressing the Option 
key as you drag one of the square handles. 
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Figure 7-2 A. Acharacter graphic B. Same graphic d ipping below 
the base line C. Selecting a character graphic which is Partialiy 

outside its character window 

You can move a character graphic outside of its character window by 
pressing Command or Option while dragging it. This is shown in 
part C of Figure 7-2. A character graphic will only stay on the line 
where it is placed. It cannot be moved into another line without the 
text below being affected. 

is When you paste equation blocks from programs such as 
Expressionist™ and MathType™ they appear placed correctly on the 
baseline. 

You can alter the appearance of a character graphic in a number of 
different ways by pressing one of the modifier keys as you resize or 
crop it as illustrated in Figure 7-3. 

Ds” You can return a character graphic to its original size and position at 
any time by selecting it and, while pressing the Shift key, double- 
clicking on it. 
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_t Cats are felines. ’ 
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; 
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Et ‘Cats are felines. 7 ee ans aa 

Figure 7-3 A. Acharacter graphic followed by text B. Same graphic 
resized larger C. Resized with Command so text does not move 

D. Resized with Option (adds space) E. Resized with Option (crops). 
Once the character graphic is deselected the rectangular character 

window will disappear 

Editing Character Graphics 

To edit a character graphic double-click on it. The Graphic for... 
window as illustrated in Figure 7-4 will open with same size as, and 
in the same location as the original graphic; the Graphics menu will 
appear to the right of the menu bar. This window functions the same 
as any other Nisus window (it can be moved, enlarged, zoomed, the 
windows menu will pop down from its title bar with the Option or 
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Command key pressed when you click on it, etc.) but it is always, 
and only, in the graphics mode (but remember, you are editing a 
character graphic). 

*Manual 3 complete 

hy rpaph ies 
i ed te is: ove tha ‘graphic ‘to tit - 
Lous lime, arwith the-Gshewn here. The’ 

Ik rests wr the baseline where itis pasted.F 

Baa nt Igy ted -on ‘the -tert sheet, -2t dbahaves like as - 
PKA} Dit. delete. copy and paste it alongwith ether: 

tent. Ifyou putthe gra phicnext tou werd (with nespaces mbetween)- 
artef that-werd ‘and will wrap with it. if you dewble- 

click a word, however, any character graphics inside that word 10: 
not selected with it."Yeu ‘can-even ‘find ‘and teplacea character: 

Any editing done in this window will appear in the character graphic 
when you close the window by clicking its close box or click on the 
original character graphic. If you make a change that affects the width 
or height of the character graphic, it will not be apparent until you 
close the Graphic for... window and press Shift as you double-click 
on the character graphic. Any changes made will be saved when you 
save your file. When the Graphic for... window is open the actions 
performed in it are added to the Undo list. However, once it is closed, 
anything that had been done in that window can no longer be undone. 

ie” When you open a character graphic to edit it, by opening the Graphic 
for... window, Nisus automatically converts it to a Nisus Objects 
Graphic. Any PICT comments or PostScript comments will be 
removed. For more technical information on what this implies sec 
PostScript Limitations page 288. 

ts” To delete a character graphic, backspace over it with the Backspacc 
(or Delete) key or select it and press Backspace (or Delete). Cut, 
Copy, Paste and Clear can be used with character graphics just as 
with other text. 
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i Copying graphics together with text has some limitations. If you 
copy more than one graphic with text, each graphic copied is limited 
to 32K in size. If any graphic in the copy region exceeds 32K, it will 
be replaced by a box with the message the size of the pasted 

This picture is > 32K. 
graphic: Copy i separately. when you paste. If you 

copy one graphic at a time, the only size limit is your computer's 
memory. Any number of graphics selected together on the graphics 
layer count as one graphic. 

xF Find/Replace... 
Copy to Find 

Mark Tent... 

Jump To > 
Cross Reference... Raa enc ee Nh 
Update H-Reference! | ine # Prefs... 

Spelling... 

Thesaurus... 

“Document 

Henders;fadatears 

fFaatnaltes 

Invisible Text 

|v Pagination 
Graphics fs # 

As PostScript™ 

Graphic finchors 

Vertical Ruler 

info Bar 

/Master Ruler 

braphics Palette 

Place Page... 
Place New Page 
Giossary b 

Edit Tools > 
Display & 

> Windows 

Macros > 

Figure 7-5 Changing from text to graphics sheet 

The Graphics Sheets 

To enter the graphics sheets, click the Show Graphics Palette icon 
at the top of the scroll bar or choose Graphics Palette from the 
Display submenu of the Tools menu as shown in Figure 7-5. The 
Graphics Palette as shown in Figure 7-1 on page 233 will replace the 
Text Ruler. 
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When on the graphics sheets the Graphics Palette and the Graphics 
menu appear. Tools and commands available to create and modify 
graphics created in, and imported into, Nisus are discussed below. 

= SSSR TPH pues" 
et tt eM te tt ts oe ie ht i, 

Soafthe Object Graphics You Can Draw In: Nisus®: : 

(") 

Figure 7-6 Graphics Palette at the top of the document and an 
example of each type of drawing in the window 

The Graphics Palette 

The tools in the Graphics Palette allow you to create and edit object 
graphics such as those illustrated in Figure 7-6. The pull-down menus 
in the Graphics Palette change the way object-oriented and PICT 
graphics interact with each other and the surrounding text. 

The pointer becomes a cross-hair -f for all tools on the Graphics 
Palette except the Text tool. The Text tool becomes an I - beam with a 
baseline marker _L. 

To draw a graphic, drag the cross-hair to draw the tool’s shape. The 
Shift key and the Command key will modify the effect of some tools. 
See the following sections about each particular tool for an explanation. 

Drawing tools are selected by clicking on them. A tool will stay 
selected until another tool is selected (see [> below for an exception). 
Click the Selection Tool if you want to select a graphic, change its 
appearance, or move it to another location. Refer to the section on 
object modifiers, below, for details on changing the frame size, frame 
and fill pattern, and other attributes of graphics. 
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tte When using any drawing tool (except the Text tool and the Polygon) 
if you make a short click without drawing that tool will be deselected 
and the Selection Tool will be activated. 

Drawing Tools 

The Nisus graphics tools are: 

Selection Tool Text 

Line Drawing Tool [ml Rectangle 

Arrow Drawing Tool Rounded Rectangle 

Bidirectional Arrow IO} Oval 

Arc [<<] Polygon 

Selection Tool 

To select graphics click on the Selection Tool, then click on the graphic 
you want to select. A selected object graphic has four square handles, 
one on each corner. A selected PICT graphic (and a Placed Page 
Graphic) has eight handles. In addition to the four square handles, it 
has four rounded handles. 

Figure 7-7 Using the selection rectangle 
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To select more than one graphic, press Shift while clicking on all 
graphics after the first. 

If the graphics are close together, you can also select them by using a 
selection rectangle. To do this, click on the Selection Tool, then click 
on One corner of an imaginary rectangle that will enclose all the 
graphics you wish to select and drag to the opposite corner, as 
illustrated in Figure 7-7. Take care to enclose all graphics completely 
because even partial exclusion will prevent selection of that graphic 
as illustrated in Figure 7-8. The entire selection will appear within a 
dotted rectangle. When you release the mouse button, selection will 
be indicated as usual (the “handles” will appear). To deselect, click 
outside the selection. 

Figure 7-8 incomplete selection of multiple graphics 

i You can only simultaneously select graphics that share the same 
attachment attribute: 

* Move with Paragraph 

e Fix to Page 

as illustrated in Figure 7-9 . For more details on the attachment 
attribute, see Page/q Menu, page 253. 
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Figure 7-9 Selecting graphics with different attachment attributes 

its” To select a number of graphics sharing the same attachment attribute, 
but are only partly enclosed by the selection rectangle, press Option 
while dragging the rectangle, as illustrated in Figure 7-10. 

Figure 7-10 Using the Option key with the selection rectangle 

i” To select all graphics on a graphics sheet that share the same attachment 
attribute choose Select All from the Edit menu. 

ke To deselect one from a number of graphics that are selected, press 
the Shift key as you click on the graphic you want to deselect. 

in the text sheet when you select different attributes for text, the 
succeeding text assumes thosc attributes (of font, size and style). The 
attributes shown on the graphics palette act in much the same way 
as the current palctte. When nothing is selected, whatever the palette 
shows will be the attributes of any newly created graphic. You change 
the attributes whenever you click on the palette, no matter whether 
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something is selected or not. Any attributes changed while a graphic 
is still selected will affect that graphic also. 

When you sclect one graphic the palette will display the attributes of 
that graphic. However, that will not affect the current palette. (This 
can be compared to moving your insertion point to another section 
of your text where the font size and style are of a particular sct of 
attributes. They show up on your menus, and affect any text contiguous 
with it, but have no affect on the text you enter when you return to 
where you had been working.) 

To change the current palette so that it will create a graphic with the 
attributes of a selected graphic you need to choose each of those 
attributes from the palette before drawing the new graphic. This 
resets the current palette. 

If two or more graphics are selected the palette will display all common 
attributes of the selected graphics. In the pop-down iconographic 
menus in the middle of the graphics palette (discussed beginning on 
page 253), check marks appear by items that are the same for all 
selected graphics. If the selected graphics do not share the same 
attribute for a menu, no check mark will be placed beside any command 
and the icon in the menu will show what was the current attribute. 
The same applies for pen and fill patterns. 

¢ No graphics selected: Display the current attributes. 
* One graphic selected: Display the attributes of that 

graphic. 
¢ Several graphics selected: Display all shared attributes 

(menu items with shared: 
attributes checked; 
attributes not shared: 
current attributes displayed). 

Once graphics are drawn, you need to select them in order to modify 
them. Move graphics by selecting them with the Selection Tool and 
dragging them to the new location. 
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To resize a graphic, first select it. Four handles appear one on each 
corner of the enclosing rectangle. Drag any one of the handles to 
resize the graphic. If you hold the Shift key as you resize, the graphic 
will be constrained to its original proportions. 

You cannot resize a graphic that is made up of many ungrouped 
~ Objects such as those illustrated in Figure 7-7 and Figure 7-10 on 

pages 243 and 245 respectively. This is actually not yet one graphic. 
Group them first (choose Group from the Graphics menu, see page 
272) then you will be able to resize them as a unit. 

Line Drawing Tool 

Use this tool to draw straight lines. Press Shift as you draw to constrain 
movement to 45° increments as illustrated in Figure 7-11. 

Figure 7-11 Restricted line drawing positions using the Shift key 

Arrow 

This tool draws a line with an arrow head pointing away from the 
initially clicked position. Drag the arrow to the spot to which it should 
point as illustrated in Figure 7-12. You can draw an arrow pointing 
in any direction. Press Shift as you draw to constrain movement to 
45° increments. 
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Figure 7-12 Drag the arrow to the spot to which it should point 

Bidirectional Arrow 

This tool draws a double-ended arrow. Both ends of the line have an 
arrow head. Press Shift as you draw to constrain movement to 45° 
increments. 

Arc 

Use this tool to draw an arc. Click to begin drawing and hold down 
the mouse button. You will get differently shaped arcs depending 
upon which direction you begin dragging. 

Figure 7-13 Shaping arcs 

You can curve arcs eight different ways. Each of the eight ways is 
ifustrated in Figure 7-13. The first direction you travel when you 
begin drawing determines that the arc will be one of two shapes. The 
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next direction you travel] will determine exactly what shape the arc 
will have and this is the direction that is labeled with the number of 
the arc in Figure 7-13. 

Press Shift to constrain the arc to a quarter circle. 

Text 

This tool enables you to create text on the graphics sheets. When it is 
active, the pointer will appear as an I-beam I with a baseline marker. 
You can enter text in two ways. 

e You can click the I-beam anywhere in your document. Text 
will be entered starting at the I-beam and resting on the 

baseline marker 4 7 The text box will continue to grow 
seheudangay 

as you type, starting new lines only when you enter a return 
character. 

TAMER Ses FES ere ctmsaaaE Nesey 
. 
« 

and activate the insertion point i . Text will be 

‘ . 
. 

i 
* 

entered to the right of the I-beam. However, the text box 
will not grow. Lines will wrap when they reach the Tight 
edge of the text box. When the text reaches the bottom of 
the text box it will continue to be entered, though it will not 
be visible. You can make the text visible by selecting the 
text box with the Selection Tool and then dragging one of 
the handles on the corners, resizing the box. 

Change the font, size and style of the text box using the menus in the 
menu bar. Set the justification from the Graphices menu which appears 
on the menu bar, see page 285. All the text typed in a text box has the 
same attributes. You may apply the following commands from the 
Style menu to the text: Bold, /talic, Underline, OUDINE, 
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SHAaGOW, Condense, and Extend. All other styles are not 
available for text in a graphic text box. Having created the text box, 
you can place it anywhere on the page. 

Text on the graphics sheet gives you greater freedom in arranging 
the text on the page than you have on the text sheet. You can use text 
on the graphics sheet to create side bars, call-out boxes, and even 
independent columns of text. 

You can achieve unusual text effects with the graphics Text tool. For 
example you can, as usual, create a text box and enter some text. 
Then select the text box and choose Cut from the Edit menu. If you 
then press the Option key as you choose Paste from the Edit menu 
the text box will be pasted as a PICT, as illustrated in Figure 7-14. 
You will be able to modify the appearance of the font by stretching 
or compressing it using the graphic box's square handles. While the 
graphic will appear strange on screen (showing the “jaggies”) it will 
print smoothly, as illustrated in Figure 7-15. 

alt was a fat fishe 

Figure 7-14 Option pasting a graphic text box 

Figure 7-15 an Option Pasted text box resized 
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J] Rectangle 

This tool is used to draw rectangles and squares. Press Shift to constrain 
the object to a square. 

oa) Rounded Rectangle 

This tool is used to draw rounded rectangles and squares. Press Shift 
fo constrain the object to a rounded square. 

IO] Oval 

This tool is used to draw ovals. Press Shift to constrain the object to a 
circle. 

[<<] Polygon 

This tool draws connected lines to form a polygon. Click to start 
drawing. Then move the pointer to form a side (do not hold the 
mouse button as you move). Clicking once more will finish a side 
and begin drawing the next side. Double-click to finish drawing and 
leave the polygon open. To close the polygon, click near the starting 
point, the end point will be placed at the start point. 

ite” You can prevent closure when the mouse comes close to the beginning 
by pressing the Option key as you click. 

LO) Freehand Drawing 

Use this tool to draw any free flowing graphics as illustrated in 
Figure 7-16 and Figure 7-17. This tool draws connected dots to shape 
a free formed object. Click to start drawing. Then, with the mouse 
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button depressed, move the pointer to form your object. Release the 
mouse button when you finish drawing. 

Figure 7-16 Using the Freehand Drawing Tool 

Figure 7-17 Using the Freehand Drawing Tool 

te” The Text tool and the Freehand Drawing tool are the only tools that 
will not automatically scroll the window as the object grows. 
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Graphic Object Attributes 

The remainder of the items on the Graphics Palette affect the attributes 
of your graphics. 

When you first enter the graphics sheets you will notice that certain 
settings are already established. These are called the “current settings.” 
You can change how your new file opens (even to the point of having 
it open on the graphics sheets) by setting your desired attributes and 
saving the file as a Nisus New File. This is explained in detail on 
page 65. 

Immediately to the right of the Tools Palette is a series of four 
iconographic pull-down menus. These menus affect the manner in 
which graphics interact with the document as a whole, the text on 
the text sheet, and other graphics. 

i As is standard with Macintosh attribute menu commands (Font, 
Size, Style, etc.), the attributes of your selection are indicated with 
a check mark. If more than one graphic is selected and more than 
one attribute from one of the iconographic attribute menus has been 
applied no check mark will show in that menu. 

ka Page/q Menu 

There are two types of graphics on the graphics sheets: 

* graphics that move with the paragraph to which they are 
anchored 

¢ graphics that are fixed to a specific page. 

Move With Paragraph 

To have graphics on the graphics sheets flow with the text as it 
moves, select the graphic/s and choose Move with 4 from the 
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[Ol s | Page/ menu. This will cause them to attach to the nearest 

paragraph (the anchor paragraph) above all the overlapping paragraph 
graphics in the text. They are actually anchored to the return character 
at the beginning of that paragraph. This graphics anchor, which ap- 
pears as a dotted line from the upper left corner of the graphic up to 

the beginning of the paragraph, can be seen by choosing Graphic 

finchors from the Display submenu of the Tools menu as shown 
in Figure 7-18. Paragraph graphics move with the paragraph to which 
they are anchored. However, their distance from that paragraph is 
not fixed. In fact it can be quite a distance, yet still remain anchored 
to the same return character. This is because Nisus tries to prevent a 
paragraph anchored graphic from crossing a page boundary. When 
you delete the return character preceding this paragraph, the graphic 
is also deleted. When you move this return character (by cutting and 
pasting or by entering other text above it) the graphic will move with 
it. 

q | 
“4, Inthe valley by the lake I knew I'd find Harvey. He 
was.an ‘inveterate fisherman. He didn't need to conquer ° 
the big-4ish from his high-powered boat; he was the quiet 
contemplatiye kind. I tumed onto-Lake Drive and slowly - 
cruised ‘along’ Ia the ‘shore. - 
The ~° few lf oe bungalows; 
half-hidden - c | in“the trees ° 
belied ‘the CO a ee 4 m= fact that I - 
was ‘still in See NNN, the second ° 
largest city m ° Vieteeess California. - i SS eam EE It ‘probably - ‘ VY wouldn't be: 
long ~ before - they'd all 
be'replaced ‘by ‘condos. Harvey's‘old “60's vintage silver - 
Porsche’ was’ parked ‘off the road near the northern end. I - 
pulled in behind him and called out through the swamp - 
grass lush‘alongthe water line; he rarely took the rowboat 
out more than‘a‘few-yards from shore.’ 

Figure 7-18 The Move With Paragraph Graphics Anchor (with space 
and return character indicators showing to indicate attachment) 

_ i If you have a paragraph anchored graphic nested within text and 
you have chosen Text Wrap Off, Nisus will keep the graphic and 

254 CHAPTER SEVEN 



the text over which it lies together on the same page. This may cause 
the graphic and those lines of text to “bounce” together from page to 
page depending on whether or not enough space exists on that par- 
ticular page to display the entire graphic (it is as though those lines of 
text have been given the text editing attribute from the Format 

menu Keep On Same Page). In reality, the graphic is still with the 

return character to which it was anchored. 

i> If you want to see the anchors on screen but you do not want them to 
print, be sure to uncheck the option Print with all “Display” 
options as shown on screen. inthe Printing Options dialog 
box (choose Printing... from the Preferences submenu of the 
File menu). 

If you want to copy and paste text with its anchored graphics, be 
sure to include the proper return character in the selection when 
choosing Cut or Copy. 

ts” When placing graphics in your document it is advisable to paste 
them on the text layer whenever possible. You can create a graphic 
on the graphics sheets and after creation cut it and paste it on the text 
layer. It then becomes a character graphic as described on page 236. 
You will only need to have graphics on the graphics sheets when 
they need to overlap text or have text wrap around them. Graphics 
pasted into the text layer will update more rapidly as you edit the 
text of the document. 

ie A graphic at the top of the document is anchored fo the top of the 
document, as there is no return character to anchor it. Thus, if you 
add new paragraphs at the beginning of the document, the graphic 
will not move. You must go to the graphics sheet and move it so that 
it attaches itself to another paragraph. 

Fix to Page 

To have your graphics remain on a specific page regardless of the 
flow of text that may be inserted above them, select them and choose 

Fix to Page from the  @ | Page/4 menu. This will cause 
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them to remain on that particular page. Graphics that are fixed to 
page also have a graphics anchor different from that of the graphic 
that moves with a paragraph. It appears as a small page icon just 
above and to the left of the graphic and can be seen by choosing 
Graphic Anchors from the Display submenu of the Tools menu 
as shown in Figure 7-19 below. If you remove enough text so that 
the number of pages in your document is less than the page number 
to which a Fix to Page graphic is attached, that fixed to page 
graphic will become invisible. It is still associated with that page. For 
example, if a graphic is fixed to page 3 and you remove text so that 
your document has only two pages, the graphic will disappear. When 
you add text again so that there are three pages, the graphic attached 
to page 3 will reappear. 

In the valley by the lake I knew I'd find Harvey. He 
was an inveterate fisherman. He didn't need to conquer 
the big fish from his high-powered boat; he was the quiet 
contemplati yg kind. I turned onto Lake Drive and slowly 
cruised alon San the shore. 
The f a MU” Z bungalows, 
half-hidden , LZ in the trees 
belied the Mie! fact that | 
was still in SS the second 
largest city in WY California. 
It probably YW wouldn't be 
long before they'd all 
be replaced by condos. Harvey's old ‘60's vintage silver 
Porsche was parked off the road near the northern end. | 
pulied in behind him and called out through the swamp 
grass lush along the water line; he rarely took the rowboat 
out more than a few yards from shore. 

Figure 7-19 The Q Fix to Page Graphics Anchor 

is” Graphics that are fixed to a page cannot be selected at the same time 
as graphics that will flow with a paragraph. If you select one or more 
graphics that are anchored in one way and then choose the other 
option from the menu, you are not simply switching between two 
views of your document, you are altering the attachment attribute of 
all those graphics selected. 
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The Front/Behind Text Menu 

As explained in the introduction to this chapter, page 234, there are 
two graphics sheets in Nisus: one in front of the text sheet and one 
behind it. When you look at your Macintosh screen all you See is “a 
thousand points of light.” It is hard to imagine that some things are 
in front of or behind anything else. Nonetheless, as you have seen 
when you have a variety of Nisus document windows open at the 
same time, just as on top of your desk, various sheets of paper are on 
top of and underneath cach other. This is also true on the Macintosh 
desktop (though since the desktop screen is vertical we speak of in 
front of and behind). Imagine for a moment that you are reading a 
biology text, the kind that uses transparent overlays which show 
various organs of the body allowing you to view successive layers. A 
Nisus document has three such layers. 

If you are using a PostScript printer, certain screen display phenomena 
cannot be printed as displayed. You can adjust for this in Nisus in 
two ways. 

If you are printing with a PostScript printer choose AS PostScript® 
from the Display submenu of the Tools menu. Though the effects 
of this command only affect Nisus Graphics Objects that are on the 
graphics sheets, it will enable you to see precisely what will print. 

To have text visible in front of a graphic (for example to create a 
“screen” effect) as illustrated in Figure 7-20 select the graphic and 

choose Behind Text. 

This text is on the text sheet. 
The irregular polygon graphic is on the 

graphics sheet. 

Figure 7-20 Text in Front of Graphic for Printing on a PostScript 
Printer 
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is Another way to create this effect (on the graphics sheets) using the 
graphics text tool is explained on page 270. 

us Transparency has no effect on a PostScript printer. Graphics placed 
in front of text will always print as opaque on a PostScript printer, 

even if on screen you have chosen [eal Transparent from the 

Opaque/Transparent menu. 

The Text Wrap Menu 

You can have the text of your Nisus document either wrap around a 
graphic on the graphics sheets or appear to pass right through it. 

In the valley by the lake I knew I'd find Harvey. He _ 
was an inveterate fisheppg pt, | 

big fish from his A (enered boat; was. the quiet | 
PSS oS Ronto Lg; eve and slowly 

sei ay BRAXRRAA alf-hidden in pee ONE AGS pega the trees belie RA SONNY 5 STS cond largest 
city in Californian AAA Rois dn't BARRY before they'd 

~*~ 

~~ all be replaced b i SSF : ¥ vintage silver 
Porsche was parket off the road near the northern end. I 
pulled in behind him and called out through the swamp 
grass lush along the water line; he rarely took the rowboat 
out more than a few yards from shore. _ 

Figure 7-21 Text Wrap Off (graphic in front of the text also expressed 
as text under the graphic) 
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With text wrapping turned off, depending on which of the graphics 
sheets your graphics are on, text will, as explained above, pass either 
under, as illustrated in Figure 7-21 or over the graphic, as illustrated 
in Figure 7-22, rather than wrapping around it as shown in Figure 
7-18 and Figure 7-19. 

The text entered on the text sheet is itself transparent and lies between 
the two graphics sheets. It may or may not be visible in relation to 
the graphics. This depends on whether the graphics are in front of 

or behind the text, transparent (that is, if you havea 

non-PostScript printer, see below, page 288), or whether you have 

chosen a0 Text Wrap On. Character graphics on the text sheet 

will not cause text wrap; they act just as any other character typed 
from the keyboard. This means that they will wrap around the graphics 
on the graphics sheets. A document can, as does this one, have a 

=.= 

mixture of graphics with #£0| Text Wrap Onand Text Wrap 

Off. 

In the valley by the lake I knew I'd seimebi He 
_-was an inveterate fishenpapeble wer 
big fish from his dat Me 
contemplative hi pa sete 
cruised alon Wey) 

“ee are 

ze eee the road near. the northern end. tr 
pulled ‘in behind him and called out through. the swamp 
grass lush along the water line; he rarely took the rowboat 
out more than a few yards from shore. , 

Figure 7-22 Text Wrap Off (graphic behind the text, also expressed 
as text over the graphic) 
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Text Wrap On 

Regardless of which graphics sheet your graphics are on, text will 
wrap around the smallest rectangle that encloses the graphic. Text 
that is interrupted by the graphic will continue on the other side of 
the graphic (justified according to the attribute set for that paragraph 
on the Master Ruier). This is illustrated in Figure 7-18 and Figure 
7-19 on pages 254 and 256. 

i> You can set the margin of white space to the right and left of the 
graphic by choosing Set Wrap Border... from the Graphics menu. 
See Set Wrap Border... page 274. These parameters can be saved as 
part of your Nisus New File. 

When you select a graphic that spans more than one column and 

Text Wrap On from the Text Wrap menu, the text 

will wrap in the other column or columns it touches. 

i The gutter lines between columns break for a graphic that spans 
columns. 

It” You can have your text wrap around irregular shaped graphics. Create 

the graphic and be sure that Text Wrap Off is the active 
attribute. After you have drawn your graphic choose the Line Drawing 

Tool and a large “weight” (see page 266). Choose EO Text 
Wrap On from the Text Wrap menu and draw a series of lines that 
span the exact width and height of the area you want the text to 
wrap. When you have finished drawing all of these lines choose 
them all using the Shift key and change their fill pattern to none (see 
page 269) (alternatively, you can have the non-wrapping graphic 
attached to the page and the lines attached to the paragraph; this will 
facilitate selecting them; be sure to make them both share the same 
attachment attribute when you finish, or they will not remain 
together.). The text will then appear to wrap around the graphic 
when it actually wraps around the lines, which will be invisible, as 
illustrated in Figure 7-23. 

260 CHAPTER SEVEN 



In the valley by the lake ] knew I'd find Harvey. He 
was an inveterate fisherman. He didn't need to conquer the 
big fish from his high-powered boat; he was the quiet 
contemplative — turned onto Lake 
Drive and LM Yy cruised along 

: the shore <GSSoa Ry LEZ, few bungalows, 
half- RW See hidden in the 
trees OSS (belied the fact 

peak gS : 
that I was WINUWNY i SN in the second 
largest city in i Qe \Y California. It 
probably wouldn'tbe long before 
they'd all be replaced by condos. Harvey's old '60's vintage 
silver Porsche was parked off the road near the northern 
end. | pulled in behind him and called out through the swamp 
grass lush along the water line; he rarely took the rowboat 
out more than a few yards from shore. 

Figure 7-23 Text wrapping around an irregular shape 

Its” Text Wrap only affects the text on the text sheet, not the text graphics 
created using the Text tool. However these text boxes can also have 
text wrap around them as illustrated in Figure 7-24. 

In the valley by the lake I knew I'd find Harvey. He 
was an inveterate fisherman. He didn't need to conquer the 
big fish from his high-powered boat; he was the quiet 
contemplative kind. "] gq turned onto Lake 
Drive and slowly cruised 
along It WaS a @ fish the shore. 
The few bungalows, 
half-hidden in the trees belied the fact that I was still in 
the second largest city in California. It probably wouldn't 
be long before they'd all be replaced by condos. Harvey's 
old ‘60's vintage silver Porsche was parked off the road near 
the northern end. | pulled in behind him and called out 
through the swamp grass lush along the water line; he rarely 
took the rowboat out more than a few yards from shore. 

Figure 7-24 Text wrapping around text boxes 
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Overlay Attributes 

Graphic objects can have different attributes in relation to each other. 
They can be either opaque (like a normal piece of paper, you cannot 
see what is behind them), transparent (like a gel or glass, you can see 
right through them to what is behind), or invert (which causes the 

point at which graphics of the same “color” intersect to invert to the 
opposite color). While all of these attributes can be seen on screen 
they will all print only on a QuickDraw printer such as the ImageWriter. 
Current PostScript printers (such as some Apple LaserWriters) do 
not support all of these drawing modes at this time. 

Ks If you are using a PostScript printer choose As PostScript® from 

the Display submenu of the Tools menu to see how your graphics 
on the graphics sheets will print. 

The Opaque/Transparent Menu 

To change the overlay attributes of a graphic or graphics select them 

and choose the desired command from the Opaque/Transparent 
menu. 

The text entered on the text sheet of Nisus can be understood to lie 
between the two graphics sheets. It may be hidden by graphics on 
top of it. The graphics in the graphics sheets may hide one another, 
as well. The white portions of graphics may allow text and graphics 
below them to show through. 
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Opaque 

The fill pattern will cover both text and graphics behind it as shown 
in Figure 7-25. 

I If you have a PostScript printer save your Nisus New File with Opaque 
from the Opaque/Transparent and choose As PostScript® from 
the Display submenu of the Tools menu. 

¢ The four graphics in the figure all share the attribute of 

opaque. The triangle , while opaque, has a fill pattern of 
none. This allows whatever is behind it to be seen through 

it. The triangle is behind the circle S52 and in front of the 

text and long rectangle Uhl 

The text entered on the text 
sheet of Nisus can be under- 
stood to lie between Tey 
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through. 

Figure 7-25 Opaque graphics 
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Transparent 

This causes the white part of any fill pattern to be “see through.” 
Anything behind this graphic can be seen through the white parts of 
the fill pattern. 

The graphics in Figure 7-26 are the same as in Figure 7-25. What you 
see Is a screen shot of the window in which the graphic was produced. 
Because this document was printed on a PostScript printer the 
transparent attribute would not print. 

¢ Once again, from front to back, the images are: circle, triangle 
horizontal rectangle (opaque), and vertical rectangle. 

its” Transparent is only compatible with QuickDraw printers, not current 
PostScript printers. 
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Invert 

The icon above illustrates the Invert mode. When a graphic or line is 
displayed in this mode, what appears on screen is modified by what 

- 4§ under it, or what intersects, it. When two black lines or shapes arc 
drawn over each other the parts that overlap show up as white when 
Invert is selected. Otherwise the original color of the graphic is shown, 
as in Figure 7-27. 

m xis 
Figure 7-27 Invert display mode. A. Black filled square B. An “x” 

drawn in Invert mode C. The square on top of the “x”. 

The graphics in Figure 7-28 are the same as in Figure 7-25 and 
Figure 7-26. What you see is a screen shot of the window in which 
the graphic was produced. 
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¢ This time, though the sequence of graphics remains the same 
as in the previous two figures, their attributes are: circle 
(invert), triangle (opaque, none fill) horizontal rectangle 
(transparent), and vertical rectangle (invert). 

\@* PostScript printers do not support the Invert drawing mode for 
graphics at this time. This is a limitation of PostScript. It means that 
the printouts on such a printer will not show the effects of this attribute. 
Quick Draw printers will show these effects. 

Pen and Fill Tools 

The preceding commands all affect how a graphic or graphics interact 
with each other and/or the text. The following tools affect appearance 
of the selected graphic objects themselves, specifically the outline 
(Pen) of a graphic or its inside (Fill). 

If you want to change a characteristic of a particular graphic, select 
the graphic by clicking on it with the Selection Tool. Then use the 
Graphics Palette to make the desired change. You can change the 
width and/or the pattern of the perimeter, the Pen, of the graphic or 
change the pattern of a graphic’s fill. 

The lines in Nisus can be thought of as drawn by a pen. The thickness 
of the vertical and horizontal directions of the pen are adjustable. 

Line Weight 

Use the Pen Size Selector tool to set the horizontal and vertical 
thickness, or weight of the pen that is used to draw the object graphics. 
To select both horizontal and vertical weights of the pen together, 
click as in Figure 7-29 A Then click on one of the horizontal lines or 
fractions on the right side of the icon which represents the thickness 
you want (the thickness ranges from 5 points to one quarter point (or 
none), as illustrated in Figure 7-30. When you get to a thickness of 

266 CHAPTER SEVEN 



less than one point you will not see the difference on the screen, but 
they will be printed accurately if your printer has a resolution higher 
than one point (or 72 DP] — Dots Per Inch). Any changes to pen 
thickness, or weight will affect both horizontal and vertical directions. 
The horizontal pen thickness, or weight is selected by clicking as 
shown in Figure 7-29 B. Once selected, click on one of the horizontal 

- lines which represents the thickness you want. To change the vertical 
pen thickness, or weight, click as in Figure 7-29 C, and then click on 
one of the lines at the side to change it. 

Figure 7-29 Changing the pen size of A. both dimensions, 

B. horizontal pen length, C. vertical pen thickness, or weight 

click here for fractions of point sizes and "none" 

Figure 7-30 Whole and fractional line options 

ig You can draw lines of varying weights using this tool. You can even 
draw lines, at angles, each having a different weight depending on 
its angle as illustrated in Figure 7-31. 
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Figure 7-31 Different line weights created by different angles 

is Ovals, polygons and freehand drawings can also have “sides” of 
different weights as illustrated in Figure 7-32. 

Figure 7-32 an Oval, Polygon and Freehand drawing with different 
line weights on their sides 
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The Pen/Fill Selector 

You can change the pattern of your pen as well as your fill. Use the 
Pen/ Fill Selector to switch between them. 

Fill Pattern Selector 

When the selector is in this mode, any pattern you choose wil] fill all 
selected objects. Any new graphics you draw are filled with the same 
pattern until it is changed to a different pattern. 

is” You can place screens behind text graphics by selecting a fill pattern 
along with the Text tool. If you want the text to be transparent so 

that whatever is behind the text shows through, choose none = 

Another way of creating a screen (using the text and graphics sheets) 
is explained on page 257. 

Pen Pattern Selector 

When the arrows on the pattern selector look like this, any pattern 
you select will affect the frame of any selected objects. The frame or 
outline of a line is the line itself, so this is how you change the pen 
pattern of lines. Any new graphics will use this pattern for their 
outlines. 

ir The Text tool is not affected by this setting. It is either white or black. 

If you have one of the patterns selected the text will still be black. 

te The Pen Pattern Selector tool is useful for creating white text on a 
black background as explained in the instructions in Figure 7-33. 
This will print on any Macintosh compatible printer. 
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To create white text on a black 
s background, enter text in the 

Mm normal manner into a graphics text 
box. 

Using the selection tool select the 
text box. 

| In the Pen/Fill selector choose black 
for the fill and white for the pen. 

Figure 7-33 White text on a black background 

Filling Objects 

You can fill any object with a pattern. This is done with the Fill 
Pattern Selector. You can also fill the border (the Pen) of any object, 
that is: lines, arcs and arrows (except text) with a pattern using the 
Pen/Fill Selector and the Pattern Palette. 

| pattem Palette Scrolling 

The pattern scrolling tool changes the patterns that are displayed in 
the Pattern Palette. Click and hold the mouse button down on the 
left arrow to scroll one way and on the right arrow to scroll the other 
way. 
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3 Pattern Palette 

The Pattern Palette is filled with patterns. To set the current pattern, 
click on the desired pattern. The patterns cannot be edited. 

ie” Some PostScript print drivers, (these are Chooser documents; check 
your Apple @ menu), check the fill pattern that a graphic is drawn 
in. If that fill pattern matches some predetermined pattern, the driver 
will substitute the screen pattern with a PostScript pattern. This is 
very much like font substitution, where the print driver will substitute 
the printer font Times for the screen font New York. In practical 
terms, the gray scale in the Nisus Pattern Palette, illustrated in Figure 
7-34 may not print as displayed. You will get a half-tone of higher 
resolution for some of the Pattern Palette grays. This is totally in the 
control of the PostScript print driver and beyond the control of Nisus. 

. . 
evuanes 

auaee 
spaee 

afatare 
tat yty agete afarere 
spacers awe ce nan at etseee creer Mah TTI) Beene Oates 98%, LLL. Me 6 4 4 oe mete nee ate tat et 

eee ew ew ww tates sa%,8 ages . 
tat 

Figure 7-34 A screen shot of the gray scales in the Pattern Patette 

The Graphics Menu 

The Graphics menu, illustrated in Figure 7-35, appears in the menu 
bar when you enter the graphics sheets and when you double-click 
on a character graphic. It contains commands which supplement the 
tools available in the graphics palette. 
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Graphics 

Bring To Front 
Send To Back 

Group *%6G 

Ungroup *#6G 
Set Wrap Border... 

Unscale 

Duplication... 

Unrotaote 

Set Round Rects... 

Show Paste Spat 
oe TAT PE ir thet © tthe eS Tih © dein ayy Se | 

Center Justify 
Right Justify 

Figure 7-35 The Graphics Menu 

Bring to Front and Send to Back 

Any graphics on the Graphics sheet can overlap. When new graphics 
are created they are placed in front of the older ones. To move a 
graphic to the front of other graphics, select it and choose Bring To 
Front from the Graphics menu. To move a graphic behind other 
graphics, select it and choose Send to Back. 

Ite” Nisus remembers the sequence in which graphic objects were created. 
If you have created a variety of graphics that you later want to bring 
together you may notice that one or another of them does not appear 
where you expected it. That graphic was probably created earlier in 
the sequence and is behind some others. 

Group and Ungroup 

You can group graphics into a single graphic for ease of moving and 
resizing. When the graphics are grouped they can be resized with 
any one of four handles at each of the corners of a surrounding 
rectangle. 

Select the graphics to be grouped while using the Shift key or by 
using a selection rectangle, then choose Group from the Graphics 
menu. To ungroup a grouped graphic select the graphic and choose 
Ungroup. Deselect the graphics by clicking outside all of them. The 
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graphics that were members of the group will now be separate and 
each of them can be selected independently as they were before you 
grouped them in part A of Figure 7-36. You must click outside the 
area of the ungrouped graphics to unselect them all before you can 
then select one of them. 

Figure 7-36 Grouping Graphics. A. Graphics selected for grouping B. 
The same graphics after choosing Group from Graphics menu 

When you group graphics, they retain their individual attributes, 
such as fill pattern, frame weight, and transparency. Once they are 
grouped, however, changing any of these attributes will change them 
for every graphic in the group. You can use Undo to undo such a 
change, but in order to change an individual graphic you must first 
ungroup the grouped graphic and then select only that graphic. 

Ia” PICT graphics in a group will not change. 

i” The command Group does not appear with a check beside it when 
you have selected grouped graphics. 
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Set Wrap Border... 

You can change the border of white space to the right and left of a 
graphic that has the Text Wrap attribute. To do this, select the graphic 
and choose Set Wrap Border... from the Graphics menu. The 
dialog illustrated in Figure 7-37 will appear. Enter the number of 
pixels you wish to have to the right and left edges of your graphic 

then click (C set} 

Point size of border: [is 

Figure 7-37 the Set Wrap Border dialog 

Scale... 

You can scale (enlarge or reduce by a specified percentage) any graphic 
on the Graphics layer. 

Select the graphic and choose Scale... from the Graphics menu. In 
the dialog that appears click on the button that indicates which of the 
five points indicated (labeled 1 through 5 when the Command key 
is pressed) should remain stationary. Enter the percent that you want 
it to scale (either enlarge or reduce). For example, if you enter 50% 
in the Horizontal box, the length of the graphic will be reduced by 
half; the same value wil! automatically be entered in the Vertical 
box. If you want these to be different values you can use the Tab key 
to move between the two text boxes. Then click as illustrated 
in Figure 7-38. 
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Horizontal % 

go 

Vertical A 

[J Scale Text 

J Scale The Pen 

The Object Scaled Without The Object Scaled 
Text or Pen Checked With Pen Checked 

Figure 7-39 Scaled graphic with and without the Pen scaled 
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Amazing! 

The Original Graphic: 
a Text Box with a Rounded 

Amazing! 

Scale Text and Pen 

Amazing! 

Scale Text, but not Pen 

Amazing! 

Scale Pen, but not Text 

Amazing! 

Neither Scale Text nor Pen 

Figure 7-40 The various options of scaling text boxes 

Only the area of a graphic will scale unless Scate Text or Scale 
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the Pen is checked. If they have been checked, those aspects of the 
graphic will also scale. Figure 7-39 illustrates scaling with and without 
Scale the Pen checked. If graphics have been created ina program 
other than Nisus and, through importing, have become bitmapped 
graphics their “fill” will also scale. 

When you scale a graphic text, you can scale the text and/or the box, 
as well as any frame you may have drawn around the text and is 
grouped with it. This is illustrated in Figure 7-40. 

The values set in the dialog window are maintained throughout the 
duration of the current working session unless they are changed. The 
last value set is saved with the file. To scale another graphic using 
the same values, press the Shift key while you choose Scale.... The 
menu command becomes Quick Scale and the dialog is bypassed. 

I” This is useful for setting regularly used scaling proportions with a 
Nisus New File or other stationery file. 

In addition to the ability to undo a scale, many graphics that have 
been scaled in Nisus can be unscaled. Select the graphic or graphics 
and choose Scale..., then click (Unscate}, Those graphics that can be 
unscaled include PICT's, bitmapped graphics imported into Nisus, 
Polygons, Freehand Drawings, and Page Placed Graphics. If one of 
these items is not unscaling, try to ungroup it and then unscale it. 

Ks A simple Nisus object (one that has only the four Square handles on 
its corners) will not unscale. To be sure you will be able to unscale it, 
select it and cut it. Then press the Shift or Option key as you paste it. 
(The menu reads Swap Paste when the Shift key is pressed). It is 
now a complex graphic (one that has eight handles, four square handles 
on its corners and four rounded handles on its sides) and can be 
unscaled. 

Ie When you press the Option key as you choose Scale... the command 
is changed to Unscale and the Scale dialog is bypassed. 

i's” If no graphic is selected when you choose Scale..., the Macintosh 
will beep a reminder to select a graphic. 
Duplication... 
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You can duplicate any graphic on the Graphics sheets. 

Select the graphic and choose Duplication... from Graphics menu. 
In the dialog that appears (Figure 7-41) enter the number of copies 
desired then enter the distance they should be displaced from the 
original: how far vertically and horizontally from the upper left corner 
of the original the copies should appear. (You can choose either inches, 
centimeters or pixels regardless of what your ruler is measuring.) 
Click {| 0k fl and the graphic will be duplicated as illustrated in 
Figure 7-42. 

Copies (2 

@ Inches Horizontal 
© Centimeters 

© Pixels/Polnts a 

C) Duplicate To Pagas from: To: 

@Qal Onddd Oven 

Figure 7-41 The Duplication dialog 
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The Graphic Duplicated . 

Figure 7-42 A graphic selected then duplicated 

Creating Tables 

The duplication tool is an excellent way to create a table in Nisus. 
These tables are easily edited if your data changes. 

First, enter your text as you normally would using tabs and returns 
as illustrated in Figure 7-43. 
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search Multiple Files 

Index All 

Built In Macros 

Graphics Layer 
Automatic Saving 
Unlimited Undos 
Multiple, Editable Clipboards 
Non-Moda! Open Dialog 
Non-Modal Page Preview 
Extensive Window Management 
Different Header/ Footer on Each Page - 
Pamphlet Format with One Click 
Automatic Pagination ++ eet teeete ee eye * @ @© b§ b» © § © ££ © BP & 4 

Figure 7-43 Preparing Text for a Table 

Then draw the line that will separate the rows of your table. Choose 
Duplication... from the Graphics menu. Set the Horizontal offset 
at 0, the Vertical offset at one pixel greater than the point size of 
your text, as illustrated in Figure 7-44. You may need two if the 
point size or line spacing is larger; this adjusts for ascending and 
descending characters (the larger the size, the greater the number of 
pixels required). Set the Copies number to whatever is required, 
then click {__ 

© Inches Horizontal 
© Centimeters 

Vertical 
@ Pixels/Points 7 

(} Duplicate To Pages From: To: 

@Ril Odtd Oven 

Figure 7-44 Setting duplication dimensions for tables 
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You can do the same with the vertical lines (if you have enough 
columns to warrant it). Repeat the above procedure with the ap- 
propriate quantities, setting the vertical offset to 0 and the horizontal 
offset to whatever is necessary. The lines will lay themselves out 
perfectly, as illustrated in Figure 7-45. 

Nisus Most Others 
Search Multiple Files 

ndex A 

Built In Macros 

Graphics Layer 

omatic Saving 

Unlimited Undos 

Multiple, Editable Clipboards 

on-Modal Open Dialog 

Non-Modal Page Preview 

Extensive Window Management 

Different Header/ Footer on Each Page 

Pamphlet Format with One Click 

Automatic Pagination 

Figure 7-45 A completed table 

The values set in the dialog window are maintained throughout the 
duration of the current working session. To duplicate another graphic 
using the same values, press the Shift key while you choose 
Duplication.... The menu command becomes Quick Duplicate 
and the dialog is bypassed. 

te” Quick Duplicate is useful for setting regularly used scaling propor- 
tions with a Nisus New File or other stationery file. 

In the Duplication dialog, check the Duplicate to Pages box to 
have a page-attached graphic appear in the same relative position on 
a range of pages at once. You can duplicate graphics so that they 
appear on every page of your document (the preset value), or you 
can determine the range as well as whether it should be on odd, 
even, or all pages. You can use this to put a screen behind text (such 
as a “watermark,” “COPY,” or a shaded half-tone), frames around 
specific pages, or a company logo. If you have selected a Move With 
{I graphic when you choose Duplication... and check the Duplicate 
to Pages box, Nisus will beep at you. To return to the duplicate 
with offset mode of this dialog simply uncheck the Duplicate to 
Pages. 
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i= If no graphic is selected when you choose Scale..., the Macintosh 

will beep a reminder to select a graphic. 

Rotation 

You can rotate any ungrouped graphic on the Graphics layer through 
multiples of 90°. 

Select the graphic and choose Rotate Right 90° from the Graphics 
menu. The graphic wil] rotate 90° in a clockwise direction around its 
midpoint, as illustrated in Figure 7-46. If you want to rotate a graphic 
in the other direction, press the Shift key and choose the same item. 

The menu will read Rotate Left 90°. The graphic will rotate 90° in 
a counter clockwise direction. 

4. 
QIES> OOOO 

929,6.0,04 

Rotate Right 90° Rotate Left 90° 

Figure 7-46 Rotating Graphics 
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Figure 7-47 Rotating Text Boxes 
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It is also possible to rotate text created on the graphics sheets, as 
illustrated in Figure 7-47 

Rounded Rectangles 

Choose Set Round Rects... from the Graphics menu or double- 
click on the Rounded Rectangle tool. You may change the curve of 
the corners of new rounded rectangles drawn with the Rounded 
Rectangle tool. 

Rounded Corner Rectangle Options 

xn Of xo xcOf xDOf REO f 

MU @ User Oefined: 

A user-defined rounded rectangle is shown being defined in Figure 
7-48. The three handles on the oval allow you to reshape the corners 
of the rounded rectangle. The middle handle allows you to resize 
both dimensions of the oval, while the other handles are limited to 
one dimension. As you change the shape of the oval, the corners of 
the rounded rectangle change to curve around it. 

you draw rounded rectangles, they will have the corners you have 
defined. 

ile” See PostScript Limitations at the end of this chapter, page 288, for 
limitations on the printing of user-defined rounded rectangles. 
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Show Paste Spot 

Nisus will paste any graphic you have on your clipboard at the last 
point clicked in your document window. If you wish to see this spot 

choose Show Paste Spot from the Graphics menu. A small dotted 

corner { will flash at the upper left hand corner of where the graphic 
will be pasted. If you do not want to see the insertion point flashing 
all the time, but just when you want to paste, press the Command 
key to activate this command. 

Graphics Text Justification 

The text in graphics text boxes can be justified either flush left, centered 
or flush right. Choose either Left Justify, Center Justify, or 

Right Justify from the bottom of the Graphics menu, respectively. 
This can be set as an attribute of your graphics text boxes and saved 
with your Nisus New File. 

Moving Small Graphics 

Pointer Position Indicators 

{EDS small object ELIE =e sméit object Eis 
h aneraesi r SBS Tr 

FIOM IIOuR 

Figure 7-49 Moving a small graphic 

WORKING WITH GRAPHICS 285 



Small graphics are often hard to select and move. In order to accomplish 
this, select the small graphic along with a larger graphic nearby (you 
may need to create a temporary larger graphic) and move the two 
together. Place your pointer directly on the smailer graphic and move 
it noting its exact placement in the vertical and horizontal rulers, as 
illustrated in Figure 7-49. 

i” When you are making fine adjustments to your graphics it is sometimes 

difficult to see precisely where a graphic is being moved because of 
the presence of the pointer or Selection Tool. You can adjust a graphic 
by grabbing on any portion of its handle. You can also hide the 
Selection Tool by pressing the Command key as you make your 
adjustment (the pointer does not disappear until you actually move 
the mouse). 

i When placing graphics in your document it is advisable to paste 
them on the text sheet (i.e. in the text mode) whenever possible. You 
can create a graphic on the graphics sheets and then cut it and paste 
it on the text sheet. You will only need to have graphics on the 
graphics sheets when they need to overlap text or have text wrap 
around them. Graphics pasted into the text sheet will update more 
rapidly as you edit the text of the document. 

is A graphic at the top of the document is anchored to the top of the 
document as there is no return character to anchor it. Thus, if you 
add new paragraphs at the beginning of the document, the graphic 
will not move. You must go to the graphics sheet and move it so that 
it attaches itself to another paragraph. 

Importing Graphics 

You can import graphics into the graphics sheet from other programs 
by using the Clipboard or the Scrapbook. If you paste a bitmap created 
with a paint program, it becomes a single object in Nisus. 
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Normally if you paste grouped object graphics from another graphics 
program into the Nisus graphics sheet, the groups can be ungrouped 
and individually edited, just as if they were created in Nisus. The 
dialog illustrated in Figure 7-50 will appear. If you want to paste 
them as a single group without the possibility of ungrouping in Nisus, 

click . You can bypass this dialog by pressing Shift 

while pasting. 

How would you like to paste this 
A picture? “PICT” is faster and 

pastes as one object. “Nisus 

Objects” separates all the objacts. 

See the manual section “Importing 

Graphics” for more details. 

Nisus Objects 

Figure 7-50 The Paste PICT dialog 

Is This grouping is necessary when pasting a graphic with imbedded 
PostScript commands into the graphics sheet. When you paste such a 
graphic into the text sheet, the PostScript commands are automatically 
included in the character graphic. On the graphics sheet, however, 
they are recognized as separate objects. In such a case, the dialog 

shown in Figure 7-51 appears. If you click (Pict —_Y) the 

PostScript commands are grouped with the bitmap as a single graphic. 
Press Shift while pasting to bypass this dialog. 

How would you like to paste this 
aN picture? “PICT” is faster and 

pastes as one object. “Nisus 

Objects” separates all the objects. 

See the manual section “Importing 
Graphics” for more details. 

NOTE: This picture has embedded 

PostScript®. Therefore it may not print like 
the originol, unless you click “PICT”. 

Nisus Objects 

Figure 7-51 the Paste PostScript dialog 
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Copying to the Graphics Sheet 

You can copy and paste graphics between text and graphics sheets. 
You can draw object graphics on the graphics sheet and then paste 
them as a character graphic on the text sheet. 

You can also do the opposite: copy a character graphic and paste it 
on the graphics sheet. This allows you to choose which method you 
want to use for attaching graphics to the text. It also gives you the 
ability to wrap text around any graphic or have the graphic on top of 
the text, opaque or transparent—just transfer it to the graphics sheet. 

is” When you press Shift as you paste a graphic on the graphics sheets 
you do not swap paste. Instead, if it was a simple Nisus object (which 
has only four square handles on its corners) it is now a complex 
graphic (which has eight handles, four square handles on its corners 
and four rounded handles on its sides) which can be unscaled after it 
has been scaled. 

PostScript Limitations 

If you print your document on a PostScript LaserWriter, some of the 
graphics may not print as they are displayed on the screen and printed 
on other (i.e. QuickDraw) printers. This is because some of the features 
supported by Nisus are not supported by the PostScript driver. This 
affects the following features: 

e Rounded Rectangles 
¢ Transparent Fills and Pen Patterns 
¢ Invert drawing mode 

i” To display on screen what a PostScript LaserWriter will print, choose 
fis PostScript® from the Display submenu of the Tools menu. 
This command only applies to the graphics on the graphics sheets. 
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Rounded Rectangles 

When using a PostScript LaserWriter to print user-defined rounded 
rectangles, the top curvature will also be used for the side curvature. 
The difference is illustrated in Figure 7-52. 

~ As Printed on 
the LaserWriter 

As Drawn byNisus — re 

Figure 7-52 A user-defined rounded rectangle is changed when 
printed on a PostScript printer 

This occurs only if a user-defined rounded rectangle with unequal 
curvatures is used. 

Invert Attribute 

A PostScript printer does not support this mode and has no effect on 
the output of graphics. 

A Technical Afterword 

What is a PICT 

A PICT is the primary means of graphic data exchange on the 
Macintosh. A PICT is actually a collection of graphics primitives. 
Nisus understands and can work with both PICTs and graphic 
primitives. Nisus understands nine graphics object types, these 
include: lines, rectangles, ovals, arcs, “regions” (an amorphously 
shaped graphic), polygons, bitmaps, text and PICTs. You can edit 
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and modify all these graphics on a graphics sheet within Nisus. When 
you paste a PICT on to the graphics sheet Nisus will automatically 
“take the PICT apart.” This means that Nisus will convert the PICT 
to graphic objects. If the PICT you are pasting on to the graphics 
sheet is larger than 1.5K in size or has any PostScript in it then Nisus 
will ask you if you would like to have the PICT taken apart. Also if 
you double-click on a PICT type graphic object then a “Graphic for...” 
window will open. This window contains the graphic primitives of 
the original PICT. That is to say that the PICT has been taken apart. 
If you change this graphic then the original PICT will be replaced by 
the newly edited PICT. 

PostScript and other Data in PICTS 

A PICT can contain PostScript and other information that is not a 
graphic object. When you take apart a PICT that contains these this 
information is removed from the PICT, though all graphics object 
information is retained. So for example if you create a picture of a 
flower in a graphics program that generates PostScript output and 
copy it to the clipboard, this picture may actually have three versions 
of the flower in the PICT. One version is for display on screen, another 
version is for printing on a PostScript printer, and the third version 
may hold information that is specific to the application that created 
the PICT. If you take this PICT apart Nisus will remove the PostScript 
and all other “invisible” data. 
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° 
Desktop Publishing and 

Introduction 

HyperText Links 
using Page Graphics 

You can place a graphic image of any Nisus document (one page at a 
time) in any other Nisus document. That image is linked to the original 
fite. You can open the original file by double-clicking on it. You can 
place a page graphic on the graphics sheets, or on the text sheet. As 
such, they will respond as other graphics do in those environments. 
You can place an already existing file or you can create and place a 
new file at any time. 

The following specialized terms are used in Placing pages: 

Term 

¢ Parent 

¢ Child 

« Place 

e Barren file 

Meaning 

the primary document into which you 
place a page. 

the Placed Page Graphic file placed into 
a Parent document (multiple genera- 
tions are possible). 

the process of linking one file with an- 
other (using the above metaphor, this is 
like adoption when choosing Place 
Page... or producing your own Child 
when choosing Place New Page). 

a Parent document that has had the links 
to its Child file or files broken (either 
through their being moved or de- 
stroyed). (English has no unique term 
for this phenomenon.) 
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Placing a Page Graphic 

Choose Piace Page... from the Tools menu. When the Place Page 
version of the Open dialog Figure 8-1 appears you can choose from 
any Nisus file already created. If a file has more than one page you 
should indicate which page of that file you wish to place, as only one 
page of a file is placed at a time (counting in absolute page numbers 
not as numbered in the document). The file is placed with all fonts 
and graphics in their original size. You can resize and/or crop the 
entire graphic after placement, and also scale the graphic using the 
graphics tools of Nisus. You can also choose the scaled proportion 
before placing if you wish. 

Please iocate the document to place here. 

D 4/11/89 

D 4/17/89 
D 5/16/89 

D 6/22/89 
D 7/15/89 

D 8/22/89 
D 8/2389 
D 9/13/89 

o) 

Figure 8-1 The Place Page... dialog 

Only numbers can be entered in the text edit boxes at the bottom of 
this dialog, if you type alphabetics they will scroll the list of available 
files that you can place. 

When the settings are as you desire, click f 

If the Placed Page Graphic is larger than the page of the Parent 
document, the warning dialog illustrated in Figure 8-2 will appear. 
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This PPG is larger than the page 

Figure 8-2 The Place Page waming dialog 

The width of the graphic placed is determined by the page margins 
set in Layout Page (the gray area on the Master Ruler). The height of 
the graphic depends on whether it is placed on the graphics sheets or 
the text sheet. 

¢ On the text sheet the height of a Placed Page is already set 
to an inch and a half. 

* On the graphics sheets the height of a Placed Page is 
determined by the height of the original page. 

The placed page will appear in the Parent document with the four 
handles of a pasted graphic object. You can crop or resize the image 
by adjusting either the rounded or square handles respectively. 

You can open the placed file to edit it any manner, by double-clicking 
on it. 

ia A page placed on the text sheet behaves as if it were a character 
graphic. A page placed on the graphics sheets always appears with 
the attribute of Fix to Page, though this can be changed simply by 
choosing Move with 9 from the Page/ menu. 

is A Child file can be placed in more than one parent document. 

Placing a New Page Graphic 

To place a page that does not yet exist in your document, choose 
Place New Page from the Tools menu. The object illustrated in 
Figure 8-3 will appear at your insertion point. 
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Le 

Resize and double-click | 

this box to edit. 
OO es | L 

Figure 8-3 the Place New Page edit box 

As indicated in the placed object, you can resize this object to whatever 
proportions you want, and, if it is on a graphic sheet, you can move 
it wherever you wish (on the text sheet it functions as a character 
graphic). When you double-click on it Nisus will open a new Child 
file the size of the box you have defined. If you have created one, it 
will open your Nisus New File (in which case, the width of the line is 
actually determined by the width of the margins as set in Layout 
Page... rather than by the way you drag the original object). If you 
do not have a Nisus New File, the margin limits will be set as you 
have defined the box. You can edit this file just as any other Nisus 
file. 

Uses for Page Graphics 

The Placed Page Graphic is a very useful tool for desktop publishing 
and for on-disk inter file communication. 

Desktop Publishing with Page Graphics 

Placing Page graphics both on the graphic sheets and the text sheets 
of Nisus allows you extreme flexibility in shaping the appearance of 
your page. 

Different Column Widths 

You can use a placed page to mix different column formats and/or 
have a document with independent columns of varying widths. 
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¢ You can set up the left column of a letterhead stationery as 
illustrated in Figure 8-4. 

The Housing Authority 

fremmare 

Mr. David R. Lacteren 
Eemcufive View President 
Bast industries of herw York, ire. 

Rati Iaeee P Vytd te 

The Unetied Syregapue 

Fremtaeet 
The Rev, Ralph E Lindgusst, DD. 

Mor emer 
Kathienn P PerdeNen, Ph.D. 

ae letterhead example n Ss oe 

Beer Herb, 

It is with pleasure the! ] share with you our Annual 
Report Open House. 

You have hed an impartan! pert in our werk and | 
went you to know how graisful we are to have you 
es 6 friend and supporter. 

With all good wishes, J em. 

Cordially yours, 

The Rev. Ralph E. Lindquist, D. D. 
President P 

REL:mm 

anci. 

Figure 8-4 Left Column letterhead stationery 

¢ You can have a three (or other number) column newsletter 
with a separate article spanning two or more columns. 
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Po ad J ° oc : ie 
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Figure 8-5 A rotated Page Graphic placed on the back of a Threefold 
flier 
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Rotate Sections of Text 

You can place a page from another document and rotate it in the 
Parent document. 

¢ One example of this technique was used shown in Figure 
4-89 on page 167. Figure 4-90 on page 164 and Figure 4-91 
on page 165, of this manual. 

¢ Another example can be seen in Figure 8-5 where a rotated 
page graphic is used as the back panel of a threefold flier. 

Create Complex Graphics 

You can create graphics that appear to disobey the rules of Nisus as 
illustrated in Figure 7-18 on page 254 through Figure 7-24 on page 
261 (except Figure 7-20, which is a very simple, filled polygon graphic 
on the graphics sheet behind the text). Each of these is a small document 
that exhibits Display attributes of a file that are not attributes of the 
Parent file. 

HyperText using Page Graphics 

felt 

[| es Memo> Marina re Statione T 

Cs) Ye 

To: Marvina 
Fram: a 
Date: , June 6, 
Re: Latest File pdate 

just finished this mockup of the corporate stationery, 
Double click an our logo (the button here: ofc ) to see how it 
looks. All the related files are here on disk. Feel free to make 
any editorial or artistic changes you like. They'll all be auto- 
matically updated. 

AES R Ol St ARARA oe deb Az cis rata detels tabs MUAH AAR cht beside date Liielt eb dtah hehe LER CG Goo Gece 

; ea Path he ae “reer parr attey a H e Bs te F fecsta Bates ¢ epats Pea tes Saran toes ey ght iB pare or ey piece ars ractesadetse speeet tetas sangre seine y iefegets rvs 

3 seat ra {s) [a] by 

+ 

= 

: 
33: 

: 
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You can insert a page graphic anywhere in your file and resize or 
crop it down to the size of a “button.” So long as the link with the 
original file has not been broken, when you double-click the button 
in the Parent, the entire original Child file opens for reading and/or 
editing. An example of how a button can be included in a file is 
illustrated in Figure 8-6. 

Breaking Links 

If you rename, move or destroy a Child file you will destroy the link 
between it and the Parent document, causing it to become a Barren 
file. If you then try to open the Child file from within the Parent, (by 
double-clicking on the graphic representation of that Child file that 
had been placed in a Parent document), a variant of the Place Page 
dialog, as illustrated in Figure 8-7, will appear asking you to find the 
original file. You can place any file at this time. If the Original file has 
been renamed or moved, simply place the file with the new name or 
the original file from the new folder. If the original file has been 
destroyed, all that remains is the graphic representation of that file 
and you will not have access it. 

Please locate the file “Placed Page” to place 

— Macintosh HD 

O 10 Creating Tol's and tn... 

07 
D brake that link 
© current work 
CG HardDisk 

© INCLUDE JN MANUAL 
DO mortagages 
© new bugs 
D New Duplicate dialac 

Page Number: (| Scoie page [100 | 

Figure 8-7 The broken link Place Page... dialog 

A Child file that appears in a Parent document can be altered and 
saved to another folder or disk. Choose Save As... to accomplish 

298 CHAPTER EIGHT 



this. However, be sure to choose Save As... and save it to its original 
location as well. Otherwise the Parent document will become Barren. 
If this occurs you will have to search for Child file if you want to 
make any changes in it that should appear in Parent document. 

Assorted Facts Regarding Placed 
Page Graphics 

° One Child can be placed in many Parents. 
¢ Different parts of one Child can be placed in different parts 

of one Parent and/or different Parents. 
¢ The same part of any Child can be placed in different parts 

of one Parent and/or different Parents. 
* When a Child is change, its appearance will change when 

its Parent is opened. 
All Placed Page Graphics on the graphics sheets enter as 
though Transperent is the current setting of the Graphics 
Palette (though they print as such only on QuickDraw 
printers). 

¢ Placed Page Graphics placed on the graphics sheets enter as 
though Fix to Page is the current setting of the Graphics 
Palette. 

* Placed Page Graphics placed on the graphics sheets enter 
and assume the attributes that are currently set for the 
Front/Behind Text and Text Wrap menus. 

Reading Nisus Documents with 
PageMaker® 

Included with Nisus is an application called ‘PMinstall’. If you have 
PageMaker version 2.0a or 3.0, this application will modify PageMaker 
so that you can “Place...” Nisus documents and stationery. It does so 
by copying a resource called an import/export filter into the 
PageMaker application. 

In order to install Nisus' filter you must first remove the Smart ASCII 
Filter PageMaker uses to import data from other word processors. 
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Using a copy of PageMaker dedicated to Nisus, open PageMaker's 
Installer and remove the Smart ASCII Filter. Save this new version of 
PageMaker and then run the program PMinstall shipped with Nisus. 

After opening the installer application you will be presented with a 
dialog with three buttons: Install, Remove, and Quit. To copy the 
import filter into PageMaker, click Install then choose the PageMaker 
application you wish to modify (a dialog showing PageMaker 
applications to choose from will appear). To delete the filter from a 
modified PageMaker application, click Remove and choose the 
application. After the operation is performed, a dialog will appear 
with a success message. 

its” Never modify your original application; make a backup copy of 
PageMaker and install the filter into the copy. 
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9 
Working with the Glossary 

The Nisus glossary saves typing effort and maintains consistency 
within your document. As you write, Nisus associates short 
abbreviations with long entries. At your command, it replaces the 
abbreviations with the corresponding glossary entries. The Glossary 
submenu of the Tools menu is illustrated in Figure 9-1. 

Replace 

{Lopy to Replace 

Mark Text... 

Jump To > 
Cross Reference... 

Update H-Reference 

Spelling... 

Thesaurus... 

Hyphenate 

Place Page... 
Place New Page 
Glossary 

Edit Taals 

Display 

Windows 

Macros 

%\ Expand Abbrev. 
Edit Glossary 

New Glossary Entry... 
New Glossary... 
rr mms + cee ts ey 

wTvrwvT Whe 

Figure 9-1 Tools menu with Glossary submenu showing 

You can use the glossary to avoid typing frequently used blocks of 
text, such as a company address or logo, or to spell out an acronym. 
For example, you can write usa instead of United States of America 
and then have the glossary make the substitution later. This will not 
only save time while typing, but will guarantee that the substitution 
is consistent throughout the document. Notice that the abbreviation 
usa is used instead of the more obvious, USA. This is to avoid any 
conflict with parts of a document where you want to write USA. 
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Care should be taken when assigning abbreviations to glossary entries. 
Choose an abbreviation that will not accidentally match other text in 
your document. For abbreviations that match the spelling of words, 
use all uppercase letters to distinguish the abbreviation from the 
word. 

oO Untitled Glossary 

<Abbreviation> 

Figure 9-2 An empty glossary 

An empty glossary is shown in Figure 9-2. To access it, choose Edit 

Glossary from Glossary submenu of the Tools menu. The 
abbreviations are displayed on the left side, and the glossary entries 
on the right. 

Creating, Naming and Deleting 
Entries 

To make a new entry, choose New Glossary Entry... from the 
Glossary submenu of the Tools. The Abbreviation dialog as shown 
in Figure 9-3 appears. 

Rbbreviation: 

CHbbrewvration> 

Figure 9-3 Abbreviation dialog 
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Type the abbreviation that you want to represent the glossary entry 

into the text edit box (where you see the word <Abbreviation>. 
Note that you cannot use any spaces or tabs. After typing the abbreviation, 

[ 0K Jor press Return or Enter. If that abbreviation is already 
used in the glossary, you will be notified with the dialog shown in 
Figure 9-4 so that you can type one that does not conflict. 

The abbrevistion “exp” already exists 

Figure 9-4 Abbreviations must have unique names 

You will then see the new abbreviation in the Glossary window and 
the insertion point will prompt you for the expanded text. 

To delete an entry and its abbreviation, double-click on the 
abbreviation in the Glossary window to bring up the Abbreviation 

dialog and then click Empty glossaries always contain a 
single entry and this cannot be deleted. 

Editing Entries 

To edit an existing glossary entry choose Edit Glossary from the 
Glossary submenu or press the Option key while you choose the 
abbreviation you wish to edit from the list that appears at the bottom 
of the Glossary submenu. 

ls When the Glossary window is open the Glossary submenu is 
available by pressing the Option or Command key as you click your 
mouse on the title bar. 

Associate an abbreviation with text by typing or pasting the text on 
the right side of the glossary window. You may also format the text, 
give it attributes (fonts, sizes and styles), have it include index and 
contents text, and even graphics, as illustrated in Figure 9-5. 
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Text of glossary entries automatically appear with the attributes Any 

Font, Any Size, + Any Styles, or Any Color. This means that 
the text of the entry will take on the attributes of the text in the 
document. If you want an abbreviation's text to retain specific 
characteristics (such as a foreign language or special character font) 
be sure to assign them in this window. 

Cl Untitled Glossary 

Figure 9-5 An example glossary entry 

Note that in order to use graphics in the glossary, they must be 
pasted in because the graphics palette is not active in the glossary 
window. Open a new document, draw your graphic in it, then copy 
and paste it into the glossary as a character graphic. 

Glossary Substitution 

Glossary substitution is very flexible in Nisus. You can insert the 
abbreviation's text directly from the Glossary submenu of the Too!s 
menu simply by choosing it. If you are typing the abbreviations you 
can expand a single abbreviation immediately to the left of your 
insertion point as you are typing, or wait and substitute all glossary 
abbreviations in the document or in selected text at once. 

Expanding an Abbreviation 

To expand the one abbreviation immediately to the left of your 
insertion point, choose Expand Abbrev. from the Glossary 
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submenu of the Tools menu or use its key equivalent (shipped as) 
#\. 

Expansion will occur even if you have some amount of white space 
between your insertion point and the abbreviation. White space 
includes spaces, tabs, and returns. 

To expand glossary definitions in a selected region of your text: 

* Select the portion of the document where you want glossary 
substitution to occur. 

« Choose Expand Abbreu. from the Glossary submenu of 
the Tools menu. 

To substitute glossary entries for their abbreviations in the whole 
document: 

« Choose Select All from the Edit menu. 

« Choose Expand Abbrev. from the Glossary submenu of 

the Tools menu. 

To substitute glossary entries as they are typed: 

* Type the abbreviation. 
e Choose Expand Abbrev. or use the key equivalent # \. 

The abbreviation preceding the insertion point will be converted to 
its glossary definition. 

ts” Note that glossary abbreviations are case-sensitive. No match will be 
found unless the abbreviation is a distinct word separated from other 
words and punctuation marks by at least one space. That means 
abbreviations which are parts of other words will not be matched 
unless they immediately precede the insertion point. 

If you place the insertion point in the middle of a word and choose 
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Expand Abbrev. or its key equivalent, the characters to the left of 
the insertion point will be interpreted as an abbreviation. 

Using Multiple Glossaries 

You may keep separate glossaries which hold different categories of 
glossary entries. The currently loaded glossary is the only one available 
for your immediate use. 

Organizing Multiple Glossaries 

It is a good idea to organize glossaries so that each one contains 
terms for a specific purpose. For example, you might have corporate 
abbreviations, letterheads, legal terms in one glossary file, and a 
general glossary in another. Because glossary entries match all 
occurrences of their abbreviations in the document, it is important to 
know which abbreviations are in the current glossary. 

Creating New Glossaries 

Any glossary entries created are put into the glossary named Nisus 
Glossary by default. If you want to place entries in another glossary, 
create it by choosing New Glossary... from the Glossary submenu 
of the Tools menu and give it a specific name by saving it. Choose 
Save from the File menu while the glossary window is active. When 
you create a new glossary, it becomes the current glossary. Any changes 
you make will affect the newly created glossary unless you change 
glossaries. 

Loading Existing Glossaries 

The glossary named Nisus Glossary, (located in the folder containing 
Nisus or in the System Folder), is loaded automatically when you 
start Nisus, and is the current glossary unless you select a new one. 
The current glossary is preceded by a check mark in the Catalog. To 
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change glossaries, find the glossary you want in the Catalog and 
open it just as you open a document. The name of the currently open 
glossary appears in the title bar of the Glossary Window. 

Importing Glossaries 

Entries can be copied from one glossary to another. Open the source 
glossary and copy or cut the entries you want to move. Then open 
the target glossary, place the insertion point in any definition and 
paste. Note that if you select across several glossary entries, copy, 
and paste into the new glossary, the abbreviations will also be pasted, 
except for the first glossary abbreviation. The first abbreviation must 
be restored manually. 
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10 
Creating Tables of Contents 

and Indexes 

Introduction to Tables of Contents 
and Indexes 

Format 

insert Ruler 

Insert Header 

Insert Footer 

insert Footnote 

Insert Page Break 
Keep On Same Page 

insert Date 

insert Time 

insert Doc Name 
insert Page # 

Update Time & Bate 

Set Date & Page* Formats... 

Mark Index 

Index As... 

Make index... 

Mark Contents 

Make Contents... 

Figure 10-1 The Format menu showing the commands for marking 

text for the Table of Contents and Index 

A Table of Contents is a list of headings related to specific sections of 
your document with page numbers that indicate where discussion of 
that subject begins. It is usually placed at the beginning of a document. 
It is possible to have various tables of contents: one for text and 
another for illustrations. Items in a Table of Contents are listed in the 
order in which they appear in the document. 
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An Index is an alphabetical list of words or phrases followed by page 
numbers indicating where key topics can be found anywhere in the 
document. It is usually placed at the back of a long document allowing 
key topics to be located quickly. It is possible to have various indexes: 
subjects, proper names, foreign words, etc. 

You can mark text in your document which you want to appear in 
the Table of Contents or Index. Such text will be shown with a dotted 

box around it when you choose Text Hilites from the Display 

submenu of the Tools menu: The Index or Table of Contents is later 
created in a separate document which can be edited. 

The Simple Techniques 

Adding Entries 

To add an entry to the Tabie of Contents and/or the Index, select the 
text to be added then choose Mark Contents and/or Mark Index 
from the Format menu illustrated in Figure 10-1. Hierarchica! 
contents or index generation is not supported—all entries will be 
copied to the Contents and/or Index documents exactly as they appear 
in the document. 

If you want entries to be indented in the Contents and/or Index 
documents, they must be preceded by a tab, which can be made 
invisible in the document by selecting the tab character and choosing 
Invisible from the More Styles submenu of the Style menu 
(thereby not affecting the formatting of your main document). Any 
white space you select when adding an entry will be included along 
with the text when the Table of Contents and/or Index is created. 

You can use this feature to separate sections automatically. Select the 
return character preceding the entries which begin a new section in 
the Table of Contents. Position the insertion point at the end of the 
preceding line, then click and drag to the end of the next line. The 
return character will be transferred along with the heading into the 
Contents document to produce a blank line before the heading. 

310 CHAPTER TEN 



If you want text to appear in the Contents, but not in the document, 
make the text have the invisible style. Type the entry as you want it 

to appear in the Contents document, select it, choose Mark 

Contents, and then choose Invisible from the More Styles 

submenu of the $tyle menu. The text will be visible only in the 
Contents. A small vertical dotted line will designate existence of the 

“invisible text in your document. To see it, select Invisible Text 

from the Display submenu of the Tools menu. 

ia? Only the text is copied, not its attributes. When you create the Contents 

and/or Index document, the text will appear in Geneva 12 point 

Plain. You can make final format decisions when all entries have 
been made. 

Removing Entries 

To remove an entry from the Table of Contents and/or the Index, 
select the entry (or just a part of it) and choose Unmark Contents 
and/or Unmark Index from the Format menu illustrated in Figure 
10-2. At least one character of the entry must be selected for this 
menu item to be active. Partially selected entries will always be 
automatically expanded to include the whole entry before they arc 
removed. 

Format 

Insert Rujer 

Insert Header 

insert Feoter 

insert Faotnote 

Insert Page Breek 
Keep On Seme Page 

insert Date 

insert Time 

insert Dac Nome 

Insert Page * 
Update Time & Date 

Set Date & Page* Formats... 

Unmark Index 

inden As... 

Make Index... 

Unmerk Contents 

Make Contents... 

Figure 10-2 The Format menu showing the commands for unmarking 
text for the Table of Contents and Index 
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te” The commands for marking and unmarking text for the Table of 
Contents and Index are enabled only when text is selected. The 
commands toggle on and off depending on whether or not selected 
text has been marked. You can tell if text is selected for the Table of 
Contents or the Index by pulling down the Format menu and 
checking to see if the command reads Mark or Unmark. If the 
command says Unmark, the text is marked. The converse is also 
true. 

ie You can remove all selected text (contiguous or noncontiguous) from 
the Index or Table of Contents at once. Press the Shift key and choose 
Remove from index or Remove from Contents from the 
Format menu. You can also remove the Index As attribute from 
selected text, but this text must be selected contiguously. Press the 
Shift key and choose Remove index As from the Format menu. 

Building the Contents Document 

To create a Table of Contents document which contains all currently 
marked entries, choose Make Contents... fromthe Format menu. 
This should be done when all the entries have been marked, but may 
be done at any time and any number of times to check on the current 
status. The Make Contents Options dialog window illustrated in 
Figure 10-3 appears from which you can make choices about the 
appearance of your Table of Contents. You may specify more than 
one column in the Table of Contents document. The remaining options 
are for page number placement and format. When you click (ok) 
the Contents will be built by gathering each entry in the order that it 
appears in the document. Contents entries are placed in a separate 
document which can be edited. 
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Make Contents Options 

Number of columns [fi] 

Page number position 

#1 © None 

%2 © Following entry 
2 %3 © (Fallowing entry) 

*4 © Right justified 

%5 @ Right justified with leader 

Figure 10-3 Make Contents Options Dialog with default options 

Nisus opens a new file window, attaches the word “Contents” to the 
source document file name, and uses that for the contents file name. 
Once created, the contents file is just like any other file. It is not 
linked to the source document file in any way. If you edit your 
document you may need to re-create the contents. When you try 
saving the contents file you will notice that you have to give it a 
name. [ts window name is only temporary, and could in fact be too 
long to use for saving. 

Building the Index Document 

To build the index, choose Make Indeu... from the Format menu. 
You will be presented with a dialog as shown in Figure 10-4. Text 
you have selected for indexing will be compiled and placed in a new 
document. 
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Make Index Optians 

Number of columns fr 

*S (J Blank line between sections 

*L BJ Label sections 

*BEIBold #! LC Italic 

*, OJ Insert comma after entry 

Page number position 
*%1t ONone 

%2 © Following entry 
%3 © (Foliowing entry) 
*%4 © Right justified 
*5 @ Right justified with leader 

- ae 
Figure 10-4 Make index dialog 

You may specify how the index will be formatted using this dialog. 
If you use more than one column, text will flow from the bottom of 
one column to the top of the next. If you do not have enough entries 
to fill a column, the index will remain in a single column at the left of 
the page. The column width, however, will remain the same size, 
even if there are no entries in the second column. 

You can have a blank line follow each section. A section is a group of 
entries beginning with the same letter of the alphabet. If there are no 
entries which begin with a certain letter of the alphabet, a section 
will not be created for that letter. If you wish to display section 
headings, check the box labeled Label Sections. You can also choose 
to have the section headings appear bold, italic or both. 

‘You can place a comma after each entry before the page numbers. 
You can list the page numbers in parentheses, right justified, or right 
justified preceded by a dotted leader. If all you want is a list of the 
indexed words, you can suppress the page numbers. 
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Advanced Features 

Nisus offers many advanced features that enable you to: 
* index a selection using a key word 

index using “see also” 
index overlapping entries 
index all appearances of a term at once 
index multiple associated words with one word at once 
index ail text of a given font, size and/or style 
create multiple tables of contents and/or indexes of the same 
document. 

Using Mark Index 

Use this method to index text which will appear in the Index exactly 
as it appears in the text. The entire selection will be placed in the 
Index when you build it. 

* Select the text to be indexed. 

e ChooseMark Index from the Format menu. 

Using Index As 

The simple method of marking words for an Index would index the 
words fish and fishing individually. Both words will appear as separate 
entries in the Index. 

fish 2,7, 149 
fishing 5, 6 

Using Index As... allows you to index the selection as any key 
word or phrase you specify. (You can, depending on the emphasis of 
your document, index “fish” as “fishing” or “fishing” as “fish” so 
that the example above would have only one entry with pages 2,5, 6, 
7, 149 following it.) This can be used to change the uppercase words 
in the document so they appear as lowercase in the index. Using this 
feature, you can also select a paragraph of text and index it as a 
single word. 
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This method also permits referencing other index entries. Readers 
are referred to other entries with See also,. 

Index as [aires 

(_) Botd LC] Italic 

secarof 

Figure 10-5 The Index As dialog 

When you choose Index As..., the currently selected text appears 
in the Index as box. You can then, as in Figure 10-5, type the text 
you want to appear in the Index into this box. Note that if the selection 
being indexed spans a few pages, the page range will be listed in the 
Index. 

You can also refer the reader to another entry by typing its name in 
the See also box. Make sure that the referenced entry is also indexed. 

Indexing Overlapping Entries 

ie” To index overlapping entries, you must use two different methods— 
Mark Index and index As.... For example, if you wish to index 
dogs, cats, birds, and iguanas as Pets in the following sentence: “The 
pet store sells dogs, cats, birds, and iguanas.” 

The pet store sells Hoge, cats, birds, and 1quiariasy 

You would select dogs, cats, birds, and iguanas as shown above and 
choose Index As... from the Format menu. Type Pets in the Index 
As box and click [0K J). To add iguanas to the index, select iguanas 
and choose Mark Index. By doing this, you have added two 
overlapping entries to the index: Pets and iguanas. 
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The pet store selis dogs, cats, birds, and IBTBTBE. 

You can index one word or phrase as several different key words. 
Add the key words to the text, index them either using Mark Index 
or Index As... or both and then make them invisible. (Choose 
Invisible style from the More Styles submenu of the Style menu.) 

Using Find/Replace to Mark and Unmark Index 
Text 

You can use the Find/Replace dialog to search through your document 
and index the text automatically. 

Indexing Literal Text 

To index text using the Find/Replace dialog: 

¢ Choose Find/Repliace from the Tools menu. 
¢ Choose Index from the Replace pop-up menu at the left of 

the dialog. 

¢ Click in the Find box and type the text to be indexed. 
¢ Click in the Index box and type the text to be displayed in 

the index. 

+ Click Cindew-ai_} 
Every occurrence of the Find text will be indexed automatically. If 
you want to check each word found, you can step through the words 
with the (Find } button, clicking only when you find 

something that you want indexed. 

ts The indexing done this way is equivalent to an Index As.... Of 
course, if you index a word as the same word, it is equivalent to a 
simple Mark Index. Internally, however, Index fs... and Mark 
tndex are different. This internal difference is important only when 
you want to create overlapping index entries or when you edit the 
entries. If you change the Mark Index text in the document, what 
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appears in the index will change also (but only if any text you add is 
not at the end of the indexed text). If you change the Index As... 
text in the document, the text in the index will not be changed. 

If you want to remove text which was entered through Index Rs..., 
you can type the text into the Find box and leave the Index box 
blank. Note that this removes only Index As... entries. It does not 
affect Mark Index entries. Other index entries can be removed by 
selecting them and then choosing Unmark Index. 

To remove any particular text from Index Qs... style (regardless of 
what it was indexed as), type the text in the Find box, select it and 
choose Index As... but leave the Index As text box empty. 

Indexing With PowerSearch 

Another advantage of using the Find/Replace dialog to index text is 
that you can use PowerSearch (or, if you wish, regular expressions 
and PowerSearch+) to find the text you want to index. PowerSearch 
is explained in Chapter 12. PowerSearch+ is discussed at length in 
Chapter 13. 

For example, you may want the subject Horses to be indexed in your 
document. Horses may be discussed wherever the words horse, horses, 
mare or colt are used. Use the Find/Replace dialog to enter the following 
PowerSearch expression: 

horse(r)mare(a)coit 

which will find them all, as shown in Figure 10-6. Note that the 
is not typed but entered by choosing OR from the Special menu on 
the menu bar of the Find/Replace dialog. This menu is accessed 
when PowerSearch is chosen from the Find pop-up menu. 
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[ee Zee Find/Repiace (eras) = 
Wild Card enGclal fapeate Position Clipboard Match 

& on Case a Whole Word panini Wrap Around 

Figure 10-6 Indexing text for Horses 

All occurrences of horse, horses, mare and colt will be referenced by 
the entry Horses in the index. If horse appears on page 10, colt on 
pages 3 and 4, horses on pages 2 and 25, and mare on page 2 then the 
entry in the index will read: 

Horses 2, 3, 4, 10, 25 

This method also allows you to find every occurrence of a word, 
while being selective about which occurrences are placed in the index. 

Continue clicking until the entry is in a context you wish to 

index, then click Index before continuing. 

If you are indexing only whole words, you may find it easier to list 
every word you want to find in the PowerSearch expression. Then, if 
you check Whole Word in the dialog, you may click (_ Index an_} 
without indexing any variants of your words. 

Ie” Be sure to check Whole Word if you do not want the above example 
to index the words nightmare or colter. 

You are not limited to indexing words. Any PowerSearch expression 
may be entered, which could specify any text from single characters 
(such as m or @) to paragraphs. You can even index a font, size or 
style. 

To create an index entry which references all text of a given font, size 
and style, do the following: 
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peel 

2. 

2 

. Choose PowerSearch from the Find pop-up menu 

. Use the menu bar to enter: 

. Select the above expression 
. Set the attributes you want to index using the Font, Size 
and $tyle menus 
Make sure Index is chosen from the Replace pop-up menu 
Click 

ts" Duplicate page numbers are not listed and multiple references follow 
a single See also phrase. 

its In the Nisus Macros file supplied there is a macro called Sub Index 
which creates sub indexes for you. Load the Nisus Macros file and 
read the Nisus Macro Language: Programming Dialect pamphlet, for 
more details on how this macro may help you in creating second 
level indexes. 

Creating Multiple Tables of Contents and Indexes 

You can make multiple tables of contents and/or indexes of the same 
document without altering your text, as was done with this manual. 

1. 

om Go 
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Choose Define Style... from the $tyle menu to establish 
specific named styles to the sections you want to be in the 

various tables of contents. For example: Hi ead I Ng,” 
“Subheading,” “tiustration,” etc. 

. When you are ready to create your Table of Contents, decide 
which levels, or categories, of contents you want included, 
and turn on Table of Contents in the Define Style dialog 
for those particular styles. 

. Choose Make Contents... from the Format menu. 
. To make the second, etc. Table of Contents, return to the 
Define Style dialog, turn off Table of Contents for those 
User Styles you do not want in this table and turn on Table 
of Contents for those styles you do. 
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ie The above example can be applied to preparing different indexes 
simply by choosing [Index in the Define Style... dialog instead of 
Table of Contents. This is especially useful when working with 
foreign languages or unusual fonts. 

Identifying Indexed Text 

All text which has been Indexed, or Indexed As, is shown inside a 

dotted box when the Text Hilites command is checked. If you do 
not have the boxes showing, and you make a change in any of the 

indexed text, the Text Hilites is aulomantely: turned on. Note that 

the dotted boxes for M ark Index text “: ‘” differ from those 

for Index As... text“: At you do not want these hilites to 

print, either make sure you uncheck the Text Hilites command 
before printing your document, or, choose Printing... from the 
Preferences menu and uncheck Print with all “Display” 

options as shown on screen. 

The text A ice in the table of contents is also shown inside dotted 
Seer ET eee rEESeenEE 

boxes “ . To identify the three kinds of boxes, select any 
PASC ONESOSAA ODS e HHO EE 

part of the boxed t text then look at the Format menu. 

If the command Unmark Contents is enabled, the text selected is 

in the contents. If Unmark Index is enabled, the selected text is in 

the index. If neither of these commands is enabled, select it and 

choose Index As.... The Index As dialog will open to show you as 
what the text was indexed. Click to remove it from the 
index. 

Ie It is not possible to index items in the footnotes. 
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1] 
special Tools 

This chapter describes features that are provided as tools to help you 
in a variety of situations. The following features are described: 

¢ Line Numbering 
¢ Comparing Files 
¢ Synchronous Scrolling 
¢ Quote and Parenthesis Matching 
e The ASCII Table 

Line Numbering 

This is useful if you are preparing legal documents, or documentation 
in which you need to reference line numbers. You can have a document 
with each line numbered, either from the top of each page or from 
the beginning of the document. 

To display line numbers in the left margin, choose Line Numbers 
from the Display submenu of the Tools menu. Initially, line 
numbering will count from the beginning of the document and number 
every line. You may restart numbering with each page, set the 
numbering interval and change the attributes of the line numbers. 
Choose Line * Prefs... from the Display submenu of the Tools 
menu. Choose the Font, Size and Style of the line numbers you 
want while this dialog is active using the menus in the menu bar. 

Line numbers must fit within the height of the line that they number. 
They will be clipped if their height is larger. See Line Numbering 
Preferences, in Chapter 15, Customizing Nisus, page 323. 

If you print the document when line numbers are showing, they will 
be printed. 
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Ks" It is not possible to number lines in the footnotes (they will appear in 
the Footnotes for... window, but not in the master document). 

ts” A “Pleading Page” stationery document is shipped with Nisus. Simply 
open this document and you will be able to enter text on a standard 
pleading page. 

Comparing Files 

Nisus can compare two files automatically. Comparing files is useful 
when you have made changes and have forgotten what they were, or 
you want to check what changes someone else has made. 

¢ Open the two files to be checked, press Shift and click in the 
zoom box of one of the windows. This will place the two 
windows side-by-side ready for comparison. 

e Place the insertion point of each file at the start of the text 
you wish to compare. 

« Choose Compare from the Edit Tools submenu of the 
Tools menu. 

The insertion point will jump to the position of the first difference in 
both windows. If no difference is found, a dialog will appear to 
notify you. This method of comparison catches all differences in text, 
including white space differences. It will however not compare font, 
size or style attributes. To ignore repeated white spaces, press Option 
while choosing Compare. Nisus will still find a difference if one file 
had no space while the other file had one, repeated spaces and tabs 
however will be counted as one. 

When you are comparing files and you have them opened side-by-side 
it is convenient to have them scroll together. Choose Sync. Scrollin g 
from the Edit Tools submenu of the Tools menu as explained on 
page 200. 

(s You can scroll or select text ina window that is not the front window 
by holding down the Command key. This is useful when comparing 
text because one of the two windows is not active. 

324 CHAPTER ELEVEN 



Synchronous Scrolling 

This feature is provided to facilitate non-automated comparison of 
files. When you choose Sync. Scrolling from the Edit Tools 
submenu of the Tools menu, the two windows last accessed will be 

~ synchronized. As you scroll one of them, the other will automatically 
scroll by the same amount. 

Nisus displays the B28 icon on the right side of the information bar 
when windows are synchronized. Choose Syne. Scrolling once 
more or close one of the windows to cancel synchronization. 

Ke” You can arrange the front two windows side-by-side by pressing 
Shift and zooming one of the zoom boxes. 

te” If you hold down the Shift key when scrolling the front window, it 
automatically synchronizes with the window behind it. 

ie” For more information on working with multiple windows see page 
195, 

Matching Quotes and Parentheses 
If you want to make sure that you have not forgotten to close a quote 
or a parenthesis, Nisus has a special feature that allows you to check 
for unmatched quotes and parentheses. This feature can also be used 
by programmers to find unmatched comments, begins, ends and so 
on. The definition of parentheses and quotes can be easily modified 
by choosing Parentheses... from the Preferences submenu of 
the File menu. See page 450 for details on how to set the parentheses 
preferences. 

Nisus keeps track of your parentheses and displays them on the right 
side of the information bar. You can use this feature either interacti vely 
or after you have finished typing. If the Check parenthesis option 
is checked then opening parentheses are added to the information 
bar as you type them, and are removed when you type closing 
parentheses. You can set this option by choosing Parentheses... 
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from the Preferences submenu and when the Parentheses 
Preferences dialog Figure 15-9, (page 450) is displayed check the 
Check parenthesis box. 

Two kinds of parentheses are recognized. The first kind acts just like 
standard parentheses and can be nested. The second kind quotes text 
and prevents parentheses checking from being done inside these 
quotes. Examples are: 

¢ The ‘(is a left parenthesis 
¢ The apostrophe (“'”) can be both an open quote and close 

quote symbol 
* The opening double quote “ and the closing double quote ” 
* The opening single quote ‘ and the closing single quote’ 

In the first example, the first quote begins a quoted expression. The 
left parenthesis that follows is ignored by the parentheses checker, 
because it is inside a quoted expression. Finally, a closing quote is 
encountered, which balances the opening quote. 

In the second example a left parenthesis is encountered. The double 
quote that follows begins a quoted expression, and all text up until 
the closing double quotes is ignored by the parenthesis checker. When 
the right parentheses is encountered, closing the left parenthesis, the 
expression is balanced. 

Nisus recognizes several variations of both types of parentheses. You 
may add your own or change the predefined variations. See page 450 
for directions. 

The following examples illustrate the use of nested parentheses in 
algebra. 

3 [4x - 2y(6 - 2xi)] + 7xy 

Nisus assumes that when you have overlapping parentheses you 
have made an error. For example: 

(1) 
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is an error. You must close one kind of parenthesis before you open 
another. It also assumes that you will enter matching and closing 
parentheses in order. For example, if you enter text like the following: 

((])) 

Nisus will display ((] ) ) in the information bar indicating that it 
cannot match the opening and closing parentheses because there was 
an intervening bracket. 

ia Sometimes, when you have pasted or cut some text with parentheses, 
or when you have just turned on parenthesis checking, you will need 

to refresh the information bar display. Choose Recount Parens 
from the Edit Tools submenu of the Tools menu. 

An additional feature of parenthesis matching allows you to find the 
closest set of matching parentheses on either side of the insertion 
point. Place the insertion point just inside a parenthesis you want to 
match and choose Balance {) from the Edit Tools submenu of the 
Tools menu. The balanced set of parentheses and the text in between 
will be selected if a match is found, as illustrated in Figure 11-1; 
otherwise a beep will sound. 

ea ane oorcsm! 1S Veory 

ASCIll Codes 

If you want to enter special symbols into your text or if you are 
moving files to or from other computers, or want to remove non- 
printing characters from your text, this section is for you. 

SPECIAL TOOLS 327 



Computers can only recognize and process numbers. In order to deal 
with character symbols, each such character is coded as a whole 
number. The standard code adopted by almost all computer 
manufacturers is called the ASCII code. 

ASCII is an acronym for the American Standard Code for Information 
Interchange. The extended ASCII includes number codes from 0 
through 255. 

The standard characters have ASCII codes beginning with 32 (space) 
and ending with 126 (tilde). Some codes are used for the Tab and the 
Return character. In order of increasing codes they are: 

° The Tab (ASCII 9), the explicit page break (ASCII 12), the 
Return (ASCII 13) and the space (ASCII 32) 
The symbols: !"#$%&'()*+ ,-./ 
Numeric characters: 0 through 9 
The symbols: :;<=>?@ 
All the uppercase alphabetic characters: A through Z 
The symbols: {[\]*_ 
The lowercase alphabetic characters a through z 
The symbols: {!}~ eo e« @ @ @ @ @ 

The last symbol (tilde) has the ASCII code 126. Other character codes 
represent different special symbols that depend upon the font being 
used. 

>” For an explanation of how different ASCH values affect the sorting of 
paragraphs in your document, see page 121. 

In the fonts shipped with the standard Macintosh system a few of 
the remaining codes display as special characters. For example the 
Apple symbol (@) is available in Chicago as ASCII 20 (also 249) and 
the cloverleaf (propeller) symbol as (3) ASCII 17. The diamond symbol 
(#) is available as ASCII 19. These three characters are useful in 
writing macros. While they appear as above in Chicago font, in the 
Macros window they appear as \§ (Option), 98 (Command) and 
4} (Shift) respectively. The other undefined characters are either 
invisible on the screen or appear as the default character, usually a 
small open rectangle 1). 
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Nisus will read and display ASCII files, that is, pure text files. If you 
have moved text files from other computers, they are most likely to 
be ASCII files. You can conveniently use Nisus to clean up these 
from any unnecessary visible or invisible characters. Choose Zap 
Gremiins from the Edit menu. 

“IG See Gremlins page 123 for a definition of Gremlins. You can also 
customize such tasks by writing your own macros. 

The ASCIl Table 

The ASCII table, illustrated in Figure 11-2, is useful if you want to 

insert some special symbols (for example @ @ % [1] « f ¥) into your 
document, or if you want to find out the code for a character. 

You can display all the available characters of a font, along with their 
decimal and hexadecimal representations, using the ASCII table. 
Choose ASCIT Table from the Edit Tools submenu of the Tools 
menu. 

The first column in the table shows the ASCII code as a hexadecimal 
number. The second column shows the same number as a decimal 
number. The third column shows the character represented by that 
code. Scroll through the table to see the rest of the codes and characters. 
You can change the font of the display in the usual way by selecting 
it from the Font menu. Use this table in several ways: 

* Asa reference. 
e To enter any ASCII code into your document. 
* To determine what code is generated when a given key is 

pressed. 
¢ To enter special codes into your document or into the Find 

dialog. 
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Figure 11-2 The ASCIl table 

There are two ways you can enter a code from the ASCH table into 
your document or the Find /Replace dialog: 

¢ Select a code, copy it, then paste it in your window, or 
* Doubie-click a code. This will enter it into your window at 

the insertion point. 

To find out which code is generated when a key is pressed, make the 
ASCII table the active window and press the key. This will highlight 
the ASCII code. Note that Command, Control, Shift and Option are 
modifier keys and do not generate any ASCII codes. 
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12 
Pattern Matching Using 

PowerSearch 

These are some of the things that you can do with pattern matching: 

e Find text in a particular font, size, or style and then replace 
it with the same text but with a different font, size, or style. 

¢ Change the first character of the first word of every paragraph 
to a specific font, size or style. 

e Replace every underlined word with the contents of a 
designated clipboard. 

e¢ Check your document for correct punctuation. 
¢ Find all capitalized words which do not begin a sentence. 

Nisus offers two ways of describing patterns: PowerSearch and 
PowerSearch+. Although PowerSearch+ is more compact and 
powerful, PowerSearch uses short common language statements to 
describe patterns and is easier to use. You will discover that pattern 
matching using PowerSearch gives you a lot of the power of 
PowerSearch+ without requiring nearly as much learning. 

Introduction to Pattern Matching 

Nisus can search for text that is described by specific patterns; this is 
called “pattern matching.” To describe a pattern, a shorthand language 
of predefined symbols called metacharacters is used. Metacharacters 
are combined to form a pattern called a “regular expression.” The 
ability to translate these regular expressions is called GREP which is 
an acronym for Global Regular Expression Parser. In Nisus the menu 
commands PowerSearch+ and PowerSearch are used to refer to the 
shorthand language of GREP. The Quick Reference Guide has a listing 
of all the metacharacters. 
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The following terminology is used throughout this chapter: 

* Metacharacters The special symbols in PowerSearch+, 
Or menu commands in PowerSearch, 
used to build a regular expression. 

¢ Kegular Expression Any pattern which is built using a 
combination of metacharacters and 
literal text. 

¢ Find Pattern The regular expression entered in the 
Find box. 

* Found Text The text which is found and selected 
upon pattern matching. 

* Replacement Pattern 
The regular expression entered in the Replace box. 

¢ Literal Text Text in which each character is matched 
exactly as displayed, without any 
translation to other special meanings. 

© Wild Card A metacharacter that matches any 
character from a particular set of 
possibilities. 

To become familiar with PowerSearch+ takes practice and some 
learning effort, so Nisus offers PowerSearch which is easy to use and 
understand. To construct a regular expression using PowerSearch, 
choose the short, common language statements, describing each 
metacharacter, from the pop-down menus provided in the 
Find/Replace dialog. 

Getting Started with PowerSearch 
1. Choose Find/Replace... from the Tools menu. 
2. Choose PowerSearch from the Find pop-up menu. A larger 

Find/Replace dialog is displayed as in Figure 12-1. This 
dialog displays a menu bar of common language descriptions 
which you can choose to describe a Find Pattern. 

3. Construct the Find Pattern. Click the search options you 
want and press Return to start the search. 
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z= B Find/Replace 

Wild Card Special Repeat * Position Clipboard Match 

mae: Cn: 

au Te 

{J ignore Case C) Whole Word bd Wrep Around 

Replace then Fine Reptece Ail 

Figure 12-1 Zoomed Find/Replace dialog 

You can switch between the two versions of the Find/Replace dialog 
by clicking its zoom box. The larger version is used with PowerSearch. 

PowerSearch Examples 

Changing the size of a font 

Type some text in 14 point Times and some in other fonts and 

sizes. To search for all text written in 14 point Times and replace 
it with the same text in 12 point Times, place the insertion point at 
the beginning of your text and follow these steps: 

1. Choose Find/Replace from the Tools menu. Choose 

PowerSearch from the Find pop-up menu. Click in the 
Find box. Choose Any character or 4% from the Wild 
Card menu. 

2. Choose 1+ from the Repeat # menu. 
The following Find Pattern is displayed in the Find box: 

Any character or q 

3. Select the text in the Find box and choose Times from the 

Font menu and choose 1 4 from the $ize menu. 
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4. Click in the Replace box. Choose Found from the Match 
menu. This is what will appear in the Replace box: 

Found 

». Select the replacement pattern in the Replace box. Choose 
Times from the Font menu and then choose 12 from the 
$iZe menu. 

6. Click (Repiace all), 

If any replacements were made, a dialog will be displayed showing 
the number of non contiguous text segments in 14 point Times that 
have been replaced with the same text in 12 point Times. 

Searching for words at the beginning of a paragraph 

To search for the word “Nisus” at the beginning of a paragraph and 
ignore all other occurrences: 

1. Choose 91 Start from the Position menu and type Nisus 
in the Find box. The following find pattern is displayed: 

@ start)Nisus 

2. Make sure that Wrap fround is checked. 

Removing extra blank lines 

To search for two or more contiguous return characters and replace 
them with a single one, do this: 

1. Place the insertion point in the Find box. Choose 9 from the 
Special menu. Choose 4 again. Choose 1+ from the Repeat 
# menu. The following is displayed in the Find box: 
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2. Click in the Replace box. Choose 9 from the S$pecia] menu. 

Click (Repiece ai) 

Finding a word from two (or more) alternatives 

1. Type some text in your document including the words John 
and Marie. 

2. Choose Find/Replace from the Tools menu. Place the 

insertion point in the Find box and type John. Choose OR 
from the $pecial menu and type Marie. This is what the 
find pattern should look like: 

John(r)Marie 

The search will stop at the first occurrence of either “John” or “Marie”. 

These are some examples of what you can do with PowerSearch. The 
PowerSearch commands are presented below, grouped by menu 
categories. Their equivalent metacharacters or symbols are also listed. 
These symbols will be understood after reading Chapter 13. Note, 
however, that the symbols can only be used in PowerSearch+ (not 
PowerSearch). 

PowerSearch Commands 

The menu bar at the top of the Find/Replace dialog in Figure 12-1 
contains the following menus: Wild Card, Special, Repeat *#, 
Position, Clipboard, and Match. These menus contain the most 
common metacharacters used in building regular expressions. These 
metacharacters are a subset of the metacharacters available in 
PowerSearch+, see Chapter 13. 

When you choose a menu item, Nisus inserts a short descriptive 
language statement. You can select, delete, cut, copy, and paste 
these statements. Although it is possible to paste them into your 
document this is not usual. They are principally for use in the 
Find/Replace dialog and in Macro Files. The following sections 
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describe each PowerSearch menu command and what it matches. 
The equivalent symbol used in PowerSearch+ is included in 
parentheses. 

PowerSearch Rules 

The menu commands in PowerSearch are organized into several 
categories. Each is placed on a separate pop-down menu in the 
Find /Replace dialog. The “Wild Cards” category includes all character 
descriptions which will match more than one character. The other 
menu names are self explanatory. 

It is important to recognize that the Position category represents 
positions and not characters. When a position category is found, therefore, 
nothing is highlighted. This should be contrasted with the case where 
one or more characters are found and are highlighted. For example, if 
you search for the beginning of a paragraph (@ Start)) the insertion 
point will jump to the next paragraph beginning, but will not highlight 
any text. If on the other hand you search for a word beginning with 
the letter “a”, the expression: 

Word Startja 

will cause the insertion point to jump to the beginning of the next 
word beginning with the letter “a” and will highlight that letter “a”. 
Another example will illustrate the meaning of the “Character On 
Left” and “Character On Right” commands. Suppose you enter the 
expression: 

Character On Left:}3 

into the Find box and click the Find button: the insertion point will 
jump to the right of the first digit without any text being highlighted. 
If on the other hand you were to enter the expression: 
Character On Left:B4, the insertion point would jump to the first 

possible position between the digits “3” and “4” and then highlight 
the digit “4”. Suppose you wanted to make the insertion point jump 
between the two digits 34 without selecting anything. 
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The following expression would do the trick: 

Character On Left:J3{Character On Riant:J4 

Notice that the commands Character On Right and Character 

On Left cannot be followed by any wild card, but must either stand 
on their own or be followed by a specific character. This means that, 
for example, the expressions: 

Character On Right: 

will not work., whereas the expressions: 

(Character On Right)(Tad)(@) 
Character On Right: 

will work. 

The Wild Card Menu 

This menu illustrated Figure 12-2 offers several metacharacters which 
are used as wild cards. A wild card is a symbol which matches several 
characters defined in a given set. A set is a range or a collection of 
characters. For example: 

* all single digits 0-9 
¢ all lowercase alphabetic characters @-2Z 

UWhld Card 

Any character 

Any character or 9 

A-2 9-2 

A-2 a-z 0-9 

0-9 

8-2 

A-Z 

Space or Tab 

Figure 12-2 The Wild Card Menu 
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Any character (.) 
This matches any character except return. The expression: 

apologize(ny character 

matches the word apologize followed by any character except a 
return (7). A search (with Whole Word unchecked) for this 
expression would find apologizes, apologize. (a period at the 
end) and apologize (with a space at the end). 

Any character or § (any character or 4) (:? or :.) 
This matches any character including a return. 

AZ az (za) 
This matches any alphabetic character. That is any letter from A 
through Z, a through z, and all the option characters which display 
as modified alphabetics (with diacritical marks) and are European 
language alphabetics. (In PowerSearch+ the metacharacter :A includes 
the underline as well as all these.). 

A-Z a-z0-9 (:n) 
This matches any alphanumerics, that is any letter from A through Z, 
a through z, and all the option characters which display as modified 
alphabetics (with diacritical marks) and are European language 
alphabetics. 

0-9 (0-9) (:) 
This matches any digit 0 through 9. So the Find Pattern: 

would match a two digit number such as 93. 

a-z (a-z) (: 1) 
This matches any lowercase letter a through z including all the 
modified lowercase characters. 
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For example a search for the regular expression: 

(a-z)ind 

will stop at find and mind but ignore Bind. 

A-Z (42) (:u) 
This matches any uppercase letter A through Z. 

Space or Tab (:b) 
This matches either a space or a tab character. Use it to search for 
unwanted blank characters. 

The Special Menu 

This menu illustrated in Figure 12-3 contains the OR metacharacter 

which is used to designate alternatives in your search. It also contains 

the commonly used white space metacharacters: 9 (the return character), 
$pace, Tab, and explicit Page Break. 

Special 

Page Break 

Figure 12-3 The Special Menu 

OR (1) 
If you have an Of statement between two expressions involving text 
or graphics, then there is a match if either of the two expressions 
occurs in the text. You can search for one or more words by separating 
them with the OR statement. For example, the expression: 

alpha(r)beta 

matches the word alpha or beta and no others. 
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The find pattern: 

Thomas(n)EllisOr)John(or)Mary 

matches any one of the names: Thomas, Ellis, John, or Mary. Note 
the OR statement refers to everything to its left (back to the previous 
OR) and everything to its right (up to the next OR). 

7@ (\z) 
This matches a return character, shown as “I” when you choose 
Space Tab & 4 from the Display submenu of the Tools menu. 
For example, the regular expression: 

matches any two consecutive blank lines. 

Space (\s) 
This metacharacter matches a space character: “"” when you choose 
Space Tab & 9 from the Display submenu of the Tools menu. 
The expression: 

-Gpace) Gpace)G=Z 
matches a period followed by two spaces and any uppercase character. 
To enter a space character in PowerSearch choose $pace from the 
Special menu or press the Space bar. It is recommended that you 
choose $pace from the menu as spaces made by pressing the Space 
bar are invisible unless you choose Space Tab & @ from the Display 
submenu of the Tools menu. 

Tab (\t) 
This metacharacter matches a tab character which appears on your 
screen as a right arrow: “**” when you choose Space Tab & 4 
from the Display submenu of the Tools menu. To enter a tab character 
in PowerSearch, hold down the Shift key and press Tab or choose 
Tab from the Special menu. The latter method is recommended because 
you can then easily see the entry. 
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Page Break (\f) 
When you insert an explicit page break in a Nisus document, which 

appears on your screen as an open down arrow: “t+” when you 

choose Space Tab & 4 from the Display submenu of the Tools 
menu, the text immediately following the insertion point advances to 
the top of the next page. 

There are two types of page breaks in Nisus: A soft page break, 
which is inserted automatically when text cannot fit on a page; and 
an explicit page break which is inserted by choosing Insert Page 
Break from the Format menu. You can only search for these explicit 
page breaks with PowerSearch. 

Sometimes you will want to remove all explicit page breaks from 
your document. This will happen when you have made editing changes 
after inserting explicit page breaks. To remove page breaks: 

1. Choose Find/Replace from the Tools menu. 

2. Choose PowerSearch from the Find pop-up menu. 
3. Choose Page Break from the $pecial Menu. This is what 

will appear in the Find box: 

4. Leave the Replace box blank. 
5. Click (Replace atl). All explicit page breaks will be removed. 

The Occurrences Menu 

This menu illustrated in Figure 12-4 contains the following three 
items: 0+, 1+, and O or 1. There is a match only if the previous 
character or wild card occurs the indicated number of times (including 
zero). Note that when the search is forward through the file, the 
match is always the longest possible. If the search is in the reverse 
direction, the match is the shortest possible. It can be used following 
any character or wild card. 
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Repeat + 

Figure 12-4 The Repeat # Menu 

0+ @) (*) 
Expression 
This statement allows the previous character (or parenthesized 
expression) to be repeated zero or any number of times. The regular 
expression: 

will match any sequence of alphabetics. Whereas the expression: 

ABQ) 
matches text consisting of an A followed by any number of B's 
(including none at all). Therefore it matches A, AB, ABB etc. Note 
that Q+ refers to the character (or parenthesized expression) 
immediately to its left. It can be used to designate a repeating wild 
card or a repeating specific character. For example, the expression: 

(AaB )@ 
will match any sequence of AB, such as ABAB. Note that because it 
will also match zero occurrences of the parenthesized pattern, the 
insertion point will jump to the next position whatever the text pattern 
is, except that, in the case when the next character sequence matches 
our pattern, it will be selected. 

1+ (+) (+) 
Expression 
This statement allows the previous character, wild card or 
parenthesized expression to be repeated one or any number of times. 
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For example, the regular expression: 

ABU + 

matches AB, ABB and ABBB but does not match A while the regular 
expression: 

(ab )@ 
matches AB, ABAB or ABABAB. 

O or (-) 
Expression(o or 1) 

This statement allows the previous character, wild card or 

parenthesized expression to be repeated zero or one time. Thus the 
expression: 

ABGaD 
matches A in AC and AB in ABB. 

i” In the above examples the Whole Word option must be unchecked. 

The Position Menu 

This menu, illustrated in Figure 12-5, contains commands which do 
not cause any selection of text. They are usually used to specify the 
beginning or end of a text pattern match. If they are used on their 
own (without any text pattern), the Find command will cause the 

insertion point to jump to the next matching position without selecting 
anything. 
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Position 

Character On Left: 

Character On Right: 

Word Start 

Line Start 

9 Start 

Document Start 

Word End 

2 End 

Document End 

Figure 12-5 The Position Menu 

When one of these position designators is used in the Find Pattern 
the insertion point is moved to the matching position. If there is a 
Replacement Pattern and the Replace command is invoked, the 
replacement will take place at the new location of the insertion point. 
For example, if your Find Pattern is and the Replacement 
Pattern is “$”, the dollar sign will be inserted at the beginning of the 
next word. As another example, if you want to insert “=” at the 

beginning of each paragraph, your Find Pattern would be 
and the Replacement Pattern would be “=” (without the quotes). 

The Position menu commands are only available in the Find box. 
They are disabled in the Replace box. In the listing below, the special 
symbol 4 can be replaced by any specific character but not a wild 
card. 

Character On Left: (Character On Letta (:<) 
When Nisus finds a match to the character specified, it moves the 
insertion point to the right of that character. A search for: 

Character On Left: VINg 

will select “ing” in “moving,” “leaving” and “grooving,” but ignore 
it in “dancing”. In this example, the Whole Word option must be 
unchecked otherwise no match will be found. 

Character On Right: Character on Right)a (:>) 
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When Nisus finds a match to the character specified, it moves the 

insertion point to the left of that character. For example, a search for: 

problem({Ccharacter On Rianht:)s 

will select problem in problems but ignore it in problem and 
problematic. In this example Whole Word must be unchecked 
otherwise no match will be found. 

Word Start (\<) 
This moves the insertion point to the beginning of the next word. 
This means that the character to the left of the insertion point is not 
an alphanumeric or an underline, and that the character to the right 
is an alphanumeric or an underline. Use this metacharacter to search 
for prefixes. For example, a search for: 

Word StartUUpre 

would find pre in prefer and predict but would not stop at pre 
In interpret. 

is There are characters other than alphanumerics that define a word. 
For example, $.70 is a word. A full definition of a word is given at 
the end of Chapter 13, Definitions, page 345. 

Line Start (:*) 
This moves the insertion point to the beginning of the next line. For 
example, a search for: 

Line Start)this 

would only find this at the beginning of any line. 

q Start (4 Start) (+) 
This moves the insertion point to the beginning of the next paragraph. 
This means the character to the left of the insertion point is a return 
or the beginning of document. The find pattern: 
q Start finds the first character at the beginning of 

a paragraph. 
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Document Start (Document Start) (:s) 
This moves the insertion point to the beginning of the document. For 
example, a search for: 

Document Start)Cat 

would find Cat only if it is at the beginning of the document. 

Word End (\>) 
This moves the insertion point to the end of the next word. This 
means that the character to the right of the insertion point is not an 
alphanumeric or an underline, and that the character to the left is an 
alphanumeric or an underline. You can use this metacharacter to 
search for suffixes. For example, a search for: 

ful(Word End) 

would find ful in helpful and restful but would not stop at 
fulin full. 

q End ($) 
This moves the insertion point to the end of a paragraph. It means 
that the character to the right of the insertion point is either a return 
character or the end of document. For example, the find pattern: 

Space or Tab 

finds any trailing blank characters at the end of a paragraph. 

Document End (:e) 
This moves the insertion point to the end of the document. For example, 
a search for: 

dog(@ocument End 

would find dog only if it is at the end of the document. 
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The Clipboard Menu 

Current Clipboard Contents (\Ccc) 

Clipboard #0 through Clipboard #9 (\c0...\C9). 

Fach metacharacter in the Clipboard menu illustrated in Figure 12-6 

refers to the text which was last copied to the corresponding clipboard. 
These can only be used in constructing the replacement pattern, and 
cannot be used in the find pattern where they are disabled. (Note 
however that in macro commands, they can be used in both the Find 
and Replacement patterns when they are placed in single quoted 
PowerSearch+ expressions.) 

Clipboard 

Figure 12-6 The Clipboard Menu 

The Match Menu 

This menu, illustrated in Figure 12-7 contains the phrases which deal 
with expressions. Quite often you want to “tag” or mark a part of the 
Find Pattern in order to use it as part of the remaining Find Pattern 
or part of the Replacement Pattern. The following metacharacters are 
used for this purpose. 
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( 
) 

(.. 
(.. 
(. 
és 
(.. 
Coss 
fc 
(. 
( 

Figure 12-7 The Match Menu 

Found (Found) (&) 
This stands for the currently found or selected text. Found can only 
be used in the replacement pattern where it means the entire text 
that was last found. 

The ...Found metacharacter can be used to add text to a found 
expression. 

Example: The following Find Pattern and Replace Pattern will add 
bullets to the beginning of each paragraph: 

Find Pattern: q Start (1+) 
Replacement Pattern: «(Found) 

You can also use this metacharacter to change the attributes (font, 
size and styles) of text without altering the text itself. You can also 
use it to count the number of occurrences of certain words or phrases. 

Example: Type any text in the Find box and enter in the 
Replace box and then click (Replace All), Nisus will replace every 
occurrence of the found text with itself in effect making no change at 
all. It will then display in a dialog box how many replacements were 
made. For example, a of Paragon with will count 
how many times the word Paragon appeared in the current document, 
or all open documents, without making any changes to the documents. 
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...Found 1 through ...Found 9 
If you choose ...Found n (where n is any digit from one to nine) 
from the Match menu. Nisus inserts the statement: 

(...Found 1) 

in your pattern. In any expression in which appears, it 
“(Found _1)) “) can be replaced with whatever the first parenthesized 
expression matches. 

Example: To convert all the dates of the form mm/dd/yy to 
international dates of the form dd/mm/yy search for: 

(Me) (We) (@e) 
and replace it with: 

(..Found 2))/U... Found 13/00. Found 3) 

This search will replace the date 09/28/88 with 28/09/88 

Nesting Parenthesized expressions. 
When a parenthesized expression occurs inside a parenthesized 
expression, the numbering count starts from left to right, from the 
outside in. 

Example: In the expression (in which we use A,B,C,D,E,F to represent 
any characters, metacharacters, or expressions): 

(a(e(co) )(zr )) 
-.Found 1 would be whatever matched A, ...Found 2 would be 
whatever matched B ...Found 3 would be whatever matched cp 
and ...Found 4 would be whatever matched EF. 
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Using Parentheses to designate repeated patterns 
When a parenthesized expression is followed by one of the repeat 
metacharacters, the resulting regular expression matches a text pattern 
in which the repeated expression can be any instance of a match for 
the first expression. This means that the found text need not be the 
same for each instance of the repeat. 

Example: The expression (GIES) © will match any 
sequence of an alphabetic followed by a digit, as for example in 
A2D2 or C3P4. When the parenthesized expression is later followed 
by one of the ...Found 1... ...Found 9 metacharacters the found 
expression must match exactly the repeated text. For example: 

(Ga ) Gara 
would match the pattern A2B3A2B3, but would not match A2B3C4D4. 
Using such parenthesized expressions you can perform many useful 
searching and replacement operations. 

Example: If you want to find two neighboring paragraphs beginning 
with the same first alphabetic character, your Find Pattern would be: 

These must match the same character 

am ( >) =m OOGMEEE=DOC 
This would highlight both paragraphs. 

Example: The Find Pattern: 

Gm ( Ga) Gaza) (G=ao) 
together with the Replacement Pattern: 

C.Found SU... Found 2)){C..Found 1) 

will swap the first two words ina paragraph. 
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ks It is important to remember that you must not use any of the ... Found 
expressions before you have “tagged” or bracketed the appropriate 
number of prior expressions. 

Replacement Patterns 

The most common use of metacharacters and regular expressions is 
in constructing find patterns; some are also useful in constructing 
replacement patterns. If a metacharacter or a regular expression has 
a unique match then it can be used in constructing replacement 

patterns. For example, the metacharacter (&) matches the 
last text selected. Because it has a unique meaning it can be used in 

constructing replacement patterns. The metacharacter (a) in 
PowerSearch which matches a return character, can also be used. 

The metacharacter which matches any digit from 0 through 9, 
cannot be used because it does not have a unique meaning. If a 
metacharacter is not allowed in a particular context, Nisus will usually 
not let you select it in PowerSearch. No such friendly restriction 
applies when using PowerSearch+ where you are left to your own 
devices and can easily create patterns which do not do what you 
expect. 

[P Even in PowerSearch it is easy to create patterns which will not 
match anything. When this happens you are advised to rebuild your 
pattern from the beginning, adding only one metacharacter at a time, 
and checking what is being found or replaced after each such 
increment. 
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(i 
Pattern Matching Using 

PowerSearch-+ 

Introduction to PowerSearch+ 

Powersearch+ is a powerful pattern matching facility, it is also 
somewhat complex. It is suggested that you leam PowerSearch first 
in order to become familiar with the concept of pattern matching. 
Try to gain a good understanding of all the metacharacters before 
exploiting the full power of PowerSearch+, which includes all the 

metacharacters of PowerSearch as well as a few of its own. 
PowerSearch+ gives you more flexibility, including the ability (not 
present in PowerSearch) to define your own metacharacters or wild 
cards. When learning the shorthand symbols for the metacharacters 
used in PowerSearch+, you can use the PowerSearch menus which 

will enter them for you. You can also change a PowerSearch expression 
into the shorter PowerSearch+ expression simply by changing modes 
from PowerSearch to PowerSearch+. Note however that the opposite 
is not possible: You cannot convert a PowerSearch+ expression into a 
PowersSearch expression. 

If pattern matching is new to you, experiment with PowerSearch 
before proceeding to PowerSearch+. Before using PowerSearch+ on a 
real document be sure to back up all your work in case any experiments 
you attempt fail! Remember though that any command that changes 
text can be undone. You will find learning PowerSearch+ to be a 
very rewarding experience especially when using it in macros. 
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You should be familiar with the following terms which were defined 
in Chapter 12, Pattern Matching with PowerSearch: 

Metacharacter 
Regular Expression 
Find Pattern 
Found Text 
Replacement Pattern 
Literal Text 
Wild Card 

Getting Started with PowerSearch+ 

1, Choose Find/Replace from the Tools menu. 
2. Choose PowerSearch+ from the upper left pop-up menu 

of the Find/Replace dialog, which at start-up reads Norma! 
Search. You can expand the dialog by clicking its zoom 
box. This will give you access to the various PowerSearch 
menus. 

3. Using the menu bar of the Find/Replace dialog, or by typing 
the necessary metacharacters, construct the pattern you wish 
to describe. Click the search options wanted and press Return 

or click ( Find } to start the search. 

The menu bar at the top of the Find/Replace dialog illustrated in 
Figure 13-1 can be used in both PowerSearch+ and PowerSearch. If 
you choose a menu item Nisus inserts descriptive phrases in 
PowerSearch, whereas in PowerSearch+ shorthand symbols are 
inserted. Note that not all metacharacters are available in the menus. 
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1s SSS eat Find/Repjace OAD teat 

Wild Card Special! Repeot * Position Clipboard Match 

ee ee 

oi 

? &) ignore Case [] Whole Word & Wrap Around 

Replace then Fias Replace fil? 

Figure 13-1 Find/Replace dialog 

Most of the symbols used in PowerSearch+ are standard characters 
but in special combinations which are not frequently used in ordinary 

text. For example the combination :d stands for any digit and :a for 
any alphabetic. In PowerSearch+ the following characters have special 
meanings: 

the backslash \ 

the caret o 

the asterisk 7 

the plus + 

minus - 

the period 

the colon : 

the brackets [] 

option x a 

option 7 | 

shift\ | 

ampersand & 

The special meanings of many of these characters are context 
dependent and will be described in what follows. Whenever these 
are used literally in a PowerSearch+ expression, they have to be 
preceded with the backslash\. This includes the backslash itself. 
Therefore two backslashes have to be used in the rare circumstance 
when you are using PowerSearch+ and need to search for \. 
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The Modifier Characters 

In constructing regular expressions the backslash and the colon are 
used to change the meaning of the character that follows them. They 
act as modifier characters. 

\ The Backslash 

The backslash (\) is used to change the meaning of the character that 
follows it. If the following character is one of the characters with a 
special meaning, the backslash turns that special meaning off. If on 
the other hand the character has no special meaning, the backslash 
preceding it may switch its meaning to a special one. It is therefore 
called a “switch”. For example the :a has a special meaning in 
PowerSearch+, it means any alphabetic character. If you want to use 
“:a" literally in your find pattern, you have to precede it with a 
backslash: \:a. On the other hand the character “r” on its own has no 
special meaning in PowerSearch+, that is it stands for “r” literally. 
However the combination “\r’ represents the return character, 
whereas “\s” represents the space character. Of course a literal typed 
space also represents the space character but because it is not easily 
visible, we use \s. 

The parentheses () do not have special meanings on their own. To 
group parts of regular expressions logically, parentheses preceded 
by backslashes are used. Thus \ (AB\) matches AB, but also permits 
referring to AB as expression 1. 

A backslash (\) followed by any character other than the following 
characters: 

0-9 CbhEnrstvE<>({) 

forms a pattern which matches that character literally. Thus, \ [ matches [, \\ matches \, and \\r matches \r. 
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: The Colon 

In PowerSearch+ the colon acts as a modifier of the character that 
follows it. For example, the pattern :d matches any digit, but the 
expression \ :d translates to a colon followed by d. 

A colon (:) followed by any character other than the following 
characters (printed in Courier font): 

[ # + @ANabdehinosuwx~ * 
? i 

<> 
Ad T(Option Shift d) # = * (Space) | fe f 

forms a pattern that is matched literally. For example, :k is not a 
metacharacter, therefore it will be matched literally as a colon followed 
by the letter k. The full listing of all the metacharacters and examples 
of their use follow. 

Parenthesized Expressions \(...\) 

See also The Match Menu page 347 for the explanation and examples 
of the use of parenthesizing PowerSearch expressions. The same rules 
apply to PowerSearch+ expressions. 

Parentheses are normally treated literally in regular expressions, but, 
when preceded with a backslash, in the Find Pattern, they take on a 
special meaning. The search for the expression \(RE\) (where RE 
stands for any regular expression) continues as if the \ (and \) were 
not present. The expression matched by RE is remembered and you 
can refer to it in the replacement pattern or in the rest of the Find 
Pattern, by \1. The metacharacter \1 matches whatever the first 
parenthesized expression matches. Up to nine parenthesized sub- 
patterns of a regular expression can be referenced with the “Match” 
metacharacters \1, \2, through \9. To reference more than nine, 
you have to use the metacharacters \E10, \E11, through \E99. 

Another application of paretheses is for the purpose of representing 
a repeating group of characters. A parenthesized expression can be 
repeated by following it with a repeat metacharacter. For example, 
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the search for the pattern \ (AB\) + would find AB followed by any 
number of repeat expressions AB as for example in ABABAB. The 
Find Pattern \ (*.+\xr\) \1 for example, matches two consecutive 
identical paragraphs. 

ite Note that a parenthesized expression must appear in the search pattern 

to the left (before) any reference is made to any \1...\E99 expressions, 
for all searches forward and reverse. Parentheses may however be 

used without any subsequent use of these \1...\E99 expressions. 
Parenthesized expressions are not used in the replacement pattern. 

The OR Operation | 

The symbol used for the OR operation is the vertical bar }. As in 
PowerSearch, this operation allows you to specify alternatives in your 
pattern. The “or” is always applied to the whole expression on its Icft 
and the whole expression on its right up to the next such “or” 
expression if any. To have two alternative endings on the same text 
you need to use parentheses. 

For example, the pattern alpha }|beta matches alpha or beta and 
no others, and the pattern alph\ (a|abet\) matches either alpha 
or alphabet. Normally, if A and B are two expressions then A|B 
and B|A match A or B. In this case the order of A and B is unimportant. 

An exception to this rule occurs when A is a part of B as the word 
alpha isa part of the word alphabet. In this case the order becomes 
significant, especially when the Whole Word option is unchecked. 

For example when Whole Word is unchecked, a search for 
alph\ (a|abet\) will never find the whole word alphabet. It will 
stop at the word alphabet but only select alpha. The reason is that 
the “or” operator is evaluated from left to right and so Nisus first 
looks for the first expression, alpha, and if no match occurs, it will 
then try to match the next expression, alphabet. Because alpha is 
the first part of the word alphabet, Nisus will not select the whole 
word alphabet unless Whole Word is checked. Reverse the order 
and you get alph\ (abet |a\). This pattern matches both words, 
whether or not Whole Word is checked. 
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User Defined Wild Cards 

Wild cards are special symbols that match one of several characters. 
The period (. ) for example, matches any character except return. The 
return character defines a paragraph break. The PowerSearch+ 

~  metacharacter set includes several predefined wild cards. In Nisus, 
you can define your own wild card by specifying the set of characters 
it must belong to. 

There are two ways to define wild cards. One way is to list all the 
characters that the wild card matches in between square brackets 
[...]. For example, the pattern [abc] isa wild card that matches any 

of the three letters a, b, or cand nothing else. 

The second way is to list all the characters, that are not matched by 
the wild card, in between brackets and a caret [%*...]. Here the caret 
reads “not in the set.” For example, the pattern (*abc] is a wild card 
that matches any character that is not a,b, c, or return. Even though 
the return character is not mentioned, it is excluded because 
expressions in brackets [] cannot include the return character. 

I~ Note that if you want to include the return character in the set, you 
have to use a colon in front of the opening bracket. For example the 
regular expression :[abc\r] represents any one of the characters a,b,c. 
It does not include the return (\r) character vern though it is listed 
inside the brackets. The expressions :[abc\r] does include the return 
character. Another example: the expression [abc] represents sny 
character excepts a,b,c, or return; whereas the expression :{Aabc] 
represents any character (including a return) other than a,b,c. 

In what follows it is necessary to distinguish character sets which are 
allowed to contain the return character and those which are not. To 
facilitate this distinction, we will use the notation where > (sigma) 
represent a set of characters which may not include the return character 
and 2' (sigma prime) a set which may include the return character. 

The reguiar expression [£] matches any one of the characters in the 
set 2 and the regular expression :[Z'] matches any character in the 
set 1’. Notice the need for the colon to allow the set to contain the 
return character. 
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[] (any character from a set 5) 
The set 2 may be defined as a range, an enumerated set, or a 
combination of both. To define a range use a minus (-) between the 
start of the range and the end of the range. For example the wild 
card [a-f] represents any character in the alphabetic range from a 
through f. The range assumes the order of increasing ASCH codes. 
To check the order of characters choose ASCII Table from the Edit 
Tools submenu of the Tools menu. 

Any ASCII characters can be included as a part of the set except 
return. If return is included, it will be ignored unless the brackets are 
preceded by the colon modifier. (In any case the return must be 
entered using shift-return or you must use the metacharacter \r.) To 
enter nonprintable ASCII characters choose ASCII Table from the 
Edit Toois submenu, select the desired character, copy it, and then 
paste it in the set. For example, the pattern [0~9abc] matches any 
digit from 0 to 9 or any of the letters a, bor c. 

Each of the specified characters must be uniquely defined, thus no 
wild cards can be included in the set. Metacharacters that have a 
unique match such as \s, \r, \t, \v, \f, \b, \0 can be included. If 
\ precedes any other character, that character is taken literally. For 
example if any of the following characters: ] [~*\ are to be used in 
the set they would have to be preceded by the \ character in order to 
be taken literally. In particular if you want to include the \ character 
itself you must use two such characters in a row: \ \ 

All other characters inside the brackets [..] are taken literally. For 
example a search for {:a] matches a colon or an a, even though the 
pattern :a has a special meaning when it is outside of the brackets 
(meaning any alphabetic or underline character). The pattern [\0-\s] 
matches any control character whose ASCII code is in the range 0 to 
32 (the space character). Although return (ASCII 13) is included in 
the range it will be ignored, whereas in :[\0-\s} it will not be 
ignored. 

‘Alternatively leave the insertion point in the place where you want 
the character inserted, choose ASCII Table from the Edit Tools submenu of 
the Tools menu and double click on the character you want to enter. 
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A way to include the right bracket ] in the set is to make it the first 
character as in []a-z). Another way is to precede it with a backslash 
as in [a\}bc]. Likewise, one way to include a minus (-) in the set 
is to place it at the beginning or at the end of the set as in [-a-z] or 
[a~z-} respectively. Another way is to precede the minus with a 
backslash as in {a\-z], which means one of the three characters a, 

~~ =,0rz. 

[*] (any character not from a set 5) 
(“2 is a pattern that matches any character which is not in the set 
x. For example, (*a-z] matches any character which is not a 
lowercase alphabetic or a return and the pattern [*!-~} matches 
any character whose ASCII code is not in the range 33 to 126. 

:[X'] (any character from a set 5') 
:{2'] is a pattern which is similar to [2], except that the return 
character may be included in the set £'. For example, the pattern 
[a-q\r] matches any character between a and q but ignores \r, but 
the pattern : [a-q\r] matches any character from a to q including a 
return. In a similar way, :[A-Za-z\r] matches any alphabetic 
character or a return. 

:[*2'] (any character not from a set 5') 
: (*2'] is a pattern which is similar to [~D], except that the return 
character may be included in the set £'. While the pattern [*A-Za-z] 
matches any nonalphabetic character except a return, the pattern 
: [*A-Za-z\r] matches any nonalphabetic character including a 
return. 

PowerSearch+ Metacharacters 

Metacharacters in PowerSearch+ are divided into several categories. 

¢ Those which only match a specified set of characters are 
called Wild Cards. 
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¢ Those which match only one character, usually non-printing, 
are called Specials. 

e Those which only affect the position of the insertion point 
and cause no selection of text are called Positions. 

* Those which are used to repeat a regular expression arc 
called Repeat characters. 

¢ Finally, those which are related to the clipboards are called 
Clipboard-related metacharacters. 

Wild Cards 

The following metacharacters are predefined wild cards. Each 
metacharacter matches a character from a given set. You can choose 
some of these metacharacters from the menus in the expanded version 
of the Find/Replace dialog. For a complete listing of metacharacters 
which are available by menus, see Metacharacter Listings at the end 
of this chapter, page 377, or refer to the Nisus Quick Reference Guide 
(pamphlet). Wild Cards are only meaningful when they are used for 
constructing the find pattern. If used in the replacement pattern, they 
will be interpreted literally because they do not represent a unique 
match. 

. (any Character except return) 
A period (.) is a wild card that matches any character except return. 
This metacharacter is equivalent to the [*} pattern. The pattern 
-ffect, with Whole Word checked, matches words such as affect 
Oreffect. 

:. OF 7? (any character or return) 
The metacharacter :. or equivalently :? matches any character 
including a return. This is equivalent to : [~] . It matches any character 
in the entire ASCII range 0 through 255. 

7! (any gremlin) 
The metacharacter :! matches any gremlin. This metacharacter is 
useful in cleaning up data base output files or downloaded user 
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network files. Note that the Zap Gremlins command in the Edit 
menu is a built-in macro. It removes all gremlins from your document 
and any trailing spaces at the end of each paragraph. The ASCII 
range of a gremlin is 0 through 31 (except the 13, the return, and 8, 
the tab) and 127 through 255. 

: (any control character) 
A colon followed by a space is a metacharacter that matches any 
control character. This metacharacter may be useful in cleaning up 
DOS files or files downloaded from a network. The ASCII range of 
the control characters is from 0 through 31 (except 13, the return). 

:@ (any gremlin, tab or space but not a return) 
The metacharacter :@ matches any gremlin, a tab, or a space. It is 
equivalent to :!|:b 

sa (any alphabetic) 
The metacharacter : a matches any lowercase or uppercase character. 
it is equivalent to the pattern A~Za~-z plus all the modified alphabetics 
which are typed using the option key. 

:A (any alphabetic or diacritical) 
The metacharacter : A matches any alphabetic, underline, or modified 
alphabetic. It is the same as :a plus the underline. 

:@ (Option a) (not alphabetic, nor diacritical, nor underline) 
The metacharacter :4 matches any character which is not an alphabetic 
as defined above. 

‘A (shift option a) 
The same as :4 but includes the undertine. 
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:b (any blank) 
The metacharacter :b matches either a space (ASCII 32) or a tab 
(ASCII 9). This is equivalent to [\s\t). For example, :b+$ matches 
any number of trailing spaces or tabs at the end of a paragraph. 

:d or :# (any digit) 
The metacharacter :d (or equivalently : #) matches any digit from 0 
through 9. It is equivalent to [0-9] . For example, :d:d:d matches 
a three digit number and :d:d:d\-:d:d:d:d matches a standard 
7-digit phone number. Notice a backslash is placed before the minus. 
The minus has a special meaning, being a repeat character, but when 
it is preceded by a backslash it is interpreted literally. 

“h of :x (any hexadecimal digit) 
The metacharacter :h or equivalently :x matches any hexadecimal 
digit; that is, any digit or any alphabetic character from a to f. It is 
equivalent to the pattern [0-9a-fA-F]. 

‘I (any lowercase) 
The metacharacter :1 matches any lowercase alphabetic character 
from a to z plus the modified alphabetics. 

:n (any alphanumeric or underline) 
The metacharacter :n matches any alphanumeric character. 

‘N (any alphanumeric or diacritical) 
The metacharacter :N matches any alphanumeric, underline. It is the 
same as :n but includes the underline. 

0 (any octal digit) 
The metacharacter :o matches any digit from 0 to 7. It is equivalent 
to [0-7]. Programmers may find this useful. 
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:u (any uppercase) 
The metacharacter :u matches any uppercase alphabetic character in 
the range A to Z. It is equivalent to [A-2}. 

:w (any character in a word) 
The metacharacter :w matches any character which is part of a word 
as defined on page 376. 

‘0 (Option d) (diacritical or underline) 
The metacharacter :¢d matches any character which is a diacritical, 
i.e., a modified alphabetic. 

:= (Option x) (any word) 
This matches any word as defined on page 376. 

‘| (Option Shift d) (Not diacritical nor underline) 
It is the opposite of :d 

:~ (Colon Tilde) (not alphanumeric) 
This is the opposite of :n 

Special Metacharacters 

Each of the following metacharacters matches one character only, 
usually a non-printable character such as a space or an invisible 
character such as the null character. Because all these metacharacters 
have a unique match, they can also be used in the construction of the 
replacement pattern. 
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\0 (null) 
The metacharacter \0 (backslash zero) matches the null character 
whose ASCII code is 0. The null character is invisible but it can be 
searched for by PowerSearch+. To see if there are null characters in 
your document search for \0 making sure that you are in 
PowerSearch+ mode. You can search for the null character literally 
(use the ASCII table to enter it into the Find/ Replace dialog) but 
because null characters are invisible it is easier to use PowerSearch+. 

\b (backspace) 
The metacharacter \b matches the backspace character whose ASCII 
code is 8. To insert a backspace character in your document choose 
ASCII Table from the Edit Tools submenu of the Tools menu and 
copy the ASCII 8 character. The backspace character does not perform 
the action of the Backspace or Delete key. 

it (tab) 
The metacharacter \t matches the tab character whose ASCII code is 
9. Insert a literal tab in your search pattern by holding down Shift 
while pressing Tab. 

lv (new line) 
The metacharacter \v matches the new line character whose ASCII 
code is 11 (the standard vertical tab). This is used to force a new line 
without starting a new paragraph. This avoids any indentation on 
rulers and at the same time forces a line break. To insert new line 
characters in your document, press the Shift and Enter keys, or choose 
ASCII Tabte from the Edit Tools submenu of the Tools menu and 
copy or double-click the ASCII 11 character. 

lf (form feed) 
The metacharacter \f matches an explicit page break or a form feed 
character whose ASCII code is 12. Replacing \£ with nothing removes 
all explicit page breaks. 
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¥ (return) 
The metacharacter \r matches the return character whose ASCII code 

is 13. 

ls (space) 
The metacharacter \s matches the space character whose ASCII code 
is 32. It does not match a non-breakable space (Option-Space). 

Position Metacharacters 

These characters include the Character On Left and the Character 
On Right symbols which cannot be searched for on their own but 
can form a part of the search pattern. Each of the remaining 
metacharacters represents a position of the insertion point. A search 
for any of these metacharacters causes the insertion point to move to 
a defined location without selecting any text. Note that if these 
metacharacters are used for constructing replacement patterns, they 
will be interpreted literally. 

:< (character on left) 
The pattern :<x matches an insertion point position to the right of 
the character x. The character x is interpreted literally even if it is 
one of the predefined wild cards. For example, a search for the pattern 
><. moves the insertion point to the right of a period. The pattern 
:<x moves the insertion point to a position where the following 
Statement is true: “the character x is the preceding character.” 

The character x can be a user defined wild card but not any predefined 
wild card. For example, the pattern :u:<{*A-F] matches any 
uppercase character, represented by :u except A through F. 

its” If the pattern [2] or {*2] is preceded by either :< or :> you can 
include the return character in the set >. 
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:> (character on night) 
The pattern :>x matches an insertion point position to the left of the 
character x. Note that :>x should always occur at the end of your 
search pattern; otherwise an ambiguity arises in the interpretation of 
the pattern and no match is found. For example, the pattern :>ab 
has no match because an insertion point to the left of the letter a 
cannot be followed by b. The pattern a:>[*.] matches the letter a 
followed by any character except a period. The pattern :>x moves 
the insertion point to a position where the following statement is 
true: “the character x is the next (or following) character.” 

\< (word start) 
A pattern preceded by the metacharacter \< matches whatever the 
pattern matches, provided the first character of the matched text is at 
the beginning of a word. A character may be at the beginning of a 
word if it is alphanumeric or an underline and if the character 
immediately to the left is not alphanumeric or an underline. In terms 
of other metacharacters \< is equivalent to: 

7<[*A-Za-z0-9_ ]:>[A-2Za~z0-9 ] 

A search for \< causes the insertion point to move to the beginning 
of the next word without selecting any text. 

\> (word end) 
A pattern x followed by \> matches whatever x matches, provided 
the last character of the matched text is at the end of a word. A 
character may be at the end of a word if it is alphanumeric or underline 
and if the character immediately to its right is not alphanumeric or 
underline. In terms of other metacharacters \> is equivalent to: 

:<[A~Za-z0-9 ]:>[*A~2a-z0-9 ] 

A search for \> causes the insertion point to move to the end of a 
word without selecting any text. 
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A (G start) 
A pattem x preceded by * forms a pattern *x which matches whatever 
x matches provided the first character of the matched text is at the 
beginning of a paragraph. A character is at the beginning of a paragraph 
if it is preceded by a return or it is at the beginning of the document. 
In terms of other metacharacters, * is equivalent to :<\rJ:s. 

$ ({ end) 
A pattern x followed by $ forms a pattern x$ which matches whatever 
x matches provided the matched text is at the end of a paragraph. A 
character is at the end of a paragraph if it is followed by a return or it 
is at the end of text. For example :b+$ matches any number of blank 
characters (tabs or spaces) at the end of a paragraph. In terms of 
other metacharacters, $ is equivalent to :>\x| :e. 

:4 (beginning of line) 
A pattern x preceded by :* forms a pattern :*x which matches 
whatever x matches provided the matched text is at the beginning of 
a line or the beginning of a paragraph. For example, the pattern 
: “fitness \> matches the word fitness at the beginning of a line. A 
search for : * on its own moves the insertion point to the beginning 
of the next line. 

:$ (document start) 
A pattern x preceded by :s forms a pattern :sx which matches 
whatever x matches provided the matched text is at the beginning of 
the document. A search for :s on its own causes the insertion point 
to move to the beginning of the document. 

se (document end) 
A pattern x followed by :e forms a pattern x:e which matches 
whatever x matches provided that the matched text is at the end of 
the document. A search for :e on its own causes the insertion point 
to move to the end of the document. 
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Repeat Metacharacters 

The plus, minus, and asterisk symbols (+ - *) are used in regular 
expressions to signal a possible repeating of the previous character 
or bracketed expression. 

+ (1+) 
A character, or a parenthesized regular expression, followed by a + is 
a pattern that matches one or more occurrences of whatever that 
character or expression matches. For example, the pattern a+ matches 
any occurrence of one or more a's. When Nisus searches for a+ and 
finds a sequence like aaaa it will select all four characters, rather 
than just the first one. A search for \ (AB\) + matches AB, ABAB, or 
ABABAB. A search for :d+ will find any sequence of digits such as 
123 or 13245. 

" (0+) 
An asterisk following a character or a parenthesized expression forms 
a pattern that matches zero or more occurrences of whatever that 
character or expression matches. The only difference between the 
repeat character * and + is that * will match no occurrences whereas 
+ must find at least one. For example, the pattern al*e matches ae 
as well as ale, alle, allle, and so forth. al+e matches whatever 
al*e matches except for the case of zero occurrences of the I, ae, 
which al+e skips. 

A pattern of the form x* matches the largest number of occurrences 
of whatever x matches. For example, using the pattern \ (AB\) * on 
the text ABABAB, Nisus does not stop at AB (1 occurrence) or ABAB (2 
occurrences) but highlights the largest match ABABAB. 

- (0 or 7) 
The minus sign following a character or a parenthesized expression 
is a pattern that matches zero or one occurrence of whatever that 
character or expression matches. For example, al~e matches only ae 
and ale. Note that the minus inside brackets, as in [a-c] signifies a 
range. 
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Cae paid 

Same as -, +, *, but matches the shortest text. For example, in searching 
for the phrase: 

“Is it,” she asked, “because I am so ugly?” 

the pattern “.:+” (must include the quotes!) would find “Is it,” 
while the pattern “.+” (also including the quotes) would find the 
entire phrase. 

Note that when searching backward, from the selection or insertion 
point toward the beginning of the document, the shortest sequence 
of characters is sometimes the one found, whether or not the colon 
precedes the repeat metacharacters. This results from the fact that 
the search proceeds in reverse. For example the expression a\(ef\)*c 
(a string like aefefefc), when searching in reverse will select the longest 
match, but if the search expression is \(ef\)*c and the search is in 
reverse the match will be efc. 

Tagging Expressions 

ite” The following is an exact repeat of the corresponding documentation 
of PowerSearch, modified to use the metacharacters symbols used in 
PowerSearch+. To enter any of these metacharacters in PowerSearch+ 
you can use the Find/Replace dialog menus. To make the menus 
accessible from PowerSearch+, zoom out the dialog to its larger size. 
PowerSearch+ is more powerful than PowerSearch and so not all 
possible metacharacters are available in the menus. 

Quite often you want to “tag” or mark a part of the Find Pattern in 
order to use it as part of the remaining Find Pattern or part of the 
Replacement pattern. The following metacharacters are used for this 
purpose. 
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Found (&) 
The & metacharacter stands for the currently found or selected text. 
This metacharacter can only be used in the replacement pattern where 
it means the entire text that was last found, which means the expression 
which last matched the complete Find Pattern. 

The & metacharacter can be used to add text to found expressions. 
For example the following Find Pattern and Replace Pattern will add 
bullets to the beginning of each paragraph: 

Find Pattern: “iF 

Replacement Pattern: ¢é& 

You can also use this metacharacter to change the attributes (font, 
size and styles) of text without altering the text itself. You can also 
use it to count the number of occurrences of certain words or phrases. 
To do this, type any text in the Find box and enter & in the Replace 
box and then click (Replace all). Nisus will replace every occurrence 
of the found text with itself in effect making no change at all. It will 
then display in a dialog box how many replacements were made. 

Example: A of Paragon with will count how many 
times the word Paragon appeared in the current document, or all 
open documents, without making any changes to the documents. 

Parentheses, Tags and \1 through \9 
The left \( and right \) backslash parentheses! are used to bracket 
or “tag” an expression (in the Find Pattern only) for the purpose of 
referring to it later in the remainder of the same Find Pattern or in 
the Replacement Pattern. They do not change the Find Pattern in any 
way. That is any regular expression without these parentheses will 
match the same text as with the parentheses except in the case where 
you use a repeat pattern metacharacter following the closed 
parentheses. Each parenthesized expression can be referred to in any 
following expression with the appropriate one or more of the items: 

‘The backslash is necessary to distinguish these special “tags” from 
the literal parentheses. 
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\1 through \9 and \E10 through \E63. Thus \1 is used to represent 
the text found by the first parenthesized expression. \2 to represent 
the text found by the second expression and so on. 

Example: To convert all the dates of the form mm/dd/yy to 
international dates of the form dd/mm/yy. Use the Find Pattern: 

NGd:d N\)/N\Gd:id\)/\Gd:d\) 

and replace it with: 

\2/\1/\3 

This search will replace the date 09/28/88 with 28/09/88 

Nesting Parenthesized expressions. 
When a parenthesized expression occurs inside a parenthesized 
expression, the numbering count starts from left to right, from the 
outside in. 

Example: In the expression (in which we use A,B,C,D,E,F to represent 
any characters, metacharacters, or expressions): 

\A\(B\(CDN)\)\(EFN)\) 

\1 would be whatever matched A, \2 would be whatever matched 
B, \3 would be whatever matched CD and \4 would be whatever 
matched EF. 

Using Parentheses to designate repeated patterns 
When a parenthesized expression is followed by one of the repeat 
metacharacters, the resulting regular expression matches a text pattern 
in which the repeated expression can be any instance of a match for 
the first expression. This means that the found text need not be the 
same for each instance of the repeat. 
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Example: The expression “\(a:d\)+” will match any sequence of an 
alphabetic followed by a digit, as for example in A2D2 or C3P4. 
However when the parenthesized expression is later followed by 
“\1”, the “\1” expression must match exactly the text to which it 
refers. For example the expressions: 

\Ga:d \)+\1 

would match the pattern A2B3A2B3, but would not match A2B3C4D4. 
Using such parenthesized expressions you can perform many useful 
searching and replacement operations. 

Example: Suppose you wanted to find two neighboring paragraphs 
beginning with the same first alphabetic character. Your Find Pattern 
would be: 

These must 

match the same 

character. 

N\(ca\) WAS 

This would highlight both paragraphs. 

Example: The Find Pattern: 

A\ (Cat \)\Cb4\)\Gat+\) 

together with the Replacement Pattern: 

\3\2N1 

will swap the first two words in a paragraph. 

ite” It is important to remember that you must not use any of the ... Found 
expressions before you have “tagged” or bracketed the appropriate 
number of prior expressions. 
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Replacement Patterns 

The most common use of metacharacters and regular expressions is 
in constructing find patterns. Some are also useful in constructing 
replacement patterns. If a metacharacter or a regular expression has 
a unique match then it can be used in constructing replacement 

patterns. For example, the metacharacter (&%) matches the 
last text selected. Because it has a unique meaning it can be used in 

constructing replacement patterns. The metacharacter in 
PowerSearch, which matches a return character, can also be used. 

The metacharacter (0-9), which matches any digit from 0 through 9, 
cannot be used because it does not have a unique meaning. If a 
metacharacter is not allowed in a particular context, Nisus will usually 
not let you select it in PowerSearch. No such restriction applies when 
using PowerSearch+ where you are left to your own devices and can 
easily create patterns which do not do what you expect. 

ie” Even in PowerSearch it is easy to create patterns that don’t match 
anything. When this happens you are advised to rebuild your pattern 
from the beginning, adding only one metacharacter at a time, and 
checking what is being found or replaced after each such increment. 

its” Note that Nisus does not have the limitations of “or” in UNIX GREP. 
In Nisus the “or” can be used anywhere including inside paretheses. 

Definitions 

Character Definitions in Nisus 

Alphabetic Characters ..............0000 Any characters in the range A 
through Z and a through z plus 
all the option and shift option 
alphabetics. These include all 
the modified alphabetics which 
are used in the European 
languages. These modified 
alphabetics are referred to as 
“Diacritical Characters” and are 
shown below. 
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Aiphanumeric Charactets.............. Any alphabetics and the digits 0 
through 9 

Control Characters..........-.ssssccsseoes Any character whose ASCII 
code ranges are: 0-12, and 14-31. 
None of them are printable in 
Helvetica. 

Diacritical Characters .............0.00 Any character whose ASCII 
code ranges are: 128-159, 167, 

174,175, 190, 191, 203-207, 216 

Diacritical in Helvetica................. 7 eee 

AAGENOUAaaAaACE RSI 
hooos6uudd BAEDaeeAO 
CEcey 

GISIMNING sisitestsctote nce ein Any character whose ASCII 
code ranges are : 0-8, 10-12, 
14-31, 127-255 

Gremlins In Helvetica..................-+ 

AACENOUdaaaadcéeéeninind o6- 
SSuLHUtP Cg eYBHO™ “ZA Geo 
+<>¥pd DTT! Q220; jv fede... 
AAOCce—*""0Y 

Word Definition in Nisus 

The following characters can be a part of a word under the conditions 
stated: 

¢ All alphanumerics, diacriticals, non-breaking space (option- 
space which is ASCH 202); 

¢ $ provided it is preceded by a non-alphanumeric and followed 
by a digit or decimal point; 

¢ ¢ (ASCII 162), %, provided they are followed by a non- 
alphanumeric and preceded by a digit or decimal point; 
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¢ ‘ (apostrophe), ' (smart apostrophe), - (hyphen or 
minus) provided they are surrounded by alphabetics; 

* The comma, provided it is surrounded by digits; 

* The period (decimal point) provided it is followed by 
a digit and preceded by a non-alphabetic. 

This defines a word for the following purposes: 

* Selection by double-clicking 
* PowerSearch+, PowerSearch and Spelling Checker searches 
¢ Word count in Get Info... from the File menu. 

Metacharacter Listing 

Wild Card 

Any character except return’ 
: (Space) Any control character 
rf Any Gremlin 
or :7? Any character including return! 
:@ Any Gremlin, tab or space but not a 

return 

“A Any alphabetic or diacritical 
‘A Any alphabetic or diacritical, or 

underline 
‘a Any alphabetic. [A-Za-z]’ or diacritical 
-@ (option a) Not alphabetic nor diacritical nor 

underline 
tb Any blank character (space or tab )' 
-d or :# Any digit [0-9]’ 
I Any lowercase character, [a-z]’ 
n Any alphanumeric or underline’ 

"These metacharacters are defined in Chapter 12, Pattern Matching 
Using PowerSearch. 
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‘N Any alphanumeric, diacritical, or 
underline’ 

0 Any octal digit, [0-7] 

U Any uppercase character [A-Z]’ 
(Ww Any character which is part of a word 
x or:h Any hexadecimal digit [0-9a-fA-F] 
~ Not alphanumeric nor diacritical nor 

underscore 
:0 (option d) Diacritical or underscore 

= (option x) Any whole word 
‘I (option D) Not diacritical nor underscore 

User Defined Wild Card 

Let 2 be a set of characters which can include any ASCII codes 
except the return character (ASCII 13). Let ¥' be a set of characters 
which can include all ASCII codes (including the return character). 

[¥] Any character from the set > 
[)] Any character not from the set > 
(X'] Any character from the set ' 
“| pe Any character not from the set > 

Special’ 

\0 The null character, (Decimal ASCII 0) 
\b Backspace character (Decimal ASCII 8). 
\t Tab, (Decimal ASCII 9)! 

'These metacharacters are defined in Chapter 12, Pattern Matching 
Using PowerSearch. 

“These metacharacters are the only ones translated in the replacement 
_ pattern. The others are interpreted literally. The metacharacters which have 
special meaning in the replacement pattern are: \1..\9 \E10...\E63 & \CC \C0...\C9 
\b \r \f \v \r \s \t 
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\v New line or line feed, (Decimal ASCII 
11) 

\f Explicit page break, (Decimal ASCII 
12) 

\r Return, (Decimal ASCII 13)! 
\s Space, (Decimal ASCII 32)’ 

Logic 

Or’ 
\ Modifier character 

Modifier character 

Repeat 

. Zero or more occurrences’ 

+ One or more occurrences? 

. Zero or one occurrence! 

Same as * but finds the shortest match 

+ Same as + but finds the shortest match 

‘- Same as - but finds the shortest match 

Position 

. Beginning of Paragraph 

$ End of Paragraph 
“i Beginning of Line 

< Preceding character is: 

[> Following character is: 

:S Beginning of Document 
7e End of Document 

'These metacharacters are defined in Chapter 12, Pattern Matching 

Using PowerSearch. 
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\< Beginning of Word 
\> End of Word 

Clipboard’** 

\cc Contents of current Clipboard 
\CO...\C9 Contents of Clipboard 0 through 9 

Expression’ 

& Currently selected expression?’ 
\(...\) Parenthesized expression 
\1...\9 Parenthesized expression 1 ... 9” 
\E10...\E99 Parenthesized expression 10 ... 99 

Advanced Examples 

Swapping Words 

To swap any two consecutive words even if they are separated by a 
return, search for \(=\)\(:{\s\t\r]+\)\(=\) and replace it 
with \3\2\1. Thus if this example finds the two words “well dressed” 
they will be replaced by “dressed well.” Here is the explanation: 

e =matches a whole word 

‘These metacharacters are defined in Chapter 12, Pattern Matching 
Using PowerSearch. 

“These metacharacters are the only ones translated in the replacement 
pattern. The others are interpreted literally. The metacharacters which have 
special meaning in the replacement pattern are: \1..\9 \E10...\E63 & \CC.\CO...\C9 
\b \r \f Ww ir \s \t 

“These metacharacters are interpreted literally in the find pattern: 
\CC \CO...\C9 & 
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\¢: {\s\t\xr]+\) matches any sequence of blank characters 
such as spaces, tabs, or returns 

= matches another word 
\3 stands for the third parenthesized expression which is 
the second of the two words found 
\2 matches whatever the second parenthesized expression 
\(: [\s\t\xr)]+\), matches 
\1 matches the first parenthesized expression which is the 
first of the two words 

Finding Duplicate Words 

To find repeated words such as “cat cat” even if they are separated 
by a return character, search for: 

\(=\) : ON\s\e\r)]4\1\> 

\ (=\) finds the same thing as = represents. 
= matches any whole word. (Type Option-x to get the symbol). 
: [\s\t\r]+ matches any sequence of blank characters such 
as spaces, tabs, or returns. 

\1 matches a repeat of the first word found. 
The metacharacter \> matches the end of a word. This 
metacharacter at the end of the find pattern is necessary to 
eliminate matches such as “for for” in “for form.” 

Repeated words are also found by the Spelling Checker. 
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Finding Phone Numbers 

To search for phone numbers with or without area codes, search for 
the pattern: 

\<\ (1\s8*\--\s*\) -\ ((-:didid)-\)-\s*\-- 
\s*:d:d:d\s*\--\s*:d:d:d:d\> 

This pattern matches phone numbers in any of these forms: 

619 481-1477 4811477 1 - (619) 481 - 1477 
(619) - 481 - 1477 481 1477 1 619 - 481 1477 
619-481-1477 481-1477 1-619-481-1477 

* \(1\s*\--\s*\)- matches zero or one occurrence of 
whatever 1\s*\--\s*\ matches. 

* 1\s* matches a 1 followed by any number of spaces including 
none. 

* \-~\s* matches a minus (-) followed by a zero or morc 
spaces. 

* \((-:d:d:d)-\)- matches one or no occurrence of 
whatever (-:d:d:d) - matches. 

¢ (- matches one or no occurrence of (. 
* :d:d:d matches a sequence of three digits. ) - matches zero 

or one Occurrence of ). 
* \s*\--\s*:d:d:d matches any number of spaces followed 

by a minus or no minus, followed by any number of spaces, 
followed by a sequence of three digits. 

¢ \s*\--\s*:d:d:d:d matches any number of spaces followed 
by a minus or no minus, followed by any number of spaces, 
followed by a sequence of four digits. 

Changing to International Dates 

To search for all dates in the following forms: 

08/16/88 8/16/88 08/16/1988 

and replace them with: 
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16/08/88 16/8/88 16/08/1988 

respectively, search for: 

VOradiea\ DP wisdid-\y 7 has d\(sded\)=\) 

and replace it with: 

\2Z7 X17 Ve 

° The first sub-pattern \ (:d:d-\) matches the month. The 
matched month is remembered as \1. 

e / matches a literal forward slash. 
¢ The second sub-pattern \(:d:d-\) matches the day. The 

matched day is remembered as \2. 
* \(:d:d\(:d:d\)-\) matches the year in either two digit 

or four digit format. Note that the text matched by the outer 
parenthesized expression is remembered as \3 and the text 
matched by the inner one is remembered as \ 4. 

* \2/\1/\3 replaces month/day/yr with day/month/yr. 

(a See Chapter 20 in Algorithms, by Robert Sedgewick (Addison Wesley, 
1983), for a theoretical discussion of Regular Expressions. 

Useful Regular Expressions 

The following are some regular expressions both as examples of useful 
regular expressions and as the beginning of a library of regular 
expressions that you can refer to without re-inventing one every time 
you need it. Other useful regular expressions are contained in the 
example macros supplied with Nisus. 

The regular 
expression... Matches... 

Pe LOC eS) any text between parentheses. 

oC" pees | any text in between quotes. 

“\<ta:+\> any alphabetic word at the beginning of a 
paragraph. 
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VFN) cS INSA\r\ty4\1 

V\CIANS*\--\s*\)-\((-: 
:d:d:d\s*\--\s*:d:d: 

\¢:b\) \1+ 

:b+$ 

aie (hae al 

ei Sau ba Yee ey 

MAEVE T Ae 

=b+\. 

Ase\s 
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any two consecutive duplicate “words” 
which need not be alphabetic and can be 
separated by a return. 

d:d:d)-\)-\s*\--\s* 
d:d 
any phone number including area code. 

two or more spaces or tabs in a row. You 
can remove the extra blank characters by 
using the replacement pattern \1 

any number of spaces\tabs in a row at the 
end of a paragraph. You can remove 
trailing blanks at the end of a paragraph 
by using nothing for the replacement 
pattern. 

the beginning of a non-empty paragraph. 

matches a quotation mark followed bya 
period or a comma. Conventionally the 
comma and the period are always 
enclosed within quotation marks. You can 
swap these punctuation marks and the 
quotation mark by using the replacement 
pattern \2\1. 

matches a semicolon or a colon followed 
by a quotation mark. Conventionally the 
colon and semicolon are never enclosed 
within quotation marks. You can swap 
these punctuation marks and the 
quotation mark by using the replacement 
pattern \2\1. 

Any trailing blanks before a period. 

Beginning of a “wrapped” line (soft 
return) (or:4:<[A\r]). 
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14 
Working with Macros 

introduction 

To automate repetitive or long and tedious tasks, Nisus can create a 
single menu command which performs the equivalent of a sequence 
of key strokes, menu selections and calculations. Such a group of 
commands is called a Macro. Macros can be recorded, typed, and 
edited. 

A Nisus macro consists of a sequence of instructions which Nisus is 
to execute: menu commands to be executed, calculations to be 
performed, keys to be typed, or mouse clicks to be done. These 
instructions and the rules which govern them form a language which 
we call the Nisus Word Processing Language. It is an extremely 
powerful language allowing you to build-in custom features which 
can make some things practical that used to be impractical, or simply 
save you a great deal of time. 

For example, if you regularly receive unformatted text files which 
you have to format in a certain standard way, you can create a macro 
which will perform the formatting completely automatically. The 
macro becomes a command in the Macros submenu of the Tools 
menu and all you have to do to make it work is choose it and watch 
the performance. Certain special macros can also be made to execute 
automatically when certain events occur. 

For example, you can have a macro execute when you first start up 
Nisus, when you open a new file, when you open any existing file, or 
even when you double-click while holding down a modifier key. 
These features allow you a great deal of flexibility in customizing 
Nisus and automating many tasks. 
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The power of the Nisus Word Processing Language is divided into 
two dialects: The Menu Command Dialect, described in this chapter, 
and the Programming Dialect described in a separate pamphlet titled 
Macro Language: Programming Dialect. The Menu Command Dialect 
is recommended for all users of Nisus. The Programming Dialect is 
recommended only for those who want to learn programming, or 
those who have become so familiar with the Menu Command language 
that they want to go beyond its limitations. The programming Dialect 
is a full procedural language which can also, incidentally, be used to 
teach elementary programming in the context of a word processing 
document. 

Paragon Concepts offers a macro writing service for those who need 
custom features but do not have the time to learn how to do it 
themselves. For more information you are invited to call our general 
number and ask for details of the Macro Programming Service. 

To create a macro you either type the instructions into a special 
macro file window or you turn on the macro recorder and perform 
the actions you want repeated. You then name the macro and save 
the macro with the usual Saye menu command. Once written, macros 
are available as menu commands by the names you gave them, just 
like the standard features. 

The Menu Command Language, as the name implies, consists of all 
the menu commands. Type a menu command on a line in a macro 
file, and when you execute the macro, its effect will be the same as if 
you had selected the menu command. This is the fundamental principle 
on which the Menu Command Language is based. To extend their 
capabilities in a macro, some menu commands also understand 
“parameters.” These parameters are explained later in this chapter. 

To help you write your own macros, several example macros arc 
supplied with Nisus. They range from a simple macro which removes 
unwanted characters from a document to one that creates a list of all 
unique words, or one which automatically numbers figures. 

ite” To fully explore the power of macros, read more about the underlying 
text description language PowerScarch+ in Chapter 13. 
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Macros can be recorded through Nisus’ macro recording facility or 
the text of the macro can be typed in directly. The text of a macro is a 
sequence of instructions, each instruction from one of two Nisus Macro 
Language dialects: the Menu Command Dialect and the Programming 
Dialect. The recording facility only creates instructions in the Menu 
Command Dialect. 

The Nisus Menu Command Dialect is very powerful; however, it has 
certain limitations, most of which are not serious drawbacks. For 

example, although there is no “if...then...” (conditional) instruction 
in the Menu Command Dialect, by using PowerSearch+ you can 
usually avoid the need for conditionals. Simple looping is supported, 
and macros may call other macros; a macro may even call itself. 
Nisus cannot record dragging, but by using keyboard commands, 
which are recorded, text can be selected. You will find “if... then...” 

conditionals in the Programming Dialect. See the separate Nisus Macro 
Language: Programming Dialect pamphlet for details on how to usc 
these expressions. 

Macros have the power to prompt the user for input or use the 
Clipboards as variables, and they may even create other macros or 
modify themselves. 

NOTE: The Programming Dialect commands are not available unless 
the file “Nisus Programming Dialect” is in the same folder as Nisus 
at the time of start up. 

Setting up a Macro File 

Macro files are Nisus documents with a distinctive icon 
load a macro file as you load any glossary, dictionary, or thesaurus 
document, by using the Open... command or double-clicking on its 
name in the Catalog or Open File dialog. Loading the macro file does 
not bring up the macro window for editing. 
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To open the macro window for editing use the Edit Macro... 
command in the Macros submenu of the Tools menu. There can 
only be one macro file loaded at a time. If you load another macro 
file, Nisus unloads the currently loaded one. Each macro file may 
contain any number of individual macros. The macros contained in 
the current macro file appear at the bottom of the Macros submenu 
of the Tools menu as menu commands. 

When you open the macro file for editing you see that it is just like a 
normal document except that it has a black Title Bar and special 
breaks between individual macros. Zoom the macro file to full size 
by double-clicking on its Title Bar. The macros in that file are separated 
from one another by a macro break, just like page breaks in regular 
documents. On the left side of the macro file, the macro names are 
listed alphabetically. On the right of each macro name the macro 
instructions are listed, one per line as illustrated in Figure 14-1. 

Macro Names Macro Instructions Macro Breaks 

> Nisus Macros 
' 41 ry ‘a : , | _ ‘ memremrmmmmemmmmrme  in/Reploce-.”"O\s\8\5"- 

Chicago 12 point | | Chicago re 
Fy 129 Ns 

Find/Replace “\r*-with-"|"-*ag"4 fp index Word List 
fi 

Select-ANIG 
Copy4 

Toggle-Front Two ee 
Find/Repioce-‘\CC'-with-°&*-"awigo0"4 

, 
eS RB ER URNS eee ee fae 

Figure 14-1 Nisus Macro file 

Auto Load Macros 

When Nisus starts up, it looks for a file called Nisus Macros in the 
same folder as Nisus, and if that's not found, in the System Folder. If 
the file is found in either folder, it is automatically loaded. No file 
called Nisus Macros is shipped. However you can choose from any 
of the macro files shipped with Nisus, or create a new one, and 
rename it Nisus Macros. 

388 CHAPTER FOURTEEN 



The explanations of the shipped macros can be found in your Nisus 
Macro Language: Programming Dialect pamphlet and by checking 
the comments in the macro file itself. By pressing Option while 
selecting a particular macro, the macro file is opened for editing and 
you are placed at the text of the selected macro where you can read 
the comments. 

Loading Other Macro Files 

Using either the Open or the Catalog... commands from the File 

menu you can load any macro file using the same commands as you 
do when you open Nisus documents. See Chapter 4: Working with 
Text and Documents for more details on how to open Nisus documents. 

Nisus uses only one macro file at a time. When a macro file is loaded, 
it becomes resident in memory. The macros of the current macro file 
become available in the Macros submenu of the TooJs menu as 
menu commands. If you try to load a new macro file and the current 
one has unsaved changes, Nisus will display a dialog asking if you 
want to save the current file before loading the new one. If you quit 
Nisus and the macro file has unsaved changes, Nisus displays a similar 
dialog. 

Creating a New Macro File 

When you choose New Macro File from the Macros submenu of 
the Tools menu, Nisus opens an untitled macro file. If the current 
macro file has unsaved changes, Nisus will display a dialog asking if 
you wish to save it before creating a new one. The untitled macro file 
becomes the current macro file and any new macros created are stored 
in this file. When you quit Nisus, you are asked to save the macro file 
and give it a name. 
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Recording Macros 

Before recording a new macro, close the macro window and open a 
new document. To record a macro, choose Record Macro from the 
Macros submenu of the Tools menu. When the Tools menu begins 
flashing, perform the actions you wish to record. When you are finished 

choose $top Recording... (the command which is shown in place 
of Record Macro during recording). 

What Gets Recorded 

When recording is on, the following actions are recorded: 

¢ Menu commands 

¢ Keyboard commands 
® Typing 

Mouse clicks 

It is important to note that although single mouse clicks such as 
clicking a button or a check box are recorded, mouse movements 

such as “click and drag” are not’. (Double-clicks, triple clicks and 
multiple are recorded.) Nisus, however, provides extensive keyboard 

editing facilities which simulate most of the mouse movements. To 
record text selection using the keyboard read Useful Editing 
Commands section in this chapter, page 429, or refer to the Quick 
Reference Guide. 

Note that Nisus does not record pop-up menu commands. You can 
however assign Command key equivalents to most pop-up menu 
commands and you can record the action of these Command key 
equivalents instead. This means that you cannot record the selection 
of a named ruler from the rulers menu, but you can record the selection 
of a user style from the styles menu. If you need to use a named ruler 
in a recording, you will need to add the ruler you want to a style and 
use that instead. 

‘Actually the contact of the mouse button when it is pressed down is 
recorded but not when it is released. 
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i Nisus records the actual Command keys. If you record a macro using 
one set of key command assignments and then change the key 
assignment used by the macro then the macro will no longer perform 
as before. 

- Stop Recording 

Choosing Stop Recording brings up the Macro Name dialog 
illustrated in Figure 14-2. 

Macro name: 

Figure 14-2 Macro Name Dialog 

The default name of the macro is <Untitled Macro>. It is selected 
so that all you need to do is type in the name of the macro and click 

Nisus will then display the current macro file and place the insertion 
point at the end of the recorded macro instructions. Edit these 
instructions if necessary. The macro names are listed alphabetically 
and appear at the bottom of the Macros submenu of the Tools 
menu. 

ite The macro file does not get saved until you quit Nisus (and confirm 
the save) or until you explicitly save it’. Read the Saving Macros 
section in page 400 in this chapter. 

‘Using the same Save command as for document files. 
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How Macros get Recorded 

When you record a macro, text is used to describe instructions. This 
text is placed in the macro file. After the recording is stopped and 
you give the macro a name, you can edit this recorded text. 

Recording Menu Commands 

When you choose a command from the menu bar, Nisus places the 
name of the command on a separate line. For example, if you choose 

Select All from the Edit menu and then choose Chicago from the 
Font menu, Nisus records the following instructions: 

Select Ali 

Chicago 

Recording Keyboard Entries 

When any text is typed or when you press Return, Nisus inserts the 
word Key followed by a space. It then inserts the typed text. For 
example, if you type the following address: 

Paragon Concepts, Inc. 

990 Highland Dr. 

Solana Beach CA 92075 

Nisus records the following macro instructions: 

Key Paragon Concepts, Inc. 

Key 

Key 990 Highland Dr. 

Key 

Key Solana Beach CA 92075 

Key 
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(> If you make a mistake in typing while recording a macro, DO NOT 
TRY TO CORRECT IT—do not even press the Backspace or Delete 
key. Leave all corrections until you have finished recording, otherwise 
the backspace character is inserted in the macro text whenever you 
type the Backspace key. 

Recording Clicks 

When you record a click, Nisus inserts the word “Click” followed by 
a space and then two coordinates separated by a comma. The first 
coordinate represents the horizontal position relative to the left (or 
right) side of the window. The second coordinate represents the vertical 
position relative to the bottom (or top) of the window. These 
coordinates represent the location of the click relative to an origin in 
the active window. If the two coordinates are both numeric then the 
numbers are relative to the top left of the window. If the first coordinate 
is a number that is preceded by the letter R it is relative to the right 
side of the window. If the second coordinate is a number preceded 
by the letter B, it is relative to the bottom edge of the window. All 
coordinates are relative to the front-most window. If no window is 
open, then the coordinates are relative to the screen. Here are some 
sample click instructions: 

Macro Command Explanation 

Click 23, 23 relative to top left corner 

Click R-8, 9 relative to top right corner 

Click 8, B-38 relative to bottom left corner 

Click R~8, B-38 relative to bottom right comer 

The negative numbers signify that the distance is to the left or up 
from the reference boundary. The coordinates are measured in terms 
of screen pixels. 

Usually you do not need to be concerned with these details because 
the recording is done for you. The above explanations may be helpful 
in the event you want to make slight adjustments to a recorded 
macro. 
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Recording Modifier and Arrows Keys 

The Command, Shift,, Control, and Option Keys are called modifier 
keys. They do not get recorded on their own but only when pressed 
with another key or when a menu command is chosen. In that event 
Nisus, uses the clover symbol % (ASCII 17) for Command, the arrow 
symbol 4? (ASCII 19) for Shift, and the symbol SS (ASCII 20) for 
Option. (The Control modifier is not currently recorded. Control 
together with another key enters control characters.) These symbols 
are only visible on the screen in the Any Font font. In other fonts, 
these symbols appear as small open rectangles LJ or other symbols, 
but still perform their function. When you press the arrow keys Nisus 
records their ASCH equivalent. Each time the Backspace key is pressed 
Nisus records a backspace character (ASCII 8) which displays as a 
reverse arrow with a double stem €. Arrow keys appear in the 
macro window as arrows with single stems: > ¢ # y . 

When recording keystrokes, the Option, Command or Shift modifier 
character appears before the key that is recorded, but after the macro 
command word “Key ”. When recording menu commands or mouse 
clicks, the modifier key symbol appears before the menu command 
name or before the macro command word “Click ”. 

For example if you hold down Shift while choosing Cut and then 
type Command-v, Command-Backspace, Nisus records the following 
macro instructions: 

cut 

Key €v¥ €& 

Macro recording is most often used for actions which include the 
modifier symbols such as Command or Option or mouse clicks. You 
can also type the macro instructions directly in the macro file. Read 
the section Typing Macros, page 401 in this chapter for more details. 

ts The macro recorder will not record the typing of Function keys. 
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Examples 

Swapping Characters 

If you are a fast typist, or a clumsy one, or perhaps have a touch of 
typing dyslexia, you may catch yourself transposing the position of 
some characters. It would be useful to have a command which swaps 
the positions of two characters. Record the following actions: 

fr: 

Zz 
3. 

Place the insertion point to the left of any two characters 
you wish to swap. 
Turn on the macro recorder by choosing Record. 
Press Command-Shift-Space to select the character to the 
right of the insertion point. 

. Press Command-x to cut the character selected. 

. Press Command-Space to move the insertion point one 
character to the right. 

. Press Command-v to paste the character cut. 

. Choose Stop Recording... from the Macros submenu. 
. When the Macro Name dialog appears type Swap Char and 
press Return or click { OK 9. The current macro file is 
displayed with the following macro instruction: 

Key #4) x ® Rv 

. Save and close the file. 

The new macro Swap Char now appears in alphabetical order at 
the bottom of the Macros submenu of the Tools menu. Choose it 
and watch how the two characters to the right of your insertion point 
are swapped. Read Assigning Command Keys to Menu Commands, 
page 452 in Customizing Nisus, to learn how to assign a Command 
key equivalent to a menu command. This allows you to choose menu 
commands without using the mouse. 
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A Macro as a Glossary 

Nisus has a special glossary feature available, however you can, if 
you wish, use a macro instead. You can record a macro of frequently 
used text such as an address. Here is an example: 

1. Choose Record Macro from the Macros submenu. 
2. Start by typing your name, address or any other text that 

you use frequently. If you make a mistake, do not try to 
correct it. Leave all corrections until you have finished 
recording. 

3. Choose Stop Recording from the Macros submenu. 

4. When the Macro Name dialog is displayed, type My address 

and press Return or click ox J. 

You should see something similar to this: 

Key Jane Elizabeth Doe 

Key 

Key 1412 Shady Lane 

Key 

Key Upper Rocktown, MA 02120 

5. Correct any mistakes. 

6. Choose Save from the File menu and close the file. 

You can now choose My address from the Macros submenu of 
the Tools menu and the address will be pasted at the insertion point. 

Executing Macros 

To play back or execute a macro, choose its name from the Macros 
submenu of the Tools menu or press the Command key equivalent 
you assigned to it. See Assigning Command Keys to Menu Commands, 
page 452 in Chapter 15: Customizing Nisus. 
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Interrupting a Macro 

If you want to stop a macro before it has finished executing, hold 
down the Command and period keys simultaneously (9.) until Nisus 
displays the message Process aborted by user. You can then either click 
Continue MACRO | to continue or [Stop MACRO} to abort the macro. 

Undoing a Macro 

Any macro, even the most complicated one, can be undone with a 
single undo. This is because all the actions of a macro are combined 
into a single undo command. 

te When you abort a macro in the middle of execution, then as you 
might expect, Nisus will leave its task only partly completed. So if 
you want to undo the partially completed changes, choose Undo 
from the Edit menu. Note, however, that undoing a macro will not 
undo operations that are not undoable elsewhere in Nisus, such as 
closing or saving a file. 

Editing Macros 

When you choose Edit Macro... from the Macros submenu of the 
Tools menu you can perform any of the following: 

Edit existing macros 
Single step through a macro 
Rename macros 
Delete macros 
Type new macros 
Save macros 
Copy macros 
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Editing Existing Macros 

To edit an existing macro: 

1. Choose Edit Macro... to open the current macro file. 
2. Scroll to locate the macro you wish to edit. Macro names are 

listed alphabetically. 
3. Click in the macro instructions area and start editing. 

it~ A quicker way to activate the current macro file and edit an existing 
macro is to hold down Option and choose the macro you wish to 
edit from the Macros submenu of the Tools menu. This scrolls the 
macro into view, and places the insertion point to the left of the first 
macro instruction. 

i You can test each macro instruction by selecting the line with that 
instruction and then choosing Execute Selection from the Macros 
submenu. 

Testing a Macro 

To allow for quick testing of a macro, Nisus can immediately execute 
selected text which appears in any document as if it were a macro. 
For example: 

1. Type the following text into your document: 
New "My document" 

2. Select this text. 

3. Choose Execute Selection from the Macros submenu. 

Nisus interprets and then executes the selected text as a macro. In 
this example a new document named My document is created. The 
macro text does not need a name and does not get listed with the 
other macros in the Tools menu. To add it to the macro file, copy the 
macro text, create a new macro, and then paste it and save it. 

is When you choose Execute Selection, Nisus moves the front 
window (the one in which you selected the macro text) to the back, 
behind all other windows. The next window becomes the active 
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window and the one affected by the macro. If a new document is 
created by a macro, it becomes the active window. 

Renaming Macros 

. To rename a macro: 

1. Choose Edit Macro... to activate the current macro file. 
2. Double-click the macro name you want to change. 

3. Type the new name and press Return or click [{_Ne 

4. Choose $ave from the File menu. 

Deleting Macros 

To delete a macro: 

1. Choose Edit Macro... to activate the current macro file. 
2. Double-click the macro name you want to delete. 

3. Click (Betete macro} 
i WARNING: You can undo the deletion of a macro until the time that 

you close the macro window. If you close the macro window the 
commands in the undo list associated with that window are lost. Sec 
Undo Command, Chapter 4: Working with Text and Documents, page 
79, for more details on the undo list. 

Even if you have removed a macro and have closed the macro window, 
you can still recover the previously saved macro file provided you 
have not saved the file after deletion. Do the following: 

1. Choose Edit Macro... from Macros submenu of the Tools 
menu to open the Macro window. 

2. Choose Revert To Saved from the File menu. 
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Saving Macros 

Each created macro is added to the current macro file. To save a 
changed or newly created macro file, choose Save from the File 
menu when the macro window is the front window. When a macro 
file is saved all the macros associated with it are also saved. If you 
want to save the current macro file under a different name, then 
choose Edit Macro... to activate the current macro file, and then 
choose Save fis.... Note that if you change a macro file and do not 
explicitly save it, Nisus asks you whether you want to save it at the 
time you quit the program, or try to load another macro file. 

Copying Macros 

In Nisus you can export or import macros from one macro file to 
another. 

1. Choose Edit Macro... from Macros submenu of the Tools 
menu to open the window of the current macro file. 

. Scroll to locate the macro you wish to copy. 
3. Copy the macro instructions in the usual Macintosh fashion. 

Be sure to include the return character that is before the 
macro name. (The highlighted section should be the black 
space at the end of the preceding macro through the end of 
the text of the macro to be copied.) 

4. Load another macro file by using the Open...command in 
the File menu or using the Catalog. 

5. Choose Edit Macro.... 
6. Set the insertion point at the end of the last macro instruction 

in the file. 
7. Press Return. 

8. Choose Paste from the Edit menu. 
9. Choose Save from the File menu. 

No 
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Creating New Macros 

To create a new macro: 

1. Choose New Macro... from theMacros submenu. 
2. When the Macro Name dialog appears type a name and 

click [_Neme_j/ or press Return. 

When the macro file is open, Nisus is ready for you to type in a 
sequence of instructions. 

fs You should not confuse the New Macro... command with the 
New File... command. As the name suggests, choosing New File 
unloads the current macro file and creates a new macro file. New 
Macro, on the other hand, allows you to add another macro to the 
existing macro file. 

Typing Macros 

Each macro consists of a sequence of menu commands that adheres 
to a prescribed format. The set of all possible macro commands forms 
the Nisus Word Processing Language. Learning this language makes it 
possible to modify existing macros and even write new macros of 
your own. If you wish to write macros using the full capability of 
Nisus, it is important to know the language structure (syntax) in 
detail. This section explains how to type simple macro instructions. 
The syntax of the macro language is explained in full detail in the 
section Menu Command Dialect: Syntax and Arguments, page 405. 

Typing Menu Commands 

To include a menu command in your macro, type the name of the 
command on a separate line, then press Return. The ellipsis which 
follow some menu command names (for example, Open...) need 
not be included. Make sure to spell the command name exactly as it 
appears on the menu. You do not need to be precise about using 
upper or lower case characters because Nisus ignores them. If a menu 
command is in a hierarchical menu, only the command of the submenu 
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needs to be used. The following macro instructions capitalize the 
initial letter of every word in a selection no matter what the case of 
the characters is at the outset: 

lowercase 

Capitalize 

in a similar fashion, you may access the ruler commands using the 
instructions listed in the following table: 

Line Paragraph Paragraph 
Height Spacing Justification 

L 1 71 Left 
L 1.5 711.5 Center 
L2 1 2 Right 
i 3 7 3 Full 
L Other 7 Other 

Table 14-1 Other menus accessible with macro commands 

“L Other” and “7 Other’ move the insertion point into the line 
spacing and {] spacing text editing boxes on the Master Ruler. To 
type a paragraph marker (41) press Option 7’. 

There are additional menus that appear on the far right of the menu 
bar immediately after choosing a certain command. When you choose 
Find/Replace from the Tools menu, the Search Method menu 
appears. When you choose Layout Page... from the File menu, 
the Layout menu appears. At other times these menus are hidden. 
In order to access the menu commands of these additional menus, 
you first need to show the menus. For example, to choose the Set 
Columns... command from the Layout menu, use the following 
macro instructions: 

‘Although these menu commands are not on the normal menus, 
they are accessible in a macro. You can see them also on the menus when you 
assign Menu Keys. 
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Layout Page... 

Set Columns... 

There are some exceptions to this rule. Among them are pop-up 
menus that appear on some dialogs, such as the Normal Search 
pop-up on the Find/Replace dialog: a macro can change this to 
PowerSearch without bringing up the Find/Replace dialog. Other 
examples are the ruler commands shown in Table 14-1 which are 
available whether or not the Master Ruler is showing. 

Menu commands sometimes have the same name but belong to 
different menus. This can only happen if you create menu commands 
(macros, markers) which conflict with the standard commands (or 
with other macros, markers, etc.). In a macro, precede the command 
by the menu name followed by a colon in order to resolve conflicts. 
For example, Font: Any Font 

Note: When in a macro you use a command that does not exist, 
Nisus informs you of the line in error and lets you choose either to 
stop the macro or continue. 

Typing Keyboard Entries 

To include keyboard entries type the word Key followed by a space 
and then type the text you wish the macro to insert when it plays 
back. The text must not include a return character. To record a return 
character type the word Key followed by a space. To write a macro, 
which when executed, displays the following text: 

“Are you,” she asked, “the man who helped me?” 
“Yes,” he said, “I was the one.” 

(which includes a return between the two lines and one at the end of 
the second line) include the following macro instructions: 
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Key “Are you,” she asked, “the man who helped me?” 
Key 
Key “Yes,” he said, “I was the one.” 

Key 

These are the same instructions that would be created if you recorded 
the keystrokes. 

Typing Mouse Click Instructions 

It is easier to record a macro that performs all the mouse clicks and 
arrow movements than to work out what you have to type. Record 
the click and key strokes into a temporary macro, and then copy the 
required lines into the macro you are writing. 

Typing Special Symbols 

Nisus uses special symbols to record the modifier keys, arrow keys, 
backspace, and so on. To enter these symbols in your macro file you 
have to choose ASCII Table... from the Edit Tools submenu of the 
Tools menu. See The ASCII Table in Chapter 11: Special Tools, page 
329 for more details. Some of the most commonly used symbols in 
macros are illustrated in Table 14-2. 

Down arrow 

Table 14-2 Common Symbols in Macros 
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Some of these characters display as open rectangles (J ) and others 
as diamonds and the Apple symbol, when they are in some specific 
font rather than the special internal Nisus font called “Any Font”. 
This special font is only available in the Clipboard, in the Macro 
window and in the Find/Replace dialog. The Paste command pastes 
characters in the Any Font so that they assume the surrounding 

- font, size and style. Thus if you try pasting these characters into your 
document, they will assume the font, size and style of the surrounding 
text and will not display as shown in their original windows. 

Menu Command Dialect: Syntax and 
Arguments 

Macro instructions make up a very simple program. Placing a menu 
command name ona line in a macro is equivalent to choosing it from 
the menu. Some menu commands bring up dialog boxes which 
normally need entries from the keyboard or mouse clicks to check 
the various check boxes or buttons. When you choose 
Find/Replace... from the Tools menu, the Find/Replace dialog 
appears on the screen. You would normally type the find pattern in 
the Find box, click in the Replace box and type the replacement 
pattern. When you are recording a macro, click in the Find box, then 
press the Tab key to move to the Replace box (pressing the Tab key 
once more will return the insertion point to the Find box, selecting 
what had been entered there). Then, you would check some search 

options and finally click the {Find Jj or button to start the 
search or replace. You can record a simple macro which finds the 
word the and replaces it with that . 

1. Open a new file and type “the” one or more times. 
2. Choose Record from the Macros submenu of the Tools 

menu. 
. Choose Find/Replace... from the Tools menu. 
- Type the in the Find box. 
. Press the Tab key to move your insertion point to the Replace 
box. 

' 6. Type that in the Replace box. 
7. Press the Command key and type 6. 

nn me Ww 
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8. When the dialog appears, press the Return key. 
9. Press the Command key and type W to close the Find/Replace 

dialog. 

You would get the following macro instructions: 

Find/Replace...4 

Key the? that#%6 49 
Key fl 
Key #WO 

Ite" Warning: If you click in the Replace box, rather than use the Tab key, 
the mouse position will be recorded and the word “that” will be 
appended to the Replace box each time this macro is executed. 

Although this macro when played back, performs as expected, you 
can accomplish the same task by typing the single instruction: 

Find/Reptace “the"-with "that"-using: "ia" 

The expressions in quotes, immediately following a menu command, 
are called arguments. They are used in place of mouse clicks or keyboard 
entries. This allows macros to execute faster and makes them easier 
to type and understand. Arguments can specify what text to search 
for, what text to replace it with, the state of various search options, 
what text to copy, what text to paste, and so on (this version of the 
macro will not bring up any dialogs). 

In the example above, the various arguments are as follows: 
* the Find argument Find “the”. 
* the Replace argument Replace it with “that”. 
¢ the Options argument Use the options “i" (meaning 

Ignore Case) and "a" 
(meaning Replace Ail). 

The meaning of the arguments depends on the particular command. 
Text between each argument is ignored, so with and using in the 
instruction above could have been left out or replaced with something 
else, and the meaning of that instruction would not have changed. 

406 CHAPTER FOURTEEN 



Note however that at least one space is required between the 
arguments. 

[=> Macro arguments are enclosed in plain quotes "..." rather than smart 
quotes “...”. They may also be enclosed in single quotes, but will 
behave differently. This difference is described later in the section 
Single Quoted Arguments, page 423. 

The following section defines the syntax of those macro commands 
which can be used with arguments. 

File Menu Commands 

The following File menu commands may take arguments when 
executed from a macro, New, Open..., Catalog..., Save As..., 
and Transfer.... 

New 

Syntax: 
e New 

® New "Pathname:Filename’ 

e New "Pathname:Filename’"Pathname :Stationery" 
° New ":Foldername:Filename" 

New 

If the Start Up preference is set to name new files as untitled, then 
this instruction creates an untitled document, otherwise it brings up 
the New File dialog. 

New "Pathname:Filename” 
This instruction creates a new document named Filename. Pathname 
is the path to where the document is to be located on disk. To specify 
a path name, start with the disk name. Follow the disk name by a 
colon (:), follow this by the name of the first level folder. Follow the 
folder name by a colon, then the name of the second level folder and 
so on. Do this level by level until you reach the name of the file you 
wish to create. Thus, New "My Notes", creates a new document called 

WORKING WITH MACROS 407 



My Notes and places it in the current folder. New “Disk 1: My 
Folder:My Notes” creates a document called My Notes and puts it in 
the folder My Folder on the disk called Disk 1. 

New “Pathname: Filename” “ Pathname :Stationeryname” 
This instruction creates and names a new document with the specified 
path name and file name. The stationery file is used as a template. 
Thus: 

New "HD:Folderl:Notes" “HD: template" 

creates a new document named Notes and places it in Folderl on the 
hard disk HD. The stationery file template is used as a template. 

New ":Foldername:Filename” 

This instruction creates a new file and names it Filename and places it 
in the folder Foldername in the current folder. If the folder “Foldername” 
does not exist, it is created. 

Open/Catalog 

Syntax: 

Open 
Catalog 
Open "Pathname:Filename' 
Catalog "Pathname:Filename" 
Open "Pathname:Filename' "A" 
Catalog "Pathname:Filename" "A" 
Open "Pathname:Filename' "R” 
Catalog "Pathname:Filename” "R” 
Open "Pathname:Foldername" "C" 
Catalog "Pathname:Foldername:" "C" 
Open "Foldername” "C” 
Catalog “Foldername" °C" 
Open ":Foldername:" "C” 
Catalog ":Foldername:” "C" 
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Catalog 

Open 

The Catalog instruction brings up the Catalog Window and the Open 
instruction brings up the Open File dialog. 

Open "Pathname:Filename” 

Catalog “ Pathname:Filename” 

The Open and Catalog instructions with arguments are synonymous. 
Filename, is the name of the document to be opened. If Pathname is 
omitted, the document is assumed to be in the current folder. If 

Nisus does not find this document, it displays a message that the file 
has not been found and asks you whether you wish to continue or 
stop the macro. If the document is already open but not active it is 
brought to the front. 

Open "Pathname:Filename” "A" 

Catalog “Pathname:Filename” "A“ 

If the second argument is A (for add) the document is not opened 
but instead it is added to the search list. For more details on multi- 
document search, see the section Searching Multiple Documents, page 
409 in Chapter 5: Finding and Replacing Text. Thus the macro 
instruction, Open " My Notes" "A", adds the file called My Notes, 
which must be in the current folder, to the search list. 

Open "Pathname:Filename" "R" 

Catalog “ Pathname:Filename” "R” 
If the second argument is R (for remove) the file is removed from the 
search list. Thus, the macro instruction, Open "My Notes" "R", 
removes this file from the search list. 

Open "Pathname:Foldername” "C” 

Catalog " Pathname:Foldername” "C" 
This instruction opens the specified folder name. The "C" argument 
is short for Change folder. The instruction reads: Open the quoted folder. 
If the folder (folder) does not exist Nisus beeps and displays a message 
that it cannot open such a folder (volume) and that no such volume 
exists. 
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Open "Foldername” "C" 
Catalog "Foldername” "C" 
This instruction opens Foldername if it is in the current folder. If 
Foldername does not exist, Nisus beeps and displays a message that 
no such volume exists. 

Open ":Foldername:" "C" 

Catalog ":Foldername:" "C" 

The colon must precede and follow Foldername. This instruction opens 
Foldername if it is in the current folder. However, if Foldername does 
not exist, it is created, placed in the current folder, and opened. 

Ite” The special instruction Open ": :" "C™ moves the current folder up 
to the next folder up in the hierarchy. You can create a subfolder to 
the current folder with Open’: New Folder: " "Cc" 

Save As 

Syntax: 

* Save As 

e Save As "Pathname:Filename" 

Save As 
This instruction brings up the standard Save File dialog. 

Save As "Pathname:Filename” 

This instruction saves the current document under the name Filename. 
If a path name is specified then it saves the document in the specified 
folder. 

Transfer 

Syntax: 
¢ Transfer 
¢ Transfer "Pathname:Application" 

¢ 4} Transfer "Pathname: Application” 
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Transfer 

This instruction brings up the Transfer window which is the Catalog 
window with only the applications shown. 

Transfer "Pathname:Application” 

This instruction quits Nisus (under MultiFinder it leaves it resident) 
and transfers you to the application specified. If a path name is not 
included, the application is assumed to be in the current folder. When 
this instruction is used, it should be the last one in a macro. if you 
are not in MultiFinder, any instructions following it are not executed 
because the effect of Transfer is to terminate Nisus and thus the 
macro. 

4} Transfer ” Pathname Application” 
When in MultiFinder, this causes Nisus to quit before launching the 
other application. When not in MultiFinder, this causes a normal 
launch (quitting Nisus) but the other application will return to Nisus 
(rather than the Finder) when it is quit. 

Edit Menu Commands 

The following Edit menu commands may take arguments when used 
in macros: Cut, Copy, and Paste. The argument "n" refers to 
clipboard number. It places whatever is cut or copied onto the 
designated clipboard. In a paste operation it would paste whatever is 
on the designated clipboard. 

Cut 

Syntax: 
e Cut 

e Cut "n’ 

«cut 

© 4 Cut"n" 

Cut - 

This instruction cuts the selection and places it in the current clipboard. 
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Cut “n" 

If the argument 7 is present then the resulting instruction cuts the 
selection and places it in Clipboard n. The argument n may be any 
whole number from 0 through 9. Thus, Cut "5", cuts the selection 
and places it in Clipboard 5, replacing whatever was in that clipboard. 

wer <h Cut 

4} Cut "n" 

If the Shift symbol <> precedes Cut, the text cut is appended to the 
contents of the designated clipboard. 

Copy 

Syntax: 
Copy 
Copy "n" "Text" 
Copy "Text" 
Copy "Hy "4 

- > Copy 

© 4} Copy "n" "Text" 
e 4> Copy itt "Text" 

© 4? Copy “n" 

Copy 
This instruction copies the selection to the current clipboard. 

Copy “n" “Text” 

The argument n is, as in Cut, the clipboard number. Text is any 
sequence of characters (not including return characters) to be copied. 
Thus the macro instruction, Copy "2" "Paragon", places the word 
Paragon in Clipboard 2. 

Copy vr ee "Text td 

If n is omitted, as in, Copy "" “Paragon”, the word Paragon is 

copied onto the current clipboard. 
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Copy *n" 
If Text is omitted, as in, Copy "3", the selected text is copied onto 
Clipboard 3. 

a> TP Copy 

“<> Copy "n" "Text" 

~ 4) Copy ”" "Text" 
af Copy “n” 

If you precede Copy with the Shift symbol 4} the resulting instruction 
appends the copied text to the designated clipboard. 

There are other ways you can use the Copy instruction. See Single 
Quoted Arguments, page 423 in this chapter for more details. 

Paste 

Syntax: 
* Paste 

e Paste "n' 

¢ Paste "” "Text" 

e Paste “n" "Text" 

° 4? Paste 

© 4 Paste "n" 

© 4} Paste" "Text" 

Paste 

This instruction replaces the selection with the contents of the current 
clipboard. 

Paste "n” 

This instruction replaces the selection with the contents of Clipboard 
n. Thus, Paste "3" replaces the selection with the contents of 
Clipboard 3. 

Paste "" "Text" 

Text is the text to be pasted. Thus, Paste "" "Paragon", replaces 
the selected text with Paragon. 

WORKING WITH MACROS 413 



Paste "n" “Text” 

This instruction copies the selection to Clipboard n and Text replaces 
the selection. 

ie” > Paste 

If the Shift symbol 4} precedes Paste, the resulting instruction swaps 
the selection with the contents of the clipboard. 

4} Paste "n" 

This instruction swaps the selected text with the contents of Clipboard 
n. 

4? Paste “" “Text” 

This instruction copies the selected text to the current clipboard and 
then replaces the selection with Text. 

Tools Menu Commands 

The following Tools menu commands can take arguments when 
used in macros: Find Next, Find All, Find in Selection, Replace 
With, Replace All, Replace in Selection, Find/Replace..., 
Line..., Page...,and Mark Text.... 

Find Next 

Syntax: 

Find Next 
Find Next "Find Pattern" "Options" 
Find Next "Find Pattern" 
Find Next "Find Pattern" "Options" 
Find Next "Find Pattern” "Options" "Windows" 

The same syntax is used with the following commands whose names 
explain their function: 

e Find All 
e Find in Selection 
¢ Replace With 
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¢ Replace All 
* Replace in Selection 

Find Next 

This instruction brings up the Find/Replace dialog. 

Find Next "Find Pattern” “Options” 
The first argument Find Pattern can be any regular expression or 
literal text that does not include a return character. The second 
argument Options, if present, is a sequence of characters each of which 
is an abbreviation for a search option. For example, w means Whole 
Word, i means Ignore Case, M means multi-document search, and so 
on. To turn off an option precede the letter representing that option 
by a minus (-). Thus -w means not necessarily Whole word. These 
characters are combined to form the Options argument. 

Example, Find Next "business" "iw", finds the word business 
with Ignore Case (i) and Whole Word (w) on. The instruction Find 
Next "\r\r" "g-—W-w", searches through to the end of the current 
document for the PowerSearch+ pattern \r\r (two carriage 
returns). Here g means: PowerSearch+ pattern. The find pattern is 
interpreted as a regular expression which matches two consecutive 
return characters. The option -W means Wrap Around is off and -w 
means Whole Word is off. 

Find Next "Find Pattern” 

If the Options argument is omitted then the search options are those 
listed in the section Default Options, page 419 in this chapter. 

Find Next "x" "*Options" 

If the Options argument is present and the first character in that 
argument is the asterisk (*), the options will be those set in the 
Find /Replace dialog plus those set by any other arguments you insert 
following the asterisk. 

Find Next “Find Pattern" “Options" "Windows" 
The first argument Find Pattern can be any regular expression or 
literal text that does not include a return character. The second 
argument Options, if present, is a sequence of characters each of which 
is an abbreviation for a search option. The third argument Windows 
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can be any open document (type the name of the file as it appears in 
the Title Bar). 

Find/Replace 

Syntax: 
e Find/Replace 
¢ Find/Replace "Find Pattern" "Replacement Pattern" 
¢ Find/Replace "Find Pattern" "Replacement Pattern" "Options" 
e Find/Replace "Find Pattern" “Replacement Pattern" '* Options" 
« Find/Replace "Find Pattern" "Replacement Pattern" "Options" 

"Windows" 

Find/Replace 

This instruction brings up the Find/Replace dialog. 

Find/Replace "Find Pattern” “Replacement Pattern” “Options” 

The arguments Find Pattern and Replacement Pattern can each be either 
a regular expression or any literal text. They can also be font, size 
and style sensitive; just select the pattern, set the attributes from the 
appropriate menus, and put the appropriate letters in the "Options" 
argument. The Options argument sets the search options as described 
in the Find Next instruction. For better readability, you may place 
the word with between the find and replacement patterns. Thus the 
instruction: 

Find/Replace "this" with "that" "-g-Awa" 

finds all occurrences of the word this and replaces them with that. Do 
not forget the spaces before and after the word with. 

Find/Replace "Find Pattern” "Replacement Pattern” 

When the "Options" argument is omitted, the search options are those 

listed in the section Default Options, page 419 in this chapter. 

Find/Replace "Find Pattern" “Replacement Pattern" “Options” "Windows" 
The arguments Find Pattern and Replacement Pattern can each be either 
a regular expression or any literal text. They can also be font, size 
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and style sensitive; just select the pattern, set the attributes from the 
appropriate menus, and put the appropriate letters in the "Options" 
argument. The Options argument sets the search options as described 
in the Find Next instruction. The fourth argument Windows can be 
any open document (type the name of the file as it appears in the 
Title Bar). 

Search Options 

The "Options" argument in the Find Next, Find / Replace ,Find All, 
Find in Selection, Replace Word, Replace All and Replace in Selection 
instructions is optional. It is used to set the search options. Each 
search option is represented by a letter. These letters are combined 
inside a pair of double quotes to form the Options argument. They 
can be placed in any order. 

The search options which can be included in the Options argument: 

a Replace All 
A or W Wrap Around 
-A or -W Not Wrap Around 
Cc Place text in the Find/Replace dialog (no search or 

replace operation is performed) 
e PowerSearch pattern 
E Jump to end of document if search fails 
g PowerSearch+ pattern 
“€ OF -g Find Literal 
G search all open documents 
-G Search front document only 
i Ignore Case 
I Index mode (instead of replacing) 
] (lowercase L) Replace All in the current selected 

paragraphs 
M orm Use the Search List 
-M or -m Search active document only 
n Select last text changed after a Replace All within the 

current selection. This option is ignored if neither s 
nor ] are used. 
Find Text Only (not attribute sensitive) 

“0 Find is attribute (font/style) sensitive 

= 
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Oe oO 

< I 

-w 

WorA 

-W or-A 

Replace Text Only 
Replace is attribute sensitive 
Search toward beginning of document (in reverse) 
Replace All in current selection 
Avoid dialogs (Terse). When search fails, no dialog 
1S given, 

Terminate the current macro if the search fails 
Display the number of substitutions after a Replace 
All (Verbose) 
Whole Word 
Not Whole Word 
Wrap Around 
Not Wrap Around 
Use with Find Next to copy the full path names of 
all files on the search list which contain the given 
find pattern, onto the Clipboard. Including this 
argument temporarily turns on multi-file search 
unless it is followed later by -M. 
Use the search options currently set in the 
Find/Replace dialog (must be first if present) 

A search option is turned on or off for each Find Next or Find / Replace 
instruction used. After the macro instruction has been executed, each 
option returns to its previous state. In other words, the search options 
in a macro do not set the search options of the Find/Replace dialog 
or the Searching menu, unless the C argument is used. For example, 
the instruction: 

Find/Replace "Find Text" "Replace Text" "*Cw-G" 
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Uses the search options currently set in the Find/ Replace 
dialog (*) 
Copies Find Text to the Find box and Replace Text to the 
Replace box without finding/replacing or bringing up the 
Find /Replace dialog (C) 
Turns on Whole Word (w) 
Chooses Search Front File (-G) 
The dialog reflects the text entered and the options changed 
because "C” is present in the arguments. 
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Default Options 

The same default options apply to the macro arguments as to the 
Find/Replace dialog. If a search option in the Options argument is 
not present, or the asterisk (* ) is not the first character in the options 
list, Nisus uses the default settings. The default settings of the 

~  Find/Replace dialog are: 

Wrap Around on 
Find literal text 
Search front document only 
Ignore Case is on 
Search forward toward end of document 
Whole Word Off 
Find and Replace is not attribute sensitive 
Terse (number of substitutions dialog is not displayed unless 
the pattern couldn't be found.) 

You can use the current state of the search options in the Find/ Replace 
dialog and the Searching menu, by placing an asterisk as the first 
search option. You may override some of the current settings in the 
Find /Replace dialog by adding more options after the asterisk. For 
example, FindNext "text" "*-w" will find text using the current 
settings in the Find/Replace dialog, but with Whole Word turned 
off. 

ts” To reset the search options in the Find/Replace dialog back to the 
default settings and clear both the Find box and the Replace box, use 
the following instruction: 

Find/Replace the oat Ht wee 

Multi-File Search 

To learn the basics of multi-document search read Searching Multiple 
Documents, page 212 in Chapter 5: Finding and Replacing Text. You 
might find the following instructions useful in multi-document 
searches. 
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Find Next "" "XK" 
Appends the full path names of all the files in the search list (the 
ones marked with an eye icon in the Catalog window) onto the current 
clipboard. In this case no searching is performed, and after this 
instruction is executed the files are removed from the search list. 

Find Next "Topic” "X" 
Searches through all files on the search list for any text Topic and 
then appends the path names of all files containing the text Topic to 
the current clipboard. Note that no windows are opened during the 
search. 

Find Next "" "X-MG" 
Appends the path of all open files onto the current clipboard (files 
need not be on the search list). Note that the path of the front-most 
file is appended twice, once at the beginning of the list and once at 
its end. 

Find Next "" "X-M-G" 

Appends the path of the front-most document to the current clipboard. 

ts" You can save and restore the search list using the supplied macros 
Save Search List and Restore Search List. You can open the 
file Macros for Editing and edit these macros to suit your needs. 
Read the Nisus Macro Language: Programming Dialect pamphlet for 
more details. 

Jump 

Syntax: 
¢ Jump 
¢ Jump "Marker Name" 
¢ Line "Line Number" 
° Page "Page Number" 
¢ Line "Starting Line Number' “Ending Line Number" 
© Jump "Start Marker" "End Marker’ 
¢ Jump “Line Number" "Marker Name" 
¢ Jump "Marker Name" 
¢ Jump "Line Number" 
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° <PJump "Marker Name" 

¢ “PLine “Line Number" 
¢ <Page "Page Number" 
° “SJump “Marker Name” 

The Jump instruction may take zero, one, or two arguments. 

Jump 

This instruction brings up the Jump dialog. 

Jump “Marker Name" 

This instruction moves the insertion point to the location of the marker 
Marker Name. Thus the instruction, Jump "Over there", moves the 
insertion point to the location of the marker Over there. If there is 
no such marker in any open file, this instruction does nothing. 

Jump “Line Number" 

For example, Jump "120", moves the insertion point to the beginning 
of line 120. If the document contains fewer lines than 120, this 
instruction moves the insertion point to the end of the file. 

Jump “Starting Line Number" "Ending Line Number” 
For example, Jump "3" "12", selects the text from the beginning of 
line 3 to the beginning of line 12 (and does not include line 12 in the 
selection). 

Jump “Line Number" "Marker Name” 
For example, Jump "3" "mark this", selects the text from the 
beginning of line 3 to the location of the marker mark this. 

Jump “Start Marker" “End Marker” 

For example, Jump "life" "death", selects text between the two 
markers life and death. 

ts” The word END is a predefined marker which designates the end of 
text. Thus, Jump "5" "END" selects the text from the beginning of 
line 5 to the end of the file. To jump to the beginning of text usc 
Jump "1". 
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“Jump "Line Number” 

If 4 precedes Jump as in, sump "3", the resulting instruction 
selects the text from the current position of insertion point to the 
beginning of line 3. 

NS Jump “Marker Name” 

if SS precedes Jump as in, “S Jump “over there ", the resulting 
instruction deletes the marker over there. 

Mark Text... 

Syntax: 

© Mark Text... “Marker Name’ 
e Mark Text... "Start Marker" “End Marker" 

Mark Text... "Marker Name” 

Places a marker called Marker Name at the insertion point or selection. 
Thus, Mark Text... "I love this", places the marker | love this at 
the insertion point or selection. 

Mark Text... “Start Marker" “End Marker" 

Piaces two markers one called Start Marker at the beginning of the 
selection and another called End Marker at the end of it. Thus, 

Mark Text “begin here" "end there" 

places the marker begin here at the beginning of the selection and the 
marker end there at the end of it. 

Double Quotes inside Arguments 

To use double quotes inside any quoted arguments, you must double 
the quotes. For example, to find: 

“Do you have the money?" He asked. 
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use this instruction: 

Find Next """Do you have the money?"" he asked." 

single Quoted Arguments 

If an argument is in single quotes in a macro instruction it is evaluated 
as a replacement expression before the instruction is executed. For 
example, in the following macro instruction: 

Find/Replace "\CC' "Bar" Ao a 

"\CC' means “contents of the current clipboard” and because it is in 
single quotes the expression is evaluated and becomes whatever is in 
the Clipboard. Because "g" means searching for a PowerSearch+ 
pattern, the contents of the Clipboard are interpreted as a regular 
expression and the matched text is searched for and replaced with 
Bar. The final result is that whatever regular expression is in the 
Clipboard, it is searched for and replaced with Bar. 

Suppose that F.. is copied onto the Clipboard. When the macro 
instruction Find/Replace '\CC' "Bar" "g", is evaluated, it 

becomes Find/Replace"F.." "Bar" "g". The resulting instruction 
is then executed and all occurrences of words such as Fly, Far, Fat, 
Fun and Fan are replaced with the word Bar. 

Single quoted arguments can be useful with the Copy or Paste 
instructions. For example, the macro instruction Copy "2" '\CC' 
copies the contents of the current clipboard onto Clipboard 2. Similarly, 
the macro instruction Copy "6" '\C9' copies the contents of 
Clipboard 9 onto Clipboard 6. 

Another useful trick is to include metacharacters in the argument, 

such as Paste "" 'Text\rMore text'. The metacharacter \r is 
first evaluated as a return character and then the resulting text in 
between single quotes is pasted at the insertion point or selection. 

Ks You can put return characters in arguments by preceding each return 
with a backslash (\). This causes the argument (quoted text) to continue 
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on the next line. The return character may also contain a ruler, as 
described below, and this procedure is effective with both single and 
double quoted arguments. 

Rulers in Macro Arguments 

You can include rulers inside the quoted text in a macro argument. 
For example, to paste a ruler at the insertion point create a new 
macro and follow these steps: 

1. Type Paste "" "\ 
2. Press Return. 

3. Choose Insert Ruler from the Format menu (Make sure 
the rulers are shown). 

4. Select the Paragraph Ruler and make changes to the Master 
Ruler. 

2. Type the closing quote " . 

Nisus Macrase 

Figure 14-3 A Paste instruction with a ruler inside tt the araiich 

Figure 14-3 shows what you may see in your macro file. When this 
macro ts executed a return character followed by the new ruler is 
inserted at the insertion point or the selection in the active document. 
Note that line wraps and tabs defined in the macro are relative to the 
left margin limit (gray region). Therefore when a ruler is inserted 
from a macro into the document, the relative distances between the 
left margin limit and the other parameters of the ruler are preserved. 
If the right margin is outside the document margin limits it is moved 
in. Some tabs may spill outside. 
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Another useful macro instruction which may include a ruler inside 
its argument is the Copy instruction. Follow similar steps to the 
previous macro. 

Ite You can create a variety of different macros that paste different named 

_ 

or unnamed rulers, such as Insert Pointer Ruler, Insert Bullet Ruler, 

etc. In script writing you might have different rulers (with appropriate 
text formatting) for stage directions, and different characters. 

Working with Other Menu Commands 

The macro instructions mentioned up to this point can take arguments. 
Those which follow do not. To use a menu command in a macro 
simply type its name on a separate line. For example, the following 
macro instructions select all the text in a document and change the 
font to Chicago and the style to bold: 

Select All 

Chicago 

Bold 

You can also call a menu command by using its item number. For 
example the instruction File: 3 executes the third menu command in 
the File menu (brings up the Catalog window). 

Working with Desk Accessories 

You can call a desk accessory and also access its menu commands. 

Here is a macro which copies the time and date from the Rlerm 
Clock to Clipboard 0. 

Alarm Clock Open the Alarm Clock 
Copy "0" Copy time and date to Clipboard 0 
Close Close the Alarm Clock 

The following macro performs a simple calculation. It uses the 
Calculator desk accessory to add the number in Clipboard 0 to the 
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one in Clipboard 1 and put the result in Clipboard 2. To try this, 
copy one number onto Clipboard 1 the other onto Clipboard 2. 

Calculator Bring Calculator to front 
Key C Clear the Calculator 
Paste "Q" Paste the first number into the Calculator 

Key + Type the + key 
Paste "1" Enter the second number 

Key = Get the answer 

Copy "2" Copy the answer into Clipboard 2 
Close Close the Calculator 

is” Note that if you have installed Macro Maker™ in your system then 
you can run both Nisus macros and macros generated by Macro 
Maker as long as there is no conflict in the names. You cannot call 
the macros of Macro Maker from Nisus macros and vice versa. Some 
menu commands in Nisus are actually built-in macros. When you try 
recording these in the Macro Maker they do not play back properly. 
The following menu commands are built-in macros, which cannot be 
used by Macro Maker: 

¢ Break Lines 

e Copy to Find 

e Insert Page Break 

« Move Left 

* Move Right 
e Zap Gremlins 

Turning Menu Commands On or Off 

Syntax: 

¢ Menu Command "On" 

¢ Menu Command “Off' 

Menu Command stands for any menu command which can be turned 
on or off. On means that the command is to be checked and Off 
means the command is to be unchecked. Menu commands that change 
their states from on to off and vice versa are called toggle commands. 
The toggle commands which allow this are: 
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« Show Clipboard 

« Keep On Same Page 

® All the commands in the Display submenu (except for Line 

# Prefs...) 

For example, the macro instructions: 

Space, Tab & 97 "On" 

Line Numbers "Off" 

display the white space characters and turn off display line numbers 

while the instructions: 

Master Ruler “On" 

Info Bar "Off" 

show the Master Ruler and hide the Info Bar. 

Looping and Accessing Other Macros 

Macros can access other macros by name. They can also access 

themselves. A macro accessing itself is called a looping macro. A 

macro continues to loop until you stop it (with Command-Period) or 

when you include a Find Next, a Find/Replace, a Find All or a Find 

in the Selection instruction with the T option. The T option terminates 

the macro when a search fails. When using Command-Period to stop 

a macro, all macros are stopped. If a macro is stopped with the T 

option in Find/Replace, only the currently running macro is stopped. 

Macros which invoke the current macro proceed normally. 

A macro can invoke any other macro which is in the currently loaded 

macro file, that is any macro that appears in the Tools menu. Invoking 

one macro from within another is like executing any other menu 

command. Write the name of the macro to be invoked on its own 

separate line in the accessing macro. 
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Example: Rolling Characters 

To create a macro that “rolls” three characters, that is, one that turns 
abc into bca, or cat into atc, use the Swap Char macro which is 
described in Recording Macros, page 390. Rolling characters can be 
seen as two successive Swaps, where abc becomes bac and then bea. If 
you put the insertion point immediately before the letter a in abc, and 
then choose the Swap Char macro, it would swap a and b, but the 
insertion point would remain to the right of b. So, to swap b and, it 
is necessary to move the insertion point back one character before 
calling Swap Char again. 

Nisus allows you to move the insertion point back one character by 
using the left arrow key or typing Command-Backspace or Command- 
Delete. The “roll” macro looks like this: 

Swap char 

Key #€& 

swap char 

To create this macro follow these steps: 

1. Choose Record from the Macros submenu. 
2. Choose Swap Char from the Macros submenu of the 

Tools menu (assuming that it is present in the loaded macros 
file menu). 

3. Press Command-Backspace to move the insertion point one 
character to the left. 

4. Choose Swap Char again. 
5. Choose Stop Recording... from the Macros submenu 

of the Toots menu. 
6. When the Macro Name dialog appears on screen, type the 

name of the macro (For example, Roll Chars) and press 
Name J. Return or click 

The current macro file is displayed on screen showing the recorded 
instructions under the macro name provided. Note that the Command- 
Backspace appears as 3 € . 
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Alternatively you can create this macro as follows: Choose New 
Macro... from the Macros submenu of the Tools menu. Type the 
name Roll Chars into the naming dialog and press Return or click 
{ Name } . Type the macro instructions listed above into the macro 
editing window. To enter the backspace and the Command “3%” 
characters, choose ASCII Table... from the Edit Tools submenu of 
the Tools menu, double-click on a backspace (ASCII 8) character 
and a clover (ASCII 20) character and they will paste into your macro 
file at the insertion point. Choose Save and Close from the File 
menu to close the window. 

Useful Editing Commands 

Nisus offers many editing facilities which may be useful in macros. 
In order to accomplish these commands, all keys indicated need to 
be press simultaneously. 

To move the 
insertion point... Press... 

left one character Command Backspace (or Left Arrow) 
right one character Command Space (or Right Arrow) 
left one word Command Option Backspace 

(or Option Left Arrow) 
night one word Command Option Space 

(or Option Right Arrow) 
up one line Up Arrow 
down one line Down Arrow 
to end of paragraph 

(non repeating) Command Right Arrow 
to beginning of paragraph 

(non repeating) Command Left Arrow 
to beginning of 

previous paragraph §= Command Enter 
to beginning of next 

paragraph Command Return 
to top of window Command Up Arrow 
to bottom of window Command Down Arrow 
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To extend the 
selection... 

left one character 
right one character 
left one word 
right one word 
up one line 

down one line 

beginning of 
previous paragraph 

beginning of 
next paragraph 

To delete... 

a character to the jeft 
a character to the right 
one word to the left 
one word to the right 

To... 

bring the selection or 
insertion point into view 

select text to end of 

paragraph 

select text to beginning of 
paragraph 

Press... 

Command Shift Backspace 
Command Shift Space 
Command Option-Shift Backspace 
Command Option-Shift Space 
Command Shift Up Arrow 
(or Shift Up Arrow on a new keyboard) 
Command Shift Down Arrow 
(or Shift Down Arrow on a new keyboard) 

Command Shift Enter 

Command Shift Return 

Press... 

Backspace 

del’ or Right Arrow then Backspace 
Option Backspace 
Option del or Command Shift Option 
Space then Backspace 

Press... 

Enter 

Command Option Shift Return. 

Command Option Shift Enter. 

‘Note that the del key is only available on the extended keyboards 
and its action is not recorded in a macro. 
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Display Dialog Box 

Syntax: 
e :1 "Message" 
* :1 "Message" “text in edit box" 

‘1 “Message” 

This instruction pauses execution of the macro, displays a dialog 
with the quoted message and resumes execution when you click 

[_oK J. For example, the instruction :1 "Hello World" displays 
a dialog box with the message Hello World. When this instruction is 
executed the dialog illustrated in Figure 14-4 is displayed on your 
screen. 

Hello World 

Figure 14-4 A dialog box displayed from a macro 

Click {0k J or press Return to resume the macro. Displaying 
dialog boxes with messages is helpful in testing macros. It is 
particularly helpful when the macro being executed is long and you 
want to know exactly when a particular instruction is being executed. 

st of 1 “Message” “text in edit Box” 
You can also display a dialog which includes a text edit box. To do 
this include a second argument in the : 1 instruction as in: 

-1 “Howare you?" "Fine, thank you!" 

When this instruction is executed the following illustrated in Figure 
14-5 is displayed on your screen. 
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Figure 14-5 A dialog with a text edit box displayed from a macro 

The user of the macro can then type any text into the dialog box. If 
you want the dialog to appear with the text box empty, include no 
text between the second set of quotes. When the user clicks [ 0K | 
the text typed in the text edit box is copied to the current clipboard. 

Ke The clipboard is not updated if it is the front-most window showing. 

Automatically Executed Macros 

The following macro names are special reserved names. Macros using 
these names are automatically executed on the occurrence of certain 
events. Name your macro one of these and it will get executed on 
these specified events. 

The macro Name...is executed when you... 

Command press and hold down Command while 
double-clicking. (This defaults to Copy 

to Find unless you write your own 
macro.) 

CommandOption press and hold down Command Option 
while double-clicking. 

Option press and hold down Option while 
double-clicking. 

InitOpen open a document. 
Initinit start Nisus. It must be in the Nisus Macros 

file which must be present in the System 
Folder or the same folder as Nisus. It is 
also executed when you load the macro 
file which contains it. 
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initRevert choose Revert To Saved from the File 
menu. 

InitNew open a new file. 
Switchin enter NisuS from the Switcher or 

MultiFinder. 

1 These macro names are not case sensitive. Nigus makes no distinction 
between upper or lowercase in macro instructions in the Menu 
Command Dialect or macro names. 

Nisus has a built-in Command macro that copies the selection to the 
Find/Replace dialog. If you press and hold Command while double- 
clicking on a word, it will be copied to the Find/Replace dialog. This 
is similar to selecting a word and then choosing Copy to Find. If 
you want to select and copy more than one word to the Find / Replace 
dialog, press and hold Command, double-click on the first word of 
the text and do not release the second click until you have dragged 
the mouse to the last word of the selection. Releasing the mouse 
triggers the macro and copies the selection into the dialog. The presence 
of your own Command macro overrides this built-in macro. 

Similarly, you can write a CommandOption macro that adds a selection 
to the index. Create a new macro and name it CommandOption, 
then type the following macro instruction: 

Mark Index 

To add an entry to the index hold down both Option and Command 
while double-clicking to select text. When you release the mouse the 
selection is entered in the index. 

similarly you can write an Option macro which adds an entry to the 
table of contents. The Option macro should have the instruction: 

Mark Contents 
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Advanced Examples 

Text selection 

Selecting text by clicking and dragging the mouse cannot be recorded 
in Nisus, but it can be done in conjunction with a Find Next instruction 
as follows: 

—" . Set a temporary marker at one end of the text to be selected. 
. Place the insertion point at the other end of the text. 

3. Choose the marker from the Jump To submenu of the Tools 
menu with the Shift key held down. This selects the text 
Starting at the insertion point to the marker. 

ho 

Here is a sample macro that uses the Jump instruction to select text 
between There was and ever after: 

Find Next "There was" 

Mark Text... "Begin" 

Find Next "ever after" 

Key % (space) 
<P gump "Begin" 

NS Jump “Begin” 

The first Find Next instruction finds There was. The instruction Mark 
Text... marks the beginning of the selection with the marker Begin. 
The second Find Next instruction finds the end of the selection. The 
instruction “Key 9” is equivalent to typing Command-Return. It moves 
the insertion point to the start of the next line. The instruction 4} sump 
“Begin" moves the insertion point back to where the marker was 
placed. The Shift key is held down, as indicated by the <? symbol, 
and the jumped over text is selected. The Option key is held down, 
as indicated by the NS symbol and the instruction SS Jump "Begin” 
removes the marker Begin. 
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Find an address 

This macro searches the active document for an address which is 
written in the form shown below and copies it to the current clipboard. 
Create a new document and type a few addresses. Separate the 
addresses by a blank line. Leave a blank line at the beginning of your 
address list. Make sure you type the addresses in the following form: 

Paragon Concepts 

990 Highland Drive Suite # 312 

Solana Beach CA 92075 

(619) 481-1477 

The zip code can be in either 5 digit or 9 digit form. Now create a 
new macro and type the following instructions: 

Find Next ":u:u\st+:d:d:d:d:d\ (\s*\--\s*:d:d:d:d\)-" 
"g-AtT-w" 

Find a State followed 
by a Zip code 

Key # Type Command-Return 
Mark Text... "ZZ2End" Set marker 
Find Next "\r\rf:s\r" "-ATtg-wr" Find blank line 
Key $ Type Command-Space 
“Poump "ZZEnd" Select text between the 

insertion point and the 
marker 

Copy Copy address 
“SJ ump "ZZEnd" Delete marker 

The comments lines are included here for clarity. The first Find Next 
instruction searches for the text that matches the following regular 
expression: 

surulstid:d:id:d:d\ (\s*\--\s*:d:id:id:d\)- 

:uz:u\st+ matches two uppercase letters 
followed by any number of spaces. 
It matches a state such as CA, AZ 
and so on. 
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sd sdediacd matches a sequence of 5 digits of a 
zip code such as 92075 

\ (As*\--\s*:d:d:d:d\)- matches zero or one occurrence of 
whatever \s*\--\s*:d:d:d:d 
matches. 

\S*\== matches zero or more spaces 
followed by zero or one dash. 

\s*idedsded matches zero or more spaces 
followed by a sequence of 4 digits. 
This matches the optional 4 digit 
extension of the zip code. 

The instruction Key 9 (no space after the Command symbol) is 
equivalent to typing Command-Return. It moves the insertion point 
to the start of the next line. The instruction Mark Text... marks the 
end of the address with ZZEnd. The second Find Next instruction 
searches backward (the search option r) for two consecutive return 
characters (\r\r) or the beginning of document (: s). The instruction 
“Key % " (with a space after the Command symbol) is equivalent to 
typing Command-Space. It moves the insertion point to the end of 
the selection. The selection point is now at the beginning of the address. 
The instruction <Jump "Z2End" moves the insertion point back to 
where the marker ZZEnd was placed. The symbol 4? indicates that 
the Shift key is held down while choosing Jump. In essence the text 
between the current position of the insertion point and the marker 
ZZEnd is selected. The Copy instruction copies the address onto the 
current clipboard. Finally the instruction ‘S Jump "zZEnd" removes 
the marker ZZEnd. 

Smart quotes 

To change all double quotes in expressions such as "The Leader of 
the People" to smart quotes as in “Over the Bounding Waves” search 
for \<" (quotes at the beginning of a word, presumably opening 
quotes) and replace it with“. Then search for \>" (quotes at the end 
of a word, presumably ending quotes) and replace it with” . Do the 
same for single quotes, except that single quotes at the end of numbers 
have to be excluded. They are presumed to designate the foot 
measurement symbol. A single quote followed by another single quote 
has to be excluded as a likely inches measurement symbol. Replacc 
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all remaining single quotes not preceded by a digit or another single - 
quote with the closing single smart quote to account for the apostrophe. 
The macro consists of the following instructions: 

Find/Replace "\<"n" "°" "“g-waAg" 

Find/Replace "\>rt ow" wa-wag" 

Find/Replace ":<[*']\<'™ "" "“a-wAg" 

Find/Replace ":<[*'Q-9]\>!'"™ "™ “"a-waAg" 

Find/Replace. *<<[*'0-9) %2> (79°) " “"" “a=waAg" 

The last find pattern matches a single quote not preceded by a digit 
and not followed by a single quote. This macro is not foolproof. It 
will not replace quotes correctly around expressions which are not 
usually parts of a word such as "-" or ‘+’. To correct for this the 
beginning of word metacharacter (\<) is replaced by the user defined 
wild card: :<{\s\r\t ({{] which translates to “the preceding 
character is a space, return, tab, or any of the opening brackets or 
parentheses.” Therefore the resulting instruction: 

Find/Replace td :< (\s\r\t { ( { ] sete ue pe yy "“a-wAgt $1 

replaces any double quotes preceded by a space, a return, tab, left 
parenthesis, brace or bracket, with smart opening quotes. While the 
instruction: 

Find/Replace wturtess§ 8 6¢t™* a¢ “a-wAgt" 

replaces all remaining double quotes with smart closing quotes. 
Similarly, the following instruction is used to replace single opening 
quotes with smart ones: 

Find/Replace ":<[\s\r\t(({]'" ™ “a-wagt" 

and the instruction: 

Find/Replace ":<[*'0-9)\>'" "’" “a-wagt" 

replaces closing quotes which are not preceded by a digit or a single 
quote with closing single quote. Finally the instruction: 
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Find/Replace ":<[*'0-9]':>[*']" "'" “a-wAgt" 

replaces the remaining single quotes not preceded by a digit 
(apostrophes) with closing single quotes. This macro is included with 
the supplied file Macros for Editing. 
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15 
Customizing Nisus 

Nisus comes with preset values called default settings. After you 
have worked with Nisus for a time you may find that you want to 
establish your own file containing personal Preferences when using 
the program. 

For example, you may write a lot of new documents and so would 
prefer to have Nisus open a new untitled document immediately 
when it starts up. The default settings are set so that the Catalog 
window opens when you start Nisus. You can change this and have 
a new file open at start up by using the Start Up... command on 
the Preferences submenu in the File menu. 

If you want the preference changes to be remembered the next time 
you use Nisus, choose Save Preferences from the File menu 
before quitting. If you quit without saving the preferences, Nisus will 
ask you if you want to save them. Choosing Revert will always set 
the Preferences back to the preset default values. 

When you save preferences, Nisus creates a file called Nisus Preferences 
3.0, in the System Folder. You can have several such sets of preferences 
saved but only one can be used at one time. To use a different 
preferences file, remove the old one from the System Folder (or rename 
it) and replace it with the new one, and rename it Nisus Preferences 
then restart Nisus. 

The Nisus Preferences 3.0 file in the System Folder is not shown 
checked (in the Catalog) when it is loaded. Do not load more than 
one preference file at a time because you might get conflicting results 
such as two menu commands being assigned to the same key. 
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Program Preferences 

Program preferences will affect all documents, whether or not they 
are currently open. The Preferences submenu is in the File menu. 

New File Preferences 

There is no preference dialog for new files because this feature is 
presented in a much more powerful way using a special stationery 
file called “Nisus New File.” 

When you choose New from the File menu, Nisus looks for the file 
Nisus New File, in the same folder as Nisus and in the System Folder. 
When it is found it automatically opens a file with the name Untitled, 
and all the settings (such as rulers, font size and style as well as any 
text) appear the way they were saved. If the file is not found, an 
empty document with the name Untitled, is opened with the font 
settoPlain 12 point Geneva and with no ruler settings. 

Nisus New File gives you control over the font, size, and style of the 
text as well as the local preferences described in this chapter. For 
more information on the Nisus New File, see page 65 and check the 
index to see what other attributes can be associated with your New 
File. 

Ks” You can also create an InitNew macro to set the font, size, style, 
and do anything else you want when a new document is created. 
This macro is executed whenever New is chosen. Read the section 
on Automatically Executed Macros page 432, for more details on how 
to create this macro. 

Revert 

Reverts all your preferences to those originally supplied with Nisus. 
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Start Up Preferences 

These preferences, illustrated in Figure 15-1 determine whether the 
Catalog, Clipboard, and new document windows are opened when 
Nisus is first opened. 

Start Up Preferences 

*xC Xj Show Catalog At Start Up 

NIX) Open New File At Start Up 

%UK)] Name New Files “Untitied” 

*S[) Show Clipboard At Start Up 

Figure 15-1 Start Up Preferences 

When you open a new file, it is named Untitled. To be prompted 
for a file name instead, uncheck this option in the dialog box. 

saving Files Preferences 

It is important to save your document frequently. If you choose Save 
then change your mind, choosing Revert To Saved from the File 
menu will not bring back the previous document because Saving 
replaces the previous version with the current version. 

Save .bak Files 

You can, however, have Nisus rename the last version automatically 
before the current version is saved to disk. You will then always 
have your work from the last two saves available. To back up your 
document automatically before every save, check the Save .bak 
Files option in the dialog box illustrated in Figure 15-2. Whenever 
you save your document, the file on disk will be renamed by appending 
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.bak to the document name. You can see the previous version of your 
document by opening this file. 

Saving Files Preferences 

%*B IX) Save .bak Files 

%*K(_) Save Rfter Every Key Strokes 

*S(L) Secondary Disk Save 

Specify a Disk & Falder 
Where the Secondary 
Backup is ta be Saved: 

—Nisus HD 45 
€& Documents Folder 

my EC Eject) © Fant Docs 

© Misc. Docs. 

© Nisus Docs 

© Pref Folder 

Figure 15-2 Saving Files Preferences 

Auto Save 

Sometimes, you may forget to save your document. You can have 
Nisus save your document automatically after a certain number of 
keystrokes. Check the Save After Every[ _] Key Strokes 
option to turn it on and set the number of keystrokes between saves. 

secondary Disk Save 

For safety, you may wish to save your document on two disks at the 
same time. Whether you choose Save, or Nisus saves automatically, 
the Secondary Bisk Save option will cause your document to be 
saved in two places. The first place is always in the current directory. 
The second place is in the folder whose name appears above the 
scroll list in the Saving Preferences dialog illustrated in Figure 15-2. 
The document will be saved with the same name in both folders. 
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Editing Preferences 

The Editing Preferences dialog, illustrated in Figure 15-3 allows you 
to customize the way text is handled in your editing window. 

Editing Preferences 

K) intelligent Cut and Paste 

[) Enable Fractional Font Spacing 

[) Use MacWrite Clipboard 

[} Auto indent 

Auto Indent Modes: 

CL] Remove Trailing Blanks When Typing 
C) Remove Leading Blanks When Typing 

Maximum Number Of Undos = 

Figure 15-3 Editing Preferences 

Intelligent Cut and Paste 

Intelligent Cut and Paste is convenient for moving words. When 
this option is checked, and you double-click on a word to select it 
and then choose Cut, the space preceding this word is also deleted. 
When you Paste, the extra space will be inserted only if the insertion 
point is placed next to another word. Consider the sentence: 

I want you to just check my spelling. 

To move just before want, perform the following steps while referring 
to Figure 15-4. 

1. Double-click on the word just. 
2. Choose Cut. 
3. Place the insertion point before want. 
4. Choose Paste. 
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I want you to check my spelling. 

I }want you to check my spelling. 

I just jwant you to check my spelling. 

Figure 15-4 Using Intelligent Cut and Paste 

The extra space is removed during Cut and inserted during Paste. If 
just is pasted in between the characters of another word while 
intelligent cut and paste is on, spaces will be inserted on both sides 
of it. If the insertion point is placed after the C in “not ABCDEFG” 
the result will be “not ABC just DEFG.” 

Enable Fractional Font Spacing 

Check Enabie Fractional Font Spacing to use the fractional 
font spacing information stored with PostScript fonts. This aligns the 
characters on an internal grid which is more precise than that of the 
screen. When the characters are displayed on the screen, they are 
aligned on the nearest pixel. This may cause your text to look irregular 
on the screen, but overall, the characters reflect more accurately their 
position in the printed document. It is best to have this option turned 
off when sending output to low resolution devices such as the 
ImageWriter, and to have it on when sending it to high-resolution 
devices, such as a PostScript printer. 

Use MacWrite Clipboard 

The Use MacWrite Clipboard option allows you to use the 
MacWrite Clipboard format. Use this option when moving formatted 
text between Nisus and other word processors which support the 
MacWrite Clipboard format. This will enable you to retain the format 
and attributes of your text which are understood by MacWrite. 
Otherwise, only the text will be preserved. 
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Auto Indent 

Automatic indentation indents the next paragraph the same amount 
as the current paragraph. This is helpful for entering text in columns. 
Indent before typing the first item in the column and Nisus will 
indent the same amount when you press Return. 

Remove Trailing/Leading Blanks When Typing 

When these preferences are checked, unnecessary spaces can be 
removed from the beginning and end of a paragraph when you press 
Return. Remove Trailing Blanks When Typing will also remove 
trailing spaces when you press Tab. These features should be turned 
on only if you are using Auto Indent and are using Nisus to do a lot 
of column entries. These features do not work when Auto Indent is 
not on. 

Undo List Length 

Initially, the maximum number of undos is set at 300. If you need 
more or less than this, you can specify a number from 1 up to 32,767. 
Set the maximum number of undos to a smaller number to conserve 
memory. 

Searching Preferences 

The Searching Preferences dialog shown in Figure 15-5 allows you to 
change the start up settings of the Find/ Replace dialog. 

CUSTOMIZING NISUS 445 



Searching Default Preferences 

&) ignore Case 

(J Whole Word 

{) Wrap fround 

Mode: 

@® Normal 
© PowerSearch 
© PowerSearch+ 

(C2 Skip “Text Not Found” Dialog 

Figure 15-5 Searching Preferences 

You can specify which search options (Ignore Case, Whole Word, 
Wrap Around) are on and which are off when you first start the 
program. You can set the initial mode of the Find/Replace dialog to 
Normal Search, PowerSearch or PowerSearch-+. In addition, 
you can turn off the message displayed when the search is unsuccessful. 
Note that if the Skip “Text Not Found” Dialog option is checked 
and text is not found Nisus beeps. Chapter 5 explains the Find / Replace 
dialog in more detail. 

scrolling Preferences 

The Scrolling Preferences dialog, illustrated in Figure 15-6 gives you 
control over automatic scrolling in both directions and the maximum 
scrolling speed. 

446 
CHAPTER FIFTEEN 



Scrolling Preferences 

1 {J Auto Horizontal Scrolling 

¥%2 (J Auto Vertical Scrotiing 

%3() Scroli To Keep 36 Pixels In View 

#4) Show Horizontal Scroll Bar 

Maximum Scroll Speed = 12-Point Lines 

Figure 15-6 Scrolling Preferences 

Automatic Scrolling 

The automatic scrolling control applies only to bringing the current 
insertion point into view while typing beyond the edges of the editing 
window. Note that when you select text and drag with the mouse, 
automatic scrolling will still occur whether or not auto scroll options 
are checked. 

Keep 36 Pixels in View 

Keeping 36 pixels in view applies to automatic scrolling in both 
directions. If automatic scrolling is turned off, it has no effect. 

Horizontal Scroll Bar 

Hiding the horizontal scroll bar removes it from view. This has no 
effect on automatic horizontal scrolling. 
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Maximum Scroll Speed 

The maximum scroll speed is specified as the number of lines. When 
you scroll up or down using the scroll bar arrows, at most that many 
lines are scrolied. Initially, one line is scrolled at a time, but as you 
hold down the mouse button the scroll speed increases until the 
maximum scroll speed is achieved. 

Measurement Preferences 

The Measurement Preferences dialog illustrated in Figure 15-7 deals 
with the ruler dimensions and the information bar display of the 
insertion point position. 

Measurement Preferences 

Measure in 

@® Inches 
m ES O Centimeters 

Ruler origin: 

@ ot left of paper. 

© at left of print srea. 

Cursor Position Display 
Cea f @ Chors Into 9/tines From Top Of Page 
33/9 © Chars tato 9/Chars Into Document 
Dicail+ O Dist. From Left Edge/Dist. From Top Edge 

© None 

Figure 15-7 Measurement Preferences 

You can select inches or centimeters for the ruler measurement. The 
display of the insertion point position in the information bar can be 
set to be: 

« Characters from beginning of paragraph/Lines from the 
beginning of the page. 

e Characters from beginning of paragraph/Characters from 
beginning of document. 

* Distance from the left of page/Distance from the top of the 
page. 
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Alternatively, the display of the insertion point position can be turned 
off by clicking the None button as in Figure 15-7. See page 69 for 
an explanation of the information bar. 

Printing Preferences 

The Printing Options dialog, illustrated in Figure 15-8 lets you specify 
a default printer for the purpose of deciding the page size and margins. 
This setting is only used when you do not have a printer driver 
selected in the Chooser dialog. This is a very useful option when 
working on a Macintosh that is not connected to a printer, because 
the printer drivers can be removed from the System Folder to save 
disk space. You can later use a system disk with the correct driver, to 
print your document. 

In this dialog you can also determine whether or not you wish to 
have your documents printed with the White Space, text hilites and 
Invisible Text shown. Check Print with all “Display” options 
as shown on screen for true WYSIWYG (What You See Is What 
You Get) printing. 

Printing Options 

CF) Skip AH Warnings Before Printing. 
C) Print with off “Display” options as shown on screen. 
C] Print Pages Last to First. 

Defauit Printer Limits For New Files 

When Current Print Driver Not Present: 

© IimageWriter 
© LaserWriter 

Figure 15-8 Printing Preferences 
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Parentheses Preferences 

Parentheses Definition 

Use this preference to set the quotes and parentheses recognized by 
Nisus while matching parentheses. Read more about this feature on 
page 325 in Chapter 11. 

Parentheses Definitions 

Expressions: Strings: 

#P [] Check parenthesis 

Figure 15-9 The Parentheses Definitions dialog 

The Parentheses Definitions dialog, illustrated in Figure 15-9 allows 
you to define the parentheses and quotes which Nisus will check. 
You may add new ones or remove the existing ones. Quote parentheses 
(labeled Strings in the dialog) are different from standard parentheses 
(labeled Expressions). The $ trings parentheses are actual quotations. 
The standard settings here are the single and double quotes as well 
as the corresponding smart quotes. The Expressions parentheses 
are true parentheses which can be nested to any depth. For example 
with the standard definitions, if you wanted to quote a left bracket as 
in “{", Nisus would not count the bracket as an unmatched parenthesis 
because it is inside quotes. The converse is not true: the bracketed 
quote [“] would be counted as an unmatched quote. 
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Parenthesis Checking 

Clicking the Check parenthesis box causes Nisus to display 
unmatched parentheses in the information bar of your window as 
you type. The default parentheses which are recognized by Nisus are 
the ones defined in the dialog seen in Figure 15-9. 

Dictionaries Preferences 

These preferences allow you to specify the dictionary, thesaurus and 
user dictionary locations so that Nisus will know where to find them. 
When you use the spelling checker or thesaurus and if you do not set 
these preferences, Nisus will look for the dictionaries in the same 
folder as the application or the System Folder. If it does not find 
them there it will ask you to locate them using the Open File dialog. 
The American version of Nisus is shipped with a combined 
Dictionary/Thesaurus called Nisus Thesaurus. If you are using one 
of the special dictionaries supplied by Paragon you should select that 

for your Main Dictionary and the Nisus Thesaurus for your 
thesaurus in the Dictionaries Preferences dialog illustrated in Figure 
15-10. Otherwise you can select the Nisus Theseurus for both the 
dictionary and the thesaurus. 

Nisus will automatically load any dictionary, thesaurus, or user 

dictionary in the same folder with the application or the System 
Folder that is prefaced with the name Nisus. 

Spelling Checker/Thesaurus Preferences 

Main Dictionary| Nisus Dictionary 

User Dictionary | Nisus User Dictionary 

Nisus Thesaurus 

Kyphenation | Nisus Hyphenation 

Figure 15-10 The Dictionaries Preferences dialog 
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You can, at any time, change from the current dictionary or thesaurus 

to another one by opening it from the Catalog. The Dictionaries... 
preference is used only to specify default locations of the dictionaries. 

Assigning Command Keys to Menu 
Commands 

Introduction 

Nisus supports full implementation of the Macintosh extended 
keyboard. Nisus comes shipped with the standard Macintosh 

Command key equivalents (H: Cut, C: Copy, U: Paste, etc.) Although 

speed tests show it is generally faster to use the mouse than the 
menu keys to initiate commands, there are people who prefer to use 
the keyboard. For these people, Nisus is shipped with a Nisus 
Preferences 3.0 file which has almost every menu command assigned 
to some key set. If you want to try out our assignment, then you 
should copy the supplied “Nisus Preferences 3.0” file to your System 
Folder and Nisus will automatically load it at start up time. You can 
edit any Command key assignments. If at any time you want to 
revert to the internal assignments of all the preferences, choose Revert 
from the Preferences submenu of the File menu. Remember that 
the preferences file also holds all the other preferences you may have 
assigned. Deleting or renaming the preferences file will also revert 
all those preferences to the ones assigned internally. Double-clicking 
on a preferences file in the Catalog will load all the assigned preferences 
in that file. 

This chapter uses special symbols to designate modifier keys and to 
distinguish the keys on the numeric keypad from the same keys on 
the main keyboard. These special symbols, illustrated in Figure 15-11 
are also used to show the key assignments on the menus. 
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SOOPER ESAS RASFE HEE ET HERTS RE SEP ER ESE ETY 

STRAT OT HTT ER SS PEA ASEERRE ESTES ERR ES OES 

"Control sacisrtitneeeuiies nae 

Numeric Key Pad .......s-sssccessssesscnssenssseneses 

PUNCHON ICY so5ecescsscitech cece tenseiteeetees "09> 4xb 

Figure 15-11 Menu Key names and their symbols 

Multiple Key Assignments 

Nisus allows you to assign one, two, or three keys to any menu 
command. To use a Command key set of two or three keys hold 
down the Command key modifier ($8) and type the assigned key 
sequence. For example if Insert Ruler has the Command key #IR 
assigned to it, you can execute Insert Ruler by holding down 3 
while you type an I followed by an R, and then letting go of the 
Command key. 

Choose the menu item and type the key(s): 

C2) SHIFT @ % COMMAND KEY : 

L) OPTION © FUNCTION KEY # : 

(CONTROL © % KEY PAD KEY 

Create Command List 

SORT BY: © Key © Item O Menu 

Figure 15-12 Menu Key Dialog 
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Nisus supports the assignment of Function keys from extended 
keyboards, option characters as Command keys, as well as 
combinations of the Control (@&), Shift (44) and Option (SS) key 
modifiers in combination with a Command key. You can also assign 
keys on the numeric keypad independently of, and in addition to 
those on the main keyboard. When Numeric keypad keys are assigned 
the special keypad symbol (()) is displayed on the menu to designate 
the assignment. When you assign the Function keys (on the extended 
keyboard) the menu displays the letter F followed by the number of 
the key. 

Misc. Menus 

i Spacing 
| Spacing 

Justify 
ng A ae 

wvTvv 

Graphics 

Page/4 

Front/Behind Text 
Text Wrap 

Opaque/Transparent 
Catalog 

Search Method 
Headers/Ffooter 
Footnotes 

Search Mode b 
Replace Mode > 

Wild Card > 
Special p 

> 

> 

> 

VvvvrvvrTvVvvvVvyw 

Repeat # 

Position 

Clipboards 

Match 

Figure 15-13 The Misc. Menu 

Assigning Command keys to menu commands is simple. Choose 
Menu Keys... from the Preferences submenu of the File menu. 
A dialog will appear, as illustrated in Figure 15-12 and every menu 
will then become active. An additional Misc. Menus menu, 
illustrated in Figure 15-13, will also appear on the menu bar. This 
menu contains submenus for those menus that are normally accessible 
only in various contexts’. This allows you to assign command keys 
to every command, no matter where the command is used. 
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Remember that Nisus has other sets of menus available when one or 
more modifier keys are pressed. When you are assigning key 
equivalents you can use modifier keys to access these alternate menu 
commands. If one of these modified menus is a submenu, your pointer 
must be in the submenu to activate it for the purpose of assigning a 
menu key. When you select a menu command its name appears in 

~ the dialog. If the selected menu command already has command 
keys assigned to it, the first key set assigned will also appear in the 
dialog with the appropriate modifier check boxes set. 

After you have selected a menu command, you may remove an 
command keys which may be already assigned using the 
button. Note that deleting or overtyping any existing assigned key 
set showing in the dialog will not remove it from that menu command. 
It will remain available as an alternative assignment, but will not 
display on the menu. Only the last assignment will display. 

Assigning Command Keys 

To assign a Command key set, when the Menu Keys dialog is active, 
do the following: 

1. Select the menu command?’ to which you wish to make a 
key assignment, using modifier keys for the modified menu 
commands when necessary. 

2. Type the unmodified key (or two, or up to three keys) which 
will then display in the assignment box as the corresponding 
character(s). All alphabetic characters display as uppercase 
only. 

'The menus L Spacing, 4 Spacing, and Justify do not appear 
on any menu. Access to these features is via the ruler and they are put on the 
Misc. Menus during menu key assignment to make it possible for you to 
assign key equivalents to all these Nisus functions. 

* If a menu command already has a command key assigned to it, 
/ou can access the menu command using the already assigned command key. 
The result is the same as selecting the menu command from the menus using a 
mouse. Menu commands that have Functions Keys assigned to them can only 
be accessed by typing the Function Keys immediately after the Menu Keys 
dialog is first opened, or after setting a Command key. 
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3. Click any of the modifier key boxes (Option, Control, Shift 
or the Numeric keypad) you wish the assignment to use. If 
you want to assign a function key, first click the Function 
Key button and then type the number of the function key 
you want to assign, or simply type the Function Key desired. 

4, Click to make the assignment. 

If there is a conflict, because the keys are already assigned, you will 
see a dialog questioning your new assignment, as illustrated in Figure 
15-14. 

Do you wish to remave XN from 
New 7 

Figure 15-14 Menu Key Removal dialog 

5. Check the menu command. It should already display the 
assignment. If you change your mind, click (meee and 
repeat the assignment. Note that special icons are used for 
the modifier keys, and to designate keys on the numeric 
keypad. 

6. Select the next menu command to which you wish to assign 
keys and repeat the process. 

7. When you have finished making all the assignments, click 
[ Done ™~ 

Serr ee 

Is” If you choose a command from those menus in which commands can 
be added and removed (Glossary, Macros, Windows, Fonts, 
Styles (User Styles) and the Apple € menus), the Menu Keys dialog 
box will add another option, illustrated in Figure 15-15 from which 
you can decide whether the key command should stay with the menu 
item name or the particular location on the menu to which the key 
was assigned. 
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Choose the menu item snd type the keys or number: 

Menu item: 
[J SHIFT @ % COMMAND KEY : 

C) OPTION © FUNCTION KEY # : 

() CONTROL © % KEY PAD KEY 

@ Key stays with menu item name. 

© Key steys with location on menu. 

Create Command List 

SORT BY: © Key © Item O Menu 

Figure 15-15 The movable command Menu Key dialog 

When you click the Menu Keys dialog will go away and 
you will be returned to your document. To preserve the assignments 
for the next time you start Nisus, use the menu command Save 
Preferences. These are saved in a special file named Nisus 
Preferences 3.0 in the System Folder. When you start Nisus, they are 
automatically loaded. If you re-name this file or move it to another 
folder, the preferences will not be loaded. You can have several 
different preferences files, but only one can be loaded at a time. You 
can force a loading of any preferences file by double-clicking on its 
name in the Catalog. 

Modified Key Assignment Method 

There are two different ways you can choose to assign certain keys 
using the Option and/or shift key modifiers. This is illustrated by 
the following examples. 

* Method I: 

To assign 3€=, type “=” and check the SHIFT box. 
* Method IE 

To assign $€+, press the Shift key and type “=” which is on 
the same key as “+”(note that when you do this you cannot 
also check the shift key box—it is disabled). 
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Both assignments will require that you press the same keys to use 
them, but they will display differently on the menu: The first method 
will display <> $=, the second as $€+ 

To assign “NS 36M, type “m” and then check the Option box. All 
shifted and unshifted keys are shown in caps. The shifted and optioned 
keys show the shift (4+) and option (S$) symbols on the menu. If 
you use the Method II procedure, some option characters will display 
as special symbols. During assignment, type the option character 
into the assignment box if you want to have those symbols displayed 
on the menu. The following is another example of these two ways to 
assign Option-Command-P: 

* Method I: 

Type “p” into the assignment dialog and check the OPTION 
check box. The display on the menu (after you click (_set_}) 
will show N& 3€P. 

* Method II: 
Press the Option key and type “p” (= x) into the assignment 
dialog and 3611 shows on the menus. 

If at any time you make a mistake you can immediately exit by 
clicking (Cancel ) voiding all the changes you have just made. 

Menu Key Assignment Rules 

There are a few rules in assigning menu keys. If you try breaking 
them, in almost all cases Nisus will not let you. They are listed here 
only to explain the occasional beeps you will get if you try. 

* You cannot mix Command keys from the keyboard, keypad 
and/or Function keys for one menu command assignment. 
Nisus will not allow you to do this. 

* Function keys cannot be assigned in combination with any 
other key: they can only be assigned on their own, only one 
key per menu command. 

¢ Command keys are limited to three letters per menu 
command. 
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e You cannot mix, in one menu command assignment, 

characters assigned by using Method II described above, 
with those assigned using Method I. If you try to do this 
Nisus will beep at you. But you can assign any key set by 
using Method I to one menu command and using Method IJ 
another key set to another menu command. 

¢« You cannot mix, in one menu command assignment, 

characters assigned using two different modifier keys. For 
example you cannot assign Command-Option-P-Shift-a to 
anything. 

e You are not allowed to assign 4? 380 through 4? 989 (in 
words: Command-Shift-Zero through Command-Shift- 
Nine). These are reserved by the Macintosh operating system. 

¢ Nisus has reserved two keys which it will not let you assign. 

These are: 3. (Command-Period: the general STOP 
command); the 9- (Command Minus: used for inserting a 
manual hyphen) and of course $8 (Command-Space), 
because you cannot see a space! 

ts" If a menu command has more than one Command key set assigned 
to it only the last one assigned will display on the menu. If you want 
to remove one of the Command key sets, other than the one that is 
showing, you have to remove all of the assigned command keys and 
then add back the ones you want to keep. 

Creating a Key Command List 

If you are not sure what Command keys are assigned to the menu 
commands or if you want to have a list of all key assignments, click 
the button in the Menu Keys dialog, to create 
a document containing a list of all the current assignments. Three 
different types of alphabetical sorts are available to you when creating 
this list: 

¢ Keys - sorted by command key 
¢ Name - sorted by menu command name 
¢ Menu - sorted by menu name under which each command 

appears, and by command name within a menu group. 
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The list is created in a new file which can be edited, saved and/or 
printed. All assignments are shown. The one showing on the menu is 
shown first. 

Using Multiple Key Assignments 

Because Nisus allows you to assign up to three keys per command, 
you can, for example, make the following assignment: 

Key Assignment Menu Command 
¢ Command-C Copy 
¢ Command-CA Cairo 

* Command-CAT Catalog 

Having made this assignment, if you now type Command and 
keep holding the Command key down, Nisus will wait to see if 
another character is to follow. It will delay execution of the command 
for a fraction of a second before it decides that no more keys are 
coming. This waiting time is proportional to the time between clicks 
which is adjustable in the Control Panel. If you want Command-C to 
execute immediately, you must let go of the Command key 
immediately after typing the “c”. 

This may affect your choice of command keys. If you want a single, 
or double command key sets to execute immediately, then you cannot 
have additional, multiple command keys that begin with the same 
letter as the single, or double command key. Triple key assignments 
always execute immediately because no more keys can be assigned. 

Document Preferences 

The following preferences are local to the document. They can be set 
differently for each document and are saved with the document rather 
than in the preferences file. 
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Line Number Preferences 

To change the way line numbers are displayed choose Line # Prefs... 
from the Display menu of the Tools menu. The dialog displayed, 
shown in Figure 15-16, allows you to set the attributes of the line 
numbers. Choose the font, size and style of line numbers from the 
Font, Size and Style menus. The other buttons are self explanatory. 
You can display every line number or every second or tenth line 
number. To set this, type the appropriate number into the box in the 
dialog. 

Line Number Options 

Choose Line Number Attributes 

Font: Geneve 

Size: 9 point 

Style: Plain 

Number Every (1 | Lines 

Number From Beginning Of 

© Page @ Document 

Height of Lines: fo | 

1 1 
Bers: 4 Oo} oO} 

Figure 15-16 Line Number Preferences 

Line number preferences are different from other preferences because 
they do not change the document text. You cannot Undo the line 
number display by using the Undo command. You can have line 
numbers displayed in one document and not in another. When you 
change line number preferences, they are changed for the document 
in the active window. To undo the display, choose the Line # Prefs... 
command once more. You can have line numbers displayed in the 
Catalog, the Find/Replace dialog, as well as in the macro and glossary 
windows. If you print the document with the line numbers showing 
they will be printed. 
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When you open a new file (without the presence of the special Nisus 
New File stationery), the default line number preferences will be 
used. These are the ones showing in Figure 15-16. To set your own 
new file line number preferences create a stationery document. For 
directions see Nisus New File, page 65. 

is It is not possible to number lines in the footnotes, headers or footers. 

Variable Format Preferences 

The display format of variables is specific to each document. You can 
change the manner in which the time, date, and page number variables 
are displayed for individual documents. 

You may display the time in 12 hour or 24 hour formats. The current 
format used is set to the one used in the Control Panel in the 
Apple @menu and variants based on it. 

The date and page number formats are set using the Variable Format 
Preferences Dialog shown in Figure 15-17. 

Variable formats for Untitled-] 

Date: @© 3/20/63 
© Tuesday, March 20, 1963 
© Tue, Mar 20, 1963 
© March 20, 1963 
© Mar 20, 1963 

Page Numbers: 

© Arabic 
@® Roman 
© Uppercase 
@ Lowercase 

Start page *#: | 

Figure 15-17 The Date & Page# Formats dialog 
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To get this dialog, choose Set Date & Page* Formats... from 

the Format menu. Any changes that you make will affect all date or 
page number variables in the entire document. You will see the changes 
the next time you update variables. This can be done by choosing 
Update Time & Date from the Format menu or by clicking the 
appropriate button in the Print dialog. 

Implied Preferences 

When you save your file, the state of the document window such as 
window size, position, ruler and information bar display, insertion 
point or selection region are all saved with the document. The attributes 
of the Catalog window, the font and size and style of its text, arc 
also saved in the preferences file when you use the Save 
Preferences command. The shape and position it has on the screen 
are saved separately from the preferences file. 
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16 
Troubleshooting 

Find/Replace Dialog 

Problem : PowerSearch+ expression not found 

Solution: If you were doing a search with PowerSearch+ and the 
expression was not found, perhaps you typed it incorrectly. Perhaps 
some characters you intended to be taken literally were interpreted 
as metacharacters. Literal characters should be preceded by a \. 

Perhaps you intended a normal search. To initiate a normal search, 
choose Normal Search from the pop-up menu. Check to see if 

Whole Word, tgnore Case, Wrap Rround in the Find/Replace 

window, and Find Text Only in the Search Method menu arc 
the way you want them. 

Problem: Undesired text is found or literal text is not found 

Solution: Make sure Normal Search is chosen from the pop-up 
menu and that Whole Word button is not checked if the expression 
includes non-word characters (spaces, returns tabs etc.) Also, check 
to see if you have an extra Return in the find pattern. This can easily 
happen if you copy and paste the text into the Find/Replace dialog. 
If you are searching for text independently of styles and fonts make 
sure that the Find Text Only command on the Search Method 
menu is checked. 
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Graphics & PostScript 

Problem: A PostScript printer doesn't print graphics as 
they appear on the screen. 

Solution: Choose As PostScript® From the Display submenu of 

the Tools menu. See PostScript Limitations page 288, for details. 

Macros 

Problem: Recording double-clicks 

Solution: Recorded macros using mouse clicks may not play back 
properly unless you lengthen the “Delay Until Repeat” option in the 
Keyboard INIT in the Controi Panel Desk Accessory on the Apple 
€ menu. 

Problem: Recording drags 

Solution: Drags, such as selection of text or dragging the thumb of a 
scroll bar, are not recorded in macros. Use an alternate method such 
as a key equivalent. 

Probiem: Recording pop-up menu choosing 

Solution: These are not recorded. Use a Command-key equivalent. 

Memory Use 

Introduction 

Nisus is a memory based word processor: while you are working on 
a document it is kept entirely in memory. 
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This means that all editing operations are fast. Scrolling and searching 
are also very fast. The size of your document, however, is limited by 
the amount of available memory. Therefore, it is important to know 
how Nisus uses memory and how to free up memory when you are 
running low. 

How Nisus Uses Memory 

Each document you open requires enough memory for the document 
itself, plus a few kilobytes (K) of overhead for Nisus. 

Every operation which goes into the undo list requires enough memory 
to store text or graphics that were deleted or changed, plus some 
overhead. Graphic changes, especially, tend to take quite a lot of 
memory. Operations not directly changing text or graphics, such as 
changing a ruler or page layout information, still require enough 
memory in the undo list to store the ruler or page layout information 
that was changed. 

Every window that is open requires several kilobytes of memory. 
The Catalog window, in particular, may take a sizeable amount of 
memory if you have a large number of files listed. 

Glossaries, macros and user dictionaries all take up memory, just as 
documents do. 

Running Low on Memory 

When you are running low on memory one or both of the following 
may happen: 

1. Nisus will beep and display a dialog stating that the operation 
you just tried failed because there was not enough free 
memory to perform the task. If an operation fails, Nisus will 
attempt to free up memory. Because of this, you may be 
able to successfully complete the operation if you attempt it 
again immediately after a failure. 
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2. One or more windows may “black out”: their contents will 
become solid black. If you are running low on memory Nisus 
may try to free up some memory by not displaying the 
contents of one or more windows. You can leave the 
window(s) black as long as you wish in order to leave the 
memory free for your use. To restore the window(s) to normal, 
simply click in the black area. 

Sometimes these may occur because memory was temporarily low, 
as when you make a large change to a document and that change is 
eventually removed from the undo list. During these temporary 
situations it may not be necessary to manually free up memory, but 
if these problems continue to occur you may have to take steps to 
alleviate the memory shortage. 

Freeing Memory 

Sometimes there just isn’t enough memory to perform an operation, 
or you may be getting black windows or failed operations frequently. 
In these situations it is best to try freeing up memory for Nisus to 
work with. 

One of the best ways to free up memory is to close any open files you 
aren't working with, especially large files. Closing any unused 
windows such as the Clipboard, Catalog or Find/Replace windows 
will help. 

Closing macro or glossary windows will not free up much memory 
because the files themselves stay in memory. To remove a macro or 
glossary file from memory it is necessary to choose New File... or 
New Glossary..., respectively, which will create a new, empty file 
in memory. 

A simple and sometimes necessary measure is to reduce the size of 
the undo list, particularly when you have made large changes, such 
as changing the font of the entire document. To do this, choose 
Editing... in the Preferences submenu of the File menu and set 
Maximum Number Of Undos to a number lower than the current 
number of undos. This will shorten the undo list and free up memory 
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by removing the oldest items in the list. To completely clear the list, 
without changing the maximum number of undos, press the Option 
key as you choose Undo. 

When you are working with large files, it is a good idea (and sometimes 
a necessary measure) to break the file into two or more smaller files. 

~ Even if the file can fit in memory, it may be more convenient to edit 
it in several files and merge it later to print or produce an index or 
table of contents. 

Other Problems 

Problem: Your window is black 

Solution: 

1. Click within the window. If this doesn’t work, try some of 
the following steps. Click in the window again after each 
step. If the window remains black, go on to the next step. 

2. Close all other windows including the Find/ Replace dialog, 
the Catalog and the Spell Checking window. 

3. Choose Editing... from the Preferences submenu of the 
File menu and set the number of undos to 1. 

4. If you still have a very large change in the undo or redo list, 
you can free memory by opening the Clipboard and typing 
a key to erase the last change. Try clearing all clipboards. 

Typing 

Problem: Typing is slow 

Solution: You may be editing the last line of the document. Place a 
blank line at the end of the document. 

Solution: You are probably running low on memory. Quit Nisus, 
choose Control Panel from the @ menu and turn off the RAM 
cache and then launch Nisus again. Nisus requires at least 700 K to 
run at reasonable speed. 
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Glossary of Terms 

ASCII; Acronym for American Standard Code for Information 
Interchange, pronounced “ASK-ee.” A code in which the numbers 
from 0 to 127 are used for representing text inside a computer and 
for transmitting text between computers or between a computer and 
a peripheral device. 

bitmap graphics: Any graphics which are defined using dots like 
MacPaint type graphics. 

control character: A non-printing character that controls or modifies 
the way information is printed or displayed. Control characters have 
ASCII values between 0 and 31, and are typed from the keyboard by 
holding down the Control key while pressing some other key. The 
form feed control character (Control-L) can be inserted in your 
document to cause a definite page break. 

document: Text grouped with all its attributes and formatting by 
Nisus in such a way that it can be viewed, edited and printed in 
Nisus. Referred to as a file when saved on disk. 

EPS: (Encapsulated PostScript), a format of files that has with it both 
a description of an image in PostScript and a bitmap version to display 
on screen. These files are not read by Nisus, though you can import 
the graphic via the Scrapbook and the Clipboard. 

file: The term which refers to documents, glossaries, sets of macros, 
and other data on disk. 

Flesch Reading Ease: A numeric estimate of the readability of a 
document. The estimates range from 1 to 100—100 being the easiest. 

leading: Pronounced “LED-ing”; the amount of blank vertical space 
between the descent line of one line of text and the ascent line of the 
next line of single-spaced text. In early typesetting, strips of lead 
were placed between lines of type for spacing; hence the term leading.. 
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macro: A collection of commands which may be performed by Nisus 
as a group. Macros can be recorded by watching you perform some 
commands, or they can be written using the Nisus Macro Language. 
In either case macros may be viewed and edited at any time. 

metacharacter: A character used to represent another character or 
group of characters. In the case of a single character, it usually 
represents a character which does not have a displayable character 
code. 

monospace font: A font in which all characters are the same width. 
Examples of a monospace fonts are Courier and Monaco. 

object graphics : This term in Macintosh usage means a graphic 
made up of arcs and fonts. In this meaning object graphics do not 
include bitmaps. 

paragraph: Text followed and preceded by a carriage return. A 
paragraph can consist of a single character if it this character both 
preceded and followed by a carriage return. Blank lines are counted 
as paragraphs. 

point: A unit of measurement for type; 12 points equal 1 pica, and 6 
picas equal | inch; thus, 1 point equals approximately +; ,inch. 

PostScript: A page description language that describes the appearance 
and position of graphics and text on a page. 

proportional font: Any font in which different characters have 
different widths; thus, the space taken up by words having the same 
number of letters varies. For example, in the typeface used here the 
letter M is wider than the letter I, so that MMMMM produces a 
wider string than IIIII. See monospace font. 

set: A set is a range or a collection of characters. For example, the 
collection of all single digits form a set ({0-9]). The collection of all 
lowercase alphabetic characters forms another set ([a-z]) 
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