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SAVE TIME, NO MORE RETYPING!

Congratulations on acquiring Readiris. This software package will undoubt-
edly be of great help in recapturing your texts, tables and graphics.

As efficient as computers are, you have to key in your information first. If you
have ever retyped a 15 page report or a large table of figures, you know how
tedious and time-consuming it can be. Use this state-of-the-art OCR package to
automatically enter text in your applications and you'll acquire an unprecedented
level of efficiency and comfort!

Scan a printed or typed document, indicate the zones of interest - or have the
system detect them for you -, execute the character recognition and export the
document to your wordprocessor. A few mouse clicks beat long hours of work as
Readiris converts your paper documents into editable computer files: it's up to 30
times faster than manual retyping!

With the automatic mode of operation, the user's effort is reduced to a single
click: he initiates the scanning and saves the text result, all intermediate steps are
taken care of by Readiris. After the recognition, you can send the reading results
directly to your favorite applications - be that a wordprocessor, spreadsheet or
web browser.

Readiris recognizes tabular data and recreates them as worksheets or as table
objects inside your wordprocessor; your numeric data are immediately ready for
further processing.

Based on the Connectionist technology from I.R.I.S., Readiris represents the
best OCR has to offer. Font-independant feature extraction is complemented by
self-learning techniques derived from a proprietary neural network. The system
can learn new characters through context analysis: linguistic knowledge about
syllables and words improves the OCR performance.

Readiris supports up to 54 languages: all American and European languages
are supported, including the Central-European languages, Greek and the Cyrillic
(“Russian”) languages. Readiris even copes with mixed alphabets: the software
detects “Western” words that pop up in Greek and Cyrillic documents - many
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untranscrible proper names, brand names etc. are written using the Western sym-
bols.

Readiris uses linguistics during the recognition phase, not after it. As a direct
result, Readiris recognizes documents of all kinds with top accuracy, including
low-quality documents, faxes and dot matrix printouts. It copes beautifully with
badly scanned and copied documents containing too light or dark font shapes.
Joined characters (“ligatures”) are resolved and fragmented forms, such as dot
matrix symbols, are recomposed.

User verification in pop-up style not only flags doubtful characters but also
increases the system's precision. All solutions confirmed by the user are memo-
rized, increasing speed and confidence as you go along. Using Readiris means
rendering it more intelligent each time! This powerful learning tool allows you to
train Readiris on special characters such as mathematic symbols and dingbats
but also to handle distorted fonts as you will find in real documents.

To increase your productivity further, Readiris not only recognizes your texts,
but can format them for you as well! Make use of “autoformatting” and Readiris
recreates a facsimile copy of the scanned document: the word, paragraph and
page formatting of the original document are retained.

Similar typefaces are used, the point sizes and typestyles as used in the source
document are maintained across the recognition. The placement of columns, text
blocks and graphics follows your original documents. And as Readiris supports
greyscale and color scanning effortlessly, you can recapture any graphics - be
they lineart, black-and-white photos or color illustrations. When a document con-
tains tables, Readiris reorganizes them in real cells and recreates the cell borders
of the original tables.

In other words, Readiris allows you to archive a true copy of your documents,
be it editable and compact text files instead of scanned images! Various levels of
formatting are available, the choice is up to the user.

Readiris supports virtually all scanners using their Photoshop “plug-in” or Twain
drivers: all models that dispose of a Photoshop “plug-in” or Twain module are
seamlessly supported.
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Chapter 1
I N S T A L L A T I O N

This chapter discusses the system requirements and installation of the Readiris
software.

SYSTEM REQUIREMENTS

This is the minimal system configuration required to use Readiris:
q a Mac OS computer with a PowerPC processor. Readiris does not run

on 680x0 processor-based computers!
q 22 MB free RAM. Foresee 32 MB free RAM to process “true color”

(RGB) images.
q System 7.6 with QuickTime 3.0 and Appearance 1.0.1 installed. Mac

OS 8.5 with QuickTime 4.0 installed is recommended. The system ex-
tension Appearance can be downloaded for free from the Apple web
site (www.apple.com).

q 25 MB of free hard disk space.

INSTALLING THE READIRIS SOFTWARE

The Readiris software is delivered compressed. To install, it is mandatory to
run the installation program.

1. Insert the Readiris CD-ROM.
2. Double-click on the Readiris installer and follow the on-screen instruc-

tions.
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You are recommended to use the “easy” installation - it places all the
necessary files on your hard disk, including the sample images which
are used in the tutorial of this manual.

The Readiris folder is created automatically by the installation program.
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REGISTER TO VOTE!

At the end of the software installation, you are invited to register your Readiris
licence by submitting a registration form on the I.R.I.S. web site - this method
obviously requires an Internet connection! (You can access the same registration
form with the command "Register Readiris" under the "Help" menu.)

You can register in many ways, not just via the web: by faxing or sending in
your registration card and by calling I.R.I.S. during working hours.



1 - 4

Registering your Readiris licence allows us to keep you informed of future
product developments and related I.R.I.S. products. The registration benefits,
including free product support and special offers, are strictly limited to regis-
tered users.
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COMFORT ISN'T LAZINESS!

Some additional steps can be completed for maximal ease of use of Readiris.

First of all, it may be useful to create an alias. Use the command "Make
Alias" of the Finder’s "File" menu to do so. As a result, you'll be able to start the
Readiris software directly from your desktop.

Also, you can add Readiris to the folder "Apple Menu Items". This folder can
be found under the System folder.

The software documentation that came with your Macintosh can tell you more
about aliases and the Apple menu.
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INSTALLING YOUR SCANNER UNDER READIRIS

Readiris exploits the Photoshop “plug-in” or Twain driver of each scanner
to support it. In other words, as soon as there's a Photoshop “plug-in” or Twain
driver available for your scanner model, Readiris supports it effortlessly!

Here's how you install your scanner under Readiris.

Using the Photoshop “plug-in”
1. Install the scanner drivers using the CD-ROM (or set of diskettes) that

comes with your scanner. Doing so will install the Photoshop “plug-in”
on your computer. (If necessary, study the installation instructions that
accompany your scanner carefully to ensure that these drivers are in-
stalled properly.)

2. Verify if the scanner operates correctly with any scanning application
other than Readiris.

3. Locate the Photoshop “plug-in” on your hard disk and copy it to the
Readiris folder, or create an alias for that “plug-in” in the Readiris folder.

4. Start up the Readiris software. You are warned when Readiris is un-
able to detect the Photoshop “plug-in” at the program startup.

5. Select your “plug-in” under Readiris with the option "Scanner" in the
"Preferences" command under the "Edit" menu. That shouldn’t be too
hard: your Photoshop “plug-in” will be the only scanner driver available
under the "Scanner" option.
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Using the Twain driver
1. Install the scanner drivers using the CD-ROM (or set of diskettes) that

comes with your scanner. Doing so will install the Twain driver on your
computer. (If necessary, study the installation instructions that accom-
pany your scanner carefully to ensure that these drivers are installed
properly.)

2. Verify if the scanner operates correctly with any scanning application
other than Readiris.

3. Start up the Readiris software. You are warned when Readiris is un-
able to detect a Photoshop “plug-in” at the program startup. As a Twain
driver is used, you can simply ignore this warning; click "Don't Remind
Me" to do so.

5. Select your scanner model under Readiris with the option "Scanner" in
the "Preferences" command under the "Edit" menu.
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More about scanner support can be found in the “Read Me” file that comes
with the Readiris software.

Don’t hesitate to contact your scanner manufacturer or its representative should
there be problems with scanner drivers. Most manufacturers allow you to down-
load the latest versions of the scanners drivers from their web site.

GETTING PRODUCT SUPPORT

The Readiris “Read Me” file details how you can get technical support.
Among other things, you can contact I.R.I.S. by e-mail at the address
support@irislink.com.

Please describe the phenomenon you experience clearly and include all rel-
evant data concerning Readiris, your scanner and your computer system.

GETTING IN TOUCH WITH I.R.I.S.

You can also contact I.R.I.S. to learn more about its range of software solu-
tions.

The Readiris startup screen and the command "I.R.I.S. on the Internet" under
the "Help" menu of Readiris bring you directly to the I.R.I.S. home page
(www.irislink.com).
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Chapter 2
GUIDED TOUR

Readiris is a state-of-the-art OCR package equipped with numerous advanced
features. We will discuss all major features in this chapter and add many tips and
hints concerning the use of Readiris.

STARTING THE SOFTWARE UP

Double-click on the Readiris application in the Readiris folder or on the alias
for the Readiris application on your desktop.

The Readiris startup screen and the menu bar of the Readiris software are
displayed. The startup screen displays the version and copyrights of the Readiris
software. It also gives direct access to I.R.I.S.' homepage - simply click on the
URL www.irislink.com to visit the I.R.I.S. web site. Clicking the mouse any-
where else makes this screen disappear.
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DISCOVERING THE READIRIS INTERFACE

The Readiris application not only contains a menu bar but also an image
window and a toolbar that gives quick access to the most frequent commands.

The toolbar gives quick access to all frequent general commands and con-
tains all common commands you need during the image preview. Initially, many
buttons are dimmed: they concern the preview. As long as no image is opened,
they are unavailable.
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The toolbar can be disabled with the command "Hide Toolbar" under the "View"
menu, but we recommend that you display it at all times.

To learn which command corresponds to a certain button, hold your mouse
pointer over it for a while: a tooltip appears in the status bar to tell you what the
button does.

The status bar below the button bar doesn't just display the tooltip. It also
gives information on the current image: the image size (in image pixels and in
KB), the image type (bit depth), the image resolution and the pixel coordinates of
the mouse cursor. Finally, the available RAM memory is mentioned on the right
side.

The window pane or image zone is where the scanned images are displayed.
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Should you wish to do so, the colors used in the image window - for the
window background, the page background and page foreground - can be changed
with the "Preferences" command under the "Edit" menu.
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GETTING STARTED WITH A FIRST TUTORIAL

The best way to become familiar with the operation of Readiris is undoubtedly
by using it. A number of prescanned images is provided with the software;
they allow you to get started even when there is no scanner connected to your
computer. Let’s turn to them now.

Readiris allows you to scan images using your scanner and open prescanned
images: use the "Open" button to open prescanned images, use the "Scan" button
to acquire images with your scanner. (You can also select the command "Open"
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from the "File" menu to load an image and use the command "Acquire" from the
"File" menu to scan an image.)

            

Color, greyscale and black-and-white images are supported on an equal basis:
Readiris allows you to open FlashPix images, GIF images, JPEG images, MacPaint
images, Photoshop images, PICT images (called “native” Readiris documents),
PNG images, QuickDraw GX images, QuickTime images, Silicon Graphics im-
ages, Targa images, (uncompressed, packbits and Group 3 compressed) TIFF
images and Windows bitmaps (BMP).

Loading prescanned images is particularly useful to convert your faxes into
editable text files.

Click the "Open" button and go to the folder "Images" under the Readiris
folder. By default, a preview (if available) of the selected image is shown - “se-
lected” means you've clicked the image once. Click the button "Hide Preview" if
you wish to disable the image preview; click "Show Preview" to enable it again.
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Double-click the image English.jpg in the image folder or click the image once
and click the button "Open". The image is read from disk and displayed in the
image zone progressively.
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For every greyscale and color image, a black-and-white version is generated
for the OCR process.
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To display a greyscale or color image as black-and-white, disable the option
"Image in Color" under the "View" menu.

There’s another way to import image files into Readiris. Drop them on the
Readiris icon: Readiris starts up and the image file is opened automatically.

Depending on the file format of the image you're trying to open, you may be
prompted to agree with the file conversion.

The toolbar contains all the commands you need during the image preview:
tools to analyze the page, to indicate the zones of interest, to rotate the image etc.
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ZOOMING IN ON IMAGES

Readiris has several commands that allow you to zoom in on the scanned
image, for instance to verify the scanning quality.

The "View" menu contains commands that allow you to zoom in at real size, to
display the image at 50% and 200% of its actual size, to fit the image to the page
width and to fit the entire image in the preview window. At actual size, a screen
pixel corresponds to an image pixel. (Shortcuts are available for all zoom levels!)

Note that the current zoom level is indicated in the window title - there's no
zoom level mentioned when the image fits the window.

       

       

You can also Ctrl-click the mouse button over a region of the scanned image
to zoom in at real size immediately. Ctrl-click a second time to zoom out again. As
soon as you press the Ctrl key over the image preview, the mouse cursor is
adapted!
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Finally, you can Shift-Ctrl-click the mouse button over the scanned image to
invoke all zoom levels. As you repeat the action, you'll go through the zoom levels
one after the other.

ONE, DECOMPOSING A SCANNED IMAGE

Now that the image is scanned, you have to indicate which parts you want to
convert into editable text by drawing frames, so-called “windows”, around the
zones of interest.

Actually, Readiris will do this for you automatically when the option "Page
Analysis" under the "Layout" menu is enabled. The page analysis is enabled by
default.

To force Readiris to decompose the current page - because you disabled page
analysis by accident, because you erased some windows erroneously and want
to redo the page analysis etc. -, you can simply click the button "Analyze Page"
(or the command "Analyze Page" under the "Process" menu).
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Automatic page decomposition is particularly useful when columnized texts
and documents with a complex page layout, possibly including graphics and tables,
are recognized.

Page decomposition uses three window types: text, graphic and table win-
dows. Readiris discriminates text blocks, tables and graphic zones containing
photos, illustrations etc. on the page. (Saving graphics and recognizing tables will
be discussed at great length below.)

A color code indicates the window type: text zones are yellow, graphic zones
are blue and tables are purple. When you are displaying the original image - even
if it is black-and-white -, you get a color border around the zone. In that way, the
windows do not hide the actual color tones or greyscales of the image. When you
are displaying the black-and-white version - the option "Image in Color" under the
"View" menu is disabled -, the zones are entirely filled.



2 - 13

USER'S GUIDE

The colors assigned to the three zone types can be modified with the "Prefer-
ences" command under the "Edit" menu should you wish to do so.

The number of windows is indicated in the status bar when the tooltips of the
window tools are called up. Hold your mouse cursor over a zoning button and the
number of windows of the selected window type is mentioned.

Page analyisis is fast, skew-tolerant and highly accurate: it traces complex,
“irregular” shapes.
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The page analysis will even detect zones where you get white text on a
black background. Recognizing such inserts is no problem: while the preview
displays the scanned document correctly on-screen, Readiris “inverts” the image
when the need arises to recognize such text blocks!

ONE AND A HALF, SORTING WINDOWS

Readiris not only detects the various blocks, but also sorts them: the zones are
sorted top-down, left to right by default to cope with columnized documents.

Arrows indicate the sort order unless you've chosen to display numbers with
the "Preferences" command under the "Edit" menu.

Evidently, you can modify the sort order. To do so, click the "Sort" button (or
use the command "Sort Zones" under the "Layout" menu).

       

The mouse cursor changes as soon as the “sort mode” is enabled.

Click on the windows you want to include. Windows you do not click on are
simply ignored, excluded from recognition. It's easy to see which zones are se-
lected and which aren't: the selected windows have no markers on them, the non-
selected windows still have markers on the corners and in the middle of each
side.
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TWO, WINDOWING A SCANNED IMAGE MANUALLY

Page analysis is the automatic way of zoning a scanned page. Alternatively,
you can zone an image manually with the windowing tools of Readiris. These
are available on the toolbar and under the "Layout" menu.

        

To draw a rectangle around a zone of interest, select the corresponding tool in
the toolbar (or under the "Layout" menu), click the cursor in the upper left corner
of the window, stretch the window by moving the mouse to the lower right corner
and click again. (Sides smaller than 1 mm are not allowed, they wouldn't even
contain a single character anyway.)
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The windows are automatically sorted in the order of creation: arrows or
numbers indicate the sort order.

You can also frame “irregular” text blocks by drawing polygonal windows
around them. Non-rectangular windows are created by merging rectangular zones:
as soon as two rectangles (of the same type) intersect, they become a single
window automatically! In a way, you're building a house by adding one room
after the other... (Creating polygonal table windows doesn't make any sense.)

Furthermore, manual zoning can be combined with window sorting: you can
draw new windows even when the “sort mode” is enabled. You then use sorting
to include a number of detected windows and manually create some other win-
dows where the page analysis didn't yield the appropriate results. As soon as you
start creating windows in the “sort mode”, all windows you didn't select are
promptly erased!

To modify, move and delete windows, you need to select them first. To do so,
choose the window selection tool in the toolbar and click inside a window. Rect-
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angular markers now appear at each corner and in the middle of the window
sides.

       

To unselect windows, click the mouse button elsewhere. To select addi-
tional windows, hold down the Shift key while clicking on these extra windows.

So much for selecting zones. To modify a window, select it, put your mouse
cursor over a marker and drag the side to change the window size.

To move a window, simply select it and drag it to another location.

To delete windows, select the window(s) and choose the "Cut" or "Clear"
command from the "Edit" menu. The "Cut" command cuts the window(s) to an
internal buffer, "Clear" erases the window(s) irretrievably. When you paste win-
dows, they are inserted in their original position, and you have to drag them to
their new location.

In fact, all familiar commands from the "Edit" menu apply to the windows:
you can delete, cut, copy and paste them! The "Undo" command also applies: if
you have unfortunately deleted, moved, resized etc. some zones, "Undo" will
cancel the last operation.

Also note that shortcuts are available for all commands! Let's give an ex-
ample: to erase all existing windows, you can choose the command "Select All"
or its shortcut Command-A and click the command "Clear" or its shortcut
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BackSpace. Alternatively, you can use the command "Clear" under the "Layout"
menu to erase the current zones from the memory.

You are now ready to recreate the necessary layout. To restore the previous
layout, you can choose "Undo" or the shortcut Command-Z. Or click "Redo" to
erase the windows a second time...

THREE, SAVING WINDOWING TEMPLATES

The resulting windowing layouts can be saved as zoning templates for fu-
ture use with the command "Save As" under the "Layout" menu and loaded into
memory with the command "Open" under the "Layout" menu. (There's a specific
command to allow you to quickly save the current layout again!)

If you have to recognize documents with a similar layout, for instance a 50
page report where the header and footer should be excluded for obvious reasons,
a single template can be applied to zone all 50 pages.

When you load a template into memory, the page analysis is disabled auto-
matically. The zoning template remains active until you re-enable the page analy-
sis.

READIRIS TAKES YOU AROUND THE WORLD

Assuming that the windows are correctly defined, you are now almost ready
to execute the character recognition. We say “almost”, because we haven’t veri-
fied the language and document settings yet.
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The language setting can be found on the toolbar. Click the "Language"
dropdown list to modify the document language.
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Readiris is far from limited to English: up to 54 languages are supported! All
American and European languages are supported, including the Central-Euro-
pean languages, Greek, Turkish, the Cyrillic (“Russian”) and the Baltic languages.

Also note that the British and American - or should we say “international”? -
variants of the English language are distinguished.

Selecting the proper document language is imperative. Based on the selection
of a language, the software knows which symbol set to recognize. Multi-linguis-
tic support ensures that “exotic” characters such as ç, ß, ñ, γ and ø are recog-
nized correctly.

Secondly, the software extensively uses linguistic databases to validate its
results. Suppose that you have to read the word "president" where an ink stain
makes the "r" look like an "f". Looking things up in the English lexicon, Readiris
will detect autonomously that the word "president" is being read and that it doesn't
make any sense to recognize the symbol "f". This “self-learning” technique is
of course highly dependant on the linguistic context.

Linguistics offer useful help to solve ambiguous cases such as an "O" which
might be mistaken for a '0'. Another typical example is the letter "l" and number
'1' which have an identical form in many fonts - think of texts produced on old
typewriters! The linguistic context helps to determine whether you are dealing
with "l" or '1'.

The illustration below shows various shapes of '1' and "l". The shapes on the
first line are unambiguous, the shapes on the second line are ambiguous, but
linguistics can solve them. When the context does not suffice, the user inter-
venes.
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READIRIS CHANGES LANGUAGES AS NEEDED

But the buck doesn't stop here: Readiris can switch languages in the middle of
a sentence without any help from the user! When Western words pop up in
Greek or Cyrillic documents - many untranscrible proper names, brand names
etc. are written using the familiar Western symbols -, Readiris can switch to the
correct alphabet automatically. In other words, you can activate a mixed alpha-
bet of Greek or Cyrillic and Western characters.

Be sure to select "Greek-English" or the appropriate Cyrillic language setting,
for instance "Byelorussian-English". In other words: don’t try to just select "Greek"
or "Byelorussian" as document language and hope that the Western symbols will
come out fine!

    

Here’s an example where a Russian text contains some English words - open
the image file Alphabets.tif if you want to try it for yourself!
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To mix other languages, simply select the language with the most extended
character set. If you have a document where the, say, French translation is placed
alongside an English text, you have to select French as language to ensure that
the accentuated characters such as ç, é and ù get recognized correctly.

DEFINING THE DOCUMENT CHARACTERISTICS

Now that the language is set, we’ll turn to the other document characteristics.
You can fine-tune the recognition by specifying some document features: the font
type and character pitch. Let’s clarify what this means.

First of all, indicate whether you are recognizing “normal” or dot matrix
printed documents with the command "Font Type" under the "Settings" menu.
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Setting this parameter correctly is mandatory: “draft” or “9 pin” dot matrix
symbols are made up of isolated, separate dots, and highly specialized recognition
routines are required to recognize them.

“Letter quality” dot matrix printing, also called “25 pin” or “NLQ” dot matrix,
requires the normal setting, as do the printing qualities typeset, typewritten,
laser printed and inkjet printed. Obviously, "Normal" is the default value.

The tooltip of the "Recognize" (and the "Auto") button indicates the selected
font type - normal or dot matrix.

The character pitch can be set with the command "Character Pitch" under
the "Settings" menu.

With fixed or “monospaced” fonts, all symbols of the font have the same
width. An "i" takes up as much horizontal space on a line as a
"w", as is the case in this sentence. Think of documents produced
using a typewriter, where the carriage moves a fixed distance for each typed
symbol.

A proportional pitch means that the width of a character depends on its
shape. Symbols like “m” and “w” are wider, take more horizontal space on a line
than the “thin” characters “l” or “j”. Virtually all books, magazines and newspa-
pers are printed in proportional pitch.

The simplest solution is to leave this option at all times on the default value
"Auto", which means that Readiris will detect the character pitch automatically.
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READIRIS GETS MORE INTELLIGENT EACH TIME!

When the document language is selected and document characteristics are
set, you can click the "Recognize" button (or the command "Recognize" under the
"Process" menu).

       

The OCR progress is indicated on-screen. You can click the "Stop" button to
abort the text recognition.

Readiris will enter the interactive learning phase at the end of the recognition
when the learning is enabled. Interactive learning is enabled by default.

Font training can substantially enhance the accuracy of the recognition sys-
tem. When the user tries to read distorted, defaced forms as are found in real
documents or stylized font shapes which Readiris does not recognize optimally,
training can overcome this temporary “failure”.

User learning is also used to train the system on special symbols which
Readiris is unable to recognize, such as mathematical and scientific symbols and
dingbats. Some examples: Readiris can be trained to recognize the "π" symbol as
"pi" or the dingbat "(" as "Tel". (However, the list of recognized symbols cannot
be extended with the symbols "π"and "("!)

How does this work? Learning is best understood in three steps: first of all,
determine whether you want to train the system on your documents or not. Sec-
ondly, once you've decided to make use of learning, determine if you want to limit
the learning to the current image. Only when you recognize similar documents
will you take the learning one step further: you will then perform training on
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several pages and use the font dictionaries created in this way on other docu-
ments.

Let's start with the first step: the interactive learning is enabled with the "Learn"
button (or with the option "Interactive Learning" under the "Learning" menu).
The "Learn" button is a toggle button: when learning is enabled, the button's back-
ground is dark, when learning is disabled, its background is white.

                

At the end of the recognition, Readiris displays the recognized text progres-
sively and the system stops on doubtful characters, or - if you are dealing with
touching characters (“ligatures”) - on doubtful character strings. They are al-
ways presented in their context, the doubtful characters are highlighted.

Unrecognized characters are by default represented by a tilde (the "~" sym-
bol). The “reject” character can be modified with the "Preferences" command
under the "Edit" menu.
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If necessary, enter a character (or character string) for the incorrect or un-
known shape and click one of the following buttons.

Learn
You agree with the proposed solution or correct it. The program saves this

doubtful character in the font dictionary as “sure”, final. Future recognition will
no longer require your intervention, the shape is considered learnt once and for
all.

In the example above, the system stops on a damaged character, and we click
"Learn" to accept a shape which cannot be confused with other characters.

Don't Learn
You agree with the proposed solution or correct it. The difference with the

"Learn" button is that the learnt symbol gets the status “unsure” in the dictionary.
For future recognition, the system will propose the “learnt” solution but still re-
quire a confirmation.

This button is used for symbols which might be confused with others: a de-
faced "e" which might be mistaken for a "c", a damaged "t" which closely re-
sembles an "r" etc.
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The "e" above is seriously damaged - in fact it is close to the letter "c", and you
should click "Don't Learn" so as not to confuse it with the symbol "c".

Delete
The displayed form is eliminated from the output. This button is used to ignore

“noise” on the documents - spots, coffee stains etc. - which might get recognized
as points, comma’s and what have you -, and to erase any other unwanted sym-
bol.

Undo
You go back to correct mistakes. You can undo the nine last decisions.

Finish
The learning process is aborted but the OCR continues in automatic mode. All

decisions by the system thereafter are accepted without user validation.
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Click this button when you see that the recognition is highly accurate and does
not require detailled proofreading.

Abort
Don't confuse "Finish" with the "Abort" button: with "Abort", no output is gen-

erated and you start all over, with "Finish", the text is created, it just isn't proof-
read in detail!

THE ROLE OF FONT DICTIONARIES

The results of such training sessions are erased after each page unless the
option "Clear on New Image" is disabled. This option is enabled by default, so, if
you want to train the system on several pages, you need to disable it.

But even when learning does extend the current page, all input from the user
is simply held in the computer’s memory! No font shapes are actually saved until
he uses the command "Save As" under the "Learning" menu. When he does so,
all learnt shapes contained in the RAM memory are stored in files called “font
dictionaries” for future use.
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The command "Open" of the "Learning" menu allows to load font dictionaries
back into memory.

The active dictionary is mentioned at all times in the title bar of the interactive
learning window! When no dictionary has been saved yet, the name "Untitled" is
used. Click the "Abort" button of the interactive learning in case you have loaded
the wrong font dictionary!

To erase the contents of the dictionary held in the computer's memory, use the
command "Clear".

Font dictionaries should be loaded into memory when you want to recognize
similar documents in order to make use of the extra intelligence they contain; in
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this way, Readiris takes into account the intelligence stored in these font libraries.
You could say that Readiris gets more intelligence each time you use it!

You can also append, complete existing dictionaries by loading them, perform-
ing extra learning and saving them again. (There's a specific command to allow
you to quickly save the current dictionary!)

Font dictionaries are limited to 500 shapes, and you are recommended to cre-
ate separate dictionaries for specific applications, for instance per type of docu-
ment. For clarity, you are recommended to give meaningful names to the font
dictionaries, for instance Report, Palatino etc. Training no longer has effect when
the dictionary is full: the results of the learning are no longer held in memory or
written to a dictionary.

SAVING THE RESULTS IN A TEXT FILE

The interactive training concludes the character recognition; you will be prompted
to save the OCR result to a text file. Just click "Save" for the time being.
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Click the "Format" button (or select the command "Text Format" under the
"Settings" menu) to discover the versatile output capabilities of Readiris.
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Readiris supports the file formats ASCII, RTF (“Rich Text Format”) and
HTML. The ASCII format is used by default. Note that the selected format is
mentioned in the title of the save window!

The option "Ask Name and Location" determines whether you are prompted
to save the recognized text at the end of the recognition phase.
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SENDING THE RESULT DIRECTLY TO YOUR APPLICATION

But we can also send the recognized text directly to our text application - as
an alternative to saving a text file and simultaneously with it. For instance, if
Microsoft Word functions as your target application, your wordprocessor will be
started up automatically at the end of the recognition (if necessary) and the rec-
ognized text will be inserted inside a new document.

The "Send to" feature offers a direct OCR link between your scanner and
your Mac OS applications. Readiris exports recognized documents directly to
any text-based Mac OS application - wordprocessors such as Microsoft Word,
spreadsheets such as Microsoft Excel, web browsers such as Microsoft Internet
Explorer, application suites such as AppleWorks and ClarisWorks and standard
Mac OS text applications such as SimpleText.

First of all, you can send the ASCII, RTF or HTML files to their “creator”.
Ensure that the creators are assigned appropriately under Readiris with the "Pref-
erences" command under the "Edit" menu. Actually, the Readiris installer detects
the creator of each filetype based on the applications installed on your computer,
but you are free to modify the assignments.

You are recommended to assign different applications to the various formats,
so that several applications become available as output targets.
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Note that the "Send to" option also allows you to copy the recognized text to
the clipboard, so there is no strict need to export the result to an application... or
save it to a text file!

Use the option "Add Item" to “declare” a application as a possible output
target; all “declared” applications remain so until they are removed again with the
option "Remove Item". Select "None" to disable the use of a target application
again.

When you send the recognized document to a target application, the text is
actually saved in a file before it is opened by the target application. Readiris uses
the Readiris folder for this purpose - unless you've specified an output folder with
the "Preferences" command under the "Edit" menu. (This occurs only when you
send the output to a target application - without saving it to a file with the option
"Ask Name and Location".)

Click the "Set" button to choose another folder as “temporary” folder.
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Concluding, Readiris offers several methods when it comes to saving the OCR
result: copying the result to the clipboard, saving the result in a text file, exporting
the recognized document promptly to a target application and even saving the
result in a text file and sending the recognized document directly to an applica-
tion.

RECOGNIZING MULTIPLE PAGES

After the OCR, the scanned image is redisplayed with the zoning as created
to be available for further processing, it stays there until you scan another page.

You can now open the recognized text with your wordprocessor, text editor,
import it into your desktop publishing software or any other text-based applica-
tion. You have indeed converted a paper document into an editable computer file,
be it up to 30 times faster than manual retyping! Go ahead and compare it with
the image you have inside your Readiris window.
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But how do you save the text of additional pages? Or in other words: how do
you process documents consisting of multiple pages? It's actually very simple: go
on recognizing pages, but enable the option "Append to File" when you are saving
to the same file!

When this option is disabled, you are warned that you are about to overwrite
the existing file: you can always click "Cancel" and enable the “append” mode
before you try to save again.
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ORGANIZING THE TEXT OUTPUT

Saving or exporting the text means more than selecting an output method -
saving a file, sending the output to a target application or the clipboard, or doing
both - or defining a filename for the output file. You also select a file format and
determine the appearance of the recognized text. In short, you have to decide
where you want to take the text before you launch the execution.

Some options of the "Format" button allow you to influence the look of the text
output.

The text flow of the output document is directly influenced by the option
"Merge Lines into Paragraphs".

Keep this option enabled to have Readiris detect the paragraphs: Readiris will
then apply the normal wordwrap typical of wordprocessors, otherwise, a car-
riage return is added after each line and hyphenated words remain so! Paragraph
detection is enabled by default.

Let’s give an example to clear things up. When the first three lines of a col-
umn are "The new presi-", "dent waved from the balcony." and "His wife had
joined him.", the paragraph detection gives you the following result: "The new
president waved from the balcony. His wife had joined him." The hyphenated
parts of the word "president" were “reglued” and a space was added at the end
of the first sentence, thus creating naturally flowing text.
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Had paragraph detection not been enabled, the original layout would have
been retained, with a carriage return added at the end of each line.

SETTING UP YOUR SCANNER

Let’s set your scanner up now. It is assumed that the scanner hardware and
necessary software are installed correctly on your computer system.

Actually, it’s all very easy: Readiris exploits the Photoshop “plug-in” or Twain
driver of each scanner to support it. In other words, as soon as there’s a Photoshop
“plug-in” or Twain module available for your scanner model, Readiris supports
it effortlessly!

In short, locate your scanner's Photoshop “plug-in” on your hard disk and
copy it to the Readiris folder, or create an alias for the “plug-in” in the Readiris
folder. Next, select your “plug-in” under Readiris with the option "Scanner" of the
"Preferences" command under the "Edit" menu.

To use a Twain driver, simply select it with the option "Scanner" of the "Pref-
erences" command.

The option "Hide User Interface" determines whether you will use the Twain
preview or not. The “interactive” mode of Twain is enabled by default. The
option "Invert" allows you to generate “inverted” images - this option is useful
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to process full pages with white text on a dark background. (These options do not
apply to scanners using the Photoshop “plug-in”.)

You are warned when Readiris is started up and no Photoshop “plug-in” is
detected by Readiris. You can choose to ignore this warning should you use a
Twain driver or should you exclusively recognize prescanned images - faxes you
receive electronically etc. (The option "Scanner" of the "Preferences" command
remains unavailable until your Photoshop “plug-in” or Twain driver is installed
correctly under Readiris.)

Go to the Readiris “Read Me” file or to chapter 1 of this manual should you
need further information.

SCAN ON!

Once the scanner is selected, you can acquire images. The scanner’s “plug-
in” or Twain driver is used to set the scanning resolution, the page format and
orientation, brightness and contrast. (The contrast setting is only available on
some scanners.)
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Which scanning options you dispose of depends on your scanner model. Refer
to the software documentation that accompanies your scanner.

Readiris supports black-and-white, greyscale and color images on an equal
basis, so you are free to choose the color mode that best suits your needs. To
include lineart graphics in the recognized documents, scan in black-and-white, to
include black-and-white photos, scan in greyscales, to include color pictures, scan
in color.

To limit the system requirements, Readiris processes 16 bit palette images
(65,536 colors) by default. It takes the "Preferences" command under the "Edit"
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menu to process “true color” images (16 million colors) or 8 bit images (256
colors or greyscales).

It goes without saying that greyscale and color images are slower to acquire
and require more RAM memory than “bilevel” images! When you increase the
color mode to true color, the required free RAM memory increases from 22 MB
to 32 MB!

Note that the image size and bit depth is mentioned on the Readiris status bar;
the status bar exclusively gives info about the actual image, never about its “re-
duced” version.

Scanning in greyscale and color isn't just useful to save the graphics with
sufficient quality, in some instances, it's also useful or necessary to obtain good
OCR results! When text is printed on a color background, scanning in color may
create the tone differences that are lacking in black-and-white images. When
there is only limited contrast between the text and the background, the back-
ground can create “noise” that renders the recognition difficult or impossible!

Think for instance of black text printed on a dark background: when you scan
such a document in black-and-white, you may not be able to “drop” the back-
ground color without losing the text information as well, as much as you may try
to adjust the scanner brightness...
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Readiris creates a black-and-white version for every greyscale and color im-
age. Thanks to its intelligent routines, even tough cases get solved - here's how
our “difficult” image gets binarized by Readiris!

To view a scanned image in black-and-white, disable the option "Display Im-
age in Color" under the "View" menu.
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Original images - be they color, greyscale or black-and-white - use color bor-
ders to indicate the window type; the black-and-white versions use “fill” colors.
With greyscale and color images, it would be a shame to mask the actual color
tones with a “fill” color! (The default colors are yellow for text zones, blue for
graphics and purple for table windows.)

Whatever your scanning mode may be, maintain a scanning resolution of
300 dpi. In all probability, this is not the default setting of your “plug-in”! Select a
resolution of 300 dpi for normal applications, use a higher resolution of 400 dpi for
small print (below 10 point) and when the document is very degraded.

Readiris reads point sizes of 6 to 72 point (0.08 to 1" or 0.21 to 2.54 cm).

Readiris also recognizes “drop letters”, large caps that cover several lines.
(These can of course be no bigger than 72 point!)

Whenever you need to adjust the page orientation, you can use the rotation
tools on the toolbar. (Corresponding commands are found under the "View" menu.)
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Three rotation directions are available: clockwise, anti-clockwise and upside
down. Rotation takes a few seconds as the image itself is updated, not just the
display on-screen.

SAVING DEFAULT SETTINGS

Set the program parameters correctly and click the command "Save As De-
fault" under the "Settings" menu to save the current settings, including your scan-
ner model, as default settings for future use.

When you quit the Readiris software and the settings were modified, you are
invited to save the current settings as default settings.

Settings files contain more than the scanner model: they also determine whether
you are going to use interactive learning, which language and font type - for
instance a normal, proportional font - the documents have, which output mode is
used - for instance send HTML texts to Internet Explorer - etc. In short, all
operational settings of Readiris are stored in the settings files.

SAVING SPECIFIC SETTINGS

The default settings will obviously be used at each program startup. To restore
the default settings without having to quit the Readiris software, use the com-
mand "Open Default" under the "Settings" menu.
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You can also save specific settings to avoid having to redefine the operational
parameters. The commands "Save As" and "Open" under the "Settings" menu
take care of this.

Let’s give an example: if you regularly have to OCR German documents, you
are recommended to create a settings file for this type of document. You would
then select "German" as the document language, disable learning because the
same typefaces are used systematically etc.

RECOGNIZING PAGES AUTOMATICALLY

Now that our scanner is set up, we want to get started capturing documents.
Instead of going through all the parameters, we'll execute automatic OCR, a
very comfortable way of recognizing pages.

Click the "Auto" button (or select the command "Automatic OCR" under the
"Process" menu).

        

As is the case with the "Recognize" button, the tooltip of the "Auto" button
indicates which read mode is enabled - normal or dot matrix.

We will now perform fully automatic OCR, that is we will recognize a page
immediately, without any interruption. Automatic OCR means that a page is suc-
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cessively scanned, windowed by page analysis or a zoning template and recog-
nized without interactive learning. All you have to do is initiate the scanning and
save the recognized text, the intermediate steps are handled by Readiris.

READIRIS RECREATES YOUR DOCUMENT LAYOUT

Automatic recognition, which renders the recognition process automatic, should
not be confused with autoformatting! “Autoformatting” means that Readiris rec-
reates a facsimile copy of the scanned document: the word, paragraph and page
formatting of your original document are applied.

Similar typefaces (serif and sans serif, proportional and fixed, normal and
condensed) are used as in the source document, the point sizes and typestyles
(bold, italic and underlined) are maintained across the recognition. The tabs and
the alignment (left, centered, right and justified) of each text block are recreated.
The placement of columns, text blocks and graphics follows your original docu-
ment.

In other words, Readiris allows you to archive a true copy of your documents,
be it a editable and compact text file instead of a scanned image!

All this implies that the sorting of windows only partially applies when
“autoformatting” is used: you can include and exclude zones, but any re-ordering
of zones is simply ignored!

Here’s an example of how it works. To get acquainted with this feature, open
the image Autoform.jpg which is found in the image folder.



2 - 47

USER'S GUIDE



2 - 48

Click the "Format" button, select the text format RTF (Rich Text Format) and
the layout option "Recreate Source Document". (The option "Merge Lines into
Paragraphs" is disabled by default.) Enable the option "Ask Name and Location"
to send the reading result to an RTF file or, if Microsoft Word is installed on your
computer, send the OCR result to Microsoft Word.

Note that layout reconstruction is limited to the RTF format - and indirectly to
target applications that support the RTF format adequately. A “poor” format
generating “plain” text such as ASCII does not support advanced formatting
codes and therefore cannot offer autoformatting. On the plus side, the RTF for-
mat is a widely used text format that can be opened by any popular wordprocessor.

When the recognized text is opened using a wordprocessor, the text looks like
this without any intervention by the user.
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To see the effect correctly, you need to enable the “WYSIWIG” mode of
your wordprocessor, mostly called “page layout” mode. However, if you send the
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recognized document directly to Microsoft Word, the page or print layout view is
activated automatically!

In short, Readiris not only recognizes your texts, but can format them for you
as well. OCR isn't just text recognition anymore, it is becoming more and more
page or document recognition as well!

TEXT FORMATTING, PART 2

The other layout options are "Create Body Text" and "Retain Word and Para-
graph Formatting".

Creating body text means you create a non-formatted, “running” text. The
text will be captured, but its formatting is entirely ignored. Use this option when
you just need to recapture a text but not its layout.

The option "Retain Word and Paragraph Formatting" represents the middle
road: the word formatting - font type (serif - sans serif, proportional - fixed,
normal - condensed), point size and typestyle (bold, italic and underlined) - is
retained across the recognition, and so is the paragraph formatting - the tabs
and the alignment (left, centered, right and justified).
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Don't confuse this formatting option with “full” autoformatting: this option just
puts one paragraph after the other, it does not recreate columns or copy the
relative position of the various zones.

SAVING GRAPHICS SEPARATELY

In our example, the graphic was included in the recognized text; whether this
is the case depends on the formatting option "Include Graphics". Saving graphics
inside the text is only possible with “full” autoformatting, not with a “poor” text
format such as ASCII.

Still, with Readiris, you can save graphics without performing text recognition.
As Readiris supports black-and-white, greyscale and color images, you can cap-
ture lineart graphics and photographs.

How? Draw a graphic zone around the illustrations, cartoons etc. you need.
Creating graphic windows manually is done in the same way as drawing text and
table windows, simply select the graphic window tool now.

Similar to the other window types, the tooltip of the graphic window tool tells
you how many graphic windows there are.

Next, choose the command "Save As" under the "File" menu and enable the
option "Graphics Only". You are prompted to specify a filename.

Determine which graphic file format you will use. Select a format that's sup-
ported by your paint or photo retouching software. A multitude of popular graphic
formats is available: the internal Readiris format (PICT), JPEG, Photoshop, PNG,
TIFF and Windows bitmaps (BMP).
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The graphics are saved in a single file. You don't have to limit yourself to a
single graphic, but if you draw several graphic windows, they will be collected,
“stacked” in a single file. (You can use the crop command of your paint or photo
retouching program to separate them.)

Sides smaller than 1 mm are not allowed - bitmaps of that size hardly contain
any information. “Irregular”, non-rectangular windows are allowed, and so are
several graphics. The surface not covered by your “complex” graphic zones
remains white. In the example below, two graphics zones - one in the left lower
corner and the other in the upper right corner - lead to lots of white space around
the actual graphics.

READING FAXES AND DEFERRED RECOGNITION

Saving images as image files opens another possibility: you can save the full
page and perform deferred OCR on it later on. That's what we did with the
prescanned images of our tutorials.

Simply scan a document and select the command "Save As" under the "File"
menu. You'll be prompted to save the entire page as a graphic file when you
enable the option "All". (Any windows you might have detected or drawn on the
page are ignored.)
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When you save a document as a JPEG file for deferred OCR, ensure that you
maintain sufficient image quality. JPEG files with high compression rates de-
grade the image quality - and the performance of your OCR software can suffer
as a consequence.

You can now open the image file with the "Open" button (or with the corre-
sponding command under the "File" menu). Or double-click the icon of a Readiris
image to load it into Readiris. Or still drop the image on the Readiris icon.

Color, greyscale and black-and-white images are supported on an equal basis:
Readiris allows you to open FlashPix images, GIF images, JPEG images, MacPaint
images, Photoshop images, PICT images (called “native” Readiris documents),
PNG images, QuickDraw GX images, QuickTime images, Silicon Graphics im-
ages, Targa images, (uncompressed, packbits and Group 3 compressed) TIFF
images and Windows bitmaps (BMP).

This capability is particularly useful to convert your faxes into editable text
files! If you have any influence over your correspondents, ask them to send faxes
with the “fine” quality - those faxes have the higher resolution of 200 dpi and will
yield better OCR results.

RECOGNIZING TABLES

So far, we've recognized texts and faxes and we've saved graphics. Let's
process a table now. Take a table of figures and scan it, or open the sample image
Table.jpg in the image folder.

Actually, the image Table.jpg contains two tables, and that's no coincidence!
The page analysis zones them as table windows, and Readiris will reconstruct
them for you by recreating the tables cell by cell in your spreadsheet or by insert-
ing a table object inside your wordprocessor files.
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Run the recognition with the layout option "Retain Word and Paragraph For-
matting" or "Recreate Source Document" enabled and the tables get recreated.
Open your wordprocessor to have a look at the result.
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Have a closer look at the “gridded” or “framed” table - the scanned table that
had borders around the cells. The cells and the borders were recreated by Readiris
one by one!

Let's concentrate on the “ungridded” table for a moment - it has no borders
around the cells. Note that the page analysis has nevertheless detected it. There's
another interesting aspect to this table: its content is purely numeric!

For optimal OCR accuracy of such tables, we can limit the recognition to the
numeric symbols with the "Language" button. (The numeric mode is not strictly
numeric, it includes the symbols 0 to 9, +, *, /, %, , (comma), . (dot), (, ), -, =, $ and
£.)

As you can only do this when the table doesn't contain any alphabetic symbols
- otherwise the text portions won't be recognized correctly - we can activate the
numeric mode only when we recognize this table but not the rest of the docu-
ment.

When we do so by selecting this table with the "Sort" button, we can send the
OCR result directly to the spreadsheet Microsoft Excel. Select HTML as text
format and Excel as target application with the "Format" button.
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The spreadsheet is started up and the typical table structure with rows and
columns gets recreated; you are immediately ready to process the data.
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You may come across “ungridded” tables the page analysis does not detect as
table zones because the columns are too widely spaced - Readiris tries to avoid
confusion with columnized text blocks. To create a table window manually, click
on the table window tool in the toolbar and proceed as usual; as expected, the
button's tooltip indicates the number of table windows.

    

GETTING PRODUCT SUPPORT

This concludes our overview of Readiris. To get product support, you can
contact I.R.I.S. by e-mail at the address support@irislink.com. Please describe
the phenomenon you experience clearly and include all relevant data concerning
Readiris and your computer system.

You can also find more information on Readiris on the I.R.I.S. web site
(www.irislink.com); the command "I.R.I.S. on the Internet" under the "Help"
menu takes you directly to the I.R.I.S. home page.
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