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“Anyone with a Macintosh will be fascinated with VideoWorks” MacWorlc 
The most Innovative product of the year, 1985. | MacUser! 

“The best computer program Ieveruseda!” FrankThomas, Disney animato! 
| “VideoWorks II is the best of the bunch” Alan Kay, Apple fellov 

VideoWorks II includes: 
¢ A slide show creator which can include 

animation or sound along with MacPaint or 
MacDraw documents. 

¢ Color capability, with up to 256 colors on the 
Macintosh II for stunning presentations and 
animations. 

- Acomplete paint program, including an Airbrush 
and Click Art EFX”, (which allows rotation, © 
perspective, distortion and skewing). 

e Art Grabber+, a desk accessory that lets you 
import and use MacPaint artwork without 
leaving VideoWorks II. 

- A graphic notational Score that allows you to 
edit up to 24 pieces of artwork on the screen at 
one time. Sound, tempo changes and transition 
effects can be added to the score with the click 

of a mouse. 

¢ Two disks full of clip animation, tutorials, 
completed movies and artwork that’s ready to 
be animated. Plus a Training Disk that guides 
you through all the basic features of 
VideoWorks II. 

Create slide shows that Pee in Metiation. sound 

and MacPaint or PICT documents. 

atl : 

othsnentoe ea 

VideoWorks II comes with a full paint program, a 
text editor and lots of artwork and animations. 

VideoWorks II uses: 
e Animated business presentations. 
Rolling in-store promotions & point-of-purchase displays. 
Multi-media storyboards for professional productions. 
Instructional & educational animations for classroom use. 
Animated cartoons, music videos-a tool for the creative artist. 
Video animations for cable or industrial video. 

OOK BOOCOOO 
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UTHEAST| 
ee You don’t have to be an artist to use VideoWorks II 

a Videoworks Aaa a ed oe ce No need to create your own drawings! VideoWorks II 
; Uu 1C e e ° e 

Me ee pcs and dissolves. comes with an abundance of artwork, clip animation 
and completed movies. Just copy the artwork or 
animation from the disks supplied with the program. 

ideoworks II is for the Macintosh 512, | Distributed by Bréderbund Softwar 

12e, Mac Plus, SE and Macintosh II. | VideoWorks || ©1987 MacroMind? Inc. 
Macintosh and MacPaint are trademarks 

of Apple Computer. 

MacroMind’ Inc, 
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Unauthorized reproduction of VideoWorks™ II 

may be a criminal offense under federal or state laws. 

Copyright 1985, 1987 MacroMind®, Inc. 
All rights reserved worldwide. 





VidedWorks If 
Clip Animation, 

Artwork & Movies 
| Unauthorized reproduction of VideoWorks™ TI 
may be a criminal offense under federal or state laws. 

|Copyright 1985, 1987 MacroMind®, Inc. 
All rights reserved worldwide. 





‘Unauthorized reproduction of VideoWorks™ TI 
may be a criminal offense under federal or state laws. 

Copyright 1985, 1987 MacroMind®, Inc. 
All rights reserved worldwide. 





Overview Reference 
Icons, Typical Sequences and Shortcuts 

Bar —e 

Bia 9} —Ee Organization: Overview Documents are played left to right. Documents are 
pS I aoe oe arranged in columns and rows. Everything in a given column is 

played at the same time. The Playback Head shows what column 
is currently being displayed. While Movies, Transitions and 
Timers can appear anywhere, PICT, GLUE or MacPaint 
documents can only occur in the top row. 

A simple Overview sequence of a MacPaint, 

PICT, and VideoWorks I] document. 

The row determines the priority of adocument. Documents in the 
second row appear in front of documents in the first row. 

Tek 

title annotation 

Window Holding down the Shift key while selecting the Play command will 
Man agement: clear the screen and start the presentation. You can open and 

close the Overview window by choosing command-3. 

A VideoWorks II document plays in front of 

a MacPaint document. The column uses the 

time of the Movie ('M’'). A reveal transition 

into a PICT, (with it's own timer) then occurs Get Info: Each Icon has a Get Info window. Use it for setting the position of 
any slide or movie, the special timing or repeat options of a 
movie, and the page number of a GLUE document. 

M 2 F : 

Ths Tos S “Ta s Shortcuts: Click on Stage = Step to next column 
So a a | fae a Double-click Icon = Get Info 

Begin 0,16 ny 0,16 Bullet Chart Shift-Play fe Play to full screen 

2) seme: Shift-Step = Repeat current column 
2 ee | Click on Playback Head = Displays that column 

eae: Command-Click = Select whole column 
073 Fi 

Foreground 

Timers: A timer sets the number of seconds that all columns after it wil 
play (until the next Timer is encountered). The time that a given 
column will play is shown above it in the Time Bar. 

Timers can be placed in any row. More than one 

VideoWorks I] document can play at the same 
time. as, 

VideoWorks || movies usually have their own time information and 
_ do not obey timers. This is indicated by the "M" above their 

ees . columns. VideoWorks || movies can, however, be adjusted to 
vn obey the current timer by using Get Info. 

, 16 Sales Chart The End 

a. ee 3: Transitions: A transition can be placed between any two document types. The 
Geol oe ete two numbers below a transition indicate the Delay before starting 

) each chunk and the Chunk Size. Increasing either of these 
values (using the Get Info command) lengthens the transition 
time. 

Sound icons can be used to accentuate slides, and PICT 

VideoWorks || documents can be used add titles, MacPaint 

captions or moving arrows. 

VideoWorks I Timer Overview 
GLUE Sound Transition 

Background Bullet Chart 10,5 ‘88 projections The End 

Cj Be 92 
3 Pres. Rane tatibn Movie Theme 

9= we 
= Drag Panel by clicking in gray area 

Pastoral 

You can insert pre-existing Overview documents GLUE is a trademark of Solutions, Inc., MacPaint and MacDraw are registered trademarks of 
Apple Computer, Inc., VideoWorks II is a trademark of MacroMind, Inc. 

into a presentation. © 1987 MacroMind, Inc. 



The Panel 

Playback Controls Record Light 

ee : chapel Indicator 

Light | \ \ 2 Indi Switch Sound Speed Frame ange Indicators 

Switch — Control Counter 

The Score 

S222. 6c] S=== 

Display 

buttons TTT A: 
Silas ollablesaliaameecel CELL NEEL 

Sound SPE EE EEE ean ae 
channel POT 

PPEEECLELEEECEP ECC EECEG LE CES E LE 
Se ee er 

Animation 

channels 

Score zoom Playback head Frame numbers 
Jump 
button 

The Paint Window 

(O| Easel Tool St3| ‘Rotation Tool 

‘FalBits Slant Tool 

| Paint Brush Bae) 

| Pencil #2] Distortion Tool 

Eraser Registration Point 

Text Tool Flop Horizontal 

(| Square Tool Flip Vertical 

(} Circle Tool agenes 

Line Tool Selected Bank in Cast 

iby Paint Bucket 

Air Brush 

a Marquee 

Lasso 

Ink Indicator 

VideoWorks ll: VideoWorks Reference 
Panel, Score, Paint and Cast Windows 

The Cast 

Cast 

Member 
Pointer Text Box Line Tool 

Tutorial #1 Cast 

Castmember number Box Tool Rounded Circle Tool 

Box Tool 

Score Display Buttons 

Direction Indicator Button 

Top portion of display shows castmember change: 

New castmember introduced 

i Castmember unchanged from previous frame 

Bottom portion of display shows direction moved 
from last frame: 

A Stop Right 

: 
Left 

Down 

Ink Setting Button 

Letter indicates what the Ink setting Is: 

- Copy - Not Copy la Matte 

Not Or Mask 

Not Xor H+ No Erase 

Up and to the right 

.| Up and to the left 

Down and to the left 
ca 

. Down and to the right 

Castmember number Button 

ag The top number is the cast row # and the 

bottom number the position in that row. 

Extended Display Button 
B = Bitmap 

Q = Quickdraw 
got = re 

Castmember 

Number 

Direction Indica ae 

Changed Castmember —+ 

Ink Setting —+ 

Change in A - 
X&Y Coordinates 

E 
5 
Py 
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MACROMIND” PRESENTS 

A NEW DOUBLE FEATURE 
FOR VIDEOWORKS II” 

ith VideoWorks IT you can turn ordinary 
presentations into “multi-media 
extravaganzas” on your Macintosh. 

Even if you’re not an artist, it’s easy to add the excitement of 
animation to your presentations, thanks to VideoWorks II's 

library of clip sound and animation. 

Now here are two great add-ons that add 
new versatility to your sages VE ngedwvor® 
Video Works IT movies: vider 

VideoWorks Il Accelerator 

VideoWorks Il 
HyperCard* Driver 

Accelerate your movies to maximum speed. Take any 

Video Works I movie and run it at up to 40 frames 

per second, 
HyperCard extends the potential 

of your Mac. And this program ex- 
tends the capabilities of HyperCard! 
With one simple command, it lets & 

sou play VideoWorks I movies with- : ~ you play “ae 
out leaving HyperCard: 

m Accelerate and smooth the animation of large and 

complex images which normally would run slowly 

in VideoWorks IL. 

idecPiorg = Use it with color as well as 

= Animate directly on top of black and white movies. 

HyperCard or in a separate window. = Play sound as well as video 

es Enjoy full-screen animation (you're and retain tempo changes. 

not limited to card size.) = Run any length movie (only 

mExercise options to reposition or pre- limit is disk space). 

load animations. Requires VideoWorks II 

=Play color or black and white movies. Suggested retail price $195.00 

Requires VideoWorks I! 

Suggested retail price $99.95 

a Products from MacroMind® Inc. are distributed by Bréderbund Software, Inc. To order, contact your 

Distributed By local Brgderbund Software dealer or call Bréderbund at (800) 527-6263. Outside United States (415) 
492-3200. 

©1988 Bréderbund Software, Inc., 17 Paul Drive, San Rafael, CA 94903-2101. All rights reserved. 

Braderbund’ VideoWorks II is a trademark of MacroMind, Inc. HyperCard and Macintosh are registered trademarks 

of Apple Computer, Inc. 
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Put Your Ideas Into Motion. 
Sally 

Ideas have always had tremen- 
dous power in moving people. 

Now MacroMind® makes 
it possible for people to exer- 

cise tremendous power in 
moving ideas. 

VideoWorks II™, along with its 
family of utilities and accessories, 

brings professional-quality ani- 
mation to the Macintosh™ Instead 

of having to rely on expensive 

and time-consuming outside 

resources, you can become 
the producer and director of 

your own animated, multi- 

media presentations. 
Marketing presentations, 

training materials, demonstra- 

tions and storyboards can all be 
enhanced and brought to life by 
the use of any or all of the multi- 

media features available with 
VideoWorks II and Macintosh. 

Animation in color or black & 
white, with or without sound, is 
a tool you can now utilize both 
economically and quickly with 
professional quality results. 

If your business depends on 
getting people to move on your 

ideas, it can be worth your 

while to put your ideas into 
motion—with MacroMind 
and VideoWorks II. 

VideoWorks II* 
The program that 
brought animation to 
the Macintosh user. 

With VideoWorks II, you 
create animated slide 
shows from McPaint, PICT 
or Glue documents, then 
add clip animation and 
sound for a true multimedia 
presentation. 
VideoWorks II features 

advanced animation 
techniques, text editing, 
graphic tools, color 
printing, a database for 
artwork, and digitized 
sound. 

It comes with everything 
you need to learn and use 
it: an interactive guided- 
tour disk, a comprehen- 
sive manual, tutorials, clip 
animation, artwork, movies 
and sounds. 
A full line of utilities and 

accessories is available for 
VideoWorks II. 

MideoWorks 
Presentations for the Office, School or 
aA ERAN TAR INE GS HON GME IR esa ee 

1028 West Wolfram 
Chicago, Illinois 60657 
312.871.0987 

.MacroMind Tne. 

VideoWorks Il 
Utilities 

HyperCard™ Driver— 
Apple provided the 
vehicle. MacroMind lets 
you drive it. 
With a single command, 
you can play any Video- 
Works II document inside 
Hypercard! 

Professional-quality 
sequences can be ani- 
mated directly on top of 
HyperCard, in a window or 
across the entire screen, in 
color or black & white. By 
combining VideoWorks II 
and the Hypercard Driver, 
you can now create 

Stackware™ with ani- 
mation, graphics and 
sound. 

Accelerator— 
Accelerate your ideas 
to the speed of your 
imagination. 
You can accelerate any 
VideoWorks || document 
easily. 

Accelerator takes an 
animation and speeds it up 
to near digital-video quality. 
It works with color or black 
& white movies, and plays 
sound along with the 
animation. 

VideoWorks I!, Clip Animation, Clip Charts 
and Clip Sounds are trademarks of MacroMind 
Inc. HyperCard, Stackware and Macintosh’ 
are trademarks of Apple Computer, Inc. © 1988 
MacroMind Inc. 

Salesperson 
of the month! 

VideoWorks Il 
Accessories 

Clip Animations™— 
Enhance your presen- 
tations with graphics 
that move. 
You don’t have to be an 
artist with these ready- 
made animations. Images 
shimmer, fade and tumble 
to get your message 

across. 

Clip Sounds™— 
An array of digitized sound 
effects and music. 
Create exciting presenta- 
tions by adding sound 
effects and music. In- 
cludes a program which 
moves sounds into Video- 
Works II and HyperCard. 

Clip Charts™— 
Bar, pie, line and bullet 
charts; pick a style. 
Show industry trends or 
company sales figures with 
ready-made animated 
charts and graphs in more 
than 30 styles. 

Black & White 
Movies— 17 of them, an 

intriguing variety. 
Our artists have created an 
exciting range of animation 
in these movies. You can 
combine movies into your 
own presentations or enjoy 
them for themselves. 

*VideoWorks II was a 1987 winner of 
the MacUser Golden Eddy Award 
and Best Creativity and Best Ver- 
tical Market Product, 1987, from the 
Software Publishers Association . 
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VIDEOWORKS II Manual 

© MacroMind,® Inc. 1987 

The VIDEOWoRKS II program and manual are copyrighted by MacroMind,® Inc. © 1987. 

The photograph on the cover of the box was produced by photographing VIDEOWoRKS II running on the 
Macintosh II with a SuperMac Spectrum monitor. Art by Stuart Sharpe, photograph by Roger Jones. 

MacroMind, Inc. 

1028 W. Wolfram 

Chicago, IL 60657 

(312) 871-0987 

Trademarks 

VideoWorks IH, VideoWorks Interactive, Sound-to-Video and Music-to-Video are trademarks of MacroMind, Inc. Glue, 
ImageSaver and Viewer are trademarks of Solutions, Inc. Macintosh, LaserWriter, MacWrite, MacPaint and MacDraw are 

trademarks of Apple Computer, Inc. PageMaker is a trademark of Aldus Corp. FullPaint is a trademark of Ann Arbor 
Softworks. SuperPaint is a trademark of Silicon Beach Software. Excel is a trademark of Microsoft Corp. More is a 
trademark of Living VideoText, Inc. GraphicWorks is a trademark of MacroMind, published by Mindscape. Easy3D is a 
trademark of Enabling Technologies, Inc. Thunderscan is a trademark of Thunderware, Inc. Art Grabber+ is a trademark of 
MacroMind, Inc. MusicWorks is a trademark of MacroMind, Inc. Illustrator is a trademark of Adobe, Inc. Cricket Graph is 
a trademark of Cricket Software. Click Art Effects is a trademark of Bill Parkhurst. 

MACROMIND'S LIMITED NINETY-DAY WARRANTY 

MacroMind warrants for a period of ninety (90) days following the original retail purchase of this copy of VideoWorks II that the program is free 
from substantial errors or defects that will materially interfere with the operation of the program as described in the enclosed user documentation. This 
policy applies to the intitial purchaser only. 

If you believe you have found any such error or defect in the program during the warranty period, call MacroMind's Technical Support 
Department, (312) 871-0987 between the hours of 9:30 a.m. and 5:30 p.m. (Central Standard Time), Monday through Friday. MacroMind technical 
personnel will attempt to help you correct or avoid the problem, but will not provide consultation. If any such error or defect cannot be corrected or 
reasonably avoided by you, MacroMind will inform you how to obtain a corrected program disk. 

Disk Replacement Policy 

If any disk supplied with this product fails within ninety (90) days of purchase for any reason other than accident or misuse by the customer, please 

retum the defective disk together with proof of purchase to MacroMind Inc., 1028 W. Wolfram, Chicago, IL 60657, for a free replacement. This policy 
applies to the initial purchaser only. 

MacroMind will replace program disks damaged for any reason, whether during or after the ninety (90) days free replacement period, for $5 per 
disk plus a postage and handling charge of $2.50 per request, as long as the program is still being manufactured by MacroMind. 

Limitations on Warranty 

Unauthorized representations: MacroMind warrants only that the program will perform as described in the user documentation. No other 
advertising, description, or representation, whether made by a MacroMind dealer, distributor, agent, or employee, shall be binding upon MacroMind or 

shall change the terms of this warranty. 

IMPLIED WARRANTIES LIMITED: EXCEPT AS STATED ABOVE, MACROMIND MAKES NO OTHER WARRANTY, EXPRESS OR 
IMPLIED, REGARDING THIS PRODUCT. MACROMIND DISCLAIMS ANY WARRANTY THAT THE SOFTWARE IS FIT FOR A PARTICULAR 
PURPOSE, AND ANY IMPLIED WARRANTY OF MERCHANTABILITY SHALL BE LIMITED TO THE NINETY (90) DAYS DURATION OF 
THIS LIMITED EXPRESS WARRANTY AND IS OTHERWISE EXPRESSLY AND SPECIFICALLY DISCLAIMED. SOME STATES DO NOT 
ALLOW LIMITATIONS ON HOW LONG AN IMPLIED WARRANTY LASTS, SO THE ABOVE LIMITATION, MAY NOT APPLY TO YOU. 

NO CONSEQUENTIAL DAMAGES: MACROMIND SHALL NOT BE LIABLE FOR SPECIAL, INCIDENTAL, CONSEQUENTIAL, OR 
OTHER DAMAGES, EVEN IF MACROMIND IS ADVISED OF OR AWARE OF THE POSSIBILITY OF SUCH DAMAGES. THIS MEAN THAT 
MACROMIND SHALL NOT BE RESPONSIBLE OR LIABLE FOR LOSS OF PROFITS OR REVENUES, OR FOR DAMAGES OR COSTS 
INCURRED AS A RESULT OF LOSS OF TIME, DATA, OR USE OF THE SOFTWARE, OR FROM ANY OTHER CAUSE EXCEPT THE ACTUAL 
COST OF THIS PRODUCT. IN NO EVENT SHALL MACROMIND'S LIABILITY EXCEED THE PURCHASE PRICE OF THIS PRODUCT. SOME 
STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE 
LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU. 

For technical support (which is good for ninety days from receipt of registration card) on this or any other MacroMind product, call (312) 871-0987. 

Contents 
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Foreword 

Congratulations, you've just purchased an exciting, powerful product to make your Macintosh do 
more than you ever imagined! I would also like to personally thank you, and wish you hours (and 
days and weeks) of fun, relaxation and professional fulfillment with VIDEOWORKS II . 

Animation is one of the most amazing feats of modern day technology. Some of our earliest 
memories are of Mickey, Betty Boop or Popeye, but more importantly the Pentagon's or 
Kremlin's Star Wars technology is also brought to life with animation. And let's not forget the 
big three Networks’ or Madison Avenue's use of animation on television, or of the educational 
aspects of animation (beyond cartoons). It's clear to see that animation touches all of our lives in 

one way or another. 

Animation really can change the way we perceive things, but it's only a small part of a larger 
category called creativity tools. The creativity tool business has always been a subset of the 
videogame, or what's called the home productivity business. On the professional side, computers 
have become commonplace in the television, radio, music and advertising industries. We are 
trying to get the message out to the businessmen (and women) of the world that creativity is an 
important part of everyone's lives, and that it is necessary in every type of business or profession. 
Creativity tools can help in the development of ideas, by just providing an outlet for the mind. By 
simply drawing a picture or composing a song, the average worker (or student) will not only be 
able to increase their own self esteem, but also tap into the inner talent which has been inside of 

them their entire life. 

MacroMind was born in 1984 to produce easy to use, powerful software. When we got into doing 
animation software, it became immediately apparent that it wasn't going to be easy to make cel 
animation accessible to everyone. We were worried that kids would find it intimidating and that 

the complexity of the ges process _— overwhelm them. EEE uk EEE kk EE 
It turned out that the ones who had trouble learning VideoWorks weren't the kids or young people, 
it was the adults who found the concept of an animation stand or cel animation so foreign to them, 
that it took them awhile to learn the product. Even getting people to try out VideoWorks became 
a chore, with some people ending up just using it as a playback device for-all the movies we 
supplied. 

We were faced with fundamental questions: how to keep the power of VideoWorks intact, while at — 
the same time making it easier to use, and more accessible for beginners. This led to the birth of 
the Overview window. 

Icons, rather than words, are better at representing bunches of things. The original VideoWorks 
linked together a list of movies by typing the names of the movies into a list. Now with the 
Overview window, you line the icons of the movies up, starting from the left and going right. 
This starts people thinking how time moves from left to right, and about how they can cut, copy 
or paste sequences of events, 

The Overview window will enable beginners to take advantage of VIDEOWORKS II from day one, 
while at the same time giving more experienced users a powerful new way to view movies, create 

Welcome 7 



complex sequences and link together different types of documents under one "shell" program. It — 
also enables us to introduce a new concept to the world — clip animation. By placing a clip 
animation in front of a "slide", a designer can quickly spiff up a presentation with something that 
moves. This will prove useful in keeping people awake during long drawn-out meetings. The 
Overview window will also enable educators to annotate lessons with animated examples, on top 
of conventional courseware. 

We've also added a number of new features to VIDEOWORKS II that increases it's capability as an 
animation program. Special effects, more control, automatic in-betweening and improved sounds 
all are now possible with VIDEOWORKS II . 

By enhancing the the overall capabilities of VideoWorks, and including the Overview window, I 
feel that this product should give you enough depth and quality to keep you busy for years to 
come. : | 

The world of VIDEOWoRKS II includes using any (or all) of the many graphics products available 
today. Video digitizers, page scanners, paint programs, clip art, 3D drafting, etc. all are 
compatible (and welcomed) within VIDEOWORKS II. The Overview in particular will serve as a 

_ handy way to view (or preview) any MacPaint or PICT documents you may have. We also think 
that's it a great way to view Glue documents. 

It's been over two years since the original VideoWorks was released. MacroMind is now 
publishing VIDEOWORKS II under our own label. With this new arrangement also comes a more 
comprehensive approach in providing the technical support, product enhancements and training 
necessary to really turn VIDEOWORKS II into an industry. You can expect more powerful versions 
of VideoWorks in the future, in addition to a full-scale training and seminar program. 

Some people might know us as the folks who created Art Grabber or Maze Wars+. Or as the guys 
who did ComicWorks and GraphicWorks. Or as the pioneer Mac developers who got MusicWorks 
out by October 1984, and three other products out within the next year. MacroMind has been 
pounding away at the Mac market for some time now, and we intend on maintaining that tradition 
by developing only high quality and innovative products for the marketplace. 

The introduction of the Macintosh II is a major milestone in the development of both MacroMind 
and the Macintosh community. It's been pretty silly for us to have an animation program on a 
microcomputer that had a black & white monitor and couldn't record on videotape. 
VIDEOWORKS II can take advantage of any color monitor, screen size or resolution available on a 
Macintosh II. As time goes on, you will see many new products from MacroMind that take 
advantage of the color capabilities of the Macintosh II. 

As the Nubus becomes a standard for professional quality graphics, audio, and video hardware 
_ technology, we intend on providing the software to take advantage of these cards. It's exciting to 
project ahead a couple of years (it's July 1987 right now) and realize that a very powerful home (or 
office) integrated multi-media studio will be able to reside inside of your Macintosh II. 

It's not a coincidence that VIDEOWoRKS II is being released at the same time as the Macintosh II, 
and that we've got some other products with names like Art Grabber II and M.U.D. I. (Hmmm, 
maybe we should rename the company MacroMind IL...) : 

The Macintosh is the most fantastic computer ever created (even if my initials weren't MAC : 
Marc Aaron Canter)! I just hope that Apple will continue to improve the Macintosh family of 
computers to give developers (like us) a great platform to build on. 

Marc Canter 
Chicago 

July 1987 



Welcome 

You're about to experience a whole new way to use your Macintosh. Instead of just looking at a 

chart or document on the screen, you can create moving presentations with movies, slide shows 

and clip animation that really bring your Macintosh to life. With VIDEOWORKS II, you can start 

out at the simplest level, creating a slide show, and work up to creating full-blown, detailed 

movies with sound. Animated presentations, multi-media storyboards and educational movies are 

all possible and well within the capabilities of VIDEOWORKS II. 

Watch All the Movies 

If you are anxious to see the movies we've included, don't wait any longer. Start your system with 

the Systems, Program & Tutorials disk, then insert the Clip Animation, Artwork & Movies disk 

into an external disk drive and, at the Finder, double-click on the document titled "Movie Show." 

When the document has loaded, call your friends over, press Shift-Enter, lean back and watch. 

This presentation will show you all the movies on that disk (which is everything but the 

tutorials). To stop the movies at any time, press the period (.) key. _ 

If you are not an experienced Macintosh user, we recommend you jump to Tutorial #2 and follow 

the steps to watching the "Movie Show." 

About This Manual 

This manual contains three main parts: 
Tutorials 
How to Animate 

Reference 

Tutorials teach you Overview-how to create slide shows and animated presentations. Then they 

teach you VideoWorks—how to create and combine artwork into movies. 

How to Animate is the major part of this manual. It covers all steps in producing Overview 

and VideoWorks documents, complete with step-by-step procedures. 

Reference describes all VIDEOWORKS II commands, windows and hidden features. The | 

commands are arranged in the order that they appear on the pull-down menus. Hidden features are 

important features that are not found on any menu or in any window. 

Guided Tour Disk — The quickest way to get up and running is by running the Guided Tour 

disk — see "Guided Tour of VIDEOWORKS II ," at the start of "Tutorials." This training disk lets 

you interact as you learn. After that, you can dive into the tutorials to get step-by-step 

instruction. 

VIDEOWORKS II has its own terminology unlike word processing, spreadsheets or data processing. 

For instance, each movie is represented notationally by a Score with channels and frames. See the 

sections on Overview and VideoWorks terminology at the start of "How to Animate" and the 

Glossary at the end of the manual. 
If you have unbridled curiosity and want more depth, you can always jump into the Reference 

section for details on any window or menu item. Refer to "How to Animate" if you want more in- 

depth information than the Tutorials or reference can give. 

The Process of Animation — Be sure to read "The Process of Animation," located at the end 

of "The Big Picture." This is a two-page description that serves two purposes: First, it will give 

you an overall understanding of the product. Second, having read it, you will understand how this 

manual is structured. ("The Big Picture" serves as the outline for "How to Animate.") 

a 
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About The Disks : 

VIDEOWORKS II provides you with three 800K disks: 

e VIDEOWORKS II System, Program and Tutorials 

¢ VIDEOWORKS II Guided Tour : 

¢ VIDEOWORKS II Clip Animation, Artwork & Movies 

System, Program & Tutorials Disk contains System 4.1, the VIDEOWORKS II program, 
and the Tutorial files (numbered #1, #2, #3, etc.) for the tutorials in the front of the manual. 

Guided Tour Disk contains a self-starting, self-running demonstration of VIDEOWORKS II. 

Clip Animation, Artwork & Movies Disk contains many pieces of art and animation that 
you can use in your own movies and presentations. From now on throughout this manual we will 
call this the Movies Disk. 

More Movies, Clip Animation, and Artwork Disks Coming! 
MacroMind will be offering a number of ancillary products to complement VIDEOWORKS II. 
These products will include disks of: 

¢ Clip Animation (for inserting in front of slides in Overview) 

e Artwork (which can be used to create animated sequences) 

* Sound (which can be included in any movie or in Overview) 
¢ Movies (which are standalone entertaining animations, complete with their own sound) 

Watch for these great products in the upcoming months. Ask for them at your local dealer. 
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Getting Started 

To use VIDEOWORKS II, you need: 

¢ A Macintosh computer with 512K or more memory 

¢ One double-sided (800K) disk drive 

or two single-sided (400K) disk drives 

or a hard disk 

¢ Extra disks for saving your documents 

Starting VIDEOWORKS Il 

The first time you start up VIDEOWORKS II , you will have a chance to personalize the diskette. 

This will make it easy for you to distinguish your copy from those belonging to other people. 

To start VIDEOWORKS IT: 

1. Turn on your Macintosh. 

2. Insert your copy of the VIDEOWORKS Il System, Program & Tutorials Disk 

into the internal disk drive. 

3. Double-click on the VideoWorks Il icon: 

VideowWorks II 

This starts VIDEOWORKS II . If this is the first time this program has been started, a dialog 

box will appear, for you to type in your name and organization. 

4. Type in your name, hit the Tab key and type in your organization name. Then click OK. 

VIDEOWORKS II starts and a new VideoWorks document opens. 

Note About Printing: The printer files (ImageWriter and 

LaserWriter) are not included on the System, Program & Tutorials Disk. 

If you are using two floppy drives (no hard disk) and if you want to 

print, you will need to move the System, VIDEOWORKS II program and 

printer files all onto the same disk (as described next). 

There are two ways you can create a disk for printing: 

¢ Copy VIDEOWORKS II onto a System disk that contains printer files 

—or— 

° Move the tutorials off the System, Program & Tutorials Disk and copy the printer files onto 

that disk. In this case it is imperative that you copy the System 4.1 printer drivers and not 

the drivers for an earlier system (such as System 3.2). 

400K Disks 
If you require 400K disks, you can go to your dealer and have your 800K disks copied to 400K _ 

disks. Or you can send in the coupon at the back of this manual along with your 800K disks and 

$25 to MacroMind, Inc. And we will send you 400K disks to run VIDEOWORKS II. The 

minimum practical configuration is two 400K drives. | ue) RE oR KE RE RK URE GRR GRRE RE GREK REA Ue 
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Starting a VideoWorks or Overview Document 
We have shown you one way to start VIDEOWoRKS II . There are basically two ways you can start 
it: 

To start VIDEOWORKS II and: Double-click 

1 Ge 
Create a new VideoWorks iss 
or Overview document Video wark= fi 

Open an existing document : 5 
VideoWorks Docurnent Overview Docurnent 

The first time you double-click on the VIDEOWORKS II program icon, VIDEOWORKS II starts up 
in Overview. Thereafter it will start up in the last application you left — either VideoWorks or 
Overview. 

Copying VIDEOWORKS Il 
VIDEOWORKS II is not copy-protected. This will allow you to work with VIDEOWOoRKS II easily. 
But please remember that the creators of VIDEOWORKS II , MacroMind are relying on you to not 
give away copies to others. They have spent a lot of time, effort and money to bring 
VIDEOWORKS II to you. The only way they can continue to provide software like this is if you 
respect the copyright laws. 

You should, however, make a backup copy of VIDEOWoRKS II for yourself. Do this soon after 
personalizing your copy of VideoWorks. 

1. Make one copy of the original VIDEOWORKS Il System, Program & 

Tutorials Disk. Do this by dragging the icon of that disk onto the icon a 
the blank disk to which you are copying. 

2. Use the same procedure to copy the other two disks. 

Use the copies in your daily work. Keep the originals in a safe place where they will not be 
damaged. 

Technical Details 

12 

System 4.1 vs. System 3.2 
We have provided System 4.1 with VIDEOWORKS II to take advantage of hierarchical menus for the 
Sound and Text menus. VIDEOWORKS II will run just as well under System 3.2 without 
hierarchical menus. See "Sound Menu" and "Text Menu” in "VideoWorks Reference" for more 
details. 

Getting Started 
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Freeing Up Disk Scace. 
You can free disk space by moving all unneeded files and fonts from your copy of the 
VIDEOWORKS II disk. 

¢ Remove Tutorial Files. When you have finished the tutorials in this book, move the 
tutorial documents to another disk. (They are the files that begin with #1, #2, #3, and so on.) 

e Move Fonts. Use the Font/DA Mover (supplied with your Macintosh) to move fonts a 
you don't use out of the System (and, hence, off the disk). 

e Remove or Reduce the Custom Sounds File. If you are not using Sound, remove 
the Sounds file. If the Sounds file has custom sounds that you are not using, remove them 
using the Sound-to-Video utility. 

e Remove the Macintalk File. If you aren't an speech, remove this file. 

You can also save disk space by reducing the size of VIDEOWORKS II movies. See “Hints, Tips 
and Tricks" earlier in the Reference section. Briefly, you can save space by making artwork as 
small as possible and replacing Paint artwork with QuickDraw shapes where possible. 

VW Preferences File 

For your information, when you first use VIDEOWORKS II, a file called VW Preferences is 
automatically created in your System Folder. This file stores the settings that you specify in the 
Preferences dialog box (available at the Control menu in VIDEOWORKS II). It also includes other 
information, such as whether you last worked in VideoWorks or Overview (this enables the 
program to start up in the application where you left off). 
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Macintosh Terminology : 
Here is a list of some Macintosh terminology you should know for the Tutorials. Refer to your 
Macintosh Owner's Guide for more details. 

To Overview 

OD CHEEZ Bi2 3 Mouies 
ie 

Se ccccerenconsonccecnas svssceeaccnsecenesceensoses 

O DANCE FEUER 

D EL CAMINO RERL 

D LOGO 
O PERCAR 
D RADAR LUD 4 
[ SEA HUNT & 

oc ceoceoacececcosconses ssroesascccecesscenceossces 

A menu A dialog box The pointer 

Pointer The very tip of the pointer is its active part. When you are told to "move the pointer to 
the box," you need to place the tip of the pointer in the middle of the box. 

Click means to briefly press and release the mouse button. 

Double-click means to click twice, quickly. If your clicks are too far apart, they will be 
interpreted as two single clicks. You can adjust the speed at which you must double-click by 
choosing Control Panel at the Apple menu. 

Drag means to press down the mouse button and hold it down while moving the mouse. For 
example, you can drag objects around on the Stage; and in the Score you can drag the pointer 
across frames to select them. 

Select an object means to highlight that object so that you can move, cut, copy or paste it. For 
example, you can select a window (to make it active), select art on the Stage (to move), and select 
frames in the Score (to cut and paste). 

You open a document when you want to watch it or work on it. To keep any changes you've 
made, save it. When you are done working on it, you close it. By Clicking on Close box. 

The Command key is the key with the symbol $£- on it. The term "Command-W" means “hold 
down the Command key (¢§-) down and press W." 
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Technical Support 

Te ee | 

How to Get Help 

Help is available in two forms: 

e Choose Help from the Apple menu. This displays a list of useful procedures, commands and 

shortcuts. 

¢ Use the Index, Table of Contents and Glossary of this manual to locate any subject in this 

manual. 

MacroMind will provide technical support (not consultation) to registered owners for 90 days after 
we receive the Registration Card. You must send in your Registration Card to receive technical 

support. 

Warranty, Licensing Agreement and Technical Support policy for VIDEOWORKS IJ is 

on page 2. Technical support hours are 9:30-5:30, (Central Standard Time), Monday-Friday. (312) 

— 871-0987 

Site Licensing Contact MacroMind for our policy on site licensing agreements for schools, 

universities, corporations and large institutions. 

Making the Transition from the Original VideoWorks 
to VIDEOWORKS Il 

VIDEOWORKS II has many improvements over the original VideoWorks. The following is a list of 

the old features that have changed (not a comprehensive list of new features) for people who are 

accustomed to the original version. 

¢ Real-time recording is now accomplished by holding down the Option-Command keys 

and does not require you to select a new channel each time you add a new castmember. 

© The Add command is now the Insert command. It functions no differentlythe word Insert, 

however, is more descriptive of the fact that it inserts a frame across all 24 channels. 

e The Kill Frame command is now the Delete Frame command. Its command key shortcut 

is now ¢h-K. 

‘CheapPaint is now called the Paint window. 

¢ QuickDraw Primitives are now called QuickDraw Shapes. 

The Paint window icons for Selection Rectangle and Paintbrush have been modified to 

conform to the MacPaint icons. Fatbits is now a magnifying glass. 

Changes on the Stage Are Now Recorded Immediately — Formerly, if you made any 

changes on the Stage (for instance, if you moved artwork, or dragged out a castmember) those 

changes would only take effect when you did a Step or an Add. To learn about the new method, 

try Tutorial #6, "The Frogs." 

The icon for movies has changed, so that you can distinguish VIDEOWORKS II movies from the 

original VideoWorks movies: 

VideoWorks 1.0 VideoWorks Il 
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The Tutorials include carefully detailed descriptions to teach you VIDEOWORKS II through 

examples. You should be able to make it through them even if you are new to the Macintosh. 

They touch every basic facet of animation and build upon each other to strengthen your Skills. At 

any time, feel free to refer ahead to the "How to Animate" and "Reference" sections. — 

The Guided Tour Disk is the first and most important part of getting a good, quick understanding 

of VIDEOWORKS II. The first three tutorials cover making presentations with Overview, and the 

remaining tutorials cover VideoWorks. 

Tutorials EE 



Guided Tour of 

Overview 

Tutorial #1 - 

Tutorial #2 

Tutorial #3 

VideoWorks 

Tutorial #4 

Tutorial #5 

Tutorial #6 

Tutorial #7 
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Guided Tour of VIDEOWORKS II 
VIDEOWORKS II comes with a Guided Tour disk. By watching and interacting with this Guided 
Tour, you will learn some of the basics of VIDEOWORKS IJ, and have a little fun along the way. 
To start the demo: | . 

1. If your Macintosh is turned on, restart your Macintosh (select Restart from 
Special menu in the Finder), otherwise turn on your Macintosh. 

There should now be no disks in your Macintosh, because we want to "boot the system” from the 
Guided Tour disk. 

2. Insert the Guided Tour disk into the Macintosh to start the Tour. 

The Guided Tour disk will start up automatically, and take you by the hand. 

The Guided Tour Demo is by far the easiest way to start learning about VIDEOWORKS II. It will 
take you less than 20 minutes to complete, and painlessly introduce you to many of the 
fundamental ideas in VIDEOWORKS II. There is also some nice animation in it! 

Note that the entire Guided Tour Demo was created with VideoWorks/Interactive, the professional 
version of VIDEOWORKS II which includes an interactivity authoring system. This will give you 
some idea of the flexibility and power that is available in VIDEOWORKS II. 

If you're in a hurry... 

If you are a fairly experienced Macintosh user, and you want to see some animation right away, 
skip to Tutorial #2 - The Movie Show. But be sure to come back to Tutorial #1 before long! 

Tutorials: Guided Tour of VideoWorks Il 19 



Overview 

Tutorial #1 - Bamboo Industries 
- VIDEOWORKS II contains two applications within it - Overview and VideoWorks.The first three 
tutorials describe how to create Overview documents, the rest describe how to create VideoWorks 

documents. 

In this tutorial we introduce the Overview window — a quick and easy way to create an animated 
slide show. Here you can combine existing graphics documents (see below) with VideoWorks 
movies and "clip animation." Clip animations are the equivalent of "clip art" for your animated 
slide show — they are short, succinct animated graphics (movies) that you can easily combine into 
your own presentation. In the Overview window you can also add in sounds, fancy — 
transitions, and adjust timing. 

In Overview you can include: — Created from these programs: 

MacPaint document MacPaint, FullPaint, GraphicWorks, 
SuperPaint, etc 

PICT document : MacDraw, MacDraft, GraphicWorks, 
SuperPaint, etc. 

Glue document Any program that can print, by using 
Glue from Solutions, Inc. 

VideoWorks document VIDEOWORKS II 

In this tutorial, we will: 

¢ Learn to control the slide show (play, rewind, stop, etc.) 

¢ Create a short slide show with two MacPaint documents 

e Add a transition 

e Adda movie 

e Add timers and sound 

¢ Re-arrange documents 

e Adda PICT and a Glue document 

First we will watch the slide show, then we will then re-create it from scratch. 
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Overview 

Watching the Animated Slide Show > 
Let's first open a finished version of the Overview document for Bamboo Industries that we will be 
re-creating in this tutorial. 

1. Open the slide show named "#1-Bamboo” (in the Tutorial Folder on the 
System, Program & Tutorials Disk) as follows: 

If you are already in VIDEOWORKS II: select Open from the File menu A dialog box lists the 
documents available. Select the document called "#/-Bamboo” and click Open. 

=) Tutorial #1 

OD #1-Bamboo 
O #3-More Bamboo 

CO Arrow From SE 

O Arrow L to R 

0 Border 

OM ChopSticks 

0 Comment 

O Easel 

0 Erik Comment 

© VideoWorks © Overview @ Both 

a 

= 
™ 
= 
a 
E, 
a 

= 
ss 
= 

=I — 

= 
3 

If you are at the Finder: click on the document named "#/-Bamboo” 
and select Open from the File menu. #1-Bamboo 
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Overview 

Your screen should now look like this: * 

@ File Edit Control Sound Window 
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The lower eleven icons you see in the Overview window represent the various documents that will 
appear in our presentation, as well other slide show effects. The documents play in succession 
from left to right. Don't worry about what they all mean just now. The white full-screen window 
behind the Overview window (yes there really is a window there!) is called the Stage window. 
This is where your slide show presentation will appear. The small window in the upper right is 
the Panel, which works much like the controls on a VCR (videocasette recorder). 

This arrangement of icons is what we call an Overview document. An Overview document is a 

very small file, typically under 1K (that's about 1000 bytes or characters). Basically, it contains 
only the list of document names to be presented. The Overview document does not contain any 
pictures or movies itself. Thus, the Overview document requires that those original documents be 
intact and available. A change in any of those original documents would show up when you run 
the slide show. : 

. Click the Loop button (in the Panel) so that it turns white: 

This turns off Loop, so that the slide show will play only once. 

. Hold down the Shift key, and select Play from the Control menu. 

This starts the presentation. It hides the Overview window and the Panel, bringing the Stage (the 
window where the slide show appears) to the front. Watch the slide show. When it is over, the — 
Overview window will return. 

Note: If you get the message "Can't find the file __ " then 
read the note titled "Finding missing documents”. 

If the Overview window doesn't go away when the slide 
show plays: you probably forgot to hold the Shift key when selecting 
Play. Let the slide show play through, and try again. | 

If the slide show doesn't stop: you probably forgot to turn off 
loop. To stop the slide show, type Command-W. 
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Note: From now on, we will use the following convention for 

Command keys: Command-W means hold down the Command key 

and press W, then release the Command key. . 

Finding Missing Documents 

If any of the documents are missing when you try to play the slide show, VIDEOWORKS 

li will tell you that it "Can't find the file" and give the name of the file that was missing. 

Why this happens: VIDEOWoRKS II remembers not only the document name, but also 

the folder it is located in. If the file has been moved to another folder, or if the folder 

has been renamed, VIDEOWORKS II will no longer be able to find it. 

Here is what you should do: 

A. Click on the "Look for it" button. 

B. The "Open File" dialog box appears. See if you can locate the file on the disk 

(the folder it is in may have been renamed, or the file may have been moved:to 

another folder). 

C. If you can locate the file, select it and click the Open button otherwise go to 

step E below. 

D. Another dialog box appears asking if you want to "Change all other occurences 

of to " where the blanks are filled in with names of folders on 

your disk. This is really a shortcut. If you click on "Cancel", then VideoWorks will 

continue to look for the next file. If it doesn't find it, you will go through this process 

again. However, if you click on "OK", then VIDEOWORKS II will automatically make this 

same change to the other documents in the Overview that need it. Most of the time 

you should click OK in this dialog. 

E. If you can't locate the file in step C, then click "Cancel". You should quit to the 

Finder, and try to find the following files, and put them all in one folder. After you 

have found the files, VIDEOWORKS II may again say that it "Can't find the file", but this 

is because the names of folders have changed. Just go through steps A through D 

above. 

Here are all the documents you should have in your Tutorials folder to play Tutorial 

#1 - Bamboo: 
#1-Bamboo Overview document 

Chopstick Mkt Glue Document 

Chopsticks VideoWorks document 

Earth MacPaint document 

Presenting VideoWorks document 

Sales Pitch 1 MacDraw PICT document — 

VideoWorks Logo MacPaint document 

EE UE WEE EE IEE WEE OtRE Ube EE tkE ibe tke bE ike GkE ORE JE 
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Using the Panel and Control Menu 
Next we will learn how to use the Panel to control the slide show. 

4. Pull down the Control menu just to look at it. Notice that the first five 
commands in the Control menu are the same as the buttons in the Panel. 

So you have three different ways to control your slide show: 

Click buttons on the Panel; or 

Choose commands from the Control menu; or 

Use the Command-key equivalents of the Control menus. 

There are two different ways to view a slide show: 

¢ Full screen: this is when the Stage window is front (obscuring the other windows 
temporarily). You will use this for your final presentations. 

¢ Overlapping windows: this is when the Stage window is behind all the other windows. You 
will use this while creating and editing your slide show. 

To see how the Control commands work, we will remain in overlapping window view for now, so 
we can see the slide show in the background, and the Overview window in front of it. First let's | 
make some room on the screen so that we can see the slide show better. 

5. Using the resizing box in the lower right hand corner of the Overview 
window, shrink the Overview window, so that it is about the size shown in 
the illustration below, and drag the window to the lower part of the 
screen. 

® File Edit Control Sound Window 7 

6. Click on the Rewind button in the Panel. 

You should now see just a white background. Notice that the "playback head" (a box shape) 
moves to above the Timer icon in the overview window. The playback head shows your current 
position in the slide show. Since the Timer has no es associated with it, you see just the 
white background. 
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Click on the Step button in the Panel. 

This takes you to the "VideoWorks Logo", and its clip animation "Presenting" and plays through 
the clip animation. Since we were only stepping (not playing), the animation stops at the end of 
the clip animation. It is waiting for your next step (or backstep) command. You can step through 
the entire slide show in this way. This is very useful if you want to talk about each slide before 
proceeding to the next one. In fact, it is so useful that there is a very easy shortcut for the step 

command: 

. Click the mouse pointer anywhere in the Stage window (i.e. where the 
slide show appears). 

This should have stepped you to the next slide. 

. Turn Loop back on by clicking it in the Panel (it should turn black). Click 
on the Play button. 

Now you are playing the slides one after the other, without stopping. The slide show can continue 

indefinitely in this loop. Watch the playback head as it moves from slide to slide. Wait until you 

see that the slide show has looped around, then: 

Click the Stop button in the Panel. 

This stops the slide show at whatever point you were at. 

Note: There are other keyboard equivalents for these commands which 
are described in the Reference section. For example, the numeric keypad 
has equivalents for Play, Stop, Step, etc. Also the space bar isa 
"Pause" control. Don't try to use these now, but be aware they exist, in 
case you touch them accidentally. 

Another thing to note about the Panel is that you can drag it to anyplace on the screen you want, 

by clicking in its gray area. 

Moving the Playback Head 

: 

It is useful to be able to jump directly to any particular slide we want to look at. We do this by 

moving the playback head ourselves: 

Click in the Playback Head area above the document "VideoWorks Logo" 
(where the letter "M" is). | 

Note: If you don't know where the Playback Head area is, turn back 
two pages to the first illustration of the Overview window. 

The "VideoWorks Logo" document.should now appear on the Stage, and the playback head (a box 

shape) appears above the "VideoWorks Logo" icon. You can try clicking the playback head above 

any of the other icons to see what they look like on the Stage. 

Note: Icons that aren't associated with graphics, like timers and 
transitions (discussed below) will just appear as a white background. 
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Window Management 

26 

12. 

13. 

14. 

15. 

16. 

17. 

In general, it is tricky to work on a full screen presentation when you have other windows in the 
way. There are several ways to deal with this problem, but don't feel you need to become expert in 
them all to use VIDEOWORKS II. Instead, you should experiment until ee find a method you are 
comfortable with. 

For example, you can try to make the Overview window as small as possible so that you can see 
the Stage on the sides. This is what we did earlier. This tends to require a lot of moving and 
resizing of the window, unless the presentation is confined to a small area of the screen. 

Or you can simply close the Overview window when you want to view the slide show. The 
advantage of this is you have most of the screen for the slide show, but can still see the menus and 
the Panel. To bring the Overview window back, select it from the Window menu (a shortcut is to 
use Command-3 to both close and open the Overview window). 

Try closing the Overview and using the various Panel buttons. Bring 
back the Overview by selecting it from the Window menu. 

In VIDEOWORKS II, selecting a window from the Window menu will "toggle" that window. That 
is, if the window is not visible it will appear. If it is visible (and the frontmost window) then it 
will become hidden. 

Click in the Playback Head area above the document "VideoWorks Logo” 
(where the letter "M" is). 

Try toggling the Overview window with Command-3 several times. Each 
time you type Command-3, the Overview window will appear or disappear. 

But a purist will want to use the full screen for the slide show. There are two ways to go to using 
the full screen: 

Select the Stage window from the Windows menu.; or 
¢ Hold the Shift key down while selecting the Play command or button. 

The Shift-Play method also starts the animation going, while the Window menu method only 
brings up the full screen Stage. We already tried the Shift key method when we first watched the 
slide show. To see how the Window menu method works: 7 

Select Stage from the Window menu. 

You should now see only your current slide, with all the other windows and the menu bar hidden. 
Notice that you can still select from the menu bar, although the menus are hidden. You can still 
select all the Control menu commands, such as Step, Rewind, Play while in full screen view, or 
type their keyboard equivalents: 

Type Commana-Q, the keyboard equivalent of the Play command. 

The slide show starts playing. 

Type Command-W, the keyboard equivalent of the Stop command. 

You are left in full screen view, and can give any of the other commands you desire. 

Note: If you had entered full screen view by using the Shift-Play 
method, then giving the stop command would automatically bring back 
the Overview window (in that case you could skip the next step). 
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To get back to the Overview window: 

18. Select Stage from the Window menu (If you can't find the menu, type 
Command-1). 

The other windows reappear, and the Stage is again in the background. 

Another good way to be able to see you slide show is to close the overview window. You can 
then use the Panel or the menus to control the slide show. Reopen the overview window when 
you need to edit again by selecting it from the Window menu. 

_Re-creating the Animated Slide Show 
We will now recreate this slide show (Overview document) from scratch. 

19. Select New from the File menu. 

Note: If you are asked to save changes then just click on "No". 

The New command gives you a blank document to start from. Your screen should look like this: 

*« File Edit Control Sound Window 

Sounds Transitions 

PIGT VideoWorks Timers Overview 

Work Area 

Notice the icons along the top and the work area below. You can drag these icons into the work 
area in any order. We will show you how to do this during the tutorial. The icons represent the 
types of documents you can use with Overview. 
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Adding the First MacPaint Document 

20. 

a 

Adding 

22 

23. 

Drag the MacPaint icon into the Overview work area as follows: Move the 
Us 

pointer onto the MacPaint icon , Click and hold down the mouse 
button, drag the icon into the Overview work area and release the button. 

Untitled Querview 

A file selection dialog box will now appear. 

Within the file selection dialog, click on the MacPaint file named 
"VideoWorks Logo” and click Open. 

A MacPaint icon appears with the name "VideoWorks Logo" below it. Typically, when creating a 
slide show, this MacPaint document would be a title page, showing the title of the presentation in 
large, bold letters. | 

Note: If you selected the wrong document: To remove a 
document, simply select it by clicking on it and choose Clear from the 
Edit menu. 

the Second MacPaint Document 

. Drag out the MacPaint icon again, placing it to the right of "VideoWorks 
Logo", but this time open the document named “Earth” and click Open. 

Now you have two MacPaint icons side by side, which is the simplest kind of slide show 
imaginable. Let's look at what we have so far: 

Play the slide show: Hold the Shift key down and click the Play button. 

Watch the slide show. The two documents will be shown one after another, like a slide show. 
However, they flash by too fast. (On a two-floppy system, the sequence runs more slowly than on 
a hard disk system.) 

Note: From now on, we won't tell you to stop the slide show after 
playing and watching it, but you should do so yourself by choosing the 
Stop command from the Control menu, clicking the Stop button, or by 
typing Command-W. 
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Overview 

Adding a Timer 

Let's insert the Timer to slow down the slide show. 
LJ ay 

a 
th oy 

24. Move the pbinet onto the Timer icon “= , click and hold down the 
mouse button, drag the Timer into the Overview work area just to the left 
of the first MacPaint document, and release the button. 

The watch icon appears, and there is a blinking text cursor underneath it, indicating that we can 

type in the amount of time we want. 

25. Type the number 3 (which specifies three seconds) and type either the 
Return or Enter key. 

Notice the 3 appears below the Timer and above each MacPaint document. This indicates the 
MacPaint documents will play for 3 seconds each. Timers affect all documents that come after 
them, until the next timer. 

26. Play the slide show: Click the Play button. 

Watch the slide show. The documents will be shown for three seconds each. You-can also see the 
playback head (the box around the number 3) moving. It indicates which document is currently 

being aces on the Stage. 

Adding a Transition 

Let's add a transition (a fancy visual etiec) between the two MacRaini documents. 

a ie Drag the Transition icon into the Overview work area and place it 

between the two MacPaint documents, as shown. 

Untitled Querview 

_6_Dc Bz: 

3 Videoorks tool karth 
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28. 

29. 

30. 

A dialog box appears with many choices for the transition. Click on Boxy 
Dissolve and then click "OK". = 

() wipe left to right () reveal north 

Cj) wipe right to left f) reveal northeast 

a (> wipe top to bottom [3 © reveal east 

= © wipe bottom to top C) reveal southeast 
fol © vertical out from center &! (reveal south 3 

| ae Q vertical in to center ( reveal southwest 
( reveal west 
(© reveal northwest 

“4 OC) dissolve 

‘4+ () square in to center fol @ boxy dissolve 

2 a (> push left wigs 

{ push right 
© push down Delay: /60ths of a second 

© push up Chunk size: 

As you can see, there are a wide variety of transitions available at the click of a mouse! 

Play the slide show: Click Rewind, then holding the Shift key down click 
the Play button. 

This time you should see the first MacPaint document dissolve into the second. The dialog box 
also gives you the option to change the speed at which the boxy dissolve occurs, and how 
"chunky" the transition is (see the "How To Animate" section for details). 

Note: When you are trying out other transitions later on, keep in 
mind that one of them (dissolve) works only in full screen view. 

a VideoWorks Movie 
Up to this point we have created a slide show with only MacPaint documents. It is important to 
realize that you do not need to include VideoWorks movies in a 1 slide show — you can just keep 
adding MacPaint or other graphics documents. 

However, VideoWorks movies and clip animations can make your presentation more dramatic. 
Now let's add a VideoWorks movie in between the two MacPaint documents. 

Send 

Drag out ‘the VideoWorks icon between the "VideoWorks Logo" 
-and the boxy dissolve icon. When the file selection dialog appears, click 
on the file named "ChopSticks" and click Open. 
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. Play the slide show: Click Rewind, then holding the Shift key down click - 

the Play button. 

You should see the movie inbetween the two MacPaint documents. You can use this technique to 
show many movies and MacPaint documents. | 

The movie runs until it is over. It is not governed by the Timer (you can tell this because the 
"M" above the movie indicates that it runs for the whole length of the movie). Options are 
available to make the movie repeat, start after a delay, or play for only the Timer length (see 

Tutorial #3, or the "How To Animate" section). . 3 

Reorder the Slides 

32. 

33. 

Let's see how simple it is to re-order these slides: 

Move the pointer onto the document "Chopsticks," click and drag it to 
the riaht of the “Earth” document. 

———————— ee at 

a . aa s 
e 

s 

aaa eae ad baieianssih, 

Earth ae ohne 

Play the slide show: Click Rewind, then holding the Shift key down click 

the Play button. 

The movie now plays after the second MacPaint document, as you would expect. 

Adding PICT and Glue documents 

34. 

35. 

Now let's add more pe to fill out the slide show. 

ARS. s 
&  & 

Drag the Glue icon S, into the work area just to the right of the 

VideoWorks Logo. When the file selection dialog appears, click on the 

name: "Chopstick Mkt". 

This is a chart that was created with Microsoft's Excel, and saved to disk using Glue from 

Solutions, Inc. Using Glue, you can easily bring into the Overview window documents from 

virtually any Macintosh program. = 

Drag the PICT icon into the work area and place it after the Glue 

icon. When the file selection dialog appears, click on the name: "Sales 

Pitch 1”. 

This is a bullet chart that was created with Living VideoText's MORE, and saved in PICT format. 

PICT is a file format that can be read and created by Apple Computer's MacDraw, and various 

other programs. « | | 
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36. Play the slide show: Click Rewind, then holding the Shift key down click 
the Play button. ? 

You may notice that "Sales Pitch 1" is not really displayed long enough to read it. We could 
make this picture run longer, by adding another Timer right before it with a longer timing. For 
now we will leave it as is. 

Adding Sound 

32 

37. 

38. 

Before doing the next step, you may want to make your Overview window a little taller, to 
accommodate a second row of icons. 

- 
|) ae 

Drag the sound icon ~“ “= into the work area, positioning it below 
"Chopstick Mkt" as shown in the next illustration. 

Pull down the Sound menu and pause at Business. A submenu pops up. 
Still holding the mouse button down, slide the pointer sideways to the 
submenu, then move down to Transition 1, and release the mouse 
button. 

« File Edit Control Spite Window . 
= gasic reassess re 

2 - Explosions > 

3 - Weapons » BESERERRERBRR TAREE ASRRR EER EER SABRE ERRRRASAES 

4-Instruments > 
5 - Nature > 

7H 6 - Space > 

“o7ah- 3 ¢ - Old Music a O-1 Introl 

ee ee 8 - New Music id 9-2? Intro? 

fre Ld 9-3 Intros 
oven =e. + 9-4 I'm Here 

9-5 Mini Fanfare 

9-6 Bad Times 

9-7 Ending 

9-6 Transition 1 

9-9 Tran&ition 2 

9-A Transition 3 

9-6 Transition 4 

9-C Transition 5 

9-D Transition 6 

Videoworks LoChopstick MkiSales Pitch 1 0,16 

Transition 1 

The name of the sound, "Transition 1," appears beneath the sound icon (note: this has nothing to 
do with the Transitions discussed above). 

Note: If you have System 3.2, instead of the latest System (4.1) 
then the sound menu will work differently for you. You will have to 
select the desired submenu first, then the sound within that submenu. 
Please look up the Sound menu in the Reference section for more 
details. 

Note: If there are no menu items in your sound menu, then 
you don't have the Sounds file in the correct place on your disk. Please 
look up "Sound Files" in the Reference section for more details. 
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42. 

43. 

44. 

45. 

Overview 

Play the slide show: Click Rewind, then holding the Shift key down click 

the Play button. 

The animated slide show now plays with sound accompanying it. 

Note: You can control whether VIDEOWORKS II will play sounds at 

all. 
VIDEOWORKS II will play sounds when then menu item "Sound Is On" 

in the Control menu is checked. To turn sound off, select that menu 

item and the check mark goes away. | 

If you don't get sounds: Make sure that the Sound Is On item is 

checked in the Control menu. Also make sure the volume is turned on 

in the Control Panel desk accessory. 

Now, let's add sounds to some of the other graphics in the same way. 

Drag another sound icon to below the "Sales Pitch 1" document. In the 

Sound menu, choose the /ntro? sound from the Business submenu. 

Drag another sound icon to below the "Earth" document. In the Sound 

menu, choose the Drone2 sound from the Space submenu. 

You can again click Rewind and Play to hear the results. 

a Clip Animation 

Next we will add a clip animation. A clip animation is a short VideoWorks movie that is designed 

to enhance a slide show presentation. 

Drag the VideoWorks movie icon into the work area, below the 

first MacPaint document, "VideoWorks Logo”. 

When the dialog box appears, select "Presenting" and click Open. 

Play the slide show: Click Rewind, then holding the Shift key down click 

the Play button. 

The letters of the word "Presenting" slide into place above the VideoWorks Logo. ‘There are 

numerous options that you can set for clip animations, for example, setting its timing and 

positioning. These will be described in the third tutorial. 

ke 

CHO 
Oo O 

You may be wondering what the Overview icon A is for. It is merely for convenience, like 

folders in the Macintosh Finder — used to keep documents together. With it, you can include a 

slide show you prepared previously in your current presentation. Or you can break up a long 

presentation into smaller sections that may be easier to work with. See the "How To Animate” 

section for details. 

You have completed your first animated slide show. At this point you might want to add some 

more transitions, or rearrange the sequence of slides to suit you. Have fun! When you are done: 

Choose New from the File Menu. A dialog box appears with the message 

"Do you want to save changes?” Click No. 

You can now Quit to the Finder, or continue on to some of the other tutorials. 

& 
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Tutorial #2 - The Movie Show 

This is a fun and quick tutorial. It will show you how to use the Overview window to quickly and 
easily view large numbers of separate VideoWorks movies. 

You will need either two 800K floppy disk drives, or a hard disk to run this tutorial because it 
displays every movie on the Clip Animation, Artwork & Movies disk. | 

. Open the Overview document "#2-Movie Show.” (Unlike the other 
tutorials this one is on the Movies disk). 

. Play the Overview: Holding the Shift key down, click the Play button. 

You will see most all of the movies on the movies disk. 

Note: If any of the movies are missing, VideoWorks II will 
tell you that it can't find them, and give you a chance to locate them 
(perhaps they were moved to a different folder or renamed). See the note 
on "Finding Missing Documents" after step 3 of Tutorial #1 for more 
information. 

If after looking for the files you couldn't find some, you can clear the 
icons of the missing documents from the Overview. To clear an icon, 
click on it and select clear from the Edit menu. 

. Hold down the Command key, and type a "W". 

This is the keyboard equivalent of the Stop command. It should stop the movies and bring back 
the Overview window and the Menu bar. 

Next we will show you how to recreate this Overview document with a single command. 

. select New from the File menu. If you are asked to save changes, click 
"No", 

. Select "Quick Create” from the Edit menu. 

You will see a dialog explaining that Quick Create will allow you to add all the documents in a 
particular Macintosh folder or disk by selecting any one document from that folder. 

. Click Continue, and a file selection dialog appears. Open the folder 
called "Movies" (if it is not already open). 

At this point you can select any of the movies in this folder, and all] the movies in the folder will 

be added to your Overview document. It doesn't matter which of the documents in the folder you 
select. 

. Select the movie called "Tangram" and click the Open button. 

After a second, all the movies from the Movies folder appear in your Overview. If you want to 
rearrange their sequence, or add in transitions, feel free to do so now. 

. Play the Overview: Click Rewind, then holding the Shift key down click 
Play. 
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Tutorial #3 - More Bamboo Industries 

This animated slide show is somewhat more advanced than Tutorial #1 - Bamboo. It demonstrates 

how to: 

¢ Use the Step command in new ways > 

¢ Set the timing and position options for a document 

¢ Show two movies simultaneously, one in front of the other 

¢ Cut, copy, paste, and duplicate icons 

e Annotate a slide with text 

For this tutorial you must have the following documents, preferably all in a single folder: 

#2-More Bamboo .............000008 Overview document 

Arrow From L to R................ VideoWorks document | 
Asrow Prom SE Ac. 2204. ais. cs: VideoWorks document - | 

Border 2.3 pat 226 ww. a Ss VideoWorks document 

Chopstick, MIR 03 <.siecnceasd «ences Glue Document 
CUO PS UCKS wc. cedengreeeceeten VideoWorks document 
COMMent 2 4. .sccc cre a VideoWorks document 
Barth). 325 ee MacPaint document 

Pace ee VideoWorks document 

PIACE “OPCS . occas ccsccsciss trues MacDraw PICT document 

PROS CHNG ic6 coendccndies seqenan ce cas VideoWorks document 
Sales Pitete bcs. w ae SS MacDraw PICT document 

Saleg: PUCW 2 ccc sicecvacenscceste cas MacDraw PICT document 

SOO lo re nee ae Cerner ae VideoWorks document 

VideoWorks Logo ..............00+: MacPaint document 

1. To see the Overview you are about to create, open and play the 
document "#3-More Bamboo". 

#3-More Bamboo Overview 

., : 

sf s 

ee en : ] acaasenooe =| Pea @ 
es 

ta [2 Pitch 2 Chopsticks Place Order aS 

Wt eed eee 
al e es 

is en: 
. 5, es 6 s 

Fresenting Transition 1 Introd Dronez Shimmer 

i s ey 

es 6 e 

Arrow From S arrow L toR Border 

; ‘6. a 5 

Comment Arrow LtoR 

Note: If any of the movies are missing, VIDEOW oRKS II will 
tell you that it can't find them, and give you a chance to locate them 

(perhaps they were moved to a different folder or renamed). See the note 
on "Finding Missing Documents" after step 3 of Tutorial #1 for more 

information. 
% 
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® 

We will be building up from where we left off in Tutorial #1, so: 

2. Open the Overview called "#1-Bamboo”. Immediately do a Save As (in 
the File menu) to rename your document to something else. 

Doing the Save As will ensure that you don't change the tutorial file, so that you can use it again 
later on. | | 

3. Drag out a VideoWorks icon to below the Glue document "Chopstick 
Mkt". Select the clip animation "Arrow From SE". 

SE stands for "South-East", which is the direction this arrow will enter from. 

More About the Step Command 

Here are two more useful ways to use the Step command: 

¢ While the Overview is playing, Step functions as a "Skip" command to skip forward to the 
next slide and keep playing. This is useful for when you are bored with a movie. 

¢ To repeat the current slide or movie, hold the Shift key down while clicking on the Step 
button (it also works with the menu and keyboard equivalents). 

4. Close the Overview window, click Rewind, and Play. Halfway through the 
"Presenting" animation, click Step. = 

- 
This will skip the rest of "Presenting" and start playing the "Arrow From SE" animation you just 

added. 

5. Click Stop. Move the playback head to above "Chopstick Mkt". Holding anes 

the Shift key down, click Step. 

You will see the "Arrow From SE" animation play through once and stop. You can Shift-Step on 
this same slide as often as you like. Please feel free to use these variations of the Step command il 
anywhere in this tutorial. 
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Positioning VideoWorks Documents 

You may have noticed that the arrow we added is not positioned quite right. We want to have it 
end up pointing at the second to last data point on the Chart. How can we do this? 

6. Click on the icon for "Arrow From SE” (make sure it is the only icon 
selected). 

7. Select "Get Info” from the Edit menu. 

Your Overview window temporarily disappears, and the Get Info box appears: 

*« File Edit Control Sound Window 

Get Info 

Info about: Arrow From SE 

Timing: @ Use movie's normal length 
(> Use current timer length 

Repeat movie: i times 

Start after: blk a seconds 

Position: ©) Use movie's start location 

(6) Set start location with mouse 

Horiz: Vertical: 

[] Before mowie starts, first image appears 

After movie ends, last image remains 

Play movie's sounds 

CANCEL 

There are many options available in the VideoWorks Get Info box. For now, we will concentrate 
on the Position options. Notice first of all that we are using the movie's own starting location 
(we haven't yet set the starting location with the mouse). 

8. Move the Get Info box to the left hand side of the screen, so that the 
right two points on the graph are visible. 

This way you can see the Chart and arrow better. 

9. Move your mouse out over the Stage window. 

Notice the cursor turns into a cross. This indicates that you can set the starting location by 

clicking the mouse in the Stage window. 

Think of setting the starting location as an archer firing an arrow. The archer can only control 
where the arrow starts from, though with enough skill the destination can also be controlled. 
This is what you will be doing here as you try to control the arrow on the Macintosh screen. | 
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10. Click the mouse somewhere in the lower right corner of the Stage 
window. (If nothing happens right away, be patient, don't click the 
mouse repeatedly). 

The animation started! You have set the starting location of the animation. 

When the animation stops you can see the starting location that you just set as a pair of gray 
lines on the screen (see the illustration above). Notice where the arrow wound up. If it didn't 
reach the second to last data point of the graph, then keep trying till you get it reasonably close. 

You can use the gray starting location lines to get the animation very close to where you want 
it to wind up. First, estimate how far off the arrow is from where you want it. Suppose that 
it overshot the mark by one inch. Then you should click the next time one inch away from 
the gray starting location lines. Keep doing this until you are as close as you want to be. 

11. Click OK in the Get Info box. Click Rewind, and holding the Shift key 
down, click the P/ay button in the Panel. 3 

Using Timers on VideoWorks Documents 

You may have noticed that the arrow does not stay in its final position very long before the next 
slide comes along. We would like to use the timer to set the length of this slide, instead of using 
the length of the movie. First notice that above the "Arrow From SE" column of icons is the 
letter "M". As explained earlier, this indicates the slide is timed by the length of the movie. 

12. Get Infoon "Arrow From SE". Click on the button labeled "Use current 
timer length". Click OK. 

Now look at the time shown above the "Arrow" column of icons, you should see the number 3 
there. If you play through the Overview now, this slide will persist after the animation finishes 
for a total length of 3 seconds as you'd expect. 
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- Showing Two Movies Simultaneously 

13. 

14. 

15. 

16. 

Drag out a VideoWorks icon underneath "Sales Pitch Ee Select the clip 
animation “Arrow L to R" from the file dialog. 

Get Info on this movie. Set the starting location so that the arrow stops 
just to the left of the second line of text. Click OK 

The Option key is a shortcut for duplicating an icon in the Overview window. Use it now to 
create a second arrow for this slide: 

Holding down the Option key, drag the “Arrow L to R" icon down an inch 
within the Overview window. 

You should now have two “Arrow L to R" icons. 

Get Info on the second "Arrow L to R." Set the starting location so that 

the arrow stops just to the left of the third line of text. Click OK. 

> Chopstick sales off in the Far East 

C>The West: a growth opportunity 

Delaying a Movie 

17. 

18. 

These two movies are now moving exactly in sync. We want the second one to start a second or 

so after the first. - 

Note: There is a shortcut for doing Get Info on an icon, which is to 

double click on that icon. Try it! 

Get Info on the second "Arrow L to R." Enter a 1 in the box labeled "Start 

after ___—s seconds.” 

After you type in the number, the animation will automatically start. 

C>Chopstick sales off in the Far East 

cC> The West: a growth opportunity 

If the timing looks OK to you: 

Click OK. Click Rewind, and holding the Shift key down, click Play the 
Overview from the beginning. 
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Using Timers (continued) aes 

Again we want this slide to last a little longer than it is now, so that we can read all the text. 
Since we have two clip animations in this column of icons, we will have to set both of them to 
use the Timer. | 

19. Get Info on the first "Arrow L to R", and click on the button labeled "Use 

current timer length”. Click OK. 

Notice that there is still an "M" at the top of the column. The "M" will turn to a "3" only when 

all the clip animations in the column use the Timer. 

20. Repeat step 19 for the second "Arrow L to R”. 

Now you should see a "3" above this column of icons. If you play the movie now, this column 

will appear on the screen for three seconds as you'd expect. 

Positioning a Graphic Document 

21. Drag out a PICT icon between "Earth" and “Chopsticks, "and select the 
document called "Sales Pitch 2". 

22. Get Info on this document. Move the Get Info box to one side. When 
you move your cursor over the Stage, it becomes a hand tool. 

Info about: Sales Pitch 2 

Drag the image on the Stage 

using the mouse. 

offset: teft(-15 | up[-15 | 

23. Use the hand tool on the Stage to drag the image, centering it. Click OK. 

Note: In all the Get Info boxes, you can find out the "full pathname" 
of the file by clicking on the file name at the top of the box. The full 
pathname lists all the folders that that file is in. 

Repeating an Animation 

24. Drag out the VideoWorks document called "Shimmer" below the PICT 
document "Sales Pitch 2”. 

Shimmer is an animation that is invisible unless it passes in front of something else. It moves 
from left to right. We will have it pass over the bottom line of text. 

25. Get Info on "Shimmer." Set the starting location to the left of the bottom 
line of text. 

Industr® ieader 
You can see that the Shimmer is much too brief. We will extend it by setting its number of 
repetitions. 
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26. 

ae Be 

Overview 

Type a 4 in the box labeled "Repeat movie times.” 

You should see the animation start automatically soon after typing, and as you'd expect it repeats 4 

times. 

While we're at it, let's add a border to this slide: 

Drag out the VideoWorks movie "Border" to below the "Shimmer" icon. 

To see the border, replay the document from the beginning, or use the Shift-Step shortcut to replay 

the current slide. 

Delaying a Movie (continued) 

28. 

29. 

30. 

31. 

32. 

se 

Drag out the PICT document called "Place Order" to the end of the 

Overview (after Chopsticks). | . 

Drag out the clip animation "Ease/” below the PICT document "Place 

Order." 

Get Info on the PICT document "Place Order". Move the Get Info box so 

that you can see the easel. Position the PICT document centered in the 

easel. 

Notice that as you move the PICT document, the easel disappears, but it immediately reappears 

when you let up on the mouse. 3 

Play the Overview: Click the playback head above "Chopsticks", and 

then holding down the Shift key, click on Play. 

You will see the easel animation happen almost immediately after it appears, giving us no time to 

read the sales message. To remedy this: 

Get Info on "Easel." Set the delay time to 4 seconds (the box labeled 

"Start after seconds’). 

The animation automatically starts after you type, and there is now time to read the message, but 

the easel doesn't appear at all till after 4 seconds! The remedy for this is simple: 

Get Info on "Easel." Check the box labeled "Before movie starts, first 

image appears." 

Annotating a Slide 

34. 

sO . 

Our last assignment is to add an annotation to the "Chopstick Mkt" slide. We want to add the 

words "Demand is Peaking” to the slide. To do this, we will create a very simple VideoWorks 

movie consisting of only these words. Later tutorials will go into more detail on using 

VideoWorks. For now, we will just walk you through the steps without too much explanation. 

Drag out a VideoWorks icon to the bottom of the "Chopstick Mkt" column 

of icons. Click the New button in the file dialog. Click Yes in the "Save 

changes?" dialog. ~ 

You are immediately launched into VideoWorks. In the background you still see the "Chopstick 

Mkt" slide, though without the arrow clip animation. 

lf the Cast window is not open, go to the File menu and select it. If there 

are any other. windows open besides the VideoWorks Panel, close them. 
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36. 

37. 

38. 

39. 

40. 

File Edit Control Sound Window Text Draw “Ink 

Click on the "A" tool in the right side of the Cast window. Use it to drag 
out a square about 1 1/2 inches wide on the Stage. 

You should now have a blinking cursor in a Text box. 

Type the words "Demand is Peaking.” From the Text menu, choose New 
York as the Font, and 18 as the Size. If you need to reposition the text 
box, you can grab it on its gray edges. 

Demand is | 
peaking | 

Select To Overview from the File menu. Answer "Yes" to the "Save 
changes?" dialog, and save this file under the name "My Comment." 

You will now find yourself back in the Overview window, and you can see the VideoWorks icon 
"My Comment" there. — 

Play the Overview: Click Rewind, and holding the Shift key down, click 
Play. 

You should now see your annotation appearing on top of the "Chopstick Mkt" slide. 

After you learn more about using VideoWorks (as opposed to Overview) you may want to learn 
more about how to go back and forth between them. This is covered later in the manual. Note 
that it is also possible to go back and forth between Overview and MacPaint, or MacDraw (see the 
Launch Editor command in the Reference section). | 

Congratulations! You've learned a lot about how to make snappy looking animated presentations. 
To finish off: 

If you want to save this Overview, select "Save As..." from the File menu, 
and save the file under a different name. Otherwise, just select New, and 
answer "No" to the "Save Changes?" dialog. 
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VideoWorks 

_ Tutorial #4 - Bouncing Face 
This exercise is a simple, brief introduction to the animation side of VIDEOWORKS Il. You will 

first watch a short movie, then re-create it. 

In this tutorial we will: 

e Learn Play and Stop 

e Create anew VideoWorks animation 

¢ Draw a picture in Paint 

e Learn Real-Time Recording 

The VideoWorks Screen 

Many of the terms used in VIDEOWoRKS II — Stage, Cast, movie, Score, and frame—are borrowed 

from the theatre and film industries. You can think of VIDEOWORKS II as a play, with these 

analogies: | 

-«[ heatre...- -. VideoWorks 
Cast (people) = Cast (artwork) 

Script to guide people = Score to guide artwork 
Theatre stage Stage window 

In working with VideoWorks, you first create your Cast of characters (your artwork), ies by 

moving the Cast around on the Stage, you create a Script (Score). At all times, what is on the 

Stage is a reflection of what is in the Script (Score). 

This first VideoWorks tutorial (as opposed to Overview tutorial) will show you the easiest way to 

move a Cast member around on the Stage to create a Score. It is called Real-Time Recording. It 

will also show you how to create a simple Cast member. 

STAGE STOP PLAY 

MENUS COMMAND BUTTON BUTTON 

Sound ERE Tent ovow ink 
See a ea] aE roa BACK | STOP | STEP | PLAY 

veast = 83 PDL oo 
Score 34 

Paint 35 

Text 366 

Tweak 7 

faig:¢ 8B 

Debug 

a File Edit Control 
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CAST 

me 
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‘Watching the Movie _ 
1. Open the movie named "#4-Bouncing Face” (in the Tutorial Folder on the 

Program Disk) by: 

Bouncing Face 

If you are already in VIDEOWORKS II: select Open from the File menu A dialog box lists | 
the documents available. Select the document called "#4-Bouncing Face” and click Open. 

If you are at the Finder: click on the document named "#4-Bouncing Face” and select Open 
from the File menu. 

. Click the Play button (in the Panel). Watch the animation. Notice 

that it repeats. 

Study this movie — the size of the face and the way it moves. Remembering it will help you re- 
create it. 

zx 
. When you are done watching, click the Stop button. 

Next we will re-create this movie. 

Creating the Circle 

44 

4. Choose New from the File menu. (If you are asked "Save changes?," 
click "“No"). 

. Choose Paint from the Window menu. 

. Click on the Easel 'Q| . An easel appears. 

. Enlarge the Easel by pulling on the handle as follows: Move the pointer 
onto the resize handle (the tab in the lower right of the easel — see the 
illustration on the next page). Click and drag the mouse button down and 
to the right. Release the button when the Easel is about three times 
larger than it was initially. 
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VideoWorks 

é File Edit Control Sound Window Text Draw Ink 

<q PLAY FAH 
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You won't see the effect of selecting the gray fill pattern until you draw the circle in the next step, 

where you will be drawing the gray circle you saw in the movie. — 
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10. Move the pointer into the white space of the easel; as shown in the 

illustration below, so you see a crosshairs se Press and drag the mouse 

button down and to the right. Move the crosshairs diagonally across the 

easel to draw a round ball. Release the button. 

Before circle is drawn While the circle is After circle is drawn 

beina drawn 

Notice the circle also appears in the Cast window, at position A11. 

Bouncing Face Cast 

Note: If you want to try drawing the circle again, double-click on the 

Eraser to erase what you have drawn and repeat steps 8, 9, and 10 

to re-draw the circle. 

The Cast holds all of the artwork to be animated. This animation will have only one = of 

artwork, (or castmember). 

11. Close Paint by clicking on the close box at the upper left corner of the 

window. (If any other windows besides the Cast and the Panel are open, 

close them as well.) 

Notice that the ball you drew is currently selected in the Cast window, the selection is indicated by 

a heavy black box appearing around it. 

Real-Time Recording 
Next we will make the circle we just drew bounce around the Stage. 

12. Move the pointer to the left edge of the Stage, where there are no other 

windows. 

Read this entire step first, then do it all at once in one smooth action, without hesitating: 

13. Holding down the Option and Command keys, drag the mouse across the 

| Stage and back, then release the mouse button. 

As you dragged the mouse, the ball should have appeared at the pointer The movie you just 

created will repeat continuously (if the Loop button in the Panel is black). Notice the Frame 
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VideoWorks 

Counter in the Panel is running. By dragging the mouse with the Option and 

Command keys down, you created several "Frames" of a movie. 

“« File Edit Control Sound Window Text Draw Ink 
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Note: If you want to try re-doing this previous step, choose Burn 

Scene from the Edit menu. (Burn Scene erases the movie, leaving the 

castmembers). Then repeat the previous step. 

Amaze Your Friends 

44. While the ball is still bouncing, open Paint by choosing Paint from the 

Window menu. 

15. Select the Paintbrush | 

16. Select the black box in the Draw menu. 

17. In Paint draw two eyes in your circle. Notice the eyes appear on the 

bouncing ball. 

Presto! Whatever you draw on the circle in Paint is duplicated exactly on the circle moving around 

on Stage. This is an example of how VideoWorks maintains direct links from Paint to the Cast to 

the Stage. 

18. Draw a mouth on the ball in Paint. 

19. Select Stage from the Window menu. This gives you a full-screen view. 

20. When you are done watching, hold the Command key (#6) and press W to 

: stop the animation. Select Stage again to bring back the menus. 

Congratulations! You have completed your first VideoWorks animation. 

21. Choose New from the File Menu. Answer "No" to the "Do you want to 

save changes?" dialog box. 
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Tutorial #5 - The City 

As we have mentioned, much of the VideoWorks terminology is borrowed from theater. Briefly, 

the animation process follows this general procedure: Each separate piece of artwork (or 

"castmember") is created in Paint, and automatically becomes a member of the Cast. Individual 

castmembers are then dragged out onto the Stage, where their movements are recorded into the 

Score. 7 

Other terminology comes from film and audio technology: A channel is an independent track of 

information (like the left and right channels of a stereo system). A frame is one snapshot of the 

movie — as in one frame of a reel of film. Frames are recorded in the Score. 

If you are familiar with the program MacDraw, then here is yet another way to think about 

VideoWorks: 

VideoWorks is very much like a series of MacDraw pictures (each with a maximum of 24 

objects), flashed on the screen one after another. Each frame is like a single MacDraw 

picture, and the Score is where the succession of MacDraw pictures is recorded, one after the 

other. As in MacDraw, the separate objects can be moved about independently. 

Since VideoWorks can easily handle up to 1000 or more frames of animation, this is like having 

1000 MacDraw documents at your fingertips! 

You will first get to watch the movie and then go back and re-create it step by step. You might 

check off each step as you do it. It is important not to skip any steps. 

In this tutorial, we will: 

¢ Practice using the controls on the Panel 

¢ Use Burn Scene 

e Learn Real-Time Recording 

¢ Use the Channel Indicator (on the Panel) 

e Introduce the Cast 

e Introduce the Score 

e Learn In-Betweening 

e Use a Film Loop 

e Add sound 

Watching the Animation 

1s 

=> 

Open the movie named "The City” (in the Tutorial Folder). 

If there are any windows open besides the Cast and the Panel, close 

them at this time. 

_ Press Command-!1 (for Stage) and then Command-Q (for Play). 

Watch the movie, noticing that it repeats. There should be sound accompanying the movie. Once 

again, as you watch, remember the action in this animation, because we will soon be re-creating 

it. 

: Press Command-1 to bring back the Cast and Panel windows. 

Notice the animation continues to run with or without the windows displayed. Command-1 

merely toggles all the windows on and off. 7 
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5. While the movie runs, press Command-1 a few more times until you get 

the feel of how it works. When done experimenting, leave the windows 

displayed. 

| a 
6. Click the Stop button to freeze the action. 

Learning the Panel 

Now you will get an opportunity to become familiar with the Panel that controls the movie. 

7. Click Rewind 44] Then click Step \ZE&) several times to step forward 
one frame at a time. 

di 
8. Press Back Step \ESCK) several times to step back one frame at a time. 

- Notice that the animation is made up of discrete images, each one slightly different from the 

previous one. A tiny bit of sound plays back with each step. Also note that the Frame Counter 

indicates which frame is being displayed. | 

BACK 
on B= a co Gow ms LOOF 

REWIND 

CHANNEL 
INDICATOR 

LIGHT SOUND ~SPEED _ FRAME 

SWITCH SWITCH CONTROL COUNTER 

9. Press Play. While the movie is playing, turn the Sound Switch off and on 

several times to see how it works. When sound is turned on, the icon is: 

Leave the sound on after experimenting. 

Note: If the volume is too loud or too soft, open the Control 

Panel at the Apple (@) menu. Adjust the volume there. — 

10. Turn the Light Switch off and on several times. When lights are turned 

on, the icon is: Leave the lights on after experimenting. 
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Re-Creating "The City" 

Next we will re-create the movie we just saw. 

11. Choose Burn Scene from the Edit menu. (Don't choose New!) You will 
see a dialog box explaining that Burn Scene will erase the Score (the 
animation information) but leave the castmembers intact. Click OK to 
continue. 

Note: If you get stuck at any point in this tutorial where you cannot 
continue, and you want to try again, choose Burn Scene and return to 
this point and start over. 

Adding the City 
Now let's add the city background. 

12. Choose Cast from the Window menu. 

The Cast holds the artwork to be animated. 

13. Move the mouse pointer to the landscape in the Cast (position A11). 
Press and hold the mouse button and drag the landscape out onto the 
Stage (you will see only a large rectangle). Center the image on the 
Stage and release the button. 
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Flying the Helicopter 

14. 

Loe 

VideoWorks 

The Channel Indicator: Ba2Anse 

VideoWorks is something like a 24 track tape recorder. You can record simultaneous animation 

into any of the 24 animation tracks. In the Panel is a Channel Indicator which is like "status 

lights" for each of the channels. It tells which channels are selected for editing or are being 

recorded into. A number there indicates artwork is assigned to the channel. 

When we go to do Real-Time recording, VideoWorks will automatically assign a new channel to 

the animation we will create by the Real-Time recording. You can actually see this happening: 

Hold down the Option and Command keys simultaneously. 

You should see the Channel Indicator for channel 2 blinking on and off. This is VideoWorks 

telling us which channel we are about to record into. (There are ways to override the choice that 

VideoWorks made for us, see "How To Animate" for more details). 

In the Cast window, select the helicopter (position A12) by clicking on it. 

_ (Do not drag it onto the Stage.) 

16. 

+f. 

Next we will add the helicopter using the Real-Time Recording technique. This technique records 

live-action, exactly as it takes place. 

Move the mouse pointer to the upper left edge of Stage where you will 

start moving the helicopter. 

We suggest you read all of this next step before doing it. 

Holding the Option and Command keys down, click and drag the mouse 

(the helicopter will instantly appear) and fly the helicopter around. Land 

the helicopter on the roof of the building and let go of the mouse button 

(as well as the Option and Command keys). 

Watch the movie — it will repeat. The movie should now be 10 to 20 seconds long, showing the 

helicopter flying in from the left and landing on the building. Notice the frame numbers are 

running in the Panel. — 

Playing with the Panel 

Next we will use some more controls on the Panel. 

18. Turn the Loop button off-it looks like this: eal 

Let the movie run to the end. Notice that now the movie does not repeat. 

19. Click Play again. Turn Loop back on. 
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20. 

21. 

Slow down the movie by clicking on the we in the Speed Control. 

Speed it up by clicking on the right arrow. ed a 

Drag the Scroll Box in the speed control first one way and then the other 
to change the speed. When done experimenting, set the speed at or 
near where it was originally (12 or so). 

Introducing The Score 

22. 

23. 

24. 

While the movie is still running, open the Score by choosing Score from 
the Window menu. 

At first glance, the Score can appear formidable. Don't worry about all of the little symbols in the 
Score — we will learn those later. For now, let's just get the larger picture of the Score. 

Move the Score down and out of the way by moving the pointer to the 
title bar, holding down the mouse button and dragging downward. 

i 

The Score is a window representing the entire movie, from the start (on the left) to the finish (on 
the right). It is like a movie script, directing the action of the members of the Cast. 

FRAME NUMBERS 
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PLAYBACK HEAD 

Watch the Playback Head as it runs by. The Playback Head is very important. It indicates 
what part of the Score is currently being displayed on Stage. 

Channel [1 | represents the city you dragged out, notice that the symbols don't change. This is 
because the city is stationary. 

Channel [2 | represents the helicopter, notice that the symbols do change. This is because the 
helicopter is moving. 

Hit the Rewind button | 44| 

The animation stops, and the Playback Head rests at frame 1. 
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VideoWorks 

25. Grab the Playback Head by moving the mouse pointer onto it, holding the 
mouse button down and moving it to the right and then back to the left. 

Notice the animation on Stage moves back and forth with the Playback Head . Also notice that 
the Frame Counter (in the Panel) changes to indicate the current frame. 

The current frame is the frame currently displayed on Stage. The Playback Head indicates which 

frame is the current frame. 

26. Click in Playback Head bar at different places. 

Notice the animation changes on the Stage according to where you click. 

27. Click the arrow in the horizontal Scroll Bar. This scrolls the Score without 
affecting the animation on Stage. Scroll a long distance, so that the 
Playback Head is no longer visible. 

28. .Click on the Jump button L#_]. This causes the Score to jump, or scroll 
instantly, to where the Playback Head is located. 

The Jump button is a great shortcut for finding the current frame. 

Let's see how the Score and Stage are intimately related. 

29. Click on the number "2" at the left of channel number 2 as shown and 

notice that the helicopter is selected on the Stage. Click elsewhere in 

the Score to de-select the helicopter. 

“a File Edit Control Sound Window Text Draw Ink 
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30. Now move the mouse pointer to the Stage and click on the 

helicopter—notice the Score indicates that channel 2 is highlighted. 

Thus, when you select cells in the Score, the corresponding artwork gets selected on the Stage, and 

vice-versa. 
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Adding the Plane foo 

31. 

32. 

33. 

34. 

35. 

36. 

37. 

Next we will add the plane using Real-Time Recording. 

Close the Score window. (It'll just be in our way). 

Click Rewind and Back Step in the Panel. 

This positions us at the last frame in the movie. 

Holding down the Option and Command keys, notice that the third 
Channel Indicator is flashing in the Panel. Release the keys. 

This is the channel that we will be Real-Time recording into. 

Select the plane (castmember A13) in the Cast by clicking on it. 

The dark box appears around the plane in the cast to show its selected. = 

Move the mouse pointer to the right end of the Stage where you want the ~ 
plane to start flying. 

Holding down the Option and Command keys, click and drag the mouse 
to fly the plane across the Stage. 

Let go of the mouse button as soon as the plane reaches the other side. 

Removing Extra Frames of the Plane 

54 

38. 

39. 

40. 

Watch the plane—if it stops when it reaches the left edge of the Stage, this means you held the 
mouse button down too long. However, this is easy to fix. 

Note: If the plane doesn't stand still at the left edge of the Stage, just 
pretend that it does stand still a few frames before it reaches the edge, and 
you can still practice the techniques discussed here. 

Play the movie and Stop it just before the plane reaches the left edge of 
the Stage. Advance the movie using Step until the plane stops moving. 

Click on the plane to select it. Then choose Blank From Stage from the 
Edit menu. 

This removes the one selected frame of the plane from the Stage. 

Click Step again to advance to the next frame. If the plane appears again 
choose Blank From Stage again. Continue using Step and Blank From 
Stage over and over again until the plane is gone, or you wrap around to 
frame one. 2 

Now when you play the movie, the plane should disappear as soon as it reaches the left edge of the 
Stage. 
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41. 

42. 

43. 

44. 

45. 

46. 

VideoWorks 
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the Car: In-Betweening 

Click Rewind in the Panel. 

Select channel 4 in the Channel Indicator. 

We are adding another channel to this multi-track animation; so to avoid recording over any of our 
existing animation, we selected a new channel to record into. 

Drag the car (castmember A14) out of the Cast window to the left edge of 
the screen, in front of the black street. 

Unlike the previous times when we did Real-Time Recording, we are now affecting only a single 
frame of the animation (frame 1) when we drag the castmember onto the Stage. 

Notice the white box around the car. The simplest way for VideoWorks to put something on the 
Stage is with a white box around it (this is called "Copy ink"). It takes less memory and runs 
faster. However, it doesn't look right in all cases. To correct this we will switch to using Matte 
ink. (Inks affect the way castmembers look on the Stage). 

First select Blank From Stage from the Edit menu to remove the car. 

Let's drag the car out again, this time using Matte ink which will display our car with the edges 
outlined, instead of surrounding it with a white rectangle. 

Select Matte from the Ink menu. Note that Matte now has a check mark 

next to it. 

We were using Copy ink beforehand, which was responsible for the white rectangle. 

Now drag the car out from the Cast again and place it on the street at the 
left end of the Stage. 

8 
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47. Position the Score as follows: 

48. 

49. 

50. 

51. 

52. 

53. 

® 

Open the Score. Move the Score near the top of the Stage (but not covering the Panel) 
by dragging it by its title bar. 7 

Adjust its size so it is as wide as possible by moving the pointer to the re-size box, 
pressing the mouse button and dragging the Score wider. Make sure frame 40, and channel 
4 are visible. : 

The Score works like a spreadsheet, but for animation. Each cell of the Score corresponds to one 
of up to 24 pictures on the Stage in a single Frame. We can select any one, or more than one of 
these cells in the Score. We can then cut, copy, or paste the cells or do many other powerful 
editing tricks to enable us to edit the animation in an easy fashion. =: 

We refer to cells by their frame and channel. Each cell is at the intersection of a certain frame and 
channel. To select a certain cell, just drag across it from left to right in the Score. 

Select the cell at frame 1 of channel 4 by dragging across it. 

Select Copy Score from the Edit menu. 
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Move the Playback Head to frame 40 by clicking the mouse in the 
Playback Head area below frame 40. 

Notice that the car is no longer on the Stage. 

To select where you want to paste in the Score, you should click on the left hand edge of the cel ielt L. 
You should then see a flashing insertion point. 

Click the mouse on the left hand edge of the cell at channel 4 of Frame 
40. 3 

Select Paste Score from the Edit menu. 

_ Now the car has appeared in the same position as before! Although it looks the same, it is really 
separated in time by 40 frames from the previous picture we saw. 

Holding down the Shift key (which constrains our motion to a straight 
line) drag the car from the left to the right side of the Stage. 
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54. In the Score, select channel 4, from Frames 1 to 40, by dragging the 
mouse | | 

from: the /eft hand edge of the cell at channel 4 of Frame 1 
to: the right hand edge of the cell at channel 4 of Frame 
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We now have a span of space and time selected in the Score. We can fill in this span with 
intermediate frames of animation with one simple, yet powerful VideoWorks command. 

55. Choose /n-Between from the Edit menu. 

56. Click Rewind and Play in the Panel. 

You should now see the car moving smoothly across the road. 

Adding a Film Loop of a Bird 
57. Close the Score. 

58. Click Rewind and Play in the Panel. Stop anywhere in the middle of the 
movie. 3 | 

59. Select Film Loop 7 in the Cast window by clicking on it. 

60. Move the pointer onto the left edge of the Stage, press and 
holdCommand-Option, hold the mouse button down and fly the bird — 
around the Stage. 

Notice how its wings flap, even when you hold the bird still. This film loop was originally 
created in the Score, then pasted into the cast. How to create film loops is discussed in the "How 
To Animate” section of this manual. 
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Switch Backgrounds 

Now we will demonstrate how easy it is to change the feeling of an animation merely by changing 
its background. 

61. Open the Score. To select all of channel 1 (the background channel) 
simply double click on the number 1 at the left hand edge of channel 1. 

All of channel 1 should now turn black (selected). 
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62. Click on the Big Sky background (castmember A16) in the Cast window. 

Now with another simple, yet powerful command we will change the background for ee entire 
MOviIc: : 

63. Choose the Switch Castmember command from the Edit menu. 

64. Close the Score window, click Rewind, and Play in the Panel. 

Now the same animation as before appears in front of a mountain scene. 

Add Sound 

65. Open the Score. 

The sound channel is the topmost channel in the Score. 

66. Select the entire sound channel, by double-clicking on the sound 
channel icon on the left hand edge of the sound channel. 

The City Score 
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67. Select a sound from the Sound menu: pull the mouse down to Old 
Music, pause there, when the submenu pops up to the right, slide your 
mouse over and choose Bach 1. 

Note: If you have System 3.2 instead of the latest System (4.1) your 
Sound menu will work differently. You will have to first select the 
submenu, then the Sound menu will be replaced by an new submenu 
which will have the sound Bach linit. 

68. Click Rewind and Play in the Panel. 

You should now hear the music playing. If not, check the troubleshooting instructions in the 
Sound Files chapter of the Reference section. 
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Tutorial #6 - The Frogs : 

Now that we have gained a working familiarity with some of the VideoWorks features, let's 
explore some advanced animation techniques. Because VideoWorks contains a powerful animation 
editor, working through the following examples will help you develop editing skills that will 
actually save you time and effort. 

In this tutorial, we will: | 

¢ Cut, Copy and Paste sequences in the Score 

¢ Use the Switch Castmember command 

e Chain sequences together 

« Add scenery with the In-Between command 

e Create and use a Film Loop 

e Add sound 

Play "The Frogs" 

60 

1. 

as 

Open the VideoWorks document called "#6-The Frogs”. 

Select Stage from the Window menu to clear the Stage. 

This clears the screen of all the other windows, such as the Cast and the Panel, and gives you an 
uncluttered view of the action. 

Start the animation by pressing Command-Q or by selecting Play from the 
Contro/ menu. 

Even though you can't see the menu bar, you can still select from the menus by moving the 
pointer to the top of the screen where the Control menu normally appears and clicking to pull it 
down. 

While the animation is playing, let's take a look behind the scenes. 

First, open the Panel (by selecting Pane/ from the Window menu) and 
experiment with some of the controls. For example, click the Stop 
button, and note that the action freezes at that point. 

. Click the Rewind button and then step through the animation frame by 
frame, by clicking the Step button. 

Note as you Step that the animation is made up of discrete images, each one slightly different from 
the previous one. Note also that as you step through the animation the Frame Counter in the 
Panel indicates where you are in the sequence (see the illustration below for the Frame Counter's 
location). 

Open the Cast window (from the Window menu). 

Note that this entire sequence, is created with only six castmembers. In other words, by using 
VideoWorks' editing functions, it is possible to achieve this multiple frog effect without having to 
create additional artwork. 
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7. Open the Score, and position it on the right of the screen as shown: 
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Channel Numbers 

The Score holds all the animation information for the movie. Don't worry about what all the 

symbols mean yet. In the Score, time moves from left to right. Each column represents one 

moment of time, or frame. | 

Notice the Playback Head moving across the bottom of the Score. It indicates which frame is 

being displayed. Animation occurs by displaying frames rapidly one after the next. 

Re-Create "The Frogs" 

8. Select Burn Scene from the Edit menu. Click OK in the resulting dialog 
box. | 

All the information in the Score has now disappeared, but the castmembers are left intact. 

. Choose Save As... from the File menu, and type in a different name (such 

as "My Frogs"). 

If you do not Save As now, then if you Save during the course of the tutorial, you will overwrite 

the original tutorial and it will no longer be available as a reference. 

Tutorial #6 - The Frogs 61 



VideoWorks 

Making the Frog Move 
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10. 

at: 

12. 

First we will learn how to use the Step command to make the frog move around on the Stage. 

Drag the first castmember (labeled A1i1) out of the Cast window and place 
it on the Stage, somewhere above the Cast window and towards the left 
hand side of the screen. 

#« File Edit Control Sound Window Text Draw Ink 

Thick Border 

First, notice that something has appeared in the Score. channel 1 of frame 1 is now filled in with 
a symbol, which represents the frog that we just dragged out. 

Notice also that there is a thick, dark border around the frog. And there is a little round circle in 
the Channel Indicator's box for channel 1. We call this the "record light." The thick border and 
the record light mean the same thing: that we are currently recording this castmember into the 
Score. 

Each channel can have its own Record Light, in fact you can have up to 24 Record Lights o on at 
the same time. 

Turn the Record Light off. Holding down the Option key, click once on 
the frog on the Stage. 

The border of the frog now is light and thin, and the Record Light in the channel 1's Indicator box 
is replaced by the number 1. 

Turn the Record Light back on. Holding edad the Option key, click once 
on the frog on the Stage. 

You can toggle the record light on or off at any time. Try it now a few times to get the hang of 
it, but leave the record light on when you are done. 
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13. 

14. 

Click on the Step button in the Panel. 

Immediately, another cell of animation is added next to the first one, in frame 2. Also, the Frame 

Counter reads "2" and the Playback Head has moved (see illustration below). Also the selection in 

the Score has changed from frame 1 to frame 2. 

Frogs Ca 
q RD 

To continue our animation, we needed some more frames. By giving the Step command we added 

a frame to our movie. The Step command will only record into the Score when the record light is 

on. When the record light is not on, it will simply step to the next frame (as we did in Step 6 

above). 
| 3 

The Score can display several different types of information about the animation. To select the 

information you want to see, click in the appropriate button of the Score Display Indicator: 

Ink 

Extended display 

Motion | 

Castmember 218 

For example, it can show the motion that is happening, or which castmembers are being 

displayed. Right now we are interested in motion. | 

If the motion display indicator is not selected, click on it now. 

Now lets start to make the frog move. 

Note: Try to drag the frog from its center, not on its edges. There are 

"resize handles" on the edges of each frog, which are used to stretch the 

image. If you drag one of these resize handles by accident, the image — 

will stretch, so you should immediately Undo. If that doesn't work, try 

reading about the "Normal Size" command in the Reference section. 
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15. Drag the frog by clicking in its center (not on the edges). Drag it up and 
to the right a short distance (about a half inch). | 3 

My Frogs Score 
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Notice that in the Score frame 1 shows a round dot (meaning there is no motion), whereas frame 
two now shows an arrow (meaning there is motion relative to the previous frame). The direction 
of the arrow is the direction you dragged the frog (up and right). 

16. Click Step to add a third frame. Drag the frog down and left. 

The arrow in frame three again reflects the direction you moved the frog. 

17. Click Play in the Panel. 

The frog moves in a small circle. Notice that the record light is no longer on in the Panel. This 
is because clicking any of the Panel buttons besides Step (such as Play, Rewind, Backstep) will 
turn the record light off. 

18. Click Stop in the Panel. Click Step till you reach frame 3. Step again. 

When the record light is off, step wraps around to the beginning of the movie when you are at the 
end. If you want to make the frog move some more with this technique, Step to frame 3, turn on 
the Record Light, and repeat the Step and drag combination as many times as you want. 

Creating the First Frog Jump 

19. Select Burn Scene from the Edit menu. Click OK in the dialog box. 

20. Select "Matte - Outlines Edge” from the Ink menu. 

This will ensure that when the frogs pass near each other later on, there won't be a white box 
around each one (which is "Copy - Normal" ink). Instead, Matte ink outlines the edges of an 
object so that they can be overlayed on top of each other. 

21. Drag the first castmember out of the Cast window and place it on the 
Stage, somewhere above the Cast nance and towards the left hand side 
of the screen. 

Notice that the Record Light comes on as soon as you drag the frog onto the Stage. 
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| | 1 22. Click Step in the Panel. 

This adds in the second frame. 
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23. Click on the Castmember Display Indicator 2 in the upper left corner of 
the Score. 3 

This lets us see the castmember numbers in the Score. So far we have two frames, both have 

castmember 1-1 in them. . 

My Frogs Score 
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24. Select (but do not drag it out) the second castmember by clicking the 
second box in the Cast window. 

25. Switch to this new castmember by selecting Switch Castmember from the 
Edit menu. 

Shortcut: There are two other shortcuts for Switch Castmember: 
typing Command-E or double-clicking the second castmember in the 
Cast window. : 

The first castmember has been replaced by the second one. And the castmember number in the 
Score changed from 1-1 to 1-2 for the cell in frame 2. 
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In general, any editing done to the Score affects the cells that are selected. The reason that the cell 
in frame 2 switched castmembers instead of the cell in frame 1 is that the frame 2 cell was the 
selected cell. . 
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We would like for the frog to jump up, instead of just jumping in place, so we should move this 
picture of the frog: 

26. Drag the frog up and to the right a short distance (about a half inch). 

Now we will repeat this procedure for each of the remaining images of the frog: | 

27. Click Step in the Panel to advance to the next frame; select the third 
castmember in the Cast window; choose Switch Castmember from the: 
Edit menu; and drag the castmember up and to the right. 

Notice that a new cell was added in the Score on frame 3, and the number of this castmember (1-3) 
is shown there. 

*@ File Edit Control Sound Window Text Draw “Ink 

28. Click Step in the Panel to advance to the next frame; select the fourth 
castmember in the Cast window; choose Switch Castmember from the 
Edit menu; and drag the castmember up and to the right. 

My Frogs Score 
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29. Click Step in the Panel to advance to the next frame; select the fifth 
castmember in the Cast window; choose Switch Castmember from the 
Edit menu; and drag the castmember up and to the right. 
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Notice that after each step of this process, a new cell was added in the Score, with the number of 
the castmember being shown there. \ 

30. Change the Score display back to motion display (by clicking on the A 
button). 
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Notice that the Score shows us that the motion is generally up and to the right, just as we would 

expect. 

31. Click the Play button, and watch the frog jump back and forth across the 
screen. 

| 

Congratulations! You have just animated your first Frame-by-Frame sequence. Now we will use 
the powerful editing capabilities of the Score to enhance our animation. 

Chaining Several Frog Jumps 

We shall now see how to take this small animated sequence and, by using | the Copy and Paste 
functions, turn it into a plague of Biblical proportions. 

32. Select frames 1 through 5 in channel 1 in the Score by dragging the 
' mouse pointer across them (start dragging near the left hand edge of 

frame 1). 

Tutorial #6 - The Frogs 67 



VideoWorks | 

Note that we can carry out any of our editing functions even while’ the animation is still running. 

If you had stopped the action go ahead and start it up again so you can watch your changes take 

immediate effect. 

33. Select Copy Score (from the Edit menu) to copy first five frames. 

34. Click on the left hand edge of frame 6 in channel 1 (you should be able to 

see a flashing vertical bar where you clicked the pointer) and select 

Paste Score from the Edit menu. 
OS - ss llCU ell re eee eee 

Note: You will notice in the Edit menu that the commands Cut, Copy 

or Paste are followed by either "Score", "Cast", "Graphic" or "Text". 

This is to reflect which window is currently active -- the. Score, the 

Cast, the Paint Window or the Text Window. It is important when you 

are using any of those commands, that you realize which window is 

active at the time or you could be unintentionally cutting, copying or 

pasting the wrong item. 

) Notice that although the selected sequence has been copied into frames 6-10, nothing seems to 

| have changed: The same old frog is still jumping back and forth across the screen. This is 

because frames 6-10 are the same as frames 1-5 in every respect, including the frog's starting 

position. But what if we want frames 6-10 to start where frames 1-5 end, so that the frog takes 

two hops across the screen? We can do this by using Paste Relative instead of Paste. Here's how: 

35. Select Undo Score from the Edit menu to undo our last Paste. 

The Score should be back to having just five frames. 

Note: If the Undo didn't work, then select frames 6-10 of 

channel 1 by dragging the mouse pointer across them, and select Clear 

Score from the Edit menu. 

36. Click the left hand edge of frame 6 (you should see a blinking vertical 
line) and select Paste Relative from the Edit menu. 
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Aha! The frog now takes two hops before starting again. 

37. Paste Relative the sequence three more times until you have filled the 

first 25 frames of channel 1 - making sure that: 

you are pasting onto the end of the animation each time; and 

you are using Paste Relative, not Paste Score. 

Watch the frog jump all the way across the screen. Next, let's edit the sequence so that the frog 

starts its journey nearer to the edge of the screen instead of its current starting position. To do 

this, we will need to stop the action. 
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- 38. Click Rewind (which both stops the action and rewinds the film to the first 
frame) and then select the whole sequence of 25 frames by dragging the 

pointer along channel 1. — | | 
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39. Click the frog as it sits in its initial position, and then drag the frog to the 

left edge of the screen, about an inch from the bottom left corner. 

Because you have selected all the frames in the Score, you have not only changed the position of 

the frog in frame 1, but you have changed the position of all the frames by the same amount. 

« File Edit Control Sound Window Text Draw Ink 
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40. Click Play. : = 

You will see that the entire sequence has been shifted over. As with all editing of the Score, 
whatever changes you make are applied to the entire selection. Even though we shifted the 
sequence by dragging the first frog (.e., the first castmember), it is important to realize that we 
could have done so by dragging any of the five castmembers the same distance, provided you had 
selected the entire channel within the Score. 

Note: If your frog did not start jumping from the left edge of the Stage 
and you notice that the frog seems to flash on another area of the screen, 
you probably did not select all of the frames in the Score. To correct 
this problem, step through the animation with the step button on the 
panel. Find the frame or frames where the frog is out of place. Select 
the frog on the screen and move it to the approximately correct position. 
Step and Backstep to see if the movement is smooth, make any minor 
adjustments necessary. 

Go Forth and Multiply 

70 

Now let's increase the frog population by further copying and pasting. 

41. Close the Cast window to make more room on the Stage. It will also be 
helpful to move the Panel to the left side of the screen - to do so, click in 
one of the white areas on the edge of the Panel and drag it. 

You will also need to adjust the size and position of the Score window from time to time during 
this section of the tutorial, in order to get at all the frogs. 

42. Select frames 1-25 of channel 1, and Copy. 

You can check to see that the correct frames are selected by looking at the Range Indicator on the 
Panel (the first number should be 1 and the second should be 25). 
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Click here t 

crag window ~ \RAKOIMe M1 inci 

43. Click the left hand edge of frame 9 in channel 2, so that you have a 
flashing line, and select Paste Score from the Edit menu. 

My Frogs Score 
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Normally frogs don't move in single file like this, so we will need to move one of them onto a 
slightly different path. 
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45. 

46. 

Click Rewind, and Step till the Frame Counter shows you are at frame 9. 

Select frames 9-33 of channel 2. 7 

The resting picture of the second frog should now be selected on the Stage (if not, make sure your 

Playback Head is at frame 9). 

Drag the selected frog on the Stage so that It is on the bottom of the 

screen, about an inch from the left corner. 

Since we had selected all the frames of this animation, the drag affected all those frames, instead of 

just the one that we see on the Stage. Now when you hit Play, the frogs should jump more 

naturally. , = 
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Let's add still more realism into the animation by making the second frog rest a little between 

hops. 

Select frames 20-33 of channel 2. Select Cut Score from the Edit menu. 

Click on the left hand edge of frame 30 of channel 2 (you should see a 

blinking white line). Select Paste Score. | 
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If you play the animation now, you will see the second frog disappear between frames 20 to 29. 

There are several techniques you can use to fill a gap like this. One is using In-Between (which 

we will discuss later), another is to copy and paste a single cell 10 times to fill the gap. 
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Instead, of those techniques for filling in the gap, we will use the Record Light and the Step 
command . Remember that Step added frames at the end of the movie earlier in this tutorial. In 
the middle of a movie, Step modifies those channels that have the Record Light on. 

47. Click Rewind, and Step till you are at frame 19 (watch the Frame Counter 
or Playback Head to see where you are). 

Note: A shortcut for this is to click in the Playback Head area of the 
Score below frame 19 to move the Playback Head directly. 

The frog you will be looking for next is probably in the very middle of the screen, so you should 
move or resize your Score till you see it. 

48. Turn on the Record Light for the second frog by holding down the Option 
key and clicking once on the frog. 

Note: If you can't find the frog, try ste the Score window temporarily. 
It may be right underneath it. 

49. Now you can click Step several times to fill in the gap. 

Notice that the gap in the Score is being filled in as you Step. Don’t Step too far or you will start 
recording over the existing animation after frame 30. 
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You can also use this technique of Stepping with the Record Light on in the middle of an 
animation to change the motion of a sprite. When you are Stepping with the Record Light on, 
you are recording only those channels that have the Record Light on. Any channels without the 
Record Light remain as they were. 
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Now we can do some mass multiplication. 

Select frames 9 to 43 of channel 2 (all the animation in that channel). 

Select Copy Score from the Edit menu. Click on the left hand edge of 

frame 16 of channel 3 (you should see a blinking white line). Select 

Paste Score from the Edit menu.. 
\ 

My Frogs Score 

RRERERRRR ERP ReR ERE RRo re BBEE geo Sha Be G Al +|5]@|3-5|+15/@/ 5] 51 4[ 510) 515/41 5/@/5) 414) 

BERRESEQHGAREEE lee slalelslelelslsls(sl ale slale|apatsis = Fa) Fal 3 Bal tJ al Palle Fal Bal al+ + 

FRB BAR BRRRRRRGRRRRRGERERRBEE Pa) Fad ud Ea Ai+j A ad End Pa) fad Cad bt 

If you play the movie now, you will see 3 frogs jumping across the screen. But again, two of the 

frogs are jumping in lock-step. 

Select all of channel 3 by double-clicking on the channel number ("3") at 

the left of the Score (or by dragging across all the animation in that 

channel). Step to frame 16 (or move the Playback Head there directly). 

You should now see the third frog selected and resting on the bottom of the screen. 

Drag this frog to the left edge of the Stage, about an inch up from the 

bottom. : 

We will repeat this procedure two more times, to add two more frogs jumping across the Stage. 

Select channel 1 from frame 1 to 25 (all the animation in that channel). 

Select Copy Score from the Edit menu. Click on the left hand edge of 

frame 19 in channel 4 (you should see a blinking white line). Select 

Paste Score from the Edit menu. 
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54. Select all of channel 4 by double-clicking on the channel number ("4") at 
the left of the Score (or by dragging across all the animation in that 
channel). Step to frame 19 (or move the Playback Head there directly). 

You should now see the fourth frog selected and resting on the left edge of the screen. 

55. Drag this frog to the center of the bottom edge of the Stage. 
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Now we will copy this frog we just pasted. 

56. Select channel 4 from frame 19 to 43 (all the animation in that channel). 
Select Copy from the Edit menu. Click on the left hand edge of frame 40 
of channel 1. Select Paste from the Edit menu. 

———————— SS 

L 10 15 20 23 30 35 40 45 30 39 
| ASSO RO SOC BOS OC ESCO BOSCO BIOOCB OOO BOCOSSEOOTBOCOTBOOOG EO: <a 

SU ee tt LTT 
1 | Siaisisiaisialaisislelaalsisleaisieaoi | 11 TLL TLL ||| Siatsisialelaatsialelataistaela F 

LTT | telat lela s[elealaleolaelalael3(sisie\s(o1a6 eS ese tHt 210 
BERRRRRRRRREREE lslelels e 

Ee PEEP EEC TT easiest (TTT |. 

If you Play the movie now, you will see a plague of frogs. You may have to temporarily close 

some windows (like the Score) to see all the frogs. 

Add Some Scenery 

Let's bring some scenery onto the Stage. 
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57. Click Rewind and select the first frame of the channel 5 either by clicking | 
_ that cell in the Score or by clicking the channel 5 box (the fifth box) in 

the Channel Indicator in the Panel. 

Whichever method you choose, you should see a blackening of the channel 5 box in the Channel 
Indicator. 

58. Open the Cast window, select the sixth castmember (the small bush), and 
drag it out onto the Stage, placing it in the bottom right hand corner of 
the screen. 

@ File Edit Control Sound Window Text Draw Ink 
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We are now faced with the same situation as when we were filling in the gap earlier in this 
tutorial. We want to extend a stationary object on the screen through time. As before we could: 

¢ Copy and Paste 64 times 

e Step 64 times with the Record Light on; or 

e Use the In-Between command a single time. 
Hmmm... Sounds like In-Between might save us a lot of work! Let's try it. 

59. Select all of channel 5 by double-clicking on the channel number ("5") on 
the left of the Score. 
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60. Select /n-Between from the Edit menu. ' 

The In-Between function allows you to specify the starting and ending positions, and the number 
of frames, for a castmember's movement across the Stage, and fills in (or “in-between's") the 
intervening frames. If you leave off an ending position, as we did here, it fills in with the starting 
position. 

You can now Play your animation to make sure it looks correct. 

Note: If the bush is blinking on and off, you probably did not In- 
Between for the entire length of the movie. To remedy this, Cut out all 

the frames of the bush except the first, and try again. 

Creating a Film Loop 
Here we will learn a new technique for Real-Time recording, that will let us animate a sequence of 
images in real-time, instead of just a single image. 

61. Select frames 1 to 5 of channel 1 in the Score. Select Copy from the Edit 
menu. 

62. Select castmember A17 (the first empty box) in the Cast window by 
clicking on it. Select Paste Score from the Edit menu. 

The Frags 9 ———————————————— 
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63. Select Burn Scene from the Edit menu. Click OK in the dialog. 

64. Close the Score window to give yourself more room. 

65. Move the mouse pointer over the Stage. 

66. Holding down the Option and Command keys, click and drag the mouse 
on the Stage. 

The frog jumps as you move your mouse. When you let go, the animation repeats (if you have 
Loop On in the Panel). 

67. Repeat the previous step as many more times as you'd like, to add more 
frogs to the movie. 

Note that when you hold down the Option and Command keys, the next available channel starts 
blinking in the Channel Indicator of the Panel. This i is showing you which channel you will be 
Real-Time Recording into. 

This technique lets you easily add many frogs. Suppose, however, you want to record over an 
existing frog. To see how to do this, we will first start over and record a single channel of 
animation. Then we will record over it. 

68. Choose Burn Scene from the Edit menu. Holding down the Option and 
Command keys, press and drag in the Stage to add a single channel of 
Real-Time animation. 

— 

69. Click Rewind to stop the animation and return to frame 1. 
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70. Holding down the Option and Command keys, click on the Channel 
Indicator for channel 1 in the Panel (it starts flashing). Keep holding 
down the Option and Command keys, and you can Real-Time record over 
the existing animation. 

When you let up on the mouse, you should see only one frog moving. 

If you want to create your own film loops, you should also learn about how to use the 
Registration Point tool in the Paint window. See the "How To Animate" section for more details. 

Adding Sound 
71. Reopen the existing movie "#6-The Frogs”. Click the "No" button when 
you are asked to save changes. 

| O Hi 
72. Open the Score window, click on the castmember display button ii 

This will let you see the numbers associated with the sounds in the sound channel. 

73. Select frames 5 to 10 of the Score. 
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74. Select a sound such as "Rivet" from the Nature submenu. 

Note: If you are using System 3.2 instead of the latest System (4.1) 
you will need to first select Nature, then (from the same menu) Rivet. 

75. Rewind, click play. 

You should hear the sound as the Playback Head passes over frame 5. You can select other parts 
of the sound channel where you would like to hear sounds and add them in. Meike AREA KEE EERE ARK ARE kk 

a 

| 

no Tutorial #6 - The Frogs 



VideoWorks 

Tutorial #7 - Point-of-Purchase Display 

This is a more advanced tutorial. To fully understand it you will want to first at least skim 
through the sections in "How To Animate” listed below to find out where the explanations are for 
the things you will be doing in this tutorial. 

¢ Editing an Animation 

¢ Adding QuickDraw Shapes 

¢ Adding Text 

In this tutorial we will: 

¢ Move artwork smoothly across the screen (using the In-Between command) 

e Use Macintalk to make the Macintosh speak 

¢ Use QuickDraw shapes | 
e Make a QuickDraw shape grow smoothly 

e- Use Art Grabber+ to import a graphic 

¢ Use a Text Box 

Watch the Presentation 
1. Open the VideoWorks document "#7-Point-of-Purchase”. 

2. Type Commanad-7 to reveal the Stage. 

3. Type Command-Q to start the movie. Watch the movie. 

4 Type Commana-1 to bring back the windows. Click Stop to stop the 
movie. 

Re-Create the Movie 
First we will make text scroll from the top of the Stage to the bottom. 

5. Select New from File menu. 

Set the speed to 20 by clicking on the Speed Control arrows in the 
Panel. 

Choose Paint from the Window menu. 

Resize the Paint window so it is as wide as possible. 

9. Click on New Easel [CJ] 
10. Drag open the easel by pressing and holding the mouse button on its 

handle (lower right corner) and moving down and to the right 

141. Click on the Text tool LAL. and click inside the easel. 

12. At the Text menu, choose New York style, Bold style, 24 pt size. 

Note: If you are using a system prior to System 4.1, your screen will show 
the Font and Style menus in place of the Text menu. In that case, choose New 
York from the Font menu and choose bold and 24 pt from the Style menu. 
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VideoWorks 

Type "MACROMIND PRESENTS" or substitute your own name or the 
name of your company. 

We could have sped the text into the Text window, but then it would move across the Stage more 
slowly. 

Close Paint. 

Click channel 1 in the Channel Indicator. 

Move the Cast towards the middle of the screen to get it out of the way. 
Drag the first castmember (A11) out onto the Stage. Position it near the 
bottom of the screen. 
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Open the Score from the Window menu, position it so that you can see 
frames 1 through 50. 

Channel 1 of frame 1 should be selected (if not, click on the left hand 
edge of that cell, and drag over to its right hand edge). Choose Copy 
Score from the Edit menu. 

Select the cell at frame 50, channel 1 so that it is black. 

Choose Paste Score from the Edit menu. 
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26. 

27. 

28. 

Click the Playback Head bar at frame 50 so that the Playback Head moves 
to frame 50. | 
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Close the Cast window to get it out of our way. 

Move the mouse pointer to the text "MACROMIND PRESENTS" at the 
bottom of your screen so the tip of the pointer is somewhere on that text. 
Press and hold the Shift key. Press the mouse button and (while holding 
the Shift key down) drag the text straight up to the top of the Stage. 
Release the mouse button and Shift key. 

The Shift key constrains the movement of the object to a straight line. 

select frames 1 to 50 by placing the pointer at the left hand edge of 
frame 1 of channel 1, pressing the mouse button and holding it down as 
you drag the pointer all the way to frame 50. 

There is no need to make the Score window bigger, the Score automatically scrolls to let you 
select an area that is larger than what is currently visible. The Score should now look like the 
following figure, with all frames black, from 1 to 50. 
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Choose /n-Between from the Edit menu. 

This fills in the intervening frames. 

Make sure Loop is turned on. 

Press Command-?1 and then Command-Q. 

Watch the text scroll down the screen. Notice that it Repeats. (The text would be less jerky if 
you had recorded more frames, say from frame 1 to 100.) 

Press Command-1 again to bring all of the windows back and then click 
Stop in the Panel. 
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Add Your Product Name | 

Next we will produce text scrolling in from the right to the center of the Stage. 

29. Open Paint. 

30. Click on the New Easel. 

31. Re-size the box like before, so that it is as wide as possible. 

32. Make sure you have New York 24 bold selected in the Text menu. 

33. Type: "Animation for office, school and home" (on two lines - type a 
Return before "school") or substitute your own product description 
instead. ; 

34. Close the Paint window. 

35. Open the Cast by selecting Cast from the Window menu. 

We will be using one of the special Inks, which are only available with the long VideoWorks 
menus. | | 

36. Pull down the Ink menu and look at it. Which of the following kinds of ink 
menu do you have? 

“Erase -normal 

No Erase-leaves trails 

“Erase -normal 

No Erase-leaves trails 

-normal 

-outlines edge 

-normal 

Matte -outlines edge 
Or -transparent 

Hor -black reverses 

Bic -black is eraser 

NotCopy-invert then Copy 

Matte 

Short Ink Menu 

NotOr -invert then Or 

NotHor -invert then Hor 

NotBic -invert then Bic 

Mask -for donut holes 
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Long Ink Menu 

If you have the Long Ink menu, then go to the next step of the tutorial. 

If you have the Short Ink menu, then select Long Menus from the Control menu. 

37. Click channel 2 at the Channel Indicator 

select "Or - transparent”. 
From the Ink menu, 
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40. 

41. 

— 42. 

43. 

44. 

45. 
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Rewind. Back Step one frame. This locates the ———— Head at the 
end (frame 50). 

Drag the second castmember out of the Cast and onto the right edge at 
the Stage so that just the first letter or two are visible. 

* File Edit Control Sound Window Text Draw Ink 
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lf it's not visible, open the Score. Position the Score near the bottom of 
the screen. 

Choose Copy Score from the Edit menu. 

Scroll the Score to frame 80 and choose Paste Score from the Edit 
menu. 

Click the Playback Head bar at frame 80. The Playback Head should jump 
to this frame. 

Move the mouse pointer to the text "Animation for office, school, and 
home" at the right of your screen so the tip of the pointer is somewhere 
near the center of that text. Press and hold the Shift key. Press the 
mouse button and (while holding the Shift key down) drag the text 
straight to the center of the Stage. 

Release the mouse button (and the Shift key). 
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46. Select the frames in the Score by placing the pointer just to the left of 
channel 2 in frame 50, pressing the mouse button and Bescing it down as 
you drag the pointer all the way to frame 80. 

The Score should now look like the following figure, with all frames black, from 50 to 80. 
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47. Choose /In-Between from the Edit menu. This fills in the intervening 

frames. 

48. Press Command-1 and Command-Q. Watch the text. 

49. Press Commanda-1 again to bring all of the windows back. 

50. Click on Stop at the Panel. 

Make Your Macintosh Speak 

Next we will add Macintalk, a speech package developed by Apple Computer. 

51. Open the Score if it is not visible now. 

52. Scroll to frame 80. Click the Playback Head bar at frame 80. 

53. Pull down the Window menu and select Text. Scroll down to row A71. 

54. Click anywhere in the row of the Text window labeled A71 and type: 
"Animation for office, school, and home" (or substitute your own 
message). This is the text that will be spoken by the Macintosh. 

55. Close the Text window by clicking in its close box. 

56. In the Score, select frame 80 of the sound channel (the top channel). 

Make it selected black. 
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Pull down the Sound menu and stop at the item ndmed Macintalk. A 
submenu opens up at the left. Keep holding the mouse button down and 
move to the first item, Cast #7-1. The Macintalk sound is now added to 
the score. 

Note: If there are no menu items in the Sound menu you 
have the Sounds file in the wrong place on your disk. See “Sound 
Files" in the Reference section. 

Note: If you are using a system prior to System 4.1, your 
Sound menu will be different. In this case, pull down the Sound menu 
and choose the last item "Macintalk." Pull down the Sound menu 

_ again—notice it has different commands (this is a submenu). Choose the 
first item, Cast #7-1. 

Click Rewind at the Panel. Type Commana-1 to clear the Stage. Type 
Command-@Q to start the movie. We have displayed the text that is being 
spoken. Macintalk text does not have to be on-screen to be heard. 

When you are done watching, type Command 17 to bring back the 
windows. And click the Stop button in the Panel. 

Note: If you hear no sound, first make sure the sound is turned 
on at the Panel-the loudspeaker should be white on a black background 
with sound coming out of it. Also check the volume control in the 
Control Panel desk accessory. If that doesn't work, refer to "Sound 
Files" in the Reference section. Most likely you don't have the 
Macintalk file in the right place on your disk. 

Add a Gray Background 

84 
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61. 

62. 

63. 

64. 

65. 

Next we will add a gray background with a border around the text. 

Open the Score if it is not visible and scroll to frame 80. Click the 
Playback Head bar at frame 80 to make the Stage display that frame. 

Close the Score by clicking its close box. 

Click channel 1 at the Channel Indicator. channel 1 is for the 
background. 

Click the QuickDraw rectangle tool at the right end of the Cast. Notice 
the pointer changes to a crosshairs with a tiny box attached to it. 

C 

Move the pointer to just above and to the left of the text "Animation for 
office, school, and home". 

Press the mouse button and hold it down while you draw diagonally 
across the text — this motion will draw a rectangle around the text. 
Release the button when the rectangle surrounds the text. 

Note: If the rectangle appears over the text, then the text is in a lower 
numbered channel than the text box. The text should be in channel 2, 
and the rectangle in channel 1. 
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66. Pull down the Draw menu, move the pointer to a light shade of gray (in 
third row of patterns, the third pattern over), and release the button. 

Notice the rectangle fills with that shade. 

67. Pull the Draw menu down again, move the pointer to select one of the 
thicker lines in the top row. 

This sets the line width of the rectangle 

68. Open the Score from the Window menu. 

69. Select channels 1 and 2, frames 80 to 145, by dragging the pointer 
across those cells. Make sure you have both channels 1 and 2 selected 
as in this illustration: 

Point of Purchase Score 
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70. Choose /[n-Between from the Edit menu. This does a "fill right," copying 
frame 80 to frames 81 through 145. 

This causes the text and the gray border to remain in one place for those frames. 

71. Click Rewind at the Panel. Press Commanda-7 to clear the Stage. Press 
Commana-@ to start the movie. 

72. When you are done watching, press Command-7 to bring back the 
windows. 

Make the Border Grow 

73. Open the Score (if not already open). 

74. Scroll to frame 145. Select the cell at channel 1, frame 145. 

75. Choose Copy Score from the Edit menu. 

76. Scroll to frame 175. Move the Playback Head to frame 175 by clicking the 
mouse in the Playback Head bar on that frame. 

77. Select the cell at channel 1, frame 175. 

78. Choose Paste Score from the Edit menu. 
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VideoWorks 
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79. Move the cursor to the Stage. Grab the upper left corner of the rectangle 
(you must click on the little box in the corner which is the Resize Handle) 
and pull it to enlarge the rectangle. 

80. Do the same for the lower right corner, to make the rectangle almost fill 
the screen. Press Command-1 to see how the rectangle looks on the 
Stage; if it needs to be adjusted press Command-1-to return to the 
windows and resize the rectangle. 

81. Select the cells in channels 1 and 2, from frame 145 to 175. 

82. Select /n-Between from the Edit menu. 

This stretches the rectangle primitive over time, as well as doing a "fill right" on the text. 

83. Click Rewind at the Panel. Press Command-1 to clear the Stage. Press 
Commana-Q to start the movie. | 

84. When you are done watching, press Command-1 to bring back the 
windows. 

Add a Piece of Art 

Next we will use Art Grabber+ to grab the VideoWorks Logo. 

85. Choose Art Grabber+ from the Apple menu. A new menu called Grabber 
appears at the right end of the menu bar. | 

86. Choose Open from the Grabber+ menu 

87. Select the file "VideoWorks Logo,” click on it, then click Open. 

88. Move the pointer into the Art Grabber+ window. Select the VideoWorks 
logo graphic as follows: Start above and to the left of the art. Press the 
mouse button; drag diagonally across the art-this will draw a selection 
rectangle around the art. When you reach the edge of the screen, Art 
Grabber+ will automatically scroll. Uk Lee Le UO UU 

89. Choose Grab from the Grabber+ menu, or choose Copy from the Edit 
menu. This places the art on the Clipboard. | 

90. Close Art Grabber+ by clicking its close box. 

91. Click position A13 of the Cast. 

92. Choose Paste Graphic from the Edit menu. This bring the art into 
VideoWorks. 

93. Scroll the Score to frame 175. Click on the Playback bar at frame 175. 

94. Click channel 3 at the Channel Indicator. In the Ink Menu, select Matte. 

95. Drag the VideoWorks Logo out from the Cast onto the Stage, over the 
gray rectangle. 

Notice that the enclosed letters in the VideoWorks Logo appear white. This doesn't look very 
good, so let's fill them in with the background pattern. 
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VideoWorks 

96. Command-click on the VideoWorks Logo on the Stage. That is, hold 
down the Command key, and click once on the artwork. : 

This automatically opens the Paint window and brings the VideoWorks Logo to the front. 

97. Select the from the Draw menu the same pattern you are using for the 
rectangle on the Stage. Use the Paint Bucket to fill in the enclosed 
letters of the Logo. 

Note: If paint spills outside of the Logo, select Undo. You don't need 
to fill in a letter which paint spills out of. 

98. Select frames 175 to 230 in channels 1, 2 and 3. (Make sure you have 
selected all three channels). | 

99. Choose In-Between from the Edit menu. This = a fill right. 

100. Click Rewind at the Panel. Press Command-1 to clear the Stage. 
Press Command-Q to start the movie. 

101. When you are done watching, press Commana-1 and click Stop. 

Adda Parting Message 

102. Scroll to frame 200 in the Score and click the Playback Head Barto move 
the Playback Head to that frame. 

103. Click the Text Box|A| at the right end of the Cast. 

Your cursor has now become a kind of cross shape. You can still select windows, menus, etc. 

with this cursor (the point is at the intersection of the cross). 

104. Select channel! 4 at the Channel Indicator. 

105. Move the pointer out onto the Stage. Draw a rectangle with it, about 2 
inches wide by 1 inch tall. 

106. Type into it: "Available Now!" Set the Font/Size/Style to New York 18 
Bold. 

Note: You can only change the Style (bold) when the text is selected 
(inverted so it looks black). 

Open the Score and select frames 200 to 230 in channels 1,2,3 and 4. 

108. Choose /n-Between at the Edit menu. 

109. Click Rewind at the Panel. Press Command-7 to clear the Stage. 
Press Commanda-@Q to start the movie. 

110. When you are done watching, press Command-1 and Click Stop. 

eee RE ERE ERE Ak 
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This part describes all of the steps in creating animations. It begins with an 
overall description of the process ("The Big Picture"). Its sections are then 
ordered according to the way you would produce an animation. It covers 
Overview (step 1 in the process), followed by VideoWorks (steps 2 through 13). 
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The Big Picture: Overview and VideoWorks 

Overview 
Overview Terminology 
A Simple Slide Show 
A Combination of Movies and Slides 

VideoWorks 
VideoWorks Terminology 
A Simple Animation 
Side-by-Side Comparison of Overview and VideoWorks 

The Process of Animation 
Overview 
VideoWorks 
Stage, Castmembers and Score 

1. Working with Overview 
The Overview Window and Overview Documents 
How to Add Documents to Overview 
Controlling an Overview Document 
Organizing Documents in Overview 
Using Timers 
Using Transitions 
Using Sounds 
Using Glue Documents 
Using Clip Animation 
How to Annotate a Slide 
Positioning a MacPaint, PICT, or Glue Document 

Using Get Info on a VideoWorks Document 
Printing in Overview 
Layout Options 
How to Launch Applications from Overview 
Moving Between Overview and VideoWorks 
Limits on the Number of Clip Animations 
Overview Hints 

2. Creating Artwork 
Using the Paint Window 
How to Create Artwork in the Paint Window 
Changing the Ink for Painting 

Using the Cast 

3. Creating an Animation 

Real-Time Recording 
How to Animate Using Real-Time Recording 
Channel Selection in Real-Time Recording 

Frame-by-Frame Animation \ 

How to Animate a Sequence Frame-by-Frame 
Foreground Priority 
Registration Points Make Animation Easier 
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Overview 

—— 136 4. Controlling an Animation 
136 Panel 

= 136 Numeric Keypad 
— 136 Light and Sound Switches 

136 Channel Indicator 
=a 137 Using the Record Lights 

a 
138 5. Editing an Animation 

— 138 Editing Artwork on Stage (Score Closed) 
— 138 = How to Place Artwork on the Stage ees 

139 How to Remove Artwork from the Stage — Blank From Stage 

—-" 139 How to Select Artwork on the Stage 
al 140 How to Re-Position Artwork on the Stage 

140 How to Constrain the Positioning of Artwork — Shift Key 
—— 141 How to Stretch Artwork on the Stage 
lel 141 How to Switch One Piece of Art on Stage with Another in the Cast — — Switch Castmember 

142 A Mini-Tutorial: The Principal of Selecting and Choosing : 

—— 144 Basic Editing in the Score 
— nil 144 Getting Around in the Score 

| 146 How to Select in the Score — "Select black" and "Select blinking" 
as 149 How to Re-Position a Sequence of Art 
=" 149 How to use Tweak — Tweak window 
= 150 How to Change Foreground Priority — Cut Score and Paste Score 

151 How to Insert Frames in a Movie — Insert Frame 
= a 151 How to Delete Frames from a Movie | — Delete Frame and Clear Score 

a. 153 Intermediate Editing in the Score 
153 How to Cut, Copy and Paste in the Score — Cut, Copy and Paste Score 

— 153 How to Clear Cells from the Score — Clear Score 
—_ 154 How to Insert and Delete Time in a Movie — Cut and Paste Score 

155 A Mini-Tutorial: Understanding Cut, Copy, Clear, and Paste 
ey 156 How to Create Stationary Artwork in a Movie : — In-Between 
— 157 How to Make Artwork Move Smoothly Between Two Points — In-Between 

158 How to Make Artwork Stretch as it Moves — In-Between 
= 159 How to Use Paste-Relative to Chain a Sequence — Paste-Relative 

—— 160 6. Adding QuickDraw Shapes 
ory 161 7. Adding Film Loops 
ae 161 How to Create a Film Loop 

162 Animating with a Film Loop 
—— 162 Setting Registration Points in a Film Loop 
lll 162 Storing Film Loops 

163 Using In-Between to Move a Film Loop Across the Stage — Shift In-Between 

a 164 8. Adding Text 
164 How to Type Text in the Paint Window 

Fr 164 How to Type Text in the Text Window 
ll 165 How to Type Text Directly On Stage — Text Box 

— 166 9. Adding Sound, Tempos and Transitions 
— 166 Adjusting the Volume 
= 166 ~ Howto Add Sound to a Movie 
a 166 Synchronizing Sound to Pictures 

167 Removing A Sound 
167 Re-Triggering a Sound 
168 How to Make a Sound Repeat 
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Overview 

169 
169 

How to Make Sound Dependent on the Position of Art : 
How to Make Your Macintosh Speak 
Sampled Sound (Sound Cap) 
Music Works 
How to Add Tempos 
How to Add Transitions 

10. Using Inks 
How to Change the Ink in Animations 
Useful Things to Do With Inks 

11. Importing Artwork 

Using Art Grabber+ 
How to Grab Art Using Art Grabber+ 
Viewing the Clipboard 
Importing a Group of Pictures 
Grabbing Art from the Current Screen 

Using the Scrapbook 

12. Printing in VideoWorks 
Layout Options 

13. Advanced Animation 

Advanced Editing 
Other Ways to Place Artwork 
Creating a New Document with the Same Cast 
How to Move Artwork and Animation Between Movies 
How to Use the Scrapbook to Import Artwork 
How to Repeat Just a Portion of a Movie 
How to Set a Registration Point 
How to Create an Ink Mask 
Making an Ink Mask for Artwork That Has No Outline 
Returning Artwork on the Stage to its Original Size 

Advanced Art Techniques 
Creating a Sequence of Artwork 
How to Combine Several Pieces of Art into One Full-Screen Background 

Advanced Animation Techniques 
How to Create Scrolling Text 
How to Create an Animation that Draws Out Letters 
Speeding Up or Slow Down a Sequence 
How to Switch a Moving Piece of Art 
Inserting Many Blank Frames in the Middle of the Score 
Accentuating a Motion 

Advanced Sound 
Sampled Sounds ("Real" Sounds) 
MusicWorks to VideoWorks 

Adding Color 3 
Selecting Colors in the Color Window 
Using Color Inks 
Memory Considerations When Using Color 
Display Monitors | 
Analyzing an Animation 
What Can I Do to Improve My Animations 
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The Big Picture: Overview and VideoWorks 
VIDEOWORKS II is a real-time computer animation program. Real-time means that you can create 
an animation and play it back immediately to see the results of your work. In fact, you can even 
modify the animation while it’s playing. There is no lengthy compile or transfer phase. 

However, real-time also means that the more artwork you move, the slower it gets. This is not 
usually a problem, though, if you keep aware of this issue and anticipate its effect. Animations 
also run faster on faster machines, for example, the Macintosh II compared to the Macintosh SE. 

An important feature of VIDEOWOoRKS II is the ability to freeze the animation at any point and 
print it. You can easily print an entire series of pictures full-size or reduced to fit a storyboard. 

VIDEOWORKS II has two parts, Overview and VideoWorks. You can use either as a stand-alone 
application, or use them jointly. When we refer to VideoWorks throughout this manual, we are 
referring to this one part of VIDEOWoRKS II. 

e Overview is for creating animated slide show presentations. It lets you work at the 
document level, combining completed documents into a finished presentation. If you need to 
edit these documents, you can launch VideoWorks, MacPaint, MacDraw, or other applications 
from Overview. : ? 

¢« VideoWorks is for creating and editing animations. 

You can easily move between these two parts by choosing the command "To VideoWorks" or 
"To Overview" at the File menu. 

With Overview, instead of just adding clip art to your slide show presentations, you can now go a 
level beyond that and include action by adding clip animation. We have included a disk of clip 
animation for you to get started — or you can create your own. 

OVERVIEW VIDEOWORKS 

Use Overview to put together slide show presentations and VideoWorks 
for creating and editing individual animations or annotating a slide show. 
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Overview 

The Overview window is the starting point for learning VideoWorks. Here you can combine 
existing movies, MacPaint, PICT and Glue documents together with sound, quickly and easily to 
form dramatic, animated presentations. And you can add timers or transitions to fill out the 
presentation. : 

The following illustration shows the building blocks for an Overview document. 

Sound 

Timer 

Transitions 

Overview 

Overview building blocks 
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Overview Terminology 

These are some basic Overview terms. For more terminology, see the Glossary 
at the end of the manual. 

A slide is any still picture — any MacPaint, PICT, Glue document — or a VideoWorks 

document that contains only one picture (a single frame). 

A slide show is any combination of slides, along with timers and transitions. 

An animated slide show is a series of slides with animation appearing in front 

of the slides. We call these animation extras clip animation. 

A movie is an entire animation, complete with various pieces of artwork and a 

background, all in the same file. 

A presentation is any of the above — from a single slide to a full animated slide 

show with movies and sound. You can string movies together and embellish 

them with introductory title slides, background slides, closing slides and overlay 

slides that annotate and identify parts. 

An Overview document is any presentation created in the Overview window. 

The Stage is the full screen window where you watch the animation. 
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il A Simple Slide Show 

Using Overview, you can create the simple slide show shown below. The slide show consists of £_ 
four MacPaint documents with two transitions and two timers. Notice that time progresses to the 
right. ae 

__ 
This slide show proceeds from left to right as follows: . 

2 SHS es "Introduction" displays for 3 seconds with music. — 

oe WOO css "Introduction" is pushed right by "Projection", which displays for 3 seconds. ie. 

3. Slide........."Sales" displays for 5 seconds. 

4. Slide......... "Sales" dissolves into "Profits", which displays for 5 seconds. — 
—o 

Transitions sontcal how one picture changes to the next. They come in over two dozen varieties, 
including wipes, reveals, pushes and dissolves. 

The first timer sets the duration of the first two MacPaint documents to 3 seconds each (notice the 
"3" above each MacPaint document). The second timer sets the remaining two MacPaint 
documents to 5 seconds each. 

This slide show was created very simply by dragging the icons into the arrangement show. You 
can easily re-arrange the presentation by dragging the icons into a new order. Generally, you can 
simply drag out any of these building blocks onto the working area to build up your presentation. 
You can start with a single slide (MacPaint document or PICT) and build to a series of slides. 
Then annotate your slides with overlays. Add clip animation. Add movies. 

If you wanted to modify the "Projection" document. You would select that icon and choose the 
Launch Editor command. This would launch MacPaint and open up the document "Projection" for 
you to edit. When you have saved and and quit MacPaint, you would be returned to this Overview 
exactly as you left it. 

Similarly, you can launch VideoWorks to modify a VideoWorks document or MacDraw to launch 
a PICT document. In fact, you can launch to any program that can save in the MacPaint or PICT 
format, such as Graphic Works, SuperPaint and MacDraft. 

Timer — ~— Slide Transition Slide Timer Slide Transition Slide 

Introduction jecti r Profits 

Timer sets each slide to 3 seconds Timer sets each slide to 5 seconds 

Overview Presentation #1 — A SIMPLE SLIDE SHOW 
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A Combination of Movies and Slides 

The following is a more involved Overview document, containing both movies and slides. This 
presentation plays out from left to right as follows: 7 

1. Slide ‘and MUSIC «2.5.2 cccas ec “Welcome” appears for 3 seconds with music 
"Pastoral." 

2. Movie and Background................. The slide "Backdrop" appears with "The Sale" 
animation in front of it. 

3. lV Pansiiion... 5 oe ee is Wipe left from "Backdrop" to "Scenery." 

4. Movie and Background................."Scenery" appears with "Follow up" appearing in 
| front of it. 

5 2 Movie: 35. 2 akon. ea eee The "Closing" animation plays, to finish the 
presentation. 

The purpose of the Timer is to set a duration for slides unaccompanied by movies. (Movies, of 
course, have their own duration, but slides do not.) We'll leave further description for later. 

As we mentioned, you can freely re-arrange these documents simply by dragging them. You can 
also easily add, remove or duplicate any of the documents to change the presentation. 

Slide Movie Transition Movie 
& & & 

Sound Background Background 

= | aw ih ees (h a Nt? 

SJ — [aa] — [ad —L 0? ie 

~; 

Welcome Backdrop Scenery Closing 

a No 
= 

“Sa 
s & td as 

Pastoral The Sale FollowUp 
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Overview Presentation #2 — COMBINATION OF MOVIES AND SLIDES 

ki kk ik 
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Here are more ideas for creating presentations with Overview: : 

¢ Create a slide show made up strictly of MacPaint documents. 

e Annotate your slide show by adding arrows and words. Do this by overlaying a VideoWorks 
frame in front of the slide. For example, if your slide shows a map, you could ey an 
arrow with a label pointing out where your company is located. 

e Add documents from MacDraw, MacDraft, GraphicWorks, SuperPaint, MacCAD, PowerPoint 
and other applications You can also add any Glue document. Glue is an application that 
allows you to bring in pictures and text from almost any application, including Excel, 
Illustrator, and PageMaker — especially those that cannot save as PICT or MacPaint files. 

e Add clip animations to your slide show. You can begin with the clip animations we have 
supplied on the Movies disk. 

Add a background to a movie. 

e String movies together, to make presentations that are 10, 15 minutes or even longer (on one 
800K disk). 

Add a title slide before a movie, intermediate slides between movies, or a closing slide at the 
end of a movie. 

¢ Use Overview as a convenient "shell" for viewing any type of document. Save off to disk any 
combination of documents, practice presentations or special demonstrations. 

We're now going to show you VideoWorks. It uses a more sophisticated process — but gives you 
more control. 
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VideoWorks 

VideoWorks is the animation part of VIDEOWORKS II. While Overview lets you combine and 

arrange existing documents, including animations, VideoWorks lets you create and edit those 

animations. It lets you draw with a paintbrush and type in text, creating anything from simple 

slide overlays to elaborate animations. You can run VideoWorks either stand-alone or launch it 

from Overview. For more terminology, see the Glossary at the end of the manual. 

VideoWorks Terminology 

A movie is a VideoWorks animation, saved to the disk in its own file. The icon for a movie is 

shown below, on the left. The terms file, document and movie are loosely interchangeable. 

A sequence of art is a series of related pictures in one channel. For example, a person walking, 

a frog leaping, a horse galloping, a ball bouncing, or text scrolling across the screen. When we 

use the term sequence by itself, it means sequence of art. : 

Artwork is any picture or graphic image. It can be created in Paint, it can be a QuickDraw shape, 

or it can be brought into VideoWorks using Art Grabber+, Scrapbook or the Clipboard. We also 

refer to artwork as art. 

A castmemberis a piece of artwork or text that is stored in the VideoWorks cast. 

The cast is what holds all of the artwork and text in VIDEOWORKS II . | 

A frame is the entire scene that appears on the Stage at one moment in time. Think of it as a 

frame in a strip of film. Thus, the length of a VideoWorks movie is measured in frames. A movie 

can be hundreds or as long as thousands of frames. In the Score, a frame is represented by a 

vertical column across all channels. The frames are numbered — the numbers appear across the 

top of the Score. In this sense, a frame is roughly an increment of time. The current frame is the 

frame that currently appears on Stage - it is also marked by the position of the Playback Head. 

A channel is a row in the Score. Each channel holds one piece of artwork at one time. The — 

Score has 24 animation channels and another channel for sound, tempo and transitions. 

A frame cellis one of the small boxes in the Score, one channel high and one frame wide. 

Each cell represents of a single Castmember at one moment in time. 

SeecERREE: EBEEREEE 
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frame cell 

Ink \ets you control whether artwork is transparent or opaque. Inks also let you reverse white 

and black, create ghost images, change solid black regions to any pattern, plus create other 

effects. Basically, ink determines how artwork interacts with any artwork behind it. 

The Score is where all of the animation information is stored in VideoWorks . The Score is also 

where the animation can be edited in detail, and where sounds or transitions can be added. 
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A Simple Animation 

Using VideoWorks, you can create the simple movie shown below — an animation of a woman 
walking by a parked cab. Of course, the frames would appear one at a time on the screen. We 
have shown the five-step sequence in one picture, spaced apart, for purposes of illustration. 

The walking woman is an example of action made up of a sequence of five pieces of art 
(castmembers). We have taken this sequence from the middle of a movie, frames 5 through 9. At 
the bottom of the illustration is a representation of the same sequence taken from the Score. The 
Score contains notation indicating how the action progresses over time. 

Like the Overview window, this animation plays left to right in the Score. The animation runs as 
follows: 

eg 1 je Seane epee Woman stepping with her left foot 
PISMO Goo. iis: Aes Woman in the middle of her first step 
NG oo cxacecagascs vcias Woman in full stride 
pe a Woman taking her second step with her right foot 
oe ee er Woman finishing her second step | 

This movie plays at the speed you set in the Panel. The woman and cab each occupy their own 
channel in the Score. Notice the arrows — they indicate the direction the woman is moving. The 
Score allows you to also identify the castmember number, position on Stage and inks (we'll 
describe these later). The Score represents the entire movie like an orchestral score represents an 
entire symphony, or a script represents an entire theatrical play. 

You could change the 3-dimensional effects by making the woman pass behind the cab by putting 
the cab in channel with a higher channel number than the woman, say channel 3. At any time you 
can change the foreground priority by moving either the woman or cab to a new channel. 

r 
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An animation of a woman walking past a cab, shown with the Score. 
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Side-by-Side Comparison of Overview and VideoWorks 
You can draw a parallel between VideoWorks and Overview. The Overview window is analogous 
to the Score and Cast. Also, the VideoWorks frames are analogous to Overview slides. This chart 
shows the similarity between Overview and VideoWorks. Notice how similar the Panels are, as 
well. 

Overview VideoWorks 
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The Process of Animation 
The VIDEOWORKS II process of animation can be broken down into the following parts. These 
parts are the section headings that form the remainder of "How to Animate." We're including each 
section's page number for reference. 7 

Overview 

(Page 106) 1. 
Bron 

Working with Overview 
The Overview window is the place to combine movies, artwork and sound into a single — 
presentation. While Overview is easy to use, the results can be elaborate . 

You can combine movies, MacPaint, PICT and Glue documents into a slide show, and add 
fancy transitions between them. You can include artwork from Graphic Works, charts from 
Excel, drawings from MacDraft, digitized photographs from Thunderscan, 3- dimensional 
renderings from Easy3D, drawings from Illustrator, and presentations from More. 

You can show movies in front of the slides; annotate a slide using VideoWorks; synchronize 
the slides to music; and print the slides full-size or reduced to fit a storyboard. 

VideoWorks 
The following are all of the steps involved in creating a complete movie within VideoWorks. Of 

course, not all of these steps would apply to a simple movie. As you read, refer to the illustration 

"Four Steps to the VideoWorks Process" located at the end of these steps. 

(Page 126) 2. 

(Page 130) 3. 

(Page 136) 4. 

Creating Artwork — The first step in any animation is creating or importing the artwork. 
You can create your own art in the Paint window in VideoWorks, or you can bring in outside 
artwork. If text is an important part of your animation, you should create text at this point 

as well. 

Creating an Animation — Once you have the artwork, the second step is to animate that 
artwork. There are two different techniques available for producing an animation: 

¢ Real-Time Recording is the process of recording artwork as you move it around on 
the Stage. Your movements with your mouse are recorded in real time, rather than one 
frame at atime. Tutorial #4, the Bouncing Face, shows the characteristic smooth and 
fluid motion of Real-Time Recording. 

e Frame- by-Frame Animation is the process of animating one frame at a time, 
placing and arranging artwork on the Stage, and doing precise editing. It is the main way 
you interact with animations. You can also use In-Between, which automatically moves 

artwork for you between two points. Tutorial #6 makes use of Ss animation 

in enatny the jumping frog one frame at a time. 

You can freely use either technique at any time in a single animation. They are simply two 
different ways of recording. Use Real-Time Recording when recording a single piece of art 
moving around on the Stage, and Frame-by-Frame in almost every other case. 

Controlling an Animation — At the Panel you can play an animation, stop it, step one 
frame at a time (either forward or backward) and rewind to the beginning, much like a tape 
recorder. You can also change the speed, and turn the sound or lights on or off. An indicator 

_lets you see which channels are occupied. 
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Editing an Animation — Once you have created a basic animation, you may find it is 
not exactly like you had planned. Perhaps one piece of artwork moves in front of another 
instead of behind it. Perhaps the action needs more animated artwork, or needs some taken 
away. Perhaps the action is taking place at the wrong place on the Stage, or is happening 
too fast. Whatever the case, this is where editing comes in — to modify the animation. 

Adding QuickDraw Shapes — QuickDraw Shapes are rectangles, ovals and lines that you 
can draw directly on the Stage, rather than in Paint. The tools for these shapes are found at 
the right end of the Cast window. These shapes take up less memory than identical shapes 
drawn in the Paint window. | 

Adding Film Loops — Each Film Loop is a sequence in real-time, usually one that cycles 
as it moves, such as a ball spinning, bird flapping its wings, a coin flipping, or a person 
walking. Film Loops can cut down the time it takes to record these animations, and are a 
great way to liven up an animation. 

/ 

Adding Text — Text is an important part of many animations. VideoWorks provides two 
ways to produce text: in the Paint window (bit-oriented text) and in the Text window 
(character-oriented text). Each kind of text has its advantages. Paint window text is good for 
moving across the screen, but text in the Text window takes up less memory and is easier to 

change (it has a search and replace feature). 

Adding Sound, Tempos and Transitions — Once you animate the artwork, you can 
add sound effects or music to accentuate it. You can also modify the tempo and create | 
transitions between frames. 

VideoWorks provides you with the capability for music, speech, sound effects and sampled 
sounds. You can enter sounds into the sound channel, where you can synchronize the sound 
to the pictures. Nearly 100 built-in sounds are available. 

Using Inks — Inks modify the way artwork appears on the Stage and how its patterns 
interact with artwork behind it. For example, makes artwork transparent. Inks also allow 
you to leave trails behind artwork, see the background through holes, remove the white box 
from around artwork, change black (or white) to any pattern, and apply other visual effects. 

Importing Artwork — You can bring in graphics to use in your animations. To give just 
a few examples: Artwork from MacPaint or GraphicWorks, charts from Excel, drawings 
from MacDraft, digitized photographs from Thunder scan, 3-dimensional renderings from 
Easy 3D, and drawings from Illustrator. All of these can be used in the Overview window. 
Any artwork can be brought in as castmembers and manipulated within a movie directly on 
the VideoWorks Stage. 7 

Printing — VIDEOWORKS II allows you to print any frames from your animation at full 
size, or reduced to 50% or 25% for storyboards. You can use this feature for keeping records 
or making presentations without a computer — on paper, or with an overhead projector. 

Advanced Animation — Once you have created a few animations, you may want to go 
beyond the basics. Advanced techniques can markedly improve an animation, as well as 
reduce the amount of effort required to create it. | 
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Stage, Castmembers and Score 
The diagram below shows the process of using VideoWorks. It shows how you can import and 
create art, bring it into the Cast, animate it on the Stage, and record it in the Score. 

The Cast holds art and text. We call each piece of art or text that resides in the Cast a castmember. 
Each castmember waits backstage, so to speak, for its chance to go on Stage and perform in a 
VideoWorks movie. Some castmembers, like background scenery, might be on Stage for the 
entire movie. Other castmembers might be on Stage for a brief moment. 

Almost all of the artwork that appears on the Stage comes from the Cast. The only exceptions are 
QuickDraw shapes. You can create QuickDraw shapes and type text directly on the Stage. 

THE VIDEOWORKS PROCESS : 
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IMPORTING ART, TEXT DATABASE OF 

ARTWORK 
AND TEXT 

OF AND 
ARTWORK QUICKDRAW 

SHAPES 
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This section describes Overview, the first step in the 
process of animating with VIDEOWORKS II. Overview 
allows you to work with entire documents to create 
animated slide shows. 
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1. Working with Overview 

Overview allows you to create an animated slide show. You can easily arrange your movies, 
MacPaint and PICT (MacDraw) documents for playback in any order you prefer, and include sound. 
You can also add transitions between any documents. 

Here are a few of the many things you can include in an Overview presentation: 

e Create a slide show — a series of MacPaint documents 

e Add clip animation in front of slides — like clip art, but animated 

¢ Include movies — 

¢ Overlay annotation on existing slides or movies for emphasis 

¢ Add title slides and closing slides 

e Add sound 

« Any combination of the above 

You have a great amount of control over these animated slide shows. You can play, stop, and step 
backward and forward. You can operate the mouse like a slide projector button, letting you step 
forward. You can even skip through the documents to move quickly to a particular place in the 
presentation. 

The Overview Window and Overview Documents 

The Overview window displays the current Overview document. An Overview document can be 
any presentation including slides, annotation, clip animation, movies, transitions and sound. The 
name you give the Overview document appears in the Title bar. 

Even for very large presentations, an Overview document remains very small, taking up very little 
memory (typically 1K). That's because it is a collection of document names. When you play an 
Overview document, it opens up the documents that are called out. Therefore, in the illustration 

below, if you were to go into MacPaint and change the document titled "Welcome," that change. 
would take effect next time you ran the Overview document. 

An Overview document is any arrangement of icons in the Overview window. We refer to this as 
a presentation. The way you typically build a presentation is as follows: 

1. Drag slides or movies into the background row. 

Add Timers to control the timing of the slides. 

Add Transitions between slides and movies. 

2 

3 

4. Add Sound below any slide or movie. 

5 Add VideoWorks documents below any slide (or movie) for annotation or clip animation. 

6 Choose Get Info for each document to fine-tune the presentation. 
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A presentation of movies and slides with a transition, a timer and sound. 
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How to Add Documents to Overview 
The following procedure describes how to drag icons out into an Overview document. First get 
into Overview. If you're in VideoWorks, choose To Overview in the File menu. Then drag an 
icon from the icon bar into the working area. The document appears as an icon in the Overview 
work area. : 

Icon 

bar 

Documents — The documents listed below are the slides and animations you can view. 

When you drag a document icon out, a dialog box appears. Click on the document you want, 
then click Open. 

! he Us cs 

MacPaint document 8 | Overview document Glue document 
e ar 

PICT document Bod VideoWorks document 

Timer — Timers let you set how long each slide plays. 

When you drag the Timer icon out, position it ahead of (or beneath) the first slide whose 
length you want to affect. Type the number of seconds you want each slide to be displayed, 
then press Return. Thus, if you type "5", each slide will play for 5 seconds. 

As you notice, the number you typed appears below the Timer. It also appears above each 
slide that follows, indicating its duration. This Timer remains in effect until another Timer is 
encountered. For more details, see "Using Timers." 

Transition — Transitions let you determine how one picture changes into the next. 

When you drag the Transition icon out, place it between the two documents you want to 
affect. (Transitions also work at the very start or end of a movie.) A dialog box appears with 
the transition choices. Select the Transition you want, then click OK. (Chunk Size and 
Delay are described later.) For more details, see "Using Transitions." 

Sound — You can add any sound that is available in the Sound menu. 

When you drag the Sound icon out, place it where you want it to occur. Pull down the Sound 
menu. Move down to the category you want and pause — the submenu should pop up. Move 
sideways and choose the sound you want . For more details, see "Using Sound." 

3) fis 

Note: Sound Menus — If you have a Macintosh System prior to 
System 4.1, your Sound menu operates differently. See the description 
under "Sound Menu" in the VideoWorks Reference section. 
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Controlling an Overview Document 

You can control the playing of an Overview document five ways: from the Panel, at the Control 

menu, with the mouse button, with the Space Bar, and with the Playback Head. 

Panel 
Click on any of the Panel buttons: 

¢ Play button starts the presentation; 

e Press Stop button to stop it. 

¢ Step skips to the next column and plays that column. The action then either stops at the end 

of that column (if it was previously stopped) or continues (if it was previously playing). In 

other words: 

If the document is stopped when you press Step, the presentation skips to the next 

column, plays through that column and stops. 

If the document is playing when you press Step, the presentation skips to the next 

column and continues playing from there. 

¢ Rewind returns the presentation back to the beginning (and stops it if it was running). 

e Back Step steps backward one column. 

Note: The presentation will not stop during a transition. If you try to 

stop the presentation during a transition, it will continue through the 

transition and then stop 

Control Menu 
All of the controls described under Panel are duplicated in the Control menu. The controls are 

identical. 

Mouse. Button . | 

When you click on the Stage the mouse button operates exactly the same as the Step button when 

the presentation is playing. That is, each time you press the button, the presentation skips to the. 

next document. In a slide show, when the presentation is stopped, pick up the mouse and use the 

button like you would the remote control on a slide projector, to run the slides at your own pace. 

Space Bar 
When a presentation is playing, you can stop it at any time (except during transitions) by pressing 

the Space Bar on your keyboard. To continue, press the Space Bar again. 

Playback Head 
You can jump to the start of any document in the presentation simply by clicking in the Time Bar 

on the number at the top of that column — the Playback Head jumps to that position, and then the 

document appears on the Stage. | 

Numeric Keypad | 

If your Macintosh has a numeric keypad, you can also control the Overview from it. Here are the 

functions of the various keys on the numeric keypad: 

Keys = Commands 

Enter Play 
1,4 Back Step 
2,5,Period Stop 

3,6 - Step 
0 Rewind 
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Organizing Documents in Overview 
The way you typically build a presentation is as follows: 

Drag slides or movies into the background row. 

Add Timers to control the timing of the slides. 

Add Transitions between slides and movies. 

Add VIDEOWORKS II documents below any slide (or movie) for annotation or clip animation. 

Add Sound below any slide or movie. 

Add VIDEOWoRKS IT documents into the background row. 

Choose Get Info for each document to fine-tune the presentation. 

You can re-arrange documents by dragging them. When arranging documents, there are a few rules | 
to remember: | 

e Place MacPaint, PICT, Glue and Overview documents in the background row. 

¢ To make a document appear in front of another document, place it beneath that document. 

Background Row: 

2 eo 
Foreground Rows: 

WY 
GR: = 
Tee 

Sound, transitions and timers can actually be included in either row, but are typically as 
shown. 

VideoWorks documents can be in either row. You generally put movies in the background row 
and annotation and clip animation in the foreground row. If you wish, you can keep adding more 
annotation, clip animation and VideoWorks documents at the bottom of any column. If you were 
to keep adding these, you would eventually reach a limit. The technical limit is: You are allowed 

- up to 24 channels in any one column. (Channels are described next.) Notice this maximum is not 
limited by the number of documents used. Typically, you would reach this maximum only if you 
were including a movie that uses lots of channels. If you go beyond 24 channels, you just won't 
see the extra channels. 
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Re-Arranging Documents — It's easy to re-arrange documents. 

- To relocate a single document, simply drag it to a new location (note that the window will 
automatically scroll when you reach the edge). 

¢ To move a group or column of documents, select them (as described below), then drag the 
selected group to a new location. 

¢ To Cut and Paste or Copy and Paste the documents, select them (as described below), then 
choose the commands from the Edit menu. (You can even Cut and Paste to the Scrapbook.) 
You can Paste in between columns of documents by clicking on the gray line between them. 

The following table describes how to select documents in the Overview window. 

To select: Do this: 

A single document Click on it. 

A group of documents Click on the first document, then Shift-click on the 
last one. All documents in between the two are selected. 

—or— 

Draw a selection rectangle around the entire group, 
as you would in the Finder. You do this by starting with 
the pointer above and to the left of the first document, 
dragging the pointer diagonally across the documents, then 
releasing the mouse button. 

A column of documents Command-click on any document in a column selects 
| the entire column. 

VideoWorks Annotation, Clip Animation and Movies — All three of these categories 
are just different kinds of VideoWorks documents. (They all use the same VIDEOWORKS II icon.) 

e VideoWorks annotation is very much like a MacPaint slide — one frame, with no animation, 
usually just text and arrows. It overlays in front of a slide (or movie). 

¢ Clip Animation is an animation extra, that is, a small movie with only one animated 
character or object, such as a person doing back flips, a coin flipping, or a logo flashing. It is 
used in front of a slide like clip art. 

¢ A movie usually is a full-screen animation, complete with its own background. 

Any kind of VideoWorks document can be in any row, and all three are created in VideoWorks in 
the same way. 
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@ 

Typical arrangements of documents within a column — The following diagram shows 
typical arrangements of slide shows. The simplest shown is a slide with annotation in front of it. 
The most sophisticated is a slide with two clip animations, an annotation and sound (perhaps 
music). Of course, the arrangements are limited only by your imagination. 

: Slide = ae 
Slide _ Slide (PICT) wa| clide 

(MJ 

HEH Annotation 
Clip 4 Clip =H Clip 
Animation = Animation Animation 

Clip 
Animation 

| 

Annotation 

Sound 

Typical ways to arrange columns of documents. 

Using Timers 
Movies have a duration of their own — slides do not (MacPaint, PICT, and Glue documents). You 
use Timers to set the duration of slides unaccompanied by movies. 

When you drag a Timer into the Overview work area and type the time, it appears below the 
Timer. It also appears above each slide that follows (until the next Timer), indicating its duration. 
If you want to set a different length for another set of slides, you can add a second Timer. 

The initial default for movies is for them to run their full length, regardless of the timer setting. 
However, with Get Info, there is an option to make the length of movies also set by the timer (by 
repeating the movie or cutting it short). "M" (Movie) means this column is determined by the 
movie (unaffected by the Timer). If every movie in a column is using the timer, the M will 
disappear, to be replaced by the number specified by the Timer. See the section on using Get Info 
below. 

Projection ! ba Sees Ie - 0,16 

The numbers above the documents indicate the duration in seconds each slide is shown. 
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Using Transitions 
A transition determines how one picture changes to the next. There are four basic categories: 

Wipes, pushes, reveals and dissolves. : 

¢ Wipe — A line wipes across the screen which unveils the second picture as it covers the first 

picture. Neither picture moves (as in a Push or Reveal). There are many kinds of wipes: to 

the left, to the right, up, down, vertical in to center, vertical out from center, horizontal in to 

center, horizontal out from center, square in to center and square out from center. 

¢ Push -— Both pictures move together — the first picture pushes the second picture off the 

screen. 

¢ Reveal — The first picture moves away to reveal the second picture behind it. A reveal can © 

start at any edge or corner, outward from the center, or inward from the four corners into the 

center. | 

¢ Dissolve — The first picture dissolves, gradually exposing the second picture. The dissolve 

can be pixel-by-pixel or by small or large boxes. ith 

When you drag a Transition icon into the Overview area between the two documents you want to 

affect, a dialog box appears, with the transition choices. You can change the Transition, Chunk 

Size and Delay: 3 

e Transition — Click in the box for the transition you want. 

¢ Delay — (in 60ths of a second) The amount of time between each incremental wipe, push, 

reveal or dissolve (chunk). | 

© Chunk size — (1 to 512, in pixels) The distance between each incremental wipe, push, 

reveal or dissolve. The chunk size is also good for controlling the speed of the transition — 

the smaller the chunk size, the slower the transition. Can be set to larger than 512 ona larger 

screen. 

When you click OK, the Transition icon appears in the Overview area. The numbers below the 

transition indicate the delay and chunk size. 

Note: If you put a Transition below a slide, it will work the same it is 

placed immediately to the left of that slide. 

<=) C) reveal north 

(a © reveal northeast 

Ea © reveal east 
Cea C reveal southeast 
fal CC) reveal south 
ga] © reveal southwest 
421 C reveal west 

ZZ) © reveal northwest 
s’4 ©) dissolve 

@® boxy dissolve 

h 

Delay: /60ths of a second 

Chunk size: Be |) push up 

How To Animate: Working with Overview 113 



Overview 

Get Info on a Transition — To identify a transition, click on it, then select Get Info from 
the Edit menu. 

Changing a Transition — To change a Transition, use Get Info as described above. Change 
the setting then click OK. 7 2 

Shortcut: Double-click on the Transition. The Get Info box appears. 

The push-right, wipe-up, reveal-southeast and the dissolve transitions. The numbers 
below the icons indicate the Delay and Chunk Size for that transition . 

Using Sounds 
You can add any sound that is available in the Sound menu. To change a sound, select the sound 
icon you want to change by clicking on it, then choose a new sound from the Sound menu. 

Remember that VideoWorks documents can have sounds also. In a given column, only one of the 
icons can control the sound. Generally, the topmost icon in the column that has sound will be the 
one that controls the sound. You can turn off the sound for a specific VideoWorks document by 
using Get Info (see below). 

Also remember that you must have "Sound Is On" selected in the Control menu to hear sounds, 
and that you can control the volume from the Control Panel desk accessory. 

Using Glue Documents 
Glue is an application for the Macintosh that gives you one simple, easy method for transferring 
text and graphics into VideoWorks. You can import images from applications like Excel, 
MacProject, Microsoft Chart, PageMaker or ReadySetGo. The image can be as large as a full 
printed page. 

You must have Glue in order to save the original image from one of these applications to disk 
(this is done via the Print command). Once saved as a Glue document, what was originally text 
and graphics on a page, or numbers in a spreadsheet, is now a single image. You can use this as 
part of your slide show. 

In this manual, what we refer to as "Glue Documents" are termed "ImageSaved Files" by 
Solutions, Inc. Glue is produced by Solutions, Inc., P.O. Box 989, Montpelier, Vermont, 05602. 

114 How To Animate: Working with Overview 

OU 

iT 1 

SF eG LOG GEE COW GO 
~ 



Overview 

Using Clip Animation 
Clip animations are the equivalent of "clip art" for your animated slide show — they are short, 

succinct animated graphics (movies) that you can easily combine into your own presentation. A 

clip animation can be as simple as a moving arrow, a spinning coin. It can be an animated 

industry symbol, a flashing company logo, a sparkling marketing message or a secretary typing at 

a desk. 

A clip animation is really just a short VideoWorks movie, usually with only one animated 

character or object. You normally place a clip animation in front of a slide. 

Note: When you place more than one clip animation in a column, the lower one 

in the column will be in the foreground. Any documents above it in the column 

will appear behind it on the Stage. 

You can set many characteristics of a Clip Animation by using its Get Info window (see "How to 

Get Info on a VideoWorks Document" which follows). 7 

How to Annotate a Slide 

If you have placed a slide in the Overview work area, you can add arrows, labels, and even clip 

animation with a VideoWorks overlay as follows. . 

Start in Overview with any slides in the work area as you want them. Then: 

1. Drag the VideoWorks document icon from the top row into the working area just below the 

slide you want to annotate. | 7 

The same dialog box appears that was described in the previous procedure "How to Add 

Documents to Overview." : 

2. Click New. 

This launches VideoWorks and opens a new VideoWorks document (you should answer "Yes" 

to the "Save Changes?" dialog). 

Now you're in VideoWorks, with the slide appearing as a background. You can use any of the 

tools available to annotate your slide. The quickest way to add text is with the Text Box tool at 

the right end of the Cast (the |A} tool). Click on it, and your cursor will change shape. Drag a 

rectangle on the Stage where you want your text to go. After you type the text, click on the Stage 

outside the text (to de-select it), and you will notice the box becomes transparent. You can move 

the text box by clicking on it (to select it) and dragging it by its edges, or re-sizing it with the 

handle at the lower right. 

When you are done annotating your slide, Save this VideoWorks document you just created and 

Quit VideoWorks — you will return to Overview returns, just as you left it. The document you 

just created appears in the Overview work area. If you want to edit the document you just created 

some more, see the section which follows on "How to Launch Applications from Overview." 

There are many other tools and techniques you can use within VideoWorks to annotate your slide. 

You can easily add lines, boxes and circles using the QuickDraw shapes. Or you can open the 

Paint window to create some artwork. One of the most powerful techniques available is to use a 

Film Loop to Real-Time Record some animation exactly where you want it. You might make a 

VideoWorks document that consisted only of special sounds for a particular slide. You can also 

open an existing VideoWorks document, modify it, and Save As to make your own special 

version of it. See the VideoWorks section of "How To Animate" for more details. 
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Positioning a MacPaint, PICT, or Glue Document 
When you want to adjust the position of a MacPaint, PICT or Glue document on the screen, 
simply select the icon and choose Get Info from the Edit menu (a shortcut is to double-click on 
that icon). The Overview window will disappear, and you will see a dialog box like this one: 

Get Info 

info about: Sales Pitch 2 

Drag the image on the Stage 

_ using the mouse. 

Sick tett(-15 | up[-i5 | 

You can move this dialog to any part of the screen (by dragging its title bar) so that you can see 
behind it. When you move the mouse pointer onto the Stage, the pointer changes to a hand. You 
can then drag the image to a new position on the Stage with the hand. 

If you click on the word "Info About” you can see the full path name of the document ee is, the 
list of folders it is in). 

Using Get Info on a VideoWorks Document 
Get Info on a VideoWorks document lets you adjust the timing and positioning of the VideoWorks 
document. Select the VideoWorks document, and choose Get Info from the Edit menu (shortcut: 
double-click on the icon). The Overview window will disappear, and you will see a dialog box 
like this one. You should move the dialog box to be able to see the animation behind it. 

When you change an option, you will see its effect on the Stage. For example, after you change 
the number of times a movie repeats, the movie will start playing (and will repeat for the number 
of times you set it for). Note that you can click OK before the animation has finished. 

Get Info 

Info about: Arrow From SE | 

Timing: @ Use movie's normal length 
© Use current timer length 

Repeat movie: times 

Start after: ree. seconds 

Position: (©) Use movie's start location 

@) Set start location with mouse 

Horiz: Vertical: 2 
[_] Before movie starts, first image appears 

><] After movie ends, last image remains 2 
><] Play movie's sounds _ 
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The Get Info options are as follows: 

Timing Options: 

e Use movie's normal length 

e Use current timer length 

These allow you the option of letting the movie run its normal length or making its 
length be set by the timer (by repeating the movie or cutting it short). This will not 
change the tempo of the movie, only the length of time it is shown. 

¢ Repeat movie: ____ times 

This allows you to set the number of times a movie will repeat. 

- Start after: —s-_- seconds 

This allows you to start the movie a certain number of seconds after the background slide 
first appears. Note that you can use decimal seconds (like 1.5). If you want the first 
image of the slide to appear before the movie starts, click on the check box that sets that 

option. 

Positioning Options: 

« Use movie's starting location 

e Set starting location 

This option allows you to change where animation appears on the Stage. To do so, 

move the mouse pointer out over the Stage, it will turn into a cross cursor. This means 

that you can set the starting location of the movie by clicking anywhere in the Stage 

window. When you click in the Stage window, the animation starts happening (note that 

if you have a delay set, there will be a delay before the animation starts), but starting 

from the point where you clicked. 

When the animation has finished, you will see a pair of gray lines on the Stage. These 

indicate the starting location point that you just set. You can use these lines to exactly 

position the animation. For example, if you have an arrow and it overshot its goal by 

one inch, click an inch away from where the gray lines intersect. 

If you want to go back to using the starting location associated with the original movie, 

click on that option. | 

Note that you can set the starting location numerically as well. This is useful for exact 

positioning. 

Other Options: 

¢ Before movie starts, first image appears 

- This is only meaningful if you have a delay on the start of the movie (see the option 

above). 

¢ After movie ends, last image remains 

The default is for this check box to be checked. If you want the last image of the movie 

to disappear when the movie ends (leaving whatever slide is in the background) the turn 

off this option. 

e Play movie's sounds 

The default is for this check box to be checked. If you have a movie with sound, but you 

want some other sounds to play for that column, you can turn off this option. (Another 

way to do this is to rearrange the order of the slides in the column, see the section on 

Using Sounds above). | 

If you click on the word "Info About" you can see the full "path name" of the document (the list of 

folders it is in). - 
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Printing in Overview 3 
In Overview, the Print command lets you print slides or the Overview window (shown below). 
With the Layout Options, you can print full-size, 50% and 25%. At full size, one slide is printed 
per page. The smaller are particularly nice if you want to storyboard your animation. You can 
also include the date, filename, frame number, and your own footer in the printout. 

When you choose Print from the File menu, the following dialog box appears: 

Overview Print Options 

@ Slides 

@ All slides 

© Selected slides 

C€ Overview window 

: OK | [Layout Options] | Cancel | 

All slides — Prints all slides in the current Overview presentation. If movies are present, it 
prints the first frame of each movie. Technically, any artwork that appears on the Stage at the 
start of each column is printed, including any annotation, clip art or clip animation. 

Selected slides — Prints a subset of All slides by printing only those slides that are selected in 
the Overview window. To select a series of slides, click on the first one, then Shift-click on the 

last one in the series — all slides in between the two are included. 

Overview window — Prints the arrangement of icons that appears in the Overview window, to 
record how you arranged your presentation. 

OK — Accepts the choice you made. After you click OK, the standard Macintosh print dialog box 
appears, giving you the choice of number of copies and range of pages (From... To...). Here, the 
page number refers to the order sheets of paper that come from the printer (and is unrelated to frame 
number). Thus, page 5 would be the fifth sheet of paper. 

Save as File — Saves the requested pages to disk as a file in MacPaint or PICT format for later 
editing. If you want to create a storyboard with annotation next to the slides, you could easy edit 
these files and drop in the text. 

Layout Options — Opens the Layout Options dialog box described next. 

Cancel — Closes the dialog box without printing. 

Timer __— Slide Movie Transition Movie 
& 

Background Background 

pa bh NS NS f 

| Sh) — hi) —[ole - 20000000006 2 

Welcome Backdrop Dy; 1 6 Scenery Closing 

4 4 

6 6 
The Sale FollowUp 

Printing a Slide Printing an Overview window 

| 
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Overview 

Layout Options 

When you select Layout Options in the Print dialog box, the Layout Options dialog box appears. 

Select the options you want. When you choose Print Page Footer, type in the text that you want 

to appear at the bottom of each page. Below are examples of different layouts: 

Thu, Jun 18, 1987 <ccrceecees forest eerste Header 

Page Options 

Print Page Header (filename & date) 

C] Print Page Footer: 

\videoWorks 11 

Frame Printing Options 

CJ Print frame around border 

ee ee a a | ee ee, ee See Border 

C] Registration marks (with full sized image) 

Include frame number 

Scale 
@ Full size © 50% size €) 25% size 

fo Pesce 

Layout Options Dialog Box Registration 
Frame number marks 

Footer Sent Goan 

Full-size 

The City June 18, 1987 The City June 18, 1987 

Frame 1 Frame 2 Frame 3 

Frame 4 Frame 5 Frame 6 

Frame 2 

Frame 10 Frame 11 Frame 12 

Scenes from “The City” Frame 3 Scenes trom "The City" 

50% with single column format : 25% 
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How to Launch Applications from Overview 
The Launch Editor command in Overview provides a way to get directly from Overview into 
another application, such as VideoWorks, MacPaint or MacDraw. This is a shortcut for 
having to quit VideoWorks and open the application from the Finder. 

For example, if you have a MacPaint document you want to modify, just select it and choose 
Launch Editor from the File menu. MacPaint is launched, and that document opens. When 
you Save and Quit, you are returned to Overview, exactly as you left it (except the MacPaint 
document is now updated). 

Note: Of course, you must have the application that you want to 
launch (MacPaint, MacDraw, etc.) available on a drive in your 

system. 

Here is the detailed procedure for launching an application from Overview: 

1. At the Overview window, select the document you want to launch: 

lf you_ select: This application will be launched: 

VideoWorks document VideoWorks 
MacPaint document MacPaint (or choice in Preferences) 
PICT document MacDraw (or choice in Preferences) 
Glue document Glue Viewer 
Overview document Overview 

2. Choose Launch Editor from the File menu. 

Overview is suspended, the application is launched, and the document you selected opens 
up. At this point you can modify your document. When done, you can return to 
Overview to continue where you left off. 

3. To return to Overview, Save the document and Quit the application. For example, if 
you were in MacPaint, you would choose Save and then Quit. (If you were in 
VideoWorks, you can choose either Quit, or choose To Overview.) 

é —— 

Launching a New VideoWorks Document — You can launch a new VideoWorks 
document from Overview, as described earlier in "How to Annotate a Slide." There is no 
direct way to launch a new MacPaint or MacDraw document. However, you can launch an 
existing one to get into the application quickly. 

Launching an Overview Document - Notice you can launch an Overview document 
from Overview (in fact, you can do this five levels deep). To return to the Overview you were 
working on, select "Return To Overview" from the file menu. 

Launching Applications Other Than MacPaint and MacDraw - If you want to use 

other programs that edit these documents, choose Preferences from the Control menu. You 

can then enter the "creator type" of the application. Here are the creator types for some 

common programs: , : 
Application Creator Type 

CricketDraw CRDW 
FullPaint | PANT 
GraphicWorks MMCB 
MacPaint MPNT 
MacDraft MACD 
MacDraw MDRW 
SuperPaint SPNT 
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Overview 

To determine creator type for programs not listed above, use a utility program like FEdit or 

ResEdit. For example, in ResEdit the creator type is listed in the "Get Info" window you can get 

after clicking on the applications name. i 

Moving Between Overview and VideoWorks 

Normally, when creating an Overview presentation, you stay in Overview and launch into 

VideoWorks whenever you need to (using the Launch Editor command). If your work is strictly 

within VideoWorks and has nothing to do with Overview, it would be smarter just to close 

Overview and go into VideoWorks (using the To VideoWorks command). 7 

Thus, these two commands serve different purposes: SS 

¢ Launch Editor — Leaves the Overview document open, with the current slide visible as the 

background. When you quit VideoWorks, you return to Overview just as you left it. 

¢ To VideoWorks — If you choose To VideoWorks, the Overview document closes, then 

VideoWorks opens. When you go back to Overview, a new blank Overview document is 

displayed. 3 

These two methods are illustrated below. When you start in Overview and use Launch Editor to 

enter VideoWorks, Overview is suspended — it is shown shaded below in the diagram. When you 

Quit VideoWorks, it is re-activated. 

When you start in Overview and use To VideoWorks to enter VideoWorks, Overview is closed. If 

you were to Quit VideoWorks, you would be sent to the Finder. 

To summarize: 

Use: For: . 

Launch VideoWorks When you are in Overview and want to edit a VideoWorks document 

To VideoWorks If you want to start working on a VideoWorks document not associated 

with any Overview document (opening the VideoWorks document has 
the same effect). 3 

r 
To VideoWorks 

ee eeeseecoveesecccocensenesoeecevccccccnssneceseusnaenanscssossussnsnes 

Launch Editor | 

Rerurn Io Pueryip is 

obeeeveceeeseesenseecusvecsecsescascucscesasneceonseneneenasueenersseny 

To VideoWorks (left) closes the Overview document and runs VideoWorks as a stand-alone 

application. Launch Editor (right) runs VideoWorks, and leaves the Overview document open in 

the background. 
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Limits on the Number of Clip Animations ° 
You can have no more than 16 clip animations in a single column of icons. But there is another 

limitation that you can run into with only 3 or 4 clip animations: 

The concept of Animation Channels comes from the Score in the VideoWorks side of 

VIDEOWORKS II. Generally you won't need to think about this when using Overview, but you 

should know about it because it limits the number of clip animations you can have in the same 

column. | 7 : 

You need a separate animation channel for each separate piece of artwork appearing on the Stage. 

You can have a maximum of 24 separate pieces of artwork on the Stage at the same time (you can 

have up to 512 pieces of artwork in a VideoWorks document) 

Suppose you have three clip animations A, B, and C and they use the following numbers of 

channels: 
VideoWorks A 3 channels 

VideoWorks B 1 channel 

VideoWorks C 20 channels 

You could play all three of these documents at the same time, because they need a total of 24 

channels. However, you could not add in a fourth VideoWorks document, because all 24 channels 

are in use. If you did add another VideoWorks document, it would simply not appear. 

Typically, a simple clip animation uses only 1 channel. More complex clip animations may use 

as many as 4 or 8 channels. Therefore you can generally combine 3 or 4 clip animations on the 

same slide without ever running out of animation channels. 

You can run into this problem if you add clip animation to an existing VideoWorks movie which 

itself uses most of the 24 channels. Most VideoWorks movies use between 5 and 15 animation 

channels. 

_ If you want to find out how many animation channels a particular VideoWorks movie or clip 

animation is using, you can open the movie and look at the Channel Indicator in the Panel. See 

the VideoWorks Reference section for more details. 

Overview Hints 
When you are ready to give your presentation, you can select Stage from the Window menu and 

use the mouse like a slide projector remote control (actually lift it off the table) to step from slide 

to slide. | 

Sometimes you may want a slide to appear motionless while you talk about it to your audience, 

and then to emphasize your point you want a dramatic animation to appear over that slide. You 

can do this in Overview as follows: 

¢ Have your background slide in two successive columns of icons. 

¢ The first column would have no clip animation, and second column would have clip 

animation. 

Then you can step to the first column, and talk for as long as you like. When you are ready, just 

click the mouse and watch fireworks happen. 
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For certain animations, you will want the first frame of the clip animation to appear during that 
first motionless slide, but still have the animation occur —_ you press the mouse button. To do 

- this: 

e Make a duplicate of the column of icons (use the option key to ; duplicate the icons) 

¢ Use Get Info to set the clip animation in the first column to a very large delay (like 99 
seconds), and to appear before the movie starts. 

e The second column should be the same as the first, but will have no delay. 

Then you can step to the first column, and talk for up to 99 seconds. When you are ready, just 
click the mouse and the animation begins. Try this technique on the last column in "Tutorial #3 — 
More Bamboo Industries". The last column is the one with the Easel clip animation over a 

MacDraw document. 
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VideoWorks 

VideoWorks 
The Animation Side of VIDEOWORKS II 

Stage 

« File Edit Control Sound Window Text Draw Ink 

aii? 
MME sc} 1] 
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The previous section covered Overview, the first step 
in the process of animating with VIDEOW ORKS II 
This part describes VideoWorks, which is steps 2 
through 13 in the process. 
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2. Creating Artwork 

This section describes how to create artwork in the Paint window, which you can then use in your 
animations. You can also draw simple shapes directly on the Stage with the QuickDraw shapes, 
which are described later in "Adding QuickDraw Shapes”. 

You also have the option of creating artwork in another program and importing it into 
VideoWorks via Art Grabber+, the Clipboard or the Scrapbook (see "Importing Art"). You can 
import digitized artwork, scanned artwork, clip art or clip animation. 

The Paint window and the Cast are intimately related. Every easel in the Paint window is a 
-castmember. When you modify artwork on an easel, the castmember in the Cast changes. 

Using the Paint Window 

The Paint window is the main place you create artwork in VideoWorks. The Paint window is a 
paint program very much like MacPaint. The drawing tools are in a row along the top of the 
Paint window. These are used to generate artwork. The editing tools are along the left edge and 
are used to modify artwork. For further description of the Paint window, refer to the Reference 

section later in this manual. 

You can draw freehand with the Pencil, Paintbrush or Airbrush. You can draw rectangles, ovals, 
straight lines, and fill patterns. Once you have draw something, you can flip it vertically, flop it 
horizontally, invert the black and white, rotate it, slant it, distort it, or change its perspective. 

Other tools allow you to get a new easel, change the patterns and inks, type text and change the 
Paintbrush size, and go into Fatbits. 

Paint - Bank Al 

The Paint Window 
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How to Create Artwork in the Paint Window 

To create artwork in the Paint window: 

L. 

2, 

- Open the Paint window. 

Click on New Easel (Gl The castmember number for that artwork (such as Al 1) appears at 

the top of the easel. 

Pull the easel open by dragging its handle down and to the right 

Select a drawing tool and draw vith it — pick any tool along the top | row: the Paintbrush, | 

Pencil, Airbrush, Line, Rectangle, Circle, or Paint Bucket. You can also select the text tool 

and type in text. 

¢ Fora Line, select a line thickness from the Draw menu. 

¢ For the Paintbrush, Rectangle or Circle, select a pattern and line shiekness from the Draw 

menu. 

¢ For another Paintbrush shape, double-click on the Paintbrush and select a shape from the 

Paintbrush palette. 

e Fill in patterns with the Paint Bucket. 

¢ Cut, copy and paste artwork using the Lasso or Selection Box. 

¢ Use Slant, Rotate, Perspective or Distort to modify artwork. 

¢ Using inks to modify how patterns paint over existing art. 

¢ Use Fatbits to enlarge a painting to work on individual pixels 

A miniature e replica of the artwork you produced appears in the first empty position in the Cast as 

you draw it. Note that each Paint easel corresponds to a different Cast position. 

Some general rules apply: 

You can select an easel to work on by clicking on it (or finding and clicking on it in the Cast, 

which also brings it to the top). 

You can drag an easel to another location in the Paint window by moving the tip of the 

pointer to the top edge of the black easel and draggin g the easel. 

You can create a background much larger than the Macintosh screen — it can be 5 feet wide and 

2 feet tall, if you want. This is useful for making a background that you can scroll during the 

animation, to show motion. You do this by pulling an easel open as far as it will go, sliding 

the easel to the left, pulling it open some more, sliding it to the left, and so on. 

You can Cut and Paste between Paint easels by selecting the artwork with the Selection Box 

or Lasso, choosing Copy Graphic or Cut Graphic from the Edit menu, clicking where 

you want it to go, and choosing Paste Graphic. 

You can create up to 512 pieces of art in one VideoWorks document (see the Cast, below). 

To modify existing artwork, simply open up the Paint window, locate the art, and use the Paint 

tools to modify it. 
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Shortcut: To open the Paint window quickly from the Stage, double- = 
click on a piece of Paint artwork on the Stage. The Paint window opens i 
immediately, with the piece of artwork on top. (However, that piece of — 
artwork may not be visible — you may have to scroll the Paint window 
to see it.) ee 

When searching for artwork in the Paint window, be aware that the Paint window does not ae 
necessarily display all of the castmembers in the Cast at the same time. It displays only those = 
currently of interest: | on 

¢ The castmember that is currently selected in the Cast, and ale 

¢ The current bank of castmembers (A through H). The current bank is displayed in the title = Zo 
at the top of the Paint window. (Banks are described next under "Using the Cast"). i 

Thus, if you cannot find a piece of art, the easiest way to locate it in Paint is to use the shortcut ae 
described above — find it in the movie, then double-click on it on the Stage. = 

All artwork on the Stage has implicit registration. If you want to accentuate a motion or re-locate 
artwork slightly on the Stage, you can do so by altering the registration of that artwork with the — 
Registration Point tool in the Paint window. (See Advanced Editing.) | a 

Changing the Ink for Painting — 
Inks modify the way the patterns in the Draw menu paint over existing artwork. / 

Note: Inks are also used in a completely different context — on the = 

Stage. For more details, see "Using Inks" later in "How to Animate." — 

Starting with artwork already on a Paint easel: = 

1. Choose the ink you want from the Ink menu. You should see the name of the ink you = 
selected appear in at the top right corner of the Paint window. (If it does not appear, click on ee 
the easel to make sure it is active.) —_— 

2. Choose the pattern you want from the Draw menu. (This can be done before or after step 1.) i 

You can now paint with any of the paint tools: Paintbrush, Airbrush, Paint Bucket or filled —— 
shapes. | . —e 

a 

=) 

—— 

= 

— 

_—— 

— 
( | 

— 
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Using the Cast 

The Cast holds all of the artwork in VideoWorks. You can think of it as the database manager for 

artwork and text in VideoWorks. You then use the Paint window to create or modify the artwork. 

Thus, each easel in the Paint window has a corresponding position in the Cast, as indicated by the 

Cast number. For example, the first Paint easel you create is numbered A11 both in the Paint 

window and in the Cast. 

/ Cast Positions — The Cast displays eight pieces of art, or positions, at any one time. You can 

scroll through all of the castmembers with the up and down arrows at the left end of the Cast. 

When you click on a position in the Cast window to select it, the corresponding easel in the Paint 

window appears in front of all other easels. 

You can create up to 512 pieces of art in one VideoWorks document, all of which appear in the 

Cast. (512 =8 x 8x 8. Eight banks, A-H, each with eight rows, with eight positions to a row). 

Banks — At the left end of the Cast are the bank indicators, A-H. Each bank holds 64 

castmembers. You can select a bank by clicking on the bank indicator or pressing one of the 

-castmember scroll arrows. One bank is displayed at a time in the Paint window. The purpose of 

banks is to keep the number of pieces of art available to be worked on at a time to a manageable 

SIZe. | 
Scroll Arrows — The up and down arrows at the left end of the Cast allow you to scroll through 

the Cast, viewing all of the castmembers. 

At the right end of the Cast are the QuickDraw shapes and the Text Box. For more information, 

refer to "Using QuickDraw Shapes" and "Using Text" later in "How to Animate." 

nla] ee S| es OOO 

_ The Cast 
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3. Creating an Animation 

There are two different methods for creating an animation. You can use either method at any time 
— pick whichever method is appropriate at the moment: 

¢ Real-Time Recording is the process of recording the motion of an object as you 
move it around on the screen. The object cannot change shape or size as it moves. You 
create this animation all at once, in real-time, rather than frame-by-frame. The result is 
an animation that is characteristically smooth and continuous. A major benefit is that it 
is quick and easy to make a Real-Time Recording. 

¢ Frame-by-Frame Animation is the main way you interact with animations. This is 
the process of animating one frame at a time, placing and arranging artwork on the Stage, 
using In-Between, and doing precise editing. It requires more work than Real-Time 
Recording, but the benefits are greater precision, control and variety. 

In both cases, the recording goes into a window we call the Score. The following diagram 
graphically illustrates the differences between these types of recordings. This is an abstract 
representation of the Score — when you look in the Score you can't actually tell which sequence 
have been recorded in real-time or frame-by-frame. : 

Remember that you can switch techniques at any time in a single animation, using each technique 
whenever appropriate. ——— 

REAL-TIME RECORDING 

FRAME-BY-FRAME ANIMATION [IIIT 

An animation can combine Real-Time and Frame-by-Frame techniques. Real-Time 
Recording is continuous recording, while Frame-by-Frame Animation is discrete . 

Use Real-Time Recording if you want to record a piece of art moving around on the Stage. Use 
Frame-by-Frame Animation in all other cases — that is: 

¢ To create a sequence composed of different pieces of art. 

¢ To create artwork or text that moves smoothly in a straight line on the Stage (In-Between). 

¢ To precisely edit the animation: Stretching, switching, copying or moving artwork. 
Inserting or deleting frames or channels. 

¢ To add ink, sounds, Macintalk speech, transitions or tempo changes. 

One advantage of Real-Time Recording is that you can add Film Loops. (We'll describe this in a 
later section.) 7 : ; 
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Real-Time Recording REAL-TIME RECORDING 

FRAME-BY-FRAME ANIMATION PEELE 

What do we mean by Real-Time Recording? As we mentioned before, Real-Time Recording 

is the process of recording the motion of artwork as you move it around on the screen. It is quick 

and easy — basically, you just select a channel, select the artwork in the Cast, hold down the 

Option and Command keys, and press the mouse button to drag the artwork around the Stage. All 

of your movements will be recorded until you release the mouse button. If you're not satisfied 

with the animation you created, Undo and try again. 

Real-Time Recording is restricted to one piece of artwork — that is, the artwork cannot change 

shape or size as it moves (unless you use Film Loops). You create this animation all at once, in 

real-time, rather than frame-by-frame. The result is an animation that is smooth and continuous. 

A Film Loop is a sequence of art saved to one position in the Cast. It could be a bird flapping 

its wings or the earth spinning. It can have a dramatic effect on the impact of your animation. 

(For more information, Film Loops are described later.) 

Examples of Real-Time Recording are given in Tutorial #4 - Bouncing Face, and Tutorial #5 - The 

City. An example of using a Film Loop is given in Tutorial #6 - The Frogs. 
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How to Animate Using Real-Time HeCaranig 
(Option-¢8 Key Combination) 

This procedure assumes your VideoWorks document already has artwork that you want to animate 
in the Cast. It works whether your animation is stopped or is playing. 

\ 

If you want to start at a particular spot in an existing movie, move to the frame where you want to 
begin the Real-Time Recording. Use Step and Back Step to move to the exact frame. 

1. In the Cast window, select the castmember you want to animate by clicking on it. (The 
castmember becomes highlighted by a dark outline around its border.) Do not drag the 
castmember out onto the Stage. Close the Cast window if it will be in the way of the 
animation. 

Note: In the next step, the recording will begin as soon as you click 
the mouse, so be prepared to begin moving the mouse as soon as you 
press the mouse button. 

2. Hold the Option and Command keys down. Press and hold down the mouse button, and 
begin moving the artwork around — all your actions are being recorded. When you are done 
animating, release the mouse button to stop recording. 

Note: Once you begin animating, you can release the Option and 
Command keys and continue recording. 

if you don't like the animation, you can Undo it and try again. You can keep adding animations 
using this procedure until all 24 channels are filled. 

Note: A way to get more control is to turn down the speed and record 
the animation in slow motion. For playback, turn the movie back up to 
normal speed. 

Since the animation starts recording the moment you press the 
mouse button down, for some animations it may work best to get 
a running start by moving the mouse just before you press the 
mouse button. 

SELECT A 
CASTMEMBER 

HOLD OPTION - 96 Channel Selection in Real-Time Recording 
When you hold down the Option and Command keys, VideoWorks 
automatically finds an unused channel for you to record into. You 
can see this by just holding down the Option and Command keys — 
the channel that VideoWorks chooses starts flashing in the Panel's 
Channel Indicator. To choose another channel, keep holding down 
the Option and Command keys and just click on the one you want 
in the Channel Indicator — it will start flashing. Then begin Real- 
Time Recording. 

AND ANIMATE THE 
ARTWORK 

The Process of 

_ Real-Time Animation 

Most of the time, letting VideoWorks choose the next channel is exactly what you want. 
However, there are cases when you want to override that choice, as we just described. For 
example, since channel assignment determines what is in the foreground or background, you might 
want to assign the next piece of art to a lower channel number so that it moves behind another 
image. Or, you might want to record over a channel that has already been used for animation. 
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Frame-by-Frame Animation | AEAL-TIME RECORDING 
FRAME-BY-FRAME ANIMATION 

Frame-by-Frame Animation is the main way you interact with animations. This is the process of 
animating one frame at a time, placing and arranging artwork on the Stage, using In-Between, and 
doing precise editing. It requires more work than Real-Time Recording, but the benefits are much 
greater precision, control and variety. 

Note: Refer to the next section "Controlling an Animation" if you 
need to become familiar with the Panel controls and Channel Indicator. 

alll 

| 

How to Animate a Sequence Frame-by-Frame 
This procedure describes how to create a sequence Frame-by-Frame. You can use this procedure 
either to create a new sequence or to add to an existing one. Refer to the flowchart on the next 
page for a quick view of this procedure. 

First get the individual pieces of artwork for the sequence into the Cast pts by drawing them in 
Paint or grabbing them with Art Grabber+. Then: 

1. If you are adding to an existing animation, move to the frame where you want to start the new 
sequence. 

You can either use the controls on the Panel, ee the Frame Counter number, or drag the 
Playback Head in the Score. ki ikki ik 

2. (Optional) If you want to specify a channel to record in, select that channel number at the 
Channel Indicator in the Panel (or select it in the Score). 

If you do not specify a channel, the next available empty channel is automatically selected for 
you in the next step. | 

Note: When selecting a channel, use channel 1 for background art and 
larger channel numbers for foreground art. See "Foreground Priority" 
which follows. 

3. Drag the first castmember onto the Stage. 

Notice the Channel Indicator for this channel now looks like a bullseye (a circle). This is the 
record light, indicating the channel is "ready to record." 

4. Click on the Step button. This copies the art to the next frame. 

5. If you want a new piece of art for the second frame, click on the second piece of art in the Cast 
and choose Switch Castmember from the Edit menu. 

Shortcut: In place of step 5, double-click on the second piece of art in 
the Cast. 

6. Re-position the new piece of art on the Stage so that it is positioned correctly in the sequence 
(or skip this step if you want it to remain stationary). 

7. Repeat steps 4 through 6 for the remaining artwork. 

You can now play this sequence. This procedure can be used for walking, jumping, galloping, 
flying — any kind of sequenced animation. This procedure is also used in Tutorial #6 - The Frogs. 
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Animating art that is already on Stage. As a variation DRAW OR GRAB 
of the previous procedure, you can create a sequence starting THE ART 
with artwork that is already on Stage (rather than dragging out 
new artwork). To do this, play the movie and stop at the frame DRAG OUT THE FIRST 
that contains the artwork where you want to begin recording. 
Then: 

CLICK ON 
Hold the Option key down and click on the artwork (to STEP BUTTON 
turn on the record light). 

SELECT THE NEXT 
This makes a gray border appear around the artwork and the CASTMEMBER 
record light turn on for that channel (in the Channel Indicator). 
Now you can continue with step 4 to 6 of the above procedure. | SWITCH 

CASTMEMBER 

An equivalent way to turn on the record light is to press the 
Option key and click in the Channel Indicator at the appropriate RE-POSITION 
channel. Option-click is a toggle, which means that you can cee BAT nee 
use Option-click to turn on the record light, and use Option- Lim 
click again to turn it off. Record lights are described further in | aes 
the next section "Controlling an Animation." The Process of Frame-by- ae 

Frame Animation — 
— 

Animating one piece of art frame-by-frame. If you want to record just one piece of art 7 
(either standing still or moving around on the Stage), use the previous procedure but skip step 5. — 

— 

Foreground Priority a8 
If two pieces of art cross paths on the Stage, the artwork in the higher channel will appear in front i | 
of the other artwork. Thus, artwork in channel 2 will appear in front of artwork in channel 1. 
VideoWorks uses channel numbers to indicate priority — the higher the channel number, the higher a 
the foreground priority. When performing the previous procedure, if you know beforehand that a. 
you want a piece of artwork to be in front of all other artwork, click on a higher channel number ieee 
in the channel indicator before dragging the artwork out onto the Stage. You can always change er 
this priority later — refer to the procedure "How to Change Foreground Priority" in "How to — 
Animate." 
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Registration Points Make Animation Easier 
If you think about some typical motions for a moment, you will realize that many of them have 
an "anchor point" which is not always the geometric center of the objects. For example, swinging 
your arm in acircle around your shoulder - not around its center (the elbow). Other motions have 
a fixed reference to the rest of the world - for example a frog jumping in place has a fixed shadow. 
You can often make use of these aspects of motion in VideoWorks by using Registration Points. 

Registration Points are set in the Paint window by a very simple procedure. Essentially you just. 
select the Registration Point tool and then click on the spot in the piece of art that should be the 
Registration Point. 

When you choose the Switch Castmember command, VideoWorks will do the following: 

e Determine where the registration point of the previous castmember is on the screen; and 

¢ Position the new castmember so that its Registration Point fits on top of where the previous 
Registration Point was. 

The default Registration Point Gf | you don't set it yourself) is the object's center. 

Imagine that you are animating an arm rotating around a shoulder as a sequence of 5 castmembers 
(that is the arm is at 90°, 45°, 0°, etc.): 

¢ Without using Registration Points, each time you gave the Switch Castmembers command, 
the arm would rotate about its center - the elbow. So the shoulder would not line up with 
where the shoulder was in the previous frame, and you would have to move it to line it up. 

© With Registration Points on the shoulder of each arm, the arm is perfectly aligned after each 
Switch Castmember because it lines up each succeeding arm at the shoulder. 

Note that Registration Points are useful even if the shoulder is not stationary. Suppose the 
shoulder is moving from left to right at a constant speed, with the arm rotating around it. Then 
after each Switch Castmember you can move the arm the same distance (for example, by using the 
Tweak window). 

One excellent way to set Registration Points is to use Repeat Selection (in the Control menu) to 
repeat the sequence. Then you can change the registration points in the Paint window, and 

immediately see the effect on the motion. 

For more information on Registration Points, see "Paint Window" in "VideoWorks Reference," 
"How to Set a Registration Point" in the "Advanced Animation" section, and "Using Film Loops" 

in "How to Animate." | 
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4. Controlling an Animation 

This section describes how to control a VideoWorks movie. (Controlling an Overview document 

is described earlier in "Working with Overview.") 

1 47. 
Channel Indicator 

RRL ALAR BACK | STOP PLAY |i Sele) 

MMMM STs L__1] 

iomswich | speed | Light switch Speed control 
Sound switch Frame counter 

Panel 

At the Panel you can play or stop the animation, step one frame at a time either forward or 
backward, and rewind to the beginning. You can also change the speed, turn the sound and lights 
on or off, and make the movie loop. The individual controls are described under Panel in the 

"Windows" section of the Overview Reference. All of the controls described under Panel are 
duplicated in the Control menu. : 

Numeric Keypad 
If your Macintosh has a numeric keypad, you can 
also control VideoWorks from it. 

Light and Sound Switches 
You can switch off the white background and 
make it black by clicking on the Light Switch. 
When you do this, some of the artwork may 
appear surrounded by white boxes. To remove 
these boxes, apply inks to the artwork. (See 
"Using Inks".) Click on the sound switch to 
turn the sound on or off. To adjust the volume, 
use the Control Panel desk accessory. 

Channel Indicator 
This is the 24-channel grid at the right-hand side of the Panel. It indicates which of the 24 
channels are occupied: | 

- A number means the channel is occupied | 

e A record light means the channel is occupied and ready to record frame-by-frame — 

¢ A blank square means the channel is empty 

In any of these three cases, if the cell is highlighted black, that indicates the channel is selected. 

DME ae 

All 24 channels Record light in channel 3 Channels 1 and 3 selected 
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The Channel Indicator also serves as a channel selector: Clicking on a square selects that channel. 

When you select a square with a number in it, the corresponding artwork on the Stage is selected. 

This is useful for selecting an object that is behind another one, so that you can re-position it on 

Stage. You can select more than one channel at a time by holding down the Shift key while 

clicking the squares. 

When you are Real-Time recording, the Channel Indicator for the channel you are about to record 

into flashes. You can override this choice of channel by clicking on another Channel Indicator 

while holding down the Option and Command keys (see Real-Time Recording). 

Using the Record Lights 
The previous illustration shows a record light in the Channel Indicator at channel 3. The record 

light means that channel is "ready to record." 

In the earlier procedure "How to Animate a Sequence Frame-by-Frame," the record light 

automatically turns on when the artwork is dragged out. Thereafter, each time you hit Step, the 

animation steps to the next frame and the artwork in that channel is carried along, overriding what 

may have previously been in that channel. Once you hit Play, any record lights turn off. 

Once artwork is on the Stage, to turn its record light on (or off): 

¢ Hold down the Option key and click either on artwork on the Stage or on a channel in the 

Channel Indicator : 

By using the Option-click method on artwork on the Stage, you can select as many pieces of 

artwork as you want and record them as a group. When a record light is turned on, and artwork is 

selected, it will be highlighted with a heavier border, as shown on the far right. 

Artwork not selected Artwork selected Artwork ready-to-record and selected 

Record Lights are circles that appear in the Channel Indicator to indicate you are "ready to 

record" frame-by-frame in that channel. The record light indicates that if you Step, the artwork in 

that channel will be copied to the next channel. 

Occupied, selected channel 

Occupied channel, record on 

[Record lights 

Occupied channel 

Occupied, selected channel, record on 

There are three ways to set the record light on for a specific channel. The last method also allows 

you to turn a record light off. 

-e Drag out a castmember onto the Stage 

_e Select a castmember, then choose Place On Stage from the Edit menu (or press Command-T). 

¢ Hold down Option and click on artwork on the Stage or on its channel in the Channel 

Indicator 
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5. Editing an Animation 
This section contains three parts: 

e Editing Artwork on Stage (Score Closed) | 

e Basic Editing in the Score — 

e Intermediate Editing in the Score 

The first part describes how to edit directly on the Stage, without the use of the Score at all. The 
next two parts describe editing using the Score, which allows you to edit more than one frame at a 

time. 

Editing Artwork on Stage (Score Closed) 

When editing artwork on the Stage, you are limited to working only on the currently displayed 

frame. This is useful for isolated changes in a movie. To edit entire sequences, you must work in 

the Score. | 

You can do the following on the Stage: 

Place and remove artwork 

Re-position artwork (including tweak) 

Stretch artwork = 

Switch artwork on the Stage with other artwork in the Cast 

Change the ink assigned to artwork 

Insert and delete frames 

In order to do some of these things, you must first select the artwork, so selecting artwork is also 

described here. Inserting and deleting frames is described later under Basic Editing in the Score. 

How to Place Artwork on the Stage 
The Stage is a special kind of window. Unlike the Cast, Score, Paint and Text windows, you 

cannot Cut and Paste directly on the Stage. We have the special command Place On Stage to place 

artwork and Blank From Stage to remove it. 

To place artwork on the Stage: 

1. If you are adding to an existing animation, first make sure the animation is at the frame where 

you want the artwork to appear. Use the Panel controls. 

2. Drag the castmember out from the Cast and place it on the Stage, at the position you want. 

The castmember is now added to this one frame. To place artwork in the next frame, use the 

special procedure "How to Animate a Sequence Frame-by-Frame" described earlier . 

Note: Another way to place artwork is with the Place On Stage 

command in the Edit menu. Refer to "Other Ways to Place Artwork." 

in the "Advanced Editing” section. 
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How to Remove Artwork from the ae 
(Blank From Stage Commanda) 

Use this procedure to remove one or more pieces of art tinoatly, from the Stage (that is, without 
opening the Score). 

1. Click on the artwork on the Stage. 

2. Select Blank From Stage from the Edit menu. 

Shortcut: Press the Backspace key instead of Blank From Stage. 

The selected artwork is removed, without affecting the rest of the animation. Using this procedure, 
you can step through the animation and remove the unwanted artwork one frame at a time. 

Note: To remove more than one piece of artwork at a time, Shift-click 
on each piece of artwork you want to remove, then select Blank From Stage. 

The Blank From Stage command in step 2 removes the artwork and empties the corresponding 
cell(s) in the Score. Unlike Delete Frame, the cell itself is not deleted — it appears blank in the 
Score. Like all cut and delete operations, you can recover the artwork by using Undo immediately. 

You can remove all of the artwork in a series of frames in one stroke by opening the Score, 
selecting the cells and using Blank From Stage. The procedure for this follows later under "How 
to Clear Cells from the Score." 

How to Select Artwork on the Stage 
In order to stretch, switch, tweak, remove, or change the ink of artwork on the Stage, you must 
first select that artwork. To select artwork on the Stage: 

To select: | Do this: 

One piece of artwork Click on the artwork. 

Additional pieces of artwork Shift-click on each piece of artwork. That is, press and 
hold down the Shift key and click on each piece of artwork 
to be selected. 

A dotted rectangle appears around each piece of artwork to indicate it is selected. (In the Score, 
each corresponding cell is selected black.) 

Whenever you click on the Stage, the artwork is selected only at the current frame. If you were to 
look in the Score, you would see that this selected artwork is in the same frame as the Playback 
Head. 
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How to Re-Position Artwork on the Stage 

To move artwork to a new position on the Stage: 

1. Move the pointer onto the artwork. 

2. Press and hold the mouse button down, drag the artwork to its new position, and release the 
button. 

To move more than one piece of artwork on the Stage in one movement, select each piece you 
want to re-position (with Shift-click), then drag all the artwork as a group. You can move an 
entire sequence or channel as well by first selecting those cells in the Score (described in "How to 
Re-Position a Sequence of Art" later in "How to Animate.") 

How to Constrain the Positioning of Artwork 
(Shift Key) 

Constrain means to limit the motion of artwork to either horizontal or vertical movements. When 
you are positioning an object on Stage, to constrain its motion: 

1. Press and hold the Shift key. | 7 

2. Drag the object the Stage up, down, left or right. The object will be constrained to the 
direction you begin moving it. 

(Once you begin dragging, you can release the Shift key — the motion will continue to be 
constrained as long as you hold the mouse button down.) 

Constrain works in two windows: Stage and Paint: 

e Artwork on the Stage 

e Artwork in Paint that is selected with the Selection Box 

You can use Constrain with In-Between to create scrolling text. See "How to Create Scrolling 
Text" in Advanced Animation Techniques, later. ; 

140 How To Animate: Editing an Animation 

Em ECE EV BEE BDO DO PVP Pv Py ee Ter ey Tee TT 
7 



Yk ik 

ae a ae = 

Video Works 

How to Stretch Artwork on the Stage 

You can stretch any piece of artwork directly on the Stage. Paint artwork tends to distort slightly 

as its size is changed, because their patterns change size. You can stretch any QuickDraw shape, 

but you will notice that its fill pattern doesn’t stretch along with its shape like with Paint artwork. 

To stretch artwork on the Stage: 

1. Click on the artwork. Eight handles (small black boxes) appear — as shown below. 

2. Move the pointer onto a handle and drag to make the artwork stretch or shrink. Release the 

button when the artwork is the size you want. | 

The handles are small, so you must be careful to place the tip of the pointer at the center of 

the handle. Pick a side handle to stretch the width, a top or bottom handle to stretch the 

height, and a corner handle to do both. 

Note: To re-size artwork without altering its proportions, press and 

hold the Shift key and then drag a corner handle. To return artwork to 

its original size, choose Normal Size from the Edit menu. 

You can create a sequence of artwork that stretches as it moves with the procedure "How to Make 

Artwork Stretch as it Moves" later in this section. This technique uses In-Betweening. 

Grab a handle... ...drag the rectangle larger... ..and stretch the car. 

How to Switch One Piece of Art on Stage with Another in the 
Cast 
(Switch Castmember Command) 
This procedure describes how to replace a piece of artwork on Stage with a piece of artwork in the 

Cast. 

1. Click on the artwork on Stage to select it — a box appears around it. 

2. Click on the artwork (castmember) in the Cast — a heavy border appears around it. 

3. Choose Switch Castmember from the Edit menu. 

The artwork on Stage is replaced by the artwork in the Cast. 

Shortcut: Instead of performing Steps 2 and 3, double-click on the 

castmember in the Cast. 

You can switch multiple pieces of artwork on the Stage with one piece of artwork in the Cast. : 

Using the previous procedure, in place of step 1 use Shift-click to select as many pieces of artwork 

on the Stage as you want. Then perform steps 2 and 3. 

One application of the Switch Castmember command is illustrated in Tutorial #6 - The Frogs. 
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A MINI-TUTORIAL 

The Principle of "Selecting and Choosing" 

Whenever you edit in VideoWorks, you use a basic two-step principle over and over again: 
First you tell VideoWorks what you want to work on by selecting it, then tell it what you want 
to do, by choosing a command. 

For example, to remove artwork on the Stage, you simply select that artwork by clicking on it, 
then choosing Blank From Stage from the Edit menu. Once you oer the knack of selecting and 
choosing, editing becomes more intuitive. 

In general, the two-step process is: 

1. You select something: 
Artwork (on Stage, in Paint or in the Cast) 
Text 
Cells (in the Score) 

= You choose a command: 
Tweak 
Clear 
Cut and Paste 
Copy and Paste 
Switch Castmember 
Change its ink 
Re-position it 

Example #1 
One of the simplest cases is removing several pieces of artwork from the Stage: 

1. Select as many pieces of artwork on Stage as you want: Click on the first piece and 
Shift-click on subsequent pieces. 

2. Remove the artwork from the Stage by choosing Blank From Stage from the Edit menu. 

Example #2 : 
However, the principle becomes much broader when you apply it to an entire sequence, 
frame or channel in the Score. A classic example is re-positioning an entire sequence of a 
man walking. The two steps are: 

1. Openup the Score and select the entire Walking Man sequence. This should cause 
one piece of artwork to become selected on the Stage. 

2. Re-position the selected piece of artwork on the Stage. 

Step 2 re-positions the entire sequence, because the entire sequence was selected. All 
selected artwork moves as a group. 

Notice that when you re-position one frame of the walking man, you can't actually see the 
rest of the sequence being re-positioned along with it. It is not until you play the movie that 
you can tell the rest of the sequence has indeed been re-positioned. 

Example #3. 
Tutorial #6 - The Frogs, gives an example of how you can re-position a sequence of a jumping 
frog by selecting the entire sequence and then moving any one selected frame. 
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A MINI-TUTORIAL 

The Principle of "Selecting and Choosing” 
(cont'd) : 

An Exercise — Try It For Yourself : 

Once you understand the principle of selecting then doing, your ability to edit an animation 

can improve dramatically. Here are some exercises to teach you the above principle. To perform 

these exercises, first open any movie. 

Selecting Artwork on the Stage 

1. Open the Score. | : 

2. Click on one piece of artwork on the Stage. Notice that one cell is selected black in the 

score. 

lecting More Artwork on th 

3. Press Shift and then click on other pieces of artwork on the Stage. Each piece of artwork 

(and their corresponding cells in the Score) should become selected as you Click. 

4. Drag any one of those pieces of artwork to a new position on the Stage. Notice that all 

selected artwork moves with it. 
5. Step through the movie and notice that the rest of that sequence is still at its original 

position — it was not re-positioned because it was not selected. | 

Selecting a Sequence of Artwork 

6. Select an entire channel by double-clicking on the channel number at the left edge of the 

Score. This should cause one piece of artwork to become selected on the Stage. 

7. Drag the selected piece of artwork to a new position on the Stage. 

8. Step through the movie and notice that the entire channel is re-positioned along with it. 

Once again, this is evidence of the fact that selected artwork can be operated on as a group. 

Similarly, at this point you could Tweak, Clear, Cut, Copy, Switch or change the ink of al/ 

selected artwork with a single command. 7 
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Basic Editing in the Score 

Up to this point, all editing we have described has been about editing directly on the Stage. This 
limits you to editing only one frame at a time. In this section we describe how to edit in the 
Score — this opens up the possibility of hace: entire sequences at a time. You can do the 
following in the Score: 

e Re-position entire sequences 

e Change foreground priority 

¢ Change the ink assigned to a sequence 

e Cut and Paste sequences to change their order 

e Make artwork move smoothly across the Stage (In-Between) 

Getting Around in the Score 
Before you can work in the Score, you need to know how to get around. The following is a 
description of the controls and indicators in the Score. Most of the controls allow you to view 
different information or regions in the Score. The Playback Head is different from all of the other 
controls in that it allows you to play back the animation. | 

Note: For more details about the Score, refer to the Score in the — 

Reference section. 

Scroll Bars — Let you scroll the Score. When you drag the horizontal Scroll Box, a frame 

number pops up. This number indicates the frame that will be in the center of the Score. 

Jump button — Makes the Score scroll instantly to bring the Playback Head into view. 

Option-Jump — Press the Option key and click the Jump button to make the first selected 
cell in the Score jump into view. 

Playback Head — Drag it left or right to play back the animation. 

Playback Head bar — Click in the Playback Head bar to make the Playback Head jump 

Zoom button [ 0 ]- Click it to magnify the view. This is particularly useful for reading 

the extended display, or for displaying the Score on larger Screens. 
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Using Display Buttons 
The four Display Buttons change the notation in the Score as follows: 

Click on this button: To show this notation: 

a The first button 

aS Channels 1-24 seeeeneens Change in identity and the direction of motion. 

Sound Channel.......... Tempo setting. 

i The second button 

H 
Channels 1-24........... Change in identity and the ink. 

Sound Channel.......... Transition chosen. 

The third button | 

Channels 1-24 ........... Castmember number (or QuickDraw shape). 

Sound Channel .......... The number corresponding to the sound chosen. 

ee The fourth button 

z4 E Channels 1-24 .......... Any combination of the information shown 

s and Sound Channel — with the other three buttons. 

Double-click on the ............... Ardialog box appears, allowing you to 
fourth button specify what you want displayed in each cell. 

5-Point o 

10 
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Castmember change & Castmember change & 

Direction indicator Ink indicator Castmember number Extended display 

(1st button) (2nd button) (3rd button) (4th button) 

The four display buttons 
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How to Select in the Score : 
("Select black" and "Select blinking") 

There are two different ways to make selections in the Score. One way is to drag across a range of 
cells — the cells are highlighted black. The other way it to click on a cell — a blinking cursor 
appears at the left edge of the cell.. We describe both cases here. 

a 

Selecting a Range of Cells ("Select black") 3 
Cells that are selected black can be selected for Cut, Copy, Poste. Clear or Blank From Stage. In 
all of these cases, only the selected cells are operated on. For example, when you Paste, only the 
cells that are selected black are pasted into. Cells that are not selected black will not be pasted 

over. This is in direct contrast to "select blinking." 
To extend 

To select: Do this: 3 the selection: 

Any group of cells Drag the pointer across the cells. * Shift-click on a cell. 

—or— 

Click the first cell, scroll the 

Score, then Shift-click the last cell. 

One entire channel Double-click on the channel Shift -— double-click 
number at the left end of the Score. on the channel number. 

A group of channels Double-click on the channel number — Shift -— double-click 
7 at the left end of the Score and hold on the channel number. 

the mouse button down, then drag 
down the column of channel numbers. 

One or more frames Drag across the frame numbers at the Shift-click on a frame 
top of the Score. number. 

* When you reach the right edge of the Score, the Score will auto-scroll, which allows you to 
continue selecting for as far as you want. However, using this auto-scroll technique is very 
slow if you have to drag hundreds of frames. In this case, click, scroll, then Shift-click. 

Selecting an Insertion Point ("Blinking cursor") 
Used only for Paste operations. When you Paste, the inserted cells paste over any existing cells in 
the Score. An insertion point appears as a blinking cursor in the Score at the left edge of the cells 
you have selected, indicating where the next Paste operation will insert. It is analogous to the 
insertion point in the Text window or in any word processor. 

To select To extend 
an insertion point: Do this: 7 the selection: 

At one cell: ) Click on the cell you Shift-click on another 
want to select. — cell directly above or 

below the selected cell. 

Vertically across Drag straight down across (same as above) 
several channels: the channels you want to 

select.* — 

es ae | 

Click on the first cell, and (same as above) 
Shift-click on the last cell 
directly below it. 

Vertically across 3 Click on the frame number (same as above) 
all channels: : at the top of the Score. 

146 | How To Animate: Editing an Animation AAT TTT PAP TT!” 

a 



VideoWorks 

Extending the selection (Shift key) — If you have already made a selection, you can easily 
change the range of the selection without starting over. Simply press the Shift key and click, drag 
or double-click on another cell. | 

You can continue to use Shift to extend the selection further. As long as you hold the Shift key 
down when you click, you won't lose the selection already made. 

Untitled Score 
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Selecting Cells, Frames and Channels ace: 
—. or 

ON STAGE: 

To select: _ | Do this: _— 
A single piece of artwork.................ceeeees Click on the artwork si 

A EGU OF QI WOE iovcevncgresrcnaiciic caters Shift-click on the artwork | am 

IN THE SCORE: ir | ii 

To select: Do this: 
; rt 3 

A single cell................005. ee re re Drag across that cell a 

A sequence or block of cells........ — sites Drag across that sequence or block of cells © ee 

: no 

Ag GH re ChARRS saa... Be eee Double-click on the channel number E 

A COUP Of CIANOHE <n iiiciicce keen t Double-click and hold on the first channel — 
number, then drag down across the other 
channel numbers. — 4 

One or more frames ............:::2.08 Se Drag horizontally across the frame numbers — | 
ee 

To @eiend a Sel60tion.. 2c. ei ac secs cs Starting with any selection, hold down the | 
| Shift key and click on the last cell, channel or — 

frame you want to select. a 

An insertion point for one channel............... Click on the cell ——| 

An insertion point across several.......... «+++..-Drag directly downward over the cells ee | 

channels | — 

An insertion point across a// channels...........Click on the frame number at the top of the — 
score | 
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How to Re-Position a Sequence of Art 

To move a sequence of art to a new position: 

1. 

a 

- Play the movie and stop at any frame in the sequence you want to re-position. 

Open the Score and select the sequence you want to re-position by dragging across it with the 
pointer. The artwork should now appear selected on Stage (that is, enclosed in a dotted box). 

Re-position the artwork in any of three ways. Which technique you use depends basically on 
how far you want to move the artwork: 

To move artwork: Do this: 

Any distance or direction: Move the pointer onto the artwork on the Stage. Drag 
the selected artwork to new position. When you move 
one piece of artwork the entire selected artwork moves. 

A uniform distance: Use Tweak (described next). 

Only one pixel at a time: Use the Command key shortcuts: 

ote To move left one pixel 
df = To move right one pixel 
df P To move up one pixel 
oo To move down one pixel 

Notice these keys are laid out in a logical pattern on the 
keyboard, as shown below. (These Command key 
equivalents are listed at the bottom of the Control menu.) 

How to use Tweak 
(Tweak window) 

To use Tweak: 

1. Select the artwork on Stage or the sequence in the Score that you want to move. 

2. Select Tweak from the Window menu. 

3. Click the pointer in the square on the left side of the Tweak window to set a line indicating 
the direction and distance you want the castmember to move. (See the illustration below.) 
You can also drag the line until it 1s positioned as you want. 

When you release the mouse button, two numbers are displayed to the right. The first number 
is the distance to move the artwork to the right. The second number is the distance down. 

Note: To tweak long distances, drag the line as described in step 3, but 
drag the pointer outside the Tweak window — just keep on dragging. 
The coordinates will display larger and larger values the further you go. 

4. To move the castmember, simply click the Do It button. The selected artwork moves the 
direction and distance specified. You can continue to move the artwork the same amount by 
clicking Do It again. 

_ Left Riaht 

2 
Up LP] Es 

ee 
« Tweak window | Tweak keys 

& 
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How to Change Foreground Priority 
(Cut Score and Paste Score) 

This procedure is a special case of "How to Cut and Paste Entire Channels" that follows. Let's say 
your animation has a woman walking behind a desk when you really want her to walk in front of 
the desk. | 
e First identify which channels the woman and desk are located in by clicking: Click on the 

woman on Stage and notice which channel in the channel indicator is selected black. Let's say 
this is channel 4. 

Then click on the desk on Stage and notice which channel in the Channel Indicator is selected 
black. Let's say this is channel 5. 

To make the woman appear in front of the desk, you must move the woman to a channel 
larger than 5 (or move the desk to a channel less than 4). Let's move the woman to channel 

Open the Score. Double-click on the number 4 at the left end of the Score. The entire 
channel should now be selected black. 

Choose Cut from the Edit menu. 

Double-click on the number 6 at the left end of the Score. The entire channel should be 

selected black. 

Choose Paste from the Edit menu. 

4 (OD 
oe 5 
Woman 6 

Woman 4 FRESE 
Desk 5 ee 

“ER GERREREERERRE 
The woman sits behind the desk when she is moved to channel 4. 
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VideoWorks 

How to Insert Frames in a Movie 

(Insert Frame Command) 

The Insert Frame command duplicates the frame that currently appears on the Stage. 

There are two common reasons to insert frames into a movie: 

_¢ To create a pause (to slow down the action, to synchronize to sound or to lengthen the 
movie). 

¢ To make room between two events for another action or castmember. 

This procedure works with the Score open or closed. To insert frames one at a time into a movie: 

1. Play the animation and stop at the frame where you want to add the extra frames. 

2. Choose Insert Frame at the Edit menu once for each frame you want to insert. 

Each frame is inserted at the current frame, across all 24 channels. If the movie was originally 100 
frames long and you inserted 5 frames, it would now be 105 frames. 

Note: If the Score is open, notice that the frame is inserted at the 
position of the Playback Head (unlike Paste which pastes frames at the 
currently selected point). 

How to Delete Frames from a Movie 
(Delete Frame and Clear Score Commands) 

Deleting a frame removes all 24 channels of that frame. As a result, the movie is one frame 
shorter in length. 

To delete just the current frame from a movie, the Score does not need to be open: 

1. Play the movie and stop so the frame you want to delete is displayed on Stage. 

2. Choose Delete Frame from the Edit menu. 

You can continue deleting more frames by repeating step 2. 

Note: If you use Delete Frame with the Score open, notice that it 
deletes the frame at the location of the Playback Head. Unlike the Clear 
command, it does not delete the frames that are selected black. 

To delete a series of frames quickly, do it in the Score: 

1. Open the Score. : | 

2. Select the frames to be deleted by clicking at the top of the Score at the first frame number 
you want to delete and dragging to the right. The frames you want to delete should be selected 

black. 

3. Choose Clear Score at the Edit menu. 

How To Animate: Editing an Animation 151 



VideoWorks 

| Action In Score On Stage 

Select a piece of — Select the frame cell Click on the artwork on the Stage. 
artwork (current containing that artwork. 
frame only). a= 7 

Select a channel Click on the channel Click on the Channel Indicator. 
(current frame only). number at the left end of 

| the Score 

Select a range of Drag pointer across the Drag the left Range Indicator up or 
frames. frames. down to set the left frame. Drag the 

152 

Stage Editing vs. Score Editing 

Practically any editing you can do in the Score you can also do from the Stage and Panel. 
_ The following is a list of equivalents: 

Move to a particular Drag the Playback Head 
frame. left or right. 

Select an insertion Click on that frame cell 
point for Paste (there will be a blinking 
(blinking cursor). vertical bar). 

right Range Indicator up or down to 
select the right-hand frames. 

Drag the Frame Counter left or right. 

(No equivalent) 

Shift-click works on both the Stage and in the Score to extend a selection. 
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Intermediate Editing in the Score 

This section describes how to: | 

¢ Cut, Copy and Paste in the Score 

e Use In-Between to create stationary artwork 

¢ Use In-Between to make artwork move smoothly 

¢ Use In-Between to make artwork stretch 

 Paste-relative to chain sequences together 

How to Cut, Copy and Paste in the Score 
(Cut Score, Copy Score and Paste Score Commands) 

_ Use this procedure to move or copy part of the Score to another spot in the same Score. This 

procedure works for any part of the Score you can select — individual cells, blocks of cells, 

sequences, or entire frames. See the previous procedure "How to Change Foreground Priority" for 

cutting and pasting entire channels. 

Open the Score and select the cells, channels or frames you want to Cut or Copy. 

Choose Cut Score or Copy Score from the Edit menu. 

To paste the entire sequence, select an insertion point (you will see a blinking cursor). 

Choose Paste Score from the Edit menu. : KRW NO = 

The sequence is cut or copied from one location and pasted at another, pasting over any existing 

cells. | : 

Note: If you want to paste into a limited region of the Score, 

drag the pointer across the region to select it black. When you 
Paste Score, the sequence will fill in only the cells that are 
selected black and no further. | 

_ How to Clear Cells from the Score 
(Clear Score Command) ss | 

This procedure works for clearing any part of the Score you can select — any single cell, group of 

cells, sequence, frames or channels. | | 

1. Open the Score and select the cells, channels or frames you want to clear. 

2. Choose Clear Score from the Edit menu. 

The selected cells are erased — they are now empty. 

Note: When you select entire frames by dragging across the 

frame numbers at the top of the Score, choosing Clear Score 

causes those frames to be deleted, rather than just emptied. 

Use the Blank From Stage command in the Edit menu when you want to empty cells in the Score 

when the Score is closed. Blank From Stage is entirely equivalent to Clear Score. 

Shortcut: When you are not entering text, the Backspace key is 

equivalent to Blank From Stage. 

4 Sa 8 Sl 4 9 Sn 8 8 9 i 9 8S 8 8 8 SS 8 8 | | How To Animate: Editing an Animation 153 



VideoWorks 

Notice that the Clear Score command operates exactly the same as Cut os except the cut 
frames are not placed on the Clipboard. 

How to Insert and Delete Time in a Movie 
(Cut and Paste Across All Channels) 

Everyone who uses a computer is familiar with the way that Cut and Paste work in a word 
processor. When you Cut something, the gap is closed up automatically.. When you Paste © 
something, the text after the insertion point gets pushed out (it doesn't disappear). 

VIDEOWORKS II doesn't always work that way, but it can. It depends on whether all 25 channels 
(24 animation + 1 sound) are selected or not. 

If all 25 channels are selected: VideoWorks works "like a word processor." That is, the 

Cut and Clear commands will cut out time (closing the gap automatically) and the Paste 
command will insert time (pushing the succeeding frames back in time). 

If not all 25 channels selected: VideoWorks will not "work like a word processor." That 

is, the Cut and Clear commands will not cut out time (any gap will remain) and it will not 
insert time (any succeeding frames will be written over, not pushed back). 

The easiest way to select all 25 channels is to click and drag across the frame numbers at the top of 
the Score. (You can also click an insertion point across all 25 channels at the top of the Score.) 

In addition, keep in mind that the Paste command works in two distinctly different ways, 
depending on the type of selection you are pasting into: 

If there is a blinking cursor: Paste will paste the entire contents of the Clipboard but only 
over those channels that have the insertion line. 

If there is a solid black selection: Paste will affect only the selected cells, even if what 
you are pasting in is loge, 
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A MINI-TUTORIAL 

Understanding Cut, Copy, Clear and Paste 

To use Cut, Copy, Clear and Paste effectively, you must be aware which window is active, or 

you may wind up, for instance, cutting a castmember from the Cast when you were actually 

trying to cut frames from the Score. Cut, Copy, Clear and Paste operate only on the currently 

active window. Observe this rule: 

Before using Cut, Copy, Paste or Clear, make sure the window you want 

to work in — either Paint, Text, Cast or Score is active. 

For example, if the Cast is currently the active window, then choosing the Cut command will cut 

artwork from the Cast. However, if the Score is active, then choosing Cut will cut cells from the 

Score. 

Note: The Stage is a special case — while you cannot use Cut, Copy and Paste 

directly on the Stage, you can open the Score and perform the operations there instead. 

Cut, Copy, Paste and Clear can operate on three different kinds of objects — artwork, text and 

cells — depending on which window is active. For example, use Cut to: 

¢ Cut the selected artwork from the Paint or Cast window 

¢ Cut the selected text from the Text window 

e Cut the selected cells from the Score 

To demonstrate, try the following mini-tutorial: 

1. Openany movie. (We will be modifying it, but will not save changes when done so as not to 

alter the document on disk.) : 

2. Open Paint, the Cast and the Score. 

3. Paint. Click on an easel in Paint to make it active. Select part of its art with the Selection Box. 

Then pull down the Edit menu and notice it says Cut Graphic, Copy Graphic and Clear Graphic. 

Choose Copy Graphic. 
7 

4. Now pull down the Edit menu again and notice that it says Paste Graphic. This indicates that 

artwork is on the Clipboard, ready to be pasted. 

5 The Cast. Now click on the Cast to make it the active window. Pull down the Edit menu and 

notice it still says Paste Graphic, since the Clipboard still contains the artwork you just pasted to it. 

However, since the Cast is active, it now says Cut Cast, Copy Cast and Clear Cast. Go ahead and 

select an empty position in the Cast and then choose Paste Graphic. You have just pasted from 

Paint to the Cast. 

6. TheScore. Click on the Score to make it active. Select a few frames in the Score. Pull 

down the Edit menu. Since the artwork is still on the Clipboard and since pasting artwork into the 

Score is not allowed, that option is now dimmed. Notice it says Cut Score, Copy Score and Clear — 

score. 
: 
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How to Create Stationary Artwork in a Movie 
(In-Between Command) 

_ This procedure describes how to make artwork stand still during a movie. The idea is to use the 
In-Between command to copy one cell over many frames of a channel. 

To prepare, open the Score and scroll it, if necessary, so that you can view the cell where you want 
the artwork to begin standing still. If the artwork is not yet on the Stage, place it on the Stage. 

Note: Be sure the range of cells you want to fill are blank. The 
In-Between command will not paste over occupied cells. 

1. Drag the pointer from this starting cell to the right as many frames as you want. 

2. Choose In-Between from the Edit menu. 

Shortcut: Command-G 

The selected cells fill in with copies of the starting cell. If you select the direction indicators in 
the Score, you will notice there is no movement from frame to frame, as shown below. 

When you play this movie, the artwork you added will stand in one place for the duration of filled- 
in cells. This technique is also called "fill right" since the cells are filled to the right with copies 
of the leftmost selected cell. 

1. LOCATE THE INITIAL FRAME 

2. SELECT THE RANGE OF CELLS 

(| I (TTT 
3. CHOOSE IN-BETWEEN R 

Using In-Between to create stationary art 

This procedure works with se number of adjacent channels. Simply select the block of cells, as 
shown below: 

gana gree Ha RERREREaRERRGREE 
BERBERS eesGG5as 

A 

santae 

Using In-Between on Multiple Channels 
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How to Make Artwork Move Smoothly Between Two Points 

(In-Between Command) | : 

This procedure describes how to make a piece of artwork move smoothly in a straight line in any 

direction across the Stage. For the sake of example, suppose we have a document where we want 

to add such a sequence in channel 5, from frames 50 to 200. 7 

To prepare, open the Score and scroll it, if necessary so that you can view the starting cell (channel | 

5, frame 50). If the artwork is not yet on the Stage, go ahead and place it on the Stage. 

Note: Be sure the range of cells are blank between the two endpoints 

(between frames 50 and 200 of channel 5). The In-Between command 

will not paste over occupied cells. 

1. Select the starting frame cell for the new artwork (frame 50) so it is selected black. 

2. Choose Copy from the Edit menu. 

3. _Use the scroll bar to scroll the Score to where you want the final frame of art to be (frame 

200) and select that frame so it is black. 

4. Choose Paste from the Edit menu. 

You now have exactly the same piece of artwork at both the starting and ending frames 

(frames 50 and 200). Because they are identical copies, both pieces have exactly the same 

locations on the Stage, as well, so let's move the ending piece of art. 

5. Click on the Playback Head bar at this final frame (frame 200) to make the Playback Head 

jump there. Move the pointer onto the Stage and re-position the artwork to where you want 

it to end up. (If you want, use the Shift key to constrain it.) 

6. Select the range of frames from start to finish (frame 50 to 200, channel 5) by dragging 

across them. | : 

7. Choose In-Between from the Edit menu. 

Play the movie you should see the artwork move smoothly in a straight line (in this case, from 

frame 50 to.frame 200). 

. POSITION THE INITIAL FRAME 

CET 
. POSITION THE FINAL FRAME 

. SELECT THE RANGE OF CELLS 

(|| a || || | | 
. CHOOSE IN-BETWEEN R 

[|] Fegkeeeeeeeesss | || [I 

Using In-Between to create a moving piece or art. 
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How to Make Artwork Stretch as it Moves 
(In-Between Command) 

This procedure describes how to create a single castmember stretching (or shrinking) as it moves 
across the Stage. (To illustrate, we'll add the artwork at channel 5, starting it small at frame 50 
and stretching to frame 200.) 

This procedure is the same as the procedure "How to Make Artwork Move Between Two Points" 
except there is another step between steps 5 and 6. (Let's call it step Sa.) 

5a. Stretch (or shrink) the artwork by pulling on its handles. 

Play the movie and watch the artwork stretch (or shrink), from frame 50 to frame 200 in this case. 

Note that you can stretch or shrink either the starting or ending artwork for different effects. 

L a =, 
" 

1 ie axetil 
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How to Use Paste-Relative to Chain a Sequence 

(Paste-Relative Command) 

Use Paste-Relative to link sequences together to create one continuous motion across the Stage. If 

you were to create a sequence of a horse galloping, all you would need to do is create one complete 

cycle of four or five frames, then use Paste-Relative to repeat that short sequence across the Stage. 

Using Paste-Relative, the horse's second gallop would automatically begin where the first gallop 

ends. 

The Paste-Relative command is merely a convenience — you could do the same thing manually, by 

using the normal Paste command, then selecting the new sequence and re-positioning it to follow 

the first sequence. 

This procedure describes how to copy a sequence and paste it after the original so that the two 

sequences play in one continuous motion across the Stage: For the sake of example, suppose we 

have a document where we want to add such a sequence in channel 1, from frames 1 to 10. 

1. Open the Score and select the sequence (channel 1, frames 1 to 10). 

2. Choose Copy from the Edit menu. 

3. Click on the last cell in the sequence (frame 10) — you should see a blinking cursor at the left 

edge of the cell. Choose Paste Relative from the Edit menu. 

4. To continue the sequence across the Stage, repeat step 3, each time selecting and pasting at the 

last cell in the sequence. — 

When you hit Play, the sequences (the original and the copies) will appear as one smooth, 

continuous motion across the Stage. 

Note: By selecting the last cell (frame 10) in step 3, that cell is pasted 

over and replaced by the first cell of the new sequence. If you do not 

want to lose that last cell, select the next frame instead (frame 11). 

However, in such a case, two frames (frames 10 and 11) would have the 

same location, creating a one-frame pause. 

Like the normal Paste command, Paste Relative pastes over any existing cells when you select 

with a blinking cursor. If you select a range of cells by dragging, only those cells will be pasted 

into. 

An instructive example of the Paste-Relative command is given in Tutorial #6 - The Frogs. You 

can use the above procedure to chain two different sequences together for a special effect. 
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6. Adding QuickDraw Shapes 

QuickDraw Shapes are geometric shapes that you can draw directly on the Stage. The four icons 
shown below are the QuickDraw tools for creating these shapes, much like the rectangle, circle and 
line tools in the Paint window. However, the shapes you draw with the QuickDraw Shape tools 
have characteristics very different from those drawn in the Paint window. In fact they resemble 
MacDraw's tools in many ways, as they are resizeable and their pattern and line thickness can be 

changed at any time. 

o 
Line Rectangle Rounded Circle 

Rectangle 

QuickDraw Shapes are ideal to use as stationary objects in a scene, such as backgrounds because 
they take much less memory than the same bit-mapped shapes in Paint When you try to move a 

QuickDraw Shape as part of an animation, it tends to flash and sometimes tear apart (especially if 

it's large). Use the Paint window to create shapes that you want to animate on the Stage. In 

addition, you cannot real-time record with QuickDraw shapes. QuickDraw Shapes are not kept in 

the Cast — they appear only on Stage and in the Score. 

You can fill a QuickDraw Shape with any of the patterns and change its outline with the line 

widths from the Draw menu. 

To create a QuickDraw Shape: 

1. Click on the QuickDraw line, rectangle, rounded rectangle or circle tool. Notice the pointer 

changes to crosshairs with a tiny, corresponding shape attached to it. 

o = ° A 

Note: If you decide you don't want to draw a QuickDraw Shape, you 
can return the crosshairs to the normal pointer, by clicking on the 

pointer tool at the right end of the Cast or on the QuickDraw 
shape tool itself (it toggles on and off). 

2. Move to the Stage, press the mouse button and drag open the shape. You can always re-size 

the shape later by pulling any one of its eight handles. 

"o Creating the circle Resizing the circle 

3. If you want, pull down the Draw menu and select a line width or fill pattern. 
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7. Adding Film Loops 
A Film Loop is an animated piece of art, kept in the Cast, that is used with real-time record. Let's 
say someone has already created a Film Loop called "Flying Bird," and it resides in the Cast at — 
position A21. When you start Real-Time Recording with it, the first thing you would notice is 
that its wings would be flapping, even when you hold the bird stationary. This is the unique 
characteristic of Film Loops — they have built-in motion, like a clip of film. | 

The best way to animate a spinning ball, for example, is with a Film Loop. Film Loops are also 
good for a person walking, a coin flipping or a man digging. We demonstrated a bird flapping its 
wings in the Tutorial #5 named "The City." Film Loops are a nice way to liven up an animation. 
Once you've created the Film Loop, you can use it over and over again very easily. 

How to Create a Film Loop 

To show you how to create a Film Loop, let's use the example of a bird flapping its wings, a 
three-frame sequence. You can create the Film Loop in either an existing or a new movie. 

1. Create the sequence or find one that already exists. To create one, use the procedure "How to 
Animate a Sequence Frame-by-Frame." 

Note: Sequences are generally smoother when they are made up of odd 
numbers of frames (3, 5, 7, ... etc.) 

Briefly, to create a sequence, you would go into the Paint window and draw three pictures on three 
different Paint easels. At this point they would appear in the Cast as shown below. Then use the 
procedure "How to Animate a Sequence Frame-by-Frame" to create the sequence on Stage of the 
bird flapping its wings. 

Note: It is highly recommended that you learn how to use registration 
points when making sequences for Film Loops. See the section on 
Registration Points below. | 

2. Open the Score and select the frames that make up the sequence by dragging the pointer across 
the frames. If the sequence cycles, select only one cycle of the sequence. 

Note: Select only one channel. Film Loop works with only one 
channel. 

4. Choose Copy from the Edit menu. 

5. Select an empty position in the Cast by clicking on it. 

6. Choose Paste from the Edit menu. That position in the Cast now contains the label "Film 
~ Loop 1" ! 

ei-P el TTL ae tas. 1 HH Fila] \7 
Ae4Y 

This Film Loop is now ready for you to Real-Time Record it on the Stage. — see the procedure 
Animating with a Film Loop that follows. 

Le ee a ee 
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It is interesting to note that after you have used a Film Loop in an animation, when you look in 
the Score and analyze this new sequence, it looks no different than any other sequence. In fact, it 
is just a copy of the same sequence that you selected in the first place. 

Note that you can copy the Film Loop out of the cast and paste it back into the Score. This way 
you could edit an existing Film Loop, and put it back in the Cast when done with it. 

An example of creating and using a Film Loop is given in Tutorial #6 - The Frogs. 

Animating with a Film Loop 
Film Loops can be animated only with Real-Time Recording, and are created no different than 
animating ordinary art. Select the Film Loop in the Cast, hold down the Command-Option keys, | 
move the pointer to the Stage and begin recording by pressing down the mouse button and moving 
the Film Loop around. All your actions will be recorded until you release the mouse button. 

Setting Registration Points in a Film Loop 
If you find your Film Loop's motion to be jerky and unnatural, you probably need to set "logical" 
registration points for your sequence. — 

For example, in the jumping frog, a good place for the registration point would be on the shadow 
of the frog. This way, when the person using the film loop holds the frog still, the shadow will 
not move yet the rest of the frog will move. Similarly, for the flapping bird, you would want the 
registration point to be on the head of the bird. For an arm that swings, you would want the 
registration point at the shoulder. For a walking animal, the shoulder or hips are possibilities. 

Registration points are easily set for a given piece of art in the Paint window . You click on the 
Registration Point tool (see Paint window in "VideoWorks Reference") and the registration point 
appears. A click of the mouse then sets the registration point to where you want it. 

Storing Film Loops 
We recommend that you store your favorite Film Loops so that you can use them in new 
animations. The simplest way to store Film Loops is as follows: 

Take a movie with Film Loops already in it and choose Burn Scene to remove the part you 
don't need (to make the movie smaller). Choose Save As, and rename the movie "Film Loop 
of Bird." (To save even more space, you can remove artwork you don't need from the Cast by 
clearing that artwork one-by-one with the Clear Cast command.) | 

You could also copy Film Loops from various VideoWorks movies and paste them all in a single 
movie. When you do this, you must Copy and Paste the sequence from one Score to the other 
Score. You cannot Copy and Paste a Film Loop from the Cast of one movie to the Cast of 
another. 
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Using In-Between to Move a Film Loop Across the Stage 
(Shift — In-Between) | 

You can use In-Between with a Film Loop to make it move in a straight line across the Stage. To 
do this, let's assume you have already created the Film Loop, have selected a channel to record in, 
and the Score is open. 

i; 

U2 

When you play the movie, the Film Loop will start out at the initial location, then move to the 
final location, all-the-while continuing its built-in motion. If the final piece of art is out of sync, 
Switch it with another castmember or delete it altogether. 

Place the first castmember of the sequence on the Stage where you want the sequence to start. 

Move the Playback Head to a later frame and place the same (or another) piece of art on the 
Stage where you want the sequence to end. 

In the Score, select the range that includes the two cells you just placed. 

Click on the Film Loop in the Cast to select it. (This determines which Film Loop will be 
pasted into the Cast.) 

Hold down the Shift key and choose In-Between. 

Shortcut: Press Shift-Command-G in place of the last step. 
(Notice that Command-G is the shortcut for a normal In-Between.) 
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8. Adding Text 
You can create text in the Paint window or in the Text window. The two kinds of text have 
very different characteristics. Paint window text has better for animating (moving across the 
Stage), while the Text window text is easier to edit and takes up less memory. 

How to Type Text in the Paint Window 
To create text in the Paint window in order to add to a movie: 

1. Open the Paint window. Click on the New Easel tool El Make the easel larger by pulling 

on its handle. 

Click on the Text tool LA 

3. Click in the Easel and begin typing. Choose a font, style and size from the Text menu either 
before or after you type. 

Note: Once you click the mouse again, the type font, style and size 
cannot be changed. 

As you type, the text immediately appears in the first available Cast position. When done typing, 
you can drag the text out onto the Stage like any other artwork. 

You can create text in the Text window (and Cast) in either of two ways: By typing into the Text 
window or by typing directly on Stage into a Text Box. 

How to Type Text in the Text Window 
To enter text into the Text window: 

1. Open the Text window. The slots in the Text window correspond exactly to the castmember 
positions in the Cast. A gray slot in the Text window indicates that Cast position is already 
occupied by Paint artwork. 

2. Move to an empty slot and click — the slot becomes taller — and begin typing. 

Note: If you type text into a slot numbered 70 to 88, you can have 
that text spoken with Macintalk. 

The text is now entered into the Text window — it also appears in the Cast as you type. You can 
drag the text out onto the Stage from the Cast like any other artwork. 

If you are importing text (from MacWrite, for instance), you can use Paste to get text into the 
Text window. — 
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How to Type Text Directly On Stage 
(Text Box) | 

To type text directly on Stage: 

1. Click the Text Box at the right end of the Cast. 

2. Move onto the Stage — the cursor should appear as: ' fA 
3. Drag a text box open on the Stage and begin typing. 

The text you type appears on the Stage. 

: HERE 1S SOME TEXT | 
: ON THE STAGE 

5 aac ass 4 . 
Making a text box A : Typing in a text box * 

The following chart compares text in the Paint Window to text in the Text window. 

Comparison of Text 
Paint Window vs. Text Window 

Text created Text created 
in Paint Window in Text Window 

Characteristic Bit Character 

oriented oriented 

Can edit directly No on Vee 
on stage? (must edit in 

Paint window) 

How quickly can it 
move across the i Faster Slower 

— Stage? 

Memory required More Less 
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9. Adding Sound, Tempos and Transitions 

Sounds, Tempos and Transitions are independent features that have one thing in common — they 

all share the top channel of the Score. : | 

Note: For the sake of brevity, throughout this manual we are calling 

this the Sound Channel. 

The Sound menu contains dozens of different sounds to add to your animations. VideoWorks has 

one sound track, the topmost channel of the Score. This channel is indicated by the loudspeaker 

icon. 

Adjusting the Volume 

You can turn the sound on and off at the Panel by clicking on the loudspeaker icon: a (here it's 

shown turned on). You can also adjust the volume of the sound at the Control Panel desk 

accessory. 

Note: If you cannot get sounds to work, refer to the Troubleshooting 

section on the Sounds file in the appendix for suggestions to get it 

working. 

How to Add Sound to a Movie 

This procedure describes how to add sound to a VideoWorks document. When assigning a sound, 

make sure the movie is playing at its proper speed. 

You can use this same procedure for either adding or changing a sound: 

1. Open the Score. 

2. Drag the pointer across the frames in the sound channel where you want the sound. Those 

frame should be selected black. 

3. Pull down the Sound menu, move down to the item you want and pause without releasing the 

mouse button. A submenu pops up — move sideways to the sound you want and release the 

mouse button. : 

Note: The submenus in step 3 work only if you are using System 4.1. 

If you are using an earlier System, see the Sound menu in the 

VideoWorks Reference section for more information. 

The sound you have chosen is pasted into the selected frames of of the sound channel. If you click 

on the castmember number button af you can see the sound's identification number in the sound 

channel. To repeat a sound, refer to the next topic. 

Synchronizing Sound to Pictures 

When you use the Speed Control to speed up a movie, the pictures speed up, as does the spacing 

between individual sounds. However, the sounds themselves do not speed up. For example, the 

Mozart piece plays at the same tempo. Therefore when fitting the action on Stage to long, 

continuous music, it is important to pick one speed and stick to it. 

However, when you synchronize very short sounds to pictures, such as footsteps sound to a person 

walking, the speed setting makes no difference. Every time the foot makes another step, the 

footsteps sound is generated at that frame. / 
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When your movie contains music, you may want to alter the pictures to fit the sound rather than 
the other way around. Use Insert Frame or Delete Frame to make a movie longer or shorter. This 
is described in "How to Speed Up or Slow Down a Sequence." under Advanced Animation 
Techniques at the end of this "How to Animate" section. 

Removing A Sound 
If you want to remove a sound, you must be careful not to remove any transition or tempo that 
stored in the same channel. If there is a hidden transition or tempo in the sound channel, the cells 
will be gray as a warning. 

Note: If there are transitions or tempos in the sound channel, you 
should write down what they are, because you will need to re-assign 
them to the frames that you clear out. | 

To remove a sound: 

1. Click on the cast member number button | This causes the sound codes to appear in the 
sound channel. 

2. Drag the pointer along the cells containing the sound you want to remove. They should be 
selected black. Choose Clear Score from the Edit menu. 

This procedure removes sounds, transitions and tempos from the sound channel. You must re- 
assign any transitions or tempos that you removed. : 

Rewind and play the movie. Notice the sound will continue uninterrupted as long as it is 
uninterrupted in the sound channel. Once the sound channel is interrupted (by another sound or by 
a blank cell), the sound resets to the beginning. 

Re-Triggering a Sound 
All sounds in VideoWorks fall into one of two categories, those that require re-triggering and those 
that do not. To re-trigger a sound, you include a blank cell in the sound channel. The blank cell 
causes the sound which follows to start over again. 

e Continuous sounds — Sound that do not require re-triggering. These have no detectable 
start or stop. They can play continuously for whatever length of time you specify — for 

thousands of frames. 

Examples: Rockslide, Forest Fire, Jet engine, Helicopter, Idle, Drone 1, Drone 2, Cartoon, 
Rock 1, Rock 2, Boogie Woogie, Jazz, Funk 1, Funk 2, YX-Synthesis and Y-Synthesis. 

¢ Sounds that require re-triggering — Most sounds in the Sound menu fall into this 
category. These have a definite start and finish. These will play only once and then stop. To 
get them to repeat, you must include at least one blank cell before you repeat the sound. 

Examples: Do, Re, Mi, Cowbell, Footstep, Mozart, Bach, and almost all other sounds except 
those listed in the previous category. These sounds might last for only a moment (Do, Re, 
Mi, Cowbell, Footstep) or for much longer (Mozart, Bach). Once the sound stops, it needs at 
least one blank cell in the sound channel before you can repeat the sound. 

- Sampled sounds can fall into either category -- you can select in "Sound-to-Video" if you want it 

continuous or not. 
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How to Make a Sound Repeat 
This procedure is necessary only for sounds that require re-triggering. 

1. Insert the sound in the sound channel as described in "How to Assign Sound to an 
Animation.” Let's say the sound is assigned to frames 1 to 200. 

2. Start the movie and set it to its proper speed. Open the Score, watch the Playback Head and 
notice the frame number where you want the sound to start again. (A convenient way to do 
this is to stop the movie at that point.) For example, let's say this is frame 50. 

3. Clear the previous cell (frame 49) in the sound channel from the Score by selecting it and 

choosing choose Clear Score from the Edit menu. : 

When you play the movie, the blank cell allows the sound to repeat again. 

The blank cell allows the sound to start again here 

DODO OO VOC SOP OOOODOOOOOUC 
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Using a blank cell to re-trigger a sound 

Sound have different lengths. Some are very quick (like a footstep), while others are very long 

(like music). You may want to repeat a sound over a longer period of time. 

Here's an example of repeating a short sound quickly. The Cowbell is a very short sound, 

requiring only one cell. To create a series of closely-spaced Cowbell sounds, you would alternate 

the Cowbell with blank cells, as shown: 

Untitled Score = 
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How to Make Sound Dependent on the Position of Art 

Two interesting never-ending sounds are Y-Synthesis and YX-Synthesis. The tone and volume of 

these sounds are determined directly by the position of the artwork on the Stage. 

With both sounds as the art moves down the screen, the sound gets lower in pitch; as it moves up, 

it gets higher in pitch. Y-synthesis produces a pure tone, while YX-Synthesis produces a raspy 

tone that also gets slightly louder as the art moves to the right. The effect is a direct 

synchronization of sound to video. | 

You can use Y-Synthesis or YX-Synthesis in this procedure to connect moving art with a sound. 

As an example, we use Y-Synthesis. 

1. Open the Score. Select the frames of an existing sequence you want to base the sound on. 

(Do not select the sound channel.) Copy and Paste this sequence into the sound channel, 

starting at the same frame. 

2. Select the frames in the sound channel you just pasted into (if not already selected) and select 

Y-Synthesis from the Basic submenu of the Sound menu. As the artwork moves toward the 

top of the Stage, you'll hear the pitch increase along with it. : 

All of the melody lines in the Old Music, New Music and Business submenus can be 

synergistically connected to artwork, but in a different way. The key they play in depends on the 

starting position of the art. 

How to Make Your Macintosh Speak 
(Macintalk) 

You can make any text in the Text window spoken by your Macintosh. 

Note: Make sure the Macintalk file is in same folder as the Sounds 

file. If not, Macintalk will be silent. For more information, see the 

Sounds file in the Appendix. 

To make your Macintosh speak text: 

1. Start with text in the Text window at A71 to A78 or A81 to A88. (For example, let's pick 

A71.) These are the only positions where Macintalk works. 

2. Open the Score and select one cell in the sound channel where you would like to hear the text 

spoken. 

3. Pull down the Sounds menu, move to Macintalk, wait for the submenu to pop up, then 

move the pointer to the cast number you used in step 1. (in this case, "F-1 Cast #7-1.") 

Play the movie. When it reaches the frame with the Macintalk, the animation stops temporarily 

and the text is spoken. All animation stops temporarily while Macintalk is speaking because it 

demands all of the computer's processing power. If Macintalk doesn't work, make sure the Sound 

switch is turned on in the Panel. If that still doesn't fix it, make sure you have the Macintalk file 

in the same folder at the Sounds file. : 

Note: If you have text that already appears somewhere in the Text 

window, you can easily turn it into Macintalk speech: Use the previous 

procedure except in step 1, simply use Copy and Paste to move the text 

into the Cast. 
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‘Sampled Sound (Sound Cap) 
Sampled sound is sound that has been captured with a microphone and stored directly on disk. 
Though this requires special hardware, the results are very impressive and realistic sounds you can 
use in your animations. For further description, see "Sampled Sound" in the "Advanced 
Animation" section later in "How to Animate." 

= MusicWorks 

Music Works is a product that allows you to create music on your Macintosh. With the program 
Music -* Video, you can import these sounds for use in animations. For further description, see 
"Music Works to VideoWorks" in the "Advanced Animation" section later in "How to Animate." 
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How to Add Tempos 

The Set Tempo command lets you easily change the tempo at different places in the animation. 

Adding a tempo is very similar to adding a sound. : . 

You can use this same procedure for either adding or changing a tempo. 

1. Open the Score. Drag the pointer across the frames in the sound channel where you want the 

tempo. Those frame should be selected black. 

2. Choose Set Tempo at the Edit menu. A dialog box appears. 

3. Type in a number from 1 to 60 for the tempo. The higher the number, the faster the speed. 

This is the same numbering system that appears on the speed control in the Panel. 

tl 

— 

Note: When you switch to another display in the Score (with the 

Display Buttons), the sound channel will be grayed out, indicating that a 

tempo is present. 

The value you typed in should now appear in the Score. An indicator to show a change of tempo 

appears in the Score. Now when you play the movie, when it reaches this frame, the tempo will 

change to the value you specified. 

If you later want to find out what value the tempo is, select the cell you are interested in and 

choose Set Tempo again. The value that is selected will appear in the dialog box. 

You can perform the above procedure whether or not the Tempo channel is actually being displayed 

— that is, regardless which of the four display buttons is pressed. 

Links Score 
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Tempo set to 60 in frame 11. 
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How to Add Transitions 

The Set Transitions command lets you easily create a transition between two frames in the 
animation. Adding a transition is very similar to adding a sound or tempo. Like a tempo, you 
assign the transition to only a single frame. 

The symbols for transitions in any BH SEOn reside in the Score in the sound channel. You can 

view them by clicking on the ink button |e 

The following procedure describes how to add transitions to your animation. You can use this 
same procedure for either adding or changing a transition. 

Note: For this procedure, it is not necessary for the transition icon to 
be showing at the left end of the Score. 

1. Open the Score. Select the frame in the sound channel that you want to make the transition 
to. For example, putting the transition in frame 11 will cause the transition to occur between 
frames 10 and 11.. That frame should be selected black. 

Note: This frame that contains the art that you want at the end of the 
transition. 

2. Choose Set Transition at the Edit menu. A dialog box appears. 

3. Click on the transition you want, then click OK. 

An indicator for the transition appears in the Score. When you play the movie, it will pause at the 
frame before the frame you selected and make the transition into the frame you selected. 

If you later want to identify what transition is present in the Score, select the cell in the sound 
channel with the transition symbol and choose Set Transition. The current transition will be 
marked off. 

Note: When you switch to another display in the Score (with the 
Display Buttons), the sound channel will be grayed out, indicating that a 
transition is present. | 

Links Score 

Transition 0-1 in frame 11. 
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10. Using Inks 

Inks modify the way artwork appears on the Stage and determine how its patterns interact with 
artwork behind it. It's important to realize that inks are used in two places: on artwork in the 
Paint window and in animations on the Stage (and Score). Which place the ink is applied to is 
determined by the window that is active (Paint or Score) when you pull down the Ink menu and 
choose the ink. Inks in the Paint window are described under "Creating Artwork." 

For some good examples of using inks, see the table below. We have included a movie called Ink 
Demo, which plays the same animation with all the various inks. 

Note: An important thing to know about inks is: When artwork A is 
positioned in front of artwork B, only the ink of artwork A determines 
how the patterns interact. It makes ole no difference what the ink 
of the background art is. 

How to Change the Ink in Animations 
There are basically two ways to set the ink mode. You can set it either before or after you place 
art on the Stage. 

If you know in advance what ink you want to use before you have placed the artwork on the Stage: 

1. Click on the Cast to make it active. 

2. Choose the ink you want from the Ink menu . 

3. Drag out the artwork onto the Stage. 

Note: This first step is important only to make sure the Paint window 
is not active. If the Paint window is active, you will set the ink for the 
Paint tools, not the ink for castmembers being dragged onto the Stage. 

The artwork will have the ink you specified This procedure is simple in that it does not require 
the Score to be open. 

If the artwork is already on the Stage and you want to change its ink: 

1. Open the Score and select the cells corresponding to the artwork whose ink you want to 
change 

2. Choose the ink you want from the Ink menu. 

The artwork now has the ink you specified. In Step 1 you can select artwork on the Stage without 
opening the Score if you only want to change one frame at a time. 

Note: In all cases, the ink you choose becomes the default ink and 
applies to all subsequent artwork you drag onto the Stage or animate in 
real time. 
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Useful Things to Do With Inks 
‘Here is a table of useful and creative ways to use inks. 

To do this: 

To remove the white box 

from around artwork 

To make artwork transparent 

To see through holes in artwork 

To reverse white and black 

To create a trail of artwork 
across the Stage 

Create a mysterious-looking 
ghost image | 

Use this ink: 

Or, Matte and Mask will each eliminate the white box and 
keep the basic appearance of the artwork with various 
degrees of success. First try Or, because that takes up the 
least amount of memory. If that doesn't work, use Matte. 
If there is no solid outline around the object, you will 
need to use Mask. 

Use Or on the foreground art. 

Use Mask. See the procedure "How to Create an Ink 
Mask" in the "Advanced Animation” section. 

Choose Xor, choose black fill at the Draw menu, then 
draw a QuickDraw rectangle on the Stage over the artwork 
you want to reverse. 

Or choose NotXor, choose white fill, then draw a Quick- 
Draw rectangle on top of the artwork you want to reverse. 

Use No Erase 

Use Bic 
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11. Importing Artwork 
There are several ways to bring artwork into VIDEOWORKS II: 

e Art Grabber+ 

¢ Scrapbook 

¢ Clipboard 

Art Grabber+ lets you bring in any artwork in MacPaint format. The Scrapbook and Clipboard let 
you bring in artwork in many other formats including PICT and text. Any artwork you can get 
into the Scrapbook or onto the Clipboard can be pasted into VideoWorks. 

Note: When bringing art into VideoWorks, the easiest way to paste it 
is to click on an empty position in the Cast and then Paste. This is 
easier than creating a new Paint easel, dragging it open and pasting 
there. Pasting into the Cast will always work, while pasting large 
pictures into the Paint easel requires that you open the easel large 
enough to hold it. 

Using Art Grabber+ 

This section decides how to use Art Grabber+ in VideoWorks 

How to Grab Art Using Art Grabber+ 
To use Art Grabber+ to grab art from an existing paint document in MacPaint anae 

1. Choose Art Grabber+ from the @ Apple menu. The Grabber menu now appears at the right 
end of the menu bar. . 

Choose Open from the Grabber menu. 

3. Find the document you want to open. If necessary, switch folders or drives: 

¢ Double-click on a folder to open it and view the files within it 

e Click Drive to switch drives 

e Click Eject to eject the current disk 

e Click Cancel to return to Art Grabber+ without opening a document 

4. Click on the document you want to open and then click Open. 

Move the pointer into the Art Grabber+ window -— the pointer turns into crosshairs. 

6. Ifnecessary, scroll to the part of the document you want. Use the scroll bars along the side of 
the window. Your can also use Show Page to see the entire document in a reduced view 
(where you can move the viewing window). 

7. Select all or part of the image by pressing and holding the mouse button and then dragging 
diagonally across the image, until the selection rectangle encloses the image you want. When 
you reach the edge, the image will auto-scroll so that en can enclose the entire document if 
you wish. 

8. Choose the Grab command from the Grabber+ menu. This copies the image onto the 
Clipboard. From there you can paste it into Paint or into the Cast window. 

9. Toclose Art Grabber+, click the close box in the upper left corner of its window. 

WN 

Result: You have copied all or part of a document to the Clipboard. At this point you can view 
the Clipboard, if you wish, to see just the selection you copied to it. 
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Viewing the Clipboard 
To view the Clipboard, choose Clipboard from the Grabber menu. The contents appears in Art 
Grabber+. If the Clipboard is empty, nothing happens — ae Art Grabber+ window continues to be 
displayed. 

Importing a Group of Pictures 
You may want to import sequences of artwork from 3D programs, digitizers and scanners. For 
instance, in Easy3D you could save individual rotated versions of an object, import them into 
VideoWorks and play them as a sequence, creating a rotated object in motion. similarly, you can 
capture sequences from a video camera through a digitizer or from scanned artwork. 

If you have a lot of artwork you need to import from another application, use the Scrapbook. For 
this procedure, see —— the Scrapbook to Import Artwork," in the "Advanced Animation" 

section. 3 | ae 

Grabbing Art from the Current Screen 
Use Command-Shift-3 to save the entire screen, as you literally see it, with the menu bar if it 
is visible (except without the cursor) as a MacPaint document. Each document is named in 
sequence "Screen 0", "Screen 1", etc. You can then grab this artwork using Art Grabber+. 

Use Command-Shift-6 saves any part of the screen as follows: Press Command-shift-6 (the 
cursor turns into a crosshairs). Draw a selection rectangle around the image on the screen that you 
want to capture. When you release the mouse button, the image is saved to the Clipboard. Then 
use Paste from the Edit menu to paste the image into the Cast or Paint window. 

Using the Scrapbook 

The Scrapbook is a desk accessory available at the Apple @ menu. You can save frequently-used 
artwork, text, sequences and Film Loops in the Scrapbook. These are saved in a file named 
Scrapbook in the System Folder. The Scrapbook is not part of VIDEOWoORKS II, but rather is a 
part of the standard Macintosh system. : 

Once the Scrapbook window is open, you can leave it open to transfer artwork to or from any 
VideoWorks window. 

_ The Scrapbook is useful for: 
¢ Copying artwork and animation from one movie to another 

¢ Copying artwork from another graphics program to VIDEOWORKS II 

e Storing artwork and animation for later use 

Examples of all three cases are given under "Advanced Editing” later. 

Typically, you might save artwork from the Paint or Cast window to the Scrapbook. Conversely, 
you can transfer artwork that was saved to the Scrapbook in another program to the Paint or Cast 
window. Likewise, you can transfer text to or from the Text window, or groups of cells to or 
from the Score. 

To copy artwork from the Scrapbook, scroll to that piece of artwork and choose Copy. You select 
the artwork in the Scrapbook merely by scrolling to it — you do not click on it as you = be 
accustomed to doing when you use Copy in other ADE Eoe. 
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12. Printing in VideoWorks 

In VideoWorks, the Print command lets you print frames of your animation full-size, 50% or 
25%. You can print the current frame or any range of frames. Within that range, you can print 
frames in regular intervals, every marked frame, or only the frames where the castmember in a 
specified channel changes. 

You can also print all of the text or artwork in the Cast, or print the Score window itself, as it 
appears on the screen, with all of its notation. 

When you choose Print, the following dialog box appears: 

VideoWorks Print Options 

What to Print: Range of Frames: 

@ Print Stage @ All 

© Print Score O From: Eo] = = 
© Current frame 

© Print Cast text © Selected frames: 10 to 20 
© Print Cast | 

artwork Within range of frames: 

@ All 

© Every Nth frame, N= 

© Frames with markers 

© When artwork changes 

in channel 

What to Print — Specifies whether you want to print artwork as it appears on the Stage, the 
Score window itself, the Cast text or the Cast artwork. 

Frames with markers — Use this option to print frames that are marked. To mark frames, 
click on the round markers along the top of the Score. 

Untitled Score 

Markers O9000008000006080000000000000000008000000 
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Markers for printing 

If Printing Does Not Work. 
To print you must have the appropriate printer file (ImageWriter or LaserWriter) on your System 
disk. Check that the printer is selected in Chooser, and check the cables to make sure they are 
securely connected. 
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Printing the Stage 

Printing the Cast 
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Layout Options 
Clicking on Layout Options brings up the dialog box shown below. The options are described 

_ earlier in the Overview Printing section of this manual. 

Page Options 

J Print Page Header (filename & date) 
[] Print Page Footer: 

|JideoWorks II 

Frame Printing Options 

(] Print frame around border 

[] Single column format 

C] Registration marks (with full sized image) 
Include frame number 

Scale 

@) Full size © 50% size © 25% size 

Co) 

Layout Options Dialog Box 
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13. Advanced Animation 

This section contains useful information for advanced users. These tips are divided into the 
following three sections (and are in no particular order within each section): 

Advanced Editing 
Advanced Art Techniques 
Advanced Animation Techniques 
Advanced Sound 
Analyzing Animation 

At the end are some tips about "What can I do to improve my animation?" 

Advanced Editing 

Other Ways to Place Artwork 
(Place On Stage Command) 

We showed earlier how you can place artwork on the Stage merely by dragging it out from the 
Cast. There are two other ways to place artwork that power users might want to take advantage of, 

using the Place On Stage command in the Edit menu, and the ¢8-T shortcut. 

¢ If the Cast is closed and you happen to know which castmember is currently selected in the 
Cast, use the Place On Stage command to place the castmember. 

¢ If you have already selected the castmember you want, and for some reason = already 
positioned the pointer on the Stage exactly where you want the artwork, you can press d6-T. 
This places the artwork without losing your pointer position on the Stage. 

In either case, the Place On Stage command operates as follows: 

1. At the Cast, select the castmember you want to place. 

2. Choose Place On Stage from the Edit menu or press d$-T. 

This changes the pointer into crosshairs ~ i 

3. Move this crosshairs where you want the center of the artwork and click. 

The currently selected castmember appears at the spot you clicked. You can actually do steps 1 and 
2 in either order. 

Note: If after step 2 you choose not to place art, you can toggle the 
crosshairs off by clicking the pointer tool at the right end of the Cast (or 
by choosing Place On Stage a second time). The crosshairs will return 
to the normal pointer. 

Creating a New Document with the Same Cast 
To create a new movie with the same castmembers of another movie (movie A), open movie A 
and Save As with the name for the new movie. Open this new movie and Burn Scene. The 
new movie has the same cast as movie A, but its Score is empty. 
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How to Move Artwork and Animation Between Movies 
The easiest way to move artwork and animation between movies is to let VideoWorks do the work 
for you. When you copy a sequence in the Score from one movie to another, VideoWorks will 
automatically get all the castmembers that are part of that sequence, and paste them into the other 

file. 
Note: For this to work, the file you are copying from must be saved on 
disk, because that is where VideoWorks will get the castmembers from. 
Also, if you want to store a sequence in the Scrapbook for any length of 
time see the warning below. 

Another technique, is to paste items temporarily into ) the Scrapbook to move them between 
documents. This is described below: : 

To move artwork from one movie (Movie A) to another (Movie B): 

1. Open Movie A, the movie that you want to copy from. To copy artwork or animation from 

Movie A into the Scrapbook: 

a. Select the artwork (in the Cast or in the Paint window) or the animation (any part of the 
Score) and choose Copy. 

b. Open the Scrapbook and choose Paste. Repeat this process for each piece of artwork 
you want to move. 

Note: When you paste a block of cells into the Scrapbook, the channel 
and frame numbers appear (as shown below), indicating the channels and 
frames in that block. | 

2. Open Movie B, the movie that you want to copy to. To paste artwork or animation from the 
Scrapbook into Movie B: 

a. Open the Scrapbook, scroll to the artwork or animation you want, and choose Copy 
(this copies the artwork from the Scrapbook to the Clipboard). 

b. Close the Scrapbook, open the appropriate window (Paint, Cast or Score), select a 
blinking insertion point and choose Paste. Repeat this procedure for each piece of 
artwork or animation you want to move. 

The pieces of artwork in movie A are now copied to movie B. 

When you paste cells into the Scrapbook, a message appears in the Scrapbook indicating the 
sequence, as shown in the following illustration. 

Scrapbook 

Videoworks Animation from: 

Petite Onze:Untitled 

Channels 1 -> 1 

Frames 1 -> 50 

TEXT, SCVW 
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The following diagram illustrates how you could copy several individual sequences to another 
movie. The Scrapbook is very useful for copying several sequences that do not appear in the Score 
as a block and for storing them for later use. 

Movie A _ Scrapbook Movie B 

You can also use the Scrapbook to store movies temporarily. However, be sure to observe the 
important notice on "Storing Sequences in the Scrapbook." 

IMPORTANT 

Storing Sequences in the Scrapbook 

The Scrapbook is a good place for storing artwork, sequences, and Film Loops. 
However, you must keep the following point in mind: When you Paste from the 
Scrapbook (or Clipboard), VideoWorks must access the original file for the Paste 
operation. 

When you Cut or Copy cells from the Score to the Clipboard or the Scrapbook, 
VideoWorks copies all of the information about the animation except it does not 
copy the castmembers. It copies only a reference saying where to find the 
castmembers (which disk, folder, file and castmember position). When you Paste 
the cells into another document, VideoWorks must access the original file to get 
the castmembers. | 

When you have done a Cut or Copy, don't alter the original file before doing the 
Paste. Specifically: | 

¢ Don't move the castmembers from their original positions in the Cast 
¢ Don't alter the name of the file or folder where the original castmembers reside — 
¢ Don't move the original file to another folder or disk 

If you ignore these warnings, and perform the Paste anyway, the worst that can 
happen is that the new movie will have be using the wrong castmembers — the movie 
will no longer make any sense, but no damage will be done. 
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How to Use the Scrapbook to Import Artwork 

Let's say we want to import artwork from another application, say Illustrator or Excel, to 

VideoWorks. This is especially valuable if you have lots of pieces of artwork to transfer. By 

using the scrapbook you won't have to close VIDEOWORKS II and go into Illustrator every time 

you want another piece of artwork. 

This is basically the same procedure as described earlier in "How to Move Artwork and Animation 

Between Movies." 

1. Open the application (Illustrator, Excel, whatever...) and create all the artwork. 

2. Select the first piece of artwork and choose Copy. Open the Scrapbook and choose Paste. 

This pastes the artwork into the Scrapbook. 

Repeat step 2 until all of the artwork is copied to the Scrapbook. When done, close the Scrapbook 

and application, open up VideoWorks, and do the reverse process, copying from the Scrapbook. 

How to Repeat Just a Portion of a Movie 
The Repeat Selection command lets you repeat a portion of a movie over again without having to 

see the entire movie. This comes in handy if you need to edit only part of a movie. Open the 

Score and select the frames to be repeated and choose Repeat Selection. When you play the movie, 

it will loop on the region you selected. 

The Frame Counter in the Panel flashes to signify that Repeat Selection is on. Notice that a gray 

bar appears in the Score just below the frame numbers, to indicate which frames are being repeated. 

To turn off Repeat Selection, choose Repeat All. 

Control 

Play 

Stop Section to be repeated 

Rewind 

Step 

Back Step 

Repeat Selection 

“Repeat All 
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Short Menus 

Preferences... 
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Registration 

Point Tool 

How to Set a Registration Point 
To set a registration point: 

1. Open the Paint window and select the artwork you want to adjust. : 

: ; n 
2. Click on the Registration Point tool and then click on the artwork at the point you want 

to define as the registration point. 

In effect, this point becomes the new "center" for this castmember. Its position on the Stage now 
centers around this point. 

When creating a sequence, such as a person walking, where the motion needs to be smooth from 
one frame to the next, it can be difficult to position castmembers correctly the first time. This is 
especially true when you use Switch Castmember to replace one castmember with the next in the 
sequence because positioning is determined by the centers of the castmembers. For many things, 
such as circles and squares, the registration point is the center. But if this is not the case, you can 
either "eye-ball" their positions for each frame. or you can set a registration point. 

Paint - Bank 8 => NOTE: 
The Registration Point 
is actually visible only 

on the active easel. 

An example of the need for a custom registration point is in the "Walk the Dog" movie, included 
in the VIDEOWORKS II package. A good place for the registration point of the man walking i is 
the intersection of the ground and a line drawn vertically through his shoulder. This point is not 
always in the same place for each cast member, so it is necessary to adjust it for each one. Using 
this feature assures that the man won't seem to stretch, but will move smoothly. 

Note: If you would like to get rid of the previously set registration 
points so that they are automatically set in the center of each cast 
member, just select the Registration Point tool, click inside the easel 
and drag outside. The registration point will automatically be set in the 
center. You must do this for each castmember. 

A good way to set the Registration Point for a sequence is to use Repeat Selection (see next 

section), and adjust it while watching the animation loop. 
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How to Create an Ink Mask 

An ink mask lets you specify which parts of a piece of artwork are opaque and which are 

transparent. This is useful for seeing through a car window, or for seeing through the center of a 

donut. You can sometimes get the effect you want with the Or ink mode, but this gives you 

much finer control. 

To create an ink mask, you need to prepare two castmembers: the original artwork and its mask. 

For a car with shiny fenders, these would look like this: 

Paint - Bank A: 

JIAO) ape 
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Original of car (on left) and mask (on right) 

Start with the original castmember in the Cast and an empty Cast position immediately following 

it. (This empty position will be for the mask.) : 

1. Click on the original castmember in the Cast and choose Copy Cast. Click on the Cast 

position immediately following it and choose Paste Cast. — 

2. Open the Paint window and use the Paint Bucket or Paintbrush to fill in the artwork, making 

it black wherever you want the artwork to be opaque. Leave white where you want the white 

part of the artwork to appear as a hole, letting the background show through. Do not paint 

outside the outer outline, or you will create a ghost effect, that resembles a Bic ink. 

The black part of the does not allow white areas in the car to be transparent. The white part of 

the mask allows white areas of the car to be see-through. Since there is a hole in the mask for 

the window, the background will show through it. 

3. Inthe Score, select the original castmember wherever it appears, and apply the Mask ink to it 

from the Ink menu. (The mask castmember never appears in the Score, and so never needs the 

Mask ink applied to it.) These channels will appear with a mask symbol as shown below. 

Ink Demo Score =HJz 
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Mask mode is represented by a 
little masked face ® 
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Note: The relative positions of the artwork and mask within their 
Paint easels is important, which is why we recommend creating a mask 
by copying from one Cast position to the next. Do not create the mask 
by making a new easel in Paint and using the Selection Box to Copy 
and Paste. 

~~ 

Making an Ink Mask for Artwork That Has No Outline 
Another situation where an ink mask is useful is when you have artwork that has no definite, hard 
outline, or where the outline has holes in it, such as the illustration of the face Such is the case 

with artwork that is created with the Airbrush. The face appears transparent if you use Matte ink. 
To prevent this, use a mask the same shape as the face. The mask will keep the background from 
showing through. 

Matte Ink Custom Mask. Mask 

Returning Artwork on the Stage to its Original Size 
(Normal Size Command) 

As we learned earlier, you can stretch or shrink any artwork by grabbing one of its handles. If at 
any time you want to return a piece of artwork exactly to its original size, just select the artwork 
and choose Normal Size from the Edit menu. 

It's possible to change the size of artwork by mistake by grabbing one of the handles when you 
only meant to move it. Sometimes you might resize it by such a small amount that you don't 
even notice it, except that the animation slows down when you get to a certain frame. If you 
change the artwork back to normal (unscaled) size, the animation will run —— without 

. Slowing down there. 
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Advanced Art Techniques 

Creating a Sequence of Artwork 
Here are some tips for drawing a series of art. Let's assume you've already drawn the first piece of 
artwork, such as a man taking a step. If you want the next piece of artwork to be only a slight 
modification of the first piece, it would probably be easiest to make a copy and modify that, as 

follows. 

Pasting from One Cast Position to Another — To quickly copy a piece of artwork, go to 
the Cast, select and Copy the artwork, select an empty position in the Cast, then Paste. (If you 
need to, you can Paste into several empty positions in the Cast.) The artwork appears on a new 

easel in the Paint window. This is possible because the Cast is just a different way of viewing the 

Paint window. 

Once you have copied the artwork, go into the Paint window and modify each of the pieces to 

create the sequence. Don’ forget that you can use Rotate, Slant, Distort and Perspective to modify 

each piece. 

How to Combine Several Pieces of Art into One Full-Screen 
Background 
Use this procedure if the background art on the Stage is composed of two or more pieces, and you 

would like to combine them into one piece. (Since it is cumbersome to create a full-screen 

background in Paint, you can create several small pieces, then use this procedure to make one full- 

screen background.) 

This procedure uses the standard Macintosh function Command-Shift-3 to save any screen to disk, 
then imports that screen using Art Grabber+: 

1. Arrange the art on the Stage as you want it captured. 

2. Choose Stage from the Window menu to remove all of the windows and show the artwork 

full-screen. 

3. Press Command-Shift-3. This saves the entire screen to disk as Screen 0. (If a file named 

Screen 0 already exists, the new file is named Screen 1.) | 

4. Choose Art Grabber+ from the Apple menu. 

5. Choose Open from the Grabber menu at the right end of the menu bar. Open Screen 0. (If 

_ you have a hard disk, look in the root directory or the VideoWorks folder for this file.) 

6. Now select Screen 0 by dragging diagonally across it with the crosshairs. Then choose 

Copy. 

7. Close Art Grabber+. Click on an empty position in the Cast and choose Paste. 

The full-screen artwork is now saved as a castmember in the Cast. You can drag it out onto the 

Stage to use as a background. The new picture is a single picture. But it's also probably larger 

than the original separate elements. 
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Advanced Animation Techniques 

How to Create Scrolling Text 
Scrolling Text is a powerful animation effect that is used a lot in television and film. You can 
easily create scrolling text in VideoWorks as follows: 

1. Create the text as artwork in the Paint window (using text from the Text window generally 
scrolls too slowly). Use the largest Fonts that you have available, and remember that you 
can choose from many different Styles and Sizes, as well as using special Inks. 

2... Usesthe procedure described under "How to Make Artwork Move Smoothly Between Two 
Points" in the “How to Animate" section. 

Note that Tutorial #7 - Point Of Purchase Display has several examples of scrolling text, illustra- 
ting different techniques. 

How to Create an Animation that Draws Out Letters 
This technique lets you create a movie that draws out pen strokes before your very eyes. You can 
use it to show your signature (or any cursive handwriting) being drawn out smoothly, stroke-by- 
stroke, exactly as you have signed it. 

1. Draw a large dot in Paint. (This will be the tip of your writing pen, so its size will determine 
the thickness of the stroke. You can even put a drop shadow on this dot, to make the word 
have a drop shadow.) 

2. Choose No Erase and Matte and turn up the speed to maximum. 

3. Draw your message using Real-Time Recording without releasing the mouse button until the 
very end of each stroke. By stroke, we mean each time you lift your pen. The word "hat" 
would be two strokes — the second stroke is needed to cross the "t". Each stroke is 
automatically drawn in a separate channel. 

When you play back this movie, it draws out your name exactly as you entered it, from beginning 
to end. (You need a fast frame rate for a solid line — a slow frame rate will generate a dotted line.) 

If you can't afford using so many channels, you can put all of the words in one channel, but it is 
tricky. Any blank cell will erase the previous No-Erase text from the Stage. 

This technique can be good in a presentation, for it generates suspense as the word is being drawn 
out and slowly becomes recognized. 

Speeding Up or Slow Down a Sequence 
To speed up (or slow down) an isolated sequence in the middle of a movies, remember that you can 
add a Tempo setting in the Score. If that doesn't give you the effect you want, you can also adjust 
the number of frames with the Delete Frame and Insert Frame commands. 

In some cases, to make a less-abrupt change, it is helpful to insert or delete every other (or every 
third) frame. If the action is of a single castmember moving on the Stage, you can use In- 
Between to smooth the transition. You can also use Delete Frame and Insert Frame to create or 
remove a Slight pause in the animation. 
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How to Switch a Moving Piece of Art 
You can take any sequence of art and replace it with any single castmember. This is useful, for 
instance, when you have artwork moving around on the Stage and you want another piece of 
artwork to move along exactly the same path. Copy & paste the original sequence before you do 
the steps below. 

1. Open the Score and select the sequence of art you want to replace by dragging across it. 

2. Click on the new castmember in the Cast that you want to appear on the Stage and choose 
Switch Castmember from the Edit menu. 

The sequence that you selected is now gone and the new castmember is in its place, moving along 
the same path the old castmember had. 

Inserting Many Blank Frames in the Middle of the Score 
Using this procedure, you can insert a hundred or more blank cells into the middle of a movie in 
one stroke, to give you room to add an entire sequence. 

1. Open the Score and move past the right end of the movie, out where there are empty cells. 

2. Drag the pointer across the frame numbers to select as many empty frames as you want to 
insert. Choose Copy. 7 

3. Move the pointer to the middle of the movie where you want to insert these empty cells. 
Select an insertion pointer (blinking cursor) by clicking on the frame number at the top of the 
Score. 

4. Choose Paste. 

The empty cells are inserted at the selected frame, pushing the existing cells out to the right. This 
method does not paste over any existing cells. 

Accentuating a Motion 
Artwork has implicit registration. If you want to accentuate a motion or re-locate an object on 
Stage, you can do so by altering the registration of that artwork with the Registration Point tool 
in the Paint window. 

For example, to make a frog jump a little bit higher in its five-frame sequence, you could open up 
the Paint window and change the registration point of the middle of the five pieces of art. If you 
move the registration point down, that would become the new center of motion, and the frog 
would jump higher on the Stage. 
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Advanced Sound 

Adding 

Sampled Sounds ("Real" Sounds) 
With special hardware, you can use a microphone to record any sound and store it on a Macintosh 
disk for use in VideoWorks. This kind of sound is uncanny in its realism-you can record the actual 
sound of your own voice, or a door-slam, or any sound effect you can get on tape or into a 
microphone. When you play it back in VideoWorks, it sounds very realistic, like the original 
sound. Someone else could even recognize that this is your voice. (Macintalk, in comparison, 
sounds like a computer speaking.) 

Keep in mind, however, that digitized sounds take a lot of memory, so you can only get a few 
seconds for any given sound. The better the quality, the more space it takes up. 

The software required to bring the sound into VideoWorks is called Sound-to-Video. This will 
be on one disk which is part of the M.U.D. II (MacroMind Utility Disk) series of utility disks, 
which will be available in the Fall of 1987. 

The Sound-to-Video program takes the digitized sound file produced by the Impulse MacNifty 
Sound Digitizer and let's you add it to the VideoWorks Sounds file. This sound shows up as a 
new menu item in the Sound menu called "Sampled Sounds". You can add up to eight sampled 
sounds to the menu (each one up to 32K in size) in one VideoWorks Sound file. For more 

information, write: 

Impulse Sound Digitizer 
Kette Group Inc. : 
13895 Industrial Park Blvd 
Minneapolis, MN 55441 

or call: 800-328-0184 

MusicWorks to VideoWorks 

MusicWork produces synthesize sound. This kind of sound does not take up as much memory as 
sampled sound. You use the Music-to- Video program to move a melody from MusicWorks to 
the Sound menu in VideoWorks. This program will be available from us later in 1987 as part of 
our M.U.D. II series of utility products. You can add up to four new menus in the Sound menu 
with 16 melody lines each. 

Color 

If you are fortunate enough to be the owner of a Macintosh II, you can include color in your 
animations. You can add colors to artwork in the Paint window and to QuickDraw shapes on the 
Stage. 

The Color command is dimmed in VideoWorks unless you have a color Macintosh — the 
Macintosh II with a color card and monitor. To set up for color, go to the Control Panel in the 
Apple @ menu, select the Monitor icon, then select either 16 or 256 colors. (You can do this 
while you're in VideoWorks.) If you leave the Color window open, you can see the colors change 
immediately. 

Selecting Colors in the Color Window 
When you choose Color from the Window menu, a color palette appears (shown below in black 
and white). You then click on the foreground/background indicator to choose one or other, then 
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click in the color palette to choose a color. If you pull down the Draw menu, you will see the 

colored patterns available to you. 

Note: Be aware of which window is in front. When clicking 

a color in the color palette, it can have either of two effects. The color 

applies to Paint tools if the Paint window is in front. If any other 

window is in front, the color applies to QuickDraw shapes selected on 

the Stage or in the Score. 

Some of the paint tools work in color: the Pencil, brushes, Paint Bucket and filled shapes. 

Transitions and some paint tools, notably Lasso and Selection Box (marquee) are disabled when 

using color — they will be coming in later versions. : 

Foreground/background indicator Color Palette 

Re-size "handle" 

Note: You can resize the Color window. This is not readily 

apparent, since it has no scroll bars or resize box. You have to first 

bring the color window to the front by clicking on the title bar. Then 

grab the lower right corner of the window and drag it larger or smaller. 

Using Color Inks | | 

All of the inks fall into two categories, regular inks and color inks: 

Regular inks: Copy, Matte, Or, Xor, Bic, NotCopy, NotOr, NotXor, NotBic, Mask. 

Color inks: Average, Minimum, Maximum, Add, Add Pin, Subtract, Subtract Pin. 

All of the regular inks work with color like they do with black and white, with more effect on the 

pattern than the color. The color inks affect color. As is true of applying colors, you can apply 

color inks to either the Paint window or a selection on the Stage or in the Score (either bitmap or 

QuickDraw). To create color text, use the Paint window, not in the Text window. 

Average is good for mixing colors to get a watercolor affect. Each of the red, green and blue 

components is averaged separately. That is, the red component of the color you are applying is 

averaged with the red component of the color that is already there. The same goes for green and 

blue. 

Minimum is good for colorizing black and white artwork. All of the white areas will be colored 

while the black areas will be left alone. 

Maximum is also good for colorizing black and white artwork. All of the black areas will be 

colors while the white areas will be left alone. 

Add is good for making colors lighter, but at some point they wrap around to darker colors. 

Experiment to see this effect. — 
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Add Pin is better for making colors lighter, because the colors go to white as a maximum. 
("Pin" means the value "pins out" at the highest value and does not wrap around to darker colors.) 

Subtract is good for making colors darker, but at some point they wrap around to lighter colors. 
Again, experiment to see this effect. 

Subtract Pin is better for making colors darker, because the colors go to black as a minimum. 
("Pin" means the value "pins out" at the lowest value and does not wrap around to lighter colors.) 

Transparent is good for making artwork appear transparent. This is good for doing a "pseudo- 
matte" where anything white in the image lets the background shine through. 

Memory Considerations When Using Color 
When you create a bitmap in VideoWorks either with the New Easel tool in Paint or by pasting 
into the Cast, that bitmap will be converted automatically to the current color resolution. (The 
color resolution is set in the Monitor icon of the Control Panel.) This means that bit-map 
artwork you make while using 256 colors (8 bits of color resolution) takes 8 times as much 
memory (and disk space) as its black and white equivalent. It also means that if you switch to a 
different color resolution, the artwork does not change its resolution. It's only when raped is 
created that the current resolution is set. 

Display Monitors 
We have tested VideoWorks and found it to work with the following display monitors (as of June 
1987): 

NEC Multi-Sync, Sipuridac Spectrum and Apple color monitor 

We will make every effort to test VideoWorks with new monitors as they become available. 

Analyzing an Animation. 

How to Dissect an Animation 
Here are some ideas about how to analyze an animation: 

1. Double-click on the artwork to open up the Paint window and make that piece of art come to 
_ the front. Look in the Score to see which castmember number it is and what ink is being 

applied. Inks often give clues to how tricks are being done. Find the artwork in the Cast by 
its castmember number. 

2. Look at foreground priorities in the Score, see how the artwork fits into a sequence, and how 
it moves in that channel. 

3. Look at the extended display in the Score (the fourth Display Button) for more details. 

4. Double-click on the artwork on the Stage to open the Paint window and bring the art to the 
front. Use Fatbits to magnify it. 

5. Look in the Score to see whether QuickDraw shapes are being used (use the third button, the 
Castmember button), and if so, which pattern and ink is applied to it. 
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what can | do to improve my animations? 
Try these suggestions 

Give your background three-dimensional perspective rather than two-dimensional. 

Create sequences of art rather than just moving the same piece of art from here to there. 

Try thinking of yourself as a cameraman with ability to: 
¢ Start wide-angle, showing the entire scene. 
e And then zoom in to inspect minute detail. 

Also think of yourself with the ability to fly or move absolutely anywhere. Consider how 
you might show someone driving their fast T-Bird convertible using these camera techniques. 

¢ Panning — (The camera stands on a tripod on the ground.) The car approaches the 
- camera, speeds by and off into the sunset. 

¢ Trucking — (The camera is mounted in a truck travelling along with the moving car.) 
Unlike panning, the car stays the same relative size, but the background races past. 

¢ Craning — (The camera moves up off the ground and swings in any direction.) The car 
can be seen from above or from any angle. 

Make your picture tell a story. Give it a beginning (boy meets girl), middle (they get to know 
each other), and ending (they get married). | 

Notice that animations fall into {wo classes: 

« Non-sequenced animations — Each object moves about on-Stage but does not change 
shape. For instance, a person driving a car does not move his head, arms or eyes. This is 
the easiest kind of animation — beginners at animation sometimes do not get beyond. 

« | Sequenced animations — Objects have moving parts. For example, the person driving 
a car has arms that move, a head that turns, or eyes that blink. — 
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This part of the manual is the directory of all commands and windows in 

VideoWorks II. It is divided into two sections, Overview Reference followed by 

VideoWorks Reference. These two sections are organized according to the way you 

view VIDEOWORKS II — by menus and windows. The explanations here are brief. 

You should refer to the previous part "How to Animate" for more in-depth 

description. : 
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199 

199 

200 
200 
200 
200 
201 
201 
201 
201 
201 
201 
201 
201 

202 
202 
202 
202 
202 
203 
203 
203 
203 
203 

204 
204 
204 
204 
204 
204 
204 
205 

206 

207 

208 

208 

208 

209 

Overview Menus 

The @ Apple Menu 

The File Menu (Overview) 
To VideoWorks 

New 

Open... 
Save 
Save AS... 
Revert 

Launch Editor 

Return to Overview 
Page Setup... 
Print... 

Quit 

The Edit Menu (Overview) 
Undo 
Cut Overview 
Copy Overview 
Paste Overview 

Clear Overview 
Select All 
Get Info... 
Quick Create... 
Gather Documents... 

The Control Menu (Overview) 
Play 
Stop 
Rewind 
Step 
Back Step 
Sound Is On 
Preferences... 

The Sound Menu (Overview) 

The Window Menu (Overview) 

Overview Windows 

The Stage 

The Panel 

The Overview Window 

VideoWorks Reference 

211 

212 
212 
213 
213 
215 

216 
216 
216 
216 

VideoWorks Menus 

The @ Apple Menu 
About VideoWorks II... 
Help... 
Art Grabber+ 
Scrapbook 

The File Menu (VideoWorks) 
To Overview 
New 
Open... 
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216 Save 

217 Save As... 
217 Revert 
oa Page Setup... 
217 Print... 
217 Quit 

218 The Edit Menu (VideoWorks) 

218 ~ Undo 
219 Cut, Copy 
220 Paste 
220 Paste Relative 
220 Clear 
221 Insert Frame 

221 Delete Frame 

222 Switch Castmember 
222 In-Between 
222 Bum Scene 
223 Blank From Stage 
225 Place On Stage 
223 Set Transition... 
223 Set Tempo... 
224 Reverse Sequence 
224 Normal Size 

225 The Control Menu (VideoWorks) 

220 Play, Stop, Rewind, Step, Back Step 

226 Repeat Selection, Repeat All 
226 Left, Right, Up, Down 
22) Short Menus / Long Menus 
22] Preferences... 

228 The Sound Menu (VideoWorks) 

229 The Window Menu (VideoWorks) 

230 The Text Menu (VideoWorks) 

230 Font, Size, Style 
230 Left, Center, Right 

231 The Draw Menu (VideoWorks) 

231 Line Widths 
231 Fill Patterns 

232 The Ink Menu (VideoWorks) 

234 Color Inks 

235 VideoWorks Windows 

235 Stage 

236 Panel 

238 Cast 

240 Score 

246 Paint Window 

251 Text Window 

252 Tweak 

253 Color Window 

254 VideoWorks Hidden Features 

254 Film Loop 

254 Constrain . 
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255 Hints, Tips and Tricks 
259 Speed, Memory and Disk Space 

261 Animation Techniques 

262 Artwork Techniques © 

263 For Advanced Users 

264 Frequently Asked Questions 

265 Shortcuts 

269 Sound Files 

271 Glossary 

277 Suggested Reading 

279 Biographies & Credits 

281 Index 

Hierarchical Menus — ViIDEOWORKS II is designed to take advantage of the 
Macintosh System 4.1 hierarchical menus. The Sound menu takes advantage of 
this. The exact differences are described under the Sound menu. There is no 
difference in function between System 4.1 and earlier systems. System 4.1 is 
merely more convenient to use. : 

Command Key Shortcuts — Command key shortcuts are shown to the right in - 
the menus. For example, the shortcut for Open is $8-O. 

Dialog Boxes Shortcuts. When a dialog box appears, there are several 
shortcuts you can use. 

Open — When you choose Open, the Open dialog box appears. Pressing a 
letter 
key selects the document starting with that letter. This works going up or 
down the list. 
Yes/No/Cancel — when a dialog box appears that says "Do you want to 
Save Changes" you can simply press the first letter of each command: 
Y for (Yes), N for (No) and C for (Cancel). 
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Overview Reference 
This section of the manual covers the Overview part of VideoWorks II. (The VideoWorks 
Reference follows this part.) 

This reference contains all Overview features, divided into two sections: 

e Overview Menus 

e Overview Windows 

Notice this reference is organized according to the way you view Overview — by menus and 
windows rather than how you use it. The explanations here are brief. You should refer to "How 
to Animate” for a more in-depth description. The basic concepts are also covered in the Tutorials. 

3 

Overview Menus 

This section describes the menus available in the Overview part of VIDEOWORKS II. The @ Apple 
menu is the same in both VideoWorks and Overview. 

The @ Apple Menu (Overview) 

The Apple menu is indicated by the @ 
symbol at the left end of the menu 
bar. This menu is identical in both 

Alarm Clock _ VideoWorks and Overview-it Is 
art Grabber+™ described fully in the VideoWorks 

Reference which follows. 
Chooser 

Control Panel 

Scrapbook 

The menu items described there are About VideoWorks, Help, Art Grabber+ and the Scrapbook. 

The other menu items are the standard Macintosh desk accessories, described in your Macintosh 

manual. ; 

| 

199 EE ikk ike ike ike (be ike (ek ike ke (ee jkF jkb ike (bk (kk (ke jhe it Reference: Overview Menus 



Overview 

The File menu contains commands for 
creating, opening, saving and printing 
Overview documents. It also lets you 
launch other programs. 

You can have only one Overview doc- 
Save As... ument open at a time. 
Revert 

Launch Editor 

Return to Overview 

To VideoWorks 

The "To VideoWorks" command closes the Overview document and opens VideoWorks. 

This command is to be distinguished from selecting a VideoWorks document in the Overview 
window and choosing Launch Editor. This second method gets you into VideoWorks, while — 
keeping the current Overview document open. 

For more information on the To VideoWorks command, see the "Moving Between Overview and 
VideoWorks" section of "How to Animate". 

New 

The New command opens a new Overview document. The document opens Untitled. It does not 
need a name until you Save or Quit — at that time you will be asked to type in a name for this 
document. 

Overview can handle only one document at a time, so if a document is already open when you 
choose New, a dialog box is displayed, giving you the opportunity to save or discard the latest 
changes. 

Open... 

The Open command lets you open an existing VideoWorks or Overview document from disk. 
When you choose Open, a dialog box appears. Click the buttons to choose which type of 
document you want to display. Then select the document and click Open. 

If you want a document from a different drive, click Drive. If you want to insert a new disk, first 
click Eject to remove the current disk. To return to Overview without opening a document, click 
Cancel. Command key shortcut: $§-O 
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Save } 

The Save command saves the current document to disk. The current version replaces any previous 

version on disk. Once a document has been saved, you can quit Overview without losing that 

document. 

Save AS... 

The Save As command allows you save the current document to disk under a different name, or 

under the same name but to another folder or drive. 

Revert 

The Revert command returns the last saved version of the current document to the display. It does 

this by discarding the currently displayed version and opening the one from disk. 

Launch Editor 

The Launch Editor command launches VideoWorks, MacPaint, MacDraw, or the Glue Viewer, or 

another level of Overview. You use it by clicking on the document in the Overview window that 

you want to launch, and choosing Launch Editor. When you quit that application, you will be 

returned to the current Overview document, just as you left it. For a better description of this 

process, refer to "Moving Between VideoWorks and Overview" at the end of the "Working with 

Overview" part of "How to Animate." 

Return to Overview 

The "Return to Overview" command is used to return you to Overview when you have launched an 

Overview document from Overview. For a better description of this process, see “Moving 

Between Overview and VideoWorks" at the end of the "Working with Overview" part of "How to 

Animate." ie 

Page Setup... 

The Page Setup command offers options for determining how a page is to be printed. You are 

offered different page sizes and other options depending on your printer. The Apple LaserWriter 

also offers reduction/enlargement, smoothing, and font substitution. 

Print... 

The Print command lets you print slides of your presentation. You can print the first slide of each 

column or any range of columns, at full size, 50% and 25%. You can also print the arrangement 

of icons as it appears in the Overview window. With each printout you can include the name of 

the document, the date, and the frame number. For more details, see "Printing in Overview" in 

"How to Animate." 

Quit 
Choosing the Quit command exits Overview and returns you to the desktop. Use this command 

when you are through using Overview. The Clipboard is saved when you quit, and its contents 

can be used by another program. If you have not saved the most recent changes to the current 

document when you choose Quit, Overview will ask you if you want to save those changes. 
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The Edit Menu (Overview) 

The Edit menu contains commands for 
i editing the Overview presentation. 
Cut Overview 

Copy Overview 

Paste Overview 

Clear Overview 

Select All 

Get Info... 

Quick Create... 
Gather Documents... 

Undo : 

Undo reverses your last action. Since it works only on your /ast action, you must use it right 
after a mistake, before making any other change to the animation. Undo works with most editing 
operations, such as Cut Overview. It does not work with File commands, such as Open. 
Command key shortcut: $§-Z 

Cut Overview 

The Cut Overview command removes the selected icons in the Overview window from their 
current location and places them on the Clipboard. You can then use Paste to move them to 
another location. Use Cut Overview and Paste Overview to move art (rather than to copy it). 

To cut artwork from the Stage, open the Score, select the cells and choose Cut Overview. Cut 
Overview does not operate directly on selected artwork on the Stage. To clear artwork from the 
Stage, use Blank From Stage. Command key shortcut: $§-X 

Copy Overview 

The Copy Overview command makes a copy of the selected icons in the Overview window and 
places that copy on the Clipboard. Unlike the Cut Overview command, Copy Overview does not 
remove the selected icons from their original location. Use Copy and Paste when you want to 
duplicate icons, rather than move them. Command key shortcut: $-C 

Paste Overview 

The Paste Overview command is used to copy the icons currently on the Clipboard into the 
currently selected location in the Overview window. You specify where you want the Clipboard 
contents to be pasted by clicking with the pointer before choosing Paste Overview. You use Paste 
Overview in conjunction with Cut Overview and Copy Overview, described above. Command key 
shortcut: $§-V 
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Overview 

Clear Overview 
Clear Overview removes and discards the selected icons from the Overview window (without 

saving them on the Clipboard). Clear is used when you have no further use for the icons, and 

when you do not want to affect the contents of the Clipboard. 

Select All 

The Select All command selects all of the icons in the Overview window. 

Get Info... 

The Get Info command lets you set how the current document is displayed in the presentation. Get 

Info works with VideoWorks, MacPaint, Glue and PICT documents, and Transitions. For more 

details, see "Working with Overview" in "How to Animate." Command key shortcut: $41 

Quick Create... 

The Quick Create command takes all documents from a folder and places them in the Overview 

window, arranged in one long row. To use this command, first choose Quick Create. When the 

dialog box appears, select any document (in any folder) and click Open. All of the usable 

documents in that folder will be opened and placed in the Overview window. This includes 

MacPaint, PICT, Glue, VideoWorks and Glue documents. This is a quick way of moving a lot of 

documents into the presentation, for watching a long list of movies. 

Gather Documents... 

The Gather Documents command moves all documents in the current presentation into the same 

folder. This is useful if you use a hard disk and your documents are scattered around in different 

folders. You would use this command if you wanted to gather the documents together so that you 

could, for example, make a copy of the presentation so that you could run it on another system. 

(Remember that to copy an entire presentation, it's not enough to copy the Overview document 

itself — you must also copy the documents along with it.) For example, for the presentation 

below, titled "BigShow," the documents "Big Sky, "College," "Indy", etc. would all be moved 

into the folder along with "BigShow." 

BigShow Overview 
_————— EE 
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The Control Menu (Overview) 

204 

Control 
The Control menu contains commands that 

Play control how a presentation plays back. These 
Stop commands do not modify the presentation 
Rewind — itself. 
Step 

Back Step 

“Sound Is On 

“Preferences... 

The following five commands appear in this menu and also in the Panel as buttons. 

Note: These five commands are further described in the "Controlling 
an Overview Document" in the "Working with Overview" part of "How 
to Animate." That section describes their other keyboard equivalents. 

Play 
Play starts the presentation. The Command key equivalent is #6-Q. If you hold the Shift key 
down when you hit Play, the Overview window closes and the presentation begins. 

Stop 
Stop halts the presentation. The Command key equivalent is #§-W. 

Rewind 3 

Rewind winds the presentation back to the start. The Command key equivalent is $§-R. 

Step 
Step advances the presentation to the next column. Step is further described in "Controlling an 
Overview Document" in "How to Animate." The Command key equivalent is $8-S. 

Back Step | 
Back Step steps the presentation backward one column. The Command key equivalent is $§-D. 

Sound Is On 

This command turns the sound on and off. 
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Overview 

Preferences... 

The Preferences command displays a dialog box which gives you the following choices. 

Note: Preferences are saved only when you Quit to the Finder. 

Coordinates for the Stage Window (This option is of interest if you develop presentations 
ona large screen destined to be played on a smaller screen, or if you simply want to change the 
Stage size.) When you create a document, the Stage is automatically made to fit full-screen for the 
monitor connected. At any time you can change the Stage size. You might do this if you were 
developing a presentation on a large-screen monitor and you wanted to fit it onto a Macintosh Plus 
screen. 

In this case, the screen size is important, because if you were to take a presentation that fills up a 
13" monitor and play it back on a 9" MacPlus screen, the right and lower edges of the presentation 
would not be visible. 

You can change the values for the four edges of the Stage at any time by: 

¢ Clicking on the MacPlus or Mac II buttons. 

¢ Typing numbers into the four boxes (Top, Left, Bottom, Right). The values are the number 
of pixels from the top and left edges of the screen. 

The MacPlus size is the same standard size as the Macintosh SE, Macintosh 512E and 512. The 
Mac II size applies to both the color and the black & white Apple monitors. 

Note: If you want to become more familiar with different Stage sizes, 
just experiment. For fun, type in numbers 50, 50, 300, 500. You'll 
find that the Stage has a title bar! 

Freeze Stage Window at Current Size — (This option applies to you if you have a screen 
size larger than the standard MacPlus.) If you select the Freeze Stage Window box, the Stage is 
frozen at the (large) size you currently see it displayed, even if you open a document that was 
created on a smaller screen. Let's explain this. 

The Stage size is stored with each document. If you open a document that was created on a smaller 
screen, and you have not checked Freeze Stage Window, the document will be displayed with its 
original, small Stage size. If you check Freeze Stage Window, the Stage size oe not change 
when you open the document. 

As you would expect, when you save a document, it is saved with its currently displayed Stage 
SIZe. 

Creator Type for MacPaint, MacDraw — You can specify which document you launch into 
from a MacPaint or PICT (MacDraw) document. For example, you could launch into 
GraphicWorks instead of MacPaint, or MacDraft instead of MacDraw. To determine the creator 
type use ResEdit (a Resource Editor). Do a Get Info in ResEdit on the application you want to 
use. 2 

Autosave of Overview Documents automatically saves the current Overview document each 
time you launch VideoWorks. Choosing this option makes it quicker to go from Overview to 
VideoWorks, since the dialog box no longer appears asking you if you want to save changes. 
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The Sound Menu (Overview) 

The Sound menu contains dozens of 
sounds you can add to your presenta. 
tion. This menu is identical to the 
Sound menu in VideoWorks. 

1 - Basic 

2 - Explosions 

3 - Weapons 

4 - Instruments 

3-1 Birdt 

6 - Space 9-2 Bird2 

? - Old Music 5-3 Rivet 
6 - New Music 9-4 Meow 

9 - Business 3-9 Bubblel 

A - Sampled 1 5-6 Bubble? 

F - Macintalk 

Sounds come in several basic categories: 

e Music (Old Music, New Music, Instruments) 

e Effects (Basic, Explosions, Weapons, Nature, Space) 

e Presentations (Business) 

¢ Computer speech (Macintalk) 

¢ Real sounds (Sampled sounds) 

In Overview, you can assign sounds to slides by dragging out the Sound icon: 3) -_ 

System 4.1 vs. Earlier Systems; We have provided System 4.1 with VIDEOWORKS II in 
order to take advantage of its hierarchical menus. System 4.1 is simply more convenient to use — 
there is no loss of function when using an earlier system. For an explanation describing how to 
use the earlier submenus, see the Sound menu description later in "VideoWorks Reference.” 

For more information on: See “How to Animate”: 

* SOQNGS. So i ee ie .."How to Add Sound" in "Working with Overview" 
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Overview 

The Window Menu (Overview) 

The following is a description of how the 
commands in this menu open and close 
windows. The windows themselves are 
described in detail in "Windows (Overview),” 
the next section of this manual. 

Stage | 

“Panel 32 

/“Ouerviem #3 

Stage, Panel and Overview are the three windows in Overview. When one of these windows is 
open, a check mark appears next to it in the Window menu. The item that is underlined in the 
menu is the currently active window. 

To illustrate how these commands work, let's use the Overview command as an example. 
Choosing the Overview command changes the window to its next state in a cycle. 

¢ If the Overview window is open but inactive, choosing the Overview command makes it active. 

¢ If the Overview window is active, choosing the Overview command closes it. 

e If the Overview window is closed, choosing the Overview command opens it. 
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Overview Windows 

Overview has three windows. This section describes each briefly. 

° Stage | 

e Panel 

e Overview window 

The Stage (Overview) 

The Stage is the full-screen window where you view the Overview presentation. All other 
windows (Panel, Cast, etc.) appear in front of the Stage. To get a full, uncluttered view of the 
presentation, choose the Stage command at the Window menu. It clears the screen of all the other 
windows and the menu bar. Selecting the Stage command again returns all previously displayed 
windows to view. The Stage in Overview is the same as the Stage in VideoWorks. 

The shortcut for the Stage command is $§-1. When you are creating an animation, use $£-1 to 
quickly toggle back and forth between the uncluttered Stage and the working windows. When the 
Stage is cleared of other windows, you can add the Panel and Overview window one at a time 
simply by choosing them from the Window menu. 

The menu bar is active even when it is invisible, when you are watching a movie. You can move 
the (invisible) pointer to the top of the screen and press the mouse button, and the menus will 
actually pull down. (Try it!) 

The Panel (Overview) 

The Panel has six controls on it. These can also be accessed by commands at the Window menu. 

Play starts the presentation. 

Stop halts the Overview document. 

Rewind winds the presentation back to the start. If the presentation was running, it stops. 

Step advances the presentation to the next column. Step is further described in "Controlling an 
Overview Document" in "How to Animate." 

Back Step steps the presentation backward one column at a time. 

Loop causes the presentation to repeat continuously, when it reaches the end, it continues with - 

frame 1. Loop is in effect when the button is black. Clicking the Loop button alternately 
activates and deactivates Loop. (This is known as a toggle.) 

You can move the Panel around on the Stage by dragging it on the gray border. Just place the 
mouse pointer anywhere on it besides the buttons and drag. To close or open the Panel, choose 
Panel at the Window menu. 
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Overview 

The Overview Window (Overview) 

The Overview window displays the current Overview document. An Overview document can be 
any presentation including slides, annotation, clip animation, movies, transitions and sound. The 
name you give the Overview document appears in the Title bar. 

An Overview document remains very small, taking up very littlke memory (typically 1K), even for 
very large presentations. That's because it is a collection of document names. When you play an 
Overview document, it opens up the documents that are shown in the Overview window. 

You can drag the Overview window around on the Stage by its title bar. 
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VideoWorks 

VideoWorks Reference 
This section of the manual covers only the VideoWorks part of VideoWorks IT. (The Overview 
Reference precedes this section.) 

This reference contains all VideoWorks features, divided into the following three sections: 

¢ VideoWorks Menus | 

e VideoWorks Windows 

e VideoWorks Hidden Features 

This reference is organized according to the way you view VideoWorks rather than how you use it. 

The explanations here are brief. You should refer to "How to Animate" for a more in-depth 

description. The basic concepts are also covered in the Tutorials. 

VideoWorks Menus 

This section describes the menus available in the VideoWorks part of VIDEOWoRKS II. The @ 

Apple menu is the same in both VideoWorks and Overview. 

Long Menus / Short Menus — VideoWorks has long and short menus. The short menus are 

for beginners. For further description, refer to Long Menus / Short Menus in the Control menu. 

Hierarchical Menus — VideoWorks was designed to take advantage of the Macintosh 

System 4.1 hierarchical menus. These menus are more convenient to use with System 4.1. These 

menus are the only differences between System 4.1 and earlier systems. 

The Sound and Text menus make use of hierarchical menus. If you are using a system prior to 

System 4.1 (such as System 3.2), you will notice that the Text menu does not appear. In its place 

are two menus Font and Style, which operate as any ordinary menu — that is: 

¢ Text menu appears if you are using System 4.1 

¢ Font menu and Style menu appear if you are using System 3.2 

The Sound menu differences are described under "Sound Menu” later in this section. 
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VideoWorks 

The @ Apple Menu (VideoWorks) 

212 Reference: VideoWorks Menus 

The Apple menu is indicated by the @ 
symbol at the left end of the menu bar. 

, The menu items we will describe here 
Alarm Clock are About VideoWorks, Help, Art 
Art Grabber+™ Grabber+ and the Scrapbook. The other 
Chooser menu items are the standard Macintosh 

Control Panel desk accessories, described in your 
Scrapbook Macintosh manual. 

About VideoWorks IL... 

About VIDEOWoRKS II displays a message indicating the amount of memory used by the Cast, 
Scene and Sound — the three components of any VideoWorks animation. It also indicates the 
amount of free memory (FreeMem) and the size of the file on disk (File Size). If you are running 
short of memory, these values, especially FreeMem, are useful for diagnosing a movie to evaluate 
whether to break it down into smaller parts or get more memory. To remove the window, just 
click the mouse button. 

The values are in bytes. For example, Cast: 50176 means the Cast takes up 50,176 bytes of 
memory. 

To convert bytes to K (kilobytes), divide the number by 1024. Thus, 50176 bytes is 49K (that is 

50176/1024). 

Cast indicates the amount of space taken up by the Cast, including all artwork in Paint, and all 
text in the Text window. 

Scene indicates the amount of space taken up by the action that takes place on the Stage, not 
counting the Cast or Sound, but including QuickDraw shapes. (This also corresponds to the 
amount of space that is freed up when you choose Burn Scene. However, you won't actually 
realize that savings until the next edit, because the scene is saved so you can restore it with Undo.) 

Sound indicates the amount of space taken up by the sounds. This will normally be less than the 
size of your Sounds file, because only the sounds you use are loaded from disk into memory. This 
value is most useful when you are using digitized (sampled) sounds, which tend to take up a lot of 
memory. 

FreeMem indicates the amount of headroom your system has. As you add to an animation, this 
number grows smaller. The Cast, Scene and Sound can grow only by this much before you run 
out of room. Once FreeMem diminishes to zero, the animation cannot grow any further. You can 
work around this memory limitation by stringing shorter movies together in Overview to produce 
one longer movie. 

Notice that FreeMem is unrelated to the amount of free space on your floppy or hard disks. See 
Speed, Memory and Disk Space later in this Reference for an explanation of this. 

File Size indicates the size of the document on disk. This is helpful to use when you're not sure 
how much room on your disk. 

Version Number The About VideoWorks message also displays the version number of your 
copy of VideoWorks. Refer to this version number when calling for technical support. 
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VideoWorks 

Help... 

The Help command displays important and useful procedures, along with a list of shortcuts. 

Art Grabber+ 

Art Grabber+ enables you to bring any art in MacPaint format into VideoWorks for use in movies. 
This art can be from MacPaint or can be from a number of other sources if saved as MacPaint, 
including Graphic Works, FullPaint, SuperPaint, Easy3D, Thunderscan, Mac Vision, other scanners 

and digitizers and any other application that saves in MacPaint format. 

When you choose Art Grabber+ from the Apple menu, a new menu called Grabber+ appears at the 
right end of the menu bar. By choosing Open from this menu, you can access any document in 
MacPaint format from any disk or folder. Then you can select all or any part of that document. by 
dragging the selection rectangle across it and choosing Grab from the Grabber+ menu. Then you 
can paste into Paint or into the Cast. 

You might use Art Grabber+ to grab a picture of a sunset created in GraphicWorks to paste into 
VideoWorks for use as a backdrop in a movie. Or you might grab art from the Art disk that comes 
with the product. You can also use Art Grabber+ to grab any screen shot in virtually any program 
(by first making use of Command-Shift-3 to save the screen to disk). Art Grabber+ also has a 
Clipboard command to let you view the contents of the Clipboard. 

Note that the Art Grabber+ desk accessory is built into the VideoWorks II program and does not ° 
need to be installed in your system file. 

The commands that appear in the Grabber+ menu are described next. 

For more information on: See "How to Animate”: 
e Using Art Grabbert i... cco: ce icececcctecvees "Creating and Importing Artwork" 

Grabber+ 

Open 

ClipBoard 

Grab 

ReOpen 

Show Page 

F. Face Kit 
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VideoWorks 

The Grabber+ Menu 
(Visible at right end of the menu bar only when Art Grabbers has been chosen) 

: Grabber+ 

Open The Grabber+ menu contains commands 
ClipBoard for using Art Grabber+. The Grabber + 

Grab menu appears only when Art Grabber+ 
has been selected from the Apple menu. 
The menu disappears from the menu bar 
when Art Grabber+ is not active. 

ReOpen | 

Show Page 

Open 
The Open command opens any document that is in MacPaint format. You can open a document 
from any folder on any drive. Art Grabber+ can display only one document at a time. 

You can eject the current disk (by clicking Eject), and insert the disk containing the document you 
wish to grab. VideoWorks will prompt you if you need to swap disks. Click the box labeled 
Drive if you need to switch drives. 

- To close Art Grabber+, click the close box — the little box in the upper left corner of the Art 
Grabber+ window. 

Clipboard 
The Clipboard command displays the current contents of the Clipboard, the area used for cut, copy 
and paste. When the Clipboard is being displayed, the name Clipboard appears in the title bar. 
Choosing Clipboard does nothing if the Clipboard is empty or contains text. 

Grab 
Grab instructs Art Grabber+ to copy the contents of the selection rectangle to the Clipboard. 
Equivalently, you can choose Copy from the Edit menu (or use ¢§-C). 

Grab is normally dimmed; to enable it, you must Select an image in Art Grabber+ by dragging the 
crosshairs across the artwork. 

When you drag your selection rectangle to the edge of the Art Grabber+ window, the artwork will 
automatically scroll in the window until you move the rectangle into the window. 

Once a selection has been grabbed, you can select a Paint easel or Cast position and paste the 
artwork. Paste is described later in the Edit commands. You cannot grab text (unless it is bit- 

mapped), nor can you view it on the Clipboard. | 

The Clipboard referred to here is the same Macintosh Clipboard used in other applications. Any 
time you Copy or Cut a graphic image (not text), you can open Art Grabber+ to view that graphic 
image. 

ReOpen 
_ The ReOpen command opens the document most recently opened in Art Grabber+. A common 
use for ReOpen is to return to the original document after viewing the Clipboard. 

Show Page 
Show Page displays the entire document, reduced to fit on the screen. At this point you can move 
the viewing window if you wish by moving the pointer into it and dragging the window. Click 
OK to return to the normal view. 
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VideoWorks 

Scrapbook 
The Scrapbook 1 is a place you can save frequently used artwork, sequences, film EHS and text. The 
Scrapbook is very useful for: | 

¢ Copying artwork and animation from one movie to another 

e Storing artwork and animation for later use 

When storing an animation in the Scrapbook, you must be careful not to change the Cast 
positions of the artwork in the original movie. | 

For more information on: See “How to Animate" 
e Using the Scrapbook : "Creating Artwork" 
¢ How to Move Artwork and | 

Animation Between Movies : "Advanced Animation” | 
¢ How to use the Scrapbook : 

for Temporary Storage "Advanced Animation" 
¢ Important: Storing Sequences ; 

in the Scrapbook "Advanced Animation" 

Scrapbook 
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The File Menu (VideoWorks) 

The File menu contains commands for creating, 
opening, saving and printing VideoWorks documents. 
When speaking of a VideoWorks document, we are 
referring to the VideoWorks (movie) or Overview 
document (animated slide show) that is saved as a file. 

To Overview 

New 

Open... 360 

Save 

Save As... 

| Revert VideoWorks allows only one document to be open at 
a time. 

To Overview 

The To Overview command closes the VideoWorks document and opens Overview. This 
command is further described in "Moving Between Overview and VideoWorks" in "How to 
Animate." | 

New ; 

The New command opens a new VideoWorks document. The document opens untitled. It does 
not need a name until you Save or Quit — at that time you will be asked to type in a name for this 
document. 

VideoWorks can handle only one document at a time, so if a document is already open when you — 
choose New, a dialog box is displayed, giving you the opportunity to save or discard the latest 
changes. | | 

Open... 

The Open command lets you open an existing VideoWorks or Overview document from disk. 
When you choose Open, a dialog box appears. Click a button to choose which type of document 
you want to display. Then select the document and click Open. 

If you want a document from a different drive, click Drive. If you want to insert a new disk, first 
click Eject to remove the current disk. To return to VideoWorks without opening a document, 
click Cancel. 

Save 
The Save command saves the current document to disk. The current version replaces any previous 
version on disk. Once a document has been saved, you can quit VideoWorks without losing that 
document. 
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VideoWorks 

Save As... 

The Save As command allows you save the current document to disk under a different name, or 

under the same name but to another folder or drive. 
| 

The Save As dialog box has an option Save As V1.0, described next. 

Save As VI1.0... 

The Save As V1.0 option allows you to save a document in the earlier VideoWorks 1.0 
format. You can use V1.0 documents with VIDEOWORKS II , but some functions will not 
work, such as sampled sounds, film loops, ASCII text, Macintalk, and Color. 

Note: The original VideoWorks movies are identified by the icon 
shown below (with the numbers 1-2-3), while VIDEOWORKS II 
documents have the icon with the numbers 4-5-6. 

? 

6 

VideoWorks 1.0 VIDEOWORKS II 

Revert 

The Revert command returns the last saved version of the current document to the display. It does 
this by discarding the currently displayed version and opening the one from disk. 

Page Setup... 
The Page Setup command offers options for determining how a page is to be printed. You are 
offered different page sizes, and a choice of vertical or horizontal orientation. The Apple 
LaserWriter also offers reduction/enlargement, smoothing, and font substitution. 

Print... 

The Print command lets you print frames of your animation. You are given a great variety of 
- choices. You can print frames from the movie full-size or reduced and arranged as a storyboard. 
You can print out all of the text or artwork in the Cast. With each printout you can include the 
name of the document, the date, and the frame number. For more details, see "Printing" in "How 
to Animate." 

Quit 
Quit does one of two things: 

¢ If you entered VideoWorks by way of Launch Editor in Overview, choosing Quit closes the 
VideoWorks document and returns you to Overview and the document that was previously 
open. 

e If you entered VideoWorks any other way, choosing the Quit command exits VideoWorks and 
returns you to the desktop. 

Use this command when you are through using VideoWorks. The Clipboard is saved when you 
quit, and its contents can be used by another program. If you have not saved the most recent 
changes to the current document when you choose Quit, VideoWorks will ask you if you want to 
save those changes. 

a 
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The Edit Menu (VideoWorks) 

The Edit menu contains commands 
for editing the Score, Cast, Paint, 
Text and the Stage. 

Insert Frame 

Delete Frame 

Suitch Castmember 

In-Between 

Burn Scene... 

Blank From Stage 

Place On Stage 

Set Transition... 

Set Tempo... 

Reverse Sequence 

Normal Size 

Undo 

Undo reverses your last action. Since it works only on your /ast action, you must use it right 
after a mistake, before making any other change to the animation. 

In Paint, the Undo command works just like it does in MacPaint. In VideoWorks, Undo also 

works with Cut, Copy, Paste, Clear, Burn Scene, Insert Frame, Delete Frame, Step, and Real- 
Time recording. 

The obvious way to use Undo is to correct a mistake. However, there are really two ways to use 
the Undo command: 

e To correct a mistake 

e To alternate between two different versions of artwork or animation 

This second option works because repeatedly choosing Undo toggles back and forth between the 
original and modified versions. You can cleverly alternate between two different versions of 
artwork (in Paint) or animation (on the Stage). For example, if you add a Real-Time animation to 
an existing movie, you can alternately view the movie with and without it, simply by choosing 
Undo prior to watching the movie. Command key shortcut: $§-Z 

In Paint, pressing the tilde (~) key 1s a shortcut for Undo. 
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VideoWorks 

Cut 

The Cut command removes the selected art or sequence of art from its current location and places it 
on the Clipboard. You can then use Paste to move that art or sequence to another location. Use 
Cut and Paste to move art (rather than to copy it). 

Cut appears as Cut Graphic if the Paint window is active, Cut Cast if the Cast is active, Cut 
Score if the Score or Panel is active, and Cut Text if the Text window is active. These correspond 
to the following: 7 

e Cut and Paste artwork within the Paint window | 

e Cut and Paste castmembers to different positions in the Cast 

¢ Cut and Paste groups of cells within the Score 

e Cut and Paste text within the Text window 

What may not be immediately apparent is that you can also: 

¢ Cut artwork from Paint and Paste into the Cast (and vice-versa) - 

° Cut cells from the Score and Paste into the Cast (Film Loop) 

Of course, you can: 

e Cut from Art Grabber+ and Paste to » Paint or Cast . 

Cut and Paste between the Scrapbook and any one of Paint, Cast, Score or Text windows 

Cut always operates on the currently active window. First you click on the window you want to 
cut from (Paint, Cast, Score, Text, Overview, Art Grabber+ or Scrapbook), then select the 
artwork, text or sequence, and finally choose Cut. 

Cut does not operate directly on selected artwork on the Stage (that is, when the Stage is cleared of 
all windows). You can open the Score and cut the cells instead. The Scrapbook is the only 
window where you do not have to select the artwork before using Cut. Command key shortcut: 
9°-x 

- For more information on: See "How to Animate": 
++: Fhe Cubcommand io it. 0 SE ee ee. "Understanding Cut,Copy,Paste and Clear" 

Copy 
The Copy command makes a copy of the selected art or sequence of art and places that copy on the 
Clipboard. Unlike the Cut command, Copy does not remove the selected art or sequence from its 
original location. Use Copy and Paste when you want to duplicate art, rather than move it. 

Copy can be used in all of the same places that Cut can be used. Refer to the list shown earlier 
under Cut. Command key shortcut: $8-C 

For more information on: See "How to Animate”: 
«* THE Goby COMIMANG ie oc nccce vets cto ceca es "Understanding Cut,Copy,Paste and Clear" 
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Paste 
® 

The Paste command copies whatever was put on the Clipboard into the currently selected location. 
To use Paste, first you put something on the Clipboard with Cut or Copy. Then you specify 
where you want the Clipboard contents to be pasted by clicking or dragging with the pointer. 
Then you choose Paste. 

You can use Paste to insert artwork, a sequence of art, or text, as described in the list under the Cut 
command. 3 

Paste always operates on the currently active window. First you click on the window you want to 
paste into (Paint, Cast, Score, Text, Overview, Art Grabber+ or Scrapbook), then select an 
insertion point, and finally choose Paste. If you want to Paste something onto the Stage, open 
the Score and Paste there. Paste does not operate directly on the Stage. 

In the Score, you can control how Paste writes over existing cells by the way you select the cells: 

¢ If you select by clicking an insertion point (a blinking selection point), it pastes the entire 
sequence from the Clipboard over as many existing cells as it needs-to insert the entire 
sequence. 

¢ If you select by dragging the cursor across a block of cells, it pastes only into that specific 
highlighted block of the Score and no further. 

Command key shortcut: $§-V 

For more information on: See "How to Animate": 

« Fhe Paste COMMANAC «... ..ce-ccciees essen ssstenss "Understanding Cut,Copy,Paste and Clear" 

Paste Relative 

The Paste Relative command alters the way Paste works in the Score. With Paste Relative 
selected, when you paste a sequence of art in the Score, the first frame of the new sequence is 
automatically positioned on Stage exactly where the previous sequence stopped. 

For example, if sequence A runs from 10 to 20 of channel 1, when you paste sequence B at the end 
of sequence A (either at 20 or 21), the first frame of B will automatically take the same position 
on the Stage as the last frame of A. The effect is that the two sequences are chained, one after 
another, in one smooth, continuous motion across the Stage. With Paste Relative turned on, you 
can repeatedly paste the same sequence all the way across the Stage. 

Clear 

Clear removes and discards the selected art or sequence of art, without saving it on the Clipboard. 
Clear is used when you have no further use for a particular art or sequence of art, when you do not 
want to affect what is already placed on the Clipboard. : 

Like Cut, Copy and Paste, the Clear command operates on artwork, sequences or text in many _ 
different windows: Paint, Cast, Score, Text , Overview, Art Grabber+ and Scrapbook. 

For more information on: See "How to Animate”: 
¢ The Clear command.............. seeaeeeeeneeeeeess "Understanding Cut,Copy,Paste and Clear" 
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Insert Frame 

Insert Frame adds a frame at the location of the Playback Head, causing the action to stand still for 
one frame. Said differently, it duplicates the frame that currently appears on the Stage. Unlike 
Cut, Copy and Paste, it does not insert at the currently selected cells in the Score. 

The Insert Frame command duplicates the current frame and steps the movie to that new frame. 
With the Score open, you will notice that it inserts a new frame into the animation across all 
channels at the location of the Playback Head. It actually lengthens the movie — adds one more 
frame to its length. 

Insert Frame works pushes the existing frames to the right to make room for the extra frame. It 
inserts somewhat like the insert function in a word processor inserts characters — no information is 
written over. Insert Frame is analogous to splicing in a new frame in a film. 

Use Insert Frame: 
¢ To cause a slight pause in the animation. Since the current frame is copied exactly, the 

animation appears to stop for one frame. 

¢ To make room between two scenes for other action to be added. 

¢ To lengthen a movie. | 
¢ To slow down action in a movie — use Insert Frame every other frame or so. (If a single 
castmember is moving in a channel, then you can use In-Between to smooth out the action.) 

Since Insert Frame inserts a frame across all channels, if you wish to introduce a new castmember 
without affecting the existing animation, you should use the procedure "How to Animate a 
Sequence Frame-by-Frame" instead. Command Key shortcut: g¢6-A 

Delete Frame 

Delete Frame deletes the frame at the location of the Playback Head, across all channels. This is 

the frame that appears on the Stage (the current frame). (Unlike Cut, Copy and Paste, ut does not 

delete the current selection in the Score.) 

Because Delete Frame actually removes a frame from the animation, it is analogous to cutting a 
frame from a film — the animation ends up one frame shorter in total length. 

Use Delete Frame: 

¢ To delete an unwanted scene from a movie (across all 24 channels plus the sound channel). 

¢ To shorten a movie. | 

¢ To speed up a movie — use Delete Frame for every other (or every third) channel. 

Be aware the Delete Frame deletes the all of the channels at the current frame, including the sound 

channel. If you are synchronizing pictures with sound, you may have to lay down a new sound 
track in that region. 

Unlike Blank From Stage, the animation has one one fewer frame after Delete Frame is used. 
Delete Frame and Insert Frame are alike in that they both affect all channels. Delete Frame has 

absolutely no affect on what is stored on the Clipboard. 

Undo works to return a frame deleted with Delete Frame. Command Key shortcut: $§-K 
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Switch Castmember 
The Switch Castmember command replaces the art selected on the Stage or Score with the art 
selected in the Cast. When you use Switch Castmember, the center of the new art registers at the 
center of the old art. 

To use Switch Castmember, select the art you want to replace by clicking it on the Stage. Then 
go to the Cast, select the art you want to put on the stage. Then choose Switch Castmember (or 
double-click on the new castmember). 7 

Shortcut for Switch Castmember command: Double-click on the new castmember in the Cast. 
Command Key shortcut: $8-E 

In-Between 

In-Between lets you specify the starting and ending position of artwork in a sequence and 
automatically fills in the intervening frames. In-Between is used in at least four different ways: 

Fill-right to make an object stand still over time. 

¢ Move an object smoothly across the Stage, such as to give motion to artwork, or to 
scroll text across the page. 

e Make an object grow or shrink, by stretching or shrinking it over time, either in-place 
or as it moves. This works for bit-mapped objects as well as QuickDraw Shapes (but not for 
Text window text). 

e With a Film Loop. See "Adding Film Loops" in "How to Animate.” 

In the second and third instances above, In-Between interpolates position and shape between two 
frames of achannel. In-Between will not paste over occupied cells. | 

For an example of how In-Betweening is used, see The Frogs" tutorial #6. 
Command Key shortcut: $6-G 

For more information on See "How to Animate" 
¢ Using In-Between..............c.ccccceseeeseseeeens How to Create Stationary Artwork in a Movie 

: How to Make Artwork Move Smoothly Between 
Two Points 
How to Make Artwork Stretch as it Moves © 

Burn Scene 

Burn Scene clears the Stage and Score, while preserving the castmembers (in the Cast, Paint and 
Text windows). Use Burn Scene if you want to create a new animation and keep the same 
castmembers. Be careful to use Burn Scene only if there is nothing in the current Score you wish 
to preserve. 
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VideoWorks 

Blank From Stage 

Blank From Stage clears the contents of the selected cells from the Score and the Stage, leaving 

the cells empty. Blank From Stage has no effect on the Cast. 

You use Blank From Stage when the Score is closed and you want to remove artwork from the 

Stage. First you click on the artwork to select it (or use Shift-click to select several pieces), then 

choose Blank From Stage. The artwork is removed from the Stage and Score. Command Key 

shortcut: ¢§-B 

Place On Stage | 

The Place On Stage command lets you place the currently selected castmember on the Stage by 

clicking the cursor. It is equivalent to dragging the castmember out from the Cast. 

Here are two situations where you would use the Place On Stage command: 

¢ If the Cast is closed and you know which castmember is currently selected, use Place On 

Stage to place the castmember on the Stage. This avoids the extra step of opening up the 

Cast. | : ‘ 

¢ If the pointer is already positioned on the Stage exactly where you want to place the 

castmember, press Command-T to place it. 

First you select a castmember, then choose Place On Stage. This changes the pointer into 

crosshairs (shown below) . Move this crosshairs to the point where you want the center of the 

artwork to appear, and click. The currently selected castmember will appear in that position. 

re —Crosshairs for Place on Stage 

Place On Stage is a toggle command. This means that if you choose Place On Stage but decide 

not to place art, just choose Place On Stage a second time — the crosshairs will return to the 

normal pointer. Command key shortcut: d6-T 

For more information on See "How to Animate" 

¢ Howto Place Artwork on the Stage............ Creating Artwork 

¢ Other Ways to Place Artwork................00 Advanced Editing 

Set Transition... 

The Set Transition command lets you determine how one picture changes to the next. The 

transition is added in the sound channel. For example, when you add a dissolve transition to frame 

10, it causes frame 9 to dissolve into frame 10. There are four basic kinds of transitions: wipes, 

pushes, reveals and dissolves. To set a transition, select a single frame in the sound channel and 

choose Set Transition. When the dialog box appears, choose a transition by clicking on the round 

button, then click OK. . 

Set Tempo... 
The Set Tempo command lets you set the tempo at different points of the animation. This allows 

you to make the action run faster in one place and slower in another. To set a tempo, select a 

frame in the sound channel and choose Set Tempo. When the dialog box appears, type in a 

number corresponding to the speed you would set from at the Speed Control in the Panel, then 

click OK. 
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Reverse Sequence 

_The Reverse Sequence command reverses the direction of any selected channels in the Score. Use 
this command if you want to make a sequence go backwards. 

The way you use Reverse Sequence is to open the Score, select the cells you want to reverse, and 
choose Reverse Sequence. The order of those cells in the Score are actually reversed by this 
command. Then when you play the movie, the sequence will play backwards. (For example, if 
you selected cells 1 through 10 of channel 5, cells 10 and 1 get swapped, cells 9 and 2 get 
swapped, and so forth.) 

Normal Size 

The Normal Size command retums the selected artwork to the size it was when originally brought 
onto the Stage. This is helpful if you inadvertently re-size artwork by grabbing one of its handles 
(when you only meant to move the artwork). 

Just select the artwork on the Stage (or select the sequence in the Score) and choose Normal Size 
from the Edit menu. 

Re-sized artwork can slow down the animation. Sometimes you might re-size artwork by such a 
small amount that you don't even notice it, except that the animation slows down when you get to 
a certain frame. The Normal Size command gives you a way to change the artwork back to its 
unscaled size. Command Key shortcut: $§-N 
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The Control Menu (VideoWorks) 

Play kK The Control menu contains commands that 
control how an animation plays back. These 

Stop d : ; 
commands do not modify the animation 

itself. Many of these commands are 
duplicated in the Panel. 

Rewind 

Step 

Back Step 

Repeat Selection 

“Repeat All 

Short Menus 

Preferences... 

The following five commands appear in the Panel as buttons. These are described more 
thoroughly in the Panel section of "Windows" later in this Reference. 

Play 
The Play command starts the animation. Play can also be accessed from the Control menu. 
Command key shortcut : $§-Q : 

Stop 
The Stop command halts the action. Stop can also be accessed from the Control menu. 
Command key shortcut: $§-W 

Rewind 

Rewind winds the animation back to frame 1. If the animation was running, it stops. Rewind can 
also be accessed at the Control menu. Command Key Shortcut: $8-R 

Step 
The Step command advances the animation forward one frame: It has an additional function, when 
recording frame-by-frame, to copy artwork to the next frame. Step is also available at the Control 

menu. Command key shortcut: $6-S 

Back Step 
A Back Step steps the animation backwards one frame at a time. Back Step can also be accessed at 

the Control menu. Command Key Shortcut: $§-D 
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Repeat Selection 

The Repeat Selection command lets you repeat a portion of a movie without having to see the 
entire movie. This comes in handy if you need to work on just one part of a movie. 

To repeat a portion of a movie, open the Score and select the frames to be repeated (in any 
channel). Choose Repeat Selection and play the movie. The Frame Counter in the Panel flashes 
to signify that Repeat Selection is on. 

Notice that a gray bar appears in the Score just above the round marker, to indicate which frames 
are being repeated. 3 

To turn off Repeat Selection, choose Repeat All. 

Repeat Selection 

Ppppbeersss = 

Repeat All 

The Repeat All command turns off the Repeat Selection. (See Repeat Selection above for more 
information.) 

Left, Right, Up, Down 

These commands move the selected artwork one pixel left, right, up and down, respectively. A 
pixel is the smallest increment possible on the display (1/72 of an inch on a standard Macintosh 
display). | 

To use the Left command, first click on the art you want to move (or select an entire sequence in 
the Score) and then choose Left from the Control menu. 

Shortcut: The quickest way to access this command is with the 
Command key ¢§ -— (Command-minus). You can repeatedly press this 
key combination to move the artwork very precisely to the left. As the 
illustration below shows, you can move very easily in the four 
directions. 

Left Riaht 

I EIE] 
» Le} LI 

"Down it 
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VideoWorks 

Short Menus / Long Menus 

The Short Menus / Long Menus commands switch between short and long menus. Short menus 
show the simpler commands that beginners would use. Long menus add more advanced 
commands. 

The first time you start VideoWorks II, short menus are displayed. If you epenge menus, it 
remembers and displays the same menus thereafter. 

Preferences... 

The Preferences command lets you specify certain settings. This command is described earlier 
under "Preferences" under the Control menu in the "Overview Reference” section. 
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The Sound Menu (VideoWorks) 

1 - Basic 

2 - Explosions 

3 - Weapons 

4- Instruments 

3-1 Bird! 

The Sound menu contains dozens of sounds 
you can add to your movie. This menu is 
identical to the Sound menu in VideoWorks. 

You can play music, make noises, produce 
speech, or play sampled (very real) sounds. 

6 - $pace 3-2 Bird2 You simply add these sounds-to the sound 
7? - Old Music 3-3 Rivet track in the Score. If you have access to an 
8 - New Music 3-4 Meow audio sampler, you can use a microphone to 

9 - Business 3-3 Bubblel save your own sounds-they will have 
uncanny realism. A - Sampled 1 3-6 Bubble2 

F - Macintalk 

Sounds come in several basic categories: 

¢ Music (Old Music, New Music, Instruments) 

¢ Effects (Basic, Explosions, Weapons, Nature, Space) 

e Presentations (Business) | 

¢ Computer speech (Macintalk) 

e Real sounds (Sampled sounds) 

Note: System 4.1 vs. Earlier Systems We have provided 

System 4.1 with VideoWorks in order to take advantage of hierarchical 
menus. System 4.1 is simply more convenient to use — there is no loss 
of function when using an earlier system. 

Sound Menus with a System Prior to System 4.1. The Sound menus operate as 
follows with Macintosh System 3.2, or any other system prior to System 4.1. First select the 

cells in the sound channel of the Score where you want to insert the sound. 

1. Pull down the Sound menu and choose a category by moving to it.and releasing the mouse 

button. 

2. Pull down the Sound menu again. You will notice a submenu appears in place of the original 

menu. Choose a sound by moving to it and releasing the mouse button. 

You can navigate around the menus using the Top and Next commands that appear at the top of 

each submenu: 

¢ Top — Returns the Sound menu to the top menu which contains all of the categories. You 

must pull down the Sound menu again to see the effect of this command. 

«Next — Changes the Sound menu to the next category. You must pull down the Sound menu 

again to see the effect of this command. 

For more information on: See “How to Animate”: 

ee rey et eee ee ee ee "Adding Sound, Tempos and Transitions” 
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The Window Menu (VideoWorks) 

Window 
The commands in this menu open and 
close windows in VideoWorks. The 
following describes how to use these 
commands. The windows themselves 
are described in detail in "Windows," a . 
later section of this manual. 

To illustrate how these commands work, let's use the Score command as an example. When you 
choose the Score command from the menu, the Score changes to its next state: 

1. Ifthe Score is on the screen but inactive, it will be made active (brought to the front). 

2. Ifthe Score is already active, it will be closed. 

3. Ifthe Score is closed, it will be opened. 

Windows that are open have check marks next to them in the Window menu. The item that is 
underlined is the currently active window. 

Active Window 
The term “active window" is important to understand when selecting with the pointer. Only one 
window can be active at a time. In general, you can tell which window is active simply by 
looking at it — its title bar is highlighted with horizontal lines. (However, the Panel and Stage, 
have no title bars.) 

The active window is in front of all other windows. To select artwork, text or cells, you must 
first make sure the window you want to select is active. Thus, you click on the Cast to make it 
active, then select a castmember, or you click on the Score, then select a cell. Here again, the 

Stage is an exception—you can select artwork on the Stage at any time. To Cut, Clear, Copy or 
Paste in a certain window, you must first make that window active. 

Most windows become active when you click anywhere on them. However, Tweak requires you 
to click on its title bar to make it active. (The reason is so that you can adjust Tweak and still 
keep your current window active.) 

Command key shortcuts for the window commands are shown to the right in the Window menu. 
For example, the shortcut for the Stage command is 3-1. 
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The Text Menu (VideoWorks) 

The Text menu lets you 
apa See specify the font, size, style 

10 point Helvetica s alignment of text in 
Bold VIZ poine ee the Paint window and Text 

PIGHE 14 point. New York window. 

Center] Underline 18 point Times 
Right Outline 24 point The menu shown here iS 

Shadow | | 36 point the hierarchical kind 
48 point available when you are 
22 point oe Macintosh System 

Note: If you see the Font and Style menus instead of the Text menu 
on your menu bar, your Macintosh is using a system prior to System 
4.1. The only difference is that System 4.1 supports hierarchical 
submenus — there is no loss of function when using an earlier system 

The Text menu has three submenus: Font, Size and Style. Use the Text menu to modify text in 
the Text window. It also works for setting the text that you are about to type, or have just 
finished typing, in the Paint window. 

These attributes are similar to those found in MacPaint, MacWrite, and most Macintosh 

applications. 

Paint text and Text text are fundamentally different in the way they are edited and in the way they 
print. Paint is bit-oriented while Text is character-oriented. Initially, when you type in the Paint 
window, you can use the Text menu to change font, size or style. However, once you click the 
mouse, the text becomes bit-oriented, and you can no longer alter the Paint text with commands 
from the Text menu — you must instead use the eraser and re-type the text. Text window text, 
however, can easily be edited at any time. You can delete characters with the Backspace key, and 
can change the font, size or style from the Text menu. 

Which fonts and sizes are available at the Text menu depends entirely on which ones are loaded 
into your current System file (in your System Folder). You can add or remove fonts and sizes 
using the Font/DA Mover. 

Font 

Sets the type fonts: Geneva, New York, Helvetica, Times, etc. 

Size 

Sets the size of the type in points: 9 pt, 10 pt, 12 pt, 14 pt, 18 pt, etc. 

Style 

Sets the type style: Plain, bold, italic, underline, outline, shadow. 

Left, Center, Right 

Causes the text to be pushed left, aligned with the left margin, centered between the margins, and 
aligned with the right margin. 
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The Draw Menu (VideoWorks) 

The Draw menu is used to set the line 
widths and fill patterns for lines and 

Poecoscescescacacvecasovasscesevessecoooeseaaes 

None (iia BReS Bed shapes. 

eS SS 
MD (ee EEE Gd 
E= EGS EE ee 
ES Fab 4 Fy] 

GS EIS 
3 ICI soca RAR RAR, 

Line Widths 
The top row of the Draw menu contains four different line thicknesses from which you can choose. 
The leftmost choice (dotted line) is no line thickness at all. The line thickness you choose. 
changes the thickness of: 

e The Line (in Paint) 

e The QuickDraw Line (in the Cast) 

e Outline of circle and rectangle (in Paint and QuickDraw Shapes) 

Fill Patterns 
Below the row of Line Widths, the remainder of the menu defines the fill patterns for shapes. 
Choosing one of these patterns changes the pattern in all of the QuickDraw shapes: 

e Circle and rectangle (in Paint) 

¢ Circle, rectangle and rounded rectangle (in QuickDraw Shapes) 

Choosing a pattern also affects these tools: 

e Brush, paint bucket, and airbrush (in Paint) 

ee 
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The Ink Menu (VideoWorks) 3 
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“Erase -normal Ink alters the way the pattern on one — 
No Erase-leaves trails piece of artwork interacts with the 

pattern on a piece of artwork behind it. 
-normal 

Matte -outlines edge 

Or -transparent 

Hor -black reverses 

You can apply ink to artwork in the 
Paint window and to artwork that has 
been selected on the Stage or in the Bic -black is eraser 

NotCopy-invert then Copy Score. 
NotOr -invert then Or 

NotHor -invert then Hor 

NotBic -invert then Bic 

Mask -for donut holes 

Average 

Minimum 

Maximum 

Add 

Add Pin 

ww 

The Ink menu covers the ways two images can interact when their paths cross on the screen. ‘With 
Copy (the default ink), for example, when a piece of art crosses in front of background art, you see 
the foreground art itself, enclosed in a white box. 

Note: When artwork A is positioned in front of artwork B, only the 

ink on artwork A determines how the patterns interact. It makes 
absolutely no difference what the ink of the background art is. 

Erase 

Erase is the default mode of animating. Each time artwork changes position on the Stage, its 
previous position is erased from the screen. This is very natural and is usually the way you want 
your animation to run. However, you can choose No Erase to change how this works, for special 
effects. 

No Erase 

When No Erase is turned on, each image remains on the Stage. As an object moves, it leaves a 
trail of its previous locations across the screen, as in the following illustration. (This example 
also uses Matte ink, which eliminates the white box from around the donut.) 
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VideoWorks 

Note: In the following examples, the ink is applied to the donut ets to 
the rectangle, which is always Copy for these examples). 

Copy (Normal) 

Copy is the default ink mode. This ink leaves a white box around the image (which is the 
quickest way for VideoWorks to generate the artwork). This white box is not visible except when 
the artwork passes in front of other artwork. Therefore, Copy is useful for backgrounds and when 
you are not positioning artwork on top of other artwork. You can use Matte to remove the white 
box, but use it sparingly. 

Copy 

Or (Transparent) 

When Or is applied to the foreground art, you can see through that piece of art. Use Or to create 
transparent effects. 

Xor (Black Reverses) 

When Xor is applied to the foreground art, any black pixel in the foreground art will reverse the 
pixel behind it. (This rule is called "Exclusive OR", or Xor, in computer parlance.) Also, the 
white pixels are holes that let the background through. Xor is useful for creating various strange 
effects. Xor is also useful for reversing black and white (such as reversing text to make it white 
on a black background)—just choose Xor, black fill from the Draw menu, then draw a QuickDraw 
rectangle on the Stage over the artwork you want to reverse. 

Xor 

Bic (Black is Eraser) 

When Bic is assigned to the foreground art, any pixel that was originally black in the foreground 
art will appear as white, regardless of the background art. A pixel that was originally white lets 
the background shine through unchanged. Bic is good for making ghost images and custom 
masks. (Technically, Bic stands for "Black is Clear," where "Clear" means transparent.) 
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Bic 

| NotCopy, NotOr, NotXor, NotBic 

These modes are variations of the above four modes. The foreground image is first reversed, then 
the Copy, Or, Xor and Bic inks are applied. These are good for odd effects. Like Xor, the NotXor 
ink is good for reversing black and white — choose NotXor, white fill, then draw a QuickDraw 
rectangle on Stage on top of the artwork you want to reverse. _ 

NotXor 

Matte (Outline Edge) 

Matte removes the white box that is visible around artwork. Matte functions much like Lasso in 

the Paint window, in that the artwork is outlined, rather than enclosed in a rectangle. Matte works 
like lasso in determining which parts are opaque and which are transparent. 

Both Matte and Mask use twice the memory of any other ink, because to create these effects, 
VideoWorks has to internally create a duplicate of the artwork. 

Mask (Donut Holes) 

When Mask is applied to the foreground art, you can see the background through its holes. For 
example, you could see the background through the window of a car, if the car were masked. For 
more information, see "How to Create an Ink Mask" in the "Advanced Animation" section of 
“How to Animate." 

Color Inks 

Average, Maximum, Minimum, Add, Add Pin, Subtract, Subtract Pin, Transparent 

These inks are used when you have a Macintosh with a color card and monitor. To find out more 
about these inks, refer to "Adding Color" in the "Advanced Animation" section of "How to 
Animate." 
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_VideoWorks Windows 

This section describes the VideoWorks windows: 

e Stage 
e Panel 

° Cast 

e Score | 

e Paint 

e Text 

e Tweak 

_* Color 

These windows can be opened and closed by choosing the corresponding command from the 
Window menu. For more information about how the commands in the Window menu work, refer 

to the "Window Menu" section earlier. 

Stage (VideoWorks) 
The Stage is the full-screen window where all animation takes place. All other windows (Panel, 
Cast, etc.) appear in front of the Stage. To get a full, uncluttered view of the Stage and animation, 

~ choose the Stage command at the Window menu. It clears the screen of all the other windows and 

the menu bar. Selecting the Stage command again returns all previously displayed windows to 

view. 

The shortcut for the Stage command is #§-1. When you are creating an animation, use g£-1 to 
quickly toggle back and forth between the uncluttered Stage and the working windows, 

The menu bar is active even when it and the cursor are both invisible, such as when you have 
selected 9-1 (Stage) and $§-Q (Play). You can move the (invisible) pointer to the top of the 
screen and press the mouse button, and the menus will actually pull down. (Try it!) 

When the Stage is cleared of other windows, you can add the Panel, Cast, Score and other 
windows one at a time simply by choosing them from the Window menu. 

@ File Edit Control Sound Window Text Draw Ink 

“T Biebstelteielselsrllse +le]ele 

The Stage command toggles between two views. 

Reference: VideoWorks Windows 235 



VideoWorks 

Panel (VideoWorks) 

236 

The Panel is the set of controls for controlling animation in VideoWorks. You can operate the 
Panel at any time to start, stop, slow down or otherwise control the animation. Most of the Panel 
controls are also accessible through the Control menu and by Command key equivalents. You 
should experiment with the various control methods to see which ones suit your particular style of 
working. The Panel functions are described next. ~The Command key shortcut for opening the 
Panel window is ¢6-2. 

BRIE ABA. BACK | STOP | STEP | PLAY |BSsila 

eel en 

ha PLAY . 
Play starts the animation. Play can also be accessed from the Control menu. Command key 

: d6-Q S 
Vite 

Hon 

= 

$TOF 

Stop halts the action. Stop can also be accessed from the Control menu. Command key 
shortcut: $§-W 

Rewind winds the animation back to frame 1. If the animation was running, it stops. Rewind 

can also be accessed at the Control menu. Command key shortcut: $6-R 

E> 
STEP 

Step advances the animation forward one frame. It has an additional function, when recording 
frame-by-frame, to copy artwork to the next frame. ei is also available at the Control menu. 
Command key shortcut: $6§-S 

Step has two uses: 

e Step Forward (Non-Recording) This is the normal way you use Step—to view an animation | 
frame-by-frame. The Step command simply steps through the animation frame-by-frame, 
without otherwise affecting it. Step functions this way when no there are no record lights on 
in the Channel Indicator. 

¢ Frame-by-Frame Record (Recording). If a record light is on in the Channel Indicator, the 
Step command steps to the next frame and copies that artwork to the next frame. The 
procedure for this is described in "How to Animate a Sequence Peres ERR: in the "How 
to Animate" section. 

BACK 

Back Step steps the animation backwards one frame at a time. Back Step can also be accessed at 
the Control menu. Command key shortcut: $§-D 
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: 

Loop causes the animation to repeat continuously. When the animation reaches the end, it 

continues with frame 1. Loop is in effect when the button is black. The button toggles, meaning 

that clicking it alternately activates and deactivates Loop. 

cH OL 
Speed Control changes the playback speed, and is operational even during playback. Dragging 

the box to the left slows down the animation, while dragging it to the right speeds it up. . For 

small animations, the number corresponds approximately to the number of frames per second. As 

more (or larger) artwork moves on the Stage, the animation slows down and the number no longer 

represents frames per second. Large animations will run faster on the Macintosh II or on a 

Macintosh with a speedup card. In those cases, this number will represent actual frames per second 

over a broader range. 3 

Frame Counter shows, by frame number, your current position in the animation sequence. In 

addition, you can access any point in the animation by moving the pointer into the Frame Counter 

box and dragging the pointer. Dragging the pointer to the right (or down) increases the frame 

number, while dragging it to the left (or up) decreases the number. This action is the same as 

dragging the Playback Head in the Score — notice that dragging the number to the right has the 

same effect as dragging the Playback Head to the right. = 

SRE Re 3 

Channel Indicator is the 24-channel grid at the right-hand side of the Panel. It indicates which 

channels are currently occupied (shows the channel number), which are empty, which are currently 

selected (shows black), and which are currently being recorded (shows record light). 

In addition, the Channel Indicator also doubles as a channel selector: By clicking any of the 24 

cells, you can select the corresponding channel. You can select more than one channel at a time 

by holding down the Shift key while clicking the squares. For more information, see "Controlling 

an Animation" in "How to Animate." : 

5S 80  —Selection Range Indicators ~ 2 

Selection Range Indicators are the two numbers that appear below the channel indicator. 

They show the beginning and ending frame numbers of the sequence selected in the Score. The left 

number indicates the first frame selected, while the right one indicates the last frame selected. If 

only one frame is selected, the same number appears in both places. If the frame is selected with a 

blinking cursor, then the frame number appears only in the left position and the right position iS 

blank. As with the Frame Counter, you can adjust either number by placing the pointer on the 

number, pressing the mouse button and dragging up or down to extend the selection. You can use 

this feature to edit in the Score without actually opening up the Score. 
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Cast 

238 

The Cast is where all of the the artwork, text and Film Loops of a document is stored. It is a 
repository that holds castmembers, almost like a database manager. The Cast can hold 512 
different castmembers (64 rows with 8 castmembers to a row) in a document. Each castmember 
has a different cast number, from All to H88. (These are the same numbers you see in the Text 
window.) One row of castmembers is visible at any one time. You can scan through the rows by 
clicking the Cast arrows up or down. Clicking any castmember will select that castmember, 
indicated by a heavy border around it. The heavy border indicates this castmember is currently — 
active in Paint. (This border does not indicate which artwork is selected on the Stage.) Once’ 
selected, the castmember can be animated in real time, or dragged onto the Stage for frame-by- 
frame animation. 

Castmembers can come from any of six sources: Paint window, Text window, Clipboard, Art 
Grabber+, Scrapbook and QuickDraw Text. For instance, by simply opening a new easel in Paint 
and drawing in it, VideoWorks automatically places that art into the first empty position in the 
Cast. (In fact, VideoWorks constantly updates the Cast to reflect any changes that are made in 
Paint.) 

The Cast number indicator at the very left of the Cast shows which row is currently visible—banks — 
A through H and rows 1 through 8. You can move directly to any row by clicking on these Cast 
numbers. The shortcut for opening the Cast is $§-3. 

— Cast 

Sislae] | BAG 

The Pointer is for returning the cursor to the pointer shape after having chosen one of the 
QuickDraw Shapes or Text Box. 

OOO’, 
QuickDraw Shapes are geometric shapes that you can draw directly on the Stage. These four 
icons are the QuickDraw tools for creating these shapes, much like the rectangle, circle and line 
tools in the Paint window. However, the shapes you draw with the QuickDraw Shape tools have 
characteristics very different from those drawn in the Paint window. 

You can fill a QuickDraw Shape with any of the paleees and change its outline with the line 
widths from the Draw menu. 

By design, QuickDraw shapes take much less memory than do the same-sized ne shapes in 
Paint. QuickDraw Shapes are especially fitting for large background areas. Large QuickDraw 
shapes are not particularly suited to being moved as part of an animation, since they tend to slow 
down the animation. QuickDraw Shapes are not kept in the Cast — they appear only on Stage and 
in the Score. You cannot use QuickDraw Shapes with Real-Time Recording. 

The Text Box is the means for typing text directly on the Stage. The icon shown is the tool for 
creating a Text Box, much like the Text tool in the Paint window. However, the text you type in 
a Text Box has very different characteristics. 

Reference: VideoWorks Windows 

| | | me Ve Gb GGG Gb GG GG bf VU be 

} 

j ( { es 



VideoWorks 

To type text on the Stage, you click on the Text — move to the Stage (the pointer is now a 
crosshairs with the letter A attached, as shown below) and drag open a box. Then you type the 
text. The text is entered into the next empty castmember position. As you type, the text is also 
entered in the Cast and in the Text window. This Text Box is merely a shortcut for typing into 
the Text window and dragging the text from the Cast onto the Stage. 

A Crosshairs for Text Box 

(If you want to put the text in a particular position in the Cast, just click on that position before 
dragging open the text box.) 

Text in the text box is character-oriented (as opposed to the bit-oriented text in Paint). You can go 
back later and edit this text character-by-character, change its font, style or size. This kind of text 
also takes up a lot less memory than Paint text. However, when animated to move across the 
Stage, it moves more slowly than does Paint text. 

The box you create with the Text Box looks like this when it's selected: 

Drag anywhere on the gray border 

Handle for re-sizing 

Use the handle on the lower right corner to resize the rectangle. Use the Font and Style menus to 
change the look of your text (note that Center, Right, and Left options also affect the text. You 
are allowed only one font size in a particular text box though you can mix different styles (like 

bold and italic). 

GERD RE ARE RD GR RT RE GRE GRY RT ART GBT ht 
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Score 

The Score contains notation indicating how the action progresses. Time progresses towards the 
right, as indicated by the Playback Head that moves along the bottom of the Score. The Score 
identifies a wealth of information: artwork, motion, position and inks. The Score represents the 
entire movie like an orchestral score represents an entire symphony, or a Script represents an entire 
theatrical play. It is the focal point for the editing of animations. 

You can control the 3-dimensional effect by making one piece of art, say, a woman, pass in front 
of another, say a taxi cab. You do this in the Score by putting the woman in channel with a 
higher channel number than the cab. You can go back at any time and change the foreground 
priority by moving either the woman or cab to a new channel. 

The channels (rows) represent the individual pieces of artwork on the Stage, with one castmember 
to arow. The small, individual boxes in the Score are called frame cells, or cells, for short. Each 
cell displays information about what is taking place at that point in the movie. 

VideoWorks has a maximum capacity of 24 channels for artwork (numbered 1 through 24) and one 
channel for sound, tempo and transitions. The length of the movie is indicated by its number of 
frames. The number of frames is limited only by memory (or disk space, whichever is smaller) 

and can easily reach into the thousands of frames. 3 
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Direction indicator Ink indicator Castmember number Extended display 

(1st button) (2nd button) (3rd button) (4th button) 

The four display buttons 

Display Buttons 
Display Buttons (in the upper left corner of the Score) let you alter oie information is displayed 

in each cell, as shown above. 

Note: The top channel of the Score is a special channel for sound, 

tempo and transitions. We call it the sound channel, for short. Its 

notation is different than for the other 24 channels. The sound channel 

1S described separately, after these four buttons. 

Direction indicatar Button — With the first button selected, the upper ‘eihbol in each cell 

indicates whether the castmember has changed. The lower symbol indicates the direction the 
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Ee castmember has moved from the previous frame (as measured at its center). See the illustrations 

: below. 
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Castmember Change (upper symbol) 

i New castmember introduced 

Cl Castmember unchanged from previous frame 

Direction Indicator (lower symbol) 

»| Right Up and to the right ae Stop le 
Up Up and to the left 

Left Down and to the left 

Down | Down and to the right 
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Ink Indicator Button — With the second button selected, the top symbol of a cell provides the 
aye same information provided by the first button. The lower symbol tells you which Ink is used. 

4H] For example, if the letter "C" appears in this row, this indicates that the Copy ink is used. The 
inks are: 

Ink (lower symbol) 

Copy Not Copy In| Matte 

| Or Not Or Mask 

Xor Not Xor E- No Erase 

Bic Not Bic 

Ink indicators 

clclolalelalelelnls 

z|zlslalsisleleiae(¢— Dotted line lnclibates No Erase 

All possible inks shown 

= a Castmember Button — When you select the third button, you are provided with information 

: about the castmember's origin. It can either show two digits or a shape (rectangle, circle or line). 
het 

of saving space. Thus, | is the number 12. This corresponds to the number displayed below 

the castmember in the Cast (but not the bank letter). 

¢ A square, circle, rounded rectangle or diagonal line indicates that the image was created using 

the corresponding QuickDraw Shape. 

QuickDraw rectangle 

| QuickDraw rounded rectangle 

QuickDraw circle 

QuickDraw line 

Text Box text is indicated with its castmember number. 

mie Extended Button — When you select the fourth button, the extended display is shown. You can 

e =3 customize the amount of information displayed in each cell. You can show as few as one or as | 
4 many as five different pieces of information. 

~ To select what information is displayed, double-click on ll The following dialog bee appears. 

Select whatever information you want displayed, then click OK. The X & Y Coordinates gives 

the location of the center of the piece of artwork on Stage. The value is the number of pixels with 
respect to the upper left corner of the Stage. The first value is the distance to the right, the second 
is the distance down. On a standard Macintosh Plus or SE screen, the edges of the Stage are 
X = 342 and Y = 512 (although the center can be off-screen). The Change in X and Y position 
setting is useful for finding out how far a piece of artwork has moved between frames. 
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B = bitmap 

Direction indicator Q = quickdraw 

Ns T = text 

Change in castmember —+ : 
Castmember number 

Ink —+ 

i X & Y coordinates 

Cell shown with extended display 

Extended Display Information: 

Mouvement Indicator 

(B=bitmap, O=quickdraw, T=text) 
Cast Number 

Ink Mode 

4H & ¥ Coordinates 

(] Change in # and ¥ Location 

Extended Display dialog box 

Note: If you select only one choice in the Extended Display dialog box, 
you can view all 24 channels at once, as shown below. 
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Sound, Tempo and Transition Channel The top row of the Score is the channel for sound, 
tempo and transitions. The symbol at the left end of that channel indicates which of the three 
features is being displayed. The procedure for adding a sound, tempo or transition is described in 
"Adding Sound, Tempo and Transitions" in "How to Animate." 

[¢] Tempo displays when you click 

| > | Transition displays when you click 

| «| Sound displays when you click H : 

Frog Score Frog Score | Frog Score 

oe t Ta a els e, = co m7 eo re a 
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| BR RORee +|+ +|-$ 

The tempo, transition and sound indicators 

Other Controls 

Playback Head The small black box at the bottom of the Score that moves to the right 
whenever an animation is playing. Its position indicates the current frame — the frame that is 
currently being displayed on the Stage. In fact, you might think of the Playback Head as the Stage 
indicator, since it indicates what part of the Score is currently on Stage. 

In addition, you can grab the Playback Head and move the movie back and forth — move the tip of 
the pointer onto the Playback Head and drag it in either direction. You can also click on the 
Playback Head bar at the desired frame (much like the Scroll Bar), to make the Frame Pointer 
jump, as shown below. 

Jump 
button 

Playback head 
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Moving the Playback Head by clicking 
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Jump Button Use this button when the Playback Head is out of view. Pressing this button 
causes the Score to jump, bringing the Playback Head to the center. This is a shortcut for using 
the horizontal scroll bar to find the Playback Head. While a movie is running, you can keep the 
Playback Head in view if you keep pressing the Jump button each time the Playback Head goes 
out of view. | | 

Selecting Cells You can select any frames and channels in the movie by opening the Score and 
dragging the pointer across them. An entire block of frames and channels can be selected by 
dragging the pointer diagonally across the desired block. Frames can be selected across all 24 
channels by dragging the pointer across the frame numbers at the top of the Score window. In 
addition, an entire channel can be selected by double clicking the channel number. A block of 
channels can be selected by double-clicking on a channel number and dragging down. Once a block 
of frames is selected, it can be edited, using the Cut, Copy, Paste and Clear commands, or varied 
by means of the inks in the Ink menu. 

For more information on: See "How to Animate”: 

«  Golecting: cells... 23a ek es "How to Select Cells in the Score” 

Scroll Bars The scroll bars are like those on any other Macintosh application. Press on the 
arrows to move smoothly, click on either side of the scroll box to jump, and grab the scroll box 
and drag to move to another part of the Score. 

Repeat Selection You can loop on any part of the Score by using Repeat Selection. See 
"How to Repeat Just a Portion of a Movie" in the "Advanced Animation" part of "How to 

_ Animate.” The gray line at the top of the Score indicates the area to be repeated. 

Repeat Selection 
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Paint Window 

Creating tools 

Paint - Bank fl 

Editing 

tools 

Paint is the paint program built into VideoWorks, and usually provides the first step in creating an 

animated sequence. Although Paint doesn't have all the capabilities of its forerunner MacPaint, it 

does include some additional special features. For example, airbrush, rotate, slant, perspective, 

distort, and the Paint window itself is re-sizable and scrollable. The top row of icons are the tools 

for creating artwork. The left column of icons are the tools for modifying existing artwork. These 

are described next. 

It's important to realize that every Paint easel is a castmember in the Cast. If you modify artwork 

in the Paint window, you are actually modifying the artwork in the Cast. You can think of the 

Paint window as another way of viewing the Cast. Also notice that, the active easel in the Paint 

window is highlighted in the Cast by a black border around the castmember. (You may have to 

scroll the Cast to see this highlighted castmember.) 

The Paint window shows only one bank of castmembers at a time, as indicated in the title bar 

("Bank A" shown above). It also shows the castmember that is currently selected in the Cast, 
regardless of what bank it is located in. 

A shortcut for opening the Paint window is $§-5. Another shortcut is to double-click on the art 

on the Stage—Paint opens with that piece of art on the top. (The art may still not be visible— 

scroll the Paint until you find it.) 

The tools in the Paint window are arranged in two groups: 

¢ Use the tools along the top row to create artwork 

¢ Use the tools along the left edge to edit artwork 
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New Easel creates a new easel in the Paint window, ready to accept a new image. The image 

created in the new easel is placed in the first available location in the Cast window. When an easel 

is active, its castmember number appears in the left side of it's title bar. Easels can be resized by 

dragging on the handle on the lower right comer, and can be repositioned within the Paint window 

by dragging the thick bar at the top. You can make an easel as large as the entire Stage, or much 

larger, by pulling it open in steps: Pull it open, scrolling the Paint window to move the easel up 

and to the left, pulling it open farther, scroll some more, and so on. This is useful for making 

scrolling background. 

FatBits magnifies the selected easel at the point last touched by the pencil or paintbrush Qust 

like FatBits in MacPaint) and allows modification of the image at the pixel level. Once in 

FatBits, clicking the icon (or the "actual size" box in the top, left corner) reverts to the original 

state. As a shortcut, while using the pencil, hold down the Command key and then click the 

mouse button — FatBits is enabled at that location in the image. All of the Paint tools work in 

FatBits. 

: 

Paintbrush is a drawing tool that allows you to draw with the fill patterns from the Draw 

Menu. : 7 

Paintbrush Shapes appear when you double-click on the Paintbrush icon. You can select the 

size and shape of the brush. It lets you choose from nine different shapes and sizes. 

Pencil is identical to the pencil in MacPaint and works the same way whether in standard mode or 

FatBits. The Pencil creates black lines on a white background and white lines on a black 

background — the reverse of whatever color it first draws on. Double-clicking the Pencil 

immediately places you in FatBits. In addition, with Pencil selected, pressing the Option key 

turns the pointer into a Hand, letting you move the image around the window. 

, 
Eraser is identical to the eraser in MacPaint. You can erase any part of an image by dragging the 

eraser over it. The Eraser also works in FatBits. Double-clicking on the Eraser erases the entire 

screen. 

Text is similar to the MacPaint text, making it possible to include bit-oriented text in your 

animations. Enter text by clicking the text icon, clicking on the easel where you wish the text to 

begin, and then typing You can choose the Font and Style from the appropriate menus. Once you 

click the mouse button again, or choose a new tool, the text becomes bit-oriented rather than 

character-oriented. (See "Adding Text" in How to Animate.) 

OO} 
Rectangle generates rectangles of any shape and size. The resulting rectangle (or square) is 

automatically filled with the fill pattern chosen from the Draw menu (described later) and outlined 

MS ee ee A) 

Reference: VideoWorks Windows 247 



VideoWorks 

with the line thickness from that same menu. By holding down the Shift key as you drag, you can 
constrain the rectangle into a perfect square. 

Circle draws circles when constrained, and ovals when not constrained. And just like the 7 -— 
Rectangle (see above), the resulting ovals or circles will be filled with the selected fill pattern and : 
outlined with the selected line thickness. Holding down the Shift key constrains the shape to a 

— 

perfect circle. , — 
—— 

_— 

Line draws straight lines at any angle. When constrained (by holding down the Shift key) the — 
Line draws lines vertically, horizontally or at 45 degrees. The line width is determined by the ee: 
currently selected line thickness in the top row of the Draw window. ae 

— 

ef 
Paint Bucket fills any area with the pattern currently selected at the Draw menu. It works just — 
like the Paint Bucket in MacPaint. _— 

Ink Indicator shows which ink is currently enabled for painting. To change the ink, make sure = 
the Paint window is active, then choose an ink from the Ink menu. Inks affect the patterns only 
when you paint on top of existing art. See "Changing the Ink for Painting." — 

a 
—— 

Selection Box (Marquee) lets you select any rectangular part of an image. You can then drag it - 
to a new location, use Cut and Paste, Copy and Paste, Clear, or some of the tools below it: Flip = 
Vertical, Flop Horizontal or Invert. To use the Selection Box, start at one corner of the image and 
drag diagonally across it. When you release the mouse button, the image will be surrounded by a —_— 
dotted rectangle. You can now move that surrounded image anywhere within the same easel by —— 
moving the pointer into the selection rectangle and dragging. When moving a selected image, 
holding down the Shift key will constrain the movement to the vertical or horizontal movement. i— 
Double-clicking on the Selection Box selects the entire easel. —— 

= — 
Lasso selects any part of a picture. Use Lasso to draw around artwork. Like the Selection Box, — 
the artwork becomes selected so that you can move it, or use Cut and Paste, Copy and Paste, or 

Clear. The Lasso has the advantage that you can draw an irregularly-shaped selection — it doesn't 
need to be rectangular. — 

—— 

—— 
a 

/ 
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Airbrush lets you draw with an airbrush effect. The longer you hold the airbrush in one spot, 
the darker it fills in the area. You can spray with any of the patterns from the Draw menu. You 
can change the size and density of the spot: 

e The spot size can be from 1 to 96 pixels in diameter. Set the size with the number keys 

(0,1,2,...8.9).across the top of the keyboard for large increments, or use the + and — keys for 
fine adjustments. 

e The density is varied with four keys: O lowest density 

P low density 

[ medium density (left square bracket) 

] high density (right square bracket] 

¢ The Option key lets you spray with a randomizing effect. Backspace key toggles from white 
to black spraypaint. 

Flip Vertical operates on artwork in the Paint window that has been selected with the Selection 
Box. Flip Vertical flips the selected image upside down. To flip the entire easel, first double-click 
on the Selection Box. 

Flop Horizontal operates on artwork in the Paint window that has been selected with the 
Selection Box. Flop Horizontal flops the selected artwork left-to-right. To flop the entire easel, 
first double-click on the Selection Box. 

The Invert tool operates on artwork in the Paint window that has been selected with the Selection 
Box. Invert reverses black and white within the selected rectangle. Invert also work with any 
artwork that is selected with the Lasso. To invert the entire artwork, first double-click on the 
Selection Box. 

Registration Point lets you change the effective center of any artwork, which changes the 
position of artwork on the Stage. If the piece of art is used several times throughout a movie, 
every instance is re-positioned. 

ee eee) 

Setting the registration point is fast and simple. To set a registration point, open the Paint 
window and select the artwork you want to adjust. Click on the Registration Point tool and then 

- click on the artwork in the Paint window at the point you want to define as the new registration 

point. 

To return the registration points to its original position in the true center of the artwork, just 
select the Registration Point tool, hold the mouse button down inside the easel, drag outside the 
easel and then release. The registration point will automatically be set in the center. You must do 
this for each castmember you want centered. 

1A An SS 
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Rotate lets you select artwork and rotate it any amount—from one degree through a full circle. 

Slant lets you select artwork and slant it backward, forward, up or down. 

Perspective lets you select artwork and enlarge or compress part of it to give the appearance that 

it stretches off into the distance, or that it is painted on a floor, ceiling, or side wall. 

Es 
Distort lets you select artwork and distort it by pulling at any corner. 

Menu Items Used with the Paint Window 
The following items in the VideoWorks menus can be used with Paint. 

Cut, Copy, Paste and Clear function in Paint on artwork that has been selected. 

Ink Menu can be used with the Paintbrush, Paint Bucket, Airbrush, Rectangle and Circle to 

make paints transparent or to create other effects. : 

Draw Menu can be used to create patterns with the painting tools: Paintbrush, Airbrush, Paint 

Bucket, Rectangle and Circle. 

2S Paint - Bank A 

Rea) ace a 
AANA 

POPE 
> = 

Ea 

Transparent ink (Or ink) 
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Text Window 

The Text window is the text editor built into VideoWorks that allows you to both enter and edit 
text in the Cast. You can also search and replace text from the Search menu that appears. 

The Text window has two uses: 

¢ To hold text that appears on the Stage 

¢ To hold text to be spoken by Macintalk (You can choose to have the spoken text displayed or 
not displayed) 

Each of the rows (cells) in the Text window represents a castmember (from All to H88), 
corresponding directly to the positions in the Cast. If a position in the Cast is already occupied by 
Paint artwork, that cell is grayed out. (See the illustration.) If there is no castmember in that cell, 

then the cell is white. 

To type text into the Text window, just click in the cell-it widens to make room for your first line 
of text-and begin typing. This text also appears in the corresponding position in the Cast. To 
place it on the Stage, simply drag it out from the Cast as you would any artwork. You can edit 
this text directly on the Stage without opening the Text window again. 

A shortcut is to create text directly on the Stage by using the Text Box at the right end of the 

Cast. The Text window allows you to view and edit all of the Text Boxes that are in your 

animation. 

When the Text window is open, a Search menu is added to the menu bar. This gives you all the 

familiar text search options that you would find in any word processor. 

Text Window 

Occupied by 

artwork in cast 

their juxtaposition and their advances, to tell which came 
into line and which in opposition, to describe all this 
without visual models would be labor spent in vain. 

Text 

ese 

peace ccc cls cep tn cnennncccwccncacacccsecenaccn cram cnccccc ccc acc econ ne cerenem ean nccnenescccacasceneccceeeceneceseneannncawcenscsermannanccocennaO Rh 585859 

Text Box 

: their juxtaposition and their advances, to tell which came : 
= into line and which in opposition, to describe all this : 
: without visual models would be labor spent in vain. 
= (Plato, Timaeus) 
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Tweak 

Search Menu 
(Appears in the menu bar only when the Text window is active.) 

Search 

Find... 

Find Same 368 

Replace & Find 38R 

Replace Everywhere 3sE 

The Search menu is for searching through 
text in the Text window. It is displayed only 
when the Text window is active. 

All searches start at the currently selected point in the Text window and work downward. When a 
search reaches the bottom of the Text window, it wraps around and continues searching from the 
top again. The Search dialog box (below) appears when you choose Find from the Search menu. 

Find searches for any text that you specify without replacing any text. You can enter a whole 
word or any part of a word. The "Replace with" part of the dialog box is ignored. Command key 
shortcut: ¢6-F 

Find Same continues the search for the same text you specified under Find. The Command key 
shortcut: $£-S (the "S" stands for "Same") for quickly continuing the search. 

Replace and Find does just what it says: It replaces the selected text, then searches for (and — 
selects) the next text ,and then stops. Thus, you can use this command repeatedly to replace text, 
stopping at each instance it finds to allow you to decide whether or not to change the text. 
Command key shortcut: #6-R 

Replace Everywhere performs the same operation as Replace and Find, but does it repeatedly, 
non-stop. Command key shortcut: #8-E 

© Separate Words 

@ Al occurrences Cancel 

The Search dialog box 

Tweak is used to precisely position art on the Stage. 

To use Tweak, first select the art you want to move (either on the Stage or in the Score). Next 
choose Tweak from the Window menu. Then click the pointer inside the large square on the left- 
hand side of the Tweak window and drag the vector in the same direction and for the same distance 
you want the castmember to move. The vector is also displayed as a change in x and y 
coordinates. To move the selected art on stage, simply click the "Do It” button. You can 
repeatedly move the art by clicking "Do It" again and again. Note that Tweak works only on the 
selected castmember. To move a long distance, you can stretch the vector outside the bounds of 
the Tweak window. The Command key shortcut for opening the Tweak window is 98-6. 
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Color Window 

The Color window takes advantage of any color graphics card (or cards) inserted into a Nubus slot 
of a Macintosh II. VideoWorks fully supports the new color Quickdraw extensions that are 
resident in the Macintosh II ROM. That means that regardless of what color resolution has been 
chosen by the user, (currently either 4 or 8 bits), VideoWorks will work. The Color window 
shows the current pallette available (either 16 or 256 colors) and lets you add colors to your 
artwork in the Paint window or to QuickDraw shapes. To open the Color window, choose Color 
from the Window menu. BY ik} ike bk . 
The Color command is dimmed in VideoWorks unless you have a color Macintosh — the 
Macintosh II with a color monitor and card. To set up for color, go to the Control Panel in the @ 
Apple menu, select the Monitor icon, then select either 16 or 256 colors. (You can do this while 

you're in VideoWorks.) If you leave the Color window open, you can see the colors change 
‘immediately. 

When you select Color at the Window menu, the following palette appears (shown here in black 
and white). Click on the foreground color indicator and select a color from the color palette. The 
small black triangle points to either the foreground or background color indicator to show which 
one you can change. Then click on the background color indicator and select another color. Pull 
down the Draw menu to see the colored patterns available. 2 

Some of the paint tools work in color: the Pencil, Paintbrush, Airbrush, Paint Bucket and filled 
shapes. You can import color images in via the clipboard or scrapbook and Fatbits works. The 
minature representation of the easels in the Cast also displays in color. 

Background color 
Foreground color 

—Color Palette 

A number of color inks are available to you. For more details about these inks and color in 
general, refer to the "Adding Colors" section of "Advanced Animation" in "How to Animate." 

oe ee ee 
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VideoWorks Hidden Features S 
__— 

Hidden features are important VideoWorks features that are not found explicitly on any menu: m 

* Film Loop | ate 
¢ Constrain i 

Thus, this section rounds out the two previous Menu and Windows sections which deal with only 5 
the visible features. — 

— 

Film Loop : a 

A Film Loop is an animated piece of art, kept in the Cast and that you can real-time record. To —e 
explain this, let's start with an example. 2 

Let's say someone has already created a Film Loop called "Flipping Coin," and it resides in the _™ 
Cast at position A21. To use the Film Loop, you would begin Real-Time Recording with it. 
The first thing you would notice is that the coin would be flipping, even when you hold it — 
stationary. This is the unique characteristic of Film Loops — they have built-in motion, like a clip | — 
of film. As you move the coin around on Stage, it will continue to flip automatically. You could 
move it in an arc, as if it were being tossed from one side of the Stage to the other. — 

Now let's ask the question, "How do you get a Film Loop into the Cast?" To create a Film Loop, = 
first you need to create the sequence as you normally would. Then you open the Score, select that == 
sequence of art (along one channel only), Copy it, then select a position in the Cast and Paste. — 

oo 

n==ee Coins Cast ieee 

_ 
— 

Note that the artwork used in a film loop should have logical registration points set - for example, ame 
in the jumping frog a good place for the registration point would be on the shadow of the frog. —— 
This way, when the person holds the frog still, the shadow will not move yet the rest of the frog _ 
will move. : 

Generally, you create a Film Loop when you want to show a sequence that has some motion built- 
in to it. A Film Loop is fine for animating any object that rotates, such as a revolving globe or a 
spinning wheel Moving art attracts your eye. You can take advantage of this with Clip Art to | | 

draw a person's eyes to a certain part of the Stage. " . a. 

For more information: See "How to Animate”: Se 
ee ee re ."Adding Film Loops” 

Constrain 

When you drag an artwork or text across the Stage (or in Paint), you can constrain its motion to 
strictly vertical or horizontal with the Shift key. This is the standard Macintosh convention used 
in MacPaint. 

To use constrain, press and hold the Shift key and then drag the object across the Stage. yy ay iy 
For more information: see “How to Animate”: 

e On Constraining artwork...............c0sceeeeees "How to Constrain the Positioning of Artwork” 
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Hints, Tips and Tricks 

This section is divided into six categories. The tips are in no particular order: 

General Hints, Tips and Tricks 

e Speed, Memory and Disk Space 

e Animation Techniques (VideoWorks) 

¢ Artwork, Pictures and Film Loops (VideoWorks) 

e For Advanced Users 

e Shortcuts 

These are tips, not elaborate explanations. While we do not give explicit references to other parts 

of the manual, you will often find further explanation in the "How to Animate" section. Also use 

the Index or Table of Contents. 

General Hints 

Save your work often. There is nothing more discouraging than losing hours of work 

because of a disconnected plug, a power shortage, or accidentally hitting the reset switch. For 

similar reasons, you should keep backup copies of your favorite animations on separate disks. 

To quickly view a lot of different documents, just open Overview and do a Quick Create 

on that folder. You can show MacPaint, PICT (MacDraw), VideoWorks and Glue documents this 

way. 

To edit artwork from the Stage, double-click on it and the Paint window will 

automatically open up. The artwork will be displayed on top, which you can then modify. 

This is very useful short cut. You can also use this technique just as a quick way of getting into 

Paint, to create new artwork. 

When viewing artwork on the Stage, a quick way to find its position in the 

Cast is to double-click on it. Not only does the Paint window open (as described in the 

previous hint), but also that castmember is selected in the Cast (that is, it has a black border 

around it). 

As you create new castmembers, group them together within the Cast so that 

they fall into "animation groups," making them easily accessible as you work. However, 

once you have castmembers in the Cast, do not cut and paste existing castmembers to new 

positions (unless the Score is empty). Cutting and pasting between positions in the Cast will 

alter the animation. 

Paint shows only one bank of castmembers at a time (one of bank A through bank 

H), as shown at the top of the Paint window. (The Paint window also shows the castmember that 

is currently selected castmember in the Cast .) 

Use the Scrapbook to store animations temporarily. You can cut existing scenes or 

sequences from the Score and store them in the Scrapbook for use in later animations. This 

eliminates repetitive opening and closing of files. (You should be careful when storing scenes for 

along time. See "Storing Sequences in the Scrapbook" in the "Advanced Animation” section of 

"How to Animate.") 
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Cut, Copy, Clear and Paste operate only on the currently active window. To 
demonstrate this, open the Score, Cast, Paint and Text. First click on the Score (to make it 
active) and pull down the Edit menu. Notice the word "Score" appears after each command: Cut 
Score, Copy Score, and Clear Score. Thus, with the Score as the active window, if you were to 
select a group of frames, Cut Score would cut the selected frames to the Clipboard. In 
comparison, click on the Cast and notice the Edit menu says Cut Cast, Copy Cast and Clear Cast. 
Also see how the Edit menu changes with Paint and Text. 

However, Paste is different — it does not depend on the active window. It will either say Paste 
Score (if frames have been copied to the Clipboard), Paste Text (if text has been copied to the 
Clipboard) or Paste Graphic (if there is a picture has been copied to the Clipboard) or just Paste (if 
the Clipboard is empty). 

You can select a piece of artwork on the Stage and remove it with the Blank 
from Stage command, without affecting the other art on the Stage. Contrary to 
what you might expect, Clear and Cut will not delete it. Cut, Copy, Clear and Paste operate only 
in the four windows Paint, Text, Cast and Score. | 

Become aware of the Channel Indicator. It is very useful. You can click on artwork on 
the Stage and glance at the Channel Indicator to tell immediately which channel it's in, without 
ever opening up the Score. Also, whenever you drag a castmember onto the Stage, you can glance 
at the Channel Indicator to see which channel that castmember was automatically assigned to. 
Also, in Real-Time recording you must explicitly select a channel before recording if you do not 
want the existing channel erased — again, click on the Channel Indicator to avoid having to open 
the Score. 

Like any other Macintosh application, VideoWorks uses whatever fonts are 

available in the system. If you have any non-standard fonts you like, add them to the 
System with the Font /DA Mover and they will appear in the Text menu. 

Use the No Erase option (in the Ink menu) to create a trailing effect on the 

Stage. This is especially useful in grabbing someone's attention. This technique is used in 
"How to Create an Animation that Draws Handwriting"— creating an animation that draws out 
handwriting on-screen, such as your signature. 

Dotted Line in the Score. If you've ever seen a dotted line in the Score and wondered what it 
meant, here's the answer: The castmember with the dotted line is using No Erase ink for those 
frames (as shown below). 

oa Demo Score = 

Channel 2 is using no-erase ink 

Use Shift-Enter. When editing with several windows showing, the easiest way to start a 
movie is with Shift-Enter. (Don't confuse the Enter key with the Return key.) All windows 
disappear and the movie begins. To return, press the period (.) key. 
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You can scan back and forth through an animation at your own pace in either 
of two ways: 

e Move the cursor into the Frame Counter on the Pandl. hold down the mouse button ie drag 
left or right. The frame number and scene change together. 

e Open the Score and drag the Playback Head back and forth. 
Of course, you can always use Step (36-S) and Back Step (d6-D), as well, to move one step at a 
time. The Playback Head is analogous to the "scratch" bar used to spin an LP record back and 
forth, used to hear the needle scratch for the start of the music. 

If you create a new file and notice that objects do not have the normal Copy 
ink mode, then change the default ink. The check mark in the Ink menu indicates the 
default ink. You can change the default by Ree an Ink mode when nothing is selected in any 
window. , 

Use the Shift-click shortcut in the Score to select a large number of frames 
quickly. Click at the initial frame, use the scroll bar to move to the last frame, then hold down 
the Shift key when you click again. 

You can move the Panel anywhere on the Stage by grabbing it anywhere around its 
edges and dragging it. 

= 

—al 

= 
—; 

eS 
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Oops, I made a mistake. All editing actions are undo-able including Burn Scene, in case you 
choose it by mistake. (As is standard, the items in the File menu — New, Open, Revert, Save, 

Print — are not undo-able.) 

Sound and pictures are always stored in separate files on your disk. The pictures 
are stored in the VideoWorks movie file. All sounds that are displayed in the Sounds menu (except 
Macintalk) are stored in the Sounds file. Macintalk is contained in its own file. Therefore, when 

you copy a movie file to another disk, be sure to copy the Sounds file along with it if it contains 
customized sounds. 

If you have a custom Sounds file, the most convenient method is to keep all related files in the 
same folder with that Sounds file. When using digitized sound, the Sounds file can be big — larger 
than the graphics portion of the animation. 

Learn to use the Command key equivalents of the more common functions to 
speed up your work. For example, use Command-S to step a frame rather than moving the 
mouse to the Panel to hit Step. With the Command key equivalents you can operate faster by 
keeping one hand on the keyboard and the other on the mouse. Having trouble remembering 
Command Key shortcut for opening the Score? “Four score and seven years ago..." 

Do not use Cut and Paste to move castmembers from one position to another 
in the Cast (unless the Score is empty). Moving a castmember in the Cast would cause it to 
disappear from the Stage. This is because the Score keeps track of artwork by the Cast position 
number you see in the Cast (A11, A12, ...), and the artwork would now have a new cast position 
number. | 

You can make sound vary according to the position of artwork on the Stage. 
Both Y-Synthesis and YX-Synthesis enable the position of the art on the Stage to determine the 
sound. As the art moves down the screen, the sound gets lower in pitch; as it moves up, it gets 
higher in pitch. Y-synthesis produces a pure tone, while YX-Synthesis produces a raspy tone that 
also gets slightly louder as the art moves to the right. The effect is a direct synchronization of 
sound to video. See YX-Synthesis in the "Adding Sound, Tempos and Transitions" section of 
"How to Animate” to find out how this is done. 
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To quickly re-position artwork on the Stage everywhere it appears, change its 
registration point. This is an amazingly easy way to re-position art. Open Paint to the piece 
of art, click on the registration tool, then click on the art to re-locate its registration point (marked 
by the intersection of the two perpendicular lines). 

Don't overlook the selection of brush shapes that are available in the Paint window by 
double-clicking the Paintbrush. 

Use Paste Relative to repeat a short sequence (such as a single frog jump). 
across the Stage, Paste Relative is a special way of pasting a copy of a sequence so that the 
start the second copy of the sequence is automatically positioned at the end of the first sequence. 
This concept is illustrated very well in The Frogs tutorial. 

— [7 Record lights 

Ever wonder what those little circles in the Channel Indicators mean? Those 
are record lights. A record light indicates that when you Step, that channel records into the 
next frame. The record light c comes on when you drag artwork on the Stage, to do frame-by-frame 
animation. 

Ever get lost in the Score, and you can't find where sequences begin? To help 
you keep your place, you can click on the round frame markers at the top of the Score to mark the 
beginnings of sequences or other important points. These markers also denote the frames to be 
printed. 

alld. 
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Speed, Memory and Disk Space 

To reduce the size of your animation, keep the following in mind. 

¢ Animate only the part of the picture that has to move. This saves disk space and 
keeps the animation speedy. For example, if you want to create a face with only the lips 
moving, don't redraw the entire face for each frame. Rather, use the same face as the 

castmember, changing only the lips each time. By the same token, use smaller figures 

(castmembers) whenever possible, since this will result in cleaner animations the bigger the 

image, the more likely it is to "flash" from one frame to the next. 

¢ Reduce the number of large castmembers by sharing common parts. Analyze 

the Paint artwork to see if parts of large castmembers are identical. If so, you can slice them 

up, discard common parts that are extra, and reconstruct the artwork from these pieces. While 

this is extra work, it may be what you need to squeeze a large document onto a disk. 

¢ If you need td reduce the size of a large VideoWorks movie, you can try 

copying the entire Score to another document. In the process of copying, any 

castmembers that are not used in the animation are automatically discarded. Also, all 

remaining castmembers are crowded together in the Cast (towards A11), removing any empty 

positions. The animation runs exactly as it did before. To select the entire Score for copying, 

drag the pointer across the frame numbers at the top of the Score. 

Use the QuickDraw Shapes whenever possible for stationary artwork. Look 

through your existing Paint documents for large areas where you can substitute QuickDraw 

shapes. You might replace a full-screen, rectangular gray Paint background with an identical 

QuickDraw background. 

VideoWorks really pushes the Macintosh to its limit, squeezing all the 

performance possible. The biggest indication of this is that all but the simplest animations 

require you to push the speed control to the maximum. When you open up the Score and watch 

the Playback Head, you will notice it slows down at points where more channels are introduced, or 

where larger artwork begins moving. | 

Realize that adding channels, increasing the size of Stage objects, or stretching 

will slow down the animation. Therefore, before starting your animation, try to anticipate 

any loss of speed that may result as you add channels. 

There is a limit to the size of a VideoWorks movie, determined by available 

memory. The limitation exists because a VideoWorks movie must be entirely loaded into 

memory before it can run. For a 1 megabyte Macintosh, the theoretically largest single movie 

you can run is about 550K (a stripped down system takes up about 150K and VIDEOW ORKS II 

takes up about 275K). This includes the sounds you use, not necessarily the entire Sounds file. 

See the next hint for a way to work around this limitation for larger files. When you reach that 

limit, VideoWorks will notify you that you are running out of memory. 

Practically speaking, editing movies larger than roughly 3000 frames gets very sluggish, 

especially if most or all of the channels are filled. For example, it might take 30 seconds or 

longer to Cut and Paste a single frame across all channels. You. will probably find you need to 

keep movies to under 250K or 300K, and editing will be easier if you keep them under 100K to 

150K. When thinking about disk space, be aware that a movie expands slightly as it is loaded into 

memory.) 

There is a way to run a movie of any length (up to the available disk space), 

working around the memory limitation mentioned above. You do this by breaking 

the long movie down into movies shorter than about 100K, running those movies in series in the 

Overview window. 
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Give the Macintosh a chance to catch up. If your animation is running up against the 
speed limitations of the Macintosh (as is true of most large movies), when cutting from one scene 
to another (that is, to a scene with a new selection of artwork), insert a blank frame down all 24 
channels to give the Macintosh a chance to "catch its breath." The result will be a cleaner segue. 

Open windows (especially the Score window) can slow down an animation. 
When adding sound to an animation, synchronization is critical. Because open windows slow 
down the animation slightly, be sure to run sound animations with all windows closed (by 
choosing Stage from the Control menu). 

Take advantage of the pauses the Macintosh has to take. For instance, when running 
a series of movies (using Overview), the display pauses on the last frame of a movie while the 
next movie is loading into memory. Make this last frame something that naturally would require 
a pause, such as a paragraph of text to be read — the viewer will not be so likely to notice the 
pause. 

Use Matte and Mask inks sparingly. These inks use twice the memory of all the other 
inks (Copy, Or, Xor,...) and will slow down your animations if used to excess. In particular, use 
Matte and Mask only for those frames when one object passes in front of another, and then only in 
the foreground channel . 

Some sounds have no effect on speed, while others have a tremendous effect. 
The standard sounds (Basic, Explosion, Weapons, etc.) do not take much memory, and slow the 
animation only slightly. Digitized sounds takes a lot of memory but slows the animation only 
slightly. However, Macintalk (speech) requires quite a lot of memory and processing time. In 
fact, all animation stops cold when Macintalk is speaking. So design Macintalk to be happening 
when there is no action on the Stage. 
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_ Animation Techniques (VideoWorks) 
Plan ahead, with foreground priority in mind. Reserve channels 1 for background art. 
You might start the foreground art at channel 3, leaving channel 2 open in case you should want to 
go back and put in other art just in front of the background. There's absolutely nothing wrong 
with skipping channels when creating a movie — that's why we give you so many channels to 
work with. VideoWorks lets you swap channels easily if you need to. 

When using text in your animations, be sure that the text remains on the 

screen long enough to be understood by the viewer. You should consider, for 

example, that as the creator of the text, you will have read it many times and so may tend to 
underestimate the amount of time the viewer may need to read it. Consider also that if you have 

movement on the screen while the text is displayed, the movement may distract the viewer from 

reading the text. 

To achieve maximum smoothness in your animations, use the Tweak and 

Constrain functions. (This will help you move clouds smoothly across the screen, for 

instance.) The Constrain function is accessed by holding down the Shift key, and works just like 

Constrain in MacPaint. 

Do some sketching in Paint with stick figures before creating your final 

castmembers for movements that require a series of changing castmembers, 
such as a person walking. Do this to see if you can get by with fewer castmembers for a 
given movement. Conversely, if your animation appears choppy, you may need to create 

intermediate castmembers. : 

Don't hesitate to consult your mirror or your friends when producing facial 

features to make your animations appear as real as possible. Model your 

animations upon real life. 

Synchronize your sounds and animation. If, for instance, you go from a screen of graphs 

‘to a screen of charts, add a little musical ditty at exactly the frame that the screen changes to 

enhance the transition. 

Transient sound effects (BDrum, LTom) cannot be strung together to make one 

longer, continuous sound. In fact, you must put a blank frame between them in the sound 

channel to allow them to retrigger. Longer, steady sounds such as explosions, can be strung 

together in the sound channel to continue for as long as you want. 

Switching an Entire Series. A powerful way to use Switch Castmember is for replacing 

not just one frame of art, but an entire series of frames all at once, such as a background. You do 

this by selecting the series of cells in the Score, selecting the new castmember in the Cast, and 

choosing Switch Castmember. 7 : 

- Momentarily suppressing the selection box around artwork. If you are working on 

the Stage and have a very small piece of artwork selected, it is often very difficult to see the art 

itself because the selection box around it (with the handles) overwhelms the small artwork. You 

can momentarily suppress the selection box by opening the Score, and holding the mouse button 

down on the Playback Head. 

It's fairly easy to create a sequence where artwork moves smoothly across the 

screen. Use the In-Between command to quickly produce a smooth, straight-line motion. You 

choose the artwork at the endpoints, and the In-Between command fills in the intervening frames 

for you. | 
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It's easy to scroll text up the screen, like credits at the ‘end of a movie. This is an 
interesting way to introduce a name, slogan or text to the viewer. It is useful for a self-running 
demonstration, or simply as a change of pace in a movie. See Tutorial #7. 

It's easy to convert an animation to a black background. Turn the lights off by 
clicking on the light switch in the Panel, then select the artwork in the Score and apply NotCopy 
from the Ink menu. (For more advanced transparency or different effects, try Xor). | 

Don't hesitate to borrow animation sequences you particularly like from the 
"Clip Animation, Artwork and Movies" disk. You can combine these with original 
animations by copying from one file to another. 

You can easily create shapes that have dynamically changing patterns as they 
move across the Stage. You use QuickDraw shapes and change the pattern at each frame. 
This is a special effect with a lot of dazzle, yet with very little expenditure of memory. You can 
also change the line thickness at each cell. Notice that you cannot do this with Paint artwork 
unless you create a new castmember for each new pattern, which uses a lot more disk space and 
memory. 

Artwork Techniques (VideoWorks) 

262 

Animate business presentations using chart and graphs from Excel, Works, 
Illustrator, Power Point, Cricket Graph and other products. Anything that can be 
copied onto the Clipboard (or Scrapbook) can be pasted into the Cast or Overview. 

Use art from the "Clip Animation, Artwork and Movies" disk supplied with 
VIDEOW ORKS II (or other art disks on the market such as clip art) to create your own 

animations. 

Use a video digitizer to add real-world pictures into the VideoWorks Cast and 
an audio sampler to add real-world sound to the Sounds menu. Once these are in 
VideoWorks, you can animate or combine them with your own artwork. 

The quickest way to copy an entire image from one easel in Paint to another is 
to go outside Paint to do it — use the Cast instead! Select one position in the Cast, 
Copy it, select another position in the Cast and Paste into it. 

You can stretch or shrink any art on Stage by pulling its handles. Paint artwork 
can distort noticeably when you change its size You can also create a sequence where the art starts 
small and grows, even as it moves across the screen. This is a good use for In-Between. Follow 
the procedure "How to Stretch Artwork As It Moves." This works for bit-mapped objects as well 
as QuickDraw Shapes (but not for text from the Text Window). 

In the Paint window, you can create a background as big as you want — it can be 
5 feet wide by 2 feet tall. You can then scroll this elaborate background during the animation, for 
instance to show motion. Do this by opening the Paint window, clicking on New Easel, and 
dragging the easel larger than the Paint window. You will need to scroll the Paint easel in order to 
do this. (Of course, when an easel is this large, you cannot see the entire easel all at once.) 

Use different Inks in the Paint window for interesting effects — For example, use 
Bic or Xor ink when typing text in the Paint window. Try using Xor with the Paintbrush, or the 
Rectangle tool. 
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For Advanced Users (VideoWorks) 

Copying and Pasting a Sequence. When you copy a sequence from document A and paste 
it into document B, VideoWorks will ask for document A when you perform the paste. This is 
because the Copy operation copies the castmember numbers rather than the castmembers 
themselves to the Clipboard. At the time of the Paste, access to the castmembers themselves is 
needed. Therefore, do not alter, rename or destroy document A until you have pasted the sequence 
into document B. 

You can automatically capture rotated shots of 3-dimensional art (in Easy 3D 
or Super 3D, for instance), by using Tempo. Tempo is a program which allows you to 
automatically repeat command sequences. You record a sequence to repeatedly (1) rotate the object 
and (2) save it to the Scrapbook. You can walk away and come back hours later when its job is 
completed. If you were to rotate an object through 360 degrees at 5 degree increments, that's 72 
shots to be captured. Once you've done this, you can paste these 72 shots into the Cast from the 
Scrapbook. , 

It is possible to view all 24 channels in the Score at once. To do this, first click 
on the box in the upper right corner of the Score to make it full-screen. Then double-click on the 
Expanded button in the upper /eft corner of the Score. De-select all options but one. You should 
now be able to see all 24 channels. This is great for a quick overview of all channels. 
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Frequently Asked Questions 

Q. 
A. 

264 

> 

> 

I can't find artwork that I put on the Stage 

If you can't see artwork on the Stage, try these: 

1. Look to see if you're using a clear ink mode, such as Bic. The artwork might be there 
but just invisible. Open the Score, switch to the ink display and check. For more 
information, refer to "Using Inks" in "How to Animate." 

2. Look to see if the artwork is hidden behind other artwork. If so, you can click on its 
channel indicator, which selects the artwork on Stage and allows you to re-position it. 

3. Maybe it's behind a window, such as the Cast or Panel. Press Command-1 to clear the 
windows from the screen and press Command-1 to bring them back. 

. When I am looping on my movie, why does it go blank at the end? 

This happens because there are blank frames at the end of your movie. This occurs when you 
have removed a sequence from the end of your movie — yet the movie continues to play as far 
as it used to. To remedy this, clear those frames from the Score as follows. 1. Start at the 
end of your animation and select the troublesome "blank" cells by dragging to the right across 
the frame numbers at the top of the Score. 2. Choose Clear Score from the Edit menu. 

. Why doesn't cut and paste in the Score work like a word processor? 

What you're referring to is the fact that when you select part of the Score and choose Cut, the 

frames to the right do not move in to close up the gap. Actually Cut will close up the gap if 

you are cutting or pasting across all 25 channels (the quick way to select across all channels is 

to drag along the frame numbers at top). See "How to Insert and Delete Time In A Movie" in 

the "How To Animate" section. 

. Where did my Sound menu go? Nothing happens when I try to pull it 

down. 

A. This means your Sounds file is missing. The Sounds file contains the sounds that accompany 

any animation. Locate the Sounds file and put it in your System Folder, or the folder with 
the VIDEOWORKS II program, or the folder with your movies. Also refer to "Sound Files" 
section at the end of the VideoWorks Reference. 

. I moved one of my castmembers from position All to A21 and now it's 

gone from my movie. 

A. VideoWorks keeps track of castmembers by their position in the Cast window (..e. their 

castmember number). If you move artwork from A11, the Score keeps looking at position 

A11 for that artwork. If you want to move a piece of artwork to another place in the Cast, 
follow these steps: 1. Copy and paste the castmember to its new position in the Cast 

window; 2. Select all the places in the Score that refer to that castmember and Switch 

Castmember (in the Edit menu) to the new position; and 3. Clear the castmember from its old 

position. 
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Shortcuts 

Shortcut | What it does 

1. General 

Numeric Keypad 

26 Se ee ee ae ee ee Step 

Save Changes? Dialog Box 

~t 

=f 

a 

mi 

m 

~~ ae eet NN es ete We 

4 

4 

anc 

4 

2. Overview 
init gis peers ree err ee Goes directly to Stage and plays slide show 

© Shift-Step.........seeeeseceeseseseecensessesceseeweseesenenean sees Replays the current slide 

Step while playing ............ssescecesseceeneeseeeeeesseneecees Immediately advances to next slide 

Click MouSE ON Stage..........eseseseeeesseessseseeseseeeeeee Advances fo next slide (same as Step) 

Shift-click MOUSE ON StaGe .............ceeceveseeeeeceeerees Replays the current slide 

Pressing SPACCDAL .........ccscceescnseecsecceneseeeeeascenaeeenes Toggles pause/resume of animation 

Click playback head ...........cceseceeseceesseseeneenesseneeees Displays that slide in Overview 

Option-Drag ICOM ..........scceeeeeeeneeeceeneeeteneesenaeceees Duplicates icon 

Commiand=Cick [COs i206 aoc occ bastese ser ete catese tens Selects whole column 

Double click ON ANY ICON ..........cceceeserecnee eee ee sooner Equivalent to Get Info 

Backspace Selected 1COMS ........sssceeseeceseseeeneeneseene noes Deletes them in Overview window 

‘Bic ge alee eee re ee er Selects single icon 

Commiand-Click OM 1COM..............ccceseeeseeeeseeeeseneens Selects column of icons 

Shift-CHCK On: “HCOML. cis. iceeeeccccest das es veqecesrescoanes Selects several icons 

Draw a Selection rectangle around ICOMS ...........+.s000+ Selects lock of icons 

3. VideoWorks 

Recording 
Option-click on artwork ON Stage..........sceeeeeeeeeeeees Toggle record light on or off 

Option-click in channel indicatOr ...........ceeeeeerseeeeees Toggle record light on or off 

Option-Command-drag mouse ON Stage ............0000 Real time record artwork selected in cast 

Creating a Film Loop: 
Select sequence in score (one channel only) | 

Copy or Cut 
Paste into an empty castmember (must keep original castmembers in cast). 

Shift-In-Between. -or- 

SHif -COmnanG= G5 scs ve coe nce canesus cease cnt eruesoeesseeser In-Between on Film Loop selected in 

Cast window 

Panel | 

SEP Dyn cocis ce ose cs cade we eee a rac rctean tener os ames enone Goes directly to Stage and plays animation 

SECT) vsscersctvsseesecsuceceteredecsesnausarsessyresasmacvsenecccness Will record if Record Light on 

Drag up or down in Frame Indicator ...........sseeeeeeeeee Advance or reverse action of animation 

a Click and drag on selection indicators .............e+esc60 Establish selected frame range 

uke | Click on Channel indicator ............ccccccceeeesssseeseeeens Select channel 

: Option-click on channel indicator ..........seeseeeereeeeeee Turns record light on 
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Shortcut | What it does 

score 
Double click channel number ...............ccccccccceeeee ees Selects all frames in an entire channel 
Double click channel number and drag ................06+ Selects all frames in multiple channels _ 
Drag across frame NUMDEIS ..... cicccseceiscsssavessecanssees Select all channels for those frame numbers 
ShEEL-Click “Or Irae — «scien case Ss svcprss eencsass ce aie Select a large section or extend a selection 
TEE AU spk fev ee Scrolls window to Playback head | 
Opi = FT OO cass ce cny ca cgneest ccna csesne oe taess Scrolls window to first selected frame 
Click in playback head Dal... <..v.cssscgetesciacs seocterss: Move Playback head to that frame location 
Diag Diy back To . .viccecstitscs cee ees Move forward or backward through animation 
ZOOI PAIOTE 5 cs overs tee a Enlarges display of frames 
Selecting a frame in the Score Selects the object on the Stage 

alc 
Display Indicators: 

Relative motion indicator switch ...............cccee Shows the position of a castmember in 
ee er seseeessceeecseeeeeee Felationship to its position in the previous frame 
Ink HCA OE SWIC 2 cisg x oenc ccna deed acne esscstcussess Shows what inks (Copy, Or, Matte, etc.) 

are being used : 
Castmember number indicator switch ................. Shows what castmembers are being used 
Expanded information indicator switch ............... Shows several types of info at once 
Double-click Expanded Info switch .................06. Select types of info to display 

Stage 
SHEE E ey 5 as, a ee ccs Select multiple pieces of artwork 
Slit eyaarar i Sea, Snes Constrains movement horizontally or vertically 
Click & drag resize handles ....... Leoscscscecsceeescscecedes TReSIZe artwork 
Shift Click & drag resize handles: .....6.....cccncassecsoeses Resize proportionatly 
Click on Playback Head in SCOre 2.....2.........0cessscves Temporarily removes selection boxes on Stage 
Backspace Gy 56 ass os ses i een Same as "Blank From Stage" 
Command-click artwork on Stage ..............ceeeseee eee Opens Paint window and corresponding easel 
Selecting artwork on the Stage .............. = Selects it in the Score 

Cast ; 
Double click in Cast Window ...........0sccscsssscecsssseees Equivalent to "Switch castmember" 
Selecting castmember in tbe Cast ...............eceeeeeeeee Selects corresponding easel in Paint 
Selecting an easel in Paint ............... ita oe Selects corresponding castmember in the Cast 

Artwork may be directly pasted into the Cast (helpful with large pieces of artwork). 

Cast members can be duplicated by copying a castmember and pasting into an empty castmember. 

When creating a custom mask, always paste the duplicate castmember in the position directly 
following the original. 

Color | 

Option click in Color WindOW .............csceeeeesceeeeees Sets background color 
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1 OU AAA 

Shortcut 

Paint 

El Easel 

Magnifying glass 

Paint brush 

Pencil 

Eraser 

ONO Rectangle and circle 

Line 

Airbrush 

Marquee 

Miscellaneous 

What it does 

Click on icon _ ..................+...--Creates new easel 

Chek ON 160-30 tases eres Opens Fatbits 

Houble click 1cen =< <s.s2s-sisoe4s. ss Selects brush shape 

Select pattern from Draw menu in which to paint 
Painting can be constrained by holding down Shift key 

Double-Click 1CONn .............0cseee00 Opens Fatbits 

Drawing can be constrained by holding down Shift key 

Double click 1CoM ................2ee008 Erase entire easel 

Select font, size, style, from Text menu _ 

Select fill pattern and line thickness from Draw menu 

Shape constrained to circle or square by holding down 
Shift key 

Select thickness from Draw menu : 
SJaNe) eh 2 ee ee ee Constrains horizontally, 

ee Se vertically, or at 45° 

(Settings can be altered on the fly) 

Air Pressure: 
Oe Light 
Peas ee es Medium 
Be ee re ee ee Heavy 
fe ee eee Maximum 

Spray Size: 
eS | eer ee 1= smallest, O=largest 

Bia eas oceans nets Change spray size by one pixel 
Spray Pattern: 

Backspace As....ces0cns Alternates black and white 
Option (a3 a. eis. Randomize 
Select pattern from Draw menu 

Double click icon ........... Selects entire visible area of easel 

Sit key ee Selected area is a square 
Command key Stretches the selection 

Press ~ (tilde) key ........... Equivalent of undo in Paint 
Cie os oes ere ee Constrains all drawing tools 
Command-click ............ .Toggles Fatbits on and off 

Reference: Shortcuts 267 



268 Reference: Shortcuts 

tanta) 
FHYSICS 

Pn em mn mom ma mom om ae ay 



Sound Files 

The following two files are important for the operation of sounds in VIDEOWORKS II. They are 
both present on your VIDEOWORKS II Program disk. 

e The Sounds file contains the sounds that are available at the Sound menu. When the Sounds 

file is not present, in fact, the Sound menu will not pull down. 

¢ The Macintalk file is necessary for making Macintalk work. 

Sounds File and Macintalk File | 
Sound and animation are always stored in separate files on your disk. The Sounds file contains all 
of the sounds in the Sound menu. Therefore, when you copy a movie file to another disk, be sure 
to copy the Sounds file along with it. When using digitized sound or Macintalk, the Sounds file 
can actually be larger than the graphics portion of the animation. 

You can customize your Sounds file by adding sampled sounds or MusicWorks melodies to it. If 
you have a movie that uses a customized Sounds file, you should think of the Sounds file as just 
part of the movie. When you move the file to another location, you should be sure to transfer the 
customized Sounds file along with it. It's easiest to keep them both in the same folder and just 
move the folder. : 

Required Location of Sounds and Macintalk Files 
The Sounds file and Macintalk file must be located in certain folders in order to work: 

File Must be located in 

lat tal tat iat Val bob lab lat dab UY UAL Et bk 

Macintalk System Folder or 
VIDEOWORKS II folder or 

Macintalk ! Same folder as movie 

Sounds System Folder or 
-~ VIDEOWORKS II folder or 

: Same folder as movie 
Sounds 

When the Macintalk file is located in the correct folder, the menu item "Macintalk" appears in the 
Sound menu. Similarly, when the Sounds file is not located in the correct folder, the Sounds file 
will not pull down. 

Using More Than One Sounds File 
If you customize your Sounds file, you can create several different ones for different movies. You 
can use as many Sounds files as you want as long as you put each Sounds file in a separate folder 

along with the movies that use that Sounds file. 

If a movie is in a folder that has no Sounds file, VIDEOWORKS II will look for it in the following 

order: 

1. Folder containing the movie 

2. VIDEOWoRKS II folder 
3. System Folder 
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Troubleshooting the Sounds 
If you cannot get Sounds to work, try these: 
1. Check that the Sound menu actually pulls down. If it doesn't, that means VideoWorks cannot 

locate the Sounds file. The Sounds file is probably not in the correct folder — it should be in 
either the folder with VideoWorks (player or program) or the System Folder. 

2. Check that the sound is turned on at the Panel in VIDEOWORKS II. The loudspeaker icon 
should be white on a black background. 

3. Check to see if any sound has actually been assigned to the sound channel. Open the Score, 
click on the Castmember Display Button and look in the sound channel to see if sound is 
assigned where it should be. You can identify the sound by its number. 

Troubleshooting Macintalk 
If you cannot get Macintalk to work, first check to see if sound works at all by doing steps 1 and 2 
from the previous procedure. If Macintalk still doesn't work, try these: 

1. Make sure the Macintalk file is in the System Folder or the folder containing 
VIDEOWORKS II. 

2. Check to see if you are using a castmember position in the range A71 to A88. 

3. If Macintalk still doesn't work, try removing any special symbols (%, $, !) from the text. 

VW Preferences File 
A file named VW Preferences is automatically created by VIDEOWORKS II when needed, and is 
therefore not a file you need to worry about. (It is unrelated to sounds.) = 

The VW Preferences file stores settings that you specify in the Preferences menu item in the 
_ Control menu. This file stores the information you set in Preferences dialog box, as well as a few 

other things. These include: your current choice of Long or Short menus, screen size, window 
positions, auto-save of Overview documents. It saves the launch application creator types for 
MacPaint and MacDraw documents in Overview. It also saves whether you were last working in 
VideoWorks or Overview and opens that application when started by double-clicking the 

VideoWorks icon. 
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Glossary 

This section includes definitions for words used in VideoWorks, Overview and animation in general. 

activate 

active window 

alert box 

animation 

animation stand 

application 

art 

artwork 

ASCII 

backup disk 

button 

castmember 

castmember 
number 

cel 

cell 

chaining 

Same as select. To specify which castmember, artwork, channel or cell will 

receive the next command or set of commands. 

The frontmost window on the desktop; the window where the next action will take 
place. An active window’s title bar is highlighted with parallel lines. 

A box that appears on the screen to give a warning or to report an error message. 

A series of static images which, when presented in rapid succession, create the 
- illusion of movement. The images can be recorded in analog form on a filmstrip, or 

digitally on a floppy disk. 

A device invented in the 1930's for creating cartoon animation. It consists of a 

special animation camera for exposing one frame at a time, and several pieces of 

glass on which are laid cels (the individual pieces of art that make up the film 

animation). 

A program written for some specific purpose, such as word processing, data base 
management, graphics, or animation. 

Same as artwork. 

Any picture. It can be created in Paint, it can be a geometric primitive, or it can be 
brought into VideoWorks using Art Grabber+ or the Clipboard. Same as aft. 

ASCII is a worldwide standard for representing text as numbers, rather than as bits. 

A copy of a disk. It’s a good idea to make backups of all your important disks and to 
keep them in a safe place. | 

A rectangular region (like the Yes, No and Cancel buttons shown to the left ) in 

dialog boxes where you click to cause an action to occur. See also mouse button. 

A member of the Cast. Each different piece of artwork that appears on Stage is a 
castmember (except QuickDraw shapes). 

The number that appears below the castmember in the Cast. 

(Short for celluloid) A transparent sheet of celluloid acetate on which drawings are 

laid. Cels are used in film animation, not in computer animation. 

(Same as frame cell.) One frame of a channel. (This is in contrast to cel with one 
se 

Chaining is what happens when you use paste relative. Each paste creates a chain 

with the last piece of artwork, which is technically called a relative offset. 
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channel 

chunk | 

click 

clip animation 

close box 

column 

computer 
animation 

current frame 

cursor 

cut 

delay 

dialog box 

dissolve 

double-click 

drag 

easel 

e 

A row in the Score, where artwork resides. A VideoWorks movie has 24 channels 

for pictures and 1 for sound. Each channel corresponds to a piece of artwork 
displayed on the Stage at any one frame. | 

Chunk is the amount of pixels a transition moves. You can manually set how big a 
chunk is for every transition with Get Info. See delay. 

To briefly press and release the mouse button. 

Small, independent animation sequences that can be used with any type of 
presentation material. The clip animation is inserted in front of a slide in Overview. 
More than one clip animation can be shown at the same time. 

The small white box on the left side of the title bar of an active window. Clicking it 
closes the window. 7 

A set of icons in an Overview document arranged in a vertical column. 

A form of animation which uses high-speed manipulation of computer artwork 
to create images moving and changing shape. 

The frame which is currently displayed on the Stage. The current frame number is 
shown in the frame counter in the Panel. In the Score, the Playback Head points to 
the current frame. 

A vertical bar displayed on the screen marking where the user’s next action will take 
effect or where the next character typed from the keyboard will appear. 

(1) The instantaneous change from one scene to another. (2) A command in the Edit 
menu for removing a selection and placing it on the Clipboard (written as Cut with a 
capital "C"). 

Delay is the amount of time (in 1/60's of a second) to pause between each chunk in a 
transition. Setting the delay will control how fast'a transition occurs. See chunk. 

A box that contains a message requesting more information from you. 

An effect in which one scene gradually fades out at the same time that a second fades 
in. 

To press and release the mouse button twice in quick succession without moving the 
mouse. If your clicks are too far apart, they will be interpreted as two single clicks. 
You can adjust the speed at which you must double-click by choosing Control Panel 
at the Apple menu. 

To position the pointer on an object, press and hold the mouse button, and move the 
mouse. When done moving, release the button. When you drag, it is important to 
hold the mouse button down while moving the mouse. You can drag the pointer 
across frames in the Score to select them, or drag an object across the Stage to a new 
location. 

A window in Paint in which you can draw artwork. You create a new easel by 
clicking on the New Easel tool . It's icon is shown below. 

| 
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rc 

a 

Re A 

edit 

film animation 

file 

font 

foreground 
prioritization 

frame 

frame cell 

Get Info 

held artwork 

icon 

import 

To change or modify. For example, to insert, remove, replace, or move artwork in 
an animation. : 2 

A form of animation where a camera shoots pictures of a physical setup, one frame at 
atime. The film must then be developed and printed before the animation can be 
previewed. Contrast to computer animation. | 

Any document stored on a disk. VideoWorks and MacPaint files are examples of 
files. You make a file when you create a document, give it a name, and save it to 
disk; in this sense, file is synonymous with document. 

In computer usage, the set of letters, numbers, punctuation marks, and other 
typographical symbols having the same typeface (such as Times, Helvetica, New 
York, Geneva). The size (10 pt, 12 pt) and style (bold, italic) can be changed readily. 

A method of defining which piece of artwork is in front of other artwork on the 
Stage. VideoWorks uses channel numbers in the Score to determine this priority — 
ranging from channel 24 in the foreground to channel 1 in the background. See 
multiplane ; 

One individual "snapshot" of the entire animation, as viewed on the Stage. A frame 
includes both the pictures and sound. A frame in the Score is represented by one 
column that spans across all 24 animation channels and the sound channel. One 
movie might be hundreds or thousands of frames in length. The frames are numbered 
across the top of the Score, starting at 1. Also see current frame. 

(Also called a cell.) One frame of a channel. The Score is composed of hundreds of 
-cells, each one channel tall and one frame wide. Each cell is the snapshot of a single 
castmember for one moment in time. 

Get Info is the command to open up the dialog box associated with each document 
type (and transition) in Overview. Get Info on VIDEOWoRKS II documents allows 
you to set timing, location and loop settings, with GLUE documents it allows to to 
set which page displayed. Get Info on transitions opens up the transition window. 
With MacPaint or PICTs it allows you to set (or move with a hand tool) the location 
of the slide. © : 

(Also known as stationary artwork.) Artwork that stands still on the Stage as the 
movie is running. For example, background can be held. In a simple animation of a 
person talking, the face could be held while the lips are animated. In film animation, 
this is called held cel. Held artwork can be created easily with In-Between. See In- 
Between. 

A graphic image that represents an object, a concept, or a message. For example, a 
MacPaint is shown below. 

tn 
To bring artwork or text into VideoWorks from another program. You can import 
using Art Grabber+, the Scrapbook, or the Clipboard. 
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in-Between 

Macintalk 

mask 

matte 

menu bar 

mouse button 

movie 

multiplane 

pixel 

pointer 

Real-Time 
Recording 

registration 

scene 

Score 

scroll bar 

e 

A feature of VIDEOWORKS II which simplifies the animator's task by filling in the 
frames between the beginning location and the end location of an animation sequence. 
In-Between is also used for extending held artwork, and sliding (and stretching) 
artwork between the points. This feature is available at the Edit menu. See held 
artwork. 

A speech-generating program that allows the Macintosh to convert typewritten text 
to spoken English. 

An opaque image used to block the view in one area, but with holes that allow the 
image to be viewed in other areas. An example is a mask of a car with holes for the 
windows, which allows you to view the background through the windows. 

An ink that allows artwork to appear without the white box around it. 

The horizontal list of menu titles at the top of the screen (File, Edit, and so on). 

The button on the top of the mouse. You can click or double-click the mouse button 
for different actions. 

A VideoWorks animation, saved to the disk in its own file. In the illustration 
below, each icon represents a movie. The terms file, document, movie and animated 
slide show are loosely interchangeable. 

Traditional term for animation stand based technology. The channels in the 
VideoWorks Score can give you a 2 '/2D effect by enabling artwork to move in front 
of and behind other artwork. This effect is called a multiplane effect. 

Short for picture element, a pixel is one dot of a screen image. On the Macintosh it 
is 1/72 of an inch square. — 

The arrow (or vertical bar or other — that moves around on the screen with the 
motion of the mouse. 

A method of computer animation used by VIDEOWORKS II in which the mouse 
movement is recorded to create an animation sequence. That recording automatically 
appears in the Score. 

The positioning of artwork to align it with other artwork. You can easily change the 
registration with the Registration Point in Paint. 

The action on Stage. You can clear the VideoWorks movie of all action with the 
command Burn Scene — which leaves the Cast unchanged. 

A VideoWorks window consisting of 24 animation channels plus one sound channel. 
The Score displays in one convenient place information about the entire movie, 
whereas the Stage displays only one frame at a time. The Score is a notational editor 
for animation, displaying the animation information left to right through time, 
somewhat like conventional music notation. 

A narrow rectangular bar appears along the right or bottom of some windows. 
Clicking or dragging in the scroll bar or dragging the scroll box causes your view of 
the document to change. 

) 
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Stet tet tal tat 

scroll box 

select. 

select 

selection 

sequence 

Shift-click 

slide 

sprite 

Stage 

switch 

sync 

synchronization 

take 

timer 2 

title bar 

The white square box ina scroll bar. The position of the scroll box in the scroll bar 
indicates the position of your view in the window relative to the entire document. 

To highlight an object so that you can move, cut, copy or paste it. For example, 
you can select a window (to make it active), select art on the Stage (to move), and 
select frames in the Score (to cut and paste). 

To specify which item on the screen will be subject to the next command. The 
object then is highlighted by turning black, showing a flashing cursor, or outlined 
with a solid or dotted line. For example, you can select artwork on the Stage, a 
castmember in the Cast, or a channel in the Score. Once an object is selected, you 
can Copy, Cut, Paste or Clear. (Also see activate) 

The artwork, text or frame cells highlighted, to be affected by the next command. 

A series of pictures. For example, a frog leaping, a person walking, a ball bouncing, 
or text scrolling across the screen. More formally, a sequence of art is any series of 
frames in one channel of the Score. When we use the term sequence, by itself, it 

means sequence of art. 

To press and hold the Shift key and then click the mouse button. This technique 

allows you to extend or shorten a selection. You position the pointer at the end of 

what you want to select and Shift-click. 

Any still picture, such as MacPaint, MacDraw, Glue or single-frame VideoWorks 

document. 

Any one piece of artwork at one point in time. Sprites are meant to be pieces of 
_ artwork that move. It is a term used by videogame programmers. 

The background window where animation and artwork is displayed what appears here 
is determined by the current frame in VideoWorks or thecorrect slide in Overview. 

In VideoWorks, switch means to replace artwork on the Stage with a castmember 
from the Cast. 

See synchronization. 

The relative positioning of sound and pictures so that they are timed together. 

Indicates the number of times a given has been recording made-for example, Take 1, 

Take 2, etc. 

_A special icon in Overview that is used for setting the time of delay (in seconds) for 
slide columns. The timer can also control the length of time that a clip animation 

(or movie) is displayed. 

The top part of a window that is highlighted when the window is active. It contains 
the name of the document or the name of the window. 
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transition 

tweak 

tween 

vector 

wipe 

8 

A special visual effect which occurs between two different frames (in VideoWorks) or 
columns (in Overview). There are a total of 24 different transitions included with 
VideoWorks. You can also control the delay or chunk size of the transition. 
See chunk and delay. 

Tweak means to move a small distance. The tweak window lets you move artwork 
on Stage a distance and direction you specify (measured in pixels). 

From the word "between." Filling in movements between frames A and B with art 
that changes shape (see also In-Between). VideoWorks cannot do true tweening. 

A quantity that has both distance and direction, usually represented by a straight line. 
The Tweak window contains a vector you specify to define distance and direction. 

An effect whereby scene A is wiped off the screen by the progressive revealing of 

scene B. 
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Suggested Reading 

If you wish to pursue your study of animation further, we recommend the following books: 

General Information 

The Animation Book, Kit Laybourne, New York, New York: Crown Publisher's 

Inc.1979. A general reference on animation techniques, methods and history. 

Microcomputer Displays, Graphics, and Animation, Bruce A. Artwick, 

Englewood Cliffs, New Jersey: Prentice Hall, Inc.,1985,1984 - A good technical primer on 

computer graphics and animation. 

Computer Animation Primer, Fox, David and Waite, Mitchell. New York, NY: 

McGraw Hill, Inc., 1984. 

Electronic Imaging Techniques, Levitan, Eli L. New York, NY: Van Nostrand 

Reinhold Company, 1977. 

Technique 

A former Disney animator presents basic animation techniques in these two how-to books. 

Animation: How to Animate Film Cartoons, Preston Blair, Laguna Beach, CA: 

Walter T. Foster, 1980. 

Animation: Learn How to Draw Animated Cartoons, Preston Blair, Tustin, 

California: Walter T. Foster, 1985. 

In the late 1870s, Muybridge cataloged the movement of humans and animals in thousands of 

photographic sequences. The following two books are an invaluable reference source for 

animators. 

Muybridge - Man in Motion, Haas, Robert Bartlett. Berkeley and Los Angeles, 

CA: University of California Press, 1976. 

Muybridge's Complete Human and Animal Locomotion, New York, NY: 

Dover Publications, Inc., 1979. 

Historical Animation Books 

Disney Animation: The Illusion of Life, Frank Thomas and Ollie Johnson, New 

York: Abbeville Press Publishers, 1984. - An extensive survey of Disney animation. 

Written by two of the top Disney animators, this book describes the development of the 

Disney style of animation. | 

Treasures of Disney Animation Art, Walton Rawls Ed., New York: Abbeville Press 

Publishers, 1982. - A selelction of classic Disney animation artwork. 

The Art of Walt Disney, Finch, Christopher. New York, NY: Abradale Press, Harry 

N. Abrams, Inc., 1983. | 

Paper Movie Machines, Budd Wentz, San Francisco: Troubador Press, Inc., 1975.- A 

combination history and How-To book. It includes the plans for flip books and other non- 

camera animation devices. 

a 
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Creators of Life — A History of Animation, Heraldson, Donald. New York, NY. 
Drake Publishers, Inc., 1975. 

Magazines 
Computer Graphics World, Littleton, Mass., PennWell Publishing Co. 

Millimeter, Cleveland, Ohio, Penton/IPC, Inc. Publisher. 

American Cinematographer 

Cinefex | 

Computer Picture, New York, NY, Backstage Publications, Inc. 

IEEE Computer Graphics and Applications, New York, NY, IEEE Computer 

Society 

Verbum, San Diego, Ca, Donovan Gosney, Inc. 

Whole Earth Software Catalog, Garden City, NY, Quantum Press/Doubleday 

Technical Journals 
SIGGRAPH proceedings 1975-1987, Computer Graphics, New York, NY, 
Association. for Computing Machinery 
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Biographies 

Marc Aaron Canter — MAC 

Marc Canter is the president and co-founder of MacroMind. His background is in music, video, 
lasers, dance and theater. He is a graduate of Oberlin College and has published several articles on 
MacroMind's authoring systems. He is responsible for running around the country making sure that 
everyone knows about MacroMind and VIDEOWORKS II, and he gives one of the best demos you've 
ever seen. You can sum up Marc's position at MacroMind as “He does everything there is to ure 
done, but program." 

Marc's dreams are confined to making MacroMind strong and implementing its technology 
throughout the creativity business. Advertising, Entertainment and Training are the markets Marc 
has decided to focus on in the next few years. So if you're part of any of those industries, get ready, 
Marc's coming! 

a i a lt BE 
Erik Neumann 

Erik is an engineer by temperament, a computer scientist and MBA by training, and a musician on 
the side. At Oberlin College he first came in contact with computers (falling in love with the 
elegance of the programming language APL) as well as electronic music. Since then he has worked 
as a mainframe programmer in various industries, finally turning to microcomputers when they 
became interesting enough (i.e., when the Macintosh was released). He knew Marc from the Oberlin 
electronic music days, and has worked on various MacroMind projects since joining the company in 
1985. He can often be heard in clubs and galleries around Chicago playing electric fuzz cello. 

‘Dan Sadowski 
Within his electronic cottage in Oak Park, on. the western reaches of Chicago, Dan develops graphic 
software on the Macintosh for MacroMind, Inc. He didn't always do this. In fact, before MacroMind 

existed, besides transporting yachts up and down the eastern seaboard from Canada to the Caribbean, 
or along the Erie Canal, Dan was busy acquiring his B.S. and M.S. degrees at the University of 
Illinois, Chicago Campus. Along the way, Dan married a fellow computer graphics addict, Patti 
‘Harrison, gave up the sea and has spent the last three years consulting in the computer graphics field. 
When not programming or bicycling, Dan and the little Ms. spend their time creating and 
maintaining the next generation of software engineers. 

\ 

Alan McNeil 

Alan has a love/hate relationship with computers. After many degrading experiences with IBM 1620 
and IBM 360 consultant-priests, he decided that programming was not for him. After dipping into 
Architecture, Industrial Design, Film, Animation, Photography, and Video, he was running out of 
gadgets to master in the Art and Architecture building when CDC’s PLATO, a great network game 
machine, came to campus. He was hooked. Then came the MITS Altair, the machine that started 

the micro revolution. Alan got one right away. 

After spending a year running the first computer store in Illinois, he joined the video/pinball game 
industry hoping to make lovable home computers. His successes include the design and 
programming of Stern Electronics’ classic arcade hits Berzerk and Frenzy, as well as work on 
Midway’s SeaWolf II, The Bally Arcade and many Stern pinball games. When the Mac came out in 
1984, Alan was again one of the first in line to buy one. As a private consultant he programmed the 
Mac version of Epyx Winter Games, ODS Consultant, MazeWars+ and GraphicWorks. 

_ Alan likes the Mac because it’s a pinball game disguised as a computer and no blue suit is required to 
operate it. Stat tat ted tet let at lot tat lat tat law Lat 
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Product design: Marc Canter, Erik Neumann, Jay Fenton, Alan McNeil, Dan Sadowski 

Programming: Erik Neumann, Dan Sadowski, Alan McNeil, Jay Fenton, Tom Ptak 

Manual; Doug Kramer 

Manual assistants: Ann Elfline, Eric Larson, Erik Neumann, Eliot Axelrod, David S. Canter, 

Devorah Samet Canter, Letran Tran, Marc Canter, Stuart Sharpe 

Tutorial designs: Erik Neumann, Doug Kramer, Ann Elfline 

Guided Tour disk: Stuart Sharpe, Jon Petit 

Sound: Stuart Sharpe, Marc Canter, David Theil 

Clip animation: Stuart Sharpe, Jeff Lee, Roy Santiago, Darnell Williams, Jon Petit, Tommy 

Marcus 

Artwork: Stuart Shame: Jeff Lee, Roy Santiago, Mark Pierce 

Movies: Stuart Sharpe, Mark Pierce, Erik Neumann 

Manual artwork: Stuart Sharpe, Roy Santiago, Tommy Marcus, Mark Pierce 

Manual illustration: Eric Larson, Ann Elfline 

Management: Marc Canter, Eliot Axelrod, Erik Neumann 

Package design: Stuart Sharpe, Roger Jones, Marc Canter 

Package production: Roger Jones 

Original manual (excerpts): Nicholas Lavroff 

Click Art Effects™: Bill Parkhurst 

Shift-Command-6 FKey: Joe Miller 

Thanks to: 

Home front: Devorah Samet Canter, Katherine Mitchell, Patricia Harrison, Karen Chesna 

McNeil, Mary Daugherty, Jane Larson, Lynne Karey, Susan Freidewald, Mary Ptak 

Financial front: Leon Samet, Joe Kornfeld, Ron Futterman, Ned Leavitt, Larry Lewis, Al 
Gusis, William Traylor, Ken Hansen. 

Distribution front: i.e. Bréderbund: Gary Carlston, Alex Hoag, Leigh Mariner, Rod Haden, 
Jeannine Cook, Doug Carlston, Tom Marcus, Steve Dumphey and many others. 

Special thanks to: Frank Thomas, Walt Disney, Windsor Mackay, Steve Jobs, Alan Kay, 
Muybridge, Babbage, Joyce, Mozart, Beethoven, Bach, Rembrandt, da Vinci, Darwin, 
Einstein, Freud, Dali, Picasso, Warhol, Monty Python, among others and to all of our 
parents. 

Look for other software products by MacroMind: Maze Wars+; Movies disks, including 
“The Mall"; other Clip Animation, sound and artwork disks; and scheduled for release in Nov. '87, 
the momma of all products-VideoWorks Interactive. 
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index 

Page numbers in bold are from the 
"How To Animate" section 

About VideoWorks, 212 
Activate, 271 
Active Window, 229, 271 
Add Color Ink, 191 
Adding Text, 164 
Advanced Users, 263 
Airbrush, 249 
Alert box, 271 
Alignment of Text, 230 
Animation, 271 

Advanced, 180 
Creating, 130 
Frame-by-Frame, 67, 133 
Process of, 102 
Real-Time Recording, 76, 131 
Techniques, 261 

Annotating a Slide, 41, 115 

Apple Menu, 212 
Art Grabber+, 86, 175, 213 
Artwork Techniques, 262 
Artwork, 271 

Creating, 126 
Importing, 175 

Copying from other documents, 181 
Autosave, 205 
Average Color Ink, 191 
Back Step, 236 

in Overview, 208 
Backspace Key, 153 
Backup disk, 271 

Bamboo Industries (Tutorial 1), 20 
Banks of Cast, 129 
Bic (Black is Eraser) Ink, 233 

Big Picture, 93 
Blank From Stage, 54, 153, 223 
Bouncing Face (Tutorial 4), 43 
Burn Scene, 49, 61, 222 
Button, 271. 
Canter, Marc, 8, 279 
Cast, 129, 238 
Castmember, 271 
Castmember Display Button (Score), 242 
Cell, 271 
Center Text Alignment, 230 
Chaining a Sequence, 67, 159. 
Channel Indicator, 50, 62, 133, 136, 237 

with Real-Time Recording, 76 
Blinking Light in, 132 

Channel, 272 

Circle QuickDraw Shapes Tool, 160, 238 
Circle Tool (Paint), 248 , 
City (Tutorial 5), 48 : 

Clear command (see also Cut/Copy/Paste) 
Clear Score command, 151, 153 
Clearing Time, 154 
in Overview, 203 
in VideoWorks, 220 

Click, 272 
Clip Animation, 33, 115 

Adding to Overview, 30 
Delaying, 39 
Limit on Number of, 122 

Positioning, 36 
Repeating, 41 
Setting Starting Location, 37 
Setting Timing, 38 

Clipboard, 214 
Close box, 272 

Color, 190 
Color inks, 191 
Color window, 253 

Column of icons, 272 

Command Key Shortcuts, 265 
Constrain, 140, 254 

Control Menu: 
Overview, 24, 204 
VideoWorks, 136, 225 

Copy command (see Cut/Copy/Paste) 
Copy Ink, 233 
Current frame, 272 
Cursor, 272 
Cut/Copy/Paste commands, 272 

From Other Documents, 181 
In Overview, 202 

In VideoWorks, 219 
Score, 70, 153 
To remove/insert time, 154 

Understanding, 155 
Delaying a Clip Animation, 39, 117 
Delete Frame command, 151, 221 

Dialog Boxes Shortcuts, 198 
Dialog box, 272 
Direction Indicator Button (Score), 241 
Disk Space, 259 
Disks: 400K, 11 
Disney, 277 
Dissolve, 272 

Distort tool (Paint), 250 
Double-click, 272 
Down command, 226 
Drag, 272 
Draw Menu, 231 

Easel (Paint), 272 

Edit Menu 
Overview, 202 
VideoWorks, 218 — 

Edit, 273 
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Editing: 
Animation, 138 

Advanced, 180 
Basic, in Score, 144 

Intermediate, in Score, 153 

Erase Ink, 232 
Eraser tool (Paint), 247 
Extended Display Button (Score), 242 
FatBits (Paint), 247 
File Menu 

Overview, 200 
VideoWorks, 216 

File Size, 212 
File, 273 
Fill Patterns, 231 
Film Loop, 57, 131, 161, 254 

Creating, 76 3 
In-Between on, 163 

Film Animation, 273 
Finding Missing Documents in Overview, 22 

Flip Vertical tool (Paint), 249 
Flop Horizontal tool (Paint), 249 
Font, 230, 273 
Foreground Priority, 134 

Changing, 150 
Frame Counter, 60, 237 

Flashing, 183 
Frame cell, 273 
Frame, 273 
Frame-by-Frame Animation, 67, 133 
FreeMem, 212 
Frogs (Tutorial 6), 60 
Gather Documents command, 203 
General Hints, 255 
Get Info (Overview), 116, 203 

Delaying a Clip Animation, 39 
On MacPaint, PICT, Glue, 40, 116 
On VideoWorks document, 116 
Positioning Clip Animation, 36 
Repeating a Clip Animation, 40 
Setting Timing, 38 

Glue icons, 31, 114 

Grabber+ Menu, 214 
Guided Tour of VideoWorks II, 19 
Held artwork, 273 
Help command, 15, 213 
Hidden Features (VideoWorks), 254 
Hierarchical Menus, 32, 198 
Hints, Tips and Tricks, 122, 255 
Icon, 273 
Import, 273 
Importing Artwork, 86, 175, 262 
In-Between, 56, 222 

On Film Loop, 163 
Scrolling Text, 80 
Stationary Artwork, 75, 156 
Stretching Artwork, 86, 158 

282 index 

Ink Indicator (Paint window), 248 
Ink Indicator Button (Score), 242, 248 

Ink Menu, 173, 232 

Color Inks, 191 
Mask, 185 
Matte, 64, 86 
No Erase, 188 
Or, 81 
With Paint Window, 128, 248 

Insert Frame, 221, 151 

Insertion Point . 
Score, 146 
Overview, I11 

Invert Tool (Paint), 249 
Jump Button, (Score) 52, 245 
Lasso tool (Paint), 248 
Launch Applications from Overview, 120 
Launch Editor command, 120,201 _ 
Layout Options (Printing) 

Overview, 118 
VideoWorks, 179 

Left command, 226 
Left Text Alignment, 230 
Light Switch (VideoWorks), 49 
Line QuickDraw Shapes Tool, 160, 238 
Line Tool (Paint), 248 
Line Widths (Draw Menu), 231 
Long Menus, 81, 211, 227 
Loop Button (Panel) 

VideoWorks, 237 
Overview, 208 

Macintalk Speech, 83, 274, 169 
Macintosh II (see Color) 

- MacPaint Icon (Overview), 27, 116 
Mask Ink, 185, 234, 274 
Matte ink, 64, 86, 274 
Maximum Ink, 191 
McNeil, Alan, 279 
Memory, 212, 259 

Cast, 212 
Color, 192 
Scene, 212 
Sound, 212 

Menu Bar, 274 
Menus: (also see title of individual menus) 

Hierarchical, 32, 198 
Overview, 199 
VideoWorks, 211 

Minimum Ink, 191 

Missing Documents in Overview, 22 
More Bamboo Industries (Tutorial 3), 35 
Motion Display Indicator (Score),63 
Mouse Button, 274 

Function in Overview, 109 
Movie Show (Tutorial 2), 34 
Movie, 274 
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Moving Artwork on the Stage, 
Frame-By-Frame 140 
Smoothly (In-Between), 157 

Moving Between VideoWorks and Overview, 41 

MusicWorks, 170, 190 

Muybridge, 277 
Neumann, Erik, 279 
New Easel tool (Paint), 247 
New command, 

Overview, 200 
VideoWorks, 216 

No Erase Ink, 188, 232 
Normal Size Command, 186, 224 
Not Copy, NotOr, NotXor, NotBic Inks, 234 
Nubus, 8, 253 
Numeric Keypad, 136 
Open command 

Overview, 200 
VideoWorks, 216 

Option and Command Keys, 46, 51, 132 
Or ink, 81, 233 
Outline Edge (see Matte) 
Oval QuickDraw Shapes Tool, 160, 238 
Overview, 105, 199 

Controlling, 109 
Documents, 106 
Hints, 122 © 

Moving to VideoWorks from, 121 
Organizing Documents, 110 
Print Layout Options, 119 
Return to Overview command, 201 
The Big Picture, 102 

Window, 106, 209 
Working with, 106 

Page Setup 
Overview, 201 

VideoWorks, 217 
Paint Bucket tool (Paint), 248 
Paint Window, 126, 164 
Paintbrush, 247 

Panel 
Overview, 21, 24, 109, 208 
VideoWorks, 49, 136, 236 

Paste Relative command, 68, 159 
Paste command (see also Cut/Copy/Paste) 

Overview, 202 
VideoWorks, 220 

Time, 154 

Pencil tool (Paing), 247 
Performance, speed, 259 
Perspective, 250 
PICT icons, 31, 116 

Pixel, 274 

Placing Artwork on the Stage, 138 
Place On Stage command, 180, 223 

Play command 
Overview, 22, 204, 208 
VideoWorks, 236, 226 

Playback Head, 244 
Overview, 25, 109 
VideoWorks, 52, 61 

Point-of-Purchase Display (Tutorial 7), 78 
Pointer, 238, 274 
Positioning a 

Animation Sequence, 69 
Graphic Document, 40 
Clip Animation, 36 

Preferences, 205 
VideoWorks, 227 

Preferences File, 13 
Print command 

Overview, 118, 201 
VideoWorks, 177, 217 

Process of Animation, 102 
Priority: Foreground, 134 
Quick Create, 34, 203 

QuickDraw Shapes, 160, 238 
Rectangle, 84 

QuickDraw Text (see Text Box) 
Quit command 

Overview, 201 

VideoWorks, 217 
To Move from VideoWorks to Overview, 121 

Range Indicator, 70, 237 
Re-position an Animation Sequence, 149 
Re-position Artwork on Stage, 140 
Real-Time Recording, 46, 51, 76, 131 

And Channel Indicator, 76 

Channel Selection, 132 
Record Light, 62, 71, 133, 137 

Rectangle tool (Paint), 247 

Rectangle QuickDraw Shapes Tool, 84, 160, 238 
Reference, 195 

Overview, 199 
VideoWorks, 211 
Process of Animation, 102 

Registration Points, 77, 162, 184, 249, 274 
Make Animation Easier, 135 

Removing artwork from Stage, 139 
ReOpen command (Art Grabber+), 214 
Repeat All command, 226 
Repeat Selection command, 183, 226, 245 
Repeating a Clip Animation, 40 
Return to Overview command, 201 

Reverse Sequence command, 224 — 
Revert command 

Overview, 201 
VideoWorks, 217 

Rewind command 
Overview, 208 
VideoWorks, 225 

Right command, 226 
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Right Text Alignment, 230 Sound (Overview) 
Rotate Tool (Paint), 250 Removing, 167 
Sadowski, Dan, 279 Repeating, 168 
Sampled Sound, 170, 190 : Re-triggering, 167 
Save As command Sampled Sound, 170, 190 

Overview, 201 Sound Is Off (Overview), 204 
VideoWorks, 217 Sound Is On (Overview), 204 
Save As V1.0, 217 Sound Switch (VideoWorks) 49 

Save command Sound, Tempo & Transition Channel, 244 
Overview, 201 7 Sound-to- Video, 190 
VideoWorks, 216 Speech (see Macintalk) 

Scene, 274 Synchronizing, 166 
Score, 240 In VideoWorks, 77, 166 

Clear cells, 153 Volume (Sound), 166 

Cut, Copy and paste, 70, 153 Space Bar to Pause Action, 109 
Display Indicators, 63, 241 Space on disk, 259 
Editing, Basic, 144 Speech, Computer Generated, 83, 169 
Editing, Intermediate, 153 Speed Control, 51, 237 

Filling in Gaps, 71 Speed of Animation, 259 
Getting Around In, 144 Sprite, 275 
Insertion Point, 146 : Stage Editing vs. Score Editing, 152 
Introduction to, 51 Stage window 
Jump Button, 52 Definition, 275 
Playback Head, 52 Overview, 208, 21 

Selecting, 56, 146 VideoWorks, 235 
Scrapbook, 176, 215 Starting Location for Clip Animation, 37 

Storing Sequences in, 182 Starting VideoWorks II, 11 
Scroll Arrows in Cast, 129 Stationary Artwork, 156 
Scroll Bars in Score, 245 Step command, 236 : 
Scroll Bar, 274 | In Frame-By-Frame Recording, 133 
scroll box, 275 And recording, 63 
Scrolling Text, 80, 188 With Record Light, 63, 71 
Search Menu, 252 In Overview, 25 
Select All command (Overview), 203 To Skip Forward, 36 
Selecting, 275 With Shift key, 36 

Artwork on Stage, 139 | Stop command, 208, 236 
Cells in Score, 146, 245 - Storing Sequences in the Scrapbook, 182 
in Score, 146 Stretching 
Insertion point in Score, 146 Artwork, 141, 158 
Summary, 147 With In-Between, 86 

Selection Box, 248 Style (Text Menu), 230 
Sequence, 275 | Subtract Ink, 191 

Shift-click, 275 Suggested Reading, 277 
Shifting a Sequence, 69 Switch Art on Stage (see Switch Castmember) 
Shortcuts, 265 Switch Castmember, 57, 65, 141, 189, 222 
Short Menus, 81, 211, 227 Switch, 275 
Show Page (Art Grabber+), 214 Synchronization, 275 
Size of Text, 230 Synchronizing Sound, 166 
Slant Tool (Paint), 250 System 4.1 vs. Earlier Systems, 32, 198, 206 
Slide, 275 Take, 275 
Sound Technical Support, 15 

Dependent on Artwork, 169 Tempo | 
Icons, 32 Speed Control (Panel), 237 
Macintalk, 83 Changing during movie, 171, 188 
Menu, 206, 228 Terminology, 
MusicWorks, 170 3 | VideoWorks II, 99 
Overview, 32, 114 : Macintosh, 14 
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Text 7 

Alignment of 230 
Menu, 230 
On Stage, 165 
QuickDraw (see Text Box) 
Scrolling, 80, 188 
Text Box, 87, 238 
Text Tool (Paint), 78, 247 
Window, 164, 251 

Time, How to Insert or Delete, 154 

Timer Icons, 28, 112 

With Clip Animation, 38 
Timing: Delaying a Clip Animation, 39, 117 
To Overview command, 121, 216 

To VideoWorks command, 121, 200 
Transitions 

Overview, 29, 113 
VideoWorks, 172 

Transparent Ink, 191 
Tutorials 

Bamboo Industries, 20 
Bouncing Face, 43 
More Bamboo Industries, 35 
Point-of-Purchase Display, 78 
The City, 48 © 
The Frogs, 60 | 
The Movie Show, 34 

Understanding Cut/Copy/Paste, 155 
Tweak, 149, 252, 276 
Tween, 276 
Undo command 

Overview, 202 

VideoWorks, 218 

Up command, 226 
VideoWorks, 125 

Icons (See Clip Animation) 
Windows, 235 
To VideoWorks pommaut, 121, 200 
The Big Picture, 102 

Volume (Sound), 166 
VW Preferences File, 13 
Warranty, 2 
Window (see also name of window) 

Management of, 25 
Menu, Overview, 207 

Menu, VideoWorks, 229 

Overlapping, 25 
Overview Windows, 208 
VideoWorks Windows, 235 

Wipe, 276 
X & Y Coordinates, 242 

Xor Ink, 233 
YX-Synthesis Sound, 169 
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